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Change log

Date Change Description

2021-06-30 Initial release.
2021-08-13 Added FortiAl logging on FortiAnalyzer on page 47
2021-12-17 Added Configuring an event handler to filter IPS attack direction on page 37.
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Introduction

Introduction

This document serves as a reference guide to common FortiAnalyzer 7.0 configuration and deployment scenarios. The
scope of this document is to explain specific examples and include information required for those examples to work. The
examples rely on the other documents to provide full product information.

Al
‘Q' For further FortiAnalyzer information, refer to the FortiAnalyzer Administration Guide available
- on the Fortinet Docs Library.

This section includes configuration examples for FortiAnalyzer 7.0:

o System settings on page 7

e Reports on page 9

o Real-time dashboards on page 11
» Fabric connectors on page 15

e SOAR and SIEM on page 28

« Logging on page 47

» Troubleshooting on page 51
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System settings

System settings

This section contains the following topics:

o Setting up a FortiAnalyzer HA cluster on page 7

Setting up a FortiAnalyzer HA cluster

You can configure two or more FortiAnalyzer units in a High Availability (HA) cluster to provide real-time redundancy in
case a primary unit fails. High Availability clusters also alleviate the load on the primary unit by using secondary units for
processes such as running reports.

The following is an overview of how to configure FortiAnalyzer units in an HA cluster:

Go to System Settings > HA.

Set the Operation Mode of the primary unit to High Availability.
Configure the settings for the primary unit.

Configure the settings for the secondary units.

Ao b=

NP All the units must:
‘Q' ¢ Be of the same FortiAnalyzer series
|| * Be visible on the network
- ¢ Run in the same operation mode: Analyzer or Collector

To configure the primary unit in an HA cluster:

Go to System Settings > HA.

Set the Operation Mode to High Availability.
Set the Preferred Role to Primary.
Configure the Cluster Virtual IP settings:

o bN-=

Interface Select the interface to be used as the clustered Virtual IP.

IP Address Type the IP address to be used by the HA cluster to provide redundancy.

5. Inthe Peer IP and Peer SN box, type the Peer IP and Peer SN for each secondary unit. The maximum is three units.

o

Type the Group Name, Group ID, and Password. These settings must be the same for all the units in the cluster.
Click Apply.

N
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System settings

To configure secondary units in an HA cluster:

1.
2,

Set the Preferred Role to Secondary.
Configure the Cluster Virtual IP settings with the HA cluster's Interface and IP Address.

Interface Select the interface being used by the cluster as the Virtual IP.
IP Address Type the IP address being used by the cluster to provide redundancy.

In the Peer IP and Peer SN box, type the Peer IP and Peer SN for the primary unit and each secondary unit.

Type the Group Name, Group ID, and Password. These settings must be the same for all the units in the cluster.
Click Apply.

FortiAnalyzer 7.0.0 Examples

Fortinet Technologies Inc.



Reports

Reports

This section contains the following topics:

» Configuring a report with an LDAP server on page 9

Configuring a report with an LDAP server

You can use report filters to only the show members of a group in an LDAP server.

This example demonstrates how to filter the Admin and System Events Report to show data for the group members in

Distinguished Name: cn=groupl, ou=groups,dc=fortinet, dc=comin the reportoutput.
Requirements:

o The LDAP server is ready and accessible.
o Group members are configured.

To configure the report:

1. Add the LDAP server to FortiAnalyzer.

a. Goto System Settings > Admin > Remote Authentication Server, and click Create New > LDAP Server.

b. Configure the LDAP server settings, then click OK.

£2%  System Settings v
€ Dashboard New LDAP Server
@ Logging Topology
& All ADOMs

Name Idap1

Server Name/IP 1000246
S Storage Info
G storag Port 389
& Network Common Name Identifier
ZHA -
Distinguished Name ou=groups dc=fortinet dc=com %

2 Admin v
Bind Type Regular

A

User DN cn=admin,dc=fortinet,dc=com

Passwor d

Secure Connection OEnable

Profile
Remote Authentication Server

Admin Settings

SAML S5O Administrative Domain Specify
@B Certificates | Advanced Options >
Local Certificates
CA Certificates
CRL
Remote Certificates
2 Log Forwarding
[ Fetcher Management
¥ Event Log
[ Task Monitor
Fs Advanced v
SNMP
Mail Server
Syslog Server
Meta Fields

e ]
2. Apply the LDAP server to the report filter.
a. Goto Reports and select the Admin and System Events Report.
b. Click the Settings tab, then expand the Filters section.
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Reports

c. Use the following settings to configure the filter:

Log Field
Match Criteria

Value

Select Group (group).
Select Equal to.

Enter groupl.

d. Click LDAP Query and set LDAP Serverto the LDAP server you created, then click Apply.

BS Generated Reports

&5 Report Definitions v
Name

5 Templates Time Period
[ud Chart Library @ Devices
8 Macro Library
£ Datasets @ Trpe
£3 Advanced ~
N Language OEnable Schedule
2 Output Profile DEnable Notification
Report Calendar OEnable Auto-cache
Filters

Log messages that match
Log Field

Group (group)

EALDAP Query

Advanced Settings >

T @> 01 (g adminy
Edit: Admin and System Events Report

Admin and System Events Report

This Week

OAIl Devices @ Specify
@ All_Device o

@single Report  OMultiple Reports

@Al OAny of the Following Conditions

Match Criteria Value @

Equal To v | [group1 + @
LDAP Server Idap1 -+
Case Change Disabled

Apply

3. Select the View Report tab and click Run Report to run the report and verify the output.
The report displays the users in the group: cn=groupl, ou=groups, dc=fortinet, dc=com inthe Login
Summary chart and the group name in the Report Filters.
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Real-time dashboards

Real-time dashboards

This section contains the following topics:

« Configuring FortiAnalyzer to detect FortiSandbox devices on page 11

Configuring FortiAnalyzer to detect FortiSandbox devices

You can use FortiAnalyzer to monitor FortiSandbox devices. Some configurations are required on FortiSandbox to add

the device to FortiAnalyzer. After you add the device, go to FortiView > Threats > FortiSandbox Detection to view the
scanned files.

To detect FortiSandbox on FortiAnalyzer:

1. Create a firewall policy on FortiSandbox.
2. Create alog server on FortiSandbox.
3. Add FortiSandbox to FortiAnalyzer.

Creating a firewall policy on FortiSandbox

You can use the CLI console in FortiSandbox to configure a firewall policy, then specify the IP address of the
FortiAnalyzer you want to monitor the FortiSandbox.

To create a firewall policy on FortiSandbox:

1. Inthe FortiGate device, click the CLI Console icon on the right-side of the banner on any page.
2. Specify the FortiSandbox in the global configuration:

config antivirus profile
edit "test"
set ftgd-analytics everything config http
set options scan avmonitor
end config ftp
set options scan avmonitor
end config imap
set options scan
end config pop3
set options scan
end config smtp
set options scan
end config nntp
set options scan
end
next
end

3. Create an antivirus profile to allow FortiGate to submit all files scanned by AntiVirus to FortiSandbox. The following
is a sample AntiVirus profile:

FortiAnalyzer 7.0.0 Examples
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config firewall policy
edit 13
set name "to-serverl"
set uuid 5107b480-3d19-51e8-f1cl1-571602a6375b
set srcintf "lan"
set dstintf "wanl"
set srcaddr "net-local"
set dstaddr "serverl"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set logtraffic all
set fsso disable
set av-profile "test"
set ssl-ssh-profile "certificate-inspection"
set nat enable
next
end

4. Use the antivirus profile in the firewall policy. The following is a sample firewall policy:
config firewall policy
edit 13
set name "to-serverl"
set uuid 5107b480-3d19-51e8-f1cl1-571602a6375b
set srcintf "lan"
set dstintf "wanl"
set srcaddr "net-local"
set dstaddr "serverl"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set logtraffic all
set fsso disable
set av-profile "test"
set ssl-ssh-profile "certificate-inspection"
set nat enable
next
end

5. Specify the IP address of the FortiAnalyzer unit for FortiGate to send logs.
configure log fortianalyzer setting
set status enable
set server <ip address of FortiAnalyzer> set upload-option realtime
end

Creating a log server for FortiAnalyzer

Use FortiSandbox to create a log server to specify the FortiAnalyzer that will monitor the scanned files.

FortiAnalyzer 7.0.0 Examples
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Real-time dashboards

To create a log server on FortiSandbox:

1. On FortiSandbox, go to Log & Report > Log Servers.
2. Click Create New in the toolbar and configure the following settings:

Name Enter a name for the new server entry.

Type Select FortiAnalyzer from the dropdown list.

Log Server Address Enter the log server IP address for the FortiAnalyzer device.

Port Enter the port number. The default port is 514.

Status Select Enable to send logs to the server.

Log Level ¢ Set the logging levels to be forwarded to the log server. The following

options are available:
Enable Alert Logs. By default, only logs of non-Clean rated jobs are sent.
Users can choose to send Clean Job Alert Logs by selecting Include job
with Clean Rating.

¢ Enable Critical Logs

e Enable Error Logs

¢ Enable Warning Logs

¢ Enable Information Logs

e Enable Debug Logs

Adding FortiSandbox to FortiAnalyzer
You can use the IP address of the configured FortiSandbox to add it to FortiAnalyzer with Device Manager.

To add the FortiSandbox:

1. InFortiAnalyzer, go to Device Manager.
2. Click Add Device, and enter the FortiSandbox information into the dialog box.

Device Name Type a name for the FortiSandbox device.

Link Device By Serial Number.

Serial Number Type the serial number for the FortiSandbox device.

Device Model Select the model of the FortiSandbox device.

Description Type a description of the FortiSandbox device (optional).
3. Click Next.

The device is added to the ADOM and, if successful, is ready to begin sending logs to the FortiAnalyzer unit.
4. Click Finish.
In Device Manager, select the FortiSandbox you added, and click Edit in the toolbar.
6. Enter the Admin User and Password to allow FortiAnalyzer to access the FortiSandbox, then click OK.

o
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Real-time dashboards

To view FortiSandbox scanned files:

1. Goto FortiView > FortiView > Threats > FortiSandbox Detection to view the files scanned by FortiSandbox.
2. Click afile to view the Drilldown Panel.

Add Filber
& File Mame End User Drestination
1 Wirus Wind2 Adson. 1651 10.2.60.143 172.184.110 & Passthrough FTP
2 OAFRICTSMKE 10.2.60.143 172.184.110 & Passthrough FTP
3 septemberdoc 10.2.60.143 172.184.110 & Passthrough FTP
4 QAZPOBCAMNE 10.2.60.143 172.184.110 & Passthrough FTP
L] QASE0ALE vae 10.2.80.143 172184110 & Passthrough FTP
& Mestedfrchive zip 10.2.60.143 172.184.110 & Passthrough FTP
7 download.com 10.2.860.143 172.184.110 & Passthrough HTTP
B Fultipart.partLrar 10.2.80.143 172.184.110 & Passthrough FTP
9 Mailbomidrchiverar 10.2.860.143 172184110 & Passthrough FTP
pla} Carrupteddrchive sip 10240143 172,184,110 5 FTP
11 B57db030 tagged 10,280,143 172184110 FTP
12 hijackercom 10280143 172.184.110 & Passthrough FTP
13 Encrypdedirchive rar 10,280,143 172184110 & Passthrough FTP
14 Fed2 e Jaaa, 10280143 172184110 @ Passthrough FTP
= Total bops stored for analytics: 50 days 9 howrs. Show | 100« Total 14
3. Click the FortiSandbox Scan link to view the Sandbox Execution Details panel.
E File Mame = QAFSOCTSM®E | Add Filter | B Sandbox Execution Details x
Uses Marme 10.2.60,143 (10.2.60.143] File Name SEorage /IR fjobs 42 FEA2YEE0T0AER 33VE/ A2 TELAZREROT0S
) £93398
o5 Windaws Analysis Malicious
Session 1D 3434149 Service L
Policy IDVULID 1/ebéfbed-4dal-51e8- 2503- 4§ 53675073
FortiSandbox Scan Time 2019-02-07 11:05:26
Process Flow
Antivirus Check analytics oF Pass.

Send to FortiSandbax
®  FortiSandbox Scan Result: Malicious
Generate Malware Package

Send MNew Signature to FortiGate

Result @ Blocked
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Fabric connectors

This section contains the following topics:

o Configuring a ServiceNow connector on page 15
» Creating a Google Cloud connector on page 18

Configuring a ServiceNow connector

Admins can use ServiceNow to manage incidents and events with the FortiAnalyzer App. To notify ServiceNow when an

incident is raised in FortiAnalyzer, create a fabric connector, then enable notifications for the fabric connector you
created.

Before you begin, ensure you have completed the following tasks in ServiceNow:

« Install the ServiceNow FortiAnalyzer App.
o Goto FortiAnalyzer App > FortiAnalyzer System Properties, and create a connection for the ServiceNow API.

To integrate FortiAnalyzer with ServiceNow:

1. Record the ServiceNow APl URL.
2. Create a fabric connector for ServiceNow.
3. Enable notifications to notify ServiceNow when an incident is raised.

Locating your ServiceNow APl URL

You will need to know the ServiceNow API URL and login credentials to create a fabric connector in FortiAnalyzer.

To locate your ServiceNow APl URL:

1. Open ServiceNow and go to FortiAnalyzer App > FortiAnalyzer System Properties.

FortiAnalyzer 7.0.0 Examples
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Fabric connectors

2. Inthe Connection to ServiceNow API section, copy the URL in the ServiceNow API URL field.
service ©

Q0

/ ¢ System Properties Secunty Oporations ForiAnalyzer Integeation vi 022

Connection to FortiAnalyzer API

+ Domain

¥6.0.0-build0306 180117 (nterim)

Connection to ServiceNow API

Upon receiving an incident from FortiAnalyzer
3 Create an incident in ITSM Incident Managemant App

IE2 Keep updating FortiAnaiyzer incidents

Creating a fabric connector for ServiceNow

You will need to create a fabric connector to notify ServiceNow when an incident is raised in FortiAnalyzer.

To create a fabric connector for ServiceNow:

1. Open FortiAnalyzer and go to Fabric View > Fabric > Connectors.
2. Click Create New.
The Create New Fabric Connector dialog opens.
3. Select the ServiceNow connector type.
4. Configure the fabric connector:

FortiAnalyzer 7.0.0 Examples
Fortinet Technologies Inc.
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Fabric connectors

Name

Description

Protocol
Method
Title

URL

User Name

Password

Status

5. Click OK.

Create New Fabric Connector

Name ven02318

Description This is a demo

Protocol HTTPS
Method POST

Title ven02318
URL ven02318 service-now.com/api/x_forti_fazintg/faz/jsonrpc
Enable HTTP Authentication

snapi

Type a name for the fabric connector. The name cannot be changed once the
fabric connector is created.

(Optional) Type a description for the fabric connector. You can change the
description after the fabric connector is created.

Select HTTPS.
Select POST.

Type a title for the fabric connector. You can change the title after the fabric
connector is created.

Type the ServiceNow API URL located in FortiAnalyzer App > FortiAnalyzer
System Properties.

Type the Username located in FortiAnalyzer App > FortiAnalyzer System
Properties.

Type the Password located in FortiAnalyzer App > FortiAnalyzer System
Properties.

Toggle ON to enable the fabric connector.

Sending notifications to ServiceNow

You will need to enable notifications in FortiAnalyzer to trigger an incident in ServiceNow:

To enable notifications in FortiAnalyzer:

oD

FortiAnalyzer 7.0.0 Examples
Fortinet Technologies Inc.

Go to FortiSoC > Incidents.

Click Settings in the toolbar.

From the Fabric Connector 1 dropdown, select the fabric connector you created for ServiceNow.
Select the notification icon settings, and click OK.
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Fabric connectors

Creating a Google Cloud connector

When logs hit a certain size, they rollover and begin deleting the earliest entries to make room for additional logs. To
prevent losing any log entries, FortiAnalyzer can periodically back up older logs to an external object storage location in

Google Cloud. This off-site log archive will help ensure compliance and data redundancy in case there is a local storage
or outage in FortiAnalyzer.

To create a Google Cloud connector:

Create a storage bucket on Google Cloud. See Configuring a Google Cloud storage bucket on page 18
Locate your Google Cloud Platform information. See Locating your Google Cloud information on page 20
Import the required CA certificates on FortiAnalyzer. See Importing the CA certificate on page 23

Create a cloud connector on FortiAnalyzer. See Creating the cloud connector on page 24

Test the connector. See Testing the Google Cloud connector on page 26.

o kN -=

Configuring a Google Cloud storage bucket

Google storage buckets must be globally unique. For simplicity, this example uses the project name. However, you can
use any name you like.

For more information about creating Google storage buckets, see the product help.
To create a Google storage bucket:

1. Open the Cloud Storage browser in the Google Cloud Console and click Create Bucket.
2. Enter a name for the bucket.

= Google Cloud Platform 2 FFT Public Cloud Script Test + Q
B8 Sstorage 4 Create a bucket

L]

* Name your bucket

Pick a globally unique, permanent name. Naming g

pr-egdz0zahtszhg

= Choose where to store your data
= Choose a default storage class for your data
= Choose how to control access to objects

= Advanced settings (optional)

FortiAnalyzer 7.0.0 Examples
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3. Select a region for the bucket. You will need this location when you create a cloud connector in FortiAnalyzer.

= Google Cloud Platform  $» FFT PublicC

B storage € Create a bucket
L]

from & Name your bucket

R Transfer

* Choose where to store your data

Transfer Appliance
This permanent chaice defines the geographic placement of your data and affects
% Setiings cost, performance, and availability. Leam more

Location type
O region

Lowest latency witina singl region
@ Wutregon

Highest availability across 13rgest area

© Duakregion
High avalad

ity and low atency across 2 regions
Location
us (multiple regions in United States) -
CONTINUE

4. Setthe object storage type to standard.

= Google Cloud Platform & FFT Public Cloud Script Test

B8 Storage &« Create a bucket
& sowse
@ Name your bucket
= Tianster
45 Transfor Appliance @ Choose where to store your data

e * Choose a default storage class for your data
A storage class sets costs for storage, retrieval, and operations. Pick & default
‘storage class based on how lang you pian 1o store your data and how often it will
be accessed Learn more

@ standard @

Best for shorttexm storage and requently accessed dela
O Nearline

Best for backups and data accessed once a month or less
O coldiine

Best for OiSaSter recovery &nd dath BCCESSEC ONCE B YEar OF less

CONTINUE

5. Setthe access control to Fine grained.

=] <

Create a bucket

& Name your bucket

@ Choose where to store your data

& Setigs

& Choose a default storage class for your data

* Choose how to control access to objects

Access control

CONTINUE

FortiAnalyzer 7.0.0 Examples
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6. Setthe encryption to Google-managed key.

E Storage € Create a bucket

- e e e e aT e v e

Advanced settings (optional)

Encryption

@ Google-managed key

O Customer-managed key
Manage \ta Google Cious Key Management Service

Retention policy

Set a refention policy to specify the minimum duration that this bucket's objects

must be p or after they're up You might

set a policy to address industry-specific retention challenges. Lear more

[ set a retention policy

Labels

Labels are keyvalue pairs that allow you to group related buckets together of with
other Cloud Plstform resources. Leam more

+ ADD LABEL
- cancr
7. Click Create.

To view the bucket details:

Go to Storage > Browser.

» Use the Objects tab to test the cloud connector. See Testing the Google Cloud connector on page 26.

» Use the Permissions tab to see who can access this bucket. The Google account JSON key will be tied to these
permissions. See Locating your Google Cloud information on page 20.

= Google Cloud Platform 3+ FFT Public Cloud Script Test ¥ Q
B3 Sstorage & Bucket details /# EDITBUCKET  ( REFRESH BUCKET
@  Browser pr-eg4z0zah0s2hg
= Transfer Objects Overview Permissions Bucket Lock
3E  Transfer Appliance
This bucket uses fine-grained access control, allowing you to Edit
£  Settings specify access to individual objects. To control access uniformly at

the bucket level, switch to uniform access control. Learn more

Add members ENIT) Filter by name or role View by. Members ~

Type Members ~ Role(s)
an Editors of project: pr-eg4z0zah0s2hg Storage Legacy Bucket Owner ~ 1
’
an Owners of project: pr-eg4z0zah0s2hg Storage Legacy Bucket Qwner ~ 1
7’
- Viewers of project: pr-eg4z0zah0s2hg Storage Legacy Bucket Reader ~ 11
s

Locating your Google Cloud information
Some information is required from Google Cloud in order to create a storage connector on FortiAnalyzer.

To locate a Google project number:

1. Open the project in Google Cloud Platform.
2. Open the Home page.

FortiAnalyzer 7.0.0 Examples
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3. Locate the Project Info widget and copy the Project Number.

&# Project info

Project name
FFT Public Cloud Script Test

Project ID
pr-eg4z0zah0s2hg

Project number
947890606217
ADD PEOPLE TO THIS PROJECT

9 Go to project settings

To create a Google service account key:

A private key is required to create a fabric connector for Google Cloud. After you create the key, save it to your computer
and paste the entire contents of the JSON file in the Service Account Credentials field when you create the cloud
connector. You can download an existing service account key from the bucket details page.

1. Open your project in Google Cloud Platform.
2. Inthe Navigation pane, go to IAM & admin > Service Accounts. The Service accounts page opens.

= Google Cloud Platform 2« -
#A Home DASHBOARD

\_!f Marketplace
8® Projectin

B Billing
Project name
APT  APIs & Services > Dev Project 0
Praiact N
s
T Support > 1AM
e IAM & admin > Identity & Organization
Organization policies
®  Getting started
Quotas
Q@ security > Semice acqpnts
Taser
COMPUTE

Privacy & Security

3. Click Create Service Account. The Create service account page opens.

= Google Cloud Platform 3 o~

B 1AM & admin Service accounts + CREATE SERVICEACCOUNT | DELETE

4. Type the Service account name, Service account ID, and Service account description, then click Create.
5. Select the account permissions from the Role dropdown, then click Continue.

e 1AM & admin Creale service account

2 1M @ Service account details — @) Grant this service account access to prc
@  identity & Organization

B organization policies Service account permissions (optional)

Grant this service account access to Dev Project 001 so that it has permission to

B o ‘complete specific actions on the resources in your project. Learn more

2 Service accounts. Role. -
Owner - L]

®  Labeis

@  Privacy & Security + ADD ANOTHER ROLE

B Ssetings

@ CONTINUE CANCEL

]

identity-Aware Proxy

FortiAnalyzer 7.0.0 Examples
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6. Inthe Grant users access to this service account section, click Create Key.

Grant users access to this service account (optional)
Grant access o users or groups that need 1o perform actions as this service account

Service account users role (]

Grant users i Jobs and VMs account

Service account admins role L]

Grant users the permission 1o agminister this service account

Create key (optional)

Download a file that contains the private key. Store the file securely because this key
‘can'tbe recovered if lost. However, f you are unsure why you need a key, skip this step
fornow.

+ CREATE KEY
DONE ‘CANCEL

7. Click Create and save your key to your computer.

Create private key for "Compute Engine default service account’

a file that contains k the fil by iy
can't be recovered if lost.

Ky type
® JsoN
Recommended

O Pz

For iackward compatibility with code using the P12 format

8. Paste the entire contents of the JSON file in the Service Account Credentials field when you create the cloud
connector.

To locate the remote path in Google Cloud:

Use the Google bucket name for the Remote Path in the Device Logs Settings. The bucket name is also the name of the
fabric connector.

1. Inthe navigation pane, go to Storage > Browser.

FortiAnalyzer 7.0.0 Examples
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= Google Cloud Platform g

Home

STORAGE

@ Bigtable

#  Datastore >

2 Firestore >

=

Storage >

=
BVOV&I
|

€ sa ! Transter
Transfer Appliance

Se  Spanner

Settings
&  Memorystore

2. Copy the name of the bucket as it appears in the Name column and paste it into the Remote Path field when you
create the cloud connector.

= Google Cloud Platform  # FFT Public Cloud Script Test

Importing the CA certificate
Google requires you provide CyberTrust and GlobalSign certificates when creating a cloud object.

To import a CA certificate:

1. Go to System Settings > Certificates > CA Certificates.
2. Click Importin the toolbar, or right-click and select Import. The Import dialog box opens.

3. Click Browse... and locate the certificate file on the management computer, or drag and drop the file onto the dialog
box.

4. Click OKto import the certificate.

Remate Authentication Server O & Certificate Name Subject Status

Admin Settings 0 CACert 1 €= IE. © = Baltimore. OU = CyberTrust, CN = Baltimore: oK
CyberTrust Root
O CACert2 OU = GlobalSign Root CA - R2 O = GlobalSign, CN = oK
BB Certificates - Globalsign
Local Certificates

SAML S50

To view a CA certificate's details:

1. Go to System Settings > Certificates > CA Certificates.
2. Select the certificates you need to see details about.

3. Click View Certificate Detail in the toolbar, or right-click and select View Certificate Detail. The View CA Certificate
page opens.
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View CA Certificate
Certificate CA_Cert_1
Name
Issuer C = IE, O = Baltimore, OU = CyberTrust, CN = Baltimore CyberTrust Root
Subject C = IE, O = Baltimore, QU = CyberTrust, CN = Baltimore CyberTrust Root
Valid From 2000-05-12 18:46:00 GMT
Valid To 2025-05-12 23:59:00 GMT
Version 3

Serial Number  02:00:00:b%

Extension Name: X509v3 Subject Key ldentifier
Critical: no
Content:
E5:9D:59:30:82:47:58:CC:AC:FA:08:54:36:86:7B:3A:B5:04:4D:FO
Name: X509v3 Basic Constraints
Critical: yes
Content:
CATRUE, pathlen:3
Name: X509v3 Key Usage
Critical: yes
Content:
Certificate Sign, CRL Sign

4. Click OKto return to the CA certificates list.

Creating the cloud connector

Before you begin creating a Google Cloud connector, ensure you have:

« Imported the required CA certificates.
» Downloaded the private key from Google Cloud.

To create a Google Cloud connector:

1. Go to Fabric View > Fabric > Connectors, and click Create New in the toolbar. The Create New Fabric Connector
dialog opens.

2. Inthe Storage section, click Google Cloud Storage Connector.

3. Configure the fabric connector settings, then click OK.
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Create New Fabric Connector e Google Cloud Storage Connector

Name fazcloud

Comments

Title fazcloud
Cloud Project Number 947890606217

Service Account Credentials

Name Type a name for the fabric connector.

Comments (Optional) Add comments about the connector.

Title Type a title for the fabric connector.

Cloud Project Number Type the project number from the Google Cloud Platform dashboard.

See Locating your Google Cloud information on page 20.

Service Account Credentials Paste the entire Google account JSON key into the field. Click the eye icon to
Show or Hide the key.

See Locating your Google Cloud information on page 20.

Cloud Location Type the bucket region. See Creating a Google storage bucket
See Locating your Google Cloud information on page 20.

The fabric connector appears in the Fabric Connectors pane.

To roll the logs to Google Cloud:

1. Go to System Settings > Advanced > Device Log Settings.
2. Inthe Registered Device Logs section, click Upload logs to cloud storage > Create New.
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Device Log Settings

— Registered Device Logs

Roll log file when size exceeds 10 |(10-1000)MB
ORoll log files at scheduled time

OUpload logs using a standard file transfer protocol

B Upload logs to cloud storage

== Create New [# Edit T Delete

O Name Cloud Storage Connector Upload Option Remote Path Schedule Comments

ar

3. Configure the following cloud storage settings and click OK.

Property Description

Cloud Storage Connector Type the name you gave to the fabric connector.

Remote Path Type the globally unique name you gave to your bucket. For simplicity use the

project name.

See Locating your Google Cloud information on page 20.

Upload option Choose between Rolling or Schedule.

Testing the Google Cloud connector

You can use the CLI console to test the cloud connector before the logs have rolled over or a scheduled backup is
performed.

To test a cloud connector:

1. Openthe CLIconsole and type: diag test application uploadd 62 <connector name> <bucket

name>.

If the connector is working, the output will show success.

uuid[
> not ready.

sage [succe

Fortifnalyzer #

2. Goto the storage bucket on Google Cloud and look for the test files you uploaded.

= Google Cloud Platform 2 FFT Public Cloud Script Test v Q - "= e O ! §
B8 storage & Bucket details # EDITBUCKET (3 REFRESH BUCKET

Ol R pr-egdzlzahDs2hg

pr-egdzizahbe2hg
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To test a cloud connector with a shell prompt:

1. With the default settings, access to shell will give the following message:
FAZ1000D # execute shell
Shell disabled.

2. Use the following commands to enable shell on the FortiAnalyzer:
FAZ1000D # config system admin setting
(setting)# set shell-access enable
Enter new password: ****x
Confirm new password: ****xx*
FAZ1000D # end

3. The shellis now enabled.
FAZ1000D # execute shell
Enter password:
sh-4.3#
sh-4.3#

Open the CLI console on any page and type: rclone --config=/drive0O/private/rclone.cfg ls

<connector-name>:<bucketname>

Fo execute shell

m admin secting
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SOAR and SIEM

This section contains the following topics:

o Event handler example scenarios on page 28
» Configuring an EMS connector for use in FortiSoC playbooks on page 31
« Configuring an event handler to filter IPS attack direction on page 37

Event handler example scenarios

Custom event handler example

Event handlers can be created to trigger events based on a variety of conditions. By viewing logs in a raw format, you
can identify notable log fields and apply corresponding filters in event handlers so that similar logs will trigger an event.
For more information on viewing raw logs in FortiAnalyzer, see the FortiAnalyzer Administration Guide.

In this scenario, information from the following raw log is used to create a custom event handler.

date="2020-08-02" time="09:49:57" i1d=6856321710715568162 bid=8050516 dvid=1039
itime=1596361797 euid=1 epid=1 dsteuid=1 dstepid=1 log id="0100026477" type="virus"
subtype="infected" pri="information" from="ga200@ga.ca" to="userlO@6.ca"
src="172.20.140.108" session id="s7Q4T9n0026475-s7Q4T%pw026475" msg="The file virus
samples/sandbox/1385973112552098.172.16.92.92.3 is infected with W32/DomalIQ.AN!'tr."
device id="FE-2KB3R09690010" vd="root" devname="FE-2KB3R09690010"

This log contains information about malware detected by FortiMail. Two notable fields are the log type, type=virus,
and the subtype, subtype=infected.

Using this information, you can create an event handler which identifies these fields and generates an alert whenever
FortiMail logs include these definitions, indicating the presence of an infection.

To create the custom event handler:

o bd-=

Go to FortiSoC > Handlers > Event Handler List, and click Create New.

Enter a name and description (optional) for the event handler.

For Devices, select your FortiMail device, and for Subnets select All Subnets.
Configure a filter with the following information:

Log Device Type: FortiMail

Log Type: Antivirus Log (virus)

Group By: Device ID

Logs match: All

. Log Field: Subtype (subtype) Equal To Infected.

® 20T o

The remaining settings can be left in their default state. Click OK to save the event handler.
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Edit Handler: FortiMail Logtype Virus

Status m
Name FortiMail Logtype Virus
Description Alerts when type=virus
Devices All Devices Specify Local Device
Enterprise_FortiMail Q
Subnets All Subnets Specify
Filters +
Fiter 1 [ v
Log Device Type FortiMail T
Log Type Antivirus Log (virus) N
Group By Device |D (device_id) « |+
Logs match All Any of the following conditions
Log Field Match Criteria Value

Sub Type (subtype) v Equal To v infected +
Generic Text Filter @
Generate Alert When At least | 1 2 Exact + matches occurred over a period of | 30 |2 | minutes

Event Message @

Event Status

Event Severity

Tane

(Blank)

Allow FortiAnalyzer to choose

Medium

]

When enabled, logs from the selected FortiMail device which include the Log Type: virus and Sub Type: Infected will
generate an event.

Predefined event handler example

In addition to custom event handlers, FortiAnalyzer includes predefined event handlers. Below are example logs that will
trigger predefined event handlers when enabled.

These examples use the Generic Text filter field to include specific log information, such as logid="0422016400, in the
event handler filters.

Default-Compromised Host-Detection-by IOC-By-Threat:

Example log:
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date="2020-10-02" time="12:54:41" 1d=6879113766412222465 bid=152167 dvid=1046
1time=1601668486 euid=3 epid=1072 dsteuid=3 dstepid=101 logflag=1 logver=604021723
type="traffic" subtype="forward" level="notice" action="close" policyid=5
sessionid=2126025 srcip="10.200.1.8" dstip="148.81.111.122" srcport=34094 dstport=80
trandisp="noop" duration=1 proto=6 sentbyte=346 rcvdbyte=397 sentpkt=5 rcvdpkt=5
1logid="0000000013" srcname="LAN-FSW-GUEST" service="HTTP" app="HTTP" appcat="unscanned"
srcintfrole="lan" dstintfrole="wan" srcserver=0 policytype="policy"
eventtime=1601668481582497121 srcuuid="2de7756a-0343-51eb-c0b5-0d5602c3ecc6t"
dstuuid="2de7756a-0343-51eb-c0b5-0d5602c3ecc6" poluuid="528f5f54-0343-51eb-bae9-
3c63£f22ce0df" srcmac="00:03:93:6d:8f:£fd" mastersrcmac="00:03:93:6d:8f:£d"
srchwvendor="Apple" osname="Linux" srccountry="Reserved" dstcountry="Poland"
srcintf="vsw.port5" dstintf="portl" tdinfoid=7317936224723035242 tdtype="infected-ip"
tdscantime=1601668440 tdthreattype=0 tdthreatname=2 tdwfcate=0 tz="-0700"
devid="FGVM02TM20001234" vd="root" devname="Enterprise Second Floor"

The above example log triggers Filter 1 in the Default-Compromised Host-Detection-by IOC-By-Threat event handler:

Fiter 10 [ LIl
Log Device Type FortiGate
Log Type Traffic Log (traffic)
Log Subtype Any
Group By Destination IP (dstip) *+
Source Endpoint (endpoint) v B

Logs match

Log Field Match Criteria Value

Click to add + o

Generic Text Filter @

Generate Alert When At least 1 Exact + matches occurred over a period of 1440 minutes
Event Message @ Traffic to C&C from $groupby2 detected
Event Status Unhandled
Event Severity Critical
Tags IP C&C loc_Rescan
Additional Info
L]

Default-Botnet-Communication-Detection-By-Threat:

Example log:

date="2020-10-02" time="12:44:16" 1d=6879111064877793339 bid=151784 dvid=1043
itime=1601667857 euid=3 epid=1083 dsteuid=3 dstepid=101 logflag=16 logver=604021723
type="utm" subtype="ips" level="warning" action="dropped" sessionid=4398915
srcip="10.100.91.100" dstip="103.226.154.43" srcport=8725 dstport=80 attackid=7630075
severity="critical" proto=6 logid="0422016400" service="HTTP"
eventtime=1601667857379929845 policyid=13 crscore=50 craction=4 crlevel="critical"
srcintfrole="1lan" dstintfrole="wan" direction="outgoing" profile="default"
srcintf="port3" dstintf="portl" ref="http://www.fortinet.com/be?bid=7630075"
attack="BlackMoon" eventtype="botnet" srccountry="Reserved" msg="Botnet C&C
Communication.”™ tz="-0700" tdthreatname=20432 devid="FGVM02TM20001234" vd="root"
devname="Enterprise Core"
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The above example log triggers Filter 8 in the Default-Botnet-Communication-Detection-By-Threat event handler:

Fiter8® [ Bl ~
Log Device Type FortiGate
Log Type IPS (ips)
Group By Attack Name (attack) -+
Source Endpoint (endpoint) v | W

Logs match All Any of the following conditions

Log Field Match Criteria Value

Click to add + B

Generic Text Filter @

Generate Alert When Atleast 1 * | Exact » matches occurred over a period of 1440 minutes
Event Message @ Traffic to Botnet CnC from $groupby?2 blocked
Event Status Unhandled
Allow FortiAnalyzer to choo
Event Severity High
Tags Botnet IP C&C

Additional Info
Use system default

Use custom message @

Configuring an EMS connector for use in FortiSoC playbooks

Configuring an EMS connector on FortiAnalyzer allows FortiSoC automation playbooks to reach out to endpoints and
collect information or take containment actions.

To use EMS connectors in FortiSoC Playbooks:

1. Configure the EMS connector on page 32
2. Create a playbook using the EMS connector on page 35

FortiAnalyzer 7.0.0 Examples
Fortinet Technologies Inc.



SOAR and SIEM

Configure the EMS connector

To configure an EMS connector for use in FortiSoC playbooks:

1. Configure a FortiClient EMS 6.4.0 server which supports the FortiAnalyzer EMS connector feature.

FortiClient Endpoint Management Server

@ Dashboard v

0

Yulnerable Endpoints

1 2
Infected Endpoints Web Filter Detections

\Ulnerability Scan

L0 Endpoints >

System Informatian x License Information
& Quarantine Management > -
Hostname DESKTOP-21354PH Ml Serial Number FCTEMS 1975003231
& Software Inventory > Version 640 build 8247 (Interim) © FortiCloud Account Add
B4 Endpaint Policy abnse Backup Restore © Fabric Agent with Endpoint Protection Expiring [EIEINEER)
L& Endpoint Profiles > ystem Time 2020-04- 14 02:52:14 PM © Sandbox Cloud Expiring :]
Uptime 11:22:21:67 icli
& Manage Rstalers > P FortiClient Licenses Used | 2 out of 300
2 Chromebook Expirin
Bt Policy Componerts bd Frng :]
Chromebook Licenses Used 0outof 400
L8 Telemetry Server Lists >
B Compliance verfication ¥
Endpoint Connection ® Endpoint Management
& Administration >
# System Settings >

2

Total

2

Online

2. Register FortiClient to the EMS server.
In the example below, two FortiClients have been registered.

@ Dashboard >
0 ~ 0 0
LG Endpaints v Mot Installed * Mot Registered Out-Of-Sync

0
Sandbox Detections Que

Renew

Renew

2

Total
2
Managed
1
Security Risk

Hapageloraipe B DESKTOP-6FFNHIT yang 172.18.32.73
Domains > ) All Groups/Other Endpoints
Warkgroups »  Ef DESKTOP-IE1AT7U oy 1vana 172.18.32.72

051 All Groups/Other Endpoints
Group Assignment Rules

A Quarantine Management ¥

& Software Inventory >
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3. InFortiClient EMS System Settings, configure FortiClient EMS to send logs to FortiAnalyzer.

FortiClient Endpaint Management Server

@ Dashhoard > Profile Name | SendToFAZ24

L0 Endpoints >
- ) )
Lx Deployment « | AR Matware o | @ sandbox o | {3y web Fiter | Q‘]._'ﬁ_ Firewall o | ﬂ VPN - | @ ulnerability Scan

4 Quarantine Management  »

s  System Settings

& Software Inventary

E Endpoint Policy > ul
L8 Endpoint Prafiles v Require Passward to Disconnact From EMS
Manage Profiles Dio Not Allaw User ta Back up Configuration

Import from FortiGate/Forti

£t Manage Installers Leg)

E& Policy Components @0 cClient-Based Logging YWhen On-Net @

8 Telemetry Server Lists @0 Upload Logs to Forianalyzer/Fortianager €

& Compliance Verification
i @0 Upload UTM Logs

& Administration @ Upload vulnerability Logs

[i]

LA A A

# System Settings
@ Upload Event Logs

IP Address/Hostname 172.18.32.27 [}
Upload Schedule B minutes
Log Generation Timeout 60 seconds

4. InFortiAnalyzer, register the EMS device to a Fabric ADOM.

Device Manager w
o 1 Devices 0 Gevices
om Total Log Status Down

+ Add Device [# Edit Fi Delete  } More~  #& Column Settings ~

O aADevice Name IP Address Platform Logs Average Log Rate(Logs/Sec) Device Storage HA Status
O ©@FCTEMS1975003231 0000 FortiClient-EMS # Real Time N A (0.01%) NA

5. Inthe Fabric ADOM, go to Fabric View > Fabric > Connectors. Click Create New, and select FortiClient EMS.

Create New Fabric Connector

Please choose a connector type.

Security Fabric (3) v

® @@

FortiClient FortiMail FortiCASB
EMS

ITSM (2) v

o) (@)

ServiceNow Generic
Connector Connector

Storage (3) v

(w) (@ ©

Amazon 53 Azure Blob Google Cloud
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Configure the EMS connector, and click OK.

. Security Fabric
Create New Fabric Connector S
Configuration Actions
Name EMS Connector John2
Description Connector to execute remote EMS operations
4
42/256
IP/FQDN 172.18.32.74
Username admin
Password sessesee @

Status u

The following playbooks will be created for the connector:
» Update Asset and Identity Database
« Get Vulnerabilities from EMS
» Get Software Inventory from EMS

6. Goto FortiSoC > Automation > Connectors. Here you can view the actions FortiAnalyzer can take on endpoints
using the EMS connector.

EMS connectors

#

[ ] g EMS - EMS Connector FortiDemo o v
Actions
Name Description Parameter Output
Get Endpoints retrieve list of endpoints and Endpoint ID ems_endpoints

all of the related information (epid)
to enrich fortianalyzer asset
and identity views

FortiClient ID
(fctuid)

Quarantine quarantine endpoints Endpoint ID N/A
(epid)® or
FortiClient ID
(fetuid)®

Unquarantine unguarantine endpoints Endpoint ID N/A
(epid)” or
FortiClient ID
(fctuid)”

Vulnerability run vulnerability scan on Endpoint ID N/A
Secan endpoints (epid)® or

FortiClient ID

(fetuid)®

AV Quick Scan run quick av scan on Endpoint ID N/A
endpoints (epid)” or
FortiClient ID
(fctuid)”

AV Full Scan run full av scan on endpoints Endpoint ID N/A
(epid)® or
FortiClient ID
(fetuid)®

Get Software retrieve list of software and Endpoint ID softwares
Inventory apps installed on endpoint to  (epid)” or
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Create a playbook using the EMS connector

Below are two examples of how FortiSoC playbooks can be configured to use the FortiClient EMS connector to enable
actions in FortiAnalyzer.

To create a playbook from a template:

1. Goto FortiSoC > Automation > Playbook, and click Create New.

+ CreateNew (9 Run [# Edit ¥ Delete 4% Column Settings ~ Choose from Playbook Templates

0O Name Description Status.

New Playbook created from scratch
No record found. Custom build plavbook to get started

Playbook Critical_Intrusion_Incident

Playbook to report and contain critical intrusion incident

Playbook EMS Run_AV_Scan
Playbook to run AV scan on endpoint

Playbook EMS Quarantine_Endpoint
Playbook to quarantine endpoint

Playbook FAZ Run_Report
Playbook to run FortiAnalyzer report

Playbook Activate_Strict IPS
Playbook to activate strict IPS profile on Firewall policies

Playbook Compromised_Host_Containment
Playbook to report and contain compromised host incident

Playbook EMS Get_Endpoint_Processes
Playbook to get process list from endpaint

Playbook Add_CnC_To_Blacklist
Playbook to add CnC IP to blacklist on edge Firewalls

Playbook EM5 Run_Vulnerability_Scan
Playbook to run Yulnerability scan on endpoint

bbb bbb

2. From the list of templates, select Playbook EMS Run_Vulnerability _Scan.
This template will run a vulnerability scan on an endpoint. Save the playbook.

Playbook EMS Run_Vulnerahility_Scan - 2020-04-14T22:10:50.0117

Playbook to run Vulnerability scan on endpoint

ON_DEMAND VULN_5CAN ATTACH_DATA _TO_INCIDENT
STARTER Run Vulnerability Scan on E... Attach action status to incid...
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3. From the Playbook menu, run the playbook.

Manually Run Playbook

Playbock EMS Run_Vulnerability_Scan - 2020-04-14T22:10:50.0117

Endpoint | DESKTOP-6FPNHI7 (1532) .|

fncid INOOO00001

.

#

A prompt appears to select the endpoint on which to perform the vulnerability scan. Select the endpoint and enter

the ID of the incident that will be updated with information from the scan.

4. Goto FortiSoC > Automation > Playbook Monitor to view the running status of the playbook job and confirm it has

completed successfully.

Playbook Tasks

0O Task D Task Start Time End Time
O attach_action_status_to_incident Attach action status to incident 2020-04-14 15:29:07 -0700 2020-04-14 15:29:08 -0700
O ems_run_vuln_scan Fun Vulnerability Scan on Endpoint. 2020-04-14 15:28:35 -0700 2020-04-14 15:28:38 -0700

To create a playbook from scratch

1. Goto FortiSoC > Automation > Playbook, and click Create New.
From the list of templates, select New Playbook created from scratch.
New Playbook created from scratch - 2020-04-14T22:34:36.260Z

Custom build playbook to get started

EMS
Nare
Destriptien
ON_DEMAND L
sraren P e ;
[ Selecrasiep | Connector

Action

Endpoint 1D
FortiClient 1D
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Sucress
Sucress

Get endpoints

| EMS Connectorehn

| Get Endpoints

| Playbnek Starter | $ltriggerepid]
NeData,  Edit
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2. Configure the playbook:
a. Select a playbook trigger. For example, the On Demand trigger.
b. Add atask with the EMS connector Get Endpoints action.
c. Add atask with the Local connector Update Asset and Identity action.

New Playbook created from scratch - 2020-04-14T22:34:36.260Z
Custem build playbeek to get started
LOCALHOST
Narme Update Assets
Deseription
P ON_DEMAND
STARTER EMS_GET_ENDPOINTS i e i s """"‘:
Get endpoints i g i H Connector Local Connector

ct a Step
Action Update Asset and |dentity

Endpoint Get endpoints (id_098_... -~ | ems_endpoints

3. Click Save Playbook.
4. Run the playbook, and go to Fabric View > Assets to view the collected endpoint information.

1 new users discoverad 2new endpoints discoverad

Endpolnt. Tags User MAC Address 1P Address FortiCllent UUID Hardware /05 Yulnerabiiiies Network Location Last Update
DESKTOP-6FPNHI7

iyang 000627:54¢:531ca 172.18.3273 BOD8555BE675443CE8711951608 WING4 2020-04-14 15:59:40

DESKTOP-IEIAT7U

ivang 00:06:29:55:17.de 172.18.32.72 24ER4676018FAA6328873385C9 WINGA 2020-04-14 15:59:40

Configuring an event handler to filter IPS attack direction

The example below demonstrates how you can create a FortiAnalyzer event handler for filtering the IPS attack direction
based on the user's network environment.

You can configure this event handler based on network subnet information or interface roles:

o Event handler setup based on user network subnet on page 37
o Event handler setup based on interface role on page 42

Event handler setup based on user network subnet

In this example, the following IP range includes the internal IPs for users. IPs outside of this range are considered
external IPs.

e« 192.168.0.0 - 192.168.255.255
The victim and attacker are identified as follows:

« The victim is identified by the IP of the traffic's origin (srcip) if the direction is incoming or the destination IP (dstip) if
the direction is outgoing.

» The attacker is identified by Attack Source and Attack Name.
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Victim identified by

srcip if (direction="incoming”)

Attacker identified by

attack name

i dstip if (direction="outgoing”) attack source

1. IPS Attack to Internal Network

Victim
srcip in “Internal Network”

Event Handler
Attack Direction “Incoming” . Groy_ped by: DstEn_dpomt and Attack Name
< « Additional Information: Attack to Internal Network:
${direction} attack was detected on
${devname} from ${dstip} to ${srcip} and ${msg}

Victim
dstip in “Internal Network”

Event Handler
Attack Direction “Outgoing” . Groy_ped by: SrcEn_dpomt and Attack Name
» | - Additional Information: Attack to Internal Network
${direction} attack was detected on
${devname} from ${srcip} to ${dstip} and ${msg}

2. IPS Attack to External Network

Victim

srcip in “External Network”

Event Handler
Attack Direction “Incoming” . Groyped by: DstEn_dponm and Attack Name
< « Additional Information: Attack to External Network:
${direction} attack was detected on
${devname} from ${dstip} to ${srcip} and ${msg}

Victim
dstip in External Network”

Event Handler
Attack Direction “Outgoing” . Gro_u_ped by: SrcEr!dpomt and Attack Name
» | < Additional Information: Attack to External Network
${direction} attack was detected on
${devname} from ${srcip} to ${dstip} and ${msg}

To create an "IPS attack to internal network" event handler:

Go to FortiSoC > Handlers > Event Handler List, and click Create New to create a new event handler.

2. Based on the previously described example IP range, create an event handler to filter the alert as an attack to the

internal network when the source IP is within the internal network and the direction is incoming.
In this example, the filter is configured as follows:

Log Device Type
Log Type
Group By

Generic Text Filter
Event Severity
Tags

Additional Info

FortiAnalyzer 7.0.0 Examples
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FortiGate
IPS (ips)

Destination Endpoint (dstendpoint)
Attack Name (attack)

direction="incoming" and srcip ~ "7192\.168\."
High
ips, attack, internal

Attack to Internal Network: S${direction} attack was
detected on ${devname} from ${dstip} to ${srcip} and
${msg}
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&3 Dashboards > Edit Handler: IPS Attack to Internal Network - Subnet

# Outbreak Alerts
Filter 1 @) W v

<€ Automation >
Log Device Type FortiGate
& Event Monitor >
Log Type IPS (ips)
iE Handlers v

Group By Destination Endpoint (dstendpoint) v |+
ent Handler List

iZ FortiGate Event Handlers Attack Name (attack) R
% Threat Hunting Logs match OAIl @Any of the following conditions
[ Incidents Log Field Match Criteria Value
‘e
Generic Text Filter @ direction="incoming” and srcip ~ " 192\.168\."

4
46/1023

Generate Alert When Atleast 1 Exact » matches occurred over a period of 1440
minutes

Event Message @ $groupbyl $groupby?2

Event Status (Blank)

[J Allow FortiAnalyzer to choose

Event Severity High
Tags  ips || attack | |x internal
Additional Info

(O Use system default

© Use custom message @

Attack to Internal Network: ${direction} attack was detected on

${devname} from ${dstip} to ${srcip} and $[msg} y
111/255

3. Add an additional filter for when the destination IP is within the internal network and the direction is outgoing.
In this example, the filter is configured as follows:

Log Device Type FortiGate
Log Type IPS (ips)

Group By Source Endpoint (endpoint)
Attack Name (attack)

Generic Text Filter direction="outgoing" and dstip ~ "7192\.168\."

Event Severity High

Tags ips, attack, internal

Additional Info Attack to Internal Network: S${direction} attack was
detected on ${devname} from ${srcip} to ${dstip} and
${msg}
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¢3 Dashboards » Edit Handler: IPS Attack to Internal Network - Subnet

% Outbreak Alerts

Filter2 @) 0 v
€ Automation > )
Log Device Type FortiGate
Event Monitor >
& Ev i Log Type 1PS (ips)
= Handlers v . S
Group By Source Endpoint (endpoint) .|+
ent Handler List
Attack Name (attack) v| &
i8 FortiGate Event Handlers

Logs match OAIll - @ Any of the following conditions
3% Threat Hunting
Log Field Match Criteria Value
[ Incidents
Click to add + B
Generic Text Filter @ direction="outgoing" and dstip ~ "*192\.168\"
7
46/1023
Generate Alert When At least 1 Exact v |matches occurred over a period of | 1440
minutes
Event Message @ $groupby1 $groupby2
Event Status (Blank)

Dl Allow FortiAnalyzer to choose

Event Severity High
Tags » ips | | % attack | |» internal
Additional Info

O Use system default

(® Use custom message @
Attack to Internal Network: ${direction} attack was detected on
$ldevname} from ${srcip} to ${dstip} and ${msg}

y
111/255

4. Click OKto save the event handler.

5. Triggered alerts for this event handler are grouped by the attack source and attack name. This example includes
additional custom information and tags to help recognize them.

ADOM: pm-17558 /> .adminv

% Dashboards > B All Devices ~ @A~ ExpandAll O Show Acknowledged ORefresh‘v P R

# Outbreak Alerts Handler = "IPS Attack to Internal Network - Subnet” Add Filter
< Automation > O #  ABvent Event Type Count Severity Additional Info Handler Tags
@ Event Monitor ~ O 1 v192168.66.20(1)
@ All Events [u] 192.168.66.20 Phishing @ IPS 1 High Attack to Internal Network: incoming attack was detected on FG101E4Q17999999 from 192.16... IPS Attack to Internal Network - Subnet
12 By Endpoint > 0 2 v192168.66.21(1)
@ By Threat o 192.168.66.21 Test_Attack @ IPS 1 High Attack to Internal Network: outgoing attack was detected on FG101E4Q17999999 from 192.16... IPS Attack to Internal Network - Subnet
y Threat >
O 3 +5069.19.10(1)
1 System Events >
a} 50.69.19.10 UDPPORTO @ IPS 1 High Attack to Internal Network: incoming attack was detected on FG101E4Q17999999 from 50.69.1... IPS Attack to Internal Network - Subnet [[ips |[ attack | internal
i Hondlers > 055 [Tz T
O 4 v5069.19.11(1)
% Threat Hunting
O 50.69.19.11 Scam ® P 1 High Attack to Internal Network: outgoing attack was detected on FG101E4Q17999999 from 50.69.1... IPS Attack to Internal Network - Subnet

[ Incidents

To create an "IPS attack to external network" event handler:

1. Goto FortiSoC > Handlers > Event Handler List, and click Create New to create a new event handler.

2. Based on the previously described example IP range, create an event handler to filter the alert as an attack to the
external network when the source IP is external and the direction is incoming.
In this example, the filter is configured as follows:

Log Device Type FortiGate
Log Type IPS (ips)

Group By Destination Endpoint (dstendpoint)
Attack Name (attack)

Generic Text Filter direction=="incoming" and srcip !~ "7192\.168\."

Event Severity High

FortiAnalyzer 7.0.0 Examples
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Tags
Additional Info

ips, attack, external

Attack to External Network: ${direction} attack was
detected on ${devname} from ${dstip} to S${srcip} and
${msg}

&3 Dashboards > Edit Handler: IPS Attack to External Network - Subnet
4 Outbreak Alerts Filter 1 (’\_ o v
4 Automation > Log Device Type FortiGate
CE Event Monitor > Log Type 1PS (ips)
8 Handlers Group By Destination Endpoint (dstendpaint) | +
ent Handler List
Attack Name (attack) « |
= FortiGate Event Handlers
Logs match @Al O Any of the following conditions
% Threat Hunting
Log Field Match Criteria Value
[ Incidents
Click to add +w
Generic Text Filter @ direction=="incoming" and srcip !~ "*192\.168\."
48/1023
Generate Alert When At least 1 Exact + 'matches occurred over a period of | 1440

Event Message @

Event Status

minutes
$groupby1 $groupby?2
(Blank)

O Allow FortiAnalyzer to choose

Event Severity

Tags

High

x ips | [x attack | [x external

Additional Info
O Use system default

(@ Use custom message @

Attack to External Network: ${direction} attack was detected on
$ldevname} from ${dstip} to $fsrcip} and $imsg}

g
111/255

3. Add an additional event handler filter for when the destination IP is external and the direction is outgoing.
In this example, the filter is configured as follows:

Log Device Type
Log Type
Group By

Generic Text Filter
Event Severity
Tags

Additional Info

FortiAnalyzer 7.0.0 Examples
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FortiGate
IPS (ips)

Source Endpoint (endpoint)
Attack Name (attack)

direction=="outgoing" and dstip !~ "7192\.168\."
High
ips, attack, external

Attack to External Network: S${direction} attack was
detected on ${devname} from ${srcip} to ${dstip} and
${msg}
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& Dashboards >

Edit Handler: IPS Attack to External Network - Subnet
4 Outbreak Alerts

Fitter2 @) W v
< Automation >
Log Device Type FortiGate
3 Event Monitor >
Log Type IPS (ips)
iE Handlers v
Group By Source Endpoint (endpoint) v+
Event Handler List
Attack Name (attack) W
S FortiGate Event Handlers
% Threat Hunting Logs match @AIl O Any of the following conditions
Y Incidents Log Field Match Criteria Value
Click to add +®
Generic Text Filter @ direction=="outgoing" and dstip !~ "*192\.168\"
y
48/1023|
Generate Alert When Atleast 1 Exact + matches occurred over a period of 1440
minutes

Event Message @ $groupby1 $groupby2

Event Status (Blank)

O Allow FortiAnalyzer to choose

Event Severity High

Tags % ips | [x attack | | x external

Additional Info
O Use system default

® Usc custom message @
Attack to External Network: ${direction} attack was detected on
${devname} from ${srcip} to ${dstip} and ${msg}

4
111/255

Click OK to save the event handler.

Triggered alerts for this event handler are grouped by the attack source and attack name. This example includes
additional custom information and tags to help recognize them.

ADOM: pm-17558 (& .admin v
&

¢ Dashboards > B Al Devices ~ Q@AI~ ,7ExpandAll O Show Acknowledged CRefresh ~ & H ~

% Outbreak Alerts Handler = "IPS Attack to External Network - Subnet" ' Add Filter

< Automation > ) #  AEvent Event Type Count Severity Additional Info Handler Tags
G Event Monitor ~ D 1 V192168662400
& All Events a} 1921686624 UDPPO.. ®IPS 1 High Attack to External Network: incoming attack was detected on FG101E4Q17999999 from 192.1...  IPS Attack to External Network - Subnet
12 By Endvoint > 0 2 v192.168.66.25(1)
® By Threat a] 192168.66.25Botnet  @IPS 1 High Attack to External Network: outgoing attack was detected on FG101E4Q17999999 from 192.16... IPS Attack to External Network - Subnet
y Threat >
0 3 v5069.09.14(1)
¥ System Events >
o 50.69.19.14 Eicar ®IPs 1 High Attack to External Network: incoming attack was detected on FG101E4Q17999999 from 50.69.... IPS Attack to External Network - Subnet
iE Handlers >
0 4 v5069.19.16(1)
% Threat Hunting
0 50.69.19.16 eicar.com oiPs 1 High Attack to External Network: outgoing attack was detected on FG101E4Q17999999 from 50.69.... IPS Attack to External Network - Subnet

[ Incidents

Event handler setup based on interface role

In this example, interface roles are set up in FortiGate, where the internal network is connected with the "lan" interface,
and the external network is connected with the "wan" interface.
Traffic follows the below situations between the internal and external networks.

« Traffic from internal to internal: srcintfrole="lan", dstintfrole="lan".

« Traffic from internal to external: srcintfrole="lan", dstintfrole="wan".

« Traffic from external to external: srcintfrole="wan", dstintfrole="wan".
« Traffic from external to internal: srcintfrole="wan", dstintfrole="lan".

FortiAnalyzer 7.0.0 Examples
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To create an "IPS attack to internal interface” event handler:

1. Goto FortiSoC > Handlers > Event Handler List, and click Create New to create a new event handler.

2. Based on the previously described interface roles, create an event handler to filter the alert as an attack to the
internal interface when the source interface role is "lan" and the direction is incoming.
In this example, the filter is configured as follows:

Log Device Type
Log Type
Group By

Generic Text Filter
Event Severity
Tags

Additional Info

FortiGate
IPS (ips)

Destination Endpoint (dstendpoint)
Attack Name (attack)

direction=="incoming" and srcintfrole=="lan"
High

ips, attack, internal

Attack to Internal Network: ${direction} attack was
detected on: ${devname} from ${dstip} to ${srcip} and
${msg}

€3 Dashboards > Edit Handler: IPS Attack to Internal - Interface
% Outbreak Alerts .
Filter1 @) W v
4 Automation >
Log Device Type FortiGate
3 Event Monitor >
Log Type IPS (ips)
iE Handlers v
Group By Destination Endpoint (dstendpoint) v| +
= Event Handler List
— Attack Name (attack) v| &
iZ FortiGate Event Handlers
% Threat Hunting Logs match All - @®Any of the following conditions
1 Incidents Log Field Match Criteria Value
Click to add -+ fr
Generic Text Filter @ direction=="incoming" and srcintfrole=="lan"
g
44/1023
Generate Alert When Atleast| 1 Exact + |matches occurred over a peried of 1440
minutes

Event Message @

Event Status

$groupby1 $groupby2

@ Allow FortiAnalyzer to choose

Event Severity

Tags

High

% attack | | % ips || internal

Additional Info

Use system default

@ Use custom message @

Attack to Internal network: ${direction} attack was detected on
$ldevname] from ${dstip} to ${srcip} and $(msg}

4

112/255

3. Add an additional filter for when the destination interface role is "lan" and the direction is outgoing.
In this example, the filter is configured as follows:

Log Device Type
Log Type
Group By

FortiAnalyzer 7.0.0 Examples
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FortiGate
IPS (ips)

Source Endpoint (endpoint)
Attack Name (attack)
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Generic Text Filter direction=="outgoing" and dstintfrole=="1lan"

Event Severity Medium

Tags ips, attack, internal

Additional Info Attack to Internal Network: ${direction} attack was

detected on: ${devname} from ${srcip} to ${dstip} and
${msg}

2 Dashboards > Edit Handler: IPS Attack to Internal - Interface
4 Outbreak Alerts
= Fiter2 @) i
<€ Automation >

Log Device Type FortiGate
GE Event Monitor >

Log Type IPS (ips)
iZ Handlers v

Group By Source Endpoint (endpoint) v | +

ent Handler List
Attack Name (attack) v m
2 FortiGate Event Handlers

Logs match QAIl @ Any of the following conditions
% Threat Hunting

Log Field Match Criteria Value

ve

B Incidents

Generic Text Filter @ direction=="outgoing" and dstintfrole=="lan"
g
44/1023
Generate Alert When Atleast 1 Exact + |matches occurred over a period of 1440
minutes
Event Message @ $groupby1 Sgroupby?2

Event Status

B Allow FortiAnalyzer to choose

Event Severity Medium
Tags % ips | [x attack | [x internal
Additional Info

O Use system default

®Use custom message @

Attack to Internal network: ${direction} attack was detected on:
${devname} from ${srcip} to ${dstip} and ${msg} )
112/255

4. Click OKto save the event handler.

5. Triggered alerts for this event handler are grouped by the attack source and attack name. This example includes
additional custom information and tags to help recognize them.

ADOM: pm-17558 £~ .adminv

€% Dashboards > B All Devices ~ @AIl~ 7Expand Al O Show Acknowledged 5 Refresh

- &5 H- &

% Outbreak Alerts Handler = "IPS Attack to Internal - Interface”  Add Filter

< Automation > O #  AEvent Event Type Count Severity Additional Info Handler Tags
G Event Monitor ~ D 1 19216866200
@ All Events a} 192.168.66.20 Phishing ~ @ IPS 1 High Attack to Internal network: incoming attack was detected on: FG101E4Q17999999 from 192.16... IPS Attack to Internal - Interface
12 By Endpoint > 0 2 v192.168.66.21(1)
® By Threat a] 192.168.66.21 Test Atta... ®1PS 1 Me... Attack to Internal network: outgoing attack was detected on: FG101E4Q17999999 from 192.16... IPS Attack to Internal - Interface
y Threat >
0 3 v5069.19.10(1)
I System Events >
o 50.69.19.10 UDP.PORTO @ IPS 1 High Attack to Internal network: incoming attack was detected on: FG101E4Q17999999 from 50.69.... IPS Attack to Internal - Interface
iE Handlers >
0 4 v5069.19.11(1)
% Threat Hunting
0 50.69.19.11 Scam ops 1 Me..._ Attack to Internal network: outgoing attack was detected on: FG101E4Q17999999 from 50.69.1... IPS Attack to Internal - Interface

[ Incidents

To create an "IPS attack to external interface" event handler:

1. Goto FortiSoC > Handlers > Event Handler List, and click Create New to create a new event handler.

2. Based on the previously described interface roles, create an event handler to filter the alert as an attack to the
external interface when the source interface role is "wan" and the direction is incoming. In this example, the filter is
configured as follows:

FortiAnalyzer 7.0.0 Examples
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Log Device Type
Log Type
Group By

Generic Text Filter
Event Severity
Tags

Additional Info

FortiGate
IPS (ips)

Destination Endpoint (dstendpoint)
Attack Name (attack)

direction=="incoming" and srcintfrole=="wan"
High
ips, attack, external

Attack to External Network: ${direction} attack was

detected on: ${devname} from ${dstip} to ${srcip} and
${msg}

% Dashboards > Edit Handler: IPS Attack to External - Interface
4 Outbreak Alerts .
Fiter 1 @) B v
€ Automation >
Log Device Type FortiGate
G Event Monitor >
Log Type IPS (ips)
iZ Handlers v
Group By Destination Endpoint (dstendpoint) 5 +
£= Event Handler List
- Attack Name (attack) | &
S FortiGate Event Handlers
. Logs match QAll ‘Any of the following conditions
% Threat Hunting e ©any wine '
] Incidents Log Field Match Criteria Value
Click to add + @
Generic Text Filter @ direction=="incoming" and srcintfrole=="wan"
p
45/1023
Generate Alert When Atleast 1 Exact + matches occurred over a period of 1440

Event Message @

Event Status

minutes

$groupby1 $groupby2

& Allow FortiAnalyzer to choose

Event Severity

Tags

High

x attack | % ips | | % external

Additional Info

O Use system default

(@ Use custom message @

Attack to External network: ${direction} attack was detected on
${devname} from ${dstip} to $isrcip} and ${msg}

3. Add an additional filter for when the destination interface role is "wan" and the direction is outgoing.
In this example, the filter is configured as follows:

Log Device Type
Log Type
Group By

Generic Text Filter
Event Severity

Tags

FortiAnalyzer 7.0.0 Examples
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FortiGate
IPS (ips)

Source Endpoint (endpoint)
Attack Name (attack)

direction=="outgoing" and dstintfrole=="wan"
High

ips, attack, external
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Additional Info Attack to External Network: ${direction} attack was
detected on: ${devname} from ${srcip} to ${dstip} and
${msg}

¢3 Dashboards > Edit Handler: IPS Attack to External - Interface
# Outbreak Alerts Filter2 @ g
<€ Autemation > Log Device Type | FortiGate 3
@ Event Monitor > Log Type [ 1PS fips) |
Handlers ~ Group By \ Source Endpoint [endpoint) v ‘ +
£= Event Handler List
FortiGate Event Handlers
Logs match QOAll @ Any of the following conditions
%% Threat Hunting
Log Field Match Criteria Value

[ Incidents

Click to a +a

Generic Text Filter @ direction=="outgoing" and dstintfrole=="wan"
5
44/1023
Generate Alert When Atleast 1 Exact v |matches occurred over a period of 1440
minutes
Event Message @ $groupby1 $groupby2
Event Status v
1% Allow FortiAnalyzer to choose
Event Severity High v
Tags % Tos ) [ attack] [x extemal
Additional Info

(O Use system default

® Use custom message @
Attack to External network: ${direction] attack was detected on:
${devname} from $fsrcip} to ${dstip} and ${msg}

4. Click OKto save the event handler.

5. Triggered alerts for this event handler are grouped by the attack source and attack name. This example includes
additional custom information and tags to help recognize them.

apom:pr-i7558 2 ([ acimin

B All Devices ~ @A~ ~Expand Al O Show Acknowledged SRefresh‘v & B~ &

€% Dashboards >

# Outbreak Alerts Handler = "IPS Attack to External - Interface” Add Filter

£ Automation > #  AEvent Event Type Count Severity Additional Info Handler Tags

3 Event Monitor ~ 1 v192168.66.24 (1)

€ AllEvents

18 By Endpoint >

192.168.66.24 UDP.PO. 9 IPS 1 ® High Attack to External network: incoming attack was detected on: FG101E4Q17999999 from 192.1... IPS Attack to External - Interface
2 v192168.66.25(1)

192.168.66.25 Botnet ¥ 1P 1 © High Attack to External network: outgoing attack was detected on: FG101E4Q17999999 from 192.16... IPS Attack to External - Interface
3 v50.69.19.14 (1)

® ByThreat >

B System Events >

50.69.19.14 Eicar ¥ 1P 1 @ High Attack to External network: incoming attack was detected on: FG101E4Q17999999 from 50.69.... IPS Attack to External - Interface
andlers >

4 v5069.19.16 (1)
% Threat Hunting

Oo0oo0Oo0oOo0oooo0o

50.69.19.16 eicar.com 9 IPS 1 ®High Attack to External network: outgoing attack was detected on: FG101E4Q17999999 from 50.69.... IPS Attack to External - Interface
B Incidents
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This section contains the following topics:

» FortiAl logging on FortiAnalyzer on page 47

FortiAl logging on FortiAnalyzer

Starting in FortiAnalyzer 7.0.1, you can configure FortiAnalyzer to accept logs from a FortiAl device for use in the
following ways:

« FortiAnalyzer can recognize FortiAi devices.

« FortiAl logs can be stored in Fabric ADOM.

o FortiAl can be viewed in LogView.

» FortiAl Device Type and Log Types are available in event handlers and report data sets.

To add a FortiAl device to FortiAnalyzer:

1. On FortiAnalyzer, ensure you in are in the correct ADOM.
2. Goto Device Manager and add the FortiAl device.

Prior to FortiAnalyzer 7.0.1, FortiAnalyzer could not recognize FortiAl devices. In 7.0.1 and later, FortiAnalyzer is
able to recognize the FortiAl device and will display it in the Unauthorized Device list once added.

Authorize Device

Add the following device(s) to ADOM: CSF (Fabric 7.0)

Device Name Assign New Device Name

FAIVMSTM21000033 FAIVMSTM21000033

3. Select Unauthorized Devices and authorize the FortiAl device.
When the FortiAl device is authorized on FortiAnalyzer, it is listed in the FortiAnalyzer Device Manager with
information including its device name, IP, serial number, and logging status.

Device Manager ADOM:CSF /& L1 e admin v
=+ Add Device [# Edit Wi Delete # More v % Column Settings v Show Map. Q
O  aDevice Name |P Address Platform Logs Average Log Rate(Logs/Sec) Device Storage Description SN
O @FAI35FT319000004 10.3.120.254 FortiAl-3500F @ Real Time 0] | (1.33%) FAI35FT312000004

FortiAnalyzer 7.0.0 Examples
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To view FortiAl logs in FortiAnalyzer:

1.
2,

On FortiAnalyzer, ensure you are in the correct ADOM.

Go to Log View > FortiAl.
There is a new FortiAl log type created for the FortiAl device. When FortiAl logs are received, they are displayed in
Log View.

Log View v ADOM:CSF /» [ 1 oadminv

¥ Fabric > B All FortiAl ~ ® Last 12 Hours ~ 21:58:50 To 09:58:49

FortiAnalvzer > Add Filter
& FortiAl ~ # ¥ Date/Time Device ID Type Sub Type Level User Status
1 06-1022:11 FAI35FT319000004 event information success
@ Attack v 2 06-10 22:48 FAI35FT319000004 event information success
Attack Chain 3 06-10 23:24 FAI35FT319000004 event information success
4 00:00:44 FAI35FT319000004 event information success
Malware 5 00:36:59 FAI35FT319000004 event information success
& Log Browse 6 01:13:14 FAI35FT319000004 event information success
B Log Group 7 01:49:29 FAI35FT319000004 event information success
8 02:25:44 FAI35FT319000004 event information success
9 03:01:59 FAI35FT319000004 event information success
10 03:38:14 FAI35FT319000004 event information success
11 03:38:15 FAI35FT319000004 event information success
12 04:14:30 FAI35FT312000004 event information success
13 05:08:37 FAI35FT319000004 event information success
14 06:02:44 FAI35FT319000004 event information success
15 06:56:51 FAI35FT319000004 event information success
16 07:50:58 FAI35FT319000004 event information success
17 08:45:05 FAI35FT319000004 event information success
18 09:39:12 FAI35FT319000004 event information success
f= Total logs for analytics: 1 day 17 hours. ‘ 50 v ltems per page « i - ! ~ 0.009 Second
Go to Log View > Fabric.
FortiAnalyzer adds a SIEM parser to FortiAl logs so that they can be viewed in the Fabric SIEM database correctly.
Log View v ADOM: CSF /¥ oadmin v

% Fabric v © Last 1 Hour~ 09:01:24 To 10:01:23 % BHB- F-

FortiAnalyzer > # ¥ Date/Time {Data Source ID ) Event Type Event Severity Source IP (Data Parser Name ) (Data Source Type
@& FortiAl » 1 10:01:13 FAI35FT3192000004 attack alert FortiAl parser FortiAl
B3 Log Browse 2 10:01:12 FAI35FT312000004 attack alert 192.168.100.2 FortiAl parser FortiAl
Bl Log Group 3 10:01:11 FAI35FT3192000004 attack alert FortiAl parser FortiAl
4 10:01:10 FAI35FT319000004 attack alert 192.168.100.2 FortiAl parser FortiAl
5 10:01:09 FAI35FT319000004 attack alert FortiAl parser FortiAl
6 10:01:08 FAI35FT319000004 attack alert 192.168.100.2 FortiAl parser FortiAl
7 10:01:07 FAI35FT3192000004 attack alert FortiAl parser FortiAl
8 10:01:06 FAI35FT319000004 attack alert 192.168.100.2 FortiAl parser FortiAl
9 10:01:05 FAI35FT312000004 attack alert FortiAl parser FortiAl
10 10:01:04 FAI35FT 319000004 attack alert 192.168.100.2 FortiAl parser FortiAl
11 10:01:03 FAI35FT 319000004 attack alert FortiAl parser FortiAl
12 10:01:02 FAI35FT312000004 attack alert 192.168.100.2 FortiAl parser FortiAl
13 10:01:01 FAI35FT312000004 attack alert FortiAl parser FortiAl
14 10:01:00 FAI35FT312000004 attack alert 192.168.100.2 FortiAl parser FortiAl
15 10:00:59 FAI35FT319000004 attack alert FortiAl parser FortiAl
16 10:00:58 FAI35FT319000004 attack alert 192.168.100.2 FortiAl parser FortiAl
17 10:00:57 FAI35FT3192000004 attack alert FortiAl parser FortiAl
18 10:00:56 FAI35FT319000004 attack alert 192.168.100.2 \ FortiAl parser _J \FortiAl i
J
= Total logs for analytics: 1 day 17 hours. f Items per page ¢ ¢ - 2 8 4 5 »  ~0125Second
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4. Goto Log View > Log Browse.
In Log Browse, you can see the FortiAl device logs listed. You can download or import FortiAl logs.

ADOM: CSF  /» oadminv

¥ Fabric > Add Filter B Al Devices~ (O Last 7 Days ~

FortiAnalyzer >

[ Display| Eil Delete | & Download |31 Import

& Fortinl > o # Device Name Serial Number VDOM  Type File Name From To Size

o 1 FAI35FT319000004  FAI35FT319000004 root Event elog.log 2021-06-09 16:20:16 2021-06-11 09:39:17 577.5k

¥ Log Group o 2 FAI35FT319000004  FAI35FT319000004 root Attack alog.log 2021-06-09 16:18:37 2021-06-11 09:59:37 49.9M
o 3 .self FAZ-VMTM20008339 CSF App Events rlog.log 2021-06-09 18:27:11 2021-06-10 16:09:51 931

To create a custom event handler using FortiAl logs:

1. Goto FortiSoC > Handlers > Event Handler List, and create a new event handler.
2. Enter a name for the event handler, for example FortiAl-Event-Handler.
3. Enable afilter, and select FortiAl as the Log Device Type.
4. InLog type, select a FortiAl log type.
5. Configure the remaining settings as required, and click OK to save the event handler.
ADOM:root &~ L5 Qadminv
€9 Dashboards > Edit Handler: FortiAl-Event-Handler
# Outbreak Alerts Status m -
€ Automation > Name FortiAl-Event-Handler
C2 Event Monitor > Description

2 Handlers ~ Devices @AIl Devices O Specify O Local Device

Event Handler List Subnets @Al Subnets O Specify

i FortiGate Event Handlers
% Threat Hunting Filters +

Incidents

Fiter 1 [ v

Log Device Type | FortiAl
Log Type Event Log (event)
Group By Attack Log (attack)
Logs match Event Log (event)
Log Field Match Criteria Value
‘ Level (pri) v‘ ‘ Equal To v‘ ‘ Emergency - ‘ == W

B . -

6. Events triggered by the event handler appear in FortiSoC > Event Monitor > All Events. The name of the event
handler is displayed in the table.

ADOM:root & L5 eadminv

€3 Dashboards > A All FortiAl ~ O Llast 7 Days..~ " ExpandAll O Show Acknowledged JRefresh~ & B+ L

=

i Outbreak Alerts Add Filter (v]
<€ Automation > O # Event Event Status Event Type Count Severity First Occurrence Handler
C3 Event Monitor ~ o 1 > action:N/A (14) & Event 30182 Medium 4 days ago FortiAl-Event-Handler
o 2 > none (6) 4 Event 8 Medium 4 days ago FortiAl-Event-Handler
8 By Endpoint > o 3 > login (8) B Event 22 Medium 4 days ago FortiAl-Event-Handler
® By Threat > o 4 > logout (1) B Event 1 Medium  An hour ago FortiAl-Event-Handler
& System Events > o 5 > dst:N/A (5) £+ Attack 295465 Medium  Aday ago FortiAl-Attack-Handler

2 Handlers v
i2 Event Handler List

i2 FortiGate Event Handlers
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To create a custom report using FortiAl logs:

1. Go to Reports > Report Definitions > Datasets, and create or edit a dataset.
2. Selecta FortiAl log type in the Log Type dropdown.

3. Configure the remaining settings as required, and click OK to save the dataset.
The dataset can now be used when configuring charts used in FortiAnalyzer reports.

ADOM:root /% L) 5 eadminv

B Generated Reports Edit Dataset
B Report Definitions v -
B All Reports Dataset { Test query with spedfied devicas and time period N
& Templates Name FortiAl-Event
[ul Chart Library @ Log Type Attack .|| Time Last N Days v
Period
[& Macro Library Query ‘ | | N 7
Fo;l;;:eptnr © [ Devices @Al Devices - OSpecify
£ Advanced ~ Event Test Result
N Language devid type  subtype level stai‘

[5 Output Profile Variables
R¢ Calend FAI35FT319000004 event perf-stats information suc
eport Calendar

Fabric FAI35FT319000004 event perf-stats information suc

Normalized

o FAI35FT319000004 event perf-stats information suc
FAI35FT319000004 event perf-stats information suc
FAI35FT319000004 event perf-stats information suc
FAI35FT319000004 event perf-stats information suc

FAI35FT319000004 event perf-stats information suc
- v -

e
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Troubleshooting

This section contains the following topics:

e Troubleshooting report performance issues on page 51
o Troubleshooting a dataset query on page 59
» Troubleshooting an empty chart on page 61

Troubleshooting report performance issues

The following topics provide guidance when troubleshooting report performance issue:

o Check the report diagnostic log on page 51

o Check hardware and software status on page 54

» Check data policy and log storage policy on page 55

o Check report and chart settings on page 55

o Check and adjust report auto-cache daemon on page 56

» Check and adjust report hcache on page 57

« Report performance troubleshooting commands on page 58

Check the report diagnostic log

For reports that take a long time to run, check the report diagnostic log to troubleshoot performance issues.

To retrieve a report diagnostic log, go to Reports > Generated Report, right-click the report and select Retrieve
Diagnostic to download the log to your computer. Use a text editor to open the log and check the log for possible causes
of performance issues.

Following are parts of a sample report diagnostic log and what to look for when troubleshooting report performance.

NAME SCHEDULED AUTO-CACHE REPORT GROUP REPORT TITLE

1 v \Y - Security Analysis

per-device option: disable
hostname-resolve: disable

Report Status
Max pending rpts: 100000
Current pendings: 0
Max running rpts: 10
Current runnings: 2
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Section What to look for

NAME / SCHEDULED / Check the SCHEDULED, AUTO-CACHE, and REPORT GROUP columns.
AUTO-CACHE / REPORT » Schedule the reports that run regularly. To configure report schedules, see
GROUP / REPORT TITLE Scheduling reports in the FortiAnalyzer Administration Guide.

» Enable auto-cache for reports that run regularly, especially schedule reports. See
How auto-cache works and Enabling auto-cache in the FortiAnalyzer
Administration Guide.

e Group reports that run regularly. To group reports, see Grouping reports in the
FortiAnalyzer Administration Guide.

hostname-resolve Ensure hostname-resolve is setto disable. Resolving hosthames usually takes a
long time. If the DNS server is slow or does not support reverse DNS, report generation
might hang.

Total Quota Summary:
Total Quota Allocated Available Allocate$%
27201.3GB 1024.0GB 26177.3GB 3.8 %

System Storage Summary:
Total Used Available Use%
27501.3GB 1117.6GB 26383.6GB 4.1 %

System Performance
Fri Aug 25 12:00:02 2017

CPU

Used: 34.4%

Used (Excluded NICE) : 34.4%
Memory

Total: 34939888 KB

Used 23899636 KB 68.4%
Hard Disk

Total: 28837161872 KB

Used: 11171927688 KB 38.7%

IoStat:
Log Rate

logs/sec: 20326.8, logs/30sec: 20395.6, logs/60sec: 20274.2
Message Rate

msgs/sec: 3057.4, msgs/30sec: 3068.1, msgs/60sec: 3039.1

Section What to look for

Total Quota Summary » Ensure there is enough disk quota and disk space for logging and reporting.
and System Storage Insufficient disk quota might affect report accuracy.

Summary Disk quota must be big enough so that quota enforcement does not affect logs

used for reporting. If quota enforcement trims the logs or tables used for the
reporting period, there might be empty charts or incorrect data.

System Performance e Check that there is enough system resources including CPU, memory, and disk
space.
» Check that the log rate and message rate is not so high that it slow report
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Section What to look for

generation.

« Ifthe log rate is higher than the sustained rates for your FortiAnalyzermodel, the
hardware is overloaded and needs an upgrade. The sustained rates for
FortiAnalyzermodels are listed in the Data Sheet on the FortiAnalyzer web page.

Run Report

Fri Aug 25 12:00:03 2017

[12:00:03] Request hcaches for 9 log tables

chart Traffic-Bandwidth-Summary-Day-Of-Month done, 1 subgrys
1/1 took 17.88s, 0 hcaches ready, 2 hcaches requested
overall time used 18.13s

chart Session-Summary-Day-Of-Month done, 1 subgrys
1/1 took 15.54s, 0 hcaches ready, 2 hcaches requested
overall time used 15.80s

chart Traffic-History-By-Active-User done, 1 subgrys
1/1 took 12.79s, 0 hcaches ready, 2 hcaches requested
overall time used 13.07s

chart Top-Attack-Victim done, 1 subqgrys
1/1 took 1.71s, 0 hcaches ready, 1 hcaches requested
overall time used 1.71s

chart Top-Attack-Source done, 1 subqgrys
1/1 took 1.51s, 0 hcaches ready, 1 hcaches requested
overall time used 1.51s

chart Top-Attacks-Detected done, 1 subgrys
1/1 took 1.91s, 0 hcaches ready, 1 hcaches requested
overall time used 1.94s

chart System-Summary-By-Severity done, 1 subqgrys
1/1 took 1.22s, 0 hcaches ready, 1 hcaches requested
overall time used 1.22s

chart System-Critical-Severity-Events done, 1 subqgrys
1/1 took 1.18s, 0 hcaches ready, 1 hcaches requested
overall time used 1.18s

chart System-High-Severity-Events done, 1 subqgrys
1/1 took 0.46s, 0 hcaches ready, 1 hcaches requested
overall time used 0.46s

Section What to look for

Run Report * Check the number of log tables.
» Check the number of hcaches requested vs ready.
If many hcaches are not ready, then those charts will take a long time.
If the number of log tables is high but the number of hcaches ready is low, retrieve
the diagnostic log after five minutes. A change in the number of hcaches ready
means the report is still running.

Since the diagnostic log is updated every five minutes, you can check this log to
view reporting progress.
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Section What to look for

¢ Check which charts take a long time to generate and reconfigure those charts to
improve performance.

Report Summary
Fri Aug 25 12:00:56 2017

Number of charts: 58
Number of tables: 9
Number of hcaches requested: 109

HCACHE building time: 53.32s
Rendering time: 13.33s
Total time: 1m7.67s

Section What to look for

Report Summary ¢ Check the number of hcaches requested, hcache building time, and rendering
time.
The number of hcaches requested =number of charts per report * number
of primary tables * number of reports.

Check hardware and software status

get system status

This command shows the system status such as platform type (hardware or VM), firmware version, system time, disk
usage, and file system format.

Use this information to check if the hardware is overloaded. This information also helps you and customer support to
quickly identify any issues and narrow down the investigation.

Following is a sample result of running this command.

Platform Type : FAZ3500E

Platform Full Name : FortiAnalyzer-3500E
Version : v5.4.3-build1187 170517 (GA)

Serial Number : FL99999999999999

BIOS version : 00010001

System Part-Number : P15168-01

Hostname : SAMPLEFZ350

Max Number of Admin Domains : 4000

Admin Domain Configuration : Disabled

FIPS Mode : Disabled

Branch Point : 738

Release Version Information : GA

Current Time : Tue May 23 10:22:53 PST 2017
Daylight Time Saving : Yes

Time Zone : (GMT-8:00) Pacific Time (US & Canada).
x86-64 Applications : Yes

Disk Usage : Free 17020.10GB, Total 40314.71GB
File System : Ext4
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Current Time This is the SQL insert start time.
File System Ensure the file system is Ext 4. Other file systems will likely cause performance
issues.

What to look for:

o Check the hardware Platform Type. Consider upgrading older hardware, especially older hardware running
newer software such as 5.2 or later.

e Version shows the software version. Ensure you are running the latest software version with the newest report
engine.

e EnsureFile Systemis Ext4. Other file systems will likely cause performance issues.

diagnose fortilogd lograte

This command shows the log receive rate.

Following is a sample result of running this command.

logs/sec: 121091.0, logs/30sec: 119613.9, logs/60sec: 116695

What to look for

« Ifthe log rate is higher than the sustained rates for your FortiAnalyzer model, the hardware is overloaded and needs
an upgrade. The sustained rates for FortiAnalyzer models are listed in the Data Sheet on the FortiAnalyzer web
page.

Check data policy and log storage policy

Check that the data policy and log storage policy are configured properly for each ADOM in each FortiAnalyzer unit. The
data policy specifies how long to keep logs. The log storage policy affects logs and the SQL database. For details, see
the FortiAnalyzer Administration Guide.

Check report and chart settings

Resolving hostnames usually takes a long time. If the DNS server is slow or does not support reverse DNS, report
generation might hang. Check that Resolve Hostname is disabled:

« In Reports Settings tab > Advanced Settings, check that Resolve Hostname is not selected.
e Inthe Chart Library, check that Resolve Hostname is setto Disabled.

If you do not need to show all results, specify a lower maximum number of entries:

o Inthe Chart Library, check that the chart's Show Top (0 for all results) is notsettoo high.
Setting this field to 0 for all results causes FortiAnalyzer to list all logs for the chart.
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Check and adjust report auto-cache daemon

get system performance

This command shows system performance statistics such as CPU, memory, and I/O usage.

Following is a sample result of running this command.

CPU:
Used: 49.51%
Used (Excluded NICE) : 49.51%
%used Suser S%Snice %sys $idle %iowait S$irg $softirg
CPUO 27.89 20.60 0.00 5.40 96.42 0.80 0.00 1.79
CPUl 21.62 12.61 0.00 8.20 98.38 0.40 0.00 0.40
Memory:

Total: 6,134,200 KB
Used: 3,770,260 KB 61.5%

Hard Disk:
Total: 82,434,736 KB
Used: 65,283,648 KB 79.2%
IOStat: tps r_tps w_tps r kB/s w_kB/s queue wait ms svc _ms %util sampling sec
4.7 0.2 4.4 27.5 144.2 0.2 52.5 8.4 3.9 599578.78
Flash Disk:
Total: 499,656 KB
Used: 314,416 KB 62.9%
IOStat: tps r_tps w_tps r _kB/s w_kB/s queue wait ms svc_ms %util sampling sec
0.0 0.0 0.0 0.0 0.0 0.0 13.6 4.6 0.0 599578.78

Following is a sample result of high $iowait. To see the iowait usage and limit, first enable debug messages for SQL
commands (diagnose debug enable)and setthe debug level (diagnose debug application
sglrptcached 8).

FAZVM64 # [530] iowait usage (27.5%) is over limit (23%).

[530] iowait usage (25.9%) is over limit (23%).

[530] iowait usage (28.3%) is over limit (23%).

What to look for

o Check the Used and T0Stat lines to see if I/O is busy.

 Ifboth CPU %used and $iowait are high, check if the report cache daemon is running:
diagnose debug enable
diagnose debug application sglrptcached 8

o If iowait is over the limit, cache building (by sglrptcached) will be paused until i owait drops below the limit. In
this case, do one or both of the following:

« Change the report schedule to run at a less busy time. To see scheduled reports, run execute sqgl-report
list-schedule <ADOM>. To configure report schedules, see Scheduling reports in the FortiAnalyzer
Administration Guide.

e Enable aggressive-schedule so the report auto-cache daemon does not stop even under heavy system
load:
config system report auto-cache

set aggressive-schedule enable
end
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Check and adjust report hcache

diagnose test application sqlrptcached 2

This command shows if hcache creation is able to catch up.

Following is a sample result of running this command.

Number of log table read: all=6453(fortiview=0, rpt=6453) pending=1
Number of log table done: all=6453(fortiview=0, rpt=6453) rpt=6453
Current hcache table entries: 155750

Number of hcache requests sent: 70999

Number of log table vacuums: 39401, pending=2

FortiView hcache load: rounds=817, tbl=653600

ncmdb:

cache hit: sch=0, config=27, chart=140, macro=0, dataset=140 config=27
calls : sch=130, config=11l, chart=23, macro=0, dataset=23

The following table provides notes about some output lines in the example.

Number of log table read pending=0 means hcache creation is able to catch up. If pendingis above 0,
see What to look for below.

Number of log table done The number of primary tables used to calculate the Number of hcache
requests sent

Current hcache table Total hcache on the system.

entries

Number of hcache The number of charts per report * the number of primary tables * the number of
requests sent reports.

Number of log table The postgres built-in status. A pending number above 0 indicates insufficient
vacuums postgres resources.

FortiView hcache load rounds is the number of FortiView caches proactively loaded into memory.
ncmdb Report configuration database.

cache hit config is the number of enabled auto cache.

What to look for

e InNumber of log table read, ifthe pending numberis continuously above 0 or is increasing, that indicates
there are too many pending log tables to read and the system lacks resources to create cache. In this case,
consider disabling auto-cache on some reports. See Enabling auto-cache and Reports Settings tab in the
FortiAnalyzer Administration Guide.

e Runexecute sgl-report list-schedule <ADOM> and check ifthere are too many scheduled reports and if
auto-cache is enabled. See Scheduling reports and Enabling auto-cache in the FortiAnalyzer Administration Guide.

e Runexecute top tocheck which applications are using the most system resources.
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execute sql-report hcache-check <ADOM> <schedule-id>

This command shows a specific report’s hcache status.
If necessary, check the hcache status of a specific report that you think might be a problem.

For example, if the ADOM is root and schedule-idis 10004, thenrun execute sql-report hcache-check
root 10004.

To getthe schedule-id, run execute sqgl-report list-schedule root and see the NAME column.

Following is a sample result of running the execute sgl-report hcache-check <ADOM> <schedule-id>
command.

layout num:1

start [0] get layout-id:10004.

start report process, layout-id:10004, layout title:Admin and System Events Report.
device list:All FortiGates.

reports num:1.

device 1ist[0].FWF60C3G13006291 [root].
device 1list[1].FG3K2C3711800039[root].

> checking (10004 t10004-Admin and System Events Report)
checking chart Admin-Login-Summary.. .

8/8 (100%) done 0.131 secs used.

checking chart Admin-Login-Summary-By-Date...

8/8 (100%) done 0.128 secs used.

What to look for

« If afew reports are causing a bottleneck, check those reports’ Check the report diagnostic log on page 51 and
consider reconfiguring those reports. See also Check and adjust report auto-cache daemon on page 56.

Report performance troubleshooting commands

CLI Description

diagnose debug application Set the debug level of the SQL report cache daemon.
sglrptcached 8

diagnose debug crashlog read Printinformation of all crashed daemons.
If daemons crash frequently, contact customer support for assistance.

diagnose debug disable Disable debug message.
diagnose debug enable Enable debug messages to run SQL diagnostic commands.
diagnose fortilogd lograte Show the log receive rate.
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CLI Description

diagnose fortilogd msgrate Show message receive rate. One message might contain multiple logs.
diagnose log device Show disk quota for all logging devices.

diagnose report status Show the maximum number of pending and running reports, and the current

number of pending and running reports.

diagnose test application Show if hcache creation is able to catch up.
sglrptcached 2

diagnose sgl show Show the hcache size.
hcache-size

diagnose sql status run-sql-  Listthe number of log tables, hcaches, and the time to generate each chart

rpt in the report.

diagnose sqgl status Show SQL query connections and hcache status.
sglreportd

execute sgl-report hcache- Show a specific report’s hcache status.

check <ADOM> <schedule-id>

execute sqgl-report Show a summary table of all configured reports with their configuration
list-schedule <ADOM> status.

execute top List the processes running on the FortiAnalyzer system.

get system performance Show system performance statistics such as CPU, memory, and I/O usage.
get system status Show the system status such as platform type (hardware or VM), firmware

version, system time, disk usage, and file system format.
Use this information to check if the hardware is overloaded. This information
also helps you and customer support to quickly identify any issues and
narrow down the investigation.
e Ensure Version is the latest software version.
e Check the hardware Platform Type. Consider upgrading older
hardware, especially older hardware running newer software such as
5.2 or later.
e Ensure File Systemis Ext4. Other file systems will likely cause
performance issues.

show system report Show non-default settings in the report auto-cache.

auto-cache Ensure auto-cache is enabled by running these commands:
config system report auto-cache
set status enable
end

Troubleshooting a dataset query

The following topics provide guidance when troubleshooting a dataset query:
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» Troubleshooting a custom dataset on page 60
» SQL functions for formatting and converting data types on page 60
» Macros for formatting date and time in a dataset on page 61

Troubleshooting a custom dataset

This topic provides a list and an example of common issues in a custom dataset that cannot be identified by the dataset
test console.

Common issues:

o $filterisnotapplied.

o No ### forinner query.

e distinct isusedininnerquery.

» No column alias for column with function.

» no hcache merge for count distinct.

» No group byor order by.

» Log tables are not joined. For example, join traffic log with IPS log.
« Dataset test console is out of memory.

The image below indicates where common issues may appear in the dataset:

Main
Query

SQL functions for formatting and converting data types

The following SQL functions can be used to format or convert different data types:
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SQL function Description

from itime / from dtime  Converts timestamp to formatted date/time.

ipstr Converts srcip/dstip field from inet to string.
app_group name Groups similar application names.

root_domain Groups similar hostnames.

vpn_trim Groups similar VPN tunnels.

nullifna Converts N/Atonull.

logid to_int Trims logid.

Macros for formatting date and time in a dataset
The following macros can be used to fine tune date and time formatting in a dataset:

Macros Description

$flex_timescale Time scale changes according to the report time period:
¢ Time period > 28 days
e Time period > 12 hours and <= 28 days
e Time period >4 hours and <= 12 hours
e Time period > 1 hour
e <=hour

$hour_of day Displays hour in 24 hr format.
$HOUR_OF DAY Displays date (YYYY-MM-DD) and hour in 24 hr format.

$DAY_OF_MONTH  Displays month in format YYYY-MM-DD (2017-01-10).
$day of month Displays day of the month in two digits format 01-12.
$day_of week Displays number and name of the day of the week

(WDAY 2-Mon).

Troubleshooting an empty chart

To troubleshoot an empty chart in a report, go to Log View to verify logs are incoming.

« If you see logs check for SQL errors.
 Ifyou don't see any logs the daemon may have stopped working.
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Example

» Display day: 2018-02-25

e Display hour: 2018-02-25
14:00

¢ Display 30 min granularity:
2018-02-25 14:30

 Display 5 min granularity:
2018-02-25 14:40

 display 1 min granularity:
2018-02-25 14:42

18:00
2018-01-13 18:00
2018-01-01

01

Mon
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Go to Log View.
Can you see incoming logs?

Ensure the database is working properly:

|

Yes

|

The daemon has likely stopped working.
—> —> NO —> —> diagnose debug enable

diagnose test application sqllogd2
diagnose sql status sqlplugind
diagnose test applicaiton oftpd2
diagnose test applicaiton fortilogd2

Enable debug to check SQL errors:

“diagnose debug enable”“diagnose debug application sqlplugind 4”, then run the report.
This will find errors in a custom dataset or chart setting.

!

Check the report setting, record the device, time range, and filter information.

|

Go to Log View.

Select the correct log type, then apply the same device, time range, and filter settings to see if the logs exist.

|

If the logs are okay, run a dataset test, then modify the filters until you can see results.

CLI commands for troubleshooting

The following table provides a list of CLI commands to troubleshoot an empty chart in a report:

Command

Description

Check report running/pending

status

Debug sql query

List current SQL process

Configure global report
automatic cache setting

List report schedule/auto-
cache status by ADOM

Diagnose report hcache
working status

Check individual report
hcache status

Check report status during
report running

FortiAnalyzer 7.0.0 Examples
Fortinet Technologies Inc.

diagnose report status {running | pending}

diagnose debug enable
diagnose debug application sqglplugind 4 ----- errors only
diagnose debug application sqglplugind 8

diagnose sqgl process list

config system report auto-cache

execute sgl-report list-schedule <ADOM-name>

diagnose test application sglrptcached 2

execute sgl-report hcache-check <ADOM-name> <schedule-id>

diagnose debug enable
diagnose sqgl status sglreportd
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Common issues

The following table provides a list of common issues that may produce an empty chart in a report:

Issue Description

Wrong report filter applied

Log field changed after
upgrade

Hcache corrupt

Log traffic

“logver” issue

"out of memory”
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Go to Log View and search for:
« Field “status” changed to “action” (since 5.0.6)
e Datatypeof srcip anddstip changed from stringto inet.

This can be identified by a dataset test console or SQL debug.

Clear hcache before running the report (dia sgl remove hcache).

e Highlograte (diagnose fortilogd lograte)
¢ Device or ADOM quota reached (diagnose log device)

Some datasets are using field “logver” to identify FOS log version.
Go to Log View and search for 1ogver=*
If there are no records, you may need to upgrade.

File system error. This occurs mostly in 5.2.

63



FE:EHT"‘IEE www.fortinet.com

Copyright© 2021 Fortinet, Inc. All rights reserved. Fortinet®, FortiGate®, FortiCare® and FortiGuard®, and certain other marks are registered trademarks of Fortinet, Inc., and other Fortinet names herein
may also be registered and/or common law trademarks of Fortinet. All other product or company names may be trademarks of their respective owners. Performance and other metrics contained herein were
attained in internal lab tests under ideal conditions, and actual performance and other results may vary. Network variables, different network environments and other conditions may affect performance
results. Nothing herein represents any binding commitment by Fortinet, and Fortinet disclaims all warranties, whether express or implied, except to the extent Fortinet enters a binding written contract,
signed by Fortinet's General Counsel, with a purchaser that expressly warrants that the identified product will perform according to certain expressly-identified performance metrics and, in such event, only
the specific performance metrics expressly identified in such binding written contract shall be binding on Fortinet. For absolute clarity, any such warranty will be limited to performance in the same ideal
conditions as in Fortinet’s internal lab tests. Fortinet disclaims in full any covenants, representations, and guarantees pursuant hereto, whether express or implied. Fortinet reserves the right to change,
modify, transfer, or otherwise revise this publication without notice, and the most current version of the publication shall be applicable.


https://www.fortinet.com/

	Change log
	Introduction
	System settings
	Setting up a FortiAnalyzer HA cluster

	Reports
	Configuring a report with an LDAP server

	Real-time dashboards
	Configuring FortiAnalyzer to detect FortiSandbox devices
	Creating a firewall policy on FortiSandbox
	Creating a log server for FortiAnalyzer
	Adding FortiSandbox to FortiAnalyzer


	Fabric connectors
	Configuring a ServiceNow connector
	Locating your ServiceNow API URL
	Creating a fabric connector for ServiceNow
	Sending notifications to ServiceNow

	Creating a Google Cloud connector
	Configuring a Google Cloud storage bucket
	Locating your Google Cloud information
	Importing the CA certificate
	Creating the cloud connector
	Testing the Google Cloud connector


	SOAR and SIEM
	Event handler example scenarios
	Custom event handler example
	Predefined event handler example

	Configuring an EMS connector for use in FortiSoC playbooks
	Configure the EMS connector
	Create a playbook using the EMS connector

	Configuring an event handler to filter IPS attack direction
	Event handler setup based on user network subnet
	Event handler setup based on interface role


	Logging
	FortiAI logging on FortiAnalyzer

	Troubleshooting
	Troubleshooting report performance issues
	Check the report diagnostic log
	Check hardware and software status
	Check data policy and log storage policy
	Check report and chart settings
	Check and adjust report auto-cache daemon
	Check and adjust report hcache
	Report performance troubleshooting commands

	Troubleshooting a dataset query
	Troubleshooting a custom dataset
	SQL functions for formatting and converting data types
	Macros for formatting date and time in a dataset

	Troubleshooting an empty chart
	CLI commands for troubleshooting
	Common issues



