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What's New in FortiAnalyzer

This chapter provides a summary of the new features and enhancements in FortiAnalyzer:

FortiAnalyzer 6.0.3 on page 10
FortiAnalyzer 6.0.2 on page 11
FortiAnalyzer 6.0.1 on page 11
FortiAnalyzer 6.0.0 on page 12

Always review all sections in the FortiAnalyzer Release Notes prior to upgrading your device.

Al
S L4
? Not all features or enhancements are supported on all models.

FortiAnalyzer 6.0.3

FortiAnalyzer 6.0.3 includes the following new features and enhancements:

Event Manager

New Default Event Handlers

The following new default Event Handlers have been added for malicious, suspicious, and high risk events:

Default-High-Risk-App-Detection
Default-Malicious-Code-Detection
Default-Malicious-Destination-Detection
Default-Malicious-File-Detetion
Default-Suspicious-File-Detection

FortiView

Log ID for long sessions

In FortiView, Log ID = 0000000020 indicates a long session that is not yet closed. A long session has multiple logs but
is still considered one session. The sent/received data of long sessions counts all interim traffic data reported by lines

with Log ID = 0000000020.
When the session is closed, the Log ID is 13.

FortiAnalyzer 6.0.3 Administration Guide 10
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What’s New in FortiAnalyzer

FortiAnalyzer 6.0.2

FortiAnalyzer 6.0.2 includes the following new features and enhancements:

Event Manager

New Default Event Handlers

New Default Event Handlers have been added for IOC Detections and Sandbox Events.

Multiple Filters in one Event Handler

Additional filters can be added to an Event Handler to trigger related events from multiple log types.
Fabric View

Fabric Connectors for ITSM

Administrators can use FortiAnalyzer to send notifications to ITSM platforms upon new incident creation or any
subsequent update in the Fabric View. The Fabric Connectors allow FortiAnalyzer to send incident notifications to third-
party platforms, such as ServiceNow.

FortiView

FortiView Improvements

The FortiView Endpoints views are enhanced for content readability and presentation.

Reports

Report Languages

You can export and import report languages. One way to create a new report language is to export a predefined
language, modify it to a different language, and then import the new language into FortiAnalyzer.

FortiAnalyzer 6.0.1

FortiAnalyzer 6.0.1 includes the following new features and enhancements:

FortiAnalyzer 6.0.3 Administration Guide 11
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What’s New in FortiAnalyzer

System Settings

Anonymization of user information for GDPR

Added a Privacy Masking option for administrators to mask or anonymize user information. Administrators can choose
which fields to mask. Masked fields show anonymous data in all modules that display those fields. Use the data mask
key to reveal the original, unmasked data.

NOC - SOC

New SOC Views

The following SOC views have been added under NOC - SOC:

o The Security > Top Threat widget has a new scatter chart view.

« Anew Worldwide Threat Prevalence widget under Threat Research.

o Anew Virus Incidents widget under Threat Research.

o The Security Fabric Rating Report widget (FSBP Maturity Milestones) has a new rings view.
« Anew Sankey topology graph in the Security > User Data Flow widget.

FortiView

FortiView Improvements

Added historical timeline charts to FortiView for improved visual representation of changes over time.

FortiAnalyzer 6.0.0

FortiAnalyzer 6.0.0 includes the following new features and enhancements:

Incident Detection & Response

Event Manager 2.0

« From Event Manager > Event Monitor > All Events, you can now search and filter events, customize columns and
save filtered events to a Custom View.

« The secondary Group By option from the event handler edit screen provides flexibility on event information
organization.

« Built-in event handlers provide threat feed to the FortiOS automation framework. You can raise an incident from
detected events. The raised incident is listed under the Incidents menu for further analysis and evidence collection.

FortiAnalyzer 6.0.3 Administration Guide 12
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What’s New in FortiAnalyzer

SOC Dashboards

o Fortinet Security Best Practice Dashboard: a simple CISO dashboard to show a snapshot of the security of your
network, including the current security ranking score, industry peer comparison, and security maturity level.

o New Vulnerability Dashboard: displays a summary of detected endpoint vulnerabilities along with the detailed
FortiGuard information for each critical vulnerability.

I0C Enhancements

« 10C scan now includes Traffic logs and DNS logs to provide better detection coverage.
« The IOC Notification Service provides event notification to FortiOS when a compromised host is detected.

FortiAnalyzer High Availability

Support automatic failover over IP for log redundancy and high system availability.

Secure Syslog Forwarding

Support forwarding logs in syslog format over TLS/SSL.

FortiAnalyzer 6.0.3 Administration Guide
Fortinet Technologies Inc.

13



Setting up FortiAnalyzer

This chapter provides information about performing some basic setups for your FortiAnalyzer units.
This section contains the following topics:

« Connecting to the GUI on page 14

o Security considerations on page 15

« GUIl overview on page 16

« Target audience and access level on page 19
o Initial setup on page 20

« FortiManager features on page 20

« Next steps on page 22

« Restarting and shutting down on page 22

Connecting to the GUI

The FortiAnalyzer unit can be configured and managed using the GUI or the CLI. This section will step you through
connecting to the unit via the GUI.

To connect to the GUI:

1. Connect the FortiAnalyzer unit to a management computer using an Ethernet cable.
2. Configure the management computer to be on the same subnet as the internal interface of the FortiAnalyzer unit:
+ |Paddress: 192.168.1.X
o Netmask: 255.255.255.0
3. Onthe management computer, start a supported web browser and browse to https://192.168.1.99.
4. Type admin in the Name field, leave the Password field blank, and click Login.
The Change Password dialog box is displayed.
5. Change the default password now, or click Laterto change the password later:
a. Inthe New Password box, type a new password.
b. Inthe Confirm Password box, type the new password again, and click OK.
6. If ADOMs are enabled, the Select an ADOM pane is displayed. Click an ADOM to select it.
The FortiAnalyzer home page is displayed.

7. Click atile to go to that pane. For example, click the Device Manager tile to go to the Device Manager pane.
See also GUI overview on page 16.

If the network interfaces have been configured differently during installation, the URL
and/or permitted administrative access protocols (such as HTTPS) may no longer be in

their default state.

FortiAnalyzer 6.0.3 Administration Guide
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Setting up FortiAnalyzer

For information on enabling administrative access protocols and configuring IP addresses, see Configuring network
interfaces on page 136.

Ay
‘Q' If the URL is correct and you still cannot access the GUI, you may also need to configure
- static routes. For details, see Static routes on page 138.

After logging in for the first time, you should create an administrator account for yourself and assign the Super_User
profile to it. Then you should log into the FortiAnalyzer unit by using the new administrator account. See Managing
administrator accounts on page 190 for information.

Security considerations

You can take steps to prevent unauthorized access and restrict access to the GUI. This section includes the following
information:

« Restricting GUI access by trusted host on page 15
« Other security considerations on page 15

Restricting GUI access by trusted host

To prevent unauthorized access to the GUI you can configure administrator accounts with trusted hosts. With trusted
hosts configured, the administrator user can only log into the GUI when working on a computer with the trusted host as
defined in the administrator account. You can configure up to ten trusted hosts per administrator account. See
Administrators on page 189 for more details.

Other security considerations

Other security consideration for restricting access to the FortiAnalyzer GUI include the following:

« Configure administrator accounts using a complex passphrase for local accounts
« Configure administrator accounts using RADIUS, LDAP, TACACSH+, or PKI

« Configure the administrator profile to only allow read/write permission as required and restrict access using read-
only or no permission to settings which are not applicable to that administrator

« Configure the administrator account to only allow access to specific ADOMs as required

FortiAnalyzer 6.0.3 Administration Guide 15
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Setting up FortiAnalyzer

GUI overview

When you log into the FortiAnalyzer GUI, the following home page of tiles is displayed:

Device Manager

Fabric View

NN
A A

ADOM:root @ A1 (§) admin+

FortiView

o

Event Manager System Settings

Select one of the following tiles to display the respective pane. The available tiles will vary, depending on the privileges

of the current user.

Device Manager
Fabric View

FortiView

NOC - SOC

Log View

Event Manager

Reports

System Settings

Add and manage devices and VDOMSs. See Device Manager on page 29.
Configure fabric connectors. See Fabric View on page 37.

View summaries of log data in graphical formats. For example, you can view top
threats to your network, top sources of network traffic, top destinations of network
traffic and so on. For each summary view, you can drill down into details for the
event. See FortiView on page 78.

This pane is not available when the unit is in Collector mode.

View network security, WiFi security, and system performance in real-time. You
can select what activities to monitor in customizable dashboards. See NOC -
SOC Monitoring on page 71.

This pane is not available when the unit is in Collector mode.

View logs for managed devices. You can display, download, import, and delete
logs on this page. You can also define custom views and create log groups. See
Log View and Log Quota Management on page 41.

Configure and view events for logging devices. See Event and Incident
Management on page 58.

This pane is not available when the unit is in Collector mode.

Generate reports. You can also configure report templates, schedules, and
output profiles, and manage charts and datasets. See Reports on page 92.

This pane is not available when the unit is in Collector mode.

Configure system settings such as network interfaces, administrators, system
time, server settings, and others. You can also perform maintenance and
firmware operations. See System Settings on page 123.

FortiAnalyzer 6.0.3 Administration Guide
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Setting up FortiAnalyzer

The top-right corner of the home page includes a variety of possible selections:

ADOM If ADOMs are enabled, the required ADOM can be selected from the dropdown list.
The ADOMSs available from the ADOM menu will vary depending on the privileges of the
current user.

Full Screen Click to view only the content pane in the browser window. See Full-screen mode on page 18.

Help Click to open the FortiAnalyzer online help, or view the About information for your device
(Product, Version, and Build Number).

You can also open the FortiAnalyzer basic setup video
(https://video.fortinet.com/video/208/fortianalyzer-basic-setup).

Notification Click to display a list of notifications. Select a notification from the list to take action on the
issue.
admin Click to change the password or log out of the GUI.
Panes

In general, panes have four primary parts: the banner, toolbar, tree menu, and content pane.

Banner Along the top of the page; includes the home button (Fortinet logo), tile menu,
ADOM menu (when enabled), admin menu, notifications, and help button.

Tree menu On the left side of the screen; includes the menus for the selected pane.
Not available in Device Manager.

Content pane Contains widgets, lists, configuration options, or other information, depending on
the pane, menu, or options that are selected. Most management tasks are
handled in the content pane.

Toolbar Directly above the content pane; includes options for managing content in the
content pane, such as Create New and Delete.

© Last 1 Week ~

+ Add Widget ~

‘® Threats ~
Top Threats Top 10 Threats o X
Threat Map
Compromised Hosts
FortiSandbox Detection

= Traffic >

2! Applications & Websites ~
Top Applications 2018... failed-connection
Top Cloud Applications
Top Web Sites MS.DN...
Top Browsing Users . .

& VPN Prox.. Web...

= WiFi

{¥ System

& Endpoints
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Setting up FortiAnalyzer

To switch between panes, either select the home button to return to the home page, or select the tile menu then select
anew tile.

E:E Device Manager ~

0 oevices 0% storage Used

r
E CIII] ’* ‘. Log Status Down n Total 50.0 GB
o~ | A |

Device Manager FortiView NOC - S0C Log View
0O a Average Log Rate{Logs/Sec) Device Storage Description
0 ¢ N/A (0%)
o ¢ N/A (0.02%)
ot P N/A (0%)

\/\/\/\ ‘

o ¢ X N/A (0%) D
g Fabric View Event Manager Reports System Settings LUL (0%)
a8 N/A (0%)

Color themes

You can choose a color theme for the FortiAnalyzer GUI. For example, you can choose a color, such as blue or plum, or
you can choose an image, such as summer or autumn. See Global administration settings on page 207.

Full-screen mode
You can view several panes in full-screen mode. When a pane is in full-screen mode, the tree menu on the left side of
the screen is hidden.

Click the Full Screen button in the toolbar to enter full-screen mode, and press the Esc key on your keyboard to exit full-
screen mode.

Switching between ADOMs

When ADOMs are enabled, you can move between ADOMs by selecting an ADOM from the ADOM menu in the
banner.

ADOM:root (2 @ QA1 A admin~w

ADOM access is controlled by administrator accounts and the profile assigned to the administrator account. Depending
on your account privileges, you might not have access to all ADOMs. See Managing administrator accounts on page
190 for more information.

Using the right-click menu

Options are sometimes available using the right-click menu. Right-click an item in the content pane, or within some of
the tree menus, to display the menu that includes various options similar to those available in the toolbar.

FortiAnalyzer 6.0.3 Administration Guide
Fortinet Technologies Inc.

18



Setting up FortiAnalyzer

In the following example on the Reports pane, you can right-click a template, and select Create New,

View, Clone, or
Create Report.

So& Reporis v ADOM:root I3 @ Q1 (§) admin v
B Genera ted Reports

+ Create New [ Edit ¥4 Delete % Clone BS CreateReport & Install Language Pack

B Report Definitions ~

B5 All Reports B  RKTemp Template

+ Create New

y review of Application Visibility and Control, Threat Detection, Data
FaTemplate - 360-D1 [ Edit ! ) . HTML
tion Detection, Endpoint Detection, Prevention and Recommended ~ * Security
[l Chart Library @ Security Review PDF
B Delete 1
[# Macro Library =l
O BgTemplate - Admin @~ °"® | taled | s HTML
= s login and failed login attempts and system severity event counts. ystem
£ Datasets @ System Events Repo B Create Report = © PDF
43 Advanced > O EgTemplate - Application Appl 'y app, web categories, vulnerability HTML
English Application ©w
Bick and Cantral attacle Fla tranctars BnE

When FortiClient sends logs to FortiAnalyzer, an avatar for each user can be displayed in the Source column in the
FortiView and Log View panes. FortiAnalyzer can display an avatar when the following requirements are met:

« FortiClient is managed by FortiGate or FortiClient EMS with logging to FortiAnalyzer enabled.
« FortiClient sends logs and a picture of each user to FortiAnalyzer.

If FortiAnalyzer cannot find the defined picture, a generic, gray avatar is displayed.

A\,

‘Q' You can also optionally define an avatar for FortiAnalyzer administrators. See
- Creating administrators on page 191.

Showing and hiding passwords

In some cases you can show and hide passwords by using the toggle icon. When you can view the password, the Toggle
show password icon is displayed:

Password test @

When you can hide the password, the Toggle hide password icon is displayed:

Password [u..

-]

Target audience and access level

This guide is intended for administrators with full privileges, who can access all panes in the FortiAnalyzer GUI,
including the System Settings pane.

In FortiAnalyzer, administrator privileges are controlled by administrator profiles. Administrators who are assigned
profiles with limited privileges might be unable to view some panes in the GUI and might be unable to perform some
tasks described in this guide. For more information about administrator profiles, see Administrator profiles on page 195.

L If you logged in by using the admin administrator account, you have the Super_User
q administrator profile, which is assigned to the admin account by default and gives the admin
- administrator full privileges.

FortiAnalyzer 6.0.3 Administration Guide
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Setting up FortiAnalyzer

Initial setup

This topic provides an overview of the tasks that you need to do to get your FortiAnalyzer unit up and running.

To set up FortiAnalyzer:

1. Connect to the GUI. See Connecting to the GUI on page 14.
2. Configure the RAID level, if the FortiAnalyzer unit supports RAID. See Configuring the RAID level on page 141.
3. Configure network settings. See Configuring network interfaces on page 136.
ﬂ Once the IP address of the administrative port of FortiAnalyzer is changed, you will lose
I connection to FortiAnalyzer. You will have to reconfigure the IP address of the
management computer to connect again to FortiAnalyzer and continue.
4. (Optional) Configure administrative domains. See Managing ADOMs on page 147.
5. Configure administrator accounts. See Managing administrator accounts on page 190.
ﬂ After you configure the administrator accounts for the FortiAnalyzer unit, you should log in
l again by using your new administrator account.
6. Add devices to the FortiAnalyzer unit so that the devices can send logs to the FortiAnalyzer unit. See Adding
devices on page 30.
7. Configure the operation mode. See Configuring the operation mode on page 130 and Two operation modes on
page 24.
FortiManager features

When FortiManager features are enabled for the FortiAnalyzer unit, the following panes are available:

Device Manager (for Add, configure, and manage FortiGate devices.
FortiManager)

Policy and Object Centrally manage FortiGate devices by creating policies and objects and

installing them to managed devices.

AP Manager Centrally manage FortiAP access points by authorizing and monitoring FortiAP

devices. You can also edit and monitor authorized devices.

FortiClient Manager Centrally manage FortiClient profiles for FortiGate devices as well as monitor

FortiClient endpoints.

VPN Manager Centrally manage IPsec VPN communities and SSL-VPN settings.

FortiSwitch Manager Centrally manage FortiSwitch templates and VLANs, and monitor FortiSwitch

devices that are connected to FortiGate devices.
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HA is not supported when FortiManager features are enabled.

For information about using FortiManager features, see the FortiManager Administration Guide.

Enable or disable FortiManager features

You can enable FortiManager features on FortiAnalyzer so it can manage a small number of FortiGate devices. All the
FortiManager features can be enabled on FortiAnalyzer except FortiGuard.

FortiAnalyzer 1000E and above devices come with a free license to manage up to two FortiGate devices when
FortiManager features are enabled.

For FortiAnalyzer 2U and above devices, you can purchase a management license to enable your FortiAnalyzer unit to
manage up to 20 FortiGate devices.

You can enable or disable FortiManager features using either the GUI or CLI.

To enable FortiManager features on FortiAnalyzer using the GUI:

1. Goto System Settings > Dashboard.
2. Inthe System Information widget, toggle the FortiManager Features switch to On.

3. After the system reboots, log in to the FortiAnalyzer GUI.
The FortiAnalyzer home page now also shows FortiManager feature tiles except FortiGuard.

To enable FortiManager features on FortiAnalyzer using the CLI:

1. From the CLI, or in the CL/ Console widget, enter the following:
config system global
set fmg-status enable
end

The following prompt is displayed:

Changing fmg status will affect FAZ feature. If you continue, system will reboot.
Do you want to continue? (y/n)

2. Typeyv.

3. After the system reboots, log in to the FortiAnalyzer GUI. FortiManager features, except FortiGuard, have been
enabled.

To upgrade the management license:

1. Goto System Settings > Dashboard.

2. Inthe License Information widget, find the Management > Devices/VDOMs field and click the Upload license
icon.

3. Inthe dialog box, provide the license key that you have purchased.

To disable FortiManager features on FortiAnalyzer using the GUI:

1. Goto System Settings > Dashboard.
2. Inthe System Information widget, toggle the FortiManager Features switch to Off.
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3. After the system reboots, log in to the FortiAnalyzer GUI.
The FortiAnalyzer home page no longer includes FortiManager feature tiles.

To disable FortiManager features on FortiAnalyzer using the CLI:

1. From the CLI, orin the CLI Console widget, enter the following:
config system global
set fmg-status disable
end

The following prompt is displayed:

Changing fmg status will affect FAZ feature. If you continue, system will reboot.
Do you want to continue? (y/n)

2. Typev.

Next steps

Now that you have set up your FortiAnalyzer units and they have started receiving logs from the devices, you can start
monitoring and interpret data. You can:

« View log messages collected by the FortiAnalyzer unit in Log View. See Types of logs collected for each device on
page 41.
« View summaries of threats, traffic, and more in FortiView. See FortiView on page 78

« View multiple panes of network activity in NOC (Network Operations Center) or SOC (Security Operations Center).
See NOC - SOC Monitoring on page 71.

« Generate and view events in Event Manager. See Event and Incident Management on page 58.
o Generate and view reports in Reports. See Reports on page 92.

Restarting and shutting down

Always use the operation options in the GUI or the CLI commands to reboot and shut down the FortiAnalyzer system to
avoid potential configuration problems.

To restart the FortiAnalyzer unit from the GUI:

1. Goto System Settings > Dashboard.
2. Inthe Unit Operation widget, click the Restart button.
3. Enter a message for the event log, then click OK to restart the system.

To restart the FortiAnalyzer unit from the CLI:

1. From the CLI, or in the CL/ Console widget, enter the following command:
execute reboot
The system will be rebooted.
Do you want to continue? (y/n)

2. Enter y to continue. The FortiAnalyzer system will restart.
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To shutdown the FortiAnalyzer unit from the GUI:

1. Goto System Settings > Dashboard.
2. Inthe Unit Operation widget, click the Shutdown button.
3. Enter a message for the event log, then click OK to shutdown the system.

To shutdown the FortiAnalyzer unit from the CLI:

1. From the CLI, orin the CL/ Console widget, enter the following command:
execute shutdown
The system will be halted.
Do you want to continue? (y/n)

2. Enter y to continue. The FortiAnalyzer system will shutdown.

To reset the FortiAnalyzer unit:

1. From the CLI, or in the CL/ Console widget, enter the following command:
execute reset all-settings
This operation will reset all settings to factory defaults
Do you want to continue? (y/n)

2. Enter y to continue. The device will reset to factory default settings and restart.

To reset logs and re-transfer all SQL logs to the database:

1. From the CLI, orin the CL/ Console widget, enter the following command:
execute reset-sgllog-transfer
WARNING: This operation will re-transfer all logs into database.
Do you want to continue? (y/n)

2. Enter y to continue. All SQL logs will be resent to the database.
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This section provides information about basic FortiAnalyzer concepts and terms. If you are new to FortiAnalyzer, use
this section to quickly understand this document and the FortiAnalyzer platform.

This section includes the following sections:

« Two operation modes on page 24

+ Administrative domains on page 26
« Log storage on page 26

« NOC/SOC dashboard on page 28

Two operation modes

FortiAnalyzer can run in two operation modes: Analyzer and Collector. Choose the operation mode for your
FortiAnalyzer units based on your network topology and requirements.

Analyzer mode

Analyzer mode is the default mode that supports all FortiAnalyzer features. Use this mode to aggregate logs from one
or more Collectors.
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The following diagram shows an example of deploying FortiAnalyzer in Analyzer mode.

FortiAnalyzer

l F I FortiGates |

ortiGates

Collector mode

When FortiAnalyzer is in Collector mode, its primary task is forwarding logs of the connected devices to an Analyzer and
archiving the logs. Instead of writing logs to the database, the Collector retains logs in their original binary format for
uploading. In this mode, most features are disabled.

Analyzer and Collector feature comparison

Feature Analyzer Mode Collector Mode
Device Manager Yes Yes
FortiView Yes No
FortiAnalyzer 6.0.3 Administration Guide 25
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Feature Analyzer Mode Collector Mode
Log View Yes Raw archive logs only
Event Manager Yes No
Monitoring devices Yes No
Reporting Yes No
System Settings Yes Yes
Log Forwarding Yes Yes

Analyzer-Collector collaboration

You can deploy Analyzer mode and Collector mode on different FortiAnalyzer units and make the units work together to
improve the overall performance of log receiving, analysis, and reporting. The Analyzer offloads the log receiving task to
the Collector so that the Analyzer can focus on data analysis and report generation. This maximizes the Collector’s log
receiving performance.

For an example of setting up Analyzer—Collector collaboration, see Collectors and Analyzers on page 220.

Administrative domains

Administrative domains (ADOMs) enable the admin administrator to constrain the access privileges of other
FortiAnalyzer unit administrators to a subset of devices in the device list. For Fortinet devices with virtual domains
(VDOMSs), ADOMs can further restrict access to only data from a specific VDOM for a device.

Enabling ADOMs alters the available functions in the GUI and CLI. Access to the functions depends on whether you are
logged in as the admin administrator. If you are logged in as the admin administrator, you can access all ADOMs. If
you are not logged in as the admin administrator, the settings in your administrator account determines access to
ADOMs.

For information on enabling and disabling ADOMSs, see Enabling and disabling the ADOM feature on page 146. For
information on working with ADOMs, see Administrative Domains on page 144. For information on configuring
administrator accounts, See Managing administrator accounts on page 190.

M ADOMs must be enabled to support FortiCarrier, FortiClient EMS, FortiMail, FortiWeb,
q FortiCache, and FortiSandbox logging and reporting. See Administrative Domains on page
- 144.

Log storage

Logs and files are stored on the FortiAnalyzer disks. Logs are also temporarily stored in the SQL database.

You can configure data policy and disk utilization settings for devices. These are collectively called log storage settings.
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You can configure global log and file storage settings. These apply to all logs and files in the FortiAnalyzer system
regardless of log storage settings.

SQL database

FortiAnalyzer supports Structured Query Language (SQL) for logging and reporting. The log data is inserted into the
SQL database to support data analysis in FortiView, Log View, and Reports. Remote SQL databases are not

supported.

For more information, see FortiView on page 78, Types of logs collected for each device on page 41, and Reports on
page 92.

The log storage settings define how much FortiAnalyzer disk space to use for the SQL database.

L When FortiAnalyzer is in Collector mode, the SQL database is disabled by default. If you want
? to use logs that require SQL when FortiAnalyzer is in Collector mode, you must enable the
- SQL database. See Two operation modes on page 24.

Archive logs and Analytics logs

Logs in FortiAnalyzer are in one of the following phases. Use a data policy to control how long to retain Analytics and
Archive logs.

« Real-time log: Log entries that have just arrived and have not been added to the SQL database.

« Analytics logs or historical logs: Indexed in the SQL database and online.

« Archive logs: Compressed on hard disks and offline.

In the indexed phase, logs are indexed in the SQL database for a specified length of time for the purpose of analysis.

Logs in the indexed phase in the SQL database are considered online and you can view details about these logs in the
FortiView, Log View, and Event Manager pane. You can also generate reports about the logs in the Reports pane.

In the compressed phase, logs are compressed and archived in FortiAnalyzer disks for a specified length of time for the
purpose of retention. Logs in the compressed phase are considered offline and you cannot immediately view details
about these logs in the FortiView, Log View, and Event Manager pane. You also cannot generate reports about the
logs in the Reports pane.

Data policy and automatic deletion

Use a data policy to control how long to keep compressed and indexed logs. When ADOMs are enabled, you can specify
settings for each ADOM and the settings apply to all devices in that ADOM. When ADOMs are disabled, settings apply
to all managed devices.

A data policy specifies:

« How long to keep Analytics logs indexed in the database
When the specified length of time in the data policy expires, logs are automatically purged from the database but
remain compressed in a log file on the FortiAnalyzer disks.

« How long to keep Archive logs on the FortiAnalyzer disks
When the specified length of time in the data policy expires, Archive logs are deleted from the FortiAnalyzer disks.

FortiAnalyzer 6.0.3 Administration Guide
Fortinet Technologies Inc.



FortiAnalyzer Key Concepts

See also Log storage information on page 55.

Disk utilization for Archive and Analytic logs

You can specify how much of the total available FortiAnalyzer disk space to use for log storage. You can specify what
ratio of the allotted storage space to use for logs that are indexed in the SQL database and for logs that are stored in a
compressed format on the FortiAnalyzer disks. Then you can monitor how quickly device logs are filling up the allotted

disk space.
Y Analytic logs indexed in the SQL database require more disk space than Archive logs (purged
‘?' from the SQL database but remain compressed on the FortiAnalyzer disks). An average
- indexed log is 400 bytes and an average compressed log is 50 bytes. Keep this difference in

mind when specifying the storage ratio for Analytics and Archive logs.

When ADOMs are enabled, you can specify settings for each ADOM and the settings apply to all devices in that ADOM.

When ADOM s are disabled, settings apply to all managed devices. See Log storage information on page 55.

NOC/SOC dashboard

FortiAnalyzer provides dashboard for Network Operations Center (NOC) or Security Operations Center (SOC)
administrators. The dashboards enhance visualization for real-time activities and historical trends for analysts to
effectively monitor network activities and security alerts. See NOC - SOC Monitoring on page 71.

FortiAnalyzer 6.0.3 Administration Guide
Fortinet Technologies Inc.

28



Device Manager

Use the Device Manager pane to add, configure, and manage devices and VDOMSs.

) ' ’, If FortiManager features are enabled, then this is the FortiManager Device Manager.
9 For information about using FortiManager features, see the FortiManager Administration
= Guide.

After you add and register a device or VDOM, the FortiAnalyzer unit starts collecting logs from that device or VDOM.
You can configure the FortiAnalyzer unit to forward logs to another device. See Log Forwarding on page 157.

ADOMs

You can organize connected devices into ADOMs to better manage the devices. ADOMs can be organized by:

« Firmware version: group all 5.4 devices into one ADOM, and all 5.2 devices into another.

« Geographic regions: group all devices for a specific geographic region into an ADOM, and devices for a separate
region into another ADOM.

« Administrator users: group devices into separate ADOMs based for specific administrators responsible for the
group of devices.

« Customers: group all devices for one customer into an ADOM, and devices for another customer into another
ADOM.

FortiAnalyzer, FortiCache, FortiClient, FortiDDos, FortiMail, FortiManager, FortiSandbox, FortiWeb, Chassis, and
FortiCarrier devices are automatically placed in their own ADOMs.

Each administrator profile can be customized to provide read-only, read/write, or restrict access to various ADOM
settings. When creating new administrator accounts, you can restrict which ADOMs the administrator can access, for
enhanced control of your administrator users. For more information on ADOM configuration and settings, see
Administrative Domains on page 144.

FortiClient EMS devices

You can add FortiClient EMS servers to FortiAnalyzer. Registered FortiClient EMS servers are added to the default
FortiClient ADOM. You must enable ADOMs to work with FortiClient EMS servers in FortiAnalyzer. When you select the
FortiClient ADOM and go to the Device Manager pane, the FortiClient EMS servers are displayed. See also FortiClient
support and ADOMs on page 145.

Unregistered devices

In FortiAnalyzer 5.2.0 and later, the config system global set unregister-pop-up command isdisabled
by default. When a device is configured to send logs to FortiAnalyzer, the unregistered device is displayed in the Device
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Manager > Devices Unregistered pane. You can then add devices to specific ADOMs or delete devices by using the
toolbar buttons or the right-click menu.

Using FortiManager to manage FortiAnalyzer devices

You can add FortiAnalyzer devices to FortiManager and manage them. When you add a FortiAnalyzer device to
FortiManager, FortiManager automatically enables FortiAnalyzer features. FortiAnalyzer and FortiManager must be
running the same OS version, at least 5.6 or later.

In the Device Manager pane, a message informs you the device is managed by FortiManager and all changes should
be performed on FortiManager to avoid conflict. The top right of this pane displays a lock icon. If ADOMs are enabled,
the System Settings > All ADOMs pane displays a lock icon beside the ADOM managed by FortiManager.

Logs are stored on the FortiAnalyzer device, not the FortiManager device. You configure log storage settings on the
FortiAnalyzer device; you cannot change log storage settings using FortiManager.

For more information, see Adding FortiAnalyzer devices in the the FortiManager Administration Guide.

Adding devices

You must add and register devices and VDOMs to FortiAnalyzer to enable the device or VDOM to send logs to
FortiAnalyzer. Registered devices are also known as devices that have been promoted to the DVM table.

You must configure devices to send logs to FortiAnalyzer. For example, after you add and
x register a FortiGate device with FortiAnalyzer, you must also configure the FortiGate device

to send logs to FortiAnalyzer. In the FortiGate GUI, go to Log & Report > Log Settings, and
enable Send Logs to FortiAnalyzer/FortiManager.

Ay
‘Q' If you are using high availability, you must specify the FortiGate HA group name when adding
- a FortiGate cluster.

Adding devices using the wizard

You can add devices and VDOMs to FortiAnalyzer using the Add Device wizard. When the wizard finishes, the device is
added to the FortiAnalyzer unit, registered, and is ready to start sending logs.
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To add devices using the wizard:

1.

If using ADOMSs, ensure that you are in the correct ADOM.

2. Goto Device Manager and click Add Device.

Add Device

Please input the following information to add a device.
IP Address

SN

Device Name
Device Model
Firmware Version

5.6

Description

T

3. Configure the following settings:

IP Address
SN

Device Name
Device Model

Firmware Version

Type the IP address for the device.

Type the serial number for the device.
Type a name for the device.

Select the model of the device.

Select the firmware version of the device.

Type a description of the device (optional).

The device is added to the ADOM and, if successful, is ready to begin sending logs to the FortiAnalyzer unit.

Description
4. Click Next.
Add Device
Name Wink
SN FGVMO000000000000
IP Address 333.33.2.333

Status

Device is added successfully

Creating device database
Retrieving high availability status.
Initializing configuration database
Updating group membership

Successfully add device

CEs ]

5. Click Finish to finish adding the device and close the wizard.
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Adding devices manually

You can configure supported devices to send logs to the FortiAnalyzer device. These devices are displayed in the root
ADOM as unregistered devices. You can quickly view unregistered devices by clicking Unregistered Devices in the
quick status bar. When you manually add an unregistered device to the FortiAnalyzer unit, the device is registered with
the FortiAnalyzer unit and can start receiving logs from the device.

When ADOMs are enabled, you can assign the device to an ADOM. When manually adding multiple devices at one
time, they are all added to the same ADOM.

When you delete a device or VDOM from the FortiAnalyzer unit, its raw log files are also deleted. SQL database logs are
not deleted.

To manually add devices:

1. Inthe root ADOM, go to Device Manager and click Unregistered Devices in the quick status bar. The content pane
displays the unregistered devices.

2. Select the unregistered device or devices, then click Add. The Add Device dialog box opens.

Add Device
Add the following device(s) to ADOM: branch
Device Name Assign New Device Name

FGT1KC0000000001 FGT1KC0000000001

e

3. If ADOMs are enabled, select the ADOM in the Add the following device(s) to ADOM list. If ADOMs are disabled,
select root.

4. Click OK to register the device or devices.
The device or devices are added and FortiAnalyzer can start receiving logs from the device or devices.

Managing devices
Use the tools and commands in the Device Manager pane to manage devices and VDOMs.

Using the quick status bar
10=- 3 A 1045, o

You can see the quick status bar at the top of the Device Manager pane. The quick status bar contains the following
tabs:

o Devices Total: Displays the registered devices.

« Devices Unregistered: Displays the unregistered devices.

o Devices Log Status Down: Displays the registered devices with a log status of down.

« Storage Used: Displays the Log View > Storage Statistics page.
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The Devices Total, Devices Unregistered, and the Devices Log Status Down tabs include the following default

columns:

Column Description

Device Name Displays the name of the device.

IP Address Displays the IP address for the device.

Platform Displays the platform for the device.

Logs Identifies whether the device is successfully sending logs to the FortiAnalyzer
unit. A green circle indicates that logs are being sent. A red circle indicates that
logs are not being sent.

A lock icon displays when a secure tunnel is being used to transfer logs from the
device to the FortiAnalyzer unit.

Average Log Rate Displays the average rate at which the device is sending logs to the FortiAnalyzer

(Logs/Sec) unit in log rate per second. Click the number to display a graph of historical
average log rates.

Device Storage Displays how much of the allotted disk space has been consumed by logs.

Description Displays a description of the device (not displayed in Devices Unregistered tab).

Using the toolbar

The following buttons and menus are available for selection on the toolbar:

Button Description

Add Device Opens the Add Device Wizard to add a device to the FortiAnalyzer unit. The
device is added, but not registered with the FortiAnalyzer unit. Unregistered
devices are displayed in the Unregistered Devices tree menu.

Edit Edits the selected device.

Delete Deletes the selected devices or VDOMs from the FortiAnalyzer unit.

When you delete a device, its raw log files are also deleted. SQL database logs
are not deleted.

Column Settings Click to select which columns to display or select Reset to Default to display the
default columns.

More Displays more menu items including Import Device List and Export Device List.

Search Type the name of a device. The content pane displays the results. Clear the
search box to display all devices in the content pane.

Editing device information
Use the Edit Device page to edit information about a device. The information and options available on the Edit Device

page depend on the device type, firmware version, and which features are enabled.
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To edit information for a device or model device:

1. Goto Device Manager and click the Devices Total tab in the quick status bar.
2. Inthe content pane, select the device or model device and click Edit, or right-click on the device and select Edit.

The Edit Device pane displays.

Edit Device
Name

Description

IP Address

Serial Number
Firmware Version
Admin User
Password

HA Cluster

Add Existing Device
Add Other Device

HA Cluster List

Device Location v

Geographic Coordinate

Company/QOrganization
Country
Province/State

City

Contact

FG149

10.10.10.10
FGVMO0O000000000 (FortiGate-VM&64)
FortiGate 5.6, build1534

admin

[ITTTTY

#  Device Name
1 FG149 (FGYM0000000000)

49.25929408629 (Latitude) | -123.0115892711

Show Map
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3. Edit the device settings as required.

Name
Description

IP Address

Serial Number
Firmware Version
Admin User
Password

HA Cluster

Geographic Coordinates

Company/Organization

Country
Province/State
City

Contact

The name of the device.

Descriptive information about the device.
Enter the IP address of the device.

The serial number of the device.

The firmware version.

Enter the administrator user name.

Enter the administrator user password.

Select to identify the device as part of an HA cluster, and to identify the other
device in the cluster by selecting them from the drop-down list, or by inputting
their serial numbers.

Identifies the latitude and longitude of the device location to support the
interactive maps.

Click Show Map to open a map showing the location of the device based on

the coordinates. Click and drag the map marker to adjust the device's location.

Optionally, enter the company or organization information.
Optionally, enter the country where the device is located.
Optionally, enter the province or state.

Optionally, enter the city.

Optionally, enter the contact information.

4. After making the appropriate changes click OK.

Displaying historical average log rates

You can display a graph of the historical, average log rates for each device.

To display historical average logs rates:

1. If using ADOMs, ensure that you are in the correct ADOM.

2. Goto Device Manager and click the Devices Total tab in the quick status bar.
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3. Inthe Average Log Rate (Logs/Sec) column, click the number to display the graph.

Log Rate History (CorpFW, Last 24 Hours)
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4. Hover the cursor over the graph to display more details.

Connecting to a registered device GUI
You can connect to the GUI of a registered device from Device Manager.

To connect to a registered device GUI:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Device Manager and click the Devices Total tab in the quick status bar.
Right-click the device that you want to access, and select Connect to Device.
If necessary, change the port number and click OK.

AoODbdD =

You will be directed to the Login page of the device GUI.
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The Fabric View module enables you to create fabric connectors.
This section contains the following topics:

o |ITSM on page 37

Fabric Connectors

You can use FortiAnalyzer to create the following types of fabric connectors:

e ITSM

ITSM

You can use the Fabric Connectors tab to create the following types of ITSM connectors:

« ServiceNow
« Webhook, a generic connector

Creating or editing ITSM connectors
You can create ITSM connectors for ServiceNow and Webhook.

To create or edit ITSM connectors:

1. Goto Fabric View > Fabric Connectors.

2. To create an ITSM connector, click Create New. In the Create New Fabric Connector wizard, select ServiceNow
or Webhook, and click Next.
To edit an ITSM connector, click the ITSM connector. The connector options are displayed.

3. Configure the following options, and then click OK:

Name Type a name for the fabric connector.

Description (Optional) Type a description for the fabric connector.

Protocol Select HTTPS.

Port Specify the port FortiAnalyzer uses to communicate with the external
platform.

Method Select POST.

Title Type a title for the fabric connector.
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URL

Enable HTTP Authentication

Status

FortiAnalyzer 6.0.3 Administration Guide
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Type the URL of the external platform.

Using ServiceNow as an example, copy and paste the URL from ServiceNow
API URL in the Connection to ServiceNow API section in ServiceNow >
FortiAnalyzer System Properties.

Set HTTP authentication to ON or OFF.

Using ServiceNow as an example, enter the username and password from the
Connection to ServiceNow AP section in ServiceNow > FortiAnalyzer
System Properties.

Toggle ON to enable the fabric connector. Toggle OFF to disable the fabric
connector.
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FortiAnalyzer can recognize a Security Fabric group of devices and display all units in the group on the Device Manager
pane. See Adding a Security Fabric group on page 39. FortiAnalyzer supports the Security Fabric by storing and
analyzing the logs from the units in a Security Fabric group as if the logs are from a single device. You can also view the
logging topology of all units in the Security Fabric group for additional visibility. See Displaying Security Fabric topology
on page 40.

FortiAnalyzer provides dynamic data and metadata exchange with the Security Fabric and uses the data in FortiView
and Reports for additional visibility. A default report template lets you monitor new users, devices, applications,
vulnerabilities, threats and so on from the Security Fabric.

A set of dashboard widgets lets you review audit scores for a FortiGate Security Fabric group with recommended best
practices and historical audit scores and trends.

If FortiClient is installed on endpoints for endpoint control with FortiGate, you can use the endpoint telemetry data
collected by the Security Fabric agent to display user profile photos in reports and FortiView.

Adding a Security Fabric group

Before you can add a Security Fabric group to FortiAnalyzer, you need to create the Security Fabric group in FortiGate.
For more information, see the FortiOS Handbook.

Fortinet recommends using a dedicated Super_User administrator account on the FortiGate for FortiAnalyzer access.
This ensures that associated log messages are identified as originating from FortiAnalyzer activity. This dedicated
Super_User administrator account only needs Read Only access to System Configuration; all other access can be set
to None.

To add a Security Fabric group:

1. Goto Device Manager > Unregistered Devices.
2. Select all the devices corresponding to the Security Fabric group created in FortiGate.

3. Authenticate the Security Fabric group by clicking the Warning icon (yellow triangle) beside the corresponding
FortiGate root.

Authentication

Please enter admin user name and password for the root device of security fabric "csf80cm”.

Admin User ||

Password

4. Enter the Authentication Credentials. The authentication credentials are the ones you specified in FortiGate. Once
the FortiGate root has been authenticated, the Warning icon will disappear.

5. After authentication, it takes a few minutes for FortiAnalyzer to automatically populate the devices under the
FortiGate root which creates the Security Fabric group.
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Displaying Security Fabric topology
For Security Fabric devices, you can display the Security Fabric topology.

To display the Security Fabric topology:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Device Manager and click the Devices Total tab in the quick status bar.
3. Right-click a Security Fabric device and select Fabric Topology.

A pop-up window displays the Security Fabric topology for that device.

If you selected Fabric Topology by right-clicking a device within the Security Fabric group, the device is highlighted
in the topology. If you selected Fabric Topology by right-clicking the name of the Security Fabric group, no device is
highlighted in the topology.

Topology for FGP2000000000000

HA Active-Passive

FGT200DPOE-L1-root B3 FGBLE-HAL2 — 5%} FG280DPOEL3

-
2mh FGB1E-HA-LS

FGVYM-076-12
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You can view log information by device or by log group.
When rebuilding the SQL database, Log View is not available until the rebuild is complete.
Click the Show Progress link in the message to view the status of the SQL rebuild.

When ADOMs are enabled, each ADOM has its own information displayed in Log View.

Log View can display the real-time log or historical (Analytics) logs.
Log Browse can display logs from both the current, active log file and any compressed log files.

For more information, see Archive logs and Analytics logs on page 27.

Types of logs collected for each device

FortiAnalyzer can collect logs from managed FortiGate, FortiCarrier, FortiCache, FortiMail, FortiManager,
FortiSandbox, FortiWeb, FortiClient, and syslog servers. Following is a description of the types of logs FortiAnalyzer
collects from each type of device:

Device Type Log Type
FortiAnalyzer Event
FortiAuthenticator  Event

FortiGate Traffic

Security: Antivirus, Intrusion Prevention, Application Control, Web Filter, DNS, Data Leak
Prevention, Email Filter, Web Application Firewall, Vulnerability Scan, VolP, FortiClient

Event: Endpoint, HA, Compliance, System, Router, VPN, User, WAN Opt. & Cache, WiFi

FortiCarrier Traffic, Event, GTP

FortiCache Traffic, Event, Antivirus, Web Filter
FortiClient Traffic, Event, Vulnerability Scan
FortiDDoS Event, Intrusion Prevention
FortiMail History, Event, Antivirus, Email Filter
FortiManager Event

FortiSandbox Malware, Network Alerts

FortiWeb Event, Intrusion Prevention, Traffic
Syslog Generic
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Traffic logs

Traffic logs record the traffic flowing through your FortiGate unit. Since traffic needs firewall policies to properly flow
through FortiGate, this type of logging is also called firewall policy logging. Firewall policies control all traffic attempting
to pass through the FortiGate unit, between FortiGate interfaces, zones, and VLAN sub-interfaces.

Security logs

Security logs (FortiGate) record all antivirus, web filtering, application control, intrusion prevention, email filtering, data
leak prevention, vulnerability scan, and VolP activity on your managed devices.

DNS logs

DNS logs (FortiGate) record the DNS activity on your managed devices.

Event logs

Event logs record administration management and Fortinet device system activity, such as when a configuration
changes, or admin login or HA events occur. Event logs are important because they record Fortinet device system
activity which provides valuable information about how your Fortinet unit is performing. FortiGate event logs includes
System, Router, VPN, User, and WiFi menu objects to provide you with more granularity when viewing and searching

log data.
NP The logs displayed on your FortiAnalyzer depends on the device type logging to it and the
‘Q' enabled features. FortiGate, FortiCarrier, FortiCache, FortiMail, FortiManager, FortiWeb,
- FortiSandbox, FortiClient, and Syslog logging is supported. ADOMs must be enabled to

support non-FortiGate logging.

For more information on logging see the Logging and Reporting for FortiOS Handbook in the Fortinet Document
Library.

Log messages

You can view log information by device or by log group.

Viewing the log message list of a specific log type
You can find FortiMail and FortiWeb logs in their default ADOMs.

To view the log message list:

1. If using ADOMSs, ensure that you are in the correct ADOM.

2. Goto Log View, and select a log type from the tree menu.
The corresponding log messages list is displayed.
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Viewing message details

To view message details:

1. Double-click a message in the message list.
The details pane is displayed to the right of the message list, with the fields categorized in tree view.

‘ Add Filter

[0 © A AllDevices~  Last1Hour~ 01:35:47 To 02:35:46

# ¥ Date/Time Device ID

1 02:35:29
2 02:35:29
3 02:35:29
4 02:35:29
5

3 02:35:29
7 02:35:29
8 02:35:29
9 02:35:29
10  02:35:29
11 02:35:29
12 02:35:29
13 02:35:29
14 02:35:29
15 02:35:29
16 02:35:29
17 02:35:

FGT1KC0000000...
FGT1KC0000000...
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FGT1KCO0000000..

FGT1KC0000000..
FGT1KC0000000...

FGT1KCO000000..

FGT1KCO0000000...

FGT1KC0000000..

FGT1KC0000000...
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FGT1KCO0000000..

FGT1KC0000000...
FGT1KC0000000..
FGT1KC0000000...
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£4172.16.175.133
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££110.2.60.65
172.184.112
£5110.2.60.65
1168.2.115

Destination IP
172.18.4.108
#5157.55.56.170
172.18.4.108
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172.18.4.108
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1+1208.91.112.53
172.18.4.108
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You can display the log details pane below the message list by clicking the Botftom icon in the log details pane.
When the log details pane is displayed below the message list, you can move it to the right of the log message list
by clicking the Right icon. This is sometimes referred to as docking the pane to the bottom or right of the screen.

The log details pane provides shortcuts for adding filters and for showing or hiding a column. Right-click a log field to
select an option.

_ ox
= -Security
L Level information
+ -General
— -Source
-Agent Debian
Device ID FG100D3G13805309
Device Name FG100D3G13805309
Source 172.28.3.15
.Source IP 172.28.3.15

ource |nterface v o
@, search "Source Interface = FMG-GUI-Team"
% T @, search "Source Interface != FMG-GUI-Team"

i 1 =+ add "Source Interface” to column settings
| Firewall Action analytics
. Policy ID 20
+ -Application
— -Type
: -Sub Type virus
- L Type utm
+-Others
Ay

If the log message contains UTM logs, you can click the UTM log icon in the log details pane
to open the UTM log view window.
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Customizing displayed columns
The columns displayed in the log message list can be customized and reordered as needed.

To customize what columns to display:

1. Inthe toolbar of the log message list view, click Column Settings and select a column to hide or display.
The available columns vary depending on the device and log type.

2. To add other columns, click More Columns. In the Column Settings dialog box, select the columns to show or

hide.
3. Toreset to the default columns, click Reset to Default.
4. Click OK.
\‘ ! 'l
? You can also add or remove a log field column in the log details pane, by right-clicking a
|| log field and selecting Add [log field name] or Remove [log field name].

To change the order of the displayed columns:

Place the cursor in the column title and move a column by drag and drop.

Filtering messages

You can apply filters to the message list. Filters are not case-sensitive by default. If available, select Tools > Case
Sensitive Search to create case-sensitive filters.
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Filtering messages using filters in the toolbar

1. Go to the view you want.

Regular search Click Add Filter and select a filter from the dropdown list, then type a value.
Only displayed columns are available in the dropdown list. You can use search
operators in regular search.

Switching between regular At the right end of the Add Filter box, click the Switch to Advanced Search
search and advanced search icon a or click the Switch to Regular Search icon .

Advanced search In Advanced Search mode, enter the search criteria (log field names and
values).

Search operators and syntax If available, click (] at the right end of the Add Filter box to view search
operators and syntax. See also Filter search operators and syntax on page 46.

CLI string “freestyle” search  Searches the string within the indexed fields configured using the CLI
command: config ts-index-field.

For example, if the indexed fields have been configured using these CLI
commands:
config system sqgl
config ts-index-field
edit "FGT-traffic"
set value "app,dstip,proto,service,srcip,user,utmaction”
next
end
end
Then if you type “Skype” in the Add Filter box, FortiAnalyzer searches for
“Skype” within these indexed fields:
app,dstip, proto, service, srcip,user and utmaction

You can combine freestyle search with other search methods, for example:
Skype user=David.

2. Inthe toolbar, make other selections such as devices, time period, which columns to display, etc.

Filtering messages using the right-click menu

In a log message list, right-click an entry and select a filter criterion. The search criterion with a @ icon returns entries
matching the filter values, while the search criterion with a & icon returns entries that do not match the filter values.

Depending on the column in which your cursor is placed when you right-click, Log View uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

NP To see log field name of a filter/column, right-click the column of a log entry and select a
‘Q' context-sensitive filter. The Add Filter box shows log field name.
- Context-sensitive filters are available for each log field in the log details pane. See Viewing

message details on page 43.
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Filtering messages using smart action filters

For Log View windows that have an Action column, the Action column displays smart information according to policy
(log field action) and utmaction (UTM profile action).

The Action column displays a green checkmark Accept icon when both policy and UTM profile allow the traffic to pass
through, that is, both the log field action and UTM profile action specify allow to this traffic.

The Action column displays a red X Deny icon and the reason when either the log field action or UTM profile action
deny the traffic.

If the traffic is denied due to policy, the deny reason is based on the policy log field action.

If the traffic is denied due to UTM profile, the deny reason is based on the FortiView threattype from craction.
craction shows which type of threat triggered the UTM action. The threattype, craction, and crscore fields
are configured in FortiGate in Log & Report. For more information, see the FortiOS - Log Message Reference in the
Fortinet Document Library.

Afilter applied to the Action column is always a smart action filter.

The smart action filter uses the FortiGate UTM profile to determine what the Action column
displays. If the FortiGate UTM profile has set an action to allow, then the Action column will
O ! ’, display that line with a green Accept icon, even if the craction field defines that traffic as a
q threat. The green Accept icon does not display any explanation.
- In the scenario where the craction field defines the traffic as a threat but the FortiGate
UTM profile has set an action to allow, that line in the Log View Action column displays a
green Accept icon. The green Accept icon does not display any explanation.

Filter search operators and syntax

Operators or symbols Syntax

And Find log entries containing all the search terms. Connect the terms with a space
character, or “and”. Examples:
1. user=henry group=sales
2. user=henry and group=sales

Or Find log entries containing any of the search terms. Separate the terms with “or”
oracomma “,”. Examples:
1. user=henry or srcip=10.1.0.15
2. user=henry, linda

Not Find log entries that do NOT contain the search terms. Add “-” before the field
name. Example:

-user=henry

> < Find log entries greater than or less than a value, or within a range. This operator
only applies to integer fields. Example:

policyid>1 and policyid<10

IP subnet/range search Find log entries within a certain IP subnet or range. Examples:
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Operators or symbols Syntax

1. srcip=192.168.1.0/24
2. srcip=10.1.0.1-10.1.0.254

Wildcard search You can use wildcard searches for all field types. Examples:
1. srcip=192.168.1.*
2. policyid=1*
3. user=*

Filtering FortiClient log messages in FortiGate traffic logs

For FortiClient endpoints registered to FortiGate devices, you can filter log messages in FortiGate traffic log files that
are triggered by FortiClient.

To Filter FortiClient log messages:

Go to Log View > Traffic.
In the Add Filterbox, type fct devid=*. Alist of FortiGate traffic logs triggered by FortiClient is displayed.
In the message log list, select a FortiGate traffic log to view the details in the bottom pane.

Click the FortiClient tab, and double-click a FortiClient traffic log to see details.
The FortiClient tab is available only when the FortiGate traffic logs reference FortiClient traffic logs.

A oODbd =

Viewing historical and real-time logs

By default, Log View displays historical logs. Custom View and Chart Builder are only available in historical log view.
To view real-time logs, in the log message list view toolbar, click Tools > Real-time Log.

To switch back to historical log view, click Tools > Historical Log.

Viewing raw and formatted logs

By default, Log View displays formatted logs. The log view you select affects available view options. You cannot
customize columns when viewing raw logs.

To view raw logs, in the log message list view toolbar, click Tools > Display Raw.
To switch back to formatted log view, click Tools > Formatted Log.

For more information about FortiGate raw logs, see the FortiGate Log Message Reference in the Fortinet Document
Library. For more information about raw logs of other devices, see the Log Message Reference for the platform type.

Custom views

Use Custom View to save the filter setting, device selection, and the time period you have specified.
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To create a new custom view:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type.
3. Inthe content pane, customize the log view as needed by adding filters, specifying devices, and/or specifying a

time period.
4. In the toolbar, click Custom View.

Save as New Custom View

5. Inthe Namefield, type a name for the new custom view.
6. Click OK. The custom view is now displayed under Log View > Custom View.

To edit a custom view:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Gotothe Log View > Custom View.

3. Inthe toolbar, edit the filter settings, and click GO.

4. Inthe toolbar, click Custom View.

5

Click Save to save the changes to the existing custom view or click Save as to save the changes to a new custom
view.

Click OK.

o

To view the traffic log of a custom view:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Gotothe Log View > Custom View.
3. Right-click the name of a custom view and select View Traffic.

Downloading log messages

You can download historical log messages to the management computer as a text or CSV file. You cannot download
real-time log messages.

To download log messages:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Log View, and select a log type.

In the toolbar, click Tools > Download.

In the Download Logs dialog box, configure download options:
« Inthe Log file format dropdown list, select Text or CSV.

AoODbd =

o To compress the downloaded file, select Compress with gzip.
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» To download only the current log message page, select Current Page. To download all the pages in the log
message list, select All Pages.

5. Click Download.

Creating charts

\ L}
‘?' You can also create charts in Reports > Report Definitions > Chart Library. See Chart library
- on page 110

Log View includes a Chart Builderfor you to build custom charts for each type of log messages.

To create charts with Chart Builder:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type.
3. Inthe toolbar, click Tools > Chart Builder.
4. Inthe Chart Builder dialog box, configure the chart and click Save.
Name Type a name for the chart.
Columns Select which columns of data to include in the chart based on the log
messages that are displayed on the Log View page.
Group By Select how to group data in the chart.
Order By Select how to order data in the chart.
Sort Select a sort order for data in the chart.
Show Limit Show Limit
Device Displays the device(s) selected on the Log View page.
Time Frame Displays the time frame selected on the Log View page.
Query Displays the query being built.
Preview Displays a preview of the chart.

Log groups

You can group devices into log groups. You can view FortiView summaries, display logs, generate reports, or create
handlers for a log group. Log groups are virtual so they do not have SQL databases or occupy additional disk space.

Ay
‘?' In FortiAnalyzer 5.0.6 and earlier, you can treat log groups as a single device that has its own
- SQL database. You cannot do this in FortiAnalyzer 5.2 and later.
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When you add a device with VDOMs to a log group, all VDOMSs are automatically added.

To create a new log group:

Go to Log View > Log Group.

In the content pane toolbar, click Create New.

In the Create New Log Group dialog box, type a log group name and add devices to the log group.
Click OK.

AoODbd-=

Log browse

When a log file reaches its maximum size or a scheduled time, FortiAnalyzer rolls the active log file by renaming the file.
The file name is in the form of x10g.N. 1og, where x is a letter indicating the log type, and N is a unique number
corresponding to the time the first log entry was received. For information about setting the maximum file size and log
rolling options, see Device logs on page 183.

Log Browse displays log files stored for both devices and the FortiAnalyzer itself, and you can logs in the compressed
phase of the log workflow.

A\,

To view log files:

In Collector mode, if you want to view the latest log messages, select the latest log file to
display its log messages.

1. Goto Log View > Log Browse

2. Select alog file, and click Display to open the log file and display the log messages in formatted view.
You can perform all the same actions as with the log message list. See Viewing message details on page 43.

Add Filter ()] B All Devices ~ (D Last 5 Minutes ~ M Display T Delete & Download ] Import
S F 3 A Device Name Serial Number VDOM Type File Name From To Size(bytes)
o1 FG100D3G00000000 FG100D3G00000000  root Event elog.log 2018-05-30 02:0... 2018-05-3013:0.. 134,358
o2 FG100D3G00000000 FG100D3G00000000 root Traffic tlog.log 2018-05-3002:0... 2018-05-3013:1... 3,924,969
(8] & FG1K2D3100000000 FG1K2D3100000000 root Event eloglog 2018-05-3002:0... 2018-05-3013:0.. 52,663

o 4 FG1K2D3100000000 FG1K2D3100000000 root Traffic tlog.log 2018-05-30 13:0... 2018-05-3013:1.. 71,916,545
o s FG3K2D3Z00000000 FG3K2D3Z00000000  root Event eloglog 2018-05-3002:0... 2018-05-3013:0.. 8,696

0 s FG3K2D3Z00000000 FG3K2D3Z00000000 root Event eloglog 2018-05-3002:0... 2018-05-3013:0... 346,536
a7 FG3K2D3Z00000000 FG3K2D3Z00000000  root Traffic tlog.log 2018-05-30 13:0... 2018-05-3013:1.. 782,844

o s FG900D3000000000 FG200D3900000000 root VolP plog.log 2018-05-3002:0... 2018-05-3013:0... 9,869
a9 FG$00D3900000000 FG200D3900000000 root Event eloglog 2018-05-3002:0... 2018-05-3013:0... 76,955

O 10 FG900D3000000000 FG200D3900000000 root Traffic tlog.log 2018-05-3002:0... 2018-05-3013:0.. 3,230,023
o 11 FG$00D3900000000 FG200D3900000000 root Event eloglog 2018-05-3002:0... 2018-05-3013:0.. 2,638

Importing a log file

Imported log files can be useful when restoring data or loading log data for temporary use. For example, if you have
older log files from a device, you can import these logs to the FortiAnalyzer unit so that you can generate reports
containing older data.
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To insert imported logs into the SQL database, the config system sgl start-time and rebuild-event-
start—-time must be older than the date of the logs that are imported and the storage policy for analytic data (the
Keep Logs for Analytics field) must also extend back far enough.

To set the SQL start time and rebuild event start time using CLI commands:

config system sqgl

set start-time <start-time-and-date>

set rebuild-event-start-time <start-time-and-date>
end

Where <start-time-and-date>isinthe format hh:mm yyyy/mm/dd.

To import a log file:

If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View > Log Browse and click Import in the toolbar.

3. Inthe Device dropdown list, select the device the imported log file belongs to or select [Take From Imported File]
to read the device ID from the log file.

If you select [Take From Imported File], the log file must contain a device id field in its log messages.

4. Drag and drop the log file onto the dialog box, or click Add Files and locate the file to be imported on your local
computer.

5. Click OK. A message appears, stating that the upload is beginning, but will be canceled if you leave the page.

6. Click OK. The upload time varies depending on the size of the file and the speed of the connection.
After the log file is successfully uploaded, FortiAnalyzer inspects the file:
o Ifthedevice idfieldinthe uploaded log file does not match the device, the import fails. Click Return to try
again.
« If you selected [Take From Imported File] and the FortiAnalyzer unit’s device list does not currently contain

that device, a message appears after the upload. Click OK to import the log file and automatically add the
device to the device list.

Downloading a log file

You can download a log file to save it as a backup or to use outside the FortiAnalyzer unit. The download consists of
either the entire log file, or a partial log file, as selected by your current log view filter settings and, if downloading a raw
file, the time span specified.

To download a log file:

1. Goto Log View > Log Browse and select the log file that you want to download.
2. Inthe toolbar, click Download.
3. Inthe Download Log File(s) dialog box, configure download options:
« Inthe Log file format dropdown list, select Native, Text, or CSV.
« If you want to compress the downloaded file, select Compress with gzip.
4. Click Download.
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Deleting log files

To delete log files:

1. Goto Log View > Log Browse.
2. Select one or more files and click Delete.
3. Click OK to confirm.

Log and file storage

Logs and files are stored on the FortiAnalyzer hard disks. Logs are also temporarily store in the SQL database.

When ADOMs are enabled, settings can be specified for each ADOM that apply only to the devices in it. When ADOMs
are disabled, the settings apply to all managed devices.

Data policy and disk utilization settings for devices are collectively called log storage settings. Global log and file storage
settings apply to all logs and files, regardless of log storage settings (see File Management on page 187). Both the
global and log storage settings are always active.

Disk space allocation

On the FortiAnalyzer, the system reserves 5% to 20% of the disk space for system usage and unexpected quota
overflow. The remaining 80% to 95% of the disk space is available for allocation to devices.

Reports are stored in the reserved space.

Total Available Disk Size Reserved Disk Quota
Small Disk (up to 500GB) The system reserves either 20% or 50GB of disk space, whichever is smaller.
Medium Disk (up to 1TB) The system reserves either 15% or 100GB of disk space, whichever is smaller.
Large Disk (up to 5TB) The system reserves either 10% or 200GB of disk space, whichever is smaller.
Very Large Disk (5TB and The system reserves either 5% or 300GB of disk space, whichever is smaller.
higher)
s‘ ! ', The RAID level you select determines the disk size and the reserved disk quota level. For
9 example, a FortiAnalyzer 1000C with four 1TB disks configured in RAID 10 is considered a
- large disk, so 10%, or 100GB, of disk space is reserved.

Log and file workflow

When devices send logs to a FortiAnalyzer unit, the logs enter the following workflow automatically:

1. Compressed logs are received and saved in a log file on the FortiAnalyzer disks.
When a log file reaches a specified size, FortiAnalyzer rolls it over and archives it, and creates a new log file to
receive incoming logs. You can specify the size at which the log file rolls over. See Device logs on page 183.
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2. Logs are indexed in the SQL database to support analysis.
You can specify how long to keep logs indexed using a data policy. See Log storage information on page 55.

3. Logs are purged from the SQL database, but remain compressed in a log file on the FortiAnalyzer disks.

4. Logs are deleted from the FortiAnalyzer disks.
You can specify how long to keep logs using a data policy. See Log storage information on page 55.
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In the indexed phase, logs are indexed in the SQL database for a specified length of time so they can be used for
analysis. Indexed, or Analytics, logs are considered online, and details about them can be used viewed in the FortiView,
NOC - SOC, Log View, and Event Manager modules. You can also generate reports about the logs in the Reports
pane.

In the compressed phase, logs are compressed and archived in FortiAnalyzer disks for a specified length of time for the
purpose of retention. Compressed, or Archived, logs are considered offline, and their details cannot be immediately
viewed or used to generate reports.

The following table summarizes the differences between indexed and compressed log phases:

Log Phase Location Immediate Analytic Support

Indexed Compressed in log file and Yes. Logs are available for analytic use in FortiView,
indexed in SQL database NOC - SOC, Event Manager, and Reports.

Compressed Compressed in log file No.
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Automatic deletion

Logs and files are automatically deleted from the FortiAnalyzer unit according to the following settings:

« Global automatic file deletion
File management settings specify when to delete the oldest Archive logs, quarantined files, reports, and archived
files from disks, regardless of the log storage settings. For more information, see File Management on page 187.
« Data policy
Data policies specify how long to store Analytics and Archive logs for each device. When the specified length of
time expires, Archive logs for the device are automatically deleted from the FortiAnalyzer device's disks.
« Disk utilization
Disk utilization settings delete the oldest Archive logs for each device when the allotted disk space is filled. The
allotted disk space is defined by the log storage settings. Alerts warn you when the disk space usage reaches a
configured percentage.

All deletion policies are active on the FortiAnalyzer unit at all times, and you should carefully configure each policy. For
example, if the disk fullness policy for a device hits its threshold before the global automatic file deletion policy for the
FortiAnalyzer unit, Archive logs for the affected device are automatically deleted. Conversely, if the global automatic file
deletion policy hits its threshold first, the oldest Archive logs on the FortiAnalyzer unit are automatically deleted
regardless of the log storage settings associated with the device.

The following table summarizes the automatic deletion polices:

Policy Scope Trigger

Global automatic file Al logs, files, and When the specified length of time expires, old files are automatically

deletion reports on the deleted. This policy applies to all files in the system regardless of the
system data policy settings associated with devices.

Data policy Logs for the device When the specified length of retention time expires, old Archive logs

with which the data for the device are deleted. This policy affects only Archive logs for the
policy is associated device with which the data policy is associated.

Disk utilization Logs for the device When the specified threshold is reached for the allotted amount of
with which the log disk space for the device, the oldest Archive logs are deleted for the
storage settings are device. This policy affects only Archive logs for the device with which
associated the log storage settings are associated.

Logs for deleted devices

When you delete one or more devices from FortiAnalyzer, the raw log files and archive packets are deleted, and the
action is recorded in the local event log. However, the logs that have been inserted into the SQL database are not
deleted from the SQL database. As a result, logs for the deleted devices might display in the Log View and FortiView
panes, and any reports based on the logs might include results.

The following are ways you can remove logs from the SQL database for deleted devices.

« Rebuild the SQL database for the ADOM to which deleted devices belonged or rebuild the entire SQL database.

« Configure the log storage policy. When the deleted device logs are older than the Keep Logs for Analytics setting,
they are deleted. Also, when analytic logs exceed their disk quota, the SQL database is trimmed starting with the
oldest database tables. For more information, see Configuring log storage policy on page 56.
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« Configure global automatic file deletion settings in System Settings > Advanced > File Management. When the
deleted device logs are older than the configured setting, they are deleted. For more information, see File
Management on page 187.

Ay
‘9' File Management configures global settings that override other log storage settings and
- apply to all ADOMs.

Log storage information

To view log storage information and to configure log storage policies, go to System Settings > Storage Info.

If ADOMSs are enabled, you can view and configure the data policies and disk usage for each ADOM.

The log storage policy affects only the logs and SQL database of the devices associated with the log storage policy.
Reports are not affected. See Disk space allocation on page 52.

[# Edit & Refresh Q
e Analytics (Actual/Config Days)  Archive (Actual/Config Days)  Max Storage  Analytics Usage (Used/Max)  Archive Usage (Used/Max)
wortiGates (2)

FortiCarrier 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
root 0/60 2/365 | 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
wOther Device Types (10)

FortiAnalyzer 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiAuthenticator ~ 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiCache 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiClient 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiDDoS 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiMail 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiManager 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiSandbox 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiWeb 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
Syslog 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)

The following information and options are available:

Edit
Refresh
Search

Name

Analytics
(Actual/Config Days)

Archive
(Actual/Config Days)

Max Storage

Analytics Usage
(Used/Max)

Archive Usage
(Used/Max)

Edit the selected ADOM's log storage policy.
Refresh the page.
Enter a search term to search the list.

The name of the ADOM.
ADOMs are listed in two groups: FortiGates and Other Device Types.

The age, in days, of the oldest Analytics logs (Actual Days), and the number of days
Analytics logs will be kept according to the data policy (Config Days).

The age, in days, of the oldest Archive logs (Actual Days) and the number of days
Archive logs will be kept according to the data policy (Config Days).

The maximum disk space allotted to the ADOM (for both Analytics and Archive logs).
See Disk space allocation on page 52 for more information.

How much disk space Analytics logs have used, and the maximum disk space allotted
for them.

How much disk space Archive logs have used and the maximum disk space allotted for
them.
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Storage information

To view log storage policy and statistics, go to System Settings > Storage Info.

The top part of Storage Info shows visualizations of disk space usage for Analytic and Archive logs where the policy
diagrams show an overview and the graphs show disk space usage details. The bottom part shows the log storage
policy.

Analytics Policy Analytics Details Show Up to Today ~ Max Line:[]

2270000

eIV N / \

86% = \/ \ /\ JK\/\/ V/\/N \\
\

|

Keep Logs for 15 Days

Actual Logs for 7 Days

— Actual

Archive Policy Archive Details Show All Configured Days ~ Max Line:[IZ]
£40000 2| Max Quota - 629146MB
0000 2
20000
30000
g 580000 WA IWAMSS ISV A A
540000
- \
s
500000 Vi
Keep Logs for 60 Days ] i : ! : i . .
Actual Logs for 35 Days 5 1o 15 2 £ @ 3 &

— Actual — Max - - Trend

The policy diagram shows the percentage of the disk space quota that is used. Hover your cursor over the diagram to
view the used, free, and total allotted disk space. The configured length of time that logs are stored is also shown.

The graphs show the amount disk space used over time. Click Max Line to show a line on the graph for the total space
allotted. Hover over a spot in the graph to view the used and available disk space at that specific date and time. Click
the graph to view a breakdown of the disk space usage by device.

Analytics Storage Statistics - Last 15 Days

Device Name Analytics Usage Average Log Rate (logs/sec) Peak Log Rate (logs/sec)
FGT37D0000000000 743.1GB 38.35% 1087.14 1615.27
FGB0O0CO000000000 221.4 MB 0.01% 424 35.58

Weixixixi_WiFi 3.1GB 0.16% 4.48 32,80
FG3K2D0000000000 513 GB 2.65% 77.29 78174
FG1K2DOD00000000 716.4 GB 36.97% 1048.14 2376.82
FG100D0000000000 4238GB 2187% 619.99 1726.02

When the used quota approaches 100 percent, a warning message displays when accessing the Storage Statistics
pane.

Warning

Analytic is using 89% of allocated disk space.
Archive is using 88% of allocated disk space.

Please click "Configure Now" button to increase ADOM quota.

[ corue o

Click Configure Now to open the Edit Log Storage Policy dialog box where you can adjust log storage policies to
prevent running out of allocated space (see Configuring log storage policy on page 56), or click Remind Me Later to
resolve the issue another time.

Configuring log storage policy

The log storage policy affects the logs and SQL database of the device associated with the log storage policy.
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If you change log storage settings, the new date ranges affect Analytics and Archive logs

A currently in the FortiAnalyzer device. Depending on the date change, Analytics logs might be
purged from the database, Archive logs might be added back to the database, and Archive
logs outside the date range might be deleted.

To configure log storage settings:

1. Goto System Settings > Storage Info.

2. Double-click on an ADOM, right-click on an ADOM and then select Edit from the menu, or select the ADOM then
click Edit in the toolbar. Scroll to the log storage policy sections at the bottom of the Edit Log Storage Policy pane.
Edit Log Storage Policy - ADOM : root
Data Palicy
Keep Logs for Analytics 365 = Days
Keep Logs for Archive 365 > Days

Disk Utilization
Maximum Allowed 50 > GB v Out of Available: 50.0 GB

Analytics : Archive 60% v 40% Modify
Alert and Delete When Usage Reaches 100%

*If analytic or archive log usages exceed the configured disk quota before the retention period expires, the oldest logs will be deleted.

e

3. Configure the following settings, then click OK.

Data Policy
Keep Logs for Specify how long to keep Analytics logs.
Analytics
Keep Logs for Specify how long to keep Archive logs.
Archive Make sure your setting meets your organization’s regulatory requirements.

Disk Utilization

Maximum Allowed Specify the amount of disk space allotted. See also Disk space allocation on

page 52.
Analytics : Specify the disk space ratio between Analytics and Archive logs. Analytics logs
Archive require more space than Archive logs. Click the Modify checkbox to change
the setting.
Alert and Delete Specify the percentage of allotted disk space usage that will trigger an alert
When Usage messages and start automatically deleting logs. The oldest Archive log files or
Reaches Analytics database tables are deleted first.
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Use Event Managerto generate, monitor, and manage alerts and events from logs. The live monitoring of security
events is a powerful and enabling feature for security operations. Incidents can be created from events to track and
respond to suspicious or malicious activities.

Event Manager displays all events generated by event handlers.

Event handlers

Event handlers determine what events to be generated from logs. Enable an event handler to start generating events.
To see which event handlers are enabled or disabled, see Enabling event handlers on page 65.

When ADOMs are enabled, each ADOM has its own event handlers and lists of events. Ensure you are in the correct
ADOM when working in Event Manager.

You can use predefined event handlers to generate events. There are predefined event handlers for FortiGate and
FortiCarrier devices.

You can create custom event handlers. An easy way to create a custom event handler is to clone a predefined event
handler and customize its settings. See Cloning event handlers on page 66.

Configure event handlers to generate events for all devices, a specific device, or for the local FortiAnalyzer unit. You can
create event handlers for FortiGate, FortiCarrier, FortiCache, FortiMail, FortiManager, FortiWeb, FortiSandbox
devices, and syslog servers. In 5.2.0 or later, Event Manager supports local FortiAnalyzer event logs.

To see event handlers, go to Event Manager > Event Monitor > Event Handler List.

Event handlers generate events only from Analytics logs and not Archive logs. For more information, see Archive logs
and Analytics logs on page 27.

In an Analyzer—Collector collaboration scenario, the Analyzer evaluates event handlers. For more information, see
Analyzer—Collector collaboration on page 26.

Predefined event handlers

FortiAnalyzer includes many predefined event handlers for FortiGate and FortiCarrier devices that you can use to
generate events. You can easily create a custom event handler by cloning a predefined event handler and customizing
its settings. See Cloning event handlers on page 66.

The following are a small sample of predefined event handlers. To see all predefined event handlers, go to Event
Manager > Event Monitor > Event Handler List and select Show Predefined.

Event Handler Description

Application Crashed Event Enabled by default
« Event Severity: Medium
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Event Handler Description

o Log Type: Event Log
o Log Subtype: System
o Group by: Log Description
« Log messages that match all conditions:
o Log Description Equal To Application crashed
o Level Greater Than or Equal To Waming
Default-High-Risk-App- Disabled by default
Detection Filter 1:
« Event Severity: Medium
o Log Type: Application Control
o Group by: Source Endpoint, Application Name

o Log messages that match all of the following conditions:

« Action Equal To Block
« Application Risk Equal To critical
Filter 2:
« Event Severity: High
« Log Type: Application Control
o Group by: Source Endpoint, Application Name

« Log messages that match all of the following conditions:

« Action Not Equal To Block
« Application Risk Equal To critical
Filter 3:
« Event Severity: Low
o Log Type: Application Control
o Group by: Source Endpoint, Application Name

« Log messages that match all of the following conditions:

« Action Equal To Block
« Application Risk Equal To high

Filter 4:
« Event Severity: Medium
o Log Type: Application Control
o Group by: Source Endpoint, Application Name

« Log messages that match all of the following conditions:

« Action Not Equal To Block
« Application Risk Equal To high

Default - Sandbox-Detection Disabled by default
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Event Handler Description

Filter 1:
« Event Severity: Critical
o Log Type: Anti