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Change Log

Date Change Description

2021-06-08 Initial release.

2022-01-12 Updated Fine-grained controls on page 192.
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What's new in FortiAuthenticator

What's new in FortiAuthenticator

This section provides a summary of the new features and enhancements in FortiAuthenticator:

» FortiAuthenticator 6.3.1 on page 10
« FortiAuthenticator 6.3.0 on page 11

Always review the FortiAuthenticator Release Notes prior to upgrading your device.

FortiAuthenticator 6.3.1

The following list contains new and expanded features added in FortiAuthenticator 6.3.1.

Self-Service Portal: FSSO support

FortiAuthenticator now allows you to set up an FSSO portal login page independent of the admin GUI login page using
the self-service portal.

Go to the Portal Services tab in Fortinet SSO Methods > SSO to specify self-service portals used to create an FSSO
session on successful end-user login. The FSSO session is removed when this end-user logs out. See Portal services
on page 182.

Once the end-user is successfully authenticated, and given that the original request to the self-service portal contains
the user continue url HTTP parameter with a valid URL, then the self-service portal redirects the end-user's
browser to the URL specified inuser continue url instead of the self-service portal's post-login menu page.

Customizable login and logout replacement messages are already available in Authentication > Portals
> Replacement Messages.

TACACS+: PAP support

TACACS+ on FortiAuthenticator now supports the PAP authentication type. See Adding clients on page 145.

Remote LDAP user synchronization rules support multiple certificate bindings

FortiAuthenticator now supports remote LDAP user synchronization rules where you can create or update user accounts
with multiple certificate bindings. All certificate bindings use the same Common Name but different CAs.

Certificate binding CA dropdown available when creating or editing a remote LDAP user synchronization rule in
Authentication > User Management > Remote User Sync Rules now allows selecting multiple CA certificates. See
Remote user sync rules on page 97.

FortiAuthenticator 6.3.1 Administration Guide 10
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Inbound proxy settings for source address detection

FortiAuthenticator now allows the administrator to specify which HTTP header(s) may or may not be used to retrieve the
source |IP address of an HTTP request.

The Edit System Access Settings page in System > Administration > System Access has a new Inbound Proxy
pane with related settings. See System access on page 45.

FortiAuthenticator 6.3.0

The following list contains new and expanded features added in FortiAuthenticator 6.3.0.

Enhancements to the FortiAuthenticator REST API

Various improvements and endpoints added to the FortiAuthenticator 6.3.0 REST API Solutions guide.

For more information, see the REST API Solutions Guide.

Exporting MAC devices list

You can now export the list of MAC devices configured in Authentication > User Management > MAC Devices.

FortiToken Mobile logo configuration

The FortiToken configuration page now includes a separate tab where users can upload logo images for their
organization which are sent to the FortiToken Mobile app during provisioning. The FortiToken Mobile app displays this
logo beside the one-time password for the specific token. This can be used to distinguish between tokens when there are
multiple tokens managed by the same FortiToken Mobile app.

FortiToken Mobile logos can be configured by selecting the Logos tab now available in Authentication > User
Management > FortiTokens.

This option replaces the previous Organizations page which included the same features, previously available in
Authentication > User Management > Organizations.

Monitor active SAML IdP sessions

A monitor for viewing active SAML IdP sessions is available in Monitor > Authentication > SAML IdP Sessions. The
page contains the following elements:

« Atable containing the list of IdP sessions.
» Search options at the top of the table to search by username or by user IP address.
» The total number of SAML sessions.

FortiAuthenticator 6.3.1 Administration Guide
Fortinet Technologies Inc.


https://docs.fortinet.com/product/fortiauthenticator/

What's new in FortiAuthenticator

TACACS+ Import clients through CSV file

TACACSH+ clients can be imported and assigned to TACACS+ policies through a CSV file. See Adding clients on page
145

Sync rule: Import RADIUS users from LDAP server

You can now configure a remote LDAP user synchronization rule that allows you to create, edit, or delete remote
RADIUS users. When this synchronization rule runs, it creates remote RADIUS users available in User Management >
Remote Users.

See Remote user sync rules on page 97.

FortiToken Mobile push notification contains user IP and geolocation

FortiAuthenticator now shows user IP and/or geolocation in the FortiToken mobile push notifications in the following
locations when available:

* Anew Look up geo-location of user IP for Web Service toggle in Authentication > User Account Policies >
General. See General on page 73.

« Anew Application name for FTM push notification field when creating or editing a SAML Service Provider in
Authentication > SAML IdP > Service Providers. See Service providers on page 159.

* Anew Application name for FTM push notification field and Resolve user geolocation from their IP address
toggle when creating or editing a self-service portal policy in Authentication > Portals > Policies. See Self-service
portal policies on page 120.

+ Anew Application name for FTM push notification field and Resolve user geolocation from their IP address
toggle when creating or editing a captive portal policy in Authentication > Portals > Policies. See Captive portal
policies on page 116.

+ Anew Application name for FTM push notification field and Resolve user geolocation from their IP address
toggle when creating or editing a RADIUS policy in Authentication > RADIUS Service > Policies. RADIUS
policies also contain a new RADIUS attribute for user IP field that allows you to specify the RADIUS attribute to
obtain the user IP from. See Policies on page 136.

RADIUS Attributes and Certificate Bindings available to users with administrator or
sponsor role

RADIUS Attributes and Certificate Bindings tabs are available when you create, edit, or import a user with the role as
Administrator or Sponsor in the following locations:
« Authentication > User Management > Local Users.

« Authentication > User Management > Remote Users: RADIUS attributes and certificate bindings are available
when you import an LDAP user.

Only Certificate Bindings tab is available for RADIUS users, and SAML users do not have these tabs.

When creating, editing, or importing a user with its role as Administrator or Sponsor, this feature is available only if
Sync in HA Load Balancing mode is enabled. See Editing a user on page 83.

FortiAuthenticator 6.3.1 Administration Guide
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GUI: Improved LDAP group selection UX

The new Set Group Filter button in Create New Remote LDAP User Synchronization window allows you to set the
LDAP filter by selecting one or more groups to build the LDAP filter string in Authentication > User Management >
Remote User Sync Rules. See Remote user sync rules on page 97.

The Set Group Filter button is also available for the LDAP user groups. See User groups on page 101.

Captive portal: Support for Cisco WLC

FortiAuthenticator captive portal now supports Cisco WLC devices. It recognizes and handles redirects from a Cisco
WLC device.

When configuring a captive portal policy in Authentication > Portals > Policies, FortiAuthenticator offers the following
new built-in HTTP parameters when you select Add Condition in Portal selection criteria > Additional source
criteria:

« client_mac

» redirect_url

« switch_url

+ wlan
The switch_url HTTP parameter helps recognize a Cisco WLC captive portal redirect. After the user has successfully

logged in to the FortiAuthenticator captive portal, FortiAuthenticator redirects the end user to the Cisco WLC API
specified in the switch_url parameter.

Understanding the captive portal workflow help in the Portal selection criteria tab offers a new Cisco WLC topic in

the Access point/NAS dropdown.

The Authentication factors tab has a new tooltip for MAC address parameter that lists which MAC parameter to use
with a device type.

Symmetric encryption keys for debug logs and config files

When creating a configuration backup, the administrator has the option to enable or disable encryption, and specify the
encryption password. By default, encryption is disabled.

When restoring a configuration backup, the administrator enters the decryption password if encryption is enabled. By
default, decryption is disabled.

See Backing up and restoring the configuration on page 36.

SAML IdP: IAM users

FortiAuthenticator now supports configuring IAM users and accounts in Authentication > User Management > |AM.
See |dentity and Account Management (IAM) on page 108.

A new IAM login setting in Authentication > SAML IdP > General that allows IAM logins. When enabled, the SAML
IdP login page shows a new Sign-In as IAM user link. This link takes you to the new customizable IAM login page.

FortiAuthenticator 6.3.1 Administration Guide
Fortinet Technologies Inc.

13



What's new in FortiAuthenticator

Also, when you create an assertion attribute for a SAML service provider in Authentication > SAML IdP > Service
Providers, it has the following new user attributes:

+ |AM account name
+ |AM account alias
« |AM username

A new IAM option when creating a local user that allows you to add this local user to an IAM account. See Local users on
page 81.

A new Sync users to IAM Account option when creating a remote LDAP user synchronization rule that allows you to
synchronize the remote users with an IAM account. See Remote user sync rules on page 97.

A new IAM Account dropdown when importing SSO users in Fortinet SSO Methods > SSO > SSO Users that allows
associating the imported users with an IAM account. See SSO users and groups on page 193.

A new SAML IdP Password Change Page replacement message that allows customization of the password change
page for a local user.

On successful IdP login of an IAM user associated with a local user for which Force password change on next logon
is enabled, FortiAuthenticator presents a password change page same as the one for non-IAM local users.

New iamaccounts and iamusers endpoints available. A new change password field is now available for the
localusers endpoint. For information about the new endpoints, see the REST API Solutions Guide.

SAML IdP: Support authentication from external IdP servers

FortiAuthenticator now supports IdP initiated SAML from the remote SAML IdP using an existing SAML IdP proxy server
type.

The following new changes were implemented to support IdP initiated SAML:

« Anew customizable SAML IdP Proxy Login Success page replacement message for successful IdP initiated
login from a proxy remote SAML server.

+ A new Realm user attribute is available when you create an assertion attribute for a SAML service provider in
Authentication > SAML IdP > Service Providers. This new SAML assertion returns the realm that the end user
was authenticated against. See Service providers on page 159.

The end user accesses the FortiAuthenticator SP login portal URL before the FortiAuthenticator IdP login page. From
the SP login portal URL, the FortiAuthenticator determines the remote SAML server and identifies its associated realm.

Logging: Improvements for SIEM security analysis

The SAML IdP logs now include a new userip field that contains the end user IP address. Also, the nas field in the logs
contains the name of the service provider.

To view log messages, go to Logging > Log Access > Logs. See Log access on page 235.

SAML IdP: RADIUS attributes for assertions

FortiAuthenticator can now include attributes returned by the remote RADIUS servers into assertions returned by the
SAML IdP.

FortiAuthenticator 6.3.1 Administration Guide
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There is a new option in the GUI to configure a SAML assertion containing the value of a RADIUS attribute:

+ Anew RADIUS attribute user attribute is available when you create an assertion attribute for a SAML service
provider in Authentication > SAML IdP > Service Providers. See Service providers on page 159.

Captive portal: Support for WeChat social login

Captive portal in FortiAuthenticator now supports social login through WeChat. See OAUTH on page 132 and Captive
portal policies on page 116.

Also, WeChat is now an option in the Guest Portal Social Network Page and Guest Portal Social Network Plus
FAC accounts replacement messages in Authentication > Portals > Replacement Messages.

Adaptive Authentication

FortiAuthenticator now supports bypassing the OTP verification when the end user IP is on a trusted subnet for the
following services:

+ RADIUS authentication- A new Adaptive Authentication toggle available when creating or editing a RADIUS
policy in Authentication > RADIUS Service > Policies. See Policies on page 136.

« Captive portals- A new Adaptive Authentication toggle available when creating or editing a captive portal policy in
Authentication > Portals > Policies. See Captive portal policies on page 116.

» Self-service portals- A new Adaptive Authentication toggle available when creating or editing a self-service portal
policy in Authentication > Portals > Policies. See Self-service portal policies on page 120.

+ TACACS+ policies- A new Adaptive Authentication toggle available when creating or editing a TACACS+ policy in
Authentication > TACACS+ Service > Policies. See Creating policies on page 143.

o SAML IdP- In Authentication > SAML IdP > Service Providers, the Bypass FortiToken authentication when
user is from a trusted subnet toggle is renamed to Adaptive Authentication. See Service providers on page
159.

TACACS+: Support for log files of size up to 500 MB

TACACS+ audit logs support a maximum file size of 500 MB. The following new size options are available:

-« 100 MB
» 250 MB
- 500 MB

See Debug logs on page 243.

Certificates: GUl improvements

FortiAuthenticator now offers an improved GUI for the Enroliment Requests tab in Certificate Management > SCEP.

A new Delete & Revoke Certificate button in the Enroliment Requests tab that removes the selected SCEP
enrollment request and revokes all the corresponding active user certificates. This option is available only if the
Automatic request type for the selected request is Regular.

New tooltips for the Subject and the Issuer columns display the full subject and the issuer names.

FortiAuthenticator 6.3.1 Administration Guide
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See Enrollment requests on page 229.

FortiAuthenticator Agent for Microsoft OWA: Supports SMS, Email, and FTM push
methods for 2FA

FortiAuthenticator Agent for Microsoft OWA supports SMS, Email, and FTM push methods for 2FA.
See FortiAuthenticator Agent for Microsoft OWA 2.2 Release Notes on the Fortinet Docs Library.

Group memberships when importing local users from a CSV file

You can now set group memberships when importing local users from a CSV file.
To support this feature, a new group names field is available in the CSV format.

When exporting the local users CSV file, FortiAuthenticator includes the list of local groups each user is a member of.
When importing the local users CSV file, FortiAuthenticator adds the users to the specified groups.

See Local users on page 81.

FortiAuthenticator 800F and 300F support user license upgrades

You can now load an add-on user license to FortiAuthenticator 300F and 800F hardware models. This allows for better
sizing flexibility without the need to maintain a wider number of different hardware models.

Similar to FortiAuthenticator-VM, number of additional users in the license specifies the number of additional users
allowed on top of the built-in user limit. For example, if a license file with a FortiAuthenticator-300F serial number
specifies 1000 additional users, uploading that license onto the FortiAuthenticator-300F will result in a maximum user
limit of 2500 (1500 built-in + 1000 license).

FSSO: Retry failed DNS lookups

Enable DNS lookup to get IP from workstation name available when the DC/TS Agent Clients setting is enabled in
Fortinet SSO Methods > SSO > General allows FortiAuthenticator to retry DNS lookup to obtain the workstation IP
address when the logon request contains only the workstation name.

If the initial lookup fails, FortiAuthenticator retries every 10 seconds for the following 5 minutes.

See General settings on page 177.

VM: Support disk partition increase
FortiAuthenticator now supports increasing the disk partition size when more disk space is allocated to a
FortiAuthenticator-VM.
To allocate more disk space to the VM, use the execute expand-partitioncommand inthe CLIconsole.

FortiAuthenticator reboots with an increased disk partition size.

FortiAuthenticator 6.3.1 Administration Guide
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Ay
‘Q' In FortiAuthenticator 6.3.1, the maximum allowed disk size is 2 TB when attempting to
- increase the disk partition size.

Logging: Ability to send FortiAuthenticator debug logs to remote logging servers

FortiAuthenticator now supports sending debug logs to remote logging servers.
There is a new Send debug logs to remote Syslog servers toggle in Logging > Log Config > Log Settings.

See Log configuration on page 237.

FortiAuthenticator 6.3.1 Administration Guide
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Introduction

Introduction

The FortiAuthenticator device is an identity and access management solution. Identity and access management
solutions are an important part of an enterprise network, providing access to protected network assets and tracking user
activities to comply with security policies.

FortiAuthenticator provides user identity services to the Fortinet product range, as well as third-party devices.

FortiAuthenticator delivers multiple features including:

Authentication: FortiAuthenticator includes Remote Authentication Dial In User Service (RADIUS), Terminal
Access Controller Access-Control System Plus (TACACS+), and Lightweight Directory Access Protocol (LDAP)
server authentication methods, and Security Assertion Markup Language (SAML), which is used for exchanging
authentication and authorization data between an Identity Provider (IdP) and a Service Provider (SP).

Two-Factor Authentication: FortiAuthenticator can act as a two-factor authentication server with support for one-
time passwords (OTP) using FortiToken Hardware, FortiToken Mobile, Short Message Service (SMS), or email.
FortiAuthenticator two-factor authentication is compatible with any system which supports RADIUS.

IEEE802.1X Support: FortiAuthenticator supports 802.1X for use in FortiGate Wireless and Wired networks.

User Identification: FortiAuthenticator can identify users through multiple data sources, including Active Directory
(AD), desktop client, guest portal logon, RADIUS accounting, Kerberos, and a Representational State Transfer
(REST) API. It can then communicate this information to FortiGate or FortiMail units for use in identity based
policies.

Certificate Management: FortiAuthenticator can create and sign digital certificates for use, for example, in
FortiGate VPNs and with the FortiToken 300 USB certificate store.

Integration: FortiAuthenticator can integrate with third-party RADIUS, LDAP, and SAML authentication systems,
allowing you to reuse existing information sources. The REST API can also be used to integrate with external
provisioning systems.

FortiAuthenticator is a critical system, and should be isolated on a network interface that is separated from other hosts to
facilitate server-related firewall protection. Be sure to take steps to prevent unauthorized access to the
FortiAuthenticator.

FortiAuthenticator 6.3.1 Administration Guide
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FortiAuthenticator on a multiple FortiGate unit network
FortiAuthenticator

-

Client Client
Network Network

The FortiAuthenticator series of identity and access management appliances complement the FortiToken range of two-
factor authentication tokens for secure remote access. FortiAuthenticator allows you to extend the support for
FortiTokens across your enterprise by enabling authentication with multiple FortiGate appliances and third-party

devices. FortiAuthenticator and FortiToken deliver cost effective, scalable, secure authentication to your entire network
infrastructure.

The FortiAuthenticator device provides an easy-to-configure remote authentication option for FortiGate users.
Additionally, it can replace the Fortinet Single Sign-On (FSSO) Agent on a Windows AD network.

For more information about FortiTokens, see the FortiToken information page on the Fortinet web site.

Before you begin

Before you begin using this guide, please ensure that:

« You have administrative access to the GUIl and/or CLI.

For details of how to accomplish this, see the QuickStart Guide provided with your product, or online at
https://docs.fortinet.com/product/fortiauthenticator/hardware.

« FortiAuthenticator is integrated into your network.
« The operation mode has been configured.

FortiAuthenticator 6.3.1 Administration Guide 19
Fortinet Technologies Inc.


http://www.fortinet.com/products/fortitoken/index.html
https://docs.fortinet.com/product/fortiauthenticator/hardware

Introduction

The system time, DNS settings, administrator password, and network interfaces have been configured.

Network Time Protocol (NTP) is critical for maintaining accurate and stable time, and is

A required when using the Time-based One-time Password (TOTP) method for two-factor
authentication. For more information, see Configuring the system date, time, and time
zone on page 35.

Any third-party software or servers have been configured using their documentation.

While using the instructions in this guide, note that administrators are assumed to have all permissions, unless otherwise
specified. Some restrictions will apply to administrators with limited permissions.

How this guide is organized

This FortiAuthenticator Administration Guide contains the following sections:

Setup describes initial setup for standalone and HA cluster FortiAuthenticator configurations.

System describes the options available in the System menu tree, including network configuration, administration
settings, and messaging settings.

Authentication describes how to configure built-in and remote authentication servers and manage users and user
groups.

Port-based network access control (PNAC) describes how to configure FortiAuthenticator for IEEE 802.1X
Extensible Authentication Protocol (EAP) authentication methods, Bring Your Own Device (BYOD), and MAC-
based device authentication.

Fortinet Single Sign-On (FSSO) describes how to use FortiAuthenticator in a single sign-on (SSO) environment.
RADIUS Single Sign-On (RSSO) describes how to use FortiAuthenticator RADIUS accounting proxy.
Monitoring describes how to monitor SSO and authentication information.

Certificate management describes how to manage X.509 certificates and how to set up FortiAuthenticator to act as
a certificate authority (CA).

Logging describes how to view the logs on your FortiAuthenticator unit.
Troubleshooting provides suggestions to resolve common problems.

LDAP filter syntax outlines some basic filter syntax that is used to select users and groups in LDAP User Import,
Dynamic LDAP Groups, and Remote User Sync Rules.

Registering your Fortinet product

Before you begin configuring and customizing features, take a moment to register your Fortinet product at the Fortinet
Support website. Many Fortinet customer services such as firmware updates, technical support, FortiGuard Antivirus,
and other FortiGuard services require product registration.
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Setup

Setup

For information about installing FortiAuthenticator and accessing the CLI or GUI, refer to the Quick Start Guide provided
with your unit.

This chapter provides basic setup information for getting started with your FortiAuthenticator device. For more detailed
information about specific system options, see System on page 32.

Initial setup

The following section provides information about setting up the virtual machine (VM) version of FortiAuthenticator on
VMware. For setup instructions for other environments, see the Fortinet Document Library.

The following virtualization environments are supported by FortiAuthenticator 6.3.1:

VMware ESXi 4/5/6

Microsoft Hyper-V 2010, 2012 R2, and 2016

KVM

Xen Virtual Machine

AWS

Microsoft Azure

Oracle Cloud Infrastructure

Alibaba Cloud

FortiAuthenticator-VM setup on VMware

Before using FortiAuthenticator-VM, you need to install the VMware application to host the FortiAuthenticator-VM
device. The installation instructions for FortiAuthenticator-VM assume you are familiar with VMware products and
terminology.

System requirements

FortiAuthenticator-VM is compatible with HyperV Windows Server 2012 and 2016. For information on the
FortiAuthenticator-VM system requirements, please see the FortiAuthenticator datasheet.

A\,

FortiAuthenticator-VM has kernel support for more than 4GB of RAM in VM images. However,
this support also depends on the VM player version. For more information, see
http://kb.vmware.com/selfservice/microsites/search.do?language=en_
US&cmd=displayKC&externalld=1014006

The default Hardware Version is 4 in order to support the widest base of VM players.
However you can modify the VM Hardware Version by editing the following line in the
FortiAuthenticator-VM.vmx file:

virtualHW.version = "4"
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FortiAuthenticator-VM image installation and initial setup
The following procedure describes setup on VMware Fusion.

To set up the FortiAuthenticator-VM image:

Download the VM image zip file to the local computer where VMware is installed.
Extract the files from the zip file into a folder.
In your VMware software, go to File > Open.

Navigate to the expanded VM image folder, select the FortiAuthenticator-VM.vmx file, and select Open.
VMware will install and start FortiAuthenticator-VM. This process can take a minute or two to complete.

P obh-=

5. Atthe FortiAuthenticator login prompt, enter admin and press Enter. By default, there is no password, however, a
password must be set before you can proceed. Enter and confirm the new administrator password.

6. Atthe CLI prompt enter the following commands:
config system interface
edit portl
set ip <ip-address>/<netmask>
set allowaccess https ssh gui
next
end
config router static
edit O
set device portl
set dst 0.0.0.0/0
set gateway <ip-gateway>
next
end

Substitute your own desired FortiAuthenticator IP address and default gateway.
You can now connect to the GUI at the IP address you set for port 1.

Suspending the FortiAuthenticator-VM can have unintended consequences. Fortinet

A recommends that you do not use the suspend feature of VMware. Instead, shut down the
virtual FortiAuthenticator system using the GUI or CLI, and then shut down the virtual
machine using the VMware console.

Administrative access

Administrative access is enabled by default on port 1. Using the GUI, you can enable administrative access on other
ports if necessary.

To add administrative access to an interface:

1. Goto System > Network > Interfaces and select the interface you need to add administrative access to. See
Network on page 40 for more information.

2. Under Access Rights, for Admin access, select the types of access to allow.
3. Select OK.
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GUI access

To use the GUI, point your browser to the IP address of port 1 (192.168.1. 99 by default). For example, enter the
following in the URL box:

https://192.168.1.99

Enter admin as the User Name and leave the Password field blank.

command in the CLI (see CLI commands on page 27), or enable HTTP access on the interface

\‘é', HTTP access is not enabled by default. To enable access, use the set ha-mgmt-access
3 in the GUI (see Network on page 40).

For security reasons, the host or domain names that the GUI responds to are restricted. The list of trusted hosts is
automatically generated from the following:

« Configured hostname.

o Configured DNS domain name.

o Network interface IP addresses that have HTTP or HTTPS enabled.
« HA management IP addresses.

Additional IP addresses and host or domain names that the GUI responded to can be defined in the GUI Access
settings. See System access on page 45 for more information.

Telnet

CLI access is available using telnet to the port1 interface IP address (192.168.1.99 by default). Use the telnet -K option
so that telnet does not attempt to log on using your user ID. For example:

$ telnet -K 192.168.1.99

At the FortiAuthenticator login prompt, enter admin. By default there is no password. When you are finished, use the
exit command to end the telnet session.

access command in the CLI (see CLI commands on page 27), or enable Telnet access on the

s‘é’, CLI access using Telnet is not enabled by default. To enable access, use the set ha-mgmt-
3 interface in the GUI (see Network on page 40).

SSH

SSH provides secure access to the CLI. Connect to the port1 interface IP address (192.168.1.99 by default). Specify the
user name admin or SSH will attempt to log on with your user name. For example:

$ ssh admin@192.168.1.99
By default there is no password. When you are finished, use the exit command to end the session.

Note that, after three failed login attempts, the interface/connection will reset, and that SSH timeout is set to 60 seconds
following an incomplete login or broken session.
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Adding FortiAuthenticator to your network

Before setting up FortiAuthenticator, there are some requirements for your network:
« You must have security policies that allow traffic between the client network and the subnet of the
FortiAuthenticator.

« You must ensure that the following ports are open in the security policies between the FortiAuthenticator and
authentication clients, in addition to management protocols such as HTTP, HTTPS, telnet, SSH, ping, and other
protocols you may choose to allow:

« UDP/161 (SNMP)

« UDP/1812 (RADIUS Auth)

« UDP/1813 (RADIUS Accounting)

« TCP/389 (LDAP)

o TCP/636 (LDAPS)

« TCP/8000 (FortiGate FSSO)

« TCP/2560 (OCSP)

o TCP/8001 (FortiClient Single Sign-On Mobility Agent FSSO)
« TCP/8002 (DC/TS Agent FSSO)

o TCP/8003 (Hierarchical FSSO)

To setup FortiAuthenticator on your network:

1. Log in to the GUI with the username admin and no password.

2. Goto System > Network > DNS. Enter your internal network primary and secondary name server IP addresses.
This is essential for successful FSSO operation. See DNS on page 42 for more information.

3. Goto System > Network > Static Routing and create a default route (IP/Mask 0.0.0.0/0) to your network
gateway on the interface that connects to the gateway. See Static routing on page 43 for more information.

4. Goto System > Dashboard > Status.

5. Inthe System Information widget select Change in the System Time field, and select your Time zone from the
list.

6. Either enable the NTP or manually enter the date and time. See Configuring the system date, time, and time zone
on page 35 for more information.
Enter a new time and date by either typing it manually, selecting Today or Now, or select the calendar or clock

icons.
S ! ’, If you plan to use FortiToken devices, Fortinet strongly recommends using NTP.
q FortiToken Time based authentication tokens are dependent on an accurate system clock.
7. Select OK.

8. Ifthe FortiAuthenticator is connected to additional subnets, configure additional FortiAuthenticator interfaces as
required. See Network on page 40 for more information.

Maintenance

System maintenance tasks include:
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« Backing up the configuration on page 25
o Upgrading the firmware on page 25

« Licensing on page 26

o Swapping hard disks on page 26

o Platform migration on page 27

Backing up the configuration

You can back up the configuration of FortiAuthenticator to your local computer. See Backing up and restoring the
configuration on page 36 for more information.

Automatic system configuration backup can also be configured. See Configuring auto-backup on page 53 for
information.

Upgrading the firmware

Periodically, Fortinet issues firmware upgrades that fix known issues, add new features and functionality, and generally
improve your FortiAuthenticator experience. See Firmware upgrade on page 52 for more information.

Before proceeding to upgrade your system, Fortinet recommends you back up your configuration. Please follow the
procedure detailed in Backing up and restoring the configuration on page 36.

To upgrade the firmware, you must first register your FortiAuthenticator with Fortinet. See Registering your Fortinet
product on page 20 for more information.

To upgrade FortiAuthenticator firmware from the GUI:

Download the latest firmware to your local computer from the Fortinet Support website.
Go to System > Administration > Firmware Upgrade.

Select Upload a file and locate the firmware image on your local computer.

Select OK.

The firmware image uploads from your local computer to the FortiAuthenticator device, which will then reboot. For a
short period of time during this reboot, the FortiAuthenticator device is offline and unavailable for authentication.

P obh-=

To upgrade FortiAuthenticator firmware using the CLI:

1. Copy the latest firmware image file to the root directory of the FTP/TFTP server.
2. Logintothe CLI.
3. Enter the following command to copy the firmware image from the FTP/TFTP server to FortiAuthenticator:
For ftp servers:
execute restore image ftp <filename> <ftp ipv4>
For tftp servers:
execute restore image tftp <filename> <tftp ipv4>
Where is the <filename> is the name of the firmware image file and <ftp ipv4>or<tftp ipv4>isthe P
address of the FTP/TFTP server.
4. Typey.
FortiAuthenticator uploads the firmware image file, upgrades to the new firmware version, and restarts.
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Licensing

FortiAuthenticator-VM works in evaluation mode until it is licensed. The license is valid only if one of the
FortiAuthenticator interfaces is set to the IP address specified in the license. See Licensing on page 57 for more
information.

To license FortiAuthenticator:

1. Goto System > Administration > Licensing.
2. Select Upload a file and locate on your local computer the license file you received from Fortinet.
3. Select OK.

Swapping hard disks

If a hard disk on a FortiAuthenticator unit fails, it must be replaced. On FortiAuthenticator devices that support hardware
RAID, the hard disk can be replaced while the unit is still running - know as hot swapping. On FortiAuthenticator units
with software RAID, the device must be shutdown prior to exchanging the hard disk.

To identify the failed hard disk, go to System > Dashboard > Status and view the Disk Monitor widget. When a hard
disk fails, the RAID status shows as Degraded and the RAID status icon displays a warning indication in yellow. In the
RAID graphic, the failed hard disk disappears from the RAID array or displays with a blue question mark symbol.

When replacing a hard disk, you need to first verify that the new disk is the same size as those supplied by Fortinet and
has at least the same capacity as the old one in the FortiAuthenticator unit. Installing a smaller hard disk will affect the
RAID setup and may cause data loss. Due to possible differences in sector layout between disks, the only way to
guarantee that two disks have the same size is to use the same brand and model.

The size provided by the hard drive manufacturer for a given disk model is only an approximation. The exact size is
determined by the number of sectors present on the disk.

Electrostatic discharge (ESD) can damage FortiAuthenticator equipment. Only perform the

A procedures described in this document from an ESD workstation. If no such station is
available, you can provide some ESD protection by wearing an anti-static wrist or ankle strap
and attaching it to an ESD connector or to a metal part of a FortiAuthenticator chassis.

To hot swap a hard disk on a device that supports hardware RAID:

1. Remove the faulty hard disk.

2. Install a new disk in the same slot from which the failed disk was removed.
The Disk Monitor widget updates. In the RAID graphic, a blue question mark symbol appears in the representative
slot where the new hard disk is installed. If the blue question mark symbol does not appear shortly after the new disk
is installed, in the widget, click Refresh to refresh the RAID status.

3. Inthe RAID graphic, click the blue question mark symbol.
The hard disk re-synchronization/rebuild process is initialized. This process can take over an hour to complete,
depending on the size of the hard disk. The RAID status changes to display the progress of the RAID re-
synchronization/rebuild.
After the re-synchronization/rebuild process is complete, the RAID status changes to OK and the RAID status icon
displays a green checkmark.
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Platform migration

Follow the steps below when changing FortiAuthenticator to a different platform type, for example a new hardware
platform, a VM using a different hypervisor, or when moving from hardware to VM or from VM to hardware.

To migrate FortiAuthenticator platforms:

1. The configuration file will need to be converted by Fortinet.
« Save the configuration file of the existing FortiAuthenticator. See Backing up and restoring the configuration on

page 36.
« Contact Fortinet support to open a case requesting a configuration conversion. Provide the configuration file as
well as the target platform.
2. The following licenses must be transferred to the new hardware: FTM, SSOMA, SMS.
« In same case, specify the license numbers as well as the serial number of the new FortiAuthenticator.

vy
‘?' Following this process, provisioned software tokens remain on the new system after

conversion and end users do not have to replace the token on their mobile application.

CLI commands

The FortiAuthenticator has CLI commands that are accessed using SSH or Telnet, or through the CLI console if a
FortiAuthenticator is installed on a FortiHypervisor. The commands can be used to initially configure the unit, perform a

factory reset, or reset the values if the GUI is not accessible.
All FortiAuthenticator CLI commands fall under the following initial setup commands:

config router static
e config system dns
e config system global
e config system ha

e config system interface

NP The FortiAuthenticator-VM's console allows scrolling up and down through the CLI output by
‘9' using Shift+PageUp and Shift+PageDown.
- Like FortiOS, the ? key can be used to display all possible options available to you, depending
- upon where you are hierarchically-situated.

Note that get, execute, and diagnose commands are also available.

Command Description

? Display list of valid CLI commands.
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exit Terminate the CLI session.
show Display bootstrap configuration.
set portl-ip <IP/netmask> Enter the IPv4 address and netmask for the port1 interface. Netmask is

expected in the /xx format, for example 192.168.0.1/24.
After this port is configured, you can use the GUI to configure the remaining
ports.

set default-gw <IP> Enter the IPv4 address of the default gateway for this interface. This is the
default route for this interface.

set date <YYYY-MM-DD> Enter the current date. Valid format is four digit year, two digit month, and
two digit day. For example: set date 2014-08-12 sets the date to
August 12, 2014.

set time <HH:MM:SS> Enter the current time. Valid format is two digits each for hours, minutes,
and seconds. 24-hour clock is used. For example 15:10:00 is 3:10pm.

set tz <timezone_ index> Enter the current time zone using the time zone index. To see a list of index
numbers and their corresponding time zones, enter set tz 2.

set ha-mode Enable or disable (default) HA mode.
{enable | disable}

set ha-port <interface> Select a network interface to use for communication between the two
cluster members. This interface must not already have an IP address
assigned and it cannot be used for authentication services. Both units must
use the same interface for HA communication.

set ns-gw <gateway> Set a default gateway for the HA management interface.

set ha-priority {high | low} Setto low onone unitand high on the other. Normally, the unit with High
priority is the primary unit.

set ha-password <password> Set the HA password.

set ha-mgmt-ip <IP/netmask> Enter the IP address, with netmask, that this unit uses for HA related
communication with the other FortiAuthenticator unit (e.g. 1.2.3.4/24.

The two units must have different addresses. Usually, you should assign
addresses on the same private subnet.

set ha-mgmt-access Select the types of administrative access to allow.
{ssh | https | http
| telnet}

FortiAuthenticator 6.3.1 Administration Guide
Fortinet Technologies Inc.

28



Setup

Command Description

set ha-dbg-level <level> Enter the level for HA service debug logs. Range: -4 (fatal) to 4 (debug
high). Default: -2 (warn).

unset <setting> Restore default value. For each set command listed above, there is an
unset command, for example unset portl-ip.

raid-add-disk <slot> Add a disk to a degraded RAID array.

ha-rebuild Rebuild the configuration database from scratch using the HA peer's
configuration.

restore-admin Restore factory reset's admin access settings to the port1 network interface.

reboot Perform a hard restart of FortiAuthenticator. All sessions are terminated.

The unit goes offline and a delay occurs while it restarts.

factory-reset Enter this command to reset the FortiAuthenticator settings to factory
default settings. This includes clearing the user database.
This procedure deletes all changes that you have made to the
FortiAuthenticator configuration and reverts the system to its original
configuration, including resetting interface addresses.

shutdown Turn off the FortiAuthenticator.

status Display basic system status information including firmware version, build
number, serial number of the unit, and system time.

hardware-info Display general hardware status information.
disk-attributes Display system disk attributes.
disk-errors Display any system disk errors.
disk-health Display disk health information.
disk-info Display disk hardware status information.
raid-hwinfo Display RAID hardware status information.
nslookup Basic tool for DNS debugging.
dig Advanced DNS debugging.
ping Test network connectivity to another network host.
tcpdump Examine local network traffic.
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Command Description

tcpdumpfile Same as tcpdump, but the output is written to a downloadable file that can
be downloaded in the debug logs.

Debug logs can be accessed via your web browser by navigating to
https://<FortiAuthenticator-IP-Address>/debug. For more
information, see Debug logs on page 243.

traceroute Examine the route taken to another network host.

Troubleshooting

Troubleshooting includes useful tips and commands to help deal with issues that may occur. For additional help, contact
customer support. See Troubleshooting on page 242 for more information.

If you have issues when attempting authentication on a FortiGate unit using the FortiAuthenticator, there are some
FortiAuthenticator and FortiGate settings to check.

In addition to these settings you can use log entries, monitors, and debugging information to determine more knowledge
about your authentication problems. For help with FortiAuthenticator logging, see Logging on page 235. For help with
FortiGate troubleshooting, see the FortiOS Handbook for troubleshooting user authentication.

FortiAuthenticator settings

When checking FortiAuthenticator settings, you should ensure that:

« There is an authentication client entry for the FortiGate unit (see RADIUS service on page 135).

» The user trying to authenticate has a valid active account that is not disabled, and that the username and password
are entered correctly.

o The user account allows RADIUS authentication if RADIUS is enabled on the FortiGate unit.
« The FortiGate unit can communicate with FortiAuthenticator, on the required ports:
« RADIUS Authentication: UDP/1812
o LDAP: TCP/389
» The user account exists either:
« as alocal user on the FortiAuthenticator (if using RADIUS authentication),
« inthelocal LDAP directory (if using local LDAP authentication),
« and/orin the remote LDAP directory (if using RADIUS authentication with remote LDAP password validation).

« The useris a member in the expected user groups and these user groups are allowed to communicate on the
authentication client (e.g. the FortiGate).

« If authentication fails with the log error "bad password", try resetting the password. If this fails, verify that the pre-
shared secret is identical on both FortiAuthenticator and the authentication client.

If FortiToken authentication is failing, try the following:

» Verify that the token is correctly synchronized.
« Remove the token from the user authentication configuration and verify authentication works when the token is not
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present.
» Attempt to log into the FortiAuthenticator with the user credentials.

These steps enable the administrator to identify whether the problem is with the FortiGate unit, the credentials, or the
FortiToken.

FortiGate settings

When checking FortiGate authentication settings, you should ensure that:

» The user has membership in the required user groups and identity-based security policies.
o There is a valid entry for the FortiAuthenticator device as a remote RADIUS or LDAP server.
o The user is configured either explicitly or as a wildcard user.
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System

The System tab enables you to manage and configure the basic system options for FortiAuthenticator. This includes the
basic network settings to connect the device to the corporate network, the configuration of administrators and their
access privileges, managing and updating firmware for the device, and managing messaging servers and services.

Dashboard

The Dashboard page displays widgets that provide performance and status information, allowing you to configure some

basic system settings. These widgets appear on a single dashboard.

&2 FortiAuthenticator VM

System ~ || 4 Add Widget
Status
User Lookup System Information
HA Status Host Name
4 Network Device FQDN
% Administration Serial Number
4 Messaging System Ti "

Firmw

Authentication
Fortinet SSO Methods

Monitor

facchoolnet
facchoolnet
FAC:VMO000000000

Wed Nov 27 123138 2019

V.10, build0356 (nt

Last Backup: N/A

User Inventory

Workstations Loggedin:0

Certificate Management

Logging License Information
SMs
Sent/Allowed
FortiTe
Status

HA Status

Enabled

1722722451

2019-11-25 12:02:20 LB device FAC-VMOD0000000O has foined the HA cluster from 172.

[View alllog records]

Authentication Activity

oAl

o % % % % 7 7
s, %, %, %, %, 2, %,
% %

Time - Last Updated: Wed, Nov 27, 2019 8:36 p.m.

Disk Monitor
RAID

The following widgets are available:

System Information

System Resources

Authentication Activity

syncaccount

admin

Lockouts: 0

Lockouts: 0

Lockouts: 0

Lockouts: 0

Lockouts: 0

Displays basic information about the FortiAuthenticator system including host
name, device FQDN name, serial number, system time, firmware version,
architecture, system configuration, current administrator, and up time.

From this widget you can manually update the FortiAuthenticator firmware to a
different release. For more information, see System information widget on page

34.

Displays the usage status of the CPU and memory. For more information, see
System resources widget on page 37.

Displays a customizable graph of the number of logins to the device. For more

information, see Authentication activity widget on page 37.
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User Inventory

HA Status

License Information

Disk Monitor

Top User Lockouts

Power Supply Monitor

Customizing the dashboard

Displays the numbers of users, groups, FortiTokens, FSSO users, and FortiClient
users currently used or logged in, as well as the maximum allowed number, the
number still available, and the number that are disabled. For more information,
see User inventory widget on page 38.

Displays whether or not HA is enabled.

Displays the device's license information, as well as SMS information. For more
information, see License information widget on page 38.

Displays if RAID is enabled, and the current disk usage in GB. For more
information, see Disk monitor widget on page 38.

Displays the top user lockouts. For more information, see Top user lockouts
widget on page 38.

Displays the status of power supply units connected to FortiAuthenticator.
Available for select FortiAuthenticator hardware devices. For more information,
see Power supply monitor widget on page 39

The FortiAuthenticator system settings dashboard is customizable. You can select which widgets to display, where they
are located on the page, and whether they are minimized or maximized.

To move a widget

Position your mouse cursor on the widget'’s title bar, then click and drag the widget to its new location.

To add a widget

In the dashboard toolbar, select Add Widget, then select the widget you want to show. Multiple widgets of the same type
can be added. To hide a widget, in its title bar, select the Hide icon.

To see the available options for a widget

Position your mouse cursor over the icons in the widget’s title bar. Options include show/hide the widget, edit the widget,
refresh the widget content, and close the widget.

The following table lists the widget options.

Show/Hide arrow

Display or minimize the widget.

Widget Title The name of the widget.
Edit Select to change settings for the widget.
This option appears only in certain widgets.
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Refresh

Remove

To change the widget title

Select to update the displayed information.

Select to remove the widget from the dashboard. You are prompted to confirm the
action. To add the widget, select Widget in the toolbar and then select the name of
the widget you want to show.

Widget titles can be customized by selecting the edit button in the title bar and entering a new title in the widget settings
dialog box. Some widgets have more options in their respective settings dialog box.

To reset a widget title to its default name, simply leave the Custom widget title field blank.

The widget refresh interval can also be manually adjusted from this dialog box.

System information widget

The system dashboard includes a System Information widget, which displays the current status of FortiAuthenticator
and enables you to configure basic system settings.

The following information is available on this widget:

Host Name

Device FQDN

Serial Number

System Time

Firmware Version

System Configuration

Uptime

The identifying name assigned to this FortiAuthenticator unit. For more
information, see Changing the host name on page 35.

The FQDN domain name. For more information, see Changing the FQDN domain
name on page 35.

The serial number of FortiAuthenticator. The serial number is unique to
FortiAuthenticator and does not change with firmware upgrades. The serial
number is used for identification when connecting to the FortiGuard server.

The current date, time, and time zone on the FortiAuthenticator internal clock or
NTP servers. For more information, see Configuring the system date, time, and
time zone on page 35.

The version and build number of the firmware installed on FortiAuthenticator. To
update the firmware, you must download the latest version from the Customer
Service & Support portal at https://support.fortinet.com. Select Upgrade and
select the firmware image to load from your management computer.

The date of the last system configuration backup. Select Backup/Restore to
backup or restore the system configuration. For more information, see Backing up
and restoring the configuration on page 36.

The duration of time FortiAuthenticator has been running since it was last started
or restarted.
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Changing the host name
The System Information widget will display the full host name.

To change the host name:

1. Goto System > Dashboard > Status.
2. Inthe System Information widget, select the edit icon in the Host Name field. The Edit Host Name page opens.
3. Inthe Host name field, type a new host name.

Ay
‘Q' The host name may be up to 35 characters in length. It may include US-ASCII letters,
- numbers, hyphens, and underscores. Spaces and special characters are not allowed.

4. Select OK to save the setting.

Changing the FQDN domain name

To change the FQDN domain name:

1. Goto System > Dashboard > Status.

2. Inthe System Information widget, select the editicon in the Device FQDN field. The Edit Device FQDN page
opens.

3. Type a domain name in the field.
The FQDN domain name identifies the exact location of this server in the DNS hierarchy.
4. Select OK to save the setting.

Configuring the system date, time, and time zone

You can either manually set the FortiAuthenticator system date and time, or configure the FortiAuthenticator unit to
automatically keep its system time correct by synchronizing with an NTP server.

Al
‘Q' For many features to work the FortiAuthenticator system time must be accurate.
- Synchronization with a NTP server is highly recommended.

To configure the date and time:

1. Goto System > Dashboard > Status.

2. Inthe System Information widget, select the edit icon in the System Time field. The Edit Time Setting dialog box
appears.
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Edit Time Setting
Change Time Zone
Current time: Wed Nov 27 12:50:35 2019
Time zone: (GMT-8:00) Pacific Time (US & Canada) ~
Change Date And Time
Date: |2019-1127 | Todey i)
Time: |12:50:35 Now | @
@ NTP enabled
NTP server 1: ntpl fortinet.net Prefer
@ Enable authentication

Key number: 1

Key type: m SHA1

Key value:
NTP server 2:

Enable authentication

“ Cance‘

3. Configure the following settings to either manually configure the system time, or to automatically synchronize the
FortiAuthenticator unit’s clock with a NTP server:

Change Time Zone
Time zone Select a timezone from the dropdown menu.
Change Date and Time

Set date/time Select Today or the calendar icon to specify the date, and Now or the clock
icon to specify the time.

NTP enabled Enable this option to set an NTP server. Note that, if you configure both NTP
servers, you can select Prefer to make NTP server 1 the preferred server.
The NTP server 1 is set to ntp1.fortinet.net by default.

In addition, you can select Enable authentication for each NTP server
configured and enter a key number, type, and the key value.

4. Select OK to apply your changes.

Backing up and restoring the configuration

Fortinet recommends that you back up your FortiAuthenticator configuration to your management computer on a regular
basis to ensure that, should the system fail, you can quickly get the system back to its original state with minimal effect to
the network. You should also perform a back up after making any changes to the FortiAuthenticator configuration.

The backup file is encrypted to prevent tampering. This configuration file includes both the CLI and GUI configurations of
FortiAuthenticator, including users, user groups, FortiToken device list, authentication client list, LDAP directory tree,
FSSO settings, remote LDAP, and certificates.

The date and time that the FortiAuthenticator was last backed up is displayed in the System Information widget.

You can perform backups manually. Fortinet recommends backing up all configuration settings from your
FortiAuthenticator unit before upgrading the FortiAuthenticator firmware.
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Your FortiAuthenticator configuration can also be restored from a backup file on your management computer.

To backup or restore the FortiAuthenticator configuration:

1. Inthe user dropdown menu, select Restore/Backup. The Configuration Backup and Restore page opens.
2. Select from the following settings:

Configuration Backup and Restore

Backup

You can backup your current system configuration and restore it at a later time.

/our current system configuration and restore it at a later time.

& Uploadafile

Backup Enable Encryption to use a dynamic encryption key, and specify the
encryption password. By default, Encryption is disabled.

Select Download backup file to save a backup file onto the management
computer.

Restore Select Upload a file to find the backup file on your management computer,
enter the encryption password in Password, then select Restore to restore
the selected backup configuration to the device. By default, decryption is
disabled.

You are prompted to confirm the restore action, and FortiAuthenticator will
reboot.

3. Select Cancel to return to the dashboard page.

When you restore the configuration from a backup file, any information changed since the backup will be lost. Any active
sessions will be ended and must be restarted. You will have to log back in when the system reboots.

Restoring a configuration is only possible from a backup file made on the same model running the same version of the
operating system.

If you are restoring a configuration on the primary device in an HA cluster, shutdown the secondary device until the
primary device is back online to ensure that the configuration synchronization occurs correctly.

System resources widget

The System Resources widget on the dashboard displays the usage status of the CPU and memory as a percentage.

Authentication activity widget

The Authentication Activity widget displays a line graph of the number of logins versus time.

To adjust the data displayed in the graph, select the edit button to open the Authentication Activity Widget Settings
dialog box.

The following settings are available:
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Custom widget title

Refresh interval

Time period

Activity Type

User inventory widget

Enter a custom widget title for the widget, or leave it blank to keep the default title.

Enter a custom refresh interval for the widget (in seconds), or leave it as the
default time of 300 seconds (or five minutes).

Select a time period for the graph to cover from the dropdown menu: Last 6
hours, Last 24 hours, Last 3 days, Last 7 days, or Last 30 days.

Select the activity type to display in the graph: All login attempts, Successful
login attempts, or Failed login attempts.

The User Inventory widget displays the numbers of users, groups, FortiTokens, FSSO users, and FortiClient users
currently used or logged in, as well as the maximum allowed number, the number still available, and the number that are

disabled.

License information widget

The License Information widget displays the device's license information, as well as SMS information. You can also
add a license and more SMS messages.

To upload a new license file, select Upload in the License Type field, then browse to the license file on the management

computer.

To add more SMS messages, select Add Messages from either the Sent/Allowed field or the Status field. In the Add
Messages dialog box, enter the certificate number for the messages and then select OK to add the messages. You can

also Refresh Messages.

Disk monitor widget

The Disk Monitor widget displays the RAID status, and the current disk usage in GB. If RAID is enabled, the
RAID status is visible and the RAID graphic displays the position and status of each disk in the RAID array.

Top user lockouts widget

The Top User Lockouts widget displays the users who are locked out the most. For more information on user lockouts
and for instruction on adjusting user lockout settings, see Lockouts on page 75.

To change the number of user lockouts displayed in the widget, select the edit icon and change the number in the
Number of lockouts field (set to five by default).

User lookup

You can search for users to easily manage and monitor the ongoing activity of a specific user. Selecting a user from the
search results presents a consolidated view of the user's information and recent activities, as well as shortcuts to
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manage that user.

To search for users, go to System > Dashboard > User Lookup. From the search results, click the username to see
user details.

The following information and options are available:

User Info
Username The user accounts' username.
Full name The user accounts' first name and last name.
Email The user account's email address.
User Type The user account type, either Local, LDAP/<server name>, or RADIUS/<server
name>.
Account The status of the user account, either Enabled, Disabled, or Locked until
status <date/time>. The following account management shortcuts are available
depending on the account status:
Disable: Select to disable the account of a user that is enabled.
Re-enable: Select to enable the account of a user that is disabled.
Unlock: Select to unlock the account of a user that has been locked.
Token The token that is assigned to the user account. Select Edit to manage the token
assigned to the account. See Configuring token-based authentication on page
86.
RADIUS-based Usage The user accounts' cumulative RADIUS-based usage statistics. See
Authentication on page 207 for more information.
Active RADIUS Sessions The user accounts' active RADIUS accounting sessions. See Authentication on
page 207 for more information.
Recent Activity The 20 most recent system logs containing the selected username in the log's

User and/or Short message fields. For more information about system logs, see
Log access on page 235.

Refresh Select to refresh the Recent Activity list.

View All Select to view all logs containing the selected username. See Log access on
page 235 for more information.

Power supply monitor widget

The Power Supply Monitor displays the status of the power supply units (PSU) connected to the FortiAuthenticator.
The widget is only available FortiAuthenticator 400E and 3000E hardware devices.

Each PSU is displayed as a color-coded icon to indicate their current status:

e Green: PSU is OK.
e Red: PSU is faulty.
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o Gray: PSU is missing/disconnected.

Power Supply Monitor

YL 1 OO XXX X XY

PSU1  PSU2 B ok M Faulty Missing

& P5U 2 Warning:

A warning message is displayed in the widget when a faulty PSU is detected. You can additionally configure SNMP traps
to send alerts for PSU failure. See SNMP on page 53

Network

The Network tree menu allows you to configure device interfaces, DNS configuration, static routing, and packet
capturing.

Interfaces

To view the interface list, go to System > Network > Interfaces.

The following information is shown:

Edit Select to edit the selected interface.
Search Enter a search term in the search text box then select Search to search the interface list.
Interface The names of the physical interfaces on your FortiAuthenticator unit. The name, including number,

of a physical interface depends on the model.

IPv4 The IPv4 address of the interface.
IPv6 The IPv6 address of the interface, if applicable.
Link status The link status of the interface.

To edit an interface:

1. Inthe interfaces list, select the interface you need to edit and select the Edit button, or select the interface name.
The Edit Network Interface window opens.
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IP Address / Netmask
IPv4:
IPvé:

Access Rights

Admin access:

Services:

192.168.50.246/255.255.255.0

@ Telnet
& SSH
B HTTRS
& GUI (/login)
@ REST API (/api)
@O Fabric (/api/v1/fabric)
@ HTTP (GUI)
@ SNMP

@ HTTPS
@ Self-service Portal (/login)
@ Guest Portals (/guests, /portal)
@ SAML IdP (/saml-idp)
@ SAML 5P 550 (/saml-sp, /login/saml-auth)
@ Kerberos 5SSO (/login/kerb-auth)
@ SCEP (/cert/scep)
& CRL Downloads (/cert/crl)
@ FortiToken Mobile API (/api/v1/pushauthresp, /api/v1/transfertoken)
@ OAuth Service API (/api/v1/oauth)
@ HTTP
@ SCEP (/cert/scep)
@ CRL Downloads (/cert/crl)
@ RADIUS Accounting Monitor
@ RADIUS Auth
@ RADIUS Accounting SSO
@ RADSEC
@ TACACS+ Auth
@ LDAP
& LDAPS
@ FortiGate FS50
@ OCsP
& FortiClient FS50
@ Hierarchical FSSO
@ DC/TS Agent FSS0
@ Syslog

Cancel

2. Edit the following settings as required.

Interface

Status

The interface name is displayed.

The interface's current link status is displayed.

IP Address / Netmask

IPv4
IPv6
Access Rights

Admin access

Enter the IPv4 address and netmask associated with this interface.

Enter the IPv6 address associated with this interface.

Select the allowed administrative service protocols from: Telnet, SSH,
HTTPS, HTTP (GUI), and SNMP.

When HTTPS is enabled, you can also specify GUI (/login), REST API (/api),
and/or Fabric (/api/vilfabric) access.
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Services

Select the allowed services from: HTTPS, HTTP, RADIUS Accounting
Monitor, RADIUS Auth, RADUS Accounting SSO, RADSEC,

TACACS+ Auth, LDAP, LDAPS, FortiGate FSSO, OCSP, FortiClient
FSSO, Hierarchical FSSO, DC/TS Agent FSSO, and/or Syslog.

When HTTPS is enabled, you can also specify Self-service Portal
(/login),Guest Portals (/guests), SAML IdP (/saml-idp), SAML SP SSO
(/saml-sp, /login/saml-auth), Kerberos SSO (/login/kerb-auth), SCEP
(/cert/scep), CRL Downloads (/cert/crl), FortiToken Mobile API
(/api/vi/pushauthresp, /api/v1/transfertoken), and/or OAuth Service API
(/apilv1/oauth) access.

When HTTP is enabled, you can also specify SCEP (/cert/scep) and/or CRL
Downloads (/cert/crl/) access.

Note that Syslog is only available if Syslog SSO has been enabled. See
General settings on page 177 for more information.

3. Select OK to apply the edits to the network interface.

DNS

To configure DNS settings:

1. Goto System > Network > DNS.

DNS Configuration

Primary DNS server:

Secondary DNS server:
@ Enable DNS cache

DNS cache maximum TTL:

208.91.112.53

208.91.112.53

= | seconds (30-600)

2. The following settings can be configured:

Primary DNS server
Secondary DNS server
Enable DNS cache

DNS cache maximum TTL

3. Toapply changes, select OK.

The IP address of the primary DNS server.
The IP address of the secondary DNS server.
Enable to cache the responses to DNS queries.

When DNS cache is enabled, configure the length of time in seconds
responses to DNS queries are cached. If the configured value is larger than
the time to live (TTL) value specified in the DNS record, the DNS TTL value is
used. The default is set to 0, which uses the TTL value specified in the

DNS record.
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Static routing

To view the list of static routes, go to System > Network > Static Routing. Routes can be created, edited, and deleted
as required. Use the checkboxes to select the static route entries you want to either Delete or Edit.

The following information is shown:

Create New Select to create a new static route.

Delete Select to delete the selected static route.

Edit Select to edit the selected static route.

IP/Mask The destination IP address and netmask for this route.

Gateway The IP address of the next hop router to which this route directs traffic.
Device The device or interface associated with this route.

To create a new static route:

1. Inthe static route list, select Create New. The Create New Static Route window opens.
2. Edit the following settings as required.

Destination IP/Mask Enter the destination IP address and netmask for this route.

Network interface Select the network interface that connects to the gateway.

Gateway Enter the IP address of the next hop router to which this route directs traffic.
Comment Optionally, enter a comment about the route.

3. Select OK to create the new static route.

Packet capture

Packets can be captured on configured interfaces by going to System > Network > Packet Capture.
The following information is available:
Edit Select to edit the packet sniffer on the selected interface.

Interface The name of the configured interface for which packets can be captured.
For information on configuring an interface, see Interfaces on page 40.

Maximum The maximum number of packets that can be captured on a sniffer.

packets to

capture

Status The status of the packet capture process. Allows you to start and stop the capturing process, and

download the most recently captured packets.
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To start capturing packets on an interface, select the Start capturing button in the Status column for that interface. The
Status changes to Capturing, and the Stop capturing and download buttons become available.

To download captured packets:

1. Select the download button for the interface whose captured packets you are downloading.
If no packets have been captured for that interface, select the Start capturing button.

2. When prompted, save the packet file (sniffer_[interface].pcap) to your management computer.
The file can then be opened using packet analyzer software.

To edit a packet sniffer:

1. Select the interface whose packet capture settings you need to configure by either selecting the configured interface
name from the interface list, or selecting the checkbox in the interface row and selecting Edit from the toolbar.
The Edit Packet Sniffer page opens.

2. Configure the following options:

interface The interface name (non-changeable).

Max packets to capture Enter the maximum number of packets to capture, between 1-10000. The
default is 500 packets.

Include IPv6 packets Select to include IPv6 packets when capturing packets.

Include non-IP packets Select to include non-IP packets when capturing packets.

3. Select OK to apply your changes.

Administration

Configure administrative settings for the FortiAuthenticator device.
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System access

To adjust system access settings:

1. Goto System > Administration >

Edit System Access Settings

Administrative Access
© Require strong cryptography.

Enable pre-authentication warning message.
CLI Access
CLiidle timeout: ° minotes (0-40 ming
GUI Access
Site title:
GUI idle timeout:

FortiAuthenticator

Maximum HTTP header length: 4
HTTPS Certificate:

ate | C-US, ST-California

HTTP Strict Transport Security (HSTS) Expiry 160 v
Certificate authority type: Local CA
CA certificate that issued the server certificate: | Fortinet_CA1_Root | C-US, ST-Calffornia, L-Suni
Allow all hosts/domain names

Additional allowed hosts/domain names:

Public IP/FQDN for FortiToken Mobile:

Legacy Self-Service Portal And OAuth Access Control Settings

@ username@realm
O realm\username
O realm/username

Username input format:

Use default realm when user-provided realm is different from all configured realms
Realms:

Default Realm
® local | Local users
dar
REST API
Restrict number of requests to: 360
For duration; )

Inbound Proxy

End-user source IP origin when going through a proxy (in order of priority):
© Get proxy IP from FORWARDED HTTP header (if available)
Configure valid FORWARDED "by" values
Get proxy IP from X_FORWARDED_FOR HTTP header (if available)

2. The following settings are available:

Administrative Access

Require strong cryptography

Enable pre-authentication
warning message

CLI Access

CLI idle timeout

GUI Access
Site title

GUI idle timeout

System Access. The Edit System Access Settings page will open.

L-Sunnyvale, O-Fortinet, OU- CN-D ver-Certificate 51w

inyvale, O-Fortinet, OU- Certificate Authority, CN=support, emailAddress-support@fortinet.com v

Allow Local Users To Override Remote Users Groups Delete

. Filter:

Enable this option to restrict administrative access using stronger
cryptographic algorithms, such as TLS 1.2, DHE, AES, and SHA256.

Pre-authentication warning messages can be found under Authentication >
Portals > Replacement Messages.

Enter the amount of time before the CLI times out due to inactivity, from 0 to
480 minutes (maximum of eight hours).

Specify the string to display as the page title in web browsers. The following
variables are available for the construction of the string:
¢ {{thostname}}: Host name

e {{:fqdn}}: Device FQDN
The default is set to FortiAuthenticator.

Enter the amount of time before the GUI times out due to inactivity, from 1 to
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Maximum HTTP
header length

HTTPS Certificate

HTTP Strict
Transport Security
(HSTS) Expiry

Certificate
authority type

CA certificate that
issued the server
certificate

Allow all
hosts/domain
names

Additional allowed
hosts/domain
names

Public IP/FQDN for
FortiToken Mobile

Username input
format

Use default realm
when user-
provided realm is
different from all
configured realms

Realms

480 minutes (maximum of eight hours).

Enter the maximum HTTP header length, from 4 to 16 KB.

Select an HTTPS certificate from the dropdown menu.

Enable or disable HSTS enforcement, to avoid SSL sniffing attacks, and set an
expiry from 0 to 730 days (where 0 means no expiry, maximum of two years).
The default is set to 180.

Select the selected certificate’s authority type, either Local CA or Trusted CA.

Select the issuing server certificate from the dropdown menu.

Enable to allow all the hosts/domain names.

Specify any additional hosts that this site can serve, separated by commas or
line breaks.

This option is only available when Allow all hosts/domain names is disabled.

Enter the IP, or FQDN, of the FortiAuthenticator for external access.

The mobile device running the FortiToken Mobile app requires access to the
FortiAuthenticator interface for push to operate.

Enter the IPs/FQDNSs in the following format:

ip addr[:port] Oor FQDN[:port]

Legacy Self-Service Portal And OAuth Access Control Settings

Select one of the following three username input formats:

e username@realm

* realm\username

* realm/username
Note: When authenticating against the default realm, the realm name is
optional.

When enabled, FortiAuthenticator selects the default realm for authentication
when the user-specified realm is different from all configured realms.

Add realms to which the client will be associated.
¢ Select a realm from the dropdown menu in the Realm column.

¢ Select whether or not to allow local users to override remote users for the

FortiAuthenticator 6.3.1 Administration Guide
Fortinet Technologies Inc.

46



System

selected realm.

« Edit the group filter as needed to filter users based on the groups they are
in.

¢ If necessary, add more realms to the list.
» Select the realm that will be the default realm for this client.

REST API
Restrict number of Enter the maximum number of REST API requests sent, from 1 to 2880
requests to requests. The default is set to 360.
For duration Enter the amount of time for which the maximum number of requests is

restricted, from 1 to 480 minutes. The default is set to 60.

Inbound Proxy

End-user source IP origin when going through a proxy (in order of priority)

Get proxy IP from  Enable to get the proxy IP address from the FORWARDED HTTP header
FORWARDED when available.

HTTP header (if

available)

Enable to specify a list of valid "by" identifiers for the
FORWARDED header, separated by a comma or a new line.

This determines the client IP address used while logging in and
Configure can be used to determine if a proxy IP address is trusted in
valid some security features (e.g. trusted subnets for SAML IdP and
FORWARDED admin GUI access and user portal adaptive authentication,
"by" values etc).

Note: This option provides a way to select the correct source IP
address in case of a chain of inbound proxy. It also provides
additional protection against spoofing.

Get proxy IP from  Enable to get the proxy IP address from the X-FORWARDED_FOR HTTP
X_FORWARDED_  (non-standard equivalent of FORWARDED+ "for") header when available.

FOR HTTP header  Note: When Get proxy IP from FORWARDED HTTP header (if available)

(if available) and Get proxy IP from X_FORWARDED_FOR HTTP header (if available)
options are enabled, FortiAuthenticator looks for a matching "FORWARDED"
header and only uses the "X_FORWARDED_FOR" header if a valid
"FORWARDED" header is not present.

3. Select OK to apply any changes. See Certificate management on page 210 for more information about certificates.

High availability

Multiple FortiAuthenticator units can operate as an high availability (HA) cluster to provide even higher reliability.
There are three HA roles:

1. Cluster member
2. Standalone primary
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3. Load-balancer
The FortiAuthenticator can operate in two separate HA modes:

1. Cluster: Active-passive clustered fail-over mode where all of the configuration is synchronized between the
devices.

2. Load-balancing: Active-active HA method in which one device acts as the standalone primary with up to ten
additional, geographically separated load-balancers. The load can be distributed across the devices using round-
robin DNS, Auth/NAS client load distribution, or external load balancing devices. Load-balancing mode is intended
for two-factor authentication deployments, as only a subset of the configuration is synchronized between the
devices.

Both HA modes can be combined with an HA cluster acting as a standalone primary for geographically distributed load-
balancers.

If an HA cluster is configured on an interface (such as port 2) and then disabled, it will not be

possible to re-enable HA.
A This is because, when disabled, the interface's IP address is reconfigured to the interface to

allow the administrator to access the newly standalone device. To ensure the port is available
for use again in a HA cluster, the IP address must be manually removed.

Cluster member role

In the cluster member role, one unit is active and the other is on standby. If the active unit fails, the standby unit becomes
active. The cluster is configured as a single authentication server on your FortiGate units.

Authentication requests made during a failover from one unit to another are lost, but subsequent requests complete
normally. The failover process takes about 30 seconds.

NP Cluster mode uses Ethernet broadcasts through UDP/720 as part of its primary/secondary
‘Q' election mechanism and for ongoing communication. Layer 2 connectivity is required between
- the two devices in an HA cluster, preferably via a crossover cable, as some network devices

might block such Ethernet broadcasts.

To configure FortiAuthenticator HA:

1. On each unit, go to System > Administration > High Availability.
2. Enter the following information:

Enable HA Enable HA.

Role Select Cluster member.

For more information about the other options, see Standalone Primary and
Load Balancer role below.

Maintenance Mode Enable to put the FortiAuthenticator unit of an HA cluster into maintenance
mode to remove it from the cluster. Upon entering maintenance mode, if the
FortiAuthenticator unit is the active member, it relinquishes the active role and
assumes a standby role. While in maintenance mode, the FortiAuthenticator
will continue to monitor the status of its HA pair and announce its presence.
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Interface

Cluster member IP address

Admin access

Priority

Password

Load Balancers
Monitored interfaces

Monitored interfaces stability
period

Node-Specific Default
Gateway

Heartbeat interval

Heartbeat lost threshold

When set to Enabled with synchronization, the FortiAuthenticator continues
to keep its configuration synchronized with the active member.

When set to Enabled without synchronization, the FortiAuthenticator stops
synchronizing its configuration with the active member.

Select a network interface to use for communication between the cluster
members. This interface must not already have a IP address assigned and it
cannot be used for authentication services. Both units must use the same
interface for HA communication.

Enter the IP address this unit uses for HA-related communication with the other
FortiAuthenticator unit. The units must have different addresses. Usually, you
should assign addresses on the same private subnet.

Select the types of administrative access to allow from: Telnet, SSH, HTTPS,
Admin access, REST API, HTTP, and SNMP.

Set to Low on one unit and High on the other. Normally, the unit with High
priority is the active member.

Enter a string to use as a shared key for IPsec encryption. This must be the
same on both units.

Add the other load-balancing cluster members by entering their IP addresses.
Enable the interfaces you want to monitor.

Define the stability period for the monitored interfaces in seconds, between 0-
3600 (or one hour). The defaultis set to 30.

Define a default gateway for the FortiAuthenticator device if it differs from the
default gateway of the other HA cluster member.

Number of milliseconds between each HA heartbeats sent to the other primary
cluster member. The default value is 1000 milliseconds.

Number of consecutive heartbeats from the other primary cluster member that
must be missed before declaring it out-of-service. The standby unit uses this
measure to trigger a failover. The default value is 6.

The Priority setting is a static value. It allows the administrator to specify which unit to elect
as the active member when both units are working equally well (i.e. in a failover situation,
the "high priority" setting will not be transferred to the new active member).

« If both units are healthy, the one with high priority will be elected as the active

A\,

member.
If the high priority active member goes down, the low priority unit becomes the active
member.

* When the low priority member is active and the high priority member comes back
online, the high priority member assigns the standby role and syncs from the low
priority active member. If the high priority member is synced and remains stable for
around five minutes, it takes over and becomes the active member again.
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3.

Select OK to apply the settings.

Ay
‘Q' When one unit has become the active member, reconnect to the GUI and complete your
- configuration. The configuration will automatically be copied to the standby member.

Standalone Primary and Load Balancer role

The load-balancing HA method enables active-active HA across geographically separated locations and Layer 3
networks. Only the following authentication related features can be synchronized:

Token and seeds.
Local user database.
Remote user database.
Group mappings.
Token and user mappings.
Certificates included in:
» Certificate Management > End Entities > Local Services, excluding firmware (Fortinet) certificates.
« Certificate Management > Certificate Authorities > Local CAs, including firmware (Fortinet) certificates.
Certificate binding settings for local/remote user accounts.
SAML configurations:

« |dP settings configured in Authentication > SAML IdP > General.
Realm tables are not synchronized, but the default realm selection (radio button) is.

o SP settings configured in Authentication > SAML IdP > Service Providers.
Administrators with Sync in HA Load Balancing mode enabled.

Other features, such as FSSO cannot be synchronized between devices.

The current synchronization status of the standalone primary to load-balancers can be viewed at Dashboard >
HA Status.

The standalone primary is the primary system where users, groups, and tokens are configured. Load-balancers are
synchronized to the standalone primary device.

To improve the resilience of the primary system, an active-passive cluster with up to ten load-balancing devices can be
configured.

To configure load-balancing HA:

1.
2,

On each unit, go to System > Administration > High Availability.
Enter the following information:

Enable HA Enable HA.

Role Select Standalone Primary on the primary device, and Load Balancer on the
load-balancing device(s).

Load Balancing primary On the load-balancing device(s), enter IP address of the primary unit.

IP address

Password Enter a string to use as a shared key for IPsec encryption. This must be the
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same on both units.

Load Balancers On the standalone primary unit, enter IP address or IP addresses of the load-
balancing devices. Up to ten can be added.

3. Select OK to apply the settings.

Administrative access to the HA cluster

Administrative access is available through any of the network interfaces using their assigned IP addresses or through
the HA interface using the Cluster member IP address, assigned on the System > Administration >
High Availability page. In all cases, administrative access is available only if it is enabled on the interface.

Administrative access through any of the network interface IP addresses connects only to the active cluster member.
The only administrative access to the standby cluster member is through the HA interface using the standby member’s
Cluster member IP address.

Configuration changes made on the active member are automatically pushed to the standby member. The standby
member does not permit configuration changes, but you might want to access the unit to change HA settings, or for
firmware upgrades, shutdown, reboot, or troubleshooting.

FortiAuthenticator VMs used in a HA cluster each require a license. Each license is tied to a specific IP address. In an
HA cluster, all interface IP addresses are the same on the units, expect for the HA interface.

Request each license backed on either the unique IP address of the unit's HA interface or the IP address of a non-HA
interface which is the same on both units.

s‘é’, If you disable and then re-enable HA operation, the interface that was assigned to HA

communication will not be available for HA use. You must first go to System > Network >
Interfaces and delete the IP address from that interface.

Restoring the configuration

When restoring a configuration to an HA active cluster member, the active member reboots and in the interim the
standby member is promoted to the role of active member. When the previous active member returns to service, it
becomes a standby member and the existing active member overwrites its configuration, defeating the configuration
restore. To avoid this, use the following process when restoring a configuration:

1. Shutdown the standby unit.

2. Restore the configuration on the active member.

3. Wait until the active member is back online.

4. Turn on standby member — it will synchronize to the restored configuration after booting up.

Firmware upgrade

For a stable HA configuration, all units in an HA cluster must be running the same firmware
version, and have the same sized license for HA devices.
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When upgrading the firmware on FortiAuthenticator devices in an HA cluster, you can perform a coordinated upgrade of
both cluster members. During the coordinated upgrade, the cluster upgrades the standby device and then the active
device to run the new firmware image. The firmware upgrade takes place without interrupting communication through
the cluster. This firmware upgrade method can only be initiated from the active member of the cluster.

The following sequence describes the steps the cluster goes through during a coordinated firmware upgrade.

1.

A

N

The administrator initiates the firmware upgrade from the active member.
The firmware image transfers to the standby member.

The firmware upgrades on the standby member.

The standby member reboots and synchronizes with the active member.

The firmware upgrade begins on the active member. The standby member becomes the new active cluster
member.

The former active member reboots and synchronizes with the new active member.

The former active member becomes the active device, and the former standby member becomes the standby
device.

If you want to perform the firmware upgrade on each FortiAuthenticator cluster member individually, specific steps must
be taken to ensure that the upgrade is successful:

1.

Start the firmware upgrade on the active member. See Upgrading the firmware on page 25.

The device reboots. While the active member device is rebooting, the standby member becomes the active
member.

Start the firmware upgrade on the new active member (former standby device).

The device reboots. After both devices have rebooted, the original active member becomes the active device, while
the standby member returns to being the standby device.

If a situation arises where both devices are claiming to be the active cluster member due to a firmware mismatch, and the
HA port of the device that is intended to be the standby member cannot be accessed (such as when a crossover cable is
used), use the following steps:

1.

Shutdown the active cluster member to which you have access, or, if physical access to the unit is not available to
turn it back on, reboot the device. See System information widget.

Note that, if rebooting the device, Step 2 below must be completed before the device finishes rebooting, which can
be as short as 30 seconds.

With the previously inaccessible device now accessible, upgrade its firmware to the required version so that both
devices have the same version.

The device reboots.

If you shutdown the device in Step 1, power it back on.

After both devices are back online, they assume the HA roles dictated by their respective HA priorities.

Firmware upgrade

The FortiAuthenticator firmware can be upgraded from System > Administration > Firmware, the CLI via FTP/TFTP,
or through the System Information widget on the dashboard (see System information widget on page 34).

For instructions on upgrading the device’s firmware, see Upgrading the firmware on page 25.
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Upgrade history

The upgrade history of the device is shown under the Upgrade History heading in the Firmware Upgrade or
Downgrade pane. It displays the version that was upgraded to, the time and date that the upgrade took place, and the
user that performed the upgrade. This information can be useful when receiving support to identify incorrect upgrade
paths that can cause stability issues.

Always review all sections in the FortiAuthenticator Release Notes prior to upgrading your device.

Configuring auto-backup

You can configure the FortiAuthenticator to automatically perform configuration back ups to an FTP or SFTP server.

Even though the backup file is encrypted to prevent tampering, access to the FTP server should be restricted. This
configuration file backup includes both the CLI and GUI configurations of FortiAuthenticator. The backed-up information
includes users, user groups, FortiToken device list, authentication client list, LDAP directory tree, FSSO settings, remote
LDAP and RADIUS, and certificates.

To configure automatic backups, go to System > Administration > Config Auto-backup.

Enter the following information, and then select OK to apply the settings:

Enable configuration auto- Enable the configuration of automatic configuration backups.
backup

Frequency Select the automatic backup frequency: Hourly, Daily, Weekly, or Monthly.

Backup time Entire a time, select Now, or select the clock icon to set the scheduled time for
backups to occur.

Note that this options is not available when the frequency is set to hourly.
FTP directory Enter the FTP directory where the backup configuration files are saved to.

FTP server Select the FTP server to which the backup configuration files are saved to. See
FTP servers on page 60 for information on adding FTP servers.

Secondary Select a secondary FTP server.
FTP server

SNMP

Simple Network Management Protocol (SNMP) enables you to monitor hardware on your network. You can configure
the hardware, such as the FortiAuthenticator SNMP agent, to report system information and send traps (alarms or event
messages) to SNMP managers. An SNMP manager, or host, is typically a computer running an application that can read
the incoming trap and event messages from the agent, and send out SNMP queries to the SNMP agents.

By using an SNMP manager, you can access SNMP traps and data from any FortiAuthenticator interface configured for
SNMP management access. Part of configuring an SNMP manager is listing it as a host in a community on the
FortiAuthenticator device it will be monitoring. Otherwise, the SNMP monitor will not receive any traps from that device,
or be able to query that device.

FortiAuthenticator 6.3.1 Administration Guide
Fortinet Technologies Inc.


https://docs.fortinet.com/document/fortiauthenticator/6.0.0/release-notes

System

The FortiAuthenticator SNMP implementation is read-only. SNMP v1, v2c, and v3 compliant SNMP managers have
read-only access to system information through queries and can receive trap messages from FortiAuthenticator.

To monitor FortiAuthenticator system information and receive FortiAuthenticator traps, your SNMP manager needs the
Fortinet and FortiAuthenticator Management Information Base (MIB) files. A MIB is a text file that lists the SNMP data
objects that apply to the monitored device. These MIBs provide information that the SNMP manager needs to interpret
the SNMP trap, event, and query messages sent by FortiAuthenticator SNMP agent.

The Fortinet implementation of SNMP includes support for most of RFC 2665 (Ethernet-like MIB) and most of RFC 1213
(MIB 1l). RFC support for SNMP v3 includes Architecture for SNMP Frameworks (RFC 3411), and partial support of
User-based Security Model (RFC 3414).

SNMP traps alert you to important events that occur, such as overuse of memory or a high rate of authentication failures.

SNMP fields contain information about FortiAuthenticator, such as CPU usage percentage or the number of sessions.
This information is useful for monitoring the condition of the unit on an ongoing basis and to provide more information
when a trap occurs.

Configuring SNMP

Before a remote SNMP manager can connect to the Fortinet agent, you must configure one or more interfaces to accept
SNMP connections by going to System > Network > Interfaces. Edit the interface, and under Admin access, enable
SNMP. See Network on page 40.

You can also set the thresholds that trigger various SNMP traps. Note that a setting of zero disables the trap.
To configure SNMP settings:

1. Goto System > Administration > SNMP.
2. Enter the following information:

SNMP Contact Enter the contact information for the person responsible for this
FortiAuthenticator unit.

SNMP Description Enter descriptive information about FortiAuthenticator.

SNMP Location Enter the physical location of FortiAuthenticator.

User Table Nearly Full Trap The user table is nearly full. The threshold is a percentage of the maximum
Threshold permitted number of users.

User Group Table Nearly Full The user group table is nearly full. The threshold is a percentage of the
Trap Threshold maximum permitted number of user groups.

RADIUS Authentication Client The RADIUS authenticated client table is nearly full. The threshold is a

Table Nearly Full Trap percentage of the maximum permitted number of RADIUS clients.

Threshold

Authentication Event Rate High authentication load. The threshold is the number of authentication events
Over Limit Trap Threshold over a five minute period.

Authentication Failure Rate High rate of authentication failure. The threshold is the number of

Over Limit Trap Threshold authentication failures over a five minute period.

CPU Utilization Trap High load on CPU. The default is set to 90%.

Threshold (%)
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Disk Utilization Trap Disk usage is high. The default is set to 80%.
Threshold (%)

Memory Utilization Trap Too much memory used. The default is set to 90%.
Threshold (%)

3. Select OK to apply the changes.

To create a new SNMP community:

1. Goto System > Administration > SNMP.
2. Select Create New under SNMP v1/v2c. The Create New SNMP V1/v2c window opens.

Create New SNMP V1/v2c

SNMPV1/v2c
Communi ity name: |
Events:

SNMP Hosts

IP/Netmask Queries Traps Delete

- =
3. Enter the following information in the SNMPv1/v2c section:
Community name The name of the SNMP community.
Events Select the events for which traps are enabled. Options include:

e CPU usage is high

* Memory is low

¢ Interface IP is changed

¢ Auth users threshold exceeded

* Auth group threshold exceeded

¢ Radius NAS threshold exceeded

¢ Auth event rate threshold exceeded
¢ Auth failure rate threshold exceeded
* User lockout detected

* HA status is changed

¢ Power Supply Unit failure

\‘é', The Power Supply Unit failure event is available with

hardware units that support the Power Supply Monitor
widget. See Power supply monitor widget on page 39.

* Disk usage is high
* HA sync activity is low
¢ RAID status changed
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4. In SNMP Hosts, select Add another SNMP Host and enter the following information:

IP/Netmask Enter the IP address and netmask of the host.
Queries Select if this host uses queries.

Traps Select if this host uses traps.

Delete Select to delete the host.

5. Select OK to create the new SNMP community.

To create a new SNMP user:

1. Goto System > Administration > SNMP.
2. Select Create New under SNMP v3. The Create New SNMP V3 window opens.

Create New SNMP V3

General

Authentication method:
Encryption method:
Events:

SNMP Notification Hosts
IP Address Delete

ther SNMP Notification Host

o e
3. Enter the following information in the General section:
Username The name of the SNMP user.
Security level Select the security level from the dropdown menu:

* None: No authentication or encryption.

¢ Authentication only: Select the Authentication method then enter the
authentication key in the Authentication key field.

¢ Encryption and authentication: Select the Authentication method,
enter the authentication key in the Authentication key field, then select
the Encryption method and enter the encryption key in the Encryption
key field. This option is set by default.

Events Select the events for which traps are enabled. See Events on page 55.
4. In SNMP Notification Hosts, select Add another SNMP Notification Host and enter the following information:

IP/Netmask Enter the IP address and netmask of the notification host.

Delete Select to delete the notification host.

5. Select OK to create the new SNMP V3 user.
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To download MIB files:

1. Goto System > Administration > SNMP.

2. Under FortiAuthenticator SNMP MIB, select the MIB file you need to download, options include the
FortiAuthenticator MIB and Fortinet Core MIB files.

Features

Edit system feature settings.

Enable legacy self-service Enable or disable the legacy Self-service Portal configuration (Authentication
portal > Self-service Portal). See Legacy self-service portal on page 165.
This feature is disabled by default, and self-service portal configuration is now
available through Authentication > Portals . See Self-service portal policies on
page 120.

Licensing

FortiAuthenticator-VM works in evaluation mode until it is licensed. In evaluation mode, only a limited number of users
can be configured on the system. To expand this capability, a stackable license can be applied to the system to increase
both the user count, and all other metrics associated with the user count.

When a license is purchased, a registration code is provided. Go to support.fortinet.com and register your device by
entering the registration code. You are asked for the IP address of your FortiAuthenticator device, and are then provided
with a license key.

Ensure that the IP address specified while registering your unit is configured on one of the device’s network interfaces,
then upload the license key to your FortiAuthenticator-VM.

The License Information widget shows the current state of the device license. See License information widget on page
38.

To license FortiAuthenticator:

Register your device at the Fortinet Support website.

Ensure that one of your device’s network interfaces is configured to the IP address specified during registration.
Go to System > Administration > Licensing.

Select Choose File and locate the license file you received from Fortinet.

Select OK.

ok oN-=

FortiAuthenticator licenses

FortiAuthenticator licenses include the following components:

o Maximum number of users (FortiAuthenticator-VM models only).
o Maximum number of SSO Mobility Agent clients (all models).
« Expiry date (trial licenses only; full licenses are perpetual).
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FortiAuthenticator-VM licenses with user limits:

FortiAuthenticator-VM licenses include a user limit which applies to:

« The number of user accounts configured on the FortiAuthenticator (local and remote users combined).
» The number of concurrent FSSO sessions.
« The maximum limits on all other configuration objects are derived as a ratio to the maximum number of users.

SSO Mobility Agent (SSOMA) client limits:

The SSOMA client component is only required for scenarios where you are doing FSSO with SSOMA clients. It
determines how many SSOMA clients can concurrently have active FSSO sessions on the FortiAuthenticator.

Licensing FortiAuthenticator HA units

Primary HA cluster: Each FortiAuthenticator unit is required to have its own license. Both units must have the same
license size (users and SSOMA clients).

HA load-balancer: The HA load-balancer needs to have a user license size big enough to be able to replicate the
configuration from the primary. While this means a load-balancer could have a smaller license than the primary,
administrators must be careful to not undersize load-balancer licenses. The size of the SSOMA license can be different
from the primary, depending on which FortiAuthenticator node the SSOMA clients will be connecting to.

FortiGuard

To view and configure FortiGuard connections, go to System > Administration > FortiGuard. The FortiGuard
Distribution Network (FDN) page provides information and configuration settings for FortiGuard subscription services.
For more information about FortiGuard services, see the FortiGuard web page.

Configure the following settings, then select OK to apply them:
FortiGuard Subscription Services
Messaging Service  The data to which the messaging service license is valid.

SMS messages The total number of allowed SMS messages, and the number of messages that
have been used.

FortiGuard Proxy Server

Enable FortiGuard If enabled, communication with FortiGuard servers will go through this proxy
proxy server server.

Enter the proxy server's address, port, and optionally specify a Username and
Password for user authentication.

FortiToken Hardware Provisioning

Server address The server address (set to update.fortiguard.net by default) and server port (set
Server port to 443 by default).
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FortiToken Mobile Provisioning

Server address
Server port

Activation timeout
Token size

Token algorithm

Time step

Require PIN

PIN Length

FTM trial license
activation

FortiGuard Messaging Service

Server address

The server address (set to fortitokenmobile.fortinet.com by default) and server
port (set to 443 by default).

The activation timeout in hours, from 1 - 168 hours (or seven days).
The token size, either 6 (set by default) or 8.

Time-based One-time Password (TOTP, set by default) or Hash-based One-time
Password (HOTP) algorithm.

The time step, either 60 (set by default) or 30.

Select whether or not to require a PIN, or to enforce a mandatory PIN.

When set to Required (set by default), the user has the option to set a PIN, but
doesn't have to set one. However, a user must set a PIN when set to Enforced,
which cannot be deleted.

The PIN length, either 8, 6, or 4 (set by default).

Option to disable the FortiAuthenticator device's free trial FortiToken Mobile
licenses.

The server address (set to msgctrl1.fortinet.com by default) and server port (set

Server port to 443 by default).
\‘ : 'l
? FTM Push credentials for Apple and Google can be updated via FortiGuard without admin
- user intervention.

FortiNACs

To view a list of the configured FortiNAC servers, go to System > Administration > FortiNACs.

The following information is shown:

Create New

Delete
Edit

Name

Select to configure a new FortiNAC server (this is the only option available if no
FortiNAC servers are configured).

Select to delete the selected FortiNAC server(s).
Select to edit the selected FortiNAC server.

The name of the FortiNAC server.
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To create a new FortiNAC server:

1. Select Create New.
The Create New FortiNAC window opens.

2. Enter the following information:

Name Enter a name for the FortiNAC server.

IP/FQDN Enter the IP address or Fully Qualified Domain Name (FQDN) of the FortiNAC
server.

Port Enter the port number.

Password Enter the FortiNAC server password.

3. Select OK to create the new FortiNAC server.

FTP servers

To view a list of the configured FTP servers, go to System > Administration > FTP Servers.

The following information is shown:

Create New Select to create a new FTP server (this is the only option available if no FTP
servers are configured).

Delete Select to delete the selected FTP server(s).

Edit Select to edit the selected FTP server.

Name The name of the FTP server.

Server name/IP The server name or IP address, and port number.

To create a new FTP server:

1. Select Create New. The Create New FTP Server window will open.
2. Enter the following information:

Name Enter a name for the FTP server.

Connection type Select the connection type, either FTP or SFTP.

Server name/IP Enter the server name or IP address.

Port Enter the port number.

Anonymous Select to make the server anonymous.

Username Enter the server username (if Anonymous is not selected).
Password Enter the server password (if Anonymous is not selected).

3. Select OK to create the new FTP server.
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Admin profiles

Similar to FortiOS, FortiAuthenticator can incorporate the use of admin profiles. Each administrator can be granted either
full permissions or a customized admin profile. Profiles are defined as aggregates of read-only or read/write permission
sets. The most commonly used permission sets are pre-defined, but custom permission sets can also be created.

To create a new admin profile, go to System > Administration > Admin Profiles > Create New. You can give the
admin profile a Name, a Description, and configure the Permission sets you want for that particular admin profile.

Go to Authentication > User Management > Local Users, and select the admin profile to an administrator. You can
assign more than one admin profile to each administrator.

NetHSMs

NetHSMs can be configured on the FortiAuthenticator for the purpose of storing the private keys of Local CAs or issuing
user and local service certificates with local CAs that have their private keys stored on the HSM.

Supported HSM servers currently include Safenet Luna v7.

Configuring an HSM server on FortiAuthenticator

Before creating the HSM server on FortiAuthenticator, you must first configure your HSM with an SSH administrator
account and key partition.

To configure a new HSM server:

1. Goto System > Administration > NetHSMs, and click Create New.
2. Inthe Create New HSM Server window, configure the HSM server settings.

-5 FortiAuthenticator VM FAC-IdP

System ~ | Create New HSM Server

>
Server Settings
Name:

System Access
High Availability
Firmware Upgrade
Config Auto-backup
SNMP

Licensing
FortiGuard
FortiNACs

FTP Servers

Admin Profiles
NetHSMs

A Messaging

Authentication

Fortinet SSO Methods

Ml HSM Server Type:

Server IP/FQDN
Partition Password:
Client IP:

Certificate Management

Upload server certificate:

HSM Server Type

Server IP/FQDN

Safenet Luna v7

@ Upload server certificate

The name of the HSM server.

This name is for FortiAuthenticator reference purposes only and does not
need to match any configuration on the HSM.

The HSM type.
Safenet Luna v7 is currently the only supported HSM type.

The address of the HSM.
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Partition Password The password for the key partition on the HSM.

Client IP The address of the FortiAuthenticator interface that the HSM can see.

For example, if the FortiAuthenticator is behind a NAT device, this should be
the NAT'ed address.

Upload server certificate Upload the server certificate downloaded from your HSM.

3. Click OK to complete setup.
You can edit an existing HSM server to download the HSM client certificate, as well as view the server and client
Network Trust Link (NTL) certificate fingerprints.

Authorizing FortiAuthenticator as an HSM client
Once your HSM server has been configured, you can authorize FortiAuthenticator as a client on your HSM.

To authorize FortiAuthenticator as a Safenet Luna client:

1. Edit the previously configured HSM server on FortiAuthenticator, and click Download client certificate.
Make sure the downloaded certificate uses the <FAC IP>.pem naming convention. For example:
172.16.68.47 .pem.

2. Upload the client certificate to the Safenet Luna HSM using SCP transfer.

scp [certificate filename] admin@[HSM address]:

3. Use SSH to connect to the HSM, then register your FortiAuthenticator, and associate it with a partition.
ssh -1 admin [HSM address]
client register -c [client name] -ip [client address]
client assignpartition -c [client name] -p [partition name]

4. Confirm the status. For example:
client show -c my fac
ClientID: my fac
IPAddress: 172.16.68.47
Partitions: my partition

Configuring or importing an HSM CA certificate

After the HSM server has been configured and FortiAuthenticator is authorized as an HSM client, local CA certificates
using the HSM can be created or imported at Certificate Management > Certificate Authorities > Local CAs. See
Local CAs on page 220.

Replacement messages

The replacement messages list lets you view and customize replacement messages, and manage images.

Go to System > Administration > Replacement Messages to view the replacement message list.
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System v ||B® Manage Images
@ Dashboard >
Name Description Modified
4 Network >
@& Administration g Account
System Access Account Change Notification Email Subject Text for subject of email that notifies user about a change on his/her account °
High Availability Account Change Notification Email Message Text for email that notifies user about a change on his/her account o
Firmware Upgrade . . . .
Admin Set Random Password for User Email Subject  Text for subject of email sent to a user whose password has been changed to a random password °
Config Auto-backup
s Admin Set Random Password for User Email Mess... Text for email sent to a user whose password has been changed to a random password °
Features Admin Set Random Expiring Password for User Em... Text for subject of email sent to a user whose password has been changed to a random password °
Licensing Admin Set Random Expiring Password for User Em... Text for email sent to a user whose password has been changed to a random password °
FortiGuard
F° N:QC' FortiToken Request Email Subject Text for subject of email that contains user's FortiToken request details °
ortil s
[ FortiToken Request Email Message HTML for email that contains user's FortiToken request details °
Admin Profiles FortiToken Mobile Activation Email Subject Text for subject of email that contains an instruction to activate a FortiToken Mobile °
NetHSMs FortiToken Mobile Activation Email Message HTML for email that contains an instruction to activate a FortiToken Mobile o
Replacement Messages . " - R § " .
7 FortiToken Mobile Transfer Email Subject Text for subject of email that contains an instruction to transfer a FortiToken Mobile °
Messaging >
FortiToken Mobile Transfer Email Message HTML for email that contains an instruction to transfer a FortiToken Mobile °
Authentication >
Fortinet SSO Methods , | Password Expiration Warning Email Subject Text for subject of email sent to a user whose password s about to expire °
Monitor , | Password Expiration Warning Email Message Text for email sent to a user whose password is about to expire °
Certificate Management > | Password Expired Notification Email Subject Text for subject of email sent to a user whose password has expired °
Logging > ' Restore Default B8 Toggle Tag List [ Format: text/plain
Account Information Change Allke -~

The replacement messages are divided into seven categories: Account, Authentication, Device Certificate

Enrollment, Password Reset, User Registration, SAML SP (FSSO), and System.

To view and customize SAML IdP replacement messages, go to Authentication > SAML IdP > Replacement
Messages.

\y

~ P The two pre-authentication replacement messages under Authentication are only available
9 after pre-authentication has been enabled under System > Administration > System
- Access.

Selecting a specific message will display the text and HTML or plain text of the message in the lower half of the content
pane.

Selecting Toggle Tag List will display a table of the tags used for that message atop the message’s HTML or plain text
box.

To edit a replacement message:

1. Select a message in the replacement message list.

2. Edit the plain text or HTML code in the lower right pane, or select Open in new window to edit the message in a
new browser window.

To insert custom images into the replacement message, see Manage Images on page 63.
3. When you are finished editing the message, select Save to save your changes.

4. If you have made an error when editing the message, select Restore Default to restore the message to its default
value.

Manage Images

Images can be managed by selecting Manage Images in the Replacement Messages window. Images can also be
added, deleted, and edited.
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To add an image:

1. From the Manage Images window, select Create New to open the Create New Image window.
2. Inthe Name field, enter a name for the image.

3. Select Choose File, find the GIF, JPEG, or PNG image file that you want to add, and then select Open.
Note: The maximum image size is 1000 kB.

4. Select OK to add the image.
To insert the image into a replacement message, add the following HTML code:
<img src={{:image/<image name>}}>

Where <image name> is the name entered for the image. For example, the HTML code for an image named
Acme_logois <img src={{:image/Acme logo}}>

To delete an image:

1. From the Manage Images window, select an image, then select Delete.
2. Select Yes, I'm sure in the confirmation window to delete the image.

To edit an image:

In the manage images screen, select an image, then select Edit.

1. From the Manage Images window, select an image, then select Edit.
2. Inthe Edit Image window, edit the image name and file as required.
3. Select OK to apply your changes.

Messaging

FortiAuthenticator sends email for several purposes, such as password reset requests, new user approvals, user self-
registration, and two-factor authentication.

By default, FortiAuthenticator uses its built-in Simple Mail Transfer Protocol (SMTP) server. This is provided for
convenience, but is not necessarily optimal for production environments. Fortinet recommends that you configure the
unit to use a reliable external mail relay.

There are two distinct email services:

1. Administrators: Password reset, new user approval, two-factor authentication, etc.
2. Users: Password reset, self-registration, two-factor authentication, etc.

If you plan to send SMS messages to users, you must configure the SMS gateways that you will use. Ask your SMS
provider for information about using its gateway. The FortiAuthenticator SMS gateway configuration differs according to
the protocol your SMS provider uses.

SMTP servers

To view a list of the SMTP servers, go to System > Messaging > SMTP Servers.

FortiAuthenticator 6.3.1 Administration Guide 64
Fortinet Technologies Inc.



System

AR

Although FortiAuthenticator can be configured to send emails from the built-in mail server
(localhost), this is not recommended. Anti-spam methods such as IP lookup, DKIM, and SPF
can block mail from such ad-hoc mail servers. It is highly recommended that email is relayed
from an official mail server for your domain.

The following information is shown:

Create New
Delete

Edit

Set as Default
Name

Server

Default

Select to create a new SMTP server.

Select to delete the selected SMTP server or servers.
Select to edit the selected SMTP server.

Set the selected SMTP server as the default SMTP server.
The name of the SMTP server.

The server name and port number.

Shows a green circle with a check mark for the default SMTP server. To change the default
server, select the server you would like to use as the default, then select Set as Default in the
toolbar.

To add an external SMTP server:

1. Goto System > Messaging > SMTP Servers and select Create New. The Create New SMTP Server window

opens.

Create New SMTP Server

Name:

Server name/1P:

Port:

Sender name (optional):

Sender email address:

25 S

Connection Security And Authentication

Secure connection:

& Enable authentication

Account username:

Password:

None ~

Test Comnecton “ Canl:e'

2. Enter the following information:

Name

Server name/IP

Enter a name to identify this mail server on FortiAuthenticator.

Enter the IP address or Fully Qualified Domain Name (FQDN) of the mail

server.
Port The default port 25. Change it if your SMTP server uses a different port.
Sender name (optional) Optionally, enter the name that will appear when sending an email from
FortiAuthenticator.
Sender email address In the From field, enter the email address that will appear when sending an

email from FortiAuthenticator.
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Connection Security and Customize the secure connection and authentication for a user.
Authentication

Secure For a secure connection to the mail server, select STARTTLS from the
connection dropdown menu.
Enable Enable if the email server requires you to authenticate when sending email.

authentication Enter the Account username and Password if required.

3. Optionally, select Test Connection to send a test email message. Specify a recipient and select Send. Confirm that
the recipient received the message.

A\,

S L4
? Note that the recipient’s email system might treat the test email message as spam.

4. Select OK to create the new SMTP server.

Email services

To view a list of the email services, go to System > Messaging > Email Services.

The following information is shown:

Edit Select to edit the selected email service.
Recipient The name of the email recipient.
SMTP server The SMTP server associated with the recipient. The server can be selected from

the dropdown menu.

Save Select to save any changes made to the email services.

To configure email services:

1. Goto System > Messaging > Email Services and select the recipient you need to edit (the user's email service is
shown below). The Edit Email Service window opens.

Edit Email Service

Recipient: Users
Description: Used for emails that are sent to regular users, such as emails for password reset, self-registration, two-factor authentication, etc.
SMTP server: Use default server v

Public Address
‘You can customize the address or link to this site which the email recipients will receive.

Address discovery method: @® Automatic discovery
(O Specify an address
(O Use the IP address from a network interface

“ Geneel
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2. Configure the following:

SMTP server
Public Address

Address discovery
method

Address
Port

Network interface

3. Select OK to apply your changes.

SMS gateways

Select the SMTP server from the dropdown menu.
Customize the address or link for the email.

Select the address discovery method:
» Automatic discovery: Use device FQDN if configured, or automatically
obtain address from the browser, or an active network interface.
e Specify an address: Manually enter the address and port number.

¢ Use the IP address from a network interface: Select a specific network

interface from the dropdown menu.

Enter the recipient IP address or FQDN. Only available if Address discovery
method is set to Specify an address.

Enter the recipient port number (set to 80 by default). Only available if
Address discovery method is set to Specify an address.

Select a configured network interface from the dropdown menu. This option is
only available when the Address discovery method is set to Use the IP
address from a network interface.

To view a list of the configured SMS gateways, go to System > Messaging > SMS Gateways.

The following information is shown:

Create New
Delete

Edit

Set as Default
Name
Protocol
SMTP Server
APl URL
Default

Select to create a new SMS gateway.

Select to delete the selected SMS gateway or gateways.
Select to edit the selected SMS gateway.

Set the selected SMS gateway as the default SMS gateway.
The name of the SMS gateway.

The protocol used by the gateway.

The SMTP server associated with the gateway.

The gateway’s APl URL, if it has one.

Shows a green circle with a check mark for the default SMS gateway. To change
the default gateway, select the gateway you would like to use as the default, then

select Set as Default in the toolbar.

You can also configure the message that you will send to users. You can use the following tags for user-specific

information:

Tag
{{zcountry_code}}

{{mobile_number}}

Information
Telephone country code, e.g. 01 for North America.

User’s mobile phone number.
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Tag Information
{{imessage}} “Your authentication token code is ” and the code.
{{:null}} Empty string or null value.

To create a new SMTP SMS gateway:

1. Goto System > Messaging > SMS Gateways and select Create New. The Create New SMS Gateway window
opens.

Create New SMS Gateway

Name:
Protocol: ® SMTP O HTTP O HTTPS
& SMTP
SMTP server: Use Email Services settings ~
Mail-to-SMS gateway: [l:mobile_number}}@domain.com
Subject: [[:messagel}
Body: [[:messagel}
Email Preview:
To 604555123 4@domain. com
Subject authenticaticn tcken cede is 123456
Body Your authentication token code is 123456

HTTP/HTTPS

festserns “ cones

2. Enter the following information:

Name Enter a name for the new gateway.
Protocol Select SMTP.
SMTP server Select the SMTP server you use to contact the SMS gateway. The SMTP

server must already be configured, see SMTP servers on page 64.

Mail-to-SMS gateway Change domain.com to the SMS provider's domain name. The default entry
{{:mobile number}}@domain.comassumes thatthe address isthe
user’s mobile number followed by @ and the domain name. In the Email
Preview section, check the To field to ensure that the format of the address
matches the information from your provider.

Email Preview View a preview of the email message.
To Format of the email address, as determined by the Mail-to-SMS gateway
field.
Subject Optionally, enter a subject for the message.
Body Optionally, enter body text for the message.
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3. Optionally, select Test Settings to send a test SMS message to the user.
4. Select OK to create a new SMTP SMS gateway.

To create a new HTTP or HTTPS SMS gateway:

1. Goto System > Messaging > SMS Gateways and select Create New. The Create New SMS Gateway window
opens.

2. Expandthe HTTP/HTTPS section, then enter the following information:

HTTP/HTTPS
HTTP method Select the method to use, either GET of POST.
API URL Enter the gateway URL, omitting the protocol prefix http:// orhttps://.
Also omit the parameter string that begins with 2.
CA certificate Select CA certificate that validates this SMS provider from the dropdown
menu.
Content-Type Select a content type from the dropdown menu.

Authorization Type Enter the Username and Password for Basic Auth.

HTTP Parameters

Field Enter the parameter names that the SMS provider's URL requires, such as
user and password.

Value Enter the values or tags corresponding to the fields.

Delete Delete the field and its value.

3. Ifyou need more parameter entries, select Add another SMS Gateway HTTP Parameter.
4. Optionally, select Test Settings to send a test SMS message to the user.
5. Select OK to create a new HTTP or HTTPS SMS gateway.
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Authentication

FortiAuthenticator provides an easy to configure authentication server for your users. Multiple FortiGate units can use a
single FortiAuthenticator unit for remote authentication and FortiToken device management.

FortiAuthenticator in a multiple FortiGate unit network

I I l G;‘ I I l FortiGate

FortiAuthenticator

_J_‘L e |

/L

FortiGate

N
/"

Client Client
Network Network

What to configure

You need to decide which elements of the FortiAuthenticator configuration you need:

» Determine the type of authentication you will use: password-based or token-based. Optionally, you can enable both
types. This is called two-factor authentication.

» Determine the type of authentication server you will use: RADIUS, TACACS+, built-in LDAP, or Remote LDAP. You
will need to use at least one of these server types.

» Determine which FortiGate units or third-party devices will use the FortiAuthenticator. The FortiAuthenticator must
be configured on each FortiGate unit as an authentication server, either RADIUS or LDAP. For RADIUS
authentication, each FortiGate or third-party device must be configured on the FortiAuthenticator as an
authentication client.

FortiAuthenticator 6.3.1 Administration Guide
Fortinet Technologies Inc.

70



Authentication

Password-based authentication

User accounts can be created on the FortiAuthenticator device in multiple ways:

« Administrator creates a user and specifies their username and password.
» Administrator creates a username and a random password is automatically emailed to the user.
» Users are created by importing either a CSV file or from an external LDAP server.

Users can self-register for password-based authentication. This reduces the workload for the system administrator.
Users can choose their own passwords or have a randomly generated password provided in the browser or sent to them
via email or SMS. Self-registration can be instant, or it can require administrator approval. See Self-service portal
policies on page 120.

Once created, users are automatically part of the RADIUS Authentication system and can be authenticated remotely.

See User management on page 80 for more information about user accounts.

Two-factor authentication

Two-factor authentication increases security by requiring multiple pieces of information on top of the username and
password. There are generally two factors:

« Something the user knows, usually a password,

« Something the user has, such as a FortiToken device.

Requiring the two factors increases the difficulty for an unauthorized person to impersonate a legitimate user.

To enable two-factor authentication, configure both password-based and token-based authentication in the user’s
account.

FortiAuthenticator token-based authentication requires the user to enter a numeric token, or one-time password (OTP),
at login. Two types of numerical tokens are supported:

o Time-based (TOTP): The token passcode is generated using a combination of the time and a secret key which is
known only by the token and the FortiAuthenticator device. The token password changes at regular time intervals,
and FortiAuthenticator is able to validate the entered passcode using the time and the secret seed information for
that token.

Passcodes can only be used a single time (one time passcodes) to prevent replay attacks. Fortinet has the
following time based tokens:

o FortiToken hardware
» FortiToken Mobile, running on a compatible smartphone

For more information about TOTP, see RFC 6238.

o Event-based or HMAC-based (HOTP): The token passcode is generated using an event trigger and a secret key.
Event tokens are supported using a valid email account and a mobile phone number with SMS service.
FortiToken devices, FortiToken Mobile apps, email addresses, and phone numbers must be configured in the
user’s account.

For more information about HOTP, see RFC 4226.

Only the administrator can configure token-based authentication. See Configuring token-based authentication on
page 86.
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Two-factor token and password concatenation

Concatenated passwords and one-time password (OTP) codes can be provided by the client in the password field so
that there is no second step to enter an OTP code. This is supported by all authentication methods on the
FortiAuthenticator that also support password-only authentication. See Authentication methods.

Authentication servers

FortiAuthenticator has built-in RADIUS and LDAP servers. It also supports the use of remote RADIUS and LDAP (which
can include Windows AD servers).

The built-in servers are best used where there is no existing authentication infrastructure, or when a separate set of
credentials is required. You build a user account database on FortiAuthenticator. The database can include additional
user information such as street addresses and phone numbers that cannot be stored in a FortiGate unit’s user
authentication database. To authenticate, either LDAP or RADIUS can be used. The remote LDAP option adds your
FortiGate units to an existing LDAP structure. Optionally, you can add two-factor authentication to remote LDAP.

RADIUS

If you use RADIUS, you must enable RADIUS in each user account. FortiGate units must be registered as RADIUS
authentication clients under Authentication > RADIUS Service > Clients. See RADIUS service on page 135. On each
FortiGate unit that will use the RADIUS protocol, FortiAuthenticator must be configured as a RADIUS server under
User & Device > RADIUS Servers.

Built-in LDAP

If you use built-in LDAP, you will need to configure the LDAP directory tree. You add users from the user database to the
appropriate nodes in the LDAP hierarchy. See Creating the directory tree on page 151. On each FortiGate unit that will
use LDAP protocol, FortiAuthenticator must be configured as an LDAP server under User & Device > LDAP Servers.

Remote LDAP

Remote LDAP is used when an existing LDAP directory exists and should be used for authentication. User information
can be selectively synchronized with FortiAuthenticator, but the user credentials (passwords) remain on, and are
validated against the LDAP directory.

To utilize remote LDAP, the authentication client (such as a FortiGate device) must connect to the FortiAuthenticator
device using RADIUS to authenticate the user information (see User & Device > RADIUS Servers). The password is
then proxied to the LDAP server for validation, while any associated token passcode is validated locally.

Authentication methods

RADIUS and TACACS+ with PAP, user portals, SAML IdP, and REST API:

o End-user password provided to FortiAuthenticator as cleartext.
« Any type of user account (i.e. local or remote) can authenticate.

RADIUS with CHAP/MSCHAPV2:
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« End-user password provided to FortiAuthenticator as a hash digest.

« Only local user accounts with passwords stored using reversible cryptography can authenticate. See Local user
account password storage on page 90

Machine authentication

Machine (or computer) authentication is a feature of the Windows supplicant that allows a Windows machine to
authenticate to a network via 802.1X prior to user authentication.

Machine authentication is performed by the computer itself, which sends its computer object credentials before the
Windows logon screen appears. User authentication is performed after the user logs in to Windows.

Based on the computer credentials provided during machine authentication, limited access to the network can be
granted. For example, access can be granted to just the Active Directory server to enable user authentication.

Following machine authentication, user authentication can take place to authenticate that the user is also valid, and to
then grant further access to the network.

Machine authentication commonly occurs on boot up or log out, and not, for example, when a device awakens from
hibernation. Because of this, the FortiAuthenticator caches authenticated devices based on their MAC addresses for a
configurable period (see User account policies on page 73). For more information on cached users, see Windows device
logins on page 208

To configure machine authentication, see RADIUS service on page 135.

User account policies

General policies for user accounts include lockout settings, password policies, and custom user fields.

General

To configure general account policy settings, go to Authentication > User Account Policies > General.

Edit General Account Policy Settings

General Settings
PCI DSS 3.2 two-factor authentication
Request password reset after token verification
Enhanced cryptography for storage of local user passwords
WARNING: This option cannot be disabled after being enabled for 30 days.
Expire device login after: 480 minutes (5-1440)

© Automatically purge disabled user accounts

Frequency: Hourly | Daily Menthiy
Time: 00:30:00 | Now

Purge users that are disabled due Manually disabled

to the following reasons: Login inactivity

@ Account expired
Usage limit exceeded

@ Discard stale RADIUS authentication requests
Request stale after: 8

Expire inactive RADIUS 6
accounting session after:

Session duration of authenticated 28800 | se
TACACS+ user:

@ Look up geo-location of user IP for Web Service

Configure the following settings:
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PCI DSS 3.2 two-factor
authentication

Request password reset after
token verification

Enhanced cryptography for
storage of local user
passwords

Expire device login after

Automatically purge disabled
user accounts

Purge users that are disabled
due to the following reasons

Discard stale RADIUS
authentication requests

Expire inactive RADIUS
accounting session after

Session duration of
authenticated TACACS+ user

Look up geo-location of user
IP for Web Service

Enable to always collect all authentication factors before indicating a success or
failure.

Enable if password reset is required, a change password request is sent once the
token is verified.

When disabled, FortiAuthenticator uses AES256 encryption for local user
passwords.

When enabled, local user passwords are hashed using bcrypt.

With enhanced cryptography, cleartext passwords can no longer be recovered,
and authentication requests requiring cleartext passwords for validation will fail.
Enhanced cryptography can be disabled within 30 days of being enabled. After 30
days it cannot be disabled. FortiAuthenticator sends an email reminder to the
administrator before the end of the 30-day period.

Local admin passwords are always hashed using bcrypt.

Login session timeout for Windows machine authentication via 802.1X.

Enable to automatically purge disabled user accounts. Select the frequency of the
purge in the Frequency field: Hourly, Daily, Weekly, or Monthly. Enter the time
of the purge in the Time field: Now to set the time to the current time, or select the
clock icon to choose a time: Now, Midnight, 6 a.m., Noon, or 6 p.m.

Set the reason for purging disabled users: Manually disabled, Login inactivity,
Account expired, or Usage limit exceeded.

Enable to select a time after which RADIUS authentication requests are
considered stale and are discarded, from 3 - 360 seconds (or six minutes). The
defaultis set to 8 seconds.

Enter a time after which RADIUS accounting sessions timeout, from 5 to 1440
minutes (or five minutes to one day). The default is set to 60 minutes.

The maximum time duration (in seconds) for which an authenticated TACACS+
user is authorized to issue commands.

Enable or disable geolocation lookup for the user IP address (if possible).

PCI DSS 3.2 two-factor authentication

The login flows for RADIUS authentication, SAML IdP, guest portals, and GUI login all meet PCI DSS 3.2 standards

regarding multi-factor authentication.

In the case where the Bypass FortiToken authentication when user is from a trusted subnet option is enabled
(under Authentication > SAML IdP > Service Providers), and the user is logging in from a trusted subnet, the login
flow reverts to password-only regardless of the PCI mode.

The GUI login page is hard-coded to Apply two-factor authentication if available (authenticate any user), so it
behaves the same as the guest portal.
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All failed authentications will return the same generic message, so as not to reveal any clue to an attacker about which
piece of information was valid or invalid:

"Please enter correct credentials. Note that the password is case-sensitive."

Remote login to the CLI (i.e. Telnet, SSH) also complies with the new PCI requirements.

Guest portal exception

There is one exception for guest portals. When a user has exceeded their time and/or data usage limit, the
FortiAuthenticator shows the "Usage exceeded" replacement message. The best behavior would be to only show the
replacement message if the credentials are valid. However, this would require a major change in the internal flow of the
current authentication implementation. Instead, the FortiAuthenticator only requires that the account name be valid (not
the credentials). The downside is that it opens the door for leaking valid account names. Nonetheless, it is deemed
acceptable because:

1. Account name leakage prevention is not a PCl requirement (just a best practice).

2. Leaked account names are not usable because they are disabled (due to exceeded usage).

3. Disabled accounts can't be leveraged to brute-force credentials (in the hope of using them if an account gets re-
enabled/usage extended).

Lockouts

For various security reasons, you may want to lock a user’s account. For example, repeated unsuccessful attempts to
log in might indicate an attempt at unauthorized access.

Information on locked-out users can be viewed in the Top User Lockouts widget, see Top user lockouts widget on page
38.

Currently locked-out users can be viewed in Monitor > Authentication > Locked-out Users.

To configure the user lockout policy:

1. Go to Authentication > User Account Policies > Lockouts.
2. Configure the following settings, then select OK to apply any changes:

Enable user account lockout Enable user account lockout for failed login attempts and enter the maximum
policy number of allowed failed attempts in the Maximum failed login attempts
field.

Specify lockout Enable to specify the length of the lockout period, from 60 to 86400 seconds
period (or one minute to one day). After the lockout period expires, the Maximum
failed login attempts number applies again.
When disabled, locked out users are permanently disabled until an
administrator manually re-enables them.

Enable inactive user lockout  Select to enable disabling a local user account if there is no login activity for a
given number of days. Inactive user lockout applies to local users only. In the
Lock out inactive users after field, enter the number of days, from 1 to 1825
(or one day to five years), after which a local user is locked out.
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Passwords

Multiple password policies can be created and implemented for different groups, as opposed to enforcing a global
password policy.

When a user is a member of multiple user groups, FortiAuthenticator applies the strictest password policy settings. For
example, if two password policies have different password expiry periods, FortiAuthenticator applies the shortest expiry
period.

Al
‘Q' For load-balancing HA (A-A), new password policy settings in user groups must be manually
- duplicated on the backup unit(s).

You can enforce a minimum length and complexity for user passwords, and can force users to change their passwords
periodically.

For information on setting a user’s password, and password recovery options, see Editing a user on page 83.

Go to Authentication > User Account Policies > Passwords and select Create New to configure a password policy.

Create New Password Policy
Name:

User Password Complexity
Minimum length: 8
@ Check for password complexity
Minimum upper-case letters: 2
Minimum lower-case letters: 2
Minimum numeric characters: 2
Minimum non-alphanumeric characters: 1

@ Use non-alphanumeric characters in random passwords — $&i%#-

User Password Change Policy
Enable password expiry
Maximum password age: 90 days (min. 14 days)

Send password renewal reminder 14731 day(s) before expiry.
on:

Enforce password history

Number of passwords to 3
remember:

Enable random password expiry

Random passwords expire after: 72 hours (1-168)
New user set password email link |24 hours {1-168)
expiry:

“ ceneel

To set password complexity requirements:

1. Under User Password Complexity, enter the minimum password length in the Minimum length field.

Al
‘Q' The default length is 8. The minimum length is 0, which means that there is no minimum
- length but the password cannot be empty.

2. Optionally, select Check for password complexity and then configure the following password requirements as
needed:

e Minimum upper-case letters
¢ Minimum lower-case letters
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¢ Minimum numeric characters

¢ Minimum non-alphanumeric characters
You can also enable Use non-alphanumeric characters in random passwords and enter the characters in
the field provided.

3. Select OK to apply the password length and complexity settings.

To set a password change policy:

1. Under User Password Change Policy, optionally select Enable password expiry, then set the
Maximum password age. When enabled, users are required to change their passwords after a period of time.
Users are notified by email when their password is expiring. Accounts with expired passwords are disabled.

The default maximum password age is 90 days. The minimum value allowed is 14 days.
You can also set the password renewal reminder intervals in the Send password renewal reminder on field
available, separating each entry by a comma. The default is every 14, 7, 3, and 1 days.

2. Optionally, select Enforce password history to prevent users from creating a new password that is the same as
their current password or recently used passwords. Then, enter the Number of passwords to remember. New
passwords must not match any of the remembered passwords.

For example, if three passwords are remembered (set by default), users cannot reuse any of their three previous
passwords.

3. Optionally, select Enable random password expiry to force randomly generated passwords to expire. Then, enter
the number of hours after which a randomly generated password will expire in the Random passwords expire
after field.

The default randomly generated password expiry age is 72 hours (or three days). The value can be set from 1 to
168 hours (or seven days).

You can also set the number of hours users have to set a new password upon receiving a new password email link.
The defaultis 24 hours. The value can be set from 1 to 168 hours (or seven days).

4. Select OK to create the password policy.

Custom user fields

You can configure custom fields to include in the user information of local users. See Local users on page 81 for
information about creating and managing local users.

To edit custom fields, go to Authentication > User Account Policies > Custom User Fields. A maximum of three
custom fields can be added.

Tokens

To configure token policy settings, go to Authentication > User Account Policies > Tokens.
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Edit Token Policy Settings

FortiTokens

TOTP authentication window 1 time steps (1-60)
size:

HOTP authentication window 3 counts (1-100)
size:

TOTP sync window size: &0 time steps (5-480)
HOTP sync window size: 100 counts (5-500)

Seed encryption passphrase:

FAC Agent Offline FortiToken Support
& Enable offline support

Shared secret:

TOTP cache size: 7 days (1-14)

HOTP cache size: 10 counts (1-1000)
FortiToken Maobile Transfer

& Enable token transfer feature

Ernail/SMS

Token timeout: 60 seconds (10-3600)

Configure the following settings:

FortiTokens
TOTP Configure the length of time, plus or minus the current time, that a FortiToken
authentication code is deemed valid, from 1 - 60 minutes. The default is set to 1 minute.
window size
HOTP Configure the count, or number of times, that the FortiToken passcode is
authentication deemed valid, from 1 - 100 counts. The default is set to 3 counts.
window size
TOTP sync Configure the period of time in which the entry of an invalid token can trigger a
window size synchronization, from 5 - 480 minutes. The default is set to 60 minutes.
If the token is incorrect according to the FortiToken valid window, but exists in
the sync window, synchronization will be initiated.
HOTP sync Configure the count, or number of times, that the entry of an invalid token can
window size trigger a synchronization, from 5 - 500 counts. The default is set to 100 counts.
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If the token is incorrect according to the FortiToken valid window, but exists in
the sync window, synchronization will be initiated.

Seed encryption Passphrase to derive a seed encryption key from, for seed returned when
passphrase provisioning a FortiToken Mobile via web service (REST API).

FortiAuthenticator Agent Offline FortiToken Support

Enable offline Configure to allow the Windows Agent to cache future tokens for users when

support they are offline. Enable this option to set the following:

Shared secret: Set the shared secret used in offline support.

TOTP cache size: Period of time after last login to pre-cache offline
TOTP tokens, from 1 - 14 days. The default is set to 7 days.

HOTP cache size: Period of time after last login to pre-cache offline
HOTP tokens, from 1 - 1000 counts. The defaultis set to 10 counts.

FortiToken Mobile Transfer
Enable token Enable to let users securely transfer FortiToken Mobile tokens from one mobile

device to another. See Transferring FortiToken Mobile tokens from old to new
devices on page 79 below.

transfer feature

Email/SMS

Token timeout Set a time after which a token code sent via email or SMS will be marked as
expired, from 10 - 3600 seconds (or one hour). The default is set to 60 seconds.

Transferring FortiToken Mobile tokens from old to new devices

Changing devices requires the user to install new tokens on their new device because the unique device ID is used to
form the seed decryption key.

If you wipe data from your device, or upgrade your device, you will need to re-provision your
accounts.

The option to Enable token transfer feature is available under Authentication > User Account Policies > Tokens.

FortiToken Mobile Transfer

& Enable token transfer feature

If it is not enabled, FortiAuthenticator blocks all requests to Transfer Activation Code (see below).
The process for transferring a token to a new device is as follows:

1. The end user selects a new FortiToken Mobile menu option: Initiate Token Transfer.

FortiToken Mobile requests a new "Token Transfer Request” service from FortiCare, and includes the token data.
FortiCare stores the token data and creates a Transfer Activation Code.

FortiCare signals back to FortiToken Mobile on the old device that "Transfer Initialization" is complete.

On the old device, FortiToken Mobile sends a request to FortiAuthenticator for the Transfer Activation Code.

o o
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6. FortiAuthenticator retrieves the Transfer Activation Code from FortiCare and signals back to FortiToken Mobile
(on the old device) that the Transfer Activation Code request was successful.

7. FortiAuthenticator sends either an email or SMS to the end user with the transfer code (as a QR code in the case of
email).

8. Onthe new device, the end user selects the FortiToken Mobile menu option Complete Token Transfer and enters
the transfer code (or scans the QR code).

9. FortiToken Mobile receives the token data from FortiCare and installs the token(s) on the new device.

\,

S L4
? All tokens are removed on the old device after the transfer is complete.

User management

The FortiAuthenticator user database has the benefit of being able to associate extensive information with each user, as
you would expect of RADIUS and LDAP servers. This information includes whether the user is an administrator, uses
RADIUS authentication, or uses two-factor authentication, and includes personal information such as full name,
address, password recovery options, and the groups that the user belongs to.

The RADIUS server on FortiAuthenticator is configured using default settings. For a user to authenticate using RADIUS,
the option Allow RADIUS Authentication must be selected for that user’s entry, and the FortiGate unit must be added
to the authentication client list. See RADIUS service on page 135.

Administrators

Administrator accounts on FortiAuthenticator are standard user accounts that are flagged as administrators. Both local
users and remote LDAP users can be administrators.

Once flagged as an administrator, a user account’s administrator privileges can be set to either full access or customized
to select their administrator rights for different parts of FortiAuthenticator.

The subnets from which administrators are able to log in can be restricted by entering the IP addresses and netmasks of
trusted management subnets.

There are log events for administrator configuration activities. Administrators can also be configured to authenticate to
the local system using two-factor authentication.

An account marked as an administrator can be used for RADIUS authentication if Alow RADIUS Authentication is
selected. See RADIUS service on page 135. These administrator accounts only support Password Authentication
Protocol (PAP).

Administrator accounts can be synced from the primary standalone device to load-balancer in an HA load-balancing
configuration when Sync in HA Load Balancing mode is enabled.

See Configuring a user as an administrator on page 87 for more information.

s‘ ! ', Whenever an admin attempts to add, edit, or delete an admin account in FortiAuthenticator, a
q dialog is displayed requesting the password for the currently logged in administrator before
= settings can be saved.
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Groups for administrators

Local and remote user accounts with administrator or sponsor roles can be entered into groups. This provides the
following benefits:

o Group filtering of administrators.
« Asingle account for individuals needing both administrator and user roles.
« Inclusion of RADIUS attributes from groups in RADIUS Access-Accept responses.

Local users

Local user accounts can be created, imported, exported, edited, and deleted as needed. Expired local user accounts can
be purged manually or automatically (see User account policies on page 73).

To manage local user accounts, go to Authentication > User Management > Local Users.

The local user account list shows the following information:

Create New Select to create a new user.

Import Select to import local user accounts from a CSV file or FortiGate configuration file.

If using a CSV file, it must have one record per line, with the following format: user
name (30 characters max), first name (30 characters max), last name (30
characters max), email address (75 characters max), mobile number (25
characters max), password (optional, 128 characters max), two-factor auth,
custom field 1, custom field 2, custom field 3, enable FortiToken-auth only (no
password), and group names.

If the optional password is left out of the import file, the user is emailed temporary
login credentials and requested to configure a new password.

Note that, even if an optional field is empty, it still must be defined with a comma.
Multiple groups can be separated by a semi-colon, e.g., g1;92;93.

Import error handling: If any error is detected (e.g., duplicate user, invalid field,
etc), none of the local user accounts from the CSV file are created. For
FortiAuthenticator to successfully add the imported local users from a CSV file to
the specified groups:
« All the specified local groups must already exist on the FortiAuthenticator.
« Ifaline is missing the group field (e.g., CSV export from a previous
FortiAuthenticator version), FortiAuthenticator assumes no group

membership.
Export Users Select to export the user account list to a CSV file.
Edit Select to edit the selected user account.
Delete Select to delete the selected user account or accounts.
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Disabled Users

Search

User

First name
Last name
Email address

Admin

Status

Token

Token requested
Groups
Authentication Methods

Expiration

Adding a user

Purge Disabled: This offers the option to choose which type of disabled users to
purge. All users matching the type(s) selection are deleted.

Re-enable: This allows the administrator to re-enable disabled accounts. Expired
users accounts can only be re-enabled individually.

Enter a search term in the search field, then select Search to search the user
account list.

The user accounts’ usernames.

The user accounts’ first names, if included.

The user accounts’ last names, if included.

The user accounts’ email addresses, if included.

If the user account is set as an administrator, a green circle with a check mark is
shown.

If the user account is enabled, a green circle with a check mark is shown.

The token that is assigned to that user account. Select the token name to edit the
FortiToken, see FortiToken device maintenance on page 111.

The status of the user's token request.
The group or groups to which the user account belongs.
The authentication method used for the user account.

The date and time that the user account expires, if an expiration date and time
have been set for the account.

When creating a user account, there are three ways to handle the password:

1. The administrator assigns a password immediately and communicates it to the user.
2. FortiAuthenticator creates a random password and automatically emails it to the new user.
3. No password is assigned because only token-based authentication will be used.

FortiAuthenticator 6.3.1 Administration Guide

Fortinet Technologies Inc.

82



Authentication

To add a new user:

1. Inthelocal users list, select Create New. The Create New Local User window opens.

2. Enter the following information:

Username

Password creation

Allow RADIUS authentication

Force password change on
next logon

Role

Enable account expiration

Expire after

IAM

Enter a username for the user.

Select one of the options from the dropdown menu:

¢ Specify a password: Manually enter a password in the Password field,
then reenter the password in the Password confirmation field.

¢ Set and email a random password: Enter an email address to which to
send the password in the Email address field, then reenter the email
address in the Confirm email address field.

¢ No password, FortiToken authentication only: After you select OK,
you will need to associate a FortiToken device with this user. See
FortiToken physical device and FortiToken Mobile on page 110.

For a user to authenticate using RADIUS, this must be enabled.

Enable or disable the option for users to change their local password on
FortiAuthenticator at first logon. This feature prevents administrators from
having to call or email the franchisee to deliver user credentials, which is not a
secure method of delivery and adds additional time to the onboarding process.

Select whether the new account is for an Administrator, Sponsor, or regular
User. Administrators can either have full permissions or have specific
administrator profiles applied. Regular users can have their account expiration
settings configured.

When creating a new administrator account, you are prompted to enter the
password of the currently logged in administrator before changes can be
saved.

Select to enable user account expiration, either after a specific amount of time
has elapsed, or on a specific date.

Select when the account will expire:
¢ Set length of time: Enter the number of hours, days, months, or years
until the account expires.
¢ Set an expire date: Enter the date on which the account will expire,
either by manually typing it in, or by selecting the calendar icon and
selecting a date.

Add this local user to an IAM account.

3. Select OK to create the new user. You are redirected to the Change local user window to continue the user

configuration in greater detail.

If the password creation method was set to No password, FortiToken authentication only, you are required to
associate a FortiToken with the user before the user can be enabled.

Editing a user

User accounts can be edited at any time. To edit a user, go to the user account list, select a user to edit, and select Edit

from the toolbar. Conversely, select the username in the user list.
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System >

Authentication v

& User Account Policies »
Local Users

Remote Users

Remote User Sync Rules
Social Login Users
Guest Users

User Groups

Usage Profile

Organizations

Realms
FortiTokens
MAC Devices
& Self-service Portal >
& Portals >
£8 Remote Auth. Servers >
& RADIUS Service >
& LDAP Service >
& OAuth Service >
B samLidp >
§8 FAC Agent »
Fortinet 550 Methods >
Monitar >
Certificate Management >
Logging >

Edit Local User

Username:

» Disabled
@ Password-based authentication | Cchange Password
@ Token-based authentication
FortiToken SMS Dual (Email & SMS) Test Token

Deliver token code by: Email

» Allow RADIUS authentication
@0 Enable account expiration

@ Set length of ime (O Set an expiry date

Expire after:
dayls)  |v
7 Force password change on next logon
T Sync in HA Load Balancing mode
User Role
Role:

» Allow LDAP browsing

Administrator

User Information
Alternative Email Addresses
Password Recovery Options
Groups

Usage Information

Ernail Routing

RADIUS Attributes
Certificate Bindings

Devices

Cancel

The following information can be viewed or configured:

Username

Disabled

Password-based authentication

Token-based authentication

Allow RADIUS authentication

Enable account expiration

Force password change on next

logon

The username cannot be changed.

Select to disable the user account.

Select to enable password-based authentication.
The user's password can be changed by selecting Change Password.

Select to enable FortiToken-based authentication. See Configuring token-
based authentication on page 86.

Select to allow RADIUS authentication. This applies only to regular users.

Select to enable account expiration and specify the account's expiration. See
Enable account expiration on page 83.

Require the user to change their password on their next logon. Once changed,
this setting will be automatically disabled again.
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Sync in HA Load Balancing mode

User Role

Role

Allow LDAP
browsing

Full permission

Web service
access

Restrict admin
login from trusted
management
subnets only

User Information

Alternative email addresses

Password Recovery Options

Groups

Usage Information

Email Routing

Select to sync the administrator across load-balanced FortiAuthenticator
devices from the primary standalone device to load-balancers.

Configure the user’s role.

Select Administrator, Sponsor, or User.

If setting a user as an administrator, see Configuring a user as an
administrator on page 87.

Select to allow LDAP browsing. This applies only to regular users.

Enable to grant this administrator full permission, or enter an Admin profile in
the field provided. This applies only to administrators.

Enable to allow this administrator to access the web services either through a
REST API or using a client application. This applies only to administrators.
After enabling Web service access and saving your changes, the User

API Access Key window is displayed allowing you to view, copy, and/or email
the APl access key.

Enable and enter trusted IP addresses and netmasks for restricted
administrator login access. This applies only to administrators.

Enter user information, such as their address and phone number. See Adding
user information on page 87.

Add alternate email addresses for the user.

\y
‘Q' In LDAP, alternative email addresses are defined by the
- rfc822MailMember attribute.

Configure password recovery options for the user. See Configuring password
recovery options on page 88

Assign the user to one or more groups. See Local users on page 81.

View the user's usage information, including bytes in/out, time used, and the
option to reset the usage statistics.

Enter a mail host and routing address into their respective fields to configure
email routing for the user.
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TACACS+ Authorization Add a TACACS+ authorization rule. See Assigning authorization rules on
page 149.
RADIUS Attributes Add RADIUS attributes. See RADIUS attributes on page 109.

available only when Sync in HA Load Balancing mode is

s‘é’, For administrator and sponsor user roles, this field is
- enabled.

Certificate Bindings Add, edit, or removed certificate bindings for the user account. See
Configuring certificate bindings on page 89.
Select the certificate name to view the certificate, or select the Revoke
Certificate button to revoke the certificate.

available only when Sync in HA Load Balancing mode is

s‘é’, For administrator and sponsor user roles, this field is
= enabled.

Devices Add devices, based on MAC address, for the user account.

Select OK when you have finished editing the user’s information and settings.

Configuring token-based authentication

Token-based authentication requires either a FortiToken device or a mobile device with the FortiToken Mobile app
installed, or a device with either email or SMS capability.

FortiToken and FortiToken Mobile tokens must first be registered under Authentication > User Management >
FortiTokens. For more information, see FortiTokens on page 105.

To configure an account for token-based authentication:

1. To view the token-based authentication options, edit a user and select Token-based authentication.
2. Select one of the following token delivery methods:
« FortiToken, then select the type of FortiToken used from the available options.
« Hardware, then select the FortiToken device serial number from the Token dropdown menu.

+ Mobile, then select the FortiToken Mobile device serial number from Token dropdown menu, and select
an Activation delivery method from Email or SMS.

¢ Cloud, then select an Activation delivery method from Email or SMS.
The device must be known to FortiAuthenticator. See FortiToken physical device and FortiToken Mobile on
page 110.

Optionally, select Temporary token to receive a temporary token code via email or SMS.

If the Temporary token is enabled with Email or SMS, the user configured for 2FA receives an OTP via email or
SMS when attempting a 2FA login. This helps the user access the network with a temporary OTP in case they
do not have access to their phone or a hardware token.
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Al
‘Q' The temporary token based authentication is automatically disabled the next time the

end-user does a successful login using their FTK/FTM.

« Email, then enter the user’'s email address in the User Information section.
« SMS, then enter the user’s mobile number in the User Information section.
« Dual (Email & SMS), then enter the user's email address and mobile number in the User Information section.

3. Select Test Token to validate the token passcode. The Test Email Token or Test SMS Token window opens
(depending on your selection).

« For email and SMS tokens, confirm that the contact information is correct, select Next, then enter the token
code received via email or SMS.

« Select Back to return to edit the contact information, select Verify to verify the token passcode, or select
Resend Code if a new code is required.

« For FortiToken, enter the token code in the Token code field, then select Verify to verify the token passcode.
4. Select OK.

W By default, token code verification must be completed within 60 seconds after the token
‘Q' code is sent by email or SMS. To change this timeout, go to Authentication > User
- Account Polices > Tokens and modify the Email/SMS Token timeout field. For more

information, see Lockouts on page 75.

Configuring a user as an administrator
For more information, see Administrators on page 80.

To set a user as an administrator:

1. Edit a user and set Role to Administrator under the User Role section.

2. Enable Full permission to give the administrator full administrative privileges, or enter Admin profiles to
customize the administrator’s permissions.

3. Optionally, enable Web service access to allow the administrator to access the web services via a REST API or
FortiAuthenticator Agent for Microsoft Windows.

4. Select Restrict admin login from trusted management subnets only, then enter the IP addresses and
netmasks of trusted management subnets in the table, to restrict the subnets from which an administrator can log in.

5. Select Sync in HA Load Balancing mode to allow the administrator to be synced from the primary standalone
device to load balancers in an HA load balancing configuration.

6. Select OK to save your changes.
A dialog appears requesting the password for the currently logged in admin account. Enter your password and click
Validate.

Adding user information

Some user information can be required depending on how the user is configured. For example, if the user is using token-
based authentication by SMS, a mobile number and SMS gateway must be configured before the user can be enabled.

The following user information can be entered:
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First name Last name
Email address Phone number
Mobile number SMS gateway: select from the dropdown menu. Select

Test SMS to send a test message.
Street address

City State/Province
Country: Select from the dropdown menu.
Language: Select a specific language from the dropdown menu, or use the default language.

FortiToken Logo: Select a FortiToken Mobile logo from the dropdown menu. See FortiTokens on page 105.

Configuring password recovery options

To replace a lost or forgotten password, FortiAuthenticator can send the user a password recovery link by email orin a
browser in response to a pre-arranged security question. The user must then set a new password.

To configure password recovery by email:

1. Edit a user and ensure that the user has an email address entered. See Adding user information on page 87.

2. Under Password Recovery Options section, enable Email recovery.
In the event that additional email addresses have been configured under Alternative Email Addresses, an email is
sent to all configured email addresses.

3. Select OK to apply the changes.

To configure password recovery by security question:

1. Editauserand, under Password Recovery Options, enable Security question, and select Edit.

2. Choose one of the questions from the dropdown menu, or select Write my own question and enter a question in
the Custom question field.

Enter the answer for the question in the Answer field.
Select OK to create the security question.
Select OK again to apply the changes to the user account.

U

How the user can configure password recovery by security question:

Log in to the user account.
Select Edit Profile at the top left of the page.
Under Password Recovery Options, select Security Question, and select Edit.

Choose one of the questions in the list, or select Write my own question and enter a question in the Custom
question field.

. Enter the answer for your question.
6. Select OK.

P obh-=
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How the user can configure password recovery by email:

o oN-=

Log in to the user account.

Select Edit Profile at the top left of the page.

Under Password Recovery Options, select Email recovery.

Optionally, select Alternative email addresses and enter additional email addresses for this user.
Select OK.

How the user recovers from a lost password:

1.

ol

Browse to the IP address of the FortiAuthenticator.

Security policies must be in place on the FortiGate unit to establish these sessions.

At the login screen, select Forgot my password.

Select to recover your password either by Username or Email.

Enter either your username or email address as selected in the previous step, and select Next.

This information is used to select the user account. If your information does not match a user account, password
recovery cannot be completed.

Do one of the following:
« Ifan email address was entered, check your email, open the email and select the password recovery link.
« If a username was entered, answer the security question and select Next.

On the Reset Password page, enter and confirm a new password and select Next.
The user can now authenticate using the new password.

Active Directory users password reset

To allow Active Directory (AD) users to reset their password from the main login page, follow the same workflow for
resetting a local user's password described above.

The Password Recovery Options setting is included in the remote LDAP users configuration page.

This feature is available for both self-service and guest portals.

Configuring certificate bindings

To use a local certificate as part of authenticating a user, you need to:

« Create a user certificate for the user (see To create a new certificate: on page 212 for more information).
« Create a binding to that certificate in the user’s account.

To create a binding to a certificate in a user’s account:

Edit a user and expand the Certificate Bindings section.
Select Add Binding.

Select either Local CA or Trusted CA from the CA certificate dropdown menu, and select the applicable CA
certificate.

Enter the Common Name on the certificate. For example, if the certificate says CN=rgreen then enter rgreen.
Select OK to add the new binding.
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Local user account password storage

FortiAuthenticator protects local user account passwords in its storage using cryptography:

» Password storage for local user accounts with the "sponsor" or "administrator" role always uses irreversible
cryptography (i.e. bcrypt hash).
» Password storage for local user accounts with the "user" role depends on the Enhanced cryptography for
storage of local user passwords option under Authentication > User Account Policies > General:
« Ifenabled, irreversible cryptography (i.e. bcrypt hash) is used.
« Ifdisabled, reversible cryptography (i.e. AES256) is used.

Remote users

Remote LDAP users must be imported into the FortiAuthenticator user database from LDAP servers. For more
information, see LDAP on page 126.

Note that you will only be able to import a maximum of five remote users if you have an unlicensed version of
FortiAuthenticator-VM.

Ay
‘Q' A FortiToken device already allocated to a local account cannot be allocated to an LDAP user
- as well; it must be a different FortiToken device.

Remote RADIUS users can be created, migrated to LDAP users, edited, and deleted.

LDAP users

To import remote LDAP users:

1. Go to Authentication > User Management > Remote Users, ensure that LDAP users is selected, and select
Import.

2. Select a server from the Remote LDAP server dropdown menu, then select Import users or Import users by
group membership, and select Go.

\‘é', An LDAP server must already be configured to select it in the dropdown menu. For

information on adding a remote LDAP server, see Remote authentication servers on page
126.

The Import Remote LDAP Users or Import Remote LDAP Users by Group Memberships window opensin a
new browser window.
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Import Remote LDAP Users

LDAP server: 172.25.176.140:389
Filter: (objectClass=person)
Apply Clear [ Configure user attributes ]

& Filter child nodes and show number of children

Select user(s) to import below. Only LDAP entries that are marked green can be imported (indicating that
these entries match the configured LDAP filter and their usernames can be found using the configured
username attribute). You can configure other user mapping attributes above.

Select Visible Select Mone
| |J CMN=Administrator
|l [[]CJ €N=Bob Dillian  Fir
| [[]CJ CN=Fortinet F550
| (] CN=Grace Gunderson
|
|
|

L) CN=Guest Username:
(] CH=Jason Michaels
[ZJ CN=5teph Lowe

() CN=krbtgt
Distinguished name: CM=Users,DC=FortiDocs, DC=com
Organization: [ Please Select] ¥

3. Optionally, enter a Filter string to reduce the number of entries returned, and then select Apply, or select Clear to
clear the filters.

NP Please note that the Member attribute field is only available if you select to Import users
‘Q' by group membership. Use this field to specify the filter by which users will be shown. In
- the example, the default attribute (member) will only show users that are members of

groups (users must be part of member attribute of the groups).

4. The default configuration imports the attributes commonly associated with Microsoft Active Directory LDAP
implementations. Select Configure user attributes to edit the remote LDAP user mapping attributes.

Selecting the field FirstName, for example, presents a list of detected attributes that can be selected. This list is not
exhaustive as additional, non-displayed attributes may be available for import. Consult your LDAP administrator for
a full list of available attributes.

5. Select the entries you want to import.

6. Optionally, select a logo from the FortiToken Logo dropdown menu to associate the imported users with the
specified logo. This logo is displayed beside the one-time password in FortiToken. See FortiTokens on page 105 for
more information.

7. Select OK.

The amount of time required to import the remote users will vary depending on the number of users to import.

To add two-factor authentication to a remote LDAP user:

1. Edit the remote user, select Token-based authentication, and follow the same steps as when editing a local user
(Editing a user on page 83).
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2. Configure the User Role, User Information, RADIUS Attributes, and Certificate Bindings for the user as

needed.

3. Select OK to apply the changes.

RADIUS users

To view remote RADIUS users, go to Authentication > User Management > Remote Users and select RADIUS
users in the toolbar. See RADIUS on page 131 for more information about remote RADIUS servers.

The following options are available (when remote RADIUS users are available to edit):

Create New
Delete

Edit
Re-enable

Migrate

Token

Search

Username

Remote RADIUS server

Admin
Status
Token

Token Requested

Enforce token-based

authentication

Select to create a new remote RADIUS user.

Select to delete the selected user or users.

Select to edit the selected user.

Select to re-enable the status of a user that has been disabled.

Select to migrate the selected user or users. See To migrate RADIUS users to
LDAP users: on page 94.

Select to either Enforce or Bypass token-based authentication for the selected
user(s).

Search the remote RADIUS user list.

The remote user’'s name.

The remote RADIUS server or which the user resides.

Displays whether or not the user is configured as an administrator.
Displays whether or not the user is enabled or disabled.

The FortiToken used by the user, if applicable.

Displays whether or not a FortiToken has been requested for the user.

Displays whether or not token-based authentication is enforced.

To create a new remote RADIUS user:

1. From the remote user list, select RADIUS users and select Create New.

2. Enter the following information:

Remote RADIUS

Select the remote RADIUS server on which the user will be created from.
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Username
Disabled

Enforce token-based
authentication if configured
below

Token-based authentication

Deliver token
code by

Sync in HA Load Balancing mode

Allow RADIUS authentication
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For more information on remote RADIUS servers, see RADIUS on page
131.

Enter a username.
Select to disable the user account.

Select to enforce token-based authentication, if you are configuring token-
based authentication.

Select to configure token-based authentication.

Select the method by which token codes are delivered:
* FortiToken, then select the type of FortiToken used from the
available options.

* Hardware, then select the FortiToken device serial number from
the Token dropdown menu.

* Mobile, then select the FortiToken Mobile device serial number
from Token dropdown menu, and select an Activation delivery
method from Email or SMS.

¢ Cloud, then select an Activation delivery method from Email
or SMS.

The device must be known to FortiAuthenticator. See FortiToken physical
device and FortiToken Mobile on page 110.

Optionally, select Temporary token to receive a temporary token code
via email or SMS.

If the Temporary token is enabled with Email or SMS, the user configured
for 2FA receives an OTP via email or SMS when attempting a 2FA login.
This helps the user access the network with a temporary OTP in case they
do not have access to their phone or a hardware token.

automatically disabled the next time the end-user does a

s‘é’, The temporary token based authentication is
- successful login using their FTK/FTM.

* Email: Enter the user’s email address in the User Information
section.
e SMS: Enter the user's mobile number in the User Information
section.
* Dual (Email & SMS): Enter the user’s email address and mobile
number in the User Information section.
Select Test Token to validate the token passcode. The Test Email
Token or Test SMS Token window opens (depending on your selection).
See Configuring token-based authentication.

Select to sync the administrator across load-balanced FortiAuthenticator
devices from the primary standalone device to load-balancers.

Enable or disable RADIUS authentication.
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User Role

Role

Full Permission

Use backup
password

Restrict admin
login from trusted
management
subnets only

User Information

TACACS+ Authorization

Usage Information

Certificate Bindings

Devices

Configure a remote user's role.

Select whether the remote user is either an Administrator (along with
related permissions), Sponsor, or a regular User.

Select Administrator, Sponsor, or User.

Enable to grant this administrator full permission, or enter an Admin profile
in the field provided. This applies only to administrators.

Enable to set up a backup password to be used when the remote server is
unreachable. This applies to administrator and sponsors only.

Enable and enter trusted IP addresses and netmasks for restricted
administrator login access. This applies to administrator and sponsors
only.

Enter user information as needed. The following options are available:
¢ Email address
¢ Mobile number and SMS gateway
e Language
* FortiToken Logo - see FortiTokens on page 105.

Add a TACACS+ authorization rule. See Assigning authorization rules on
page 149.

View the user's usage information, including bytes in/out, time used, and
the option to reset the usage statistics.

Add, edit, or removed certificate bindings for the user account. See
Configuring certificate bindings on page 89.

Select the certificate name to view the certificate, or select the Revoke
Certificate button to revoke the certificate.

\‘é', For administrator and sponsor user roles, this field is

available only when Sync in HA Load Balancing mode
is enabled.

Add devices, based on MAC address, for the user account.

3. Select OK to create the new remote RADIUS user.

To migrate RADIUS users to LDAP users:

1. From the remote RADIUS users list (see Learned RADIUS users on page 208), select the user or users you need to

migrate, then select Migrate from the toolbar.
2. Select an LDAP server from the dropdown menu and select Next.

3. Enter the distinguished names for the users to migrate, or browse the LDAP tree (see Directory tree overview on

page 150) to find the users.

4. Select Migrate to migrate the user or users.
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SAML users

To view remote SAML users, go to Authentication > User Management > Remote Users and select SAML users.

To create a new remote SAML user:

1. From the remote user list, select SAML users and select Create New.
The Create New Remote SAML User window appears.
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2. Enter the following information:

Remote SAML

Username

Disabled

Token-based authentication

Deliver token code

by

User Information

Select the remote SAML server on which the user will be created from. For
more information on remote SAML servers, see SAML on page 133.

Enter a username.
Select to disable the user account.
Select to configure token-based authentication.

Select the method by which token codes are delivered:
* FortiToken, then select the type of FortiToken used from the available
options.
+ Hardware, then select the FortiToken device serial number from the
Token dropdown menu.

* Mobile, then select the FortiToken Mobile device serial number from
Token dropdown menu, and select an Activation delivery method
from Email or SMS.

* Cloud, then select an Activation delivery method from Email or
SMS.

The device must be known to FortiAuthenticator. See FortiToken physical
device and FortiToken Mobile on page 110.

Optionally, select Temporary token to receive a temporary token code via
email or SMS.

If the Temporary token is enabled with Email or SMS, the user configured for
2FA receives an OTP via email or SMS when attempting a 2FA login. This
helps the user access the network with a temporary OTP in case they do not
have access to their phone or a hardware token.

\‘é', The temporary token based authentication is automatically d

isabled the next time the end-user does a successful login us
ing their FTK/FTM.

* Email: Enter the user’'s email address in the User Information section.
e SMS: Enter the user’s mobile number in the User Information section.
¢ Dual (Email & SMS): Enter the user’s email address and mobile number
in the User Information section.
Select Test Token to validate the token passcode. The Test Email Token or
Test SMS Token window opens (depending on your selection).
See Configuring token-based authentication.

Enter user information as needed. The following options are available:
e First name
* Last name
¢ Email address
¢ Mobile number and SMS gateway
e Language
* FortiToken Logo - see FortiTokens on page 105.

3. Select OK to create the new remote SAML user.
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To import remote SAML users:

1. From the remote user list, select SAML users, and select Import.
The Import remote SAML Users window opens.

2. Select the following:

Remote SAML server Select the remote SAML server on which the users will be imported from. For
more information on remote SAML servers, see SAML on page 133.

Group Select the SAML server group to import users from.

3. Select OK to import the remote SAML users.

Remote user sync rules

Synchronization rules can be created to control how and when remote LDAP and SAML users are synchronized. To view
a list of the remote user synchronization rules, go to Authentication > User Management > Remote User Sync
Rules.

To create a new remote LDAP user synchronization rule:

1. From the Remote User Sync Rules page, select LDAP users, and select Create New.
2. Configure the following settings:

Name Enter a name for the synchronization rule.

Remote LDAP Select a remote LDAP server from the dropdown menu. To configure a remote
LDAP server, see LDAP on page 126.

Base distinguished name Base DN of the remote LDAP server that automatically populates when a
remote LDAP server is selected above.

LDAP filter Optionally, enter an LDAP filter.

Select Set Group Filter to set the LDAP filter. This opens the Set Group
Filter window where you can select one or more groups within the tree to build
the LDAP filter string. Click Use Filter to confirm the selection.

vy
‘?' Once the groups have been selected, the LDAP filter string
is set to the proper syntax that filters the selected groups.

The objectClass and the memberOf portion must be
set according to the User object class and the Group
I membership attribute setting of the remote LDAP

server configuration respectively. See LDAP on page 126.
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Token-based authentication
sync priorities

Sync as
User Role for new user

imports

Remote RADIUS

Sync every

Group to associate users
with

FortiToken Logo

Certificate binding CA

Sync users to IAM Account

Email password recovery

If the LDAP filter is already configured with a non-empty value, selecting Set
Group Filter attempts to interpret the LDAP filter value to preselect the
already configured groups in the LDAP tree. However, if the LDAP filter value
does not match the string generated by Set Group Filter, the existing filter is
ignored, and Set Group Filter opens with no preselected groups. Clicking
Use Filter overwrites the previous LDAP filter.

Select Test Filter to test that the filter functions as expected.
FortiAuthenticator shows an LDAP tree with all the users that match the
current remote LDAP server setting (i.e., the users that the sync rule syncs
when it runs).

Select the required authentication synchronization priorities.
Drag the priorities up and down in the list change the priority order.

Select to synchronize as a remote LDAP user, remote RADIUS user, or a local
user.

Select the user role to assign to remote users. Users assigned the role of
Administrator are granted full permissions.

Specify a remote RADIUS server to associate the imported users with.

This dropdown allows you to select from a list of RADIUS servers. Select the
pen icon to edit the selected RADIUS server, + to create a new RADIUS
server, or x to delete the selected RADIUS server.

This setting is available only when Remote RADIUS User is selected as the
Sync as option.

See RADIUS on page 131.
Select the amount of time between synchronizations.

Optionally, select a group from the dropdown menu with which to associate the
users with, or select Create New to create a new user group. See User groups
on page 101.

When Sync as is set to Remote RADIUS User, this option contains a list of
remote RADIUS user groups to choose from.

Optionally, select a logo from the FortiToken Logo dropdown menu to
associate the imported users with the specified logo. This logo is displayed
beside the one-time password in FortiToken. See FortiTokens on page 105 for
more information.

Select CA certificates from the Certificate binding CA dropdown for users
who use remote user sync rules.

When the Certificate binding common name field is populated (under
LDAP User Mapping Attributes) this field must also be specified.

Select an IAM account to synchronize the remote users with.

When enabled, FortiAuthenticator will enable the email password recovery
setting for new and existing remote LDAP users if they also have a valid email
address.

When disabled (default), the email password recovery setting will not be
available to new or existing remote LDAP users.
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Do not delete synced users
when they are no longer
found on the remote server

Proceed with rule even when
response empty

LDAP User Mapping
Attributes

Debugging Settings

Preview Mapping

Show Sync Fields

Select to ensure that synchronized users are not deleted when they are no
longer found on the remote server. This option is only available when Proceed
with rule even when response empty is disabled.

Select to enforce the synchronization rule even when the LDAP response is
empty. Use this option to delete all users from a FortiAuthenticator group when
synchronization rule returns an empty response. This option is only available
when Do not delete synced users when they are no longer found on the
remote server is disabled.

Warning: This option should be used with caution. An error from the
administrator (e.g. a typo when changing the LDAP query) could cause the
deletion of all existing synchronized users, requiring the administrator to
reprovision any assigned FortiTokens.

Optionally, edit the remote LDAP user mapping attributes.

Optionally, log synchronization details, including LDAP query results. These
log files can be downloaded under Debug Report > LDAP Sync. In addition,
select whether to delete synchronized users when they are no longer found on
the remote server.

Select to preview the LDAP user sync mappings in a new window.

Select to view the user fields that will be synchronized.

3. Select OK to create the new LDAP synchronization rule.

To create a new remote SAML user synchronization rule:

1. From the Remote User Sync Rules page, select SAML users, select Create New.
2. Configure the following settings:

Name

Remote SAML server

SAML group

Token-based authentication
sync priorities

Sync every

Group to associate users
with

FortiToken Logo

Enter a name for the synchronization rule.

Select a remote SAML server from the dropdown menu. To configure a remote
SAML server, see SAML on page 133.

Select a group from the SAML server. SAML groups are retrieved dynamically
from the server.

Select the required authentication synchronization priorities.
Drag the priorities up and down in the list change the priority order.

Select the amount of time between synchronizations.

Optionally, select a group from the dropdown menu with which to associate the
users with. See User groups on page 101.

Optionally, select a logo from the FortiToken Logo dropdown menu to
associate the imported users with the specified logo. This logo is displayed
beside the one-time password in FortiToken. See FortiTokens on page 105 for
more information.
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Do not delete synced users Select to ensure that synchronized users are not deleted when they are no
when they are no longer longer found on the remote server. This option is only available when Proceed
found on the remote server with rule even when response empty is disabled.

SAML User Mapping Optionally, edit the remote SAML user mapping attributes.
Attributes

3. Select OK to create the new SAML synchronization rule.

Guest users

Guest user accounts can be created as needed. Guest users are similar to local users, only they are created with a
restricted set of attributes.

To manage guest user accounts, go to Authentication > User Management > Guest Users.

Users can be authenticated against local or remote user databases with single sign-on using client certificates or SSO
(Kerberos/SAML).

Common use cases might include:

» Hotel receptionists creating room accounts
«» Office staff creating visitor accounts

Newly created account information can be sent to users via email, SMS, or printed out individually.
To create a new guest user/multiple guest users:

1. Go to Authentication > User Management > Guest Users and select Create New.
2. Enter the following information:

Ay
‘?' The "Sponsor" role for local and remote users is equivalent to an administrator with Read-
- Write permissions to the Guest Users sub-menu only.
General
Creation There are three guest user creation methods:
Mode » Express: Quickly create guest user accounts without the need to enter
any user information.
Guest accounts generated this way only have four attributes: Sponsor,
Username (eight random lowercase letters—must be unique from any
other existing user account), Password, and Expiry.
* From CSV file: Create guest user accounts using information from a
CSV file in the following format: <first name>, <last name>, <email>,
<mobile>, <group>.
« Manual Input: Create guest user accounts by manually entering the user
attributes for each guest user.
Expiry date  Set the date that the guest user account(s) will expire.
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Expiry time

Express

Number of
new guest
users

Groups
CSV Import

CSV file
Guest Basic Information

Add Guest
User

User groups

Set the time that the guest user account(s) will expire. The time can either be
manually entered, or defined from four options: Now, Midnight, 6 a.m., or
Noon.

The following is only available when Creation Mode is set to Express.

Number of new guest users to add, up to a maximum of 1000.

Choose user groups from the list available to assign the new guest users.
The following is only available when Creation Mode is set to From CSV file.
Choose a CSYV file to import the user attributes.

The following is only available when Creation Mode is set to Manual Input.

Manually enter guest user information, including their First name, Last name,
Email address, Mobile number, Groups, and Actions. Choose user groups
from the list available to assign the new guest users.

Users can be assigned to groups during user account configuration (see Editing a user on page 83), or by editing the

groups to add users to it.

To view the user groups list, go to Authentication > User Management > User Groups.

S !/ P Note that user groups can be created for MAC devices. However, MAC devices will only be
q available to add in a MAC user group after devices have been created or imported. See MAC
3 devices for more information.

To create a new user group:

1. Go to Authentication > User Management > User Groups and select Create New.

2. Enter the following information:

Name

Type

Users

Password policy

Enter a name for the group.

Select the type of group: Local, Remote LDAP, Remote RADIUS, Remote
SAML, or MAC.

Select users from the search box.
This option is only available if Type is Local.

Select a password policy from the dropdown.
A default password policy is already selected, see Passwords on page 76.
This option is only available if Type is Local.
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Usage Profile

User retrieval

Remote LDAP

Remote RADIUS

LDAP filter

LDAP users

Enable to determine user time and data usage on a granular level.

Select a usage profile from the dropdown. At least one usage profile must already
be configured, see Usage profile on page 103.

This option is only available if Type is Local, Remote LDAP, or Remote
RADIUS.

Determine group membership by selecting either Specify an LDAP filter or Set
a list of imported remote LDAP users.

This option is only available if Type is Remote LDAP.

Select a remote LDAP server from the dropdown menu. At least one remote
LDAP server must already be configured, see Remote authentication servers on
page 126.

This option is only available if Type is Remote LDAP.

Select a remote RADIUS server from the dropdown menu. At least one remote
RADIUS server must already be configured, see Remote authentication servers
on page 126.

This option is only available if Type is Remote RADIUS.

Enter an LDAP filter.

Select Set Group Filter to set the LDAP filter. This opens the Set Group Filter
window where you can select one or more groups within the tree to build the
LDAP filter string. Click Use Filter to confirm the selection.

Ay
‘Q' Once the groups have been selected, the LDAP filter string is
set to the proper syntax that filters the selected groups.

The objectClass and the memberOf portion must be set
according to the User object class and the Group
I membership attribute setting of the remote LDAP server

configuration respectively. See LDAP on page 1.

If the LDAP filter is already configured with a non-empty value, selecting Set
Group Filter attempts to interpret the LDAP filter value to preselect the already
configured groups in the LDAP tree. However, if the LDAP filter value does not
match the string generated by Set Group Filter, the existing filter is ignored, and
Set Group Filter opens with no preselected groups. Clicking Use Filter
overwrites the previous LDAP filter.

Select Test Filter to test that the filter functions as expected. FortiAuthenticator
shows an LDAP tree with all the users that match the current remote LDAP server
setting (i.e., the users that the sync rule syncs when it runs).

This option is only available if Type is Remote LDAP and User retrieval is set to
Specify an LDAP filter.

Select remote LDAP users from the LDAP users search box.
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This option is only available if Type is Remote LDAP and User retrieval is set to
Set a list of imported remote users.

RADIUS users Select remote RADIUS users from the RADIUS users search box.
This option is only available if Type is Remote RADIUS.

Remote saml Select aremote SAML server from the dropdown menu. At least one remote
SAML server must already be configured, see Remote authentication servers on
page 126.

This option is only available if Type is Remote SAML.

SAML users Select remote SAML users from the SAML users search box.

This option is only available if Type is Remote SAML.

MAC devices Select from Available MAC Devices and move them to the Chosen MAC
Devices box to add them to the group.

This option is only available if Type is MAC.
TACACS+ Authorization Select a TACACS+ authorization rule to apply to the user group.

3. Select OK to create the new group.

To edit a user group:

1. Inthe user group list, select the group that you need to edit.
2. Edit the settings as required. The settings are the same as when creating a new group.
3. Select OK to apply your changes.

User groups for MAC-based RADIUS authentication

Once created, MAC user groups can then be used under the MAC-based authentication section of RADIUS clients,
under Authentication > RADIUS Service > Clients. See RADIUS service for more information.

Usage profile

Usage profiles can be created to determine user time and data usage on a granular level.
To view the usage profile list, go to Authentication > User Management > Usage Profile.
To create a new usage profile:

1. Go to Authentication > User Management > Usage Profile and select Create New.
2. Enter the following information:

Name Enter a name for the profile.
Description Optionally, enter information about the usage profile.
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Time Usage Select how time usage is determined.

Time limit For this profile, the user's time limit will be either unlimited or measured from
the moment their account was created, from when they first logged on, or how
much time they have used.

When the method has been chosen, enter the time period, in either minutes,
hours, days, weeks, or months. The default is set to seven days.

Data Usage Select how data usage is determined.

Data limit For this profile, the user's data limit will either be unlimited or restricted to the
amount of data they have used.

If you want to limit data usage, enter the data amount in either KB, MB, GB, or
TB. The defaultis setto 1 GB.

Time Schedule Select the timezone the usage profile should follow.

Timezone Timezone the usage profile should follow. The defaultis set to (GMT) UTC -
No Daylight Savings.

3. Select OK to add the new usage profile.

Realms

Realms allow multiple domains to authenticate to a single FortiAuthenticator unit. LDAP, RADIUS, and SAML remote
servers are supported. Each RADIUS realm is associated with a name, such as a domain or company name, that is used
during the login process to indicate the remote (or local) authentication server on which the user resides.

For example, the username of the user PJFry, belonging to the company P_Express, would become any of the
following, depending on the selected format:

o PJFry@P_Express
o P_Express\PJFry
o P_Express/PJFry

The FortiAuthenticator uses the specified realm to identify the back-end RADIUS, LDAP, or SAML authentication server
(s) used to authenticate the user.

Acceptable realms can be configured on a per RADIUS server client basis. See Realms on page 104.

To manage realms, go to Authentication > User Management > Realms. The following options are available:

Create New Select to create a new realm.
Delete Select to delete the selected realm or realms.
Edit Select to edit the selected realm.
Name The names of the realms.
User Source The source of the users in the realms.
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Chained token authentication  Available when User source is set to an LDAP server. Enable from the dropdown
with remote RADIUS server menu to chain token authentication with a RADIUS server.

To create a new realm:

1. From the realms list, select Create New.
2. Enter a Name for the realm.

iy
‘?' The realm name may only contain letters, numbers, periods, hyphens, and underscores. It
- cannot start or end with a special character.

3. Select the User source for the realm from the dropdown menu. The options include Local users, or from specific
RADIUS or LDAP servers.

4. Enable Chained token authentication with remote RADIUS server. Note that this option is only available when
selecting a remote LDAP server as the User source. Chained authentication provides the ability to chain two
different authentication methods together so that, for example, a two-factor authentication RSA solution can
validate passcodes via RADIUS.

5. Select OK to create the new realm.

FortiTokens

Go to Authentication > User Management > FortiTokens to view a list of configured FortiTokens. From here,
FortiTokens can be added, imported, exported, edited, deleted, and activated.

See FortiToken physical device and FortiToken Mobile on page 110 for more detailed information.

The following information is shown on the FortiTokens tab:

Create New Create a new FortiToken.

Import Import a list of FortiTokens from a serial number CSV file, a seed CSV file, or from
a FortiGate configuration.

Export FTK Hardware Export the FortiToken list.
Refresh FTM Refresh the Status of a FortiToken Mobile token.
Delete Delete the selected FortiToken(s).
Edit Edit the selected FortiToken.
Activate Activate the selected FortiToken(s).
Search Search the FortiToken list.
Serial number The FortiToken’s serial number.
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Token type The FortiToken type, either FortiToken Hardware or FortiToken Mobile.
Status Whether or not the FortiToken is activated.
Comment Comments about the token.
User The user to whom the FortiToken applies.
Algorithm The FortiToken's encryption.
Size The size of the token.
Drift/Counter The time difference between the FortiAuthenticator and the FortiToken.
Timestep The FortiToken timestep.
FTM license The FortiToken Mobile license applied to the FortiToken.
Platform The FortiToken's platform.
Logos

FortiToken can include an organization's logo. Logos can be associated with local and remote users.

When a user provisions FortiToken Mobile on their device, the organization's logo is automatically pushed to the device,
rebranding the user interface of the FortiToken Mobile application.

Logos can be created, edited, and deleted as needed. Logos are applied to users from the various user management
pages. See Local users on page 81, Remote users on page 90, and Remote user sync rules on page 97 for more
information.

To manage FortiToken's logos, go to Authentication > User Management > FortiTokens > Logos.

The following information is shown on the Logos tab:

Create New Create a new logo.
Delete Delete the selected logo(s).
Edit Edit the selected logo.

To create a new logo:

From the Logos tab, click Create New.

Enter a Name for the organization.

Upload a logo file on your computer. The image can be a maximum of 320x320 pixels, and must be 24-bit PNG file.
Select OK to create the new logo.

A owbdhd-=
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MAC devices

Non-802.1X compliant devices can be identified and accepted onto the network using MAC address authentication. See
Non-compliant devices on page 175 for more information.

Go to Authentication > User Management > MAC Devices to view a list of configured MAC devices. From here, MAC
devices can be created, imported, exported, edited, and deleted.

The following information is shown:

Create New Create a new MAC-based authentication devices.

Import Import a list of MAC devices from a CSV file.
See To import FortiTokens from a CSV file: on page 111

Export Export a list of MAC devices to a CSV file.

Once created/imported, MAC devices can be added to MAC user groups. See User groups for more information.

Device tracking

When enabled, this feature allows end users to self-register their devices, and to have those devices tracked, based on
the device MAC address.

An unregistered device is granted restricted network access, and is redirected to the FortiAuthenticator guest portal. The
user enters valid credentials, then the FortiAuthenticator detects the unregistered device and offers the user an option to
register it. If the user registers the device, it becomes part of their authorized device group and the user is granted
network access on that device (if the user does not register the device, they are redirected to the guest portal login
page).

To link a device to a user configuration, create a new MAC-based authenticaation device entry under Authentication
> User Management > MAC Devices, and enable This device belongs to a user. Similarly, it is possible to link a
device from a user configuration. In either case, names and MAC addresses must be unique.

Create New MAC-based Authentication Device

Mame: printer.fortiad.net
MAC address: 00:22:68:1a:f1:a0
Description:

@ This device belongs to a user

User Type: Remote LDAP  Remote RADIUS
Owner: john.doe w

To fully benefit from this feature, you must use a FortiAuthenticator in conjunction with a FortiGate running FortiOS 6.0+.
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Identity and Account Management (IAM)

FortiAuthenticator allows you to configure IAM users and accounts.

To view IAM users and accounts, go to Authentication > User Management > IAM, and toggle between Users or
Accounts.

The IAM users and accounts list shows the following information:

Create New Select to create an IAM account or user.

Delete Select to delete the selected IAM accounts or users.

Import Select to import IAM users.
In the Import IAM Users window, enter information as shown in To create an IAM
user.

Edit Select to edit the selected IAM account.
In the Edit IAM Account window, enter information as shown in To create an IAM
account.

To create an IAM account:

1. Goto Authentication > User Management > IAM.
2. Select Accounts, and then select Create New.
3. Enter the following information:

Account Name Enter the account name. The name must be unique among all the IAM
accounts.
Alias Enter alias. This must be unique among all the IAM accounts.
4. Click OK.

To create an IAM user:

1. Go to Authentication > User Management > IAM.
2. Select Users, and then select Create New.
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3. Enter the following information:

entication

Username

Administrator

Account

User Type

Local User

Remote LDAP server

LDAP User

4. Click OK.

RAD

IUS attributes

Enter the account name. The name must be unique within the selected IAM
account.

Enable to give this user administrator privileges.
An administrator can manage users within the same account.

From the dropdown, select the account to add this user to.

Use the pen icon to edit the selected account, + to create a new IAM account,
and x to delete the selected IAM account.

Select the user account type, either Local or Remote LDAP.

From the dropdown, select the local user. This option is only available when
the User Type is Local.

From the dropdown, select the Remote LDAP server. This option is only
available when the User Type is Remote LDAP.

From the dropdown, select the LDAP user. This option is only available when
the User Type is Remote LDAP.

Some services can receive information about an authenticated user through RADIUS vendor-specific attributes.
FortiAuthenticator user groups and user accounts can include RADIUS attributes for Fortinet and other vendors.

Attributes in user accounts can specify user-related information. For example, the Default attribute Framed-IP-Address
specifies the VPN tunnel IP address sent to the user by the Fortinet SSL VPN.

Attributes in user groups can specify more general information, applicable to the whole group. For example, specifying
third-party vendor attributes to a switch could enable administrative level login to all members of the Network_Admins

group, or authorize the user to the correct privilege level on the system.

To add RADIUS attributes to a user or group:

1.

Go to Authentication > User Management > Local Users and select a user account to edit, or go to

Authentication > User Management > User Groups and select a group to edit.

In the RADIUS Attributes section, select Add Attribute. The Create New User Group RADIUS Attribute or

Create New User RADIUS Attribute window opens.

Select the appropriate Vendor and Attribute ID, then enter the attribute’s value in the Value field.
Select OK to add the new attribute to the user or group.
Repeat the above steps to add additional attributes as needed.
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FortiToken physical device and FortiToken Mobile

A FortiToken device is a disconnected one-time password (OTP) generator. It is a small physical device with a button
that when pressed displays a six digit token passcode. FortiToken Mobile is an application for mobile devices that
performs the same one-time password function as a FortiToken device.

Each FortiAuthenticator unit or VM is supplied with two trial FortiToken Mobile tokens. To obtain the free FortiToken
Mobile tokens (if they have not been created dynamically on install), select Get FortiToken Mobile trial tokens when
adding a FortiToken Mobile token. This may be required if, for example, you are upgrading an unlicensed
FortiAuthenticator unit to a licensed one, as the old tokens associated with the unlicensed serial number will not be

compatible with the new, licensed serial number. The tokens will still work, but they cannot be reassigned to a new user.

In this case, you must delete the old tokens, and then generate new ones.

Time-based token passcodes require that FortiAuthenticator clock is accurate. If possible, configure the system time to
synchronize with an NTP server.

To perform token-based authentication, the user must enter the token passcode. If the user’s username and password
are also required, this is called two-factor authentication. The displayed code changes every 60 seconds.

FortiAuthenticator supports FortiToken OTP push notifications, or FTMv4 push notifications.
N - /, Using FTMv4, when required to authenticate themselves, FortiToken Mobile users don't have
? to look-up a code in FortiToken and enter the code into their browser. Instead FortiToken
- Mobile is queried and the user just responds to accept the connection and the session is
authenticated.

FortiAuthenticator and FortiTokens
With FortiOS, FortiToken identifiers must be entered into the FortiGate unit, which then contacts FortiGuard servers to
verify the information before activating them.

FortiAuthenticator on the other hand acts as a repository for all FortiToken devices used on your network. It is a single
point of registration and synchronization for easier installation and maintenance.

To register FortiTokens, you must have a valid FortiGuard connection, otherwise any
) ! ’, FortiTokens you enter will have an Inactive status. After the FortiTokens are registered, the
? connection to FortiGuard is no longer essential.
- If a token authentication fails, check that the system time on FortiAuthenticator is correct and
re-synchronize the FortiToken.

To add FortiTokens manually:

1. Go to Authentication > User Management > FortiTokens and select Create New.
2. Selectthe Token type, either FortiToken Hardware or FortiToken Mobile.
3. IfFortiToken Hardware is selected, enter one or more token serial numbers in the Serial numbers field.
You can also import multiple tokens by selecting Import Multiple, or by selecting Add all FortiTokens from the

same Purchase Order and entering a single token's serial number; all tokens associated with that purchase order
will then be imported.
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4. If FortiToken Mobile, enter the Activation codes in the field provided, or select Get FortiToken Mobile free trial
tokens to use temporary tokens.

5. Select OK to add the FortiToken(s).

To import FortiTokens from a CSV file:

1. From the FortiToken list, select Import.
2. Do one of the following:

« Select Serial number file to load a CSV file that contains token serial numbers. FortiToken devices have a
serial number barcode on them used to create the import file.

» Select Seed file to load a CSV file that contains the token serial numbers, encrypted seeds, and IV values.
3. Select Choose File, find the configuration file, and select Open.
4. Select OK to import the FortiTokens.

To import FortiTokens from a FortiGate unit:

1. Export the FortiGate unit configuration to a file.

2. From the FortiToken list, select Import.

3. Select FortiGate configuration file.

4. For Data to import, select either Import FortiToken Hardware only, Import FortiToken Hardware and only
their associated users, or Import all FortiToken Hardware and users.

5. Select Choose File, find the configuration file, and select Open.

6. Ifthefile is encrypted, enter the Password in the field provided.

7. Select OK to import the FortiTokens.

To export FortiTokens:

1. From the FortiToken list, select Export FTK Hardware.
2. Save the file to your computer.

Monitoring FortiTokens

To monitor the total number of FortiToken devices registered on FortiAuthenticator, as well as the number of disabled
FortiTokens, go to System > Dashboard > Status and view the User Inventory widget.

You can also view the list of FortiTokens, their status, token clock drift, and which user they are assigned to from the
FortiToken list found at Authentication > User Management > FortiTokens.

FortiToken device maintenance

Go to Authentication > User Management > FortiTokens, then select the FortiToken you need to perform
maintenance and select Edit. The following actions can be performed:

« Comments can be added for FortiToken.
« The device can be locked if it has been reported lost or stolen.
A reason for locking the device must be entered, and a temporary SMS token can be provided.
» The device can be unlocked if it is recovered.
o The device can be synchronized.
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Synchronize the FortiAuthenticator and the FortiToken device when the device clock has drifted. This ensures that
the device provides the token code that FortiAuthenticator expects, as the codes are time-based. Fortinet
recommends synchronizing all new FortiTokens.

» The device history can be viewed, showing all commands applied to this FortiToken.

FortiToken Mobile licenses

FortiToken Mobile licenses are purchased for a specified number of FortiToken Mobile tokens. Activating a FortiToken
Mobile license imports the FTM tokens to FortiAuthenticator. During activation, Fortinet links the FTM license and
corresponding FTM token's serial numbers with the FortiAuthenticator serial number. After activation on the
FortiAuthenticator, no other FortiAuthenticator or other Fortinet products are permitted to re-use the same FTM license,
however, there is no limit to how many times an FTM license can be re-activated on the same FortiAuthenticator (for
example after a factory reset).

You must contact Fortinet Support to transfer a FortiToken Mobile license to a new FortiAuthenticator unit (for example
for RMA or migration to a new FortiAuthenticator unit).

Portals

The following section describes how to configure captive or self-service portals on a per customer or per AP/controller
basis.

Portals can permit certain pre-login and post-login services for users, including password reset and token registration
abilities.
Policies and access points are used to determine access to the portal.

Social pinholes and replacement messages can be configured to further customize portals.

Beginning in 6.1.0, portal authentication logic is determined by policies, configured in

ﬂ Authentication > Portals > Policies.
I When upgrading from a version prior to 6.1.0, existing guest portal configurations are migrated

into portals, policies, and access points with corresponding settings.
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Portals

To create a portal:

1. Go to Authentication > Portals > Portals, and select Create New.

Create New Portal
Name:

Description:

General

SMS gateway Use default v

Pre-login Services
Disclaimer
Password Reset
Account Registration
Token Revocation
Usage Extension Notifications
Post-login Services
Profile
Password Change
Token Registration
Smart Connect

Device Tracking and Management

2. Enter the following information:
Name Enter the name of the portal.
Description Optionally, enter a description of the portal.
General Assign an SMS gateway for self-registered users.
Pre-login Services Configure various pre-login services to permit to users.
Disclaimer Enable or disable the appearance of a disclaimer to the end-user that must be

accepted before proceeding to the login page.

To configure the disclaimer, edit the Login Disclaimer Page replacement
message under Authentication > Portals > Replacement Messages.

Password Reset Enable or disable pre-login password reset link.
Account Select to configure various user account registration options:
Registration « Require administrator approval: Enable/disable whether the user

FortiAuthenticator 6.3.1 Administration Guide
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requires administrator approval. If enabled, select whether to send admin
approval emails to freeform addresses or to selected user groups.
Account expires after: Enable/disable account expiration. If enabled,
enter the number of hours, days, months, or years the account remains
expired from the dropdown menu.

Use mobile number as username: Determine whether to require the
user's mobile number as their username.

Place registered users into a group: Determine whether to place
registered users into a group from the dropdown menu.

Password creation: Determine whether the user's password is user-
defined or randomly generated.

Enforce contact verification: Enable/disable whether to enforce
contact verification. If enabled, select whether to verify the user's email
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Token Revocation

Usage Extension
Notifications

Post-login Services

Profile

Password Change

Token
Registration

address or mobile number, or allow the user to decide between email
address or mobile number.

¢ New user is automatically logged-in after successful contact
verification: Enable to allow newly registered users to access the guest
network without having to enter their credentials. Disable to require users
to enter their credentials to access the guest network after successful
registration. This option is enabled by default.
Note that this option is not available if Enforce contact verification is
disabled.

¢ Account delivery options available to the user: Determine whether
the user's account information is sent to them by SMS, email, or
displayed on the browser page. If more than one option is selected, the
self-registering user decides which account delivery method to use. If
Require administrator approval is enabled, Display on browser page is
disabled.

* Required field configuration: Configure the available fields required by
the user to enter (First name, Last name, Email address, and Mobile
number are enabled by default).

Select to revoke tokens based on various conditions:

¢ Allow users to report a lost token to the Administrator at this email
address

« Allow users to temporarily use SMS token authentication if a
mobile number was pre-configured

¢ Allow users to temporarily use email token authentication if an
email was pre-configured

¢ Allow users to re-provision their FortiToken Mobile

* Allow users to re-provision their FortiToken Cloud

Allow users who exceeded their time and/or data usage to request an
extension via an email notification.

Configure various post-login services to permit to users.

Select to determine whether authenticated users can view/edit their account
information.

Select to determine whether local and/or remote users have the ability to
change their passwords after they log in.

Select to configure FortiToken Mobile self-provisioning privileges, including:
e Allow FortiToken Hardware self-provisioning
* Allow FortiToken Mobile self-provisioning
* Allow FortiToken Cloud self-provisioning
* Allow Email self-provisioning
e Allow SMS self-provisioning
* Allow user to request a token from Administrator at this email
address
» Restrict token self-provisioning to members of specific group
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Smart Connect Select to assign a Smart Connect profile.
See Smart Connect Profiles for more information.

Device Tracking Select to require users to register their devices after they log in. Registered
and Management devices can be placed into a specified MAC device user group.

3. Select OK to create the new portal.

Token self-revocation

Token self-provisioning is offered as a pre-login service for guest portals.

When the token self-revocation feature is enabled (Authentication > Self-service Portal > Token self-provisioning),
the guest portal's token verification page will have an additional Lost my token link. Clicking this link provides access to
the token self-revocation service page that includes the following options:

» Re-provision my FortiToken Mobile
« Switch to email token authentication
» Disable my account

Post-login device tracking

When the post-login service option Device Tracking and Management is enabled, the administrator must specify into
which device group to put the self-registered devices, as well as specify the Maximum number of devices per user
(up to 20; 3 by default). When enabled, users have access to a post-login interface where they can add/edit/delete their
list of devices. If enabled but the device is not registered, the FortiAuthenticator presents a device registration page after
account credential validation.

If the user reaches their device limit, they must select an existing device to replace. If the MAC address is currently
associated with a different user, it is re-assigned to this newly logged-in user with the following warning message:

"Your device had previously been registered by another user. Ownership has now been changed to your account.”

Policies

Portal policy configuration is available in Authentication > Portals > Policies.

To determine policy priority, FortiAuthenticator attempts to match the portal access request to each policy, starting with
the top policy in the list, and moves down until a match is found. Policy priority can be re-arranged by selecting the up
and down icons next to each policy in the list.

You can change between Captive portals and Self-service portals views using the toggle in the top-right corner of the
GUL.

FortiAuthenticator 6.3.1 Administration Guide 115
Fortinet Technologies Inc.



Authentication

System + Create New

Authentication
[} Name

@ User Management [m] Captive Portal Allow

& Selfservice Portal u] Captive Portal Deny

% Portals Ml 2 Portal Policies

Portals

>
& User Account Policies >
>
>

Policies
Access Points
Pinholes
Replacement Messages
Smart Connect Profiles
S5 Remote Auth. Servers
& RADIUS Service
& LDAP Service
& OAuth Service
B sAamLIdP
&3 FAC Agent
Fortinet S50 Methods
Monitor
Certificate Management

Logging

Self Service Portsl | @

HTTP Parameter Criteria Portal Priority

Search for Portal Policies
Access Points/NAS
172.27.2.247 Allow Access Portal L]

172.27.1.0/24 L]

A\,

For more information on the captive portal workflow, click the help icon in the top-right corner
of the GUI, and select an access point/NAS.

Captive portal policies

There are two types of captive portal policies:

« Allow captive portal access: Presents a captive portal login page when end-users' HTTP requests contain
parameters or values that meet the pre-defined criteria.

« Deny captive portal access: Blocks end-users from accessing a captive portal login page if their HTTP request
contains parameters or values that meet the pre-defined criteria.

To configure an allow access captive portal policy:

1. Goto Authentication > Portals > Policies, click Captive portals and Create New.
The Captive Portal Policy Creation Wizard is launched.

2. Enter the following information:
Policy type
Name
Description
Type

Portal selection criteria

Additional source
criteria
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Specify the name and type of the portal policy.

Enter a name for the policy.

Optionally, enter a description of the policy.

Select Allow captive portal access and choose a portal.

Specify the necessary criteria for presenting this captive portal to an end
user.

Redirects to this captive portal must contain parameters that meet all of the
criteria included here. For example, a condition to restrict the portal to users
from subnet192.168.1.0/24 would be:

e HTTP parameter = userip

e Operator= [ip]in range
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Access points
RADIUS clients
Authentication type

Authentication
type

Identity sources

Social Users

Username format

Use default realm
when user-
provided realm is
different from all
configured realms

Realms

e Value=192.168.1.0/24
Select the access points used to access the captive portal.
Select the RADIUS clients to associate with this portal policy.
Specify the type of end-user authentication used by the portal.

Select either Password/OTP or MAC authentication.

« Password/OTP Authentication: Selected by default, this option
requires authentication with user account credentials (local or remote)
or with social site credentials:

¢ Local/remote user: Credentials are verified against one of the
local or remote user accounts.

¢ Social users: Authentication with social site credentials (OAUTH),
phone number, or email. Successful authentication creates a social
user account containing details about the third-party account.

¢ MAC Authorization: The access point/NAS can attempt a
MAC authentication bypass (MAB) prior to redirecting to the captive
portal. If the MAB is successful, the access point/NAS provides network
access without redirecting to the captive portal.

Specify the identity sources against which to authenticate end users.

Enable authorized redirects to social platforms and specify if phone or email
verification is required.

This setting is only available for Password/OTP Authentication when
Social Users is enabled in Authentication type.

Select one of the following three username input formats:
e username@realm
¢ realm\username
¢ realm/username
This setting is only available for Password/OTP Authentication.

When enabled, FortiAuthenticator selects the default realm for
authentication when the user-specified realm is different from all configured
realms.

Add realms to which the client will be associated.
¢ Select a realm from the dropdown menu in the Realm column.
¢ Select whether or not to allow local users to override remote users for
the selected realm.
¢ Select whether or not to use Windows AD domain authentication.
 Edit the group filter as needed to filter users based on the groups they
arein.
¢ If necessary, add more realms to the list.
¢ Select the realm that will be the default realm for this client.
This setting is only available for Password/OTP Authentication.
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Authentication factors

Authentication
type

User IP address
parameter

Adaptive
Authentication

MAC address
parameter

Restrict access
based on end-
user MAC address

Advanced
Options

Specify which authentication factors to verify.

Select one of the following:
¢ Mandatory two-factor authentication: Two-factor authentication is
required for every user.
¢ Verify all configured authentication factors: Two-factor
authentication is required if it is enabled on the user's account,
otherwise, allow one-factor authentication.
¢ Password-only authentication: Authenticate users through password
verification only. User accounts for which password authentication is
disabled cannot be authenticated.
¢ Token-only authentication: Authenticate users through token
verification only. User accounts for which token authentication is
disabled cannot be authenticated.
This setting is only available for Password/OTP Authentication.

Select the user IP address parameter.

Use userip for FortiGate/FortiWiFi.
Enable this option if you would like to have certain users bypass OTP
validation, so long as they belong to a trusted subnet.
Select All trusted subnets to add all the available trusted subnets.

You can specify the trusted subnets by selecting Specify trusted subnets
and clicking the pen icon. This opens a window where you can choose from a
list of available trusted subnets.

Ay Adaptive Authentication is available only for the following

‘Q' authentication types:
¢ Mandatory two-factor authentication

» Verify all configured authentication factors

Select the MAC address parameter.

Use usermac for FortiGate/FortiWiFi, station_mac for WortiWLC, or client_mac
for Cisco WLC.

Select the authorized MAC device groups.

Authorized groups must be first created under Authentication > User
Management > User Groups, where the Type is MAC.

Toggle on/off FTM Push notifications for RADIUS users.
Allow FortiToken This setting is only controlled here on a per RADIUS client
Mobile push basis, not for specific users.
notifications This setting is only available for Password/OTP
Authentication.

Application name
for FTM push
notification

Enter the client application name. This field is displayed
on the FortiToken app.
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RADIUS response

3. Click Save and exit.

When creating a new policy or upgrading to
FortiAuthenticator 6.3, the policy name is the default
client application name.

Resolve user geolocation
from their IP address

Enable to resolve the user geolocation from
their IP address (if possible).

Enable this setting to reject usernames that
Reject usernames containing contain uppercase letters.
uppercase letters This setting is only available for

Password/OTP Authentication.

Specify the content of the RADIUS authentication response based on the
outcome of the authentication.

To configure a deny access captive portal policy:

1. Go to Authentication > Portals > Policies, click Captive portals and Create New.
The Captive Portal Policy Creation Wizard is launched.

2. Enter the following information:

Policy type
Name

Description

Type

Portal selection criteria

Additional source
criteria

Access points

Browser response

3. Click Save and exit.

Specify the name and type of the portal policy.
Enter a name for the policy.

Optionally, enter a description of the policy.
Select Deny captive portal access.

Specify the necessary criteria for denying captive portal access to an end-
user.

Redirects to this captive portal must contain parameters that meet all of the
criteria included here. For example, a condition to restrict the portal to users
from subnet192.168.1.0/24 would be:

e HTTP parameter = userip

* Operator= [ip]in range

* Value=192.168.1.0/24

Select the portal access points.

End-users must be redirected to the captive portal from one of these access
points/NAS.

The FortiAuthenticator presents an error message to end-users' browsers
when captive portal access is denied.

You can customize the browser response error message at Authentication

> Self-service Portal > Replacement Message > System > 403
Forbidden.
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Self-service portal policies
Self-service portals are accessed directly and allow local and remote users to self-manage their account.

To configure a self-service portal policy:

1. Go to Authentication > Portals > Policies, click Self-service portals and Create New.
The Self-Service Portal Policy Creation Wizard is launched.
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2. Enter the following information:
Policy type
Name
Description

Portal

Identity sources

Username format

Use default realm
when user-
provided realm is
different from all
configured realms

Realms

Authentication factors

Authentication
type

Adaptive
Authentication

Specify the name and type of the portal policy.
Enter a name for the policy.
Optionally, enter a description of the policy.

Allow self-service portal access is enabled by default.
Select a portal.

Specify the identity sources against which to authenticate the end-users.

Select one of the following three username input formats:
e username@realm
¢ realm\username
¢ realm/username

When enabled, FortiAuthenticator selects the default realm for authentication
when the user-specified realm is different from all configured realms.

Add realms to which the client will be associated.

¢ Select a realm from the dropdown menu in the Realm column.

¢ Select whether or not to allow local users to override remote users for the
selected realm.

¢ Select whether or not to use Windows AD domain authentication.

« Edit the group filter as needed to filter users based on the groups they are
in.

« If necessary, add more realms to the list.

» Select the realm that will be the default realm for this client.

Specify which authentication factors to verify.

Select one of the following:

¢ Mandatory two-factor authentication: Two-factor authentication is
required for every user.

» Verify all configured authentication factors: Two-factor authentication
is required if it is enabled on the user's account, otherwise, allow one-
factor authentication.

¢ Password-only authentication: Authenticate users through password
verification only. User accounts for which password authentication is
disabled cannot be authenticated.

» Token-only authentication: Authenticate users through token
verification only. User accounts for which token authentication is disabled
cannot be authenticated.

Enable this option if you would like to have certain users bypass OTP validation,
so long as they belong to a trusted subnet.

Select All trusted subnets to add all the available trusted subnets.
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You can specify the trusted subnets by selecting Specify trusted subnets and
clicking the pen icon. This opens a window where you can choose from a list of
available trusted subnets.

A\l Adaptive Authentication is available only for the following

‘q‘ authentication types:
* Mandatory two-factor authentication

¢ Verify all configured authentication factors

Advanced Options

Allow FortiToken Mobile Toggle to enable or disable FortiToken Mobile
push notifications push notifications for RADIUS users.

Enter the client application name. This field is displayed
Application name  on the FortiToken app.

for FTM push When creating a new policy or upgrading to
notification FortiAuthenticator 6.3, the policy name is the default
client application name.

Resolve user geolocation Enable to resolve the user geolocation from
from their IP address their IP address (if possible).

Reject usernames containing Enable this setting to reject usernames that
uppercase letters contain uppercase letters.

3. Click Save and exit.

Access points
An access point is the address that an end-user must be redirected from in order to access the configured portal.

To create an access point:

1. Go to Authentication > Portals > Access Points, and select Create New.
2. Enter the following information.

Name Enter a name for the access point.

Client address Provide the client address.
Client addresses can be in the format of IP/Hostname, Subnet, or Range.

3. Click OK.

FortiWLC Pinholes

Portal pinhole configuration is available under Authentication > Portals > FortiWLC Pinholes.
Pinhole values can be added to the default list, separated by comma or a new line.

The default pinholes are:
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e www.google.com

« accounts.google.com
 ssl.gstatic.com

« fonts.gstatic.com

« www.gstatic.com

« accounts.youtube.com
» www.facebook.com

« static.xx.fbcdn.net

Replacement messages

Portal replacement message mappings are available under Authentication > Portals > Replacement Messages.

The replacement messages are split into four categories: Authentication, Password Reset, User Registration, and
Post-Login.

Selecting a specific message will display the text and HTML or plain text of the message in the lower half of the content
pane.

Selecting Toggle Tag List will display a table of the tags used for that message above the message’s HTML or plain text
box.

To edit a replacement message:

1. Select a message in the replacement message list.

2. Edit the plain text or HTML code in the lower right pane, or select Open in new window to edit the message in a
new browser window.
To insert custom images into the replacement message, see Manage Images on page 123.

3. When you are finished editing the message, select Save to save your changes.

4. If you have made an error when editing the message, select Restore Default to restore the message to its default
value.

Manage Images

Images can be managed by selecting Manage Images in the Replacement Messages window. Images can be added,
deleted, and edited.

To add an image:

1. From the Manage Images window, select Create New to open the Create New Image window.
2. Inthe Name field, enter a name for the image.

3. Select Upload a file, find the GIF, JPEG, or PNG image file that you want to add, and then select Open.
Note: The maximum image size is 1000 kB.

4. Select OKto add the image.
To insert the image into a replacement message, add the following HTML code:

<img src={{:image/<image name>}}>
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Where <image name> is the name entered for the image. For example, the HTML code for an image named
Acme_logois <img src={{:image/Acme logo}}>

To delete an image:

1. From the Manage Images window, select an image, then select Delete.
2. SelectYes, I’'m sure in the confirmation window to delete the image.

To edit an image:

1. From the Manage Images window, select an image, then select Edit.
2. Inthe Edit Image window, edit the image name and file as required.
3. Select OK to apply your changes.

Smart Connect profiles

Smart Connect profiles are available under Authentication > Portals > Smart Connect Profiles.

This feature provides the ability to set up network settings (such as WiFi configuration) on an endpoint by downloading a
script or an executable (depending on the endpoint's OS) from the FortiAuthenticator portal.

When configured, the Smart Connect feature will show up as a new button on the portal's post-login main page:

Smart Connect

When clicking on the Smart Connect button, the user is given the option to download a self-install file for the OS type of
their choice, including iOS/MacOS and Windows. A device ID can also be entered, however, this is only available if the
Smart Connect profile uses EAP-TLS. If entered, the ID is used to generate the end-user certificate.

To configure a Smart Connect profile:

1. Select Create New to start the profile configuration wizard.
2. Enter a Name and select Next (you cannot configure a different Connect type other than Wireless).
3. Enteran SSID, and select the Auth method to use: WPA2 Personal or WPA2 Enterprise.
You can optionally enable or disable Hidden SSID to show or hide the SSID. When finished, select Next.
4. Enter a Pre-shared Key, then select Next.

5. You can edit the profile to review and change any of the previously set options, and define additional settings, as
shown below:
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Edit Smart Connect Profile

Name: Profilel

Connect type:
Wireless

» Hidden SSID

Authentication: WPA2 Personal |~
SSID:

WHPA2 Personal
Pre-shared Key: sssssses

WPA2 Enterprise

EAP Type: TLS TTLS PEAP
Signing CA: [ Please Select ] ~
Anonymous Identity: Anonymous Username

® Include user credentials in configuration file
Phase 2 Authentication: PAP CHAP MSCHAP MSCHAPv2

Certificate Installation Settings

Install local CA certificates: Available Install Local CA Certificates @ Selected Install Local CA Certificates

Q ilter
RootCA | C=CA, ST=ON, L=Ottawa, O=Local Comp
secure | CN=secure

Choose all

Install trusted CA certificates: Awvailable Install Trusted CA Certificates @ Selected Install Trusted CA Certificates

Q, |Filter

Fortinet_CA1_Reot | C=US, ST=California, L=Sunny

Choose all

“ e

6. Select OK to apply your options and finish the configuration.
When created, a Smart Connect profile can be associated with a guest portal and be available as a post-login
service (see Post-login Services under Portals).

Smart Connect for Windows

The Smart Connect for Windows feature provides an executable file that adds specific network settings to an end-user's
Windows device. The Smart Connect profile settings are the same as the ones implemented for iOS and macOS. The
main difference is in how the downloaded executable file is built and packaged, so that it installs seamlessly on Windows
devices.
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Self-service URL

When using the device tracking feature, users are no longer redirected by the FortiGate after initial device registration.
Instead, the FortiAuthenticator provides a specific URL for each guest portal, as derived from the guest portal name
(under Authentication > Portals > Portals).

When the end user navigates to the self-service URL, they must provide valid credentials to get network access, but the
login does not trigger the call to the FortiGate device's API.

Ay
S L4
q Note that special characters must be encoded in the self-service URL.
Firmware upgrade
When upgrading from a previous release, as a result of the device tracking feature, the
following occurs:
¢ MAB Unauthorized devices are set to Deny access by default for existing RADIUS
A clients.
« MAB Blocked groups are set to empty by default for existing RADIUS clients.
¢ Device tracking and device management are disabled by default for existing guest
portals.

« Existing replacement messages are left unchanged for existing guest portals.
* New (default) replacement messages are added to existing guest portals.

Remote authentication servers

If you already have LDAP or RADIUS servers configured on your network, FortiAuthenticator can connect to them for
remote authentication, much like FortiOS remote authentication.

General

Go to Authentication > Remote Auth. Servers > General to edit general settings for remote LDAP and
RADIUS authentication servers.

Remote LDAP Enter the number of seconds between 1-3600 (or one second to one hour) for the
LDAP server response and status cache timeouts.

Remote RADIUS Select whether the remote RADIUS server requires case sensitive usernames.

LDAP

If you have existing LDAP servers, you may choose to continue using them with FortiAuthenticator by configuring them
as remote LDAP servers.
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\ﬂ When entering the remote LDAP server information, if any information is missing or in the

’ wrong format, error messages will highlight the problem for you.

Ny FortiAuthenticator supports multiple Windows AD server forests, with a maximum of 20 remote
‘?' LDAP servers with Windows AD enabled.
- To view all information about your multiple servers, go to Monitor > Authentication
= > Windows AD.

To add a remote LDAP server entry:

1. Go to Authentication > Remote Auth. Servers > LDAP and select Create New. The Create New LDAP Server
window opens.
Create New LDAP Server
Name:
Primary server name/IP: Port: 389 >

 Use secondary server
Base distinguished name: @

Bind type: m Regular

“» Add supported domain names (used only if this is not a Windows Active Directory server)

Query Elements

Pre-defined templates: --- Please select a template - |+ Apply
User object class: person

Username attribute: sAMAccountMame

Group object class: group

Obtain group memberships from: Group attribute

Group membership attribute: memberOf

“® Force use of administrator account for group membership lookups

Secure Connection

& Enable
Protocol: LDAPS STARTTLS
CA certificate: [ Please Select ] ~

» Use Client Certificate for TLS Authentication
Windows Active Directory Domain Authentication
& Enable
Kerberos realm name:

Domain NetBIOS name:

FortiAuthenticator NetBIOS FortiAuthentica
name:

Administrator username:

Administrator password:

“ Cdncel
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2. Enter the following information.

Name
Primary server name/IP
Port

Use secondary server

Secondary server name/IP

Secondary port

Base distinguished name

Bind Type

Server type

Add supported domain
names (used only if this is
not a Windows Active
Directory server)

Enter the name for the remote LDAP server on FortiAuthenticator.
Enter the IP address or FQDN for this remote server.
Enter the port number.

Select to use a secondary server. The secondary server name/IP and port
must be entered.

Enter the IP address or FQDN for the secondary remote server. This option is
only available when Use secondary server is selected.

Enter the port number for the secondary server. This option is only available
when Use secondary server is selected.

Enter the base distinguished name for the server using the correct X.500 or
LDAP format. The maximum length of the DN is 512 characters.

You can also select the browse button to view and select the DN on the LDAP
server.

The Bind Type determines how the authentication information is sent to the
server. Select the bind type required by the remote LDAP server.
¢ Simple: bind using the user’s password which is sent to the server in
plaintext without a search.
* Regular: bind using the user’s DN and password and then search.
If the user records fall under one directory, you can use Simple bind type. But
Regular is required to allow a search for a user across multiple domains.

Select a LDAP server type and click Apply template to populate the Query
Elements fields with the selected template: Microsoft Active Directory,
OpenLDAP, or Novell eDirectory

Select to enter multiple domain names for remote LDAP server configurations.
The FortiAuthenticator can then identify the domain that users on the LDAP
server belong to.

If you want to want to import a specific LDAP system's template, under Query Elements, enter the following:

User object class
Username attribute

Group object class

Obtain group memberships

from

Group membership attribute

The type of object class to search for a user name search. The default is
person.

The LDAP attribute that contains the user name. The default is
sAMAccountName.

The type of object class to search for a group name search. The default is
group.

The LDAP attribute (either user or group) used to obtain group membership.
The default is User attribute.

Used as the attribute to search for membership of users or groups in other
groups.
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Force use of administrator Enabling this feature prevents non-admin users from searching their own
account for group attributes even after successful binding. This feature has been implemented to
membership lookups enhance Oracle-based ODSEE LDAP support.

4. If you want to have a secure connection between FortiAuthenticator and the remote LDAP server, under Secure
Connection, select Enable, then enter the following:

Protocol Select LDAPS or STARTLS as the LDAP server requires.
CA Certificate Select the CA certificate that verifies the server certificate from the dropdown
menu.

Use Client Certificate for TLS Enable to select a client certificate to use to authenticate a TLS connection
Authentication with the secure remote LDAP server.

5. If you want to authenticate users using MSCHAP2 PEAP in an Active Directory environment, enable Windows
Active Directory Domain Authentication, then enter the required Windows AD Domain Controller information.

Kerberos realm name Enter the domain’s DNS name in uppercase letters.
Domain NetBIOS name Enter the domain’s DNS prefix in uppercase letters.

FortiAuthenticator NetBIOS Enter the NetBIOS name that identifies FortiAuthenticator as a domain
name member.

Administrator username Enter the name of the user account that's used to associate FortiAuthenticator
with the domain. This user must have at least domain user privileges.
To configure an Active Directory user with the minimum privileges needed to
join an AD domain, see Configure minimum privilege Windows AD user
account on page 130.

Administrator password Enter the administrator account’s password.

When you are finished here, go to Authentication > RADIUS Service > Clients to choose whether authentication
is available for all Windows AD users or only for Windows AD users who belong to particular user groups that you
select. See RADIUS service on page 135 for more information.

6. If you wantto import remote LDAP users, under Remote LDAP Users, select either Import users or Import users
by group memberships and click Go. A separate window opens where you may specify the LDAP server, apply
filters, and attributes. Select Configure user attributes to edit the following LDAP user mapping attributes:

Username Enter the remote LDAP user's name.

First name Enter the attribute that specifies the user's first name. Set to givenName by
default.

Last name Enter the attribute that specifies the user's last name. Set to sn by default.

Email Enter the attribute that specifies the user's email address. Set to mail by
default.

Phone Enter the attribute that specifies the user's number. Set to telephoneNumber
by default.

Mobile number Enter the attribute that specifies the user's mobile number. Set to mobile by
default.
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FTK-200 serial number Enter the remote LDAP user's FortiToken serial number.

Certificate binding common Enter the remote LDAP user's certificate-binding CN. When this field is
name populated, the Certificate binding CA must also be specified.

Certificate binding CA Local or trusted CAs to apply for the remote LDAP user. Must be specified if
the Certificate binding common name is populated.

7. Select OK to apply your changes.
You can now add remote LDAP users, as described in Remote users on page 90.

Configure minimum privilege Windows AD user account

To respect the principle of least privilege, a domain administrator account should not be used to associate
FortiAuthenticator with a Windows AD domain. Instead, a non-administrator account can be configured with the
minimum privileges necessary to successfully join a Windows AD domain. To do this, create a user account in the
applicable hierarchy of your Active Directory, then delegate the ability to manage computer objects to the user account.

1. Inthe Active Directory, create a user account with the following options selected:
« User cannot change password
« Password never expires

2. InActive Directory Users and Computers, right-click the container under which you want the computers added,
then click Delegate Control.
The Delegation of Control Wizard opens.

Click Next.

Click Add, then enter the user account created in step 1.

Click Next.

Select Create custom task to delegate, then click Next.

Select Only the following objects in the folder, and then select Computer objects.

Select Create selected objects in this folder, then click Next.

Under Permissions, select Create All Child Objects, Write All Properties, and Change password.
Click Next, then click Finish.

© v oNOo O MO

—

Remote LDAP password change

Windows AD users can conveniently change their passwords without provision changes being made to the network by a
Windows AD system administrator. There are three ways FortiAuthenticator supports a password change: RADIUS
login, GUI user login, and GUI user portal.

RADIUS login:
For the method to work, all of the following conditions must be met:

» FortiAuthenticator has joined the Windows AD domain.

« RADIUS client has been configured to "Use Windows AD domain authentication".
« RADIUS authentication request uses MS-CHAPv2.

« RADIUS client must also support MS-CHAPV2 password change.

A "change password" response is produced that FortiAuthenticator will recognize, which allows cooperation between the
NAS and the Windows AD server that will result in a password change.

GUI user login:
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For this method to work, one of the following conditions must be met:

« FortiAuthenticator has joined the Windows AD domain
o Secure LDAP is enabled and the LDAP admin (i.e. regular bind) has the permissions to reset user passwords

You must log in via the GUI portal. FortiAuthenticator will validate the user password against a Windows AD server. The
Windows AD server returns with a change password response. If that happens, the user is prompted to enter a new
password.

GUI user portal:
For this method to work, one of the following conditions must be met:

» FortiAuthenticator has joined the Windows AD domain.
« Secure LDAP is enabled.

After successfully logging into the GUI, the user has access to the user portal. If desired, the user can change their
password in the user portal.

RADIUS

If you have existing RADIUS servers, you may choose to continue using them with FortiAuthenticator by configuring
them as remote RADIUS servers. This feature can also be used to migrate away from third-party two-factor
authentication platforms.

ﬂ When entering the remote RADIUS server information, if any information is missing or in the
, wrong format, error messages will highlight the problem for you.

To add a remote RADIUS server entry:

1. Go to Authentication > Remote Auth. Servers > RADIUS and select Create New. The Create New RADIUS
Server window opens.

2. Enter the following information, then select OK to add the RADIUS server.

Name Enter the name for the remote RADIUS server on FortiAuthenticator.
Preferred auth. method Select from either MSCHAPV2 (by default), MSCHAP, CHAP, or PAP.
Timeout Enter a timeout in seconds between 1-60 seconds (3 by default).

Note that a high timeout may impact the processing rate of authentication
requests if the remote RADIUS server becomes unresponsive.

Primary Server Enter the server name or IP address, port, and secret in the fields provided to
configure the primary server.

Secondary Server Optionally, add redundancy by configuring a secondary server.

User Migration Select Enable learning mode to record and learn users that authenticate
against this RADIUS server. This option should be enabled if you need to
migrate users from the server to the FortiAuthenticator.
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OAUTH

Select View Learned Users to view the list of learned users. See Learned
RADIUS users on page 208.

FortiAuthenticator can be configured to connect to remote OAuth servers to dynamically look up group memberships
from third-party SAML identify providers, such as G Suite and Azure, for SAML SP FSSO.

To add a remote OAuth Server:

1. Go to Authentication > Remote Auth. Servers > OAUTH and select Create New.
The Create New Remote OAuth Server window appears.

2. Enter the following information:

Name

OAuth source

Key

Secret

Client ID

Client Key

G-suite admin

Service account key file
(.json)

Enter the name for the remote OAuth server on FortiAuthenticator.

Select Facebook, Google, LinkedIn, Twitter, WeChat, Azure Directory, or
G Suite Directory as the OAuth source.

For Facebook, Google, LinkedIn, Twitter, and WeChat enter the Key and
Secret for the selected OAuth source.

For Azure Directory, enter the Client ID and Client Key for the Azure
Directory.

For G Suite Directory, enter the G-suite admin and select and upload the
Service account key file (.json) for the G Suite Directory.

Enter the OAuth application key for the selected OAuth source. This option is
only available when Facebook, Google, LinkedIn, Twitter, or WeChat is
selected as an OAuth source.

Enter the OAuth application secret for the selected OAuth source . This option
is only available when Facebook, Google, LinkedIn, Twitter, or WeChat is
selected as an OAuth source.

Enter the application ID for the Azure Directory application, obtained from the
Azure portal. This option is only available when Azure Directory is selected
as an OAuth source.

Enter the key for the Azure Directory application, obtained from the Azure
portal. This option is only available when Azure Directory is selected as an
OAuth source.

Enter the G Suite admin username for the G Suite Directory application. This
option is only available when G Suite Directory is selected as an OAuth
source.

Select and upload the service account key file for the G Suite Directory
application, obtained from the Google developers portal. This option is only
available when G Suite Directory is selected as an OAuth source.

3. Select OK to add the remote OAuth server.
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SAML

To add a remote SAML Server:

1. Go to Authentication > Remote Auth. Servers > SAML and select Create New.
The Create New Remote SAML Server window appears.

2. Enter the following information:

Name
Description
Device FQDN
Type

URL Nomenclature

Portal URL
Entity ID
ACS (login) URL

Import
IDP metadata/certificate

IDP entity ID

IDP single sign-on URL

IDP certificate

Enter a name for the remote SAML server.

Enter a description for the remote SAML server.

The FQDN of the configured device from the system dashboard.
Select FSSO or Proxy as the remote SAML server type.
Select the method to determine the URL path of the SAML service provider.
 Individualize:Enable to include the name of the SAML service provider in the
URL path.

e Legacy: Enable to set the URL to a predetermined URL path. Note that
Legacy can only be enabled for an existing configured SAML identity
providers.

The SAML service provider login URL.

The SAML service provider Entity ID.

The SAML service provider Assertion Consumer Service (ACS) login URL.
Select to import the SAML IdP metadata or certificate file.

Also known as the entity descriptor. Enter the unique name of the SAML identity
provider, typically an absolute URL:

https://idp name.example.edu/idp
Enter the identity provider portal URL you want to use for SSO.

Enter the fingerprint of the certificate file. To calculate the fingerprint, you can use

fingerprint OpenSSL.

Use the following OpenSSL command:
S openssl x509 -noout -fingerprint -in "server.crt"
Example result, showing the fingerprint:
SHA1
Fingerprint=AF:E7:1C:28:EF:74:0B:C8:74:25:BE:13:A2:26:3D:37:
97:1D:Al1:F9
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Fingerprint algorithm

Authentication context

Enable IdP-initiated
assertion response

Sign SAML requests
with a local certificate

Single Logout

Username

Enable
SAML
single
logout

Obtain
username
from

Group Membership

Obtain
group
membershi
p from

The SAML portal by default uses SHA-256.

Select the authentication context value for the "RequestedAuthnContext" assertion.
e Default: The default value uses "PasswordProtectedTransport"
authentication, which indicates that the IdP requires users to be authenticated
using a password-based method.
¢ None: Omits the "RequestedAuthnContext" assertion when an alternative to
password-based authentication is used.

Allows IdP to send an assertion response to the SP without a prior request from the
SP. Enabling this setting allows the SP to participate in IdP initiated login.

Select to choose a local SAML certificate.

Select to enable SLS (logout) URL and set IDP single logout URL.

Select the method to extract usernames:
« Subject NamelD SAML assertion: Enable to obtain usernames from the
subject NamelD assertion returned by the SAML IdP.
* Text SAML assertion: Enable and enter the text-based SAML assertion that
usernames are obtained from. For example: email

Most SAML IdP services will return the username in the Subject NamelD assertion,
however not all IdP services are consistent. FSSO requires group membership of
each user with an active SSO session while different SAML IDP services require
different methods of retrieving the group information. Before now, group information
could only be obtained from very specific (hardcoded) SAML assertions. You can
choose to configure SAML assertions used in group membership retrieval, retrieve
group membership from an LDAP service, or retrieve group membership from an
OAuth server.
Select the method to extract usernames:
e SAML assertions: Enable and choose whether usernames are pulled in from
boolean assertions or text-based attributes.
e LDAP lookup: Enable and select the LDAP server to obtain group
memberships.
¢ Cloud: Enable and select the OAuth server and group field to obtain group
memberships.
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Implicit Select to choose a local group the retrieved SAML users are placed into.
group

membershi

p

3. Select OK to add the remote SAML server.

RADIUS service

The FortiAuthenticator RADIUS AAA (authentication, authorization, and account) server is already configured and
running with default values. Each user account on FortiAuthenticator has an option to allow authentication using the
RADIUS database.

Before FortiAuthenticator will accept RADIUS authentication requests from a device, it must be registered as a
authentication client on FortiAuthenticator, and it must be assigned a RADIUS policy.

When changes are made to RADIUS authentication clients and policies, log messages are generated to confirm the
admin configuration change, and to state that the RADIUS server was restarted to apply the change.

FortiAuthenticator allows both RADIUS and remote authentication for RADIUS configurations. If you want to use a
remote server, you must configure it first. See Remote authentication servers on page 126. You can configure the built-in
LDAP server before or after creating client entries, see LDAP service on page 149.

For VM appliances, the ratio for RADIUS clients is "number of max users / 3".

M, The number of RADIUS policies is "number of max users x 2", because each RADIUS client
? might need more than one policy.
- See the Maximum values table included in the latest FortiAuthenticator Release Notes for

more details.

Beginning in 6.1.0, RADIUS authentication logic is determined by policies, created in
ﬂ Authentication > RADIUS Service > Policies.
I When upgrading from a version prior to 6.1.0, existing RADIUS client configurations are

migrated into clients and policies with corresponding settings.

Clients

You must configure each device requesting authorization from the RADIUS server as a FortiAuthenticator
RADIUS client.
RADIUS accounting clients can be managed from Authentication > RADIUS Service > Clients.

Configured clients are assigned to one or more RADIUS policies that determine the authentication logic.

To configure a RADIUS client:

1. Go to Authentication > RADIUS Service > Clients, and click Create New to add a new RADIUS client.
The Create New Authentication Client window opens.

FortiAuthenticator 6.3.1 Administration Guide 135
Fortinet Technologies Inc.


https://docs.fortinet.com/product/fortiauthenticator/

Authentication

2. Provide the following information to configure the client:

NP Subnets and IP ranges can be defined in the Client address field. All authentication
‘Q' clients within a defined subnet/IP range will share the same configuration and shared
- secret. For example, 192.168.0.0/24 would allow all 255 IP addresses to authenticate.

This saves time because it only uses a single client entry in the license table.

Name A name to identify the authentication client.

Client address The IP/Hostname, Subnet, or Range of the client.

Secret The RADIUS passphrase shared with the client.

Accept RADIUS account Allows FortiAuthenticator to accept RADIUS accounting messages for

messages for usage enforcement  usage enforcement.

W) In order to accept account messages for enforcement,
‘Q' the client address must be set as an IP/Hostname.
- Subnet and Range client address types are not
- supported.

Support RADIUS Disconnect Allows FortiAuthenticator to support RADIUS Disconnect messages.
messages

client address must be set as an IP/Hostname. Subnet

\‘é', In order to support RADIUS disconnect messages, the
- and Range client address types are not supported.

3. Select OK to add the new RADIUS client.

NV If authentication fails, check that the authentication client is configured and that its IP
‘?' address is correctly specified. Common causes of problems are:
|| * RADIUS packets sent from an unexpected interface, or IP address.
- ¢ NAT performed between the authentication client and FortiAuthenticator.

Policies

RADIUS policy configuration is available in Authentication > RADIUS Service > Policies.

FortiAuthenticator RADIUS authentication requires that RADIUS clients are assigned one or more policies. Policies can
be created for Password/OTP, MAC authentication bypass (MAB), and EAP-TLS authentication.

To distinguish authentication requirements for clients, RADIUS attributes can be added to policies to indicate the type of
service the user has requested or the type of service that is provided. Each policy can contain up to two RADIUS
attributes.

FortiAuthenticator attempts to match the RADIUS attributes from an authentication request to each policy, starting with
the top policy in the list, and moves down until a match is found. Policy priority can be re-ordered by selecting the up and
down icons next to each policy in the list.
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System

+ Create New  Authentication policies
Authentication
m] Name RADIUS Clients

RADIUS Attribute Criteria Authentication Type Priority

>
& User Account Policies >
>

& User Management () FortiGate Office #2 Password/OTP o

& Self-service Portal > |0 Fortigate-1 Office #2
& Portals >
&R Remote Auth. Servers >
& RADIUS Service v

Clients

Policies

EAP

Services

Password/OTP [+]

2 Authentication pelicies

Custom Dictionaries
& LDAP Service >
& OAuth Service
B saMLidP >
&3 FAC Agent >

Fortinet SSO Methods

Monitor >

Certificate Management >

Logging

To configure a RADIUS policy:

1. Go to Authentication > RADIUS Service > Policies, and click Create New to add a new RADIUS policy.
The RADIUS Policy Creation Wizard is launched.

2. Configure the RADIUS policy:

N ! /., Displayed configuration settings vary depending on the Authentication type selected. The
? list below contains all possible settings, but only settings that are applicable to your

configuration are shown in the GUI.

RADIUS clients
Policy name
Description

RADIUS clients

RADIUS attribute criteria

RADIUS authentication
request must contain
specific attributes

Authentication type

Password/OTP
authentication

MAC authentication
bypass (MAB)
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The policy name, description, and clients.
Enter a name to identify the RADIUS policy.
Optionally, provide a description of the policy.

Choose the clients to which this policy applies.
For more information, see Clients on page 135.

The attributes that must be present in the RADIUS authentication
request in order to be processed by this policy.

When enabled, RADIUS authentication requests must contain
specific attributes from the FortiAuthenticator's list of vendors,
viewable at Authentication > RADIUS Service > Dictionaries.

The type of end-user authentication used by this policy.

Configure password or one-time password authentication on selected
realms.
When Accept EAP is enabled, password/OTP authentication can be

configured to accept EAP, including PEAP, EAP-TTLS, and EAP-
GTC.

Configure MAC authentication bypass (MAB) for certain devices,
provided their MAC addresses appear in the User-Name, User-
Password, and Calling-Station-ID attributes.
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Client Certificates (EAP-
TLS)

Identity source

Username format

Use default realm when
user-provided realm is
different from all
configured realms

Realms
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Configure client certificates (EAP-TLS) to verify the certificate
provided by the end-user. A certificate is deemed valid if ALL of the
following conditions match the certificate binding settings of one of the
configured local or remote users:

e End-user certificate "Subject" has a CN value AND that value
matches the "Common name" certificate binding setting of one of
the configured local or remote users.

» End-user certificate "Issuer" matches the "CA" certificate binding
setting of that same configured user account.

« End-user certificate is properly signed.

e End-user certificate is NOT expired.

For example, if an end-user provides a certificate with the following
fields:

e Subject: CN=SAM, OU=Sales, DC=Company, DC=com

e Issuer: CN=MyCA, OU=IT, DC=Company, DC=com

* Properly signed and not expired.

This certificate would be deemed valid if it matches a configured user
account with the following certificate binding settings:

e Common name: Sam

e CA:CN=MyCA, 0OU=IT, DC=Company, DC=com

The identity sources against which to authenticate end-users.

Identity source settings vary depending on the authentication type
selected.

Select one of the following three username input formats:

* username@realm

* realm\username

e realm/username
These settings are only displayed for Password/OTP and EAP-TLS
authentication.

When enabled, FortiAuthenticator selects the default realm for
authentication when the user-specified realm is different from all
configured realms.

Add realms to which the client will be associated.
e Select a realm from the dropdown menu in the Realm column.
« Select whether or not to allow local users to override remote
users for the selected realm.
» Select whether or not to use Windows AD domain authentication.
See Windows AD domain authentication on page 140.
« Edit the group filter as needed to filter users based on the groups
they are in.
 If necessary, add more realms to the list.
» Select the realm that will be the default realm for this client.
These settings are only displayed for Password/OTP and EAP-TLS
authentication.
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MAC groups

Authentication factors

Authentication type

RADIUS attribute for
user IP

Adaptive Authentication

Device authorization
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When editing group filters for remote RADIUS realms, you can enable
Allow remote LDAP groups to allow the selection of remote
LDAP groups.

Define the allowed and blocked groups for this feature.

MAC groups must be first created under Authentication > User
Management > User Groups, where the Type is MAC.

Optionally, you can require the Call-Check attribute for MAC-based
authentication.

These settings are only displayed for MAC authentication bypass
(MAB) authentication.

The authentication factors to verify.

Authentication factor settings are only displayed for Password/OTP
and EAP-TLS authentication types.

Select one of the following:

e Mandatory two-factor authentication: Two-factor
authentication is required for every user.

* Verify all configured authentication factors: Two-factor
authentication is required if it is enabled on the user's account,
otherwise, allow one-factor authentication.

e Password-only authentication: Authenticate users through
password verification only. User accounts for which password
authentication is disabled cannot be authenticated.

* Token-only authentication: Authenticate users through token
verification only. User accounts for which token authentication is
disabled cannot be authenticated.

Enter the radius attribute for the user IP address.
Framed-IP-Address is the default RADIUS attribute.

Enable this option if you would like to have certain users bypass the
OTP validation, so long as they belong to a trusted subnet.

Select All trusted subnets to add all the available trusted subnets.
You can specify the trusted subnets by selecting Specify trusted
subnets and clicking the pen icon. This opens a window where you
can choose from a list of available trusted subnets.

Ay Adaptive Authentication is available only for the

‘?' following authentication types:
* Mandatory two-factor authentication

¢ Verify all configured authentication factors

To allow 802.1X authentication for non-interactive devices,
FortiAuthenticator can identify and bypass authentication for a device
based on its MAC address.
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Advanced Options

RADIUS response

3. Select OK to add the new RADIUS policy.

This is used for devices that do not allow the usual username or
password input to perform 802.1X authentication, such as network
printers. MAC devices can be specified in Authentication > User
Management > MAC Devices.

When Verify MAC address in authentication requests is

enabled, you can select the RADIUS attribute and authorized group.
The default RADIUS attribute is Calling-Station-Id.

Enable this setting to allow FortiToken
Mobile push notifications for RADIUS users.
This setting is controlled on a per RADIUS
client basis, not for specific users.

Allow FortiToken
Mobile push
notifications

Enter the client application name. This field is
Application name displayed on the FortiToken app.
for FTM push When creating a new policy or upgrading to
notification FortiAuthenticator 6.3, the policy name is the
default client application name.

Resolve user geolocation Enable to resolve the user geolocation
from their IP address from their IP address (if possible).

Reject usernames
containing uppercase
letters

Enable this setting to reject usernames
that contain uppercase letters.

The content of the RADIUS authentication response based on the
outcome of the authentication.

Windows AD domain authentication

Windows AD domain authentication can be enabled to allow for PEAP-MSCHAPvV2 (802.1x) over RADIUS.

When enabled, authentication is performed using NTLM once the FortiAuthenticator has joined the AD domain,
replacing the default LDAP authentication process. The ports used with Windows AD domain authentication are TCP/88,

135, 139, and 445.

When determining which LDAP server to authenticate users against, the domain provides a list of domain controllers,
and FortiAuthenticator cycles round-robin through them when joining the domain instead of using the primary/secondary
IP/FQDN from the remote LDAP server settings. Enabling Preferred Domain Controller Hostname will limit the round-

robin activity to the DCs specified by this setting.

Certificates

FortiAuthenticator supports RADSEC and several IEEE 802.1X Extensible Authentication Protocol (EAP) methods,
configurable from Authentication > RADIUS Service > Certificates. For more information about EAP, see Extensible

Authentication Protocol on page 173.

You can specify the following certificate information:
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EAP Server Certificate Specify the server certificate to be used with Extensible Authentication Protocol
(EAP) methods.

RADSEC Server Certificate Specify the server certificate to be used with RADSEC RADIUS requests.

Local CAs Specify the local CA.

Trusted CAs Specify trusted CAs.

RADSEC support

When using RADSEC, the certificate used to encrypt the TLS traffic between FortiAuthenticator and the RADSEC client
must be configured in the Radsec Server Certificate field. Certificates can be created locally or imported to
FortiAuthenticator.

When a RADSEC client connects to FortiAuthenticator through TLS on the specified port, after being decrypted, they are
handled by the FortiAuthenticator's RADIUS daemon like standard RADIUS requests via UDP. The maximum number of
simultaneous RADSEC clients supported is 500. The default RADSEC port is 2083 and can be configured in
Authentication > RADIUS Service > Services. See Services on page 141

Services

You can optionally change the RADIUS authentication, accounting SSO, and accounting monitor ports under
Authentication > RADIUS Service > Services.

By default, the ports are set to:

« RADIUS authentication port: 1812

+ RADIUS accounting SSO port: 1813

+ RADIUS accounting monitor port: 1646
» RADSEC port: 2083

Y When upgrading from a firmware version prior to 5.0, and the Enable RADIUS Accounting
‘?' SSO clients option is enabled under Fortinet SSO Methods > SSO > General, both the
|| SSO accounting port and the usage monitoring accounting port should remain at their default

values (1813 and 1646 respectively) in order to avoid service disruption.

Custom dictionaries

The custom dictionary list enables you to view built-in vendors and their RADIUS attributes, and create new customized
entries.

Go to Authentication > RADIUS Service > Dictionaries to view the list.

Some services can receive information about an authenticated user through RADIUS vendor-specific attributes.
FortiAuthenticator user groups and user accounts can include RADIUS attributes for Fortinet and other vendors.

Attributes in user accounts can specify user-related information. For example, the Default attribute Framed-IP-Address
specifies the VPN tunnel IP address sent to the user by the Fortinet SSL VPN.
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Attributes in user groups can specify more general information, applicable to the whole group. For example, specifying
third-party vendor attributes to a switch could enable administrative level login to all members of the Network_Admins
group, or authorize the user to the correct privilege level on the system.

Vendor Id
49426
43356
41482
40808
40676
37538
35987
35265
34536
32620
30065
29671
28557
27880
27262
27030
26928
25622
25506
25461
25178
25053
24757
24023
22736

Name
Cnergee
Mimosa
Yubico
WiFi-Alliance
Microserni
Big-Switch-Networks
NetBorder
Eltex
fdXtended
AnueSystems
Arista
Meraki
Hillstone
Freeswitch
DANTE
Wichorus
Aerohive
UKERNA
H3C
PaloAlto
TERENA
Ruckus
WIMAX
IEA-Software

Digium

Attributes Count

31
29

Attributes
BELRAS-Up-Speed-Limit, BELRAS-Down-Speed...
Mimosa-Device-Configuration-Parameter, Mimo...
‘Yubikey-Key, Yubikey-Public-1D, Yubikey-Private-...
HS520-Subscription-Remediation-Needed, H520-...
Microsemi-User-Full-Name, Microsemi-User-Na...

BSN-User-Role, BSN-AVPair
NetBorder-AVPair, NetBorder-CLID, NetBorder-...
Eltex-AVPair, Eltex-Disconnect-Code-Local
fdXtended-Bandwidth-Up, fdXtended-Bandwidt...
Anue-Role, Anue-Groups, Anue-Service, Anue-L..
Arista-AVPair, Arista-User-Priv-Level, Arista-Use...
Meraki-Device-Name, Meraki-Network-Name, ...
Hillstone-User-vsys-id, Hillstone-User-Type, Hills...
Freeswitch-AVPair, Freeswitch-CLID, Freeswitch...
Default-TTL
‘Wichorus-Policy-Name, Wichorus-User-Privilege
AH-HM-Admin-Group-ld
UKERNA-GSS-Acceptor-Service-Name, UKERN...
H3C-Input-Peak-Rate, H3C-Input-Average-Rate,...
PaloAlto-Admin-Role, PaloAlto-Admin-Access-D...
Eduroam-SP-Country, Eduroam-Monitoring-Inflate
Ruckus-User-Groups, Ruckus-Sta-RSSI, Ruckus-S...
WiMAX-Capability, WiMAX-Device-Authenticati...
AM-Interrupt-HTMLFile, AM-Interrupt-Interval, ...

Asterisk-Acc-Code, Asterisk-Src, Asterisk-Dst, As...

To create a new custom RADIUS attribute vendor, open the Custom Vendors view and select Create New where you

are prompted to upload a RADIUS dictionary file.

To add RADIUS attributes to a user or group:

1. Go to Authentication > User Management > Local Users and select a user account to edit, or go to

Authentication > User Management > User Groups and select a group to edit.

2. Inthe RADIUS Attributes section, select Add Attribute. The Create New User Group RADIUS Attribute or

Create New User RADIUS Attribute window opens.

3. Select the appropriate Vendor and Attribute ID, then enter the attribute’s value in the Value field.

4. Select OKto add the new attribute to the user or group.
5. Repeat the above steps to add additional attributes as needed.

TACACS+ service

Before FortiAuthenticator can accept TACACS+ authentication requests from a client, the device must be registered on
FortiAuthenticator, and it must be assigned to a policy. TACACS+ authorization can be specified by creating

authorization rules that can be applied to users and user groups in FortiAuthenticator.

The TACACS+ service can be enabled or disabled on each FortiAuthenticator network interface individually. Before you
configure the TACACS+ service for use, confirm that it is enabled on the desired FortiAuthenticator network interface(s).

TACACS+ logs are viewable from the debug logs page.
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To view the logs, goto (https://<FAC IP>/debug/), and select TACACS+ from the Service dropdown.
0 @ wm-

Name Client Address

CiscolSE 192.168.1.22

& OAuth Service
B samLip
€8 FAC Agent

TACACS+ authentication on FortiAuthenticator does not currently support
challenge/response, which means:
A ¢ Two-factor authentication is only supported by appending the token to the password
during login. For example, where the password is Fortinet and the token PIN is
123456, the password entered by the user willbe Fortinet123456.
¢ Having end-users change their password during login is not supported.

Creating policies

TACACS+ policy configuration is available under Authentication > TACACS+ Service > Policies.

FortiAuthenticator TACACS+ authentication requires that a TACACS+ client is assigned one or more policies. Policies
determine the authentication method, identity source, and TACACS+ response for the clients assigned to the policy.

To create a TACACS+ policy:

1. Go to Authentication > TACACS+ Service > Policies.
The Create New TACACS+ Policy Wizard opens.

2. Enter the following information:

TACACSH+ clients Specify the policy name and description.
Specify all clients that this policy will accept TACACS+ requests
from.
Policy name Enter a name for the policy.
Description Optionally, enter a description of the policy.
TACACS+ clients Lists the available TACACS+ clients. Select the client(s) to which

this policy applies by using the arrows to move clients into the
Chosen TACACS+ Clients box.

For more information about creating TACACS+ clients, see
Adding clients on page 145.

Identity source Specify the identity sources against which to authenticate end-
users.
Username format Select one of the following three username input formats:
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Use default realm when
user-provided realm is
different from all configured
realms

Realms

Authentication factors

Authentication method

Adaptive Authentication

FortiAuthenticator 6.3.1 Administration Guide
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¢ username@realm
¢ realm\username
¢ realm/username

When enabled, FortiAuthenticator selects the default realm for
authentication when the user-specified realm is different from all
configured realms.

Add the realms to which the client(s) will be associated.

¢ Select a realm from the dropdown menu in the Realm
column.

« Select whether or not to allow local users to override remote
users for the selected realm.

¢ Select whether or not to use Windows AD domain
authentication.

« Edit the group filter as needed to filter users based on the
groups they are in.

* If necessary, add more realms to the list.

¢ Select the realm that will be the default realm for this client.

Specify which authentication factors to verify.

Select one of the following:

* Mandatory two-factor authentication: Two-factor
authentication is required for every user.

¢ Verify all configured authentication factors: Two-factor
authentication is required if it is enabled on the user's
account, otherwise, allow one-factor authentication.

¢ Password-only authentication: Authenticate users
through password verification only. If password
authentication is disabled on the user account, the account
cannot be authenticated.

¢ Token-only authentication: Authenticate users through
token verification only. If token-based authentication is
disabled on the user account, the account cannot be
authenticated.

Enable this option if you would like to have certain users bypass
OTP validation, so long as they belong to a trusted subnet.
Select All trusted subnets to add all the available trusted
subnets.

You can specify the trusted subnets by selecting Specify
trusted subnets and clicking the pen icon. This opens a window
where you can choose from a list of available trusted subnets.
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Adaptive Authentication is available only for the
ML’ following authentication types:
q ¢ Mandatory two-factor authentication
- ¢ Verify all configured authentication
factors

TACACS+ response TACACS+ authentication response based on the outcome of the
authentication.

3. Click OK to save the policy.

Adding clients

TACACSH+ clients can be managed from Authentication > TACACS+ Service > Clients.

Clients can be added, imported, deleted, and edited as needed.

Ay
‘?' TACACS+ clients must use single-connection mode when using FortiAuthenticator for
|| TACACS+ AAA.

Once created, clients can be assigned to a TACACS+ policy. See Creating policies on page 143.

To configure a TACACS+ client:

1. Go to Authentication > TACACS+ Service > Clients, and click Create New to add a new TACACS+ client.
The Create New TACACS+ Client window opens.

2. Enter the following information:

Name Input a name to identify the TACACS+ client.

Client address Choose to specify the client address as an IP address or Subnet.
IP Address/Subnet Enter the IP address or subnet of the client.

Secret Enter the TACACS+ passphrase that is shared with the client.

3. Select OK to add the new TACACS+ client.

* TACACSH+ packets sent from an unexpected interface, or IP address.
« NAT performed between the authentication client and FortiAuthenticator.

If authentication fails, check that the authentication client is configured and that its IP address
x is correctly specified. Common causes of authentication problems are:

TACACS+ on FortiAuthenticator supports the ASCIl and PAP authentication types. Other
\{ authentication types supported by the TACACS+ protocol (CHAP and MSCHAPV2) will be

denied.

When configuring TACACS+ settings on a client, for example FortiGate, the
ASCII authentication type must be selected.
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To import TACACS+ clients:

1. Go to Authentication > TACACS+ Service > Clients, and click Import.
The Import TACACS+ Clients window opens.

2. Click Upload a file and choose the file location of the CSV file containing your TACACS+ client list.
Each line of the CSV file must contain values in the following format:
« Name: String.
« Address: IP address or subnet.
« Secret: String.
« Policy: Name of a TACACS+ policy (optional).
For example:
e Unique IP and policy: myclient,1.2.3.4,secretl123,mypolicy
e Subnet and no policy: myclients,1.2.3.0/24,secretl23,
3. Click OK.

Creating authorization rules

TACACS+ authorization can be managed from Authentication > TACACS+ Service > Authorization. In the
TACACS+ Authorization menu, you can configure Rules, non-shell Services, and Shell Commands. Authorization
rules can be specified within user groups or on individual user accounts. See Assigning authorization rules on page 149.

After successful authentication, FortiAuthenticator creates an authorization session for the
user that lasts 28,800 seconds (8 hours). Any changes made to authorization rule
configurations during that time will not apply to the user until the 8 hour session has expired.
To configure the maximum time duration (in seconds) for which an authenticated TACACS+
user is authorized to issue commands, go to Authentication > User Account Policies >

General, and enter a value between 120 - 36,000 for Session duration of authenticated
TACACS+ user.

To create an authorization rule:

1. Goto Authentication > TACACS+ Service > Authorization, select Rules, and click Create New.
The Create New TACACS+ Rule window opens.

2. Enter the following information:

Create New TACACS+ Rule

[
Name Enter a name for the authorization rule.
Privilege level Determines the access level users have before they are required to enter an

enable password.
The privilege level can be set in the range of 0 and 15.
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Ay
‘Q' Currently, escalation/elevation of privileges using the enable
- mode is not supported.

Default permission for non- Set the permissions for non-shell services.

shell services Non-shell services cannot be specified and are only supported as Allow all or
Deny all.

Allowed services Specify the list of allowed services. See Services.

Default permission for shell Set the permissions for shell commands not explicitly specified under Allowed

commands shell commands.

Shell commands Select the configured shell commands to include in this authorization rule.

3. Click OK to save the authorization rule.

To create a shell command:

1. Go to Authentication > TACACS+ Service > Authorization, select Shell commands, and click Create New.
The Create New TACACS+ Shell Command window opens.

2. Enter the following information:

Create New TACACS+ Shell Command
Name:
Command:

Default Permission for ® Deny O Allow
unspecified arguments:

Allowed arguments:

“ Cance'

Name Enter a name for the shell command.

Command Enter the shell command.

Default permission for Set the permission for command arguments not explicitly specified under
unspecified arguments Allowed/Denied arguments.

Allowed arguments/Denied Specify all sets of arguments to be allowed or denied.

arguments

ﬂ One set of arguments can be provided per line, and curly
I braces are not permitted.
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3. Select OK to save the shell command.

To create a non-shell service:

1. Goto Authentication > TACACS+ Service > Authorization, select Services, and click Create New.
The Edit TACACS+ Service window opens.

2. Enter the following information:

Create New TACACS+ Service

Name:
Service:

Default permission for attributes: O Deny @ Allow

Name Enter a name for the non-shell service.

Service Enter the service. The service string can only contain ASCII characters in the
0x20-0x7E range, except'@' and /.

Default permission for Allow: Attributes not listed in this service are allowed. These attributes are
attributes copied unchanged from the authorization request into the authorization
response.

Deny: Attributes not listed in this service are denied. If the TACACS+ client
marked the denied attribute as mandatory, the authorization response is fail. If
marked as optional, the attribute is removed from the authorization response.

3. Click OK to save the non-shell service.

4. Once the non-shell service has been created, you can then edit it to add, edit, or remove attribute value-pairs.
To create a new attribute-value pair, click Add Attribute in the Attribute-value Pairs section and configure the
following information:

Create New Tacacs Service Attribute-value Pair

Attribute:

Value:

Restriction: @ Mandatory O Optional

“ e
v

Attribute-value Pairs Specify the attribute, value, and restriction for this service.
The available options for the restriction setting include:
¢ Mandatory: Requires that the receiving side understands the attribute
and will act on it. If the client receives a mandatory argument that it cannot
oblige or does not understand, it must consider the authorization to have
failed.
¢ Optional: May be disregarded by the client.
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Assigning authorization rules

Authorization rules can be specified within user groups or on individual user accounts. If the user is member of multiple

groups, the FortiAuthenticator arbitrarily chooses one of the TACACS+ authorization rules from one of the groups. When
a TACACS+ authorization rule is specified on a user's account, it will override rules from any group for which the useris a

member.

To configure TACACS+ authorization rules in user groups:

1. Go to Authentication > User Management > User Groups.
2. Create a new user group or edit an existing one.

3. Under the TACACS+ Authorization menu, select a rule from the TACACS+ authorization rule dropdown.

Create New User Group
Name:

Type: [EXJ RerotelDAP  RemoteRADIUS | RemoteSAML | MAC
Users:

search

Password policy:

Usage Profile

TACACS+ Authorization
TACACS+ authorization rule: [Please Select ] v

To configure TACACS+ authorization rules on individual users:

1. Go to Authentication > User Management > Local Users.
2. Create a new user or edit an existing one.
3. Underthe TACACS+ Authorization menu, select a rule from the TACACS+ authorization rule dropdown.

Edit Local User
Username: admin
Disabled

Password-based authentication | Crange passuor
Token-based authentication

Allow RADIUS authentication

Force password change on next logon

Syncin HA Load Balancing mode

User Role

Role: Sponsor User
© Full permission
© Web service access
Restrict admin login from trusted management subnets only
© User Information
© Alternative Email Addresses
© Password Recovery Options
8 Groups
© Usage Information
© Email Routing
© TACACS+ Authorization

TACACS+ authorization rule: [Please Select] v

© Devices

LDAP service

LDAP is an Internet protocol used to maintain authentication data that may include departments, people, groups of
people, passwords, email addresses, and printers. LDAP consists of a data-representation scheme, a set of defined

operations, and a request/response network.
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In the LDAP protocol there are a number of operations a client can request such as search, compare, and add or delete
an entry. Binding is the operation where the LDAP server authenticates the user. If the user is successfully
authenticated, binding allows the user access to the LDAP server based on the user’s permissions.

rfc822MailMember attribute

For users, the rfc822Mai 1Member attribute lists the alternative email addresses configured

M, for the local user.
q For user groups, the rfc822Mai 1Member attribute records the values of all unique email
- addresses (not including alternative email addresses) associated with users belonging to that

group. In Windows AD, this is mapped by the member0f attribute.
Email addresses and alternative email addresses can be configured for the local user settings
in Authentication > User Management > Local Users.

General

To configure general LDAP service settings, go to Authentication > LDAP Service > General.
LDAP Server Settings

LDAP server certificate Select the certificate that the LDAP server will present from the dropdown

menu.

Certificate authority Select either Local CA or Trusted CA.

type

CA certificate that Select the CA certificate that issued the server certificate from the dropdown
issued the server menu.

certificate

LDAP User Auto Provisioning Enable this feature to specify how users can be automatically provisioned into

LDAP.

Select OK to apply any changes that you have made.

Directory tree overview

The LDAP tree defines the hierarchical organization of user account entries in the LDAP database. The FortiGate unit
requesting authentication must be configured to address its request to the right part of the hierarchy.

An LDAP server’s hierarchy often reflects the hierarchy of the organization it serves. The root represents the
organization itself, usually defined as Domain Component (DC), a DNS domain, such as example . com (as the name
contains a dot, it is written as two parts separated by a comma: dc=example, dc=com). Additional levels of hierarchy
can be added as needed; these include:

e Country (c)
o User Group (cn)
o Local User (uid)
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« Organization (0)
« Organizational Unit (ou)

The user account entries relevant to user authentication will have element names such as UID or CN; the user's name.
They can each be placed at their appropriate place in the hierarchy.

Complex LDAP hierarchies are more common in large organizations where users in different locations and departments
have different access rights. For basic authenticated access to your office network or the Internet, a much simpler LDAP
hierarchy is adequate.

The following is a simple example of an LDAP hierarchy in which the all user account entries reside at the OU level, just
below DC.

dc=example,dc=com

ou=people

cn:Philip Fry cn:user2 cn=usern
uid:pfy uid:userid2 uid=useridn

When requesting authentication, an LDAP client, such as a FortiGate unit, must specify the part of the hierarchy where
the user account record can be found. This is called the distinguished name (DN). In the above example, DN is
ou=People,dc=example, dc=com.

The authentication request must also specify the particular user account entry. Although this is often called the common
name (CN), the identifier you use is not necessarily CN. On a computer network, it is appropriate to use UID, the
person’s user ID, as that is the information that they will provide at logon.

Creating the directory tree

The following sections provide a brief explanation of each part of the LDAP attribute directory, what is commonly used for
representation, and how to configure it on FortiAuthenticator.

O ' ’, When an object name includes a space, as in Test Users, you have to enclose the text with
q double-quotes. For example:

cn="TesTUsers",cn=Builtin,dc=get,dc=local.

+ Expand All @M Delete %93 of 1000 entries remaining CL Search (only for loaded entries) | Search

B &3 de=examplede=com
£ g# cn=Planet Express
| L[ vid=leela
& ] ou=People
&1 g vid=leela (1) 4k o~ 3%
Lo [ o=example
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Editing the root node

The root node is the top level of the LDAP directory. There can be only one. All groups, OUs, and users branch off from
the root node. Choose a DN that makes sense for your organization’s root node.

There are three common forms of DN entries:

The most common consists of one or more DC elements making up the DN. Each part of the domain has its own DC
entry. This comes directly from the DNS entry for the organization. For example, for example.com, the DN entry is
"dc=example,dc=com".

Another popular method is to use the company’s Internet presence as the DN. This method uses the domain name as
the DN. For example, for example.com, the DN entry would be "o=example.com".

An older method is to use the company name with a country entry. For example, for Example Inc. operating in the United
States, the DN would be o="Example, Inc.",c=US. This makes less sense forinternational companies.

\‘é', When you configure FortiGate units to use FortiAuthenticator as an LDAP server, you will

specify the distinguished name that you created here. This identifies the correct LDAP
structure to reference.

To rename the root node:

Go to Authentication > LDAP Service > Directory Tree.

Select dc=example, dc=com to edit the entry.

In the Distinguished Name (DN) field, enter a new name (e.g. "dc=fortinet, dc=com").
Select OK to apply your changes.

Ao bdh-=

) ! /. If your domain name has multiple parts to it, such as shiny.widgets.example.com, each
? part of the domain should be entered as part of the DN, for example:

dc=shiny, dc=widgets, dc=example, dc=com

Adding nodes to the LDAP directory tree

You can add a subordinate node at any level in the hierarchy as required.

To add a node to the tree:

1. From the LDAP directory tree, select the green plus symbol next to the DN entry where you want to add the node.
The Create New LDAP Entry window opens.

2. Inthe Class field, select the identifier to use.
For example, to add the ou=People node from the earlier example, select Organizational Unit (ou).

3. Select the required value from the dropdown menu, or select Create New to create a new entry of the selected
class.

4. Select OK to add the node.

Nodes can be edited after creation by selecting the edit, or pencil, icon next to the node name.
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Adding user accounts to the LDAP tree

You must add user account entries at the appropriate place in the LDAP tree. These users must already be defined in the
FortiAuthenticator user database. See Adding a user on page 82.

To add a user account to the tree:

1. From the LDAP directory tree, expand nodes as needed to find the required node, then select the node’s green plus
symbol.
In the earlier example, you would do this on the ou=People node.

2. Inthe Class field, select User (uid).
The list of available users is displayed. You can choose to display them alphabetically by either user group or user.

3. Select the required users in the Available Users box and move them to the Chosen Users box. If you want to add
all local users, select Choose all below the users box.

4. Select OKto add the user account to the tree.
You can verify your users were added by expanding the node to see their UIDs listed below it.

Moving LDAP branches in the directory tree

At times you may want to rearrange the hierarchy of the LDAP structure. For example a department may be moved from
one country to another.

While it is easy to move a branch in the LDAP tree, all systems that use this information will
need to be updated to the new structure or they will not be able to authenticate users.

To move an LDAP branch:

1. From the LDAP directory tree, select Expand All and find the branch that you want to move.

2. Click and drag the branch from its current location to its new location
When the branch is hovered above a valid location, an arrow appears to the left of the current branch to indicate
where the new branch will be inserted. It will be inserted below the entry with the arrow.

Removing entries from the directory tree

Adding entries to the directory tree involves placing the attribute at the proper place. However, when removing entries it
is possible to remove multiple branches at one time.

S ! ’, Take care not to remove more branches than you intend. Remember that all systems using
? this information will need to be updated to the new structure or they will not be able to
- authenticate users.

To remove an entry from the LDAP directory tree:

1. From the LDAP directory tree, select Expand All and find the branch that you want to remove.
2. Select the red X to the right of the entry name.
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You are prompted to confirm your deletion. Part of the prompt displays the message of all the entries that will be
removed with this deletion. Ensure this is the level that you intend to delete.

3. Select Yes, I'm sure to delete the entry.
If the deletion was successful there is a green check next to the successful message above the LDAP directory and
the entry is removed from the tree.

Configuring a FortiGate unit for FortiAuthenticator LDAP

When you have defined the FortiAuthenticator LDAP tree, you can configure FortiGate units to access the
FortiAuthenticator as an LDAP server and authenticate users.

To configure the FortiGate unit for LDAP authentication:

1. On the FortiGate unit, go to User & Device > LDAP Servers and select Create New.
2. Enter the following information:

Name Enter a name to identify the FortiAuthenticator LDAP server on the FortiGate
unit.

Server IP/Name Enter the IP address FQDN of FortiAuthenticator.

Server Port Leave at default (389).

Common Name Identifier Enter uid, the user ID.

Distinguished Name Enter the LDAP node where the user account entries can be found. For

example, ou=People, dc=example, dc=com

Bind Type The FortiGate unit can be configured to use one of three types of binding:
¢ Simple: Bind using a simple password authentication without a search.
¢ Anonymous: Bind using anonymous user search.
* Regular: Bind using username/password and then search.
You can use simple authentication if the user records all fall under one
distinguished name (DN). If the users are under more than one DN, use the
anonymous or regular type, which can search the entire LDAP database for
the required username.
If your LDAP server requires authentication to perform searches, use the
regular type and provide the Username and Password.

Secure Connection If you select Secure Connection, you must select LDAPS or STARTTLS
protocol and the CA security certificate that verifies the FortiAuthenticator
device's identity. If you select LDAPS protocol, the Server Port will change to
636.

3. Optionally, use the Test Connectivity and Test User Credentials features. Select OK to apply your settings.

4. Addthe LDAP server to a user group. Specify that user group in identity-based security policies where you require
authentication.
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OAuth Service

FortiAuthenticator can act as an authorization server to issue and manage OAuth access tokens via a set of

REST API endpoints. An OAuth client is issued an OAuth access token by FortiAuthenticator after successfully providing
its login credentials. The OAuth client can then use this access token as proof of authorization to access a third-party
service. The third-party service may contact FortiAuthenticator to validate any given OAuth access token.

To enable OAuth service access, enable the Auth Service API (/api/v1/oauth) service on applicable network interface
(s) under System > Network > Interfaces.

Settings

To configure the OAuth Service settings, go to Authentication > OAuth Service > Settings.

OAuth Service Settings

Auto-generated client Determines the length of the generated client secret for confidential OAuth
secret length applications. The default is set to 128.

Select OK to apply the changes you have made.

Applications

OAuth applications can be managed from Authentication > OAuth Service > Applications.

The OAuth service has a per-configured FortiOS Fabric OAuth application used for Fortinet Security Fabric integration.
The FortiOS Fabric application settings should not be changed.

To configure an OAuth application:

1. From the OAuth application list, select Create New to add a new OAuth application.
The Create New Application window opens.
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2. Enter the following information:

Name

Client type

Client id

Client secret

Access token expiry

Enter a name for the OAuth application.

Select the client type for the OAuth application:
¢ Confidential: OAuth clients are required to provide the client secret in
requests to the OAuth application.
¢ Public: OAuth clients are not required to provide the client secret in
requests to the OAuth application.

Enter a client id for the OAuth application. A generated value is provided by
default.

Enter a client secret for the OAuth application. A generated value is provided
by default. Only available if Client type is set to Confidential.

Configure the length of the automatically generated value under
Authentication > OAuth Service > Settings.

Enter a length of time for which OAuth access tokens issued by this application
are valid. The default is set to 36000. Access tokens will not expire if the value
is setto 0.

3. Select OK to create the new OAuth application.

SAML IdP

Security Assertion Markup Language (SAML) is used for exchanging authentication and authorization data between an

identity provider (IdP) and a service provider (SP), such as Google Apps, Office 365, and Salesforce. The

FortiAuthenticator can be configured as an IdP, providing trust relationship authentication for unauthenticated users

trying to access an SP.

Realms can be selectively enabled while configuring the FortiAuthenticator as the IdP. When more than one realm is

selected, a default realm can be chosen. New realms can be configured at Authentication > User Management

>

Realms.

SAML authentication on FortiAuthenticator can be set up in an SP-initiated or IdP-initiated configuration.

SAML SP-initiated authentication works as follows:

1.
2,
3.

Two possibilities:

A user attempts to access an SP, for example Google, using a browser.
The SPs web server requests the SAML assertions for its service from the browser.

« The user's browser already has valid SAML assertions, so it sends them to the SPs web server. The web
server uses them to grant or deny access to the service. SAML authentication stops here.

¢ The user's browser doesn't have valid SAML assertions, so the SPs web server redirects the browser to the

SAML IdP.
Two possibilities:

» The user's browser is already authenticated with the I1dP, go to step 5.

« The user's browser is not yet authenticated with the IdP, so the IdP requests and validates the user's
credentials. If successful, go to step 5. Otherwise, access is denied.
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5. IdP provides SAML assertions for the SPs and redirects the user's browser back to the SPs web server. Go back to
step 2.

SAML IdP-initiated authentication works as follows:

1. A user attempts to access the IdP login portal, resulting in one of two possibilities:
» The user's browser is already authenticated by the |dP. Proceed to step 2.

« The user's browser is not yet authenticated by the IdP, so the IdP requests and validates the user's credentials.
If successful, go to step 2. Otherwise, access is denied.

2. The useris presented with an IdP portal landing page that includes a list of the SPs participating in IdP-initiated
login. The user selects an SP.

3. IdP generates the SAML assertions for the browser and sends it to the SP.

4. The SP receives the assertions and authenticates the user, resulting in one of two possibilities:
« The user is authorized, and the SP provides the requested resource to the user.
¢ The useris not authorized, and access to the SP is denied.

General

To configure general SAML IdP portal settings:

1. Goto Authentication > SAML IdP > General, and select Enable SAML Identity Provider portal.

Edit SAML Identity Provider Settings

@ Enable SAML Identity Provider portal

Device FQDN Please configure a device FQDN from the system dashboard.

Server address:

IdP-initiated login URL: https:/[server_address]/saml-idp/portal/ @)

Username input format @® username@realm
O realm\username
O realm/username

© 1AM login

Use default realm when user-provided realm is different from all configured realms
Realms: .
Default Realm Allow Local Users To Override Remote Users Groups Delete

Login session timeout:

Default IdP certificate:

Get nested groups for user
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2. Configure the following settings:

Device FQDN

Server address

IdP-initiated login URL

Username input format

Use default realm when user-
provided realm is different
from all configured realms

Realms

Login session timeout

Default IdP certificate

Get nested groups for user

IAM login

To configure this setting, you must enter a Device FQDN in the System
Information widget in the Dashboard.

Enter the IP address or FQDN of the FortiAuthenticator device.

The URL used to access the IdP portal in an IdP-initiated login scenario.

SPs configured in FortiAuthenticator must have the option Support IdP-
initiated assertion response enabled in order to be listed in the portal.

Select one of the following three username input formats:
¢ username@realm
¢ realm\username
¢ realm/username

When enabled, FortiAuthenticator selects the default realm for authentication
when the user-specified realm is different from all configured realms.

Select Add a realm to add the default local realm to which the users will be
associated.

Use Groups and Filter to add specific user groups.

Set the user's login session timeout limit between 5 - 1440 minutes (one day).

The default is 480 minutes (eight hours).

Select a default certificate the IdP uses to sign SAML assertions from the
dropdown menu.

Enable to get nested groups for Windows AD users.

Enable to allow IAM login.

3. Select OK to apply any changes that you have made.

Replacement messages

The replacement messages list lets you view and customize SAML IdP replacement messages and manage images.

To view the SAML replacement message list, go to Authentication > SAML IdP > Replacement Messages.

[@ Manage Images

Name Description Modified

SAML IdP
Login Page HTML page for SAML IdP user login
Token Login Page HTML page for SAML IdP two factor authentication
SAML IdP Login Success Page HTML page presented when user is successfully authenticated

SAML IdP Request Expired Page HTML page presented when SAML assertion request is expired

0O 0 0 0 o

SAML IdP Logout Success Page HTML page presented when user is successfully logged-out

For more information about customizing replacement messages, see Replacement messages on page 62.
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Service providers

Service providers (SP) can be managed from Authentication > SAML IdP > Service Providers.

To configure SAML service provider settings:

1. Select Create New.

Edit SAML Service Provider

IdP address: Please configure SAML IdP server address first.
SP name: st
1dP prefix: ut 9e7as
Server certificate: Use default setting in SAML P General page. v
1dP entity id: http://www.example.com/samk-idp/ut1dz3brucp9e7q5/metadata/ )
IdP single sign-on URL: https://www.example.com/saml-idp/ut1dz3brucp9e7q5/login/ 2]
1dP single logout URL: https://www.example.com/saml-idp/ut1dz3brucp9e7q5/logout/ 2]
© Support IdP-initiated assertion response
Relay state:
© Participate in single logout
SP Metadata
& impont 5P,
SPentity ID
SPACS (login) URL: i R
SP SLS (logout) URL:
@© SAML request must be signed by SP
Certificate type: SP certicate v
Certificate fingerprint et
Fingerprint algorithm:
Alternative certificate fingerprint: cert
Fingerprint algorithm:
Use ACS URL from SP authentication request (override ACS URLS configured above)
Authentication
Authentication method: O Mandatory two-factor authentication
® Verify all configured authentication factors
O Password-only authentication
O Token-only authentication
Adaptive Authentication Configure subets
Application name for FTM push
notification:
Assertion Attributes
Subject NamelD: v
Format mesitcSAML2 Onameid-format-unspecifed v
Include realm name in subject NamelD
SAML Attribute User Attribute Actions

© Debugging Options

Do not return to service provider automatically after successful authentication, wait for user input.

Disable this service provider

2. Enter the following information:

IdP address

SP name

IdP prefix

Server certificate

IDP entity id

IDP single sign-on URL

IDP single logout URL

To configure the IDP address (and IDP settings below), you must have
already configured the server's address under Authentication
> SAML IdP > General.

Enter a name for the SP.

Enter a prefix for the IDP that is appended to the end of the IDP URLSs.

Alternatively, you can select Generate prefix to generate a random 16 digit
alphanumeric string.

Select a server certificate to use for the SP. If a certificate is not selected, the
specified default IdP certificate is used.

The IDP's entity ID, for example:
http://www.example.com/saml-idp/xxx/metadata/

The IDP's login URL, for example:
http://www.example.com/saml-idp/xxx/login/

The IDP's logout URL, for example:
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Support IdP-initiated assertion
response

Relay state

Participate in single logout

SP Metadata

SP entity id
SP ACS (login) URL

SP SLS
(logout) URL

SAML request must be signed
by SP

Certificate type

Certificate
fingerprint

Fingerprint
algorithm

Alternative
certificate
fingerprint

Use ACS URL from
SP authentication
request

Authentication

Authentication
method

http://www.example.com/saml-idp/xxx/logout/

Allows the IdP to send an assertion response to the SP without a prior
request from the SP.

Enabling this setting allows the SP to participate in IdP initiated login, and
causes the SP to appear in the IdP login portal.

Allows SP to redirect user to the provided URL after a successful assertion
response.

Enable or disable participation in single logout for the SAML IdP service.

SP Metadata fields are only available once the SAML Service Provider
settings has been saved.

Enter the SP's entity ID.

Enter the SP's Assertion Consumer Service (ACS) login URL.

Click Alternative ACS URLSs to configure up to three additional ACS (login)
and SLS (logout) URLs.

Enter the SP's Single Logout Service (SLS) logout URL.

Enable this option and import the SP certificate for authentication request
signing by the SP.
SP certificate: The SP request is signed by the specified certificate.

Direct CA certificate: The SP request must contain the SP certificate
fingerprint that was used to sign the request, and the certificate fingerprint
must be issued by the CA specified in the configuration.

The primary certificate for verifying the SP request signature.

Displays the detected fingerprint algorithm of the certificate fingerprint or
alternative certificate fingerprint.

Specify a second acceptable certificate for verifying the SP request
signature. FortiAuthenticator will accept SP requests with a valid signature
from either configured certificate.

When enabled, indicates that the ACS URL must be included within the
SP request, and that the FortiAuthenticator must use it instead of the pre-
configured ACS URL.

Select one of the following:
* Mandatory two-factor authentication

¢ Verify all configured authentication factors

¢ Password-only authentication (exclude users without a password)
¢ Token-only authentication (exclude users without a FortiToken)
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Adaptive
Authentication

Application name
for FTM push
notification

Assertion Attributes

Subject NamelD

Format

Include realm name
in subject NamelD

SAML Attribute

Enable this option if you would like to have certain users bypass the OTP
verification, so long as they belong to a trusted subnet.

Select Configure subnets to configure trusted subnets (under
Authentication > User Account Policies > Trusted Subnets).

Select All trusted subnets to add all the available trusted subnets.

You can specify the trusted subnets by selecting Specify trusted subnets
and clicking the pen icon. This opens a window where you can choose from a
list of available trusted subnets.

Enter the client application name. This field is displayed on the FortiToken
app.

When creating a new SP or upgrading to FortiAuthenticator 6.3, the SP name
is the default client application name.

Select the user attribute that serves as SAML assertion subject NamelD.

Select from either Username, Email, Remote LDAP user DN, Remote
LDAP user objectGUID, Remote LDAP user mS-DS ConsistencyGuid,
Remote LDAP Custom attribute, Remote SAML Subject NamelD, or
Remote SAML Custom assertion.

If the attribute selected is not available for a user, Username is used by
default.

Select from Unspecified, Transient, or Persistent.

When enabled, you can select the username/realm format to include in
subject NamelD.

Select Create New to create a new attribute that is added to SAML assertion.

The following user attributes are available when creating a new assertion
attribute:

FortiAuthenticator:

Username

First Name

Last Name

Email

Group

IAM account name
IAM account alias
IAM username

Remote LDAP server:
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e Group

e Custom attribute
Remote RADIUS server:

¢ RADIUS attribute

When RADIUS attribute is selected as the User attribute, the following
additional settings are available in the Create New Assertion Attribute
dialog:

¢ Vendor: The RADIUS vendor name.

e Attribute ID: The attribute within the vendor's RADIUS dictionary.
Remote SAML server:

¢ SAML username

e SAML group membership
¢« SAML assertion

Other:
¢ Authentication status

¢ Realm (returns the realm that the end user was authenticated against)

Debugging Options

Do not return to Enable this option to let users choose where to navigate to after they are
service provider authenticated.

automatically after

successful

authentication, wait
for user input

Disable this service Disables the SP.
provider

FortiAuthenticator agents

FortiAuthenticator provides multiple agents for use in two-factor authentication:

« FortiAuthenticator Agent for Microsoft Windows
« FortiAuthenticator Agent for Outlook Web Access

Both agents can be downloaded from the FortiAuthenticator GUI under Authentication > FortiAuthenticator Agent.
FortiAuthenticator Agent for Microsoft Windows

FortiAuthenticator Agent for Microsoft Windows is a credential provider plug-in that enhances the Windows login process
with a one time password, validated by FortiAuthenticator.
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Configurable default domain

When configuring two-factor authentication in the FortiAuthenticator Agent for Microsoft Windows, you can select a
Default Domain at Logon Screen. The options are None, Most Recent, and a populated list of available domains

(also configurable).

This is particularly useful for environments that have a single domain (where previously, the user had to manually pick a
domain from a dropdown every single login, even in single-domain environments).

= Two Factor Authentication Configuration

General Authentication Offine  Domains  Exempt Users

Default Domain

Default Domain at Logon Screen: ® Mone

Corfigure

Available Domains:

Domain

FORTINET-US

MERUNETWORKS
ACCELOPS

) Most Recent

Include in Two Factor Authentication:

(O | FORTINET-US

Load-balancing HA configurations

Customers with a load-balancing HA configuration can configure the FortiAuthenticator Agent for Microsoft Windows to
try to reach the secondary FortiAuthenticator if the primary is unreachable, with retries occurring in the same order (in

round-robin fashion).
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%25 Two Factor Authentication Configuration E

General | Authentication | Offiine | Domains | Exempt Users |

Secondary

FortiAuthenticator Configuration
FortiAuthenticator Name/1P:  152.168.50.21
Administrator Mame: admin

Rest AP| Key: TITIY]

[ Verfy Server Certfficate
Server Subject Mame:

CA Cerfficate File: Browse

Corfigure a secondany FortifAuthenticator (during retries. servers attemate)

| oK || Camcel || Apply

)

Offline token validation at login

You can view the time remaining for offline token validation when logging in using the FortiAuthenticator Agent for
Microsoft Windows.

FortiAuthenticator Agent Version: v2.1 FortiAuthenticator Agent Version: v2.1

Service St cted
Offline To - None available

JERDOM JERDOM

Administrator dollar$

otp pre

FortiAuthenticator Agent Version: v2.1
Service Status: Connected
Offline Tokens: Until 2018-04-24 10:25

JERDOM

pill$

pre

FortiAuthenticator 6.3.1 Administration Guide
Fortinet Technologies Inc.

164



Authentication

For all tokens, FortiAuthenticator downloads enough offline tokens for the configured cache size plus the authentication
window size (so if the HOTP cache = 50 and the HOTP window = 10, you initially have 60 tokens remaining; when tokens
are displayed but not submitted to FortiAuthenticator, this ends up as fewer than 60 authentication attempts).

TLS 1.2 support

All network communications take place over TLS 1.2. As a result, the minimum required version of the .NET Framework
is 4.6.0. The FortiAuthenticator Agent for Microsoft Windows installer will offer to install TLS 1.2 when it is necessary.

FortiAuthenticator Agent for Outlook Web Access

FortiAuthenticator Agent for Outlook Web Access is a plug-in that enhances the Web login process with a one time
password, validated by FortiAuthenticator.

Legacy self-service portal

Al
‘?' FortiAuthenticator self-service portal configuration is now available in Authentication
- > Portals. See Self-service portal policies on page 120.

The legacy self-service portal configuration is disabled by default and can be enabled through system administration
settings.

To enable the legacy self-service portal, go to System > Administration > Features and select Enable legacy self-
service portal.

General

To configure general self-service portal settings, go to Authentication > Self-service Portal > General.

The following settings can be configured:

Default portal language Select from several default portal language packs from the dropdown menu.

Add a Language Upload a different language pack.

Pack Obtain additional translation packs from the Fortinet Support website if you need
to translate to your local language.

Site name Enter a name that is used when referring to this site. If left blank, the default name
is the site DNS domain name or IP address.

Email signature Add a signature that is appended to the end of outgoing email messages.
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Allow users to change their Enable to allow local and/or remote users the ability to change their own
password password.

Access control

To configure self-service portal access settings, go to Authentication > Self-service Portal > Access Control.

The following settings can be configured:

Username input format Select from the following username input formats: username@realm,
realm\username, realm/username. The realm name is optional when
authenticating against the default realm.

Realms Add realms to which the user will be associated.
¢ Select a realm from the dropdown menu in the Realm column.
¢ Select whether or not to allow local users to override remote users for the
selected realm.
« Edit the group filter to filter users based on the groups they belong to.
* If necessary, add more realms to the list.
¢ Select the default realm for this client.

Self-registration

When self-registration is enabled, users can request registration through the FortiAuthenticator login page. Self-
registration can be configured so that a user request is emailed to the device administrator for approval.

When the account is ready for use, the user receives an email or SMS message with their account information.
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To enable self-registration:

1. Go to Authentication > Self-service Portal > Self-registration.

Edit Self-registration Settings

& Enable
L Require administrator approval
B Enable email to freeform addresses

® Select User Groups allowed to approve new user registrations
B Account expires after 1 hour(s) ¥
® Use mabile number as username
® Place registered users into a group | [ Please Select] ¥

Password creation: ® User-defined
Randomly generated

O Enforce contact verification: Email address
Mobile number
User's choice (email or mobile)

Account delivery options available €© 5MS
to the user: » Email
® Display on browser page

SMS gateway: Use default v
Required Field Configuration

2. Select Enable to enable self-registration.
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3. Optionally, configure the following settings:

Require administrator
approval

Enable email to
freeform
addresses

Select User
Groups allowed to
approve new user
registrations

Account expires after
Use mobile number as

username

Place registered users into a
group

Password creation

Send account information via

SMS gateway

Required Field Configuration

4. Select OK to apply your changes.

Self-registration approval

The self-registration page is a customizable replacement message. The default replacement message contains a new
optional field for the self-registering guest to select an approver. The list of approvers comes from the groups specified in
the configuration. The dropdown list is populated with the explicit list of group members for local groups, remote RADIUS

groups, and remote LDAP groups.

Select to require that an administrator approves the user.

Select to send self-registration requests to the email addresses entered in the
Administrator email addresses field.

Select to send self-registration requests to specific user groups. Select the
required approvers from the Available groups box and move them to the
Chosen groups box.

If enabled, the guests are given a dropdown list of approvers to choose from
on the self-registration page. The FortiAuthenticator sends an approval
request to that approver's email address. The list of approvers is the union of
all the users/administrators who are members of the specified groups. Local,
remote LDAP, and remote RADIUS groups are supported.

Enable to specify an expiration for self-generated accounts after they are
generated.

If enabled, after a successful registration, the user’s password is sent to them
via SMS to confirm their identity.

Select a group into which self-registered users are placed.

Select how a password is created, either User-defined or
Randomly generated.

Choose how to send account information to the user, either SMS, Email, or
Display on browser page.

The Display on browser page option is only available if administrator
approval is not required.

Select an SMS gateway from the dropdown menu. See SMS gateways on
page 67 for more information.

Select the fields that the user is required to populate when self-registering.
Options include: First name, Last name, Email, address, Address, City,
State/Province, Country, Phone number, Mobile number, Custom field 1,
Custom field 2, and Custom field 3.

See Custom user fields on page 77 for more information.
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Each approver in the dropdown list is designated as "Lastname, Firstname". In cases where first and last name are not
available, an approver is designated as "username" instead. Disabled user accounts are excluded from the list. User
accounts without a configured email address are also excluded from the list.

To approve a self-registration request:

1. Selectthe link in the Approval Required for... email message to open the New User Approval page in your web
browser.

2. Review the information and select either Approve or Deny, as appropriate.
Approval is required only if Require administrator approval is enabled in the self-registration settings.

If the request is approved, FortiAuthenticator sends the user an email or SMS message stating that the account has
been activated.

How a user requests registration
A user can request registration, or self-register, from the FortiAuthenticator login screen.

To request registration:

1. Browse to the IP address of FortiAuthenticator.

Security policies must be in place on the FortiGate unit to establish these sessions.
2. Select Register to open the user registration page.
Fill in all the required fields and, optionally, fill in the Additional Information fields.
4. Select OK to request registration.

If administrator approval is not required and Display on browser page is enabled, the account details are
immediately displayed to the user.

Lud

Token self-provisioning

User token self-provisioning allows users to set up their own FortiTokens without direct intervention of an administrator.
To configure token self-provisioning settings, go to Authentication > Self-service Portal > Token self-provisioning.

The following settings can be configured:

Token Self-registration

Allow FortiToken Hardware Enable this option if you want to allow users to self-provision their own FortiToken
self-provisioning Hardware tokens.

Allow FortiToken Mobile self- Enable this option if you want to allow mobile users to self-provision their
provisioning FortiToken Mobile.

Allow Email self-provisioning  Enable this option if you want to allow users to self-provision their FortiToken
Mobile via email.

Allow SMS self-provisioning Enable this option if you want to allow users to self-provision their FortiToken
Mobile via SMS.
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Token Self-registration

Allow user to request a token Enable this option if you want to allow users to request a new token using an email
from Administrator at this address.
email address

Restrict token self- Enable this option if you want to restrict token self provisioning only to members of

provisioning to members of selected user groups.
specific groups

Token Self-revocation

Allow users to report a lost Enable this option if you want to allow users to report a lost token to a specific
token to the Administrator at email address.
this email address

Allow users to temporarily use Enable this option if you want to allow users to switch to temporary SMS based
SMS token authentication if a  authentication. The administrator will also be notified.

mobile number was pre-

configured

Allow users to temporarily use Enable this option if you want to allow users to switch to temporary email based
email token authentication if authentication. The administrator will also be notified.
an email was pre-configured

Allow users to re-provision Enable this option if you want to allow mobile users to re-provision their token.
their FortiToken Mobile

How a user registers a token
If enabled, a user can self-register a token from the user portal screen.

To self-register:

1. Browse to the IP address of the user portal and log in.
2. Goto My Account > User > Register Token to open the token registration options.
3. Fillin all the required fields.
Only options that the administrator has configured under the Token Self-registration options are available.
4. Select OK to register token.

If a token is already assigned to the user, the token registration page will display the token along with its serial
number.

How a user reports a lost token

A user can report a lost token (mobile or physical) from the user portal screen.
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To report lost token:

1. Browse to the IP address of the user portal.
2. Selectl lost my token.

The user is directed to a page warning them that their account will be locked and the administrator will be notified.
Select OK to continue.

3. Select the preferred option.
Only options that the administrator has configured under the Token Self-revocation options are available.
4. Select OK to continue.

Device self-enroliment

Device certificate self-enrollment is a method for local and remote users to obtain certificates for their devices. It can be

used to enable EAP-TLS for BYOD configurations, or for VPN authentication. For example:

« Auser brings their tablet to a BYOD organization.

« They log in to FortiAuthenticator and create a certificate for the device.

« With their certificate, username, and password they can authenticate to gain access to the wireless network.
» Without the certificate, they are unable to access the network.

ﬂ EAP-TLS is a bidirectional certificate authentication method; the client and the
’ FortiAuthenticator EAP need to have matching certificates from the same CA.

To enable device self-enrollment and adjust self-enroliment settings, go to Authentication > Self-service Portal >
Device Self-enroliment and select Enable user device certificate self-enroliment.

SCEP must be enabled to activate this feature, see SCEP on page 228.

Edit Device Self-enrollment Settings

@ Enable user device certificate self-enrollment

SCEP enrollment template: [ Please Select ] |~

Maximum devices: 1

Key size: 1024 4096

Enable self-enrollment for Smart Card certificate

The following settings can be configured:

SCEP enroliment template Select a SCEP enrollment template from the dropdown menu. SCEP can be
configured in Certificate Management > SCEP.
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Maximum devices

Key size

Enable self-enroliment for
Smart Card certificate

Set the maximum number of devices that a user can self-enroll.

Select the key size for self-enrolled certificates (1024, 2048, or 4096 bits).
Note that iOS devices only support 1024 and 2048.

Select to enable self-enrollment for smart card certificates.

This requires that a Device FQDN be configured (in the System Information
widget under System > Dashboard > Status), as itis used in the CRL
Distribution Points (CDPs) certificate extension.

Select OK to apply any changes you have made.
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Port-based network access control

Port-based network access control (PNAC), or 802.1X authentication requires a client, an authenticator, and an
authentication server (such as a FortiAuthenticator device).

The client is a device that wants to connect to the network. The authenticator is simply a network device, such as a
wireless access point or switch. The authentication server is usually a host that supports the RADIUS and EAP
protocols.

The client is not allowed access to the network until the client’s identity has been validated and authorized. Using 802.1X
authentication, the client provides credentials to the authenticator, which the authenticator forwards to the authentication
server for verification. If the authentication server determines that the credentials are valid, the client device is allowed
access to the network.

FortiAuthenticator supports several IEEE 802.1X EAP methods.

Extensible Authentication Protocol

FortiAuthenticator supports several IEEE 802.1X Extensible Authentication Protocol (EAP) methods. These include
authentication methods most commonly used in WiFi networks.

EAP is defined in RFC 3748 and updated in RFC 5247. EAP does not include security for the conversation between the
client and the authentication server, so it is usually used within a secure tunnel technology such as TLS, TTLS, or MS-
CHAP.

FortiAuthenticator supports the following EAP methods:

Method Server Auth Client Auth Encryption Native OS Support

PEAP (MSCHAPvV2) Yes Yes Yes Windows XP, Vista, 7, 8, 10
EAP-TTLS Yes No Yes Windows Vista, 7, 8, 10

EAP-TLS Yes Yes Yes Windows (XP, 7, 8, 10), Mac OS X,

iOS, Linux, Android
EAP-GTC Yes Yes Yes None (external supplicant required)

In addition to providing a channel for user authentication, EAP methods also provide certificate-based authentication of
the server computer. EAP-TLS provides mutual authentication: the client and server authenticate each other using
certificates. This is essential for authentication onto an enterprise network in a BYOD environment.

For successful EAP-TLS authentication, the user’s certificate must be bound to their account in Authentication > User
Management > Local Users (see Local users on page 81) and the relevant RADIUS client in Authentication >
RADIUS Service > Clients (see RADIUS service on page 135) must permit that user to authenticate. By default, all
local users can authenticate, but it is possible to limit authentication to specified user groups.
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FortiAuthenticator and EAP

FortiAuthenticator delivers all of the authentication features required for a successful EAP-TLS deployment, including:

» Certificate Management: Create and revoke certificates as a CA. See Certificate management on page 210.

« Simple Certificate Enroliment Protocol (SCEP) Server: Exchange a certificate signing request (CSR) and the
resulting signed certificate, simplifying the process of obtaining a device certificate.

FortiAuthenticator unit configuration

To configure FortiAuthenticator, you need to:

1. Create a CA certificate for FortiAuthenticator. See Certificate authorities on page 220.
Optionally, you can skip this step and use an external CA certificate instead. Go to Certificate Management >
Certificate Authorities > Trusted CAs to import CA certificates. See Trusted CAs on page 228.

2. Create a server certificate for FortiAuthenticator, using the CA certificate you created or imported in the preceding
step. See End entities on page 211.

3. Ifyou configure EAP-TTLS authentication, go to Authentication > RADIUS Service > EAP and configure the
certificates for EAP. See Configuring certificates for EAP on page 174.

4. |f SCEP will be used:

« Configure an SMTP server for sending SCEP notifications. Then configure the email service for the
administrator to use the SMTP server that you created. See Email services on page 66.

» Goto Certificate Management > SCEP > General, select Enable SCEP, select the CA certificate that you
created or imported in Step 1 in the Default CA field, and select OK. See SCEP on page 228.

5. Goto Authentication > Remote Auth. Servers > LDAP and add the remote LDAP server that contains your user
database. See LDAP on page 126.

6. Import users from the remote LDAP server. You can choose which specific users are permitted to authenticate. See
Remote users on page 90.

7. Goto Authentication > RADIUS Service > Clients to add the FortiGate wireless controller as an authentication
client. Be sure to select the type of EAP authentication you intend to use. See RADIUS service on page 135.

Configuring certificates for EAP

FortiAuthenticator can authenticate itself to clients with a CA certificate.

1. Goto Certificate Management > Certificate Authorities > Trusted CAs to import the certificate you will use. See
Trusted CAs on page 228.

Go to Authentication > RADIUS Service > EAP.

Select the EAP server certificate from the EAP Server Certificate dropdown menu.

Select the trusted CAs and local CAs to use for EAP authentication from their requisite lists.

Select OK to apply the settings.

o oD

Configuring switches and wireless controllers to use 802.1X authentication

The 802.1X configuration is largely vendor dependent. The key requirements are:

« RADIUS server IP: This is the IP address of the FortiAuthenticator.
« Key: The pre-shared secret configured in the FortiAuthenticator authentication client settings.
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o Authentication port: By default, FortiAuthenticator listens for authentication requests on port 1812.

Non-compliant devices

802.1X methods require interactive entry of user credentials to prove a user’s identity before allowing them access to the
network. This is not possible for non-interactive devices, such as printers. MAC Authentication Bypass (MAB) is
supported to identify and accept non-802.1X compliant devices onto the network using their MAC address as
authentication.

This feature is only for 802.1X MAB. FortiGate captive portal MAC authentication is supported by configuring the MAC
address as a standard user, with the MAC address as both the username and password, and not by entering it in the
MAC Devices section.

Multiple MAC devices can be imported in bulk from a CSV file. The first column of the CSV file contains the device
names (maximum of 50 characters), and the second column contains the corresponding MAC addresses
(0123456789AB0r01:23:45:67:89:AB).

When creating a new MAC-based authentication device, MAC addresses can be defined using wildcard capability to
identify and accept all devices from a specific vendor. The first three bytes of a MAC address identify the vendor of the
device. Define MAC devices using only the top three bytes to include all devices from a specific vendor. The following
wildcard input formats are valid:

e 112233

e 11:22:33

o 112233XXXXXX

o 11:22:33:xx:XX:XX

To configure MAC-based authentication for a device:

1. Go to Authentication > User Management > MAC Devices.
The MAC device list is displayed.

2. Ifyou are adding a new device, select Create New to open the Create New MAC-based Authentication Device
window.
If you are editing an already existing device, select the device from the device list.

3. Enterthe device name in the Name field.

4. Enterthe device’s MAC address in the MAC address field. Alternatively, enter a wildcard MAC address to
represent all MAC devices from a specific vendor.

5. Select OK to apply your changes.

To import MAC devices:

1. Inthe MAC device list, select Import.
2. Select Browse to locate the CSV file on your computer.

3. Select OK to import the list.
The import will fail if the maximum number of MAC devices has already been reached, or if any of the information
contained within the file does not conform, for example if the device name too long, or there is an incorrectly
formatted MAC address.
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Fortinet Single Sign-On

Fortinet Single Sign-On (FSSO) is a set of methods to transparently authenticate users to FortiGate devices. This means
that FortiAuthenticator is trusting the implicit authentication of a different system, and using that to identify the user.
FortiAuthenticator takes this framework and enhances it with several authentication methods:

« Users can authenticate through a web portal and a set of embeddable widgets.

» Users with FortiClient Endpoint Security installed can be automatically authenticated through the FortiClient SSO
Mobility Agent.

« Users authenticating against Active Directory can be automatically authenticated.

» RADIUS Accounting packets can be used to trigger an FSSO authentication.

« Users can be identified through the FortiAuthenticator API. This is useful for integration with third-party systems.

vy
‘?' This section describes FSSO only. FSSO authentication methods do not require accounting

proxy configuration.

FortiAuthenticator must be configured to collect the relevant user logon data. After this basic configuration is complete,
the various methods of collecting the log in information can be set up as needed.

Domain controller polling

When FortiAuthenticator runs for the first time, it will poll the domain controller (DC) logs backwards until either the end of
the log file or the logon timeout setting, whichever is reached first.

When FortiAuthenticator is rebooted, the memory cache is written to the disk, then re-read at startup, retaining the
previous state. Windows DC polling restarts on boot, then searches backwards in the DC log files until it reaches either
the log that matches the last known serial number found in the login cache file, the log that is older than the last recorded
read time, or the end of the log file, whichever is reached first.

The currently logged in FSSO users list is cached in memory and periodically written to disk. In an active-passive HA
cluster, this file is synchronized to the standby member.

Windows management instrumentation polling

FortiAuthenticator supports Windows Management Instrumentation (WMI) polling to detect workstation log off. This
validates the currently logged on user for an IP address that has been discovered by the DC polling detection method.

Remote WMI access requires that the related ports are opened in the Windows firewall, and access to a domain account
that belongs to the domain admin group.

To open ports in the Windows firewall in Windows 7, run gpedit .msc, go to Computer configuration >
Administrative Templates > Network > Network Connections > Windows Firewall > Domain Profile, go to Allow
remote admin exception, then enable remote admin exception and, if necessary, configure an IP subnet/range.
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General settings

FortiAuthenticator units listen for requests from authentication clients and can poll Windows AD servers.

To configure FortiAuthenticator FSSO polling:

1. Goto Fortinet SSO Methods > SSO > General to open the Edit SSO Configuration window. The Edit SSO
Configuration window contains sections for FortiGate, FSSO, and user group membership.

2. Inthe FortiGate section, configure the following settings:

Edit 550 Configuration

FortiGate
Listening port:

& Enable authentication

STatatel
LA

Secret kﬁ‘y‘: LTI T
Login expiry: 480 minutes
Extend user session beyond logoff by: 4] seconds (0-3600)

& Enable NTLM authentication

User domain:

Listening port

Enable authentication

Login expiry

Extend user session beyond

logoff by
Enable NTLM authentication

techdoc. local

Leave at 8000 unless your network requires you to change this. Ensure this
port is allowed through the firewall.

Select to enable authentication, then enter a secret key, or password, in the
Secret key field.

The length of time, in minutes, that users can remain logged in before the
system logs them off automatically. The default is 480 minutes (8 hours).

The length of time, in seconds, that a user session is extended after the user
logs off, from 0 (default) to 3600 seconds.

Select to enable NTLM authentication, then enter the NETBIOS or DNS name
of the domain that the login user belongs to in the User domain field.
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In the Fortinet Single Sign-On (FSSO) section, configure the following settings:

Fortinet Single Sign-On (FSSO)

Maximum concurrent user sessions: 0 [Configure Per User/Graup)]

v [ oe

@ Enable Windows event log polling (e.g. domain controllers/Exchange servers) [Configure Events,

Log level: Error [Configur

@ Enable DNS lookup to get IP from workstation name
@ Directly use domain DNS suffix in lookup
@ Enable reverse DNS lookup to get workstation name from IP
Do one more DNS lookup to get full list of IPs after reverse lookup of workstation name
Include account name ending with $ {usually computer account)
Enable FortiNAC SSO
Enable RADIUS Accounting SSO clients
@ Enable Syslog SSO[Configure ources|
@ Enable FortiClient S50 Mobility Agent Service

FortiClient listening port: 8001
@ Enable authentication
Secret key: sssssnee
Keep-alive interval: 5 minutes (1-60)
Idle timeout: 10 minutes
@ Enable NTLM
NTLM authentication expiry: 480 minutes (1-10080)
@ Enable hierarchical FSSO tiering
Collector listening port: 8003
@ Enable DC/TS Agent Clients
DC/TS Agent listening port: 8002

@ Require authentication for TS agents (disables DC agent support)
Secret key: sssssses
@ Enable DNS lookup to get IP from workstation name

@ Ignore workstation name that is not full DNS name
@ Enable reverse DNS lookup to get workstation name from IP
Restrict auto-discovered domain controllers to configured Windows event log sources and remote LDAP servers
@ Enable Windows Active Directory workstation IP verification
Enable IP change detection via DNS lookup

@ Disable NTLMv1 in client authentication to Windows AD server

@ Disable SMB1 in client connection to Windows AD server

Maximum concurrent user
sessions

Log level

Enable Windows event log
polling (e.g. domain
controllers/Exchange servers)

Enable DNS
lookup to get IP
from workstation
name

Directly use
domain DNS
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Enter the maximum number of concurrent FSSO login sessions a user is

allowed to have. Use 0 for unlimited.

Select Configure Per User/Group to configure the maximum number of
concurrent sessions for each user or group. See Fine-grained controls on
page 192.

Select one of Error, Warning, Info, or Debug as the minimum severity
level of events to log.

Select Download all logs to download all FSSO logs to your management
computer.

Select to enable Windows AD polling. This includes polling logon events
from devices using Kerberos authentication or from Mac OS X systems.

Select Configure Events to select the Windows security event IDs to use in
event log polling. Select from event IDs 528, 540, 672, 673, 674, 680, 4624,
4768,4769,4770,and 4776.

Select to use DNS lookup to get IP address information when an event
contains only the workstation name. This option is enabled by default.

Select to use the domain DNS suffix when doing a DNS lookup. This option
is disabled by default.
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suffix in lookup

Enable reverse
DNS lookup to

get workstation
name from IP

Do one more DNS
lookup to get full
list of IPs after
reverse lookup of
workstation name

Include account
name ending with
$ (usually
computer
account)

Enable FortiNAC SSO

Enable Radius Accounting SSO
clients

Enable Syslog SSO

Enable FortiClient SSO Mobility
Agent Service

FortiClient
listening port

Enable
authentication

Keep-alive
interval

Idle timeout

Enable NTLM
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Select to enable reverse DNS lookup. Reverse DNS lookup is used when
an event contains only an IP address and no workstation name. This option
is enabled by default.

Reverse DNS lookup is used when an event contains only an IP address
and no workstation name. After the workstation name is determined, it is
used in the DNS lookup again to get more complete IP address information.
This is useful in environments where workstations have multiple network
interfaces. This option is disabled by default.

Accounts that end in "$" used to exclusively denote computer accounts with
no actual user, but in some cases, valid accounts imported from dated
systems can feature them. This option is disabled by default.

Select to enable the retrieval of SSO sessions from FortiNAC sources.

Select Edit to choose one or more configured FortiNAC sources to use as
SSO sources.

Select Configure FortiNACs to configure FortiNAC sources (under
System > Administration > FortiNACs). For more information, see
FortiNACs on page 59.

Select to enable the detection of users sign-ons and sign-offs from
incoming RADIUS accounting (Start, Stop, and Interim-Update) records.

Select to enable Syslog SSO, and configure syslog sources.

Select to enable single sign-on (SSO) by clients running FortiClient
Endpoint Security. For more information, see FortiClient SSO Mobility
Agent on page 198.

Enter the FortiClient listening port number.

Select to enable authentication, then enter a secret key, or password, in the
Secret key field.

Enter the duration between keep-alive transmissions, from 1 to 60 minutes.
Default is 5 minutes.

Enter an amount of time in minutes after which to logoff a user if their status
is not updated. The value cannot be lower than the Keep-alive interval
value.

Select to enable the NT LAN Manager (NTLM) to allow logon of users who
are connected to a domain that does not have the FSSO DC Agent
installed. Disable NTLM authentication only if your network does not
support NTLM authentication for security or other reasons.

Enter an amount of time after which NTLM authentication expires in the
NTLM authentication expiry field, from 1 to 10080 minutes (7 days).
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Enable hierarchical FSSO
tiering

Enable DC/TS Agent Clients

Require

authentication for

TS agents
(disables DC
agent support)

Enable DNS
lookup to get IP
from workstation
name

Ignore

workstation name

that is not full
DNS name

Enable reverse
DNS lookup to

get workstation
name from IP

Restrict auto-discovered
domain controllers to
configured Windows event log
sources and remote LDAP
servers

Enable Windows Active
Directory workstation IP
verification

Disable NTLMv1 in client
authentication to Windows AD
server

Disable SMB1 in client
connection to Windows AD
server
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Select to enable hierarchical FSSO tiering. Enter the collector listening port
in the Collector listening port field.

Select to enable clients using DC or TS Agent. Enter the UDP port in the
DC/TS Agent listening port field. Default is 8002.

Select to require authentication, then enter a secret key, or password, in
the Secret key field.

Select to use DNS lookup to get IP address information when a client
contains only the workstation name. This option is enabled by default.
FortiAuthenticator attempts to obtain the workstation IP address using DNS
lookup if the logon request contains only the workstation name. If the initial
lookup fails, FortiAuthenticator will retry every 10 seconds for the following
5 minutes.

Select if the DNS server does not support a workstation name thatis not a
full DNS name, otherwise service delay may occur. This option is enabled
by default.

Select to enable reverse DNS lookup. Reverse DNS lookup is used when a
client contains only an IP address and no workstation name. This option is
enabled by default.

Select to enable restricting automatically discovered domain controllers to
already configured domain controllers only. See Windows event log
sources on page 186.

Select to enable workstation IP verification with Windows Active Directory.

If enabled, select Enable IP change detection via DNS lookup to detect
IP changes via DNS lookup.

Optionally, disable NTLMv1, as NTLMv2 is supported.

Optionally, disable SMB1.
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4,

In the User Group Membership section, configure the following settings:

User Group Membership
Group cache mode:

Group cache item lifetime: 480

Passive

Active

minutes (30-10080}

Clear cache

@ Do not use cached groups and always load groups from server for the following SSO sources:

Windows event log polling
RADIUS Accounting 550
Syslog S50
FortiClient S50 Mobility Agent
DC Agent
TS Agent

@ User login portal
550 web service

Base distinguished names to search:

F

@ Use groups in group container (instead of using container name as group) when handling FortiGate group filtering

Group cache mode

Group cache item
lifetime

Do not use cached groups
and always load groups from
server for the following SSO
sources

Base distinguished names to
search for nesting of
users/groups into cross
domain, domain local groups

Use groups in group
container (instead of using
container name as group)
when handling FortiGate
group filtering

5. Select OK to apply the settings.

Select the group cache mode:
» Passive: ltems have an expiry time after which the are removed and re-
queried on the next logon.
« Active: Items are periodically updated for all currently logged on users.

Enter the amount of time in minutes between 30-10080 (maximum of one
week) after which items will expire (when Group cache mode is set to
Passive), or the amount of time after which items will update for active logins
(when Group cache mode is set to Active).

Additionally, you can Clear cache (when in Passive), or manually Update
cache (whenin Active).

Select to prevent using cached groups and to always load groups from server
for the following SSO sources:

* Windows event log polling

¢ RADIUS Accounting SSO

e Syslog SSO

* FortiClient SSO Mobility Agent

* DC Agent

e TS Agent

e User login portal

» SSO web service

Enter the base distinguished names to search for nesting of users or groups
into cross domain and domain local groups.

Select to use groups in group container instead of using container name as the
group when handling FortiGate group filtering. This option is enabled by
default.
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Configuring FortiGate units for FSSO

Each FortiGate unit that will use FortiAuthenticator to provide Single Sign-On authentication must be configured to use
FortiAuthenticator as an SSO server.

To configure SSO authentication on the FortiGate unit:

On the FortiGate unit, go to Security Fabric > External Connectors and select Create New.
Select FSSO Agent on Windows AD.

Enter a name for FortiAuthenticator in the Name field.
In the Primary FSSO agent field, enter the |P address of FortiAuthenticator.

In the Password field, enter the secret key that you defined for FortiAuthenticator. See Enable authentication on
page 177.

6. Select OK.

In a few minutes, the FortiGate unit receives a list of user groups from FortiAuthenticator. When you open the
server, you can see the list of groups. The groups can be used in identity-based security policies.

a b obd-=

Portal services

The SSO portal supports a logon widget that you can embed in any web page. Typically, an organization would embed
the widget on its home page.

The SSO portal sets a cookie on the user’s browser. When the user browses to a page containing the login widget,
FortiAuthenticator recognizes the user and updates its database if the user’s IP address has changed. The user will not

need to re-authenticate until the login timeout expires, which can be up to 30 days. To log out of FSSO immediately, the
user can select the Logout button in the widget.

The SSO portal supports multiple authentication methods including manual authentication, embeddable widgets, and
Kerberos authentication.

To configure portal services, go to Fortinet SSO Methods > SSO > Portal Services.

Edit Portal Services Settings

@ Enable SSO on legacy self-service portal

Realms:

Realm 550

local (default realm)
Embeddable login widget:

Login widget demo:

SAML Portal
Enable SAML portal
S50 Web Service
@ Enable SSO Web Service
S50 user type:

The following settings can be configured:

FortiAuthenticator 6.3.1 Administration Guide 182
Fortinet Technologies Inc.



Fortinet Single Sign-On

User Portal

Self-service portal
policies

Realms

Embeddable login
widget

Login widget demo

Login timeout

Maximum delay

when redirecting to

an external URL
Kerberos User Portal

Import keytab and
enable

Kerberos Principal

Select Enable SSO on self-service portals to use self-service portals as SSO
login portal.

Select self-service portal policies from the Self-service portal policies search
box.

Select Enable SSO on legacy self-service portal to use legacy self-service
portals as SSO login portal.

\‘é', Enable SSO on legacy self-service portal toggle is only

available if the legacy self-service portal is enabled in System
> Administration > Features.

Add realms to which the client will be associated. See RADIUS service on page
135.

e Select a realm from the dropdown menu in the Realm column.

e Select whether or not to allow local users to override remote users for the

selected realm.

¢ Select whether or not to use Windows AD domain authentication.

« Edit and filter users based on the groups they are in.

« If necessary, add more realms to the list.

» Select the realm that will be the default realm for this client.

Use this code to embed the login widget onto your site. The code in the field
cannot be manually edited.

A demo of what the login widget will look like on your site.

Set the maximum number of minutes a user is allowed to stay logged in before
they are automatically logged out from SSO, between 1-10080 (maximum of one
week, set by default).

Set the delay in seconds that occurs when redirecting to an external URL,
between 1-10 seconds, with a default of 7 seconds.

Select Enable Kerberos login for SSO to enable Kerberos log in for SSO. See

Kerberos on page 184 for more information.

Select to open the Import Keytab window where you can import a keytab from
your computer.

A keytab must be imported to enable Kerberos log in for SSO.

View the Kerberos principal.
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SAML Portal Select Enable SAML portal to enable SAML Portal log in for SSO.
SSO Web Service Select Enable SSO Web Service to use the web service to log users in and out.
SSO user type Specify the type of user that the client will provide: external, local, or remote

(LDAP server must be selected from the dropdown menu).

Kerberos

Kerberos authentication allows the FortiAuthenticator to identify connecting users through a Kerberos exchange after a
redirect from a FortiGate device.

A keytab file that describes your Kerberos infrastructure is required. To generate this file, you can use a ktpass utility.
The following code can be used in a batch file to simplify the keytab file creation:

set OUTFILE=FortiAuthenticator.keytab
set USERNAME=FortiAuthenticator@corp.example.com

set PRINC=HTTP/FortiAuthenticator.corp.example.com@CORP.EXAMPLE.COM
set CRYPTO=all

set PASSWD=Pa$s$pOrt
set PTYPE=KRB5 NT PRINCIPAL

ktpass -out SOUTFILES -pass $SPASSWD% -mapuser S$USERNAMES -princ $PRINC% -crypto $CRYPTO% -
ptype $PTYPES

The FortiGate device can be configured to redirect unauthenticated users to the FortiAuthenticator, however the
Kerberos authentication URL is different than the standard login URL. The Custom Message HTML for the Login Page
HTML Redirect for Kerberos is as follows:

<!DOCTYPE HTML>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta http-equiv="refresh" content="1;url=http://<FortiAuthenticator-fgdn>/login/kerb-
auth?user continue url=%%PROTURI%%">
<script type="text/javascript">
window.location.href = http://<FortiAuthenticator-fgdn>/login/kerb-auth?user
continue url=%%PROTURI%% B
</script>
<title>
Page Redirection
</title>
</head>
<body>
If you are not redirected automatically, click on the link
<a href='http://<FortiAuthenticator-fgdn>/login/kerb-auth?user continue
url=%%PROTURISS ' > Bl a
http://<FortiAuthenticator-fqgdn>/login/kerb-auth?user continue url= $%$PROTURI%%
</a>
</body>
</html>
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SAML authentication

Security Assertion Markup Language (SAML) is an XML standard that allows for maintaining a single repository for
authentication amongst internal and/or external systems.

The FortiAuthenticator can act as a Service Provider (SP) to request user identity information from a third-party Identity

Provider (IDP). This information can then be used to sign the user on transparently based on what information the IDP
sends.

Multiple SAML SP portals can be created on the FortiAuthenticator, with each portal configured to a different SAML IDP.

In this scenario:

1. Auser attempts to connect to the Internet via FortiGate.

The user is not authenticated in FSSO so gets redirected to FortiAuthenticator.

FortiAuthenticator (a service provider) checks with the existing third-party IDP to get the user identity.
FortiAuthenticator pushes identity and group information into FSSO.

FortiAuthenticator redirects the user to the original URL.

FortiGate sees the user in FSSO and allows the user to pass.

o a ks wN

To configure a SAML SP portal, go to Fortinet SSO Methods > SSO > SAML Authentication.

The following options are available:

Create New Configure a new SAML SP portal.
Delete Delete the selected SAML SP portals.
Edit Edit the selected SAML SP portal.

To configure a new SAML SP portal:

1. From Fortinet SSO Methods > SSO > SAML Authentication, select Create New.
2. Configure the following settings:

Remote SAML server Select a configured remote SAML server, or select [ Create New ]
to configure a new remote SAML server. See SAML on page 133
for more information.

Enable SSO disclaimer Select to require a SAML SP SSO end-user to agree to a disclaimer
before they are redirected to the SAML IDP for authentication.

The Login Disclaimer Page and Disclaimer Denied Page can be
customized. See Replacement messages on page 62 for more
information.

Domain Membership

Get SSO domain name from Select the method that determines the domain name:

« SAML assertion attribute: Enable and enter the SAML
assertion attribute that domain names are obtained from.
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¢ Username prefix/suffix: Enable to obtain the domain name
specified in the username. For example: user@domain,
domain\user, domain/user

» Explicitly set to: Enable and enter the domain name to

assign to the user.

3. Select OK to create the new SAML SP portal.

Windows event log sources

FortiAuthenticator must be configured to communicate with the domain controller if Active Directory (AD) will be used to

ascertain group information.

A domain controller entry can be disabled without deleting its configuration. This can be useful when performing testing

and troubleshooting, or when moving controllers within your network.

A\,

must specify a DNS server that can provide the IP addresses of the domain controllers. See

DNS on page 42.

sq, In order to properly discover the available domains and domain controllers, the DNS settings

To add a domain controller:

1. Goto Fortinet SSO Methods > SSO > Windows Event Log Sources.
2. Select Create New to open the Create New Windows Event Log Source window.
Create New Windows Event Log Source
NetBIOS name: \
Display name:
IP:

Account:

Password:

Server type: Exchange server
Disable

LDAP Lookup

Priority: Primary Secondary Disabled

Enable secure connection

3. Enter the following information:

NetBIOS name Name of the domain controller as it appears in NetBIOS.
Display name Unique name to easily identify this domain controller.

IP Network IP address of the controller.

Account Account name used to access logon events.
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Password
Server type
Disable

Priority

Enable secure connection

4. Select OK.

By default, FortiAuthenticator uses auto-discovery of Domain Controllers. If you want to restrict operation to the
configured domain controllers only, go to Fortinet SSO Methods > SSO > General and enable Restrict auto-
discovered domain controllers to configured Windows event log sources and remote LDAP servers. See
General settings on page 177.

The user must have read access to the logs using the built in AD security
group "Event Log Readers."

Password for the above account.

Select either Domain controller or Exchange server as the server type.

Disable the domain controller without losing any of its settings.

Define multiple domain controllers for the same domain. Each can be

designated as Primary or Secondary. The Primary unit is accessed first.

Enable a secure connection over either LDAPS or STARTTLS with a CA
certificate.

RADIUS accounting sources

If required, SSO can be based on RADIUS accounting records. The FortiAuthenticator receives RADIUS accounting

packets from a carrier RADIUS server or network device, such as a wireless controller, collects additional group
information, and then inserts itinto FSSO for use by multiple FortiGate devices for identity based policies.

The FortiAuthenticator must be configured as a RADIUS accounting client to the RADIUS server.

To view the RADIUS accounting SSO client list, go to Fortinet SSO Methods > SSO > RADIUS Accounting Sources.

To configure and enable a RADIUS accounting client:

1. From the RADIUS accounting SSO client list, select Create New. The Create New RADIUS Accounting SSO

Client window opens.
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Create New RADIUS Accounting SSO Client

Name:
Client name/IP:
Secret:

Description:

SSO user type: @ External @
(O Local users @

(O Remote users @ | [Please Select ]

@ Strip off prefix or suffix from username if any

RADIUS Attributes

Username attribute: User-Name Browse Default
Client IPv4 attribute: Calling-Station-Id Browse Default
Client IPvé attribute: Framed-|Pvé-Address Browse Default
User group attribute: Fortinet-Group-Name Browse Default

2. Enter the following information:

Name

Client name/IP
Secret
Description

SSO0 user type
Strip off prefix or suffix from

username if any

RADIUS Attributes

3. Select OK to apply the changes.

“ Canl:e'

Enter a name in the Name field to identify the RADIUS accounting client on the
FortiAuthenticator.

Enter the RADIUS accounting client's FQDN or IP address.
Enter the RADIUS accounting client’s pre-shared key.
Optionally, enter a description of the client.

Specify the type of user that the client will provide: external, local, or remote
(LDAP server must be selected from the dropdown menu).

Enable to strip prefixes and suffixes from the SSO usernames.

If required, customize the username, client IP, and user group RADIUS
attributes to match the ones used in the incoming RADIUS accounting
records. See RADIUS attributes on page 109.

4. Enable RADIUS accounting SSO clients by going to Fortinet SSO Methods > SSO > General and selecting
Enable RADIUS Accounting SSO clients. See General settings on page 177.

Syslog sources

The FortiAuthenticator can parse username and IP address information from a syslog feed from a third-party device, and

inject this information into FSSO so it can be used in FortiGate identity based policies.

Syslog objects include sources and matching rules. Sources identify the entities sending the syslog messages, and
matching rules extract the events from the syslog messages. Messages coming from non-configured sources will be

dropped.
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Ay
‘Q' Injection of IPv6 addresses using Syslog-to-FSSO and API-to-FSSO is supported. IPv6
- addresses are accepted by the backend parsing engine.

To configure syslog objects, go to Fortinet SSO Methods > SSO > Syslog Sources.

iy
‘?' Syslog SSO must be enabled to configure syslog objects. Go to Fortinet SSO Methods >
- SSO0 > General to enable Syslog SSO. See General settings on page 177.

The following options and information are available:

Create New Create a new syslog source or matching rule.

Delete Select to delete the selected object or objects.

Edit Select to edit the selected object.

View Select Syslog Sources or Matching Rules from the dropdown menu.
Name The name of the source or rule.

Client name/IP The IP address or the client.

Syslog sources

Each syslog source must be defined for the syslog daemon to accept traffic. Each source must also be configured with a
matching rule (either pre-defined or custom built; see below), and syslog service must be enabled on the network
interface(s) that will listen to remote syslog traffic.

To add a new syslog source:

1. Inthe syslog list, select Syslog Sources from the View dropdown menu.
2. Select Create New. The Create New Syslog Source page ones.
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3. Enter the following information:

Name Enter a name for the source.
IP address Enter the IP address of the source.
Matching rule Select the requisite matching rule from the dropdown menu. A

matching must already be created for the source.

SSO0 user type Select the SSO user type:

¢ External: Users are not defined on the FortiAuthenticator and
user groups come from the source.

* Local users: Users are defined on the FortiAuthenticator as local
users, and user groups are retrieved from the local groups. Any
group from the syslog messages are ignored.

¢ Remote users: Users are defined on a remote LDAP server and
user groups are retrieved from the LDAP server. Any group from
the syslog messages are ignored.

Strip off prefix or suffix Enable to strip prefixes and suffixes from the SSO usernames.
from username if any

4. Select OK to add the source.

Matching rules

A matching rule is a query, or policy, that is applied to a syslog message in order to determine required information, such
as the username and IP address. Rules are required for every syslog source.

Predefined rules are available for FortiNAC appliances, and Aruba and Cisco wireless controllers (see Predefined rules
on page 190). For other systems, custom policies can be created to parse message files in various formats.

Predefined rules

Predefined matching rules are included for FortiNAC appliances, and Aruba and Cisco ACS or ISE wireless controllers.

\y

~ P Each field containing a variable (e.g. Client IPv4 and Client IPv6 fields) needs one or more
? characters after the {{:variable}} to let FortiAuthenticator know where to stop the parsing. Any
- combination of characters will work. The examples below use ",".
FortiNAC
Trigger FSSO
Auth Type Indicators Logon: 1ogin

Logoff: 1ogout
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Username field
Client IPv4 field
Client IPv6 field

Group field

Group list separator

Aruba

Trigger

Auth Type Indicators

Username field
Client IPv4 field
Client IPv6 field

Group field

Group list separator

Cisco

Trigger

Auth Type Indicators

Username field
Client IPv4 field
Client IPv6 field

Group field

username={{:username}},

IP={{:client ip}},

€.g. Framed-IPv6-Address={{:client ipv6}},
tags="{{:group}}"

SSO syslog feed can parse multiple groups if the names are
separated by a plus (+) symbol or a comma (,).

None; any logs are accepted.

Logon: User Authentication Successful (exact match
required; no delimiter or value)

username={{:username}},

IP={{:client ip}},

€.g. Framed-IPv6-Address={{:client ipv6}},
AAA profile={{:group}}

SSO syslog feed can parse multiple groups if the names are
separated by a plus (+) symbol or a comma (,).

NOTICE Radius-Accounting

Logon: Acct-Status-Type=Start
Update: Acct-Status-Type=Interim
Logoff: Acct-Status-Type=Stop

User-Name={ { :username}},
Framed-IP-Address={{:client ip}},
€.g. Framed-IPv6-Address={{:client ipv6}},

e.g.profile={{:group}}
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Group list separator

SSO syslog feed can parse multiple groups if the names are

separated by a plus (+) symbol or a comma (,).

To create a new matching rule:

1. Inthe syslog list, select Matching Rules from the View dropdown menu.

2. Select Create New. The Create New Syslog Matching Rule page opens.

3. Enter the following information:

Name
Description
Fields to Extract

Trigger

Auth Type Indicators

Username field

Client IPv4 field

Client IPv6 field

Group field

Test Rule

Enter a name for the source.
Optionally enter a description of the rule.
Configure the fields to extract from the message.

Optionally, enter a string that must be present in all syslog
messages. This will act as a pre-filter.

Enter strings to differentiate between the types of user activities:
Logon, Update (optional), and Logoff (optional).

Define the semantics of the username field. For example: User-
Name={ { :username} }, where {{iusername}} indicates where
the username is extracted from.

Define the semantics of the client IPv4 address.
Define the semantics of the client IPv6 address.

Optionally, define the semantics of the group. The group may not
always be included in the syslog message, and may need to be
retrieved from a remote LDAP server.

Use the Group list separator to specify the separator.

Paste a sample log message into the text box, then select Test to
test that the desired fields are correctly extracted.

4. Select OK to add the new matching rule.

Fine-grained controls

The Fine-grained Controls menu provides options to include or exclude a user or group from SSO, and set the

maximum number of concurrent sessions that a user or group can have.

To adjust the controls, go to Fortinet SSO Methods > SSO > Fine-grained Controls.

The following options are available:

Clear Configuration Clear the SSO configuration for the selected users or groups.
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Include in SSO

SSO Type

SSO Name

Maximum Concurrent
Sessions

Excluded from SSO

To edit an SSO user or group:

Select a user or users, then select Include in SSO to include the selected users
in SSO.

Select the SSO type to view from the dropdown menu. The options are: Local
Users, Local Groups, SSO Users, and SSO Groups.

The users’ or groups’ names. Select the column title to sort the list by this column.

The maximum concurrent sessions allowed for the user or group. This number
cannot be greater than five.

If the user or group is excluded from SSO, a red circle with a line is displayed.

1. Inthe Fine-grained Controls window, click the SSO user or group to edit.
The Edit SSO Fine-grained Control Item window opens.

2. Enter the maximum number of concurrent SSO logon sessions per user that the user or group is allowed to have.
Enter 0 for unlimited. The value must be less than or equal to five.

3. Select OK to apply the changes.

SSO users and groups

To manage SSO users and groups, go to Fortinet SSO Methods > SSO > SSO Users or SSO Groups.

The following options are available:

Create New

Import
Delete
Edit
Name

Created/Imported

Select to create a new user or group.

In the Create New SSO User or Create New SSO Group window, enter a name
for the user or group, then select OK.

Import SSO users or groups from a remote LDAP server.
Delete the selected users or groups.

Edit the selected user or group.

The SSO user or group names.

Displays whether or not the user or user group was created or imported.

FortiAuthenticator SSO user groups cannot be used directly in a security policy on a FortiGate device. An FSSO user
group must be created on the FortiGate unit, then the FortiAuthenticator SSO groups must be added to it. FortiGate
FSSO user groups are available for selection in identity-based security policies. See the FortiOS Handbook for more

information.
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To import SSO users or groups:

1. Inthe SSO Users or SSO Groups list, select Import.
 Inthe Import SSO Users or Import SSO Groups window, select whether to import the DN or Username, and
select a remote LDAP server from the Remote LDAP Server dropdown menu, then select Browse.
¢ Inthe Import SSO Groups window, select a remote LDAP server from the Remote LDAP Server dropdown

menu and select Browse. Alternatively, select Azure ADFS and specify the Graph API Service Root, Client
ID, and Client key.

Ay
‘Q' An LDAP server must already be configured to select it in the dropdown menu. See LDAP
- service on page 149 for more information on adding a remote LDAP server.

The Import SSO Users or Import SSO Groups window opens in a new browser window.

Import SSO Users

LDAP server: 192.168.1.25:389
Distinguished name: test
Filter: (&lobjectClass=user){objectCategory = person))

Apply Clear User attributes

@ Filter child nodes and show number of children

Select user(s) to import below. Only LDAP entries that are marked green can be imported (indicating that these entries match the configured LDAP filter and their usernames can be found using the
configured username attribute). You can configure other user mapping attributes above
Select Visible Select Nons
Query failed: Idap_search_ext_s connection failed: Can't contact LDAP server
FortiToken Logo: [ Please Select] »
IAM Account: [ Please Select] »

n conee

2. Optionally, edit the Distinguished name. This field is automatically filled when you select a remote LDAP server
from the Remote LDAP Server dropdown.

3. Optionally, enter a Filter string to reduce the number of entries returned, and then select Apply, or select Clear to
clear the filters.
For example, uid=7j* returns only user IDs beginning with “j”.

4. The default configuration imports the attributes commonly associated with Microsoft Active Directory LDAP
implementations. Select User attributes to edit the remote LDAP user mapping attributes.
Selecting the field, FirstName for example, presents a list of attributes which have been detected and can be
selected. This list is not exhaustive; other non-displayed attributes may be available for import. Consult your LDAP
administrator for a list of available attributes.

5. Select the entries you want to import.

6. Optionally, select a logo from the FortiToken Logo dropdown menu to associate the imported users with the

specified logo. This logo is displayed beside the one-time password in FortiToken. See FortiTokens on page 105 for
more information.

7. Optionally, select an IAM account from the IAM Account dropdown to associate the imported users with the
specified IAM account. See Identity and Account Management (IAM) on page 108.

8. Select OK to import the users or groups.

Domain groupings

Domain groupings enable you to identify and group together SSO sessions from domains belonging to a specific
FortiGate or virtual domain (VDOM). This is useful in environments where the networks behind each FortiGate or VDOM
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have their own set of users and IP subnets. Domain groupings allow the FortiAuthenticator to return only the SSO
sessions belonging to users from a specific FortiGate or VDOM.

To manage domain groupings, go to Fortinet SSO Methods > SSO > Domain Groupings.

The following options are available:

Create New Configure a new domain grouping.

Delete Delete the selected domain groupings.

Edit Edit the selected domain grouping.

Name The name of the domain grouping.

Description A description of the domain grouping.

Domains A list of domains that belong to the domain grouping.

Logins from domains that do not belong to any other configured domain grouping are assigned to the Default domain
grouping.

To create a new domain grouping:

1. From the Domain Groupings list, select Create New.
The Create New Domain Grouping window opens.

2. Enter the following information:

Name Enter a name for the domain grouping.
Description Optionally, enter a description for the domain grouping.
Domain list Enter the domains that belong to the domain grouping, separated with

commas or line breaks.
Note: A domain can only belong to one domain grouping.

3. Select OK to create the new domain grouping.
After domain groupings are defined, the SSO sessions list displays the corresponding domain grouping of each
SSO session. See SSO on page 205 for more information.

FortiGate filtering

If you are providing FSSO to only certain groups on a remote LDAP server, you can filter the polling information so that it
includes only those groups, or organizational units (OU).

To view a list of the FortiGate group filters, go to Fortinet SSO Methods > SSO > FortiGate Filtering.
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To create a new filter:

1. From the FortiGate filters select Create New.
The Create New FortiGate Filter window opens.

2. Enter the following information:

Name
FortiGate name/IP
Description

IP Filtering

Domain Grouping Filtering

Fortinet Single Sign-On
(FSSO)

Enter a name in the Name field to identify the filter.
Enter the FortiGate unit's FQDN or IP address.
Optionally, enter a description of the filter.

Select to enable IP filtering for this service.

Choose the desired IP filtering rules from the Available IP filtering rules box
and move them to the Selected IP filtering rules box.

Note: If you have not yet configured IP filtering rules, you can select the
[Create new rule] option in the Available IP filtering rules box, or create
them under Fortinet SSO Methods > SSO > IP Filtering Rules (see IP
filtering rules on page 196 for more information).

Select to enable forwarding FSSO information for users from only the selected
domain groupings.
See Domain groupings on page 194 for more information.

Select to enable forwarding FSSO information for users from only the specific
subset of users, groups, or containers.

Select Create New under SSO Filtering Objects, enter a name to identify the
policy, and select from the following object types:

¢ Group: Specifies the DN of a group. All users who are members of that
group must be included in SSO.

» Group container: Specifies the DN of an LDAP container, e.g. OU. All
users who are members of a group under that container or one of its sub-
containers must be included in SSO.

¢ User: Specifies the DN of a user. This user must be included in SSO.

¢ User container: Specifies the DN of an LDAP container, e.g. OU. All
users who are under that container or one of its sub-containers must be
included in SSO.

* User and group container: Specifies the DN of an LDAP container, e.g.
OU. Itis the union of the user and the group containers.

You can also use the Import option to import an existing object.
To select individual groups in FortiGate policies, each AD group must be
imported and listed in the FortiGate filter.

3. Select OK to create the new FortiGate group filter.

IP filtering rules

The user logon information sent to FortiGate units can be restricted to specific IP addresses or address ranges. If no
filters are defined, information is sent for all addresses.
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When created, IP filtering rules must be assigned to FortiGate filters under Fortinet SSO Methods > SSO > FortiGate
Filtering (see FortiGate filtering on page 195 for more information).

To view the list of the IP filtering rules, go to Fortinet SSO Methods > SSO > IP Filtering Rules.
To create new IP filtering rules:

1. From the IP filtering rules list, select Create New. The Create New IP Filtering Rule window opens.
2. Enter the following information:

Name Enter a name for the rule.
Filter Mode Either Include or Exclude the defined IPs in SSO.
Filter Type Select whether the rule will specify an IPv4 address and netmask, an IPv6

address range, or an IPv6 address.

Rule Enter either an IP address and netmask or an IP address range (depending on
the selected filter type). For example:
* IPv4 address/mask: 10.0.0.1/255.255.255.0
e IPrange:10.0.0.1/10.0.0.99
e IPv6:2001:db8:1ced:f00d::/128

3. Select OK to create the new IP filtering rule.

Tiered architecture

Tier nodes can be managed by going to Fortinet SSO Methods > SSO > Tiered Architecture. A maximum of five tier
nodes can be configured.

The following options are available:

Create New Select to create a new tier node.
Delete Select to delete the selected node or nodes.
Edit Select to edit the selected node.
Search Enter a search term to search the tier node list.
Name The node name.
Tier Role The node’s tier role, either Collector or Supplier.
Address The IP address of the node.
Port The collector port number. Only applicable if Tier Role is Collector.
Serial Number The serial number or numbers.
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Enabled If the node is enabled, a green circle with a check mark is shown.
A node can be disabled without losing any of its settings.

To add a new tier node:

1. From the tier node list, select Create New. The Create New Tier Node window opens.

Create New Tier Node
MName:

Serial number: Alternative serial number:

Tier role: Supplier Collector

MNode IP address:
Collector Port: 3
Disable

“ Cance'

2. Enter the following information:

Name Enter a name to identify the node.

Serial number Enter the device serial number.

Alternative serial number Optionally, enter a second, or alternate, serial number for an HA cluster
member.

Tier role Select the tier node role, either Supplier or Collector.

Node IP address Enter the IP address for the supplier or collector.

Collector Port Enter the collector port number. Default is 8003.

This is only available when Tier role is set to Collector.

Disable Disable the node without losing any of its settings.

3. Select OK to create the new tier node.

FortiClient SSO Mobility Agent

The FortiClient SSO Mobility Agent is a feature of FortiClient Endpoint Security. The agent automatically provides user
name and IP address information to FortiAuthenticator for transparent authentication. IP address changes, such as
those due to WiFi roaming, are automatically sent to the FortiAuthenticator. When the user logs off or otherwise
disconnects from the network, FortiAuthenticator is aware of this and deauthenticates the user.

The FortiClient SSO Mobility Agent Service must be enabled in Fortinet SSO Methods > SSO > General. See Enable
FortiClient SSO Mobility Agent Service on page 179

Setup of the FortiClient SSO Mobility Agent uses standard Msiexec installation switches as well as FortiClient SSO
switches, including SSOSERVER, SSOPORT, and SSOPSK. For example: FortiClientSSO.msi /qgn /i
SSOSERVER="1.2.3.4" SSOPORT="8001" SSOPSK="pre shared key".

For additional Msiexec installation switches, see Microsoft's documentation on command-line options.

FortiAuthenticator 6.3.1 Administration Guide 198
Fortinet Technologies Inc.


https://docs.microsoft.com/en-us/windows/win32/msi/command-line-options

Fortinet Single Sign-On

For information on configuring FortiClient, see the FortiClient Administration Guide for your device.

Fake client protection

Some attacks are based on a user authenticating to an unauthorized AD server in order to spoof a legitimate user logon
through the FortiClient SSO Mobility Agent. You can prevent this type of attack by enabling NTLM authentication (see
Enable NTLM on page 179).

FortiAuthenticator will initiate NTLM authentication with the client, proxying the communications only to the legitimate AD
servers it is configured to use.

If NTLM is enabled, FortiAuthenticator requires NTLM authentication when:

« the userlogs on to a workstation for the first time,

« the user logs off and then logs on again,

» the workstation IP address changes,

» the workstation user changes,

o and NTLM authentication expires (user configurable).
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A FortiGate or FortiMail unit can transparently identify users who have already authenticated on an external RADIUS
server by parsing RADIUS accounting records. However, this approach has potential difficulties:

« The RADIUS server is business-critical IT infrastructure, limiting the changes that can be made to the server
configuration.

« In some cases, the server can send accounting records only to a single endpoint. Some network topologies may
require multiple endpoints.

The FortiAuthenticator RADIUS accounting proxy overcomes these limitations by proxying the RADIUS accounting
records, modifying them, and replicating them to the multiple subscribing endpoints as needed.

RADIUS accounting proxy

The FortiAuthenticator receives RADIUS accounting packets from a carrier RADIUS server, transforms them, and
forwards them to multiple FortiGate or FortiMail devices for use in RADIUS Single Sign-On (RSSO). This differs from the
packet use of RADIUS accounting (RADIUS accounting sources on page 187).

The accounting proxy needs to know:

« the rule sets to define or derive the RADIUS attributes that the FortiGate unit requires,
« the source of the RADIUS accounting records (i.e. the RADIUS server),

« and the destination(s) of the accounting records (i.e. the FortiGate units using this information for RSSO
authentication).

General

General RADIUS accounting proxy settings can be configured by going to Fortinet SSO Methods > Accounting Proxy
> General.

The following settings are available:

Log level Select Error, Warning, Info, or Debug as the minimum event severity level to log
from the dropdown menu. The default is Error.

Group cache lifetime Enter the amount of time after which user group memberships will expire in the
cache, from 1-10080 minutes (maximum of one week). The default is 480.

Number of proxy retries Enter the number of times to retry proxy requests if they timeout, from 0-3 retries,
where 0 disables retries. The default is 3.

Proxy retry timeout Enter the retry timeout period of a proxy request, from 1-10 seconds. The default
is 5.
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Statistics update period Enter the time between statistics updates to the seconds debug log, from 1-3600
seconds (maximum of one hour). The default is 5.

Select OK to apply your changes.

Rule sets

A rule set can contain multiple rules. Each rule can do one of the following:

o Add an attribute with a fixed value.
« Add an attribute retrieved from a user’s record on an LDAP server.
» Rename an attribute to make it acceptable to the accounting proxy destination.

FortiAuthenticator can store up to 25 rule sets. You can provide both a name and description to rule sets to help identify
each rule set and their purpose.

Rules access RADIUS attributes of which there are both standard attributes and vendor-specific attributes (VSAs). To
select a standard attribute, select the default vendor. See RADIUS attributes on page 109.

To view the accounting proxy rule set list, go to Fortinet SSO Methods > Accounting Proxy > Rule Sets.
To add RADIUS accounting proxy rule sets:

1. From the rule set list, select Create New. The Create New Rule Set window opens.

Create New Rule Set

Name:

Description:

Rules

Rule: #1

Action: Add v

Attribute: Browse

Value type: Static value v

Value:

Description: Add attribute "[Attribute]" containing static value "[value]"
Rule: #2

Action: Add ~

Attribute: Browse

Value type: Group names |+

Username attribute: Browse

Remote LDAP: [ Please Select ] ~

Description: Add attribute "[Attribute]" containing "Group names” from group membership of *[Username Attribute]" attribute on remote LDAP server "[server]"

Add another Rule
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2. Enter the following information:

Name Enter a name to use when selecting this rule set for an accounting proxy
destination.
Description Optionally, enter a brief description of the rule’s purpose.
Rules Enter one or more rules.
Action The action for each rule can be either Add or Modify.

* Add: Add either a static value or a value derived from an LDAP server.
* Modify: Rename an attribute.

Attribute Select Browse and choose the appropriate Vendor and Attribute ID in the
Select a RADIUS Attribute dialog box.

Attribute 2 If Action is set to Modify, a second attribute may be selected. The first
attribute is renamed to the second attribute.

Value type If the action is set to Add, select a value type from the dropdown menu.
e Static value: Adds the attribute in the Attribute field containing the static
value in the Value field.
¢ Group names: Adds attribute in the Attribute field containing "Group
names" from the group membership of the Username Attribute on the
remote LDAP server.

Value If the action is set to Add and Value Type is set to Static value, enter the
static value.

Username If the action is set to Add, and Value Type is not set to Static value, specify

attribute an attribute that provides the user’s name, or select Browse and choose the
appropriate Vendor and Attribute ID in the Select a RADIUS Attribute dialog
box.

Remote LDAP If the attribute addition requires an LDAP server, select one from the
dropdown menu. See LDAP on page 126 for information on remote LDAP
servers.

Description A brief description of the rule is provided.

Add another Rule Select to add another rule to the rule set.

3. Select OK to create the new rule set.

Example rule set

The incoming accounting packets contain the following fields:

e User-Name
o NAS-IP-Address
« Fortinet-Client-IP-Address

The outgoing accounting packets need to have these fields:

o User-Name
o« NAS-IP-Address
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o Fortinet-Client-IP-Address
» Session-Timeout: Value is always 3600

o Fortinet-Group-Name: Value is obtained from user's group membership on remote LDAP

The rule set needs two rules to add Session-Timeout and Fortinet-Group-Name. The following image provides an

example:

Create New Rule Set

Name:

Description:

Rules

Rule: #1

Action:

Attribute:

Value type:

Value:

Description:
Rule: #2

Action:

Attribute:

Value type:
Username attribute:
Remote LDAP:
Description:

Add another Rule

Sources

rule-1

Add ~
Session-Timeout Browse
Static value ~

3600

Add attribute "Session-Timeout” containing static value "3600"

Add <
Fortinet-Group-Name Browse
Group names |
User-Name Browse

LDAP REMOTE AUTH (172.27.2.245) |~

Add attribute "Fortinet-Group-Name"” containing "Group names" from group membership of "User-Name" attribute on remote LDAP server "LDAP REMOTE AUTH (172.27.2.245)"

“ gancel

The RADIUS accounting proxy sources list can be viewed in Fortinet SSO Methods > Accounting Proxy > Sources.
Sources can be added, edited, and deleted as needed. A maximum of 500 proxy sources can be configured.

To add a RADIUS accounting proxy source:

1. From the source list, select Create New. The Create New RADIUS Accounting Proxy Source window opens.
2. Enter the following information:

Name Enter the name of the RADIUS server. This is used in FortiAuthenticator
configurations.

Source name/IP Enter the FQDN or IP address of the server.

Secret Enter the pre-shared secret required to access the server.

Description Optionally, enter a description of the source.

3. Select OK to add the RADIUS accounting proxy source.
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Destinations

The destination of the RADIUS accounting records is the FortiGate unit that will use the records to identify users. When

defining the destination, you also specify the source of the records (a RADIUS client already defined as a source) and

the rule set to apply to the records.

To view the RADIUS accounting proxy destinations list, go to Fortinet SSO Methods > Accounting Proxy >
Destinations. A maximum of 500 proxy destinations can be configured.

To add a RADIUS accounting proxy destinations:

1. From the destinations list, select Create New. The Create New RADIUS Accounting Proxy Destination window

opens.
2. Enter the following information:

Name

Destination name/IP

Secret

Source

Rule set

Enter a name to identify the destination device in your configuration.

Enter The FQDN or IP address of the FortiGate that will receive the RADIUS
accounting records.

Enter the pre-shared key of the destination.

Select a RADIUS client defined as a source from the dropdown menu. See
Sources on page 203.

Select an appropriate rule set from the dropdown menu or select Create New
to create a new rule set. See Rule sets on page 201.

3. Select OK to add the RADIUS accounting proxy destination.
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Monitoring

The Monitor menu tree provides options for monitoring SSO and authentication activity.

For more information, see SSO on page 205 and Authentication on page 207.

SSO

FortiAuthenticator can monitor the units that make up FSSO. This is useful to ensure there is a connection to the different
components when troubleshooting.

Domains

To monitor SSO domains, go to Monitor > SSO > Domains. Select Refresh to refresh the domain list. Select Expand
All to expand all of the listed domains, or Collapse All to collapse the view.

All configured domain controllers appear in the domain list. Each domain controller is displayed in:

« green if the last connection attempt was successful.
« gray if no recent connection information is available.
« red if the last connection attempt failed.

Hold the pointer over a domain controller to view the status of the last LDAP query, how long ago it was, and the LDAP
query's response time in milliseconds (ms). This response time will show a warning icon if the highest recent response
time is above 500 ms.

In addition, you can click on the domain controller entry to view statistics for the 100-most recent LDAP queries. The
listed response times are color coordinated as follows: green for less than 500 ms, orange for between 500 and 1000
ms, and red for more than, or equal to, 1000 ms.

SSO sessions

To monitor SSO sessions, go to Monitor > SSO > SSO Sessions. Users can be manually logged off of if required.

The following information is available:

Refresh Refresh the SSO sessions list.
Logoff All Log off all of the connected users.
Logoff Selected Log off only the selected users.
Search Enter a search term in the search field, then select Search to search the SSO
sessions list.
FortiAuthenticator 6.3.1 Administration Guide 205

Fortinet Technologies Inc.



Monitoring

Filter Filter the SSO session list by the source of the connection and/or by Domain
Group.
To view SSO sessions not associated with any configured domain grouping,
select Default.

Logon Time When the session was started.

Update Time When the session was last updated.
Workstation The workstation that the user is using.

IP address The IP address of the workstation.

Domain Grouping The domain group to which the domain belongs.
Domain The domain to which the user belongs.
Username The username of the user.

Source The source of the connection.

Group The group to which the user belongs.

Windows event log sources

Windows event log sources can be viewed by going to Monitor > SSO > Windows Event Log Sources.
The sources list can be refreshed by selecting Refresh, and searched using the search field.

The list shows the total number of events, as well as the most recent event.

FortiGates

FortiGate units that are registered with FortiAuthenticator can be viewed at Monitor > SSO > FortiGates.

The list can be refreshed by selecting Refresh and searched using the search field. The list shows the connection time
of each device, as well as its IP address and serial number.

User authentication events are logged in the FortiGate event log. See the FortiGate Handbook for more information.

DC/TS agents

Domain controller (DC) agents and terminal server (TS) agents that are registered with FortiAuthenticator can be viewed
at Monitor > SSO > DC/TS Agents.

The list can be refreshed by selecting Refresh and searched using the search field.

The list shows the server name of each agent, as well as its IP address, its agent type, last connection time, connection
status, and the number of logged-on users.
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NTLM statistics

Dumped NTLM statistics can be viewed at Monitor > SSO > NTLM Statistics.

The statistics can be refreshed and cleared by selecting Refresh and Clear respectively.

Authentication

Locked out/inactive users, RADIUS sessions, the Windows AD server and device login sessions, and learned RADIUS
users can be monitored under Monitor > Authentication.

Locked-out users

To view the locked-out users, go to Monitor > Authentication > Locked-out Users.

To unlock a user from the list, select the user and select Unlock. The list can be refreshed by selecting Refresh, and
searched using the search field.

The list shows the username, server, the reason the user was locked out, and when their lock-out expires.

For more information on locked-out users, see Top user lockouts widget on page 38, Lockouts on page 75, and User
management on page 80.

RADIUS sessions

You can monitor RADIUS activity and log out users.
To view currently active RADIUS accounting sessions, go to Monitor > Authentication > RADIUS Sessions.

The page shows the user's name, type, IP address, MAC address, and RADIUS client, duration, and data usage
columns. More specifically, Accounting-Start Interim-Update packets are received. A user session is removed from this
table after the Accounting-Stop packet is received, or the session doesn't receive any RADIUS accounting packets
before the timeout period expires.

To log out a user as an admin, select the user from the table and select Logoff.

There are two pages to view: Active and Cumulative. Select Cumulative to view statistics for user who have a time
and/or data usage limit. This information may be accumulated through a succession of RADIUS accounting sessions. A
user's stats are removed when explicitly deleted by the administrator (by selecting the user and selecting Delete), or
when the user's account itself is deleted.

While administrators can log out users, they can also reset a user's time and/or data usage using Reset Usage.
For more information on user time and data usage limits, see Usage profile on page 103.

RADIUS accounting sessions can be configured to timeout after a specific time period has been reached. To do so, see
General.
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Windows AD

FortiAuthenticator supports multiple Windows AD server forests, as shown below. A maximum of 20 remote
LDAP servers with Windows AD enabled can be configured at once. In addition, you can see when the server was last
updated, and an option to reset the connection for individual servers.

To view Windows AD server information, go to Monitor > Authentication > Windows AD.

To refresh the connection, select Refresh in the toolbar. The server name, IP address, authentication realm, agent, and
connection are shown.

Windows device logins

To view the Windows device logins, go to Monitor > Authentication > Windows Device Logins.

To refresh the list, select Refresh in the toolbar. See Machine authentication on page 73 for more information.

Learned RADIUS users

Learned RADIUS users are users that have been learned by the FortiAuthenticator after they have authenticated against
a remote RADIUS server.

For information on enabling learning RADIUS users, see RADIUS on page 131.

SAML IdP sessions

This page monitors active sessions of SAML IdP logged-in users. The monitoring page displays a list of all the active
sessions in a table format with each row containing the key information of the session.

To view currently active SAML sessions, go to Monitor > Authentication > SAML IdP Sessions.
The page shows the user's name, type, IP address, MAC address, authentication time, and validity period.
You can search for active SAML IdP sessions by username or IP address in the search field.

Selecting an active session opens the SAML IdP session Details. Session details include the following information:

User Info
Username The username of the user.
User type The user type (local or remote).
User IP The user's IP address.
Session valid The session validity period (start and end time).
Authentication factor The authentication factors used (password, token, etc.).
User Attributes Lists the user attributes and their values associated with this session.

Service Providers
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Name The name of the service provider.
Time of Request The time the SAML request was made.
Certificate Subject Identifies the certificate subject of the SAML request.
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Certificate management

This section describes managing certificates with the FortiAuthenticator device.

FortiAuthenticator can act as a CA for the creation and signing of X.509 certificates, such as server certificates for
HTTPS and SSH, and client certificates for HTTPS, SSL, and IPsec VPN.

The FortiAuthenticator unit has several roles that involve certificates:

Certificate authority The administrator generates CA certificates that can validate the user certificates
generated on this FortiAuthenticator.

The administrator can import other authorities' CA certificates and Certificate
Revocation Lists (CRLs), as well as generate, sign, and revoke user certificates.
See End entities on page 211 for more information.

SCEP server A SCEP client can retrieve any of the local CA certificates (Local CAs on page
220), and can have its own user certificate signed by the FortiAuthenticator
device's CA.

Remote LDAP authentication Acting as an LDAP client, FortiAuthenticator can authenticate users against an
external LDAP server. It verifies the identity of the external LDAP server by using
a trusted CA certificate. See Trusted CAs on page 228 for more information.

EAP authentication FortiAuthenticator can check that the client’s certificate is signed by one of the
configured authorized CA certificates (see Certificate authorities on page 220).
The client certificate must also match one of the user certificates (see End entities
on page 211).

Any changes made to certificates generate log entries that can be viewed under Logging > Log Access > Logs. See
Logging on page 235.

Policies

The policies section includes global configuration settings which are applied across all CAs and end-entity certificates
created on FortiAuthenticator.

Certificate expiry

Certificate expiration settings can be configured under Certificate Management > Policies > Certificate Expiry.

Enable Warn when a certificate is about to expire to configure the following:

Send a warning email Enter the number of days before the certificate expires that the email will be sent,
between 0-365 (maximum of one year). The defaultis 7.
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Administrator's email Enter the email address to which the expiry warning message are sent to.

Select OK to apply any configuration changes.

End entities

User and server certificates are required for mutual authentication on many HTTPS, SSL, and IPsec VPN network
resources. You can create a user certificate on the FortiAuthenticator device, or import and sign a CSR. User
certificates, client certificates, or local computer certificates are all the same type of certificate.

To view the user certificate list, go to Certificate Management > End Entities > Users. To view the server certificate
list, go to Certificate Management > End Entities > Local Services.

The following information is available:

Create New Create a new certificate.

Import Select to import a certificate signed by a third-party CA for a previously generated
CSR (see To import a local user certificate: on page 217 and To import a server
certificate: on page 217) or to import a CSR to sign (see To import a CSR to sign:
on page 217).

Revoke Revoke the selected certificate. See To revoke a certificate: on page 219.

Delete Delete the selected certificate.

Export Certificate

Export Key and Cert

Save the selected certificate to your computer.

Export the PKCS#12. This is only available for user certificates.

Search Enter a search term in the search field, then press Enter to search the certificate
list.

Filter Select to filter the displayed certificates by status. The available selections are:
Active and Pending, Pending, Pending, Expired, Revoked, Active, and All.
By default, only valid (active and pending) certificates are shown.

Certificate ID The certificate ID.

Subject The certificate’s subject.

Issuer The issuer of the certificate.

Status The status of the certificate.

Expiry The expiration date of the certificate.
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Certificates can be created, imported, exported, revoked, and deleted as required. CSRs can be imported to sign, and
the certificate detail information can also be viewed, see To view certificate details: on page 219.

To create a new certificate:

1. To create a new user certificate, go to Certificate Management > End Entities > Users. To create a new server
certificate, go to Certificate Management > End Entities > Local Services.

2. Select Create New to open the Create New User Certificate or Create New Server Certificate window.
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Create New User Certificate

Certificate ID:

Certificate Signing Options

lssuer: » Local CA Third-party CA
Local User (Optional): [ Please Select] ¥
Certificate authority: v

Subject Information

Subject input method: Fully distinguished name ® Field-by-field
Name (CM):

Department (OU):

Company (O):

City (L):

State/Province (ST):

Country (C): v

Email address:

Key and Signing Options

Validity period: ® Set length of time Set an expiry date
365 days

Key type: RSA

Key size: 2048 Bits T

Hash algorithm: SHA-256 ¥

Subject Alternative Name
P Email:

D@ User Principal Name (UPN):
@ URL:

P DNS:

Other Extensions
O Add CRL Distribution Points extension (Location: http://fac.school.net/cert/crl/FIPS.crl) [Edit device FQDM]
» Add OCSP Responder URL (Location: http:/fac.school.net:2560) [Edit device FQDN]

O Use certificate for Smart Card logon

Advanced Options: Key Usages

3. Configure the following settings:
Certificate ID Enter a unique ID for the certificate.

Certificate Signing Options

Issuer Select the issuer of the certificate, either Local CA or Third-party CA.
Selecting Third-party CA generates a CSR that is to be signed by a third-
party CA.
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Certificate authority

Local User (Optional)

Subject Information

Subject input method

Subject DN

Name (CN)

Key and Signing Options

Validity period

Key type

Key size

Hash algorithm

Subject Alternative Name
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If Local CA is selected as the issuer, select one of the available CAs
configured on FortiAuthenticator from the dropdown menu.

The CA must be valid and current. If it is not you will have to create or
import a CA certificate before continuing. See Certificate authorities on
page 220.

If Local CA is selected as the issuer, you may select a local user from the
dropdown menu to whom the certificate will apply. This option is only
available when creating a new user certificate.

Select the subject input method, either Fully distinguished name or
Field-by-field.

If the subject input method is Fully distinguished name, enter the full
distinguished name of the subject. There should be no spaces between
attributes.

Valid DN attributes are DC, C, ST, L, O, OU, CN, and emailAddress. They
are case-sensitive.

If the subject input method is Field-by-field, enter the subject name in the
Name (CN) field, and optionally fill-in the following fields:
¢ Department (OU)
¢ Company (O)
e City (L)
« State/Province (ST)
Country (C) (select from dropdown menu)
Email address

Select the amount of time before this certificate expires. This validity
period option is only available when Issuer is set to Local CA.

Select Set length of time to enter a specific number of days, or select Set
an expiry date to enter the specific date on which the certificate expires.

The key type is set to RSA.

Select the key size from the dropdown menu, either 1024, 2048, or 4096
bits.

Select the hash algorithm from the dropdown menu, either SHA-256 or
SHA-1.

Subject alternative names (SAN) allow you to protect multiple host names
with a single SSL certificate. SAN is part of the X.509 certificate standard.
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Email

User Principal Name
(UPN)

URI
DNS

Other Extensions

Add CRL Distribution
Points extension

Add OCSP Responder
URL

Use certificate for
Smart Card logon

Advanced Options: Key Usages

Digital Signature

Non Repudiation
Key Encipherment
Data Encipherment

Key Agreement

Certificate Sign

CRL Sign
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For example, SANs are used to protect multiple domain names such as
www.example.comand www.example.net, in contrast to wildcard
certificates that only protect all first-level subdomains on one domain, such
as *.example.com.

Enter the email address of a user to map to this certificate.

Enter the UPN used to find the user’s account in Microsoft Active
Directory. This will map the certificate to this specific user. The UPN is
unique for the Windows Server domain. This is a form of one-to-one

mapping.
Enter the URI used to validate certificates.
Enter the DNS used to validate and sign the imported CSR.

This option is only available when creating a new user certificate, and
when Issuer is set to Local CA.

Select to add CRL distribution points extension to the certificate.

A DNS domain name must be configured. If it has not been, select Edit
DNS name to configure one. See DNS on page 42.

Note: After a certificate is issued with this extension, the server must be
able to handle the CRL request at the specified location.

Enable Online Certificate Status Protocol (OCSP) to obtain the revocation
status of a certificate.

Select to use the certificate for smart card logon.

Enabling this setting will automatically enable Add CRL Distribution
Points extension.

Some certificates require the explicit presence of key usage attributes
before the certificate can be accepted for use.

A high-integrity signature that assures the recipient that a message was
not altered in transit

An authentication that is deemed as genuine with high assurance.
Uses the public key to encrypt private or secret keys.
Uses the public key to encrypt data.

An interactive method for multiple parties to establish a cryptographic key,
based on prior knowledge of a password.

A message from an applicant to a certificate authority in order to apply for a
digital identity certificate.

A Certificate Revocation List (CRL) Sign states a validity period for an
issued certificate.
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Encipher Only

Decipher Only

Advanced Options: Extended
Key Usages

Server Authentication

Client Authentication

Code Signing

Secure Email

OCSP Signing

IPSec End System

IPSec Tunnel
Termination

IPSec User

IPSec IKE Intermediate
(end entity)

Time Stamping

Microsoft Individual
Code Signing

Microsoft Commercial
Code Signing

Microsoft Trust List
Signing

Microsoft Server Gated
Crypto

Netscape Server Gated
Crypto
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Information is converted into code only.
Code is converted into information only.

Some certificates require the explicit presence of extended key usage
attributes before the certificate can be accepted for use.

Authentication will only be granted when the user submits their credentials
to the server.

Authentication is granted to the server by exchanging a client certificate.

Used to confirm the software author, and guarantees that the code has not
been altered or corrupted through use of a cryptographic hash.

A secure email sent over SSL encryption.

Online Certificate Status Protocol (OCSP) Signing sends a request to the
server for certificate status information. The server will send back a
response of "current”, "expired”, or "unknown". OCSP permits a grace
period to users or are expired, allowing them a limited time period to
renew. This is typically used over CRL.

IPsec Security Associations (SAs) are terminated through deletion or by
timing out

An intermediate certificate is a subordinate certificate issued by a trusted
root specifically to issue end-entity certificates. The result is a certificate

chain that begins at the trusted root CA, through the intermediate CA (or
CAs) and ending with the SSL certificate issued to you.

User submits information that is compared to an independent consumer
database to validate their credentials.

User submits information that proves their identity as corporate
representatives.

Uses a certificate trust list (CTL), a list of hashes of certificates. The listis
comprised of pre-authenticated items that were approved by a trusted
signing entity.

A defunct mechanism that stepped up 40-bit and 50-bit to 128-bit cipher
suites with SSL.

A defunct mechanism that stepped up 40-bit and 50-bit to 128-bit cipher
suites with SSL.
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Microsoft Encrypted The Encrypted File System (EFS) enables files to be transparently

File System encrypted to protect confidential data.

Microsoft EFS File The certificate is granted on the condition it has an EFS file recovery agent
Recovery prepared.

Smart Card Logon The certificate is granted on the condition that the user logs on to the

network with a smart card.

EAP over PPP Extensible Authentication Protocol (EAP) will operate within a Point-to-
Point Protocol (PPP) framework.

EAP over LAN EAP will operate within a Local Area Network (LAN) framework.

KDC Authentication An authentication server forwards usernames to a key distribution center

(KDC), which issues an encrypted, time-stamped ticket back to the user.

4. Select OK to create the new certificate.

To import a local user certificate:

1. Goto Certificate Management > End Entities > Users and select Import.
2. For Type, select Local certificate.

3. Select Choose File to locate the certificate file on your computer.

4. Select OK to import the certificate.

To import a server certificate:

1. Goto Certificate Management > End Entities > Local Services and select Import.
2. Select Choose File to locate the certificate file on your computer.
3. Select OK to import the certificate.

To import a CSR to sign:

1. Goto Certificate Management > End Entities > Users and select Import.
2. For Type, select CSR to sign.
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Import Signing Request or Certificate

Type: # CSR to sign Local certificate

Certificate ID:

CSR file (.csr, .req): Choose File | Mo file chosen

Certificate Signing Options

Certificate authority:

Validity period: » Set length of time Set an expiry date

365

days

Hash algorithm: SHA-256 v

Subject Alternative Name

@ Email:
@@  User Principal Name (UPN):

Other Extensions

O Add CRL Distribution Points extension (Location: http:/fac.school.net/cert/crl/FIPS.crl) [Edit device FQDN]
O Add OCSP Responder URL (Location: http://fac.school.net:2560) [Edit device FQDN]

(W Use certificate for Smart Card logon

Advanced Options: Key Usages

3. Configure the following settings:
Certificate ID
CSR file (.csr, .req)
Certificate Signing Options

Certificate
authority

Validity period

Hash algorithm

Subject Alternative Name
Email

User Principal
Name (UPN)

Other Extensions

_ cance

Enter a unique ID for the certificate.

Select Choose File then locate the CSR file on your computer.

Select one of the available CAs configured on the FortiAuthenticator from the
dropdown menu.

The CA must be valid and current. If it is not you will have to create or import a
CA certificate before continuing. See Certificate authorities on page 220.

Select the amount of time before this certificate expires.

Select Set length of time to enter a specific number of days, or select Set an
expiry date and enter the specific date on which the certificate expires

Select the hash algorithm from the dropdown menu, either SHA-256 or SHA-
1.

Enter the email address of a user to map to this certificate.

Enter the UPN used to find the user’s account in Microsoft Active Directory.
This will map the certificate to this specific user. The UPN is unique the
Windows Server domain. This is a form of one-to-one mapping.
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Add CRL
Distribution Points
extension

Add OCSP
Responder URL

Use certificate for
Smart Card logon

Advanced Options: Key
Usages and Extended Key
Usages

4. Select OK toimport the CSR.

To revoke a certificate:

Select to add CRL distribution points extension to the certificate.

A DNS domain name must be configured. If it has not been, select Edit DNS
name to configure one. See DNS on page 42.

Note: After a certificate is issued with this extension, the server must be able
to handle the CRL request at the specified location.

Enable Online Certificate Status Protocol (OCSP) to obtain the revocation
status of a certificate.

Select to use the certificate for smart card logon.

Enabling this setting will automatically enable Add CRL Distribution Points
extension.

Some certificates require the explicit presence of key usage attributes before
the certificate can be accepted for use.

Same settings available as when creating a new user certificate (see above).

1. Goto Certificate Management > End Entities > Users or to Certificate Management > End Entities > Local

Services.

2. Select the certificate you want to revoke and select Revoke.
3. Select areason for revoking the certificate from the Reason code dropdown menu. The reasons available are:

« Unspecified

« Key has been compromised
o CA has been compromised

« Changes in affiliation
o Superseded

« Operation ceased

e On Hold

Some of these reasons are security related (such as a compromised key or CA), while others are more business

related. A Change in affiliation could be an employee leaving the company, while Operation ceased could be a

project that was canceled.

4. Select OK to revoke the certificate.

To view certificate details:

From the certificate list, select a certificate ID to open the Certificate Detail Information window.

Select Edit next to the Certificate ID field to change the certificate ID. If any of this information is out of date or incorrect,

you will not be able to use this certificate. If this is the case, delete the certificate and re-enter the information in a new
certificate, see To create a new certificate: on page 212. Select Close to return to the certificate list.
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Certificate authorities

A certificate authority (CA) is used to sign other server and client certificates. Different CAs can be used for different
domains or certificates. For example, if your organization is international you may have a CA for each country, or smaller
organizations might have a different CA for each department. The benefits of multiple CAs include redundancy, in case
there are problems with one of the well-known trusted authorities.

After you have created a CA certificate, you can export it to your local computer.

Local CAs

The FortiAuthenticator device can act as a self-signed, or local, CA.
To view the certificate information, go to Certificate Management > Certificate Authorities > Local CAs.

The following information in shown:

Create New Create a new CA certificate.

Import Import a CA certificate. See Importing CA certificates and signing requests on
page 224.

Revoke Revoke the selected CA certificate.

Delete Delete the selected CA certificate.

Export Certificate

Export Key and Cert

Save the selected CA certificate to your computer.

Save the selected intermediate CA certificate and private key to your computer.

Search Enter a search term in the search field, then press Enter to search the CA
certificate list. The search will return certificates that match either the subject or
issuer.

Filter Select to filter the displayed CAs by status. The available selections are: All,
Pending, Expired, Revoked, and Active.

Certificate ID The CA certificate ID.

Subject The CA certificate subject.

Issuer The issuer of the CA certificate.

Status The status of the CA certificate.

CA Type The CA type of the CA certificate.
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To create a CA certificate:

1. From the local CA certificate list, select Create New. The Create New Local CA Certificate window opens.

Create New Local CA Certificate
Certificate |D:

Certificate Authority Type

Certificate type: Intermediate CA Intermediate CA signing request (CSR)

Use netHSM

Subject Information

Subject input method: Fully distinguished name Field-by-field

Name (CN):
Department (OU):
Company (O):

City (L):
State/Province (ST):
Country (C):

Email address:

Key And Signing Options

Validity period: Set an expiry date
3650 || days

Key type: RSA

Key size: 1024 4096

Hash algorithm: SHA-1

Subject Alternative Name
Email:
User Principal Name (UPN):
Advanced Options: Key Usages
Certificate Revocation List (CRL)
Lifetime: 30

Re-generate every: 1

2. Enter the following information:

Certificate ID
Certificate Authority Type
Certificate type

Certificate
authority

Use netHSM

Subject Information

days (1-365)

days

— Seneet

Enter a unique ID for the CA certificate.

Select one of the following options:
¢ Root CA certificate: A self-signed CA certificate.
» Intermediate CA certificate: A CA certificate that refers to a different
root CA as the authority.
* Intermediate CA certificate signing request (CSR)

Select one of the available CAs from the dropdown menu.

This field is only available when the certificate type is Intermediate CA
certificate.

Select one of the available NetHSMs from the dropdown menu. See NetHSMs
on page 61.

This field is only available when the certificate type is Root CA.
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Subject input
method

Subject DN

Name (CN)

Key and Signing Options
Validity period

Key type

Key size

Hash algorithm

Subject Alternative Name

Email

User Principal
Name (UPN)

Advanced Options: Key
Usages

Key Usages

Select the subject input method, either Fully distinguished name or Field-
by-field.

If the subject input method is Fully distinguished name, enter the full
distinguished name of the subject. There should be no spaces between
attributes.

Valid DN attributes are DC, C, ST, L, O, OU, CN, and emailAddress. They are
case-sensitive.

If the subject input method is Field-by-field, enter the subject name in the
Name (CN) field, and optionally enter the following fields:

e Department (OU)

e Company (O)

» City (L)

e State/Province (ST)

e Country (C) (select from dropdown menu)

* Email address

Select the amount of time before this certificate expires.

Select Set length of time to enter a specific number of days, or select Set an
expiry date and enter the specific date on which the certificate expires.

This option is not available when the certificate type is set to Intermediate CA
certificate signing request (CSR).

The key type is set to RSA.

Select the key size from the dropdown menu: 1024, 2048 (set by default), or
4096 bits.

Select the hash algorithm from the dropdown menu, either SHA-256 (set by
default) or SHA-1.

SANSs allow you to protect multiple host names with a single SSL certificate.
SAN is part of the X.509 certificate standard.

This section is not available when the certificate type is Intermediate CA
certificate signing request (CSR).

Enter the email address of a user to map to this certificate.

Enter the UPN used to find the user’s account in Microsoft Active Directory.
This will map the certificate to this specific user. The UPN is unique for the
Windows Server domain. This is a form of one-to-one mapping.

Some certificates require the explicit presence of extended key usage
attributes before the certificate can be accepted for use.

For detailed information about these attributes, see End entities on page 211.

« Digital Signature
¢ Non Repudiation
* Key Encipherment
e Data Encipherment
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Extended Key
Usages

Other Extensions

Add CRL
Distribution Points
extension

Add OCSP
Responder URL

Certificate Revocation List
(CRL)

Lifetime

Re-generate every

* Key Agreement
 Certificate Sign
» CRL Sign

e Encipher Only
» Decipher Only

« Server Authentication

¢ Client Authentication

e Code Signing

e Secure Email

» OCSP Signing

¢ IPSec End System

¢ IPSec Tunnel Termination

* IPSec User

» IPSec IKE Intermediate (end entity)
¢ Time Stamping

¢ Microsoft Individual Code Signing
e Microsoft Commercial Code Signing
e Microsoft Trust List Signing

¢ Microsoft Server Gated Crypto

¢ Netscape Server Gated Crypto

e Microsoft Encrypted File System
» Microsoft EFS File Recovery

¢ Smart Card Logon

« EAP over PPP

e« EAP over LAN

« KDC Authentication

Specify an OCSP and/or CRL distribution URL.

Other Extensions options are only available for Intermediate
CA certificates.

Select to add a CRL Distribution Points extension to the certificate.

Once a certificate is issued with this extension, the server must be able to
handle the CRL request at the specified location.

A fully qualified domain name (FQDN) must be configured. The FQDN can be
added or configured by clicking Edit device FQDN.

Select to add an Online Certificate Status Protocol (OCSP) responder URL to
obtain the revocation status of a certificate.

A fully qualified domain name (FQDN) must be configured. The FQDN can be
added or configured by clicking Edit device FQDN.

Determine the certificate's lifetime before the CA certificate is revoked.

Enter the lifetime of the certificate in days, between 1-365 (maximum of one
year). The default is 30.

Enter how often the certificate will regenerate.
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3. Select OK to create the new CA certificate.

Importing CA certificates and signing requests

Five options are available when importing a certificate or signing request: PKCS12 Certificate, Certificate and Private

Key, CSR to sign, Local certificate, and NetHSM certificate.

To import a PKCS12 certificate:

1. From the local CA certificate list, select Import. The Import Signing Request or Local CA Certificate window

opens.
2. Select PKCS12 Certificate in the type field.

Import Signing Request or Local CA Certificate

Type: Certificate and Private Key CSR to sign Local certificate NetHSM certificate
Certificate ID:

PKCS512 certificate file (.p12): & Upload a file

Passphrase:

Initial Serial Number
Serial number radix: Decimal Hex

Initial serial number: 10000000

“ ceneel

3. Enter the following:

Certificate ID Enter a unique ID for the certificate.
PKCS12 certificate file (.p12) Select Choose File to locate the certificate file on your computer.

Passphrase Enter the certificate passphrase.

Initial Serial Number Select the serial number radix, either Decimal or Hex, and enter the initial

serial number in the Initial serial number field.

4. Select OK to import the certificate.

To import a certificate with a private key:

1. From the local CA certificate list, select Import. The Import Signing Request or Local CA Certificate window

opens.
2. Select Certificate and Private Key in the type field.

FortiAuthenticator 6.3.1 Administration Guide
Fortinet Technologies Inc.

224



Certificate management

3. Enter the following:
Certificate ID
Certificate file (.cer)
Private key file
Passphrase

Initial Serial Number

4. Select OK to import the certificate.

To import a CSR to sign:

Enter a unique ID for the certificate.

Select Choose File to locate the certificate file on your computer.
Select Choose File to locate the private key file on your computer.
Enter the certificate passphrase.

Select the serial number radix, either Decimal or Hex, and enter the initial
serial number in the Initial serial number field.

1. From the local CA certificate list, select Import. The Import Signing Request or Local CA Certificate window

opens.

2. Select CSR to sign in the type field.

3. Enterthe following:
Certificate ID
CSR file (.csr, .req)
Certificate Signing Options

Certificate
authority

Validity period

Hash algorithm
Subject Alternative Name

Email

User Principal

Name (UPN)

Advanced Options: Key
Usages

4. Select OK toimport the CSR.

Enter a unique ID for the certificate.

Select Choose File to locate the CSR file on your computer.

Select one of the available CAs from the dropdown menu.

Select the amount of time before this certificate expires.

Select Set length of time to enter a specific number of days, or select Set an
expiry date and enter the specific date on which the certificate expires.

Select the hash algorithm from the dropdown menu, either SHA-256 or SHA-
1.

SANs allow you to protect multiple host names with a single SSL certificate.
SAN is part of the X.509 certificate standard.

Enter the email address of a user to map to this certificate.

Enter the UPN used to find the user’s account in Microsoft Active Directory.
This will map the certificate to this specific user. The UPN is unique for the
Windows Server domain. This is a form of one-to-one mapping.

Some certificates require the explicit presence of extended key usage
attributes before the certificate can be accepted for use.

For detailed information about these attributes, see End entities on page 211.
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To import a local CA certificate:

1. From the local CA certificate list, select Import. The Import Signing Request or Local CA Certificate window
opens.

Select Local certificate in the type field.
Select Upload a file to locate the certificate file on your computer.
. Select OK to import the local CA certificate.

AN

To import a NetHSM certificate:

1. From the local CA certificate list, select Import. The Import Signing Request or Local CA Certificate window
opens.

Select NetHSM certificate in the type field.

Select Upload a file to locate the certificate file on your computer.
Select the previously configured NetHSM. See NetHSMs on page 61.
Select OK to import the local CA certificate.

o oD

Certificate revocations lists

A certificate revocation list (CRL) is a file that contains a list of revoked certificates, their serial numbers, and their
revocation dates. The file also contains the name of the issuer of the CRL, the effective date, and the next update date.
By default, the shortest validity period of a CRL is one hour.

Some potential reasons certificates can be revoked include:

« A CA server was hacked and its certificates are no longer trusted.
» Asingle certificate was compromised and is no longer trusted.
« A certificate has expired and cannot be used past its lifetime.

Go to Certificate Management > Certificate Authorities > CRLs to view the CRL list.

The following information is shown:

Import Importa CRL.

Automatic Downloads Select to view automatically downloaded CRLs. Select View CRLs to switch back
to the regular CRL view.

Export Save the selected CRL to your computer.
CA Type The CA type of CRL.
Issuer name The name of the issuer of the CRL.
Subject The CRL’s subject.
Revoked Certificates The number of revoked certificates in the CRL.
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To import a CRL:

1. Download the most recent CRL from a CDP. One or more CDPs are usually listed in a certificate under the Details
tab.

2. Fromthe CRL list, select Import.
3. Select Choose File to locate the file on your computer, then select OK to import the list.

NV Before importing a CRL file, make sure that either a local CA certificate or a trusted
‘?' CA certificate for this CRL has first been imported.
- When successful, the CRL is displayed in the CRL list on the FortiAuthenticator. You can

select it to see the details (see To view certificate details: on page 219).

Locally created CRLs

When you import a CRL, it is from another authority. If you are creating your own CA certificates, you can also create
your own CRL to accompany them.

As a CA, you sign user certificates. If for any reason you need to revoke one of those certificates, it will go on a local
CRL. When this happens you must export the CRL to all your certificate users so they are aware of the revoked
certificate.

To create a local CRL:

1. Create alocal CA certificate. See Local CAs on page 220.
2. Create one or more user certificates. See End entities on page 211.

3. Goto Certificate Management > End Entities > Users, select one or more certificates, and select Revoke. See
To revoke a certificate: on page 219.
The selected certificates are removed from the user certificate list and a CRL is created with those certificates as
entries in the list. If there is already a CRL for the CA that signed the user certificates, the certificates is added to the

current CRL.
\‘ ! 'l
q If later one or more CAs are deleted, their corresponding CRLs will also be deleted, along
- with any user certificates that they signed.

Configuring OCSP

FortiAuthenticator also supports Online Certificate Status Protocol (OCSP), defined in RFC 2560. To use OCSP,
configure the FortiGate unit to use TCP port 2560 on the FortiAuthenticator IP address.

For example, enter the following to configure OCSP on the FortiGate CLI Console, where the URL is the IP address of
the FortiAuthenticator:

config vpn certificate ocsp-server
edit FortiAuthenticator ocsp
set cert "REMOTE Cert 1"
set url "http://172.20.120.16:2560"
end
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Trusted CAs

Trusted CA certificates can be used to validate certificates signed by an external CA.
To view the trusted CA certificate list, go to Certificate Management > Certificate Authorities > Trusted CAs.

The certificate ID, subject, issuer, and status are shown. Certificates can be imported, exported, deleted, and searched.

To import a trusted CA certificate:

1. From the trusted CA certificate list, select Import.
2. Enter a certificate ID in the Certificate ID field.

3. Select Choose File to locate the certificate file on your computer, and select OK to import the list.
When successful, the trusted CA certificate is displayed in the list on the FortiAuthenticator device. You can select it
to see the details (see To view certificate details: on page 219).

SCEP

FortiAuthenticator contains a Simple Certificate Enroliment Protocol (SCEP) server that can sign user CSRs, and
distribute CRLs and CA certificates. To use SCEP, you must:

« Enable HTTP administrative access on the interface(s) connected to the Internet. See Network on page 40.

The recommended configuration for SCEP interfaces includes:
Al

~ P ¢ One dedicated interface for system administration which includes enforced IP
q address restriction on admin access.

¢ One dedicated interface for service provisioning.
* One dedicated interface for the HA heartbeat when configured in an HA cluster.

« Add alocal certificate authority (root or intermediate). See Certificate authorities on page 220.
« Select the local signing CA to use for SCEP. See Default CA on page 229.

Users can request a user certificate through online SCEP, found at http://<FortiAuthenticator-IP-
Address>/cert/scep.

General

As an administrator, you can allow FortiAuthenticator to either automatically sign the user’s certificate or alert you about
the request for a signature.
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To enable SCEP and configure general settings:

1. Goto Certificate Management > SCEP > General, and select Enable SCEP.
2. Configure the following settings:

Revoke the old certificate on  Enable to revoke the old certificate after it is renewed.
renewal

Default CA Select the default local CA to use from the dropdown menu.

Default enroliment password Enter the default enroliment password that is used when not setting a random
password.

Enroliment method Select the enrollment method:

» Automatic: The certificate is pre-approved by the administrator. The
administrator enters the certificate information on FortiAuthenticator and
gives the user a challenger password to use when submitting their
request.

¢ Manual and Automatic: The user submits the CSR, the request shows
up as pending on FortiAuthenticator unit, then the administrator manually
approves the pending request. Optionally, enter an email address to be
informed of pending approval notifications.

3. Select OK to apply any changes you have made.

Enroliment requests

To view and manage certificate enroliment requests, go to Certificate Management > SCEP > Enrollment Requests.

N ! 7, Before you can create or configure certificate enroliment requests, SCEP must be enabled,
? and HTTP access must be enabled on the network interface(s) that will serve SCEP clients
3 (under System > Network > Interfaces).

The following information is available:

Create New Create a new certificate enroliment request.

Delete Delete the selected certificate enroliment request.

Approve or Reject Approve or reject the selected certificate enroliment request.

Delete & Revoke Certificate Delete the selected SCEP enroliment requests and revoke all the corresponding

active user certificates.

Ay
‘?' This option is available only if the Automatic request type for
- the selected request is Regular.
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Search

Method
Status
Wildcard

Issuer

Subject

Renewable Before Expiry

(days)

Updated at

Search for SCEP enrollment requests with subject fields matching the input text
string.

The enrollment method used.
The status of the enrollment: Pending, Approved, or Rejected.
Ifitis a wildcard request, a green circle with a check mark is shown.

The issuer of the certificate. Hover over the truncated value to see the full issuer
name.

The certificate subject. Hover over the truncated value to see the full subject
name.

The number of days before the certificate enrollment request expires that it can be
renewed.

The date and time that the enroliment request was last updated.

To view the enrollment request details:

1. From the enrollment request list, select a request by clicking within its row.
2. Select Cancel to return to the enroliment request window.
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To create a new certificate enroliment request:

1. From the certificate enroliment requests list, select Create New.

Create New Certificate Enrollment Request

Automatic request type: [ Resuiar  [RETESRS
Certificate Authority

Certificate authority. test Auth | CN-abe v

Subject Information

Subject input method Fully distinguished name
Name (CN)

Department (OU):

Company (O

City (L):

State/Province (ST):

Country (C): v
Email address:

Certificate Signing Options

Validity period: Setan expiry date

365 days

Hash algorithm: sHA256 [N

Challenge Password

Password creation: [ Rancom  [ERENS
Challenge password distribution: sMs | Email
Email address;
Mobile number: SMS gateway:
Renewal
Allow renewal |7 days before certificate is expired
Allow renewal if revoked
Allow renewal if expired
Verify renewal request signature using the old private key
Subject Alternative Name
Email
User Principal Name (UPN):
Other Extensions
it device FQDN
Add CRL Distribution Points extension (Location: Device FQDN has not been configured)
Add OCSP Responder URL (Location: Device FQDN has not been configured)
© Advanced Options: Key Usages
Key Usages:
Critical

Extended Key Usages:
Critical

Choose all

2. Enter the following information:

Automatic request type

Certificate Authority

Subject Information

Subject input method
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Chosen Key Usages @

Chosen Extended Key Usages @

Select the automatic request type, either Regular or Wildcard.

Select one of the available local CAs configured on FortiAuthenticator from
the dropdown menu.

The CA must be valid and current. If it is not you will have to create or
import a CA certificate before continuing. See Certificate authorities on
page 220.

Select the subject input method, either Fully distinguished name or
Field-by-field.
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Subject DN

Name (CN)

Certificate Signing Options

Validity period

Hash algorithm

Challenge Password

Password creation

Challenge password
distribution

Renewal

Subject Alternative Name

FortiAuthenticator 6.3.1 Administration Guide
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If the subject input method is Fully distinguished name, enter the full
distinguished name of the subject. There should be no spaces between
attributes.

Valid DN attributes are DC, C, ST, L, O, OU, CN, and emailAddress. They
are case-sensitive.

If the subject input method is Field-by-field, enter the subject name in the
Name (CN) field (if the Automatic request type is set to Regular), and
optionally enter the following fields:
¢ Department (OU)
¢ Company (O)
City (L)
» State/Province (ST)
Country (C) (select from dropdown menu)
Email address

Select the amount of time before this certificate expires.

Select Set length of time to enter a specific number of days, or select Set
an expiry date and enter the specific date on which the certificate expires.

Select the hash algorithm from the dropdown menu, either SHA-256 (set by
default) or SHA-1.

Select to either set a random password, or use the default enrollment
password (see Enroliment requests on page 229).

Select the challenge password distribution method. This option is only
available if Password creation is set to Set a random password.
¢ Display: Display the password on the screen.
¢ SMS: Send the password to a mobile phone. Enter the phone number
in the Mobile number field and select an SMS gateway from the
dropdown menu.
¢ Email: Send the password to the email address entered in the email
field.

To allow renewals, select Allow renewal, then enter the number of days
before the certificate expires (minimum of one day).

When renewal is enabled, you can optionally either allow or reject SCEP
renewal requests for expired and revoked certificates (as burst renewal
requests from FortiGate devices could exhaust the FortiAuthenticator and
create duplicate certificates), and either allow or reject SCEP renewal
requests signed using the old private key.

SANSs allow you to protect multiple host names with a single SSL certificate.
SAN is part of the X.509 certificate standard.

This section is not available when the certificate type is Intermediate CA
certificate signing request (CSR).
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Email

User Principal Name
(UPN)

Other Extensions

Add
CRL Distribution
Points extension

Add
OCSP Responder
URL

3. Optionally, apply key usage attributes.

& Advanced Options: Key Usages
Key Usages:

® Critical Q, [Filter
Digital Signature
Non Repudiation
Key Encipherment
Data Encipherment
Key Agreement
Certificate Sign
CRL Sign
Encipher Only
Decipher Only

Available Key Usages @

Enter the email address of a user to map to this certificate.

Enter the UPN used to find the user’s account in Microsoft Active Directory.
This will map the certificate to this specific user. The UPN is unique for the
Windows Server domain. This is a form of one-to-one mapping.

Includes optional settings for SCEP enrollment requests.

Select to add a CRL Distribution Points extension.

A fully qualified domain name (FQDN) must be configured. The FQDN can
be added or configured by clicking Edit device FQDN.

Select to add an Online Certificate Status Protocol (OCSP) responder URL
to obtain the revocation status of a certificate.

A fully qualified domain name (FQDN) must be configured. The FQDN can
be added or configured by clicking Edit device FQDN.

Selected Key Usages

Choose all

Extended Key Usages:

» Critical Q, Filter

Awvailable Extended Key Usages (%]

Selected Extended Key Usages

Server Authentication A

Client Authentication

Code Signing
Secure Email
OCSP Signing
IPSec End System

IPSec Tunnel Termination

IPSec User

IPSec IKE Intermediate (end entity)

Time Stamping

Microsoft Individual Code Signing

Microsoft Commercial Code Signing

Microsoft Trust List Signing

Mirrnsoft Seruer Gated Cruntn hd

Choose all

Advanced Options: Key
Usages
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Key Usages

Extended Key
Usages

Key usage attributes identify the purpose(s) of a certificate's key. Some
applications require the explicit presence of attributes before the certificate will
be accepted for use. When an entity contains multiple certificates or keys, key
usage attributes can also be used to identify which is the correct certificate or
key to use.

When the Critical option is enabled, the certificate can only be used for the
purposes indicated by the selected attributes, and attempting to use the
certificate for other purposes results in a CA policy violation.

For detailed information about key usage attributes, see End entities on page
211.

Extended Key Usages provides an extended list of selectable attributes.

The Critical option can also be applied to extended key usage attributes.
When the Critical option is applied to both key usage and extended key usage
attributes, only certificates that are consistent with both fields are accepted.

For detailed information about extended key usage attributes, see End entities
on page 211

4. Select OK to create the new certificate enroliment request.
When created, the request will have a Status of Pending. A code is displayed which must be provided to the client
as a challenge password for the automatic certificate enroliment process.
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Accounting is an important part of FortiAuthenticator. The Logging menu tree provides a record of the events that have
taken place on FortiAuthenticator.

Log access

To view the log events table, go to Logging > Log Access > Logs.

The following options and information are available:

Refresh Refresh the log list.
Simplified/ Full View Simplified or full log view.
Download Raw Log Export the FortiAuthenticator log to your computer as a text file named

FortiAuthenticator.log.

Log Type Reference Select to view the log type reference dialog box. See Log type reference on page
236.

Debug Report Select to download the debug report to your computer as a file named
report.dbg.

You can also download a full debug report for one of the following (using the
dropdown menu):
¢ Authentication
» Database
* GUI
e LDAP Sync
¢ RADIUS Accounting
» SSO
e System
e Custom debug
* Push Authentication
 REST API

Search for log records Enter a search term in the search field to search the log message list.

The search string must appear in the Message portion of the log entry to result in
a match. To prevent each term in a phrase from matching separately, multiple
keywords must be in quotes and be an exact match.
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ID
Timestamp

Level

Category

Sub Category
Log Type ID
Action

Status

Source IP
Short Message

User

To view log details:

After the search is complete the number of positive matches is displayed next to

the Search button, with the total number of log entries in brackets following. Select

the total number of log entries to return to the full list. Subsequent searches will
search all the log entries, and not just the previous search’s results.

The log message’s ID.
The time the message was received.

The log severity level:
* Emergency: The system has become unstable.
¢ Alert: Immediate action is required.
 Critical: Functionality is affected.
< Error: An erroneous condition exists, and functionality is probably affected.
» Warning: Functionality could be affected.
* Notification: Information about normal events.
¢ Information: General information about system operations.
e Debug: Detailed information useful for debugging purposes.

The log category, which is always Event. See Log type reference on page 236.
The log subcategory. See Log type reference on page 236.

The log type ID.

The action which created the log message, if applicable.

The status of the action that created the log message, if applicable.

The source IP address of the relevant device if an authentication action fails.
The log message itself, sometimes slightly shortened.

The user to whom the log message pertains.

From the log list, select the log whose details you need to view by clicking anywhere within the log’s row. The Log
Details pane will open on the right side of the window.

After viewing the log details, select the close icon in the top right corner of the pane to close the details pane.

Log type reference

Select Log Type Reference in the log list toolbar to open the log type reference dialog box.

The following information and options are available:
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Search for log types Enter a search term in the search field to search the log type reference.
Type id The log type ID.

Name The name of the log type.

Sub category The log type subcategory, one of: Admin Configuration, Authentication,

System, High Availability, User Portal, or Web Service.
Category The log type category, which is always Event.
Description A brief description of the log type.

To close the Log Type Reference dialog box, select close above the top right corner of the box, or simply click
anywhere outside the box within the log list.

Sort the log messages

The log message table can be sorted by any column. To sort the log entries by a particular column, select the title for that
column. The log entries will now be displayed based on data in that column in ascending order. Select the column
heading again to sort the entries in descending order. Ascending or descending is displayed with an arrow next to the
column title, an up arrow for ascending and down arrow for descending.

Log configuration

Logs can be remotely backed up to an FTP server, automatically deleted, and sent to a remote syslog server in lieu of
storing them locally.

Log settings

To configure log backups, automatic deletion, and remote storage, go to Logging > Log Config > Log Settings.
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Edit Log Setting

Log Backup
© Enable remote backup

Frequency: ooy Voniy
Time: 00:00 Nowl @

FTP directory:

FTP server. [Please Select] v

Log Auto-Deletion
@© Enable log auto-deletion
Auto-delete logs older than: 12 montis) v
FortiManager/FortiAnalyzer
© Send logs to FortiManager/FortiAnalyzer
IP Address:
Remote Syslog

@ Send system logs to remote Syslog servers

Remote syslog servers: Available

Q [Fitter

Chosen Sysiog Servers ©

@ Send debug logs to remote Syslog servers

are to be forwarded:

Syslog S5O
TACACS+ >

Choose all

Remote syslog servers: Available Syslog Servers @ Chosen Syslog Servers @

Q [Fitter

To configure log backups:

1. Under Log Backup, select Enable remote backup.
2. Setthe Frequency to either Daily, Weekly, or Monthly.
3. Configure the time of day that the backup will occur in one of the following ways:
« Enter a time in the Time field.
» Select Now to enter the current time.
« Select the clock icon and choose a time from the pop-up menu: Now, Midnight, 6 a.m., Noon, or 6 p.m.

4. Selectan FTP server from the FTP server dropdown menu. For information on configuring an FTP server, see FTP
servers on page 60.

5. Select OK to save your settings.

To configure automatic log deletion:

1. Under Log Auto-Deletion, select Enable log auto-deletion.

2. Use the Auto-delete logs older than field and dropdown menu to specify the number of either day(s), week(s), or
month(s) after which a log will be deleted.

3. Select OK to save your settings.

FortiAuthenticator 6.3.1 Administration Guide 238
Fortinet Technologies Inc.



Logging

To configure logging to a FortiManager/FortiAnalyzer unit:

1. Under FortiManager/FortiAnalyzer, select Send logs to FortiManager/FortiAnalyzer.
2. Enterthe Internet-facing IP address of the FortiManager or FortiAnalyzer unit.

To configure logging to a remote syslog server:

1. Under Remote Syslog, select Send system logs to remote Syslog servers.

2. Move the remote syslog servers to which the logs will be sent from the Available syslog servers box to the
Chosen syslog servers box.

For information on adding syslog servers, see Syslog servers on page 239.
3. Select OK to save your settings.

To send debug logs to a remote syslog server:

—

Under Remote Syslog, select Send debug logs to remote Syslog servers.

2. Move the available applications for which debug logs are to be forwarded from the Available Applications box to
the Chosen Applications box.

3. Move the remote syslog servers to which the debug logs will be sent from the Available syslog servers box to the
Chosen syslog servers box.

4. Select OK to save your settings.

Syslog servers

Syslog servers can be used to store remote logs. To view the syslog server list, go to Logging > Log Config > Syslog
Servers. A maximum of 20 syslog servers can be configured.

Create New Add a new syslog server.

Delete Delete the selected syslog server or servers.
Edit Edit the selected syslog server.

Name The syslog server name on FortiAuthenticator.
Server name/IP The server name or |IP address, and port number.

To add a syslog server:

1. From the syslog servers list, select Create New.
Create New Syslog Server

Name:
Server name/IP:

Port: 514

Level: Emergency | Alert | Critical | Emor | Warning | Notice m Debug

Facility: user v
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2. Enter the following information:

Name Enter a name for the syslog server on FortiAuthenticator.

Server name/IP Enter the syslog server name or IP address.

Port Enter the syslog server port number. The default port is 514.

Level Select a log level to store on the remote server from the dropdown menu. See

Level on page 236.

Facility Select a facility from the dropdown menu.

3. Select OK to add the syslog server.

Audit reports

User audit reports can be generated in order to comply with audit requirements. These reports include various attributes
for all users configured on the FortiAuthenticator.

Users audit

To generate and download user audit reports, go to Logging > Audit Reports > Users Audit and select Download. A
CSV format file will be saved to the computer.

Users Audit
Users Audit Report
The Users Audit Report provides a complete list of the currently configured user accounts (CSV format).

& Download

The following attributes are included in the .csv file:

username Username.

user type Set to either local, Idap, or radius.

remote server name Set to either Idap or radius, or empty for local.

first name User's first name.

last name User's last name.

email address User's email address.

active Set to either t for true/enabled or f for false/disabled.
role Set to either user, sponsor, or administrator.
admin profile One of the following:

e Setto full if role is set to administrator with full permissions.

¢ Set to their admin profile names separated by "/" for multiple profiles (e.g.
logging/saml) if role is set to administrator without full permissions.

* Emptyisrole is set to either user or sponsor.
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created Date and time of account creation.
last used Date and time of last login.
token type Type of token-based authentication.
token info Token information.
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Troubleshooting

This chapter provides suggestions to resolve common problems encountered while configuring and using your
FortiAuthenticator device, as well as information on viewing debug logs.

For more support, visit the Fortinet Support website.

Before starting, please ensure that your FortiAuthenticator device is plugged in to an appropriate, and functional, power

source.

Troubleshooting

The following table describes some of the basic issues that can occur while using your FortiAuthenticator device, and

suggestions on how to solve said issues.

Problem

Suggestions

All user log in attempts fail, there
is no response from the
FortiAuthenticator device, and
there are no entries in the system
log.

All user log in attempts fail with
the message RADIUS ACCESS-
REJECT, and invalid password
shown in the logs.

Generally, user log in attempts
are successful, however an
individual user authentication
attempt fails with

invalid password shown in the
logs.

Generally, user log in attempts
are successful, however an
individual user authentication
attempt fails with invalid token
shown in the logs.

Check that the authentication client has been correctly configured. See
Adding FortiAuthenticator to your network on page 24.

If the authentication client is not configured, all requests are silently dropped.
Verify that traffic is reaching the FortiAuthenticator device.

Check to see if there is an intervening firewall blocking 1812/UDP RADIUS
authentication traffic, if the routing correct, if the authentication client is
configured with the correct IP address for FortiAuthenticator, etc.

Verify that the authentication client secrets are identical to those on
FortiAuthenticator.

Reset the user’s password and try again. See Editing a user on page 83.
Have the user privately show their password to the administrator to check for
unexpected characters (possibly due to keyboard regionalization issues).

Verify that the user is not trying to use a previously used PIN. Tokens are one
time passwords, so you cannot log in twice with the same PIN.

Verify that the time and timezone on FortiAuthenticator are correct and,
preferably, synchronized using NTP. See Configuring the system date, time,
and time zone on page 35.

Verify that the token is correctly synchronized with FortiAuthenticator, and
verify the drift by synchronizing the token.

Verify the user is using the token assigned to them (validate the serial
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Suggestions

number against FortiAuthenticator configuration). See User management on
page 80.

« Ifthe useris using an email or SMS token, verify it is being used within the
valid timeout period. See Lockouts on page 75.

Debug logs

Extended debug logs can be accessed by using your web browser to browse to https://<FortiAuthenticator-
IP-Address>/debug.

Service: LDAP v Max. log files size: 200 KB ¥ rch in the log

LDAP Logs
Showing the last 100 lines
2019-02-25T10:59:38.657977-085: 00 FortiAuthenticator slapd[767]: attributeType: nam "
join_where="auth_user.password I5 NOT NULL" add_proc="" delete_proc="" sel_expr_u=
2019-02-25T10:59:38.657988-085: 02 FortiAuthenticator slapd[767]: backsql_oc_get_attr_mapping{): preconstructed guery "SELECT text(auth_user.first_name||'
'| |auth_user.last_name) AS cn FROM auth_user WHERE auth_user.id=? ORDER BY cn"
2019-02-25T10:59:38.657983-85: 0@ FortiAuthenticator slapd[767]: backsql_load_schema_map("facPerson™): autoadding 'objectClass' and 'ref' mappings
2019-02-25T10:59:38.658021-85: 02 FortiAuthenticator slapd[767]: backsql_oc_get_attr_mapping(): executing at_query#812 "SELECT
name,sel_expr,from_tbls,join_where,add_proc,delete_proc,param_order,expect_return,sel_expr_u FROM ldap_attr_mappings WHERE occ_map_id=>"#812 for objectClass
"organization"#812 with param oc_id=3
2019-02-25T10:59:38.658275-085: 0@ FortiAuthenticator slapd[767]: attributeType: name="dc" sel_expr="lower(organizations.name)" from="organizations,ldap_entries AS
dcObject,ldap_entry_objclasses AS auxObjectClass" joim where="organizations.id=dcObject.keyval AND dcObject.oc_map_id=3 AND dcObject.id=auxObject(lass.entry_
2019-02-25T10:59:38.658283-85: 0@ FortiAuthenticator slapd[767]: backsql_oc_get_attr_mapping{): preconstructed guery "SELECT lower{organizations.name) AS dc FROM
organizations,ldap_entries AS dcObject,ldap_entry_objclasses AS auxObjectClass WHERE organizations.id=? AND organizations.id=dcObject.keyval AND dcObject.oc_map_id=3 AND
dcObject.id=auxObjectClass.entry_id AND auxObjectClass.oc_name="dcObject' ORDER BY dc™
2019-02-25T10:59:38.658286-085: 0@ FortiAuthenticator slapd[767]: attributeType: name sel_expr="organizations.name" from="organizations"
join_where="organizations.id=dcObject.keyval AND dcObject.oc_map_id=3 AND dcObject.id=auxObjectClass.entry_id AND auxObjectClass.oc_name='dcObject'™ add_proc=""
delete_proc= sel_
2019-082-25T19:59:38.658289-85: 0@ FortiAuthenticator slapd[767]: backsql_oc_get_attr_mapping{): preconstructed guery "SELECT organizations.name AS o FROM organizations
WHERE crganizations.id=? ORDER BY o"
2019-92-25T19:59:38.658293-85: 8@ FortiAuthenticator slapd[767]: backsql_load_schema_map("organization"): sutocadding 'objectClass' and 'ref" mappings
2@19-92-25T1@:59:38.658295-85: 8@ FortiAuthenticator slapd[767]: backsql_oc_get attr_mapping{): executing at_guery#el2 "SELECT
name,sel_expr,from_tbls,join_where,add_proc,delete_proc,param_order,expect_return,sel_expr_u FROM ldap_attr mappings WHERE oc_map_id=2"#812 for objectClass
"organizationalUnit"#@12 with param oc_id=6
2@19-92-25T1@:59:38.658629-85: 9@ FortiAuthenticator slapd[767]: attributeType: name="ou" sel_expr="organizationalunits.name" from="organizationalunits" join_where
add_proc="" delete_proc="" sel_expr_u=""
2@19-92-25T10:59:38.658637-85: 0@ FortiAuthenticator slapd[767]: backsql_oc_get attr_mapping{): preconstructed guery "SELECT organizationalunits.name AS ou FROM
organizationalunits WHERE organizationalunits.id=? ORDER BY ou"

cn" sel_expr="text{auth_user.first_name||' '||auth_user.last_name)" from="auth_user"

M 4 » M Show 100 ¥ lines

Service Select the service whose logs are shown from the dropdown menu:

» FSSO
e FSSO (Filtered)
* FSSO Domain Manager
* GUI
« HA
e LB HA Sync
e LDAP
e LDAP User Sync Daemon.
* Push Authentication Service
* RADIUS Accounting
¢ RADIUS Accounting Monitor
* RADIUS Authentication
* RADIUS DNS Updates
» REST API
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Max. log files size

Enter debug mode

Search

Page navigation

Show

RADIUS debugging

e SAML User Sync Daemon

« SNMP

e Syslog SSO

e TACACS+

e« TACACS+ Accounting

e TACACS+ Authentication

e TACACS+ Authorization

» Web Server

e WinAD Monitor

e CLI Packet Capture (tcpdumpfile)
Note: The CLI Packet Capture (tcpdumpfile) service is only available when the
tcpdumpfile command has been entered using SSH or Telnet, or through the CLI
Console if a FortiAuthenticator is installed on a FortiHypervisor. For more information,
see CLI commands on page 27.

To have access to a longer history of debug log files, a dropdown menu has been added
for changing the maximum log file size, up to a maximum of 500 MB. Note that this is

available for only certain debug log types.

If RADIUS Authentication is selected as the service, the option to enter the debug mode
is available. See RADIUS debugging on page 244.

Enter a search term in the search field, then select Search to search the debug logs.

Use the First Page, Previous Page, Next Page, and Last Page icons to navigated
through the logs.

Select the number of lines to show per page from the dropdown menu. The options are:
100 (default), 250, and 500.

RADIUS authentication debugging mode can be accessed to debug RADIUS authentication issues.

From the Service dropdown menu, select RADIUS Authentication and select Enter debug mode from the toolbar.
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Senice: RADIUS Authentication v | Max.logfilessize: 200KB v | Exitdebug mode | DEBUGGING MODEACTIVE @ Search in ihe log

Send Authentication

Username

Password

{ 0K

RADIUS Authentication Logs
Showing the |ast 500 lines

2014-08-06T13:2 07:00 FortiRuthenticator radiusd[22242]: Setting 'Ruth-Type := FACAUTH
2014-08-06T13:23:48-07:00 Fortiluthenticator radiusd[22242]: [pap] WARNING! No "known gocd” password found for the
user. RAuthenticaticn may fail because of this.

2014-08-06T13:23:48-07:00 Fortiluthenticator radiusd[22242]: # Executing group from file fusr/etc/raddb/sites-enabled
/default
2014-08-06T13:2

:00 FortiRuthenticator radiusd[22242]: Realm: (null) (default realm id: 1) username: admin
:00 FortiAuthenticator radiusd([22242]: Realm not specified, default geoes teo FAC leocal user
:00 FortiRuthenticator radiusd[22242]: Local user found: admin

:00 FortiRuthenticator radiusd[22242]: Ruthentication OK

:00 FortiAuthenticator radiusd[22242]: Setting 'Post-Auth-Type := FACAUTH'

:00 FortiAuthenticator radiusd([22242]: Updated auth log 'admin': Local administrator

5 0 B Oe b 00

2014-08-06T13:2:
authentication with no token successful

2014-08-06T13:23:48-07:00 FortiRuthenticator radiusd[22242]: # Executing group from file /fusr/etc/raddb/sites-enabled
/default
2014-08-06T13:2:

:00 Fortiluthenticator radiusd[22242]: Waking up in 4.9 seconds.
100 Fortiluthenticator radiusd[22242]: Ready to process requests.
:00 Fortihuthenticator radiusd([22242]: Ready To process requesta.
:00 FortiAuthenticator radiusdr222421: Exiting normallv.

2014-08-06T13
2014-08-06T13
2014-08-06T13:

(LI Show 500 v lines
Service: RADIUS Authentication v Max. log files size:. 200KBE ¥ Exit debug mode DEBUGGING MODE ACTIVE @ Q Search in the log

Send Authentication

Username

Password

RADIUS Authentication Logs
Showing the last 100 lines

2019-83-15T14:
2819-83-15T14:
2019-83-15T14:
2819-83-15T1.

2019-83-15T14:
2819-83-15T14:

.698727-64:88 Fortiduthenticator radiusd[873]: Ready to process reguests.

A56468-04: 00 FortiAuthenticator radiusd[873]: # Executing sectien authorize from file /fusr/etc/raddb/sites-enabled/default
.456475-84: 88 Fortiduthenticator radiusd[873]: »NAS TP:127.8.8.1

A56477-64: 0@ FortiAuthenticator radiusd[873] Username :mcornwall

.456488-64: 08 Fortiduthenticator radiusd[873] Timestamp: 1552675219 .456286, age:@ms

.A56482-64:00 FortiAuthenticator radiusd[873]: Setting 'Auth-Type := FACAUTH'

2819-83-15T14: . A56485-64; 00 Fortiduthenticator radiusd[873]: [pap] WARNING! Mo “"known good" password found for the user. Authentication may fail because of this.
2819-@3-15T14: A56487-04:00 FortiAuthenticator radiusd[873]: # Executing group from file fusr/etc/raddb/sites-enabled/default
2819-83-15T14:48:19.457258-64; 00 Fortiduthenticator radiusd[873]: Realm: (null) (default realm id: 1) username: mcornwall

2819-@3-15T14: 0,457714-84:0@ Fortifuthenticator radiusd[873]: Realm not specified, default goes to FAC local user

201%9-83-15T14: A58667-64;00 FortiAuthenticator radiusd[873]: Local user found: mcornwall

2219-83-15T14:48:19,471924-64: 0@ FortiAuthenticator radiusd[873]: Authentication OK

2819-83-15T14:40:19.471979-64; 00 Fortiduthenticator radiusd[873]: Setting 'Post-Auth-Type := FACAUTH'

M4 F M Show 100 v lines -

Enter the username and password and select OK to test the RADIUS authentication and view the authentication
response and returned attributes.

Select Exit debug mode to deactivate the debugging mode.

TCP stack hardening

Configure the number of TCP SYNACK retries for the Linux kernel by accessing:

https://<FortiAuthenticator-IP-Address>/debug/tcp tuning

Edit TCP Settings

TCP SYNACK retries (1-255}) 3
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From here, enter the number of retries between 1 - 255 (default is 3).
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LDAP filter syntax

This chapter outlines some basic filter syntax that is used to select users and groups in LDAP User Import, Dynamic
LDAP Groups, and Remote User Sync Rules.

Filters are constructed using logical operators:

= Equal to

~= Approximately equal to

<= Lexicographically less than or equal to
>= Lexicographically greater than or equal to
& AND

| OR

! NOT

Filters can consist of multiple elements, suchas (& (filterl) (filter2)).
More information about the query syntax of AD filters, see the following web sites:

o Search Filter Syntax
 Active Directory: LDAP Syntax Filters

Examples

The following examples are for a Windows 2008 AD server with the domain corp.example.com, default domain
administrators and users, and an additional group called FW_Admins:

» Users (CN) = atano, pjfry, tleela, tbother

o FW_Admins (Security Group) = atano, tbother

An unfiltered browse will return all results from the query, including system and computer accounts. To prevent this and
only return user accounts, apply the filter (objectClass=person) or (objectCategory=user).

Even if unfiltered, only user accounts are imported, so this is only required to clean up the results that are displayed in
the GUI.

To filter and return only members of the security group: (& (objectCategory=user) (memberOf=CN=FW_
Admin, DC=corp, DC=example, DC=com) ).

It is not possible to use the filter to limit results to CNs or OUs. To achieve this, you must change the Base DN in the
LDAP Server configuration. For example, to return only users from the CompanyA OU, create an LDAP Server entry with
the following Base DN: OU=CompanyA, DC=corp, DC=example, DC=comn.
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LDAP filter syntax

Caveats

Users do not always have a memberOf property for their primary group, this means that querying system groups, such
as Domain Users, may return zero results. This can be confusing as these are often the first queries tried, and can lead
the user to think the filter syntax is incorrect.

For example: (memberOf=CN=Domain Users,CN=Domain Admins,DC=corp, DC=example, DC=com) Will return
no valid results.

To return all users in such a group, the filter can be made against the ID value of the Primary Group. So, for Domain
Users (Group ID = 513), the filter would be: (primaryGroupId=513).
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