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Introduction
FortiClient Enterprise Management Server (FortiClient EMS) is a security management solution that enables
scalable and centralized management of multiple endpoint devices (computers). FortiClient EMS provides an
efficient and effective administration of endpoints running FortiClient. It provides visibility across the network to
securely share information and assign security profiles to endpoints. It is designed to maximize operational
efficiency and includes automated capabilities for device management and troubleshooting.
FortiClient EMS is designed to meet the needs of small to large enterprises that deploy FortiClient on endpoints.
Some of the benefits of deploying FortiClient EMS include:
l
l

Remotely deploying FortiClient software to Windows PCs
Updating profiles for endpoint users regardless of access location, such as, administering antivirus, web filtering,
VPN, and signature updates

l

Administering FortiClient endpoint registrations, such as, accept, de-register, and block registrations

l

Managing endpoints, such as, status, system, and signature information

l

Identifying outdated versions of FortiClient software

You can manage endpoint security for both Windows and Mac OS X platforms by using a unified organizational
security policy. An organizational security policy provides a full, understandable view of the security policies
defined in the organization. You can see all policy rules, assignments, and exceptions in a single unified view.

Components of FortiClient EMS
FortiClient EMS provides the infrastructure to install and manage FortiClient Endpoint software. FortiClient
protects endpoint clients from viruses, threats, and risks. FortiClient EMS can be used to ensure clients are
compliant with the organization’s security profiles.
The following table lists the components of FortiClient EMS.

Component

Description

FortiClient EMS

Manages the client computers (endpoints) that connect to your network. It
includes the following software:
l

l

The console software that manages security profiles and client
computers.
The server software provides secure communication to and from the
client computers and the console.

Database

Stores security profiles and events. The SQL database is installed as part
of the FortiClient EMS installation.

FortiClient

Enforces security and protection on the client computers (endpoints). It
runs on servers, desktops, and portable computers you wish to be secured.
See the FortiClient Administration Guide on docs.fortinet.com for more
information.
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FortiClient EMS and Fortinet Endpoint Security Management

FortiClient EMS allows you to:
l

Establish and enforce security profiles

l

Manage deployment, configuration, and updates

l

Obtain a consolidated view of multiple security components across all endpoint clients in your network

l

Perform integrated installation of security components and set profiles
An informative video introducing you to FortiClient EMS is available in the Fortinet
Video Library.

FortiClient EMS and Fortinet Endpoint Security Management
FortiClient EMS is part of the Fortinet Endpoint Security Management suite, which ensures a comprehensive
policy administration and enforcement for an enterprise network.

Documentation
You can access the FortiClient EMS documentation from the following link: docs.fortinet.com
The FortiClient EMS documentation set includes the following documents:
l

l

9

FortiClient EMS 1.0.5 Release Notes
This document describes new features and enhancements in the FortiClient EMS system for the release and
lists any known issues and limitations. This document also defines supported platforms and the required
minimum system requirements.
FortiClient EMS 1.0.5 QuickStart Guide
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Documentation

Introduction

This document describes how to install and begin working with the FortiClient EMS system. It provides
instructions on installation, deployment, and also includes a high-level task flow for using the FortiClient EMS
system.
l

FortiClient EMS 1.0.5 Administration Guide
This document describes how to set up FortiClient EMS and use it to manage FortiClient endpoints. It includes
information on how to configure multiple endpoints, configure and manage profiles for the endpoints, and view
and monitor the FortiClient endpoint profile status.

Administration Guide
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What's New
The new features in FortiClient EMS 1.0.5 include the following:

FortiClient EMS 1.0.5
There are no new features or enhancements for FortiClient EMS 1.0.5.

FortiClient EMS 1.0.4
There are no new features or enhancements for FortiClient EMS 1.0.4.

FortiClient EMS 1.0.3
There are no new features or enhancements for FortiClient EMS 1.0.3.

FortiClient EMS 1.0.2
There are no new features or enhancements for FortiClient EMS 1.0.2.

FortiClient EMS 1.0.1
Assign FortiClient Telemetry Gateway IP List to Endpoints
Instead of managing and monitoring endpoints from FortiGate and FortiClient EMS, this feature de-couples the
FortiGate IP List from the rest of the profile. This allows users to manage endpoints only using FortiClient EMS.
The user selects an Endpoint Profile and assigns a FortiClient Telemetry Gateway IP List. Then, deploys by
assigning the FortiClient Telemetry Gateway IP List to an Endpoint Profile. After deployment, the endpoint will
register to a FortiGate based on the FortiClient Telemetry Gateway IP List.
Users can assign FortiClient Telemetry Gateway IP Lists to endpoints (even if the endpoint is already registered
to a FortiGate) and update FortiGate IPs as required.

Auto-Sync FortiClient Profiles with FortiGate
Users can manage profile configurations from one place while using FortiClient EMS to manage client
deployment. Users can auto-sync profile changes to FortiClient EMS once its been modified on the FortiGate.
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What's New

It will only deploy to endpoints if they are registered to the EMS.

CA Certificates imported from FortiGates
FortiClient EMS can pull CA certificates from FortiGates through a protocol that does not need authentication
(SNMP). These CA certificates are pulled from various FortiGates and can be grouped and/or managed. Users
can push these CA certificate groups to selected FortiClient endpoints. Thereupon, FortiClient will download and
install them into the endpoint's certificate store as a trusted certificate.

Deploy a FortiClient Upgrade from EMS
You can deploy a FortiClient software update from EMS. A prompt will appear in the FortiClient endpoint when an
installer package is requested to be deployed.

Email Alert Notifications
You can add an option to setup a SMTP server to enable an Alert for Endpoint Events. When an alert is triggered,
an email notification will be sent.

Host names and License Updates
When you update your license information, FortiClient EMS will update the serial number of the FortiClient
Telemetry server once. You are able to change the EMS host name in the settings dialog.

Vulnerability Scan Settings and Summary Chart
Administrators are able configure the Vulnerability Scan Settings for each endpoint profile.
The Vulnerability Scan Summary Chart provides a centralized vulnerability summary for all managed endpoints.
Administrators are able to get a good idea of high risk hosts and critical vulnerabilities that exist on endpoints. It
also provides links on how to fix or repair the vulnerabilities.

FortiGate Integration with FortiClient EMS
To integrate FortiGate with FortiClient EMS, users must set up a FortiClient Endpoint Compliance in the
FortiGate and import the profile to FortiClient EMS for deployment. Profiles created in EMS do not support NAC.
If users want to update profiles after deployment, the profile must be updated in FortiGate, not FortiClient EMS.

FortiGate Managed Endpoints Summary Chart
This chart indicates how many clients are registered to specific FortiGates.It provides an overview of the
FortiGate Managed Endpoint registration status.

LDAP Integration for Administrator Login
LDAP integration implementation allows LDAP users to login to FortiClient EMS as an administrator.
The list of LDAP users is derived from the server on which FortiClient EMS is installed. If you want to add more
LDAP users, you must add them to the server.

Administration Guide
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What's New

FortiClient EMS 1.0.1

License Expiration Notification
When the FortiClient EMS License is near expiration, a pop-up message will appear:
l

When 60 days are left

l

When 30 days are left

l

Upon every login when there are less than 30 days left

The same license expiration notification will be shown (bell icon) in the top banner.

MSSQL Server Enterprise Edition
FortiClient uses a pre-installed MSSQL server to improve scaling.

Purchased Licenses
Instead of stacking licenses, you can now specify the number of FortiClient EMS licenses and the duration of use
at the time of purchase.

Updated Trial License
When you install FortiClient EMS, the free trial license is enabled by default. The free trial license supports 10
FortiClient endpoints. FortiClient EMS consumes one license count for each managed FortiClient device.
For a free 60 day trial, please contact a sales representative.
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Overview
This section provides an overview of how to:
l

Install and configure FortiClient EMS.

l

Discover endpoint devices and deploy FortiClient

l

Monitor and update endpoint devices

Installing and configuring FortiClient EMS
Before installing FortiClient EMS, it is recommended that you read the FortiClient EMS
Release Notes and the FortiClient Enterprise Management Server - QuickStart Guide
available on docs.fortinet.com to become familiar with relevant software components and
other important information about the product.
Following is an overview of how to install and configure FortiClient EMS.
1. Prepare for the FortiClient EMS installation. See Required Services and Ports on page 17.
2. Install FortiClient EMS. See Installing FortiClient EMS on page 23.
3. Log into FortiClient EMS. See Logging into FortiClient EMS on page 24.
4. License FortiClient EMS. See Installation on page 23.
5. Configure FortiClient EMS settings. See Settings on page 30.
6. Configure user accounts and permissions. See User Management on page 39.

Deploying FortiClient to endpoints
Following is an overview of how to discover endpoint devices and deploy FortiClient on the endpoint devices from
FortiClient EMS.
1. Discover endpoint devices. See Adding Endpoints on page 45.
2. Add FortiClient installers to FortiClient EMS, and specify what FortiClient features to install. See Adding Installers
on page 52.
3. Configure profiles to select the FortiClient installer and specify settings for the features that it will install. See
Configuring Profiles on page 55.
4. Prepare domains and workgroups for deployment. See Deploying FortiClient on Endpoint Devices on page 80.
5. Assign profiles to domains and workgroups to deploy FortiClient on endpoints. See Assigning Profiles to Endpoints
on page 57.
6. Create and assign FortiClient Telemetry Gateway IP Lists to endpoints. See Creating FortiClient Telemetry
Gateway IP Lists on page 77 and Assigning FortiClient Telemetry Gateway IP Lists to Endpoints on page 78.

Administration Guide
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Overview

Integrating FortiGate with FortiClient EMS

Integrating FortiGate with FortiClient EMS
To integrate FortiGate with FortiClient EMS, users must set up a FortiClient Endpoint Compliance in FortiGate
and import the profile to FortiClient EMS for deployment. Profiles created in EMS do not support NAC.
FortiClient profiles created by using FortiGate contain compliance rules to support NAC, and they might contain
configuration information, depending on the non-compliance setting in the FortiClient profile.
When non-compliance is set to Block or Warn, the FortiClient profile contains compliance rules, but no
configuration information. When non-compliance is set to Auto-Update, the FortiClient profile contains
compliance rules and some configuration information. For more information about FortiClient profiles and
compliance rules, see the FortiOS Handbook.

How FortiGate integrates with FortiClient EMS depends on the non-compliance setting in the
FortiClient profile:
Block or Warn:

When non-compliance is set to Block or Warn, you can create an endpoint profile in EMS and assign the profile
to endpoints. The profile from EMS is in addition to the FortiClient profile from FortiGate.
1. Using a FortiGate running 5.4.1 and later, create a FortiClient profile.
2. On FortiClient EMS, import the FortiClient profile.

15
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Managing and updating endpoint devices

Overview

a. Import the FortiClient profile and review the compliance rules.
b. Create an endpoint profile that enables the options required by the compliance rules, such as AntiVirus
and so on.
c. Create a FortiClient Telemetry Gateway IP List for the FortiGate.
d. Assign an installer to the profile.
e. Assign the FortiClient Telemetry Gateway IP List to endpoints.
You can add the FortiGate IP list to the FortiClient installer. In this scenario, the endpoints will
receive the IP list automatically.
f. Assign the FortiClient profile to the endpoints. After the profile is deployed, an installer is deployed with it.
If the installer includes a gateway IP list then the endpoint will connect to the gateway IP list.
3. Use FortiClient EMS to manage endpoints.
4. On the FortiGate update the profile as needed. Changes are automatically pushed to the endpoints.

Auto-Update
When non-compliance is set to Auto-Update, you can assign only the FortiClient profile from FortiGate to
endpoints. The FortiClient profile contains the compliance rules, but no configuration.
1. Using a FortiGate running 5.4.1 and later, create a FortiClient profile.
2. On FortiClient EMS, import the FortiClient profile.
a. Import the FortiClient profile.
b. Create a FortiClient Telemetry Gateway IP List for the FortiGate.
c. Assign an installer to the profile.
d. Assign the FortiClient Telemetry Gateway IP List to endpoints.
If the installer comes with the FortiGate IP list, endpoints will be assigned automatically.
e. Assign the FortiClient profile to the endpoints. This will deploy the installer. The endpoints register to the
FortiGate.
3. Use FortiClient EMS to manage endpoints.
4. On the FortiGate update the profile as needed. Changes are automatically pushed to the endpoints.

Managing and updating endpoint devices
Following is an overview of how to monitor endpoint devices.
1. Monitor endpoint status. See Viewing Endpoint Information on page 49.
2. Monitor FortiClient EMS status. See Endpoint Information on page 49.
3. Update profiles to update FortiClient on endpoint devices. See Editing Profiles on page 57.

Administration Guide
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Required Services and Ports

Requirements and Dependencies
You can install and use FortiClient EMS as a standalone product on an active directory server or a standalone
Windows machine. Requirements for installation and operation vary in relation to the presence of other software
on the server and according to how you use FortiClient EMS.

Required Services and Ports
You must ensure that required ports and services are enabled for use by FortiClient EMS and its associated
applications on your server. The required ports and services enable FortiClient EMS to communicate with clients
and servers running associated applications.

Communication

Service

Protocol

Port

FortiClient endpoint

File transfers

TCP

8013 (default)

Computer browser service

Enabled

l

Computer browser service is not needed if an
Active Directory is used or clients can manually
register to EMS.

Samba (SMB) service

Enabled

445

Enabled

135

Active Directory server connection

When used as a
default connection

389

Apache

HTTPS

l

During FortiClient deployment, endpoints may
connect to the FortiClient EMS server using the
SMB service.

Distributed Computing Environment / Remote
Procedure Calls (DCE- RPC)
l

The FortiClient EMS server connects to the
endpoints using RPC for FortiClient deployment.

TCP

443

SQL server

Ensure that the Computer Browser Service is running. On Windows Server 2012 R2,
the service is disabled by default. If this service is not active, FortiClient EMS cannot
detect computers on the same network, even if they are available.
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Requirements and Dependencies

Management Capacity
FortiClient EMS is intended for use by enterprises. It has the capacity to manage a large number of endpoints.
The following are suggested EMS host system hardware configurations, depending on the number of endpoints
being managed.

Suggested minimum EMS system hardware
You will need at least 200GB of free disk space available.

Max number of managed endpoints

Number of virtual
CPUs

Memory (RAM) (in GB) Suggested keep alive
interval

10, 000

2

8

default

20, 000

4

8

default

30, 000

4

8

120 seconds

40, 000

4

8

120 seconds

50, 000

4

8

120 seconds

Suggested minimum EMS system hardware
75, 000

8

16

120 seconds

For the purpose of this table, an Intel i5 processor with two cores and two threads per
core will be considered to have 4 virtual CPUs. An Intel i3 processor with two cores and
one thread per core has two virtual CPUs.

Server Readiness Checklist for Installation
Use the following checklist to prepare your server for installation.

Checklist

Readiness Factor
Temporarily disable security applications. You must temporarily disable any antivirus software
on the target server before you install FortiClient EMS. Installation might be slow or disrupted
while these programs are active. Note that a server might be vulnerable to attack when you
uninstall or disable security applications.

Administration Guide
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Checklist

Server Readiness Checklist for Installation

Readiness Factor
Carefully consider the date and time settings that you apply to your server.
Confirm that required services and ports are enabled and available for use by FortiClient EMS.
Ensure that no conflict exists with Port 443 for Apache service to function properly.
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Licenses

Licenses
This section describes the licensing options available for FortiClient EMS. It provides information about the
number of supported FortiClient endpoints for each type of license to help you determine which license best suits
your needs.

Description of Licenses for FortiClient EMS
FortiClient EMS supports the following types of licenses:
l

Free trial license

l

Purchased license

Free Trial License
When you install FortiClient EMS, the free trial license is enabled by default. The free trial license supports 10
FortiClient endpoints. FortiClient EMS consumes one license count for each managed FortiClient device.

Purchased License
Each purchased license allows management of one FortiClient endpoint. You will need to purchase a minimum of
100 endpoints and you have an option to have this EMS license for a maximum three year term. You can specify
the number of endpoints and the duration of term at the time of purchase.
You can use a licensed FortiClient EMS to deploy, provision, and manage FortiClient
endpoints. However, if you have a FortiGate in your network, you can buy an Add-On
FortiGate Endpoint license to enforce Endpoint Compliance and participate in the
Security Fabric, while the endpoints are being managed by EMS. Using FortiGate with
EMS is optional.

Licensing FortiClient EMS
The following will describe how to license FortiClient EMS.
1. Visit forti.net/Reseller to find a Reseller.
Once you purchase FortiClient EMS, you will receive the FortiClient Host Security License Certificate via
email. This email contains the Certificate Number that will be used to obtain the FortiClient EMS License.
2. Login to the Fortinet Support site.
a. Click Register and Renew .
b. Enter the Certificate Number. This is the number you received in the FortiClient Host Security License
Certificate email.

Administration Guide
Fortinet, Inc.
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Licenses

Upgrading the FortiClient EMS License

If you have not already registered an EMS device, you will be prompted to do so. This will require
obtaining the Hardware ID from FortiClient EMS. You can obtain the Hardware ID by clicking the
Upgrade link located in the FortiClient EMS Dashboard.
c. Enter the Hardware ID.
d. Enter the Fortinet Partner Reseller.
e. Read, verify and agree to the Terms and Conditions of the service.
f. Verify the Product Entitlement List for your recent FortiClient EMS purchase. Check the By accepting
these terms... checkbox. Then, click Confirm. The license file will now be available to use with your
FortiClient EMS installation.
g. Click Finish.
h. From your Products List, select FortiClient EMS.
i. From the left panel, select License and Key.
j. From the Available Keys List, select the FortiClient EMS entry. Then, click Get the License File.
k. From FortiClient EMS Dashboard > Upgrade, click Browse.
l. Select the license file and Upload File. You have successfully licensed FortiClient EMS.
If you need to renew your license or make changes to your requirements, please contact Fortinet Support.

An instructional video on how to obtain licensing for FortiClient EMS is available in the
Fortinet Video Library.

Upgrading the FortiClient EMS License
To upgrade the FortiClient EMS license:
1. Go to View > Upgrade License. The Add FortiClient EMS License pane is displayed.
2. Click Browse, locate the license key file, and click Upload File.

Licenses for Component Applications
Common services or applications do not require a license. See the FortiClient Enterprise Management Server QuickStart Guide for more information about the common components.
During the installation of common services required for FortiClient EMS, you are not
asked for license information.
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Help with Licensing

Licenses

Help with Licensing
For licensing issues with FortiClient EMS, contact the licensing team at Fortinet Technical Assistance Center
(TAC):
l

Phone: +1-866-648-4638

l

Technical support: support.fortinet.com/

Administration Guide
Fortinet, Inc.

22

Installation

Installing FortiClient EMS

Installation
Before you install and license FortiClient EMS on a server, ensure you have:
l

Reviewed Description of Licenses for FortiClient EMS on page 20

l

Met the requirements listed in the Required Services and Ports on page 17

l

Completed the Server Readiness Checklist for Installation on page 18

l

Logged into the server as administrator. The administrator user account is equivalent to a Windows administrator
account and provides access to all common services, FortiClient EMS, and other application tasks. You can use this
account to initially log in to the server and to create other user accounts for normal day-to-day use of the
applications.
It is recommended that you install FortiClient EMS on a dedicated server in a controlled environment. Installing other software applications can interfere with the normal operation of FortiClient EMS.

Installing FortiClient EMS
Installing and licensing FortiClient EMS requires the following steps:
1. Be aware of software dependencies.
2. Obtain or locate the FortiClient EMS installation program.
3. Run the FortiClient EMS installation program.

Obtaining the FortiClient EMS installation program
FortiClient EMS is available for download from the following locations:
l

Fortinet Support website (support.fortinet.com)

l

Sales representative

Download the following .exe file: FortiClientEnterpriseManagement_1.0.5.0130_x64.exe

Running the FortiClient EMS Installation Program
To install FortiClient EMS:
1. Double-click the downloaded installation file for FortiClient EMS. The installation wizard starts.
If you are not logged into the server as an administrator, right-click the installation file
and select Run as administrator.
2. Follow the installation wizard instructions.
In the License terms and agreement window: Select I agree to the license terms and conditions if you agree with
the license terms and conditions. If you do not agree, the installation process stops.
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Specifying Different Ports for FortiClient EMS

Installation

3. Click Install.
The applications that will be installed appear. The FortiClient EMS installation package includes the
following applications: FortiClient EMS, Microsoft SQL Server 2014 Express Edition, Apache HTTP
server, and Python. The installation setup process begins.
4. Continue following the installation wizard instructions.
After the program has installed, the Setup Successful window appears.
5. Click Close.
A desktop icon is created, which opens the FortiClient EMS application home page.
6. Re-enable any antivirus applications that you temporarily disabled.
An instructional video on how to install, login, and change your administrator password
is available in the Fortinet Video Library.

Specifying Different Ports for FortiClient EMS
In cases where there are pre-existing services running on default FortiClient EMS ports, you can specify another
port to be used using the CLI to run the installer.
Use the following commands:

Command

Description

ClientDownloadPort

The port FortiClient will be downloaded from FortiClient EMS.

RemoteManagementPort

The port that will be used for EMS administration.

Example: FortiClientEnterpriseManagement_1.0.0.6401_interim_x64.exe RemoteManagementPort=10553

Logging into FortiClient EMS
FortiClient EMS runs as a service on Windows computers.

To open FortiClient EMS:
1. Double-click the FortiClient EMS icon, or select Start > All Programs > FortiClient Enterprise Management
Server to start the application.
2. Log in by using the default admin account. Enter admin for user name, and leave the password field empty. Click
Sign in. The FortiClient EMS application opens.

Administration Guide
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Uninstalling FortiClient EMS

The client automatically closes if it is idle for 30 minutes.

3. Add a password to the administrator account by going to View > User Management. See also Configuring User
Management on page 39.
4. To exit the application, click Admin > Logout from the toolbar.

Accessing FortiClient EMS Remotely
FortiClient EMS can be accessed using a web browser in lieu of the GUI.
l

To access the EMS from the EMS server, visit https://localhost.

l

To access the server remotely, use the server's hostname: https://<server_name>.

Ensure you can access the device remotely. This can be achieved by adding it into a DNS entry, or by adding it to
the Windows hosts file. You may have to modify the Windows Firewall rules to allow the connection.
You will need to have View > Settings > Server Settings > Remote Administration
HTTPS Access enabled on the FortiClient EMS to access the server's hostname.

Uninstalling FortiClient EMS
Use the Programs and Features pane of the Control Panel in Microsoft Windows to uninstall FortiClient EMS.
FortiClient EMS installs the following dependencies. If they are not being used by other applications on the same
computer, they can be uninstalled manually after the EMS has been removed.
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l

Microsoft ODBC Driver 11 for SQL Server

l

Microsoft SQL Server 2008 Setup Support Files

l

Microsoft SQL Server 2012 Native Client

l

Microsoft SQL Server 2014 (64-bit)

l

Microsoft SQL Server 2014 Setup (English)

l

Microsoft SQL Server 2014 Transact-SQL ScriptDom

l

Microsoft Visual C++ 2010 x64 Redistributable – 10.0

l

Microsoft Visual C++ 2010 x86 Redistributable – 10.0
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l

Microsoft Visual C++ 2013 x86 Redistributable – 12.0

l

Microsoft VSS Writer for SQL Server 2014

l

SQL Server Browser for SQL Server 2014

Installation

To uninstall FortiClient EMS:
1. Select Start > Control Panel > Programs > Uninstall a program.
2. Select FortiClient Enterprise Management Server, and click Uninstall.
3. Follow the uninstallation wizard prompts.
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GUI
Navigating the FortiClient EMS Interface
FortiClient EMS offers a centralized view of managing FortiClient endpoints and allows you to define and make
endpoint security profile changes.
The application provides views or panes in which you can manage endpoints and profiles, such as domain and
workgroup, endpoint profile, and content pane views. You can switch between these views according to your
needs. The user interface is a graphical summary of important security information about the endpoint clients in
your organization.

Banner
Option

Description

License Type

Displays current license information.

Envelope icon

Clicking the Envelope icon displays all Alerts.

View

View and configure the following:
l
Upgrade License

Help

Admin

l

Software Manager

l

User Management

l

CA Certificate Management

l

Database Management

l

View Logs

l

Settings

View the following:
l
Technical Documentation
l

How-To Videos

l

Forums

l

Getting Started

l

Create Support Package

l

About

Logout of FortiClient EMS.

Left Pane
The left navigation pane is used to display content in the right content pane.
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Option

Description

Dashboard

Display a dashboard of information about all managed FortiClient endpoints.

Vulnerability Scan

The Vulnerability Scan Summary Chart provides a centralized vulnerability
summary for all managed endpoints. Administrators are able to get a good
idea of high risk hosts and critical vulnerabilities existing on endpoints. It
also provides links on how to fix or repair the vulnerabilities.
When you click on a circle, it drills down the vulnerability details.
The following tables are displayed:
l
Current Vulnerabilities:
a. Total
b. Operating System
c. Browser
d. Microsoft Office
e. Third Party App
f. Service
g. User Config
h. Other
l

Host Scan Summary

l

Top 10 Vulnerable Hosts

l

Top 10 Vulnerabilities

Endpoints

Add and manage endpoints. You can add and manage endpoints from
domains and from workgroups.

Endpoint Profiles

Create and assign profiles as well as manage profile updates.

FortiClient Telemetry Gateway IP Lists

Create and assign FortiClient Telemetry Gateway IP Lists as well as manage IP list updates.

Right Pane
The right content pane displays the user interface controls that correspond to the selection you make in the left
navigation pane. The status and menu icons on the top-right display controls that you can use to configure
additional settings for user management and each individual endpoint.

To view the dashboard:
1. Click the Dashboard on the left pane. A summary of the status of the endpoints is displayed.
2. Click any of the pie charts to view more details about the summarized endpoints.
3. Click any of the displayed endpoints to view more details about the endpoint.
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License Information
Option

Description

License Information

Displays the following information:
l
Status of your License
l

Expiration Date

l

Number of Licenses

Charts
In the right pane, there are a number of pie charts. Each pie chart provides a summary of endpoint information.
The sections in each of the charts are links. You can click any section of the pie charts or any row in the table to
display more details.
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Option

Description

Client Stats

Statistics of Clients in use.

FortiGate Managed Endpoints
Summary Chart

This chart indicates how many clients are registered to which FortiGates. It
provides an overview of the FortiGate Managed Endpoint status.

Devices by OS

This chart indicates how many clients are registered to and using which
OS.

Event Summary

Summary of events
l
Endpoints with Out-of-date Protection
l

Endpoints with Out-of-sync Profiles

l

Endpoints with Pending Software Updates

l

Errors or Warnings (last 7 days)

l

Inactive Endpoints (last 30 days)

l

Unprotected Clients

Installed FortiClient Version
Summary

Percentage of FortiClient versions used.

Vulnerability Scan Chart

The chart provides a centralized vulnerability summary for all managed endpoints, and an overall idea of high risk hosts and critical vulnerabilities existing on the endpoints.
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Settings
This section describes FortiClient EMS server settings and log settings. It also describes how to import
CA certificates as well as back up and restore the database.

FortiClient EMS Settings
Server Settings
FortiClient EMS installs with a default IP address and port configured. You can change the IP address and port,
and configure other server settings for FortiClient EMS.

To configure server settings:
1. Go to View > Settings.
2. Select Server Settings, and configure the options. For a description of the options, see the Server Settings on
page 32.
3. Select Save.

Log settings
You can specify what level of log messages to capture in the logs for FortiClient EMS. You can also specify when
to automatically delete logs and alerts.

To configure log settings:
1. Go to View > Settings.
2. Under Log Settings, configure the options. For a description of the options, see Log Settings on page 34.
3. Select Save.

Email Alert Settings
You can add an option to setup a SMTP server to enable an Alert for EMS/Endpoint Events. When an alert is
triggered, an email notification will be sent.

To configure Email Alerts and a SMTP server
1. Go to Settings > Alerts > Email Alerts
2. Enable Send e-mail alerts for the following EMS/endpoint events.
3. Select the Alert types you would like to receive an email notification for.
4. Click Save.
5. If you have not already set up a SMTP Server, the GUI will automatically prompt you to configure the SMTP
Server Settings information. See the Configuration References on page 32.
6. Click Save.
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Importing Certificates
You can import CA certificates into FortiClient EMS.

To import certificates:
1. Go to View > CA Certificate Management.
2. Select Import.
3. In the Certificate Upload window, select either:
a. Manual Upload: If you select this option, click Browse to locate the certificate.
b. Import from FortiGate: If you select this option, you will be require to enter the following information:
Server IP/Hostname

Enter the server P/Hostname in the following format:
<ip address> : <port>.

VDOM

Enter the VDOM.

Username

Enter the username.

Password
c.

Enter the password.

4. Click Import to import the certificate.

Backing Up and Restoring the Database
You can back up and restore the FortiClient EMS database.

To back up the database:
1. Go to View > Database Management. The Database Operations pane is appears.
2. Select Backup Database.
When the database backup is complete, Windows Explorer is appears with the database backup file
selected.

To restore the database:
1. Go to View > Database Management. The Database Operations pane is displayed.
2. Select the Restore tab.
3. Select Browse, and select the database backup file.
4. Select Restore Database.
When the database is restored, a message appears. The message instructs you to wait for the restored
database to reload.
5. Wait for the restored database to be reloaded.

31

Administration Guide
Fortinet, Inc.

Configuration References

Settings

Configuration References
This section contains descriptions of the fields used to configure FortiClient EMS.

Server Settings
Following is a description of the fields on the View > Settings > Server Settings tab.

Option

Description

Host Name

Displays the Host Name for the FortiClient EMS server.

Listen on IP Addresses

Displays the IP addresses for the FortiClient EMS server. FortiClient will
register to the FortiClient EMS on the specified IP address.

Listen on Port

Displays the default port for the FortiClient EMS server. You can change the
port by typing a new port number. FortiClient will register by using the specified port number.

EMS has a FQDN

Turn on to specify a fully qualified domain name (FQDN) for the FortiClient
EMS server.

EMS FQDN

Displayed when EMS has a FQDN is turned on. Type the FQDN for the
FortiClient EMS server. FortiClient can register by using either the specified
IP address in the Listen on IP Addresses option or the specified FQDN.

FortiClient Telemetry Connection Key

Add the FortiClient Telemetry Connection Key for FortiClient EMS. FortiClient must provide this key during registration. There is no key by default.

Confirm Key

Add the registration key for FortiClient EMS again to confirm the key.

Keep Alive Interval

Each registered FortiClient sends a short keep-alive message to FortiClient
EMS at the specified interval.

License Timeout

A license seat is consumed by each registered FortiClient.
If a FortiClient endpoint unregisters from EMS, the license seat is retained
in anticipation that the FortiClient endpoint will re-register. If the FortiClient
endpoint does not re-register, within the given timeout, its registration
record will be removed from EMS.
If the FortiClient endpoint is removed, switched off, becomes offline etc.
and does not re-connect to EMS within a given timeout, the FortiClient endpoint will be removed from EMS even if it is still registered to EMS.
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Option

Description

DHCP Onnet/Offnet

Enable to monitor endpoints that are within the company network (onnet).
Endpoints that register to FortiClient EMS from outside of the company network are considered offnet.
There are two settings in EMS that would affect the FortiClient onnet/offnet
status:
1. DHCP on-net/off-net setting in EMS
2. Subnet setting in EMS
The following is the on-net/off-net matrix:

DHCP
Onnet/Offnet
Setting

Subnet Setting

DHCP 224
Option

Result

off

no

N/A

onnet

off or on

yes, match

N/A

onnet

off

yes, not
match

N/A

offnet

on

yes or no

option configured

onnet

Notes:
For Subnet settings in EMS, the value meanings:
no: subnet setting in EMS is disabled
yes: subnet setting in EMS is configured
match: client has an IP in the EMS configured subnet
not match: client has IP not in the EMS configured
subnet

Option 224 can have any serial number of a Fortinet device. EMS assumes
that FortiClient is behind a FortiGate and there is onnet with that FortiGate.
Remote administration/HTTPS Access

Specify settings for remote administration access to FortiClient EMS.
Turn remote HTTPS access to FortiClient EMS console on and off. When
enabled, administrators can use a browser and HTTPS to log into the
FortiClient EMS console. When disabled, administrators can only log into
FortiClient EMS console on the server.
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Pre-defined
Host Name

Displays the pre-defined host name. The name cannot be changed.

Custom Host
Name

Available when HTTPS Access is turned on. Displays the pre-defined host
name of the server on which FortiClient EMS is installed. You can customize the host name. When you change the host name, the web server
restarts.

Administration Guide
Fortinet, Inc.

Configuration References

Settings

Option

Description

Scan local workgroups

Turn on to enable FortiClient EMS to automatically scan workgroups on the
network to discover endpoint devices in the workgroups.

FortiClient download URL

FortiClient installers created on FortiClient EMS will be made available for
download at the URL.

Open port 10443 in Windows
Firewall

Turn on to open port 10443, and turn off to close port 10443. Port 10443 is
used to download FortiClient.

SSL Certificate

Displays the SSL Certificate currently imported. If you have not imported a
SSL Certificate, a No SSL certificate imported message is displayed.

New SSL Certificate

Upload a new SSL Certificate.

New SSL Private Key

Upload a new SSL Private Key.

User Inactivity Timeout

Specify the user inactivity timeout (in hours).

Log Settings
Following is a description of the fields on the View > Settings > Log Settings tab.

Option

Description

Log level

Select the level of messages to include in FortiClient EMS logs. For
example, if you select Info, all log messages from Info to Emergency are
added to the FortiClient EMS logs.

Auto Remove Logs

Type the number of days that you want to store logs. For example, if you
type 30, logs will be stored for 30 days. Any logs older than 30 days are
automatically deleted.

Remove All Logs

Click to immediately delete all FortiClient EMS logs.

Auto Remove Alerts

Type the number of days that you want to keep alerts. For example, if you
type 30, alerts will be kept for 30 days. Any alerts older than 30 days are
automatically deleted.

Remove All Alerts

Click to immediately delete all FortiClient EMS alerts.

FortiGuard
FortiClient EMS regularly connects to FortiGuard to determine the current versions of FortiClient software and
signatures that are available. The information is compared to the update information provided by each registered
FortiClient endpoint. A summary of outdated registered endpoints is available on the FortiClient EMS dashboard.
Following is a description of the fields on the View > Settings > FortiGuard tab.
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Option

Description

Use FortiManager for client
software/signature update

Turn on to use FortiManager for updating FortiClient software or signatures. You must specify the IP address or host name for FortiManager as
well as the port number.

IP
Address/Host
Name

Enter the IP Address/Host Name.

Port

Configure the port number.

Failover Port

Configure the failover port.

Timeout

Configure the timeout interval (in seconds).

Failover to
FDN when
FortiManager
is not available

Enable failover to FDN when FortiManager is not available.

Use proxy for updates

Turn on to specify a proxy for updates to FortiClient software.

IP
Address/Host
name

Enter the IP Address/Host Name.

Port

Configure the port.

Username

Configure the username. This is optional.

Password

Configure the password.

To configure FortiManager for use by FortiClient on each endpoint, see Profile References on page 58.

Endpoint Settings
Following is a description of the fields on the View > Settings > Endpoint Settings tab.

Option

Description

Automatically upload user
avatars to FortiClient EMS

When the automatic user avatar upload feature is enabled, FortiClient will
upload user avatars to all FortiGates, FortiAnalyzers, and EMS servers it is
registered to.

Email Alerts
Following is a description of the field for View > Settings > Alerts > Email Alerts > Send e-mails alerts for the
following EMS events.
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Option

Description

Notify when new EMS versions are available for deployment

New EMS versions are available.

Remind me
everyday for 2
weeks
Notify when new FortiClient
versions are available for
deployment
Remind me
everyday for 2
weeks

Enable to remind you when new EMS versions are available everyday for 2
weeks.

New FortiClient versions available for deployment.

Enable to remind you when new FortiClient versions are available everyday
for 2 weeks.

Notify when EMS license is
expiring or expired.

Expiring or expired EMS license.

Notify when EMS fails to sync
with LDAP domain(s).

EMS does not sync with LDAP domains.

Notify when EMS fails to sync
Auto-sync enabled profile(s)

EMS does not sync with Auto-sync enabled profiles.

Following is a description of the fields for View > Settings > Alerts > Email Alerts > Send e-mails alerts for the
following endpoints events.

Option

Description

Send email alerts every

Configure the time interval email alerts are sent. Options include:
l
1 min
l

5 mins

l

10 mins

l

15 mins

l

30 mins

l

1 hour

l

2 hours

l

6 hours

l

12 hours

l

1 day

Malware is detected.

Malware detected.

Repeated malware is detected.

Same malware is detected on the same machine in the last 24 hours.
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Option

Description

Multiple malware detected.

Different malware is detected on the same machine in the last 24 hours.

Malware outbreak detected.

Same malware is detected on different endpoints in the last 24 hours.

Zero-day malware detected by
FortiSandbox.

Previously unknown computer virus or other malware for which specific antivirus software signatures are not yet available.

C&C attack communication
channel is detected.

Command and control attack communication channel is detected.

Critical vulnerability is detected.

Critical vulnerability detected,

Endpoint FortiClient Telemetry is manually disconnected by user.

FortiClient Telemetry endpoint is manually disconnected by user.

Endpoint signature database
is out-of-date.

Out-of-date Endpoint signature is detected.

Endpoint software is out-ofdate.

Out-of-date Endpoint software is detected.

SMTP Server Settings
Following is a description of the fields on the View > Settingrs > Alerts > Enable send email alerts for the
following EMS/endpoint events > SMTP Server Settings. You will need to enable Enable send an email for the
following EMS/endpoint events to show the SMTP Server Settings.
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Option

Description

SMTP Server

Enter SMTP Server.

Port

Enter Port number.

Security

Select either None, STARTTLS, or SMTPS for the security type, or you
can select the Auto-Detect button to automatically select the security type.

Username

Enter Username.

Password

Enter Password.

From Address

Enter From Address.

Reply-To

Enter Reply Address.

Subject

Subject of the sent e-mail alert.
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Option

Description

Recipient(s)

Enter email address(es) to send Alerts to. Click the + button to add more
email addresses.

Test Email Settings

Click the button to test the Email Settings.
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User Management
This section describes the default user accounts and permissions for FortiClient EMS. It also describes how to
change the administrator password and how to configure Windows users.

Default User Accounts and Permissions
The administrator has complete access to all FortiClient EMS permissions, including modification, user
permissions, approval, discovery, and deployment.
The administrator has access to all configured Windows and LDAP servers and users; and has the authority to
configure user privileges and permissions. If you are not authorized for certain tasks or devices, the related menu
items, items in content pages, and buttons are hidden or disabled. In addition, a message informs you that you
do not have permission to view the selected information or perform the selected operation.

Configuring User Management
Changing the Administrator Password
By default, the password is blank for the administrator account. You should add a password to increase security.

To Change the Administrator Password:
1. Go to View > User Management.
2. On the Administration tab, select the Admin account.
3. Click Change Password from the toolbar.
4. Change your password, and click Save.

Configuring Windows User Accounts
You can configure Windows users to have no access to FortiClient EMS, or you can configure Windows users to
have administrator access to FortiClient EMS.
The list of Windows users is derived from the server on which FortiClient EMS is installed. If you want to add
more Windows users, you must add them to the server.

To configure Windows users:
1. Go to View > User Management.
2. On the Administration tab, click the +Add button from the toolbar.
3. From the Add User drop-down menu, select the Windows User.
4. Perform one of the following actions:
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a. Select the specific domain access for the user. For a description of the permissions, see Default User
Accounts and Permissions on page 39.
b. Configure the permissions. For a description of the options, see Windows/LDAP Users on page 42.
5. Click Save.

Configuring LDAP User Accounts
The list of LDAP users is derived from the server on which FortiClient EMS is installed. If you want to add more
LDAP users, you must add them to the server.

To add a new LDAP Server:
1. Go View > User Management.
2. Select the LDAP Server tab.
3. Configure the options. For a description of the options, see the User Management Reference on page 41.
4. Click Save.

To configure LDAP users:
1. Go to View > User Management.
2. On the Administration tab, click the +Add from the toolbar.
3. From the Add User drop-down menu, select the LDAP User.
4. Configure the options.
a. Select the specific domain access for the user. For a description of the permissions, see Default User
Accounts and Permissions on page 39.
b. Configure the permissions. For a description of the options, see Windows/LDAP Users on page 42.
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5. Click Save.

User Management Reference
This section contains descriptions of the fields used to configure user management.

Administration
Following is a description of the fields on the View > User Management > Administration tab.
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Option

Description

+Add

Add a new user.

Name

Name of the user.

Access

Type of user access.

Type

Type of user.

Administration Guide
Fortinet, Inc.

User Management Reference

User Management

Windows/LDAP Users
Following is a description of the fields on the View > User Management > Add > Windows/LDAP User.

Option

Description

Add Windows/LDAP User

Select the Windows/LDAP User for whom you want to configure permissions for FortiClient EMS.

Super Administrator Permissions

Enable the Super Administrator feature to give the new Windows/LDAP
Users Super Administrator permissions.

Comments

Enter optional comments/information for the Windows/LDAP User.

Domain Access

Select or add a Domain Access for the Windows or LDAP User and configure their permissions.
If you choose one or more domains in the domain access field, you will
need to select specific permissions.

Permissions

Use the settings to configure permissions to FortiClient EMS for the selected Windows/LDAP User.

General
Create /
Delete /
Rename
LDAP Records

Select to allow the Windows user to create, delete, and rename
LDAP records. Clear to disable this permission.

Create /
Delete Filters

Select to allow the Windows user to create and delete filters. Clear to disable this permission.

Endpoints

Use the following options to configure permissions for the selected Windows user.
Block /
Unblock /
Deregister /
Quarantine /
Unquarantine
Endpoints

Select to allow the Windows user to block, unblock, deregister, quarantine,
and unquarantine endpoints. Clear to disable this permission.

Run comSelect to allow the Windows user to run commands on endpoints. Clear to
mands on End- disable this permission.
points
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Option

Description
Can access
Software Manager

Select to allow the Windows user to access the View > Software Management options. Clear to disable this permission.

Can access
Certificate
Management

Select to allow the Windows user to access the View > CA certificate Management options. Clear to disable this permission.

Assign / Unassign Policy /
Custom
Groups Management

Select to allow the Windows user to assign to endpoints and unassign profiles from endpoints as well as manage custom groups. Clear to disable
this permission.

Create /
Delete / Edit /
Rename
Policy

Select to allow the Windows user to create, delete, edit, and rename profiles. Clear to disable this permission.

Edit Advanced
Policy

Select to allow the Windows user to use the advanced settings when editing a profile. Clear to disable this permission.

Policies

LDAP Server
Option

Description

Server IP/Name

Enter the Server IP/Name.

Server Port

Enter the Server Port.

Distinguished Name

Enter a Distinguished Name.

Bind Type

Select either Simple, Anonymous or Regular for the Bind Type.

Test
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Username

Appears only when Regular bind type is selected. Enter the Username.

Password

Appears only when Regular bind type is selected. Enter the Password.

Show Password

Enable Show Password.

LDAPS Connection

Enable LDAPS Connection.

Click to test the LDAP server settings.
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Global Settings
Following is a description of the fields on the View > User Management > Global Settings tab.

Option

Description

Inactivity Timeout

Specify how long to keep inactive users logged into FortiClient EMS. When
the time expires, the user is automatically logged out of FortiClient EMS.
Type 0 to keep inactive users logged into FortiClient EMS indefinitely.
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Endpoints
FortiClient Enterprise Management System (FortiClientEMS) needs to determine which devices it has to
manage. Device information can come from either an Active Directory Service, Windows workgroup or manual
FortiClient registration.

Adding Endpoints
Adding Endpoints through an Active Directory Domain service
Endpoints can be manually imported from an Active Directory (AD) Domain Service. Users can import and
synchronize information about computer accounts with a LDAP or STARTTLS service. You can add endpoints by
identifying the endpoint devices that are part of an Active Directory (AD) domain service.

To search for endpoints using Active Directory Domain Service:
1. Click Endpoints > Add a New Domain.
2. In the Domain Settings page, set the options. For a description of the options, see Domain Settings Pane on
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page 50.

3. Click Test to test the domain settings connection.
4. If the test is successful, select Save to save the new domain. If not, correct the information as required then test
the settings again.

An instructional video on how to Add a Domain is available in the Fortinet Video
Library.

You cannot add, delete, or move groups within a domain.

You have the option to add the entire domain or just an organizational unit (OU) from
the domain.
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Enabling an Automatic Discovery of Endpoints with Windows Workgroups
You can enable an automatic discovery of endpoint devices in local Windows workgroups.

To enable automatic discovery of workgroups:
1. Go to View > Settings.
2. Turn on Scan local workgroups. For a description of the options, see Server Settings on page 32.
3. Click Save.
4. View the discovered endpoints in the Endpoints > Workgroups list.
Workgroups are listed under Endpoints > Other Groups . You cannot add, delete or
move groups within a workgroup.

Registering Manually from FortiClient
You can manually register FortiClient endpoints to FortiClient EMS by specifying the IP address for FortiClient
EMS in FortiClient.
FortiClient 5.2.4 or later must be installed on the endpoint device to use the
antivirus scan feature of FortiClient EMS.

To Register an Endpoint to FortiClient EMS
1. Ensure that FortiClient 5.2.4 or later is installed on the endpoint (device).
2. In FortiClient, select Register to FortiGate.
3. Enter the IP address configured for the FortiClient EMS. See FortiClient EMS Settings on page 30.
4. Select Go to register FortiClient.
For more information about endpoint management, refer to the FortiClient Administration Guide available on the
docs.fortinet.com site.
The FortiClient Telemetry Gateway port may be appended to the FortiClient Telemetry Gateway IP List address on FortiClient and separated by a colon. When the port
is not provided, FortiClient attempts to register to the IP address given by using the
default port. The default registration port in FortiClient 5.2 is 8010 and in FortiClient
5.4 is 8013. FortiClient EMS listens for registration on port 8013 by default.

Viewing Endpoints
After FortiClient EMS has been populated by endpoints, users can view the details about its clients.

To View Endpoints:
1. Go to Endpoints to view all endpoints.
2. Select an endpoint to view its details.
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To View Workgroups:
1. Go to Endpoints > Workgroups > All Groups to view all endpoints in the workgroups.
2. Select an endpoint to view its details.

To View Domains:
1. Go to Endpoints > select a Domain tree to view all endpoints in the domain.
2. Select an endpoint to view its details.

To View Manually Registered FortiClient Endpoints
1. Go to Endpoints > Workgroups > All Groups > Other Endpoints to view all endpoints that were manually
registered.
2. Select an endpoint to view its details.

Managing Endpoints
You can manage endpoints from the Endpoints pane. Some options are available as buttons, and some options
are available in the right-click menu. Right-click an endpoint to display the menu.

Option

Description

Refresh

Refresh the list of domains or workgroups.

Show empty containers

Click to display a list of domains without endpoints.

Add a New Domain

Click to add a new Active Directory (AD) server to FortiClient EMS.

Assign profile

Select and apply a profile to the selected workgroup.

Unassign profile

Select to unassign a profile from a selected workgroup.

Assign FortiClient Telemetry
Gateway IP List

Right-click to assign a FortiClient Telemetry Gateway IP List.

Unassign FortiClient Telemetry Gateway IP List

Select to unassign a FortiClient Telemetry Gateway IP List.

Update Signatures

Select to update signatures on the FortiClient endpoint. The option is available for endpoints when FortiClient is registered and its signatures are out
of date.

Exclude from management

Select to exclude the selected workgroup from management by FortiClient
EMS. You can also exclude individual endpoints within the workgroup from
management by FortiClient EMS.
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Option

Description

Enable management

Select to enable FortiClient EMS to manage the selected workgroup. You
can also enable management by FortiClient EMS for individual endpoints
within the workgroup.

Create group

Select to create a group or subgroup. You can then move devices into the
group or subgroup.

Rename group

Select to rename the selected group or subgroup.

Delete group

Select to delete the selected group or subgroup.

Move devices

Select to move the devices from the selected group to another group.

Full AV scan

Select to start a full antivirus scan on the selected workgroup.

Quick AV scan

Select to start a quick antivirus scan on the selected workgroup.

Vulnerability Scan

Select to start a Vulnerability Scan on the selected endpoint.

Patch Critical and High Vulnerabilities

Select to patch critical and high vulnerabilities on the selected endpoint.

Updating FortiClient Endpoints
You can update endpoints by editing the profile associated with the endpoint. When you save the profile, the
changes are automatically pushed to the endpoints.
If you enable the Auto-Sync FortiClient Profiles with FortiGate, users can can auto-sync profile changes to
FortiClient EMS once its been modified on the FortiGate. For more information, see Configuring Profiles on page
55.

Endpoint Information
Viewing Endpoint Information
l

Endpoint status

l

System information

l

FortiClient registration information

l

Outdated versions of FortiClient on the endpoint computers

To view Endpoint information:
Go to Domain > select an Endpoint. A list of information about the Endpoint is displayed.
The following options are available:
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Option

Description

Filter (star icon)

Click the Filter icon to filter for a specific endpoint.

Clear Current Filter (filter icon)

Click the Clear Current Filter icon to clear the currently used filter.

Search

Use the Search field to find a specific endpoint.

Refresh

Click the Refresh icon to refresh the page.

The following information is displayed:

Option

Description

Group

Workgroup name.

Name

Endpoint name.

IP

User's IP address.

User

User's name.

Status

Current status of the user.

Endpoint Profile

Current assigned endpoint profile.

Gateway IP List

Current assigned Gateway IP list.

OS

OS the user is using.

Version

Current running FortiClient EMS version.

Events

List of FortiClient events.

Endpoint References
This section contains descriptions of the fields used to discover endpoints.

Domain Settings Pane
Following is a description of the fields on the Endpoints > Domains > Add a domain pane.
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Option

Description

Group Name

Enter a name for the group. The name will be displayed in the FortiClient
EMS Endpoint view

Server IP/ Name

Type the IP address or name.

Server Port

Type the port number.

Distinguished Name

Type the distinguished name (optional).

Bind Type

Select the bind type. Simple, Anonymous, Regular . When you select
Regular, enter the User DN and password.

User DN

Available when Bind Type is set to Regular. Type the user DN.

Password

Available when Bind Type is set to Regular. Type the user password.

Show Password

Available when Bind Type is set to Regular. Turn on and off to show or
hide the password.

Test

Tests the domain settings connection. If the test is successful, select Save
to save the new domain. If not, correct the information as required, and
then test the settings again.

Clear

Reset the content of the Domain Settings page.

Administration Guide
Fortinet, Inc.

Installers
FortiGuard Distribution Network
FortiClient EMS automatically connects to FortiGuard Distribution Network (FDN) to provide access to FortiClient
installers that you can use with FortiClient EMS profiles. If a connection to FDN is not available, you must
manually download FortiClient installers to use with FortiClient EMS.

Adding Installers
Adding FortiClient Installers to FortiClient EMS
When a connection to FortiGuard Distribution Network (FDN) is available, FortiClient installers are available in
FortiClient EMS for you to select in FortiClient EMS. You must select and add the FortiClient installers that you
want to use to FortiClient EMS, so you can use the installers with profiles.
When you add the installer to FortiClient EMS, you can specify what FortiClient features to include in the installer
for the endpoint. You can include a feature in the installer, and then disable the feature in the profile. Because the
feature is included in the installer, you can update the profile later to enable the feature on the endpoint.
You can also specify whether FortiClient EMS or FortiGate will manage the endpoint after FortiClient is installed.
You cannot edit a FortiClient installer after you add it to FortiClient EMS. You can delete the installer, and add it
again.

To add FortiClient Installers to FortiClient EMS:
1. Go to View > Software Manager. The FortiClient Software Manager pane is displayed.
2. Click the + Add button.
3. Select a FortiClient installer, and configure the options. For a description of the options, see Add Installer
Reference on page 53.
4. Click Save. The installer is added to FortiClient EMS and displayed on the FortiClient Software Manager pane.

Adding Custom FortiClient installers to FortiClient EMS
You can create a custom FortiClient installer and add it to FortiClient EMS. Alternately, if a connection to FDN is
not available, you might need to manually download a FortiClient installer and add it to FortiClient EMS. For
more information, see FortiGuard Distribution Network on page 52.

To add Custom FortiClient Installers to FortiClient EMS:
1. Download a FortiClient installer.
2. Go to View > Software Manager. The FortiClient Software Manager pane is displayed.
3. Click Add. The Add Installer pane is displayed.
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4. In the FortiClient Version list, select Upload. For a description of the options, see Add Installer Reference on
page 53.
5. Click the Browse button, and select the custom installer.
6. Click Save. The installer is added to FortiClient EMS and displayed on the FortiClient Software Manager pane.

Installer References
This section contains descriptions of the fields used to configure installer packages.

Add Installer Reference
Following is a description of the fields on the Add Installer page.

Option

Description

Name

Type a descriptive name for the installer.

Notes

(Optional) Type notes about the installer.

OS

Select Mac OS X or Windows to identify the operating system for which
the installer file is created.

FortiClient Version

Select the installer for the FortiClient version that you want to deploy to endpoints.

Patch Version

Select the patch version for the FortiClient installer if applicable.

Keep software updated to
latest patch release

Enable to keep FortiClient EMS up to date with the latest patch release.

Automatic
Registration

53

Available when OS is set to Windows. Turn on for FortiClient endpoints to
automatically register with the management server, which is either FortiClient EMS or FortiGate. Turn off to disable automatic registration with management server.

Features to install

Available when OS is set to Windows. Select what features you want to
include in the FortiClient installer. Only selected features are included in
the installer. Excluded features are excluded from the installer. You can
configure selected features when you configure the FortiClient EMS profile.

This FortiClient will be managed by

Available when OS is set to Windows. Select EMS or FortiGate to identify
whether FortiClient EMS or FortiGate will manage the endpoints after
FortiClient is installed. You must also select the IP address for the FortiClient EMS or FortiGate that will manage the endpoint. The FortiClient endpoint uses the IP address to automatically register with the management
server. For example, if FortiClient EMS will manage the FortiClient endpoint, select the IP address for FortiClient EMS. If FortiGate will manage
the FortiClient endpoint, select the IP address for the FortiGate.
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Option

Description

Desktop shortcut

Available when OS is set to Windows. Turn on for a FortiClient desktop
shortcut to be created when FortiClient is installed on endpoints. Turn off to
disable this feature.

Start menu shortcut.

Available when OS is set to Windows. Turn on for a FortiClient start menu
shortcut to be created when FortiClient is installed on endpoints. Turn off to
disable this feature.

FortiClient Installer

Available when OS is set to Mac OS X. Select the FortiClient installer that
you created for Mac OS X.

FortiClient Installer (64 bit)

Select the 64-bit FortiClient installer that you created.

FortiClient Installer (32 bit)

Select the 32-bit FortiClient installer that you created.
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XML Configuration
You can configure FortiClient profile settings in FortiClient EMS by using a custom XML configuration file. The
custom file includes all settings required by the endpoint at the time of deployment. When the endpoint registers
to FortiClient EMS, ensure the complete XML configuration file is used. For more information about how to
configure a profile with XML, see the FortiClient XML Reference on docs.fortinet.com

Configuring Profiles
Importing FortiGate Profiles
You can import profiles from FortiGate to FortiClient EMS and use the profiles with FortiClient EMS.
To import FortiGate profiles successfully to FortiClient EMS, FortiGate must have the
HTTPS port open. Go to Network > Interfaces > Restrict Access, and Enable the
checkbox for HTTPS.

To Import Profiles:
1. Click Endpoint Profiles > Import Profile from FortiGate. The Import Profile from FortiGate window opens.
2. Configure the following settings:
Server IP / Hostname

Enter the IP address and hostname of the FortiGate device from which the
profile is being imported, in the format: <ip address>.

VDOM

Enter a VDOM name from the FortiGate if applicable.

Username

Enter the device' s login username.

Password

Enter the device's login password.

3. Select Next.
4. Select the FortiClient profiles from the FortiGate that will be imported to the EMS.
The selected FortiClient profiles are automatically named and listed in the Profile to Import box. Selecting a
FortiClient profile from the Profile to Import box will display a preview of the FortiClient profile, in XML, in the
Profile Preview box.
5. Optionally, select whether to automatically synchronize the profile in EMS when you update the profile in FortiOS
by enabling the Auto-sync every option and specifying a time interval.
6. Select Import to import the selected FortiClient profiles.
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The imported FortiClient profiles will be listed under the Endpoint Profiles pane in a group named after the
FortiGate device from which they were imported.
Imported FortiClient profiles are read-only in FortiClient EMS. However, you can
enable automatic synchronization of imported profiles in the profile settings. Then
when you update the profile in FortiGate, the changes are automatically updated in
FortiClient EMS.
7. To add an installer to the profile, select a profile to open the Endpoint Profiles page, then select an installer in the
Install Options tab.
Custom installers can also be created.

Adding New Profiles
When you install FortiClient EMS, a default profile is created. This profile is applied to any groups that you create.
The default profile is designed to provide effective levels of protection. If you want to use specific features, such
as application firewall, you can create a new profile or change the default profile.
Consider the following when creating profiles:
l

Use default settings within a profile.

l

Consider the role of the computer when changing default profile or creating new profiles.

l

Create a separate group and profile for computers that require long-term special configuration.

l

Use FortiClient EMS for all central profile settings, and set options for within the group instead of for the computer
itself when possible.

To Add New Profiles:
1. Go to Endpoint Profiles > Add a new profile.
2. On the Install Options tab, select a FortiClient installer from the FortiClient Deployment list.
The selected installer controls what tabs are displayed for the profile, based on the features that the installer
includes. For example, if the installer includes only the VPN feature, only the VPN tab is displayed for you to
configure. The System Settings tab is always displayed.
You can disable a feature that is included in the installer, and then enable the feature in the profile at a later
date. For example, if the installer includes the Application Firewall, VPN, Web Filtering, and Vulnerability
Scan features, you can disable the Web Filter feature and keep the other features enabled. When FortiClient
is installed on the endpoint, the Web Feature is installed, but disabled.
3. Configure the settings on the tabs. For a description of the options, see Profile References on page 58.
4. Click Save to save the profile.
You have the option to schedule an installation. Go to Profile > Install Options, and
select a FortiClient installer. The Schedule Installation option becomes available.

Vulnerability Scan Settings
1. Go to Endpoint Profiles > EMS Profiles, and create a new profile, or select an existing profile.
2. Go to the Vulnerability Scan Settings tab.
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Pushing Profile Changes to Endpoints

3. Configure the options. For a description of the options, see Profile References on page 58.
4. Click Save.

Pushing Profile Changes to Endpoints
Assigning Profiles to Endpoints
After creating the profile, you can assign the profile to domains or workgroups. When you assign the profile to
domains or workgroups, the profile settings are automatically pushed to the endpoints in the domain or
workgroup.

To assign profiles:
1. Go to Endpoints
2. Right-click a domain or group, select Assign Profile, and then the profile. The profile is assigned.
3. Hover the mouse over the name of the domain or group to view the name of the assigned profile.

Editing Profiles
When you edit a profile that is assigned to endpoints, the changes are automatically pushed to the endpoints
when you save the profile.

To update profiles:
1. Go to Endpoint Profiles > EMS Profiles, and select a profile. The profile settings are displayed in the content
pane.
2. Edit the settings. For a description of the options on the tabs, see Profile References on page 58.
3. Click Save. The changes are installed on the endpoints associated with the profile.

Managing Profiles
You can manage profiles from the Endpoint Profiles pane by clicking the icons.
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Option

Description

Refresh

Refresh the list of profiles.

Import

Click to import a profile from FortiGate.

Add a New Profile

Click to create a new profile.

Revert to default

Click to revert the default profile to its default settings.

Edit

Select a profile to display its settings in the content pane for editing.
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Option

Description

Clone

Click to clone the profile.

Delete

Click to delete the profile.

Profile References
This section contains descriptions of the fields used to configure profiles.

Endpoint Profile Pane
Configuration

Description

Profile Name

Type a name for the profile.

Basic

Select to configure the profile by using the GUI.

Advanced

Select to configure the profile by using XML.

Basic Settings
FortiClient Installer Settings
Option

Description

Installers can only be assigned to non-default profiles
FortiClient Deployment

Specify whether to configure the profile to install a FortiClient package to
endpoints or uninstall FortiClient from endpoints. Select the Select an
action option if you want to leave FortiClient software as is on endpoints.
Otherwise, select one of the following options:
l Install a FortiClient Package. See Install a FortiClient Package on page
58.
l

l

Select Uninstall FortiClient. See Uninstall a FortiClient Package on page
59.
Create a new installer

Install a FortiClient Package
Option

Description

FortiClient Deployment

Select Install a FortiClient package, and then select a package.
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Option

Description

Schedule Installation
Start

Specify what time to start the installation of the FortiClient package on endpoint devices.

Prompt end
user if a
reboot is
needed during installation

Toggle On to prompt the end user if a reboot of the endpoint device is
needed. Toggle Off to reboot the endpoint device without prompting the
user.

Use these credentials to install
Username

Type the username to use for installation.

Password

Type the password to use for installation.

Show Password

Toggle On the display the password. Toggle Off to hide the password.

Uninstall a FortiClient Package
Option

Description

FortiClient Deployment

Select Uninstall.

Schedule Uninstall
Start

Specify what time to start the uninstallation of the FortiClient package on
endpoint devices.

Use these credentials to uninstall
Username

Type the username to use for uninstallation.

Password

Type the password to use for uninstallation.

AntiVirus Protection
Enable antivirus protection. Configure the following options:

Options

Description

Real Time Protection
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Options

Description

Scan files as they are downloaded

Scan files as they are downloaded or copied to my system.

Extended scanning using FortiSandbox

Extended scanning using FortiSandbox. An IP address is
required.

IP Address

Enter the IP Address. This is required.

Deny access to file
until FortiSandbox
results are received

Enable to deny access to file(s) until FortiSandbox results are
received.

Deny access to
downloaded files if
FortiSandbox is offline

Enable to deny access to downloaded files if FortiSandbox is offline.

Identify malware &
exploits using signatures received
from FortiSandbox

Enable to identify malware & exploits using signatures received
from FortiSandbox.

Block known communication channel
used by attackers

Enable to block known communication channels used by attackers.

Block all access to malicious websites

Enable to block all access to malicious websites.
When enabled, the Endpoints > Client Details pane displays
Web Filter running in the Features section. When disabled, the
Client Details pane displays Web Filter installed.

Use the exclusion
list defined in the
Web Filter profile

Enable to use the exclusion list defined in the Web Filter Profile.

Alert when viruses are detected

Enable to alert when viruses are detected.

Scheduled Scan

Enable scheduled scans.

Scheduled Type

Select either Daily, Weekly, or Monthly.

Scan On

If Weekly is selected, select the day of the week to perform the
scan. If Monthly is selected, select the day of the month to perform the scan.

Start

Configure the start time for the scheduled scan.
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Description

Scan Type

Select either Quick system scan, Full system scan, or Custom scan. If Custom scan is selected, enter the full path of the
folder that will be scanned in the Folder field.
Full system scan

If Full system scan is selected, you have the following options:
l
Scan removable media, if present
l

Custom Scan

Scan network drives

If Custom scan is selected, enter the full path of the folder that
will be scanned in the Folder field.

Exclusions

Enable exclusions.

Excluded Folders

Enter fully qualified excluded folder paths in the provided text
box to exclude these folders from antivirus scanning.

Excluded Files

Enter fully qualified excluded files in the provided text box to
exclude these files from antivirus scanning.

Show Advanced Options

Turn on to display and configure basic and advanced options.
Turn off to display and configure only basic options.

Real Time Protection

Enable real-time protection.

Scan files as they are downloaded or
copied to my system.

Select one of the following:
l
Clean infected files (quarantine if cannot clean)
l
l

Repair infected files (quarantine if cannot clean)
Warn the user if a process attempts to access infected
files

l

Quarantine infected files

l

Deny access to infected files

Extended scanning using FortiSandbox
Deny Access to file
until FortiSandbox
results are
received.

Configure the timeout in seconds.

Identify malware &
exploits using signatures received
from FortiSandbox.

Enable to identify malware & exploits using signatures received
from FortiSandbox.

Scan compressed files
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Configure the time interval (in minutes) to download new signatures.
Enable to scan compressed files.
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Description
Max size

Configure the maximum size of compressed files to be
scanned. 0 means unlimited.

Scan email

Enable to scan email.

User process scanning

Enable user process scanning. Select one of the following:
l
Scan files when processes read or write them

System process scanning

l

Scan files when processes read them

l

Scan files when processes write them

Enable system process scanning. Select one of the following:
l
Scan files when system processes read or write them
l

Scan files when system processes read them

l

Scan files when system processes write them

l

On Demand Scanning

Do not scan files when system processes read or write
them

Enable On Demand scanning. Select one of the following:
l
Clean infected files (quarantine if cannot clean)
l
l

l

Repair infected files (quarantine if cannot clean)
Warn the user if a process attempts to access infected
files
Quarantine infected files

Integrate FortiClient into Windows
Explorer's mouse menu

Enable to integrate FortiClient into Windows Explorer's mouse
menu.

Pause scanning when running on battery
power

Enable to pause scanning when running on battery power.

Automatically submit suspicious files to
FortiGuard for analysis

Enable to automatically submit suspicious files to FortiGuard for
analysis.

Scan compress files
Maximize scan
speed on computers with more
than XGB of
memory installed

Select one of the following:
l
4GB
l

6GB

l

8GB

l

12GB

l

16GB

Scheduled Scan
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Options

Description

Scan Priority

Select one of the following:
l
Low
l

Normal

l

High

Scan removable media, if present

Enable to scan removable media, if present.

Scan network drives

Enable to scan network drives.

Scheduled scans even when a 3rd-party
AV product is present.

Enable scheduled scans even when a 3rd-party AV product is
present.

Exclusions
File extensions excluded from Real Time
AntiVirus Protection

Enable to exclude file extensions from Real Time AntiVirus Protection.

File Extensions excluded from On
Demand AntiVirus Protection

Enable to exclude file extensions from On Demand AntiVirus
Protection.

More Options
Scan for rootkits

Enable to scan for rootkits.
Rootkits is a collection of programs that enable administrator
level access to a computer or computer network. Typically a
rootkit is installed on a computer after first obtaining user-level
access either by exploiting a known vulnerability or cracking a
password.

Scan for adware

Enable to scan for adware.
Adware is a form of software that downloads or displays
unwanted ads when a user is online.

Scan for riskware

Enable to scan for riskware.
Riskware are legitimate programs which, when installed and
executed, presents a possible but not definite risk to the computer.

Advanced heuristics

Enable advanced heuristics.
Advanced heuristics is a sequence of heuristics to detect complex malware.

Scan removable media on insertion
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Enable to scan removable media (CDs, DVDs, Blu-ray disks,
USB keys etc) on insertion.
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Options

Description

Scan mime files (inbox files)

Enable to scan mime files.
Multipurpose Internet Mail Extensions (mime) is an Internet
standard that extends the format of the email to support the following:
l
Text in character sets other than ASCII
l

l

FortiGuard Analytics

Non text attachments (audio, video, images,
applications)
Message bodies with multiple parts

Enable FortiGuard Analytics.

Notify logged in users if their AntiVirus sig- Enable to notify logged in users if their AntiVirus signatures
natures expire
expire.

Web Filter
Configuration

Description

Web Filter

Enable web filtering.
l
Client Web Filtering when On-Net
l

l
l

Client Web Filtering when On-Net

Enable FortiGuard URL categorization: Block, Warn,
Allow, or Monitor specific categories of web sites. See
the FortiGuard web site for descriptions of the available
categories and subcategories.
Rate IP addresses: Select to rate IP addresses.
Exclusion List: Enter specific URLs to block or allow.
Wildcard characters and Perl Compatible Regular
Expressions (PCRE) can be used.

Enable for client web filtering when on net.

Enable FortiGuard URL categorization
Adult/Mature Content

Select one of the following:
l
Block
l

Warn

l

Allow

l
Monitor
See the FortiGuard web site for descriptions of the available categories and subcategories.
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Configuration

Description
Bandwidth Consuming

Select one of the following:
l
Block
l

Warn

l

Allow

l
Monitor
See the FortiGuard web site for descriptions of the available categories and subcategories.

General InterestBusiness

Select one of the following:
l
Block
l

Warn

l

Allow

l
Monitor
See the FortiGuard web site for descriptions of the available categories and subcategories.

General InterestPersonal

Select one of the following:
l
Block
l

Warn

l

Allow

l
Monitor
See the FortiGuard web site for descriptions of the available categories and subcategories.

Potentially Liable

Select one of the following:
l
Block
l

Warn

l

Allow

Monitor
See the FortiGuard web site for descriptions of the available categories and subcategories.
l

Security Risk

Select one of the following:
l
Block
l

Warn

l

Allow

l
Monitor
See the FortiGuard web site for descriptions of the available categories and subcategories.
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Description
Unrated

Select one of the following:
l
Block
l

Warn

l

Allow

l
Monitor
See the FortiGuard web site for descriptions of the available categories and subcategories.

Exclusion List
Action

Select one of the following actions:
l
Block
l

Allow

URL

Enter specific URLs to block or allow.

Type

Select one of the following types:
l
Simple
l

Wildcard

Regular Expression
Wildcard characters and Perl Compatible Regular Expressions
(PCRE) can be used.
l

Show Advanced Options

Web Filter

Turn on to display and configure basic and advanced options.
Turn off to display and configure only basic options.
l

Log All URLs

l

Log user initiated traffic

l

Enable Safe Search

Application Firewall
Configuration

Description

Application Firewall

Enable application control.

Notification bubbles on user's desktop when applications are blocked

Enable notification bubbles when applications are
blocked.

Detect & Block Exploits

Enable to detect and block exploits.
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Description

Categories

Block, allow or monitor the following categories:
a. IM
b. P2P
c. VoIP
d. Video/Audio
e. Proxy
f. Remote Access
g. Game
h. General Interest
i. Network Service
j. Update
k. Botnet
l. Email
m. Storage Backup
n. Social Media
o. File Sharing
p. Web Other
q. Industrial
r. Special
s. Collaboration
t. Business
u. Cloud IT
v. Mobile
w. All other known applications
x. All other unknown applications

Application Overrides
Delete

Delete an application.

Add Signature

Add a signature to an application.

VPN
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Configuration

Description

VPN

Enable VPN use.

Allow Personal VPN

Enable to allow personal VPN.

Disable Connect/Disconnect

Enable to disable connect/disconnect.
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Show VPN Before Logon

Enable to show VPN before logon.

Local Computer Windows Store Certificates (IPSec only)

Enable local computer Windows Store certificates (IPSec only).

Current User Windows Store Certificates
(IPSec only)

Enable current user Windows Store certificates (IPSec only).

SSL VPN

Enable SSL VPN.

IPSec VPN

Enable IPSec VPN.

Add VPN Tunnel
VPN Name

Enter a VPN name.

Type

Select either SSL VPN or IPSec VPN for the type.

Remote Gateway

Enter an IP address or hostname.

Require Certificate

Enable to require a certificate.

Access Port

Enter the access port.

Show advanced options

Enable to display and configure advanced options. .

Show VPN Before Log on
Use Windows Credentials

Use Windows credentials for VPN.

Minimize Window on Connect

Enable to minimize the window upon connecting.

Show Negotiation Window

Enable to show negotiation window.

Keep Running Maximum Tries

Configure the maximum number of logon attempts.

SSL VPN
DNS Cache Service
Control

Enable for DNS Cache Service Control.
When this setting is 0, the custom DNS server from SSL VPN
will not be added to physical interface. When this setting is 1,
custom DNS server from SSL VPN will be prepended to physical
interface.

Prefer SSL VPN
DNS
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Description

IPSec VPN

Enable or disable the following:
a. Beep if Error
b. Local Computer Windows Store Certificates
(IPSec only)
c. Current User Windows Store Certificates
(IPsec only)
d. Use Windows Store Certificates
e. Use Local Certificates
f. Use Smart Card Certificates
g. Show Auth Certificates Only
h. Block IPv6
i. Enable UDP Checksum
j. Disable Default Route
k. Check For Certificate Private Key
l. Enhanced Key Usage Mandatory
m. Use Vendor ID

Add VPN Tunnel
Single User Mode

Enable Single User Mode.

Warn on Invalid
Server Certificate

Enable to warn when an invalid server certificate is used.

Remember Password option

Enable to remember password.

Always Up option

Enable to have the VPN Tunnel always up. This is also needs to
be enabled on the FortiGate.

Auto Connect
option

Enable to auto connect the VPN Tunnel. This is also needs to
be enabled on the FortiGate.

On Connect Script

Enable the On Connect script. This is also needs to be enabled
on the FortiGate.

On Disconnect
Script

Enable the Disconnect script. This is also needs to be enabled
on the FortiGate.

Vulnerability Scan
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Configuration

Description

Vulnerability Scan Settings

Enable Vulnerability Scan Settings.
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Description

Scan on registration

Scan endpoints upon registering to a FortiGate.

Scan on signature update

Scan endpoints upon updating a signature.

Schedules Scan

Schedule the scan.
Schedule Type

Configure either Daily, Weekly, Monthly.

Scan On

Configure the day the scan will run (1st-31st of the month). This
only applies if the Schedule Type is configured to Monthly.

Start

Configure the time the scan will start.

Scan for Windows Updates

Scan for Windows updates

Automatically Patch Vulnerabilities

When enabled, patches will be installed automatically when vulnerabilities are detected. Select one of the following:
l
Patch critical vulnerabilities only
l

Patch high severity, and above, vulnerabilities

l

Patch medium severity, and above, vulnerabilities

l

Patch low severity, and above, vulnerabilities

l

Patch all vulnerabilities.

System Settings
Configuration

Description

UI options

Specify how the FortiClient user interface will appear when
installed on endpoints.

Password Lock Configuration

Turn on the password lock for FortiClient.

Password

Type a password in the Password field.

Show Password

Select Show Password to show the password in plain text.

Log Settings

Specify the log settings for FortiClient.

Client-based Logging when On-Net

Turn on client-based logging when On Net. For more information about using the on-net feature, see the FortiClient
Administration Guide.

Upload Logs to FortiAnalyzer/FortiManager

Turn on to upload FortiClient logs to the FortiAnalyzer or
FortiManager device at the specified address or hostname.

Upload Traffic Logs
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Configuration

Description
Upload Vulnerability
Logs

Enable to upload Vulnerability Logs.

Upload Event Logs

Enable to upload Event Logs.

IP Address

Enter the IP address.

Upload Schedule

Configure the upload schedule in minutes.

Update Settings

Specify whether to use FortiManager to update FortiClient on
endpoints

Use FortiManager for client software/signature update

Turn on to enable FortiClient EMS to obtain antivirus signatures and software updates from the FortiManager device
at the specified IP address or hostname.
Enter the following:
l
IP Address/hostname
l
Port
You can enable the following:
l
Failover to FDN when FortiManager is not available.

IP Address/Hostname

Enter the IP address/hostname.

Port

Enter the port number.

Failover to FDN when
FortiManager is not
available

Enable failover to FDN when FortiManager is not available.

Endpoint Control Settings

Specify settings for the endpoints.

Silent Registration

Turn on to enable silent registration of endpoints, which
means that endpoints are registered without user interaction.
Turn off to require user interaction to register endpoints.

Log off when user logs out of Windows

Turn on to log off FortiClient when the endpoint user logs out
of Windows. Turn off to remain logged in.

Disable Unregister

Turn on to forbid users from unregistering FortiClient from
FortiClient EMS. Turn off to allow users to unregister FortiClient from FortiClient EMS.
Disable FGT Switch

Onnet Subnets

Turn on to enable onnet subnets.
List of IP
Addresses/Masks
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Enable to disable FGT Switch.

Enter IP addresses/mask to connect to onnet subnets.
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Configuration

Description
Gateway Mac
Addresses

Enter mac addresses.

Other Options
Install CA Certificate on Client

Turn on to select and install a CA certificate on the FortiClient
endpoint.
You can add certificates by going to View > CA Certificate
Management.

FortiClient Single sign-On mobility agent

Turn on to enable the single sign-on mobility agent. Enter the
following:
l
IP address or hostname
l

Port

Pre-shared key.
You can enable the following:
l
Show Password
l

IP Address/Hostname

Enter the IP address or hostname.

Port

Enter the port number.

Pre-shared Key

Enter the pre-shared key.

Show Password

Enable to show the password in plain text.

iOS
Distribute Configuration Profile (.mobileconfig file)

Turn on to select and distribute a configuration profile to
FortiClient endpoints.

Show Advanced Options

Enable to display and configure advanced options. .

UI Options
Dashboard Banner

Turn on to display the dashboard banner in FortiClient. Turn
off to hide the dashboard banner.

Hide System Tray Icon

Enable to hide the System Tray icon.
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Configuration

Description

Culture Code

Configure the Culture Code. Select one of the following:
l
os-default
l

zh-tw

l

cs-cz

l

de-de

l

en-us

l

fr-fr

l

hu-u

l

ru-ru

l

ja-jp

l

ko-kr

l

pt-br

l

sk-sk

l

es-es

l

zh-cn

l

et-ee

l

lv-lv

l

It-It

l

fi-fi

l

sv-se

l

da-dk

l

pl-pl

l

nb-no

Log Settings
Levels
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Select one of the following:
l
Emergency
l

Alert

l

Critical

l

Error

l

Warning

l

Notice

l

Information

l

Debug
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Configuration

Description

Features

Enable any (or all) of the following:
l
IPSec VPN
l

SSL VPN

l

Update

l

Application Firewall

l

AntiVirus

l

Proxy

l

Web Filter

l

Endpoint Control

l

FSSOMA

l

Wan Optimization

Upload Logs to FortiAnalyzer/FortiManager
Upload Event Logs

Enable to upload event logs. Enter the IP address/hostname.

SSL Enabled

Enable SSL. Configure the Log Retention in days.

Proxy Settings
Use Proxy for Updates
Type

Enable to use proxy for updates.
Configure the type. Options include:
l
http
l

socks4

l

socks5

IP Address/Hostname

Enter the IP Address/Hostname.

Port

Enter the port number.

User Name

Enter the User Name.

Password

Enter the Password. Enable Show Password to show the
password in plain text.

Us Proxy for virus submission

Enable to use proxy for virus updates

Update Settings
Auto-Patch
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Configuration

Description

Update Action

Configure the following Update Action:
l
Notify Only

Update Schedule

l

Download and Install

l

Download Only

Enable to configure the update schedule
Schedule

Select either Hourly or Daily.

Interval

Configure the interval.

FortiProxy Settings
FortiProxy Settings

Enable to only disable when troubleshooting.
HTTPS Proxy

Enable HTTPS Proxy. Configure the HTTP Timeout.

POP3 client comforting

Enable POP3 client comforting.

POP3 server comforting

Enable POP3 server comforting.

SMTP

Enable SMTP.

SelfTest

Enable SelfTest. You have the option to Notify the Last Port.

Endpoint Control Settings
Show Bubble Notifications

Enable to show bubble notifications.

Show Profile Details

Enable to show profile details.

Other Options
Wan Optimization

Enable Wan Optimization.
Maximum Disk Cache
Size
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Select either 512 or 1024 MB.
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Advanced Settings
Configuration Tab
Configuration

Description

XML Editor

Configure using the XML Editor.
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FortiClient Telemetry Gateway IP Lists
About FortiClient Telemetry Gateway IP Lists
FortiClient Telemetry Gateway IP List feature allows greater control of FortiClient Telemetry client registration.
Instead of managing and monitoring endpoints from FortiGate or FortiClient EMS, this feature de-couples the
FortiGate IP List from the rest of the profile. This allows EMS administrators to dictate where the FortiClient
Telemetry clients register to.
The user creates a list of IP addresses to register to. This becomes the FortiClient Telemetry Gateway IP List. To
deploy, assign the FortiClient Telemetry Gateway IP List to a domain or workgroup. After deployment and
FortiClient Telemtery data registration process has started, the endpoint will try to register to a FortiGate or EMS.
This registration is based on the FortiClient Telemetry Gateway IP List received from EMS.
Even if the endpoint is already registered to a FortiGate, users can still assign a FortiClient Telemetry Gateway IP
List. Users can also update list as required. The updates will then be pushed to the its clients.

Creating FortiClient Telemetry Gateway IP Lists
To create a FortiClient Telemetry Gateway IP List:
1. Go to FortiClient Telemetry Gateway IP List
2. Click the + button.
3. Configure the following:
List Name

Enter the list name.

Comment

Enter additional comments (optional).

IP Addresses

Enter the IP address and port for FortiGate devices by
using the following format: IP:port. This can also be a
Fully Qualified Domain Name (FQDN).

Connection Key (Optional)

Enable the registration key for FortiGate devices that
FortiClient endpoints can use for registration.

Connection Key

Enter the registration key.

Confirm Key

Re-enter the registration key to confirm.

Monitored by EMS

Select an option from the drop down. Users can configure
this IP address in the View > Settings page.

4. Click Save.
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FortiClient Telemetry Gateway IP Lists

Assigning FortiClient Telemetry Gateway IP Lists to Endpoints
After creating the FortiClient Telemetry Gateway IP List, you can assign the list to endpoints. When you assign
the IP list and FortiClient Telemetry data registration process has started, the endpoint will register to a FortiGate
based on the FortiClient Telemetry Gateway IP List.

To assign a FortiClient Telemetry Gateway IP List
1. Select a domain or workgroup.
2. Right-click > Assign FortiClient Telemetry Gateway IP List > Select List.

Viewing Assigned FortiClient Telemetry Gateway IP Lists
To view an Assigned Endpoint's FortiClient Telemetry Gateway IP List:
1. Select an Endpoint.
2. View the FortiClient Information > Gateway IP List column.
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Deployment and Updates
You can use FortiClient EMS to deploy FortiClient on the endpoint devices that are part of an Active Directory
(AD) server. Deploying FortiClient from FortiClient EMS requires the following steps:
l

Preparing the AD server for deployment

l

Deploying FortiClient on endpoint devices

After FortiClient is deployed on endpoints, and endpoints are registered with FortiClient EMS, you can update
endpoints by editing the profiles associated with endpoints. Profile changes are automatically pushed to the
endpoints.

Preparing the AD Server for Deployment
Before you can successfully deploy a FortiClient installation, ensure that you install and prepare the AD server as
follows:
l

Configure a group policy on the AD server.

l

Configure the required Windows services on the AD server.

l

Create deployment rules for Windows firewall

l

Configure Windows firewall domain profile settings

Configuring a Group Policy on the AD Server
To configure a group policy on the AD server:
1. On the AD server, open Group Policy Management.
2. Right-click the Default Domain Policy setting. The Group Policy Management Editor opens.
A new policy will be applied to the entire AD domain. Alternatively, you can create a new Group Policy Object, and
link it to one or more organizational units (OU) in the AD server that contains the endpoint computes on which
FortiClient will be deployed.

Configuring Required Windows Services
To configure required Windows services:
1. In the Group Policy Management Editor, in the left panel, go to Computer Configuration > Policies > Windows
Settings > Security Settings > System Services.
2. In the right panel, select the following:
a. Task Scheduler: Automatic
b. Windows Installer: Manual
c. Remote Registry: Automatic
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Creating Deployment Rules for Windows Firewall
To create deployment rules for Windows firewall:
1. In the Group Policy Management Editor, in the left panel, go to Computer Configuration > Policies > Windows
Settings > Security Settings > Windows Firewall with Advanced Security > Inbound Rules.
2. Right-click Inbound Rules and select New Rule.
3. Select Predefined from the drop-down list and select File and Printer Sharing.
4. Click Next.
5. Ensure that the File and Printer Sharing (SMB-In) box is select and click Next.
6. Select Allow the connection and click Finish.
7. Repeat steps 1 to 2.
8. Select Predefined from the drop-down list and select Remote Scheduled Tasks Management and click Next.
9. Ensure that the Remote Scheduled Tasks Management (RPC) box is checked and click Next.
10. Select Allow the connection and click Finish.

Configuring Windows Firewall Domain Profile Settings
To Configure Windows Firewall Domain Profile Settings:
1. In the Group Policy Management Editor, in the left panel, go to Computer Configuration > Policies >

Administrative Templates > Network > Network Connections > Windows Firewall > Domain Profile.
2. Select Allow inbound file and printer sharing exception:
a. Right-click and select Edit.
b. Enable the radio button.
c. Provide the IP address of the EMS server in the text box.
d. Allow unsolicited incoming messages from these IP addresses.
e. Click OK.
3. Select Allow inbound file and remote administration exception:
a. Repeat steps listed in step 2 above to create an exception.
To deploy the group policy manually, execute gpupdate /force on the AD
server to update the group profile on all endpoint clients.
Execute gpresult.exe /H gpresult.html on any AD client to view the
group policy deployed on the endpoints.

Deploying FortiClient on Endpoint Devices
Before you can successfully deploy a FortiClient installation from FortiClient EMS by using an AD server, you
must have prepared the AD server. See Preparing the AD Server for Deployment on page 79.

Administration Guide
Fortinet, Inc.

80

Deployment and Updates

Deploying FortiClient on Endpoint Devices

To Deploy FortiClient on Endpoint Devices
1. Add the AD server to FortiClient EMS by adding a domain. See Adding Endpoints on page 45.
2. Add a FortiClient installer package to FortiClient EMS. See Adding Installers on page 52.
3. Add a profile, select the FortiClient installer package, and configure FortiClient features in the profile. See
Configuring Profiles on page 55.
4. Assign the profile to a branch of the AD domain to push the FortiClient installation process on the endpoint
devices. See Assigning Profiles to Endpoints on page 57.
5. Verify the deployment by monitoring FortiClient registrations to the FortiClient EMS.

To Deploy to Workgroups
Deployment to workgroups is supported as long as the policies and credentials have the proper setup.
1. Configure the required Windows services on the AD server. Configuring Required Windows Services on page 79
2. Create deployment rules for the Windows Firewall. See Creating Deployment Rules for Windows Firewall on page
80.
3. Configure the Windows Firewall domain profile settings. See Configuring Windows Firewall Domain Profile
Settings on page 80.

To Deploy a FortiClient Upgrade from EMS
You can deploy a FortiClient software update from EMS. A prompt will appear in the FortiClient endpoint when an
installer package is requested to be deployed. The prompt will request the user to do either of the following:
l

Upgrade Now
If this option is selected, it will perform the upgrade and will automatically restart your computer.

l

Upgrade Later
If this option is selected, you can indicate the time to start the upgrade. Otherwise, the default time is at
8:00PM. Your computer will automatically restart after the upgrade has finished.
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No Option
If no option is selected, the upgrade will occur, by default at 8:00PM.

After FortiClient EMS uninstalls the previous version, it will ask if the user would like to reboot. The prompt will
request the user to do either of the following:
l

Reboot Now
If this option is select, the reboot will occur immediately.

l

Reboot Later
If this option is selected, you can indicate the time to start the reboot.

l

Cancel Reboot
If this option is select, you can cancel the reboot request and reboot at your discretion.
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Alerts and Log Messages
You can view alerts and log messages generated by FortiClient EMS.

Viewing Alerts
You can view the alerts generated by FortiClient EMS. Examples of events that generate an alert include:
l

New version of FortiClient is available

l

FortiClient deployment failed

l

Failure to check for signature updates

l

Error encountered when downloading AD server entries

l

Error encountered when scanning for local computers

A red label is associated with the Alert icon when new notifications are available or received. It is cleared when
you view the alert.

To view alerts:
1. Click the Alert icon (an envelope) in the toolbar. The EMS Alert Logs pane is displayed.
2. Click the Filter icon in each column heading to apply filters.
3. Click Clear Filter to remove the filters.

Viewing Log Messages
You can view the log messages generated by FortiClient EMS.

To view log messages:
1. Go to View > View Logs. The Logs pane is displayed.
2. Click the Filter icon in each column heading to apply filters.
3. Click Clear Filters to remove the filters.

Downloading Raw Logs
You can download the raw logs generated by FortiClient EMS.

To download raw logs:
1. Go to View > View Logs. The Logs pane is displayed.
2. Click Raw Logs.
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3. Click the calendar icon in the Start Date and End Date boxes to select a start date and end date for the logs that
you want to download.
4. In the Levels box, select one or more levels of logs to include.
5. In the Sources list, select one or more sources to include.
6. In the Message box, type the log message or messages to include. Leave blank to include all log messages.
If you want to exclude the log message, enable the NOT option.
7. Click the Calculate Size button to view the size of the download.
8. Click Download.
A zip of the raw logs is downloaded to your computer.

Email Alert Settings
You can add an option to set up an SMTP server to enable an Alert for EMS/Endpoint Events. When an alert is
triggered, an email notification will be sent. For more information, seeEmail Alert Settings on page 30.
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