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Change Log

Change Log

Date Change Description

2023-05-15 Initial release.
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¢ Managing a Compromised Hosts rescan policy on page 85
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2023-05-31 Updated Management Extensions on page 398.

2023-06-08 Updated Creating macros on page 267.

2023-06-21 Updated Output profiles on page 319.

2023-06-29 Updated Licensing in an air-gap environment on page 341.
2023-07-06 Updated How ADOMs affect reports on page 239.
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Setting up FortiAnalyzer

This chapter provides information about performing some basic setups for your FortiAnalyzer units.

This section contains the following topics:

Connecting to the GUI on page 12

Security considerations on page 20

GUIl overview on page 22

Target audience and access level on page 29
Initial setup on page 29

FortiManager features on page 29

Next steps on page 30

Restarting and shutting down on page 30

Connecting to the GUI

The FortiAnalyzer unit can be configured and managed using the GUI or the CLI. This section will step you through
connecting to the unit via the GUI.

Ay
‘Q' If you are connecting to the GUI for a FortiAnalyzer virtual machine (VM) for the first time, you
- are required to activate a license. See Activating VM licenses on page 18.

To connect to the GUI:

Connect the FortiAnalyzer unit to a management computer using an Ethernet cable.

Configure the management computer to be on the same subnet as the internal interface of the FortiAnalyzer unit:
o |P address: 192.168.1.X
» Netmask: 255.255.255.0

On the management computer, start a supported web browser and browse to https://192.168.1.99.

The login dialog box is displayed.

Type admin in the Name field, leave the Password field blank, and click Login.

The FortiAnalyzer Setup wizard is displayed.

Click Begin to start the setup process. See FortiAnalyzer Setup wizard on page 13.
The Later option is available for certain steps in the wizard, allowing you to postone steps. The Register with

FortiCare step cannot be skipped and must be completed before you can access the FortiAnalyzer appliance or VM.

If ADOMs are enabled, the Select an ADOM pane is displayed. Click an ADOM to select it.
The FortiAnalyzer home page is displayed.

Click a tile to go to that pane. For example, click the Device Manager tile to go to the Device Manager pane.
See also GUI overview on page 22.

FortiAnalyzer 7.4.0 Administration Guide
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Setting up FortiAnalyzer

If the network interfaces have been configured differently during installation, the URL
and/or permitted administrative access protocols (such as HTTPS) may no longer be in

their default state.

For information on enabling administrative access protocols and configuring IP addresses, see Configuring network
interfaces on page 282.

L}
‘9' If the URL is correct and you still cannot access the GUI, you may also need to configure static

routes. For details, see Static routes on page 284.

After logging in for the first time, you should create an administrator account for yourself and assign the Super_User
profile to it. Then you should log into the FortiAnalyzer unit by using the new administrator account. See Managing
administrator accounts on page 347 for information.

FortiAnalyzer Setup wizard

When you log in to FortiAnalyzer, the FortiAnalyzer Setup wizard is displayed to help you set up FortiAnalyzer by
performing the following actions:

« Registering with FortiCare and enabling FortiCare single sign-on

« Specifying the hostname

« Changing your password

» Upgrading firmware (when applicable)

You can choose whether to complete the wizard now or later.

Al
‘Q' The FortiAnalyzer Setup wizard requires that you complete the Register with FortiCare step

before you can access the FortiAnalyzer appliance or VM.

When actions are complete, a green checkmark displays beside them in the wizard, and the wizard no longer displays
after you log in to FortiAnalyzer.

FortiAnalyzer 7.4.0 Administration Guide
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Setting up FortiAnalyzer

FortiAnalyzer Setup - Welcome (1/4)

Welcome

Perform the following steps to complete the setup of this FortiAnalyzer.

1. Register and 550 with FortiCare

O Import the Entitlement File

2. Specify Hostname
3. Change Your Password

4. Upgrade Firmware

This topic describes how to use the FortiAnalyzer Setup wizard.

To use the FortiAnalyzer setup wizard:

1. Login to FortiAnalyzer.
The FortiAnalyzer Setup dialog box is displayed.
2. Click Begin to start the setup process now.
Alternately, click Later to postpone the setup tasks. Some tasks cannot be postponed.

3. When prompted, register with FortiCare and enable FortiCare single sign-on. You must complete the Register with
FortiCare step before you can access the FortiAnalyzer appliance or VM.

x When using FortiAnalyzer in an air-gapped environment, you must manually import your

Entitlement File. See Licensing in an air-gap environment on page 341.

FortiAnalyzer 7.4.0 Administration Guide 14
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Setting up FortiAnalyzer

FortiAnalyzer Setup - Register and SSO with FortiCare (2/4)

Register with FortiCare

Serial Number FAZVMTM22003795

Account ID/Email

Password

Register
Country/Region Click to select
Reseller Click to select

5SSO with FortiCloud

FortiCloud Single Sign-on @& @O

FortiAnalyzer 7.4.0 Administration Guide

Fortinet Inc.
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Setting up FortiAnalyzer

4. When prompted, specify the hostname.

FortiAnalyzer Setup

Specify Hostname

By default, this FortiManager will use the serial number/model as its hostname. It is
strongly recommended to set a descriptive hostname to make this device more identifiable.

Hostname FAZVME&4S

5. Inthe Hostname box, type a hostname.
6. Click Next.

FortiAnalyzer 7.4.0 Administration Guide
Fortinet Inc.
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Setting up FortiAnalyzer

7. When prompted, change your password.

FortiAnalyzer Setup

Change Your Password

This account is using the default password. You are required to change your password.
New Password sssssses ® @

Confirm Password sssssses ® @

4

a. Inthe New Password box, type the new password.
b. Inthe Confirm Password box, type the new password again.
c. Click Next.

8. When a new firmware version is available for your device on FortiGuard, the Upgrade Firmware option in the wizard
indicates that a new version is available, and you can click Next to upgrade to the new firmware, or Later to upgrade
later.

FortiAnalyzer 7.4.0 Administration Guide
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Setting up FortiAnalyzer

9. Complete the setup by clicking Finish.

FortiAnalyzer Setup

Setup Complete

The setup of this FortiAnalyzer is now complete. Click "Finish" to exit
this dialog.

[

You are logged in to FortiAnalyzer.

Activating VM licenses

If you are logging in to a FortiAnalyzer VM for the first time by using the GUI, you are required to activate a purchased
license or activate a trial license for the VM.

To activate a license for FortiAnalyzer VM:

1. On the management computer, start a supported web browser and browse to https://<ip address> forthe
FortiAnalyzer VM.
The login dialog box is displayed.

FortiAnalyzer 7.4.0 Administration Guide 18
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Setting up FortiAnalyzer

FortiAnalyzer-VMé4

This product requires a valid license. You could log in to FortiCloud
to activate your purchased license, or use a free trial license.

u Account ID/Email ‘

u Passworc

® Free Trial

O Activate License

Login with FortiCloud

Register with FortiCloud

Upload license

2. Take one of the following actions:

Action Description

Free Trial If a valid license is not associated with the account, you can start a free trial license.

1.
2,

3.

Select Free Trial, and click Login with FortiCloud.

Use your FortiCloud account credentials to log in, or create a new account.
FortiAnalyzer connects to FortiCloud to get the trial license. The system will restart to
apply the trial license.

Read and accept the license agreement.

For more information, see the FortiAnalyzer VM Trial License Guide.

Activate License If you have a license file, you can activate it .

1.
2,

Upload License 1.

Select Activate License, and click Login with FortiCloud.

Use your FortiCloud account credentials to log in.

FortiAnalyzer connects to FortiCloud, and the license agreement is displayed.
Read and accept the license agreement.

Click Browse to upload the license file, or drag it onto the field.
Click Upload. After the license file is uploaded, the system will restart to verify it. This
may take a few moments.

To download the license file, go to the Fortinet Technical Support site

ﬂ (https://support.fortinet.com/), and use your FortiCloud credentials to
log in. Go to Asset > Manage/View Products, then click the product
serial number.

FortiAnalyzer 7.4.0 Administration Guide
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Security considerations

You can take steps to prevent unauthorized access and restrict access to the GUI. This section includes the following
information:

« Restricting GUI access by trusted host on page 20
o Trusted platform module support on page 20
» Other security considerations on page 22

Restricting GUI access by trusted host

To prevent unauthorized access to the GUI you can configure administrator accounts with trusted hosts. With trusted
hosts configured, the administrator user can only log into the GUI when working on a computer with the trusted host as
defined in the administrator account. You can configure up to ten trusted hosts per administrator account. See
Administrators on page 346 for more details.

Trusted platform module support

On supported FortiAnalyzer hardware devices, the Trusted Platform Module (TPM) can be used to protect your
password and key against malicious software and phishing attacks. The dedicated module hardens the FortiAnalyzer by
generating, storing, and authenticating cryptographic keys.

For more information about which models feature TPM support, see the FortiAnalyzer Data Sheet.

By default, the TPM is disabled. To enable it, you must enable private-data-encryption and set the 32
hexadecimal digit master-encryption-password. This encrypts sensitive data on the FortiAnalyzer using AES128-CBC.
With the password, TPM generates a 2048-bit primary key to secure the master-encryption-password through RSA-
2048 encryption. The master-encryption-password protects the data. The primary key protects the master-encryption-
password.

The key is never displayed in the configuration file or the system CLI, thereby obscuring the information and leaving the
encrypted information in the TPM.

\ L}
S L4
? The TPM module does not encrypt the disk drive of eligible FortiAnalyzer.

The primary key binds the encrypted configuration file to a specific FortiAnalyzer unit and never leaves the TPM. When
backing up the configuration, the TPM uses the key to encrypt the master-encryption-password in the configuration file.
When restoring a configuration that includes a TPM protected master-encryption-password:

« If TPMis disabled, then the configuration cannot be restored.

« If TPMis enabled but has a different master-encryption-password than the configuration file, then the configuration
cannot be restored.

« If TPMis enabled and the master-encryption-password is the same in the configuration file, then the configuration
can be restored.

For information on backing up and restoring the configuration, see Backing up the system on page 46 and Restoring the
configuration on page 48.

FortiAnalyzer 7.4.0 Administration Guide 20
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Setting up FortiAnalyzer

The master-encryption-password is also required when migrating the configuration, regardless if TPM is available on the
other FortiAnalyzer model. For more information, see Migrating the configuration on page 48.

Passwords and keys that can be encrypted by the master-encryption-key include:

Admin password

Alert email user's password

BGP and other routing related configurations
External resource

FortiGuard proxy password
FortiToken/FortiToken Mobile’s seed

HA password

IPsec pre-shared key

Link Monitor, server side password

Local certificate's private key

Local, LDAP. RADIUS, FSSO, and other user category related passwords
Modem/PPPoE

NST password

NTP Password

SDN connector, server side password
SNMP

Wireless Security related password

A\,

‘Q' In HA configurations, each cluster member must use the same master-encryption-key so that
- the HA cluster can form and its members can synchronize their configurations.

To check if your FortiAnalyzer device has a TPM:

Enter the following command in the FortiAnalyzer CLI:

The outputin the CLl includes ### TPM info, which displays if the TPM is detected (enabled), not detected (disabled),

diagnose hardware info

or not available.

To enable TPM and input the master-encryption-password:

Enter the following command in the FortiAnalyzer CLI:

config system global
set private-data-encryption enable
end

Please type your private data encryption key (32 hexadecimal numbers):

khkhkhkhkhk kA hkkrhkhkrhkhkrhkhkhkhkhkhkxhkhkxkkxk

Please re-enter your private data encryption key (32 hexadecimal numbers)

R I b S b I b S b b b 2 I b S b S Sb b Sh b I 2h b S 3 3

Your private data encryption key is accepted.

FortiAnalyzer 7.4.0 Administration Guide
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Setting up FortiAnalyzer

Other security considerations

Other security consideration for restricting access to the FortiAnalyzer GUI include the following:

» Configure administrator accounts using a complex passphrase for local accounts
« Configure administrator accounts using RADIUS, LDAP, TACACS+, or PKI

Configure the administrator profile to only allow read/write permission as required and restrict access using read-
only or no permission to settings which are not applicable to that administrator

« Configure the administrator account to only allow access to specific ADOMs as required

When setting up FortiAnalyzer for the first time or after a factory reset, the password cannot be

NP left blank. You are required to set a password when the admin user tries to log in to
‘Q' FortiManager from GUI or CLI for the first time. This is applicable to a hardware device as well
as a VM. This is to ensure that administrators do not forget to set a password when setting up

FortiAnalyzer for the first time.
After the initial setup, you can set a blank password from System Settings > Administrators.

GUI overview

When you log into the FortiAnalyzer GUI, the Dashboard pane is displayed. The Dashboard contains widgets that
provide performance and status information. For more information about the Dashboard, see Dashboard on page 39

=% Enterprise_FortiAnalyzer

Dashboard

& Device Manager
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Use the navigation menu on the left to open another pane. The available panes vary depending on the privileges of the
current user.

Device Manager Add and manage devices and VDOMSs. See Device Manager on page 60.
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FortiView

Log View

Fabric View

Incidents & Events

Reports

Management Extensions

System Settings

The banner at the top of the screenis

The following options are available in

Menu

ADOM

CLI Console

Online Help

Notifications

FortiAnalyzer 7.4.0 Administration Guide
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Summarizes SOC information in FortiView and Monitors dashboards, which
include widgets displaying log data in graphical formats, network security, WiFi
security, and system performance in real-time.

This pane is not available when the unit is in Collector mode.

View logs for managed devices. You can display, download, import, and delete
logs on this page. You can also define custom views and create log groups. See
Log View and Log Quota Management on page 110.

Configure fabric connectors and playbook automation. Playbook automation
requires a FortiSoC subscription service. See Fabric View on page 135.

Configure and view events for logging devices. See Incidents & Events on page
175.

This pane is not available when the unit is in Collector mode.

Generate reports. You can also configure report templates, schedules, and output
profiles, and manage charts and datasets. See Reports on page 239.

This pane is not available when the unit is in Collector mode.

Enable and use management extension applications that are released and signed
by Fortinet. See Management Extensions on page 398.

Configure system settings such as network interfaces, administrators, system
time, server settings, and others. You can also perform maintenance and
firmware operations. See System Settings on page 281.

available in every pane.

the banner:

Click to toggle the visibility of the navigation menu on the left.

If ADOMs are enabled, the required ADOM can be selected from the dropdown
list.

The ADOMs available from the ADOM menu will vary depending on the privileges
of the current user.

Open the CLI console to configure the FortiAnalyzer unit using CLI commands
directly from the GUI, without making a separate SSH, or local console
connection to access the CLI.

For more information, see Using the CLI console on page 26.
Note: The CL/ Console requires that your web browser support JavaScript.

Click to open the FortiAnalyzer online help.

You can also open the FortiAnalyzer basic setup video
(https://video.fortinet.com/products/fortianalyzer/6.2/).

This option is context-sensitive, so it will open to the relevant documentation for
the pane you are in.

Click to display a list of notifications. Select a notification from the list to take
action on the issue.
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admin

Panes

From this dropdown, you can:
« view the current firmware build of your FortiAnalyzer device.

¢ upgrade the firmware.

¢ open the Process Monitor.

¢ change your password.

« update your profile information, including the avatar and theme.
¢ log out of the GUI.

In general, each pane four primary parts: the banner, toolbar, tree menu, and content pane.

Banner

Tree menu

Content pane

Toolbar

Along the top of the page.

The banner includes the device name (next to the Fortinet logo) and options to
open/close side menu, switch ADOMs (when enabled), open the CLI console,

view notifications, and access the admin menu. In some panes, further options
will be included in the banner.

On the left side of the screen. In some panes, further navigation will be available
as tabs along the top of the content pane. This additional horizontal menu can be
toggled to a vertical menu, if preferred.

Use this navigation menu to open panes in the GUI.

Contains widgets, lists, configuration options, or other information, depending on
the pane, menu, or options that are selected. Most management tasks are
handled in the content pane.

Directly above the content pane.

The toolbar includes options for managing content in the content pane, such as
Create New and Delete.

213 Enterprise_FortiAnalyzer

Dashboard
Device Manager

FortiView

Log View

Fabric View

Incidents & Events

mEeBamn6Ee

Reports S

Generated Reports

Report Definitions

Advanced Settings
= Management Extensions

& System Settings

FZERATINET

AllReports [T Chart Library | Macro Library | Datasets ']
HE D Search

O | Titles La... ¢ Description <
O ETemplate - 360 Protection Report en Present a brief summary of hardware/software inventory of the FortiGate devices over a 30 day period

[0 B&Template - 360 Security Report en Present a brief summary report about traffic, threat, app, user, incident, compromised host and so on.

O [ERTemplate - 360-Degree Security Review en Security review of Application Visibility and Control, Threat Detection, Data Exfiltration Detection, Endpoint Detection, |
[0 B#Template - Admin and System Events Report en Admin login and failed login attempts and system severity event counts.

[ B&Template - Application Risk and Control en Application risk, categories, bandwidth by app, web categories, vulnerability exploits, virus, botnet, adware malicious attz
[m} F&Template - Asset and Identity Report en Present a brief summary report on assets and their users, vulnerabilities, software installed as well as running processes.
[0 B#Template - Bandwidth and Applications Report | en Traffic, Bandwidth, Sessions, Destinations summaries - by users and applications

O  BETemplate - Client Reputation en Client and user network behaviour, incidents by user, devices, threat summary.

O ETemplate - Cyber Threat Assessment en Cyber Threat review of Application Visibility and Control, Threat Detection, Prevention and Recommended Actions.

0% 76
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Color themes

You can choose a color theme for the FortiAnalyzer GUI. For example, you can choose a color, such as blue or plum, or
you can choose an image, such as summer or autumn.

By default, all users are assigned the global color theme. To change the global color theme, see Global administration
settings on page 375.

To change your color theme:

1. Inthe banner, open the dropdown for your account and click Change Profile.
The Change Profile dialog displays.
2. Inthe Theme Mode field, select Use Own Theme.
3. Enable the High Contrast Theme or select a color them from the list.
Change Profile

B x

Change Avatar
Add files by drag & drop here or Add Files

Theme Mode Use Global Theme [USJeNIR iE Y
High Contrast Theme

Summer m Circuit Board i
| e

Ig

Side menu open or closed

After you choose a tile, such as Device Manager, you can close the side menu and view only the content pane.
Alternately you can view both the side menu and the content pane.

In the banner, click the Open/close side menu button to change between the views.

Switching between ADOMs

When ADOMs are enabled, you can move between ADOMs by selecting an ADOM from the ADOM button in the banner.
You are also prompted to select an ADOM when you log in.

ADOM:roct  >. @~ L2~ @Admin-

ADOM access is controlled by administrator accounts and the profile assigned to the administrator account. Depending

on your account privileges, you might not have access to all ADOMs. See Managing administrator accounts on page 347
for more information.

FortiAnalyzer 7.4.0 Administration Guide
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To switch ADOMs:

1. Inthe banner, click the ADOM button.
The Select an ADOM diaolog displays.
2. Click the ADOM to switch to.
The ADOM you are in displays on the ADOM button in the banner.

Using the right-click menu

Options are sometimes available using the right-click menu. Right-click an item in the content pane to display the menu
of available options. This menu often includes actions available in the toolbar, as well as some unique actions depending
on the pane and its content.

In the following example on the Reports pane, you can right-click a report, and select Edit, Clone, Delete, and more.

2% Enterprise_FortiAnalyzer =

@ Dashboard PXLTNS Templates | Chart Library | Macro Library | Datasets O
B Device Manager
a |u Run Report ‘ ‘1:,} Report v ‘ ‘E Folder v‘ ‘ § More v| O Show Scheduled Only Search
FortiView >
M Log View N m® | Tites Language = Cache Status =+ Time Period < Devices + Schedule + Output meu
@ Fabric View > O ©GWApplication
Incidents & Events > | O @WEDetailed User Report [ Edit
I B Reports v | O @ WFortiClient Report % Clone
el Reis O @ MEOutbreak Alert Reports 1 Delete
Report Definitions O olive ; Remove from Folder
= Disable Schedule
Advanced Settings O | B8360-Degree Security Review
88 Management Extensions + ssign to Folder
= © O EAdmin and System Events Rel 3 00
& System Settings N i i
O  EApplication Risk and Control | © Run Report Previous 7 Days All_FortiGate
[0 BsBandwidth and Applications § [# Rename Folder
O  BiClient Reputation Delete Folder This Week All Devices
c3
~  BiCyber Threat Assessment & Export Previous 7 Days All_FortiGate Weekly Monday @ 03:00 AM
[0  BaCyber-Bullying Indicators Report English
O  ESData Loss Prevention Detailed Report English
FiERTINET 0% 121

Using the CLI console

The CLI console is a terminal window that enables you to configure the FortiAnalyzer unit using CLI commands directly
from the GUI, without making a separate SSH, or local console connection to access the CLI.

When using the CLI console, you are logged in with the same administrator account that you used to access the GUI.
You can enter commands by typing them, or you can copy and paste commands into or out of the console.

For more information about using the CLI, see the FortiAnalyzer CLI Reference on the Fortinet Documents Library.

The CLI Console requires that your web browser support JavaScript.

To open the CLI console in the GUI, click the CLI Console icon (>_) in the banner.

You can perform the following actions from the top of the CLI Console:

FortiAnalyzer 7.4.0 Administration Guide
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Option Description

Clear Console Clear previous text in the console.

Copy History to Clipboard Copy all text in the console.

Record CLI Commands Begin recording the next commands entered in the console; click again to finish
recording. The commands and outputs from the recording are copied to the
clipboard.

Download History Download all text in the console as a text file.

Reconnect Console Reconnect to the console, clearing the previous text in the console and returning

to the initial prompt.

Run CLI Script Drag and drop or select a script file to run in the CLI.
Detach Open the console in a new tab.
CLI of Current Page (if Go to the commands for the current page of the GUI, if they are available.
available)
Minimize Minimize the console in the GUI.
Full screen Expand the console to full screen within the GUI.
Close Close the console.
Avatars

When FortiClient sends logs to FortiAnalyzer, an avatar for each user can be displayed in the Source column in the
FortiView and Log View panes. FortiAnalyzer can display an avatar when FortiClient is managed by FortiGate or
FortiClient EMS with logging to FortiAnalyzer enabled.

« When FortiClient Telemetry connects to FortiGate, FortiClient sends logs (including avatars) to FortiGate, and the
logs display in FortiAnalyzer under the FortiGate device as a sub-type of security.
The avatar is synchronized from FortiGate to FortiAnalyzer by using the FortiOS REST API.

o When FortiClient Telemetry connects to FortiClient EMS, FortiClient sends logs (including avatars) directly to
FortiAnalyzer, and logs display in a FortiClient ADOM.

If FortiAnalyzer cannot find the defined picture, a generic, gray avatar is displayed.

Al
‘Q' You can also optionally define an avatar for FortiAnalyzer administrators. See
- Creating administrators on page 348.

Using the Process Monitor

The Process Monitor displays running processes with their CPU and memory usage as well as their disk I/O levels.
Administrators can sort, filter, and terminate processes within the Process Monitor pane.

FortiAnalyzer 7.4.0 Administration Guide 27
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Process Monitor x

CPU Memory (Percentage) Memory (Bytes) Disk IO

N | OKilF Search...
PID < Command CPU < Memory &  State & RES ¢ VIRT & Disk Read = Disk Write =
10095 | /bin/python /usr+ | 20.5% 1.7% S 1347MB 1667 MB | 0 Kbps 0Kbps
1183 Jusr/bin/clickho+ 17.2% 8.3% S 6629MB | 51GB 0 Kbps 0Kbps
25030  postgres: postgr+ 6.6% 0.9% s 741MB 14GB 0 Kbps 0 Kbps
11937 | /bin/python /sbi+ 5.6% 0.2% S 124 MB 14.6 MB 0 Kbps 0Kbps
1144 /binfoftpd 2.3% 0.8% S 64.9 MB 4243 MB | 0 Kbps 0Kbps
1137 /bin/forticldd 2.0% 0.5% s 38.0MB 96.1MB 0 Kbps 0 Kbps
1140 /bin/logfwd 1.7% 0.5% S 38.7 MB 393.8MB | 0 Kbps 0Kbps
253 /binfcmdbsvr 1.3% 0.4% s 34.3MB 8%9.1 MB 0 Kbps 0 Kbps
752 /binfredis-serve+ 0.7% 0.1% s 11.9MB 57.7MB 0 Kbps 0 Kbps
1017 sve authd 0.7% 9.5% S 757.7MB | 891.6 MB | OKbps 0Kbps
1032 svc cmdb reader 0.7% 9.5% S 7552MB  891.3MB | OKbps 0 Kbps

0% 78

To use the Process Monitor:

1. Inthe banner, click fadmin_name] > Process Monitor.
Aline chart and a table view are available in the Process Monitor pane. Both the chart and the table refresh
automatically unless paused.

2. To change the line chart according to your needs, click CPU, Memory (Percentage), Memory (Bytes), or Disk I/O.
The table view will automatically sort by the selection as well.

3. To pause the chart and table from refreshing, click the pause button.
You can click the play button to resume the automatic refresh.

4. Use the search field to search for any field in the table view.
5. Toterminate a process, select it in the table view and click Kill Process.

Showing and hiding passwords

In some fields, you can show and hide information by clicking the toggle icon.

For example, see the image of the Change Password dialog below. In this example, the Old Password is toggled to show
the password. The other fields are toggled to hide the password.

Change Password | x
Old Password test ® @
New Password ® ®
Confirm Password ® ©
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Target audience and access level

This guide is intended for administrators with full privileges, who can access all panes in the FortiAnalyzer GUI, including
the System Settings pane.

In FortiAnalyzer, administrator privileges are controlled by administrator profiles. Administrators who are assigned
profiles with limited privileges might be unable to view some panes in the GUI and might be unable to perform some
tasks described in this guide. For more information about administrator profiles, see Administrator profiles on page 355.

s‘é’, If you logged in by using the admin administrator account, you have the Super_User

administrator profile, which is assigned to the admin account by default and gives the admin
administrator full privileges.

Initial setup

This topic provides an overview of the tasks that you need to do to get your FortiAnalyzer unit up and running.

To set up FortiAnalyzer:

1. Connect to the GUI. See Connecting to the GUI on page 12.
2. Configure the RAID level, if the FortiAnalyzer unit supports RAID. See Configuring the RAID level on page 299.
3. Configure network settings. See Configuring network interfaces on page 282.

\{ Once the IP address of the administrative port of FortiAnalyzer is changed, you will lose

connection to FortiAnalyzer. You will have to reconfigure the IP address of the
management computer to connect again to FortiAnalyzer and continue.

4. (Optional) Configure administrative domains. See Managing ADOMs on page 305.
5. Configure administrator accounts. See Managing administrator accounts on page 347.

x After you configure the administrator accounts for the FortiAnalyzer unit, you should log in

again by using your new administrator account.

6. Add devices to the FortiAnalyzer unit so that the devices can send logs to the FortiAnalyzer unit. See Adding
devices on page 64.

7. Configure the operation mode. See Configuring the operation mode on page 49 and Operation modes on page 31.

FortiManager features

FortiManager features are not available in FortiAnalyzer 6.2.0 and up.

For information about FortiManager, see the FortiManager Administration Guide.
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NP If FortiManager features are enabled in FortiAnalyzer before upgrading to 6.2.0 and later, the
‘Q' existing feature configurations will continue to be available after the upgrade.
- FortiManager features carried over during an upgrade can be disabled through the CLI
- console.
Next steps

Now that you have set up your FortiAnalyzer units and they have started receiving logs from the devices, you can start
monitoring and interpreting data. You can:

View log messages collected by the FortiAnalyzer unitin Log View. See Types of logs collected for each device on
page 110.

View multiple panes of network activity in FortiView > Monitors. See Monitors on page 92.
View summaries of threats, traffic, and more in FortiView . See FortiView on page 76.
Generate and view events in Incidents & Events. See Incidents & Events on page 175
Generate and view reports in Reports. See Reports on page 239.

Restarting and shutting down

Always use the operation options in the GUI or the CLI commands to reboot and shut down the FortiAnalyzer system to

avoid potential configuration problems.

See Restart, shut down, or reset FortiAnalyzer on page 58 in System Settings on page 281.
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This section provides information about basic FortiAnalyzer concepts and terms. If you are new to FortiAnalyzer, use this
section to quickly understand this document and the FortiAnalyzer platform.

This section includes the following sections:

o Operation modes on page 31

o Administrative domains on page 33
o Logsonpage 34

» Log storage on page 34

« FortiView dashboard on page 37

Operation modes

FortiAnalyzer can run in two operation modes: Analyzer and Collector. Choose the operation mode for your
FortiAnalyzer units based on your network topology and requirements.

Analyzer mode

Analyzer mode is the default mode that supports all FortiAnalyzer features. Use this mode to aggregate logs from one or
more Collectors.

FortiAnalyzer 7.4.0 Administration Guide
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The following diagram shows an example of deploying FortiAnalyzer in Analyzer mode.

FortiAnalyzer

l F I FortiGates |

ortiGates

Collector mode

When FortiAnalyzer is in Collector mode, its primary task is forwarding logs of the connected devices to an Analyzer and
archiving the logs. Instead of writing logs to the database, the Collector retains logs in their original binary format for
uploading. In this mode, most features are disabled.

Analyzer and Collector feature comparison

Feature Analyzer Mode Collector Mode
Device Manager Yes Yes
FortiView Yes No
FortiAnalyzer 7.4.0 Administration Guide 32
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Feature Analyzer Mode Collector Mode
Log View Yes Raw archive logs only
Incidents & Events Yes No
Monitoring devices Yes No
Reporting Yes No
System Settings Yes Yes
Log Forwarding Yes Yes

Analyzer—Collector collaboration

You can deploy Analyzer mode and Collector mode on different FortiAnalyzer units and make the units work together to
improve the overall performance of log receiving, analysis, and reporting. The Analyzer offloads the log receiving task to
the Collector so that the Analyzer can focus on data analysis and report generation. This maximizes the Collector’s log
receiving performance.

For an example of setting up Analyzer—Collector collaboration, see Collectors and Analyzers on page 395.

FortiAnalyzer Fabric

FortiAnalyzer can also join a FortiAnalyzer Fabric which enables centralized viewing of devices, incidents, and events
across multiple FortiAnalyzers acting as members.

The FortiAnalyzer Fabric is ideal for use in high volume environments with many FortiAnalyzers. For more information
about sizing and design considerations, see the FortiAnalyzer Architecture Guide.

In this mode, FortiAnalyzer Fabric members form a Fabric with one device operating in supervisor mode as the root
device. Incident, event, and log information is synced from members to the supervisor using the API.

See the FortiAnalyzer Fabric Deployment Guide for more information.

Administrative domains

Administrative domains (ADOMs) enable the admin administrator to constrain the access privileges of other
FortiAnalyzer unit administrators to a subset of devices in the device list. For Fortinet devices with virtual domains
(VDOMs), ADOMs can further restrict access to only data from a specific VDOM for a device.

Enabling ADOMs alters the available functions in the GUIl and CLI. Access to the functions depends on whether you are
logged in as the admin administrator. If you are logged in as the admin administrator, you can access all ADOMs. If you
are not logged in as the admin administrator, the settings in your administrator account determines access to ADOMs.

For information on enabling and disabling ADOMs, see Enabling and disabling the ADOM feature on page 304. For
information on working with ADOMSs, see Administrative Domains (ADOMs) on page 302. For information on configuring
administrator accounts, see Managing administrator accounts on page 347.
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M, ADOMs must be enabled to support FortiCarrier, FortiClient EMS, FortiMail, FortiWeb,
? FortiCache, and FortiSandbox logging and reporting. See Administrative Domains (ADOMSs)
3 on page 302.

Logs

Logs in FortiAnalyzer are in one of the following phases.

« Real-time log: Log entries that have just arrived and have not been added to the SQL database. These logs are
stored in Archive in an uncompressed file.

« Archive logs: When a real-time log file in Archive has been completely inserted, that file is compressed and
considered to be offline.

« Analytics logs or historical logs: Indexed in the SQL database and online.

In order for FortiAnalyzer to accept logs, the sending device must be registered in FortiAnalyzer. You can add devices to

FortiAnalyzer by specifying the serial number and other details, or you may point the device’s log settings to the
FortiAnalyzer. If initiated by the remote device, the device must be authorized before logs can be received on
FortiAnalyzer. See Adding devices on page 64.

For more information on the types of logs collected for each device, see Types of logs collected for each device on page

110.

Log encryption

Beginning in FortiAnalyzer 6.2, all logs from Fortinet devices (using Fortinet's proprietary protocol: OFTP) must be
encrypted. FortiAnalyzer encryption level must be equal or less than the sending device’s level. For example, when

configuring logging from a FortiGate, FortiAnalyzer must have the same encryption level or lower than FortiGate in order

to accept logs from FortiGate.

To configure the encryption level on FortiAnalyzer:
1. Inthe FortiAnalyzer CLlI, enter the following commands:

config system global
set enc-algorithm {high | low | medium}

To configure the encryption level on FortiGate:
1. Inthe FortiGate CLI, enter the following commands:

config log fortianalyzer setting
set enc-algorithm {high-medium | high | low}

See also Appendix B - Log Integrity and Secure Log Transfer on page 404.

Log storage

Logs and files are stored on the FortiAnalyzer disks. Logs are also temporarily stored in the SQL database.
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You can configure data policy and disk utilization settings for devices. These are collectively called log storage settings.

You can configure global log and file storage settings. These apply to all logs and files in the FortiAnalyzer system
regardless of log storage settings.

Log rolling

When FortiAnalyzer receives a log, it is stored in a file. Logs will continue to populate this file until its limit is reached, at
which time the file is "rolled" which involves compressing the file and creating a new one for further logs of that type.
There are two settings that you can use to configure when log rolling occurs, and both may be used at the same time,
with rolling taking place when either condition is met.

« Log file size: This is enabled by default and set to 200 MB.
« Atascheduled time: Either daily or weekly at a set time.

Rolling the files daily is recommended to avoid a file from spanning more than 24 hours and masking the actual amount
of days you are storing logs for.

See also Configuring rolling and uploading of logs using the GUI on page 336.

Log deletion

When you reach your archive retention limit as defined by allocated storage size or specified days, FortiAnalyzer deletes
old logs to make room for new logs. FortiAnalyzer can only delete files, not logs within a file. Controlling file growth is
important because storage capacity is not infinite and it directly affects how old logs are deleted to make room for new
logs.

FortiAnalyzer will delete old files based on which condition is forcing the deletion:

« Days: Delete the log file that contains logs which are all outside the configured day retention period. Log files can
span several days, or even months. When this is the case, the file will not be considered eligible for deletion when
logs that are within the configured retention days would be deleted. This can lead to Archive indicating it is storing
more days than it is configured for (for example, 100/90 days). This is due to the number displaying the oldest log
date, and not specifically that it has logs for each day up to that number.

» Storage size: Delete the log file with the oldest last received log. This can lead to the administrator not seeing the
true amount of logs in analytics since there's no way to indicate that there are no logs for days 60 through 89, only
that there are some logs from 90 days ago.

See also Data policy and automatic deletion on page 37 and Disk utilization for Archive and Analytic logs on page 37.

SQL database

FortiAnalyzer supports Structured Query Language (SQL) for logging and reporting. The log data is inserted into the
SQL database to support data analysis in FortiView, Log View, and Reports. Remote SQL databases are not supported.

For more information, see FortiView on page 76, Types of logs collected for each device on page 110, and Reports on
page 239.

The log storage settings define how much FortiAnalyzer disk space to use for the SQL database.
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\‘é’, When FortiAnalyzer is in Collector mode, the SQL database is disabled by default. If you want

to use logs that require SQL when FortiAnalyzer is in Collector mode, you must enable the
SQL database. See Operation modes on page 31.

Analytics and Archive logs

Logs in FortiAnalyzer are in one of the following phases.

« Real-time log: Log entries that have just arrived and have not been added to the SQL database. These logs are
stored in Archive in an uncompressed file.

« Archive logs: When a real-time log file in Archive has been completely inserted, that file is compressed and
considered to be offline.

» Analytics logs or historical logs: Indexed in the SQL database and online.
Use a data policy to control how long to retain Analytics and Archive logs.

« Archive logs on page 36
« Analytic logs on page 36

Archive logs

When FortiAnalyzer receives a log, it is stored in a file. Logs will continue to populate this file until its limit is reached, at
which time the file is "rolled" which involves compressing the file and creating a new one for further logs of that type.
These files (rollled or otherwise) count against the archive retention limits and are referred to as Archived or Offline logs.

You cannot immediately view details about these logs in the FortiView, Log View, and Incidents & Events panes. You
also cannot generate reports about the logs in the Reports pane.

Archive logs are stored unchanged and can be uploaded to a file server for use as backups.

« If you are using a FortiAnalyzer-VM, you may also choose to snapshot the data drive to backup your logs.

« If you are using a physical FortiAnalyzer which leverages RAID for storage, remember that RAID is not a backup
solution.

Log storage in Archive is important since it is used to rebuild the database in the event of database corruption, orin some
cases during upgrades.

Analytic logs
Immediately following the storage of a log in an archive, the same log is inserted into the SQL database. This function is
also known as being indexed, and these logs are referred to as Analytic or Online logs.

Analytic logs are the only logs which are used for analysis in FortiAnalyzerLog View (excluding Log Browse), Incidents
and Events, and Reports.

Analytic logs are dissected during insertion and any subtypes are stored as their own category. For example, security
profile logs such as web filtering logs are sent and stored as Traffic logs when archived, however, Analytics extracts the
relevant web filtering fields and stores them in a web filtering table.

Indexed logs take up significantly more space than the same amount of logs in Archive.
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Most administrators may need to store between 30 and 60 days in Analytics, however, this should be configured for the
amount of time that you would typically need to explore the logs for.

If you need to run analytics for dates outside your Analytics retention, you may perform a database rebuild and load the
particular date range. A database rebuild involves purging all logs from Analytics and loading logs for the days of interest
from Archive. Once analysis is complete, you can then rebuild once more to load the most current logs into analytics
from the archive.

Data policy and automatic deletion

Use a data policy to control how long to keep compressed and indexed logs. When ADOMs are enabled, you can specify

settings for each ADOM and the settings apply to all devices in that ADOM. When ADOMs are disabled, settings apply to
all managed devices.

A data policy specifies:

« How long to keep Analytics logs indexed in the database
When the specified length of time in the data policy expires, logs are automatically purged from the database but
remain compressed in a log file on the FortiAnalyzer disks.

» How long to keep Archive logs on the FortiAnalyzer disks
When the specified length of time in the data policy expires, Archive logs are deleted from the FortiAnalyzer disks.

See also Log storage information on page 130.

Disk utilization for Archive and Analytic logs

You can specify how much of the total available FortiAnalyzer disk space to use for log storage. You can specify what
ratio of the allotted storage space to use for logs that are indexed in the SQL database and for logs that are stored in a
compressed format on the FortiAnalyzer disks. Then you can monitor how quickly device logs are filling up the allotted
disk space.

Analytic logs indexed in the SQL database require more disk space than Archive logs (purged
‘\él, from the SQL database but remain compressed on the FortiAnalyzer disks).

An average Analytic log is 600 bytes, and an average Archive log is 80 bytes. By default, after
seven days Analytic logs are compressed and are an average of 150 bytes.

Keep this difference in mind when specifying the storage ratio for Analytics and Archive logs.

When ADOM s are enabled, you can specify settings for each ADOM and the settings apply to all devices in that ADOM.
When ADOMs are disabled, settings apply to all managed devices. See Log storage information on page 130.

FortiView dashboard

FortiAnalyzer provides dashboards for Security Operations Center (SOC) administrators. FortiView includes monitors
which enhance visualization for real-time activities and historical trends for analysts to effectively monitor network
activities and security alerts. See FortiView on page 75.
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In high capacity environments, the FortiView module can be disabled to improve performance. See Enabling and
disabling FortiView on page 109.
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The Dashboard contains widgets that provide performance and status information and enable you to configure basic
system settings.

Toggle Widget v

System Information @ ¥ I =v ||License Information e ¥ I =Ev
Host Name Enterprise_FortiAnalyzer BBVMS License ©VMS License wl+lla
Serial Number FAZVMSTM22003024 @ ADOM License © No License (0 Used / 5 Total) w
Platform Type FAZVM64-KVM @ FortiCloud @ Registered © Cloud Management =
HA Status Standalone © FortiGuard Indicators of Compromise Service @ Licensed (Expires 2023-06-04)
System Time Thu Mar 30 15:29:19 2023 PDT FortiAnalyzer Outbreak Detectio... @ Licensed (Expires 2023-06-04)
Firmware Version V7.4.0-build2183 230326 (Beta 1) Server Location 5 Servers located in US only <]
System Configuration Last Backup : N/A @ Security Operations Security Automation © Licensed (Expires 2023-06-04)
Current Administrators emorlang / 1 in total 2 Logging Devices/VDOMs 7/10,000 (0.1%)
Up Time 6 hours 29 minutes GB/Day @ 04/5(8.0%) [
Administrative Domain © & Storage Connector Service  Cloud @ No License w

Q Undate Server AntiVirus and IPS 208.184.237.66 (== Sunnwvale. California. United States)
System Resources & X I =v ||UnitOperation e X I =Ev
FORTINET FortiAnalyzer-VM64-KVM
12
41% 55% 8%
Average CPU Usage Memory Usage Disk Usage
More Details
Restart @ Shutdown

The following widgets are available:

Widget Description

System Information Displays basic information about the FortiAnalyzer system, such as up time and
firmware version. You can also enable or disable Administrative Domains and
adjust the operation mode. For more information, see System Information widget
on page 41.

From this widget you can manually update the FortiAnalyzer firmware to a
different release. For more information, see Updating the system firmware on
page 43.

The widget fields will vary based on how the FortiAnalyzer is configured, for
example, if ADOMs are enabled.

System Resources Displays the real-time and historical usage status of the CPU, memory and hard
disk. For more information, see System Resources widget on page 49.

License Information Displays whether the unit license is registered to FortiCloud, and if remote access
from FortiCloud is enabled.

Displays how many devices of the supported maximum are connected to the
FortiAnalyzer unit. See License Information widget on page 49.

From this widget you can purchase a license, add a license, or manually upload a
license for VM systems.
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Widget Description

Unit Operation Displays status and connection information for the ports of the FortiAnalyzer unit.
It also enables you to shutdown and restart the FortiAnalyzer unit or reformat a
hard disk. For more information, see Unit Operation widget on page 55.

Alert Message Console Displays log-based alert messages for both the FortiAnalyzer unit and connected
devices. For more information, see Alert Messages Console widget on page 55.

Log Receive Monitor Displays a real-time monitor of logs received. You can view data per device or per
log type. For more information, see Log Receive Monitor widget on page 56.

Insert Rate vs Receive Rate Displays the log insert and receive rates. For more information, see Insert Rate vs
Receive Rate widget on page 56.

The Insert Rate vs Receive Rate widget is hidden when the FortiAnalyzer is
operating in Collector mode, and the SQL database is disabled.

Log Insert Lag Time Displays how many seconds the database is behind in processing the logs. For
more information, see Log Insert Lag Time widget on page 57.

The Log Insert Lag Time widget is hidden when the FortiAnalyzer is operating in
Collector mode, and the SQL database is disabled.

Receive Rate vs Forwarding Displays the Receive Rate, which is the rate at which FortiAnalyzer is receiving

Rate logs. When log forwarding is configured, the widget also displays the log
forwarding rate for each configured server. For more information, see Receive
Rate vs Forwarding Rate widget on page 57.

Disk I/0 Displays the disk utilization, transaction rate, or throughput as a percentage over
time. For more information, see Disk I/0O widget on page 57.

Device widgets For example, widgets such as Connectivity, Disk Quota Usage, and Last Log
Received Within.
These widgets display summary information for authorized devices.
For more inforamtion, see Device widgets on page 58.

Customizing the dashboard

The FortiAnalyzer system dashboard can be customized. You can select which widgets to display, where they are
located on the page, and whether they are minimized or maximized. It can also be viewed in full screen by selecting the
full screen button on the far right side of the toolbar.

Action Steps

Move a widget Move the widget by clicking and dragging its title bar, then dropping it in its new location
Add a widget Select Toggle Widgets from the toolbar, then select the name widget you need to add.
Delete a widget Click the Close icon in the widget's title bar.
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Action Steps

Customize a widget For widgets with an edit icon, you can customize the widget by clicking the Edit icon and
configuring the settings.

Reset the Select Toggle Widgets > Reset to Default from the toolbar. The dashboards will be reset to the
dashboard default view.

System Information widget

The information displayed in the System Information widget is dependent on the FortiAnalyzer model and device
settings. The following information is available on this widget:

Host Name The identifying name assigned to this FortiAnalyzer unit. Click the edit host name
button to change the host name. For more information, see Changing the host
name on page 42.

Serial Number The serial number of the FortiAnalyzer unit. The serial number is unique to the
FortiAnalyzer unit and does not change with firmware upgrades. The serial
number is used for identification when connecting to the FortiGuard server.

Platform Type Displays the FortiAnalyzer platform type, for example FAZVM64 (virtual
machine).
HA Status Displays if FortiAnalyzer unit is in High Availability mode and whether it is the

Primary or Secondary unit in the HA cluster.

System Time The current time on the FortiAnalyzer internal clock. Click the edit system time
button to change system time settings. For more information, see Configuring the
system time on page 42.

Firmware Version The version number and build number of the firmware installed on the
FortiAnalyzer unit.
You can access the latest firmware version available on FortiGuard from
FortiAnalyzer.
Alternately you can manually download the latest firmware from the Customer
Service & Support website at https://support.fortinet.com. Click the update button,
then select the firmware image to load from the local hard disk or network volume.

For more information, see Updating the system firmware on page 43.

System Configuration The date of the last system configuration backup. The following actions are
available:

 Click the backup button to backup the system configuration to a file; see
Backing up the system on page 46.

 Click the restore to restore the configuration from a backup file; see
Restoring the configuration on page 48. You can also migrate the
configuration to a different FortiAnalyzer model by using the CLI. See
Migrating the configuration on page 48.
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Current Administrators The number of administrators currently logged in. Click the current session list
button to view the session details for all currently logged in administrators.

Up Time The duration of time the FortiAnalyzer unit has been running since it was last
started or restarted.

Administrative Domain Displays whether ADOMs are enabled. Toggle the switch to change the
Administrative Domain state. See Enabling and disabling the ADOM feature on
page 304.

Operation Mode Displays the current operation mode of the FortiAnalyzer. Click the other mode to
change to it. For more information on operation modes, see Operation modes on
page 31.

Changing the host name

The host name of the FortiAnalyzer unit is used in several places.

« lItappears in the System Information widget on the dashboard.
e ltis used in the command prompt of the CLI.
« ltis used as the SNMP system name.

The System Information widget and the get system status CLIcommand will display the full host name. However, if
the host name is longer than 16 characters, the CLI and other places display the host name in a truncated form ending
with a tilde ( ~ ) to indicate that additional characters exist, but are not displayed. For example, if the host name is
FortiAnalyzer1234567890, the CLI prompt would be FortiAnalyzer123456~#.

To change the host name:

1. Goto Dashboard.
2. Inthe System Information widget, click the edit host name button next to the Host Name field.
3. Inthe Host Name box, type a new host name.

The host name may be up to 35 characters in length. It may include US-ASCII letters, numbers, hyphens, and
underscores. Spaces and special characters are not allowed.

4. Click the checkmark to change the host name.

Configuring the system time

You can either manually set the FortiAnalyzer system time or configure the FortiAnalyzer unit to automatically keep its
system time correct by synchronizing with a Network Time Protocol (NTP) server.

Al
‘Q' For many features to work, including scheduling, logging, and SSL-dependent features, the
- FortiAnalyzer system time must be accurate.
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To configure the date and time:

1. Goto Dashboard.

2. Inthe System Information widget, click the edit system time button next to the System Time field.

3. Configure the following settings to either manually configure the system time, or to automatically synchronize the
FortiAnalyzer unit’s clock with an NTP server:

System Time

Time Zone

Update Time By

Set Time
Select Date

Select Time
Synchronize with NTP Server

Server

Min

Max

The date and time according to the FortiAnalyzer unit’s clock at the time that
this pane was loaded or when you last clicked the Refresh button.

Select the time zone in which the FortiAnalyzer unit is located and whether or
not the system automatically adjusts for daylight savings time.

Select Set time to manually set the time, or Synchronize with NTP Server to
automatically synchronize the time.

Manually set the data and time.

Set the date from the calendar or by manually entering it in the format:
YYYY/MM/DD.

Select the time.
Automatically synchronize the date and time.

Enter the IP address or domain name of an NTP server. Click the plus icon to
add more servers. To find an NTP server that you can use, go to
http://www.ntp.org.

Minimum poll interval in seconds as power of 2 (e.g. 6 means 64 seconds,
default = 6).

Maximum poll interval in seconds as power of 2 (e.g. 6 means 64 seconds,
default = 10).

4. Click the checkmark to apply your changes.

Updating the system firmware

To take advantage of the latest features and fixes, you can update FortiAnalyzer firmware. From the Dashboard menu in
FortiAnalyzer, you can access firmware images on FortiGuard and update FortiAnalyzer. Alternately you can manually
download the firmware image from the Customer Service & Support site, and then upload the image to FortiAnalyzer.

For information about upgrading your FortiAnalyzer device, see the FortiAnalyzer Upgrade Guide or contact Fortinet

Customer Service & Support.

Back up the configuration and database before changing the firmware of FortiAnalyzer.

A Changing the firmware to an older or incompatible version may reset the configuration and
database to the default values for that firmware version, resulting in data loss. For information
on backing up the configuration, see Backing up the system on page 46.

A\,

FortiAnalyzer unit with Customer Service & Support. For details, go to
https://support.fortinet.com/ or contact Customer Service & Support.

~ q, Before you can download firmware updates for FortiAnalyzer, you must first register your
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To update FortiAnalyzer firmware using FortiGuard:

1. Goto Dashboard.

2. Inthe System Information widget, beside Firmware Version, click Upgrade Firmware.
The Firmware Management dialog box opens.

Firmware Management M x

Current Version v7.4.0-build2177 230314 (Interim)
Upload Firmware

Add files by drag & drop here or Add Files

FortiGuard Firmware 7.2.2(1334) -
Backup Configuration o
Encryption [ ]

o PR

3. Before upgrading your firmware, you can choose to enable or disable Backup Configuration. When this setting is
enabled, you will automatically download a backup copy of your FortiAnalyzer configuration when performing a
firmware upgrade.

If you want to encrypt the backup file, enable Encryption, then type and confirm the password you want to use. The
password can be a maximum of 63 characters.

4. From the FortiGuard Firmware box, select the version of FortiAnalyzer for the upgrade, and click OK.
The FortiGuard Firmware box displays the FortiAnalyzer firmware images available for upgrade:

« When FortiAnalyzer has a valid contract, all available firmware versions are displayed for upgrading or
downgrading.

« When FortiAnalyzer has no valid contract, or the contract is expired, only display the available patch upgrades.
« A green checkmark displays beside the recommended image for FortiAnalyzer upgrade.
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Firmware Management

Current Version v7.4.0-build2177 230314 {Interim)

Upload Firmware

Add files by drag & drop here or Add Files

FortiGuard Firmware 7.2.2 (1334)
Backup Configuration Q
Encryption
v 7.2.2(1334)
7.2.1{1215)
7.2.0(1124)
7.0.4 (306)
7.0.3 (254)
7.0.2 (180)

6.4.10 (2549)

6.4.9 (2513)

« If you select an image without a green checkmark, a confirmation dialog box is displayed. Click OK to continue.

Firmware Download

Upgrade to selected firmware version is not recommended, would you like to continue?

« FortiAnalyzer downloads the firmware image from FortiGuard.

Firmware Management

Downloading the selected image file...

Total: 1/1, © Pending: 1, <™* In Progress: 0, @
Completed: 0

] o

Index MName Status Time Used History

r

« FortiAnalyzer uses the downloaded image to update its firmware, and then restarts.
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Firmware Management

i.» The image has been uploaded successfully and the system is restarting. Please wait for a
few moments.

« After FortiAnalyzer restarts, the upgrade is complete.

To manually update FortiAnalyzer firmware:

1. Download the firmware (the . out file) from the Customer Service & Support website, https://support.fortinet.com/.

2. Goto Dashboard.

3. Inthe System Information widget, in the Firmware Version field, click Upgrade Firmware. The Firmware Upload
dialog box opens.

4. Before upgrading your firmware, you can choose to enable or disable Backup Configuration. When this setting is

enabled, you will automatically download a backup copy of your FortiAnalyzer configuration when performing a
firmware upgrade.

If you want to encrypt the backup file, enable Encryption, then type and confirm the password you want to use. The
password can be a maximum of 63 characters.

5. Drag and drop the file onto the dialog box, or click Browse to locate the firmware package (. out file) that you
downloaded from the Customer Service & Support portal and then click Open.

6. Click OK. Your device will upload the firmware image and you will receive a confirmation message noting that the
upgrade was successful.

. Optionally, you can upgrade firmware stored on an FTP or TFTP server using the following
sy

S CLI command:
q execute restore image {ftp | tftp} <file path to server> <IP of
- server> <username on server> <password>

For more information, see the FortiAnalyzer CLI Reference.

7. Refresh the browser and log back into the device.
8. Go to Device Manager module and make sure that all formerly added devices are still listed.
9. Open the other functional modules and make sure they work properly.

Backing up the system

Fortinet recommends that you back up your FortiAnalyzer configuration to your management computer on a regular
basis to ensure that, should the system fail, you can quickly get the system back to its original state with minimal affect to
the network. You should also back up your configuration after making any changes to the FortiAnalyzer configuration or
settings that affect connected devices.

Fortinet recommends backing up all configuration settings from your FortiAnalyzer unit before upgrading the
FortiAnalyzer firmware. See Updating the system firmware on page 43.
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An MD5 checksum is automatically generated in the event log when backing up the configuration. You can verify a
backup by comparing the checksum in the log entry with that of the backup file.

To back up the FortiAnalyzer configuration:

1.
2,

Go to Dashboard.

In the System Information widget, click the backup button next to System Configuration. The Backup System dialog
box opens

If you want to encrypt the backup file, select the Encryption box, then type and confirm the password you want to

use. The password can be a maximum of 63 characters.
Select OK and save the backup file on your management computer.

Configuring automatic backups

You can configure FortiAnalyzer to automatically backup your configuration on a set schedule. This feature can only be
configured through the CLI.

To schedule automatic backup of the FortiAnalyzer configuration:

1.

In the FortiAnalyzer CLI, enter the following command:
config system backup all-settings

2. Configure the backup settings:

set
set
set
set
set
set
set
set
set
end

status {enable | disable}

server {<ipv4 address>|<fqgdn str>}

user <username>

directory <string>

week days {monday tuesday wednesday thursday friday saturday sunday}
time <hh:mm:ss>

protocol {ftp | scp | sftp}

passwd <passwd>

crptpasswd <passwd>

For example, the following configuration uses the FTP protocol to backup the configuration to server 172.20.120.11 in
the /usr/local/backup directory every Monday at 1:00pm.

config
set
set
set
set
set
set
set

end

system backup all-settings
status enable

server 172.20.120.11

user admin

directory /usr/local/backup
week days monday

time 13:00:00

protocol ftp

For more information, see the FortiAnalyzer CLI| Reference Guide on the Fortinet Documents Library.

To find the MD5 checksum generated with the backup:

1. Inthe GUI, go to System Settings > Event Log.
2. Inthe Changes column for the event log, note the MD5 checksum.
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Restoring the configuration

You can use the following procedure to restore your FortiAnalyzer configuration from a backup file on your management
computer.

To restore the FortiAnalyzer configuration:

1. Goto Dashboard.

2. Inthe System Information widget, click the restore button next to System Configuration. The Restore System dialog
box opens.

3. Configure the following settings then select OK.

Choose Backup File Select Browse to find the configuration backup file you want to restore, or drag
and drop the file onto the dialog box.

Password Type the encryption password, if applicable.

Overwrite current IP and Select the checkbox to overwrite the current IP and routing settings.

routing settings

Migrating the configuration
You can back up the system of one FortiAnalyzer model, and then use the CLI and the FTP, SCP, or SFTP protocol to
migrate the settings to another FortiAnalyzer model.

If you encrypted the FortiAnalyzer configuration file when you created it, you need the password to decrypt the
configuration file when you migrate the file to another FortiAnalyzer model.

N ! /., The execute migrate all-settingscommand migrates all configurations except the
q CLI system settings. These system settings must be manually copied from the original
3 FortiAnalyzer model to the other FortiAnalyzer model.

To migrate the FortiAnalyzer configuration:

In the original FortiAnalyzer model, go to Dashboard.
Back up the system. See Backing up the system on page 46.
In the other FortiAnalyzer model, go to Dashboard.

If the configuration file is for multiple ADOMs, enable Administrative Domains in the System Information widget
before migrating.

o bN-=

5. Open the CLI Console, and enter the following command:

execute migrate all-settings <ftp | scp | sftp> <server> <filepath> <user> <password>
[cryptpasswd]

6. After migrating, update the CLI system settings, as needed.
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Configuring the operation mode

The FortiAnalyzer unit has two operation modes: Analyzer and Collector. For more information, see Operation modes on
page 31.

When FortiAnalyzer is operating in Collector mode, the SQL database is disabled by default so logs that require the SQL
database are not available in Collector mode unless the SQL database is enabled.

To change the operation mode:

1. Goto Dashboard.
2. Inthe System Information widget, select Analyzer or Collectorin the Operation Mode field
3. Click OKin the confirmation dialog box to change the operation mode.

System Resources widget

The System Resources widget displays the usage status of the CPUs, memory, and hard disk. You can view system
resource information in real-time or historical format, as well as average or individual CPU usage.

On VMs, warning messages are displayed if the amount of memory or the number of CPUs assigned are too low, or if the
allocated hard drive space is less than the licensed amount. These warnings are also shown in the notification list (see
GUI overview on page 22). Clicking on a warning opens the FortiAnalyzer VM Install Guide.

To toggle between real-time and historical data, click Edit in the widget toolbar, select Historical or Real-time, edit the
other settings as required, then click OK.

To view individual CPU usage, from the Real-Time display, click on the CPU chart. To go back to the standard view, click
the chart again.

License Information widget

The License Information widget displays the number of devices connected to the FortiAnalyzer.
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License Information

© VMS License

© Not Licensed (0 Used / 5 Total)
© Registered

© Cloud Management

@ Expiring in 27 days
@ Licensed (Expires 2023-06-04)

on @ Expiring in 27 days

Not Licensed (Trial)
Not Licensed (Trial)

=5 Servers located in US only

7 /10,000 (0.1%)
0.1/5(2.0%)

Not Licensed (Trial)

(& Sunnyvale, California, United States)

(& Sunnyvale, California, United States)

VMS License

ADOM License

FortiCloud

FortiGuard
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VM license information and status.

Click the Add License button to log in to FortiCloud and activate an add-on
license. See Activating add-on licenses on page 53.

Click the Upload License button to upload a new VM license file.

This field is only visible for FortiAnalyzer VM.

The Duplicate status appears when users try to upload a license that is already in
use. Additionally, the following message will be displayed in the Notifications:
Duplicate License has been found! Your VM license will expire in XX hours (Grace
time: 24 hours)

Users will have 24 hours to upload a valid license before the duplicate license is
blocked.

ADOM license information and status.
For Hardware models, the default number of ADOMs can be found in the Release
Notes on docs.fortinet.com.

For FortiAnalyzer-VM Subscription licenses, 5 ADOMs are included. They are
non-stackable. Additional ADOMs can be purchased with an ADOM subscription
license.

License registration status with FortiCloud. Displays Not Registered or
Registered.

When FortiCloud displays Not Registered, a Register Now link is available. You
can click the Register Now link to register the device or VM license with
FortiCloud. See Registering with FortiCloud on page 51.

If registered, you can enable/disable remote access from FortiCloud. See
Enabling remote access from FortiCloud on page 52

The license status.

Click the purchase button to go to the Fortinet Customer Service & Support
website, where you can purchase a license.
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FortiAnalyzer The license status. For more information, see Outbreak Alerts on page 237.
Outbreak Detection

Service

Security The license status.

Automation Click the purchase button to go to the Fortinet Customer Service & Support

website, where you can purchase a license.

Industrial Security  The license status.

Service Click the purchase button to go to the Fortinet Customer Service & Support
website, where you can purchase a license.

Security Rating The license status.

Update Click the purchase button to go to the Fortinet Customer Service & Support
website, where you can purchase a license.

Secure DNS Server The SDNS server license status.
Click the upload image button to upload a license key.

Server Location The locations of the FortiGuard servers, either global or US only.

Click the edit icon to adjust the location. Changing the server location will cause
the FortiAnalyzer to reboot.

Security Operations The license status.
Logging

Device/VDOMs The total number of devices and VDOMs connected to the FortiAnalyzer and the
total number of device and VDOM licenses.

GB/Day The gigabytes per day of logs allowed and used for this FortiAnalyzer. Click the
show details button to view the GB per day of logs used for the previous 6 days.

The GB/Day log volume can be viewed per ADOM through the CLI using:
diagnose fortilogd logvol-adom <name>.

Storage Connector Service The cloud storage license status.

Displays usage statistics as well as the license expiration date when a valid
license is present.

Click the purchase button to go to the Fortinet Customer Service & Support
website, where you can purchase a license.

Update Server
AntiVirus and IPS The IP address and physical location of the Antivirus and IPS update server.

Web and Email The IP address and physical location of the web and email filter update server.
Filter

FortiClient Update The IP address and physical location of the FortiClient update server.

Registering with FortiCloud

Register your device with FortiCloud to receive customer services, such as firmware updates and customer support.
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ﬂ To view a list of registered devices, go to the Fortinet Technical Support site
I (https://support.fortinet.com/), and use your FortiCloud credentials to log in. Go to Asset >
Manage/View Products.

See also Activating VM licenses on page 18.

To register a FortiAnalyzer device:

1. Goto Dashboard.

2. Inthe License Information widget, click Register Now for FortiCloud.
The registration dialog opens.

3. Enter the device details.
4. Click OK. FortiAnalyzer connects to FortiCloud and registers the device.
A confirmation message appears at the top of the content pane, and the Status field changes to Registered.

Enabling remote access from FortiCloud

Enable remote access to your device from FortiCloud.

The device must be registered with FortiCloud to enable remote access.

You cannot enable remote access from FortiCloud if the FortiAnalyzer is managed by a
FortiManager. You must disable the management before enabling remote access.
For a FortiAnalyzer high availability (HA) cluster, only the primary unit needs to register and enable remote access from
FortiCloud.

To enable remote access from FortiCloud using the GUI:

1. Goto Dashboard.

2. Inthe License Information widget, click the edit icon for FortiCloud.
The Cloud Management dialog opens.

d

Enable Cloud Management.
4. Inthe Password field, type the password for the FortiCloud account.

The Serial Number and FortiCloud Account ID/Email are automatically populated.
5. Click OK.

To enable remote access from FortiCloud using the CLI:

1. Enter the following command to set central management to cloud-management:
config system central-management
set type cloud-management

Ifthe central management typeis setto fortimanager (default) or none, remote access from FortiCloud will
be disabled.

2. Enter the following command to log in to FortiCloud:
execute cloud-remote-access login <id> <password> <domain> <email confirm>
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Activating add-on licenses

If you have purchased an add-on license and have a FortiCloud account, you can use the License Information widget to
activate an add-on license. You will need the contract registration code to activate the license.

After you enter the contract registration code for the license, FortiAnalyzer communicates with FortiCloud to activate the
license.

To purchase a new license:

1. Go to the Fortinet Technical Support site at https://support.fortinet.com/.
2. Login by using your FortiCloud account credentials.
3. Purchase a license.
You will receive an email from Fortinet with a PDF attachment that includes a contract registration code.

To add a license:

1. Goto Dashboard.

2. Inthe License Information widget, beside the VM License option, click the Add License button.
The Add License dialog box is displayed.

3. Complete the following options, and click OK:
a. Inthe Account ID/Email box, type the email for your FortiCloud account.
b. Inthe Password box, type the password for your FortiCloud account.

c. Inthe Registration Code box, enter the contract registration code for the add-on license.
The License Agreement is displayed.
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License Agreement

@

Q

4 1 of9 — | 4+ Automatic Zoom v L= I |

SERATINET

Fortinet Service Terms & Conditions
For FortiCare, FortiGuard and other Fortinet Service Offerings

THESE TERMS AND CONDITIONS APPLY TO THE PROVISION OF SERVICES BY FORTINET AND EXCLUSIVELY GOVERN THE LEGAL
RELATIONSHIP BETWEEN YOU (THE “CUSTOMER”) AND FORTINET. IT SETS FORTH THE LEGALLY BINDING RIGHTS AND OBLIGATIONS
OF THE CUSTOMER IN RELATION TO FORTICARE SUPPORT OR FORTIGUARD SUBSCRIPTION SERVICES OR OTHER FORTINET SERVICE
OFFERINGS. THE CUSTOMER CONSENTS TO BE BOUND BY THESE TERMS AND CONDITIONS (THE “AGREEMENT"”). THE CUSTOMER
REPRESENTS THAT IT IS A SOPHISTICATED ENTITY, THAT HAS READ AND UNDERSTANDS THIS AGREEMENT AND HAS HAD SUFFICIENT
QOPPORTUNITY TO CONSULT WITH COUNSEL BEFORE AGREEING TO THE TERMS HEREIN. IF THE CUSTOMER DOES NOT AGREE TO THE
TERMS, THE CUSTOMER SHOULD NOT ACCEPT THE AGREEMENT AND SHOULD CONTACT LEGAL@FORTINET.COM TO REQUEST
CHANGES TO THE AGREEMENT. THE CUSTOMER AGREES THAT ANY OF THE FOLLOWING ACTIONS BY CUSTOMER REPRESENTATIVES
REPRESENT THE CUSTOMER’S AUTHORIZED CONSENT TO BE BOUND BY THIS AGREEMENT: (I) RECEIVING, DOWNLOADING,
DEPLOYING OR USING ANY SOFTWARE PROVIDED IN CONNECTION WITH FORTINET SERVICES, (Il) RECEIVING, CONFIGURING,
LOGGING IN, REGISTERING OR OTHERWISE USING OR BENEFITTING FROM THE SERVICES, OR (lll) BY CLICKING ON THE “ACCEPT”
BUTTON UPON REGISTRATION (ANY OF (1), (I1), OR (1ll) SHALL CONSTITUTE “ACCEPTANCE” BY CUSTOMER). THE CUSTOMER HEREBY
ACKNOWLEDGES AND AGREES THAT THE PERSON ENGAGING IN (1), (I1), AND/OR (Ill) IS AUTHORIZED TO BIND THE CUSTOMER TO
THE TERMS HEREIN. FOR CLARITY, NOTWITHSTANDING ANYTHING TO THE CONTRARY, IF CUSTOMER IS USING AN
AUTOREGISTRATION TOOL OR HAS ENGAGED A FORTIPARTNER OR FORTINET TO REGISTER THE SERVICE CONTRACT ON ITS BEHALF,
CUSTOMER ACKNOWLEDGES AND AGREES THAT ANY AND ALL UNITS REGISTERED USING SUCH TOOL SHALL BE SUBJECT TO THIS
AGREEMENT.

Services are available independently or in connection with the purchase of Fortinet's commercial networking products and related
equipment, including Hardware products with embedded Software, and stand-alone Software products sold and licensed to
Customer  pursuant to Fortinet's End User License Agreement ("EULA"), which EULA is available at
https://www fortinet.com/content/dam/fortinet/assets/legal /EULA.pdf, and Customer hereby agrees to the terms of the EULA.

This Agreement constitutes a legal agreement between the parties with respect to FortiCare and FortiGuard Subscription services or
other Services, and shall supersede all prior representations, discussions, negotiations and agreements, whether written or oral.
Notwithstanding anything to the contrary, Fortinet is only bound by, and Customer is only entitled to, services pursuant to official
service descriptions that are authorized by Fortinet pursuant to this Agreement and are contractually binding on Fortinet pursuant
to the terms herein

11 have read and accept the terms in the License Agreement.

L

OK

4. Accept the license agreement:
a. Read the license agreement.
b. Selectthe | have read and accept the terms in the License Agreement checkbox.
c. Click OK.
The Restart Device dialog box is displayed.

Restart Device

This device must restart to apply the new license. Would you like to restart now?

Restart N Restart Later

5. Click Restart Now to apply the license.
FortiAnalyzer restarts, and the license is applied.

6. Go to Dashboard > License Information widget.
The VM License option displays Valid <license name>.
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Unit Operation widget

The Unit Operation widget graphically displays the status of each port. The port name indicates its status by its color.
Green indicates the port is connected. Grey indicates there is no connection.

Hover the cursor over the ports to view a pop-up that displays the full name of the interface, the IP address and netmask,
the link status, the speed of the interface, and the amounts of sent and received data.
Unit Operation e X I =v
FORTINET VM6V
oo

sent 71MB
Received 1512 MB

3¢ Restart @ shutdown

Alert Messages Console widget

The Alert Message Console widget displays log-based alert messages for both the FortiAnalyzer unit itself and
connected devices.

Alert messages help you track system events on your FortiAnalyzer unit such as firmware changes, and network events
such as detected attacks. Each message shows the date and time the event occurred.

S L 4
Alert messages can also be delivered by email, syslog, or SNMP.

-—

=
Alert Message Console B e ¥ I =Ev
Message <]
Mar 30, 11:56:49 fgfm connection to device Enterprise_Second_Floor is up
Mar 30, 11:56:49 fgfm connection to device Enterprise_First_Floor is up
Mar 30, 11:56:49 fgfm connection to device Enterprise_Second_Floor is down
Mar 30, 11:56:49 fgfm connection to device Enterprise_First_Floor is down
Mar 30, 11:52:22 fgfm connection to device Enterprise_First_Floor is up
Mar 30, 11:52:21 fgfm connection to device Enterprise_First_Floor is down
Mar 30, 11:52:21 Device Enterprise_First_Floor add succeeded

Mar 30, 11:52:20 fgfm connection to device Enterprise_Second_Floor is up

0% 10

Click Edit from the widget toolbar to view the Alert Message Console Settings, where you can adjust the number of
entries that are visible in the widget, and the refresh interval.

To view a complete list of alert messages, click Show More from the widget toolbar. The widget will show the complete
list of alerts. To clear the list, click Delete All Messages. Click Show Less to return to the previous view.
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Log Receive Monitor widget

The Log Receive Monitor widget displays the rate at which the FortiAnalyzer unit receives logs over time. Log data can
be displayed by either log type or device.

Hover the cursor over a point on the graph to see the exact number of logs that were received at a specific time. Click the
name of a device or log type to add or remove it from the graph. Click Edit in the widget toolbar to modify the widget's
settings.

Log Receive Monitor e X I =v

Average Rate (42.333 Logs/Sec)

FAZVMSTM22003024

-O- FGVM02TM22015042 other -O- FGVM010000166969 Branch_Office 01 Branch_Office_02 FAZVMSTM22003024

Insert Rate vs Receive Rate widget

The Insert Rate vs Receive Rate widget displays the log insert and log receive rates over time.

» Log receive rate: how many logs are being received.
» Loginsert rate: how many logs are being actively inserted into the database.

If the log insert rate is higher than the log receive rate, then the database is rebuilding. The lag is the number of logs
waiting to be inserted.

Hover the cursor over a point on the graph to see the exact number of logs that were received and inserted at a specific
time. Click Receive Rate or Insert Rate to remove those data from the graph. Click the edit icon in the widget toolbar to
adjust the time interval shown on the graph and the refresh interval.

Receive Rate e ¥ I =v

database is disabled.

x This widget is hidden when FortiAnalyzer is operating in Collector mode, and the SQL
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Log Insert Lag Time widget

The Log Insert Lag Time widget displays how many seconds the database is behind in processing the logs.

Click the edit icon in the widget toolbar to adjust the time interval shown on the graph and the refresh interval (0 to
disable) of the widget.

x This widget is hidden when FortiAnalyzer is operating in Collector mode, and the SQL

database is disabled.

Receive Rate vs Forwarding Rate widget

The Receive Rate vs Forwarding Rate widget displays the rate at which the FortiAnalyzer is receiving logs. When log
forwarding is configured, the widget also displays the log forwarding rate for each configured server.

Click the edit icon in the widget toolbar to adjust the time period shown on the graph and the refresh interval, if any, of the
widget.

i | 2022-03-3015:1834 |
i | ®ReceiveRate 48

Disk I1/O widget

The Disk I/0 widget shows the disk utilization (%), transaction rate (requests/s), or throughput (KB/s), versus time.

Click the edit icon in the widget toolbar to select which chart is displayed, the time period shown on the graph, and the
refresh interval (if any) of the chart.
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Device widgets

The following widgets in the Dashboard provide a summary of the devices that are added and authorized in the
FortiAnalyzer. These widgets link to other panes in the GUI, which provide more detailed information.
Click one of the following widgets to open Device Manager. For more information, see Device Manager on page 60
e Log Status
» Disk Quota Usage
e LastLog Time

Restart, shut down, or reset FortiAnalyzer

Always use the operation options in the GUI or the CLI commands to reboot and shut down the FortiAnalyzer system to
avoid potential configuration problems.

Restarting FortiAnalyzer

To restart the FortiAnalyzer unit from the GUI:

1. Goto Dashboard.
2. Inthe Unit Operation widget, click the Restart button.
3. Enter a message for the event log, then click OK to restart the system.

To restart the FortiAnalyzer unit from the CLI:

1. From the CLI, or in the CLI/ Console menu, enter the following command:
execute reboot

The system will be rebooted.
Do you want to continue? (y/n)

2. Enter yto continue. The FortiAnalyzer system will restart.
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Shutting down FortiAnalyzer

To shutdown the FortiAnalyzer unit from the GUI:

1. Goto Dashboard.
2. Inthe Unit Operation widget, click the Shutdown button.
3. Enter a message for the event log, then click OK to shutdown the system.

To shutdown the FortiAnalyzer unit from the CLI:
1. From the CLI, or in the CLI/ Console menu, enter the following command:
execute shutdown

The system will be halted.
Do you want to continue? (y/n)

2. Enter y to continue. The FortiAnalyzer system will shutdown.

Resetting system settings
FortiAnalyzer settings can be reset to factory defaults using the CLI.

To reset settings to factory defaults:

1. From the CLI, or in the CLI/ Console menu, enter the following command:
execute reset {adom-settings | all-except ip | all-settings | all-shutdown}

Variable Description

adom-settings <adom> Reset an ADOM's settings.
<version> <mr> <ostype> ¢ <adom>: The ADOM name.
e <version>: The ADOM version.
e <mr>: The major release number.
e <ostype>: Supported OS type.

all-except-ip Reset all settings except the current IP address and route information.
all-settings Reset to factory default settings.
all-shutdown Reset all settings and shutdown.

2. Enter y to continue. The device will reset settings based on the type of reset performed.
For example, execute reset all-settings will reset all FortiAnalyzer to factory defaults.
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Use the Device Manager pane to add, configure, and manage devices and VDOMs.

After you add and authorize a device or VDOM, the FortiAnalyzer unit starts collecting logs from that device or VDOM.
You can configure the FortiAnalyzer unit to forward logs to another device. See Log Forwarding on page 315.

You can toggle between a Table View and Map View from the toolbar in Device Manager.

Table View:

215 Enterprise_FortiAnalyzer = @ AddDevice g Device Group v

@ Dashboard =
F | Search. Q Connectivity Disk Quot.. Last Log R...
Device Manager " " — — —

o

& Fordvi R mUp o M Ente... () W15 Min.. @

ortiview * | Unauthorized Devices W Unknown @) et @D m30Mn. @

M LogView > 7 W Ente... D E1lHour @

Devices
Fabric View > got.. @ @ity @
mun.. D B 1+ Days

Incidents & Events > °

B Reports >

& System Settings > ME B Delete | [ @ Table View v © Show Charts ~ | | Search
a Device Name = IP Address = Platform < HA Status < Description < Firmware Version <
[m} @ Enterprise_FortiMail 10.100.88.4  FortiMail-vM FortiMail 6.6 F
a @ Enterprise_FortiSandbo; 10.100.88.13 FortiSandbox-VM FortiSandbox 6.6 F
O v fabric
a @ Branch_Office_01 10.1.0.1 FortiGate-VM64-... FortiGate 7.2.4,build1396 (GA) F
a @ Branch_Office_02 10.2.0.1 FortiGate-VM64-... FortiGate 7.2 4,build1396 (GA) F
a @ Enterprise_Core” 10.100.88.1 FortiGate-VM64-... FortiGate 7.2.4,build1396 (GA) F
a @ Enterprise_First_Floc 10.100.88.1C FortiGate-VMé4-... FortiGate 7.2.4,build1396 (GA) F
a @ Enterprise_Second_F 10.100.88.1C FortiGate-VMé4-... FortiGate 7.2.4,build1396 (GA) F

FIEATINET

Three donut charts display above the list of authorized devices:

» Connectivity
» Disk Quota Usage
» LastLog Received Within

By default, the Show Charts toggle is enabled. You can select which charts appear by selecting them in the Show Charts
dropdown, or you can hide all the charts by disabling the Show Charts toggle.

Mouse over the charts to see more information in a tooltip. Click a section of a chart to filter the charts and the table by
that information. You can apply multiple filters across the charts. Once filtered, a filter icon appears next to the chart title;
click the filter icon to remove the filter.

If you create a custom device group, it appears in the Device & Groups tree menu. Select the device group to display
information about those devices.

The Device Manager table view includes the following default columns for authorized devices:

Column Description

Device Name Displays the name of the device.

Serial Number Displays the serial number of the device. The serial number is unique to the unit
and does not change with firmware upgrades.

Platform Displays the platform for the device.
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Column Description

Firmware Version Displays the firmware version of the device.
IP Address Displays the IP address for the device.
Connectivity Displays the connectivity status of the device.

The status is displayed according to the OF TP connection with the logging device:

Connection Up: The OFTP connection is up.

Connection Down: The OF TP connection is down, or there is currently no
OFTP connection when there previously was.

Unknown: The logging device has never had an OF TP connection.

No Connection (Logs Forwarded): There is no OF TP connection with the
logging device. The logs are forwarded from a FortiAnalyzer collector.

No Connection (Synced from Primary): There is no OF TP connection with
the logging device. The logs are synced from the primary FortiAnalyzer HA
unit. This status can only be seen on a secondary FortiAnalyzer HA unit.

Mouse over the connection icon to view the information in a tooltip, including
Logging Mode, Connectivity, Last Log Time, and Encrypted Transmission
(enabled or disabled).

Logging Mode Displays the logging mode for the device. A lock icon displays when a secure
tunnel is being used to transfer logs from the device to the FortiAnalyzer unit.

Last Log Time Displays the date and time that the last log was received from the device.
Average Log Rate Displays the average rate at which the device is sending logs to the FortiAnalyzer
(Logs/Sec) unit in log rate per second. Click the number to display a graph of historical

average log rates.

Disk Quota Usage Displays how much of the allotted disk storage space has been consumed by
logs.
HA Status Displays information if the device is part of a High Availability cluster. You can

manually identify devices as part of an HA cluster by editing the device
information. See Editing device information on page 70.

Description Displays a description of the device.
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Map View:
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The Map View provides an interactive map displaying the physical locations of authorized devices. You can navigate the
map by using your mouse. Zoom in or out with the scroll wheel or with the plus (+) or minus (-) buttons on the map. When
zoomed in, only the devices that are currently visible on the map are displayed in the sidebar. The sidebar provides
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information about the devices, including logging status, average log rate, and disk quota usage.

ADOMs

You can organize connected devices into ADOMs to better manage the devices. ADOMs can be organized by:

« Firmware version: group all 7.0 devices into one ADOM, and all 7.2 devices into another.

» Geographic regions: group all devices for a specific geographic region into an ADOM, and devices for a separate
region into another ADOM.

« Administrator users: group devices into separate ADOMSs based for specific administrators responsible for the

group of devices.

» Customers: group all devices for one customer into an ADOM, and devices for another customer into another

ADOM.

FortiAnalyzer, FortiCache, FortiClient, FortiDDos, FortiMail, FortiManager, FortiSandbox, FortiWeb, Chassis, and

FortiCarrier devices are automatically placed in their own ADOMs.

» Security Fabric: group all devices that are within the Security Fabric.

Each administrator profile can be customized to provide read-only, read/write, or restrict access to various ADOM
settings. When creating new administrator accounts, you can restrict which ADOMs the administrator can access, for
enhanced control of your administrator users. For more information on ADOM configuration and settings, see

Administrative Domains (ADOMs) on page 302.
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FortiClient EMS devices

You can add FortiClient EMS servers to FortiAnalyzer. Authorized FortiClient EMS servers are added to the default
FortiClient ADOM. You must enable ADOMs to work with FortiClient EMS servers in FortiAnalyzer. When you select the
FortiClient ADOM and go to the Device Manager pane, the FortiClient EMS servers are displayed. See also FortiClient
support and ADOMs on page 303.

Unauthorized devices

When a device is configured to send logs to FortiAnalyzer but has not yet been authorized, it is displayed in Device
Manager > Device & Groups > Unauthorized Devices. From this device group, you can authorize, delete, or hide devices
by using the toolbar buttons or the right-click menu.

Al
‘Q' The Unauthorized Devices device group is not available when all added devices are

authorized.

Enable Display Hidden Devices to view devices that were previously hidden.

Click Return to view the Device Manager pane containing authorized devices.

&2 Enterprise_FortiAnalyzer = @AddDevice 3B Device Group v > @ N2 o;\dmin o

Search,

18 Search... Q || [& Authorize | [ Hi [

All Logging Devices O | Device Name = Platform < Serial Number < IP Address < Firmware Version = Managemeu
Unauthorized Devices O  ©FGVMO2TM22025733 FortiGate-VM64 FGVMO02TM2202573 10.100.55.25 FortiGate 5.2 Configuration §

>
>
>
>
>
& Management Extensions

£ System Settings
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The Unauthorized Devices device group includes the following default columns:

Column Description

Device Name Displays the name of the device.
Platform Displays the platform for the device.
Serial Number Displays the serial number of the device. The serial number is unique to the unit

and does not change with firmware upgrades.

Firmware Version Displays the firmware version of the device.
IP Address Displays the IP address for the device.
Management Mode Displays the management mode of the device.

Using FortiManager to manage FortiAnalyzer devices

You can add FortiAnalyzer devices to FortiManager and manage them. When you add a FortiAnalyzer device to
FortiManager, FortiManager automatically enables FortiAnalyzer features. FortiAnalyzer and FortiManager must be
running the same OS version, at least 5.6 or later.
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In the Device Manager pane, a message informs you the device is managed by FortiManager and all changes should be
performed on FortiManager to avoid conflict. The top right of this pane displays a lock icon. If ADOMs are enabled, the
System Settings > ADOMs pane displays a lock icon beside the ADOM managed by FortiManager.

Logs are stored on the FortiAnalyzer device, not the FortiManager device. You configure log storage settings on the
FortiAnalyzer device; you cannot change log storage settings using FortiManager.

For more information, see Adding FortiAnalyzer devices in the FortiManager Administration Guide.

Adding devices

You must add and authorize devices and VDOMs to FortiAnalyzer to enable the device or VDOM to send logs to
FortiAnalyzer. Authorized devices are also known as devices that have been promoted to the DVM table.

You must configure devices to send logs to FortiAnalyzer. For example, after you add and
ﬂ authorize a FortiGate device with FortiAnalyzer, you must also configure the FortiGate device
I to send logs to FortiAnalyzer. In the FortiGate GUI, go to Log & Report > Log Settings, and
enable Send Logs to FortiAnalyzer/FortiManager.

Adding devices using the wizard

This section describes how to add model devices and VDOMs to the FortiAnalyzer using zero-touch provisioning (ZTP).

When using the Add Device wizard, model devices added to the FortiAnalyzer unit using a serial number are authorized
and are ready to begin sending logs. When a FortiGate model is configured using a pre-shared key, you must also
configure the key on the device itself before it will be authorized on FortiAnalyzer.

To add devices using the wizard:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.

2. Goto Device Manager and click Add Device.
The Add Device wizard opens. You can add devices by serial number or pre-shared key.

Add Device (1/2) B x

Please input the following information to add a device.

Name ‘ ‘

This field is required
Link Device By @ Pre-shared Key
Serial Number Serial Number
Device Model Click to select

Description Description

[
3. Configure the following settings:
Name Type a name for the device.
Link Device By Select Serial Number or Pre-shared Key.
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Depending on your selection, the device model will automatically link to a real
device by serial number or configured pre-shared key.

Serial Number Enter the device's serial number.

Pre-shared Key Enter a pre-shared key for the device. If using a pre-shared key, each device
must have a unique pre-shared key
Only FortiGate devices can be added to FortiAnalyzer using a pre-shared key.
You must also configure this pre-shared key on the corresponding FortiGate
device. See Configuring a pre-shared key on FortiGate on page 65

Device Model Select the model of the device from the dropdown.
Description Type a description of the device (optional).
4. Click Next.

The device is added to the ADOM and, if successful, is ready to begin sending logs to the FortiAnalyzer unit.
5. Click Finish to finish adding the device and close the wizard.

Configuring a pre-shared key on FortiGate

When configuring a FortiGate model device on FortiAnalyzer using a pre-shared key, the pre-shared key must also be
configured on FortiGate using the following CLI commands. This can be done after the FortiGate has been configured to
send logs to FortiAnalyzer in Log & Report > Log Settings.

To configure a pre-shared key on FortiGate:

1. Inthe FortiGate CLI, enter the following commands.
config log fortianalyzer setting
set preshared-key <pre-shared key>

Authorizing devices

You can configure supported devices to send logs to the FortiAnalyzer device. These devices are displayed in the root
ADOM as unauthorized devices. You can quickly view unauthorized devices by clicking Unauthorized Devices in the
quick status bar. You must authorize the devices before FortiAnalyzer can start receiving logs from the devices.

When ADOMs are enabled, you can assign the device to an ADOM. When authorizing multiple devices at one time, they
are all added to the same ADOM.

By default, FortiAnalyzer expects you to use the default admin account with no password. If
N - /, the default admin account is no longer usable, or you have changed the password, the device
? authorization process fails. If the device authorization fails, delete the device from
- FortiAnalyzer, and add the device again by using the Add Device wizard, where you can
specify the admin login and password.

When you delete a device or VDOM from the FortiAnalyzer unit, its raw log files are also deleted. SQL database logs are
not deleted.
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To authorize devices:

1. Inthe root ADOM, go to Device Manager and click Unauthorized Devices in the quick status bar. The content pane
displays the unauthorized devices.

2. Ifnecessary, select the Display Hidden Devices check box to display hidden unauthorized devices.
3. Select the unauthorized device or devices, then click Authorize. The Authorize Device dialog box opens.

Authorize Device

Add the following device(s) to ADOM: root

Device Name Assign New Device Name

FGVM010000102012 FGVM010000102012

4. If ADOMs are enabled, select the ADOM in the Add the following device(s) to ADOM list. If ADOMs are disabled,
select root. The default value is None.

If you try to authorize devices having different firmware versions than the selected ADOM
version, the system shows a Version Mismatch Warning confirmation dialog.
If you authorize the devices in spite of the warning, the configuration syntax may not be

fully supported in the selected ADOM.

5. Click OK to authorize the device or devices.
The device or devices are authorized, and FortiAnalyzer can start receiving logs from the device or devices.

Hiding unauthorized devices

You can hide unauthorized devices from view, and choose when to view hidden devices. You can authorize or delete
hidden devices.

To hide and display unauthorized devices:

1. Inthe root ADOM, go to Device Manager and click Unauthorized Devices in the quick status bar. The content pane
displays the unauthorized devices.

2. Select the unauthorized device or devices, then click Hide.
The unauthorized devices are hidden from view.

You can view hidden devices by selecting the Display Hidden Devices check box.

Adding an HA cluster

You can use a HA cluster to synchronize logs and data securely among multiple FortiGate devices.

An HA cluster can have a maximum of four devices: one primary device with up to three backup devices. All the devices
in the cluster must be of the same FortiGate series and must be visible on the network.
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You can use auto-grouping in FortiAnalyzer to group devices in a cluster based on the group

i, name specified in Fortigate's HA cluster configuration. For auto-grouping to work properly,
‘ql each FortiGate cluster requires a unique group name.
— If a unique group name is not used, auto-grouping should be disabled.

FAZ # config system global
(global)# set ha-member-auto-grouping disable

To create a HA cluster:

If using ADOMs, ensure that you are in the correct ADOM.
Add the devices to the Device Manager.

Choose a primary device, and click Edit.

In the Edit Device pane, enable HA Cluster.

In the Action column, click the Add icon.

In the Add Existing Device column, enable the toggle to select an existing device from the dropdown.

Edit Device

2B

x

Name Branch_Office_01

Description

1P Address

FGVMO2TM22010600 (FortiGate-VM64-KVM)
FortiGate 7.2.0, build4228

HA

HA Cluster ©

HA Cluster List From Existing Devices HA Member Action

Branch_Office_01 (FGVMO02TM22010600) +

© Click to select - x +

o JmcE

Alternatively, you can disable the toggle and enter the Serial Number of the device.

I\I Adding the devices before you create the HA is recommended.

7. Add more devices to the HA cluster as necessary, and click OK.
The maximum is three backup devices.

To view the HA in the Device Manager, click Column Settings > HA Status.

Adding a FortiGate using Security Fabric authorization

The following steps describe how to add and authorize a FortiGate device on FortiAnalyzer through the FortiAnalyzer
Fabric connector configuration on FortiOS.

Al
‘9' FortiAnalyzer authentication through the FortiGate Fabric connector configuration is available
- when both FortiAnalyzer and FortiGate devices are on 7.0.1 or higher.
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To authorize a FortiGate on FortiAnalyzer using Fabric authorization:

1. In FortlAnaIyzer go to System Settings > Settings and configure the Fabric Authorization address and port.

Admi

Idle Timeout (GUI) 900 Seconds (60-28800)
View Settings

Language Auto Detect -
High Contrast Theme (e )

Other Themes

— E

Mars Blue Sea Technology [ Twilight Canynn
- -
B
(o]
K

Password Policy o

Fabric Authorization €@

Authorization Address

Authorization Port 443

Apply

2. Onthe FortiGate, go to Security Fabric > Fabric Connectors, and double-click the Logging & Analytics card.

d

Select the Settings tab, and then select the FortiAnalyzer tab.

4. Configure the details of your FortiAnalyzer, including the IP address, and click OK.

The FortiAnalyzer Connection status is Unauthorized.

Core Network Security Connectd Logging Settings

'/Z/J Security Fabric Setup

Settings nfo

FortiAnalyzer Cloud Logging
FabricRgq——
ame fabric Status A EVESE © Disabled
Server
Connection status 0 Unauthorized

£ Refresh [ Authorize

Upload option Every Minute | Every 5 Minutes

LI Bl Allow access to FortiGate REST APl @D

Device Type Device Cal
2B FortiGate

Verify FortiAnalyzer certificate ©

*t? FortiAP FortiAnalyzer Status

X FortiSwitch
Logqueued 41695

& FortiExtender Failedlogs 0

Security Fabric Connectors “ Cancel

5. Click Authorize.
The Fortinet Security Fabric authorization dialog appears.

FortiAnalyzer 7.4.0 Administration Guide
Fortinet Inc.

68



Device Manager

6. Enter your FortiAnalyzer administrator credentials, and click Login.

Fortinet
Security
Fabric

223 FortiAnalyzer-VM64

E—

7. Select Approve to allow FortiAnalyzer to authorize the FortiGate, and click OK.

Fortinet
Security
Fabric

Select an action for the following unregistered devices.

FGVMOOTM Q

FGVMOOTM Deny  Later

et

If the authorization is successful, you will see a message confirming that the FortiGate is authorized by
FortiAnalyzer.

Core Network Security Connemj Logging Settings

ﬂ Security Fabric Setup

Settings Info

FortiAnalyzer Cloud Logging
Role FabricRg———
Fabric name fabric Status Disabled

Server

| Connection status 0 Authorized
£ Refresh

Upload option Every Minute | Every 5 Minutes
LAN Edge Devices ] Allow access to FortiGate REST APl @©
LEER LR EEEEE Verify FortiAnalyzer certificate @ O FAZVMSTM =«
B FortiGate (5]
57 FortiAP FortiAnalyzer Status

Logqueued 42921
Failedlogs 0

(3]
2 FortiSwitch [3]
B FortiExtender [0]

Security Fabric Connectors Cancel

8. Loginto FortiAnalyzer, and go to Device Manager.
The FortiGate is included in the list of authorized devices.

+ AddDevice [# Edit [ Delete I More~ 4 Column Settings v
O ADevice Name 1P Address Platform Average Log Rate(Logs/Sec)

FGVMOOTME S T .- FortiGate-VMé4
0O @FMG FortiManager-VMé4-Xen

FortiAnalyzer 7.4.0 Administration Guide
Fortinet Inc.

69



Device Manager
Managing devices
Use the tools and commands in the Device Manager pane to manage devices and VDOMs.

Using the toolbar

The following buttons and menus are available for selection on the toolbar:

Button Description

Add Device Opens the Add Device Wizard to add a device to the FortiAnalyzer unit. The
device is added, but not authorized. Unauthorized devices are displayed in the
Unauthorized Devices tree menu.

Device Group Displays menu items including Create New Group, Edit Group, and Delete Group.
New device groups are added to the Device & Groups tree menu. Select a custom
device group to edit or delete it.

Edit Edits the selected device.

Delete Deletes the selected devices or VDOMSs from the FortiAnalyzer unit.

When you delete a device, its raw log files are also deleted. SQL database logs
are not deleted.

Table View/Map View Select the view from the dropdown.
More Displays more menu items, including Import Device List and Export Device List.
Show Charts Enable or disable the charts that display above the Table View. From the

dropdown, you can select the charts that display above the Table View.

Column Settings Click to select which columns to display or select Reset to Default to display the
default columns.

Search Type the name of a device. The content pane displays the results. Clear the
search box to display all devices in the content pane.

Editing device information

Use the Edit Device page to edit information about a device. The information and options available on the Edit Device
page depend on the device type, firmware version, and which features are enabled.

To edit information for a device or model device:

1. Go to Device Manager > Device & Groups.

2. Inthe tree menu, select the device group.

3. Inthe content pane, select the device or model device and click Edit, or right-click on the device and select Edit.
The Edit Device pane displays.
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£22 Enterprise_FortiAnalyzer

@ Add Device 33 Device Group v

@ Dashboard 18 Search... Q

& Fortiview Unauthorized Devices

>
M LogView >
@ Fabric View >
B FortiSoC >
B Reports >
& Management Extensions

4 System Settings

FiERATINET

Name
Description

IP Address

Serial Number
Firmware Version
Admin User
Password

HA Cluster

Geographic Coordinate

Meta Fields

Company/Organization
Contact Email
Contact Phone Number

Address
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Edit Device x

Name Branch_Office_01

Description

1P Address 10.1.0.1
Serial Number FGVMO2TM22010600 (FortiGate-VM64-KVM)
Firmware Version FortiGate 7.2.0, build4228
Admin User

Password
HA

HA Cluster e}
Geographic Coordinate

Show Map
Meta Fields v/

Company/Organization Optional

Contact Email Optional
Contact Phone Number Optional

Address Optional

4. Edit the device settings and click OK.

Change the name of the device.

Type a description of the device.

Displays the IP address.

Displays the serial number of the device.

Displays the firmware version of the device.

Change the administrator user name for the device.
Change the administrator user password for the device.

Select to identify the device as part of an HA cluster, and to identify the other
device in the cluster by selecting them from the drop-down list, or by inputting
their serial numbers.

Displays the latitude and longitude of the device.
Click Show Map to view and edit the device location.

Displays default and custom meta fields for the device. Optional meta fields
can be left blank, but required meta fields must be defined.

See also Setting values for required meta fields on page 72.
Optionally, enter the company or organization information.
Optionally, enter the contact email.

Optionally, enter the contact phone number.

Optionally, enter the address where the device is located.
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Displaying historical average log rates
You can display a graph of the historical, average log rates for each device.

To display historical average logs rates:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Device Manager and view your authorized devices.
3. Inthe Average Log Rate (Logs/Sec) column, click the number to display the graph.

Log Rate History (Enterprise_First_Floor, Last 24 Hours)

Close

4. Hover the cursor over the graph to display more details.

Connecting to an authorized device GUI

You can connect to the GUI of an authorized device from Device Manager.

To connect to an authorized device GUI:

If using ADOMs, ensure that you are in the correct ADOM.
Go to Device Manager.
Right-click the device that you want to access, and select Connect to Device.

If necessary, change the port number and click OK.
You are directed to the login page of the device GUI.

P obN-=

Setting values for required meta fields

When a required meta field is defined for a device object, a column automatically displays on the Device Manager pane.
The column displays the value for each device. When the required meta field lacks a value, an exclamation mark
displays, indicating that you must set the value.

See also Meta Fields on page 334.

To set values for required meta fields:

1. Go to Device Manager.
2. View the columns.
A column displays for required meta fields.
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In the following example, a column named location is displayed for the required meta field named location. A value
of San Jose is defined for one device, but no value is defined for the other device.

+ AddDevice [# Edit i Delete §More~ & Column Settings +
O  ADevice Name 1P Address Platform Logs Average Log Rate(Logs/Sec) Device Storage Description location
O @Branch_Office_01 FortiGate-VMé4 & @ Real Time 4 I (613%) San Jose
O @Branch_Office_02 FortiGate-VMé4 & @ Real Time 4 I (562% A

3. Right-click the device that lacks a value, and select Edit.
The Edit Device pane is displayed.

Edit Device
Name Branch_Office_02 B
Description
4
0/128
IP Address
Serial Number FGVM (FortiGate-VMé4)
Firmware Version FortiGate 6.6.0, build2287
Admin User faz
Password ssssssce ®
HA Cluster
Meta Fields

Company/Organization
Contact Email

Contact Phone Number
Address

location

4. Under Meta Fields, complete the options labeled as Required, and click OK.
The value displays on the Device Manager pane.

Device groups

Device groups are displayed in Device Manager > Device & Groups. All devices added to FortiAnalyzer are included in a
default device group. You can create custom device groups as well to organize devices for convenient selection in other
features of FortiAnalyzer.

Type in the Search field to search for device groups by name. Click 2 {0 sort the list of device groups in ascending or
descending alphabetical order. The default device group will always remain at the top of the list. Select the device group
to display its list of devices in the Device Manager pane.
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NP The maximum number of device groups that can be created is the same as the maximum
‘Q' number of devices/VDOMs supported for your VM license or model. See the FortiAnalyzer
- data sheet on https://www.fortinet.com/ for information about the maximum number of

supported devices/VDOMs for your VM license or device.

Adding device groups

Once created, custom device groups can be selected in device filters for FortiView and Log View, and they can also be
used in event handlers and reports.

To create a custom device group:

1. Go to Device Manager.

2. From the Device Group dropdown in the toolbar, click Create New Group.
The Create New Device Group dialog opens.

3. Inthe Group Name field, type a name to identify the group of devices.
Description is optional.

4. Click Add Member to view the list of devices and existing device groups.
5. Select the check box for each device to add to the group, and click Add.

Al
‘Q' FortiAnalyzer allows nested device groups. For example, you can create Device Group A
- and add it under Device Group B.

6. Click OK.
The device group is now available in Device Manager.

Managing device groups

You can manage device groups from Device Manager. The device groups display in the left-pane. This includes default
device groups, such as All Logging Devices and Unauthorized Devices. Right-click a device group to open the shortcut
menu, which is also available from the Device Group dropdown.

From the Device Group dropdown in the toolbar, select one of the following options:

Option Description

Create New Group Create a new device group.

Edit Group Edit the selected device group. You cannot edit default device groups.

Delete Group Delete the selected device group. You cannot delete default device groups.
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FortiView

Use FortiView to view the FortiView and Monitors panes.
FortiView is a comprehensive monitoring system for your network that integrates real-time and historical data into a
single view. It can log and monitor threats to networks, filter data on multiple levels, keep track of administrative activity,
and more.
Monitors is designed for network and security operation centers where dashboards are displayed across multiple large
monitors.

o FortiView on page 76

» Monitors on page 92

N ! ’, To allow tuning of CPU and memory usage in high capacity environments, you can opt to
9 disable FortiView, which stops the background processing for this feature. See Enabling and
- disabling FortiView on page 109.

FortiAnalyzer 7.4.0 Administration Guide
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FortiView is a comprehensive monitoring system for your network that integrates real-time and historical data into a
single view. It can log and monitor threats to networks, filter data on multiple levels, keep track of administrative activity,
and more.

FortiView allows you to use multiple filters in the consoles, enabling you to narrow your view to a specific time, by user ID
or local IP address, by application, and others. You can use it to investigate traffic activity such as user
uploads/downloads or videos watched on YouTube on a network-wide user group or on an individual-user level.

In FortiView dashboards, you can view summaries of log data such as top threats to your network, top sources of
network traffic, and top destinations of network traffic.

Depending on which dashboard you are viewing, information can be viewed in different formats: table, bubble, map, or
tile. Alternative chart types are available in each widget's Settings menu.

For each summary, you can drill down to see more details.
FortiGate, FortiCarrier, and FortiClient EMS devices support FortiView.

Some dashboards require that specific log types are enabled before they can be used. When an ADOM does not include
any logs of the required type, the dashboard appears in gray and includes an information icon that indicates what logs
must be enabled before the dashboard can be used.

performance in high capacity environments. For more information, see Enabling and disabling
FortiView on page 109

\ﬂ The FortiView module, which includes the FortiView pane, can be disabled to improve

How ADOMs affect FortiView

When ADOMs are enabled, each ADOM has its own data analysis in FortiView.

Fabric ADOMs will show data analysis from all eligible devices in the Security Fabric.

Logs used for FortiView

FortiView displays data from Analytics logs. Data from Archive logs is not displayed in FortiView. For more information,
see Analytics and Archive logs on page 36.

FortiView dashboards

Many dashboards display a historical chart in a table format to show changes over the selected time period.

If you sort by a different column, the chart shows the history of the sorted column. For example, if you sort by Sessions
Blocked/Allowed, the chart shows the history of blocked and allowed sessions. If you sort by Bytes Sent/Received, the
chart shows the history of bytes sent and received.

When you drill down to view a line item, the historical chart show changes for that line item.

FortiAnalyzer 7.4.0 Administration Guide
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FortiView dashboards for FortiGate and FortiCarrier devices

Top Threats

Threat Map

Threats

Compromised Hosts

FortiSandbox
Detection

FortiAnalyzer 7.4.0 Administration Guide
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Lists the top threats to your network.

The following incidents are considered threats:
* Risk applications detected by application control.
« Intrusion incidents detected by IPS.
e Malicious web sites detected by web filtering.
» Malware/botnets detected by antivirus.

Displays a map of the world that shows the top traffic destinations starting
at the country of origin. Threats are displayed when the threat score is
greater than zero and either the source or destination IP is a public IP
address.

The Threat Window below the map, shows the threat, source, destination,
severity, and time. The color gradient of the lines indicate the traffic risk. A
yellow line indicates a high risk and a red line indicates a critical risk.

This view does not support filtering and Day, Night, and Ocean themes.
See also Viewing the threat map on page 80.

Displays end users with suspicious web use compromises, including end

users’ IP addresses, overall threat rating, and number of threats.

To use this feature:

1. UTM logs of the connected FortiGate devices must be enabled.

2. The FortiAnalyzer must subscribe to FortiGuard to keep its threat
database up-to-date.

Displays a summary of FortiSandbox related detections.

The following information is displayed: Filename, End User and/or IP,
Destination IP, Analysis (Clean, Suspicious or Malicious rating), Action
(Passthrough, Blocked, etc.), and Service (HTTP, FTP, SMTP, etc.).

Select an entry to view additional information in the drilldown menu.
Clicking a FortiSandbox action listed in the Process Flow displays details
about that action, including the Overview, Indicators, Behavior Chronology
Chart, Tree View, and more. Information included in the Details and Tree
View tab is only available with FortiSandbox 3.1.0 and above.
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Category View

Top Sources

Top Source
Addresses

Top Destinations
Traffic

Top Destination
Addresses

Top Country/Region

Policy Hits

DNS Logs

ZTNA Servers

Top Cloud

Shadow IT Applications

Top Cloud Users

Top Applications

Applications &
Websites Top Website
Domains

Top Website
Categories

Top Browsing Users
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Description

Displays the highest network traffic by source IP address and interface,
device, threat score (blocked and allowed), sessions (blocked and
allowed), and bytes (sent and received).

Displays the top source addresses by source object, interface, device,
threat score (blocked and allowed), sessions (blocked and allowed), and
bytes (sent and received).

Displays the highest network traffic by destination IP addresses, the
applications used to access the destination, sessions, and bytes. If
available, click the icon beside the IP address to see its WHOIS
information.

Displays the top destination addresses by destination objects,
applications, sessions, and bytes. If available, click the icon beside the IP
address to see its WHOIS information.

Displays the highest network traffic by country in terms of traffic sessions,
including the destination, threat score, sessions, and bytes.

Lists the policy sessions by policy, device name, VDOM, number of hits,
bytes, and last used time and date.

Summarizes the DNS activity on the network. Double click an entry to drill
down to the specific details about that domain.

ZTNA servers by bytes.

Displays the top cloud applications used on the network.

When viewing information about an application, FortiAnalyzer will first
check the Shadow IT database, and if no results are found, it will use the
metadata.

Displays the top cloud users on the network.

Displays the top applications used on the network including the application
name, category, risk level, and sessions blocked and allowed. Bytes sent
and received can also be enabled through the widget settings. Top
Applications can be viewed as a stackbar, bar, table, or bubble chart.

For a usage example, see Finding application and user information on
page 90.

Displays the top allowed and blocked website domains on the network.

Displays the top website categories.

Displays the top web-browsing users, including source, group, number of
sites visited, browsing time, and number of bytes sent and received.
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Category View Description

Displays the users who are accessing the network by using the following
types of security over a virtual private network (VPN) tunnel: secure socket
layers (SSL) and Internet protocol security (IPsec).
SSL & Dialup IPsec | You can view VPN traffic for a specific user from the top view and drilldown
VPN views. In the top view, double-click a user to view the VPN traffic for the
specific user. In the drilldown view, click an entry from the table to display
the traffic logs that match the VPN user and the destination.

Site-to-Site IPsec Displays the names of VPN tunnels with Internet protocol security (IPsec)
that are accessing the network.

Admin Logins Displays the users who logged into the managed device.

System Events Displays events on the managed device.

Displays device CPU, memory, logging, and other performance
information for the managed device.

Resource Usage
i e Resource Usage includes two widgets: Resource Usage Average and
Resource Usage Peak.
Failed . . .
N Displays the IP addresses of the users who failed to log into the managed
Authentication device
Attempts '

Using FortiView

When ADOMs are enabled, FortiView displays information for each ADOM. Please ensure you are in the correct ADOM.
See Switching between ADOMs on page 25.

» Viewing FortiView dashboards on page 79

« Filtering FortiView on page 81

« Viewing related logs on page 81

» Exporting filtered summaries on page 81

» Monitoring resource usage of devices on page 82
« Long-lived session handling on page 82

Viewing FortiView dashboards

When viewing FortiView dashboards, use the controls in the toolbar to select a device, specify a time period, refresh the
view, and switch to full-screen mode.

Many widgets on FortiView dashboards let you drill down to view more details. To drill down to view more details, click,
double-click, or right-click an element to view details about different dimensions in different tabs. You can continue to drill
down by double-clicking an entry. Click the close icon in the widget's toolbar to return to the previous view.

Many FortiView widgets support multiple chart types such as table view, bubble view, map view, tile view, etc.

» In widgets that support multiple views, select the settings icon in the top-right corner of the widget to choose another
view.
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« If sorting is available, there is a Sort By dropdown list in the top-left.
« Some widgets have a Show dropdown list in the bottom-right for you to select how many items to display.
» To sort by a column in table view, click the column title.

« To view more information in graphical views such as bubble, map, or user view, hover the mouse over a graphical
element.

Some dashboards require that specific log types are enabled before they can be used. When an ADOM does not include
the log type(s) required, the dashboard appears in gray and includes an information icon that indicates what logs must
be enabled.

Viewing the threat map

[ Dashboard v BAIDevicess @ last 1Hourv OBO047 - 09:0049

2
i
=
B
E
E
B

E

You can view an animated world map that displays threats from unified threat management logs. Threats are displayed
in real-time. No replay or additional details are available.

You must specify the longitude and latitude of the device to enable threats for the device to
ﬂ display in the threat map. You can edit the device settings to identify the geographical location
I of the device in Device Manager. For more information, see Editing device information on
page 70

To view the threat map:

1. Goto FortiView > Threats > Threat Map.
2. Inthe map, view the geographic location of the threats.
Threats are displayed when the threat level is greater than zero.
o Avyellow line indicates a high threat.
« Ared line indicates a critical threat.
3. Inthe Threat Window, view the Time, Threat, Source, Destination, and Severity(Score).
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Filtering FortiView

Filter FortiView widgets using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-
sensitive filter. You can also filter by specific devices or log groups and by time.

To filter FortiView widgets using filters in the toolbar:

1. Specify filters in the Add Filter box.

« Filter Mode: In the selected summary view, click Add Filter and select a filter from the dropdown list, then type a
value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or “or”.

« Text Search: Click the Switch to Text Search icon at the right end of the Add Filter box. In Text Search mode,
enter the search criteria (log field names and values). Click the Switch to Filter Mode icon to go back to Filter
Mode.

2. Inthe Device list, select a device.
3. Inthe Time list, select a time period.

including Source Object and Destination Object.See the FortiGate/FortiOS

s‘é’, UUID logging must be enabled in FortiGate/FortiOS to filter traffic by object name,
3 Administration Guide for more information about UUID logging.

To filter FortiView widgets using the right-click menu:

In the selected view, right-click an entry and select a filter criterion (Search <filter value>).

Depending on the column in which your mouse is placed when you right-click, FortiView uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

Viewing related logs

You can view the related logs for a FortiView summary in Log View. When you view related logs, the same filters that you
applied to the FortiView summary are applied to the log messages.

To view related logs for a FortiView summary, right-click the entry and select View Related Logs.

Exporting filtered summaries

You can export filtered FortiView summaries or from any level of drilldown to PDF and report charts. Filtered summaries
are always exported in table format.

To export a filtered summary:

1. Inthe filtered summary view or its drilldown, select the tools icon in the top-right corner of the widget and choose
Export to PDF or Export to Report Chart.

2. Inthe dialog box, review and configure settings:
« Specify a file name for the exported file.
« Inthe Top field, specify the number of entries to export.

« Ifyou are in a drilldown view, the tab you are in is selected by default. You can select more tabs. If you are
exporting to report charts, the export creates one chart for each tab.
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3. Click OK.

Charts are saved in the Chart Library. You can use them in the same way you use other charts.

Al
S L4
? Only log field filters are exported. Device and time period filters are not exported.

Monitoring resource usage of devices

You can monitor how much FortiAnalyzer system resources (e.g., CPU, memory, and disk space) each device uses.
When ADOMs are enabled, this information is displayed per ADOM. In a specific ADOM, you can view the resource
usage information of all the devices under the ADOM.

Go to FortiView > System > Resource Usage to monitor resource usage for devices.

Long-lived session handling

Because traffic logs are only sent at the end of a session, long-lived sessions can be unintentionally excluded when
narrowing searches in FortiView. To account for this, interim traffic logs can be enabled through FortiOS, allowing
FortiView to show the trend of session history rather than one large volume once the session is closed.

For a long-lived session with a duration greater than two minutes, interim traffic logs are generated with the Log ID of 20.

« Forinterim traffic logs, the sentdelta and rcvddelta fields are filled in with an increment of bytes which are
sent/received after the start of the session or previous interim traffic log.

« Interim traffic logs are not counted in Sessions, but the sentdelta and recvddelta in related traffic logs will be added
when calculating the sent and received bytes.

When a long-lived session ends, a traffic log with a Log ID of 13 is sent which indicates the session is closed.
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Summary 5:55“3"5 Blocked —(- Allowed

Application VavNC

Category Not.Scanned o0&

Risk High 0.6

# of Clients 1 0.4

Sessions( " Blocked/ M Allowed) [ 1] 02

Bytes( " Sent/ M Received)

¢ 1315 13:20 13:‘25 13:30 13:35 13:40 1345 13:50 13:55 14:00 14:10
Destination ~ Country/Region  Threat  Session

# ¥ Date/Time Device ID Firewall Action  Source IP Destination IP Service Application |LogID Session ID sentdelta rcvddelta Duration
1 14:11:55 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 | 187053 180 5600 1791
2 14:09:25 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 270 5736 1671
3 14:06:27 FGT91E4Q160005...  + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 180 8408 1491
4 14:04:28 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 187053 270 8394 1371
5 14:01:02 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 | 187053 270 8298 1191
6 13:58:08 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 187053 180 5204 1011
7 13:56:09 FGT91E4Q160005... ' + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 187053 270 7788 891
8 13:53:28 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 | 187053 180 5090 711
9 13:51:35 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 | 187053 3518 22200 591
10 13:49:32 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 187053 270 7824 471
11 13:46:27 FGT91E4Q160005...  + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 22942 1340721 291
12 13:44:23 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 11864 411594 171
13 13:33:28 FGT91E4Q160005... + close 172.184.112 172.18.4.201 VNC  VNC 0000000013 | 186001 17584 183669 801
14 13:31:35 FGT91E4Q160005... '+ accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 186001 21980 272402 723
15 13:29:23 FGT91E4Q160005...  + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 | 186001 21940 272680 602
16  13:27:30 FGT91E40160005... '+ accent 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 186001 22004 270784 481

£= Total logs for analytics: 60 days 22 hours.

50

Items per page

~ 0.281 Second

Ay
‘?' When enabled, interim logs must be handled specially for Reports and Events to avoid
- multiple counting.

Viewing Compromised Hosts

Compromised Hosts or Indicators of Compromise service (IOC) is a licensed feature.

When using Compromised Hosts, it is recommended to turn on the UTM web filter of FortiGate devices and subscribe
your FortiAnalyzer unit to FortiGuard to keep its local threat database synchronized with the FortiGuard threat database.
See Subscribing FortiAnalyzer to FortiGuard on page 341.

FortiGate devices also generate an event log for IOC when they are detected in local out traffic. The source IP in these
event logs are considered a compromised host, and they can be monitored in FortiAnalyzer.

Email filter logs from FortiMail devices are also supported by IOC, and can be rescanned when enabled in the
Compromised Hosts settings.

The Indicators of Compromise service (I0C) downloads the threat database from FortiGuard. The FortiGuard threat
database contains the blacklist and suspicious list. IOC detects suspicious events and potentially compromised network
traffic using sophisticated algorithms on the threat database.

FortiAnalyzer identifies possible compromised hosts by checking the threat database against an event's IP, domain, and
URL in the following logs of each end user:

» Web filter logs.
o DNSlogs.
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o Trafficlogs.
« Email filter logs (for FortiMail devices).

When a threat match is found, sophisticated algorithms calculate a threat score for the end user. When the check is
complete, FortiAnalyzer aggregates all the threat scores of an end user and gives its verdict of the end user’s overall
I0C.

Compromised Hosts displays the results showing end users with suspicious web usage which can indicate that the
endpoint is compromised. You can drill down to view threat details.

Compromised Hosts can be configured to rescan logs at regular intervals using new definitions from FortiGuard.

Understanding Compromised Hosts entries

When a log entry is received and inserted into the SQL database, the log entry is scanned and compared to the blacklist
and suspicious list in the IOC threat database that is downloaded from FortiGuard.

If a match is found in the blacklist, FortiAnalyzer displays the endpoint in Compromised Hosts with a Verdict of Infected.
If a match is found in the suspicious list, FortiAnalyzer flags the endpoint for further analysis.

In the analysis, FortiAnalyzer compares the flagged log entries with the previous endpoint's statistics for the same day
and then updates the score.

If the score exceeds the threshold, that endpoint is listed or updated in Compromised Hosts.
When an endpoint is displayed in Compromised Hosts, all the suspicious logs which contributed to the score are listed.

When the database is rebuilt, all log entries are reinserted and rescanned.

Working with Compromised Hosts information

Go to FortiView > Threats > Compromised Hosts.
To navigate the Compromised Hosts dashboard:

« Use the toolbar icons to select the table, user ioc, or bubble view.
o Use the exporticon to export table information into a PDF or report chart.

« Use settings to edit rescan configuration, and set additional display options, including Show Only Rescan and Show
Acknowledged.

« Use the toolbar to select devices, specify a time period, refresh the view, or enable Dark Mode.

When viewing the Compromised Hosts dashboard, # of Threats is the number of unique threat names associated with
that compromised host (end user).

o To acknowledge a Compromised Hosts line item, click Ack on that line.
« Tofilter entries, click Add Filter and specify devices or a time period.
o To drilldown and view threat details, double-click a tile or a row.

When viewing threat details, the # of Events is the number of logs matching each blacklist entry for that compromised
host (end user).

Incorrectly rated IOCs can be reported after drilling down to view threat details. Click the Detect Pattern for the row, and,
in the Information dialog, click report Misrated IOC.
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Managing a Compromised Hosts rescan policy

Compromised Hosts can be configured to scan previous entries on regular intervals or when a new package is received
from FortiGuard so that FortiAnalyzer performs a rescan using the latest available definitions.

Requirements for managing a Compromised Hosts rescan policy:
) ! ’, * This feature requires a valid indicators of compromise (IOC) license. The rescan options
? are not available in the GUI or CLI without a license.
- ¢ The administrator must have Read-Write privileges for System Settings in order to
configure global IOC rescan settings.

When IOC rescan is performed, the Joc_Rescan tag is added to rescanned logs. Event handlers that include the loc_
Rescan tag in their rules will process rescanned logs and generate new alerts tagged with loc_Rescan. Real-time logs
matching these event handler rules continue to generate alerts without the loc_Rescan tag.

B csiv60~ OlLast7Days.. " Expand Al O Show Acknowledged

CRefresh v % CustomView B~ &

Handiler = Default-Compromised Host-Detection-IOC-By-Threat Add Filter o
0 # Event Event Statu Event Type Count Severity  First Occurrence ¥ Last Update Additional Info Handler Togs Device Name

O 1 v116911288(2)

o Traffic to C&C from VAN-200289-... Unhandled £ Traffic 3 @Critical | 2020-04-02 18:10:45  2020-04-02 18:10:50  Traffc to C&C:1.169.112.88, Traffic pa... Default-C ised Host-Detection...| IP | C&C || loc_Rescan HA91E_FGTI1E

[a} Web traffic to C&C from VAN-200... Unhandied @ Web Filter 1 ®Critical | 2020-04-02 18:10:43  2020-04-02 18:10:43  Traffc to C&C:1.169.112.88, Traffic pa... Default-Compromised Host-Detection...| C&C || URL || loc_Rescan HAI1E FGT91E

O 2 1163163199 (2)

o Traffic to CSC from VAN-200289-... Unhandied £t Traffic 3 @Ciitical  2020-04-0218:05:34  2020-04-02 18:05:39  Traffic to C&C:1.163.163.199, Traffic p... Default-Ct d jon...| | 1P| C&C HA91E FGT91E

o Web traffic to C&C from VAN-200... Unhandied @ Web Filter 1 @Ciitical  2020-04-0218:05:32  2020-04-02 18:0532  Traffic to C&C:1.163.163.199, Traffic p... Default:C ised Host-Detection...| C&C || URL HA91E FGT91E

By default, the following basic event handlers include loc_Rescan tag for all rules:

o Default-Compromised Host-Detection-IOC-By-Endpoint
o Default-Compromised Host-Detection-IOC-By-Threat

@ Dashboard Data Selectors | Notification Profiles [:ECTEUNITE  Correlation Handlers O
& Device Manager
@ 8
B FortiView >
M Log View N O  Status Name + Rules + Dﬂ
@ Fabric View > Rule-1 Traffic to CnC detected: (Default,By_Endpoint IPC&C loc_Rescan) tdtype~infected
I Incidents & Events v o @9 Default-Compromised Host-Detection-IOC-By-Endp... Rule-2 Web traffic to CnC detected: (Default,By_Endpoint,C&C,URL.loc_Rescan) tdtype~infected
Event Monitor Rule-3 DNS trafic to CnC detected: (Default,By_Endpoint.C&C,Domain,loc_Rescan) tdtype~infected
m Rule-1Traffic to CnC detected: (Default,By_Threat.IP.C&Cloc_Rescan) tdtype~infected
. Rule-2 Web traffic to CnC detected: (Default,By_Threat,C&C,URL loc_Rescan) tdtype~infected
Incidents O ©@  Default-Compromised Host-Detection-IOC-By-Threat
T Rule-3 DNS traffic to CnC detected: (Default,By_Threat,C&C,Domain,loc_Rescan) tdtype~infected
reat Hunting
Rule-4 Traffic to CnC event detected by FortiGate: (Default,By_Threat,C&C) logid==0100020214
Log Parser
FEERTINET 0% 5/68

To configure rescan settings and check rescan results:

1. Goto FortiView > Threats > Compromised Hosts.
2. Click the Rescan Task icon above the table view.
The Compromised Hosts Rescan pane displays.
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Compromised Hosts Rescan

Compromised Hosts Rescan Global Settings €

Enable Global Compromised ~ @
Hosts Rescan

Running at € 12:00:00 AM

Compromised Hosts Rescan Current ADOM Settings

Enable Current ADOM [e ]
Compromised Hosts Rescan

Log Type Filters

Last N Days

Rescan tasks

Start Time + Status Percentage

No record found.

Threat Count Log Count Package Update Time Blocklist Count u

3. Configure the Compromised Hosts Rescan Global Settings.
a. Toggle Enable Global Compromised Hosts Rescan to On.
b. Setthe running time to a specific hour of the day, or select package update to perform a rescan when a

package update is received.

4. Configure the Compromised Hosts Rescan Current ADOM Settings.
a. Toggle Enable Current ADOM Compromised Hosts Rescan to On.
b. Selectthe log types to be scanned (DNS, Web Filter logs, Traffic logs, or Email filter logs).
c. Setthe number of previous days' logs to be scanned.
By default, DNS, web filter, and traffic logs are enabled, and the scan will cover the last 14 days. The maximum
recommended number of scan days is calculated based on historical scan speeds, or 30 days if no previous scans

have been done.

5. Rescan jobs are shown in the Rescan tasks table, which includes the following columns:

Start Time
Status

Percentage

End Time

Threat Count

Log Count

Package Update Time
Blacklist Count
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The task's start time.

The status of the task (complete, running, etc.).
Running tasks can be canceled by clicking the cancel icon in the Status
column.

Task progress as a percentage.

The task's end time.

Configure the parameters for the selected action.
The total number of logs with threats.

The 10C package update time.

A count of the newly detected threats added to the blacklist.
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Compromised Hosts Rescan x
Enable Global Compromised @O
Hosts Rescan

Running at €@ 12:00:00 AM -

Compromised Hosts Rescan Current ADOM Settings

Enable Current ADOM [ e}

Compromised Hosts Rescan

Log Type Filters DNS Logs
Web Filter Logs
Traffic Logs
Email Filter Logs

Last N Days (Recommended 1

Maximum Days: 30)

Rescan tasks

Start Time + Status Percentage End Time Threat Count Log Count Package Update Time Blocklist Count n
May 16 22:21:51  complete May 16 22:21:51 | @) 188 May 16 22:14:55 1200

6. Select a non-zero threat count number in the table to drilldown to view specific task details, including the Detect
Pattern, Threat Type, Threat Name, # of Events, and Endpoint.

Compromised Hosts Rescan x

&

Summary

Start Time: 1684300911

Status: complete

Percentage: 100

End Time: 1684300911

Threat Count: 129

Log Count: 188

Package Update Time: 1684300495
Blocklist Count: 1200

Detect Pattern Threat Type = Threat Name = # of Events + Endpoint + u
http:/www.iyou.com/xyz Malware CnC 95
150.1.1.1 Malware PostlInfectionTraffic 34

In FortiView > Threats > Compromised Hosts, a rescan icon is displayed in the Last Detected column if threats are
found during a rescan. To view only those hosts that had threats found during a rescan, go to the Settings and
enable Only Show Rescan.

For FortiMail email filter rescans, the endpoint which visited an allowed URL will be marked as compromised if the
URL is blocklisted in the latest URL blocklist. The compromised hosts are the users' email addresses which can be
found in the To field of the log.

Indicators of Compromise

I0C (Indicators of Compromise) detects compromised client hosts (endpoints) by comparing the IP, domain, and URL
visited against the TIDB package, downloaded daily from FortiGuard. Compromised hosts are listed in FortiView in a
table or map style, and drilling down on a compromised endpoint displays the details of detected threats.

» The TIDB package contains a blacklist which is made up of IPs, domains and URLSs, and a suspicious URL list (also
called Crowdsource URLS). Only suspicious URLs have a score rating in the TIDB package. Once a URL is
included in the blacklist, the suspicious score rating is no longer performed.

« Once a new TIDB package has been downloaded by FortiAnalyzer, the previous package becomes obsolete.

« The blacklist statistics by endpoint are updated in near realtime (ASAP), and suspicious rating statistics by endpoint
are updated on a half-hour schedule.
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« The IOC inspection is performed on a daily cycle because the updated FortiGuard TIDB package is received daily.
At the end of the day, the IOC endpoint summary is fixed and will not receive additional changes, and a new
summary will be created for the next day.

« Web Filter, DNS, and traffic logs from FortiGate, and email filter logs from FortiMail are inspected.

» The IOC module requires a license. Without a license, only demo TIDB packages are loaded into the FortiAnalyzer
image, and no updated package from FortiGuard is used in the IOC function.

« When a threat is detected, FortiAnalyzer sends a notification to the FortiGate via REST API. The FortiGate can be
configured to take automatic action against detected threats.

« |OC threat detection can be performed in both realtime and rescan mode. Realtime detection monitors new
incoming logs, whereas rescan mode checks historical logs against the new blacklist once an updated TIDB
package is available. Rescan mode does not check historical logs against the suspicious list. Realtime detection is
always enabled, and IOC rescan can be enabled or disabled.

Understanding suspicious list detection

The suspicious list is crowdsourced each day by FortiGuard Al from millions of global endpoint devices. The list is
comprised of IPs, URLs, and domains that have a low reputation, usually because they are questionable websites.

The TIDB package includes threat ranking scores which FortiAnalyzer normalizes using its internal logic. When an
endpoint visits a site that matches one included in the suspicious list, the score is deposited into the “reputation account”
for that endpoint. The total normalized score is then used to determine a verdict for the endpoint. The higher the score,
the higher the confidence. When a new TIDB package becomes available, the process to determine a verdict begins
again. FortiAnalyzer processes logs for all monitored endpoints against the new TIDB and will determine a verdict for
each endpoint based on their new normalized score.

Endpoints that visit suspicious sites on an infrequent basis are at a low risk for compromise and are not included in the
Compromised Host watch list. The FortiAnalyzer IOC engine continues to monitor these endpoints until it has enough
confidence to produce a verdict, at which point they are given the verdict Low Suspicious and are added to the watch list.
Endpoints that regularly visit suspicious sites are at a higher risk for infection or may already be infected with zero-day
malware. These endpoints are assigned a verdict and are added to the Compromised Host watch list.

Suspicious verdicts include:

» High suspicious (high confidence)
o Medium suspicious (medium confidence)
« Low suspicious (low confidence)

In the example below, an endpoint visits multiple sites included in the suspicious list, and as a result, has its verdict
changed from Low suspicious to Medium suspicious. The data included in this example is purely hypothetical for the
purpose of illustration.

Activity time Suspicious site Ranking of Suspicious score  FortiAnalyzer
stamp visited by suspicious site of endpoint I0C verdict
endpoint
Time stamp 1 suspicious-url-1 60 60 Low suspicious
Time stamp 2 suspicious-ip-2 100 160 Low suspicious
Time stamp 3 suspicious-domain-3 40 200 Medium suspicious

The specific algorithm used for the decision to change the verdict of an endpoint is internal to FortiAnalyzer.
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Viewing IOC licenses and TIDB package downloads

To check the license downloaded from FortiGuard in the CLI:

diagnose fmupdate dbcontract
FL-1KE3R16000271 [SERIAL NO]
AccountID:
Industry:
Company:
Contract: 1
PBDS-1-99-20250104
Contract Raw Data:
Contract=PBDS-1-99-20250104:0:1:1:0

In the output, PBDS is the IOC license.

To check the I0C package in the CLI:
diagnose fmupdate fds-getobject

FAZ object version information

ObjectId Description Version Size Created Date Time

00001000TIDB0O0100O ThreatIntel DB 00000.01052 34 MB 19/04/14 20:10
ext desc:ThreatIntel DB

00001000TIDB0O0100O ThreatIntel DB 00000.01053 37 MB 19/04/16 04:13

<latest> ext desc:ThreatIntel DB

FortiAnalyzer periodically syncs its own IOC TIDB files to the version of IOC package downloaded by fmupdate. This is
performed on a one hour schedule.

To check the license and TIDB version used by FortiAnalyzer in the CLI:
diagnose test application sgllogd 204 stats

License of post breach detection installed.

License expiration : 2025-Jan-04

TIDB version : 00000.01017-1902242107
TIDB load time : 2019-02-24 14:11:2

Configuring FortiGate to FortiAnalyzer REST API authentication

FortiGate to FortiAnalyzer REST API authentication allows the FortiAnalyzer to send IOC alerts and trigger configured
automation rules, if configured.

To configure REST API authentication:

1. Go to the Device Manager in the FortiAnalyzer.

2. Edit the FortiGate device to set the FortiGate super admin username and password.
This is the only way to configure REST API authentication prior to 6.2.
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Alternatively, when configuring logging to FortiAnalyzer on FortiGate, you can go to Security Fabric > Settings and
enable Allow access to FortiGate REST APl and Trust FortiAnalyzer by serial number.

Throttling IOC alerts

To avoid flooding FortiGate with event alerts, you can configure a throttle which allows only one alert to be sent within a
set period of time for the same endpoint.
The default time period is one day (1440 minutes).

To set an IOC alert throttle in the CLI:

config system log ioc
(ioc) # set

notification Disable/Enable Ioc notification.

notification-throttle Minute value for throttling the rate of IoC notifications.
(ioc)# get

notification : enable

notification-throttle: 1440

Debugging I0C notifications

Check for the FortiGate system event: IOC detected by FortiAnalyzer.

If the system event is not present, check FortiAnalyzer's OF TP debug or FortiGate's httpsd debug for the same
message.

Examples of using FortiView

You can use FortiView to find information about your network. The following are some examples.

» Finding application and user information on page 90
e Analyzing and reporting on network traffic on page 91
o Finding FortiGate C&C detection logs on page 91

Finding application and user information

Company ABC has over 1000 employees using different applications across different divisional areas, including supply
chain, accounting, facilities and construction, administration, and IT.

The administration team received a $6000 invoice from a software provider to license an application called Widget-Pro.
According to the software provider, an employee at Company ABC is using Widget-Pro software.

The system administrator wants to find who is using applications that are not in the company’s list of approved
applications. The administrator also wants to determine whether the user is unknown to FortiGuard signatures, identify
the list of users, and perform an analysis of their systems.
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To find application and user information:

If using ADOMs, ensure that you are in the correct ADOM.

Go to FortiView > Applications & Websites > Top Applications.

Click Add Filter, select Application, type Widget-Pro.

If you do not find the application in the filtered results, go to Log View > FortiGate > Traffic.
Click the Add Filter box, select Source IP, type the source IP address, and apply the filter.

o wDbd =

Analyzing and reporting on network traffic

A new administrator starts at #1 Technical College. The school has a free WiFi for students on the condition that they
accept the terms and policies for school use.

The new administrator is asked to analyze and report on the top source and destinations students visit, the source and

destinations that consume the most bandwidth, and the number of attempts to visit blocked sites.

To review the source and destination traffic and bandwidth:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto FortiView > Traffic > Top Sources.
3. Goto FortiView > Traffic > Top Destinations.
If available, select the icon beside the IP address to see its WHOIS information.

Finding FortiGate C&C detection logs

FortiGate detected botnet events while performing an I0OC scan. The administrator wants to view the C&C and logs with
SOC view in Compromised Hosts.

To view C&C detection logs:

1. Goto FortiView > Threats > Compromised Hosts.

2. Inthe main view, right-click an entry and select Blocklist, or double-click an entry. The Blocklist is displayed. C&C
detection logs have the following values:

Threat Name * Botnet (for example, Asprox.Botnet)
Detect Method detected-by-fgt
Log Type attack

3. Inthe Blocklist drill-down view, double-click an entry to view related logs. Log View is displayed.
C&C detection entries appear in either the Aftack Name or Message columns with one of the following values:

Column Value

Attack Name * .Botnet (for example, Asprox.Botnet)

Message Botnet C&C * (for example, Botnet C&C Communication)
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Monitors

FortiView > Monitors is designed for a network and security operations center where multiple dashboards are displayed
in large monitors.

In the Monitors view, dashboards display both real-time monitoring and historical trends. Centralized monitoring and
awareness help you to effectively monitor network events, threats, and security alerts. Use Monitors dashboards to view
multiple panes of network activity, including monitoring network security, compromised hosts, endpoints, Security
Fabric, WiFi security, and FAZ system performance.

A typical scenario is to set up dashboards and widgets to display information most relevant to your network and security
operations. Use the main monitors in the middle to display important dashboards in a larger size. Then use the monitors
on the sides to display other information in smaller widgets.

For example, use the top monitor in the middle to display the Top Threat Destinations widget in full screen, use the
monitor(s) below that to display other Threat Monitor widgets, use the monitors on the left to display WiFi Monitor
widgets at the top and FAZ Performance Monitor widgets at the bottom, and use the monitors on the right as a
workspace to display widgets showing the busiest network activity. You can move, add, or remove widgets.

Monitor dashboards and widgets are very flexible and have the following features:

« You can create predefined or custom dashboards.

» For both predefined and custom dashboards, you can add, delete, move, or resize widgets.
¢ You can add the same dashboard multiple times on the same or different monitors.

» Each widget monitors one activity.

¢ You can add the same widget multiple times and apply different settings to each one. For example, you can add
widgets to monitor the same activity using a different chart type, refresh interval, or time period.

» You can resize widgets or display a widget in full screen.

Some dashboards and widgets require that specific log types are enabled before they can be used. When an
ADOM does not include any logs of the required type, the dashboard or widget appears in gray and includes an
information icon that indicates what logs must be enabled before it can be used.

\y

~ P FortiView, including the Monitors pane, can be disabled to improve performance in high
9 capacity environments. For more information, see Enabling and disabling FortiView on page
= 109
To prevent timeout, ensure Idle Timeout is greater than the widget's Refresh Interval. See Idle
timeout on page 379 and Settings icon on page 106.

FortiView Monitors

FortiView > Monitors includes predefined dashboards.

Both predefined and custom dashboards can be modified with widgets, including: Threats, Compromised Hosts, Traffic,
Applications & Websites, VPN, WiFi, Endpoints, Local System Performance on page 104, Global Threat Research,
Fabric State of Security, FortiClient Software Inventory, and FortiFirewall widgets (Traffic and VPN).
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For example, the default Threat Monitor dashboard includes four widgets: Threat Map, Top Threat Destinations, Top
Threats, and Top Virus Incidents Over Time. These widgets can be removed, enlarged, reduced, or customized, and
new widgets can be added to the dashboard.

For more information, see Customizing the Monitors dashboard on page 106.
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FortiView Monitors includes the following predefined dashboards:

Threats on page 94
Traffic on page 95

Applications & Websites on
page 95

Compromised Hosts on page
96

Incidents and Events on page
96

Secure SD-WAN Monitor on
page 97

SD-WAN Summary on page 98

Traffic Shaping Monitor on
page 98

ZTNA on page 99

FortiSandbox Detections on
page 99

FortiMail on page 100
Endpoints on page 101

Fabric State of Security on
page 101

Monitor the top security threats to your network.
Monitor the traffic on your network.

Monitor the application and website traffic on your network.

Monitor compromised and suspicious web use in your network.

Monitor incidents and events.

Monitor secure software-defined networking.

Monitor SD-WAN operations.

Monitor traffic shaping information.

Monitor ZTNA metrics.

Monitor FortiSandbox detections on your network.

Monitor FortiMail statistics.
Monitor endpoint activity on your network.

Monitor your network's Security Fabric rating, score, and topology.

This information for this dashboard is available after you create a Security Fabric
group in FortiGate and add it in FortiAnalyzer. The Security Fabric can be
selected in the settings options for each widget.
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VPN on page 102
WiFi on page 102

FortiClient Software Inventory
on page 102

loT on page 102

Threat (FortiClient) on page
102

Applications & Websites
(FortiClient) on page 103

Endpoints (FortiClient) on
page 103

Traffic (FortiDDOS) on page
103

Traffic (FortiFirewall) on page
103

VPN (FortiFirewall) on page
104

Local System Performance on
page 104

Global Threat Research on
page 105

Local Threat Research on
page 105

Archive

Monitor VPN activity on your network.
Monitor WiFi access points and SSIDs.

Monitor the FortiClient endpoints sending logs to FortiAnalyzer.

Monitor loT devices.

Monitor threat activity from FortiClient.

Monitor application and website activity from FortiClient.

Monitor endpoint activity from FortiClient.

Monitor FortiDDoS detected traffic activity. This chart requires Intrusion

Prevention logs to be enabled.

Monitors FortiFirewall traffic.

Monitors FortiFirewall VPN usage.

Monitor the local system performance of the FortiAnalyzer unit.

Monitor global threat research.

Monitor local threat research.

Includes archived monitors from previous versions.

\y

When upgrading versions prior to FortiAnalyzer 6.2.0, custom dashboards will not be migrated
and must be recreated.

Threats

Threats includes the following widgets:

Threat Map

Top Threat
Destinations

Threats happening right now across the world.

A world map, spinning 3D globe, or table showing the top 10, 20, 50, 100 threat destinations.
On the map view, hover the cursor over data points to see the source device and IP address,

destination IP address and country, threat level, and the number of incidents (blocked and

allowed).
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Top Threats

Top Threats by
Weight & Count

Top Virus Incidents
Over Time

Traffic

The top threats to your network. Hover the cursor over data points to see the threat, category,
threat level, threat score (blocked and allowed), and the number of incidents (blocked and
allowed).
The following incidents are considered threats:

¢ Risk applications detected by application control

¢ Intrusion incidents detected by IPS

¢ Malicious web sites detected by web filtering

¢ Malware/botnets detected by antivirus

The top threats by weight and count to your network from risk applications, intrusion incidents,
malicious websites, and malware/botnets.

The top virus incidents over time.

Traffic includes the following widgets:

Top Sources

Top
Country/Region

Top Policy Hits
Top Destinations

Traffic Over Time
by Sessions

Policy Hits Over
Time by Bandwidth

User Data Flow
Top Sources Today

Top Interface of
Sent Bit Rate

Top Interface of
Received Bit Rate

The highest network traffic by source IP address and interface, sessions (blocked and
allowed), threat score (blocked and allowed), and bandwidth (sent and received).

The historical network traffic by country/region, sessions, bandwidth, or threat score.

Top policy hits from recent traffic.
Top destinations from recent traffic by bandwidth or sessions.

The historical destinations from recent traffic.

The historical policy hits from recent traffic.

Bandwidth breakdown of top user destination country/region or application usage.
Near real-time network traffic by blocked and allowed sessions.

Line charts for the top 10 sent bit rate of interfaces over the specified time period.
Mouse over the line charts to view bit rate information for each interface.

Line charts for the top 10 received bit rate of interfaces over the specified time period.
Mouse over the line charts to view bit rate information for each interface.

Applications & Websites

Applications & Websites includes the following widgets:

Top Website
Domains

Top website domains from recent traffic.

FortiAnalyzer 7.4.0 Administration Guide
Fortinet Inc.

95



Top Cloud
Applications

Top Applications

Top Browsing User

Cloud Applications
Over Time by
Sessions

Top Applications
Over Time by
Sessions

Top Endpoint
Applications

Website Browsing
Over Time by
Sessions

Browsing User
Over Time by
Bandwidth

Top cloud applications from recent traffic.

The top applications used on the network, including application name, risk level, category,
sessions (blocked and allowed), and bytes (sent and received).

Top browsing users from recent traffic.

The historical sessions of cloud applications used on the network.

The historical sessions of applications used on the network, including application name, risk
level, category, sessions (blocked and allowed), and bytes (sent and received).

The top applications used on the network, including application name, risk level, category,
sessions (blocked and allowed), and bytes (sent and received).

Only available in a Fabric ADOM.

The historical websites browsing sessions from recent traffic.

The historical browsing users from recent traffic.

Compromised Hosts

Compromised Hosts includes the following widget:

Compromised
Hosts

Suspicious web use compromises. By default, this widget includes two panes: Compromised
Hosts and Compromised Hosts Incidents.

The Compromised Hosts pane automatically rotates through compromised hosts. You can
pause autoplay or click > or < to manually move to another compromised host.

The Compromised Hosts Incidents pane displays a map of compromised hosts incidents.

Click Settings to change the number of top compromised hosts, Time Period, Refresh
Interval, Autoplay Interval, and to show or hide Compromised Hosts Incidents.

Incidents and Events

There are two dashboards available within FortiView > Monitors > Incidents & Events.

Events:

The Events dashboard includes the following widgets:

Event Summary

Total number of events generated, mitigated, and unhandled.
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Top 10 Events by
Type

Events by Severity

Top 10 Events by
Handler

Incidents:

Number of events in a bar chart by type.

Total number of events by severity in a donut chart.

Number of events in a bar chart by handler.

The Incidents dashboard includes the following widgets:

Total Incidents
Unsolved Incidents

Incidents Timeline

Total number of incidents by status in a donut chart.
Total number of unsolved incidents by severity in a donut chart.

Total number of incidents by category in a line chart timeline.

Secure SD-WAN Monitor

Secure SD-WAN Monitor includes the following widgets:

SD-WAN Bandwidth
Overview

SD-
WAN Performance
Status

SD-WAN Rules
Utilization

SD-WAN Utilization
by Application

Top SD-WAN
SLA Issues

Health Check Status

SD-WAN Events

Application
Bandwidth
Utilization

Per-Application
Performance

The bandwidth of the SD-WAN network over time. This widget displays a line chart of the
sent/received rate (bps) in the selected time period for SD-WAN members interfaces.

The SD-WAN performance status comparison with interfaces. Mousing over the scatter
chart displays the status for health checks and member interface in a tooltip. The colors (red,
orange, yellow, and green) indicate the different percentage of a member's interface or
health check. Click on a scatter chart to view additional details.

The SD-WAN rule traffic utilization by interface and application.

The share of bandwidth utilization by application for each WAN link.

The top SD-WAN SLA issues.

This widget dynamically creates a child-widget for each health check where a line chart of
latency, jitter, and packet loss in the selected time period for SD-WAN interfaces is
displayed.

This widget displays a table chart for SD-WAN event logs which have a level higher than
notice (warning, error, etc.) within the selected time period.

The total bandwidth from all applications as well as the bandwidth per-SD-WAN interface.
This widget can be viewed in a sanky chart or table chart format.

The performance for the selected application based on chosen metric. You can select an
application in the widget's Application dropdown menu.

Latency, Jitter, Packet Loss, and Bandwidth metrics are available.
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Global-Application The global application performance for the selected metric.
Performance Latency, Jitter, and Packet Loss metrics are available.

SD-WAN Interfaces The information for SD-WAN interfaces and ADVPN shortcut interfaces.
Latency, Jitter, and Packet Loss metrics are available.

Audio MOS Score The MOS score by interface. Mousing over the chart displays a summary of the MOS score
and VolP quality at that point.

The interface must have a performance SLA with MOS enabled to display in the chart.

\ﬂ To update the Refresh Interval, click the settings icon at the top of the widget, and then select a

value from the dropdown.
To filter a chart, click a key in the legend.

SD-WAN Summary

SD-WAN Summary monitor includes the following widgets:

SD-WAN Health Overview The SD-WAN devices' status.
Top SD-WAN SLA Issues The SD-WAN SLA issues.
Top SD-WANApplications The SD-WAN devices' top applications.

SD-WAN Top Device Throughput The SD-WAN devices' throughput.
Top SD-WAN Talkers The SD-WAN devices' top talkers.
Audio MOS Score The MOS score across all SD-WAN devices.

Traffic Shaping Monitor

This dashboard monitors the traffic shaping information in FortiGate logs. It includes the following widgets:

Bandwidth The bandwidth of traffic shapers over time. Mouse over the line chart to display the bandwidth
at a specific time.

Top Applications The total traffic by application. Mouse over the stacked bar chart to display a summary of

and Traffic Shaping application traffic and dropped bytes for that application. Click a bar in the chart to display the
user information for that application in a table view. This view includes a summary of the
application traffic, including the number of sessions and bytes (sent/received) by user.

This widget displays the top five applications by default.

Dropped Bytes The total dropped bytes per shaper. Mouse over the line chart to display a summary of
Over Time Per dropped bytes per shaper at a specific time. Click a shaper in the legend to hide/unhide it in
Shaper the line chart. Greyed-out shapers in the legend are hidden in the line chart.

Click More details to display the traffic shaping policy hits information in a table view. This
table includes the total sessions and bytes (sent/received) by shaping policy.
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ZTNA

ZTNA includes the following widgets:

Statistics
Connection Attempts
Devices

ZTNA Device Tags
User Overview

Known Devices with Failed
Posture Check

Bandwidth Trends
Top Users by Connections
Private Apps Access

Public Cloud Business Apps
Access

Users
Policy Overview

Private & Public Applications
Access Failure History

CASB Apps Access

FortiSandbox Detections

The number of blocked sessions, users, and devices.

The number of connection attempts allowed and blocked.

The number of devices connected and blocked.

The number of ZTNA device tags.

The number of high risk users, including a summary of the top high risk users.

The number of known devices with a failed posture check by user.

Bandwidth trends.
Top users by number of connections, allowed and blocked.
A list of private apps, including their number of allowed and blocked connections.

A list of public cloud business apps, including their number of allowed and blocked
connections.

The number of users connected and blocked.
The number of violated policies, including a summary of the top violated policies.

Private and public app access failures.

A list of CASB apps, including their number of allowed and blocked sessions.

FortiSandbox Detections includes the following widgets:

FortiSandbox FortiSandbox detection detail, including date, file name, end user, destination IP, analysis,
Detection action, and service.
FortiSandbox - The number of files detected by FortiSandbox by type: Malicious, Suspicious, Clean, and

Scanning Statistics Others.

FortiSandbox - Top Usersor IP

addresses that have the highest number of malicious and suspicious files

Malicious detected by FortiSandbox.

& Suspicious File
Users
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FortiMail

FortiMail includes the following widgets:

Statistics History

Top Sender by
Categories

Top Recipient by
Categories

Threat Statistics

Mail Statistics

Outbreak Statistics
(FortiSandbox)

Statistics Summary

The statistics history from FortiMail that displays the summary of total messages and spam in
the selected time period.

Place your mouse over a line in the chart to view a tooltip which includes the total messages
and total spam for the corresponding date and time.

The top email, virus, and spam senders in the selected time period.

Place your mouse over a bar in the graph to view a tooltip which includes the sender, count,
size, virus count, and spam count.

This widget may be viewed by Count, Size, Virus Count, and Spam Count.

The top email, virus, and spam recipients in the selected time period.

Place your mouse over a bar in the graph to view a tooltip which includes the recipient, count,
size, virus count, and spam count.

This widget may be viewed by Count, Size, Virus Count, and Spam Count.

The summary of spam and virus mail in the selected time period.

Place your mouse over a bar in the graph to view a tooltip which includes the date/time,
classifier, and count.

This widget may be viewed by Count and Size.

This widget can be also be displayed as a donut chart which includes charts for total mail,
virus mail, and spam mail.

The summary of email messages where the FortiMail detected viruses, spam, or neither in the
selected time period.

Place your mouse over a bar in the graph to view a tooltip which includes the date/time,
classifier, and count.

This widget may be viewed by Count, Size, Scan Speed, and Transfer Speed.

The summary of the number of email messages that the FortiSandbox unit is scanning in the
selected time period. Email messages are tracked as either clean, containing a malicious file,
or containing a malicious URL.

Place your mouse over a bar in the graph to view a tooltip which includes the date/time, clean,
malicious file, and malicious URL.

This widget requires a FortiSandbox.
The summary of spam, viruses, and not spam in the selected time period, including the

classifier details per category, the corresponding total number of every classifier, the subtotal
number, the subtotal percentage of every category, and the total number of all emails.
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Endpoints

Endpoints includes the following widgets:

Top Endpoint Vulnerability information about FortiClient endpoints including vulnerability name and CVE ID.
Vulnerabilities

Top Endpoint Vulnerability information about FortiClient endpoints including vulnerability name and CVE ID.
Vulnerabilities Only available in a Fabric ADOM.

(FortiClient)

Top Endpoint Vulnerability information about FortiClient endpoints including source IP address and device.

Devices with
Vulnerabilities

Top Endpoint Vulnerability information about FortiClient endpoints including source IP address and device.
Devices with Only available in a Fabric ADOM.
Vulnerabilities

(FortiClient)

User Vulnerabilities User vulnerabilities summary.
Summary

All Endpoints All endpoints.

All Endpoints All endpoints.

(FortiClient)

Top Endpoint Top threats from all endpoints.
Threats

Top Endpoints Top applications from all endpoints.
Applications Only available in a Fabric ADOM.

Fabric State of Security

Security Fabric includes the following widgets.

This information for this dashboard is available after you create a Security Fabric group in FortiGate and add it in
FortiAnalyzer. The Security Fabric can be selected in the settings options for each widget.

Security Fabric A report showing the security rating details of connected Security Fabric devices. Click a
Rating Report milestone to drill down and hover the cursor over data points to see more details.

Security Fabric The current and historical Security Fabric scores. The Historical Security Fabric Scores pane
Score displays your Security Fabric score over time and how it compares to the industry average

and the industry score range. You can hide the Historical Security Fabric Scores pane.

Security Fabric A topology map showing the logical structure of connected Security Fabric devices.
Topology
Best Practices Overview of the device best practices across regions of North America, Latin America, EMEA,
Overview and APAC.
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VPN

VPN includes the following widgets:

Top Dialup VPN The users accessing the network using SSL or IPsec over a VPN tunnel.
VPN Site-to-Site The names of VPN tunnels with Internet protocol security (IPsec) that are accessing the
network.
WiFi

WiFi includes the following widgets:

Authorized APs The names of authorized WiFi access points on the network.

Top Rogue APs The top SSID (service set identifiers) of unauthorized WiFi access points on the network.
Hover the cursor over data points to see the SSID and total live time.

Top SSID The top SSID (service set identifiers) of authorized WiFi access points on the network. Hover
the cursor over data points to see the SSID and bytes (sent and received).

Top SSID Over The historical SSID (service set identifiers) traffic of authorized WiFi access points on the
Time by Bandwidth  network.

WiFi Clients The top WiFi access points on the network by bandwidth/sessions.

FortiClient Software Inventory

FortiClient Software includes the following widget:

FortiClient The total number of apps installed, top apps, new apps installed, top apps by installs, and top
Software Inventory  hosts by number of apps.

loT

loT includes the following widget:

loT Inventory The total number of loT devices installed.

This includes summaries for the new loT apps installed, top loT apps, top loT
users, and top loT by number of hosts.

Threat (FortiClient)

Threat (FortiClient) includes the following widgets:

Threat The top threats to your network from risk applications, intrusion alerts, malicious websites,
and malware/botnets.

Only visible in a Fabric ADOM.
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Applications & Websites (FortiClient)

Applications & Websites (FortiClient) includes the following widgets:

Application The top applications used on the network, including application name, risk level, category,
sessions (blocked and allowed), and bytes (sent and received).

Only available in a Fabric ADOM.

Website Top website domains from recent traffic.
Only available in a Fabric ADOM.

Endpoints (FortiClient)

Endpoints (FortiClient) includes the following widgets:

Top Endpoint Vulnerability information about FortiClient endpoints including vulnerability name and CVE ID.
Vulnerabilities Only available in a Fabric ADOM.

(FortiClient)

Endpoint Devices Information about FortiClient endpoints including source IP address, device, and

vulnerabilities.
Only available in a Fabric ADOM.

All Endpoints All endpoints.
(FortiClient)

Traffic (FortiDDOS)

Traffic (FortibDOS) includes the following widgets:

Top Source Top source IP addresses from recent traffic.
(FortiDDoS) Only available in a Fabric ADOM.

Top Destination Top destination IP addresses from recent traffic.
(FortiDDoS) Only available in a Fabric ADOM.

Top Type Top types from recent traffic.

(FortiDDoS) Only available in a Fabric ADOM.

Traffic (FortiFirewall)

Traffic (FortiFirewall) includes the following widgets:
Top Sources The highest network traffic by source IP address and interface, sessions (blocked and
allowed), threat score (blocked and allowed), and bandwidth (sent and received).

Top The historical network traffic by country/region, sessions, bandwidth, or threat score.
Country/Region
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Top Policy Hits
Top Destinations

Traffic Over Time
by Sessions

Policy Hits Over

Time by Bandwidth

User Data Flow

Top policy hits from recent traffic.
Top destinations from recent traffic by bandwidth or sessions.

The historical destinations from recent traffic.

The historical policy hits from recent traffic.

Bandwidth breakdown of top user destination country/region or application usage.

VPN (FortiFirewall)

VPN (FortiFirewall) includes the following widgets:

Top Dialup VPN The users accessing the network using SSL or IPsec over a VPN tunnel.

VPN Site-to-Site The names of VPN tunnels with Internet protocol security (IPsec) that are accessing the

network.

Local System Performance

This dashboard monitors the system performance of the FortiAnalyzer unit running FortiView. It includes the following
widgets:

Multi Core CPU
Usage

Insert Rate vs
Receive Rate

CPU & Memory
Usage

Disk 1/0

Receive Rate vs
Forwarding Rate

Resource Usage
Average

Resource Usage
Peak

The usage status of a multi-core CPU.

The number of logs received vs the number of logs actively inserted into the database,
including the maximum and minimum rates.

* Receive rate: how many logs are being received.

* Insert rate: how many logs are being actively inserted into the database.
If the insert rate is higher than the log receive rate, then the database is rebuilding. The lag is
the number of logs waiting to be inserted.

The usage status of the CPU and memory.

The disk Transaction Rate (1/Os per second), Throughput (KB/s), or Utilization (%). The
Transaction Rate and Throughput graphs also show the maximum and minimum disk activity.

The number of logs received vs the number of logs forwarded out, including the maximum and
minimum rates.

¢ Receive rate: how many logs are being received.

¢ Forward rate: how many logs are being forwarded out.

Overview of average resource usage history across all devices.

Overview of peak resource usage history across all devices.
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Failed Top unauthorized connections from recent traffic.
Authentication

Attempts
System Events Top system events from recent traffic.
Admin Logins Top admin logins from recent traffic.

Global Threat Research

Global Threat Research includes the following widgets:

Worldwide Threat The top threats globally by industry based on UTC. The threat map can be viewed by Virus,

Prevalence By IPS, Botnet, and Application. The widget is available as a chord chart or map.
Industry - Today By default, the threat map displays information from accross all industries. You can change
(UTC) which industries are included in the chart by clicking the All Industries dropdown and removing

a check mark from any industries you want to exclude.
Global Threat Research data is from FortiGuard and not from FortiGate.

Local Threat Research

Local Threat Research includes the following widgets:

Local Threat The top threats based on the current ADOM. The threat map can be viewed by Virus, IPS,
Prevalence Botnet, and Application.

Hover your mouse over a datapoint in the chord chart to view additional details.
Local Threat Research data is from FortiGuard and not from FortiGate.

Using the Monitors dashboard

FortiView Monitors contain widgets that provide network and security information. Use the controls in the dashboard
toolbar to work with a dashboard.

Edit Layout Add, remove, resize, or move widgets on a predefined dashboard.

Devices Select the devices to include in the widget data.
The device list will also include a Security Fabric if available.

To select a Security Fabric, you need to first create a Security Fabric group in FortiGate and
add the Security Fabric group in FortiAnalyzer.

Time Period Select a time period from the dropdown menu, or set a custom time period.
Dark Mode Enable/disable dark mode. Dark mode shows a black background for the widgets in the
dashboard.
Refresh Refresh the data in the widgets.
Hide Side-menu or  Using the main toolbar, you can hide or show the tree menu on the left. In a typical SOC
Show Side-menu environment, the side menu is hidden and dashboards are displayed in full screen mode.
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Use the controls in the widget title bar to work with widgets.

Settings icon

View different chart
types

Hide or show a
data type

View more details

View a narrower
time period

Zoom in and out

Change the settings of the widget. Widgets have settings applicable to that widget, such as
how many of the top items to display, Time Period, Refresh Interval, and Chart Type.

Some widget settings let you choose different chart types such as the Disk I/O and Top
Countries widget. You can add these widgets multiple times and set each widget to show a
different chart type.

For widgets that show different data types, click a data type in the title bar to hide or show that
data type in the graph.

For example, in the Insert Rate vs Receive Rate widget, click Receive Rate or Insert Rate in
the title bar to hide or show that data. In the Disk I/O widget, click Read or Write in the title bar
to hide or show that data type.

Hover the cursor over a widget's data points to see more details.

Some widgets have buttons below the graph. Click and drag the buttons to view a narrower
time period.

For widgets that show information on a map such as the Top Threat Destinations widget, use
the scroll wheel to change the zoom level. Click and drag the map to view a different area.

Customizing the Monitors dashboard

You can add any widget to a custom or predefined dashboard. You can also move, resize, or delete widgets. You cannot

rename or delete a predefined dashboard. To reset a predefined dashboard to its default settings, click Dashboard
settings icon > Reset. The dashboard settings icon is visible when you mouse-over the dashboard in the tree menu.

To create a dashboard:

1. In FortiView > Monitors, click the menu icon for Custom Views.
2. From the shortcut menu, click Create New.

g

Specify the Name and whether you want to create a blank dashboard or use a template.

If you select From Template, specify which predefined dashboard you want to use as a template.
4. Click OK. The new dashboard appears in the tree menu.

o

Select widgets to include on the dashboard, and click Save Changes.

To display Security Fabric in Monitor:

Create a Security Fabric in FortiGate.
. Add the Security Fabric in FortiAnalyzer.

Select the Fabric State of Security dashboard.

1
2
3. Goto FortiView > Monitors.
4
5

Select the Security Fabric from the Devices menu.
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To add a widget:

1. Select the predefined or custom dashboard where you want to add a widget.

2. Click Add Widget to see a list of available widgets. Select the widget(s) you would like to add.
Some widgets can only be added when their corresponding log type is enabled in the ADOM, for example, the Top
Threats widget requires that Traffic logs are enabled. Widgets that cannot be added appear in gray and include an
information icon indicating what logs must be present in the ADOM before the widget can be added to the

dashboard.
Number of widgets: 1
Q
This chart requires following Log
® Threats 10 be enabled:Traffic
[1fi Threat Map [1fi Top Threat Destinations
ul Top Threats [# Top Threats by Weight & Count

[E] Top Virus Incidents over Time

3. When you have finished adding widgets, click Save Changes to close the Add Widget pane.

Creating custom widgets
Custom widgets can be created and added to custom dashboards in FortiView > Monitors.

To create a custom widget:

1. Goto FortiView > Monitors.

2. Goto a previously configured custom dashboard and click Add Widget.
For information on creating and managing dashboards, see Customizing the Monitors dashboard on page 106

3. Scroll to the Custom Widgets field and click Add Widget.
The Custom Widget Dashboard opens.
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4. Configure the following information for your widget.

Custom Widget Dashboard b 4

Bandwidth
65.2 GB

Name

Data Source

Time Frame

Chart Type

X Axis

Y Axis

Category

Name ‘custom—widgetz

Data Source s0C-sources

Time Frame ® Last 1 Hour v |19:40 - 20:40

Chart Type Bar Chart
X Axis Source

Y Axis Bandwidth
Show Top 10

Enter a name for the widget.

Select a data source for the widget. The following data sources are available:
e soc-sources
* soc-destinations
¢ soc-threats
¢ soc-sdwan-stats

Select the time frame.

You can specify a custom time frame by clicking Custom..., choosing the start and end
date, and clicking Apply.

Choose how the data is presented in the widget from one of the following options:
e Bar Chart
e Line Chart
* Pie Chart
e Donut Chart

Select the source type for the X axis. The sources available for selection depend on the
data source selected.

X Axis is only available when the chart type is Bar or Line.

Select the source type for the Y axis. The sources available for selection depend on the
data source selected.

Y Axis is only available when the chart type is Bar or Line.

Select the data category. The categories available for selection depend on the data
source selected.
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Category is only available when the chart type is Pie or Donut.

Value Select the data value. The values available for selection depend on the data source
selected.

Value is only available when the chart type is Pie or Donut.

Show Top Select the number of results that are displayed in the widget.
Options include the top 10, 20, 50, and 100 results.

5. Click Preview to preview the widget based on the information selected.

6. Click Create to save your changes.
After the widget has been created, you can select it in the Add Widget window to add it to your dashboard.
For information on managing your dashboard, see Using the Monitors dashboard on page 105.

To edit a custom widget:

1. Inany custom dashboard, select Add Widget.
2. Right-click on the custom widget that you want to edit, and click Edit
3. Edit the widget's settings, and click Update.

To delete a custom widget:

1. Inany custom dashboard, select Add Widget.
2. Right-click on the custom widget that you want to delete, and click Delete.

Enabling and disabling FortiView

The FortiAnalyzer FortiView module can be disabled for performance tuning through the CLI. When disabled, the GUI
will hide FortiView and stop background processing for this feature.

To disable FortiView in the CLI:
config system global

set disable-module fortiview-noc
end

To enable FortiView in the CLI:

config system global
unset disable-module

end
Disabling FortiView will cause the FortiAnalyzer to return the following error message when
the FortiGate attempts to retrieve FortiAnalyzer data: Server Error: FortiView\/NOC
function is disabled on FortiAnalyzer
The FortiGate GUI displays the message: Failed to retrieve FortiView data.
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Log View and Log Quota Management

You can view log information by device or by log group.
When rebuilding the SQL database, Log View is not available until the rebuild is complete.
Click the Show Progress link in the message to view the status of the SQL rebuild.

When ADOM s are enabled, each ADOM has its own information displayed in Log View.

Log View can display the real-time log or historical (Analytics) logs.
Log Browse can display logs from both the current, active log file and any compressed log files.

For more information, see Analytics and Archive logs on page 36.

Types of logs collected for each device

FortiAnalyzer can collect logs from the following device types: FortiADC, FortiAnalyzer, FortiAuthenticator, FortiCache,
FortiCarrier, FortiClient, FortiDDoS, FortiDeceptor, FortiEDR, FortiGate, Fortilsolator, FortiMail, FortiManager,
FortiNAC, FortiNDR (formerly FortiAl), FortiProxy, FortiSandbox, FortiSOAR, FortiWeb, and Syslog servers. Following is
a description of the types of logs FortiAnalyzer collects from each type of device:

Fabric All
FortiADC Event, Intrusion Prevention, Traffic
FortiAnalyzer Event, Application

FortiAuthenticator Event

FortiGate Traffic

Security: Antivirus, Intrusion Prevention, Application Control, Web Filter, File Filter, DNS,
Data Leak Prevention, Email Filter, Web Application Firewall, Vulnerability Scan, VolP,
FortiClient

Event: Endpoint, HA, Compliance, System, Router, VPN, User, WAN Opt. & Cache, WiFi

Ay

~ P File Filter logs are sent when the File Filter sensor is enabled in the
q FortiOS Web Filter profile. You can enable the File Filter sensor in
- FortiOS at Security Profiles > Web Filters.
FortiCarrier Traffic, Event, GTP
FortiCache Traffic, Event, Antivirus, Web Filter
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Log View and Log Quota Management

FortiClient Traffic, Event, Vulnerability Scan
FortiDDoS Event, Intrusion Prevention
FortiDeceptor Event
FortiEDR Event: Audit, System Event, Security Event
Fortilsolator Traffic, Event
FortiMail History, Event, Antivirus, Email Filter

L

Event, Antivirus, or Email Filter logs from FortiMail, you can click on the

\q, FortiMail logs support cross-log functionality. When viewing History,
— Session ID to see correlated logs.

When VDOMs are used to divide FortiMail into two or more virtual units,
Y cross-log searches display correlated log data from FortiMail's VDOMs,
‘Q' including those assigned to different ADOMs. VDOM results are
|| included only when performing the cross-log search through FortiMail's
- History log view, but results include correlated data for all available log
types (History, Events, Antivirus, and Email Filter).

FortiManager Event
FortiNAC Event
FortiNDR Event, NDR

Attack: Attack Chain, Malware
FortiProxy Traffic, Event, Antivirus, Web Filter
FortiSandbox Malware, Network Alerts
FortiSOAR Event
FortiWeb Event, Intrusion Prevention, Traffic

x You can view a subset of FortiWEB packet logs which contain additional

HTTP request information. See Viewing message details on page 113.

FortiWeb Cloud Attack, Event
Syslog Generic
NV The logs displayed on your FortiAnalyzer depends on the device type logging to it and the
‘9' enabled features.
- ADOMSs must be enabled to support non-FortiGate logging. In a Security Fabric ADOM, all

device logs are displayed.
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Traffic logs

Traffic logs record the traffic flowing through your FortiGate unit. Since traffic needs firewall policies to properly flow
through FortiGate, this type of logging is also called firewall policy logging. Firewall policies control all traffic attempting to
pass through the FortiGate unit, between FortiGate interfaces, zones, and VLAN sub-interfaces.

ZTNA logs: FortiAnalyzer syncs unified ZTNA logs with FortiGate. ZTNA logs are a sub-type of FortiGate traffic logs,
and can be viewed in Log View > FortiGate > Traffic. You can filter for ZTNA logs using the sub-type filter and optionally
create a custom view for ZTNA logs. See Custom views on page 121.

Security logs

Security logs (FortiGate) record all antivirus, web filtering, file filtering, application control, intrusion prevention, email
filtering, data leak prevention, vulnerability scan, and VolP activity on your managed devices.

DNS logs

DNS logs (FortiGate) record the DNS activity on your managed devices.

Event logs

Event logs record administration management and Fortinet device system activity, such as when a configuration
changes, or admin login or HA events occur. Event logs are important because they record Fortinet device system
activity which provides valuable information about how your Fortinet unit is performing. FortiGate event logs includes
System, Router, VPN, User, and WiFi menu objects to provide you with more granularity when viewing and searching
log data.

Application Logs

Application logs record playbook and incident activity on FortiAnalyzer. Logs are generated and stored separately for
each ADOM. Application logs can only be viewed on the local FortiAnalyzer.

Fabric (SIEM) Logs

Fabric logs are a licensed feature that enables FortiAnalyzer's SIEM capabilities to parse, normalize, and correlate logs
from Fortinet products as well as security event logs of Windows and Linux hosts (with Fabric Agent integration). When
licensed, parsing is predefined by FortiAnalyzer and does not require manual configuration by administrators.

\{ A SIEM database is automatically created for Fabric ADOMs once a SIEM license has been

applied to FortiAnalyzer and Fabric devices begin logging. Past logs and imported log files are
notincluded in the SIEM database.
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Log messages

You can view log information by device or by log group.

Viewing the log message list of a specific log type

You can find FortiMail and FortiWeb logs in their default ADOMs.

To view the log message list:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type from the tree menu.

The corresponding log messages list is displayed.

Viewing message details

To view message details:

1. Double-click a message in the message list.

The details pane is displayed to the right of the message list, with the fields categorized in tree view.

[Add Fitter

# | Date/Time
1 16:09:24
2 160924
3 160924
4 1609:24
5 160924
6 160924
7 160924
8 160924
9 160924
10 160924
1160924
12 160924
13 160924

You can display the log details pane below the message list by clicking the Bottom icon in the log details pane.
When the log details pane is displayed below the message list, you can move it to the right of the log message list by
clicking the Righticon. This is sometimes referred to as docking the pane to the bottom or right of the screen.

Device ID Action
FGVMOU2TM22( vclose
FGVMO02TM22( vaccept
FGVMO02TM22( vaccept
FGVMO02TM22( vaccept
FGVMO02TM22( vaccept
FGVMO02TM22( vaccept
FGVMO02TM22C client-rst
FGVMO02TM22( pass
FGVMO02TM22( pass
FGVMO02TM22( vclose
FGVMO02TM22( vaccept
FGVMO02TM22C client-rst
FGVMO02TM22( vaccept

Source

Kit Herman(Kit%20Hermal
Skylar Khan(Skylar%20Khz
Skylar Khan(Skylar%20Khz
Skylar Khan(Skylar%20Khz
Skylar Khan(Skylar%20Khz
Skylar Khan(Skylar%20Khz
Kit Herman(Kit%20Herma
Kit Herman(10.2.0.17)

Kit Herman(10.2.0.17)

Kit Herman(Kit%20Herma
Skylar Khan(Skylar%20Khz
Kit Herman(Kit%20Herma
Skylar Khan(Skylar%20Khz
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User

Destination IP Su & Security
Level

10.100.88.5 teps
= General
88 DN LogiD
Session D
795142 | NTH Tran Display
w7126 i Virtual Domain
Source
93.207.11 NTi @ Destination
= Action
140.142.11 NTH “Action
5104261178 | HT Poliey 1D
Policy UUID
10.10088.5 SSL @ Application
‘Appication Category
10.100.88.5 SsL Application Control List
10.10088.5 tep) Protocal
Service
8588 DN = Data
" & Duation
19817186 | HT *  eceived Pacets
_ 88 DN Sent Packets
= Type
Sub Type

Type

x
By Fo
o a e
- x
0000000013

99328
noop
root

close
3
b22219b8-ced5-51ed-

unknown
default

6
tcp/8013

1
3
4
18008/13208 |

forward
traffic

113



Log View and Log Quota Management

The log details pane provides shortcuts for adding or replacing filters and for showing or hiding a column. Right-click a

log field to select an option.

-— X
= logDetails

ADOM root
ADOM OID 3
Admin Profile Super_User
Changes ‘admin’ login accepted from to/
Date 2023-03-16
Date/Time 146:00:31
Description User login/logout successful
Destination End User ID 1
Destination Endpoint ID 1
Device ID FAZ-VMTM
Device Name FRC-FAZL
Device Time 2023-03-16 16:00:31
1D Q0001010018

2
Message @ Add AND Filter "Level = information” pein accepte
Operation &, Add AND Filter "Level != information”
Performed . . .
Session ID @ Add OR Filter "Level = information”
Sub Type &, Add OR Filter "Level '= information”
2:: Zone Q Replace with Filter "Level = information”
Type Q, Replace with Filter "Level != information”
UEBAENdpd o Add to Columns
UEBA User |
User I CopyValue
User From W) T

9 If the log message contains UTM logs, you can click the UTM log icon in the log details pane to

- open the UTM log view window.

Ay

If the log message contains IPS signature information, you can click the IPS signature link
under Attack Name to view the IPS Signature details in a dialog window.

To view FortiWEB packet logs:

1. Inthe Type column, click Attack log.
2. Double-click a message in the list to open the log details pane.
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3. Inthe Datafield, click the Device icon. The View Attack Content dialog displays a subset of FortiWwEB's packet log
(headers, arguments, and a truncated HTTP body). The maximum size of the packet log is 8 KB.

=I-logDetails
L. Action Alert
Back End Service unknown
| Bot Detection Information none
| Cipher Suite none
__Client Device ID none
Data &

ata rorma b&a/brt

i.Date/Time 01-10 14:59

x The Device icon is also available in the Data column. To display the column, click Column

Settings, and select Data from the dropdown.

Customizing displayed columns
The columns displayed in the log message list can be customized and reordered as needed.

To customize what columns to display:

1. Inthe toolbar of the log message list view, click Column Settings and select a column to hide or display.
The available columns vary depending on the device and log type.
2. Toreset to the default columns, click Reset to Default.

3. Toadd other columns, click More Columns. In the Column Settings dialog, select the columns to show or hide.
4. Click OK.
\‘ ! ’I
q You can also add or remove a log field column in the log details pane, by right-clicking a
- log field and selecting Add [log field name] or Remove [log field name].

To change the order of the displayed columns:

Place the cursor in the column title and move a column by drag and drop.

Customizing default columns

In Log View, you can select the columns that are displayed as the default by clicking Save as Default in the Column
Settings dialog. See Customizing displayed columns on page 115.
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Column Settings

@ Date/Time

G Device ID
Gsub Type
Quser

B Message

& 0peration

& performed On
B Changes
QApomM
OADOM Lock Status
OADOM Name
OADOM 0ID
OAction

Save as Default “ Cancel

4

Customizing the default column view can only be done on a Super_User administrator profile.
Default column customization is applied per devtype/logtype across all ADOMs.
The GUI displays columns based on the following order of priority:

1. Displays the user’s column customizations (if defined).
2. Displays the default columns set by the Super_User administrator (if defined).
3. Displays the system default columns.

Customized default column configuration is preserved during upgrades.

x To reset default columns to the system default, deselect all columns from the Column Settings

selection menu and then select Set as Default.

Filtering messages

You can apply filters to the message list. Filters are not case-sensitive by default. If available, select Tools > Case
Sensitive Search to create case-sensitive filters.
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Filtering messages using filters in the toolbar

1. Go to the view you want.

Filter mode search

Switching between filter
mode search and text mode
search

Text mode search

Search operators and syntax

CLI string “freestyle” search

In the Add Filter box, click the plus icon and select a filter from the dropdown
list. Then select =, !=, >, or < and type a value for the filter. Click Apply to add
the filter.

Click the plus icon again to add another filter. It will be added with an AND
relationship to the previous filter. You can click the operator in the Add Filter
box to toggle between AND and OR, or click a filter to edit the value.

When adding a filter, only displayed columns are available in the dropdown
list.

At the right end of the Add Filter box, click the Switch to text mode icon to
switch to a text mode search. When in text mode search, click the Switch to
filter mode icon to switch to a filter mode search.

In text mode search, enter the search criteria (log field names and values).

If available, click the help icon at the right end of the Add Filter box to view
search operators and syntax. See also Filter search operators and syntax on
page 119.

Searches the string within the indexed fields configured using the CLI
command: config ts-index-field

For example, if the indexed fields have been configured using these CLI
commands:
config system sqgl
config ts-index-field
edit "FGT-traffic"
set value "app,dstip,proto,service,srcip,user,utmaction"
next
end
end
Then if you type “Skype” in the Add Filter box, FortiAnalyzer searches for
“Skype” within these indexed fields:
app,dstip, proto, service, srcip,user and utmaction

You can combine freestyle search with other search methods, for example:
Skype user=David

2. Inthetoolbar, make other selections such as devices, time period, which columns to display, etc.

name, including Source Object and Destination Object.See the
FortiGate/FortiOS Administration Guide for more information about UUID logging.

\‘é', UUID logging must be enabled in FortiGate/FortiOS to filter FortiGate traffic logs by object

Filtering messages using the right-click menu

In the log message table view, right-click an entry to select a filter criteria from the menu. Depending on the column in
which your cursor is placed when you right-click, Log View uses the column value as the filter criteria. This context-
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sensitive filter is only available for certain columns.
You can perform the following filter actions from the right-click menu:

 Add afilter entry with an AND condition, such as AND event type=traffic

 Add afilter entry with an AND negate condition, suchas AND event type!=traffic
» Add afilter entry with an OR condition, such as OR event type=traffic

 Add afilter entry with an OR negate condition, suchas OR event type!=traffic

» Replace all filters with the selected entry, such as event type=utm

» Replace all filters with the selected negate, such as event type!=utm

If no filter is used before right-click filtering, the new filter will be added no matter which option is selected in the right-click
menu.

NP To see log field name of a filter/column, right-click the column of a log entry and select a
‘?' context-sensitive filter. The Add Filter box shows log field name.
- Context-sensitive filters are available for each log field in the log details pane. See Viewing

message details on page 113.

Filtering messages using smart action filters

For Log View windows that have an Action column, the Action column displays smart information according to policy (log
field action) and utmaction (UTM profile action).

The Action column displays a green checkmark Accept icon when both policy and UTM profile allow the traffic to pass
through, that is, both the log field action and UTM profile action specify allow to this traffic.

The Action column displays a red X Deny icon and the reason when either the log field action or UTM profile action deny
the traffic.

If the traffic is denied due to policy, the deny reason is based on the policy log field action.

If the traffic is denied due to UTM profile, the deny reason is based on the FortiView threattype from craction.
craction shows which type of threat triggered the UTM action. The threattype, craction, and crscore fields are
configured in FortiGate in Log & Report. For more information, see the FortiOS - Log Message Reference in the Fortinet
Document Library.

A filter applied to the Action column is always a smart action filter.

The smart action filter uses the FortiGate UTM profile to determine what the Action column
displays. If the FortiGate UTM profile has set an action to allow, then the Action column will
M, display that line with a green Accepticon, even if the craction field defines that traffic as a
? threat. The green Accept icon does not display any explanation.
= In the scenario where the craction field defines the traffic as a threat but the FortiGate UTM
profile has set an action to allow, that line in the Log View Action column displays a green
Accepticon. The green Accepticon does not display any explanation.
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Filter search operators and syntax

Operators or symbols Syntax

And Find log entries containing all the search terms. Connect the terms with a space
character, or “and”. Examples:
1. user=henry group=sales
2. user=henry and group=sales

Or Find log entries containing any of the search terms. Separate the terms with “or”
oracomma “,”. Examples:
1. user=henry or srcip=10.1.0.15

2. user=henry,linda

Not Find log entries that do NOT contain the search terms. Add “-” before the field
name. Example:

-user=henry

>, < Find log entries greater than or less than a value, or within a range. This operator
only applies to integer fields. Example:

policyid>1 and policyid<10

IP subnet, range, subnet list Find log entries within a certain IP subnet, IP range, subnet list, or subnet group.
search Examples:

1. srcip=192.168.1.0/24

2. srcip=10.1.0.1-10.1.0.254

3. srcip=SubnetGrp Name A

4. srcip=Subnet Name A

Wildcard search You can use wildcard searches for all field types. Examples:
1. srcip=192.168.1.*
2. policyid=1*

3. user=*

Ay
S L4
q Log View also supports the regex (regular expresion) syntax.

Filtering FortiClient log messages in FortiGate traffic logs

For FortiClient endpoints registered to FortiGate devices, you can filter log messages in FortiGate traffic log files that are
triggered by FortiClient.

To Filter FortiClient log messages:

1. Goto Log View > FortiGate > Traffic.
2. Inthe Add Filter box, type fct _devid=*. Alist of FortiGate traffic logs triggered by FortiClient is displayed.
3. Inthe message log list, select a FortiGate traffic log to view the details in the bottom pane.
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4. Click the FortiClient tab, and double-click a FortiClient traffic log to see details.
The FortiClient tab is available only when the FortiGate traffic logs reference FortiClient traffic logs.

Monitoring all types of security and event logs from FortiGate devices

You can monitor all types of security and event logs from FortiGate devices in:

* Log View > FortiGate > Security > Summary
» Log View > FortiGate > Event > Summary

All widgets in these dashboards can be filtered by FortiGate device and timeframe in the toolbar. The widgets can be
toggled on/off from the Toggle Widgets dropdown. By clicking an event name in the widget, you can open a list view of
those logs filtered by the devices and timeframe you selected on the dashboard.

Security: Summary dashboard:

Toggle Widgets v All Devices ¥ @ Last 1 Hour v 2023-04-06 12:02:00 - 2023-04-06 13:02:00
ﬂ AntiVirus x E Application Control x
Top Virus/Botnet & Action = Count & u Top Category = Action = Count % H
EICAR_TEST_FILE blocked 240 ] Network.Service pass 30410 I
VBA/Agent.LAG!tr.dldr blocked 1 I Web.Client pass 16460  n—
Social. Media pass 3179 |
General.Interest pass 1725 n
Video/Audio pass 1605 m
Collaboration pass 1126 1
2 0% 10
n Intrusion Prevention x m Anomaly
Top Attack + Action = Count = u Top Attack = Action + Count =
MS.5MB.Server.SMB1.MID.FID.Parsin dropped 11 I ip_dst_session detected 12
ip_src_session detected 8
tep_port_scan detected 1

ll‘
w Ll x

Event: Summary dashboard:

The summary dashboard for event logs includes a Total Events widget, which displays a line chart of the event logs by
level. You can hover your cursor over the line chart to display a summary of the count and time at that point. This widget
cannot be toggled off.
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Toggle Widgets v All Devices v @ Last 4 Hours v 2023-03-29 12:16:00 - 2023-03-29 16:16:00

Total Events

System Events M VPN Events
View general system events. View events relating to VPN.
Event Name Level Count u Event Name Level Count

FortiCloud ai

FortiCloud a

Sy

R

Viewing historical and real-time logs

By default, Log View displays historical logs. Custom View and Chart Builder are only available in historical log view.
To view real-time logs, in the log message list view toolbar, click Tools > Real-time Log.

To switch back to historical log view, click Tools > Historical Log.

Viewing raw and formatted logs

By default, Log View displays formatted logs. The log view you select affects available view options. You cannot
customize columns when viewing raw logs.

To view raw logs, in the log message list view toolbar, click Tools > Display Raw.
To switch back to formatted log view, click Tools > Formatted Log.

For more information about FortiGate raw logs, see the FortiGate Log Message Reference in the Fortinet Document
Library. For more information about raw logs of other devices, see the Log Message Reference for the platform type.

Custom views

Use Custom View to save the filter setting, device selection, and the time period you have specified.

Custom views can be set as public or private. Public custom views can be viewed by all administrators, whereas private
custom views can only be viewed by the creator. Users cannot make changes to custom views created by other
administrators but can right-click the view and select Save As to copy it.

To create a new custom view:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.

2. Goto Log View, and select a log type.

3. Inthe content pane, customize the log view as needed by adding filters, specifying devices, and/or specifying a time
period.
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4. In the toolbar, click the custom view icon.

Save as New Custom View

Name
Log Type Event
Devices All Devices

Time Period  Last 1 Hour
Public

Others can see this Custom View

Privacy ©

5. Inthe Name field, type a name for the new custom view.
6. Inthe Privacy field, select the custom view visibility.

« Public: Others can view this custom view displayed in Log View > Custom View.

« Private: Only you can see this custom view displayed in Log View > Custom View.
7. Click OK.

To edit a custom view:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.

2. Gotothe Log View > Custom View, and select the custom view to be updated.

3. Inthe toolbar, edit the filter settings.

4. Inthe tree menu, select the menu icon next to your custom view, and select Save.

To rename a custom view:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.

2. Gotothe Log View > Custom View.

3. Inthe tree menu, select the menu icon next to your custom view, and select Rename.
4. Change the name of the custom view, and click OK.

To change the visibility of a custom view:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.

2. Gotothe Log View > Custom View.

3. Inthe tree menu, select the menu icon next to your custom view, and select Share with Others.
4. Setthe Privacy field to On: Public or Off: Private, and click OK.

Downloading log messages

You can download historical log messages to the management computer as a text or CSV file. You cannot download
real-time log messages.

To download log messages:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type.
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3. Inthe toolbar, click Tools > Download.

4. Inthe Download Logs dialog box, configure download options:
 Inthe Log file format dropdown list, select Text or CSV.
« To compress the downloaded file, select Compress With gzip.

« Todownload only the current log message page, select Current Page. To download all the pages in the log
message list, select All Pages.

5. Click Download.

Creating charts with Chart Builder

Ay
‘?' You can also create charts in Reports > Report Definitions > Chart Library. See Chart library
- on page 263

Log View includes a Chart Builder for you to build custom charts for each type of log messages.

To create charts with Chart Builder:

If using ADOMs, ensure that you are in the correct ADOM.

Go to Log View, and select a log type.

In the toolbar, click Tools > Chart Builder.

In the Chart Builder dialog box, configure the chart and click Save.

Ao b=

Name Type a name for the chart.

Columns Select which columns of data to include in the chart based on the log
messages that are displayed on the Log View page.

Group By Select how to group data in the chart.

Order By Select how to order data in the chart.

Sort Select a sort order for data in the chart.

Show Limit Enter the number of rows to be shown per page.
Device Displays the device(s) selected on the Log View page.
Time Frame Displays the time frame selected on the Log View page.
Query Displays the query being built.

Preview Displays a preview of the chart.

Once a chart has been created, it can be inserted into a new report. See Reports Editor tab on page 251.

User and endpoint ID log fields

Log information about user and endpoint IDs is available in Log View and can be viewed by configuring these fields as
displayed columns. See Customizing displayed columns on page 115.
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UEBA User ID and UEBA Endpoint ID fields with values below 1024 are special cases which are tracked by
FortiAnalyzer's UEBA. See the table below for information on what each value represents.

Value Name

1 EPEU_NOT_IMPL_DEVTYPE
EPEU_NOT_IMPL_LOGTYPE
EPEU_NO_ENOUGH_INFO

EPEU_INTERNAL_ERROR

2
3

4 EPEU_CANNOT_GET_UID

5

6 EPEU_HA_BACKUP_ASK_FAIL
7

EPEU_HA_REBUILD_THROTTLE

Description

EP and EU not implemented for this devtype.
EP and EU not implemented for this logtype.
Not enough information to identify an EP or EU.
Cannot get a UID range (max limit reached).
Internal error (e.g. cannot allocate memory).
Ask primary failed and could not recover.

Prevent too many EP and EU requests during
database rebuilding.

8 EPEU_CLIENT_ASK_FAIL Ask server failed and could not recover.
10 EPEU_NOT_SUPPORT_LOGVER Log version is not supported.
100 EPEU ID LOCAL _HOST Local host event, such as a local host event in
FortiGate.
101 EPEU_ID_UNTRACK_IP IP is public and related interface role is not LAN.
102 EPEU_ID_UNTRACK_LOGID Log ID is not identified.
103 EPEU_ID_UNTRACK_TOOMANYIP Too many IPs on one MAC.
104 EPEU_ID_UNTRACK_VPN_IP Do not track VPN IP.
W0 When a device has FortiClient installed and FortiAnalyzer is able to retrieve endpoint
‘9' information, all interfaces of this device will belong to a single endpoint with the FCT-UID as
- the key. For devices without FortiClient that have multiple NICs, each interface appears as a

separate endpoint.

) ! /. The User ID and UEBA User ID fields are interchangeable and contain the same information.
? The Endpoint ID and UEBA Endpoint ID fields are interchangeable and contain the same
= information.

Log groups

You can group devices into log groups. You can view FortiView summaries, display logs, generate reports, or create
handlers for a log group. Log groups are virtual so they do not have SQL databases or occupy additional disk space.

\,

S L4
9 A maximum of 100 devices can be included in a log group.
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When you add a device with VDOM s to a log group, all VDOMs are automatically added.

To create a new log group:

1. GotoLog View > Log Group.

2. Inthe content pane toolbar, click Create New.
3.

4. Click OK.

Log browse

When a log file reaches its maximum size or a scheduled time, FortiAnalyzer rolls the active log file by renaming the file.
The file name is in the form of x10g.N. 1og, where x is a letter indicating the log type, and N is a unique number
corresponding to the time the first log entry was received. For information about setting the maximum file size and log

rolling options, see Device logs on page 335.

Log Browse displays log files stored for both devices and the FortiAnalyzer itself, and you can log in the compressed

phase of the log workflow.

In the Create New Log Group dialog box, type a log group name and add devices to the log group.

Ay

display its log messages.

‘Q' In Collector mode, if you want to view the latest log messages, select the latest log file to

To view log files:

1. GotoLog View > Log Browse

2. Selectalog file, and click Display to open the log file and display the log messages in formatted view.

You can perform all the same actions as with the log message list. See Viewing message details on page 113.

@ Dashboard All Devices v @ Last 1 Day v May 24 To May 25
8 Device Manager Search or type filters
& Fortiview >
I M LogView . O | Device Name + Device ID +
% Fabric O  Enterprise_Second_Floor FGVMO02TM22025319%
® FortiGate [m} Enterprise_Second_Floor FGVMO02TM22025319%
FortiSandbox O  Enterprise_FortiSandbox FSAVMOTM23000365
FortiAnalyzer O Enterprise_First_Floor FGVMO2TM22025461
2 Custom View (2) [ Enterprise_First_Floor FGYMO02TM22025461
O Enterprise_Core FGVMO2TM22025906
[ Log Group O  Enterprise_Core FGVM02TM22025906
@ Fabric View > O  Branch_Office 02 FGVMO2TM22012576
Incidents & Events > O Branch_Office_02 FGVM02TM22012576
B Reports ’ | O | Branch Office 01 FGVMO2TM22013394
B System Seccings > 'O Branch Office 01 FGVMO02TM22013394
O self FAZVMSTM22005211
O self FAZVMSTM22005211

FL:RTINET
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root
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root

root

root

root

root

root

root

root
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Importing a log file

Imported log files can be useful when restoring data or loading log data for temporary use. For example, if you have older
log files from a device, you can import these logs to the FortiAnalyzer unit so that you can generate reports containing
older data.

Log files can also be imported into a different FortiAnalyzer unit. Before importing the log file you must add all devices
included in the log file to the importing FortiAnalyzer.

To insert imported logs into the SQL database, the config system sqgl start-time and rebuild-event-
start-time must be older than the date of the logs that are imported and the storage policy for analytic data (the Keep
Logs for Analytics field) must also extend back far enough.

To set the SQL start time and rebuild event start time using CLI commands:

config system sqgl

set start-time <start-time-and-date>

set rebuild-event-start-time <start-time-and-date>
end

Where <start-time-and-date>isinthe formathh:mm yyyy/mm/dd.

To import a log file:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View > Log Browse and click Import in the toolbar.

3. Inthe Device dropdown list, select the device the imported log file belongs to or select [Taken From Imported File] to
read the device ID from the log file.

If you select [Taken From Imported File], the log file must contain a device idfieldinits log messages.

4. Drag and drop the log file onto the dialog box, or click Add Files and locate the file to be imported on your local
computer.

5. Click OK. A message appears, stating that the upload is beginning, but will be canceled if you leave the page.
6. Click OK. The upload time varies depending on the size of the file and the speed of the connection.
After the log file is successfully uploaded, FortiAnalyzer inspects the file:

» Ifthe device idfield in the uploaded log file does not match the device, the import fails. Click Return to try
again.

« If you selected [Taken From Imported File] and the FortiAnalyzer unit’s device list does not currently contain
that device, an error is displayed stating Invalid Device ID.

Downloading a log file

You can download a log file to save it as a backup or to use outside the FortiAnalyzer unit. The download consists of
either the entire log file, or a partial log file, as selected by your current log view filter settings and, if downloading a raw
file, the time span specified.

To download a log file:

1. Goto Log View > Log Browse and select the log file that you want to download.
2. Inthe toolbar, click Download.
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3. Inthe Download Log File(s) dialog box, configure download options:

« Inthe Log file format dropdown list, select Native, Text, or CSV.

« If you want to compress the downloaded file, select Compress with gzip.
4. Click Download.

Deleting log files

To delete log files:

1. GotoLog View > Log Browse.
2. Select one or more files and click Delete.
3. Click OK to confirm.

Log and file storage

Logs and files are stored on the FortiAnalyzer hard disks. Logs are also temporarily stored in the SQL database.
When a SIEM license is added, a SIEM database is created to store normalized Fabric logs.

When ADOMs are enabled, settings can be specified for each ADOM that apply only to the devices in it. When ADOMs
are disabled, the settings apply to all managed devices.

Data policy and disk utilization settings for devices are collectively called log storage settings. Global log and file storage
settings apply to all logs and files, regardless of log storage settings (see File Management on page 339). Both the global
and log storage settings are always active.

NP The log rate and log volume per ADOM can be viewed through the CLI using the following

‘?' commands:
diagnose fortilogd lograte-adom <name>

diagnose fortilogd logvol-adom <name>

Disk space allocation

On the FortiAnalyzer, the system reserves 5% to 20% of the disk space for system usage and unexpected quota
overflow. The remaining 80% to 95% of the disk space is available for allocation to devices.

Reports are stored in the reserved space.

Small Disk (up to 500GB) The system reserves either 20% or 50GB of disk space, whichever is smaller.
Medium Disk (up to 1TB) The system reserves either 15% or 100GB of disk space, whichever is smaller.
Large Disk (up to 3TB) The system reserves either 10% or 200GB of disk space, whichever is smaller.
Very Large Disk (5TB and The system reserves either 5% or 300GB of disk space, whichever is smaller.
higher)
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\‘é’, The RAID level you select determines the disk size and the reserved disk quota level. For

example, a FortiAnalyzer 1000C with four 1TB disks configured in RAID 10 is considered a
large disk, so 10%, or 100GB, of disk space is reserved.

Log and file workflow

When devices send logs to a FortiAnalyzer unit, the logs enter the following workflow automatically:

1. Compressed logs are received and saved in a log file on the FortiAnalyzer disks.
When a log file reaches a specified size, FortiAnalyzer rolls it over and archives it, and creates a new log file to
receive incoming logs. You can specify the size at which the log file rolls over. See Device logs on page 335.
2. Logs are indexed in the database to support analysis.
You can specify how long to keep logs indexed using a data policy. See Log storage information on page 130.
3. Logs are purged from the database, but remain compressed in a log file on the FortiAnalyzer disks.
4. Logs are deleted from the FortiAnalyzer disks.
You can specify how long to keep logs using a data policy. See Log storage information on page 130.

FortiAnalyzer
- ™
Logs
compressed
and savedto '
log file .~ N

Logs indexed
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Log file rolls
over and
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Logs purged
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<« | Il
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-
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In the indexed phase, logs are indexed in the database for a specified length of time so they can be used for analysis.
Indexed, or Analytics, logs are considered online, and details about them can be used viewed in the FortiView, Log View,
and Incidents & Events panes. You can also generate reports about the logs in the Reports pane.
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In the compressed phase, logs are compressed and archived in FortiAnalyzer disks for a specified length of time for the
purpose of retention. Compressed, or Archived, logs are considered offline, and their details cannot be immediately
viewed or used to generate reports.

The following table summarizes the differences between indexed and compressed log phases:

Log Phase Location Immediate Analytic Support

Indexed Compressed in log file and Yes. Logs are available for analytic use in FortiView,
indexed in database Incidents & Events, and Reports.

Compressed Compressed in log file No.

Automatic deletion

Logs and files are automatically deleted from the FortiAnalyzer unit according to the following settings:

» Global automatic file deletion
File management settings specify when to delete the oldest Archive logs, quarantined files, reports, and archived
files from disks, regardless of the log storage settings. For more information, see File Management on page 339.

» Data policy
Data policies specify how long to store Analytics and Archive logs for each device. When the specified length of time
expires, Archive logs for the device are automatically deleted from the FortiAnalyzer device's disks.

» Disk utilization
Disk utilization settings delete the oldest Archive logs for each device when the allotted disk space is filled. The
allotted disk space is defined by the log storage settings. Alerts warn you when the disk space usage reaches a
configured percentage.

When log trimming is performed by disk quota enforcement, tables from both the SQL and
SIEM databases are considered together, and the oldest table, identified by the timestamp
ﬂ of logs inside, is timmed. The process repeats until the quota is within the defined
I threshold. The SIEM database is always partitioned by day, whereas the size of the SQL

database partition can be configured in FortiAnalyzer settings. For information on SIEM
logs, see Types of logs collected for each device on page 110.

All deletion policies are active on the FortiAnalyzer unit at all times, and you should carefully configure each policy. For
example, if the disk fullness policy for a device hits its threshold before the global automatic file deletion policy for the
FortiAnalyzer unit, Archive logs for the affected device are automatically deleted. Conversely, if the global automatic file
deletion policy hits its threshold first, the oldest Archive logs on the FortiAnalyzer unit are automatically deleted
regardless of the log storage settings associated with the device.

The following table summarizes the automatic deletion polices:

Policy Scope Trigger
Global automatic file  All logs, files, and When the specified length of time expires, old files are automatically
deletion reports on the deleted. This policy applies to all files in the system regardless of the
system data policy settings associated with devices.
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Policy Scope Trigger

Data policy Logs for the device When the specified length of retention time expires, old Archive logs
with which the data for the device are deleted. This policy affects only Archive logs for the
policy is associated device with which the data policy is associated.

Disk utilization Logs for the device When the specified threshold is reached for the allotted amount of
with which the log disk space for the device, the oldest Archive logs are deleted for the
storage settings are device. This policy affects only Archive logs for the device with which
associated the log storage settings are associated.

Logs for deleted devices

When you delete one or more devices from FortiAnalyzer, the raw log files and archive packets are deleted, and the
action is recorded in the local event log. However, the logs that have been inserted into the SQL database are not
deleted from the SQL database. As a result, logs for the deleted devices might display in the Log View and FortiView
panes, and any reports based on the logs might include results.

The following are ways you can remove logs from the SQL database for deleted devices.

» Rebuild the SQL database for the ADOM to which deleted devices belonged or rebuild the entire SQL database.

« Configure the log storage policy. When the deleted device logs are older than the Keep Logs for Analytics setting,
they are deleted. Also, when analytic logs exceed their disk quota, the SQL database is trimmed starting with the
oldest database tables. For more information, see Configuring log storage policy on page 132.

» Configure global automatic file deletion settings in System Settings > Advanced > File Management. When the

deleted device logs are older than the configured setting, they are deleted. For more information, see File
Management on page 339.

Al
‘Q' File Management configures global settings that override other log storage settings and
- apply to all ADOMs.

Log storage information

To view log storage information and to configure log storage policies, go to System Settings > Storage Info.
If ADOMs are enabled, you can view and configure the data policies and disk usage for each ADOM.

The log storage policy affects only the logs and databases of the devices associated with the log storage policy. Reports
are not affected. See Disk space allocation on page 127.
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The following information and options are available:
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Search

Name
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(Actual/Config Days)

Archive
(Actual/Config Days)

Max Storage

Analytics Usage
(Used/Max)

Archive Usage
(Used/Max)

Storage information

To view log storage policy and statistics, go to System Seftings > ADOMs, select an ADOM, and click View Storage Info.
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Edit the selected ADOM's log storage policy.

Refresh the page.

Enter a search term to search the list.

The name of the ADOM.
ADOMs are listed in two groups: FortiGates and Other Device Types.

The age, in days, of the oldest Analytics logs (Actual Days), and the number of days
Analytics logs will be kept according to the data policy (Config Days).

The age, in days, of the oldest Archive logs (Actual Days) and the number of days
Archive logs will be kept according to the data policy (Config Days).

The maximum disk space allotted to the ADOM (for both Analytics and Archive logs).

See Disk space allocation on page 127 for more information.

How much disk space Analytics logs have used, and the maximum disk space allotted

for them.

How much disk space Archive logs have used and the maximum disk space allotted for

them.

Alternatively, you can right-click or select an ADOM in the list and click Edit.
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The top part of Storage Info shows visualizations of disk space usage for Analytic and Archive logs where the policy
diagrams show an overview and the graphs show disk space usage details. The bottom part shows the log storage
policy.

Analytics Policy Analytics Details Show Up toToday + Max Line:[]
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2250000 / \
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The policy diagram shows the percentage of the disk space quota that is used. Hover your cursor over the diagram to
view the used, free, and total allotted disk space. The configured length of time that logs are stored is also shown.

The graphs show the amount disk space used over time. Click Max Line to show a line on the graph for the total space
allotted. Hover over a spot in the graph to view the used and available disk space at that specific date and time. Click the
graph to view a breakdown of the disk space usage by device.

Analytics Storage Statistics - Last 15 Days

Device Name Analytics Usage Average Log Rate (logs/sec) Peak Log Rate (logs/sec)
FGT37D0000000000 743.1GB 38.35% 1087.14 1615.27
FGBO0CO000000000 221.4 MB 0.01% 424 35.58

Weixixixi_WiFi 3.1GB 0.16% 4.48 32,80
FG3K2D0000000000 513 GB 2.65% 77.29 78174
FG1K2DOD00000000 716.4 GB 36.97% 1048.14 2376.82
FG100D0000000000 423.8GB 21.87% 619.99 1726.02

When the used quota approaches 100 percent, a warning message displays when accessing the Storage Statistics
pane.

Warning

Analytic is using 89% of allocated disk space.
Archive is using 88% of allocated disk space.

Please click "Configure Now" button to increase ADOM quota.

E=

Click Configure Now to open the Edit Log Storage Policy dialog box where you can adjust log storage policies to prevent
running out of allocated space (see Configuring log storage policy on page 132), or click Remind Me Later to resolve the
issue another time.

Configuring log storage policy

The log storage policy affects the logs and databases of the devices associated with the log storage policy.
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If you change log storage settings, the new date ranges affect Analytics and Archive logs

A currently in the FortiAnalyzer device. Depending on the date change, Analytics logs might be
purged from the database, Archive logs might be added back to the database, and Archive
logs outside the date range might be deleted.

To configure log storage settings:

1. Go to System Settings > ADOMs

2. Double-click on an ADOM, right-click on an ADOM and then select Edit from the menu, or select the ADOM then
click Edit in the toolbar. Scroll to the log storage policy sections at the bottom of the Edit ADOM pane.

Data Policy
Keep Logs for Analytics 60 S Days
Keep Logs for Archive 365 S Days

Disk Utilization
Allocated 50 o GB »  Maximum Available: 64.7 GB
Analytics : Archive 70% v 30% Modify

Alert and Delete When Usage | 90%
Reaches

*If analytic or archive log usages exceed the configured disk quota before the retention period
expires, the oldest logs will be deleted.

3. Configure the following settings, then click OK.

Data Policy
Keep Logs for Specify how long to keep Analytics logs.
Analytics
Keep Logs for Specify how long to keep Archive logs.
Archive Make sure your setting meets your organization’s regulatory requirements.

Disk Utilization

Allocated Specify the amount of disk space allotted. See also Disk space allocation on
page 127.

Analytics: Archive Specify the disk space ratio between Analytics and Archive logs. Analytics
logs require more space than Archive logs. Click the Modify checkbox to
change the setting.

Alert and Delete Specify the percentage of allotted disk space usage that will trigger an alert
When Usage messages and start automatically deleting logs. The oldest Archive log files or
Reaches Analytics database tables are deleted first.

Configuring log rate receiving limits

You can manually configure log rate limits for devices in an ADOM or for specific logging devices. By default, no rate limit
is enforced.

When setting the log rate limit to manual in the CLI, you can specify a default device log rate and a per device/ADOM
rate. Both a default and per device limit can be set simultaneously, in which case the per device limit will take priority for
configured devices.
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You can view configured logging rates in the CLI using the following command: diagnose test application
fortilogd 17anddiagnose test application oftpd 17.

To configure the default device log rate limit:

In the FortiAnalyzer CLI, enter the following commands:

config system log ratelimit
set mode manual
set device-ratelimit-default <set the rate limit, for example 2000>
end

To configure the log rate limit per device:

In the FortiAnalyzer CLI, enter the following commands:

config system log ratelimit
set mode manual
config ratelimits
edit <rate limit profile, for example "1">
set filter-type devid
set filter <device serial number>
set ratelimit <set the rate limit, for example 3000>
next
end

To configure the log rate limit per ADOM:

In the FortiAnalyzer CLI, enter the following commands:

config system log ratelimit
set mode manual
config ratelimits
edit <rate limit profile, for example "1">
set filter-type adom
set filter <ADOM name>
set ratelimit <set the rate limit, for example 3000>
next
end

To disable the log rate limit:

In the FortiAnalyzer CLI, enter the following commands:

config system log ratelimit
set mode disable
end
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The Fabric View module enables you to create fabric connectors and view the list of endpoints. The Fabric View tab is
available in version 6.0 ADOMs and later.

This section contains the following topics:

o Automation on page 135

o Fabric Connectors on page 148

e Subnets on page 163

o Asset Identity Center on page 154

Automation

You can configure playbooks to automate tasks from Fabric View > Automation.

Ay
‘Q' A Security Automation subscription is required to run at full capacity. For additional information

about licensing, please see support.fortinet.com.

Summary

Fabric View > Automation > Summary provides a dashboard to review playbook performance at a glance.

This dashboard includes the following widgets:

Playbook Summary The total number of playbooks executed and plabook actions (tasks) executed.

Playbooks The total number of playbooks executed by playbook name in a donut chart.

Executed

Total Executed The total number of playbooks executed and actions (tasks) executed in a line chart timeline.
Playbooks and

Actions Trend

Connectors

Fabric View > Automation > Connectors displays connectors and the automated actions that they can perform in
playbooks.

The following connectors are supported for playbook automation:

¢ Local (FortiAnalyzer)
» FortiOS
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* FortiMail
o FortiGuard
o FortiClient EMS

FortiOS devices are organized by standalone, Cooperative Security Fabric (CSF), and high availability (HA). Clicking a
CSF or HA grouping will expand the list to display all FortiGate members.

The status of each connectors is indicated with a colored icon:

« Green: The API connection successful.
« Black: The API connection is unknown.
« Red: The API connection is down.

You can see when the status was last updated by hovering your mouse over the status icon. Click the refresh icon to
update the status.

FortiClient EMS connector

~ G EMS Connector FortiDemo

Q

FortiOS connector

o~ FortiOS Connector >
Localhost connector

~ Local Connector >
FortiGuard connector

~ FortiGuard Connector [
FortiMail connector

& [=] FML Connector

Q

FortiCASB connector

& (&> FortiCasb Connector

0

The following information is displayed for configured connectors:

Connector type Field Description
Local, FortiMail, Actions The name of the action.
FortiGuard, and L. - .
EMS connectors Description A description of the action.
Parameter The parameters that can be specified when configuring the action.

Required parameters are listed with an asterisk.

Output The output available with the action.
Not applicable to FortiGuard connectors.

FOS connectors Automation The name of the automation rule created on FortiOS.
Rule
Automation The action(s) that occur when the task is triggered.
Action
Parameter The parameters that can be specified when configuring the action.

Required parameters are listed with an asterisk.
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Configuring connectors for automation

Local Connector

The local connector is the default connector for FortiAnalyzer and is available automatically. The local connector
displays a set of predefined FortiAnalyzer actions to be used within playbooks.

Local connectors include the following actions:

Name Description Output
Update Asset and Update FortiAnalyzer's Asset and Identity. N/A

Identity

Get Events Get events. events

Get Endpoint Get endpoint vulnerabilities. vulnerabilities

Vulnerabilities

Create Incident Create a new incident. incident_id
Update Incident Update an existing incident. N/A
Attach Data to Incident Attach the specified data to an existing incident. attach_ids
Run Report Run the specified FortiAnalyzer report. report_uuid
Get EPEU from incidents Get the EPEU from an incident. epeu

EMS Connector

FortiClient EMS connectors are configured as Security Fabric connectors in Fabric View > Connectors > Fabric
Connectors. See Creating or editing Security Fabric connectors on page 151. Individual FortiClient EMS connector
actions can be toggled on and off while editing the connector in Fabric View.

FortiClient EMS connectors include the following actions:

Name Description Output

Get Endpoints Retrieve list of endpoints and all of the related information ems_endpoints
to enrich FortiAnalyzer asset and identity views.

Quarantine Quarantines an endpoint. N/A
Unquarantine Unquarantines an endpoint. N/A
Vulnerability Scan Run a vulnerability scan on endpoints. N/A
AV Quick Scan Run a quick antivirus scan on endpoints. N/A
AV Full Scan Run a full antivirus scan on endpoints. N/A

Get Software Inventory Retrieve list of software and apps installed on an endpoint softwares
to enrich FortiAnalyzer asset view.

Get Process List Retrieve list of running process on endpoints OS. processes
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Name Description Output

Get Vulnerabilities Retrieve list of endpoint vulnerabilities on endpoints OS. vulnerabilities
Tag Endpoints Tag endpoints. N/A

Untag Endpoints Untag endpoints. N/A

FortiMail Connector

FortiMail connectors are configured as Security Fabric connectors in Fabric View > Connectors > Fabric Connectors.
See Creating or editing Security Fabric connectors on page 151.

Individual FortiMail connector actions can be toggled on and off while editing the connector in Fabric View.

FortiMail connectors include the following actions:

Name Description Output
Get Email Statistics Query a given email address. statistics
Get Sender Reputation Query a given sender's reputation information. reputation
Add Sender to Blocklist Update system and domain level blocklist. N/A

FortiGuard Connector

The FortiGuard connector is automatically configured when a valid license has been applied to FortiAnalyzer.

FortiGuard connectors include the following actions:

Name Description

Lookup Indicator Lookup indicators in FortiGuard to get threat intelligence.

FortiOS Connector

The FortiOS connector is added after the first FortiGate has been authorized on an ADOM. Additional devices
authorized to the ADOM are displayed as separate entries within the same connector. FortiOS connectors are available
in FortiGate and Fabric ADOMs.

Enabling FortiOS actions

The actions available with FortiOS connectors are determined by automation rules configured on each FortiGate.
Automation rules using the Incoming Webhook trigger must be created in FortiOS before they are shown as actions in
FortiAnalyzer. FortiOS automation rules are configured on FortiOS in Security Fabric > Automation. For information on
creating FortiOS automation rules, see the FortiOS administration guide.

Rules for FortiOS actions:

« Automation rules must use the Incoming Webhook trigger.
» Automation rules are configured on FortiGate devices individually.

» When multiple FortiOS connectors are configured, FortiAnalyzer decides which device to call based on the devid
(serial number) identified in the task. FortiGate serial numbers can be manually entered or supplied by a preceding
task.
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« Automation rules must have unique names to be displayed in the task's Action dropdown menu. Rules sharing the
same name will appear only once, as they are considered to be the same automation rule configured on multiple
FortiGate devices.

« FortiOS automation rules are only displayed in Fabric View > Automation > Connectors when they are enabled in
FortiOS.

Playbooks

Playbooks include a starter event (a trigger) and one or more tasks configured with automated actions. A task is run as
soon as the playbook is triggered and all connected tasks preceding it are complete.

Ay
‘Q' To manage playbooks, administrators must be assigned an administrator profile with Read-
- Write permissions for Incidents & Events. See Administrator profiles on page 355.

To manage playbooks, go to Fabric View > Automation > Playbook. The following options are available:

Create New Create a new playbook. Playbooks can be created from scratch or by using
playbook templates.

Run Run selected playbooks that are configured with the ON_DEMAND trigger.

Edit Edit the selected playbook.

Delete Delete the selected playbook.

Column Settings Choose which columns are displayed in the playbook table.

Search Perform a text search for the playbook name, description, created time, and
modified time.

Creating a playbook

To create a playbook:

1. Goto Fabric View > Automation > Playbook, and click Create New.
Select a playbook template or choose New Playbook created from scratch.

The playbook editor opens.
N ! /., When a playbook template is selected, the playbook designer is automatically populated
q with a trigger and one or more tasks. You can configure trigger filter conditions and add or
= remove tasks to customize the playbook. See Playbook templates on page 142.

2. Click within the playbook's title field to change its name and description.

FortiAnalyzer 7.4.0 Administration Guide 139
Fortinet Inc.



Fabric View

3. Select a playbook trigger from the Triggers menu and configure the trigger's filter conditions.
On Demand - Quarantine Endpoint

Quarantine an endpoint

© Add a Trigger to start the playbook

_________________________ TRIGGERS
I

[ '
=4 sdectast ] EVENT_TRIGGER
.........................

INCIDENT_TRIGGER

ON_SCHEDULE
ON_DEMAND

Cancel
Once the trigger is created, it is displayed in the playbook editor with highlighted connector points.
For more information on the available playbook triggers, see Playbook triggers and tasks on page 143.
4. Add playbook tasks.

Drag-and-drop any connector point to add a new task. A new placeholder step is added to the playbook editor, and
the Tasks window is displayed showing available connectors. See Connectors on page 135.

On Demand - Quarantine Endpoint

Quarantine an endpoint

8

INNECTORS

FortiAnalyzer

mm
LY I
Q
2

ON_DEMAND
STARTER w

-------------------------

.,.,
o
b
@
@

_________________________

w
a

rviceNow

MS_TEAMS

|
(élelalojulala]e]
-
3
E3
i

oK Cancel
=
5. Select a connector type and configure an automated action:
Name Enter a name for the task.
Description Enter a description of the task.
Connector Select a connector to use from the dropdown menu. See Connectors on page
135.
Action Select the automated action to be performed.
Parameters Configure the parameters for the selected action.
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On Demand - Quarantine Endpoint

Quarantine an endpoint

EMS_QUARANTINE

Name QUARANTINE
Description Quarantine an endpaint
ON_DEMAND
STARTER
Connector EMS Connector FortiDemo
Action Quarantine
site @ No Data.  Edit
Endpoint ID @ Playbook Starter v | epid v|T
------------------------- o
E R FortiClient ID No Data.  Edit
e
=" SelectaStep
.........................

Save Playbook Cancel

6. Connect playbook tasks.
Additional connector points can be added to connect this task to other tasks in the playbook. A task automatically
begins once all preceding tasks connected to it have been completed. A playbook ends when there are no
additional tasks to run.
On Demand - Quarantine Endpoint

Quarantine an endpoint

8
z
z
o]
o
3

ON_DEMAND
STARTER

EMS_QUARANTINE

QUARANTINE
-------------------------
-1 NEWTASK 1
i I 1

_________________________
LOCALHOST_ATTACH_DATA_TO_I
Attach data to an incident

3 2
R
@ g

a

w
a
z
g
H

MS_TEAMS

-
g 2
E?
H

OK Cancel
Save Playbook Cancel

7. (Optional) Manage your playbook by clicking on one of the options displayed when hovering your mouse over the
trigger or task:

« Edit: Edit the trigger or task.
» Delete: Delete the task.
8. Click Save Playbook.

Enabling and disabling playbooks

Once created, playbooks can be enabled or disabled through the playbook editor. Enabled playbooks will run as soon as
their trigger conditions are met. Playbooks configured with the On_Demand trigger start when manually initiated by the
administrator in Fabric View > Automation > Playbook or an Incident Analysis page.

To enable or disable a playbook:

1. Go to Fabric View > Automation > Playbook.
2. Edit a previously configured playbook.
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3. Inthe playbook designer, select the option to Enable or Disable the playbook located in the top-right corner.
4. Click Save Playbook.

Playbook templates

When a playbook template is selected, the playbook designer is automatically populated with a trigger and one or more
tasks. You can configure, add, or remove tasks to customize the playbook.

When creating a new playbook, the following predefined templates are available:

Connector \ET[) Description

FAZ Localhost Compromised Host Playbook to create an incident on FortiAnalyzer compromised hosts
Incident detected by the loC feature.
Critical Intrusion Playbook to create an incident on FortiAnalyzer for critical
Incident intrusions detected by IPS.
Attach Endpoint Playbook to collect the list of endpoint vulnerabilities from logs and
Vulnerability List to attach it to an incident.
Incident

FortiOS Quarantine Endpoint by  Playbook to quarantine an endpoint by FOS connector providing
FortiOS the MAC address or FortiClient UID.

FortiClient EMS Update Asset and Playbook to automatically update FortiAnalyzer Asset and Identity
Identity Database database with endpoint and user information from EMS.
Run AV Scan on Playbook to run AV scan on an endpoint by EMS Connector.
Endpoint
Run Vulnerability Scan Playbook to run a vulnerability scan on an endpoint.
on Endpoint
Quarantine Endpoint by  Playbook to quarantine an endpoint by EMS connector.
EMS
Unquarantine Endpoint  Playbook to unquarantine an endpoint by EMS connector.
by EMS
Enrich Incident with Playbook to get running processes on endpoint by EMS connector
Process List and attach to an incident.
Enrich Incident with Playbook to collect the list of endpoint vulnerabilities from logs and
Vulnerability List attach to an incident.
Enrich Incident with Playbook to get software inventory from endpoint by EMS
Software Inventory connector and attach to an incident.
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Playbook triggers and tasks

Triggers

Triggers determine when a playbook is to be executed. Triggers are always the first step in a playbook, and each
playbook can only include one trigger. Once a playbook has been triggered, it flows through the remaining tasks as
defined by the routes in the playbook using the trigger as a starting point.

The following playbook triggers are available:

Trigger Description

EVENT_TRIGGER The playbook is run when an event is created that matches the configured filters.
When no filters are set, all events will trigger the playbook.
INCIDENT_TRIGGER The playbook is run when an incident is created that matches the configured
filters.
When no filters are set, all incidents will trigger the playbook.

ON_SCHEDULE The playbook is run during the configured schedule.
You can define the start time, end time, interval type, and interval frequency for
the schedule.

ON_DEMAND The playbook is run when manually started by an administrator.

You can run playbooks configured with the ON_DEMAND trigger from Fabric
View > Automation > Playbook or within an incident's Analysis page.

Tasks

Tasks include automated actions that take place on FortiAnalyzer or devices with configured connectors. See
Connectors on page 135.

Tasks can be linked together in sequences. A task's automated action will only begin once the playbook is triggered and
all preceding connected tasks are complete.

Tasks can be configured with default input values or take inputs from the trigger or preceding tasks. For more information
about linking and configuring tasks in a playbook, see Playbooks on page 139.

vy
‘Q' FortiOS actions are configured using automation rules created on FortiGate. For more
- information on enabling FortiOS actions in tasks, see Connectors on page 135.

Configuring tasks using variables

Variables can be used when configuring playbook tasks. There are two types of playbook variables, including output
variables and trigger variables.

For a list of trigger and output variables that can be used when configuring playbook tasks, see FortiAnalyzer Playbook
Variables on the Fortinet Docs Library.
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Output variables

Output variables allow you to use the output from a proceeding task as an input to the current task. For example, the
report generated in one task can be attached to an incident in a second task. For a list of output types, see Fabric View >
Automation > Connectors. A task ID is created automatically for each task added to the playbook.

Output variables use the following format:
Format: $ {<task id>.<output>}

Example: ${id 2c7 84b 2c5 f47.vulnerabilities}

Obtaining task IDs

Task IDs are not currently displayed within a task. To view a task ID, the following workaround

can be used.
1. Create a new task in the playbook using the Local Connector action Attach Data to
Incident.

2. Inthe Aftachment dropdown, select a preceding task to view its task ID. You can switch to
text mode to copy the value after selection.

ﬂ E“': NEW T NIGEALHOSH
I GET_EVENTS - [l ==
Get Events B e

Description

Connector Lacal Connector

Action Attach Data to Incident
Incident ID @ No Data.  Edit
CREATE_INCIDENT | Attachment (& . «|T
1
Create Incident B Playbook Starter
Get Events

(id_a74_3e6_f49_94e)

Trigger (incident and event) variables

Trigger variables allow you to use information from the trigger (starter) of a playbook when it has been configured with an
incident or event trigger.

For example, the Run Report action can include a filter for the endpoint IP address from the event that triggered the
playbook.

Trigger variables use the following format:
Format: s{trigger.<variable>}

Example: ${trigger.epip}
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LOCALHOST
Name Run Report
Description
ON_DEMAND
STARTER
Connector Local Connector
Action Run Report
______________________ Report Playbook Starter | T
I 1
) NEWIASK 1 Time Period Last 7 Days
1 1
il Skar ' §
_______ o R Filter Log messages that @®All O Any of the Following Conditions
match
Log Field Match Criteria Value @
Source IP (srcip)  + | Equal To + S${trigger.epip} + @
Devices B 7|l Devices +

B -
Save Playbook Cancel

Importing and exporting playbooks

You can import or export playbooks, including the connectors required to support the playbook, by using the right-click
context menu in the playbook dashboard.

To import a playbook:

1. Go to Fabric View > Automation > Playbook.

2. Right-click in the playbook dashboard, and click Import.
The Import Playbook dialog appears.

3. Click Browse and select the playbook file to be imported.
When the playbook file includes connectors, a toggle allowing you to include or exclude the connectors during the
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import process is displayed.

Import Playbook

Upload file by drag & drop here or  Browse

Get Vulnerabilities from EMS (EMS Connector)(1).json

Do you want to include Connector ? Include Connector

“ ane'

4. Click OK.
A message is displayed confirming that the playbook was imported successfully.

To export a playbook:

1. Go to Fabric View > Automation > Playbook.

2. Highlight the playbook(s) that you want to export, then right-click in the dashboard and click Export.
The Export Playbook dialog opens.

Export Playbook

Do you want to include Connector OFF

Select Export Data Type O text (@ zipped
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3. Configure the settings for exporting the selected playbook:

a. Do you want to include Connector: When enabled, connectors required to run this playbook will be included in
the exported file.

b. Select Export Data Type: Select the export file type as either plain text JSON or zipped/base 64 encoded

JSON.
4. Click OK.
N ! /, When an imported playbook has the same name as an existing playbook, FortiAnalyzer
9 will automatically create a new name which includes the import timestamp to avoid a
= conflict.

Playbook Monitor

You can view the status of playbook jobs in Fabric View > Automation > Playbook Monitor.
You can perform the following actions on the Playbook Monitor table:

» Click Refresh to refresh the table view.
» Select the checkbox for playbook jobs and click Delete to remove them from the table view.
» Use the Search field to find specific playbook jobs.

The Playbook Monitor table includes the following columns:

Column Description

Job ID The unique ID of the playbook job.
The ID includes the date and time that the job began as well as a unique number.

Playbook The name of the playbook as configured in Fabric View > Automation > Playbook .

User Displays the name of the administrator who started the playbook job when
configured with theOn Demand trigger.

Start Time The date and time that the job began.
End Time The date and time that the job ended.
Status The current status of the job. Statuses include:

¢ Running: The job is currently running.

e Success: The job has finished with all tasks completed successfully.

 Failed: The job has finished with one or more tasks failing to complete
successfully.

Details Clicking the Details icon shows the status of each task run by the playbook.
After clicking the Details icon for a playbook job, the Playbook Tasks dialog displays. This dialog provides details about
the tasks, including their status, in a table view.

Task statuses include:
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Scheduled Scheduled to run.

Success Completed successfully.

Failed Failed to complete.

Upstream_failed Failed because the task could not connect with an upstream device.

Playbook jobs that include one or more failed tasks are labeled as Failed in Playbook Monitor, however, individual
actions may have been completed successfully.

Fabric Connectors

You can use FortiAnalyzer to create the following types of fabric connectors:

e ITSM
o Security fabric on page 151
» Storage on page 153

ITSM

You can use the Fabric Connectors tab to create the following types of ITSM connectors:

e MS Teams

o ServiceNow

« Slack

» Webhook, a generic connector

Creating or editing ITSM connectors
You can create ITSM connectors for ServiceNow, Slack, MS Teams, and Webhook.

To create an ITSM connector:

1. Go to Fabric View > Fabric Connectors, and click Create New.

2. Under ITSM, click ServiceNow Connector, Slack Connector, MS Teams Connector, or Generic Connector and click
Next.

3. Configure the following options, and click OK:

Property Description
Name Type a name for the fabric connector.
Description (Optional) Type a description for the fabric connector.
Protocol Select HTTPS.
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Property Description

For Slack connectors and Generic connectors, you can also select HTTP.

Port Specify the port FortiAnalyzer uses to communicate with the external platform.
Method Select POST.
For Slack connectors and Generic connectors, you can also select PUT.
Title Type a title for the fabric connector.
URL Type the URL of the external platform. This option is not available for the MS

Teams Connector.

Using ServiceNow as an example, copy and paste the URL from ServiceNow
API URL in the Connection to ServiceNow APl section in ServiceNow >
FortiAnalyzer System Properties.

Teams Webhook URL Type the incoming webhook URL created in MS Teams. This option is only
available for the MS Teams Connector.

Enable HTTP Authentication  Set HTTP authentication to ON or OFF. This option is not available for the MS
Teams Connector.
If set to ON, select Basic or OAuth2 authentication type.
Using ServiceNow with Basic authenictation as an example, enter the
username and password from the Connection to ServiceNow API section in
ServiceNow > FortiAnalyzer System Properties.
Using Webhook Connector with OAuth2 authentication as an example, enter
the URL of the token service as well as the client ID and client secret for
authentication.

HTTP Body Type the HTTP body of the message that should be sentin MS Teams by the
connector. This option is only available for the MS Teams Connector.
Forexample, { \"text\": \"<message to send>\" }.Youalsouse
$ {} for macros in the message. For a list of supported macros, see Supported
macros for the MS Teams Connector.

Status Toggle ON to enable the fabric connector. Toggle OFF to disable the fabric
connector.

ServiceNow connectors can be used to post incident change notices. After it is created, the

\ﬂ ServiceNow connector can be added in the incident settings or as part of a playbook.

For more information, see:
» Configuring incident settings on page 231

¢ Playbooks on page 139
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R

MS Teams connectors can be used to send messages about incidients and events. After it is

created, the MS Teams connector can be added in the incident settings, notification profiles for

event handlers, or as part of a playbook.
For more information, see:
¢ Configuring incident settings on page 231

¢ Creating notification profiles on page 215
* Playbooks on page 139

To edit an ITSM connector:

1. Goto Fabric View > Fabric Connectors.

2. Right-click an ITSM connector, and select Edit.
The Edit Connectors dialog box is displayed.

3. Editthe settings, and click OK.

Supported macros for the MS Teams Connector

Category
Global
Global
Global
Global
Event
Event

Event

Event
Event
Event

Event

Event
Event
Event
Event
Event

Event

Variable Macro

type ${type}

adom ${adom}

from ${from}

timestamp ${timestamp}

event ${event}

eventid ${event.eventid}
alertid ${event.alertid}
logtype ${event.logtype}
devtype ${event.devtype}
eventtime ${event.eventtime}
alerttime ${event.alerttime}
firstlogtime ${event firstlogtime}
lastlogtime ${event.lastlogtime}
devid ${event.devid}
devname ${event.devname}
eventtype ${event.eventtype}
groupby1 ${event.groupby1}
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Description
Notification type
Adom name

FAZ SN

Notification timestamp
All event fields
Eventid

Alert id (same with eventid, but name
consistent with previous notification format)

Log type
Device type
Event time

Alert time (same with eventtime, but name
consistent with previous notification format)

First log time
Last log time
Device id
Device name
Event type
groupby1
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Category Variable Macro Description

Event groupby2 ${event.groupby2} grouby?2

Event groupby3 ${event.groupby3} grouby3

Event indicator ${event.indicator} indicator

Event severity ${event.severity} severity

Event subject ${even.subject} subject

Event tag ${event.tag} tag

Event triggername ${event.triggername} Trigger name

Event vdom ${event.vdom} vdom

Event epid ${event.epid} epid

Event euid ${event.euid} euid

Event epip ${event.epip} epip

Event epname ${event.epname} epname

Event euname ${event.euname} euname

Event extrainfo ${event.extrainfo} Additional info

Event log-length ${event.log-length} Log length

Event log-detail ${event.log-detail} Log detail

Incident incident ${incident} Allincident fields

Incident incid ${incident.incid} Incident ID

Incident type ${incident.type} Notification type

Incident revision ${incident.revision} revision

Incident attach_revision ${incident.attach_ attach revision
revision}

Security fabric

You can use the Fabric Connectors tab to create the following types of security fabric connectors:

¢ FortiClient EMS
¢ FortiMail
« FortiCASB

Creating or editing Security Fabric connectors

You can create a Security Fabric connector on FortiAnalyzer for FortiClient EMS, FortiMail, and FortiCASB. Once
configured, Security Fabric connectors enrich incident response related actions available in playbooks.
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To create a Security Fabric connector:

1. Go to Fabric View > Fabric Connectors, and click Create New.
The Create New Fabric Connector dialog is displayed.

2. Under Security Fabric, click FortiClient EMS, FortiMail, or FortiCASB.
3. Inthe Configuration tab, configure the following options for:

FortiClient EMS

Property

Type
Name
Description

FortiClient
EMS

FortiClient
EMS Cloud

Status

FortiMail

Property
Name
Description
IP/FQDN
Username
Password

Status
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IP/FQDN
Username
Password

Account ID

Description

Select FortiClient EMS or FortiClient EMS Cloud.

Type a name for the Security Fabric connector.

(Optional) Type a description for the Security Fabric connector.
Type the IP address or FQDN for the Security Fabric device.
Type the username for the Security Fabric device.

Type the password for the Security Fabric device.

Super users can type the account ID of the FortiClient EMS Cloud
instance.

For non-super users, the field is automatically populated with the default
account ID. The FortiAnalyzer device must be registered with FortiCloud
to create and update the connector as a non-super user.

The FortiClient EMS must be v7.0 or later. After the FortiClient EMS
Cloud connector is created, the connector's health-check sends an
authentication request with SNI (the account ID) to the EMS instance.
The authentication request from the FortiAnalyzer device must be
approved in EMS: Administration > Fabric Devices. For more
information, see FortiClient on the Fortinet Docs Library.

Toggle On to enable the Security Fabric connector. Toggle Off to disable
the Security Fabric connector.

Description

Type a name for the Security Fabric connector.

(Optional) Type a description for the Security Fabric connector.
Type the IP address or FQDN for the Security Fabric device.
Type the username for the Security Fabric device.

Type the password for the Security Fabric device.

Toggle On to enable the Security Fabric connector. Toggle Off to disable
the Security Fabric connector.
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FortiCASB
Property Description
Name Type a name for the Security Fabric connector.
Description (Optional) Type a description for the Security Fabric connector.
IP/FQDN Type the IP address or FQDN for the Security Fabric device.

Use the FortiCASB FQDN for your chosen server location. The server
location is selected when creating your FortiCASB account. Use
forticasb.comforglobal serversor eu. forticasb.comfor EU
based servers.

Account ID Enter the credentials token used for authentication.

To create a FortiCASB credentials token, log in to FortiCASB with your
account, go to Home > Manage Company > API Setting, and click
Generate New. For more information, see FortiCASB on the Fortinet
Docs Library.

Status Toggle On to enable the Security Fabric connector. Toggle Off to disable
the Security Fabric connector.

4. Click the Actions tab to view the actions available with the Security Fabric connector, then click OK.

After the Security Fabric connector is created, playbooks configured in Fabric View can use the connector to execute
automated actions. For a list of connector actions available in playbooks, see Connectors on page 135.

Default playbooks are automatically created when configuring some Security Fabric connectors. For more information
on playbooks, see Playbooks on page 139.

To edit a Security Fabric connector:

1. Goto Fabric View > Fabric Connectors.
2. Right-click a Security Fabric connector, and select Edit.
The Edit Connectors dialog is displayed.

3. Edit the settings, and click OK.

Storage

You can use the Fabric Connectors tab to create the following types of storage connectors:

e« Amazon S3
e Azure Blob Container
e Google Cloud Storage

Creating or editing storage connectors

You can create storage connectors for Amazon S3, Azure Blob, and Google Cloud. Once you have created a storage
connector, you can upload FortiAnalyzer logs to cloud storage. You must also import the CA certificate from the cloud
service provider. See Upload logs to cloud storage on page 339
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To create a storage connector:

1. Go to Fabric View > Fabric Connectors, and click Create New.
2. Under Storage, click Amazon S3, Azure Blob, or Google, and click Next.
3. Configure the following options, and click OK.

Property

Name
Description
Title

Status

Amazon S3

Azure Blob

Google

Provider
Region
Access Key ID

Secret Access Key

Storage Account
Name

Account Key

Cloud
Project Number

Service Account
Credentials

Cloud Location

Description

Type a name for the fabric connector.

(Optional) Add a description for the fabric connector.
Type a title for the fabric connector.

Toggle On to enable the fabric connector. Toggle Off to disable the
fabric connector.

Type AWS.
Select aregion.
Paste the access key from the IAM user account.

Paste the secret access key from the IAM user account. Click the eye
icon to Show or Hide the key.

Paste the storage account name from the Microsoft Azure account.

Paste the account key from the Microsoft Azure account.

Paste the project number from the Google account.

Paste the entire Google account JSON key into the field. Click the eye
icon to Show or Hide the key.

Select a Google Cloud location. For information about Google locations,
visit the product help.

4. Advanced options will differ between the various types of storage connectors.

To edit a storage connector:

1. Goto Fabric View > Fabric Connectors.

2. Right-click a storage connector, and select Edit.
The Edit Connectors dialog box is displayed.

3. Editthe settings, and click OK.

Asset Identity Center

The Fabric View > Asset Identity Center is the central location for security analysts to view endpoint and user information

to make sure they are compliant. Endpoints are important assets in a network as they are the main entry pointsin a
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cybersecurity breach.
The asset information is useful for the following:
« Incident response: check assets that are infected or vulnerable as part of your SOC analysis and incident
response process.
» Compliance: identify unknown and non-compliant users and endpoints.
The Asset Identity Center is also useful for user and endpoint mapping. Some users might use multiple endpoints in the
network, endpoints might use multiple different interfaces to connect, network interfaces might have multiple IP

addresses, and so on. A map of users and their endpoints gives you better visibility when you analyze logs, events, and
incidents. This also helps with your reporting.

This topic includes the following information:

e Asset Summary on page 155

¢ Identity Summary on page 156

¢ Asset List on page 157

« Identity List on page 159

e OT View on page 161

« Configuring endpoint and end user data sources on page 161

Asset Summary

The Asset dashboard in Fabric View > Asset Identity Center > Summary includes widgets for analysis of endpoints.

You can click Toggle Widgets to select which widgets are visible on the dashboard, and refine the list of endpoints
included in the widgets by using the dashboard filter. You can also apply filters from some widgets.

By default, the following widgets are displayed in the dashboard:

Detection Method Displays endpoint detections by method.

Detection Source Displays a breakdown of the asset center data sources.

Click the settings icon to sort in ascending or descending order, and to filter by top
5, top 10, or top 20.

Identification/Unidentified Displays the number of detected endpoint assets that are identified and
Asset unidentified.
Hardware/OS Distribution Displays endpoint hardware operating system distribution.

Click the settings icon to adjust the view, and to filter by top 5, top 10, or top 20.

Discovery Timeline Displays an asset discovery timeline.
Click the settings icon to adjust the time filter or disable/enable the refresh
interval.
Identified Active Asset Displays identified asset visibility over the past 24 hours to 52 weeks.
Assets By Location Displays identified assets by location.

Click the settings icon to adjust the view, and to filter by top 5, top 10, or top 20.

Identified Activity Timeline Displays a first seen, last update, and last seen identified asset activity timeline.
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Changes Timeline

Unidentifed Active Asset

Unidentifed Activity Timeline

To use the dashboard filter:

Click the settings icon to adjust the time filter or disable/enable the refresh
interval.

Displays an asset changes timeline.

Click the settings icon to adjust the time filter or disable/enable the refresh
interval.

Displays unidentified asset visibility over the past 24 hours to 52 weeks.

Displays a first seen, last update, and last seen unidentified asset activity timeline.

Click the settings icon to adjust the time filter or disable/enable the refresh
interval.

1. Goto Fabric View > Asset Identity Center > Summary, and select Asset.

2. Click the settings icon in the top-ri

ght corner of the pane.

The following options are displayed.

Tags Filter

Hardware\OS
Detect Method

Device Filter

3. Click OK.

Identity Summary

Select Include or Exclude, and select a tag from the Tags Field dropdown.
You can click the add icon next to the tags field to add additional items to be
included or excluded. Click the trash icon to remove a field.

Select a hardware/OS type from the dropdown to only display endpoints with
the matching hardware or operating system type.

Select a detection method in the dropdown to only display endpoints that were
detected by the specified method.

Select devices to filter by or select All.

The Identity dashboard in Fabric View > Asset Identity Center > Summary includes widgets for analysis of end users.

You can click Toggle Widgets to select which widgets are visible on the dashboard, and refine the list of endpoints
included in the widgets by using the dashboard filter. You can also apply filters from some widgets.

By default, the following widgets are displayed in the dashboard:

Top Users

Number of Active Users

User Groups

User's Location
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Displays asset user data.

Click the settings icon to sort in ascending or descending order, and to filter by top
5, top 10, or top 20.

Displays user visibility data over the past 24 hours to 52 weeks.

Displays user groups.
Click the settings icon to sort in ascending or descending order, and to filter by top
5, top 10, or top 20.

Displays user numbers by location.
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User's Manager

Discovery Timeline

Activity Timeline

Endpoint Tag Distribution

To use the dashboard filter:

Click the settings icon to sort in ascending or descending order, and to filter by top
5, top 10, or top 20.

Displays user numbers by manager.

Click the settings icon to sort in ascending or descending order, and to filter by top
5, top 10, or top 20.

Displays the user discovery timeline.

Click the settings icon to adjust the time filter or disable/enable the refresh
interval.

Displays the user activity timeline.

Click the settings icon to adjust the time filter or disable/enable the refresh
interval.

Displays the distribution of endpoint tags.

Click the settings icon to sort in ascending or descending order, and to filter by top
5, top 10, or top 20.

1. Goto Fabric View > Asset Identity Center > Summary and select Identity.

2. Click the settings icon in the top-right corner of the pane.
The following options are displayed.

Device Filter

User Group
3. Click OK.
Asset List

To open the Asset List, go to Fabric View > Asset Identity Center > Asset Identity List > Asset List and select Asset in the

top-right corner of the pane.

This table view lists all endpoints and

Select devices to filter by or select All.

Select user groups to filter by or select All.

users from relevant logs and correlates them with FortiAnalyzer modules. Sort by

the Vulnerabilities column to see which endpoints and users have the highest vulnerabilities.

The following default columns are available in the table:

Column Description

Endpoint Name Endpoint host name.

Tags Tags are used to group and identify assets to assist SOC analysts with incident management
and prioritization.

Tags can be defined by FortiClient EMS or when creating subnets and subnet groups in
FortiAnalyzer.
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Column Description

FortiClient EMS tags are determined based on the Classification Tag assigned in FortiClient
EMS. Tags are displayed in the Asset Center when a playbook retrieves information about
that endpoint using the Get Endpoints task available with a FortiClient EMS connector. See
Connectors on page 135.

User

MAC Address
IP Address
FortiClient UUID
Hardware / OS

Software

Vulnerabilities

Last Update

Subnet tags are configurable when creating new subnets and subnet groups in FortiAnalyzer.
See Subnets on page 163.

The name of the user. Click the name to view the corresponding user information in the
Identity Center pane.

Endpoint MAC address.

IP address the endpoint is connected to. A user might be connected to multiple endpoints.

Unique ID of the FortiClient.

OS name and version.

Click Details to view information about software installed on an endpoint when available.

Endpoint software information is retrieved when a playbook runs the Get Software Inventory
action using the FortiClient EMS connector. See Automation on page 135.

The number of vulnerabilities for critical, high, medium, and low vulnerabilities. Click the
vulnerability to view the name and category. Right-click the vulnerability to view available on-
demand actions using a security fabric connector.

Endpoint vulnerability information is retrieved when a playbook runs the Get Vulnerabilities
action using the FortiClient EMS connector. See Automation on page 135.

The date and time the log was updated.

If there is no FortiClient in your installation, then endpoint and end user information is limited.

Endpoints are detected based on MAC address and displayed by IP address instead of
host name.

User related information might not be available.

Detailed information such as OS version, avatar, and social ID information are not
available.

To filter the entries using filters in the toolbar:

» Specify filters in the Add Filter box.

» Regular Search: In the selected summary view, click the plus icon and select a filter from the dropdown list,
then type a value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and”

or “or”.

» Advanced Search: Click the Switch to Advanced Search icon at the end of the Add Filter box. In Advanced
Search mode, enter the search criteria (log field names and values). Click the Switch to Regular Search icon to
go back to regular search.
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To create a custom view in the toolbar:

1. Inthe toolbar, click the column settings icon, and select the columns you want to display.
2. Click Custom View > Save As Custom View. The Save as New Custom View dialog is displayed.

3. Inthe Name field, enter a name for the custom view, and click OK. The view is saved under Fabric View > Asset
Identity Center > Custom View.

To change the visibility of a custom view:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.

2. In Fabric View > Asset Identity Center > Custom View, select the menu icon next to your custom view, and select
Share with Others.
You can also Rename, Save As (clone), or Delete the custom view.

3. Setthe Privacy field to On: Public or Off: Private, and click OK.

To download the entries as a CSV file:

1. Click More > Download.

Identity List

To open the Identity List, go to Fabric View > Asset Identity Center > Asset Identity List > Asset List and select Identity in
the top-right corner of the pane.

This table lists all endpoints and users from relevant logs and correlates them with FortiAnalyzer modules.

Column Description

User Id The ID of the user.
User Name The name of the user.
User Group The group of user identities. An identity can be a:

¢ Local user account (username/password stored on the FortiGate unit)

¢ Remote user account (password stored on a RADIUS, LDAP, or TACACS+ server)

¢ PKI user account with digital client authentication certificate stored on the FortiGate unit

¢ RADIUS, LDAP, or TACACS+ server, optionally specifying particular user groups on that
server

¢ User group defined on an FSSO server.

Endpoints Endpoint host name, IP address, or MAC address. A user may be connected to multiple
endpoints.

Click the endpoint to display the corresponding user information in the Assets pane.

Social The user's Name, Picture, Email, Phone Number, and Social if it is available.
Source The name of device that created the log.
VPN IP The VPN IP.

Identification Time  The time of identification.
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Column Description

Last Seen The last seen time.

Last Update The date and time the log was updated.

End user information is limited if there is no FortiClient in your installation.
« Endpoints are detected based on MAC address and displayed by IP address instead of

host name.
¢ User related information might not be available.

* Detailed information such as OS version, avatar, and social ID information are not
available.

To filter the entries using filters in the toolbar:

« Specify filters in the Add Filter box.

» Regular Search: In the selected summary view, click Add Filter and select a filter from the dropdown list, then
type a value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or

“or”.

» Advanced Search: Click the Switch to Advanced Search icon at the end of the Add Filter box. In Advanced
Search mode, enter the search criteria (log field names and values). Click the Switch to Regular Search icon to
go back to regular search.

To create a custom view:

1. Inthe toolbar, click the column settings icon, and select the columns you want to display.
2. Click Custom View > Save As Custom View. The Save as New Custom View dialog is displayed.

3. Inthe Name field, enter a name for the custom view, and click OK. The view is saved under Fabric View > Asset
Identity Center > Custom View.

To change the visibility of a custom view:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.

2. In Fabric View > Asset Identity Center > Custom View, select the menu icon next to your custom view, and select
Share with Others.
You can also Rename, Save As (clone), or Delete the custom view.

3. Setthe Privacy field to On: Public or Off: Private, and click OK.

To configure the display settings in the Social column:

1. Goto Log View >Tools icon > User Display Preferences.

2. Select the order preference tab you want to configure.
Tabs include Name, Picture, Email, Phone Number, and Social.

w

Rearrange the order preference as per your needs by drag-and-dropping an entry. For names, pictures, emails, and
phone numbers, only the top entry will appear in the identity pop-up window.

User information can be disabled by moving the Show toggle to the Off position in the respective tabs.

P>
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To download the entries as a CSV file:

1. Click More > Download.

OT View

The Fabric View > Asset Identity Center > Asset Identity List > OT View displays the relationships between endpoints,
allowing you to analyze the structure.

The following actions are available in the toolbar:

Option Description

Select Devices Select the devices include in the OT view.
Group By Select how the devices should be grouped in the OT view.

Lock/Unlock View Lock or unlock the endpoints. After unlocking, the device can move only in parallel at the level.

Hide/Show Hide or show the connection cables between devices.
Connection

Search Search for an endpoint in the OT view.

Custom View Save the current view as a custom view.

To create a custom view:

1. Inthe toolbar, click the column settings icon, and select the columns you want to display.
2. Click Custom View. The Save as New Custom View dialog is displayed.

3. Inthe Name field, enter a name for the custom view, and click OK. The view is saved under Fabric View > Asset
Identity Center > Custom View.

To change the visibility of a custom view:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.

2. In Fabric View > Asset Identity Center > Custom View, select the menu icon next to your custom view, and select
Share with Others.

You can also Rename, Save As (clone), or Delete the custom view.
3. Setthe Privacy field to On: Public or Off: Private, and click OK.

Configuring endpoint and end user data sources

You can configure the data sources used in the Fabric View > Asset Identity Center > Asset Identity List to specify which
sources are used to identify endpoints and end users. Data source modification is configured per ADOM.

The following data sources are configurable in FortiAnalyzer:
FortiGate Log By default, the log identification of endpoints and end users is enabled for all

devices and subnets. You can create rules to specify which FortiGate devices and
which subnets are excluded in the data source.
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FortiClient Log

FortiMail Log

FortiWeb Log

FortiNAC Log

EMS Connector

Set the status to OFF to disable UEBA identification on the specified devices or all
devices.

By default, the log identification of endpoints and end users is enabled for all
devices. You can create rules to specify which FortiClient devices are excluded in
the data source.

Set the status to OFF to disable identification of endpoints and end users from the
specified devices or all devices.

By default, the log identification of endpoints and end users is disabled for all
devices. You can create rules to specify which FortiMail devices and domains are
included in the data source.

By default, the log identification of endpoints and end users is enabled for all
devices. You can create rules to specify which FortiWeb devices and which
subnets are excluded in the data source.

Set the status to OFF to disable UEBA identification on the specified devices or all
devices.

By default, the log identification of endpoints and end users is enabled for all
devices. You can create rules to specify which FortiNAC devices and which
subnets can be excluded in the data source.

Set the status to OFF to disable UEBA identification on the specified devices or all
devices.

By default, the log identification of endpoints and end users is disabled for all EMS
connectors. You can create rules to specify which EMS connectors can be
included in the data source.

\,

Rules created for individual devices have priority over those created for "all devices".
You can configure the same data source multiple times when the device or connector is
unique. When a conflict arises, you will see a message indicating the data source for that
device already exists, and you will have the option to override the existing data source.

To configure data sources:

1. Goto Fabric View > Asset Identity Center > Asset Identity List, and click More > Data Sources.
The Data Source Selection dialog opens. You can create, edit, and delete data sources in this dialog.

2. Tocreate a new data source, click Create New.
The Data Source Selection wizard opens.

Data Source Selection

Data Source
Status
Devices

Exclude Subnets

FortiGate Log

@Al Devices O Specify

Click here to select
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3. Configure your data source. Different fields appear for different data source types:

Data Source

Status

Devices

Exclude Subnets

Include Domains

Connectors

Select the data source that you want to configure.

Data sources include FortiGate Log, FortiClient Log, FortiMail Log, FortiWeb
Log, FortiNAC Log, and EMS Connector.

Depending on your selection, different configurable fields will appear below.

Enable or disable the data source by setting the Status to ON or OFF.

When the data source is disabled, FortiAnalyzer will not identify endpoints and
end users in this ADOM from the devices, domains, or connectors configured
in the data source.

Devices is only available when the data source is FortiGate Log, FortiClient
Log, FortiMail Log, FortiWeb Log, or FortiNAC Log.

Select All Devices or Specify to select individual devices.

Exclude Subnets is only available when the data source is FortiGate Log,
FortiWeb Log, or FortiNAC Log.

Select subnets to be excluded from the data source selection. You can create
subnets in Fabric View > Fabric > Subnets. See Subnets on page 163.

Include Domains is only available when the data source is FortiMail Log.
Enter domains to be included in the data source selection.

Connectors is only available when the data source is EMS Connector.

Select an EMS connector to be included in the data source selection. See
Creating or editing Security Fabric connectors on page 151.

4. Click OKto save changes to the data source.
Once created, you can edit and delete the data sources from the Data Source Selection dialog.

Subnets

In Fabric View > Subnets, you can define subnet lists which can be added to subnet groups.

Subnet lists and groups can be used to create include and exclude lists in event handlers and reports.

You can filter for subnet lists and subnet groups in Log View. See Filtering messages on page 116.

Creating, updating, or deleting subnets will generate local event logs.

O  Name Details Create Time Update Time Tags Description u

10.100.92.100-10.100.92.10
10.100.55.100-10.100.55.10
10.100.94.100-10.100.94.10
10.100.91.100-10.100.91.10

4

Subnets includes the following options in the toolbar and right-click menu:
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Create New Create a new subnet or subnet group.
Edit Edit the selected subnet or subnet group.
Clone Clone the selected subnet or subnet group.
Delete Delete the selected subnet(s) or subnet group(s).
Import Import a subnet or subnet group.
Export Export a subnet or subnet group in either a text or zipped format.
\‘ ! 'l
q Subnet filtering for event handlers is supported in FortiGate, FortiWeb, FortiMail, and Fabric
- ADOMs.
Ay
S L4
q A maximum of 10,000 subnet objects can be created.

o Creating a subnet list on page 164
o Creating a subnet group on page 165
« Assigning subnet filters to event handlers on page 165

Creating a subnet list

To create a new subnet:

1. Goto Fabric View > Subnets.

2. From the Create New dropdown, select Subnet.
The New Subnet wizard opens.

New Subnet x

o JmcE

3. Enter a name for the subnet.

4. Selecta Subnet type and configure the corresponding information.
Subnet types include:

e Subnet Notation
e IP Range
e Batch Add
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5. Enter any Tags to be associated with this subnet. Tags are displayed in Assets when the endpoint IP falls within the
subnet. SeeAsset List on page 157.

6. Optionally, enter a description.
7. Click OK.

Once a subnet has been created, it can be edited, cloned, or deleted by highlighting it and selecting the
corresponding action in Subnet List toolbar.

Creating a subnet group

To create a subnet group:

1. Goto Fabric View > Connectors > Subnets.

2. From the Create New dropdown, select Subnet Group.
The New Subnet Group wizard opens.

New Subnet Group x

Name

Subnets Click here to select
Subnet Groups Click here to select
Tags Press enter to add tags

Description

Enter a name for the subnet group.

Select the subnet entries to be included in the group and select OK in the pop-up window.

Optionally, select one or more existing subnet groups to be nested in the new subnet group as a member.

Enter any Tags to be associated with this subnet group. Tags are displayed in Assets when the endpoint IP falls
within the subnets that are a part of this group. SeeAsset List on page 157.

Optionally, enter a description.

8. Click OK.

Once a subnet group has been created, it can be edited, cloned, or deleted by highlighting it and selecting the
corresponding action in Subnet List toolbar.

o g kv

N

Assigning subnet filters to event handlers

You can streamline SOC processes by defining a subnet whitelist/blacklist for event handlers. These addresses can be
linked to any event handler through a data selector, enabling or preventing the selected subnets from triggering an
event. Creating a subnet whitelist/blacklist in data selectors eliminates the need to specify common networks in every
event handler.

To include or exclude subnets in an event handler:

1. Goto Incidents & Events > Handlers > Data Selectors.
2. Click Create New.
The Add New Data Selector pane displays.
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You can also Clone or Edit an existing data selector to include or exclude subnets.
3. Inthe Subnets field, select Specify.
The Include Subnets and Exclude Subnets fields display.
4. Selectthe subnets to include or exclude in event handlers as part of the data selector.
5. Configure the other options for the data selector, and click OK. For more information, see Creating data selectors on

Add New Data Selector x
Name* Test-Data Selector
Devices IR specify | Local Device
Subnets All Subnets
Include Subnets Q
Finance x
1 entry selected
Exclude Subnets Q
Management x
marketing x
2 entries selected
Filters Any of the following conditions

+

6. Goto Incidents & Events > Handlers > Basic Handlers.
7. Selectan event handler to add the data selector to, and click Edit.
The Edit Basic Event Handler pane displays.
You can also create a custom event handler to add the data selector to.
8. From the Data Selector dropdown, select the data selector configured to include or exclude the selected subnets.

9. Configure the other options for the event handler, and click OK. For more information, see Creating a custom event
handler on page 216.

Edit Basic Event Handler x
Status ©
Name* Default-Compromised Host-Detection-IOC-By-Threat
Description

Default event handler to detect compromised hosts by IOC feature grouped by threat

Data Selector No Data Selectors

Automation Stitch
Q +

Rules Compromised Host Detection Selector

Default Intrusion Selector For Malicious Code Detection

© & Traffic to CnC detecte
Default IP Scanning Selector For Recon Activity Detection

© & Web traffic to CnC de Default Local Device Selector

R Default Malicious File Selector For Malicious File Detection

© & DNS traffic to CnC de

Default Risky App Selector For Risky App Detection

Default-Malicious-Code-Detection-By-Endpoint Selector

Default-Malicious-Code-Detection-By-Threat Selector

Handler Settings

Notifications Click to select

10. Add the data selector to other event handlers, as needed.

Al
S L4
? If a conflict arises between the exclude and include lists, the exclude list will take priority.
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Ay
‘Q' Subnet filters work when either SRCIP or DSTIP hit the subnet, meaning SRCIPs and DSTIPs
- share the same subnet filters.
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FortiAnalyzer can recognize a Security Fabric group of devices and display all units in the group on the Device Manager
pane. See Adding a Security Fabric group on page 168. FortiAnalyzer supports the Security Fabric by storing and
analyzing the logs from the units in a Security Fabric group as if the logs are from a single device. You can also view the
logging topology of all units in the Security Fabric group for additional visibility. See Displaying Security Fabric topology
on page 169.

FortiAnalyzer provides dynamic data and metadata exchange with the Security Fabric and uses the data in FortiView
and Reports for additional visibility. A default report template lets you monitor new users, devices, applications,
vulnerabilities, threats and so on from the Security Fabric.

A set of dashboard widgets lets you review audit scores for a FortiGate Security Fabric group with recommended best
practices and historical audit scores and trends.

If FortiClient is installed on endpoints for endpoint control with FortiGate, you can use the endpoint telemetry data
collected by the Security Fabric agent to display user profile photos in reports and FortiView.

Adding a Security Fabric group

Before you can add a Security Fabric group to FortiAnalyzer, you need to create the Security Fabric group in FortiGate.

Fortinet recommends using a dedicated Super_User administrator account on the FortiGate for FortiAnalyzer access.
This ensures that associated log messages are identified as originating from FortiAnalyzer activity. This dedicated
Super_User administrator account only needs Read Only access to System Configuration; all other access can be set to
None.

To add a Security Fabric group:

1. Go to Device Manager > Unauthorized Devices.
2. Select all the devices corresponding to the Security Fabric group created in FortiGate.

3. Authenticate the Security Fabric group by clicking the Warning icon (yellow triangle) beside the corresponding
FortiGate root.

Authentication

Please enter admin user name and password for the root device of security fabric "csf80cm”.

Admin User ||

Password

4. Enterthe Authentication Credentials. The authentication credentials are the ones you specified in FortiGate. Once
the FortiGate root has been authenticated, the Warning icon will disappear.

5. After authentication, it takes a few minutes for FortiAnalyzer to automatically populate the devices under the
FortiGate root which creates the Security Fabric group.
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Displaying Security Fabric topology
For Security Fabric devices, you can display the Security Fabric topology.

To display the Security Fabric topology:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.

2. Goto Device Manager.

3. Right-click a Security Fabric device and select Fabric Topology.
A pop-up window displays the Security Fabric topology for that device.
If you selected Fabric Topology by right-clicking a device within the Security Fabric group, the device is highlighted
in the topology. If you selected Fabric Topology by right-clicking the name of the Security Fabric group, no device is
highlighted in the topology.

Topology for FGP2000000000000

HA Active-Passive

FGT200DPOE-L1-root B3 FGBLE-HA-L2 — 55} FG2B0DPOE-L3

-
2mh FGE1E-HA-LS

FGVM-076-12

Security Fabric traffic log to UTM log correlation

FortiAnalyzer correlates traffic logs to corresponding UTM logs so that it can report sessions/bandwidth together with its
UTM threats. Within a single FortiGate, the correlation is performed by grouping logs with the same session IDs, source
and destination IP addresses, and source and destination ports.

In a Cooperative Security Fabric (CSF), the traffic log is generated by the ingress FortiGate, while UTM inspection (and
subsequent logs) can occur on any of the FortiGates. This means that the traffic logs did not have UTM related log fields,
as they would on a single FortiGate. Different CSF members also have different session IDs, and NAT can hide or
change the original source and destination IP addresses. Consequently, without a proper UTM reference, the
FortiAnalyzer will fail to report UTM threats associated with the traffic.

This feature adds extensions to traffic and UTM logs so that they can be correlated across different FortiGates within the
same security fabric. It creates a UTM reference across CSF members and generates the missing UTM related log fields
in the traffic logs as if the UTM was inspected on a single FortiGate.

NAT translation is also considered when searching sources and destinations in both traffic and UTM logs. The FortiGate
will generate a special traffic log to indicate the NAT IP addresses to the FortiAnalyzer within the CSF.

Traffic logs to DNS and SSH UTM references are also implement - the DNS and SSH counts in Log View can now be
clicked on to open the related DNS and SSH UTM log. IPS logs in the UTM reference are processed for both their
sources and destinations in the same order, and in the reverse order as the traffic log. The FortiGate log version indicator
is expanded and used to make a correct search for related IPS logs for a traffic log.

FortiAnalyzer 7.4.0 Administration Guide 169
Fortinet Inc.



Fortinet Security Fabric

This feature requires no special configuration. The FortiAnalyzer will check the traffic and UTM logs for all FortiGates
that are in the same CSF cluster and create the UTM references between them.

To view the logs:

1. Onthe FortiAnalyzer, go to Log View > FortiGate > Traffic.
The UTM security event list, showing all related UTM events that can happen in another CSF member, is shown.

2. Click the count beside a UTM event to open the related UTM event log window. In this example, the traffic log is
from the CSF child FortiGate, and the UTM log is from the CSF root FortiGate.

Device Mame Policy I

FGT_100D_CSF root 2 1011012

Action Saurce

=I-Security
Level waming

Threat Level eritical -
Threat Score 50 4
=I-Source -4
Agent RIFTLRT =)- Des.
Device I FGLO0D3G1 4840718 £
Device Mame FGT_1000_C57 oot L
o Liser 1D 3 -
Endpeint I s4242 !
" 1011012 -1
Intterface Ly i
Fterface Rale lan =D
Part 33761 e

Like other UTM logs, newly added DNS and SSH UTM references can also be shown in the FortiAnalyzer Log View.

Clicking the count next to the DNS or SSH event opens the respective UTM log.
3. Goto FortiView > Threats > Top Threats. All threats detected by any CSF member are shown.

Add Filter &

Threat Score = Critical - High Medium Low
100.

a0

&0

40

20

o T T T T T

150500 151000 151500 152000 152500 15:30:00
@ Threat Category CVEID Threat Level Threat Scorel - Blocked ™ Incidents| - Blocked m
Allowed) Allved)

1 Wa2PaiteB Malware 300 5
2 EICAR TEST FILE Malware 250 5
3 kprowy.com Preoy Avoldance Medium 60— &
4 K Prooy Preoy Medium 50 - 5
2= Total logs stored for analytics: 42 days 22 hours. Show 100« | Total 4

4. The created UTM reference is also transparent to the FortiGate when it gets its logs from the FortiAnalyzer. On the
FortiGate, the traffic log shows UTM events and referred UTM logs from other CSF members, even though the
FortiGate does not generate those UTM log fields in its traffic log. In this example, the CSF child FortiGate shows
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the referred UTM logs from the CSF root FortiGate.
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HA Events 21 17 minutes ago @0 00:06:29:29:92:72 172.18.32.126 [ wiee [l wee B Direction autgoing
WAN Opt. & Cache Events 22 19 minutes ago @0 00:0¢:29:29:92:72 172.18.32.92 Log event ariginal timestamp 1547077055
iEi il T —oscocssss Ts cTTen oo .|| Event Type urlmonitor
WiFi Events - <<l 1 s Hostname 172.1832.12c.

Security Fabric ADOMs

All Fortinet devices included in a Security Fabric can be placed into a Security Fabric ADOM, allowing for fast data
processing and log correlation. Fabric ADOMs enable combined results to be presented in the Device Manager, Log
View, FortiView, Incidents & Events and Reports panes.

In a Fabric ADOM:
o Device Manager: View and add all Fortinet devices in the Security Fabric to the Fabric ADOM, including FortiGate,
FortiSandbox, FortiMail, FortiDDoS, and FortiClient EMS.
o Log View: View logs from all Security Fabric devices.
o FortiView: FortiDDoS and FortiClient EMS widgets are available.

e Incidents & Events: Predefined event handlers for FortiGate, FortiSandbox, FortiMail, and FortiWeb ADOMs are
available, and triggered events are displayed for all device types.

» Reports: View predefined reports, templates, datasets, and charts for all device types. Charts from all device types
can be inserted into a single report.

Creating a Security Fabric ADOM

To create a Fabric ADOM:

1. InFortiAnalyzer, go to System Settings > ADOMs.
2. Select Create New.

3. Configure the settings for the new Fabric ADOM and select Fabric as the type.
See Creating ADOMs on page 306 for more information on the individual settings.
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nterprise_FortiAnalyzer
Dashboard

= Device Manager

B FortiView >
M Log View >
@ Fabric View >
[ Incidents & Events >
B FReports >

| System Settings

Administrators

Admin Profiles

Remote Authentication 5...
Fabric Management

SAML SSO

Settings

HA

Network

Event Logs

Certificates

Advanced

4. Select OKto create the ADOM.
The Fabric ADOM is listed under the Security Fabric section of All ADOMs.

Dashboard

B Device Manager

& Fortiview >

M Log View >
B Fabric View >
[ Incidents & Events >
B Reports >

|# System Settings

Administrators

Admin Profiles

Remote Authentication S...
Fabric Management

SAML S5O

Settings

HA

Network

Event Logs

Certificates

Advanced

*If analytic or archive log usages exceed the configured disk quata before the retention period

expires, the oldest logs will be deleted

ADOM:root  >- @+ L[z -~ @Admin o
Create ADOM
Narne
This field is required.
Type Fabric
Time Zone [ -
Q =
Description
v Fabric
FortiAnalyzer
FortiAuthenticator L
Devices FortiCache Search...
FortiCarrier Fess = Platform
FortiClient [
FortiDDo$
FortiDeceptor
Data Policy
Keep Logs for Analytics 60 Days -
Keep Logs for Archive 365 Days -
Disk Utilization
Allocated 15990 MB ~ | Maximum Available: 15.6
GB
Analytics: Archive 70% - || 30% O Modify
Alert and Delete When Usage Reaches 90% -

[ Edit 0 Search...
O Name= Comments +  Analytics (Actual/Config Days) =+ = Archive (ﬂ
[m} root Fabric 32GB 7 Devices (including 7 VDOMs) > 0/14 (0%)
[m} FortiProxy FortiProxy 1000 MB 0/60 (0%)
[m] FortiFirewallCarrier | FortiFirewallCarrier 1000 MB 0/60 (0%)
[m} FortiFirewall FortiFirewall 1000 MB 0/60 (0%)
[m] FortiDeceptor FortiFirewall 1000 MB 0/60 (0%)
[m} FortiCarrier FortiCarrier 1000 MB 0/60 (0%)

Oo0oo0oO0O0OO0O0OO0OO000a0

Chassis
Syslog
FortiWeb
FortiSandbox
FortiNAC
FortiManager
FortiMail
FortiDDoS
FortiClient
FortiCache
FortiAuthenticator

FortiAnalyzer

Syslog

FortiWeb
FortiSandbox
FortiNAC
FortiManager
FortiMail
FortiDDoS
FortiClient
FortiCache
FortiAuthenticator

FortiAnalyzer

1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB

Migrating to a Fabric ADOM

0/60 (0%)
0/60 (0%)
0/60 (0%)
0/60 (0%)
0/60 (0%)
0/60 (0%)
0/60 (0%)
0/60 (0%)
0/60 (0%)
0/60 (0%)
0/60 (0%)

You can change an existing non-Fabric ADOM to a Fabric ADOM using the FortiAnalyzer CLI.

1. Inthe FortiAnalyzer CLlI, enter the following commands:

execute migrate fabric <fabric name>
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A note is displayed informing you of the number of ADOMs that will be affected, and once begun, a summary is
displayed and the system will reboot.

Enabling SAML authentication in a Security Fabric

When FortiGate is configured as a SAML SSO IdP in a Security Fabric, FortiAnalyzer can register itself to FortiGate as
an SAML service provider, allowing for simplified configuration of SAML authentication.

When FortiAnalyzer is configured as a Fabric SP, a default SSO administrator is automatically created for each Security
Fabric. When a user logs in through Fabric SSO, the Fabric IdP provides the user's profile name. If FortiAnalyzer has a
profile with a matching name, the profile is assigned to the user. Otherwise, the profile of the SSO administrator is
assigned to the user by default.

Before configuring FortiAnalyzer as a Fabric SP, Security Fabric Connection and FortiAnalyzer Logging must be
configured on the root FortiGate.

YL
‘9' When ADOMs are enabled, SSO users can only access the ADOM that includes the root
FortiGate.

To configure FortiAnalyzer as a Fabric SP:

1. Enable SAML SSO on the root FortiGate in the Security Fabric. For more information, see the FortiGate
documentation in the Fortinet Document Library.

2. On FortiAnalyzer, enable the Fabric SP Single Sign-On Mode.
a. Goto System Settings > SAML SSO.

Select Fabric SP as the Single Sign-On Mode.

Enter the address of the FortiAnalyzer SP.

Select a Default Admin Profile.

Click Apply.

Single Sign-On Settings

200U

Server Address €
Allow admins to login with FortiCloud @ ©
Single Sign-On Mode Disabled Identity Provider (IdP) Service Provider (SP) Fabric SP

In Fabric SP mode, an SSO administrator is created for each Security Fabric. When a user
logs in via Fabric SSO, the Fabric IdP provides the user’s profile name. If this system has a

o profile with the matching name, the profile is assigned to the user. Otherwise, the profile of
the $SO administrator is assigned to the user by default.

Default Admin Profile @ Super_User -
Fabric IdPs
Search
[0 | Root Device ADOM Name Status IdP Settings u
Entity ID:
O FGVMO1TM19006435 Enabled | Login URL:
Logout URL:
Entity ID:
0O FGVYMO02TM20007869 Enabled Login URL:
Logout URL:
Entitv ID: htto:,

Apply

The FortiAnalyzer will automatically detect the IdP FortiGate and register itself as a SAML SP. This process may
take up to ten minutes. Once completed, IdP information is displayed in the Fabric SP table on FortiAnalyzer, and
SP information can be viewed in FortiOS.
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3. Sign in using Fabric SSO.
Users are presented with the Login via Fabric Single Sign-On option on the FortiAnalyzer login page. When more
than one Security Fabric with SAML SSO enabled is configured, you are presented with the option to select which
Fabric login to use.

FortiAnalyzer-VMé64

Login via Fabric Single Sign-On

Fabric devices configured to the IdP can be accessed through the Security Fabric members dropdown which
appears in the top-right corner of the toolbar.

FabricRoot_FortiGate SecurityFabric v @ 02 (&) admin

FGVMO0TM20002507
FortiGate-VM64

V6.4.0 build1560 (Interim)

Management IP/FQDN 172.27.2.248
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Incidents & Events

Use Incidents & Events to generate, monitor, and manage alerts and events from logs. The live monitoring of security
events is a powerful and enabling feature for security operations. Incidents can be created from events to track and
respond to suspicious or malicious activities.

Event Monitor

After event handlers start generating events, view events and event details in Incidents & Events > Event Monitor.

\‘é', When rebuilding the SQL database, you might not see a complete list of historical events.

However, you can always see events in real-time logs. You can view the status of the SQL
rebuild by checking the Rebuilding DB status in the Notification Center.

All Events

To view all the events, go to Incidents & Events > Event Monitor > All Events.
Double-click an event line to drill down for more details.

Hover your mouse over an entry to view the asset and identity information for that event.

£ Enterprise_FortiAnalyzer =

@ Dashboard PUIYSSl By Endpoint ~ | By Threat v | System Events v | Custom View v | Toggle Views O
| Device Manager
a B Al Devices + @ Last 7 Days..» ,”Expand All O Show Acknowledged DiRefresh~ % EB~ &
i FortiView >
[ Add Fitter] [} ‘
M LogView >
Fabric Vi , o # Event Event Statu Event Type Count  Severity First Occurrence ¥ Last Update Additional Info Handler
B incid oy o1 >10.100.91.... Unhandled ... 4378 @Critical 5 hours ago Aminute ago E
M Incidents & Events v
" o 2 >10.100.91.... Unhandled SIEM 1420 High 4 hours ago Aminute ago SIEM_Alerts_Normaliz
Exenchionkcon O 3 >176.31.62.... Unhandled %# Traffic 2125 @ Critical | 5 hours ago A minute ago - Default-Compromisec
s 0 |4 | >10200.11.. Unhandied ... 190 | @Critical | 5hoursago Aminute ago .
Incidents O 5 >23.25346... Unhandied & Traffic 2079  @Critical | 5 hours ago Aminute ago Default-Compromisec
Threat Hunting O 6  >1488111. Unhandied & Traffic 2123 @Critical | 5 hours ago Aminute ago . Default-Compromisec
Log Parser o7 >10.200.1.1... Unhandled % Traffic 147 @ Critical | 5 hours ago A minute ago - Default-Compromisec
Outbreak Alerts o 8 >10.200.1.1... Unhandled .. 156 @ Critical | 5 hours ago Aminute ago
Reports > 9 > Branch_O.. - 3866 High 5 hoursago Aminute ago
[m)
B Management Extensions [0 10  >Branch O. B 3546 @ Critical | 5 hours ago Aminute ago o .
& System Settings O 11 > §192.168.. Contained SIEM 398 Medi... 5 hours ago Aminute ago Threat: EICAR_TEST_FILE ... SIEM_Alerts_Normali:
o 12 > fe80:d978... Unhandled E Event 18019 @ Critical 5 hours ago A minute ago FGT detected traffic to 10... | Default-Compromisec
F:iERTINET
Devices To view events for specific devices, click the devices dropdown and select a
device.
Time Period To change the time period to display, click the time icon and specify a time period.
Select Custom to specify a time period not in the dropdown list.
Collapse All/Expand All To view event summaries or details, click Collapse All or Expand All.
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Show Acknowledged

Refresh

Custom View

Column Settings

Export to CSV

Default event views

To include acknowledged events, click Show Acknowledged. See Acknowledging
events on page 178.

To manually refresh the events data, click Refresh.
You can specify a refresh interval of Every 10 Seconds, Every 30 Seconds, Every

1 Minute, or Every 5 Minutes.

Save the current view including filter settings, device selection, and time period.

Select which columns are displayed in the All Events pane. Columns not
displayed by default include

Acknowledged, Acknowledged By, Acknowledged Time, Assigned To, Comment,
Commented By, Commented Time, Device ID, Device Type, Event ID, Group By,
Group By 2, Group By 3, Indicators, Last Occurence, and VDOM Name.

Download the events to a CSV file.

FortiAnalyzer event handlers apply one or more tags to events, allowing the events to be grouped into views in the Event
Monitor. These views are visible in the navigation.

Default views are organized into three view categories under Incidents & Events > Event Monitor:

« By Endpoint. Provides security event views from an endpoint perspective.
» By Threat: Provides security event views from a threat perspective.
» System Events: Provides event views which cover device system events.

In order for events to be displayed in default views, the corresponding event handler(s) must be enabled. Refer to the
chart below for a list of the predefined event handlers that must be enabled to support each default view:

View category

Default view

Required predefined event handler

By Endpoint

All Security Events

Compromised Hosts

Sandbox Detections

Malware Activity

Ongoing Intrusions
Malicious Domain/URL Access

High Risk App Usage

FortiAnalyzer 7.4.0 Administration Guide

Fortinet Inc.

Displays all events within category with enabled handlers

Default-Botnet-Communication-Detection-By-Endpoint
Default-Compromised Host-Detection-lOC-By-Endpoint

Default-Sandbox-Detections-By-Endpoint

Default-Sandbox-Detections-By-Endpoint
Default-Malicious-File-Detection-By-Endpoint

Default-Malicious-Code-Detection-By-Endpoint
Default-Risky-Destination-Detection-By-Endpoint

Default-Risky-App-Detection-By-Endpoint
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View category Default view
By Threat All Security Events
C&C Call Backs

Sandbox Detections

Malware Activity

Ongoing Intrusions
Malicious Domain/URL Access
High Risk App Usage
System Events Local Device
All
FortiGate

Required predefined event handler
Displays all events within category with enabled handlers

Default-Botnet-Communication-Detection-By-Threat
Default-Compromised Host-Detection-lOC-By-Threat

Default-Sandbox-Detections-By-Threat

Default-Sandbox-Detections-By-Threat
Default-Malicious-File-Detection-By-Threat

Default-Malicious-Code-Detection-By-Threat
Default-Risky-Destination-Detection-By-Threat
Default-Risky-App-Detection-By-Threat

Local Device Event

Displays all events within category with enabled handlers

Default FOS System Events

Default views can be hidden or disabled. For more information, see Managing default views.

Admins can copy existing views to create custom views. For more information, see Creating custom views.

Filtering events

Filter the Event Monitor using Add Filter in the toolbar or by right-clicking an entry and selecting a context-sensitive filter.

You can also filter by specific devices or timeframes.

To filter events using filter mode:

1. Inthe Add Filterfield, toggle to filter mode.

The filter icon (@) indicates you are in filter mode. Click the icon to toggle modes, as needed.

N

Click Add Filter, and then select a filter.
In the filter field, type or select a value.

o

To change the filter action, click the equal sign (=) for the filter.

For example, you can select != to make the filter a negate condition.

5. Click Add Filter to add another filter, as needed.

To filter events using text mode:

1. Inthe Add Filterfield, toggle to text mode.

The texticon () indicates you are in text mode. Click the icon to toggle modes, as needed.

2. Type thefilter and its condition. Use the log field names and values.
You can review log field names and values by selecting the filter in filter mode and then toggling to text mode.

You can review the list of available conditions by clicking the equal sign for a filter in filter mode.

3. Toadd more filters, type the connector (AND or OR) and then type the next filter.

FortiAnalyzer 7.4.0 Administration Guide
Fortinet Inc.

177



Incidents & Events

To filter events using the right-click menu:

In the event list, right-click an entry and select a filter criterion (Search <filter value>).
Depending on the column in which your mouse is placed when you right-click, Event Monitor uses the column value as

the filter criteria. This context-sensitive filter is only available for certain columns.

To launch Search in Log View from an event:

In the event list, right-click an entry and select Search in Log View.
Log View will launch with the filter automatically filled in with the following information:

o Log type of the event
« Time range (the first to the last occurrence of the event)
« Eventtrigger and group by value

Viewing event details

In an event list, to view event details, double-click an event line to drill down for more details.

The event details page contains information about the event and a list of all individual logs. You can work on events
using buttons in the toolbar or by right-clicking an event.

« To change what columns to display, click Column Settings or Column Settings > More Columns.
« In event details, to view raw logs, click Tools > Display Raw.

» To switch back to formatted log view, click Tools > Formatted Log.

» To return to the previous page, click the back button.

IPS Signature Lookup

You can view IPS signature information from the event details when they are available by clicking on the link included in
the log's Attack Name column. You can add the Attack Name column to the table using Column Settings.

After clicking the attack name link, a dialog window appears which includes the IPS signature information. You can click
Show Raw Data to display the raw information and access additional features including a search option.

Acknowledging events

Acknowledging an event removes it from the event list. Click Show Acknowledged to view acknowledged events.
You can enable the Acknowledged By and Acknowledged Time columns from the column settings option in the toolbar.
Acknowledged By displays the username of the administrator who acknowledged the event, and Acknowledged Time

displays the time and date that the event was acknowledged.

To acknowledge events:

1. Goto Incidents & Events > Event Monitor and select a dashboard.
2. Inthe eventlist, select one or more events, then right-click and select Acknowledge.
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Assigning events

Events can be assigned to administrators.

To view the administrator assigned to an event, enable the Assigned To column in the table from the column settings
option in the toolbar. The Assigned To column displays the username of the administrator assigned to the event.

To assign an event:

1.

Go to Incidents & Events > Event Monitor and select a dashboard.

2. Right-click on an event, and click Assign To.

The Assign to User dialog appears.

Assign to User

User | admin (Super_User)

Assign to myself

Select a user from the dropdown or select Assign to myself, and click Save.
When enabled, the Assigned To column displays the username of the administrator assigned to the event.

B | Devices + @ last7Days~ ,*Expand Al [ Show Acknowlediged 23 Refresh|~ &

B~ &

Add Filter

Count  Severity  First Occurrence ¥ Last Update Additional Info Handler Tags Device Name Assigned To
[ ~ ' L [ -

2912 ®Critical  8daysago Aminute ago Default-Compromised Host-D... Enterprise_Second_Flaor
3510 @®Critical 8 days ago 2 minutes ago Default-Compromised Host-D... Enterprise_Second_Floor
5043 @ Critical 8 days ago 2 minutes ago infected-ip: 23.253.46.64,.. :80... Default-Compromised Host-D... Enterprise_Second_Floor, ... |
9618 ®Critical 8 days ago 2 minutes ago infected-ip: 23.253.46.64,.. :80... Default-Compromised Host-D... Enterprise_Second_Floor, ... 1
12291 @ Critical 8 days ago 2 minutes ago infected-ip: 23.253.46.64,.. :80... Default-Compromised Host-D... Enterprise_Second_Floor, ... 1
6301 ®Critical 8 days ago 3 minutes ago Default-Compromised Host-D... C Enterprise_Second_Floor 1
8168 ®Critical 8 days ago 3 minutes ago Default-Compromised Host-D... Enterprise_Second_Floor 1
7346 ®Critical 8 days ago 3 minutes ago Default-Compromised Host-D... C Enterprise_Second_Floor 1
7397 ®Critical 8 days ago 4 minutes ago infected-ip: 23.253.46.64,.. :80... Default-Compromised Host-D... Enterprise_Second_Floor 1
3740 @®Critical 8 days ago 4 minutes ago Default-Compromised Host-D... Enterprise_Second_Floor 1

4 minutes ago Default-Compromised Host-D... Enterprise_Second_Floor
9902 @ Critical 8 days ago 5 minutes ago Default-Compromised Host-D... Enterprise_Second_Floor
4059 ®Critical 8 days ago 5 minutes ago Default-Compromised Host-D... Enterprise_Second_Floor 1
8332 @ Critical 8 days ago 5 minutes ago Default-Compromised Host-D... Enterprise_Second_Floor, ... |
8425 @Critical 8 days ago 5 minutes ago Default-Compromised Host-D... Enterprise_Second_Floor, .. 1
15978  @Critical 8 days ago & minutes ago Default-Compromised Host-D... Enterprise_Second Flaor, ... |
11664  @Critical 8 days ago & minutes ago Default-Compromised Host-D... Enterprise_Second_Floor, .. 1
3202 @ Critical 8 days ago & minutes ago infected-ip: 23.253.46.64,.. :80... Default-Compromised Host-D.. Enterprise_Second_Floor |

3551 ® High 8 days ago An hour ago Default-FCT-Threat-Detection..

Enterprise_ QA
Enterprise QA

10484 @ High 8 days ago 3 hours ago Default-FCT-Threat-Detection...
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Managing default views

Default views in the By Endpoint, By Threat, and System Events view categories can be hidden, disabled, or copied as a
custom view, allowing you to display only the views that are useful to the user.

To hide default views:

1. Goto Incidents & Events > Event Monitor.
2. Click the menu icon for a default view.

3. Click Hide.

£12 Enterprise_FortiAnalyzer

@ Dashboard JXJYUW By Endpoint v | By Threat v | System Events v | Custom View v | Toggle Views O
f Device Manager B AlDe| Al Security Events O Show Acknowledged CRefresh~ & B~ &
i Fortiview ’ il Compromised Hosts ‘
B LogView ? M Sandbox Detections - i °
@ Febric View s o # o Count Severity  First Occurrence ¥Last Update Additional Info Handler
B Incidents & Everts o MR @Hide 3707  ®High 5 hoursago Afew seconds ago SIEM_Alerts_ Normali )
w o 2 Ongoing Intrusiens ™ 158  @Critical | 5 hours ago A few seconds ago Default-Compromisec
[mE] Malicious Domain/URL Access 2276  @Critical |5 hours ago A few seconds ago Default-Compromisec
Handlers O a High Risk App Usage 2273 | @Critical |5 hours ago Afew seconds ago Default-Compromisec
(et 2w O 5 1020012 Unhandied | 190  @Critical |5 hours ago Afew seconds ago
T Iy 0 6  >Branch.O.. 4123 High 5 hours ago Afew seconds ago
Log Parser o7 Enterprise_... £ System 24 High 5 hours ago Aminute ago
Outbreak Alerts o 8 »10.200.1.7... Unhandled %k Traffic 157 @ Critical | 5 hours ago Aminute ago Default-Compromisec
FoATINET 0O 9  >BranchO. 3824  @Critical |5 hours ago Aminute ago

To toggle default views:

1. Goto Incidents & Events > Event Monitor > Toggle Views.
2. Select the Default Views that should be visible in the GUI navigation.
3. Click Save.

£12 Enterprise_FortiAnalyzer

@ Dashboard AllEvents | ByEndpoint v | ByThreat v | System Events v | Custom View v [RCTSVS [ m}

= Device Manager
= Toggle Default Views

FortiView >

M LogView > | By Endpoint

@ Fabric View ? All Security Events
[ Incidents & Events v Compromised Hosts

O Sandbox Detections
Malware Activity

Event Monitor

Handlers O Ongoing Intrusions
Incidents O Malicious Domain/URL Access
Threat Hunting 0 High Risk App Usage
By Threat
Log Parser
All Security Events
Outbreak Alerts C8.C Call Backs
B Reports > O Sandbox Detections
P O Malware Activity

@ Management Extensions
Ongoing Intrusions

O Malicious Domain/URL Access
[0 High Risk App Usage

System Events

£ System Settings

Local Device
All
FortiGate

Save

FZERTINET

Creating custom views

To create a custom view:

1. Goto Incidents & Events > Event Monitor.
2. Goto an existing view to copy.
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3. Add filters that you want to include in the custom view.
4. Click the custom view icon in the toolbar.
5. Enter a name for the custom view and assign it to one of the following categories:
« By Endpoint
o By Threat
o System Events
o Custom View

Save as New Custom View

Name

Category \ By Endpoint

Public

Privacy © Others can see this Custom View

6. Inthe Privacy field, toggle the custom view visibility.
« Public: Others can view this custom view displayed in Incidents & Events > Event Monitor > Custom View.

 Private: Only you can see this custom view displayed in Incidents & Events > Event Monitor > Custom View.

7. Select OKto save the view.

Ay
‘9' When upgrading from versions prior to 6.2.0, existing custom views will be placed in the
- Custom View category.

To edit a custom view:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Inthe navigation, click the menu icon for the custom view.
For example, click the menu icon for a custom view in Incidents & Events > Event Monitor > Custom View.

3. Inthe menu, click one of the following options:

 Edit: change the name or category of the custom view.

» Share with Others: change the privacy setting for the custom view.

» Save: after opening the custom view and changing the filters, save the custom view.

» Save As: after opening the custom view and changing the filters, save a new custom view.

» Delete: delete the custom view.
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Understanding event statuses

In the Event Monitor dashboards, you can view the status of an event in the Event Status column. Event statuses include
Unhandled, Mitigated, Contained, and (blank).

Event statuses are applied by the associated event handler. When creating a custom event handler, you can manually
select an event status or choose to allow FortiAnalyzer to decide.

In general, when Allow FortiAnalyzer to choose is selected, the event status for UTM events is applied based on the

following:

Event status Description

Unhandled The security event risk is not mitigated or contained, so it is considered open.
Example: an IPS/AV log with action=pass will have the event status Unhandled.
Botnet and IoC events are also considered Unhandled.

Contained The risk source is isolated.
Example: an AV log with action=quarantine will have the event status Contained.

Mitigated The security risk is mitigated by being blocked or dropped.
Example: an IPS/AV log with action=block/drop will have the event status
Mitigated.

(Blank) Other scenarios.

Event handlers

Basic event handlers and correlation event handlers determine what events are generated from logs.

For basic event handlers, an event is generated when one of the rules in the event handler is met. Each rule in the basic
event handler has an OR relationship with the others.

For correlation event handlers, an event is generated when a set of rules are met in correlation sequence. For correlation
handlers, you can define both the rules and the operators (AND, AND_NOT, OR, FOLLOWED_BY, and NOT _
FOLLOWED_BY).

There are predefined event handlers for FortiGate, FortiSandbox, FortiMail, and FortiWeb devices. In a Security Fabric
ADOM, all predefined event handlers are displayed. Some predefined event handlers are disabled by default, but you
can enable them from the GUI.

You can also create your own custom event handlers. An easy way to create a custom event handler is to clone a
predefined event handler and customize its settings.

Data selectors and notification profiles are configured separately from event handlers, and then selected as part of
configuring predefined or custom event handlers as needed. Data selectors determine which devices, subnets, and
filters to use for the handler, and notification profiles determine if and where to send alert notifications when an event is
generated by the handler. These groupings promote reusability, which results in increased efficiency and a reduction in
human error when configuring event handlers.
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When ADOMs are enabled, each ADOM has its own event handlers and list of events. Ensure you are in the correct
ADOM when working in Incidents & Events. You can import and export the event handlers, allowing you to develop
custom event handlers and deploy them in bulk to other ADOMSs or FortiAnalyzer units, if needed.

NP Event handlers generate events only from Analytics logs and not Archive logs. For more
‘Q' information, see Analytics and Archive logs.
- In an Analyzer—Collector collaboration scenario, the Analyzer evaluates the event handlers.
= For more information, see Analyzer—Collector collaboration.

In Incidents & Events > Handlers, you can manage the Data Selectors, Notification Profiles, Basic Handlers, and
Correlation Handlers separately.

In this section, you will find the following topics:

Predefined event handlers on page 183

Predefined correlation handlers on page 209

Creating data selectors on page 213

Creating notification profiles on page 215

Creating a custom event handler on page 216

Creating a custom correlation handler on page 219

Using the Automation Stitch for event handlers on page 224
Using the Generic Text Filter on page 224

Managing event handlers on page 225

Enabling event handlers on page 226

Cloning event handlers on page 226

Resetting predefined event handlers to factory defaults on page 226
Importing and exporting event handlers on page 227

Predefined event handlers

FortiAnalyzer includes many predefined event handlers that you can use to generate events. You can easily create a

custom event handler by cloning a predefined event handler and customizing its settings. See Cloning event handlers on

page 226.

If you wish to recieve notifications from a pedefined event handler, configure a notification profile and assign it to the
event handler. See Creating notification profiles on page 215.

Al
‘Q' In 6.2.0 and up, predefined event handlers have been consolidated and have multiple rules
- that can be enabled or disabled individually.
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To view predefined event handlers in the FortiAnalyzer GUI, go to Incidents & Events > Handlers > Basic Handlers. From

the More dropdown, select Show Predefined.

+ Create New | |4 Edit |[@i De % C § More v

O | Status Name OE ‘m\es

Show Predefined

o ©
O Show Custom
3] Import

O ©  Default-Compromised Host-Detection-og| = ©
C

O ©  Default-Risky-Destination-Detection-By-Endpoint

Data Selector n

Rule-1 Traffic to Botnet CnC blocked in virus log: (Default By_Endpoint Botnet IPC&C) logid==0202009248
Rule-2 Traffic to Botnet CnC detected in virus log: (Default By_Endpoint, Botnet IP.CSC) logid==

Rule-3 DNS traffic to Botnet CnC blocked: (Default By_Endpoint Botnet Domain C&C) logid==1501054601 OR logid==1
Rule-4 Traffic to Botnet CnC detected i ips log 1: (Default By_Endpoint Botnet Signature.C&C) attack ~ Botnet and direc

Rule-1 Traffic to CnC detected: (Default.By_Endpoint.IP.CSC loc_Rescan) tdtype-infected
Rule-2 Web traffic to CnC detected: (DefaultBy_Endpoint C&C,URL loc_Rescan) tdtype-infected

1 To blocked AND (cat
detected: (Def Equal To blocked ANI

n detected: (Default

isky URL) Action Not Equal To blocked AN

Rule-4 DNS request to malicious destination detected: (Default.By_Endpoint Risky.Domain) logid==1501054802 and (cat

efault By_Er

Default Intrusion Selector For Malicious Co

O ©  Default-Malicious-Code-Detection-By-Endpoint

The following are a small sample of FortiAnalyzer predefined event handlers.

Event Handler Description

Disabled by default
Rule 1: Traffic to CnC detected

Default-Compromised Host-
Detection-lOC-By-Threat

Event Severity: Critical
Log Type: Traffic Log > Any
Group by: Destination IP, Source Endpoint
Log messages that match all of the following conditions:
* tdtype~infected
Tags: IP, C&C, loc_Rescan
Custom Message: Traffic to C&C:${dstip}, Traffic path: PolicylD
${policyid\${dstintf\${dstip}:${dstport}

Rule 2: Web traffic to CnC detected

FortiAnalyzer 7.4.0 Administration Guide
Fortinet Inc.

Event Severity: Critical

Log Type: Web Filter

Group by: Hostname URL, Source Endpoint

Log messages that match all of the following conditions:
o tdtype~infected

Tags: C&C, URL, loc_Rescan

Custom Message: Traffic to C&C:${hostname}, Traffic path: PolicylD
${policyid)\${dstintf\${dstip}:${dstport}
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Event Handler Description

Rule 3: DNS traffic to CnC detected

Default-Data-Leak-Detection-
By-Threat

Default-Sandbox-Detections-
By-Endpoint
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Event Severity: Critical

Log Type: DNS Log

Group by: QNAME, Source Endpoint

Log messages that match all of the following conditions:
¢ tdtype~infected

Tags: C&C, Domain, loc_Rescan

Custom Message: Traffic to C&C:${qname}, Traffic path: PolicylD
${policyid)\${dstintf\${dstip}:${dstport}

Rule 4: Traffic to CnC event detected by FortiGate

Event Severity: Critical
Log Type: Event Log
Log messages that match all of the following conditions:
¢ logid==0100020214
Tags: C&C
Custom Message: FGT detected traffic to IOC location, from the source
ip:${srcip}

Disabled by default
Rule 1: Data leak detected

Event Severity: Medium

Log Type: DLP

Group by: Filter Category, Source Endpoint

Tags: Signature, Leak

Custom Message: File:${filename} (Type:${filetype}, Size:${filesize}), Traffic
path: PolicylD ${policyid)\${dstip}:${dstport}

Rule 2: Data leak blocked

Event Severity: Low

Log Type: DLP

Group by: Filter Category, Source Endpoint

Event Status: Mitigated

Tags: Signature, Leak

Custom Message: File:${filename} (Type:${filetype}, Size:${filesize}), Traffic
path: PolicylD ${policyid}\${dstip}:${dstport}

Disabled by default
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Event Handler Description

Rule 1: Malware detected
» Event Severity: Critical
e Log Type: AntiVirus
» Group by: Source Endpoint, Virus Name
¢ Log messages that match all of the following conditions:
¢ logid==0211009235 or logid==0211009237
e Tags: Sandbox, Signature, Malware

« Custom Message: Malware:${virus} with severity:${crlevel} found in
file:${filename} from ${dstip}:${dstport}, Reference: ${ref}

Rule 2: Malware blocked
« Event Severity: Critical
e Log Type: AntiVirus
» Group by: Source Endpoint, Virus Name
¢ Log messages that match all of the following conditions:
¢ logid==0211009234 or logid==0211009236
e Tags: Sandbox, Signature, Malware

» Custom Message: Malware:${virus} with severity:${crlevel} found in

file:${filename} from ${dstip}:${dstport}, Reference: ${ref}
Rule 3: Sandbox detected Malware

» Event Severity: Critical

e Log Type: AntiVirus

e Group by: Source Endpoint

¢ Log messages that match all of the following conditions:

¢ logid==0201009238 and fsaverdict==malicious

e Tags: Sandbox, Malware

» Custom Message: File:${filename}, Traffic path: ${dstintf}
(Policy:${policyid})\${dstip}:${dstport}, Checksum:${analyticscksum}

Default-Shadow-IT-Events Requires a FortiCASB connector configured on FortiAnalyzer in Fabric View. See
Creating or editing Security Fabric connectors on page 151. This automatically
creates the Get Cloud Service Data (FortiCasb Connector) playbook, which must
be enabled for this event handler to generate events. See Playbooks on page
139.

Disabled by default
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Event Handler Description

Rule 1: Unsanctioned Applications detected
¢ Event Severity: High
¢ Log Type: Application Control
» Group by: Source IP, Application Name
¢ Log messages that match all of the following conditions:
e (siflags & 1) == 0 && siappid >=0
e Tags: Unsanctioned_App

« Custom Message: Unsanctioned application ${app} with app risk: ${apprisk}
detected on: ${devname} with message: ${msg}

Rule 2: File Exfiltration Attempts detected
» Event Severity: High
¢ Log Type: Application Control
« Group by: Source IP, Application Name
¢ Log messages that match all of the following conditions:
e (siflags & 4) ==
e Tags: File_EXfiltration
« Custom Message: File exfiltration detected on: ${devname} with message:
${msg}
Rule 3: Unsanctioned Users detected
» Event Severity: High
e Log Type: Application Control
« Group by: Source IP, Application Name
¢ Log messages that match all of the following conditions:
e (siflags & 1) == 1 && (siflags & 2) ==
e Tags: Unsanctioned_User

« Custom Message: Unsanctioned user: ${unauthuser} with app risk:
${apprisk} detected on: ${devname} with message: ${msg}

Local Device Event Available only in the Root ADOM.

Enabled by default

Data Selector: Default Local Device Selector

Rule 1: Critical or important events
» Event Severity: Medium
e Log Type: Event
e Group by: Log Description
¢ Log messages that match the following conditions:

e Level Greater Than or Equal To Warning

e Tags: System, Local

Default-NOC-Interface-Events  Event handler for FortiGate device type logs to generate events for vlan/interface
status up or down, and DNS service on interface status.

Disabled by default
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Event Handler Description

Rule 1: Interface status changed to up

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:
e action="interface-stat-change" and status="UP"

Tags: NOC, Interface

Custom message: Device ${devname}, status changed to ${status} with
message ${msg}.

Rule 2: Interface status changed to down

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:
¢ action="interface-stat-change" and status="DOWN"

Tags: NOC, Interface

Custom message: Device ${devname}, status changed to ${status} with
message ${msg}.

Rule 3: DNS server config added

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:
o cfgpath="system.dns-server"and action="Add"

Tags: NOC, Interface, DNS

Custom Message: Device ${devname}, DNS server status changed with
message ${msg}.

Rule 4: DNS server config deleted

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:
* cfgpath="system.dns-server"and action="Delete"

Tags: NOC, Interface, DNS

Custom Message: Device ${devname}, DNS server status changed with
message ${msg}.

Default-NOC-FortiExtender- Event handler for FortiGate device type logs to generate events for FortiExtender
Events alerts, authorization and controller activity events.
Disabled by default

Rule 1: FortiExtender Authorized
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Event Severity: Medium
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Event Handler Description

e Log Type: Event > FortiExtender
e Group by: SN, Log Description
¢ Log messages that match all of the following conditions:
» action="FortiExtender Authorized"
e Tags: NOC, FortiExtender
» Custom message: Device: ${ip} ${action} with message: ${msg}
Rule 2: Warning event detected
e Event Severity: High
* Log Type: Event > FortiExtender
¢ Group by: SN, Log Description
» Log messages that match all of the following conditions:
e level="warning"
e Tags: NOC, FortiExtender
» Custom message: ${action} on ${ip} with message: ${msg}
Rule 3: Alert event detected
e Event Severity: High
* Log Type: Event > FortiExtender
¢ Group by: SN, Log Description
¢ Log messages that match all of the following conditions:
* level="alert"
e Tags: NOC, FortiExtender
» Custom message: ${action} on ${ip} with message: ${msg}
Rule 4: Critical event detected
» Event Severity: Critical

e Log Type: Event > FortiExtender

e Group by: SN, Log Description

¢ Log messages that match all of the following conditions:

e level="critical"

e Tags: NOC, FortiExtender

» Custom message: ${action} on ${ip} with message: ${msg}
Rule 5: Error event detected

» Event Severity: Medium

e Log Type: Event > FortiExtender

e Group by: SN, Log Description

¢ Log messages that match all of the following conditions:

* level="error"

e Tags: NOC, FortiExtender

» Custom message: ${action} on ${ip} with message: ${msg}
Rule 6: Emergency event detected

e Event Severity: Critical
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Event Handler Description

e Log Type: Event > FortiExtender
e Group by: SN, Log Description
¢ Log messages that match all of the following conditions:
e level="emergency"
e Tags: NOC, FortiExtender
» Custom message: ${action} on ${ip} with message: ${msg}
Rule 7: FortiExtender controller activity detected
¢ Event Severity: Medium
* Log Type: Event > FortiExtender
¢ Group by: SN, Log Description
» Log messages that match all of the following conditions:
¢ Jogid="0111046401"and logdesc="FortiExtender controller activity"
e Tags: NOC, FortiExtender
» Custom message: ${action} on ${ip} with message: ${msg}
Rule 8: FortiExtender controller activity error detected
¢ Event Severity: Medium
* Log Type: Event > FortiExtender
¢ Group by: SN, Log Description
¢ Log messages that match all of the following conditions:

* Jogid="0111046402" and logdesc="FortiExtender controller activity
error"

e Tags: NOC, FortiExtender
» Custom message: ${action} on ${ip} with message: ${msg}

Default-NOC-Routing-Events Event handler for FortiGate device type logs to generate events for changes in
routing information including BGP Neighbor Status, Routing information change,
OSFP Neighbor Status, Neighbor Table Changed and VRRP State Changed

Disabled by default

Rule 1: Routing information changed

¢ Event Severity: Medium

e Log Type: Event > Any

¢ Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

* Jogdesc="Routing information changed"

e Tags: NOC, Routing

« Custom message: ${logdesc} on ${devname} with message ${msg}
Rule 2: BGP neighbor status changed

» Event Severity: Medium

¢ Log Type: Event > Router

¢ Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:
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Event Handler Description

¢ Jogdesc="BGP neighbor status changed"
e Tags: NOC, Routing
» Custom message: ${devname}. BGP neighbor status changed with message
${msg}
Rule 3: OSPF or OSPF6 neighbor status changed
¢ Event Severity: Medium
e Log Type: Event > Router
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

¢ Jogdesc=="OSPF neighbor status changed" OR logdesc=="OSPF6
neighbor status changed"

e Tags: NOC, Routing
» Custom message: ${logdesc} on ${devname} with message ${msg}

Rule 4: Neighbor table changed
» Event Severity: Medium

e Log Type: Event > Router
« Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
* Jogdesc=="neighbor table change"
e Tags: NOC, Routing
¢ Custom message: ${logdesc} on ${devname} with message ${msg}

Rule 5: VRRP state changed
« Event Severity: Medium

¢ Log Type: Event > Router
e Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ Jogdesc=="VRRP state changed"
e Tags: NOC, Routing
+ Custom message: ${logdesc} on ${devname} with message ${msg}

Default-NOC-Network-Events Event handler for FortiGate device type logs to generate network events including
SNMP queries, routing information changes, DHCP server and status changes

Disabled by default
Rule 1: Device SNMP query failed
e Event Severity: High
* Log Type: Event > System
¢ Group by: Device Name, Log Description
* Log messages that match all of the following conditions:
¢ logid="0100029021" AND logdesc="SNMP query failed"
e Tags: NOC, Network
» Custom message: Device: ${devname} ${logdesc} with message: ${msg}
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Event Handler Description

Rule 2: Device routing information changed

Event Severity: High
Log Type: Event > System
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
¢ |logdesc=="Routing information changed"
Tags: NOC, Network
Custom message: Device: ${devname} ${logdesc} with message: ${msg}

Rule 3: DHCP client lease granted or usage high

Event Severity: High

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

¢ Jogdesc=="DHCP client lease granted" OR logdesc=="DHCP lease

usage high" OR logdesc=="DHCP lease usage full"

Tags: NOC, Network

Custom message: DHCP status on Device ${devname} is ${logdesc} with

message: ${msg}

Rule 4: SNMP enabled

Event Severity: Medium
Log Type: Event > System
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
o cfgpath="system.snmp.sysinfo" and logdesc="Aftribute configured" and
cfgattr=status[disable->enable]
Tags: NOC, Network
Custom message: Device ${devname} ${logdesc} ${cfgattr} with message
${msg}.

Rule 5: SNMP disabled

Event Severity: Medium
Log Type: Event > System
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
e cfgpath="system.snmp.sysinfo" and logdesc="Aftribute configured" and
cfgattr=status[enable->disable]
Tags: NOC, Network
Custom message: Device ${devname} ${logdesc} ${cfgattr} with message
${msg}.

Rule 6: DHCP server status changed
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Event Severity: Medium
Log Type: Event > System
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Event Handler Description

¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

o cfgpath="system.dhcp.server"and logdesc="Object attribute
configured"

e Tags: NOC, Network
» Custom message: DHCP server status change ${cfgattr} with message
${msg}.
Rule 7: DHCP lease renewed
¢ Event Severity: Medium
e Log Type: Event > System
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
e dhcp_msg="Ack" and logdesc="DHCP Ack log"
e Tags: NOC, Network
» Custom message: Host ${hostname} with message ${msg}.
Rule 8: DHCP lease released
» Event Severity: Medium
e Log Type: Event > System
« Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
e dhcp_msg="Release"and logdesc="DHCP Release log"
e Tags: NOC, Network
» Custom message: Host ${hostname} with message ${msg}.

Default-NOC-Switch-Events Event handler for FortiGate device type logs to generate events for Switch-

Controller added/deleted or authorized/deauthorized, Switch-Controller Status,
Interface flapping, LAG/MCLAG and split-brain status, Cable test/diagnosis and
physical port up/down
Disabled by default
Rule 1: Switch-Controller activity detected

» Event Severity: Medium

¢ Log Type: Event > Any

e Group by: Device Name, Message

¢ Log messages that match all of the following conditions:

e (subtype="switch-controller") and (logdesc=="Switch-Controller
discovered” OR logdesc=="Switch-Controller authorized" OR
logdesc=="Switch-Controller deauthorized" OR logdesc=="Switch-
Controller deleted” OR logdesc=="Switch-Controller warning")

e Tags: NOC, Switch, Controller
» Custom message: ${logdesc}

Rule 2: Vlan interface change has occurred
» Event Severity: Medium
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Event Handler Description

¢ Log Type: Event > Any
» Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ Jogdesc='FortiSwitch system'and msg~"interface vian"
¢ Tags: NOC, Switch, Controller
» Custom message: Device ${devname} interface vlan change with message:
${msg}
Rule 3: Port switch detected
e Event Severity: Medium

* Log Type: Event > Any
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jlogdesc="FortiSwitch link" AND msg~"switch port"
¢ Tags: NOC, Switch, Controller
» Custom message: ${logdesc} on Device: ${devname} with message: ${msg}

Rule 4: Device flap detected
¢ Event Severity: Medium

* Log Type: Event > Any

¢ Group by: Device Name, Message

* Log messages that match all of the following conditions:
e msg~"flap"

e Tags: NOC, Switch, Controller

¢ Default message

Rule 5: Device LAG-MCLAG status change
¢ Event Severity: Medium
e Log Type: Event > Any
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
* msg~"lag" OR msg~"mclag"
e Tags: NOC, Switch, Controller
» Custom message: Device: ${devname} LAG-MCLAG status update with
message: ${msg}
Rule 6: Device MCLAG split-brain detected
« Event Severity: Medium
¢ Log Type: Event > Any
« Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
e Jog_id=0115032695 and msg~"MCLAG split-brain”
e Tags: NOC, Switch, Controller
« Custom message: Device ${devname} ${msg}.
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Rule 7: Device cable diagnose detected
¢ Event Severity: Medium
* Log Type: Event > Any
¢ Group by: Device Name, Log Description
» Log messages that match all of the following conditions:
¢ log id=0115032699 and msg~"CABLE DIAGNOSE"
e Tags: NOC, Switch, Controller
» Custom message: Device ${devname} ${msg}.
Rule 8: Device come up detected
¢ Event Severity: Medium
* Log Type: Event > Any
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
e Jog id=="0115032695" and msg~"come up"
e Tags: NOC, Switch, Controller
» Custom message: Device ${devname} ${msg}.

Rule 9: Device gone down detected
« Event Severity: Medium
¢ Log Type: Event > Any
« Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
e Jog id=="0115032695" and msg~"gone down"
e Tags: NOC, Switch, Controller
« Custom message: Device ${devname} ${msg}.

Default-NOC-HA-Events Event handler for FortiGate device type logs to generate events for HA cluster
updates and alerts including HA Device interface failure, Cluster Priority
Changed, cluster member state moved, device interface down, HA device
syncronization status, connection to FortiAnalyzer status, FortiManager tunnel
connection status and connection with CSF member status.

Disabled by default

Rule 1: HA device interface failed
» Event Severity: High

e Log Type: Event>HA
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ logdesc=="HA device interface failed" and logid=="0108037898"
e Tags: NOC, HA, Cluster
o Default message

Rule 2: Device set as HA primary
e Event Severity: High

e Log Type: Event>HA
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Event Handler Description

¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ Jogdesc=="Device set as HA primary"
e Tags: NOC, HA, Cluster
» Custom message: Device: ${devname} has been set to HA Primary with
msg: ${msg}
Rule 3: Cluster state moved or Heartbeat device interface down
e Event Severity: High
e Log Type: Event>HA
e Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

* Jogdesc=="Virtual cluster member state moved" OR
logdesc=="Heartbeat device interface down"

e Tags: NOC, HA, Cluster

» Custom message: Device: ${devname} ${logdesc} with HA role: ${ha_role}
Rule 4: Synchronization activity detected

» Event Severity: High

e Log Type: Event>HA

« Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

¢ logdesc=="HA secondary synchronization failed" OR
logdesc=="Secondary sync failed" OR logdesc="Synchronization status
with master”

e Tags: NOC, HA, Cluster

¢ Custom message: Device: HA synchronization status for Device:
${devname} ${logdesc}. Message: ${msg}. Status is: ${sync_status}

Rule 5: FortiAnalyzer connection up
¢ Event Severity: Medium
e Log Type: Event > System
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

* action="connect"and status="success" and logdesc="FortiAnalyzer
connection up"

e Tags: NOC, HA, Cluster
» Custom message: Device ${devname} ${msg}.
Rule 6: FortiAnalyzer connection failed
» Event Severity: High
e Log Type: Event > System
« Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
e action="connect"and status="failure" and logdesc="FortiAnalyzer
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connection failed"
Tags: NOC, HA, Cluster
Custom message: Device ${devname} ${msg}.

Rule 7: Upstream connection with CSF member established and authorized

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

direction="upstream" and logdesc="Connection with CSF member
established and authorized"

Tags: NOC, HA, Cluster
Custom message: Device ${devname} ${msg}.

Rule 8: Upstream connection with authorized CSF member terminated

Event Severity: High

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

e direction="upstream" and logdesc="Connection with authorized CSF
member terminated"

Tags: NOC, HA, Cluster
Custom message: Device ${devname} ${msg}.

Rule 9: FortiManager tunnel connection up

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

e action="connect" and status="success"and logdesc="FortiManager
tunnel connection up"

Tags: NOC, HA, Cluster
Custom message: Device ${devname} ${logdesc} with message - ${msg}.

Rule 10: FortiManager tunnel connection down
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Event Severity: High

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

e action="connect"and status="failure" and logdesc="FortiManager
tunnel connection down"

Tags: NOC, HA, Cluster
Custom message: Device ${devname} ${logdesc} with message - ${msg}.
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Default-NOC-Wireless-Events  Event handler for FortiGate device type logs to generate events for wireless wifi,
AP updates and alerts including AP Status Change and Fake/Rogue AP
detection, wireless client status change added/removed/allowed or denied status,
signal to noise ratio (SNR) poor/fair/good, SSID status up/down.

Disabled by default
Rule 1: Fake AP detected
» Event Severity: Medium
¢ Log Type: Event > Wireless
¢ Group by: Device Name, SSID
¢ Log messages that match all of the following conditions:
¢ Jogid="0104043567" AND logdesc=="Fake AP detected"
e Tags: NOC, Wireless, Wifi, AP
« Custom message: ${logdesc}. SN: ${sndetected}

Rule 2: Rogue AP detected
¢ Event Severity: Medium

* Log Type: Event > Wireless

e Group by: Device Name, SSID

¢ Log messages that match all of the following conditions:

¢ Jlogid=="0104043563" AND logdesc=="Rogue AP detected"

e Tags: NOC, Wireless, Wifi, AP

» Custom message: ${logdesc}. SN: ${sndetected} with message: ${msg}
Rule 3: Wireless event log id matched

¢ Event Severity: Medium

* Log Type: Event > Wireless

¢ Group by: Device Name, Message

* Log messages that match all of the following conditions:

o subtype="wireless" AND (logid=="0104043551" OR
logid=="0104043552" OR logid=="0104043553")

e Tags: NOC, Wireless, Wifi, AP
» Custom message: ${logdesc}. of AP: ${ap}
Rule 4: Wireless client activity detected
¢ Event Severity: Medium
* Log Type: Event > Wireless
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

¢ (logdesc=="Wireless client associated" OR logdesc=="Wireless client
authenticated" OR logdesc=="Wireless client disassociated” OR
logdesc=="Wireless client deauthenticated" OR logdesc=="Wireless
client idle" OR logdesc=="Wireless client denied" OR
logdesc=="Wireless client kicked" OR logdesc="Wireless client IP
assigned” OR logdesc=="Wireless client left WTP" OR
logdesc=="Wireless client WTP disconnected")

FortiAnalyzer 7.4.0 Administration Guide 198
Fortinet Inc.



Incidents & Events

Event Handler Description

e Tags: NOC, Wireless, Wifi, AP
» Custom message: ${logdesc} for ${ssid} with message: ${msg}

Rule 5: Signal-to-noise ratio is poor
¢ Event Severity: Medium

* Log Type: Event > Wireless
¢ Group by: Device Name
» Log messages that match all of the following conditions:
e snr<="24"
e Tags: NOC, Wireless, Wifi, AP
» Custom message: SSID ${ssid}. has a poor quality SNR at ${snr} dB.
Rule 6: Signal-to-noise ratio is fair
¢ Event Severity: Medium
* Log Type: Event > Wireless
¢ Group by: Device Name
¢ Log messages that match all of the following conditions:
e snr>="25"and snr<="40"
e Tags: NOC, Wireless, Wifi, AP
» Custom message: SSID ${ssid}. has fair quality SNR at ${snr} dB.
Rule 7: Signal-to-noise ratio on is excellent
« Event Severity: Medium
e Log Type: Event > Wireless
* Group by: Device Name
¢ Log messages that match all of the following conditions:
e snr>="41"
e Tags: NOC, Wireless, Wifi, AP
» Custom message: SSID ${ssid}. has excellent quality SNR at ${snr} dB.

Rule 8: Physical AP radio ssid up
« Event Severity: Medium

¢ Log Type: Event > Wireless
e Group by: SSID, Log Description
¢ Log messages that match all of the following conditions:
¢ logdesc="Physical AP radio ssid up"and action="ssid-up"
e Tags: NOC, Wireless, Wifi, AP
« Custom message: Device ${sn} SSID status change with message ${msg}.

Rule 9: Physical AP radio ssid down
¢ Event Severity: Medium

* Log Type: Event > Wireless
¢ Group by: SSID, Log Description
» Log messages that match all of the following conditions:
¢ Jlogdesc="Physical AP radio ssid down"and action="ssid-down"
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e Tags: NOC, Wireless, Wifi, AP
« Custom message: Device ${sn} SSID status change with message ${msg}.

Default-NOC-Security-Events Event handler for FortiGate device type logs to generate events for security
events including Admin Logins failed or disabled, Admin or Admin Monitor
Disconnected, Admin password expired and UTM Profile changes

Disabled by default

Rule 1: Admin login failed or desabled
e Event Severity: High

e Log Type: Event > System
e Group by: Device Name, Log Description
» Log messages that match all of the following conditions:

¢ Jogdesc=="Admin login failed" OR logdesc=="Admin login disabled"” OR
logdesc=="SSL VPN login fail"

e Tags: NOC, Security, Login, Password

» Custom message: ${logdesc} for ${user} on device: ${devname} due to:
${reason} with message: ${msg}

Rule 2: Admin password expired
e Event Severity: High

e Log Type: Event > System

¢ Group by: Device Name, Log Description

» Log messages that match all of the following conditions:
¢ Jlogdesc=="Admin password expired"

e Tags: NOC, Security, Login, Password

» Custom message: Device: ${devname} ${logdesc} with message: ${msg}

Rule 3: Admin disconnected

» Event Severity: High

e Log Type: Event > System

¢ Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

¢ Jogdesc=="Admin disconnected" OR logdesc=="Admin monitor
disconnected"

e Tags: NOC, Security, Login, Password
» Custom message: ${logdesc} on device: ${devname} with message: ${msg}

Rule 4: AV or IPS change detected
e Event Severity: High

e Log Type: Event > System
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

¢ Jogdesc=="AV updated by admin" OR logdesc=="IPS package - Admin
update successful”" OR logdesc=="AV package update by SCP failed"
OR logdesc=="IPS package failed to update via SCP" OR
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logdesc=="IPS custom signatures backup failed"
e Tags: NOC, Security, Login, Password
» Custom message: Device: ${devname} ${logdesc} with message: ${msg}

Default-NOC-Fabric-Events Event handler for FortiAnalyzer and FortiGate log device type to detect Fabric
events, including device offline, CSF member connection status down or
terminated, CSF member configuration changes, automation stitch triggered ,
licenses that are expiring or failed updates.

Disabled by default

Rule 1: Device offline detected
» Event Severity: High
e Log Type: Application
¢ Group by: Logging Device Name, Message
¢ Log messages that match all of the following conditions:
* desc="Device offline"
e Tags: NOC, Fabric
» Custom message: ${logdev _id} is offline
Rule 2: FortiAnalyzer connection down detected
» Event Severity: High
¢ Log Type: Event > System
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
* Jlogdesc="FortiAnalyzer connection down"
e Tags: NOC, Fabric
e Default message
Rule 3: Connection with authorized CSF member terminated
« Event Severity: High
* Log Type: Event > System
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jlogdesc="Connection with authorized CSF member terminated”
e Tags: NOC, Fabric
» Custom message: ${logdesc} on: ${devid} due to: ${reason}
Rule 4: Automation stitch triggered
¢ Event Severity: Medium
* Log Type: Event > System
¢ Group by: Device Name, Log Description
* Log messages that match all of the following conditions:
¢ Jlogdesc="Automation stitch triggered"
e Tags: NOC, Fabric
» Custom message: ${logdesc} on: ${devname} with message: ${msg} and
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stitch action: ${stitchaction}
Rule 5: Device license failed or expiring detected
« Event Severity: Critical
e Log Type: Event > System
¢ Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jogdesc~'"license failed" OR logdesc~"license expiring"
e Tags: NOC, Fabric
« Custom message: ${logdesc} on: ${devid}
Rule 6: System update or failure detected
« Event Severity: Critical
e Log Type: Event > System
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jogdesc~"update" AND logdesc~"failed"
e Tags: NOC, Fabric
» Custom message: ${logdesc} on: ${devname} with message: ${msg}
Rule 7: Security fabric settings change detected
¢ Event Severity: Medium

e Log Type: Event > System
¢ Group by: Device Name, Log Description
» Log messages that match all of the following conditions:

¢ Jogdesc=="Settings modified by Security Fabric service" OR
logdesc=="Looped configuration in Security Fabric service" OR
logdesc=="Connection with CSF member established and authorized"
OR logdesc=="Connection with authorized CSF member terminated"
OR logdesc=="Serial number of upstream is changed"

e Tags: NOC, Fabric
» Custom message: Device: ${devname} change with message: ${msg}

Default-NOC-System-Events Event handler for FortiGate device type logs to generate events for system events
including Power failure and device shutdown, High Resource usage (CPU, Mem,
Storage), log device full status warnings and disk rolled, and devices
entering/exiting conserve mode.

Disabled by default
Rule 1: Device shutdown detected
» Event Severity: Critical
e Log Type: Event > System
e Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ Jogdesc="Device shutdown"
e Tags: NOC, System, Power, CPU, Memory, Storage
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» Custom message: ${devname} experienced $logdesc with message: ${msg}
Rule 2: Device conserve mode detected

» Event Severity: High

e Log Type: Event > System

» Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

¢ Jogdesc=="conserve mode"

e Tags: NOC, System, Power, CPU, Memory, Storage

» Custom message: ${logdesc} on Device: ${devname} with message ${msg}
Rule 3: Disk or memory is full

e Event Severity: High

e Log Type: Event > System

e Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

¢ logdesc=="Disk log full over first warning" OR logdesc=="Memory log
full over first warning level" OR logdesc=="Memory log full over second
warning level” OR logdesc=="Memory log full over final warning level"
OR logdesc=="Disk full" OR logdesc=="Disk log rolled”" OR
logdesc=="Log disk full"

e Tags: NOC, System, Power, CPU, Memory, Storage

» Custom message: Device: ${devname} ${logdesc} with message: ${msg}
Rule 4: Device high CPU consumption detected

» Event Severity: High

e Log Type: Event > System

» Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

e cpu>="80"

e Tags: NOC, System, Power, CPU, Memory, Storage

» Custom message: ${devid} performance cpu: ${cpu}
Rule 5: Device high memory consumption detected

» Event Severity: Medium

e Log Type: Event > System

e Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

s mem>="75"
e Tags: NOC, System, Power, CPU, Memory, Storage
» Custom message: ${devid} performance memory: ${memory}
Default-NOC-VPN-Events Event handler for FortiGate device type logs to generate events for VPN status

changes including IPsec Phase1 error or failure, and Phase2 Up/Down and

errors, Ipsec Tunnel Up/Down, VPN SSL login failures, IPSec ESP Error, IPsec
DPD failures
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Disabled by default
Rule 1: User SSL VPN login failed
» Event Severity: High
e Log Type: Event>VPN
¢ Group by: Device Name, End User
¢ Log messages that match all of the following conditions:
¢ logid=="0101039426" and action=="ssl-login-fail"
e Tags: NOC, VPN
» Custom message: ${logdesc} due to: ${reason}
Rule 2: IPsec phase 1 error or status fail detected
¢ Event Severity: High
e Log Type: Event>VPN
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:

¢ (logid=="0101037124" OR logid=="0101037120") and
(logdesc=="IPsec phase 1 error" OR status="fail")

e Tags: NOC, VPN
« Custom message: ${logdesc} due to: ${status} with reason: ${reason}
Rule 3: IPsec ESP error detected
e Event Severity: High
* Log Type: Event> VPN
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jlogid=="0101037131"and logdesc=="IPsec ESP"
e Tags: NOC, VPN
» Custom message: ${status} on: ${devname}, ${error _num}
Rule 4: IPsec DPD failed
¢ Event Severity: High
* Log Type: Event> VPN
¢ Group by: Device Name, Message
* Log messages that match all of the following conditions:
e Jogid=="0101037136"and logdesc=="IPsec DPD failed"
e Tags: NOC, VPN
» Custom message: ${msg} on device: ${devname}
Rule 5: Device tunnel-up or tunnel-down detected
» Event Severity: High
e Log Type: Event> VPN
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ Jogid="0101037138" and (action="tunnel-up" or action= "tunnel-down")
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e Tags: NOC, VPN
» Custom message: ${msg} due to: ${action}
Rule 6: IPsec phase 2 error detected
¢ Event Severity: High
* Log Type: Event> VPN
¢ Group by: Device Name, Message
» Log messages that match all of the following conditions:
e Jogid=="0101037125"and logdesc=="IPsec phase 2 error"
e Tags: NOC, VPN
» Custom message: ${logdesc} due to: ${reason}
Rule 7: Device phase2-up or phase2-down detected
¢ Event Severity: Medium
* Log Type: Event>VPN
¢ Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jogid=="0101037139" and (action=="phase2-up" OR action=="phase2-
down")
e Tags: NOC, VPN
» Custom message: ${logdesc} due to: ${action}

Default-NOC-SD-WAN-Events  Event handler for FortiGate device type logs to generate events for SD-WAN
status, alerts, and health check events including SLA targets/SLA met or not met
for jitter, latency, packetloss, Health-check server status (alive or dead), status
(up or down), and member status change.

Disabled by default
Rule 1: SLA failed for jitter
e Event Severity: High
e Log Type: Event > SD-WAN
¢ Group by: Device Name, Health Check
¢ Log messages that match all of the following conditions:
e subtype=="sdwan" AND metric=="jitter" AND msg~"SLA failed"
e Tags: NOC, SD-WAN
» Custom message: On ${devname} the SLA for the ${healthcheck} failed for
${metric} with the current value of ${jitter} which violates the target ID
${slatargetid}.
Rule 2: SLA failed for latency
e Event Severity: High
e Log Type: Event > SD-WAN
e Group by: Device Name, Health Check
¢ Log messages that match all of the following conditions:
e subtype=="sdwan"AND metric=="latency” AND msg~"SLA failed"
e Tags: NOC, SD-WAN
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» Custom message: On ${devname} the SLA for the ${healthcheck} failed for
${metric} with the current value of ${latency} which violates the target ID
${slatargetid}.

Rule 3: SLA failed for packetloss

e Event Severity: High

e Log Type: Event > SD-WAN

¢ Group by: Device Name, Health Check

¢ Log messages that match all of the following conditions:

e subtype=="sdwan" AND metric=="packetloss" AND msg~"SLA failed"

e Tags: NOC, SD-WAN

» Custom message: On ${devname} the SLA for the ${healthcheck} failed for
${metric} with the current value of ${packetloss} which violates the target ID
${slatargetid}.

Rule 4: Device status changed to die

¢ Event Severity: Medium

e Log Type: Event > SD-WAN

¢ Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

¢ logid="0113022925" AND newvalue="die"
e Tags: NOC, SD-WAN
» Custom message: Device: ${devname} with status ${newvalue}. ${msg}.
Rule 5: Device status changed to alive.
» Event Severity: Medium

e Log Type: Event > SD-WAN
» Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ logid="0113022925" AND newvalue="alive"
e Tags: NOC, SD-WAN
¢ Custom message: Device: ${devname} with status ${newvalue}. ${msg}.

Rule 6: Device status is up
» Event Severity: Medium

e Log Type: Event > SD-WAN
e Group by: Device Name, Health Check
¢ Log messages that match all of the following conditions:
* Jogid="0113022925" AND status=="up"
e Tags: NOC, SD-WAN
» Custom message: Device: ${devname} ${msg} status is ${status}.

Rule 7: Device status is down
¢ Event Severity: Medium

* Log Type: Event > SD-WAN
e Group by: Device Name, Health Check
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Log messages that match all of the following conditions:
¢ logid="0113022925" AND status=="down"
Tags: NOC, SD-WAN
Custom message: Device: ${devname} ${msg} status is ${status}.

Rule 8: Number of pass member changed

Event Severity: Medium
Log Type: Event > SD-WAN
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
¢ Jogid="0113022923" AND msg="Number of pass member changed."
Tags: NOC, SD-WAN
Custom message: ${msg} from ${oldvalue} to ${newvalue} for ${devname}

Rule 9: Member status changed

Event Severity: Medium

Log Type: Event > SD-WAN

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

¢ Jogid="0113022923" AND msg="Member status changed. Member out-
of-sla."”

Tags: NOC, SD-WAN
Custom message: ${msg}. Member is now ${member} on ${devname}.

Default-NOC-Docker-Events Event handler for FortiGate device type logs to generate events for Docker
including inlcuding container enabled/disabled, CPU value set/max reached and
MEM value set/max reached
Disabled by default

Rule 1: Memory report detected

Event Severity: Medium
Log Type: Event
Group by: Type, Subtype
Log messages that match all of the following conditions:
* Jog_id=="0042010266"and msg~"MEM"
Tags: NOC, Docker
Custom message: Device ${devname} with message ${msg}.

Rule 2: CPU report detected
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» Custom message: Device ${devname} with message ${msg}.
Rule 3: Status changed to disable 1
« Event Severity: Medium
e Log Type: Event
« Group by: Type, Subtype
¢ Log messages that match all of the following conditions:
e Jog id="0001010026" and changes~"status=disable"
e Tags: NOC, Docker
¢ Custom message: Device ${devname} with changes ${changes}.
Rule 4: Status changed to disable 2
« Event Severity: Medium
e Log Type: Event
e Group by: Type, Subtype
¢ Log messages that match all of the following conditions:
¢ Jog_id="0001010026" and changes~"status=disable"
e Tags: NOC, Docker
« Custom message: Device ${devname} with changes ${changes}.

Below are examples of raw logs that would trigger the associated default event handler.

Default Event Handler Example Log

Local Device Event 1d=6872390755323740160 itime=2020-09-14 10:06:03 euid=1 epid=1
dsteuid=1 dstepid=1 log id=0034043006 subtype=logdb type=event
level=warning time=10:06:03 date=2020-09-14 user=system
action=delete msg=Requested to trim database tables older than
60 days to enforce the retention policy of Adom root.
userfrom=system desc=Trim local db devid=FAZ-VMTM20001572
devname=FAZ-VMTM20001572 dtime=2020-09-14 10:06:03 itime
t=1600103163

Default-Compromised Host- date=2020-09-20 time=07:41:20 1d=6874471739997290516

Detection-by I0C-By-Threat itime=2020-09-20 00:41:20 euid=3 epid=1161 dsteuid=3
dstepid=101 type=utm subtype=ips level=warning
sessionid=917509475 policyid=2 srcip=172.16.93.164
dstip=5.79.68.109 srcport=51392 dstport=80 proto=6
10gid=0421016399 service=HTTP eventtime=1537181449 crscore=30
crlevel=high srcintfrole=lan dstintfrole=wan
direction=outgoing url=/ hostname=survey-smiles.com
profile=default eventtype=malicious-url srcintf=95-FortiCloud
dstintf=0SPF msg=URL blocked by malicious-url-list
devid=FG100D3G02000011 vd=root dtime=2020-09-20 07:41:20
itime t=1600587680 devname=FG100D3G02000011

Default-Risky-App-Detection- date=2020-09-20 time=07:41:23 1d=6874471752882192399
By-Threat itime=2020-09-20 00:41:23 euid=3 epid=1201 dsteuid=3
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dstepid=101 type=utm subtype=app-ctrl level=information
action=pass sessionid=3003333495 policyid=79
srcip=172.16.80.218 dstip=122.195.166.40 srcport=38625
dstport=26881 proto=6 1ogid=1059028704 service=tcp/26881
eventtime=1537399002 incidentserialno=603516169 crscore=5
crlevel=low direction=outgoing apprisk=high appid=6
srcintfrole=lan dstintfrole=wan applist=scan appcat=P2P
app=BitTorrent eventtype=app-ctrl-all srcintf=80-software-r
dstintf=port7 msg=P2P: BitTorrent HTTP.Track,
devid=FG100D3G02000011 vd=root dtime=2020-09-20 07:41:23
itime t=1600587683 devname=FG100D3G02000011

Default_NOC_Routing_Events date=2021-02-08 time=10:36:09 eventtime=1612809370040652208
tz="-0800" logid="0103027001" type="event" subtype="router"
level="information" vd="root" logdesc="VRRP state changed"
interface="portl" msg="VRRP vrid 200 vrip 172.17.200.200
changes state from Master to Backup due to ADVERTISEMENT with

higherer priority received"

FortiOS system events

FortiOS predefined system event handlers are consolidated into a single event handler with multiple rules called Default
FOS System Events.

Events are organized by device in the Incidents & Events dashboards, which can be expanded to view all related events.

Default FOS System Events rules apply tags to each event, allowing you to identify which Default FOS System Events
rule triggered the event.

\ﬂ If you are upgrading from a version before FortiAnalyzer 6.2.0, the existing legacy predefined

handlers which are enabled or have been modified will be available as custom handlers. In the
Event Handler List, select the More dropdown and choose Show Custom.

Predefined correlation handlers

FortiAnalyzer includes some predefined correlation event handlers that you can use to generate events.

If you wish to recieve notifications from a pedefined correlation handler, configure a notification profile and assign it to the
correlation handler. See Creating notification profiles on page 215.

To view predefined event handlers in the FortiAnalyzer GUI, go to Incidents & Events > Handlers > Correlation Handlers.
From the More dropdown, select Show Predefined. Predefined correlation handlers are named according to their use
case. For example, there are predefined correlaton handlers for:

¢ CnC (Command and Control)

» Credential Access

» Defense Evasion

» Execution
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« EXxfiltration

« Initial Access

« Lateral Movement
* Persistence

» Privilege

The following are a small sample of FortiAnalyzer predefined correlation handlers.

CnC - Default-Suspicious- This handler is to detect if an endpoint is infected and there is a large traffic from
Traffic-From-Infected- the same endpoint.
Endpoint Disabled by default

Event Severity: Medium

Tags: CnC

Threshold Duration: 30 minutes
Correlation Sequence:
Logic Group 1

Traffic to Botnet CnC detected or blocked in virus log

Log Device Type FortiGate
Log Type Antivirus
Group By Source Endpoint
Log messages that * Log ID Equal To 0202009248
match any of the « Log ID Equal To 0202009249
following conditions:
Aggregate COUNT >=1
Expression:
OR

Traffic to CnC detected

Log Device Type FortiGate
Log Type Traffic Log > Any
Group By Source Endpoint

Log messages that tdtype~infected
match any of the
following conditions:

Aggregate COUNT >=1
Expression:

OR
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Web traffic to CnC detected

Log Device Type FortiGate
Log Type Web Filter
Group By Source Endpoint

Log messages that tdtype~infected
match any of the
following conditions:

Aggregate COUNT >=1
Expression:

DNS traffic to CnC detected

‘.
Py

Log Device Type FortiGate
Log Type DNS Log
Group By Source Endpoint

Log messages that tdtype~infected
match any of the
following conditions:

Aggregate COUNT >=1
Expression:

FOLLOWED_BY, within 15m
Logic Group 2

Traffic from endpoint

Log Device Type FortiGate
Log Type Traffic Log > Any
Group By Source Endpoint

Log messages that
match any of the
following conditions:

Aggregate SUM sentbyte >= 100 Mega Byte
Expression:

Correlation Criteria:
* Traffic to Botnet CnC detected or blocked in virus log endpoint = Traffic to
CnC detected endpoint

 Traffic to CnC detected endpoint = Web traffic to CnC detected endpoint
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* Web traffic to CnC detected endpoint = DNS traffic to CnC detected endpoint
e DNS traffic to CnC detected endpoint = Traffic from endpoint endpoint

Credential Access - Default- This handler is to detect if an account login failed many times not followed by a
Brute-Force-Account-Login- login success for FortiAnalyzer.
Attack-FAZ Disabled by default

Event Severity: Medium

Tags: login, attack

Threshold Duration: 30 minutes
Correlation Sequence:

Login Failed 5 Times

Log Device Type FortiAnalyzer

Log Type Event Log

Group By Device ID

Log messages that Operation Equal To login failed

match any of the
following conditions:

Aggregate COUNT >=5
Expression:

NOT_FOLLOWED_BY, within 5m

Login Success

Log Device Type FortiAnalyzer

Log Type Event Log

Group By Device ID

Log messages that Operation Equal To login

match any of the
following conditions:

Aggregate COUNT >=1
Expression:

Correlation Criteria:
* Login Failed 5 Times devid = Login Success devid

Credential Access - Default- This handler is to detect if an account login failed many times not followed by a
Brute-Force-Account-Login- login success for FortiGate.
Attack-FGT Disabled by default

Event Severity: Medium
Tags: login, attack
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Threshold Duration: 30 minutes
Correlation Sequence:

Login Failed 5 Times

Log Device Type FortiGate
Log Type Event Log > System
Group By Device ID

Log messages that Log ID Equal To 0100032002
match any of the
following conditions:

Aggregate COUNT >=5
Expression:

NOT_FOLLOWED_BY, within 5m

Login-Success

Log Device Type FortiGate
Log Type Event Log > System
Group By Device ID

Log messages that Log ID Equal To 0100032001
match any of the
following conditions:

Aggregate COUNT >=1
Expression:

Correlation Criteria:
* Login Failed 5 Times devid = Login-Success devid

Creating data selectors

Data selectors are used to select devices, subnets, and filters for event handlers. You can create, edit, clone, and delete
data selectors in Incidents & Events > Handlers > Data Selectors.

To assign a data selector to a basic event handler, see Creating a custom event handler on page 216.

To assign a data selector to a correlation handler, see Creating a custom correlation handler on page 219.

This means the filter criteria does not need to be added individually within each rule of the

s‘é’, The filters in the data selector are applied before every rule configured in the event handler.
3 event handler(s) that the data selector is assigned to.

There are five default data selectors:
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o Default Intrusion Selector For Malicious Code Detection

o Default IP Scanning Selector For Recon Activity Detection
o Default Local Device Selector

» Default Malicious File Selector For Malicious File Detection
o Default Risky App Selector for Risky App Detection

These default data selectors are used in some of the predefined handlers, and they cannot be edited or deleted.

To create a data selector:

1. Goto Incidents & Events > Handlers > Data Selectors.
2. Click Create New.
The Add New Data Selector pane displays.

3. Configure the following options, and click OK to save the data selector.

Option Description

Name Enter a name for the data selector.

Devices Select one of the following:

» All Devices.

e Specify: Select the devices to include.

e Local Device: Select if the event handler is for local FortiAnalyzer
event logs. This option is only available in the root ADOM and is
used to query FortiAnalyzer event logs.

For Local Device, the Log Type must be Event Log and Log
Subtype must be Any.

Subnets Select All Subnets to include all subnets, or select Specify to choose
which subnet(s) or subnet group(s) will be included or excluded from
triggering events. For more information, see Subnets on page 163.

Filters Click plus (+) to insert a new filter in the list. The Filter dialog displays.
Configure the options and click OK to save.

To delete afilter from the list, click the x next to the filter.
Name Enter a name for the filter.
Log Device Type Select the device type from the dropdown.

Log Type Select a log type from the dropdown. The log types will vary depending
on the device type.

Log Subtype Select a log subtype from the dropdown. The log subtype is not available
for all device types.
Logs match Select All or Any of the following conditions.

Click plus (+) to insert a new condition. You can insert multiple
conditions.

Configure the condition(s):
e Log Field: Select a log field from the dropdown.

» Match Criteria: Select an operator from the dropdown.
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e Value: Select the event type from the dropdown.
To delete a condition, click the delete icon next to the condition.

Generic Text Filter  (Optional) Enter a filter string. For more information, see Using the
Generic Text Filter on page 224.

Creating notification profiles

Notification profiles are used to send alert notifications when an event is generated by an event handler. You can
configure the notification profile to send the alert to an email address, SNMP community, and/or syslog server. You can
also configure the notification profile to send the alert through a fabric connector.

You can create, edit, clone, and delete notification profiles in Incidents & Events > Handlers > Notification Profiles.
To assign a notification profile to a basic event handler, see Creating a custom event handler on page 216.

To assign a notification profile to a correlation handler, see Creating a custom correlation handler on page 219.

To create a notification profile:

1. Goto Incidents & Events > Handlers > Notification Profiles.
2. Click Create New.
The Add New Notification Profile pane displays.

3. Configure the following options, and click OK to save the notification profile.

Option Description

Name Enter a name for the notification profile.
Send Alert through Fabric Send an alert through one or more fabric connectors selected from the
Connectors dropdown. Click the plus (+) to add fabric connectors. For more information,

see Fabric Connectors on page 148.

Send Alert Email Send an alert to one or more email addresses. Specify the email parameters,
including the mail server. For more information, see Mail Server on page 331.

To Enter the email address(es) to send the alert to. Use a semicolon (;) to
separate multiple email addresses.

From Enter a from address for the alert email.
Subject Enter a subject line for the alert email.
Email Server Select the mail server for the alert email.
Send SNMP(...) Trap Send an alert to an SNMP community or user selected from the dropdown. For

more information, see SNMP on page 288.

Send Alert to Syslog Server Send an alert to the syslog server selected from the dropdown. For more
information, see Syslog Server on page 332.

Send Each Alert Separately Enable to send each alert individually instead of in a group.
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Creating a custom event handler

You can create a custom event handler from scratch or clone a predefined event handler and customize its settings. See
Cloning event handlers on page 226.

Configuring an event handler includes defining the following main sections in the GUI:

Option Description

Event handler attributes The status, name, description, data selector, and automation stitch for the event
handler.
Rules The rules for event generation.

» Select the log types and subtypes to limit the logs that trigger an event.

« Group the logs by primary and secondary (optional) values to separate the
events that are generated for different Group By values.

¢ Set the number of occurrences within a time frame that triggers an event.

¢ Configure event fields, such as event status and severity.

Handler Settings The notification profile for the event handler.
Add New Basic Event Handler x

Status ©

Name*

Description

Data Selector Click to select M

Automation Stitch o

Rules

Add New Rule
Handler Settings
Notifications Click to select v

To create a new event handler:

1. Goto Incidents & Events > Handlers > Basic Handlers.
2. Inthetoolbar, click Create New.
The Add New Basic Event Handler pane displays.

3. Configure the following options, and click OK to save the event handler.

Option Description

Status Enable or disable the event handler.

Enabled event handlers show a o icon in the Status column. Disabled event

handlers show a @ icon in the Status column.

Name Enter a name for the event handler.
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Option Description

Description (Optional) Enter a description for the event handler.

Data Selector Select a data selector for the event handler.

This selects devices, subnets, and filters used for the event handler. See
Creating data selectors on page 213.

Automation Stitch Enable or disable automation stitch.

When enabled, FortiAnalyzer sends a notification to FortiGate when events
are generated by the event handler. The events are available in the
FortiAnalyzer GUI as well. For more information, see Using the Automation
Stitch for event handlers on page 224.

Rules

Add New Rule Click to add a rule. The Add New Rule pane displays. Configure the options
below, and then click OK to save the rule.

You can add multiple rules to the event handler. Each rule has an OR
relationship with other rules enabled in the event handler.

Status Enable or disable the rule. If the rule is disabled, it will not be used to generate
events.

Name Enter a name for the rule.

Log Device Type If you are in a Security Fabric ADOM, select the log device type from the
dropdown list. If you are not in a Security Fabric ADOM, you cannot change
the Log Device Type.

The Fabric log device type can be used to generate alerts from SIEM logs
when SIEM logs are available.

Log Type Select the log type from the dropdown list.

When Devices is set to Local Device, you cannot change the Log Type or Log
Subtype.

Log Subtype Select the category of event that this event handler monitors. The available
options depend on the platform type.
This option is only available when the Log Type has a subtype. For example,
Event Log and Traffic Log have log subtypes which can be selected from the
dropdown.

Group By Select how to group the events. Click Add beside the Group By field to add up
to two additional Group By fields, to a maximum of three.

Logs match Select All or Any of the following conditions.
Click plus (+) to insert a new condition. You can insert multiple conditions.
Configure the condition(s):
¢ Log Field: Select a log field from the dropdown.

After the log device and log type are selected, the Log Field dropdown list
will only include log fields that belong to the specified log type. For
example, the Botnet IP log field is available when the Log Type is DNS,
but not available when the Log Type is Event Log.
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Option Description

Generic Text Filter

Aggregate
Expression

Aggregate
Duration

Event Type
Override

Event Message

Event Status
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¢ Match Criteria: Select an operator from the dropdown. The available
options depends on the selected log field.
Some log fields, such as Source Port, will provide a variety of operators in
the dropdown list, such as Equal To, Not Equal To, Greater Than or Equal
To, Less Than or Equal To, Greater Than, and Less Than.
Other log fields, such as Log Description, will be limited to Equal To and
Not Equal To.

¢ Value: Select a value from the dropdown list or enter a value in the text
box. The available options depends on the selected log field.
If there is no dropdown list provided by FortiAnalyzer, you must manually
enter a value to find in the raw log.
If a dropdown list is provided, you can select a value from the list. For
some log fields, such as Level, the dropdown list also allows you to enter
a custom value. If there is no textbox to enter a custom value in the
dropdown list, you must use the Generic Text Filter instead.

To delete a condition, click the x next to the condition.

Enter a generic text filter. See Using the Generic Text Filter on page 224.

For information on text format, hover the cursor over the help icon. The
operator ~ means contains and ! ~ means does not contain.

Enter the minimum threshold for the rule.
e COUNT: enter the minimum count threshold.
e« COUNT_DISTINCT: select the field that must be distinct, such as Source
IP or Application, and enter the minimum count threshold.
e SUM: select the measure, and enter the minimum sum threshold.

Al
‘Q' The SUM option is used for data exfiltration detection. This
- option is only supported in Fabric ADOMs.

Enter the minimum threshold in minutes to generate events.

This option works together with the Aggregate Expression. Enter the number
of matching logs (Aggregate Expression) that must occur in the number of
minutes (Aggregate Duration) to generate an event.

Specify a custom event type, or leave this field blank to use the default value.

(Optional) Enter a custom event message.

The default message is the Group By value. You can use variables in the
event message.

Select Allow FortiAnalyzer to choose or select a status from the dropdown list:
Unhandled, Mitigated, Contained, (Blank). You can use a custom event status
by clicking the plus (+) that appears in the Event Status dropdown.

Event statuses, including custom statuses, are displayed in the Event Status
column in the Event Monitor.
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Option Description

Event Severity Select the severity from the dropdown list: Critical, High, Medium, or Low.

Tags (Optional) Enter custom tags.
Tags can be used as a filter when using default or custom views.

Indicators (Optional) Add indicators by clicking the plus (+). You can configure the Log
Field, Indicator Type, and Count for each indicator created in an event
handler. Use the buttons in the Action column to add (+) or remove (x)
indicators. Up to five indicators can be created.
When Indicators is selected in Event Monitor > Display Options, the Indicators
column displays indicator types for detected events. You can see additional
details when clicking on an indicator. See Event Monitor on page 175
If an incident is raised from an event that includes indicators, they can be
viewed in the Indicators tab of the incident analysis page. See Analyzing an
incident on page 229.

Additional Info Specify what to show in the Additional Info column of the Event Monitor.

Select Use system default or Use custom message. A custom message can
include variables and log field names. For more information, hover over the
help icon.

Handler Settings

Notifications Select a notification profile for the event handler. See Creating notification
profiles on page 215.

Creating a custom correlation handler

You can create a custom correlation handler from scratch or clone a predefined correlation handler and customize its
settings. See Cloning event handlers on page 226.

Configuring an correlation handler includes defining the following main sections in the GUI:

Option Description

Correlation event handler The name, description, data selector, and automation stitch for the correlation
attributes handler.

This section also includes the threshold duration for the handler.

Correlation Sequence The rules for event generation in sequence and logic group.
» Select the log types and subtypes to limit the logs that trigger an event.
¢ Group the logs by primary and secondary (optional) values to separate the
events that are generated for different Group By values.
e Set the number of occurrences that can trigger an event.

Correlation Criteria The correlation criteria to specify the type of logs that the event handler will look
for. The criteria is applied to two rules on a field from each rule.

Handler Settings The event fields, including the event type override, event message, event status,
event severity, indicators, and tags.

FortiAnalyzer 7.4.0 Administration Guide 219
Fortinet Inc.



Incidents & Events

Option Description

This section also includes the notification profile for the correlation handler.

Add New Correlation Event Handler x

Status ©

Name

Description

Automation Stitch @
Data Selectar Click to select M

Threshold Duration € 30
Correlation Sequence

Pl + New Conreiation Group

Show Raw Config @
Correlation Criteria

Rule Field Match Criteria Rule Field Action

Handler Settings

Event Type Override Specify an event type, or leave blank to use default value
Event Message @
Event Status :

Allow FortiAnalyzer to choose
Event Severity Medium -
Tags
Indicators € Log Field Indicator Type Count Action

Additional Info @ Use system defauit

© Use custom message @

Noftifications Click to select v

[ o Jacmm

To create a new correlation event handler:

1. Goto Incidents & Events > Handlers > Correlation Handlers.

2. Inthetoolbar, click Create New.
The Add New Correlation Event Handler pane displays.

3. Configure the following options, and click OK to save the correlation event handler.

Option Description

Status Enable or disable the event handler.

Enabled event handlers show a O icon in the Status column. Disabled event

handlers show a @ icon in the Status column.

Name Enter a name for the event handler.
Description (Optional) Enter a description for the event handler.
Automation Stitch Enable or disable automation stitch.

When enabled, FortiAnalyzer sends a notification to FortiGate when events
are generated by the event handler. The events are available in the
FortiAnalyzer GUI as well. For more information, see Using the Automation
Stitch for event handlers on page 224.

Data Selector Select a data selector for the event handler.
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Option Description

This selects devices, subnets, and filters used for the event handler. See
Creating data selectors on page 213.

Threshold Duration

Correlation Sequence

Add Rule

Name

Log Device Type

Log Type

Log Subtype

Group By

Logs match
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Enter the threshold duration for the correlation handler in minutes.

The logs must match the criteria in correlation sequence within this time to
generate an event.

Click the icon to add a rule. The Add New Rule pane displays. Configure the
options below and click OK to save the rule.

After creating the rules, make sure they are in the correct correlation
sequence. You can drag and drop the rules to re-order them, if needed.

Select the correlation between each of the rules:

AND

AND_NOT

OR

FOLLOWED_BY (if selected, enter a time limit for the correlation to occur
in)

NOT_FOLLOWED_BY (if selected, enter a time limit for the correlation to
occurin)

The rules must be met in the correlation sequence for the event handler to
generate an event.

Enter a name for the rule.

If you are in a Security Fabric ADOM, select the log device type from the
dropdown list. If you are not in a Security Fabric ADOM, you cannot change
the Log Device Type.

The Fabric log device type can be used to generate alerts from SIEM logs
when SIEM logs are available.

Select the log type from the dropdown list.

When Devices is set to Local Device, you cannot change the Log Type or Log
Subtype.

Select the category of event that this event handler monitors. The available
options depend on the platform type.

This option is only available when the Log Type has a subtype. For example,
Event Log and Traffic Log have log subtypes which can be selected from the
dropdown.

Select how to group the events. Click Add beside the Group By field to add up
to two additional Group By fields, to a maximum of three.

Select All or Any of the following conditions.

Click plus (+) to insert a new condition. You can insert multiple conditions.

Configure the condition(s):

Log Field: Select a log field from the dropdown.
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Option Description

Generic Text Filter

Aggregate
Expression

Add Logic Group

Show Raw Config

Correlation Criteria
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After the log device and log type are selected, the Log Field dropdown list
will only include log fields that belong to the specified log type. For
example, the Botnet IP log field is available when the Log Type is DNS,
but not available when the Log Type is Event Log.

¢ Match Criteria: Select an operator from the dropdown. The available
options depends on the selected log field.
Some log fields, such as Source Port, will provide a variety of operators in
the dropdown list, such as Equal To, Not Equal To, Greater Than or Equal
To, Less Than or Equal To, Greater Than, and Less Than.
Other log fields, such as Log Description, will be limited to Equal To and
Not Equal To.

¢ Value: Select a value from the dropdown list or enter a value in the text
box. The available options depends on the selected log field.
If there is no dropdown list provided by FortiAnalyzer, you must manually
enter a value to find in the raw log.
If a dropdown list is provided, you can select a value from the list. For
some log fields, such as Level, the dropdown list also allows you to enter
a custom value. If there is no textbox to enter a custom value in the
dropdown list, you must use the Generic Text Filter instead.

To delete a condition, click the x next to the condition.

Enter a generic text filter. See Using the Generic Text Filter on page 224.

For information on text format, hover the cursor over the help icon. The
operator ~ means contains and ! ~ means does not contain.

Enter the minimum threshold for the rule.
e COUNT: enter the minimum count threshold.
e« COUNT_DISTINCT: select the field that must be distinct, such as Source
IP or Application, and enter the minimum count threshold.
e SUM: select the measure, and enter the minimum sum threshold.

Al
‘Q' The SUM option is used for data exfiltration detection. This
- option is only supported in Fabric ADOMs.

Add a logic group.

You must select a correlation between groups (AND, AND_NOT, OR,
FOLLOWED_BY, or NOT_FOLLOWED_BY). All groups must be metin
correlation sequence for the correlation event handler to generate an event.

Enable to display the raw config of the correlation sequence.

Edits made to the raw config will appear above in the correlation sequence
fields. If there is an error in the text, the fields will not display and you will not
be able to save the changes.

Specify the fields that the event handler will look for to correlate the rules.
Each correlation criteria is applied to two rules, using a field from each rule.
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Option Description

Configure the following options for each correlation criteria:
e Rule: Select two rules to create a correlation criteria for.
» Field: Select a field for each rule in the correlation criteria. The fields
available in the dropdown are determined by the Group By field in the
rule.

» Match Criteria: Select an operator from the dropdown. The available
options depends on the selected fields.

Use the buttons in the Action column to add (+) or remove (x) correlation

criteria.
Handler Settings
Event Type Override Specify a custom event type, or leave this field blank to use the default value.
Event Message (Optional) Enter a custom event message.

The default message is the Group By value. You can use variables in the
event message.

Event Status Select Allow FortiAnalyzer to choose or select a status from the dropdown list:
Unhandled, Mitigated, Contained, (Blank). You can use a custom event status
by clicking the plus (+) that appears in the Event Status dropdown.

Event statuses, including custom statuses, are displayed in the Event Status
column in the Event Monitor.

Event Severity Select the severity from the dropdown list: Critical, High, Medium, or Low.

Tags (Optional) Enter custom tags.
Tags can be used as a filter when using default or custom views.

Indicators (Optional) Add indicators by clicking the plus (+). You can configure the Log
Field, Indicator Type, and Count for each indicator created in an event
handler. Use the buttons in the Action column to add (+) or remove (x)
indicators. Up to five indicators can be created.
When Indicators is selected in Event Monitor > Display Options, the Indicators
column displays indicator types for detected events. You can see additional
details when clicking on an indicator. See Event Monitor on page 175
If an incident is raised from an event that includes indicators, they can be
viewed in the Indicators tab of the incident analysis page. See Analyzing an
incident on page 229.

Additional Info Specify what to show in the Additional Info column of the Event Monitor.

Select Use system default or Use custom message. A custom message can
include variables and log field names. For more information, hover over the
helpicon.

Notifications Select a notification profile for the event handler. See Creating notification
profiles on page 215.
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Using the Automation Stitch for event handlers

All FortiGates added to FortiAnalyzer use a default event handler on the FortiAnalyzer side to receive high severity
events such as Botnet Communication, IPS Attack Pass Through, and Virus Pass Through AntiVirus. This basic event
handler, Default-Botnet-Communication-Detection, has automation stitch enabled in FortiAnalyzer.

Automation Stitch can also be enabled for any custom event handler. See Creating a custom event handler on page 216
and Creating a custom correlation handler on page 219.

To determine if an event handler has automation stitch enabled, review the Automation Stitch column in Incidents
& Events > Handlers > Basic Handlers and Incidents & Events > Handlers > Correlation Handlers.

When an event is generated by a handler with automation stitch enabled, FortiAnalyzer sends a notification to the
FortiGate automation framework. If an automation stitch is configured on the FortiGate, the notification will trigger the
related automation stitch and activate an action in response. For example, the FortiGate could send a custom email
notification, execute a CLI script, and/or perform a system action in response to the trigger. For more information about
automation stitches, including their triggers and actions, see the FortGate/FortiOS Administration Guide.

The events generated by handlers with the automation stitch enabled can also be viewed in the FortiAnalyzer GUI
through Incidents & Events > Event Monitor.

To receive the notifications from FortiAnalyzer on the FortiGate device, you must configure
FortiAnalyzer logging on the FortiGate device.

NP To use the notifications as part of an automation stitch, you must configure a trigger on the
‘?' FortiGate device for each event handler that has automation stitch enabled. This includes the
- predefined event handlers with automation stitch enabled, such as Default-Botnet-

Communication-Detection.

For more information about configuring FortiAnalyzer logging and automation stitch triggers,
see the FortiGate/FortiOS Administration Guide.

Using the Generic Text Filter

The Generic Text Filter field is available when creating filters for data selectors and rules for event handlers.

The Generic Text Filter uses the glibc regex library for values with operators (~,!~), using the POSIX standard. Filter
string syntax is parsed by FortiAnalyzer, and both upper and lower case characters are supported (for example, "and" is
the same as "AND"). You must use an escape character when needed. For example, cfgpath=firewall.policyis
the wrong syntax because it is missing an escape character. The correct syntax is cfgpath=firewall\.policy.

To create an event handler using the Generic Text Filter to match raw log data:

1. Goto Log View, and select a log type.
2. Inthetoolbar, click Tools > Display Raw.

The easiest method is to copy the text string you want from the raw log and paste it into the Generic Text Filter field.
Ensure you insert an escape character when necessary, for example, cfgpath=firewall\.policy.

3. Locate and copy the text in the raw log.
4. Goto Incidents & Events > Handlers > Basic Handlers and click Create New.
5. Click Add New Rule.

You can also use the Generic Text Filter when creating a rule for a correlation handler. See Creating a custom
correlation handler on page 219.
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6. Inthe Generic Text Filter box, paste the text you copied or type the text you want. Ensure you use the raw log field
names, for example, mem (not memory) and setuprate (not setup-rate).
For information on text format and operators, hover the cursor over the help icon. The operator ~ means contains
and ! ~ means does not contain.

7. Configure other settings for the rule, and click OK. For a description of the fields, see Creating a custom event
handler on page 216.
You can also use the Generic Text Filter in data selectors, which can be assigned to event handlers and correlation
handlers. For more information, see Creating data selectors on page 213.

Managing event handlers

To manage basic event handlers, go to Incidents & Events > Handlers > Basic Handlers.
To manage correlation event handlers, go to Incidents & Events > Handlers > Correlation Handlers.

These panes list the predefined and custom event handlers. An icon in the Status column indicates if the event handler is
enabled or disabled.

The following options are available:

Option Description

Create New Create a new event handler.

Edit Edit the selected event handler.

Some fields in predefined event handlers cannot be modified, such as the name,
description and filter settings. However, you can clone the predefined event
handler to create a custom event handler and modify its settings according to your
needs.

Delete Delete the selected event handler.
You cannot delete predefined event handlers.

Clone Clone the selected event handler.
You can clone a predefined event handler and modify it to create a custom event
handler.

Enable / Disable Enable or disable the selected event handler to start or stop generating events.

The current status is indicated by an icon in the Status column.

Generated events are displayed on the Incidents & Events > Event Monitor > All
Events pane.

Show Predefined Show or hide predefined event handlers in the list.

Show Custom Show or hide custom event handlers in the list.

Import / Export Export the selected event handlers or import a event handler that you have
exported.
You can export event handlers and import them into another ADOM or
FortiAnalyzer.

Factory Reset If you have modified a predefined event handler, return the selected predefined

event handler to its factory default settings.
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Enabling event handlers

For both predefined and custom event handlers, you must enable the event handler to generate events. The Event
Handlers and Correlation Handlers display an icon to indicate which event handlers are enabled. The O icon indicates

enabled event handlers and the @ icon indicates disabled event handlers.

To enable event handlers:

1. Goto Incidents & Events > Handlers > Basic Handlers.
If enabling a correlation handler, go to Incidents & Events > Handlers > Correlation Handlers.

2. Selectone or more event handlers and click More > Enable.
You can also right-click the event handler and select Enable.

Cloning event handlers

Cloning an event handler allows you to build a custom event handler by using an existing one as a template.

Most attributes in a predefined event handler cannot be modified, such as the name, description, and rule settings. You
can, however, clone a predefined event handler to customize its settings and give it a meaningful name to show its
function.

To clone an event handler:

1. Goto Incidents & Events > Handlers > Basic Handlers.

If cloning a correlation handler, go to Incidents & Events > Handlers > Correlation Handlers.
2. Select an event handler and in the toolbar and click Clone.

You can also right-click the event handler and select Clone.

3. Configure the cloned event handler. For a description of the fields, see Creating a custom event handler on page
216 or Creating a custom correlation handler on page 219.

Use a descriptive name so it is not confused with the event handler it was cloned from.
4. Click OK save the cloned event handler.

Resetting predefined event handlers to factory defaults

You can change some settings in predefined event handlers as needed. If required, you can restore those predefined
event handlers to their factory default settings.

The Factory Reset option is only available for predefined event handlers that have been changed.

To reset predefined event handlers:

1. Goto Incidents & Events > Handlers > Basic Handlers.

If resetting a predefined correlation handler, go to Incidents & Events > Handlers > Correlation Handlers.
2. Inthe More menu, select Show Predefined.
3. Select one or more predefined event handlers and click More > Factory Reset.

You can also right-click the event handler and select Factory Reset.
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If the predefined event handler has not been changed from the factory default settings, this option will be grayed-
out.

Importing and exporting event handlers

You can import and export event handlers. This feature allows you to develop custom event handlers and deploy them in
bulk to other ADOMs or FortiAnalyzer units. To do so, export the custom event handlers, and then import them into the
ADOMs or FortiAnalyzer units where you want them deployed. You can also export event handlers as part of your
backup procedure, if needed.

To export event handlers:

1. Goto Incidents & Events > Handlers > Basic Handlers.

If exporting a correlation handler, go to Incidents & Events > Handlers > Correlation Handlers.
2. Select the event handler(s) to export, and click More > Export.

You can also right-click the event handler and select Export.

‘+ Create New ‘ ‘z Edit ‘ ‘ﬁ[ Delete Hva Clone | 3 More v| Search...

[ | Status| Name © Enable ‘ Rules u
@ Disable Rule-1 Outbreak Alert - Windows Installer Zero-Day Event-Handler-0: (Outbreak Windows Installer Zer

v © Outbreak Alert - Windows Installer Zero-Da Rule-2 Outbreak Alert - Windows Installer Zero-Day Event-Handler-1: (Outbreak,Windows Installer Zer

Show Predefined
Rule-3 Outbreak Alert - Windows Installer Zero-Day Event-Handler-2: (Outbreak Windows Installer Zer
v

& Show Custom Rule-1 Outbreak Alert - Windows HTTP Protocol Stack RCE Event-Handle-0: (Outbreak Windows HTT}
Rule-2 Outbreak Alert - Windows HTTP Protocol Stack RCE Event-Handle-1: (Outbreak Windows HTTF

Rule-3 Outbreak Alert - Windows HTTP Protocol Stack RCE Event-Handle-2: (Outbreak Windows HTTF

O ©  Outbreak Alert - Windows HTTP Protocol S| H Import

B Eport Rule-4 Outbreak Alert - Windows HTTP Protocol Stack RCE Event-Handle-3: (Outbreak Windows HTTF
C Factory Reset Rule-1 Traffic to Botnet CnC blocked in virus log: (Default,By_Endpoint,Botnet,IP,C&C) logid==0202009
Rule-2 Traffic to Botnet CnC detected in virus log: (Default,By_Endpoint,Botnet,IP.C&C) logid==020200
o 9 Default-Botnet-Communication-Detection-By-Endpoint Rule-3 DNS traffic to Botnet CnC blocked: (Default,By_Endpoint,Botnet,Domain,C&C) logid==1501054
Rule-4 Traffic to Botnet CnC detected in ips log 1: (Default,By_Endpoint,Botnet,Signature,C&C) attack ~
o
Rule-1 Traffic to CnC detected: (Default,By_Endpoint,IP.C&C,loc_Rescan) tdtype~infected
O ©  Default-Compromised Host-Detection-IOC-By-Endpoint Rule-2 Web traffic to CnC detected: (Default,By_Endpoint,C&C,URL,loc_Rescan) tdtype~infected

Rule-3 DN trafic to CnC detected: (Default,By_Endpoint,C&C,Domain,loc_Rescan) tdtype~infected

3. Enable Include Data Selectors, if needed.
4, Enable Include Notification Profiles, if needed.
5. Inthe Select Export Data Type field, select Zipped, Text, or CLI.
If the data type is Zipped or Text, it will be saved as a JSON file. If the data type is CL/, it will be saved as CONF file.
6. Click OKto save the export file.

Export Event Handler

Include Data Selectors o
Include Notification Profiles (B
Select Export Data Type Zipped IRC e
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To import handlers:

1. Goto Incidents & Events > Handlers > Basic Handlers.
Ifimporting a correlation handler, go to Incidents & Events > Handlers > Correlation Handlers.

2. Click More > Import.
The Import Event Handler dialog displays.

Import Event Handler

Drag & Drop your files or Browse

3. Drag and drop the exported event handler JSON or CONF file into the import dialog, or click Browse to locate the file
on the management computer.
You can import multiple event handlers at a time.

4. Click OKto import the event handler(s).

If the imported event handler's name already exists, you will be asked if you want to Rename,

M, Replace, or Skip.
9 If you select Rename, the Unix epoch timestamp will be automatically appended to the
- imported event handler's name. For example, App Ctrl Event‘1544644459276775. The name

can be edited as required after importing.

L}
S L4
9 If the imported file is the wrong format or has an error, the system will report an error.

Incidents

Incidents can be created to track and analyze events.

Incidents raised from the Event Monitor contain event details, as well as information and actions helpful for administrator
analysis. From the incident's analysis page, administrators can assign incidents, view audit history, and manage
attached reports, events, and comments.

For more information on incidents, see the following topics:

» Raising an incident on page 229

« Analyzing an incident on page 229

» Configuring incident settings on page 231
« Adding reports to an incident on page 231
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Incidents can be viewed at Incidents & Events > Incidents.

To configure incident settings, go to Incidents & Events > Incidents, and click Settings.

Raising an incident

You can raise an incident only from alerts generated for one endpoint.
Incidents can be raised in the following ways:

« InIncidents & Events > Incidents, click Create New in the toolbar. This opens the Create New Incident pane.

« InIncidents & Events > Event Monitor > All Events, right-click an event and select Create New Incident. This opens
the Raise Incident pane with the applicable fields filled in, such as the Affected Endpoint.

The following is a description of the options available in the Create New Incident and Raise Incident pane.

Incident Category Select a category from the dropdown list.

Severity Select a severity level from the dropdown list.

Status Select a status from the dropdown list.

Affected Endpoint In the Raise Incident pane, the affected endpoint is filled in and cannot be
changed.
In the Create New Incident pane, select the affected endpoint from the dropdown
list.

Description If you wish, enter a description.

Assigned To The admin account to which the incident is assigned.

Analyzing an incident

In Incidents & Events > Incidents, double-click an incident or right-click an incident and select Analysis.

The analysis page shows the incident's affected endpoint and user, audit history, attached events, reports, comments,
and more.

In the incident information panel, you can change information collected about the incident.

In order to assist SOC analysts during their investigation, information including comments and reports can be attached to
incidents.

In the Events panel, you can review and delete events attached to the incident. See Raising an incident on page 229.

The Analysis page includes the following information and features:

Panel Description

Incident information General information about the incident.
Click Edit to modify the following information:
¢ Incident Number: The unique incident ID.
 Incident Date/Time: The date and time that the incident was created.
 Incident Category: The incident category, including Unauthorized Access,
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Panel Description

Affected Endpoint/User

Executed Playbooks

Audit History

Incident Timeline

Comments

Events

Reports

Indicators

Affected Assets

Denial of Service (DoS), Malicious Code, Improper Usage,
Scans/Probes/Attempted Access, and Uncategorized.

e Severity: The severity of the incident, including High, Medium, and Low.

« Status: The current status of the incident, including New, Analysis,
Response, Closed: Remediated, and Closed: False Positive.

¢ Affected Endpoint: The endpoint associated with this incident.

¢ Description: A description of the incident provided by the administrator.

e Assigned To: A dropdown menu of administrators to which the incident can
be assigned.

Click Refresh to manually update the displayed information.

Information about the affected endpoint/user. When multiple endpoints/users are
associated with the incident, the total number is displayed and you can click the
forward or backwards arrow on the tile to cycle between them.

The history of executed playbooks related to the incident.

Click Execute Playbook to run a playbook configured with the On_Demand
trigger. See Automation on page 135.

Displays the history of changes made to an incident, including the user who made
the change and information about the type of change that was made.

Click Expand All to see additional details.

The timeline of the events raised for the incident.
Scroll using your mouse wheel to change the displayed time frame.

Displays comments made by administrators for this incident with a timestamp.
The most recent comments appear at the top of the list.

Enter a comment and click POST to create a new comment.
Existing comments can be edited and deleted by administrators.

Displays the events that have been raised for this incident.

Attach and manage reports related to this incident.
See Adding reports to an incident on page 231.

Displays indicators attached to an incident from FortiGuard, FortiMail, or event
handlers.

Hover your mouse over an indicator to view detailed information from FortiGuard
or click Details under Results to view information from FortiMail including sender
reputation and email statistics.

Indicator information can be attached to incidents using the FortiGuard and
FortiMail connector in playbooks, or when an incident is created from an event
that includes indicators identified in the event handler.

Displays affected asset(s) in a table. Includes the host, user, IP address, and
MAC address of the asset.

Selecting a user shows endpoint information in a window.
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Panel Description

Processes Displays endpoint processes associated with this incident including the process
ID, process path, and network connection.

Select a time period to view by choosing a snapshot from the snapshot dropdown.
Processes can be displayed in a table format or as raw data.

Software Displays endpoint software associated with this incident including the software,
installation path, and installation time.

Select a time period to view by choosing a snapshot from the snapshot dropdown.
Software can be displayed in a table format or as raw data.

Vulnerabilities Displays endpoint vulnerabilities associated with this incident including the
vulnerability name, ID, severity, and category.

Select a time period to view by choosing a snapshot from the snapshot dropdown.
Vulnerabilities can be displayed in a table format or as raw data.

\,

S L4
9 Some features of incident analysis are only available with the applicable license.

Configuring incident settings

To configure incident settings, go to Incidents & Events > Incidents > Settings.

When an incident is created, updated, or deleted, you can send a notification to external platforms using selected fabric
connectors.

When an incident is created, updated, or deleted, you can send a notification to external platforms using selected fabric
connectors. To create fabric connectors to external platforms, such as ServiceNow or MS Teams, see Creating or
editing ITSM connectors on page 148.

To configure incident notification settings:

1. Goto Incidents & Events > Incidents > Settings.
2. Select a Fabric Connector from the dropdown list.
3. Select which notifications you want to receive:
« Send notification when new incident is created. Incidents with draft status will not trigger notification.
« Send notification when new incident is updated.
« Send notification when new incident is deleted.
4. To add more fabric connectors, click Create New and repeat the above steps to configure notification settings.

Adding reports to an incident

Reports can be attached to incidents to include historical data relevant to that incident.

Reports can be added to incidents through the following methods:
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1. Reports can be manually added by an admin from the Reports module or from the incident's Analysis page.
2. Reports can be automatically added to an incident by a playbook. See Automation on page 135.

Once areport has been attached to an incident, it can be viewed, managed, and downloaded from the Reports tab on
the incident's Analysis page. Multiple reports can be attached to a single incident.

To attach reports from an incident:

1. Go to Incidents & Events > Incidents, and select an incident.
2. Click on the Reports tab in the incident analysis page, and click Add.
3. Select one or more previously generated reports, and click OK.

To attach reports from the Reports module:

1. Goto Reports > Generated Reports.
2. Right-click on a report, and select Attach to Incident.
3. Selectan incident from the list, and click Add to this incident.

Threat Hunting

Incidents & Events includes the Threat Hunting pane which offers a SOC analytics dashboard using the SIEM database.
Threat Hunting uses cached data to allow SOC analysts to quickly drilldown on logs in fields of interest. To view the
Threat Hunting dashboard, go to Incidents & Events > Threat Hunting. The Threat Hunting dashboard includes a log
count chart and SIEM log analytics table.

The Threat Hunting dashboard is only available in Fabric ADOMs when ADOMs are enabled.

To change the displayed time range, select a time from the dropdown in the top-left corner of the dashboard. You can
configure custom time ranges by selecting either Last N Minutes, Last N Hours, or Last N Days. Apply filters to the
dashboard using Add Filter or by right-clicking on a value in the table and selecting the corresponding filter. Only logs
matching the selected time range and filter are displayed in the SIEM log analytics table.
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1% Enterprise_FortiAnalyzer
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Using the log count chart

A chart displaying the total log count during the specified time range is presented at the top of the Threat Hunting
dashboard.

You can zoom in and out on the displayed time range by using your mouse's scroll wheel or by adjusting the timebar
below the graph. You can adjust the time bar by dragging the start and stop bars on either side of the selected time
range, or by clicking and dragging the entire time range to the left or right. Only logs displayed within the time period
visible in the chart are shown in the SIEM log analytics table.

LastNHours v | N|1 15:07:36 To 16:07:35

|[Add Filter | (7] ‘

Using the SIEM log analytics table

The SIEM log analytics table contains a list of fields of interest in the left menu as well as the analytics table. You can
select a field from the left menu to view corresponding data in the table. The table includes a row for the null value of that
field, if applicable. For example, see the image below where Application Service is blank (null) in row 5.

Double-click an item in the table to open the log drilldown page which displays detailed log information. This feature
includes the same functions as are available in Log View, including the search bar filter, time filter, columns settings,
right-click filter, and more. See Viewing message details on page 113
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Threat Action (4) 2021-03-30 13:00:00 - 2021-03-30 13:35:00
Threat Pattern (242) # Application Service Count Sent (bytes) Session Duration
Threat Name (239) 1 HTTP 23,809(17%) m— 5.6 MB 03s
Threat Type (8) 2 NTP 23.273(17%) m— 19.9 MB 07m 32s
) 3 DNS 18,817(14%) mmmm 3.2 MB 04m 05s
File Hash (&) 4 S5 17,143(12%)
File Name (10) 5 15,107(11%) mmm 657.4 MB 34m 13s
Application Process (2) 6 tcp/B013 13,287(10%) mm 20.0 MB 03s
o 7 HTTPS 11,028(8%) mm 17.6 MB 07s
Application Name (23)
8 TIMESTAMP 1.557(1%) 1 80.7 KB 01m
Application Service (10326) 9 PING 1,541(1%) 1 42.1 KB o1m
HTTP Referrer (2) 10 tep/514 775(1%) 1 638.5 MB 30m 455
. 9
Destination Domain (39) 11 icmp/0/13 639(< 1%) |
12 icmp/0/8 245(< 1%) I
Destination IP (757]
stination IP (757) 13 tcp/10432 206(<1%) | 30.6 KB 19s
Source IP (143) 14 EMS(iZ€4,YAS) 169(< 1%) |
Event Action (26) 15 EMS(i%:°5,YAS) g
16 udp/B888 72(< 1%) 6.5 KB 10s
Event ID (34)
17 FTGD 72(< 1%)
UEBA User ID (14] 18 EMS(ARBUTUS) 44(< 1%)
UEBA Endpoint ID (151) 19 BusinessCritialCloudApp 36(< 1%)
20 tcp/55800 22{< 1%) 3.2 KB 15s

Data Source ID (11)

SIEM log parsers

FortiAnalyzer's SIEM capabilities parse, normalize, and correlate logs from Fortinet products, Apache and Nginx web
servers, and the security event logs of Windows and Linux hosts (with Fabric Agent integration). The SIEM logs are
displayed as Fabric logs in Log View and can be used when generating reports. See Types of logs collected for each
device on page 110.

Parsing is predefined by FortiAnalyzer and does not require manual configuration by administrators. The predefined
SIEM log parsers can be managed in Incidents & Events > Log Parser. This pane includes predefined log parsers and
any custom log parsers that you have imported.

This topic includes information about:

+ Log Parsers on page 234
¢ Assigned Parsers on page 236

Log Parsers

Go to Incidents & Events > Log Parser > Log Parsers and select Show Predefined and Show Custom to show all
available log parsers in the table view.
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The table view has the following columns:

Column Description

# The priority of the log parser.

To change the priority of a log parser, click and hold the checkbox for the row.
Drag and drop the row in the desired priority.

Name The name of the SIEM log parser.

Application The application of the log parser, such as FortiGate.
Category The category of the log parser, such as Fortinet Device.
Status The status of the log parser: Enabled or Disabled.

Double-click a log parser in the table view to display the Log View for Log Parser pane. This pane displays all related
SIEM logs for the log parser in a table view.

You can also view the SIEM logs from Log View > Fabric > All. Filter the log view by Data
ﬂ Parser Name = name of the log parser todisplay the related logs. For example,
I filterby Data Parser Name = FortiGate Log Parser todisplay logs related to the
predefined FortiGate Log Parser.

You can perform the following actions from Incidents & Events > Log Parser > Log Parsers:

Action Description

Import Import a custom log parser. The log parser must be in JSON format.

Export Export a log parser in the JSON format.

View Logs Open the Log View for Log Parser pane to display all related SIEM logs in a table
view.

Delete Delete a custom log parser. You cannot delete a predefined log parser.

Enable Enable a log parser.

Disable Disable a log parser. You cannot disable a log parser if it is assigned and in use.

Validate Validate a raw log with the selected log parser. You cannot perform the Validate

action with more than one log parser at a time.
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See below for more information about these actions.

To import a custom log parser:

1. InIncidents & Events > Log Parser > Log Parsers, click Import.
The Import Log Parser dialog displays.

2. Dragand drop or select the log parser.
The log parser must be in the correct format as a JSON file to meet the requirements checked during the import.

3. Click OK.
Once added, the custom log parser will be included in the table view when Show Custom is selected.

To export a log parser:

1. InIncidents & Events > Log Parser > Log Parsers, select the checkbox for log parser(s).

2. Click Export.
The log parser(s) are exported in JSON format. You can export predefined log parsers to use them as a template for
custom log parsers.

To enable or disable a log parser:

1. InIncidents & Events > Log Parser > Log Parsers, select the checkbox for log parser(s).
2. Click Enable or Disable.
The Enable action is only available when the selected log parsers are disabled.

The Disable action is only available when the selected log parsers are enabled. The action can only be performed
when the log parser is not assigned to any devices.

To validate if the original logs can be parsed:

1. InIncidents & Events > Log Parser > Log Parsers, select the checkbox for a log parser.
2. Click Validate.
The Validate Log Parser pane opens.

3. Enteralog to validate and click Validate.
A Parse Result displays in the Validate Log Parser pane.

Assigned Parsers

Go to Incidents & Events > Log Parser > Assigned Parsers to view the devices/applications and their current log parser
assignments in a table view.
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To assign a log parser to a device/application:

1. InIncidents & Events > Log Parser > Assigned Parsers, click Create New.
The Assign Parser pane displays.

2. From the Device ID dropdown, select a device for the log parser assignment.

3. From the Application dropdown, select an application for the log parser assignment.

4. From the Current Parser dropdown, select the log parser.
The log parser must use the selected Application. See Incidents & Events > Log Parser > Log Parsers to determine
which application is used by the log parser.

5. Click OK.

To edit a log parser assignment:

1. InIncidents & Events > Log Parser > Assigned Parsers, click Create New.
The Change Parser pane displays.

2. From the Current Parser dropdown, select the log parser.
The log parser must use the selected Application. See Incidents & Events > Log Parser > Log Parsers to determine
which application is used by the log parser.

3. Click OK.

Outbreak Alerts

The FortiAnalyzer Outbreak Detection Service is a licensed feature that allows FortiAnalyzer administrators to view
outbreak alerts and automatically download related event handlers and reports from FortiGuard.

When FortiAnalyzer has a valid license for the Outbreak Detection Service, outbreak alerts from Fortinet are displayed in
the Incidents & Events > Outbreak Alerts pane. Outbreak alerts can be viewed from any ADOM. You can navigate
between outbreak alerts by clicking on the corresponding tab at the top of the pane, and click the download icon to
download a copy of the outbreak alert.
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Outbreak event handlers and reports are created in real-time by Fortinet to detect and respond to emerging outbreaks.
Outbreak reports and event handlers are automatically downloaded so that they are available in your environment. See
Viewing imported event handlers and reports on page 238.

Without a valid license for the Outbreak Detection Service, Outbreak Alerts displays a default alert page, and outbreak
event handlers and reports are not available from FortiGuard. To obtain a valid license for FortiAnalyzer Outbreak
Detection Service, contact Fortinet FortiCare.

Viewing imported event handlers and reports

With a valid license, the FortiAnalyzer Outbreak Detection Service automatically downloads event handlers and reports
created by Fortinet in response to known outbreaks. This section includes information on how to view downloaded
outbreak event handlers and reports.

To view outbreak event handlers and reports:

1. Goto Incidents & Events > Handlers > Basic Handlers.
Event handlers created by the FortiAnalyzer Outbreak Detection Service are displayed with the Outbreak Alert
prefix. See Event handlers on page 182.
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2. Goto Reports > All Reports.
The Outbreak Alert Reports folder includes available reports from the FortiAnalyzer Outbreak Detection Service.
Reports can be run in HTML, PDF, XML, CSV, and JSON output formats. See Generating reports on page 241.
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You can generate data reports from logs by using the Reports feature. You can do the following:

» Use predefined reports. Predefined report templates, charts, and macros are available to help you create new
reports.

» Create custom reports.

Report files are stored in the reserved space for the FortiAnalyzer device. See Automatic deletion on page 129.
When rebuilding the SQL database, Reports are not available until the rebuild is completed.
Select the Show Progress link in the message to view the status of the SQL rebuild.

For more information on FortiAnalyzer report technology and troubleshooting report performance issues, see the
FortiAnalyzer Report Performance Troubleshooting Guide.

How ADOMs affect reports

When ADOMs are enabled, each ADOM has its own reports, libraries, and advanced settings. Make sure you are in the
correct ADOM before selecting a report. See Switching between ADOMs on page 25.

Some reports are available only when ADOMs are enabled. For example, ADOMs must be enabled to access
FortiCarrier, FortiCache, FortiClient, FortiDDoS, FortiMail, FortiSandbox, and FortiWeb reports. In a Security Fabric
ADOM, all reports are displayed.

You can configure and generate reports for these devices within their respective default ADOM or a Security Fabric
ADOM. These devices also have device-specific charts and datasets.

ADOM limits for reports

The following table identifies FortiAnalyzer ADOM limits for reports.

Chart 5000
Dataset 5000
Macro 5000
Layout 2000
Schedule 2000
Layout-folder 100

Output 2000

FortiAnalyzer 7.4.0 Administration Guide 239

Fortinet Inc.



Reports

Predefined reports, templates, charts, and macros

FortiAnalyzer includes a number of predefined elements you can use to create and/or build reports.

Predefined... GUI Location Purpose
Reports Reports > Report Definitions > All You can generate reports directly or with minimum
Reports setting configurations. Predefined reports are actually

report templates with basic default setting configurations.

Templates Reports > Report Definitions > You can use directly or build upon. Report templates
Templates include charts and/or macros and specify the layout of
the report. A template populates the Layout tab of a
report that is to be created. See List of report templates

on page 258.
Charts Reports > Report Definitions > Chart You can use directly or build upon a report template you
Library are creating, or in the Layout tab of a report that you are

creating. Charts specify what data to extract from logs.

Macros Reports > Report Definitions > Macro ~ You can use directly or build upon a report template that
Library you are creating, or in the Layout tab of a report that you
are creating. Macros specify what data to extract from
logs.

Logs used for reports

Reports uses Analytics logs to generate reports. Archive logs are not used to generate reports. For more information,
see Data policy and automatic deletion on page 37.

You can use the Report Guidance feature to make sure the appropriate Analytics logs are available for a custom or
predefined report. For more information, see Report guidance on page 241.

For reports about users, the FortiGate needs to populate the user field in the logs sent to FortiAnalyzer.

How charts and macros extract data from logs

Reports include charts and/or macros. Each chart and macro is associated with a dataset. When you generate a report,
the dataset associated with each chart and macro extracts data from the logs and populates the charts and macros.
Each chart requires a specific log type.

FortiAnalyzer includes a number of predefined charts and macros. You can also create custom charts and macros.

How auto-cache works

When you generate a report, it can take days to assemble the required dataset and produce the report, depending on the
required datasets. Instead of assembling datasets at the time of report generation, you can enable the auto-cache
feature for the report.
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Auto-cache is a setting that tells the system to automatically generate hcache. The hcache (hard cache) means that the
cache stays on disk in the form of database tables instead of memory. Hcache is applied to “matured” database tables.
When a database table rolls, it becomes “mature”, meaning the table will not grow anymore. Therefore, it is unnecessary
to query this database table each time for the same SQL query, so hcache is used. Hcache runs queries on matured
database tables in advance and caches the interim results of each query. When it is time to generate the report, much of

the datasets are already assembled, and the system only needs to merge the results from hcaches. This reduces report
generation time significantly.

The auto-cache process uses system resources to assemble and cache the datasets and it takes extra space to save
the query results. You should only enable auto-cache for reports that require a long time to assemble datasets.

Generating reports

You can generate reports by using one of the predefined reports or by using a custom report that you created. You can
find all the predefined reports and custom reports listed in Reports > Report Definitions > All Reports.

x Click the icon in the Config Recommendation column to determine if the appropriate Analytics

logs are available for the report. For more information, see Report guidance on page 241.

To generate a report:

1. Goto Reports > Report Definitions > All Reports.
2. Inthe content pane, select a report from the list.

3. (Optional) Click Edit in the toolbar and edit settings on the Settings and Layout tabs. For a description of the fields in
the Settings and Layout tabs, see Reports Settings tab on page 247 and Creating charts on page 263 and Macro
library on page 267.

4. Inthe toolbar, click Run Report.

Generated reports can be attached to incidents. See Adding reports to an incident on page 231.

Report guidance

You can use the Report Guidance feature to determine if FortiAnalyzer has the appropriate Analytics logs available for a
report.

If Analytics logs are not available for a chart or macro used in the report, it will display No Data in the report output. For
example, the Analytics logs may not be available if;

« logging is not enabled correctly on the device,

» the log requires a FortiGuard license and you do not have one,

« orthere are no matching logs at that time.
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To use Report Guidance:

1. Goto Reports > Report Definitions > All Reports.

2. Click the icon in the Config Recommendation column for the report.
The Report Guidance pane dispays for that report. The information in the Report Guidance pane is organized by
Item Title (chartor macroname), Device Type,and Log Type. Tehe pane indicates the relevant Log
Fields and if the Analytics logs are available.
See below for a partial example from Report Guidance for the 360-Degree Security Review report:

Item Title: 360 Degree Application Visibility and Control
Device Type: FortiGate

Log Type: app-ctrl

Log Fields: app, appcat

Analytics logs available: Yes

Item Title: 360 Degree Threats Detection and Prevention
Device Type: FortiGate

Log Type: app-ctrl

Log Fields: app, appcat

Analytics logs available: Yes

Device Type: FortiGate

Log Type: attack

Log Fields: attack, severity
Analytics logs available: Yes

Viewing completed reports

After you generate reports, you can view completed reports in Reports > Generated Reports or Reports > Report
Definitions > All Reports. You can view reports in the following formats: HTML, PDF, XML, CSV, and JSON.

To view completed reports in Generated Reports:

1. Goto Reports > Generated Reports.
This view shows all generated reports for the specified time period.
2. To sort the report list by date, click Order by Time.To sort the report list by report name, click Order by Name.
3. Locate the report and click the format in which you want to view the report to open the report in that format.
For example, if you want to review the report in HTML format, click the HTML link.

To view completed reports in All Reports:

1. Go to Reports > Report Definitions > All Reports.
2. Onthe report list, double-click a report to open it.

3. Inthe View Report tab, locate the report and click the format in which you want to view the report to open the report
in that format.

For example, if you want to review the report in HTML format, click the HTML link.
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Enabling auto-cache

You can enable auto-cache to reduce report generation time for reports that require a long time to assemble datasets.
For information about auto-cache and hcache, see How auto-cache works on page 240.

You can see the status of building the cache in Reports > Report Definitions > All Reports in the Cache Status column.

To enable auto-cache:

Go to Reports > Report Definitions > All Reports.

Select the report from the list, and click Edit in the toolbar.
In the Settings tab, select the Enable Auto-cache checkbox.
Click Apply.

o bd-=

Grouping reports

If you are running a large number of reports which are very similar, you can significantly improve report generation time
by grouping the reports. Grouping reports has these advantages:

o Reduce the number of hcache tables.
« Improve auto-hcache completion time.
« Improve report completion time.

Step 1: Configure report grouping

For example, to group reports with titles containing string Security Report by device ID and VDOM, enter the
following CLI commands:

config system report group
edit O
set adom root
config group-by
edit devid
next
edit vd
next
end
set report-like Security Report
next
end

Notes:
o The report-1ike field specifies the string in report titles that is used for report grouping. This string is case-
sensitive.
» The group-by value controls how cache tables are grouped.

» To view report grouping information, enter the following CLI command, then check the Report Group column of the
table that is displayed.

execute sgl-report list-schedule <ADOM>
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Step 2: Initiate a rebuild of hcache tables

To initiate a rebuild of hcache tables, enter the following CLI command:

diagnose sgl hcache rebuild-report <start-time> <end-time>

Where <start-time>and <end-time> are in the format: <yyyy-mm-dd hh:mm:ss>.

Retrieving report diagnostic logs

Once you start to run a report, FortiAnalyzer creates a log about the report generation status and system performance.
Use this diagnostic log to troubleshoot report performance issues. For example, if your report is very slow to generate,
you can use this log to check system performance and see which charts take the longest time to generate.

For information on how to interpret the report diagnostic log and troubleshoot report performance issues, see the
FortiAnalyzer Report Performance Troubleshooting Guide.

To retrieve report generation logs:

1. In Reports > Generated Report, right-click the report and select Retrieve Diagnostic to download the log to your
computer.

2. Use atext editor to open the log.

Auto-Generated Reports

The Cyber Threat Assessment report is automatically generated. By default, the report will run at 3:00AM every Monday.
For more information on report scheduling, see Scheduling reports on page 244.

Schedules can be viewed in the Report Calendar. See Report calendar on page 279.

Ay
‘9' This will only affect newly installed FortiAnalyzer or newly created ADOM. Upgraded ADOM
- reports, scheduling and calendar will be kept as is.

Scheduling reports

You can configure a report to generate on a regular schedule. Schedules can be viewed in the Report Calendar. See
Report calendar on page 279.

To schedule a report:

Go to Reports > Report Definitions > All Reports.

Select a report and click Edit in the toolbar.

Click Settings in the toolbar.

Select the Enable Schedule checkbox and configure the schedule.
Click Apply.

a b obd-=
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Creating reports

You can create reports from report templates, by cloning and editing predefined/existing reports, or start from scratch.

Creating reports from report templates

You can create a new report from a template. The template populates the Layout tab of the report. The template
specifies what text, charts, and macros to use in the report and the layout of the content. Report templates do not contain
any data. Data is added to the report when you generate the report.

To create a new report from a template:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > All Reports.
3. Inthetoolbar, click Report > Create New. The Create Report dialog box opens.

Create Report

Mame
Create from Elank
(® From Template
Template - Cyber Threat Assessment
Save to Folder All Reports/Application Reports « |+

4. Inthe Name box, type a name for the new report. The following characters are NOT supported in report names: \/"'
<>&,|#?%%$+

5. Select From Template for the Create from setting, then select a template from the dropdown list. The template
populates the Layout tab of the report.

6. Select the folder that the new report will be saved to from the dropdown list. You can click the add button to include
additional folder locations. See Organizing reports into folders on page 255

7. Select OKto create the new report.

8. Onthe Settings tab, configure the settings as required. For a description of the fields, see Reports Settings tab on
page 247.

9. Optionally, go to the Layout tab to customize the report layout and content. For a description of the fields, see
Reports Editor tab on page 251.

10. Click Apply to save your changes.

#)
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Creating reports by cloning and editing

You can create reports by cloning and editing predefined and/or existing reports.

To create a report by cloning and editing:

o bN-=

If using ADOMs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the content pane, select the report from the list, then click Report > Clone in the toolbar.

In the Clone Report dialog box, type a name for the cloned report. The following characters are NOT supported in
report names:\/"'<>&,|#?%$ +

Select the folder that the new report will be saved to from the dropdown list. See Organizing reports into folders on
page 255

Select OK to create the new report.

On the Settings tab, configure the settings as required. For a description of the fields, see Reports Settings tab on
page 247.

Optionally, go to the Layout tab to customize the report layout and content. For a description of the fields, see
Reports Editor tab on page 251.

Click Apply to save your changes.

Creating reports without using a template

To create a report without using a template:

P owbd-=

o

10.

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the toolbar, click Report > Create New. The Create New Report dialog box opens.

In the Name box, type a name for the new report. The following characters are NOT supported in report names: \/"'
<>&,|#?7%$+

Select the Blank option for the Create from setting.

Select the folder that the new report will be saved to from the dropdown list. You can click the add button to include
additional folder locations. See Organizing reports into folders on page 255

Select OK to create the new report.

On the Settings tab, you can specify a time period for the report, what device logs to include in the report, and so on.
You can also add filters to the report, add a cover page to the report, and so on. For a description of the fields, see
Reports Settings tab on page 247.

x To create a custom cover page, you must select Print Cover Page in the Advanced

Settings menu.

On the Layout tab, you can specify the charts and macros to include in the report, as well as report content and
layout.

For a description of the fields, see Reports Editor tab on page 251.

For information about creating charts and macros, see Creating charts on page 263 and Creating macros on page
267.

Click Apply to save your changes.
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Reports Settings tab

The following options are available in the Settings tab:

Field Description

Name The report name.

Time Zone The time zone to use for data in the report.

The Default time zone is the time zone set for the FortiAnalyzer. For more information, see

Configuring the system time on page 42.

Time Period The time period th

e report covers.

Available report filter time periods include Previous 7 Days, Previous 14 Days, Previous
30 Days, This Week, Previous Week, Previous 2 Weeks, Previous N Hours, Previous

N Days, Previous N Weeks, This Month, Previous Month, This Quarter, Previous Quarter,

This Year, Today,

Select a time period or select Custom to manually specify the start and end date and time.

Yesterday, and Custom.

The specific range of time included for your report is displayed below the selected Time

Period.

Ay

Previous time period filters can include up to the previous days data at
the latest, and do not include data from the current day. This ensures
that data is not missed during report generation and that scheduled
reports using these filters include a consistent time period.

Devices The devices to include in the report. Select either All Devices or Specify to add specific
devices. Select the add icon to select devices.

Subnets Select All Subnets to include all subnets, or select Specify to include/exclude subnets as a

filter for this report. See Subnets on page 163.

Type Select either Single Report (Group Report) or Multiple Reports (Per-Device).
This option is only available if multiple devices are selected.
Enable Schedule Select to enable report template schedules.
Enable Notification Select to enable notification to the selected output profile.
Enable Auto-Cache Select to assemble datasets before generating the report and as the data is available.

This process uses system resources and is recommended only for reports that require

days to assemble

datasets. Disable this option for unused reports and for reports that

require little time to assemble datasets.

Extended Log Enable to cache the following log fields for faster filtering.

Filtering e Device ID

e Source Endpoint ID

e Source IP
e Source Userl
¢ Destination IP

D

Generate PDF Report Select when the report is generated.

Every
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Field Description

Enter a number for the frequency of the report based on the time period selected from the
dropdown list.

Start time Enter a starting date and time for the file generation.
End time Enter an ending date and time for the file generation, or set it to never ending.
Enable Notification Select to enable report notification.

Output Profile Select the output profile from the dropdown list, or click Create New to create a new output

profile. See Output profiles on page 275.

Filters section of Reports Settings tab

See Filtering report output on page 253.

Advanced Settings section of Reports Settings tab

The following options are available in the Advanced Settings section of the Setftings tab.

Field

Description

Language

Bundle rest into “Others”

Print Orientation
Chart Heading Level
Default Font

Hide # Column

Layout Header

Layout Footer

Print Cover Page

Print Table of Contents

Print Device List

Print Report Filters
Obfuscate User

Resolve Hostname

FortiAnalyzer 7.4.0 Administration Guide
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Select the report language.

Select to bundle the uncategorized results into an Others category.
Set the print orientation to portrait or landscape.

Set the heading level for the chart heading.

Set the default font.

Select to hide the column numbers.

Enter header text and select the header image. Accept the default Fortinet image
or click Browse to select a different image.

Select either the default footer or click Custom to enter custom footer text in the
text field.

Select to print the report cover page. Click Customize to customize the cover
page. See Customizing report cover pages on page 249.

Select to include a table of contents.

Select to print the device list. Select Compact, Count, or Detailed from the
dropdown list.

Select to print the filters applied to the report.
Select to hide user information in the report.

Select to resolve hostnames in the report.
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Field Description

Allow Save Maximum Select a value between 1-10000 for the maximum number of reports to save.

Color Code The color used to identify the report on the calendar. Select a color code from the

dropdown list to apply to the report schedule. Color options include: Bold Blue,

Blue, Turquoise, Green, Bold Green, Yellow, Orange, Red, Bold Red, Purple, and

Gray.

Enable Report Filter Caching Select to accelerate processing speed when generating multiple reports. In this

case, all filters are applied when querying the hcache table. This is the default.
De-select to improve report accuracy. In this case, the filters are put inside the

hcache to increase data accuracy. However, this will also impact performance.

Enable High Accuracy Select to increase the maximum hcache rows, increasing data accuracy.

Caching You can show, set, or reset the maximum number of rows for high-accuracy

hcache by entering the following command in the FortiAnalyzer CLI:

diagnose sqgl config hcache-max-high-accu-row [reset | set
<integer>]

De-select to use the default number of hcache rows, increasing system

performance. This is the default.

You can show, set, or reset the default number of hcache rows by entering the

following command in the FortiAnalyzer CLI:

diagnose sqgl config hcache-max-rpt-row [reset | set
<integer>]

Customizing report cover pages

A report cover page is only included in the report when enabled on the Settings tab in the Advanced Settings section.

When enabled, the cover page can be customized to contain the desired information and imagery.

To customize a report cover page:

If using ADOMs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the content pane, select the report from the list, and click Report > Edit in the toolbar.
Select the Settings tab and then click Advanced Settings.

Select the Print Cover Page checkbox, then click Customize next to the checkbox. The Edit Cover Page pane
opens.

o wDb =
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Edit Cover Page

FEATINET

360-Degree Se

Background Image Browse...

Top Image Browse...
Top Image Position Center
Text Color W Black
{8 show Creation Time

Show Data Range

Report Title {default}
Custom Text 1

Custom Text 2

Bottom Image Browse...
Footer Left Text {default}
Footer Right Text [default}

Footer Background Color Gray

def_cove...png

6. Configure the following settings:

Background Image

Top Image

Top Image Position

Text Color

Show Creation Time
Show Data Range
Report Title

Custom Text 1
Custom Text 2

Bottom Image

Footer Left Text
Footer Right Text
Footer Background Color

Reset to Default

Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image as the background image of the
cover page.

Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image at the top of the cover page.

Select the top image position from the dropdown menu. Select one of the
following: Left, Center, Right.

Select a text color from the dropdown list.

Select to print the report date on the cover page.

Select to print the data range on the cover page.

Accept the default title or type another title in the Report Title field.
If you want, enter custom text for the Custom Text 1 field.

If you want, enter custom text for the Custom Text 2 field.

Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image to the bottom of the cover page.

If you want, enter custom text to be printed in the left footer of the cover page.

If you want, enter custom text to be printed in the right footer of the cover page.

Select the cover page footer background color from the dropdown list.

Select to reset the cover page settings to their default settings.

7. Click OKto save the configurations and return to the Settings tab.
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Reports Editor tab

Because the cut, copy, and paste functions need access to the clipboard of your operating
system, some Internet browsers either block it when called from the layout editor toolbar, or

ask you to explicitly agree to it. If you're blocked from accessing the clipboard by clicking the
respective cut, copy, and paste buttons from the toolbar or context menu, you can always use
keyboard shortcuts.

The following options are available in the Editor tab (layout editor):

Field Description

Insert Chart or Edit Chart Click to insert a FortiAnalyzer chart. Charts are associated with datasets that
extract data from logs for the report.
In the Insert Chart or Chart Properties dialog box, you can specify a custom title,
width, and filters for the chart. For information on setting filters, see Filtering report
output on page 253.
You can edit a chart by right clicking the chart in the layout editor and selecting
Chart Properties or by clicking the chart to select it and then clicking Edit Chart.

Insert Macro Click to insert a FortiAnalyzer macro. Macros are associated with datasets that
extract data from logs for the report.

Image Click the Image button in the toolbar to insert an image into the report layout.
Right-click an existing image to edit image properties.

Table Click the Table button in the toolbar to insert a table into the report layout. Right-
click an existing table to edit a cell, row, column, table properties, or delete the
table.

Insert Horizontal Line Click to insert a horizontal line.

Insert Page Break for Printing  Click to insert a page break for printing.

Link Click the Link button in the toolbar to open the Link dialog box. You can select to
insert a URL, a link to an anchor in the text, or an email address.

Anchor Click the Anchor button in the toolbar to insert an anchor in the report layout.

Cut To cut a text fragment, start with selecting it. When the text is selected, you can
cut it using one of the following methods:
¢ Click the cut button in the toolbar
e Use the CTRL+X shortcut on your keyboard.

Copy To copy a text fragment, start with selecting it. When the text is selected, you can
copy it using one of the following methods:
 Click the copy button in the toolbar
e Use the CTRL+C shortcut on your keyboard.

Paste To paste text, start with cutting or copying from within the editor or from another
source. Once the text is cut or copied, you can paste it in the editor using one of
the following methods:

¢ Click the paste button in the toolbar
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Field Description

¢ Use the CTRL+V shortcut on your keyboard.

Undo Click to undo the last action. Alternatively, use the CTRL+Z keyboard shortcut to
perform the undo operation.

Redo Click to redo the last action. Alternatively, use the CTRL+Y keyboard shortcut to
perform the redo operation.

Find Type text in the search field, and then click Find to highlight instances of that text
in the editor. The instances of that text will be highlighted one at a time, starting at
the top of the editor. The search field is not case-sensitive.

Replace This is only actionable when text has been highlighted using the Find button. Type
the replacement text in the replace field, and then click Replace to put it in place of
the highlighted text.

Replace All This is only actionable when text has been highlighted using the Find button. Type
the replacement text in the replace field, and then click Replace All to putitin
place of all instances of the text in the Find field.

Save as Template Click to save the layout as a template.

Paragraph Format Select the paragraph format from the dropdown list. Select one of the following:
Normal, Heading 1, Heading 2, Heading 3, Heading 4, Heading 5, Heading 6.

Font Name Select the font from the dropdown list.
Font Size Select the font size from the dropdown list. Select a size ranging from 8 to 72.
Bold Select the text fragment and then click the Bold button in the toolbar. Alternatively,

use the CTRL+B keyboard shortcut to apply bold formatting to a text fragment.

Italic Select the text fragment and then click the /talic button in the toolbar. Alternatively,
use the CTRL+/ keyboard shortcut to apply italics formatting to a text fragment.

Underline Select the text fragment and then click the Underline button in the toolbar.
Alternatively, use the CTRL+U keyboard shortcut to apply underline formatting to
a text fragment.

Strike Through Select the text fragment and then click the Strike Through button in the toolbar.
Subscript Select the text fragment and then click the Subscript button in the toolbar.
Superscript Select the text fragment and then click the Superscript button in the toolbar.

Text Color You can change the color of text in the report by using a color palette. To choose a
color, select a text fragment, click the Text Color button in the toolbar, and select a
color.

Background Color You can also change the color of the text background.

Insert/Remove Numbered List Click to insert or remove a numbered list.

Insert/Remove Bulleted List Click to insert or remove a bulleted list.
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Field Description

Decrease Indent To decrease the indentation of the element, click the Decrease Indent toolbar
button. The indentation of a block-level element containing the cursor will
decrease by one tabulator length.

Increase Indent To increase the indentation of the element, click the Increase Indent toolbar
button. The block-level element containing the cursor will be indented with one
tabulator length.

Block Quote Block quote is used for longer quotations that are distinguished from the main text
by left and right indentation. It is recommended to use this type of formatting when
the quoted text consists of several lines or at least 100 words.

Align Left When you align your text left, the paragraph is aligned with the left margin and the
text is ragged on the right side. This is usually the default text alignment setting for
the languages with left to right direction.

Center When you center your text, the paragraph is aligned symmetrically along the
vertical axis and the text is ragged on the both sides. This setting is often used in
titles or table cells.

Align Right When you align your text right, the paragraph is aligned with the right margin and
the text is ragged on the left side. This is usually the default text alignment setting
for the languages with right to left direction.

Justify When you justify your text, the paragraph is aligned to both the left and right
margins and the text is not ragged on either side..

Remove Format Click to remove formatting.

Filtering report output
You can apply log message filters to reports and charts.

To filter output in a report:

Click the Settings tab and scroll to the Filters section.

To filter output in a chart:

1. Click the Layout tab.
2. Filter a new or existing chart:
« Click Insert Chart and scroll to the Filters section.
» Right-click a chart in the layout and select Chart Properties. Scroll to the Filters section.

In the Filters section, the following options are available.

Field Description

Log messages that match Available in the Settings tab only.
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Field Description

Select All to filter log messages based on all of the added conditions, or select
Any of the Following Conditions to filter log messages based on any one of the
conditions.

Add Filter Click to add filters. For each filter, select the field, and operator from the dropdown
lists, then enter or select the values as applicable.

Filters vary based on device type.

When adding a filter, keep the following considerations in mind:

W ¢ The Settings and Layout tabs use the same Log Field list
‘?' to filter output; however, some log fields are not used in
charts. The Log Field you use to filter a report may not

apply to the log fields in a chart.
¢ The Value field is case sensitive.

LDAP Query Available in the Settings tab only.

Click to add an LDAP query, then select the LDAP Server and the Case Change
value from the dropdown lists.

Use this option to query an LDAP server for group membership. The results of this
query is used to filter the report to only match logs for users belonging to that
group.

You must specify the group name in the filter definition.

If you enable LDAP Query, the group name is not used to match the group field in

logs. The group name is only used for the LDAP query to determine group
membership.

The query will not retrieve the userPrincicpalName if the
N/, Distinguished Name in the System Settings does not contain
9 an organization unit (ou). To retrieve the UPN, add the
= Distinguished Name as it appears in the System Settings to
your query.

Ay
‘Q' If both chart and report filters are selected for the same report, the chart filter will be used
- instead of the report filter.

Managing reports

You can manage reports by going to Reports > Report Definitions > All Reports. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click a report to display the menu.
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Option Description

Run report Generates a report.
Report See below for report options.
Create New Creates a new report. You can choose whether to base the new report on a report
template.
Edit Edit the selected report.
Clone Clones the selected report.
Disable Schedule Disable the schedule for the selected report. You can enable schedules, if

needed, by editing the report.

Delete Deletes the selected report.

Remove from Remove the selected report from its current folder.

Folder

Move Move the report to a new folder location.

Assign to Folder Assign the selected report(s) to a folder. From the dropdown menu, select an

existing report folder. Click the add icon to add an additional folder. When multiple
folders are selected, reports are included in both folders.

Folder See below for folder options.

Create New folder Create a new folder. Folders can be nested.

Rename Folder Rename the currently selected folder.
Delete Folder Delete the currently selected folder. Folders which include reports cannot be
deleted.
More See below for more options.
Import Imports a report from a management computer.
Export Exports a report to a management computer.
Show Scheduled Only Filters the list to include only reports that have been run or are scheduled to be
run.

This setting is only available in the toolbar.

Organizing reports into folders

FortiAnalyzer reports are organized into default folders. You can create additional folders to organize reports. Reports
can be assigned to multiple folders, and folders can be nested.

To organize reports into folders:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > All Reports.
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3. Click Folderin the toolbar, and select Create New Folder.

Create Folder

Name New Reports

Save to Folder All Reports

“ Cancel

4. Specify the folder name and location and click OK. The folder is now displayed in the report list.

5. You can now drag-and-drop, move, assign, create, clone, or import reports into this folder. See Managing reports on
page 254.

#

To move folder locations:

If using ADOMs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

Highlight an existing folder, and select Report > Move from the right-click menu.
Select the target folder location, and click OK.

P obh-=

Importing and exporting reports

You can transport a report between FortiAnalyzer units. You can export a report from the FortiAnalyzer unit to the
management computer. The report is saved as a .dat file on the management computer. You can then import the report
file to another FortiAnalyzer unit.

Exporting reports only exports the report layout, charts, datasets, and images. Other report
configurations are not exported.

To export reports:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > All Reports.

3. Inthe content pane, select a report, and select More > Export in the toolbar to save the file to the management
computer.

To import reports:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.

2. Goto Reports > Report Definitions > All Reports.

3. Inthe content pane, click More > Import in the toolbar. The Import Report dialog box opens.
4

Drag and drop the report file onto the dialog box, or click Browse and locate the file to be imported on your local
computer.

o

Select a folder to save the report to from the dropdown list.
Click OK to import the report.

o
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Report template library

Because the cut, copy, and paste functions need access to the clipboard of your operating
system, some Internet browsers either block it when called from the layout editor toolbar, or

ask you to explicitly agree to it. If you're blocked from accessing the clipboard by clicking the
respective cut, copy and paste buttons from the toolbar or context menu, you can always use
keyboard shortcuts.

A report template defines the charts and macros that are in the report, as well as the layout of the content.
You can use the following items to create a report template:

o Text

o Images

o Tables

o Charts that reference datasets
« Macros that reference datasets

Datasets for charts and macros specify what data are used from the Analytics logs when you generate the report. You
can also create custom charts and macros for use in report templates.

Creating report templates
You can create a report template by saving a report as a template or by creating a totally new template.

To create a report template:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Go to the Reports > Report Definitions> Templates.
3. Inthe toolbar of the content pane, click Create New.
4. Set the following options:
a. Name.
b. Description.
c. Category. If you are in a Security Fabric ADOM, the Category must be SecurityFabric.
d. Language.

5. Use the toolbar to insert and format text and graphics for the template. In particular, use the Insert Chart and Insert
Macro buttons to insert charts and macros into the template.

For a description of the fields, see Reports Editor tab on page 251. For information about creating charts and
macros, see Creating charts on page 263 and Creating macros on page 267.

6. Click OK.
The new template is now displayed on the template list.

To create a report template by saving a report:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > All Reports.
3. Inthe content pane, select the report from the list, and click Edit in the toolbar.
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4. Inthe Layouttab, click the Save As Template button in the toolbar.

5. Inthe Save as Template dialog box, set the following options, and click OK:
a. Name.
b. Description.

c. Category. If you are in a Security Fabric ADOM, the Category must be SecurityFabric.
The new template is now displayed on the template list.

Viewing sample reports for predefined report templates
You can view sample reports for predefined report templates to help you visualize how the reports would look.

To view sample reports:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Gotothe Reports > Report Definitions > Templates.

3. Inthe content pane, click the HTML or PDF link in the Preview column of a template to view a sample report based
on the template.

Managing report templates

You can manage report templates in Reports > Report Definitions> Templates. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click a template to display the menu.

Option Description

Create New Creates a new report template

Edit Edits a report template. You can edit report templates that you created. You
cannot edit predefined report templates.

View Displays the settings for the predefined report template. You can copy elements
from the report template to the clipboard, but you cannot edit a predefined report
template.

Delete Deletes the selected report template. You cannot delete predefined report
templates.

Clone Clones the selected report template.

Create Report Creates the selected report template.

Install Template Pack Upload and install a template pack.

List of report templates

FortiAnalyzer includes report templates you can use as is or build upon when you create a new report. FortiAnalyzer
provide different templates for different devices.

You can find report templates in Reports > Report Definitions > Templates.
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Application report templates

Template - Application Risk and Control
Template - Bandwidth and Applications Report
Template - Cyber-Bullying Indicators Report
Template - Detailed Application Usage and Risk

Template - High Bandwidth Application Usage Report
Template - SaaS Application Usage Report

Assets report templates

Template - Asset and Identity Report

Fabric report templates

Template - Fortinet Email Risk Assessment

Template - FortiPortal User Summary Report

FortiCache report templates

Template - FortiCache Default Report
Template - FortiCache Security Analysis
Template - FortiCache Web Usage Report

FortiClient report templates

Template - FortiClient Default Report

Template - FortiClient Vulnerability Scan Report

FortiDDoS report templates

Template - FortiDDoS Default Report
FortiDeceptor report templates

Template - FortiDeceptor Default Report
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Template - Self-Harm and Risk Indicators Report
Template - Shadow IT Report
Template - Social Media Usage Report

Template - Top 20 Categories and Applications
(Bandwidth)

Template - Top 20 Categories and Applications (Session)

Template - Top Allowed and Blocked with Timestamps
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FortiMail report templates

Template - FortiMail Analysis Report
Template - FortiMail Default Report
Template - FortiMail Summary Report

FortiNAC report templates

Template - FortiNAC Endpoints and Network Report

FortiNDR (formerly FortiAl) report templates

Template - FortiNDR Breach Prevention Report

Template - FortiNDR Network Anomalies Report

FortiProxy report templates

Template - FortiProxy Default Report
Template - FortiProxy Security Analysis
Template - FortiProxy Web Usage Report

FortiSandbox report templates

Template - Endpoint Sandbox Detections Report
Template - FortiSandbox CTAP Report

Template - FortiSandbox Default Report

FortiWeb report templates

Template - FortiWeb Default Report

Template - FortiWeb Web Application Analysis Report

Security report templates

Template - 360-Degree Security Review Template - PCI-DSS Compliance Review
Template - 360 Security Report Template - PCI Security Rating Report
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Template - CIS Security Rating Report

Template - Cyber Threat Assessment

Template - Daily Summary Report

Template - Data Loss Prevention Detailed Report
Template - DNS Security Report

Template - Email Report

Template - FortiClient Default Report from FortiGate

Template - FortiClient Vulnerability Scan Report from
FortiGate

Template - FSBP Security Rating Report
Template - IPS Report

Template - Operational Technology (OT) Security Risk
Report

System report templates

Template - 360 Protection Report
Template - Admin and System Events Report
Template - DNS Report

Template - FortiGate Performance Statistics Report

User report templates

Template - Client Reputation

Template - User Detailed Browsing Log
Template - User Security Analysis

Template - User Top 500 Websites by Bandwidth

Template - User Top 500 Websites by Session

Web report templates

Template - Hourly Website Hits

Template - Top 20 Category and Websites (Bandwidth)
Template - Top 20 Category and Websites (Session)
Template - Top 500 Sessions by Bandwidth
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Template - Security Analysis

Template - Security Events and Incidents Summary

Template - Situation Awareness Report
Template - SOC Incident Report
Template - Threat Report

Template - VPN Report

Template - Web Usage Report

Template - Web Usage Summary Report

Template - What is New Report
Template - WiFi Network Summary

Template - Wireless PCl Compliance

Template - GTP Report
Template - Secure SD-WAN Assessment Report
Template - Secure SD-WAN Report

Template - Throughput Utilization Billing Report

261



Reports

Using the Template - Shadow IT Report

This topic provides an example for creating a report from a template. This topic also provides a brief explanation of the
report used in the example: the Shadow IT Report.

To view a sample of the report:

1. Goto Reports > Report Definitions > Templates.
2. Inthe Searchfield, type Shadow IT Report.
The table will filter and display the Template - Shadow IT Report.

eadmin o

Dashboard All Reports ERCULEICEM Chart Library | Macro Library | Datasets [ m}
&8 Device Manager
a ' etz ] §
+ Create New | [ © View | | i Delete |[ § More v shadow IT
& Foriview , [© View ]
M Log View , @ Titles Langu Description + Category = | Preview + u
@ Fabric View > v  [ETemplate - ShadowITReport ~ en  Presenta brief summary report about cloud-based services. Application  HTML PDF
B Incidents & Events >
|§ Reports v

Generated Reports

Report Definitions
Advanced Settings

£ System Settings >

F:ATINET 1/77

3. Inthe Preview column for the report, click HTML or PDF to view the sample report in that format.
For example, see page 1 of the report in PDF below.

feul v 1of1s — |+ Automaticzoom v s nIZ(»
o = -

8= =

EXECUTIVE SUMMARY Shadow IT Report F::RTINET

Visibilty Data Range: 2022-09-01 00:00:00 2022-09-30 00:00:00PDT (FAZ local)

Cloud Services
Users

Threats EXECUTIVE SUMMARY
Analytics
Data Volume Visibility
DLP Actions
Cloud Services Users

Uploads Detected
VISIBILITY \
Actions Taken

Overall Risk Level:

Categories
@ Managed: 97.99% @ Managed: 99.75%
Risk Level 149 @ Unmansgec: 201% 15K © Unmanaged: 025% © Low

TOP 10 USERS USING
MANAGED CLOUD
APPLICATIONS BY NO. OF

REQUESTS
TOP 10 USERS USING
UNMANAGED CLOUD Threats
APPLICATIONS BY NO. OF
REQUESTS . - .
a A 141 Malwares @ 4 vulnerabilities 0 High Risk Sessions
THREATS
TOP 10 USERS BY THREAT .
SCORE Analytics
Malware Types Data Volume DLP Actions Uploads Detected

Actions Taken
Malware Victims

TOP 10 MALWARE BY NUMBER
OF OCCURRENCES
@ Dovnload: 344178
0 10 MANAGED CLOUD 64TB fiseepanis ® Block: 100% ® App Controk 100%
APPLICATIONS BY RISK

TOP 10 UNIMANAGED CLOUD
APPLICATIONS BY RISK LEVEL

APPLICATION VULNERABILITIES
Vulnerability Risks
Vulnerability Types

Actions Taken

TOP 10 APPLICATION
VULNERABILITIES BY SEVERITY

ANALYTICS page 10f15

The Shadow IT Report provides enhanced visibility and control for cloud based applications.
Detected applications are classified as:

* Managed: Allowed applications.

* Unmanaged: Blocked, quarantined, or reset applications.

Information about the applications, including their Category and Compliance Standard, is provided by the Shadow
IT database (SIDB).

Application risk is determined by a numerical score provided by the SIDB for each application. The Risk Levels in
the report are as follows:
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e Low: Scoreis 110 15.
» Guarded: Scoreis 16 to 30.
e Elevated: Scoreis 31to 50.
e High: Scoreis 51to 70.
e Severe: Scoreis 711to 100.
The Overall Risk Level is the average application risk score for all detected managed applications.

The High Risk Sessions are the number of sessions from managed applications with a risk score of High or
Severe.

To create the report from the template:

Go to Reports > Report Definitions > Templates.
Select the checkbox for Template - Shadow IT Report.
From the More dropdown, click Create Report.

In the Name field, enter a name for the report.

If you did not make any changes, consider naming the report Shadow IT Report. The GUI notifies you ifa
duplicated name already exists.

5. From the Save to Folder dropdown, select a folder for the report.

o bh =

If needed, you can save the report to multiple folders. To create a report folder, see Organizing reports into folders
on page 255

6. Click OK.
The report is now available to be run, as needed, from Reports > Report Definitions > All Reports.

To run the report:

1. Goto Reports > Report Definitions > All Reports, and double-click the row for the Shadow IT Report.
The Edit: Shadow IT Report pane opens.

2. Inthe Generated Reports tab, click Run Report.
3. When the report is available, click the Format to open the report in.

Chart library

Use the Chart library to create, edit, and manage your charts.

In a Security Fabric ADOM, you can insert charts from all device types into a single report.

Creating charts

Al
‘Q' You can also create charts using the Log View Chart Builder. See Creating charts with Chart
- Builder on page 123.
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To create charts:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > Chart Library.

3. Click Create New in the toolbar.

Name
Description
Dataset App-Risk-App-Usage-By-Category

Resolve
Hostname

Inherit

Chart Type Table
Table Type

@® Regular

Data Bindings
Ranked () Drilldown

Columns

Column 1

Title
appcat

Width [0 |3/ %(0for Auto)
Data Binding ~ Format

appcat v Default

Order By
Show Top (O for all results) 10 =

appcat

Jt+w

Column 2

T bandwidin

Width ] = % (0 for Auto)

Data Binding ~ Format

bandwidth - Default

4. Configure the settings for the new chart, the click OK.

Name
Description

Dataset

Resolve Hostname

Chart Type

Data Bindings

Table
Table Type
Add Column

Columns
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Enter a name for the chart.
Enter a description of the chart.

Select a dataset from the dropdown list. For more information, see Datasets
on page 269. Options vary based on device type.

Select to resolve the hostname. Select one of the following: Inherit, Enabled,
or Disabled.

Select a graph type from the dropdown list; one of: Table, Bar, Pie, Line, Area,
Donut, or Radar. This selection affects the rest of the available selections.

The data bindings vary depending on the chart type selected.

Select Regular, Ranked, or Drilldown.

Select to add a column. Up to 15 columns can be added for a Regular table.
Ranked tables have two columns, and Drilldown tables have three columns.

The following column settings must be set:
e Column Title: Enter a title for the column.
e Width: Enter the column width as a percentage.
» Data Binding: Select a value from the dropdown list. The options vary
depending on the selected dataset.
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Order By

Show Top

Drilldown
Top

Bar
X-Axis

Y-axis

Bundle rest
into "Others"

Group By

Order By
Pie, Donut, or Radar

Category
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Format: Select a value from the dropdown list.All formats are available
regardless of the data binding selected for the column. Select a format to
display the data according to your needs.

NP Some formats will only work with select data bindings.
‘Q' For example, the Icon-IP Country/Region format only
- displays the correct flag icon when the Data Binding is
- dstcountry.

Add Data Binding: Add data bindings to the column. Every column must
have at least one data binding. The maximum number varies depending
on the table type.

Select what to order the table by. The available options vary depending on the
selected dataset.

Enter a numerical value. Only the first ‘X’ items are displayed. Other items can
be bundled into the Others category for Ranked and Drilldown tables.

Enter a numerical value. Only the first ‘X’ items are displayed. This options is
only available for Drilldown tables.

Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.

Label: Enter a label for the axis.

Show Top: Enter a numerical value. Only the first X’ items are displayed.
Other items are bundled into the Others category.

Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.

Format: Select a format from the dropdown list: Bandwidth, Counter,
Default, Percentage, or Severity.

Label: Enter a label for the axis.

Select to bundle the rest of the results into an Others category.

Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.

Show Top: Enter a numerical value. Only the first X’ items are displayed.
Other items can be bundled into the Others category.

Select to order by the X-Axis or Y-Axis.

Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.

Label: Enter a label for the axis.

Show Top: Enter a numerical value. Only the first ‘X’ items are displayed.
Other items can be bundled into the Others category.
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Series » Data Binding: Select a value from the dropdown list. The available options

vary depending on the selected dataset.

¢ Format: Select a format from the dropdown list: Bandwidth, Counter,
Default, Percentage, or Severity.

e Label: Enter a label for the axis.

Bundle rest Select to bundle the rest of the results into an Others category.

into "Others™
Line or Area
X-Axis e Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.
* Format: Select a format from the dropdown list: Default, or Time.
e Label: Enter alabel for the axis.
Lines e Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.
e Format: Select a format from the dropdown list: Bandwidth, Counter,
Default, Percentage, or Severity.
e Type: Select the type from the dropdown list: Line Up or Line Down.
e Legend: Enter the legend text for the line.
Add line Select to add more lines.

Managing charts

Manage your charts in Reports > Report Definitions > Chart Library. Some options are available as buttons on the
toolbar. Some options are available in the right-click menu. Right-click a chart to display the menu.

Option Description

Create New Creates a new chart.

Edit Edits a chart. You can edit charts that you created. You cannot edit predefined
charts.

View Displays the settings for the selected predefined chart. You cannot edit a
predefined chart.

Delete Deletes the selected chart. You can delete charts that you create. You cannot

delete predefined charts.

Clone Clones the selected chart.

Import Imports a previously exported FortiAnalyzer chart.
Export Exports one or more FortiAnalyzer charts.

Show Predefined Displays the predefined charts.

Show Custom Displays the custom charts.

Search Lets you search for a chart name.
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Viewing datasets associated with charts

To view datasets associated with charts:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > Chart Library.

Select a chart, and click View in the toolbar.

In the View Chart pane, find the name of the dataset associated with the chart in the Dataset field.
Go to Reports > Report Definitions > Datasets.

In the Search box, type the name of the dataset.

Select the dataset that is found, and click View in the toolbar to view it.

No o bkowobh-=

Macro library

Use the Macro library to create, edit, and manage your macros.

Creating macros

FortiAnalyzer includes a number of predefined macros. You can also create new macros, or clone and edit existing
macros.

Macros are predefined to use specific datasets and queries. They are organized into categories, and can be added to,
removed from, and organized in reports.

To create a new macro:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > Macro Library, and click Create New. The Create Macro pane is displayed.

Create Macro
Name
Description
Dataset App-Risk-App-Usage-By-Category
Query select appcat, sum(coalesce(sentbyte, O dt

and (logflag&1>0) and nullifnalappcat ba
Data Binding
Display Text
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3. Provide the required information for the new macro.

Name Enter a name for the macro.

Description Enter a description of the macro.

Dataset Select a dataset from the dropdown list. The options will vary based on device
type.

Query Displays the query statement for the dataset selected.

Data Binding The data bindings vary depending on the dataset selected. Select a data

binding from the dropdown list.

Display Select a value from the dropdown list.
4. Click OK. The newly created macro is shown in the Macro library.
Managing macros

You can manage macros by Reports > Report Definitions > Macro Library. Some options are available as buttons on the
toolbar. Some options are available in the right-click menu. Right-click a macro to display the menu.

Option Description

Create New Creates a new macro.

Edit Edit the selected macro. You can edit macros that you created.

View Displays the settings for the selected macro. You cannot edit predefined macros.
Delete Deletes the selected macro. You can delete macros that you create. You cannot

delete predefined macros.

Clone Clones the selected macro.

Show Predefined Displays the predefined macros.
Show Custom Displays the custom macros.
Search Lets you search for a macro name.

Viewing datasets associated with macros

To view datasets associated with macros:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > Macro Library.

Select a macro, and click View (for predefined macros) or Edit (for custom macros) in the toolbar.

In the View Macro or Edit Macro pane, find the name of the dataset associated with the macro in the Dataset field.
Go to Reports > Report Definitions> Datasets.

In the Search box, type the name of the dataset.

Double-click the dataset to view it.

No o bkowoh-=

FortiAnalyzer 7.4.0 Administration Guide 268
Fortinet Inc.



Reports

Datasets

Use the Datasets pane to create, edit, and manage your datasets.

Creating datasets

FortiAnalyzer datasets are collections of data from logs for monitored devices. Charts and macros reference datasets.
When you generate a report, the datasets populate the charts and macros to provide data for the report.

FortiAnalyzer has many predefined datasets that you can use right away. You can also create your own custom
datasets. An easy way to build a custom query is to copy and modify a predefined dataset's query.

To create a new dataset:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > Datasets, and click Create New.
3. Inthe Create Dataset pane, provide the required information for the new dataset.

chger:DE A:p:;l:. : Devices © All Devices () Specify .
[ o
Name Enter a name for the dataset.
Log Type Select a log type from the dropdown list. Below is a list of the available log
types based on device.
« FortiGate: Application, Intrusion Prevention, Content , Data Leak
Prevention, DNS, Email Filter, Event, FortiClient System Event,
FortiClient Security Event, FortiClient Traffic, File Filter, GTP,
Vulnerability Scan, Protocol, SSH, SSL, Traffic, Antivirus, VoIP, Web
Application Firewall, Web Filter, Local Event.
e FortiMail: Email Filter, Event, History, and Antivirus.
e FortiAnalyer: Application, Event, and Local Event.
» FortiWeb: Attack , Event, and Traffic.
¢ FortiCache: Application, Intrusion Prevention, Content , Data Leak
Prevention, Email Filter, Event, Vulnerability Scan, Traffic, Antivirus,
VoIP, and Web Filter.
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Query

Validate

Analyze Query

Format

Variables

Test

Time Period

Devices
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« FortiClient: FortiClient System Event, FortiClient Security Event,
FortiClient Traffic.

e Syslog: Syslog.

« FortiManager: Application and Event.

e FortiSandbox: Event, Vulnerability Scan, and Antivirus.

e FortiDDoS: Intrusion Prevention and Event.

¢ FortiAuthenticator: Event.

e FortiProxy: Application, Intrusion Prevention, Data Leak Prevention,
DNS, Email Filter, Event, SSH, Traffic, Antivirus, VolP, and Web Filter.

* FortiNAC: Asset and Event.

* FortiFirewall: DNS, Event, File Filter, GTP, SSH, SSL, and Traffic.

¢ FortiDeceptor: Event.

* FortiSOAR: Event

* FortiADC: Intrusion Prevention, Event, and Traffic.

» FortiNDR (formerly FortiAl): Aftack, Event, and Vulnerability Scan.

e Fabric: Normalized.

Enter the SQL query used for the dataset.

While entering SQL in the query field, automatic suggestions are provided that
offer a list of possible commands, table names, log fields, and more to use in
your query.

Click Validate to validate the entered SQL query. If any errors are present in
the query, the details of the error are displayed below, otherwise the message
will display OK.

Click Analyze Query to perform a detailed analysis on the SQL query. Analyze
Query displays the original SQL query, the transformed SQL query (if
applicable), and the SQL validation results.

This function also allows users to view the hcache query that is used when a
report using this dataset has enabled the auto-cache option for faster report
generation. For more information on hcache, see How auto-cache works on
page 240

Click Format to automatically format the entered SQL query, making it easier
to read, update, and detect errors.

Click the Add button to add variable, expression, and description information.
If added, the expression for the variable will be used when configuring filters
for reports that use this dataset. For example, if Variable = User (user) and
Expression = coalesce(nullifna("user’), ipstr('srcip’)), then the expression will
be used when User (user) is selected as the Log Field in a report's filter. See
Filtering report output on page 253.

Click to test the SQL query before saving the dataset configuration.
Click Stop to end a test in progress.

Use the dropdown list to select a time period. When selecting Custom, enter
the start date and time, and the end date and time.

Select All Devices or Specify to select specific devices to run the SQL query
against. Click the Select Device button to add multiple devices to the query.
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4. Click Test.
The query results are displayed.
5. Click OK.

If the query is not successful, an error message appears in the Test Result pane.

Viewing the SQL query of an existing dataset

You can view the SQL query for a dataset, and test the query against specific devices or all devices.

To view the SQL query for an existing dataset:

1. Ifusing ADOMSs, ensure that you

are in the correct ADOM.

2. Goto Reports > Report Definitions > Datasets.

3. Hover the mouse cursor over the
You can also open the dataset to

dataset on the dataset list. The SQL query is displayed as a tooltip.
view the Query field.

It should not be used to test returned values as those may be different than the

ﬂ The SQL dataset test function can be used to determine if any errors are present in the
I SQL format.

ones used in reports.

SQL query functions

In addition to standard SQL queries, the following are some SQL functions specific to FortiAnalyzer. These are based on

standard SQL functions.

root_domain(hostname)

nullifna (expression)

email domain
email user

from dtime
from itime

FortiAnalyzer 7.4.0 Administration Guide
Fortinet Inc.

The root domain of the FQDN. An example of using this function is:

select devid, root domain (hostname) as website FROM $log
WHERE 'user'='USERO1' GROUP BY devid, hostname ORDER BY
hostname LIMIT 7

This is the inverse operation of coalesce that you can use tofilterout n/a
values. This function takes an expression as an argument. The actual SQL syntax
thisisbaseonis select nullif (nullif (expression, 'N/A'),

'n/a').

In the following example, if the user is n/a, the source IP is returned, otherwise the
username is returned.

select coalesce(nullifna('user'), nullifna('srcip')) as user_
src, coalesce(nullifna(root domain (hostname)), 'unknown')
as domain FROM $log WHERE dstport='80' GROUP BY user src,
domain ORDER BY user src LIMIT 7

email domain returns the text after the @ symbol in an email address. email

user returns the text before the @ symbol in an email address. An example of

using this function is:

select 'from' as source, email user('from') as e user, email
domain ('from') as e domain FROM $log LIMIT 5 OFFSET 10

from dtime (bigint) returns the device timestamp without time zone. from
itime (bigint) returns FortiAnalyzer’s timestamp without time zone. An
example of using this function is:
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select itime, from itime(itime) as faz local time, dtime,
from dtime (dtime) as dev local time FROM $log LIMIT 3

get_devtype () Returns the source device type. An example of using this function is:
select get devtype (srcswversion, osname, devtype) as devtype
new, coalesce(nullifna( srcname’),nullifna( srcmac),
ipstr('srcip’)) as dev _src, sum(crscore%$65536) as scores
from $log where $filter and (logflag&l>0) and crscore is
not null group by devtype new, dev src having sum
(crscore%65536)>0 order by scores desc

This function may return null values. To replace null values with "Unknown", you

can add the following outer query:

select coalesce(nullifna( devtype new' ), 'Unknown') as
devtype newl,dev src, scores

from ### (select get devtype(srcswversion, osname, devtype) as
devtype new, coalesce(nullifna( srcname’),nullifna
(*srcmac’), ipstr('srcip’)) as dev_src, sum
(crscore%65536) as scores from $log where $filter and
(logflag&l>0) and crscore is not null group by devtype
new, dev src having sum(crscore%65536)>0 order by scores
desc ) ### t

Managing datasets

You can manage datasets by going to Reports > Report Definitions > Datasets. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click a dataset to display the menu.

Option Description

Create New Creates a new dataset.

Edit Edit the selected dataset. You can edit datasets that you created.

View Displays the settings for the selected dataset. You cannot edit predefined
datasets.

Delete Deletes the selected dataset. You can delete datasets that you create. You

cannot delete predefined datasets.

Clone Clones the selected dataset. You can edit cloned datasets.
Validate Validate selected datasets.

Validate All Custom Validates all custom datasets.

Search Lets you search for a dataset name.

Aliases and metadata tables

Aliases in predefined datasets

Some predefined FortiAnalyzer datasets make use of aliases which are labeled as t 1, t2, etc. These temporary names
can only be referenced within the dataset in which they are created.
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As an example, the t1 and t2 aliases are used in the threat-Top-Intrusions-By-Types dataset to define the following

tables:

o t1:Intrusion Prevention log data.
o t2: The name, CVE, and vuin_type from the IPS_mdata table.

View Dataset

Name threat-Top-Intrusions-By-Types Go

Log Type Intrusion Prevention

Query 1 SELECT Devices

2 wuln_type,
3 count(*) AS totalnum

5 _slog t1
6 LEFT JOIN
SELECT
NAME,
9 cve,
10 vuln_type
11 FROM
12 ips_mdata
13 t2 ON tl.attack = t2.name
14 WHERE
15 $filter
16 AND vuln_type IS NOT NULL
17 GROUP BY
18  wuln_type
19 ORDER BY
2@ totalnum DESC

o ~

Validate Analyze Query Format

Variables Variable Expression  Description

Click here to add new entry.

Metadata tables

FortiAnalyzer has access to metadata tables which are used in some predefined datasets to enrich a chart's data by
complementing log fields with information from FortiGuard. This is typically accomplished through the use of the

SQL JOIN clause.

As an example, in the threat-Top-Intrusions-By-Type dataset, the ijps_mdata metadata table is referenced. The ips_
mdata table is a collection of intrusion prevention related metadata from FortiGuard that is used by this dataset to add
information about vulnerability types, vulnerability names, and CVE data to intrusion prevention logs.
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View Dataset

Name threat-Top-Intrusions-By-Types
Log Type Intrusion Prevention

Query 1 SELECT
2 vuln_type,
3 count(®*) AS totalnum
4 EROM

5 _%$log t1

6 LEFT JOIN (

7 SELECT

8 NAME,

] cve,

18 vuln_type

11 FROM

12 ips_mdata

13 ) t2 ON tl.attack = t2.name

14 WHERE

15 $filter

16  AND vuln_type IS NOT NULL

17 GROUP BY

18  wvuln_type

19 ORDER BY

28  totalnum DESC

Validate Analyze Query Format

Variables Variable Expression

Click here to add new entry.

Go

Time Period

Devices

Previous 7 Days
@Al Devices v

You can view the information contained in the metadata tables (as well as other tables) using the following custom

dataset. An asterisk can be used to select all applicable fields.

select <field> from <table name>

For example, the custom dataset below displays all fields retrieved from the IPS metadata table.

Create Dataset

Name
Log Type Application
Query 1 select * from ips_mdata
WValidate Analyze Query Format
Variables Variable Expression

Click here to add new entry.
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Time Period

Devices

id

10001

10002

10005

10007

10011

10016

10018

10020

10029

10041

10052

10072

10080

10091

Previous 7 Days

Al Devices ~
name
SafeNet.Sentinel.License.Manager.Buffer.Overflow
CA BrightStor. ARCserve.UniversalAgent.Buffer.Overflow
MBS.IE.Valid.File.DragDrop.Code.Embedded
MS.Windows.HTML.Help.Control.CrossZone.Scripting

LHA Filename.Buffer.Overflow

MySQL.Create.Function.Privilege.Elevation

Oracle?i.XDB.FTP.Unlock.Overflow
MS.RPC.LLSSRV.Buffer.Overflow

IMAP.LOGIN.Command.Buffer.Overflow

ISC.DHCPD.Hostname.Buffer.Overflow
Squid.NTLM.Authentication.Buffer.Overflow
Samba.NTTrans.Fragment.Buffer.Overflow
IBM.WebSphere.AS.Console.Buffer.Overflow

MS.Word.Malformed. Document Integer.Buffer.Overflow

group
applications
applications
web_client
web_server

misc

database

file_transfer
netbios

email

operating_system
web_app

netbios
web_server

applications
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Metadata tables from FortiGuard are also available to be used in custom dataset queries. The following metadata tables

are available:

Output profiles

Output profiles allow you to define email addresses to which generated reports are sent and provide an option to upload

ips_mdata
app_mdata
fct_mdata
pci_dss_mdata

td_threat_name_mdata

the reports to FTP, SFTP, or SCP servers. Once created, an output profile can be specified for a report.

Creating output profiles

You must configure a mail server before you can configure an output profile. See Mail Server
on page 331.

To create output profiles:

If using ADOMs, ensure that you are in the correct ADOM.
Go to Reports > Advanced Settings > Output Profile.
Click Create New. The Create Output Profile pane is displayed.

Create Output Profile

Name
Comments
Output Format

Email Generated Reports
Subject

Body

Recipients

Upload Report to Server
Server Type

Server
User
Password

Directory

O Delete file(s) after uploading

O HTML EPDF [ XML [J CSV [ JSON

0/1023
Email Server From To
Click here to add new entry.

FTP v

0.0.00
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4. Provide the following information, and click OK:

Name
Comments

Output Format

Email Generated Reports
Subject
Body

Recipients

Upload Report to Server
Server Type
Server
User
Password
Directory

Delete file(s) after
uploading

Managing output profiles

You can manage output profiles by going to Reports > Advanced Settings > Output Profile. Some options are available
as buttons on the toolbar. Some options are available in the right-click menu. Right-click an output profile to display the

menu.

Enter a name for the new output profile.
Enter a comment about the output profile (optional).

Select the format or formats for the generated report. You can choose HTML,
PDF, XML, CSV, or JSON format.

Enable emailing of generated reports.
Enter a subject for the report email.
Enter body text for the report email.

Select the email server from the dropdown list and enter to and from email
addresses. Click Add to add another entry so that you can specify multiple
recipients.

Enable uploading of generated reports to a server.
Select FTP, SFTP, or SCP from the dropdown list.
Enter the server IP address.

Enter the username.

Enter the password.

Specify the directory where the report will be saved.

Select to delete the generated report after it has been uploaded to the selected

server.

Description

Create New
Edit

Delete

Report languages

Creates a new output profile.
Edits the selected output profile.

Deletes the selected output profile.

The languages available for reports can be found in Reports > Advanced Settings > Language. In this pane, you can
export and import language files to be used in reports. If a custom language file is no longer needed, it can be deleted

from this pane.
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You can specify the language when creating a report. Select the language from the Language dropdown in the Report

Settings tab. For more information, see Reports Settings tab on page 247.

This topic includes:

« Exporting and modifying a language on page 277
« Importing a language on page 277
¢ Deleting a language on page 278

Exporting and modifying a language

You can export a language file to modify the language or text.

Once the exported language file is modified, it can be imported to override a system language or to add a custom
language.

To export and modify a language:

ok oN-=

Go to Reports > Advanced Settings > Language.

Select the checkbox for a language to export.

From the More dropdown, click Export.

Extract the zip file and use a text editor to modify it.

Change the text after the equal sign (=) to a different language or text.

Forexample, rpt name=[text to be changed]. Do notchange texton the left-side of the equal sign.
Save and zip the modified file.

You can change the title of the language file, or you can leave the title unchanged. You will select the language
name when importing the modified file.

There should only be one language file in the zipped folder.

The language file is ready to be imported into FortiAnalyzer.

Importing a language

After exporting and modifying a language file, you can import it to use in reports.

You can override a system language with the import, or you can import a custom language.

To import a language file:

1.
2,

5.

Go to Reports > Advanced Settings > Language.

From the More dropdown, click Import.

The Import Language pane displays.

In the Language File field, drag and drop or select the zip file.
Select a Language Name from the dropdown.

You can select a system language to override it.

Click OK.

The language is now available in the table view. The Date Imported column indicates when the language file was
imported, and the Status column indicates thatitis User defined.
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The language can now be used in reports. To use this imported language, select it from the Language dropdown in the
Report Settings tab. See Reports Settings tab on page 247.

s‘ ! ', If the import was to override a system language, such as English, the Status column
q changes from Systemto User defined. You can delete this row to restore the original
3 system language. See Deleting a language on page 278.

Deleting a language

You can delete custom languages that have been imported in Reports > Advanced Settings > Language.

You cannot delete system languages unless they have been overridden by an import. Deleting the overridden language
will restore the original system language. For example, if you imported a language file with modified text to override
English, you can delete it to restore the system English language.

To delete a language:

1. Goto Reports > Advanced Settings > Language.
2. Select the checkbox for a language to delete.
3. Click Delete.

If you delete custom language, it is no longer available in the table view.

If you delete an overridden system language, the Status column changes from User definedto System. The original
system language is restored.
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Report calendar

You can use the report calendar to view all the reports that are scheduled for the selected month. You can edit or disable
upcoming report schedules, as well as delete or download completed reports.

Viewing all scheduled reports

To view all scheduled reports:

1. If using ADOMSs, ensure that you are in the correct ADOM.

2. Goto Reports > Advanced Settings > Report Calendar.
< >  today June 2018

w Sun Mon Tue Wed Thu Fri Sat
22 1 2
{(£/3:00 AM Admin and System Eveni] () 3:00 AM Admin and System Event]

23 3 4 5 6 7 8 9
(D3:00 AM Adrmin and System Event] (= 3:00 AM Admin and System Event) () 3:00 AM Admin and System Event) (21 12:00 AM Security Analysis ) (51200 AM Bandwidth and Applica) (0 3:00 AM Admin and System Event) (= 3:00 AM Admin and System Event)
(1 12:00 AM Top 20 Categories and ) (5 3:00 AM Admin and System Evend)
(£/12:00 AM VPN Report
(100 AMVieb Usage Report)

+2 mare

24 10 1 12 13 14 15 16
(5300 AM Admin and System Event] () 3:00 AM Admin and System Event ((©) 3:00 AM Admin and System Event] (5] 12:00 AM Security Analysis ) (5 12:00 AM Bandwidth and Applica) (5 3:00 AM Admin and System Event (Z) 3:00 AM Admin and System Event)
((5/12:00 AM Top 20 Categories and ) (© 3:00 AM Admin and System Event|
((*)12:00 AM VPN Report
1200 A et Usage port_|
+2 more
25 17 18 19 20 21 22 23
(D3:00 AM Admin and System Event] (5 3:00 AM Admin and System Event) (0 3:00 AM Admin and System Event) (Z112:00 AM Security Analysis ) (01200 AM Bandwidth and Applica) (0 3:00 AM Admin and System Event) () 3:00AM Admin and System Event)
((Z)12:00 AM Top 20 Categories and ) () 3:00 AM Admin and System Event,
(£/12:00 AM VPN Report
(£/12:00 AM Web Usage Report |
+2 more
26 24 25 26 27 28 29 30
(5300 AM Admin and System Event] () 3:00 AM Admin and System Event ((©) 3:00 AM Admin and System Event] (5] 12:00 AM Security Analysis ) (5 12:00 AM Bandwidth and Applica) (5 3:00 AM Admin and System Event (Z) 3:00 AM Admin and System Event)
((5/12:00 AM Top 20 Categories and ) (© 3:00 AM Admin and System Event)
((/12:00 AM VPN Report
((212:00 AM Web Usage Report__|

+2 more

Hover the mouse cursor over a calendar entry to display the name, status, and device type of the scheduled report.
Click a generated report to download it.
Click a scheduled report to go to the Settings tab of the report.

Click the left or right arrow at the top of the Report Calendar pane to change the month that is displayed. Click Today
to return to the current month.

o g kv

Managing report schedules
You can manage report schedules in Reports > Advanced Settings > Report Calendar.

To edit a report schedule:

1. In Report Calendar, right-click an upcoming calendar entry, and select Edit.
2. Inthe Settings tab of the report that opens, edit the corresponding report schedule.
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To disable a report schedule:

In Report Calendar, right-click an upcoming calendar entry, and select Disable. All scheduled instances of the report are
removed from the report calendar. Completed reports remain in the report calendar.

To delete or download a completed report:

In Report Calendar, right-click a past calendar entry, and select Delete or Download. The corresponding completed
report will be deleted or downloaded.

Al
‘Q' You can only delete or download scheduled reports that have a Finished status. You cannot
- delete scheduled reports with a Pending status.
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System Settings allows you to manage system options for your FortiAnalyzer device.

click the mouse on different navigation panes on the GUI page to access these options.

x Additional configuration options and short-cuts are available using the right-click menu. Right-

This section contains the following topics:

« Logging Topology on page 281

o Network on page 282

+ RAID Management on page 296

o Administrative Domains (ADOMs) on page 302
 Certificates on page 310

o Log Forwarding on page 315

o Log Fetching on page 322

« EventLogon page 327

o Task Monitor on page 329

« Mail Server on page 331

o Syslog Server on page 332

o Meta Fields on page 334

« Device logs on page 335

» File Management on page 339

» Miscellaneous Settings on page 340

Logging Topology

The System Settings > Advanced > Logging Topology pane shows the physical topology of devices in the Security
Fabric. Click, hold, and drag to adjust the view in the content pane, and double-click or use the scroll wheel to change the
zoom.

The visualization can be filtered to show only FortiAnalyzer devices or all devices by device count or traffic.
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Hovering the cursor over a device in the visualization will show information about the device, such as the IP address and
device name. Right-click on a device and select View Related Logs to go to the Log View pane, filtered for that device.

@ FMG-VMé4

E"(é FAZVMé&4-Collector2

FAZVMS542

Network

The network settings are used to configure ports for the FortiAnalyzer unit. You should also specify what port and
methods that an administrators can use to access the FortiAnalyzer unit. If required, static routes can be configured.

The default port for FortiAnalyzer units is port 1. It can be used to configure one IP address for the FortiAnalyzer unit, or
multiple ports can be configured with multiple IP addresses for improved security.

You can configure administrative access in IPv4 or IPv6 and include settings for HTTPS, HTTP, PING, SSH, SNMP,
Web Service, and FortiManager.

Ay
b ] L4
9 FortiAnalyzer supports SSHv2.

You can prevent unauthorized access to the GUI by creating administrator accounts with trusted hosts. With trusted
hosts configured, the administrator can only log in to the GUI when working on a computer with the trusted host as
defined in the administrator account. For more information, see Trusted hosts on page 346 and Managing administrator
accounts on page 347.

Configuring network interfaces

Fortinet devices can be connected to any of the FortiAnalyzer unit's interfaces. The DNS servers must be on the
networks to which the FortiAnalyzer unit connects, and should have two different IP addresses.
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The following port configuration is recommended:

o Use port 1 for device log traffic, and disable unneeded services on it, such as SSH, Web Service, and so on.

« Use a second port for administrator access, and enable HTTPS, Web Service, and SSH for this port. Leave other
services disabled.

To configure port 1:

1. Go to System Settings > Network.The Interface pane is displayed at the top of the page.

Network

Interface

[m} Name * Type Members/Interface IP/Netmask IPv6 Address Enable u

a portl Physical Interface 10.100.55.2/255.255.255.0 0 o

a port2 Physical Interface 10.100.88.2/255.255.255.0 0 o

a port3 Physical Interface 0.0.0.0/0.0.0.0 0 o

a port4 Physical Interface 0.0.0.0/0.0.0.0 0 o

a port5 Physical Interface 0.0.0.0/0.0.0.0 0 o

a porté Physical Interface 0.0.0.0/0.0.0.0 0 o

a port7 Physical Interface 0.0.0.0/0.0.0.0 0 o

a port8 Physical Interface 0.0.0.0/0.0.0.0 0 o

a port9 Physical Interface 0.0.0.0/0.0.0.0 0 o

0% 12
DNS
Primary DNS Server 8.8.8.8
Secondary DNS Server 208.91.112.53
[ o

2. Inthe Interface pane, double-click Port1. The Edit System Interface pane is displayed.

Edit Network Interface x

Name port1

Alias

1P Address/Netmask 10.100.55.2/255.255.255.0

IPV6 Address 0

Administrative Access HTTPS [ HTTP PING ssH O SNMP [ Web [ FortiManager
1Pv6 Administrative Access (] HTTPS [ HTTP [JPING [ ssH O SNMP [ Web [ FortiManager
Status ©

[ o |
3. Configure the following settings for port1, then click OK to apply your changes.

Name Displays the name of the interface.

IP Address/Netmask The IP address and netmask associated with this interface.

IPv6 Address The IPv6 address associated with this interface.

Administrative Access Select the allowed administrative service protocols from: HTTPS, HTTP,

PING, SSH, SNMP, Web Service, and FortiManager.

IPv6 Administrative Access Select the allowed IPv6 administrative service protocols from: HTTPS, HTTP,
PING, SSH, SNMP, Web Service, and FortiManager.

Status Select Enable or Disable.

4. Configure the DNS settings, and click Apply.

Primary DNS Server The primary DNS server IP address.
Secondary DNS Server The secondary DNS server IP address.
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To configure additional ports:

1.
2,

Go to System Settings > Network. The Interface pane is displayed at the top of the page.

In the Interface pane, double-click on a port, right-click on a port then select Edit from the pop-up menu, or select a
port then click Edit in the toolbar. The Edit System Interface pane is displayed.

Configure the settings as required.
Click OK to apply your changes.

vy
‘?' The port name, default gateway, and DNS servers cannot be changed from the Edit System
- Interface pane. The port can be given an alias if needed.

Disabling ports

Ports can be disabled to prevent them from accepting network traffic

To disable a port:

1.
2,

Go to System Settings > Network. The Interface list is displayed.

Double-click on a port, right-click on a port then select Edit from the pop-up menu, or select a port then click Edit in
the toolbar. The Edit System Interface pane is displayed.

In the Status field, click Disable
Click OK to disable the port.

Changing administrative access

Administrative access defines the protocols that can be used to connect to the FortiAnalyzer through an interface. The
available options are: HTTPS, HTTP, PING, SSH, SNMP, Web Service, and FortiManager.

To change administrative access:

1.
2,

Go to System Settings > Network and click All Interfaces. The interface list opens.

Double-click on a port, right-click on a port then select Edit from the pop-up menu, or select a port then click Editin
the toolbar. The Edit System Interface pane is displayed.

Select one or more access protocols for the interface for Administrative Access and IPv6 Administrator Access, as
required.

Click OK to apply your changes.

Static routes

Static routes can be managed from the routing tables for IPv4 and IPv6 routes. The routing tables can be accessed by
going to System Settings > Network.
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To add a static route:

1. From the network routing table, click Create New in the toolbar. The Create New Network Route pane opens.
2. Selectthe IP Type as either IPv4 or IPv6.

3. Enter the destination IP address and netmask, or IPv6 prefix, and gateway in the requisite fields.

4

Select the network interface that connects to the gateway from the dropdown list. Ports, aggregate links, and VLANs
are available.

Click OK to create the new static route.

o

To edit a static route:

1. From the network routing table: double-click on a route, right-click on a route then select Edit from the pop-up menu,
or select a route then click Edit in the toolbar. The Edit Network Route pane opens.

2. Edit the configuration as required. The route ID cannot be changed.
3. Click OK to apply your changes.

To delete a static route or routes:

1. From the newtork routing table, right-click on a route then select Delete from the pop-up menu, or select a route or
routes then click Delete in the toolbar.

2. Click OKin the confirmation dialog box to delete the selected route or routes.

Packet capture

Packets can be captured on configured interfaces by going to System > Network > Packet Capture.

The following information is available:

Interface The name of the configured interface for which packets can be captured.
For information on configuring an interface, see Configuring network interfaces on
page 282.

Filter Criteria The values used to filter the packet.

# Packets The number of packets.

Maximum Packet Count The maximum number of packets that can be captured on a sniffer.

Progress The status of the packet capture process.

Actions Allows you to start and stop the capturing process, and download the most

recently captured packets.

To start capturing packets on an interface, select the Start capturing button in the Actions column for that interface. The
Progress column changes to Running, and the Stop capturing and Download buttons become available in the Actions
column.
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To add a packet sniffer:

1. From the Packet Capture table, click Create New in the toolbar. The Create New Sniffer pane opens.
2. Configure the following options:

Interface The interface name (non-changeable).

Max. Packets to Save Enter the maximum number of packets to capture, between 1-10000. The
default is 4000 packets.

Include IPv6 Packets Select to include IPv6 packets when capturing packets.

Include Non-IP Packets Select to include non-IP packets when capturing packets.

Enable Filters You can filter the packet by Host(s), Port(s), VLAN(s), and Protocol.
3. Click OK.

To download captured packets:

1. Inthe Actions column, click the Download button for the interface whose captured packets you want to download.
If no packets have been captured for that interface, click the Start capturing button.

2. When prompted, save the packet file (sniffer_[interface].pcap) to your management computer.
The file can then be opened using packet analyzer software.

To edit a packet sniffer:

1. From the Packet Capture table, click Edit in the toolbar. The Edit Sniffer pane opens.
2. Configure the packet sniffer options
3. Click OK.

Aggregate links

Link aggregation enables you to bind two or more physical interfaces together to form an aggregated (combined) link.
This new link has the bandwidth of all the links combined. If a link in the group fails, traffic is transferred automatically to
the remaining interfaces.

To configure aggregate links:

Go to System Settings > Network.

In the Interface toolbar, click Create New. The Create New Interface page is displayed.
In the Name field, enter a name for the interface.

In the Type field, select Aggregate.

In the Members field, select the ports you want to include in the aggregate.

In the IP Addess/Netmask field, enter the IP address for the aggregate link.

In the Administrative Access field, select the access protocol.

In the IPv6 Administrative Access area, select the access protocol.

Setthe LACP Speed to Slow or Fast.

© ®No b ON-=

FortiAnalyzer 7.4.0 Administration Guide 286
Fortinet Inc.



System Settings

10. Inthe Minimum Links Up field, enter the number of aggregated ports that must be up.

A\,

b [ 4
? You must enter a minimum value of 2 for the aggregate links to work.

11. Set Minimum Links Down to Operational or Administrative.

12. Inthe Links up Delay, set the number of milliseconds to wait before considering the link is up.
13. Click OK.

After the aggregate links are configured, log into FortiGate and go to Network > Interfaces, and configure an aggregation
interface. For information, see Aggregation and redundancy in the FortiOS Administration Guide.

To enable the interface with the GUI:

1. Go to System Settings > Network.

2. Inthe Interface pane, double-click the aggregate interface to edit it. The Edit System Interface window opens.
3. Setthe Statusto Enable.

To enable the interface with the CLI:

# config system interface
(interface) # edit Aggregationl
(Aggregationl) # set status up
(Aggregationl) # end

VLAN interfaces

You can configure a VLAN interface in FortiAnalyzer by going to System Settings > Network.

To configure a VLAN interface:

1. Go to System Settings > Network.
2. Inthe Interface toolbar, click Create New. The Create New Network Interface page is displayed.
3. Inthe Name field, enter a name for the VLAN.
4. Inthe Typefield, select VLAN.
5. Inthe VLAN IDfield, enter a VLAN ID. You can use a range between 1 and 4094.
6. Inthe Interface field, select the interface to which the VLAN will be bound.
7. Inthe Protocol field, select either IEEE 802.1Q. or IEEE 802.1AD.
8. Inthe IP Address/Netmask field, enter the IP address for the VLAN.
9. Optionally, add an IPv6 Address.
10. Inthe Administrative Access field, select the access protocol.
11. Optionally, configure the IPv6 Administrative Access.
12. Inthe Service Access field, select which services can be accessed in this VLAN.
13. Inthe Statusfield, select the VLAN status.
14. Click OK.
15. Ifrequired, you can create a static route with the VLAN interface. See Static routes on page 284.
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SNMP

Enable the SNMP agent on the FortiAnalyzer device so it can send traps to and receive queries from the computer that is
designated as its SNMP manager. This allows for monitoring the FortiAnalyzer with an SNMP manager.

SNMP has two parts - the SNMP agent that is sending traps, and the SNMP manager that monitors those traps. The
SNMP communities on monitored FortiGate devices are hard coded and configured by the FortiAnalyzer system - they
are not user configurable.

The FortiAnalyzer SNMP implementation is read-only — SNMP v1, v2c, and v3 compliant SNMP manager applications,
such as those on your local computer, have read-only access to FortiAnalyzer system information and can receive
FortiAnalyzer system traps.

SNMP agent

The SNMP agent sends SNMP traps originating on the FortiAnalyzer system to an external monitoring SNMP manager
defined in a SNMP community. Typically an SNMP manager is an application on a local computer that can read the
SNMP traps and generate reports or graphs from them.

The SNMP manager can monitor the FortiAnalyzer system to determine if it is operating properly, or if there are any
critical events occurring. The description, location, and contact information for this FortiAnalyzer system will be part of
the information an SNMP manager will have — this information is useful if the SNMP manager is monitoring many
devices, and it will enable faster responses when the FortiAnalyzer system requires attention.

Go to System Settings > Network and scroll to the SNMP section to configure the SNMP agent.

Network

SNMP

SNMP Agent 1 O
Description
Location
Contact
SNMP vi/v2c
O  Community Name Queries Traps Enable E
O solara [] [} <
O  Terminus [] [] v
O  Trantor [] [] v
3)
SNMP v3
O  User Name ¢ Security Level Notification Hosts Queries E
] Bliss No Authentication, No Privacy @
O Daneel Authentication, No Privacy @
O Fallom Authentication, Privacy @
O Golan No Authentication, Mo Privacy @
The following information and options are available:
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SNMP Agent

Description

Location

Contact

SNMP v1/2c

SNMP v3

SNMP v1/v2c communities

Create New

Edit
Delete
Community Name

Queries

Traps

Enable

Create New

Edit

Delete

User Name
Security Level
Notification Hosts

Queries

Select to enable the SNMP agent. When this is enabled, it sends FortiAnalyzer
SNMP traps.

Optionally, type a description of this FortiAnalyzer system to help uniquely identify
this unit.

Optionally, type the location of this FortiAnalyzer system to help find it in the event
it requires attention.

Optionally, type the contact information for the person in charge of this
FortiAnalyzer system.

The list of SNMP v1/v2c communities added to the FortiAnalyzer configuration.

Select Create New to add a new SNMP community. If SNMP agent is not
selected, this control will not be visible.

For more information, see SNMP v1/v2c communities on page 289.
Edit the selected SNMP community.

Delete the selected SNMP community or communities.

The name of the SNMP community.

The status of SNMP queries for each SNMP community. The enabled icon
indicates that at least one query is enabled. The disabled icon indicates that all
queries are disabled.

The status of SNMP traps for each SNMP community. The enabled icon indicates
that at least one trap is enabled. The disabled icon indicates that all traps are
disabled.

Enable or disable the SNMP community.
The list of SNMPv3 users added to the configuration.

Select Create New to add a new SNMP user. If SNMP agent is not selected, this
control will not be visible.

For more information, see SNMP v3 users on page 292.
Edit the selected SNMP user.

Delete the selected SNMP user or users.

The user name for the SNMPv3 user.

The security level assigned to the SNMPv3 user.

The notification host or hosts assigned to the SNMPv3 user.

The status of SNMP queries for each SNMP user. The enabled icon indicates
queries are enabled. The disabled icon indicates they are disabled.

An SNMP community is a grouping of equipment for network administration purposes. You must configure your
FortiAnalyzer to belong to at least one SNMP community so that community’s SNMP managers can query the
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FortiAnalyzer system information and receive SNMP traps from it.

A\,

‘?' These SNMP communities do not refer to the FortiGate devices the FortiAnalyzer system is

managing.

Each community can have a different configuration for SNMP traps and can be configured to monitor different events.
You can add the IP addresses of up to eight hosts to each community. Hosts can receive SNMP device traps and

information.

To create a new SNMP community:

1. Go to System Settings > Network.
2. Inthe SNMP section, ensure the SNMP agent is enabled.
3. Inthe SNMP v1/v2c section, click Create New in the toolbar. The New SNMP Community pane opens.

New SNMP Communif ity

x

Please input the SNMP Community Name.

1Pv4 Hosts 1P Address/Netmask Interface Action

0.0.0.0/0.0.0.0 ANY v %+

vi ©Port | 161
vac ©Port | 161
Trap
vi ©pot | 162
vac ©pot | 162
SNMP Events
CPU Overuse
High licensed device quota
Interface IP changed
Log Data Rate
Log Rate
System Restart
o e

CPU usage exclude NICE threshold

High Licensed Log GB/day
Log Alert

Log Disk Space Low
Memory Low

4. Configure the following options, then click OK to create the community.

Name

Hosts

IP
Address/Netmask

FortiAnalyzer 7.4.0 Administration Guide
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Enter a name to identify the SNMP community. This name cannot be edited
later.

The list of hosts that can use the settings in this SNMP community to monitor
the FortiAnalyzer system.

When you create a new SNMP community, there are no host entries. Select
Add to create a new entry that broadcasts the SNMP traps and information to
the network connected to the specified interface.

Enter the IP address and netmask of an SNMP manager.

By default, the IP address is 0.0.0.0 so that any SNMP manager can use this
SNMP community.
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Interface
Delete
Add

Queries

Traps

SNMP Event

To edit an SNMP community:

1. Go to System Settings > Network.

Select the interface that connects to the network where this SNMP manager
is located from the dropdown list. This must be done if the SNMP manager is
on the Internet or behind a router.

Click the delete icon to remove this SNMP manager entry.

Select to add another entry to the Hosts list. Up to eight SNMP manager
entries can be added for a single community.

Enter the port number (161 by default) the FortiAnalyzer system uses to send
v1 and v2c queries to the FortiAnalyzer in this community. Enable queries for
each SNMP version that the FortiAnalyzer system uses.

Enter the Remote port number (162 by default) the FortiAnalyzer system
uses to send v1 and v2c traps to the FortiAnalyzer in this community. Enable
traps for each SNMP version that the FortiAnalyzer system uses.

Enable the events that will cause SNMP traps to be sent to the community.
* Interface IP changed
e Log disk space low
e CPU Overuse
* Memory Low
e System Restart
e CPU usage exclude NICE threshold
e RAID Event (only available for devices that support RAID)
» Power Supply Failed (only available on supported hardware devices)
e Fan Speed Out of Range
e Temperature Out of Range
e Voltage Out of Range
* High licensed device quota
e High licensed log GB/day
* LogAlert
e Log Rate
» Data Rate

2. Inthe SNMP v1/v2c section, double-click on a community, right-click on a community then select Edit, or select a
community then click Edit in the toolbar. The Edit SNMP Community pane opens.

3. Edit the settings as required, then click OK to apply your changes.

To delete an SNMP community or communities:

o bd-=
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Go to System Settings > Network.
In the SNMP v1/v2c section, select the community or communities you need to delete.
Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected community or communities.
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SNMP v3 users

The FortiAnalyzer SNMP v3 implementation includes support for queries, traps, authentication, and privacy. SNMP v3
users can be created, edited, and deleted as required.

To create a new SNMP user:

1. Go to System Settings > Network.
2. Inthe SNMP section, ensure the SNMP agent is enabled.
3. Inthe SNMP v3 section, click Create New in the toolbar. The New SNMP User pane opens.

New SNMP User x

Please input the SNMP User Name
User Name No Authentication, No Privacy -

Notification Hosts 0000 x| +

CPU Overuse CPU usage exclude NICE threshold
High licensed device quota High Licensed Log GB/day
Interface IP changed Log Alert

Log Data Rate Log Disk Space Low

Log Rate Memory Low

System Restart

4. Configure the following options, then click OK to create the community.

User Name The name of the SNMP v3 user.

Security Level The security level of the user. Select one of the following:
* No Authentication, No Privacy
¢ Authentication, No Privacy: Select the Authentication Algorithm (SHA1,
MD5) and enter the password.
* Authentication, Privacy: Select the Authentication Algorithm (SHA1,
MD5), the Private Algorithm (AES, DES), and enter the passwords.

Queries Select to enable queries then enter the port number. The default port is 161.
Notification Hosts The IP address or addresses of the host. Click the add icon to add multiple IP
addresses.
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SNMP Event Enable the events that will cause SNMP traps to be sent to the SNMP
manager.

¢ Interface IP changed
e Log disk space low
e CPU Overuse
e Memory Low
e System Restart
e CPU usage exclude NICE threshold
¢ RAID Event (only available for devices that support RAID)
e Power Supply Failed (only available on supported hardware devices)
¢ High licensed device quota
e High licensed log GB/day
e Log Alert
¢ Log Rate
e Data Rate
e Fan Speed Out of Range
e Temperature Out of Range
¢ Voltage Out of Range
FortiAnalyzer feature set SNMP events:

To edit an SNMP user:

1. Go to System Settings > Network.

2. Inthe SNMP v3 section, double-click on a user, right-click on a user then select Edit, or select a user then click Edit
in the toolbar. The Edit SNMP User pane opens.

3. Editthe settings as required, then click OK to apply your changes.

To delete an SNMP user or users:

Go to System Settings > Network.

In the SNMP v3 section, select the user or users you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected user or users.

P obh-=

SNMP MiBs

The Fortinet and FortiAnalyzer MIBs, along with the two RFC MIBs, can be obtained from Customer Service & Support
(https://support.fortinet.com). You can download the FORTINET-FORTIMANAGER-FORTIANALYZER-MIB.mib MIB file
in the firmware image file folder. The FORTINET-CORE-MIB.mib file is located in the main FortiAnalyzer 5.00 file folder.

RFC support for SNMP v3 includes Architecture for SNMP Frameworks (RFC 3411), and partial support of User-based
Security Model (RFC 3414).

To be able to communicate with the SNMP agent, you must include all of these MIBs into your SNMP manager.
Generally your SNMP manager will be an application on your local computer. Your SNMP manager might already
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include standard and private MIBs in a compiled database that is ready to use. You must add the Fortinet and
FortiAnalyzer proprietary MIBs to this database.

MIB file name or RFC Description

FORTINET-CORE-MIB.mib The proprietary Fortinet MIB includes all system configuration information and
trap information that is common to all Fortinet products.

Your SNMP manager requires this information to monitor Fortinet unit
configuration settings and receive traps from the Fortinet SNMP agent.

FORTINET-FORTIMANAGER-  The proprietary FortiAnalyzer MIB includes system information and trap
MIB.mib information for FortiAnalyzer units.

RFC-1213 (MIB II) The Fortinet SNMP agent supports MIB Il groups with the following exceptions.

¢ No support for the EGP group from MIB |l (RFC 1213, section 3.11 and 6.10).

» Protocol statistics returned for MIB Il groups (IP/ICMP/TCP/UDP/etc.) do not
accurately capture all Fortinet traffic activity. More accurate information can
be obtained from the information reported by the Fortinet MIB.

RFC-2665 (Ethernet-like MIB) The Fortinet SNMP agent supports Ethernet-like MIB information with the
following exception.

No support for the dot3Tests and dot3Errors groups.

SNMP traps

Fortinet devices share SNMP traps, but each type of device also has traps specific to that device type. For example

FortiAnalyzer units have FortiAnalyzer specific SNMP traps. To receive Fortinet device SNMP traps, you must load and

compile the FORTINET-CORE-MIB into your SNMP manager.

Traps sent include the trap message as well as the unit serial number (fnSysSerial) and host name (sysName). The Trap
Message column includes the message that is included with the trap, as well as the SNMP MIB field name to help locate

the information about the trap.

Trap message Description

ColdStart, WarmStart, LinkUp, Standard traps as described in RFC 1215.

LinkDown

CPU usage high CPU usage exceeds the set percent. This threshold can be set in the CLI
(fnTrapCpuThreshold) using the following commands:

config system snmp sysinfo
set trap-high-cpu-threshold <percentage value>

end
CPU usage excluding NICE CPU usage excluding NICE processes exceeds the set percentage. This
processes threshold can be set in the CLI using the following commands:

(fmSysCpuUsageExcludedNice) config system snmp sysinfo
set trap-cpu-high-exclude-nice-threshold <percentage

value>
end
Memory low Memory usage exceeds 90 percent. This threshold can be set in the CLI using
(fnTrapMemThreshold) the following commands:
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Trap message Description

config system snmp sysinfo
set trap-low-memory-threshold <percentage value>

end
Log disk too full Log disk usage has exceeded the configured threshold. Only available on
(fnTrapLogDiskThreshold) devices with log disks.
Temperature too high A temperature sensor on the device has exceeded its threshold. Not all
(fnTrapTempHigh) devices have thermal sensors. See manual for specifications.

Voltage outside acceptable range Power levels have fluctuated outside of normal levels. Not all devices have

(fnTrapVoltageOutOfRange) voltage monitoring instrumentation.

Power supply failure Power supply failure detected. Available on some devices that support
(fnTrapPowerSupplyFailure) redundant power supplies.

Interface IP change The IP address for an interface has changed. The trap message includes the
(fnTraplpChange) name of the interface, the new IP address and the serial number of the

Fortinet unit. You can use this trap to track interface IP address changes for
interfaces with dynamic IP addresses set using DHCP or PPPoE.

Log rate too high The incoming log rate has exceeded the peak log rate threshold.

(fmTrapLogRateThreshold) To determine the peak log rate, use the following CLI command: get
system loglimits

Data rate too high The incoming data rate has exceeded the peak data rate threshold.
(fmTrapLogDataRateThreshold) The peak data rate is calculated using the peak log rate x 512 bytes (average
log size).

Fortinet & FortiAnalyzer MIB fields

The Fortinet MIB contains fields reporting current Fortinet unit status information. The below tables list the names of the
MIB fields and describe the status information available for each one. You can view more details about the information
available from all Fortinet MIB fields by compiling the fortinet.3.00.mib file into your SNMP manager and browsing
the Fortinet MIB fields.

System MIB fields:

MIB field Description

fnSysSerial Fortinet unit serial number.

Administrator accounts:

MIB field Description

fnAdminNumber The number of administrators on the Fortinet unit.
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fnAdminTable Table of administrators.
fnAdminindex Administrator account index number.
fnAdminName The user name of the administrator account.
fnAdminAddr An address of a trusted host or subnet from
which this administrator account can be used.
fnAdminMask The netmask for fnAdminAddr.

Custom messages:

MIB field Description

fnMessages The number of custom messages on the Fortinet unit.

MIB fields and traps

MIB field Description

fmModel A table of all FortiAnalyzer models.

RAID Management

RAID helps to divide data storage over multiple disks, providing increased data reliability. For FortiAnalyzer devices
containing multiple hard disks, you can configure the RAID array for capacity, performance, and/or availability.

Ay
‘9' The RAID Management tree menu is only available on FortiAnalyzer devices that support

RAID.

Supported RAID levels

FortiAnalyzer units with multiple hard drives can support the following RAID levels:

% See the FortiAnalyzer datasheet to determine your devices supported RAID levels.

Linear RAID

A Linear RAID array combines all hard disks into one large virtual disk. The total space available in this option is the
capacity of all disks used. There is very little performance change when using this RAID format. If any of the drives fails,
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the entire set of drives is unusable until the faulty drive is replaced. All data will be lost.

RAID 0

A RAID 0 array is also referred to as striping. The FortiAnalyzer unit writes information evenly across all hard disks. The
total space available is that of all the disks in the RAID array. There is no redundancy available. If any single drive fails,
the data on that drive cannot be recovered. This RAID level is beneficial because it provides better performance, since
the FortiAnalyzer unit can distribute disk writing across multiple disks.

e Minimum number of drives: 2
« Data protection: No protection

A\,
S r'd
? RAID 0 is not recommended for mission critical environments as it is not fault-tolerant.

RAID 1

A RAID 1 array is also referred to as mirroring. The FortiAnalyzer unit writes information to one hard disk, and writes a
copy (a mirrorimage) of all information to all other hard disks. The total disk space available is that of only one hard disk,
as the others are solely used for mirroring. This provides redundant data storage with no single point of failure. Should
any of the hard disks fail, there are backup hard disks available.

e Minimum number of drives: 2
« Data protection: Single-drive failure

S ! ’, One write or two reads are possible per mirrored pair. RAID 1 offers redundancy of data. A re-
? build is not required in the event of a drive failure. This is the simplest RAID storage design
- with the highest disk overhead.

RAID 1s

A RAID 1 with hot spare array uses one of the hard disks as a hot spare (a stand-by disk for the RAID). If a hard disk fails,
within a minute of the failure the hot spare is substituted for the failed drive, integrating it into the RAID array and
rebuilding the RAID’s data. When you replace the failed hard disk, the new hard disk is used as the new hot spare. The
total disk space available is the total number of disks minus two.

RAID 5

A RAID 5 array employs striping with a parity check. Similar to RAID 0, the FortiAnalyzer unit writes information evenly
across all drives but additional parity blocks are written on the same stripes. The parity block is staggered for each stripe.
The total disk space is the total number of disks in the array, minus one disk for parity storage. For example, with four
hard disks, the total capacity available is actually the total for three hard disks. RAID 5 performance is typically better
with reading than with writing, although performance is degraded when one disk has failed or is missing. With RAID 5,
one disk can fail without the loss of data. If a drive fails, it can be replaced and the FortiAnalyzer unit will restore the data
on the new disk by using reference information from the parity volume.

e Minimum number of drives: 3
» Data protection: Single-drive failure
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RAID 5s

A RAID 5 with hot spare array uses one of the hard disks as a hot spare (a stand-by disk for the RAID). If a hard disk fails,
within a minute of the failure, the hot spare is substituted for the failed drive, integrating it into the RAID array, and
rebuilding the RAID’s data. When you replace the failed hard disk, the new hard disk is used as the new hot spare. The
total disk space available is the total number of disks minus two.

RAID 6
A RAID 6 array is the same as a RAID 5 array with an additional parity block. It uses block-level striping with two parity
blocks distributed across all member disks.

e Minimum number of drives: 4
» Data protection: Up to two disk failures.

RAID 6s

A RAID 6 with hot spare array is the same as a RAID 5 with hot spare array with an additional parity block.

RAID 10

RAID 10 (or 1+0), includes nested RAID levels 1 and 0, or a stripe (RAID 0) of mirrors (RAID 1). The total disk space
available is the total number of disks in the array (a minimum of 4) divided by 2, for example:

o 2 RAID 1 arrays of two disks each,
« 3 RAID 1 arrays of two disks each,
« 6 RAID1 arrays of two disks each.

One drive from a RAID 1 array can fail without the loss of data; however, should the other drive in the RAID 1 array fail,
all data will be lost. In this situation, it is important to replace a failed drive as quickly as possible.

e Minimum number of drives: 4
« Data protection: Up to two disk failures in each sub-array.

Ay
S L4
q Alternative to RAID 1 when additional performance is required.

RAID 50

RAID 50 (or 5+0) includes nested RAID levels 5 and 0, or a stripe (RAID 0) and stripe with parity (RAID 5). The total disk
space available is the total number of disks minus the number of RAID 5 sub-arrays. RAID 50 provides increased
performance and also ensures no data loss for the same reasons as RAID 5. One drive in each RAID 5 array can fail
without the loss of data.

e Minimum number of drives: 6
» Data protection: Up to one disk failure in each sub-array.

Al
S L4
? Higher fault tolerance than RAID 5 and higher efficiency than RAID 0.
FortiAnalyzer 7.4.0 Administration Guide 298

Fortinet Inc.



System Settings

unless otherwise configured via the CLI. Use the diagnose system raid status CLI
command to view your current RAID level, status, size, groups, and hard disk drive
information.

\ RAID 50 is only available on models with 9 or more disks. By default, two groups are used

RAID 60

A RAID 60 (6+ 0) array combines the straight, block-level striping of RAID 0 with the distributed double parity of RAID 6.

¢ Minimum number of drives: 8
« Data protection: Up to two disk failures in each sub-array.

Al
‘Q' High read data transaction rate, medium write data transaction rate, and slightly lower
- performance than RAID 50.

Configuring the RAID level

Changing the RAID level will delete all data.

To configure the RAID level:

1. Go to System Settings > RAID Management.
2. Click Change inthe RAID Levelfield. The RAID Settings dialog box is displayed.
3. Fromthe RAID Level list, select a new RAID level, then click OK.

The FortiAnalyzer unit reboots. Depending on the selected RAID level, it may take a significant amount of time to
generate the RAID array.

Monitoring RAID status

To view the RAID status, go to System Settings > RAID Management. The RAID Management pane displays the RAID
level, status, and disk space usage. It also shows the status, size, and model of each disk in the RAID array.

x The Alert Message Console widget, located in Dashboard, provides detailed information about

RAID array failures. For more information see Alert Messages Console widget on page 55.
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Summary

e |l

l_‘ v el ' +
=) = ¥ v v
RAID Level Raid-10 [Change]
Status System is functioning normally.
Disk Space Usage [—— 125% Used
1890GB Used/ 5442GB Free/ 7332GB Total
Disk Management
Disk Number Disk Status Size(GB) Disk Model
0 A4 1862 ST2000NM0033-9ZM175
1 A4 1862 ST2000NMO033-9ZM175
2 A 4 1862 ST2000NMO033-9ZM175
3 v 1862 ST2000NM0033-9ZM175
4 v 1862 ST2000NM0033-9ZM175
5 v 1862 ST2000NM0033-9ZM175
6 v 1862 ST2000NM0033-9ZM175
7 v 1862 ST2000NM0033-9ZM175
Summary Shows summary information about the RAID array.
Graphic Displays the position and status of each disk in the RAID array. Hover the cursor
over each disk to view details.
RAID Level Displays the selected RAID level.
Click Change to change the selected RAID level. When you change the RAID
settings, all data is deleted.
Status Displays the overall status of the RAID array.

Disk Space Usage Displays the total size of the disk space, how much disk space is used, and how
much disk space is free.

Disk Management Shows information about each disk in the RAID array.
Disk Number Identifies the disk number for each disk.
Disk Status Displays the status of each disk in the RAID array.

¢ Ready: The hard drive is functioning normally.

e Rebuilding: The FortiAnalyzer unit is writing data to a newly added hard drive
in order to restore the hard drive to an optimal state. The FortiAnalyzer unit is
not fully fault tolerant until rebuilding is complete.

* Initializing: The FortiAnalyzer unit is writing to all the hard drives in the device
in order to make the array fault tolerant.

e Verifying: The FortiAnalyzer unit is ensuring that the parity data of a
redundant drive is valid.

» Degraded: The hard drive is no longer being used by the RAID controller.
 Inoperable: One or more drives are missing from the FortiAnalyzer unit. The
drive is no longer available to the operating system. Data on an inoperable

drive cannot be accessed.

Size (GB) Displays the size, in GB, of each disk.

Disk Model Displays the model number of each disk.

Swapping hard disks
If a hard disk on a FortiAnalyzer unit fails, it must be replaced. On FortiAnalyzer devices that support hardware RAID, the

hard disk can be replaced while the unit is still running - known as hot swapping. On FortiAnalyzer units with software
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RAID, the device must be shutdown prior to exchanging the hard disk.

To identify which hard disk failed, read the relevant log message in the Alert Message Console widget. See Alert
Messages Console widget on page 55.

Electrostatic discharge (ESD) can damage FortiAnalyzer equipment. Only perform the
procedures described in this document from an ESD workstation. If no such station is
available, you can provide some ESD protection by wearing an anti-static wrist or ankle strap
and attaching it to an ESD connector or to a metal part of a FortiAnalyzer chassis.

When replacing a hard disk, you need to first verify that the new disk is the same size as those

supplied by Fortinet and has at least the same capacity as the old one in the FortiAnalyzer unit.

Installing a smaller hard disk will affect the RAID setup and may cause data loss. Due to
possible differences in sector layout between disks, the only way to guarantee that two disks
have the same size is to use the same brand and model.

The size provided by the hard drive manufacturer for a given disk model is only an
approximation. The exact size is determined by the number of sectors present on the disk.

To hot swap a hard disk on a device that supports hardware RAID:

1. Remove the faulty hard disk.

2. |Install a new disk.

The FortiAnalyzer unit automatically adds the new disk to the current RAID array. The status appears on the
console. The RAID Management pane displays a green checkmark icon for all disks and the RAID Status area
displays the progress of the RAID re-synchronization/rebuild.

Adding hard disks

Some FortiAnalyzer units have space to add more hard disks to increase your storage capacity.

A\,

Fortinet recommends you use the same disks as those supplied by Fortinet. Disks of other
brands will not be supported by Fortinet. For information on purchasing extra hard disks,
contact your Fortinet reseller.

To add more hard disks:

1. Obtain the same disks as those supplied by Fortinet.

2. Back up the log data on the FortiAnalyzer unit.
You can also migrate the data to another FortiAnalyzer unit, if you have one. Data migration reduces system down
time and the risk of data loss.

3. Install the disks in the FortiAnalyzer unit.
If your unit supports hot swapping, you can do so while the unit is running. Otherwise the unit must be shut down
first. See Unit Operation widget on page 55 for information.

4. Configure the RAID level. See Configuring the RAID level on page 299.
5. If you backed up the log data, restore it.
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Administrative Domains (ADOMs)

Administrative domains (ADOMs) enable administrators to manage only those devices that they are specifically
assigned, based on the ADOMs to which they have access. When the ADOM mode is advanced, FortiGate devices with
multiple VDOMSs can be divided among multiple ADOMs.

Administrator accounts can be tied to one or more ADOMSs, or denied access to specific ADOMs. When a particular
administrator logs in, they see only those devices or VDOMs that have been enabled for their account. Super user
administrator accounts, such as the admin account, can see and maintain all ADOMs and the devices within them.

Each ADOM specifies how long to store and how much disk space to use for its logs. You can monitor disk utilization for
each ADOM and adjust storage settings for logs as needed.

The maximum number of ADOMs you can add depends on the FortiAnalyzer system model. Please refer to the
FortiAnalyzer data sheet for more information.

When the maximum number of ADOMs has been reached, you will be unable to create a new ADOM.

When upgrading to FortiAnalyzer 6.2.1 or later, you will continue to have access to any ADOMs exceeding the limit,
however, no additional ADOMs can be created, and an alert will be issued in the Alert Message Console in System
Settings > Dashboard.

By default, ADOMs are disabled. Enabling and configuring ADOMs can only be done by administrators with the Super_
User profile. See Administrators on page 346.

The root ADOM and Security Fabric ADOMs are available for visibility into all Fabric devices. See Security Fabric
ADOMs on page 171.

Ay
‘?' Non-FortiGate devices are automatically located in specific ADOMs for their device type. They
- cannot be moved to other ADOMs.
Ay
S L4
? ADOMSs must be enabled to support the logging and reporting of non-FortiGate devices.
Root ADOM

When ADOMs are enabled, the default root ADOM type is Fabric. Fabric ADOMs show combined results from all
Security Fabric devices in the Device Manager, Log View, FortiView, Incidents & Events and Reports panes. For more
information on Fabric ADOMs, see Security Fabric ADOMs on page 171.

In FortiAnalyzer 6.2.0 and earlier, the root ADOM is a FortiGate ADOM. When upgrading to FortiAnalyzer 6.2.1 and later,
the root ADOM type will not be changed to Fabric. Resetting the FortiAnalyzer settings through a factory reset will cause
the root ADOM to become a Fabric ADOM.
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Default device type ADOMs

When ADOMs are enabled, FortiAnalyzer includes default ADOMs for specific types of devices. When you add one or
more of these devices to FortiAnalyzer, the devices are automatically added to the appropriate ADOM, and the ADOM
becomes selectable. When a default ADOM contains no devices, the ADOM is not selectable.

For example, when you add a FortiClient EMS device to the FortiAnalyzer, the FortiClient EMS device is automatically
added to the default FortiClient ADOM. After the FortiClient ADOM contains a FortiClient EMS device, the FortiClient
ADOM is selectable when you log into FortiAnalyzer or when you switch between ADOMs.

You can view all of the ADOMSs, including default ADOMs without devices, on the System Settings > ADOMs pane.

Organizing devices into ADOMs

You can organize devices into ADOMs to allow you to better manage these devices. Devices can be organized by
whatever method you deem appropriate, for example:

« Firmware version: group all devices with the same firmware version into an ADOM.

« Geographic regions: group all devices for a specific geographic region into an ADOM, and devices for a different
region into another ADOM.

» Administrative users: group devices into separate ADOMs based for specific administrators responsible for the
group of devices.

o Customers: group all devices for one customer into an ADOM, and devices for another customer into another
ADOM.

FortiClient support and ADOMs

FortiClient logs are stored in the device that the FortiClient endpoint is registered to.

For example, when endpoints are registered to a FortiGate device, FortiClient logs are viewed on the FortiGate device.
When endpoints are registered to a FortiClient EMS, FortiClient logs are viewed in the FortiClient ADOM that the
FortiClient EMS device is added to.

ADOMs must be enabled to support FortiClient EMS devices.

Merge FortiAnalyzer Logging Support for FortiClient EMS for Chromebooks

1. Add https-logging tothe allowaccess list using the following CLI command:
config system interface
edit "portl"
set allowaccess https ssh https-logging
next
end
2. Add SSL certificate to enable communication.
An SSL certificate is required to support communication and send logs between FortiClient Web Filter extension
and FortiAnalyzer. If you use a public SSL certificate, you only need to add the public SSL certificate to
FortiAnalyzer.

However, if you prefer to use a certificate that is not from a common CA, you must add the SSL certificate to
FortiAnalyzer, and you must push the root CA of your certificate to the Google Chromebooks. Otherwise, the
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HTTPS connection between the FortiClient EMS Chromebook Web Filter extension and FortiAnalyzer will not work.

The common name of the certificate must be the FortiAnalyzer IP address.

a. InFortiAnalyzer, go to System Settings > Certificates.

b. Click Create New/Import > Certificate. The Import Local Certificate dialog box appears.

c. Inthe Type list, select Certificate. Or,
In the Type list, select PKCS#12 Certificate to upload the certificate in PK12 format.

d. Beside the Certificate File field, click Browse to select the certificate.

e. Enterthe password and certificate name.

f. Click OK.

3. Select certificates for HTTPS connections:

a. InFortiAnalyzer, go to System Settings > Settings.

b. Inthe HTTPS & Web Service Certificate box, select the certificate you want to use for HTTPS connections, and
click Apply.

4. Enable the FortiClient ADOM using the following CLI command:
conf sys global
set adom-status enable
end

5. Add FortiClient EMS for Chromebooks as a device to the FortiClient ADOM:

Go to Device Manager > click the + Add Device button to add FortiClient EMS for Chromebooks as a FortiClient
ADOM device.

6. Enable logging in FortiClient EMS for Chromebooks:
You will need to enable logging in FortiClient EMS for Chromebooks, see the FortiClient EMS for Chromebooks
Administration Guide for more information.

Enabling and disabling the ADOM feature

By default, ADOMs are disabled. Enabling and configuring ADOMSs can only be done by super user administrators.

When ADOMs are enabled, the Device Manager, FortiView, Log View, Incidents & Events, and Reports panes are

displayed per ADOM. You select the ADOM you need to work in when you log into the FortiAnalyzer unit. See Switching

between ADOMs on page 25.

To enable the ADOM feature:

1. Login to the FortiAnalyzer as a super user administrator.
2. Goto Dashboard.
3. Inthe System Information widget, toggle the Administrative Domain switch to ON.
You will be automatically logged out of the FortiAnalyzer and returned to the log in screen.

To disable the ADOM feature:

1. Remove all the devices from all non-root ADOMSs. That is, add all devices to the root ADOM.
2. Delete all non-root ADOMs. See Deleting ADOMSs on page 309.

Only after removing all the non-root ADOMs can ADOMs be disabled.

Go to Dashboard.

In the System Information widget, toggle the Administrative Domain switch to OFF.
You will be automatically logged out of the FortiAnalyzer and returned to the log in screen.

Lol

FortiAnalyzer 7.4.0 Administration Guide
Fortinet Inc.

304



System Settings

Ay
‘Q' The ADOMs feature cannot be disabled if ADOMs are still configured and have managed
- devices in them.

ADOM device modes

ADOM deployment can have two device modes: Normal (default) and Advanced.

¢ In Normal mode, you cannot assign different FortiGate VDOM s to different ADOMs. The FortiGate unit can only be
added to a single ADOM.

 In Advanced mode, you can assign a VDOM from a single device to a different ADOM. This allows you to analyze
data for individual VDOMs, but will result in more complicated management scenarios. It is recommended only for
advanced users.

Al
‘Q' FortiAnalyzer does not support splitting FortiGate VDOMs between multiple ADOMs in
- different ADOM modes (normal/backup).

To change from Advanced mode back to Normal mode, you must ensure no FortiGate VDOMs are assigned to an
ADOM.

To change the ADOM device mode:

1. Go to System Settings > Advanced > Advanced Settings.
2. Inthe ADOM Mode field, select either Normal or Advanced.
3. Select Apply to apply your changes.

Managing ADOMs

The ADOMs feature must be enabled before ADOMs can be created or configured. See Enabling and disabling the
ADOM feature on page 304.

To create and manage ADOMs, go to System Settings > ADOMSs.

WD = Enter AD X AD Search.

O Names ADOM Type & Allocated Storage + Devices + Comments & u

[m] root Fabric 32GB 7 Devices (including 7 VDOMs) >

1000 MB
1000 MB
1000 MB
1000 MB
1000 MB

[JO 00O

E.
i N
B

Syslog Syslog 1000 MB
FortiWeb Fortiweb 1000 MB
FortiSandbox FortiSandbox 1000 MB
FortiNAC FortiNAC 1000 MB
FortiManager FortiManager 1000 MB
FortiMail FortiMail 1000 MB
FortiDDoS FortiDDoS 1000 MB
FortiClient FortiClient 1000 MB

Oooo0oo0ooOoo0o0o0o

FortiCache FortiCache 1000 MB

0% 18
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Create New

Edit

Delete

Enter ADOM
Disable ADOM

More

Search

Name

Firmware Version

Devices

Creating ADOMs

Create a new ADOM. See Creating ADOMs on page 306.

Edit the selected ADOM. This option is also available from the right-click menu.
See Editing an ADOM on page 309.

Delete the selected ADOM or ADOMs. You cannot delete default ADOMs. This
option is also available from the right-click menu. See Deleting ADOMSs on page
309.

Switch to the selected ADOM. This option is also available from the right-click
menu.

Disable the selected ADOM. This option is also available from the right-click
menu.

Select Expand Devices to expand all of the ADOMs to show the devices in each
ADOM.
Select Collapse Devices to collapses the device lists.

Select an ADOM, and click Clone to make a copy of the ADOM. Devices are not
cloned to the new ADOM.

Some of these options are also available from the right-click menu.
Enter a search term to search the ADOM list.

The name of the ADOM.

ADOMs are listed in the following groups: Security Fabric, FortiGates and Other
Device Types. A group can be collapsed or expanded by clicking the triangle next
to its name.

The firmware version of the ADOM. Devices in the ADOM should have the same
firmware version.

The number of devices and VDOMSs that the ADOM contains.
The device list can be expanded or by clicking the triangle.

ADOMs must be enabled, and you must be logged in as a super user administrator to create a new ADOM.

Consider the following when creating ADOMs:

« The maximum number of ADOMs that can be created depends on the FortiAnalyzer model. For more information,
see the FortiAnalyzer data sheet at https://www.fortinet.com/products/management/fortianalyzer.html.
When the maximum number of ADOMs has been exceeded, an alert will be issued in the Alert Message Console in

System Settings > Dashboard.

» You must use an administrator account that is assigned the Super_User administrative profile.
» You can add a device to only one ADOM. You cannot add a device to multiple ADOMs.

« You cannot add FortiGate and FortiCarrier devices to the same ADOM. FortiCarrier devices are added to a specific,
default FortiCarrier ADOM.

« You can add one or more VDOMs from a FortiGate device to one ADOM. If you want to add individual VDOMs from

a FortiGate device to different ADOMs, you must first enable advanced device mode. See ADOM device modes on

page 305.
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« You can configure how an ADOM handles log files from its devices. For example, you can configure how much disk
space an ADOM can use for logs, and then monitor how much of the allotted disk space is used. You can also
specify how long to keep logs in the SQL database and how long to keep logs stored in compressed format.

To create an ADOM:

1. Ensure that ADOMs are enabled. See Enabling and disabling the ADOM feature on page 304.

2. Goto System Settings > ADOMs.

3. Click Create New in the toolbar. The Create New ADOM pane is displayed.

Create ADOM

x

Name

Type Fabric

Description

Data Policy

Keep Logs for Analytics 60 Days
Keep Logs for Archive 365 Days

Disk Utilization

Allocated 15990 MB

Analytics: Archive

Alert and Delete When Usage Reaches

1P Address Platform n

+ | Maximum Available: 15.6

4. Configure the following settings, then click OK to create the ADOM.

Name

Type

Time Zone

Devices

Data Policy

Keep Logs for
Analytics

FortiAnalyzer 7.4.0 Administration Guide
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Type a name that allows you to distinguish this ADOM from your other
ADOMs. ADOM names must be unique.

Select the type of device that you are creating an ADOM for. The ADOM type
cannot be edited.

For Security Fabric ADOMSs, select Fabric.

Although you can create a different ADOM for each type of device,
FortiAnalyzer does not enforce this setting.

Select the time zone for the ADOM. This time zone will be used when
displaying data in Log View and FortiView.

The Default time zone is the time zone set for the FortiAnalyzer. For more
information, see Configuring the system time on page 42.

Add a device or devices with the selected versions to the ADOM. The search
field can be used to find specific devices. See Assigning devices to an ADOM
on page 308.

Specify how long to keep logs in the indexed and compressed states.

Specify how long to keep logs in the indexed state.
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Keep Logs for
Archive

Disk Utilization

Maximum Allowed

Analytics : Archive

Alert and Delete
When Usage
Reaches

During the indexed state, logs are indexed in the SQL database for the
specified amount of time. Information about the logs can be viewed in the
FortiView, Incidents & Events, and Reports modules. After the specified length
of time expires, Analytics logs are automatically purged from the SQL
database.

Specify how long to keep logs in the compressed state.

During the compressed state, logs are stored in a compressed format on the
FortiAnalyzer unit. When logs are in the compressed state, information about
the log messages cannot be viewed in the FortiView, Incidents & Events, or
Reports modules. After the specified length of time expires, Archive logs are
automatically deleted from the FortiAnalyzer unit.

Specify how much disk space to use for logs.

Specify the maximum amount of FortiAnalyzer disk space to use for logs, and
select the unit of measure.

The total available space on the FortiAnalyzer unit is shown.

For more information about the maximum available space for each
FortiAnalyzer unit, see Disk space allocation on page 127.

Specify the percentage of the allotted space to use for Analytics and Archive
logs.

Analytics logs require more space than Archive logs. For example, a setting of
70% and 30% indicates that 70% of the allotted disk space will be used for
Analytics logs, and 30% of the allotted space will be used for Archive logs.
Select the Modify checkbox to change the setting.

Specify at what data usage percentage an alert messages will be generated
and logs will be automatically deleted. The oldest Archive log files or Analytics
database tables are deleted first.

Assigning devices to an ADOM

To assign devices to an ADOM you must be logged in as a super user administrator. Devices cannot be assigned to

multiple ADOMs.

To assign devices to an ADOM:

1. Go to System Settings > ADOMs.

2. Double-click on an ADOM, right-click on an ADOM and then select the Edit from the menu, or select the ADOM then

click Editin the toolbar. The Edit ADOM pane opens.
3. Click Select Device. The Select Device list opens on the right side of the screen.

4. Selectthe devices that you want to add to the ADOM. Only devices with the same version as the ADOM can be
added. The selected devices are displayed in the Devices list.
If the ADOM mode is Advanced you can add separate VDOMs to the ADOM as well as units.

5. When done selecting devices, click Close to close the Select Device list.

6. Click OK.

The selected devices are removed from their previous ADOM and added to this one.

FortiAnalyzer 7.4.0 Administration Guide
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Assigning administrators to an ADOM

Super user administrators can create other administrators and either assign ADOMs to their account or exclude them
from specific ADOMSs, constraining them to configurations and data that apply only to devices in the ADOMs they can

access.
s‘ ! ’, By default, when ADOMs are enabled, existing administrator accounts other than admin are
q assigned to the root domain, which contains all devices in the device list. For more information
3 about creating other ADOMs, see Creating ADOMs on page 306.

To assign an administrator to specific ADOMs:

1. Login as a super user administrator. Other types of administrators cannot configure administrator accounts when
ADOMs are enabled.

2. Goto System Settings > Administrators.

3. Double-click on an administrator, right-click on an administrator and then select the Edit from the menu, or select the
administrator then click Edit in the toolbar. The Edit Administrator pane opens.

4. Edit the Administrative Domain field as required, either assigning or excluding specific ADOMs.
5. Select OKto apply your changes.

A\,

b ] L4
? The admin administrator account cannot be restricted to specific ADOMs.

Editing an ADOM

To edit an ADOM you must be logged in as a super user administrator. The ADOM type and version cannot be edited.
For the default ADOMs, the name cannot be edited.

To edit an ADOM:

1. Go to System Settings > ADOMs.

2. Double-click on an ADOM, right-click on an ADOM and then select Edit from the menu, or select the ADOM then
click Editin the toolbar. The Edit ADOM pane opens.

3. Edit the settings as required, and then select OK to apply the changes.

Deleting ADOMs

To delete an ADOM, you must be logged in as a super-user administrator (see Administrator profiles on page 355), such
as the admin administrator.

Prior to deleting an ADOM:

« All devices must be removed from the ADOM. Devices can be moved to another ADOM, or to the root ADOM. See
Assigning devices to an ADOM on page 308.
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To delete an ADOM:

Go to System Settings > ADOMs.

Ensure that the ADOM or ADOMs being deleted have no devices in them.
Select the ADOM or ADOMSs you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation box to delete the ADOM or ADOMs.

If there are users or policy packages referring to the ADOM, they are displayed in the ADOM References Detected
dialog. Click Delete Anyway to delete the ADOM or ADOMs. The references to the ADOMs are also deleted.

o gk wbh-=

\,
S r'd
? Default ADOMs cannot be deleted.

Certificates

The FortiAnalyzer generates a certificate request based on the information you entered to identify the FortiAnalyzer unit.

After you generate a certificate request, you can download the request to a management computer and then forward the
request to a CA.

Local certificates are issued for a specific server, or website. Generally they are very specific, and often for an internal
enterprise network.

CA root certificates are similar to local certificates, however they apply to a broader range of addresses or to an entire
company.

The CRL is a list of certificates that have been revoked and are no longer usable. This list includes expired, stolen, or
otherwise compromised certificates. If your certificate is on this list, it will not be accepted. CRLs are maintained by the
CA that issues the certificates and include the date and time when the next CRL will be issued, as well as a sequence
number to help ensure you have the most current versions.

Local certificates

The FortiAnalyzer unit generates a certificate request based on the information you enter to identify the FortiAnalyzer
unit. After you generate a certificate request, you can download the request to a computer that has management access
to the FortiAnalyzer unit and then forward the request to a CA.

The certificate window also enables you to export certificates for authentication, importing, and viewing.
The FortiAnalyzer has one default local certificate: Fortinet_Local.

You can manage local certificates from the System Settings > Certificates page. Some options are available in the
toolbar and some are also available in the right-click menu.

vy
‘?' In order to safeguard against compromise, in FortiAnalyzer 7.4.0, FAZ-VM license files contain
- a unique certificate which is tied to the device's serial number.
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Creating a local certificate

To create a certificate request:

1. Go to System Settings > Certificates.
2. Click Create New/Import > Generate CSR in the toolbar. The Generate Certificate Signing Request pane opens.
3. Enter the following information as required, then click OK to save the certificate request:

Certificate Name The name of the certificate.

Subject Information Select the ID type from the dropdown list:

* Host IP: Select if the unit has a static IP address. Enter the public IP
address of the unit in the Host IP field.

e Domain Name: Select if the unit has a dynamic IP address and
subscribes to a dynamic DNS service. Enter the domain name of the unit
in the Domain Name field.

e Email: Select to use an email address. Enter the email address in the
Email Address field.

Optional Information

Organization Unit
(ov)

Organization (O)
Locality (L)

State/Province
(ST)

Country (C)

E-mail Address
(EA)

Subject
Alternative Name

The name of the department. You can enter a series of OUs up to a maximum
of 5. To add or remove an OU, use the plus (+) or minus (-) icons.

Legal name of the company or organization.
Name of the city or town where the device is installed.

Name of the state or province where the FortiGate unit is installed.

Select the country where the unit is installed from the dropdown list.

Contact email address.

Optionally, enter one or more alternative names for which the certificate is also
valid. Separate names with a comma.

A name can be:

* e-mail address

* |P address

* URI

¢ DNS name (alternatives to the Common Name)

« directory name (alternatives to the Distinguished Name)
You must precede the name with the name type. Examples:

e IP:1.1.1.1

» email:test@fortinet.com

¢ email:my@other.address

* URL:http://my.url.here/

Key Type The key type can be RSA or Elliptic Curve.

FortiAnalyzer 7.4.0 Administration Guide
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Key Size

Curve Name

Enroliment Method

Importing local certificates

To import a local certificate:

Select the key size from the dropdown list: 5712 Bit, 1024 Bit, 1536 Bit, or 2048
Bit. This option is only available when the key type is RSA.

Select the curve name from the dropdown list: secp256r1 (default),
secp384r1, or secp521ri1. This option is only available when the key type is
Elliptic Curve.

The enrollment method is set to File Based.

1. Go to System Settings > Certificates.
2. Click Create New/Import > Local Certificate in the toolbar.
3. Enter the following information as required, then click OK to import the local certificate:

Type
Certificate File

Key File

Password

Certificate Name

Deleting local certificates

Select the certificate type from the dropdown list: Local Certificate, PKCS #12
Certificate, or Certificate.

Click Browse... and locate the certificate file on the management computer, or
drag and drop the file onto the dialog box.

Click Browse... and locate the key file on the management computer, or drag
and drop the file onto the dialog box.

This option is only available when Type is Certificate.

Enter the certificate password.
This option is only available when Type is PKCS #12 Certificate or Certificate.

Enter the certificate name.
This option is only available when Type is PKCS #12 Certificate or Certificate.

To delete a local certificate or certificates:

o bd-=

Go to System Settings > Certificates.

Select the certificate or certificates you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected certificate or certificates.

Viewing details of local certificates

To view details of a local certificate:

1. Go to System Settings > Certificates.

2. Select the certificates that you would like to see details about, then click View Certificate Detail in the toolbar or
right-click menu. The View Local Ceritificate page opens.

FortiAnalyzer 7.4.0 Administration Guide
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View Local Certificate

Certificate Name ~ Fortinet_Local

Issuer €= US, ST = California, L = Sunnyvale, O = Fortinet, OU = Certificate Authority, CN = support, emailAddress = support@fortinet.com
Subject €= Us, ST = California, L = Sunnyvale, O = Fortinet, OU = FortiManager, CN = FMG-VM0000000000, emailAddress = support@fortinet.com
Valid From 2011-11-08 23:12:50 GMT

Valid To 2038-81-89 03:14:07 GMT

Version 3

Serial Number TLiead7

Extension Name: X509v3 Basic Constraints
Critical: no
Content:
CAFALSE

3. Click OKto return to the local certificates list.

Downloading local certificates

To download a local certificate:

1.
2,
3.

Go to System Settings > Cetrtificates.
Select the certificate that you need to download.

Click Download in the toolbar, or right-click and select Download, and save the certificate to the management
computer.

S ! ’, When an object is added to a policy package and assigned to an ADOM, the object is available
? in all devices that are part of the ADOM. If the object is renamed on a device locally,
- FortiManager automatically syncs the renamed object to the ADOM.

CA certificates

The FortiAnalyzer has one default CA certificate, Fortinet_CA. In this sub-menu you can delete, import, view, and
download certificates.

Importing CA certificates

To import a CA certificate:

1.
2,
3.

Go to System Settings > Cetrtificates.
Click Create New/Import > CA Certificate in the toolbar.

Click Browse... and locate the certificate file on the management computer, or drag and drop the file onto the dialog
box.

Click OK to import the certificate.

Viewing CA certificate details

To view a CA certificate's details:

1.
2,
3.

Go to System Settings > Cetrtificates.
Select the certificates you need to see details about.
Click View Certificate Detail in the toolbar, or right-click and select View Certificate Detail. The View CA Certificate
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page opens.
4. Click OKto return to the CA certificates list.

Downloading CA certificates

To download a CA certificate:

1. Goto System Settings > Certificates.
2. Select the certificate you need to download.

3. Click Download in the toolbar, or right-click and select Download, and save the certificate to the management
computer.

Deleting CA certificates

To delete a CA certificate or certificates:

Go to System Settings > Certificates.

Select the certificate or certificates you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected certificate or certificates.

o bd-=

Al
S L4
? The Fortinet_CA certificate cannot be deleted.

Certificate revocation lists

When you apply for a signed personal or group certificate to install on remote clients, you can obtain the corresponding
root certificate and Certificate Revocation List (CRL) from the issuing CA.

The CRL is a list of certificates that have been revoked and are no longer usable. This list includes expired, stolen, or
otherwise compromised certificates. If your certificate is on this list, it will not be accepted. CRLs are maintained by the
CA that issues the certificates and includes the date and time when the next CRL will be issued as well as a sequence
number to help ensure you have the most current version of the CRL.

When you receive the signed personal or group certificate, install the signed certificate on the remote client(s) according
to the browser documentation. Install the corresponding root certificate (and CRL) from the issuing CA on the
FortiAnalyzer unit according to the procedures given below.

Importing a CRL

To import a CRL:

Go to System Settings > Certificates.
Click Create New/Import > CRL in the toolbar.

Click Browse... and locate the CRL file on the management computer, or drag and drop the file onto the dialog box.
Click OK to import the CRL.

o bd-=
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Viewing a CRL

To view a CRL:

Go to System Settings > Certificates.
Select the CRL you need to see details about.

Click View Certificate Detail in the toolbar, or right-click and select View Certificate Detail. The Result page opens.
Click OK to return to the CRL list.

o bd-=

Deleting a CRL

To delete a CRL or CRLs:

Go to System Settings > Certificates.

Select the CRL or CRLs you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected CRL or CRLs.

o bd-=

Log Forwarding

You can forward logs from a FortiAnalyzer unit to another FortiAnalyzer unit, a syslog server, or a Common Event
Format (CEF) server when you use the default forwarding mode in log forwarding. You can also forward logs via an
output plugin, connecting to a public cloud service.

The client is the FortiAnalyzer unit that forwards logs to another device. The server is the FortiAnalyzer unit, syslog
server, or CEF server that receives the logs.

In addition to forwarding logs to another unit or server, the client retains a local copy of the logs. The local copy of the
logs is subject to the data policy settings for archived logs. See Log storage on page 34 for more information.

involved, go to System Settings > Logging Topology. For more information, see Logging
Topology on page 281.

\ﬂ To see a graphical view of the log forwarding configuration, and to see details of the devices

Modes

FortiAnalyzer supports two log forwarding modes: forwarding (default), and aggregation.

Forwarding

Logs are forwarded in real-time or near real-time as they are received. Forwarded content files include: DLP files,
antivirus quarantine files, and IPS packet captures.

This mode can be configured in both the GUI and CLI.
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Aggregation
As FortiAnalyzer receives logs from devices, it stores them, and then forwards the collected logs at a specified time
every day. To avoid duplication, the client only sends logs that are not already on the server.

FortiAnalyzer supports log forwarding in aggregation mode only between two FortiAnalyzer units. Syslog and CEF
servers are not supported.

Al
‘Q' The client must provide super user log in credentials to get authenticated by the server to

aggregate logs.

Aggregation mode can only be configured with the 1og-forward and log-forward-service CLI commands. See
the FortiAnalyzer CLI Reference for more information.

The following table lists the differences between the two modes:

Log Forwarding Log Aggregation

Configuration Portal GUl or CLI CLI

Remote Server Type FortiAnalyzer FortiAnalyzer
Syslog/CEF/Forward via Output Plugin

Device Filter Support Yes Yes

Log Filter Support Yes No

Log Archive Support Yes Yes

Server Port customization Yes (Except for FortiAnalyzer) No

Compression Yes (FortiAnalyzer only) No

Log Field Exclusion Yes No

Log Delay Real-time (max 5 minutes delay) Max 1 day

Log Data Masking Yes No

Meta-data synchronization Yes No

Secure channel support Yes (SSL as reliable connection) Yes (rsync + SSH)

Network bandwidth Normal (as log traffic received) Peak hour as aggregation starts to
finish

Impact on remote Normal (as log volume received) Potentially large table

FortiAnalyzer (If there is a mix of incoming real-time

and real-time logs.)

Configuring log forwarding

Forwarding mode only requires configuration on the client side. No configuration is needed on the server side. In
aggregation mode, accepting the logs must be enabled on the FortiAnalyzer that is acting as the server.
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Forwarding mode

Forwarding mode can be configured in the GUI. No configuration is required on the server side.

To configure the client:

1. Go to System Settings > Advanced > Log Forwarding > Settings.
2. Click Create New in the toolbar. The Create New Log Forwarding pane opens.

Create New Log Forwarding

x

Name

Please input name.

Status ©

Remote Server Type FortiAnalyzer
Server FQDN/IP FQDN/IP
Compression @

Reliable Connection @

Sending Frequency Real-time
Log Forwarding Filters

Device Filters Select Device
Log Filters fo )

Enable Exclusions @

Enable Masking fo )

Every 1 Minute Every 5 Minutes

3. Fillin the information as per the below table, then click OK to create the new log forwarding. The FortiAnalyzer
device will start forwarding logs to the server.

Name
Status

Remote Server Type

Output Profile

Server FQDN/IP

Server Port

FortiAnalyzer 7.4.0 Administration Guide
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Enter a name for the remote server.
Set to On to enable log forwarding. Set to Offto disable log forwarding.

Select the type of remote server to which you are forwarding logs:
* FortiAnalyzer

e Syslog (this option can be used to foward logs to FortiSIEM and
FortiSOAR)

e Syslog Pack

e Common Event Format (CEF)

e Forward via Output Plugin
Select the output profile. You must configure output profiles to appear in the
dropdown. For more information, see Output profiles on page 319.
This option is only available when the server type is Forward via Output
Plugin.
Enter the fully qualified domain name or IP for the remote server.
This option is not available when the server type is Forward via Output Plugin.

Enter the server port number. Default: 514.

This option is only available when the server type is Syslog, Syslog Pack, or
Common Event Format (CEF).
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Compression Turn on to enable log message compression when the remote FortiAnalyzer
also supports this format. If the remote FortiAnalyzer does not support
compression, log messages will remain uncompressed.

This option is only available when the server type is FortiAnalyzer.

Reliable Connection Turn on to use TCP connection. Turn off to use UDP connection.

If you want to forward logs to a Syslog or CEF server, ensure this option is
supported. RELP is not supported.

If the connection goes down, logs are buffered and automatically forwarded
when the connection is restored. The buffer limitis 12GB.

This option is not available when the server type is Forward via Output Plugin.

Sending Frequency Select when logs will be sent to the server: Real-time, Every 1 Minute, or
Every 5 Minutes (default).

This option is only available when the server type is FortiAnalyzer.
Log Forwarding Filters
Device Filters Click Select Device, then select the devices whose logs will be forwarded.

Log Filters Turn on to configure filter on the logs that are forwarded.
Select All or Any of the Following Conditions in the Log messages that match
field to control how the filters are applied to the logs.

Add filters to the table by selecting the Log Field, Match Criteria, and Value for
each filter.

Enable Exclusions Turn on to configure filter on the logs that are forwarded.
Add exclusions to the table by selecting the Device Type and Log Type. Then,
add Log Fields to the Exclusion List by clicking Fields and specifying the
excluded log fields in the Select Log Field pane.

Enable Masking Turn on to enable log field masking.
In the Masking Data Fields, select any data fields that should be masked
during log forwarding. The remote server will receive logs with the selected
field values masked. Configure a Data Mask Key.

vy
‘?' Devices whose logs are being forwarded to another FortiAnalyzer device are added to the
- server as unauthorized devices. To authorize devices, see Authorizing devices on page 65.

Aggregation mode

Aggregation mode can only be configured using the CLI. Aggregation mode configurations are not listed in the GUI table,
but still use a log forwarding ID number.

Ay
‘?' Use the following CLI command to see what log forwarding IDs have been used:
get system log-forward
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To configure the server:

1. Ifrequired, create a new administrator with the Super_User profile. See Creating administrators on page 348.
2. Enable log aggregation and, if necessary, configure the disk quota, with the following CLI commands:
config system log-forward-service
set accept-aggregation enable
set aggregation-disk-quota <quota>
end

To configure the client:

1. Open the log forwarding command shell:
config system log-forward
2. Create a new, or edit an existing, log forwarding entry:
edit <log forwarding ID>
Set the log forwarding mode to aggregation:
set mode aggregation
4. Setthe server display name and IP address:
set server-name <string>
set server-ip <XXX.XXX.XXX.XXX>
5. Enter the user name and password of the super user administrator on the server:
set agg-user <string>
set agg-password <string>

ol

6. Ifrequired, set the aggregation time from 0 to 23 hours (default: 0, or midnight):
set agg-time <integer>
7. Enter the following to apply the configuration and create the log aggregation:

end
The following line will be displayed to confirm the creation of the log aggregation:

check for cfg[<log forwarding ID>] svr disp name=<server-name>

A\,
S r'd
q For more information, see the FortiAnalyzer CLI Reference.

Output profiles

You can use output profiles to configure log forwarding to public cloud services.

You can create and manage these output profiles in System Settings > Advanced > Log Forwarding > Output Profile.
Once created, you can use the output profile when configuring a client for log forwarding. See Configuring log forwarding
on page 316.

To create an output profile:

1. Go to System Settings > Advanced > Log Forwarding > Output Profile.
2. Click Create New.
The Create Output Profile pane displays.
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3. Configure the following options:

Name Enter a name for the output profile.
Type Select the public cloud service for the output profile.
Configuration Click Use Default to use the default Fluentd configuration for the selected

public cloud service.

Alternatively, copy and paste the Fluentd configuration into this field for the
selected public cloud service.

Field Fields will automatically be added into the configuration if a keyword matches
the placeholder in the configuration to provide encryption for you to hide the
credentials.

For example, a password placeholder in the configuration would be
"s {password}". Inthe field, you can define Field: password, Value:
actual password.

4. Click Validate and Save.

To edit an output profile:

Go to System Settings > Advanced > Log Forwarding > Output Profile.
Select the checkbox for the output profile.

Click Edit.

Edit the options as needed.

Click Validate and Save.

o 0N -=

To clone an output profile:

Go to System Settings > Advanced > Log Forwarding > Output Profile.
Select the checkbox for the output profile.

Click Clone.

Edit the options to create the new output profile.

Click Validate and Save.

o oON-=

You can enable and troubleshoot Fluentd logging from the FortiAnalyzer CLI using the

following commands:
ﬂ diagnose sgl fluentd log-tail
I diagnose sgl fluentd log-view

diagnose test application fwdplugind
For more information, see the FortiAnalyzer CLI Reference on the Fortinet Documents Library.

Managing log forwarding

Log forwarding mode server entries can be edited and deleted using both the GUI and the CLI. Aggregation mode server
entries can only be managed using the CLI. Entries cannot be enabled or disabled using the CLI.
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To enable or disable a log forwarding server entry:

1.
2,

Go to System Settings > Advanced > Log Forwarding > Settings.

Double-click on a server entry, right-click on a server entry and select Edit, or select a server entry then click Edit in
the toolbar. The Edit Log Forwarding pane opens.

Set the Status to Off to disable the log forwarding server entry, or set it to On to enable the server entry.
Only the name of the server entry can be edited when it is disabled.

Click OK to apply your changes.

To edit a log forwarding server entry using the GUI:

Go to System Settings > Advanced > Log Forwarding > Settings.

Double-click on a server entry, right-click on a server entry and select Edit, or select a server entry then click Edit in
the toolbar. The Edit Log Forwarding pane opens.

Edit the settings as required, then click OK to apply your changes.

To edit a log forwarding server entry using the CLI:

1.

Open the log forwarding command shell:
config system log-forward

Enter an existing entry using its log forwarding ID:
edit <log forwarding ID>

Edit the settings as required. See the FortiAnalyzer CLI Reference for information.

Enter the following command to apply your changes:
end

To delete a log forwarding server entry or entries using the GUI:

Ao b=

Go to System Settings > Advanced > Log Forwarding > Settings.

Select the entry or entries you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected entry or entries.

To delete a log forwarding server entry using the CLI:

1.

Open the log forwarding command shell:
config system log-forward

Delete an entry using its log forwarding ID:
delete <log forwarding ID>
The log forwarding server entry is immediately deleted. There is no confirmation.

To delete all log forwarding entries using the CLI:

1.

Enter the following CLI command:
config system log-forward
purge
Enter y to delete all the entries.
This operation will clear all table!
Do you want to continue? (y/n)y
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Log forwarding buffer

When log forwarding is configured, FortiAnalyzer reserves space on the system disk as a buffer between the fortilogd
and logfwd daemons. In the event of a connection failure between the log forwarding client and server (network jams,
dropped connections, etc.), logs are cached as long as space remains available. When storage space is exceeded, older
logs are deleted in favor of new logs.

The default log forward buffer size is 30% of the system reserved disk size, and can be increased to use up to 80% of the
available reserved disk. Additional storage space is available by using the disk space reserved for ADOMs. When
configuring the log forward buffer size above 80% of the reserved disk size, the space available for ADOMs is reduced.

For example, in a scenario where the FortiAnalyzer has a total disk size of 275 GB for the entire system, with a system
reserved disk size of 50 GB and an ADOM disk space of 50 GB, the log forwarding buffer can be configured up to a
maximum of 90 GB (80% of the 50 GB reserved disk size = 40 GB + 50 GB disk reserved for ADOMs = 90 GB total).

The size of the system reserved disk varies by platform and total available storage. See Disk space allocation on page
127.

The log forward buffer is shared between fortilogd for all logfwd servers.

When changes are made to the log forward cache size, each server individually resets the log
reading position to the latest one, and all logs currently in the log-forward disk cache are
dropped.

To change the log forward cache size:

1. Inthe FortiAnalyzer CLI, enter the following commands:
config system global (global)#
set log-forward-cache-size [number (GB)]
2. When prompted, enter Y to confirm the change.
« When entering a number outside of the valid cache size range, an error with the valid range is displayed.

« When entering a number that uses storage from both the reserved disk size and available ADOM disk, a
message displays to indicate that the cache will be allocated from the available disk quota and reserved space.
(global) # set log-forward-cache-size 50
Log-forward disk cache will be allocated from available disk quota and reserved
space.
All logs currently in log-forward disk cache will be dropped.
Do you want to continue? (y/n)

s‘é’, The diagnose test application logfwd 3 CLIcommand can be used to display log

positions for the last log buffered and last log sent, as well as determine the buffer lag-behind.
See the FortiAnalyzer CLI Reference.

Log Fetching

Log fetching is used to retrieve archived logs from one FortiAnalyzer device to another. This allows administrators to run
queries and reports against historic data, which can be useful for forensic analysis.

FortiAnalyzer 7.4.0 Administration Guide 322
Fortinet Inc.


https://docs.fortinet.com/product/fortianalyzer/7.0

System Settings

The fetching FortiAnalyzer can query the server FortiAnalyzer and retrieve the log data for a specified device and time
period, based on specified filters. The retrieved data are then indexed, and can be used for data analysis and reports.

Log fetching can only be done on two FortiAnalyzer devices running the same firmware. A FortiAnalyzer device can be
either the fetch server or the fetching client, and it can perform both roles at the same time with different FortiAnalyzer
devices. Only one log fetching session can be established at a time between two FortiAnalyzer devices.

The basic steps for fetching logs are:

1. Onthe client, create a fetching profile. See Fetching profiles on page 323.
2. Onthe client, send the fetch request to the server. See Fetch requests on page 324.

3. Ifthis s the first time fetching logs with the selected profile, or if any changes have been made to the devices and/or

ADOMs since the last fetch, on the client, sync devices and ADOMs with the server. See Synchronizing devices and
ADOMs on page 326.

4. Onthe server, review the request, then either approve or reject it. See Request processing on page 326.
Monitor the fetch process on either FortiAnalyzer. See Fetch monitoring on page 327.
6. On the client, wait until the database is rebuilt before using the fetched data for analysis.

o

Fetching profiles

Fetching profiles can be managed from the Profiles tab on the System Settings > Advanced > Log Fetch pane.

Profiles can be created, edited, and deleted as required. The profile list shows the name of the profile, as well as the IP
address of the server it fetches from, the server and local ADOMs, and the administrator name on the fetch server.

To create a new fetching profile:

1. Onthe client, go to System Settings > Advanced > Log Feftch.

2. Select the Profiles tab, then click Create New in the toolbar, or right-click and select Create New from the menu. The
Create New Profile dialog box opens.

Create New Profile

3. Configure the following settings, then click OK to create the profile.

Name Enter a name for the profile.

Server IP Enter the IP address of the fetch server.

User Enter the username of an administrator on the fetch server, which, together
with the password, authenticates the fetch client's access to the fetch server.

Password Enter the administrator's password, which, together with the username,
authenticates the fetch client's access to the fetch server.

Peer Certificate CN Enter the certificate common name of the server.
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Ay
‘Q' The fetch server administrator user name and password must be for an administrator with
- either a Standard_User or Super_User profile.

To edit a fetching profile:

1. Go to System Settings > Advanced > Log Fetch > Profiles.

2. Double-click on a profile, right-click on a profile then select Edit, or select a profile then click Edit in the toolbar. The
Edit Profile pane opens.

3. Editthe settings as required, then click OK to apply your changes.

To delete a fetching profile or profiles:

Go to System Settings > Advanced > Log Fetch > Profiles.

Select the profile or profiles you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected profile or profiles.

Ao b=

Fetch requests

A fetch request requests archived logs from the fetch server configured in the selected fetch profile. When making the
request, the ADOM on the fetch server the logs are fetched from must be specified. An ADOM on the fetching client must
be specified or, if needed, a new one can be created. If logs are being fetched to an existing local ADOM, you must
ensure the ADOM has enough disk space for the incoming logs.

The data policy for the local ADOM on the client must also support fetching logs from the specified time period. It must
keep both archive and analytics logs long enough so they will not be deleted in accordance with the policy. For example:
Today is July 1, the ADOM's data policy is configured to keep analytics logs for 30 days (June 1 - 30), and you need to
fetch logs from the first week of May. The data policy of the ADOM must be adjusted to keep analytics and archive logs
for at least 62 days to cover the entire time span. Otherwise, the fetched logs will be automatically deleted after they are
fetched.

To send a fetch request:

1. On the fetch client, go to System Settings > Advanced > Log Fetch > Profiles.

2. Select the profile then click Request Fetch in the toolbar, or right-click and select Request Fetch from the menu. The
Fetch Logs dialog box opens.
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Fetch Logs

Name FAZVM &S

Server IP 222222.222.222

User admino

Secure Connection

Server ADOM root

Local ADOM root

Devices FortiGate-VM&4

Enable Filters

Time Period | 2017/01/30 -
| 2017/02/04 -

Index Fetched Logs

i}

Select Device 4=

3. Configure the following settings, then click Request Fetch.
The request is sent to the fetch server. The status of the request can be viewed in the Sessions tab.

Name

Server IP

User

Secure Connection

Server ADOM

Local ADOM

Devices

Enable Filters

Time Period

Index Fetch Logs

FortiAnalyzer 7.4.0 Administration Guide
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Displays the name of the fetch server you have specified.
Displays the IP address of the server you have specified.
Displays the username of the server administrator you have provided.
Select to use SSL connection to transfer fetched logs from the server.

Select the ADOM on the server the logs will be fetched from. Only one ADOM
can be fetched from at a time.

Select the ADOM on the client where the logs will be received.

Either select an existing ADOM from the dropdown list, or create a new ADOM
by entering a name for it into the field.

Add the devices and/or VDOMs that the logs will be fetched from. Up to 256
devices can be added.

Click Select Device, select devices from the list, then click OK.

Select to enable filters on the logs that will be fetched.

Select All or Any of the Following Conditions in the Log messages that match
field to control how the filters are applied to the logs.

Add filters to the table by selecting the Log Field, Match Criteria, and Value for
each filter.

Specify what date and time range of log messages to fetch.

If selected, the fetched logs will be indexed in the SQL database of the client
once they are received. Select this option unless you want to manually index
the fetched logs.
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Synchronizing devices and ADOMs

If this is the first time the fetching client is fetching logs from the device, or if any changes have been made the devices or
ADOMs since the last fetch, then the devices and ADOMs must be synchronized with the server.

To synchronize devices and ADOMs:

1.
2,

On the client, go to System Settings > Advanced > Log Fetch > Profiles.

Select the profile then click Sync Devices in the toolbar, or right-click and select Sync Devices from the menu. The
Sync Server ADOM(s) & Device(s) dialog box opens and shows the progress of the process.

Once the synchronization is complete, you can verify the changes on the client. For example, newly added devices
in the ADOM specified by the profile.

NP If anew ADOM is created, the new ADOM will mirror the disk space and data policy of the
‘?' corresponding server ADOM. If there is not enough space on the client, the client will create an
- ADOM with the maximum allowed disk space and give a warning message. You can then

adjust disk space allocation as required.

Request processing

After a fetching client has made a fetch request, the request will be listed on the fetch server in the Received Request
section on the System Settings > Advanced > Log Fetch > Sessions pane. It will also be available from the notification
center in the GUI banner.

Fetch requests can be approved or rejected.

To process the fetch request:

1.

Go to the notification center in the GUI banner and click the log fetcher request, or go to System Settings >
Advanced > Log Fetch > Sessions.

" Expand All # Collapse All

Request Time Host/Server IP User Status Action
w Received Request(1)
15:01:55 FAZVM6&4(FAZ-VMO000000001) admino € Waiting for approval :]

) Fetch Request(1)

Find the request in the Received Request section. You may have to expand the section, or select Expand All in the
content pane toolbar. The status of the request will be Waiting for approval.

Click Review to review the request. The Review Request dialog box will open.

Review Request

Host Name FAZVM&4

Serial No. FAZ-VMO0000000000

Version v5.60

User Agg

Devices ADOM Device VDOM

root FGVMEVO000000000

Filters None

Time Period 16:02 2016/01/30 - 16:02 2017/02/02

Secure Connection

=

FortiAnalyzer 7.4.0 Administration Guide 326
Fortinet Inc.



System Settings

4. Click Approve to approve the request, or click Reject to reject the request.
If you approve the request, the server will start to retrieve the requested logs in the background and send them to
the client. If you reject the request, the request will be canceled and the request status will be listed as Rejected on
both the client and the server.

Fetch monitoring

The progress of an approved fetch request can be monitored on both the fetching client and the fetch server.

Go to System Settings > Advanced > Log Fetch > Sessions to monitor the fetch progress. A fetch session can be paused
by clicking Pause, and resumed by clicking Resume. It can also be canceled by clicking Cancel.

Once the log fetching is completed, the status changes to Done and the request record can be deleted by clicking
Delete. The client will start to index the logs into the database.

It can take a long time for the client to finish indexing the fetched logs and make the analyzed

data available. A progress bar is shown in the GUI banner; for more information, click on it to
open the Rebuild Log Database dialog box.

Log and report features will not be fully available until the rebuilding process is complete.

You may need to rebuild the ADOM after the transfer is complete depending on the Log Fetch settings.
To perform post fetch actions:

Is Index Fetched Yes The ADOM is rebuilt automatically and the log fetch workflow is complete.

Logs enabled in the
Log Fetch settings? NO You will need to rebuild ADOM manually from the CLI.

Event Log

The Event Log pane provides an audit log of actions made by users on FortiAnalyzer. It allows you to view log messages
that are stored in memory or on the internal hard disk drive. You can use filters to search the messages and download
the messages to the management computer.

See the FortiAnalyzer Log Message Reference, available from the Fortinet Document Library, for more information
about the log messages.

Go to System Settings > Event Log to view the local log list.
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© Last 1 Day v Mar 29 To Mar 30 By £~
o ale
# | A $Date/Time Changes | Device D Message Operation  Performed ... SubType | User u
1 13:17:31 log| FAZVMSTM2200% User with profile ‘Super_User' login accepted from GUI(1. login GUI(10.100.5! system

2 131731 user FAZVMSTM2200% user with profile ‘Super_User' timed out from GUI(10.10( system sessiol system

3 131717 | Show system | FAZVMSTM2200% System performance status: log rate low (35%), lograte=50/sec, ms¢ Perfstats  Local system | system system

4 131710 Did not receiv FAZVMSTM2200% Did not receive any log from device FSAVMOTM23000221(FSAVM Device offline logdev system

5 131352 user FAZVMSTM2200% user with profile ‘Super_User' timed out from GUI(10.10¢ system sessiol system

6 13:12:17 | Show system | FAZVMSTM2200% System performance status: log rate low (33%), lograte=47/sec, ms¢ Perfstats  Local system | system system

7 13:09:46  Receive anup FAZVMSTM2200% Receive an update package from fds(00000.00000-2303302009): € Update Respo 208.184.237.¢ fgd update_mai
8 13:07:17 | Show system | FAZVMSTM2200% System performance status: log rate low (35%), lograte=49/sec, ms¢ Perfstats  Local system | system system

9 13:02:17 | Show system | FAZVMSTM2200% System performance status: log rate low (35%), lograte=49/sec, ms¢ Perfstats  Local system | system system

10 130210  Received logs FAZVMSTM2200% Device FSAVMOTM23000221[FSAVMOTM23000221] is back onlir Device online logdev system

11 12:59:34  Receive anup FAZVMSTM2200% Receive an update package from fds(00000.00000-2303301959): € Update Respo 208.184.237.¢ fgd update_mai
12 12:57:17 | Show system | FAZVMSTM2200% System performance status: log rate low (35%), lograte=50/sec, ms¢ Perfstats  Local system | system system

13 12:52:17 | Show system | FAZVMSTM2200% System performance status: log rate low (35%), lograte=49/sec, ms¢ Perfstats  Local system | system system
£ Total logs for analytics: 7 hours. 50 vipecll 2 3 4 5 » 18| ~0259Second

The following options are available:

Last...

Add Filter

Column

Tools

Settings

Display Raw /
Formatted Log

Real-time Log /
Historical Log

Download

Case Sensitive
Search

Pagination

The following information is shown:

#

Date/Time

Device ID

Level

User

Sub Type

Description

Select the amount of time to show from the available options, or select a custom
time span or any time.

Filter the event log list based on the log level, user, sub type, or message. See
Event log filtering on page 329.

Select which columns are enabled or disabled in the Event Log table.

Click on Display Raw to view the logs in their raw state.
Click Formatted Log to view logs formatted into a table.

Click to view the real-time or historical logs list.

Download the event logs in either CSV or the normal format to the management
computer.

Enable or disable case sensitive searching.

Browse the pages of logs and adjust the number of logs that are shown per page.

The log number.
The date and time that the log file was generated.
The ID of the related device.

The severity level of the message. For a description of severity levels, see the Log
Message Reference.

The user that the log message relates to.

The event log subtype. For a description of the subtypes for event logs, see the
Log Message Reference.

A description of the event.
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Operation

Performed On

Changes

Message

Event log filtering

The change or operation that triggered the event.

Entity affected by the change or operation. For example, when you log out of the
FortiAnalyzer GUI, the operation is performed on the local FortiAnalyzer GUI.

Details of the change.

Log message details. A Session ID is added to each log message. The username
of the administrator is added to log messages wherever applicable for better

traceability.

The event log can be filtered using the Add Filter box in the toolbar.

To filter event log results using the toolbar:

1. Specify filters in the Add Filter box.
« Filter mode: Click in the Add Filter box, select a filter from the dropdown list, then type a value.
« Text Mode: Click the Switch to Text Mode icon at the right end of the Add Filter box to switch to text mode. In
this mode, you can type in the whole search criteria.
Click the Switch to Filter Mode icon to return to filter mode.
Additional search operators such as "And", "Or", and "Not" can be used in event log filtering. Click the help icon
next to the filter bar in the GUI for additional information.

2. Click Goto apply the filter.

Task Monitor

Use the task monitor to view the status of the tasks you have performed.

Go to System Settings > Advanced > Task Monitor to view the task monitor. The task list size can also be configured;
see Miscellaneous Settings on page 340.

To filter the information in the monitor, enter a text string in the search field.

© Show Status v

ID+ | Source Description

150 | Device Manager | Add/delete Unauthorized Devices

149 | Device Manager = Add Multiple Devices

148 | Device Manager = Add/delete Unauthorized Devices

147 | Device Manager | Add/delete Unauthorized Devices

146 | Device Manager | Delete Device

145 | Device Manager | Delete Device

144 | Device Manager = Add/delete Unauthorized Devices

143 | Device Manager = Add Multiple Devices

0O 0O 00O 0O 0O o0 o oaog

142 | Device Manager | Add/delete Unauthorized Devices

]

Mavica Mananar | Add /dalate | inatharizad Navicac

User

A

> > >» > > >» > >

>

admin

admin

admin

admin

admin

admin

admin

admin

admin

ardmin

Status

@Success: 1 <

@success: 7

@Success: 1

@Success: 1

@Success: 1

@Success: 1 <

@Success: 1

@success: 7

@Success: 1

A1 oce 1

The following options are available:
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e

ADOM

root

root

root

root

root

root

root

root

root

Start Time

Fri Nov 18 2022 9:28:11 AM

Fri Nov 18 2022 9:27:50 AM

Wed Nov 02 2022 10:24:4...

Wed Nov 02 2022 10:24:4...

Fri Sep 09 2022 3:56:54 PM

Fri Sep 09 2022 3:56:48 PM

Fri Sep 09 2022 3:56:36 PM

Tue Sep 06 2022 6:04:25 PM

Tue Sep 06 2022 3:53:28 PM

Thi Auie 11 9199 0.15.25 D

Search

End Time u

Fri Nov 18 2022 9:28:11
Fri Nov 18 2022 9:27:51
Wed Nov 02 2022 10:24
Wed Nov 02 2022 10:24
Fri Sep 09 2022 3:56:56
Fri Sep 09 2022 3:56:48
Fri Sep 09 2022 3:56:38
Tue Sep 06 2022 6:04:2¢
Tue Sep 06 2022 3:53:2€

Thi Auie 11 9099 0.15.90

1% 152/152
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Group Error Devices Create a group of the failed devices, allowing for re-installations to be done only
on the failed devices.

Delete Remove the selected task or tasks from the list.
This changes to Cancel Running Task(s) when View is Running.

View Task Detail View the task Index, Name, Status, Time Used, and History, in a new window.

Click the icons in the History column to view the following information:

e History

» Promotion of device in FortiAnalyzer with autolink

¢ Upgrade remote device firmware

« Retrieve remote device configuration

« Installation of device templates

« Installation of policy packages

¢ Execution of additional scripts
To filter the information in the task details, enter a text string in the search field.
This can be useful when troubleshooting warnings and errors.

Show Status Select which tasks to view from the dropdown list, based on their status. The
available options are: All, Pending, Running, Canceling, Canceled , Done, Error,
Aborting, Aborted, and Warning.

Column Settings Select the columns you want to display from the dropdown.

The following information is available:

ID The identification number for a task.
Source The platform from where the task is performed.
Description The nature of the task. Double-click the task to display the specific actions taken

under this task.
User The user or users who performed the tasks.

Status The status of the task:
e Success: Completed with success.
e Error: Completed without success.
» Canceled: User canceled the task.
e Canceling: User is canceling the task.
e Aborted: The FortiAnalyzer system stopped performing this task.
e Aborting: The FortiAnalyzer system is stopping performing this task.

* Running: Being processed. In this status, a percentage bar appears in the
Status column.

* Pending
e Warning
Time Used The number of seconds to complete the task.
ADOM The ADOM associated with the task.
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Start Time The time that the task was started.

End Time The time that the task was completed.

Mail Server

A mail server allows the FortiAnalyzer to sent email messages, such as notifications when reports are run or specific
events occur. Mail servers can be added, edited, deleted, and tested.

Go to System Settings > Advanced > Mail Server to configure SMTP mail server settings.

Ay
‘?' If an existing mail server is in use, the delete icon is removed and the mail server entry cannot
be deleted.

To add a mail server:

1. Go to System Settings > Advanced > Mail Server.
2. Click Create New in the toolbar. The Create New Mail Server Settings pane opens.

Create New Mail Server Settings x

3. Configure the following settings and then select OK to create the mail server.

SMTP Server Name Enter a name for the SMTP server.

Mail Server Enter the mail server information.

SMTP Server Port Enter the SMTP server port number. The default port is 25.

Enable Authentication Enable or disable authentication.

Email Account Enter an email account. This option is only accessible when authentication is
enabled.

Password Enter the email account password. This option is only accessible when

authentication is enabled.

From (Optional) Optionally, set the default username for sending.

To edit a mail server:

1. Go to System Settings > Advanced > Mail Server.
2. Double-click on a server, right-click on a server and then select Edit from the menu, or select a server then click Edit
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in the toolbar. The Edit Mail Server Settings pane opens.
3. Edit the settings as required, and then click OK to apply the changes.

To test the mail server:

Go to System Settings > Advanced > Mail Server.

Select the server you need to test.

Click Test from the toolbar, or right-click and select Test.

Type the email address you would like to send a test email to and click OK. A confirmation or failure message will be
displayed.

Click OK to close the confirmation dialog box.

o bd-=

@

To delete a mail server or servers:

Go to System Settings > Advanced > Mail Server.

Select the server or servers you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Click OK in the confirmation box to delete the server.

o bN-=

Syslog Server

Go to System Settings > Advanced > Syslog Server to configure syslog server settings. Syslog servers can be added,
edited, deleted, and tested.

After adding a syslog server, you must also enable FortiAnalyzer to send local logs to the syslog server. See Send local
logs to syslog server on page 334.

Ay
‘?' If an existing syslog server is in use, the delete icon is removed and the server entry cannot be
deleted.

To add a syslog server:

1. Go to System Settings > Advanced > Syslog Server.
2. Click Create New in the toolbar. The Create New Syslog Server Settings pane opens.

Create New Syslog Server Settings x

Name |

FQDN/IP

Local Certificate CN Fortinet_Local

Peer Certificate CN
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3. Configure the following settings and then select OK to create the syslog server.

Name
IP address (or FQDN)
Syslog Server Port

Reliable Connection

Secure Connection

Local Certificate CN

Peer Certificate CN

Enter a name for the syslog server.
Enter the IP address or FQDN of the syslog server.
Enter the syslog server port number. The default port is 514.

Enable or disable a reliable connection with the syslog server. The default is
disable.

Enable/disable connection secured by TLS/SSL. The default is disable.
This option is only available when Reliable Connection is enabled.

Enter one of the available local certificates used for secure connection:
Fortinet_Local or Fortinet_Local2. The default is Fortinet _Local.

This option is only available when Secure Connection is enabled.

Enter the certificate common name of syslog server. Null means no certificate
CN for the syslog server.

This option is only available when Secure Connection is enabled.

To enable sending FortiAnalyzer local logs to syslog server:

1. Go to System Settings > Advanced > Syslog Server.

2. Double-click on a server, right-click on a server and then select Edit from the menu, or select a server then click Edit
in the toolbar. The Edit Syslog Server Settings pane opens.

3. Editthe settings as required, and then click OK to apply the changes.

To edit a syslog server:

1. Go to System Settings > Advanced > Syslog Server.

2. Double-click on a server, right-click on a server and then select Edit from the menu, or select a server then click Edit
in the toolbar. The Edit Syslog Server Settings pane opens.

3. Editthe settings as required, and then click OK to apply the changes.

To test the syslog server:

1. Go to System Settings > Advanced > Syslog Server.

2. Select the server you need to test.

3. Click Test from the toolbar, or right-click and select Test.
A confirmation or failure message will be displayed.

To delete a syslog server or servers:

P obh-=
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Send local logs to syslog server

After adding a syslog server to FortiAnalyzer, the next step is to enable FortiAnalyzer to send local logs to the syslog
server. See Syslog Server on page 332.

You can only enable these settings by using the CLI.

config system locallog syslogd setting
set severity information
set status enable
set syslog-name <syslog server name>
end

Meta Fields

Meta fields allow administrators to add additional attributes to objects and administrators. You can make meta fields
required or optional.

When meta fields are required, administrators must supply additional information when they create an associated object.
For example, if you create a required meta field for a device object, administrators must define a value for that meta field
for all devices.

Go to System Settings > Advanced > Meta Fields to configure meta fields. Meta fields can be added, edited, and deleted.

D & Collapse All | | &1 Expand All Search.

Meta Fields + Length + Importance Status &
por

150 Optional Enabled

50 Optional Enabled
50 Optional Enabled
50 Optional Enabled

50 Optional Enabled
50 Optional Enabled

Al
‘Q' Select Expand All or Collapse All from the toolbar or right-click menu to view all or none of the

meta fields under each object.

To create a new meta field:

1. Go to System Settings > Advanced > Meta Fields.
2. Click Create New in the toolbar. The Create New Meta Field pane opens.

Create New Meta Fields x

Object System Administrator -
Name test

Length 20 -

Importance Optional
Status. ©
[ o |
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3. From the Object field, select an object.
Some objects also allow you to define a value for the meta field for each device.

Object The object this metadata field applies to: Administrative Domains, Devices,
Device Groups, Device VDOM, or System Administrator.

4. Configure the following settings:

Name Enter the label to use for the field.
When you type the name, a variable name is automatically created.

Length Select the maximum number of characters allowed for the field from the
dropdown list: 20, 50, or 255.

Importance Select Required to make the field compulsory; otherwise, select Optional.
Status Disable/enable the field. The default selection is Enabled.
5. Click OK.

The meta field is created.

To edit a meta field:

1. Go to System Settings > Advanced > Meta Fields.

2. Double-click on a field, right-click on a field and then select Edit from the menu, or select a field then click Editin the
toolbar. The Edit Meta Fields pane opens.

3. Editthe settings as required, and then click OK to apply the changes.

Al
S L4
? The Object and Name fields cannot be edited.

To delete a meta field or fields:

Go to System Settings > Advanced > Meta Fields.

Select the field or fields you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Click OK in the confirmation box to delete the field or fields.

o bd-=

\,
S r'd
? The default meta fields cannot be deleted.

Device logs

The FortiAnalyzer allows you to log system events to disk. You can control device log file size and the use of the
FortiAnalyzer unit’s disk space by configuring log rolling and scheduled uploads to a server.
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As the FortiAnalyzer unit receives new log items, it performs the following tasks:
¢ Verifies whether the log file has exceeded its file size limit.
¢ Checks to seeif it is time to roll the log file if the file size is not exceeded.

When a current log file (t 1og . 10g) reaches its maximum size, or reaches the scheduled time, the FortiAnalyzer unit
rolls the active log file by renaming the file. The file name will be in the form of x10g.N. 1og (for example,
tlog.1252929496.10g), where x is a letter indicating the log type and N is a unique number corresponding to the time
the first log entry was received. The file modification time will match the time when the last log was received in the log file.

Once the current log file is rolled into a numbered log file, it will not be changed. New logs will be stored in the new
currentlog called t1og. 1og. Iflog uploading is enabled, once logs are uploaded to the remote server or downloaded via
the GUI, they are in the following format:

FG3K6A3406600001-t10g.1252929496.10g-2017-09-29-08-03-54.9gz

If you have enabled log uploading, you can choose to automatically delete the rolled log file after uploading, thereby
freeing the amount of disk space used by rolled log files. If the log upload fails, such as when the FTP server is
unavailable, the logs are uploaded during the next scheduled upload.

Log rolling and uploading can be enabled and configured using the GUI or CLI.

Configuring rolling and uploading of logs using the GUI

Go to System Settings > Advanced > Device Log Setting to configure device log settings.

Device Log Settings
Registered Device Logs

Roll log file when size exceeds 200 MB (10-1000)

Roll log files at scheduled time ©

FQDN/IP

Remote Directory

Upload Log Files When Rolled [JIeRINS Hour

Upload log files in gzip file format o

Delete log files after uploading o

Upload logs to cloud storage -

Local Device Log

Send the local e

©
FortiAnalyzer/FortiManager

FQDN/IP FQDN/IP

Upload Option Schedule Time

Severity Level Emergency -

Reliable log transmission

Apply
Configure the following settings, and then select Apply:

Registered Device Logs
Roll log file when size exceeds Enter the log file size, from 10 to 500MB. Default: 200MB.

Roll log files at scheduled time Select to roll logs daily or weekly.
¢ Daily: select the hour and minute value in the dropdown lists.
* Weekly: select the day, hour, and minute value in the dropdown
lists.
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Upload logs using a standard file
transfer protocol

Upload Server Type
Upload Server IP
User Name
Password

Remote Directory

Upload Log Files

Upload rolled files in
gzip file format

Delete files after
uploading

Local Device Log

Send the local event logs to
FortiAnalyzer / FortiManager

IP Address

Upload Option

Severity Level
Reliable log
transmission

Secure connection

Peer Certificate CN

Select to upload logs and configure the following settings.

Select one of FTP, SFTP, or SCP.

Enter the IP address of the upload server.

Enter the username used to connect to the upload server.
Enter the password used to connect to the upload server.

Enter the remote directory on the upload server where the log will be
uploaded.

Select to upload log files when they are rolled according to settings
selected under Roll Logs, or daily at a specific hour.

Select to gzip the logs before uploading. This will result in smaller logs
and faster upload times.

Select to remove device log files from the FortiAnalyzer system after
they have been uploaded to the Upload Server.

Select to send local event logs to another FortiAnalyzer or
FortiManager device.

Enter the IP address of the FortiAnalyzer or FortiManager.

Select to upload logs in real time or at a scheduled time.

When selecting a scheduled time, you can specify the hour and minute
to upload logs each day.

Select the minimum log severity level from the dropdown list. This
option is only available when Upload Option is Realtime.

Select to use reliable log transmission.

Select to use a secure connection for log transmission. This option is
only available when Reliable log transmission is selected.

Enter the certificate common name of syslog server. Null means no
certificate CN for the syslog server.

This option is only available when Reliable log transmission is enabled.

Configuring rolling and uploading of logs using the CLI

Log rolling and uploading can be enabled and configured using the CLI. For more information, see the FortiAnalyzer CLI

Reference.

Enable or disable log file uploads

Use the following CLI commands to enable or disable log file uploads.
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To enable log uploads:

config system log settings
config rolling-regular
set upload enable

end

To disable log uploads:

config system log settings
config rolling-regular
set upload disable

end

Roll logs when they reach a specific size

Use the following CLI commands to specify the size, in MB, at which a log file is rolled.

To roll logs when they reach a specific size:

config system log settings
config rolling-regular
set file-size <integer>

end

Roll logs on a schedule

Use the following CLI commands to configure rolling logs on a set schedule, or never.

To disable log rolling:

config system log settings
config rolling-regular
set when none

end

To enable daily log rolling:

config system log settings
config rolling-regular
set upload enable
set when daily
set hour <integer>
set min <integer>

end

To enable weekly log rolling:

config system log settings
config rolling-regular
set when weekly
set days {mon | tue
set hour <integer>

fri | sat | sun}

| wed | thu
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set min <integer>
end

Upload logs to cloud storage

The FortiAnalyzer can be set to upload logs to cloud storage. Before enabling this feature, you must have a valid Storage
Connector Service license. See License Information widget on page 49.

For information on setting up a storage fabric connector, see Creating or editing storage connectors on page 153.

To upload logs to cloud storage:

1. Go to System Settings > Advanced > Device Log Settings.
2. Select Create New.
3. Complete the following options, and click OK.
« Enter a name for the cloud storage.
« Inthe Cloud Storage Connector list, select a Fabric Connector.
» Inthe Remote Path box, type the bucket or container name from the storage account.

Certificates required for cloud storage

Before logs can be uploaded to cloud storage using Amazon S3, Azure Blob, or Google connectors, the cloud provider's
CA certificate(s) must be imported into FortiAnalyzer.

Third-party CA certificates, for example GlobalSign and CyberTrust, may be required. Check with your cloud storage
provider to see which CA certificates are supported.

For information on how to import certificates into FortiAnalyzer, see CA certificates on page 313.

File Management

FortiAnalyzer allows you to configure automatic deletion of device log files, quarantined files, reports, and content
archive files after a set period of time.

Go to System Settings > Advanced > File Management to configure file management settings.

File Management

Automatically Delete

“«

Scheduled daily at time | 00:00 +

Device log files old Days

Scheduled daily at time | 00:00 +

Reports older than Days

“«

000

Scheduled daily at time | 00:00 +

ive files older Days

“«

Quarantined files older than ~ QB Days Scheduled daily at time | 00:00 +

“«

Apply

Configure the following settings, and then select Apply:

Device log files older than Select to enable automatic deletion of compressed log files.
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Enter a value in the text field, select the time period (Days, Weeks, or Months),
and choose a time of day.

Reports older than Select to enable automatic deletion of reports of data from compressed log files.
Enter a value in the text field, select the time period, and choose a time of day.

Content archive files older Select to enable automatic deletion of IPS and DP archives from Archive logs.
than Enter a value in the text field, select the time period, and choose a time of day.
Quarantined files older than Select to enable automatic deletion of compressed log files of quarantined files.

Enter a value in the text field, select the time period, and choose a time of day.

The time period you select determines how often the item is checked. If you select Months, then the item is checked
once per month. If you select Weeks, then the item is checked once per week, and so on. For example, if you specify
Device log files older than 3 Months, then on July 1, the logs for April, May, and June are kept and the logs for March and
older are deleted.

Miscellaneous Settings

Go to System Settings > Advanced > Misc Settings to view and configure advanced settings and download WSDL files.

Configure the following settings and then select Apply:

ADOM Mode Select the ADOM mode, either Normal or Advanced.

Advanced mode will allow you to assign a VDOM from a single device to a
different ADOM, but will result in more complicated management scenarios. It is
recommended only for advanced users.

Download WSDL file Select the required WSDL functions then click the Download button to download
the WSDL file to your management computer.

When selecting Legacy Operations, no other options can be selected.

Web services is a standards-based, platform independent, access method for
other hardware and software APIs. The file itself defines the format of commands
the FortiAnalyzer will accept as well as the responses to expect. Using the WSDL
file, third-party or custom applications can communicate with the FortiAnalyzer
unit and operate it or retrieve information, just as an administrator can from the
GUI or CLL.

Task List Size Set a limit on the size of the task list. Default: 2000.

FortiGuard

This section includes information on FortiGuard for FortiAnalyzer, and includes the following topics:

« Subscribing FortiAnalyzer to FortiGuard on page 341
» Licensingin an air-gap environment on page 341
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Subscribing FortiAnalyzer to FortiGuard

To keep your FortiAnalyzer threat database up to date:

o Ensure your FortiAnalyzer can reach FortiGuard at fds1.fortinet.com.

o Purchase a FortiGuard Indicators of Compromise Service license and apply that license to the product registration.
No change is needed on the FortiAnalyzer side.

To subscribe FortiAnalyzer to FortiGuard:

1. Goto Dashboard.
2. Inthe License Information widget, find the FortiGuard > Indicators of Compromise Service field and click Purchase.

3. After purchasing the license, check that the FortiGuard > Indicators of Compromise Service is Licensed and shows
the expiry date.

Licensing in an air-gap environment

When performing the initial setup of FortiAnalyzer, you are required to register your FortiAnalyzer to FortiCare, which
typically requires internet access. While operating in a closed network or air-gap environment, you must complete this
step by uploading the entitlements file through the FortiAnalyzer CLI.

To register FortiAnalyzer in an air-gap environment:

1. InFortiAnalyzer, disable access to the public FortiGuard Distribution Servers (FDS) using the following
CLI commands:
config fmupdate publicnetwork
set status disable
end

2. Connectto the FortiAnalyzer GUI, and on the FortiAnalyzer login screen, click Upload License.

FortiAnalyzer 7.4.0 Administration Guide 341
Fortinet Inc.



System Settings

FortiAnalyzer-VMé4

This product requires a valid license. You could log in to
FortiCloud to activate your purchased license, or use a free trial
license.

® Free Trial
) Activate License

Login with FortiCloud

Register with FortiCloud

Upload license

3. Click Browse to select your FortiAnalyzer license or drag-and-drop the license file, and click Upload.

Upload License File

Upload file by drag & drop here or  Browse

Upload Cancel

The license file will be applied, and the FortiAnalyzer will be restarted in order to verify the license.

4. Signin to FortiAnalyzer.
The FortiAnalyzer Setup Wizard is displayed.
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FortiAnalyzer Setup - Register and SSO with FortiCare (2/4)

Register with FortiCare

Serial Number

Account ID/Email

Password

Country/Region

Reseller

SSO with FortiCloud

FortiCloud Single Sign-on €@

FAZ-VMTM22003795

Register Forgot your password?
Click to select -
Click to select -

[ @)

In order to access your FortiAnalyzer, it must be registered to FortiCare in the FortiAnalyzer Setup Wizard.
5. On FortiCloud, create a ticket for your FortiAnalyzer entitlements file, and Fortinet Customer Service will provide you

with the file.

6. You can upload your entitlement file either through the setup wizard or through the FortiAnalyzer CLI.

a. Onboarding wizard:

i. Select Import the Entitlement File in the FortiAnalyzer Setup wizard.
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ii. Drag and drop the entitlement file into the import area, or click Add Files to select the file location.

FortiAnalyzer Setup - Welcome (1/4)

Welcome

Perform the following steps to complete the setup of this FortiAnalyzer.

1. Register and SSO with FortiCare
Import the Entitlement File

Add files by drag & drop here or Add Files

2. Specify Hostname
3. Change Your Password v

4. Upgrade Firmware v

b. Command line interface:
i. Open the FortiAnalyzer CLI.
ii. Upload the entitlement file using the following command.

execute fmupdate <ftp | scp | tftp> import license <filename> <server> <port>
<directory> <username> <password>

The <port> variable is only required when connecting to a remote SCP host. The
ﬂ <directory>, <username>, and <password> variables are only required for
I logging into a FTP server or SCP host to download the file. For more information,
see the FortiAnalyzer CLI Reference.

For example:
execute fmupdate ftp import license entitlement-file 172.10.1.10 /pub/place
userl passwordl
This operation will replace the current package!
Do you want to continue? (y/n)y

Start getting file from FTP Server...

Transferred 0.001M of 0.001M in 0:00:00s (0.008M/s)
FTP transfer is successful.

Package installation is in process...
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This could take some time.
Update successfully

7. The FortiAnalyzer Setup wizard will display that you are successfully registered with FortiCare.

FortiAnalyzer Setup

Welcome

Perform the following steps to complete the setup of this FortiAnalyzer.

1. Register and S50 with FortiCare v
2. Specify Hostname
3. Change Your Password

4. Upgrade Firmware v
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The System Settings administrator menus enable you to configure administrator accounts, access profiles, remote
authentication servers, and adjust global administrative settings for the FortiAnalyzer unit.

Administrator accounts are used to control access to the FortiAnalyzer unit. Local and remote authentication is
supported, as well as two-factor authentication. Administrator profiles define different types of administrators and the
level of access they have to the FortiAnalyzer unit, as well as its authorized devices.

Global administration settings, such as the GUI language and password policies, can be configured on the Admin
Settings pane. See Global administration settings on page 375 for more information.

This section contains the following topics:

o Trusted hosts on page 346

o Monitoring administrators on page 346

» Disconnecting administrators on page 347

« Managing administrator accounts on page 347
o Administrator profiles on page 355

» Authentication on page 362

o Global administration settings on page 375

» Two-factor authentication on page 380

Trusted hosts

Setting trusted hosts for all of your administrators increases the security of your network by further restricting
administrative permissions. In addition to knowing the password, an administrator must connect only through the subnet
or subnets you specify. You can even restrict an administrator to a single IP address if you define only one trusted host
IP address with a netmask of 255.255.255.255.

When you set trusted hosts for all administrators, the FortiAnalyzer unit does not respond to administrative access
attempts and cannot be pinged from any other hosts. This provides the highest security. If you leave even one
administrator unrestricted, the unit accepts administrative access attempts on any interface that has administrative
access enabled, potentially exposing the unit to attempts to gain unauthorized access.

The trusted hosts you define apply to both the GUI and to the CLI when accessed through SSH. CLI access through the
console connector is not affected.

Ay
‘Q' If you set trusted hosts and want to use the Console Access feature of the GUI, you must also
- set 127.0.0.1/255.255.255.255 as a trusted host.

Monitoring administrators

The Admin Session List lets you view a list of administrators currently logged in to the FortiAnalyzer unit.
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To view logged in administrators:

1.
2,

Go to Dashboard.

In the System Information widget, in the Current Administrators field, click the Current Session List button. The
Admin Session List opens in the widget.

The following information is available:

User Name The name of the administrator account. Your session is indicated by (current).

IP Address The IP address where the administrator is logging in from. This field also displays the
logon type (GUI, jsconsole, or SSH).

Start Time The date and time the administrator logged in.

Time Out (mins) The maximum duration of the session in minutes (1 to 480 minutes).

Disconnecting administrators

Administrators can be disconnected from the FortiAnalyzer unit from the Admin Session List.

To disconnect administrators:

1.
2,

Go to Dashboard.

In the System Information widget, in the Current Administrators field, click the Current Session List button. The
Admin Session List opens in the widget.

Select the administrator or administrators you need to disconnect.
Click Delete in the toolbar, or right-click and select Delete.
The selected administrators will be automatically disconnected from the FortiAnalyzer device.

Managing administrator accounts

Go to System Settings > Administrators to view the list of administrators and manage administrator accounts.

Only administrators with the Super_User profile can see the complete administrators list. If you do not have certain

viewing permissions, you will not see the administrator list. When ADOMs are enabled, administrators can only access

the ADOMs they have permission to access.

- B " Searc!
O | Name+ Type = Profile + JSON API Access + ADOMs + Trusted IPv4 Hosts + u
& System Administrator (4)
a A admin LOCAL Super_User Read & Write AllADOMs 0.0.0.0/0.0.00
a fortinet LOCAL restrictive None all_adoms 0.0.0.0/0.0.0.0
O E em LOCAL Super_User None All ADOMs 0.0.0.0/0.0.00
o AQA‘ min LOCAL Super_User None AllADOMs 0.0.0.0/0.0.00
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The following options are available:
Create New
Edit
Clone
Move

Delete

Table View/Tile View

Column Settings
Search

Change Password

The following columns are available:
#
Name
Type
Profile
JSON API Access
ADOMs
Comments

Trusted IPv4 Hosts
Trusted IPv6 Hosts
Contact Email

Contact Phone

Creating administrators

Create a new administrator. See Creating administrators on page 348.
Edit the selected administrator. See Editing administrators on page 353.
Clone the selected administrator.

Move the adminstrator to a different sequence in the table.

Delete the selected administrator or administrators. See Deleting administrators
on page 354.

Change the view of the administrator list.

Table view shows a list of the administrators in a table format. Tile view shows a
separate card for each administrator in a grid pattern.

Change the displayed columns.
Search the administrators.

Change the selected administrator's password. This option is only available from
the right-click menu. See Editing administrators on page 353.

The sequence number.

The name the administrator uses to log in.

The user type, as well as if the administrator uses a wildcard.

The profile applied to the administrator. See Administrator profiles on page 355
The administrators read/write privileges for JSON API.

The ADOMs the administrator has access to or is excluded from.

Comments about the administrator account. This column is hidden by default.

The IPv4 trusted host(s) associated with the administrator. See Trusted hosts on
page 346.

The IPv6 trusted host(s) associated with the administrator. See Trusted hosts on
page 346. This column is hidden by default.

The contact email associated with the administrator. This column is hidden by
default.

The contact phone number associated with the administrator. This column is
hidden by default.

To create a new administrator account, you must be logged in as a super user administrator.
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You need the following information to create an account:

« Which authentication method the administrator will use to log in to the FortiAnalyzer unit. Local, remote, and Public
Key Infrastructure (PKI) authentication methods are supported.

« What administrator profile the account will be assigned, or what system privileges the account requires.
o If ADOMs are enabled, which ADOMs the administrator will require access to.
« Ifusing trusted hosts, the trusted host addresses and network masks.

Ay
‘Q' For remote or PKI authentication, the authentication must be configured before you create the
- administrator. See Authentication on page 362 for details.
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To create a new administrator:

1.
2,

Create New Administrator

User Mame
Aatar

Description

Admin Type

Mew Password
Confirm Password
FortiToken Cloud
Administrative Domain
Admin Profile

JSON AP| Access
Theme Mode

Trusted Hosts

Meta Fields >

Advanced Options ~

change-password

ext-auth-accprofile-override

ext-auth-adom-override
ext-auth-group-match
fingerprint

first-name

last-name

login-max

pager-number

Go to System Settings > Administrators.
In the toolbar, click Create New > Administrator to display the Create New Administrator pane.

o= Add Photo -

LOCAL

FortiToken Mobile | Email | SMs

All ADOMSs All ADOMs except specified ones
Restricted_User

Mone

Use Global Theme LUze Own Theme

»

enable
disable
disable
undefined
undefined
undefined
undefined
32

undefined

Specify

3. Configure the following settings, and then click OK to create the new administrator.

User Name

Avatar

Enter the name of the administrator will use to log in.

Apply a custom image to the administrator.
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Comments

Admin Type

Server or Group

Match all users on remote
server

Subject

CA

Required two-factor

authentication

New Password

Confirm Password
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Click Add Photo to select an image already loaded to the FortiAnalyzer, or to
load an new image from the management computer.

If no image is selected, the avatar will use the first letter of the user name.

Optionally, enter a description of the administrator, such as their role, location,
or the reason for their account.

Select the type of authentication the administrator will use when logging into
the FortiAnalyzer unit. One of: LOCAL, RADIUS, LDAP, TACACS+, PKI,
Group, or SSO. See Authentication on page 362 for more information.

Select the RADIUS server, LDAP server, TACACS+ server, or group, as
required.

The server must be configured prior to creating the new administrator.
This option is not available if the Admin Type is LOCAL or PKI.

Select this option to automatically add all users from a LDAP server specified
in Admin>Remote Authentication Server. All users specified in the
Distinguished Name field in the LDAP server will be added as FortiManager
users with the selected Admin Profile.

Select this option when the Admin Type is SSO to create one SAML SSO
wildcard admin user to match all users on the identity provider (IdP) server.
This FortiAnalyzer must be configured as a service provider (SP), added to the
IdP, and have the same user profile and ADOM names as the IdP. If this is
done, the user is assigned the same profile and ADOMs when logging in as an
SSO user on this SP. See SAML admin authentication on page 370.

If this option is not selected, the User Name specified must exactly match the
LDAP user specified on the LDAP server.

This option is not available if the Admin Type is LOCAL or PKI.

Enter a comment for the PKI administrator.
This option is only available if the Admin Type is PKI.

Select the CA certificate from the dropdown list.
This option is only available if the Admin Type is PKI.

Select to enable two-factor authentication.
This option is only available if the Admin Type is PKI.

Enter the password.
This option is not available if Match all users on remote serveris selected.

If the Admin Type is PKI, this option is only available when Require two-factor
authentication is selected.

If the Admin Type is RADIUS, LDAP, or TACACS+, the password is only used
when the remote server is unreachable.

Enter the password again to confirm it.
This option is not available if Match all users on remote serveris selected.

If the Admin Type is PKI, this option is only available when Require two-factor
authentication is selected.
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Force this administrator to
change password upon next
log on.

FortiToken Cloud

Administrative Domain

Admin Profile

JSON API Access

Trusted Hosts

Theme Mode

Meta Fields

Advanced Options
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Force the administrator to change their password the next time that they log in
to the FortiAnalyzer.

This option is only available if Password Policy is enabled in Admin Settings.
See Password policy on page 377.

Enable or disable two-factor authentication with FortiToken Cloud, then select
the token delivery method from the following options:

* FortiToken Mobile: Use the FortiToken Mobile app to get tokens. The
administrator is sent an email with a link to activate their token in the
FortiToken Mobile app on their mobile device.

* Email: Receive the token by email.

e SMS: Receive the token by SMS message.

This option is not available if Admin Type is set to PK/ or SSO. See Two-factor
authentication on page 380.

Choose the ADOM s this administrator will be able to access.

¢ AllADOMs: The administrator can access all the ADOMs.

e Al ADOMs except specified ones: The administrator cannot access the
selected ADOMs.

» Specify: The administrator can access the selected ADOMs. Specifying
the ADOM shows the Specify Device Group to Access check box. Select
the Specify Device Group to Access check box and select the Device
Group this administrator is allowed to access. The newly created
administrator will only be able to access the devices within the Device
Group and sub-groups.

If the Admin Profile is Super_User, then this setting is All ADOMs.
This field is available only if ADOMs are enabled. See Administrative Domains
(ADOMSs) on page 302.

Select an administrator profile from the list. The profile selected determines
the administrator’s access to the FortiAnalyzer unit’s features. See
Administrator profiles on page 355.

Select the permission for JSON API Access. Select Read-Write, Read, or
None. The default is None.

Optionally, turn on trusted hosts, then enter their IP addresses and netmasks.
Up to ten IPv4 and ten IPv6 hosts can be added.

See Trusted hosts on page 346 for more information.

Select Use Global Theme to apply a theme to all administrator accounts.
Select Use Own Theme to allow administrators to select their own theme.

Optionally, enter the new administrator's email address and phone number.

Configure advanced options, see Advanced options below.

For more information on advanced options, see the FortiAnalyzer CLI
Reference.
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Advanced options

Option Description Default
change-password Enable or Disable changing password. disable
ext-auth-accprofile- Enable or Disable overriding the account profile by administrators disable
override configured on a Remote Authentication Server.

ext-auth-adom-override Enable or Disable overriding the ADOM by administrators configured disable
on a Remote Authentication Server. This will also override the Admin
Profile configured for each ADOM.

ext-auth-group-match Specify the group configured on a Remote Authentication Server. -

fingerprint Specify the user certificate fingerprint based on MD5, SHA-1, or SHA- -
256 hash function.

This option is only available if the Admin Type is PKI.

first-name Specify the first name. -
last-name Specify the last name. -
mobile-number Specify the mobile number. -
pager-number Specify the pager number. -
restrict-access Enable or Disable restricted access. disable

Editing administrators

To edit an administrator, you must be logged in as a super user administrator. The administrator's name cannot be
edited. An administrator's password can be changed using the right-click menu, if the password is not a wildcard.

To edit an administrator:

1. Go to System Settings > Administrators.

2. Double-click on an administrator, right-click on an administrator and then select Edit from the menu, or select the
administrator then click Edit in the toolbar. The Edit Administrator pane opens.

3. Editthe settings as required, and then select OK to apply the changes.

To change an administrator's password:

1. Go to System Settings > Administrators.

2. Right-click on an administrator and select Change Password from the menu. The Change Password dialog box
opens.
3. Ifyou are editing the admin administrator's password, enter the old password in the Old Password field.
4. Enterthe new password for the administrator in the New Password and Confirm Password fields.
5. Select OKto change the administrator's password.
\‘ : ’I
q The current administrator's password can also be changed from the admin menu in the GUI
- banner. See GUI overview on page 22 for information.
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Deleting administrators

To delete an administrator or administrators, you must be logged in as a super user administrator.

Al
S L4
? You cannot delete an administrator that is currently logged in to the device.
Al
S L4
9 The admin administrator can only be deleted using the CLI.

To delete an administrator or administrators:

Go to System Settings > Administrators.

Select the administrator or administrators you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Select OKin the confirmation box to delete the administrator or administrators.

o bd-=

To delete an administrator using the CLI:

1. Open a CLI console and enter the following command:
config system admin user
delete <username>
end

Override administrator attributes from profiles

FortiAnalyzer administrator accounts can be configured to use the RPC Permit (JSON API Access) and Trusted Hosts
attributes that are defined by an administrator profile.

When an administrator has been configured to use the attributes from the profile, the attributes can no longer be
changed by editing the administrator account.

This feature can only be configured from the FortiAnalyzer CLI.

For more information, see the FortiAnalyzer CLI Reference Guide on the Fortinet Document Library.

To use RPC Permit and Trusted Host administrator attributes from a profile:

1. Go to System Settings > Administrators, and create or edit an admin user.
2. In Admin Profile dropdown, select an administrator profile, and click OK.

3. Configure the settings for the rpc-permit and/or trusthost1 attributes in the admin profile.
Enter the following commands in the FortiAnalyzer CLI:
config system admin profile
edit <profile name>
set rpc-permit {none | read | read-write}
set trusthostl <ip & netmask>
end

FortiAnalyzer 7.4.0 Administration Guide 354
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4. Configure the admin user to use the from-profile option for the rpc-permit and/or trusthost1 attributes.

Enter the following commands in the FortiAnalyzer CLI:

config system admin user
edit <admin user>

set rpc-permit from-profile
set trusthostl from-profile

end

5. Inthe FortiAnalyzer GUI, go to System Settings > Administrators and view the administrator account. The attributes
that were configured to use the from-profile setting can no longer be edited and display the settings defined in
the administrator profile.

Edit Administrator

User Name

Avatar

Description

Admin Type

Admin Profile
Administrative Domain
Policy Package

J50N APl Access
Theme Mode

Trusted Hosts
Trusted IPv4 Host 1

Trusted IPv4 Host 2
Trusted IPv4 Host 3
Trusted IPvé Host 1
Trusted IPvé Host 2
Trusted IPvé Host 3

Meta Fields >
Advanced Options >

Administrator profiles

TestAdmin

T = Add Photo = Remave Photo

LOCAL

test

All ADOMSs All ADOMs except specified ones
All Packages Specify

Read-Write

Use Global Theme Use Own Theme

10.2.116.0/255.255.255.0
255.255.255.255/255.255.255.255
255.255.255.255/255.255.255.255
/0

T A A A PP P AT AP/ 128
T A A A PP P AT AP/ 128

o [

AN

{

Administrator profiles are used to control administrator access privileges to devices or system features. Profiles are

assigned to administrator accounts when an administrator is created. The profile controls access to both the
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FortiAnalyzer GUl and CLI.

There are three predefined system profiles:

Restricted_User

Standard_User

Super_User

Restricted user profiles have no system privileges enabled, and have read-only
access for all device privileges.

Standard user profiles have no system privileges enabled, and have read/write
access for all device privileges.

Super user profiles have all system and device privileges enabled. It cannot be
edited.

These profiles cannot be deleted, but standard and restricted profiles can be edited. New profiles can also be created as
required. Only super user administrators can manage administrator profiles.

Go to System Settings > Admin Profiles to view and manage administrator profiles.

+ Create New [# Edit R§ Clone Wi Delete QI

O # Name

0O 1 Restricted_User
o 2 Standard_User
a 3 Super_User

a 4 Teltro

0O s Sup

The following options are available:

Create New

Edit
Clone

Delete

Search

The following information is shown:

Name

Type

Description

Permissions

Type Description
Restricted user profiles have no System Privileges enabled, and have read-only access for all
Device Privileges.

Standard user profiles have no System Privileges enabled, but have read/write access for all
Device Privileges.

Super user profiles have all system and device privileges enabled.

Create a new administrator profile. See Creating administrator profiles on page
359.

Edit the selected profile. See Editing administrator profiles on page 361.
Clone the selected profile. See Cloning administrator profiles on page 361.

Delete the selected profile or profiles. See Deleting administrator profiles on page
362.

Search the administrator profiles list.

The name the administrator uses to log in.
The profile type.

A description of the system and device access permissions allowed for the
selected profile.

The below table lists the default permissions for the predefined administrator profiles.
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When Read-Write is selected, the user can view and make changes to the FortiAnalyzer system. When Read-Only is
selected, the user can only view information. When None is selected, the user can neither view or make changes to the
FortiAnalyzer system.

Setting Predefined Administrator Profile

Super User Standard User Restricted User

System Settings Read-Write None None

system-setting

Administrative Domain Read-Write Read-Write None

adom-switch

Device Manager Read-Write Read-Write Read-Only

device-manager

Add/Delete/Edit Read-Write Read-Write None
Devices/Groups

device-op
Log View/FortiView Read-Write Read-Write Read-Only

log-viewer

Incidents & Events Read-Write Read-Write Read-Only

event-management

Create & Update Incidents Read-Write Read-Write None
update-incidents

Triage Event Read-Write Read-Write None

triage-events

Execute Playbook Read-Write Read-Write None

execute-playbook

Reports Read-Write Read-Write Read-Only

report-viewer

Run Report Read-Write Read-Write None

run-report

Fabric View Read-Write Read-Write Read-Only

fabric-viewer

CLI only settings

device-wan-link-load-balance Read-Write Read-Write Read-Only
device-ap Read-Write Read-Write Read-Only
device-forticlient Read-Write Read-Write Read-Only
device-fortiswitch Read-Write Read-Write Read-Only
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Setting Predefined Administrator Profile
Super User Standard User Restricted User

realtime-monitor Read-Write Read-Write Read-Only
adom-lock Read-Write Read-Write Read-Only
device-policy-package-lock Read-Write Read-Write Read-Only
extension-access Read-Write Read-Write None
execute-playbook Read-Write Read-Write None
script-access Read-Write Read-Write None

Privacy Masking

Use Privacy Masking to help protect user privacy by masking or anonymizing user information. You can select which
fields to mask. Masked fields show anonymous data. You can unmask and see the original data by entering the Data
Mask Key that you specify in the administrator profile.

When Privacy Masking is enabled in an administrator profile, accounts using that profile have a See Original Data button
in the banner.

B AllDevices~ @ Last 1 HEEE SR ISIER
Source [ Manual Input

0.. 751963521
0. 75.196.35.21
0.. 751963521

To turn privacy masking on:

—

In System Settings > Admin Profiles, create or edit a profile.

In the Privacy Masking section, set the toggle to ON

3. Inthe Masked Data Fields section, select the fields you want to mask.

The fields you select are masked in all modules that display those fields.

In the Data Mask Key field, type the key that will allow users to unmask the data.

In the Data Unmasked Time field, type the number of days the data is unmasked.

You can enter a number between 0-365. Logs that are older than the number of days appear masked.

N

o A

To see the original, unmasked data:

1. Inany list showing masked data, click See Original Data in the banner and select Screen Picker or Manual Input.
2. Ifyou select Screen Picker, click a masked field, for example, 75.196.35.21.
The Unmask Protected Data dialog box displays with the field you clicked already entered.

If you select Manual Input, enter the masked text, for example, 75.196.35.21.
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3. Enter the Data Mask Key that was set up in the administrator profile and click OK.

Unmask Protected Data

Masked Text 77.696.355.299
Data Mask Key

Unmasked Text 172.88.33.861

o

Creating administrator profiles

To create a new administrator profile, you must be logged in to an account with sufficient privileges, or as a super user

administrator.

To create a custom administrator profile:

1. Goto System Settings > Admin Profiles.
2. Click Create New in the toolbar. The New Profile pane is displayed.

FortiAnalyzer 7.4.0 Administration Guide
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3. Configure the following settings:

Profile Name Enter a name for this profile.

Description Optionally, enter a description for this profile. While not a
requirement, a description can help to know what the profiles is for,
or the levels it is set to.

Permissions Select None, Read Only, or Read-Write access for the categories
as required.
Privacy Masking Enable/disable privacy masking.
Masked Data Fields Select the fields to mask: Destination Name, Source IP,
Destination IP, User, Source Name, Email, Message, and/or
Source MAC.
Data Mask Key Enter the data masking encryption key. You need the Data Mask
Key to see the original data.
Data Unmasked Time(0- Enter the number of days the user assigned to this profile can see
365 Days) all logs without masking.

The logs are masked if the time period in the Log View toolbar is
greater than the number of days in the Data Masked Time field.

¢ Only integers between 0-365 are supported.
N : & » Time frame masking does not apply to real tim
q e logs.
- ¢ Time frame masking applies to custom view a
nd drill-down data.

4. Click OKto create the new administrator profile.

To apply a profile to an administrator:

1. Go to System Settings > Administrators.
2. Create a new administrator or edit an existing administrator. The Edit Administrator pane is displayed.
3. From the Admin Profile list, select a profile.

Creating administrator profiles for incident & event management

Incident and event profile permissions allow security analysts to access the Incidents & Events module while preventing
them from making changes to configurations that will affect the SLA.

To create an analyst profile:

Go to System Settings > Admin Profiles.

In the toolbar, click Create New.

In the Profile Name field, give the profile a distinctive name such as, Analyst.
Set Incidents & Events to Read-Only.

o bd-=
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5. Setone or more of the following settings to Read-Write.

Permission Description

Create & Update Incidents Allows analysts to create and update incidents.

Triage Event Allows analysts to acknowledge, comment, view logs, create new incidents,
and add to existing incidents.

Execute Playbook Allows analysts to view and run a playbook.

Run Report Allows analysts to view, run, and export a report.

6. Configure the other settings as required, and click OK.

To apply a profile to an administrator:

1. Go to System Settings > Administrators.
2. Create a new administrator or edit an existing administrator. The Edit Administrator pane is displayed.
3. From the Admin Profile list, select a profile.

Editing administrator profiles

To edit an administrator profile, you must be logged in to an account with sufficient privileges, or as a super user
administrator. The profile's name cannot be edited. The Super_User profile cannot be edited, and the predefined profiles
cannot be deleted.

To edit an administrator:

1. Go to System Settings > Admin Profiles.

2. Double-click on a profile, right-click on a profile and then select Edit from the menu, or select the profile then click
Edit in the toolbar. The Edit Profile pane opens.

3. Edit the settings as required, and then select OK to apply the changes.

Cloning administrator profiles

To clone an administrator profile, you must be logged in to an account with sufficient privileges, or as a super user
administrator.

To edit an administrator:

1. Go to System Settings > Admin Profiles.

2. Right-click on a profile and select Clone from the menu, or select the profile then click Clone in the toolbar. The
Clone Profile pane opens.

3. Editthe settings as required, and then select OK to apply the changes.
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Deleting administrator profiles

To delete a profile or profiles, you must be logged in to an account with sufficient privileges, or as a super user
administrator. The predefined profiles cannot be deleted.

To delete a profile or profiles:

1. Goto System Settings > Admin Profiles.

2. Select the profile or profiles you need to delete.

3. Click Delete in the toolbar, or right-click and select Delete.

4. Select OKin the confirmation box to delete the profile or profiles.
Authentication

The FortiAnalyzer system supports authentication of administrators locally, remotely with RADIUS, LDAP, or TACACS+
servers, and using PKI. Remote authentication servers can also be added to authentication groups that administrators
can use for authentication.

Security Assertion Markup Language (SAML) authentication can be enabled across all Security Fabric devices, enabling
smooth movement between devices for the administrator. FortiAnalyzer can play the role of the identity provider (IdP) or
the service provider (SP) when an external identity provider is available. See SAML admin authentication on page 370.

To use PKI authentication, you must configure the authentication before you create the administrator accounts. See
Public Key Infrastructure on page 362 for more information.

To use remote authentication servers, you must configure the appropriate server entries in the FortiAnalyzer unit for
each authentication server in your network. New LDAP remote authentication servers can be added and linked to all
ADOMs or specific ADOMs. See LDAP servers on page 365, RADIUS servers on page 367, TACACS+ servers on page
369, and Remote authentication server groups on page 369 for more information.

Public Key Infrastructure

Public Key Infrastructure (PKI) authentication uses X.509 certificate authentication library that takes a list of peers, peer
groups, and user groups and returns authentication successful or denied notifications. Administrators only need a valid
X.509 certificate for successful authentication; no username or password is necessary.

To use PKI authentication for an administrator, you must configure the authentication before you create the administrator
accounts. You will also need the following certificates:

» an X.509 certificate for the FortiManager administrator (administrator certificate)

« an X.509 certificate from the Certificate Authority (CA) which has signed the administrator’s certificate (CA
Certificate)

For more information on the CSR generation process, see Local certificates on page 310.

To get the CA certificate:

1. Log into your FortiAuthenticator.
2. Go to Certificate Management > Certificate Authorities > Local CAs.
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Select the certificate and select Export in the toolbar to save the ca_fortinet.com CA certificate to your
management computer. The saved CA certificate’s filename is ca_fortinet.com.crt.

To get the administrator certificate:

Log into your FortiAuthenticator.
Go to Certificate Management > End Entities > Users.

Select the certificate and select Export in the toolbar to save the administrator certificate to your management
computer. The saved CA certificate’s filename is admin _fortinet.com.pl2. This PCKS#12 file is password
protected. You must enter a password on export.

To import the administrator certificate into your browser:

1.
2,

In Mozilla Firefox, go to Options > Advanced > Certificates > View Certificates > Import.
Select the file admin fortinet.com.pl2 and enter the password used in the previous step.

To import the CA certificate into the FortiAnalyzer:

Log into your FortiAnalyzer.
Go to System Settings > Cetrtificates.

Click Create New/Import > CA Certificate, and browse forthe ca fortinet.com.crt file you saved to your
management computer, or drag and drop the file onto the dialog box. The certificate is displayed as CA_Cert_1.

To create a new PKI administrator account:

N

Go to System Settings > Administrators.

Click Create New. The Create New Administrator pane opens.
See Creating administrators on page 348 for more information.

3. Select PKlfor the Admin Type.
4. Enter a commentin the Subject field for the PKI administrator.
5. Select the CA certificate from the dropdown list in the CA field.
6. Click OKto create the new administrator account.
ﬂ PKI authentication must be enabled via the FortiAnalyzer CLI with the following commands:
config system global
I set clt-cert-reqg enable
end
ﬂ When connecting to the FortiAnalyzer GUI, you must use HTTPS when using PKI certificate
I authentication.
\‘ ! 'l
q When clt-cert-reqis set to optional, the user can use certificate authentication or user
- credentials for GUI login.
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Managing remote authentication servers

The FortiAnalyzer system supports remote authentication of administrators using LDAP, RADIUS, and TACACS+
remote servers. To use this feature, you must configure the appropriate server entries for each authentication serverin
your network, see LDAP servers on page 365, RADIUS servers on page 367, and TACACS+ servers on page 369 for
more information.

Remote authentication servers can be added, edited, deleted, and added to authentication groups (CLI only).

Go to System Settings > Remote Authentication Server to manage remote authentication servers.

4 Create New ~» [# Edit fij Delete QI
[0 & Name Type ADOM Details
[0  Actlack TACACS+ 10.10.10.15 CHAP
[0 Dapple LDAP All ADOMs 10.10.10.11:389/cn:
[  Lapper LDAP Syslog, FortiAuthenticator, FortiCache, FortiMail, FortiWWeb 10.10.10.55:38%9/cn:
1 Rader RADIUS 10.10.10.13 PAP
[0 Radium RADIUS 10.11.10.10 10.11.11.10 MSv2

The following options are available:

Create New Add an LDAP, RADIUS, or TACACS+ remote authentication server. See LDAP
servers on page 365, RADIUS servers on page 367, and TACACS+ servers on
page 369.

Edit Edit the selected remote authentication server. See Editing remote authentication

servers on page 364.

Delete Delete the selected remote authentication server or servers. See Deleting remote
authentication servers on page 365.

The following information is displayed:

Name The name of the server.

Type The server type: LDAP, RADIUS, or TACACS+.

ADOM The administrative domain(s) which are linked to the remote authentication
server.

Details Details about the server, such as the IP address.

Editing remote authentication servers

To edit a remote authentication server, you must be logged in to an account with sufficient privileges, or as a super user
administrator. The server's name cannot be edited.

To edit a remote authentication server:

1. Go to System Settings > Remote Authentication Server.

2. Double-click on a server, right-click on a server and then select Edit from the menu, or select the server then click
Editin the toolbar. The Edit Server pane for that server type opens.

FortiAnalyzer 7.4.0 Administration Guide 364
Fortinet Inc.



Administrators

3. Editthe settings as required, and then select OK to apply the changes.
See LDAP servers on page 365, RADIUS servers on page 367, and TACACS+ servers on page 369 for more
information.

Deleting remote authentication servers

To delete a remote authentication server or servers, you must be logged in to an account with sufficient privileges, or as
a super user administrator.

To delete a remote authentication server or servers:

Go to System Settings > Remote Authentication Server.

Select the server or servers you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Select OKin the confirmation box to delete the server or servers.

o bd-=

LDAP servers

Lightweight Directory Access Protocol (LDAP) is an Internet protocol used to maintain authentication data that may
include departments, people, groups of people, passwords, email addresses, and printers. LDAP consists of a data-
representation scheme, a set of defined operations, and a request/response network.

If you have configured LDAP support and an administrator is required to authenticate using an LDAP server, the
FortiAnalyzer unit sends the administrator’s credentials to the LDAP server for authentication. If the LDAP server can
authenticate the administrator, they are successfully authenticated with the FortiAnalyzer unit. If the LDAP server cannot
authenticate the administrator, the FortiAnalyzer unit refuses the connection.

When configuring an LDAP connection to an Active Directory server, an administrator must
provide Active Directory user credentials.

¢ To secure this connection, use LDAPS on both the Active Directory server and
FortiAnalyzer.

¢ Apply the principle of least privilege. For the LDAP regular bind operation, do not use
credentials that provide full administrative access to the Windows server when using
credentials.

To use an LDAP server to authenticate administrators, you must configure the server before configuring the
administrator accounts that will use it.
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To add an LDAP server:

1. Go to System Settings > Remote Authentication Server.
2. Select Create New > LDAP Server from the toolbar. The New LDAP Server pane opens.

New LDAP Server

Name

Server Name/IP

Port 389
Common Name Identifier cn
Distinguished Name

Bind Type Regular

User DN

Password sssses

Secure Connection B Enable

Protocol
Certificate
Administrative Domain

Advanced Options >

Name
Server Name/IP
Port

Common Name ldentifier

Distinguished Name

Bind Type

User DN

Password
Secure Connection

Protocol

Certificate

Administrative Domain

Advanced Options

adom-attr
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3. Configure the following settings, and then click OK to add the LDAP server.

Enter a name to identify the LDAP server.
Enter the IP address or fully qualified domain name of the LDAP server.

Enter the port for LDAP traffic. The default port is 389.

The common name identifier for the LDAP server. Most LDAP servers use cn.

However, some servers use other common name identifiers such as UID.

The distinguished name is used to look up entries on the LDAP server.

The distinguished name reflects the hierarchy of LDAP database object
classes above the common name identifier. Clicking the query distinguished
name icon will query the LDAP server for the name and open the LDAP
Distinguished Name Query window to display the results.

Select the type of binding for LDAP authentication: Simple, Anonymous, or
Regular.

When the Bind Type is set to Regular, enter the user DN.

When the Bind Type is set to Regular, enter the password.

Select to use a secure LDAP server connection for authentication.

When Secure Connection is enabled, select either LDAPS or STARTTLS.

When Secure Connection is enabled, select the certificate from the dropdown
list.

Choose the ADOM s that this server will be linked to for reporting: All ADOMs
(default), or Specify for specific ADOMs.

Specify an attribute for the ADOM.
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attributes
connect-timeout
filter

group

memberof-attr

profile-attr
secondary-server

tertiary-server

RADIUS servers

Specify the attributes such as member, uniquemember, or memberuid.
Specify the connection timeout in millisecond.

Specify the filter in the format (ocbjectclass=*)

Specify the name of the LDAP group.

Specify the value for this attribute. This value must match the attribute of the
group in LDAP Server. All users part of the LDAP group with the attribute
matching the memberof-attr will inherit the administrative permissions
specified for this group.

Specify the attribute for this profile.
Specify a secondary server.

Specify a tertiary server.

Remote Authentication Dial-in User (RADIUS) is a user authentication and network-usage accounting system. When
users connect to a server they type a user name and password. This information is passed to a RADIUS server, which
authenticates the user and authorizes access to the network.

You can create or edit RADIUS server entries in the server list to support authentication of administrators. When an
administrator account’s type is set to RADIUS, the FortiAnalyzer unit uses the RADIUS server to verify the administrator
password at log on. The password is not stored on the FortiAnalyzer unit.

To use a RADIUS server to authenticate administrators, you must configure the server before configuring the

administrator accounts that will use it.

FortiAnalyzer 7.4.0 Administration Guide
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To add a RADIUS server:

1. Go to System Settings > Remote Authentication Server.
2. Select Create New > RADIUS Server from the toolbar. The New RADIUS Server pane opens.

Name

Server Name/IP 10.2.0.159
Port 1812
ssssssne

Server Secret

Connection Status Successful

Test Connectivity Test User Credentials

Secondary Server Name/IP

Secondary Server Secret ssssssss

Test Connectivity

Authentication Type ANY

Advanced Options >

]

Test User Credentials

3. Configure the following settings, and then click OK to add the RADIUS server.

Name
Server Name/IP

Port

Server Secret

Test Connectivity

Test User Credentials

Secondary Server Name/IP

Secondary Server Secret

Authentication Type

Advanced Options

nas-ip

FortiAnalyzer 7.4.0 Administration Guide
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Enter a name to identify the RADIUS server.
Enter the IP address or fully qualified domain name of the RADIUS server.

Enter the port for RADIUS traffic. The default portis 1812. Some RADIUS
servers use port 1645.

Enter the RADIUS server secret. Click the eye icon to Show or Hide the server
secret.

Click Test Connectivity to test the connectivity with the RADIUS server. Shows
success or failure.

Click Test User Credentials to test the user credentials. Shows success or
failure.

Enter the IP address or fully qualified domain name of the secondary RADIUS
server.

Enter the secondary RADIUS server secret.

Select the authentication type the RADIUS server requires. If you select the
default ANY, FortiAnalyzer tries all authentication types.

Specify the IP address for the Network Attached Storage (NAS).
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TACACS+ servers

Terminal Access Controller Access-Control System (TACACS+) is a remote authentication protocol that provides
access control for routers, network access servers, and other network computing devices via one or more centralized
servers. It allows a client to accept a user name and password and send a query to a TACACS authentication server.
The server host determines whether to accept or deny the request and sends a response back that allows or denies
network access to the user. The default TCP port for a TACACS+ server is 49.

If you have configured TACACS+ support and an administrator is required to authenticate using a TACACS+ server, the
FortiAnalyzer unit contacts the TACACS+ server for authentication. If the TACACS+ server can authenticate the
administrator, they are successfully authenticated with the FortiAnalyzer unit. If the TACACS+ server cannot
authenticate the administrator, the connection is refused by the FortiAnalyzer unit.

To use a TACACS+ server to authenticate administrators, you must configure the server before configuring the
administrator accounts that will use it.

To add a TACACS+ server:

1. Go to System Settings > Remote Authentication Server.
2. Select Create New > TACACS+ Server from the toolbar. The New TACACS+ Server pane opens.
New TACACS+ Server

Name

Server Name/IP

Port 49
Server Key

Authentication Type

3. Configure the following settings, and then click OK to add the TACACS+ server.

Name Enter a name to identify the TACACS+ server.

Server Name/IP Enter the IP address or fully qualified domain name of the TACACS+ server.
Port Enter the port for TACACS+ traffic. The default port is 49.

Server Key Enter the key to access the TACACS+ server. The server key can be a

maximum of 16 characters in length.

Authentication Type Select the authentication type the TACACS+ server requires. If you select the
default ANY, FortiAnalyzer tries all authentication types.

Remote authentication server groups

Remote authentication server groups can be used to extend wildcard administrator access. Normally, a wildcard
administrator can only be created for a single server. If multiple servers of different types are grouped, a wildcard
administrator can be applied to all of the servers in the group.

Multiple servers of the same type can be grouped to act as backups - if one server fails, the administrator can still be
authenticated by another server in the group.

To use a server group to authenticate administrators, you must configure the group before configuring the administrator
accounts that will use it.
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Remote authentication server groups can only be managed using the CLI. For more information, see the FortiAnalyzer
CLI Reference.

To create a new remote authentication server group:

1. Open the admin group command shell:
config system admin group

2. Create a new group, or edit an already create group:
edit <group name>

3. Add remote authentication servers to the group:

set member <server name> <server name> ...

4. Apply your changes:

end

To edit the servers in a group:

1. Enter the following CLI commands:
config system admin group
edit <group name>
set member <server name> <server name> ...
end

Only the servers listed in the command will be in the group.

To remove all the servers from the group:

1. Enter the following CLI commands:
config system admin group
edit <group name>
unset member
end

All of the servers in the group will be removed.

To delete a group:

1. Enter the following CLI commands:
config system admin group
delete <group name>

end

SAML admin authentication

SAML can be enabled across devices, enabling smooth movement between devices for the administrator. FortiAnalyzer
can play the role of the identity provider (IdP) or the service provider (SP) when an external identity provider is available.

When FortiGate is acting as the IdP in a Security Fabric, FortiAnalyzer can be configured to automatically connect as a
Fabric SP, allowing for easy setup of SAML authentication. See Enabling SAML authentication in a Security Fabric on
page 173.

Devices configured to the IdP can be accessed through the Quick Access menu which appears in the top-right corner of
the main menu. The current device is indicated with an asterisk (currently only supported between FAZ/FMG).
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Logging into an SP device will redirect you to the IdP login page. By default, it is a Fortinet login page. After successful
authentication, you can access other SP devices from within the same browser without additional authentication.

When FortiAnalyzer is registered to FortiCloud, you can enable Allow admins to login with FortiCloud. This feature allows
administrators to log in to FortiAnalyzer using their FortiCloud SSO account credentials. See FortiCloud SSO admin

authentication on page 373.

The admin user must be created on both the IdP and SP, otherwise you will see an error

Alternatively, you can configure the ADOM and profile names in the SP to match the IdP.

\‘é', message stating that the admin doesn't exist.

When this is done, you can create one SAML SSO wildcard admin user on the SP to match all
users on the IdP server.

When accessing FortiGate from the Quick Access menu, if FGT is set up to use the default
login page with SSO options, you must select the via Single Sign-On button to be

automatically authenticated.

To configure FortiAnalyzer as the identity provider:

Select Identity Provider (IdP).

a b obd-=

selecting Customize.

Ne

Name

IdP Prefix

SP Type

SP Address
SAML Attributes

FortiAnalyzer 7.4.0 Administration Guide
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Go to System Settings > SAML SSO.

In the IdP Certificate dropdown, choose a certificate where IdP is used.
Select Download to get the IdP certificate, used later to configure SPs.
(Optional) A custom login page can be created by moving the Login Page Template toggle to the On position and

In the SP Settings table, select Create New to add a service provider.
In the Edit Service Provider window, configure the following information:

Enter a name for the service provider.

Copy the IdP prefix. This will be required when configuring your service
providers.

Select Fortinet as the SP Type.

If the SP is not a Fortinet product, select Custom as the SP Type and copy the
SP Entity ID, SP ACS (Login) URL, and SP SLS (Logout) URL from your SPs
configuration page.

Enter the IP address of the service provider.

SAML attributes can be added to a service provider to specify ADOM and/or
profile names.
FortiAnalyzer acting as IdP supports the following SAML attributes:

e Type: Username, Attribute: username

¢ Type: Profile Name, Attribute: profilename

e Type: ADOM, Attribute: adoms
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SAML SSO Wildcard users

As long as the SP has the same user profile and ADOM
names as the IdP, you do not need to re-create each user
ML/, fromthe IdP on the SP. Instead, you can create one SAML
9 SSO wildcard admin user on the SP with the Match all users
- on remote server setting enabled to match all users on the
IdP server. When logging in as an SSO user on the SP, the
user is assigned the same profile and ADOMs as are
configured on the IdP. See Creating administrators on page
348.

8. Select OKto save changes to the service provider.
9. Click Apply to save the IdP configuration.

To configure FortiAnalyzer as a service provider:

1. Goto System Settings > SAML SSO.

2. Select Service Provider (SP).

3. Enter the Server Address which is the browser accessible address for this device.
4. Optionally, configure the signing options:

» Authentication Request Signed: Enable this setting to require that all authentication requests sent by the
FortiAnalyzer service provider are signed. A valid SP certificate is required to enable this option.

e Require Assertions Signed from IdP: Enable this setting to require that all assertions received from the IdP are
signed.

5. Configure the IdP Settings:
a. Selectthe IdP type as Fortinet or Custom.
b. Enterthe IdP Address and the Prefix that you obtained while configuring the IdP device.

c. Select the IdP certificate. If this is a first-time set up, you can import the IdP certificate that you downloaded
while configuring the IdP device.

6. Confirm that the information is correct and select Apply.
7. Repeat the steps for each FAZ/FMG that is to be set as a service provider.

For information on configuring FortiAnalyzer as an SP in a Security Fabric, see: Enabling SAML authentication in a
Security Fabric on page 173.

Supported SAML attribute overrides

The following SAML attributes are accepted by FortiAnalyzer SAML service provider.

SAML Attribute Description

username The username of the local/SSO user. This attribute is mandatory.

Example:
<Attribute Name="username">
<AttributeValue>userl</AttributeValue>
</Attribute>
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SAML Attribute Description

profilename The Profile assigned to the user. If a matching profile exists on the FortiAnalyzer, it will be
assigned to the user. This attribute is optional.
Example:
<Attribute Name="profilename">

<AttributeValue>SSOPROFILE</AttributevValue>
</Attribute>

adoms The ADOM(s) to which the user will have access. Multiple ADOMs can be specified in the
SAML assertion if supported by the IdP. This attribute is optional.
Example:
<Attribute Name="adoms">
<AttributeValue>ADOMI1</AttributevValue>
<AttributeValue>ADOM2</AttributeValue>
</Attribute>

You can use the following command in the CLI to verify the correct adoption of the SAML attributes by FortiAnalyzer.

diagnose system admin-session list

For example:

diagnose system admin-session list
*x*k% entry 0 ***
session _id: 57410 (seq: 0)
username: userl
admin template: SSO
from: SSO(192.168.50.188) (type 7)
profile: SSOPROFILE
adom: adoml
session length: 3 (seconds)

FortiCloud SSO admin authentication
When FortiAnalyzer is registered to FortiCloud, you can enable login to FortiAnalyzer using your FortiCloud
SSO account.

By default, only the FortiCloud account ID which the FortiAnalyzer is registered to can be used to log into FortiAnalyzer.
Additional SSO users can be configured as IAM users in FortiCloud. See IAM user account login on page 374.
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To enable login with FortiCloud:

1. Before enabling this feature, FortiAnalyzer must be registered to FortiCloud, and a FortiCloud account must be

configured.
You can check your FortiCloud registration status in Dashboard in the License Information widget.

2. Goto System Settings > SAML SSO, and enable Allow admins to login with FortiCloud.

Single Sign-On Settings
Server Address 192.168.50.249
Allow admins to login with m
FortiCloud @
Single Sign-On Mode EELIEGE Identity Provider (IdP)  Service Provider (SP)  Fabric SP

3. Sign out of FortiAnalyzer to return to the sign in screen.
An option to Login with FortiCloud is now visible on the FortiAnalyzer login page.

FortiAnalyzer-VMé4

Login with FortiCloud

AN
FortiCloud

4. Click Login with FortiCloud. Enter your login credentials from FortiCloud and click LOGIN.

Email Login

Al fields are case-sensilive

Forgot Email ? Forgot Password?

Welcome Back!

LOG IN

1AM Login

You are signed in with your FortiCloud user account.

IAM user account login

FortiCloud supports the creation of additional users called IAM users. Once created, you can use the IAM user account
to sign in to FortiAnalyzer.
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To sign in using a FortiCloud IAM user:

o bd-=

5.

In FortiCloud, create one or more additional IAM user accounts. See Identity and Access Management (IAM).
Enable Allow admins to login with FortiCloud in System Settings > SAML SSO.

Sign out of FortiAnalyzer, return to the FortiAnalyzer sign on page, and click Login with FortiCloud.

At the bottom of the FortiCloud login portal, click Sign in as IAM user.

AN
FortiCloud

Account ID / Alias
Username

Password

LOGIN

Sign in using email Forgot password?

Learn more about FortiCloud  Privacy  Terms

Enter your IAM user credentials.
You are signed in using your FortiCloud IAM account.

Global administration settings

The administration settings page provides options for configuring global settings for administrator access to the
FortiAnalyzer device. Settings include:

Ports for HTTPS and HTTP administrative access

To improve security, you can change the default port configurations for administrative connections to the
FortiAnalyzer. When connecting to the FortiAnalyzer unit when the port has changed, the port must be included,
suchashttps://<ip address>:<port>. Forexample, if you are connecting to the FortiAnalyzer unit using
port 8080, the URL would be https://192.168.1.99:8080. When you change to the default port number for
HTTP, HTTPS, or SSH, ensure that the port number is unique.

Idle timeout settings

By default, the GUI disconnects administrative sessions if no activity occurs for five minutes. This prevents
someone from using the GUI if the management computer is left unattended.

GUI language

The language the GUI uses. For best results, you should select the language used by the management computer.

GUI theme

The default color theme of the GUI is Blueberry. You can choose another color or an image.
Password policy

Enforce password policies for administrators.

FortiAnalyzer 7.4.0 Administration Guide
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A\,

Only super user administrators can access and configure the administration settings. The
settings are global and apply to all administrators of the FortiAnalyzer unit.

To configure the administration settings:

1. Go to System Settings > Settings.

Admin Settings

Administration Settings

HTTP Port

HTTPS Port

HTTPS & Web Service
Certificate

Idle Timeout

Idle Timeout (API)

Idle Timeout (GUI)

View Settings

Language
High Contrast Theme

Other Themes

80
© Redirects to HTTPS
443

@ FortiDemo_2023

480
900
200

Auto Detect

I‘J

E

Seconds (60-28800)
Seconds (1-28800)
Seconds (60-28800)

Mariner Dark Matter
[/}

m e

Apply

2. Configure the following settings as needed, then click Apply to save your changes to all administrator accounts:

Administration Settings

HTTP Port

HTTPS Port

HTTPS & Web
Service Server
Certificate

Idle Timeout

Idle Timeout (API)

Idle Timeout (GUI)

View Settings

FortiAnalyzer 7.4.0 Administration Guide
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Enter the TCP port to be used for administrative HTTP access. Default: 80.
Select Redirect to HTTPS to redirect HTTP traffic to HTTPS.

Enter the TCP port to be used for administrative HTTPS access. Default: 443.

Select a certificate from the dropdown list.

Enter the number of seconds an administrative connection can be idle before
the administrator must log in again, from 60 to 28800 (eight hours). See Idle
timeout on page 379 for more information.

Enter the number of seconds an administrative connection to the APl can be
idle before the administrator must log in again, from 1 to 28800 (eight hours).
Default: 900.

Enter the number of seconds an administrative connection to the GUI can be

idle before the administrator must log in again, from 60 to 28800 (eight hours).

Default: 900.
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Language Select a language from the dropdown list. See GUI language on page 378 for
more information.

High Contrast Toggle ON to enable a high contrast dark theme in order to make the

Theme FortiAnalyzer GUI more accessible, and to aid people with visual disability in
using the FortiAnalyzer GUI.

Other Themes Select a theme for the GUI. The selected theme is not applied until you click

Apply, allowing to you to sample different themes. Default: Blueberry.

Password Policy Click to enable administrator password policies. See Password policy on page
377 and Password lockout and retry attempts on page 378 for more
information.

Minimum Length Select the minimum length for a password, from 8 to 32 characters. Default: 8.
Must Contain Select the types of characters a password must contain.

Admin Password Select the number of days a password is valid for, after which it must be

Expires after changed.
Fabric Authorization Specifies the accessible management IP of FortiAnalyzer for FortiOS to
retrieve and use for authorization of a Security Fabric connection to
FortiAnalyzer.

When you are using FortiOS to create a Security Fabric connection to
FortiAnalyzer, a browser pop window is displayed and connects to
FortiAnalyzer as part of the authorization process. FortiOS retrieves the
information specified in FortiAnalyzer and provides it to the browser popup
window to successfully connect to FortiAnalyzer.

Without this information, the browser popup window cannot connect to
FortiAnalyzer in certain topologies, such as when NAT is used.

See also Security Fabric authorization information for FortiOS on page 379.

Authorization Type the accessible management IP for FortiAnalyzer.
Address

Authorization Port  If a non-default port is used for the management port of FortiAnalyzer, specify
the custom port.

Password policy

You can enable and configure password policy for the FortiAnalyzer.

L}
‘?' When a password policy is enabled, only the current password is remembered for each user in
- password reuse history.

To configure the password policy:

1. Go to System Settings > Settings.
2. Click to enable Password Policy.
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3. Configure the following settings, then click Apply to apply to password policy.

Minimum Length Specify the minimum number of characters that a password must be, from 8 to 32.
Default: 8.

Must Contain Specify the types of characters a password must contain: uppercase and lowercase
letters, numbers, and/or special characters.

Admin Password Specify the number of days a password is valid for. When the time expires, an
Expires after administrator will be prompted to enter a new password.

Password lockout and retry attempts

By default, the number password retry attempts is set to three, allowing the administrator a maximum of three attempts
atlogging in to their account before they are locked out for a set amount of time (by default, 60 seconds).

The number of attempts and the default wait time before the administrator can try to enter a password again can be
customized. Both settings can be configured using the CLI.

To configure the lockout duration:

1. Enter the following CLI commands:
config system global
set admin-lockout-duration <seconds>
end

To configure the number of retry attempts:

1. Enter the following CLI commands:
config system global
set admin-lockout-threshold <failed attempts>
end

Example

To set the lockout threshold to one attempt and set a five minute duration before the administrator can try to log in again,
enter the following CLI commands:

config system global
set admin-lockout-duration 300
set admin-lockout-threshold 1
end

GUI language

The GUI supports multiple languages, including:
« English
» Simplified Chinese
 Traditional Chinese
o Japanese
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o Korean
e Spanish
e French

By default, the GUI language is set to Auto Detect, which automatically uses the language used by the management

computer. If that language is not supported, the GUI defaults to English. For best results, you should select the language
used by the operating system on the management computer.

For more information about language support, see the FortiAnalyzer Release Notes.

To change the GUI language:

1. Go to System Settings > Settings.

2. Under the View Settings, in the Language field, select a language, or Auto Detect, from the dropdown list.
3. Click Apply to apply the language change.

Idle timeout

To ensure security, the idle timeout period should be short. By default, administrative sessions are disconnected if no
activity takes place for 900 seconds (15 minutes). This idle timeout is recommended to prevent anyone from using the
GUl on a PC that was logged in to the GUI and then left unattended.

To change the idle timeout:

1. Go to System Settings > Settings.
2. Change the Idle Timeout period as required.
3. Click Apply.

Security Fabric authorization information for FortiOS

When using FortiOS to create a Security Fabric connection to FortiAnalyzer, the process includes device authorization.
The authorization process uses a browser popup window that requires communication to FortiAnalyzer. Depending on
the topology, communication might fail, unless you specify the accessible management IP address and/or port of
FortiAnalyzer that the browser popup window in FortiOS can use to connect with FortiAnalyzer.

FortiOS retrieves this information from FortiAnalyzer and makes it available to the browser popup window used for the
authorization process.

To specify the authorization address and/or port:

1. InFortiAnalyzer, go to System Settings > Settings.
2. Under Fabric Authorization, set the following options:

Authorization Address Type the GUI-accessible URL for FortiAnalyzer.
Authorization Port If a non-default port is used, type the port number used for GUI access to
FortiAnalyzer.
3. Click Apply.
FortiAnalyzer 7.4.0 Administration Guide 379

Fortinet Inc.


https://docs.fortinet.com/product/fortianalyzer/

Administrators

Control administrative access with a local-in policy

Administrative access to FortiAnalyzer can be controlled by a IPv4/IPv6 local-in policy. This feature can only be
configured using the FortiAnalyzer CLI.

For more information, see the FortiAnalyzer CLI Reference Guide on the Fortinet Docs Library.

To create an IPv4 local-in policy to control administrator access to FortiAnalyzer:

1. Access the FortiAnalyzer CLI.

2. Enter the following command to create the IPv4 local-in policy:
config system local-in-policy
(local-in-policy) # edit <policy ID>
new entry '<Policy ID>' added
3. Configure additional settings for the local-in policy using the set command.
For example:
set
action Action performed on traffic matching this policy.
dport Destination port number (0 for all).
dst Destination IP and mask.
intf Incoming interface name.
protocal Traffic protocal.
src Source IP and mask.

To create an IPv6 local-in policy to control administrator access to FortiAnalyzer:

1. Access the FortiAnalyzer CLI.

2. Enter the following command to create the IPv6 local-in policy:
config system local-in-policy6
(local-in-policy6)# edit <policy ID>
new entry '<Policy ID>' added
3. Configure additional settings for the local-in policy using the set command.
For example:
set
action Action performed on traffic matching this policy.
dport Destination port number (0 for all).
dst Destination IP and mask.
intf Incoming interface name.
protocal Traffic protocal.
src Source IP and mask.

Two-factor authentication

FortiAnalyzer supports the following two methods for two-factor authentication:

o FortiAuthenticator
e FortiToken Cloud
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Two-factor authentication with FortiAuthenticator

To configure two-factor authentication for administrators with FortiAuthenticator you will need the following:

o FortiAnalyzer
o FortiAuthenticator
o FortiToken

Configuring FortiAuthenticator

On the FortiAuthenticator, you must create a local user and a RADIUS client.

Before proceeding, ensure you have configured your FortiAuthenticator, created a NAS entry

>ﬂ for your FortiAnalyzer, and created or imported FortiTokens.

For more information, see the RADIUS Interoperability Guide and FortiAuthenticator
Administration Guide in the Fortinet Document Library.

To create a local user:

1. Go to Authentication > User Management > Local Users.
2. Click Create New in the toolbar.
3. Configure the following settings:

Username Enter a user name for the local user.

Password creation Select Specify a password from the dropdown list.

Password Enter a password. The password must be a minimum of 8 characters.
Password confirmation Re-enter the password. The passwords must match.

Allow RADIUS authentication Enable to allow RADIUS authentication.
Role Select the role for the new user.

Enable account expiration Optionally, select to enable account expiration. For more information see the
FortiAuthenticator Administration Guide.

4. Click OKto continue to the Change local user page.

@ Successfully added local user “pifry". You may editit again below.

Usemame pifty
[ Disabled
Password-based authentication ~[Change Password]

[] Token-based autnentication

[ Allew RADIUS authentication

Role: @) Administrator
QUser

mll|

estrict admin login from

Alternative Email Addresses

oK ) | Cancel |

trusted management subnets only
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Disabled

Password-based
authentication

Token-based authentication

Deliver token code
by

Allow RADIUS authentication

Enable account expiration

User Role
Role

Full Permission

Web service

Restrict admin
login from trusted
management
subnets only

Allow LDAP
Browsing

5. Configure the following settings, then click OK.

Select to disable the local user.

Leave this option selected. Select [Change Password]to change the
password for this local user.

Select to enable token-based authentication.

Select to deliver token by FortiToken, email, or SMS.
Click Test Token to test the token.

Select to allow RADIUS authentication.

Optionally, select to enable account expiration. For more information see the
FortiAuthenticator Administration Guide.

Select either Administrator or User.

Select to allow Full Permission, otherwise select the admin profiles to apply to
the user. This option is only available when Role is Administrator.

Select to allow Web service, which allows the administrator to access the web
service via a REST API or by using a client application. This option is only
available when Role is Administrator.

Select to restrict admin login from trusted management subnets only, then
enter the trusted subnets in the table. This option is only available when Role
is Administrator.

Select to allow LDAP browsing. This option is only available when Role is
User.

Create a RADIUS client:

1. Go to Authentication > RADIUS Service > Clients.
2. Click Create New in the toolbar.
3. Configure the following settings, then click OK.

Name Enter a name for the RADIUS client entry.

Client name/IP Enter the IP address or Fully Qualified Domain Name (FQDN) of the

FortiAnalyzer.

Secret Enter the server secret. This value must match the FortiAnalyzer RADIUS

server setting at System Settings > Remote Authentication Server.
First profile name See the FortiAuthenticator Administration Guide.
Description Enter an optional description for the RADIUS client entry.

Apply this profile based on
RADIUS attributes

Select to apply the profile based on RADIUS attributes.
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Authentication method
Username input format
Realms

Allow MAC-based
authentication

Check machine
authentication

Enable captive portal

Select Enforce two-factor authentication from the list of options.
Select specific user name input formats.
Configure realms.

Optional configuration.

Select to check machine based authentication and apply groups based on the
success or failure of the authentication.

Enable various portals.

EAP types Optional configuration.
\‘ ! 'l
? For more information, see the FortiAuthenticator Administration Guide, available in the
- Fortinet Document Library.

Configuring FortiAnalyzer

On the FortiAnalyzer, you need to configure the RADIUS server and create an administrator that uses the RADIUS

server for authentication.

To configure the RADIUS server:

1. Go to System Settings > Remote Authentication Server.
2. Click Create New > RADIUS Serverin the toolbar.
3. Configure the following settings, then click OK.

Name

Server Name/IP
Port

Server Secret

Secondary Server Name/IP

Secondary Server Secret

Authentication Type

To create the administrator:

Enter a name to identify the FortiAuthenticator.

Enter the IP address or fully qualified domain name of your FortiAuthenticator.
Enter the port for FortiAuthenticator traffic.

Enter the FortiAuthenticator secret.

Enter the IP address or fully qualified domain name of the secondary
FortiAuthenticator, if applicable.

Enter the secondary FortiAuthenticator secret, if applicable.

Select the authentication type the FortiAuthenticator requires. If you select the
default ANY, FortiAnalyzer tries all authentication types.

Note: RADIUS server authentication for local administrator users stored in
FortiAuthenticator requires the PAP authentication type.

1. Go to System Settings > Administrators.

2. Click Create New from the toolbar.
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3. Configure the settings, selecting the previously added RADIUS server from the RADIUS Server dropdown list. See
Creating administrators on page 348.

4. Click OKto save the settings.

To test the configuration:

1. Attemptto log in to the FortiAnalyzer GUI with your new credentials.
2. Enteryour user name and password and click Login.
3. Enter your FortiToken pin code and click Submit to log in to the FortiAnalyzer.

Two-factor authentication with FortiToken Cloud

To use two-factor authentication with FortiToken Cloud, you must have an active FortiToken Cloud license registered on
FortiCloud. For more information about this process, see the FortiToken Cloud Admin Guide.

To configure two-factor authentication for administrators with FortiToken Cloud:

1. InFortiAnalyzer, go to System Settings > Administrators and click Create New or edit an existing administrator.
2. Inthe FortiToken Cloud field, select the token delivery method from the following options:

» FortiToken Mobile: Use the FortiToken Mobile app to get tokens. The administrator is sent an email with a link
to activate their token in the FortiToken Mobile app on their mobile device.

* Email: Receive the token by email.
» SMS: Receive the token by SMS message.
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Create New Administrator

User Name

Avatar

Description

Admin Type

New Password
Confirm Password
FortiToken Cloud
Emiil

Country Dial Code

Mobile Number

Administrative Domain

Admin Profile
JSON APl Access
Theme Mode

Trusted Hosts

Meta Fields »

Advanced Options >

test

T | 4 AddPhoto

= Remove Photo

LOCAL

Disable | FortiToken Mobile | Email [N

test@fortinet.com

=5 United States Canada

| 1234567890

All ADOMs All ADOMs except specified ones Specify
Restricted_User

Mone

Use Global Theme Use Own Theme

(s |

3. Enter the appropriate contact information.
4. Edit other fields as needed and click OK.

When the administrator logs in, they are prompted to enter the token code from their email, SMS, or FortiToken
Mobile.

Please input FortiToken code:

test

Token C

ode

Login
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A FortiAnalyzer high availability (HA) cluster provides the following features:

» Provide real-time redundancy in case a FortiAnalyzer primary unit fails. If the primary unit fails, another unit in the
cluster is selected as the primary unit. See If the primary unit fails on page 394.

« Synchronize logs and data securely among multiple FortiAnalyzer units. Some system and configuration settings
are also synchronized. See Configuration synchronization on page 389.

« Alleviate the load on the primary unit by using secondary (backup) units for processes such as running reports.

A FortiAnalyzer HA cluster can have a maximum of four units: one primary unit with up to three secondary units. All units
in the cluster must be of the same FortiAnalyzer series. All units are visible on the network.

All units must run in the same operation mode: Analyzer or Collector.

When devices with different licenses are used to create an HA cluster, the license that allows
for the smallest number of managed devices is used.
/- ™
port2: port2:
10.10.10.1/24 Peer Network 10.10.10.2/24 [~
FortiAnalyzer HA Primary Unit FortiAnalyzer HA Secondary Unit
‘ Cluster Virtual IP ‘
via VRRP
172.nn.nn.nnn/24
port1: port1:
172.nn.nn.nnn/24 Cluster Network: 172.nn.nn.n/24 172.nn.nn.nnn/24

Configuring HA options

To configure HA options go to System Settings > HA and configure FortiAnalyzer units to create an HA cluster or change
cluster configuration.

In System Settings > HA, use the Cluster Settings pane to create or change HA configuration, and use the Cluster Status
pane to monitor HA status.

To configure a cluster, set the Operation Mode of the primary unit to Active-Passive or Active-Active. Then add the IP
addresses and serial numbers of each secondary unit to the primary unit peer list. The IP address and serial number of

FortiAnalyzer 7.4.0 Administration Guide 386
Fortinet Inc.



High Availability

the primary unit and all secondary units must be added to each secondary unit's HA configuration. The primary unit and
all secondary units must have the same Group Name, Group ID and Password.

You can connect to the primary unit GUI to work with FortiAnalyzer. Using configuration synchronization, you can
configure and work with the cluster in the same way as you work with a standalone FortiAnalyzer unit.

£12 Enterprise_FortiAnalyzer

Search...

@ Dashboard Cluster Status
B Device Manager
FortiView >

M LogView > m |[=DS
Fabric View » | Norecord found.
Incidents & Events > | Cluster Settings
B Reports >

| & System Settings Operation Mode

ADOMs

Administrators Preferred Role

Admin Profiles

Cluster Virtual IP
Remote Authentication S...
Fabric Management |IP Address and Interface

SAML SSO

Serial Number % P=

Host Name +

Standalone Active-Active

IP Address Interface

Uptime/Downtime *

Initial Logs Sync +

yo—

Configuration Sync +

Action

0.00.0 portl AR K 3
Settings
Network
Peer IP and Peer SN Peer IP Peer SN Action
Event Logs
0.00.0 x| +
Certificates
AR Group Name
Group ID 0 (1-255)
Password | sssessss o
Heart Beat Interval 4 Seconds
Heart Beat Interface Click to select v
Failover Threshold 12
Priority 100 (80-120)
Log Data Sync ©
Fi:ATINET Apply

Configure the following settings:

Cluster Settings
Operation Mode

Preferred Role

Cluster Virtual IP

IP Address

Interface

FortiAnalyzer 7.4.0 Administration Guide
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Select Active-Passive or Active-Active to configure the FortiAnalyzer unit for HA.
You can use Active-Active mode to create a geo-redundant solution. For more
information, see Geo-redundant HA on page 390.

Select Standalone to stop operating in HA mode.

Select the preferred role when this unit first joins the HA cluster.

If the preferred role is Primary, then this unit becomes the primary unit if it is
configured first in a new HA cluster. If there is an existing primary unit, then this
unit becomes a secondary unit.

The default is Secondary so that the unit can synchronize with the primary unit. A
secondary unit cannot become a primary unit until it is synchronized with the
current primary unit.

The IP address for which the FortiAnalyzer HA unit is to provide redundancy.

The interface the FortiAnalyzer HA unit uses to provide redundancy.
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Action

Cluster Settings

Peer IP
Peer SN

Action

Group Name

Group ID

Password

Heart Beat Interval

Heart Beat
Interface

Failover Threshold

Priority
Log Data Sync

Log synchronization

Click the plus (+) to add another virtual IP. Click the x to remove a virtual IP from
the list.

Type the IP address of another FortiAnalyzer unit in the cluster.

Type the serial number of the FortiAnalyzer unit corresponding to the entered IP
address.

Click the plus (+) to add another FortiAnalyzer unit in the cluster. Click the x to
remove a FortiAnalyzer unit from the cluster.

Type a group name that uniquely identifies the FortiAnalyzer HA cluster. All units
in a cluster must have the same Group Name, Group ID and Password.

Type a group ID from 1 to 255 that uniquely identifies the FortiAnalyzer
HA cluster.

A password for the HA cluster. All members of the HA cluster must have the same
password.

The time the primary unit waits between sending heartbeat packets, in seconds.
The heartbeat interval is also the amount of time that secondary units waits before
expecting to receive a heartbeat packet from the primary unit.

By default, the Heart Beat Interval is set to 4.

Select the interface used to send heartbeat packets.

The number of seconds that one of the cluster units waits to receive HA heartbeat
packets from other cluster units before assuming that the other cluster units have
failed. This value corresponds to Heart Beat Interval x 3 and it is automatically
updated based on the configured Heart Beat Interval.
For example, the failure is detected after 12 seconds with the default settings:

* Heart Beat Interval: 4

e Failover Threshold: 12

The Heart Beat Interval can be increased or decreased to adapt to latency
conditions of your network and to detect legitimate failures.

The priority or seniority of the secondary unit in the cluster.

This option is on by default. It provides real-time log synchronization among
cluster members.

To ensure logs are synchronized among all HA units, FortiAnalyzer HA synchronizes logs in two states: initial logs
synchronization and real-time log synchronization.
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Initial Logs Sync

When you add a unit to an HA cluster, the primary unit synchronizes its logs with the new unit. After initial sync is
complete, the secondary unit automatically reboots. After the reboot, the secondary unit rebuilds its log database with
the synchronized logs.

You can see the status in the Cluster Status pane Initial Logs Sync column.

Log Data Sync

After the initial log synchronization, the HA cluster goes into real-time log synchronization state.
Log Data Sync is turned on by default for all units in the HA cluster.

When Log Data Sync is turned on in the primary unit, the primary unit forwards logs in real-time to all secondary units.
This ensures that the logs in the primary and secondary units are synchronized.

Log Data Sync is turned on by default in secondary units so that if the primary unit fails, the secondary unit selected to be
the new primary unit will continue to synchronize logs with secondary units.

If you want to use a FortiAnalyzer unit as a standby unit (not as a secondary unit), then you don't need real-time log
synchronization so you can turn off Log Data Sync.

Configuration synchronization

Configuration synchronization provides redundancy and load balancing among the cluster units. A FortiAnalyzer HA
cluster synchronizes the configuration of the following modules to all cluster units:

+ Device Manager

« Incidents & Events

o Reports

o Most System Settings

FortiAnalyzer HA synchronizes most System Settings in the HA cluster. The following table shows which System Setting
configurations are synchronized:

System Setting Configuration synchronized

Dashboard > System Information Only Administrative Domain is synchronized. All other settings in the
System Information widget are not synchronized.

All ADOMs Yes
Storage Info Yes
Network No
Network > SNMP Yes
HA No
Admin Yes
Certificates > Local Certificates No
FortiAnalyzer 7.4.0 Administration Guide 389
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System Setting Configuration synchronized
Certificates > CA Certificates Yes
Certificates > CRL Yes
Log Forwarding Yes
Fetcher Management Yes
Event Log No
Task Monitor Yes
Advanced > Mail Server Yes
Advanced > Syslog Server Yes
Advanced > Meta Fields Yes
Advanced > Device Log Settings Yes
Advanced > File Management Yes
Advanced > Advanced Settings Yes

Geo-redundant HA

The active-active mode for FortiAnalyzer HA helps to create a geo-redundant solution.

In FortiAnalyzer HA active-passive mode, a layer 2 connection is required between HA members in order to set up the
HA cluster virtual IP. In active-active mode, however, a layer 2 connection is not required between data centers at
different locations.

Below is a brief comparison between FortiAnalyzer HA in active-passive and active-active mode.

active-passive active-active

Only the HA primary can receive logs and archive files All HA members can receive logs and archive files from
from its directly connected device and forward them to HA its directly connected device and forward logs and
secondary. archive files to its HA peer.

Only the HA primary can forward data to the remote All HA members can forward its directly received logs and
server. archive file to the remote server.

In the examples below, the goal is to build an active-active geo-redundant layer 3 FortiAnalyzer HA cluster between two
data centers. The FortiAnalyzer HA members are located in different places. They are communicating with each other
via routers. There is no layer 2 connection.

Unicast must be enabled for the HA heartbeat in order for the cluster to operate in this mode.

O ! ’, This setting can only be configured from the CLI. For more information on enabling the unicast
q heartbeat setting, see the FortiAnalyzer CLI Reference.
- When unicast is enabled, VRRP packets are sent to the peer address instead of the multicast

address. VRRP (IP protocol 112) must be allowed through any connecting firewalls.
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To build a geo-redundant FortiAnalyzer HA via the GUI:

1. In the first FortiAnalyzer, configure the primary in System Settings > HA.

For Operation Mode, select Active-Active.

For Preferred Role, select Primary.

Complete the other fields, including Peer IP and Peer SN.

Cluster Virtual IP (VIP) is optional. It requires a layer 2 connection between HA members. If VIP is not
configured, select the interface which is used to communicate with the peer as Heart Beat Interface. You can
click the Xicon next to the VIP entry to remove it.

@ Dashboard Cluster Status
& Device Manager
@ Fortiview >

M Log View > [0 [Roles
@ FabricView > | O Primary
Incidents & Events s | O  Secondary
B Reports > | Cluster Settings
4 System Settings v

ADOMs Operation Mode

Administrators
Admin Profiles Preferred Role
Remote Authentication Server

Cluster Virtual IP
Fabric Management

SAMLSSO IP Address and Interface
Settings
Network Cluster Settings
Event Logs Peer IP and Peer SN
Certificates
Advanced

Group Name

Group ID

FE:RTINET

Serial Number P Host Name = Uptime/Downtime Initial Logs Sync Confguration Sync + Message * n
FAZVMTM 7 192168.2.102 FAZVM64-102 41d0h 23m42s @Config will be synced to secondaries
FAZVMTM s 1921681101 FAZVM64-101 4230 35m 205 ©@Done Oin-Sync
Standalone | Active-Passive
Secondary
1P Address Interface Action
1026093 portl - x+
PeerIP Peer SN Action
1921681101 FAZVMTM %+
FAZVM64-HA
100 1-259)
........ °
4 Seconds
portl -
120 (80-120)
©

2. Inthe second FortiAnalyzer, configure the primary in System Settings > HA.
» For Operation Mode, select Active-Active.
» For Preferred Role, select Secondary.

» Complete the other fields, including Peer IP and Peer SN.

» Cluster VIP is optional. It requires a layer 2 connection between HA members. If VIP is not configured, select
the interface which is used to communicate with the peer as Heart Beat Interface. You can click the Xicon next
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to the VIP entry to remove it.

£13 FAZVM64-101

@ Dashboard

| Device Manager

Cluster Status

,
]
B Fortiview >
m tegvien L O Troes Serial Number & s Host Name = Uptime/Downtime =
@ FabrcView s O Primay FAZ-VMTM 7 1921682102 FAZVMo4-102 423h 19m 515
Incidents & Events 5| O Secondary FAZVMTM s 1921681101 FAZVMo4-101 #23h 20m 265
B Reports > | Cluster Settings
© System Settings v
ADOMs Operation Mode Standalone | Active-Passive
Administrators
i e Prefered Rle Primary
Remote Authentication s,
Cluster Virtual IP
Fabric Management
SAMLSSO 1P Address and Interface 1P Address Interface Action
Settings 1026093 port1 - x4+
HA
Network Cluster Settings
Event Logs Peer IP and Peer SN Peer P Peer SN Action
Certifcates
1921682.102 FAZVMTM 7 x|+
Advanced
Group Name FAZVMB4-HA
Group ID 100 (1-255)
Password [ eeeessen
Heart Beat Interval 4 Seconds
Heart Beat Interface port1 -
Failover Threshold
Priority 100 (80-120)
Log Data Sync ©
FeATINET

To build a geo-redundant FortiAnalyzer HA via the CLI:

Initial Logs Sync &

©Done

[

Configuration Sync +

©in-Sync

For more information about the FortiAnalyzer CLI commands, see the FortiAnalyzer 7.4 CLI Reference.

1. Configure the FortiAnalyzer HA.
When configuring the FortiAnalyzersystem ha, setmode to a-a. The vip is optional; if there is no layer 2

connection between HA members, vip will not work. In this case, set hb-interface as the interface which is

used to communicate with the peer.

a. Configure the first FortiAnalyzer. In the CLI, enter the following commands:

config
set
set
set
set
set
set

system ha
mode a-a
group-id 100

group-name "FAZVM64-HA"
hb-interface "portl"
unicast enable

password XXXXXX

config peer

edit 1

set ip "192.168.1.101"

set serial-number

next

end

set preferred-role primary

set

end

b. Configure the second FortiAnalyzer. In the CLI, enter the following commands:
config system ha

set
set
set
set
set
set

priority 120

mode a-a
group-id 100

group-name "FAZVM64-HA"

hb-interface "
unicast enable

portl"

password XXXXXX
config peer

FortiAnalyzer 7.4.0 Administration Guide
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edit 1
set ip "192.168.2.102"
set serial-number "FAZ-VMTM----- 7"
next
end

end
2. Ifthe alternate FortiAnalyzer can be configured on FortiGate, set server tothe HA primary and set alt-
server to the HA secondary. In the FortiGate CLI, enter:

config log fortianalyzer setting
set status enable

set ?
*server The main remote FortiAnalyzer.
alt-server The alternate remote FortiAnalyzer.

set server 192.168.2.102
set alt-server 192.168.1.101

end
3. Ifthe alternate FortiAnalyzer cannot be configured on FortiGate, set server to a HA member which is reachable
from the FortiGate or to the VIP address of the FortiAnalyzer HA, if any. In the FortiGate CLI, enter:

config log fortianalyzer setting
set status enable

set server 192.168.2.102 (or 10.2.60.93)

end

Monitoring HA status

In System Settings > HA, the Cluster Status pane shows the HA status. This pane displays information about the role of
each cluster unit, the HA status of the cluster, and the HA configuration of the cluster.

Ay
‘?' You can use the CLI command diagnose ha status to display the same HA status
- information.

The Cluster Status pane displays the following information:

Role Role of each cluster member.
Serial Number Serial number of each cluster member.
IP IP address of each cluster members including the host.
Host Name Host name of the HA cluster.
Uptime/Downtime Uptime or downtime of each cluster member.
Initial Logs Sync Status of the initial logs synchronization.
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Configuration Sync Status of synchronizing configuration data.

Message Status or error messages, if any.

If the primary unit fails

If the primary unit becomes unavailable, another unit in the cluster is selected as the primary unit using the following
rules:

« All cluster units are assigned a priority from 80 — 120. The default priority is 100. If the primary unit becomes
unavailable, an available unit with the highest priority is selected as the new primary unit. For example, a unit with a
priority of 110 is selected over a unit with a priority of 100.

« If multiple units have the same priority, the unit whose primary IP address has the greatest value is selected as the
new primary unit. For example, 123.45.67.124 is selected over 123.45.67.123.

« If a new unit with a higher priority or a greater value IP address joins the cluster, the new unit does not replace (or
preempt) the current primary unit.

Load balancing

Because FortiAnalyzer HA synchronizes logs among HA units, the HA cluster can balance the load and improve overall
responsiveness. Load balancing enhances the following modules:

» Reports
o FortiView

When generating multiple reports, the loads are distributed to all HA cluster units in a round-robin fashion. When a report
is generated, the report is synchronized with other units so that the report is visible on all HA units.

Similarly, for FortiView, cluster units share some of the load when these modules generate output for their widgets.

Upgrading the FortiAnalyzer firmware for an operating cluster

For information on upgrading the FortiAnalyzer firmware for an operating cluster, see the FortiAnalyzer Upgrade Guide
on the Fortinet Docs Library.
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Collectors and Analyzers

This topic describes how to configure two FortiAnalyzer units as the Analyzer and Collector and make them work
together. In the scenario shown in the diagram below, Company A has a remote branch network with a FortiGate unit
and a FortiAnalyzer 400E in Collector mode. In its head office, Company A has another FortiGate unitand a
FortiAnalyzer 3000D in Analyzer mode. The Collector forwards the logs of the FortiGate unit in the remote branch to the
Analyzer in the head office for data analysis and reports generation. The Collector is also used for log archival.

Remote Branch Office Head Office
) QT . =

Log Forwarding

| g
@ Log Fetching @

Ld
FortiAnalyzer 400E FortiAnalyzer 3000D
Collector Mode Analyzer Mode

For related concepts, see Operation modes on page 31 and Analyzer—Collector collaboration on page 33. You need to
complete the initial setup for your FortiAnalyzer units first. See Initial setup on page 29.

Configuring the Collector

To configure the Collector:

1. Ensure the FortiAnalyzer Operation Mode is Collector. See Configuring the operation mode on page 49.
2. Check and configure the storage policy for the Collector. See Log storage information on page 130.

NP For the Collector, you should allocate most of the disk space for Archive logs. You should
‘Q' keep the Archive logs long enough to meet the regulatory requirements of your
- organization. After this initial configuration, you can monitor the storage usage and adjust it
- as you go.
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Following is a storage configuration example of the Collector.

Edit Log Storage Policy - ADOM : Branch_office_FGT

Data Palicy
Keep Logs for Analytics 0 Days
Keep Logs for Archive 365 Days
Disk Utilization
Maximum Allowed 1 TE v Out of Available: 4.5 TB
Analytics : Archive 59 v 959 B Modify
Alert and Delete When 90%

Usage Reaches

*If analytic or archive log usages exceed the configured disk quota before the retention period
expires, the oldest logs will be deleted.

=]

3. Setup log forwarding to enable the Collector to forward the logs to the Analyzer. See Log Forwarding on page 315.
In particular,

o Set Remote Server Type to FortiAnalyzer.
« Set Server IPto the IP address of the Analyzer that this Collector will forward logs to.
» Click Select Device and select the FortiGate device that the Collector will forward logs for.

Configuring the Analyzer

To configure the Analyzer:

1. Ensure the FortiAnalyzer Operation Mode is Analyzer. See Configuring the operation mode on page 49
2. Check and configure the storage policy for the Analyzer. See Log storage information on page 130.

want to keep the Analytics logs for 30-90 days. After this initial configuration, you can

\‘é', For the Analyzer you should allocate most of the disk space for Analytics logs. You may
3 monitor the storage usage and adjust it as you go.
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Following is a storage configuration example of the Analyzer.

Edit Log Storage Policy - ADOM : For_Branch_Office

Data Palicy
Keep Logs for Analytics &0 Days
Keep Logs for Archive 0 Days
Disk Utilization
Maximum Allowed 1 TB v Out of Available: 4.5 TB
Analytics : Archive 95% « 59 B Modify
Alert and Delete When 90%

Usage Reaches

*If analytic or archive log usages exceed the configured disk quota before the retention period
expires, the oldest logs will be deleted.

3. Make sure that the aggregation service is enabled on the Analyzer. If not, use this CLI command to enable it:
config system log-forward-service
set accept-aggregation enable
end
4. Add the FortiGate device of the remote office that the Collector will forward logs for. See Authorizing devices on
page 65.

Once the FortiGate of the remote office is added, the Analyzer starts receiving its logs from the Collector.

Fetching logs from the Collector to the Analyzer

At times, you might want to fetch logs from the Collector to the Analyzer. The Collector will perform the role of the fetch
server, and the Analyzer will perform the role of fetch client. For information about how to conduct log fetching, see Log
Fetching on page 322.
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Management Extensions

The Management Extensions pane allows you to enable licensed applications that are released and signed by Fortinet.
The applications are installed and run on FortiAnalyzer.

The Management Extensions pane is only displayed in the GUI after at least one management
x extension application (MEA) is enabled and running on FortiAnalyzer.

You must enable your first MEA using the CLI; subsequent MEAs can be enabled using
the GUI.

A number of management extension applications (MEAs) are available. The following table identifies the available
applications and any ADOM requirements needed to access the application:

Management Extension Application ADOM Requirements for Access

FortiSOAR MEA on page 398 Root fabric ADOM
FortiSIEM MEA on page 398

See also Enabling management extension applications on page 399.

For information on how to access event logs for a management extension, see Accessing management extension logs
on page 400.

FortiSIEM MEA

You can enable the FortiSIEM management extension application (MEA) on FortiAnalyzer. FortiSIEM uses machine
learning to detect unusual user and entity behavior (UEBA) without requiring the administrator to write complex rules.
FortiSIEM helps identify insider and incoming threats that would pass traditional defenses. High fidelity alerts help
prioritize which threats need immediate attention.

For details about using FortiSIEM MEA, see the FortiSIEM MEA Administration Guide on the Document Library.

FortiSOAR MEA

You can enable the Fortinet Security Orchestration, Automation, and Response (FortiSOAR) management extension
application (MEA) on FortiAnalyzer, and use it to manage the entire lifecycle of a threat or breach within your
organization. For details about using FortiSOAR MEA, see the FortiSOAR MEA Administration Guide on the Document
Library.
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Enabling management extension applications

Some management extension applications require a minimum amount of memory or a

minimum number of CPU cores.
Before you enable a management extension application, review the requirements in the

FortiAnalyzer Release Notes.

FortiAnalyzer provides access to applications that are released and signed by Fortinet.

A CA certificate is required to install management extensions on FortiAnalyzer. See CA

“é’, Only administrators with a Super_User profile can enable management extensions.
- certificates on page 313.

To enable management extensions:

1. Go to Management Extensions.

« The first MEA used on FortiAnalyzer must be enabled using the CLI. After it is enabled and running, the
Management Extensions pane is displayed in the GUI and subsequent MEAs can be enabled in the GUI
following the steps below. For instructions on enabling your first MEA, see CLI for management extensions on
page 399.

« Some management applications are only available in the root ADOM or in specific ADOM versions.

2. Click a grayed out tile to enable the application.
Grayed out tiles represent disabled applications.

3. Click OKin the dialog that appears. It might take some time to install the application.

CLI for management extensions

You can use the CLI console to enable, disable, update, debug, and check the management extension.

To enable management extensions:

1. Enable the production registry:
FAZ-VM64 # config system docker
(docker) # set status
enable Enable production registry.

2. Enable the management application.
(docker) # set
fortisoar Enable/disable container.
fsmcollector Enable/disable container.

FortiAnalyzer supports FortiSIEM MEA and FortiSOAR MEA. Although you can use the CLI to

enable additional management extension applications, they are not supported by
FortiAnalyzer. Enabled, unsupported management extension applications are hidden from the

FortiAnalyzer GUI, but still consume valuable resources. Be sure to only enable

FortiSIEM MEA and/or FortiSOAR MEA on FortiAnalyzer when using the CLI.
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Management Extensions

To disable management extensions:
config system docker

(docker) # get
(docker)# set {fsmcollector | fortisoar} disable

To debug management extensions:

diagnose debug application docker

To clean up or check management extensions:

diagnose docker {cleanup|status}

To limit CPU and RAM resources for management extensions:

config system docker
(docker) # set cpu <integer> #Set the maximum $ of CPU usage (10 - 50, default = 50).
(docker) # set mem <integer> #Set the maximum $ of RAM usage (10 - 50, default 50) .

V) ¢ The CLI commands allow you to set the resource limit globally for all management
‘?' extension applications.
- ¢ If management extension applications reach the limit of allocated FortiAnalyzer resource,
= a warning appears in the Alert Message Console widget.

See also Checking for new versions and upgrading on page 401.

Accessing management extension logs

Event logs generated by a management extension are available in the local event log of FortiAnalyzer. They are
displayed in the following locations:

e Dasboard > Alert Message Console widget
» System Settings > Event log pane

To access management extension logs in the Alert Message Console widget:

1. Goto Dashboard > Alert Message Console widget.
The recently generated management extension local logs are displayed in the Alert Message Console widget.

To access management extension logs in the Event Log pane:

1. Goto System Settings > Event Log to view the local log list.
The recently generated management extension local logs are displayed in the Event Log pane.
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Checking for new versions and upgrading

You can check whether a new version of an enabled management extension application is available on the Fortinet
registry by using the CLI.

When the latest version of an enabled management extension application is running on FortiAnalyzer, the version is
reportedas (up to date).When a new image is available on the Fortinet registry for an enabled management
extension application, the output displays (new image available).

In the example below, FortiSOAR MEA is enabled and a new version is available for installation. You can upgrade
FortiSOAR MEA by using the CLI.

To check for new versions of enabled management extensions:
diagnose docker status

fortisoar: running (new image available)
fsmcollector: disabled

To upgrade enabled management extensions:

diagnose docker upgrade {fsmcollector | fortisoar}
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This section identifies the request for comment (RFC) notes supported by FortiAnalyzer.

RFC 2548

Description:

Microsoft Vendor-specific RADIUS Attributes

Category:
Informational
Webpage:

http://tools.ietf.org/html/rfc2548

RFC 2665

Description:

Ethernet-like MIB parts that apply to FortiAnalyzer units.

Category:
Standards Track
Webpage:

http://tools.ietf.org/html/rfc2665

RFC 1918

Description:

Address Allocation for Private Internets.
Category:

Best Current Practice

Webpage:

http://tools.ietf.org/html/rfc1918
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RFC 1213

Description:

MIB Il parts that apply to FortiAnalyzer units.
Category:

FortiAnalyzer (SNMP)

Webpage:

http://tools.ietf.org/html/rfc1213
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Appendix B - Log Integrity and Secure Log Transfer

This section identifies the options for enabling log integrity and secure log transfer settings between FortiAnalyzer and
FortiGate devices.

Log Integrity

FortiAnalyzer can create an MD5 checksum for each log file in order to secure logs from being modified after they have
been sent to an analytics platform.

The log integrity setting selected determines the values recorded at the time of transmission or when rolling the log:

« MD5: Record the log file's MD5 hash value only.
o MDS5-auth: Record the log file's MD5 hash value and authentication code.
» None: Do not record the log file checksum (default).

Configuring log integrity settings

To configure FortiAnalyzer log integrity:

1. Inthe FortiAnalyzer CLlI, enter the following commands:
configure system global
set log-checksum {md5 | md5-auth | none}
end

Verifying log-integrity

When log integrity settings are applied, you can view the MD5 checksum for logs in FortiAnalyzer event logs and the
FortiAnalyzer CLI.

To view the log file's MD5 checksum in event logs:

1. Goto Incidents & Events > Event Monitor > All Events and select an event log.

2. Inthetoolbar, select Display Raw to view the raw log details.
The MD5 checksum is included in the details of the raw log.
1d=6906469110439837696 itime=2020-12-18 06:47:59 euid=1 epid=1 dsteuid=1 dstepid=1l
log id=0031040026 subtype=logfile type=event level=information time=06:47:59
date=2020-12-18 user=system action=roll msg=Rolled log file tlog.1608270213.1log
of device FGVM01TM20000000 [FGVM01TM20000000] vdom root, MD5 checksum:
ad85f8e889a3436d75b22b4a33c492ec userfrom=system desc=Rolling disk log file
devid=FAZVMSTM20000000 devname=FAZVMSTM20000000 dtime=2020-12-18 06:47:59 itime
t=1608270479
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To query the log file's MD5 checksum in the CLI:

1. Enter the following command in the FortiAnalyzer CLI:
execute log-integrity <device name> <vdom name> <log name>
For example:
execute log-integrity FGVM01TM20000000 root tlog.1608279204.log.gz
Integrity checking passed:
MD5 checksum is [82598ec0086319db73bd0£9de2396047]

Secure Log Transfer

Optimized Fabric Transfer Protocol (OFTP) is a proprietary Fortinet protocol. It is used for connectivity, performing
health checks, file transfers, and log display on FortiGate. OF TP listens on ports TCP514 and UDP514.

In the default configuration, there are two communication streams between FortiGate and FortiAnalyzer.
OFTP communication is encrypted and log communication is not.

o OFTP communication occurs on TCP514 using TLS.
» Log communication occurs on UDP514 (default setting).

Default FortiGate Settings

OFTP - TCP514 (TLS)

Log - UDP514

To secure log transfer, you can enable TCP and encryption. When enabled, logs are transferred securely between the
FortiGate and FortiAnalyzer using TCP514 (TLS).

Secure Log Transfer

OFTP - TCP514 (TLS)

Log - TCP514 (TLS)

Configuring secure log transfer settings

To enable secure log transfer:

1. Inthe FortiGate CLI, enter the following commands:
configure log fortianalyzer setting
set reliable enable
end
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A Enabling secure log transfer over TCP will impact overall logging performance.

Ay

S L4

q OFTP SSL protocol supports SSLv3, TLSv1.0, TLSv1.2, and TLSv1.3 (default TLSv1.2).

Log caching with secure log transfer enabled

When secure log transfer is enabled, log sync logic guarantees that no logs are lost due to connection issues between
the Fortigate and FortiAnalyzer. When connection is lost, logs will be cached and sent to FortiAnalyzer once the
connection resumes.

To confirm cached logs are sent when connection is lost/resumed between FortiGate and FortiAnalyzer:

1. Confirm the value of logsync_enabledis 1 on the FortiGate device.
In the FortiGate CLI, enter the following command:
diagnose test application fgtlogd 1

faz2: global , enabled
server=10.2.169.54, realtime=1, ssl=1, state=connected
server log status=Log is allowed.,
src=, mgmt name=FGh Log root 10.2.169.54, reliable=1, sni prefix type=none,
required entitlement=none, region=ca-west-1,
logsync_enabled:1, logsync conn 1d:131071, seq no:257
status: ver=6, used disk=0, total disk=0, global=0, vfid=0 conn verified=Y
SNs: last sn update:2097 seconds ago.
Sn list:
(FAZ-VM0000000001, age=2097s) (FAZ-VMJY00000004,age=2097s)
queue: glen=0.
filter: severity=6, sz exclude list=0
2. While connection between the FortiGate and FortiAnalyzer is established, check the log sequence number on the
OFTP connection.
In the FortiAnalyzer CLI, enter the following command:
diagnose test application oftpd 3
# DEVICE CONN HOSTNAME IP UPTIME IDLETIME #PKTS

1 FGT40FTK20025663 131071: 257 FortiGate-40F 10.3.169.1 31ml4s 4s 620
The coNN column has been added to record the connection ID and log sequence number. In this example, the
connection ID is 131071 and the sequence numberis 257.
3. When connection between the FortiGate and FortiAnalyzer is lost, check the log sequence number on the OFTP
connection.
In the FortiAnalyzer CLI, enter the following command:

diagnose test application oftpd 3
# DEVICE CONN HOSTNAME IP UPTIME IDLETIME #PKTS
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1 FGT40FTK20025663 131071: 257 FortiGate-40F 10.3.169.1 35mlds 244s 620
While the connection is lost, logs generated on the FortiGate device will be stored in its memory queue. The log
squence number on the OF TP connection will not increase. In this example, the log sequence number has
remained at 257.

4. When the connection between the FortiGate and FortiAnalyzer devices resumes, check logs on the FortiGate

device.
In the FortiGate CLI, enter the following command:

diagnose test application fgtlogd 41

cache maximum: 100573388 (95MB) objects: 37 used: 25788 (0MB) allocated: 29440 (0OMB)

VDOM: root
Memory queue for: global-faz
queue:
num:0 size:0(0MB) total size:25788 (0MB) max:100573388 (95MB) logs:0
Confirm queue for: global-faz
queue:
num:25 size:17382 (0MB) total size:25788(0MB) max:100573388 (95MB) logs:81
Memory queue for: global-faz2
queue:
num:0 size:0(0MB) total size:25788 (0MB) max:100573388 (95MB) logs:0
Confirm queue for: global-faz2
queue:
num:12 size:8406(0MB) total size:25788 (0MB) max:100573388 (95MB) logs:40

The confirm queue on the FortiGate device shows all the logs that are waiting to be confirmed and cleared. Once
the confirm queue displays 0, all of the cached logs have been sent to the FortiAnalyzer device.

5. Once the logs have been confirmed and cleared from the FortiGate device, check the log sequence number on the
OFTP connection.
In the FortiAnalyzer CLI, enter the following command:

diagnose test application oftpd 3
# DEVICE CONN HOSTNAME IP UPTIME IDLETIME #PKTS

1 FGT40FTK20025663 131071: 308 FortiGate-40F 10.3.169.1 36m23s 6s 635
Once the cached logs have been sent to the FortiAnalyzer device, the log sequence number increases. In this
example, the log sequence number has increased to 308.

Supported ciphers

The list of supported ciphers is determined when configuring enc_algorithmusingthe configure log
fortianalyzer settingcommand inthe FortiGate CLI.

Cipher security levels

FortiAnalyzer allows administrators to specify the security levels for cipher suites as low, medium, or high. Using a higher

security level means using more secure ciphers. SSL static key ciphers can be disabled to support forward secrecy.

Defining the enc-algorithmand ssl-static-key-ciphers usage settings in FortiAnalyzer allows administrators

to choose which OpenSSL cipher suites are supported.

e Lowenc-algorithmuses all OpenSSL ciphers.
e Medium enc-algorithm uses high and medium OpenSSL ciphers.
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e High enc-algorithm uses only high OpenSSL ciphers.
o Disabling ss1-static-key-ciphers enables forward secrecy.

To configure the cipher suite security level in the FortiAnalyzer CLI:

1. Enter the following command in the FortiAnalyzer CLI:
config system global
set enc-algorithm {high | medium | low}
set ssl-static-key-ciphers {enable | disable}
end

Ifenc-algorithmis setto custom, configure the ssl-cipher-suites table to enforce the user specified preferred cipher
order in the incoming SSL connections. Enter the following command:

config system global
config ssl-cipher-suites
edit <priority>
set cipher <string>
set version {tlsl.2-or-below | tlsl.3}
end

If using enc-algorithmis setto high, medium, or 1ow, see the list of supported ciphers based on security level
settings below.

ssl-static-key-ciphers enabled
enc-algorithm

Low TLS_AES_256_GCM_SHA384:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_
128_GCM_SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-
AES256-GCM-SHA384:DHE-DSS-AES256-GCM-SHA384:DHE-RSA-AES256-
GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY 1305:ECDHE-RSA-
CHACHA20-POLY 1305:DHE-RSA-CHACHA20-POLY 1305:ECDHE-ECDSA-
AES256-CCM:DHE-RSA-AES256-CCM:ECDHE-ECDSA-ARIA256-GCM-
SHA384:ECDHE-ARIA256-GCM-SHA384:DHE-DSS-ARIA256-GCM-
SHA384:DHE-RSA-ARIA256-GCM-SHA384:ECDHE-ECDSA-AES256-
SHA384:ECDHE-RSA-AES256-SHA384:DHE-RSA-AES256-SHA256:DHE-DSS-
AES256-SHA256:ECDHE-ECDSA-CAMELLIA256-SHA384:ECDHE-RSA-
CAMELLIA256-SHA384:DHE-RSA-CAMELLIA256-SHA256:DHE-DSS-
CAMELLIA256-SHA256:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-
SHA:DHE-RSA-AES256-SHA:DHE-DSS-AES256-SHA: DHE-RSA-CAMELLIA256-
SHA:DHE-DSS-CAMELLIA256-SHA:RSA-PSK-AES256-GCM-SHA384:DHE-PSK-
AES256-GCM-SHA384:RSA-PSK-CHACHA20-POLY 1305:DHE-PSK-CHACHA20-
POLY1305:ECDHE-PSK-CHACHA20-POLY 1305:DHE-PSK-AES256-CCM:RSA-
PSK-ARIA256-GCM-SHA384:DHE-PSK-ARIA256-GCM-SHA384:AES256-GCM-
SHA384:AES256-CCM:ARIA256-GCM-SHA384:PSK-AES256-GCM-SHA384:PSK-
CHACHA20-POLY1305:PSK-AES256-CCM:PSK-ARIA256-GCM-
SHA384:AES256-SHA256: CAMELLIA256-SHA256:ECDHE-PSK-AES256-CBC-
SHA384:ECDHE-PSK-AES256-CBC-SHA:SRP-DSS-AES-256-CBC-SHA:SRP-
RSA-AES-256-CBC-SHA:SRP-AES-256-CBC-SHA:RSA-PSK-AES256-CBC-
SHA384:DHE-PSK-AES256-CBC-SHA384:RSA-PSK-AES256-CBC-SHA:DHE-
PSK-AES256-CBC-SHA:ECDHE-PSK-CAMELLIA256-SHA384:RSA-PSK-
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Medium

CAMELLIA256-SHA384:DHE-PSK-CAMELLIA256-SHA384:AES256-
SHA:CAMELLIA256-SHA:PSK-AES256-CBC-SHA384:PSK-AES256-CBC-
SHA:PSK-CAMELLIA256-SHA384:ECDHE-ECDSA-AES128-GCM-
SHA256:ECDHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-
SHA256:DHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-CCM:DHE-
RSA-AES128-CCM:ECDHE-ECDSA-ARIA128-GCM-SHA256:ECDHE-ARIA128-
GCM-SHA256:DHE-DSS-ARIA128-GCM-SHA256:DHE-RSA-ARIA128-GCM-
SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:DHE-
RSA-AES128-SHA256:DHE-DSS-AES128-SHA256:ECDHE-ECDSA-
CAMELLIA128-SHA256:ECDHE-RSA-CAMELLIA128-SHA256:DHE-RSA-
CAMELLIA128-SHA256:DHE-DSS-CAMELLIA128-SHA256:ECDHE-ECDSA-
AES128-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES128-SHA:DHE-DSS-
AES128-SHA:DHE-RSA-CAMELLIA128-SHA:DHE-DSS-CAMELLIA128-
SHA:RSA-PSK-AES128-GCM-SHA256:DHE-PSK-AES 128-GCM-SHA256:DHE-
PSK-AES128-CCM:RSA-PSK-ARIA128-GCM-SHA256:DHE-PSK-ARIA128-GCM-
SHA256:AES128-GCM-SHA256:AES128-CCM:ARIA128-GCM-SHA256:PSK-
AES128-GCM-SHA256:PSK-AES128-CCM:PSK-ARIA128-GCM-SHA256:AES 128-
SHA256:CAMELLIA128-SHA256:ECDHE-PSK-AES128-CBC-SHA256:ECDHE-
PSK-AES128-CBC-SHA:SRP-DSS-AES-128-CBC-SHA:SRP-RSA-AES-128-CBC-
SHA:SRP-AES-128-CBC-SHA:RSA-PSK-AES128-CBC-SHA256:DHE-PSK-
AES128-CBC-SHA256:RSA-PSK-AES128-CBC-SHA:DHE-PSK-AES128-CBC-
SHA:ECDHE-PSK-CAMELLIA128-SHA256:RSA-PSK-CAMELLIA128-
SHA256:DHE-PSK-CAMELLIA128-SHA256:AES128-SHA:CAMELLIA128-
SHA:PSK-AES128-CBC-SHA256:PSK-AES128-CBC-SHA:PSK-CAMELLIA128-
SHA256:ECDHE-ECDSA-AES256-CCM8:ECDHE-ECDSA-AES128-CCM8:DHE-
RSA-AES256-CCM8:DHE-RSA-AES128-CCM8:DHE-PSK-AES256-CCM8:DHE-
PSK-AES128-CCM8:AES256-CCM8:AES128-CCM8:PSK-AES256-CCM8:PSK-
AES128-CCM8

TLS_AES_256_GCM_SHA384:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_
128_GCM_SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-
AES256-GCM-SHA384:DHE-DSS-AES256-GCM-SHA384: DHE-RSA-AES256-
GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY 1305:ECDHE-RSA-
CHACHA20-POLY 1305:DHE-RSA-CHACHA20-POLY 1305:ECDHE-ECDSA-
AES256-CCM:DHE-RSA-AES256-CCM:ECDHE-ECDSA-ARIA256-GCM-
SHA384:ECDHE-ARIA256-GCM-SHA384:DHE-DSS-ARIA256-GCM-
SHA384:DHE-RSA-ARIA256-GCM-SHA384:ECDHE-ECDSA-AES256-
SHA384:ECDHE-RSA-AES256-SHA384:DHE-RSA-AES256-SHA256:DHE-DSS-
AES256-SHA256:ECDHE-ECDSA-CAMELLIA256-SHA384:ECDHE-RSA-
CAMELLIA256-SHA384:DHE-RSA-CAMELLIA256-SHA256:DHE-DSS-
CAMELLIA256-SHA256:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-
SHA:DHE-RSA-AES256-SHA:DHE-DSS-AES256-SHA: DHE-RSA-CAMELLIA256-
SHA:DHE-DSS-CAMELLIA256-SHA:RSA-PSK-AES256-GCM-SHA384:DHE-PSK-
AES256-GCM-SHA384:RSA-PSK-CHACHA20-POLY 1305:DHE-PSK-CHACHA20-
POLY1305:ECDHE-PSK-CHACHA20-POLY 1305:DHE-PSK-AES256-CCM:RSA-
PSK-ARIA256-GCM-SHA384:DHE-PSK-ARIA256-GCM-SHA384:AES256-GCM-
SHA384:AES256-CCM:ARIA256-GCM-SHA384:PSK-AES256-GCM-SHA384:PSK-
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High

CHACHA20-POLY1305:PSK-AES256-CCM:PSK-ARIA256-GCM-
SHA384:AES256-SHA256:CAMELLIA256-SHA256:ECDHE-PSK-AES256-CBC-
SHA384:ECDHE-PSK-AES256-CBC-SHA:SRP-DSS-AES-256-CBC-SHA:SRP-
RSA-AES-256-CBC-SHA:SRP-AES-256-CBC-SHA:RSA-PSK-AES256-CBC-
SHA384:DHE-PSK-AES256-CBC-SHA384:RSA-PSK-AES256-CBC-SHA:DHE-
PSK-AES256-CBC-SHA:ECDHE-PSK-CAMELLIA256-SHA384:RSA-PSK-
CAMELLIA256-SHA384:DHE-PSK-CAMELLIA256-SHA384:AES256-
SHA:CAMELLIA256-SHA:PSK-AES256-CBC-SHA384:PSK-AES256-CBC-
SHA:PSK-CAMELLIA256-SHA384:ECDHE-ECDSA-AES128-GCM-
SHA256:ECDHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-
SHA256:DHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-CCM:DHE-
RSA-AES128-CCM:ECDHE-ECDSA-ARIA128-GCM-SHA256:ECDHE-ARIA128-
GCM-SHA256:DHE-DSS-ARIA128-GCM-SHA256:DHE-RSA-ARIA128-GCM-
SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:DHE-
RSA-AES128-SHA256:DHE-DSS-AES128-SHA256:ECDHE-ECDSA-
CAMELLIA128-SHA256:ECDHE-RSA-CAMELLIA128-SHA256:DHE-RSA-
CAMELLIA128-SHA256:DHE-DSS-CAMELLIA128-SHA256:ECDHE-ECDSA-
AES128-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES128-SHA:DHE-DSS-
AES128-SHA:DHE-RSA-CAMELLIA128-SHA:DHE-DSS-CAMELLIA128-
SHA:RSA-PSK-AES128-GCM-SHA256:DHE-PSK-AES 128-GCM-SHA256:DHE-
PSK-AES128-CCM:RSA-PSK-ARIA128-GCM-SHA256:DHE-PSK-ARIA128-GCM-
SHA256:AES128-GCM-SHA256:AES128-CCM:ARIA128-GCM-SHA256:PSK-
AES128-GCM-SHA256:PSK-AES128-CCM:PSK-ARIA128-GCM-SHA256:AES128-
SHA256:CAMELLIA128-SHA256:ECDHE-PSK-AES128-CBC-SHA256:ECDHE-
PSK-AES128-CBC-SHA:SRP-DSS-AES-128-CBC-SHA:SRP-RSA-AES-128-CBC-
SHA:SRP-AES-128-CBC-SHA:RSA-PSK-AES128-CBC-SHA256:DHE-PSK-
AES128-CBC-SHA256:RSA-PSK-AES128-CBC-SHA:DHE-PSK-AES128-CBC-
SHA:ECDHE-PSK-CAMELLIA128-SHA256:RSA-PSK-CAMELLIA128-
SHA256:DHE-PSK-CAMELLIA128-SHA256:AES128-SHA:CAMELLIA128-
SHA:PSK-AES128-CBC-SHA256:PSK-AES128-CBC-SHA:PSK-CAMELLIA128-
SHA256:ECDHE-ECDSA-AES256-CCM8:ECDHE-ECDSA-AES128-CCM8:DHE-
RSA-AES256-CCM8:DHE-RSA-AES128-CCM8:DHE-PSK-AES256-CCM8:DHE-
PSK-AES128-CCM8:AES256-CCM8:AES128-CCM8:PSK-AES256-CCM8:PSK-
AES128-CCM8

TLS AES 256 GCM_SHA384:TLS CHACHA20 POLY1305 SHA256:TLS AES
128_GCM_SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-
AES256-GCM-SHA384:DHE-DSS-AES256-GCM-SHA384:DHE-RSA-AES256-
GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY 1305:ECDHE-RSA-
CHACHA20-POLY1305:DHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-
AES256-CCM:DHE-RSA-AES256-CCM:ECDHE-ECDSA-ARIA256-GCM-
SHA384:ECDHE-ARIA256-GCM-SHA384:DHE-DSS-ARIA256-GCM-
SHA384:DHE-RSA-ARIA256-GCM-SHA384:ECDHE-ECDSA-AES256-
SHA384:ECDHE-RSA-AES256-SHA384:DHE-RSA-AES256-SHA256: DHE-DSS-
AES256-SHA256:ECDHE-ECDSA-CAMELLIA256-SHA384:ECDHE-RSA-
CAMELLIA256-SHA384:DHE-RSA-CAMELLIA256-SHA256:DHE-DSS-
CAMELLIA256-SHA256:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-
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fips enabled

SHA:DHE-RSA-AES256-SHA:DHE-DSS-AES256-SHA:DHE-RSA-CAMELLIA256-
SHA:DHE-DSS-CAMELLIA256-SHA:RSA-PSK-AES256-GCM-SHA384:DHE-PSK-
AES256-GCM-SHA384:RSA-PSK-CHACHA20-POLY1305:DHE-PSK-CHACHA20-
POLY1305:ECDHE-PSK-CHACHA20-POLY1305:DHE-PSK-AES256-CCM:RSA-
PSK-ARIA256-GCM-SHA384:DHE-PSK-ARIA256-GCM-SHA384:AES256-GCM-
SHA384:AES256-CCM:ARIA256-GCM-SHA384:PSK-AES256-GCM-SHA384:PSK-
CHACHA20-POLY1305:PSK-AES256-CCM:PSK-ARIA256-GCM-
SHA384:AES256-SHA256:CAMELLIA256-SHA256:ECDHE-PSK-AES256-CBC-
SHA384:ECDHE-PSK-AES256-CBC-SHA:SRP-DSS-AES-256-CBC-SHA:SRP-
RSA-AES-256-CBC-SHA:SRP-AES-256-CBC-SHA:RSA-PSK-AES256-CBC-
SHA384:DHE-PSK-AES256-CBC-SHA384:RSA-PSK-AES256-CBC-SHA:DHE-
PSK-AES256-CBC-SHA:ECDHE-PSK-CAMELLIA256-SHA384:RSA-PSK-
CAMELLIA256-SHA384:DHE-PSK-CAMELLIA256-SHA384:AES256-
SHA:CAMELLIA256-SHA:PSK-AES256-CBC-SHA384:PSK-AES256-CBC-
SHA:PSK-CAMELLIA256-SHA384:ECDHE-ECDSA-AES128-GCM-
SHA256:ECDHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-
SHA256:DHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-CCM:DHE-
RSA-AES128-CCM:ECDHE-ECDSA-ARIA128-GCM-SHA256:ECDHE-ARIA128-
GCM-SHA256:DHE-DSS-ARIA128-GCM-SHA256:DHE-RSA-ARIA128-GCM-
SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:DHE-
RSA-AES128-SHA256:DHE-DSS-AES128-SHA256:ECDHE-ECDSA-
CAMELLIA128-SHA256:ECDHE-RSA-CAMELLIA128-SHA256:DHE-RSA-
CAMELLIA128-SHA256:DHE-DSS-CAMELLIA128-SHA256:ECDHE-ECDSA-
AES128-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES128-SHA:DHE-DSS-
AES128-SHA:DHE-RSA-CAMELLIA128-SHA:DHE-DSS-CAMELLIA128-
SHA:RSA-PSK-AES128-GCM-SHA256:DHE-PSK-AES 128-GCM-SHA256:DHE-
PSK-AES128-CCM:RSA-PSK-ARIA128-GCM-SHA256:DHE-PSK-ARIA128-GCM-
SHA256:AES128-GCM-SHA256:AES128-CCM:ARIA128-GCM-SHA256:PSK-
AES128-GCM-SHA256:PSK-AES128-CCM:PSK-ARIA128-GCM-SHA256:AES128-
SHA256:CAMELLIA128-SHA256:ECDHE-PSK-AES128-CBC-SHA256:ECDHE-
PSK-AES128-CBC-SHA:SRP-DSS-AES-128-CBC-SHA:SRP-RSA-AES-128-CBC-
SHA:SRP-AES-128-CBC-SHA:RSA-PSK-AES128-CBC-SHA256:DHE-PSK-
AES128-CBC-SHA256:RSA-PSK-AES128-CBC-SHA:DHE-PSK-AES128-CBC-
SHA:ECDHE-PSK-CAMELLIA128-SHA256:RSA-PSK-CAMELLIA128-
SHA256:DHE-PSK-CAMELLIA128-SHA256:AES128-SHA:CAMELLIA128-
SHA:PSK-AES128-CBC-SHA256:PSK-AES128-CBC-SHA:PSK-CAMELLIA128-
SHA256

TLS_AES_256_GCM_SHA384:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_
128_GCM_SHA256:AES256-SHA:AES256-SHA256:DHE-RSA-AES256-
SHA:DHE-RSA-AES256-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-
AES256-GCM-SHA384:ECDHE-ECDSA-AES256-SHA:ECDHE-ECDSA-AES256-
GCM-SHA384:AES128-SHA:AES128-SHA256:DHE-RSA-AES128-SHA: DHE-
RSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-RSA-AES128-GCM-
SHA256:ECDHE-ECDSA-AES128-SHA:ECDHE-ECDSA-AES 128-GCM-SHA256

The following ciphers are not available when using forward secrecy (ss1-static-key-ciphers is disabled).

ssl-static-key-ciphers disabled
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enc-algorithm

Low

Medium

High

fips enabled

AES256-GCM-SHA384:AES256-CCM:ARIA256-GCM-SHA384:AES256-
SHA256:CAMELLIA256-SHA256:AES256-SHA:CAMELLIA256-SHA:AES128-
GCM-SHA256:AES128-CCM:AES128-SHA256: CAMELLIA128-SHA256:AES128-
SHA:CAMELLIA128-SHA:AES256-CCM8:AES128-CCM8

AES256-GCM-SHA384:AES256-CCM:ARIA256-GCM-SHA384:AES256-
SHA256:CAMELLIA256-SHA256:AES256-SHA:CAMELLIA256-SHA:AES128-
GCM-SHA256:AES128-CCM:AES128-SHA256:CAMELLIA128-SHA256:AES128-
SHA:CAMELLIA128-SHA:AES256-CCM8:AES128-CCM8

AES256-GCM-SHA384:AES256-CCM:ARIA256-GCM-SHA384:AES256-
SHA256:CAMELLIA256-SHA256:AES256-SHA:CAMELLIA256-SHA:AES128-
GCM-SHA256:AES128-CCM:AES128-SHA256:CAMELLIA128-SHA256:AES128-
SHA:CAMELLIA128-SHA

AES256-SHA:AES256-SHA256:AES128-SHA:AES128-SHA256

Maximum TLS/SSL version compatibility

The tables below indicate the maximum supported TLS version that you can configure for communication between a
FortiGate and FortiAnalyzer, as well as FortiAnalyzer's configured with log forwarding when the type is FortiAnalyzer.

For more information on secure log transfer and log integrity settings between FortiGate and FortiAnalyzer, see
Appendix B - Log Integrity and Secure Log Transfer on page 404.

Maximum configurable TLS version for FortiGate to FortiAnalyzer communication:

FGT 6.4.0+

FGT 6.2.3 -6.2.8
FGT 6.2.0 - 6.2.2
FGT 6.0.2 - 6.0.12

FGT 6.0.0 - 6.0.1

FAZ 6.4.0+ FAZ 6.2.0+ FAZ 6.0.0+

tlsv1.3 tlsv1.2 tlsv1.2

tlsv1.3 tisv1.2 tisv1.2

tisv1.2 tisv1.2 tlsv1.2

tisv1.2 tisv1.2 tisv1.2

The setting is not This setting is not This setting is not
configurable in FGT 6.0.0- | configurable in FGT 6.0.0 - | configurable in FGT 6.0.0 -
6.0.1. 6.0.1. 6.0.1.

Maximum configurable TLS version for FortiAnalyzer to FortiAnalyzer log forwarding:

FAZ 6.4.0+

FAZ 6.4.0+ FAZ 6.2.0+ FAZ 6.0.0+
tlsv1.3 tlsv1.2 tlsv1.2
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FAZ 6.2.0+ tlsv1.2 tlsv1.2 tlsv1.2

FAZ 6.0.0+ tisv1.2 tlsv1.2 tlsv1.2

To configure the global TLS/SSL version on FortiAnalyzer:

1. Inthe FortiAnalyzer CLI, enter the following:
config system global

set ssl-protocol {tlsvl.3 | tlsvl.2 | tlsvl.l | tlsvl.0 | sslv3}

To configure the global TLS/SSL version on FortiGate:

1. Inthe FortiGate CLI, enter the following:
config system global

set ssl-min-proto-version {tlsvl.3 | tlsvl.2 | tlsvl.l | tlsvl.0 | sslv3}
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Appendix C - FortiAnalyzer Ansible Collection
documentation

Documentation for the Fortinet FortiAnalyzer Ansible Collection is available through the link below.

o FortiAnalyzer Ansible Collection documentation
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https://ansible-galaxy-fortianalyzer-docs.readthedocs.io/en/latest/
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