
FortiAnalyzer - New Features Guide
Version 6.4.0



FORTINET DOCUMENT LIBRARY
https://docs.fortinet.com

FORTINET VIDEO GUIDE
https://video.fortinet.com

FORTINET BLOG
https://blog.fortinet.com

CUSTOMER SERVICE & SUPPORT
https://support.fortinet.com

FORTINET TRAINING & CERTIFICATION PROGRAM
https://www.fortinet.com/training-certification

FORTINET TRAINING INSTITUTE
https://training.fortinet.com

FORTIGUARD CENTER
https://www.fortiguard.com

END USER LICENSE AGREEMENT
https://www.fortinet.com/doc/legal/EULA.pdf

FEEDBACK
Email: techdoc@fortinet.com

June 1, 2023
FortiAnalyzer 6.4.0 New Features Guide
05-640-617437-20230601

https://docs.fortinet.com/
https://video.fortinet.com/
https://blog.fortinet.com/
https://support.fortinet.com/
https://www.fortinet.com/training-certification
https://training.fortinet.com/
https://www.fortiguard.com/
https://www.fortinet.com/doc/legal/EULA.pdf
mailto:techdoc@fortinet.com


TABLE OF CONTENTS

Change Log 5
Security-driven Networking 6
SD-WAN 6

FortiAnalyzer SD-WANMonitoring Dashboard 6
Enhanced SD-WAN Report 12
Secure SD-WAN assessment report 6.4.2 14

Dynamic Cloud Security 17
Public cloud 17

FortiCare license for AWS PAYG instances 17
Support for cloud-init service for KVM, Azure, and AWS 6.4.1 18

Application security 24
FortiWeb Pcap Support 24

Zero Trust Network Access 27
NAC 27

FortiNAC Report 27
IAM 28

SAML Fabric SSO 28
AI-driven Security Operations 33
SOC automation 34

Attach reports to incidents 34
Automation Playbooks 38
Add comments to incidents 45
Expanded incident analysis page 47
FortiSOC dashboards 51
FortiOS Connector 52
EMS Connector 56
Normalized Fabric logs 62
Incidents with multiple endpoints and users 6.4.2 66
Default playbook template improvements 6.4.1 67
Incident page improvement 6.4.1 70
Filters for local report action 6.4.2 76
SOC subscription license 6.4.1 77
Try it Out feature for FortiSoC 6.4.2 79
Vulnerabilities and software inventory data from EMS connector 6.4.2 81
FortiMail connector 6.4.2 85
Alerts on normalized logs 6.4.3 88
Normalized logs for reports 6.4.3 91
FortiGuard connector 6.4.3 93
Connector's health check 6.4.3 96
FortiGuard outbreak and alert service 6.4.6 97

Advanced threat protection 101
IoC re-scan events 101
FortiDeceptor logging 105
Unique count for event handler 6.4.2 107

FortiAnalyzer 6.4.0 New Features Guide 3
Fortinet Inc.



FortiGate C&C Detection in SOC View 6.4.3 108
FortiADC logging 6.4.3 111

Dashboard/widgets/reports 113
FortiView custom widgets 6.4.1 114
Extra caching for SOC reports 6.4.1 117
Asset tags 118
Sankey Chart 120
FortiPortal user summary report 6.4.2 121
FortiSandbox default report improvement 6.4.2 123
Improved SOC incident report 6.4.2 124
Add stackbar chart in FortiView 6.4.2 126
Interface bandwidth widgets 6.4.2 128
EMS classification tag 6.4.3 130
Throughput utilization billing reporting 6.4.3 133
Subnet list for reports 6.4.3 135
Asset & Identity View Improvement 6.4.3 138

Cyber-Physical Security 143
Facial Recognition 6.4.1 143
Zoom function in FortiRecorder 6.4.1 149

Fabric Management Platform 152
Single pane 152

Prompt admin to register FortiAnalyzer with FortiCloud 152
Online update and verification for third-party certificates (OCSP stapling) 158
FortiManager support for FortiAnalyzer HA 158
FortiAnalyzer firmware upgrade from FortiGuard servers 160
FortiAnalyzer GUI accessibility improvements 6.4.4 161

Other 165
FortiAnalyzer Application logs 165

FortiAnalyzer 6.4.0 New Features Guide 4
Fortinet Inc.



Change Log

Date Change Description

2023-06-01 Updated Throughput utilization billing reporting 6.4.3 on page 133.

2022-07-05 Added Support for cloud-init service for KVM, Azure, and AWS 6.4.1 on page 18.

2022-01-17 Added FortiGuard outbreak and alert service 6.4.6 on page 97.

2021-06-01 Initial release of FortiAnalyzer 6.4.6.

2021-05-19 Updated information in Online update and verification for third-party certificates (OCSP stapling)
on page 158.

2021-01-28 Updated information in Throughput utilization billing reporting 6.4.3 on page 133.

2020-12-16 Initial release of FortiAnalyzer 6.4.4.

2020-11-27 Added Connector's health check 6.4.3 on page 96.

2020-10-22 Initial release of FortiAnalyzer 6.4.3.

2020-09-24 Added FortiMail connector 6.4.2 on page 85.

2020-09-14 Added Asset tags on page 118.

2020-08-31 Added Secure SD-WAN assessment report 6.4.2 on page 14.

2020-08-20 Added:
l Incidents with multiple endpoints and users 6.4.2 on page 66
l Vulnerabilities and software inventory data from EMS connector 6.4.2 on page 81

2020-08-13 Added:
l SOC subscription license 6.4.1 on page 77
l Try it Out feature for FortiSoC 6.4.2 on page 79

2020-08-10 Added Unique count for event handler 6.4.2 on page 107.

2020-08-06 Initial release of FortiAnalyzer 6.4.2.

2020-07-20 Added Zoom function in FortiRecorder 6.4.1 on page 149 .

2020-06-26 Added Facial Recognition 6.4.1 on page 143.

2020-06-23 Added Sankey Chart on page 120.

2020-06-15 Initial release of FortiAnalyzer 6.4.1.

2020-05-04 Added Normalized Fabric logs on page 62.

2020-05-01 Added EMS Connector on page 56
Added FortiCare license for AWS PAYG instances on page 17

2020-04-17 Added FortiDeceptor logging on page 105.

2020-04-09 Initial release of FortiAnalyzer 6.4.0.
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Security-driven Networking

Security-driven Networking

This section lists the new features added to FortiAnalyzer for Security-driven Networking. They are organized into the
following sections:

l SD-WAN on page 6
l FortiAnalyzer SD-WANMonitoring Dashboard on page 6
l Enhanced SD-WAN Report on page 12
l Secure SD-WAN assessment report 6.4.2 on page 14

SD-WAN

This section lists the new features added to FortiAnalyzer for SD-WAN.

List of new features:

l FortiAnalyzer SD-WANMonitoring Dashboard on page 6
l Enhanced SD-WAN Report on page 12
l Secure SD-WAN assessment report 6.4.2 on page 14

FortiAnalyzer SD-WAN Monitoring Dashboard

Charts similar to those available in the Secure SD-WAN Report can be found as widgets in the default SD-WAN
dashboard of FortiView.

TheMonitors window in FortiView has a predefined Secure SD-WANMonitor pane with eight SD-WAN widgets.

A ninth widget, SD-WAN Rules Utilization, can be added to the dashboard.

To view the SD-WAN widgets:

1. Go to FortiView >Monitors.
2. In the tree menu, select Secure SD-WANMonitor.

The Secure SD-WANMonitor pane displays the SD-WAN widgets.

Default SD-WAN Widgets:

1. SD-WAN Performance Status: It gives the status of individual links and the SD-WAN enhancements after the SD-
WAN implementation.
Hover over a bar to see its link status, date, and time in the tooltip.
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2. Jitter: The Jitter widget shows a line chart of the jitter data for each SD-WAN link across the selected time period.
Hover over the line chart to see date, time, and jitter data in the tooltip.

3. Latency: The Latency widget shows a line chart of the latency data for each SD-WAN link across the selected time
period.
Hover over the line chart to see date, time, and latency data in the tooltip.
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4. Packet Loss:The Packet Loss widget shows a line chart of the packet loss data for each SD-WAN link across the
selected time period.
Hover over the line chart to see date, time, and packet loss data in the tooltip.

5. SD-WAN Utilization by Application:It shows a bar chart of the top 10, 20, or 30 applications on each SD-WAN link
across the selected time period.
Hover over the bar chart to see application name and the utilization on each link in the tooltip.
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6. Bandwidth Utilization by SD-WAN Rules:It shows a donut chart of SD-WAN rules utilization across the selected
time period.
Hover over the donut chart to see the rule name and utilization (percentage) in the tooltip.

You can see the total utilization for all rules at the center of the donut chart.

7. SD-WAN Link Utilization: It shows a donut chart of utilization for each SD-WAN link across the selected time period.
Hover over the donut chart to see link name and utilization (percentage) in the tooltip.
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You can see the total utilization for all links at the center of the donut chart.

8. SD-WAN High and Critical Events: It shows a donut chart of events across the selected time period.
Hover over the donut chart to see the event name and number (percentage) in the tooltip.

You can see the total number of events at the center of the donut chart.
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To add the SD-WAN Rules Utilization widget:

1. Go to FortiView > Monitors > Secure SD-WAN Monitor, and click Edit Dashboard.
2. Click the plus icon and select the SD-WAN Rules Utilization widget to add it to the dashboard, then click Done.

The SD-WAN Rules Utilization widget includes two sankey diagrams. Toggle between the displayed diagrams by
selecting a display type in the By: dropdown.
l SD-WAN Rules Utilization by Application: SD-WAN rules are displayed connected to SD-WAN member
interfaces and applications.

l SD-WAN Rules Utilization by Interface: SD-WAN rules are displayed connected to SD-WAN member
interfaces.
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Enhanced SD-WAN Report

This report leverages enhanced FortiGate SD-Wan logs to display SD-Wan utilization by different rules, links,
applications a users as well as link SLA, performance and quality KPIs such as Latency, Packet Loss and Jitter changes
over time.

The enhanced report includes the following:

l Improved report cover page.

l Added Sankey chart type for better visualization.
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l Added horizontal bar chart: SD-WAN Availability.

l Added Sankey chart for device drilldown.
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l Added horizontal bar chart: SD-WAN Users.

To view the full sample report, go to Reports > Templates and select HTML or PDF for Template - Secure SD-
WAN Report.

Secure SD-WAN assessment report - 6.4.2

This new report on FortiAnalyzer will be consistent with CTAP Secure SD-WAN report that we already provide to
prospective customers via the CTAP program.

To view the Secure SD-WAN assessment report:

1. In FortiAnalyzer, go to Reports > Templates and view Template - Secure SD-WAN Assessment Report.

The report is also available in All Reports.
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Below is a sample of the Secure SD-WAN assessment report.
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Dynamic Cloud Security

This section lists the new features added to FortiAnalyzer for Dynamic Cloud Security. They are organized into the
following sections

l Public cloud on page 17
l FortiCare license for AWS PAYG instances on page 17

l Application security on page 24
l FortiWeb Pcap Support on page 24

Public cloud

This section lists the new features added to FortiAnalyzer for public cloud.

List of new features:

l FortiCare license for AWS PAYG instances on page 17
l Support for cloud-init service for KVM, Azure, and AWS 6.4.1 on page 18

FortiCare license for AWS PAYG instances

FortiAnalyzer instances on AWS (PAYG) obtain FortiCare-generated licenses automatically.

When logging into a FortiAnalyzerAWS On Demand instance for the first time, a pre-login disclaimer page is displayed.

After successful login, the FAZ-AWS instance retrieves the license from the FortiCare server. This license includes a
certificate that uses the serial number as the CN name.

The following is a comparison between the local certificate in a FortiAnalyzer 6.2.3 and 6.4.0 AWS On Demand instance.
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l FortiAnalyzer-AWS On Demand 6.2.3

l FortiAnalyzer-AWS On Demand 6.4.0

Support for cloud-init service for KVM, Azure, and AWS - 6.4.1

You can use the cloud-init service for customizing a prepared image of a virtual installation. The cloud-init service is built
into the virtual instances of FortiAnalyzer-VM found on the support site so that you can use them on a VM platform that
supports the use of the service. To customize the installation of a new FortiAnalyzer-VM instance, you must combine the
seed image from the support site with user data information customized for each new installation.

Hypervisor platforms such as QEMU/KVM support the use of this service on most major Linux distributions, as well as
BSD and Hyper-V. A number of cloud-based environments, such as VMware and AWS also support it.

You can use the cloud-init service to help install different instances based on a common seed image by assigning
hostnames, adding SSH keys, and settings particular to the specific installation. You can add other more general
customizations, such as the running of post install scripts.
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While cloud-init is the service used to accomplish the customized installations of VMs, various other programs,
depending on the platform, are used to create the customized ISOs used to create the images that will build the
FortiAnalyzer-VM.

Although this feature supports FortiAnalyzer, this topic only includes examples for
FortiManager.

This topic includes the following sections:

l KVM on page 19
l AWS on page 21
l Microsoft Azure on page 22

KVM

To configure on KVM:

1. On the host server (Ubuntu), start service libvirtd.
2. Prepare the FortiAnalyzer configuration and license file.

This license is named 0000, without any extension.
The folder structure should be as follows:

<holding folder>
/openstack
/content
0000
/latest
user_data

For example:

config system global
set hostname fmg-boot-strap

end

3. Convert the folder to an ISO image using the mkisofs utility.
Following is the syntax of the command:

mkisofs [options] [-o <filename of new ISO> pathspec [pathspec...]

4. Create a FortiAnalyzer instance, attach a virtual CDROM, which is based on fmg-config-lic-bootstap.iso.
The following command sets up a virtual CDROM drive as if it were on an IDE bus holding a virtual CD in it with no
cache, and the data is in RAW format.

disk /home/username/test/fmg-config-lic-
bootstap.iso,device=cdrom,bus=ide,format=raw,cache=none -
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5. Boot up the FortiAnalyzer KVM virtual machine.
In the following example for FortiManager, the configuration and license upload to the FortiManager KVM virtual
machine.

bash# cat vmd.log.1
[186] cdrom mounted
[186] /cdrom/openstack/content/0000: size=9171:
-----BEGIN FMG VM LICENSE-----
QAAAAKgh6/7exA+Da/9ho2iypJYLjYKx+vFPBYd6cR6XlTq1WFz95Fz+b1n1sa2OPLldeC5h5sgh
CZMEcGUczbnSZMcQGgAAMC/mTe8EPRK/ARkMpi8Av3IIIcm7Irgds8xk+cgeMpZTMBtq2FrXsAmr
yErFgUgYmouRu9VMtJnJln4nnFRXZzsBez/Xa7XeBBUeHuLuxAiHyI2rIUfXQOPeIgV06eLrFLdu

FortiAnalyzer 6.4.0 New Features Guide 20
Fortinet Inc.



Dynamic Cloud Security

UpD1EqadFK3eDDoMX4wEFzLHJbbBrjErWKvu2Cf94sEDsaVQmI/Cv5nOZd9rQgR2TdxQ06YO25dr
cRuhoxA/nY4fvqwOcHbhUYpafF2NDeKiXzDVS1iRun5ZYFcCuIOTkGr2AQb5zx6MdlQgc+k8boI0

........................

JAyU8CgENbH++ClFTDAG6lznT68KcZDF7lcoAr56+p7OjXBEZrwUFVVIv4CWCtfntG1v7uE9Po0P
9PZyNgupzf7lstWtYDfrgSZO
-----END FMG VM LICENSE-----

[186] /cdrom/openstack/latest/user_data: size=438:
config system global

set hostname fmg-boot-strap
end

AWS

To configure on AWS:

1. Go to the AWS marketplace, and follow the procedure to launch a FortiAnalyzer AZURE virtual machine.
2. On the 3. Configure Instance page, select the VPC subnet and the IAM role.

When selecting the VPC subnet, select the IAM role that was created, and specify information about the license file
and configuration file from the AWS S3 bucket that was previously configured under Advanced Settings. In this
example, the IAM role name is fmgrole.

FortiAnalyzer 6.4.0 New Features Guide 21
Fortinet Inc.



Dynamic Cloud Security

3. Expand Advanced Details, and set User data to As text, for example:

4. Go to the FortiAnalyzer GUI, and log in.
5. In FortiAnalyzer, go to System Settings > Dashboard.

In the following example for FortiManager, the System Information widget displays the specified hostname, and the
License Information widget displays the activated license.

Microsoft Azure

To configure on Microsoft Azure:

1. Use PowerShell to deploy the FortiAnalyzer Azure VM with user data.
2. Create a MIME text file named azureinit.conf in local PC C:\Azure\misc directory.

You can change the directory path and file name using the $customdataFile =
C:\Azure\misc\azureinit.conf parameter in the ps1 file. The azureinit.conf is the text file in
MIME format that includes both FortiGate CLI commands and license file content.
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Content-Type: multipart/mixed; boundary="===============0740947994048919689=="
MIME-Version: 1.0

--===============0740947994048919689==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="config"

config system admin setting
set idle_timeout 480
set shell-access enable

end

--===============0740947994048919689==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="license"

-----BEGIN FMG VM LICENSE-----
QAAAAD1P27eiQC4JGGA1wDYnqMasNcDlXUtjg02/nt21seyucBTncObcRqPsXXFcRqkpoINA83PC
........
IOb6sMYu8MnmDPAJLgygex1BdImccRJ3pe+E9ZgT5tAu7gBVhDa5Bo/kf3IdJOoRdxvFXcUGC0+k
4TgteYmIRK7E5C0ZGV0AGqn2zTmwaFxF9J22R68tkI3fGbhGbAfjcPN5IAdC7TwHWyJWEoOqy8o/
TJ9wReuzEIWC3SrWtgpgfMNM527h4RQrLXBJP0VOm+C4ZHkedrbBy7qFQWhHC+Lps8rsPh/Qj1PN
Ii6kVnHrAgf9dI7C4IAmEKlQ
-----END FMG VM LICENSE-----

--===============0740947994048919689==--

After FortiAnalyzer Azure VM is created, the FortiAnalyzer license and configuration are uploaded.
3. Go to FortiAnalyzer GUI, and log in.
4. Go to System Settings > Dashboard. In the following example, the System Information widget displays the serial

number.
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5. Go to System Settings > Admin > Admin Settings.
The following example displays the Administration Settings:

Application security

This section lists the new features added to FortiAnalyzer for application security.

List of new features:

l FortiWeb Pcap Support on page 24

FortiWeb Pcap Support

The FortiWeb attack log provides a deep analysis tool that allows customers to understand why a particular request was
flagged as a violation. It gives detailed information in a 'Wireshark' like visual separating the HTTP requests into
headers, cookies, parameters, and the HTTP body, highlighting the pattern that triggered the violation.

This enhancement in FortiAnalyzer allow users to view FortiWeb packet logs with additional HTTP request information
included.

To view FortiWeb packet logs:

1. Go to Log View.
2. In the tree menu, select Application Attack Prevention.

The Application Attack Prevention pane opens.
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In the Application Attack Prevention pane, FortiWeb packets appear in the far right-side under Data.

By default, Data is not visible in the log view. You can enable it from the settings on the far-
right side.

FortiWeb packets also appear in the log detail panel.

3. Click on the packet icon to view the packet details.
The View Attack Content dialog appears. It shows packet details using the same design as IPS Archive.
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Zero Trust Network Access

This section lists the new features added to FortiAnalyzer for Zero Trust Network Access.

List of new features:

l NAC on page 27
l FortiNAC Report on page 27

l IAM on page 28
l SAML Fabric SSO on page 28

NAC

This section lists the new features added to FortiAnalyzer for NAC.

List of new features:

l FortiNAC Report on page 27

FortiNAC Report

A default FortiAnalyzer report template has been added for endpoints and networks detected by FortiNAC.

To view the FortiNAC report template:

1. Go to Reports > Templates.
The Template - FortiNAC Endpoints and Network Report is available.
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2. View a sample report by clicking HTML or PDF.

3. In the layout editor, you can customize the report.

IAM

This section lists the new features added to FortiAnalyzer for IAM.

List of new features:

l SAML Fabric SSO on page 28

SAML Fabric SSO

FortiAnalyzer supports SAML SSO as part of one or more Security Fabrics.

To enable SAML Fabric SSO on FortiAnalyzer:

1. On the root FortiGate of the Security Fabric, enable SAML Single Sign-On, and configure FortiAnalyzer logging by
inputting the IP address of FortiAnalyzer.
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2. On FortiAnalyzer, authorize FortiGate to an ADOM (or the root ADOM).

3. On FortiAnalyzer, go to System Setting >SAML SSO >Fabric SP. Input the FortiAnalyzer SP IP address, choose an
existing admin profile as default profile for SSO admin users, and click Apply.
After a short wait (approximately 5 minutes), check the Fabric IdPs table on the Fabric SP page. Information about
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Fabric IdPs is displayed.

4. Log in using Fabric SSO from the FortiAnalyzer login page.
When logging in with Fabric SSO, each Fabric IdP registered on FortiAnalyzer is displayed. Choose an IdP to log in
to using the SSO admin user account.
Each SAML Fabric SSO is bound to the ADOM to which it was authorized, and the SSO admin only has access this
specific ADOM on FortiAnalyzer.

From the top-right corner menu on FortiAnalyzer, a Fabric tree including all FortiGates in the Fabric is displayed.
Click a Fabric device to access that device through the SSO admin user.
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From the root FortiGate of the Security Fabric, administrators can view the Fabric tree in the top-left corner of the
screen. Click a Fabric device to access that device through the SSO admin user.

5. Additional Security Fabric IdPs can be registered by authorizing the root Fabric device onto a different
FortiAnalyzer ADOM and repeating the steps above.

To configure Fabric SAML SSO in the FortiAnalyzer CLI:

FAZVM64 # config sys saml

(saml)# show
config system saml

set status enable
set role FAB-SP
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set server-address "10.2.90.216"
set default-profile "SSO_RW"

config fabric-idp
edit "FGVM02TM20000893"

set idp-cert "csf-FGVM02TM20000893"
set idp-entity-id "http://10.2.90.212/saml-idp/csf_

j7mi9ojacy1g0wuzpe5pox8l7zgq3cs/metadata/"
set idp-single-logout-url "https://10.2.90.212/saml-idp/csf_

j7mi9ojacy1g0wuzpe5pox8l7zgq3cs/logout/"
set idp-single-sign-on-url "https://10.2.90.212/saml-idp/csf_

j7mi9ojacy1g0wuzpe5pox8l7zgq3cs/login/"
set idp-status enable

next
edit "FGVM02TM20000899"

set idp-cert "csf-FGVM02TM20000899"
set idp-entity-id "http://10.2.90.215/saml-idp/csf_

wl5j3jgxvq70wtvhn503vbu7fetths5/metadata/"
set idp-single-logout-url "https://10.2.90.215/saml-idp/csf_

wl5j3jgxvq70wtvhn503vbu7fetths5/logout/"
set idp-single-sign-on-url "https://10.2.90.215/saml-idp/csf_

wl5j3jgxvq70wtvhn503vbu7fetths5/login/"
set idp-status enable

next
end

end

FortiAnalyzer 6.4.0 New Features Guide 32
Fortinet Inc.



AI-driven Security Operations

AI-driven Security Operations

This section lists the new features added to FortiAnalyzer for AI-driven Security Operations.

List of new features:

l SOC automation on page 34
l Attach reports to incidents on page 34
l Automation Playbooks on page 38
l Add comments to incidents on page 45
l Expanded incident analysis page on page 47
l FortiSOC dashboards on page 51
l FortiOS Connector on page 52
l EMS Connector on page 56
l Normalized Fabric logs on page 62
l Incidents with multiple endpoints and users 6.4.2 on page 66
l Default playbook template improvements 6.4.1 on page 67
l Incident page improvement 6.4.1 on page 70
l Filters for local report action 6.4.2 on page 76
l SOC subscription license 6.4.1 on page 77
l Try it Out feature for FortiSoC 6.4.2 on page 79
l Vulnerabilities and software inventory data from EMS connector 6.4.2 on page 81
l FortiMail connector 6.4.2 on page 85
l Alerts on normalized logs 6.4.3 on page 88
l Normalized logs for reports 6.4.3 on page 91
l FortiGuard connector 6.4.3 on page 93
l Connector's health check 6.4.3 on page 96

l Advanced threat protection on page 101
l IoC re-scan events on page 101
l FortiDeceptor logging on page 105
l Unique count for event handler 6.4.2 on page 107
l FortiGate C&C Detection in SOC View 6.4.3 on page 108
l FortiADC logging 6.4.3 on page 111

l Dashboard/widgets/reports on page 113
l FortiView custom widgets 6.4.1 on page 114
l Extra caching for SOC reports 6.4.1 on page 117
l Asset tags on page 118
l Sankey Chart on page 120
l FortiPortal user summary report 6.4.2 on page 121
l FortiSandbox default report improvement 6.4.2 on page 123
l Improved SOC incident report 6.4.2 on page 124
l Add stackbar chart in FortiView 6.4.2 on page 126
l Interface bandwidth widgets 6.4.2 on page 128
l EMS classification tag 6.4.3 on page 130
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l Throughput utilization billing reporting 6.4.3 on page 133
l Subnet list for reports 6.4.3 on page 135

l Cyber-Physical Security on page 143
l Facial Recognition 6.4.1 on page 143
l Zoom function in FortiRecorder 6.4.1 on page 149

SOC automation

This section lists the new features added to FortiAnalyzer for SOC automation.

List of new features:

l Attach reports to incidents on page 34
l Automation Playbooks on page 38
l Add comments to incidents on page 45
l Expanded incident analysis page on page 47
l FortiSOC dashboards on page 51
l FortiOS Connector on page 52
l EMS Connector on page 56
l Normalized Fabric logs on page 62
l Incidents with multiple endpoints and users 6.4.2 on page 66
l Default playbook template improvements 6.4.1 on page 67
l Incident page improvement 6.4.1 on page 70
l Filters for local report action 6.4.2 on page 76
l SOC subscription license 6.4.1 on page 77
l Try it Out feature for FortiSoC 6.4.2 on page 79
l Vulnerabilities and software inventory data from EMS connector 6.4.2 on page 81
l FortiMail connector 6.4.2 on page 85
l Alerts on normalized logs 6.4.3 on page 88
l Normalized logs for reports 6.4.3 on page 91
l FortiGuard connector 6.4.3 on page 93
l Connector's health check 6.4.3 on page 96
l FortiGuard outbreak and alert service 6.4.6 on page 97

Attach reports to incidents

You can attach reports to incidents to add historical data in addition to real-time events through one of the following
methods:

l Manually added by an admin after incident creation.
l Automatically added by SOC automation playbooks. SOC automation is a licensed feature.

Two views are available in the Incident Analysis page:

l Closed view showing attached reports.
l Open view showing the content of the report.
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To attach reports from Generated Reports:

1. Go to Reports > Generated Reports.
Select the report(s) to be attached, right-click on a selected report, and click Attach to Incident.

The Select an Incident window appears.

2. Select an incident and click Add to this incident.

To attach reports from the Incident Analysis page:

1. Go to Incidents & Events/FortiSoC > Incidents and double-click on an incident to view the Incident Analysis page.
2. On the bottom of the page, click the Report tab.
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3. Click Add.
The Attach Report window appears with a list of generated reports available for selection.

4. Select one or more reports and clickOK.
The reports are added to incident as an attachment.

To view reports in the Incident Analysis page:

1. In the Incident Analysis page, click the Reports tab.
The list of attached reports is shown and displays basic report information.
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2. Click a format type in the Format column to launch a new tab showing the report's content.

To delete reports from the Incident Analysis page:

1. In the Incident Analysis page, click the Reports tab.
2. Select the report(s) to be deleted, and click Delete.

A confirmation dialog appears.

3. Click OK.
The selected reports are deleted from incident.
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Automation Playbooks

A sequence of one or more actions offered by SOC connectors can be defined in playbooks and executed manually or
automatically.

Playbooks consist of a trigger and multiple actions from configured connectors.

l Playbook triggers include:
l Incident
l Event
l On Schedule
l On Demand

l Playbook actions:
l This is the automated action taken by the playbook at any step.
l Actions can be configured with default input values or take inputs from the trigger or preceding actions.
l Actions be selected from the local FortiAnalyzer or a configured connector's list of actions.

Connectors

To view FortiSoC connectors:

1. View the connector list from FortiSoC > Automation > Connectors.

2. Click on a connector to view its details.
The actions available with each connector are displayed, including the action name, and the action's parameters
used in the playbook.
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l EMS connectors:

l FOS connectors:
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l Local connectors:

Playbooks

To create a playbook:

1. Click Create New from the Playbook list, and select a template.
You can also select New Playbook created from scratch to start with a blank playbook.
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2. Provide a name and description for the playbook, and set it to Enabled if you want to use it immediately after saving
the playbook.

3. If a predefined template is selected, check each trigger and task configuration, and update them as need by clicking
the edit icon.
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4. If a playbook is created from scratch, select trigger and trigger filter conditions.

5. Add a task by clicking the connector point of a parent task or trigger and dragging-and-dropping a new task onto the
playbook.
a. Select the Connector type.
b. Enter a name, description, and the ID for the task.
c. Select a connector and action, and enter the action's required parameters. The parameter may come from any

parent task/trigger output or be a fixed value.
d. ClickOK to save your changes.
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6. Save the playbook once finished and the playbook will appear in the playbook list.

To run an on-demand playbook:

1. Go to FortiSoC > Automation > Playbooks.
2. Select a playbook configured with an On_Demand trigger.
3. Click Run in the toolbar or through the context menu of the selected playbook.

FortiAnalyzer 6.4.0 New Features Guide 43
Fortinet Inc.



AI-driven Security Operations

4. Input the desired parameters if prompted.

Playbooks with an Incident, Event, orOn_Schedule trigger run automatically once the trigger's filter is matched.

Playbook Monitor

To view the Playbook Monitor:

1. Go to FortiSoC > Automation > Playbook Monitor.
All playbook jobs that are running or have been run are displayed.
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2. Double-click a job or click the details icon in the status column to view the playbook status details.

Add comments to incidents

This feature introduces Comments to the Incident Analysis pane. It allows comments by admins with their names and
timestamps displayed.

To post a comment:

1. Go to FortiSoC.
2. In the tree menu, select Incidents.

The Incidents pane opens.
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3. In the Incidents pane, enter your comment in the comment box under Incident Timeline and select Post.
Comments show up next to admins who posted them, with the latest at the top.

4. Click on the edit icon next to your comment to modify it when needed.

To delete a comment:

1. Click on delete next to your comment to delete the comment.
The Confirmation Deletion dialog opens.

From the Confirmation Deletion dialog box, clickOK to delete your comment.
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Changes in comments are logged in the Audit History on right, with the latest at the top.

Expanded incident analysis page

The incident analysis page has been expanded and redesigned to integrate with SOC playbooks and accommodate
more evidence and notes for SOC analysis.

The expanded incident analysis page includes the following new and enhanced features:

l The incident headline bar provides basic information about the incident.
l Basic information includes severity, incident number, incident description, category, assigned to, and incident
create/modify time.

l Click Edit to edit the incident information.
l Click Refresh to update all incident information, including executed playbooks, audit history, and retrieved
endpoint information. All incident analysis page content is updated.
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l The incident analysis page provides more information about affected endpoints.

l The incident analysis page provides automation (playbook) execution from within incidents.
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l Incident timelines show the timeline of events added to the incident.

l Multiple incident attachments are supported and can be viewed from the attachment area.
l Comments
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l Events

l Reports

l Incident audit history shows the history of changes to the incident. Click the toggle icon in the top-right corner to
hide/display the audit history panel.
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FortiSOC dashboards

FortiSOC dashboards display events, incidents, and SOC playbook trends and breakdowns.

FortiSOC dashboards include the following:

l Playbook dashboard displays:
l Total playbooks/actions (task) executed.
l Total playbook executed by playbook.
l Total playbooks/actions (task) executed by day trend.

l Incident dashboard displays:
l Total incidents by status.
l Total unresolved (not closed) incidents by severity.
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l Total incidents breakdown by category trend by day.

l Events dashboard displays:
l Total events byGenerated/Mitigated/Unhandled.
l Total events by severity.
l Total events breakdown by type.
l Total events breakdown by event handler

FortiOS Connector

The FortiOS connector on FortiAnalyzer now allows SOC playbooks to use FortiOS automation rules as actions.
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To create a FortiSoC connector:

1. Go to FortiSoC > Automation > Connectors.
The Connectors pane opens.

There are no FortiOS connectors available at this time. FortiOS connector is created once FortiAnalyzer has the first
FortiGate prompted.

2. Go to Security Fabric > Automation to create an incoming webhook stitch on FortiGate.
The Automation pane is displayed.
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3. In the Automation pane, select Edit to edit automation stitch.

ClickOK.
4. Now, go to FortiSoC > Automation > Connectors.

You will see that the connector shows up in FortiOS Connector.
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To deploy FortiOS connector action:

1. Go to FortiSoC > Automation > Playbooks.
2. Customize the playbook task to use FortiOS connector action.

Click Save Playbook.

To run a playbook:

1. Go to FortiSoC > Automation > Playbooks.
2. Select a playbook and click Run from the toolbar or right click on the playbook and select Run to automatically direct

request to the FortiGate with the specified device.

CSF device request is handled by the CSF root and dispatched to the specified device.
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EMS Connector

EMS connector on FortiAnalyzer allows automation playbooks to reach out to endpoints and collect information or take
containment actions.

To configure an EMS connector for use in FortiSoC playbooks:

1. Configure a FortiClient EMS 6.4.0 server which supports the FortiAnalyzer EMS connector feature.
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2. Register FortiClient to the EMS server. In the example below, two FortiClients have been registered.

3. In FortiClient EMS System Settings, configure FortiClient EMS to send logs to FortiAnalyzer.

4. In FortiAnalyzer, register the EMS device to a Fabric ADOM.
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5. In the Fabric ADOM, go to Fabric View > Fabric Connectors. Click Create New, and select FortiClient EMS.

Configure the EMS connector, and clickOK.

6. Go to FortiSoC > Automation > Connectors. Here you can view the actions FortiAnalyzer can take on endpoints
using the EMS connector.
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Playbook EMS connector examples

Below are two examples of how the FortiClient EMS connector enables actions in FortiSoC playbooks:
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To create a playbook from a template:

1. Go to FortiSoC > Automation > Playbook, and click Create New.

2. From the list of templates, select Playbook EMS Run_Vulnerability_Scan.
This template will run a vulnerability scan on an endpoint. Save the playbook.
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3. From the Playbook menu, run the playbook.

A prompt appears to select the endpoint on which to perform the vulnerability scan.
4. Go to FortiSoC > Automation > Playbook Monitor to view the running status of the playbook job.

To create a playbook from scratch

1. Go to FortiSoC > Automation > Playbook, and click Create New.
From the list of templates, select New Playbook created from scratch.

2. Configure the playbook:
a. Select theOn Demand trigger.
b. Add a task with the EMS connectorGet Endpoints action.
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c. Add a task with the Local connector Update Asset and Identity action.

3. Click Save Playbook.
4. Run the playbook, and go to Fabric View > Assets to view the collected endpoint information.

Normalized Fabric logs

All logs from different Fabric devices are normalized and available for search in Log View under the Fabric section.

l In FortiAnalyzer 6.4.0, SIEM features are available with all VMmodels and most hardware models (FortiAnalyzer
400E and above).

l When one or more devices are added or promoted to a Fabric ADOM and logs are being sent to FortiAnalyzer, a
SIEM database (siemdb) is automatically created for the ADOM. All logs are inserted into the siemdb and displayed
in Log View > Fabric > All.

l SIEM databases are created based on ADOMs. If there are multiple Fabric ADOMs with logs, the same number of
SIEM databases are automatically created.
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To create a Fabric ADOM and view normalized Fabric logs:

1. Go to System Settings > All ADOMs and create a Fabric ADOM. For example, Fabric_ADOM1.

2. Configure a FortiGate to send logs to FortiAnalyzer, and promote the FortiGate device to the Fabric ADOM.

3. From the CLI, confirm the siemdb has been created properly for the Fabric_ADOM1 ADOM.
FAZVM64 # dziagnose test application siemdbd 6

ADOM Fabric_ADOM1[150] : part-days=1 rows=33 bytes=21.4KB time=[2020-04-27
15:40:17, 2020-04-27 15:40:17] duration=1s

*** Total tracked ADOMs: 1, Time to refresh: 27(sec)
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4. Go to Log View > Fabric > All. Normalized logs from FortiGate are automatically displayed in the siemdb format.

When other types of devices such as FortiMail and FortiWeb are added to the Fabric ADOM, their logs are also
displayed.

Click Column Settings to change the columns that are displayed.
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Double click on an individual log to view its details. Details are displayed according to groups.

SIEM log display can be filtered based on SIEM fields.
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Incidents with multiple endpoints and users - 6.4.2

This is an enhancement to the FortiSOCmodule supporting multiple endpoints and users for incidents.

To view incidents with multiple endpoints/users:

1. In the Event Monitor, you can raise or add events with multiple endpoints and users to an incident.

When endpoint/users are manually raised/added to an incident, only the first endpoint will
be displayed when the incident is raised and there is an approximate five second delay to
show multiple endpoint/user information on the incident analysis page. When a playbook
runs a task using the local connector to create an incident, there is an approximate 20
second delay to display all information.

2. On the incident analysis page, information about multiple endpoint/users is available in the Affected Assets tab.
You can also click the navigation arrows in the Affected Endpoint/User widget to show additional users and
endpoints.
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Click a user in the Affected Assets list to see additional endpoint information in a dialog window.

Default playbook template improvements - 6.4.1

The list of default Playbook templates has been updated.

FAZ
Localhost

Compromised Host Incident

Critical Intrusion Incident

Attach Endpoint Vulnerability list to Incident

FortiOS Quarantine Endpoint by FortiOS
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EMS Update Asset and Identity Database

Run AV Scan on Endpoint

Run Vulnerability Scan on Endpoint

Quarantine Endpoint by EMS

Unquarantine Endpoint by EMS

Enrich Incident with Process List

Enrich Incident with Vulnerability List

Enrich Incident with Software Inventory
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Example of the updated Compromised Host Incident template:

Example of the updated Enrich Incident with Vulnerability List template:
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Incident page improvement - 6.4.1

This is an enhancement to the incident analysis page that offers a more useful view for users by introducing Processes,
Software and Vulnerabilities tabs. These tabs include endpoint information that attaches to incidents.

To view the incident page improvements:

1. Go to FortiSOC > Incidents, and select an incident to view the Incident Analysis page.
l Incident attachment for endpoint processes:

l Click the table view icon in the top-right corner in the attachment section to view endpoint processes in a
table format.

l Click the raw data icon in the top-right corner in the attachment section to view endpoint process
information as raw data.
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l Select a time from the snapshots dropdown to view different snapshots.

l Enter search keywords in the search field to view filtered records which match the keyword. Matching
keywords are highlighted in the results.
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l Incident attachment for installed software.
l Click the table view in the top-right corner in the attachment section to view installed software in a table
format.

l Click the raw data icon in the top-right corner in the attachment section to view installed software
information as raw data.
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l Select a time from the snapshots dropdown to view different snapshots.

l Enter search keywords in the search field to view filtered records which match the keyword. Matching
keywords are highlighted in the results.
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l Incident attachment for endpoint vulnerabilities.
l Click the table view icon in the top-right corner in the attachment section to view endpoint vulnerabilities in
a table format.

l Click the raw data icon in the top-right corner in the attachment section to view endpoint process
information as raw data.
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l Select a time from the snapshots dropdown to view different snapshots.
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l Enter search keywords in the search field to view filtered records which match the keyword. Matching
keywords are highlighted in the results.

Filters for local report action - 6.4.2

This is an enhancement to the existing feature to address limitations on resources and timeline by offering filter, time
range and log field selection for the local report playbook action.

To view report options for local report actions in playbooks:

1. Reports with the Extended Log Filtering option enabled are supported in the local connector's Run Report action.
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2. Reports support custom time ranges, device filters, and log filters in the playbook task.
a. Time range - Select a time range from the dropdown list or enter a custom time range.
b. Filter - Select the filters to apply to the report.
c. Devices - Select the devices to be included in the report, or choose Playbook Starter to use a dynamic device

input from the trigger.

SOC subscription license - 6.4.1

FortiSOC features in FortiAnalyzer are enabled through a SOC subscription license. The SOC subscription license
includes features such as playbooks, connecting to third-party feeds, and incident investigation.
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To view the SOC subscription license in FortiAnalyzer:

1. The SOC subscription license can be viewed in System Settings > Dashboard in the License Information widget.
You can also check the license through the CLI using the diagnose license list command.

2. With a valid license, FortiSoC features are fully available.

3. When the license is expired or there is no valid license, FortiSoC includes a try-it-out mode with a maximum of five
playbooks run per day.

FortiAnalyzer 6.4.0 New Features Guide 78
Fortinet Inc.



AI-driven Security Operations

Try it Out feature for FortiSoC - 6.4.2

This new feature allows customers to access the FortiSoC module and try SOC automation features with some
restrictions. Without a SOC subscription license, SOC automation will run in limited capacity with restricted number of
playbooks to be executed per day.

To use the Try it Out feature for FortiSoC:

1. Navigate to the FortiSoC module in FortiAnalyzer.
When viewing FortiSoC without a SOC subscription license, a warning message and Purchase License option
appears at the bottom of the page.
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Without a license, up to five playbooks can be run per day. Additional playbooks will fail with a warning, and a local
application log will be generated.
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Vulnerabilities and software inventory data from EMS connector - 6.4.2

This new feature helps FortiAnalyzer to get more information, vulnerabilities and software inventory, from the FortiClient
EMS server directly.

To get endpoint data from an EMS connector:

1. In Fabric View > Fabric Connectors, click Create New and select FortiClient EMS.
Configure the connector details for FortiClient EMS and clickOK.

2. Go to FortiSoC > Automation > Playbook and create a new playbook.
Administrators can use wildcards to get all endpoints registered on the EMS server and then create another task to
update Fabric View > Assets.
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3. Run the playbook, then go to Fabric View > Assets. The retrieved endpoints in the EMS server are displayed.
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To get vulnerability information from an EMS connector:

1. With a configured FortiClient EMS connector, create a playbook with an action toGet Vulnerabilities.

2. Run the playbook. In this example, the user selects a specific endpoint to get its vulnerabilities.

Confirm that the
playbook has run successfully in FortiSoC > Automation > Playbook Monitor.

3. Go to Fabric View > Assets, and check the Vulnerabilities column. The number of Critical and High level
vulnerabilities are displayed. Click on a number to view additional details. You can further drill-down on an individual
vulnerability to see its details.
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To get software information from an EMS connector:

1. With a configured FortiClient EMS connector, create a playbook with an action toGet Software Inventory.

2. Run the playbook. In this example, the admin selects a specific endpoint to get its software inventory.

Confirm that the playbook has run successfully in FortiSoC > Automation > Playbook Monitor.
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3. Go to Fabric View > Assets, and check the Software column. Click on Details to display the software inventory
retrieved from FortiClient EMS.

FortiMail connector - 6.4.2

FortiMail connector on FortiAnalyzer allows playbooks to collect information from FortiMail and take containment action.

To configure a FortiMail connector:

1. Install a FortiMail device with the latest release.
2. In FortiMail, create a domain and some users.
3. In FortiAnalyzer, go to Fabric View > Fabric Connectors and create a FortiMail Connector.

4. Go to FortiSoC > Automation > Connectors to view the actions available with the FortiMail connector. This
connector supports three actions:
l Get Email Statistics
l Get Sender Reputation
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l Add Sender to Blocklist

The following examples demonstrate how to create a FortiSoC playbook using FortiMail connector actions.

To create a playbook using the Get Email Statistics action:

1. Go to FortiSoC > Automation > Playbook and create a new playbook from scratch.
2. Create a task with the action toGet Email Statistics using the FortiMail connector. This example gets email statistics

for user u2@test1.com.
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3. Create a second task with the action Attach Data to Incident using the local connector, and enter an incident
number.

4. Save and run the playbook, and check the Playbook Monitor to confirm the playbook was run successfully.
5. Go to FortiSoC > Incidents and open the incident. The recently run playbook is displayed in Executed Playbooks.

To create a playbook using the Add Sender to Blocklist action:

1. Go to FortiSoC > Automation > Playbook, and create a new playbook from scratch.
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2. Create a task with the action Add Sender to Blocklist using the FortiMail connector. This example adds user
user4@test1.com to the blocklist.

3. Save and run the playbook, and check the Playbook Monitor to confirm the playbook was run successfully.
4. In FortiMail, go to Security > Block/Safe List > System > Block List. user4@test1.com has been added to the

block list.

Alerts on normalized logs - 6.4.3

Event handler support for SIEM normalized logs.
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To create an event handler for SIEM normalized logs:

1. On FortiAnalyzer, go to FortiSoC > Handlers > Event Handler List, and create a new event handler.
2. Select SIEM in the Log Device Type, and complete the other settings like a normal FortiGate log based handler

definition.

Device and subnet filters are also supported for SIEM log handlers.
ClickOK to save the event handler.
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3. Go to FortiSoC > Event Monitor > All Events to check the event list for events generated by SIEM logs.

Double-click a log to see related logs, or right click the log and select View Log from the context menu.

In the context menu, select Search in Log View to see all logs associated with the event.

FortiAnalyzer 6.4.0 New Features Guide 90
Fortinet Inc.



AI-driven Security Operations

Normalized logs for reports - 6.4.3

Normalized logs are supported in the report module.

To create reports using normalized logs:

1. Go to Reports > Report Definitions > Datasets, and edit a dataset.
The Normalized log type is available under the SIEM category in the Log Type dropdown.

2. Click Test to test the dataset and view the results. ClickOK to save the dataset.

Charts including normalized log data can be created using the newly created dataset.
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Once created, the chart can be inserted into report layouts.

After the report has been run, you can view normalized log data in the report output.
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FortiGuard connector - 6.4.3

The FortiGuard connector on FortiAnalyzer allows SOC playbooks to look up indicators and get threat intelligence
information.

To use the FortiGuard connector:

1. Go to FortiSoC > Automation > Connectors to view the FortiGuard connector.
The FortiGuard connector is automatically installed with default actions. The FortiGuard connector is connected and
ready for use when the status icon is green.

2. Go to FortiSoc > Automation > Playbook, and create a new playbook.
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3. Create a task to perform a FortiGuard indicator lookup. Select the FortiGuard Connector type and the Lookup
Indicator action. You can choose the indicator type based on your requirements (e.g. IP/URL/Domain).

4. Create another task to attach data to an incident. Select the Local Connector type and Attach Data to Incident
action. Enter an Incident ID and then save the playbook.

FortiAnalyzer 6.4.0 New Features Guide 94
Fortinet Inc.



AI-driven Security Operations

5. Manually run the playbook. You will see a prompt to input the value of an indicator according to the configured
indicator type.

6. Go to FortiSoc > Automation > Playbook Monitor to confirm that the playbook has run successfully. Once complete,
go to FortiSoC > Incidents to view the incident you configured in the playbook. The FortiSoC indicators are attached
to the incident in the Indicators tab.
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Click Detail to drilldown for additional information about the indicator.

Connector's health check - 6.4.3

This enhanced feature provides visibility on the status of connectors.

To view the status of FortiSoC connectors:

1. Go to FortiSoC > Automation > Connectors.
You can see health status and refresh icons for each connector.

Click the refresh icon to refresh the status of a connector. Mouse over the health status icon to view detailed status
information, including when the connector status was last updated.
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When a connector is down, mouse over the health status icon to view additional information about why the
connector is unavailable.

FortiGuard outbreak and alert service - 6.4.6

The FortiGuard Outbreak Alert Service is available with a valid FOAS license to protect customers' networks against
malware outbreaks. The Outbreak Alert content package consists of a FortiGuard Report for the outbreak, an Event
Handler, and a Report Template to detect the outbreak.
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To view outbreak alerts, reports, and event handlers:

1. Go to FortiSoC > Outbreak Alerts. Available outbreak alerts are displayed and can be browsed in all ADOMs.

2. Go to FortiSoC > Handlers > Event Handler List. Corresponding outbreak alert event handlers are installed and
listed in related ADOMs automatically. The events can be triggered by logs which satisfy the event handlers' filter
conditions.

3. Go to Reports > Report Definitions > All Reports.
A newOutbreak Alert Reports folder is available in all ADOMs. All outbreak reports are stored in this folder.
Right click a report to run the report. Reports can be generated in HTML, PDF, XML, and CSV formats.
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Below is an example of the HafniumM.S.Exchange Attack Detection Report.
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4. When FortiAnalyzer does not have a valid FOAS license, a default Fortinet Outbreak Alert page is displayed with a
warning that the service is not available in this ADOM yet.

5. Go to FortiSoC > Handlers > Event Handler List.
Without a valid license, no outbreak related event handlers are available.
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6. Go to Reports > Report Definitions > All Reports.
Without a valid license, theOutbreak Alerts Reports folder is displayed, but no reports are assigned to it.

Advanced threat protection

This section lists the new features added to FortiAnalyzer for advanced threat protection.

List of new features:

l IoC re-scan events on page 101
l FortiDeceptor logging on page 105
l Unique count for event handler 6.4.2 on page 107
l FortiGate C&C Detection in SOC View 6.4.3 on page 108
l FortiADC logging 6.4.3 on page 111

IoC re-scan events

Event Handlers can generate events for compromised hosts detected by the IoC rescan feature.

Example of viewing IoC re-scanned events:

1. Go to FortiView > FortiView > Threats > Compromised Hosts, and click the settings icon to configure global and
ADOM rescan settings.
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2. In the rescan task list, select a task and click on a threat count (red circle) to view the rescan result.
Threat 1.169.112.88 was found on the endpoint 172.18.4.116 and VAN-200289-PC2.

3. Go to FortiView > FortiView > Threats > Compromised Hosts.
For the end user faz-test(10.2.60.145) on endpoint VAN-200289-PC2, a rescan icon is displayed in the Last
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Detected column to indicate that there were threats found during rescan.

4. Go to the drilldown view for the end user to view the detected threat patterns.
For end user faz-test(10.2.60.145) there are two threat patterns: 1.163.163.199 was found by real-time logs, and
1.169.112.88 was found during rescan.

5. Go to FortiSoC > Handlers > Event Handler List.
The ioc_rescan tag is added in all filters for the following default event handlers: Default-Compromised Host-
Detection-IOC-By-Endpoint and Default-Compromised Host-Detection-IOC-By-Threat.
For comparison, there is no ioc_rescan tag for any filters in the custom event handlers: Copy of Default-
Compromised Host-Detection-IOC-By-Endpoint and Copy of Default-Compromised Host-Detection-IOC-By-
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Threat.

6. Go to FortiSoC > Event Monitor > All Events and view alerts for the Default-Compromised Host-Detection-IOC-By-
Threat handler.
The ioc_rescan tag exists for threat 1.169.112.88 because they are generated by rescan logs. There is no ioc_
rescan tag for threat 1.163.163.199 because they are generated by real-time logs.

7. View alerts for the Copy of Default-Compromised Host-Detection-IOC-By-Threat handler.
There are no alerts for threat 1.169.112.88 because the handler does not process rescan logs. There are alerts

FortiAnalyzer 6.4.0 New Features Guide 104
Fortinet Inc.



AI-driven Security Operations

without the ioc_rescan tag for threat 1.163.163.199 because the handler still processes real-time logs.

FortiDeceptor logging

FortiDeceptor logs are supported on FortiAnalyzer.

To view FortiDeceptor logs on FortiAnalyzer:

1. On FortiDeceptor, go to Log > Log Servers, and click Create New to create a new remote log server.

2. Configure the following details:
l Enter a name for the remote log server. For example: To_Test_FAZ.
l Select FortiAnalyzer as the server Type.
l Keep the default settings for all other options.
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3. On FortiAnalyzer, go to Device Manager > Unauthorized.
FortiDeceptor appears in the unregistered devices table.

4. Authorize the FortiDeceptor device to an ADOM, for example the root which is a Fabric ADOM.

All logs sent by FortiDeceptor are stored in the root ADOM and displayed in Log View.

Below are sample raw logs from FortiDeceptor:

date=2020-03-12 time=16:54:01 id=6861604606372216836 itime=2020-08-16 08:30:17 euid=1
epid=1 dsteuid=1 dstepid=1 devhost=FDC-VM0000000552 tz=PDT logid=0106000001
type=event subtype=system level=information user=admin ui=GUI action=Logout
status=Success msg=Administrator admin logged out website successfully from
172.18.32.10 devid=FDC-VM0000000353 dtime=2020-03-12 16:54:01 itime_t=1597591817
devname=FDC-VM0000000353

date=2020-03-12 time=16:49:16 id=6861604602077249536 itime=2020-08-16 08:30:16 euid=1
epid=1 dsteuid=1 dstepid=1 devhost=FDC-VM0000000552 tz=PDT logid=0106000001
type=event subtype=system level=information user=admin ui=GUI action=Login
status=Success msg=Administrator admin logged into website successfully from
172.18.32.10 devid=FDC-VM0000000353 dtime=2020-03-12 16:49:16 itime_t=1597591816
devname=FDC-VM0000000353
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Unique count for event handler - 6.4.2

This is an enhancement to theGenerate Alert threshold section of the event handlers which provides additional criteria
(Distinct field value) for triggering events.

To configure unique count in an event handler:

1. When editing an event handler, there are two new options available in theGenerate Alert When section:
l Exact: The legacy function. An event is triggered when the set number of logs meet the general condition
defined in the event log filter.

l Distinct: An event is triggered when there are a set number of distinct values from the chosen log field, and the
conditions of the general event log filter are met.
In the example below, five distinct attacks within 30 minutes from the same endpoint will generate an event,
allowing for strict criteria for an IPS event definition.
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2. Generated events with associated first and last logs from before the trigger event is recorded are consolidated into
the same event to a maximum of 50 logs. For a full log list, use Search in Log View from the event context menu.

FortiGate C&C Detection in SOC View - 6.4.3

The IOC scan feature has been enhanced to allow FortiAnalyzer to include FortiGate C&C detection in Compromised
Hosts in the SOC View.
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To view C&C attack logs:

1. Go to FortiView > Compromised Hosts.
2. Under Verdict, click Infected.

The C&C events have a Detect Method of detected-by-fgt and Log Type of attack.
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3. Drilldown to view the log details. C&C logs will have an Attack Namematching *.Botnet.

To view C&C message logs:

1. Go to FortiView > Compromised Hosts.
2. Under Verdict, click Infected. The C&C events have a Detect Method of detected-by-fgt and Log Type of

attack.

\
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3. Drilldown to see the log details. The C&C logs appear underMessage as Botnet C&C.

FortiADC logging - 6.4.3

FortiADC logs are supported on FortiAnalyzer.

To enable FortiADC logging:

1. On FortiADC, go to Logs & Report > Log Setting and click the Syslog Server tab.

2. Click Create New to create a remote log server. In the Proto field select UDP. FortiADC currently only supports this
protocol. Click Save once complete.
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Once the remote log server is created and logs are generated on the FortiADC, the logs are sent to FortiAnalyzer.

3. On FortiAnalyzer, go to the Device Manager and click the Unauthorized view to see the FortiADC device.
Promote the FortiADC device to a Fabric ADOM, for example the root ADOM. FortiADC devices can only be added
to Fabric ADOMs.

After the FortiADC device is registered in the Device Manager, the FortiADC's logs can be stored and displayed in
Log View.
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Sample FortiADC Logs:

Traffic log:

id=6878052772042768384 itime=2020-09-29 16:17:34 euid=1 epid=1 dsteuid=1 dstepid=1
date=2020-08-19 time=17:13:37 type=traffic subtype=slb_layer4 log_id=0100008000
pri=information msg_id=8891139290341374 proto=6 src=20.20.0.1 src_port=55442
dst=20.20.0.100 dst_port=80 policy=VS1 action=none srccountry=United dstcountry=United
duration=3 ibytes=398 obytes=1075 service=tcp trans_src=20.20.0.1 trans_src_port=55442
trans_dst=20.20.2.3 trans_dst_port=80 real_server=pool1-3 device_id=FADV040000002384
vd=root dtime=2020-08-19 17:13:37 itime_t=1601421454 devname=FADV040000002384

Security Log:

id=6878052935251525632 itime=2020-09-29 16:18:12 euid=1 epid=1 dsteuid=1 dstepid=1
date=2020-08-19 time=15:04:13 type=attack subtype=ip_reputation log_id=0200006001
pri=warning msg_id=8891139290340651 count=1 severity=high proto=6 service=http
src=20.20.0.1 src_port=55194 dst=20.20.0.100 dst_port=80 policy=VS1 action=deny
srccountry=United dstcountry=United msg=IP Reputation Violation: Botnet was detected.
device_id=FADV040000002384 vd=root dtime=2020-08-19 15:04:13 itime_t=1601421492
devname=FADV040000002384

Event Log:

d=6878052845057212416 itime=2020-09-29 16:17:51 euid=1 epid=1 dsteuid=1 dstepid=1
date=2020-08-19 time=16:32:11 type=event subtype=config log_id=0000000100
pri=information msg_id=8891139290341031 user=admin ui=telnet(10.106.3.210) action=add
logdesc=Change msg=added cfgpath=system cfgobj=name cfgattr=HC_dnsv6 device_
id=FADV040000002384 vd=root dtime=2020-08-19 16:32:11 itime_t=1601421471
devname=FADV040000002384

Dashboard/widgets/reports

This section lists the new features added to FortiAnalyzer for dashboards, widgets and reports.

List of new features:

l FortiView custom widgets 6.4.1 on page 114
l Extra caching for SOC reports 6.4.1 on page 117
l Asset tags on page 118
l Sankey Chart on page 120
l FortiPortal user summary report 6.4.2 on page 121
l FortiSandbox default report improvement 6.4.2 on page 123
l Improved SOC incident report 6.4.2 on page 124
l Add stackbar chart in FortiView 6.4.2 on page 126
l Interface bandwidth widgets 6.4.2 on page 128
l EMS classification tag 6.4.3 on page 130
l Throughput utilization billing reporting 6.4.3 on page 133
l Subnet list for reports 6.4.3 on page 135
l Asset & Identity View Improvement 6.4.3 on page 138
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FortiView custom widgets - 6.4.1

Custom widgets can be created from predefined Data sources and added to new dashboards in FortiView.

To create a custom widget in FortiView Monitors:

1. Go to FortiView > Monitors and select or create a custom dashboard.
2. In the AddWidget window, select the plus icon next to CustomWidgets to create a new widget.

3. In the custom widget dashboard, enter the name of the custom widget, then select the Data Source, Chart Type,
X Axis or Category field, and Y Axis or Value field.
a. For Data Source, one of four pre-defined data sources can be selected for a widget: soc-sources, soc-

destinations, soc-threats, and soc-sdwan-stats.
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b. For Chart Type, one of four chart types can be selected for a widget: Bar Chart, Line Chart, Pie Chart, and
Donut Chart.

c. The fields available in the X Axis and Y Axis or Category and Value fields vary depending on the data source
selected.
For example, when the data-source is soc-sources, fields in the X Axis include Device ID, Date/Time, User,
Source, Source Interface, Device Source, Device Type,MAC Address, and the fields in the Y Axis include
Threat Score, Threat Block, Threat Pass, Bandwidth, Traffic In, Traffic Out, Sessions, Session Block, and
Session Pass.

d. For Bar Chart and Line Chart, X Axis is the name field and Y Axis is the value field. For Pie Chart and Donut
Chart, Category is the name field and Value is the value field.
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4. Before creating the widget, you can specify the Time Frame and Show Top, then click the Preview button to view the
widget.

5. Click Create to create the widget or click Cancel to discard the widget. After the widget has been created, it will be
listed in the AddWidget window under the CustomWidgets category.
Widgets can be edited or deleted by right clicking them from the AddWidget window and clicking Edit or Delete.

After adding a widget to a custom dashboard, you can select the device, time period, and top results to display from
the widget's toolbar.
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You can further customize the widget's top results and refresh interval through the widget's settings.

Extra caching for SOC reports - 6.4.1

Caching can be enabled for common log fields used for extended log filtering in reports. This feature is an enhancement
for current report Auto Cache and report group function. After enabling this option, the following fields are added to each
running report query:

l Device ID
l VDOM name
l Source Endpoint ID
l Source Enduser ID
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l Source IP
l Destination IP

To enable extended log filtering:

1. Go to Reports > All Reports and select a report.
2. Click the Settings tab.
3. Click Enable Auto-cache.

The option to enable Extended Log Filtering is now available.
4. Enable Extended Log Filtering, and click Apply.

After it has been enabled, run the report and debug. You can see that devid, vd, srcip, dstip, epid, and euid
are added to each report query.

Asset tags

Asset tags from EMS and FortiNAC is available in FortiAnalyzer Assets view.
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To view asset tags in FortiAnalyzer:

1. In the FortiClient EMS Server, go to Compliance Verification > Compliance Verification Rules, and create a new
rule.
In this example, the tag "QA Windows 10Workstation" was created forOS Version: Windows 10.

Once saved, go to Compliance Verification > Host Tag Monitor to confirm the presence of the tag.
Below, the two endpoints using Windows 10 operating systems are tagged withQA Windows 10Workstation.

2. On FortiAnalyzer, go to Fabric View > Fabric Connectors, and create a new FortiClient EMS Connector.

3. Go to FortiSoC > Automation > Playbook and create a new customized playbook with a task using the action
Update Asset and Identity, and save the playbook.
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4. Run the playbook and go to Playbook Monitor to confirm that the playbook was run successfully.

After a few
moments, go to Fabric View > Assets. Tags are now displayed in the Tags column. In this example, the two
Windows 10 endpoints are displayed in the table with the tag "QA Windows 10Workstation".

Sankey Chart

The Sankey Chart type is now available in FortiAnalyzer reports.

To use a Sankey Chart in FortiAnalyzer reports:

1. Go to Reports > Report Definitions > Chart Library.
2. Click Create New to create a new sankey chart or select an existing sankey chart to edit.
3. In the Chart Type field, select Sankey. Configure the remaining settings for your chart and clickOK.
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Run the report to view the generated sankey chart.

FortiPortal user summary report - 6.4.2

Existing customers can generate the same report "Default FortiPortal User Summary report" for deployments without
collectors using FortiAnalyzer.

To view the FortiPortal User Summary report:

1. Go to Reports > Report Definitions > Templates.
The Template - FortiPortal User Summary Report is displayed.

2. Go to All Reports.
The FortiPortal User Summary Report. is available.
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The FortiPortal User Summary Report includes the following table of contents.
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FortiSandbox default report improvement - 6.4.2

This report is an improved version of the "FortiSandbox Default Report" that provides more visibility on file submission to
FSA, performance statistics and threat rating statistics.

To view the improved FortiSandbox default report:

1. Go to Reports > Report Definitions > All Reports.
The FortiSandbox Default Report is available.

2. In the Layout Editor, you can view the following new charts:
l FortiSandbox - File Submission Information

l File Type Summary Submitted to FSA by VMModule
l File Type Breakdown Submitted to FSA by VMModule
l File Type Summary Submitted to FSA
l File Type Breakdown Submitted to FSA

l FortiSandbox - Performance Statistics
l Threat Rating Summary by VM Module
l Threat Rating Breakdown by VM Module
l Threat Rating Breakdown by File Type and VM Module
l Threat Rating Breakdown by Time and VM Module
l Average Threat Rating Duration by VM Module
l Average Threat Rating Duration by Time and VM Module
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Improved SOC incident report - 6.4.2

The SOC incident report has been added to the list of predefined report templates. This summary report will provide
statistics on SOC incidents by their status, severity and category.

To view the SOC incident report:

1. Go to Reports > Report Definitions > Templates.
You can see the Template - SOC Incident Report in the template library.
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2. On the All Reports page, you can view the SOC Incident Report.

The SOC Incident Report contains new charts, including Incidents by Severity, Incidents by Status, Unresolved
Incidents by Category, and Unresolved Incidents by Severity.
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Add stackbar chart in FortiView - 6.4.2

A new chart type, stack bar chart, is added to the Top Application widget under the Applications &Websites dashboard
in FortiView to show the total bandwidth/session stacked by each application over time.

To view the stackbar chart in FortiView:

1. Go to FortiView > Monitors > Applications & Websites > Top Applications and select the settings icon.
The stackbar chart type is displayed in the Chart Type list.

The stackbar chart shows stacked bars for the top 5/10 applications as well as other applications over the specified
time period. The Y axis can be set as Bandwidth or Sessions. Each color in the stacked bar chart represents a
different application.
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2. Mouse over a bar in the chart to show details of the related application in a tooltip.

Interface bandwidth widgets - 6.4.2

Two new widgets, Top Interface of Sent Bit Rate and Top Interface of Received Bit Rate, were added to FortiView under
the Traffic category to provide bandwidth visibility on different interfaces over time.

To add interface bandwidth widgets in the GUI:

1. Go to FortiView > Monitors, and click the Traffic category in the tree menu.
2. In the toolbar, click Edit Dashboard and then click the add icon.
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3. Add the Top Interface of Sent Bit Rate and Top Interface of Received Bit Rate widgets, and click Done.

The Top Interface of Sent Bit Rate widget shows line charts for top 10 sent bit rate of interfaces during the specified
time period.
The Top Interface of Received Bit Rate widget shows line charts for top 10 received bit rate of interfaces during the
specified time period.
Different colors represent the different interfaces in both of the line charts.
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4. Hover your mouse over the line charts to display a tooltip that shows the bit rate for each interface.

EMS classification tag - 6.4.3

This is an enhancement to the Asset and Identity View enriching endpoints information with classification tags from
EMS.

To view EMS classification tags in Assets:

1. On the FortiClient EMS Server, go to Endpoints > All Endpoints, and select an endpoint.
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2. In the Summary tab in the Classification Tabs category, click Add and add a tag. In this example, the Critical tag is
added.

3. On FortiAnalyzer, go to Fabric View > Fabric Connector, and create a new FortiClient EMS Connector.

4. Go to FortiSoC > Playbooks, and create a customized playbook with a task toGet Endpoints, and a second task to
Update Asset and Identity.
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Save and run the playbook, and check the Playbook Monitor to confirm the playbook was run successfully.
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5. Go to Fabric View > Assets to check the endpoints. The applied tag (Critical) has been applied to the endpoint.

Throughput utilization billing reporting - 6.4.3

This report enables users to generate the throughput consumption reporting for the billing purposes through utilizing
interface bandwidth consumption information logged by FortiGate. You must also enable the "billing-report" option under
interface-stats in the FortiAnalyzer CLI in order to use this report.

Dependencies

l The FortiGate must be connected directly to the FortiAnalyzer.
l The FortiGate must have at least one interface configured with theWAN role.
l Before running this report, billing must be enabled for 24 hours or longer.
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To setup the FortiGate device and FortiAnalyzer:

1. In the FortiAnalyzer CLI, enter the following command to enable billing report config:
config system log interface-stats

set billing-report enable
end

2. In the FortiGate device's CLI, enter the following command to connect the device to the FortiAnalyzer:
config log fortianalyzer setting

set upload-option realtime
set reliable enable
set serial <FAZ-SN>

end

If you do not enter the FortiAnalyzer serial number in the above steps, you must configure the following in the
FortiAnalyzer GUI:

1. Go to Device Manager, select the FortiGate device, and click Edit.
2. Set the Admin User and Password fields correctly for the device.
3. ClickOK.

To view the Throughput Utilization Billing Report:

1. On FortiAnalyzer, go to Reports > Templates.
You can see the Template - Throughput Utilization Billing Report in the list of report templates.

2. Go to Reports > All Reports.
You can see the Throughput Utilization Billing Report in the list of reports.
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In the report's Settings tab you can select the interface from Physical Ports or VLAN.

Subnet list for reports - 6.4.3

This new feature offers flexibility of filtering where specific subnets need to be included/excluded from reports.
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To configure subnet list for reports in the GUI:

1. Go to FortiSoC > Handlers > Subnet List and click Create New. Create a new Subnet and Subnet Group:

a. To create a subnet, click Subnet, enter a name, and select a Type. Subnet Notation, IP Range, and Batch Add
are supported.

b. To create a subnet group, click Subnet Group, enter a name, and select the subnet entries.

2. Go to Reports > All Reports, select a report, and click Edit.
On the Settings tab you can see the Subnets setting which includes the options for All Subnets and Specify.
l When All Subnets is selected, subnet and subnet groups are not specified and there is no filtering on srcip or
dstip log fields based on subnets.
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l When Specify is selected, the Include Subnets and Exclude Subnets options become available. You can
specify which subnets and/or subnet groups are included and/or excluded from the list of available entries.

3. After the report settings are defined, run the report and check the results.
Any logs with a srcip or dstip within the specified subnets are checked as analytical data for this report.
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Defined subnet information for included and excluded subnets is displayed in the report as Appendix B.

Asset & Identity View Improvement - 6.4.3

These improvements offer more flexibility to the asset and identity views and address SOC operations limitations
identified in the Asset and Identity center.
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To view the improvements in the Identity center:

1. Go to Fabric View > Identity Center. Pagination is supported and new columns such as VPN IP were added.

2. Click the column display dropdown to add or remove columns in the view.
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3. Click Add Filter in the toolbar to apply a custom filter.

The filter is applied to the view
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4. Click Custom View to save the current view.

5. ClickOK.The view is added to Custom View in the tree menu.
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To view Assets improvements:

1. Go to Fabric View > Assets. More options have been added to the column display dropdown.

2. Click Add Filter in the toolbar, and select a value from the list.
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3. Click Tools > Download, to export entries as CSV file.

Cyber-Physical Security

This section lists the new features added to FortiAnalyzer for cyber-physical security.

List of new features:

l Facial Recognition 6.4.1 on page 143
l Zoom function in FortiRecorder 6.4.1 on page 149

Facial Recognition - 6.4.1

A new AI engine has been added to the FortiRecorder module to identify a person by analyzing patterns in the person's
facial features. Faces detected by the camera can be used to enrich the Assets and Identity feature for UEBA
correlation. The facial recognition feature allows SOC to easily perform video surveillance for its physical security from a
single FortiAnalyzer console.
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GUI

To enable face recognition in the GUI:

1. Go to FortiRecorder > Camera Manager.
2. In the tree menu, click Camera and select a managed camera in the pane.

a. Enable Face Recognition.
b. Click the AF icon to focus the camera.

3. To view faces detected by the camera, go to FortiRecorder > Face Recognition, and click New Face Detected in the
tree menu.
l Similar faces are organized into clusters.
l Each cluster represents a different user.
l You can delete a face from a cluster or merge faces in a cluster.
l Click the image in a cluster to watch a video of the user event.
l Clusters can be ordered by count or time.
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4. Use the profile pane at the right side of the page to link faces to user profiles.
New faces can be linked to following profile types:
l UEBA : The user has an existing endpoint entry within FortiAnalyzer, and has information retrieved from
FortiClient and FortiGate.

l Non-UEBA Staff: The user does not have an endpoint entry in FortiAnalyzer, but is employed by your
organization. For example, a maintenance person.

l Guest: Someone who is not employed by your organization.

5. In the tree menu, click Known Faces to view faces that are linked to a user profile.
l New events detected by the camera events are saved to the related known faces cluster.
l You can delete events from a cluster.
l Click the image to view a video of the event.
l You can order the clusters by count, or by the image time stamp.
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To view activity reports in the GUI:

1. In the tree menu, go to Activity Report > Guests.
The report pane displays the user events.
a. Hover an event in the time line to view when the event was detected and the camera that detected it.
b. Click an event in the time line to watch a video of the event.
c. Use your scroll wheel to adjust the time frame.
d. Click Reset Zoom to reset the time line.

2. In the tree menu, go to Activity Report > Internal Users.
Click a heading to sort a column in ascending or descending order. The following information is displayed:
l User Name: The internal user name.
l Bandwidth (Sent/Received): The bandwidth sent and received from the camera in bytes.
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l Captured Times: The number of times the camera captured an image of the user.
3. In the toolbar, click the time frame dropdown to specify the time period.

CLI

To enable and disable the AI module in the CLI:

config system global
# set disable-module

The disable-module command enables all of the AI modules.

To set the database and disk quota in the CLI:

1. Set disk quota for AI.
config system global

set ai-disk-quota value <disk limit in GB>

If the configuration is successful, the remaining available hard disk space shall be deducted accordingly.
2. Set database table item count limit.

execute face-recognition setting event_item_count_max <limit>

3. The aisched daemon cleans up the database and disk used by AI approximately once a day.

CPU usage

CPU usage is managed by nice. The AI module has three daemons:

aid Pre-processes videos with deep learning algorithms, which consumes lots of computational
resources. The niceness is set to 19 (lowest priority).
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aiclusterd Requires limited CPU/memory resource and is responsible for user interfaces. The niceness
is set to default value 0.

aisched Performs routine tasks,such as daily database clean up and requires very limited
CPU/memory sources. The niceness is set to default value 0.

Memory usage

Memory usage of daemon aid is controlled by Cgroup. If the limit is violated, daemon aid will be killed by Linux kernel.

The following CLI is used to update the maximummemory limitation. The default value is 4096.

config system global
set ai-memory-quota <limit in MB>

end

Face Recognition

Face recognition related CLIs have been added under the execute face-recognition command:

execute face-recognition

backup backup AI infos

log AI log

process process specific videos

restore restore AI infos

setting Show/Modify AI configuration

To back up an AI user's personal information in the CLI:

execute face-recognition backup <ip:port> <filename><username><password>

Now we support restore from FTP server only.

Restoring an AI user's information is supported in the FTP server only.

To insert a specific camera's into the AI database in the CLI:

execute face-recognition process <camera_name>

To configure AI specific settings in the CLI:

Show all AI setting parameters:

execute face-recognition setting

Show a specific key value:

execute face-recognition setting <key>

Modify a specific key value:

execute face-recognition setting <key> <key_value>
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Event logs

Three log types have been added to the current log system:

LOG_EVENT_AID_STATUS

LOG_EVENT_AID_CONFIG

LOG_EVENT_AID_UI

Zoom function in FortiRecorder - 6.4.1

Zoom and auto focusing functions were added to the FortiRecorder module in FortiAnalyzer to improve the recorded
video quality without manually focusing the cameras.

To use the zoom and auto-focus functions in the GUI:

1. Go to FortiRecorder > Camera Manager.
2. In the tree menu, click Camera, and select an authorized camera from the list. Three new icons appear below the

preview image: Zoom In, Zoom Out, and Auto-Focus.

3. To zoom in, click the Zoom In icon several times, and then click the Auto-Focus icon. Wait several seconds for the
camera to zoom in and auto-focus.
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4. To zoom out, click the Zoom Out icon several times, and then click the Auto-Focus icon. Wait several seconds for
the camera to zoom out and auto-focus.
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5. ClickMonitor to view the changes you made to the camera settings.
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Fabric Management Platform

This section lists the new features added to FortiAnalyzer for Fabric Management Platform.

List of new features:

l Single pane on page 152
l Prompt admin to register FortiAnalyzer with FortiCloud on page 152
l FortiManager support for FortiAnalyzer HA on page 158
l Online update and verification for third-party certificates (OCSP stapling) on page 158
l FortiAnalyzer firmware upgrade from FortiGuard servers on page 160

Single pane

This section lists the new features added to FortiAnalyzer for single pane.

List of new features:

l Prompt admin to register FortiAnalyzer with FortiCloud on page 152
l FortiManager support for FortiAnalyzer HA on page 158
l Online update and verification for third-party certificates (OCSP stapling) on page 158
l FortiAnalyzer firmware upgrade from FortiGuard servers on page 160
l FortiAnalyzer GUI accessibility improvements 6.4.4 on page 161

Prompt admin to register FortiAnalyzer with FortiCloud

FortiAnalyzer VM users are now required to register their VM license or get a free trial license. You can register a
hardware device directly from the System Settings > Dashboard pane with FortiCloud.

This topic contains the following section:

l Registering a VM license on page 152
l Getting a trial VM license on page 153
l Registering a hardware device on page 155
l Viewing license information with the CLI on page 157

Registering a VM license

To download a VM license file, log in to FortiCloud, and click Asset >Manage/View Products.
Select a device from the list, and click the link in the License File field.
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To register a VM license:

1. Go to the FortiAnalyzer VM login page.
2. Click Upload License, and take one of the following actions:

l Drag and drop the license file onto the field.
l Click Browse to navigate to the location of your license file on your computer.

3. Click Upload.

Getting a trial VM license

If a VM license is not associated with your FortiCloud account, you can get a free trial license for up to three devices.
Trial licenses do not expire.

To get a trial VM license:

1. Go to the FortiAnalyzer VM login page.
2. Click Login with FortiCloud.
3. Enter your FortiCloud account credentials, and click Login. If you do not have a FortiCloud account, click Create

Account.

FortiAnalyzer VM connects to FortiCloud to get the trial license, and the system reboots.
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4. Log back into FortiAnalyzer VM.

5. Go to System Settings > Dashboard to view the license status in the in the License Information widget.
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6. To view your trial license in FortiCloud, log in to your account, and click Asset >Manage/View Products.

Registering a hardware device

To register a hardware device:

1. To verify the license is not registered, log in to FortiCloud, and click the Assets tab. If you do not see your device,
then it is not registered.

2. In FortiAnalyzer, go to System Settings > Dashboard.
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3. In the License Information widget, click Register Now.

4. Enter your device information in the FortiCloud window, and clickOK. FortiAnalyzer sends the information to
FortiCloud.

After the information is synchronized, the Status changes to Registered.
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5. Go back to the Assets page in FortiCloud to verify the device is registered.

Viewing license information with the CLI

You can view the license status and information by using the CLI.

To view the license status in the CLI:

get system status

To view the license information in the CLI:

diagnose debug vminfo
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To connect the VM to FortiCloud when you set up the device:

diagnose debug enable
diagnose debug application vmd <integer>

Online update and verification for third-party certificates (OCSP stapling)

You can enable Anycast to optimize the routing performance to FortiGuard servers. Relying on Fortinet DNS servers,
FortiAnalyzer obtains a single IP address for the domain name of each FortiGuard service. BGP routing optimization is
transparent to FortiAnalyzer. The domain name of each FortiGuard service is the common name in that service's
certificate. The certificate is signed by a third-party intermediate CA. The FortiGuard server uses the Online Certificate
Status Protocol (OCSP) stapling technique, enabling FortiAnalyzer to always validate the FortiGuard server certificate
efficiently.

This feature focuses on the Anycast option and TLS handshake using OCSP stapling when connecting to the FortiGuard
server.

To enable online update and verification for third party certificates:

1. Enable Anycast support:
config fmupdate fds-setting

set fortiguard-anycast enable
set fortiguard-anycast-source {aws | fortinet}

end

When Anycast is enabled, FortiAnalyzer only completes the TLS handshake with a FortiGuard server that provides a
goodOCSP status for its certificate. Any other status will result in a failed SSL connection. Also, FortiGuard enforces
connection only over port 443.

FortiAnalyzer connecting to FortiGuard:

1. FortiAnalyzer embeds CA bundle that includes third party intermediate CA and the root CA.
2. FortiAnalyzer finds FortiGuard IP address from the DNS.
3. FortiAnalyzer initiates TLS handshake with the FortiGuard IP address.
4. FortiGuard servers provide certificates with its OCSP status: good, revoked, or unknown.
5. FortiAnalyzer verifies CA against the root CA within the CA bundle.
6. FortiAnalyzer then verifies the intermediate CA's revoke status against the root CA's CRL.
7. Finally, FortiAnalyzer verifies the FortiGuard certificate OCSP status.

OCSP stapling is reflected on the signature interval (currently, 24 hours), and good means that the certificate is not
revoked at that timestamp. The FortiGuard servers query the CA's OCSP responder every four hours and updates its
OCSP status. If the FortiGuard server is unable to reach the OCSP responder, it keeps the last known OCSP status for
seven days. This cached OCSP status is immediately sent out when a client connection request is made, which
optimizes the response time.

FortiManager support for FortiAnalyzer HA

You can manage FortiAnalyzer HA via FortiManager. FortiManager retrieves the cluster member list and updates the
information whenever it changes, including FortiAnalyzer HA failover or a change in members.
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To enable support for FortiAnalyzer HA:

1. Go to Device Manager > Device and Groups.
2. Click the down arrow next to Add Devices. Select Add FortiAnalyzer.

The Add FortiAnalyzer dialog opens.

3. From the Add FortiAnalyzer box, add FortiAnalyzer HA to FortiManager DVM by HA cluster's VIP, and click Next.
The FortiAnalyzer HA is discovered with its HA status information. Click Next to continue.

FortiAnalyzer HA is added successfully. Click Finish.

4. In the tree menu, selectManaged FortiAnalyzer. The device status icon is shown as the HA cluster and the SN is
shown as the primary SN.

FortiManager DVM gets an update after the failover on FortiAnalyzer in 300 seconds. Here, the previous primary
"FAZ-VMTM20001379" becomes the secondary, and the new primary is "FAZ-VMTM20001378".
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You can get the HA status update immediately, select the FortiAnalyzer device and either
click Refresh Device from the toolbar, or right-click and select Refresh.

To check the DVM device list in the CLI:

1. View the DVM device list once FortiAnalyzer HA is added to FortiManager:
diagnose dvm device list

It will have correct HA cluster information, including member list and role.
2. View the DVM device list after the failover on FortiAnalyzer:

diagnose dvm device list

It will have the updated HA cluster information. The previous primary changes to secondary and vice versa.

FortiAnalyzer firmware upgrade from FortiGuard servers

You can upgrade FortiAnalyzer firmware by using images available on FortiGuard servers. A green checkmark beside
the available firmware images indicates the recommended FortiAnalyzer upgrade path. You can also upgrade to a
firmware image that is not recommended if desired.

To upgrade FortiAnalyzer firmware in the GUI:

1. Go to System Settings.
2. In the System Information widget, beside Firmware Version, click Update Firmware.

The Firmware Management dialog box opens.

3. From the FortiGuard Firmware box, select the version of FortiAnalyzer for the upgrade, and clickOK.
The FortiGuard Firmware box displays all FortiAnalyzer firmware images available for upgrade. A green checkmark
displays beside the recommended image for FortiAnalyzer upgrade.
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Because this image was captured before the release of FortiAnalyzer 6.4.0, a green
checkmark is not yet available.

If you select an image without a green checkmark, a confirmation dialog box is displayed. ClickOK to continue.

FortiAnalyzer downloads the firmware image from FortiGuard.

FortiAnalyzer uses the downloaded image to update its firmware, and then restarts.

After FortiAnalyzer restarts, the upgrade is complete.

FortiAnalyzer GUI accessibility improvements - 6.4.4

FortiAnalyzer now implements a high contrast dark theme in order to make the FortiAnalyzer GUI more accessible, and
to aid people with visual disability in using the FortiAnalyzer GUI.
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To change the currently active theme to the High Contrast Dark theme:

1. Go to System Settings > Admin > Admin Settings.
2. Scroll to View Settings > Theme.
3. Select the High Contrast Dark theme tile from the available theme tiles.
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4. Click Apply.
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This section lists the other new features added to FortiAnalyzer.

List of new features:

l FortiAnalyzer Application logs on page 165

FortiAnalyzer Application logs

FortiAnalyzer applications such as incident management and automation playbooks generate local audit logs,
accessible in LogView under each ADOM.

In the root ADOM, administrators can view the local event logs and the application logs of the root ADOM.
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Use Log Browse to find application log files.
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