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Change Log

Date Change Description

2019-04-11 Initial release.

2019-04-16 Updated FortiClient EMSConnector on page 29.

2019-05-08 Added Fabric ADOM management on page 13.

2019-05-24 Added License for FortiGates with FortiManager Cloud Entitlement on page 143.

2019-05-30 Added Zero-touch provisioning for FortiSwitch on page 83 and Zero-touch provisioning for
FortiAP on page 78.

2019-07-04 Updated the URL for FNDN in Swagger support for FNDN API Tool on page 142.

2020-09-11 Updated Zero Touch Provisioning - CLI Template with Variables on page 68.
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Expanding Fabric

This section lists the new features added to FortiManager for the expanding fabric.

List of new features:

l Security Fabric Topology on page 7
l Fabric ADOM management on page 13
l Dynamic Mapping for SSID on page 16
l Split Task VDOM Mode Support on page 18

Security Fabric Topology

Both the Physical Topology and Logical Topology from Security Fabric deployments can now be accessed from
FortiManager. In the event FortiManager is managing multiple Fabric deployments in the same ADOM, the
administrator can switch between them from a single console. The FortiManager uses shared components with
FortiGate, thereby supporting a consistent look and feel, level of detail, and usability exactly like FortiGate devices.

See Security Fabric Topology.

Security Fabric Deployments

Manage multiple Security Fabric deployments in an ADOM using FortiManager.
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Expanding Fabric

On FortiManager, go to Fabric View. Physical Topology tab and Logical Topology tab are shown at top menu bar. To
switch between fabric deployments, go to top right hand corner fabric list and select a fabric deployment.

Physical Topology

The Physical Topology shows the devices in the Security Fabric and the devices they are connected to. You can also
select whether or not to view access devices in this topology.

l Access Device View: In below example, the access device FortiSwitch "S108DVWA9XDVGG54" is shown.

l No Access Device View: In below example, the access device FortiSwitch "S108DVWA9XDVGG54" is not shown.
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Expanding Fabric

l More information: Hover over a device for more information.

l Search: The search field is located above the view. The search highlights devices that match your search criteria,
and grays out devices that don't match.
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Expanding Fabric

Filter Topology View

Use filters to narrow down the data on the topology views to find specific information. The filter menu is located at top
right corner.

l Filter: Filter by Device Traffic, Device Count, Device Type, Vulnerability, or No Devices.

l Sub-filter: When the filter is set to Device Traffic or Device Count, there is a sub-filter that provides Bytes, Packets,
Bandwidth, and Sessions options.
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Expanding Fabric

Logical Topology

The Logical Topology view is similar to the Physical Topology view, but it shows the network interfaces, logical or
physical, that are used to connect devices in the Security Fabric. Logical Topology provides the same search function,
tooltips for device information and the filter view as Physical Toplogy. Logical Topology does not have Access Device
view and No Access Device view, which is different from Physical Topology.

To see the Logical Topology, go to Fabric View > Logical Topology.

l Device Information: Hover over a icon to see information for a device.
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Expanding Fabric

l Filter: Logical Topology view can be filtered by Device Traffic, Device Count, Device Type, Vulnerability or No
Devices.

l Sub-filter: When the filter is set to Device Traffic or Device Count, the view can be further filtered by Bytes, Packets,
Bandwidth, and Sessions.
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Expanding Fabric

Fabric ADOM management

Starting from 6.2.0, FortiAnalyzer supports a new ADOM type called Fabric ADOM, which contains logs from all Fabric
products (FortiGate, FortiMail, FortiWeb, FortiSandbox, FortiClient, and so on). When FortiManager is managing a
FortiAnalzyer that contains a Fabric ADOM:

l ADOM type on FortiManager will be converted to a Fabric ADOM.
l Devices will be synchronized to the new ADOM (non-FortiGate devices are synchronized as log-only devices).
l Users can access logs from all devices in the remote ADOM.

This feature requires both FortiManager and FortiAnalyzer to be running version 6.2.0 or later.

FortiManager adds FortiAnalyzer devices by using central management. Any FortiGate devices that exist in
FortiManager, but not in FortiAnalyzer will synchronize to FortiAnalyzer as logging devices. Any FortiGate devices that
exists in FortiAnalyzer, but not in FortiManager will synchronize to FortiManager as configuration and logging devices,
which means you must provide valid IP addresses and login credentials when adding the device. The non-FortiGate
logging devices that exist in FortiAnalyzer, but not in FortiManager will synchronize to FortiManager as logging-only
devices.

This procedure requires the following steps:

1. On FortiAnalyzer, create a Fabric ADOM.
2. On FortiManager, add an ADOM, and add the FortiAnalyzer device to the ADOM

To create a Fabric ADOM on FortiAnalyzer:

1. On FortiAnalyzer create a Fabric ADOM.
2. Open the ADOM, and add FortiGate logging devices, Security Fabric group and non-FortiGate logging devices,
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Expanding Fabric

such as FortiWeb, FortiCache, FortiSandbox, and so on.

To configure FortiManager:

1. On FortiManager, create a FortiGate ADOM with the same name as the Fabric ADOM in FortiAnalyzer.
The FortiGate ADOM will be used to manage the FortiAnalyzer Fabric ADOM. Although FortiManager supports
Fabric ADOMs, you cannot use the GUI to create a Fabric ADOM.

2. Open the ADOM, and go to DeviceManager.
3. From the AddDevicemenu, select Add FortiAnalyzer to use the wizard to add the FortiAnalyzer device.

When the FortiAnalyzer ADOM type is Fabric, a warning is displayed. If you continue to synchronize the ADOM, the
FortiManager ADOM type will change from FortiGate to Fabric.
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Expanding Fabric

4. ClickSynchronize ADOM andDevices.
FortiManager starts to synchronize devices, and the AddMultiple Devices dialog box is displayed where you can
edit the device name/ IP Address/ Admin User/ Password.

A valid IP address and login credentials are required to add FortiGate devices.
After all devices are synchronized, FortiAnalyzer is successfully added to FortiManager.
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Expanding Fabric

Dynamic Mapping for SSID

Dynamically map IP subnets to FortiGate devices where the SSID credentials are the same, but the subnet is different.
This saves time for administrators since they can use the same SSID profile, and change granular settings using per-
device mapping.

To configure per-device mapping for SSID:

1. Go to AP Manager > WiFi Profiles > SSID.
2. Toggle Per-DeviceMapping toON.
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Expanding Fabric

3. Create a new SSID or edit an existing SSID. Configure the following settings:
a. Select the mapped FortiGate device.
b. Specify theMapped IP/Netmask.
c. ToggleMapped DHCP Server toON. ClickCreate New and specify the Address Range.

d. Select the SSID security mode asWPA Enterprise,WPA only Enterprise orWPA2Only Enterprise, to
override the authentication settings for mapped devices.

4. When the SSIDs are being used for the mapped FortiGate device, install the per-device settings on FortiGate
instead of the default settings in the SSID.
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Expanding Fabric

Split Task VDOM Mode Support

FortiManager 6.2.0 supports management of the new FortiGate Split Task VDOM mode.

There are three VDOM modes available:

l NoVDOMis when no VDOMs can be created.
l Multi VDOM is the original VDOMs enabled mode. You can create as many vdoms as you want, up to the VDOM

license limit.
l Split VDOM is a specialized VDOM mode, with only 2 VDOMs - FG-traffic and root. More VDOMs cannot be

added. FG-traffic is a regular VDOM. It is intended to have all the policies, addresses, UTM profiles for the device,
and it will handle all the traffic, just like in No VDOM mode. root does not (and cannot) have policies or profiles. root
is intended for the management of the FGT itself. Interfaces likemgmt , ha should be assigned to root and the rest
of the interfaces to FG-traffic.

Multi VDOM and Split VDOMmodes are not related and there is no compatibility between them. It is not possible to
switch between Multi VDOM and Split VDOM. Any change has to go through NoVDOMmode.
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Expanding Fabric

To configure Split VDOM:

l Turn on Split VDOM.

l Two pre-defined VDOMs are available - FG-traffic and root.
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Expanding Fabric

l You cannot add or delete VDOMs. The options are disabled in the right-click menu.

l Map all interfaces to ADOM.
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Expanding Fabric

l Create policies and policy packages in FG-traffic and install.

FortiManager 6.2.0 New Features Guide 21
Fortinet Technologies Inc.



Fabric Connectors

This section lists the new features added to FortiManager for Fabric Connectors.

List of new features:

l Cisco pxGrid/ISE on page 22
l Multiple Concurrent Fabric Connectors on page 28
l FortiClient EMSConnector on page 29
l Cloud Connector - OCI on page 33
l Cloud Connector - GCP on page 38
l Cloud Connector - ESXi on page 43
l SDN Connector - Kubernetes (K8S) (Multiple Clouds) on page 49
l Cloud Connector - AliCloud on page 56

Cisco pxGrid/ISE

A new fabric connector is added for Cisco pxGrid. When enabled, FortiManager centralizes the updates from pxGrid for
all FortiGate devices, and leverages the efficient FSSO protocol to apply dynamic policy updates to FortiGate.

Deploying pxGrid connector consists of the following steps:

1. Configure Cisco ISE Server.
2. Configure FortiManager.

Configure Cisco ISE Server

To configure Cisco ISE server:

1. Create a Security Group: Go to ISE > Work Centers > TrustSec > Components > Security Groups. Click Add.
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Fabric Connectors

2. Create a User Identity Group: Go to ISE > Administration > Identity Management > Groups > User Identity
Groups. ClickAdd.

3. Create a user and add it to User Identity Group: Go to ISE > Administration > Identity Management > Identities.
ClickAdd.

4. Match the Security Group with User Identity Group in the policy: Go to ISE > Work Centers >TrustSec >
Components > Policy Sets. Right-click and go to Authorization policy > Basic_Authenticatied _Access and click
Edit to match the Security Group with the User Identity Group.
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Fabric Connectors

5. Generate the pxGrid certificate and download it to the local computer: Go to ISE > Administration > pxGrid
Services > Certificate and select Generate pxGrid Certificates.

6. See log for current users: Go to ISE > Operations > RADIUS > Live Logs.

7. See live sessions of current users: Go to ISE > Operations > RADIUS > Live Sessions.
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Fabric Connectors

Configure FortiManager

To configure FortiManager:

1. Go to System Settings > Local Certificates > Import. Import the downloaded certificate.

2. Go to Fabric View > Fabric Connectors. Create a new pxGrid Fabric Connector with the imported certificate.

3. Go to Policy & Objects > Object Configuration > Single Sign-On. Select the connector and click Import.
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Fabric Connectors

4. The pxGrid connector is imported. ClickClose to close the import dialog.

5. ClickUser Groups and create a new group. Set the type as FSSO/Cisco TrustSec, and select pxGrid user as a
member.

6. Create a policy with the ISEgroup user group and install the policy to FortiGate.
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Fabric Connectors

7. Go to Fabric View > Fabric Connectors. ClickMonitor to see the users currently logged in.

8. Log on to FortiGate to view the ISE user group.

9. On the FortiGate command line, use the diagnose debug authd fsso list to monitor the current user list.

Command Line

Command line for FortiManager:

config system connector
set
fsso-refresh-interval FSSO refresh interval (60 - 1800 seconds).
fsso-sess-timeout FSSO session timeout (30 - 600 seconds).
px-refresh-interval pxGrid refresh interval (60 - 1800 seconds).
px-svr-timeout pxGrid server timeout (30 - 600 seconds).
Realtime monitor debug to watch server connection:
diag debug application connector 255

Command line for FortiGate:

diag debug authd fsso server-status
diag debug authd fsso list-------> show connected users
----FSSO logons----
IP: 192.168.1.19 User: test2 Groups: px_fc1_security_grp1 Workstation: MemberOf: fscs1
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Fabric Connectors

IP: 192.168.1.20 User: test2 Groups: px_fc1_security_grp1 Workstation: MemberOf: fscs1
Total number of logons listed: 2, filtered: 0
----end of FSSO logons----
diag debug authd fsso refresh-logon
diag debug authd fsso refresh-group

Multiple Concurrent Fabric Connectors

Previous versions of FortiManager allowed adding only one connector per type. For example, if you add the AWS
connector, you could not add another AWS connector in FortiManager.

FortiManager version 6.2.0 allows adding multiple connectors of the same type.

To add multiple connectors of the same type from Fabric View:

1. Go to Fabric View and clickCreate New.
2. Select a fabric connector and configure the settings to add the connector.

3. Select the same Fabric Connector and configure the settings to add the connector again.

To add multiple connectors of the same type from Policy & Objects:

1. Go to Policy & Objects > Object Configurations > Fabric Connectors.
2. ClickCreate New.
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Fabric Connectors

3. Select a fabric connector and configure the settings to add the connector.

4. Select the same Fabric Connector and configure the settings to add the connector again.

FortiClient EMS Connector

The FortiClient EMSConnector works virtually the same way as Active Directory / Single Sign On (FSSO) from the
FortiManager's perspective:

l Configure the connector in FortiManager that manages the FortiGate devices. The administrator can define and
install the dynamic groups and policies to FortiGate devices.

l FortiGate will communicate directly to FortiClient EMS to learn dynamic group changes and apply them in runtime.

To configure FortiClient EMS Connector with FSSO in FortiManager:

1. Install FortiClient Endpoint Management Server in Windows server. Log on to the EMS server and go to
Compliance Verification > Compliance Verification Rules and clickAddRules. Create a few rules with different
tags.
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Fabric Connectors

2. Log on to FortiManager. Go to Fabric View > Fabric Connectors and clickCreate. Select FSSO and clickNext.

3. In the Create New Fabric Connector screen, specify a Name, select the Type as FortiClient EMS, IP/Name as
the Windows Server's IP and leave the password blank if the Windows Server does not have a password. Turn SSL
toON.
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Fabric Connectors

4. ClickApply and Refresh. The connector gets a list of tags from the EMS server and shows them as User Groups.
This is similar to the Active Directory group in the backend of the Windows Server.

5. Go to Policy & Objects > Object Configurations > User & Device > User Groups and create a new user group.
Specify a name for the group, select the type as FSSO/Cisco TrustSec and in Select Entries, select the tags from
EMS server as members. Use this user group in a policy and install the policy to FortiGate devices.
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Fabric Connectors

6. The Fabric Connectors are also visible in Policy & Objects > Object Configurations > Fabric Connectors >
SSO/Identity where they can be edited if required.

Refer to FortiClient Enterprise Management Server (EMS) Administration Guide or FortiClient
Enterprise Management Server (EMS) Release Notes for system requirement and versions of
Windows Server supported.
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Fabric Connectors

Cloud Connector - OCI

FortiOS 6.2 cloud connector for Oracle (OCI) can be centrally managed by FortiManager.

Create an OCI Certificate and Dynamic Local Certificate

l Import OCI certificate to FortiManager

l Create a New Dynamic Local Certificate mapping FortiGate OCI certificate from Policy Packages > Objects
Configurations > Dynamic Objects > Local Certificate. This certificate is used to install to FortiGate with the
correct OCI certificate configuration.

Create OCI SDN connector in Policy Packages

Create the SDN connector in Policy Packages.
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Fabric Connectors

To create the SDN connector:

1. Go to Policy & Objects > Fabric View > Fabric Connectors.
2. ClickCreate New.

3. Select theOracle OCI connector.
4. Specify the values. Most importantly, the System Certificate for Connection and theOCI Certificate.

5. ClickOK. The Oracle OCI connector is created.
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Fabric Connectors

Create OCI SDN connector in Object Configurations

Alternatively, you can create the SDN connector in Object Configurations.

To create the SDN connector:

1. Go to Policy & Objects > Object Configuration > Fabric Connectors.
2. ClickSDN Connector > Oracle OCI connector.

3. Click the Import to import OCI objects. The Import option is only available on Policy & Objects > Object
Configurations.
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Fabric Connectors

4. Add the filter and then clickOK to apply the selected filter.

5. Click Import button to import.

6. The new imported OCI address created.
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Fabric Connectors

7. Create a new Fabric Connector Address. Import the connector or enter the details of the connector.

Install the SDN connector to FortiGate

To install the SDN connector to FortiGate:

1. Install OCI SDN connector configuration and imported OCI dynamic object to FortiGate.

2. Check the FortiGate whether, the OCI connector and address is installed.
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Fabric Connectors

3. The OCI address IP can now be resolved.

Cloud Connector - GCP

FortiOS 6.2 cloud connector for Google (GCP) can be centrally managed by FortiManager.

Create GCP SDN connector in Policy Packages

Create the SDN connector in Policy Packages.

To create the SDN connector:

1. Go to Policy & Objects > Fabric View > Fabric Connectors.
2. ClickCreate New.
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Fabric Connectors

3. Select theGCPconnector.

4. Specify the values.

5. ClickOK. The GCP connector is created.

Create GCP connector in Object Configurations

Alternatively, you can create the SDN connector in Object Configurations.
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Fabric Connectors

To create the SDN connector:

1. Go to Policy & Objects > Object Configuration > Fabric Connectors.
2. ClickSDN Connector > GCP connector.

3. Configure the GCP connector information.

4. Click the Import to import GCP objects. The Import option is only available on Policy & Objects > Object
Configurations.
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Fabric Connectors

5. Add the filter and clickOK to apply selected filter.

6. The new imported GCP address created.

7. Create a new Fabric Connector Address. Import the connector or enter the details of the connector.
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Fabric Connectors

Install the SDN connector to FortiGate

To install the SDN connector to FortiGate:

1. Install GCP SDN connector configuration and imported GCP dynamic object to FortiGate.

2. Check the FortiGate whether, the GCP connector and address is installed.

3. The GCP address IP can now be resolved.
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Fabric Connectors

Cloud Connector - ESXi

FortiOS 6.2 cloud connector for VMWare (ESXi) can be centrally managed by FortiManager.

Create ESXi SDN connector in Policy Packages

Create the SDN connector in Policy Packages.

To create the SDN connector:

1. Go to Policy & Objects > Fabric View > Fabric Connectors.
2. ClickCreate New.

3. Select the ESXiconnector.
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Fabric Connectors

4. Specify the values.

5. ClickOK. The ESXi connector is created.

Create ESXi connector in Object Configurations

Alternatively, you can create the SDN connector in Object Configurations.

To create the SDN connector:

1. Go to Policy & Objects > Object Configuration > Fabric Connectors.
2. ClickSDN Connector > ESXi connector.
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Fabric Connectors

3. Configure the ESXi connector information.

4. Click the Import to import ESXi objects. The Import option is only available on Policy & Objects > Object
Configurations.
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Fabric Connectors

5. Add the filter and clickOK to apply selected filter.

6. Click Import.

FortiManager 6.2.0 New Features Guide 46
Fortinet Technologies Inc.



Fabric Connectors

7. The new imported ESXi address created.

8. Create a new Fabric Connector Address. Import the connector or enter the details of the connector.
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Fabric Connectors

Install the SDN connector to FortiGate

To install the SDN connector to FortiGate:

1. Install ESXi SDN connector configuration and imported ESXi dynamic object to FortiGate.

2. Check the FortiGate whether, the ESXi connector and address is installed.

3. The ESXi address IP can now be resolved.
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Fabric Connectors

Filter IP Addresses from VMWare ESXi

To filter out the IPs from VMware ESXi and vCenter servers, following address filters are introduced:

l vmid
l host
l name
l uuid
l vmuuid
l vmnetwork
l guestid
l guestname
l annotation

SDN Connector - Kubernetes (K8S) (Multiple Clouds)

FortiOS 6.2 cloud connector for Kubernetes can be centrally managed by FortiManager. This includes:

l Private Cloud (K8S)
l AWS (EKS)
l Azure (AKS)
l Google (GKE)
l Oracle (OKE)

Create Kubernetes SDN connector in Policy Packages

Create the SDN connector in Policy Packages.

To create the SDN connector:

1. Go to Policy & Objects > Fabric View > Fabric Connectors.
2. ClickCreate New.
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Fabric Connectors

3. Select the Kubernetes connector.

4. Specify the values.

5. ClickOK. The Kubernetes connector is created.

Create Kubernetes connector in Object Configurations

Alternatively, you can create the SDN connector in Object Configurations.
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To create the SDN connector:

1. Go to Policy & Objects > Object Configuration > Fabric Connectors.
2. ClickSDN Connector > Kubernetes connector.
3. Configure the Kubernetes connector information.

4. Click the Import to import Kubernetes objects. The Import option is only available on Policy & Objects > Object
Configurations.

5. Add the filter and clickOK to apply selected filter.
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6. Click Import. Select the SDN connector.

7. Click Import.

8. The new imported Kubernetes address created.
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9. Create a new Fabric Connector Address. Import the connector or enter the details of the connector.

Install the SDN connector to FortiGate

To install the SDN connector to FortiGate:

1. Install Kubernetes SDN connector configuration and imported Kubernetes dynamic object to FortiGate.

2. Check the FortiGate whether, the Kubernetes connector and address is installed.
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3. The Kubernetes IP can now be resolved.

SDN Connector for Kubernetes for Azure
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SDN Connector for Kubernetes for GCP

SDN Connector for Kubernetes for AWS
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SDN Connector for Kubernetes for Oracle OCI

Cloud Connector - AliCloud

FortiOS 6.2 cloud connector for AliCloud (ACS) can be centrally managed by FortiManager.

Create ACS SDN connector in Policy Packages

Create the SDN connector in Policy Packages.

To create the SDN connector:

1. Go to Policy & Objects > Fabric View > Fabric Connectors.
2. ClickCreate New.
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3. Select the ACSconnector.

4. Specify the values.

5. ClickOK. The ACS connector is created.

Create ACS connector in Object Configurations

Alternatively, you can create the SDN connector in Object Configurations.
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To create the SDN connector:

1. Go to Policy & Objects > Object Configuration > Fabric Connectors.
2. ClickSDN Connector > ACS connector.

3. Configure the ACS connector information.

4. Click the Import to import ACS objects. The Import option is only available on Policy & Objects > Object
Configurations.
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5. Add the filter and clickOK to apply selected filter.

6. Click Import.

7. The new imported ACS address created.
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8. Create a new Fabric Connector Address. Import the connector or enter the details of the connector.

Install the SDN connector to FortiGate

To install the SDN connector to FortiGate:

1. Install ACS SDN connector configuration and imported ACS dynamic object to FortiGate.

2. Check the FortiGate whether, the ACS connector and address is installed.
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3. The ACS address IP can now be resolved.
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This section lists the new features added to FortiManager for SD-WAN.

List of new features:

l IPSECWizard in Device Manager on page 62
l Zero Touch Provisioning - CLI Template with Variables on page 68
l SD-WAN History Monitoring on page 70
l Template Import from Device on page 75
l Zero-touch provisioning for FortiAP on page 78
l Zero-touch provisioning for FortiSwitch on page 83

IPSEC Wizard in Device Manager

The SD-WAN Interface page in FortiManager now includes an IPsec VPN creation wizard.

Configuring the IPsec VPN in SD-WAN

1. Go to System Settings > All ADOMs and edit the ADOM. Disable SD-WAN in Central Management. ClickOK.
2. Go to DeviceManager > SD-WAN. Select any device or VDOM and clickEdit. If no device is available, click

Create New.
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3. ClickCreate VPN under InterfaceMembers in the Create New SD-WAN or Edit SD-WAN page.
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4. Configure the settings. ForOutgoing Interface, select one or more interfaces.
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5. ClickOK to auto-generate IPsec VPNs.
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6. The auto-generated VPN interface are automatically added to the list of SD-WANmembers.

7. Edit the VPN in InterfaceMembers to configureGateway IP, Estimated Upstream Bandwidth (Kbps), and
Estimated Downstream Bandwidth (Kbps).
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8. The IPsec VPN with the configured settings is now available for use.
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Zero Touch Provisioning - CLI Template with Variables

In FortiManager 6.2, it is now possible to define a CLI template using variables, and to assign those variable definition
per-device. For Zero-Touch Provisioning (ZTP), this allows to define a model device, and to assign a template with
variables, so that on the first connection, the unique configuration for that site can be deployed without manual
intervention.

To configure a CLI Template with variables:

1. Go to System Settings > Advanced > Meta Fields. Define the variables which are used in the CLI templates.

2. Go to DeviceManager, edit the device and enter the value for the variables.
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3. Go to Script Manager. There are two new script types: CLI Template and CLI Template Group. Create a newCLI
Script Template. Here is an example of CLI Template Script.

config system interface
edit "vlan32"

set ip $(vlan32) $(mask)
set interface "port2"
set vlanid 32

next
end

4. The variables in the CLI Template can be modified. FortiManager only supports modified variable for IPv4 address
format. Here is the example that a CLI Template could contain modified variables.

config router static
edit 1

set gateway $(vlan32:2,-1:3,+1:4,254)
set device "vlan32"

next
end

In this example, the CLI Template mechanism will subtract -1 to the 2nd byte of the IP address defined in the
variable subnet_lan and add 1 to the 3rd byte, and finally will set the 4th byte to 254.

5. Create a CLI template group. You can drag and drop to re-order members.
6. Assign the CLI template and template group to device (global) or VDOM.
7. On the Device Manager page, a new column CLI Template Status was added onManaged FortiGate list page,

and it works together with Config Status and Policy Package Status to indicate device status. EitherConfig
Status orCLI Template Status is dirty, it is able to install device configuration changes to FortiGate.
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8. ACLI Template is implicitly applied when the administrator is triggering a push operation (Install Device Settings or
Policy Package Install). There is no need for an explicit Apply CLI Template operation. When installing device
settings or a policy package, FortiManager should always consider applying the CLI Template after all the copy
operations.

SD-WAN History Monitoring

History graphs are now available for the SD-WANMonitoring. You can View bandwidth, packet loss, latency and jitter
history for each device / WAN-link interface and cloud applications. Additionally, the interface allows drill-down to
selected time periods for deeper inspection of those events.

l Go to SD-WANMonitoring > Table view. For each device / interface you can now see Bandwidth / Packet Loss /
Latency / Jitter history

l Go to SD-WANMonitoring > Table view. For each device, you can now see the interface status history.
l This feature is only for ADOM 6.2 and FortiOS 6.2.
l FortiOS 6.0 does not support history API and hence the drill-down is disabled in table view.

Enable or Disable SD-WAN History Monitoring

Enable/disable the SD-WAN history monitoring from the command line. The default is disable.

To enable SD-WAN History Monitoring:

config system admin setting
set sdwan-monitor-history enable

end
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To disable SD-WAN History Monitoring:

config system admin setting
set sdwan-monitor-history disable

end

When SD-WAN History Monitoring is disabled

When SD-WAN history monitoring is disabled, go to SD-WAN Monitor> Table View to view the drill-down monitor.
When disabled, FortiManager shows only the history for the last 10 minutes querying the data directly from FortiGate
devices.

l Go to SD-WAN Monitoring > Table View. The drill-down is available to monitor Health Check History and Interface
Status History.

l Go to SD-WAN Monitoring > Table view. For each device / interface you can now see Bandwidth Overview/ Traffic
Overview.

l Go to SD-WAN Monitoring > Table view. For each device / interface you can now see Packet Loss / Latency /
Jitter history.
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l Go to SD-WAN Monitoring > Table view. For each application, you can now see Packet Loss / Latency / Jitter
history.

When SD-WAN History Monitoring is enabled

See Optimize FortiManager REST API querying of FortiGate on page 73.
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Optimize FortiManager REST API querying of FortiGate

Longer-term history (up to 8 days) can be stored by FortiManager and available for drill-down and and trending analysis.
This feature is enabled in CLI and should be assessed for deployment size, available storage, etc.

History graphs are now available for the SD-WANMonitoring. You can View bandwidth, packet loss, latency and jitter
history for each device / WAN-link interface and cloud applications. Additionally, the interface allows drill-down to
selected time periods for deeper inspection of those events.

l Go to SD-WANMonitoring > Table view. For each device / interface you can now see Bandwidth / Packet Loss /
Latency / Jitter history

l Go to SD-WANMonitoring > Table view. For each device, you can now see the interface status history.
l This feature is only for ADOM 6.2 and FortiOS 6.2.
l FortiOS 6.0 does not support history API and hence the drill-down is disabled in table view.

Enable or Disable SD-WAN History Monitoring

Enable/disable the SD-WAN history monitoring from the command line. The default is disable.

To enable SD-WAN History Monitoring:

config system admin setting
set sdwan-monitor-history enable

end

To disable SD-WAN History Monitoring:

config system admin setting
set sdwan-monitor-history disable

end

When SD-WAN History Monitoring is disabled

Go to SD-WAN Monitoring > Table View. The drill-down is available only for 10 minutes and is directly queried from
FortiGate devices.
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When SD-WAN History Monitoring is enabled
Go to SD-WAN Monitoring > Table View. The drill-down monitor can now select different time
period for last 24/12/6/1/N hours, and custom days.

Maximum of 8 days data can be kept in the FortiManager database.
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Template Import from Device

When central SD-WANmanagement is enabled, a device pre-configured device can have its configuration imported to
central templates, which can then be reused for other devices in the deployment.

To import SD-WAN templates:

1. Go to DeviceManager > SD-WAN > SD-WAN Templates.
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2. Click Import and select the device/VDOM to import.
l The SD-WAN templates are imported.

l The Interface Members, Performance SLA, and SD-WAN rules are also imported.

l After import is completed, the Interface Members will generate a name like Import_FGT-VM64-148_root_
member_port2. Default import name for member:Import_{device-name}_{vdom-name}_member_{interface-
name}.

l After import is completed, the Health Check servers will generate a name like Import_FGT-VM64-148_root_
health_lp_ts2. Default import name for member:Import_{device-name}_{vdom-name}_health_{health-check-
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name}.
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Zero-touch provisioning for FortiAP

Model devices used for ZTP can also be linked to model FortiSwitches, enabling provisioning of switch settings when
first connected.

Pre-previsoning model FortiAP and link it to a model FortiGate

1. Create a Model FortiGate device by using a real FortiGate serial number.
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2. Configure a model device interface IP, which will be used as the management IP by FortiManager.

3. In APManager, create model APs on the model FortiGate by using a real FortiAP serial number.
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4. Connect the physical AP to the real FortiGate, and connect the FortiGate with FortiManager through the network.
5. Log on to FortiGate. Go to Security Fabric > Settings, configure Central Management to FortiManager. (You can

also use other methods to let FortiGate learn FortiManager IP and trigger FortiManager model device auto-link
function).
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6. ClickApply to apply the settings and clickOK to confirm the grant to FortiManager.

7. Go back to FortiManager to double-check the auto-link function status with the real FortiGate.

8. After the configuration is pushed to FortiGate, access FortiGate and verify that the FortiAP is enabled and
displayed in Managed FortiAPs page.
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9. Log on to FortiManager. Go to AP Manager > Managed APs. The AP is now displayed as online.
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Zero-touch provisioning for FortiSwitch

Model devices used for ZTP can also be linked to model FortiAPs, enabling provisioning of AP settings when first
connected.

Scenario 1: When FortiGate is provisioned as a Model Device and uses auto-link for zero-touch install

1. Create a model FortiGate device by using a real FortiGate serial number.

FortiManager 6.2.0 New Features Guide 83
Fortinet Technologies Inc.



Zero-touch provisioning for FortiSwitch

2. Configure a model device interface IP, which will be used as the management IP to FortiManager.

3. In the model device, choose the interface which will be used to connect FortiSwitch, enable FortiSwitch and specify
the IP address.

4. In FortiSwitch Manager, create a model FortiSwitch on the FortiGate by using a real FortiSwitch serial number.
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5. In FortiSwitchManager > FortiSwitch Template, create a FortiSwitch template, modify port settings and assign it
to the model FortiSwitch.
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6. Create a policy package for the model device, then do a policy copy and perform a Copy Only to the model
FortiGate.
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7. Connect the real FortiSwitch to the real FortiGate, and connect the FortiGate to the network that FortiManager can
reach.

8. Log on to FortiGate. Go to Security Fabric > Settings and configure central management to connect to
FortiManager. (You can also use other method to let FortiGate learn FortiManager IP and trigger FortiManager
model device auto-link function.)
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9. ClickApply to apply the settings and click OK to agree the grant to FortiManager.

10. Go back to FortiManager and double check model device auto link function status with the real FortiGate.

11. After the configuration is pushed to FortiGate, access FortiGate and verify that the FortiSwitch is enabled and
displayed in FortiGate.
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12. Go to FortiManager > FortiSwitchManager > Managed FortiSwitches. You can see the FortiGate status is up and
FortiSwitch is now online.

Scenario 2: FortiGate is already managed by FortiManager

1. Log on to FortiManager. Go to FortiSwitchManager > Managed Switchesand clickCreate New. Choose
FortiGate and FortiLink interface, enter the serial number, name, and clickOK.

2. Log on to FortiGate. Go toWiFi & Switch Controller > Managed FortiSwitch and verify that the model FortiSwitch
has been deployed.
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3. Go to FortiManager. Go to FortiSwitchManager > Managed Switches and verify that the model switch is also
displayed.
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4. Assign the FortiSwitch template to the model FortiSwitch and deploy the template configuration to FortiGate.

5. Connect the real FortiSwitch to the FortiGate by using FortiLink port and start the FortiSwitch. After FortiLink
negotiation, the FortiSwitch is connected with FortiGate and its status is online.
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6. Go back to FortiManager > FortiSwitchManager, right-click the managed FortiSwitch and clickRefresh. The
FortiSwitch status will displayed asOnline.
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This section lists the new features added to FortiManager for Multi-Cloud.

List of new features:

l Oracle Cloud - Paravirtualized Mode Support on page 94

Oracle Cloud - Paravirtualized Mode Support

FortiManager now supports Paravirtualized mode in Oracle Cloud.

Configuring Paravirtualized mode

1. Download FMG_VM64_OPC-v6-build0292-FORTINET.out.OpenXen.zip image from the Fortinet website.
2. Unzip the file and extract the fmg.qcow2 file. Rename the file to fmg292.qcow2.
3. Upload the fmg292.qcow2 file to Oracle Object Storage.
4. Copy the fmg292.qcow2 file link from the Oracle Object Storage web UI. For example, https://objectstorage.us-

ashburn-1.oraclecloud.com/n/fortinetoraclecloud1/b/fmgopc/o/fmg292.qcow2.

5. Create a paravirtualized mode FortiManager image:
a. Go toOracle Cloud > Compute > Custom Images > Import Image.
b. Select Paravirtualizedmode in LaunchMode section. Depending on the Oracle Cloud traffic, make sure the

image is available after approximately 30 minutes.
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6. Create an instance with the above image.

7. Attach paravirtualized mode FMG-VM disk.

8. Boot up the paravirtualized mode FMG-VM instance.
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This section lists the new features added to FortiManager for compliance.

List of new features:

l FortiGate change log traceability on page 96
l Extended admin session logging on page 98

FortiGate change log traceability

The FortiManager administrator name is now visible in the System Events on FortiGate thereby providing end-to-end
traceability.

FortiManager Administrator Traceability

1. Log on to FortiManager. For this example, we have used the administrator name Simon.
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2. Install a Policy Package on a FortiGate device using the Install Wizard.

3. Alternatively, schedule an installation.

4. After the installation is completed, logon to the FortiGate device. Go to Log & Report > System Events to see the
actions of the administrator Simon@FortiManager.
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Extended admin session logging

In previous releases, the checksum Linux epoch timestamp was not clear. In version 6.2, it has been converted into
human readable format for clarity. The ADOM pre-empt lock takeover event logs have also been made clear.

Event Log GUI

The following improvements have been made in the Event Log:

l Session ID added to each log entry:
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l Existing checksum Linux epoch timestamps converted into human readable format:

l ADOM pre-empt lock takeover event logs are more clear. For example, if user 1 locks an ADOM, and user 2 takes
over the ADOM, the event log shows username and session ID for workspace takeover log.
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This section lists the new features added to FortiManager for usability.

List of new features:

l Consolidated Firewall Mode on page 100
l IPv6 Address Template on page 104
l Policy and Route Lookup on page 107
l Policy Blocks on page 109
l Promote Objects (LOCAL > GLOBAL) on page 114
l Address Icon/Tile View on page 116
l Device Manager Map View on page 118
l Clone Reverse Policy on page 122
l Admin Preference - Policy Package Cookie on page 123
l Promote Objects (LOCAL > GLOBAL) on page 114
l Upgrade Path Enforcement for Managed FortiGates on page 125

Consolidated Firewall Mode

Consolidated Firewall Mode allows administrators to create consolidated IPv4 and IPv6 policies from a single interface.
This feature saves time in configuring two separate policies for IPv4 and IPv6.

See Create New Policy Packages.
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To create a Single Policy table for IPv4 and IPv6 policies:

1. Go to Policy andObjects > Policy Packages. Click Tools menu and select Display Options.

2. In the Display Options screen, select IPv4 Policy, IPv6 Policy, and Consolidated IPv4/IPv6 Policy. ClickOK to
save.
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3. IPv4 and IPv6 policies are shown separately.

4. Right-click the Policy Package and clickEdit.
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5. Switch Consolidated Firewall Mode toON. ClickOK.

6. IPv4 and IPv6 policies are now shown together in Consolidated IPv4/IPv6 Policy.
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7. Create a new policy. Both IPv4 and IPv6 are configurable in the same policy.

IPv6 Address Template

IPv6 Address Template allows administrators to create an IPv6 template with pre-defined parameters. The IPv6
Address Template can be reused while creating an IPv6 address. The IPv6 Address Template saves time since the
predefined parameters in the template do not need to be entered while creating each IPv6 address.

See IPv6 Address Template.
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Creating an IPv6 Template

1. Go to Policy & Objects > Object Configuration. ClickAddresses. ClickCreate New > IPv6 Address Template.

2. Define the IPv6 address template. If Exclusive set to Enable, at least 1 segment value must be defined.

3. Create an IPv6 address that uses the template. If Specific is selected, defined segment values are available for
selection from the drop-down list, which simplifies what the administrator has to enter and pick human readable
values. The administrator may also select Any without specifying a value.
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4. Set Host Type asAny for wildcard. or specify a host. A standard IPv6 address can be divided into three parts: [IPv6
network prefix] + [subnet segments] + [host address].
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5. After selecting the IPv6 address template, and configuring the other settings, clickOK.

Policy and Route Lookup

Policy Lookup allows administrators to search for policies on a FortiGate device (or VDOM) based on certain input
parameters. The input parameters simulate a packet received on FortiGate, and return the matching policy that would
be triggered for it. This feature helps administrators troubleshoot issues and test new policies that they are creating.

Route Lookup allows administrators to similarly test a routing decision by specifying similar types of input parameters.
Both policy routing and normal routing are consulted for the decision.

The policy and route lookup features are both invoked using the FortiGate API, as they require
the real-time state of the FortiGate.

Policy Lookup

1. Go to Policy & Objects > Policy Packages.
2. In the tree menu, select a policy package then a policy type, such as IPv4 Policy.
3. ClickPolicy Lookup in the toolbar.

The IPv4 Policy lookup from remote device dialog box opens.
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4. Fill in the required information, then clickOK.
The matching policy entry, learned from the remote FortiGate, will be highlighted in the policy list.

Route Lookup

1. Go to DeviceManager, and open a synchronized, managed device.
2. Go toQuery > Routing.
3. ClickRoute Lookup in the toolbar.

The Route Lookup dialog box opens.
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4. Select IPv4 or IPv6, enter the destination address, then clickOK.
A pop-up will show the show the route information from the FortiGate, and the route will be highlighted in the
routing table.

Policy Blocks

Policy Blocks are created to store multiple policies. Policy Blocks can be appended to a Policy Package. When creating a
Policy Package, the administrator does not need to add one policy at a time. By appending a Policy Block to a Policy
Package, the administrator can ensure that all policies in the Policy Block are added to the policy package together.

See Creating Policy Blocks.
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To create Policy Blocks:

1. Go to Policy Packages and select Policy Blocks.

2. Expand the Policy Packagemenu and clickNew.
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3. Specify a name and configure other settings. ClickOK to save.

4. Create a few policies in the new Policy Block. Policy ID in policy block is in a special defined range, similar to the
Global header and footer policies.
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5. Select a policy and click Policy Block > Insert Policy Block Below.

6. Select the Policy Block to insert. ClickOK.
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7. The Policy Block is inserted into the package.

Important information about Policy Blocks

l A Policy Block can be added or removed from a Policy Package.  But an individual policy in a Policy Block cannot be
added, edited or deleted in a policy package. When a policy is selected, relevant menu items are grayed out.
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l The policy block is for FortiManager only.  It is not installed to FortiGate. FortiGate shows individual policies only.

l When importing a FortiGate to a policy package, Policy Blocks are not imported. In this example, only two policies
are imported to FortiManager.

Promote Objects (LOCAL > GLOBAL)

Administrators can promote an object from an ADOM to Global Database. This can be an object imported from a
FortiGate device or created on FortiManager. Once the object is promoted to the Global Database, it can be reused by
other ADOMs and need not be re-created.

See Promoting Objects to Global Database.
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To promote objects from ADOM to Global Database:

1. Go to Policy andObjects > Object Configurations.
2. Right-click an object and clickPromote to Global.

3. Specify a new name in the Rename object(s) dialog. If you do not specify a new name, the object will be promoted
with the same name which may create a conflict if the Global database already contains an object with the same
name.

4. ClickPromote. The object is now promoted to the Global Database.

5. Switch the ADOM toGlobal Database to verify the promoted object.
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Address Icon/Tile View

View the objects as Icons or in a table format. This provides a better visual presentation of objects in a user-defined
format.

See Search Objects.

Improvements in Icon or Table view

l Switch between views - select View > Icon View or View > Table View to switch between views.

l Sort by Menu - sort by Name, Type, Create Time, and Last Modified Time

l Select multiple objects - select multiple objects to Promote to Global, Clone orDelete the objects.

FortiManager 6.2.0 New Features Guide 116
Fortinet Technologies Inc.

https://docs2.fortinet.com/document/fortimanager/6.2.0/administration-guide/773382


Usability

l Tool-tip - mouse-over the object for more information about the object.

l Drag and drop - drag and drop single or multiple objects into the policy in dual pane display mode.
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Device Manager Map View

Automatically view the location of FortiGate devices on Google Maps. Manually configure the location of the FortiGate
from FortiManager. Perform various actions directly from the Map View.

Map View feature

1. Go to Device Manager and select Map View from the menu options.

2. Map view shows device location on Google Maps and a combined status in Green, Orange, and Red colors.
l Green - Shows devices are healthy. The policy package configuration and device configuration are in sync.
l Orange - Shows a warning status. The device configuration status or policy package configuration status isOut

of Sync. Or, there is no policy imported or no policy package installed.
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l Red - Shows an error status. Copy has failed, installation has failed or device connection is down.

3. Select Show Problematic Devices Only to filter devices on the map and show it on the right pane withOrange or
Red status.
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4. To manually position a device, click the device shown on the smaller map on the right pane.

5. Enter the location of the device manually. You can also drag the device to the accurate position.
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6. ClickShow Unpositioned Devices to filter devices that do not have any location.

7. ClickView Details for the device to show device configuration status and policy package status.

8. Right-click the device menu to run various operations such as Quick Install, Install Wizard, Import Policy, Re-install
Policy, Policy Package Diff, Edit, Refresh Device, Add VDOM, and Run Script.
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Clone Reverse Policy

Administrators can now clone a policy in such a way that the Incoming Interface andOutgoing Interface are switched in
the newly cloned policy. The Source Address and Destination Address are also switched in the newly cloned policy.

For example, if a policy is configured with the Incoming Interface as port1 and theOutgoing Interface as port2, cloning
the policy with Clone Reverse automatically sets the Incoming Interface as port2 andOutgoing Interface as port1.

If a policy is configured with the Source Address as update.microsoft.com and the Destination Address as all, cloning
the policy with Clone Reverse automatically sets the Source Address as all and Destination Address as
update.microsoft.com.

The original policy remains unchanged.
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To Clone Reverse a Policy:

1. Select a policy and select Clone Reverse from the Edit menu.

2. The policy is cloned with the Incoming Interface andOutgoing Interface switched with each other. The Source and
Destination are also switched with each other.

Admin Preference - Policy Package Cookie

In previous releases, when an administrator opened a Policy Package and logged out, the default view was shown on
the Policy Packages page on logging in. The administrator had to navigate to the same Policy Package again upon
logging in. When an administrator opened an Object and logged out, the default view was shown on theObject
Configurations page upon logging in. The administrator had to navigate to the Object again upon logging in.

In this release, the Policy Package and Object opened by the administrator is remembered by FortiManager.
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Last opened Policy Package

The last opened Policy Package is shown upon logging in.

Last opened Object

The last opened Object is shown upon logging in.
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Upgrade Path Enforcement for Managed FortiGates

In earlier versions of FortiManager, when upgrading FortiGate devices to a higher version than FortiManager, there was
no check and the upgrade process would be completed. Managing higher version FortiOS devices with lower version of
FortiManager caused issues.

This release includes multiple usability improvements to guide the administrator towards a successful upgrade.

Warning when upgrading to a higher version of FortiOS than FortiManager

When trying to upgrade FortiOS devices to a version higher than FortiManager, the upgrade process is blocked and the
following warning is shown to the administrator:

Upgrading Multiple FortiGate devices with the Recommended Upgrade Path

This version improves the upgrade process by providing useful warnings and options to take a recommended upgrade
path:

l Go to DeviceManager > Firmware, select multiple FortiGate devices and clickUpgrade. The versions available in
the upgrade path are shown by a green check mark.

l When upgrading, the administrator is presented with an option to upgrade as per the recommended upgrade path
or continue with the selected version.
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l If the administrator selects a customized image, a warning is shown with an option to upgrade as per the
recommended upgrade path or to continue with the selected customized image.

Upgrading FortiGate Devices Individually with the Recommended Upgrade Path

l Go to DeviceManager > [Device Name] > System Informationwidget. Click the Firmware Version update icon.
The recommended upgrade is shown with a green check mark.
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l Selecting a firmware that is not on the upgrade path shows a warning with an option to upgrade as per the
recommended upgrade path.
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l Upgrading to a customized firmware image shows a warning asking the administrator to confirm the action.

Spanish UI

The FortiAnalyzer and FortiManager user interface now supports Spanish in addition to the previously supported
English, Simplified Chinese, Traditional Chinese, Korean, and Japanese.

Set user interface language preferences

To set the UI language to Spanish:

1. Go to System Settings > Admin > Admin Settings.
2. In View Settings, select Spanish in the Language drop-down.
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3. Select Apply.

To set the UI language to Spanish in the CLI:

FAZ300F # config system admin setting
(setting)# set webadmin_language ?
auto_detect Automatically detect language.
english English.
japanese Japanese.
korean Korean.
simplified_chinese Simplified Chinese.
spanish Spanish.
traditional_chinese Traditional Chinese.

(setting)# set webadmin_language spanish

Spanish user interface examples

l System Settings
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l FortiView

l Reports
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This section lists other new features added to FortiManager.

List of new features:

l Delete Empty ADOMs on page 131
l Telnet Removed on page 134
l 6000/7000-series UI Updates on page 134
l Improve RADIUS Setup on page 138
l Support for FortiOS VM Directly Connecting to FortiGuard on page 141
l Swagger support for FNDN API Tool on page 142
l License for FortiGates with FortiManager Cloud Entitlement on page 143

Delete Empty ADOMs

Empty ADOMs can now be deleted without un-assigning the Policy Packages assigned to the ADOM. Empty ADOMs
can also be deleted without having to remove them from administrator's accounts. Once FortiGate devices are removed
and the ADOM is empty, the ADOM can be deleted immediately.

See Deleting ADOMs.

Deleting ADOMs in earlier versions

Deleting an ADOM after removing FortiGate devices resulted in a message Unable to delete because the adom is in
global assignment list or is referenced by a defined admin account. The ADOM may still be referenced by
administrator accounts or global policy packages, and the references may be not easy to be find and remove. The
following message was shown in earlier versions:

FortiManager 6.2.0 New Features Guide 131
Fortinet Technologies Inc.

https://docs2.fortinet.com/document/fortimanager/6.2.0/administration-guide/379799


Other

Improvement in deleting ADOMs

The process of deleting ADOMs has been improved in this release. The administrator must remove all FortiGate
devices from the ADOM. While deleting the ADOM, the references to administrator accounts and global policy
packages will be shown and you can delete the ADOM without removing the listed references. The references to
administrator accounts and global policy packages will be removed when deleting the ADOM.

To delete ADOMs:

1. Create a test-ADOM and reference it in the user test-admin.
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2. Use the ADOM in Global Database assignment.

3. Delete the ADOM. The following message is shown.

FortiManager 6.2.0 New Features Guide 133
Fortinet Technologies Inc.



Other

4. ClickDelete Anyway to automatically remove the reference and delete the ADOM.

Telnet Removed

Telnet has been removed as a communication method in FortiManager for administrative access. Removing Telnet
enhances the security since Telnet is not secure.

See Changing Administrative Access.

6000/7000-series UI Updates

FortiGate 6000 and 7000 series running FortiOS 5.6 and earlier do not support Security Fabric features with external
devices. Earlier versions of FortiManager showed FortiGate 6000 and 7000 series running ForitOS 5.6 and earlier as
Security Fabric devices which caused confusion. In FortiManager 6.2, these devices are correctly shown as non-Security
Fabric FortiGate devices.
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Displaying FortiGate 6000 and 7000 FortiManager

l FortiGate 6000 running FortiOS 5.6.7
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l FortiGate 7000 running FortiOS 5.6.7
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l Earlier versions of FortiManager showed the Security Fabric tag in the Device Name column.

l FortiManager 6.2 correctly shows FortiGate 6000 and FortiGate 7000 running FortiOS 5.6 or earlier as regular
FortiGate devices.
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Improve RADIUS Setup

The FortiManager RADIUS setup now includes the Test Connectivity and Test User Credentials options. The
Administrators > AdvancedOptions now include Admin Profile Override and other minor usability improvements.
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List of Improvements

l RADIUSConfiguration now includes Test Connectivity and Test User Credentials buttons.

l Test User Credentials shows success or failure.
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l Eye icon added to show or hide the Server Secret.

l Wildcard option changed toMatch all users on remote server in GUI.
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l Go to System Settings > Administrators > AdvancedOptions to add admin profile override configuration.

l Wildcard and override feature can also be configured via CLI.
config system admin user

edit "Radius"
set adom "all_adoms"
set policy-package "all_policy_packages"
set user_type radius
set radius_server "test-Radius"
set wildcard enable
set ext-auth-accprofile-override enable
set ext-auth-adom-override enable

next
end

Support for FortiOS VM Directly Connecting to FortiGuard

In previous releases, FortiOS-VM (FortiMeter) instances needed to get services from FortiManager that facilitated
updates by tracking service entitlements based on serial numbers starting with FOSVM1. However, if the FortiOS-VM
connected directly to Fortinet Distribution Network (FDN), updates were not available since FDN was not aware of serial
numbers with prefix FOSVM1.

In the current release, the serial number prefix FOSVM2 was added to FortiOS-VM. When the FortiOS-VM connected
directly to FDN, it is now able to receive the updates.

The same serial number will have two different prefixes depending on the situation:

l FortiOS-VM sends the serial numbers with prefix FOSVM2 to FortiManager or FortiGuard for updates and rating
service. FOSVM2 is not visible on the FortiManager GUI.

l FortiOS-VM sends the serial numbers with prefix FOSVM1 to FortiManager for management. FOSVM1 is shown
on the FortiManager GUI.
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FortiGate Serial Numbers shown in FortiManager

l FortiOS-VM in FortiManagerUnauthorized Devices list with the serial number prefix FOSVM1

l Authorized FortiOS-VM in FortiManager

l Authorize FortiGuard service to FortiOS-VM. FortiManager checks service license with serial number prefix
FOSVM1 while providing service to FOSVM2.

Swagger support for FNDN API Tool

A new Swagger API viewer is added to FNDN, with try it out feature enabling dev-ops developers to quickly review, test
and monitor changes to REST API across versions.

To use the FNDN API tool:

1. Log on to fndn.fortinet.net.
2. Click the FortiAPI tab.
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3. Click FortiManager.

4. To get the detailed JSON API information, click any URL. For example, click the task URL.

License for FortiGates with FortiManager Cloud Entitlement

When a FortiGate contains the FortiManager Cloud license entitlement (from 360 Protection Bundle or a la carte SKU
purchase), it will not count towards the license of FortiManager.
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To view the license count via GUI:

1. Add a FortiGate with 10 VDOMs to FortiManager.

The Device Manager shows the count as 10. However, the total license count is not increased.

To check the license count via CLI:

1. Run the command diagnose fmupdate dbcontract fds FGVM04TM19000191
The following output is shown:

FGVM04TM19000191 [SERIAL_NO]
AccountID: fmgclouduser001@mail.com
Industry: Technology
Company: fortinet
Contract: 13
AVDB-1-06-20200125
AVEN-1-06-20200125
ENHN-1-10-20200125
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FGSA-1-06-20200125
FMGC-1-06-20200204
FMWR-1-06-20200125
FRVS-1-06-20200125
FURL-1-06-20200125
ISSS-1-06-20200125
NIDS-1-06-20200125
SPAM-1-06-20200125
SPRT-1-10-20200125
ZHVO-1-06-20200125
Contract Raw Data:

Contract=AVDB-1-06-20200125:0:1:1:0*AVEN-1-06-20200125:0:1:1:0*ENHN-1-10-
20200125:0:1:1:0*FGSA-1-06-20200125:0:1:1:0*FMGC-1-06-20200204:0:1:1:0*FMWR-1-06-
20200125:0:1:1:0*FRVS-1-06-20200125:0:1:1:0*FURL-1-06-20200125:0:1:1:0*ISSS-1-06-
20200125:0:1:1:0*NIDS-1-06-20200125:0:1:1:0*SPAM-1-06-20200125:0:1:1:0*SPRT-1-10-
20200125:0:1:1:0*ZHVO-1-06-
20200125:0:1:1:0|AccountID=fmgclouduser001@mail.com|Industry=Technology|Company=fortinet|Us
erID=876051
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