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Change Log

Date Change Description

2017-06-22 Initial release.
2017-07-06 Added a note about port3 WAN egress to Device > FortiGate Device.
2017-07-07 Added a note about backup configuration from HC in Dashboard > Dashboard

Setting > Backup or Restore the System Configuration.

2017-07-19 AddedMD5 of vdi file in lowercaseandmproduct.list com-
mands to Appendix D.



Introduction

Fighting today’s Advanced Persistent Threats (APTs) requires a multi-layer approach. FortiSandbox
offers the ultimate combination of proactive mitigation, advanced threat visibility, and comprehensive
reporting. More than just a sandbox, FortiSandbox deploys Fortinet’s award-winning, dynamic antivirus
and threat scanning technology, dual level sandboxing, and optional integrated FortiGuard cloud
queries to beat Advanced Evasion Techniques (AETs) and deliver state-of-the-art threat protection.

Fortinet’s dynamic scanning is based on our custom Compact Pattern Recognition Language (CPRL)
and ASIC hardware acceleration. The result is fast, powerful detection, unique to Fortinet, that uses a
single signature to identify tens of thousands of variations of viral code. FortiSandbox utilizes advanced
detection, dynamic antivirus scanning, and threat scanning technology to detect viruses and APTs. It
leverages the FortiGuard web filtering database to inspect and flag malicious URL requests, and is able
to identify threats that standalone antivirus solutions may not detect.

FortiSandbox works with your existing devices, like FortiGate, FortiWeb, FortiClient and FortiMail, to
identify malicious and suspicious files and network traffic. It has a complete extreme antivirus database
that will catch viruses that may have been missed.

FortiSandbox can be configured to sniff traffic from the network, scan files on a network share with a
pre-defined schedule, quarantine malicious files, and receive files from FortiGate, FortiWeb, FortiMail,
and FortiClient. For example, FortiMail 5.2.0 and later allows you to forward email attachments to
FortiSandbox for advanced inspection and analysis. Files can also be uploaded directly to it for
sandboxing through the web GUI or JSON API. You can also submit a website URL to scan to help you
identify web pages hosting malicious content before users attempt to open the pages on their host
machines.

FortiSandbox executes suspicious files in the VM host module to determine if the file is High, Medium,
or Low Risk based on the behavior observed in the VM sandbox module. The rating engine scores each
file from its behavior log (tracer log) that is gathered in the VM module and, if the score falls within a
certain range, arisk level is determined.

The following table lists infection types and attacks that are identified by FortiSandbox.

Infection Type Description

Infector Infector malware is used to steal system and user information. The stolen
information is then uploaded to command and control servers. Once the
infector installs on a computer, it attempts to infect other executable files with
malicious code.

Worm Worm malware replicates itself in order to spread to other computers. This type
of malware does not need to attach itself to an existing program. Worms, like
viruses, can damage data or software.

Botnet Botnet malware is used to distribute malicious software. A botnet is a collection
of Internet-connected programs communicating with other similar programs in
order to perform a task. Computers that are infected by botnet malware can be
controlled remotely. This type of malware is designed for financial gain or to
launch attacks on websites or networks.

Hijack Hijack malware attempts to hijack the system by modifying important registry
keys or system files.



Infection Type Description

Stealer Stealer malware is used to harvest login credentials of standalone systems, net-
works, FTP, email, game servers and other websites. Once the system is infec-
ted, the malware can be customized by the attacker.

Backdoor Backdoor malware installs a network service for remote access to your network.
This type of malware can be used to access your network and install additional
malware, including stealer and downloader malware.

Injector Injector malware injects malicious code into system processes to perform tasks
on its behalf.
Rootkit Rootkit malware attempts to hide its components by replacing vital system

executables. Rootkits allow malware to bypass antivirus detection as they
appear to be necessary system files.

Adware Adware malware is a software package which attempts to access advertising
websites. Adware displays these unwanted advertisements to the user.

Dropper Dropper malware is designed to install malicious software to the target system.
The malware code may be contained within the dropper or downloaded to the
target system once activated.

Downloader Downloader malware attempts to download other malicious programs.

Trojan Trojan malware is a hacking program which gains privileged access to the oper-
ating system to drop a malicious payload, including backdoor malware. Trojans
can be used to cause data damage, system damage, data theft or other mali-
cious purposes.

Riskware Riskware malware has security critical functions which pose a threat to the com-
puter.
Grayware Grayware malware is a classification for applications that behave in a manner

that is annoying or undesirable. Grayware includes spyware, adware, dialers,
and remote access tools that are designed to harm the performance of com-
puters on your network.

Unknown No definitions currently exist for this type of attack.

FortiSandbox scans executable (Windows . exe and . d11 script files), JavaScript, Microsoft Office,
Adobe Flash, PDF, archives, and other file types the user defines. JavaScript and PDF are the two
common software types that malware uses to execute malicious code. For example, JavaScript is often
used to create heap sprays and inject malicious code to execute in other software products such as
Adobe Reader (PDF).

When a malware is scanned inside a FortiSandbox VM environment,FortiSandbox scans its outgoing
traffic for connections to botnet servers and determines the nature of the traffic and connection hosts.

Key features of FortiSandbox include:

« Dynamic Antimalware updates/Cloud query: Receives updates from FortiGuard Labs and send queries to
the FortiSandbox Community Cloud in real time, helping to intelligently and immediately detect existing
and emerging threats.



« Code emulation: Performs lightweight sandbox inspection in real time for best performance, including
certain malware that uses sandbox evasion techniques and/or only executes with specific software
versions.

« Full virtual environment: Provides a contained runtime environment to analyze high risk or suspicious
code and explore the full threat life cycle.

« Advanced visibility: Delivers comprehensive views into a wide range of network, system and file activity,
categorized by risk, to help speed incident response.

« Network Alert: Inspects network traffic for requests to visit malicious sites, establish communications with
C&C servers and other activity indicative of a compromise. It provides a complete picture of the victim
host's infection cycle.

« Manual analysis: Allows security administrators to manually upload malware samples via the
FortiSandbox web GUI or JSON API to perform virtual sandboxing without the need for a separate
appliance.

« Optional submission to FortiSandbox Community Cloud: Tracer reports, malicious files and other
information may be submitted to FortiSandbox Community Cloud in order to receive remediation
recommendations and updated in line protections.

« Schedule scan of network shares: Perform a schedule scan of network shares in Network File System
(NFS) v2 to v4 and Common Internet File System (CIFS) formats to quarantine suspicious files.

« Scan job archive: You can archive scan jobs to a network share for backup and further analysis.

« Website URL scan: Scan websites to a certain depth for a predefined time period.

« Cluster supporting High Availability: Provide a non-interruption, high performance system for malware
detection.

What's new in FortiSandbox 2.4.1

To view a detailed list of the new features and enhancements in FortiSandbox 2.4.1, please see the
FortiSandbox 2.4.1 Release Notes available at the Fortinet Document Library.

About this document

This document describes how to configure and manage your FortiSandbox system and the connected
FortiGate/FortiMail devices.

FortiSandbox system documentation assumes that you have one or more Fortinet products such as
FortiGate/FortiMail units, the Fortinet system documentation, and you are familiar with configuring
your Fortinet devices units before using the FortiSandbox system.

To configure your FortiGate device to submit files to FortiSandbox, your
Mo FortiGate must be running FortiOS or FortiOS Carrier version 5.0.4 and later or
@ 5.2.0 and later.
= For more information, see The FortiOS Handbook in the Fortinet Document
Library.
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To configure your FortiMail email gateway to identify suspicious or high risk
NP files in email and submit them to FortiSandbox, your FortiMail must be running
~9, FortiMail version 5.2.0 and later.
= For more information, see the FortiMail 5.2 Administration Guide in the
Fortinet Document Library.

To configure your FortiClient to send files to the FortiSandbox and receive res-
~9« ults, your FortiClient must be running FortiClient 5.4.0 and later.
= For more information, see the FortiClient 5.4.0 Administration Guide in the
Fortinet Document Library.

To configure your FortiWeb to submit files for FortiSandbox to evaluate, your
~9r Fortiweb must be running 5.4.0 and later
= For more information, see the FortiWeb 5.4.0 Administration Guide in the
Fortinet Document Library.

Connecting to the Command Line Interface

The FortiSandbox CLI commands are intended to be used for initial device configuration and
troubleshooting. The FortiSandbox device is primarily configured using the GUI. You can enable SSH
and Telnet access on the port1 (administration) interface and access the CLI through SSH or Telnet to
troubleshoot the device including RAID related hard disk issues. You can also connect to the CLI
through the console port.

To connect to the CLI through the console port:

1. Connect the FortiSandbox unit console port to the management computer using the provided console
cable.

2. Start a terminal emulation program on the management computer.
3. Use the following settings:

Serial line to connect to COM1

Speed (baud) 9600
Data bits 8
Stop bits 1
Parity None
Flow Control None

4. Press Open to connect to the FortiSandbox CLI. The 1ogin as page is displayed.
5. Type a valid administrator name and press Enter.
6. Type the password for this administrator and press Enter.


http://docs.fortinet.com/fortimail/admin-guides
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For example, to configure the IP address and gateway of the FortiSandbox device, use the
following commands:

set portl-ip 192.168.0.10/24

set default-gw 192.168.0.1

For more information on FortiSandbox CLI commands, see the FortiSandbox CLI Reference
Guide available in the Fortinet Document Library.


http://docs.fortinet.com/fortisandbox/reference

Using the GUI

This section describes general information about using the GUI to access the FortiSandbox system
from within a web browser. This section also explains common GUI tasks that an administrator does on
aregular basis.

GUI overview

The GUI is a user-friendly interface for configuring settings and managing the FortiSandbox unit. The
GUI can be accessed from a web browser on any management computer.

Connecting to the GUI

The FortiSandbox unit is configured and managed using the GUI. This section will step you through
connecting to the unit via the GUI.

\{‘ To quickly locate a menu item, you can enter the term in the Search bar loc-
4 ated at the top of the left side panel.

R Information messages for certain pages will be displayed in the Message Bar
? located at the top of the right side panel. Messages will disappear after a few
- seconds.

To connect to the FortiSandbox GUI:

1. Connect the port1 (administration) interface of the device to a management computer using the
provided Ethernet cable.
2. Configure the management computer to be on the same subnet as the internal interface of the
FortiSandbox unit:
a. Browse to Network and Sharing Center > Change adapter settings > Local Area Connection
Properties > Internet Protocol Version 4 (TCP/IPv4) Properties. These directions may vary
based on the version of your operating system.

b. Change the IP address of the management computerto 192.168. 0.2 and the network mask
t0255.255.255.0.

3. Start a supported web browser and browsetohttps://192.168.0.99.
4. Type admin in the Name field, leave the Password field blank, and select Login.
You can now proceed with configuring your FortiSandbox unit.

If the network interfaces have been configured differently during installation,
the URL and/or permitted administrative access protocols may no longer be in
their default state.




Default port information

FortiSandbox treats Port1 as reserved for device management, and Port3 be reserved for the Windows
VM to communicate with the outside network. The other ports are used for file input and
communication among cluster nodes. In Cluster mode, FortiSandbox uses TCP ports 2015 and 2018
for cluster internal communication. If the unit works as a Collector to receive threat information from
other units, it uses TCP port 2443

The following tables list the default open ports for each FortiSandbox interface.

FortiSandbox 3500D and 3000E default ports
Port (Interface) Type Default Open Ports

Port1 RJ-45 22 (SSH), 23 (Telnet), 80 and 443 (GUI), 514 (OF TP communication
with FortiGate, FortiWeb, FortiClient & FortiMail), SNMP local query
port.

FortiGuard Distribution Servers (FDS) use 8890 for download. The
FortiSandbox will use a random port picked by the kernel.

FortiGuard Web Filtering servers use UDP port 53 or 8888. The
FortiSandbox will use a random port picked up by the kernel.

Fortinet FortiSandbox VM download uses TCP port 443 for down-
load. The FortiSandbox will use a random port picked by the kernel.

The Sandbox Community Cloud uses UDP port 53 or 8888 and TCP
port 443. The FortiSandbox will use a random port picked up by the
kernel.

If you configure an internal mail server, internal DNS server, remote
syslog server, LDAP server, SNMP managers, NTP server, or over-
ride the web filtering server IP address, communication is recom-
mended to be through this interface. Ensure that the applicable
routing is configured.

Port2, Port4 RJ-45 No service listens except OFTP.

Port3 RJ-45 No service listens. Reserved for guest VM to communicate with the
outside network.

Port5, Port6 SFP+ No service listens except OFTP.



FortiSandbox 3000D default ports
Port (Interface) Type Default Open Ports

Port1 RJ-45 22 (SSH), 23 (Telnet), 80 and 443 (GUI), 514 (OF TP communication
with FortiGate, FortiWeb, FortiClient & FortiMail). SNMP local query
port.

FortiGuard Distribution Servers (FDS) use 8890 for download. The
FortiSandbox will use a random port picked by the kernel.

FortiGuard Web Filtering servers use UDP port 53 or 8888. The
FortiSandbox will use a random port picked up by the kernel.

The Sandbox Community Cloud uses UDP port 53 or 8888 and TCP
port 443. The FortiSandbox will use a random port picked up by the
kernel.

If you configure an internal mail server, internal DNS server, remote
syslog server, LDAP server, SNMP managers, NTP server, or over-
ride the web filtering server IP address, communication is recom-
mended to be through this interface. Ensure that the applicable
routing is configured.

Port2, Port4 RJ-45 All ports are open.

Port3 RJ-45 All ports are open. Reserved for guest VM to communicate with the
outside network.

Port5, Port6 SFP All ports are open.

Port7, Port8 SFP+ All ports are open.



FortiSandbox 1000D default ports
Port (Interface) Type Default Open Ports

Port1 RJ-45 22 (SSH), 23 (Telnet), 80 and 443 (GUI), 514 (OF TP communication
with FortiGate, FortiWeb, FortiClient & FortiMail).

FortiGuard Distribution Servers (FDS) use 8890 for download. The
FortiSandbox will use a random port picked by the kernel.

FortiGuard Web Filtering servers use UDP port 53 or 8888. The
FortiSandbox will use a random port picked up by the kernel.

The Sandbox Community Cloud uses UDP port 53 or 8888 and TCP
port 443. The FortiSandbox will use a random port picked up by the
kernel.

If you configure an internal mail server, internal DNS server, remote
syslog server, LDAP server, SNMP managers, NTP server, or over-
ride the web filtering server IP address, communication is recom-
mended to be through this interface. Ensure that the applicable
routing is configured.

Port2, Port4, RJ-45 All ports are open.
Port5, Port6
Port3 RJ-45 All ports are open. Reserved for guest VM to communicate with the

outside network.

Port7, Port 8 SFP All ports are open.
\‘ ! 'l
9 All ports mentioned above are the same for both IPv4 and IPv6 protocols..
~‘9"' You can dynamically change system firewall rules using the iptables CLI

command. New rules will be lost after a system reboot.

For more information on FortiSandbox 1000D, FortiSandbox 3000D, FortiSandbox 3500D, and
FortiSandbox 3000E interfaces, see Network on page 47.



Dashboard

The System Status dashboard displays widgets that provide information and enable you to configure
basic system settings. All of the widgets appear on a single dashboard, which can be customized as
desired.

=+ Add widget "D Reset View

= System Information &S o % = Scanning Statistics - Last 24 Hours &S o
Unit Type Standalone Rating Sniffer Devicels) B0 . 4 Metwork Adapter URL Al
Host Name snmp-host-update-20141125180432 [Change et 2365 0 0 o 0 0 2,365
Serial Number FSA3KD3R130 Suspicious - High Risk
System Time Mon Jul 18 12:27:43 2016 PDT [Change] Suspicious - Medium Risk 7 7
Firmware Version v2.30,build0175 (Interim) [Updat Suspicious - Low Risk 45 0 0 a 0 o 45
System Configuration Last Backup: 2016-05-17 13:42 Clean 28031 501 0 o 0 0 28,632
System Utilities Version 02003.00185 [Update; Other ) o o 0
Current Administrator admin 30455 80 [ 0 (2] [ 31,056
Uptime ) 19 hour(s) 55 minute(s) 287 a o o 0 0 267
Windows VM ] 35 o o o o [ a5
Microsoft Office ] Tota 30777 601 a a 0 o 31378
VM Internet Access ]
FDN Download Server ]
Cloud Server L] ast Updated: Mon. ) 1ot
Web Filtering Server ]

== Pending File Job Statistics S <

Antivirus DB Contract

Web Filtering Contract
Mabile Security © Trial
— System Resources F o %
PU Usage: m
ﬁ Memory Usage S d L
] e . . .
~‘9’* If the unit is the master node in a cluster, the displayed data will be a summary
= of all nodes in the cluster, otherwise only the individual unit's data is displayed.

The following widgets are available:

System Information Displays basic information about the FortiSandbox system, such as
the serial number, system up time, and license status information.

System Resources Displays the real-time usage status of the CPU and memory.
Hover the cursor over the memory dial to view the total system
memory.

Scanning Statistics Displays a table providing information about the files scanned over a

selected time span. This includes Sniffer, Device(s), On Demand,
Network, Adapter, and URL.

Scanning Activity Displays the number of clean, suspicious, and malicious events that
have occurred at specific times over a selected time period. Hover
the cursor over a colored portion of a bar in the graph to view the
exact number of events of the selected type that occurred at that
time.

Sniffer Traffic Through- Displays sniffed traffic throughput across time.
put



Top Devices Displays the total scanning jobs for the top five devices over a selec-
ted time interval.
Hover the cursor over a bar in the graph to view the exact number of
scanning jobs for that device.

Top Critical Logs Displays recent critical logs, including the time they occurred and a
brief description.

Pending Job Statistics Displays pending scan job numbers for a period of time. This widget
allows you to monitor the workload trend on your FortiSandbox.

Disk Monitor Displays the RAID level and status, disk usage, and disk man-
agement information. This widget is only available in hardware based
models.

Customizing the dashboard

The FortiSandbox system dashboard can be customized. You can select which widgets to display,
where they are located on the page, and whether they are minimized or maximized.

To move a widget

Position your mouse cursor on the widget’s title bar, then click and drag the widget to its new location.

To refresh a widget

Select the refresh icon in the widget'’s title bar to refresh the data presented in the widget.

To add a widget

In the dashboard toolbar, select Add Widget, then select the names of widgets that you want to add.
To hide a widget, in its title bar, select the close icon.

The following is a list of widgets you can add to your dashboard.

« System Information

« System Resources

« Scanning Statistics

« Scanning Activity

« Top Devices

« Top Critical Logs

« Pending Job Statistics

« Disk Monitor

« Sniffer Traffic Throughput

Ay

~9' Multiple widgets of the same type can be added to the dashboard. This can be
= useful for viewing information over different time intervals.

To edit a widget

Select the edit icon in the widget'’s title bar to open the edit widget window.



Configure the following information, and then select OK to apply your changes:

Custom widget title

Refresh interval

Top Count

Time Period

Expand the right panel to
full screen

System Information

Optionally, type a custom title for the widget. Leave this field blank to
use the default widget title.

Enter a refresh interval for the widget, in seconds.
Some widget have default refresh values:
« Scanning Statistics: 600

« Top Devices: 300

« Scanning Activity: 300

« System Resources: 60
o Top Critical Logs: 3600
« Disk Monitor: 300

Select the number of entries to display in the widget. The top count
can be between 5 to 20 entries.

This option is only available in the following widgets: Top Devices,
Top Critical Logs.

Select a time period to be displayed from the drop-down list. The
options are: Last 24 hours, Last 7 days, Last 2 weeks.

This option is only available on the following widgets: Scanning Stat-
istics, Top Devices, Disk Monitor, and Scanning Activity.

Click the Full Screen button located in the upper right corner to
toggle and only view the right side content.

TheSystem Information widget displays various information about the FortiSandbox unit and enables
you to configure basic system settings.

This widget displays the following information and options:

Unit Type

Host Name

Serial Number

System Time

The HA cluster status of the device: Standalone, Master, Primary
Slave, or Regular Slave. Select [Change] to change the cluster
status of the device.

The name assigned to this FortiSandbox unit. Select [Change] to
edit the FortiSandbox host name.

The serial number of this FortiSandbox unit. The serial number is
unique to the FortiSandbox unit and does not change with firmware
upgrades. The serial number is used for identification when con-
necting to the FortiGuard server.

The current time on the FortiSandbox internal clock or NTP server.
Select [Change] to configure the system time.



Firmware Version

System Configuration

System Utilities Version

Current Administrator

Uptime

Windows VM

Microsoft Office

The version and build number of the firmware installed on the
FortiSandbox unit.

To update the firmware, you must download the latest version from
the Fortinet Customer Service & Support portal. Select [Update]
and select the firmware image to load from the local hard disk or net-
work volume.

The date and time of the last system configuration backup. Select
Backup/Restore to browse to the System Recovery page.

The current sandbox engine version. Select [Update] to go to the
FortiGuard Modules page, where you can upload package files. In
this page, you can also override the FortiGuard server address.

The administrator that is currently logged on to the system.

The duration of time that the FortiSandbox unit has been running
since it boot up.

Microsoft Windows VM license activation and initialization status.
Displays an up icon if the Microsoft Windows VM is activated and ini-
tialized. Displays a Caution icon if the Microsoft Windows VM is ini-
tializing or having issues. Hover the mouse pointer on the status icon
to view detailed information.

In addition to the pre-installed default set of Windows VM images,
the user can also purchase, download, and install extra Android, Win-
dows 8.1 and Windows 10 image packages. The user should down-
load their license file from the Fortinet Customer Service & Support
portal. Then, click the [Upload License] link next to the Windows

VM field. Browse to the license file on the management computer
and click the Submit button. The system will reboot and activate the
newly installed Windows 8.1/10 guest VMs.

Microsoft Office product activation status. Select to upload a
Microsoft Office license file.

Displays an up icon if the Microsoft Office is activated and initialized.
Displays a Caution icon if the Microsoft Office is initializing or having
issues. Hover the mouse pointer on the status icon to view detailed
information. A warning is displayed when the license file is not avail-
able or has not been uploaded to FortiSandbox.
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VM Internet Access

FDN Download Server

Cloud Server

Web Filtering Server

Antivirus DB Contract

Web Filtering Contract

Mobile Security

Displays the status of the FortiSandbox VM accessing the outside net-
work.

Displays an up icon if the VM can access the outside network. Dis-
plays a caution icon if the VM cannot access the outside network.
Hover the mouse pointer on the status icon to view detailed inform-
ation. If the VM cannot access the outside network, a simulated net-
work (SIMNET) will start by default. SIMNET provides responses of
popular network services, like ht tp where certain malware is expec-
ted. If the VM internet access is down, beside the down icon,
SIMNET status is displayed. Clicking it will enter the VM network con-
figuration page.

FortiSandbox VM accesses external network through port3. The next-
hop gateway and DNS settings can be configured in Scan Policy >
General > Allow Virtual Machines to access external network
through outgoing port3.

Displays the status of the FDN download server. When the FDN
download server is inaccessible, no update packages will be down-
loaded.

Displays an up icon if the system can access the FDN download
server. Displays a caution icon if the system cannot access the FDN
download server. Hover the mouse pointer on the status icon to view
detailed information.

Displays the status of the Sandbox Community Cloud server.
Displays an up icon if the system can access the cloud server. Dis-
plays a caution icon if the system cannot access the cloud server.
Hover the mouse pointer on the status icon to view detailed inform-
ation.

Displays the status of the Web Filtering query server.

Displays an up icon if the system can access the Web Filtering query
server. Displays a caution icon if the system cannot access the Web

Filtering query server. Hover the mouse pointer on the status icon to
view detailed information.

The date that the antivirus database contract expires. If the contract
expires within 15 days, a warning icon will appear.

The date that the web filtering contract expires. If the contract
expires within 15 days, a warning icon will appear.

The date that the Android Sandbox engine contract expires. In this
release, the contract follows that of the AntiVirus Database.

~‘9"' Select the edit icon to type a custom widget title and enter the refresh interval.
= The default refresh interval is 300 seconds.

System Resources

This widget displays the following information and options:

CPU Usage

Gauges the CPU percentage usage.



Memory Gauges the Memory percentage usage.
Reboot/Shutdown Options to shutdown or reboot the FortiSandbox device.
*‘9"' Select the edit icon to type a custom widget title and enter the refresh interval.

The default refresh interval is 30 seconds.

Scanning Statistics

The Scanning Statistics widget displays information about the files that have been scanned over a

specific time period.

This widget displays the following information:

Rating

Sniffer, Device(s), On
Demand, Network,
Adapter, All

Malicious

Suspicious - High Risk

Suspicious - Medium

Risk

Suspicious - Low Risk

Clean

Other

Processed

Pending

The file rating refers to the rating categories.

The input type from which the files were received.

The number of files scanned for each input type that were found to
be malicious in the selected time period.
Click the link to view the associated jobs.

The number of files scanned for each input type that were found to
be suspicious and posed a high risk in the selected time period.
Click the link to view the associated jobs.

The number of files scanned for each input type that were found to
be suspicious and posed a medium risk in the selected time period.
Click the link to view the associated jobs.

The number of files scanned for each input type that were found to
be suspicious and posed a low risk in the selected time period.
Click the link to view the associated jobs.

The number of files scanned for each input type that were found to
be clean in the selected time period.
Click the link to view the associated jobs.

The number of files for each input type which have an unknown
status. Unknown status files include jobs which have timed out,
crashed, been canceled by the user through a JSON API call, or been
terminated by the system.

Click the link to view the associated jobs.

The total number of files processed for each input type in the selec-
ted time period.

The number of files pending. Pending files are not put in the scan
queue.



Processing The number of files in the scan process.

Total The total number of files for each input type in the selected time
period.
N Select the edit icon to type a custom widget title, enter the refresh interval, and
9 select the time period. The default refresh interval is 600 seconds. The default

time period is the last 24 hours.

~9' If the device is the Master node of a cluster, the numbers in this widget are the
= total numbers of all cluster nodes.

Scanning Activity

The Scanning Activity widget shows the number of clean, suspicious, and malicious events that have
occurred at specific times over a selected time period.

If the time interval is set to Last 24 hours, a bar will be shown for each hour. If it is set to Last 7 days or
Last 2 weeks, a bar will be shown for each day.

Hovering the cursor over a colored portion of a bar in the graph for a brief time will show the exact
number of events of the selected type that occurred at that time.

R Select the edit icon to type a custom widget title, enter the refresh interval, and
9 select the time period. The default refresh interval is 300 seconds. The default
= time period is the last 2 weeks.

Top Devices

The Top Devices widget displays the total number of scanning jobs for the top five devices over a
selected time interval.

Hovering the cursor over a bar in the graph for a brief time will show the exact number of scanning jobs
for that particular device.

N Select the edit icon to type a custom widget title, enter the refresh interval, top
9 count, and select the time period. The default refresh interval is 300 seconds.
= The default time period is the last 24 hours.

Top Critical Logs

The Top Critical Logs widget displays recent critical logs, including the time they occurred and a brief
description of the event.

~‘9"' Select the edit icon to type a custom widget title, enter the refresh interval, and
= top count. The default refresh interval is 3600 seconds.

Pending Job Statistics

The Pending Job Statistics widget displays the total number of pending jobs for on-demand, sniffer,
and network share for the past 72 hours.



Hovering the cursor over the graph displays the number of pending jobs for the on-demand, sniffer, and
Fortinet devices over a selected time interval.

~‘9"' Select the edit icon to type a custom widget title and enter the refresh interval.
= The default refresh interval is 900 seconds.

Disk Monitor

Displays the RAID level and status, disk usage, and disk management information. This widget is only
available in hardware based models.

This widget displays the following information:

Summary Disk summary information including RAID level and status.
RAID Level Displays the RAID level.

Disk Status Displays the disk status.

Disk Usage Displays the current disk usage.

Disk Number Displays the disk number

Disk Size Displays the disk size.

Sniffer Traffic Throughput

Displays the Sniffer Traffic Throughput in Mb/s across time.

Dashboard Settings

Change the system host name

The System Information widget will display the full host name. However, if the host name is longer
than 16 characters, the host name in a truncated form ending with a tilde (~) to indicate that additional
characters exist, but are not displayed. You can change the FortiSandbox host name as required.

To change the host name:

1. Goto Dashboard > System Information widget > Host Name.

2. Click [Change].

3. Inthe New Name field, type a new host name.
The host name may be up to 50 characters in length. It may include US-ASCII letters, numbers,
hyphens, and underscores. Spaces and special characters are not allowed.

4. Select Apply.

Change the administrator password

By default, you can log in to the GUI using the admin administrator account and no password. It is
highly recommended that you add a password to the admin administrator account. For improved



security, you should regularly change the admin administrator account password and the passwords for
any other administrator accounts that you add.

To change an administrator’s password

The user can click the current login username from the top right corner and select Change Password
or:

Go to System > Administrators

Select the administrator's account you want to edit

Click the Edit button in the toolbar

Change the password.

PoODd =

Change the GUl idle timeout

By default, the GUI disconnects administrative sessions if no activity takes place for five minutes. This

idle timeout is recommended to prevent someone from using the GUI on a PC that has been logged
into the GUI and left unattended.

To change the idle timeout length:

1. Goto System > Admin > Settings.

2. Change the idle timeout minutes (1 to 480 minutes) as required.
3. Select OK to save the setting.

\#

N\ In this page you can also reset all widgets to their default settings.

Configure the system time

The FortiSandbox unit’s system time can be changed from theDashboard. You can configure the
FortiSandbox system time locally or select to synchronize with an NTP server.

1. Inthe System Information widget > System Time
2. Click [Update].
Time Settings

System Time

20146-03-01 11:17:48 PST Refresh
Time Zone
(GMT-8:00)Pacific Time(US&Canada) r

Set Time
Hour [49 »| Minute [q7 +| Second (48 «

Month [pgar » | Day 1 = | Year 2016 *

» Synchronize with NTP Server
Server

Apply Back

3. Configure the following settings:



System Time

Time Zone

Set Time

Synchronize with NTP
Server

Server

The date and time according to the FortiSandbox unit’s clock at the
time that this tab was loaded.

Select the time zone in which the FortiSandbox unit is located.

Select this option to manually set the date and time of the
FortiSandbox unit’s clock, then select the Hour, Minute, Second,
Month, Day, and Year fields before you select Apply.

Select this option to automatically synchronize the date and time of
the FortiSandbox unit’s clock with an NTP server. The
synchronization interval is hard-coded to be 5 minutes. You can
configure only one NTP server.

Enter the IP address or domain name of an NTP server. To find an
NTP server that you can use, go to http://www.ntp.org. Ensure that
the applicable routing is configured when an NTP server is used.

4. Click Apply to apply the changes, then select OK in the confirmation dialog box.

You may need to log in again after changing the time.

Microsoft Windows VM license activation

When Fortinet ships FortiSandbox, the Microsoft Windows VM license used by the sandbox is
activated. After an RMA or new Windows VM installation, the Windows VM license will be in an
unactivated state and need re-activation.

g

o

’ If the user purchases a Windows VM upgrade package to add Windows 8 or 10
support, the downloaded license file should be uploaded here by clicking the

[Upload License] link.

Microsoft Office license upload and activation

User can purchase add-on Office licenses from Fortinet and upload it in the System Information

widget.

By default, physical FortiSandbox models are shipped with a certain number of

Ay

~9' Microsoft Office license keys. Users can purchase more licenses from Fortinet

to improve the scan capacity of Microsoft Office files. Users can upload the
license file in the System Information widget.

To upload a Microsoft Office license

Click [Upload License].

o b=

Click Submit.

Go to Dashboard > System Information widget > Microsoft Office.

Click Choose File to browse for the license file on your management computer.

The FortiSandbox will reboot after the license file in installed. After the license file is installed, you can
scan Microsoft Office files including .docx and .pptx file.


http://www.ntp.org/

Log out of the unit

1. Select your user name from the top right corner of the banner
2. Select Logout from the drop down to log out of your administrative session.

If you only close the browser or leave the GUI to browse another web site, you will remain logged in
until the idle timeout period elapses.

Visit online help

Click the Help icon to visit Online Help.

Update the FortiSandbox firmware
Before any firmware update, complete the following:

« Download the FortiSandbox firmware image and Release Notes document from the Fortinet Customer
Service & Support portal. Review the Release Notes, including the special notices, upgrade information,
product integration and support, and resolved and known issues.

« Backup your configuration file. It is highly recommended that you create a system backup file and save it
to your management computer.

« Plan a maintenance window to complete the firmware update. If possible, you may want to setup a test
environment to ensure that the update does not negatively impact your network.

« Once the update is complete, test your FortiSandbox device to ensure that the update was successful.

Firmware best practice: Stay current on patch releases for your current major
release. Only update to a new major release or version when you are looking

for specific functionality in the new major release or version. For more inform-

ation, see the FortiSandbox Release Notes or contact Technical Support.

To update the FortiSandbox firmware:

Go to Dashboard > System Information widget > Firmware Version.

Click [Update].

Select Choose File, locate the firmware image on your management computer
Click Submit to start the upgrade.

o b=

Update the system utilities version

FortiSandbox system utilities include the following FortiGuard modules: Antivirus Scanner, Antivirus
Extreme Signature, Antivirus Active Signature, Network Alerts Signature, Sandbox Engine, and Android
Analytic and Rating Engines. They can be manually downloaded from the Fortinet Customer Service &
Support portal. This page displays the current version of these modules, the last update date and time,
and last update status.

To update the FortiSandbox system utilities version:

Go to Dashboard > System Information widget > System Ultilities Version.

Click [Update].

Click Choose File to locate the upload package file on your management computer
Click Submit to start the upgrade.

P obd =
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Server overrides

By default, FortiSandbox units connect to the FortiGuard Distribution Network (FDN) using a set of
default connection settings. You can override these settings to use an IP address or FQDN of a private
FortiGuard Distribution Server (FDS), like FortiManager, for these FortiGuard services. When
configured, FortiSandbox will query the IP address specified for FortiGuard services.

L

~9' To use a FortiManager device as a private FDN server, the FortiManager must
= be running version 5.0.8 and later or version 5.2.0 and later.

To configure an override FDN server to download module updates:

1. Goto System > FortiGuard.

2. Select the checkbox beside Use override FDN server to download module updates and enter the server
IP address or FQDN. If a proxy server is needed to access the FDN server, check the Use Proxy box to
enable and configure a proxy server.

3. Click Apply to save the settings.

4. To schedule animmediate FDN update, click the Connect FDN Now button.

Ay

~9' The target TCP port 8890 must be opened on your firewall for the updates
= downloads to work.

To configure an override server for web filtering query:

1. Goto System > FortiGuard.

2. Select the checkbox beside Use override server for web filtering query and enter the server |IP address
or FQDN. If a proxy server is needed to access the FDN server, check the Use Proxy checkbox to
enable and configure a SOCKSS5 type proxy server.

3. Click the Apply button to save the setting.

The target UDP port 53 must be opened on your firewall for web filtering query
~‘9"r to work. FortiGuard web filtering server also listens on UDP port 8888. To use
L this port, you must put the port number in the override field at Maintenance >
FortiGuard.

To configure an override port to access the FortiSandbox Community Cloud Server

1. Goto System > FortiGuard.

2. Select the checkbox beside Use override server port for community cloud server query (Ex:8888) and
enter 8888. If a proxy server is needed, check the Use Proxy checkbox to enable and configure a
SOCKSS5 type proxy server.

3. Select the Apply button to save the setting.

N By default, FortiSandbox Community Cloud server listens on UDP port 53 and
9 TCP port 443 for query. User can override UDP port 53 to use port 8888
= instead.




Reboot and shutdown the unit

Always reboot and shutdown the FortiSandbox system using the options in the GUI or CLI to avoid
potential configuration or hardware problems.

To reboot the FortiSandbox unit:

Go to Dashboard > System Resources widget.

Select Reboot.

Enter a reason for the reboot in the Reason field, and then select OK to reboot the unit.

Upon reboot, some databases may take up to ten minutes to be populated.

After reboot, the FortiSandbox VM system will initialize again. This initialization can take up to 30

minutes. The Windows VM icon in the System Information widget will show a warning sign before the
process completes.

It is normal to see the following critical event log in Log Access after FortiSand-

R box boots up:
9 The VM system is not running and might need more time to startup.
= Please check system logs for more details. If needed, please
reboot system.
N After FortiSandbox is upgraded to a new firmware version, the system might
9 clean up data and a Database is not ready message will be displayed. The

clean up time depends on the size of historical data.

To shutdown the FortiSandbox unit:

oo Db =

Go to Dashboard > System Resources widget.
Select Shutdown.

Enter a reason for the shutdown in the Reason field.
Select OK to shutdown the unit.

Backup or restore the system configuration

It is recommended that you create a system backup file as part of your maintenance plan. Always
perform a backup before upgrading firmware or making major system configuration changes. Save
these configuration backups to your management computer in the event that you need to restore the
system after a network event.

The FortiSandbox configuration file is in binary format and manual editing is
not supported.

To backup the FortiSandbox configuration:

1.
2,
3.

Go to Dashboard > System Information widget > System Configuration.
Select Backup/Restore.
Click Click here to save your backup file to your management computer.



To restore the FortiSandbox configuration:

Go to Dashboard >System Information widget > System Configuration.

2. Select Backup/Restore.

3. Click Choose File, locate the backup file on your management computer, then select Restore to load
the backup file.

4. Select OK in the confirmation dialog box. The system configuration restore process has been started,
you will be redirected to the login page once it has completed.

By performing a system restore, all of your current configurations will be
~‘9"' replaced with the backup data. The system will reboot automatically to com-
s plete the restore operation. Only backup configuration from the previous or

same release is supported.

To restore a backup configuration from HC, you will need to change to Stan-
dalone mode first.




FortiView

The FortiView menu provides access to the following menus:

Operation
Center

Threats by
Hosts

Threats by Files

Threats by
Devices

Search

Operation Center

The FortiView pages allow you to view and search threats detected
by FortiSandbox.

In this page you are able to view malware, which have been detected
and what the status is from a security update perspective. This page
displays severity levels, victim |P addresses, incident time, threat
and current action status.

On this page you can view and drill down all threats grouped by indi-
viduals or victim hosts in your organization. This page displays
threats by user name or host IP address; the number of threats; the
number of suspicious files (if available); and a button to show the vic-
tim's threat timeline chart. Select an entry in the table to view
detailed information including attacker events, Botnet events, and
URL events.

On this page you can view and drill down all threats grouped by files.
This page displays threats by file name, risk, and number of users.
Select a filename in the table to view detailed information including
user IP, destination, and number of detection times.

On this page you can view and drill down all threats grouped by
devices. This page displays threats by device, number of malicious
files, and number of suspicious files. Select a device in the table to
view detailed information including malware name, destination,
domain, and number of detection times.

Search by detection time, file MD5, file name, file SHA1 or SHA256,
job ID, malware name, rating, service, source IP, user, submit
device, or detection OS. You can add multiple search criteria by click-
ing the search field. If the search criteria is the filename or the file's
download domain, you can also do a pattern search.

In this page you are able to view newly detected malware, which have been detected and what the
status is from a security update perspective.

When a dynamic signature is sent back to FortiGate, FortiMail, or FortiClient, the status information
will be displayed so you can see that it has been done.

When a new antivirus update is received, FortiSandbox will recheck all samples not covered by the
standard antivirus package and update its status. Malware detected by FortiSandbox before an
antivirus signature is available will be marked as Zero-day.



Q Last7Days ~ Export Data | (C@ Search

o Rating  Medium Risk, Hig...
Severity Victim IP

Za Medium Risk

ZBE S A HighRisk

ZHES A HighRisk

Za Medium Risk
ZHBES A HihRisk
ZH O Medium Risk
Fha Medium Risk
Za © Zero-day
Za © Zero-day

The following options are available:

Time Period

Export Data

Search

Refresh

Add Search Filter

View Job

In Cloud

In Signature

Perform Rescan

Archived File

Pagination

Incident Time
May 18 2016 10:47:22
May 18 2016 10:28:32
May 18 2016 10:07:47
May 18 2016 09:54:50
May 17 2016 12:46:49

May 17 2016 12:44:03

Threat Name
Suspicious - Medium
Suspicious - High
Suspicious - High
Suspicious - Medium
Suspicious - High

Suspicious - Medium

Action
@ Action Required
® Action Required
® Action Required
® Action Required
@ Action Required

@ Action Required

May 17 2016 12:44:03 Suspicious - Medium @ Action Required
May 17 2016 11:32:50 ‘W32/Injector.CYOQ!tr @ Action Required
May 17 2016 11:32:42 W32/Injector.CYOQ!tr @ Action Required

Select the time period from the drop-down list. Select one
of the following: 24 Hours, 7 Days, or 4 Weeks.

Click the Export Data button to create a PDF or CSV snap-
shot report. The time to generate the report is dependent
on the number of events selected. Do not close the dialog
box or navigate away from the page during report gen-
eration.

Show or hide the search filter field.

Click the refresh icon to refresh the entries displayed after
applying search filters.

Click the search filter field to add search filters. Click the
cancel icon to the left of the search filter to remove the spe-
cific filter. Click the clear all filters icon in the search filter
field to clear all filters.

In this page, several fields, like victim host IP can be the
search criteria.

Search filters can be used to filter the information dis-
played in the GUI.

Click the View Jobs icon show the job detail page.

An icon will appear if the malware is available in the
FortiSandbox Community Cloud.

An icon will appear if the malware is included in the current
FortiSandbox generated Malware Package.

An icon will appear if the malware has a Malicious rating.
Users can perform a Rescan to obtain its Sandboxing beha-
vior details.

An icon will appear if the file is an Archived File.

Use the pagination options to browse entries displayed.

This page displays the following information:



Severity The severity rating of the malware.
Severity levels include:
o Low Risk

¢ Medium Risk
« High Risk

« Malicious
If afile is detected by FortiSandbox first before an antivirus signature
is available, the Severity level will be Zero-day.

Victim IP The IP address of the client that downloaded the malware. Use the
column filter to sort the entries in ascending or descending order.

Incident Time The date and time that the file was received by FortiSandbox. Use
the column filter to sort the entries in ascending or descending order.

Threat Name The name of the virus. Use the column filter to sort the entries in
ascending or descending order.
If the virus name is not available, the malware's Severity will be used
as its Threat Name.

Action Current action applied to the malware. Users use this field to track
responses taken towards the incident. Three values are available:
« Action Taken

« lIgnore
« Action Required

To view file details:

Select afile.

Click the click the View Details icon. A new tab will open.

See Appendix A - View Details Page Reference on page 170 for descriptions of the View Details page.
Close the tab to exit the View Details page.
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Threats by Topology

Go to FortiView > Threats by Topology. It combines both device and threat information together.

Devices (or input sources) are displayed in separated top level circles and the threats that occur on
them are displayed inside them as second level circles. The radius of threat circle is proportional to
threat event counts. Threat circles can be multiple levels and each level represents a subnet level.

Clicking on circles will drill down to the host level. At the host level, clicking on circle will display a new
page to show threat details.

There are host and time range filters in the toolbar on top.

The following options are available:

Hosts Select the host.

Time Period Select the time period from the drop-down list. Select one of the fol-
lowing: 24 Hours, 7 Days, 4 Weeks, or All.



Toggle Light Select Toggle Light to change the topology background color.

Toggle Network Alert Select to toggle and include Network Alert data from sniffed traffic.
Data
& hosts = @ Last2aHours & L TogeleLight (@ Toggle Metwork Alert Data

B alicious
[ HighRisk
| Medium Risk
B LowRisk

Device: Sniffer Device: F( @

Threats by Hosts

In this page you can view and drill down all threats grouped by hosts. The Host can be a user name if it
is available or a device that is the target of a threat. This page displays all threats that have occurred to
the user or victim host during a time period. Click the View Jobs icon or double-click an entry in the
table to view the second level.

Threats by Hosts - level 1

The following options are available:

Time Period Select the time period from the drop-down list. Select one of the fol-
lowing: 24 Hours, 7 Days, or 4 Weeks.

Export Data Click the Export Data button to create a PDF or CSV snapshot
report. Do not close the dialog box or navigate away from the page
during report generation.



Search

Refresh

Add Search Filter

View Job

Pagination

Show or hide the search filter field.

Click the refresh icon to refresh the entries displayed after applying
search filters.

Click the search filter field to add search filters. Click the cancel icon
to the left of the search filter to remove the specific filter. Click the
clear all filters icon in the search filter field to clear all filters.

In this page, the threat target host or user name can be the search cri-
teria.

Search filters can be used to filter the information displayed in the
GUL.

Click the View Jobs icon to drill down the entry.

Use the pagination options to browse entries displayed.

This page displays the following information:

Host/Username

Device Name

# of Malicious Files

# of Suspicious Files

# of Network Threats

Timeline

Total Files

Threats by Hosts - level 2

The device and username that is the target of threats. Click the
column header to sort the table by this column.

Note: A duplicate user name or host from a different VDOM is con-
sidered a different user. For more information about user man-
agement, SSO, and VDOMSs see The FortiOS Handbook located in
the Fortinet Document Library.

The device name. Click the column header to sort the table by this
column.

The number of unique malicious files associated with the user for the
time period selected. Click the column header to sort the table by this
column.

The number of unique suspicious files associated with the user for
the time period selected. Click the column header to sort the table by
this column.

The number of unique network threats (attacker, botnet, and sus-
picious URL events) associated with the user for the time period
selected. Click the column header to sort the table by this column.

View the Threat Timeline Chart. When you click on any dot in the
chart, all events associated will be displayed. When you click on an
event, the View Details page will open.

The number of files displayed and the total number of files.

Double-click an entry in the table to view the second level.

The following options are available:


http://docs.fortinet.com/

Back

Time Period

Search

Refresh

View Job

Pagination

Click Back button to return to the main landing page.

Select the time period from the drop-down list. Select one of the fol-
lowing: 24 Hours, 7 Days, or 4 Weeks.

Show or hide the search filter field.

Click the refresh icon to refresh the entries displayed after applying
search filters.

Click the View Jobs icon to drill down the entry.

Use the pagination options to browse entries displayed.

The following information is displayed:

Threat Timeline Chart

Summary

Details

Malicious Files

Suspicious
Files

Attacker Events

Botnet Events

URL Events

Threats by Hosts - level 3

This chart displays the number of threats and types of threats which
occurred to the threat target during the period of time selected in the
Time Period drop-down. Hover the mouse pointer over the dots in the
chart and more detailed threat information will be displayed.

The following fields are displayed: Device, Threat Target, Time
Period, Total Files, number of: Malicious Files, Suspicious Files, and
Network Share Events.

Malicious file information including malware name, Threat Source,
domain name, and number of detection times. The options are:
a. Click the View Jobs > View Details icons to drill down
the entry.

b. Click the malware name to view the related FortiGuard
Encyclopedia page.

Suspicious file information including file name, file type, risk level, its
download domain name, destination IP address, and number of
detection times. Click the View Jobs > View Details icons to drill
down the entry. Right-clicking various field will add filters.

Attacker event information including attacker name, attack origin
address and port, attack destination address and port, and number of
detection times. Right-clicking various field will add filters.

Botnet event information including botnet name, user IP address,
user port, destination IP address, destination IP port and number of
detection times. Right-clicking various field will add filters.

Suspicious URL event information including site category, host or IP
address, URL, type, user IP address, user port and number of detec-
tion times. Right-clicking various field will add filters.

The following options are available:



Back

View Details

Perform Rescan

Pagination

Click the Back button to return to the main landing page.

Click the View Details icon to view file information. The information
displayed in the view details page is dependent on the file type and
risk level.

Click the icon to rescan the entry. In the Rescan Configuration dialog
box you can select to skip Static Scan, AV Scan, Cloud Query, and
Sandboxing. Click OK to continue. Click the close icon or select the
Close button to close the dialog box.

This feature is only available for files with a malicious rating.

Use the pagination options to browse entries displayed.

The following information is displayed:

Malicious Files

Suspicious Files

Threats by Hosts - level 4

Displays the date and time that the file was detected, malware
name, source |P address, destination |P address, and domain name,
if available.

Click the malware name to view the related FortiGuard Encyclopedia
page. Right-clicking various field will add filters.

Displays the date and time that the file was detected, file type, rat-
ing, source |IP address, destination IP address, domain name, and
number of detection times, if available. Right-clicking various field
will add filters.

For more information on the information available in the View Details pages for malicious and
suspicious files, see Summary Report on page 148 and Summary Report on page 148.
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When a file has been rescanned, the results of the rescan are displayed on this
page. Select the job ID to view the job details.

To create a snapshot report for all threats by users:

2 o o

Select a time period from the Time Period drop-down list.

Click the Filterfield to apply filters to further drill down the information in the report.
Click the Export Data button in the toolbar..

In the Report Generator, select either PDF or CSV for the report type.

Click the Generate Report button to create the report.

When the report generation is completed, select the Download button to save the file to your
management computer.

7. Click the Cancel button, to exit the report generator.

In this release, the maximum number of events you can export to PDF report is
5,000; the maximum number of events you can export to CSV report is




Threats by Files

In this page you can view and drill down all threats group by malware file name. This page displays
threats by filename, rating, and number of targeted users and hosts. Click the View Jobs icon or
double-click an entry in the table to view the second level.

Threats by Files -level 1

The following options are available:

Time Period

Export Data

Search

Refresh

Add Search Filter

View Jobs

Pagination

Select the time period from the drop-down list. Select one of the fol-
lowing: 24 Hours, 7 Days, or 4 Weeks.

Click the Export Data button to create a PDF or CSV snapshot
report. The time period of jobs included in the report depends on the
selection of Time Period drop-down. The time to generate the report
is dependent on the number of events selected. Do not close the dia-
log box or navigate away from the page during report generation.

Show or hide the search filter field.

Click the refresh icon to refresh the entries displayed after applying
search filters.

Click the search filter field to add search filters. Click the cancel icon
to the left of the search filter to remove the specific filter. Click the
clear all filters icon in the search filter field to clear all filters.

Search filters can be used to filter the information displayed in the
GUL.

Click the View Jobs icon to drill down the entry.

Use the pagination options to browse entries displayed.

This page displays the following information:

Filename

Rating

# of Users

Timeline

Total Files

The threat file name. Click the column header to sort the table by this
column.

The file rating. Click the column header to sort the table by this
column.

The number of users affected. Click the column header to sort the
table by this column.

View the Threat Timeline Chart. When you hover over any dot, all vic-
tim hosts by the infected by that malware will appear in five minutes.
When you click on any dot in the chart, all events associated will be
displayed. When you click on an event, the View Details page will
open.

The number of files displayed and the total number of files.



Threats by Files - level 2

The following options are available:

Back

Time Period

Search

Refresh

Add Search Filter

View Jobs

Pagination

Click the icon to return to the main landing page.

Select the time period from the drop-down list. Select one of the fol-
lowing: 24 Hours, 7 Days, or 4 Weeks.

Show or hide the search filter field.

Click the refresh icon to refresh the entries displayed after applying
search filters.

Click the search filter field to add search filters. Click the cancel icon
to the left of the search filter to remove the specific filter.

Search filters can be used to filter the information displayed in the
GUL.

Click the View Jobs icon to drill down the entry.

Use the pagination options to browse entries displayed.

The following information is displayed:

Summary of

Details

Threats by Files - level 3

Summary information including link to FortiGuard Encyclopedia Ana-
lysis, source |IP address, destination |P address, time period, down-
load location, file type, threat type, submission information, and
device information (if available). If the malware appears more than
once, the information is from its most recent detection.

Detail information including user IP address. destination |P address,
and number of detection times. Select the View Jobs icon, or
double-click on the row, to drill down the entry.

The following options are available:

Back

View Details

Perform Rescan

Pagination

Select to return to the main landing page.

Select the View Details icon to view file information. The information
displayed in the view details page is dependent on the file type and
risk level.

Click the icon to rescan the entry. In the Rescan Configuration dialog
box you can select to skip Static Scan, AV Scan, Cloud Query, and
Sandboxing. Click OK to continue. Click the close icon or select the
Close button to close the dialog box.

This feature is only available for files with a malicious rating.

Use the pagination options to browse entries displayed.



~‘9"' When a file has been rescanned, the results of the rescan are displayed in this
= page. Select the job ID to view the job details.

The following information is displayed:

Detected The date and time that the file was detected by FortiSandbox. Click
the column header to sort the table by this column.

Filename Displays the filename.

Source Displays the source IP address. Click the column header to sort the

table by this column.

Destination Displays the destination IP address. Click the column header to sort
the table by this column.

Rating Displays the file rating. Click the column header to sort the table by
this column.
Total Jobs The number of jobs displayed and the total number of jobs.

Threats by Files - level 4

For more information on about the information available in the View Details pages for malicious and
suspicious files, See Summary Report on page 148

To create a snapshot report for all threats by files:

Select a time period from the first drop-down list.

Select to apply search filters to further drill down the information in the report.
Click the Export Data button in the toolbar.

In the Report Generator, select either PDF or CSV for the report type.

Click the Generate Report button to create the report.

When the report generation is completed, select the Download button to save the file to your
management computer.

AU IS

7. Click the Cancel button, to exit the report generator.

N In this release, the maximum number of events you can export to PDF report is
9 5,000; the maximum number of events you can export to CSV report is
= 150,000.

Threats by Devices

In this page you can view and drill down all threats grouped by devices. This page displays device
name, number of malicious files, and number of suspicious files. Double-click an entry in the table to
view the second level, View Jobs.



Threats by Devices - level 1

The following options are availa

Time Period

Export Data

Search

Refresh

Add Search Filter

View Jobs

Pagination

ble:

Select the time period from the drop-down list. Select one of the fol-
lowing: 24 Hours, 7 Days, or 4 Weeks.

Click the Export Data button to create a PDF or CSV snapshot
report. The time period of included jobs in the report depends on the
selection of Time Period drop-down. The time to generate the report
is dependent on the number of events selected. Do not close the dia-
log box or navigate away from the page during report generation.

Show or hide the search filter field.

Click the refresh icon to refresh the entries displayed after applying
search filters.

Click the search filter field to add search filters. Click the cancel icon
to the left of the search filter to remove the specific filter. Click the
clear all filters icon in the search filter field to clear all filters.

Search filters can be used to filter the information displayed in the
GUL.

Click the View Jobs icon to drill down the entry.

Use the pagination options to browse entries displayed.

This page displays the following information:

Device

# of Malicious Files

# of Suspicious Files

Timeline

Total Devices

Displays the device name. Click the column header to sort the table
by this column.

Note: A different VDOM on the same device is considered a different
device.

The number of malicious files submitted by the device. Click the
column header to sort the table by this column.

The number of suspicious files submitted by the device. Click the
column header to sort the table by this column.

View the Threat Timeline Chart of the device. When you hover on
any dot, all victim hosts managed by the device will appear in five
minutes. When you click on any dot in the chart, all events associated
will be displayed. When you click on an event, the View Details page
will open.

The number of devices displayed and the total number of devices.

Threats by Devices - level 2

The following options are availa

ble:



Back

Time Period

Export Data

Search

Refresh

Add Search Filter

Pagination

Click the icon to return to the main landing page.

Select the time period from the drop-down list. Select one of the fol-
lowing: 24 Hours, 7 Days, or 4 Weeks.

Click the Export Data button to create a PDF or CSV snapshot
report. The time period of included jobs in the report depends on the
selection of Time Period drop-down. The time to generate the report
is dependent on the number of events selected. Do not close the dia-
log box or navigate away from the page during report generation.

Show or hide the search filter field.

Click the refresh icon to refresh the entries displayed after applying
search filters.

Click the search filter field to add search filters. Click the cancel icon
to the left of the search filter to remove the specific filter.

Search filters can be used to filter the information displayed in the
GUL.

Use the pagination options to browse entries displayed.

The following information is displayed:

Summary of

Details

Malicious Files

Suspicious
Files

Displays a summary of the device type selected..

Detailed information includes device name, selected time period and
total number of malicious and suspicious files.

Malicious file information including malware name, destination IP
address, domain name the virus was downloaded from, and number
of detection times. Click the View Details icon, or double-click the
row, to drill down the entry.

Click the malware name to view the related FortiGuard Encyclopedia
page. Right-clicking various field will add filters.

Suspicious file information including file name, file type, risk level,
domain name the virus was downloaded from, destination IP
address, and number of detection times. Click the View Details icon,
or double-click the row, to drill down the entry. Right-clicking various
field will add filters.

Threats by Devices -level 3

The following options are available:

Back

View Details

Select to return to the main landing page.

Select the View Details icon to view file information. The information
displayed in the view details page is dependent on the file type and
risk level.



Perform Rescan Click the icon to rescan the entry. In the Rescan Configuration dialog
box you can select to skip Static Scan, AV Scan, Cloud Query, and
Sandboxing. Click OK to continue. Click the close icon or select the
Close button to close the dialog box. This feature is only available for
files with a Malicious rating.

Pagination Use the pagination options to browse entries displayed.
The following information is displayed:

Malicious Files Displays the date and time that the file was detected, malware
name, source |IP address, destination |P address, and domain name,
if available.

Click the malware name to view the related FortiGuard Encyclopedia
page.

Suspicious Files Displays the date and time that the file was detected, file type, rat-
ing, source |IP address, destination |P address, domain name, and
number of detection times, if available.

Threats by Devices - level 4

For more information on the information available in the View Details pages for malicious and
suspicious files, see Summary Report on page 148 and Summary Report on page 148.
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~9' When a file has been rescanned, the results of the rescan are displayed in this
= page. Select the job ID to view the job details.

To create a snapshot report for all threats by devices:

Select a time period from the first drop-down list.
Select to apply search filters to further drill down the information in the report.
Click the Export Data button in the toolbar. The Report Generator window opens.

Select either PDF or CSV for the report type. Optionally you can further define the report start/end date
and time.

oD =

o

Click the Generate Report button to create the report.

6. When the report generation is completed, select the Download button to save the file to your
management computer.

7. Click the close icon or the Cancel button, to quit the report generator.

N In this release, the maximum number of events you can export to PDF report is
9 5,000; the maximum number of events you can export to CSV report is
= 150,000.

File Scan Search

To view all files and search files, go to FortiView > File Scan Search .You can apply search filters to
drill down the information displayed. Filenames and domains can also be searched based on name



patterns, and a snapshot report can be created for all search results.

If the device is the Master node of a cluster, all jobs processed by the cluster are available to be
searched. If the device is a Slave node of a cluster, only jobs processed by this device are available to

be searched.

The following options are available:

Refresh

Search Field

Time Period

Export to Report

Customize

Action
View Details
Archived File
Perform Rescan

Pagination

The following information is displayed:

Click the refresh icon to refresh the entries displayed after
applying search filters.

Enter the detection time frame and click to add additional
search filters for File MD5, Filename, File SHA1, File
SHA256, Job ID, Malware, Rating, Service, Source, User,
Device, Infected OS, Domain, Rated by, or Scan Unit.
When the search criteria is a Filename or Domain, click the
= sign to toggle between the exact and pattern search.

Select a time period to apply to the search.

Select to open the Report Generator dialog box. Select to
generate a PDF or CSV report. During generation, do not
close the dialog box or navigate away from the page.

Click the Customize icon to customize the Job View set-
tings page. Go to Job View Settings on page 67 for more
information.

Click the View Details icon to view file information. The
information displayed in the view details page is dependent
on the file type and risk level.

The icon displays the file is archived.

Click the icon to rescan the entry. In the Rescan Con-
figuration dialog box you can select to skip Static Scan, AV
Scan, Cloud Query, and Sandboxing. Click OK to continue.
Click the close icon or select the Close button to close the
dialog box. This feature is only available for files with a
Malicious rating.

Use the pagination options to browse entries displayed.

Total Jobs The number of jobs displayed and the total number of jobs.

The displayed columns are determined by settings defined in System > Job View Settings > File
Detection Columns page. Go to Job View Settings on page 67 for more information.



URL Scan Search

To view all files and search files, go to FortiView > URL Scan Search. You can apply search filters to
drill down the information displayed. Filenames and domains can also be searched based on name
patterns, and a snapshot report can be created for all search results.

If the device is the Master node of a cluster, all jobs processed by the cluster are available to be
searched. If the device is a Slave node of a cluster, only jobs processed by this device are available to

be searched.
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The following options are available:

Refresh

Search Field

Time Period

Export to Report

Customize

Action

View Details

Archived File

Rating submitted Filename Submitted By Infected OS
@ Nia bad_url.txt admin N/A
@ Nia bad_url.txt admin N/A
@ Nia bad_url.txt admin N/A
@ N/A bad_url.txt admin N/A
@ N/A bad_url.txt admin N/A
@ N/A bad_url.txt admin N/A
@ N/A bad_url.txt admin N/A

Click the refresh icon to refresh the entries displayed after
applying search filters.

Enter the detection time frame and click to add additional
search filters for File MD5, Filename, File SHA1, File
SHA256, Job ID, Malware, Rating, Service, Source, User,
Device, Infected OS, Domain, Rated by, or Scan Unit.
When the search criteria is a Filename or Domain, click the
= sign to toggle between the exact and pattern search.

Select a time period to apply to the search.

Select to open the Report Generator dialog box. Select to
generate a PDF or CSV report. During generation, do not
close the dialog box or navigate away from the page.

Click the Customize icon to customize the Job View set-
tings page. Go to Job View Settings on page 67 for more
information.

Click the View Details icon to view file information. The
information displayed in the view details page is dependent
on the file type and risk level.

The icon displays the file is archived.



Perform Rescan

Pagination

The following information is displayed:

Detection

URL

Rating

Submitted Filename

Submit User

Infected OS

Total Jobs

Click the icon to rescan the entry. In the Rescan Con-
figuration dialog box you can select to skip Static Scan, AV
Scan, Cloud Query, and Sandboxing. Click OK to continue.
Click the close icon or select the Close button to close the
dialog box. This feature is only available for files with a
Malicious rating.

Use the pagination options to browse entries displayed.

The date and time that the file was detected by FortiSand-
box.

Displays the name of the file. This field is only displayed in
the FortiView > URL Scan Search section.

The file rating. The rating can be one or more of the fol-
lowing: Clean, Low Risk, Medium Risk, High Risk, Mali-
cious, or Unknown. Click the column header to sort the
table by this column.

The submitted filename associated with the URL. Click the
column header to sort the table by this column.

If the URL is from the body of an Email, and submitted by
FortiMail, the Email's session ID is used as the Submitted
Filename.

The user that submitted the URL to be scanned. Click the
column header to sort the table by this column.

The OS version of the FortiSandbox VM that was used to
make the Suspicious verdict

The number of jobs displayed and the total number of jobs.

The displayed columns are determined by settings defined in System > Job View Settings > URL
Detection Columns page. Go to Job View Settings on page 67 for more information.



Network

The Network page provides interface, DNS, and routing management options.

Interfaces

To view and manage interfaces, go to Network > Interfaces .

This page displays the following information and options:

Interface

port1 (admin-
istration port)

port2

port3 (VM out-
going interface)

portd

port5/port6

port7/port8

IPv4

IPv6

The interface name and description, where applicable.

Failover IP will be listed under this field with the following descriptor:
(cluster external port).

port1 is hard-coded as the administration interface. You can select to
enable or disable HTTP, SSH, Telnet access rights on port1. HTTPS
is enabled by default. port1 can be used for Device mode, although a
different, dedicated port is recommended.

port2 can be used for Sniffer mode, Device mode, and inter-node
communication within a cluster.

port3 is reserved for outgoing communication triggered by the exe-
cution of the files under analysis. It is recommended to put this inter-
face on an isolated network behind a firewall.

One special type of outgoing communication from a guest VM is
used to connect to the Microsoft Windows activation server to activ-
ate the Windows Sandbox VM product keys. You must enable Allow
Virtual Machines to access external network through outgoing port
and setup the next hop gateway and DNS server to allow files running
inside VMs to access the external network.

port4 can be used for Sniffer mode, Device mode, and inter-node
communication within a cluster.

port5 and port 6 can be used for Sniffer mode, Device mode, and
inter-node communication within a cluster. On FortiSandbox 3000E
and 3500D devices, port5 and port6 are 10G fiber ports. It is recom-
mended that they be used on a master node/primary slave as com-
munications ports with the cluster slaves.

port7 and port8 can be used for Sniffer mode, Device mode, and
inter-node communication within a cluster.

On FortiSandbox 3000D devices, port7 and port8 are 10G fiber ports.
It is therefore recommended that they be used on a master
node/primary slave as communications ports with the cluster slaves.

The IPv4 IP address and subnet mask of the interface.

The IPv6 IP address and subnet mask of the interface.



Interface Status The state of the interface, one of the following states:
« Interface is up

« Interface is down
« Interface is being used by sniffer

Link Status The link status.
e Linkup
o Linkdown
Access Rights The access rights associated with the interface. HTTPS is enabled by

default on port1. You can select to enable HTTP, SSH, and Telnet
access on port1.

Edit Select the interface and select Edit from the toolbar to edit the inter-
face.

The FortiSandbox uses port 3 to allow scanned files to access the Internet. The
Internet visiting behavior is an important factor to determine if a file is mali-

cious.
\ M As malicious files are infectious, you should ensure that the connection for port
N 3 is able to both access the Internet and be isolated. The connection should not

belong to or be able to access any internal subnet that needs to be protected.
Fortinet recommends placing this interface on an isolated network behind a fire-
wall.

~‘9"' For more information on FSA-1000D, FSA-3000D, FSA-3500D, FSA-3000E
= ports, see Default port information on page 14 .

Edit an interface

The IPv4/IPv6 address of an interface can be edited by selecting the interface name and clicking the
Edit button from the toolbar.

Edit the IP address as required, then click OK to apply the changes. You can also change the interface
status from Up to Down.

Do not change settings on an interface used for sniffing traffic.

Edit administrative access

The port1 interface is used for administrative access to the FortiSandbox device. HTTPS is enabled by
default, but you can edit this interface to enable HTTP, SSH, and Telnet support.

Edit the IP address and the access rights as required, then click OK to apply the changes.
Allow Interaction with VM Image During On-Demand Scan

Requirements:

« HTTP need to be enabled on port1. Go to Network > Interface > port1 edit page.
« One and only one VM type should be selected to perform the scan.



To use the Allow Interaction feature, go to the On Demand page when submitting a job. See To use
the Allow Interaction Feature: on page 103 for more information.

~‘9"' To be able to use the Allow Interaction feature with a VM image during On-

Demand scan, HTTP has to be enabled on port1.

Failover IP

Users are able to configure a cluster level fail-over |IP, which will be set only on Master node. This fail-
over IP can only be set on current Master node through the CLI. It should be in the same subnet of the
port’s local IP. Clients, such as FortiGates, and should point to the failover IP in order to use the HA
functionality. When a fail-over occurs, a failover IP will be applied on new Master node.

The Master node and Primary Slave node local IP will be kept during failover.

Example:

Here is an example to set a fail-over IP for port1.

> show

Configured parameters:

Port 1 IPv4 IP: 172.16.69.145/24 MAC: 14:18:77:52:37:72

Port 1 IPv6 IP: 2620:101:9005:69::145/64 MAC: 14:18:77:52:37:72
Port 2 IPv4 IP: 1.1.7.5/24 MAC: 14:18:77:52:37:73

Port 3 IPv4 IP: 192.168.199.145/24 MAC: 14:18:77:52:37:74

IPv4 Default Gateway: 172.16.69.1

> hc-settings -sc -tM -nl45 -c3000d-cluster -pl234 -iport2

The unit was successfully configured.

> hc-settings -si —-iportl -al72.16.69.160/24

The external IP address 172.16.69.160 for cluster portl was set successfully
> hc-settings -1

SN: FSA3KD3R16000xxx

Type: Master

Name: 145

HC-Name: 3000d-cluster

Authentication Code: 1234

Interface: port2

Cluster Interfaces:

portl: 172.16.69.160/255.255.255.0

DNS Configuration

The primary and secondary DNS server addresses can be configured from Network > DNS .
FortiSandbox is configured to use the FortiGuard DNS servers by default.

Static Routing

The static routing page allows you to manage static routes on your FortiSandbox device. Go to
Network > Static Routing to view the routing list.

The following options are available:



Create New Select to create a new static route.

Edit Select a static route in the list and select Edit in the toolbar to edit the
entry.

Delete Select a static route in the list and select Delete in the toolbar to
delete the entry.

The following information is displayed:

IP/Mask Displays the |P address and subnet mask.

Gateway Displays the gateway IP address.

Device Displays the interface associated with the static route.
Number of Routes Displays the number of static routes configured.

Create a new static route:

1. Click Create New from the toolbar.
2. Enter adestination IP address and mask, and a gateway, in their requisite fields.

~‘9"' The destination IP/Mask can be entered in the format
= 192.168.1.2/255.255.255.0, 192.168.1.2/24, or fe80:0:0:0:0:0:c0a8: 1fe.

3. Select a device (or interface) from the drop-down list.
4. Click OK to create the new static route.

Edit a static route:

Select a Static Route

Click the Edit button .

Edit the destination IP address and mask, gateway, and device (or interface) as required.
Click OK to apply the edits to the static route.

oo Db =

Delete a static route or routes:

1. Select one or more Static Routes.
2. Click the Delete button from the toolbar.
3. Select Yes, I'm sure on the confirmation page to delete the selected route or routes.

~‘9"' Static route entries defined in this page is for the system to use and will not be

applied to traffic originating from the guest VM during a file's execution.




System

The System tree menu enables you to manage and configure the basic system options for the
FortiSandbox unit. This includes administrator configuration, mail server settings, and maintenance
information.

The System menu provides access to the following menus:

Administrators Configure administrator user accounts.

Certificates Configure CA certificates, LDAP and RADIUS servers, and
other administrative settings.

LDAP Servers Configure LDAP Servers.

RADIUS Servers Configure RADIUS Servers.

Mail Server Configure the Mail Server

SNMP Configure SNMP.

FortiGuard Configure FortiGuard.

Login Disclaimer Configure the Login Disclaimer

Settings Configure the idle timeout value for the Web Ul and CLI

interface and Web Ul language. You can also reset all wid-
gets to their default state.

Ay
9 Some menus are not displayed on the Slave Nodes in a cluster.

Administrators

The Administrators menu allows you to configure administrator user accounts.
With the exception of the admin account, users are only able to view and edit their own information.

The following options are available:

Create New Select to create a new administrator account.

Edit Select an administrator account from the list and select Edit in the
toolbar to edit the entry.

Delete Select an administrator account from the list and select Delete in the
toolbar to delete the entry.



Test Login

Select a LDAP/RADIUS administrator account from the list and select
Test Login to test the user's login settings. If an error occurs, a
detailed debug message will display.

The following information is displayed:

Name

Type

Number of Admin-
istrators

Create a new user:

Displays the administrator account name.

The administrator type:
« Local (Read-Write)

o Local (Read-Only)

« Local (Device)

o LDAP (Read-Write)
« RADIUS (Read-Write)

Displays the number of administrator accounts configured on the
device.

1. Login as admin, and go to System > Administrators .
2. Select + Create New from the toolbar .

Mew Administrator

Administrator:
Password:

Confirm Password:
Type:

Privilege:

Trusted Host #1:
Trusted Host £2:
Trusted Host #3:

IPvé Trusted Host #1:
IPvé Trusted Host #2:
IPvé Trusted Host #3:

Comments:

Download original file
JSOM AP

Language:

# Local LDAP RADIUS

Read-Only ® Read-Write Device

0.0.0.0/00.00
0.0.0.0/000.0
10.0.0.0/00.0.0
Wit
=0
-0
A
English v

3. Configure the following:



Administrator Enter a name for the new administrator account. The administrator
name must be 1 to 30 characters long and may only contain upper-
case letters, lower-case letters, numbers, and the underscore
character _.

Password Enter a password for the account. The password must be 6 to 64
characters long and may contain upper-case letters, lower-case
letters, numbers, and special characters.

This field is available when Type is set to Local .

Confirm Password Confirm the password for the account.
This field is available when Type is set to Local.

Type Select either Local, LDAP, or RADIUS.

LDAP Server When Typeis LDAP, select the LDAP server from the drop-down list.
For information on creating an LDAP server, see LDAP Servers on
page 56.

RADIUS Server  When Type is RADIUS, select the RADIUS server from the drop-
down list. For information on creating a RADIUS server, see RADIUS
Servers.

Privilege Select either Read-only Read-Write or Device. Read-only
administrators have a limited set of permissions and cannot edit or
change the FortiSandbox configuration.

When the privilege is Device, the admin user can assign existing or
new devices and/or VDOMs to the user. When the user logs in, only
jobs belonging to the assigned devices or VDOMs will be visible.
Also, this user has Read-only privileges and can only view job data
pages.

Assigned Devices Assigned devices and/or VDOMs to the user when the user privilege
is set to Device.

When the user clicks the panel, an Available Devices panel will slide
out from the right side. This panel lists all available devices and
VDOMSs. Users can assign devices and VDOMs to the user by clicking
the device serial number or VDOM name. Users can also add or
delete user defined devices which have not been seen by the
FortiSandbox unit.

After editing, click outside the device panel to accept the changes.

Trusted Host 1, Trusted Enter up to three IPv4 trusted hosts.
Host 2, Trusted Host 3

Trusted IPv6 Host 1, Enter up to three IPv6 trusted hosts.
Trusted IPv6 Host 2,
Trusted IPv6 Host 3

Comments Enter an option description comment for the administrator account.



Download original file Deselect to prevent the user from downloading the original file from
the job details pages. When deselected, if the user attempts to
download the original file, they will receive an Access Denied error.
This setting can only be adjusted by the admin user.

JSON API Enable to allow users to make JSON API calls.

By default, Read-Only users cannot make JSON API calls.

Language Set the GUI language for the user, either English or Japanese.

Setting trusted hosts for administrators limits what computers an administrator

can log in the FortiSandbox unit from. When you identify a trusted host, the

N\ FortiSandbox unit will only accept the administrator’s login from the configured
IP address or subnet. Any attempt to log in with the same credentials from any
other IP address or any other subnet will be dropped.

4. Select OK to create the new user.

Edit a user account:

Login as admin, and go to System > Administrators .
Select the name of the user you would like to edit and select Edit from the toolbar.
Edit the account as required and then re-type the new password in the confirmation field.

PooDbd=

Click OK to apply the changes.

\ls

e When editing an administrative account, you will be required to type the old
password before you can set a new password.

~

g

L3
9 Only the admin user can edit its own settings.

g

Delete one or more user accounts:

Login as admin, and go to System > Administrators.

Select the user account you want to delete.

Select Delete from the toolbar.

Select Yes, I’'m sure in the confirmation page to delete the selected user or users.

o bd =

LDAP/RADIUS user test login:

Login as admin, and go to System > Administrators.
Select a LDAP/RADIUS user to test.

Select Test Login from the toolbar.

In the dialog box, enter the user's password.

Click OK.

If an error occurs, a detailed debug message will appear.

o Dd=



Certificates

In this page you can import, view, and delete certificates. Certificates are used for secure connection to
an LDAP server, system HTTPS and SSH services. The FortiSandbox has one default certificate
firmware.

by

~9' FSA does not support generating certificates, but imports certificates for SSH
= and HTTPS access to FSA..crt, PKCS12, and . pem formats are supported.

The following options are available:

Import Import a certificate.

Service Select to configure specific certificates for the HTTP and SSH serv-
ers.

View Select a certificate in the list and select View in the toolbar to view

the CA certificate details.

Delete Select a certificate in the list and select Delete in the toolbar to
delete the certificate.

The following information is displayed:

Name The name of the certificate.

Subject The subject of the certificate.

Status The certificate status, active or expired.

Service HTTPS or SSH service that is using this certificate.

To import a certificate:

Go to System > Certificates.

Select Import from the toolbar.

Enter the certificate name in the text field.

Select Choose File and locate the certificate and key files on your management computer.
Select OK to import the certificate.

o ODd=

Users have the option to import a Password Protected PKCS12
~‘9"' Certificate.To import a PKCS12 Certificate, check the PKCS12
= Format box upon importing a new certificate and writing down

possible passwords.




To view a certificate:

Go to System > Certificates.
2. Select the certificate from the list and select View from the toolbar.
3. The following information is available:

Certificate Name The name of the certificate.

Status The certificate status.

Serial number The certificate serial number.

Issuer The issuer of the certificate.

Subject The subject of the certificate.

Effective date The date and time that the certificate became effective.
Expiration date The date and time that the certificate expires.

4. Select OK to return to the Certificates page.

To delete a CA certificate:

1. Goto System > Certificates .
2. Select the certificate from the list and select Delete from the toolbar.
3. Select Yes, I'm sure in the Are You Sure confirmation page.

by
9 Firmware certificate(s) cannot be deleted.

LDAP Servers

The FortiSandbox system supports remote authentication of administrators using LDAP servers. To use
this feature, you must configure the appropriate server entries in the FortiSandbox unit for each
authentication server in your network.

If you have configured LDAP support and require a user to authenticate using an LDAP server, the
FortiSandbox unit contacts the LDAP server for authentication. To authenticate with the FortiSandbox
unit, the user enters a user name and password. The FortiSandbox unit sends this user name and
password to the LDAP server. If the LDAP server can authenticate the user, the FortiSandbox unit
successfully authenticates the user. If the LDAP server cannot authenticate the user, the FortiSandbox
unit refuses the connection.

The following options are available:

Create New Select to add an LDAP server.

Edit Select an LDAP server in the list and select Edit in the toolbar to edit
the entry.

Delete Select an LDAP server in the list and select Delete in the toolbar to

delete the entry.



The following information is displayed:

Name The LDAP server name.
Address The LDAP server address.
Common Name The LDAP common name.
Distinguished Name The LDAP distinguished name.
Bind Type The LDAP bind type.
Connection Type The LDAP connection type.

Number of LDAP servers  The number of LDAP server configured on the device.

To create a new LDAP server:

1. Goto System > LDAP Servers .
2. Select + Create New from the toolbar.
New LDAP Server
MName:
Server Name/IP:
Port: 389
Common Name:
Distinguished Name:
Bind Type: = Simple Anonymaous Regular

Enable Secure Connection

3. Configure the following settings:

Name Enter a name to identify the LDAP server. The name should be
unique to FortiSandbox.

Server Name/IP Enter the IP address or fully qualified domain name of the LDAP
server.

Port Enter the port for LDAP traffic. The default port is 389.

Common Name The common name identifier for the LDAP server. Most LDAP

servers use cn. However, some servers use other common name
identifiers such as uid.

Distinguished Name The distinguished name used to look up entries on the LDAP servers
use. The distinguished name reflects the hierarchy of LDAP database
object classes above the common name identifier.



Bind Type Select the type of binding for LDAP authentication. The following
options are available:

« Simple
« Anonymous
+ Regular
Username When the Bind Type is set to Regular, type the user name.
Password When the Bind Type is set to Regular, type the password.
Enable Secure Select to use a secure LDAP server connection for authentication.
Connection
Protocol When Enable Secure Connection is selected, select either LDAPS or
STARTTLS.

CA Certificate When Enable Secure Connection is selected, select the CA
certificate from the drop-down list.

4. Select OKto add the LDAP server.

RADIUS Servers

The FortiSandbox system supports remote authentication of administrators using RADIUS servers. To
use this feature, you must configure the appropriate server entries in the FortiSandbox unit for each
authentication server in your network.

If you have configured RADIUS support and require a user to authenticate using an RADIUS server, the
FortiSandbox unit contacts the RADIUS server for authentication. To authenticate with the
FortiSandbox unit, the user enters a user name and password. The FortiSandbox unit sends this user
name and password to the RADIUS server. If the RADIUS server can authenticate the user, the
FortiSandbox unit successfully authenticates the user. If the RADIUS server cannot authenticate the
user, the FortiSandbox unit refuses the connection.

The following options are available:

Create New Select to add a RADIUS server.

Edit Select a RADIUS server in the list and select Edit in the toolbar to edit
the entry.

Delete Select a RADIUS server in the list and select Delete in the toolbar to
delete the entry.

The following information is displayed:

Name The RADIUS server name.
Primary Address The primary server IP address.

Secondary Address The secondary server |P address.



Port The port used for RADIUS traffic. The default port is 1812.

Auth Type

The authentication type the RADIUS server requires. The default set-

ting of ANY has the FortiSandbox try all the authentication types.
Select one of: ANY, PAP, CHAP, or MSv2.

To add a RADIUS server:

1. Goto System > RADIUS Servers .
2. Select + Create New from the toolbar.

Mew RADIUS Server

Name:

Primary Server Name/IP:
Secondary Server Name/|P:
Port:

Auth Type:

Primary Secret:

Secondary Secret:

NASIP:

1812

w Any PAP CHAP MSv2

3. Configure the following settings:

Name

Primary Server Name/IP

Secondary Server
Name/IP

Port
Auth Type

Primary Secret
Secondary Secret

NAS IP

Enter a name to identify the RADIUS server. The name should be
unique to FortiSandbox.

Enter the IP address or fully qualified domain name of the primary
RADIUS server.

Enter the IP address or fully qualified domain name of the secondary
RADIUS server.

Enter the port for RADIUS traffic. The default port is 1812.

Enter the authentication type the RADIUS server requires. The
default setting of ANY has the FortiSandbox try all the authentication
types. Select one of: ANY, PAP, CHAP, or MSv2.

Enter the primary RADIUS server secret.
Enter the secondary RADIUS server secret.

Enter the NAS IP address.

4. Select OK to add the RADIUS server.



AWS Config

Ay
9 This page is only available on FSA-AWS models.

If you would like to try FortiSandbox in Amazon Web Services Cloud, please contact Fortinet Support.

£2% FortiSandbox AWS

Q Configure AWS

& Dashboard i
Region: us-west-2
[ FortiView >
Userld:
&+ Network >
Key:  isesssesessssssssscsnstisistisstssssies
£ System b
B VPC: vp-fad48c9d
Administrators
Zone: |us-west-2b
Certificates et
LDAP Servers Test Connection
RADIUS Servers
AWS Config

Mail Server

SNMP

FortiGuard

The following information is displayed:

Region The region code.
Userld The userid.

Key The key.

VPC The VPC code.
Zone The zone code.

Mail Server

The Mail Server page allows you to adjust the mail server settings. Go to System > Mail Serverto view
the Mail Server Settings page. In this page you can configure notifications for when a malicious file is
detected and the weekly report global email list.

The following options can be configured:

SMTP Server Address Enter the SMTP server address.
Port Enter the SMTP server port number.
E-Mail Account Enter the mail server email account. This will be used as

the from address.

Login Account Enter the mail server login account.
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Password
Confirm Password

Send notification mail to global
email list when malicious file is
detected

What rating of
job to send alert
email

Global noti-
fication mail
receivers list
(separated by
comma)

Notification mail
subject template

Send a notification email to the
below email list when mali-
cious/suspicious verdict is
returned to client device

Global verdict
notification
email receivers
list (separated
by comma)

Use FQDN as unit address for job
detail link (default is IP address of
Port1)

FQDN Name
Send scheduled PDF report

Send PDF
report to VDOM
email address

Report Sched-
ule Type:

Week Day:

At hour:

Enter the password.

Confirm the password.

Select to enable this feature. When enabled, a notification
email is sent to the global email list when a malicious file is

detected.

Select the rating of jobs that are included in the email
alerts. Options include: Malicious, High Risk, Medium
Risk, and Low Risk.

Enter the email addresses that comprise the global email
list.

Enter the subject line for the notification emails.

Select to enable this feature. When enabled, a notification
email is sent to a specific email list when a mali-
cious/suspicious file is retrieved by a client device.

Enter the email addresses that comprise the global email
list.

Use FQDN instead of port1 IP for a job detail link inside
alert emails and reports.

Enter FQDN name.

Select Yes to send a report email to the global email list.
Select to send PDF report to VDOM email address also.

The report will only contain jobs sent from the VDOM.
VDOM email address can be set in the VDOM edit page.

Select the report schedule type. Options include: Hourly,
Daily, and Weekly.

For different schedule types, different frequency options
are displayed. If the schedule type is Daily, the user can
set the hour for which the report is generated.

Select the day the report is to be sent.

Select the hour interval the report is to be sent.



Include job data Select the job data before 0-28 days.
before Days (0-
28) days:

Hours (0-23): Select the job data before 0-23 hours.

For example, if the user wants to include job data from the
last two days and three hours before report generation, the
user should select two in the Day Field and three in the
Hour field.

What rating of Select the rating of jobs that are included in the reports.
job to be Options include: Malicious, High Risk, Medium Risk, Low
included in the  Rjsk, and Clean.
detail report
Because there is a large amount of jobs with a Clean rat-
ing, it is recommended to exclude the Clean rating from
the detail report.

Global email list Enter the email addresses that comprise the summary
to receive sum- report global email list.

mary report (sep-

arated by The email addresses will receive reports including jobs
comma) from all input sources.

Global email list Enter the email addresses that comprise the detail report
to receive detail global email list. The email addresses will receive reports

report (sep- including jobs from all input sources.
arated by
comma)
OK Select OK to apply any changes made the mail server con-
figuration.
Send Test Email Select Send Test to send a test email to the global email
list.

If an error occurs, the error message will appear at the top
of the page and recorded in the System Logs.

Restore Default Select Restore Default to restore the default mail server
settings.

SNMP

SNMP is a method for a FortiSandbox system to monitor your FortiSandbox system on your local
computer. You will need an SNMP agent on your computer to read the SNMP information.

Using SNMP, your FortiSandbox system monitors for system events including CPU usage, memory
usage, log disk space, interface changes, and malware detection. Go to System > SNMP to configure
your FortiSandbox system’s SNMP settings.



SNMP has two parts - the SNMP agent or the device that is sending traps, and the SNMP manager that
monitors those traps. The SNMP communities on the monitored FortiSandbox are hard coded and
configured in the SNMP menu.

The FortiSandbox SNMP implementation is read-only — SNMP v1, v2c, v3 compliant SNMP manager
applications, such as those on your local computer, have read-only access to FortiSandbox system
information and can receive FortiSandbox system traps.

From here you can also download FortiSandbox and Fortinet core MIB files.

L

~9' When one plug is cut off, the unit will send out SNMP trap and generate a log.
= Only 3000D, 3000E and 3500D models are supported.

Configuring the SNMP agent

The SNMP agent sends SNMP traps that originate on the FortiSandbox system to an external
monitoring SNMP manager defined in one of the FortiSandbox SNMP communities. Typically an SNMP
manager is an application on a local computer that can read the SNMP traps and generate reports or
graphs from them.

The SNMP manager can monitor the FortiSandbox system to determine if it is operating properly, or if
there are any critical events occurring. The description, location, and contact information for this
FortiSandbox system will be part of the information an SNMP manager will have — this information is
useful if the SNMP manager is monitoring many devices, and it will enable faster responses when the
FortiSandbox system requires attention.

Go to System > SNMP to configure the SNMP agent.

Configure the following settings:

SNMP Agent Select to enable the FortiSandbox SNMP agent. When this is
enabled, it sends FortiSandbox SNMP traps.

Description Enter a description of this FortiSandbox system to help uniquely
identify this unit.

Location Enter the location of this FortiSandbox system to help find it in the

event it requires attention.

Contact Enter the contact information for the person in charge of this
FortiSandbox system.

SNMP v1/v2c Create new, edit, or delete SNMP v1 and v2c communities. You can
select to enable or disable communities in the edit page. The fol-
lowing columns are displayed: Community Name, Queries, Traps,
Enable

SNMP v3 Create new, edit, or delete SNMP v3 entries. You can select to
enable or disable queries in the edit page. The following columns are
displayed: User Name, Security Level, Notification Host, Queries.

Create a new SNMP v1/v2c community:

1. Goto System > SNMP .
2. Inthe SNMP v1/v2c section of the screen select Create New from the toolbar.



3. Configure the following settings:

Enable
Community Name

Hosts

IP/Netmask

Queries v1

Queries v2c

Traps v1

Traps v2c

SNMP Events

Select to enable the SNMP community.
Enter a name to identify the SNMP community.

The list of hosts that can use the settings in this SNMP community to
monitor the FortiSandbox system.

Enter the IP address and netmask of the SNMP hosts. Select the Add
button to add additional hosts.

Enter the port number and select to enable. Enable queries for each
SNMP version that the FortiSandbox system uses.

Enter the port number and select to enable. Enable queries for each
SNMP version that the FortiSandbox system uses.

Enter the local port number, remote port number, and select to
enable. Enable traps for each SNMP version that the FortiSandbox
system uses.

Enter the local port number, remote port number, and select to
enable. Enable traps for each SNMP version that the FortiSandbox
system uses.

Enable the events that will cause the FortiSandbox unit to send
SNMP traps to the community.
« CPU usage is high

o Memory is low

« Logdisk space is low
« Interface IP is changed
« Malware is detected

4. Select OK to create the SNMP community.

Create a new SNMP v3 user:

1.
2,
3.

Go to System > SNMP .

In the SNMP v3 section of the screen select Create New from the toolbar.
Configure the following settings:

Username

Security Level

Authentication

Method

Enter the name of the SNMPV3 user.

Select the security level of the user. Select one of the following:
« None

o Authentication only
« Encryption and authentication

Authentication is required when Security Level is either
Authentication only or Encryption and authentication .

Select the authentication method. Select either:
o MDS5 (Message Digest 5 algorithm)

« SHAT1 (Secure Hash algorithm)



Password Enter the authentication password. The password must be a
minimum of 8 characters.

Encryption Encryption is required when Security Level is Encryption and
authentication .
Method Select the encryption method, either DES or AES.
Key Enter the encryption key. The encryption key value must be a

minimum of 8 characters.

Notification Hosts (Traps)

IP/Netmask Enter the IP address and netmask. Click the Add button to add
additional hosts.
Query
Port Enter the port number. Select to Enable the query port.
SNMP V3 Events Select the SNMP events that will be associated with that user.

« CPU usage is high

+ Memory is low

« Logdisk space is low

« Interface IP is changed
+ Malware is detected

4. Select OK to create the SNMP community.

MIB files

To download MIB files, scroll to the bottom of the SNMP page, and select the MIB file that you would
like to download to your management computer.

FortiSandbox SMNMP MIB

Download FortiSandbox MIB File
Download Fortinet Core MIB File
FortiGuard

Go to System > FortiGuard to view the FortiGuard page.

The following options and information are available:

Module Name The FortiGuard module name, including: AntiVirus Scanner,
AntiVirus Extreme Signature, AntiVirus Active Signature,
Network Alerts Signature, Sandbox Engine, Android Analytic
Engine, Android Analytic Rating Engine and Traffic Sniffer.
All modules automatically install update packages when they are
available on the FDN.

Current Version The current version of the module.



Last Check Time
Last Update Time
Last Check Status

Upload Package File:

FortiGuard Server Location

FortiGuard Server Settings

Use over-
ride FDN
server to
download
module
updates

Use Proxy

Connect
FDN Now

FortiGuard Web Filter Set-
tings

Use over-
ride server
address
for web fil-
tering
query

Use Proxy

FortiSandbox Community
Cloud Settings

The time that module last checked for an update.
The time that module was last updated.
The status of the last update attempt.

Select Browse to locate a package file on the management com-
puter, then select Submit to upload the package file to the
FortiSandbox.

When the unit has no access to the Fortinet FDN servers, the
user can go to the Customer Service and Support site to down-
load package files manually.

Select FDN servers for package update and Web Filtering query.
By default, the selection is Nearest, which means the closest
FDN server according to the unit's time zone is used. When US
Region is selected, only servers inside Unite States are used.

Select to enable an override FDN server, or FortiManager, to
download module update, then enter the server IP address or
FQDN in the text box. For more information, see Server overrides
on page 28.

By default, the closest FDN server according to the unit's time
zone is used. Click Connect FDN Now button to schedule an
immediate update check.

Select to enable a Proxy. Configure the Proxy Type (HTTP Con-
nect, SOCKS v4, or SOCKS v5), Server Name, Port, Proxy User-
name, and Password.

Click the Connect FDN Now button to connect the override
FDN server/Proxy.

Select to enable an override server address for web filtering
query, then enter the server IP address (IP address or IP address:-
port) or FQDN in the text box. For more information, see Server
overrides on page 28.

By default, the closest web filtering server according to the unit's
time zone is used.

If port is not provided, target UDP port 53 will be used.

Select to enable a Proxy. Configure the SOCKS v5 server name
or IP, Port, Proxy Username, and Password.
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Use over-  Select to enable an override server port for community cloud.
ride server Enterthe port number in the text box.

port for

community You can toggle between port 53 and port 8888.

cloud

server

query
(Ex.8888)

Use Proxy Select to enable a Proxy. Configure the SOCKS v5 server name
or IP, Port, Proxy Username, and Password.

Select Apply to apply your changes.

Login Disclaimer

Go to System > Login Disclaimerto customize the warning message, and to enable or disable the
Login Disclaimer.

If enabled, the Login Disclaimer will appear when a user tries to login to the unit.

Settings

Go to System > Settings to configure and the administrator account idle timeout, that is, the amount
of time after which the user's login session will expire if there is no activity. You can also temporarily
change the GUI language to Japanese. After logging out and then back in, the language will be reset to
English.

» In this page you can select to reset all widgets in Dashboard, File Detection >
>\ Summary Report, Network Alerts > Summary Report, URL Detection > Sum-
mary Report.

Configure the idle timeout:

1. Goto System > Settings .
2. Enter avalue between 1 and 480 minutes.
3. Click OKto save the setting.

Reset all widgets:

You can reset all the widgets in the Dashboard by clicking the Reset button.

Job View Settings

Go to System > Job View Settings to define columns and their order applied in every job result page.
You can set number of jobs shown in each page, when view type supports pagination.

You can also determine how to load the next set of jobs. It can be one of three options:



Pagination
Infinite Scroll
Both (infinite scroll but also showing paging information)

Job Result pages show job data. They include but not limited to:

FortiView > File Scan Search page page

File Detection > URL Scan Search Files page

File Detection > File Scan page

File Detection > URL Scan page

Job links in Dashboard > Scanning Statistics widget

Selected columns, and their order, are displayed in the top row. Available columns are displayed in the
bottom row. Drag and drop columns to adjust their order.

Job result pages also have the Customize icon. Clicking it will open the Job View Setting page, where
the user can adjust the settings dynamically.

The File Detection Columns section defines the columns and the order to display file scan results. The
URL Detection Columns section defines the columns and the order to display URL scan results.

You can adjust column width, drag column headers to adjust their orders, and the change will be saved
for future visits. You can also use the column setting button in the job result page to change settings on
the fly and go back to original page.

~‘9"' Column settings is user based, which means different users have their own set-
= tings.

Job View Settings

[3 File Detection Columns

Customized Column Headers and Orders

Available Column Headers

% URL Detection Columns

Customized Column Headers and Orders

Available Column Headers

2= Table Settings

Page Size 50

Wiew Type Pagination  Infinite Scroll

The following columns are available to choose from for the View Job pages:



Action

Destination

Detection

Device
Filename

Infected OS

Job ID
Malware
MD5/SHA1/SHA256

Rated By

Rating

Scan Unit

Service

Source

Submitted Filename

Submit User

Suspicious Type

URL

Extra information, such as showing if a file is an archive
file, or the file is detected through AV Rescan. Users can
also view job details or perform a rescan of a Malicious file.

The IP address of the client that downloaded the file.

The date and time that the file was detected by FortiSand-
box.

The job's input source.
The file's name.

The OS version of the FortiSandbox VM that was used to
make the Suspicious verdict.

The ID of the scan job .
The name of the virus of a Malicious file.
The checksum values of the scanned file or URL.

The method by which the job is rated, such as the VM
Engine.

The rating of the scan job. It can be one of Malicious, High
Risk, Medium Risk, Low Risk, Clean and Unknown.

The serial number of the FortiSandbox unit which the file is
scanned on.

The traffic protocol that file is transferred, such as FTP,
HTTP, IMAP, POP3, SMB, OTHER and SMTP.

The IP address of the host where the file was downloaded.
The scan job's file name, or a file's parent archive file
name, or the submitted filename associated with an On-

Demand scan.

The user name or IP address who submits the scan file or
URL.

The malware's type, such Attacker, Riskware or Trojan.

The scanned URL. Only available in URL scan job pages



Virtual Machine

The FortiSandbox VM host is a based on a modified hypervisor. By default, every unit is installed with
Microsoft Windows XP Service Pack 3 (32-bit), Windows 7 (32-bit), and Windows 7 Service Pack 1 (64-
bit) VM images.

VM Host Support:

FSA-1000D Supports 8 VM hosts.

FSA-3000D Supports 28 VM hosts

FSA-3500D Supports 8 VM hosts.

FSA-3000E Supports 8 VM hosts by default, maximum up to 56 VM hosts

Users can also purchase, download, and install extra Android, Windows 8.1 and Windows 10 image
package. Official license is needed to use these extra images. Before an official license is installed, the
images cannot be used. FSA-VM is offered in a stackable license model and supports up to 54 VM
hosts, while FSA-VMOO is also offered a stackable license model and supports up to 8 VM hosts. The
following software is installed on each VM host:

« Adobe Flash Player

« Adobe Reader

« Java Run Time

¢ MSVC Run Time

o Microsoft .Net Framework

« Microsoft Office software (only on WINXPVM and WIN7X86VM)
« Web Browsers

~‘9"' By default, Fortinet provides license keys for installed Microsoft Office soft-

ware.

The number of supported VM hosts mentioned above of each model is for Win-
~‘9"' dows XP and Windows 7 images published by Fortinet. When using other VM
= types, such as Windows 10, Android or customized images, the number may
be less because of possible higher resource requirements of those types.

VM Status

Go to Virtual Machine > VM Status to view files currently scanned inside the VM. The page displays
the file name, and progress. Users can also click the VM Screenshot button, then the PNG Link button
to view a screenshot of running scan. If the scan allows VM interaction, users can click the VM Interact
icon to interact with the scan.
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~9' Making snapshots of scans or interaction with VM is only available when login
= useris admin.

VM Images

Go to Virtual Machine > VM Images to view all installed VM Images and configure the number of
instances of each image.

VM Images are grouped to three categories:

Default VMs Basic set of images installed on FortiSandbox by default. For FSA-
AWS model, it's the installed Windows VMs on AWS.

Optional VMs Fortinet published new VM images.
Customized VMs User created images and uploaded to FortiSandbox.
Remote VMs In this 2.4.1 release, only MACOSX is supported as remote VMs. It

has the hard-coded clone number of one. Each unit can only upload
one file to the MacOS Cloud to scan through Scan Input > File On-
Demand page.

When Fortinet publishes a new version of VM image on its image server, the image will show up in the
Optional VMs group. A download button will show up in Status column. Users can click the button to
start downloading. After the image has downloaded, a Ready to Install button will be displayed. When
the user clicks on it, all downloaded images will start installing. After installation, the system will reboot
automatically. Users can also click the Remove button to delete a downloaded image.

After an image is installed, its license key will be checked. If no key is available, the image's status will
be installed but disabled, until the key is installed and the image is activated. After the image is
activated, users can start using it by setting its clone number to be greater than 0. Thereafter, the
Image's status will become activated.

VM Images
TR Clone Number:/ 28 || @ Keys: /26 || I Enabled VM Types: /4 || [ VM Screenshot
Name Version  Status  EnabledClone &Load & Extensions
= Defaul:vMs (2/) (&)
I WINTXEEVM [} @ activated 8 8 pdf WEBLink
l# WINTXASWM 7 © activated g 9 exe msivbs bat cnd ps1jar
= Optional VMs (5 /)
L~ WINXPYM1 6 @ activated 1 1
[ WINXPVM 7 © activated 7 7 ppsx ppt pptx xls xlsx doc doox rtf dotx docm dotm xitx xlsm xitm xlsb xlam potx sldx pptm ppsm potm ppam sldm msg dot
l2  WINIOX86VM 2 & installed o ] exe msi bat cmd vhs ps1jar
l#  WINIOXE64VM 2 & installed o ] exe msi wbs bat emd ps1 jar WEBLink
e ndraidv @ 2 & activated o ] apk
= Customized WVMs (1) @
|+ win7xé4newtool 1 @ activated 0 Q pdf WEBLink
= Remote VMs (1}
|~ MACOSX 0 @ activated 1 1

The following options are available:



Edit Clone Number

Delete VM

Undelete VM

VM Screenshot

Select a VM Image and select Edit Clone Number from the toolbar to
edit the entry. Click the green checkmark to save the new number.
Then, click the Apply button to apply the changes.

Select a VM Image and select Delete VM from the toolbar to delete
the entry. The default set of four Windows VMS (WINXPVM,
WINXPVM1, WIN7X86VM, and WIN7X64VM) cannot be deleted.
Deleted VMs will only be deleted after the system reboots.

After deleting a VM you have the option to Undelete the VM to
recover it. After the system reboots and the delete action has been
completed, the user cannot undelete a VM.

Select to take a screenshot of a running VM, and the file name the
VM is scanning. The button is only available for admin user.

The following information is displayed:

Enabled VM Types

Keys

Clone Number

VM Usage

Name

Version

Max number of VM types that can concurrently run. It cannot exceed
four.

Max number of keys. It cannot exceed 25. Clone numbers of Android
VMs and customized VMs do not affect this result.

Max Clone number. It is the number of the installed Windows
license. For example, for FSA-3000D, the maximum clone number is
28. While on FSA-1000D and FSA-3500D, it is 8. For FSA-3000E, the
maximum clone number is 56.

When clicked, the VM Chart is launched. This chart displays a rough
percentage of used clones of this type across time. If the usage per-
centage is maintained at a high level across time, the user should
consider allocating more clone numbers to it.

Name of the VM Image. The name is unique in the system. If the
user uploads a new VM image of the same name, the current install-
ation will be replaced.

A Chart icon is located beside the Name column on the left side.
When you click on the Chart icon, the VM’s usage chart will appear.

VM Image version. If a new version of an image is published on the
Fortinet Image Server, a New Version Available icon will appear.
Users can download, install and activate it.



Status

Enabled

Clone#

Load#

Extensions

VM Image status. A VM image can be one of the following statuses:
+ Ready to Download

+ Readyto Upgrade

« Downloading (shows a progress bar)

« Ready to Install (Install or Remove downloaded image)
« Installing

o Installed (Disabled)

« Installed (No Key Available)

« Activated

Number of enabled VMs. If an image's clone number is 0, it is dis-
abled. Otherwise it is enabled.

VM Clone number. The user can double click the number to edit it,
then click the green check mark to save the new number. Click Apply
to apply the change. The VM system will initialize again. The total
clone number of all VM images cannot exceed the number of
installed Windows license(s). For example, for FSA-3000D, the max-
imum clone number is 28.

The used VM Clone number in fact. For example, if a Cluster Master
node is set to use 50% of sandboxing scan power, the Load # will be
half of Clone #.

List of all the file types the VM image is associated with. It means
files of these types will be scanned by this VM if these types are
determined to enter the job queue. The system decides if they need
to be sandboxed.

If prefiltering is turned off for a file type, it will be scanned inside each
associated VM type. If prefiltering is turned on, files of this file type
will be statically scanned first by an advanced analytic engine and
only non-suspicious ones will be scanned inside associated VM type.

File type and VM association can be defined in the Scan Policy >
Scan Profile page. Users can double click the value to access the
Scan Profile page to edit the list.

For FSA-VM and FSA-VMO00 models, enabled clone numbers will be checked
against allocated CPU and memory resources. If they are not enough, a warn-
ing message will appear. Fortinet recommends that the number of CPU cores
be four more than the number of Windows VMs, and 3GB of RAM be allocated
per enabled Windows VM clone.

Clone Number for VM Image

By default, the clone number for the VM image(s) is set to the following:



FSA-1000D, FSA-3500D and FSA-3000E

VM Image Number of Clones

WINXPVM 4

WINXPVM1 0

WIN7X64VM 2

WIN7X86VM 2

FSA-3000D

VM Image Number of Clones

WINXPVM 14

WINXPVM1 0

WIN7X64VM 7

WIN7X86VM 7

~‘9"' For FortiSandbox devices purchased after March 17, 2017, WINXP VM type
= and its licenses are no longer supported due to Microsoft EOL.

The user can change the default settings according to the majority of file types in their environment. For
example, if the majority file type is Office files and WINXPVM is associated with Office files, the user
can decrease the clone number of other VM images and increase the clone number of the WINXPVM
image.

In a cluster environment, clone numbers should be configured individually on each node as their models
might be different.

VM Screenshot

When the user admin clicks the VM Screenshot button, all currently running guest images along with
the processed file name will be displayed. Click the VM Screenshot button, then the PNG Link button
to view a screenshot of running clones. Clicking on the Refresh button in upper left corner of the popup
window will refresh the running image list.

This feature is useful to troubleshoot issues related to guest images.

Ay

~9, This button is only available when login user is admin.




Scan Policy

Scan Profile

The profile page allows you to configure the types of files that are put into the job queue. It also allows
you to configure the VM image to scan pre-defined file types and user defined file types.

By default, all Images sections are expanded.

ScanProfile

Put files /URLs from sniffer, netwark share and devices of the following types tojob queue
@ Executables (@ PDFdocuments (@ | [ Officedocuments (@ | [ Flashfiles (@ | B Webpages ® [ Compressedarchives (® | # Androidfiles (@
&  Userdefined extensions (@

% URLdetection (@
MaximumURL: -1
Default Depth: [0

Default Timeout: (86400

— win7xé4newtool Clone#:6
£33 Installed Applications. [E: Scanned File Types
Cannot fetch the information for installed applications WEBLink
£22 Installed Applications [ Scanned File Types
Adobe AIR 104990 L
Adobe AIR 108.4990 “
Adobe Flash Player 15 Plugin 15.00.152
Adobe Reader 9
Adobe Reader 9 9.0.0
Hotfix for Microsoft NET Framework 3.5 SP1(KB953595) 1 <
ooy |

FortiSandbox, by default, supports the following file types:

Executables BAT, CMD, DLL, EXE, JAR, MSI, PS1, UPX, WSF, and VBS.

Most DLL files cannot be executed within a VM, it is recommended

to turn on its Pre-Filtering with the following CLI command:
sandboxing-prefilter -e -tdll

Only the DLL files which can be executed inside a VM will be put into

the Job Queue.

Archives 7Z, ARB, BZIP, BZIP2, CAB, EML, GZIP, LZW, RAR, TAR, XZ and
more

Microsoft Office Word, Excel, PowerPoint, Outlook and more

Adobe PDF, SWF, Flash



Static Web Files HTML, JS, URL, LNK

Android File APK

Scan Profile Part One

The first part of the Scan Profile page is to define file types and URLSs that are allowed to enter the job
queue if they are from a sniffer, device, adapter and/or network share.

N If files or URLs are submitted through On-Demand or RPC JSON API, they will
9 always be put into the job queue, even if their file types are not set to enter the
= job queue.

To allow a file type to enter the job queue

Click its toggle button on the right side to enable it.If the button is greyed out, files of that type will be
dropped.

URL Detection

When URL detection is enabled, it means FortiSandbox will scan URLs (WEBLinks). The user can also
define default settings of depth FortiSandbox should visit the URL and the default timeout value that
FortiSandbox should stop even when not all web page have been scanned.

If FortiSandbox unit has a long queue of pending jobs, user should consider
turning off certain file types to job queue. For example, in most network envir-
onment, static web files (JavaScript, html, aspx files etc) and Adobe flash files
Mo consist of a big part of all files. When performance issue is met, user can con-
9 sider turning them off.

If afile type is turned off, files of this type already in the job queue will still be
processed. Users can use the pending-jobs CLI command or Scan Input >
Job Queue page to purge them if needed.

\ M To find out number of each file type and input source, user can use CLI com-
N\ mand pending-jobs or Scan Input > Job Queue page.

Scan Profile Part 2

The second part is to define file type and VM image association. Association means files of a certain
file type will be sandboxed by the associated VM image. This part shows all installed VM image(s), their
clone numbers, version and status.

>{‘ If a VM type is disabled (clone # is 0), its Clone # field will be red.

To configure association

Click the VM image’s name. The left side panel shows installed applications and right side panel shows
current associated file types.



Note: for an associated file to be sandboxed in the VM image

~‘9", a. lItsfile type has to be configured to enter a job queue
= b. The VM image has a non-zero clone number (i.e.: it is
enabled)

If sandboxing pre-filtering is OFF for a file type, it will be scanned by each associated VM type; if
sandboxing pre-filtering is ON, files of this file type will be statically scanned first by an advanced
analytic engine and only suspicious ones will be scanned by associated VM type. Other files go through
all scan steps except the Sandboxing scan step. For example, the user can associate web filters to VM
types. If the sandboxing pre-filtering is OFF, by default, all of them will be scanned by associated VM
types. This may up the system sandboxing scan capacity because web files are usually in large in size.
It is recommended to turn on sandboxing pre-filtering for web files.

To improve the system scan capacity, users can turn on the pre-filtering of a file type through the
sandboxing-prefilter CLI command. For more details, refer to the FortiSandbox 2.4.1 CLI
Reference Guide.

To edit associated file type

1. Click right side panel and a popup file type list will show up.

2. File types are grouped to different categories. Clicking the category title will toggle associations of all
grouped file types. Clicking on individual file type will toggle its own association. When the file type is
displayed in full length, it means the file type is associated.

Add a user defined extension

Make sure the user defined extension is enabled.

1. Click + sign and type a non-existing extension

2. Click the green check mark. The user can then click on the new extension to toggle its association.
Finalizing the list of Scanned File Types

1. After the user has finished the association configuration, click the Scanned File Types panel to finalize
the list for double check.

2. Click Apply button to apply the changes. User can also click Apply button to apply changes directly.
Files will then be scanned by associated VM images.

For files with a user defined extension, they will be scanned by a VM image no
~‘9"' matter what file types they really are. During scan, the file will be opened with
= associated software pre-defined by VM image. For example, if FireFox is asso-
ciated with HTML files, HTML files will be opened by FireFox.

FortiSandbox provides default scan profile settings. To be specific

« WINXPVM: Office files, Adobe Flash files
o WIN7X86VM: Adobe PDF files
o WIN7X64VM: Executable files



In a cluster environment, it is highly recommended that all cluster nodes have
the same list of enabled VM images, although it is not enforced.

If cluster nodes do not have the same list of enabled VM images, a warning
message will show up on top of the Scan Profile page for five seconds.

The Scan Profile can only be configured on the Master node and the con-
figurations will be synced to slave nodes. Master node will collected all installed
VM image information. If a different VM image is only installed on a slave
node, the user can still configure on the Master node and the result will be syn-
chronized to that Slave node.

Link file types in Static Web files group is for shortcuts to a webpage or URL.
While WEBLink types in URL detection group are for URL scans, which follows
depth and timeout settings in Scan Profile Part 1

A

There might be malicious URLs inside Office files and PDF files. Users can
choose to scan randomly selected URLs with the original file altogether inside a
VM image. To turn this feature ON, use the sandboxing-embeddedurl
CLI command. For more details, refer to the FortiSandbox 2.4.1 CLI Refer-
ence Guide.

File Scan Priority

Files of different file types and input sources have different processing priority. Priority means, under
the same situation, files in the high priority queue will be processed first before those in the low priority
queue. This means if a VM image is configured to scan two different job queues, the job queue with
high priority will be scanned first and only when this queue is empty, the low priority job queue will be
processed. Therefore, it is recommended that different job queues are associated with different VM
image(s). In this release, job queue priority is hard coded to be:

Files from On-Demand/RPC
sniffer/device submitted executable files

user defined file types

sniffer/device submitted Office files
sniffer/device submitted PDF files
sniffer/device submitted Android files
URLs of all sources

device submitted Adobe flash/web files
sniffer submitted Adobe flash/web files
Adapter submitted files

Network share submitted files

File Scan Flow

After a file is received from an input source, it goes through the following steps before a verdict is
reached. If a verdict can be reached at any step, the scan will stop.

1. Filtering and Static Scan
In this step, the file will be scanned by the Anti Virus engine and the YARA rule engine. Its file type
will be compared with the Scan Profile page, Part One settings to decide if it should be put in the
job queue. If yes, it will be compared with the Black/White list and overridden verdict list.



For certain file types, such as Office and PDF files, they will be scanned statistically in virtual
engines to detect suspicious contents. If they contain embedded URLs, the URLs will be checked
to see if the website is a malicious website.

2. Community Cloud Query

The file will be queried against the Community Cloud Server to check if an existing verdict is
available. If yes, the verdict and behavior information will be downloaded. This makes the malware
information shareable amongst the FortiSandbox Community for fast detection.

3. Sandboxing Scan

If the file type is associated with a VM type, as defined in the Scan Profile page, Part Two, the file
will be scanned inside a clone of that VM type. Afile that is supposed to be scanned inside a VM
might skip this step if it's filtered out by sandboxing prefiltering. For more information, see the
FortiSandbox CLI Guide for the sandboxing-prefiltering command.

URL Scan Flow

After an URL is received from an input source, it goes through the following steps before a verdict is
reached. If a verdict can be reached at any step, the scan will stop.

1. Static Scan
In this step, the URL is checked against the Overridden Verdict list.

2. Sandboxing Scan

If WEBLInk is associated with a VM type as defined in Scan Profile page, Part Two, the URL will
be scanned inside a clone of that VM type. If the URL type is enabled for sandboxing pre-
filtering command, only URLs whose webfiltering category is UNRATED will be scanned
inside a VM. For more information, please refer to the FortiSandbox CLI Guide, for the
sandboxing-prefiltering command.

R The URL will be checked against the user uploaded white domain list and black
9 domain list. If the domain of the URL falls into them, the URL will be rated as
= Clean or Malicious respectively.

General

Go to Scan Policy > General to view and configure the General Options.



General Options

Upload Settings
Upload malicious and suspicious file information to Sandbox Community Cloud
Submit suspicious URL to Fortinet WebFilter Service
# Upload statistics data to FortiGuard service
# Allow Virtual Machines to access external network through outgoing port3
Status: L]
Port3 [P:
Gateway:
Disable SIMMET if Wirtual Machines are not able to access external network through cutgoing port3
DINS:
Use Proxy
# Apply default passwords to extract archive files

Password list:

Disable Community Cloud Query
Disable AV Rescan of finished jobs
# Enable URL callback detection
Enable log event of file submission
# Devices
Adapter
Metwork Share
¥ ICAP
# Reject duplicate file from device
Delete eriginal files of Clean or Other rating after
Delete eriginal files of Malicious or Suspicious rating after

# Delete all traces of jobs of Clean or Other rating after

Day (0-27): 7
Hour: o
Minute: ]

Delete all traces of jobs of Malicious or Suspicious rating after

The following options are available:

Upload malicious and sus- Enable to upload malicious and suspicious file information to the
picious file information to Sandbox community Cloud. If enabled, the file checksum, tracer
Sandbox community Cloud log, verdict, and original files are uploaded.

Submit suspicious URL to Enable to submit malware downloading URL to the FortiGuard
the Fortinet WebFilter Ser- Web Filter Service.
vice



Allow Virtual Machines to
access external network
through outgoing port3

Status
Gateway

Disable
SIMNET if Vir-
tual Machines
are not able
to access
external net-
work through
outgoing
port3

DNS

Use Proxy

Proxy Type

Enable to allow Virtual Machines to access external network
through the outgoing port3.

If the VM cannot access the outside network, a simulated network
(SIMNET) will start by default. SIMNET provides responses of pop-
ular network services, like ht tp where certain malware is expec-
ted. If the VM internet access is down, beside the down icon,
SIMNET status is displayed. Clicking it will enter the VM network
configuration page.

FortiSandbox VM accesses external network through port3. The
next-hop gateway and DNS settings can be configured in Scan
Policy > General > Allow Virtual Machines to access external
network through outgoing port3.

Port3 status.
Enter the next hop gateway IP address.

Enable to disable SIMNET when Virtual Machines are not able to
access external network through the outgoing port3.

DNS server used by VM images when a file is scanned.

Enable to use the proxy. Configure the Proxy Type, Server
Name/IP, Port, Proxy Username, and Proxy Password.

When the proxy server is enabled, all the non UDP outgoing traffic
started from Sandbox VM will be directed to the proxy server.

When a proxy server is used, if the proxy server type is not
SOCKS, the system level DNS server is used. If the type is
SOCKSS5, users need to configure an external DNS server that
port3 can access.

For other traffic started by FortiSandbox firmware, such as
FortiGuard Distribution Network (FDN) upgrades, the con-
figurations should be done under the Network menu.

Select the proxy type from the drop-down list. The following
options are available:
o HTTP Connect

« HTTP Relay
o SOCKS v4
o SOCKS v5; requires DNS.

UDP protocol is not supported.



Server
Name/IP

Port

Proxy User-
name

Proxy Pass-
word

Apple default passwords to
extract archive files

Disable Community Cloud
Query

Disable AV Rescan of fin-
ished Jobs

Enable URL call back detec-
tion

Enable log event of file sub-
mission

Devices
Adapter
Network
Share

ICAP

Reject duplicate file from
device

Delete original files of Clean
or Other rating after

Day

Hour

Enter the proxy server name or |P address.

Enter the proxy server port number.

Enter a proxy username.

Enter the proxy password.

User can define a list of passwords that can be tried to extract
archive files. Input passwords line by line.

By default the Cloud Query is enabled. Disable the Cloud Query in
the following scenarios:
« You have an enclosed environment. Disabling the Cloud

Query will improve the scan speed.
« You receive an incorrect verdict from the Cloud Query and
before Fortinet fixes it, you can turn it off temporarily.

AV signature updates are frequent (every hour). Running an

AV rescan against finished jobs of the last 48 hours could hinder
performance. You have the option to disable the AV Rescan to
improve performance.

Enable URL call back detection. When enabled, previously detec-
ted clean URLs in sniffered traffic are frequently rated.

Enable to log the file submission events of an input source.
Select to log the file submission events of a device, like FortiGate,
FortiMail or FortiClient.

Select to log the file submission events from an adapter like a Car-
bon Black server.

Select to log the file submission events when they are from a net-
work share.

Select to log the file submission events from an ICAP client.
Enable to reject duplicate files from devices.

Enable to delete original files of Clean or Other ratings after a spe-
cified time. If the time is 0, the original files with either Clean or
Other ratings will not be kept on the system. Original files of
Clean or Other rating can be kept in system for a maximum of 4
weeks.

Enter the day.

Enter the hour.



Minute Enter the minute.

Delete original files of Mali- Enable to delete original files of Malicious or Suspicious ratings
cious or Suspicious rating after a specified time.
after

Day Enter the day.

Hour Enter the hour.

Minute Enter the minute.

Delete all traces of jobs of Enable to delete all traces of jobs of Clean or Other ratings after a
Clean or Other rating after specified time. Traces of jobs with Clean or Other rating can be
kept in system for a maximum of 4 weeks..

Day Enter the day.
Hour Enter the hour.
Minute Enter the minute.

Delete all traces of jobs of Enable to delete all traces of jobs of Malicious or Suspicious rat-

Malicious or Suspicious ings after a specified time.
after

Day Enter the day.

Hour Enter the hour.

Minute Enter the minute.

If the user upgrades from a previous version, the user will have to go to Scan
Policy > General to configure the network settings in order for the Windows VM

~‘9"' to be able to access the internet.
If the Windows VM connection is down, the Dashboard > System Information
widget > VM Intermet Access field will reflect this.
~‘9"' By default, job traces of files with a Clean or Other rating will be kept for three
= days.

How to improve system scan performance

There is a limited number of files that a unit can process within a time period. There are certain ways to
improve the unit’s scan power

a. Only keep jobs with Clean rating for a short period. If the user is not concerned about processed
files with a Clean rating, the user can configure the system to remove them after a short period.
This will save the system resource and improve system performance. To do that, go to Scan
Policy > General, and configure Delete all traces of jobs of Clean or Other rating after.



b. Turn on Pre-Filtering for certain file types. By default, if a file type is associated with a Windows

VM image, all files of this file type will be scanned inside it. Sandboxing scans inside Windows
VM is a slow and expensive process.

For example, a FSA3000D unit can only scan 560 files/hr inside VM on average. Users can
enable Pre-Filtering on certain file types. If it is enabled, files of that file type will be pre-
filtered and have a Clean rating; only suspicious ones will be scanned inside a VM.

The following file types support Pre-Filtering: DLL, PDF, SWF, JS, HTML, URL.

For URL type, if Pre-filtering is enabled, only URLs whose web filtering category is Unrated
will be scanned inside VM.

. Associate every file type to only one VM type. Theoretically, one file should be scanned inside

all enabled VM types to get best malware catch rate. However, to improve scan performance,
every file type should be associated with only one VM type.

. Allocate clone numbers of each VM type according to distribution of file types.

Each unit can only prepare limited number of guest image clones. The number is
determined by installed Windows license keys. Users should allocate clone numbers
according to distribution of file types.

For example, if there are a lot of Office files and WINXPVM is associated with Office files,
user can decrease clone number of other VM types and increase the clone number of the
WINXPVM image. If the user sees a large number of pending jobs, he can use pending-
jobs CLI command, or go to Scan Input > Job Queue page, to find out files of which file
type is the most waiting in the queue and increase clone numbers of its associated VM
type. See Job Queue on page 109 for more information.

White/Black Lists

White and black lists help improve scan performance and malware catch rate and reduce the false
positive and can be appended to, replaced, cleared, deleted, and downloaded. The lists contain the
file's checksum values (MD5, SHA1, or SHA256 checksums, and the file's download domain). Users can
put trusted domains in the White List to improve performance. Wild Card formats, like * . domain, is
supported. For example, when the user adds windowsupdate.microsoft.com to the White
Domain List, all files downloaded from this domain will be rated as Clean files immediately. If the user
adds * .microsoft.comtothe White Domain List, all files downloaded from sub-domains of
microsoft.com will be rated as Clean immediately.

L]

By BlackLists: L

If a white list entry is hit, the job rating will be Clean with a local overwrite flag.

If a black list entry is hit, the job rating will be Malicious with a local overwrite flag. Malware names will be
FSA/BL_DOMAIN, FSA/BL_MD5, FSA/BL_SHA1, or FSA/BL_SHA256.

If the same entry exists on both lists and is hit, the black list will take priority and the file will be rated
Malicious.

White / Black List

B White Lists: X 3488567..669c43f fpdownl...obe.com

www.google.com www.yahoo.com




To manage the White/Black list manually:

Go to Scan Policy > White/Black List.
Click the White or Black list panel, the Detail panel will slide out from the right side.
Click the head of each type to expand or collapse the list.

PoODd =

Click the + button to add a new entry.
Alternatively, click the Trash button to either remove the whole list or remove a single entry.

5. Click outside the Detail panel to accept the change.

To manage the White/Black list through files:

. Goto Scan Policy > White/Black List.
2. Click the File Upload button for either the White List or Black List.
3. Select the list type from the drop down menu:
o Domain
« MD5
« SHA1
« SHA256
4. Select the Action to take from the drop down menu:
« Append: Add checksums to the list.
« Replace: Replace the list.
« Clear. Remove the list.
« Download: Download the list to the management computer.
« Delete: Delete an entry from the list if the entry is in the uploaded file.
5. If the action is Download, click OK to download the list file to the management computer.

6. If the action is Append or Replace, click Choose File, locate the checksum file on the management
computer, then click OK.

7. If the action is Clear, click OK to remove the list.

Ay

~9' In a Cluster setting, White/Black lists should only be created on the Master
= node.

Overridden Verdicts

The Overridden Verdicts page displays jobs that the user has manually marked them as False Positive
or False Negative. Job IDs, Job Finish Time, and the time that the user manually marks the verdict
will be displayed. If the job's detailed information is still available, the user can click on Job ID to display
them.

Users can easily delete a FP/FN verdict in this page without having to revert the FP/FN verdict in the
Job Detail page.

Overridden Verdicts
ﬂ Delete

FPN Job Detected Time Override Time
2092455118275295516 N/A Jan 202015 15:56:01

@ 2217051432347746846 N/A Apr 142015 15:18:14



YARA Rules

YARA is the third scan engine, which is a pattern matching engine for malware detection. The YARA
Rules page allows you to upload your own YARA rules. The rules must be compatible with the 3.x
schema and put inside ASCI| text files.

The following options are available:

Import Select to import a YARA rule file. You can apply one YARA rule to
multiple file types.

Edit Select to edit a YARA rule file. You can apply one YARA rule to mul-
tiple file types.

Delete Select to delete a YARA rule file.
Change Status Select to change the status (Active or Inactive) of a YARA rule.
Export Select to export a YARA rule file.

The following information is displayed:

Name The name of the YARA rule.

File Type The file types the YARA rule is applied to.

Modify Time The date and time the YARA rule was last modified.

Size The size of the YARA rule.

Sha256 The Sha256 number.

Status The current status (Active or Inactive) of the Inactive or Active YARA

rule. Click the icon to toggle the status.

To upload YARA Rule File:

Go to Scan Policy > YARA Rules.
2. Select Import.
3. Configure the following settings:

YARA Rule Name Enter a name for the YARA rule set.

Default Description Enter a description of the YARA rule set.



Rules Risk Level Select a rule risk level between 1-10.

0-1: Clean

2-4: Low Risk
5-7: Medium Risk
8-10: High Risk

All the YARA rules inside the YARA rule file will share the same risk
level.

File Type Select file types to scan against uploaded YARA rules. One YARA
rule file can be applied to multiple file types.

YARA Rule File Choose a text file containing YARA rules.

4. Select OKtoimport rules.

5. Aftera YARA Rule File is imported, you can select the Activate/Deactivate icon to enable/disable the
YARA rule.

If you want the same set of rules to match more than one file type, you should import the file more than

once; for each import, set a different file type to match.

R If a file hits multiple rules, a complicated algorithm is used to calculate the final
9 rating of the file. For example, if a file hits more than one Low Risk YARA rules,
= the file's verdict can be higher than the Low Risk rating.

To edit a YARA Rule:

1. Goto Scan Policy > YARA Rules.
2. Select a YARA Rule.
3. Click the Edit button from the toolbar.



4. Configure the following options:

ID
Yara Rule Name

Default
Description

Rules Risk
Level

File Type

YARA Rule File

YARA ID number. You cannot edit this field.
Enter a name for the YARA rule set.

Enter a description of the YARA rule set.

Select a rule risk level between 1-10.

0-1: Clean

2-4: Low Risk
5-7: Medium Risk
8-10: High Risk

All the YARA rules inside the YARA rule file will share the same risk
level.

Select file types to scan against uploaded YARA rules. One YARA rule
file can be applied to multiple file types.

Choose a text file containing YARA rules.

5. Click OKto apply changes.

To delete a YARA rule:

P obd =

Go to Scan Policy > YARA Rules.
Select a YARA Rule.
Select Delete from the toolbar.

Click Yes I'm sure button from the Are you sure? confirmation box.

To change the status of a YARA rule:

The status of the selected YARA rule will switch to Active or Inactive depending on its previous

1. Goto Scan Policy > YARA Rules.
2. Select a YARARuUle.
3. Select Change Status.
status.
URL Category

Go to Scan Policy > URL Category to define specific URL categories as non-suspicious. URLs of
these categories will be treated as Clean. By default, the following categories are in the list:

Drug Abuse

Explicit Violence
Abortion

Other Adult Materials
Advocacy Organizations
Gambling



o Extremist Groups

« Pornography

« Dating

« Weapons (sales)

« Homosexuality

« Marijuana

« Alcohol and Tobacco

Benign URL Category

Treat the following URL Abortion
categories as benign, excluding advocacy Oreanizations
Mazlicious Websites, Phishing '

and Spam URLs: Aleohol

Alcohol and Tobacco
Child Abuse

# Dating
Discrimination
Drug Abuse
Explicit Violence
Extremist Groups

Gambling

Y

Grayware

Hacking
Homosexuality
llegal or Unethical

Marijuana

Y

Mudity and Risque
Occult

%

Other Adult Materials
Plagiarism
Pornography

Tobacco

¥ Weapons [Sales)

Supporting URL Pre-Filtering

Devices like FortiMail can be configured to send all DLL files inside an Email body to FortiSandbox. By
default, all of them will be scanned inside the VM. However, if performance is a concern, users can turn
on URL Pre-Filtering.

When URL Pre-Filtering is enabled, it will work together with the Scan Profile settings and URL
Category settings.

Scenarios
URL Sandboxing Pre-Filtering is Enabled

a. If the category or URL is Unrated, the URL will be scanned inside the VM.

b. If the URL's category is not defined as Benign in the Scan Policy > URL Category page, a job
will be created and the URL will be rated as High Risk

c. Ifthe URL's category is defined as Benign in the Scan Policy > URL Category page, a job will
be created and the URL will be rated as Clean and will not be scanned inside the VM.



URL Sandboxing Pre-Filtering is Disabled

In this case, all URLs will be scanned inside the VM. For more information, see the FortiSandbox CL/
Guide for the sandboxing-prefiltering command.

Customized Rating

The Customized Rating page allows you to set verdicts for the following cases: VM Timeout, Tracer
Engine Timeout, and Unextractable Encrypted Archive.

The following options can be configured:

VM Timeout Windows VM cannot be launched properly. This usually
occurs on FSA-VM model running on hardware with limited
resources.

Select one of the following ratings:
« Unknown

o Clean

« Malicious

o Low Risk

o Medium Risk
« High Risk

Tracer Engine Timeout Tracer engine is not working properly. For example, the
malware crashes the Windows VM or kills the tracer engine
process. Thus, the tracer log is not available.

Select one of the following ratings:
« Unknown

o Clean

« Malicious

o LowRisk

o Medium Risk
« High Risk

Unextractable Encrypted Archive The archive file is password protected and cannot be extrac-
ted with a predefine password list set in the Scan Policy >
General page.
Select one of the following ratings:
o Unknown

o Clean

« Malicious

o Low Risk

o Medium Risk
« High Risk



Job Archive

The Archive page allows you to adjust the archive location settings. Archive location is a network share
folder. Archiving job information is useful when processing job files and data with third party tools.

Go to Scan Policy > Job Archive to view the Archive Location page.

Archive Location

Enabled

Mount Type:

Server Name/IP:

Share Path:

Username:

Password:

Confirm Password:

File Name:

Folder Structure:

Save metadata
Save tracer log

Save Malicious rating jobs

Save Suspicious rating jobs

Save Clean rating jobs

Save Unknown rating jobs

CIFs M

<script=alert]'1)</script>

hpathl
Scan Job ID as File Name T
Save all files in the same folder T

“ Test Connectivity | | Restore Default

The following options can be configured:

Enabled

Mount Type

Server Name/IP
Share Path

Username

Password

Confirm Password

Select to enable the job archive feature.
Select the mount type of the network share folder. The following

options are available:
o CIFS

o« NFSv2
e NFSv3
« NFSv4

Enter the server fully qualified domain name (FQDN) or IP address.
Enter the file share path in the format of /pathl/path2.

Enter a user name. The username should have the write privilege of
the remote network share folder.

Enter the password.

Enter the password a second time for verification.



File Name

Folder Structure

Save meta data
Save tracer log

Save Malicious rating
jobs

Save Suspicious rating
jobs

Save Clean rating jobs

Save Unknown rating
jobs

Select the file name from the drop-down list. The following options
are available:
« Scan Job ID as File Name

« Original File Name
Select the folder structure from the drop-down list. The following

options are available:
« Save all files in the same folder

« Save file in folders of the scan finish time
« Save file in folders of ratings

When selected, the job summary information will be saved.
When selected, the job's tracer log will be saved.

When selected, files of Malicious rating will be saved.

When selected, files of Suspicious rating will be saved.

When selected, files of Clean rating will be saved.

When selected, files of Unknown rating will be saved.

Package Options

The FortiSandbox can generate antivirus database packages (malware packages) and blacklist URL
packages from scan results, and distribute them to FortiGate devices and FortiClient end points for
antispyware/antivirus scan and web filtering extension to block and quarantine malware.

This feature requires that:

« The FortiGate device, running FortiOS 5.4 or later, is authorized on the FortiSandbox

« The FortiClient end point is running version 5.4 or later and has successfully connected to the
FortiSandbox, and

« FortiSandbox is running version 2.1 or later.

The FortiGate or FortiClient sends a malware package request to FortiSandbox every two minutes that
includes its installed version (or 0.0, if none exists). The FortiSandbox receives the request then
compares the version with the latest local version number. If the received version is lower,
FortiSandbox sends the latest package to the FortiGate or FortiClient. If the versions are the same,
then FortiSandbox will display an already-up-to-date message.

A new package is generated when:

« The FortiSandbox has a new malware detection whose rating falls into an already configured rating. The
new detection can be from local or from another unit if this unit joins a Global Threat Information
Network.

« Malware in the current malware package is older than the time set in the malware package configuration.
« The malware package generation condition is changed in the configuration page.



« The malware's rating has been overwritten locally by a black list, white list, or False Positive/False

Negative (FPN) mark.

Malware and URL Package Options

The malware package options allow you to configure how many days worth of data that the malware
packages save and the malware ratings that are included in the packages. It also defines where the
malware information is from. It can be either from local detection, or from other units if the unit joins a
Global Threat Information Network.

The URL package contains downloaded URLs of detected malware.

Mode

Working As

Collector IP
Address

Alias

Authentication
Code

Show Con-
tributors

Select either Global or Local.

Global mode means the unit joins a threat information sharing net-
work and generate packages with threat information from all units
in the network.

Local mode means the unit only uses local detections to generate
packages.

This options is only available in Global mode.

Select either Collector or Contributor, and configure its respective
settings. In the Global mode, the unit can work either as threat
information Collector or Contributor.

In a Global network, only one Collector can exist. Collector
should set authentication code to improve security.

The Collectorlistens on TCP port 2443 and the traffic between
Contributor and Collector is encrypted.

Contributors upload detected malware information with Malicious
and Suspicious ratings to Collector and download malware inform-
ation from other Contributors to local. Each Contributor can con-
figure what to include in its own generated malware packages and
STIX10C package.

Enter the collector IP address.
Only available when Contributor is selected.

The Collector's Alias.

Enter the authentication code of the Collector.

Enable to display the list of contributors.
Only available when Collectoris selected.

After the units receive threat information, packages can be generated locally with the fol-

lowing options:
Malware Package Options



Include past __ day(s) of
data. (1-365 days)

Include the job data of the
following ratings

Malicious

High Risk
Medium Risk
URL Package Option

Include past __ day(s) of
data. (1-365 days)

Include the job data of the
following ratings

Malicious

High Risk
Medium Risk

Enable STIX 10C

Enter the number of days.

Include malware with malicious ratings.

By default, only data with Malicious or High Risk rating will be
included in the Malware Package.

Include malware with high risk ratings.

Include malware with medium risk ratings.

Enter the number of days.

Include downloaded URLs of malware with malicious ratings.

By default, only downloaded URLs of malware with a Malicious or
High Risk rating will be included in the URL Package.

Include downloaded URLs of malware with high risk ratings.
Include downloaded URLs of malware with medium risk ratings.

Enable to generate STIX I0OC packages.

STIX Malware Package Options

Include past __ day(s) of
data. (1-365 days)

Include the job data of the
following ratings

Malicious
High Risk
Medium Risk

Download
STIX

STIX URL Package Options

Enter the number of days.

Include malware with malicious ratings.
Include malware with high risk ratings.
Include malware with medium risk ratings.

Download most recently generated Malware STIX |OC package.



Include past __ day(s) of Enter the number of days.
data. (1-365 days)

Include the job data of the
following ratings

Malicious Include malware with malicious ratings.

High Risk Include downloaded URLs of malware with high risk ratings.
Medium Risk Include downloaded URLs of malware with medium risk ratings.
Download Download most recently generated URL STIX 10C package.
STIX

Because of size limitation, malware packages can only have 100K entries at
the most.

Because of size limitations, URL package can only have 1000 entries at the
most.

I0C Package

Indicator of Compromise (IOC), in computer forensics, is an artifact observed on a network or in an
operating system which indicates a computer intrusion. Typical IOCs are virus signatures and IP
addresses, malware files or URLs MD5 hashes, or domain names of botnet command and control
servers. In order to share, store and analyze in a consistent manner, Structured Threat Information
Expression (STIX™) is commonly adopted by the industry.

FortiSandbox supports IOC in STIX v1.2 format. Two types of |IOC packages are generated:

a. File Hash Watchlist package contains the Malware's file hash and is generated along with each
Malware package. If the malware is detected in local unit, behavioral information is also
included. The most recent package can be downloaded from the Scan Input > Package
Options page.

b. URL Watchlist package contains the Malware's download URL and is generated along with each
URL Package. The most recent package can be downloaded at Scan Input > Package Options
page.

The following is a example snippet of a File Hash Watchlist ICO package in STIX format:

<stix:STIX Package

xmlns:
xmlns:
xmlns:
xmlns:
xmlns:
xmlns:
xmlns:
xmlns:

xmlns

FileObj="http://cybox.mitre.org/objects#FileObject-2"
FortiSandbox="http://www.fortinet.com"
cybox="http://cybox.mitre.org/cybox-2"
cyboxCommon="http://cybox.mitre.org/common-2"
cyboxVocabs="http://cybox.mitre.org/default vocabularies-2"
indicator="http://stix.mitre.org/Indicator-2"
stix="http://stix.mitre.org/stix-1"
stixCommon="http://stix.mitre.org/common-1"

:stixVocabs="http://stix.mitre.org/default vocabularies-1"



xmlns:ttp="http://stix.mitre.org/TTP-1"
xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance" id="FortiSandbox:Package-
ba2ad205-b390-40fd-96e4-44c2efaacabl" version="1.2">
<stix:STIX Header/>
<stix:Indicators>
<stix:Indicator id="FortiSandbox:indicator-7d3e889e-957c-428c-9f68-
8e48d3346316" timestamp="2016-08-12T18:25:52.674621+00:00"
xsi:type='indicator:IndicatorType'>
<indicator:Title>File hash for Suspected High Risk -
Riskware</indicator:Title>
<indicator:Type xsi:type="stixVocabs:IndicatorTypeVocab-1.1">File Hash
Watchlist</indicator:Type>
<indicator:0Observable id="FortiSandbox:0Observable-723483db-a3e0-4de0-93cd-
5bd37b3c4611">
<cybox:0bject id="FortiSandbox:File-3d9%e7590-b479-4352-9%9all~-
8fa313ceelf0">
<cybox:Properties xsi:type="FileObj:FileObjectType">
<FileObj:Hashes>
<cyboxCommon :Hash>
<cyboxCommon:Type xsi:type="cyboxVocabs:HashNameVocab-
1.0">SHA256</cyboxCommon: Type>
<cyboxCommon:Simple Hash Value
conditionz"EquaIs">OE96e7ec6646977967f2c6f4dcb641473e76b
4d5c9beb6ed33e0229c2accec5d</cyboxCommon: Simple Hash
Value> B B
</cyboxCommon : Hash>
</FileObj:Hashes>
</cybox:Properties>
</cybox:0bject>
</indicator:Observable>
<indicator:Indicated TTP>
<stixCommon:TTP idref="FortiSandbox:ttp-afa9d28b-9602-4936-8b9%4-
93e29cc8830c™ xsi:type='ttp:TTPType'/>
</indicator:Indicated TTP>
</stix:Indicator>
</stix:Indicators>
<stix:TTPs>
<stix:TTP id="FortiSandbox:ttp-afa9d28b-9602-4936-8b94-93e29cc8830c"
timestamp="2016-08-12T18:25:52.674181+00:00" xsi:type='ttp:TTPType'>
<ttp:Title>Suspected High Risk - Riskware</ttp:Title>
<ttp:Behavior>
<ttp:Malware>
<ttp:Malware Instance>
<ttp:Type xsi:type="stixVocabs:MalwareTypeVocab-1.0">Exploit
Kits</ttp:Type>
<ttp:Name>Suspected High Risk - Riskware</ttp:Name>
</ttp:Malware Instance>
</ttp:Malware>
</ttp:Behavior>
</stix:TTP>
</stix:TTPs>
</stix:STIX Package>



Scan Input

File Input

FortiSandbox utilizes Fortinet antivirus to scan files for known threats and then executes files in a VM
host environment. Unlike traditional sandboxing solutions, FortiSandbox is able to perform local scans
to detect sandbox evasion. FortiSandbox also has integrated web filtering to inspect and flag malicious
URL requests. Based on the traced output of the OS sandbox, botnet and command & control
(C&C/2C) channels are detected and classified.

There are five methods of importing files to your FortiSandbox ; sniffer mode, device mode, adapter,
network share, and on demand (including on demand through JSON API call and GUI submission). In
sniffer mode, the FortiSandbox sniffs traffic on specified interfaces, reassembles files, and analyzes
them. In device mode, your FortiGate, FortiWeb, FortiMail, or FortiClient end points are configured to
send all files to your FortiSandbox for analysis and can receive malware packages from the
FortiSandbox. Network share allows you to scan files located on a remote file share as scheduled, and
quarantine bad files. On demand allows you to upload files, URLs inside a file, or archived files directly
to your FortiSandbox for analysis.

FortiSandbox will execute code in a contained virtual environment by simulating human behavior and
the output is analyzed to determine the characteristics of the file. Inspection is run post-execution and
all aspects of the file are examined. FortiSandbox checks files for the dozens of suspicious
characteristics, including but no limited to:

« Known virus downloads
« Registry modifications
« Outbound connections to malicious IP addresses
« Infection of processes
« File system modifications
« Suspicious network traffic
FortiSandbox can process multiple files simultaneously since the FortiSandbox has a VM pool to

dispatch files to for sandboxing. The time to process a file depends on hardware and the number of
sandbox VMs used to scan the file. It can take 60 seconds to five minutes to process a file.

File On Demand

To view on-demand files and submit new files to be sandboxed, go to Scan Input > File On-Demand .
You can drill down the information displayed and apply search filters. You can select to create a PDF or
CSV format snapshot report for all on-demand files. Search filters will be applied to the detailed report
and will be displayed in the Report Profile section.

On demand allows you to upload various file types directly to your FortiSandbox device. Upon upload,
the file is inspected by FortiSandbox in the VM modules. You can then view the results and decide
whether or not to install the file on your network.

FortiSandbox has a rescan feature. When a virus file is detected, you can click the ReScan icon to
rescan the file. This is useful when you want to know the file behavior that is executed on the Microsoft



Windows host. You can select to bypass Static Scan, AV Scan, Cloud Query, or Sandboxing in the
Rescan Configuration dialog box. All rescanned jobs can be found in the On-Demand page.

You can select VM types to do the sandboxing by overwriting what is defined in the Scan Profile. When
MACOSX is selected, the file will be uploaded to the MacOS cloud to be scanned. For password
protected archive files, write down all possible passwords. If a password protected archive file contains
a different password protected archive file, both passwords should be written down. The default
password list set in the Scan Policy > General page will also be used t extract the archive files.

All files submitted through the JSSON API are treated as On-Demand files. Their results will also be
shown on this page.

Double-click an entry in the table to view the second level, View Jobs .

File On-Demand page - level 1

The following options are available:

Time Period Select the time period from the drop-down list. Select one
of the following: 24 Hours, 7 Days, or 4 Weeks.
You can select the time period to filter the information dis-
played in the GUI. This selection is also applied to expor-
ted data for the snapshot report.

Submit File Click the button to submit a new file. You can upload a reg-
ular or archived file.
Only one level of file compression is supported. All archive
files in the archive will be treated as a single file.

Export Data Click the Export Data button to create a PDF or CSV snap-
shot report. The time period of included jobs in the report
depends on the selection of Time Period drop-down. Do
not close the dialog box or navigate away from the page
during report generation.

Search Show or hide the search filter field.

Refresh Click the refresh icon to refresh the entries displayed after
applying search filters.

Show Rescan Job Jobs either generated from AV Rescan or manually
launched Rescan of Malicious job can be shown/hidden by
this option.

Add Search Filter Click the search filter field to add search filters. Click the

cancel icon to the left of the search filter to remove the spe-
cificfilter. Click the clear all filters icon in the search filter
field to clear all filters.

When the search filter is Filename, select the equal icon to
toggle between exact search and pattern search.



View Jobs

Pagination

Click the icon to view the scan job(s) associated with the
entry. In this page you can view detailed information for
files scanned. If the file is an archive file, all files in the
archive are displayed in this page. Click the back button to
return to the on-demand page.

Use the pagination options to browse entries displayed.

This page displays the following information:

Submission Time

Submitted Filename

Submitted By

Rating

Status

File Count

Comments

Rescan Job

Archive Submission

The date and time that the file was submitted to FortiSand-
box. Use the column filter to sort the entries in ascending
or descending order.

The file name.

The name of the administrator that submitted the file. Use
the column filter to sort the entries in ascending or des-
cending order.

Hover over the icon in this column to view the file rating.
The rating can be one or more of the following: Clean, Low
Risk, Medium Risk, High Risk, Malicious, or Unknown. For
archive files, the possible ratings of all files in the archive
will be displayed.

During the file scan, the rating is displayed as N/A. If a
scan times out or is terminated by the system, the file will
have an Other rating.

The file status can be Queued, In-Process, or Done.

The number of files associated with the entry. Itisin the
format of (finished file count)/(total files of this sub-
mission). When the scan is In Progress. When the scan is
done, it will display the total number of files in this sub-
mission.

The comments user enters when submitting the file.

This icon indicates that this file is a rescanned version of
anotherfile.

This icon indicates that an archived file has been sub-
mitted for scanning.

Total Jobs The number of jobs displayed and the total number of
jobs.
N After a file is submitted, the file might not be visible immediately until the file,
9 or any file, inside an archive file is put into a job queue. In a Cluster setting, the

file will not be visible until the file is put into one slave node's job queue.




To view the scan job(s) associated with the entry:

1.

In the right-pane click the View Jobs icon or double click on the row. The view jobs page is displayed.

~‘9"' In this page you can view detailed information for files scanned. If the file is an
= archive file, all files in the archive are displayed in this page.

2. This page displays the following information and options:

Back
Search

Refresh

Add Search Filter

View Details

Scan Video

Pagination

Click the back button to return to the On Demand page.
Show or hide the search filter field.

Click the refresh icon to refresh the entries displayed after
applying search filters.

Click the search filter field to add search filters. Click the
cancel icon to the left of the search filter to remove the
specific filter.

When the search filter is Filename, select the equal icon to
toggle between exact search and pattern search.

Select the View Details icon to view file information. The
information displayed in the view details page is dependent
on the file type and risk level.

When the scan is submitted, if the Record scan process in
video is selected, a video icon is displayed. Clicking it will
allow user to select one VM type in which the scan is done
and recorded. Select the VM type to play video or save it to
a local hard disk.

The reset of displayed columns are determined by settings
defined in System > Job View Settings > File Detection
Columns page. For more information, refer to Job View
Settings on page 67.

Use the pagination options to browse entries displayed.

Click the View Details icon to view file details. The View Details page will open a new tab. See
Appendix A - View Details Page Reference on page 170 for descriptions of the View Details page.

Click the parent job ID icon to view rescan file details.

If the parent job is an archive file, all the childrens' file names are included in the Archive Files drop
down list. Select child's file name to view its detail

5. Close the tab to exit the View Details page.

To create a snapshot report for all on-demand files:

o Dd=

Select a time period from the first drop-down list.

Select to apply search filters to further drill down the information in the report.
Click the Export Data button in the toolbar. The Report Generator window opens.
Select either PDF or CSV and define the report start and end date and time.

Click the Generate Report button to create the report.



6. When the report generation is completed, select the Download button to save the file to your
management computer.

7. Click the close icon or the Cancel button, to quit the report generator.

N In this release, the maximum number of events you can export to PDF report is
9 5,000; the maximum number of events you can export to CSV report is
= 150,000.

To submit a file to FortiSandbox :

1. Click the Submit File button from the toolbar.
2. You can configure the following:

Skip: Select one or more of the following steps to skip:
« Static Scan

o AV Scan
« Cloud Query
« Sandboxing



Overwrite Scan Profile
Settings to Scan
in VM Type:

Select a File

Allow Interaction

Record scan process in
video

Possible password(s) for
archive file:

Comments

Overwrite Scan Profile Settings to Scan in VM Type by selecting one
or more of the following enabled VMs:

o WINXPVM

o WIN7X86VM

o WIN7X64VM

o WIN10X64VM

« MACOSX

Note: MACOS file scan is only available for On-Demand
scans. The file will be sent over to the MacOS Cloud
and after the scan is finished, a detailed verdict will be
downloaded.

License Consideration of the MacOS file scan:

« Each unit has one free trail license for the MacOS file scan.
When you run vm-1license -1, thisrecord will show KEY
MAC MACOS-TRAIL-TRAIL-TRAIL-TRAIL.

« Each unit can only upload one file to the MacOS Cloud. If
there are other files, they will wait in the queue.

« Inthe Virtual Machine > VM Images page, there is a Remote
VMs section. MACOS X has the hard-coded clone number of
one.

MAC OSX VM cannot be used with local VMs at the

same time.
Enabled VM means its clone number is larger than 0. If a VM type is
not selected, settings from the Scan Profile page will be used. If VM
images are not ready, the VM list will not be displayed.

Select one or more of enabled VM. Enabled VM means its clone
number is larger than 0.

If no VM type is selected, settings from the Scan Profile page will be
used. If any VM type is selected, settings from the Scan Profile will
be overridden and the file will only be scanned in selected VM types.
If VM images are not ready, the VM list will not be displayed.

Click the Browse button and locate the sample file or archived
sample file on your management computer.

Select the Allow Interaction checkbox to interact with the Windows
VM. See To use the Allow Interaction Feature: on page 103 for more
information.

Select to enable video recording. After scan finishes, a video icon will
show in the File On-Demand second level detail page. Clicking it will
trigger a download or play the video.

List all possible passwords contained inside a password protected
archive file. One password per line. Default password list set in the
Scan Policy > General page will also be used to extract the archive
files.

Optional comments for future reference.



3. Click the Submit button. A confirmation dialog box will be displayed. Click OK to continue. The file will
be uploaded to FortiSandbox for inspection.

4. Click the Close button to exit.

The file will be listed in the On-Demand page. Once FortiSandbox has completed its analysis, you
can select to view the file details.

by

~9' If the submitted file is an archive file with multiple files, the File Count, Rating
= and Status values might change until all files have finished scanning.

To use the Allow Interaction Feature:

1. Goto Scan Input > File On-Demand > click Submit File from the toolbar.

2. Inthe Submit New File window, check the Allow Interaction checkbox, and click Submit. One and only
one VM type should be selected to do the scan.

Submit Mew File

x FY
Please upload sample file or archived sample files. The following archive formats are supported: tar, .z, xz, gz, targz,
tez, zip, .bz2, tarbz2, tarZ, 7z, rar, lzh, .ace
Only onz VM type can be selected when the ‘Allow Interaction’ is enabled
Skip: # Static Scan
# AN Scan
# Cloud Query

Sandboxing
Orwerwrite Scan Profile settings to F WINXPVYM1
Scanin VM type: WINXPWM

WINFXEAWVM

WINTXAAWM
Select a file: Choose File | Mo file chosen
# Allow Interaction

Record scan process in viden
Possible password(s) for archive file:
4
Comments:
A
w

3. Goto Virtual Machine > VM Status page, the job will be launched when a clone of a selected VM is
available.
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There are two ways to interact with the windows VM.

1. Use a VNC client and connect to £sa_ip:port. The port number can be found in the Interaction icon
tooltip. Click the Interaction icon, the login password will appear in the address bar.

2. Click the Interactionicon to use web based VNC client. Click Yes in the Do you want to start the scan?
popup, the scan will start and the question becomes Do you want to stop the scan?
Click Yes to stop the scan and VNC session will close after a few seconds. Go back to On-Demand
page to check the scan result.

~‘9"' The user has 30 minutes to finish the interaction. After that, the VNC session

will be closed automatically.

L2

~ L4
9 This feature is only available to user admin.

g

URL On Demand

URL On Demand allows you to upload a plain-text file containing a list of URLs, or an individual URL
directly to your FortiSandbox device. Upon upload, the URLs inside the file, or the individual URL is
inspected by FortiSandbox in the VM modules. The Depth to which the URL is examined, as well as the
length of time that the URL is scanned, can be set. You can then view the results and decide whether or
not to allow access to the URL.

To view On Demand URLs and submit URLSs to scan, go to Scan Input > URL On-Demand. You can
drill down the information displayed and apply search filters.

URL On-Demand page - level 1

The following options are available:

Time Period Select the time period from the drop-down list. Select one
of the following: 24 Hours, 7 Days, or 4 Weeks.
You can select the time period to filter the information dis-
played in the GUI. This selection is also applied to expor-
ted data for the snapshot report.

Submit File/URL Click the button to submit a file containing a list of scanned
URLs, or submit an individual URL.

Export Data Click the Export Data button to create a PDF or CSV snap-
shot report. The time period of included jobs in the report
depends on the selection of Time Period drop-down. Do
not close the dialog box or navigate away from the page
during report generation.

Search Show or hide the search filter field.

Refresh Click the refresh icon to refresh the entries displayed after
applying search filters.



Add Search Filter Click the search filter field to add search filters.

When the search criteria is URL, click the equals (=)sign to
toggle between exact and pattern search.

Click the close icon in the search filter field to clear all
search filters.

The search filter will be displayed below the search filter
field. Click the close icon beside the search filter to remove
the filter.

Search filters can be used to filter the information dis-
played in the GUI.

View Jobs Click the icon to view the scan job(s) associated with the
entry. Click the back button to return to the on-demand
page.

Pagination Use the pagination options to browse entries displayed.

This page displays the following information:

Submission Time The date and time that the URL file or individual URL was
submitted to FortiSandbox. Use the column filter to sort
the entries in ascending or descending order.

Submitted Filename The submitted URL file name. If the scan is about an indi-
vidual URL, the name is scan of URL

Submitted By The name of the administrator that submitted the file
scan.
Rating Hover over the icon in this column to view the file rating.

The rating can be one or more of the following: Clean, Low
Risk, Medium Risk, High Risk, or Unknown.

During the file scan, the rating is displayed as N/A. If a
scan times out or is terminated by the system, the file will
have an Other rating.

Status The scan status can be Queued, In-Process, or Done.

URL Count The number of URLs associated with the submission when
the scan is done. When the scan is In Progress, it shows
(finished scan)/(total URLs of this submission).

Comments The comments user enters when submitting the file scan.

To view the scan job(s) associated with the entry:

1. Double click an entry in the table or select the View Jobs icon to view the specific URLs that were
scanned.

2. This page displays the following information and options:



Back Click the back button to return to the on-demand page.
Search Show or hide the search filter field.

Refresh Click the refresh icon to refresh the entries displayed
after applying search filters.

Add Search Filter Click the search filter field to add search filters.

Click the close icon in the search filter field to clear all
search filters.

Search filters can be used to filter the information
displayed in the GUI.

View Details Select the View Details icon to view file information.

Scan Video When the scan is submitted, if Record scan process in
video is selected, a video icon is displayed. Clicking it will
allow user to select one VM type in which the scan is
done and recorded. Select the VM type to play video or
save it to a local hard disk.

Pagination Use the pagination options to browse entries displayed.

The reset of displayed columns are determined by settings defined in System > Job View Settings >
URL Detection Columns. For more information, refer to Job View Settings on page 67.

3. Click the View Details icon to view file details. The View Details page will open a new tab. See
Appendix A - View Details Page Reference on page 170 for descriptions of the View Details page.

4. Close the tab to exit the View Details page.

To submit a file containing a list of URLs or an individual URL to FortiSandbox:

1. Click the Submit File / URL button from the toolbar. The Submit New File window opens.
2. Enter the following information:

Depth Enter the Recursive Depth in which URLs are
examined. The original URL is considered level 0. A
depth of 1 will open all links on the original URL page
and crawl into them. The default value is define in the
Scan Policy > Scan Profile page.

Timeout Enter the Timeout Value. The Timeout Value
controls how long the device will scan the URL. If the
network bandwidth is low, the timeout value should
be larger to accommodate higher depth values. The
default is value is defined in the Scan Policy > Scan
Profile page.



Overwrite Scan Profile Settings
to Scan in VM Type

Direct URL

Allow Interaction

Record scan process in video

Select a File

Comments

4. Click Submit.

To use the Allow Interaction Feature:

Overwrite Scan Profile Settings to Scan in VM Type
by selecting one or more of the following enabled
VMs:

o« WINXPVM

« WIN7X86VM

o WIN7X64VM

« WIN10X64VM

Enabled VM means its clone number is larger than 0.
If a VM type is not selected, settings from the Scan
Profile page will be used. If VM images are not ready,
the VM list will not be displayed.

Select one or more of enabled VM. Enabled VM
means its clone number is larger than 0.

If no VM type is selected, settings from the Scan
Profile page will be used. If any VM type is selected,
settings from the Scan Profile will be overridden and
the file will only be scanned in selected VM types. If
VM images are not ready, the VM list will not be
displayed.

To scan only a single URL, check the Direct URL
checkbox. Enter the URL in the Enter a URL field.

Select the Allow Interaction checkbox to interact with
the Windows VM. See To use the Allow Interaction
Feature: on page 107 for more information.

Select to enable video recording. After scan finishes,
a video icon will show in the second level detail page.
Clicking it will trigger a download or play the video.

Click the Browse button and locate the plain-text file
on your management computer. The maximum
number of URLs in this file is determined by
Maximum URL Value in Scan Policy > Scan Profile
page.

You can choose to enter optional comments for
future reference.

1. Goto Scan Input > URL On-Demand > click Submit File / URL from the toolbar.
2. Inthe Submit New File window, check the Allow Interaction checkbox, and click Submit.



Submit New File »
Please upload a plain-text file containing a list of URLs (1 URL per ling).
Cinly one WM type can be selected when the ‘Allow Interaction’ is enabls
Depth: o]
Timeout: 50
Owerwrite Scan Profile settings to #OWINXPYM 1
Scanin VM type: WINXPYM
WINTXEEWM
WINTHAAWM
Direct URL
# Allow Interaction
Record scan process invideo
select a file: Choose File | Mo file chosen
Comments:
e
Close v

Go to Virtual Machine > VM Status page, the job will be launched when a clone of a selected VM is
available.
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Q Screenshot VM File
@ Dashboard
| Fortivi @ E EI WINXPVM_clone1é fsa_downloader.exe.txt
ortiView
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There are two ways to interact with the windows VM.

1.

Use a VNC client and connectto £sa_ip:port. The port number can be found in the Interaction icon
tooltip. Click the Interaction icon, the login password will appear in the address bar.

Click the Interaction icon to use web based VNC client. Click Yes in the Do you want to start the scan?
popup, the scan will start and the question becomes Do you want to stop the scan?

Click Yes to stop the scan and VNC session will be closed. Go back to On Demand page to check
the scan result.

Ay

~9' The user has 30 minutes to finish the interaction. After that, the VNC session
= will be closed automatically.

~9' This feature is only available the user admin.




Job Queue

In this page, users can view the current pending job number, average scan time and arrival rate of each
job queue. The associated VM is also displayed for each queue. The user can click the VM name to go
to Scan Profile page and change its settings.

Users can use this page's information to help make sure each Job Queue is not piling up with too many
jobs. If there are a lot of jobs pending in the Job Queue, the user can try to associate it with less VM
types and/or allocate more clone numbers to its associated VM types.

To refresh the data, click the Job Queue menu again.

AveScan
TimeinlLast Expected Arrival Rate
Input Source  File Type Pending # 24 hrs (s) Finish Time  (Last 1hr) WM Type (Clone #)
Sniffer Mot assigned files 336 W
Executables/DLL/VBS/BAT/PS1/JAR/MSI
Device files o 38 WIN7X64VM(6) Ll
Executables/DLL/VBS/BAT/PS1/JAR/MSI
Sniffer files 0 40 276 WINZXE4VM(6) Ll
Sniffer User defined extensions ] 2 17
Microsoft Office files (Word, Excel,
Device PowerPoint files etc) 1] 96 WINXPVM(7) Lhil , WIN7X86VM(6) [l
Microsoft Office files (Word, Excel,
Sniffer PowerPoint files etc) 0 55 15 WINXPVYM(7) bl , WINTX86VM(6) Lahil
Device PDF files 0 85 win7xé4newtool(7) Ll
Sniffer PDF files ] 89 38 win?7xé4newtool(7) [l
Sniffer Android files ] 4 8
Device Adobe Flash files o 33 WINXPVM(7) Ll
Sniffer Adobe Flash files ] 35 184 WINXPVM(7) Ll
Sniffer Static Web files ] 3 46
The following options are available:
Chart icon When clicking on the Chart icon beside each VM type, the VM's

Usage Chart will be displayed.

Trash icon When clicking on the Trash icon, beside the Pending Job Number,
the job queue will be purged.

The following information is displayed:



Input Source

File Type

Pending #

Ave Scan Time in Last 24
hrs (s)

Expected Finish Time
Arrival Rate (Last 1 hr)

VM Type (Clone #)

The type of Input Source. Input source types can be the following val-
ues:
+ On Demand

o File RPC

« Device

o Sniffer

o Adapter

o Network Share
+ URL On Demand
« URLRPC

+ URL Device

« URL Adapter

File types can be one of the following values:
o Executables /DLL/VBS/BAT/PS1/JAR/MSI/WSF files

« Microsoft Office files (Word, Excel, Powerpoint etc)
« Adobe Flash files

« Archive files (extensions: .7z, xz, .bz2, .gz, .tar, .zip, .Z, .kgb,
.ace, etc.)

o PDF files

« Static Web files

o Android files

« URL detection

o User defined extensions

« Not assigned files (files received from input sources and not
yet processed)

« Not determined files (files that do not enter the Sandboxing
scan step according to the current Scan Profile settings. If the
Scan Profile settings are changed, they may enter the
Sandboxing scan step.)

Current pending job number.

A Trash Can appears beside the pending job number. If you click on
the Trash Canicon, the job queue will be purged.

Average scan time of one file in the last 24 hours, in seconds.

The expected time when the pending jobs will finish.
Files put in the Job Queue in the last hour.
The VM type with its clone number.

A Chart icon appears beside the VM Type (Clone#). If you click on
the Chart icon, the VM's usage chart appears. This chart shows a
rough percentage of used clones of this VM type across time. If the
usage percentage is consistently at a high level across time, the user
should consider allocating more clone numbers to it.



Sniffer

FortiSandbox [,
A
Sniffer Input Mode

4—5=—>‘<—5 —

Sniffer mode relies on inputs from spanned switch ports. It is the most suitable infrastructure for adding
protection capabilities to existing threat protection systems from various vendors.

Sniffer mode enables you to configure your FortiSandbox to sniff all traffic on specified interfaces.
When files are received by FortiSandbox , they are executed and scanned within the VM modules.
Sniffer mode supports the following protocols: HTTP, FTP, POP3, IMAP, SMTP, SMB and raw TCP
protocol. To enable and configure sniffer settings, go to Scan Input > Sniffer.

N FortiSandbox reserves port1 for device management and port3 for scanned
9 files to access the Internet. Port1, port3 and the port used for cluster internal
= communication can not be used as a sniffed interface.

\ M The default size for sniffer mode is 2048kB. To change this value, go to Scan
N\ Input > Shniffer.

In FortiSandbox you can select to sniff multiple interfaces. For example, when
2\ FortiSandbox is deployed with a network tap device you can sniff both the
incoming and outgoing traffic on separate FortiSandbox interfaces.




Sniffer Settings

¥ Enable file based detection

+ Enable network alert detection

¥ Keepincomplete files

# Enzble conserve mode

Max file size:
Sniffed Interfaces:
¥ port2
port4
ports
porté
Service Types:
4 FTP
HTTP
IMAP
COTHER
POP3
SMB
SMTP

L Y Y Y U S

e Types:

100 | KB (The limit of max file size is 200,000 KB)

7 All Ijﬂ"e- following file types and any other file type)

bzip
bzip2
cab
com
doc
exe
flash
gzip
htmnl
jar
java
is

pdf
ppt
rar
tar
zip
URLs in Emai

Extract and scan URLs in Email message body, up to 1 | URLs(1to5)

Configure the following settings:

Enable file based detec-

tion

Enable network alert

detection

Keep incom-
plete files

Enable con-
serve mode

Select the checkbox to enable file based detection

Select the checkbox to enable network alerts detection. This feature
detects sniffed live traffic for connections to botnet servers and intru-
sion attacks and visited suspicious web sites with Fortinet IPS and
Web Filtering technologies.

Alerts can be viewed in the System > Network Alerts page.

For URL visits, certain categories are treated as not suspicious by
default, such as dating. To check the list, go to Scan Policy > URL
Category.

Keep files without completed TCP sessions. Select the checkbox to
keep incomplete files. Sometimes incomplete files can be useful to
detect known viruses.

When conserve mode is enabled, if there are already too many jobs
in the pending queue (250K), sniffer will enter conserve mode, during
which time only executable (.exe) and MS Office files are extracted.



Maximum The maximum size of files captured by sniffer. Enter a value in the
file size text box. The default value is 2048kB and the maximum file size is
200,000kB.
Note: Files that exceed the maximum file size will not be
sent to FortiSandbox.

Sniffed Select the interface to monitor.

Interfaces

Service Select the traffic protocol that the sniffer will work on. Options
Types include: FTP, HTTP, IMAP, POP3, SMB, OTHER and SMTP.

The OTHER service type is for raw TCP protocol traffic.

File Types Select the file types to extract from traffic. When All is checked. all
files in the traffic will be extracted.

When URLs in Email type is selected, URLs embedded inside Email
body will be extracted and scanned as a WEBLink type. User can
define the number of URLs to extract for each Email, from 1 to 5.

~9' When an interface is used in sniffer mode, it will lose its IP address. The inter-
= face settings cannot be changed.

Device

In Device mode, you can configure your FortiGate, FortiWeb or FortiMail devices to send files to your
FortiSandbox. For FortiGate, you can select to send all files for inspection. For FortiMail, you can select
to send suspicious email attachments to FortiSandbox for inspection or just Suspicious files. When
executable files are received by FortiSandbox , they are executed and scanned within the VM modules.
FortiSandbox also sends statistics back to the FortiGate, Fortiweb and FortiMail. When integrated with
FortiGate, the following protocols are supported: HTTP, FTP, POP3, IMAP, SMTP, MAPI, IM, and their
equivalent SSL encrypted versions. To view, edit, and authorize FortiGate devices, go to Scan Input >
Device.

For FortiOS 5.2.3 and later, the FortiGate can query a file's verdict, and retrieve detailed information
from FortiSandbox.

For FortiOS 5.4.0 and later, the FortiGate can download Malware packages and URL packages from
FortiSandbox as complimentary AV signatures and web filtering black lists, respectively. These
packages contain detected malware signatures and their downloading URLSs.



The default file size scanned and forwarded by FortiGate is 10MB and the max-
imum depends on the memory size of the FortiGate. You can change the file
size on the FortiGate side using the following CLI command:
config firewall profile-protocol-options
edit <name str>
config http
set oversize-limit <size_ int>

end
Note: The profile-protocol-options setting decides the maximum file
size that will be AV scanned on the FortiGate. After a virus scan verdict has
been made (Clean or Suspicious), if the file's size isless than analytics-
max-upload size, it will be set over to FortiSandbox according to Send
All/Suspicious Only settings on the FortiGate.
For more information on configure the oversize limit forprofile-pro-
tocol-optionsandanalytics-max-upload, see the CLI Reference
for FortiOS in the Fortinet Document Library.

The following options are available:

Device Filter

Edit

Delete

Users can filter devices by entering part of device name or serial num-
ber.

Click to edit a device or a VDOM. Users can edit device permission
policy and device level email settings.

Click to delete the device or VDOM. If a device is deleted, all its
VDOMs will be deleted also. If the device connects to FortiSandbox
later, it will show up again as a new device.

This page displays the following:

Device Name

Serial

Malicious

High

Medium

Low

Clean

The name of the device and the VDOM that send files to FortiSand-
box. For device, it has the format of: Device Name. For VDOM, it
has the format of: Device Name: VDOM Name.

The FortiGate, FortiWeb or FortiMail serial number.

The number of malicious files submitted by the FortiGate, FortiWeb
or FortiMail to FortiSandbox in the last seven days. Malicious files
are not executed in the FortiSandbox VM module as the antivirus
scanner has already determined the file status.

The number of high risk files submitted by the FortiGate, FortiWeb or
FortiMail to FortiSandbox in the last seven days.

The number of medium risk files submitted by the FortiGate,
FortiWeb or FortiMail to FortiSandbox in the last seven days.

The number of low risk files submitted by the FortiGate, FortiWeb or
FortiMail to FortiSandbox in the last seven days.

The number of clean files submitted by the FortiGate, FortiWeb or
FortiMail to FortiSandbox in the last seven days.


http://docs.fortinet.com/fortigate/reference

Others

Malware Pkg
URL Pkg

Authorized

Limit

Status

The number of other files submitted by FortiGate, FortiWeb or
FortiMail to FortiSandbox in the last seven days.

The malware package version currently on the device.
The URL package versions currently on the device.

If the device or VDOM is authorized to submit files. Only authorized
device or VDOM is allowed to submit files to FortiSandbox.

If a submission limit is set for this device.
The status of the FortiGate, FortiWeb or FortiMail. This field displays

an up icon when the device is connected and a down icon for devices
which are disconnected.

Ay

FortiSandbox uses a Fortinet proprietary traffic protocol (OF TP) to com-
municate with connected devices. This communication occurs on TCP port
514. The traffic is encrypted.

Supported Devices

In FortiOS, you can configure your FortiGate device to send suspicious files to FortiSandbox for

inspection and analysis. FortiGate queries scan results and retrieves scan details. In FortiOS 5.4 and
later, FortiGate can also download malware packages as a complimentary AV signature database to
block future appearances of the same malware and download URL packages as complimentary web

filtering black list.

FortiSandbox supports the following devices:

FortiGate

FortiMail

FortiSandbox is able to perform additional analysis on files that have been
AV scanned by your FortiGate. You can configure your FortiGate to send all
files or only suspicious files passing through the AV scan.

FortiGate can retrieve scan results and details from FortiSandbox, and also
receive antivirus and web filtering signatures to supplement the current sig-
nature database.

When FortiGate learns from FortiSandbox that a terminal is infected, the
administrator can push instruction for self-quarantine on a registered FortiCli-
ent host.

You can configure your FortiMail to send suspicious, high risk files and sus-
picious attachments. FortiSandbox is able to perform additional analysis on
files that have been scanned by your FortiMail email gateway.
Suspicious email attachments include:

« Suspicious files detected by heuristic scan of the AV engine

« Executable files and executable files embedded in archive files
« Type 6 hashes (binary hashes) of spam email detected by FortiGuard
AntiSpam service.

Recent release of FortiMail build can only send suspicious URLs to FortiSand-
box to do URL scans and block suspicious emails based on the scan result.



FortiClient

FortiWeb

FortiSandbox can accept files from FortiClient to perform additional analysis,
while FortiClient holds the files until the scan results are received. FortiClient
will also receive additional antivirus signatures from FortiSandbox, generated
from scan results, to supplement current signatures.

You can now use a file upload restriction policy to submit uploaded files to
FortiSandbox for evaluation. FortiSandbox evaluates whether the file poses a
threat and returns the result to FortiWeb. If FortiSandbox determines that the
file is malicious, FortiWeb performs the following tasks:

« Generates an attack log message that contains the result (for
example, messages with the Alert action in the illustration).

« For 10 minutes after it receives the FortiSandbox results, takes the
action specified by the file upload restriction policy. During this time, it
does not re-submit the file to FortiSandbox (for example, messages
with the Alert_Deny action in the illustration).

FortiGate devices

Ay

If port3 of the FortiSandbox is connected to an interface behind the FortiGate

device, make sure the egress WAN interface does not have the Scan Outgoing

Connections to Botnet Sites feature enabled, nor any active security profiles—-

this might impact the detection rate. If this is not possible, we recommend con-

necting the FortiSandbox port3 to a different egress WAN port or directly to the
Internet in front of the perimeter firewall.

To configure the FortiGate to send files to FortiSandbox:

1. Connect the FortiSandbox Appliance to your FortiGate so that port1 and port3 on the FortiSandbox are

on different subnets.

by

FortiSandbox port3 is used for outgoing communication triggered by the
execution of the files under analysis. It is recommended to connect this
port to a dedicated interface on your FortiGate to protect the rest of the
network from threats currently being investigated by the FortiSandbox.
FortiSandbox port3 must be able to connect to the Internet.

2. Inthe FortiGate, go to Policy & Objects > IPv4 Policy and create a policy allowing connections from
the FortiSandbox to the Internet (using the isolated interface on the FortiGate mentioned above).

3. Inthe FortiSandbox, go to Network > System Routing and add static routes for port1 and port3.

4. Inthe FortiSandbox, go to Dashboard > System Information Widget. Now that the FortiSandbox has
Internet access, it can activate its VM licenses. Wait until a green arrow shows up beside Windows VM
field before continuing to the next step.

5. Inthe FortiGate, go to System > Cooperative Security Fabric. Select Enable Sandbox Inspection and
select FortiSandbox Appliance. Set the IP Address and enter a Notifier Email.



Enable sandbox inspection

FortiSandbox type REsgsrRlloENhlELE FortiSandbox Cloud

Server Test Connectivity

Notifier Email
Applied Threat Intelligence

Dynamic Malware Detection version | 2.2755 (signatures: not loaded)

URL Threat Detection version 2.2329 (entries: 1000)

If you select Test Connectivity, the Status shows as Service is not configured because the
FortiGate has not been authorized to connect to the FortiSandbox.

6. Inthe FortiSandbox, go to Scan Input > Device. Click the Edit button beside the FortiGate you want to
authorize. Under Permissions & Policy > Authorized field, select the checkbox and click OK to
authorize the FortiGate.

7. Inthe FortiGate, go to System > Cooperative Security Fabric and for FortiSandbox select Test
Connectivity. The Status now shows that Service is online.

Once the FortiGate is connected to FortiSandbox, an AntiVirus profile can be configured to send

suspicious files for inspection. Sandbox integration can also be configured.

To verify the FortiGate is connected to FortiSandbox:

On your FortiSandbox device, go to Scan Input > Devices. Your FortiGate device and VDOMs will be
listed on this page.

The communication protocol does not include a way for the FortiGate to notify FortiSandbox whether
VDOMs are enabled. When VDOMs are disabled on the FortiGate, the files received from the
FortiGate will be marked with vdom=root.

Since the FortiGate does not explicitly send a list of possible VDOMs to
~‘9"* FortiSandbox , the FortiSandbox only learns about a VDOM once it receives a
= file associated with it. Each of the devices VDOMs listed on this page will only
displayed after the first file has been received from that specific VDOM.

If VDOMSs are enabled on your FortiGate, you can select the checkbox to have new VDOMSs inherit
authorization based on the device level setting. If the FortiGate authorization is disabled, all VDOMs
under it will not be authorized even if authorization is enabled fora VDOM.

To configure a FortiGate antivirus profile to send suspicious files for inspection:

1. Inthe FortiGate, go to Security Profiles > AntiVirus and select Send Files to FortiSandbox Appliance
for Inspection.
In FortiOS 5.4.0, you can also elect to send Suspicious Files, Executable files or All Supported
Files.

In FortiOS 5.4.1, you can choose to Treat Windows Executables in Email Attachments as
Viruses and Send All Supported Files. When you select Send All Supported Files, you then have
the option to withhold files from FortiSandbox inspection by type or by name pattern.



2. Select Use FortiSandbox Database to add signatures for suspicious files found by FortiSandbox to your
FortiGate antivirus signature database.

3. Then add this antivirus profile to a firewall policy to send files in traffic accepted by the firewall policy to
FortiSandbox.

4. You can also go to Security Profiles > Web Filter and select Block Malicious URLs discovered by
FortiSandbox.

To edit FortiGate settings:

1. On your FortiSandbox device, go to Scan Input > Device. All FortiGate devices and VDOMs will be
listed on this page.

Since the FortiGate does not explicitly send a list of possible VDOMs to
~‘9"' FortiSandbox , the FortiSandbox only learns about a VDOM once it receives a
= file associated with it. Each of the devices VDOMs listed on this page will only
displayed after the first file has been received from that specific VDOM.

2. Select the FortiGate device that you want to edit. The Edit FortiGate Settings page opens.
3. Edit the following settings:

Device Status
Serial Number
Alias

IP

Status

Last Modified

Last Seen

Permissions

Authorized

New VDOMs inherit
authorization

Email Settings

Administrator Email

Send Notifications

The device serial number is displayed.
The host name of the FortiGate unit. This is a read-only value.
The IP address of the FortiGate is displayed.

The status of the device, either connected or not connected. This
field cannot be edited.

The date and time that the FortiGate settings were last changed is
displayed.

The date and time that the FortiGate last connected to the
FortiSandbox is displayed.

Select the checkbox to authorize the FortiGate device. If this field is
not checked, files sent from the FortiGate will be dropped.

The date and time that the authorization status was changed is
displayed.

Select the checkbox to have new VDOMSs inherit the authorization
setting configured at the device level.

The email address entered in the Notifier Email field configured on
the FortiGate device at System > Config > FortiSandbox. You
cannot edit this field on the FortiSandbox.

Select the checkbox to send notifications. When notifications are
enabled, you will receive email notifications when a file from your
environment has been detected as potential malware. The email will
contain a link to the scan job details page.



Send Reports

Click OK to save the settings.

To edit VDOM settings:

1.

Select the checkbox to send job detail PDF reports. To receive
reports and define report generation frequency, you must configure
mail server related settings in System > Mail Server.

On your FortiSandbox device, go to Scan Input > Device. All FortiGate devices and VDOMSs will be

listed on this page.

Select the VDOM that you want to edit.

Edit the following settings:

Device Status
VDOM Serial Number

Alias

IP

Status

Files Transmitted

Last Modified

Last Seen

Permissions & Policy
Authorized

Submission Limitation

Send Reach Limit Alert
Email

Email Settings

VDOM Email

The device VDOM. This field cannot be edited.

Enter a name for the FortiGate VDOM. If you have multiple VDOMs
configured to send files to FortiSandbox , select an unique name to
identify the VDOM.

The IP address of the FortiGate. This field cannot be edited.

The status of the device, either connected or not connected. This
field cannot be edited.

The total number of files transmitted to FortiSandbox in the last
seven days.

The date and time that the authorization status was changed. This
field cannot be edited.

The date and time that the FortiGate VDOM last connected to the
FortiSandbox. This field cannot be edited.

Select the checkbox to authorize the FortiGate VDOM.

Limit the FortiGate submission speed. Specify the number of
submissions per Hour, Day, or Unlimited.

When limitation is reached, FSA will send a signal to FGT to stop file
submission. This will save resources on both sides.

This only applies to FortiGate.

If this field is checked, when submission limitation is reached, an
alert email will be sent to VDOM email address.

Enter the Administrator Email address for the VDOM, separated by a
comma.



Send Notifications Select checkbox to send notifications when viruses or malware from

this VDOM is detected.

Send PDF Reports Select checkbox to send PDF reports of jobs. To receive reports and

define report generation frequency, you must configure System >
Mail Serverpage. Also the Send Scheduled PDF report to VDOM
email address in that page should be checked.

4. Click OKto save the settings.

FortiMail devices

In FortiMail version 5.2.0 or later, you can configure your FortiMail device to send suspicious files and
suspicious attachments to FortiSandbox for inspection and analysis. FortiSandbox statistics for total
detected and total clean are displayed on FortiMail.

To configure your FortiMail to send files to FortiSandbox:

On your FortiMail device, go to System > Configuration and select the FortiSandbox tab.

Select to enable FortiSandbox inspection, enter the IP address/FQDN of your FortiSandbox device, and
enter a value in the Statistics interval text field. You can configure your FortiMail to communicate with
your FortiSandbox on port1, port2, or port4.

Click Apply to save the setting.

On your FortiSandbox device, go to Scan Input > Devices. Your FortiMail device will be listed on this
page.

Select the checkbox beside the FortiMail and select Edit in the toolbar. The Edit Device Settings page
opens.

In the Permissions section, select the checkbox beside the Authorized field.

Click OK to save the setting.

On your FortiMail, select the Test Connectivity button. The Test FortiSandbox Connectivity dialog box
will list the IP address of the FortiSandbox server and the status will show the status connected
successfully.

Upload suspicious attachments to FortiSandbox

FortiMail version 5.2 includes an option to control whether suspicious attachments captured by an
antivirus policy will be sent to FortiSandbox for further analysis.

To send suspicious attachments captured by an AV policy to FortiSandbox :

1.

3.
4,

On your FortiMail device, go to System > Profile > AntiVirus and select New from the toolbar. The
AntiVirus Profile page opens.

Configure the Domain, Profile name, and Default action. Select to enable Virus scanning and select to
Upload suspicious attachment to FortiSandbox.

Click OK to save the antivirus profile.

Apply the antivirus profile to the applicable policies.

Device and VDOM level notifications

When enabling Send notifications in the Edit Device Settings or Edit VDOM Settings page, you will
receive an email every time a file from your environment has been detected as potential malware.



Sample notification email

This email will contain a link to the Scan Job Details page. You can also view the View Details page in
the Suspicious, Clean Files, and On-Demand dashboard pages.

» You can enable or disable VDOM level notifications for each VDOM sending
>\ files to FortiSandbox. To configure global notifications, go to System > Mail
Server.

Device and VDOM level PDF reports

When enabling Send PDF reports in the Edit Device Settings or Edit VDOM Settings page, you will
receive a PDF report by email at defined moment in Config > Mail Server page. This email will contain
a FortiSandbox Summary Reports PDF. The report lists statistics of scan jobs from the defined previous
time period configured from the System > Mail Server page. This report contains the following
information:

« Scanning Statistics: A table listing the number of files processed by FortiSandbox and a breakdown of
files by rating.
« Scanning Statistics by Type: A table listing the file type, rating and event count.

« Scanning Activity: Atable and graph listing the number of clean, suspicious, and malicious files
processed by FortiSandbox per day.

« Top Targeted Hosts: Alist of the top targeted hosts.

« Top Malware Files: Alist of the top malware programs detected by FortiSandbox.

« Top Infectious URLs: Alist of the top infectious URLs detected by FortiSandbox.

« Top Callback Domains: A list of the top call back domains detected by FortiSandbox.

~‘9"' You can enable or disable device and VDOM level reports for each device or
= VDOM sending files to FortiSandbox.

FortiWeb

To configure FortiWeb to send files to the FortiSandbox and receive results back:

You can configure FortiWeb to submit all files that match your upload restriction rules to FortiSandbox.
FortiSandbox evaluates whether the file poses a threat and returns the result to FortiWeb. If
FortiSandbox determines that the file is malicious, FortiWeb performs the following tasks:

« Generates an attack log message that contains the result (for example, messages with the Alert action in
the illustration).

« For 10 minutes after it receives the FortiSandbox results, takes the action specified by the file upload
restriction policy. During this time, it does not re-submit the file to FortiSandbox (for example, messages
with the Alert_Deny action in the illustration).

To configure FortiWeb with FortiSandbox:

1. Goto System > Config > FortiSandbox.
2. Configure the FortiSandbox Settings.
3. Select Apply.

Server IP Enter the IP address of the FortiSandbox.



Secure Connection

Admin Email

Statistics Interval

FortiClient

Select to communicate with the specified FortiSandbox using SSL.

Enter the email address that FortiSandbox sends reports and noti-
fications to.

Specifies how often FortiWeb retrieves statistics from FortiSandbox.
Intervals are in minutes.

FortiClient 5.4 and later can silently connect to FortiSandbox without needing to be authorized. Users
can de-authorize a FortiClient host manually.

To view connected FortiClients, go to Scan Input > FortiClient.

The following options are available:

Device Filter

Edit

Delete

Users can filter FortiClient by entering part of host name, host IP or
serial number.

Click to edit the FortiClient. Users can enable or disable authorization
of the FortiClient

Click to delete the FortiClient. If FortiClient connects to FortiSandbox
later, it will show up again as a new one.

This page displays the following information:

FCT Serial
Hostname
User

IP

Malicious

High Risk

Medium Risk

Low Risk

Clean

The FortiClient serial number.

Hostname.

Current login user on the FortiClient host

Host IP Address.

The number of malicious files forwarded by the FortiClient to
FortiSandbox in the last seven days. Malicious files are not executed
in the FortiSandbox VM module as the antivirus scanner has already

determined the file rating.

The number of high risk rating files submitted to FortiSandbox in the
last seven days.

The number of medium rating risk files submitted to FortiSandbox in
the last seven days.

The number of low risk rating files submitted to FortiSandbox in the
last seven days.

The number of clean rating files submitted to FortiSandbox in the last
seven days.



Others

Malware Pkg
URL Pkg
Auth

Status

The number of other rating files submitted by FortiGate or FortiMail
to FortiSandbox in the last seven days.

The malware package currently on the device.

The URL package versions currently on the device.

If the FortiClient is authorized.

The status of the FortiClient host. This field displays an up icon when

the device is connected and a down icon for devices which are dis-
connected.

To configure FortiClient to send files to the FortiSandbox and receive results back:

o D=

Go to the Realtime Protection tab in FortiClient.

Select Extended scanning using FortiSandbox, then enter the FortiSandbox IP address in the text box.
If required, select Wait for FortiSandbox results before allowing file access.

Select Identify malware & exploits using signatures or URLS received from FortiSandbox.

Select OK to apply your changes.

For more information about configuring FortiClient, see the FortiClient Administration Guide, available
in the Fortinet Document Library.

Ay

A FortiSandbox system, either a Standalone unit or a cluster system has no
number limitation on authorized devices and FortiClients. However, the con-
current connections of all client devices is limited to 30,000.

Adapter

FortiSandbox uses adapters to connect to third party products. Carbon Black/Bit9 server and ICAP
client are supported. FortiSandbox automatically create an ICAP adapter which allows FortiSandbox to
work as an ICAP server.With an Adapter, FortiSandbox can analyze files downloaded from the Carbon
Black server to send notifications of file verdict back to the server, or receive HTTP message from an
ICAP client and return a response to it.

The following options are available:

Create New

Edit

Delete

Create a new adapter.
Edit an adapter.

Delete an adapter.
ICAP adapter cannot be deleted.

This page displays the following information:

Adapter Name

The Adapter's name.
When the adapter type is ICAP, the value is ICAP.


http://docs.fortinet.com/forticlient/admin-guides

Vendor Name

Serial

FQDN/IP

Malicious

High

Medium

Low

Clean

Unknown

To create a new adapter:

Vendor name.
When the adapter type is ICAP, the value is ICAP.

Serial number.
When the adapter type is ICAP, the value is ICAP.

FQDN/IP address.
When the adapter type is ICAP, the value is empty.

File and URL count of Malicious rating from this Adapter in the last
seven days. Separated by |.

File and URL count of Highly Suspicious rating from this Adapter in
the last seven days. Separated by |.

File and URL count of Medium rating from this Adapter in the last
seven days. Separated by |.

File and URL count of Low rating from this Adapter in the last seven
days. Separated by |.

File and URL count of Clean rating from this Adapter in the last seven
days. Separated by |.

File and URL count of Unknown rating from this Adapter in the last
seven days. Separated by |.

1. Goto Scan Input > Adapter.
2. Clickthe + Create New button from the toolbar.

3. Configure the following:

Vendor Name
Adapter Name
Server FQDN/IP

Token

Timeout (seconds)

Serial

4. Click OKto save the entry.

To edit an adapter:

Select Carbon Blaclk/Bit9 as the vendor name.
Enter the adapter name.
Enter the FQDNY/IP address of the Carbon Black server.

Enter the token string. Authentication token is assigned by the
Carbon Black or ICAP server.

Enter the timeout value.

Auto-generated serial number for this adapter. It works as a
device serial number to denote file's input device.

1. Goto Scan Input > Adapter.

2. Select an adapter.

3. Click the Edit button from the toolbar.



4. Make edits as necessary.
When the adapter type is ICAP, the user can:

« Enable or disable FortiSandbox to work as an ICAP server.

« Define the port for encrypted and non-encrypted communication ports with the client.

« Extract URLs or files from HTTP messages from the client and put them into the Job Queue.
« Define which ratings are treated as bad to return a block code.

« Enable a Real Time AV Scan for a faster response before a file is put into the job queue.

ICAP Settings
# Status
Enable o
% Connection
Port 1344
SSL Support & ]
SSL Port 11344
¥ Methods
Q@ Receive URL @ ] Receive File & )

URLs with selected risk and above will be blocked: URLs with selected risk and above will be blocked:

LowRisk MediumRisk High Risk LowRisk MediumRisk High Risk

Realtime AV Scan

Apply Back

5. Click OKto save the entry.

To delete an adapter

Go to Scan Input > Adapter.
2. Select an adapter.
ICAP adapter cannot be selected.

3. Click the Delete button from the toolbar.
4. Click Yes I'm sure button from the Are you sure confirmation box.

N After a Carbon Black adapter is created, FortiSandbox will try to communicate
9 with Carbon Black server. If the connection and authentication is successful,
= the status column will show a green icon, otherwise a red icon is displayed.

\ M CLI command: diagnose-debug adapter can be used to troubleshoot
I\ communciations with the Carbon Black server.

Configure Carbon Black/Bit9 Server

To be able to configure a Carbon Black (Bit9) server to work with FortiSandbox, you will need to login.



Submitting selected files to FortiSandbox

Computers

‘Computers connected: 2  Total computers: 2  Current CL version: 862

Saved Views:
| (none) v | (Add

Days Disconnected:
(ncne) v

Group By:
| (none) v |[Ascending ¥

show/Hide Filter + | Show/Hide Columns ~ | Export to CSV | Refresh Page

(& Action Go || Clear
o Computer Name Connected Policy Status Upgrade Status Connected Enforcement Disconnected Enforcement

o= WORKGROUP\HENRYDU-PC ‘ [ ] ‘ Up to date | Up to date ‘ Low (Monitor Unapproved) ‘ Low (Monitor Unapproved)

(8] WORKGROUP\WIN-KMIGPUGGBSH ‘ ® ‘ Up to date | Up to date ‘ High (Block Unapproved) ‘ High (Block Unapproved)

2 items Page 1/1

1. Goto Assets > Computers. All computers that are managed by the server will be listed.

2. Inthe left panel, select Files on Computers. All files will be listed on this computer.
=

File Catalog

Files on Computers

Devices

Device Catalog
Devices on Computers

3. Select one or more files.
4. Click the Action button > Analyze with FortiSandbox. The files will be submitted to FortiSandbox for
analysis.

Creating an event rule to automatically submit files to FortiSandbox

Edit Event Rule

General

Rule Name:  [Analyze All New Files ]

Description:

Status: Enabled () Simulate only (@ Disabled

Select Event Properties

B —

@ subtype [is v |[New unapproved file to computer

Add filter |

Select Process Properties

Add filter |

Action:  Analyze file

Priority:

Use Fortisandbox: ¥

Date Created:  Feb 11 2016 09:55:19 AM
Created By:  admin
Date Modified:  Feb 22 2016 07:56:24 PM
Last Modified By:  admin
Last Evaluation Time:  Feb 22 2016 07:55:45 PM
Last Processed Event:  Feb 22 2016 06:28:16 PM

» Processed Events (82 items) (click to expand)




1. Goto Rules > Event Rules.
2. Click the Create Rule button.
3. Configure the settings.

How to view analysis results

Go to Reports > Extemnal Notifications. All files analyzed by FortiSandbox will be listed.

Configure ICAP Client
FortiSandbox can work as an ICAP server with any ProxySG that supports ICAP.

When ICAP client sends a HTTP request to FortiSandbox, FortiSandbox extracts the URL and checks if
a verdict is available. If the verdict is not a user selected blocking rating or not available , a 200 return
code is sent back to client so the request can move on on the client side. If the verdict is user selected
blocking rating, a 403 return code along with a block page is sent back to the client. If no verdict is
available, the URL will be put into the Job Queue for a scan. Scan Profile settings will apply.

When the ICAP client sends a HTTP response to FortiSandbox, FortiSandbox extracts file from it and
checks if verdicts are available. If verdicts are not a user selected blocking rating or not available , a 200
return code is sent back to client so the response can be delivered to the endpoint host. If a verdict is
user selected blocking rating, a 403 return code along with a block page is sent back to the client. If the
user enables Realtime AV Scan, the file will be scanned by the AV Scanner. If the file is a known virus, a
403 return code along with a blocked page is sent back to the client. If no verdict is available, these files
will be put into the Job Queue for a scan. Scan Profile settings will apply.

When ICAP client sends a preview request, FortiSandbox returns a 204 return code, which means it is
not supported.

The following is an example ICAP configurations for a SQUID 4.x proxy server, which should be added
tothe end of squid. conf file:

cache deny all

icap enable on

icap send client ip on

icap send client username on

icap client username header X-Authenticated-User

icap preview enable off

icap persistent connections off

icap service svcBlockerl regmod precache icap://fortisandbox ip:port number/reqmod
Eypass:O ipve=off N a a

adaptation access svcBlockerl allow all

icap service svclLoggerl respmod precache icap://fortisandbox ip:port
Eumber/respmod routing=on i§v6=off a a

adaptation access svcLoggerl allow all

##4 add the following lines to support ssl ###

#icap service svcBlocker2 reqmod precache icaps://sandbox ip:ssl port
namber/reqmod bypass=1 tls—fiags:DONT_VERIFY_PEER B N B

#adaptation access svcBlocker2 allow all

#icap service svclLogger2 respmod precache icaps://sandbox ip:ssl port
number/respmod bypass=1 tls-flags=DONT VERIFY PEFR - -

#adaptation access svcLogger2 allow all



Network Share

FortiSandbox can scan files stored on a network share and optionally quarantine any malicious files. Go
to Scan Input > Network Share to view and configure network share information.

Network share scans can be scheduled or run on-demand, and connectivity with the network share can
be tested.

The following options are available:
Create New Select to create a new network share.

Edit Select an entry from the list and then select Edit in the toolbar to edit
the entry selected.

Delete Select an entry from the list and then select Delete in the toolbar to
remove the entry selected.

Scan Now Select an entry from the list and then select Scan Now in the toolbar
to scan the entries.

Scan Details Select an entry from the list and then select Scan Details in the tool-
bar to view the scheduled scan entries.

Test Connection Select an entry from the list and then select Test Connection in the

toolbar to test the connection. Result message will be displayed in
the top message bar.

The following information is displayed:

Name The name of the network share.

Scan Scheduled The scan scheduled status.

Type The mount type.

Share Path The file share path.

Quarantine Displays if the quarantine enabled status.

Enabled Displays if the network share is enabled. If a network share is dis-

abled, its scheduled scan will not be executed.

Status Displays the network share status. One of the following states:
o Network is Accessible

« Network Down

To create a new network share:

1. Goto Scan Input > Network Share.
2. Click the + Create New button from the toolbar.
3. Configure the following options:



Enabled

Network Share Name

Mount Type

Server Name/IP
Share Path

Scan Files Of Specified
Pattern

File Pattern Name

Username

Password

Confirm
Password

Keep A Copy Of Original
File On FortiSandbox

Skip Sandboxing for the
same unchanged files

Enable Quarantine of
Malicious Files

Enable Quarantine of
Suspicious - High Risk
Files

Select to enable network share configuration. If network share is not
enabled, its scheduled scan will not run.

Enter the network share name.

Select the mount type from the drop-down list. The following options
are available:
« CIFS

o NFSv2
e NFSv3
« NFSv4

Enter the server fully qualified domain name (FQDN) or IP address.
Enter the file share path. In the format /pathl/path2

Select to include or exclude files which match a file pattern.

Enter the file pattern name.

Enter a user name. For a domain users, use format domain
name\user name.

Enter the password.

Enter the password a second time for verification.

Select to keep a copy of the original file on FortiSandbox.

Select to skip Sandboxing scan on existing files and only Sandboxing
scan of new files. Existing files will only be scanned by AntiVirus
engine and Community Cloud query. This is to improve scan speed.

Select to enable quarantine then select the quarantine location from
the drop-down list. Files with a Malicious rating will be quarantined in
the quarantine location.

Quarantined file is placed inside a folder with the name of the Job ID.
Inside the folder each quarantined file is renamed with the
corresponding Job ID for that particular file and a meta file with more
information.

Select to enable quarantine of Suspicious High Risk files, then
select the quarantine location from the drop-down list. Files with a
High Risk rating will be quarantined in the quarantine location.

Quarantined file is placed inside a folder with the name of the Job ID.
Inside the folder each quarantined file is renamed with the
corresponding Job ID for that particular file and a meta file with more
information.



Enable Quarantine of
Suspicious - Medium
Risk Files

Enable Quarantine of
Suspicious - Low Risk
Files

Enable Quarantine of
Other rating files

Enable moving clean
files to a sanitized
location

Enable Scheduled Scan

Select to enable quarantine of Suspicious Medium Risk files, then
select the quarantine location from the drop-down list. Files with a
Medium Risk rating will be quarantined in the quarantine location.

Quarantined file is placed inside a folder with the name of the Job ID.
Inside the folder each quarantined file is renamed with the
corresponding Job ID for that particular file and a meta file with more
information.

Select to enable quarantine of Suspicious Low Risk files, then
select the quarantine location from the drop-down list. Files with a
Low Risk rating will be quarantined in the quarantine location.

Quarantined file is placed inside a folder with the name of the Job ID.
Inside the folder each quarantined file is renamed with the
corresponding Job ID for that particular file and a meta file with more
information.

Select to enable quarantine of Other Rating files, then select the
quarantine location from the drop-down list. Files with a Other rating
, Wwhich means the scan was not completed for some reason, will be
quarantined in the quarantine location.

Quarantined file is placed inside a folder with the name of the Job ID.
Inside the folder each quarantined file is renamed with the
corresponding Job ID for that particular file and a meta file with more
information.

Select to move Clean rating files to another location. When a Clean
file is moved, its folder structure is kept at sanitized location.

Select to enable scheduled scan. Select the schedule type from the
drop-down list. Select the minute or hour from the second drop-down
list.

Description Enter an optional description for the network share entry.
Mo When a file is moved, to leave a copy in its original location, the user
9 can go to the Quarantine edit page or sanitized share and select the

Keep Original File At Current Location checkbox.

4. Select OK to save the entry.

To run a network share scan immediately:

1. Goto Scan Input > Network Share

2. Select a share.

3. Click the Scan Now button to run the scan immediately.

To test network share connectivity:

1. Goto Scan Input > Network.

2. Select a share.



3. Click Test Connection to test connectivity with the network share.

Scan Details

The Scan Detailspage shows scheduled scans for the selected network share. To open the Scans
page, select a network share, then select Scan Details from the toolbar.

The following information is shown:

Back Go back to the network share page.

Refresh Refresh the scans page.

Delete Delete the selected scan.

Total The total number of finished scanned jobs.

Start The start time of the scan.

End The end time of the scan.

Finished Percentage of files that finished the scan. Click on the number to
show details.

Malicious The number of Malicious files discovered. Click on the number to

show detected Malicious rating files. The number of quarantined
files are also displayed.

Suspicious The number of Suspicious files discovered, divided in High Risk,
Medium Risk and Low Risk columns. Click on the number to show
detected Suspicious rating files. The number of quarantined files are
also displayed.

Clean The number of Clean files detected. Click on the number to show
detected Clean rating files.

Others The number of files that do not finish scanning for various reasons.

Click on the number to show them. The number of quarantined files
are also displayed.

When jobs are displayed after clicking links on numbers, clicking the Job Detail button will display the
details. If the detailed job information has been deleted according to the settings in the Scan Profile >
General page, the job details will not be displayed.

Quarantine

Go to Scan Input > Quarantine to view the quarantine information.

The following options are available:

Create New Select to create a new quarantine location.



Edit

Delete

Test Connection

Select an entry from the list and then select Edit in the toolbar to edit
the entry selected. When editing an entry you can select to test con-
nectivity to ensure that the quarantine location is accessible.

Select an entry from the list and then select Delete in the toolbar to
remove the entry selected.

Select an entry from the list and then select Test Connection in the
toolbar to test the connection. The result will show in the top mes-
sage panel and will disappear after a few seconds.

The following information is displayed:

Name
Type
Share Path
Enabled

Status

The name of the quarantine location.

The mount type.

The file share path.

Displays if the quarantine location is enabled.

Displays the quarantine access status. One of the following states:
o Quarantine is Accessible

o Quarantine Down

To create a new quarantine entry:

1. Goto Scan Input > Quarantine.
2. Click the + Create New button from the toolbar.
3. Configure the following options:

Enabled
Quarantine Name

Mount Type

Server Name/IP
Share Path

Username

Password

Confirm Password

Select to enable quarantine location.
Enter the quarantine name.

Select the mount type from the drop-down list. The following options
are available:
o CIFS

o NFSv2
o NFSv3
o« NFSv4

Enter the server fully qualified domain name (FQDN) or IP address.
Enter the file share path. In the format /pathl/path?2.

Enter a user name. For a domain user, use the format domain_
name\user name.

Enter the password.

Enter the password a second time for verification.



Keep Original File At Select to keep the original file at the current location when a file is
Current Location quarantined form a network share. By default, the original file is kept
at its current location when being moved.

Description Enter an optional description for the quarantine location entry.

4. Select OK to save the entry.

To edit a quarantine:

Go to Scan Input > Quarantine.
Select a quarantine.

Click the Edit button from the toolbar.
Make the necessary changes.

Click OK to save the entry.

o ODd=

To delete a quarantine:

Go to Scan Input > Quarantine.

Select an quarantine.

Click the Delete button from the toolbar.

Click Yes I'm sure button from the Are you sure confirmation box.

P obd =

Malware Package

Go to Scan Input > Malware Package, to view the Malware Package list.

The following options are available:

Refresh Refresh the Malware Package list.

View Select a package version number and click the View button from the
toolbar. The following information is shown:

« Job Detail: View the file's detailed information.

« Mark the detection as False Positive: If marked, the entry will
be removed from future Malware Packages. If the unit is
joining a global threat information sharing network, the
change is also reported to the Collector and is shared by all
units in the network.

« Detected: The time and date that the item was detected.
« Checksum: The file checksum (SHA256).
« Rating: The risk rating.

« Serial Number: From which unit the threat information is
from.

o Global/Local: If this threat information is from a local unit, or
from another unit.

Download SHA256 You have the option to download packages containing malware
Download SHA1 SHA256, SHA1 and MD5.
Download MD5



This page displays the following:

Version The malware package release version.
Release Time The malware package release time.
Total The total number of malware antivirus signatures inside the package.

The maximum number of signatures is 100K.

Ay
9 FortiSandbox only keeps malware packages generated in last 7 days.

URL Package

Go to Scan Input > URL Package, to view the URL Package list.

The following options are available:

Refresh Refresh the URL Package list.

View Select a package version number and click the View button from the

toolbar. The following information is shown:
« Job Detail: View the downloaded file's detailed information.

« Mark the URL as False Positive: If marked, the URL will be

global threat information sharing network, the change is also
reported to the Collector and is shared by all units in the
network. A new package will generate after removing the
entry.

« Detected: The time and date that the item was detected.

« URL: The URL in the package.

« Rating: The risk rating of the downloaded file.

« Serial Number: From which unit the threat information is
from.

o Global/Local: If this threat information is from a local unit, or
from another unit.

Download URL You have the option to download the malware's download URL. It is
not related to URL scan.

This page displays the following:

Version The URL package release version.
Release Time The URL package release time.
Total The total number of malware antivirus signatures inside the package.

The maximum number of signatures is 1000.



~9, FortiSandbox only keeps URL packages generated in last 7 days.




HA-Cluster

There are limits to the number of files that a single FortiSandbox can scan in a given time period. To
handle heavier loads, multiple FortiSandbox devices can be used together in a load-balancing high
availability (HA) cluster.

There are three types of nodes in a cluster: Master, Primary Slave, and Slave.

FortiSandbox HA Cluster
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Master The Master node (Unit 1 in the diagram) manages the cluster, distributes jobs
and gathers the results, and interacts with clients. It can also perform normal
file scans. All of the scan related configuration should be done on the master
node and they will be broadcasted from the Master node to the other nodes.
Any scan related configuration that has been set on a slave will be overwritten.

On the Master node, users can:
« Change a slave node's role (Primary and Regular slave)
« Configure a slave node's network settings
o Upgrade slave nodes
« View VM status page of slave nodes
« Configure FortiGuard settings of slave nodes
« Configure VM images of slave nodes, such as setting clone numbers of
each VM image
« Configure a Ping server to frequently check unit's network condition and

downgrade itself as a Primary Slave node when necessary to trigger a
failover

Although all FSA models can work as a Master node, it is advised to use a
FortiSandbox-3000D or above model.

Primary Slave The Primary Slave node (Unit 2 in the diagram) is for HA support and normal
file scans. It monitors the master's condition and, if the master node fails, the
primary slave will assume the role of master. The former master will then
become a primary slave when it is back up.

The Primary Slave node must be the same model as the Master node.

Slave The Slave nodes (Units 3 - 5 in the diagram) perform normal file scans and
report results back to the master and primary slave. They can also store
detailed job information. Slave nodes should have its own network settings and
VM image settings.

The Slave nodes can be any FortiSandbox model, including FortiSandbox VM.
Slave nodes in a cluster does not need to be the same model.

sq' The total number of slaves, include the primary slave, can not exceed 100.

sq' It is advised to use FortiSandbox-3000D and above if the job load is heavy.

Centrally manage Slave nodes on the Master node
Users can manage Slave nodes on the Master node.

1. Goto HA Cluster.
2. Select the Slave node's serial number.
3. Users can perform any of the following tasks:



a. View the Slave node's dashboard.
Switch the Slave node's role using the Dashboard > System Information widget.

Configure the Slave node's network settings (such as its IP address, routing table, DNS and
Proxy settings). Configure Slave nodes' network settings for VM external traffic through port3.

Upgrade the Slave node (including firmware, AV database etc.).
View the Slave node's VM Status page.
f. View and configure Slave node's VM image settings.

Requirements before Configuring a HA Cluster

1.

The scan environment on all cluster nodes should be the same.

For example, the same set of Windows VM should be installed on all nodes so the same scan
profile can be used.

Port3 on all nodes should be connected to the Internet separately.

All nodes should be on the same firmware build.

Each node should have a dedicated network port for internal cluster communication.
Internal cluster communication includes:

« jobdispatch

« job result reply

« setting synchronization

« clustertopology broadcasting

It's recommended these ports are connected to the same switch and

Ay

~9' have IP addresses in the same subnet. If the job load is heavy, the 10G
= fiber port is recommended to be used as the internal communication
port.

Master's Role and Slave's Role

On the Master node, all functionalities are turned on. This includes accepting files from different input
sources, sending alert emails, and generating malware packages. Scan profiles should also be
configured on the Master node and will be synchronized to other nodes. The following information is
synchronized from the Master node to all other nodes so they should not be configured on Slave nodes:

Job cleanup schedule

FortiGuard page settings

Malware package generation settings

VM access to the Internet settings.

Only the Allow Virtual Machines to access extemnal network through outgoing Port3 status is
synchronized. The network settings for Port3 (IP address) and next hop gateway, etc., are not
synchronized. They have to be set on each unit separately.

Black and White lists

Yara rules

Scan profile settings

The following information are synchronized from the Master node to Primary Slave nodes only, and are
only applied when the Primary Slave node becomes a Master during a failover:



« Users

« Archive server settings

« Sniffer settings

« Mail server settings

« Network settings (including DNS, proxy, and routing tables)
« Scheduled task settings (network share scans, and scheduled report generation)
« Log server settings

« Uploaded certificates

« Devices

« SNMP settings

« Widget settings

« Adapter settings

« Others (login disclaimers)

Configure a cluster level fail-over IP set for Master unit

The user can configure a cluster level fail-over IP for each port except port3 and ports the sniffer is
sniffing. This IP set works as an alias IP of the Master node network port. The Master node Local IP set
and Primary Slave node Local IP set are kept during fail-over.

This fail-over IP set should be set on the current Master node through the CLI command hc-
settings. Itshould be in the same subnet of each port’s local IP. Client devices such as FortiGate
should point to this fail-over IP. When a failover occurs, this fail-over IP set will be applied on the new
Master node.

Main HA Cluster CLI Commands

CLI Command Description

hc-settings Configure the unit as a HA Cluster mode unit. Configure
cluster fail-over IP set.

hc-status List the stats of HA Cluster units.
hc-slave Add, Update, Remove a slave unit to or from the HA Cluster.
hc-master Turn on/off the file scan on the Master node and adjust the

Master's scan power.

Example configuration

This example shows the steps for setting up an HA cluster using three FortiSandbox 3000D units.

Step 1 - Prepare the hardware
The following hardware will be required:

« Nine cables for network connections
« Three 1/10 Gbps switches
« Three FortiSandbox 3000D units with proper power connections (units A, B, and C).



The master and primary slaves should be on different power circuits.

Step 2 - Prepare the subnets

Prepare three subnets for your cluster (customize as needed):

« Switch A: 192.168.1.0/24: For system management.
« Gateway address: 192.168.1.1
« External management IP address: 192.168.1.99

o Switch B: 192.168.2.0/24: For internal cluster communications.

« Switch C: 192.168.3.0/24: For the outgoing port (port 3) on each unit.
« Gateway address: 192.168.3.1

Step 3 - Setup the physical connections

1. Connect port 1 of each FortiSandbox device to Switch A..
2. Connect port 2 of each FortiSandbox device to Switch B.
3. Connect port 3 of each FortiSandbox device to Switch C.

Step 4 - Configure the master

1. Power on the device (Unit A), and log into the CLI (see Connecting to the Command Line Interface on
page 11).
2. Configure the port IP addresses and gateway address with the following commands:
set portl-ip 192.168.1.99/24
set port2-ip 192.168.2.99/24
set port3-ip 192.168.3.99/24
3. Configure the device as the master node and its cluster fail-over IP for Port1 with the following
commands:
hc-settings -sc -tM -nMasterA -cTestHCsystem -ppasswOrd -iport2
hc-settings -si -iportl -al92.168.1.98/24
See the FortiSandbox CLI Reference Guide available on the Fortinet Document Library for more
information about the CLI commands.

4. Review the cluster status with the following command:
hc-status -1
Other ports on the device can be used for file inputs.

Step 5 - Configure the primary slave

1. Power on the device (Unit B), and log into the CLI.

2. Configure the port IP addresses and gateway address with the following commands:
set portl-ip 192.168.1.100/24
set port2-ip 192.168.2.100/24
set port3-ip 192.168.3.100/24
3. Configure the device as the primary slave node with the following commands:
hc-settings -s —-tP -nPslaveB -iport2
hc-settings -1
hc-slave -a -s192.168.2.99 -ppasswOrd
4. Review the cluster status with the following command:
hc-status -1


http://docs.fortinet.com/fortisandbox/reference

Step 6 - Configure the normal slave

Power on the device (Unit C), and log into the CLI.

2. Configure the port IP addresses and gateway address with the following commands:

set portl-ip 192.168.1.101/24
set port2-ip 192.168.2.101/24
set port3-ip 192.168.3.101/24
3. Configure the device as a slave node with the following commands:
hc-settings -s -tR -nSlaveC -iport2
hc-settings -1
hc-slave -a -s192.168.2.99 -ppasswOrd
4. Review the cluster status with the following command:
hc-status -1

Step 7 - Configure other settings

VM Image settings and network settings, such as default gateway, static route, and DNS servers etc.,
should be configured on each unit individually. Scan related settings, such as the scan profile, should
be set on Master unit only; they will be synchronized to the Slave node. For more details, refer to
Master's Role and Slave's Role on page 138.

Step 8 - Finish

The HA cluster can now be treated like a single, extremely powerful standalone FortiSandbox unit.

In this example, files are submitted to, and reports and logs are available over IP address

192.168.1.99.
N” FortiSandbox 3500D unit has been configured as a cluster system, with blade 1
N\ configured as the Master node, blade 2 as the Primary Slave node and the

other blades as Regular Slave nodes.

What happens during a failover

The Master node and Primary Slave nodes sends heartbeats to each other to detect if it peers are alive.
If the Master node is not accessible, such as rebooting, a fail-over will occur. Users can also configure a
Ping server to frequently check the unit's network condition and downgrade itself to Primary Slave type

when the condition is appropriate to trigger a failover. The failover logic handles two different scenarios:

Scenario Description

Objective node avail- The Object node is a slave (either Primary or Regular) that can justify

able the new Master. For example, if a cluster is consisted of one Master
node, one Primary Slave node, and one Regular Slave node, the Regu-
lar Slave node is the objective node.

After a Primary Slave node takes over the Master role, and the new role
is accepted by the Object node, the original Master node will accept the
decision when it is back online.

After the original Master is back online, it will become a Primary Slave
node.



Scenario Description

No Objective node This occurs when the cluster's internal communication is down.
available
For example, the cluster contains one Master node and one Primary
Slave node and the Master node reboots; or the internal cluster com-
munication is down due to a failed switch, all Primary Slave nodes
become the Master (more than one Master unit).

When the system is back online, the unit with the largest Serial Number
will keep the Master role and the other will return back to a Primary
Slave.

When the new Master is decided, it will:

1. Restart the main controller to rebuild the scan environment.

2. Apply all the setting synchronized from the original Master except port3 IP and the internal cluster IP of

the original Master.
After a failover occurs, the original Master might become a Primary Slave node and the following will be

reset:
Port1 IPv4 |IP 192.168.0.99
IPv6 Empty

It keeps its original Port3 IP and internal cluster communication IP. All other interface ports will be
shutdown as it becomes a slave node. Some functionalities will be turned off such as Email Alerts. If
the user wants to re-configure its settings, such as the interface IP, the user must do that through the
CLI command or the Master's Central Management page.

As the new Master takes over, the network settings of the management port
~‘9"' (port1) and the port that client devices communicate with, will switch to it. As
s the new Master starts up all the services, clients may experience a temporary
service interruption.

Upgrading or rebooting a Cluster

Upgrading or rebooting a Cluster has to be done by logging into each device or through the Master
unit's central management interface by going into each device's dashboard page. You must upgrade
the cluster in the following order:

1. Slave devices

2. Primary Slave

3. Master
N If you are upgrading from 2.1 to 2.2, you have to reconfigure the cluster on the
9 master because 2.2 brings new features, such as redesigned scan profile,

clone number for each VM, and isolated port3 configuration.




It is highly recommended to setup cluster level fail-over IP set so the fail-over
between Master and Primary Slave can occur smoothly. If the user does not

>{‘ want the fail-over to happen, the user can change the Primary Slave unit role to
Regular Slave. You can either do this through the Ul dashboard or the CLI prior
to the fail-over, then change the role back after the unit boots up.

In-line mode

~‘9"' FortiSandbox can be configured in an HA cluster to increase the number of files
= that can be scanned in a given time period and add redundancy.

In-line mode in core environments

FortiGate, FortiMail, or FortiClient can be configured to submit either only suspicious files or all files to
the FortiSandbox for inspection. This seamless integration reduces network complexity and expands
the applications and protocols supported, including those that are SSL encrypted such as HTTPS.

Integration in core environment topology

FortiSandbox |*

Headquarters
(Enterprise Core)

In-line mode in distributed enterprise environments

This deployment is attractive for organizations that have distributed environments, where FortiGate
and FortiMail devices, along with FortiClient endpoints, are deployed in the branch offices and submit
suspicious files to a centrally located FortiSandbox. This setup yields the benefits of the lowest total
cost of ownership, and protects against threats in remote locations.



Integration in distributed environment topology

FortiSandbox [ Headquarters

(Enterprise Core)

Brach Offices
(Distributed Enterprise) >

Health Check

The Health Check page is only available on the Master node. Users can use the HA Health Check to set
up a Ping server to ensure the network condition between client devices and FortiSandbox is always up.
If not, the Master node will downgrade itself to a Primary Slave node if there is at least one Primary
Slave node existing, a failover will occur after the configured period elapses. If no Primary Slave node
exists, the Master node will keep its Master role.

The following options are available:

Create New Create a new health check Ping server.
Edit Edit a health check Ping server.
Delete Delete a health check Ping server.

This page displays the following information:



Interface
Remote Server

Ping

TCP Echo

Interval

Failover Threshold

The interface port to connect to the Ping server.
IP address or fully-qualified domain name of the remote Ping server.

Enable or disable sending the Ping packet to the remote server to
ensure the network connection is up.

Enable or disable sending TCP Echo packet to ensure the network
connection to the remote sever is up.

Time interval in seconds (30-180 seconds) to send a Ping or TCP
Echo packets.

Failover threshold (3-120 times). After a certain number of con-
secutive missing responses of Ping or TCP Echo packets, the Master
node will downgrade itself as a Primary Slave if there is an existing
Primary Slave node.

To create a new HA Health Check

Configure the settings.
Click Ok.

P obd =

To edit a HA Health Check

Edit the settings.
Click Ok.

o Db

Go to HA-Cluster > Health Check.
Click + Create New from the tool bar.

Go to HA-Cluster > Health Check.
Select the Health Check you want to edit.
Click the Edit button from the toolbar.

To delete a HA Health Check

oo Db =

Job Summary

Go to HA-Cluster > Health Check.

Select the Health Check you want to delete.

Click the Delete button from the toolbar.

Click the Yes, I'm sure button to delete the Health Check.

The Job Summary page shows job statistics data of each node in a cluster. It is only available on the

Master node.

To view a HA Job Summary

1. Goto HA-Cluster > Job Summary.
2. Select either File or URL button to view file-based scan results and URL scan results..
The following information is shown:



Time Period Drop Select the period of time over which the data was collected
down from the drop down. You have the following options: Last 24
Hours, Last 7 Days, and Last 4 Weeks.

Serial Number The serial number of the device in the cluster.

Pending The number of files in the job queue waiting to be scanned.

Malicious The number of malicious files detected.

Suspicious The number of suspicious files detected.

Clean The number of clean files detected.

Other Other files that have been scanned and have an Unknown
rating.

Select a number from the Malicious, Suspicious, Clean or Other columns to view details
about those specific files.

Status

The Status page shows the basic information of cluster nodes.

To view a HA Status

1. Goto HA-Cluster > Status.
The following information is shown:

Serial Number The serial number of the device in the cluster.
Type The type of the device: Master, Primary Slave, or Regular
Slave.
Alias The device's alias.
IP Address The device's internal communication |IP address.
Status The status of the device: Active or Inactive.
~‘9"' The total number of cluster members are shown at the bottom of the list. This

number cannot exceed 101, including the master.

HA Cluster Information

On a Master, you can select a Slave to view and manage the following information pertaining to that
Slave:



For more detailed information regarding each section, click on the respective link.

System Status Dashboard: The following widgets are displayed: System Information, Scanning Statistics,
System Resources, and Disk Monitor.

Interfaces on page 47

Static Routing on page 49

DNS Configuration on page 49
General on page 79 (VM Network)
FortiGuard on page 65

VM Status on page 70

VM Images on page 71



File Detection

Summary Report

The Summary Reports page provides a page similar to the System dashboard. You can add and
customize widgets in this page. By selecting a device and time period, you can customize what data is
displayed. To view the summary reports page go to File Detection > Summary Report.

If the unit is the master node in a cluster, the data are a summary of all cluster nodes. Otherwise, only
the individual unit's data are displayed.
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~9' On-Demand job data is not included.
== Scanning Statistics S o %X
Rating Count WINXPVM WINTXEAVM
Malicious 883 0 0
Suspicious - High Risk 0 0 0
Suspicious - Medium Risk 1 0 0
Suspicious - Low Risk 11 2 1
Total 895 2 1
Last Updated: Tue, Mar 1, 2016 11:35
The following options are available:
Add Widget Click the button to add widgets to the summary report page.
Reset View Click the button to restore widgets to the default setting. A con-

firmation dialog box will be displayed, select OK to continue.

Time Period Select a time period to be displayed from the drop-down list. The
options are: Last 24 hours, Last 7 days, Last 2 weeks.

Device Select the device from the drop-down list.
The following widgets are available:

Scanning Statistics Displays a table providing information about the files scanned for a
selected device for a selected time period.



Scanning Statistics by Displays a table proving information about file types, rating, and

Type event count for a selected device over a selected time period.

Top Targeted Hosts Displays a chart providing the number of infection events for specific
hosts that have occurred for a selected device over a selected time
period.

Hover the cursor over a colored portion of a bar in the chart to view
the exact number of infection events that have occurred for the host
selected.

Selecting the infected host allows you to drill down to the job details.

File Scanning Activity Displays the number of clean, suspicious, and malicious events that
have occurred at specific times over a selected time period for the
selected device.

Hover the cursor over a colored portion of a bar in the graph to view
the exact number of events of the selected type that occurred at that
time.

Top Infectious URLs Displays a chart providing the top infectious URLs that have been
detected over a selected time period.
Hover the cursor over a colored portion of a bar in the chart to view
the exact number of infection events that have occurred for the mal-
ware selected.

Top Malware Displays a chart providing the number of infection events for specific
malware that have occurred for a selected device over a selected
time period.

Hover the cursor over a colored portion of a bar in the chart to view
the exact number of infection events that have occurred for the mal-
ware selected.

Selecting the malware name allows you to drill down to the job
details related to them.

Top Callback Domains Displays a chart providing the top callback domains that have been
detected over a selected time period. Callback domains are hosts
that files visit when executing in VM.
Hover the cursor over a colored portion of a bar in the chart to view
the exact number of infection events that have occurred for the mal-
ware selected.

Top File Types Displays a chart providing the top file types that have been detected
over a selected time period. When Scanned by Sandboxing is selec-
ted, only files that have finished sandboxing will be counted.

Customizing the summary report page

The FortiSandbox summary reports page can be customized. You can select the device and time period
in the toolbar to display specific information. You can also select which widgets to display, where they
are located in the page, and whether they are minimized or maximized.

To move a widget

Position your mouse cursor on the widget'’s title bar, then click and drag the widget to its new location.



To refresh a widget

Click the refresh icon in the widget'’s title bar to refresh the data presented in the widget.

To add a widget

In the dashboard toolbar, select Add Widget, then select the names of widgets that you want to add.
To hide a widget, in its title bar, select the Close icon.
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~9' Multiple widgets of the same type can be added to the dashboard. This can be
= useful for viewing information over different refresh time intervals.

To edit a widget

Click the edit icon in the widget'’s title bar to open the edit widget settings window.

Configure the following information, and then select OK to apply your changes:

Custom widget title Optionally, enter a custom title for the widget. Leave this field blank
to use the default widget title.

Refresh interval Enter a refresh interval for the widget, in seconds. The widgets have
default refresh values:
« Scanning Statistics: 3600 seconds

« Scanning Statistics by Type: 3600 seconds
o Top Malware: 3600 seconds

« Scanning Activity: 300 seconds

o Top Targeted Hosts: 10 seconds

« Top Infectious URLs: 3600 seconds

o Top Callback Domains: 3600 seconds

Top Count Select the number of entries to display in the widget. The top count
can be between 5 to 20 entries. This setting is available in all widgets
except Scanning Statistics, Scanning Statistics by Type, and Scan-
ning Activity.

File Scan

File Scan page shows file based job scans. Users can toggle to view Malicious, Suspicious and Clean
job ratings. By default, Suspicious jobs are displayed.

In this page, you can view job details and apply search filters. You can select to create a PDF or CSV
format snapshot report for files based on search filters.

The following options are available:

File Scan Options
Malicious Click the Malicious icon to view the malicious jobs.

Suspicious Click the Suspicious icon to view the suspicious jobs.



Clean Click the Cleanicon to view the clean or unknown jobs.

Refresh Click the button to refresh the entries displayed.

Search Show or hide the search filter field.

Add Search Fil- Click the search filter field to add search filters. Click the
ter close icon in the search filter field to clear all search filters.

When the search criteria is Domain, select the equal icon
to toggle between exact search and pattern search.

The search filter will be displayed below the search filter
field. Click the close icon beside the search filter to remove
the filter.

Search filters can be used to filter the information dis-
played in the GUI.

Export Data Click the Export Data button to create a PDF or CSV snap-
shot report. The time to generate the report is dependent
on the number of events selected. Do not close the dialog
box or navigate away from the page during report gen-
eration.

Customize Click the Customize button to customize the Job View Set-
tings. The change will be applied to all file based scan res-
ult pages.

Action

View Details Click the View Details icon to view the file description and
analysis details. The information displayed is dependent
on the file selected.

Perform Rescan For Malicious jobs, users can also select the Rescan icon
to perform a manual rescan of the file. By this way, you can
find out the behavior of a known virus. You can select to
skip Static Scan, AV Scan, Cloud Query, and Sandboxing
in the rescan settings.

Archived File An icon will appear if the file is an Archived File.
AV Scan An icon will appear if this job is from an AV Rescan.

Pagination Use the pagination options to browse entries displayed.

FortiSandbox has a Anti Virus rescan feature. When a new antivirus signature is available,
FortiSandbox will perform a second antivirus scan of all the jobs from last 48 hours whose ratings are
Clean or Suspicious using the new signatures. Detected viruses will be displayed as Malicious jobs
with the Rescan icon beside the View Details icon. The original job can still be viewed in the job detail
page of the rescanned file by clicking the original job ID.

Virus behavior information is not collected as viruses are detected by the AV
>\ scanner. The rescan feature allows you to see how a virus behaves while it is
being executed inside a VM.




The displayed columns are determined by settings defined in System > Job View Settings > File
Detection Columns page. For more information, see Job View Settings on page 67.

To view file details:

1.
2,

Select afile.

Click the View Details icon. A new tab will open. See Appendix A - View Details Page Reference on
page 170 for descriptions of the View Details page.

Close the tab to exit the View Details page.

To rescan a file:

o o0Dbd=

Select a file with Malicious Rating.

Click the Perform Rescan icon.

You can select to skip Static Scan, AV Scan, Cloud Query, and Sandboxing.
Click OK to start the rescan.

Click the close icon or select the Close button to close the dialog box.

by

“9' Rescan results are found in the Scan Input > File On-Demand.

To create a snapshot report for all malicious files:

Click the Export Data button in the toolbar. The Report Generator window opens.

Select either PDF or CSV for the report type. Optionally you can further define the report start/end date
and time.

Click the Generate Report button to create the report.
When the report generation is completed, select the Download button to save the file to your
management computer.

Click the close icon or select the Cancel button, to quit the report generator.

R In this release, the maximum number of events you can export to PDF report is
9 5,000; the maximum number of events you can export to CSV report is
= 150,000.




Network Alerts

Network Alerts allows you to view network based activity. You must enable network alerts detection in
Scan Input > Sniffer. Sniffed data is scanned by the IPS engine to populate data on this page. You can
select to view data for a specific time period. In the Networks Alerts page, you can view alerts (Attacker,
Botnet, and URL), and drill down the information displayed and apply search filters.

Summary Report

The Summary Reports page provides a page similar to the System dashboard. You can add and
customize widgets in this page. By selecting the time period, you can customize what data is displayed.
To view the summary reports page go to Network Alerts > Summary Report.

+ Add widget ) ResetView || @ Last24Hours

o
x

x = Top Network Attacks &

Q

= Event Trend &

| Network Attack Suspicious URL Visit Botnet Callback

Last Updated: Tue, Mar 1, 2015 12:00 Last Updated: Tue, Mar 1, 2015 12:00

o
x

= Top Attacked Hosts & % = Top Communicated Botnet &

Last Updated: Tue, Mar 1, 2018 12:00 Last Updated: Tue, Mar 1, 2016 12:00
The following options are available:

Add Widget Click the button to add widgets to the summary report page.

Reset View Click the button to restore widgets to the default setting. A con-
firmation dialog box will be displayed, select OK to continue.

Time period Select a time period to be displayed from the drop-down list. The
options are: Last 24 hours, Last 7 days, Last 2 weeks.

The following widgets are available:

Event Trend Displays a table providing information about the number of network
attacks, suspicious URL visits, and Botnet callbacks over a period of
time.

Hover the cursor over a colored portion of a bar in the graph to view
the exact number of events that occurred at that time.



Top Network Attacks

Top Attacked Hosts

Top Communicated Bot-
net

Top Botnet Infected
Hosts

Top Visited Suspicious
URL Hosts

Top Hosts Visiting Sus-
picious URL

Displays a table providing information about the number and type of
network attacks.

Hover the cursor over a colored portion of a bar in the graph to view
the exact number of events that occurred at that time.

Displays a table providing information about the top attacked hosts
on your network.

Hover the cursor over a colored portion of a bar in the graph to view
the exact number of events that occurred at that time.

Displays a table providing information about the top communicated
botnets on your network.

Hover the cursor over a colored portion of a bar in the graph to view
the exact number of events that occurred at that time.

Displays a table providing information about the top botnet infected
hosts on your network.

Hover the cursor over a colored portion of a bar in the graph to view
the exact number of events that occurred at that time.

Displays a table providing information about the top visited sus-
picious URL hosts.

Hover the cursor over a colored portion of a bar in the graph to view
the exact number of events that occurred at that time.

Displays a table providing information about the top hosts visiting sus-
picious URLs.

Hover the cursor over a colored portion of a bar in the graph to view
the exact number of events that occurred at that time.

Customizing the summary report page

The FortiSandbox summary reports page can be customized. You can select the time period in the
toolbar to display specific information. You can also select which widgets to display, where they are
located on the page, and whether they are minimized or maximized.

To move a widget

Position your mouse cursor on the widget'’s title bar, then click and drag the widget to its new location.

To refresh a widget

Click the refresh icon in the widget'’s title bar to refresh the data presented in the widget.

To add a widget

In the dashboard toolbar, select Add Widget, then select the names of widgets that you want to add.
To hide a widget, in its title bar, select the Close icon.



To edit a widget
Click the edit icon in the widget'’s title bar to open the edit widget settings window.

Configure the following information, and then select OK to apply your changes:

Custom widget title Optionally, enter a custom title for the widget. Leave this field blank
to use the default widget title.

Refresh interval Enter a refresh interval for the widget, in seconds. Set the field to 0 to
disable. The widgets have default refresh values:
o Event Trend: 3600 seconds

o Top Network Attacks: 3600 seconds

o Top Attacked Hosts: 3600 seconds

o Top Communicated Botnet: 3600 seconds

« Top Botnet Infected Hosts: 3600 seconds

« Top Visited Suspicious URL Hosts: 3600 seconds

o Top Hosts Visiting Suspicious URLs: 3600 seconds

Top Count Select the number of entries to display in the widget. The top count
can be between 5 to 20 entries. This setting is available in all widgets
except Event Trend.

Network Alerts

FortiSandbox scans sniffed traffic for connections to botnet servers using the botnet database and
attack traffic using the IPS signature database. FortiSandbox then compares this traffic against the
Web Filter database.

To view network alerts (Attacker, Botnet, and URL), go to Network Alerts. You can drill down the
information displayed and apply search filters. You can select to create a PDF or CSV format snapshot
report for specific types of network alert files. Search filters will be applied to the detailed report and will
be displayed in the Report Profile section.

Q Last 24 Hours = &F Attacker ~ [A exportDatz | | (@ Search
o Filter ...
Detected Backdoor Source Destination

Mar 012016 12:.02:21 backdoor: Nitol Botnet 2089111511 506320240
Mar 012016 12:02:11 backdoor: Nitol Botnet 2089111511
Mar 012016 12:01:38 backdoor: Nitol Botnet 2089111511
Mar 012016 12:01:07  backdoor: Nitol Botnet 208.91.115.11
Mar 012016 11:58:42 applications3: Malicious.JavaScript Obfuscation.Code.Packer.Detection 190.36.171.72 208.91.115.10
Mar 012016 11:58:04 backdoor: Nitol Botnet 208.91.115.11 50.63.202.40

This page has the following options:

Time Period Select the time period from the drop-down list. Select one of the fol-
lowing: 24 Hours, 7 Days, or 4 Weeks.
You can select the time period to filter the information displayed in
the GUI. This selection is also applied to exported data for the snap-
shot report.



Alert Type

Attacker

Botnet

URL

Select Attacker, Botnet, or URL from the drop-down list. You can
select the alert type to filter the information displayed in the GUI.
This selection is also applied to exported data for the snapshot
report.

When selecting Attacker from the drop-down list, the following
information is displayed:
« Detected: The date and time that the attack was detected by
FortiSandbox.

o Backdoor: The name of the attack.
o Source: The attacker’s IP address.
« Destination: The attacked host IP address.

All columns include a filter to allow you to sort the entries in ascend-
ing or descending order.

When selecting Botnet from the drop-down list, the following inform-
ation is displayed

« Detected: The date and time that the botnet contact was

detected by FortiSandbox.

« Name: The botnet name.

« Source: The IP address of the infected host.

« Destination: The botnet command and control IP address.
The Detected, Name, and Source columns include a filter to allow
you to sort the entries in ascending or descending order.
By default, FortiSandbox queries the public FDN service for the URL
category. You can override the server address in the System >
Maintenance > FortiGuard page.

When selecting URL from the drop-down list, the following inform-
ation is displayed:
o Detected: The date and time that the malicious URL was
visited.

« Rating: The severity of the visiting activity.
« Category: The URL'’s web filtering category.

e Host: The host IP address. The first level domain name of
the URL.

« URL: The visited URL address.
o Type: The URL type, http or https

o Source: The IP address of the host who visited the malicious
URL.

The Detected, Category, Hostname, URL, Type, and Source
columns include a filter to allow you to sort the entries in ascending or
descending order.

Tip: Certain URL categories are set as Benign by default. To view
and change, go to Scan Policy > URL Category



Export Data Select to create a PDF or CSV snapshot report. The time to generate
the report is dependent on the number of events selected. Do not
close the dialog box or navigate away from the page during report

generation.
Refresh Click the icon to refresh the log message list.
Search Show or hide the search filter field.
Add Search Filter Click the search filter field to add search filters. Click the close icon in

the search filter field to remove the search filter.
Search filters can be used to filter the information displayed in the
GUL.

To create a snapshot report for all network alert files:

Select a time period from the first drop-down list.

Select Attacker, Botnet, or URL from the second drop-down list.

Select to apply search filters to further drill down the information in the report.
Click the Export Data button in the toolbar. The Report Generator window opens.

Select either PDF or CSV for the report type. Optionally you can further define the report start/end date
and time.

6. Click the Generate Report button to create the report.

When the report generation is completed, select the Download button to save the file to your
management computer.

o wDd-=

7. Click the close icon or the Cancel button, to quit the report generator.

N In this release, the maximum number of events you can export to PDF report is
9 5,000; the maximum number of events you can export to CSV report is
= 150,000.




URL Detection

Summary Report

The Summary Report page provides a page similar to the System dashboard. You can add and
customize widgets in this page. By selecting a time period, you can customize what data is displayed.
To view the summary report page go to URL Detection > Summary Report.

~‘9"' Job data of URLs submitted through On-Demand or JSON API are also
s included in the Summary Report.

The following options are available:

Add Widget

Reset View

Time Period

Device

Click the button to add widgets to the summary report page.

Click the button to restore widgets to the default setting. A con-
firmation dialog box will be displayed, select OK to continue.

Select a time period to be displayed from the drop-down list. The
options are: Last 24 hours, Last 7 days, Last 2 weeks.

Click the button to filter for a specific device.

The following widgets are available:

Scanning Statistics

Scanning Statistics by

Type

Scanning Activity

Top Infectious URLs

Displays a table providing information about the URLs scanned per
OS for a selected time period. Clicking on the number in the widget
will drill down to the associated job list.

Displays a table proving information about URL types, rating, and
event count for a selected time period. Clicking on the number in the
widget will drill down to the associated job list.

Displays the number of clean, suspicious, and malicious events that
have occurred at specific times over a selected time period.

Hover the cursor over a colored portion of a bar in the graph to view
the exact number of events of the selected type that occurred at that
time.

Displays a chart providing the top infectious URLs that have been
detected over a selected time period.

Hover the cursor over a colored portion of a bar in the chart to view
the exact number of infection events that have occurred for the mal-
ware selected. Clicking on the URL in the widget will drill down to the
associated job list.



Customizing the summary report page

The FortiSandbox summary reports page can be customized. You can select the time period in the
toolbar to display specific information. You can also select which widgets to display, where they are
located in the page, and whether they are minimized or maximized.

To move a widget

Position your mouse cursor on the widget'’s title bar, then click and drag the widget to its new location.

To refresh a widget

Click the refresh icon in the widget's title bar to refresh the data presented in the widget.

To add a widget

In the dashboard toolbar, select Add Widget, then select the names of widgets that you want to add.
To hide a widget, in its title bar, select the Close icon.

L

~9' Multiple widgets of the same type can be added to the dashboard. This can be
= useful for viewing information over different refresh time intervals.

To edit a widget
Click the edit icon in the widget'’s title bar to open the edit widget settings window.

Configure the following information, and then select OK to apply your changes:

Custom widget title Optionally, enter a custom title for the widget. Leave this field blank
to use the default widget title.

Refresh interval Enter a refresh interval for the widget, in seconds. The widgets have
default refresh values:
« Scanning Statistics: 3600 seconds

« Scanning Statistics by Type: 3600 seconds
« Scanning Activity: 300 seconds
o Top Infectious URLs: 3600 seconds

Top Count Select the number of entries to display in the widget. The top count
can be between 5 to 20 entries. This setting is available in the Top
Infectious URLs widget.

URL Scan

The URL Scan page shows jobs of URL based scans. Users can toggle to view Suspicious and Clean
job ratings. By default, Suspicious jobs are displayed. URLs are submitted through the Fortinet device,
like FortiMail and the JSON API.

In this page, you can view job details and apply search filters. You can select to create a PDF or CSV
format snapshot report for files based on search filters

The following options are available:



URL Scan Options

Suspicious Click the Suspicious icon to view the suspicious jobs.
Clean Click the Cleanicon to view the clean jobs.

Refresh Click the button to refresh the entries displayed.

Search Show or hide the search filter field.

Add Search Filter Click the search filter field to add search filters. When the

search criteria is URL or the Submitted Filename, click the
equals sign to toggle between exact and pattern search.
Click the close icon in the search filter field to clear all
search filters.

Search filters can be used to filter the information dis-
played in the GUI.

Export Data Select to create a PDF or CSV snapshot report. The time to
generate the report is dependent on the number of events
selected. Do not close the dialog box or navigate away
from the page during report generation.

Customize Click the Customize button to customize the Job View Set-
tings.
Action
View Details Click the View Details icon to view the file description and

analysis details. The information displayed is dependent
on the file selected.

Pagination Use the pagination options to browse entries displayed.

The displayed columns are determined by settings defined in System > Job View Settings > URL
Detection Columns page. For more information, go to Job View Settings on page 67.

To create a snapshot report for all search results:

Select to apply search filters.
Select the generate to report button. The Report Generator window opens.
Select either PDF or CSV and click the Generate Report button to create the report.

PooDbd =

When report generation is completed, select the Download button to save the file to your management
computer.

5. Click the close icon or the Cancel button, to quit the report generator.

N In this release, the maximum number of events you can export to PDF report is
9 5,000; the maximum number of events you can export to CSV report is
= 150,000.
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If the URL is submitted by FortiMail, Email sender/receiver and the subject will
by shown as well.




Log & Report

The Log & Reports menu allows you to view and download all logs collected by the device, access
reports, and generate reports. You can log locally to FortiSandbox, a remote syslog server, or
FortiAnalyzer/FortiManager.

About Logs

Log Details

To view more details about a specific log in the log list, simply select that log. A log details pane at the
bottom of the window.

The log details pane contains the same information as the log message list, except with a full message
in lieu of a shortened one.

Logging Levels

FortiSandbox logs can be Emergency (reserved), Alert, Critical, Error, Warning, Information, or Debug.
The following table provides example logs for each log level.

Log Level Descrip- Example Log Entry
tion

Alert Imme- Suspicious URL visit domain.com from 192.12.1.12 to 42.156.162.21:80.
diate
action is
required.

Critical Func- System database is not ready. A program should have started to rebuild it
tionalityis  and it shall be ready after a while.
affected.

Error An erro- Errors that occur when deleting certificates.
neous con-
dition
exists and
func-
tionality is
probably
effected.

Warning  Func- Submitted file AVSInstallPack.exe is too large: 292046088.
tionality
might be
affected.



Log Level Descrip- Example Log Entry

tion

Inform- General LDAP server information that was successfully updated.
ation inform-

ation

about sys-

tem oper-

ations.

Debug Detailed Launching job for file. jobid=2726271637747836543 filename=log md5-

inform- 5=ebe5ae2bec3b653c2970e8cec9f5f1d9 sha1-
ationuse- 1=06ea6108d02513f0d278ecc8d443df86dac2885b
ful for sha256-

debugging =d678da5-
purposes. 5fb9eal3ee20af779a4ae13c402585ebb070edcf20091¢cb20509000f74b

Raw logs

Raw logs can be downloaded and saved to the management computer using the Download Raw Logs
button. The raw logs will be saved as a text file with the extension ./og.gz. The user can search the
system log for more information.

Sample raw logs file content

1time=1458669062 date=2016-03-22 time=17:51:02 1logid=1220000020 type=event
subtype=unknown pri=alert user=system ui=system action=rating status=success
reason=none letype=6 msg=fname=v32.cab jobid=2725911139058114340
shal=f61045626e5f4f74108£fb6b15dde284£e0249370
sha256=£f75fca6300e48ec4876661314475cdd7£38d4c73e87dfb5a423ef34a7ce0154f
rating=Clean scantime=11 malwarename=N/A srcip=204.79.197.200
dstip=208.91.115.250 protocol=HTTP device=()
url=http://officecdn.microsoft.com/pr/492350£6-3a01-4£97-b9c0-
c7c6ddf67d60/0ffice/Data/v32.cab

1itime=1458669062 date=2016-03-22 time=17:51:02 logid=0106000001 type=event
subtype=system pri=debug user=system ui=system action=controller
status=success reason=none letype=6 pid=8605 msg="Sandboxing environment is
not available for job 2725913445926977878, file type: htm, file extension:
htm"

1time=1458669062 date=2016-03-22 time=17:51:02 logid=1220000020 type=event
subtype=unknown pri=alert user=system ui=system action=rating status=success
Jjobid=2725913445926977878 shal=098a2ca8dB81979f2bb281af236£9baa651d557d5
sha256=424c62eaaad736740e43£5c7376ec6£20900d3df0el0cadcc94324280eafalllf
rating=Clean scantime=12 malwarename=N/A srcip=125.39.193.250
dstip=208.91.115.12 protocol=HTTP device=() url=http://all.l7k.com/lib/book/0_

Ay

~9' Fort detailed log format information, please refer to the FortiSandbox 2.4.1
= Log Reference available on the Fortinet Document Library.

Log Categories

In FortiSandbox, logs are group into different categories


http://docs.fortinet.com/

All Events
System Events
VM Events

Job Events

HA-Cluster Events

Notification Events

& Download Log History Logs

£ | @ Filter

P Date/Time
debug
debug
debug
debug

woR W N e

debug
debug
debug
debug
debug
debug
debug

- o

= oo @

(@ search

Level

Shows all logs.
Shows system level logs, like user creation and FDN downloads.
Shows logs related to a VM system, such as VM initialization.

Shows logs related to scans. Users can trace the scan flow of each
file or URL.

Shows logs related to cluster configuration and fail overs.

Shows logs related to email alerts and SNMP traps.

Message
HC: distributed file to unit FSA3KD3R. a5 self), sha256=db726186ae7a48che5fdectb1ed741642cab6cb021c82fed5b 186,
HC: distributed file to unit FSA3KD3R. al
HC: distributed file to unit FSA3KD3R.
HC: distributed file to unit FSA3KD3R.
HC: distributed file to unit FSA3KD3R.
HC: distributed file to unit FSASKD3R:
HC: distributed file to unit FSASKD3R
HC: distributed file to unit FSA3KD3R:
HC: distributed file to unit FSA3KD3R:
HC: distributed file to unit FSA3KD3R:
HC: distributed file to unit FSA3KD3R:

The following options are available:

Download Raw Log

History Logs
Refresh

Add Search Filter

Pagination

Select to download a file containing the raw logs to the management
computer.

Enable to include historical logs in Log Search.

Select to refresh the log message list.

Click the search filter field to add search filters. Users can select dif-
ferent categories to search the logs. The Search feature is not case

sensitive.

Use these controls to jump or scroll to other pages.
The total number of pagers and logs is also shown.

The following information is displayed:

#

Date/Time

Level

Log number.
The time that the log message was created.

The level of the log message. The available logging levels are:
« Alert: Immediate action is required.

« Critical: Functionality is affected.

« Error: Functionality is probably affected.

« Warning: Functionality might be affected.

« Information: Information about normal events.

« Debug: Information used for diagnosis or debugging.



User The user to which the log message relates. User can be a specific
user or system.

Message Detailing log message.

Log Servers

FortiSandbox logs can be sent to a remote syslog server, common event type (CEF) server, or
FortiAnalyzer. Go to Log & Reports > Log Servers to create new, edit, and delete remote log server
settings. You can configure up to 30 remote log server entries.

The following options are available:

Create New Select to create a new log server entry.

Edit Select a log server entry in the list and select Edit in the toolbar to
edit the entry.

Delete Select a log server entry in the list and select Delete in the toolbar to
delete the entry.

This page displays the following information:

Name The name of the server entry.

Server Type The server type. One of the following options: CEF, syslog , or
FortiAnalyzer.

Server Address The log server address.

Port The log server port number.

Status The status of the log server, Enabled or Disabled.

To create a new server entry:

1. Goto Log & Reports > Log Servers.
2. Select + Create New from the toolbar.
3. Configure the following settings:

Name Enter a name for the new server entry.

Type Select Log Server Type from the drop-down list.
Log Server Address Enter the log server IP address or FQDN.

Port Enter the port number. The default port is 514.

Status Select to enable or disable sending logs to the server.



Log Level Select to enable the logging levels to be forwarded to the log server.
The following options are available:
« Enable Alert Logs

« Enable Critical Logs

« Enable Error Logs

« Enable Warning Logs

« Enable Information Logs
« Enable Debug Logs

4. Select OK to save the entry.
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“9' You can forward FortiSandbox logs to a FortiAnalyzer running 5.2.0 or later.

To edit or delete a syslog server, FortiAnalyzer, new common event entry

1. Goto Log and Report > Log Servers.
2. Select a syslog server, FortiAnalyzer, or new common event entry.
3. Click the Edit or Delete button from the toolbar.

a. Make the necessary edits.

b. Clickthe Yes, I'm sure button to delete the entry.

Viewing Logs in FortiAnalyzer

To view FortiSandbox logs in your FortiAnalyzer

B Al Devices~ (® Last 1 hour ~ ra
# Tools v

appid ="

Add Filter
H Column Settings v

# wDate/Time Device ID Firewall Action  Source IP Destination IP Service © Real-time Log
No entry found. B Display Raw
&, Download

Case Sensitive Search

& Custom View

[ul Chart Builder
1. Login to your FortiAnalyzer
2. Select FortiSandbox from the Select an ADOM prompt.
3. Clickthe Log View tile.
The following options are available:
Add Filter Enter a search term to search the log messages. You can also right-

click an entry in one of the columns and select to add a search filter.
Select GO in the toolbar to apply the filter. Not all columns support
the search feature.

Device Select the device in the drop-down list.



Time Period

GO

Column Settings

Tools

Real-time Log
Display Raw

Download

Case Sensitive
Search

Chart Builder

Display Details button

Search Scope

Select a time period from the drop-down list. Options include: Last
30 mins, Last 1 hour, Last 4 hours, Last 12 hours, Last 1 day, Last 7
days, Last N hours, Last N days, or Custom.

Select to apply the time period and limit to the displayed log entries.
A progress bar is displayed in the lower toolbar.

Select specific columns to be displayed. You can also reset the
columns to its default.

The tools button provides options for changing the manner in which
the logs are displayed, and search and column options.

FortiSandbox does not support Real-time Log.

Select to change view from formatted display to raw log display.
Select to download logs. A download dialog box is displayed. Select
the log file format, compress with gzip, the pages to include and

select Apply to save the log file to the management computer.
This option is only available when viewing logs in formatted display.

Select to enable case sensitive search.

Select to create a custom chart.

Detailed information on the log message selected in the log message
list. The item is not available when viewing raw logs.
Log Details are only displayed when enabled in the Tools menu.

Select the maximum number of log entries to be displayed from the
drop-down list. Options include: 1000, 5000, 10000, 50000, or All.

This page displays the following information:

Logs

Status Bar

Pagination

Customizing the log view

The columns and information shown in the log message list will vary
depending on the selected log type and the view settings. Right-click
on various columns to add search filters to refine the logs displayed.
When a search filter is applied, the value is highlighted in the table
and log details.

Displays the log view status as a percentage.

Adjust the number of logs that are listed per page and browse
through the pages.

The log message list can show raw or formatted. The columns in the log message list can be
customized to show only relevant information in your preferred order.



To View Raw and Formatted Logs

By default, formatted logs are displayed. The selected log view will affect available view options. You
cannot customize the columns when viewing raw logs.

To view raw logs:

Go to Tools and select Display Raw from the drop-down menu from the toolbar.

To view formatted logs:

Go to Tools and select Display Formatted from the drop-down menu from the toolbar.

Columns

The columns displayed in the log message list can be customized and reordered as needed. Filters can
also be applied to the data in a column.

To customize the displayed columns:

1. Inthelog message list view, click Column Settings in the toolbar.
2. From the drop-down list that is displayed, select a column to hide or display.

~‘9"' The available column settings will vary based on the device and log type

selected.

3. To add more columns, select More Columns. In the Column Settings dialog box that opens, you can
show or hide columns by selecting and deselecting the

4. columns.
5. Toreset to the default columns, click Reset to Default.
6. Click OKto apply your changes.

To change the order of the displayed columns:

Place the cursor in the column header area, and then move a column by dragging and dropping.

To filter column data:

1. You can filter log summaries by using the Add Filter box in the toolbar or by right-clicking an entry and
selecting a context-sensitive filter.

2. Specifyfilters in the Add Filter box.
Use Regular Search. In the selected summary view, click in the Add Filter box, select a filter from the

dropdown list, and type a value. You can click on an operator to use it, such as greater than (>), less
than (<), OR, and NOT. You can add multiple filters at a time, and connect them with "and" or "or".

Use Advanced Search. Click the Switch to Advanced Search icon at the end of the Add Filter box. In
Advanced Search mode, you provide the whole search criteria (log field names and values) by typing.
Click Switch to Regular Search icon to go back to regular search.

Mo From the Tools drop-down menu in the tool bar, you can use the Case
9 Sensitive Search check box to specify whether you want Log View to
- treat the filter value that you type case-sensitive or not.




3. Inthe Device list, select a device.
4. Inthe Time list, select a time period.
5. Click Go.

To filter log summaries by using the right-click menu:

In a log message list view, right-click an entry, and select a filter criteria. The search criteria with a icon
will return entries that match the filter values, while the search criteria with a icon will return entries that
negate the filter values.

Depending on the column in which your mouse is located when you right-click, Log View will use the
column value of the selected entry as the filter criteria. This context-sensitive filter is only available for
certain columns.
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~9' For additional information, see the FortiAnalyzer Administration Guide in the
= Fortinet Document Library.

Report Access

Report Access lists all Executive Summary and Threat Activity reports including their statuses and the
user that generated the report. You can download and delete the PDF reports in this page.

Ay

9 Report pages are not visible on the Slave node in a cluster.

Generate reports
To generate reports on demand, go to Logs & Reports > Report Generate.
You can generate executive summary and threat activity reports for a specified time period.

The following options are available:

Generate Report Generate a report.

Download Report Download a report.

Refresh Click the button to refresh the entries displayed.
Delete Delete a report.

This page displays the following information:

Time Period Time period of data the report includes.
Report Type Type of report.

Size Report size.

Status Status of the report.

User Who generated the report.


http://docs.fortinet.com/fortianalyzer/admin-guides

Appendix A - View Details Page Reference

When you click on the View Details icon, a new tab will open in your browser.

The following information are descriptions of the View Details page for:

Last drill-down level of the FortiView pages

Scan Input > File and URL On Demand

File Detection > Malicious Files
File Detection > Suspicious Files
File Detection > Clean Files

Item Description

File type
Virus Name

Mark as clean (false positive) /
Mark as suspicious (false neg-
ative)

FortiGuard Encyclopedia Analysis

Received
Started

Status

Rated by

Submit Type
Source IP
Destination IP

Digital Signature

The file type, High Risk Downloader for example.
The name of the virus.

Select to mark the file as clean (false positive) or sus-
picious (false negative). This field is dependent on the file
risk type. In the Apply Override Verdict dialog box type a
comment and select Submit or Submit to Cloud to send
the file to the FortiGuard team for analysis.

After a file has an overridden verdict, its future rating will be
the overridden one until you reset the verdict.

After a file's verdict is overridden, the job will be listed in
the Scan Profile > Overridden Verdicts page for easy track-

ing.

Select to view the FortiGuard Encyclopedia analysis of the
file if the file has a Malicious rating. This page provides ana-
lysis details, detection information, and recommended
actions.

The date and time the file was received by FortiSandbox.
The date and time the scan started.

The status of the scan. Status: Done, Canceled, Timed
Out.

Which scan module made the rating decision, such as the
AV Scanner, FortiSandbox Community Cloud, Static File
Scan or VM Engine.

The input source of the file such as FortiMail.
The malware host |P address.
The IP address of the client that downloaded the virus.

The digital signature availability status.



Item Description

Scan Bypass Configuration When available, the scan bypass configuration will be dis-
played.
Virus Total By clicking the Virus Total link, a new page will open to

query www.virustotal.com.
Only a limited number of queries per minute is allowed
without manual interaction with the Virus Total website.

Rescan Select the link to view the original and all rescans. The num-
ber is a parent job ID which is a random unique number
generated from the timestamp.

More Details View additional file information including the following:
Packers, File Type, Download From, Packer, Filename,
File Size (bytes), Sent Over (protocol), Email Sender-
/Receiver, MD5, SHA1, SHA256, 1D, Submitted By, Start
Time, Finish Time, Scan Time, Scan Unit, Device that sub-
mitted this file, VDOM that submitted this file, Detection
OS (VM images that scanned this file), and Infected OS
(VM image name that detected this malware).

If the file is from FortiMail, Email related information, such
as the Email Sender, Receiver,and Subject will also be
shown.

Behavior Summary View the file behavior summary.
Analysis Details are located in the right pane.

Analysis Details View the following analysis details for each Detection OS
that is launched during the scan. Each Detection OS's
detail will be shown in a separate tab. The Infected OS will
have a VM Infected icon in its tab title.
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Item Description

Behavior Chro- View the file's behavior over time and its density during its
nology Chart execution.

Clean behaviors: green bubble
Suspicious behaviors: red, blue or orange bubble

The higher the bubble, the more serious the event is.

To view the event details, hover the mouse on top of the
bubble.

If a file scan is scanned with more than one VM type, the
VM tab will dynamically switch to the chart for that type.

If the file hits any imported YARA rule, a YARA tab will
appear with detailed information.
Including:

-The hit rule
-Rule's risk level
-Rule set name

-Link to original YARA rule file

Captured Pack-  Select the Captured Packets button to download the

ets tracer PCAP file to your management computer.
The packet capture (PCAP) file contains network traffic ini-
tiated by the file. You must have a network protocol ana-
lyzer installed on your management computer to view this
file.
The Captured Packets button is not available for all file
types.

Screenshot Download a screenshot image when the file was running in
the sandbox. This image is not always available.

Original File Download the password protected original file (. zip
format) to your management computer for further analysis.
The default password for this file is fortisandbox.

Caution: The original file should only be unzipped on a
management computer in an analysis environment.

Tracer Log A text file containing detailed information collected inside
the Sandbox VM.



Tracer Package

YARA Hits
Suspicious
Behaviors
Botnet Info

Files Created

Files Deleted

File Modified

Launched Pro-
cesses

Registry
Changes

Network Beha-
viors

Behaviors In
Sequence

Item Description

Download the compressed . tar file containing the tracer
log and related files. The password protected /backup
folder in the tracer log contains information about the pro-
gram’s execution. The default password for this file is for-
tisandbox.

Caution: The tracer log should only be unzipped on a man-
agement computer in an analysis environment.

If the file hits FortiSandbox internal YARA rules, detailed
information is displayed.

A summary of suspicious behaviors, if available.

The botnet name and target |P address.

The executable has been observed to drop some files.
Click the Files Created drop-down icon to view the files cre-
ated by the file. This field may not be available for all file
types.

This executable has been observed to delete some files.
Click the Files Deleted drop-down icon to view the files
deleted by the file. This field may not be available for all
file types.

The executable file has been observed to modify some
files.

The executable spawns some processes.

Click the Launched Processes drop-down icon to view the
processes launched by the file. This field may not be avail-
able for all file types.

The executable applies autostart registry modifications to
be able to start itself automatically.

Click the Registry Changes drop-down icon to view the
registry changed made by the file. This field may not be
available for all file types.

Users that are infected by this executable will notice HTTP
connections with certain URL/IP addresses.

Click the Network Behaviors drop-down icon to view the
network behavior of the file. This field may not be available
for all file types.

For certain document files, if they contain malicious URLs,
those URLs are displayed here. Users can select a URL to
display its detailed information, like rating history and visit
volume history.

The executable file's behavior during execution, in time
sequence.



Item Description

Tracer/Rating The tracer/rating package version is displayed at the bot-
Engine Version tom of the job detail page and in the PDF Report.

Print Click the print icon to print the malware details page inform-
ation.
Open in New Click the icon to open the page in a new web browser win-

Window dow.



Appendix B - Reset a Lost Password

Periodically a situation arises where the FortiSandbox needs to be accessed or the admin account’s
password needs to be changed but no one with the existing password is available. If you have physical
access to the device and a few other tools the password can be reset.

by
9 This procedure will require the reboot of the FortiSandbox unit.

You will need:

« Console cable

« Terminal software such as Putty.exe (Microsoft Windows) or Terminal (Mac OS X)

« Serial number of the FortiSandbox device

To reset the FortiSandbox password:

© © No G A

Connect the computer to the FortiSandbox via the Console port on the back of the unit.
Start a terminal emulation program on the management computer.
Select the COM port and use the following settings:

Speed (baud) 9600
Data bits 8
Stop bits 1
Parity None
Flow Control None

Press Open to connect to the FortiSandbox CLI.

The FortiSandbox should then respond with its name or hostname. (If it does not try pressing Enter)
Reboot the FortiSandbox using the power button.

Wait for the FortiSandbox name and login prompt to appear.

Type in the username: maintainer.

The password is bcpb + the serial number of the firewall. (The letters of the serial number are in
UPPERCASE format, Example: bcpbFSA3KD3R13000024)

On the FortiSandbox 3000D, after the device boots, you have ten minutes to
R type in the username and password. You may opt to have the credentials ready
9 in a text editor, and then copy and paste them into the login screen. There is no
= indicator of when your time runs out so it is possible that it might take more
than one attempt to succeed.

10.

1.

Now you should be connected to the FortiSandbox. To change the admin password, enter the following
CLI commands:

admin-pwd-reset <password string>
You can now proceed to log in to the FortiSandbox using admin and the password you set in the
previous step.



Appendix C - Hot Swapping Hard Disks

If a hard disk on a FortiSandbox unit fails, it must be replaced. FortiSandbox devices support hardware
RAID and the hard disk can be replaced while the FortiSandbox unit is running, also known as hot
swapping. The default RAID level is RAID-10 (FSA-3000D) or RAID-1 (FSA-1000D).

To identify which hard disk failed the following diagnostic commands are available:

hardware-info Display general hardware status information. Use this command to

view CPU, memory, disk, and RAID information, and system time set-
tings.

disk-attributes Display system disk attributes.

disk-errors Display any system disk errors.
disk-health Display disk health information.
disk-info Display disk hardware status information.
raid-hwinfo Display RAID hardware status information.

To hot-swap a hard disk on a device that supports hardware RAID, simply remove the faulty hard disk
and replace it with a new one.

Electrostatic discharge (ESD) can damage FortiSandbox equipment. Only per-
form the procedures described in this document from an ESD workstation. If no
such station is available, you can provide some ESD protection by wearing an
anti-static wrist or ankle strap and attaching it to an ESD connector or to a
metal part of a FortiSandbox chassis.

When replacing a hard disk, you need to first verify that the new disk has the
same size as those supplied by Fortinet and has at least the same capacity as
the old one in the FortiSandbox unit. Installing a smaller hard disk will affect
the RAID setup and may cause data loss. Due to possible differences in sector
layout between disks, the only way to guarantee that two disks have the same
size is to use the same brand and model.

The size provided by the hard drive manufacturer for a given disk model is only
an approximation. The exact size is determined by the number of sectors
present on the disk.

The FortiSandbox unit will automatically add the new disk to the current RAID array. The status
appears on the console. The RAID Management page will display a green check mark icon for all disks
and the RAID Status area will display the progress of the RAID re-synchronization/rebuild.

by

Once a RAID array is built, adding another disk with the same capacity will not
affect the array size until you rebuild the array by restarting the FortiSandbox
unit.




Appendix D - Create a Customized Virtual Machine
Image using Pre-Configured VMs

Customers purchases licenses from Microsoft distributors. In FSA-
1000D, FSA-3000D, FSA-3500D and VM, the maximum number of
clones allowed for the whole system is limited by the Windows
“9' license shipped.

For FSA-3000E, the maximum number of clones running is limited by
the Windows license and the number of stacked licenses provided by
Fortinet. A customized VM can have up to 48 clones.

The guest VM images published by Fortinet might not reflect the user’s working environment. For
example, on current Windows 8 and Windows 10 images, no Microsoft Office software is installed.
FortiSandbox allows user to create their own guest image, install software running in their environment
and upload the image to the unit to scan files. This document provides step-by-step instructions on how
to create and utilize them.

You can choose to use the VMs provided by Fortinet or by creating your own. If you would like to create
your own VMs see Appendix E - Create a Customized Virtual Machine Image using your own SO on
page 181.

Fortinet prepared a base set of supported VM images for customers to create their own customized
images more easily. These images have complete VirtualBox configurations and necessary software.
What customer needs to do:

a. Download and install Oracle VM Virtual Box 5.X.XX and open the base image and create a
clone image of it.

b. Activate the base Windows image with valid license key.
c. Install software and components that meet their environment on the base image.
For detailed instructions, please refer to steps below. These base images can be downloaded from:

VM Download Size 32 or 64 bit
image
https://fsavm.fortinet.net/vmtools/V5Win10Entx64.zip 4.8G 64
https://fsavm.fortinet.net/vmtools/V5Win10Entx86.zip 3.7G 32
https://fsavm.fortinet.net/vmtools/V5Win7EntSP1x64.zip 3.4G 64
https://fsavm.fortinet.net/vmtools/V5Win7ProSP1x86.zip 2.7G 32
https://fsavm.fortinet.net/vmtools/V5Win81Entx64.zip 3.8G 64
https://fsavm.fortinet.net/vmtools/V5Win81Entx86.zip 2.7G 32

https://fsavm.fortinet.net/vmtools/V5WinXpSp3.zip 704Mb 32


https://fsavm.fortinet.net/vmtools/V5Win10Entx64.zip
https://fsavm.fortinet.net/vmtools/V5Win10Entx86.zip
https://fsavm.fortinet.net/vmtools/V5Win7EntSP1x64.zip
https://fsavm.fortinet.net/vmtools/V5Win7ProSP1x86.zip
https://fsavm.fortinet.net/vmtools/V5Win81Entx64.zip
https://fsavm.fortinet.net/vmtools/V5Win81Entx86.zip
https://fsavm.fortinet.net/vmtools/V5WinXpSp3.zip

VM Download Size 32 or 64 bit
image

https://fsavm.fortinet.net/vmtools/V5Win7016x86.zip 3.6G 32

Their checksum value can be found at: https://fsavm.fortinet.net/vmtools/md5.txt

1. Download, install Oracle VM Virtual Box 5.X, open the base image and create a
clone

VirtualBox 5.X can be downloaded from https://fsavm.fortinet.net/vmtools/VirtualBox-5.0.26-108824-
Win.exe. The checksum value can be found at https://fsavm.fortinet.net/vmtools/md>5.txt

For help with VirtualBox installation and troubleshooting, please refer to The Virtual Box Manual.

VirtualBox is an open source software and licensed under GNU General Public
R License V2 license. The detailed information of its license can be found at
9 https://www.virtualbox.org/wiki/Licensing_FAQ

Mac OS is not supported.

2. Install Software and Components on the Customized VM Image

After a clone of the base image is created, the user can install applications and components required in
their environment on the clone image. They can be but not limited to the following list:

« .Net Framework

« Microsoft Office suite
« Adobe Acrobat Reader
« Oracle Java Run Time

There are two ways to install them:

a. Put theirinstallers on a computer in management network that VM image can download
through http, ftp protocols or network share. This requires network settings of VM image to be
configured to access hosting computer.

b. Package theirinstallation package as an ISO file in the VirtualBox Manager, select the VM
image, click Settings button or right click on the VM image name to open Settings page.
Go to the Storage page > Empty optical drive node > disk icon > Chose a virtual CD/DVD disk
file, select the ISO file. Then inside the VM image, go to drive D to install the software.

After installation of a software or component, go to Control Panel > Add or
N\ Remove Programs on Windows XPControl Panel > Programs and Features
in Windows 7, 8, and 10 to verify that the installation is successful.

Automatic update of software should be disabled. For details, please refer to
~9r software’s manual. For example, to disable automatic update on Acrobat
L Adobe Reader, refer to https://helpx.adobe.com/acrobat/kb/automatic-
updates---acrobat-reader.html



https://fsavm.fortinet.net/vmtools/V5Win7O16x86.zip
https://fsavm.fortinet.net/vmtools/md5.txt
https://fsavm.fortinet.net/vmtools/VirtualBox-5.0.26-108824-Win.exe
https://fsavm.fortinet.net/vmtools/VirtualBox-5.0.26-108824-Win.exe
https://fsavm.fortinet.net/vmtools/md5.txt
https://www.virtualbox.org/manual/
https://www.virtualbox.org/wiki/Licensing_FAQ
https://helpx.adobe.com/acrobat/kb/automatic-updates---acrobat-reader.html
https://helpx.adobe.com/acrobat/kb/automatic-updates---acrobat-reader.html

Use a text editor and create a meta file, enter in the installed applications for this VM image. The meta
file will be used later and its content is displayed in the Scan Profile > Installed Applications of
FortiSandbox.

R Certain software needs to be configured to associate with the file types as the
9 default application. For example, Adobe Reader needs to be launched after
= installation to be the default PDF application.

For Windows 10, the default web browser is Windows Edge which FortiSandbox does not currently
support. It is recommended to change the default web browser to be Internet Explorer. To do that:

1. Goto Start > Settings > System > Default apps.
2. Click Web Browser in the right pane and select Internet Explorer.

by
9 Fortinet is not responsible for software’s support and their license rights.

3. Setup FortiSandbox Tracer Engine Launcher

1. Open an editor, such as Notepad and type in the following scripts:

@echo off

:checker
if not exist d:\launcher.bat (
echo Wait for d:\launcher.bat
rem sleep 5
ping -n 5 127.0.0.1 >nul
goto checker

)

start /min d:\launcher.bat

2. Savethefile asautorun.bat onyour Desktop.

3. Findthe autorun.bat file on your Desktop, and Right-click > Cut.

4. On Windows XP and Windows 7, go to Start > All Programs > Startup > Right-click > Open All Users.
Windows Explorer will open. Paste the autorun.bat file.
On Windows 8 and Windows 10, go to Start > Run..., enter shell:startup to open the startup folder.
paste the autorun.bat file.

~‘9"' The D: \ directory forthe autorun.bat file is created after the
= VM image is uploaded.

4. Install the Customized VM Image to FortiSandbox and Apply It

1. Put the VM image’s . vdi file and its meta file from Step 4 to a server that supports ftp or scp
protocol.
2. Inthe FortiSandbox CLI interface:

a. execute CLI command vm-customized as follows:
vm-customized -cn -t<ftp|scp> -s<server ip> —u<username> -p<password> -
f</vdi_ file path> -vo<Windows type> -vn<custom vm name> -d<Machine
uuid> -k<MD5 of vdi file in lowercase>
Tip: Machine uuid canbe foundin <Machine> section of . vbox file of the image
build directory, suchas C:\Users\user name\VirtualBox VMs\WIN7X86SPI1\

b. If a customized VM image of the same name exists on the unit, the installation will fail. Go to
the VM Image page and set its clone number to 0. Click Apply to disable existing images. Use



-r to replace the existing one with new one. The Scan Profile settings for the image will be
inherited.

c. Theinstallation process can take up to one hour, depending on unit model and network speed.
If installation fails or stops unexpectedly, execute the command again.

d. Itisoptional to upload the meta file. The information in the meta file will be displayed in the
Installed Applications area in Scan Profile page of the FortiSandbox. To install it, execute CLI
command vm-customized as follows:

vm-customized -cf -mproduct.list -t<ftp|scp> -s<server ip> —u<username> -
p<password> -f</meta file path> -vn<custom vm name> -mproduct.list

The custom_vm_name should be the same as step a.

e. The unit will reboot after installation.

3. After unit reboots, user can enable it by setting up its clone number to be more than 0 in the VM Image
page and associate file types in the Scan Profile page to scan files.

[ Scanned File Types

% System > = WIN7X86CUST

i i > . —
Ij Virtual Machine 211 Installed Applications

!1 Scan Policy ~ P P
Scan Profile Microsoft Office InfoPath 2007
Je—— Microsoft Office Picture 2007 jpg

White List

m

Microsoft Office PowerPoint 2007
Microsoft Office Outlook 2007
Microsoft Office Access 2007

Black List Microsoft Office Excel 2007

Microsoft Office Groove 2007
Microsoft Office OneNote 2007
FastStone Image Viewer 5.5
Adobe Reader 11.0.0

Yara Rules

URL Category
Job Archive
Malware Package

URL Package

For example, the above is a Windows 7 customized image. It has an image file editor called
FastStone Image Viewer and it is associated to open JPG files. The user can create a User
defined extension for JPG files and associate it to this customized image. Subsequently, all JPG
files will be scanned by this customized image and opened by the FastStone Image Viewer.



Appendix E - Create a Customized Virtual Machine
Image using your own ISO

Customers purchases licenses from Microsoft distributors. In FSA-
1000D, FSA-3000D, FSA-3500D and VM, the maximum number of
clones allowed for the whole system is limited by the Windows
“9' license shipped.

For FSA-3000E, the maximum number of clones running is limited by
the Windows license and the number of stacked licenses provided by
Fortinet. A customized VM can have up to 48 clones.

The guest VM images published by Fortinet might not reflect the user’s working environment. For
example, on current Windows 8 and Windows 10 images, no Microsoft Office software is installed.
FortiSandbox allows user to create their own guest image, install software running in their environment
and upload the image to the unit to scan files. This document provides step-by-step instructions on how
to create and utilize them.

You can choose to use the VMs provided by Fortinet or by creating your own. If you would like to create
a customized image using pre-configured VMs see Appendix D - Create a Customized Virtual Machine
Image using Pre-Configured VMs on page 177.

1. Download and Install Oracle VM Virtual Box 5.X

VirtualBox 5.X can be downloaded from https://fsavm.fortinet.net/vmtools/VirtualBox-5.0.26-108824-
Win.exe. The checksum value can be found at https://fsavm.fortinet.net/vmtools/md5.txt

For help with VirtualBox installation and troubleshooting, please refer to The Virtual Box Manual.

VirtualBox is an open source software and licensed under GNU General Public
Mo License V2 license. The detailed information of its license can be found at
9 https://www.virtualbox.org/wiki/Licensing_FAQ

Mac OS is not supported.

2. Prepare the Operating System Installation Package

In FortiSandbox 2.4.1, the following operating systems can be used to build a customized VM image.

« Microsoft Windows XP 32/64 bit
« Microsoft Windows 7 32/64 bit

o Microsoft Windows 8.1 32/64 bit
« Microsoft Windows 10 32/64 bit

The installation package of above operating systems should be packaged as an ISO file. The ISO file
should be copied to the host installed with VirtualBox.

N The Windows Operating System is available from Microsoft and Microsoft
9 Channel Partners. Fortinet does not provide their installation package, their
= support or their license rights.
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~‘9"* To support 64-bit operating systems, hardware virtualization must be enabled
s on motherboard BIOS on the host installed with VirtualBox.

3. Create a Customized Image in Virtual Box

1. Launch Virtual Box and click New.

1 — ? =

-

o/ Create Virtual Machine

Name and operating system

Flease choose a descriptive name for the new virtual machine and select the
type of operating system you intend to install on it. The name you choose will
be used throughout VirtualBox to identify this machine,

Marme: Enter name here

Type: [Microsnf‘t Windows v] %ﬂ

Version: [Winduws XP. 7, 8 or10

Expert Mude] [ Mext ] [ Cancel

b e

2. Enter a meaningful name for the new image. The name cannot be more than 15 characters.
In the Type field > Microsoft Windows > select the OS version.

The following VM image names are reserved by Fortinet and should not
be used by customized images.

« WINXPVM
o WINXPVM1
Sl o WIN7X86VM
g o WIN7X64VM

o WIN81X86VM
o WIN81X64VM
« WIN10X86VM
o WIN10X64VM

3. Click Next.
4. Inthe Memory Size page, allocate the base memory size.

Windows XP 512MB

Windows 7, 8, 10 1024MB
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Click Next.

In the Hard Drive page, select Create a virtual hard drive now and click Create.
In the Hard drive file type page, select VirtualBox Disk Image (.vdi) format. Click Next.
In the Storage on physical hard drive page, select Dynamically allocated. Click Next.

In the File location and size page, set the path of the virtual disk file (optionally) and allocation 20GB
virtual disk size for the VM. Click Create. The VM will be created and will appear in the left pane.

Click the Settings button or right click on the VM image name to configure the VM image settings
defined below:

a. Goto General > Advanced, and apply the following settings:

r{E} MyWin7_Img - Settings D e |
E General General
@ System Basic | Advanced | Description | Encryption |
Display SnapshotFolder: || C:\Users!\NamelyirtualBox YMs\MyWin7_Img\Snapshots -
Storage Shared Clipboard:
@ Audio Drag'n'Drop:
@ MNetwork
@ Serial Ports
(P use
E Shared Folders
E User Interface

[ oK ] [ Cancel ] [ Help

h

b. Goto System > Motherboard, and apply the following settings:
For Windows XP:



-

Ca MyWinXP _Img - Settings

I@I General System
H| System Motherboard | Processor I Acceleration
Display Base Memory: U 192MB =
| T N A T Y T Y O Y Y Y Y Y Y U A O T O I Y IO B B B
| 4MB 5192 MB
Lﬁ‘ Storage
Boot Order: [ Floppy o
udio tica ’
Audi @ optical | [4]
Hard Disk
@ Metwork ] 2 Network
{ Serial Ports Chipset: [PIX3__ =
ﬁ USE Pointing Device: [USBTablet v]
Extended Features: [ | Enable I/ APIC
ﬁ shared Folders [ Enable EFI (spedial OSes only)
E User Interface [ Hardware Clodk in UTC Time
[ ok || cancel || Hep

s

For Windows 7, 8,10:

-
=3 MyWin7_Img - Settings

L2 o)

l@l General System
4| System Motherboard | Processor I Acceleration
Display Base Memory: * 1024 MB =
| N T T A T Y T Y O Y Y A A Y Y JOY U A O T O I Y IO B B B
4 MB 8192 MB
Lﬁ‘ Storage
Boot Order: [ Floppy | [
B Audio @ optical | [4]
Hard Disk
|§I MNetwork ] @ Network
£ Serial Ports Chipset: [PIX3 =
ﬁ USE Pointing Device: [UE‘.BTablet v]
Extended Features: [¥] Enable I/ APIC
E Shared Folders || Enable EFI (spedal OSes only)
E User Interface [7] Hardware Clock in UTC Time
[ ok || cancel |[ Hep
[
Processor Tab
Processor(s) 1
Execution Cap 100

Enable PAE/NX

Check the box




Acceleration Tab
Enable VT-x/AMD-C Check the box

Enable Nested Paging Check the box

c. Goto Display, keep the default settings.
d. Go to Storage, and apply the following settings:
If the operating system is Windows XP:

i. Click Controller: IDE, set Type to PIIX 4 and enable Use host I/0 cache.

ii. Click on the Empty Optical Drive node, make sure the CD/DVD Drive is set as the
IDE Secondary Master.

iii. Clickthe @ icon > Choose a virtual CD/DVD disk file, select the /SO file containing
the operating system installation package.

If the operating system is Windows 7,8,10:

i. Click Controller: SATA node, right click > Remove Controller to remove it.
ii. Right clickin the Storage Tree panel, and choose Add IDE Controller.

iii. Click the k'ﬁ’ Add Hard Disk icon. The following prompt will appear:
o — =
or¢ VirtualBox - Question L &Iﬂ—hj

% ‘You are about to add a virtual hard disk to
controller TDE.

Would you like to create a new, empty file to
hold the disk contents or select an existing one?

Create new disk] lChtmse existing disk] [ Cancel ]

" _—

iv. Click Choose Existing Disk and select the virtual disk file (*.vdi) that was created in the
previous steps.
v. Click Controller: IDE, set Type to PlIX4, and enable Use host I/0 cache.

vi. Click on the Empty Optical Drive node, make sure the CD/DVD Driveis set as the IDE
Secondary Master.

vii. Click the @ icon > Choose a virtual CD/DVD disk file, select the /SO file containing
the operating system installation package.

e. Go to Audio, and uncheck the Enable Audio checkbox.
f. Go to Network, and apply the following settings:
If the operating system is Windows XP:

Adapter 1 Tab
Network Adapter Check the box

Attached to NAT



Adapter 2 Tab

Adapter Type

MAC Address

Cable Connected

Network Adapter
Attached to

Adapter Type

MAC Address

Cable Connected

If the Operating System is Windows 7, 8, 19:

Adapter 1 Tab

Adapter 2 Tab

Network Adapter
Attached to

Adapter Type

MAC Address

Cable Connected

Network Adapter
Attached to

Adapter Type

MAC Address

Cable Connected

d. Goto Serial Ports, keep the default settings.
h. Goto USB, uncheck the Enable USB Controller checkbox.

Intel PRO/1000T Server
(82543GC)

080027C83864

Check the box

Check the box
NAT

Intel PRO/1000T Server
(82543GC)

080027C83980

Check the box

Check the box
NAT

Intel PRO/1000MT Server
(82545EM)

080027C83864

Check the box

Check the box
NAT

Intel PRO/1000MT Server
(82545EM)

080027C83980

Check the box



i. Go to Shared Folders, make sure no shared folders exist.
10. Click OK to apply the settings.
>

11. Inthe VirtualBox Manager page, clickthe St jcon to turn on the image. The operating system will
start installing. Follow the on-screen instructions to complete the installation.

4. Install Software and Components on the Customized VM Image

After a customized VM image is installed, the user can install applications and components required in
their environment. They can be but not limited to the following list:

« .Net Framework

« Microsoft Office suite

« Adobe Acrobat Reader

« Oracle Java Run Time

There are two ways to install them:

a. Put theirinstallers on a computer in management network that VM image can download

through http, ftp protocols or network share. This requires network settings of VM image to be
configured to access hosting computer.

b. Package their installation package as an ISO file in the VirtualBox Manager, select the VM
image, click Settings button or right click on the VM image name to open Settings page.

Go to the Storage page > Empty optical drive node > disk icon > Chose a virtual CD/DVD disk
file, select the ISO file. Then inside the VM image, go to drive D to install the software.

P After installation of a software or component, go to Control Panel > Add or
>\ Remove Programs on Windows XPControl Panel > Programs and Features
in Windows 7, 8, and 10 to verify that the installation is successful.

Automatic update of software should be disabled. For details, please refer to
~‘9"f software’s manual. For example, to disable automatic update on Acrobat
= Adobe Reader, refer to https://helpx.adobe.com/acrobat/kb/automatic-
updates---acrobat-reader.html

Use a text editor and create a meta file, enter in the installed applications for this VM image. The meta

file will be used later and its content is displayed in the Scan Profile > Installed Applications of
FortiSandbox.

N Certain software needs to be configured to associate with the file types as the
9 default application. For example, Adobe Reader needs to be launched after
= installation to be the default PDF application.

All applications that are used during a job scan should be launched after install-
~9' ation to finish their initialization. This is especially important for software like

= web browsers such as Internet Explorer, Adobe Reader and Microsoft Office
software.



https://helpx.adobe.com/acrobat/kb/automatic-updates---acrobat-reader.html
https://helpx.adobe.com/acrobat/kb/automatic-updates---acrobat-reader.html

For Windows 10, the default web browser is Windows Edge which FortiSandbox does not currently
support. It is recommended to change the default web browser to be Internet Explorer. To do that:

1. Goto Start > Settings > System > Default apps.
2. Click Web Browser in the right pane and select Internet Explorer.

Al
9 Fortinet is not responsible for software’s support and their license rights.

5. Modify the VM Image Environment

If the operating system is Windows XP:

Go to Control Panel >Security Center and disable Windows Automatic Updates.
Disable any installed antivirus software.
3. Navigate to the Start Menu > right click on My computer > click Properties

In Hardware tab, click Driver Signing button and select Ignore — Install the software anyway and don’t
ask for my approval.

In Advanced tab, click the Error Reporting button and check Disable the Error Reporting function. Also,
uncheck But notify me when critical errors occur.

In System Restore tab, make sure the System Restore function is off.

4. Make sure the built-in Administrator account is enabled. Open a command prompt and execute net
user Administrator /active: yes.

5. Setup Administrator auto-login:

a. Openacommand prompt and enter control userpasswords?2. This will open the User
Accounts page.

b. Uncheck Users must enter a user name and password to use this computerto ensure the
Administrator has automatic login privileges

Click Apply.

Use Administrator as the login account, password is optional.

Go to the User Accounts > Advanced tab.

Under Advanced User Manager > click the Advanced button to open the 1usrmgr page.
Click the Users folder to select the Administrator and edit its properties.

h. Make sure its password never expires.
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6. Open acommand prompt and enterpowercfg —h off to disable host hibernation if it is supported.

7. Goto Control Panel > Display Properties, navigate to Screen Savertab and select None from the
Screen Saver dropdown menu.

8. Go to Control Panel > Network Connection, and rename the following:

Local Area Connection 1 renamed to: ethO
MAC Address 080027C83864
Local Area Connection 2 renamed to: ethl

MAC Address 080027C83980



~9' If there are network devices already named as eth0 and eth1, change them
= to different names first.

The exact names showing in Network Connection page
might not be Local Area Connection 1 or Local Area
Connection 2. You may might need to swap eth0 and eth1l
names to make the customized image to work on
FortiSandbox.

If system doesn't allow rename to eth0 orethl with
messages like connection eth0 or ethl already exists, but
~‘9", they are not showing up in Network Connections page,

a. Click Start > Run, type cmd . exe, and then press ENTER.

b. Type set devmgr show nonpresent devices=1,

and then press ENTER.
c. Type Start DEVMGMT.MSC, and then press ENTER.

d. Click View > Show Hidden Devices. Expand the Network
Adapters tree. Right-click the greyed out network adapters,
and click Uninstall.

Go to the Start menu, execute Run... and enter $TEMP% . This will open the $TEMP$ folder. Delete
everything in the folder.

R To maximize catch rate, it is recommended the Windows Firewall is disabled.
9 To do that, go to Control Panel > Security Center > Windows Firewall and
= turn it off.

If the operating system is Windows 7:

1.

Turn off Windows automatic update. Go to Control Panel > System and Security > Windows Update >
Change. From the dropdown menu, select Never check for updates.

Disable Windows Defender or any installed antivirus software. Go to Start menu and type Windows
Defenderto locate and launch it. Click Tools > Options > Administrator, uncheck Use this program
check box, click Save.

Go to Control Panel > System and Security > Action Center > Change Action Center settings,
uncheck every item. Click Problem Reporting settings, check Never check for solution.

Run a command prompt as the Administrator and enterpowercfg -h off to disable host
hibernation.

Go to Control Panel > Appearance and Personalization > Change screen saver, select (None) from the
Screen Saver dropdown list.

Make sure Administrator account is enabled. Go to the Start menu, search command prompt. Right
click on it and launch it as the Administrator. Execute net user Administrator /active:

yes.

Setup auto-login for the Administrator account.



8.

a. Openacommand prompt and type in control userpasswords?2. This will open the User
Accounts page.

b. Make sure the Administrator account has the automatically login privilege by un-checking option
Users must enter a user name and password to use this computer.

c. Click Apply.

d. Use Administrator as the login account, password is optional.
e. Goto UserAccounts > Advanced tab.

f

Under the User Accounts > Advanced tab > Advanced User Management > click the
Advanced button button to open the 1usrmgr page.

dg. Click onthe Users Folderto select Administrator and edit its properties.
h. Make sure its password never expires.

Go to Control Panel > Network and Interet > Network and Sharing Center > Change Adapter
settings, rename the following:

Ethernet 1 renamed to: ethO

MAC Address 080027C83864

Ethernet 2 renamed to: ethl

10.

MAC Address 080027C83980

~9' If there are network devices already named as eth0 and eth1, change
= them to different names first.

The exact names showing in Network Connection page
might not be Local Area Connection 1 or Local Area
Connection 2. You may might need to swap eth0 and ethl
names to make the customized image to work on
FortiSandbox.

If system doesn't allow rename to eth0 orethl with
messages like connection eth0 or ethl already exists, but
M they are not showing up in Network Connections page,

a. Click Start > Run, type cmd . exe, and then press ENTER.

b. Type set devmgr show nonpresent devices=1,

and then press ENTER.
c. Type Start DEVMGMT.MSC, and then press ENTER.

d. Click View > Show Hidden Devices. Expand the Network
Adapters tree. Right-click the greyed out network adapters,
and click Uninstall.

Go to the Start menu, execute Run... and enter $TEMP% . This will open the $TEMP$ folder. Delete
everything in the folder to save disk space.

If the Windows Firewall is on, go to Control Panel > System and Security > Windows Firewall >
Advanced Settings. If the Windows Firewall is off, the following steps are not necessary:



1.

Click on Inbound Rules > Add New Rule > click Program.

Check This Program Path and type: c: \Windows\System32\ ftp.exe. Then, click Next.
Check Allow the Connection, then click Next.

Provide a name for the rule such as Allow FTP.

Click Finish.

Follow these steps to create Outbound Rules for the same executable.
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To maximize the catch rate, it is recommended to configure the following
settings:

Turn off Windows Firewall

Go to Control Panel > System and Security > Windows Firewall >
Customize Settings page and turn it off for both private and public
networks.

Turn off UAC (User Account Control Settings)
Search for UAC in Start menu, open the Change the User Account
~9r Control Setting, move the slider to Never, click OK.

Use public profile for all unidentified networks

Go to Control Panel > System and Security > Administrative Tools >
Local Security Policy > Network List Manager Policies > right click on
Unidentified Networks > Properties, change Location Type to Public,
click OK.

Turn off system protection for hard drive

Go to the Start menu, right click on Computer > Properties > System
protection > System Protection tab > Protection Settings > Local Disk
(C:) > Configure, check Tum off system protection, click OK.

If the Windows Firewall is off, execute the following commands in the command prompt:
sc config mpssvc start= demand

sc config wscsvc start= demand

net start wscsvc

net start mpssvc

netsh firewall set opmode disable

netsh advfirewall set allprofiles state off

The warning message about netsh firewall can be ignored

If the operating system is Windows 8:

1.

Turn off Windows automatic update. Go to Control Panel > System and Security > Windows Update >
Change Settings. Change the dropdown menu to Never Check for Updates.

Disable Windows Defender or any installed antivirus software. Go to the Start menu and type Windows
Defender to locate and launch the program. Go to Settings > Real Time Protection and uncheck the
Tum on Real-Time Protection.

In the Control Panel > System Security > Action Center page, expand the Maintenance section. Click
on the settings under the Check for solutions to problem reports, select Never check for solution to
disable the Action Center notifications. In the Action Center > Change Action Center Settings page,
uncheck every item and click OK.

Run a command prompt as Administrator and enter powercfg-h off to disable the host hibernation.



5. Right click on the Desktop and select Personalize. Navigate to the Screen Saver settings. Change the
Screen Saver dropdown list to None to disable the Screen Saver.

6. Make sure the Administrator account is enabled. Go to the Start Menu and search for the Command
Prompt. Right click on it and launch it as the Administrator. Execute net user Administrator
/active: yes.

7. Set up auto-login for the Administrator account.

a. Openacommand prompt and enter control userpasswords2. The User Accounts page
will open.

b. Make sure the Administrator has automatically login privilege enabled by unchecking the Users
must enter a user name and password to use this computer option.

Click Apply.

User the Administrator as the login account. The password is optional.

Go to User Accounts > Advanced tab.

Go to Advanced User Management > click the Advanced button to open the 1usrmgr page.
Click on the Users folder, and select Administrator to edit its properties

Q@ -0 2 0

h. Make sure its password never expires.

8. Go to Control Panel > Network and Intemet > Network Sharing > Change Adapter settings, rename
the following:

Ethernet 1 renamed to: etho
MAC Address 080027C83864
Ethernet 2 renamed to: ethl
MAC Address 080027C83980
~‘9"' If there are network devices already named as eth0 and eth1, change

them to different names first.




10.
1.
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The exact names showing in Network Connection page
might not be Local Area Connection 1 or Local Area
Connection 2. You may might need to swap eth0 and eth1l
names to make the customized image to work on
FortiSandbox.

If system doesn't allow rename to eth0 orethl with
messages like connection eth0 or ethl already exists, but
they are not showing up in Network Connections page,

a. Click Start > Run, type cmd . exe, and then press ENTER.

b. Type set devmgr show nonpresent devices=1,

and then press ENTER.
c. Type Start DEVMGMT.MSC, and then press ENTER.

d. Click View > Show Hidden Devices. Expand the Network
Adapters tree. Right-click the greyed out network adapters,
and click Uninstall.

Go to Start menu > enter Run...> enter $TEMP% and press enter. The $ TEMP$ folder will appear.

Delete everything in
Go to Control Panel

In the Navigation tab, check When [ sign in or close all apps on a screen, go to the desktop instead of

the folder.
> Appearance and Personalization > Taskbar and Navigation.

start in the Start screen area checkbox. click OK to save the change.

To maximize the catch rate, it is recommended to configure the
following settings:

Turn off Windows Firewall
Go to Control Panel > Windows Firewall. Select Turn off Windows
Firewall for both public and private networks.

Turn off UAC (User Account Control Settings)
Search for UAC in Start menu, open the Change the User Account
Control Setting, move the slider to Never, click OK.

Use public profile for all unidentified networks

Go to Control Panel > System and Security > Administrative Tools >
Local Security Policy > Network List Manager Policies > right click on
Unidentified Networks > Properties, change Location Type to Public,
click OK.

Turn off system protection for hard drive

Go to Control Panel > System and Security > System, click Change
Settings next to the Computer name, domain and workgroup settings
section. Navigate to System Protection tab, select Configure..., and

select Disable system protection.

If the Windows Firewall is turned off, execute the following commands in the command prompt:

sc config mpssvc
sc config wscsvc
net start wscsvc

start= demand
start= demand



net start mpssvc
netsh firewall set opmode disable
netsh advfirewall set allprofiles state off

The warning message about netsh firewall can be ignored.

If the operating system is Windows 10:

1. Disable Windows Defender or any installed antivirus software. Go to the Start > type Windows
Defender to locate and launch the program. Go to Settings > Real-Time Protection and uncheck Turn
on Real-Time Protection.

2. Goto Start >execute Run... and enter gpedit .msc and click OK. The Local Group Policy Editor will
open.

3. Inthe left pane, go to Computer Configuration > Administrative Templates > Windows Components >
Windows Defender. In the right pane, double click on the Tum off Windows Defender policy to edit it.
Click OK to save the change.

4. Goto Start > Settings > System > Notifications & Actions. Turn off all notifications.
5. Open a command rompt as the Administrator, enterpowercfg-h off to disable hibernation.

6. Right click on the Desktop and select Personalize. Navigate to the Screen Saver setting and change
the Screen Saver dropdown list to None to disable the Screen Saver.

7. Make sure the Administrator account is enabled. Go to Start > search Command Prompt > right click
on the application to launch it as the Administrator. Execute net user Administrator
/active: yes.

8. Setup auto-login for the Administrator account.

a. Open the command prompt and type in control userpasswords2. The User Accounts
page will appear.

b. Make sure the Administrator account automatically login privilege enabled by unchecking the
Users must enter a user name and password to use this computer option.

c. Click Apply.

d. Use Administrator as the login account; the password is optional.

e. Goto Users Accounts > Advanced tab.

f. Goto Advanced User Management > click the Advanced button to launch the 1usrmgr
page.

g. Click onthe Users folder to select the Administratorto edit its properties.

h. Make sure its password never expires.

9. Goto Control Panel > Network and Internet > Network and Sharing Center > Change Adapter
settings. Rename the following:

Ethernet 1 renamed to: ethO
MAC Address 080027C83864
Ethernet 2 renamed to: ethl
1 MAC Address 080027C83980
*‘9"' If there are network devices already named as eth0 and eth1, change them

to different names first.




The exact names showing in Network Connection page might not be
Local Area Connection 1 or Local Area Connection 2. You may
might need to swap eth0 and eth1 names to make the customized
image to work on FortiSandbox.

If system doesn't allow rename to eth0 or ethl with messages like
connection eth0 or ethl already exists, but they are not showing
up in Network Connections page,

g a. Click Start > Run, type cmd . exe, and then press ENTER.

b. Type set devmgr show nonpresent devices=1, and

then press ENTER.
c. Type Start DEVMGMT.MSC, and then press ENTER.

d. Click View > Show Hidden Devices. Expand the Network
Adapters tree. Right-click the greyed out network adapters, and click
Uninstall.

1.

Go to Start > execute Run... > enters TEMP%. The $TEMP% folder will appear. Delete everything in the
folder.

To maximize the catch rate, it is recommended to configure the following
settings:

Turn off Windows Firewall
Go to Control Panel > System and Security > Windows Firewall. Select Tumn
off Windows Firewall for both public and private networks.

Turn off UAC (User Account Control Settings)
Search for UAC in Start menu, open the Change the User Account Control
NP Setting, move the slider to Never, click OK.

Use public profile for all unidentified networks

Go to Control Panel > System and Security > Administrative Tools > Local
Security Policy > Network List Manager Policies > right click on Unidentified
Networks > Properties, change Location Type to Public, click OK.

Turn off system protection for hard drive

Go to Control Panel > System and Security > System, click Change Settings
next to the Computer name, domain and workgroup settings section. Navigate
to System Protection tab, select Configure..., and select Disable system
protection.

12

If Windows Firewall was turned off, execute the following commands in a command prompt:
sc config mpssvc start= demand

sc config wscsvc start= demand

net start wscsvc

net start mpssvc

netsh firewall set opmode disable

netsh advfirewall set allprofiles state off

The warning message about netsh firewall can beignored



6. Setup FortiSandbox Tracer Engine Launcher

1. Open an editor, such as Notepad and type in the following scripts:

@echo off

:checker
if not exist d:\launcher.bat (
echo Wait for d:\launcher.bat
rem sleep 5
ping -n 5 127.0.0.1 >nul
goto checker

)

start /min d:\launcher.bat

2. Savethefile as autorun.bat onyour Desktop.

3. Findthe autorun.bat file on your Desktop, and Right-click > Cut.

4. On Windows XP and Windows 7, go to Start > All Programs > Startup > Right-click > Open All Users.
Windows Explorer will open. Paste the autorun.bat file.
On Windows 8 and Windows 10, go to Start > Run..., enter shell:startup to open the startup
folder. paste the autorun.bat file.

~‘9"' The D: \ directory forthe autorun.bat file is created after the
= VM image is uploaded.

7. Install the Customized VM Image to FortiSandbox and Apply It

1. Put the VM image’s . vdi file and its meta file from Step 4 to a server that supports ftp or scp
protocol.

2. Inthe FortiSandbox CLlI interface:

a. execute CLI command vm-customized as follows:

vm-customized -cn -t<ftp|scp> -s<server ip> —u<username> -p<password> -
f</vdi_file path> -vo<Windows type> -vn<custom vm name> -d<Machine
uuid> -k<MD5 of vdi file in lowercase>

Tip:Machine uuid can be foundin <Machine> section of .vbox file of theimage
build directory, suchas C: \Users\user name\VirtualBox VMs\vm_ name\

b. If a customized VM image of the same name exists on the unit, the installation will fail. Go to
the VM Image page and set its clone number to 0. Click Apply to disable existing images. Use
-r to replace the existing one with new one. The Scan Profile settings for the image will be
inherited.

c. Theinstallation process can take up to one hour, depending on unit model and network speed.
If installation fails or stops unexpectedly, execute the command again.

d. Itisoptional to upload the meta file. The information in the meta file will be displayed in the
Installed Applications area in Scan Profile page of the FortiSandbox. To install it, execute CLI
command vm-customized as follows:

vm-customized -cf -mproduct.list -t<ftp|scp> -s<server ip> —u<username> -
p<password> -f</meta file path> —vn<custom vm name> -mproduct.list

The custom_vm_ name should be the same as step a.

e. The unit will reboot after installation.

3. After unit reboots, user can enable it by setting up its clone number to be more than 0 in the VM Image
page and associate file types in the Scan Profile page to scan files.



£ System > — WIN7X86CUST Clone #:1

P Virtual Machine »
!1 Scan Policy ~ P P
Scan Profile Microsoft Office InfoPath 2007

Microsoft Office Picture 2007

5% Installed Applications [ Scanned File Types

Pg

General Microsoft Offica PowerPoint 2007
White List Microsoft Office Outlook 2007

. | Microsoft Office Access 2007
Hlac it = || Microsoft Office Excel 2007
YaraRules Microsoft Office Groove 2007

Microsoft Office OneNote 2007

URL Category FastStone Image Viewer 5.5
Job Archive Adobe Reader 11.0.0

Malware Package

URL Package

For example, the above is a Windows 7 customized image. It has an image file editor called
FastStone Image Viewer and it is associated to open JPG files. The user can create a User
defined extension for JPG files and associate it to this customized image. Subsequently, all JPG
files will be scanned by this customized image and opened by the FastStone Image Viewer.



Fi:RTINET

High Performance Network Security

Copyright© 2017 Fortinet, Inc. All rights reserved. Fortinet®, FortiGate®, FortiCare® and FortiGuard®, and certain other marks are registered trademarks of Fortinet,
Inc., inthe U.S. and other jurisdictions, and other Fortinet names herein may also be registered and/or common law trademarks of Fortinet. All other product or company
names may be trademarks of their respective owners. Performance and other metrics contained herein were attained in internal lab tests under ideal conditions, and

actual performance and other results may vary. Network variables, different network environments and other conditions may affect performance results. Nothing herein
represents any binding commitment by Fortinet, and Fortinet disclaims all warranties, whether express or implied, except to the extent Fortinet enters a binding written
contract, signed by Fortinet’s General Counsel, with a purchaser that expressly warrants that the identified product will perform according to certain expressly-identified
performance metrics and, in such event, only the specific performance metrics expressly identified in such binding written contract shall be binding on Fortinet. For
absolute clarity, any such warranty will be limited to performance in the same ideal conditions as in Fortinet’s internal lab tests. In no event does Fortinet make any
commitment related to future deliverables, features or development, and circumstances may change such that any forward-looking statements herein are not accurate.
Fortinet disclaims in full any covenants, representations, and guarantees pursuant hereto, whether express or implied. Fortinet reserves the right to change, modify,
transfer, or otherwise revise this publication without notice, and the most current version of the publication shall be applicable.




	Change Log
	Introduction
	What's new in FortiSandbox 2.4.1
	About this document
	Connecting to the Command Line Interface

	Using the GUI
	GUI overview
	Connecting to the GUI
	Default port information


	Dashboard
	Customizing the dashboard
	Dashboard Settings
	Change the system host name
	Change the administrator password
	Change the GUI idle timeout
	Configure the system time
	Microsoft Windows VM license activation
	Microsoft Office license upload and activation
	Log out of the unit
	Visit online help
	Update the FortiSandbox firmware
	Update the system utilities version
	Server overrides
	Reboot and shutdown the unit
	Backup or restore the system configuration


	FortiView
	Operation Center
	Threats by Topology
	Threats by Hosts
	Threats by Hosts - level 1
	Threats by Hosts - level 2
	Threats by Hosts - level 3
	Threats by Hosts - level 4

	Threats by Files
	Threats by Files - level 1
	Threats by Files - level 2
	Threats by Files - level 3
	Threats by Files - level 4

	Threats by Devices
	Threats by Devices - level 1
	Threats by Devices - level 2
	Threats by Devices - level 3
	Threats by Devices - level 4

	File Scan Search
	URL Scan Search

	Network
	Interfaces
	Failover IP

	DNS Configuration
	Static Routing

	System
	Administrators
	Certificates
	LDAP Servers
	RADIUS Servers
	AWS Config
	Mail Server
	SNMP
	Configuring the      SNMP agent
	MIB files

	FortiGuard
	Login Disclaimer
	Settings
	Job View Settings

	Virtual Machine
	VM Status
	VM Images
	Clone Number for VM Image
	VM Screenshot


	Scan Policy
	Scan Profile
	File types
	Scan Profile Part One
	Scan Profile Part 2
	File Scan Priority
	File Scan Flow
	URL Scan Flow

	General
	How to improve system scan performance

	White/Black Lists
	Overridden Verdicts
	YARA Rules
	URL Category
	Supporting URL Pre-Filtering

	Customized Rating
	Job Archive
	Package Options
	Malware and URL Package Options

	IOC Package

	Scan Input
	File Input
	File On Demand
	URL On Demand
	Job Queue
	Sniffer
	Device
	Supported Devices

	FortiClient
	Adapter
	Configure Carbon Black/Bit9 Server
	Configure ICAP Client

	Network Share
	Quarantine
	Malware Package
	URL Package

	HA-Cluster
	Centrally manage Slave nodes on the Master node
	Requirements before Configuring a HA Cluster
	Master's Role and Slave's Role
	Configure a cluster level fail-over IP set for Master unit
	Main HA Cluster CLI Commands
	Example configuration
	What happens during a failover
	Upgrading or rebooting a Cluster
	In-line mode
	In-line mode in core environments
	In-line mode in distributed enterprise environments

	Health Check
	Job Summary
	Status
	HA Cluster Information

	File Detection
	Summary Report
	File Scan

	Network Alerts
	Summary Report
	Network Alerts

	URL Detection
	Summary Report
	URL Scan

	Log & Report
	About Logs
	Log Details
	Logging Levels
	Raw logs

	Log Categories
	Log Servers
	Viewing Logs in FortiAnalyzer
	Customizing the log view
	Columns

	Report Access
	Generate reports


	Appendix A - View Details Page Reference
	Appendix B - Reset a Lost Password
	Appendix C - Hot Swapping Hard Disks
	Appendix D - Create a Customized Virtual Machine Image using Pre-Configured VMs
	Appendix E - Create a Customized Virtual Machine Image using your own ISO

