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Introduction

FortiDeceptor creates a network of Decoy VMs to lure attackers and monitor their activities on the network. When
attackers attack Decoy VMs, their actions are analyzed to protect the network.
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Key features of FortiDeceptor include:

Deception OS: Windows, Linux, SCADA OS, IoT OS, VoIP OS, ERP OS, Medical OS, SSL-VPN OS, or POS OS
images are available to create Decoy VMs.

Decoy VMs: Decoy VMs that behave like real network assets can be deployed via FortiDeceptor.

Deception Lures: Deception Lures are services, applications, or users added to a Decoy VM to simulate a real
user environment.
FortiDeceptor token package: Install a FortiDeceptor token package to add breadcrumbs on real endpoints and
lure an attacker to a Decoy VM. Tokens are normally distributed within the real endpoints and other IT assets on the
network to maximize the deception surface. Use tokens to influence attackers' lateral movements and activities.
Examples of what you can use in a token include: cached credentials, database connections, network share, data
files, and configuration files.
Monitor the hacker's actions: Monitor Incidents, Events, and Campaign.
« An Eventrepresents a single action. For example, a login-logout event on a victim host.
« An Incident represents all actions on all actions taken by a hacker on a single decoy/victim host. Examples
include, a login-logout, file system change, a registry modification, and a website visit on a single victim host.
» A Campaign represents the hacker's lateral movement. All related Incidents are a Campaign. For example, an
hacker logs on to a system using the credentials found on another system.
Log Events: Log all FortiDeceptor system events.

FortiDeceptor 5.2.2 Administration Guide
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Set up FortiDeceptor

Use the following checklist to verify you have completed all of the general configuration tasks.

Task Description

Connect to the GUI Connect the administration interface to a management computer with
an Ethernet cable, then configure the management computer to be
on the same subnet as the internal interface of the FortiDeceptor unit.

Change the administrator password You are required to create a create strong password the first time
you log into FortiDeceptor.

Change the system hostname Change the full host name in the System Information widget.
Connect to the CLI If necessary, connect to the CLI console.
Configure the system time Configure the FortiDeceptor system time manually or synchronize

with an NTP server from the System Information widget.

Upload the license file to FortiDeceptor ~ Go to Dashboard > System Information widget, click Upload License
beside Firmware License.

Review the default port information FortiDeceptor reserves Port1 for device management. The other
ports are used to deploy deception decoys.

O00o0o00 0O

Configure Central Managementon the  Configure the Central Management console to manage remote
manager FortiDeceptor appliances including Decoy VMs deployment, system
configuration, and incident alert monitoring.

Connect to the GUI

Use the GUI to configure and manage FortiDeceptor.

To connect to the FortiDeceptor GUI:

1. Using an Ethernet cable, connect the management computer to FortiDeceptor's port1.
2. Configure the management computer to be on the same subnet as the internal interface of the FortiDeceptor unit:
« Change the IP address of the management computerto 192.168.0.2.
« Change the IP address of the network mask to 255.255.255.0.
3. Gotohttps://192.168.0.909.
4. Type admin in the Name field, leave the Password field blank, and click Login.
You can now proceed with configuring your FortiDeceptor unit.

FortiDeceptor 5.2.2 Administration Guide
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Set up FortiDeceptor

If the network interfaces have been configured differently during installation, the URL and
administrative access protocols might not be in their default state.

Connect to the CLI

You can use CLI commands to configure and manage FortiDeceptor.

To connect to the FortiDeceptor CLI:

1. Inthe FortiDeceptor banner at the top, click the CL/ Console icon.
i FortiDeceptor VM / admin v

( CLl Censole
L aldmmdn © Taimandn Cuvndmann fedeiladl;e A M aa

The CLI Console pane opens.
2. Ifnecessary, click Connect and enter your username and password.

The CLI Console pane has icons to disconnect from the CLI console, clear console text, download console text,
copy console text, open the CLI console in its own window, and close the console.

3. Toclose the CLI console, click the Close icon.

Change the system hostname

The System Information widget displays the full host name. You can change the FortiDeceptor host name.

To change the host name:

1. Goto Dashboard, System Information widget.
2. Click Change beside Host Name.
3. Inthe New Name field, type a new host name.

The hostname can start with a character or digit, and cannot end with a hyphen. A-Z, a-z, 0-9, or hyphen are allowed
(case-sensitive). Other symbols, punctuation, or white space are not allowed.

4. Click Apply.

Change the administrator password

The first time you log into FortiDeceptor you will be prompted to change the administrator password. Passwords must be
8-60 characters long, and contain only upper/lower-case letters, numbers and special characters #$%().

Al
‘Q' Due to a higher level of password encryption introduced in version 5.2.0, users upgrading from
- v5.1.0 to v5.2.0 will be prompted to change their password.
FortiDeceptor 5.2.2 Administration Guide 12
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Set up FortiDeceptor

9 admin ~

© You are required to change your password due to the password policy.

Edit Administrator

Administrator: admin

Old Password: |

|
New Password: | ‘
|

Confirm Password: |

To change the password of the logged in administrator:

1. Inthe FortiDeceptor banner at the top, click the username and select Change Password.
2. Change the password and click OK.

To change the administrator password in the Administrators page:

1. Goto System > Administrators.
2. Select an administrator and click Edit.
3. Change the password and click OK.

To change the administrator password with the CLI:

Run the following command:

passwd
Example:

> passwd

Old paSSWOrd: Kk ok kkkkokkkkkkk

New paSSWOrd: Kk k ok ok ok ok ok ok ok ok ok ok
Confirm password: **x**xxxkkxkskx

Successfully changed password, please re-login with the new password.

Configure the system time

You can change the FortiDeceptor system time in the Dashboard. You can configure the FortiDeceptor system time
manually or synchronize with an NTP server.

To configure the system time:

1. Goto Dashboard > System Information widget and click Change beside System Time.
2. Selectthe Time Zone and wait for the widget to refresh.
3. Check that the System Time is correct. If necessary, click Set Time and manually set the time and date.

FortiDeceptor 5.2.2 Administration Guide
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Set up FortiDeceptor

4. Click Apply.
You might need to log in again.

If the time is not correct, we recommend configuring the NTP server for time synchronization.

Upload license file to FortiDeceptor

To upload the license to FortiDeceptor:

1. Goto Dashboard > System Information widget, click Upload License beside Firmware License.
2. Locate the license and click Submit.

Default port information

FortiDeceptor treats Port1 as reserved for device management. The other ports are used to deploy deception decoys.

The following table list the default open ports for each FortiDeceptor interface.

FortiDeceptor default ports:

Configure the FortiDeceptor management IP address on port1.
Configure the FortiDeceptor management IP address on port1.

Port (Interface) Default Open Ports

Port1 TCP ports 22 (SSH), 23 (Telnet), 80 and 443 (GUI).
FortiGuard Distribution Servers (FDS) use TCP port 443 or 8890 for download. FortiDeceptor
uses a random port picked by the kernel.
FortiGuard Web Filtering servers use TCP port 443 or UDP port 53 or 8888. FortiDeceptor
uses a random port picked up by the kernel.
FortiDeceptor deception VM download uses TCP port 443 for download. FortiDeceptor uses a
random port picked by the kernel.
FortiDeceptor Manager is required to open port 8443 from the client (remote appliance) to
the FortiDeceptor Manager.

FortiDeceptor Manager is required to have access to virustotal.com over port 443 for malware
analysis based on MD5 request.

Port2 to port8 Each FortiDeceptor port can be directly connected to a specific VLAN or use the network trunk
to communicate with multiple VLANs from a single interface.

In DMZ mode, no service listens. In regular mode, token communication service listens on
deployment interface monitor IP with port 1443. The token communication uses HTTPS
protocol.

FortiDeceptor 5.2.2 Administration Guide
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A\,

The default port for FortiDeceptor VM is 443. To add HTTP, SSH, Telnet or another port, go to
Network >Interfaces > port1> Edit.

DMZ Mode

Deploy a FortiDeceptor hardware unit or VM in the Demilitarized Zone (DMZ). You can monitor attacks on the DMZ
network when FortiDeceptor is installed in the DMZ network.

DMZ mode is useful when you want to deploy decoys to a segment of the network that hosts critical services. When a
threat actor attacks a server and attempts to move laterally inside the DMZ segment they are detected by the decoys

without exposing the decoys on the Internet.

Internet

WAN

FortiDeceptor

Linux/Win
Deception VMs DMZ Network

DMZ EL_;_}-'-EE

LAN

Firewall

Internal
Network

Limitations of the DMZ Mode

The DMZ Mode in FortiDeceptor functions like regular mode with the following exceptions:

» When DMZ mode is enabled, the banner displays DMZ-MODE.

» In Deception > Deployment Network, Deception Monitor IP/Mask is hidden. See Deployment Network on page 67.
« In Deception > Decoy & Lure Status in the Deception Status view, the Attack Test selection is disabled.

« Decoy VMs are limited to one deploy Interface. For information about IP address range, see Deployment Wizard on

page 72.

To enable DMZ mode in the CLI:

dmz-mode -e

FortiDeceptor 5.2.2 Administration Guide
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To disable DMZ mode in the CLI:

dmz-mode -d

Ay
‘Q' Enabling or disabling the DMZ mode removes all previous configurations including Decoy
- VMs, lures, and tokens. Deception OS is not removed.

JSON API

FortiDeceptor provides a Representational State Transfer (REST) API for interaction with system components.
Programs communicate with the REST APl over HTTP, the same protocol your web browser uses to interact with web
pages.

The REST-API authentication is based on a token generated by the FortiDeceptor.
The FortiDeceptor API has the following capabilities:

» Get the decoy deployment template list.

« Deploy decoys based on the decoy template configuration and the deployment network configuration (both STATIC
and DHCP IP).

» Get a decoy deployment status.
» Stop/start the deployed decoys.
» Getincident alerts based on filter requests like time range (last minutes/hours/days) / service name/decoy name.

The FortiDeceptor JSON API Reference guide is available in the Fortinet Developer Network (FNDN). To access the
guide, log in to FNDN and enter FortiDeceptor in the Search field.

Fortinet Developer Network is a subscription-based community. For more information about FNDN, visit Fortinet
Worldwide Developer Community.

FortiDeceptor 5.2.2 Administration Guide 16
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Deploy Decoy VM

Use the Deception pages to deploy Decoy VMs on your network. When a hacker gains unauthorized access to Decoy
VMs, their movements can be monitored to understand how they attack the network.

To use FortiDeceptor to monitor the network:

Task Location in GUI More information

Check the Deception OS is available Go to Deception > Deception OS  See Deception OS on page 66.

Auto-detect or specify the network where Go to Deception > Deployment See Deployment Network on

the Decoy VMs are deployed Network page 67.

Deploy the Decoy VM on the network Go to Deception > Deployment See Deployment Wizard on page
Wizard 72.

Start or stop the deployed Decoy VMs, or  Go to Deception > Decoy Status ~ See Decoy Status on page 86.
download the FortiDeceptor token
package to manually install it on

computers

Specify the IP address that is to be Go to Deception > Safe List See Safe List on page 94.

considered safe This is useful when you want to
log in to the deployment network
without being flagged as an
attacker.

View and work with lure resources Go to Deception > Lure See Lure Resources on page 69.

Resources

For more information, see Deception deployment best practices on page 161.

FortiDeceptor 5.2.2 Administration Guide
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Dashboard

Dashboard

The Dashboard contains system information widgets that allow you to monitor the performance of the FortiDeceptor. The
Dashboard also includes widgets that provide an overview of incidents and events over the last 24 hours to 7 days. You
can customize the Dashboard by adding and removing widgets.

2 Dashboard >, # v @~ adminv
Incidents & Events Distribution- ¢ 2 System Information S o % Lure Distribution A
Last 4 Weeks x
Appliance Mode Manager 528 Lures Deployed
561 Incidents & 1175 Events detected Host Name g 000000139 TP — SANBA — HTTP . RDP — WP
== TCPListener == NBNSSpoofSpotter === GIT == SSH
Low Risk ~ Unknown Medium Risk Serial Number FDCVMS000000013% HTTPS = TP-LINKWEB = Elastic Search == ICMP
w— Critical High Risk - SMB
System Time [2(%)“2?]2.{;]86]-27 09:18:25 PDT NBNSSposiSpotter: &
8 35
Firmware Version v4.2.0,build0226 (GA)[Update] TCPListener: ] \ ssH
24

60
Firmware License @ [Upload License] e
1
- Last Backup: N/A
System Configuration [Backup/Repstore] ROP:
5
Current User admin Vé HT;:S
e ol WP 4 g

System Resources S o \ £ Blastic
\ Al CurrentvCPU: 12 SA;"UBA ~ 'C;"f.P.
# currentGRAM: 15
@ Active Decoy VMs: 5 50 - 5;"53
@ Max Decoy VMs: 5
AL Labad Decoy Distribution by OS S o n
Incidents & Events Count - Last 4 Weeks &S o %

= Win7x64v1 == iotv1 == ubuntu16v2 ubuntu16vl
win10v1

ubuntutfvi

600 / 1

500 o \

400

300

200

100

0 A A T A im;H - win11unv1'

~\\ vq}\ (\&v& <\°h vé‘vbﬁ N <\ NN <\\ v\‘b m\h v\b <\\h<\ <\ N m"’n (\'ﬁ\ A’ibv'}vmh m"’% Q'Lb N
w\a’\“3\“\“?“}“\“9999999999}“9999999999

== Event == Incident

+  Cc| Bl O e

The following widgets are available:

Widget Description

System Resources Hardware requirements benchmark for FortiDeceptor Virtual appliances only.
This widget provides real-time guidelines for system performance and increasing
vCPU & RAM resources during deployment and ongoing maintenance. The
widget also provides the overall Real-time usage status of the CPU and memory.

System Information Basic information about the FortiDeceptor system, such as the serial number,
system up time, and license status information.

License Information The list of VM license keys and their expiry dates.

FortiDeceptor 5.2.2 Administration Guide
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Dashboard

Widget Description

Disk Monitor For hardware models:
¢ The RAID level and status, disk usage, and disk management information.

For VM models:

¢ Disk usage.

Incidents & Events Information about the number of incidents and events, and their level of severity.

Distribution

Incidents & Events Count Number of events occurring each day.

Decoy Distribution by OS Number of decoys displayed as a pie-chart showing the OS such as Windows or
Ubuntu.

Lure Distribution Number of decoys deployed displayed a pie-chart showing the type of service
such as SSH, SAMBA, SMB, SCADA, RDP, HTTP, HTTPS, IIS (HTTP, HTTPS),
or MSSQL.

Incidents Distribution by Information about the number and types of incidents, such as SMB, HTTP, TCP,

Service and so on.

Top 10 Attackers by Incidents  The top 10 attackers by the number of incidents. .
Top 10 Attackers by Events The top 10 attackers by the number of events.
Global Incidents Distribution Displays the number of Attackers by country on a global map.

Top 10 IPS attacks Displays the top 10 IPS attackers by the number of events.

For information about adding widgets, see Customizing the dashboard on page 30.

System Resources

The System Resources widget displays basic information about the FortiDeceptor system, such as the serial number,
system up time, and license status information. Use the System Resources to reboot or shutdown the unit.

System Resources S o %

M Current vCPU: 12

& Current G-RAM: 15

@ Active DecoyVMs: 4

@ Max Decoy VMs: 5

#ll: CPU Usage:
ﬂ Memory Usage: 62%

' Reboot @ Shutdown

This System Resources widget displays the following information:.

FortiDeceptor 5.2.2 Administration Guide
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Current vCPU The current number of vCPUs.

Current G-RAM The current amount of RAM in GB.
Active Decoy VMs The current number of active decoy VMs.
Max Decoy VMs The maximum number of decoy VMs.
CPU Usage The CPU usage as a percentage.
Memory Usage The memory usage as a percentage.

Reboot or shut down the unit

To avoid potential configuration or hardware problems, always use the GUI or CLI to reboot or shut down FortiDeceptor.

To reboot the FortiDeceptor unit:

Go to Dashboard > System Resources.

Click Reboot.

Enter a reason for the reboot in the Reason field.
Click OK.

o bd-=

After reboot, the FortiDeceptor VM initialization requires approximately 30 minutes. The Decoy VM icon in the System
Information widget shows a warning sign until the process completes.

When FortiDeceptor boots or reboots, the following critical event log message is normal:

The VM system is not running and might need more time to start up. Please check system logs for more details. If
needed, please reboot system.

After upgrading FortiDeceptor to a new firmware version, the system might clean up data and a Database is not ready
message displays. The clean up time depends on the size of historical data.

To shut down the FortiDeceptor unit:

Go to Dashboard > System Resources.

Click Shutdown.

Enter a reason for the shutdown in the Reason field.
Click OK.

P owbd-=
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System Information

The System Information widget displays information about the FortiDeceptor device. Use this widget to configure the
device host name, update the firmware version, upload a license or back up the system configuration.

System Information S T %
Appliance Mode Manager
Host Name FDCVMS0000000139 [Change]
Serial Number FDCVMS0000000139
System Time 2022-07-12 11:22:48 PDT [Change]
Firmware Version v4.2.0,build0226 (GA)[Update]
Firmware License @ [Upload License]
System Configuration Last Backup: N/A [Backup/Restore]
Current User admin
Uptime 26 day(s) 1 hour(s) 57 minute(s)
Deception 05 ]

This widget displays the following information and options.

Appliance Mode
Appliance CM Status

Appliance CM Live Time

Host Name

Serial Number

System Time

Firmware Version

Firmware License

System Configuration

Current User

The mode of the appliance: Manager, Client, or standalone.

Optional for client appliance. Display the status in Central Management. See
Central Management on page 32.

Optional for client appliance. The last live timestamp in Central Management. See
Central Management on page 32.

The name assigned to this FortiDeceptor unit. Click Change to edit the
FortiDeceptor host name.

Serial number of this FortiDeceptor unit. The serial number is unique to the
FortiDeceptor unit and does not change with firmware upgrades. The serial
number is used for identification when connecting to the FortiGuard server.

The current time on the FortiDeceptor internal clock or NTP server. Click Change
to configure the system time. See Configure the system time on page 13.

Version and build number of the firmware installed on the FortiDeceptor unit.

To update the firmware, you must download the latest version from the Fortinet
Customer Service & Support portal. Click Update or UPDATE AVAILABLE and
select the firmware image to load from the local hard disk or network volume.

For information, see Update FortiDeceptor firmware on page 22.

To load a firmware license, click Upload License and select a license file. See
Upload license file to FortiDeceptor on page 14.

Date and time of the last system configuration backup. Click Backup/Restore to
go to the System Recovery page. See Back up or restore the system
configuration on page 23.

The administrator that is currently logged into the system.
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Uptime
Deception OS

FDN Download Server

Web Filtering Server
Antivirus DB Contract
Antivirus Engine Contract
IDS Engine/DB Contract
Web Filtering Contract
ARAE Engine Contract
Custom VM Contract

SSL VPN Contract

To change the Host Name:

Duration that the FortiDeceptor unit has been running since it booted up.

Deception OS license activation and initialization status.

Displays a green check mark if the Deception OS is activated and initialized. A
Caution icon is displayed if the Deception OS is initializing or having issues. Hover
you mouse over the status icon to view detailed information. For more

information, see Log > All Events.

To go to Deception > Deception OS to see the images available on FortiDeceptor,
click Update or UPDATE AVAILABLE.

After purchase, download the license file from the Fortinet Customer Service &
Support portal. Then click Upload License to select the license file. The system
reboots and activates the newly-installed Deception OS.

Shows if the FDN download server is accessible. When the FDN download server
is inaccessible, no update packages are downloaded.

Shows if the web filtering query server is accessible.
Brief information about this contract.
Brief information about this contract.
Brief information about this contract.
Brief information about this contract.
Brief information about this contract.

Brief information about this contract.
This is displayed when FortiDeceptor is running a v1 license.

Brief information about this contract.
These is displayed when FortiDeceptor is running a v4 license.

1. Goto Dashboard > System Information widget.
2. Click Change. The Edit Host Name page opens.
3. Inthe New Name field, enter the new Host Name and click Apply.

Update FortiDeceptor firmware

A best practice is to stay up-to-date with patch releases for currently deployed major release. Only update to a new major

release or version when you are looking for specific functionality in the new major release or version. For more
information, see the FortiDeceptor Release Notes or contact Technical Support.

Before any firmware update, complete the following:

» Download the FortiDeceptor firmware image and Release Notes document from the Fortinet Customer Service &
Support portal. Review the Release Notes, including the special notices, upgrade information, product integration
and support, and resolved and known issues.

FortiDeceptor 5.2.2 Administration Guide
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« Back up your configuration file. It is highly recommended that you create a system backup file and save it to your
management computer. You can also schedule the system to back up system configurations to a remote server.
See, Back up or restore the system configuration on page 23.

« Plan a maintenance window for the firmware update. If possible, consider setting up a test environment to check
that the update does not negatively impact your network.

To update the FortiDeceptor firmware:

1. Goto Dashboard > System Information > Firmware Version.
2. Inthe System Information widget beside Firmware Version, click Update or UPDATE AVAILABLE.

3. Click Choose File and locate the previously downloaded firmware image on your management computer; then click
Submit to start the upgrade.

Alternatively, in the AVAILABLE FIRMWARE pane Install column, click the download icon beside the firmware
release you want. The system upgrades and restarts automatically.

When the update is complete, test your FortiDeceptor device to ensure that the update was successful.

Back up or restore the system configuration

We recommend that your regular maintenance includes system backups. Always backup before upgrading firmware or
making major system configuration changes. Save configuration backups to a management computer in case you need
to restore the system after a network event.

The FortiDeceptor configuration file is in binary format and manual editing is not supported.

To back up the FortiDeceptor configuration to your local management computer:

1. Goto Dashboard > System Information > System Configuration.
2. Click Backup/Restore.
3. Click Click here to save your backup file.

To restore the FortiDeceptor configuration:

Go to Dashboard >System Information > System Configuration.

Click Backup/Restore.

Click Choose File and locate the backup file on your management computer.

Click Restore to load the backup file.

Click OK.

When the system configuration restore process completes, the login page appears.

o oN-=

N ! 7, When you do a system restore, all configurations are replaced with the backup data. The
? system reboots automatically to complete the restore. Only the backup configuration file from
3 the previous or the current release is supported.
FortiDeceptor 5.2.2 Administration Guide 23

Fortinet Inc.



Dashboard

License Information

The License Information widget displays the license version, type, expiration dates and license key.

License Information &S o
Version 4.0.0
Type Evaluation License
M Valid for 901 days
usG Disabled
VLAN 128 /Valid for 901 days
Key TRIAL-WIN7P-FDCPS-TRIALXXXXX
Key TRIAL-WIN7P-FDCPT-TRIALXOOX
Key TRIAL-WIN7P-FDCPU-TRIALXXOOX
Key TRIAL-WIN7P-FDCPV-TRIALXOOXX
Key TRIAL-WIN7P-FDCPW-TRIALXXOOX

Disk Monitor

This Disk Monitor is only available in hardware-based models. This widget displays the RAID level and status, disk
usage, and disk management information.

Disk Monitor F =
- (o I

- v

' S

1753 RAID Level: RAID-1

GD Status: oK

& Disk Usage:

Disk Mumber Disk Status Disk Size (GB)
0 oK 931

1 (]9 231

This Disk Monitor displays the following information:

RAID Level The RAID level.

Disk Status The disk status.

Disk Usage The current level of disk usage as a percentage.
Disk Number The disk number.
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Disk Size The disk size in GB.

Incidents & Events Distribution

This Incidents & Events Distribution widget displays the number of incidents and events by risk level as a pie chart.
Hover the pie chart to see the number of Incidents or Events and their percentage.
Incidents & Events Distribution - Last 4 Weeks A

48 Incidents & 138 Events detected

Low Risk Unknown High Risk Medium Risk == Critical

The Incidents & Events Distribution widget shows following risk level information:

Unknown Incident or Event where the risk level is unknown. Entries are in grey.
Low Risk Incident or Event where the risk level is low. Entries are in green.
Medium Risk Incident or Event where the risk level is medium. Entries are in yellow.
High Risk Incident or Event where the risk level is high. Entries are in orange.
Critical Incident or Event where the risk level is critical. Entries are in red.

Incidents and Events Count

The Incidents and Events Count widget displays the number of Incidents and Events as a chart. The Events are in blue
and the Incidents are in orange. Hover over the chart to view the counts by date. To filter the chart, click Event or Incident
in the legend.
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Incidents & Events Count - Last 4 Weeks &
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= Event = Incident

Decoy Distribution by OS

The Decoy Distribution by OS widget displays the number and percentage of Decoy VMs by OS as a pie chart. Hover
over a piece of the chart to view the distribution by percentage. To filter the chart by OS, click the OS name in the chart
legend.

0
x

Decoy Distribution by OS rd

= Win7x64¥1 == jotv1 == ubuntu16v2 ubuntul16vl == win10v1

ubuntu1bve:
5

ubuntu16v2:
9

-~ win10vi:
1

Click a piece of the chart to isolate a Decoy VM from the chart.

Decoy Distribution by OS S o %

= win7x64v1 = iolv1 = ubuntul6v2 ubuntut16yl = win10v1
ubuntu 16y

ubuntulévi: 16.67 %

ubuntu1év2,
9

N

Supported OS types:

The Decoy Distribution by OS widget displays the distribution for the following OS types:
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Ubuntu, Windows, SCADAV3, SSLVPN, Medical, ERP, POS, loT and SAP.

Lure Distribution

The Lure Distribution widget displays the number of lures deployed as a pie chart. Hover of a piece of chart to view the

number and percentage of decoys by service. To filter the chart, click the service name in the legend.

Lure Distribution &S T %R

528 Lures Deployed

== FTP == SAMBA == H[EB 55 CWMP == TGPL\stener == NBNSSpoofSpotier
— GIT — 88H HTTPS T LINKWTE T E%ghc Search =— ICMP — SWMB

TCPLAS(BnEr

‘D

\ SMB:

75

SSH
H'ITPS
TP LINKWEE

/ Elashc Saamh
L~

o e
23

Supported services

The Lure Distribution widget displays information for of decoy images using the following services:

SSH, SAMBA, SMB, TCPLISTENER, NBNSSpoofSpotter, RDP, HTTP, FTP, TFTP, SNMP, MODBUS, STCOMM,
BACNET, IPMI, TRICONEX, Guardian-AST, IEC104, MSSQL, IIS, GIT, ENIP, Infusion Pump Telnet, Infusion Pump
FTP, POS-WEB, ERP-WEB, PACS, PACS-WEB, DICOM, SSLVPN, DNP3, Telnet, Printer-WEB, JETDIRECT, IP
CAMERA-WEB, UPNP, RTSP, SAP WEB, SAP ROUTER, SAP DISPATCHER , TP-LINK WEB and CWMP

Incidents Distribution by Service

The Incidents Distribution by Service widget displays the number of incidents by service as a pie chart. Hover over a
section of chart to view the percentage by service. To filter the chart by service, click the service name in the chart
legend.

[$]
x

Incidents Distribution by Service &

—CMp =—rdp — E"ﬂfz" ttp 55h == TCP == netbios-ns

hitp:

22 —

285 \

TR
#7700

rdp. Z
184

emp. 4 . nefbiosns
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Click the pie chart to split a service from the chart.

Incidents Distribution by Service &S T %R

hitp:

A T\

= jcmp = rdp — smt:g Tp == 55h == TCP == netbios-ns

Supported services

Incidents Distribution by Service widget displays incidents occurring for the following services:

SSH, SAMBA, SMB, RDP, SWIFT Lite2, HTTPS, HTTP, FTP, TFTP, SNMP, MODBUS, S7TCOMM, BACNET, IPMI,
TRICONEX, GUARDIAN-AST, IEC104, HTTPS, PACSWEB, POSWEB, AST, IPCAMERA, JETIRECT, TELNET,
SSLVPN, KAMSTRUP, DICOM, ENIP, UPNP_HTTP, GIT, RTSP, PRINTER, DNP3, SAP_DISPATCHER, SAP_WEB_
HTTPS, SAP_WEB,SAP_ROUTER,NETBIOS-NS, and ERPWEB

Top 10 Attackers by Incidents

The Top 10 Attackers by Incidents widget displays the top ten attackers by the number of incidents as well as the
attacker's IP address. Hover over a bar in the chart to view the number of incidents by IP.

Top 10 Attackers by Incidents - Last 4 Weeks S o %

e _ N
s _ N
- ’

10.10.2.1 (Private)
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Top 10 Attackers by Events

The Top 10 Attackers by Events widget displays the top ten attackers by the number of events as well as the attacker's
IP address. Hover over a bar in the chart to view the number of events.

Top 10 Attackers by Events - Last 4 Weeks &S T %R

e _ N
s _ “
- '

10.10.2.1 (Private)

Global Incidents Distribution

The Global Incidents Distribution widget displays the number of attackers by country on a global map. Hover over each
country to see the number of attackers from each country.

Global Incidents Distribution &S T %R

Top 10 IPS Attacks

The Top 10 IPS Attacks widget displays the IPS attack name and number of events for the selected time period (24
hours, 7 Days, or 4 weeks).
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Top 10 IPS Attacks - Last 4 Weeks &S o %

PN
MS.SMB.Server Compression. Transform.Header Memory.Corruption 20

Apache.Jetspeed.UserManager REST.APL.Security Bypass I 2

Customizing the dashboard

You can select which widgets to display on the Dashboard and where they are located on the page. You can also
configure the time period and refresh interval for individual widgets.

Dashboard toolbar

The dashboard toolbar is located near the bottom of the pages. You can perform the following tasks:
« Click Add Widget to add a widget to the dashboard.

=+

» Click Reset to restore the dashboard settings. This will remove any widgets you added to Dashboard and revert any
changes you made to the widget settings.

(&

« Click Save to save the current Dashboard view.

« Click Save as Default to save the current layout as the default Dashboard view.

a8
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To add a widget to the Dashboard:

1. Click the Add icon. The Widget Selection dialog opens.

Widget Selection X
B SystemInformation =2

System Resources

B TopCriticallogs P

B License Information () = DiskMonitor @@

(il

Incidents & Events Distribution =

Incidents & Events Count

]

Decoy Distribution by OS = LureDistribution

B Incidents Distribution by Service @) B  Top 10 Attackers by Incidents ()

= Top 10 Attackers by Events () = GlobalIncidents Distribution ({3

B Top10IPSAttacks

2. Select the widget you want to add to the Dashboard.
Widget toolbar

The widget tools are located in the widget header.

« Click Edit to configure the widget Time Period and Refresh Interval. The widgets setting will vary depending on the
widget.

y

&

o Click Refresh Data to refresh the widget data.
~a
L=

o Click Delete to remove a widget from the Dashboard.
x
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Central Management

Central Management allows you to manage remote FortiDeceptor appliances including Decoy VM deployments, system
configuration, and incident alert monitoring.

You can configure a FortiDeceptor hardware or VM appliance to be a Management Device or Remote Client. The
Management Device has deception capabilities. You can use the Management Device to deploy decoys and lures to the
Remote Clients on the network.

Network communication requirements:

Communication between: From:

Management device and Client to manager port1 IP and 8443 port
regular client appliance

Management device and Management device to cloud client port1 public IP and 8443 port
cloud client appliance

2805
-

FortiDeceptor VM £ Appliances P s @~  adminv

re you looking for? Q  central Management Appliances

@ Dashboard
¢ Add Cloud Appliance

% Central Management v
Appliances (] Action SNt IPt Name t Approval St... Live Status Version t Enroll Time 1 Last Activity 1
O Deception v
= " " 2022-06-16 2022-06-20
O a FDC-VMOO0... . 239 Approved 4+ Online va10buildoz..  £25508° 18, 1025958

Custom Decoy Image

Deception OS

Use the buttons in the Central Management Appliances pane to manage Remote Clients.

Approve Allow the selected clients to participate in Central Management.
Hold Pause the selected clients’ participation in Central Management.
Delete Pause the selected clients and then permanently delete related data in the Manage Device's

local database, including OS, network settings, decoys, and lures.

This action does not:
¢ Delete or change any data in the Remote Client.
¢ Change incident and campaign data generated in the past.

Refresh Force re-sync all data between manager and selected clients.

Restart Send signal to selected clients to reboot.
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Remote Client

When a FortiDeceptor is managed as a Remote Client the navigation pane will only displays the Network, System and

Log modules.
E2% FortiDeceptor VM £ Interfaces >, P TR @ adminv
are you looking for? Q

@ Dashboard Interface IPv4 IPvé Interface Status Link Status Access Rights
€ Network A port1 (administration port) /255.255.255.0 o L] HTTPSSSH
£F System ~  port2 /255.255.255.0 [+] [
Log . port3 1/255.255.255.0 o ]

port4 /255.255.255.0 (4] (i

port5 /255.255.255.0 o ]

porté /255.255.255.0 o ]

To prevent access to a Remote Client outside the Central Management or other trusted IP addresses, go to System >
Administrators. See Administrators on page 124.

When the Remote Client is a cloud device, configure the trusted host with the Management Device's IP to ensure only
the Management Device can access itself.

On the Management Device, configure the trusted host with regular client IPs to ensure regular clients can access
Management Device.

When you deploy a decoy or network, select the local or Remote Client name. Use the local configuration to deploy
decoys and lures from the Management Device.

Configuring Central Management

To configure Central Management:

Enable Central Management on the Management Device.
Enable Central Management the Remote Client.

Approve the Remote Client on the Management Device.
Configure the Remote Client with the Management Device.

oo Dd =

The tasks below are based on the following topology:

FortiDeceptor Manager FortiDeceptor Client
(Management Device) (Remote Appliance)
172.16.130.12 192.168.0.100

To enable Central Management on the Management Device:

cm -sc -mM —-nManager -a<password>

Example:

cm -sc -mM -nManager -al234567890
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To enable Central Management on the Remote Client:

NP Before configuring FortiDeceptor as a Remote Client, perfforma factory reset and basic
‘Q' network configuration to avoid data incompatibility between the Management Device and
- Remote Client. For more information on manager and client configuration, see the CL/
- Reference.

cm -sc —-mC —nAppliancel -a<password> -i<manager ip address>

Example:
cm -sc —mC —-nAppliancel -al234567890 -1172.16.130.12
To approve a Remote Client with the Management Device:

1. Onthe Management Device, go to Central Management > Appliances. The Approval Status for the Remote Client
will display On-Hold.

- 4 2805 .
£ Appliances > & "I @~ adminv

Central Management Appliances

&> Add Cloud Appliance

ction t 1] ame 1 roval St... ive Status ‘ersion t nroll Time t as ivity +
Acti SN P N Appi 1S Live St Versi Enroll Ti Last Activi

N " : 2022-06-16 2022-06-20
[ i FDC-VMOO0... €239 @ On-Hold 4 Online vA10bulldO2..  $55:05 ppT 1535:11 PDT

2. Select the appliance and click Approve. The Approval Status changes to Approved.
@ Request sent successfully. >_ y ZB" @v admin~

Central Management Appliances

&> Add Cloud Appliance

| Action SNt 1P+ Name t Approval St... Live Status Version t Enroll Time t Last Activity 1
M = FDC-VMOQO. 172.16.69. €239 o £ onli 2022.06-16 2022.06-16
@ 3 - -16.65... Approved Online 15:47:53 PDT 15:47:53 PDT

To configure the Remote Client with the Management Device:

1. Onthe Management Device, go to Central Management > Appliances.
2. Inthe Action column, click the Configicon . The Appliance - <name> page displays the following tabs.

Firmware Push FortiDeceptor firmware updates and upgrades to the Remote Client.
Synchronization can be immediate or scheduled.

Deception OS Push deception VM images from the Management Device to the Remote Client.
Synchronization can be immediate or scheduled.

Status Current status of deception OS image.
Name Name of deception OS.
OS Type Type of this deception OS.
FortiDeceptor 5.2.2 Administration Guide 34
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VM Type Category of this deception OS.
Lures Lure services can be provided by this deception OS.
Interfaces Configure the Remote Client network interfaces.
Routing Configure the Remote Client network routing table.
DNS Configure the Remote Client DNS configuration.
FortiGuard Configure the Remote Client FortiGuard configuration.

3. To synchronize the firmware, click the Firmware tab and select one of the following options and then click Apply:

Synchronize firmware image Click to synchronize the firmware immediately.
from manager now

Synchronize firmware image  Click to schedule the synchronization.
from manager at

£ Appliances : ®~ admin~

Appliance-C239 £

Firmware | DeceptionOS  Interfaces Routing DNS  FortiGuard

SERIAL NUMBER: FDC-VMO0000
FIRMWARE VERSION: v4.1.0,build0225 (Interim)  The appliance firmware need to be synchronized.
AVAILABLE VERSION: v4.2.0,build226 (GA)

O Synchronize firmware image from manager now

®  Synchronize firmware image from manager at

Date:  2022/06/20 | Time:  10:00:00 ®©

% Cancel

To remove a client from Central Management:

1. On the Remote Client, run the following CLI command:

cm —-sc —mN

After a client leaves Central Management, its status on the manager changes to Offline.
2. Onthe Management Device, select that client and click Delete.

To remove the Management Device from Central Management:

1. Onthe Management Device, run the following CLI command:
cm —-sc —mN
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Deception

Use the Deception module to customize, deploy, and monitor decoys.
This section includes the following topics:
o Deception OS on page 66

View the deception OSes available for creating Decoy VMs. You can also upload a deception OS package or
synchronize the deception OS list.

o Custom Decoy Image on page 36

Create custom OS images for the decoy. FortiDeceptor supports Decoy Customization with a purchased FDC
Custom Decoy Subscription.

o Deployment Network on page 67
Set up a monitoring interface in a VLAN or a subnet.
o Lure Resources on page 69

View the current lure, upload resources such as Word and PDF files to automatically generate lures, and import a
user name list from an LDAP server.

o Deployment Wizard on page 72

Create and deploy Decoy VMs on your network. Decoy VMs appear as real endpoints to hackers and can collect
valuable information about attacks

o Decoy Status on page 86
Monitor the status of the Decoys on your network.
o Deception Token on page 88
Use a FortiDeceptor token package to add breadcrumbs on real endpoints and lure an attacker to a Decoy VM.
o Deployment Map on page 90
View the entire network showing real endpoints and decoy VMs.
o Asset Discovery on page 92

Generate Asset Inventory by passively fingerprinting the OS and other parameters for the assets in OT/IT/loT
networks.

o Safe List on page 94

Add an IP address that is considered legitimate without generating an Event or Incident when accessing decoys.

Custom Decoy Image

For most deployments, the decoys included with FortiDeceptor are enough and are easier to deploy. However, you have
the option to build a decoy from your gold image using the custom decoy feature that is included under the subscription
license.
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Some examples of using Decoy Customization include:

o Windows 10/11/2016/2019/2022 decoy joining AD.
» Windows 10/11 Enterprises users with SQL Server (without IIS server).
o Windows Server 2016/2019/2022 Enterprises users with SQL Server, web applications using an IS server, and

more.
S ! ’, This version only supports Decoy Customization for Windows 10/11 and Windows Server
? 2016/2019/2022. Windows Server 2016/2019/2022 supports customized MSSQL and 1S
- services. Windows 10/11 supports customized MSSQL.

Overview of implementing Decoy Customization:

1. Order the FortiDeceptor Custom Decoy Subscription for FortiDeceptor hardware appliance only.
The Decoy Customization subscription is for FortiDeceptor hardware appliances only. This subscription license is
already included in the FortiDeceptor VM bundle.

2. Install FortiDeceptor.

After installing FortiDeceptor with the Decoy Customization subscription, the Help menu in the toolbar will display an
option for the Custom Decoy Image Cookbook.

3. Follow the instructions in the Customization Cookbook. The high-level instructions are:
a. Upload an ISO image.
b. Install ARAE engine onimage.
c. Use the Deployment Wizard to install the customized decoy.

Customize the deception base OS image

Overview of customizing the deception base OS image:

1. Import Windows ISO image.
2. Customize VM image.
3. Deploy custom image.

Import Windows ISO image

Before importing an ISO image into FortiDeceptor, ensure you have completed the following:

o Purchased a FortiDeceptor Custom Decoy Subscription

The FortiDeceptor Custom Decoy Subscription is for FortiDeceptor hardware appliances only. This subscription
license is already included in the FortiDeceptor VM bundle.

« Setup an ISO image with the licenses for your environment. For example, if you want to allow Active Domain (AD)
accounts to access decoys, configure the settings on the AD servers, such as create dummy accounts, and so on.
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To import an ISO image using the Imported Images page:

1. Go to Deception > Custom Decoy Image and click the Imported Images tab.

wp (2802 .
 Custom Decoy Image > F FIiv @~ adminv
Customized Images ‘ Imperted Images |
& Import New ISO Image
D Actions Image Name MD5 Import Time

2. Click Import New ISO Image.
3. Click Choose a file or drag and drop an image file into that pane.

To import an ISO image using the Customized Images page:

1. Go to Deception > Custom Decoy Image and click the Customized Images tab.

& Custom Decoy Image > # X @~ admin~
J Customized Images | Imported Images
= Import Image and Customize
D Actions VM Name Joined Domain CPU Memory (KB) HDD (GB)

2. Click Import Image and Customize.
3. Click Choose a file or drag and drop an image file into that pane.

To delete an ISO image:
1. Go to Deception > Custom Decoy Image and click the Imported Images tab.

2. Select one or more images and then click Delete.

Customize VM image

To initialize the VM instance:

Go to Deception > Custom Decoy Image and click the Customized Images tab.

Click Import Image and Customize. The custom image wizard opens.

In the Select an imported ISO image dropdown list, select an ISO image. Then click Next.
In the Configuration step, specify the following and then click Next.

Ao b=

Name Upper and lowercase letters and numbers totaling under 48 characters.
CPU Cores 1-4 cores.

Memory 1024-8192 MB.

Storage 20-50 GB.
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Customized Images | Imported Images

@ Select or upload an ISO & ) @ Configuration 8§

Name:

CPU Cores: 1

Memory: 1024 VB
HDD: 20 cB

This configuration is applied to the VM instance for customizing the image, This
configuration is not applied to decoys.

5. Inthe Customize step, install the OS from the ISO image.

Customized Images  lmponed Inages

| Solec o upioad an 150 L. ¥ &) Canfiguraton & ) ) Cusicinze O J

' Windows’

Follow the prompts until the installation is complete.
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K5 ol wotens Seng

To customize the VM:

1.

Ensure the OS is installed and then log in with an admin account.
2,

In Windows Explorer, locate the FDC_Toolkit folder and read the instructions in toolkit README.txt.

LAnnace

t am o This PC » D Dreve (B) FOC_Toolkt

# Cuick sccess

FOC_CUS_tosoliot
B Deskiop A S

FOC_Customization_Cookbook. pdf
& Downloads -

. Documents

=] wed_metwerk
=1 Pictures toolkit_README

A This PC

o Metwork

3. Configure the network using one of the following options.

» Right-click set_network.bat and then click Run as Administrator.

« Follow the instructions in net.json to configure the IP address, gateway, and DNS in Windows Control Panel >
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Network and Internet > Network Connections.

B Ch\Windows\System3Dcmd e

10.254.253.0/24 set by the script is the internal NAT IP address that is temporarily
used by the customization VM to allow downloading files and accessing other network

resources via the FortiDeceptor default route.

To customize the system for Windows 2016:

1. Ensure your license is activated.

2. Ifyou are using Windows 2016, enter the following commands in the PowerShell window to prevent lure
configuration failures in the Decoy Deployment wizard.
secedit /export /cfg c:\secpol.cfg
(gc C:\secpol.cfqg).replace ("PasswordComplexity = 1", "PasswordComplexity = 0") | Out-
File C:\secpol.cfg
secedit /configure /db c:\windows\security\local.sdb /cfg c:\secpol.cfg /areas
SECURITYPOLICY

rm -force c:\secpol.cfg -confirm:$false

To customize the system for standalone Windows Server 2016:

1. Goto Server Manager > Tools > Local Security Policy. The Local Security Policy directory opens.

2. Inthe Security Settings folder, go to Account Policies > Password Policy folder, and double-click Password must
meet complexity requirements.

3. Select Disabled and then click OK.

4. Open a Command Prompt as an Administrator and type the following command to update the group policy:
gpupdate /force

You should get the following response:

C:Users\Administrator>gpupdate /force
Updating policy...
Computer policy update has completed successfully.

To customize the system for Server 2016 Domain Controller :

1. Inthe Domain Controller, go to Server Manager > Tools > Group Policy Management.
2. Right-click Default Domain Policy and click Edit. The Group Policy Management Editor opens.

3. Inthe Computer Configuration folder, go to Policies > Windows Settings > Security Settings\Account Policies >
Password Policy > Password must meet complexity requirements.

4. Select Disabled and click OK.

5. Open a Command Prompt as Administrator and type the following command to update the group policy:
gpupdate /force
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Optional: Install the Microsoft SQL Server

The following SQL Server versions are supported.

o SQL Server 2016: https://www.microsoft.com/en-us/download/details.aspx?id=56840

e SQL Server 2017: https://www.microsoft.com/en-us/download/details.aspx?id=55994

o SQL Server 2019: https://www.microsoft.com/en-us/sql-server/sql-server-downloads

o QL Server 2022: https://www.microsoft.com/en-ca/sql-server/sql-server-downloads

o SQL Server Management Studio for SQL server management and customization. https://aka.ms/ssmsfullsetup

If you are downloading with Internet Explorer, it is recommended you disable /E Enhanced Security Configuration.

Server Manager * Local Server P’ Manage  Tooks Ve

_ 'i PROFERTIES

i Dashboard TASKS -

Local Server ) .

i Al Servers whcshgrous S Wincioves Update. et g
B§ File and Storage Services b rit checked fod update Higver

Since there is no desktop for Windows Server core OS, you must download the installation file on another computer and
then use SMB to install the SQL Server.

To install SQL server:

1. Download and install the SQL server on another computer.

SQL Server 2016 with SP2

Express Edition

Download successful!

Installing...
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Deception

2. When the SQL Server installation is complete, click Install SMSS to download and install the SQL Server
Management Studio to manage and customize the SQL Server.

SQL Server 2016 with SP2

Express Edition

Installation has completed

RELEASE 18.5

Microsoft SQL Server Management Studio

Cancel

To further customize the SQL database:

1. Download a sample database from https://github.com/Microsoft/sql-server-samples/releases/download/wide-
world-importers-v1.0/WideWorldImporters-Full.bak.

dithon aside from LocalDB; SOL Server 2006 RTM (of later
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2. Inthe FortiDeceptor Customize Decoy console, open SQL Server Management Studio.
3. Right-click the database object and select Restore Database.
| & Select or upkoad a0 150 1) § Configuraion o ) ) Customizs - 2

¢ ohulen’ Aok vt S0 Serewr Wl Sy |l gt H o= & x
Fie D8 Yew Pt Tooh Wedes  Halg
-1 a- = P Areteey A2 S 22 | RAaD-,

4. Locate and add the sample DB you downloaded.

Q St ilond 0 180 3. > © Contgaton & > © Cusiorzn -+
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5. When the sample DB is restored, right-click that DB and select Properties to change access permission to make the
decoy DB more attractive to attackers.

e Wi W Srrert Wlarugurrrent e [Aderetlor)

~ - o -
Fdg Lt Verw Peowil  Teoh  Weedow e
B-0-2H Aty 8228 P XL
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6. Give Grant permission to Select and Connect.

Y

i

TeErereew

7. Close SQL Server Management Studio.
8. Verify that your DB is up using the command netstat —-an | findstr 1433.
9. The listening port on the SQL Express Database is disabled by default. To enable the port:
a. Click Start > Programs > Microsoft SQL Server 20XX and select SQL Server Configuration Manager.
Select SQL Server Network Configuration.
Double-click Protocols for SQLEXPRESS
Right-click TCP/IP and select Properties. If necessary, first enable TCF/IP.
Scroll down to /PAll and verify TCP Dynamic Ports is blank and that TCP Port is set to 1433.
Click OK.

- 0 2 0 T

Optional: Install Internet Information Service (lIS)

IIS 10 is supported on Windows Server 2016/2019/2022.
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To add the IS role and service:

1. Goto Server Manager >Dashboard.
2. Click Manage > Add Roles and Features.

Ea Sorver Masager

Rermcve Roles and Festured
WELOOME TO SERVER MANAGER
A Servens

Creant Serves Growp

e o nficure t ATVET Sorrts Mg Frogarid
B File snd Soormge Servces &

WHATS KW

ROLES AND SERVER GROUPS

H File and Storage |
Sarvices

Server Manager * Dashboard

B & Bodes snd Feabures Wigard o *
i Local 54
B AnSen
BE File 52 m Thd witieed betlpes pns wviall pades, pole deveces, o Featured. Vin Setermene miurh soles, sobe servled, oo
- feafured 1 nstad Baded G the computing reech of your organisstien, such i tharng document or

hosting & wetaite

vk PO, PO JT0ES, OF Fedlufes

Erfore you contins, werify that the following Extks have besn complsted

= The Adminitrator scioont hat & firong paspwond
™ Maptwork wafmngs, Bach a5 static 1P sddeemas. are configueed
* The most QuTent se0sty up<abes feom Windows Updaie are mstaled

H s mrase vtrsly That vy of Thet preceding prentgusion Paree betn Compleied, Dot the wized Hade
complent the 35605, Bl Thiss fun The wizbid agaen,

To contimes, click Maxt

Sk thes page by detsult
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On the Select installation type page, click Next.

Bo A Fodes el Featuses Wiasid

b T o

[ TR

BE Fis anc Belors Vou Baain Selot the nstalation type. Veu £an install roles aned featunes o0 & Forang physal comput
maching, or on an offine vartual hard de (VRO

Cm————— * Roe based o0 feature- baied imiallation

Configure & tingle veresr by adding roles, role senvices, and fatures

s Al Tard

Remate Deililop Sefvioes inallation
Ingtall recuine role services for Virtoal Desking Infr
O 3435200 hated desiiog deployrrs

= =

BPA results Pesformance

BFA, rersults

E. édd Roies and Feabure:

Whatr et Wormbime. Sevver 21U Smedadl

1 Comprtir(s] foard
This pubet S0t BERAETE il 3 nasren 20132 0  rervves vebeane of Windows Sere,
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6. Onthe Select server roles page, click Web Server (11S).

B s Bobes pnd Feabures Winsd I o e

B Local s
Hi ais

S
B File ang

7. Inthe pop-up dialog box, click Add Features.
8. Onthe Select features page, click Next.

E. &dd Fobry and Frstunn Wisard - [m] E
[
e AT U
. Loscal 51 -k =9
| FEETE
WE Fite and i St o or mione fratine 85 ingtall on the selected server.
Feature Dirscription

MET Frarcwnsh 1% Feature

- TRTHEWD

Cancel

BPA results
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9. Onthe Web Server Role (IIS) page, click Next.

K

Ea Add Roles and Features Wizard - o *®

T
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tic and sdminatraton, s unded Wik platform that infegraten 3, ASPNET, and Windowy
sracatizn Foundyion

e gasgh wviranets gnd
nhanced secarity

indialatien far the Wels Server (JI5] role inchuied the mgtaliatien of role senvites that
sationd fiuch st defsult documents and HTTP

* The defimit
aruble y seren 20t content, malos mincr
o] monitor snd log saver sctivity. snd configune SIS conSent compeettion.

EPA results

il ] gherg pos Saben the rode servacis bo raiall or Web Servp

Fole service Dricription

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.



Deception

11. On the Confirm installation selections page, click Install.
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Custom OS Windows 11

The OS Windows 11(64 bits) deception OS is similar to Windows 10 services: however, the GUI restricts the CPU Cores,
Memory and Storage. Since Windows 11(64 bits) requires more resources, you may see the following messages:
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@ ¢f) Windows Setup

This PC can’t run Windows 11

This PC doesn't meet the minimum system requirements to install this version of Windows. For
more information, visit https://aka.ms/Windows5ysReq

You may also be blocked on the following OOBE page.
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Let's connect you to a
network
You'll need an internet connection to continue setting up

your device. Once connected, you'll get the latest
features and security updates.

Cl Unidentified network
No Internet

Having trouble getting connected?
For truub|2‘5h00'iﬂt‘ tips, use another device and visit
aka.ms/networksetup

To run Set Bypass TPM and SecureBoot check:

1. Boot off of your Windows 11 install disk.
2. Press SHIFT + F10 to launch the command prompt (If this does not work, you can try SHIFT + F10 +FN).
3. Enter regedit and press Enter.

BN Select Administrator X 'I.wmdnws'l.systemSZl.cmd EXE
icrosoft Windows r'wlllrl 16.

Microsoft LurpL ; on. Hll

4. Goto HKEY_LOCAL_MACHINE > SYSTEM> Setup. Right-click the folder to add a new key folder called
LabConfig.
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B Registry Editor
File Edit View Fovorites Help
Computer\HKEY LOCAL_MACHINE\SYSTEM\Setup

(=] 5 |

>

~ [l Computer

HKEY_CLASSEY ROOT
HEEy CURRENT | ISCR

I

HKEY_LOCAL_MACHINE I

?
’
2
>
o

TN A NE
SAM
SECURITY
SOFTWARE

SYSTEM

» ontrolset00]

» CumrentControlSet
5 DriverDaotabase

5 HardwareConfig

» Keyboard Layout

i MountedDevices
5 ResourceManager
RNG

Select

) Allowstart

Pid
SETUPCL
» Software

LT owea
HKEY_USERS

HKEY_ CURRENT_CONFIG

Name Type Data

26} (Default) REG SZ (value not set)

ab| CmdlLine REG 5Z winpeshlexe

.‘{-'_c'r]FactoryPrefnsta lL.. REG_DWORD 00000007 (1)

ab| Osl oaderPath REG 57 \

| Respecialize REG_DWORD OxOO000000 (0)

J':l'_c'rJResmrf.S'etup REG_ DWORD Ox00000000 (0)

J‘:l'_c'r] SetupType REG_ DWORD Ox00000000 (0)

fg',c'r]SystemSetupfnP... REG_DWORD Ox00000007 (1)

I Mew Key I

String Value
Einary Value

DWORD (32-bit) Value
QWORD (64-bit) Value
Multi-String Value
Expandable String Value

5. Add new value named BypassTPMCheck.
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6. Inthe LabConfig folder, type REG_DWORD", setitto 1.

B Registry Editor
File Edit View Fovorites Help
Computed HKEY_LOCAL MACHINE\SYSTEM\Setup\LabConfig

[= e =]

~ [l Computer
> HKEY CLASSES_ROOT
5 HKEY CURRENT_USER
v HKEY LOCAL_MACHINE

HARDWARE

SAM

SECURITY

SOFTWARE

SYSTEM
ControlSet(d7
CurrentControlSet

€ W W

DriverDatabase
HardwareConfig
Keyboard Layout

S R Y LT T

: MountedDevices
> ResourceManager
LT RNG
i Select
v Setup
|5 70 AllowStart
Fid

.. lLabConfig

WPA
> HKEY_USERS

Type
REG 5Z

New

Data

{value not set)

Key

String Value
Binary Value

Muttt-String Value
Expandable String Value
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7. Inthe LabConfig folder, add a new value called BypassSecureBootCheck then type REG_DWORD, and setitto 1.

View

Computer\ HKEY_LOCAL_MACHINE\SYSTEM\Setup\LabConfig

(=& ][=]

~ [l Computer
5 HKEY CLASSES_ROOT
5 HKEY CURREMNT_USER
v HKEY_LOCAL MACHINE

DRIVERS

HARDWARE

SAM

SECURITY

SOFTWARE

SYSTEM
Control5et007
CurrentControlSet

L R N

DriverDatabase
HardwareConfig
Keyboard Layout

e N RE WF N N

i MountedDevices
5 ResourceManager
RNG
Select
w Setup
5 =7 AllowStart
Al
SETUPCL
LabConfig
» Software
LT owea

MName Type Data
3_'.'] (Default) REG_SZ (value not set)
_u‘iu'g'] BypassTPMCheck REG DWORD 0000001 (1)
.?5'9'\] BypassSecureBootCheck REG_DWORD (00000007 (1)
Edit DWORD (32-bit) Value [

BypazsSecureBootCheck

Value data: Base

0 Hexadecimal

() Decimal

»
4

You can set the RAM larger or equal to 4G during configuration, but If the RAM is less than
4G, you can add another new value called BypassRAMCheck to the LabConfig folder, and
type REG_DWORD, and set to 1.
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To set the bypass network setup during OOBE:

1. Press SHIFT + F10 or SHIFT +Fn+ F10 to launch the command prompt when asked to setup network
2. Enter"OOBE\BYPASSNRO" and press Enter.

BER Administrator: CAWindows\system32\cmd.exe —

Join a domain

Before joining a custom Windows OS to a domain, change its DNS server to the DNS server of the domain.

A\,

b ] L4
? This task is optional.
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To join a domain:

1. Go to Control Panel > System and Security > System and click Change settings.

A Conrol PamehSystenn and Securin System - o k4
4 B+ Contrel Pasel + Sysbem and Security » Sysbem w Saarch Condrod Panel o
Cortrol Pareel Home . i s . e
View basic information about your computer
' Device Manager Windows etien
W Remote settings Windows Server 2016 Standard
) Advanced system settings © 2016 Micrasoft Carporation. All ights BR Windows Server 2016
reserved.
Systern
Processon CHEMU Virbual CPU wersion 2.5= 350 GHz {2 procesacrs]
Installed mamory (RAME 300 GB
Sybern bype 8Bt Oiparabing Symiam, ol Bated prss siicd
Pen and Touch: Mo Pen or Touch Input is svailable fer this Display

Computer name, domain, and workgroup seftings

Computmaame -

Full computer names WIN-G0ASEEAIRG h
Computer descrplion:
Waorkgroup: WORKGROUS

‘Windows activation

‘Windoras o not scteabed.  Fesd the Mecresol Solteare Lcerde Terms

Product I0: 00376~ 30000-00259- 8808 WP ictivate Windows
See also

Securty and Maintenancs

2. Onthe System Properties dialog box, click Change.

[ -
4 B o Contrel Panel + System and Security » Syslemn w & Search Control Panel )
Centred Pand Home “
Gytem Properties =
% Device Manager Computer Mams  fiarthware  Advanced  Flamcle
W Remote sestings

Wirdows T S p——
& advanced syitem settings L o e

dows Server 2016

Computer goscrpten: || ]
For esampls: “NE Producion Server™ or
Aot Sereer

Fulcompusrrans:  WIRLITPTSONUTY Gz (2 pracessoes)

'wa proceiide

T sroames This Compeuer or changss 8 domsn o m te tiis Diplary
ik grings ik Charede

WP hange settings

E Softevare Licerde Terd

[ ]| caca oo & tctraae Window

St shae

Security and Mantenance
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3. Enter the Domain and click OK.

Cergter Harne Dermain Changed ®

Wious can changa the name and the membanhp of s LoMmpener
compuler. Changes might afect 3o0ees 10 Metwer rescurces

Cormpater name
WIN-G03ASSENRG

Full exmga.ber name
WIN-EOOASSIARG

B | e ]
M of
) Chcwvasin
L o]
L Wfesogronn
on |l Cancel
1
oK Cancel

4. Click Close and restart the computer to join the domain.

Install the FortiDeceptor customization toolkit

When system customization is complete, right-click FDC_CUS_toolkit.exe and select Run as Administrator and wait for
the installation to finish.

Another option is to run the CLI command FDC_CUS_toolkit.exe as anadministrator.

Save the custom image

When the customization status in the GUI displays Ready, click Start -> Power > Shut down to shut down Windows and
then click Save to save this image.

If the Windows Server is connected to a domain, there may not be a Power option in the GUI. In this case, run the
command shutdown /s /t 1 /f asadministrator.

It might take several minutes to save the entire image. When the image is saved, the page lists the image in Customized
Images.

In Deception > Customization, the Customized Images tab lists the custom images.

The Actions column has icons for you to view logs, apply the image, or delete the image.
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Deploy custom image

To apply a custom image:

1. Go to Deception > Custom Decoy Image and click the Customized Images tab.
2. Select a custom image and click the Apply button or click the Apply icon 4 beside a custom image.

Customized Images Imporied Images

= Import Image and Customize * Apply @ Delete
Actions VM Name CPU
A ®0 custest 4

It might take a few minutes to apply the custom image. When applied, the custom image is listed in Deception >

Deception OS.
[ | Status Mo T 05 Type VM Type Lures
=] £ Initlalized ustest = Cuntomized Windomas 10 Wz Erd Pl | %
X Get scadanl ’ Seads SCADAIOT device &
& Initislized ubuntultvi f_“ [T Linue End Point

To deploy decoys with custom images—generic image:

1. Go to Deception > Deployment Wizard.
2. Click a custom image and deploy it like a standard decoy.

3. Select whether to domain users to access RDP and SMB.
For normal users:
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I.__é RDP(2)

Username

loretta

lawrence

@ SMB (2)

O

Password

O

Username Password

rhonda

maurice

For domain users:

(@ ror
Allow domain user to access RDP

Username

david@name.com

ethan@name.com

@ SMB (1)

Allow domain user to access SMB

Password

O
©

Username Password

robert@name.com

+ Add Lure

4 Add Lure

Sharename

4+ Add Lure

4 Add Lure

Sharename

A\,

and not set in any local lure accounts. Many domains have different policies for account
name and password which may cause the decoy to fail to initialize.

\9, We highly recommend enabling RDP and SMB services for decoys joined in the domain
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To deploy decoys with custom images—SQL Server:

1. Go to Deception > Deployment Wizard.
2. Click a custom SQL serverimage.

£2% FortiDeceptor VM O Deployment Wizard

Q0  Deployment Wizard

P (& Template ¥ ) € Cortguration o ) ) Set Network O 4

a Deception
Mams i
Customiration SSQL_Server -]
Deception 05 Herailabie Deception Orbes cus. WinSrvls MSSCHL %
Dhepiloyment Metwor Saplec e Services 8
Dagsloryrmant Wirard
SMB 0
Dty & Lure Status E
Decry Magp L_‘m RDP O
Wihiteliat [B SQLSERVER )
B incigent "
Lintening Port
2 Fabric
Dt abais Mame
@ Metwork
& System - Diatabase Content
B Leg A
SOLSERVER USERS & Add Usar
Username Password
— TEMER
— CPLISTENER (4 O
Ligbening Perly P i EANEF SOTITLE LORAT IR ot valieed
Launch Immediatety C
Rt D vy

3. (Optional) Click Sample to download a sample .sq/file.
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4. Click Upload SQL Schema to upload your own custom .sq/file .

Deployment Wizard

© Teowiote 49 © Corvin o6 DO Sethetuk © 3

Name win2016svr-sql (]
Avallable Deception OSes cus 16ad
Selected Service S50 -
Automate Lures any GCenerate Lures Clear
-
(@ roro0
tening Port 1433 o
atabase Name pubs L]
Database Conte 2. Upload SQL Schema |o|:|
MSSQL Use + Add User
Username Password

- 7.
an 25

To generate SQL alerts:

1. You can generate SQL alerts using the SQL.CMD tool or using WideWorldImporters.

e To use SQLCMD, run the following commands.
sglcmd -S "IP Address" -U "username" -P "password"
use WideWorldImporters;
SELECT name
from SYSOBJECTS
WHERE
xtype = 'U'
go
o TouseWideWorldImporters, run the following commands.
use WideWorldImporters;
select top 100 * from Sales.Orders;
go
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The Incident > Analysis page displays the alerts for the SQL server attack.
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To deploy decoys with custom images-IIS (HTTP/HTTPS):

1. Go to Deception > Deployment Wizard.
2. Click a custom IIS image.

&Y usHTTR) (1)
HTTP

Listening Port

O
80 ©

11S (HTTP) Users + Add User
& s tTTeS) (1) O
Listening Port 443 (-]
SSL Certificate (optional) X Upload certificate/key zip file @
@ The zip file should contain both SSL certificate and key files
11S (HTTPS) Users + Add User
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To deploy decoys with custom images—NBNSSpoofSpotter:

1. Go to Deception > Deployment Wizard.
2. Click a custom NBNSSpoofSpotter image.

Net

glos] NBNSSpoofSpotter (0) O
Username scott ]
Password ]

Domain (optional)

Hostname ]
© Please provide a fake hostname for NBNS request
Interval 3600 |seconds @
\‘ : 'l
q NBNSSpoofSpotter feature detects attacks using the Responder tool and includes a link to
- https://github.com/SpiderLabs/Responder with more information about the attack.

To Deploy decoys with custom images-SWIFT Lite2

1. Go to Deception > Deployment Wizard.
2. Click SWIFT Lite2 service.
3. Upload the MT Files.

SWIFT Lite2 @)

SWIFT MT Files * X sample_MTzip | @& Sample MT files

FortiDeceptor 5.2.2 Administration Guide
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Deception OS

The Deception OS page displays the deception OS or deception packages available for creating Decoy VMs. Use this
page to upload a deception OS package or to synchronize the deception OS list.

# @~ 02567~ O admin~

X Upload Deception OS Package X Upload Deception Service Package = Synchronize Deception OS List

Status Name t OSType VM Type Lures Appliance

BN ENNNNNNN
£* Initialized outbreakvl [(® Ubuntu Linux Server % Z I Z z E E E z Z I Z Local
BB EENNENNENNE.
& synchronize outbreakvi @ ubuntu Linux Server % FRC I 2N I Y I I I Y 2 ) c123
£ Initialized posvl [, Posos POS system Local
A Synchronize posvl [:lﬂ POSOs POS system c123

The Deception OS page displays the following in formation:

Column Description

Status Status of the Deception OS.

Name Name of the Deception OS.

OS Type Operating System type.

VM Type VM type of the Deception OS endpoint.

Lures Lures used by the Decoy VM such as SSH, SAMBA, SMB, RDP,

TCPLISTENER, HTTP, NBNSSpoofSpotter, FTP, TFTP, SNMP,
MODBUS, S7TCOMM, BACNET, IPMI, TRICONEX, Guardian-AST,
IEC104, DNP3, ENIP, KAMSTRUP, Infusion Pump (Telnet), Infusion Pump
(FTP), PACS, PACS-WEB, DICOM server, POS-WEB, ERP-WEB,
SSLVPN, ScadaBR (HTTP), SRTP, Tomcat(HTTP, HTTPS), MariaDB and
Elastic Search(HTTP).

To upload a deception OS or service package:

1. Go to Deception > Deception OS.
2. Click Upload Deception OS Package or Upload Deception Service Package.
3. Click Choose a file or drag and drop the file onto the field.

To synchronize the list:

Click Synchronize Deception OS List.

To install a Deception OS on a device:

In the Status column, click the Synchronize button next to the OS name.
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>, # @~ L7468~ O admin~

X Upload Deception OS Package < Synchronize Deception OS List
Status Name t OS Type VM Type Lures Appliance
. e [ [w B & &
X Synchronize medicalvi EB Medical OS Medical loT system = e C123

@) () &

Deployment Network

Use the Deployment Network page to set up a monitoring interface into a VLAN or a subnet.

®~ admin~

2 Deployment Network

Deployment Network
Auto Vlan Detection port2 (]
OK
o
Action Status Name Interface t VLAN ID Deploy Monitor IP/Mask Tag Gateway Ref.
£+ Initialized deploynet1 port2 0 any 10.10.2.1 9
£+ Initialized deploynet3 port3 0 any 0.0.0.1 2
¢ Initialized deploynet4 port4 0 any12 10.12.2.1 7
L Initialized deploynet5 port5 0 any 0.0.0.1 2
Edit Delete £+ Initialized deploynets porté 0 any 0001 0

Arp Protec.

No

No

No

No

The Deployment Network page displays the following information:

Action Click Edit to edit the VLAN or subnet entry. The Edit button is visible only after the

entry is saved.
Click Delete to remove a VLAN or Subnet.

Status Status of the IP address, such as if it is initialized.

Name Name of the VLAN or subnet.

Interface The port that connects to the VLAN or subnet.

VLAN ID The VLAN's unique integer ID.

Deploy Monitor IP/Mask The monitor IP provides the dynamic content for the online token, collects the

token installation information, and acts as the probing client for active asset

discovery when auto-deployment is triggered.

Tag The tag for the VLAN or subnet.
Gateway The gateway IP address of the deployment network.
ARP Protection Indicates ARP Protection is enabled (Yes) or disabled (No).
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Setting up the deployment network

To add a VLAN or subnet to FortiDeceptor:

1. Go to Deception > Deployment Network.

2. Enable Auto VLAN Detection to automatically detect the VLANs on your network.
Auto VLAN detection allows FortiDeceptor to detect the available VLANs on the deployment network interface and
display them in the GUI. You can select and add the VLANs for the deployment of Decoys later.

3. Select the Detection Interface and click OK. You can select multiple ports.

4. Click Add New VLAN/Subnet to manually add a VLAN or a subnet. Configure the following settings:

Name

Interface

Tagged Interface
VLAN ID

Deploy Monitor

Gateway

ARP Protection

Name of the VLAN or subnet.

The port that connects to the VLAN or subnet.
Select to enable vilan tag. Default is untagged.
The VLAN's unique integer ID.

The IP address to monitor.

The deploy monitor IP/Mask must be an IP address and not
a subnet.

You must use the following guidelines to set the network
IP/mask:
N : /, ¢ Interface name and VLAN ID must be unique among all
q network IP/masks.

- e IfVLANIDis 0, the network IP/mask must be unique
among all the network IP/masks without VLAN and all
system interfaces.

e |fVLAN is not 0, the network IP/mask must be unique
among all subnets in the same VLAN.

The gateway IP address of the deployment network.

Select to enable ARP poisoning detection. ARP Protection is disabled by
default. Upgrading FortiDeceptor will disable this setting.

Tag You can specify a tag for the VLAN or subnet.
Ref The number of objects referring to this object.
NP Each VLAN/Subnet with a network mask of /24 and higher is counted as one seat of the
‘?' VLAN license.
- Each VLAN/Subnet with a network mask less than /24 is counted as two seats of the VLAN
- license.
5. Click Save.
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Lure Resources

Use the Lure Resources page to view the current lure, upload resources such as Word and PDF files to automatically
generate lures, and import a user name list from an LDAP server.

2 Lure Resources > # B @~ admin~
+ Upload Import Users from LDAP
Action Type Tag File Name + Upload Time
Delete et P any Competitive Research.docx 2022-06-15 14:29:55 PDT
Delete Documents - Fake Content (zip) any Human Resources.zip 2022-06-15 14:43:15 PDT
50 1-20f 2items

Uploading lure resources

Upload a lure resource to automatically generate lures. There are two types of lure resource:

» Documents: Word and PDF files that generate authentic directories and files over the Decoy network shares.
» Credential: Username (with password) list files that generate authentic credentials access to the network Decoys.

To upload a lure resource:

1. Go to Deception > Lure Resources.
2. Click Upload. The Upload New Lure Resource dialog opens.
3. From the Lure Type dropdown, select the lure type.

Credential - Fake Users (txt) Upload a list file with fake users and passwords.

Documents - Template Upload files as a template. FortiDeceptor will insert content to build honey
(docx,pdf,zip) docs.

Documents - Fake Content 1. Upload Zip Word Document (.docx), PDF, Excel (.xIsx,.xIsm,.xltm,.xItx) then
(zip) upload .zip file directly to FortiDeceptor.

Credential - AWS Key (txt) Upload a list file with AWS users and passwords.
Requirements:

* Create AWS IAM users with no permissions. (Without real AWS user, the
AWS platform will not generate a log that indicates the user access.)

¢ Upload a text file with the correct AWS Region, AWS Access Key ID,
AWS Secret Access in the format below.
AWS Access Key ID:AWS Secret Access:AWS
Region:AWSusername

For more information, see Deploying AWS deception keys on page 200.
Credential — Azure Keys (txt) Upload a list file with Azure Application IDs and Tenant IDs.

Requirements:
¢ Register Azure Application to get Application ID and Tenant ID.
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Certificate — Azure Certificate
(pem,crt,cer)

¢ Upload a text file with the correct Azure Application IDs, Tenant IDs in the
format below.
Application ID:display name:Tenant ID

For example,

35739abl1-0682-783a-88b3-
722eb2ef51f1:MyAzureApplication:933b88cd-1b19-02al-
8dcf-1b2ldabc6lba

For more information, see .Deploying Azure deception keys on page 210.

Upload a certificate with private Key and certificate.
For example,

For more information, see .Deploying Azure deception keys on page 210.

Import Users from LDAP x

o

Version:

Bind DN:*

LDAP URL:*

Bind Password: *
CA Certificates:
Search Limit:
TCP Timeout:
Search Timeout:

SASL Bind User:

Tag:

SASL Bind Mechanism: |

Import user names only from the LDAP server,
for deployment step to use as lure login name in decoys.

Version 3

[protacol://Thost[:port][/basedn|?attribute,...]
[?scopel[?filter]]

firmware o
3600
3600

any

»

4

The Credential - Fake Users (txt) and Documents - Template (doc,docx,pdf,zip) options

include sample files to help you create a resource.

4. Enter an optional Tag, such as any.

5. Inthe Resource File field, click Choose a file to upload the resource, or drag and drop it onto the field.

6. Click Save.
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Importing users from LDAP

To import an LDAP user list:

1. Go to Deception > Lure Resources.
2. Click Import Users from LDAP.
3. Configure the import settings.

Version Select the version from the dropdown.

Bind DN Username used to connect to the LDAP service on the specified LDAP Server.

LDAP URL Enter the LDAP URL using the following format:
[protocol///lhost|[:port] [/basedn[?attribute, ...] [?scope]
[?filter]]

Bind Password Enter the Bind DN's password.

CA Certificates Select a certificate from the dropdown.

Search Limit Search sub-tree depth.

TCP Timeout Enter the TCP connection timeout in seconds.

Search Timeout Enter the search timeout in seconds.

SASL Bind User The username to authenticate a DN on the directory server using SASL.

SASL Bind Mechanism The username and password for authentication.

Tag Enter a tag for the import.

Scheduler Type Select One Time or Recurring

Scheduler Timezone Select the timezone.

Scheduler Start Select the scheduler start time.

Scheduler End Select the scheduler end time.

Scheduler Interval Select the Interval including Daily, Weekly or Monthly.

Days Select the day.

Time Select the time.

4. Click Save.

Examples: Import Users from LDAP

Open LDAP example:

"dn": "uid=test, o=org,dc=example,dc=com",
"url": "ldap://192.168.0.100/0=0rg,dc=example,dc=com?uid?sub? (objectclass=*)",
"password": "password"
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Windows AD example:

"version": "3",
"dn": "cn=users,cn=usergroup,dc=example,dc=com",
"url": "1dap:192.168.0.100/cn=usergroup,dc=example, dc=com?sAMAccountName?sub?

(objectClass=user)",
"password": "password"

Support is offered if the format of the tree can parse uid/sAMAccountName in the search results. Ensure the URL
queries the proper data.

Deployment Wizard

Use the Deployment Wizard to create and deploy Decoy VMs on your network. Decoy VMs appear as real endpoints to
hackers and can collect valuable information about attacks.

To deploy Decoys on the network:

1. Go to Deception > Deployment Wizard.
2. Click + Create a new decoy to add a Decoy VM.
3. Configure the following:

Name Specify the name of the deployment profile. Maximum 15 characters using
A-Z, a-z, 0-9, dash, or underscore. No duplicate profile names.

Appliance Name Destination of the Decoy VM. This can be local (manager) or remote client
(remote appliance).

This column only shows in Central Management mode on manager.

Available Deception OSes Select a Deception OS. The OS you select determines the services that are
available.

Available Deception Decoys  Select a deception decoy. This option is only available in SCADAV3/loT.
Ubuntu16v2, Ubuntu18v1, VolPv1 and Medicalv1 deception OSes. The decoy
you select determines the options in the Selected Services dropdown. See
Available Deception OSes, Decoys and Selected Services on page 74.

Selected Services Select a service based on the Deception OS. See Available Deception OSes,
Decoys and Selected Services on page 74.

Automate Lures Select one or more tag names to automate lure generation and to generate
related contents. Selecting any and all generate random content.

Click Generate Lures to automatically generate lures and list them in the
panes below.

Click Clear to delete the lures on this page.

4. If applicable, click Generate lures or Add Lure for the service and configure the lure settings. See, Lure Settings on
page 78.
5. Tolaunch the decoy VM immediately, scroll to the bottom of the page and enable Launch Immediately.

6. Toresetthe decoy VM after it detects incidents, enable Reset Decoy and specify the Reset Interval value in
seconds.
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7. Inthe HTTP/HTTPS Merge Time Window field, enter a range between 0-300 seconds. The default is 30 seconds.

activity of next HTTP request is less than the configured time, FortiDeceptor will merge the

\‘é', When the time difference between last activity of the first HTTP request and the first
3 activities into the same HTTP incident.

8. Inthe Monitor Admin Behaviors for field, enter the number of minutes to trigger the reset. Enter 0 to shutdown the
decoy immediately after admin activities are found. The decoy will re-launch in approximately 30 seconds.

L}
S L4
? Configure this option for deployments with the RDP service is enabled.

9. Click Next. The Set Network tab opens.
10. Configure the network IP and Hostname. You can enter up to two DNS IP addresses.

DNS Enter the network IP address.

You must set Domain DNS server IP to be the 1st DNS when custom Windows
decoys are in the domain(s).

DNS2 (Optional) Enter a second network IP address.
Two DNS IP addresses are not supported in t FortiGate SSLVPN decoy
deployments.

Hostname Enter the hostname for the network.

The Hostname can start with an English character or a digit, and must not end
with a hyphen. Maximum 15 characters using A-Z, a-z, 0-9, or hyphen (case-
sensitive). Other symbols, punctuation, or white space are not supported.

The Hostname cannot conflict with decoy names.

11. Click Deploy Into Network.
12. Select the Deploy Interface. Set this to the VLAN or subnet added in Deployment Network on page 67
13. Configure the following settings in the Add Interface for Decoy pane:

Addressing Mode Select Static or DHCP.
Static allows you to configure the IP address for all the decoys.

DHCP allows the decoys to receive IP address from the DHCP server. If you select
DHCRP, IP Count is automatically set to 1 and all other fields are not applicable.

Network Mask This field is set automatically.

Gateway Specify the gateway.

MAC Address OUI The first three octets of the MAC address for the device vendor. Only the xx:xx:xx
format is supported.

IP Count Specify the number of IP addresses to be assigned, up to 24 ( for both STATIC and
DHCP).

Min The minimum IP address in the IP range.
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Max The maximum IP address in the IP range.
IP Ranges Specify the IP range between Min and Max.
14. Click Done.

15. To deploy the decoys on the network, click Deploy.
16. To save this as a template in Deception > Deployment Wizard, click Template.

Al
‘9' For deception strategies and examples, see Deployment best practices checklist on page 186
- and Deception decoy best practices on page 180

Available Deception OSes, Decoys and Selected Services

The following table shows the Available Deception OSes and their corresponding Available Deception Decoys and
Selected Services in the Deployment Wizard.

The Available Deception Decoys are only available for SCADAV3/loT, Ubuntu16v2, Ubuntu18v1, VolPv1 and Medicalv1
deception OSes. The decoy you select determines the available Selected Services.

Available Decep- Available Deception Decoys Selected Services

tion OSes

centosv1 SSH, SAMBA, STMP, HTTP, HTTPS, GIT,
TCPListener. ICMP, FTP, RADIUS

fgt601v1 SSLVPN

fgt601v2 SSLVPN

crmvi ERP-WEB
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Available Decep-
tion OSes

scadav3

Available Deception Decoys

Liebert Spruce UPS

Schneider Power Meter - PM5560
MOXA NPORT 5110

Rockwell 1769-L35E Ethernet Port
GE PLC 90

Kamstrup 382

Siemens S7-200 PLC

VAV-DD BACnet controller
Niagra4 Station

Schneider EcoStruxure BMS server
Rockwell PLC

NiagaraAX Station

Rockwell 1769-L16ER/B LOGIX5316ER
Guardian-AST

Schneider SCADAPack 333E
Siemens S7-300 PLC

IPMI Device

Siemens S7-1500 PLC

Phoenix contact AXC 1050
PowerLogic ION7650

Ascent Compass MNG

C-More HMI

Modicon M241

Modicon M580

Emerson iPro by Dixell

Lantronix XPORT V1.8

Lantronix XPORT V2.0
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Selected Services

TFTP, SNMP, HTTP

SNMP, BACNET, HTTP, DNP3, ENIP
SNMP, Telnet, HTTP, MOXA

SNMP, ENIP, HTTP

SNMP, HTTP, SRTP

KAMSTRUP

HTTP, TFTP, SNMP, MODBUS, S7TCOMM
SNMP, BACNET

SNMP, HTTP, BACNET

SNMP, HTTP, TRICONEX, BACNET
HTTP, TFTP, SNMP, ENIP

SNMP, HTTP, BACNET

SNMP, ENIP, HTTP

Guardian-AST

SNMP, DNP3, Telnet

TFTP, SNMP, IEC104

HTTP, FTP, SNMP, IPMI

HTTP, TFTP, SNMP, IEC104, PROFINET
HTTP, SNMP, PROFINET, FTP

SNMP, MODBUS, DNP3, HTTP

HTTP, FTP, SNMP, IPMI, BACNET
SNMP, HTTP, FTP, HTTPS

TFTP, SNMP, MODBUS, ENIP, HTTP
TFTP, SNMP, MODBUS, ENIP, HTTP
SNMP, MODBUS, HTTP

SNMP, HTTP, Lantronix Discovery Protocol
SNMP, HTTP, Lantronix Discovery Protocol
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Available Decep- Available Deception Decoys
tion OSes
ubuntu16v2 Elastic Search
Linux Decoy
ESXI Decoy
Mac Decoy
Ubuntu16v1
Ubuntu18v1 Tomcat Decoy

MySql MariaDB Decoy

ESXI Decoy
Elastic Search

Linux Decoy

ScadaBR Decoy
Webmin Decoy

win7x64v1

Custom Windows
2016/2019/2022

Custom Windows
10/11

Custom French
Windows 2016/
French Windows 10

Custom Redhat
Linux

win10ltsc2021v1

win10v1

*outbreakv1 Spring4Shell
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Selected Services

Elastic Search

SSH, SAMBA, SMTP, TCPListener, HTTP,
HTTPS, GIT, ICMP, FTP, RADUIS, vnc

SSH, HTTP, HTTPS
SSH, vnc

SSH, SAMBA, SMTP, TCPListner, HTTP,
HTTPS, GIT, ICMP, FTP, RADIUS, vnc

HTTP, HTTPS, SSH
MariaDB, SSH
SSH, HTTP, HTTPS
Elastic Search

SSH, SAMBA, SMTP, HTTP, HTTPS, GIT,
TCPListener, ICMP, FTP, RADIUS, vnc

ScadaBR
TTP, HTTPS

RDP, SMB, SMTP, TCPListener,
NBNSSpoofSpotter

RDP, SMB, TCPListener,
NBNSSpoofSpotter, ICMP, FTP, SWIFT
Lite2

RDP, SMB, MSSQL, SMTP, TCPListener,
NBNSSpoofSpotter, ICMP, SWIFT Lite2,
FTP

RDP, SMB, MSSQL, HTTP/HTTPS, SMTP,
TCPListener, NBNSSpoofSpotter, ICMP,
SWIFT

HTTP, HTTPS, GIT, SAMBA, SSH, SMTP,
TCPListener, FTP, RADIUS

RDP, SMB, SMTP, TCPListener,
NBNSSpoofSpotter, ICMP, SWIFT Lite2,
FTP

RDP, SMB, SMTP, TCPListener,
NBNSSpoofSpotter, ICMP, SWIFT Lite2,
FTP

Spring4Shell
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Available Decep- Available Deception Decoys Selected Services
tion OSes

Spring4Shell services need time
\ 1, todownload. There may be a
‘9' delay displaying these services in
W the Deception OS and
=  Deployment Wizard pages after
the outbreakv1 OS is installed.

Log4j2 Log4j2

Log4j2 services need time to
\ 1, download. There may be a delay
‘Q' displaying these services in the
W Deception OS and Deployment
= Wizard pages after the outbreakv1

OSisinstalled.
posvi POS-WEB
iotv1 Lexmark Printer Decoy SNMP, Jetdirect, Printer-WEB
HP Printer Decoy SNMP, Jetdirect, Printer-WEB
Cisco Router Decoy Telnet, HTTP, SNMP, CDP
Brother MFC Printer SNMP, Jetdirect, Printer-WEB
TP-LINK Router Decoy TP-LInk WEB, CWMP
IP Camera Decoy IP Camera-WEB, UPnP, SNMP, RTSP
SWIFT VPN Gateway Telnet, HTTPS
HP Switch Decoy SNMP, Telnet, CDP, HTTP
medicalv1 PACS Decoy Infusion Pump (Telnet), Infusion Pump (FTP)
SPACECOM Decoy HTTP, HTTPS, FTP, CAN bus Protocol, SSH
INFUSOMAT Decoy HTTP, HTTPS, FTP, CAN bus Protocol,
B.BRAUN
sapv1 SAP ROUTER, SAP DISPATCHER, SAP
WEB
voipv MQTT WEB, CoAP, SIP, XMPP WEB

*Outbreakv1: When a cybersecurity incident/attack/event occurs that has large ramifications for the cybersecurity
industry and affects numerous organizations, FortiGuard Outbreak Alerts will be the mechanism for communicating
important information to Fortinet's customers and partners. These Outbreak Alerts will help you understand what
happened, the technical details of the attack and how organizations can protect themselves from it and others like it. The
FortiDeceptor Deception VM called Outbreakv1 provides the outbreak vulnerabilities that the FortiGuard Outbreak Alerts
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cover. For example, you can deploy a network decoy based on FortiGuard Outbreak Alerts such as Spring4Shell and
Log4j2.

fgt601v1 / fgt601v2 comparison chart

fgt601v1 fgt601v2

Support models FGT-60E, FGT-100F, FGT-1500D, FGT-60F, FGT-100F, FGT-1500D,
FGT-2000E, FGT-3700D FGT-2000E, FGT-3700D, FGT-60F-
DMZ, FGT-100F-DMZ, FGT-1500D--
DMZ, FGT-2000E-DMZ, FGT-3700D-
DMZ

Incidents reported All logins are recorded. DMZ models:
¢ Only imported LDAP user logins
are recorded as an incident. All
other events, including connection,
url, logins are dropped.
¢ Loginincident only have sslvpn
login events.
All other models are the same as
fgteé01v1.

oul E0:23:FF, 90:6C:AC, E8:1C:BA E0:23:FF, 90:6C:AC, E8:1C:BA

Lure Settings

The lure settings will vary depending on the service. The character limits and requirements in FortiDeceptor may differ
from the requirements implemented in the service.

Character restrictions and guidelines

Lure setting Service Requirements
Hostname Windows: NBNSSpoofSpotter SAP DISPATCHER Maximum of 15
characters.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-) and
underscores (_) are
supported.
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Lure setting

Client Number

Database Name

DICOM
Listening Port

DICOM Server
Name

Domain
(optional)

DSN Description

DSN Name

Service

SAP DISPATCHER

MariaDB

Medical

Medical

Windows: NBNSSpoofSpotter

Windows: ODBC lure

Windows: ODBC lure
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Requirements

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), commas
(,), hyphens (-),
underscores (_), and
spaces are supported.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-) and
underscores (_) are
supported.

Enter a value between
1-65535. Default is
4242.

Maximum of 16
characters.

Name cannot begin with
a digit.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-) and
underscores (_) are
supported.

Alphanumeric
characters (A-Z, a-z, 0-
9) and periods (.), are
supported.

Maximum of 256
characters.

Alphanumeric
characters (A-Z, a-z, 0-
9), special characters (.
_@(~)?:[+;*/") and
spaces are supported.

Maximum of 32
characters.

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), hyphens
(-), underscores (_), and
spaces are supported.
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Lure setting Service
ES Cluster Elastic Search
Name

ES Node Name Elastic Search

FTP Banner SCADAV3, Ubuntu, Centos

HTTP Listening Ubuntu, Centos, Tomcat
Port

HTTPS Listening Ubuntu, Centos, Tomcat
Port

HTTPS SSL Ubuntu, Centos
Certificate

Instance Name SAP DISPATCHER

Interval(sec) Windows: NBNSSpoofSpotter

Listening Port ERP (CRM), POS, SAP Router, SAP DISPATCHER, TP-LINK,
CWMP, ScadaBR,MariaDB, Elastic Search(HTTP)
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Requirements

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), hyphens
(-), underscores (_), and
spaces are supported.

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), hyphens
(-), underscores (_), and
spaces are supported.

Alphanumeric
characters (A-Z, a-z, 0-
9), Periods (.), hyphens
(-), underscores (_), and
spaces are supported.

Enter a value between
1-65535.
¢ Ubuntu, Centos:
Defaultis 80.
e Tomcat: Defaultis
9200.

Enter a value between
1-65535.
¢ Ubuntu, Centos:
Defaultis 443
e Tomcat: Defaultis
9200

Optional. Upload using
default settings is
supported.

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), commas
(,), hyphens (-),
underscores (_), and
spaces are supported.

Enter a value between
60-3600.

Enter a value between
1-65535.
¢ ERP (CRM), POS,
and TP-LINK:
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Lure setting

Listening Port
Over HTTPS

Location

Module type

MQTT WEB port

PACS Listening
Port

PACS System
Name

Service

SAP WEB

SCADAV3

SCADAV3

VolP

Medical

Medical

FortiDeceptor 5.2.2 Administration Guide
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Requirements

Default is 80.

¢ SAP Router:
Default is 3299

e SAP
DISPATCHER:
Defaultis 3200

¢ CWMP: Defaultis
7547

¢ ScadaBR: Default
is 9090

¢ MariaDB: Default is
3306

¢ Elastic Search
(HTTP): Default is
9200

Enter a value between
1-65535. Default is 443

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-), period
(1)1 comma (:)1
underscores (_) and
space are supported

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-),
underscores (_), and
spaces are supported.

Enter a value between
1-65535. Default is
18083.

Enter a value between
1-65535. Default is 80.

Maximum of 16
characters.

Name cannot start with
a digit.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-), and
underscores (_) are
supported.
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Lure setting Service
Page title SCADAV3
Password Windows: RDP & SMB, Ubuntu and Centos: SSH & SAMBA,

RADIUS, NBNSSpoofSpotter
French Windows:RDP, SMB, MSSQL, HTTP/HTTPS, SMTP, FTP

GIT Users, ERP (CRM), Medical, POS, FortiGate, Cisco Router
(Telnet/HTTP), HP Printer (HTTP), IP Camera (HTTP), Centos, SAP
Router, SAP WEB, Brother MFC Printer (HTTP), Lexmark Printer
(HTTP), TP-LINK

Plant SCADAV3
Identification

PLC name SCADAV3
Repository GIT Users
Name

Serial number SCADAV3

Serial number SCADAV3
for ENIP
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Requirements

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-),
underscores (_), and
spaces are supported.

Maximum of 32
characters.

Alphanumeric
characters (A-Z, a-z, 0-
9) and special
characters (-! @ #$ (~)
AN&?<>:|+;%/,."" )
are supported.

The password is
optional in GIT
repository import.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-),
underscores (_), and
spaces are supported.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-),
underscores (_), and
spaces are supported.

Maximum of 100
characters.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-) and
underscores (_) are
supported.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-),
underscores (_), and
spaces are supported.

Only 0-9 allowed
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Lure setting Service

Sharename French Windows:RDP, SMB, MSSQL, HTTP/HTTPS, SMTP, FTP
Windows:RDP & SMB, Ubuntu Centos-SSH & SAMBA
Centos

SID SAP DISPATCHER

SIP port VolP

SMTP Banner Windows, Ubuntu, Centos

SMTP Domain Windows, Ubuntu, Centos

SNMP SCADAVS3, Cisco Router (Telnet/HTTP), HP Printer (HTTP), IP
Camera (HTTP), Brother MFC Printer (HTTP), Lexmark Printer
(HTTP)

SNMP Banner SCADAV3, Ubuntu, Centos

FortiDeceptor 5.2.2 Administration Guide
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This option is only
available for SAMBA
(Ubuntu) or SMB
(Windows). Enter a
Sharename between 3-
63 characters.

Alphanumeric
characters (a-z, 0-9)
and hyphens are
supported.

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), commas
(), hyphens (-),
underscores (_), and
spaces are supported.

Enter a value between
1-65535.

TCP Default is 5060,
5061.

UDP Default is 5060.

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), hyphens
(-), underscores (_), and
spaces are supported.

Alphanumeric
characters (A-Z, a-z, 0-
9) and periods (.), and
hyphens (-) are
supported.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-) and
underscores (_) are
supported.

Alphanumeric
characters (A-Z, a-z, 0-
9), hyphens (-),
underscores (_), and
spaces are supported.
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Lure setting

SSH Banner

SSLVPN
Bookmarks
Name

SSLVPN
Bookmarks URL

SSLVPN
Listening Port

TCP Banner

TCP Listener

Telnet

Token

Service

Ubuntu, Centos

FortiGate

FortiGate

FortiGate

Windows: TCP Listener Ubuntu, Centos

Windows: TCP Listener
Ubuntu, Centos

SCADAV3

GitHub repository import
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Requirements

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), hyphens
(-), underscores (_), and
spaces are supported.

Maximum of 15
characters.

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), hyphens
(-), underscores (_), and
spaces are supported.

Required field.

Alphanumeric
characters (A-Z, a-z, 0-
9), spaces, and special
characters (-@#~7:./_=)
are supported.

Enter a value between
1-65535. Default is
10443.

Alphanumeric
characters (A-Z, a-z, 0-
9), periods (.), hyphens
(-), underscores (_), and
spaces are supported.

Separate multiple ports
with a comma (,).

Telnet username
password is the same
as ERP

Alphanumeric
characters (A-Z, a-z, 0-
9), and periods (.) are
supported.
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Lure setting

Update or
Cancel

URL

Username

Service

Windows: RDP & SMB, Ubuntu and Centos: SSH & SAMBA

GitHub repository import

LINK Windows (FTP/NBNSSpoofSpotter/RDP/SMB/SMTP), Ubunbu

and Centos (Elastic

Search/FTP/GIT/HTTP/HTTPS/MariaDB/RADIUS/SAMBA/SMTP),
CRM (ERP-WEB), FortiGate (SSLVPN), Brother MFC Printer (HTTP),
Cisco Router (HTTP/Telnet), HP Printer (HTTP), HP Switch (HTTP),
IP Camera (HTTP), Lexmark Printer (HTTP), TP-LINK Router
(HTTP), Medical (B.BRAUN/FTP/HTTP/HTTPS/Telnet), POS
(HTTP), SAP (HTTP), Schneider SCADAPack 333E (Telnet), Phoenix

contact AXC 1050 (FTP)

Ubuntu and Centos (SSH), Medical (SSH),

XMPP WEB port  VolP
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Click Update to save the
username and
password. Click Cancel
to discard the username
and password. Click
Delete to delete an
existing lure.

Required field.

Alphanumeric
characters (A-Z, a-z, 0-
9), spaces, and special
characters (-@#~?:./_=)
are supported.

Maximum of 32
characters.

Alphanumeric
characters (a-z, 0-9),
hyphens (-) and
underscores (_) are
supported.

Usernames should start
with letters or
underscores (_) and
could end with dollar
sign ($).

Maximum of 32
characters

Alphanumeric
characters (a-z, 0-9),
hyphens (-) and
underscores (_) are
supported.

Usernames should start
with letters or
underscores (_) and
could end with dollar
sign ($).

Enter a value between
1-65535.Default is
5280.
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Decoy Status

The Decoy Status page shows the status of the Decoys on your network. Use the page to start, stop or delete a decoy.
You can also view the decoy's configuration details and copy the decoy template.

We recommend operating Decoy VMs with the same status for expected behavior.

2 Decoy Status > # v @~  admin~
< Refresh

|:| Action Appliance t Status Decoy Name t MAC Network Type IP
I:‘ @ @ C239 © Stopped B119-23%w 52:94:74:74:fa:la Static 10.10.2.60
J @ @ r i C239 © Stopped B119-23%w 52:3a:33:b3:75:4b Static 10.10.2.61
D @ @ r @ C239 Q Stopped B212 52:ed:5d:ae:7d:89 DHCP 10.10.2.25
I:‘ @ G @ C239 ©Q Stopped €239-ubuntu 52:29:0d:3e:ef:98 Static 10.10.2.108

I I:‘ @ G @ C239 ©Q Stopped €239-ubuntu 52:4e:0d:8d:8d:bb Static 10.10.2.105

The Decoy Status page displays the following information:
Status The status of the decoy can be Initializing, Running, Stopped, or Cannot Start.
If the Decoy VM cannot start, hover over the VM to see the reason.
Decoy Name Name of the decoy.

Initialize Time and The decoy's initialization time and its last start time.

Start Time

(015 Operating system of the decoy.

VM The name of the Decoy VM.

IP The IP address of the Decoy VM.

Services List of services enabled. Hover over an icon to see a text list.
Network Type Shows if the IP address is Static or DHCP.

DNS DNS of the Decoy VM.

Gateway Gateway of the Decoy VM.

FortiDeceptor 5.2.2 Administration Guide
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To view the decoy configuration details:

1. Go to Deception > Decoy Status and select a decoy.
2. Inthe Action column, click View Details=. The Config Detail page opens.

Config Detail x

DETAIL

Name: win10-B193
1D: 2519859670313766147
Deception OS: win10v1

Selected Services:RDP. SMB, TCPListener, NBNSSpoofSpotter, ICMP

Launch Immediately: Yes
Reset: No
RDP

Username Password

stanley Z4Ubf5s

sherri OkBw8

taylor gX1Zn

faith KVSCd

malik v7tZ70zcU4

SMB

To copy a decoy the Deployment Wizard:

1. Go to Deception > Decoy Status and select a decoy.
2. Click Copy to Template @. The template is copied to the Deployment Wizard.

To delete Decoy VMs:

1. Go to Deception > Decoy Status and select one more decoys.
2. Inthe Action column, click Delete .
3. Click OK.

To start a Decoy VM:

1. Go to Deception > Decoy Status and select one more decoys that are stopped.
2. Inthe Action column, click Start ».

To stop a Decoy VM:

1. Go to Deception > Decoy Status and select one more decoys that are running.
2. Inthetoolbar, click Stop. The decoy status changes to Stoppeds .

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.



Deception

Deception Token

Use a FortiDeceptor token package to add breadcrumbs on real endpoints and lure an attacker to a Decoy VM. Tokens
are normally distributed within real endpoints and other IT assets on the network to maximize the deception surface.

For information about using FortiDeceptor to generate a deception lure package based on the decoy service
configuration, see Deploying tokens using AD GPO logon script on page 195.

The following token types are available:

Token type Description

SMB (hidden mapped network disk) Map the shared directory to a remote decoy that acts as file server while the
shared disk is hidden. The username and password are saved in the
Windows Vault (Credentials Manager).

SMB remote folders are Windows folders.

SAMBA (hidden mapped network Same as SMB but for Linux SAMBA shares. SAMBA remote folders are
disk) Linux folders.

RDP (Remote Desktop) The username, password and the windows Decoy IP are saved in the
Windows Vault (Credentials Manager).
Additionally, it creates RDP shortcuts in $USERPROFILES \Documents.
The file name formatis rdp  USERNAME IP.rdp and created files are
hidden.

The RDP Lure username and password are saved in Windows Vault.

SSH (Secure Shell) Create a hidden Putty shortcut in $USERPROFILE%\Documents.
If Putty (putty.exe) is not installed in the specified directory, no shortcut is
created.

Credential Cache Lure In Domain environment, add a new credentials entry to the real desktop or

Server process lsass.exe.

HoneyDocs Add fake files (Word & PDF) to Windows directories. The default is to the
most recent folder. You can specify the location in the Windows directory.

Please use the Linux decoy to deploy the HoneyDocs token campaign.

OoDBC The ODBC lure saves a DSN connection string using the Trusted
Connection mechanism.
To deploy an effective ODBC token, the following is required:

* Deploy with domain DNS and SQL SERVER service based on a
custom windows image joining a domain. See, Custom Decoy Image
on page 36 > To deploy decoys with custom images—SQL Server.

« Install ODBC lures into domain user accounts that are on the same
domain as the custom Windows server.

SAP token Add fake SAP configuration files to Windows SAP installation path that
contains decoy IP and other SAP related configuration data.

FortiDeceptor 5.2.2 Administration Guide
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Token type Description

AWS Key Add a JSON file including AWS Keys to Windows directories. You can
specify the location in the Windows directory. The default location is the
most recent folder.

Azure Key Add a JSON file including Azure Keys to Windows directories. You can
specify the location in the Windows directory. The default location is the
most recent folder. You can also specify a certificate with Azure Keys in the
same directory.

To create a FortiDeceptor token campaign:

1. Go to Deception > Deception Token > Token Campaign.
2. Click +Campaign.
3. Configure the campaign Name and Mode.

Name Enter the campaign name.

Mode ¢ Offline: The complete Deception Tokens package will be downloaded
from the FDC manager and copied to the endpoint using the external
distribution system like the A/D logon script for deployment.

¢ Online: A light Deception Tokens package will download from the FDC
manager and copied to the endpoint using the external distribution
system like the A/D logon script. The package will have the binary file and
one configuration file that points to the endpoint to download the
deception campaign from the FDC manager over a secure port.

ﬂ Use Online mode to change the campaign at any time on
I the FortiDeceptor server. Any changes you make will be

applied to the endpoint.

4. Selectthe lures. At least one lure must be selected.

NP You can only select lures with valid Static IP addresses.
‘9' The related decoys must have a status of Initialized, Stopped, Running, or Failed. We
- recommend keeping the related decoys with a status of Running for successful lure
- deployment.

5. (Optional) Click Generate API Auth Key to generate an API key.
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6. Click Save.
‘Campaign

Campaign Name: Mode: Online ¥
D Lure Type t Decoy t IP Address + IP Mode +
[ RDP w7-r12734 Static
O SMB w7-r12734 Static

20 1-2o0f 2items
It is required to select one Lure at least.
Generate APl Auth Key

Save Cancel

To view campaign list:

1. Go to Deception > Deception Token.

2. Select a campaign from the list. In the column:
 Click Edit= to edit the campaign.
» Click Delete u to delete the campaign.
» Click Download + to download the campaign.

To deploy FortiDeceptor token campaign on an existing endpoint:

1. Download FortiDeceptor token campaign package
2. Copy the downloaded FortiDeceptor token campaign package to an endpoint such as a Windows or Linux endpoint.
3. Unzip the FortiDeceptor token campaign package.
4. Inthe OS folder, follow the instructions in README .txt file to install the token package.
« Windows: Open the windows folder, and double-click the windows_token.exe to run it.
e Ubuntu: Open Terminal and run python script ./ubuntu_token.py.
In the OS folder, uninstall the token campaign package.

» By default, the new token installation process will automatically clear the lure information before installing the
new ones.

o

When the FortiDeceptor token package is installed on a real Windows or Ubuntu endpoint, it increases the deception
attack surface and lures the attacker to a Decoy VM

To review Token Deployment Status:

1. Go to Deception > Deception Token > Token Deployment Status.
2. Expand the Endpoint Name to view the Deployment Details for the endpoint.

Deployment Map

The Deployment Map is a visual representation of the entire network showing real endpoints and decoy VMs. Click a
node on the map to view its details. Use Discover & Deploy to detect the OSes for all the assets on the network and
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automatically deploy decoys for those OSes.

If you know the IP of an endpoint or partition, you can search for it with the Locate By IP box.

= Deployment Map >_ 7 fxv @v admin v
LEGEND DISCOVER AND DEPLOY
® <
Ir_l DECOY e - Q e @ O
T 1LURE e ©
" TOKEN © o O 0 0
B INCIDENT O 0o © 09 e ©
77 PARTITION lCl' o 0o e 6 0 0o 06 O
._DISCCI\."ERED i o0 0 0.0 3 e e 0
77 PROPOSED =) . e
| UNAVAILABLE = ':' 9 -O-- i i
.- P ° 0000989
LOCATE BY TP @ e N e e © 0 .9 e o
i Q o 06 09 =1
©09.:9290 8
0 0 00 2.4 2
©008 9, ®
The nodes on the map are color-coded by importance:
Node Color Description
Partition White Click the node to view the Network Partition

ID, Interface port, and subnet.

Incident Red A glowing red node indicates the decoys
have been attacked.
Click the node to view the Decoy ID, view
incidents in the Analysis page.

Decoy Pink Click to start or stop the, view its
configuration, save the decoy as a template,
or delete it.

Lure Coral Click to view the Decoy type, Service, and

data such as the username and password.
Endpoint Green Click to view the IP, MAC address, and OS.

Proposed Yellow Click a yellow node to edit its settings,
generate lures, duplicate, or delete it.

Unavailable Grey FortiDeceptor cannot retrieve data for the
asset.
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Discover & Deploy

Use Discover & Deploy to detect the OSes for all the assets on the network. After the OSes are discovered,

FortiDeceptor will attempt to create decoys to auto-fit the assets in the network.

To discover OSes and auto-deploy decoys:

1. Click Discover & Deploy. The Discovery & Deployment dialog opens.
2. Configure the discover settings.

Select Networks to Scan Select the ports on the network you want to discover.

Add Deployment Network Click to open the Add New Vian/Subnet dialog. See Deployment Network on
page 67.

Additional TCP Scan Port Enter the additional scan ports. The default scan ports are 21, 22, 23, 25, 53,

Decoys per VLAN/Subnet

69, 80, 110, 135, 137, 1378, 139, 143, 443, 445, 993, 995, 1433, 3306, 3389,
5900, 8080.

Enter the number of decoys per VLAN based on the asset discovery results.

3. Click Discover and wait a few minutes for the system to complete the discovery. The results are displayed.

OS Covered The OSes FortiDeceptor can cover with a suitable decoy for auto-deployment.
Total auto-deploy decoys The number of decoys that are suitable for auto-deployment.

Total coverage The percentage of assets that will be covered by the deployment.

Download assets list CSV Click to download the asset list as CSV file.

4. Click Accept & Deploy. FortiDeceptor deploys the decoys.

Asset Discovery

The Asset Discovery module generates Asset Inventory by passively fingerprinting the OS and other parameters for the
assets in OT/IT/IoT networks. This improves threat visibility for the networks and helps with optimizing decoy placement.

& Asset Discovery > # "% @~ admin~
(& Asset discovery setting D Export to CSV 1 Delete
\:| Action IP Address MAC Vendor Network Hostname Device OS Device Fir... Device Ty...
\:| i | 00:0c:29:88:... deploynet1 Windows 7 E... 6.1.7601
\:| o 00:0c:29:62:... deploynet1 Windows 10... 10.0.19041
\:‘ o 00:0c:29:62:... 10.11.2.0/24 Windows 10 ... 10.0.19041

The Asset Discovery page displays the following information:

Action Click Delete to remove the asset.
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IP Address The IP address of the asset.

MAC The MAC address of the asset.

Vendor The vendor identified by the asset MAC address.
Network The network this asset was discovered.
Hostname The hostname of the asset.

Device OS The Device OS of the asset.

Device Firmware The firmware version of the asset.

Device Type The type of the asset.

To enable Asset Discovery:

1. Go to Deception > Asset Discovery.

2. Click Asset discovery setting.
3. Enable the following the settings:

Passive IT Network
Discovery

Passive ICS Network

Enable to allow FortiDeceptor to identify common IT devices such as servers,
laptops, and routers by sniffing network traffic.

Select all the ports connected to the network for discovery.

Enable to allow FortiDeceptor to identify industrial control devices such as

Discovery PLC controllers.
Select all the ports connected to the network and ICS protocols for discovery.
The available protocols are, MODBUS, DNP3, ENIP, S7comm/S7comm plus,
BACNET, Profinet, FINS, ATG, Kamstrup, Moxa, IEC104, FL-net, GE-EGD,
GE-SRTP, Triconex and PCOM.
Setting
@ Pessive IT Network Discovery
port2 ]
@ Ppassive ICS Network Discovery
port3 V]
MODBUS Port
@ bnP3POrt
@ enprort
@ s7coMM part
@ BACNET Port
@ profinet Port
Cance
4. Click OK.
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To delete multiple assets at the same time:

1. Select the assets you want to delete.
2. Inthe toolbar, click Delete.

To export the asset details as a CSV file:

In the toolbar, click Export CSV.

Safe List

Use the Deception > Safe List page to add an IP address that is considered legitimate so that it does not generate an
Event or Incident when accessing decoys. For example, the IP address of a monitoring system that is polling the
network.

To add a new Safe List IP address:

1. Go to Deception > Safe List.
2. Click Add New Safe List IP and configure its settings:

IP/Mask Specify the IP address or subnet from where the connection originate.
Source Ports Specify the source ports from where the connection originates.

Destination Ports Specify the destination ports on the network where the connection terminates.
Description Specify a description. For example, you can name it as Safe_Network.
Services Select the name of the services used to connect to the network.

Status Select Enabled or Disabled.

Action Click Update or Cancel.
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Incident

The Incident module displays the incidents and attacks detected by FortiDeceptor.
This section contains information about the following topics:
« Analysis on page 95
View incidents and related events detected by FortiDeceptor
o Campaign on page 97
View attacks and related events detected by FortiDeceptor.

» Attack Map on page 99
View ongoing attacks and related events detected by FortiDeceptor.

Analysis

The Analysis page displays the list of incidents detected by FortiDeceptor. Use this page to generate the Incidents
Report PDF. The Incidents Report can be generated one at time, or you can schedule the report to generate on a
recurring basis. You can also export incidents list as a CSV file.

When you expand an incident to the view the details, the incident is marked as read. Newly-detected incidents are in
bold to indicate they are unread. To refresh the data click the Refresh button in the toolbar.

or go to System > Table Customization. For more information, see Table Customization on
page 146.

\ﬂ You can configure the table settings by clicking the gear icon # at the bottom-right of the page

The Analysis page displays the following information:

Severity Severity of the event.
Protocol Network protocol the attacker used to perform the attack.
Last Activity Date and time of the last activity.
Type Event Type Triggered By
Connection 1. Port scan (SYNConnection).

2. Ping.

3. SYN connection.

4. Access to the service with no other interaction like
accessing a web server without entering any
credentials.

Reconnaissance 1. Port scan (Full TCP Connection).

2. Access the decoy network share and browse files.
3. Access the decoy web application and browse the
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Attacker IP
Attacker User

Event Type Triggered By

web application.
4. Access decoy FTP server and browse files.

Interaction 1. The attacker accesses the decoy and passes the
log in phase.
2. Attackerlogs into a decoy and runs commands
inside the session like RDP.

Infection 1. Attacker copies files to the decoy.
2. Attacker accesses the decoy and downloads files
from the internet.
3. The attacker runs an exploit against the decoy and
injects a binary file.

Attacker IP address.

Attacker username.

Victim IP IP address of the victim.

Victim Port Port of the victim.

Decoy ID Unique ID of the Decoy VM.

ID ID of the incident.

Attacker IP Attacker IP address and domain name.
Attacker Port Port where the attack originated.

Tag Key Unique key string for the incident.

Attacker Password

Start

Password used by the attacker.

Date and time when the attack started.

x The infected files captured by the decoy are saved as a password protected .zip file you can

download. The password for the file is FortiDeceptor.

To generate the Incidents Report:

1. Goto Incidents > Analysis.
2. Inthe toolbar, click PDF Report.
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3. Configure the report settings.

Mail Address
Scheduler Type
User Timezone

Generate report for data
From

Generate report for data To
Scheduler Timezone
Scheduler Start

Scheduler End

Scheduler Interval

Days

Time

Enter the destination email for the report.
Select One Time or Recurring.
For one time reports, set the recipient's timezone.

For one time reports, select the report start date and time.

For one time reports, select the report end date and time.

For recurring reports, select the scheduled timezone.

For recurring reports, select the schedule start date and time.
For recurring reports, select the schedule end date and time.

Select Daily, Weekly, or Monthly.

For Weekly reports, select the day of the week to generate the report.

For Monthly reports, select the date to generate the report.

Select the time to generate the report for the selected day.

4. Click Generate.

To export the Incidents list a CSV file:

« In the toolbar, click Exportto CSV.

It may take some time to export the report depending on the number of incidents in the list.

Campaign

The Campaign page displays a list of attacks detected by FortiDeceptor. An attack consists of multiple incidents.

You can configure the table settings by clicking the gear icon # at the bottom-right of the page
or go to System > Table Customization. For more information, see Table Customization on
page 146.

R

The Campaign page displays the following information:

Severity Severity of the event.

Start Date and time when the attack started.
Attacker IP IP mask of the attacker.

ID ID of the campaign record.

Last Activity Date and time of the last activity.
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To view the attack details:

1. Goto Incident > Campaign.
2. Expand an attack in the list. The campaign Timeline is displayed.

iETimeline B Table < Refresh

2022-06-13 12:24:33 PDT
C3 Attacker User: N/A
= Attacker IP:

@ VictimIP:

= Event Count: 1

2022-06-13 12:24:33 PDT
C3 Attacker User: N/A
= Attacker IP:

@ VictimIP:

= Event Count: 1

3. Click table to view the attack Severity, Last Activity, Type, Attacker IP, Attacker User, Victim IP, and Victim Port.

ETimeline  EBTable < Refresh

Severity Last Activity Type Attacker IP Attacker User Victim IP
2022-06-13 12:24:33 PDT Connection N/A
2022-06-13 12:24:33 PDT Connection N/A

4. (Optional) Click Refresh to refresh the data.
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Attack Map

The Attack Map is a visual representation of the entire network showing real endpoints, Decoy VMs, and ongoing

attacks.
2 Attack Map > & @« admine
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The nodes on the map are color-coded by severity.
Node Color Description
Decoy Pink Click to view the Name, MAC address, IP,
DNS, and Gateway.
Victim Red Click to view the attack history including
Attacker, Start Time and Incident ID.
When a node is both Victim and Attacker, the
node will appear as Attacker.
Attacker Black Click to view the attacker's history including

To filter the Attack Map by IP:

Attacker, Start Time and Incident ID.

1. Under Filter Current View, click in inside Click to begin filtering. The options menu is displayed.

2. Select one of the following options:
o Attacker IP
 Victim IP
» Decoy IP

3. Enterthe IP address. FortiDeceptor sorts the nodes on the map.
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To save the current view of the map:

To filter the map by date:

Drag the red arrows at the bottom of the page to set the start and end dates.

To search for a node by IP:

In the Locate by IP box, enter the IP address.

MITRE ICS

The MITRE ICS matrix provides an overview of the tactics and techniques in the ATT&CK for the ICS Knowledge Base.
ATT&CK for ICS is a Knowledge Base used to describe an adversary's actions during an attack. The MITRE ICS page
visually aligns individual techniques under the tactics where they can be applied. Some techniques span more than one
tactic because they can be used for different purposes.

MITRE ICS is relevant to IoT/OT networks. To identify the network, you will need to tag each FortiDeceptor appliance.

To tag MITRE ICS a FortiDeceptor client with the CLI:

set tag ICS

To remove a tag from a FortiDeceptor client with the CLI:

unset tag

Viewing the MITRE ICS matrix

After the FortiDeceptor appliance is tagged, go to Incident > MITRE ICS to view the matrix. The matrix displays the
Tactics as columns and the Techniques as tiles. Management devices display a blue banner at the top of the matrix that
shows the tagged appliances in the network. Standalone devices do not display the banner. When an incident meets the
Tactic criteria, the Technique tile displays a red dot with the number of incidents.

To view the MITRE ICS incidents, click a Technique tile in the Tactics column.
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@ Dashboard >
1= Central Management > @ Aooliancels)with ICS tag enabled: Azure 23515 FDCVM ).C234(FDCVM
FDCVM' ]
@® Deception >
| [E] Incident ¥
Analysis Initial Access Execution  Persistence  Privilege Escalation Evasion
Campaign
Drive-by Compromise Change Modify Exploitation for Change
Attack Map Operating Program Privilege Escalation € Operating
Exploit Public-Facing Mode Mode
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After you click a technique, you are redirected to the Incidents > Analysis page. The Analysis page displays the incidents
that meet conditions for the technique you selected.

\y

The MITRE ICS page is only available in the FortiDeceptor appliances tagged with set tag ICS.

In the image below, the Analysis page displays the incidents that match MITRE ICS Technique: TO867.

A 61013 -

o

@ Dashboard >

i Refresh
& Central Management >
® Deception > Severity
Incident ~
Analysis 5
Campaign 14
Attack Map
MITRE ICS 2
# Fabric > 10
€ Network >
© System > B
o
1 Log > 3 N
1
13
1
10
10 »
6 »
3
6 »
6 >
6
5
6
3

Click an attack to view its details. Scroll down to the MITRE ICS Techniques field to view the techniques linked to the

PDF Report

Prot..

SMB

[ ExporttoCsv + Markallas read Show  All v MITREICS Technique: T0867
Applianc..: DecoyNa... Attacker IP Victim IP Start Attacker Password
c123 NA 2022-08-15 22:26:46 PDT s0l0123
c123 u4s51 2022-08-2413:54:29 PDT NA
c123 NA 2022-08-19 17:47:15 PDT dragon
c123 NA 2022-08-15 23:23:31 PDT photoshop
c123 u451 2022-08-2413:51:03 PDT N/A
c123 u451 2022-08-2413:03:55 PDT NA
c123 NA 2022-08-15 22:52:54 PDT batman
€123 ud51 2022-08-2413:51:10 PDT NA
AWS_FDCh... NA 2022-08-1123:18:24 PDT password
AWS_FDCh... u444 2022-08-27 20:55:25 PDT password
AWS_FDCh... u444q 2022-08-2300:18:23 PDT login1
Local B429-16ws 2022-08-26 00:32:55 PDT NA
Local 434 2022-08-23 15:34:30 PDT NA
Local B429-16ws 2022-08-25 21:55:32 PDT NA
Local BA29-16ws 2022-08-25 18:47:28 PDT NA
Local BA29-16ws 2022-08-25 17:38:07 PDT N/A
Local <434 2022-08-23 15:31:41 PDT 696969
Local BA29-16ws 2022-08-26 00:32:55 PDT N/A
Local €434 2022-08-23 15:34:30 PDT N/A

50

Attacker User

daniel

anonymous

adam

Joyce

anonymous

NA

gabriella

anonymous

sander

sander

terri

NA

N/A

NA

NA

NA

lance

NA

Last Activity

2022-08-1522:31:29 PDT

2022-08-2413:59:09 PDT

2022-08-19 17:47:39 PDT

2022-08-15 23:26:18 PDT

2022-08-2413:55:44 PDT

2022-08-2413:08:33 PDT

2022-08-15 22:58:52 PDT

2022-08-2413:55:44 PDT

2022-08-1123:23:23 PDT

2022-08-27 21:00:14 PDT

2022-08-23 00:23:16 PDT

2022-08-26.00:38:27 PDT

2022-08-23 15:39:07 PDT

2022-08-25 22:01:56 PDT

2022-08-25 18:53:03 PDT

2022-08-25 17:44:30 PDT

2022-08-23 15:36:27 PDT

2022-08-26 00:38:27 PDT

2022-08-23 15:39:06 PDT

attack. Click a TXXX link to view a description of technique in the ATT&CK for the ICS Knowledge Base.
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Type

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Interaction

Attacke
48332
1183
51574
46078
1421
1165
56616
5491
40968
35228
57298
5752
54200
10625
1284
3678
54071
5751

54199 -
>

1-500f103items &
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@ Dashboard >
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Campaign
Attack Map
MITRE ICS imeline B8 Table & Refresh
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>
" R o @D Appliance: Local
4 {og
,Ei Attacker User:
”-',?AttacksrlP:
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<. Download lures
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Use the Fabric pages to manage and configure FortiGate information for integration with FortiDeceptor. This includes
blocking settings and Security Fabric status information. Blocking from FortiGate is an API call from FortiDeceptor which
allows instant quarantine from FortiGate once an incident is detected. The quarantined IP is under user quarantine in the
FortiGate GUI.

This section includes the following topics:

o Detection Devices on page 103
Configure the third-party malware detection devices for FortiDeceptor integration.

o Quarantine Integration on page 105

Configure the quarantine devices for FortiDeceptor integration.
o Quarantine Status on page 117

Status of blocked IP addresses.
e |OC Export on page 118

Export the I0C file in CSV format for a specified time period.

Detection Devices

The Detection Devices page allows you to configure integrations with FortiSandbox, Cuckoo Sandbox, and Virus Total
devices.

FortiSandbox

The integration between FortiDeceptor and FortiSandbox will provide a complete static and dynamic analysis against
malicious code captured by the network decoys. The malware analysis report will be available on the FortiDeceptor
admin console.

To configure integration with FortiSandbox:

1. Goto Fabric > Detection Devices.
2. Enable FortiSandbox.
3. Configure the following parameters:

Type Select Appliance or Cloud.

IP/URL Type the FortiSandbox appliance or cloud IP address or URL

Port Type the FortiSandbox API port. Default is 443.

Username Type the APl username for the FortiDeceptor appliance. You can configure the
FortiDeceptor 5.2.2 Administration Guide 103
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4,
5.

APl username in FortiSandbox.

Password Type the API password for the FortiDeceptor appliance. You can configure the
API password in FortiSandbox.

Token Access Type the Token for FortiSandbox Cloud. You can find this in FortiSandbox
Cloud CLI with the following command: 1ogin-token

User ID Type the FortiSandbox Cloud User ID.

Click the Test button to ensure the API connection is working properly.
Click Save to store the configuration

Cuckoo Sandbox

The integration between FortiDeceptor and Cuckoo Sandbox will provide a complete static and dynamic analysis against
malicious code captured by the network decoys. The malware analysis report will be available on the FortiDeceptor
admin console.

To configure integration with Cuckoo Sandbox:

1. Go to Fabric > Detection Devices.
2. Enable Cuckoo Sandbox .
3. Configure the following parameters:
Name The Fabric connector name
IP/URL Type the Cuckoo Sandbox IP address or URL
Port Type the Cuckoo SandboxAPI port. (default is 1337)
API Token Type the API Token located in the Cuckoo Sandbox's configuration file.
4. Click on the Test button to ensure the API connection is working properly.
5. Click Save to store the configuration
Virus Total

The integration between FortiDeceptor and the well-known Virus Total service allows the submission of suspicious files
(MD5) for malware analysis. When integrated, Virus Total detection ratios will be displayed in the incident analysis alert
Workflow for relevant events.

Virus Total engages with multiple service providers to perform the same file inspection. Some service providers return a
score of 0, meaning it is not malware, whereas other providers return a score of 7, meaning it is malware. Virus Total
then returns a ratio such as 15/36 that indicates 75 out of 36 service providers determined the file is malware.

To configure integration with VirusTotal:

1.
2,

Join the VirusTotal Community.
In your personal settings section find your personal API key in your personal settings section.

3. Goto Fabric > Detection Devices.

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.

104


https://www.virustotal.com/gui/join-us

Fabric

4. Enable VirusTotal.
5. In VT API Key field enter the your Virus Total personal API key.
6. Click Save.

Quarantine Integration

FortiDeceptor on FortiGate Security Fabric topology map

Security Fabric integration allows FortiDeceptor and deception decoys to be visible through the Fabric network topology
map.

To configure Security Fabric integration, enter the upstream device IP in Port in FortiDeceptor. Next you will add the
FortiDeceptor fabric connector in FortiGate.

To configure FortiGate for Security Fabric integration in FortiDeceptor:

1. InFortiDeceptor, go to Fabric > Quarantine Integration.
2. Under Fabric Upstream section, select Enabled.

< Quarantine Integration

Fabric Upstream

Enabled:

Upstream IP Address: Port: :

Quarantine Via Upstream:

3. Enter the FortiGate IP address in Upstream IP Address and the FortiGate connector port in Port.

Fabric Upstream

Enabled: ()
Upstream IP Address: | ‘ Port: 8013

Quarantine Via Upstream: ()

Quarantine severty: N I T I
Quarantine Expiry: seconds

Apply Cancel
+ Quarantine Integration With New Device

Action Enabled Status Name Integrate Method + Severity Detail

To add the FortiDeceptor fabric connector in FortiGate:

1. InFortiGate, log in as an admin and go to Security Fabric > Fabric Connectors.

2. Add the FortiDeceptor connector for this integration. For information, see Configuring other Security Fabric devices
> FortiDeceptor in the FortiGate Administration Guide.
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Fabric

# Edit | @ Delete

Security Fabric Setup FortiAnalyzer Logging
fabric_setup 172.16.69.65 o

Cloud Sandbox

Cloud Logging
Disabled Disabled

Fabric Connectors

IP Address Management (IPAM) FortiClient EMS Cloud

Disabled Disabled

FortiClient EMS

Disabled

Fortinet Products

E

FortiSandbox FortiManager

E ATINET | Disabled J Disabled

When configuring the Fabric Connector in FortiGate, you must enable Allow downstream device REST API.

Core Network Security

Security Fabric
Setup

Security Fabric Settings

Status AJSEER © Disabled
Security Fabric role REEELE L lal Join Existing Fabric

Fabric name fabric_setup
Allow other Security Fabric devices to join © M portl %
M port2 x
® port4 x
2 registration x
+
Device authorization 10 Connected /28 Total  # Edit
Allow downstream device REST APl access @ @© |
Administrator profile @ super_admin -
Fabric synchronization @O
SAML Single Sign-On @© (& Advanced Options
Mode Identity Provider (IdP)
IdP certificate Fortinet_Factory -
& Download
Management IP/FQDN € Use WAN IP
172.16.69.66
Management port Use Admin Port
443 o
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FortiDeceptor supports the CSF protocol that triggers automatic mitigation-isolation of the infected endpoint from
the network and prevents the attack from moving laterally.

The CSF integration provides access to more fabric devices for isolation like FortiSwitch through the FortiGate.
SAML support between FortiGate WEB-UI to FortiDeceptor to allows SSO login from FortiGate to FortiDeceptor.

Cooperative Security Fabric (CSF), also known as a Fortinet Security Fabric, spans across

an entire network linking different security sensors and tools together to collect,
x coordinate, and respond to malicious behavior in real time. CSF can be used to coordinate

the behavior of different Fortinet products in your network, including FortiGate,
FortiAnalyzer, FortiClient, FortiSandbox, FortiAP, FortiSwitch, and FortiClient Enterprise
Management Server (EMS).

3. To trigger automatic mitigation using the CSF:

a. InFortiGate, login as an admin and go to Security Fabric > Automation.
b. Click Trigger > Create New.
c. Configure the Fabric Connector Event:

Enter the Name of the event.

Enter a Description of the event.

Select a FDC appliance from the connector menu.
Select an event.

Select the Event Severity.

Click OK.

Create New Automation Trigger
€ | Fabric Connector Event A specified Fabric Connector's event has occurred.

Mame FDC
Description | FDC Mitigation

Fabric Connector Event
Connector FDCVM-LAB
Event name

Event severity O

Insider Threat

4. Inthe same screen, go to Action > Create New and choose any mitigation response you would like to execute once
the FortiDeceptor pushes an incident alert to FortiGate.
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e DB MF® B

Access Layer Quarantine

Quarantine the MAC address on access layer
devices (FortiSwitch and FortiAP).
e

FortiClient Quarantine

Use FortiClient EMS to quarantine the
endpoint device.

X Security Fabric

Ph I To

FortiNAC Quarantine

Use FortiNAC to quarantine the endpoint

device. &'
Automation

VMware NSX Security Tag

Assign a specified security tag to a VMware
endpoint device. ('

IP Ban

Ban the IP address specified in the
automation trigger event.

Notifications

Email
Send a custom email to the specified
recipient(s).
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In FortiGate, go top Dashboard > Status to view FortiDeceptor information and deception decoys configuration
status.
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|

FortiDeceptor integration for threat response mitigation

Use Fabric > Quarantine Integration to view and configure FortiGate and other device settings for integration with
FortiDeceptor. Integration uses REST APIs, XML APIs, or webhooks. When decoys are accessed, FortiDeceptor makes
quarantine calls and attackers are immediately quarantined on the device for further analysis.

The following information is displayed:

Action

Enabled
Status

Name

Integrate Method

Click Edit to edit the integration settings.
Click Delete to delete the device.

Shows if the device is enabled or disabled.

Device status.

Alias of the integrated device.

FortiDeceptor 5.2.2 Administration Guide
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A/D Connector Isolation
Aruba ClearPass
CheckPoint-FW-Isolation
Cisco-ISE
CrowdStrike-Isolation
FGT-REST-API
FGT-WEBHOOK
FNAC-WEBHOOK
FortEDR-Isolation
FSM-Watch-List
GEN-WEBHOOK

IR Collector (see, Integrate Windows IR collector on page 318)
Microsoft-ATP
PAN-XMLAPI

SentinelOne Isolation
Windows Network Isolation
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Severity Security level. The selected level and all levels above it are blocked. For example,
if you select Medium, then when any attack reaches medium, high, or critical
levels, the attacker IP address is blocked. If you select Critical, then only the
critical level is blocked.

Detail Device integration details.

To integrate a device:

1. Go to Fabric > Integration Devices.
2. Click Quarantine Integration With New Device.
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3. Configure the device for integration. Then click Save.

Enabled
Name

Block Severity

Appliance

Integrate Method

IP or Device IP

Port

Username and Password
VDOM

Verify SSL

Expiry

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.

Enable or disable this device.
Specify a name for this device.

The selected level and all levels above it are blocked. For example, if you
select Medium, then when any attack reaches medium, high, or critical levels,
the attacker IP address is blocked. If you select Critical, then only the critical
level is blocked.

Option for Central Management manager device to integrate the incidents
from the specified appliances only.

The integration method of this device:
¢ FGT-REST-API (Default)

¢ FGT-WEBHOOK

¢ PAN-XMLAPI

¢ GEN-WEBHOOK

¢ FNAC-WEBHOOK

¢ Windows Network Isolation

¢ FortEDR-Isolation

e Cisco-ISE

¢ Microsoft-ATP

¢ CrowdStrike-Isolation
¢ FSM-Watch-List

Different integration methods have different settings. To view the settings for
each integration type, see Integrate Method settings on page 112

IP address of the integrated device.

Port number of the integrated device API service. Default is 8443.
Username and password of the integrated device.

For FortiGate devices, the default access VDOM.

Enable to verify SSL.

Default blocking time in second. Default is 3600 seconds.
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Integrate With New Device X

Enabled: [ @

Name: * |fgth|ncker6 ‘

Block Severity: | ow | Medium | __High | Critical ]
Integrate Method: FGT-REST-API =

@ Compatible FortiGate version: 6.0.4 or later

Pz [Ip \
Port:* |443 ‘
Username: * |Useman’e ‘
Password: |Passwmrd ‘
Vdom: * |ront ‘
Expiry:* |3600 ‘seconds

Save Cancel
Integrate Method settings
A/D Connector Isolation
Hostname IP address or Hostname of the Active Directory (AD) server.
Port Port number used for connecting to the AD server.
Username Valid AD service account with a minimum of account operators access.
Password Password for your AD user.
Base DN The base, or node from where the search should start.

All connector operations are carried out using the Base DN as a root to the AD
organization tree. You can restrict the AD lookup by providing appropriate filters in
this parameter.

Some examples are as follows:
DC=fdc, DC=com
OU=workstation, DC=fdc, DC=com

OU=Finance, OU=workstation, DC=fdc, DC=com

Bind DN The fully distinguished name, which is used to bind to the AD server.
Use TLS Specifies whether SSL and TLS. SSL is used by default.
Limit The number of quarantine attackers per 24 hours.

Aruba ClearPass

Server URL The Aruba ClearPass URL or IP address.
Client ID Client ID of the Aruba ClearPass application which is used to access Aruba
ClearPass.
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Auth Type
Username
Password
Client Secret

Verify SSL

Expiry

AWS Keys

AWS Region

AWS Access Key ID
AWS Secret Access Key
Verify SSL

Azure Keys

Select Username/Password or Client Secret.

If the Auth Type is Username/Password, enter the Aruba ClearPass username.

If the Auth Type is Username/Password, enter the Aruba ClearPass password.

If the Auth Type is Client Secret, enter the Aruba ClearPass client secret.
Enable to verify Secure Sockets Layer.

Default blocking time in seconds. Default is 3600 seconds

AWS region to access the AWS CloudTrail.
ID of the AWS Access Key to access AWS services.
Key of the AWS Secret Access to access AWS services.

Specifies whether the SSL certificate for the server is to be verified or not. By
default, this option is set as True.

Client ID Also called Application ID;Unique ID of the Azure Active Directory application.

Client Client Secret of the Azure Active Directory application that is used to create an authentication token
Secret required to access the API.

Tenant ID Tenant ID provided for your Azure Active Directory.

Verify Specifies whether the SSL certificate for the server is to be verified or not. By default, this option is set as

SSL True.

CheckPoint-FW-Isolation

Compatible CheckPoint version: R81 build392 or later

IP/URL
Port

IP Block Policy(Network
Group Name)

Username
Password
Verify SSL
Install Policy After Publish

Cisco-ISE

IP address or URL of the integrated device.
Port number of the integrated device API service. Default is 443.

Enter the Network Group Name.

Username of the integrated device.
Password of the integrated device.
Enable to verify Secure Sockets Layer.

Enable to install the policy after it is published.

Compatible Cisco ISE version: 2.7 or later.
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Server URL/IP
Port
Username
Password

Verify SSL

Expiry

CrowdStrike-Isolation

Server URL
Client ID

Client Secret

Verify SSL

Expiry

FGT-REST-API

The Cisco server URL and IP address.

Port number of the integrated device API service. Default is 8443.
Username of the integrated device.

Password of the integrated device.

Enable to verify SSL.

Default blocking time in seconds. Default is 3600 seconds.

CrowdStrike server URL.

Client ID of the Crowdstrike application which is used to access CrowdStrike
isolation service.

Secret string of the Crowdstrike application which is used to access CrowdStrike
isolation service.

Enable to verify SSL.

Default blocking time in seconds. Default is 3600 seconds.

Compatible FortiGate version: 6.0.4 or later

IP

Port
Username
Password

VDOM

Expiry

FGT-WEBHOOK

IP address of the integrated device.

Port number of the integrated device API service. Default is 8443.
Username of the integrated device.

Password of the integrated device.

For FortiGate devices, the default access VDOM.

Default blocking time in second. Default is 3600 seconds.

Compatible FortiGate version: 6.4.0 or later

Block Action Expiry Default blocking time in seconds.
Default is 3600 seconds.
URL Enter the request APl URI.
Authorization Enter the APl key.
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Unblock Action

FNAC-WEBHOOK

Expiry Default blocking time in seconds.
Default is 3600 seconds.

URL Enter the request APl URI.

Authorization Enter the API key.

Compatible FortiNAC version: 8.8.2.1714 or later.

IP:
Port:

Authorization Token:

Expiry:

FortiEDR-Isolation

IP address of the integrated device.

Port number of the integrated device API service. Default is 8443.

The FortiNAC-WEBHOOK authorization token generated by FNAC.

Default blocking time in seconds. Default is 3600 seconds.

Compatible FortiEDR version: 5.0.2.305 or later.

IP
Port
Organization\Username

Password

Expiry

FSM-Watch-List

IP

Port

Username:

Password:

Organization

Verify SSL

Watch-List Name

Lure Users-Manual Mode

Polling Time Interval

GEN-WEBHOOK

IP address of the integrated device.

Port number of the integrated device API service. Default is 8443.

The FortiEDR organization and username.
Password of the integrated device.

Default blocking time in seconds. Default is 3600 seconds.

IP address of the integrated device.

Port number of the integrated device API service. Default is 8443.

Username of the integrated device.

Password of the integrated device.

Type the organization name for the integration device.
Enable to verify SSL.

Type Watch-List Name as defined in FortiSIEM.

Type the other lures you want to watch.

Default polling time in seconds. Default is 3600 seconds.

Compatible FortiNAC version: 8.8 or later (Firmware: 8.8.2.1714)
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Block Action:

Unblock Action:

IR Collector

Domain
Username
Password

Limit

Microsoft-ATP

Server URL

Client ID

Client Secret

Tenant ID
Verify SSL

Expiry

PAN-XMLAPI

Expiry Default blocking time in seconds.
Default is 3600 seconds.

Http Method Select GET, POST, PUT, or PATCH

URL Enter the request APl URI.

Authorization Enter the API key.

HTTP Header Select Empty, Hacker-IP, Hacker-MAC,
or Expiry-Time.

HTTP Data Select Empty, Hacker-IP, Hacker-MAC,
or Expiry-Time.

Http Method Select GET, POST, PUT, or PATCH

URL Enter the request APl URI.

Authorization Enter the APl key.

HTTP Header Select Empty, Hacker-IP, Hacker-MAC,
or Expiry-Time.

HTTP Data Select Empty, Hacker-IP, Hacker-MAC,
or Expiry-Time.

The device domain.
Username of the integrated device.
Password of the integrated device.

The number of collections per endpoint per 24 hour.

Service base URI to connect and perform the automated operations. For
example, https://api.securitycenter.microsoft.com.

Client ID of the Azure application that is used to access Windows Defender ATP

Secret string that the application (used to access Windows Defender ATP) uses
to prove its identity

Tenant ID of the Azure application
Enable to verify SSL.

Default blocking time in seconds. Default is 3600 seconds.

Compatible PAN-device version: 10.0.0 or later
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Device IP
Port
Username
Password
Vsys

Policy Index

Expiry
SentinelOne Isolation

Server URL
API Token
API Version
Verify SSL

Expiry
Windows Network Isolation

Domain
Username

Password

Quarantine Status

The Fabric > Quarantine Status page displays the status of blocked and quarantined IP addresses. It also lets you

IP address of the integrated device.

Port number of the integrated device API service. Default is 8443.

Username of the integrated device.

Password of the integrated device.

The virtual system which is configured on PAN
Select Top or Bottom.

Default blocking time in seconds. Default is 3600 seconds.

SentinelOne server URL.

The SentinelOne authorization token.
The version of the SentinelOne token.
Enable to verify SSL.

Default blocking time in seconds. Default is 3600 seconds.

The device domain.
Username of the integrated device.

Password of the integrated device.

manually block or unblock devices. The following options are available:

Refresh
Block
Unblock

Refresh the page to get the latest data.

Manually send a blocking request for the selected attacker IP addresses.

Manually send an unblocking request for the selected attack IP addresses.

The following information is displayed:

Attacker IP
Start
End

IP addresses of blocked attacker.
Start time of blocking behavior.

End time of blocking behavior.
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Type

Integrated Device

Time Remaining
Status

Message

IOC Export

Blocking type, manual, or automatic quarantine.

Alias of the device which blocks the Attacker IP address. This is the Name field in
Fabric > Integration Devices.

The remaining blocking time.
Current status of the attacker.

Additional message for the quarantine operation.

The I0C Export page allows you to export the I0C file in CSV or STIX format for a specified time period. The CSV file

can be processed by third party Threat Intelligence Platforms. The file contains the TimeStamp, Incident ID, Attacker IP,

related files, and WCF (Web Content Filtering) events. You can include MD5 checksums, WCF category, and

reconnaissance alerts.

2 10C Export . # v @~ admn~
10C Export
From™ [ C]
To* B ®
Include File MD5
Include WCF Category
Exclude Reconnaissance Alerts
C' Reset & Export as C5V £ Export as STIX
STIX/TAXII Integration
C e

To export the IOC as a CSV file:

1. Goto Fabric > 10C Export.

2. Specify the date range by setting the date and time in the From and To fields.

3. (Optional) Include or exclude the following files and alerts:
* Include File MD5
 Include WCF Category
e Exclude Reconnaissance Alerts

4. Click Export as CSV

To Push the I0C over STIX/TAXII server

1. Goto Fabric > 10C Export.

2. Specify the date range by setting the date and time in the From and To fields.
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3. Enable STIX/TAXII Integration.
4. Configure the export settings:

API Root URL Enter the API Root URL.

TAXIl Username Enter the TAXIl username.

TAXIlI Password Enter the TAXII password.

Collection ID Enter the Collection ID.

Certificate File Click Upload a certificate file to upload the certificate file.
Key File Click to upload the API key file.

Certificate/Key Verification Enable Certificate/Key Verification.

Include File MD5 Enable to include the MD5 file.
Include WCF Category Enable to include the WCF category.
Include IPS Category Enable to include the IPS category.

@  STIX/TAXI Integration

APIRoot URL™

This field cannot be empty.

TAXII Username *
This field cannaot be empty.

TAXII Password *

This field cannot be empty.
Collection ID*

This field cannaot be empty.
Certificate File Lu pload a certificate file
Key File A Upload a key file

Certificate/Key Verification

Include File MD5

Include WCF Category

Include IPS Category

5. Click Export as STIX to push the export over the protocol in real time.
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Network

The Network page provides interface, DNS, and routing management options.

This section includes the following topics:

 Interfaces
o System DNS
o System Routing

Interfaces

To view and manage interfaces, go to Network > Interfaces. All of the columns in the table are searchable and support

custom filters.

This page displays the following information and options:

Interface

port1
(administration
port)

port2
port3
port4
port5/port6é
port7/port8
IPv4
IPv6

Interface Status

Link Status

Access Rights

The interface name and description.
Failover IP is listed under this field with the descriptor: (cluster external port).

Port1 is hard-coded as the administration interface. You can enable or disable
HTTP, SSH, and Telnet access rights on port1. HTTPS is enabled by default and
cannot be disabled. You can use port1 for Device mode although a different,
dedicated port is recommended.

Decoy VM deployment.
Decoy VM deployment.
Decoy VM deployment.
Decoy VM deployment.
Decoy VM deployment.
The IPv4 IP address and subnet mask of the interface.
The IPv6 IP address and subnet mask of the interface.

The state of the interface:
* Interface up
* Interface down
* Interface is being used by sniffer

The link status:
e Linkup
e Link down

The access rights associated with the interface. HTTPS is enabled by default on
port1. You can enable HTTP, SSH, and Telnet access on port1.
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Edit Select the interface and click Edit in the toolbar to edit the interface.

To filter the columns in the table:

1. Click the plus sign in the Search field. The Filterable Columns menu opens.
L+

2. Selecta columnin the list to Resize to Contents, Group By This column or create a custom filter.
3. Click Apply.

To show or hide columns in the table:

1. Hover the header row until the Configure Table icon appears.

2. Click Configure Table. The Best Fit Columns menu opens.
3. Select the columns to appear in the table and click Apply.
4. To restore the default table, click Reset Table.

To edit an interface:

Select the IPv4 or IPv6 address of an interface name and click Edit in the toolbar.
Edit the IP Address / Netmask. The Confirmation dialog opens.

(Optional) Change the Interface Status.

In the IP Address / Netmask pane, update the IPv4 and IPv6 address.

Click OK.

o oN-=

To edit administrative access:

—

Select port1 (administration port) and click Edit in the toolbar.

Edit the Access Rights.

HTTPS is enabled by default. You can also enable HTTP, SSH, and Telnet support.
3. Ifnecessary, edit the IP Address / Netmask.

Click OK.

g

>

System DNS

You can configure the primary and secondary DNS server addresses in Network > System DNS.

DNS Configuration

Primary DNS Server: ‘ ‘

Secondary DNS Server: ‘ ‘
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To configure the System DNS:

1. Go to Network > System DNS.

2. Inthe Primary DNS Server and Secondary DNS Server fields, enter the address of the primary and secondary
servers.

System Routing

Use the Network > System Routing page to manage static routes of your FortiDeceptor device. All of the columns in the
table are searchable and support custom filters.

The following options are available:

Create New Create a new static route.
Edit Edit the selected static route.
Delete Delete the selected static route.

The following information is displayed:

IP/Mask IP address and subnet mask.
Gateway Gateway IP address.
Device The interface associated with the static route.

To create a new static route:

1. Click Create New.
2. Enterthe Destination IP address, Mask, and Gateway.

\y
‘9' You can enter the Destination IP/Mask in the format 192.168.1.2/255.255.255.0,
- 192.168.1.2/24,0rfe80:0:0:0:0:0:c0a8:1fe.

3. Selecta Device (or interface).
4. Click OK.

To edit a static route:

Select a Static Route

Click Edit.

Edit the destination IP address and mask, gateway, and device (or interface) as required.
Click OK to apply the edits to the static route.

P obh-=

FortiDeceptor 5.2.2 Administration Guide 122
Fortinet Inc.



Network

To delete a static route or routes:

1. Select one or more Static Routes.
2. Click Delete.
3. Confirm the deletion.

To filter the columns in the table:

1. Click the plus sign in the Search field. The Filterable Columns menu opens.
L+
2. Selecta columnin the list to Resize to Contents, Group By This column or create a custom filter.

3. Click Apply.

To show or hide columns in the table:

1. Hover the header row until the Configure Table icon appears.

2. Click Configure Table. The Best Fit Columns menu opens.
3. Select the columns to appear in the table and click Apply.
4. To restore the default table, click Reset Table.
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Use the System pages to manage and configure the basic system options for FortiDeceptor. This includes administrator
configuration, mail server settings, and maintenance information.

This section includes the following topics:

Administrators
Admin Profile
Certificates
LDAP Servers
RADIUS Servers
Mail Server
SNMP
FortiGuard

FDC License
Settings

Login Disclaimer

Table Customization

Administrators

Configure administrator user accounts.

Configure admin profiles to define admin privileges.
Configure CA certificates.

Configure LDAP servers.

Configure RADIUS servers.

Configure the mail server.

Configure SNMP.

Configure FortiGuard settings and upgradeable packages.
Upload license files and input confirmation ID.

Configure the idle timeout or reset all widgets to their default state.
Configure the Login Disclaimer.

Define columns and order of Incident and Event tables.

Use the System > Administrators page to configure administrator user accounts.

If the admin user's Admin Profile does not have Read Write privilege under System > Admin Profiles, the user can only
view and edit their own information.

The following options are available:

Create New
Edit
Delete

Test Login

Create a new administrator account.
Edit the selected entry.
Delete the selected entry.

Test the selected user's login settings. If an error occurs, a debug message appears.

The following information is displayed:

Name

The administrator account name.

FortiDeceptor 5.2.2 Administration Guide 124

Fortinet Inc.



System

Type The administrator type:

» Local: Userinformation is stored in the FortiDeceptor local database and
authenticated locally by FortiDeceptor.

e LDAP: User information is stored in the remote LDAP server. A copy of the
username is stored in the FortiDeceptor local database (without password and
other information), and is authenticated remotely by the LDAP server. See, LDAP
Servers on page 131.

* RADIUS: User information is stored in the remote RADIUS server. A copy of the
username is stored in the FortiDeceptor local database (without password and
other information), and is authenticated remotely by the RADIUS server. See,
RADIUS Servers on page 132.

NOTE: For Single Sign-On (SSO), user information is stored in a remote Identity
Provider (IdP) server. No user information is stored locally. Instead, FortiDeceptor acts
as a Service Provider (SP). When a login request is received, FortiDeceptor redirects
the request via SAML protocol to the IdP to complete the authentication. See Single
Sign-On on page 133.

Profile The Admin Profile the user belongs to.

To create a new user:

1. Log in using an account with Read/Write access and go to System > Administrators.
2. Click Create New.
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3. Configure the following:

Administrator

Password, Confirm
Password

Type
LDAP Server

RADIUS Server

Regular Admin

Push notification to mobile if
applicable

Admin Profile

Trusted Host 1, Trusted Host
2, Trusted Host 3

Trusted IPv6 Host 1, Trusted
IPv6 Host 2, Trusted IPv6

Name of the administrator account. The name must be 1 to 30 characters
using upper-case letters, lower-case letters, numbers, or the underscore
character (_) for Local and LDAP administrators.

The character limit for RADIUS server administrators is 64 characters.

Password of the account. The password must be 6 to 64 characters using
upper-case letters, lower-case letters, numbers, or special characters.

This field is available when Type is set to Local.
Select Regular Admin, Local, LDAP, or RADIUS.

When Type is LDAP, select an LDAP Server. For more information, see LDAP
Servers on page 131.

When Type is RADIUS, select a RADIUS Server. For more information, see
RADIUS Servers.

When Type is Regular Admin, the user will have almost all the same privileges
of a Super admin, but cannot see or can change the Super Admin user profile.

Only Super Admin and Regular Admin accounts can choose the Regular
Admin type to create a new Regular Admin.

When a Regular Admin logs in, they will not see the Super User account.
Regular Admins can see and edit all other users. Regular Admins have access
to the same Menu items and CLI Commands settings as a Super Admin.

Enable FortiToken push notifications for mobile devices.
This option is available when Type is RADIUS.

Select the Admin Profile.

Enter up to three IPv4 trusted hosts. Only users from trusted hosts can access
FortiDeceptor.

Enter up to three IPv6 trusted hosts. Only users from trusted hosts can access
FortiDeceptor.

Host 3
Comments Enter an optional comment.
Setting trusted hosts for administrators limits the computers an administrator can use to
ﬂ log into FortiDeceptor. When you identify a trusted host, FortiDeceptor only accepts the
I administrator’s login from the configured IP address or subnet. Attempts to log in with the
same credentials from another IP address or subnet are dropped.
4. Click OK.

To edit a user account:

1. Log in using an account with Read/Write access and go to System > Administrators.

2. Select and account and click Edit.

Only the admin user can edit its own settings.

You must enter the old password before you can set a new password.
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3. Edit the account and click OK.

To delete one or more user accounts:

1. Log in using an account with Read/Write access and go to System > Administrators.
2. Select the user account you want to delete.
3. Click Delete and confirm that you want to delete the user.

To test LDAP or RADIUS logins:

Log in using an account with Read/Write access and go to System > Administrators.
Select an LDAP or RADIUS user to test.

Click Test Login.

Enter the user password.

Click OK.

If an error occurs, a debug message appears.

o ODd-=

\ L}
‘?' When a remote RADIUS server is configured for two-factor authentication, RADIUS users

must enter a FortiToken code or the code from email/SMS to complete login or to test login.

Admin Profiles

Use administrator profiles to control administrator access privileges to system features. When you create an
administrator account, you assign a profile to the account.

You cannot modify or delete the following predefined administrator profiles:

o Read Write has access to all functionality. This includes creating, editing, and deleting administrator profiles
* Read only has read-only access.

The Menu Access section has the following settings:

None User cannot view or make changes to that page.

Read Only User can view but not make any change to that page, except session-related user settings
such as Table Customization, Dashboard, or Attack Map filter.

Read Write User can view and make changes to that page.
Super Admin User cannot view or make changes to that page.
Regular Admin User cannot view or make changes to that page.

The CLI Commands section has the following settings:

None User cannot execute CLI commands.
Execute User can execute CLI commands.
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To create an Administrator Profile:

Go to System > Admin Profiles.
Select the Profile Name.

Click Create New.

Specify the Profile Name.

If you wish, add a Comment.

o gk wbh-=

Specify the privileges for Menu Access:

Dashboard Dashboard

Central Management Appliances

Deception o

Incident .

Fabric o

Network .

System .

FortiDeceptor 5.2.2 Administration Guide
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Custom Decoy Image

Deception OS

Deployment Network

Deployment Wizard
Decoy Status
Deployment Map
Asset Discovery
Safe List

Lure Resources

Deception Token

Analysis
Campaign
Attack Map

Integration Devices
Quarantine Status
10C Export
Detection Devices

Interfaces
System DNS
System Routing

Administrators
Admin Profiles
Certificates
LDAP Servers
RADIUS Servers
Mail Server
SNMP

Login Disclaimer
FortiGuard

FDC License
System Settings
Table Customization
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Log * All Events
» Log Servers
REST API e Decoy

e Attack

7. Specify the privileges for CLI Commands:

Configuration e Set
¢ Unset
System ¢ Reboot
¢ Shutdown

* Reset Configuration

* Factory Reset

e Firmware Upgrade

¢ Reset Widgets

e IP Tables

* test-network

e usg-license

¢ Set Confirm ID for Windows VM
e List VM License

e Show VM Status

¢ VM reset

¢ DC Image Status

¢ Set Maintainer

» Set Timeout for Remote Auth
e Data Purge

¢ Log Purge

¢ DMZ Mode

* FDN Package Information

¢ Fabric Binding

¢ Central Management Settings

Utilities e TCP Dump
¢ Trace Route
Diagnostics ¢ Diagnose
8. Click Save.
Certificates

Use this page to import, view, and delete certificates. Certificates are used for secure connection to an LDAP server,
system HTTPS, and SSH services. FortiDeceptor has one default certificate named firmware.

FortiDeceptor does not support generating certificates. FortiDeceptor supports importing certificates for SSH and
HTTPS access using .crt, PKCS12, or . pem format.
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The following options are available:

Import Import a certificate.

Service Configure specific certificates for HTTP and SSH servers.
View View the selected CA certificate details.

Delete Delete the selected certificate.

The following information is displayed:

Name Name of the certificate.

Subject Subject of the certificate.

Status The certificate status, active or expired.

Service HTTPS or SSH service that is using this certificate.

To import a certificate:

Go to System > Certificates.

Click Import.

Enter the Certificate Name.

If you want to import a password protected PKCS12 certificate, select PKCS12 Format.
Click Choose File and locate the certificate and key files on your management computer.
Click OK to import the certificate.

o gk wbh-=

To view a certificate:

1. Go to System > Certificates.

2. Select a certificate and click View.
The following information is available:

Certificate Name Name of the certificate.

Status Certificate status.

Serial number Certificate serial number.

Issuer Issuer of the certificate.

Subject Subject of the certificate.

Effective date Date and time that the certificate became effective.
Expiration date Date and time that the certificate expires.

To delete a CA certificate:

1. Go to System > Cetrtificates.
2. Select the certificate you want to delete.
3. Click Delete and confirm you want to delete the certificate.
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A\,
S L4
? You cannot delete the firmware certificate.

LDAP Servers

FortiDeceptor supports remote authentication of administrators using LDAP servers. To use this feature, configure the
server entries in FortiDeceptor for each authentication server in your network.

If you have configured LDAP support and require users to authenticate using an LDAP server, FortiDeceptor contacts
the LDAP server for authentication. To authenticate with FortiDeceptor, the user enters a user name and password.
FortiDeceptor sends this user name and password to the LDAP server. If the LDAP server can authenticate the user,
FortiDeceptor authenticates the user. If the LDAP server cannot authenticate the user, FortiDeceptor refuses the

connection.
\‘ ! 'l
? Due to the security enhancement requirement, FortiDeceptor requires peer servers to use
|| strong cipher algorithm for certificates.

The following options are available:

Create New Add an LDAP server.
Edit Edit the selected LDAP server.
Delete Delete the selected LDAP server.

The following information is displayed:

Name LDAP server name.
Address LDAP server address.
Common Name LDAP common name.
Distinguished Name LDAP distinguished name.
Bind Type LDAP bind type.
Connection Type LDAP connection type.

To create a new LDAP server:

1. Goto System > LDAP Servers.
2. Click Create New.
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3. Configure the following settings:

Name
Server Name/IP

Port

Common Name

Distinguished Name

Bind Type

Username

Password
Enable Secure Connection

Protocol

CA Certificate

4. Click OK.

RADIUS Servers

A unique name to identify the LDAP server.
IP address or FQDN of the LDAP server.

The port for LDAP traffic.
The default port is 389.

Common name identifier of the LDAP server.

Most LDAP servers use cn. Some servers use other common name identifiers
such as uid.

Distinguished name used to look up entries on LDAP servers. The
distinguished name reflects the hierarchy of LDAP database object classes
above the common name identifier.

The type of binding for LDAP authentication:
e Simple
* Anonymous
e Regular

When the Bind Type is set to Regular, enter the user name.

When the Bind Type is set to Regular, enter the password.

Use a secure LDAP server connection for authentication.

When Enable Secure Connection is selected, select LDAPS or STARTTLS.

When Enable Secure Connection is selected, select a CA Certificate.

FortiDeceptor supports remote authentication of administrators using RADIUS servers. To use this feature, configure the
server entries in FortiDeceptor for each authentication server in your network.

If you have configured RADIUS support and require users to authenticate using a RADIUS server, FortiDeceptor
contacts the RADIUS server for authentication. To authenticate with FortiDeceptor, the user enters a user name and
password. FortiDeceptor sends this user name and password to the RADIUS server. If the RADIUS server can
authenticate the user, FortiDeceptor authenticates the user. If the RADIUS server cannot authenticate the user,

FortiDeceptor refuses the connection.

The following options are available:

Create New Add a RADIUS server.
Edit Edit the selected RADIUS server.
Delete Delete the selected RADIUS server.
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The following information is displayed:

Name RADIUS server name.
Primary Address Primary server IP address.
Secondary Address Secondary server IP address.
Port Port used for RADIUS traffic.

The default port is 1812.

Type Select either FortiAuthenticator or Other from the dropdown.

Auth Type The authentication type the RADIUS server requires.

Select Any, PAP, CHAP, or MSv2. Any means FortiDeceptor tries all
authentication types.

Primary Secret Primary RADIUS server secret.

Secondary Secret

Secondary RADIUS server secret.

NAS IP NAS IP address.

To add a RADIUS server:

1. Goto System > RADIUS Servers.
2. Click Create New.
3. Configure the following settings:

Name
Primary Server Name/IP
Secondary Server Name/IP

Port

Auth Type
Primary Secret

Secondary Secret

NAS IP

4. Click OK.

Single Sign-On

Go to System > Single sign-on to allow administrators to log into FortiDeceptor with a single ID. User information is
stored in a remote Identity Provider (IdP) server. No user information is stored locally. Instead, FortiDeceptor acts as a

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.

A unique name to identify the RADIUS server.
IP address or FQDN of the primary RADIUS server.
IP address or FQDN of the secondary RADIUS server.

Port for RADIUS traffic.
The default port is 1812.

Authentication type the RADIUS server requires.

Select Any, PAP, CHAP, or MSv2. Any means FortiDeceptor tries all
authentication types.

Primary RADIUS server secret.
Secondary RADIUS server secret.
NAS IP address.
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Service Provider (SP). When a login request is received, FortiDeceptor redirects the request via SAML protocol to the
IdP to complete the authentication.

To enable Single Sign-On:

1. Goto System > Single sign-on and click Enable . The Single Sign-On settings are displayed.
2. Configure the Single Sign-On settings and click Apply.

Service Provider Configuration

Address
Entity ID

Assertion consumer service

URL

Single logout service URL

Enable Certificate

Certificate

Identity Provider Configuration

Entity ID

Single sign-on service URL

Single logout service URL

Certificate

Additional SAML Attributes

Attribute used to identify

users

Configuring SSO with Azure

The address the identify provider will send SAML authentication requests to.
Click the Copy icon to copy the Entity ID.
Click the Copy icon to copy the URL.

Click the Copy icon to copy the URL.

Service provider will use this certificate to sign or encrypt the request. When this
option is disabled , the request will not be signed or encrypted.

Allow the service provider to sign or encrypt the request. Select the certificate to
use from the list. You can also download the public key of the certificate and
upload it to the identity provider to verify and decrypt the request.

Enter the entity ID of identity provider

Enter the identity provider's sign on URL.

Enter the identity provider's logout URL.

Upload the public X.509 certificate of the identity provider .

The identity provider will use this attribute in the request to report the sign-on user
name.

Configuring SSO with Azure requires a Claim Attribute. This section provides an overview on how to configure a new
Claim Attribute in Azure and where to enter it in FortiDeceptor. For more information about Claim Attributes, see the

Azure product help.

A

As SSO is a standard method, setting Claim Attribute on the IDP side can be applied to any

IDP servers.
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To configure SSO for Azure:

1. In Azure, go to Identity > Applications > Enterprise applications > All applications.

2. Select the application, select Single sign-on in the left-hand menu, and then select Edit in the Attributes & Claims

section.
Home » Enterprise applications | All applications > | SAML-based Sign-on » SAML-based Sign-on >
f Home s .
Attributes & Claims
“ Favorites
t Add new claim Add a group claim == Columns &7 Got feedback?
@ Identity
Required claim
@ overview
Claim name Type Value
R Users = = 8
Unigue User Identifier (Name 10) SAML useruserprincipalname [... ***
2 Groups
Additional claims
£ Devices Claim name Type Value
I& Applications emailaddress SAML user.mail o
FDC_S50 User SAML user.userprincipalname b

®

Enterprise applications
App registrations
Protection

Identity governance
External Identities

Show more

http://schemasxmlscap.org/ws/2005/05/identity/claims/givenname SAML

http://schemas.xmlsoap.org/ws/2005/05/identity/claims/name

http://schemas.xmisoap.org/ws/ 2005/05/identity/claims/surname

urnioid:0.9.2342.19200300.100.1.3

~  Advanced settings

SAML
SAML

SAML

user.givenname
user.userprincipalname
usersurnams

user.userprincipalname

3. Goto Manage Claim.
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4. Go to Manage > Single-Sign On.

#

*

g & 3 o & ¢

& m

Home

Favorites

Identity

Overview

Users

Groups

Devices
Applications
Enterprise applications
App registrations
Protection

Identity governance
External Identities

Show more

Protection

Identity gevernance

Verifiable credentials

Learn & support

Forti_Chee | SAML-based Sign-on
Enterprise Application
~
T Upload metadatafile “? Change single sign-on mode
i ovenview
~
Deployment Plan Basic SAML Configuration
X Diagnose and solve problems Identifier (Entity 1D)
~ Reply URL (Assertion Consumer Service URL)
Manage Sign on URL
s Relay State (Optional)
~ I
It properties Logout Ul (Optional)
~ & Owners
y I ini " -
A 4. Reles and administrators Attributes & Claims
&8 Users and groups
givenname
D single sign-on surname
» EuES name
¥ Pravissning urn:0id:0.9.2342.19200300.100.1.3
~ C  self-service emailaddress
FDC_SSO_User
C Unigue User Identifier
Y
Securi
oo ity
® conditional Access SAML Certificates
il Permissions Token signing certificate
Status
v @ Token encryption Thumbprint
s Expiration
Acti = H
hicd Netification Email
' ) Sign-in logs App Federation Metadata Url
. Certificate (Basetd)
w Usage & insights Certificate (Raw)
B Auditlogs Federation Metadata XML
ﬁ Provisioning logs
~ g'es erification certificates (optional)
#= Access reviews Required
i Active

Home > Enterprise applications | All applications >

i

Test this application

57 Got feedback?

& et

https://10.47.4.136/remote/sam|/metadata

hitps://10.47.4.136/remote/saml/acs
https://10.47.4.136/remotefsaml/acs
Optional
https://10.47.4.136/remote/sami/sls

usergivenname
user.surname
user.userprincipalname
user.userprincipalname
user.mail
user.userprincipalname
user.userprincipalname

Active
11/8/2026, 4:46:27 PM

-mPs-‘”hgin = ine.com/

& Edit

& Edit

2951-c9cb-... [ |

Download
Download
Download

& et

Specify the attribute Name and the Source Afttribute.

& Got feadback?

Name *

Home > Enterprise applications | All applications > Forti_Chee | SAML-based Sign-on > SAML-based Sign-on > Attributes & Claims >

Manage claim

| Foc_sso_user

Namespace

Source *

[ Enter a namespace ui

~ Choose name format

(® attribute (O Transformation (O Directory schema extension

Source attribute * [ useruserprincipainame |

A Home
K Favorites v
@ identity ~
@ overview
A Users ~
' Groups ~
& Devices i
B8 Applications

Enterprise applications

App registrations
B Protection

~ Claim conditions

v Advanced SAML claims options
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6. In FortiDeceptor enter the attribute claim in the Attribute used to identify users field.

£23 FDCVMS0000000000 = Y - Q- ©admin~

@ Dashboard
@® Deception
Incident
@) Fabric

<F Network

Single Sign-On

Service Provider Configuration

Single logout service URL ttps

< v v v v v

Enable Certificate (o]
& System

Administrators Identity Provider Configuration
Admin Profiles
Certificates @ Logintoyour Identity Provider platform tofind the following

LDAP Servers information.

RADIUS Servers Entity ID* indows. 51-c9cb-4bcS-aba7
Single Sign-On
ingle si ice URL*

Mail Server

m/ '951-cPch-4bc5-aba7-f0494f6245

p: in.
S Single logout service URL https://login.microsoftonline.com/ea5e295 1-c9cb-4bc5-aba7-f0494f6245

FortiGuard

FDC License

Settings Certificate *
e @ Successfully uploaded Forti Chee.cer T

Table Customization

L Log >

Additional SAML Attributes

The FortiDeceptor will look for these attributes to verify authentication
@ attempts. Configure your Identity Provider toinclude them inthe SAML
Attribute Statement.

Attribute used toidentify users*  FDC_SSO_User

FEIRTINET 500

Mail Server

Use the Mail Server page to send incident alerts. You can also create custom delivery rules.
Configure Mail Server Settings

Send Incidents Alerts* (B

SMTP Server Address* | 0.0.0.0

Port™ 25

From * user@fortinet.com

Login User optional

Login Password sesscsse Change

€ Back

Creating incident alerts

To send incident alerts:

1. Go to System > Mail Server. The Mail Server page opens.
2. Enable Send Incidents Alerts.
3. Configure the mail server settings.

SMTP Server Address SMTP server address.
Port SMTP server port number.

From The mail server email account. This is the "from" address.

FortiDeceptor 5.2.2 Administration Guide 137
Fortinet Inc.



System

Login User

Login Password

The mail server login account.

Enter and confirm the password.

(Optional) Click Send Test Email to send a test email to one or more email addresses. If an error occurs, the error
message appears at the top of the page and is recorded in the System Logs.

Click Save.

Click Back to return to the Mail Server page.

Creating alert delivery rules

To create a alert delivery rule:

1.
2. Enable the rule. When enabled, FortiDeceptor sends an email alert to the Receiver Email List according to the rule

Click Alert Deliver Rule. The Alert Rule dialog opens.

3. Configure the rule settings.

Name

Incident URL

Alert Severity
Alert Type

Binary Infection

Incident Alert
Section

Attacker IP/Subnet

Attacker User

Attacker Password

Operation Content

Victim Decoy
Name

Enter a name for the rule.

When enabled, the device hostname is used instead of the management IP.

Note: The device hostname must be able to be resolved in your DNS server for the
Incident URL link to work.

Select Low, Medium, High, or Critical.
Select Connection, Reconnaissance, Interaction, and Infection.

This options is available when the Alert Type is Interaction or Infection .

Select Yes to be alerted when an attacker drops or downloads suspicious files into
decoys.

Select All, Interaction Events Only, IPS events only, or Web filter events only.

Enter one or more values for the attacker IP address or attacker IP network.

Enter one or more values for the attacker username.

To trigger the rule, the username entered by the attacker and the value for Attacker User
must be exactly same. The string is case sensitive.

Enter one or more values for the attacker password.

To trigger the rule, the password entered by the attacker and the value for Attacker
Password must be exactly same. The string is case sensitive.

Enter one or more key words that will trigger the rule.

Operation Content supports exact and partial matches. For example, if the value is
Monkey and the attacker enters Key, the rule is triggered. However, the rule is not
triggered if the attacker only enters ey. Operation Content is not case sensitive.

Select one or more deployed decoys from the Select Entries pane that slides open.

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.

138



System

Victim Decoy Port

Recipients

Display Original
Recipient

Enter one or more decoy service port numbers.
Enter one or more receiver email addresses.

Enable to view the original recipient of the alert email message.

»
4

The relationship between each of the lines in the rule is And. To trigger the rule, all the
values must be met. For example, the rule is not triggered if the value for Aftacker User is
met, but the value for Attacker Password is not.

The relationship for each line of the rule is Or. To trigger the rule, only one of the values
must be met. For example, if the values for Attacker User are Admin and
Administrator, the rule is triggered if only Admin is entered.

Create Adert Rule

Enabed *

Incident LIRL *

Mame *
Alert Severity *

At Type

Binary Infection
Incident Alert Section *
Attacker |BSubnetil)
Attacker User(d)
Attacker Password|[0)
Operation Contentil]
Wictin Decoy Mamse(0
Wictien Decoy Porti0]

Eecipients|1] ®

Display Original Recipient *

4. Click Save.

SNMP

x
s ]
B iise hostrame Instead of port1 iP for
ncident LIRL
Loy lesdivin Hi.gh Crithcal
Conmection Feconnaiisanis
B Interaction Indeetion

= ]
m Interaction Events Only  IPSevents only  Web filter events only
+

[+

SNMP is a method to monitor your FortiDeceptor system on your local computer. You need an SNMP agent on your

computer to read the SNMP information. Using SNMP, your FortiDeceptor system monitors for system events including

CPU usage, memory usage, log disk space, interface changes, and malware detection.

SNMP has two parts:

o The SNMP agent or the device that is sending traps.
« The SNMP manager that monitors those traps.
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The SNMP communities on the monitored FortiDeceptor are configured in the SNMP page.

The FortiDeceptor SNMP implementation is read-only. SNMP v1, v2c, v3 compliant SNMP manager applications, such
as those on your local computer, have read-only access to FortiDeceptor system information and can receive
FortiDeceptor system traps.

You can also download FortiDeceptor and Fortinet core MIB files.

Configure the SNMP agent

The SNMP agent sends SNMP traps that originate on FortiDeceptor to an external monitoring SNMP manager defined in
one of the FortiDeceptor SNMP communities. Typically, an SNMP manager is an application on a local computer that
can read the SNMP traps and then generate reports or graphs.

The SNMP manager can monitor FortiDeceptor to determine if it is operating properly or if critical events are occurring.
The description, location, and contact information for this FortiDeceptor system is part of the information an SNMP
manager collects. This information is useful if the SNMP manager is monitoring many devices, and it enables a faster
response when FortiDeceptor requires attention.

To configure SNMP agents:

1. Goto System > SNMP.
2. Configure the following settings:

SNMP Agent When enabled, the FortiDeceptor SNMP agent sends FortiDeceptor SNMP
traps.

Description Description of this FortiDeceptor to identify this unit.

Location Location of this FortiDeceptor if it requires attention.

Contact Contact information of the person in charge of this FortiDeceptor.

SNMP vi/v2c Create, edit, or delete SNMP v1 and v2c communities. You can enable or

disable communities in the edit page. Columns include: Community Name,
Queries, Traps, Enable.

SNMP v3 Create, edit, or delete SNMP v3 entries. You can enable or disable queries in
the edit page. Columns include: Username, Security Level, Notification Host,
and Queries.

To create an SNMP v1/v2c community:

1. Goto System > SNMP.
2. Inthe SNMP v1/v2c section, click Create New.
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3. Configure the following settings:

Enable Enable the SNMP community.
Community Name The name that identifies the SNMP community.
Hosts The list of hosts that can use the settings in this SNMP community to monitor
FortiDeceptor.
IP/Netmask IP address and netmask of the SNMP hosts.

Click Add to add additional hosts.

Queries v1, Queries v2c Port number and if it is enabled.
Enable queries for each SNMP version that FortiDeceptor uses.

Traps v1, Traps v2c Local port number, remote port number, and if it is enabled.
Enable traps for each SNMP version that FortiDeceptor uses.

SNMP Events Events that cause FortiDeceptor to send SNMP traps to the community:
e CPU usage is high
¢ Memory is low
e Log disk space is low
* Incident is detected

4. Click OK.

To create an SNMP v3 user:

1. Goto System > SNMP.
2. Inthe SNMP v3 section, click Create New.
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3. Configure the following settings:

4,

Username

Security Level

Authentication

Method

Password
Encryption
Method

Key
Notification Hosts (Traps)

IP/Netmask
Query

Port
SNMP V3 Events

Click OK.

To download MIB files:

1.

Go to System > SNMP.

Name of the SNMPV3 user.

Security level of the user:
* None
¢ Authentication only
* Encryption and authentication

Authentication is required when Security Level is either Authentication only or
Encryption and authentication.

Authentication method:
e MD5 (Message Digest 5 algorithm)
» SHA1 (Secure Hash algorithm)

Authentication password of at least eight characters.
Encryption is required if Security Level is Encryption and authentication.

Encryption method:
 DES
e AES

Encryption key of at least eight characters.

IP address and netmask. Click Add to add more hosts.

Port number and if it is enabled.

SNMP events associated with that user:
e CPU usage is high
e Memory is low
e Log disk space is low
¢ Incident is detected

2. Scroll down to FortiDeceptor SNMP MIB and click one of the following links:
» Download FortiDeceptor MIB File
» Download Fortinet Core MIB File

To filter the columns in the table:

1.

FortiDeceptor 5.2.2 Administration Guide
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2. Selecta columnin the list to Resize to Contents, Group By This column or create a custom filter.

3. Click Apply.
905416

To show or hide columns in the table:

1. Hover the header row until the Configure Table icon appears.

2. Click Configure Table. The Best Fit Columns menu opens.
3. Select the columns to appear in the table and click Apply.
4. To restore the default table, click Reset Table.

FortiGuard

The FortiGuard Distribution Network (FDN) provides FortiGuard services for your FortiDeceptor system. The FDN is a
worldwide network of FortiGuard Distribution Servers (FDS), which update the FortiGuard services on your
FortiDeceptor system on a regular basis so that your FortiDeceptor system protects against the latest threats.

The FortiGuard services available on the FortiDeceptor system include:

Service Description

Antivirus

IDS engines

Web filtering engine

Anti-Recon and Anti-Exploit
Service

Al Malware Engine

Malware scanning against files that get captured by the decoys.

¢ Scanning the traffic between the threat actor and the decoys to detect
network attacks
¢ Contain the industrial signature pack for the ICS network .

Databases and look-ups against access from the decoy to the internet.

The Anti-Reconnaissance and Anti-Exploit Service (ARAE) service is available on
FortiDeceptor and is responsible for tracking hackers' activities on decoys with
real-time alerts. Similar to how FortiSandbox traces malware behavior activities,
ARAE will record malicious activities such as files extracted, intrusions activities,
planted malware, and web sites visited. ARAEs goal is to Deceive, Expose and
Eliminate threats.

Al Pallas malware detection engine used for backend file inspection.
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To configure FortiGuard updates:

1. Goto System > FortiGuard.

2. The following options and information are available:

Module Name

Current Version
Release Time
Last Update Time
Last Check Status

Upload Package File

FortiGuard Server Settings

Use override FDN
server to
download module
updates

Use Proxy

The FortiGuard module name, including: AntiVirus Scanner, AntiVirus Extended

Signature, AntiVirus Active Signature, AntiVirus Extreme Signature, IDS Engine,
IDS Signature, Anti-Reconnaissance & Anti-Exploit Engine.

All modules automatically install update packages when they are available on the
FDN.

The current version of the module.

The time that module was released.
The time that module was last updated.
The status of the last update attempt.

Select Browse to locate a package file on the management computer, then select
Submit to upload the package file to the FortiDeceptor.

When the unit has no access to the Fortinet FDN servers, the user can go to the
Customer Service and Support site to download package files manually.

Select to enable an override FDN server, or FortiManager, to download module
update, then enter the server IP address or FQDN in the text box. When an
overridden FDN server is used, FortiGuard Server Location will be disabled.

Click Connect FDN Now button to schedule an immediate update check. The
default port on FDN server is 443 and can be changed to 53 or 8888.

Select to use a proxy. Configure the Proxy Type (HTTP Connect, SOCKS v4, or
SOCKS vb), Server Name/IP, Port, Proxy Username, and Proxy Password.

FortiGuard Web Filter Settings

Use override
server address for
web filtering

query

Use Proxy

Select to enable an override server address for web filtering query, then enter the
server IP address (IP address or IP address:port) or FQDN in the text box.

By default, the closest web filtering server according to the unit's time zone is
used.

The default port on FDN server is 443.

Select to use a proxy. Configure the Proxy Type (HTTP Connect, SOCKS v4, or
SOCKS v5), Server Name/IP, Port, Proxy Username, and Proxy Password.

VM Image Download Proxy Settings

Use Proxy

Select to use a proxy. Configure the Proxy Type (HTTP Connect, SOCKS v4, or
SOCKS v5), Server Name/IP, Port, Proxy Username, and Proxy Password.

3. Click Connect FDN Now to connect the override FDN server/proxy.
« Click Test Connection to test your connection.
« Click Apply to apply your changes.
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FDC License

FortiDeceptor is a subscription-based model that calculates the amount of Network VLANSs the system can connect to.
Single Class C (/24) will consume 1 VLAN, while other network classes with /23 and below will consume 2 VLANs (max).

To upload a FortiDeceptor license:

1. Goto System > FDC License.
2. Click License Upload. The Firmware License Upload page opens.
3. Click Browse and navigate to the license file on your computer.
4. Click Submit.
\‘ ! 'l
q FortiDeceptor will reboot after the license file is installed.

To input the confirmation ID for Windows:

Go to System > FDC License.

Click Input Confirmation ID . The Input Confirmation ID for Windows dialog opens.
From the Windows Key dropdown, select a Windows key.

In the Confirmation ID field, enter the confirmation ID.

Click OK.

o obd-=

+ License Upload -ﬂ Input Confirmation 1D

FDC License Status
Module Name ‘ License Details ‘ Module version Status
FDC Platform FDCVM 4.0.0 Active
Network Segment Coverage Input Confirmation |D for Windows x Active
Deception Lure Active

Warning: Please do not reboot the unit after save this confirmation |D!!!
System will re-activate the OS with given information immediately !!!

Windows Key * ‘ |

Please select a Windows key.

Confirmation ID * ‘ |

Please enter a confirmation ID.

Cancel

Al
S L4
q Do not reboot FortiDeceptor until the activation is complete.
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Settings

Configure the idle timeout for the administrator account or reset all the widgets in the Dashboard.

To configure idle timeout:

1. Goto System > Settings.
2. Enter avalue between 1 and 480 minutes.
3. Click OK.

To reset all widgets:

Click the Reset button to revert the Dashboard to the default settings. This removes any widgets you added to the
Dashboard and restores the widget settings.

To enable Mitre ICS tag:

1. Go to System > Settings.
2. Under Mitre ICS settings select Enable Mitre ICS.
3. Click Apply.

To Upload deception statistics to FortiGuard:

1. Goto System > Settings.
2. Enable FortiDeceptor Attack Detection Exchange Program.
3. Click Apply.

Login Disclaimer

Create a custom disclaimer message to display when a user logs into the FortiDeceptor unit.

To create a custom log in disclaimer:

Go to System > Login Disclaimer.

In the Disclaimer field, enter the disclaimer text.

(Optional) Select Show disclaimer on login, to display the disclaimer when a user logs in.
Click OK.

P owbdh-=

Table Customization

You can customize the page layout for the Incidents and Events pages.
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To customize the columns available for Incidents or Events:
1. Inthe Incident Columns pane:

To show a column Drag and drop the headers from the Available Column Headers to Customized
Column Headers and Orders.

To hide a column Drag and drop the headers from the Customized Column Headers and Orders
to Available Column Headers.

To change the column order  Drag and drop the position of the headers in Customized Column Headers and
Orders.

2. Inthe Table Settings pane, configure the table size and view.

Page Size Enter the number of incidents to display per page when View Type >
Pagination is selected.

View Type Select Pagination, Infinite Scroll or Both.

Table View Settings - 0ox

3@ Incident Columns

‘Customized Column Headers and Orders

Available Column Headers

%= Table Settings

Page Size
View Type Pagination WOTLGNEEGGIN Both

Apply Reset Cancel

3. Click Apply.

\ L}
S L4
? You may need to refresh the page to see your changes.

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.

147



System

Raw logs

You can download and save raw logs to the management computer. Raw logs are saved as a text file with the extension
Jdog.gz.

To download raw logs:

1. Goto Log > All Events and select a log.
2. Inthetoolbar, click Download Log.

Sample raw logs file content

itime=1535413204 date=2018-08-27 time=16:40:04 logid=0106000001 type=event subtype=system
pri=debug user=system ui=system action= status=success msg="SNMP TRAP sent out:
Service=SSH AttackerIp=10.95.5.83 AttackerPort=57190 VictimIp=10.95.5.21 VictimPort=22
Operation=Established SSH connection Description=10.95.5.83 Username=NA Password=NA"
itime=1535413204 date=2018-08-27 time=16:40:04 1logid=0106000001 type=event subtype=system
pri=debug user=system ui=system action= status=success msg="SNMP TRAP sent out:
Service=SSH AttackerIp=10.95.5.83 AttackerPort=57190 VictimIp=10.95.5.21 VictimPort=22
Operation=SSH connection closed Description=83ssh Username=83ssh Password=83ssh"
1itime=1535413204 date=2018-08-27 time=16:40:04 1logid=0106000001 type=event subtype=system
pri=debug user=system ui=system action= status=success msg="SNMP TRAP sent out:
Service=SSH AttackerIp=10.95.5.83 AttackerPort=57190 VictimIp=10.95.5.21 VictimPort=22
Operation=Authentication Failure Description=83ssh Username=83ssh Password=83ssh"
1time=1535413204 date=2018-08-27 time=16:40:04 1logid=0106000001 type=event subtype=system
pri=debug user=system ui=system action= status=success msg="SNMP TRAP sent out:
Service=SAMBA AttackerIp=10.95.5.83 AttackerPort=NA VictimIp=10.95.5.21 VictimPort=445
Operation=Change to dir Description=/home/share/samba Username=83samba
Password=83samba"
1itime=1535413204 date=2018-08-27 time=16:40:04 1logid=0106000001 type=event subtype=system
pri=debug user=system ui=system action= status=success msg="SNMP TRAP sent out:
Service=SAMBA AttackerIp=10.95.5.83 AttackerPort=NA VictimIp=10.95.5.21 VictimPort=445
Operation=Access path Description=samba Username=83samba Password=83samba"
1time=1535413204 date=2018-08-27 time=16:40:04 1logid=0106000001 type=event subtype=system
pri=debug user=system ui=system action= status=success msg="SNMP TRAP sent out:
Service=SAMBA AttackerIp=10.95.5.83 AttackerPort=NA VictimIp=10.95.5.21 VictimPort=445
Operation=Disconnect net share Description=samba Username=83samba Password=83samba"
1time=1535413201 date=2018-08-27 time=16:40:01 1logid=0106000001 type=event subtype=system
pri=alert user=system ui=GUI action=update status=success msg="Service=SSH
AttackerIp=10.95.5.83 AttackerPort=57190 VictimIp=10.95.5.21 VictimPort=22
Operation=SSH connection closed Description=83ssh Username=83ssh Password=83ssh"
1itime=1535413201 date=2018-08-27 time=16:40:01 logid=0106000001 type=event subtype=system
pri=alert user=system ui=GUI action=update status=success msg="Service=SSH
AttackerIp=10.95.5.83 AttackerPort=57190 VictimIp=10.95.5.21 VictimPort=22
Operation=Authentication Failure Description=83ssh Username=83ssh Password=83ssh"
1time=1535413198 date=2018-08-27 time=16:39:58 1logid=0106000001 type=event subtype=system
pri=alert user=system ui=GUI action=update status=success msg="Service=SSH
AttackerIp=10.95.5.83 AttackerPort=57190 VictimIp=10.95.5.21 VictimPort=22
Operation=Established SSH connection Description=10.95.5.83 Username=NA Password=NA"
1time=1535413198 date=2018-08-27 time=16:39:58 1logid=0106000001 type=event subtype=system
pri=alert user=system ui=GUI action=update status=success msg="Service=SAMBA
AttackerIp=10.95.5.83 AttackerPort=NA VictimIp=10.95.5.21 VictimPort=445
Operation=Disconnect net share Description=samba Username=83samba Password=83samba"
itime=1535413197 date=2018-08-27 time=16:39:57 logid=0106000001 type=event subtype=system
pri=alert user=system ui=GUI action=update status=success msg="Service=SAMBA
AttackerIp=10.95.5.83 AttackerPort=NA VictimIp=10.95.5.21 VictimPort=445
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Operation=Change to dir Description=/home/share/samba Username=83samba
Password=83samba"

1itime=1535413197 date=2018-08-27 time=16:39:57 1logid=0106000001 type=event subtype=system
pri=alert user=system uil=GUI action=update status=success msg="Service=SAMBA
AttackerIp=10.95.5.83 AttackerPort=NA VictimIp=10.95.5.21 VictimPort=445
Operation=Access path Description=samba Username=83samba Password=83samba"
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Log

Use the Log pages to view and download FortiDeceptor system logs. You can put logs locally on FortiDeceptor oron a
remote log server.

Log Servers

You can send FortiDeceptor logs to a remote syslog server, FortiAnalyzer, or common event type (CEF) server. In Log >
Log Servers, you can create new remote log servers, and edit and delete remote log servers. You can configure up to 30
remote log server entries.

The following options are available:

Create New Create alog server entry.
Edit Edit the selected log server entry.
Delete Delete the selected log server entry.

This page displays the following information:

Name Name of the server entry.

Type Server type: syslog, syslog over TLS, FortiAnalyzer or CEF.
Log Server Address Log server address.

Port Log server port number.

Status Log server status, Enabled or Disabled.

To create a server entry:

1. GotoLog > Log Servers.
2. Click Create New.
3. Configure the following settings:

Name Name of the new server entry.

Type Select Syslog Protocol, FortiAnalyzer, or Common Event Format.

Log Server Address Log server IP address or FQDN.

Port Port number. The default port is 514.

Status Enable or disable sending logs to the server.

Log Level Select the logging levels to forward to the log server. For logging levels, see Logging

Levels on page 151.

4. Click OK.
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To edit or delete a log server

1. GotoLog > Log Servers.

2. Select an entry and click Edit or Delete.

Log Categories

Log > All Events shows all logs.

The following options are available.

Download Log
History Logs
Refresh

Search

Details

Download the raw log file to the management computer.
Enable to include historical logs in Log Search.
Refresh the log message list.

Click Search to add search filters. You can select different categories to search
the logs. Search is not case sensitive.

Click the + button to choose from Date/Time, Level, User, Message, or Appliance.

Click to view the Log Details.

The following information is displayed.

#
Date/Time
Level
User

Message

Logging Levels

Log number.

Date and time the log message was created.

Level of the log message. For logging levels, see Logging Levels on page 151.
The user to which the log message relates. User can be a specific user or system.

Detailed log message.

FortiDeceptor log level can be Emergency (reserved), Alert, Critical, Error, Warning, Information, or Debug. The
following table provides example logs for each log level.

Log Level Description Example Log Entry
Alert Immediate action is required. Suspicious URL visit domain.com from 192.12.1.12 to
42.156.162.21:80.
Critical Functionality is affected. System database is not ready. A program should have
started to rebuild it and it shall be ready after a while.
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Log

Log Level Description

Error An erroneous condition exists and
functionality is probably affected.

Warning Functionality might be affected.

Information General information about system
operations.

Debug Detailed information for debugging.

FortiDeceptor 5.2.2 Administration Guide
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Example Log Entry

Errors that occur when deleting certificates.

Submitted file AVSInstallPack.exe is too large:
292046088.

LDAP server information that was successfully updated.

Launching job for file. jobid=2726271637747836543
filename=log
md5=ebe5ae2bec3b653c2970e8cec9f5f1d9
sha1=06ea6108d02513f0d278ecc8d443df86dac2885b
sha256=d678da5fb9eal3ee20af779a4ae13c402585
ebb070edcf20091cb20509000f74b
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gapped networks

This section shows how to deploy FortiDeceptor in an offline or air-gapped network with no internet access, using the
following procedures.

« Applying the license in an offline or air-gapped network on page 153

« Importing deception VMs in an offline or air-gapped network on page 155

» Importing firmware in an offline or air-gapped network on page 157

e Importing an FDS package via FDC GUI in an offline or air-gapped network on page 157

» Importing FDS package and license file via FortiManager in an offline or air-gapped network on page 158
FortiDeceptor uses deception VMs to deploy decoys across the network. Deploying FortiDeceptor VMs in a closed
network requires downloading the required images directly from the FortiDeceptor VM external repository and manually

uploading the deception VMs. For information about downloading the deception VMs, see Importing deception VMs in
an offline or air-gapped network on page 155

You can also use the Deception > Deception OS page or the fw-upgrade CLI command to download and import
packages.

Because FortiDeceptor also uses FDS services (IPS/AV/WEB) in offline and air-gapped networks, you must also import
these packages.

Deception VM security

You can download deception VMs via the HTTPS protocol. Each image is compressed, encrypted, and packed by the
FDC tool separately. The metafile describes the MD5 of each VM image.

The security layers that protect deception images are:

o Download via HTTPS.
» Deception VMs do not have any Fortinet propriety software.
» We provide the file's MD5 so that you can confirm the MD5 checksum for the downloaded files.

» FortiDeceptor always verifies the VM image by encryption and multiple layer checksum inside the package before
installing it.

Applying the license in an offline or air-gapped network

To download the FortiDeceptor license file from the Fortinet support site:

1. Log into Customer Service and Support. The Asset Portal opens.
2. Goto My Assets and locate the device then click the Serial Number. The product details page opens.
3. Inthe License & Key widget, click Get The License File and save it to the local disk.
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To upload the license file to FortiDeceptor:

1. Loginto FortiDeceptor.
2. Configure the management IP address on port1.
3. Inthe Dashboard System Information widget, click Upload License beside Firmware License.

FortiDeceptor VM = Dashboard
What are you looking for? (
System Information P %
@ Dashboard v il
Iﬂ Deception v Host Name F&%%E]'PM'DEMO
Customization Serial Number FDC
Dsceton s spanTme Y508 P
Deployment Network : - - v3.2.0,buildiusg
play Firmware Version (Inferim)Updatel
Deployment Wizard Firmware License @ [Upload License]
Decoy & Lure Status System Last Backup: N/A
onfiguration |Backup/Restore]
Deployment Map Current User admin
Safe List . 0 day(s) 3 hour(s) 3
Uptime minLTte(sJ

4. Locate the license and click Submit.

FortiDeceptor extracts the serial number, IP addresses, decoy keys, expiry date; and then performs the following
verifications.

« Verify the expiration time of the license.
« Verify that the embedded management IP address is the same as the current management IP address. You can
view the IP address in the Product Information widget in the product details page.

« Verify the expiration time of the decoys keys if the keys are subscription type.

If all the verifications pass, the unit is ready to import deception images.

 FortiDeceptor decoy WCF lookup (any URLSs visiting from decoys) are not categorized.

¢ You can use FortiManager to resolve this. Because FortiDeceptor supports override

NP FDS server, you can enter the FortiManager IP address there.
N . « Subscription-based decoys, that is, SSL VPN Windows customization, is in the * . 1ic file
q from the support site, which you can run offline.
= ¢ FortiDeceptor Custom Decoy Subscription Service includes:
¢ FC-10-FDCVM-292-02-DD (for VM).
¢ FC-10-FDC1K-292-02-DD (for HW).
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Importing deception VMs in an offline or air-gapped network

This topic shows how to download and import deception VMs in an offline or air-gapped network.

To download and import a deception VM:

1. Log into Customer Service and Support. The Asset Portal opens.
2. Inthe banner, click Support > Downloads > Firmware Download.

@ Support ¥
@ Firmware Download 4 Create a Ticket 4 Manage Tickets
W VM Images © Manage Active Tickets  [# Ticket Survey

@ Service Updates ) Contact Support & Technical Web Chat
@& HQIP Images

# Firmware Image Checksum

on-

3. Inthe Select Product dropdown list, select FortiDeceptor and then click Download.

Welcome to the Firmware Images download center for Fortinet's extensive line of security solutions.

Select Product

FortiDeceptor v

Release Nores

Image File Path

/ FartiDeceptor/

Image Folders/Files

Name Size (KB) Date Created Date Modified
] Deception0S Directory 2020-10-13 14:10:32 2022-04-28 16:04:39
] v3.00 Directory 2019-12-24 08:12:03 2022-06-20 12:06:08
=) v4.00 Directory 2021-07-30 13:07:35 2022-04-28 17:04:19
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4. Click Deception OS to see the list of deception OS VM files.

Firmware
Images

Welcome to the Firmware Images download center for Fortinet's extensive line of security solutions.

Select Product

FortiDeceptor

Image File Path

/ FortiDeceptor/ Deception0S/

Image Folders/Files

Up to higher level directory

Name
CE'\[-jS\_-'.Q{E
crmvi.pkg
FDCVE_mdS.oxt
fEtB01V.pkg
ionvl.pkg 20210716
md3.oxe
medicalvl.pkg
posvi.pkg
sapvl.pkg

Size (KB)

1,065,548

1,077,316

1

48,144

1,363,899

1

1,100,552

1,687,679

1,055,669

Fortinet Firmware Images And Software Releases

Date Created

2022-04-28 16:04:39

2021-04-01 11:04:33

2021-04-01 11:04:05

2020-10-13 14:10:44

2021-08-05 14:08:35

2020-10-13 14:10:44

202

04-01 11:04:46

2021-04-01 11:04:01

2022-04-28 16:04:34

Date Modified

2022-04-28 16:04:04

2021-04-01 11:04:56

2021-04-01 11:04:05

2020-10-13 1

049

2021-08-051

2020-10-13 14:10:44

2021-04-011

2021-04-01 11:0401

2022-04-28 16:04:36

5. Download all the deception OS VM .pkg files in this directory.
6. Copy the downloaded files to the offline or air-gapped network.

7. InFortiDeceptor, go to Deception > Deception OS and click Upload Deception OS Package to import the

FortiDeceptor images.

FortiDeceptor VM

¥} Deception v *
Customization
Deployment Metwark
Deployment Wizard
Decoy & Lure Status
Deployment Map
Safe List
Lure Resources

ﬁ Incident v
Analysis

Campaign

Attack Map

FortiDeceptor imports the images, verifies image integrity and other security layers, confirms that the images are the
originals, and then initializes them. After initialization the Deception OS window Status column shows these images as

Initialized.

Status

L& Initizlized

L& Initizlized

L& Initizlized

£ Initialized

L3 Initialized

= Deception OS

& Upload Deception OS Package

Mame

fgt601v1

scadavl

ubuntulsvl

winl0vl

win7x36v1
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OS Type

-
B Forticat
Z.E Scadz
4'_(_\ Ubuntu

Windows 10

Windows 7

WM Type Lures

Fortinet device

SCADA/IOT
device

Linux Server @
Windows
Desktop r‘@ @

o
Wirgons g &

®v admin~
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Importing firmware in an offline or air-gapped network

To download and import FortiDeceptor firmware:

NG R ODN=

9.

Log into Customer Service and Support.

Go to Download > Firmware Images.

In the Select Product dropdown list, select FortiDeceptor and then click Download.
Click the version you want.

Download the FortiDeceptor firmware file (the . out file).

Copy the downloaded file to the offline or air-gapped network.

Log into FortiDeceptor.

In the Dashboard System Information widget, click Update beside Firmware Version.

e FortiDeceptor VM £ Dashboard

What are you looking for? (
N System Information &S o on
ashboar

[ Deception o Host Name FDC-VM-PM-DEMO [Change]

Customization Serial Number FDC-VMOQQ000698%
. Mon Oct 26 14:42:49 2020 PDT
Deception OS System Time [Change]
Deployment Network Firmware Version v3.2.0,build0092 (Interim)[Update]
Firmware License & [Upload License]

Deployment Wizard
System Configuration Last Backup: N/A [Backup/Restore]

Decoy & Lure Status

Current User admin
Deployment Map

Uptime 0 day(s) 4 hour(s) 56 minute(s)
Safe List

Deception O5 o

Lure Resources

FDN Download Server <

Click Choose file, then locate the firmware file and click Submit.
FortiDeceptor reboots after the update.

Importing an FDS package via FDC GUI in an offline or air-gapped
network

To download and import a FortiDeceptor FDS package:

PoOobd-=

Log into Customer Service and Support.

Go to Download > FortiGuard Service Updates.

Locate and download the FortiDeceptor FDS package (the . pkg file).
Copy the downloaded file to the offline or air-gapped network.
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5. InFortiDeceptor, go to System > FortiGuard, then beside Upload Package File, click Choose File and locate the

FDS package.
=8 FortiDeceptor VM = FortiGuard
Administrators “
Module Name Current Version
Admin Profiles AntiVirus Scanner 00006.00009
Certificates AntiVirus Extended Signature 00000.00000
AntiVirus Active Signature 00008.00777
LDAP Servers AntiVirus Extreme Signature 00000.00000
IDS Signature 00015.00853
Meail Server Anti-Reconnaissance & Anti-Exploit Engine  01000.00011
SNMP I Upload Package File: Choose File '\Jo file chosen

6. Click Submit.
Ensure you receive a confirmation that installation is successful.

>_

s

Release Time
2018-05-01 17:45:00
Unknown
2016-11-0500:23:00
Unknown
2018-10-12 16:54:00
2020-05-2% 12:03:00
2020-10-26 09:59:00

®~ admin~
Last Update Time
2020-10-26 14:15:43
2020-10-26 14:15:43
2020-10-26 14:15:43
2020-10-26 14:15:43
2020-10-26 14:15:43
2020-10-26 14:15:43
2020-10-26 14:15:43

Importing FDS package and license file via FortiManager in an

offline or air-gapped network

This topic shows how to download and import a FortiDeceptor license in an offline or air-gapped network using

FortiManager.

When FortiManager is operating in a closed network, you can create a support ticket to request account entitlement files
from Fortinet Customer Service & Support for devices, and then upload the files to FortiGuard. This allows devices in the

closed network to check licenses.

To request the FortiDeceptor entitlement license file for FortiManager:

Log into Customer Service and Support.
Go to Assistance > Create a Ticket.
Expand Customer Service and click Submit Ticket.
Enter the required information.
o For Subject, enter Entitlement file.
« For Category, select CS Contract/License.
5. Complete and submit the ticket.
6. When you receive the entitlement file via email, download it to your computer.

PoOobd-=

Without a connection to a FortiGuard server, update packages and licenses must be manually downloaded from

support, and then uploaded to FortiManager.

To upload the FortiDeceptor entitlement license file to FortiManager:

1. InFortiManager, go to FortiGuard > Settings.

2. Set Enable Communication with FortiGuard Serverto OFF so that you can configure FortiManager as a local FDS

server.
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3. Inthe Upload Options for FortiGate/FortiMail section, click Upload besides Service License.

FortiGuand Server and Service Scitings

E Communica ForthGuand S o
E Antivirus and PS5 Service E
FortiGate Al wd 5.0 5.2 54 5.4
; Chent Al vl S0 5.2 5.4
FortiA ; All wd Bso B2 Bsa
F Pelail All vd Al wh
Enable Web Filter Service DF
Enabde Email Filter Sensice o
Upload Options for FortsGate/Fortiblail
Arthvirues/IPS Packages ® Upload
Web Filter Database ® Upload
Email Filter Database ® Upload
Garvice Licene @ Upload
Uplaad Options for FortiChent
Anthanes/1PS Packages @ Uplaad

Enable Communication with
FortiGuard Server

Enable AntiVirus and IPS
Service

Enable Web Filter Service

AntiVirus/IPS Packages

Web Filter Database

Service License

Toggle OFF to disable communication with FortiGuard servers.

Toggle ON to enable antivirus and intrusion protection service.

When on, select the versions of FortiGate, FortiClient, FortiAnalyzer, and
FortiMail to download updates.

Toggle ON to enable web filter services. When uploaded to FortiManager, the
web filter database displays.

Click Upload to upload antivirus and IPS packages you downloaded from the
Customer Service & Support portal.

Click Upload to upload the web filter database you downloaded from the
Customer Service & Support portal. As the database can be large, uploading
with CLI is recommended.

Click Upload to import the FortiGate license.

You can get a license file from support by requesting your account entitlement
for the device.

To configure FortiDeceptor to use FortiManager for FortiGuard services:

1. Goto System > FortiGuard.

2. Inthe FortiGuard Server Settings section, select Use override FDN server to download module updates and enter

the FortiManager IP address.

3. Inthe FortiGuard Web Filter Settings section, select Use override server for web filtering query (address or
address:port) and enter the FortiManager IP address.
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4. Inthe FortiGuard Server Settings section, click Connect FDN Now to test the FDN connection.

22 FortiDeceptor VM £ FortiGuard 7 T @~  admin~
I L2 System v FortiGuard Server Settings
Administrators I Use override FDN server to download module updates |fdsl.f0rt|'net.cum ‘ I
Admin Profiles [ Use Proxy
Certificates Connect FDN Now
LDAP Servers . . q
FortiGuard Web Filter Settings
RADIDSSe e I Use override server for web filtering query (address or address:port) |service.fort|'guard.net ‘ I 5888
Mail Server CUse Proxy
SNMP

VM Image Download Proxy Settings
[JUse Proxy

e
5. Ifthe test passes, click Apply.
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This section provides best practices principles and use cases on how to deploy FortiDeceptor in different network
topologies.

The section covers the following topics:

o Deception strategy on page 161

o FortiDeceptor platform on page 167

» Deploying deception on page 180

» Attack vectors vs deception on page 191

« Deploying tokens using AD GPO logon script on page 195
« Deploying AWS deception keys on page 200

» Deploying Azure deception keys on page 210

« Configuring trunk ports on FortiDeceptor VM on page 216

Deception strategy

The ancient war strategies by Sun Tzu says: "Know thy self, know thy enemy. A thousand battles, a thousand victories.”

This means if you know the strengths and weaknesses of your enemy, and if you know the strengths and weaknesses in
your defense system, you can win any battle. To win against cyber attackers and hackers or users with malicious
intention, the cyber security team needs to understand the attacker’s techniques and tools, as well as shortfalls in the
organization's defense system.

To understand the attack techniques and hackers’ interests in your environment, we need to understand three tools that
can help security professionals stop attackers before a data breach happens.

« Sandboxing: This technique allows the malware to install and run in an enclosed environment where the security
team can monitor the malware's actions to identify potential risks and countermeasures.

» Honeypots: These are intentionally vulnerable systems that are meant to attract attackers. Honeypots entice
attackers to attempt to steal valuable data or further scope out the target network. Honeypots help you to
understand the process and strategy of attackers.

« Deception technologies: These are more advanced honeypot and honeynet products that offer more automation
for both detection and implementation of defenses based on the data they gather.

Deception technology is like honeypots on steroids. It has more advanced capabilities like deception lure, deception
automation, threat analysis, threat hunting, and more.

The core technology behind deception is the decoy. In general, there are several kinds: low, medium, and high. To align
with FortiDeceptor technology, let's focus on two types of decoys: Low Interaction and High Interaction.

» Low interaction honeypot: This decoy has limited capability of emulating enterprise applications and is used only
to detect from where the attackers are coming and what they attempt to exploit. These are easy for attackers to
fingerprint and bypass.

« High interaction honeypot: This decoy is identical to the enterprise systems and can run real operating systems,
applications, and services with dummy data. They allow the attacker to log in and they respond to the attacker’s

FortiDeceptor 5.2.2 Administration Guide 161
Fortinet Inc.



Appendix B - Deception deployment best practices

request. In this way, the decoy helps you understand the attacker's intentions, lures them for a long time to identify
how command and control infrastructure is set up.

Deception technology systems are more advanced and have more components, breadcrumbs, baits, and lures.
Deception systems are implemented alongside enterprise systems but still remain in an isolated environment.

Deception technology systems are used to interrupt the attacker's kill chain, prolong the attack either to exhaust the
attacker’s resources or encourage attackers by providing obvious vulnerabilities to help identity the details of their
network and arsenals.

Deception strategy components

Deployment of enterprise-scale deception includes the following components:

Medium interaction decoy and high interaction decoy that are deployed everywhere.

Customizable decoys to match infrastructure and applications.

Create and deploy lures to redirect attackers toward decoys.

Create and deploy lures with trackable misinformation.

Threat analysis capabilities.

Integration with existing security infrastructure for mitigation and remediation (Security Fabric and third-party).

Deception strategy goals

Deployment of enterprise-scale deception should achieve the following cyber security requirements and goals:

Generate actionable, high-fidelity alerts.

Reduce the “dwell time” of an initial compromise.

Confuse the attacker with false assets and misinformation.

Block the human attacker or Advanced Persistent Threat (APT).

Collect threat intelligence regarding tactics, techniques, and procedures.
Integrate with existing defense-in-depth architecture.

Deception philosophy

Deception philosophy is a straightforward concept. You deploy deception across the whole network infrastructure and
location which generates a fake virtual network layer that masks the real assets with a fake one.

The networks today are fluid and dynamic, so we need to be sure that every network segment and location has this
deception layer and capability.

For example:

IT Endpoint segment — Requires deployment of lures and decoys.
IT Servers segment — Requires deployment of lures and decoys.
Network Devices — Requires deployment of decoys.

loT Devices — Requires deployment of decoys.

OT Devices — Requires deployment of decoys.

Data Repository — Requires deployment of honey files and decoys.
Application segment — Requires deployment of lures and decoys.
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« Network Traffic — Require decoys that generates fake network traffic and lure that creates fake network
connections and entries on the endpoint level.

o Public/Private Cloud — Requires deployment of decoys.

Deception light stack vs full stack

Deception light stack concept

The light deception concept uses a combination of endpoint lures with several high interaction decoys only as
destination targets.

Using the light deception concept against a sophisticated adversary has some significant drawbacks:

« Deception lures reside on the endpoint and if there is no in-depth customization, this can be fingerprinted.

» A sophisticated adversary that controls several endpoints might fail once and learn the deception lure logic so that
the adversary will not make the same mistake next time.

« A sophisticated adversary might not touch the deception lures if it can get high privilege at the beginning of the
attack, and the probability of finding several decoys from several thousand assets is non-existent.

« Lack of visibility around unmanaged devices (IoT/OT) where an adversary has plenty of time and space to attack
without detection.

« Simple malware spread vectors like pass the hash / single vulnerability attacks are not detected due to a lack of
decoys in the network segment level. For example, the Wannacry malware will not get detected using this
deployment stack.

Deception full stack concept

A simple explanation of the deception full stack concept is “do not let the sophisticated adversary / malware fingerprint
your fake story!”

The deception full stack addresses the drawback of the light deception concept using several deception layers’
architectures:

» Server/endpoint lures are the first layer that engages with the adversary / APT.

« Alarge scale of decoys that creates a fake network surface on top of the real one offering false endpoints, servers,
network devices, loT/OT, database, files, applications, cloud, and more. This is the deception everywhere concept.

« Some of the decoys are generated from a customer “gold image” and are part of the network domain to increase the
authentic deception level.

The dynamic deception decoys module prevents the sophisticated adversary from fingerprinting the decoys by changing
the decoys' IP addresses and profile based on time or trigger.

The FortiDeceptor full stack deception concept runs deception lures with a large scale of decoys using a hybrid mode
engine that provides medium and high-level interaction decoys against the adversary / APT malware.

Deception for FortiGuard Outbreak Alerts

FortiGuard Outbreak Alerts communicate important information about cybersecurity attacks and the Fortinet products
that will break the attack sequence. When a cybersecurity incident/attack/event occurs that affects numerous
organizations, the Outbreak Alerts page is updated with a link to an individual FortiGuard Outbreak Alert. For more
information, visit the Outbreak Alerts page.
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FortiDeceptor's outbreakv1 Deception OS contains Deception Decoys that are designed to target and mitigate
vulnerabilities identified in the FortiGuard Outbreak Alerts page.

The following steps describe how to configure the outbreakv1 Deception OS for Log4j2 attacks.

To deploy deception decoys for Outbreak Alerts:

1. |Install the outbreakv1 deception OS.
a. Go to Deception > Deception OS.
b. Inthe Status column, click Synchronize next to outbreakv1. The status changes to Initialized.

@ Dashboard >

L. Upload Deception OS Package i Synchronize Deception OS List
& Central Management >
| ® Deception v Status Name + OS Type VM Type Lures Appliance

Custom Decoy Image - ~ ‘ ®e w0 &y o
Deployment Network £¥ Initialized medicalvi ?@ Medical OS Medical loT system E:) g g & Local
Lure Resources
Deployment Wizard e [
Decoy Status & Synchronize medicalvl ?0 Medical OS5 Medical loT system £ & C123
Deception Token
Deployment Map £+ Initialized outbreak.. & Ubuntu Linux Server [N X Local
Asset Discovery
Safe List & Synchronize outbreak... [ﬁ‘ Ubuntu Linux Server i i i i Cc123

Incident >

@) Fabric > £¥ Initialized posvi E]Q POSOs POS system Local

i Network >

£ System > & Synchronize posv1 @0 PO5 QS POS system c123

L Log >

2. Goto Deception > Deployment Wizard and click Create a new decoy. The Configuration page opens.
3. Configure the following deployment settings.
Available Deception OSes Select outbreakv1.
Available Deception Decoys  Select and outbreak deception decoy. For example, Log4j2.
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@ Dashboard Deployment Wizard

& Central Management >

® Deception v & Template o ) @ Configuration & ) ) Set Network @

Custom Decoy Image

Deception OS Name~ log4j2 o
Deployment Network
Lure Resources Appliance Name local X v
Deployment Wizard
Available Deception OSes * outbreakvl W W
Decoy Status
Deception Token Available Deception Decoys * Log4j2 A
Deployment Map
Asset Discovery Selected Services * Totalflow
Safe List LOE4]2
Incident > Automate Lures Exchange
Fabri >
@) Fabric Generate lures Clear
i» Network >
& System ? L0G4)2 ALERT @
LM Log >
Launch Immediately o
Reset Decoy
@ Template < Start Over MNext >

For more information about configuring deployment, see Deployment Wizard on page 72.
4. Continue to follow the steps in the Deployment Wizard and then click Deploy.

@ Dashboard

Deployment Wizard
& Central Management >
| ® Deception v & Template ff > @& Configuration &8 > @ Set Network @
Custom Decoy Image
Deception OS DNS* 8.8.8.8 (]
Deployment Network
Hostname logdj2 (]

Lure Resources

Deployment Wizard

Deploy into Network

Decoy Status
Deception Token ‘ + Add network for deployment
Deployment Map
Asset Discovery Addressing Partition Vlan ID Network Mask Gateway MAC Address O... MAC Address Deploy IP IP Cour
Sl o dhep subnet 0 255.255.255.0 1
Incident >
@ Fabric >
4x Network >
£ System >
Ll [og >
% Template < Back Deploy v
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5. Go to Deception > Decoy Status to verify the decoy is running and configured correctly.

Dashboard >

& Central Management >
| ® Deception v
Custom Decoy Image
Deception OS
Deployment Network Config Detail
Lure Resources
Deployment Wizard DETAIL
Deception Token
PIIHED Deception OS: outbreakvl
S Deception Decoy: Log4j2
Safe List
Incident
@ Fabric
i Network
£ System
1l Log

Selected Services: LOG4J2 ALERT

Launch Immediately:

Reset:

B

LOG4J2 ALERT

NETWORK

Hostname: log4j2
DNs: 8.888

Interface Count: 1

Partition Mode: subnet

FERATINET 50

6. Run a simulated attack with the Log4j2 traffic pattern from an endpoint machine located within same deployment
network as the outbreak decoy. For example, curl -X POST http://10.10.1.124/login -F "test-
f=\${jndi:ladp:test-f}"

7. Goto Incident > Analysis to verify the attack results.

3 Deception > Severity T LastActivity T Type T Appliance T AttackerIP T VictimIP

1 Incident = 3 2022-12-06 14:43:25 PST Interaction Local

Campaign eline B8 Table & Re
Attack Map
MITRE ICS
§ Fabric R 2022-12-06 14:38:52 PST
¥ Network > &0 Appliance: Local
B System > C3 Attacker User: N/A
4 Log > = Attacker IP:
@ Attacker Port: 43584
& MITREICS T0840 T0844 T0B67
Techniques:
& Download lures
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FortiDeceptor platform

The FortiDeceptor platform includes the following:

« FortiDeceptor components on page 167
» FortiDeceptor Token Package on page 167
» FortiDeceptor decoys on page 168

FortiDeceptor components

The FortiDeceptor platform includes the following components:
« The FortiDeceptor management console manages and operates the whole platform including deployment,
configuration, alerting, analysis, and ECO system integration.
» FortiDeceptor offers a highly-scalable three-tier architecture that combines three levels of deception:
« Server/endpoint lures.
» Medium interaction decoys (IoT / OT).
« High interaction decoys.

You can deploy deception lures using existing infrastructure tools such as A/D GPO, MS SCCM, and so on.

A single FortiDeceptor appliance can run up to 16 deception VMs that support a total of 256 IP addresses. Each IP
address represents a single decoy.

You can download a deception VM from the FortiDeceptor marketplace. You can also allow the end user admin bring
their own gold image and convert it to a decoy using the FortiDeceptor decoy customization wizard.

FortiDeceptor Token Package

The FortiDeceptor Token package adds breadcrumbs on real endpoints and servers, and redirects an attacker to
engage with a decoy instead of a real asset. Deception tokens are typically distributed within real endpoints and servers
on the network to expand the deception surface.

Effective deception lure technology should support the following:

» Deploy deception lure data and configurations where attackers collect information.

« Deception lure location must be invisible to end users, and doesn’t affect endpoint functionality.

» Deception lure is accessible with user level permissions so that attackers can access it early on and get detected.
This saves the privileged escalation attack time.

The current FortiDeceptor token packages are:
Windows » Cached Credential

e HoneyDocs
¢ Network Connection (static MAC address)

- ODBC
e RDP
« SMB
Linux ¢ RDP (xfreerdp)
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+ SMB (SAMBA)

» SSH

MAC e RDP (xfreerdp)
e SMB (SAMBA)
» SSH

SAP e SAP

AWS Key * AWS Keys

Azure Key e Azure Keys

When the FortiDeceptor token package is installed on a real Windows, Linux, or MAC endpoint, it increases the
deception surface and redirects an attacker to engage with a decoy instead of a real asset.

FortiDeceptor decoys
FortiDeceptor creates a network of decoys to lure attackers and monitor their activities on the network. When a hacker
attacks a decoy, an alert is generated and their malicious activities are captured and analyzed in real-time. This analysis

generates a mitigation and remediation response that protects the network.

The current FortiDeceptor decoy OS are:

Windows Windows 7, Windows 10, Windows 10ltsc2021v1

Linux Ubuntu Desktop, CentOS, ESXiand ELK

loT/OT SCADA version 3, Medical OS, loT OS, and d VolP version1.

VPN Fortinet SSL-VPN (FG-60E, FG-100F, FG-1500D, FG-2000E, FG-3700D)
Customized Windows Windows 10, Windows 11, Windows Server 2016, Windows Sever 2019,

Windows Sever 2022, French Windows 10, French Windows Server 2016

The current FortiDeceptor application decoys are:

Application Decoys POS OS, ERP OS PACS and SAP

The current FortiDeceptor lure services are:

Windows RDP, SMB, TCPListener, NBNSSpoofSpotter, ICMP, FTP, SMTP, SWIFT Lite2.
Does not contain (Windows 7.
Linux SSH, SAMBA, TCPListener, HTTP, HTTPS, GIT, ICMP and FTP
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loT/OT HTTP, FTP, TETP, SNMP, MODBUS, S7TCOMM, BACNET, IPMI, TRICONEX,
ENIP, Kamstrup, DNP3, Telnet, PACS-WEB, PACS, DICOM server, Infusion
Pump (TELNET), Infusion Pump (FTP), POS-WEB, ERP-WEP, GUARDIAN-
AST, IEC104, Jetdirect, Printer-WEB, IP Camera-WEB, UPnP, RTSP, CDP, TP-
link WEB, CWMP, SAP DISPATCHER, SAP WEB, MOXA, MQTT WEB, CoAP,
SIP, and XMPP WEB

SSL VPN HTTPS

Customized Windows RDP, SMB, NBNSSpoofSpotter, MSSQL, IS (HTTP/HTTPS), ICMP,
TCPListener, SMTP, SWIFT Lite2 and FTP

The current FortiDeceptor IP address capacity are:

« Asingle EOL can host up to 16 deception VMs.

e Asingle FDCIKG can host up to 20 deception VMs.

o Asingle FDCVMS can host up to 20 deception VMs.

« A single deception VM supports up to 24 IP addresses or decoys. Each IP represents a decoy.
« Asingle FortiDeceptor appliance (HW/VM) can support up to 480 IP addresses.

» Asingle FortiDeceptor appliance (HW/VM) can support up to 128 segments (VLANS).

ﬂ VPN only supports 8 IPs.
I Cisco Decoy only supports 1VLAN.

Decoy services details

e 0T OS on page 169

o Medical on page 172

o POSonpage 172

e CRM(ERP)on page 172
« SAPonpage 172

« SCADA

e VOIP V1 OSon page 179

loT OS

Brother MFC Printer Decoy

Service Description

SNMP ¢ Enable this service to open port 161 on the decoy VM, and respond to SNMP
(v1 or v2c) request from within the network.
e Community name is user-defined.
* SNMP response is customized for Brother MFC Printer decoy.
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Service Description

Jetdirect Enable this service to open port 9100 on the decoy VM and respond to PJL
(Printer Job Language) requests.

Printer-WEB A web GUI that simulates the administration GUI of Brother NC-340h printer.

Cisco router decoy

Service Description
Models* 4 Cisco images (models) are supported: 2691, 3660, 3725 and 3745.

An error is displayed if you upload an image that is not supported.
Router Running-Config Allows you to upload a customized Cisco config file to predefine the Cisco router
(optional) setting
Telnet service A login-required service that enables attackers to utilize all Cisco router functions.
HTTP service A login-required GUI service similar to the telnet service but with less functionality.
SNMP service ¢ Enable this service to open port 161 on the decoy VM, and respond to SNMP

(v1 or v2c) requests from within the network.
e Community name is user-defined.
e SNMP response is customized for Cisco router decoy.

CDP service Enable this service to allow the decoy VM to send CDP traffic within the network.

*Please provide Cisco I0S software to run the Cisco decoy. You can copy the 10S from any Cisco router/switch flash by
using TFTP server and running the copy flash tftp: command on the Cisco router/switch side, and then
completing the deployment wizard.

HP printer decoy

Service Description

SNMP service « Enable this service to open port 161 on the decoy VM, and respond to SNMP
(v1 or v2c) requests from within network

e Community name is user-defined
* SNMP response is customized for HP printer decoy.

Jetdirect ¢ Enable this service to open port 9100 on the decoy VM, and respond to PJL
(Printer Job Language) requests.

Printer-WEB ¢ A web GUI that simulates the administration GUI of HP Officejet Pro X451dw
printer.

IP camera decoy

Service Description
IP Camera-WEB » Alogin-required service that displays videos to simulate IP cameras. Default
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Service Description

videos are available. However, we strongly recommend uploading 1-8 .mp4
videos that fit best with the working environment.

SNMP service « Enable this service to open port 161 on the decoy VM, and respond to SNMP
(v1 or v2c) requests from within the network

¢ Community name is user-defined.
¢ SNMP response is customized for IP camera decoy.

UPnP service * Enable this service to open port 8080 on the decoy VM and simulate UPnP
service.
¢ A UPnP msg will broadcast within the network. Within the msg there is a URL
for the attacker to download a .xml/ file showing device information.

RTSP service * When this service is enabled, you will also need to upload a video to a
predefined location so the attacker can watch the video.

¢ The RTSP port can be adjusted.

» To upload the video, you can use ffmpeg, or any other method to infinitely
loop a video so it is available to the attacker

Example:

To infinitely loop a video:sudo ffmpeg -re -stream loop -1 -i {path
to local video} -c copy -f rtsp rtsp://{ip}:{port}/{name
you choose};

From the attacker perspective, the live camera stream is available at rtsp: //
{ip}:{port}/{name_ you choose}

Lexmark Printer decoy

Service Description

SNMP » Enable this service to open port 161 on decoy VM, and respond to SNMP(v1
or v2c) request from within the network.
e Community name is user-defined.
e SNMP response is customized for Lexmark Printer decoy

Jetdirect Enable this service to open port 9100 on the decoy VM and respond to PJL
(Printer Job Language) requests.

Printer-WEB A web GUI that simulates the administration GUI of Lexmark MX410de printer.

TP-LINK decoy

Service Description

TP-LINK WEB Enable this service to allow attackers to login to a fake TP-link setting site.
CWMP Enable this service to send data using CWMP protocol to {ip}:{port}/cpe.
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Medical

Service Description

Infusion Pump (Telnet) service ¢ Simulates Infusion Pump (telnet)
e A username/password is required to login.

Infusion Pump (FTP) » Simulates Infusion Pump (FTP)
¢ Ausername/password is required to login.
PACS service » Auser-defined name for the PACS system.
PACS-WEB service * Login-required web GUI for PACS, with existing medical data

¢ Port can be adjusted

DICOM Server service e Server port can be adjusted
» Server name can be adjusted
e DICOM operations (e.g. C-STORE, C-FIND) are supported

B. Braun Infusomat service e HTTP/S: Built-in web services to retrieve medical data
« CAN Bus Protocol (enable/disable)
¢ B.BRAUN (port 8080): Login-required web GUI for the B.Braun Infusomat
device

POS

Service Description

POS-WEB service ¢ Login-required web GUI simulate POS website
» Port can be adjusted

CRM(ERP)

Service Description

ERP-WEB service ¢ Login-required web GUI simulates ERP website
e Port can be adjusted

SAP

Service Description

SAP ROUTER » Enable SAP ROUTER Service so SAP Logon can configure the SAProuter
String.

» Use the default port to ensure SAP Logon can connect.

SAP DISPATCHER ¢ Enable SAP DISPATCHER so SAP Logon can get responses from the SAP

decoy.
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Service Description

¢ Use the default port to ensure SAP Logon can connect.

SAP WEB A fake SAP HTTP and HTTPS GUI for SAP Fiori Launchpad or Legacy WebGUI.

SCADA (version3) OS

Ascent Compass MNG decoy

Service Description

HTTP service ¢ Enable this service to capture attacks through HTTP on the default HTTP
port.

FTP service « Enable this service to capture attacks through FTP on the default FTP port

e FTP banner is user-defined.

SNMP service e Enable this service to open port 161 on the decoy VM and respond to SNMP
(v1 or v2c) request from within the network

e Community name is user-defined
e SNMP response is customized for Ascent Compass MNG decoy.

BACNET service « Enable this service to capture attacks through BACNET on the default
BACNET port.

Guardian-AST decoy

Service Description

Guardian-AST service » Enable this service to simulate an AST’s satellite communications remote
asset tracking system named Guardian.

» Todeploy a Guardian-AST decoy, this service must be enabled since it is the
only service available

IPMI Device decoy

Service Description

HTTP service « Enable this service to capture attacks through HTTP on the default HTTP
port.

SNMP service ¢ Enable this service to open port 161 on the decoy VM and respond to SNMP

(v1 or v2c) requests from within the network.
e Community name is user-defined.
* SNMP response is customized for IPMI Device decoy.

FTP service « Enable this service to capture attacks through FTP on the default FTP port.
e FTP banner is user-defined.
IPMI service « Enable this service to capture attack through IPMI on the default IPMI port.
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KAMSTRUP 382 decoy

Service Description
KAMSTRUP service ¢ Toggle to enable/disable this service. Enable this service to simulate a
Kamstrup device

* To deploy a KAMSTRUP decoy, this service must be enabled since it is the
only service available

Liebert Spruce UPS decoy

Service Description
TFTP Enable this to service capture attacks through TFTP on default TFTP port
SNMP ¢ Enable this service to open port 161 on decoy VM and respond to SNMP(v1

or v2c) requests from within the network.
e Community name is user-defined.
* SNMP response is customized for Liebert Spruce UPS decoy.

HTTP Enable this service to capture attacks through HTTP on default HTTP port.

Niagara4 Station decoy

Service Description

SNMP e Enable this service to open port 161 on the decoy VM and respond to SNMP
(v1 or v2c) requests from within the network.
e Community name is user-defined.
e SNMP response is customized for IPMI Device decoy.

HTTP Enable this service to capture attacks through HTTP on default HTTP port.
BACNET Enable this service to capture attack through BACNET on default BACNET port.

NiagaraAX Station decoy

Service Description

SNMP » Enable this service to open port 161 on the decoy VM and respond to SNMP
(v1 or v2c) requests from within the network.
e Community name is user-defined.
e SNMP response is customized for IPMI Device decoy.

HTTP Enable this service to capture attacks through HTTP on the default HTTP port.
BACNET Enable this service to capture attacks through BACNET on the default BACNET
port.
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PowerLogic ION7650 decoy

Service Description

SNMP ¢ Enable this service to open port 161 on the decoy VM and respond to SNMP
(v1 or v2c) requests from within the network.
e Community name is user-defined.
e SNMP response is customized for PowerLogic ION7650 decoy.

MODBUS Enable this service to capture attacks through MODBUS on the default MODBUS
port.

DNP3 Enable this service to capture attacks through DNP3 on the default DNP3 port.

HTTP Enable this service to capture attacks through HTTP on the default HTTP port.

Rockwell 1769-L16ER/BLOGIX5316ER decoy

Service Description

SNMP » Enable this service to open port 161 on the decoy VM and respond to SNMP
(v1 or v2c) requests from within the network.
e Community name is user-defined.
e SNMP response is customized for Rockwell 1769-L16ER/B LOGIX5316ER

decoy.
ENIP Enable this service to capture attacks through ENIP on the default ENIP port.
HTTP Enable this service to capture attacks through HTTP on the default HTTP port.

Rockwell 1769-L35E Ethernet Port decoy

Service Description

SNMP ¢ Enable this service to open port 161 on the decoy VM and respond to SNMP
(v1 or v2c) requests from within the network.
e Community name is user-defined.
» SNMP response is customized for Rockwell 1769-L35E Ethernet Port

decoy.
ENIP Enable this service to capture attacks through ENIP on the default ENIP port.
HTTP Enable this service to capture attacks through HTTP on the default HTTP port.
Rockwell PLC decoy
Service Description
HTTP service » Enable s this service capture attack through HTTP on the default HTTP port.
e HTTP page title is user defined.
TFTP service » Enable this service to capture attacks through TFTP on the default TFTP
FortiDeceptor 5.2.2 Administration Guide 175

Fortinet Inc.



Appendix B - Deception deployment best practices

Service Description
port.
SNMP service ¢ Enable this service to open port 161 on the decoy VM and respond to SNMP

(v1 or v2c) request from within the network.
e Community name is user-defined.
e SNMP response is customized for Siemens Rockwell PLC decoy.

ENIP service « Enable this service to capture attack through ENIP on the default ENIP port.
¢ ENIP serial number is user-defined.

GE PLC decoy

Service Description
HTTP service « Enable this service to capture attacks through HTTP on the default HTTP
port.
e HTTP page title is user defined.
TFTP service ¢ Enable this service to capture attacks through TFTP on the default TFTP
port.
SNMP service » Enable this service to open port 161 on the decoy VM and respond to SNMP

(v1 or v2c) request from within the network.
e Community name is user-defined.
e SNMP response is customized for GE PLC decoy.

ENIP service ¢ Enable this service to capture attacks through ENIP on the default ENIP port.
* ENIP serial number is user-defined.

Schneider EcoStruxure BMS server decoy

Service Description

SNMP service » Enable this service to open port 161 on decoy VM and respond to SNMP (v1
or v2c) requests from within the network.

e Community name is user-defined.
* SNMP response is customized for Schneider EcoStruxure BMS server

decoy.
BACNET service ¢ Enable this service to capture attacks through BACNET on the default
BACNET port.
HTTP service « Enable this service to capture attacks through HTTP on the default HTTP
port.
TRICONEX service ¢ Enable this service to capture attacks with the TRICONEX service.
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MOXA NPORT 5110 decoy

Service Description

SNMP service ¢ Enable this service to open port 161 on decoy VM and respond to SNMP (v1
or v2c) requests from within the network.
e Community name is user-defined.
¢ SNMP response is customized for moxa nport 5110 decoy.

Telnet service ¢ Login-required telnet service simulates moxa nport 5110 command line
environment.
e Two command choices: 1 and 2

HTTP service » Enable this service to capture attacks through HTTP on the default HTTP
port.

MOXA service « Download MOXA script from GitHub is required (https://github.com/Z-
One/MoxaNportScan)

Schneider Power Meter - PM5560 decoy

Service Description

SNMP service ¢ Enable this service to open port 161 on the decoy VM and respond to SNMP
(v1 or v2c) requests from within the network

e Community name is user-defined.
e SNMP response is customized for Schneider Power Meter - PM5560 decoy.

BACNET service « Enable this service to capture attacks through BACNET on the default
BACNET port.

HTTP service ¢ Enable this service to capture attacks through HTTP on default HTTP port.

DNP3 service ¢ Enable this service to capture attacks through DNP3 on the default DNP3
port.

ENIP service « Enable this service to capture attacks through ENIP on the default ENIP port.

Schneider SCADAPack 333E decoy

Service Description

SNMP service » Enable this service to open port 161 on decoy VM, and respond to SNMP(v1
or v2c) requests from within the network.

e Community name is user-defined.
e SNMP response is customized for Schneider SCADAPack 333E decoy.

DNP3 service ¢ Enable this service to capture attacks through DNP3.

Telnet service * Login-required telnet service simulates SCADAPack E Smart RTU command
line environment.
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Siemens S7-200 PLC decoy

Service Description

HTTP service ¢ Enable this service to capture attacks through HTTP on the default HTTP
port.

e HTTP page title is user defined.
¢ Plant Identification is user-defined.
e Serial Number is user-defined.

TFTP service ¢ Enable this to service capture attacks through TFTP on the default TFTP
port.
SNMP service e Enable this service to open port 161 on decoy VM, and respond to SNMP(v1

or v2c) request from within the network.
e Community name is user-defined.
e SNMP response is customized for Siemens S7-200 PLC decoy.

MODBUS service » Enable this service to capture attacks through MODBUS on the default
MODBUS port.

S7COMM service ¢ Enable this service to capture attacks through S7COMM on the default
S7COMM port.

¢ Module Type is user-defined.
e PLC Name is user-defined.

Siemens S7-300 PLC decoy

TFTP service « Enable this service to capture attacks through TFTP on the default TFTP
port.
SNMP service ¢ Enable this service to open port 161 on the decoy VM and respond to SNMP

(v1 or v2c) requests from within the network.
e Community name is user-defined.
¢ SNMP response is customized for Siemens S7-300 PLC decoy.

IEC104 service « Enable this service to capture attacks through IEC104 on the default IEC104
port.

Siemens S7-1500 PLC decoy

Service Description

HTTP service Enable this service to capture attacks through HTTP on the default HTTP port.
HTTP page title is user defined. Plant Identification is user-defined. Serial Number
is user-defined.

TFTP service Enable this to service capture attacks through TFTP on the default TFTP port
IEC104 service Enable this to service capture attacks through IEC104 on the default IEC104 port.
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Service Description

SNMP service Enable this service to open port 161 on decoy VM, and respond to SNMP (v1 or
v2c) request from within the network. Community name is user-defined. SNMP
response is customized for Siemens S7-1500 PLC decoy.

S7COMM service Enable this service to capture attacks through S7COMM on the default S7TCOMM
port. Module Type is user-defined. PLC Name is user-defined.

PROFINET service Enable this service to capture attacks through PROFINET

Phoenix contact AXC 1050 decoy

Service Description

HTTP service Enable this service to capture attacks through HTTP on the default HTTP port.
HTTP page title is user defined. Plant Identification is user-defined. Serial Number
is user-defined.

SNMP service Enable this service to open port 161 on decoy VM, and respond to SNMP (v1 or
v2c) request from within the network. Community name is user-defined. SNMP
response is customized for Phoenix contact AXC 1050 decoy.

FTP service Enable this service to capture attacks through FTP on the default FTP port FTP
banner is user-defined Anonymous Access can be enabled which let user enters
"anonymous" as a user ID and eliminate the need to authenticate themselves

PROFINET service Enable this service to capture attacks through PROFINET

VAV-DD BACNET controller decoy

Service Description

SNMP service » Enable this service to open port 161 on the decoy VM and respond to SNMP
(v1 or v2c) requests from within the network.

e Community name is user-defined.
¢ SNMP response is customized for VAV-DD BACNET controller decoy.

BACNET service ¢ Enable this service to capture attacks through BACNET on the default
BACNET port.
VOIP V1 OS
MQTT decoy
Service Description
MQTT WEB » Enable this service to capture attacks through MQTT WEB on the default
MQTT WEB port.

e Supports custom listening port. Default port is 18083.
e Supports adding User/Password.
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Service Description
CoAP ¢ Enable this to service capture attacks through CoAP on the default CoAP
port.

¢ Download 1ibcoap from GitHub is required. Go to
https://github.com/miri64/libcoap and follow the command 1ibcoap
command rule.

SIP decoy
Service Description
SIP » Enable this service to capture attacks through MQTT WEB on the default SIP
port.

e Supports adding User/Password.

» Users can connect to the SIP server from SIP client service (like Linphone)
through UDP or TCP, and register an account, text message, voice call, and
video call each other.

XMPP decoy
Service Description
XMPP WEB ¢ Enable this service to capture attacks through XMPP WEB on the default
XMPP WEB port.

e Supports custom listening port (default port is 5280).
e Supports adding User/Password.
e Can be reached through HTTP.

Deploying deception

To deploy FortiDeceptor to optimize the deception surface, see the following best practices.
Deception decoy best practices on page 180

Deception token best practices on page 184

AD integration best practices on page 185

Deployment best practices checklist on page 186

Network topology best practices on page 187

Deception decoy best practices

Deception effectiveness requires deployment across all network segments and locations.
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This topic provides deception deployment best practices for the decoy layer, including deployment guidelines for each
kind of network VLAN that can exist on an enterprise network.

Example of 5-8 decoys per data-center segment (VLAN)

0s

Deploy a matching decoy OS for each type of critical / sensitive IT system in this segment.

Services

Enable matching services for each type of critical / sensitive IT system in this segment and customize the services:

» Apply banner matching the network.
» Apply user access rule such as fake user and password.
» Upload fake data (SMB, FTP, HTTP).

If you do not have out-of-the-box matching services, you can use the custom TCP port listener.
Data

Upload fake data to the decoys to provide authentic engagement. If you do not have matching files, ask the customer to
provide a public files package that you can upload and generate fake data using the same structure.

Application

Enable a false matching application for each type of critical / sensitive IT system on this segment If you do not have a
matching application, enable high profile fake applications like ERP, POS, or PACS, and so on.

Hostname

Follow corporate standard server’s names for half the decoys and assign enticing names to the remaining half, such as
JumpHost001, ERP-XXX, MNG-XXX, Net-Monitor, and so on. Remember that we need to configure these hostnames
on the AD level as we use single deception VM across 16 IP address and we can have just one real hostname per OS.
For the rest of the IP address, we should have it virtual on the DNS level.

Attackers also like to attack servers with a hostname that has names like “-test” or “-dev” as attackers assume that these
servers are less protected.

Gold Image

Ensure you use at least two Windows servers as customer gold images that host critical applications and data. To
increase authenticity, configure them to be part of the organization domain.

STATIC / DHCP IP Address

For datacenter segment hosting servers that always use static IP addresses, also use static IP configuration for the
decoys.
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Example of 2-4 decoys per endpoint segment (VLAN)

0s

Deploy a matching decoy OS and also an “old’ OS like Win7.

Services

Enable matching services for the endpoint on this segment.

If you do not have out-of-the-box matching services, you can use the custom TCP port listener.
Data

Upload fake data to the decoys to provide authentic engagement. If you do not have matching files, ask the customer to
provide a public files package that you can upload and generate fake data using the same structure.

Hostname

Follow corporate standard server’s names for half the decoys and assign enticing names to the remaining half, such as
IT Admin, HelpDesk, DBA, Finance, and so on. Remember that we need to configure these hostnames on the AD level
as we use single deception VM across 16 IP address and we can have just one real hostname per OS. For the rest of the
IP address, we should have it virtual on the DNS level.

Gold Image

Ensure you use at least 3—4 Windows servers as customer gold images. To increase authenticity, configure them to be
part of the organization domain.

STATIC / DHCP IP Address

For endpoints segment hosting desktops that always use DHCP IP addresses, also use the DHCP IP configuration for
the decoys. The DHCP configuration in FortiDeceptor 3.1 and 3.2 allows us to configure one IP per segment, so use the
static configuration in this stage to have more decoys per segment.

Example of 7-10 decoys per OT segment (VLAN)

0s

Deploy a matching decoy SCADA OS.
Deploy a matching regular IT OS such as Win7, Win10, or Win2016.

Services

Enable matching services for the OT assets on this segment and customize the services.

o Apply banner matching the network.
« Apply access rule such as fake user and password.
» Upload fake data (SMB, FTP, HTTP).

If you do not have out-of-the-box matching services, you can use the custom TCP port listener.
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Data

Upload fake data to the decoys to provide authentic engagement. If you do not have matching files, ask the customer to
provide a public files package that you can upload and generate fake data using the same structure. You can also use a
search engine like SHODAN.IO to find this data on the Internet and use it to customize the decoys.

Hostname

Follow the OS SCADA names for half the decoys and assign enticing names to the remaining half, such as IT Admin,
SCADA-MNG, PLC_ADMIN, HMI_SERVER, NET-MONITOR, and so on.

Application

Check if the customer is willing to provide you access to his OT software. Otherwise, use open-source OT software or
use the customize decoy option to generate this kind of decoy.

MAC ADDRESS

Ensure the OT decoy uses the appropriate MAC ADDRESS per vendor.

STATIC / DHCP IP Address

OT networks are mainly a static environment that does not has a DHCP server, so use static IP configuration as well for
the decoys.

Example of 8-10 decoys per cloud segment (VPC, VNET)

0os

Deploy a matching decoy OS for each type of critical / sensitive IT system in this segment.

Services

Enable matching services for each type of critical / sensitive IT system in this segment and customize the services:

« Apply banner matching the network.
o Apply user access rule such as fake user and password.
o Upload fake data (SMB, FTP, HTTP).

If you do not have out-of-the-box matching services, you can use the custom TCP port listener.

Data

Upload fake data to the decoys to provide authentic engagement. If you do not have matching files, ask the customer to
provide a public files package that you can upload and generate fake data using the same structure.

Application

Enable a false matching application for each type of critical / sensitive IT system on this segment. If you do not have a
matching application, enable high profile fake applications like ERP, POS, or PACS, and so on.
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Hostname

Follow corporate standard server’s names for half the decoys and assign enticing names to the remaining half, such as

JumpHost001, WEB-XXX, DB-XXX, Sec-Monitor, and so on. Remember that we need to configure these hostnames on
the AD level as we use single deception VM across 16 IP address and we can have just one real hostname per OS. For

the rest of the IP address, we should have it virtual on the DNS level.

Attackers also like to attack servers with a hostname that has names like “-test” or “-dev” as attackers assume that these
servers are less protected.

Gold Image

Ensure you use at least two Windows servers as customer gold images that host critical applications and data. To
increase authenticity, configure them to be part of the organization domain.

STATIC / DHCP IP Address

Cloud environments mainly host servers that always use static IP addresses, so use static IPs configuration as well for
the decoys.

Deception token best practices

Deception effectiveness requires deployment across all managed endpoints and servers.

This topic provides deception deployment best practices for the deception token layer. For token deployment over AD
logon script, see appendix A.

Example of deception tokens on Windows, MAC, or Linux endpoint segment (VLAN)

RDP token

« Set up several Windows server decoys that support RDP access.

» Set up appropriate decoy hostnames like Terminal-XX, VDI-XX, and so on. This increases the level of authenticity
when you add the Windows server decoys to the company domain.

» Follow company username and password policy.
o Generate 2-3 deception lures and deploy them over several different AD user groups.

SMB token

For Windows endpoints, use either SMB token or SAMBA token. Do not use both.

o Set up at least two Windows server decoys that support two fake network share access.
» Generate at least two tokens with two different share names.
o Use a share name similar to the company structure.

» Set up appropriate hostnames like FileSRV-XX, File-Server, and so on. This increases the level of authenticity
when you add the Windows server decoy to the company domain.

» Follow company username and password policy.
« Generate a single deception token package and deploy it over all the network endpoints.
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SAMBA token

For Windows endpoints, use either SMB lure or SAMBA token. Do not use both.

Set up at least two Linux server decoys that support network share access.

Set up appropriate hostnames like Storage-XX, Backup-Server, and so on.

Generate at least two tokens with two different share names.

Use a share name similar to the company structure.

Follow company username and password policy.

Generate a single deception token package and deploy it over all the network endpoints.

SSH lure

Set up several Linux server decoys that support SSH access.
Set up appropriate hostnames like JumpHost-XX, Control-XX, Cloud-XXX, and so on.
Use a complicated password. This gives the attacker the impression that this is a critical server.

Generate 2-3 deception tokens and deploy them over the IT endpoints group only. Attackers do not expect to see
SSH clients on a regular desktop.

AD integration best practices

Active Directory (AD) is Microsoft's proprietary directory service. It runs on Windows Server and allows administrators to
manage permissions and access to network resources. Active Directory stores data as objects. An object is a single
element, such as a user, group, application; or device, such as a printer.

To detect AD attack using deception technology, use the following deception configuration example.

» Deploy custom Windows decoys (Windows 10, Windows 11, Windows Server 2016, Windows Sever 2019,

Windows Sever 2022, French Windows 10, French Windows Server 2016) and add them to the customer network
domain.

Example of custom decoys in customer network domain

Add several custom Windows decoys to the customer network domain.

On the Windows domain, configure schedule task scripts to run using the fake users, such as the one from the
cache credentials lure.

Add to each domain decoy the maximum number of IP addresses and ensure they are static IP addresses.
On the network DNS server, configure a decoy DNS.
« Add DNS records to each decoy IP address.

» Set up attractive hostnames for each decoy IP address. For more information, see Deception decoy best
practices on page 180.
Deploy the SMB lure front in a domain decoy to avoid detection by tools like HoneyBuster.
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Deployment best practices checklist

This checklist is an example of a deception deployment profiling and sizing. This example is based on a company with
one headquarters (HQ) site and two remote sites, one of which is a manufacturing site.

Deception
Items

FortiDeceptor
appliance
HW/VM

HQ site
installation

Number of
remote sites

Remote sites
are office / OT
network

Number of
segments
(VLANS) to
cover

Number of DC
segments to
cover

Customer's
server OS

Critical services
inthe DC
segments

Number of
endpoint
segments to
cover

Customer's
endpoint OS

Customer
Requirements

VM

Yes

1 remote office + 1
manufacture site

30

Windows, Linux

SAP, web logistic
app

25

Windows, MAC
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Deployment

The VM supports VMware, Hyper-V or KVM.

Deploy on the company ESXi where you have access to most of the network
VLANSs.

If the primary and remote locations are connected by FortiGate firewall,
configure the VXLAN tunnel between firewalls to publish decoys over the L2
tunnel from the HQ to the remote sites. For details on setting up the VXLAN,
see
https://kb.fortinet.com/kb/microsites/search.do?cmd=displayKC&docType=
kc&externalld=FD47325&sliceld=1&docTypelD=DT_KCARTICLE_1_
1&dialoglD=163742631&stateld=1%200%20163740760%27.

If the firewalls are different, check with Customer Support on how to configure
an L2 Tunnel.

For remote office site, deploy Windows / Linux desktop decoys and deception
lures like SMB, RDP and cache credentials.

For remote OT site, deploy Windows / Linux and SCADA decoys.

Deploy Windows / Linux server decoys.

Deploy Windows / Linux server decoys.

Deploy ERP decoy, Windows decoy with a web app.

Deploy Windows / Linux desktop decoys.

Deploy deception lures such as SMB, RDP, and cache credentials for both
Windows and MAC.
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Deception Customer Deployment
Items Requirements
Customer's SAP Deploy Windows decoy with SQL that uses SAP fake data.

most important
asset to protect

Attack vectors Phishing, PTH, Deploy deception lures like SMB, RDP, and cache credentials. Follow cache
customer is lateral movement  credentials best practice.

facing based on AD

Customer Printer, camera,

network's loT temp sensors

devices

Customer SCADAPLC, HMI  Deploy Windows / Linux and SCADA decoys.

network's OT

devices

Customer Yes Configure Security Fabric integration for isolation mitigation response.
FortiGate

firewall solution

Customer SIEM  Yes Send SYSLOG from the FDC.

solution Configure a correlation rule to detect lateral movement based on cache

credentials lure.

Network topology best practices

For effective deception, you must also understand the customer's network topology, company security risks, where his
most important assets are located, and what kind of attack vectors they face or have concerns.

Several common network topologies require different deception deployment approaches.
This topic provides best practices for the following scenarios:

1. Network with data center and users at the same location.
2. Network with a data center, users at the same location, and users at remote offices.
3. Network with a data center, users at the same location, users at remote offices, and remote OT sites.

Deception deployment in HQ only

A network topology without remote location is less common today. The reasoning might be that the most important
assets are in HQ only and there is no need to deploy deception in remote sites.
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This scenarios shows deploying deception in the main HQ only even if there are also remote locations.
4
INTERNET

MAIN SITE

WEB
E. F SWITCH L3
- Desktop Desktop

Decoys Decoys USERS

AD/DNS

DATA CENTER

g VLAN1 VLANS
SRV
SAP Decoys
Deception
Tok
N DB RDP.SMB,SSH
FINANCE ’ ’
< 3
@ 1 Etherhet— LAN N
| | J :
DATA CENTER = :
VLAN2 | Desktop
sry Decoys
= Decoys &
SECURITY @ FDC
VLAN
TRUNK

In this scenario, follow these best practice recommendations:

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.

188



Appendix B - Deception deployment best practices

Deception deployment in HQ and remote offices
Network topology with remote locations is the most common enterprise network topology for installations that want to
provide the same security protection across all sites.

The level of connectivity required by remote office users is broader and will lead to a data breach if the security level is
not similar to the HQ security.
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RDP,SMB,SSH RDP,SMB,SSH Decoys
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| \J LAN ] Deception
DATA CENTER
b FDC Manager (" Ethernet Tokens
y g LN 5 RDP,SMB.SSH
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RP/SAP Decoys \ / sl
VLAN TRUNK Decoys

In this scenario, follow these best practice recommendations:

« Deploy a single FortiDeceptor appliance and connect it to the network via trunk to cover most of the HQ network
VLANSs.

» Deploy decoys following the best practice recommendation in Deception decoy best practices on page 180.
o On data center VLANSs: 5-7 decoys per VLAN.
e On endpoint VLANSs: 2-4 decoys per VLAN.
« Deploy deception lures across all manageable endpoints even if some of them are in remote sites.
« RDP
« SMB
« Cached credentials
+ HoneyDocs
SSH (on IT department desktops only)
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« Fabric integration.

« Ifyou have FortiGate, consider the integration value between FortiDeceptor and FortiGate for alert mitigation
by isolating the infected machine.

» Send SYSLOG to SIEM or any logger solution in place.

* Send SYSLOG to SOAR solution for Deception playbooks. For example, FortiSOAR has pre-built deception
playbooks for FortiDeceptor.

Deception deployment in HQ, remote offices, and OT sites

Network topology with remote location (offices + OT sites) is very common for manufacturing, critical infrastructure, and
energy companies. The OT site presents a security challenge due to its environmental complexity, such as legacy OSes,
non-standard devices and protocols, and so on.
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In this scenario, follow these best practice recommendations:
« Deploy a single FortiDeceptor appliance and connect it to the network via trunk to cover most of the HQ network
VLANS.
» Deploy decoys following the best practice recommendation in Deception decoy best practices on page 180.
« On data center VLANSs: 5-7 decoys per VLAN.
« On endpoint VLANSs: 2-4 decoys per VLAN.
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« Deploy deception lures across all manageable endpoints even if some of them are in remote sites.
« RDP
« SMB
« Cached credentials
+ HoneyDocs
o SSH (on IT department desktops only)
« Fabric integration.

« Ifyou have FortiGate, consider the integration value between FortiDeceptor and FortiGate for alert mitigation
by isolating the infected machine.

e Send SYSLOG to SIEM or any logger solution in place.

» Send SYSLOG to SOAR solution for Deception playbooks. For example, FortiSOAR has pre-built deception
playbooks for FortiDeceptor.

Attack vectors vs deception

This section shows the best practices for attack vectors vs deception.
Compromised internal endpoint using lateral movement on page 191
Lateral movement based on AD mapping on page 193

Lateral movement based on Mimikatz / PTH on page 194

Compromised internal endpoint using lateral movement
This scenario shows a human attacker trying to compromise an internal endpoint using lateral movements.

Attack vector scenario

An attacker uses a phishing email to compromise the internal user and get access to an internal endpoint.

The attacker then explores the compromised endpoint and collect intelligence on the network before running any
privileged escalation or lateral movement.

Attacker's possible first steps on the compromised endpoint:

» Use network commands to understand the network environment and the endpoint location, such as getting
information on critical servers and sensitive application locations.

« Access the local / network drive to find information like sensitive files, credentials, and more. The attacker is building

the lateral movement route.

« Extract/dump saved password from Windows Credential Manager, browser, or memory, whether in clear text or
hashed.

Deception layer

Use SMB deception lures that generate fake network drive fronts with a file server decoy with fake files. The fake
network drive configuration is hidden to avoid users from opening it and generating false alerts. Keep in mind that the
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SMB lure also inserts fake credentials to the Windows credentials manager as well.

Use RDP deception lures that store saved usernames and passwords in the Windows Credential Manager that provides
access to a Windows / Linux server decoy.

Use Cached credentials lures that inject saved usernames and passwords in the Windows memory to detect attacks
using password dump like Mimikatz. Use a real domain user with IP restrictions.

Early breach detection

Since most users store data on the network drive, when an attacker finds that the compromised endpoint has a local disk
and network drive, the attacker will likely access the fake network drive and generate alerts.

Attackers might use a tool like MIMIKATZ to extract clear-text password. An attacker engaging with a decoy using the
extracted password generates alerts.

Alert details

The FortiDeceptor console presents the alert as a kill chain flow and presents a profile of the attacker. The alert data
includes:

« Attacker username.
« One of the most critical indicators that provide a quick answer regarding the attacker, attack stage, and phase.

« A standard user means that the attacker / attack is in the early stage. Admin-level credentials means that the
attacker / attack is in the privilege escalation phase or the attack was directed against high profile users from
the IT department.

o Compromised IP address.

» This is a critical indicator that points directly to the compromised host. Early detection prevents more persistent
points by the attacker.

« Data that has been accessed by the attacker.

« To see what data an attacker wants to access and steal, one way is to deploy interesting fake data that
resembles your organization's real data.

« Another way is to deploy a decoy file server with a structure that contains at least ten fake directories that
resemble your organization’s real server.

» You can monitor what data the attacker accesses or copies to assess the attacker's goal.
« Malicious binary.

« For example, if the attacker engages with a decoy over RDP, the attacker will likely use malicious code to get
more persistent and privilege access. So having malicious binary as a piece of evidence with the full binary
analysis helps IOC look across the network for more compromised endpoints. You can use an IOC scanner or
AV/EDR API to find the indicators across network endpoints and servers.

ECO system flow:

» Send alerts to your SIEM solution.
« Use your FortiGate Fabric integration to isolate the compromised endpoint from the network.
« Deploy more decoys on the isolated segment to keep monitoring the compromised endpoint.
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Lateral movement based on AD mapping

This scenario shows a human attacker trying to compromise an internal endpoint using lateral movements based on AD
mapping.

Attack vector scenario

An attacker uses a phishing email to compromise the internal user and get access to an internal endpoint.

The attacker uses the compromised user credentials to passively map the network and collect information without
generating network noise.

The attacker uses the compromised user credentials to run LDAP queries against the AD to retrieve asset inventory
since all users have read-only access on AD objects.

Leveraging the AD asset inventory saves the attacker from running active port scan mapping that generates network
noise that can expose his malicious activity.

Attacker's toolkit for AD attack:

o PS script or LDAP query command tools to extract company endpoint and server assets.

» Analyze the hostname to find assets where the hostname reflects their role or dev / test servers that might not be
protected like the rest of the network.

Deception layer

* Deploy Windows decoys and add them to the network Domain
+ Add DNS A record using attractive hostnames for all domain decoys' IP address. Each decoy supports up to 24 IPs.

» Use SMB deception lures that generate a fake network drive share on the endpoint that mapped front a file server
decoy with fake files. The fake network drive configuration is hidden to prevent users from opening it and generating
false alerts. Keep in mind that the SMB lure also inserts fake credentials to the Windows credentials manager as
well.

» Use RDP deception lures that store saved usernames and passwords in the Windows Credential Manager that
provides access to a Windows / Linux server decoy.

« Use Cached credentials lures that inject saved usernames and passwords in the Windows memory to detect
attacks using password dump like Mimikatz. Use a real domain user with IP restrictions.

Early breach detection

When the attacker retrieves asset inventory from the AD and starts probing the attractive servers based on their
hostname or the fake network connection, these activities generate alerts.

Alert details
The FortiDeceptor console presents the alert as a kill chain flow and presents a profile of the attacker. The alert data
includes:

« Attacker username.
« One of the most critical indicators that provide a quick answer regarding the attacker, attack stage, and phase.
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« A standard user means that the attacker / attack is in the early stage. Admin-level credentials means that the
attacker / attack is in the privilege escalation phase or the attack was directed against high profile users from
the IT department.

o Compromised IP address.

« This is a critical indicator that points directly to the compromised host. Early detection prevents more persistent
points by the attacker.

« Malicious binary.

« Forexample, if the attacker engages with a decoy over RDP, the attacker will likely use malicious code to get
more persistent and privilege access. So having malicious binary as a piece of evidence with the full binary
analysis helps I0C look across the network for more compromised endpoints. You can use an IOC scanner or
AV/EDR API to find the indicators across network endpoints and servers.

ECO system flow:

» Send alerts to your SIEM solution.

» Use your FortiGate Fabric integration to isolate the compromised endpoint from the network. FortiDeceptor offers
more fabric connectors for isolation.

» Deploy more decoys on the isolated segment to keep monitoring the compromised endpoint.

Lateral movement based on Mimikatz / PTH

This scenario shows a human attacker trying to compromise an internal endpoint using lateral movements based on
Mimikatz / PTH.

Attack vector scenario

An attacker uses a phishing email to compromise the internal user and get access to an internal endpoint.
The attacker looks for any powerful user in the compromised endpoint.

The attacker / APT uses an advanced tool like Mimikatz to run several attacks to extract clear text passwords from
memory or Windows Credential Manager, AD Kerberos tickets, Windows local hash, and so on.

The Mimikatz tool's goal is to get administrator-level permission and run in-depth lateral movement across the network.

Attacker's toolkit:

o Tools like Mimikatz, Meterpreter, password dump, and so on.
« Leverage services like RDP, RPC, WMI, VNC, SSH, and WINRM for lateral movement.

Deception layer

» Deploy Windows decoys and add them to the network Domain.

» Add DNS A record using attractive hostnames for all domain decoys' IP addresses. Each decoy supports up to 24
IPs.

» Use SMB deception lures that generate a fake network drive share on the endpoint that mapped front a file server
decoy with fake files. The fake network drive configuration is hidden to prevent users from opening it and generating
false alerts. Keep in mind that the SMB lure also inserts fake credentials to the Windows Credential Manager as
well.
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+ Use RDP deception lures that store saved usernames and passwords in the Windows Credential Manager that
provides access to a Windows / Linux server decoy.

» Use Cached credentials lures that inject saved usernames and passwords in the Windows memory to detect
attacks using password dump like Mimikatz. Use a real domain user with IP restrictions.

Early breach detection

An attacker using fake credentials in the sRDP lure to engage with a decoy generates alerts.

An attacker engaging with a real asset using the fake username and password (in the cache credential lure) generate an
alert on the SIEM solution. This requires a SIEM correlation rule.

Alert details

The FortiDeceptor console presents the alert as a kill chain flow and presents a profile of the attacker. The alert data
includes:

» Attacker username.
» One of the most critical indicators that provide a quick answer regarding the attacker, attack stage, and phase.

« A standard user means that the attacker / attack is in the early stage. Admin-level credentials means that the
attacker / attack is in the privilege escalation phase or the attack was directed against high profile users from
the IT department.

o Compromised IP address.

« This is a critical indicator that points directly to the compromised host. Early detection prevents more persistent

points by the attacker.
« Malicious binary.

« Forexample, if the attacker engages with a decoy over RDP, the attacker will likely use malicious code to get
more persistent and privilege access. So having malicious binary as a piece of evidence with the full binary
analysis helps 10C look across the network for more compromised endpoints. You can use an IOC scanner or
AV/EDR API to find the indicators across network endpoints and servers.

ECO system flow:

» For SIEM:
« Send alerts to your SIEM solution.
» Create a correlation rule that creates an alert on using the fake username (cache credential lure.
» Use your FortiGate Fabric integration to isolate the compromised endpoint from the network. FortiDeceptor offers
more fabric connectors for isolation.
« Deploy more decoys on the isolated segment to keep monitoring the compromised endpoint.

Deploying tokens using AD GPO logon script

FortiDeceptor generates a deception lure package based on the decoy service configuration. For example, deploying a
Windows server decoy with the services RDP and SMB, and Linux desktop decoy with the services SSH and SAMBA
generates a deception lure package named FDC_TokenPKG_XXXXXXXXX that contains the deception lure files.

The deception lure package is a zip file that has three directories containing all the relevant data and configuration for
each OS.
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The deception lure for each OS uses the same concept: binary files with several JSON files that provide the decoy fake
access parameters for the lure.

There are two ways to assign logon scripts. The first is on the Profile tab of the user properties dialog in the Active
Directory Users and Computers (ADUC). The second is via Group Policy Objects (GPO).

This section provides in-depth instructions on how to deploy Windows lures using the second option via AD GPO logon
script.

The main idea for the GPO logon script distribution is:

» Place the deception lure package in a network directory that is accessible to all endpoints.

« Generate a batch file that runs under the logon script and runs each time the end user logs into the network domain.
» The batch file copies the deception lure package to the endpoint and executes it.

« After execution, the endpoint has the deception lure in place.

To prepare the GPO logon script:

Download the deception lure package from the FortiDeceptor Admin Console.
Unzip the downloaded file to a temporary location.

Open the unzipped file and access the windows directory.

Copy all the files and directories, except uninstall.bat, from the windows directory:

e windows_ token.exe

P obh-=

« Config.json
« res directory (ifitis there)
e Honeydocs directory (if it is there)
5. Onthe AD server, goto \\%UserDNSDomain%\SysVol\domain\scripts
In this example, the domain is FDC.COM so the location is \\FDC.COM\SysVol\FDC.COM\scripts.
6. Inthe scripts directory, create a new directory and name itMyFiles.
7. Copywindows_token.exe andthe res directory to the MyFiles directory.

8. Create a batch file named Lure . bat with the following commands. In this example, the domain is FDC.com.
set SFolder=\\FDC.COM\SysVol\FDC.COM\scripts\MyFiles
set DFolder=%UserProfile$%
xcopy /E /S /H /K /F /C /Y /I "%$SFolder%" "%DFolder%\MyFiles"
start /B /WAIT /MIN "windows_ token" "%DFolder%\windows token.exe" "--non-interactive"
exit
A similar script for token installation is:
set SFolder=\\FDC.COM\SysVol\FDC.COM\scripts\MyFiles
start /B /WAIT /MIN "windows token" "$SFolder$%\windows token.exe" "--keep-files" "--non-
interactive" B B
exit
Syntax example:

windows token.exe "[optional command]" "<optional parameters>"...

Command ¢ (blank): The default command both uninstalls previous lures (if
applicable), and installs the new lures.
e uninstall: Uninstalls all previous installed lures (if applicable) for the
current user.
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Parameters --non-interactive: (Optional) Used with any command, this parameter
prevents any user interface from being displayed while the command is being
executed.

--keep-files (Optional) Keep the installation files/directories. Otherwise,
all files and directories in the current folder will be wiped out.

9. (Optional) *The default installation process both uninstalls previous lures (if applicable), and installs the new lures.
To uninstall tokens without installation:
a. Copywindows_token.exe from the windows directory to the MyFiles\Uninstall directory.
b. Create a batch file named uninstall lure.bat with the following commands.
In the following example, the domain is FDC.com:

set SFolder=\\fdc.com\SYSVOL\fdc.com\scripts\MyFiles\Uninstall

start /B /WAIT /MIN "uninstall windows token" "%SFolder%\windows_ token.exe"
"uninstall" "--non-interactive"

exit

Configuring the GPO logon script

To configure the GPO logon script:

1. Loginto the AD server and open the Group Policy Management tool.
You can also open this tool using the CLI gpmc . msc.

2. Right-click the top-level domain object (in this example, FDC.COM) and select Create a GPO in this domain, and

link it here.
This creates a new group policy object.
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3 WMI
: ] Starte Group Policy Modeling Wizard... )51 FDC.COM is the baseline domain controller fo
{3 Sites New Organizational Unit
st% Group Policy : ists for this d
«« Group Policy Search... e
Change Domain Controller... below to gather infrastructure status from all of th
Remove

Active Directory Users and Computers...

View »
New Window from Here

Refresh

3. Enter a name for the new group policy object. Do not use a name that has any association with a deception
technology.
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2 Group Policy Management FDC.COM
v £ Forest FOCCOM Status  Linked Group Policy Objects  Group Policy Inheritance  Delegation
v 55 Domains
v @ FDCCOM This page shows the status of Active Directory and SYSVOL (DF5R) replication for this domain as it relates to Group Policy.

i/ Default Domain Policy
2| Domain Controllers

"' Group Policy Objects
5 WMI Filters Status Details

3 Starter GPOs D !
B Si'tesg iy 9H|New GPO l X

Wy G Policy Modeli
S N No Infrastructure St _Name:

= Group Policy Results [—’—
Click the Detect No Ll I is domain.

Source Starter GPO:

none) v

[ ok | | Cancel

4. Right-click the new group policy object and select Edit.
Go to User configuration > Policies > Windows Settings > Scripts (Logon/Logoff).
6. Inthe right pane, double click the Logon script to configure the Logon script properties.

o

=/ Group Policy Management Editor — O ™
File Action View Help

o | 27 = HE

I=/ FDC [WIN-9N771200051.FDC.COM] Policy | .=

v & Computer Configuration “" S o
Select an item to view its description.  Name

. || Policies
> | Preferences
vy S Togon

v || Policies

L wingows setting: |
& Scripts (Logon/Logoff)

s Ta Security Settings

» [ Folder Redirection

> gl Policy-based QoS

» = Deployed Printers

_| Administrative Templates: Policy defir|

| Preferences

< > '\\_\ Extended fr(\Standard /

7. Inthe Logon Properties dialog box, click Show Files.
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8. Copy the batch file Lure .bat that you have prepared.

FDC
Scope Detals Settings Delegation
Logon Properties ? X
Scripts  PowerShell Scripts
QEJ Logon Scripts for FDC Path
- FOC.COM
Name Parameters | M = | Logon = O X
P Home Share View - )
Down
—| 1T~ Scripts » Logon v Search L¢
Name
N s FF Quick access
Edit m Desktop P This folder is empty.
Remove & Downloads -
Documents *
: < e ; = Pictures »
To view the script files stored in this Group Policy Object, press
the button below.
|  =ThisPC
==
 e— 1 Network
0K Cancel Apply < >
0 items
5 _—

| <none>

9. Inthe Logon Properties dialog box, click Add to open the Add a Scriptdialog box.
10. Click Browse, locate the Lure.bat batch file and add it to Scripts (Logon/Logoff).

{

FDC
Scope Details Settings Delegation
Logon Properties ? X Add a Script =
i i ~
Scripts  PowerShell Scripts Script Name:
=] Logon Scripts for FOC | | [(oowse ]
< J
Script Parameters:
Name Parameters l J
Up
Down oK Cancel
Browse
o Organize + New folder Bz = I
%) Documents # »  Name Date modified
[&] Pictures +
E:ewmeb:gipt files stored in this Group Policy Object, press s No items match your search,
4 utt 2
sl [ This PC
— =¥ Network
oK Cancel Apply
File name: “ v] Al Files
<none> ~ Oper| Open Cal
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11. Click Apply and then click OK to close this window.

To enforce the group policy:

1. Inthe Group Policy Management console, select the new group policy object. In this example, FDC.COM.

2. Inthe Scope tab, verify that FDC.COM is linked.

3. Inthe Security Filtering section, add and remove the user groups to get the deception lure package through the
logon script.

4. Inthe left pane, right-click the FDC group policy object and select Enforced.
& Group Policy Management FDC

v A\ Forest: FDC.COM

- Details Settings Delegation
v [ Domains

v 3 FDC.COM "’“"’ o
| Default Domain Policy Display links in this location: FDC.COM
4 FDC The following sites, domains, and OUs are linked to this GPO:
= | Domain Controllers _ ~ -
“+ Group Policy Objects Location Enforced Link Enabled Path
% WMI Filters g3 FDC.COM No Yes FDC.COM
] Starter GPOs
i@ Sites

s8¢ Group Policy Modeling
. Group Policy Results Security Filtering
The settings in this GPO can only apply to the following groups, users, and computers:

-

Name
Authenticated Users
Add... Remove Properties

Deploying AWS deception keys

To deploy AWS deceptions keys, first create the keys in AWS, then upload them to the FortiDeceptor and create a new
campaign.

To create an IAM user:

1. Log in to your AWS administrator account.
2. Goto Access Management > Users and click Add Users.
3. Inthe User details page, enter a User Name and click Next.

IAM > Users > Create user

Step1

Specify user details

Specify user details

Step2 User details

Set permissions

User name
Step3

Review and create managerHenry

The user name can have up to 64 characters. Valid characters: A-Z, a-z, 09, and + =, .@ _ - (hyphen)

[ Provide user access to the AWS Management Console - optional
If you're providing console access to a person, it's a best practice [ to manage their access in 1AM Identity Center.

@® If you are creating programmatic access through access keys or service-specific credentials for AWS CodeCommit or Amazon Keyspaces, you can generate them after you create this IAM user. Learn more [4

Cancel Next
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4. Onthe Set Permissions page, do not assign permissions, and click Next.

IAM > Users > Create user

Step1 e
Set permissions
Specify user details
Add user to an existing group or create a new one. Using groups is a best-practice way to manage user's permissions by job functions. Learn more [
Step2
Set permissions
Permissions options

Step 3

Review and create

© Add user to group Copy permissions Attach policies directly
Add user to an existing group, or create a new group. We recommend using Copy all group memberships, attached managed policies, and inline Attach a managed policy directly to a user. As a best practice, we
groups to manage user permissions by job function. policies from an existing user. recommend attaching policies to a group instead. Then, add the user ta the
appropriate group.

User groups (1)

Create group

Q. Search groups 1 &
(] Group name [4 a Users v Attached policies [7 v Created v
O = 0 None 2022-09-26 (7 months ago)

» Permissions boundary - optienal

Set a permissians boundary to eantrol the maximum permissions for this user. Use this advanced feature used to delegate permission management to others. Learn more [2]

Cancel
5. Onthe Review and create page, click Create User. The new user is created.
IAM > Users » Createuser
- Review and create
Specify user details
Review your choices. After you create the user, you can view and download the autogenerated password, if enabled.
Set permissions
User details
Review and create User name Console password type Require password reset
managerHenry None No
Permissions summary
1
Name [2 v Type v Used as v

No resources

Tags - optional

Tags are key-value pairs you can add to AWS resources to help identify, organize, or search for resources. Choose any tags you want to associate with this user.

No tags associated with the resource.

You can add up to 50 more tags.

Cancel

6. Create an access key for an AWS Connector user.

FortiDeceptor 5.2.2 Administration Guide 201
Fortinet Inc.



Appendix B - Deception deployment best practices

To create an AWS Connector user with AWSCloudTrail_ReadOnlyAccess permission:

1. Create a new AWS Connector user such as AWSKeyscon.

IAM > Users » Createuser

Step 1
Specify user details

Specify user details

Step 2 User details
Set permissions

User name
Step 3
Review and create AWSKeyscon
The user name can have up to 64 characters. Valid characters: A-Z, a-z, 0-9,and + =, . @ _ - (hyphen)

[] Provide user access to the AWS Management Console - optional
I you're providing console access to a person, it's 3 best practice [ to manage their access in IAM Identity Center.

@ If you are creating programmatic access through access keys or service-specific credentials for AWS CodeCommit or Amazon Keyspaces, you can generate them after

you create this IAM user. Learn more [

Cancel Next

2. Setthe permissions to Attach existing polices directly and select AWSCloudTrail_ReadOnlyAccess.

- Set permissions

Specify user details

Add user to an existing group or create a new one. Using groups is a best-practice way to manage user's permissions by job functions. Learn more [4

Step 2

Set permissions
Permissions options

Step3

Review and create -
O Copy permissions

Copy all group memberships, attached managed policies,
and inline policies from an existing user.

(O Add user to group
Add user to an existing group, or create a new group. We
recommend using groups to manage user permissions by job
function.

© Attach policies directly
Attach a managed policy directly to a user. As a best practice,
we recommend attaching policies toa group instead. Then,
add the user to the appropriate group.

Permissions policies (1/1090)

Choose one or more policies to attach to your new user.

Create policy [2

ilter distributions by text, property or value matcl
Q Filter distributions by il 1 match 1 o)
‘ Clear filters ‘
Policy name [2 a | Type v | Attached entities v
‘ = AWSCloudTrail_ReadOnlyAccess AWS man... 6

» Permissions boundary - optional

Set a permissions boundary to control the maximum permissions for this user. Use this advanced feature used to delegate permission management to others. Learn more [}
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3. Review the user permissions and click Create user.
Review and create

Review your choices. After you create the user, you can view and download the autogenerated password, if enabled.

Specify user details

Step2

Set permissions
User details

Step3

Review and create User name Console password type Require password reset
AWSKeyscon None No

Permissions summary

Name [2 v Type v Usedas v

AWSCloudTrail_ReadOnlyAccess AWS managed Permissions policy

Tags - optional

Tags are key-value pairs you can add to AWS resources to help identify, organize, or search for resources. Choose any tags you want to associate with this user.

No tags associated with the resource.

You can add up to 50 more tags.

o =

To grant an AWS connector user access to credential reports:

1. Go to Policies and create a custom policy such as fdcAWScredentialReport.
2. Click the Permissions tab and configure the permissions. For example:

{

"Version": "2012-10-17",
"Statement": {

"Effect": "Allow",

"Action": [
"iam:GenerateCredentialReport",
"iam:GetCredentialReport"

] 4

"Resource": "*"
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Policies > fdcAWScredentialReport

Summary

Policy ARN  arn:awsiam:" [ | “policy/fdcAWScredentialReport (]

Description GenerateCredentialReport and GetCredentialReport

Permissions Policy usage Tags Policy versions Access Advisor
Policy summary | {}JSON | Edit policy
{
"Version": ' s
"Statement™:
"Effect":
"Action":
"iam CredentialReport”,
"Lam:( i
1,
"Resource™: "*"
}

3. Goto /AM > Users and select the AWS Connector user such as AWSKeyscon, and then click Add Permissions.

AWSKeyscon

Summary

ARN Console access Access key 1
3 arn:aws:iam: Tl = @ ==./:user/AWSKeyscon Disabled Not enabled
Created Last console sign-in Access key 2
May 02, 2023, 10:17 (UTC-07:00) - Not enabled
Permissions Groups Tags Security credentials Access Advisor

Permissions are defined by policies attached to the user directly or through groups.

Q_ Find policies 1 o]
O Policy name [2 A Type v Attached via [2
[ ¥ AWSCloudTrail_ReadOnlyAccess AWS managed Directly

» Permissions boundary (not set)

Set a permissions boundary to control the maximum permissions for this user. Use this advanced feature used to delegate permission management to others. Learn more [/}
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4. Configure the permissions.

a.
b.

Under Permissions polices add the custom policy such as fdcAWScredentialReport.

Click Next.

IAM > Users » AWSKeyscon > Add permissions

Step 1

Add permissions Add permissions

Add user to an existing group or create a new one. Using groups is a best-practice way to manage user's permissions by job functions. Learn more [
Step 2
Review

Permissions options

Add user to group © Copy permissions

Copy all group memberships, attached managed policies,

inline policies, and any existing permissions boundaries from
an existing user.

Add user to an existing group, or create a new group. We
recommend using groups to manage user permissions by job
function.

O Attach policies directly

Attach a managed policy directly to a user. As a best practice,

we recommend attaching policies to a group instead. Then,
add the user to the appropriate group.

Permissions policies (1/1089)

‘ Q fdcAWScredentialReport X | 1 match

Create policy [4

1 @
Policy name [ a | Type v | Attached entities v
‘ [ fdcAWScredentialReport Customer managed 2 ‘
Review the User details and Permissions summary and click Add Permissions.
IAM > Users » AWSKeyscon » Add permissions
Step 1 .
Add permissions Review
The following policies will be attached to this user. Learn more [4
Step2
Review User details
User name
AWSKeyscon
Permissions summary (1)
1
Name [2 v Type Used as

fdcAWScredentialReport Customer managed

Permissions policy
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To create an access key for an AWS Connector user:

1. Goto IAM users and select a user such as AWSKeyscon, and then click the Security credentials tab.

IAM > Users » AWSKeyscon

AWSKeyscon Delete

Summary

ARN Console access Access key 1
@ arnawsiam:a @ B 1 7:user/AWSKeyscon Disabled Not enabled
Created Last console sign-in Access key 2
20" 2023, 10:17 (UTC-07:00) - Not enabled

Permissions Groups Tags Security credentials Access Advisor
Console sign-in Enable console access

Console sign-in link Console password
https:// “&gaidat = §1.signin.aws.amazon.com/console Not enabled

2. Under Access keys click Create access key.

Access keys (0)

Use access keys to send programmatic calls to AWS from the AWS CLI, AWS Toals for PowerShell, AWS SDKs, or direct AWS API calls. You can have a maximum of two access keys (active or inactive) at a time. Learn more [

Create access key

No access keys

As a best practice, avoid using long-term credentials like access keys. Instead, use tools which provide short term credentials. Learn more [4

Create access key
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3. Under Access key best practices & alternatives select Command Line Interface (CLI) and click Next.

Access key best practices & alternatives

Avoid using long-term credentials like access keys to improve your security. Consider the following use cases and alternatives.

© Command Line Interface (CLI)

You plan to use this access key to enable the AWS CLI to access your AWS account.

O Local code

You plan to use this access key to enable application code in a local development environment to access your AWS account

(O Application running on an AWS compute service

You plan to use this access key to enable application code running on an AWS compute service like Amazon EC2, Amazon ECS, or AWS Lambda
to access your AWS account.

(O Third-party service
You plan to use this access key to enable access for a third-party application or service that monitors or manages your AWS resources.

O Application running outside AWS

You plan to use this access key to enable an application running on an on-premises host, or to use a local AWS client or third-party AWS plugin

(O Other

Your use case is not listed here.

A Alternatives recommended
s Use AWS CloudShell, a browser-based CLI, to run commands. Learn more &

e Use the AWS CLI V2 and enable authentication through a user in 1AM Identity Center. Learn more [

I understand the above recommendation and want to proceed to create an access key.

4. (Optional) Set the description tag and click Create access key.

IAM D> Users » AWSKeyscon » Create access key

Step 1

Set description tag - optional

alternatives The description for this access key will be attached to this user as a tag and shown alongside the access key.

Access key best practices &

Step 2 - optional

Description tag value
Set description tag

Describe the purpose of this access key and where it will be used. A good description will help you rotate this access key confidently later.

Sive Maximum 256 characters. Allowed characters are letters, numbers, spaces representable in UTF-8, and: __:/ = +- @
Retrieve access keys
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5. Onthe Retrieve access keys page, click Download .csv file and then click Done.

IAM > Users » AWSKeyscon » Create access key

Step 1

Step 2 - optional

Step 3

Retrieve access keys

Retrieve access keys

Access key

I you lose or forget your secret access key, you cannot retrieve it. Instead, create a new access key and make the old key inactive

Access key Secret access key
AKIAYQPWFHIOXHL5DGIH Sriisse Show

Access key best practices

= Never store your access key in plain text, in a code repository, or in code.
- Disable or delete access key when no longer needed.

- Enable least-privilege permissions.

- Rotate access keys regularly.

For more details about managing access keys, see the Best practices for managing AWS access keys

[[Corvne v | o]

6. Inthe Permissions tab, ensure the AWS Keys Connector has the following two permissions: AWSCloudTrail-
ReadOnlyAccess and the custom policy such as fdcAWScredentialReport.

Q Search IAM

Dashboard

v Access management
User groups
Users
Roles
Policies
Identity providers

Account settings

¥ Access reports
Access analyzer
Archive rules
Analyzers
Settings
Credential report

Oraanization activity

ARN Console access
arn:aws:iam:: 5= ksl 5 17:user/tes & W't Disabled
Created Last console sign-in

February 16, 2023, 22:55 (UTC-08:00) -

Access key 1
AKIAYQPWF s o™i = F - Active
@ Used today. 74 days ol

Access key 2
Not enabled

d.

Groups Tags Security credentials Access Advisor

Permissions policies (2)

Permissions are defined by policies attached to the user directly or through groups.

Q Find policies

O Policy name [ A Type
m] o] AWSCloudTrail_ReadOnlyAccess AWS managed
O [ fdcAWScredentialReport Customer managed

4

Attached via [4
Directly

Directly

Add permissions ¥

1 @
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To deploy the deception keys in FortiDeceptor:

1. Login to FortiDeceptor and go to Deception > Lure Resources.

@ Dashboard

| ® Deception
Custom Decoy Image Upload New Lure Resource

Deception 05

AWSKeysSample txt

Deployment MNetwork Lure Type: I Credential - AWS Keys (txt) I v

Depl Wizard © Please configure the AWS connector in Fabric Quarantine
e ment Wizar ) .
Pyl Integration page to trace the activities for these AWS lure accounts.

Decoy Status
Tag: any

real_awskeys_with_NOpermission.txt

Deception Token
Deployment Map

Asset Discovery

Safe List ' |
Incident > I I
) Fabric > f
¢ Network »

@ System > Resource File: H
L Log >

| Choose a file |

NOpermission. txt

Save Cancel

2. Goto Fabric > Quarantine Integration > +Quarantine Integration With New Device and configure the integration.

Integrate method Select AWS Keys.
AWS Region Enter the region for the AWS Connector user you created in the previous
task.
AWS Access Key ID Enter the access key ID for the AWS Connector user you created in the
previous task.
AWS Secret Access Key Enter the secret access key for the AWS Connector user you created in the
previous task.
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Enabled ©
Mame™ AWSConnSample
Elock Severity Low Risk MediumRisk HighRisk Critical

Integrate Method AWS Keys -

o Please configure the lure users in AWS in advance for AWS connector
to detect the suspicious access. Refer to AWS document

AWS Region ~ us-g2st-1
AWS Access Key ID ™ ABCAYBCFHIJKILMMNSOP
AWSSecret Access Key ™ | sssssssssssssssssssssssssss @

Verify 55L* [ o}

Save Cancel

3. Goto Deception > Deception Token > Token Campaign.
4. Click + Campaign and select the AWS lure you unloaded in Step 2.

@ Dashboard *  campaign

I () Deception v
Custom Decoy Image Campaign Name: awskeys100 Mode: Online
Deception OS5
Deployment Network ™ Lure Type 1 Decay IP Address t IP Mode t
Lure Resources
Deployment Wizard O Cached Credential auto322016cuad 10.10.2.158 Static
Dy SiEns O HaneyDoc auto522016cuad 10.10.2.188 Static
Deception Token
Deployment Map l:l ODBC auto322018cuad 10.10.2.188 Static

Asset Discavery —

5. Click Generate API Auth Key and click Save.

AWS Keys: E

Azure Keys:

AWS/Azure Keys Installation Path: |%u ser’&\HRKeys

Generate APl Auth Key 781b8bb4d5fhé5arsdbf3aase2besf44fa742a22abff6301d0f2fb11abs0c1s

Deploying Azure deception keys

To deploy Azure deception keys, first create the keys in Azure, then upload them to the FortiDeceptor and create a new
campaign.
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To create Azure AD application keys for Lure Resource:

1. Login to your Azure account.

2. Goto Azure Active Directory > App registrations > Register an application > Register. Do not assign any API
permissions to this application.

L Search resources, services, and docs (G+/)

Heme 3> App registrations >

Register an application

* Name

The user-facing display name for this application (this can be changed later).

| MewsPPzamplel W

Supported account types
Whao can uze this z2pplicstion or acozss thiz APT
l@:l Accounts in this organizational directory only (Fortinet AzureStore only - Single tenant)

o Accounts in any organizationsl directory (Any Entra |D tenant - Multitenant)

O Accounts in any organizational directory {Any Mic
Xbaox)

fz Entra |D tenant - Multitenant) and personal Microsoft sccounts (=g. Skype.
O Personal Microsoft accounts only

Help me choose.

Redirect URI {opticnal)

We'll return the authenticstion response to this URI after successfully suthenticating the user. Providing this mow is optional and it can be
changed later, but 2 value is required for most authentication scenarios.

Select a platform R | | e.g. https/fexample.com/auth

Register an app you're working on here. Integrate gallery apps and other apps from outside your organization by adding from Enterprize applications.

By procesding. you agree to the Microzoft Platform Policies 0

3. Goto Azure Active Directory > App registrations > All applications, and locate the application you created (for
example, NewAPPsample1).
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4. Copy and paste the client ID and the tenant ID into a .txt file (for example KeysSample1.txt).

= Microsoft Azure

£ Search resources, services, and docs (G+/)

| App registrations >

g NewAPPsamplel =

Bwwn e

li] Delete € Endpoints

Preview features

B Overview
\ Essentials
& Quickstart
Display name : NewAPPsample1
# ' Integration assistant
Application (client) ID JD- - dl
Manage Object ID : f2d90968-d429-4bb2-b126-8d27dffTbded

E Branding & properties Directory (tenant) IC,
9 Authentication
Certificates & secrets

1l Token configuration

¢

API permissions

:IB.I "l

|

Ol IFlYy "S-l [ 15 Bl 4. T bd i NewApp : Od Daafil . J9i- 4.0

Client credentials

Redirect URIs

Application ID URI

Managed application in I...

e i Toha

O

& Expose an API

i App roles

& Owners

& Roles and administrators

Manifest

Support + Troubleshooting
¢&? Troubleshooting

& New support request

Ln 1, Col 1_ 100%  Windows (CRLF) UTF-8
5. Input multiple applications info into one .txt file, such as Keys3Samples.txt
ﬂ 3-Keys3Samples.txt - Notepad - O X

File Edit Format View Help

3aafcdag-1eal-3dab-b361-a6efdooebela:DevOpsTool912336da-2a88-32b1-8abd-3b61abdf33ba
c66d36a6-cd62-3397-bave-90328a63b3c1:DataAnalyzer:912336da-2a88-32b1-8abd-3b61abdf33ba
6af90aff-d239-3bP3-8962-9938916b3199: customerPortal :912336da- 2a88-32b1-8abd-3b61abdf33ba

: Add a certificate or secret

: Add a Redirect URI

: Add an Application 1D URI

: NewAPPsample1

X

fll continue to provide technical support and secur

ty platform

1 You can create modern, standards-based
#rs. Learn more

,E;

6. Locate the application you created (for example, NewAPPsample1). Go to Certificate & secrets > Certificates, and

upload a certificate (public key).
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a. (Optional) Upload a public key to the deception application.

b.

Home >

App registrations >

NewAPPsamplel | Certificates & secrets =

|}'J Search

| «

B Overview
Quickstart

#" Integration assistant

Manage

B Branding & properties

29 Authentication
Certificates & secrets

{Il Token configuration

2 APl permissions

& Expose an AP

#. App roles

& Owners

a. Roles and administrators

0l Manifest

Support + Troubleshooting
42 Troubleshooting

2 Newsu pport request

27 Got feedback?

Credentials enable confidential applications to identify themselves to tt
scheme). For a higher level of assurance, we recommend using a certifi

o Application registration certificates, secrets and federated credentials

Certificates (0)  Client secrets (0) Federated credentials (0)
Certificates can be used as secrets to prove the application’s identity
T Upload certificate
Thumbprint Description

No certificates have been added for this application.

Upload certificate X
Upload a certificate (public key) with one of the following file types: .cer, .pem, .crt *

‘ “publicKeySample1.pem” ‘ E
Description

‘ forAzureToken ‘

caneel

(Optional) Keep the certificate file that corresponds to the public key you uploaded in the previous step.

To create Azure application keys for Azure Connector:

1. Goto create an AD application for Azure Connector.
2. Ensure that the required permissions are granted for the registration of this application.
For a Microsoft Graph User, following API/Permissions must be granted:

User.Read . All

User.ReadWrite.All

GroupMember.Read.All

GroupMember.ReadWrite. All
Group.ReadWrite. All

Group.Read . All

AuditLog.Read.All
Directory.Read.All

Directory.ReadWrite. All

User.Manageldentities.All of type Application.
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Home App registrations

2 azuM Py B | APl permissions  #

B Search « () Refresh & Got feedback?
B oveniew
CQuickstart A\ This application is using Azure AD Graph AP|, which is on a deprecation path. Starting June 30th, 2020 we will no longsr add any new features 1o Azure ADY Graph AP We strongly recommend that you upgrad:
7 Integration assistant

@ The "Admin consent raquirsd” column shows the default valus for an organization.

Manage n b2 custornized per parizsion, uses, or 2op. This column may not reflact the valus inyour organiz
= Branding & properties

Configured permissions
3 Authentication

Applications arz authariz

to call APis when they sre grantad pen

ers/admins a5 part of the consent process. The list of configured permissions should include

Certificates & secrets all the permissions the application nesds. Leam more about pam nsent
ill Token configuration
# APl permissions -
APl / Permissions name Type Description Admin consent requ...  Status

¥l Approles

" - 1
8 Owners

1 ]
& Roles and administrators e
o o

I Manifest

] u k

Suppert + Troubleshooting

£ Troublsshocting Applicstion  Resd 2l audit log dats Yas

B Mew support request

Application  Read directory data ACH L™
Application Read and write directory data Yes
Application Read all groups Yes
Application d and write 21l groups as
Application  Read all group memberships Yes
Application Read and write all group memberships Yes
Application your organization's policies Yes 5
Application  Read your organization's conditional access policies Yes
cc Application Read and write your organization's conditional access poli... Yes
Application  Manage zIl users’ identities Yes
2 " u
Applicati Read all users’ full profiles Yes Grantzd for
Application  Read and write all users’ full profiles Yes Gr: "

To view and manage consented permissions for individual apps, as well a5 your tenant’s consent settings, try Enterprise applicstions.

3. Create the secret, and keep the client ID and tenant ID for the Azure Connector later.

To deploy the deception keys in FortiDeceptor:

1. Login to FortiDeceptor and go to Deception > Lure Resources and click Upload. You cannot select which Azure key
is to be installed if you upload multiple keys at the same time.

2. For Lure Type, select Credential - Azure Keys (txt) and upload the text file you created in the previous task ( for
example, KeysSample1.txt) , and click Save.

If you kept the certificate file which includes certificate with private key, for Lure Type, select Azure Certificate, and
upload the certificate file from 6.b.

3. Goto Fabric > Quarantine Integration .
4. Click +Quarantine Integration With New Device and configure the integration.

Integrate Select Azure Keys.
method

Client ID Also called Application ID;Unique ID of the Azure Active Directory application.
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Client
Secret

Tenant ID
Verify SSL

Client Secret of the Azure Active Directory application that is used to create an authentication

token required to access the API.

Tenant ID provided for your Azure Active Directory.

Specifies whether the SSL certificate for the server is to be verified or not. By default, this option

is setas True.

@ Dashboard
® Deception
Incident

I ¥ Fabric

Detection Devices

T — Quarantine Via Upstream 1

Quarantine Status
10C Export

£ Network

@ System

LW | og

>  Fabric Upstream

>

, Enabled a Enabled
Upstream IP Address/URL * .

v Name

Hol g Block Severity

Integrate Method

ClientID*

Client Secret *

>
‘ =+ Quarantine integration with f
>

N © Q Search Tenant ID *
Enabled Status Verify SSL*

O @ Disabled (@ UnchecK

© Disabled ~ ® Uncheck

5. Goto Deception > Deception Token > Token Campaign.

6. Click + Campaign. Enable the toggle and use the default location or customized location to create the Azure keys

campaign.
@ Dashboard

I ® Deception
Custom Decoy Image
Deception OS
Deployment Network
Lure Resources
Deployment Wizard

Decoy Status

Deception Token

Deployment Map
Asset Discovery
Safe List

Incident

% Fabric

2 Network

2 System

Ll Log

7. Click Save.

Campaign

Campaign Name: TokenAzureKey1l

D Lure Type t
D HoneyDoc
] SAMBA
(| ccul
AWS Keys:
Azure Keys: @

Integrate With New Device

©

AzureConnector

LowRisk MediumRisk HighRisk Critical

Azure Keys v

1cabcdal-10a1-2dab-b261-a60fd990b0
eescsccscsssscssssssscsssecl D
912336da-2a88-32b1-8abd-3bé1abdf3!

©

Cancel

Save

Mode: Online ¥
Decoy t IP Address t
131ul6vi HES-L e |
131ul6vl L LT A B

4724004 &vid PR LAY N

AWS/Azure Keys Installation Path:  |%user%\DevOpsAzureApp

v v v v

Generate APl Auth Key
>

5492e6d0df1923da66e3401485260ac26fd2fbd637eb3f467efac5d21dbfabed

Save

Cancel
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Configuring trunk ports on FortiDeceptor VM

This section describes how to configure trunk ports to extend VLANs between FortiDeceptor VM and ESXi vSwitch using

a single interface.

This setup requires FortiDeceptor VM v3.1 build 0061 and vSwitch ESXi v6.7.0 build 13006603.

Set up a single ESXi host with the following workloads.

» 1 FortiDeceptor VM with one decoy monitoring two network segments.

o 2 web servers in different VLANs / network segments.

« 1 vSwitch dedicated to connecting the FortiDeceptor decoy to the network segments.

N
FDC

FortiDeceptor
VM
Deception VM |
Decoys ' :'-|
<
vSwitch_FDC -‘.;\ . Hypervisor

= Virtual Switch
\ / \ /
. / \ i ™
% $' Web Servers
Ny
\ VMs

\ Web-1 Web-2 )

Decoys

-— (Deception VMs)

-— FortiDeceptor VM

Web Servers

ESXi Host
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FortiDeceptor VM has internal network ports. Set up FortiDeceptor VM with the following.

« Reserve port1 for device management.
» Use the other ports to deploy deception decoys.

FortiDeceptor VM < Interfaces y 4 7 admin v

t are you looking for? Q [ Edit
@ Dashboard

Interface 1Pv4 IPvé Interface Status Link Status Access Rights
(P Deception v . . :
port1 (administration port. 192.168.0.36/255.255.255.0 [+] [ HTTPS.SSH
Customization port2 192.168.1.9/255.255.255.0 ) ]
Deception OS port3 192.168.2.99/255.255.255.0 [+] ]
Deployment Network port4 192.168.3.99/255.255.255.0 [+] ]
port5 192.168.4.99/255.255.255.0 [+] [
Deployment Wizard
porté 192.168.5.99/255.255.255.0 [+] [
Decoy & Lure Status
Decoy Map
Whitelist
B Incident ~
222 Fabric ~
@ Network v
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When you initially set up FortiDeceptor, the interface configuration in Network > Interfaces is provisioned automatically.
You do not need to change this section as these network settings are just for internal use. The actual deception network
interfaces that connect to the monitored segments are configured under Deception > Deployment Network.

In this environment, port3 is used to deploy a Linux-based deception VM (decoy). The goal is to monitor network activity
in two different VLANs where the production servers reside: WebServer-1 (192.168.11.11/24) in VLAN11 and
WebServer-2 (192.168.21.21/24) in VLAN21.

FortiDeceptor Management

port-3

Deception VM

® 0

Decoy VLAN11

Web-1 Web-2

The deception VM has a single network interface to monitor two different VLANSs so it is necessary to configure VLAN
trunking between port3 and the ESXi vSwitch port. There is only one vSwitch to connect all the devices together using
different virtual ports for each device.
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Configuring FortiDeceptor
Configure FortiDeceptor to monitor the subnet networks, one for each VLAN, using the same network port3.

To configure FortiDeceptor:

1. Go to Deception > Deployment Network and click Add New Vlan / Subnet to add the monitored segments.

£ FortiDeceptor VM

i Dastboar -
|ﬁ Duception
Cunominaton
oo [ o
BT

Leve Retonsces

Doepioryrresl Wiksed Rcsion St e Irgarfacn WLANID Depioy Monitor [P/ agk Tag [ACER
Decoy & Lore Status
Depioymatnt Mg

Sale Lt

-

2. Use the VLAN tag for each monitored subnet so that FortiDeceptor can differentiate the traffic between them.
Verify that both VLANSs use port3.

3. Specify the Deploy Network IP/Mask that the deception VM use to monitor its decoys on each segment.
Ensure these IP addresses are unique and belong to the monitored subnets.

4. Go to Deception > Deployment Wizard to deploy the actual deception VM and attach the monitored segments.
£ FortiDeceptor VM < Deployment Wizard . F O @~  admin~

What are you looking for? Q

@ Dashboard

Ijl Deception v
Customization

Deception OS
eception Add Interface for Decoy

Deployment Network

Deployment Wizard

Decoy & Lure Status

Deploy Interface | | A | Interface cannot be empty:

port3: vian#11 192.168.11.100/24
port3: vlan#21 192.168.21.100/24 I

Decoy Map

Whitelist
H Incident A
&% Fabric A
@ Network ~

Interfaces

5. Specify the network settings for the decoys.
FortiDeceptor automates the creation of deception VMs and decoy services to lure and expose attackers; so decoy
services on each segment require dedicated IP addresses to interact with attackers.
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If you want to use a static IP address for the decoy services, click Static, then specify a single IP address or IP
address range in IP Ranges.

B Dashbcard

Ia Decepticn
Customiration
Dception 05
Deeplarprraedil MNetadii

Lufe Resounoes

o

Deevoy & Lure Status

Dreployment Map

Sady List Drepiy Interface Local portd: sebnet 100114724
B tecident Aderiting Mode

Bnatysis n —

fratinek i 55552550

Campaign

Attack Mag Gatwny 10001
El Fatvic MAL Address QU1

Integration Devies
Cuarantine Status
B3 Export
@ Mtk 1P Count
B Syes
Admindsirabos
Aedmin Profiles el
Certificabes L 001F5S
LD Servars IF Ranges {51) 10.0.8.50- 100, 7, 10]
RLADIUIE Sarvery
Mg S rver

[ ]

Z Decoy & Lure Status J @~ adminv

What are you looking for? Q 2 Refresh

@ Dashboard

9 Deception .| O Action Status Decoy Name + os vM Lure Count P Services Network Type
Customization [l eamgtd? O Runing pnarvaez-mx075 A ubuntulévl 3 1921681199 B2 sttc
Deception OS
Deployment Network

Deployment Wizard

Decoy & Lure Status
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o= FortiDeceptor VM 2 Decoy & Lure Status

What are you lo

@ Dashboard
@ Deception ~

Customization

Deception OS
Deployment Network Config Detail
Deployment Wizard 23,80,8080,443
Decoy & Lure 5t
Decoy Map
Hostname: pnarvaez-mx075
Whitelist
DNS: 8.8.88
m Incident ~
Interface Count: 1
8% Fabric ~
@ Network Partition Mode: vlan
etworl v
Addressing Mode: static
Interfaces
Deploy Port: port3
System DNS

Vlan ID: 11
System Routing

Gateway: 192.168.11.1

£ System ~

@ Log ~

IP Count: 1
Range: 192.168.11.99
Mask: 255.255.255.0

Monitor: 192.168.11.100/24

7. Test connectivity by pinging the decoy and the monitoring IP addresses and verify that they are reachable.
The web servers are not reachable as ESXi is not configured yet.

2 Dashboard > # X @~ adminv
Q CLI Console & BB x

What are you lo

Iﬁ Dashboard
@ Deception ~

Customization

Deception OS
Deployment Network
Deployment Wizard
Decoy & Lure Status
Decoy Map
Whitelist
B Incident ~
£28 Fabric ~
@ Network ~
¥ System ~
3 Log ~
12
q
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From the networking perspective, FortiDeceptor is ready to monitor both VLANSs over port3. However, to activate the
logical trunk interface, FortiDeceptor needs to receive VLAN trunking traffic from the vSwitch port.

If you have a physical switch connected to the ESXi host, you must configure 802.1Q on the switch port that is connected
to the host uplink.
Configuring the vSwitch

To simplify configuration, we recommend using a dedicated vSwitch for the decoy and monitored segments.

The following diagram shows the vSwitch ports relationship.

FortiDeceptor Management

port-3

Deception VM ‘ iy ‘ __— vlan21 deception monitor ip
S ‘ 192.168.21.100/24
vlanl1l deception monitorip — R
192.168.11.100/24 ___ FDC Trunk

vSwitch_FDC_Decoys P m decoy vian21
S ‘*-T;:-. P j&‘_‘é 192.168.21.99/24
Web-Server2

Web-Serverl

OPe)
192.168.11.11/24 decoy vianll 192.168.21.21/24
192.168.11.95/24

VILANIL
VLAN21
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On ESXi, configure the vSwitch_ FDC_Decoys vSwitch to connect both VLANSs to FortiDeceptor. Then configure three
network port-groups:

1. FDC_Trunk— Port-group for the actual trunk interface between FortiDeceptor and vSwitch.
2. VLAN11—Port-group to connect VLAN11 to vSwitch.
3. VLANZ21 - Port-group to connect VLAN21 to vSwitch.

To configure the vSwitch:

1. On the ESXi client, go to Networking > Virtual Switches and add a standard virtual switch.

Just configure the vSwitich Name, remove the uplink (unless you need it), and use default values for the other
options.

& Add standard virtual switch - vSwitch_FDC_Decoys.

=8 Add uplink
vSwitch Name vSwitch_FDC_Decoys.
MTL 1500 5

k Link discovery Click to expand

F Security Click to expand

Add || Cancel

2. Go to Networking > Port groups and add the port groups.

Port groups for VLAN11 and VLAN21 are similar. For each port group, specify a Name, configure the VLAN ID, and
select the Virtual switch.

%3 Add port group - VLAN11.

Name | VLANT1.
VLAN D PR
Virtual switch

vawitch_FDC_Decoys

¥ Security Click to expand

Add H Cancel
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3. Forthe FDC Trunk port, configure a special port-group.
On ESX:i, you do not need to configure 802.1Q. You only need to set the port group to be a promiscuous interface
and specify 4095 for the VLAN ID so the vSwitch can send and receive traffic from the VLANs configured on

FortiDeceptor.

Select the Virtual switch and set all Security options to Accept.

@ Add port group - FDC_Trunk.

Mame

YLAN 1D

Virtual switch

« Security

Promiscuous mode

MAC address changes

Forged transmits

| FDC_Trunk

vawitch_FDC_Decoys -

@Accept O Reject O Inherit from vSwitch

@Accept O Feject O Inherit from vSwitch

@Accept O Feject O Inherit from vSwitch

Add

|| Cancel |

4. To verify the configuration, check the vSwitch topology and ensure all devices are connected to this switch.

vmware ESXi admin@102066.194 ~ | Help~ | (CELcEEs
“¥ Navigator 1 || = vSwitch_FDC_Decoys
~ [g Host
Termme = Adduplink 7 Editsettings | & Refresh | £} Actions
Monitor i
P —] vSwitch_FDC_Decoys
| | Type Standard vSwitch
+ (51 Virtual Machines | - aroups: s
- [ FortiDeceptor_v3.1 e Uplinks:
Monitor
More VMs... ‘v vSwitch Details ‘v vSwitch topology
H storage MTU 1500 —

- FDC_Trunk Mo physical adapters
€ Networking Ports 3246 (3189 avallale) & Foo 7 oy P
b Q FDC_Trunk VLAN ID: 4095

Link discovery Unknown ~ Virtual Machines (1) -
Monitor FortiD 4 a1
Attached Vs 3 (3 active) iy FortiDeceptor_
» 3 VAN MAC Address 00:0c28:7d:24:7a —]
m= vSwitch_FDC_Decoys (+ NIC teaming policy —J
M tworks... ™
ore networks Motify switches Yes Q VLAN21 7
Paolicy Route based on originating port ID VLAN ID: 21
~ Virtual Mach 1
Reverse policy Yes irtual Machines (1)
(B WebServer-03
Failback Yes MAC Address 00:0c:29 72:67:0c —i]
‘v Security policy
Allow promiscuous mode No (7 il 7
VLANID: 11
Allow forged transmits No - Virtual Machines (1) —
Allow MAC changes No @ WebServer-01
MAG Address 00:0c:28'8Fb:12 —d
~ Shaping policy
Enabled Mo
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5. Test connectivity from FortiDeceptor to the web servers, and from each web server to the decoys connected to the

same VLAN.
o From FortiDeceptor.

@
2

FortiDeceptor VM

Q

Dashboard admin
Wk
Deception v
Customization
Deception OS
Deployment Network
Deployment Wizard
, 0% packet loss

Decoy & Lure Status 0.102 ms
Decoy Map
Whitelist
Incident A
Fabric A
Network N packet loss
System PN
Log ~

e« From web server 1.

168.11.99 ping s
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How to setup and use LDAP/RADIUS servers

1. Set up the LDAP server

Requirements:

» FortiAuthenticator login credentials

To set up the LDAP server:

1. InFortiDeceptor Go to System > LDAP Servers.
2. Click Create New. The New LDAP Server window opens.
3. Configure the LDAP server settings, see LDAP Servers on page 131.

New LDAP Server
Server Name/IP: :
Port: 389
Common Name: ‘uid ‘
Distinguished Name: |o:fdc,dc:fortinet,dc:mﬂ |
Bind Type: @ Simple O Anonymous (O Regular
[ Enable Secure Connection
Cancs

You must use the following format for the Distinguished Name field :<root_node>,<subordinate_node>. To find the
names of the Root and Subordinate nodes in FortiAuthenticator, by go to LDAP Service > Directory Tree.

E2% FortiAuthenticator VM
System + Expand All| @ Delete
Authentication
& User Account Policies
& User Management
& Self-service Partal
"'f Guest Portals
= Remote Auth. Servers i
. & RADIUS Service |
|

General

P A

<

Directory Tree
& OAuth Service >
By samLidp >
>
>

23 FAC Agent
Fortinet S5O Methods

173 uid=Idap_readonly

Setup the RADIUS server

Requirements:

» FortiAuthenticator login credentials

To set up the RADIUS server in FortiDeceptor:

1. Goto System > RADIUS Servers.
2. Click Create New. The New RADIUS Server window opens.
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3. Configure the RADIUS server settings. See RADIUS Servers on page 132.

3. Create an account in FortiAuthenticator and enable LDAP/RADIUS

You do not need to complete this step if you already have a FortiAuthenticator account.

New RADIUS Server

Name:

Primary Server Name/IP:

Secondary Server Name/IP:

Port:

Type:

Auth Type:
Primary Secret:
Secondary Secret:

NAS IP:

I
I
]
[other v

@Any OPAP (O CHAP

]
[ ]
L ]

OMsv2

Cancel

y
4

In the Primary Secretfield enter, fortinet.

To enable LDAP/RADIUS:

1.

| & RADIUS Service »
& LDAP Senvice

In FortiAuthenticator, go to User Management > Local Users and create a new account.

a. Enable Allow RADIUS authentication.

b. Inthe Password and Password confirmation fields, enter fortinet.

Go LDAP Service > Directory Tree to enable LDAP.

Expand the Root node, and then click the green plus symbol next to the Subordinate node. The Create New LDAP
entry window opens.

FortiAuthenticator VM FAC

System
Authentication
& User Account Policies
& User Management
& Self-service Portal
o Guest Portals
E& Remote Auth. Servers

General
Directary Tree

& OAuth Service

B samLidp »

3 FAC Agent

> | 4+ Expand Al @1 Delete

I8 id=dap_readarly
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4. From the Class dropdown, select Local User (uid).

5. Goto User Management > Local Users to verify the RADIUS and LDAP servers are enabled. To do this, check that
the Authentication Methods column shows RADIUS and LDAP.

4. Create login account using LDAP/RADIUS accounts from FortiAuthenticator

To create a login account with LDAP/RADIUS:

1. In FortiAuthenticator, go to User Management > Local Users and locate an account that has LDAP/RADIUS
enabled. To do this, look in the Authentication Methods column for RADIUS and LDAP.

2. InFortiDeceptor, go to System > Administrators and click + Create New to create a new administrator. The New
Administrator window opens.

3. Configure the administrator settings.

Ay
‘Q' The values for the Administrator, Type, and LDAP Server fields must match the user's
- settings in FortiAuthenticator.

4. Loginto FortiDeceptor with the administrator account you created.
5. Goto System > Administrators and click + Create New . The New Administrator window opens.

FortiDeceptor 5.2.2 Administration Guide 228
Fortinet Inc.



Appendix B - Deception deployment best practices

6. Create a new administrator and set the Type to RADIUS.

New Administrator

Administrator:
Type:

Admin Profile:
Timezone:
RADIUS Server:
Trusted Host #1:
Trusted Host #2:

Trusted Host #3:

IPvé Trusted Host #1:

IPvé Trusted Host #2:

IPvé Trusted Host #3:

Comments:

Olocal OLDAP @ RADIUS

|Read Only

| (GMT-12:00)Eniwetok, Kwajalein

" v

0.00.0/00.00

‘ 255.255.255.255/255.255.255.255

‘ 255.255.255.255/255.255.255.255

=0

/0

=0

OK

Cancel
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Appendix C - Hardening

System hardening reduces security risks by eliminating potential attack vectors and shrinking the system's attack
surface. This section covers some of the actions that can be used.

Building security into FDC-OS

The FortiDeceptor operating system, FortiDeceptor hardware devices, and FortiDeceptor virtual machines (VMs) are
built with security in mind, so many security features are built into the hardware and software. Fortinet maintains an
1ISO:9001 certified software and hardware development processes to ensure that FortiDeceptor products are developed
in a secure manner.

Boot device security

The FortiDeceptor boot device in hardware devices use Fortinet’s customized bootloader which is specifically designed
and implemented for the FortiDeceptor product. FortiDeceptor physical devices always boot from this boot device.

FDC-OS kernel and user processes

FortiDeceptor is a multi-process operating system with kernel and user processes. The FortiDeceptor kernel runs in a
privileged hardware mode while higher-level applications run in user mode. FortiDeceptor is a closed system that does
not allow the loading or execution of third-party code in the FortiDeceptor user space. All non-essential services,
packages, and applications are removed.

Physical security

Install the FortiDeceptor in a physically secure location. Physical access to the FortiDeceptor can allow it to be
bypassed, or other firmware could be loaded after a manual reboot.

Optionally, disable the maintainer account with CLI command set-maintainer. Note that doing this will make you unable
to recover administrator access using a console connection if all of the administrator credentials are lost.
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Vulnerability - monitoring PSIRT

The FortiGuard Labs Product Security Incident Response Team (PSIRT) continually tests and gathers information about
Fortinet hardware and software products, looking for vulnerabilities and weaknesses. Any such findings are fed back to
Fortinet's development teams and serious issues are described along with protective solutions. The PSIRT regulatory
releases PSIRT advisories when issues are found and corrected. Advisories are listed at
https://www.fortiguard.com/psirt.

Firmware

Keep the FortiDeceptor firmware up to date. The latest patch release has the most fixed bugs and vulnerabilities, and
should be the most stable. Firmware is periodically updated to add new features and resolve important issues.

« Read the release notes. The known issues may include issues that affect your business.
« Do not use out of support firmware. Review the product lifecycle and plan to upgrade before the firmware expires.
» Optionally, subscribe to the Fortinet firmware RSS feed: https://pub.kb.fortinet.com/rss/firmware.xml.

Encrypted protocols

Use encrypted protocols whenever possible, for example, SNMPv3 instead of SNMP, SMTPS instead of SMTP, SSH
instead of telnet and HTTPS instead of HTTP.

Strong ciphers

FortiDeceptor already sets to use higher levels of encryption and strong ciphers for communications with Fortinet fabric
devices.

FortiGuard databases

Ensure that FortiGuard databases, such as Industry Security Signature, Network Alerts Signature, AntiVirus Scanner
and Signatures, Al Malware Engine and ARAE Engines are updated punctually.

Trusted Hosts

Limit access to the FortiDeceptor to a management interface on a management network. Trusted hosts can also be used
to specify the IP addresses or subnets that can log in to the FortiDeceptor. When authenticating to the FortiDeceptor,
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implement two-factor authentication (2FA). This makes it significantly more difficult for an attacker to gain access to the
FortiDeceptor.

Limit login user’s access right

The features that a login user can access should be limited to the scope of that user's work to reduce possible attack
vectors. The admin profile tied to the user account defines the areas on the FortiDeceptor that the user can access, and
what they can do in those areas. The list of users with access should be audited regularly to ensure that it is current.

Administration access security

Secure administrative access features:

SSH, Telnet, and SNMP are disabled by default. If required, these admin services must be explicitly enabled on
each interface from the GUI or CLI.

SSHv1 is disabled by default. SSHv2 is the default version.

SSLv3 and TLS1.0 are disabled by default. TLSv1.1 and TLSv1.2 are the SSL versions enabled by default for
HTTPS admin access.

HTTP is disabled by default, HTTP redirect to HTTPS is enabled by default.

The strong-crypto global setting is enabled by default and configures FortiDeceptor to use strong ciphers (AES,
3DES) and digest (SHA1) for HTTPS/SSH/TLS/SSL functions.

Admin administrator account

All FortiDeceptor ship with a default administrator account called admin. By default, this account does not have a
password. However, FortiDeceptor uses restricted password policy that enforce the admin account to change the

password on the first user login and use a complex password. (This mechanism is enforced across all users upon their
firstlogin.)

Maintainer account

Administrators with physical access to a FortiDeceptor appliance can use a console cable and a special administrator
account called maintainer to log into the CLI. When enabled, the maintainer account can be used to log in from the
console after a hard reboot. The password for the maintainer account is bcpb followed by the FortiDeceptor serial
number. An administrator has 60-seconds to complete this login using the CLI command admin-pwd-reset

The only action the maintainer account has permissions to perform is to reset the passwords of super admin accounts.
Logging in with the maintainer account requires a hard boot of the FortiDeceptor.

FortiDeceptor generates event log messages when you log in with the maintainer account and for each password reset.
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Non-factory SSL certificates

Non-factory SSL certificates should be used for the FortiDeceptor web management interface.

The default Fortinet factory self-signed certificates are provided to simplify initial installation and testing. Using these
certificates leaves you vulnerable to man-in-the-middle attacks, where an attacker spoofs your certificate, compromises
your connection, and steals your personal information.

Your administrator web portal should also be configured with a server certificate from a trusted CA.

Other recommended actions user can take

The following general administrative settings are recommended:

Set the idle timeout time for login users to a low value, preferably less that ten minutes.

In Interfaces page, limit access right for network ports.

Replace the certificate that is offered for HTTPS access with a trusted certificate that has the FQDN or IP address of
the FortiDeceptor.

For local accounts on the FortiDeceptor, try upgrading to FortiDeceptor to V4.3.0 and later which enforces a default
password policy with minimum complexity level.

Do not use shared accounts to access the FortiDeceptor. Shared accounts are more likely to be compromised, are
more difficult to maintain as password updates must be disseminated to all users, and make it impossible to audit
access to the FortiDeceptor.
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Appendix D - Configuration examples

This section provides configuration examples to integrate FortiDeceptor with other Fabric devices as well as third-party
integrations.

This section contains the following topics:

» Configure FortiDeceptor for admin access authentication from Active Directory on page 234
» Configure a Active Directory (AD) user as FortiDeceptor administrator on page 239
o MFA (RADIUS) configuration on page 243

« Integrate with Checkpoint Firewall on page 246

« Integration with Crowdstrike on page 248

« Integrate with Cuckoo Sandbox on page 251

« Integration with FortiSIEM on page 254

o FortiSIEM Watch List on page 258

« Mitigation using windows Remote Command on page 262

« Integration with PAN devices on page 264

« Integration with Microsoft ATP on page 267

« Integration with FortiSandbox on page 269

« Integration with FortiNAC on page 272

« Integration with FortiEDR on page 277

« Integration with FortiAnalyzer on page 279

« Integration with FortiGate over Webhook on page 284

« Integrate with FortiGate 6.0.3 to 7.2.3 over REST-API on page 295

« Integrate FortiDeceptor with FortiGate over Fabric v7.2.4 on page 299

« Integrate with Cisco ISE on page 312

Configure FortiDeceptor for admin access authentication from
Active Directory

To configure FortiDeceptor to authenticate from the Active Directory (AD) server, prepare and import a signed server
certificate into FortiAuthenticator. Next you will configure the LDAP service and add the local user to the LDAP directory
tree in FortiAuthenticator. Then you will import the server certificate and configure the LDAP server in FortiDeceptor.

FortiDeceptor admin access authentication from FortiAuthenticator

To configure FortiDeceptor admin access authentication front FortiAuthenticator using LDAP:

Prepare the certificate.

Import the signed server certificate to FortiAuthenticator.
Import the RootCA to FortiAuthenticator.

Configure the FortiAuthenticator LDAP Service.

Pobd-=
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o

Add the local user the LDAP Directory Tree.
Import the RootCA into FortiDeceptor.
7. Configure the LDAP server in FortiDeceptor.

o

—

. Prepare the certificate
If you are not using LDAP, you can proceed directly to Step 5: Create LDAP Directory Tree.

To prepare the certificate:

1. Create a Certificate Signing Request (CSR) and private key.

2. Sign the CSR with either a public Certificate Authority (CA) or your own RootCA. For the purpose of this example,
we will be using a self-created RootCA.

2. Import the signed server certificate to FortiAuthenticator

1. Login to FortiAuthenticator.
2. Goto Certificate Management > End Entities > Local Services and click Import.

=& FortiAuthenticator VM FAC-VM

System > || 4 Create New | & Import

Authentication >

Fortinet S50 Methods N (m] Certificate ID Subject Issuer

Monitor > |0 Default-Server-Certificate C=US, ST=California, L=Sunnyvale, O=Fortinet, O... Remote CA: C=US, ST=Cali...

Certificate Management ~ (O Fortinet_CA1_Factory C=Us, ST=California, L=Sunnyvale, O=Fortinet, O... Remote CA: C=US, ST=Cali...
B Policies > [0 Fortinet_CA2_Factory C=Us, ST=California, L=Sunnyvale, O=Fortinet, O... Remote CA: C=US, ST=Cali...

(] Idap.svr.20220215 signed CN=LDAPSVR 20220215 Remote CA: C=CA, ST=BC...

Users
e /3000 server cestincates
4§88 Certificate Authorities >
R SCEP >

Logging »

3. Select Choose File to locate the certificate file on your computer.
4. Select OK to import the certificate.

For more information, see Certificate Management > End Entities in the FortiAuthenticator Administration Guide.

3. Import the RootCA to FortiAuthenticator

1. Go to Certificate Management > Certificate Authorities > Local CAs.
2. Click Create New and configure the certificate settings.
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3. Click OKto create the new certificate.

System > | 4 Create New & Import
Authentication >
Fortinet S5O Methods ; m] Certificate ID Subject
Monitor > a RootCA C=CA, ST=BC, L=Burnaby, O=Fortinet... Remote CA: C=CA, ...
Certificate Management ~ | 1/1500local CA certificates
B Policies >
L3 Fnd Fntities >

%85 Certificate Authorities

Local CAs
CRLs
Trusted CAs
(=% SCEP »
Logging »

For more information, see Certificate Management > Certificate Authorities > Local CAs in the FortiAuthenticator

Administration Guide.

4. Configure the FortiAuthenticator LDAP Service

1. In FortiAuthenticator, go to Authentication > LDAP Service > General.

2. From the LDAP server certificate dropdown, select the server certificate you imported.
3. Fromthe CA cetrtificate that issued the server certificate dropdown, select RootCA and click OK.

System * | Edit LDAP Service Settings
Authentication v
LDAP Server Settings
User A t Polici 5 : )
& Usee decunt Palicics # LDAP server certificate: | ldap.svr.20220215 signed | CN-LDAPSVR 20220215 ~
User Management >
w g Certificate authority type: Trusted CA
& Portals > ; ;
CA cer‘hﬁc:‘ate that issued the RootCA | emailAddress=ssu@fortinet.com »
E& Remote Auth. Servers » | server certificate:
& RADIUS Service » | LDAP User Auto Provisioning
& TACACS+ Service » (Z® Auto provision users into LDAP from following sources:
& LDAP Service v
General

Directory Tree

& OAuth Service >
B saMLidP >
808 FAC Agent >
Fortinet S50 Methods >
Monitor >
Certificate Management >

5. Add the local user the LDAP Directory Tree

1. In FortiAuthenticator, from the LDAP directory tree, select the green plus (+) symbol next to the DN entry where you

want to add the node. The Create New LDAP Entry window opens.
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== FortiAuthenticator VM FAC-VM

o+ Expand All @ Delete (59991 of 40000 entries remaining)

iystem

\uthentication
& User Account Policies
& User Management
& Portals
E& Remote Auth. Servers
& RADIUS Service
& TACACS+ Service
& LDAP Service

General

I

Directory Tree
a8 OAuth Service
B saMLIdP
&28 FAC Agent

‘ortinet 550 Methods

»

~

»

»

»

»

B ) de=fortinet,dc=com (1)

=] =] o=fdc 4

3 cn=dev

2J cn=guest

o e @ +
! L () uid=ldapl
- (2] uid=local1
- [2J uid=ssu

iw [_) cn=localgroup

2. Inthe Class field, select the identifier to use.
3. Select the required value from the dropdown menu, or select Create New to create a new entry of the selected

class.
4. Click OK.

x

For more information, see Creating the directory tree in the in the FortiAuthenticator Administration Guide.

6. Import the RootCA into FortiDeceptor

If you are not using LDAP, proceed to Step 7. Configure the LDAP server in FortiDeceptor.

1. In FortiDeceptor, go to System > Certificates and click Import.

2. Inthe Certificate field, click Browse and upload a copy of the RootCA certificate you imported to FortiAuthenticator

in Step 3 Import the RootCA to FortiAuthenticator.
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3. Configure the rest of the certificate settings and click OK.

== FDC =
Pashboard > =] Import £} service @ View
‘& Central Management >
¥ Deception y  Name Subject
] Incident » = = o s - . s ;
RootCA C=CA,5T=BC, L=Burnaby, © = Fortinet, OU = FDC, CN = FDCQA, emailAddress = ssu@fortinet.com
Fi Fabric >
& Network 69.53https C=CA,ST=BC, L= Burnaby, 0 = FTNT,0U = FDC, CN = 69.53.https, emailAddress = ssu@fortinet.com
iar Networl >
X System v firmware C=US, ST = California, L = Sunnyvale, O = Fortinet, OU = FortiDeceptor, CN = FDC1KGT 621000036, emailAdd

Administrators
Admin Profiles
LDAP Servers
RADIUS Servers
Mail Server
SNMP
FortiGuard

For more information, see Certificates on page 129.

7. Configure the LDAP server in FortiDeceptor

1. InFortiDeceptor, go to System > LDAP servers and click Create New. The New LDAP Server page opens.
2. Configure the LDAP settings keeping the following considerations in mind:

Common Name The Common Name must match the node you created in the LDAP tree.
Enable Secure Connection When enabled, you must select the RootCA you imported from the CA
Certificate dropdown.
~= FDC —
Dashboard > Edit LDAP Server
& Central Management >
Name:
¥ Deception >
] Incident " Server Name/IP: | |
% Fabric > Port: léBé |
= Network > Common Name: !uid ‘
@ System s Distinguished Name: icn=qa,a=fdc.d:::foninet.dc:com ‘

Administrat
ministrators Bind Type:

Admin Profiles
Enable Secure Connection
Certificates

Protocol:
LDAP Servers

RADIUS Servers Shienoats
Mail Server

SNMP

FortiGuard

FDC License

Settings

Login Disclaimer

3. Click OK.

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.

® Simple O Anonymous () Regular

@LDAPS (O STARTTLS

RootCA v

238



Appendix D - Configuration examples

Configure a Active Directory (AD) user as FortiDeceptor
administrator

To configure an AD user as an administrator:

1. Configure the LDAP Server in FortiDeceptor.
2. Setthe Active Directory user to be an administrator.

1. Configure the LDAP Server in FortiDeceptor

1. On the Active Directory server, enable LDAP signing.
2. Goto System > LDAP Servers and click Create New. The New LDAP Server page opens.
3. Configure the LDAP settings as follows:

Name Enter a unique name for the LDAP server.

Server Name/IP Enter the FQDN IP or address of the AD server.

Port Enter the connection port of the LDAP server.

Common Name Enter the name of the user identifier field on the LDAP server. In this example,
SAMAccountName.

Distinguished Name Enter the LDAP node where the user account entries can be found. In this

example, DC=fdc,DC=com.

Bind Type Select the binding type:

¢ Simple: Bind using a simple password authentication without a search.

¢ Anonymous: Bind using anonymous user search.

¢ Regular: Bind using username/password and then search.
Use simple authentication if the user records all fall under one distinguished
name (DN). If the users are under more than one DN, use the anonymous or
regular type, which can search the entire LDAP database for the required
username.
If the LDAP server requires authentication to perform searches, use the
regular type and provide the Username and Password.

Username Enter the LDAP server domain username.
Password Enter the LDAP server domain password.
Enable Secure Connection Enable or disable secure connection to the LDAP server.
FortiDeceptor 5.2.2 Administration Guide 239

Fortinet Inc.



Appendix D - Configuration examples

@ Dashboard > New LDAP Server
® Deception >
Name: ‘ADdirect |
Incident >
0 Fabric N Server Name/IP: ‘ |
< Network > | Port: 389 |
& System v Common Name: ‘sAMAccountName ‘
adininEtaors Distinguished Name: ‘DC:fdc,DC:COm ‘
Admin Profiles
Bind Type: O Simple O Anonymous @ Regular
Certificates
LDAP Servers Username: ‘ADuserMaria |
RADIUS Servers Password: sevcsescnseenee |
Mail Server [J Enable Secure Connection
SNMP
FortiGuard
4. Click OK.
@ Dashboard ? + Create New E, Edit ]ﬁ Delete
® Deception H
Incident > Name Address Common Name Distinguished Name Bind Type Connection Type
% Fabric > ADdirect sAMAccountMName  DC=fde.DC-com Regular NON SECURE
£F Network >
& System v

Administrators
Admin Profiles

Certificates

LDAP Servers

RADIUS Servers

2. Set the Active Directory user to be an administrator

1. Goto System > Administrators and click Create New. The New Administrator page opens.
2. Configure the administrator settings keeping the following considerations in mind:

Type Select LDAP.
LDAP Server Select the LDAP server you created in Step 1.
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@ Dashboard > New Administrator
® Deception > "
ministrator: ADuserSall
Incident > | serely |
€ Fabric 3 Type: (Clocal ®LDAP (O RADIUS
ins Network > Admin Profile: | Read Only v|
£ System ¥ | Timezone: [(GMT-8:00)Pacific Time(US&Canada) v
LDAP Server:
Admin Profiles
Cortiheates Trusted Host #1: [0.000/0000 |
LDAP Servers Trusted Host £2: | 255.255.255.255/255.255.255.255 |
RADIUS Servers Trusted Host #3: | 255.255.255.255/255.255.255.255 |
Mail Server IPv6 Trusted Host #1: B |
SNMP
1Pv6 Trusted Host #2: ER |
FortiGuard
IPvé Trusted Host #3: -
FDC License e o |'JO |
Settings Comments:

Login Disclaimer
Table Customization

L Log »

3. Click OK.
4. (Optional)To test the user credentials, select the user you created, and click Test Login.

@ Dashboard
@ Deception
Incident
& Fabric

4F Network

R System

Admin Profiles

LDAP login test for: ADuserSally

Please enter your password

<

Certificates

LDAP Servers.

Enter the password and click OK.

@ Dashboard

@ Deception
E incident
@ Faoric
42F Network
R System

+ LDAP login test result for: ADuserSally

Login test passed.

C v v v v owv

Admin Profiles
Certificates
LDAP Servers
RADIUS Servers

Mail Server

Use the Active Directory user account you created to log in to FortiDeceptor.

@ Dashboard

Lure Distribution # 2 % SystemInformation s x
@ Deception » 310 Lures Deployed Appliance Mode standalone -
Incident > Host N FDCV Ch,
Q == XMPP WEB == HTTP == TOMCAT (HTTP) RTSP == CWMP st Name St [Change]
Fabric > = B.BRAUN (port 8080) == TCPListener == Printer-WEB == CAN Bus Protocol -
POS- = Teingt == SAP ROUTER == FTP == GIT == Jetdrect Serial Number FOC =gl
& Network N — SAP DISPATCHER == HTTPS == TP-LINK WEB — ICMP — MQTT WEB — SNMP
~— ERPWEB = UPNP = ScadaBR — CDP — SSH — TOMCAT (HTTPS) System Time 2022-09-17 22:13:27 PDT [Change]
B System B — SAMEA — P Camera WEE o, 84F WEE  sup DispaTCHER
v i Firmware Version ¥4.3.0,0uild0457 (Interim){Update]
1 Log > il P
o — /— Pl Firmware License © [Upload License]

ar
T / Hpaed System Configuration Last Backup: N/A [Backup/Restore]
2 — Current User ADuserSally
=5
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Import network users from the Active Director server for Decoy lure
configuration

To Import the lure user from the Active Directory server:

1. InFortiDeceptor, go to Deception > Lure Resources and click Import Users from LDAP. The Import Users from
LDAP dialog opens.

2. Configure the import and click Import. For more information, see Lure Resources on page 69.

Bind DN Username used to connect to the LDAP service on the specified LDAP Server.
For example:

uid=ssu.cn=ga.o=fdc.dc=fortinet.dc=com

LDAP URL Enter the LDAP URL using the following format:
[protocol///lhost[:port] [/basedn[?attribute,...] [?scope]
[?filter]]
For example:
ldap://<ip_
address>/cn=qga, o=fdc,dc=fortinet,dc=com?uid?sub?

Bind Password Enter the Bind DN's password.
CA Certificates Select RootCA.
£ FDC

b Dashboard Import Users from LDAP

# Central Management

Dl Deception o Import user names only from the LDAP server,
tor deployment step to use as lure login name in decoys.

Custom Decoy Image

Deception OS . 3
Version: Version 3
Deployment Network
Lar Bind DN: * uid=ssu,cn=qa,o=fdc.dc=fortinet,dc=com

Deployment Wizard

Idaps://172.16.69.92

Decoy Status LDAP URL: * |/cn= ga,o=fdc,dc=fortinet,dc=com?uid?sub?
Deception Token
Deployment Map Bind Password: * sessssse
Asset Discovery
CA Certificates: RootCA
Safe List
il Incident Search Limit: ‘
B.Fatnc TCP Timeot: 3600
* Network
Search Timeout: ‘ 3600
b System
i1 Log SASL Bind User: ‘
SASL Bind Mechanism: \
Tag: any
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MFA (RADIUS) configuration

To integrate the RADIUS service with FortiDeceptor:

1. Configure FortiAuthenticator on the RADIUS server side.
2. Configure the RADIUS user on FortiDeceptor.

1. Configure FortiAuthenticator on the RADIUS server side

1. Add the radius clients for remote RADIUS service access.

a.
Authentication Client window opens.

Configure the client service settings. For information, see Clients > To configure a RADIUS client in
FortiAuthenticator Administration Guide.

Click OK.

& FortiAuthenticator VM FAC-VM

In FortiAuthenticator, go to Authentication > RADIUS Service > Clients, and click Create New. The Create New

the

stem + Create New | & Import

thentication

>
v

& User Account Policies > - Hame Sllert Name/ 12

i@ User Management » (O 10.100.1.x 10.100.1.0/24

e Portals s O 10.10.1.x 10.10.1.0/24

=3 Remote Auth. Servers » |O 172.16.69.x 172.16.69.0/24

Clients

2. Create aradius policy for the radius client you created.

a.
opens.

E FortiAuthenticator VM FAC-VMTM22005157

Go to Authentication > RADIUS Service > Policies, and click Create New. The RADIUS Policy Creation Wizard

stem; > | 4 Create New

thentication v
a Name

P e RADIUS Clients Authentication Type RADIUS Attribute Criteria Authentication Type
ser Account Policies >

W User Management =] pio 10.10.1, 10.100.1.x Password/OTP

e Portals » (O P69 172.16.69.x Password/OTP

£ Remote Auth. Servers > | 2/ 3000

& RADIUS Service v

Clients

Follow the steps in the wizard to configure the policy. For information, see Policies > To configure a
policy in the FortiAuthenticator Administration Guide.

Click OK.
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3. (Optional) Create or import a FortiToken.

a. InFortiAuthenticator, go to Authentication > User Management > FortiTokens and click Create New.

jystem >
\uthentication v
& User Account Policies >

¢

agement >

Local Users

Remote Users

Remote User Sync Rules

Social Login Users

Guest Users

User Groups

Usage Profile

Realms

FortiTokens

MAC Devices

1AM
e Portals >
=2 Remote Auth. Servers >
& RADIUS Service »
& TACACS+ Service N

4. Create alocal user.

+ Create New | | @ Import| | & Export FTK Hardware

a Token Serial Number Token Type

[m] FTKMOB232E32138A FortiToken Mobile
[m] FTKMOB233FADOOE7 FortiToken Mobile
[m] FTKMOB23415B5DAE FortiToken Mobile
o FTKMOB2347182541 FortiToken Mobile
[m] FTKMOB23779508FF FortiToken Mobile
(=] FTKMOB237B9B7CCA FortiToken Mobile
[m] FTKMOB23A9082D90 FortiToken Mobile
(=] FTKMOB23B541ABBC FortiToken Mobile
[m] FTKMOB23CC32D5D0 FortiToken Mobile
[m] FTKMOB23EBEA9D58 FortiToken Mobile
[m] FTKMOB281BB1E691 FortiToken Mobile
[m] FTKMOB2869C67E7B FortiToken Mobile

12/ 60000 FortiTokens

& Refresh FTM

Status
Assigned
Assigned

Locked
Assigned

Locked

Locked

Locked

Locked
Available
Assigned
Available

Auvailable

Last Used
2022-08-24T717:24:00
2022-08-23722:59:00

N/A
2022-05-11T17:13:00
N/A
N/A
N/A
N/A
N/A
2022-07-13T16:10:00
N/A
N/A

a. Go to Authentication > Local Users and click Create New.
b. Configure the user settings and click OK.

FAC-VMTM2200

Comment

token does not belong to product

Disassociate FTM from user failed
token does not belong to product
token does not belong to product

token does not belong to praduct

User
Local: gsmobile

Local: radius1

Local: lushu

Local: tokentest

arch for FortiTokens

Algorithm
TOTP
TOTP

TOTP

TOTP

ystem »
uthentication ~
& User Account Policies »

Local Users

Remote Users

Remote User Sync Rules

Social Login Users
Guest Users
User Groups
Usage Profile
Realms
FortiTokens
MAC Devices
1AM

+&» Portals

S8 Remote Auth. Servers >

& DARNIC Caminn

Create New Local User
Username:

Password creation:
Password:

Password confirmation:

& Allow RADIUS authentication
(I Force password change on next logon

Role

Role:
Account Expiration
(Z® Enable account expiration

1AM

Account:
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c. Afterthe useris created, enable OTP with FortiToken for this local user.

One-Time Password (OTP Enable.
authentication

Deliver token by FortiToken

=& FortiAuthenticator VM FAC-VMTM22005157

ystem * | Edit Local User
uthentication v | @ The local user "user3" was added successfully. You may edit it again below.
& User Account Policies * | Username: user3
% User Management B Disabled
Local Users & Password authentication | change Password
Remote Users @ One-Time Password (OTP) authentication
Remote User Sync Rules Deliver token code by: Emal | SMS | Dual {Email & SMS)

Social Login Users Hardware Mohile m

Guest Users Activation delivery method: m SMS

User Groups
== Tempaorary token
Usage Profile
B 1 FIDO authentication .
et @ Allow RADIUS authentication
. (I Enable account expiration
MAC Devices ~
1AM (I Force password change on next logon
[ Sync in HA Load Balancing mode
& Portals »
User Role
E8 Remote Auth. Servers >
Role: Administrator Sponsar
& RADIUS Service > |
I Allow LDAP browsing
& TACACS+ Service »
& LDAP Service »
First name: Last 4
& OAuth Service » stname
ﬁ SAML IdP R Email: Issu@fﬁrtinettom{
£73 FAC Agent . Mokile number: B#0 +1 ~ 506-234-5678 SMS gateway: Use default v Test SM!

ortinet 550 Methods > Streebaddress;
. City: State/Pravince:

5. Activate the FortiToken for this user via an email link.

2. Configure the RADIUS user on FortiDeceptor

1. Add the RADIUS server.
a. InFortiDeceptor, go to System > RADIUS.
b. Configure the server settings and click OK.

ﬂ We recommend enabling Push notification to mobile of applicable to allow users to
authorize the login with a mobile device.
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278 FDC

@ Dashboard >  Edit RADIUS Server
& Central Management >
Name:
@ Deception >
Incldent 3 Primary Server Name/IP:
@ Fabric > Secondary Server Name/IP:
i Network > Port:
% System ¥ Auth Type:

Administrators -
Primary Secret:

Admin Profiles

Secondary Secret:
Certificates

| DAP Servers Naalk:

Mail Server
SNMP
FortiGuard

[1812 \

@Any OPAP (QCHAP (OMSv2

2. Addthe local user you created in FortiAuthenticator.
a. Goto System > Administrators and click Create New.
b. Configure the Administrator settings and click OK.

FDC -

& Dashboard > New Administrator
& Central Management >

Administrator:
® Deception >

Type:
Incident > Ype
(ﬁ Fabric >
5 Network > Admin Profile:
£ System v Timezone:

Administrators

Admin Profiles

RADIUS Server:

Trusted Host #1:

Certificates
Trusted Host #2:
LDAP Servers

RADIUS Servers Trusted Host#a:

Mail Server IPv6 Trusted Host #1:
SNMP IPv6 Trusted Host #2:
FortiGuard 1Pv6 Trusted Host #3:
FDC License

Comments:
Settings

Login Disclaimer
Table Customization

L Log >

c. Click Test Login to verify the credentials.

Integrate with Checkpoint Firewall

|user3 |

Olocal OLDAP ®RADIUS

Push notification to mobile if applicable

| Read Only v
[ (GMT-12:00)Etc/GMT-12 3
| 172.16.69.92 v

|0.0.0.0/0.0.00

| 255.255.255.255/255.255.255.255

|=/0

|::/0

|
|
|255.255.255.255/255.255.255.255 |
|
|
|

B

All the configurations for CheckPoint Firewall are done with the SmartConsole.
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1. Configure the REST API permissions.

Open the SmartConsole and go to Management APl and click Advanced Settings > All IP addresses.
Click Publish.

Use SSH to log in to the manager server, then type api restart.

Create a domain object named . quarantine.com.

Create a network group object named fdc-block-ip.

Add the domain object named . quarantine. com to the network group object named fdc-block-ip.
Create a new policy rule.

No ok obh-=

a. Create a new policy rule named quarantine.
b. Setthe policy Source to fdc-block-ip.
c. SetDestinationtoAny.

Destination VPN Services & Applications Action

w1 quarantine a5 fdc-blodk-ip ¥ Any * Any ®  Any £ test
1.1 Cleanup rule % Any B oy *® Amy % Any @® Drop
2 test_quarantine B PRI % Any * Any #  Any & Accept
3 Cleanup rule * Any # Any * Any *  Any @ Accept

d. Set Actionto Inline Layer > New Layer. Give the layer a name such as Cleanup Rule and click OK.

i B Applicati Acti
Services B Applications ian Network Grou|

B fdc-blogk-

on Rnt-block

#  infine Layer . ——

e. Set Action to Drop.
f. You can use the default settings for the other fields.
8. (Optional) Make the CheckPoint Fire Wall pingable.
a. Logintothe SmartConsole.
b. Go to Global Properties and enable Accept ICMP requests.
c. Install the policy.

2. Configure FortiDeceptor

1. On FortiDeceptor go to Fabric > Quarantine Integration, and click +Quarantine Integration with New Device.
2. Configure the new device based on the following recommendations and click Save.

Integrate Method Select CheckPoint-FW-Isolation.
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IP Block Policy (network Enter the group object name you created (fdc-block-ip).
Group Name)

Username Enter the Username for the management account in CheckPoint Fire Wall.
You can create new admin with AP| permissions or use Admin.

Password Enter the Password for the management account in CheckPoint Fire Wall.
Verify SSL Disable.
Install Policy After Publish Enable.

Integrate With New Device x

Enabled: ()
Name: * |fg‘{blocker2 |
Integrate Method: CheckPoint-FW-Is... ¥

© Compatible CheckPoint version: R81 build392 or later

IP: * | |

Port: * [443 |

IP Block Policy(Network Group Name): * |fdc—b|ock—ip |

Expiry: * | 3600 | seconds
Username: * |admim |
Password: * |--n----uu. |

Verify S5L:

Install Policy After Publish: ()

Save Cancel

Integration with Crowdstrike

1 Configure CrowdStrike

Al
S L4
9 OAuth2 will be used for authentication of the incoming REST API requests.
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1.1 REST API Permission

To define a CrowdStrike API client, you must be designated as the Falcon Administrator role to view, create, or modify
API clients or keys. Secrets are only shown when a new API Client is created or when it is reset.

1.2 Create client ID and client secret

1. Login to the Falcon UL.
2. Goto Support > API Clients and Keys to view existing clients, add new API clients, or view the audit log.

3. Click Add new API Client. You will be prompted to provide a descriptive name and select the appropriate API
scopes.

4. Click Save. You will be presented with the Client ID and Client Secret. The secret will only be shown once and
should be stored in a secure place. If the Client Secret is lost, a reset must be performed and any applications
relying on the Client Secret will need to be updated with the new credentials.
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Add new API client

Read Write
Detections
- -
Hosts
Host groups
Prevention policies
) o - -
Sensor update policies
User management
CANCEL ADD

2. Configure FortiDeceptor

—

In FortiDeceptor, go to Fabric > Quarantine Integration.
Click + Quarantine Integration with new device. The Integrate With New Device window opens.
3. Configure the integration settings.

N

Name Enter the Quarantine Integration name.
Integrate Method Select CrowdStrike-Isolation from the dropdown list.
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Server URL Set the server URL
Client ID Enter the Client ID.
Client Secret Enter the Client Secret.

Integrate With New Device x

Enabled: D

Name: * |fg’tb|0cker2

Block Severity: Low Medium
Integrate Method: CrowdStrike-Isola.. ¥
Server URL: * |https:f/api.crowdstrike.com
Client ID: * |

Client Secret: * |

Verify SSL: * [ @)

Expiry: * [3600

Save Cancel

4. Click Save.
5. Confirm the status is Ready.

_—
- o @ Ready crowdstr... CrowdSt..

X Delete Isolation

Integrate with Cuckoo Sandbox

1. Configure Cuckoo Sandbox

Server URL: https:/api.crowdstrike.com; Client ID:
db65fe8087244cc59ff201¢33c5af993; _ Client
?(e)goe_t: premwmesssss. Verify SSL: false;  Expiry:

For information about installing Cuckoo Sandbox, please see the product documentation.

1.1 Start Cuckoo Sandbox

Before starting Cuckoo Sandbox, ensure the guest machine (for example, Win 7 running in VirtualBox) has started. To

start Cuckoo, use the command cuckoo_venv.

In this example, cuckoo is installed in the Python virtual environment. In this case, you will need to activate the virtual

environment first.

(cuckoo_venv)
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1.2 Start cuckoo API server

To start the Cuckoo API server, use the following command:

cuckoo api --host 172.16.69.243 --port 1337

(cuckoo_venv) : $ cuckoo api --host

172.16.69.243 --port 1337

\
S g -
q To access to the API, the api_token can be found in <cwd>/conf/cuckoo.cfg.

Troubleshooting:

If you see the following attribute error when requesting the API:

AttributeError: 'Request' object has no attribute 'is xhr'

Open /flask/app.pyandset JSONIFY PRETTYPRINT REGULARtO False.

Therequest.is xhr property was deprecated since Werkzeug 0.13 and removed in Werkzeug 1.0.0. As a result,
this error will occur when using Flask <= 0.12.4 and Werkzeug >=1.0.0 because Flask uses this property in the source
before the 1.0.0 version.

2. Configure FortiDeceptor to integrate with Cuckoo Sandbox

1. In FortiDeceptor go to Fabric > Detection Devices.
2. Enable Cuckoo Sandbox.
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3. Configure Cuckoo Sandbox.

IP/URL Set the IP the based on the command in step 1.2 Start cuckoo API server.
Port Set the Port the based on the command in step 1.2 Start cuckoo API server.
API Token API token information can be found on <cwd>/conf/cuckoo.cfgq.
D CuckooSandbox
IP/URL: " | |
Port: * ‘ ‘
API Token: * | |

4. Click Test. You should see The Cuckoo device <IP> is accessible".

=2 Forti Deceptor VM @ The Cuckoodevice is accessible.

O Deception «  FabricDetection

3. Verify the detection result from Cuckoo Sandbox

1. Copy afile from any endpoint to the decoy using SMB/FTP protocol and verify that the file is captured and analyzed
by the Cuckoo sandbox.

2. To verify the result in FortiDeceptor:
a. Goto Incident > Analysis.
b. Expand the incident and verify Cuckoo-Sandbox Result is displayed.

® 4minutes later(2022-04-14 16:14:05 UTC)

FTP Traffic: uploaded file

& Download File
MD5 5fb521491319c%c3f40976007085d7al
File Size 768 KB
File Type exe
Virus W32/Allaple.gen!tr
Virus Total Result 2/62 security vendors flagged this file as malicious
& Download VT detail result
FortiSandbox Result Clean [Score is Oand scan takes 163 seconds]
& Download PDF
Cuckoo-Sandbox Result Score is 0.0 and scan takes 20 seconds
& Download Cuckoo detail result
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3. To verify the result in Cuckoo Sandbox, go to WebU! > Recent. Open the Cuckoo report to verify result.

@ Dashboard

Files  URLs Score 0-4
1 2022-04-27 17:28
10 2022-04-27 16:09
9 2022-04-27 16:06
8 2022-04-27 16:03
7 2022-04-27 16:02
6 2022-04-27 16:00
5 2022-04-27 15:57
4 2022-04-27 15:26
3 2022-04-27 15:17
2 2022-04-25 10:32
1 2022-04-25 10:32

%% Pending Q Search

Score4-7 Score 7-10

15e5¢578¢4239083€207b5eac3d1aaos

2a991d6e29bf8ebac1b56c599dffceda

aa991d6e29bf8ebac1b56c599dffceda

2a991d6e29bf8ebac1b56c599dffceva

bb6abcdba7a31278e80476a8b4d86d86

2a991d6e29bf8ebac1b56c599dffceda

aa991d6e29bf8ebac1b56c599dffceda

25af89feese2d9aasa228dea371b733

828584873dd396764a2a944b884a1853

acc206e68c70cceca2af34600300802¢

1d4c23ce9418a78ddfc93683ae337c7d

Integration with FortiSIEM

To integrate FortiDeceptor with FortiSIEM:

1. Configure FortiSIEM as a remote log server in FortiDeceptor
2. Change the discovered FortiDeceptor status from Pending to Approved

EICAR_TEST_FILE
EICAR_TEST_FILE
EICAR_TEST_FILE
EICAR_TEST_FILE
temp_file
EICAR_TEST_FILE
EICAR_TEST_FILE
temp_file
temp_file
temp_file

temp_file

3. Check the logs and generate reports in FortiSIEM

reported
reported
reported
reported
reported
reported
reported
reported
reported
reported

reported

1. Configure FortiSIEM as a remote log server in FortiDeceptor

1. InFortiDeceptor, go to Log > Log Servers.
2. Click Create new. The New Remote Log Server window opens.
3. Configure the Log Server Address for FortiSIEM and click OK. For more information, see Log Servers on page 150.

centos-decoy-test

@ Dashboard
&% Central Management
@ Deception
Incident
¥ Fabric
€% Network
& System
L Log
All Events

> Edit Remote Log Server

>

Name:
>
3 Type:

> Log Server Address:

¥ Port:
>
Status:
v
& Alert Logs

Critical Logs
Error Logs
Warning Logs
Information Logs

Debug Logs

FortiDeceptor 5.2.2 Administration Guide

Fortinet Inc.

O Enable
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@ Disable

Submit

Cancel
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2. Change the discovered FortiDeceptor status from Pending to Approved

1. InFortiSIEM go to Devices and select the FortiDeceptor device from the list.
2. Click the Actions dropdown and change the status from Pending to Approved.

Change Status

Hame Status

FoC approved

Change Status to:  Pending

3. Check the logs and generate reports in FortiSIEM

ﬂ To see how FortiSIEM and FortiDeceptor integrations improve cyberthreat detection and

increase visibility of potential attacks, watch this short video FortiSIEM Demo: FortiSIEM and

FortiDeceptor Integrations

1. InFortiSIEM click the DASHOBARD tab, the Fortinet Security Fabric dashboard, and click the FortiDeceptor

dashboard. The information received from FortiDeceptor is displayed. You can click on any widget to drill down on

the information.

@ DASHBOARD -

FortiSandbox FortiGate Threat FortiGate Traffic FortiMail FortiClient FortiCare 360

+ Y Layout: Tile = ]
(82%)192.168.....:19; 2
(47%)192.168.100.19
5:1200
7%)218.92.0,208: 157 (25%)192.168.100.19
(2%)85.209. 7 :
(1%)85.209.0.101:35
(1%)222.186.30...:33
o0 o0
FortiDeceptor: IPS Attacks an Decoys Source IP to 2adstx : Decoy External FortiGuard Activity By Destina.Z Q@ &5x  For : Top Process 2a0sx
Last 8 hours®13:15 Last 8 hours®13:15 Last 8 hours@13:15
Destination TCP / UDP  COUNT(Matched COUNT(Matched
Destination IP Port Events) Operation Name ~ Description Events)
LI T98.67 w3z ~ “launch process  C:\Program App-
192.148.1.200 13.226.42.117 443 12— Other file opera.. %PROGRAMFILES%\Google\Chrome'\Ap... 79I
23.210.180.135 443 12— ] o/Suspand pr..  CAPRogram F pp.. 76—
192.168.1.196.
185.199.111.154 443 12— Launch process C:\Windows\System32\net. exe 60N
181168, 15,205, 213.211.198.58 443 12— p/Suspend pr.. € .exe [ =
213.211.198.62 80 12— Launch process  C:\Windows\System3Z\net!, exe sl
I 13.32.87.92 443 o ] p/Suspend pr..  C: 1exe 45l
. 192.168.1,203
progrry 13.35.112.29 80 o ] Launch process C:\Windows\explorer.exe 36l
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2. Inthe Top Services widget click SSH.

@ DASHBOARD

Fortinet Security Fabric» | §  FortiSandbox FortiGate Threat FortiGate Traffic FortiMail FortiClient FortiCare 360 FortiDeceptor X FortiEDR X FortiADC X L] » a

+|7 Lyout: Tie- & L & @
Top Attacker Q08O x  Top Victim ZaoaOx | Top Services caoscx
Last 8 hours@13:15 Last 8 hours@13:15 Last 8 hours@13:15
COUNT(Matched Events) COUNT(Matched Events)
(32%)192.168.10.20:9 il
(82%)192.168....:1920° o
MODBUS
unknown
ssu
SAMBA Drill Down 2
L
(47%)192.168.100.19 N
r 5:1200 P
D — BACNET
4 URRUESLD 208187 (25%)192.168.100.19
12%)85.209.0.103:54 L
11%)85.209.0.101:35 AST
(1%)222.186.30. 3
o B

The events and the raw logs are displayed in the ANALYTICS tab.

s ANALYTICS

BActions » | | X [1] Raw Messages % (2] FortiDeceptor: Top Services
B~ [sym. Name = S5H AND (( Event Type = FortiDe /L OR Event Type » FortiDecep | QRun Chart for COUNT(Matched Events) « | i =

FortiDeceptor: Top Services - Today 05:19:13 AM to 01:19:13 PM 15m 1h 1d 7d 304 3p

©
[
v 50 0 0 o ) wo % woe 10 w0 ) 15os

(0 wrap Raw Events K < 1140 7 > M
Event Recetve Time Service Name Raw Event Log
Jan 152021, 12:04:43PM. SSH <25>2019:09-26720:20:32 device-FortiDeceptor version=1.2 devhost=FDC-VMO000000303 devid=FDC-VMOODD000303 logver=25 tzone=0 t2=UTC date=2019-09-26 time=20:20:32 logid-0106000001...
Jan 15 2021, 12:04:43 PM SSH <25>2019.09-26T20:20:32 device=FortiDeceptor version=1.2 devhost=FDC-VMO000000303 devid=FOC-VMOODD000303 logver=25 tzone=0 tz=UTC date=2019-09-26 time=20:20:32 logid=0106000001...
Jan 152021, 12:04:43 PM. SSH <25:2019.09-26T20:20:32 device-FortiDeceptor version=1.2 devhost-FOC-VM0000000303 devid=FDC-VMO000000303 logver=25 tzone-0 tz=UTC date=2019-09-26 lime=20:20:32 logid=0106000001...
Jan 152021, 12:04:43PM SSH <2552019.09-26720:20:28 device-FortiDeceplor versions1.2 devhost=FDC- VMO000000303 devid=FDC-VMOOODD00303 logver<25 tzone=0 tz<UTC date-2019-09-26 time=20:20:28 logid 0106000001
Jan 152021, 12:04:42 PM. SSH £25+2019.09-26720:20:15 device-FortiDeceptor versions1.2 devhost=FOC-¥M0000000303 devid=FDC-VMOO00000303 logver=25 tzones0 tz=UTC date=2019-09-26 time=20:20:15 logid=0106000001
Jan 15 2021, 12:04:42 PM.  SSH £25:2019.09-26T20:20:11 devi version=1.2 devid=FDC logver=25 tzone=0 12=UTC date=2019-09-26 time=20:20:11 logid=0106000001..
Jan 152021, 12:04:42PM. SSH <25>2019.09-26720:20:17 device-FortiDeceplor version=1.2 devhost=FOC-VMO000000303 devid=FDC-VMOOOD000303 logver=25 tzone=0 12-UTC date=2019-09-26 time=20:20:17 logid~0106000001...
Jan 152021, 12:04:42PM SSH <25>2019.09.26720:20:15 device-FortiDeceplor version=1.2 devhost=FDC.VMO000000303 devid=FDC-VMOOODD00I03 logver=25 Lzone=0 tz=UTC date=2019-09-26 time=20:20:15 logid-0106000001

3. Use a Group By and the Display Fields template to view the Source IP and Destination IP.

& ANALYTICS 'y

@Actions » | § X [1] Raw Me X [2] FortiDeceptor: Top Services
> | Service Name = 55H AND (( Event Type = FortiDeceptor-Alert OR Event Type = FortiDecep Q Run Chart for COUNT(Matched Events) = - -
au
Group By and Display Fields Load | Save | Clear Al b iAo
Attribute Order Display As Row Move
0
Source IP 4 ce oo
; Destination IF g oo oo
COUNT( Matched Events ) J Count ©c o o o©
ho: Display Conditions
o+ ! Paren Attribute Operator Value Paren Next Row
jayeey sapp ) ) o ) ! 3 nae 1200 B [
e e - o o wo - @@
Wrap Raw Events H < 1740 784 > M
Event Receive Time Service Name R§ Ml&,ﬁ Run Apply Cancel
FOTSTOTTe T2 TogveT tzone=0 tz=UTC date=2019-09-26 time=20:20:32 logid=0106000001
Jan 15 2021, 12:04:43 PM SSH typesevent sublypessystem levelsalert userssystem ulsGUI action=update SLAUS=SUCCEss MIgs"AtLACKerp=192. 168.1.53 AttackerPort=57043 Victimip=192.168.1.200 VictimPort=22
Opera £ S5H session Deserip n closed Username=NA Password=NA

<25>2019-09.26T20:20:32 device-FortiDeceptor version= 1.2 devhost-FDC-VMO000000303 devidsFDC-YMOO0D000IO3 logver=25 tzane=0 tz-UTC dates2019-09-26 time=20:20:2 logid=0106000001
Jan 152021, 12:04:43 PM SSH type=event subtype=system level-alert user=system ui=GUI action-update status-success msg="Attackerlp=192.168.1.53 AttackerPort=57043 Victimip=192.168.1.200 VictimPort=22
Operation=SsH cannection closed ServicesSSH Description=192.168.1.53 UsernameNA PasswordNA

<25>2019-09-26T20:20:32 devicesFortiDeceptor versions1.2 devhost=FDC-YMOO00000303 devid=FDC-VMO000000303 logver=25 tzane=0 tz<UTC date<2019-09-26 time=20:20:32 logid=0106000001
Jan 15 2021, 12:04:43 PM SsH typeevent subtype=system level=alert user=system ui=GUI actien=update status=success msg="Attackerlp=192.168.1.53 AttackerPort=57043 Victimip=152.168.1.200 VictimPort=22
Operation=Authentication Fallure Service=SSH Description=invalld user frannk Usemame-Invalid user frannk Password=NA

<25»2019-09-26T20:20:28 device- pror version-1.2
Jan 15 2021, 12:04:43 PM S5H typesevent subtype=system level=alert user

devid-FOC logver=25 tzone-0 tz-UTC date-2019-09-26 time-20:20:28 logid-0106000001
ystem ui=GUI action-update status-success msg="Attackerlp=192. 168. 1.53 AttackerPort=57043 Victimip=192.168.1.200 VictimPort=22
Operation=Authentication Failure Service=55H Description=invalid user frannk Username=invalid user frannk Password=NA"

The Source and Destination IPs are displayed.
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QActions v |3 X [1] Raw Message X (2] FortiDecoptor: Top Services
@+ | service Name = S5i1 AND (( Event Type = FortiDeceptor-Alert OR Event Type = Fo Q Run Chart for Count ~ | v
FortiDeceptor: Top Services - Today 05:19:13 AM to 0 15m 1h 14 74 304 37
H < 1 3 > N
Source IP Destination IP x Count
@ 19216815 192.168.15.200 64
192.168.1.53 192.168.1.200 136
192.168.1.196 192.168.1.200 84

information about the incident.

A INCIDENTS

Click the Incidents tab. Select and incident in the list and the click the Details, Events, and Rule tab to view more

QActions » | BB Overview & Risk

List by Time =

All Incidents

Severity

Category Incident Title

BRI  successful SSH Login to Decoy from 192.168.1.53
B 5 Attack to Decoy from 192.168.1.196
EEIZE 75 Attack to Decoy from 192.168.1.196

1PS Attack to Decoy from 192.168.1.196
BEIZEE 75 Attack to Decoy from 192.168.1.196
Successful $SH Login ta Decoy from 192.168.1.196

1PS Attack to Decoy from 192.168.1.196

& Explorer

Details Events Rule | [ Auto expand
Attributes
Category: Security
Count: 3

Event Name:

Event Type:

First Occurred:

FortiDeceptor
Login to Decoy
FortiDeceptor_Successful_SSH_Log
in_to_Decoy

Jan 15 2021, 01:05:00 PM

Successful SSH

0 Actions »

Change Display Columns.

B Overview

List by Time » 2 Risk

€ Clear All Incidents in View

Q search

X Show Locations

© Change Severity

€ Clear Incigent

10 Decoy from 192.168.1.53
om 192.168.1.196
om 192

168.1.196

© Create Event Dropping Rule

W Create Case.

X Disable Rule
# Edit Comment

[ Edit Rule

© Edit Rule Exception
# Export Incident

B8 Notify via Email

6 Resolve Incident

om 192.168.1.196

om 192.168.1.196
0 Decoy from 192.165.1.196
om 192.168.1.196

b 103 sae s vne

spattem: filter = B Auto expand

#nt Name

Gk Run External Integration. .

D Show Ticket History

Jan 13 £uet, Urveieo Fm

rortiDeceptor-Established_SSH_connection

= Last Occurred

Jan 15 2021, 01:06:00 PM

Jan

152021, 01:05:00 PM

Jan 15 2021, 01:05:00 PM

Jan 15 2021, 01:05:00 PM

15 2021, 01:05:00 PM.

Jan 15 2021, 01:05:00 PM.

152021, 01:04:30 PM.

Incident Comments

1 Explorer

= Last Occurred

Jan 15 2021, 01:06:00 PM

2021, 01:05:00 PM

Jan

Jan 15 2021, 01:05:00 PM

Jan 15 2021, 01:05:00 PM
Jan 15 2021, 01:05:00 PM
Jan 15 2021, 01:04:30 PM

e 1K M98 A a0 B

[ Wrap Raw Events

Reporting 1P

192.168.137.55
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o Attacks

B usa

Reporting
FDC-VMO000000303

VM0000000303
VM0000000303
VM0000000303
FDC-VMO000000303
VMO000000303

FDC-VMO000000303

Attacks

& ueBA

Reporting

FDC-

FDC

ene

[ show Event Type

VMOD00000303

VMOD00000303

VMOD00000303

VMODD0000303

VMOD00000303

VMODD0000303

VMOD00000303

Source IP

® 19216015

&1 minute =

21 minute »

“

Q search
Source

192.168.1.53
192.168.1.19

192.168.1.196

192.168.1.196

192.168.1.196

192.168.1.19

192.168.1,196

03 a4 ane

Ti

Q search

Source

192.168.1.53

192.168.1.196

192.168.1.196

192.168.1.196

192.168.1.196

92.168.1.196

192.168.1.196

189 149 1 1

O Show Raw Event Only

Target

4

192.168.1.200

192.168.1.205
Destination TCP/UD.

192.168.1.200
Destination TCP/UD.

192.168.1.205
Destination TCP/UD..

192.168.1.205
Destination TCP/UD.

192.168.1.200

192.168.1.205
Destination TCP/UD.

2.168.1.205

Action History

me.

Target

-

.

192.168.1.200

192.168.1.205
Destination TCP/UD.

92.168.1.200
Destination TCPAUD...

192.168.1.205
Destination TCP/UD.

192.168.1.205
Destination TCP/UD.

192.168.1.200

192.168.1.205
Destination TCP/UD...

192.168.1.205

Destination IP

192.168.1.200

Attack Name:

Attack Name:

Attack Name:

Attack Name:

Attack Name.

Action

Detail

Attack Name:

Attack Name:

Attack Name:

Attack Name:

Attack Name:

applications: MS.SMB. Serve.

tools: Nmap.Script.Scanner

applications3: MS.SMB. Serve.

backdoor: Backdoor. Double.

backdoor: Remote, CMD, Shell

Fan thatt

Result

Click the Actions menu and select Remediable Incident to block the IP address.

Destination TCP/UDP

Incident Status

Active

Active

Active

Active

15m 1h

Resolution

Open

Open

Open

Open

Open

Open

Open

15m 1h

14

”moon

ternal User

7d 04

> M

Or

7d 304

K € 2 2 >N
Incident Status Resolution External User or
Active Open
applications3: MS.SMB.Serve...  Active Open
tools: Hmap.Script.Sca Active Open
applications3: MS.SMB.Serve..  Active Open
backdoor: Backdoor.Double—.  Active Open
Open
backdoor: Remote.CMD.Shell  Active Open
P
Raw Event Log
19:32:09 versions1.2 -
VMO000000303 devideFDC-VMO000000303 logvers2$ tzones0 tzaUTC
time=19:32:09 typerevent sublypersy
level-alert uisGUI -
mige” Ip 168.1.53 168.1.200
p $SH connection
D 2.168.1.53 Us :
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FortiSIEM Watch List

Deception Tokens are part of the FortiDeceptor platform and are included in the product license at no additional cost.
FortiDeceptorTokens:

« Are an agentless technology.

« Deceive threat actors by adding breadcrumbs to real endpoints and servers so the actor engages with network
decoys instead of real assets.

« Are normally distributed within real endpoints and server assets to expand the attack surface.

FortiDeceptor generates a deception token package based on the decoy service configuration. The FortiDeceptor and
FortiSIEM integration for the Watch List detects when a threat actor attempts to use the fake credentials from the token
package to access a real asset (as opposed to a decoy). FortiDeceptor cannot detect this type of access because the
asset is not a decoy. When integrated, both the FortiDeceptor and FortiSIEM GUI will display an alert for this type of
access.

To integrate FortiDeceptor with FortiSIEM:

Configure FortiSIEM.

Configure the Watch List in FortiDeceptor.
Test the integration.

Check the incidents on FortiSIEM.

View the incidents on FortiDeceptor.

ok oN-=

1. Configure FortiSIEM

1. InFortiSIEM go to Watch Lists and click New to create a new watch list or edit an existing Watch List. For more
information, see Managing Resources > Watch List > Creating a Watch List in the FortiSIEM User Guide.

@ DASHBOARD I ANALYTICS ~ MUINCIDENTS il CASES S CMDB LM RESOURCES = TASKS €& ADMIN

e @
¥ Watch Lists

Q & Resources > Watch Lists > lureuser

vew | Edit | Detete ~ )
Accounts Locked Vew JREIEN SN [ Import Export & M < o0 0 > M
Application Issues Active Value Triggering Rules Count First Seen Last Seen

Authentication Issue
No Matching Watch List Found

Availability Issues

Availability Issues (IP)

Denied Countries

Denied Ports

Devices Under Attack

DNS Violators

Environmental Issues

FDC

Fortilnsight Alert

Hardware Issues

hi lo

Honeypot Match

Host Scanners

Mail Violators
Malware Found

Malware Likely 1P

2. Goto Resources and define the Watch List rules. For information, see Managing Resources > Watch List > Using a
Watch List > Adding a Watch List to a Rule in the FortiSIEM User Guide.
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In the image below, the usernames (face credential tokens) are generated automatically by FortiDeceptor during
the integration.

@ DASHBOARD I ANALYTICS ~ M INCIDENTS ~ W CASES S CMDB LM RESOURCES = TASKS ¢ ADMIN

0w Q @ Resources > Watch Lists > lureuser
~ Watch [ists
New | Edit  Delete p ,
T Ne Edit  De Q Import  Export K < 171 2 >
Application Issues Active Value Triggering Rules Count First Seen Last Seen

Authentication Issue Jultiple Logon Failures: Server 1/21/2022 2022-01-21;Multiple

= admin -
Logon Failures: Server 1/20/2022

2 Oct 17 2022, 10:42:30 AM Oct 17 2022, 10:44:30 AN
Availability Issues

Availability Issues (IP) ity Multiple Logon Failures: Server 1/21/2022 2022-01-21;Multiple

Logon Failures: Server 1/20/2022 N Cctiigiavzzipio:z:solen Oct 172022, 11:25:30 AM

Denied Countries
Denied Ports

Devices Under Attack
DNS Violators
Environmental Issues
FoC

Fortilnsight Alert
Hardware Issues

hilo

Honeypot Match

Host Scanners

Mail Violators

Malware Found

2. Configure the Watch List in FortiDeceptor

1. In FortiDeceptor, go to Fabric > Quarantine Integration and click Quarantine Integration With New Device.
2. From the Integrate Method dropdown, select FSM Watch-List.
3. Configure the integration settings.

IP Enter the IP for the FortiSIEM device.

Port Enter the Port number for the FortiSIEM device.

Username Enter the username for the FortiSIEM device.

Password Enter the password for the FortiSIEM device.

Watch-List Name Enter the name of the Watch List you created in Step 1 Configure FortiSIEM.
Lure Users-Manual Mode This option allow you to add more usernames manually to the FortiSIEM watch

list in addition to the one that FortiDeceptor generates automatically based on
the deception token package. Please enter the Lure Users you created and
separate multiple users with a comma.
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Integrate With New Device X

Enabled: (}

Name: * |fgtbtocker15 |

Severity: Low Medium
Appliance: Local®

Integrate Method: FSM-Watch-List ¥

@ Compatible FortiSIEM version: 6.3.3 or later

Ip:~ | |
Port:* | |
Username: * |ad min |
Password: * | sesssssnssns |
Qrganization: * |Super |
Verify S5L:

Woatch-List Name: | lureuser |
Lure Users-Manual Mode: |ad min,lily |
Polling Time Interval (seconds): | 1000 |

Save Cancel
4. Click Save.

3. Test the integration

To test the integration, use one of the fake credentials to access a real asset. Verify that FortiSIEM can detect fake
credentials when used to access an asset that is not a decoy.

[E£™ NUO@riuo-virual-macnine: ~ = 5} 2

4. Check the incidents on FortiSIEM

In FortiSIEM, go to Incidents to verify the incidents you triggered are reported. For information, see FortiSIEM Manager >
FortiSIEM Manager Incidents > FortiSIEM Manager Incidents - List View in the FortiSIEM User Guide.
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<
& Actions v | EBOverview 2 Risk | M Explorer | @UEBA | MITREATT&CK® v | @ Disable v 15m 1h 1d 7d 30d
All Incidents K ¢ 124 40 > M
gz‘;:;‘u‘fy + Last Occurred Incident Tactics Technique Reporting Source Target Detail Incident Stat
Usert howard "
Re
ubuntutg
Oct 17 2022, 10:44:30 Al Multiple Logon Failures: Ser..  Credential Access ubuntu1s 10.100.100.2 172.16.69.243 Triggered Event Count: 4 System Cle ;
User: lily a
ubuntuig
Oct 17 2022, 10:44:30 Al Jultiple Logon Failures: Ser..  Credential Access Brute Force: Password Guessing  ubuntu1s 10.100.100.2 172.16.69.243 Triggered Event Count: 2 System Cle
User: admin
ubuntutg ot
Oct 17 2022, 10:44:30 Al Multiple Logon Failures: Ser..  Credential Access Password Guessing  ubuntu1s 10.100.10.35 172.16.69.243 Triggered Event Count: 3 System Cle
User: lily1
ubuntutg
Oct 17 2022, 10:44:30 Al Multiple Logon Failures: Ser..  Credential Access Brute Force: Password Guessing  ubuntu1s 10.100.100.2 172.16.69.243 Triggered Event Count: 4 System Cle
User: lily
ubuntutg
Oct 17 2022, 10:44:30 Al Multiple Logon Failures: Ser..  Credential Access Password Guessing  ubuntu1s 10.100.100.2 172.16.69.243 Triggered Event Count: 2 System Cle
User: admin
ubuntutg
Oct 17 2022, 10:44:30 Al Jultiple Logon Failures: Ser..  Credential Access Brute Force: Password Guessing  ubuntu1s 10.100.10.35 172.16.69.243 Triggered Event Count: 3 System Cle
User: lily1
ubuntutg
Oct 17 2022, 10:44:00 Al Jultiple Logon Failures: Ser..  Credential Access Brute Force: Password Guessing  ubuntu1s 10.100.100.2 172.16.69.243 Triggered Event Count: 29 System Cle
User: ity
i 8 Valid Acc - ubuntu1g Count: 181 N
Oct 17 2022, 10:44:00 Al Sudden Increase in Failed Lo... Persistence, Privilege Escalation,De...  Valid Accounts: Local Accounts  ubuntu18 a1 69243 Avg Hatched Events: 74.80 Active
ubuntutg
Oct 17 2022, 10:44:00 Al Multiple Logon Failures: Ser..  Credential Access Brute Force: Password Guessing  ubuntu1s 10.100.100.2 172.16.69.243 Triggered Event Count: 31 System Cle
User: admin .
,
Details Events Rule | [0 Auto expand A v {

5. View the incidents on FortiDeceptor

In FortiDeceptor, go to Incident > Analysis to view the incidents you triggered.

I\ Incidents captured by FortiSIEM are recorded as UNKNOWN in the Protocol column.

centos-decoy-test @~ 0emer
hi >
@ Destioord £ Refresh [® PDF Report [ Export toCSV + Markallas read Show Interaction EventsOnly v
i Central Management >
@® Deception > Protocol T Severity T  AttackerIP Y Victim IP Y D T LastActivity ¢ T Type T Attacker!
[ Incident v
Ty 1 >  UNKNOWN 10.100.1035 172.16.69.243 2810991496540996537 2022-09-1913:59:11 PDT Interaction admin
Campaign
Attack Map 218 »  UNKNOWN 10.100.10.9 172.16.69.243 2810991465718068846 2022-09-19 13:59:11 PDT Interaction lily
MITREICS
@ Fabric > 15 » UNKNOWN 10.100.10.35 172.16.69.243 2810991617645259295 2022-09-19 13:56:49 PDT Interaction lily
& Netwnrk >

Click the arrow to expand the alert. You will see the incident was captured by FortiSIEM.
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£I2 centos-decoy-test

@ Dashboard

< Refresh PDF Report [ Exporttocsv + Markallas read
@® Deception >
Incident v Protocol Severity Attacker IP Attacker User
n 107 UNKNOWN gees 10.100.100.2 lily

Campaign a

Attack Map

MITRE ICS B Timeline B8 Table & Refresh
) Fabric >
& System >
0 Log N 2022-10-17 10:41:45 PDT

o (3 Attacker User: ity

2 Attacker IP: 10.100.100.2

@ Attacker Port: None

© rightafter(2022-10-17 10:41:45 PDT)

FortiSiem Event:
Logon Failure:

Failed SSH logon username: lily ReportinglP: 172.16.69.243
@ 1secondlater(2022-10-17 10:41:46 PDT)

FortiSiem Event:

Failed SSH logon username: lily ReportinglP: 172.16.69.243
Logon Failure:

© 2seconds later(2022-10-17 10:41:47 PDT)

FortiSiem Event:
Logon Failure:

*
V500

Failed SSH logon username: lily ReportinglP: 172.16.69.243

F:IATINET

Show Interaction EventsOnly v

v L5282 - @O admin -

Victim IP D Last Activity + Type

172.16.69.243 2852349365405044522 2022-10-17 10:43:33 PDT Interactio,

3

1-20f2items &

i

Mitigation using windows Remote Command

1. Configure the endpoint

1.1 Verify the endpoint domains and permissions.

FortiDeceptor will use the administrator account of the AD domain to access Windows endpoints. Please ensure the
Windows endpoints are connected to the AD domain and the administrator account of AD domain can access the

endpoints.

A\,

network interfaces.

The administrator can also be a domain local admin with permission to disable the endpoint

1.2 Open the Windows SMB port

By default, Windows blocks the SMB port 445. To open the port run the following command in PowerShell:

Set-NetFirewallRule -Name FPS-SMB-In-TCP -Enabled True
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1.3 Enable SMB

A\,

If the Firewall is enabled by the A/D GPO, you will need to add the FortiDeceptor management

IP to the exclusion list.

1. Typewf. mscinthe Windows search box.
2. Click Inbound Rules in the navigation pane.
3. Scroll down to File and Printer Sharing (Echo Request - ICMPv4-In).
4. Enable the options in both Private and Domain profile

File Action View Help
9 25 =2 HE
@ Windows Defender Firewall witl
&3 Inbound Rules
Outbound Rules

%% Connection Security Rules
» B, Monitoring

@ Windows Defender Firewall with Advanced Security

Press @ to exit full screen

Inbound Rules
Name Group Profile Enabled
{9 Delivery Optimization (UDP-In) Delivery Optimization All Yes
& Desktop App Web Viewer Desktop App Web Viewer All Yes
@ Desktop App Web Viewer Desktop App Web Viewer All Yes
@ DIAL protocol server (HTTP-In) DIAL protocol server Private  Yes
@ DIAL protocol server (HTTP-in) DIAL protocol server Domain  Yes
Distributed Transaction Coordinator (RPC) Distributed Transaction Coo... Domain No
Distributed Transaction Coordinator (RPC) Distributed Transaction Coo... Private.. No
Distributed Transaction Coordinator (RPC... Distributed Transaction Coo... Private.. No
Distributed Transaction Coordinator (RPC... Distributed Transaction Coo... Domain  No
Distributed Transaction Coordinator (TCP... Distributed Transaction Coo... Domain No
Distributed Transaction Coordinator (RPC... Distributed Transaction Coo... Private.. No
9 File and Printer Sharing (Echo Request - I.. File and Printer Sharing Private.. Yes
@ File and Printer Sharing (Echo Request - |... File and Printer Sharing Domain  Yes
File and Printer Sharing (Echo Request - I.. File and Printer Sharing Domain Ne
File and Printer Sharing (Echo Request - I.. File and Printer Sharing Domain No
File and Printer Sharing (LLMNR-UDP-In)  File and Printer Sharing All No
File and Printer Sharing (NB-Datagram-In) File and Printer Sharing Private.. No
File and Printer Sharing (NB-Datagram-In) File and Printer Sharing Domain  No
Eilm o Deintme Chasicm MD Mamna lm) il amdd Deimbms Chmsinn Rrcmaic  Ala
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Action
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow

Al

~

Actions

Inbound Rules

44 <8

e}

e

New Rule...
Filter by Profile
Filter by State
Filter by Group
View

Refresh

Export List...
Help

v v v w
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2. Configure FortiDeceptor

1. In FortiDeceptor, go to Fabric > Quarantine Integration and click + Quarantine Integration with new device.

2. Configure the integration settings ensuring the user has sufficient privileges to manage NICs.

Integrate With New Device

Enabled
Name *
Severity Filter

Appliance Filter

x

©

Low Risk Medium Risk HighRisk Critical

+

Agent Type

Agent Device

Origin: Block/Unblock will be executed in the device which the incident
0 is from. This origin type does not support integrate methods: Azure

Key/ AWS Key/ FSM Watch List.

Specific: Block/Unblock will be executed in the designated device.

Local -

Integrate Method

Domain
Username *

Password *

Windows Network Isolation -

0 FortiDeceptor will isolate the attacker by accessing the attacker's unit
via the deployment network where the related attacker comes from

@

Save Cancel

3. (Optional) Click Credentials Test and then click Start to test the connection.

Credential Test

IP/URL * \

Test Result @ Local: The IR Collector IRcol: the credential test for passed.

Integration with PAN devices

To integrate FortiDeceptor with PAN devices:

1. Configure PAN.

2. Configure the PAN device on FortiDeceptor.
3. Check the PAN status on FortiDeceptor.
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4. Verify the policy has been added on PAN.
5. Attack a decoy and check the quarantine status in FortiDeceptor.

1. Configure PAN

Create an administrator on the PAN device. For information, see the PAN-OS Administrator's Guide.

c. PA-440 DASHBOARD ACC MONITOR POLICIES

OBJECTS NETWORK DEVICE

PUBLIC KEY
rrrrrrrrrrr CATE AUTHENTICATI
AUTHENTICATION (WEB) | (SSH) PROFILE LOCKED USER

2. Configure the PAN device on FortiDeceptor

1. In FortiDeceptor, go to Fabric > Quarantine Integration and click + Quarantine Integration with new device.

2. Configure the integration settings and click Save.

Enabled

Name

Integration Method
Device IP

Port

Username
Password

Vsys

Policy Index

Expiry

FortiDeceptor 5.2.2 Administration Guide
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Enable

Enter a name for the integration.

Select PAN-XMLAPI.

Enter the IP for the PAN device.

Enter the port number for the PAN device.

Enter the username for the PAN device.

Enter the password the PAN device.

The virtual system (Vsys) which is configured on the PAN device.
Select Top or Bottom.

Default blocking time in seconds. Default is 3600 seconds.
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Integrate With New Device x

Enabled: ()
Name: " |PAN |
Block Severity [ low | Medum | High | Critical |
Integrate Method: PAN-XMLAPI ¥

O Compatible PAN-device version: 10.0.0 or later
Device IP: " | |
Port: * |443 |
Username: * |deceptor |
Password: [eeessssssses |
Vsys: * |Vsy31 |
Policy Index: * Top Bottom
Expiry: * |3600 |5econds

Cancel

3. Check the PAN status on FortiDeceptor

In FortiDeceptor, click Quarantine Integration and verify the PAN device status is Ready.

/ Edit X Delete V] @ Ready PAN PAN-XMLAPI

4. Verify the policy has been added on PAN

Device IP: 10.101.15.17; Port: 443; Username; deceptor,
Low 3Ig(e)l(s)_swmd:“““““”: Vsys:vsys1: Policy Index: top; Expiry:

For more information about PAN polices, see the PAN-OS Administrator’s Guide.

{ PA-340

NAME TAGS TYPE ZONE ADDRESS

(%]
e

Destination

USER DEVICE ZONE ADDRESS DEVICE APPLICATION | SERVICE

=)
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5. Attack a decoy and check the quarantine status in FortiDeceptor

To check quarantine status in FortiDeceptor:

1. Go to Fabric > Quarantine Status.

2. Search for the PAN device in the Integrated Device column.

228 centos-decoy-test

@ Dashboard

Start

End

Type

Integrated Device

Time Remaining

2022-09-2111.

2022-09-2111

Auto quarantine

PAN

1m 36s

>
Z Refresh
38 Central Management »
>
(@ Deceiion ] Attacker IP
Incident >
€ Fabric «( C 10.100.100.2
Detection Devices
10.100.100.2
Quarantine Integration
-

2022-09-2111..

2022-09-2111..

2022-09-2111.

N/A

Integration with Microsoft ATP

1. Configure Azure

1.1 Configure the permissions

For the Application registration stage, you must have a Global administrator role in your Azure Active Directory (Azure

AD) tenant.

1.2 Create an App in Microsoft

For information about creating an App in the Azure Active Directory, see Microsoft Defender for Endpoint API - Hello

World.
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Auto quarantine

Auto quarantine

fgtblocker20

wmidisable

0

0

Status Message
Quarantined )
N/A The device was...

Quarantine fail...
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2. Onboard devices on Microsoft 365 Defender

2.1 Verify the tenant IDs are identical

1. Login to Microsoft 365 Defender (https://security.microsoft.com/) with your Azure account.
2. Ensure the Tenant IDs in Azure and Microsoft 365 Defender are identical.
« Toview the Tenant ID in Azure, go to Azure Home > Azure Active Directory > Properties.

MU QUL IERBUDELK S

-

)
4 censes Tenant properties
2 Azure AD Connect Name *
: [ -
&=l Custom domain names
@ Mobility (MDM and MAM) Country or region

Password reset

~ Location
Il Company branding

9

e ;
& User settings Notification language

gt g

@ security Tenant ID
| o

Monitoring

« Toview the Tenant ID in Microsoft 365 Defender, go to Settings > Microsoft 365 Defender > Account.

Email & collaboration ~ & | Settings > Microsoft 365 Defender |

=
Review

g Exchange message trace

Account Account

- e
25 Policies & rules
Email notifications

Data Retention

& Cloud apps ~ Preview features
The service will store your data at rest in US. Read about data storage and privacy.
App governance Streaming API
Tenant ID
b Reports
= Audit Org ID
¥ Health

Q Permissions
%& Settings

O More resources

2.1 Onboard devices in Defender

1. In Microsoft Defender, go to Settings > Endpoints > Device management > Onboarding .
2. Onboard the endpoints you want to manage.
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3. Configure FortiDeceptor

1. InFortiDeceptor, go to Fabric > Quarantine Integration and click Quarantine Integration With New Device.
2. Configure the integration settings and click Save.

Integrate Method Select Microsoft-ATP.
Server URL Enter the URL of APl: https://api.securitycenter.microsoft.com.
Client ID Enter the Azure Client ID.
Client Secret Enter the Azure Client Secret.
Tenant ID Enter the Azure Tenant ID.
Enabled: ()
Name: * |fgtblocker7 |
Appliance:
Integrate Method: Microsoft-ATP v
Server URL:* |ﬁ.securitycenter.mTcmsnft.cnm|
Client ID: * [client 1D |
Client Secret: ® |CIientSecreI |
Tenant ID:* |Tenant 1D |
Verify S5L: * [ @)
Expiry: * [3600 |

3. Verify the device status is Ready

# Edit | X Delete Q Q Ready fgtblocker4 Microsoft-ATP Low _

Integration with FortiSandbox

FortiSandbox is an anti-virus engine. When integrated, FortiDeceptor submits malware to FortiSandbox and retrieves
the scanning result.

To integrate FortiDeceptor with FortiSandbox:

1. Create a new user role in FortiSandbox.
2. Integrate FortiDeceptor with FortiSandbox.
3. Verify the scanning results in FortiDeceptor and FortiSandbox.
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1. Create a new user role in FortiSandbox

Create a new user role whose with privileges to access JSON API.
1. Create an Admin Profile with JSON API privileges. For information, see Admin Profiles in the FortiSandbox
Administration Guide.
a. Goto System > Admin Profiles and click Create New.
b. Give the profile a descriptive Name such as testApi.
c. Under Control Access, select JSON API. Configure the other settings as required and click Save.

Administrator Profile

File Statistic/Scan = ~ >
Network Alerts ® O O
URL Statistic/Scan ® © O
Log Servers © O O
Log Settings ® © O
ﬂ':'& Control Access Disable l l Enable

Mark FPN ® ©

Download Original File ® o

JSON AP O ®

Allow On-Demand Scan Interaction ® O

Allow On-Demand Scan Video ® O

Recording

2. Create a new administrator with the profile you just created. For information see Administrators in the FortiSandbox
Administration Guide.

a. Goto System > Administrators, click Create New.
b. Setadministrator name and password.
c. From the Admin Profile dropdown, select the profile you just created and click OK.
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Administrator: api_user

Password:

Must be 6 - 64 characters Ic-ng and may contain upper-case letters, lower-case letters, numbers, and special characters

Confirm Password:

Enter the same password as above, for verification

Email Address: l I

Phone Number: l l

Phone number must start with +

Admin Profile: | testApi v

Type: ® Local OLDAP ORADIUS

() Device User
(J Two-factor Authentication (FortiToken Cloud)
(J Default On-Demand Submit settings

Restrict login to trusted host v

2. Integrate FortiDeceptor with FortiSandbox

1. Configure a user on FortiSandbox to use for access from FortiDeceptor.

2. InFortiDeceptor, go to Fabric > Detection Device. The Fabric Detection dialog opens.

3. Enable FortiSandbox.

4. Configure the device settings and click Save.

() FortiSandbox Test
IP/URL: *
Port: * 443
Username: * api_user
Password: sesssscsseee
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3. Verify the scanning results in FortiDeceptor and FortiSandbox

1. Send a SMB/FTP put attack to the decoy from the endpoint.
2. To verify the results in FortiDeceptor:
a. Goto Incident > Analysis.
b. Expand the incident and a make a note of the filename in the MD5 field and the FortiSandbox Result.

@ 5seconds later(2022-10-20 21:51:37 UTC)

SMTP Upload upload attachment dino.bin
Attachments:

= Download File
MD5 ab2e178c77f6df518024a71d05e98451
File Size 4/6.3KB
File Type unknown
AV Scan Result W32/Fareit. A
Pallas Al Scan Result Clean
Virus Total Result 34/61 security vendors flagged this file as malicious
= Download VT detail result
| FortiSandbox Result Clean [Score is 0 and scan takes 5 seconds] |
& Download PDF

3. To verify the results in FortiSandbox:
a. Goto Scan Job > File Job Search.
b. Search for the filename and verify the Rating is the same as the FortiSandbox Result in FortiDeceptor.

FortiSandbox VM 2 File Job Search
o @ Detection 2022-10-1915:47:48 to 2022-10-2015:47:48 1
Action Detection Filename Rating Malware
£y 1 Oct 20 2022 15:24:12 6f5902ac237024bdd0c176cb93063dc4 Clean N/A
= ) Oct 202022 15:24:11 ab2e178c77f6df518024a71d05e98451 Clean N/A

Integration with FortiNAC

This topic assumes FortiNAC has been set up properly as a NAC solution. We have provided an example on how to
configure the integration for testing purposes.

To integrate FortiDeceptor with FortiNAC:

1. Configure the attack host on FortiNAC.

2. Convert the pingable device to a host.

3. Verify the host was added successfully.

4. Generate an API token on FortiNAC.

5. Configure the integration with FortiNAC (Gen-Webhook).

6. Configure the integration with FortiNAC (FNAC-WEBHOOK).

FortiDeceptor 5.2.2 Administration Guide 272
Fortinet Inc.



Appendix D - Configuration examples

1. Configure the attack host on FortiNAC

1. OnFortiNAC, go to Network > Inventory.
2. Select the Containericon.

3. Right-click a container and select Add Pingable Device or right-click a pingable device in the Devices tab and select

Modify.

4. From the drop-down menu select the Container where this device will be stored. You can use the icon next to the

Container field to add a new container.
5. Configure the pingable device.

IP Address
Physical Address

File Edit View Searc

rluo@rluo-virtual-machine: ~

pe

luo@rluo-
luo@rluo-
luo@rluvo-
luo@rluo-

ns256

virtual-machine:~$

virtual-machine:~$§

virtual-machine:~$

virtual-machine:~$ ifconfig

Link encan:Fthercnet Huaddr|00:0c:29:b2:1c:6a

inet addr:10.100.11.100 | BcdSt:10.100.11.255 Mask:25!

et audT T Te80 1655 Za54:ae5b:26c1/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 n

RX packets:186563 errors:0 dropped:® overruns:0 frame [
TX packets:5382349 errors:® dropped:@ overruns:0@ carr]
collisions:@ txqueuelen:1000
RX bytes:16837173 (16.8 MB) TX bytes:434291159 (434.]
Link encap:Local Loopback

inet addr:127.0.6.1 Mask:255.0.0.0

inet6é addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:7776003 errors:0 dropped:® overruns:0 framgg

TX packets:7776003 errors:® dropped:® overruns:0 carr]

6. Click OK.

For information about adding and modifying pingable devices in FortiNAC, see Add or modify a pingable device in the

FortiNAC Administration Guide.

2. Convert the pingable device to a host

1. InFortiNAC, click Network > Inventory.
2. Expand the Container where the device is located.
3. Select the device to be converted.
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Enter the IP address of the endpoint.

. [i'] vian?

ks
=@ 10100100

@ attacker

decoy
={®FcT66

| rluo-fde77

E] test

1+ Wireless APs

@ Wireless Controllers

i"@ vian?

Enter the address of hardware endpoint.

Add Filter: | Select v

| Update |

E. Add Pingable Device

—— |Add to Container:
NO
Name

10.100.100.x v | g

IP Address:
Physical Address
Device Type:
Incoming Events:
H SS0 Agent:

Role

Description:

Note:

Contact Status Polling:

IMUWCHHUD I
100:0c:29:b2:1c62

.

(minutes)
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4. Right-click a device and select Convert To Host. This option converts the non-SNMP devices selected to hosts.
T T < S

Bookmarks + Users + Hosts = Network Devices = Logs = Policy + System = Help =
-® Customer “ Details |
—H{®10957x |attacker1 |
vian? IP Address: [10.100.11.100 |
= 10.100.100.
-® & Physical Address: |00:0C:29'B2:1C-6A |
decoy =
@ attacko Device Type: | Pingable v|e
P Convert to Host hg Events: Not Applicable
I % attacke Delete . Not icabl
fe @ EGTE6 Group Membership pent: ot Applicable v
Huofde  Local Management (http) | NAC-Default V|
Move to Container n:
: fest Foll for Contact Status }
+(® Wircless Al Role Membership tion:
AP Wireless G{  Show Audit Log -
+ ® vlan? Sht:nf\.r Events
Modify e
Set Model Configuration htact Status Polling: minutes) | Poll Now

Last Successful Poll:
Last Attempted Poll:

Save

5. Click Yes on the confirmation window.
6. Select and verify that the pingable devices now display.

For more information, see Convert all pingables to hosts in the FortiNAC Administration Guide.

3. Verify the host was added successfully

Go to the Hosts tab, and check the status. For information, see Host Summary in the FortiNAC Administration Guide.

« Bookmarks  Usersw  Hostsw  NetworkDevicesw  Logsv  Policyw  Systemw  Helpw
Hosts - Displayed: 56 Total: 56 [z
| e [ &
t <prev 1 next t 100 [©
"Stalus | HostName RegisteredTo | Logged On User | HostRole | Operaling Sysem Criticality Persistent Agent Host Created Host Expires Lastodiied By LastHodified Date Address Stale | Userina
= NAC-Default @ 10128/20 12:05 P PDT admin 10/28/20 12:05 P FOT il
(- NAC-Default o 10127120 02:23 P PDT admin 10128120 01:00 PM PDT
» DESKTOP- . Wi
oy |DESKTo NAC-Defaull  Windaws 10 @ 1012720 03:03 P PDT SYSTEM 110720 10:25 AM PST
» EE RootPC NAC-Default 2} 10/28/20 12:05 P PDT admin 10/28/20 12:05 PN POT
b test NAC-Default 2] 10/26/20 01:17 PM PDT test_api_user 03/22/21 11:52 AM PDT
> BB fom NAC-Default (%] 11102120 04:26 Al PST SYSTEM 1102120 07:22 AM PST
> B van7 NAC-Defaut @ 11102120 04:33 Al PST test_api_user 12101120 09:22 AW PST
> @ wnt NAC-Default o 11102120 06:01 Al PST admin 11/02/20 06:01 AM PST
bRy | sdmini2vitual NAG-Default Linux Debian based ) 1103120 10:10 AW PST SYSTEM 03/19/2107:41 PN PDT
» s WIN-
| s Windows 10 ) 0308721 1038 PMPST 0407121 113 PUPDT | SYSTEM 03008721 10:36 P PST
> @ yamingvm Linux Ubunty [~ 0300121 10:15 AMPST | 04/08/21 11:15 AM PDT | SYSTEM 03100121 10:15 AW PST
> EEE oo Windows 10 %) 03/09/21 01:54 PIPST | 04/08/21 0254 P PDT  SYSTEM 03/09121 04:56 PN PST
g WIN-
W | craesn Windows 10 @ 0309121 02:02 PIPST | 040081210302 P PDT | SYSTEM 03109121 02:02 PN PST
» WN-
B N cpasen Windows 10 -} 03110121 1206 PMPST | 0408/2101:06 P PDT | SYSTEM 03110/21 12:06 PN PST
> @ endpoint ° 03110121 01:12PIPST | 04109/21 0212 P PDT | SYSTEM 0310/21 01:56 P PST
» @ endpeint ) 03H0/21 0112 PMPST | 041091210212 PMPDT | SYSTEM 03110721 01:56 PN PST
> BEE soHnFC @ 03111121 0145 PMPST | 041101210245 P PDT | SYSTEM 0311121 01:45 PM PST
» g debian @ 03111721 03:30 PMPST | 04/10/2110:30 PU PDT | SYSTEM 03/11/2108:30 P PST
> lEmy DESKTOP- Windows & ) 03112121 04:02PMPST | 04/11/2105:02 PH PDT | SYSTEM 03112121 04:02 P PST
b B |DESKTOR- -3 03112121 04:36 PMPST  04/11/21 05:36 PN PDT  SYSTEM 03/12/21 04:36 PN PST
Y lgge \DESKTOR- Windows 8 ° 0312121 1253 PUPST |04/12/21 01553 PU PDT | SYSTEM 03113121 12:53 PN PST
» N
e Windows 10 -} 0311321 11:21PMPST | 04/13/211221 AN PDT  SYSTEM 03113121 11:21 P PST
» WN-
e W Windows 10 @ 0311421 01:32 AMPST | 04/13(21 0232 Al PDT | SYSTEM 03114121 01:32 AW PST
> EEE WINAD-6O Windows 10 2} 03114121 07:47 PUPDT | 0413/21 07:47 PMPDT  SYSTEM 03/14721 07:47 PN PDT
»oiEe et windows 8 ) 03114121 02:33 PUIPDT | D4/13/2108:33 P PDT | SYSTEN 03114121 09:44 P PDT
>R ki Linux Ubuntu [} 03115121 10:01 AMPDT | 04/14(2110:01 Al PDT  SYSTEM 03115721 10:01 A PDT
[E -] Linux Ubuntu @ 03115121 10:19 AWFDT | 04/14/2110:19 Al PDT | SYSTEM 03(16/21 10:19 AM PDT
» @ salppe ) 03115/2112:25 PUPDT | 04/14/121 12:25 P PDT | SYSTEM 03/16121 12:25 PN PDT
s | DESKTOP-
" - M=t ) 03116121 06:34 AMPDT | 04/15/2106:34 AW PDT | SYSTEN 03116121 06:34 Al PDT v
< >
import | Exportto: e & - g
Options Add | Modiy | Delste | Enale Disanle
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4. Generate an API token on FortiNAC

1. InFortiNAC go to the Users tab.
2. Select a user from the list. The Modify User page opens.
3. Nextto REST API Access Token, click Regenerate Token.

emw FOMNAC-VM-CA * Admin Users =

Bookmarks » Users v Hosts = Network Devices v Logsw Policy v System v Help v

| Phone: [
Email | Title:
Mobile Number

Mobile Provider:

[Hone v

Zip/Postal Code

Filter Modify User x

Add Filter Asterisk (*) indicates required fields

Adrmin Users - Displayed: 2 Total: 2 Userlnoumation
*Authenticate Type:

<<first <prev. 1 next> last>> 200 w =y

[3%0 ~] “Aderin Profle DE
User ID First Name Last Name Admin Profile Auth Type s REST API Access

admin Admin admin | System Administrator | Local UzerID e Easswan )
First Name: | Last Name: [testing | _
Address |
City | state: [ |

Notes:

Allow REST AP| Access for this Admin User
REST API Access Token | Regenerate Token
T7216.69.7973.
172.16.68.180/32
172.16.68.0124

Add

Allowed Subnets 172.16.69.77/32 Modify
172.16.69.229/32 Delete

5. Configure the integration with FortiNAC (Gen-Webhook)

1. In FortiDeceptor, go to Fabric > Quarantine Integration and click Quarantine Integration With New Device.

2. Configure the integration settings and click Save.

Integrate Method Select GEN-WEBHOOK.

Block Action

Http Method POST

URL https://<your-fortinac-address:8443>/api/v2/host/disable-by-ip
Authorization Enter the API access token you generated in step 4

HTTP Header
HTTP Data
Unblock Action
HTTP Method
URL

FortiDeceptor 5.2.2 Administration Guide
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Integrate With New Device X

Enabled:

Name: *

Block Severity:

Appliance:

Integrate Method:

Block Action:
Expiry:

Http Method:

URL:

Authorization:

HTTP Header:

HTTP Data:
Unblock Action:

Http Method:

URL:

Authorization:

HTTP Header:

HTTP Data:

«
‘fnacwebhook |
[__Low | Medium | __High | Critical _]

GEN-WEBHOOK v

@ Compatible FortiNAC version: 8.8 or later (Firmware: 8.8.2.1714)

3600 seconds

POST 4
https://< :8443>/api/v2/host/disable-
by-ip

whblockheader : Empty v m +

b ] Hackerp RLIE

https://< :8443>/api/v2/host/enable-

whunblockheader * Empty v L] +
o e - e [+

6. Configure the integration with FortiNAC (FNAC-WEBHOOK)

1. InFortiDeceptor, go to Fabric > Quarantine Integration and click Quarantine Integration With New Device.

2. Configure the integration settings and click Save.

IP

PORT

Authorization Token

Expiry

Enter the FortiNAC address.
8443
Enter the API access token you generated in Step 4.

1-3600 (default is 3600).

FortiDeceptor 5.2.2 Administration Guide
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Integrate With New Device X

Enabled: ()

Name: FNACintegrate

Integrate Method: FNAC-WEBHOOK ¥

Port:* 8443

Authorization Token: * :

Expiry: * 3600 seconds

3. Verify the device status is Ready.

Block
: /api/v2/host/enable-by-ip;
HttoMethod: POST. Expirv: 3608: _Authurizatinn:

Header: {whblockheader: Empty, }; Data: {ip: Hacker-IP,}.

# Edit | X Delete V) @ Ready genweb 63\IEE%HOOK Me... T
URL: httPs:// /api/v2/host/disable-by-ip;
HttpMethod: POST; Authorization: .
Header: {whunblockheader: Empty, }; ' Data: { whunblockdata:
Hacker-IP,}.
/ Edit X Delete (V] @ Ready FNACintegr... WE/-I\SC}JIOOK Me.. 1P: i_Port:8443; Token: Expiry: 3600:

Integration with FortiEDR

To integrate FortiDeceptor with FortiEDR:

1. Configure FortiEDR.
2. Configuration on FortiDeceptor.

1. Configure FortiEDR

FortiDeceptor performs API calls using basic authentication by supplying a username and password. The user
performing the calls must have the relevant REST API role defined in FortiEDR.
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USER DETAILS

User Name [rest l

Title rest l

First Name [rest l

Last Name lrest ] ! g 16-30/3 *l
Email Address lrest@rechom ]

i [User | [Reszami : bess

m
o
a
m
(L8
m
o
1
T

A user attempting to perform API calls without the REST API role sees a 401 Unauthorized Access error code. The
Admin role does not provide access to the REST API layer, and does not contain the REST APl role.

2. Configuration on FortiDeceptor

1. InFortiDeceptor, go to Fabric > Quarantine Integration and click Quarantine Integration With New Device.
2. Configure the integration settings and click Save.

Integrate Method Select FortiEDR-Isolation.
IP Enter the IP address of the FortiEDR.
Organization\Username Separate the organization and username with a backslash (\) if organization is
applicable.
Password Enter the password for the FortiEDR username.
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Integrate With New Device X

Enabled:

Name: *

Block Severity:

Integrate Method:

1p;*
Park®

Organization\Username: *

Password:

Expiry: *

«

|f0rtiedr |

(ow

FortiEDR-Isolation ¥
© Compatible FortiEDR version: 5.0.2.305 or later

443 |

| ISR SE\deceptor |

© Organization is optional, Username is mandatory

13600 |

Save Cancel

Integration with FortiAnalyzer

The steps in this topic assume the FortiDeceptor device has never to been connected to and has not been authorized by

FortiAnalyzer.

To integrate FortiDeceptor with FortiAnalyzer:

1. Configure the Log Servers in FortiDeceptor.
2. Authorize FortiDeceptor in FortiAnalyzer.

3. Create the FortiDeceptor security

FortiDeceptor 5.2.2 Administration Guide
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1. Configure the Log Servers in FortiDeceptor

1. InFortiDeceptor, go to Log > Log Servers and click Create New. The New Remote Log Server window opens.
2. Setthe Type to FortiAnalyzer and enter the Log Server Address.

= FOCWVMS0000069200

# Dashboard > Mew Remote Log Server
¥ Deception ¥

Mame: | |
] Incident »
i Fabric 3 Type: |Furtuﬁ.nah,rzer v
v Metwork ¥ Log Server Address: | |
©® System > | Port: 514 |
il _ .
— ¥ Status: @ Enable ) Disable

All Events

Alert Logs

Log Servers

Critical Logs
Error Logs
Warning Logs
Information Logs

Debug Logs

3. Configure the additional log server settings as required and click OK.

2. Authorize FortiDeceptor in FortiAnalyzer

I\I Allow a minimum of five minutes before attempting to authorize FortiDeceptor in FortiAnalyzer.

1. InFortiAnalyzer, go to Device Manager.

2. Search for FortiDeceptor in the Unauthorized Devices list. It may take up to half an hour for the device to appear in
the list.
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== Device Manager v =

ADOM:root & L5 Q admin v

+ AddDevice [# Edit ff Delete § Morev & Column Settings v

O  4Device Name 1P Address Platform
0O v¥%6914

u] @FGT_RACKB_14° 172166914 FortiGate-500D

0O ©FGT L 66 1721669.66  FortiGate-VM64

0 ®©FGT 126970 1721669.66  FortiGate-VM64

u] aroot vdom

[u] ofdc vdom

0O ®@FeTL270 172166970  FortiGate-VM64

0  mFSA35D0000000002 172166932 FortiSandbox-3500D
O v sfabric 69 10

u] @FGT_10_ 11" 172166910  FortiGate-VM64

O v ¥fabric_setup

[u] @FGT_L1_69 66" 1721669.66  FortiGate-VM64

[u] @FGVMULTM21001958 1721669.66  FortiGate-VM64

Logs

@ Real Time
@ Real Time
@ Real Time
@ Real Time
@ Real Time
® Real Time
® Real Time

® Real Time

@ Real Time
@ Real Time

Average Log Rate(Logs/Sec)

N/A
N/A
N/A
N/A
N/A
N/A
N/A

N/A

N/A
N/A

[ @ i | | a
|

Device Storage Description

1 (21.21%)
(0%)
(0%)
(0%)
(0%)
(0%)
(0%)

(0%)

(0%)
| (4.99%)

3. Select the device and click Authorize. The Authorize Device dialog opens.

amn .
= = Device Manager v

4 Return m & Hide il Delete [J Display Hidden Devices

Device Name

@ FDC-VMTM2
@ FDC1KFT418000002
@ FDCYMS0000000202
@ FDCWYMS0000069200
@ FDCYMSTMZ21000009
@ FDRI1HGT621000002
@ FGYMULTM22000064
@ FGYMULTM22001464

O0oo0oo0o@eoooOo0O

Model Serial Number Connecting IP
FortiDeceptor-VM FDC-VMTM21000075 172.16.69.222
FortiDeceptor-1000F FDC1KFT618000002 172.16.69.82
FortiDeceptor-VM FDCWYMS0000000202 172.16.69.202
FortiDeceptor-VM FDCWYMS0000069200 172.16.69.200
FortiDeceptor-VM FDCVYMSTM21000009 172.16.69.14
FortiDeceptorRugged-100C FDR1HGT621000002 172.16.69.48
FortiGate-VM&4 FGVMULTMZ22000064 172.16.69.70
FortiGate-VM&4 FGVMULTMZ22001464 172.16.69.10

4. From the Add the following device(s) to ADOM list, select the ADOM you want to add the device to.

Authorize Device

Add the following device(s) to ADOM:

Device Name

FDCVMS0000069200

FortiDeceptor 5.2.2 Administration Guide
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5. Gotothe ADOM's Device Manager and verify the FortiDeceptor is added.

Device Manager ADOM: FortiDeceptor & [ 2
+ Add Device [4 Edit W Delete § Morev %% Column Settings v (D C
O  Device Name IP Address Platform Logs Average Log Rate(Logs/Sec) Device Storage Description
O  @FDC-VM0000000302 17216.69.83  FortiDeceptor-VM @ Real Time N/A (0.56%)
O @FDC-VMTM20000204 17216.69.77  FortiDeceptor-VM @ Real Time N/A (0.81%)
O  @FDC-VMTM21000059 17216.69.244  FortiDeceptor-VM @ Real Time N/A (0%)
0 mFDCIKFT619000051 172166973 FortiDeceptor-1000F @ Real Time N/A (1.56%)
O  @FDCIKGT621000036 172166953  FortiDeceptor-1000G ® Real Time N/A I (632%)
O @FDCVMS0000000191 1721669191  FortiDeceptor-VM @ Real Time N/A (©.07%)
0 mFDCVMS0000000203 1721669203 FortiDeceptor-VM @ Real Time N/A (0.01%)
0  mFDCVMS0000000206 17216.69.206  FortiDeceptor-VM @ Real Time N/A (0.01%)
O @FDCVMS0000000228 17216.69.228  FortiDeceptor-VM @ Real Time N/A (0.01%)
O @FDCVMS0000000246 1721669246 FortiDeceptor-VM @ Real Time N/A ©.29%)
0 mFDCVMS0000000248 17216.69.248  FortiDeceptor-VM @ Real Time N/A (0.57%)
0  mFDCVMS0000069077 172166977 FortiDeceptor-VM ® Real Time N/A (0.44%)
O @FDCVMS0000069141 17216.69.141  FortiDeceptor-VM @ Real Time N/A (0.39%)
@FDCVMS0000069200 172.16.69.200  FortiDeceptor-VM @ Real Time N/A (0%)
0 mFDCVMS0000069208 1721669208  FortiDeceptor-VM @ Real Time N/A (0.04%)
O @FDCVMS0000069218 1721669218  FortiDeceptor-VM @ Real Time N/A (0.93%)
O DFDCVMS0004560902 17216.69.174  FortiDeceptor-VM ® Real Time N/A (0.3%)
0  @FDCVMS0007190435 1721669175  FortiDeceptor-VM @ Real Time N/A (1.24%)
O  mFDRIHGT621000001 172166948  FortiDeceptorRugged-100C @ Real Time N/A (0.09%)

6. Inthe Logs column, the status will display a red dot until FortiDeceptor generates syslogs. A green dot indicates the
device is connected and functioning properly.

Device Manager v

4 Add Device [# Edit T Delete § Morewv {5 Column Settings v

O  aDevice Name IP Address Platform Logs Average Log Rate(Logs/Sec) Device Storage Des
0O @ FDC-VM0000000302 172.16.69.83 FortiDeceptor-VM @ Real Time N/A (0.56%)
O @ FDC-VMTM20000204 172.16.69.77 FortiDeceptor-VM @ Real Time N/A (0.81%)
O @ FDC-VMTM21000059 172.16.69.244 FortiDeceptor-VM @ Real Time N/A (0%)

O @ FDC1KFT619000051 172.16.6%9.73 FortiDeceptor-1000F @ Real Time N/A (1.56%)
O @ FDC1KGT621000036 172.16.69.53 FortiDeceptor-1000G ® Real Time N/A | (6.32%)
0O @ FDCVMS0000000191 172.16.69.191 FortiDeceptor-VM @ Real Time N/A (0.07%)
O @ FDCVYMS0000000203 172.16.69.203 FortiDeceptor-VM @ Real Time N/A (0.01%)
O @ FDCYMS0000000206 172.16.69.206 FortiDeceptor-VM @ Real Time N/A (0.01%)
O @ FDCVYMS0000000228 172.16.69.228 FortiDeceptor-VM @ Real Time N/A (0.01%)
0O @ FDCVMS0000000246 172.16.69.246 FortiDeceptor-VM @ Real Time N/A (0.29%)
O @ FDCVYMS0000000248 172.16.69.248 FortiDeceptor-VM @ Real Time N/A (0.57%)
O @ FDCVYMS0000069077 172.16.69.77 FortiDeceptor-VM ® Real Time N/A (0.44%)
O @ FDCVYMS0000069141 172.16.69.141 FortiDeceptor-VM @ Real Time N/A (0.39%)
@ FDCVYMS0000069200 172.16.69.200 FortiDeceptor-VM @ Real Time N/A (0.01%)
O @ FDCVYMS0000069208 172.16.69.208 FortiDeceptor-VM @ Real Time N/A (0.04%)
O @ FDCVYMS0000069218 172.16.69.218 FortiDeceptor-VM @ Real Time N/A (0.93%)
O @ FDCVYMS0004560%02 172.16.69.174 FortiDeceptor-VM @ Real Time N/A (0.3%)
0O @ FDCVYMS0007190435 172.16.69.175 FortiDeceptor-VM @ Real Time N/A (1.24%)
O @ FDRIHGT621000001 172.16.69.48 FortiDeceptorRugged-100C @ Real Time N/A (0.09%)

7. Goto Log View and select this FortiDeceptor to view the logs.

ADOM: FortiDeceptor & 0 1

2, Custom View (1) v « A B F-
Jack - attack only ‘ R o e

8 Browse
# ¥ Date/Time Device ID Sub Type User Message

Bl Log Group 1 10:24:58 FDCVMS0000069200 system system Error happened in downloading certific:
2 10:22:02 FDCVMS000006 9200 system admin Administrator admin input invalid usern
3 10:22:01 FDCVMS000006 9200 system system Administrator admin login failed from w
4 FDCVMS000006 9200 system admin Administrator admin logged out website
5 10:19:59 FDCVMS000006 9200 system system Error happened in downloading certific:

3. Create the FortiDeceptor security report in FortiAnalyzer

1. In FortiAnalyzer, create the report template:
a. Open the Reports module.
b. Go tothe Reports > Report Definitions > Templates.
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In the template list, select FortiDeceptor Default Report.

3 Security Fabric Demo & 1 1

B Generated Reports +Create New [FiEdit FiDelete i More ~ ¥& Column Settings v Q
ES Report Definitions O  ATite Language Description
B All Reports O [ Template - FortiCache Web Usage Report en
[ Template - FortiClient Default Report en Summaries for Installation, OS, Device, FCT version and client summary. Threat summary by AV threats, infect
femplates
O B Template - FortiClient Default Report from FortiGate en Summaries for Installation, OS, Device, FCT version and client summary. Threat summary by AV threats, infect
Il Chart Library @ O  E&Template - FortiClient Vulnerability Scan Report en The vulnerabilities detected through Forticlient scans across the network
& Macro Library O & Template - FortiClient Vulnerability Scan Report from FortiGate en The vulnerabilities detected through Forticlient scans across the network
£= Datasets @ O B Template - FortiDDos Default Repart en Attacks and attackers by time period. Top 20 attacks, attack types, destinations and destinations by type.
[0  E&Template - FortiDeceptor Default Report en Present a quick summary of incidents and alerts generated by ForiDeceptor
Advanced ~ - ) :
o O B Template - FortiGate Performance Statistics Repart en FortiGate Performance Statistics Report.
™ Language O B Template - FortiMail Analysis Report en Statistics for Avg and Total mail size, number of mails and connections, delays, ip policies, recipient policies, to
 Output Profile O & Template - FortiMail Default Report en Tap 10 client IP, senders, virus senders, local users, recipients and virus recipients
Resort Calend O B Template - FortiNAC Endpoints and Netwark Repart en FortiNAC Endpoints and Netwark Report.
eport Calendar
[0  E&Template - FortiNDR Breach Prevention Report en FortiNDR Breach Prevention Report.

In the toolbar, click Create New.
Give the template a descriptive Name such as FortiDeceptor Security Report andfrom the Category
dropdown, select Security.

% Security Fabric Demo % [\ 1 .

B Generated Reports View Template/Application/Security/
& Report Definitions ~ -
Name FortiDeceptor Security Report
L All Reports
& Al Rep Description

B Templates
T .. Searity -

[ul Chart Library @
[# Macro Library

Language English v

£ Datasets @ Insert Chart | InsetMacro M Hv=E ™ X Bl «~ ~ Nomal~v Font~ Sizev BT USXx A B =
f= Datase
Q Find Replace Replace All
£F Advanced v~
N Langusge
= Output Profile

Report Calendar

Configure the rest of the template settings as required and click OK. For information, see Creating report
templates in the FortiAnalyzer Administration Guide.

2. Create the report:

a.

b.
c.
d

Go to the Reports > Report Definitions.

In the toolbar, click Report > Create New.

Give the report a distinctive Name.

Next to Create From, select Template and from the Select Template dropdown, select the FortiDeceptor
template you created.

[ Create Report x
[

SN _

i ame [ FDC Security Report] l
t Create from Q Blank ® Template

t Select Template FortiDeceptor Security Report ~

i Save to Folder All Reports v+

[

[

[

[

r o T
[

e. Select the folder to save the report and click OK.
For more information about creating reports in FortiAnalyzer see Reports in the FortiAnalyzer Administration Guide.
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Integration with FortiGate over Webhook

This topic describes how to integrate FortiDeceptor with FortiGate versions 6.4 and 7.0. The GUI may vary depending
the version of FortiGate/FortiOS you are using. For more information about Automation Stitches, select the version of
FortiGate / FortiOS Administration Guide you are using in the Fortinet Document Library.

To integrate FortiDeceptor with FortiGate over Webhook:

Ao b=

Configure the APl key on FortiGate.

Configure Webhook on FortiGate 6.4.x .

Configure Webhook on FortiGate 7.0.x .

Configure FortiDeceptor to integrate with FortiGate over Webhook.

1. Configure the API key on FortiGate

1. InFortiGate, go to System > Administrators and select a user.

2. Nextto API Key, click Regenerate, then copy the API key.

1 o s £t A4 b ety rvsi O o b B
r = Lrca AL g 2% DA B

2. Configure Webhook on FortiGate 6.4.x

For information about creating and editing webhooks in FortiGate, see Automation webhook stitches in the FortiGate /
FortiOS 6.4.0 Administration Guide.

2.1 Configure the incoming webhook for block action

1. Goto Security Fabric > Automation.
2. Create a new Automation Stitch

a.

b
c.
d

In the toolbar, click Create New.
Under Trigger click Incoming Webhook.
Under Action, click IP Ban.

In the APl admin key field, enter the API key you recorded in Step 1. Configure the APl key on FortiGate . A
Sample cURL request is created.
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e. Copy the Sample cURL request.

@ Dashboard » | Edit Automation Stitch

N& Security Fabric ~
Name fdc_black
Physical Topology
Status ARZEGELE © Disabled
Logical Topology

Security Rating

Trigger
Automation bd
Fabric Connectors o
External Connectors &
 Network >
Incoming
O Systein LI Webhook
B Policy & Objects >
; URL @
& Security Profiles >
O VPN >
APl admin ke
& User & Authentication > admin ey (@ .
Sample cURL request | curl 4 -X POST -H £
= WiFi & Switch Controller > Authorization: Bearer
ldl Log & Report 3 " -—-data

0B12DAGY4E47BA4ADF

S8E2F"

Action

OO E

CLI Script Email FortiExplorer Access Layer Quarantine Quarantine via Assign IP Ban AWS Lambda Azure
Notification  Quarantine FortiClient FortiNAC  VMware NSX Function
Security Tag
Cance

3. Execute the request:
a. Edit the sample cURL you recorded in the previous step.
b. Edit parameters to the data field (“srcip”, "mac™ and "fctuid"), and then execute the request.

root@pc:~# curl -k -X POST -H 'Authorization: Bearer cfgtctlmmx3fQxr4khb994p7swdfmk' --
data '{ "mac":"0c:0a:00:0c:ce:b0", "fctuid": "0000BBOBOABDODOOBODOAOBOEOFOBOOB"}'
https://172.16.116.226/api/v2/monitor/system/automation—
stitch/webhook/Incoming%20Webhook%20Quarantine

"http method":"POST",
"status":"success",

"http status":200,
"serial":"FGTOOEOQOOOOOOOO",
"version":"v6.4.0",
"build":1545

Ay
‘9' Encode the spaces in the automation-stitch name with $20. For example,
Incoming%20Webhook%20Quarantine
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2.2 Configure the incoming webhook for unblock action

1. Go to Security Fabric > Automation.
2. Create a new Automation Stitch

a. Inthe toolbar, click Create New.

b. Under Trigger click Incoming Webhook.
c. Under Action, click CLI Script.
d

Under CLI Script, in the Script field enter the following command: diagnose user quarantine delete

srcd %$%log.srcip%%

e. Inthe APl admin key field, enter the API key you recorded in the previous Step 1. Configure the APl key on

FortiGate . A Sample cURL request is created.

# Dashboard » | Edit Automation Stitch

%% Security Fabric -

Physical Topology Trigger

Logical Topology °
Security Rating &
Automation e

Fabric Connectors

incoming
External Connectors ‘Webhoole

He Netwark i @

¥ System Y

™ Policy & Objects b

@ Security Profiles SR
= VPN
i@ User & Authentication

[® WiFi & Switch Controller

il Log & Report

Action

CLI Seript Email  Fortifxplorer Accesslayer Quarantine Quarantinevia  Assign IPBan  AWSLlambda  Azure  GoogleCloud  AliCloud
Motiication Quarantine  FortiClient  ForiNAC ~ VMware NSX Function Function Function
Security Tag

Minimum interval (seconds) | O

CLI Script
1st Action
MName | unblock_ip

Script | diagnose user | %
quarantine delete src4
s6%log.srcip%sh Asor100s
© Upload
>_ Recerd in CUI console

©

e

19I01010J0I0I0I0I0IO0I0I0I0

2.3 Review the configuration on FortiGate side

In FortiGate, go to Security Fabric > Automation and verify the Status for the block and unblock webhooks are Enabled.
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%% Security Fabric P
Name ¢
Physical Topology

fdc_block

Security Rating

Automation Seg fdc_unblock

Fabric Connectors
External Connectors
'*!* Metwark
£ System [1]
B Policy & Objects
& Security Profiles
O vPn
& User & Authentication
F WiFi & Switch Controller

I Log & Report

| Search

[a]

Action &

© IPBan @ Enabled
3_ CLI Script & Enabled

Status =

Logical Topology El - Incoming Webhook @

3. Configure Webhook on FortiGate 7.0.x

3.1 Configure the incoming webhook for block automation

1. Go to Security Fabric > Automation.

2. Inthe banner, click Trigger > Create New. The Create New Automation Trigger page opens.
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3. Click Incoming Webhook. The Create New Automation Trigger dialog opens.

Create New Automation Trigger

to low memory

Configuration Change

An administrator's session that changed a
FortiGate's configuration has ended.

License Expiry
A specified license is about to expire.

NX Security Fabric

AV &IPS DB Update

The antivirus and IPS database has been
updated.

Ph

High CPU
A FortiGate has high CPU usage.

Automation

wlw]a]u]

Fa

Miscellaneous

FortiOS Event Log

A specified FortiOS event log ID has
occurred.

Incoming Webhook
Anincoming webhook has been triggered.

Schedule

A scheduled monthly, weekly, daily, cr hourly
trigger.

of:]s

F:=RTINET Cancel

4. Give the trigger a descriptive name such as fdc_block trigger and click OK.

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.

288



Appendix D - Configuration examples

5. Enterthe APl admin key and click OK.

Edit Automation Trigger

& Incoming Webhook Anincoming webhook has been triggered.

Mame fdc_block_trigger

Description #0/255

Incoming Webhook

URL @ 1
APl admin key €
Sample cURL request (V]

3.2 Create block stitch with

the block trigger

1. Go to Security Fabric > Automation.
2. Inthe banner, click Stitch > Create New. The Create New Automation Stitch page opens.
3. Click Add Trigger. The Select Entries pane opens.
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4. Selectthe fdc_block_ trigger you created and click Apply.

Create New Automation Stitch

Name
Status LAASIELEY © Disable
FortiGate(s) =5 All FortiGates

+
Actionexecution €@  JEELIENNEIN Parallel
Description
Stitch
Add Trigger

Add Action

5. Click Add Action. The Select Entries pane opens.

Select Entries x

Q Search + Create

Compromised Host (2}

A Access_Layer_Quarantine &

& Compromised Host - High

Configuration Change (1)
Configuration_Change_Notification

FortiOS Event Log (2)

B2 FortiAnalyzer Connection Down

E& Network Down

HA Failover (1)

& HA Failover

Incoming Webhook (5)

& activate_strict_ips

& add_cnc_to_blacklist

& blocker

&% fdc_block _trigger

&% Incoming Webhook Call
License Expiry (1)

&= License Expired Notification
Reboot (1)

C' Reboot

Schedule (2}

@ AWS_Activate VM

@ AWS_Deactivate VM
Security Rating Summary (1)

¥4 Security Rating Notification

Apply Cancel

6. Click Create. The Create New Automation Trigger windows opens.

7. Click IP Ban. Enter a Name such as banip and click OK.
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8. Select the action you created (banip), click Apply and click OK.

NX Security Fabric

Physical To

Automation

Fabric

Create New Automation Stitch

Name fdc_block_stitch
Status VEGEGIEE © Disable
FortiGate(s) =5 All FortiGates x
+
Action execution @ BI0ENEIN Parallel
Description 4 0/255
Stitch
.% Trigger
@3 fdc_block_trigger
(), Add delay
o x
Action

Add Action

3.3 Configure the incoming

oo Dd =
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webhook for unblock automation

Go to Security Fabric > Automation.
In the banner, click Trigger > Create New. The Create New Automation Trigger page opens.
Click Incoming Webhook. The Create New Automation Trigger dialog opens.

Give the Trigger a descriptive name such as fdc_unblock_ trigger and click OK.
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5. Enterthe APl admin key and click OK.

& Dashboard Edit Automation Trigger

@& Incoming Webhook An incoming webhook has been triggered.

MNams fdc_unblock_trigger

Description < 0/255

Incoming Webhook

URL @ . &
APl zdminkey €

Sample cURL request  curl -k -X POST -H ‘Authorizatior Wl

Automation

Fabric
External Connectors
Asset Ide

Lt |

3.4 Create unblock action with CLI script

Go to Security Fabric > Automation.

In the banner, click Stitch > Create New. The Create New Automation Stitch page opens.

Click Add Trigger. The Select Entries pane opens.

Selectthe fdc_unblock trigger you created and click Apply.

Click Add Action. The Select Entries pane opens.

Click Create. The Create New Automation Trigger windows opens.

In the Search field enter CL.1 and click the CL/ Script tile. The Create New Automation Action opens.
Click IP Ban. Enter a Name such as fdc_unblock_ip.

©® Nk~ oON-=

In the Script field enter the following command: diagnose user quarantine delete src4
%$%1log.srcip%5s.
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10. Click OK.

Create New Autornation Action

>_ CLI Script  Execute a CLI script. (4

MName fdc_unblock_ip

Minimum interval @ 0

Description

CLI Script

Script

Administrator profile @
Execute on Security Fabric &

second(s)

#0/255

%% L ip%%

@ Upload | >_ RecordinCLl console

-

& CHANGETYPE

50/1023
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11. Click Add Action. From the Add Entries pane, select the Action you created (fdc_unblock ip)and click Apply.

Create New Autohation Stitch

Name fdc_unblock_stitch
e Status (R ELIEN © Disable
ty Profiles
FortiGate(s) = All FortiGates x
+
x Authentication Actionexecution €@ BEERIENEIN Parallel
WiFi Controller ipti
irote Description 4 0/255
Stitch
Trigger {
S

fdc_block_trigger

Automation (G, Add delay

Fabric Connectors
Action
fdc_unblock_ip

External Connectors

Asset Identity Center

Add Action

4. Configure FortiDeceptor to integrate with FortiGate over Webhook

1. InFortiDeceptor, go to Fabric > Quarantine Integration and click Quarantine Integration With New Device.
2. Configure the integration settings and click Save.

Integrate Method Select FGT-WEBHOOK.

Block Action

URL Enter the webhook URL from FortiGate.
Authorization Enter the API key from FortiGate.
Unblock Action

URL Enter the webhook URL from FortiGate.
Authorization Enter the API key from FortiGate.

FortiDeceptor 5.2.2 Administration Guide
Fortinet Inc.

294



Appendix D - Configuration examples

Integrate With New Device X

Appliance:

Integrate Method:

Enabled: [ @)
MName: * |fgtb|oc|<er1 |
Block Severty:

FGT-WEBHOOK A

© Compatible FortiGate version: 6.4.0 or later

Block Action:
Expiry: |3600 seconds
L https:/ /api/v2/monitor/system/automation-
stitch/webhook/badlogin
URL:
P
Authorization: - \C
Unblock Action:
https:# /api/v2/monitor/system/automation-
stitch/webhook/unblock
URL:
4
Authorization: |

Save Cancel

-

3. Ensure the integration Status is Ready.

Integrate with FortiGate

The following instructions are based on FortiGate 6.0.3 to 7.2.3 and FortiDeceptor 4.3.0. For information about the
versions of FortiGate and FortiDeceptor you are using, select the version in the Fortinet Document Library.
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1. Configure FortiGate

1.1 Configure a new profile with minimum permissions for REST API integration

1. On FortiGate, go to System > Admin Profiles and click Create New.
2. Configure the profile Access Permissions. The following are the minimum required permissions.

Security Fabric Read/Write
FortiView Read
User & Device Read/Write
Firewall Read
Log & Report Read
Network Read
System Read/Write
Security Profile Read
VPN Read
WAN Opt & Cache Read
WiFi & Switch Read
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New Admin Profile

Name admin_api

Comments
Access Permissions
Access Control Permissions  SetAll ~

Security Fabric @ None @ Read | & Read/Write
FortiView @ None | @ Read & Re: rite
User & Device @ None @ Read | # Read/Write
Firewall @ None | @ Read | # Read/Write & Custom
Log & Report @ None | @ Read | ¢ Re: rite | #% Custom
Networlk @ None | @ Read & Re: rite | ## Custom
System @ None @ Read | & Read/Write #¥ Custom
Security Profile @ None | @ Read # Read/Write % Custom

VPN @ None | @ Read

WAN Opt &Cache | @ None | @ Read

WiFi & Switch @ None | @ Read # Read/Write

Permit usage of CLI diagnostic commands

Scope Virtual Demain = Global

@ Override Idle Timeout

1.2 Create a new administrator

1. On FortiGate, go to System > Administrators.
2. Click Create New > Administrator.
3. Entera Username and Password for the administrator.
4. From the Administrator profile dropdown, select the profile you created in step 1.1 Create the administrator profile in
FortiGate.
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New Administrator

Username API_Admin
Type

Match a user on a remote server group
Match all users in a remote server group
Use public key infrastructure (PKI) group

Password @
Confirm Password @

Comments Write a comment... 4 04255
Administrator profile  Rest_API - |

@ Two-factor Authentication
@ Restrict login to trusted hosts

@ Restrict admin to guest account provisioning only

5. Click OK.

2. Configure FortiDeceptor to integrate with FortiGate

1. In FortiDeceptor, go to Fabric > Quarantine Integration and click Quarantine Integration With New Device.
2. Configure the integration settings and click OK.

Enabled Enable the integration.
Name Enter a name for the integration.
Integrate Method Select FGT-REST-API.
IP Enter the IP address of the FortiGate.
Port Enter the Port for the FortiGate.
Username Enter the username for the admin you just created.
Password Enter the password for the admin you just created.
Vdom Enter the VDOM the FortiGate belongs to.
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E-% FDC-77-Fabric-Mail-LDAP-.. =

@ Dashboard ¥
® Deception L4 Integrate With New Device
Incident »
5 Fabric - Enabled: «
Detection Devices Mame: * |_fgh'esrapi
antine Stab
Quarantine Status et Ned: e
I Export
3 Network ¥ @ Compatible FortiGate version: 6.0.4 or [ater
a 1y
! System * - |
L Log »

[4a3

Username: * |Cu5case

dom: * |rn-ot

Expiry:”

3. Verify the integration Status is Ready.

PETRUTRTEIrr, LY MBI T A S AL I VT S, LAY U,

' 3 . - L Abadadhdbe i,
# Edit ¥ Delete [+] & Ready fetrestapi FGT-REST-AFI Ly IPPorT: a4 Exniry:L"ISQEOrPa@;bm; o Password: :

3. Test the integration

Send an attack against a decoy.
On FortiDeceptor, check the quarantine status.
On FortiGate, go to Dashboard > Users Device and expand the Quarantine widget to check quarantine status.
(Optional) Check the quarantine status on FortiDeceptor after it has expired.
« On FortiDeceptor, go to Fabric > Quarantine Status to check the status.
5. (Optional) Check the quarantine status on FortiGate after it has expired.
« On FortiGate, go to Dashboard > Users Device and expand the Quarantine widget to check quarantine status.

oo Dd =

Integrate FortiDeceptor with FortiGate over Fabric v7.2.4

This topic describes how to integrate FortiDeceptor with FortiGate over Fabric in FortiOS versions 7.2.4 .

vy
‘9' FortiGate 7.2.1 has a bug which prevents adding and displaying the FortiDeceptor information
- widgets in the dashboard.

Integrate FortiDeceptor with FortiGate over Fabric:

1. Configure the Fabric Connector on FortiGate.
2. Configure the upstream FortiDeceptor.
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Authorize FortiDeceptor on FortiGate.
Configure the automation on FortiGate.
Create a stitch for manual block on FortiGate.
Create a stitch for manual unblock.

Check the quarantine status in FortiDeceptor.
Check quarantine status on FortiGate.

©NOo g~

1. Configure the Fabric Connector on FortiGate

1.1 Create the administrator profile in FortiGate

1. InFortiGate, go to System > Admin Profiles.
2. Select prof_admin or super_admin and click Create New. The New Admin Profile page opens.
3. Configure the profile Access Permissions. The following are the minimum required permissions.

Security Fabric Read/Write
FortiView Read
User & Device Read/Write
Firewall Read
Log & Report Read
Network Read
System Read/Write
Security Profile Read
VPN Read
WAN Opt & Cache Read
WiFi & Switch Read
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Edit Admin Profile

Name FDC

Comments

Access Permissions

Access Control

Security Fabric

FortiView

User & Device

Firewall

Log & Report

Network

System

Security Profile

VPN

WAN Opt & Cache

WiFi & Switch

#0/255

Permissions Set All~

@ None @ Read WALCELANEIE)

@ None RCR:EELN & Read/Write

@ None @ Read WALCELANEIE)

@ None RCR:EELN & Read/Write

@ None & Read/Write

@ None BOREELN & Read/Write

@ None @ Read WALCELANEIE)

@ None RCR:EELN & Read/Write

@ None RCR:EELN & Read/Write
@ None RONEEEN & Read/Write

@ None RON:EELRN & Read/Write

Permit usage of CLI diagnostic commands @

@ Override Idle Timeout

4. Click OK.

1.2 Configure the Fabric Connector using the FortiGate profile

Enable the Security Fabric. For more information, see Configuring the root FortiGate and downstream FortiGates.

1. Go to Security Fabric > Fabric Connectors.

2. Click the Security Fabric Setup tile and click Edit. The Security Fabric Settings window opens.
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3. Configure the following settings and click OK.

Security Fabric role Select Serve as Fabric Root.
Allow downstream device Enable.
REST API access
\‘ ! 'I
9 Enabling Allow downstream device REST APl access is man
- datory.
Administrator profile Select the profile you create in Step 1.1 Create the administrator profile in
FortiGate.
Security Fabric Settings X
Settings Info
Security Fabric role Standalone BEEREESEELGEGEIE Join Existing Fabric
Allow other Security Fabric devices to join |E| Internet_A (port1) X
[® DMZ Segment (port2) X
] 1SFW (port3) x
[ Management (port4) x
[®] Internet_B (port5) x
[ MPLS-to-HQ (porté) x
(2} VPN_A_Tunnel (Branch-HQ-A) x
(2} VPN_B_Tunnel (Branch-HQ-B) x
2} HQ-MPLS (HQ-MPLS) x
(2) FortiDEMO x
+
Fabric name fabric
Group password ssssssee Change
Device authorization 5 Connected /5 Total ¢ Edit
FortiCloud account enforcement @ ©
Allow downstream device REST APlaccess @ @
Administrator profile a FDC -
Fabric global object £ [ o]
SAML Single Sign-On @ © [ Advanced Options
Mode Identity Provider (IdP)
IdP certificate Fg FortiDemo A _llv_ Download
IdP address @ Use Management IP/FQDN BEJel=l«13%
Management IP/FQDN @ Use WAN IP
tcorreia-tonycorreia.fortidemo.fortinet.con
Management port Use Admin Port
14003
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2. Configure the upstream FortiDeceptor

1. InFortiDeceptor, go to Fabric > Quarantine Integration.
2. Configure the Fabric Upstream settings and click Apply.

Enabled

Upstream IP address

Quarantine Via Upstream

Enable.
Enter the IP of the upstream FortiGate
Enable.

Fabric Upstream

Enabled:
Upstream IP Address:

Authorization Status:

Quarantine Via Upstream:
Quarantine Severity:

Quarantine Expiry:

«©

| | Port: [8013

The device is authorized by upstream. [FGYM04TM21012009]

| @)
~low | Medum | High | Critial |

| 3600 | seconds

Apply Cancel
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3. Authorize FortiDeceptor on FortiGate

3.1 Update the device status

1. Go to System > Fabric Management.
2. Select the FortiDeceptor with a status of Waiting for authorization and click "Authorize.

=
Device Type
M FortiGate
FortiSwitch
&) Fabric Upgrade 2 u grade | EBE Register & Authorize © Q search
£ System
Device Status = Registra
= @ FGT L1 66 @ Online & Registered
FRRIIEACAECErt @ FGT_L2.70 @ Online © Failed to fetch
= FDCVM0000069233 & Waiting for authorization

FDCVMS00 0131 Waiting for authorization

L 2 $124DN3W14000007 © Offline
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3.2 Add the fabric device widget in FortiGate Dashboard

1. Goto Dashboard > Status and click Add Widget. The Add Dashboard Widget menu opens.

2. Under Security Fabric, click Fabric Device.
Add Dashboard Widget

Q Search

[ Fortiview
FortiView Application Bandwidth FortiView Applications
FortiView Destination Interfaces FortiView Destination Owners
FortiView Policies FortiView Sessions
FortiView Sources FortiView VPN
FortiView Web Sites FortiView ZTNA Servers

@ Show More

\,/\' Security Fabric

Fabric Device FortiGate Cloud

3. From the Device dropdown, select the FortiDeceptor.

FortiView Cloud Applications

FortiView Destinations

FortiView Source Interfaces

FortiView Web Categories

Add Dashboard Widget - Fabric Device

Device 4 FDC-VM-Zhenhui-54
Widget name Deception Decoys

Visualizationtype | Table

4. Configure the other settings and click Add Widget.

Add Widget

3.3 Monitor the FortiDeceptor widgets on FortiGate

Use the FortiDeceptor Fabric Device widget to monitor FortiDeceptor System Information and Deception Decoys

information.
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System Info -

ance Mode  Standalone

420
Build GA build0226
Serial Number FDCVMTM21000017
Model FDC-VM

FDCVMS0000000216

FDCVMS0000000216

Q

Status *

Running

4. Configure the automation on FortiGate

§~ | |Deception Decoys -
Decoy Name & os = VM =

pantestcentos2

FDCVYMS0000000216
Service ¥

CentOS

4.1 Create Stitch for automated quarantine on FortiGate side

1. Go to Security Fabric >Automation.
2. Inthe banner click Action.
3. Click Create New and then click /P Ban. The Create New Automation Action page opens.

& Security Profiles
0 VPN
=& User & Authentication
= WiFi & ch roller
& System
¥ Security Fabric
Physical Topology
Ls | Topology
Security Rating
Automation

c Connectors

dentity Center

Ll |og & Report

Q, Search

Create New Automation Action

Security Response

Access Layer Quarantine

Quarantine the MAC address on access layer
devices (FortiSwitch and FortiAP).

FortiNAC Quarantine

Use FortiNAC to quarantine the endpoint
device. (&'

IP Ban

Ban the IP address specified in the
automation trigger event.

Notifications

Email

Send a custom email to the specified
recipient(s).

Slack Notification

Send a notification to a Slack channel. ('

FortiDeceptor 5.2.2 Administration Guide
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FortiClient Quarantine

Use FortiClient EMS to quarantine the
endpoint device.

VMware NSX Security Tag

Assign a specified security tag to a VMware
endpoint device. (&'

FortiExplorer Notification

Send a notification to FortiExplorer.

Microsoft Teams Notification

Send a notification to a Microsoft Teams
channel.

~
(5

centosvl SSH,SAMBA, HTTP, HT...

Netw¢

DHCP

306



Appendix D - Configuration examples

4. Enter a descriptive name Name such as £dc_ban-ip and a Description such as For fabric and click OK.

Create New Automation Action

n IPBan ganthe IP address specified in the automation trigger event. # CHANGE TYPE

Name fdc_ban-ip

Description | For fabrid %' 10/255

4.2. Create a trigger for automated quarantine

1. InFortiGate go to Fabric > Automation.
2. Inthe banner, click Trigger.
3. Click Create New and then click the Fabric Connector Event tile.

FortiDeceptor 5.2.2 Administration Guide
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4. Configure the following settings, and click OK.

Name Give the connector a descriptive name such as FDC_Insider Threat.
Description Enter a description such as FDC mitigation.

Connector Select the upstream FortiDeceptor device.

Event name Select Insider Threat.

<M Fabric Connector Event A specified Fabric Connector's event has occurred.

Name FDC _Insider_Threat
Description  FDC mitigation 4 14/255
Fabric Connector Event
((Connector & FDC-77-Fabric-Mail-LDAP-Radius-Log ¥ )

Event name ( Insider Threat ) v

Event severity (B

4.3 Create a stitch for automated quarantine

In FortiGate go to Security Fabric > Automation.
In the banner, click Stitch and then click Create New.
Give the Stitch a descriptive name such as FDC_ban.

HPoODd =

Insider_ Threat) .
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5. Click the Action tile and select the Action you created (fdc_ban-ip).

Description

Stitch

@ Trigger
an FDC_Insider_Threat

Action
fdc_ban-ip

Add Action

5. Create a stitch for manual block on FortiGate

5.1 Create an Action for manual block

1. InFortiGate go to Security Fabric > Automation.
2. Inthe banner, click Action.
3. Click Create New and then click the /P Ban tile.

FortiDeceptor 5.2.2 Administration Guide
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= Q

Edit Automation Stitch
Mame FDC_ban
Status @ Enable JDERIIELE
FortiGate(s) =5 All FortiGates

+
Action execution €@ Parallel

/10/255
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4. Give the Action a descriptive Name such as ipban and enter a Description suchasblock the IP and click OK.

Edit Automation Action

IP Ban Banthe IP address specified in the automation trigger event.

MName ipban

Description  block the IP #12/255

5.2 Create a trigger for manual block

1. InFortiGate, go to Security Fabric > Automation.

2. Inthe banner, click Trigger,

3. Click Create New and then click the Fabric Connector Eventtile.

4. Configure the following settings and click OK.
Name Enter a descriptive name such as manual-ban.
Connector Select the downstream FortiDeceptor device.
Event Name Select Notify Ban.

Edit Automation Action

IP Ban Banthe IP address specified in the automation trigger event.

MName ipban

Description | block the IP #£12/255

5.3 Create a stitch for manual block

1. Go to Security Fabric > Automation.
2. Inthe banner, click Stitch, and then click Create New.
3. Give the Stitch a descriptive name such as FDC Manual Block.
4. Click the Trigger tile and select the trigger you created in 5.2 Create Trigger for manual block (manual-ban).
5. Click the Action tile and select the Action you created in Step 5.1 Create Action for manual block (ipban)
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6. Create a stitch for manual unblock

6.1 Create an Action for manual unblock

In FortiGate go to Security Fabric > Automation.

In the banner, click Action.

Click Create New and then scroll down and click the CL/ Script tile.

Give the action an descriptive Name such as unblock.

In the CLI Script > Script field enter the following command and click OK.

diagnose user banned-ip delete src4 %$%1og.srcip%%
Edit Automation Action

CLI Script  Execute a CLI script.

Name unblock

a b obd-=

Minimum interval €@ 0 second(s) =

Description £ Q/255

CLI Script

Script diagnose user banned-ip delete srcd %%log.srcip%s %

#50/1023
© Upload | >_ RecordinCLIconsole

Administrator profile €@ super_admin i

Execute on Security Fabric @ (B

6.2 Create a trigger for manual unblock

1. InFortiGate, go to Security Fabric > Automation.
2. Inthe banner, click Trigger
3. Click Create New, then configure the following settings and click OK.

Name Give the trigger a descriptive name such as Trigger-unban.
Connector Select the downstream FortiDeceptor device.
Event name Select Notify Unban.

6.3 Create a stitch for manual unblock

Go to Security Fabric > Automation.

In the banner, click Stitch, and then click Create New.

Give the Stitch a descriptive name such as FDC Manual Unblock.

Click the Trigger tile and select the trigger you created in 6.2 Create Trigger for manual unblock (unblock).

P obh-=
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5. Click the Action tile and select the Action you created in Step 6.1 Create Action for manual unblock (Trigger-
ban).

7. Check the quarantine status in FortiDeceptor

1. In FortiDeceptor, go to Fabric > Quarantine Status.
2. For Type > Auto quarantine, verify the Status is Quarantined.
3. (Optional) Trigger a manual block.

a. Select a device with Type > Manual quarantine.

b. Inthe toolbar, click Block.

8. Check quarantine status on FortiGate

To view the quarantine status with the FortiGate GUI:

Go to Dashboard > Users & Devices and expand the Quarantine widget.

To view quarantine status with FortiGate CLI:

Run the following command:

diagnose user quarantine list

To view the debug log for quarantine with the FortiGate CLI:

Run the following command:

diagnose debug en

Integrate with Cisco ISE

Topology

This topic assumes Cisco ISE has been set up properly as a NAC solution, to work with a switch which has CoA enabled.
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FortiDeceptor
ISE

AR % Switch /
L Radius Client

To integrate FortiDeceptor with Cisco ISE:

Configure Cisco ISE.

Configure the Authorization Policy.
Check the configuration

Configure FortiDeceptor.
Quarantine the endpoint.
Un-quarantine the endpoint.

ok wbd-=

1. Configure Cisco ISE

1.1 Configure the ERS on Cisco ISE

Please refer to the Cisco developer documentation on how to enable the ERS interface and configure the ERS admin
account on Cisco ISE. This ERS admin account must be enabled with REST API and will be used by FortiDeceptor to
communicate with Cisco ISE to quarantine and un-quarantine the attackers by IP.

1.2 Create a new policy in Cisco ISE

1. In Cisco ISE, go to Policy > Policy Sets.
2. Click the + button, and type a name in the Policy Set Name field such as Fortinet Policy.
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3. Inthe Conditions column, click +.
Policy Sets

* Status Policy Set Name Description Conditions

i O] Fortinet Policy|

In the Attribute box, click Choose from list or type and select All Device Types.

Allowed Protocols / Server Sequence

Reset Policyset Hitcounts @ m

Actions View

4. In Conditions Studio, click Click to add an attribute.
5. Inthe Editor pop-up window, type device type.
6.
7. Click Use.

Editnr

DEVICE Devica Typa

E Edisls r Chaiosa f Istar fyps

Sat ba'ls not I
Al Device Types

#1 Devine TypeslUnknown

m. L .

The new policy will look like the image below.

Policy Sets
+ Shatus Pelicy Sei Name Dascriplion
1ok
& Forinat Palcy
@ Defauii Defauit polizy sei
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2. Configure the Authorization Policy

1. Inthe View column, click on the arrow >.

Policy Sets Reset Policyset Hitcounts
+ Status Policy Set Name Description Conditions Allowed Protocols / Server Sequence Hits Actions View
Search
@ Fortinet Policy Bl fortinet Default Network Access x v o 0 L E
@ Default Default policy set Default Network Access x v | 0 E e >

2. Click + to the left side of the Status column. A new authorization is generated.
3. Inthe Rule Name column, enter aname such as ftnt EPS rule.

¥ Authorization Policy (1)

Results
Status Rule Name Conditions Profiles Security Groups Hits Actions
Search
@ Default = DenyAccess + Seleat from list v 4 0

4. Inthe Conditions column, click +.
5. In Conditions Studio, in the Editor, click Click to add an attribute.
6. inthe Attribute box, type EPS and select EPSStatus.

Editor
Chak o add an altribute :
-]
Select attribute for condition ®
O 0w o0 FeEEABECRLOET
Dictionary Attribute {[n] Infa
All Dictionaries w |EPY X D
EPSStatus =
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7. Click Choose from list or type and select Quarantine from the dropdown list.

Editor
Session EPSSiatus
k Equals " Lhoosa 1 Isi or ypa -

Set to 'ls not’ m

Menw AND OR

= JEEN

8. Click Use.

3 Check the configuration

If each network component is configured properly, the endpoint will be authenticated successfully. In Windows 10, use
the Command Prompt of Windows 10, to verify the IP address is acquired and the DHCP server is pingable.

In Cisco ISE go to Operations > RADIUS > Live Logs. The endpoint should be displayed.

Licanss Waming 4

sl idenlity Senvices Engine Home » Cantext Wisitility ¥ Priicy v Admmistratian b Wiork Cenbers
= HADIUS Threat-Centric NAC Lve: Legs b TACAGS ¢ Troulieshoal ¥ Adaplive Metwork Cantrel — Repors
Click nere to do wiraless sabup and visillly setup Do not zhow This &
e Logs Live Sessions
Misconficurod Supplicants @ Migconfigursd Hetwark RAJIUS Drops @ Ciient Stopped Responding @ Repeat Counter

0 0 0 0 0

Refresh | Never ~ Show | Latest 20 rocords  w Within . Last & hours
3 Relresn @ Resst Repect Counts 2 ExpoiTar F Filter
Idenliy Endpainl 1D Endpoint Profile Authertication Poicy Autharization Policy Audhorizali IP Address Metw
ErdlF Autter Al @ Myt
Widare- Devioz Forlinet Policy »» Dafzull Permilfccess 10.82.121
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4. Configure FortiDeceptor

1. InFortiDeceptor, go to Fabric > Quarantine Integration and click Quarantine Integration With New Device.
2. Configure the integration settings and click Save.

Enabled Enable

Name Enter a descriptive name for the integrations.
Integrate Method Select Cisco-ISE.

ServerURL/IP Enter the IP address for Cisco ISE.
Username Enter the username for Cisco ISE.
Password Enter the password for Cisco ISE.

Expiry Set the expiry in seconds.

Integrate With New Device

Enabled [
Marn fgthlockerd |
Integrate Bethad: Clzgo-15E o
ﬂ Car 123 L 1
Sarwer LIRLYP
Pare:* S0E0
Useerame: * rowAdrin
Password AR EEREE
Werify S5L:* &
Enpiry: © |1?.’.l |
Save Camcel
3. Verify the Statusis Ready.
# Edit Server URL/IP: ; Port: 9060; Username:
(v] @ Ready fgtblocker2 Cisco-ISE Low newAdmin; _Password: ****""******" "Verify SSL: true:
X Delete Expiry: 120;

5. Quarantine the endpoint

1. Attack a decoy deployed in FortiDeceptor from the endpoint. When FortiDeceptor detects the attack has occurred, a
quarantine of REST API with the IP address of the endpoint will be sent to Cisco ISE.

2. In FortiDeceptor go to Fabric > Quarantine Status, to verify the quarantine was successful.

Attacker IP Start End Type Integrated ... Time Rema... Status
10.92.1.21 2021-11-02 18:0.. 2021-11-02 18:13:17 PDT Auto quarantine fgtblocker2 im2s Quarantined
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3. Onthe endpoint, you should see the status of the network adapter becomes Authentication failed and DHCP server
is no longer pingable.

4. In Cisco ISE, navigate to the Live Logs.
« Inthe Authorization Profiles column, you should see PermitAccess is replaced by DenyAccess.
« Inthe Authorization Policy column Fortinet Policy >> Default changes to Fortinet Policy >> ftnt_EPS_

quarantine.
Identity Endpoint ID Endpoint P. Authentication Policy Authorization Policy Authorizati... IP Address
fint_usert 00:0C:29:C7:73:D5 VMWare-De Fortinet Policy >> Default Fortinet Policy >> fint_EPS_guarantine DenyAccess

6. Un-quarantine the endpoint

After 120 seconds, un-quarantine of REST APl is sent to Cisco ISE from FortiDeceptor. At the same time, Status of
Quarantine Status changes to Quarantine stopped.

Attacker IP Start End Type Integrated ... Time Rema... Status

10.92.1.21 2021-11-0218:.. 2021-11-02 18:13:17 PDT Auto quarantine fatblocke... 0 Quarantine stopped

On the endpoint, the status of the network adapter is Resumed and the DHCP server becomes pingable.

In Cisco ISE go to Live Logs:

« Inthe Authorization Profiles column, DenyAccess changes to PermitAccess.
« Inthe Authorization Policy column Fortinet Policy >> fint_EPS_quarantine changes to Fortinet Policy >> Default.

Identity Endpoint ID Endpoint P... Authentication Policy Authorization Policy Authorization Profiles IP Address

tnt_user1 00:0C:29:C7:73:D5 VMWare-De Fortinet Policy >> Default Fortinet Policy >> Default PermitAccess 10.92.1.21

Integrate Windows IR collector

The IR Collector integration allows admins with local and domain permissions to connect to Windows endpoints
remotely, copy IR tools, run commands on the endpoint and collect digital artifacts for future analysis. After the IR

Collector is configured, it will collect incident related forensic data by accessing the attacker's unit via the deployment
network where the attack originated from.

To configure the IR Collector:

1. Go to Fabric > Quarantine Integration and click Quarantine integration with new device. The Integrate With New

Device pane opens.
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2. From the Integrate method dropdown, select IR collector and configure the integration settings as required.

x The Username should be a user who is either a local admin or a domain user with

administrative privileges to access the endpoints.

@ Dashboard >

=+ Quarantine integration with new device
28 Central Management > -
© Q Searc
@ Deception
Incident > Enabled Status Name
I @) Fabric v @ Disabled = @ Local: Unchecked fgtblocker1

Detection Devices

Quarantine Integration O © Disabled

@ Local: Unchecked

20ldATPB212

|| Integrate With New Device

Enabled
Name *
Severity Filter

Appliance Filter

©

LowRisk Medium Risk HighRisk Critical

+

Quarantine Status Agent Type Origin
10C Export
o Origin: Block/Unblock will be executed in the device which the incident
4 Network > © Disabled O© Local: Unchecked ~ ATPnew o is from. This origin type does not support integrate methods: Azure
£ System > Key/ AWS Key/ FSM Watch List.
Specific: Block/Unblock will be executed in the designated device.
Lt Log >
Agent Device Local
© Disabled @ Local:Unchecked = ATPzold € 7
Integrate Method ‘ IR Collector v ‘
® Enabled © Local: Failed realnew FortiDeceptor will collect the incident related forensic data by
@ accessing the attacker's unit via the deployment network where the
related attacker comes from
Domain
Username *
FERTINET 500 Cance
3. Click Save.

4. Configure the Windows endpoint. Both IR and Windows network isolation in the Fabric require the same setting for
the endpoints. For information, see Mitigation using windows Remote Command on page 262.

5. After you configuring FortiDeceptor and the Windows endpoint, perform a connection check.

a. Goto Fabric > Quarantine Integration
b. Selectthe IR Collector integration and click Credential Test.

Credential Test

IP/URL * \

Test Result @ Local: The IR Collector IRcol: the credential test for

To download the artifacts:

1. Goto Incident > Analysis.
2. Click anincidentin the table.
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3. Click Download Forensic Data. The artifacts are saved as a Zip file.

@ Dashboard

& Central Management

o PDF Report

© Q Search
@® Deception
i Last Activity &
Incident [PSTEPDT]
2024/01/26 11....
Campaign
2024/01/26 10....
Attack Map
2024/01/09 15:...
MITREICS
O Fabric 5 | 2024/01/0911:..
& Network s | 2023/12/1800...
£ System » 2023/12/1800....
L Log » 2023/12/1800....
2023/12/1800:...
2023/12/1800:...
2023/12/17 13....
2023/12/17 13....
2023/12/17 13....
2023/08/0221....
2023/08/0221....
2023/08/0221....
2023/0R/07 71+

Artifacts list

Start <
[PST8PDT]

2024/01/26 10...
2024/01/26 09...
2024/01/09 15...
2024/01/09 11...
2023/12/18 00...
2023/12/18 00...
2023/12/18 00...
2023/12/18 00...
2023/12/18 00...
2023/12/17 13...
2023/12/17 13...
2023/12/17 13...
2023/08/02 21...
2023/08/02 21...
2023/08/02 21...

2023/08/09 21

Extracted from the file system:

« |E/Firefox/Chrome History
+ Named Pipes

o Prefetch Startup

» Directories

» etc.

Extracted from the registry:

« Installer Folders
+ Recent Docs

o Services

o UserAssists

o Networks List

Extracted from in-memory processes:

e Opened Files

Other information:

 Drives List Network
o Drives Network Cards
o Processes

« Routing Table

o Sessions

o Sockets
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Severity

B ExporttoCSV  « Markallasread Show All

Events

26
12
2
2
18
8

Appliance

45 Attacker User
= Attacker IP
@ Attacker Port

Event Count

o 2024-01-26 10:40:02 PST

Local

N/A

N/A
26

& MITRE ICS Techniques TO802 T0840 T0846 TO0888

& Download lures

& Download Forensic Data

Q@ right after

ICMP Ping Request

2024-01-26 10:40:02 PST
Echo request from 10.10.2.119 to 10.10.2.91

X Download Traffic PCAP
MD5  1e57313979d281ef098109fffclads9
FileSize 267.0KB
File Type pcap
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A\,
S L4
? Artifacts labeled eftc are files that contain more information.
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