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Change Log

Change Log

Date Change Description

2023-02-02 Initial release.

2023-03-06 Updated Configuring log forwarding on page 311.
2023-03-08 Updated SAML admin authentication on page 373.
2023-04-10 Updated Device Manager on page 38.
2023-04-12 Updated SQL query functions on page 243.
2023-05-18 Updated:

¢ Managing a Compromised Hosts rescan policy on page 63
¢ Modes on page 310

2023-06-08 Updated Creating macros on page 239.

2023-06-29 Updated Licensing in an air-gap environment on page 344.
2023-08-21 Updated FortiAnalyzer Fabric on page 32.

2023-10-23 Updated Enabling and disabling the ADOM feature on page 299.
2024-01-18 Updated Configuring HA options on page 390.

2024-02-09 Updated:

¢ Creating a custom event handler on page 168
e Creating a custom correlation handler on page 171
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Setting up FortiAnalyzer

This chapter provides information about performing some basic setups for your FortiAnalyzer units.

This section contains the following topics:

Connecting to the GUI on page 13

Security considerations on page 21

GUIl overview on page 23

Target audience and access level on page 27
Initial setup on page 27

FortiManager features on page 28

Next steps on page 28

Restarting and shutting down on page 29

Connecting to the GUI

The FortiAnalyzer unit can be configured and managed using the GUI or the CLI. This section will step you through
connecting to the unit via the GUI.

Ay
‘Q' If you are connecting to the GUI for a FortiAnalyzer virtual machine (VM) for the first time, you
- are required to activate a license. See Activating VM licenses on page 19.

To connect to the GUI:

Connect the FortiAnalyzer unit to a management computer using an Ethernet cable.

Configure the management computer to be on the same subnet as the internal interface of the FortiAnalyzer unit:
o |P address: 192.168.1.X
» Netmask: 255.255.255.0

On the management computer, start a supported web browser and browse to https://192.168.1.99.

The login dialog box is displayed.

Type admin in the Name field, leave the Password field blank, and click Login.

The FortiAnalyzer Setup wizard is displayed.

Click Begin to start the setup process. See FortiAnalyzer Setup wizard on page 14.
The Later option is available for certain steps in the wizard, allowing you to postone steps. The Register with

FortiCare step cannot be skipped and must be completed before you can access the FortiAnalyzer appliance or VM.

If ADOMs are enabled, the Select an ADOM pane is displayed. Click an ADOM to select it.
The FortiAnalyzer home page is displayed.

Click a tile to go to that pane. For example, click the Device Manager tile to go to the Device Manager pane.
See also GUI overview on page 23.

FortiAnalyzer 7.2.2 Administration Guide
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Setting up FortiAnalyzer

If the network interfaces have been configured differently during installation, the URL
and/or permitted administrative access protocols (such as HTTPS) may no longer be in

their default state.

For information on enabling administrative access protocols and configuring IP addresses, see Configuring network
interfaces on page 286.

L}
‘9' If the URL is correct and you still cannot access the GUI, you may also need to configure static

routes. For details, see Static routes on page 287.

After logging in for the first time, you should create an administrator account for yourself and assign the Super_User
profile to it. Then you should log into the FortiAnalyzer unit by using the new administrator account. See Managing
administrator accounts on page 350 for information.

FortiAnalyzer Setup wizard

When you log in to FortiAnalyzer, the FortiAnalyzer Setup wizard is displayed to help you set up FortiAnalyzer by
performing the following actions:

« Registering with FortiCare and enabling FortiCare single sign-on

« Specifying the hostname

« Changing your password

» Upgrading firmware (when applicable)

You can choose whether to complete the wizard now or later.

Al
‘Q' The FortiAnalyzer Setup wizard requires that you complete the Register with FortiCare step

before you can access the FortiAnalyzer appliance or VM.

When actions are complete, a green checkmark displays beside them in the wizard, and the wizard no longer displays
after you log in to FortiAnalyzer.

FortiAnalyzer 7.2.2 Administration Guide
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Setting up FortiAnalyzer

FortiAnalyzer Setup - Welcome (1/4)

Welcome

Perform the following steps to complete the setup of this FortiAnalyzer.

1. Register and 550 with FortiCare

O Import the Entitlement File

2. Specify Hostname
3. Change Your Password

4. Upgrade Firmware

This topic describes how to use the FortiAnalyzer Setup wizard.

To use the FortiAnalyzer setup wizard:

1. Login to FortiAnalyzer.
The FortiAnalyzer Setup dialog box is displayed.
2. Click Begin to start the setup process now.
Alternately, click Later to postpone the setup tasks. Some tasks cannot be postponed.

3. When prompted, register with FortiCare and enable FortiCare single sign-on. You must complete the Register with
FortiCare step before you can access the FortiAnalyzer appliance or VM.

x When using FortiAnalyzer in an air-gapped environment, you must manually import your

Entitlement File. See Licensing in an air-gap environment on page 344.

FortiAnalyzer 7.2.2 Administration Guide 15
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Setting up FortiAnalyzer

FortiAnalyzer Setup - Register and SSO with FortiCare (2/4)

Register with FortiCare

Serial Number FAZVMTM22003795

Account ID/Email

Password

Register
Country/Region Click to select
Reseller Click to select

5SSO with FortiCloud

FortiCloud Single Sign-on @& @O

FortiAnalyzer 7.2.2 Administration Guide

Fortinet Inc.
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Setting up FortiAnalyzer

4. When prompted, specify the hostname.

FortiAnalyzer Setup

Specify Hostname

By default, this FortiManager will use the serial number/model as its hostname. It is
strongly recommended to set a descriptive hostname to make this device more identifiable.

Hostname FAZVME&4S

5. Inthe Hostname box, type a hostname.
6. Click Next.

FortiAnalyzer 7.2.2 Administration Guide
Fortinet Inc.
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Setting up FortiAnalyzer

7. When prompted, change your password.

FortiAnalyzer Setup

Change Your Password

This account is using the default password. You are required to change your password.
New Password sssssses ® @

Confirm Password sssssses ® @

4

a. Inthe New Password box, type the new password.
b. Inthe Confirm Password box, type the new password again.
c. Click Next.

8. When a new firmware version is available for your device on FortiGuard, the Upgrade Firmware option in the wizard
indicates that a new version is available, and you can click Next to upgrade to the new firmware, or Later to upgrade
later.

FortiAnalyzer 7.2.2 Administration Guide
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Setting up FortiAnalyzer

9. Complete the setup by clicking Finish.

FortiAnalyzer Setup

Setup Complete

The setup of this FortiAnalyzer is now complete. Click "Finish" to exit
this dialog.

[

You are logged in to FortiAnalyzer.

Activating VM licenses

If you are logging in to a FortiAnalyzer VM for the first time by using the GUI, you are required to activate a purchased
license or activate a trial license for the VM.

To activate a license for FortiAnalyzer VM:

1. On the management computer, start a supported web browser and browse to https://<ip address> forthe
FortiAnalyzer VM.
The login dialog box is displayed.

FortiAnalyzer 7.2.2 Administration Guide 19
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Setting up FortiAnalyzer

FortiAnalyzer-VMé4

This product requires a valid license. You could log in to FortiCloud
to activate your purchased license, or use a free trial license.

u Account ID/Email ‘

u Passworc

® Free Trial

O Activate License

Login with FortiCloud

Register with FortiCloud

Upload license

2. Take one of the following actions:

Action Description

Free Trial If a valid license is not associated with the account, you can start a free trial license.

1.
2,

3.

Select Free Trial, and click Login with FortiCloud.

Use your FortiCloud account credentials to log in, or create a new account.
FortiAnalyzer connects to FortiCloud to get the trial license. The system will restart to
apply the trial license.

Read and accept the license agreement.

For more information, see the FortiAnalyzer VM Trial License Guide.

Activate License If you have a license file, you can activate it .

1.
2,

Upload License 1.

Select Activate License, and click Login with FortiCloud.

Use your FortiCloud account credentials to log in.

FortiAnalyzer connects to FortiCloud, and the license agreement is displayed.
Read and accept the license agreement.

Click Browse to upload the license file, or drag it onto the field.
Click Upload. After the license file is uploaded, the system will restart to verify it. This
may take a few moments.

To download the license file, go to the Fortinet Technical Support site

ﬂ (https://support.fortinet.com/), and use your FortiCloud credentials to
log in. Go to Asset > Manage/View Products, then click the product
serial number.

FortiAnalyzer 7.2.2 Administration Guide
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Security considerations

You can take steps to prevent unauthorized access and restrict access to the GUI. This section includes the following
information:

« Restricting GUI access by trusted host on page 21
o Trusted platform module support on page 21
o Other security considerations on page 23

Restricting GUI access by trusted host

To prevent unauthorized access to the GUI you can configure administrator accounts with trusted hosts. With trusted
hosts configured, the administrator user can only log into the GUI when working on a computer with the trusted host as
defined in the administrator account. You can configure up to ten trusted hosts per administrator account. See
Administrators on page 349 for more details.

Trusted platform module support

On supported FortiAnalyzer hardware devices, the Trusted Platform Module (TPM) can be used to protect your
password and key against malicious software and phishing attacks. The dedicated module hardens the FortiAnalyzer by
generating, storing, and authenticating cryptographic keys.

For more information about which models feature TPM support, see the FortiAnalyzer Data Sheet.

By default, the TPM is disabled. To enable it, you must enable private-data-encryption and set the 32
hexadecimal digit master-encryption-password. This encrypts sensitive data on the FortiAnalyzer using AES128-CBC.
With the password, TPM generates a 2048-bit primary key to secure the master-encryption-password through RSA-
2048 encryption. The master-encryption-password protects the data. The primary key protects the master-encryption-
password.

The key is never displayed in the configuration file or the system CLI, thereby obscuring the information and leaving the
encrypted information in the TPM.

\ L}
S L4
? The TPM module does not encrypt the disk drive of eligible FortiAnalyzer.

The primary key binds the encrypted configuration file to a specific FortiAnalyzer unit and never leaves the TPM. When
backing up the configuration, the TPM uses the key to encrypt the master-encryption-password in the configuration file.
When restoring a configuration that includes a TPM protected master-encryption-password:

« If TPMis disabled, then the configuration cannot be restored.

« If TPMis enabled but has a different master-encryption-password than the configuration file, then the configuration
cannot be restored.

« If TPMis enabled and the master-encryption-password is the same in the configuration file, then the configuration
can be restored.

For information on backing up and restoring the configuration, see Backing up the system on page 274 and Restoring
the configuration on page 276.

FortiAnalyzer 7.2.2 Administration Guide 21
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Setting up FortiAnalyzer

The master-encryption-password is also required when migrating the configuration, regardless if TPM is available on the
other FortiAnalyzer model. For more information, see Migrating the configuration on page 276.

Passwords and keys that can be encrypted by the master-encryption-key include:

Admin password

Alert email user's password

BGP and other routing related configurations
External resource

FortiGuard proxy password
FortiToken/FortiToken Mobile’s seed

HA password

IPsec pre-shared key

Link Monitor, server side password

Local certificate's private key

Local, LDAP. RADIUS, FSSO, and other user category related passwords
Modem/PPPoE

NST password

NTP Password

SDN connector, server side password
SNMP

Wireless Security related password

A\,

‘Q' In HA configurations, each cluster member must use the same master-encryption-key so that
- the HA cluster can form and its members can synchronize their configurations.

To check if your FortiAnalyzer device has a TPM:

Enter the following command in the FortiAnalyzer CLI:

The outputin the CLl includes ### TPM info, which displays if the TPM is detected (enabled), not detected (disabled),

diagnose hardware info

or not available.

To enable TPM and input the master-encryption-password:

Enter the following command in the FortiAnalyzer CLI:

config system global
set private-data-encryption enable
end

Please type your private data encryption key (32 hexadecimal numbers):

khkhkhkhkhk kA hkkrhkhkrhkhkrhkhkhkhkhkhkxhkhkxkkxk

Please re-enter your private data encryption key (32 hexadecimal numbers)

R I b S b I b S b b b 2 I b S b S Sb b Sh b I 2h b S 3 3

Your private data encryption key is accepted.

FortiAnalyzer 7.2.2 Administration Guide
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Setting up FortiAnalyzer

Other security considerations

Other security consideration for restricting access to the FortiAnalyzer GUI include the following:

« Configure administrator accounts using a complex passphrase for local accounts
« Configure administrator accounts using RADIUS, LDAP, TACACS+, or PKI

» Configure the administrator profile to only allow read/write permission as required and restrict access using read-
only or no permission to settings which are not applicable to that administrator

» Configure the administrator account to only allow access to specific ADOMs as required

When setting up FortiAnalyzer for the first time or after a factory reset, the password cannot be

NP left blank. You are required to set a password when the admin user tries to log in to
‘9' FortiManager from GUI or CLI for the first time. This is applicable to a hardware device as well
as a VM. This is to ensure that administrators do not forget to set a password when setting up

FortiAnalyzer for the first time.
After the initial setup, you can set a blank password from System Settings > Administrators.

GUI overview

When you log into the FortiAnalyzer GUI, the following home page of tiles is displayed:

om

Device Manager iVi Log View Fabric View

1 -3

Management
Extensions

FortiSoC System Settings

Select one of the following tiles to display the respective pane. The available tiles vary depending on the privileges of the
current user.

Device Manager Add and manage devices and VDOMs. See Device Manager on page 38.
Fabric View Configure fabric connectors. See Fabric View on page 112.
Management Extensions Enable and use management extension applications that are released and signed

by Fortinet. See Management Extensions on page 399.

FortiView Summarizes SOC information in FortiView and Monitors dashboards, which
include widgets displaying log data in graphical formats, network security, WiFi
security, and system performance in real-time.

FortiAnalyzer 7.2.2 Administration Guide
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Setting up FortiAnalyzer

This pane is not available when the unit is in Collector mode.

Log View View logs for managed devices. You can display, download, import, and delete
logs on this page. You can also define custom views and create log groups. See
Log View and Log Quota Management on page 88.

FortiSoC FortiSoC is a subscription service that enables playbook automation for security
operations on FortiAnalyzer. See FortiSoC on page 194.

Reports Generate reports. You can also configure report templates, schedules, and output
profiles, and manage charts and datasets. See Reports on page 214.

This pane is not available when the unit is in Collector mode.

FortiRecorder Manage FortiCamera devices and view camera streams and recordings through
the Monitors dashboard.

This pane is only available in physical appliances and is disabled by default. See
FortiRecorder on page 252

This pane is not available when the unit is in Collector mode.

System Settings Configure system settings such as network interfaces, administrators, system
time, server settings, and others. You can also perform maintenance and
firmware operations. See System Settings on page 267.

Incidents & Events Configure and view events for logging devices. See Incident and Event
Management on page 135.

This pane is only visible when the FortiSoC pane is disabled. This pane is not
available when the unit is in Collector mode.

After you choose a tile, click the Open/Close side menu button beside the tile name to close the side menu and view only
the content pane in the browser window, or click to display the side menu and the content pane. See Side menu open or
closed on page 26.

The top-right corner of the home page includes a variety of possible selections:

ADOM If ADOMs are enabled, the required ADOM can be selected from the dropdown
list.

The ADOMs available from the ADOM menu will vary depending on the
privileges of the current user.

Tools Click to access the CLI Console and the Online Help.
CLlI The CLI console is a terminal window that enables you to configure the
Console FortiAnalyzer unit using CLI commands directly from the GUI, without making a

separate SSH, or local console connection to access the CLI.

When using the CLI console, you are logged in with the same administrator
account that you used to access the GUI. You can enter commands by typing
them, or you can copy and paste commands into or out of the console.

Click Detach in the CLI Console toolbar to open the console in a separate
window.

Note: The CL/ Console requires that your web browser support JavaScript.

Online Click to open the FortiAnalyzer online help.
Help
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You can also open the FortiAnalyzer basic setup video
(https://video.fortinet.com/products/fortianalyzer/6.2/).

Notification Click to display a list of naotifications. Select a notification from the list to take
action on the issue.

admin Click to change the administrator profile, upgrade the firmware of FortiAnalyzer,
change your password, or log out of the GUI.

Panes

In general, panes have four primary parts: the banner, toolbar, tree menu, and content pane.

Banner Along the top of the page; includes the home button (Fortinet logo), tile menu,
open/close side menu, ADOM menu (when enabled), tools menu, notifications,
and admin menu.

Tree menu On the left side of the screen; includes the menus for the selected pane.
Not available in Device Manager.

Content pane Contains widgets, lists, configuration options, or other information, depending on
the pane, menu, or options that are selected. Most management tasks are
handled in the content pane.

Toolbar Directly above the content pane; includes options for managing content in the
content pane, such as Create New and Delete.

&3 FortiView~ FortiView Monitors 0 @5 Q1 (§ adminy

[# Edit Dashboard M All Devices » @ Last 1 Hour ~ 00:27 - 01:27

Traffic B¢ . .
Threat Map o Top Threat Destinations Top: 50 - @ @B

Applications & Websites

Comproms ot |
FortiSandbox Detections

Endpoints

Fabric State of Security

VPN

WiFi

FortiClient Software Inventory
Threat(FortiClient )

Applications & Websites(FortiClient )
Endpoints(FortiClient)

Local System Performance

Global Threat Research

Secure SD-WAN Monitor

test

Archive

To switch between panes, either select the home button to return to the home page, or select the tile menu then select a
new tile.

FortiAnalyzer 7.2.2 Administration Guide
Fortinet Inc.


https://video.fortinet.com/products/fortianalyzer/6.2/fortianalyzer-basic-setup-1

Setting up FortiAnalyzer

="% Device Manager v H l v

@] m ‘ H Average Log Rate(Logs/Sec) Device Storage Descriptiol
@] (e 111] P Time B | (4.52%)
0 Time 3 | (5.67%)

FortiView Log View Fabric View :
@] Time 12 1 (21.52%)
@] Time 7 1 (11.89%)
@] ® Time 7 1 (11.89%)
@] Time N/A (0.01%)
@] me N/A (0%)

9

o FortiSoC Reports System Settings Management re Y (001%)
(@] Extensions me 7 1 (10.47%)
0O  wonepise_sewonu_roor IUIUU00 UL FUIIGAEARMIOH VIV w real Time 7/ 1 (12.85%)

Color themes
You can choose a color theme for the FortiAnalyzer GUI. For example, you can choose a color, such as blue or plum, or
you can choose an image, such as summer or autumn. See Global administration settings on page 377.

Side menu open or closed

After you choose a tile, such as Device Manager, you can close the side menu and view only the content pane.
Alternately you can view both the side menu and the content pane.

In the banner, click the Open/close side menu button to change between the views.

Switching between ADOMs

When ADOMs are enabled, you can move between ADOMs by selecting an ADOM from the ADOM menu in the banner.
ADOM:Test?0 &> 8 e v

ADOM access is controlled by administrator accounts and the profile assigned to the administrator account. Depending

on your account privileges, you might not have access to all ADOMs. See Managing administrator accounts on page 350

for more information.

Using the right-click menu

Options are sometimes available using the right-click menu. Right-click an item in the content pane, or within some of the
tree menus, to display the menu that includes various options similar to those available in the toolbar.

In the following example on the Reports pane, you can right-click a template, and select Create New, View, Clone, or
Create Report.

ADOM:root I3 @ Q1 (§) admin v

B3 Generated Reports + CreateNew [% Edit ¥ Delete W Clone B CreateReport & Install Language Pack | q

B Report Definitions

B All Reports &Temp Template | Security

+ Create New
B Templates FdTemplate - 360-D [ Edit
[l Chart Library @

y review of Application Visibility and Control, Threat Detection, Data i

tion Detection, Endpoint Detection, Prevention and Recommended Security PDF

Security Review B Delete

£ Macro Library 5 Cl
O ETemplate-Admin & —'° | taled | . HTML
= L login and fail login attempts and system severity event counts. ystem
£= Datasets @ oo eI R B Create Report gl gi .
43 Advanced >| O EgTemplate - Application Application risk, categories, bandwidth by app, web categories, vulnerability HTML
English Application ©w
Bick and Cantral avelnite wire hntnat adwars malicines sttacks Fla francars onE
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Avatars

When FortiClient sends logs to FortiAnalyzer, an avatar for each user can be displayed in the Source column in the
FortiView and Log View panes. FortiAnalyzer can display an avatar when FortiClient is managed by FortiGate or
FortiClient EMS with logging to FortiAnalyzer enabled.

« When FortiClient Telemetry connects to FortiGate, FortiClient sends logs (including avatars) to FortiGate, and the
logs display in FortiAnalyzer under the FortiGate device as a sub-type of security.
The avatar is synchronized from FortiGate to FortiAnalyzer by using the FortiOS REST API.

« When FortiClient Telemetry connects to FortiClient EMS, FortiClient sends logs (including avatars) directly to
FortiAnalyzer, and logs display in a FortiClient ADOM.

If FortiAnalyzer cannot find the defined picture, a generic, gray avatar is displayed.

Ay
‘?' You can also optionally define an avatar for FortiAnalyzer administrators. See
- Creating administrators on page 351.

Showing and hiding passwords

In some cases you can show and hide passwords by using the toggle icon. When you can view the password, the Toggle
show password icon is displayed:

Password test @

When you can hide the password, the Toggle hide password icon is displayed:

Password [.. . },l

Target audience and access level

This guide is intended for administrators with full privileges, who can access all panes in the FortiAnalyzer GUI, including
the System Settings pane.

In FortiAnalyzer, administrator privileges are controlled by administrator profiles. Administrators who are assigned
profiles with limited privileges might be unable to view some panes in the GUI and might be unable to perform some
tasks described in this guide. For more information about administrator profiles, see Administrator profiles on page 358.

N ! 7, If you logged in by using the admin administrator account, you have the Super_User
? administrator profile, which is assigned to the admin account by default and gives the admin
3 administrator full privileges.

Initial setup

This topic provides an overview of the tasks that you need to do to get your FortiAnalyzer unit up and running.
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To set up FortiAnalyzer:

1.
2,
3.

Connect to the GUI. See Connecting to the GUI on page 13.
Configure the RAID level, if the FortiAnalyzer unit supports RAID. See Configuring the RAID level on page 293.
Configure network settings. See Configuring network interfaces on page 286.

\ﬂ Once the IP address of the administrative port of FortiAnalyzer is changed, you will lose

connection to FortiAnalyzer. You will have to reconfigure the IP address of the
management computer to connect again to FortiAnalyzer and continue.

(Optional) Configure administrative domains. See Managing ADOMs on page 300.
Configure administrator accounts. See Managing administrator accounts on page 350.

again by using your new administrator account.

x After you configure the administrator accounts for the FortiAnalyzer unit, you should log in

Add devices to the FortiAnalyzer unit so that the devices can send logs to the FortiAnalyzer unit. See Adding
devices on page 41.

Configure the operation mode. See Configuring the operation mode on page 276 and Operation modes on page 30.

FortiManager features

FortiManager features are not available in FortiAnalyzer 6.2.0 and up.

For information about FortiManager, see the FortiManager Administration Guide.

Ny If FortiManager features are enabled in FortiAnalyzer before upgrading to 6.2.0 and later, the
‘?' existing feature configurations will continue to be available after the upgrade.
- FortiManager features carried over during an upgrade can be disabled through the CLI
- console.
Next steps

Now that you have set up your FortiAnalyzer units and they have started receiving logs from the devices, you can start
monitoring and interpreting data. You can:

View log messages collected by the FortiAnalyzer unitin Log View. See Types of logs collected for each device on
page 88.

View multiple panes of network activity in FortiView > Monitors. See Monitor on page 70.

View summaries of threats, traffic, and more in FortiView. See FortiView on page 54.

Generate and view events in Incidents & Events or FortiSoC. See Incident and Event Management on page 135
Generate and view reports in Reports. See Reports on page 214.
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Restarting and shutting down

Always use the operation options in the GUI or the CLI commands to reboot and shut down the FortiAnalyzer system to
avoid potential configuration problems.

See Restart, shut down, or reset FortiAnalyzer on page 347 in System Settings on page 267.
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This section provides information about basic FortiAnalyzer concepts and terms. If you are new to FortiAnalyzer, use this
section to quickly understand this document and the FortiAnalyzer platform.

This section includes the following sections:

o Operation modes on page 30

o Administrative domains on page 32
o Logsonpage 33

» Log storage on page 33

o FortiView dashboard on page 36

Operation modes

FortiAnalyzer can run in two operation modes: Analyzer and Collector. Choose the operation mode for your
FortiAnalyzer units based on your network topology and requirements.

Analyzer mode

Analyzer mode is the default mode that supports all FortiAnalyzer features. Use this mode to aggregate logs from one or
more Collectors.
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The following diagram shows an example of deploying FortiAnalyzer in Analyzer mode.

FortiAnalyzer

l F I FortiGates |

ortiGates

Collector mode

When FortiAnalyzer is in Collector mode, its primary task is forwarding logs of the connected devices to an Analyzer and
archiving the logs. Instead of writing logs to the database, the Collector retains logs in their original binary format for
uploading. In this mode, most features are disabled.

Analyzer and Collector feature comparison

Feature Analyzer Mode Collector Mode
Device Manager Yes Yes
FortiView Yes No
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Feature Analyzer Mode Collector Mode
Log View Yes Raw archive logs only
Incidents & Events Yes No
Monitoring devices Yes No
Reporting Yes No
System Settings Yes Yes
Log Forwarding Yes Yes

Analyzer—Collector collaboration

You can deploy Analyzer mode and Collector mode on different FortiAnalyzer units and make the units work together to
improve the overall performance of log receiving, analysis, and reporting. The Analyzer offloads the log receiving task to
the Collector so that the Analyzer can focus on data analysis and report generation. This maximizes the Collector’s log
receiving performance.

For an example of setting up Analyzer—Collector collaboration, see Collectors and Analyzers on page 396.

FortiAnalyzer Fabric

FortiAnalyzer can also join a FortiAnalyzer Fabric which enables centralized viewing of devices, incidents, and events
across multiple FortiAnalyzers acting as members.

The FortiAnalyzer Fabric is ideal for use in high volume environments with many FortiAnalyzers. For more information
about sizing and design considerations, see the FortiAnalyzer Architecture Guide.

In this mode, FortiAnalyzer Fabric members form a Fabric with one device operating in supervisor mode as the root
device. Incident, event, and log information is synced from members to the supervisor using the API.

See the FortiAnalyzer Fabric Deployment Guide for more information.

Administrative domains

Administrative domains (ADOMs) enable the admin administrator to constrain the access privileges of other
FortiAnalyzer unit administrators to a subset of devices in the device list. For Fortinet devices with virtual domains
(VDOMs), ADOMs can further restrict access to only data from a specific VDOM for a device.

Enabling ADOMs alters the available functions in the GUIl and CLI. Access to the functions depends on whether you are
logged in as the admin administrator. If you are logged in as the admin administrator, you can access all ADOMs. If you
are not logged in as the admin administrator, the settings in your administrator account determines access to ADOMs.

For information on enabling and disabling ADOMs, see Enabling and disabling the ADOM feature on page 299. For
information on working with ADOMSs, see Administrative Domains (ADOMs) on page 296. For information on configuring
administrator accounts, see Managing administrator accounts on page 350.
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M, ADOMs must be enabled to support FortiCarrier, FortiClient EMS, FortiMail, FortiWeb,
? FortiCache, and FortiSandbox logging and reporting. See Administrative Domains (ADOMSs)
3 on page 296.

Logs

Logs in FortiAnalyzer are in one of the following phases.

« Real-time log: Log entries that have just arrived and have not been added to the SQL database. These logs are
stored in Archive in an uncompressed file.

« Archive logs: When a real-time log file in Archive has been completely inserted, that file is compressed and
considered to be offline.

« Analytics logs or historical logs: Indexed in the SQL database and online.

In order for FortiAnalyzer to accept logs, the sending device must be registered in FortiAnalyzer. You can add devices to

FortiAnalyzer by specifying the serial number and other details, or you may point the device’s log settings to the
FortiAnalyzer. If initiated by the remote device, the device must be authorized before logs can be received on
FortiAnalyzer. See Adding devices on page 41.

For more information on the types of logs collected for each device, see Types of logs collected for each device on page

88.

Log encryption

Beginning in FortiAnalyzer 6.2, all logs from Fortinet devices (using Fortinet's proprietary protocol: OFTP) must be
encrypted. FortiAnalyzer encryption level must be equal or less than the sending device’s level. For example, when

configuring logging from a FortiGate, FortiAnalyzer must have the same encryption level or lower than FortiGate in order

to accept logs from FortiGate.

To configure the encryption level on FortiAnalyzer:
1. Inthe FortiAnalyzer CLlI, enter the following commands:

config system global
set enc-algorithm {high | low | medium}

To configure the encryption level on FortiGate:
1. Inthe FortiGate CLI, enter the following commands:

config log fortianalyzer setting
set enc-algorithm {high-medium | high | low}

See also Appendix B - Log Integrity and Secure Log Transfer on page 405.

Log storage

Logs and files are stored on the FortiAnalyzer disks. Logs are also temporarily stored in the SQL database.
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You can configure data policy and disk utilization settings for devices. These are collectively called log storage settings.

You can configure global log and file storage settings. These apply to all logs and files in the FortiAnalyzer system
regardless of log storage settings.

Log rolling

When FortiAnalyzer receives a log, it is stored in a file. Logs will continue to populate this file until its limit is reached, at
which time the file is "rolled" which involves compressing the file and creating a new one for further logs of that type.
There are two settings that you can use to configure when log rolling occurs, and both may be used at the same time,
with rolling taking place when either condition is met.

« Log file size: This is enabled by default and set to 200 MB.
« Atascheduled time: Either daily or weekly at a set time.

Rolling the files daily is recommended to avoid a file from spanning more than 24 hours and masking the actual amount
of days you are storing logs for.

See also Configuring rolling and uploading of logs using the GUI on page 338.

Log deletion

When you reach your archive retention limit as defined by allocated storage size or specified days, FortiAnalyzer deletes
old logs to make room for new logs. FortiAnalyzer can only delete files, not logs within a file. Controlling file growth is
important because storage capacity is not infinite and it directly affects how old logs are deleted to make room for new
logs.

FortiAnalyzer will delete old files based on which condition is forcing the deletion:

« Days: Delete the log file that contains logs which are all outside the configured day retention period. Log files can
span several days, or even months. When this is the case, the file will not be considered eligible for deletion when
logs that are within the configured retention days would be deleted. This can lead to Archive indicating it is storing
more days than it is configured for (for example, 100/90 days). This is due to the number displaying the oldest log
date, and not specifically that it has logs for each day up to that number.

» Storage size: Delete the log file with the oldest last received log. This can lead to the administrator not seeing the
true amount of logs in analytics since there's no way to indicate that there are no logs for days 60 through 89, only
that there are some logs from 90 days ago.

See also Data policy and automatic deletion on page 36 and Disk utilization for Archive and Analytic logs on page 36.

SQL database

FortiAnalyzer supports Structured Query Language (SQL) for logging and reporting. The log data is inserted into the
SQL database to support data analysis in FortiView, Log View, and Reports. Remote SQL databases are not supported.

For more information, see FortiView on page 54, Types of logs collected for each device on page 88, and Reports on
page 214.

The log storage settings define how much FortiAnalyzer disk space to use for the SQL database.
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\‘é’, When FortiAnalyzer is in Collector mode, the SQL database is disabled by default. If you want

to use logs that require SQL when FortiAnalyzer is in Collector mode, you must enable the
SQL database. See Operation modes on page 30.

Analytics and Archive logs

Logs in FortiAnalyzer are in one of the following phases.

« Real-time log: Log entries that have just arrived and have not been added to the SQL database. These logs are
stored in Archive in an uncompressed file.

« Archive logs: When a real-time log file in Archive has been completely inserted, that file is compressed and
considered to be offline.

» Analytics logs or historical logs: Indexed in the SQL database and online.
Use a data policy to control how long to retain Analytics and Archive logs.

« Archive logs on page 35
« Analytic logs on page 35

Archive logs

When FortiAnalyzer receives a log, it is stored in a file. Logs will continue to populate this file until its limit is reached, at
which time the file is "rolled" which involves compressing the file and creating a new one for further logs of that type.
These files (rollled or otherwise) count against the archive retention limits and are referred to as Archived or Offline logs.

You cannot immediately view details about these logs in the FortiView, Log View, and Incidents & Events/FortiSoC
panes. You also cannot generate reports about the logs in the Reports pane.

Archive logs are stored unchanged and can be uploaded to a file server for use as backups.

« If you are using a FortiAnalyzer-VM, you may also choose to snapshot the data drive to backup your logs.

« If you are using a physical FortiAnalyzer which leverages RAID for storage, remember that RAID is not a backup
solution.

Log storage in Archive is important since it is used to rebuild the database in the event of database corruption, orin some
cases during upgrades.

Analytic logs
Immediately following the storage of a log in an archive, the same log is inserted into the SQL database. This function is
also known as being indexed, and these logs are referred to as Analytic or Online logs.

Analytic logs are the only logs which are used for analysis in FortiAnalyzer FortiSoC, Log View (excluding Log Browse),
Incidents and Events, and Reports.

Analytic logs are dissected during insertion and any subtypes are stored as their own category. For example, security
profile logs such as web filtering logs are sent and stored as Traffic logs when archived, however, Analytics extracts the
relevant web filtering fields and stores them in a web filtering table.

Indexed logs take up significantly more space than the same amount of logs in Archive.
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Most administrators may need to store between 30 and 60 days in Analytics, however, this should be configured for the
amount of time that you would typically need to explore the logs for.

If you need to run analytics for dates outside your Analytics retention, you may perform a database rebuild and load the
particular date range. A database rebuild involves purging all logs from Analytics and loading logs for the days of interest
from Archive. Once analysis is complete, you can then rebuild once more to load the most current logs into analytics
from the archive.

Data policy and automatic deletion

Use a data policy to control how long to keep compressed and indexed logs. When ADOMs are enabled, you can specify

settings for each ADOM and the settings apply to all devices in that ADOM. When ADOMs are disabled, settings apply to
all managed devices.

A data policy specifies:

« How long to keep Analytics logs indexed in the database
When the specified length of time in the data policy expires, logs are automatically purged from the database but
remain compressed in a log file on the FortiAnalyzer disks.

» How long to keep Archive logs on the FortiAnalyzer disks
When the specified length of time in the data policy expires, Archive logs are deleted from the FortiAnalyzer disks.

See also Log storage information on page 107.

Disk utilization for Archive and Analytic logs

You can specify how much of the total available FortiAnalyzer disk space to use for log storage. You can specify what
ratio of the allotted storage space to use for logs that are indexed in the SQL database and for logs that are stored in a
compressed format on the FortiAnalyzer disks. Then you can monitor how quickly device logs are filling up the allotted
disk space.

Analytic logs indexed in the SQL database require more disk space than Archive logs (purged
‘\él, from the SQL database but remain compressed on the FortiAnalyzer disks).

An average Analytic log is 600 bytes, and an average Archive log is 80 bytes. By default, after
seven days Analytic logs are compressed and are an average of 150 bytes.

Keep this difference in mind when specifying the storage ratio for Analytics and Archive logs.

When ADOM s are enabled, you can specify settings for each ADOM and the settings apply to all devices in that ADOM.
When ADOMs are disabled, settings apply to all managed devices. See Log storage information on page 107.

FortiView dashboard

FortiAnalyzer provides dashboards for Security Operations Center (SOC) administrators. FortiView includes monitors
which enhance visualization for real-time activities and historical trends for analysts to effectively monitor network
activities and security alerts. See FortiView on page 53.
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In high capacity environments, the FortiView module can be disabled to improve performance. See Enabling and
disabling FortiView on page 86.
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Use the Device Manager pane to add, configure, and manage devices and VDOMs.

After you add and authorize a device or VDOM, the FortiAnalyzer unit starts collecting logs from that device or VDOM.
You can configure the FortiAnalyzer unit to forward logs to another device. See Log Forwarding on page 310.

You can toggle between a Table View and Map View from the toolbar in Device Manager.

Table View:
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FERTINET

Three donut charts display above the list of authorized devices:

» Log Status
* Logging Mode
» Log Encryption

By default, the Show Charts toggle is enabled. You can select which charts appear by selecting them in the Show Charts
dropdown, or you can hide all the charts by disabling the Show Charts toggle.

Mouse over the charts to see more information in a tooltip. Click a section of a chart to filter the charts and the table by
that information. You can apply multiple filters across the charts. Once filtered, a filter icon appears next to the chart title;
click the filter icon to remove the filter.

If you create a custom device group, it appears in the Device & Groups tree menu. Select the device group to display
information about those devices.

The Device Manager table view includes the following default columns for authorized devices:

Column Description

Device Name Displays the name of the device.

Serial Number Displays the serial number of the device. The serial number is unique to the unit
and does not change with firmware upgrades.
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Column Description

Platform Displays the platform for the device.

Firmware Version Displays the firmware version of the device.

IP Address Displays the IP address for the device.

Logs Identifies whether the device is successfully sending logs to the FortiAnalyzer

unit. A green circle indicates that logs are being sent. A red circle indicates that
logs are not being sent. The status indicator will turn from green to red when logs
have not been sent for 15 minutes or longer.

A lock icon displays when a secure tunnel is being used to transfer logs from the
device to the FortiAnalyzer unit.

Average Log Rate Displays the average rate at which the device is sending logs to the FortiAnalyzer
(Logs/Sec) unit in log rate per second. Click the number to display a graph of historical
average log rates.

Device Storage Displays how much of the allotted disk space has been consumed by logs.

HA Status Displays information if the device is part of a High Availability cluster. You can
manually identify devices as part of an HA cluster by editing the device
information. See Editing device information on page 48.

Description Displays a description of the device.
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The Map View provides an interactive map displaying the physical locations of authorized devices. You can navigate the
map by using your mouse. Zoom in or out with the scroll wheel or with the plus (+) or minus (-) buttons on the map. When
zoomed in, only the devices that are currently visible on the map are displayed in the sidebar. The sidebar provides
information about the devices, including logging status, average log rate, and device storage.
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ADOMs

You can organize connected devices into ADOMs to better manage the devices. ADOMs can be organized by:

o Firmware version: group all 7.0 devices into one ADOM, and all 7.2 devices into another.

« Geographic regions: group all devices for a specific geographic region into an ADOM, and devices for a separate
region into another ADOM.

» Administrator users: group devices into separate ADOMSs based for specific administrators responsible for the
group of devices.

o Customers: group all devices for one customer into an ADOM, and devices for another customer into another
ADOM.

FortiAnalyzer, FortiCache, FortiClient, FortiDDos, FortiMail, FortiManager, FortiSandbox, FortiWeb, Chassis, and
FortiCarrier devices are automatically placed in their own ADOMs.

» Security Fabric: group all devices that are within the Security Fabric.

Each administrator profile can be customized to provide read-only, read/write, or restrict access to various ADOM
settings. When creating new administrator accounts, you can restrict which ADOMSs the administrator can access, for

enhanced control of your administrator users. For more information on ADOM configuration and settings, see
Administrative Domains (ADOMs) on page 296.

FortiClient EMS devices

You can add FortiClient EMS servers to FortiAnalyzer. Authorized FortiClient EMS servers are added to the default
FortiClient ADOM. You must enable ADOMs to work with FortiClient EMS servers in FortiAnalyzer. When you select the

FortiClient ADOM and go to the Device Manager pane, the FortiClient EMS servers are displayed. See also FortiClient
support and ADOMs on page 298.

Unauthorized devices

When a device is configured to send logs to FortiAnalyzer but has not yet been authorized, it is displayed in Device
Manager > Device & Groups > Unauthorized Devices. From this device group, you can authorize, delete, or hide devices
by using the toolbar buttons or the right-click menu.

Ay
‘Q' The Unauthorized Devices device group is not available when all added devices are
- authorized.

Enable Display Hidden Devices to view devices that were previously hidden.

Click Return to view the Device Manager pane containing authorized devices.

@ Add Device 3B Device Groupw

& Device & Groups v © Retun [ Authorize @ Hide B Delete ([J Display Hidden Devices Q
1 [searen q O ADeiiceNome Model Serial Number Connecting IP
O @Branch_Office 01 FortiGate-VM&4 FGVM02TM21010449 10101
Managed FortiGate o Branch_Office_02 FortiGate-VM64 FGVMO2TM21010409 102.0.1
[m] @ Enterprise_First_Floor FortiGate-VMé4 FGVMO02TM21011968 10.100.88.101
0 _Second_Floor FortiGate-VM64 FGVM02TM21011485 10.100.88.102
O @emorlang-pmdb17551 FortiGate-VM64 FGVMO2TM21013304 10100.88.1

The Unauthorized Devices device group includes the following default columns:
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Column Description

Device Name Displays the name of the device.

Model Displays the model of the device.

Serial Number Displays the serial number of the device.
Connecting IP Displays the IP address of the device.

Using FortiManager to manage FortiAnalyzer devices

You can add FortiAnalyzer devices to FortiManager and manage them. When you add a FortiAnalyzer device to
FortiManager, FortiManager automatically enables FortiAnalyzer features. FortiAnalyzer and FortiManager must be
running the same OS version, at least 5.6 or later.

In the Device Manager pane, a message informs you the device is managed by FortiManager and all changes should be
performed on FortiManager to avoid conflict. The top right of this pane displays a lock icon. If ADOMs are enabled, the
System Settings > All ADOMs pane displays a lock icon beside the ADOM managed by FortiManager.

Logs are stored on the FortiAnalyzer device, not the FortiManager device. You configure log storage settings on the
FortiAnalyzer device; you cannot change log storage settings using FortiManager.

For more information, see Adding FortiAnalyzer devices in the FortiManager Administration Guide.

Adding devices

You must add and authorize devices and VDOMSs to FortiAnalyzer to enable the device or VDOM to send logs to
FortiAnalyzer. Authorized devices are also known as devices that have been promoted to the DVM table.

You must configure devices to send logs to FortiAnalyzer. For example, after you add and
ﬂ authorize a FortiGate device with FortiAnalyzer, you must also configure the FortiGate device
I to send logs to FortiAnalyzer. In the FortiGate GUI, go to Log & Report > Log Settings, and
enable Send Logs to FortiAnalyzer/FortiManager.

Adding devices using the wizard

This section describes how to add model devices and VDOMs to the FortiAnalyzer using zero-touch provisioning (ZTP).

When using the Add Device wizard, model devices added to the FortiAnalyzer unit using a serial number are authorized
and are ready to begin sending logs. When a FortiGate model is configured using a pre-shared key, you must also
configure the key on the device itself before it will be authorized on FortiAnalyzer.

To add devices using the wizard:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.

2. Goto Device Manager and click Add Device.
The Add Device wizard opens. You can add devices by serial number or pre-shared key.
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Device Manager

Add Device

MName

Link Device By ©)

Serial Number

Device Model

Description

i

Please input the following information to add a device.

MName

(*)Serial Number Pre-shared Key
Serial Numbe

Description

Mext = Cancel

3. Configure the following settings:

Name

Link Device By

Serial Number

Pre-shared Key

Device Model

Description

4. Click Next.

Type a name for the device.

Select Serial Number or Pre-shared Key.

Depending on your selection, the device model will automatically link to a real
device by serial number or configured pre-shared key.

Enter the device's serial number.

Enter a pre-shared key for the device. If using a pre-shared key, each device
must have a unique pre-shared key

Only FortiGate devices can be added to FortiAnalyzer using a pre-shared key.

You must also configure this pre-shared key on the corresponding FortiGate
device. See Configuring a pre-shared key on FortiGate on page 43

Select the model of the device from the dropdown.

Type a description of the device (optional).

The device is added to the ADOM and, if successful, is ready to begin sending logs to the FortiAnalyzer unit.
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Add Device
MName Branch_Office_03
SN FGYMOO0000000004

Status 0 Device is added successfL
Creating device database
Retrieving high availability status
Initializing configuration database
Updating group membership

Successfully add device

Finish

L

5. Click Finish to finish adding the device and close the wizard.

Configuring a pre-shared key on FortiGate

When configuring a FortiGate model device on FortiAnalyzer using a pre-shared key, the pre-shared key must also be
configured on FortiGate using the following CLI commands. This can be done after the FortiGate has been configured to
send logs to FortiAnalyzer in Log & Report > Log Settings.

To configure a pre-shared key on FortiGate:

1. Inthe FortiGate CLI, enter the following commands.
config log fortianalyzer setting
set preshared-key <pre-shared key>

Authorizing devices

You can configure supported devices to send logs to the FortiAnalyzer device. These devices are displayed in the root
ADOM as unauthorized devices. You can quickly view unauthorized devices by clicking Unauthorized Devices in the
quick status bar. You must authorize the devices before FortiAnalyzer can start receiving logs from the devices.

FortiAnalyzer 7.2.2 Administration Guide 43
Fortinet Inc.



Device Manager

When ADOMs are enabled, you can assign the device to an ADOM. When authorizing multiple devices at one time, they
are all added to the same ADOM.

By default, FortiAnalyzer expects you to use the default admin account with no password. If
N : /, the default admin account is no longer usable, or you have changed the password, the device
? authorization process fails. If the device authorization fails, delete the device from
- FortiAnalyzer, and add the device again by using the Add Device wizard, where you can
specify the admin login and password.

When you delete a device or VDOM from the FortiAnalyzer unit, its raw log files are also deleted. SQL database logs are
not deleted.

To authorize devices:

1.

In the root ADOM, go to Device Manager and click Unauthorized Devices in the quick status bar. The content pane
displays the unauthorized devices.

If necessary, select the Display Hidden Devices check box to display hidden unauthorized devices.
Select the unauthorized device or devices, then click Authorize. The Authorize Device dialog box opens.

Authorize Device

Add the following device(s) to ADOM: root

Device Name Assign New Device Name

FGVM010000102012 FGVM010000102012

If ADOMs are enabled, select the ADOM in the Add the following device(s) to ADOM list. If ADOMs are disabled,
select root. The default value is None.

If you try to authorize devices having different firmware versions than the selected ADOM
version, the system shows a Version Mismatch Warning confirmation dialog.
If you authorize the devices in spite of the warning, the configuration syntax may not be

fully supported in the selected ADOM.

Click OK to authorize the device or devices.
The device or devices are authorized, and FortiAnalyzer can start receiving logs from the device or devices.

Hiding unauthorized devices

You can hide unauthorized devices from view, and choose when to view hidden devices. You can authorize or delete
hidden devices.

To hide and display unauthorized devices:

1.

In the root ADOM, go to Device Manager and click Unauthorized Devices in the quick status bar. The content pane
displays the unauthorized devices.

Select the unauthorized device or devices, then click Hide.
The unauthorized devices are hidden from view.

You can view hidden devices by selecting the Display Hidden Devices check box.
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Adding an HA cluster

You can use a HA cluster to synchronize logs and data securely among multiple FortiGate devices.

An HA cluster can have a maximum of four devices: one primary device with up to three backup devices. All the devices

in the cluster must be of the same FortiGate series and must be visible on the network.

You can use auto-grouping in FortiAnalyzer to group devices in a cluster based on the group
NV name specified in Fortigate's HA cluster configuration. For auto-grouping to work properly,
‘?' each FortiGate cluster requires a unique group name.
- If a unique group name is not used, auto-grouping should be disabled.
FAZ # config system global
(global)# set ha-member-auto-grouping disable

To create a HA cluster:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.

2. Addthe devices to the Device Manager.
3. Choose a primary device, and click Edit.
4. Inthe Edit Device pane, select HA Cluster.
5. From the Add Existing Device list, select a device, and click Add.
Name FG149
Description
1P Address 10.10.10.10
Serial Number FGVYMO0000000000 (FortiGate-VM&4)
Firmware Version FortiGate 5.6, build1534
Admin User admin
Password sensee
HA Cluster
Add Existing Device
Add Other Device
HA Cluster List # Device Name

1 FG149 (FGYMO0000000000)

6. Optionally, you can use the Add Other Device field to add a new device.

I\ Adding the devices before you create the HA is recommended.

7. Add more devices as necessary, and click OK.
The maximum is three backup devices.

To view the HA in the Device Manager, click Column Settings > HA Status.

Adding a FortiGate using Security Fabric authorization

The following steps describe how to add and authorize a FortiGate device on FortiAnalyzer through the FortiAnalyzer

Fabric connector configuration on FortiOS.
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Al
‘Q' FortiAnalyzer authentication through the FortiGate Fabric connector configuration is available
- when both FortiAnalyzer and FortiGate devices are on 7.0.1 or higher.

To authorize a FortiGate on FortiAnalyzer using Fabric authorization:

1. InFortiAnalyzer, go to System Settings > Admin > Admin Settings and configure the Fabric Authorization address

Admin Settings
Idle Timeout (GUI) 900 4 | (60-28800 Seconds)
View Settings
Language Auto Detect

High Contrast Theme
Other Themes

ﬂ m
T
>

Cany

Password Policy
Fabric Authorization ©
Authorization Address | 192.168.50.249

Authorization Port 443

2. Onthe FortiGate, go to Security Fabric > Fabric Connectors, and double-click the Logging & Analytics card.
Select the Settings tab, and then select the FortiAnalyzer tab.
4. Configure the details of your FortiAnalyzer, including the IP address, and click OK.

The FortiAnalyzer Connection status is Unauthorized.

w

Core Network Security Connectd Logging Settings x
y, Settings nfo
q} Security Fabric Setup
FortiAnalyzer Cloud Logging
FabricRg———
ame fabric Status A EVESE © Disabled
Server
Connection status @ Unauthorized
£ Refresh | [ Authorize
Upload option Every Minute | Every 5 Minutes
LI Bl Allow access to FortiGate REST APl @D
LEER LR EEIERGE Verify FortiAnalyzer certificate ©
2B FortiGate
*t? FortiAP FortiAnalyzer Status
X FortiSwitch
— Logqueued 41695
B FortiExtender Failedlogs O
Security Fabric Connectors “ Cancel

5. Click Authorize.
The Fortinet Security Fabric authorization dialog appears.
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6. Enter your FortiAnalyzer administrator credentials, and click Login.

Fortinet
Security
Fabric

223 FortiAnalyzer-VM64

E—

7. Select Approve to allow FortiAnalyzer to authorize the FortiGate, and click OK.

Fortinet
Security
Fabric

Select an action for the following unregistered devices.

FGVMOOTM Q

FGVMOOTM Deny  Later

et

If the authorization is successful, you will see a message confirming that the FortiGate is authorized by
FortiAnalyzer.

Core Network Security Connemj Logging Settings

ﬂ Security Fabric Setup

Settings Info

FortiAnalyzer Cloud Logging
Role FabricRg———
Fabric name fabric Status Disabled

Server

| Connection status 0 Authorized
£ Refresh

Upload option Every Minute | Every 5 Minutes
LAN Edge Devices ] Allow access to FortiGate REST APl @©
LEER LR EEEEE Verify FortiAnalyzer certificate @ O FAZVMSTM =«
B FortiGate (5]
57 FortiAP FortiAnalyzer Status

Logqueued 42921
Failedlogs 0

(3]
2 FortiSwitch [3]
B FortiExtender [0]

Security Fabric Connectors Cancel

8. Loginto FortiAnalyzer, and go to Device Manager.
The FortiGate is included in the list of authorized devices.

+ AddDevice [# Edit [ Delete I More~ 4 Column Settings v
O ADevice Name 1P Address Platform Average Log Rate(Logs/Sec)

FGVMOOTME S T .- FortiGate-VMé4
0O @FMG FortiManager-VMé4-Xen
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Managing devices
Use the tools and commands in the Device Manager pane to manage devices and VDOMs.

Using the toolbar

The following buttons and menus are available for selection on the toolbar:

Button Description

Add Device Opens the Add Device Wizard to add a device to the FortiAnalyzer unit. The
device is added, but not authorized. Unauthorized devices are displayed in the
Unauthorized Devices tree menu.

Device Group Displays menu items including Create New Group, Edit Group, and Delete Group.
New device groups are added to the Device & Groups tree menu. Select a custom
device group to edit or delete it.

Edit Edits the selected device.

Delete Deletes the selected devices or VDOMSs from the FortiAnalyzer unit.

When you delete a device, its raw log files are also deleted. SQL database logs
are not deleted.

Table View/Map View Select the view from the dropdown.
More Displays more menu items including Import Device List and Export Device List.
Show Charts Enable or disable the charts that display above the Table View. From the

dropdown, you can select the charts that display above the Table View.

Column Settings Click to select which columns to display or select Reset to Default to display the
default columns.

Search Type the name of a device. The content pane displays the results. Clear the
search box to display all devices in the content pane.

Editing device information

Use the Edit Device page to edit information about a device. The information and options available on the Edit Device
page depend on the device type, firmware version, and which features are enabled.

To edit information for a device or model device:

1. Go to Device Manager > Device & Groups.

2. Inthe tree menu, select the device group.

3. Inthe content pane, select the device or model device and click Edit, or right-click on the device and select Edit.
The Edit Device pane displays.
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£ Device Manager v @ Add Device 3B Device Group + > @ D2~ oAdmin -
@ Device & Groups v Edit Device x
1& Search.. Q
All Logging Devices Name Branch_Office_01
Unauthorized Devices Description
IP Address 10.1.01
Serial Number FGVMO02TM22010505 (FortiGate-VMé64-KVM)
Firmware Version FortiGate 7.2.0, build4217
Admin User
Password ~ eesseees ®
HA
HA Cluster o
Geographic Coordinate 37.338207 Latitude
-121.88633 Longitude
Show Map
Meta Fields v
Company/Organization Optional
Contact Email Optional
Contact Phone Number Optional
Address Optional

Name
Description

IP Address

Serial Number
Firmware Version
Admin User
Password

HA Cluster

Geographic Coordinate

Meta Fields

Company/Organization
Contact Email
Contact Phone Number

Address
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4. Edit the device settings and click OK.

Change the name of the device.

Type a description of the device.

Displays the IP address.

Displays the serial number of the device.

Displays the firmware version of the device.

Change the administrator user name for the device.
Change the administrator user password for the device.

Select to identify the device as part of an HA cluster, and to identify the other
device in the cluster by selecting them from the drop-down list, or by inputting
their serial numbers.

Displays the latitude and longitude of the device.
Click Show Map to view and edit the device location.

Displays default and custom meta fields for the device. Optional meta fields
can be left blank, but required meta fields must be defined.

See also Setting values for required meta fields on page 50.
Optionally, enter the company or organization information.
Optionally, enter the contact email.

Optionally, enter the contact phone number.

Optionally, enter the address where the device is located.
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Displaying historical average log rates
You can display a graph of the historical, average log rates for each device.

To display historical average logs rates:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Device Manager and view your authorized devices.
3. Inthe Average Log Rate (Logs/Sec) column, click the number to display the graph.

Log Rate History (Enterprise_First_Floor, Last 24 Hours)

4. Hover the cursor over the graph to display more details.

Connecting to an authorized device GUI
You can connect to the GUI of an authorized device from Device Manager.

To connect to an authorized device GUI:

If using ADOMs, ensure that you are in the correct ADOM.
Go to Device Manager.
Right-click the device that you want to access, and select Connect to Device.

If necessary, change the port number and click OK.
You are directed to the login page of the device GUI.

Ao b=

Setting values for required meta fields

When a required meta field is defined for a device object, a column automatically displays on the Device Manager pane.
The column displays the value for each device. When the required meta field lacks a value, an exclamation mark
displays, indicating that you must set the value.

See also Meta Fields on page 336.
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To set values for required meta fields:

1.

Go to Device Manager.

2. View the columns.

4,

A column displays for required meta fields.

In the following example, a column named /ocation is displayed for the required meta field named location. A value
of San Jose is defined for one device, but no value is defined for the other device.

=+ AddDevice [# Edit i Delete Morev % Column Settings v
O  ADevice Name 1P Address Platform Logs Average Log Rate(Logs/Sec) Device Storage Description location
O @Branch_Office 01 FortiGate-VM64 & @ Real Time 4 I (613%) San Jose
O @Branch_Office_ 02 FortiGate-VM64 & @ Real Time 4 I (5.62%) A

Right-click the device that lacks a value, and select Edit.
The Edit Device pane is displayed.

Edit Device
Name Branch_Office_02 B
Description
4
0/128
IP Address
Serial Number FGVM (FortiGate-VMé4)
Firmware Version FortiGate 6.6.0, build2287
Admin User faz
Password ssssssce ®
HA Cluster
Meta Fields

Company/Organization
Contact Email

Contact Phone Number
Address

location

Under Meta Fields, complete the options labeled as Required, and click OK.
The value displays on the Device Manager pane.

Device groups

Device groups are displayed in Device Manager > Device & Groups. All devices added to FortiAnalyzer are included in a
default device group. You can create custom device groups as well to organize devices for convenient selection in other
features of FortiAnalyzer.
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Type in the Search field to search for device groups by name. Click 2 {0 sort the list of device groups in ascending or

descending alphabetical order. The default device group will always remain at the top of the list. Select the device group
to display its list of devices in the Device Manager pane.

NP The maximum number of device groups that can be created is the same as the maximum
‘Q' number of devices/VDOMs supported for your VM license or model. See the FortiAnalyzer
- data sheet on https://www.fortinet.com/ for information about the maximum number of

supported devices/VDOMs for your VM license or device.

Adding device groups

Once created, custom device groups can be selected in device filters for FortiView and Log View, and they can also be
used in event handlers and reports.

To create a custom device group:

1. Go to Device Manager.

2. From the Device Group dropdown in the toolbar, click Create New Group.
The Create New Device Group dialog opens.

3. Inthe Group Name field, type a name to identify the group of devices.
Description is optional.

4. Click Add Member to view the list of devices and existing device groups.
5. Select the check box for each device to add to the group, and click Add.

Al
‘Q' FortiAnalyzer allows nested device groups. For example, you can create Device Group A
- and add it under Device Group B.

6. Click OK.
The device group is now available in Device Manager > Device & Groups.

Managing device groups

You can manage device groups from Device Manager > Device & Groups. From the Device Group dropdown in the
toolbar, select one of the following options:

Option Description

Create New Group Create a new device group.
Edit Group Edit the selected device group. You cannot edit default device groups.
Delete Group Delete the selected device group. You cannot delete default device groups.
\ L}
S L4
? You must remove all devices from the group before you can delete the group.
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FortiView

Use FortiView to view the FortiView and Monitor panes.
FortiView is a comprehensive monitoring system for your network that integrates real-time and historical data into a
single view. It can log and monitor threats to networks, filter data on multiple levels, keep track of administrative activity,
and more.
Monitor is designed for network and security operation centers where dashboards are displayed across multiple large
monitors.

o FortiView on page 54

e Monitor on page 70

N ! ’, To allow tuning of CPU and memory usage in high capacity environments, you can opt to
9 disable FortiView, which stops the background processing for this feature. See Enabling and
- disabling FortiView on page 86.
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FortiView is a comprehensive monitoring system for your network that integrates real-time and historical data into a
single view. It can log and monitor threats to networks, filter data on multiple levels, keep track of administrative activity,
and more.

FortiView allows you to use multiple filters in the consoles, enabling you to narrow your view to a specific time, by user ID
or local IP address, by application, and others. You can use it to investigate traffic activity such as user
uploads/downloads or videos watched on YouTube on a network-wide user group or on an individual-user level.

In FortiView dashboards, you can view summaries of log data such as top threats to your network, top sources of
network traffic, and top destinations of network traffic.

Depending on which dashboard you are viewing, information can be viewed in different formats: table, bubble, map, or
tile. Alternative chart types are available in each widget's Settings menu.

For each summary, you can drill down to see more details.
FortiGate, FortiCarrier, and FortiClient EMS devices support FortiView.

Some dashboards require that specific log types are enabled before they can be used. When an ADOM does not include
any logs of the required type, the dashboard appears in gray and includes an information icon that indicates what logs
must be enabled before the dashboard can be used.

performance in high capacity environments. For more information, see Enabling and disabling
FortiView on page 86

\ﬂ The FortiView module, which includes the FortiView pane, can be disabled to improve

How ADOMs affect FortiView

When ADOMs are enabled, each ADOM has its own data analysis in FortiView.

Fabric ADOMs will show data analysis from all eligible devices in the Security Fabric.

Logs used for FortiView

FortiView displays data from Analytics logs. Data from Archive logs is not displayed in FortiView. For more information,
see Analytics and Archive logs on page 35.

FortiView dashboards

Many dashboards display a historical chart in a table format to show changes over the selected time period.

If you sort by a different column, the chart shows the history of the sorted column. For example, if you sort by Sessions
Blocked/Allowed, the chart shows the history of blocked and allowed sessions. If you sort by Bytes Sent/Received, the
chart shows the history of bytes sent and received.

When you drill down to view a line item, the historical chart show changes for that line item.
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FortiView dashboards for FortiGate and FortiCarrier devices

Top Threats

Threat Map

Threats

Compromised Hosts

FortiSandbox
Detection

FortiAnalyzer 7.2.2 Administration Guide
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Lists the top threats to your network.

The following incidents are considered threats:
* Risk applications detected by application control.
« Intrusion incidents detected by IPS.
e Malicious web sites detected by web filtering.
» Malware/botnets detected by antivirus.

Displays a map of the world that shows the top traffic destinations starting
at the country of origin. Threats are displayed when the threat score is
greater than zero and either the source or destination IP is a public IP
address.

The Threat Window below the map, shows the threat, source, destination,
severity, and time. The color gradient of the lines indicate the traffic risk. A
yellow line indicates a high risk and a red line indicates a critical risk.

This view does not support filtering and Day, Night, and Ocean themes.
See also Viewing the threat map on page 58.

Displays end users with suspicious web use compromises, including end

users’ IP addresses, overall threat rating, and number of threats.

To use this feature:

1. UTM logs of the connected FortiGate devices must be enabled.

2. The FortiAnalyzer must subscribe to FortiGuard to keep its threat
database up-to-date.

Displays a summary of FortiSandbox related detections.

The following information is displayed: Filename, End User and/or IP,
Destination IP, Analysis (Clean, Suspicious or Malicious rating), Action
(Passthrough, Blocked, etc.), and Service (HTTP, FTP, SMTP, etc.).

Select an entry to view additional information in the drilldown menu.
Clicking a FortiSandbox action listed in the Process Flow displays details
about that action, including the Overview, Indicators, Behavior Chronology
Chart, Tree View, and more. Information included in the Details and Tree
View tab is only available with FortiSandbox 3.1.0 and above.
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Category View

Top Sources

Top Source
Addresses

Top Destinations
Traffic

Top Destination
Addresses

Top Country/Region

Policy Hits

DNS Logs

ZTNA Servers

Top Cloud

Shadow IT Applications

Top Cloud Users

Top Applications

Applications &
Websites Top Website
Domains

Top Website
Categories

Top Browsing Users
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Description

Displays the highest network traffic by source IP address and interface,
device, threat score (blocked and allowed), sessions (blocked and
allowed), and bytes (sent and received).

Displays the top source addresses by source object, interface, device,
threat score (blocked and allowed), sessions (blocked and allowed), and
bytes (sent and received).

Displays the highest network traffic by destination IP addresses, the
applications used to access the destination, sessions, and bytes. If
available, click the icon beside the IP address to see its WHOIS
information.

Displays the top destination addresses by destination objects,
applications, sessions, and bytes. If available, click the icon beside the IP
address to see its WHOIS information.

Displays the highest network traffic by country in terms of traffic sessions,
including the destination, threat score, sessions, and bytes.

Lists the policy sessions by policy, device name, VDOM, number of hits,
bytes, and last used time and date.

Summarizes the DNS activity on the network. Double click an entry to drill
down to the specific details about that domain.

ZTNA servers by bytes.

Displays the top cloud applications used on the network.

When viewing information about an application, FortiAnalyzer will first
check the Shadow IT database, and if no results are found, it will use the
metadata.

Displays the top cloud users on the network.

Displays the top applications used on the network including the application
name, category, risk level, and sessions blocked and allowed. Bytes sent
and received can also be enabled through the widget settings. Top
Applications can be viewed as a stackbar, bar, table, or bubble chart.

For a usage example, see Finding application and user information on
page 68.

Displays the top allowed and blocked website domains on the network.

Displays the top website categories.

Displays the top web-browsing users, including source, group, number of
sites visited, browsing time, and number of bytes sent and received.
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Category View Description

Displays the users who are accessing the network by using the following
types of security over a virtual private network (VPN) tunnel: secure socket
layers (SSL) and Internet protocol security (IPsec).
SSL & Dialup IPsec | You can view VPN traffic for a specific user from the top view and drilldown
VPN views. In the top view, double-click a user to view the VPN traffic for the
specific user. In the drilldown view, click an entry from the table to display
the traffic logs that match the VPN user and the destination.

Site-to-Site IPsec Displays the names of VPN tunnels with Internet protocol security (IPsec)
that are accessing the network.

Admin Logins Displays the users who logged into the managed device.

System Events Displays events on the managed device.

Displays device CPU, memory, logging, and other performance
information for the managed device.

Resource Usage
i e Resource Usage includes two widgets: Resource Usage Average and
Resource Usage Peak.
Failed . . .
N Displays the IP addresses of the users who failed to log into the managed
Authentication device
Attempts '

Using FortiView

When ADOMs are enabled, FortiView displays information for each ADOM. Please ensure you are in the correct ADOM.
See Switching between ADOMs on page 26.

» Viewing FortiView dashboards on page 57

« Filtering FortiView on page 59

« Viewing related logs on page 59

» Exporting filtered summaries on page 59

» Monitoring resource usage of devices on page 60
« Long-lived session handling on page 60

Viewing FortiView dashboards

When viewing FortiView dashboards, use the controls in the toolbar to select a device, specify a time period, refresh the
view, and switch to full-screen mode.

Many widgets on FortiView dashboards let you drill down to view more details. To drill down to view more details, click,
double-click, or right-click an element to view details about different dimensions in different tabs. You can continue to drill
down by double-clicking an entry. Click the close icon in the widget's toolbar to return to the previous view.

Many FortiView widgets support multiple chart types such as table view, bubble view, map view, tile view, etc.

» In widgets that support multiple views, select the settings icon in the top-right corner of the widget to choose another
view.
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« If sorting is available, there is a Sort By dropdown list in the top-left.
« Some widgets have a Show dropdown list in the bottom-right for you to select how many items to display.
» To sort by a column in table view, click the column title.

« To view more information in graphical views such as bubble, map, or user view, hover the mouse over a graphical
element.

Some dashboards require that specific log types are enabled before they can be used. When an ADOM does not include
the log type(s) required, the dashboard appears in gray and includes an information icon that indicates what logs must
be enabled.

Viewing the threat map

[ Dashboard v BAIDevicess @ last 1Hourv OBO047 - 09:0049

2
i
=
B
E
E
B

E

You can view an animated world map that displays threats from unified threat management logs. Threats are displayed
in real-time. No replay or additional details are available.

You must specify the longitude and latitude of the device to enable threats for the device to
ﬂ display in the threat map. You can edit the device settings to identify the geographical location
I of the device in Device Manager. For more information, see Editing device information on
page 48

To view the threat map:

1. Goto FortiView > Threats > Threat Map.
2. Inthe map, view the geographic location of the threats.
Threats are displayed when the threat level is greater than zero.
o Avyellow line indicates a high threat.
« Ared line indicates a critical threat.
3. Inthe Threat Window, view the Time, Threat, Source, Destination, and Severity(score).
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Filtering FortiView

Filter FortiView widgets using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-
sensitive filter. You can also filter by specific devices or log groups and by time.

To filter FortiView widgets using filters in the toolbar:

1. Specify filters in the Add Filter box.

« Filter Mode: In the selected summary view, click Add Filter and select a filter from the dropdown list, then type a
value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or “or”.

« Text Search: Click the Switch to Text Search icon at the right end of the Add Filter box. In Text Search mode,
enter the search criteria (log field names and values). Click the Switch to Filter Mode icon to go back to Filter
Mode.

2. Inthe Device list, select a device.
3. Inthe Time list, select a time period.

including Source Object and Destination Object.See the FortiGate/FortiOS

s‘é’, UUID logging must be enabled in FortiGate/FortiOS to filter traffic by object name,
3 Administration Guide for more information about UUID logging.

To filter FortiView widgets using the right-click menu:

In the selected view, right-click an entry and select a filter criterion (Search <filter value>).

Depending on the column in which your mouse is placed when you right-click, FortiView uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

Viewing related logs

You can view the related logs for a FortiView summary in Log View. When you view related logs, the same filters that you
applied to the FortiView summary are applied to the log messages.

To view related logs for a FortiView summary, right-click the entry and select View Related Logs.

Exporting filtered summaries

You can export filtered FortiView summaries or from any level of drilldown to PDF and report charts. Filtered summaries
are always exported in table format.

To export a filtered summary:

1. Inthe filtered summary view or its drilldown, select the tools icon in the top-right corner of the widget and choose
Export to PDF or Export to Report Chart.

2. Inthe dialog box, review and configure settings:
« Specify a file name for the exported file.
« Inthe Top field, specify the number of entries to export.

« Ifyou are in a drilldown view, the tab you are in is selected by default. You can select more tabs. If you are
exporting to report charts, the export creates one chart for each tab.
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3. Click OK.

Charts are saved in the Chart Library. You can use them in the same way you use other charts.

Al
S L4
? Only log field filters are exported. Device and time period filters are not exported.

Monitoring resource usage of devices

You can monitor how much FortiAnalyzer system resources (e.g., CPU, memory, and disk space) each device uses.
When ADOMs are enabled, this information is displayed per ADOM. In a specific ADOM, you can view the resource
usage information of all the devices under the ADOM.

Go to FortiView > System > Resource Usage to monitor resource usage for devices.

Long-lived session handling

Because traffic logs are only sent at the end of a session, long-lived sessions can be unintentionally excluded when
narrowing searches in FortiView. To account for this, interim traffic logs can be enabled through FortiOS, allowing
FortiView to show the trend of session history rather than one large volume once the session is closed.

For a long-lived session with a duration greater than two minutes, interim traffic logs are generated with the Log ID of 20.

« Forinterim traffic logs, the sentdelta and rcvddelta fields are filled in with an increment of bytes which are
sent/received after the start of the session or previous interim traffic log.

« Interim traffic logs are not counted in Sessions, but the sentdelta and recvddelta in related traffic logs will be added
when calculating the sent and received bytes.

When a long-lived session ends, a traffic log with a Log ID of 13 is sent which indicates the session is closed.
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Summary 5:55“3"5 Blocked —(- Allowed

Application VavNC

Category Not.Scanned o0&

Risk High 0.6

# of Clients 1 0.4

Sessions( " Blocked/ M Allowed) [ 1] 02

Bytes( " Sent/ M Received)

¢ 1315 13:20 13:‘25 13:30 13:35 13:40 1345 13:50 13:55 14:00 14:10
Destination ~ Country/Region  Threat  Session

# ¥ Date/Time Device ID Firewall Action  Source IP Destination IP Service Application |LogID Session ID sentdelta rcvddelta Duration
1 14:11:55 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 | 187053 180 5600 1791
2 14:09:25 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 270 5736 1671
3 14:06:27 FGT91E4Q160005...  + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 180 8408 1491
4 14:04:28 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 187053 270 8394 1371
5 14:01:02 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 | 187053 270 8298 1191
6 13:58:08 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 187053 180 5204 1011
7 13:56:09 FGT91E4Q160005... ' + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 187053 270 7788 891
8 13:53:28 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 | 187053 180 5090 711
9 13:51:35 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 | 187053 3518 22200 591
10 13:49:32 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 187053 270 7824 471
11 13:46:27 FGT91E4Q160005...  + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 22942 1340721 291
12 13:44:23 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 11864 411594 171
13 13:33:28 FGT91E4Q160005... + close 172.184.112 172.18.4.201 VNC  VNC 0000000013 | 186001 17584 183669 801
14 13:31:35 FGT91E4Q160005... '+ accept 172.184.112 172.18.4.201 VNC VNC 0000000020 f 186001 21980 272402 723
15 13:29:23 FGT91E4Q160005...  + accept 172.184.112 172.18.4.201 VNC VNC 0000000020 | 186001 21940 272680 602
16  13:27:30 FGT91E40160005... '+ accent 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 186001 22004 270784 481

£= Total logs for analytics: 60 days 22 hours.
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Items per page

~ 0.281 Second

Ay
‘?' When enabled, interim logs must be handled specially for Reports and Events to avoid
- multiple counting.

Viewing Compromised Hosts

Compromised Hosts or Indicators of Compromise service (IOC) is a licensed feature.

When using Compromised Hosts, it is recommended to turn on the UTM web filter of FortiGate devices and subscribe
your FortiAnalyzer unit to FortiGuard to keep its local threat database synchronized with the FortiGuard threat database.
See Subscribing FortiAnalyzer to FortiGuard on page 343.

FortiGate devices also generate an event log for IOC when they are detected in local out traffic. The source IP in these
event logs are considered a compromised host, and they can be monitored in FortiAnalyzer.

Email filter logs from FortiMail devices are also supported by IOC, and can be rescanned when enabled in the
Compromised Hosts settings.

The Indicators of Compromise service (I0C) downloads the threat database from FortiGuard. The FortiGuard threat
database contains the blacklist and suspicious list. IOC detects suspicious events and potentially compromised network
traffic using sophisticated algorithms on the threat database.

FortiAnalyzer identifies possible compromised hosts by checking the threat database against an event's IP, domain, and
URL in the following logs of each end user:

» Web filter logs.
o DNSlogs.
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o Trafficlogs.
« Email filter logs (for FortiMail devices).

When a threat match is found, sophisticated algorithms calculate a threat score for the end user. When the check is
complete, FortiAnalyzer aggregates all the threat scores of an end user and gives its verdict of the end user’s overall
I0C.

Compromised Hosts displays the results showing end users with suspicious web usage which can indicate that the
endpoint is compromised. You can drill down to view threat details.

Compromised Hosts can be configured to rescan logs at regular intervals using new definitions from FortiGuard.

Understanding Compromised Hosts entries

When a log entry is received and inserted into the SQL database, the log entry is scanned and compared to the blacklist
and suspicious list in the IOC threat database that is downloaded from FortiGuard.

If a match is found in the blacklist, FortiAnalyzer displays the endpoint in Compromised Hosts with a Verdict of Infected.
If a match is found in the suspicious list, FortiAnalyzer flags the endpoint for further analysis.

In the analysis, FortiAnalyzer compares the flagged log entries with the previous endpoint's statistics for the same day
and then updates the score.

If the score exceeds the threshold, that endpoint is listed or updated in Compromised Hosts.
When an endpoint is displayed in Compromised Hosts, all the suspicious logs which contributed to the score are listed.

When the database is rebuilt, all log entries are reinserted and rescanned.

Working with Compromised Hosts information

Go to FortiView > Threats > Compromised Hosts.
To navigate the Compromised Hosts dashboard:

« Use the toolbar icons to select the table, user ioc, or bubble view.
o Use the exporticon to export table information into a PDF or report chart.

« Use settings to edit rescan configuration, and set additional display options, including Show Only Rescan and Show
Acknowledged.

« Use the toolbar to select devices, specify a time period, refresh the view, or enable Dark Mode.

When viewing the Compromised Hosts dashboard, # of Threats is the number of unique threat names associated with
that compromised host (end user).

o To acknowledge a Compromised Hosts line item, click Ack on that line.
« Tofilter entries, click Add Filter and specify devices or a time period.
o To drilldown and view threat details, double-click a tile or a row.

When viewing threat details, the # of Events is the number of logs matching each blacklist entry for that compromised
host (end user).

Incorrectly rated IOCs can be reported after drilling down to view threat details. Click the Detect Pattern for the row, and,
in the Information dialog, click report Misrated IOC.
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Managing a Compromised Hosts rescan policy

Compromised Hosts can be configured to scan previous entries on regular intervals or when a new package is received
from FortiGuard so that FortiAnalyzer performs a rescan using the latest available definitions.

Ay

Requirements for managing a Compromised Hosts rescan policy:
« This feature requires a valid indicators of compromise (IOC) license. The rescan options
are not available in the GUI or CLI without a license.

¢ The administrator must have Read-Write privileges for System Settings in order to
configure global IOC rescan settings.

When IOC rescan is performed, the Joc_Rescan tag is added to rescanned logs. Event handlers that include the loc_

Rescan tag in their rules will process rescanned logs and generate new alerts tagged with loc_Rescan. Real-time logs

matching these event handler rules continue to generate alerts without the loc_Rescan tag.

Bcsfv60~ Olast7Days..~

27 Expand All O Show Acknowledged

Handler =

o #
o1

ooooo

Event
+1169.112.88(2)
Traffic to C&C from VAN-200289-
Web traffic to C&C from VAN-200.
~1163.163.199 2)
Traffic to CS&C from VAN-200289-...
Web traffic to C&C from VAN-200.

Default-Compromised Host-Detection-IOC-By-Threat | Add Fite!

Event Statu Event Type

Unhandled

Unhandled

Unhandled
Unhandled

£ Traffic
© Web Filter

L Traffic
© Web Filter

Count. Severity
3 @ Critical
1 @ Critical
3 @ Critical
1 @ Criical

First Occurrence

2020-04-02 18:1045
2020-04-02 18:1043

2020-04-02 18:05:34
2020-04-02 18:05:32

¥ Last Update

2020-04-02 18:10:50
2020-04-02 18:10:43

2020-04-02 18:05:39
2020-04-02 18:05:32

Additional Info

Traffic to C&C:1.169.112.88, Traffic pa.

Handler

Default-Ca ised Host-Detection...

Traffic to C&C:1.169.112.88, Traffic pa.

Traffic to C&C:1.163.163.199, Traffic p...

. Default-Compromised Host-Detection...

Default-Ca d

Traffic to C&C:1.163.163.199, Traffic p.

Default-C ised Host-Detection...

By default, the following handlers include loc_Rescan tag for all rules:

o Default-Compromised Host-Detection-IOC-By-Endpoint
ised Host-Detection-IOC-By-Threat

B FortiSoC v

@ Dashboards
# Outbreak Alerts
€ Automation
W Event Monitor
| &= Handiers
Data Selector List

Notification Profile List

Default-Comprom

T C T C

% Security Fabric Demo  >_

Tags

1P || C&C || loc_Rescan
C&C | URL || loc_Rescan

.| 1P cac

C&C || URL

10C

2 Refresh ~

Device Name

HA91E_FGT91E
HA91E_FGT91E

HA91E_FGT91E
HA91E_FGT91E

- Oz~ eAdmin'

Event Handler List

Correlation Handler List
% Threat Hunting
F:ERTINET

(m]
o o
o 9

Status Name =

Default-Compromised Host-Detection-10C-By-Endpoint

Default-Compromised Host-Detection-IOC-By-Threat

Rules +

Rule-1 Traffic to CnC detected: (Default,By_Endpoint,IPC&C,loc_Rescan) tdtype~infected

Rule-2 Web traffic to CnC detected: (Default,By_Endpoint.C&CURLloc_Rescan) tdtype~infected
Rule-3 DNS trafic to CnC detected: (Default,By_Endpoint,C&C,Domain,loc_Rescan) tdtype~infected

Rule-1 Traffic to CnC detected: (Default, By_Threat,IPC&C loc_Rescan) tdtype-infected

Rule-2 Web traffic to CnC detected: (Default,By_Threat.C&CURL loc_Rescan) tdtype~infected
Rule-3 DNS traffic to CnC detected: (Default,By_Threat,C&C,Domain,loc_Rescan) tdtype~infected
Rule-4 Traffic to CnC event detected by FortiGate: (Default,By_Threat,C&C) logid==0100020214

To configure rescan settings and check rescan results:

1.

Go to FortiView > Threats > Compromised Hosts.

2. Click the Compromised Hosts menu icon above the table view.
The Compromised Hosts settings pane displays.
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B All Devices ~  (® Today ~ May 18 2023 - May 18 2023 Dark Mode @ &

Compromised Hosts Top: 100 ~ B % & B
Chart Type (=0 25 users IOC | & bubble
Show Top 100 -

OShow Acknowledged
Oonly Show Rescan

Compromised Hosts Rescan Global Settings @
Enable Global Compromised Hosts Rescan ©

Running at @ 12:00:00 AM

Compromised Hosts Rescan Current ADOM Settings

Enable Current ADOM Compromised Hosts Rescan @

EIDNS Logs

B Web Filter Logs

B Traffic Logs
OEmail Filter Logs

Log Type Filters

Last N Days (Recommended Maximum Days: 14) 14

Rescan tasks

Start Time Status Percentage | End Time Threat Count Log Count Package Update Time Blocklist Count

3. Configure the Compromised Hosts Rescan Global Settings.
a. Toggle Enable Global Compromised Hosts Rescan to On.

b. Set the running time to a specific hour of the day, or select package update to perform a rescan when a
package update is received.

4. Configure the Compromised Hosts Rescan Current ADOM Settings.
a. Toggle Enable Current ADOM Compromised Hosts Rescan to On.
b. Selectthe log types to be scanned (DNS, Web Filter logs, Traffic logs, or Email filter logs).

c. Setthe number of previous days' logs to be scanned.

By default, DNS, web filter, and traffic logs are enabled, and the scan will cover the last 14 days. The maximum
recommended number of scan days is calculated based on historical scan speeds, or 30 days if no previous scans
have been done.

5. Rescan jobs are shown in the Rescan tasks table, which includes the following columns:

Start Time The task's start time.

Status The status of the task (complete, running, etc.).
Running tasks can be canceled by clicking the cancel icon in the Status
column.

Percentage Task progress as a percentage.

End Time The task's end time.

Threat Count Configure the parameters for the selected action.

Log Count The total number of logs with threats.

Package Update Time The 10C package update time.

Blacklist Count A count of the newly detected threats added to the blacklist.
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A Al Devices ~ O Today ~ May 16 2023 - May 16 2023 Dark Mode @ &

Compromised Hosts Top: 100 + @ 2 & S
Show Top 100 v a
Oshow Acknowledged

OO0nly Show Rescan

Compromised Hosts Rescan Global Settings €

Enable Global Compromised Hosts Rescan (j

Running at @ 12:00:00 AM

Compromised Hosts Rescan Current ADOM Settings

Enable Current ADOM Compromised Hosts Rescan (j

G@DNS Logs

@ Web Filter Logs
@ Traffic Logs

B Email Filter Logs

Log Type Filters

Last N Days (Recommended Maximum Days: 30) 1
Rescan tasks

Start Time Status Percentage  End Time Threat Count Log Count Package Update Time Blacklist Count
May 16 22:21:51 complete m May 16 22:21:51 [129) 188 May 16 22:14:55 1200

6. Select a non-zero threat count number in the table to drilldown to view specific task details, including the Detect

Pattern, Threat Type, Threat Name, # of Events, and Endpoint.

Compromised Hosts >  Rescan Block Listv Q

ioc-rescan-time = 1684300495 ioc-logtype-mask =23 Add Filter o 0 B B
Summary
Start Time: May 16 22:21:51
Status: complete
Percentage: 100
End Time: May 16 22:21:51
Threat Count: 129
Log Count: 188
Package Update Time: May 16 22:14:55
Blacklist Count: 1200
# Detect Pattern Threat Type  Threat Name # of Events Endpoint
1 http:/www.iyou.com/xyz Malware CnC 95 awang@fortilog.com
2 150.1.1.1 Malware PostinfectionTraffic 34 50.2.1.1,50.2.2.1,50.2.2.4,50.2.3.1

In FortiView > Threats > Compromised Hosts, a rescan icon is displayed in the Last Detected column if threats are
found during a rescan. To view only those hosts that had threats found during a rescan, go to the settings menu and
select Only Show Rescan.

For FortiMail email filter rescans, the endpoint which visited an allowed URL will be marked as compromised if the
URL is blocklisted in the latest URL blocklist. The compromised hosts are the users' email addresses which can be

found in the To field of the log.

Indicators of Compromise

I0C (Indicators of Compromise) detects compromised client hosts (endpoints) by comparing the IP, domain, and URL
visited against the TIDB package, downloaded daily from FortiGuard. Compromised hosts are listed in FortiView in a

table or map style, and drilling down on a compromised endpoint displays the details of detected threats.

« The TIDB package contains a blacklist which is made up of IPs, domains and URLs, and a suspicious URL list (also

called Crowdsource URLS). Only suspicious URLs have a score rating in the TIDB package. Once a URL is
included in the blacklist, the suspicious score rating is no longer performed.

« Once a new TIDB package has been downloaded by FortiAnalyzer, the previous package becomes obsolete.

o The blackilist statistics by endpoint are updated in near realtime (ASAP), and suspicious rating statistics by endpoint

are updated on a half-hour schedule.
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« The IOC inspection is performed on a daily cycle because the updated FortiGuard TIDB package is received daily.
At the end of the day, the IOC endpoint summary is fixed and will not receive additional changes, and a new
summary will be created for the next day.

« Web Filter, DNS, and traffic logs from FortiGate, and email filter logs from FortiMail are inspected.

» The IOC module requires a license. Without a license, only demo TIDB packages are loaded into the FortiAnalyzer
image, and no updated package from FortiGuard is used in the IOC function.

« When a threat is detected, FortiAnalyzer sends a notification to the FortiGate via REST API. The FortiGate can be
configured to take automatic action against detected threats.

« |OC threat detection can be performed in both realtime and rescan mode. Realtime detection monitors new
incoming logs, whereas rescan mode checks historical logs against the new blacklist once an updated TIDB
package is available. Rescan mode does not check historical logs against the suspicious list. Realtime detection is
always enabled, and IOC rescan can be enabled or disabled.

Understanding suspicious list detection

The suspicious list is crowdsourced each day by FortiGuard Al from millions of global endpoint devices. The list is
comprised of IPs, URLs, and domains that have a low reputation, usually because they are questionable websites.

The TIDB package includes threat ranking scores which FortiAnalyzer normalizes using its internal logic. When an
endpoint visits a site that matches one included in the suspicious list, the score is deposited into the “reputation account”
for that endpoint. The total normalized score is then used to determine a verdict for the endpoint. The higher the score,
the higher the confidence. When a new TIDB package becomes available, the process to determine a verdict begins
again. FortiAnalyzer processes logs for all monitored endpoints against the new TIDB and will determine a verdict for
each endpoint based on their new normalized score.

Endpoints that visit suspicious sites on an infrequent basis are at a low risk for compromise and are not included in the
Compromised Host watch list. The FortiAnalyzer IOC engine continues to monitor these endpoints until it has enough
confidence to produce a verdict, at which point they are given the verdict Low Suspicious and are added to the watch list.
Endpoints that regularly visit suspicious sites are at a higher risk for infection or may already be infected with zero-day
malware. These endpoints are assigned a verdict and are added to the Compromised Host watch list.

Suspicious verdicts include:

» High suspicious (high confidence)
o Medium suspicious (medium confidence)
« Low suspicious (low confidence)

In the example below, an endpoint visits multiple sites included in the suspicious list, and as a result, has its verdict
changed from Low suspicious to Medium suspicious. The data included in this example is purely hypothetical for the
purpose of illustration.

Activity time Suspicious site Ranking of Suspicious score  FortiAnalyzer
stamp visited by suspicious site of endpoint I0C verdict
endpoint
Time stamp 1 suspicious-url-1 60 60 Low suspicious
Time stamp 2 suspicious-ip-2 100 160 Low suspicious
Time stamp 3 suspicious-domain-3 40 200 Medium suspicious

The specific algorithm used for the decision to change the verdict of an endpoint is internal to FortiAnalyzer.
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Viewing IOC licenses and TIDB package downloads

To check the license downloaded from FortiGuard in the CLI:

diagnose fmupdate dbcontract fds
FL-1KE3R16000271 [SERIAL NO]
AccountID:
Industry:
Company:
Contract: 1
PBDS-1-99-20250104
Contract Raw Data:
Contract=PBDS-1-99-20250104:0:1:1:0

In the output, PBDS is the IOC license.

To check the I0C package in the CLI:
diagnose fmupdate fds-getobject

FAZ object version information

ObjectId Description Version Size Created Date Time

00001000TIDB0O0100O ThreatIntel DB 00000.01052 34 MB 19/04/14 20:10
ext desc:ThreatIntel DB

00001000TIDB0O0100O ThreatIntel DB 00000.01053 37 MB 19/04/16 04:13

<latest> ext desc:ThreatIntel DB

FortiAnalyzer periodically syncs its own IOC TIDB files to the version of IOC package downloaded by fmupdate. This is
performed on a one hour schedule.

To check the license and TIDB version used by FortiAnalyzer in the CLI:
diagnose test application sgllogd 204 stats

License of post breach detection installed.

License expiration : 2025-Jan-04

TIDB version : 00000.01017-1902242107
TIDB load time : 2019-02-24 14:11:2

Configuring FortiGate to FortiAnalyzer REST API authentication

FortiGate to FortiAnalyzer REST API authentication allows the FortiAnalyzer to send IOC alerts and trigger configured
automation rules, if configured.

To configure REST API authentication:

1. Go to the Device Manager in the FortiAnalyzer.

2. Edit the FortiGate device to set the FortiGate super admin username and password.
This is the only way to configure REST API authentication prior to 6.2.
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Alternatively, when configuring logging to FortiAnalyzer on FortiGate, you can go to Security Fabric > Settings and
enable Allow access to FortiGate REST APl and Trust FortiAnalyzer by serial number.

Throttling IOC alerts

To avoid flooding FortiGate with event alerts, you can configure a throttle which allows only one alert to be sent within a
set period of time for the same endpoint.
The default time period is one day (1440 minutes).

To set an IOC alert throttle in the CLI:

config system log ioc
(ioc) # set

notification Disable/Enable Ioc notification.

notification-throttle Minute value for throttling the rate of IoC notifications.
(ioc)# get

notification : enable

notification-throttle: 1440

Debugging I0C notifications

Check for the FortiGate system event: IOC detected by FortiAnalyzer.

If the system event is not present, check FortiAnalyzer's OF TP debug or FortiGate's httpsd debug for the same
message.

Examples of using FortiView

You can use FortiView to find information about your network. The following are some examples.

» Finding application and user information on page 68
e Analyzing and reporting on network traffic on page 69
o Finding FortiGate C&C detection logs on page 69

Finding application and user information

Company ABC has over 1000 employees using different applications across different divisional areas, including supply
chain, accounting, facilities and construction, administration, and IT.

The administration team received a $6000 invoice from a software provider to license an application called Widget-Pro.
According to the software provider, an employee at Company ABC is using Widget-Pro software.

The system administrator wants to find who is using applications that are not in the company’s list of approved
applications. The administrator also wants to determine whether the user is unknown to FortiGuard signatures, identify
the list of users, and perform an analysis of their systems.

FortiAnalyzer 7.2.2 Administration Guide
Fortinet Inc.



To find application and user information:

If using ADOMs, ensure that you are in the correct ADOM.

Go to FortiView > FortiView > Applications & Websites > Top Applications.

Click Add Filter, select Application, type Widget-Pro.

If you do not find the application in the filtered results, go to Log View > FortiGate > Traffic.
Click the Add Filter box, select Source IP, type the source IP address, and apply the filter.

o wDbd =

Analyzing and reporting on network traffic

A new administrator starts at #1 Technical College. The school has a free WiFi for students on the condition that they
accept the terms and policies for school use.

The new administrator is asked to analyze and report on the top source and destinations students visit, the source and

destinations that consume the most bandwidth, and the number of attempts to visit blocked sites.

To review the source and destination traffic and bandwidth:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto FortiView > Traffic > Top Sources.
3. Goto FortiView > Traffic > Top Destinations.
If available, select the icon beside the IP address to see its WHOIS information.

Finding FortiGate C&C detection logs

FortiGate detected botnet events while performing an I0OC scan. The administrator wants to view the C&C and logs with
SOC view in Compromised Hosts.

To view C&C detection logs:

1. Goto FortiView > Threats > Compromised Hosts.

2. Inthe main view, right-click an entry and select Blocklist, or double-click an entry. The Blocklist is displayed. C&C
detection logs have the following values:

Threat Name * Botnet (for example, Asprox.Botnet)
Detect Method detected-by-fgt
Log Type attack

3. Inthe Blocklist drill-down view, double-click an entry to view related logs. Log View is displayed.
C&C detection entries appear in either the Aftack Name or Message columns with one of the following values:

Column Value

Attack Name * .Botnet (for example, Asprox.Botnet)

Message Botnet C&C * (for example, Botnet C&C Communication)
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Monitor

FortiView > Monitor is designed for a network and security operations center where multiple dashboards are displayed in
large monitors.

In the Monitor view, dashboards display both real-time monitoring and historical trends. Centralized monitoring and
awareness help you to effectively monitor network events, threats, and security alerts. Use Monitor dashboards to view
multiple panes of network activity, including monitoring network security, compromised hosts, endpoints, Security
Fabric, WiFi security, and FAZ system performance.

A typical scenario is to set up dashboards and widgets to display information most relevant to your network and security
operations. Use the main monitors in the middle to display important dashboards in a larger size. Then use the monitors
on the sides to display other information in smaller widgets.

For example, use the top monitor in the middle to display the Top Threat Destinations widget in full screen, use the
monitor(s) below that to display other Threat Monitor widgets, use the monitors on the left to display WiFi Monitor
widgets at the top and FAZ Performance Monitor widgets at the bottom, and use the monitors on the right as a
workspace to display widgets showing the busiest network activity. You can move, add, or remove widgets.

Monitor dashboards and widgets are very flexible and have the following features:

« You can create predefined or custom dashboards.

» For both predefined and custom dashboards, you can add, delete, move, or resize widgets.
¢ You can add the same dashboard multiple times on the same or different monitors.

» Each widget monitors one activity.

¢ You can add the same widget multiple times and apply different settings to each one. For example, you can add
widgets to monitor the same activity using a different chart type, refresh interval, or time period.

» You can resize widgets or display a widget in full screen.

Some dashboards and widgets require that specific log types are enabled before they can be used. When an
ADOM does not include any logs of the required type, the dashboard or widget appears in gray and includes an
information icon that indicates what logs must be enabled before it can be used.

\y

~ P FortiView, including the Monitor pane, can be disabled to improve performance in high
9 capacity environments. For more information, see Enabling and disabling FortiView on page
- 86
To prevent timeout, ensure Idle Timeout is greater than the widget's Refresh Interval. See Idle
timeout on page 383 and Settings icon on page 83.

FortiView Monitor dashboards

FortiView > Monitor includes predefined dashboards.

Both predefined and custom dashboards can be modified with widgets, including: Threats, Compromised Hosts, Traffic,
Applications & Websites, VPN, WiFi, Endpoints, Local System Performance on page 82, Global Threat Research, Fabric
State of Security, FortiClient Software Inventory, and FortiFirewall widgets (Traffic and VPN).
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For example, the default Threat Monitor dashboard includes four widgets: Threat Map, Top Threat Destinations, Top
Threats, and Top Virus Incidents Over Time. These widgets can be removed, enlarged, reduced, or customized, and
new widgets can be added to the dashboard.

For more information, see Customizing a Monitor dashboard on page 84.

FortiView > 4 AddWidget [ EditLayout BAIllDevices ~ @ Last 1 Hour ~ 10:32 - 11:32 DarkMode @ &
Monitor v
Threat Map [ Top Threat Destinations G Top: 50 » 1y @ B 3

= Traffic
Map Satellite
2 Applications & We...
£= Compromised Hosts
Secure SD-WAN ...
SD-WAN Summary
Kazakhston

Traffic Shaping Mo...
ZTNA

United States. Turkey.
Atghanistan

FortiSandbox Dete... Nowis e Ea4 Pakston
@ Endpoints
@ VPN
= WiFi

@ FortiClient Softwar...
@ loT
-

G
Threat (FortiClient) Google Agentina Keyboard shortcuts | Map data ©2022 | Terms of Use.

Applications & We...

Endpoints (FortiCli...
Gl Top Threats [ET = N Top Virus Incidents over Time O Top: 10 v

SortBy: Threatlevel v SortBy: MostRecent v Auto Play: Il

& Local System Perfo...
® Global Threat Rese... No Data
® Local Threat Resea..

& Archive >

FortiView Monitors includes the following predefined dashboards:

Threats on page 72 Monitor the top security threats to your network.
Traffic on page 73 Monitor the traffic on your network.

Applications & Websites on Monitor the application and website traffic on your network.
page 74

Compromised Hosts on page Monitor compromised and suspicious web use in your network.
74

Secure SD-WAN Monitor on Monitor secure software-defined networking.
page 74

SD-WAN Summary on page 75 Monitor SD-WAN operations.

Traffic Shaping Monitor on Monitor traffic shaping information.

page 76

ZTNA on page 76 Monitor ZTNA metrics.

FortiSandbox Detections on Monitor FortiSandbox detections on your network.
page 77

FortiMail on page 77 Monitor FortiMail statistics.

Endpoints on page 78 Monitor endpoint activity on your network.
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Fabric State of Security on
page 79

VPN on page 79
WiFi on page 79

FortiClient Software Inventory
on page 79

loT on page 80
Threat (FortiClient) on page 80

Applications & Websites
(FortiClient) on page 80

Endpoints (FortiClient) on
page 80

Traffic (FortiDDOS) on page 81

Traffic (FortiFirewall) on page
81

VPN (FortiFirewall) on page 81

Local System Performance on
page 82

Global Threat Research on
page 82

Local Threat Research on
page 83

Archive

Monitor your network's Security Fabric rating, score, and topology.

This information for this dashboard is available after you create a Security Fabric
group in FortiGate and add it in FortiAnalyzer. The Security Fabric can be
selected in the settings options for each widget.

Monitor VPN activity on your network.
Monitor WiFi access points and SSIDs.

Monitor the FortiClient endpoints sending logs to FortiAnalyzer.

Monitor loT devices.
Monitor threat activity from FortiClient.

Monitor application and website activity from FortiClient.

Monitor endpoint activity from FortiClient.

Monitor FortiDDoS detected traffic activity. This chart requires Intrusion
Prevention logs to be enabled.

Monitors FortiFirewall traffic.

Monitors FortiFirewall VPN usage.

Monitor the local system performance of the FortiAnalyzer unit.

Monitor global threat research.

Monitor local threat research.

Includes archived monitors from previous versions.

A\,

When upgrading versions prior to FortiAnalyzer 6.2.0, custom dashboards will not be migrated
and must be recreated.

Threats

Threats includes the following widgets:

Threat Map

Top Threat
Destinations

Threats happening right now across the world.

A world map, spinning 3D globe, or table showing the top 10, 20, 50, 100 threat destinations.
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Top Threats

Top Threats by
Weight & Count

Top Virus Incidents
Over Time

Traffic

On the map view, hover the cursor over data points to see the source device and IP address,
destination IP address and country, threat level, and the number of incidents (blocked and
allowed).

The top threats to your network. Hover the cursor over data points to see the threat, category,
threat level, threat score (blocked and allowed), and the number of incidents (blocked and
allowed).
The following incidents are considered threats:

¢ Risk applications detected by application control

¢ Intrusion incidents detected by IPS

* Malicious web sites detected by web filtering

¢ Malware/botnets detected by antivirus

The top threats by weight and count to your network from risk applications, intrusion incidents,
malicious websites, and malware/botnets.

The top virus incidents over time.

Traffic includes the following widgets:

Top Sources

Top
Country/Region

Top Policy Hits
Top Destinations

Traffic Over Time
by Sessions

Policy Hits Over
Time by Bandwidth

User Data Flow
Top Sources Today

Top Interface of
Sent Bit Rate

Top Interface of
Received Bit Rate

The highest network traffic by source IP address and interface, sessions (blocked and
allowed), threat score (blocked and allowed), and bandwidth (sent and received).

The historical network traffic by country/region, sessions, bandwidth, or threat score.

Top policy hits from recent traffic.
Top destinations from recent traffic by bandwidth or sessions.

The historical destinations from recent traffic.

The historical policy hits from recent traffic.

Bandwidth breakdown of top user destination country/region or application usage.
Near real-time network traffic by blocked and allowed sessions.

Line charts for the top 10 sent bit rate of interfaces over the specified time period.
Mouse over the line charts to view bit rate information for each interface.

Line charts for the top 10 received bit rate of interfaces over the specified time period.
Mouse over the line charts to view bit rate information for each interface.
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Applications & Websites

Applications & Websites includes the following widgets:

Top Website
Domains

Top Cloud
Applications

Top Applications

Top Browsing User

Cloud Applications
Over Time by
Sessions

Top Applications
Over Time by
Sessions

Top Endpoint
Applications

Website Browsing
Over Time by
Sessions

Browsing User
Over Time by
Bandwidth

Top website domains from recent traffic.

Top cloud applications from recent traffic.

The top applications used on the network, including application name, risk level, category,
sessions (blocked and allowed), and bytes (sent and received).

Top browsing users from recent traffic.

The historical sessions of cloud applications used on the network.

The historical sessions of applications used on the network, including application name, risk
level, category, sessions (blocked and allowed), and bytes (sent and received).

The top applications used on the network, including application name, risk level, category,
sessions (blocked and allowed), and bytes (sent and received).

Only available in a Fabric ADOM.

The historical websites browsing sessions from recent traffic.

The historical browsing users from recent traffic.

Compromised Hosts

Compromised Hosts includes the following widget:

Compromised
Hosts

Suspicious web use compromises. By default, this widget includes two panes: Compromised
Hosts and Compromised Hosts Incidents.

The Compromised Hosts pane automatically rotates through compromised hosts. You can
pause autoplay or click > or < to manually move to another compromised host.

The Compromised Hosts Incidents pane displays a map of compromised hosts incidents.

Click Settings to change the number of top compromised hosts, Time Period, Refresh
Interval, Autoplay Interval, and to show or hide Compromised Hosts Incidents.

Secure SD-WAN Monitor

Secure SD-WAN Monitor includes the following widgets:
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SD-WAN Bandwidth
Overview

SD-
WAN Performance
Status

SD-WAN Rules
Utilization

SD-WAN Utilization
by Application

Top SD-WAN
SLA Issues

Health Check Status

SD-WAN Events

Application
Bandwidth
Utilization

Per-Application
Performance

Global-Application
Performance

SD-WAN Interfaces

Audio MOS Score

The bandwidth of the SD-WAN network over time. This widget displays a line chart of the
sent/received rate (bps) in the selected time period for SD-WAN members interfaces.

The SD-WAN performance status comparison with interfaces. Mousing over the scatter
chart displays the status for health checks and member interface in a tooltip. The colors (red,
orange, yellow, and green) indicate the different percentage of a member's interface or
health check. Click on a scatter chart to view additional details.

The SD-WAN rule traffic utilization by interface and application.

The share of bandwidth utilization by application for each WAN link.

The top SD-WAN SLA issues.

This widget dynamically creates a child-widget for each health check where a line chart of
latency, jitter, and packet loss in the selected time period for SD-WAN interfaces is
displayed.

This widget displays a table chart for SD-WAN event logs which have a level higher than
notice (warning, error, etc.) within the selected time period.

The total bandwidth from all applications as well as the bandwidth per-SD-WAN interface.
This widget can be viewed in a sanky chart or table chart format.

The performance for the selected application based on chosen metric. You can select an
application in the widget's Application dropdown menu.

Latency, Jitter, Packet Loss, and Bandwidth metrics are available.

The global application performance for the selected metric.
Latency, Jitter, and Packet Loss metrics are available.

The information for SD-WAN interfaces and ADVPN shortcut interfaces.

Latency, Jitter, and Packet Loss metrics are available.

The MOS score by interface. Mousing over the chart displays a summary of the MOS score
and VolP quality at that point.

The interface must have a performance SLA with MOS enabled to display in the chart.

To update the Refresh Interval, click the settings icon at the top of the widget, and then select a
value from the dropdown.

To filter a chart, click a key in the legend.

R

SD-WAN Summary

SD-WAN Summary monitor includes the following widgets:

SD-WAN Health Overview The SD-WAN devices' status.
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Top SD-WAN SLA Issues The SD-WAN SLA issues.

Top SD-WANApplications The SD-WAN devices' top applications.

SD-WAN Top Device Throughput The SD-WAN devices' throughput.

Top SD-WAN Talkers
Audio MOS Score

The SD-WAN devices' top talkers.
The MOS score across all SD-WAN devices.

Traffic Shaping Monitor

This dashboard monitors the traffic shaping information in FortiGate logs. It includes the following widgets:

Bandwidth

Top Applications
and Traffic Shaping

Dropped Bytes
Over Time Per
Shaper

ZTNA

The bandwidth of traffic shapers over time. Mouse over the line chart to display the bandwidth
at a specific time.

The total traffic by application. Mouse over the stacked bar chart to display a summary of
application traffic and dropped bytes for that application. Click a bar in the chart to display the
user information for that application in a table view. This view includes a summary of the
application traffic, including the number of sessions and bytes (sent/received) by user.

This widget displays the top five applications by default.

The total dropped bytes per shaper. Mouse over the line chart to display a summary of
dropped bytes per shaper at a specific time. Click a shaper in the legend to hide/unhide it in
the line chart. Greyed-out shapers in the legend are hidden in the line chart.

Click More details to display the traffic shaping policy hits information in a table view. This
table includes the total sessions and bytes (sent/received) by shaping policy.

ZTNA includes the following widgets:

Statistics

Connection Attempts

Devices
ZTNA Device Tags

User Overview

The number of blocked sessions, users, and devices.
The number of connection attempts allowed and blocked.
The number of devices connected and blocked.

The number of ZTNA device tags.

The number of high risk users, including a summary of the top high risk users.

Known Devices with Failed The number of known devices with a failed posture check by user.

Posture Check

Bandwidth Trends

Bandwidth trends.

Top Users by Connections Top users by number of connections, allowed and blocked.

Private Apps Access

A list of private apps, including their number of allowed and blocked connections.

Public Cloud Business Apps A list of public cloud business apps, including their number of allowed and blocked

Access

connections.
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Users

Policy Overview

The number of users connected and blocked.

The number of violated policies, including a summary of the top violated policies.

Private & Public Applications Private and public app access failures.
Access Failure History

CASB Apps Access

A list of CASB apps, including their number of allowed and blocked sessions.

FortiSandbox Detections

FortiSandbox Detections includes the following widgets:

FortiSandbox
Detection

FortiSandbox -
Scanning Statistics

FortiSandbox - Top
Malicious

& Suspicious File
Users

FortiMail

FortiSandbox detection detail, including date, file name, end user, destination IP, analysis,
action, and service.

The number of files detected by FortiSandbox by type: Malicious, Suspicious, Clean, and
Others.

Users or IP addresses that have the highest number of malicious and suspicious files
detected by FortiSandbox.

FortiMail includes the following widgets:

Statistics History

Top Sender by
Categories

Top Recipient by
Categories

Threat Statistics

The statistics history from FortiMail that displays the summary of total messages and spam in
the selected time period.

Place your mouse over a line in the chart to view a tooltip which includes the total messages
and total spam for the corresponding date and time.

The top email, virus, and spam senders in the selected time period.

Place your mouse over a bar in the graph to view a tooltip which includes the sender, count,
size, virus count, and spam count.

This widget may be viewed by Count, Size, Virus Count, and Spam Count.

The top email, virus, and spam recipients in the selected time period.

Place your mouse over a bar in the graph to view a tooltip which includes the recipient, count,
size, virus count, and spam count.

This widget may be viewed by Count, Size, Virus Count, and Spam Count.

The summary of spam and virus mail in the selected time period.

Place your mouse over a bar in the graph to view a tooltip which includes the date/time,
classifier, and count.

This widget may be viewed by Count and Size.

This widget can be also be displayed as a donut chart which includes charts for total mail,
virus mail, and spam mail.
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Mail Statistics

Outbreak Statistics
(FortiSandbox)

Statistics Summary

Endpoints

The summary of email messages where the FortiMail detected viruses, spam, or neither in the
selected time period.

Place your mouse over a bar in the graph to view a tooltip which includes the date/time,
classifier, and count.

This widget may be viewed by Count, Size, Scan Speed, and Transfer Speed.

The summary of the number of email messages that the FortiSandbox unit is scanning in the
selected time period. Email messages are tracked as either clean, containing a malicious file,
or containing a malicious URL.

Place your mouse over a bar in the graph to view a tooltip which includes the date/time, clean,
malicious file, and malicious URL.

This widget requires a FortiSandbox.
The summary of spam, viruses, and not spam in the selected time period, including the

classifier details per category, the corresponding total number of every classifier, the subtotal
number, the subtotal percentage of every category, and the total number of all emails.

Endpoints includes the following widgets:

Top Endpoint
Vulnerabilities

Top Endpoint
Vulnerabilities
(FortiClient)

Top Endpoint
Devices with
Vulnerabilities

Top Endpoint
Devices with
Vulnerabilities

(FortiClient)

User Vulnerabilities
Summary

All Endpoints

All Endpoints
(FortiClient)

Top Endpoint
Threats

Top Endpoints
Applications

Vulnerability information about FortiClient endpoints including vulnerability name and CVE ID.

Vulnerability information about FortiClient endpoints including vulnerability name and CVE ID.
Only available in a Fabric ADOM.

Vulnerability information about FortiClient endpoints including source IP address and device.

Vulnerability information about FortiClient endpoints including source IP address and device.
Only available in a Fabric ADOM.

User vulnerabilities summary.

All endpoints.

All endpoints.

Top threats from all endpoints.

Top applications from all endpoints.
Only available in a Fabric ADOM.
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Fabric State of Security

Security Fabric includes the following widgets.

This information for this dashboard is available after you create a Security Fabric group in FortiGate and add it in
FortiAnalyzer. The Security Fabric can be selected in the settings options for each widget.

Security Fabric
Rating Report

Security Fabric
Score

Security Fabric
Topology

Best Practices
Overview

VPN

A report showing the security rating details of connected Security Fabric devices. Click a
milestone to drill down and hover the cursor over data points to see more details.

The current and historical Security Fabric scores. The Historical Security Fabric Scores pane
displays your Security Fabric score over time and how it compares to the industry average
and the industry score range. You can hide the Historical Security Fabric Scores pane.

A topology map showing the logical structure of connected Security Fabric devices.

Overview of the device best practices across regions of North America, Latin America, EMEA,
and APAC.

VPN includes the following widgets:

Top Dialup VPN
VPN Site-to-Site

WiFi

The users accessing the network using SSL or IPsec over a VPN tunnel.

The names of VPN tunnels with Internet protocol security (IPsec) that are accessing the
network.

WiFi includes the following widgets:

Authorized APs

Top Rogue APs
Top SSID
Top SSID Over

Time by Bandwidth
WiFi Clients

The names of authorized WiFi access points on the network.

The top SSID (service set identifiers) of unauthorized WiFi access points on the network.
Hover the cursor over data points to see the SSID and total live time.

The top SSID (service set identifiers) of authorized WiFi access points on the network. Hover
the cursor over data points to see the SSID and bytes (sent and received).

The historical SSID (service set identifiers) traffic of authorized WiFi access points on the
network.

The top WiFi access points on the network by bandwidth/sessions.

FortiClient Software Inventory

FortiClient Software includes the following widget:
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FortiClient

Software Inventory

loT

The total number of apps installed, top apps, new apps installed, top apps by installs, and top
hosts by number of apps.

10T includes the following widget:

loT Inventory

The total number of IoT devices installed.

This includes summaries for the new loT apps installed, top loT apps, top loT
users, and top loT by number of hosts.

Threat (FortiClient)

Threat (FortiClient) includes the following widgets:

Threat

The top threats to your network from risk applications, intrusion alerts, malicious websites,
and malware/botnets.

Only visible in a Fabric ADOM.

Applications & Websites (FortiClient)

Applications & Websites (FortiClient) includes the following widgets:

Application

Website

The top applications used on the network, including application name, risk level, category,
sessions (blocked and allowed), and bytes (sent and received).

Only available in a Fabric ADOM.

Top website domains from recent traffic.
Only available in a Fabric ADOM.

Endpoints (FortiClient)

Endpoints (FortiClient) includes the following widgets:

Top Endpoint
Vulnerabilities
(FortiClient)

Endpoint Devices

All Endpoints
(FortiClient)

Vulnerability information about FortiClient endpoints including vulnerability name and CVE ID.
Only available in a Fabric ADOM.

Information about FortiClient endpoints including source IP address, device, and
vulnerabilities.

Only available in a Fabric ADOM.

All endpoints.
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Traffic (FortiDDOS)

Traffic (FortibDOS) includes the following widgets:

Top Source Top source |IP addresses from recent traffic.
(FortiDDoS) Only available in a Fabric ADOM.

Top Destination Top destination IP addresses from recent traffic.
(FortiDDoS) Only available in a Fabric ADOM.

Top Type Top types from recent traffic.

(FortiDDoS) Only available in a Fabric ADOM.

Traffic (FortiFirewall)

Traffic (FortiFirewall) includes the following widgets:
Top Sources The highest network traffic by source IP address and interface, sessions (blocked and
allowed), threat score (blocked and allowed), and bandwidth (sent and received).

Top The historical network traffic by country/region, sessions, bandwidth, or threat score.
Country/Region

Top Policy Hits Top policy hits from recent traffic.

Top Destinations Top destinations from recent traffic by bandwidth or sessions.
Traffic Over Time The historical destinations from recent traffic.

by Sessions

Policy Hits Over The historical policy hits from recent traffic.

Time by Bandwidth

User Data Flow Bandwidth breakdown of top user destination country/region or application usage.

VPN (FortiFirewall)

VPN (FortiFirewall) includes the following widgets:

Top Dialup VPN The users accessing the network using SSL or IPsec over a VPN tunnel.
VPN Site-to-Site The names of VPN tunnels with Internet protocol security (IPsec) that are accessing the
network.
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Local System Performance

This dashboard monitors the system performance of the FortiAnalyzer unit running FortiView. It includes the following
widgets:

Multi Core CPU
Usage

Insert Rate vs
Receive Rate

CPU & Memory
Usage

Disk 1/0

Receive Rate vs
Forwarding Rate

Resource Usage
Average

Resource Usage
Peak

Failed
Authentication
Attempts

System Events

Admin Logins

The usage status of a multi-core CPU.

The number of logs received vs the number of logs actively inserted into the database,
including the maximum and minimum rates.

* Receive rate: how many logs are being received.

 Insertrate: how many logs are being actively inserted into the database.
If the insert rate is higher than the log receive rate, then the database is rebuilding. The lag is
the number of logs waiting to be inserted.

The usage status of the CPU and memory.

The disk Transaction Rate (1/Os per second), Throughput (KB/s), or Utilization (%). The
Transaction Rate and Throughput graphs also show the maximum and minimum disk activity.

The number of logs received vs the number of logs forwarded out, including the maximum and
minimum rates.

¢ Receive rate: how many logs are being received.

¢ Forward rate: how many logs are being forwarded out.

Overview of average resource usage history across all devices.

Overview of peak resource usage history across all devices.

Top unauthorized connections from recent traffic.

Top system events from recent traffic.

Top admin logins from recent traffic.

Global Threat Research

Global Threat Research includes the following widgets:

Worldwide Threat
Prevalence By
Industry - Today
(UTC)

The top threats globally by industry based on UTC. The threat map can be viewed by Virus,
IPS, Botnet, and Application. The widget is available as a chord chart or map.

By default, the threat map displays information from accross all industries. You can change
which industries are included in the chart by clicking the All Industries dropdown and removing
a check mark from any industries you want to exclude.

Global Threat Research data is from FortiGuard and not from FortiGate.
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Local Threat Research

Local Threat Research includes the following widgets:

Local Threat
Prevalence

The top threats based on the current ADOM. The threat map can be viewed by Virus, IPS,
Botnet, and Application.

Hover your mouse over a datapoint in the chord chart to view additional details.
Local Threat Research data is from FortiGuard and not from FortiGate.

Using a Monitor dashboard

FortiView Monitor dashboards contain widgets that provide network and security information. Use the controls in the
dashboard toolbar to work with a dashboard.

Edit Layout

Devices

Time Period

Dark Mode

Refresh

Hide Side-menu or
Show Side-menu

Add, remove, resize, or move widgets on a predefined dashboard.

Select the devices to include in the widget data.
The device list will also include a Security Fabric if available.

To select a Security Fabric, you need to first create a Security Fabric group in FortiGate and
add the Security Fabric group in FortiAnalyzer.

Select a time period from the dropdown menu, or set a custom time period.

Enable/disable dark mode. Dark mode shows a black background for the widgets in the
dashboard.

Refresh the data in the widgets.

Using the main toolbar, you can hide or show the tree menu on the left. In a typical SOC
environment, the side menu is hidden and dashboards are displayed in full screen mode.

Use the controls in the widget title bar to work with widgets.

Settings icon

View different chart
types

Hide or show a
data type

View more details

View a narrower
time period

Zoom in and out

Change the settings of the widget. Widgets have settings applicable to that widget, such as
how many of the top items to display, Time Period, Refresh Interval, and Chart Type.

Some widget settings let you choose different chart types such as the Disk I/O and Top
Countries widget. You can add these widgets multiple times and set each widget to show a
different chart type.

For widgets that show different data types, click a data type in the title bar to hide or show that

data type in the graph.

For example, in the Insert Rate vs Receive Rate widget, click Receive Rate or Insert Rate in
the title bar to hide or show that data. In the Disk I/O widget, click Read or Write in the title bar
to hide or show that data type.

Hover the cursor over a widget's data points to see more details.

Some widgets have buttons below the graph. Click and drag the buttons to view a narrower
time period.

For widgets that show information on a map such as the Top Threat Destinations widget, use
the scroll wheel to change the zoom level. Click and drag the map to view a different area.
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Customizing a Monitor dashboard

You can add any widget to a custom or predefined dashboard. You can also move, resize, or delete widgets. You cannot
rename or delete a predefined dashboard. To reset a predefined dashboard to its default settings, click Dashboard
settings icon > Reset. The dashboard settings icon is visible when you mouse-over the dashboard in the tree menu.

To create a dashboard:

1. In FortiView > Monitor, click the plus (+) at the bottom of the tree menu.

Specify the Name and whether you want to create a blank dashboard or use a template.

If you select From Template, specify which predefined dashboard you want to use as a template.
Click OK. The new dashboard appears in the tree menu.

4. Select widgets to include on the dashboard, and click Save Changes.

g

ol

To display Security Fabric in Monitor:

1. Create a Security Fabric in FortiGate.

2. Addthe Security Fabric in FortiAnalyzer.

3. Goto FortiView > Monitors.

4. Selectthe Fabric State of Security dashboard.

5. Select the Security Fabric from the Devices menu.

To add a widget:

1. Select the predefined or custom dashboard where you want to add a widget.

2. Click Add Widget to see a list of available widgets. Select the widget(s) you would like to add.
Some widgets can only be added when their corresponding log type is enabled in the ADOM, for example, the Top
Threats widget requires that Traffic logs are enabled. Widgets that cannot be added appear in gray and include an
information icon indicating what logs must be present in the ADOM before the widget can be added to the

dashboard.
Number of widgets: 1
Q
This chart requires following Log
® Threats 10 be enabled:Traffic
[1fi Threat Map [1fi Top Threat Destinations
|ul Top Threats |# Top Threats by Weight & Count

[Z] Top Virus Incidents over Time

3. When you have finished adding widgets, click Save Changes to close the Add Widget pane.

Creating custom widgets

Custom widgets can be created and added to custom dashboards in FortiView > Monitor.
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To create a custom widget:

1. Goto FortiView > Monitor.

2. Goto a previously configured custom dashboard and click Add Widget.

For information on creating and managing dashboards, see Customizing a Monitor dashboard on page 84
3. Scroll to the Custom Widgets field and click Add Widget.

The Custom Widget Dashboard opens.

4. Configure the following information for your widget.

Custom Widget Dashboard b 4

Bandwidth
65.2 GB 4

Name

Data Source

Time Frame

Chart Type

X Axis

Name ‘custom—widgetz

Data Source s0C-sources

Time Frame ® Last 1 Hour v |19:40 - 20:40

Chart Type Bar Chart
X Axis Source

Y Axis Bandwidth
Show Top 10

[ Proden | e

Enter a name for the widget.

Select a data source for the widget. The following data sources are available:
e soc-sources
* soc-destinations
¢ soc-threats
¢ soc-sdwan-stats

Select the time frame.

You can specify a custom time frame by clicking Custom..., choosing the start and end
date, and clicking Apply.

Choose how the data is presented in the widget from one of the following options:
e Bar Chart
e Line Chart
* Pie Chart
e Donut Chart

Select the source type for the X axis. The sources available for selection depend on the
data source selected.
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X Axis is only available when the chart type is Bar or Line.

Y Axis Select the source type for the Y axis. The sources available for selection depend on the
data source selected.
Y Axis is only available when the chart type is Bar or Line.

Category Select the data category. The categories available for selection depend on the data
source selected.
Category is only available when the chart type is Pie or Donut.

Value Select the data value. The values available for selection depend on the data source
selected.
Value is only available when the chart type is Pie or Donut.

Show Top Select the number of results that are displayed in the widget.
Options include the top 10, 20, 50, and 100 results.

5. Click Preview to preview the widget based on the information selected.

6. Click Create to save your changes.
After the widget has been created, you can select it in the Add Widget window to add it to your dashboard.
For information on managing your dashboard, see Using a Monitor dashboard on page 83.

To edit a custom widget:

1. Inany custom dashboard, select Add Widget.
2. Right-click on the custom widget that you want to edit, and click Edit
3. Edit the widget's settings, and click Update.

To delete a custom widget:

1. Inany custom dashboard, select Add Widget.
2. Right-click on the custom widget that you want to delete, and click Delete.

Enabling and disabling FortiView

The FortiAnalyzer FortiView module can be disabled for performance tuning through the CLI. When disabled, the GUI
will hide FortiView and stop background processing for this feature.

To disable FortiView in the CLI:

config system global
set disable-module fortiview-noc
end

To enable FortiView in the CLI:

config system global
unset disable-module
end
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Disabling FortiView will cause the FortiAnalyzer to return the following error message when
the FortiGate attempts to retrieve FortiAnalyzer data: Server Error: FortiView\/NOC
function is disabled on FortiAnalyzer.

The FortiGate GUI displays the message: Failed to retrieve FortiView data.
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Log View and Log Quota Management

You can view log information by device or by log group.
When rebuilding the SQL database, Log View is not available until the rebuild is complete.
Click the Show Progress link in the message to view the status of the SQL rebuild.

When ADOM s are enabled, each ADOM has its own information displayed in Log View.

Log View can display the real-time log or historical (Analytics) logs.
Log Browse can display logs from both the current, active log file and any compressed log files.

For more information, see Analytics and Archive logs on page 35.

Types of logs collected for each device

FortiAnalyzer can collect logs from the following device types: FortiAnalyzer, FortiAuthenticator, FortiCache,
FortiCarrier, FortiClient, FortiDDoS, FortiDeceptor, FortiEDR, FortiGate, Fortilsolator, FortiMail, FortiManager,
FortiNAC, FortiNDR (formerly FortiAl), FortiProxy, FortiSandbox, FortiSOAR, FortiWeb, and Syslog servers. Following is
a description of the types of logs FortiAnalyzer collects from each type of device:

Device Type Log Type
Fabric All
FortiAnalyzer Event, Application

FortiAuthenticator Event

FortiGate Traffic

Security: Antivirus, Intrusion Prevention, Application Control, Web Filter, File Filter, DNS,
Data Leak Prevention, Email Filter, Web Application Firewall, Vulnerability Scan, VoIP,
FortiClient

Event: Endpoint, HA, Compliance, System, Router, VPN, User, WAN Opt. & Cache, WiFi

) : ’, File Filter logs are sent when the File Filter sensor is enabled in the
q FortiOS Web Filter profile. You can enable the File Filter sensor in
- FortiOS at Security Profiles > Web Filters.
FortiCarrier Traffic, Event, GTP
FortiCache Traffic, Event, Antivirus, Web Filter
FortiClient Traffic, Event, Vulnerability Scan
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FortiDDoS Event, Intrusion Prevention
FortiDeceptor Event
FortiEDR Event: Audit, System Event, Security Event
Fortilsolator Traffic, Event
FortiMail History, Event, Antivirus, Email Filter
iy

Event, Antivirus, or Email Filter logs from FortiMail, you can click on the

sq, FortiMail logs support cross-log functionality. When viewing History,
- Session ID to see correlated logs.

When VDOMs are used to divide FortiMail into two or more virtual units,
Y cross-log searches display correlated log data from FortiMail's VDOMs,
‘Q' including those assigned to different ADOMs. VDOM results are
|| included only when performing the cross-log search through FortiMail's
- History log view, but results include correlated data for all available log
types (History, Events, Antivirus, and Email Filter).

FortiManager Event
FortiNAC Event
FortiNDR Event, NDR

Attack: Attack Chain, Malware
FortiProxy Traffic, Event, Antivirus, Web Filter
FortiSandbox Malware, Network Alerts
FortiSOAR Event
FortiWeb Event, Intrusion Prevention, Traffic

>ﬂ You can view a subset of FortiWEB packet logs which contain additional

HTTP request information. See Viewing message details on page 91.

Syslog Generic
K ' ’, The logs displayed on your FortiAnalyzer depends on the device type logging to it and the
q enabled features.
- ADOMs must be enabled to support non-FortiGate logging. In a Security Fabric ADOM, all

device logs are displayed.
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Traffic logs

Traffic logs record the traffic flowing through your FortiGate unit. Since traffic needs firewall policies to properly flow
through FortiGate, this type of logging is also called firewall policy logging. Firewall policies control all traffic attempting to
pass through the FortiGate unit, between FortiGate interfaces, zones, and VLAN sub-interfaces.

ZTNA logs: FortiAnalyzer syncs unified ZTNA logs with FortiGate. ZTNA logs are a sub-type of FortiGate traffic logs,
and can be viewed in Log View > FortiGate > Traffic. You can filter for ZTNA logs using the sub-type filter and optionally
create a custom view for ZTNA logs. See Custom views on page 98.

Security logs

Security logs (FortiGate) record all antivirus, web filtering, file filtering, application control, intrusion prevention, email
filtering, data leak prevention, vulnerability scan, and VolP activity on your managed devices.

DNS logs

DNS logs (FortiGate) record the DNS activity on your managed devices.

Event logs

Event logs record administration management and Fortinet device system activity, such as when a configuration
changes, or admin login or HA events occur. Event logs are important because they record Fortinet device system
activity which provides valuable information about how your Fortinet unit is performing. FortiGate event logs includes
System, Router, VPN, User, and WiFi menu objects to provide you with more granularity when viewing and searching
log data.

Application Logs

Application logs record playbook and incident activity on FortiAnalyzer. Logs are generated and stored separately for
each ADOM. Application logs can only be viewed on the local FortiAnalyzer.

Fabric (SIEM) Logs

Fabric logs are a licensed feature that enables FortiAnalyzer's SIEM capabilities to parse, normalize, and correlate logs
from Fortinet products as well as security event logs of Windows and Linux hosts (with Fabric Agent integration). When
licensed, parsing is predefined by FortiAnalyzer and does not require manual configuration by administrators.

\{ A SIEM database is automatically created for Fabric ADOMs once a SIEM license has been

applied to FortiAnalyzer and Fabric devices begin logging. Past logs and imported log files are
notincluded in the SIEM database.
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Log messages

You can view log information by device or by log group.

Viewing the log message list of a specific log type

You can find FortiMail and FortiWeb logs in their default ADOMs.

To view the log message list:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type from the tree menu.
The corresponding log messages list is displayed.

Viewing message details

To view message details:

1. Double-click a message in the message list.
The details pane is displayed to the right of the message list, with the fields categorized in tree view.

© A AllDevices~ (@ Last1Hour~ 01:35:47 To 02:35:46

¥ Date/Time  Device ID

‘ Add Filter

#

1 02:35:29
2 02:35:29
3 02:35:29
4 02:35:29
5

3 02:

7 02:35:29
8 02:35:29
9 02:35:29
10 02:35:29
11 02:35:29
12 02:35:29
13 02:35:29
14 02:35:29
15 02:35:29
16 02:35:29
17 02:35:29

FGT1KC0000000...
FGT1KC0000000..
FGT1KC0000000...

FGT1KCO000000..

FGT1KC0000000..

FGT1KC0000000...
FGT1KC0000000...
FGT1KCO000000...

FGT1KCO0000000..

FGT1KC0000000...
FGT1KC0000000..
FGT1KC0000000...

FGT1KCO000000..

FGT1KCO0000000...

FGT1KC0000000..

FGT1KC0000000...

£= Total logs for analytics: 8 hours. More

NS N O S S O R R S SR

50

Source

172.18.4.112

lliao (§%172.28.3.133)
£1§172.16.175.133
=172.184.112

3172.16.175.133
=172.18.4.112
£1§172.16.175.133
17216175133
5172.184.112
172.18.4.112
172.16.175.133
172.18.4.112
£1:10.2.60.65
9172.184.112
310.2.60.65
192.168.2.115

+ |Items per page

User Destination IP
172.18.4.108
B5157.55.56.170
172.18.4.108
172.18.4.108
£=233.105.162
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
1+1208.91.112.53
172.18.4.108
1#1208.91.112.52
10.2.60.58

;2345

Service
HTTPS
udp/40032
HTTPS
HTTPS

HTTPS
HTTPS
HTTPS
HTTPS
HTTPS
HTTPS
HTTPS
HTTPS
DNS

HTTPS
DNS

RSH

~ 0.041 Second

Application
HTTPS  ~
udp/4003;
HTTPS
HTTPS

=--Security

1PS Count.
Level
Threat Score

+-General
+-Source
+}- Destination
=--Action

Action
Firewall Action
Policy ID
Security Action
Threat

1 Application
+-Data
#-Threat

= Type

SubType
Type

+-Others

oIrs
v dose
2

© block
8192

forward
traffic

You can display the log details pane below the message list by clicking the Bottom icon in the log details pane.
When the log details pane is displayed below the message list, you can move it to the right of the log message list by
clicking the Right icon. This is sometimes referred to as docking the pane to the bottom or right of the screen.
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The log details pane provides shortcuts for adding filters and for showing or hiding a column. Right-click a log field to
select an option.

ox

-} Security
Ll Level information
+-General
--Source
i ! Agent Debian

-~ Device ID FG100D3G13805309

- Device Name FG100D3G13805309

- Source 172.28.3.15

- Source IP 172.28.3.15

gurce [nterface v e

@, search "Source Interface = FMG-GUI-Team"

L @), search "Source Interface '= FMG-GUI-Team”
A

=+ add "Source Interface” to column settings

. Firewall Action analytics
. Policy ID 20
+-Application
- Type
] ; Sub Type virus
.. Type utm
+-Others
\‘ ! ’I
q If the log message contains UTM logs, you can click the UTM log icon in the log details pane to
- open the UTM log view window.
\‘ ! 'l
9 If the log message contains IPS signature information, you can click the IPS signature link
|| under Attack Name to view the IPS Signature details in a dialog window.

To view FortiWEB packet logs:

1. Inthe Type column, click Attack log.
2. Double-click a message in the list to open the log details pane.

3. Inthe Data field, click the Device icon. The View Attack Content dialog displays a subset of FortiWEB's packet log
(headers, arguments, and a truncated HTTP body). The maximum size of the packet log is 8 KB.

- X
—i-logDetails
Action Alert
. Back End Service unknown
.. Bot Detection Information none
\_.Cipher Suite none
i..Client Device ID none
| i..Data &J I
: Date/Time r_)v;r:;ru 59
ﬂ The Device icon is also available in the Data column. To display the column, click Column
I Settings, and select Data from the dropdown.
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Customizing displayed columns
The columns displayed in the log message list can be customized and reordered as needed.

To customize what columns to display:

1. Inthe toolbar of the log message list view, click Column Settings and select a column to hide or display.
The available columns vary depending on the device and log type.
2. Toreset to the default columns, click Reset to Default.

3. To add other columns, click More Columns. In the Column Settings dialog, select the columns to show or hide.
4. Click OK.
\‘ ! 'l
9 You can also add or remove a log field column in the log details pane, by right-clicking a
- log field and selecting Add [log field name] or Remove [log field name].

To change the order of the displayed columns:

Place the cursor in the column title and move a column by drag and drop.

Customizing default columns

In Log View, you can select the columns that are displayed as the default by clicking Save as Defaultin the Column
Settings dialog. See Customizing displayed columns on page 93.

Column Settings

[Ipearch

B Date/Time

B Device ID
Source

O Application Category

O Application Control List

[ anslication 1D

Save as Default

Customizing the default column view can only be done on a Super_User administrator profile.
Default column customization is applied per devtype/logtype across all ADOMs.
The GUI displays columns based on the following order of priority:

1. Displays the user’s column customizations (if defined).
2. Displays the default columns set by the Super_User administrator (if defined).
3. Displays the system default columns.
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Customized default column configuration is preserved during upgrades.

x To reset default columns to the system default, deselect all columns from the Column Settings

selection menu and then select Set as Default.

Filtering messages

You can apply filters to the message list. Filters are not case-sensitive by default. If available, select Tools > Case
Sensitive Search to create case-sensitive filters.

Filtering messages using filters in the toolbar

1. Go to the view you want.

Filter mode search Click Add Filter and select a filter from the dropdown list, then type a value.
Only displayed columns are available in the dropdown list. You can use search
operators in regular search.

Switching between filter At the right end of the Add Filter box, click the Switch to text mode icon o to
mode search and text mode switch to a text mode search. When in text mode search, click the Switch to
search filter mode icon T to switch to a filter mode search.

Text mode search In text mode search, enter the search criteria (log field names and values).

Search operators and syntax [ available, click & at the right end of the Add Filter box to view search
operators and syntax. See also Filter search operators and syntax on page 95.

CLI string “freestyle” search  Searches the string within the indexed fields configured using the CLI
command: config ts-index-field

For example, if the indexed fields have been configured using these CLI
commands:
config system sqgl
config ts-index-field
edit "FGT-traffic"
set value "app,dstip,proto,service,srcip,user,utmaction"
next
end
end
Then if you type “Skype” in the Add Filter box, FortiAnalyzer searches for
“Skype” within these indexed fields:
app,dstip,proto, service, srcip,user and utmaction.

You can combine freestyle search with other search methods, for example:
Skype user=David

2. Inthetoolbar, make other selections such as devices, time period, which columns to display, etc.

name, including Source Object and Destination Object.See the

\‘é', UUID logging must be enabled in FortiGate/FortiOS to filter FortiGate traffic logs by object
3 FortiGate/FortiOS Administration Guide for more information about UUID logging.
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Filtering messages using the right-click menu

In a log message list, right-click an entry and select a filter criterion. The search criterion with a & icon returns entries
matching the filter values, while the search criterion with a & icon returns entries that do not match the filter values.

Depending on the column in which your cursor is placed when you right-click, Log View uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

NV To see log field name of a filter/column, right-click the column of a log entry and select a
‘Q' context-sensitive filter. The Add Filter box shows log field name.
- Context-sensitive filters are available for each log field in the log details pane. See Viewing

message details on page 91.

Filtering messages using smart action filters

For Log View windows that have an Action column, the Action column displays smart information according to policy (log
field action) and utmaction (UTM profile action).

The Action column displays a green checkmark Accept icon when both policy and UTM profile allow the traffic to pass
through, that is, both the log field action and UTM profile action specify allow to this traffic.

The Action column displays a red X Deny icon and the reason when either the log field action or UTM profile action deny
the traffic.

If the traffic is denied due to policy, the deny reason is based on the policy log field action.

If the traffic is denied due to UTM profile, the deny reason is based on the FortiView threattype from craction.
craction shows which type of threat triggered the UTM action. The threattype, craction, and crscore fields are
configured in FortiGate in Log & Report. For more information, see the FortiOS - Log Message Reference in the Fortinet
Document Library.

Afilter applied to the Action column is always a smart action filter.

The smart action filter uses the FortiGate UTM profile to determine what the Action column
displays. If the FortiGate UTM profile has set an action to allow, then the Action column will

O ! ’, display that line with a green Accept icon, even if the craction field defines that trafficas a
q threat. The green Accept icon does not display any explanation.
- In the scenario where the craction field defines the traffic as a threat but the FortiGate UTM

profile has set an action to allow, that line in the Log View Action column displays a green
Accepticon. The green Accepticon does not display any explanation.

Filter search operators and syntax

Operators or symbols Syntax

And Find log entries containing all the search terms. Connect the terms with a space
character, or “and”. Examples:
1. user=henry group=sales
2. user=henry and group=sales
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Operators or symbols Syntax

Or Find log entries containing any of the search terms. Separate the terms with “or”
oracomma “,”. Examples:
1. user=henry or srcip=10.1.0.15
2. user=henry,linda

Not Find log entries that do NOT contain the search terms. Add “-” before the field
name. Example:

-user=henry

> < Find log entries greater than or less than a value, or within a range. This operator
only applies to integer fields. Example:
policyid>1 and policyid<10

IP subnet, range, subnet list Find log entries within a certain IP subnet, IP range, subnet list, or subnet group.
search Examples:

1. srcip=192.168.1.0/24

2. srcip=10.1.0.1-10.1.0.254

3. srcip=SubnetGrp Name A

4. srcip=Subnet Name A

Wildcard search You can use wildcard searches for all field types. Examples:
1. srcip=192.168.1.*
2. policyid=1~*

3. user=*

Ay
b [ 4
? Log View also supports the regex (regular expresion) syntax.

Filtering FortiClient log messages in FortiGate traffic logs

For FortiClient endpoints registered to FortiGate devices, you can filter log messages in FortiGate traffic log files that are
triggered by FortiClient.

To Filter FortiClient log messages:

Go to Log View > FortiGate >Traffic.

In the Add Filter box, type fct_devid=*. Alist of FortiGate traffic logs triggered by FortiClient is displayed.
In the message log list, select a FortiGate traffic log to view the details in the bottom pane.

Click the FortiClient tab, and double-click a FortiClient traffic log to see details.

The FortiClient tab is available only when the FortiGate traffic logs reference FortiClient traffic logs.

o bd-=

Monitoring all types of event logs from FortiGate devices

You can monitor all types of event logs from FortiGate devices in Log View > FortiGate > Event > All Types. This
dashboard displays the total counts for event logs by type, name, and level. You can filter the dashboard by FortiGate
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device(s) and time frame for the event logs.

The Total Events widget on this dashboard displays a line chart of event logs by level. You can hover your cursor over
the line chart to display a summary of the count and time at that point.

The other widgets on this dashboard list the event names for the displayed event types. These widgets can be toggled
on/off from the Toggle Widgets dropdown. By clicking an event name in the widget, you can open a list view of those
event logs filtered by the devices and time frame you selected on the dashboard.

Toggle Widgets v All_FortiGate v @ Last4 Hours v 2022-02-10 13:24:00 - 2022-02-10 17:24:00

Total Events

- information <0~ notice -0« warning -0~ errer

2022/02/10 16:20
@ information 49 |-
® notice 309

warning 45 |

error 0

A V/\v,\'ﬂ e N ”?‘V/\vb"_‘

System Events % VPN Events "
View general system events, View events relating to VPN,

Event Name Level Count Event Name Level Count
System performance statistics notice 240 | IPsec tunnel statistics notice 288 ]
NTP server status changes to reachable notice 198  mmm Progress IPsec phase 2 notice 168 —
er status changes to unreachable notice 195 | IPsec SA installed notice 108 |
Files dropped due to poor network connection warning 88 ] Negotiate IPs notice 108 —
DHCP statistics information 88 | Negotiate IPsec ¢ e notice 54 [
FortiGate update succeeded natice 80 - Progress IPsec phase 1 notice 24 -
DHCP client lease granted information 35 ™ IPsec phase 1 SA deleted notice 12 X
Scanunit reloaded AV Database notice 27 [ ] SSLVPN alert error 10 1
notice 9 1 SSLVPN exit error error 7 1
= * , SSLVPNnewconnection information 1 |
@ SD-WAN Events x E User Events x
View events relating to SD-WAN, View events relating to users.
Event Name Level Count Event Name Level Count
SDWAN status notice 5817 L] No record found.

Viewing historical and real-time logs

By default, Log View displays historical logs. Custom View and Chart Builder are only available in historical log view.
To view real-time logs, in the log message list view toolbar, click Tools > Real-time Log.

To switch back to historical log view, click Tools > Historical Log.

Viewing raw and formatted logs

By default, Log View displays formatted logs. The log view you select affects available view options. You cannot
customize columns when viewing raw logs.

To view raw logs, in the log message list view toolbar, click Tools > Display Raw.
To switch back to formatted log view, click Tools > Formatted Log.

For more information about FortiGate raw logs, see the FortiGate Log Message Reference in the Fortinet Document
Library. For more information about raw logs of other devices, see the Log Message Reference for the platform type.
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Custom views

Use Custom View to save the filter setting, device selection, and the time period you have specified.

Custom views can be set as public or private. Public custom views can be viewed by all administrators, whereas private
custom views can only be viewed by the creator. Users cannot make changes to custom views created by other
administrators but can right-click the view and select Save As to copy it.

To create a new custom view:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type.

3. Inthe content pane, customize the log view as needed by adding filters, specifying devices, and/or specifying a time
period.

4. In the toolbar, click the custom view icon.

Save as New Custom View

Name
Log Type Event
Devices All_FortiAnalyzer

Time Period Last 1 Hour

Public
P
fvacy ﬂ Others can see this Custom View

5. Inthe Name field, type a name for the new custom view.
6. Inthe Privacy field, select the custom view visibility.

« Public: Others can view this custom view displayed in Log View > Custom View.

« Private: Only you can see this custom view displayed in Log View > Custom View.
7. Click OK.

To edit a custom view:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.

2. Gotothe Log View > Custom View, and select the custom view to be updated.

3. Inthe toolbar, edit the filter settings.

4. Inthe tree menu, select the menu icon next to your custom view, and select Save.

To rename a custom view:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Gotothe Log View > Custom View.
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3. Inthe tree menu, select the menu icon next to your custom view, and select Rename.
4. Change the name of the custom view, and click OK.

To change the visibility of a custom view:

1. If using ADOMSs, ensure that you are in the correct ADOM.

2. Gotothe Log View > Custom View.

3. Inthe tree menu, select the menu icon next to your custom view, and select Share with Others.
4. Setthe Privacy field to On: Public or Off: Private, and click OK.

Downloading log messages

You can download historical log messages to the management computer as a text or CSV file. You cannot download
real-time log messages.

To download log messages:

If using ADOMs, ensure that you are in the correct ADOM.
Go to Log View, and select a log type.
In the toolbar, click Tools > Download.
In the Download Logs dialog box, configure download options:
« Inthe Log file format dropdown list, select Text or CSV.
« To compress the downloaded file, select Compress With gzip.

« To download only the current log message page, select Current Page. To download all the pages in the log
message list, select All Pages.

5. Click Download.

o bd-=

Creating charts with Chart Builder

Ay
‘?' You can also create charts in Reports > Report Definitions > Chart Library. See Chart library
- on page 236

Log View includes a Chart Builder for you to build custom charts for each type of log messages.

To create charts with Chart Builder:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type.
3. Inthetoolbar, click Tools > Chart Builder.
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4. Inthe Chart Builder dialog box, configure the chart and click Save.

Name

Columns

Group By
Order By
Sort

Show Limit
Device
Time Frame
Query

Preview

Type a name for the chart.

Select which columns of data to include in the chart based on the log
messages that are displayed on the Log View page.

Select how to group data in the chart.

Select how to order data in the chart.

Select a sort order for data in the chart.

Show Limit

Displays the device(s) selected on the Log View page.
Displays the time frame selected on the Log View page.
Displays the query being built.

Displays a preview of the chart.

Once a chart has been created, it can be inserted into a new report. See Reports Editor tab on page 224.

User and endpoint ID log fields

Log information about user and endpoint IDs is available in Log View and can be viewed by configuring these fields as

displayed columns. See Customizing displayed columns on page 93.

UEBA User ID and UEBA Endpoint ID fields with values below 1024 are special cases which are tracked by

FortiAnalyzer's UEBA. See the table below for information on what each value represents.

Value Name

1 EPEU_NOT_IMPL_DEVTYPE

2 EPEU_NOT_IMPL_LOGTYPE

3 EPEU_NO_ENOUGH_INFO

4 EPEU_CANNOT_GET_UID

5 EPEU_INTERNAL_ERROR

6 EPEU_HA BACKUP_ASK_FAIL
7 EPEU_HA REBUILD_THROTTLE
8 EPEU_CLIENT_ASK_FAIL

10 EPEU_NOT_SUPPORT_LOGVER
100 EPEU_ID_LOCAL_HOST

101 EPEU_ID_UNTRACK_IP

FortiAnalyzer 7.2.2 Administration Guide
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Description

EP and EU not implemented for this devtype.
EP and EU not implemented for this logtype.
Not enough information to identify an EP or EU.
Cannot get a UID range (max limit reached).
Internal error (e.g. cannot allocate memory).
Ask primary failed and could not recover.

Prevent too many EP and EU requests during
database rebuilding.

Ask server failed and could not recover.
Log version is not supported.

Local host event, such as alocal host eventin
FortiGate.

IP is public and related interface role is not LAN.
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Value Name Description
102 EPEU_ID_UNTRACK_LOGID Log ID is not identified.
103 EPEU_ID_UNTRACK_TOOMANYIP Too many IPs on one MAC.
104 EPEU_ID_UNTRACK_VPN_IP Do not track VPN IP.
NP When a device has FortiClient installed and FortiAnalyzer is able to retrieve endpoint
‘?' information, all interfaces of this device will belong to a single endpoint with the FCT-UID as
- the key. For devices without FortiClient that have multiple NICs, each interface appears as a

separate endpoint.

) ! /. The User ID and UEBA User ID fields are interchangeable and contain the same information.
q The Endpoint ID and UEBA Endpoint ID fields are interchangeable and contain the same
- information.

Log groups

You can group devices into log groups. You can view FortiView summaries, display logs, generate reports, or create
handlers for a log group. Log groups are virtual so they do not have SQL databases or occupy additional disk space.

Al
S L4
? A maximum of 100 devices can be included in a log group.

When you add a device with VDOM s to a log group, all VDOMs are automatically added.

To create a new log group:

Go to Log View > Log Group.
In the content pane toolbar, click Create New.

In the Create New Log Group dialog box, type a log group name and add devices to the log group.
Click OK.

Ao b=

Log browse

When a log file reaches its maximum size or a scheduled time, FortiAnalyzer rolls the active log file by renaming the file.
The file name is in the form of x10g.N. 1og, where x is a letter indicating the log type, and N is a unique number
corresponding to the time the first log entry was received. For information about setting the maximum file size and log
rolling options, see Device logs on page 338.
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Log Browse displays log files stored for both devices and the FortiAnalyzer itself, and you can log in the compressed
phase of the log workflow.

A\,

To view log files:

In Collector mode, if you want to view the latest log messages, select the latest log file to
display its log messages.

1. GotoLog View > Log Browse
2. Selectalog file, and click Display to open the log file and display the log messages in formatted view.
You can perform all the same actions as with the log message list. See Viewing message details on page 91.

Add Filter (sl B Al Devices ~ (D Last 5 Minutes ~ M Display T Delete & Download ] Import
O # A Device Name Serial Number VDOM Type File Name From To Size(bytes)

o1 FG100D3G00000000 FG100D3G00000000  root Event elog.log 2018-05-3002:0... 2018-05-3013:0... 134,358 (o]
o 2 FG100D3G00000000 FG100D3G00000000 root Traffic tlog.log 2018-05-3002:0... 2018-05-3013:1... 3,924,969

o 3 FG1K2D3100000000 FG1K2D3100000000 root Event elog.log 2018-05-3002:0... 2018-05-3013:0.. 52,663

0 4 FG1K2D3100000000 FG1K2D3100000000 root Traffic tlog.log 2018-05-30 13:0... 2018-05-3013:1.. 71,916,545

0 s FG3K2D3Z00000000 FG3K2D3Z00000000  root Event elog.log 2018-05-3002:0... 2018-05-3013:0.. 8,696

a s FG3K2D3Z00000000 FG3K2D3Z00000000 root Event elog.log 2018-05-3002:0... 2018-05-3013:0... 346,536

a7 FG3K2D3Z00000000 FG3K2D3Z00000000  root Traffic tlog.log 2018-05-30 13:0... 2018-05-3013:1.. 782,844

o s FG?00D3000000000 FG200D3900000000 root VolP plog.log 2018-05-3002:0... 2018-05-3013:0.. 9869

a 9 FG200D3900000000 FG900D3900000000 root Event elog.log 2018-05-3002:0... 2018-05-3013:0... 76,955

0O 10 FG200D3000000000 FG900D3900000000 root Traffic tlog.log 2018-05-3002:0... 2018-05-3013:0.. 3,230,023

O 11 FG200D3900000000 FG900D3900000000 root Event elog.log 2018-05-3002:0... 2018-05-3013:0.. 2,638 v

Importing a log file

Imported log files can be useful when restoring data or loading log data for temporary use. For example, if you have older
log files from a device, you can import these logs to the FortiAnalyzer unit so that you can generate reports containing
older data.

Log files can also be imported into a different FortiAnalyzer unit. Before importing the log file you must add all devices
included in the log file to the importing FortiAnalyzer.

To insertimported logs into the SQL database, the config system sgl start-time and rebuild-event-
start-time must be older than the date of the logs that are imported and the storage policy for analytic data (the Keep
Logs for Analytics field) must also extend back far enough.

To set the SQL start time and rebuild event start time using CLI commands:

config system sqgl

set start-time <start-time-and-date>

set rebuild-event-start-time <start-time-and-date>
end

Where <start-time-and-date>isinthe formathh:mm yyyy/mm/dd.
To import a log file:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View > Log Browse and click Import in the toolbar.
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3. Inthe Device dropdown list, select the device the imported log file belongs to or select [Taken From Imported File] to
read the device ID from the log file.

If you select [Taken From Imported File], the log file must contain a device id field inits log messages.

4. Drag and drop the log file onto the dialog box, or click Add Files and locate the file to be imported on your local
computer.

5. Click OK. A message appears, stating that the upload is beginning, but will be canceled if you leave the page.

6. Click OK. The upload time varies depending on the size of the file and the speed of the connection.
After the log file is successfully uploaded, FortiAnalyzer inspects the file:

» Ifthe device idfield in the uploaded log file does not match the device, the import fails. Click Return to try
again.

« If you selected [Taken From Imported File] and the FortiAnalyzer unit’s device list does not currently contain
that device, an error is displayed stating Invalid Device ID.

Downloading a log file

You can download a log file to save it as a backup or to use outside the FortiAnalyzer unit. The download consists of
either the entire log file, or a partial log file, as selected by your current log view filter settings and, if downloading a raw
file, the time span specified.

To download a log file:

1. Goto Log View > Log Browse and select the log file that you want to download.
2. Inthe toolbar, click Download.
3. Inthe Download Log File(s) dialog box, configure download options:
« Inthe Log file format dropdown list, select Native, Text, or CSV.
« If you want to compress the downloaded file, select Compress with gzip.
4. Click Download.

Deleting log files

To delete log files:

1. GotoLog View > Log Browse.
2. Select one or more files and click Delete.
3. Click OK to confirm.

Log and file storage

Logs and files are stored on the FortiAnalyzer hard disks. Logs are also temporarily stored in the SQL database.
When a SIEM license is added, a SIEM database is created to store normalized Fabric logs.

When ADOMs are enabled, settings can be specified for each ADOM that apply only to the devices in it. When ADOMs
are disabled, the settings apply to all managed devices.
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Data policy and disk utilization settings for devices are collectively called log storage settings. Global log and file storage
settings apply to all logs and files, regardless of log storage settings (see File Management on page 342). Both the global
and log storage settings are always active.

NP The log rate and log volume per ADOM can be viewed through the CLI using the following

‘q’ commands:
diagnose fortilogd lograte-adom <name>

diagnose fortilogd logvol-adom <name>

Disk space allocation

On the FortiAnalyzer, the system reserves 5% to 20% of the disk space for system usage and unexpected quota
overflow. The remaining 80% to 95% of the disk space is available for allocation to devices.

Reports are stored in the reserved space.

Total Available Disk Size Reserved Disk Quota
Small Disk (up to 500GB) The system reserves either 20% or 50GB of disk space, whichever is smaller.
Medium Disk (up to 1TB) The system reserves either 15% or 100GB of disk space, whichever is smaller.
Large Disk (up to 3TB) The system reserves either 10% or 200GB of disk space, whichever is smaller.
Very Large Disk (5TB and The system reserves either 5% or 300GB of disk space, whichever is smaller.
higher)
M The RAID level you select determines the disk size and the reserved disk quota level. For
q example, a FortiAnalyzer 1000C with four 1TB disks configured in RAID 10 is considered a
= large disk, so 10%, or 100GB, of disk space is reserved.

Log and file workflow

When devices send logs to a FortiAnalyzer unit, the logs enter the following workflow automatically:

1. Compressed logs are received and saved in a log file on the FortiAnalyzer disks.
When a log file reaches a specified size, FortiAnalyzer rolls it over and archives it, and creates a new log file to
receive incoming logs. You can specify the size at which the log file rolls over. See Device logs on page 338.
2. Logs are indexed in the database to support analysis.
You can specify how long to keep logs indexed using a data policy. See Log storage information on page 107.
3. Logs are purged from the database, but remain compressed in a log file on the FortiAnalyzer disks.
4. Logs are deleted from the FortiAnalyzer disks.
You can specify how long to keep logs using a data policy. See Log storage information on page 107.
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In the indexed phase, logs are indexed in the database for a specified length of time so they can be used for analysis.
Indexed, or Analytics, logs are considered online, and details about them can be used viewed in the FortiView, Log View,
and Incidents & Events/FortiSoC panes. You can also generate reports about the logs in the Reports pane.

In the compressed phase, logs are compressed and archived in FortiAnalyzer disks for a specified length of time for the
purpose of retention. Compressed, or Archived, logs are considered offline, and their details cannot be immediately
viewed or used to generate reports.

The following table summarizes the differences between indexed and compressed log phases:

Log Phase Location Immediate Analytic Support

Indexed Compressed in log file and Yes. Logs are available for analytic use in FortiView,
indexed in database Incidents & Events/FortiSoC, and Reports.

Compressed Compressed in log file No.
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Automatic deletion

Logs and files are automatically deleted from the FortiAnalyzer unit according to the following settings:

» Global automatic file deletion
File management settings specify when to delete the oldest Archive logs, quarantined files, reports, and archived
files from disks, regardless of the log storage settings. For more information, see File Management on page 342.

» Data policy
Data policies specify how long to store Analytics and Archive logs for each device. When the specified length of time
expires, Archive logs for the device are automatically deleted from the FortiAnalyzer device's disks.

« Disk utilization
Disk utilization settings delete the oldest Archive logs for each device when the allotted disk space is filled. The
allotted disk space is defined by the log storage settings. Alerts warn you when the disk space usage reaches a
configured percentage.

When log trimming is performed by disk quota enforcement, tables from both the SQL and
SIEM databases are considered together, and the oldest table, identified by the timestamp
ﬂ of logs inside, is trimmed. The process repeats until the quota is within the defined
I threshold. The SIEM database is always partitioned by day, whereas the size of the SQL

database partition can be configured in FortiAnalyzer settings. For information on SIEM
logs, see Types of logs collected for each device on page 88.

All deletion policies are active on the FortiAnalyzer unit at all times, and you should carefully configure each policy. For
example, if the disk fullness policy for a device hits its threshold before the global automatic file deletion policy for the
FortiAnalyzer unit, Archive logs for the affected device are automatically deleted. Conversely, if the global automatic file
deletion policy hits its threshold first, the oldest Archive logs on the FortiAnalyzer unit are automatically deleted
regardless of the log storage settings associated with the device.

The following table summarizes the automatic deletion polices:

Policy Scope Trigger

Global automatic file  All logs, files, and When the specified length of time expires, old files are automatically

deletion reports on the deleted. This policy applies to all files in the system regardless of the
system data policy settings associated with devices.

Data policy Logs for the device When the specified length of retention time expires, old Archive logs

with which the data for the device are deleted. This policy affects only Archive logs for the
policy is associated device with which the data policy is associated.

Disk utilization Logs for the device When the specified threshold is reached for the allotted amount of
with which the log disk space for the device, the oldest Archive logs are deleted for the
storage settings are device. This policy affects only Archive logs for the device with which
associated the log storage settings are associated.

Logs for deleted devices

When you delete one or more devices from FortiAnalyzer, the raw log files and archive packets are deleted, and the
action is recorded in the local event log. However, the logs that have been inserted into the SQL database are not
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deleted from the SQL database. As a result, logs for the deleted devices might display in the Log View and FortiView
panes, and any reports based on the logs might include results.

The following are ways you can remove logs from the SQL database for deleted devices.

« Rebuild the SQL database for the ADOM to which deleted devices belonged or rebuild the entire SQL database.

» Configure the log storage policy. When the deleted device logs are older than the Keep Logs for Analytics setting,
they are deleted. Also, when analytic logs exceed their disk quota, the SQL database is trimmed starting with the
oldest database tables. For more information, see Configuring log storage policy on page 109.

» Configure global automatic file deletion settings in System Settings > Advanced > File Management. When the
deleted device logs are older than the configured setting, they are deleted. For more information, see File
Management on page 342.

iy
‘9' File Management configures global settings that override other log storage settings and

apply to all ADOMs.

Log storage information

To view log storage information and to configure log storage policies, go to System Settings > Storage Info.
If ADOMs are enabled, you can view and configure the data policies and disk usage for each ADOM.

The log storage policy affects only the logs and databases of the devices associated with the log storage policy. Reports
are not affected. See Disk space allocation on page 104.

[# Edit & Refresh Q.

Name Analytics (Actual/Config Days)  Archive (Actual/Config Days)  Max Storage  Analytics Usage (Used/Max)  Archive Usage (Used/Max)
“wFortiGates (2)

FortiCarrier 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
root 0/60 2/365 | 50GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
wOther Device Types (10)

FortiAnalyzer 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiAuthenticator | 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiCache 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiClient 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiDDoS 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiMail 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiManager 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiSandbox 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiWeb 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
Syslog 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)

The following information and options are available:

Edit Edit the selected ADOM's log storage policy.
Refresh Refresh the page.
Search Enter a search term to search the list.
Name The name of the ADOM.
ADOMs are listed in two groups: FortiGates and Other Device Types.
Analytics The age, in days, of the oldest Analytics logs (Actual Days), and the number of days
(Actual/Config Days) Analytics logs will be kept according to the data policy (Config Days).
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Archive The age, in days, of the oldest Archive logs (Actual Days) and the number of days

(Actual/Config Days) Archive logs will be kept according to the data policy (Config Days).

Max Storage The maximum disk space allotted to the ADOM (for both Analytics and Archive logs).
See Disk space allocation on page 104 for more information.

Analytics Usage How much disk space Analytics logs have used, and the maximum disk space allotted

(Used/Max) for them.

Archive Usage How much disk space Archive logs have used and the maximum disk space allotted for

(Used/Max) them.

Storage information

To view log storage policy and statistics, go to System Settings > Storage Info and double-click an ADOM in the list.
Alternatively, you can right-click or select an ADOM in the list and click Edit.

The top part of Storage Info shows visualizations of disk space usage for Analytic and Archive logs where the policy
diagrams show an overview and the graphs show disk space usage details. The bottom part shows the log storage
policy.

Analytics Policy Show Up to Today ~ Max Linez[]
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Quota Used

Keep Logs for 60 Days
Actual Logs for 35 Days

— Actual — Max - - Trend

The policy diagram shows the percentage of the disk space quota that is used. Hover your cursor over the diagram to
view the used, free, and total allotted disk space. The configured length of time that logs are stored is also shown.

The graphs show the amount disk space used over time. Click Max Line to show a line on the graph for the total space
allotted. Hover over a spot in the graph to view the used and available disk space at that specific date and time. Click the
graph to view a breakdown of the disk space usage by device.

Analytics Storage Statistics - Last 15 Days

Device Name Analytics Usage Average Log Rate (logs/sec) Peak Log Rate (logs/sec)
FGT37D0000000000 743.1GB 38.35% 1087.14 1615.27
FG800CO000000000 2214 MB 0.01% 424 3558

Weixixixi_ WiFi 31GB 0.16% 448 32.80
FG3K2D00D00000000 51.3GB 2.65% 77.29 781.74
FG1K2D0000000000 7164 GB 36.97% 1048.14 2376.82
FG100D000D000000 423.8GB 2187% 619.99 1726.02
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When the used quota approaches 100 percent, a warning message displays when accessing the Storage Statistics
pane.

Warning

Analytic is using 89% of allocated disk space.
Archive is using 88% of allocated disk space.

Please click "Configure Now" button to increase ADOM quota.

[ corue o

Click Configure Now to open the Edit Log Storage Policy dialog box where you can adjust log storage policies to prevent
running out of allocated space (see Configuring log storage policy on page 109), or click Remind Me Later to resolve the
issue another time.

Configuring log storage policy
The log storage policy affects the logs and databases of the devices associated with the log storage policy.
If you change log storage settings, the new date ranges affect Analytics and Archive logs
currently in the FortiAnalyzer device. Depending on the date change, Analytics logs might be

purged from the database, Archive logs might be added back to the database, and Archive
logs outside the date range might be deleted.

To configure log storage settings:

1. Go to System Settings > Storage Info.

2. Double-click on an ADOM, right-click on an ADOM and then select Edit from the menu, or select the ADOM then
click Editin the toolbar. Scroll to the log storage policy sections at the bottom of the Edit Log Storage Policy pane.
DJIZ::‘II_(DLS for Analytics 60 : Days
Keep Logs for Archive 365 : Days
Disk Utilization
Allocated 50 2 GB . | Maximum Available: 64.7 GB
Analytics : Archive 70% v 30% Modify

Alert and Delete When Usage | 90%
Reaches

*If analytic or archive log usages exceed the configured disk quota before the retention period
expires, the oldest logs will be deleted.

3. Configure the following settings, then click OK.

Data Policy
Keep Logs for Specify how long to keep Analytics logs.
Analytics
Keep Logs for Specify how long to keep Archive logs.
Archive Make sure your setting meets your organization’s regulatory requirements.

Disk Utilization

Allocated Specify the amount of disk space allotted. See also Disk space allocation on
page 104.
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Analytics: Archive Specify the disk space ratio between Analytics and Archive logs. Analytics
logs require more space than Archive logs. Click the Modify checkbox to
change the setting.

Alert and Delete Specify the percentage of allotted disk space usage that will trigger an alert
When Usage messages and start automatically deleting logs. The oldest Archive log files or
Reaches Analytics database tables are deleted first.

Configuring log rate receiving limits

You can manually configure log rate limits for devices in an ADOM or for specific logging devices. By default, no rate limit
is enforced.

When setting the log rate limit to manual in the CLI, you can specify a default device log rate and a per device/ADOM
rate. Both a default and per device limit can be set simultaneously, in which case the per device limit will take priority for
configured devices.

You can view configured logging rates in the CLI using the following command: diagnose test application
fortilogd 17anddiagnose test application oftpd 17.

To configure the default device log rate limit:

In the FortiAnalyzer CLI, enter the following commands:

config system log ratelimit
set mode manual
set device-ratelimit-default <set the rate limit, for example 2000>
end

To configure the log rate limit per device:

In the FortiAnalyzer CLI, enter the following commands:

config system log ratelimit
set mode manual
config ratelimits
edit <rate limit profile, for example "1">
set filter-type devid
set filter <device serial number>
set ratelimit <set the rate limit, for example 3000>
next
end

To configure the log rate limit per ADOM:

In the FortiAnalyzer CLI, enter the following commands:

config system log ratelimit
set mode manual
config ratelimits

edit <rate limit profile, for example "1">
set filter-type adom
set filter <ADOM name>
set ratelimit <set the rate limit, for example 3000>

next
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end

To disable the log rate limit:

In the FortiAnalyzer CLI, enter the following commands:

config system log ratelimit
set mode disable
end
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The Fabric View module enables you to create fabric connectors and view the list of endpoints. The Fabric View tab is
available in version 6.0 ADOMs and later.

This section contains the following topics:

o Fabric Connectors on page 112

e Subnets on page 117

« Identity Center on page 121

o Asset Center on page 123

» Configuring endpoint and end user data sources on page 126

Fabric Connectors

You can use FortiAnalyzer to create the following types of fabric connectors:

e ITSM
o Security fabric on page 113
o Storage on page 115

ITSM

You can use the Fabric Connectors tab to create the following types of ITSM connectors:

o ServiceNow
e Slack
» Webhook, a generic connector

Creating or editing ITSM connectors
You can create ITSM connectors for ServiceNow, Slack, and Webhook.

To create an ITSM connector:

1. Go to Fabric View > Fabric > Fabric Connectors, and click Create New.
2. Under ITSM, click ServiceNow Connector, Slack Connector, or Generic Connector and click Next.
3. Configure the following options, and click OK:

Property Description

Name Type a name for the fabric connector.
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Description (Optional) Type a description for the fabric connector.
Protocol Select HTTPS.

For Slack connectors and Generic connectors, you can also select HTTP.
Port Specify the port FortiAnalyzer uses to communicate with the external platform.
Method Select POST.

For Slack connectors and Generic connectors, you can also select PUT.
Title Type a title for the fabric connector.
URL Type the URL of the external platform.

Using ServiceNow as an example, copy and paste the URL from ServiceNow
API URL in the Connection to ServiceNow API section in ServiceNow >
FortiAnalyzer System Properties.

Enable HTTP Authentication = Set HTTP authentication to ON or OFF.
If set to ON, select Basic or OAuth2 authentication type.
Using ServiceNow with Basic authenictation as an example, enter the
username and password from the Connection to ServiceNow API section in
ServiceNow > FortiAnalyzer System Propetrties.
Using Webhook Connector with OAuth2 authentication as an example, enter
the URL of the token service as well as the client ID and client secret for
authentication.

Status Toggle ON to enable the fabric connector. Toggle OFF to disable the fabric
connector.

x After a ServiceNow connector is created, playbooks configured in FortiSoC can use the

connector to post incident change notices. See Playbooks on page 200.

To edit an ITSM connector:

1. Goto Fabric View > Fabric > Connectors.
2. Right-click an ITSM connector, and select Edit.
The Edit Connectors dialog box is displayed.

3. Edit the settings, and click OK.

Security fabric

You can use the Fabric Connectors tab to create the following types of security fabric connectors:

¢ FortiClient EMS
¢ FortiMail
« FortiCASB
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Creating or editing Security Fabric connectors

You can create a Security Fabric connector on FortiAnalyzer for FortiClient EMS, FortiMail, and FortiCASB. Once
configured, Security Fabric connectors enrich incident response related actions available in FortiSoC.

To create a Security Fabric connector:

1. Go to Fabric View > Fabric > Fabric Connectors, and click Create New.
The Create New Fabric Connector dialog is displayed.
2. Under Security Fabric, click FortiClient EMS, FortiMail, or FortiCASB.
3. Inthe Configuration tab, configure the following options for:
FortiClient EMS
Property Description
Type Select FortiClient EMS or FortiClient EMS Cloud.
Name Type a name for the Security Fabric connector.
Description (Optional) Type a description for the Security Fabric connector.
FortiClient IP/FQDN Type the IP address or FQDN for the Security Fabric device.
EMS
Username Type the username for the Security Fabric device.
Password Type the password for the Security Fabric device.
FortiClient Account ID Super users can type the account ID of the FortiClient EMS Cloud
EMS Cloud instance.
For non-super users, the field is automatically populated with the default
account ID. The FortiAnalyzer device must be registered with FortiCloud
to create and update the connector as a non-super user.
The FortiClient EMS must be v7.0 or later. After the FortiClient EMS
Cloud connector is created, the connector's health-check sends an
authentication request with SNI (the account ID) to the EMS instance.
The authentication request from the FortiAnalyzer device must be
approved in EMS: Administration > Fabric Devices. For more
information, see FortiClient on the Fortinet Docs Library.
Status Toggle On to enable the Security Fabric connector. Toggle Off to disable
the Security Fabric connector.
FortiMail
Property Description
Name Type a name for the Security Fabric connector.
Description (Optional) Type a description for the Security Fabric connector.
IP/FQDN Type the IP address or FQDN for the Security Fabric device.
Username Type the username for the Security Fabric device.
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Property Description

Password Type the password for the Security Fabric device.
Status Toggle On to enable the Security Fabric connector. Toggle Off to disable
the Security Fabric connector.
FortiCASB
Name Type a name for the Security Fabric connector.
Description (Optional) Type a description for the Security Fabric connector.
IP/[FQDN Type the IP address or FQDN for the Security Fabric device.

Use the FortiCASB FQDN for your chosen server location. The server
location is selected when creating your FortiCASB account. Use
forticasb.comforglobal servers or eu. forticasb.comfor EU
based servers.

Account ID Enter the credentials token used for authentication.

To create a FortiCASB credentials token, log in to FortiCASB with your
account, go to Home > Manage Company > API Setting, and click
Generate New. For more information, see FortiCASB on the Fortinet
Docs Library.

Status Toggle On to enable the Security Fabric connector. Toggle Off to disable
the Security Fabric connector.

4. Click the Actions tab to view the actions available with the Security Fabric connector, then click OK.

After the Security Fabric connector is created, playbooks configured in FortiSoC can use the connector to execute
automated actions. For a list of connector actions available in FortiSoC playbooks, see Connectors on page 197.

Default playbooks are automatically created when configuring some Security Fabric connectors. For more information
on playbooks in FortiSoC, see Playbooks on page 200.

To edit a Security Fabric connector:

1. Goto Fabric View > Fabric > Connectors.

2. Right-click a Security Fabric connector, and select Edit.
The Edit Connectors dialog is displayed.

3. Edit the settings, and click OK.

Storage

You can use the Fabric Connectors tab to create the following types of storage connectors:

¢ Amazon S3
« Azure Blob Container
« Google Cloud Storage
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Creating or editing storage connectors

You can create storage connectors for Amazon S3, Azure Blob, and Google Cloud. Once you have created a storage
connector, you can upload FortiAnalyzer logs to cloud storage. You must also import the CA certificate from the cloud
service provider. See Upload logs to cloud storage on page 341

To create a storage connector:

1. Go to Fabric View > Fabric > Fabric Connectors, and click Create New.
2. Under Storage, click Amazon S3, Azure Blob, or Google, and click Next.
3. Configure the following options, and click OK.

Name Type a name for the fabric connector.
Description (Optional) Add a description for the fabric connector.
Title Type a title for the fabric connector.
Status Toggle On to enable the fabric connector. Toggle Off to disable the
fabric connector.
Amazon S3 Provider Type AWS.
Region Select a region.
Access Key ID Paste the access key from the IAM user account.

Secret Access Key Paste the secret access key from the IAM user account. Click the eye
icon to Show or Hide the key.

Azure Blob Storage Account Paste the storage account name from the Microsoft Azure account.
Name
Account Key Paste the account key from the Microsoft Azure account.

Google Cloud Paste the project number from the Google account.

Project Number

Service Account Paste the entire Google account JSON key into the field. Click the eye

Credentials icon to Show or Hide the key.

Cloud Location Select a Google Cloud location. For information about Google locations,
visit the product help.

4. Advanced options will differ between the various types of storage connectors.

To edit a storage connector:

1. Go to Fabric View > Fabric > Connectors.
2. Right-click a storage connector, and select Edit.
The Edit Connectors dialog box is displayed.

3. Edit the settings, and click OK.
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Subnets

In Fabric View > Fabric > Subnets, you can define subnet lists which can be added to subnet groups.
Subnet lists and groups can be used to create include and exclude lists in event handlers and reports.

You can filter for subnet lists and subnet groups in Log View. See Filtering messages on page 94.

Creating, updating, or deleting subnets will generate local event logs.

-+ Create New~ [# Edit T Clone Wi Delete % More ~ QI
[] Name Details Create Time Update Time Tags Description
~Subnet (4)
O EFinance 10.100.92.100-10.100.92.100 2021-04-05 09:31:25 2021-04-05 09:32:12 IP Range
O EManagement 10.100.55.100-10.100.55.100 2021-04-05 09:31:40 2021-04-05 09:32:07 Management
O EMarketing 10.100.91.100-10.100.91.100 2021-04-05 09:32:32 2021-04-05 09:32:32 Marketing
O DSales 10.100.94.100-10.100.94.100 2021-04-05 09:31:58 2021-04-05 09:31:58 Sales
O Bgrpl EFinances 2021-04-05 09:33:36 2021-04-05 09:33:36 Grpl

Subnets includes the following options in the toolbar and right-click menu:

Create New Create a new subnet or subnet group.
Edit Edit the selected subnet or subnet group.
Clone Clone the selected subnet or subnet group.
Delete Delete the selected subnet(s) or subnet group(s).
Import Import a subnet or subnet group.
Export Export a subnet or subnet group in either a text or zipped format.
\‘ ! ’I
9 Subnet filtering for event handlers is supported in FortiGate, FortiWeb, FortiMail, and Fabric
|| ADOMs.
A\,
S L4
9 A maximum of 10,000 subnet objects can be created.

o Creating a subnet list on page 118
» Creating a subnet group on page 118
 Assigning subnet filters to event handlers on page 119
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Creating a subnet list

To create a new subnet:

1. Goto Fabric View > Fabric > Subnets.

2. Select Create New > Subnet.
The New Subnet wizard opens.

New Subnet
Name Subnet 1
Type Subnet Notation

Subnet Notation
Tags

Description

“ Cancel

3. Enter a name for the subnet.

4. Selecta Subnet type and configure the corresponding information.
Subnet types include:

o Subnet Notation
» IPRange
e Batch Add

5. Enter any Tags to be associated with this subnet. Tags are displayed in Assets when the endpoint IP falls within the
subnet. See Asset Center on page 123.

6. Optionally, enter a description.

7. Click OK.
Once a subnet has been created, it can be edited, cloned, or deleted by highlighting it and selecting the
corresponding action in Subnet List toolbar.

Creating a subnet group

To create a subnet group:

1. Goto Fabric View > Fabric > Subnets.

2. Select Create New > Subnet Group.
The New Subnet Group wizard opens.
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New Subnet Group

Name grpl

Subnets Click here to select ] x
Select Entries (Total: 4)

Subnet Groups Click here to select
o

Tags
[JFinance

Description [OManagement
[[Marketing
[sales
=] m Cancel

Enter a name for the subnet group.

Select the subnet entries to be included in the group and select OK in the pop-up window.

Optionally, select one or more existing subnet groups to be nested in the new subnet group as a member.

Enter any Tags to be associated with this subnet group. Tags are displayed in Assets when the endpoint IP falls
within the subnets that are a part of this group. See Asset Center on page 123.

Optionally, enter a description.

8. Click OK.

Once a subnet group has been created, it can be edited, cloned, or deleted by highlighting it and selecting the
corresponding action in Subnet List toolbar.

o0k w

N

Assigning subnet filters to event handlers

You can streamline SOC processes by defining a subnet whitelist/blacklist for event handlers. These addresses can be
linked to any event handler through a data selector, enabling or preventing the selected subnets from triggering an
event. Creating a subnet whitelist/blacklist in data selectors eliminates the need to specify common networks in every
event handler.

To include or exclude subnets in an event handler:

1. Goto FortiSoC > Handlers > Data Selector List.
2. Click Create New.

The Add New Data Selector pane displays.

You can also Clone or Edit an existing data selector to include or exclude subnets.
3. Inthe Subnetsfield, select Specify.

The Include Subnets and Exclude Subnets fields display.

4. Selectthe subnets to include or exclude in event handlers as part of the data selector.

5. Configure the other options for the data selector, and click OK. For more information, see Creating data selectors on
page 165.
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Add New Data Selector x

Name* Test-Data Selector

Devices PR Soecify | Local Device
Subnets All Subnets

Include Subnets Q
Finance x
1 entry selected
Exclude Subnets Q
Management x
marketing x

2 entries selected

Filters Any of the following conditions

+

6. Goto FortiSoC > Handlers > Event Handler List.
7. Select an event handler to add the data selector to, and click Edit.
The Edit Basic Event Handler pane displays.
You can also create a custom event handler to add the data selector to.
8. From the Data Selector dropdown, select the data selector configured to include or exclude the selected subnets.

9. Configure the other options for the event handler, and click OK. For more information, see Creating a custom event
handler on page 168.

Edit Basic Event Handler x
Status ©
Name* Default-Compromised Host-D Ll By-Threat

Description

Default event handler to detect ¢ OC feature grouped by threat
Data Selector No Data Selectors -
Automation Stitch

Q +

Rules Compromised Host Detection Selector

Default Intrusion Selector For Malicious Code Detection
© & Traffic to CnC detecte . - X

Default IP Scanning Selector For Recon Activity Detection

© & Web traffic to CnC de Default Local Device Selector

R Default Malicious File Selector For Malicious File Detection
© [ DNS traffic to CnC def
Default Risky App Selector For Risky App Detection

Default-Malicious-Code-Detection-By-Endpoint Selector

. Default-Malicious-Code-Detection-By-Threat Selector
Handler Settings

Notifications Click to select v

10. Add the data selector to other event handlers, as needed.

Ay
S L4
q If a conflict arises between the exclude and include lists, the exclude list will take priority.
\‘ ! ’l
? Subnet filters work when either SRCIP or DSTIP hit the subnet, meaning SRCIPs and DSTIPs
- share the same subnet filters.
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Identity Center

The Fabric View > Identity Center > All pane displays a list of users and endpoints in the network from relevant logs, and
correlates them with FortiAnalyzer modules.

The Identity Center is useful for user and endpoint mapping. Some users might use multiple endpoints in the network,
endpoints might use multiple different interfaces to connect, network interfaces might have multiple IP addresses, and so
on. A map of users and their endpoints gives you better visibility when you analyze logs, events, and incidents. This also

helps with your reporting.
This Identity Center pane lists all endpoints and users from relevant logs and correlates them with FortiAnalyzer
modules.
Column Description
User Name The name of the user.
User Group The group of user identities. An identity can be a:
¢ Local user account (username/password stored on the FortiGate unit)
¢ Remote user account (password stored on a RADIUS, LDAP, or TACACS+ server)
¢ PKIl user account with digital client authentication certificate stored on the FortiGate unit
* RADIUS, LDAP, or TACACS+ server, optionally specifying particular user groups on that
server
¢ User group defined on an FSSO server.
Endpoints Endpoint host name, IP address, or MAC address. A user may be connected to multiple
endpoints.
Click the endpoint to display the corresponding user information in the Assets pane.
VPN IP The VPN IP.

Identification Time  The time of identification.
Last Seen The last seen time.

Last Update The date and time the log was updated.

Use the toolbar to select a Security Fabric, time period, and columns.

End user information is limited if there is no FortiClient in your installation.
« Endpoints are detected based on MAC address and displayed by IP address instead of

host name.
¢ User related information might not be available.

* Detailed information such as OS version, avatar, and social ID information are not
available.

To provide a unified experience, you can customize how identity information is displayed, including which fields are
displayed, the order, and the priority.
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To filter the entries using filters in the toolbar:

 Specify filters in the Add Filter box.

» Regular Search: In the selected summary view, click Add Filter and select a filter from the dropdown list, then
type a value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or

or.

» Advanced Search: Click the Switch to Advanced Search icon at the end of the Add Filter box. In Advanced
Search mode, enter the search criteria (log field names and values). Click the Switch to Regular Search icon to
go back to regular search.

To create a custom view:

1. Inthe toolbar, click the column settings icon, and select the columns you want to display.
2. Click Custom View. The Save as New Custom View dialog is displayed.

3. Inthe Name field, enter a name for the custom view, and click OK. The view is saved under Custom View in the tree
menu.

To change the visibility of a custom view:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.

2. Inthe tree menu, select the menu icon next to your custom view or right click the view, and select Share with Others.

3. Setthe Privacy field to On: Public or Off: Private, and click OK.

To configure the display settings in the Social column:

1. Goto Log View >Tools > User Display Preferences.

2. Select the order preference tab you want to configure.
Tabs include Name, Picture, Email, Phone Number, and Social.

Rearrange the order preference as per your needs by drag-and-dropping an entry. For names, pictures, emails, and
phone numbers, only the top entry will appear in the identity pop-up window.

4. Userinformation can be disabled by moving the Show toggle to the Off position in the respective tabs.

ol

Identity Center dashboard

The Identity Center dashboard includes widgets for analysis of end users.

You can click Toggle Widgets to select which widgets are visible on the dashboard, and refine the list of endpoints
included in the widgets by using the dashboard filter. You can also apply filters from some widgets.

By default, the following widgets are displayed in the dashboard:

User Groups Displays user groups.

User Visibility Displays user visibility data over the past 24 hours to 52 weeks.
User Location Displays user numbers by location.

Asset Users Displays asset user data.

User Manager Displays user numbers by manager.
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User Discovery Displays the user discovery timeline.

User Changes Displays the user changes timeline.

To use the dashboard filter:

1. Go to Fabric View > Identity Center > Dashboard.

2. Click the filter icon in the top-right corner of the pane.
The following options are displayed.

Device Filter Click Select Device to add a device filter.
User Group Click the User Group dropdown to select user groups or choose All.
3. Click Apply.

Asset Center

The Fabric View > Asset Center > All pane is the central location for security analysts to view endpoint and user
information to make sure they are compliant. Endpoints are important assets in a network as they are the main entry
points in a cybersecurity breach.

The Asset Center pane is useful for the following:
« Incident response: check assets that are infected or vulnerable as part of your SOC analysis and incident

response process.
« Compliance: identify unknown and non-compliant users and endpoints.

The Asset Center pane lists all endpoints and users from relevant logs and correlates them with FortiAnalyzer modules.
Sort by the Vulnerabilities column to see which endpoints and users have the highest vulnerabilities.

Column Description

Endpoint Name Endpoint host name.

Tags Tags are used to group and identify assets to assist SOC analysts with incident management
and prioritization.
Tags can be defined by FortiClient EMS or when creating subnets and subnet groups in
FortiAnalyzer.
FortiClient EMS tags are determined based on the Classification Tag assigned in FortiClient
EMS. Tags are displayed in the Asset Center when a FortiSoC playbook retrieves information
about that endpoint using the Get Endpoints task available with a FortiClient EMS connector.
See Connectors on page 197.

Subnet tags are configurable when creating new subnets and subnet groups in FortiAnalyzer.
See Subnets on page 117.

User The name of the user. Click the name to view the corresponding user information in the
Identity Center pane.
MAC Address Endpoint MAC address.
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Column Description

IP Address IP address the endpoint is connected to. A user might be connected to multiple endpoints.
FortiClient UUID Unique ID of the FortiClient.
Hardware / OS OS name and version.

Software Click Details to view information about software installed on an endpoint when available.
Endpoint software information is retrieved when a playbook runs the Get Software Inventory
action using the FortiClient EMS connector. See Configuring playbook automation on page
197.

Vulnerabilities The number of vulnerabilities for critical, high, medium, and low vulnerabilities. Click the
vulnerability to view the name and category. Right-click the vulnerability to view available on-
demand actions using a security fabric connector.

Endpoint vulnerability information is retrieved when a playbook runs the Get Vulnerabilities
action using the FortiClient EMS connector. See Configuring playbook automation on page
197.

Last Update The date and time the log was updated.

Use the toolbar to select a Security Fabric, time period, and columns.

If there is no FortiClient in your installation, then endpoint and end user information is limited.
¢ Endpoints are detected based on MAC address and displayed by IP address instead of

host name.
¢ User related information might not be available.

» Detailed information such as OS version, avatar, and social ID information are not
available.

To filter the entries using filters in the toolbar:

» Specify filters in the Add Filter box.

» Regular Search: In the selected summary view, click Add Filter and select a filter from the dropdown list, then
type a value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or

“or”.

» Advanced Search: Click the Switch to Advanced Search icon at the end of the Add Filter box. In Advanced
Search mode, enter the search criteria (log field names and values). Click the Switch to Regular Search icon to
go back to regular search.

To create a custom view in the toolbar:

1. Inthe toolbar, click the column settings icon, and select the columns you want to display.
2. Click Custom View. The Save as New Custom View dialog is displayed.

3. Inthe Name field, enter a name for the custom view, and click OK. The view is saved under Custom View in the tree
menu.
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To change the visibility of a custom view:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Inthe tree menu, select the menu icon next to your custom view or right click the view, and select Share with Others.
3. Setthe Privacy field to On: Public or Off: Private, and click OK.

To download the entries as a CSV file:

1. Click Tools > Download.

Asset Center dashboard

The Asset Center dashboard includes widgets for analysis of endpoints.

You can click Toggle Widgets to select which widgets are visible on the dashboard, and refine the list of endpoints
included in the widgets by using the dashboard filter. You can also apply filters from some widgets.

By default, the following widgets are displayed in the dashboard:

Detection Method Displays endpoint detections by method.

HW OS Distribution Displays endpoint hardware operating system distribution.

Tag Distribution Displays the distribution of endpoint tags.

Data Source Breakdown Displays a breakdown of the asset center data sources.

Asset Identification Displays the number of detected endpoint assets that are identified and
unidentified.

Asset Discovery Displays an asset discovery timeline.

Asset Changes Displays an asset changes timeline.

Identified Asset Visibility Displays identified asset visibility over the past 24 hours to 52 weeks.

Identified Assets By Location  Displays identified assets by location.
Identified Asset Activity Displays a first seen, last update, and last seen asset activity timeline.

Unidentifed Asset Visibility Displays an unidentified asset activity timeline.

To use the dashboard filter:

1. Goto Fabric View > Asset Center > Dashboard.

2. Click the filter icon in the top-right corner of the pane.
The following options are displayed.

Tags Filter Select Include or Exclude then search for a tag.
You can click the add icon next to the tags field to add additional items to be
included or excluded. Click the trash icon to remove a field.

Hardware/OS Select a hardware/OS type from the dropdown to only display endpoints with
the matching hardware or operating system type.
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Detect Method

Device Filter

3. Click Apply.

Select a detection method in the dropdown to only display endpoints that were
detected by the specified method.

Click Select Device to add a device filter.

Configuring endpoint and end user data sources

You can configure the data sources used in the Asset Center and Identity Center to specify which sources are used to
identify endpoints and end users. Data source modification is configured per ADOM.

The following data sources are configurable in FortiAnalyzer:

FortiGate Log

FortiClient Log

FortiMail Log

FortiWeb Log

FortiNAC Log

EMS Connector

By default, the log identification of endpoints and end users is enabled for all
devices and subnets. You can create rules to specify which FortiGate devices and
which subnets are excluded in the data source.

Set the status to OFF to disable UEBA identification on the specified devices or all
devices.

By default, the log identification of endpoints and end users is enabled for all
devices. You can create rules to specify which FortiClient devices are excluded in
the data source.

Set the status to OFF to disable identification of endpoints and end users from the
specified devices or all devices.

By default, the log identification of endpoints and end users is disabled for all
devices. You can create rules to specify which FortiMail devices and domains are
included in the data source.

By default, the log identification of endpoints and end users is enabled for all
devices. You can create rules to specify which FortiWeb devices and which
subnets are excluded in the data source.

Set the status to OFF to disable UEBA identification on the specified devices or all
devices.

By default, the log identification of endpoints and end users is enabled for all
devices. You can create rules to specify which FortiNAC devices and which
subnets can be excluded in the data source.

Set the status to OFF to disable UEBA identification on the specified devices or all
devices.

By default, the log identification of endpoints and end users is disabled for all EMS
connectors. You can create rules to specify which EMS connectors can be
included in the data source.

\,

Rules created for individual devices have priority over those created for "all devices".
You can configure the same data source multiple times when the device or connector is
unique. When a conflict arises, you will see a message indicating the data source for that
device already exists, and you will have the option to override the existing data source.
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To configure data sources:

1. Go to Fabric View > Identity Center/Asset Center> Tools > Data Sources.
The Data Source Selection wizard opens. You can create, edit, and delete data sources.

2. Click Create New to create a new data source.

Data Source Selection

Data Source FortiGate Log
Status

Devices @Al Devices O Specify

Exclude Subnets

Click here to select

Cancel

3. Configure your data source. Different fields appear for different data source types:

Data Source

Status

Devices

Exclude Subnets

Include Domains

Connectors

Select the data source that you want to configure.

Data sources include FortiGate Log, FortiClient Log, FortiMail Log, FortiWeb
Log, FortiNAC Log, and EMS Connector.

Depending on your selection, different configurable fields will appear below.

Enable or disable the data source by setting the Status to ON or OFF.

When the data source is disabled, FortiAnalyzer will not identify endpoints and
end users in this ADOM from the devices, domains, or connectors configured
in the data source.

Devices is only available when the data source is FortiGate Log, FortiClient
Log, FortiMail Log, FortiWeb Log, or FortiNAC Log.

Select All Devices or Specify to select individual devices.

Exclude Subnets is only available when the data source is FortiGate Log,
FortiWeb Log, or FortiNAC Log.

Select subnets to be excluded from the data source selection. You can create
subnets in Fabric View > Fabric > Subnets. See Subnets on page 117.

Include Domains is only available when the data source is FortiMail Log.
Enter domains to be included in the data source selection.

Connectors is only available when the data source is EMS Connector.

Select an EMS connector to be included in the data source selection. See
Creating or editing Security Fabric connectors on page 114.

4. Click OKto save changes to the data source.
Once created, you can edit and delete the data sources from the Data Source Selection wizard.
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FortiAnalyzer can recognize a Security Fabric group of devices and display all units in the group on the Device Manager
pane. See Adding a Security Fabric group on page 128. FortiAnalyzer supports the Security Fabric by storing and
analyzing the logs from the units in a Security Fabric group as if the logs are from a single device. You can also view the
logging topology of all units in the Security Fabric group for additional visibility. See Displaying Security Fabric topology
on page 129.

FortiAnalyzer provides dynamic data and metadata exchange with the Security Fabric and uses the data in FortiView
and Reports for additional visibility. A default report template lets you monitor new users, devices, applications,
vulnerabilities, threats and so on from the Security Fabric.

A set of dashboard widgets lets you review audit scores for a FortiGate Security Fabric group with recommended best
practices and historical audit scores and trends.

If FortiClient is installed on endpoints for endpoint control with FortiGate, you can use the endpoint telemetry data
collected by the Security Fabric agent to display user profile photos in reports and FortiView.

Adding a Security Fabric group

Before you can add a Security Fabric group to FortiAnalyzer, you need to create the Security Fabric group in FortiGate.

Fortinet recommends using a dedicated Super_User administrator account on the FortiGate for FortiAnalyzer access.
This ensures that associated log messages are identified as originating from FortiAnalyzer activity. This dedicated
Super_User administrator account only needs Read Only access to System Configuration; all other access can be set to
None.

To add a Security Fabric group:

1. Go to Device Manager > Unauthorized Devices.
2. Select all the devices corresponding to the Security Fabric group created in FortiGate.

3. Authenticate the Security Fabric group by clicking the Warning icon (yellow triangle) beside the corresponding
FortiGate root.

Authentication

Please enter admin user name and password for the root device of security fabric "csf80cm”.

Admin User ||

Password

4. Enterthe Authentication Credentials. The authentication credentials are the ones you specified in FortiGate. Once
the FortiGate root has been authenticated, the Warning icon will disappear.

5. After authentication, it takes a few minutes for FortiAnalyzer to automatically populate the devices under the
FortiGate root which creates the Security Fabric group.
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Displaying Security Fabric topology
For Security Fabric devices, you can display the Security Fabric topology.

To display the Security Fabric topology:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.

2. Goto Device Manager.

3. Right-click a Security Fabric device and select Fabric Topology.
A pop-up window displays the Security Fabric topology for that device.
If you selected Fabric Topology by right-clicking a device within the Security Fabric group, the device is highlighted
in the topology. If you selected Fabric Topology by right-clicking the name of the Security Fabric group, no device is
highlighted in the topology.

Topology for FGP2000000000000

HA Active-Passive

FGT200DPOE-L1-root B3 FGBLE-HA-L2 — 55} FG2B0DPOE-L3

-
2mh FGE1E-HA-LS

FGVM-076-12

Security Fabric traffic log to UTM log correlation

FortiAnalyzer correlates traffic logs to corresponding UTM logs so that it can report sessions/bandwidth together with its
UTM threats. Within a single FortiGate, the correlation is performed by grouping logs with the same session IDs, source
and destination IP addresses, and source and destination ports.

In a Cooperative Security Fabric (CSF), the traffic log is generated by the ingress FortiGate, while UTM inspection (and
subsequent logs) can occur on any of the FortiGates. This means that the traffic logs did not have UTM related log fields,
as they would on a single FortiGate. Different CSF members also have different session IDs, and NAT can hide or
change the original source and destination IP addresses. Consequently, without a proper UTM reference, the
FortiAnalyzer will fail to report UTM threats associated with the traffic.

This feature adds extensions to traffic and UTM logs so that they can be correlated across different FortiGates within the
same security fabric. It creates a UTM reference across CSF members and generates the missing UTM related log fields
in the traffic logs as if the UTM was inspected on a single FortiGate.

NAT translation is also considered when searching sources and destinations in both traffic and UTM logs. The FortiGate
will generate a special traffic log to indicate the NAT IP addresses to the FortiAnalyzer within the CSF.

Traffic logs to DNS and SSH UTM references are also implement - the DNS and SSH counts in Log View can now be
clicked on to open the related DNS and SSH UTM log. IPS logs in the UTM reference are processed for both their
sources and destinations in the same order, and in the reverse order as the traffic log. The FortiGate log version indicator
is expanded and used to make a correct search for related IPS logs for a traffic log.
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This feature requires no special configuration. The FortiAnalyzer will check the traffic and UTM logs for all FortiGates
that are in the same CSF cluster and create the UTM references between them.

To view the logs:

1.

On the FortiAnalyzer, go to Log View > Traffic.
The UTM security event list, showing all related UTM events that can happen in another CSF member, is shown.
Click the count beside a UTM event to open the related UTM event log window. In this example, the traffic log is

from the CSF child FortiGate, and the UTM log is from the CSF root FortiGate.

Antivirus

A% Wi Date/Time Dievice Name Palicy ID Action Source

| [151636 FGT_1000_CSF_root 2 1011042

=-Security
Lovel wamhg L

Threat Level eritical -
Threat Score 50 4
=I-Source -4
Agent lIFTART =I-Des:
Device ID FGILOD3G14840718 -
Bevice Kame FGT_1000_C57 oot L
o User D 3 -
Endpeint I 54242 !
" 1011012 !
Interface ™ i
Fterface Rale i = Agn
Part 33761 e

Like other UTM logs, newly added DNS and SSH UTM references can also be shown in the FortiAnalyzer Log View.

Clicking the count next to the DNS or SSH event opens the respective UTM log.
Go to FortiView > Threats > Top Threats. All threats detected by any CSF member are shown.

ADOM; CSF_tdom 23 @ (B admin +

B summary A Filtar 3401 F-B- S
# Threats ~
Threat Score = Critical - High Medium Low
Top Threats. 1o N !
Threat Map an.
Compromised Hosts &0
FortiSandbon Detection an
= Traffic ¥ 20
§H Applications & Wehsites * o T T T T T
150500 151000 151500 15:2000 15:2500 15:3000
& PN ¥
2 WIFl N [ Threat Category CVE IO Threat Level Threat Scorel  Blocked! ™ Incidents{  Blocked/ ™
Allowad) Allowed)
»
£ System 1 W32iPaiteB Malwara 300 s
& Endioints Plz EICARTEST FILE Malware 250 5
3 kprowy.com Preoy Avoldance Mexdium 60— &
4 KProssy Preoy Medium 50 = 5
2= Total logs stored for analytice: 42 days 22 hours. Show 100« | Total 4

The created UTM reference is also transparent to the FortiGate when it gets its logs from the FortiAnalyzer. On the
FortiGate, the traffic log shows UTM events and referred UTM logs from other CSF members, even though the
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FortiGate does not generate those UTM log fields in its traffic log. In this example, the CSF child FortiGate shows
the referred UTM logs from the CSF root FortiGate.

@ Dashboard > e] & o AddFiter
% Security Fabri > . m— = ;

% Security Fabric # | % | DateTime Souree Destination Security Events Log Details x
& Fortiview 4 N dminutes ago @0 00:0c:29:29:9a:72 172.18.32.92 : Details
+ Metwork 2 4minutes ago @ 00:0¢:29:29:9::72 172.18.32.92 B Antivi = (& :

ntivirus =
& System N E 4minutes ago 172.18.32.92 ek 107
_ . Agent curl/ 7. 1%,
il 1
B Policy & Objects | ¢ OmiEses TR I | £ isandbox Checksum  275a0216bib
@ Security Profil N 5 éminutes ago O 00:0¢:29:29:9a.72 1721832126 1EEY A submitted to FortiSandbox false
ECUrit T e5 . -
i 6 7minutes ago @0 00:0c:29:29:92:72 172.18.32.126 [ wea [B1 ave [ ?eralls hast: 172,182
2PN >17 Friinutessgo @ 00:06:29:29:972 141167.114.102230 (kprowycom) [ 1S 1 poeat el e aG1d
& User & Device > 8 9minutesago O 00:0c:29:29:92:72 172.18.32.92 Directian incoming
= WIFi & Switch Controller > | ¢ Fminutes ago @ 00:00:29:29:92:72 172.18.32.92 Detection Type Wirus
. P Log event original timestarmp 1547077055
Ll Log & Report o |10 Gminutes age @ 00:00:29:29:92:72 172.18.32.92 Event Type infected
11 10minutesago @D 00:0:29:29:9a72 172.18.32.126 1P A | Fie Name cicarcaom
12 11 minutes ago - 72 1721832126 1 I Message Fileisinfectec
Local Traffic . 1 Profile Name default
13 12 minutes ago 11167.114.102.230 (kproxycom)  [Ed 1IEEH 1 Quarantine Ski File-yas-not
I ; Luarantine s} e - “(
TSI 14 12 minutes ago 2 172.18.32.126 [ 100 8 Reference https://fortigu
System Events 15 14 minutes ago [ ? 172,18.32.92 Type utrm
Router Events 16 14minutesago 172.18.32.92 tJrRL ot 'E‘}‘CF:'; ﬁéif
rus/sotnet - -
VBN Events 17 14 minutes ago 172.18.32.92 Virtss D 2172 - 7]
18 15minutesago @ 00:0c29:29:9a:72 172.16.32.126 bl wes [ e |
User Events . P B Web Filter = &
19 16 minutes ago @0 00:0¢:29:29:92:72 1721832126 il wie [ aee | =
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HA Events 21 17 minutes ago @0 00:0¢:29:29:92:72 172.18.32.126 | wes [l e G Direction cutgaing
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Security Fabric ADOMs

All Fortinet devices included in a Security Fabric can be placed into a Security Fabric ADOM, allowing for fast data
processing and log correlation. Fabric ADOMs enable combined results to be presented in the Device Manager, Log
View, FortiView, Incidents & Events/FortiSoC and Reports panes.

In a Fabric ADOM:
» Device Manager: View and add all Fortinet devices in the Security Fabric to the Fabric ADOM, including FortiGate,
FortiSandbox, FortiMail, FortiDDoS, and FortiClient EMS.
o Log View: View logs from all Security Fabric devices.
o FortiView: FortiDDoS and FortiClient EMS widgets are available.

e Incidents & Events: Predefined event handlers for FortiGate, FortiSandbox, FortiMail, and FortiWeb ADOMs are
available, and triggered events are displayed for all device types.

» Reports: View predefined reports, templates, datasets, and charts for all device types. Charts from all device types
can be inserted into a single report.

Creating a Security Fabric ADOM

To create a Fabric ADOM:

1. InFortiAnalyzer, go to System Settings > All ADOMs.
2. Select Create New.

3. Configure the settings for the new Fabric ADOM and select Fabric as the type.
See Creating ADOMs on page 301 for more information on the individual settings.

FortiAnalyzer 7.2.2 Administration Guide 131
Fortinet Inc.



Fortinet Security Fabric

£75 System Settings v ADOM:root (3 @ (@) admin v

€ Dashboard " | Create New ADOM

& Logging Topology Name

LA - Type Fabric

C storage Info Comments | Q

& HA FortiAnalyzer

& Admin v Devices FortiAuthenticator Q
Administrators FortiCache 1P Address Platform

Profile FortiCarier

FortiClient

FortiDDoS

Remote Authentication Server
Admin Settings

EB Certificates ~
Local Certificates
CA Certificates
CRL

£ Log Forwarding

B8] Fetcher Management

 Event Log

[@Task Monitor

E: Advanced ~ | Data Policy
SNMP Keep Logs for Analytics 60 = Days
Mail Server Keep Logs for Archive 365 + Days
Syslog Server Disk Utilization

Meta Fields Mowiemsion Allossind ar10 . rvrS Availahla 20 GR

v Lo et ! C e 1]

4. Select OKto create the ADOM.
The Fabric ADOM is listed under the Security Fabric section of All ADOMs.

ystem Settings v ADOM: my_fabric 2 @ (&) admin v
 Dashboard + CreateNew [ Edit Tl Delete Jisable ADOM  § More v % Column Settings ~ Y
& Logging Topology O Name Allocated Storage Devices Comments
@ All ADOMSs

-~ O my_fabric Fabric 50GB
C storage Info

© Network O FortiCarrier FortiCarrier 1000 MB
aHA O root FortiGate 168
2 Admin v

O Chassis - -
Administrators
O FortiAnalyzer FortiAnalyzer 1000 MB
Profile O FortiAuthenticator FortiAuthenticator 1000 MB
Remote Authentication Server O FortiCache FortiCache 1000 MB
Adrmin Settings O FortiClient FortiClient 1000 MB
O FortiDDoS FortiDDoS 1000 MB
BB Certificates v
O FortiMail FortiMail 1000 MB
Local Certificates O FortiManager FortiManager 1000 MB
CA Certificates O FortiProxy FortiProxy 1000 MB
. O FortiSandbox FortiSandbox 1000 MB
O FortiWeb FortiWeb 1000 MB
& Log Forwarding
O Syslog Syslog 1000 MB

B8] Fetcher Management

B Event Log

Migrating to a Fabric ADOM

You can change an existing non-Fabric ADOM to a Fabric ADOM using the FortiAnalyzer CLI.
1. Inthe FortiAnalyzer CLI, enter the following commands:
execute migrate fabric <fabric name>

A note is displayed informing you of the number of ADOMSs that will be affected, and once begun, a summary is
displayed and the system will reboot.

Enabling SAML authentication in a Security Fabric

When FortiGate is configured as a SAML SSO IdP in a Security Fabric, FortiAnalyzer can register itself to FortiGate as
an SAML service provider, allowing for simplified configuration of SAML authentication.

When FortiAnalyzer is configured as a Fabric SP, a default SSO administrator is automatically created for each Security
Fabric. When a user logs in through Fabric SSO, the Fabric IdP provides the user's profile name. If FortiAnalyzer has a
profile with a matching name, the profile is assigned to the user. Otherwise, the profile of the SSO administrator is
assigned to the user by default.
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Before configuring FortiAnalyzer as a Fabric SP, Security Fabric Connection and FortiAnalyzer Logging must be

configured on the root FortiGate.

A\,

‘Q' When ADOMs are enabled, SSO users can only access the ADOM that includes the root
FortiGate.

To configure FortiAnalyzer as a Fabric SP:

1. Enable SAML SSO on the root FortiGate in the Security Fabric. For more information, see the FortiGate

documentation in the Fortinet Document Library.

2. On FortiAnalyzer, enable the Fabric SP Single Sign-On Mode.
a. Goto System Settings > Admin > SAML SSO.

Select Fabric SP as the Single Sign-On Mode.

Enter the address of the FortiAnalyzer SP.

Select a Default Admin Profile.

P a200T

Click Apply.

£23  System Settings v

€ Dashboard Single Sign-On Settings

= Lossing Topology Single Sign-OnMode | Disabled | Identity Provider () | Service Provider (57) | e

& All ADOMs

& Storage Info In Fabric SP mode, an SSO administrator is created for each Security Fabric. When a user

@ 985 n via Fabric SSO, the Fabric IdP provides the user' profile name. If this system has a
profile with the matching name, the profile is assigned to the user. Otherwise, the profile

LHA of the SSO administrator is assigned to the user by default.

£ Network

2 Admin v
Administrators SP Address 172.27.2247
Profile Default Admin Profile @/ Standard_User
Remote Authentication Server Fabric IdPs

Admin Settings B Dele

e % Column Settings~
O  Root Device ADOM Name Status
B Certificates v
Local Certificates O  FGYMOOTM20002507 root Enabled
CA Certificates
CRL
Remote Certificates
< Log Forwarding
Fetcher Management
& Event Log
[2Task Monitor
s Advanced ~
SNMP
Mail Server
Syslog Server
Meta Fields
Device Log Settings
File Management

Advanced Settings

[ ]

The FortiAnalyzer will automatically detect the IdP FortiGate and register itself as a SAML SP. This process may
take up to ten minutes. Once completed, IdP information is displayed in the Fabric SP table on FortiAnalyzer, and

SP information can be viewed in FortiOS.
3. Signin using Fabric SSO.

Users are presented with the Login via Fabric Single Sign-On option on the FortiAnalyzer login page. When more
than one Security Fabric with SAML SSO enabled is configured, you are presented with the option to select which

Fabric login to use.
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Fortinet Security Fabric

FortiAnalyzer-VMé64

“

Login

Login via Fabric Single Sign-On

Fabric devices configured to the IdP can be accessed through the Security Fabric members dropdown which

appears in the top-right corner of the toolbar.
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Device Manager

"

Incidents & Events

Log View

EJE"D

FortiSoC

Device Name FabricRoot_FortiGate SecurityFabric v @ L 2 s‘!‘o admin v

Serial Number FGVMO0TM20002507 ¥ FabricRoot_FortiGate (Fabric Root)

Model FortiGate-VM64
Version V6.4.0 build1560 (Interim)

Management IP/FQDN 172.27.2.248

Fabric View
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Use FortiSoCl/Incidents & Events to generate, monitor, and manage alerts and events from logs. The live monitoring of
security events is a powerful and enabling feature for security operations. Incidents can be created from events to track
and respond to suspicious or malicious activities.

By default, incidents and events can be managed through the FortiSOC module. See FortiSoC

\ L}
‘?' on page 194.
- When the FortiSoC module is disabled, incidents and event management is available through

the Incidents & Events module.

Event handlers

Basic event handlers and correlation event handlers determine what events are generated from logs.

For basic event handlers, an event is generated when one of the rules in the event handler is met. Each rule in the basic
event handler has an OR relationship with the others.

For correlation event handlers, an event is generated when a set of rules are met in correlation sequence. For correlation
handlers, you can define both the rules and the operators (AND, AND_NOT, OR, FOLLOWED_BY, and NOT_
FOLLOWED_BY).

There are predefined event handlers for FortiGate, FortiSandbox, FortiMail, and FortiWeb devices. In a Security Fabric
ADOM, all predefined event handlers are displayed. Some predefined event handlers are disabled by default, but you
can enable them from the GUI.

You can also create your own custom event handlers. An easy way to create a custom event handler is to clone a
predefined event handler and customize its settings.

Data selectors and notification profiles are configured separately from event handlers, and then selected as part of
configuring predefined or custom event handlers as needed. Data selectors determine which devices, subnets, and
filters to use for the handler, and notification profiles determine if and where to send alert notifications when an event is
generated by the handler. These groupings promote reusability, which results in increased efficiency and a reduction in
human error when configuring event handlers.

When ADOMs are enabled, each ADOM has its own event handlers and list of events. Ensure you are in the correct
ADOM when working in FortiSoC/Incidents & Events. You can import and export the event handlers, allowing you to
develop custom event handlers and deploy them in bulk to other ADOMs or FortiAnalyzer units, if needed.

NP Event handlers generate events only from Analytics logs and not Archive logs. For more
‘Q' information, see Analytics and Archive logs.
- In an Analyzer—Collector collaboration scenario, the Analyzer evaluates the event handlers.
= For more information, see Analyzer—Collector collaboration.

In FortiSoC/Incidents & Events > Handlers, you can manage the Data Selector List, Notification Profile List, Event
Handler List, and Correlation Handler List separately.
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In this section, you will find the following topics:

« Predefined event handlers on page 136

» Predefined correlation handlers on page 161

» Creating data selectors on page 165

» Creating notification profiles on page 167

» Creating a custom event handler on page 168

» Creating a custom correlation handler on page 171

» Using the Automation Stitch for event handlers on page 176
» Using the Generic Text Filter on page 177

« Managing event handlers on page 177

« Enabling event handlers on page 178

« Cloning event handlers on page 178

« Resetting predefined event handlers to factory defaults on page
» Importing and exporting event handlers on page 179

Predefined event handlers

179

FortiAnalyzer includes many predefined event handlers that you can use to generate events. You can easily create a
custom event handler by cloning a predefined event handler and customizing its settings. See Cloning event handlers on

page 178.

If you wish to recieve notifications from a pedefined event handler, configure a notification profile and assign it to the

event handler. See Creating notification profiles on page 167.

\y

that can be enabled or disabled individually.

In 6.2.0 and up, predefined event handlers have been consolidated and have multiple rules

To view predefined event handlers in the FortiAnalyzer GUI, go to FortiSoC/Incidents & Events > Handlers > Event

Handler List. From the More dropdown, select Show Predefined.

i De W C ~

O | soud e

§ More

© Enable

@ Disabl

‘ Rules
Rule-1 Traffic to Botnet CnC blocked in virus log: (Default By Endpoint Botnet IPCAC] logid==0202009248

Rule-2 Traffic to Botnet CnC detected invirus log: (Default By_Endpoint Botnet IP.CSC) logid==0202009249
Show Predefined

O ©  Defauit-Botnet-Communication-Detection- Rule-3 DNS traffic to Botnet CnC blocked: (Default By_Endpoint Botnet,Domain C&C) logid==1501054601 OR logid==1
O Show Custom Rule-4 Traffic to Botnet CnC detected in ips log 1: (Default By_Endpoint Botnet Sig attack ~ Botnet and direc
51 Import o
Rule-1 Traffic to CnC detected: (Default By_Endpoint |RC&Cloc_Rescan) tdtype-infected
O ©  Default-Compromised Host-Detection-og] = 7 Rule-2 Web traffc to CnC detected: (Default By_Endpoint,CSCURLIoc_Rescan) dtype-infected
G Factory Reset Rule-3 DNS trafic to CnC detected: (Default By_Endpoint C&C,Domain loc_Rescan) tdtype-infected
Rule-1 Web request to malicious destination blocked: (Default,By_Endpoint Risky URL) Action Equal To blocked AND (cat
Rule-2 Web request to m: detected: (Default By_En isky,URL) Action Not Equal To blocked AN
O ©  Default-Risky-Destination-Detection-By-Endpoint Rule-3 Web request to s destination detected: (Default By _Endpoint,Risky,URL) Action Not Equal To blocked AN
Rule-4 DNS request to malicious destination detected: (Default. By_Endpoint Risky,Domair) logid==1501054802 and (cat
D
Rule-1 sroup efault By_Endpoint or dstintf
Rule-2 Intrusion blocked group by endpoint: (Default, By_Endpoint Intrusion.Signature WAN) (srcintfrole==wan or dstintfr
O ©  Default-Malicious-Code-Detection-By-Endpoint Rule-3 Internal group By_EndpointInts t
Rule-4 Internal intrusion blocked group by endpoint: (Default By Signature,
(-]

Data Selector

Default Intrusion Selector For Malicious Co

The following are a small sample of FortiAnalyzer predefined event handlers.

Event Handler Description

Default-Compromised Host-
Detection-lIOC-By-Threat

Disabled by default
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Event Handler Description

Rule 1: Traffic to CnC detected

Event Severity: Critical

Log Type: Traffic Log > Any

Group by: Destination IP, Source Endpoint

Log messages that match all of the following conditions:
e tdtype~infected

Tags: IP, C&C, loc_Rescan

Custom Message: Traffic to C&C:${dstip}, Traffic path: PolicylD
${policyid)\${dstintf\${dstip}:${dstport}

Rule 2: Web traffic to CnC detected

Default-Data-Leak-Detection-
By-Threat
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Event Severity: Critical

Log Type: Web Filter

Group by: Hostname URL, Source Endpoint

Log messages that match all of the following conditions:
e tdtype~infected

Tags: C&C, URL, loc_Rescan

Custom Message: Traffic to C&C:${hostname}, Traffic path: PolicylD
${policyid)\${dstintf\${dstip}:${dstport}

Rule 3: DNS traffic to CnC detected

Event Severity: Critical
Log Type: DNS Log
Group by: QNAME, Source Endpoint
Log messages that match all of the following conditions:
* tdtype~infected
Tags: C&C, Domain, loc_Rescan
Custom Message: Traffic to C&C:${qname}, Traffic path: PolicylD
${policyid\${dstintf\${dstip}:${dstport}

Rule 4: Traffic to CnC event detected by FortiGate

Event Severity: Critical
Log Type: Event Log
Log messages that match all of the following conditions:
e logid==0100020214
Tags: C&C
Custom Message: FGT detected traffic to |OC location, from the source
ip:${srcip}

Disabled by default
Rule 1: Data leak detected

Event Severity: Medium
Log Type: DLP
Group by: Filter Category, Source Endpoint
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Tags: Signature, Leak
Custom Message: File:${filename} (Type:${filetype}, Size:${filesize}), Traffic
path: PolicylD ${policyid}\${dstip}:${dstport}

Rule 2: Data leak blocked

Event Severity: Low

Log Type: DLP

Group by: Filter Category, Source Endpoint

Event Status: Mitigated

Tags: Signature, Leak

Custom Message: File:${filename} (Type:${filetype}, Size:${filesize}), Traffic
path: PolicylD ${policyid}\${dstip}:${dstport}

Default-Sandbox-Detections- Disabled by default
By-Endpoint Rule 1: Malware detected

Event Severity: Critical

Log Type: AntiVirus

Group by: Source Endpoint, Virus Name

Log messages that match all of the following conditions:
¢ logid==0211009235 or logid==0211009237

Tags: Sandbox, Signature, Malware

Custom Message: Malware:${virus} with severity:${crlevel} found in
file:${filename} from ${dstip}:${dstport}, Reference: ${ref}

Rule 2: Malware blocked

Event Severity: Critical

Log Type: AntiVirus

Group by: Source Endpoint, Virus Name

Log messages that match all of the following conditions:
¢ logid==0211009234 or logid==0211009236

Tags: Sandbox, Signature, Malware

Custom Message: Malware:${virus} with severity:${crlevel} found in
file:${filename} from ${dstip}:${dstport}, Reference: ${ref}

Rule 3: Sandbox detected Malware
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Event Severity: Critical

Log Type: AntiVirus

Group by: Source Endpoint

Log messages that match all of the following conditions:
¢ logid==0201009238 and fsaverdict==malicious

Tags: Sandbox, Malware

Custom Message: File:${filename}, Traffic path: ${dstintf}
(Policy:${policyid})\${dstip}:${dstport}, Checksum:${analyticscksum}
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Default-Shadow-IT-Events Requires a FortiCASB connector configured on FortiAnalyzer in Fabric View. See
Creating or editing Security Fabric connectors on page 114. This automatically
creates the Get Cloud Service Data (FortiCasb Connector) playbook, which must
be enabled for this event handler to generate events. See Playbooks on page
200.

Disabled by default
Rule 1: Unsanctioned Applications detected

Event Severity: High

Log Type: Application Control

Group by: Source IP, Application Name

Log messages that match all of the following conditions:
o (siflags & 1) == 0 && siappid >=0

Tags: Unsanctioned_App

Custom Message: Unsanctioned application ${app} with app risk: ${apprisk}
detected on: ${devname} with message: ${msg}

Rule 2: File Exfiltration Attempts detected

Event Severity: High
Log Type: Application Control
Group by: Source IP, Application Name
Log messages that match all of the following conditions:
e (siflags & 4) ==
Tags: File_Exfiltration
Custom Message: File exfiltration detected on: ${devname} with message:

${msg}

Rule 3: Unsanctioned Users detected

Event Severity: High

Log Type: Application Control

Group by: Source IP, Application Name

Log messages that match all of the following conditions:
e (siflags & 1) == 1 && (siflags & 2) ==

Tags: Unsanctioned_User

Custom Message: Unsanctioned user: ${unauthuser} with app risk:
${apprisk} detected on: ${devname} with message: ${msg}

Local Device Event Available only in the Root ADOM.
Enabled by default
Data Selector: Default Local Device Selector

Rule 1: Critical or important events
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Event Severity: Medium

Log Type: Event

Group by: Log Description

Log messages that match the following conditions:
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Default-NOC-Interface-Events
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e Level Greater Than or Equal To Warning
Tags: System, Local

Event handler for FortiGate device type logs to generate events for vlian/interface
status up or down, and DNS service on interface status.

Disabled by default
Rule 1: Interface status changed to up

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:
e action="interface-stat-change" and status="UP"

Tags: NOC, Interface

Custom message: Device ${devname}, status changed to ${status} with
message ${msg}.

Rule 2: Interface status changed to down

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:
¢ action="interface-stat-change" and status="DOWN"

Tags: NOC, Interface

Custom message: Device ${devname}, status changed to ${status} with
message ${msg}.

Rule 3: DNS server config added

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:
e cfgpath="system.dns-server"and action="Add"

Tags: NOC, Interface, DNS

Custom Message: Device ${devname}, DNS server status changed with
message ${msg}.

Rule 4: DNS server config deleted

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:
e cfgpath="system.dns-server"and action="Delete"

Tags: NOC, Interface, DNS

Custom Message: Device ${devname}, DNS server status changed with
message ${msg}.
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Default-NOC-FortiExtender- Event handler for FortiGate device type logs to generate events for FortiExtender
Events alerts, authorization and controller activity events.
Disabled by default

Rule 1: FortiExtender Authorized

Event Severity: Medium
Log Type: Event > FortiExtender
Group by: SN, Log Description
Log messages that match all of the following conditions:
» action="FortiExtender Authorized"
Tags: NOC, FortiExtender
Custom message: Device: ${ip} ${action} with message: ${msg}

Rule 2: Warning event detected

Event Severity: High
Log Type: Event > FortiExtender
Group by: SN, Log Description
Log messages that match all of the following conditions:
e level="warning"
Tags: NOC, FortiExtender
Custom message: ${action} on ${ip} with message: ${msg}

Rule 3: Alert event detected

Event Severity: High
Log Type: Event > FortiExtender
Group by: SN, Log Description
Log messages that match all of the following conditions:
e level="alert"
Tags: NOC, FortiExtender
Custom message: ${action} on ${ip} with message: ${msg}

Rule 4: Critical event detected

Event Severity: Critical
Log Type: Event > FortiExtender
Group by: SN, Log Description
Log messages that match all of the following conditions:
* level="critical"
Tags: NOC, FortiExtender
Custom message: ${action} on ${ip} with message: ${msg}

Rule 5: Error event detected
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Event Severity: Medium

Log Type: Event > FortiExtender

Group by: SN, Log Description

Log messages that match all of the following conditions:
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Default-NOC-Routing-Events
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* level="error"
Tags: NOC, FortiExtender
Custom message: ${action} on ${ip} with message: ${msg}

Rule 6: Emergency event detected

Event Severity: Critical
Log Type: Event > FortiExtender
Group by: SN, Log Description
Log messages that match all of the following conditions:
* level="emergency"
Tags: NOC, FortiExtender
Custom message: ${action} on ${ip} with message: ${msg}

Rule 7: FortiExtender controller activity detected

Event Severity: Medium
Log Type: Event > FortiExtender
Group by: SN, Log Description
Log messages that match all of the following conditions:
* Jogid="0111046401"and logdesc="FortiExtender controller activity"
Tags: NOC, FortiExtender
Custom message: ${action} on ${ip} with message: ${msg}

Rule 8: FortiExtender controller activity error detected

Event Severity: Medium

Log Type: Event > FortiExtender

Group by: SN, Log Description

Log messages that match all of the following conditions:

¢ Jlogid="0111046402" and logdesc="FortiExtender controller activity
error"

Tags: NOC, FortiExtender
Custom message: ${action} on ${ip} with message: ${msg}

Event handler for FortiGate device type logs to generate events for changes in
routing information including BGP Neighbor Status, Routing information change,
OSFP Neighbor Status, Neighbor Table Changed and VRRP State Changed

Disabled by default
Rule 1: Routing information changed

Event Severity: Medium
Log Type: Event > Any
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
¢ Jogdesc="Routing information changed"
Tags: NOC, Routing
Custom message: ${logdesc} on ${devname} with message ${msg}
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Rule 2: BGP neighbor status changed

Event Severity: Medium
Log Type: Event > Router
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
¢ Jogdesc="BGP neighbor status changed”
Tags: NOC, Routing
Custom message: ${devname}. BGP neighbor status changed with message

${msg}

Rule 3: OSPF or OSPF6 neighbor status changed

Event Severity: Medium

Log Type: Event > Router

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

¢ Jogdesc=="OSPF neighbor status changed" OR logdesc=="OSPF6
neighbor status changed”

Tags: NOC, Routing
Custom message: ${logdesc} on ${devname} with message ${msg}

Rule 4: Neighbor table changed

Event Severity: Medium
Log Type: Event > Router
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
* Jogdesc=="neighbor table change"
Tags: NOC, Routing
Custom message: ${logdesc} on ${devname} with message ${msg}

Rule 5: VRRP state changed

Event Severity: Medium
Log Type: Event > Router
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
* Jogdesc=="VRRP state changed"
Tags: NOC, Routing
Custom message: ${logdesc} on ${devname} with message ${msg}

Default-NOC-Network-Events Event handler for FortiGate device type logs to generate network events including
SNMP queries, routing information changes, DHCP server and status changes

Disabled by default
Rule 1: Device SNMP query failed
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Event Severity: High
Log Type: Event > System
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¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ logid="0100029021" AND logdesc="SNMP query failed"
e Tags: NOC, Network
» Custom message: Device: ${devname} ${logdesc} with message: ${msg}

Rule 2: Device routing information changed

» Event Severity: High

e Log Type: Event > System

» Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

¢ logdesc=="Routing information changed"

e Tags: NOC, Network

» Custom message: Device: ${devname} ${logdesc} with message: ${msg}
Rule 3: DHCP client lease granted or usage high

e Event Severity: High

* Log Type: Event > System

¢ Group by: Device Name, Log Description

* Log messages that match all of the following conditions:

¢ Jlogdesc=="DHCP client lease granted" OR logdesc=="DHCP lease
usage high" OR logdesc=="DHCP lease usage full"

e Tags: NOC, Network
» Custom message: DHCP status on Device ${devname} is ${logdesc} with
message: ${msg}
Rule 4: SNMP enabled
» Event Severity: Medium
e Log Type: Event > System
e Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

e cfgpath="system.snmp.sysinfo" and logdesc="Attribute configured" and
cfgattr=status[disable->enable]

e Tags: NOC, Network
» Custom message: Device ${devname} ${logdesc} ${cfgattr} with message
${msg}.
Rule 5: SNMP disabled
e Event Severity: Medium
e Log Type: Event > System
e Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

e cfgpath="system.snmp.sysinfo" and logdesc="Attribute configured" and
cfgattr=status[enable->disable]

e Tags: NOC, Network

FortiAnalyzer 7.2.2 Administration Guide
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Default-NOC-Switch-Events
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Custom message: Device ${devname} ${logdesc} ${cfgattr} with message
${msg}.

Rule 6: DHCP server status changed

Event Severity: Medium
Log Type: Event > System
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
o cfgpath="system.dhcp.server"and logdesc="Object attribute
configured”
Tags: NOC, Network
Custom message: DHCP server status change ${cfgattr} with message
${msg}.

Rule 7: DHCP lease renewed

Event Severity: Medium
Log Type: Event > System
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
e dhcp_msg="Ack" and logdesc="DHCP Ack log"
Tags: NOC, Network
Custom message: Host ${hostname} with message ${msg}.

Rule 8: DHCP lease released

Event Severity: Medium
Log Type: Event > System
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
e dhcp_msg="Release" and logdesc="DHCP Release log"
Tags: NOC, Network
Custom message: Host ${hostname} with message ${msg}.

Event handler for FortiGate device type logs to generate events for Switch-
Controller added/deleted or authorized/deauthorized, Switch-Controller Status,
Interface flapping, LAG/MCLAG and split-brain status, Cable test/diagnosis and
physical port up/down

Disabled by default

Rule 1: Switch-Controller activity detected

Event Severity: Medium

Log Type: Event > Any

Group by: Device Name, Message

Log messages that match all of the following conditions:

e (subtype="switch-controller") and (logdesc=="Switch-Controller
discovered" OR logdesc=="Switch-Controller authorized”" OR
logdesc=="Switch-Controller deauthorized” OR logdesc=="Switch-
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Controller deleted” OR logdesc=="Switch-Controller warning")
e Tags: NOC, Switch, Controller
» Custom message: ${logdesc}

Rule 2: Vlan interface change has occurred
« Event Severity: Medium
¢ Log Type: Event > Any
« Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ logdesc="FortiSwitch system'and msg~"interface vian"
e Tags: NOC, Switch, Controller
« Custom message: Device ${devname} interface vlan change with message:
${msg}
Rule 3: Port switch detected
» Event Severity: Medium
¢ Log Type: Event > Any
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ |logdesc="FortiSwitch link" AND msg~"switch port"
e Tags: NOC, Switch, Controller
« Custom message: ${logdesc} on Device: ${devname} with message: ${msg}

Rule 4: Device flap detected
e Event Severity: Medium

* Log Type: Event > Any

e Group by: Device Name, Message

¢ Log messages that match all of the following conditions:
e msg~"flap"

¢ Tags: NOC, Switch, Controller

¢ Default message

Rule 5: Device LAG-MCLAG status change

¢ Event Severity: Medium

* Log Type: Event > Any

¢ Group by: Device Name, Log Description

* Log messages that match all of the following conditions:
¢ msg~"lag" OR msg~"mclag"

e Tags: NOC, Switch, Controller

» Custom message: Device: ${devname} LAG-MCLAG status update with
message: ${msg}

Rule 6: Device MCLAG split-brain detected
¢ Event Severity: Medium
* Log Type: Event > Any
¢ Group by: Device Name, Log Description
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¢ Log messages that match all of the following conditions:
e Jog_id=0115032695 and msg~"MCLAG split-brain”

¢ Tags: NOC, Switch, Controller

+ Custom message: Device ${devname} ${msg}.

Rule 7: Device cable diagnose detected
¢ Event Severity: Medium

* Log Type: Event > Any

¢ Group by: Device Name, Log Description

» Log messages that match all of the following conditions:
¢ log id=0115032699 and msg~"CABLE DIAGNOSE"

e Tags: NOC, Switch, Controller

» Custom message: Device ${devname} ${msg}.

Rule 8: Device come up detected

¢ Event Severity: Medium

* Log Type: Event > Any

¢ Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:
e Jog id=="0115032695" and msg~"come up"

e Tags: NOC, Switch, Controller

» Custom message: Device ${devname} ${msg}.

Rule 9: Device gone down detected
» Event Severity: Medium

e Log Type: Event > Any

« Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:
e Jog id=="0115032695" and msg~"gone down"

e Tags: NOC, Switch, Controller

« Custom message: Device ${devname} ${msg}.

Default-NOC-HA-Events Event handler for FortiGate device type logs to generate events for HA cluster
updates and alerts including HA Device interface failure, Cluster Priority
Changed, cluster member state moved, device interface down, HA device
syncronization status, connection to FortiAnalyzer status, FortiManager tunnel
connection status and connection with CSF member status.

Disabled by default

Rule 1: HA device interface failed
» Event Severity: High

e Log Type: Event>HA
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ logdesc=="HA device interface failed" and logid=="0108037898"

FortiAnalyzer 7.2.2 Administration Guide
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e Tags: NOC, HA, Cluster
e Default message

Rule 2: Device set as HA primary
e Event Severity: High
* Log Type: Event>HA
¢ Group by: Device Name, Log Description
» Log messages that match all of the following conditions:
¢ Jogdesc=="Device set as HA primary"
e Tags: NOC, HA, Cluster
» Custom message: Device: ${devname} has been set to HA Primary with
msg: ${msg}
Rule 3: Cluster state moved or Heartbeat device interface down
e Event Severity: High
* Log Type: Event>HA
¢ Group by: Device Name, Log Description
* Log messages that match all of the following conditions:

¢ Jogdesc=="Virtual cluster member state moved" OR
logdesc=="Heartbeat device interface down"

e Tags: NOC, HA, Cluster

» Custom message: Device: ${devname} ${logdesc} with HA role: ${ha_role}
Rule 4: Synchronization activity detected

e Event Severity: High

* Log Type: Event>HA

¢ Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

¢ Jogdesc=="HA secondary synchronization failed" OR
logdesc=="Secondary sync failed" OR logdesc="Synchronization status
with master"

e Tags: NOC, HA, Cluster

¢ Custom message: Device: HA synchronization status for Device:
${devname} ${logdesc}. Message: ${msg}. Status is: ${sync_status}

Rule 5: FortiAnalyzer connection up
¢ Event Severity: Medium
* Log Type: Event > System
¢ Group by: Device Name, Log Description
* Log messages that match all of the following conditions:

e action="connect"and status="success"and logdesc="FortiAnalyzer
connection up"

e Tags: NOC, HA, Cluster
» Custom message: Device ${devname} ${msg}.
Rule 6: FortiAnalyzer connection failed
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Event Severity: High

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

e action="connect" and status="failure" and logdesc="FortiAnalyzer
connection failed"

Tags: NOC, HA, Cluster
Custom message: Device ${devname} ${msg}.

Rule 7: Upstream connection with CSF member established and authorized

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

direction="upstream" and logdesc="Connection with CSF member
established and authorized"

Tags: NOC, HA, Cluster
Custom message: Device ${devname} ${msg}.

Rule 8: Upstream connection with authorized CSF member terminated

Event Severity: High

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

¢ direction="upstream" and logdesc="Connection with authorized CSF
member terminated”

Tags: NOC, HA, Cluster
Custom message: Device ${devname} ${msg}.

Rule 9: FortiManager tunnel connection up

Event Severity: Medium

Log Type: Event > System

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

e action="connect" and status="success" and logdesc="FortiManager
tunnel connection up"

Tags: NOC, HA, Cluster
Custom message: Device ${devname} ${logdesc} with message - ${msg}.

Rule 10: FortiManager tunnel connection down

FortiAnalyzer 7.2.2 Administration Guide
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Event Severity: High
Log Type: Event > System
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
e action="connect"and status="failure" and logdesc="FortiManager
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tunnel connection down"
e Tags: NOC, HA, Cluster
» Custom message: Device ${devname} ${logdesc} with message - ${msg}.

Default-NOC-Wireless-Events  Event handler for FortiGate device type logs to generate events for wireless wifi,
AP updates and alerts including AP Status Change and Fake/Rogue AP
detection, wireless client status change added/removed/allowed or denied status,
signal to noise ratio (SNR) poor/fair/good, SSID status up/down.

Disabled by default

Rule 1: Fake AP detected
¢ Event Severity: Medium

e Log Type: Event > Wireless
¢ Group by: Device Name, SSID
¢ Log messages that match all of the following conditions:
* Jogid="0104043567" AND logdesc=="Fake AP detected"
e Tags: NOC, Wireless, Wifi, AP
» Custom message: ${logdesc}. SN: ${sndetected}

Rule 2: Rogue AP detected
» Event Severity: Medium

¢ Log Type: Event > Wireless
¢ Group by: Device Name, SSID
¢ Log messages that match all of the following conditions:
¢ Jogid=="0104043563" AND logdesc=="Rogue AP detected"
e Tags: NOC, Wireless, Wifi, AP
« Custom message: ${logdesc}. SN: ${sndetected} with message: ${msg}

Rule 3: Wireless event log id matched
¢ Event Severity: Medium

* Log Type: Event > Wireless
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:

e subtype="wireless" AND (logid=="0104043551" OR
logid=="0104043552" OR logid=="0104043553")

e Tags: NOC, Wireless, Wifi, AP
» Custom message: ${logdesc}. of AP: ${ap}

Rule 4: Wireless client activity detected
¢ Event Severity: Medium

* Log Type: Event > Wireless
¢ Group by: Device Name, Log Description
» Log messages that match all of the following conditions:

¢ (logdesc=="Wireless client associated" OR logdesc=="Wireless client
authenticated" OR logdesc=="Wireless client disassociated” OR
logdesc=="Wireless client deauthenticated" OR logdesc=="Wireless
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client idle" OR logdesc=="Wireless client denied" OR
logdesc=="Wireless client kicked" OR logdesc="Wireless client IP
assigned” OR logdesc=="Wireless client left WTP" OR
logdesc=="Wireless client WTP disconnected")

e Tags: NOC, Wireless, Wifi, AP
» Custom message: ${logdesc} for ${ssid} with message: ${msg}
Rule 5: Signal-to-noise ratio is poor
¢ Event Severity: Medium
* Log Type: Event > Wireless
¢ Group by: Device Name
* Log messages that match all of the following conditions:
e snr<="24"
e Tags: NOC, Wireless, Wifi, AP
» Custom message: SSID ${ssid}. has a poor quality SNR at ${snr} dB.

Rule 6: Signal-to-noise ratio is fair
¢ Event Severity: Medium
e Log Type: Event > Wireless
¢ Group by: Device Name
¢ Log messages that match all of the following conditions:
e snr>="25"and snr<="40"
e Tags: NOC, Wireless, Wifi, AP
¢ Custom message: SSID ${ssid}. has fair quality SNR at ${snr} dB.
Rule 7: Signal-to-noise ratio on is excellent
» Event Severity: Medium
¢ Log Type: Event > Wireless
* Group by: Device Name
¢ Log messages that match all of the following conditions:
e snr>="41"
e Tags: NOC, Wireless, Wifi, AP
» Custom message: SSID ${ssid}. has excellent quality SNR at ${snr} dB.

Rule 8: Physical AP radio ssid up
¢ Event Severity: Medium

* Log Type: Event > Wireless
¢ Group by: SSID, Log Description
¢ Log messages that match all of the following conditions:
¢ logdesc="Physical AP radio ssid up"and action="ssid-up"
e Tags: NOC, Wireless, Wifi, AP
» Custom message: Device ${sn} SSID status change with message ${msg}.

Rule 9: Physical AP radio ssid down
¢ Event Severity: Medium
* Log Type: Event > Wireless
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¢ Group by: SSID, Log Description
¢ Log messages that match all of the following conditions:
¢ Jlogdesc="Physical AP radio ssid down"and action="ssid-down"
e Tags: NOC, Wireless, Wifi, AP
» Custom message: Device ${sn} SSID status change with message ${msg}.

Default-NOC-Security-Events Event handler for FortiGate device type logs to generate events for security
events including Admin Logins failed or disabled, Admin or Admin Monitor
Disconnected, Admin password expired and UTM Profile changes

Disabled by default

Rule 1: Admin login failed or desabled
» Event Severity: High

e Log Type: Event > System
» Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

¢ logdesc=="Admin login failed" OR logdesc=="Admin login disabled" OR
logdesc=="SSL VPN login fail"

e Tags: NOC, Security, Login, Password

» Custom message: ${logdesc} for ${user} on device: ${devname} due to:
${reason} with message: ${msg}

Rule 2: Admin password expired

» Event Severity: High

e Log Type: Event > System

» Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

* Jogdesc=="Admin password expired"

e Tags: NOC, Security, Login, Password

» Custom message: Device: ${devname} ${logdesc} with message: ${msg}
Rule 3: Admin disconnected

« Event Severity: High

e Log Type: Event > System

e Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:

¢ Jogdesc=="Admin disconnected" OR logdesc=="Admin monitor
disconnected"

e Tags: NOC, Security, Login, Password
« Custom message: ${logdesc} on device: ${devname} with message: ${msg}

Rule 4: AV or IPS change detected
e Event Severity: High

e Log Type: Event > System
e Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
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¢ Jogdesc=="AV updated by admin" OR logdesc=="IPS package - Admin
update successful” OR logdesc=="AV package update by SCP failed"
OR logdesc=="IPS package failed to update via SCP" OR
logdesc=="IPS custom signatures backup failed"

e Tags: NOC, Security, Login, Password
» Custom message: Device: ${devname} ${logdesc} with message: ${msg}

Default-NOC-Fabric-Events Event handler for FortiAnalyzer and FortiGate log device type to detect Fabric
events, including device offline, CSF member connection status down or
terminated, CSF member configuration changes, automation stitch triggered ,
licenses that are expiring or failed updates.

Disabled by default
Rule 1: Device offline detected
¢ Event Severity: High
e Log Type: Application
¢ Group by: Logging Device Name, Message
» Log messages that match all of the following conditions:
e desc="Device offline"
e Tags: NOC, Fabric
» Custom message: ${logdev _id} is offline
Rule 2: FortiAnalyzer connection down detected
¢ Event Severity: High
e Log Type: Event > System
¢ Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jlogdesc="FortiAnalyzer connection down"
e Tags: NOC, Fabric
¢ Default message

Rule 3: Connection with authorized CSF member terminated
» Event Severity: High

e Log Type: Event > System
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jogdesc="Connection with authorized CSF member terminated”
e Tags: NOC, Fabric
» Custom message: ${logdesc} on: ${devid} due to: ${reason}

Rule 4: Automation stitch triggered
« Event Severity: Medium

¢ Log Type: Event > System

« Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:
¢ Jogdesc="Automation stitch triggered"
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e Tags: NOC, Fabric
» Custom message: ${logdesc} on: ${devname} with message: ${msg} and
stitch action: ${stitchaction}

Rule 5: Device license failed or expiring detected
e Event Severity: Critical

¢ Log Type: Event > System
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jogdesc~"license failed" OR logdesc~"license expiring"
e Tags: NOC, Fabric
» Custom message: ${logdesc} on: ${devid}
Rule 6: System update or failure detected
¢ Event Severity: Critical
* Log Type: Event > System
¢ Group by: Device Name, Message
* Log messages that match all of the following conditions:
¢ Jogdesc~"update" AND logdesc~"failed"
» Tags: NOC, Fabric
» Custom message: ${logdesc} on: ${devname} with message: ${msg}
Rule 7: Security fabric settings change detected
¢ Event Severity: Medium
e Log Type: Event > System
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

* Jogdesc=="Settings modified by Security Fabric service" OR
logdesc=="Looped configuration in Security Fabric service" OR
logdesc=="Connection with CSF member established and authorized"
OR logdesc=="Connection with authorized CSF member terminated"
OR logdesc=="Serial number of upstream is changed”

e Tags: NOC, Fabric
» Custom message: Device: ${devname} change with message: ${msg}

Default-NOC-System-Events Event handler for FortiGate device type logs to generate events for system events
including Power failure and device shutdown, High Resource usage (CPU, Mem,
Storage), log device full status warnings and disk rolled, and devices
entering/exiting conserve mode.

Disabled by default
Rule 1: Device shutdown detected
e Event Severity: Critical
e Log Type: Event > System
¢ Group by: Device Name, Log Description
» Log messages that match all of the following conditions:
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¢ Jogdesc="Device shutdown"
e Tags: NOC, System, Power, CPU, Memory, Storage
» Custom message: ${devname} experienced $logdesc with message: ${msg}

Rule 2: Device conserve mode detected
» Event Severity: High

e Log Type: Event > System
» Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
* Jogdesc=="conserve mode"
e Tags: NOC, System, Power, CPU, Memory, Storage
» Custom message: ${logdesc} on Device: ${devname} with message ${msg}

Rule 3: Disk or memory is full
e Event Severity: High
e Log Type: Event > System
¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:

e logdesc=="Disk log full over first warning" OR logdesc=="Memory log
full over first warning level" OR logdesc=="Memory log full over second
warning level” OR logdesc=="Memory log full over final warning level"
OR logdesc=="Disk full" OR logdesc=="Disk log rolled”" OR
logdesc=="Log disk full"

e Tags: NOC, System, Power, CPU, Memory, Storage
» Custom message: Device: ${devname} ${logdesc} with message: ${msg}

Rule 4: Device high CPU consumption detected
» Event Severity: High

e Log Type: Event > System

« Group by: Device Name, Log Description

¢ Log messages that match all of the following conditions:
e cpu>="80"

e Tags: NOC, System, Power, CPU, Memory, Storage

» Custom message: ${devid} performance cpu: ${cpu}

Rule 5: Device high memory consumption detected
» Event Severity: Medium

e Log Type: Event > System
e Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
s mem>="75"
e Tags: NOC, System, Power, CPU, Memory, Storage
» Custom message: ${devid} performance memory: ${memory}
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Default-NOC-VPN-Events Event handler for FortiGate device type logs to generate events for VPN status
changes including IPsec Phase1 error or failure, and Phase2 Up/Down and
errors, Ipsec Tunnel Up/Down, VPN SSL login failures, IPSec ESP Error, IPsec
DPD failures

Disabled by default

Rule 1: User SSL VPN login failed
» Event Severity: High

¢ Log Type: Event>VPN

¢ Group by: Device Name, End User

¢ Log messages that match all of the following conditions:
¢ logid=="0101039426" and action=="ssl-login-fail"

e Tags: NOC, VPN

« Custom message: ${logdesc} due to: ${reason}

Rule 2: IPsec phase 1 error or status fail detected
e Event Severity: High

* Log Type: Event> VPN
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:

* (logid=="0101037124"OR logid=="0101037120") and
(logdesc=="IPsec phase 1 error" OR status="fail")

e Tags: NOC, VPN
» Custom message: ${logdesc} due to: ${status} with reason: ${reason}
Rule 3: IPsec ESP error detected
e Event Severity: High
* Log Type: Event> VPN
¢ Group by: Device Name, Message
» Log messages that match all of the following conditions:
e Jlogid=="0101037131"and logdesc=="IPsec ESP"
e Tags: NOC, VPN
» Custom message: ${status} on: ${devname}, ${error num}
Rule 4: IPsec DPD failed
¢ Event Severity: High
* Log Type: Event>VPN
¢ Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
¢ Jogid=="0101037136" and logdesc=="IPsec DPD failed"
e Tags: NOC, VPN
» Custom message: ${msg} on device: ${devname}

Rule 5: Device tunnel-up or tunnel-down detected
» Event Severity: High

e Log Type: Event>VPN
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¢ Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ Jogid="0101037138" and (action="tunnel-up" or action= "tunnel-down")
e Tags: NOC, VPN
» Custom message: ${msg} due to: ${action}
Rule 6: IPsec phase 2 error detected
» Event Severity: High
e Log Type: Event>VPN
¢ Group by: Device Name, Message
¢ Log messages that match all of the following conditions:
* logid=="0101037125"and logdesc=="IPsec phase 2 error"
e Tags: NOC, VPN
» Custom message: ${logdesc} due to: ${reason}
Rule 7: Device phase2-up or phase2-down detected
« Event Severity: Medium
e Log Type: Event>VPN
e Group by: Device Name, Message
¢ Log messages that match all of the following conditions:

¢ Jogid=="0101037139" and (action=="phase2-up" OR action=="phase2-
down")

e Tags: NOC, VPN
« Custom message: ${logdesc} due to: ${action}

Default-NOC-SD-WAN-Events = Event handler for FortiGate device type logs to generate events for SD-WAN
status, alerts, and health check events including SLA targets/SLA met or not met
for jitter, latency, packetloss, Health-check server status (alive or dead), status
(up or down), and member status change.

Disabled by default
Rule 1: SLA failed for jitter
« Event Severity: High
e Log Type: Event > SD-WAN
e Group by: Device Name, Health Check
¢ Log messages that match all of the following conditions:
e subtype=="sdwan" AND metric=="jitter" AND msg~"SLA failed"
e Tags: NOC, SD-WAN
» Custom message: On ${devname} the SLA for the ${healthcheck} failed for
${metric} with the current value of ${jitter} which violates the target ID
${slatargetid}.
Rule 2: SLA failed for latency
« Event Severity: High
e Log Type: Event > SD-WAN
e Group by: Device Name, Health Check
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¢ Log messages that match all of the following conditions:
e subtype=="sdwan" AND metric=="latency" AND msg~"SLA failed"
e Tags: NOC, SD-WAN
» Custom message: On ${devname} the SLA for the ${healthcheck} failed for
${metric} with the current value of ${latency} which violates the target ID
${slatargetid}.
Rule 3: SLA failed for packetloss
e Event Severity: High
e Log Type: Event> SD-WAN
e Group by: Device Name, Health Check
¢ Log messages that match all of the following conditions:
e subtype=="sdwan" AND metric=="packetloss" AND msg~"SLA failed"
e Tags: NOC, SD-WAN
» Custom message: On ${devname} the SLA for the ${healthcheck} failed for
${metric} with the current value of ${packetloss} which violates the target ID
${slatargetid}.
Rule 4: Device status changed to die
e Event Severity: Medium
e Log Type: Event> SD-WAN
e Group by: Device Name, Log Description
¢ Log messages that match all of the following conditions:
¢ logid="0113022925" AND newvalue="die"
e Tags: NOC, SD-WAN
» Custom message: Device: ${devname} with status ${newvalue}. ${msg}.

Rule 5: Device status changed to alive.
¢ Event Severity: Medium

* Log Type: Event > SD-WAN
¢ Group by: Device Name, Log Description
» Log messages that match all of the following conditions:
¢ Jlogid="0113022925" AND newvalue="alive"
e Tags: NOC, SD-WAN
» Custom message: Device: ${devname} with status ${newvalue}. ${msg}.
Rule 6: Device status is up
¢ Event Severity: Medium
e Log Type: Event > SD-WAN
e Group by: Device Name, Health Check
¢ Log messages that match all of the following conditions:
e logid="0113022925" AND status=="up"
e Tags: NOC, SD-WAN
» Custom message: Device: ${devname} ${msg} status is ${status}.
Rule 7: Device status is down
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Default-NOC-Docker-Events
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Event Severity: Medium
Log Type: Event > SD-WAN
Group by: Device Name, Health Check
Log messages that match all of the following conditions:
¢ logid="0113022925" AND status=="down"
Tags: NOC, SD-WAN
Custom message: Device: ${devname} ${msg} status is ${status}.

Rule 8: Number of pass member changed

Event Severity: Medium
Log Type: Event > SD-WAN
Group by: Device Name, Log Description
Log messages that match all of the following conditions:
¢ logid="0113022923" AND msg="Number of pass member changed.”
Tags: NOC, SD-WAN
Custom message: ${msg} from ${oldvalue} to ${newvalue} for ${devname}

Rule 9: Member status changed

Event Severity: Medium

Log Type: Event > SD-WAN

Group by: Device Name, Log Description

Log messages that match all of the following conditions:

* Jogid="0113022923" AND msg="Member status changed. Member out-
of-sla."

Tags: NOC, SD-WAN
Custom message: ${msg}. Member is now ${member} on ${devname}.

Event handler for FortiGate device type logs to generate events for Docker
including inlcuding container enabled/disabled, CPU value set/max reached and
MEM value set/max reached

Disabled by default

Rule 1: Memory report detected

Event Severity: Medium
Log Type: Event
Group by: Type, Subtype
Log messages that match all of the following conditions:
¢ Jog_id=="0042010266" and msg~"MEM"
Tags: NOC, Docker
Custom message: Device ${devname} with message ${msg}.

Rule 2: CPU report detected

Event Severity: Medium
Log Type: Event
Group by: Type, Subtype
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Log messages that match all of the following conditions:
e Jog_id=="0042010266"and msg~"CPU"
Tags: NOC, Docker
Custom message: Device ${devname} with message ${msg}.

Rule 3: Status changed to disable 1

Event Severity: Medium
Log Type: Event
Group by: Type, Subtype
Log messages that match all of the following conditions:
¢ Jog _id="0001010026" and changes~"status=disable"
Tags: NOC, Docker
Custom message: Device ${devname} with changes ${changes}.

Rule 4: Status changed to disable 2

Event Severity: Medium
Log Type: Event
Group by: Type, Subtype
Log messages that match all of the following conditions:
e Jog id="0001010026" and changes~"status=disable"
Tags: NOC, Docker
Custom message: Device ${devname} with changes ${changes}.

Below are examples of raw logs that would trigger the associated default event handler.

Default Event Handler Example Log

1d=6872390755323740160 itime=2020-09-14 10:06:03 euid=1 epid=1
dsteuid=1 dstepid=1 log 1d=0034043006 subtype=logdb type=event
level=warning time=10:06:03 date=2020-09-14 user=system

Local Device Event

Default-Compromised Host-
Detection-by IOC-By-Threat

action=delete msg=Requested to trim database tables older than

60 days to enforce the retention policy of Adom root.
userfrom=system desc=Trim local db devid=FAZ-VMTM20001572
devname=FAZ-VMTM20001572 dtime=2020-09-14 10:06:03 itime
t=1600103163

date=2020-09-20 time=07:41:20 1d=6874471739997290516
itime=2020-09-20 00:41:20 euid=3 epid=1161 dsteuid=3
dstepid=101 type=utm subtype=ips level=warning
sessionid=917509475 policyid=2 srcip=172.16.93.164
dstip=5.79.68.109 srcport=51392 dstport=80 proto=6
10gid=0421016399 service=HTTP eventtime=1537181449 crscore=30
crlevel=high srcintfrole=lan dstintfrole=wan

direction=outgoing url=/ hostname=survey-smiles.com

profile=default eventtype=malicious-url srcintf=95-FortiCloud
dstintf=0SPF msg=URL blocked by malicious-url-list
devid=FG100D3G02000011 vd=root dtime=2020-09-20 07:41:20
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itime t=1600587680 devname=FG100D3G02000011

Default-Risky-App-Detection-  date=2020-09-20 time=07:41:23 1d=6874471752882192399

By-Threat itime=2020-09-20 00:41:23 euid=3 epid=1201 dsteuid=3
dstepid=101 type=utm subtype=app-ctrl level=information
action=pass sessionid=3003333495 policyid=79
srcip=172.16.80.218 dstip=122.195.166.40 srcport=38625
dstport=26881 proto=6 1logid=1059028704 service=tcp/26881
eventtime=1537399002 incidentserialno=603516169 crscore=5
crlevel=low direction=outgoing apprisk=high appid=6
srcintfrole=lan dstintfrole=wan applist=scan appcat=P2P
app=BitTorrent eventtype=app-ctrl-all srcintf=80-software-r
dstintf=port7 msg=P2P: BitTorrent HTTP.Track,
devid=FG100D3G02000011 vd=root dtime=2020-09-20 07:41:23
itime t=1600587683 devname=FG100D3G02000011

Default_ NOC_Routing_Events date=2021-02-08 time=10:36:09 eventtime=1612809370040652208
tz="-0800" logid="0103027001" type="event" subtype="router"
level="information" vd="root" logdesc="VRRP state changed"
interface="portl" msg="VRRP vrid 200 vrip 172.17.200.200
changes state from Master to Backup due to ADVERTISEMENT with

higherer priority received"

FortiOS system events

FortiOS predefined system event handlers are consolidated into a single event handler with multiple rules called Default
FOS System Events.

Events are organized by device in the FortiSoC/Incidents & Events dashboards, which can be expanded to view all
related events.

Default FOS System Events rules apply tags to each event, allowing you to identify which Default FOS System Events
rule triggered the event.

\ﬂ If you are upgrading from a version before FortiAnalyzer 6.2.0, the existing legacy predefined

handlers which are enabled or have been modified will be available as custom handlers. In the
Event Handler List, select the More dropdown and choose Show Custom.

Predefined correlation handlers

FortiAnalyzer includes some predefined correlation event handlers that you can use to generate events.

If you wish to recieve notifications from a pedefined correlation handler, configure a notification profile and assign it to the
correlation handler. See Creating notification profiles on page 167.
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To view predefined event handlers in the FortiAnalyzer GUI, go to FortiSoC/Incidents & Events > Handlers > Correlation
Handler List. From the More dropdown, select Show Predefined.

The following predefined correlation handlers are available:

Event Handler Description

Default-Brute-Force-Account-  This handler is to detect if an account login failed many times not followed by a
Login-Attack-FAZ login success for FortiAnalyzer.

Disabled by default

Event Severity: Medium

Tags: login, attack

Threshold Duration: 30 minutes
Correlation Sequence:

Login Failed 5 Times

Log Device Type FortiAnalyzer

Log Type Event Log

Group By Device ID

Log messages that Operation Equal To login failed

match any of the
following conditions:

Aggregate COUNT >=5
Expression:

NOT_FOLLOWED_BY, within 5m

Login Success

Log Device Type FortiAnalyzer

Log Type Event Log

Group By Device ID

Log messages that Operation Equal To login

match any of the
following conditions:

Aggregate COUNT >=1
Expression:

Correlation Criteria:
* Login Failed 5 Times devid = Login Success devid

Default-Brute-Force-Account-  This handler is to detect if an account login failed many times not followed by a
Login-Attack-FGT login success for FortiGate.

Disabled by default

Event Severity: Medium

Tags: login, attack
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Threshold Duration: 30 minutes

Correlation Sequence:

Login Failed 5 Times

Log Device Type
Log Type
Group By

Log messages that
match any of the
following conditions:

Aggregate
Expression:

FortiGate
Event Log > System
Device ID

Log ID Equal To 0100032002

COUNT >=5

NOT_FOLLOWED_BY, within 5m

Login-Success
Log Device Type
Log Type
Group By

Log messages that
match any of the
following conditions:

Aggregate
Expression:

Correlation Criteria:

FortiGate
Event Log > System
Device ID

Log ID Equal To 0100032001

COUNT >=1

e Login Failed 5 Times devid = Login-Success devid

Default-Suspicious-Traffic- This handler is to detect if an endpoint is infected and there is a large traffic from
From-Infected-Endpoint the same endpoint.
Disabled by default

Event Severity: Medium

Tags: CnC

Threshold Duration: 30 minutes

Correlation Sequence:

Logic Group 1

Traffic to Botnet CnC detected or blocked in virus log
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Log Device Type

FortiGate
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Traffic to Botnet CnC detected or blocked in virus log

Log Type Antivirus

Group By Source Endpoint

Log messages that
match any of the
following conditions:

* Log ID Equal To 0202009248
¢ Log ID Equal To 0202009249

Aggregate COUNT >=1

Expression:

Traffic to CnC detected

‘.
Py

Log Device Type FortiGate

Log Type Traffic Log > Any
Group By Source Endpoint
Log messages that tdtype~infected
match any of the

following conditions:

Aggregate COUNT >=1
Expression:

‘.
Py

Web traffic to CnC detected

Log Device Type FortiGate
Log Type Web Filter
Group By Source Endpoint

Log messages that
match any of the
following conditions:

tdtype~infected

Aggregate COUNT >=1

Expression:

DNS traffic to CnC detected

‘.
Py

Log Device Type FortiGate
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DNS traffic to CnC detected

Log Type DNS Log
Group By Source Endpoint

Log messages that tdtype~infected
match any of the
following conditions:

Aggregate COUNT >=1
Expression:

FOLLOWED_BY, within 15m

Logic Group 2
Log Device Type FortiGate
Log Type Traffic Log > Any
Group By Source Endpoint

Log messages that
match any of the
following conditions:

Aggregate SUM sentbyte >= 100 Mega Byte
Expression:

Correlation Criteria:
« Traffic to Botnet CnC detected or blocked in virus log endpoint = Traffic to
CnC detected endpoint

 Traffic to CnC detected endpoint = Web traffic to CnC detected endpoint
* Web traffic to CnC detected endpoint = DNS traffic to CnC detected endpoint
e DNS traffic to CnC detected endpoint = Traffic from endpoint endpoint

Creating data selectors

Data selectors are used to select devices, subnets, and filters for event handlers. You can create, edit, clone, and delete
data selectors in FortiSoC/Incidents & Events > Handlers > Data Selector List.

To assign a data selector to a basic event handler, see Creating a custom event handler on page 168.

To assign a data selector to a correlation handler, see Creating a custom correlation handler on page 171.

This means the filter criteria does not need to be added individually within each rule of the

s‘é’, The filters in the data selector are applied before every rule configured in the event handler.
3 event handler(s) that the data selector is assigned to.
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There are five default data selectors:

Default Intrusion Selector For Malicious Code Detection

Default IP Scanning Selector For Recon Activity Detection

Default Local Device Selector

Default Malicious File Selector For Malicious File Detection
Default Risky App Selector for Risky App Detection

These default data selectors are used in some of the predefined handlers, and they cannot be edited or deleted.

To create a data selector:

1.

2. Click Create New.

Go to FortiSoC/Incidents & Events > Handlers > Data Selector List.

The Add New Data Selector pane displays.
3. Configure the following options, and click OK to save the data selector.

Option Description

Name

Devices

Subnets

Filters

Name
Log Device Type
Log Type

Log Subtype

Logs match
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Enter a name for the data selector.

Select one of the following:

» All Devices.

e Specify: Select the devices to include.

» Local Device: Select if the event handler is for local FortiAnalyzer
event logs. This option is only available in the root ADOM and is
used to query FortiAnalyzer event logs.

For Local Device, the Log Type must be Event Log and Log
Subtype must be Any.

Select All Subnets to include all subnets, or select Specify to choose
which subnet(s) or subnet group(s) will be included or excluded from
triggering events. For more information, see Subnets on page 117.

Click plus (+) to insert a new filter in the list. The Filter dialog displays.
Configure the options and click OK to save.

To delete a filter from the list, click the x next to the filter.
Enter a name for the filter.
Select the device type from the dropdown.

Select a log type from the dropdown. The log types will vary depending
on the device type.

Select a log subtype from the dropdown. The log subtype is not available
for all device types.

Select All or Any of the following conditions.

Click plus (+) to insert a new condition. You can insert multiple
conditions.

Configure the condition(s):
e Log Field: Select a log field from the dropdown.
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e Match Criteria: Select an operator from the dropdown.
» Value: Select the event type from the dropdown.
To delete a condition, click the delete icon next to the condition.

Generic Text Filter (Optional) Enter a filter string. For more information, see Using the
Generic Text Filter on page 177.

Creating notification profiles

Notification profiles are used to send alert notifications when an event is generated by an event handler. You can
configure the notification profile to send the alert to an email address, SNMP community, and/or syslog server. You can
also configure the notification profile to send the alert through a fabric connector.

You can create, edit, clone, and delete notification profiles in FortiSoC/Incidents & Events > Handlers > Notification
Profile List.

To assign a notification profile to a basic event handler, see Creating a custom event handler on page 168.

To assign a notification profile to a correlation handler, see Creating a custom correlation handler on page 171.

To create a notification profile:

1. Goto FortiSoC/Incidents & Events > Handlers > Notification Profile List.
2. Click Create New.
The Add New Notification Profile pane displays.

3. Configure the following options, and click OK to save the notification profile.

Option Description

Name Enter a name for the notification profile.
Send Alert through Fabric Send an alert through one or more fabric connectors selected from the
Connectors dropdown. Click the plus (+) to add fabric connectors. For more information,

see Fabric Connectors on page 112.

Send Alert Email Send an alert to one or more email addresses. Specify the email parameters,
including the mail server. For more information, see Mail Server on page 333.

To Enter the email address(es) to send the alert to. Use a semicolon (;) to
separate multiple email addresses.

From Enter a from address for the alert email.
Subject Enter a subject line for the alert email.
Email Server Select the mail server for the alert email.
Send SNMP(...) Trap Send an alert to an SNMP community or user selected from the dropdown. For

more information, see SNMP on page 324.
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Send Alert to Syslog Server Send an alert to the syslog server selected from the dropdown. For more
information, see Syslog Server on page 334.

Send Each Alert Separately Enable to send each alert individually instead of in a group.

Creating a custom event handler

You can create a custom event handler from scratch or clone a predefined event handler and customize its settings. See
Cloning event handlers on page 178.

Configuring an event handler includes defining the following main sections in the GUI:

Option Description

Event handler attributes The status, name, description, data selector, and automation stitch for the event
handler.
Rules The rules for event generation.

e Select the log types and subtypes to limit the logs that trigger an event.

» Group the logs by primary and secondary (optional) values to separate the
events that are generated for different Group By values.

« Set the number of occurrences within a time frame that triggers an event.

¢ Configure event fields, such as event status and severity.

Handler Settings The notification profile for the event handler.
Add New Basic Event Handler x

Status ©

Name™

Description

Data Selector Click to select v

Automation Stitch o )

Rules

Add New Rule
Handler Settings
Notifications Click to select v
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To create a new event handler:

1. Goto FortiSoC/Incidents & Events > Handlers > Event Handler List.
2. Inthe toolbar, click Create New.
The Add New Basic Event Handler pane displays.

3. Configure the following options, and click OK to save the event handler.

Option Description

Status Enable or disable the event handler.
Enabled event handlers show a O icon in the Status column. Disabled event

handlers show a @ icon in the Status column.

Name Enter a name for the event handler.
Description (Optional) Enter a description for the event handler.
Data Selector Select a data selector for the event handler.

This selects devices, subnets, and filters used for the event handler. See
Creating data selectors on page 165.

Automation Stitch Enable or disable automation stitch.

When enabled, FortiAnalyzer sends a notification to FortiGate when events
are generated by the event handler. The events are available in the
FortiAnalyzer GUI as well. For more information, see Using the Automation
Stitch for event handlers on page 176.

Rules

Add New Rule Click to add a rule. The Add New Rule pane displays. Configure the options
below, and then click OK to save the rule.

You can add multiple rules to the event handler. Each rule has an OR
relationship with other rules enabled in the event handler.

Status Enable or disable the rule. If the rule is disabled, it will not be used to generate
events.

Name Enter a name for the rule.

Log Device Type If you are in a Security Fabric ADOM, select the log device type from the
dropdown list. If you are not in a Security Fabric ADOM, you cannot change
the Log Device Type.

The Fabric log device type can be used to generate alerts from SIEM logs
when SIEM logs are available.

Log Type Select the log type from the dropdown list.
When Devices is set to Local Device, you cannot change the Log Type or Log
Subtype.

Log Subtype Select the category of event that this event handler monitors. The available
options depend on the platform type.
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Option Description

This option is only available when the Log Type has a subtype. For example,
Event Log and Traffic Log have log subtypes which can be selected from the
dropdown.

Group By

Logs match

Generic Text Filter

Aggregate
Expression
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Select how to group the events. Click Add beside the Group By field to add up
to two additional Group By fields, to a maximum of three.

Select All or Any of the following conditions.

Click plus (+) to insert a new condition. You can insert multiple conditions.

Configure the condition(s):

Log Field: Select a log field from the dropdown.

After the log device and log type are selected, the Log Field dropdown list
will only include log fields that belong to the specified log type. For
example, the Botnet IP log field is available when the Log Type is DNS,
but not available when the Log Type is Event Log.

Match Criteria: Select an operator from the dropdown. The available
options depends on the selected log field.

Some log fields, such as Source Port, will provide a variety of operators in
the dropdown list, such as Equal To, Not Equal To, Greater Than or Equal
To, Less Than or Equal To, Greater Than, and Less Than.

Other log fields, such as Log Description, will be limited to Equal To and
Not Equal To.

Value: Select a value from the dropdown list or enter a value in the text
box. The available options depends on the selected log field.

If there is no dropdown list provided by FortiAnalyzer, you must manually
enter a value to find in the raw log.

If a dropdown list is provided, you can select a value from the list. For
some log fields, such as Level, the dropdown list also allows you to enter
a custom value. If there is no textbox to enter a custom value in the
dropdown list, you must use the Generic Text Filter instead.

To delete a condition, click the x next to the condition.

Enter a generic text filter. See Using the Generic Text Filter on page 177.

For information on text format, hover the cursor over the help icon. The
operator ~ means contains and ! ~ means does not contain.

Enter the minimum threshold for the rule.

COUNT: enter the minimum count threshold.

COUNT_DISTINCT: select the field that must be distinct, such as Source
IP or Application, and enter the minimum count threshold.

SUM: select the measure, and enter the minimum sum threshold.

Ay
‘Q' The SUM option is used for data exfiltration detection. This
- option is only supported in Fabric ADOMs.
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Option Description

Aggregate
Duration

Event Type
Override

Event Message

Event Status

Event Severity

Tags

Indicators

Additional Info

Handler Settings

Notifications

Enter the minimum threshold in minutes to generate events.

This option works together with the Aggregate Expression. Enter the number
of matching logs (Aggregate Expression) that must occur in the number of
minutes (Aggregate Duration) to generate an event.

Specify a custom event type, or leave this field blank to use the default value.

(Optional) Enter a custom event message.

The default message is the Group By value. You can use variables in the
event message.

Select Allow FortiAnalyzer to choose or select a status from the dropdown list:
Unhandled, Mitigated, Contained, (Blank). You can use a custom event status
by clicking the plus (+) that appears in the Event Status dropdown.

Event statuses, including custom statuses, are displayed in the Event Status
column in the Event Monitor.

Select the severity from the dropdown list: Critical, High, Medium, or Low.

(Optional) Enter custom tags.
Tags can be used as a filter when using default or custom views.

(Optional) Add indicators by clicking the plus (+). You can configure the Log
Field, Indicator Type, and Count for each indicator created in an event
handler. Use the buttons in the Action column to add (+) or remove (x)
indicators. Up to five indicators can be created.

When Indicators is selected in Event Monitor > Display Options, the Indicators
column displays indicator types for detected events. You can see additional
details when clicking on an indicator. See Events on page 181

If an incident is raised from an event that includes indicators, they can be
viewed in the Indicators tab of the incident analysis page. See Analyzing an
incident on page 190.

Specify what to show in the Additional Info column of the Event Monitor.
Select Use system default or Use custom message. A custom message can
include variables and log field names. For more information, hover over the
help icon.

Select a notification profile for the event handler. See Creating notification
profiles on page 167.

Creating a custom correlation handler

You can create a custom correlation handler from scratch or clone a predefined correlation handler and customize its
settings. See Cloning event handlers on page 178.
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Configuring an correlation handler includes defining the following main sections in the GUI:

Option Description

Correlation event handler
attributes

Correlation Sequence

Correlation Criteria

Handler Settings

/Add New Correlation Event Handler

Status
Name

Description

Automation Stitch
Data Selector

Threshold Duration €

Correlation Sequence

o

>
Click to select

30

e Corsatonoro |

Show Raw Config

Correlation Criteria

Rule

@

Field Match Criteria

Rule

Field

The name, description, data selector, and automation stitch for the correlation
handler.

This section also includes the threshold duration for the handler.

The rules for event generation in sequence and logic group.
» Select the log types and subtypes to limit the logs that trigger an event.
¢ Group the logs by primary and secondary (optional) values to separate the
events that are generated for different Group By values.
¢ Set the number of occurrences that can trigger an event.

The correlation criteria to specify the type of logs that the event handler will look
for. The criteria is applied to two rules on a field from each rule.

The event fields, including the event type override, event message, event status,
event severity, indicators, and tags.

This section also includes the notification profile for the correlation handler.

Action

Handler Settings

Event Type Override
Event Message @

Event Status
Event Severity
Togs

Indicators @

Additional Info

Notifications

Specify an event type, or leave blank to use default value

Allow FortiAnalyzer to choose

Medium

Log Field Indicator Type

Count.

Action

® Use system default

O Use custom message @

Click to select
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To create a new correlation event handler:

1. Goto FortiSoC/Incidents & Events > Handlers > Correlation Handler List.

2. Inthe toolbar, click Create New.

The Add New Correlation Event Handler pane displays.

3. Configure the following options, and click OK to save the correlation event handler.

Option Description

Status

Name
Description

Automation Stitch

Data Selector

Threshold Duration

Correlation Sequence

Add Rule

Name

FortiAnalyzer 7.2.2 Administration Guide
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Enable or disable the event handler.

Enabled event handlers show a O icon in the Status column. Disabled event

handlers show a @ icon in the Status column.

Enter a name for the event handler.

(Optional) Enter a description for the event handler.

Enable or disable automation stitch.

When enabled, FortiAnalyzer sends a notification to FortiGate when events
are generated by the event handler. The events are available in the
FortiAnalyzer GUI as well. For more information, see Using the Automation
Stitch for event handlers on page 176.

Select a data selector for the event handler.

This selects devices, subnets, and filters used for the event handler. See
Creating data selectors on page 165.

Enter the threshold duration for the correlation handler in minutes.

The logs must match the criteria in correlation sequence within this time to
generate an event.

Click the icon to add a rule. The Add New Rule pane displays. Configure the
options below and click OK to save the rule.

After creating the rules, make sure they are in the correct correlation
sequence. You can drag and drop the rules to re-order them, if needed.

Select the correlation between each of the rules:

AND

AND_NOT

OR

FOLLOWED_BY (if selected, enter a time limit for the correlation to occur
in)

NOT_FOLLOWED_BY (if selected, enter a time limit for the correlation to
occurin)

The rules must be met in the correlation sequence for the event handler to
generate an event.

Enter a name for the rule.
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Option Description

Log Device Type If you are in a Security Fabric ADOM, select the log device type from the
dropdown list. If you are not in a Security Fabric ADOM, you cannot change
the Log Device Type.

The Fabric log device type can be used to generate alerts from SIEM logs
when SIEM logs are available.

Log Type Select the log type from the dropdown list.
When Devices is set to Local Device, you cannot change the Log Type or Log
Subtype.

Log Subtype Select the category of event that this event handler monitors. The available

options depend on the platform type.

This option is only available when the Log Type has a subtype. For example,
Event Log and Traffic Log have log subtypes which can be selected from the
dropdown.

Group By Select how to group the events. Click Add beside the Group By field to add up
to two additional Group By fields, to a maximum of three.

Logs match Select All or Any of the following conditions.
Click plus (+) to insert a new condition. You can insert multiple conditions.

Configure the condition(s):
* Log Field: Select a log field from the dropdown.
After the log device and log type are selected, the Log Field dropdown list
will only include log fields that belong to the specified log type. For
example, the Botnet IP log field is available when the Log Type is DNS,
but not available when the Log Type is Event Log.

« Match Criteria: Select an operator from the dropdown. The available
options depends on the selected log field.
Some log fields, such as Source Port, will provide a variety of operators in
the dropdown list, such as Equal To, Not Equal To, Greater Than or Equal
To, Less Than or Equal To, Greater Than, and Less Than.
Other log fields, such as Log Description, will be limited to Equal To and
Not Equal To.

¢ Value: Select a value from the dropdown list or enter a value in the text
box. The available options depends on the selected log field.
If there is no dropdown list provided by FortiAnalyzer, you must manually
enter a value to find in the raw log.
If a dropdown list is provided, you can select a value from the list. For
some log fields, such as Level, the dropdown list also allows you to enter
a custom value. If there is no textbox to enter a custom value in the
dropdown list, you must use the Generic Text Filter instead.

To delete a condition, click the x next to the condition.

Generic Text Filter Enter a generic text filter. See Using the Generic Text Filter on page 177.

For information on text format, hover the cursor over the help icon. The
operator ~ means contains and ! ~ means does not contain.
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Option Description

Aggregate Enter the minimum threshold for the rule.
Expression ¢ COUNT: enter the minimum count threshold.
e« COUNT_DISTINCT: select the field that must be distinct, such as Source
IP or Application, and enter the minimum count threshold.
e SUM: select the measure, and enter the minimum sum threshold.

iy
‘Q' The SUM option is used for data exfiltration detection. This
- option is only supported in Fabric ADOMSs.

Add Logic Group Add a logic group.

You must select a correlation between groups (AND, AND_NOT, OR,
FOLLOWED_BY, or NOT_FOLLOWED_BY). All groups must be metin
correlation sequence for the correlation event handler to generate an event.

Show Raw Config Enable to display the raw config of the correlation sequence.

Edits made to the raw config will appear above in the correlation sequence
fields. If there is an error in the text, the fields will not display and you will not
be able to save the changes.

Correlation Criteria Specify the fields that the event handler will look for to correlate the rules.
Each correlation criteria is applied to two rules, using a field from each rule.
Configure the following options for each correlation criteria:
e Rule: Select two rules to create a correlation criteria for.
» Field: Select a field for each rule in the correlation criteria. The fields
available in the dropdown are determined by the Group By field in the
rule.

» Match Criteria: Select an operator from the dropdown. The available
options depends on the selected fields.

Use the buttons in the Action column to add (+) or remove (x) correlation

criteria.
Handler Settings
Event Type Override Specify a custom event type, or leave this field blank to use the default value.
Event Message (Optional) Enter a custom event message.

The default message is the Group By value. You can use variables in the
event message.

Event Status Select Allow FortiAnalyzer to choose or select a status from the dropdown list:
Unhandled, Mitigated, Contained, (Blank). You can use a custom event status
by clicking the plus (+) that appears in the Event Status dropdown.

Event statuses, including custom statuses, are displayed in the Event Status
column in the Event Monitor.

Event Severity Select the severity from the dropdown list: Critical, High, Medium, or Low.
Tags (Optional) Enter custom tags.
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Option Description

Tags can be used as a filter when using default or custom views.

Indicators (Optional) Add indicators by clicking the plus (+). You can configure the Log
Field, Indicator Type, and Count for each indicator created in an event
handler. Use the buttons in the Action column to add (+) or remove (x)
indicators. Up to five indicators can be created.
When Indicators is selected in Event Monitor > Display Options, the Indicators
column displays indicator types for detected events. You can see additional
details when clicking on an indicator. See Events on page 181
If an incident is raised from an event that includes indicators, they can be
viewed in the Indicators tab of the incident analysis page. See Analyzing an
incident on page 190.

Additional Info Specify what to show in the Additional Info column of the Event Monitor.

Select Use system default or Use custom message. A custom message can
include variables and log field names. For more information, hover over the
help icon.

Notifications Select a notification profile for the event handler. See Creating notification
profiles on page 167.

Using the Automation Stitch for event handlers

All FortiGates added to FortiAnalyzer use a default event handler on the FortiAnalyzer side to receive high severity
events such as Botnet Communication, IPS Attack Pass Through, and Virus Pass Through AntiVirus. This basic event
handler, Default-Botnet-Communication-Detection, has automation stitch enabled in FortiAnalyzer.

Automation Stitch can also be enabled for any custom event handler. See Creating a custom event handler on page 168
and Creating a custom correlation handler on page 171.

To determine if an event handler has automation stitch enabled, review the Automation Stitch column in
FortiSoC/Incidents & Events > Handlers > Event Handler List and FortiSoC/Incidents & Events > Handlers > Correlation
Handler List.

When an event is generated by a handler with automation stitch enabled, FortiAnalyzer sends a notification to the
FortiGate automation framework. If an automation stitch is configured on the FortiGate, the notification will trigger the
related automation stitch and activate an action in response. For example, the FortiGate could send a custom email
notification, execute a CLI script, and/or perform a system action in response to the trigger. For more information about
automation stitches, including their triggers and actions, see the FortGate/FortiOS Administration Guide.

The events generated by handlers with the automation stitch enabled can also be viewed in the FortiAnalyzer GUI
through FortiSoC/Incidents & Events > Event Monitor.
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To receive the notifications from FortiAnalyzer on the FortiGate device, you must configure
FortiAnalyzer logging on the FortiGate device.

NP To use the notifications as part of an automation stitch, you must configure a trigger on the
‘?' FortiGate device for each event handler that has automation stitch enabled. This includes the
- predefined event handlers with automation stitch enabled, such as Default-Botnet-

Communication-Detection.

For more information about configuring FortiAnalyzer logging and automation stitch triggers,
see the FortiGate/FortiOS Administration Guide.

Using the Generic Text Filter

The Generic Text Filter field is available when creating filters for data selectors and rules for event handlers.

The Generic Text Filter uses the glibc regex library for values with operators (~,!~), using the POSIX standard. Filter
string syntax is parsed by FortiAnalyzer, and both upper and lower case characters are supported (for example, "and" is
the same as "AND"). You must use an escape character when needed. For example, cfgpath=firewall.policyis
the wrong syntax because it is missing an escape character. The correct syntax is cfgpath=firewall\.policy.

To create an event handler using the Generic Text Filter to match raw log data:

1.
2,

Go to Log View, and select a log type.

In the toolbar, click Tools > Display Raw.

The easiest method is to copy the text string you want from the raw log and paste it into the Generic Text Filter field.
Ensure you insert an escape character when necessary, for example, cfgpath=firewall\.policy.

Locate and copy the text in the raw log.

Go to FortiSoCl/Incidents & Events > Handlers > Event Handler List and click Create New.

Click Add New Rule.

You can also use the Generic Text Filter when creating a rule for a correlation handler. See Creating a custom
correlation handler on page 171.

In the Generic Text Filter box, paste the text you copied or type the text you want. Ensure you use the raw log field
names, for example, mem (not memory) and setuprate (not setup-rate).

For information on text format and operators, hover the cursor over the help icon. The operator ~ means contains
and ! ~ means does not contain.

Configure other settings for the rule, and click OK. For a description of the fields, see Creating a custom event
handler on page 168.

You can also use the Generic Text Filter in data selectors, which can be assigned to event handlers and correlation
handlers. For more information, see Creating data selectors on page 165.

Managing event handlers

To manage basic event handlers, go to FortiSoC/Incidents & Events > Handlers > Event Handler List.

To manage correlation event handlers, go to FortiSoC/Incidents & Events > Handlers > Correlation Handler List.

These panes list the predefined and custom event handlers. An icon in the Status column indicates if the event handler is
enabled or disabled.

The following options are available:
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Option Description

Create New Create a new event handler.

Edit Edit the selected event handler.

Some fields in predefined event handlers cannot be modified, such as the name,
description and filter settings. However, you can clone the predefined event
handler to create a custom event handler and modify its settings according to your
needs.

Delete Delete the selected event handler.
You cannot delete predefined event handlers.

Clone Clone the selected event handler.
You can clone a predefined event handler and modify it to create a custom event
handler.

Enable / Disable Enable or disable the selected event handler to start or stop generating events.

The current status is indicated by an icon in the Status column.

Generated events are displayed on the FortiSoC/Incidents & Events > Event
Monitor > All Events pane.

Show Predefined Show or hide predefined event handlers in the list.

Show Custom Show or hide custom event handlers in the list.

Import / Export Export the selected event handlers or import a event handler that you have
exported.
You can export event handlers and import them into another ADOM or
FortiAnalyzer.

Factory Reset If you have modified a predefined event handler, return the selected predefined

event handler to its factory default settings.

Enabling event handlers

For both predefined and custom event handlers, you must enable the event handler to generate events. The Event
Handler List and Correlation Handler List displays an icon to indicate which event handlers are enabled. The o icon

indicates enabled event handlers and the @ icon indicates disabled event handlers.

To enable event handlers:

1. Goto FortiSoC/Incidents & Events > Handlers > Event Handler List.
If enabling a correlation handler, go to FortiSoC/Incidents & Events > Handlers > Correlation Handler List.

2. Selectone or more event handlers and click More > Enable.
You can also right-click the event handler and select Enable.

Cloning event handlers

Cloning an event handler allows you to build a custom event handler by using an existing one as a template.
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Most attributes in a predefined event handler cannot be modified, such as the name, description, and rule settings. You
can, however, clone a predefined event handler to customize its settings and give it a meaningful name to show its
function.

To clone an event handler:

1. Goto FortiSoC/Incidents & Events > Handlers > Event Handler List.

If cloning a correlation handler, go to FortiSoC/Incidents & Events > Handlers > Correlation Handler List.
2. Selectan event handler and in the toolbar and click Clone.

You can also right-click the event handler and select Clone.

3. Configure the cloned event handler. For a description of the fields, see Creating a custom event handler on page
168 or Creating a custom correlation handler on page 171.

Use a descriptive name so it is not confused with the event handler it was cloned from.
4. Click OK save the cloned event handler.

Resetting predefined event handlers to factory defaults

You can change some settings in predefined event handlers as needed. If required, you can restore those predefined
event handlers to their factory default settings.

The Factory Reset option is only available for predefined event handlers that have been changed.

To reset predefined event handlers:

1. Goto FortiSoC/Incidents & Events > Handlers > Event Handler List.

If resetting a predefined correlation handler, go to FortiSoC/Incidents & Events > Handlers > Correlation Handler
List.

2. Inthe More menu, select Show Predefined.
3. Select one or more predefined event handlers and click More > Factory Reset.
You can also right-click the event handler and select Factory Reset.

If the predefined event handler has not been changed from the factory default settings, this option will be grayed-
out.

Importing and exporting event handlers

You can import and export event handlers. This feature allows you to develop custom event handlers and deploy themin
bulk to other ADOMs or FortiAnalyzer units. To do so, export the custom event handlers, and then import them into the
ADOMs or FortiAnalyzer units where you want them deployed. You can also export event handlers as part of your
backup procedure, if needed.

To export event handlers:

1. Goto FortiSoC/Incidents & Events > Handlers > Event Handler List.

If exporting a correlation handler, go to FortiSoC/Incidents & Events > Handlers > Correlation Handler List.
2. Selectthe event handler(s) to export, and click More > Export.

You can also right-click the event handler and select Export.
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‘+ Create New ‘ ‘E Edit ‘ ‘ﬁ[ Delete ]|=|. Clone | 3 More v Search... \
[ | Status| Name © Enable ‘ Rules n
@ Disable Rule-1 Outbreak Alert - Windows Installer Zero-Day Event-Handler-0: (Outbreak Windows Installer Zer
v © Outbreak Alert - Windows Installer Zero-D: Rule-2 Outbreak Alert - Windows Installer Zero-Day Event-Handler-1: (Outbreak,Windows Installer Zer

Show Predefined
Rule-3 Outbreak Alert - Windows Installer Zero-Day Event-Handler-2: (Outbreak Windows Installer Zer
® Show Cust

& Show Custom Rule-1 Outbreak Alert - Windows HTTP Protocol Stack RCE Event-Handle-0: (Outbreak Windows HTT
Rule-2 Outbreak Alert - Windows HTTP Protocol Stack RCE Event-Handle-1: (Outbreak Windows HTTF

O ©  OutbreakAlert - Windows HTTP Protocol s| 2 ImPort . i
Rule-3 Outbreak Alert - Windows HTTP Protocol Stack RCE Event-Handle-2: (Outbreak Windows HTTF

B Export
Rule-4 Outbreak Alert - Windows HTTP Protocol Stack RCE Event-Handle-3: (Outbreak Windows HTTF
C Factory Reset Rule-1 Traffic to Botnet CnC blocked in virus log: (Default,By_Endpoint,Botnet,IP,C&C) logid==0202009
Rule-2 Traffic to Botnet CnC detected in virus log: (Default,By_Endpoint,Botnet,IP.C&C) logid==020200
o ° Default-Botnet-Communication-Detection-By-Endpoint Rule-3 DNS traffic to Botnet CnC blocked: (Default,By_Endpoint,Botnet,Domain,C&C) logid==1501054
Rule-4 Traffic to Botnet CnC detected in ips log 1: (Default,By_Endpoint,Botnet,Signature, C&C) attack ~
o
Rule-1 Traffic to CnC detected: (Default,By_Endpoint,IP.C&C,loc_Rescan) tdtype~infected
O ©  Default-Compromised Host-Detection-I0C-By-Endpoint Rule-2 Web traffic to CnC detected: (Default,By_Endpoint,C&C,URL,loc_Rescan) tdtype~infected

Rule-3 DN trafic to CnC detected: (Default,By_Endpoint,C&C,Domain,loc_Rescan) tdtype~infected

3. Enable Include Data Selectors, if needed.
Enable Include Notification Profiles, if needed.
5. Inthe Select Export Data Type field, select Zipped, Text, or CLI.
If the data type is Zipped or Text, it will be saved as a JSON file. If the data type is CL/, it will be saved as CONF file.
6. Click OKto save the export file.

E

Export Event Handler

Include Data Selectors (e )

Include Notification Profiles

Select Export Data Type Zipped Text = CLI

To import handlers:

1. Goto FortiSoC/Incidents & Events > Handlers > Event Handler List.

If importing a correlation handler, go to FortiSoC/Incidents & Events > Handlers > Correlation Handler List.
2. Click More > Import.

The Import Event Handler dialog displays.

Import Event Handler

Drag & Drop your files or Browse

3. Drag and drop the exported event handler JSON or CONF file into the import dialog, or click Browse to locate the file
on the management computer.

You can import multiple event handlers at a time.
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4. Click OKto import the event handler(s).

If the imported event handler's name already exists, you will be asked if you want to Rename,

M, Replace, or Skip.
? If you select Rename, the Unix epoch timestamp will be automatically appended to the
- imported event handler's name. For example, App Cirl Event‘1544644459276775. The name

can be edited as required after importing.

b [ 4
? If the imported file is the wrong format or has an error, the system will report an error.

Events

After event handlers start generating events, view events and event details in FortiSoC/Incidents & Events > Event

Monitor.
S ! ’, When rebuilding the SQL database, you might not see a complete list of historical events.
q However, you can always see events in real-time logs. You can view the status of the SQL
- rebuild by checking the Rebuilding DB status in the Notification Center.
All Events

To view all the events, go to FortiSoC/Incidents & Events > Event Monitor > All Events.

Double-click an event line to drill down for more details.

Hover your mouse over an entry to view the asset and identity information for that event.

& Dashboards > B All Devices + @ Last 7 Days...» " Expand All. O Show Acknowledged ORefresh &% B+ &
i Outbreak Alerts Add Fiter o ‘
£ Automation > O # Event Event Statu Event Type Count Severity  First Occurrence ¥ Last Update Additional
B Event Monitor vyipo 1 > User login/logout failed (1) E Event 1 Medi... 2 minutes ago 2 minutes ago
O 2 > Uppulling FortiGuard server error (5) £ Event 5 Medi... 7 hours ago 26 minutes ago

By Endpoint > [ 3 > FortiAnalyzer license limit exceede... £ Event 1 Medi... 8 hours ago 8 hours ago

By Threat > O 4 > lmport FortiAnalyzer config failed (1) & Event 27 Medi... 8 hours ago 8 hours ago

S BaErs > O 5 >Timlocaldb (1) ES Event 18 Medi... 8 hours ago 8 hours ago

@ O 6 > lmage upgrade status (1) £ Event 1 Medi... 8 hours ago 8 hours ago

£2 Handlers >

% Threat Hunting
Incidents

Devices To view events for specific devices, click the devices dropdown and select a
device.
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Time Period

Collapse All/Expand All

Show Acknowledged

Refresh

Custom View

Column Settings

Export to CSV

Default event views

To change the time period to display, click the time icon and specify a time period.
Select Custom to specify a time period not in the dropdown list.

To view event summaries or details, click Collapse All or Expand All.

To include acknowledged events, click Show Acknowledged. See Acknowledging
events on page 184.

To manually refresh the events data, click Refresh.

You can specify a refresh interval of Every 10 Seconds, Every 30 Seconds, Every
1 Minute, or Every 5 Minutes.

Save the current view including filter settings, device selection, and time period.

Select which columns are displayed in the All Events pane. Columns not
displayed by default include

Acknowledged, Acknowledged By, Acknowledged Time, Assigned To, Comment,
Commented By, Commented Time, Device ID, Device Type, Event ID, Group By,
Group By 2, Group By 3, Indicators, Last Occurence, and VDOM Name.

Download the events to a CSV file.

FortiAnalyzer event handlers apply one or more tags to events, allowing the events to be grouped into views in the Event
Monitor. These views are visible in the left navigation tree.

Default views are organized into three view categories, including:

» By Endpoint. Provides security event views from an endpoint perspective.
o By Threat: Provides security event views from a threat perspective.
» System Events: Provides event views which cover device system events.

In order for events to be displayed in default views, the corresponding event handler(s) must be enabled. Refer to the
chart below for a list of the predefined event handlers that must be enabled to support each default view:

View category Default view Required predefined event handler
By Endpoint All Security Events Displays all events within category with enabled handlers
Compromised Hosts Default-Botnet-Communication-Detection-By-Endpoint

Default-Compromised Host-Detection-IOC-By-Endpoint

High Risk App Usage Default-Risky-App-Detection-By-Endpoint

Malicious Domain/URL Access Default-Risky-Destination-Detection-By-Endpoint

Malware Activity Default-Sandbox-Detections-By-Endpoint
Default-Malicious-File-Detection-By-Endpoint
Ongoing Intrusions Default-Malicious-Code-Detection-By-Endpoint
Sandbox Detections Default-Sandbox-Detections-By-Endpoint
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View category Default view Required predefined event handler
By Threat All Security Events Displays all events within category with enabled handlers
C&C Call Backs Default-Botnet-Communication-Detection-By-Threat

Default-Compromised Host-Detection-lOC-By-Threat
High Risk App Usage Default-Risky-App-Detection-By-Threat

Malicious Domain/URL Access Default-Risky-Destination-Detection-By-Threat

Malware Activity Default-Sandbox-Detections-By-Threat
Default-Malicious-File-Detection-By-Threat
Ongoing Intrusions Default-Malicious-Code-Detection-By-Threat
Sandbox Detections Default-Sandbox-Detections-By-Threat
System Events All Displays all events within category with enabled handlers
FortiGate Default FOS System Events
Local Device Local Device Event

You can see the tags associated with each view by hovering your mouse over the view in FortiSoC/Incidents & Events; a
pop-up is displayed.

D@ N2 ‘ admin

€3 Dashboards > B )l Devices v (D last7 Days~ " Expand Al O Show Acknowledged S Refresh~ % M~

<€ Automation > Add Filter

8 Event Monitor o # Event Event Statu: Event Type  Cour Severity  First Occurrence ¥ Last Update Additional Info | Handler Tags Device Name
3 All Events ] 3 LAN-FSW-.. Unhandled £¥ Traffic 62... @Critical 8 days ago A few seconds ago Default-Comp... | IP || C&C Enterprise_Second...
18 By Endpoint ~ O 5 LAN-FINAN... Unhandled £ DNS 51.. @Critical 8 days ago Aminute ago infected-doma... Default-Comp... | C&C ... Enterprise_Second...
Al Security Events O 5 LAN-FSW-.. Unhandled %3 Traffic  62.. @Critical 8 daysago Aminute ago Default-Comp... | IP|[ C&C Enterprise_Second...
0 > LAN-FSW-.. Unhandled % Traffic 62.. @Critical 8 days ago Aminute ago Default-Comp... | IP | C&C Enterprise_Second...

High RisK 12g=Default and tag="CaC

1
2
3
a
ndta‘:g:‘By,andpmnf T
6
7
8
9

Malicious Domain/URL O 5 LAN-FSW-.. Unhandled %¥ Traffic 62... @Critical 8 days ago 2 minutes ago Default-Comp... | IP || C&C Enterprise_Second...
Access O > LAN-FSW-... Unhandled %3 Traffic 62... @Critical 8 days ago 2 minutes ago infected-ip: 23... Default-Comp... | IP || C&C Enterprise_Second...
Malware Activity O 9 LAN-FSW-... Unhandled %3 Traffic 62... @Critical 8 days ago 2 minutes ago infected-ip: 23... Default-Comp... | IP | C&C Enterprise_Second...
Ongoing Intrusions O 3 LAN-FSW-...  Unhandled %} Traffic 62... @Critical 8 days ago 2 minutes ago Default-Comp... | IP | C&C Enterprise_Second...
Sandbox Detections o 1 > LAN-FSW-... Unhandled %¥ Traffic 62... @Critical 8 days ago 3 minutes ago Default-Comp... | IP || C&C Enterprise_Second...

® By Threat » 00 11 >LAN-FSW-.. Unhandled % Traffic 62.. @Critical 8 days ago 3 minutes ago Default-Comp... | IP || c&C Enterprise_Second...
System Events > 0 12 > LAN-FSW-... Unhandled £ Traffic 63.. @Critical 8 days ago 3 minutes ago Default-Comp... | IP || C&C Enterprise_Second...
&, Custom View (4) > O 13 > LAN-FSW-.. Unhandled %¥ Traffic 62... @Critical 8 days ago 3 minutes ago Default-Comp... | IP || C&C Enterprise_Second...
S=Handlers > o 14 > LAN-FSW-... Unhandled %3 Traffic 62... @Critical 8 days ago 4 minutes ago Default-Comp... | IP | C&C Enterprise_Second...
Incidents o 15 9 LAN-FSW-... Unhandled %3 Traffic 62... @Critical 8 days ago 4 minutes ago Default-Comp... | IP | C&C Enterprise_Second...

Default views can be hidden or disabled. For more information, see Managing default views.

Admins can copy existing views to create custom views. For more information, see Creating custom views.

Filtering events

You can filter events using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-sensitive

filter.

Filter FortiView summaries using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-
sensitive filter. You can also filter by specific devices or log groups and by time.
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To filter events using filters in the toolbar:

« Specify filters in the Add Filter box.

« Regular Search: In the selected summary view, click Add Filter and select a filter from the dropdown list, then
type a value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or
“Or”_

» Advanced Search: Click the Switch to Advanced Search icon @ at the end of the Add Filter box. In Advanced
Search mode, enter the search criteria (log field names and values). Click the Switch to Regular Search icon =
to go back to regular search.

To filter events using the right-click menu:

In the event list, right-click an entry and select a filter criterion (Search <filter value>).
Depending on the column in which your mouse is placed when you right-click, FortiView uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

To launch Search in Logview from an event:

In the event list, right-click an entry and select Search in Logview.
Log View will launch with the filter automatically filled in with the following information:

o Log type of the event
« Time range (the first to the last occurrence of the event)
« Eventtrigger and group by value

Viewing event details

In an event list, to view event details, double-click an event line to drill down for more details.

The event details page contains information about the event and a list of all individual logs. You can work on events
using buttons in the toolbar or by right-clicking an event.

« To change what columns to display, click Column Settings or Column Settings > More Columns.
« In event details, to view raw logs, click Tools > Display Raw.

» To switch back to formatted log view, click Tools > Formatted Log.

» To return to the previous page, click the back button.

IPS Signature Lookup

You can view IPS signature information from the event details when they are available by clicking on the link included in
the log's Attack Name column. You can add the Attack Name column to the table using Column Settings.

After clicking the attack name link, a dialog window appears which includes the IPS signature information. You can click
Show Raw Data to display the raw information and access additional features including a search option.

Acknowledging events

Acknowledging an event removes it from the event list. Click Show Acknowledged to view acknowledged events.
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You can enable the Acknowledged By and Acknowledged Time columns from the column settings option in the toolbar.

Acknowledged By displays the username of the administrator who acknowledged the event, and Acknowledged Time
displays the time and date that the event was acknowledged.

To acknowledge events:

1. Go to FortiSoC/Incidents & Events > Event Monitor and select a dashboard.
2. Inthe eventlist, select one or more events, then right-click and select Acknowledge.

Assigning events

Events can be assigned to administrators.
To view the administrator assigned to an event, enable the Assigned To column in the table from the column settings
option in the toolbar. The Assigned To column displays the username of the administrator assigned to the event.

To assign an event:

1. Goto FortiSoC/Incidents & Events > Event Monitor and select a dashboard.

2. Right-click on an event, and click Assign To.
The Assign to User dialog appears.

Assign to User

User | admin (Super_User)

Assign to myself
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3. Select a user from the dropdown or select Assign to myself, and click Save.
When enabled, the Assigned To column displays the username of the administrator assigned to the event.

B | Devices ~

@ Last7Days~ " Expand All

O show Acknowledged

£ Refresh|~ % M ~

Add Filter

Count Severity First Occurrence
2912 @ Critical 8 days ago
3510 @ Critical 8 days ago
5043 @ Critical 8 days ago
9618 @ Critical 8 days ago
12291 @ Critical 8 days ago
6301 @ Critical 8 days ago
8168 @ Critical 8 days ago
7346 @ Critical 8 days ago
7397 @ Critical 8 days ago
3740 @ Critical 8 days ago

9902 @ Critical 8 days ago
4059 @ Critical 8 days ago
8339 @ Critical 8 days ago
8425 @ Critical 8 days ago
15978 @ Critical 8 days ago
11664 @ Critical 8 days ago
3202 @ Critical 8 days ago
3551 High 8 days ago
10484 High 8 days ago

¥ Last Update

Aminute ago
2 minutes ago
2 minutes ago
2 minutes ago
2 minutes ago
3 minutes ago
3 minutes ago
3 minutes aga
4 minutes ago

4 minutes ago

5 minutes aga
5 minutes ago
5 minutes aga
5 minutes ago
& minutes ago
& minutes ago
& minutes ago
An hour ago

3 hours ago

Managing default views

Default views in the By Endpoint, By Threat, and System Events view categories can be hidden, disabled, or copied as a

Additional Info

infected-ip: 23.253.46.64,.. :80...
infected-ip: 23.253.46.64... :80...

infected-ip: 23.253.46.6 0...

infected-ip: 23.253.46.64,.. :80...

infected-ip: 23.253.46.64,.. :80...

Handler

Default-Compromised Host-D...
Default-Compromised Host-D...
Default-Compromised Host-D...
Default-Compromised Host-D...
Default-Compromised Host-D..

Default-Compromised Host-D...
Default-Compromised Host-D...
Default-Compromised Host-D...
Default-Compromised Host-D...

Default-Compromised Host-D..

Default-Compromised Ho:

Default-Compromised Host-!

Default-Compromised Host-D...
Default-Compromised Host-D...
Default-Compromised Host-D...
Default-Compromised Host-D...
Default-Compromised Host-D...

Default-Compromised Host-D...

Default-FCT-Threat-Detection.

Default-FCT-Threat-Detection...

custom view, allowing you to display only the views that are useful to the user.

To hide default views:

1. Goto FortiSoC/Incidents & Events > Event Monitor.
2. Selectan event category.
3. Right-click on an event view and select Hide.

= FortiSoC

€2 Dashboards >

€ Automation >

B Al Devices ~

Add Filter

®last7Days~ " Expand All O Show Acknowledged

Device Name

Enterprise_Second_Flaor
Enterprise_Second_Floor
Enterprise_Second_Flaor, ...
Enterprise_Second_Floor, ...
Enterprise_Second_Flaor, ...
Enterprise_Second_Floor
Enterprise_Second_Floor
Enterprise_Second_Flaor
Enterprise_Second_Floor

Enterprise_Second_Floor

Enterprise_Second_Flaor
Enterprise_Second_Floor
Enterprise_Second_Flaor, ...
Enterprise_Second_Floor, ...
Enterprise_Second_Flaor, ...
Enterprise_Second_Floor, ...
Enterprise_Second_Floor
Enterprise_QA
Enterprise_QA

Assigned To

T@®r N1 ! admin +

ORefressh &% B~

L3 Event Monitor ~ o o#

€3 All Events

18 By Endpoint >

® By Threat v
All Security Events
C&C Call Backs
High Risk App Usage

Malicious Domain/URL
Access

Malware Activity
Ongoing Intrusions
Sandbox Detections
@ Hide
B System Events > )

2 Custom View (1) >

andlers >

Incidents.
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Event Statu Event Type Count

Severity | First Occurrence

¥ Last Update

No entry found.

Additional Info Handler

Tags

Device Name
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To disable/enable default views:

1. Goto FortiSoC/Incidents & Events.
2. Select the gearicon on the bottom of the navigation tree to access the Default Views setting.

3. Choose which views are displayed. Add a checkmark to enable the view; remove the check mark to disable the
view.

4. Select Save.

Default Views

By Endpoint

B Al Security Events

B Compromised Hasts

[ sandbox Detections

B Malware Activity

[ Ongoing Intrusions

[ Malicious Domain/URL Access
[JHigh Risk App Usage

By Threat

B All Security Events

B CaC Call Backs

[ sandbox Detections
[OMalware Activity

[ Ongoing Intrusions

[ Malicious Domain/URL Access
[JHigh Risk App Usage

System Events

B Local Device
Ban
BFortiGate

Creating custom views

To create a custom view:

Go to FortiSoC/Incidents & Events > Event Monitor.
Select an existing view to copy.
Select Add Filters to add any additional filters you want to include in the custom view.
Select the custom view icon on the top-right side of the toolbar.
Enter a name for the custom view and assign it to one of the following categories:
e By Endpoint
e By Threat
« System Events

o prhwbd=
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e Custom View

Save as New Custom View

Name

Category | Custom View

Privacy n Public

Others can see this Custom View

6. Inthe Privacy field, select the custom view visibility.

o Public: Others can view this custom view displayed in Log View > Custom View.

« Private: Only you can see this custom view displayed in Log View > Custom View.
7. Select OKto save the view.

Ay
‘9' When upgrading from versions prior to 6.2.0, existing custom views will be placed in the
- Custom Views category.

To edit a custom view:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Inthe toolbar, edit the filter settings as desired.

3. Inthe tree menu, select the menuicon next to your custom view or right click the view, and select Save or Save As.
Save As creates a new custom view which includes your changes.
You can change the Name and/or Category of the view by selecting Edit from the custom view's menu.

To change the visibility of a custom view:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Inthe tree menu, select the menu icon next to your custom view or right click the view, and select Share with Others.
3. Setthe Privacy field to On: Public or Off: Private, and click OK.
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Understanding event statuses

In the Event Monitor dashboards, you can view the status of an event in the Event Status column. Event statuses include
Unhandled, Mitigated, Contained, and (blank).

Event statuses are applied by the associated event handler. When creating a custom event handler, you can manually
select an event status or choose to allow FortiAnalyzer to decide.

In general, when Allow FortiAnalyzer to choose is selected, the event status for UTM events is applied based on the

following:

Event status Description

Unhandled The security event risk is not mitigated or contained, so it is considered open.
Example: an IPS/AV log with action=pass will have the event status Unhandled.
Botnet and IoC events are also considered Unhandled.

Contained The risk source is isolated.
Example: an AV log with action=quarantine will have the event status Contained.

Mitigated The security risk is mitigated by being blocked or dropped.
Example: an IPS/AV log with action=block/drop will have the event status
Mitigated.

(Blank) Other scenarios.

Incidents

Incidents can be created to track and analyze events.

Incidents raised from the Event Monitor contain event details, as well as information and actions helpful for administrator
analysis. From the incident's analysis page, administrators can assign incidents, view audit history, and manage
attached reports, events, and comments.

For more information on incidents, see the following topics:

« Raising an incident on page 189

« Analyzing an incident on page 190

« Configuring incident settings on page 192
» Adding reports to an incident on page 192

Incidents can be viewed at FortiSoC/Incidents & Events > Incidents.
To configure incident settings, go to FortiSoC/Incidents & Events > Incidents, and click Settings.

Raising an incident

You can raise an incident only from alerts generated for one endpoint.
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Incidents can be raised in the following ways:

 In FortiSoC/Incidents & Events > Incidents, click Create New in the toolbar. This opens the Create New Incident

pane.

« In FortiSoC/Incidents & Events > Event Monitor > All Events, right-click an event and select Create New Incident.
This opens the Raise Incident pane with the applicable fields filled in, such as the Affected Endpoint.

The following is a description of the options available in the Create New Incident and Raise Incident pane.

Incident Category Select a category from the dropdown list.

Severity Select a severity level from the dropdown list.

Status Select a status from the dropdown list.

Affected Endpoint In the Raise Incident pane, the affected endpoint is filled in and cannot be
changed.
In the Create New Incident pane, select the affected endpoint from the dropdown
list.

Description If you wish, enter a description.

Assigned To The admin account to which the incident is assigned.

Analyzing an incident

In FortiSoC/Incidents & Events > Incidents, double-click an incident or right-click an incident and select Analysis.

The analysis page shows the incident's affected endpoint and user, audit history, attached events, reports, comments,

and more.

In the incident information panel, you can change information collected about the incident.

In order to assist SOC analysts during their investigation, information including comments and reports can be attached to

incidents.

In the Events panel, you can review and delete events attached to the incident. See Raising an incident on page 189.

The Analysis page includes the following information and features:

Panel Description

Incident information General information about the incident.
Click Edit to modify the following information:

FortiAnalyzer 7.2.2 Administration Guide
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Incident Number: The unique incident ID.

Incident Date/Time: The date and time that the incident was created.
Incident Category: The incident category, including Unauthorized Access,
Denial of Service (DoS), Malicious Code, Improper Usage,
Scans/Probes/Attempted Access, and Uncategorized.

Severity: The severity of the incident, including High, Medium, and Low.
Status: The current status of the incident, including New, Analysis,
Response, Closed: Remediated, and Closed: False Positive.

Affected Endpoint: The endpoint associated with this incident.
Description: A description of the incident provided by the administrator.
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Panel Description

¢ Assigned To: A dropdown menu of administrators to which the incident can
be assigned.
Click Refresh to manually update the displayed information.

Affected Endpoint/User Information about the affected endpoint/user. When multiple endpoints/users are
associated with the incident, the total number is displayed and you can click the
forward or backwards arrow on the tile to cycle between them.

Executed Playbooks The history of executed playbooks related to the incident.

Click Execute Playbook to run a playbook configured with the On_Demand
trigger. See FortiSoC on page 194.

Audit History Displays the history of changes made to an incident, including the user who made
the change and information about the type of change that was made.

Click Expand All to see additional details.

Incident Timeline The timeline of the events raised for the incident.
Scroll using your mouse wheel to change the displayed time frame.

Comments Displays comments made by administrators for this incident with a timestamp.
The most recent comments appear at the top of the list.

Enter a comment and click POST to create a new comment.
Existing comments can be edited and deleted by administrators.

Events Displays the events that have been raised for this incident.

Reports Attach and manage reports related to this incident.
See Adding reports to an incident on page 192.

Indicators Displays indicators attached to an incident from FortiGuard, FortiMail, or event
handlers.

Hover your mouse over an indicator to view detailed information from FortiGuard
or click Details under Results to view information from FortiMail including sender
reputation and email statistics.

Indicator information can be attached to incidents using the FortiGuard and
FortiMail connector in FortiSoC playbooks, or when an incident is created from an
event that includes indicators identified in the event handler.

Affected Assets Displays affected asset(s) in a table. Includes the host, user, IP address, and
MAC address of the asset.

Selecting a user shows endpoint information in a window.

Processes Displays endpoint processes associated with this incident including the process
ID, process path, and network connection.
Select a time period to view by choosing a snapshot from the snapshot dropdown.
Processes can be displayed in a table format or as raw data.

Software Displays endpoint software associated with this incident including the software,
installation path, and installation time.

Select a time period to view by choosing a snapshot from the snapshot dropdown.
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Panel Description

Software can be displayed in a table format or as raw data.

Vulnerabilities Displays endpoint vulnerabilities associated with this incident including the
vulnerability name, ID, severity, and category.

Select a time period to view by choosing a snapshot from the snapshot dropdown.
Vulnerabilities can be displayed in a table format or as raw data.

A\,

S L4
q Some features of incident analysis are only available with the applicable license.

Configuring incident settings

To configure incident settings, go to FortiSoC/Incidents & Events > Incidents > Settings.

When an incident is created, updated, or deleted, you can send a notification to external platforms using selected fabric
connectors.

To configure incident notification settings:

1. Goto FortiSoC/Incidents & Events > Incidents > Incident Settings.

2. Select a Fabric Connector from the dropdown list.

3. Select which notifications you want to receive:
« Send notification when new incident is created. Incidents with draft status will not trigger notification.
« Send notification when new incident is updated.
« Send notification when new incident is deleted.

4. To add more fabric connectors, click Add Fabric Connector and repeat the above steps to configure notification
settings.

Adding reports to an incident

Reports can be attached to incidents to include historical data relevant to that incident.
Reports can be added to incidents through the following methods:

1. Reports can be manually added by an admin from the Reports module or from the incident's Analysis page.
2. Reports can be automatically added to an incident by a FortiSoC playbook. See FortiSoC on page 194.

Once areport has been attached to an incident, it can be viewed, managed, and downloaded from the Reports tab on
the incident's Analysis page. Multiple reports can be attached to a single incident.

To attach reports from an incident:

1. Goto FortiSoC/Incidents & Events > Incidents, and select an incident.
2. Click on the Reports tab in the incident analysis page, and click Add.
3. Select one or more previously generated reports, and click OK.
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To attach reports from the Reports module:

1. Goto Reports > Generated Reports.
2. Right-click on a report, and select Attach to Incident.
3. Selectan incident from the list, and click Add to this incident.
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FortiSoC

FortiSoC is a subscription service that enables playbook automation for security operations on FortiAnalyzer.

FortiAnalyzer's SIEM capabilities parse, normalize, and correlate logs from Fortinet products and the security event log
of Windows and Linux hosts (with Fabric Agent integration). Parsing is predefined by FortiAnalyzer and does not require
manual configuration by administrators. SIEM logs are displayed as Fabric logs in Log View and can be used when
generating reports. See Types of logs collected for each device on page 88.

FortiSoC provides incident management capabilities with playbook automation to accelerate incident response. When
FortiAnalyzer has a valid subscription license, the FortiSoC module is activated and administrators are able access
playbook automation features. Task automation can be configured by SOC analysts using playbooks which consist of a
trigger and sequence of automated actions. Playbooks can be created from scratch or by using one of the predefined
templates. Fabric connectors further enhance FortiSoC functionality by allowing playbooks to perform tasks using
connected devices, including FortiOS and FortiClient EMS.

A SOC subscription is required to run at full capacity. For additional information about

s‘é’, FortiSoC includes a trial with a limited capacity allowing up to five playbooks per day.
- licensing, please see support.fortinet.com.

Al
‘?' For information about FortiSoC incidents and events, see Incident and Event Management on

page 135.

Viewing FortiSoC dashboards

FortiSoC includes multiple dashboards for viewing information about playbooks, incidents, and events.

There is a toolbar available for each dashboard, providing the following options:

Dark Mode Enable/disable dark mode. Dark mode shows a black background for the
dashboard.
Refresh From the Refresh dropdown in the toolbar, you can select a frequency for the

dashboard to automatically refresh the information. If you need to manually
refresh the dashboard before it is done automatically, click Refresh in the toolbar.

By default, the refresh frequency is set to Manual Refresh. Click Refresh in the
toolbar to refresh the dashboard when needed.
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Playbooks

Total Playbooks Executed

280

Total Playbook Actions Executed

623

The Playbooks dashboard includes:

Total Playbooks Executed

Total Playbook Actions
Executed

Playbooks Executed
Overall Time Saved

Total Executed Playbooks and
Actions
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2 8 0 ® On Event
® On Incident

Playbooks Execurte: = On demand FAZ Run_Report

Total Executed Playbooks and Actions

The total number of playbooks executed.

The total number of playbook actions (tasks) executed.

The number of times each playbook has been run.
The estimated time saved by administrators resulting from FortiSoC automation.

A timeline of the number of playbooks and actions run for each day. Both actions
and playbooks can be toggled on or off in the graph by clicking the corresponding
name below the graph.
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Incidents

Total Incidents

= New

High
= Analysis 2 2 8 )
um

= Response .
- ) Unsolved Incidents
= Closed: Remediated

Incidents Timeline

The Incidents dashboard includes:

Total Incidents
Unsolved Incidents

Incidents Timeline

Events

Total Events Generated

Tetal Events

0

299

Events by Severity,

Critical

The Events dashboard includes:
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Displays the total number of incidents created by their status.
Displays the total number of unsolved (not closed) incidents by severity.

Total incidents breakdown by category trend by day.

Top Events by Type
|

Application Control

Web Filter

Top Events by Handler

Default FOS System Events

196



FortiSoC

Total Events
Generated/Mitigated/Unhandled

Events by Severity
Top Events by Type
Top Events by Handler

The total number of events with the Generated/Mitigated/Unhandled status
created by FortiAnalyzer.

The total number of events by severity.
Total events breakdown by type.

Total events breakdown by event handler.

Configuring playbook automation

FortiSoC enables the ability to automate SOC tasks through the use of playbooks.

Connectors

Connectors displays the automated actions that can be performed in playbooks using configured FortiSoC connectors.

Local (FortiAnalyzer), FortiOS, FortiMail, FortiGuard, and FortiClient EMS connectors are supported. To view FortiSoC
connectors, go to FortiSoC > Automation > Connectors.

FortiOS devices are organized by standalone, Cooperative Security Fabric (CSF), and high availability (HA). Clicking a
CSF or HA grouping will expand the list to display all FortiGate members.

The status of FortiSoC connectors are indicated with a colored icon:

« Green: The API connection successful.
« Black: The API connection is unknown.

¢ Red: The API connection is down.

You can see when the status was last updated by hovering your mouse over the status icon. Click the refresh icon to get

an updated status.

FortiClient EMS connector

~ @ EMS Connector FortiDemo
FortiOS connector

o~ FortiOS Connector
Localhost connector

~ Local Connector
FortiGuard connector

~ FortiGuard Connector
FortiMail connector

& [=] FML Connector
FortiCASB connector

& (& FortiCasb Connector

Q

Q

Q

0

The following information is displayed for configured connectors:
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Connector type Field Description
Local, FortiMail, Actions The name of the action.
FortiGuard, and o - .
EMS connectors Description A description of the action.
Parameter The parameters that can be specified when configuring the action.

Required parameters are listed with an asterisk.

Output The output available with the action.
Not applicable to FortiGuard connectors.

FOS connectors Automation The name of the automation rule created on FortiOS.
Rule
Automation The action(s) that occur when the task is triggered.
Action
Parameter The parameters that can be specified when configuring the action.

Required parameters are listed with an asterisk.

Configuring FortiSoC connectors

Local Connector

The local connector is the default connector for FortiAnalyzer and is available automatically. The local connector
displays a set of predefined FortiAnalyzer actions to be used within playbooks.

Local connectors include the following actions:

Name Description Output
Update Asset and Update FortiAnalyzer's Asset and Identity. N/A

Identity

Get Events Get events. events

Get Endpoint Get endpoint vulnerabilities. vulnerabilities

Vulnerabilities

Create Incident Create a new incident. incident_id
Update Incident Update an existing incident. N/A
Attach Data to Incident Attach the specified data to an existing incident. attach_ids
Run Report Run the specified FortiAnalyzer report. report_uuid
Get EPEU from incidents Get the EPEU from an incident. epeu

EMS Connector

FortiClient EMS connectors are configured as Security Fabric connectors in Fabric View > Fabric Connectors. See
Creating or editing Security Fabric connectors on page 114. Individual FortiClient EMS connector actions can be toggled
on and off while editing the connector in Fabric View.
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FortiClient EMS connectors include the following actions:

Name Description Output

Get Endpoints Retrieve list of endpoints and all of the related information ems_endpoints
to enrich FortiAnalyzer asset and identity views.

Quarantine Quarantines an endpoint. N/A
Unquarantine Unquarantines an endpoint. N/A
Vulnerability Scan Run a vulnerability scan on endpoints. N/A
AV Quick Scan Run a quick antivirus scan on endpoints. N/A
AV Full Scan Run a full antivirus scan on endpoints. N/A

Get Software Inventory Retrieve list of software and apps installed on an endpoint softwares
to enrich FortiAnalyzer asset view.

Get Process List Retrieve list of running process on endpoints OS. processes
Get Vulnerabilities Retrieve list of endpoint vulnerabilities on endpoints OS. vulnerabilities
Tag Endpoints Tag endpoints. N/A

Untag Endpoints Untag endpoints. N/A

FortiMail Connector

FortiMail connectors are configured as Security Fabric connectors in Fabric View > Fabric Connectors. See Creating or
editing Security Fabric connectors on page 114.

Individual FortiMail connector actions can be toggled on and off while editing the connector in Fabric View.

FortiMail connectors include the following actions:

Name Description Output
Get Email Statistics Query a given email address. statistics
Get Sender Reputation Query a given sender's reputation information. reputation
Add Sender to Blocklist Update system and domain level blocklist. N/A

FortiGuard Connector

The FortiGuard connector is automatically configured in FortiSoC when a valid license has been applied to
FortiAnalyzer.

FortiGuard connectors include the following actions:

Name Description

Lookup Indicator Lookup indicators in FortiGuard to get threat intelligence.
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FortiOS Connector

The FortiOS connector is added after the first FortiGate has been authorized on an ADOM. Additional devices

authorized to the ADOM are displayed as separate entries within the same connector. FortiOS connectors are available

in FortiGate and Fabric ADOMs.

Enabling FortiOS actions

The actions available with FortiOS connectors are determined by automation rules configured on each FortiGate.
Automation rules using the Incoming Webhook trigger must be created in FortiOS before they are shown as actions in
FortiSoC. FortiOS automation rules are configured on FortiOS in Security Fabric > Automation. For information on
creating FortiOS automation rules, see the FortiOS administration guide.

Rules for FortiOS actions:

Automation rules must use the Incoming Webhook trigger.
Automation rules are configured on FortiGate devices individually.

When multiple FortiOS connectors are configured, FortiAnalyzer decides which device to call based on the devid
(serial number) identified in the task. FortiGate serial numbers can be manually entered or supplied by a preceding
task.

Automation rules must have unique names to be displayed in the task's Action dropdown menu. Rules sharing the
same name will appear only once, as they are considered to be the same automation rule configured on multiple
FortiGate devices.

FortiOS automation rules are only displayed in FortiSoC when they are enabled in FortiOS.

Playbooks

To manage playbooks, go to FortiSoC > Automation > Playbooks. The following options are available:

Create New Create a new playbook. Playbooks can be created from scratch or by using

playbook templates.

Run Run selected playbooks that are configured with the ON_DEMAND trigger.
Edit Edit the selected playbook.
Delete Delete the selected playbook.
Column Settings Choose which columns are displayed in the playbook table.
Search Perform a text search for the playbook name, description, created time, and
modified time.
\‘ ! 'l
? To manage playbooks, administrators must be assigned to an administrator profile with Read-
- Write permissions for Incidents & Events. See Administrator profiles on page 358.

Creating a playbook

Playbooks include a starter event (trigger) and one or more tasks configured with automated actions.
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Atask is run as soon as the playbook is triggered and all connected tasks preceding it are complete.

To create a playbook:

1. Goto FortiSoC > Automation > Playbooks, and click Create New.
Select a playbook template or choose New Playbook created from scratch.

The playbook editor opens.
N ! /., When a playbook template is selected, the playbook designer is automatically populated
q with a trigger and one or more tasks. You can configure trigger filter conditions and add or
= remove tasks to customize the playbook. See Playbook templates on page 205.

2. Click within the playbook's title field to change its name and description.

3. Select a playbook trigger from the Triggers menu and configure the trigger's filter conditions.
On Demand - Quarantine Endpoint

Quarantine an endpoint

TASKS

x

@ Add a Trigger to start the playbook

- | TRIGGERS

EVENT_TRIGGER
INCIDENT_TRIGGER
ON_SCHEDULE

ON_DEMAND

[ \

[ \

Once the trigger is created, it is displayed in the playbook editor with highlighted connector points.
For more information on the available playbook triggers, see Triggers and tasks on page 204.
4. Add playbook tasks.

Drag-and-drop any connector point to add a new task. A new placeholder step is added to the playbook editor, and
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the Tasks window is displayed showing available FortiSoC connectors. See Connectors on page 197.

On Demand - Quarantine Endpoint =
TASKS x
— B
stagTER E
—EE B-
ﬁ Foo
[ o | ol
]
5. Selecta connector type and configure an automated action:
Name Enter a name for the task.
Description Enter a description of the task.
Connector Select a connector to use from the dropdown menu. See Connectors on page
197.
Action Select the automated action to be performed.
Parameters Configure the parameters for the selected action.
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On Demand - Quarantine Endpoint [:]
Quarantine an endpoint
EMS
Name QUARANTINE
Description Quarantine an endpoint
ON_DEMAND
B o

Connector EMS Connector

Action Quarantine

Endpoint ID @ Playbook Starter v | $ltrigger.epid) T
FortiClient ID @ NoData. Edit

[ oo

6. Connect playbook tasks.
Additional connector points can be added to connect this task to other tasks in the playbook. A task automatically
begins once all preceding tasks connected to it have been completed. A playbook ends when there are no
additional tasks to run.

On Demand - Quarantine Endpoint
Quarantine an endpoint
TASKS x
CONNECTORS
ATTACH_DATA_TO_INCIDENT LOCALHOST

h ON_DEMAND
— =
e

QUARANTINE L
Quarantine Endpoint.
[ e

;
i
§
i

- =
=
7. (Optional) Manage your playbook by clicking on one of the options displayed when hovering your mouse over the
trigger or task:

« Edit: Edit the trigger or task.
» Delete: Delete the task.
8. Click Save Playbook.
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Enabling and disabling playbooks

Once created, playbooks can be enabled or disabled through the playbook editor. Enabled playbooks will run as soon as
their trigger conditions are met. Playbooks configured with the On_Demand trigger start when manually initiated by the
administrator in FortiSoC > Automation > Playbook Monitor or an Incident Analysis page.

To enable or disable a playbook:

Go to FortiSoC > Automation > Playbooks.

Edit a previously configured playbook.

In the playbook designer, select the option to Enable or Disable the playbook located in the top-right corner.
Click Save Playbook.

Ao b=

Triggers and tasks

Triggers

Triggers determine when a playbook is to be executed. Triggers are always the first step in a playbook, and each
playbook can only include one trigger. Once a playbook has been triggered, it flows through the remaining tasks as
defined by the routes in the playbook using the trigger as a starting point.

The following playbook triggers are available:

Trigger Description

EVENT_TRIGGER The playbook is run when an event is created that matches the configured filters.
When no filters are set, all events will trigger the playbook.
INCIDENT_TRIGGER The playbook is run when an incident is created that matches the configured
filters.
When no filters are set, all incidents will trigger the playbook.

ON_SCHEDULE The playbook is run during the configured schedule.
You can define the start time, end time, interval type, and interval frequency for
the schedule.

ON_DEMAND The playbook is run when manually started by an administrator.

You can run playbooks configured with the ON_DEMAND trigger from
FortiSoC > Automation > Playbook or within an incident's Analysis page.

Tasks

Tasks include automated actions that take place on FortiAnalyzer or devices with configured FortiSoC connectors. See
Connectors on page 197.

Tasks can be linked together in sequences. A task's automated action will only begin once the playbook is triggered and
all preceding connected tasks are complete.
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Tasks can be configured with default input values or take inputs from the trigger or preceding tasks. For more information
about linking and configuring tasks in a playbook, see Playbooks on page 200.

Ay
‘Q' FortiOS actions are configured using automation rules created on FortiGate. For more
- information on enabling FortiOS actions in tasks, see Connectors on page 197.

Playbook templates

When a playbook template is selected, the playbook designer is automatically populated with a trigger and one or more
tasks. You can configure, add, or remove tasks to customize the playbook.

When creating a new playbook, the following predefined templates are available:

Connector Name Description

FAZ Localhost Compromised Host Playbook to create an incident on FortiAnalyzer compromised hosts
Incident detected by the loC feature.
Critical Intrusion Playbook to create an incident on FortiAnalyzer for critical
Incident intrusions detected by IPS.
Attach Endpoint Playbook to collect the list of endpoint vulnerabilities from logs and
Vulnerability List to attach it to an incident.
Incident

FortiOS Quarantine Endpoint by  Playbook to quarantine an endpoint by FOS connector providing
FortiOS the MAC address or FortiClient UID.

FortiClient EMS  Update Asset and Playbook to automatically update FortiAnalyzer Asset and Identity
Identity Database database with endpoint and user information from EMS.
Run AV Scan on Playbook to run AV scan on an endpoint by EMS Connector.
Endpoint
Run Vulnerability Scan Playbook to run a vulnerability scan on an endpoint.
on Endpoint
Quarantine Endpoint by  Playbook to quarantine an endpoint by EMS connector.
EMS
Unquarantine Endpoint  Playbook to unquarantine an endpoint by EMS connector.
by EMS
Enrich Incident with Playbook to get running processes on endpoint by EMS connector
Process List and attach to an incident.
Enrich Incident with Playbook to collect the list of endpoint vulnerabilities from logs and
Vulnerability List attach to an incident.
Enrich Incident with Playbook to get software inventory from endpoint by EMS
Software Inventory connector and attach to an incident.
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Playbook Monitor

You can view the status of playbook jobs in FortiSoC > Automation > Playbook Monitor.

The Playbook Monitor table includes:

Field Description

Job ID The unique ID of the playbook job.
The ID includes the date and time that the job began as well as a unique number.

Playbook The name of the playbook as configured in FortiSoC > Automation > Playbook.

User Displays the name of the administrator who started the playbook job when
configured with theOn Demand trigger.

Start Time The date and time that the job began.
End Time The date and time that the job ended.
Status The current status of the job. Statuses include:

* Running: The job is currently running.

¢ Success: The job has finished with all tasks completed successfully.

¢ Failed: The job has finished with one or more tasks failing to complete
successfully.

Details Clicking on the Detail icon shows the status of each task run by the playbook.

Task statuses include:

Task status Description

Scheduled Scheduled to run.

Success Completed successfully.

Failed Failed to complete.

Upstream_failed Failed because the task could not connect with an upstream device.

Playbook jobs that include one or more failed tasks are labeled as Failed in Playbook Monitor, however, individual
actions may have been completed successfully.

Configuring tasks using variables

Variables can be used when configuring playbook tasks. There are two types of playbook variables, including output
variables and trigger variables.

For a list of trigger and output variables that can be used when configuring playbook tasks, see FortiAnalyzer Playbook
Variables on the Fortinet Docs Library.
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Output variables

Output variables allow you to use the output from a proceeding task as an input to the current task. For example, the
report generated in one task can be attached to an incident in a second task. For a list of output types, see FortiSoC >
Automation > Connector. A task ID is created automatically for each task added to the playbook.

Output variables use the following format:
Format: $ {<task id>.<output>}

Example: ${id 2c7 84b 2c5 f47.vulnerabilities}

Obtaining task IDs

Task IDs are not currently displayed within a task. To view a task ID, the following workaround

can be used.
1. Create a new task in the playbook using the Local Connector action Attach Data to
Incident.

2. Inthe Aftachment dropdown, select a preceding task to view its task ID. You can switch to
text mode to copy the value after selection.

ﬂ E“': NEW T NIGEALHOSH
I GET_EVENTS - [l ==
Get Events B e

Description

Connector Lacal Connector

Action Attach Data to Incident
Incident ID @ No Data.  Edit
CREATE_INCIDENT | Attachment (& . «|T
1
Create Incident B Playbook Starter
Get Events

(id_a74_3e6_f49_94e)

Trigger (incident and event) variables

Trigger variables allow you to use information from the trigger (starter) of a playbook when it has been configured with an
incident or event trigger.

For example, the Run Report action can include a filter for the endpoint IP address from the event that triggered the
playbook.

Trigger variables use the following format:
Format: s{trigger.<variable>}

Example: ${trigger.epip}
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LOCALHOST
Name Run Report
Description
ON_DEMAND
STARTER
Connector Local Connector
Action Run Report
______________________ Report Playbook Starter | T
I 1
) NEWIASK 1 Time Period Last 7 Days
1 1
il Skar ' §
_______ o R Filter Log messages that @®All O Any of the Following Conditions
match
Log Field Match Criteria Value @
Source IP (srcip)  + | Equal To + S${trigger.epip} + @
Devices B 7|l Devices +

B -
Save Playbook Cancel

Importing and exporting playbooks

You can import or export playbooks, including the connectors required to support the playbook, by using the right-click
context menu in the FortiSoC playbook dashboard.

To import a playbook:

1. Goto FortiSoC > Automation > Playbook.

2. Right-click in the playbook dashboard, and click Import.
The Import Playbook dialog appears.

3. Click Browse and select the playbook file to be imported.
When the playbook file includes connectors, a toggle allowing you to include or exclude the connectors during the
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import process is displayed.

Import Playbook

Upload file by drag & drop here or  Browse

Get Vulnerabilities from EMS (EMS Connector)(1).json

Do you want to include Connector ? Include Connector

“ ane'

4. Click OK.
A message is displayed confirming that the playbook was imported successfully.

To export a playbook:

1. Goto FortiSoC > Automation > Playbook.

2. Highlight the playbook(s) that you want to export, then right-click in the dashboard and click Export.
The Export Playbook dialog opens.

Export Playbook

Do you want to include Connector OFF

Select Export Data Type O text (@ zipped
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3. Configure the settings for exporting the selected playbook:

a. Do you want to include Connector: When enabled, connectors required to run this playbook will be included in
the exported file.

b. Select Export Data Type: Select the export file type as either plain text JSON or zipped/base 64 encoded

JSON.
4. Click OK.
N ! /, When an imported playbook has the same name as an existing playbook, FortiAnalyzer
9 will automatically create a new name which includes the import timestamp to avoid a
3 conflict.

Threat Hunting

FortiSoC includes the Threat Hunting pane which offers a SOC analytics dashboard using the SIEM database. Threat
Hunting uses cached data to allow SOC analysts to quickly drilldown on logs in fields of interest. To view the Threat
Hunting dashboard, go to FortiSoC > Threat Hunting. The Threat Hunting dashboard includes a log count chart and
SIEM log analytics table.

The Threat Hunting dashboard is only available in Fabric ADOMs when ADOMSs are enabled.

To change the displayed time range, select a time from the dropdown in the top-left corner of the dashboard. You can
configure custom time ranges by selecting either Last N Minutes, Last N Hours, or Last N Days. Apply filters to the
dashboard using Add Filter or by right-clicking on a value in the table and selecting the corresponding filter. Only logs
matching the selected time range and filter are displayed in the SIEM log analytics table.

You can toggle between the light mode and dark mode dashboard theme using the Dark Mode toggle in the toolbar.

E:E FortiSoC & N1 A administrator

Last 12 Hours N 01:45:42 To 13:45:41 @ Dork Mode

€3 Dashboards ~
o, Playbooks

Add Filter

B Incidents Log Count
. 21,000
& Events 18,000
15,000
12,000
9,000
6,000
% Playbook 3,000
o

LJ Playbook Manitor 2021-03-30 9:30:00 2021-03-30 %:45:00 2021-03-30 10:00:00 2021-03-30 10:15:00 2021-03-30 10:30:00

€ Automation ~

. Connectors

L3 Event Monitor v

& All Events

Threat Action (4) 2021-03-30 9:20:00 - 2021-03-30 10:40:00
18 By Endpoint >
Threat Pattern (241) # Threat Action Count Sent (bytes) Session Duration
® ByThreat >
& s . Threat Name (238) 1 282 068(92%) 11GB 01m 525
ystem Events >
) Threat Type (8) 2 Detected 18792(6%)
& Custom View (4) > ) 3 blocked 54102% 1
£ Handlers > File Hash {3) a unquarantined 1128(<1%) |
% Threat Hunting File Name (3) 5 detected 179(< 1%)
Incidents Application Process (4)
Application Name (27)
Application Service (18070)
HTTP Referrer (2)
Destination Domain (44)
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Using the log count chart

A chart displaying the total log count during the specified time range is presented at the top of the Threat Hunting
dashboard.

You can zoom in and out on the displayed time range by using your mouse's scroll wheel or by adjusting the timebar
below the graph. You can adjust the time bar by dragging the start and stop bars on either side of the selected time
range, or by clicking and dragging the entire time range to the left or right. Only logs displayed within the time period
visible in the chart are shown in the SIEM log analytics table.

[ Last N Hours v n = 12:49:58 To 13:49:57 @ Dark Made
Q

| Add Filter

Log Count
21,000
18,000
15,000
12,000

9,000
6,000
3,000

o

2021-03-30 13:00:00 2021-03-30 13:10:00 2021-03-30 13:20:00 2021-03-30 13:30:00

Using the SIEM log analytics table

The SIEM log analytics table contains a list of fields of interest in the left menu as well as the analytics table. You can
select a field from the left menu to view corresponding data in the table. The table includes a row for the null value of that
field, if applicable. For example, see the image below where Application Service is blank (null) in row 5.

Double-click an item in the table to open the log drilldown page which displays detailed log information. This feature
includes the same functions as are available in Log View, including the search bar filter, time filter, columns settings,
right-click filter, and more. See Viewing message details on page 91

Threat Action (4) 2021-03-30 13:00:00 - 2021-03-30 13:35:00
Threat Pattern {242) # Application Service Count Sent (bytes) Session Duration
Threat Name (239) 1 HTTP 23,809(17%) m— 5.6 MB 03s
Threat Type (8) 2 NTP 23,273(17%) m—m 19.9 MB 07m 325
. 3 DNS 18,817(14%) 3.2 MB 04m 055
File Hash (6] 4 ssL 17,43012%) mmm
File Name (10) 5 15,107(11%) . 657.4 MB 34m 13s
Application Process (2) & tcp/8013 13,287(10%) 20.0 MB 03s
o 7 HTTPS 11,028(8%) mm 17.6 MB 07s
Application Name (23)
8 TIMESTAMP 1,557(1%) 1 60.7 KB 01m
Application Service (10326) 9 PING 1541(1%) 1 42.1KB 01m
HTTP Referrer (2) 10 tcp/514 775(1%) 1 638.5 MB 30m 455
. 9
Destination Domain (39) 1 icmp/0/13 639(< 1%) ‘
12 icmp/0/8 245(< 1%) I
Destination IP (757]
stination [P (757) 13 tcp/10432 206(< 1%) I 30.6 KB 19s
Source IP (143) 14 EMS(i7€5,YAS) 169(< 1%) |
Event Action (26) 15 EMS(i%:°4,YAS) 149(< 1%) |
16 udp/8888 72{< 1%) 6.5KB 10s
Event ID (34)
17 FTGD 72{< 1%)
UEBA User ID (14] 18 EMS(ARBUTUS) 44(< 1%)
UEBA Endpoint I {151) 19 BusinessCritialCloud App 36(< 1%)
22(< 1%,
Data Source ID (11) 20 tcp/55800 (< 1%) 3.2 KB 15s
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Outbreak Alerts

The FortiAnalyzer Outbreak Detection Service is a licensed feature that allows FortiAnalyzer administrators to view
outbreak alerts and automatically download related event handlers and reports from FortiGuard.

When FortiAnalyzer has a valid license for the Outbreak Detection Service, outbreak alerts from Fortinet are displayed in
the FortiSoC > Outbreak Alerts pane. Outbreak alerts can be viewed from any ADOM. You can navigate between
outbreak alerts by clicking on the corresponding tab at the top of the pane, and click the download icon to download a
copy of the outbreak alert.

Outbreak event handlers and reports are created in real-time by Fortinet to detect and respond to emerging outbreaks.
Outbreak reports and event handlers are automatically downloaded so that they are available in your environment. See
Viewing imported event handlers and reports on page 212.

Without a valid license for the Outbreak Detection Service, Outbreak Alerts displays a default alert page, and outbreak
event handlers and reports are not available from FortiGuard. To obtain a valid license for FortiAnalyzer Outbreak
Detection Service, contact Fortinet FortiCare.

Viewing imported event handlers and reports

With a valid license, the FortiAnalyzer Outbreak Detection Service automatically downloads event handlers and reports
created by Fortinet in response to known outbreaks. This section includes information on how to view downloaded
outbreak event handlers and reports.

To view outbreak event handlers and reports:

1. Goto FortiSoC > Handlers > Event Handler List.
Event handlers created by the FortiAnalyzer Outbreak Detection Service are displayed with the Outbreak Alert
prefix. See Event handlers on page 135.

+ CreateNew [# Edit ¥ Delete % Clone § Morev Q
O v Status Name Filters Devices Send Alert to Events Included Subnets Excluded Subnets
e] (] Local Device Event > 1 Filter Local Device 189
e] (] Default-Botnet-Communication-Detection-By-Threat > 9 Filters All Devices
e] (] Default-Compromised Host-Detection-IOC-By-Threat > 3 Filters All Devices
o (] Default-Malicious-Code-Detection-By-Threat > 8 Filters All Devices 1891
o (] Default-Risky-Destination-Detection-By-Threat > 15 Filters All Devices 1084
8] o Default-Risky-App-Detection-By-Threat > 2 Filters All Devices 270
o (] Default-Malicious-File-Detection-By-Threat > 8 Filters All Devices 2
o] ] Default-Risky-App-Detection-By-Endpoint > 4 Filters All Devices 270
o] ] Default-Malicious-File-Detection-By-Endpoint > 24 Filters All Devices 2
o] ] Default-Malicious-Code-Detection-By-Endpoint > 8 Filters All Devices 1889
0] ] Default-Risky-Destination-Detection-By-Endpoint > 14 Filters All Devices 375
o] -] Default-Compromised Host-Detection-10C-By-Endpoint > 3 Filters All Devices
o] ] Default-Botnet-Communication-Detection-By-Endpoint > 9 Filters All Devices
o] -] Qutbreak Alert - Fortinet_SOC-Hafnium-MS-Exchange-Attack-Detect > 4 Filters All Devices
0] V] Qutbreak Alert - Fortinet_SOC-DearCry-Ransomware-Detection > 3 Filters All Devices
0 (V] Out\:rc&kA\:'t - FDVULC( SOC-Compromised Host Detection SolarW > 18 Filters All Devices
0 @ Default FFW System Events > 8 Filters All Devices
0 @ Default-FFW-Compromised Host-Detection-IOC-By-Threat > 3 Filters All Devices
O @  Default-FFW-Risky-Destination-Detection-By-Threat > 10Filters All Devices
e] @ Default-FFW-Risky-Destination-Detection-By-Endpoint > 10 Filters All Devices
e] @ Default-FFW-Compromised Host-Detection-IOC-By-Endpoint > 2 Filters All Devices

2. Goto Reports > All Reports.
The Outbreak Alert Reports folder includes available reports from the FortiAnalyzer Outbreak Detection Service.
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Reports can be run in HTML, PDF, XML, CSV, and JSON output formats. See Generating reports on page 215.

Meonthly @ 2021/05/12 09:40 AM

older ~ O Show Scheduled
o Language  Cache Status Time Period Devices Schedule
O » B Application
O » 5 Detailed User Report
O p B FortiClient Report
O w1 Qutbreak Alert Reports
O B Outbreak Alert - DearCry Report - Fortinet English Last 7 Days All_FortiGate
O B Outbreak Alert - Hafnium MS.Exchange Attack Detection Report - Fortinet English Last 7 Days >2 Devices
O B Outbreak Alert - SolarWinds Normalized Report English
O B&web
0 oo English T -t 7 Doy All_Device Weekly Monday @ 09:50 AM
O & 0o Timestamp English [ REELEE All_Device
O B 360 Protection Report English Last 30 Days All_Device
O B 360-Degree Security Review English O o<t 7 Davs All Device Hourly @10:20 AM
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You can generate data reports from logs by using the Reports feature. You can do the following:

» Use predefined reports. Predefined report templates, charts, and macros are available to help you create new
reports.

» Create custom reports.

Report files are stored in the reserved space for the FortiAnalyzer device. See Automatic deletion on page 106.
When rebuilding the SQL database, Reports are not available until the rebuild is completed.
Select the Show Progress link in the message to view the status of the SQL rebuild.

For more information on FortiAnalyzer report technology and troubleshooting report performance issues, see the
FortiAnalyzer Report Performance Troubleshooting Guide.

How ADOMs affect reports

When ADOMs are enabled, each ADOM has its own reports, libraries, and advanced settings. Make sure you are in the
correct ADOM before selecting a report. See Switching between ADOMs on page 26.

Some reports are available only when ADOMs are enabled. For example, ADOMs must be enabled to access
FortiCarrier, FortiCache, FortiClient, FortiDDoS, FortiMail, FortiSandbox, and FortiWeb reports. In a Security Fabric
ADOM, all reports are displayed.

You can configure and generate reports for these devices within their respective default ADOM or a Security Fabric
ADOM. These devices also have device-specific charts and datasets.

Predefined reports, templates, charts, and macros

FortiAnalyzer includes a number of predefined elements you can use to create and/or build reports.

Predefined... GUI Location Purpose
Reports Reports > Report Definitions > All You can generate reports directly or with minimum
Reports setting configurations. Predefined reports are actually

report templates with basic default setting configurations.

Templates Reports > Report Definitions > You can use directly or build upon. Report templates
Templates include charts and/or macros and specify the layout of
the report. A template populates the Layout tab of a
report that is to be created. See List of report templates
on page 232.
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Predefined... GUI Location Purpose
Charts Reports > Report Definitions > Chart You can use directly or build upon a report template you
Library are creating, or in the Layout tab of a report that you are

creating. Charts specify what data to extract from logs.

Macros Reports > Report Definitions > Macro ~ You can use directly or build upon a report template that
Library you are creating, or in the Layout tab of a report that you
are creating. Macros specify what data to extract from
logs.

Logs used for reports

Reports uses Analytics logs to generate reports. Archive logs are not used to generate reports. For more information,
see Data policy and automatic deletion on page 36.

For reports about users, the FortiGate needs to populate the user field in the logs sent to FortiAnalyzer.

How charts and macros extract data from logs

Reports include charts and/or macros. Each chart and macro is associated with a dataset. When you generate a report,
the dataset associated with each chart and macro extracts data from the logs and populates the charts and macros.
Each chart requires a specific log type.

FortiAnalyzer includes a number of predefined charts and macros. You can also create custom charts and macros.

How auto-cache works

When you generate a report, it can take days to assemble the required dataset and produce the report, depending on the
required datasets. Instead of assembling datasets at the time of report generation, you can enable the auto-cache
feature for the report.

Auto-cache is a setting that tells the system to automatically generate hcache. The hcache (hard cache) means that the
cache stays on disk in the form of database tables instead of memory. Hcache is applied to “matured” database tables.
When a database table rolls, it becomes “mature”, meaning the table will not grow anymore. Therefore, it is unnecessary
to query this database table each time for the same SQL query, so hcache is used. Hcache runs queries on matured
database tables in advance and caches the interim results of each query. When it is time to generate the report, much of
the datasets are already assembled, and the system only needs to merge the results from hcaches. This reduces report
generation time significantly.

The auto-cache process uses system resources to assemble and cache the datasets and it takes extra space to save
the query results. You should only enable auto-cache for reports that require a long time to assemble datasets.

Generating reports

You can generate reports by using one of the predefined reports or by using a custom report that you created. You can
find all the predefined reports and custom reports listed in Reports > Report Definitions > All Reports.
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To generate a report:

1. Goto Reports > Report Definitions > All Reports.
2. Inthe content pane, select a report from the list.

3. (Optional) Click Edit in the toolbar and edit settings on the Settings and Layout tabs. For a description of the fields in

the Settings and Layout tabs, see Reports Settings tab on page 220 and Creating charts on page 236 and Macro
library on page 239.

4. Inthe toolbar, click Run Report.

Generated reports can be attached to incidents. See Adding reports to an incident on page 192.

Viewing completed reports

After you generate reports, you can view completed reports in Reports > Generated Reports or Reports > Report
Definitions > All Reports. You can view reports in the following formats: HTML, PDF, XML, CSV, and JSON.

To view completed reports in Generated Reports:

1. Goto Reports > Generated Reports.
This view shows all generated reports for the specified time period.
2. To sort the report list by date, click Order by Time.To sort the report list by report name, click Order by Name.

3. Locate the report and click the format in which you want to view the report to open the report in that format.
For example, if you want to review the report in HTML format, click the HTML link.

To view completed reports in All Reports:

1. Goto Reports > Report Definitions > All Reports.
2. Onthe report list, double-click a report to open it.

3. Inthe View Report tab, locate the report and click the format in which you want to view the report to open the report
in that format.

For example, if you want to review the report in HTML format, click the HTML link.

Enabling auto-cache

You can enable auto-cache to reduce report generation time for reports that require a long time to assemble datasets.
For information about auto-cache and hcache, see How auto-cache works on page 215.

You can see the status of building the cache in Reports > Report Definitions > All Reports in the Cache Status column.

To enable auto-cache:

Go to Reports > Report Definitions > All Reports.

Select the report from the list, and click Edit in the toolbar.
In the Settings tab, select the Enable Auto-cache checkbox.
Click Apply.
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Grouping reports

If you are running a large number of reports which are very similar, you can significantly improve report generation time
by grouping the reports. Grouping reports has these advantages:

» Reduce the number of hcache tables.
o Improve auto-hcache completion time.
e Improve report completion time.

Step 1: Configure report grouping

For example, to group reports with titles containing string Security Report by device ID and VDOM, enter the
following CLI commands:

config system report group
edit O
set adom root
config group-by
edit devid

next
edit vd
next
end
set report-like Security Report
next
end
Notes:

o The report-1ike field specifies the string in report titles that is used for report grouping. This string is case-
sensitive.

e The group-by value controls how cache tables are grouped.

« To view report grouping information, enter the following CLI command, then check the Report Group column of the
table that is displayed.
execute sgl-report list-schedule <ADOM>

Step 2: Initiate a rebuild of hcache tables

To initiate a rebuild of hcache tables, enter the following CLI command:

diagnose sgl hcache rebuild-report <start-time> <end-time>

Where <start-time>and <end-time> are in the format: <yyyy-mm-dd hh:mm:ss>.

Retrieving report diagnostic logs

Once you start to run a report, FortiAnalyzer creates a log about the report generation status and system performance.
Use this diagnostic log to troubleshoot report performance issues. For example, if your report is very slow to generate,
you can use this log to check system performance and see which charts take the longest time to generate.

For information on how to interpret the report diagnostic log and troubleshoot report performance issues, see the
FortiAnalyzer Report Performance Troubleshooting Guide.
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To retrieve report generation logs:

1. In Reports > Generated Report, right-click the report and select Retrieve Diagnostic to download the log to your
computer.

2. Use atext editor to open the log.

Auto-Generated Reports

The Cyber Threat Assessment report is automatically generated. By default, the report will run at 3:00AM every Monday.
For more information on report scheduling, see Scheduling reports on page 218.

Schedules can be viewed in the Report Calendar. See Report calendar on page 250.

Ay
‘Q' This will only affect newly installed FortiAnalyzer or newly created ADOM. Upgraded ADOM
- reports, scheduling and calendar will be kept as is.

Scheduling reports

You can configure a report to generate on a regular schedule. Schedules can be viewed in the Report Calendar. See
Report calendar on page 250.

To schedule a report:

Go to Reports > Report Definitions > All Reports.
Select a report and click Edit in the toolbar.
Click Settings in the toolbar.

Select the Enable Schedule checkbox and configure the schedule.
Click Apply.
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Creating reports

You can create reports from report templates, by cloning and editing predefined/existing reports, or start from scratch.

Creating reports from report templates

You can create a new report from a template. The template populates the Layout tab of the report. The template
specifies what text, charts, and macros to use in the report and the layout of the content. Report templates do not contain
any data. Data is added to the report when you generate the report.

To create a new report from a template:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > All Reports.
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3. Inthetoolbar, click Report > Create New. The Create Report dialog box opens.

Create Report

Mame
Create from Elank
(® From Template
Template - Cyber Threat Assessment
Save to Folder All Reports/Application Reports « |+

4. Inthe Name box, type a name for the new report. The following characters are NOT supported in report names: \/"'
<>&,|#?%$+

5. Select From Template for the Create from setting, then select a template from the dropdown list. The template
populates the Layout tab of the report.

6. Select the folder that the new report will be saved to from the dropdown list. You can click the add button to include
additional folder locations. See Organizing reports into folders on page 229

7. Select OKto create the new report.

8. On the Settings tab, configure the settings as required. For a description of the fields, see Reports Settings tab on
page 220.

9. Optionally, go to the Layout tab to customize the report layout and content. For a description of the fields, see
Reports Editor tab on page 224.

10. Click Apply to save your changes.

#)

Creating reports by cloning and editing
You can create reports by cloning and editing predefined and/or existing reports.

To create a report by cloning and editing:

If using ADOMs, ensure that you are in the correct ADOM.
Go to Reports > Report Definitions > All Reports.
In the content pane, select the report from the list, then click Report > Clone in the toolbar.

In the Clone Report dialog box, type a name for the cloned report. The following characters are NOT supported in
reportnames:\/"'<>&,|#?%$ +

5. Select the folder that the new report will be saved to from the dropdown list. See Organizing reports into folders on
page 229

6. Select OKto create the new report.
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7. Onthe Settings tab, configure the settings as required. For a description of the fields, see Reports Settings tab on
page 220.

8. Optionally, go to the Layout tab to customize the report layout and content. For a description of the fields, see
Reports Editor tab on page 224.

9. Click Apply to save your changes.

Creating reports without using a template

To create a report without using a template:

If using ADOMs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the toolbar, click Report > Create New. The Create New Report dialog box opens.

In the Name box, type a name for the new report. The following characters are NOT supported in report names: \/"'

<>&,|#?%$+

5. Select the Blank option for the Create from setting.

6. Select the folder that the new report will be saved to from the dropdown list. You can click the add button to include
additional folder locations. See Organizing reports into folders on page 229

7. Select OKto create the new report.

8. Onthe Settings tab, you can specify a time period for the report, what device logs to include in the report, and so on.

You can also add filters to the report, add a cover page to the report, and so on. For a description of the fields, see

Reports Settings tab on page 220.
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x To create a custom cover page, you must select Print Cover Page in the Advanced

Settings menu.

9. Onthe Layout tab, you can specify the charts and macros to include in the report, as well as report content and
layout.
For a description of the fields, see Reports Editor tab on page 224.

For information about creating charts and macros, see Creating charts on page 236 and Creating macros on page
239.

10. Click Apply to save your changes.

Reports Settings tab

The following options are available in the Settings tab:

Field Description

Name The report name.

Time Period The time period the report covers.

Available report filter time periods include Previous 7 Days, Previous 14 Days, Previous
30 Days, This Week, Previous Week, Previous 2 Weeks, Previous N Hours, Previous

N Days, Previous N Weeks, This Month, Previous Month, This Quarter, Previous Quarter,
This Year, Today, Yesterday, and Custom.

FortiAnalyzer 7.2.2 Administration Guide 220
Fortinet Inc.



Reports

Field Description

Select a time period or select Custom to manually specify the start and end date and time.
The specific range of time included for your report is displayed below the selected Time

Period.
V) Previous time period filters can include up to the previous days data at
‘9' the latest, and do not include data from the current day. This ensures
|| that data is not missed during report generation and that scheduled
- reports using these filters include a consistent time period.
Devices The devices to include in the report. Select either All Devices or Specify to add specific

devices. Select the add icon to select devices.

Subnets Select All Subnets to include all subnets, or select Specify to include/exclude subnets as a
filter for this report. See Subnets on page 117.

Type Select either Single Report (Group Report) or Multiple Reports (Per-Device).
This option is only available if multiple devices are selected.
Enable Schedule Select to enable report template schedules.
Enable Notification Select to enable notification to the selected output profile.
Enable Auto-Cache Select to assemble datasets before generating the report and as the data is available.

This process uses system resources and is recommended only for reports that require
days to assemble datasets. Disable this option for unused reports and for reports that
require little time to assemble datasets.

Extended Log Enable to cache the following log fields for faster filtering.
Filtering » Device ID

e Source Endpoint ID

» Source IP

* Source UserID

* Destination |IP

Generate PDF Report Select when the report is generated.

Every Enter a number for the frequency of the report based on the time period selected from the
dropdown list.

Start time Enter a starting date and time for the file generation.

End time Enter an ending date and time for the file generation, or set it to never ending.

Enable Notification Select to enable report notification.

Output Profile Select the output profile from the dropdown list, or click Create New to create a new output

profile. See Output profiles on page 247.

Filters section of Reports Settings tab

See Filtering report output on page 227.
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Advanced Settings section of Reports Settings tab

The following options are available in the Advanced Settings section of the Settings tab.

Field Description

Language Select the report language.

Bundle rest into “Others” Select to bundle the uncategorized results into an Others category.

Print Orientation Set the print orientation to portrait or landscape.

Chart Heading Level Set the heading level for the chart heading.

Default Font Set the default font.

Hide # Column Select to hide the column numbers.

Layout Header Enter header text and select the header image. Accept the default Fortinet image

or click Browse to select a different image.

Layout Footer Select either the default footer or click Custom to enter custom footer text in the
text field.
Print Cover Page Select to print the report cover page. Click Customize to customize the cover

page. See Customizing report cover pages on page 223.
Print Table of Contents Select to include a table of contents.

Print Device List Select to print the device list. Select Compact, Count, or Detailed from the
dropdown list.

Print Report Filters Select to print the filters applied to the report.

Obfuscate User Select to hide user information in the report.

Resolve Hosthame Select to resolve hostnames in the report.

Allow Save Maximum Select a value between 1-10000 for the maximum number of reports to save.
Color Code The color used to identify the report on the calendar. Select a color code from the

dropdown list to apply to the report schedule. Color options include: Bold Blue,
Blue, Turquoise, Green, Bold Green, Yellow, Orange, Red, Bold Red, Purple, and
Gray.

Enable Report Filter Caching Select to accelerate processing speed when generating multiple reports. In this
case, all filters are applied when querying the hcache table. This is the default.

De-select to improve report accuracy. In this case, the filters are put inside the
hcache to increase data accuracy. However, this will also impact performance.

Enable High Accuracy Select to increase the maximum hcache rows, increasing data accuracy.
Caching You can show, set, or reset the maximum number of rows for high-accuracy
hcache by entering the following command in the FortiAnalyzer CLI:
diagnose sgl config hcache-max-high-accu-row [reset | set
<integer>]

De-select to use the default number of hcache rows, increasing system
performance. This is the default.
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Field Description

You can show, set, or reset the default number of hcache rows by entering the
following command in the FortiAnalyzer CLI:

diagnose sqgl config hcache-max-rpt-row [reset | set
<integer>]

Customizing report cover pages

A report cover page is only included in the report when enabled on the Settings tab in the Advanced Settings section.

When enabled, the cover page can be customized to contain the desired information and imagery.

To customize a report cover page:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the content pane, select the report from the list, and click Report > Edit in the toolbar.
Select the Settings tab and then click Advanced Settings.

Select the Print Cover Page checkbox, then click Customize next to the checkbox. The Edit Cover Page pane
opens.

S

Edit Cover Page

Background Image Browse...
def_cove...png
Top Image Browse...
Top Image Position Center
Text Color W Black
Show Creation Time
— {3 Show Data Range
) . Report Title (default]
360-Degree Security Review

Custom Text 1
cport Date: June 02, 2016 07:01

Data Range: 2016-06-01 0701 2016 06-02 07:01 (FAZ local) Custom Text 2
Bottom Image Browse...
Footer Left Text {default)
Footer Right Text {default}

Footer Background Color Gray

Fortinet nc. All Rights Reserved ‘Created on yyyy-min-dd Hr Mt
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6. Configure the following settings:

Background Image Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image as the background image of the
cover page.

Top Image Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image at the top of the cover page.

Top Image Position Select the top image position from the dropdown menu. Select one of the
following: Left, Center, Right.

Text Color Select a text color from the dropdown list.

Show Creation Time Select to print the report date on the cover page.

Show Data Range Select to print the data range on the cover page.

Report Title Accept the default title or type another title in the Report Title field.
Custom Text 1 If you want, enter custom text for the Custom Text 1 field.
Custom Text 2 If you want, enter custom text for the Custom Text 2 field.

Bottom Image Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image to the bottom of the cover page.

Footer Left Text If you want, enter custom text to be printed in the left footer of the cover page.
Footer Right Text If you want, enter custom text to be printed in the right footer of the cover page.
Footer Background Color Select the cover page footer background color from the dropdown list.

Reset to Default Select to reset the cover page settings to their default settings.

7. Click OKto save the configurations and return to the Settings tab.

Reports Editor tab

Because the cut, copy, and paste functions need access to the clipboard of your operating
system, some Internet browsers either block it when called from the layout editor toolbar, or

ask you to explicitly agree to it. If you're blocked from accessing the clipboard by clicking the
respective cut, copy, and paste buttons from the toolbar or context menu, you can always use
keyboard shortcuts.

The following options are available in the Editor tab (layout editor):

Field Description

Insert Chart or Edit Chart Click to insert a FortiAnalyzer chart. Charts are associated with datasets that
extract data from logs for the report.
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Field Description

In the Insert Chart or Chart Properties dialog box, you can specify a custom title,
width, and filters for the chart. For information on setting filters, see Filtering report
output on page 227.

You can edit a chart by right clicking the chart in the layout editor and selecting
Chart Properties or by clicking the chart to select it and then clicking Edit Chart.

Insert Macro Click to insert a FortiAnalyzer macro. Macros are associated with datasets that
extract data from logs for the report.

Image Click the Image button in the toolbar to insert an image into the report layout.
Right-click an existing image to edit image properties.

Table Click the Table button in the toolbar to insert a table into the report layout. Right-
click an existing table to edit a cell, row, column, table properties, or delete the
table.

Insert Horizontal Line Click to insert a horizontal line.

Insert Page Break for Printing  Click to insert a page break for printing.

Link Click the Link button in the toolbar to open the Link dialog box. You can select to
insert a URL, a link to an anchor in the text, or an email address.

Anchor Click the Anchor button in the toolbar to insert an anchor in the report layout.

Cut To cut a text fragment, start with selecting it. When the text is selected, you can
cut it using one of the following methods:
* Click the cut button in the toolbar
¢ Use the CTRL+X shortcut on your keyboard.

Copy To copy a text fragment, start with selecting it. When the text is selected, you can
copy it using one of the following methods:
« Click the copy button in the toolbar
¢ Use the CTRL+C shortcut on your keyboard.

Paste To paste text, start with cutting or copying from within the editor or from another
source. Once the text is cut or copied, you can paste it in the editor using one of
the following methods:

 Click the paste button in the toolbar

e Use the CTRL+V shortcut on your keyboard.

Undo Click to undo the last action. Alternatively, use the CTRL+Z keyboard shortcut to
perform the undo operation.

Redo Click to redo the last action. Alternatively, use the CTRL+Y keyboard shortcut to
perform the redo operation.

Find Type text in the search field, and then click Find to highlight instances of that text
in the editor. The instances of that text will be highlighted one at a time, starting at
the top of the editor. The search field is not case-sensitive.
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Field Description

Replace This is only actionable when text has been highlighted using the Find button. Type
the replacement text in the replace field, and then click Replace to put it in place of
the highlighted text.

Replace All This is only actionable when text has been highlighted using the Find button. Type
the replacement text in the replace field, and then click Replace All to putitin
place of all instances of the text in the Find field.

Save as Template Click to save the layout as a template.

Paragraph Format Select the paragraph format from the dropdown list. Select one of the following:
Normal, Heading 1, Heading 2, Heading 3, Heading 4, Heading 5, Heading 6.

Font Name Select the font from the dropdown list.
Font Size Select the font size from the dropdown list. Select a size ranging from 8 to 72.
Bold Select the text fragment and then click the Bold button in the toolbar. Alternatively,

use the CTRL+B keyboard shortcut to apply bold formatting to a text fragment.

Italic Select the text fragment and then click the /talic button in the toolbar. Alternatively,
use the CTRL+/ keyboard shortcut to apply italics formatting to a text fragment.

Underline Select the text fragment and then click the Underline button in the toolbar.
Alternatively, use the CTRL+U keyboard shortcut to apply underline formatting to
a text fragment.

Strike Through Select the text fragment and then click the Strike Through button in the toolbar.
Subscript Select the text fragment and then click the Subscript button in the toolbar.
Superscript Select the text fragment and then click the Superscript button in the toolbar.

Text Color You can change the color of text in the report by using a color palette. To choose a
color, select a text fragment, click the Text Color button in the toolbar, and select a
color.

Background Color You can also change the color of the text background.

Insert/Remove Numbered List Click to insert or remove a numbered list.
Insert/Remove Bulleted List Click to insert or remove a bulleted list.

Decrease Indent To decrease the indentation of the element, click the Decrease Indent toolbar
button. The indentation of a block-level element containing the cursor will
decrease by one tabulator length.

Increase Indent To increase the indentation of the element, click the Increase Indent toolbar
button. The block-level element containing the cursor will be indented with one
tabulator length.

Block Quote Block quote is used for longer quotations that are distinguished from the main text
by left and right indentation. It is recommended to use this type of formatting when
the quoted text consists of several lines or at least 100 words.
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Field Description

Align Left When you align your text left, the paragraph is aligned with the left margin and the
text is ragged on the right side. This is usually the default text alignment setting for
the languages with left to right direction.

Center When you center your text, the paragraph is aligned symmetrically along the
vertical axis and the text is ragged on the both sides. This setting is often used in
titles or table cells.

Align Right When you align your text right, the paragraph is aligned with the right margin and
the text is ragged on the left side. This is usually the default text alignment setting
for the languages with right to left direction.

Justify When you justify your text, the paragraph is aligned to both the left and right
margins and the text is not ragged on either side..

Remove Format Click to remove formatting.

Filtering report output
You can apply log message filters to reports and charts.

To filter output in a report:

Click the Settings tab and scroll to the Filters section.

To filter output in a chart:

1. Click the Layout tab.
2. Filter a new or existing chart:
« Click Insert Chart and scroll to the Filters section.
« Right-click a chart in the layout and select Chart Properties. Scroll to the Filters section.

In the Filters section, the following options are available.

Field Description

Log messages that match Available in the Settings tab only.

Select All to filter log messages based on all of the added conditions, or select
Any of the Following Conditions to filter log messages based on any one of the
conditions.

Add Filter Click to add filters. For each filter, select the field, and operator from the dropdown
lists, then enter or select the values as applicable.

Filters vary based on device type.
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Field Description

When adding a filter, keep the following considerations in mind:

NV ¢ The Settings and Layout tabs use the same Log Field list
‘9' to filter output; however, some log fields are not used in
charts. The Log Field you use to filter a report may not

apply to the log fields in a chart.
¢ The Value field is case sensitive.

LDAP Query Available in the Settings tab only.

Click to add an LDAP query, then select the LDAP Server and the Case Change
value from the dropdown lists.

Use this option to query an LDAP server for group membership. The results of this
query is used to filter the report to only match logs for users belonging to that
group.

You must specify the group name in the filter definition.

If you enable LDAP Query, the group name is not used to match the group field in

logs. The group name is only used for the LDAP query to determine group
membership.

The query will not retrieve the userPrincicpalName if the
- 1/ -’ Distinguished Name in the System Settings does not contain
9 an organization unit (ou). To retrieve the UPN, add the
= Distinguished Name as it appears in the System Settings to
your query.

vy
‘?' If both chart and report filters are selected for the same report, the chart filter will be used
- instead of the report filter.

Managing reports

You can manage reports by going to Reports > Report Definitions > All Reports. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click a report to display the menu.

Option Description

Run report Generates a report.
Report See below for report options.
Create New Creates a new report. You can choose whether to base the new report on a report
template.
Edit Edit the selected report.
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Option Description

Clone Clones the selected report.

Disable Schedule Disable the schedule for the selected report. You can enable schedules, if
needed, by editing the report.

Delete Deletes the selected report.

Remove from Remove the selected report from its current folder.

Folder

Move Move the report to a new folder location.

Assign to Folder Assign the selected report(s) to a folder. From the dropdown menu, select an

existing report folder. Click the add icon to add an additional folder. When multiple
folders are selected, reports are included in both folders.

Folder See below for folder options.

Create New folder Create a new folder. Folders can be nested.

Rename Folder Rename the currently selected folder.
Delete Folder Delete the currently selected folder. Folders which include reports cannot be
deleted.
More See below for more options.
Import Imports a report from a management computer.
Export Exports a report to a management computer.
Show Scheduled Only Filters the list to include only reports that have been run or are scheduled to be
run.

This setting is only available in the toolbar.

Organizing reports into folders

FortiAnalyzer reports are organized into default folders. You can create additional folders to organize reports. Reports
can be assigned to multiple folders, and folders can be nested.

To organize reports into folders:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > All Reports.
3. Click Folderin the toolbar, and select Create New Folder.

Create Folder

Name New Reports

Save to Folder All Reports

“ Cancel

4. Specify the folder name and location and click OK. The folder is now displayed in the report list.

#
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5. You can now drag-and-drop, move, assign, create, clone, or import reports into this folder. See Managing reports on
page 228.

To move folder locations:

If using ADOMs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

Highlight an existing folder, and select Report > Move from the right-click menu.
Select the target folder location, and click OK.
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Importing and exporting reports

You can transport a report between FortiAnalyzer units. You can export a report from the FortiAnalyzer unit to the

management computer. The report is saved as a .dat file on the management computer. You can then import the report
file to another FortiAnalyzer unit.

Exporting reports only exports the report layout, charts, datasets, and images. Other report
configurations are not exported.

To export reports:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > All Reports.

3. Inthe content pane, select a report, and select More > Export in the toolbar to save the file to the management
computer.

To import reports:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.

2. Goto Reports > Report Definitions > All Reports.

3. Inthe content pane, click More > Import in the toolbar. The Import Report dialog box opens.
4

Drag and drop the report file onto the dialog box, or click Browse and locate the file to be imported on your local
computer.

Select a folder to save the report to from the dropdown list.
Click OK to import the report.

o a

Report template library

Because the cut, copy, and paste functions need access to the clipboard of your operating
system, some Internet browsers either block it when called from the layout editor toolbar, or

ask you to explicitly agree to it. If you're blocked from accessing the clipboard by clicking the
respective cut, copy and paste buttons from the toolbar or context menu, you can always use
keyboard shortcuts.
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A report template defines the charts and macros that are in the report, as well as the layout of the content.

You can use the following items to create a report template:

o Text

o Images

o Tables

o Charts that reference datasets
» Macros that reference datasets

Datasets for charts and macros specify what data are used from the Analytics logs when you generate the report. You
can also create custom charts and macros for use in report templates.

Creating report templates

You can create a report template by saving a report as a template or by creating a totally new template.

To create a report template:

Ao bdh-=

If using ADOMSs, ensure that you are in the correct ADOM.
Go to the Reports > Report Definitions> Templates.

In the toolbar of the content pane, click Create New.

Set the following options:

a.
b.
c.
d.

Name.

Description.

Category. If you are in a Security Fabric ADOM, the Category must be SecurityFabric.
Language.

5. Use the toolbar to insert and format text and graphics for the template. In particular, use the Insert Chart and Insert
Macro buttons to insert charts and macros into the template.

For a description of the fields, see Reports Editor tab on page 224. For information about creating charts and
macros, see Creating charts on page 236 and Creating macros on page 239.

6. Click OK.
The new template is now displayed on the template list.

To create a report template by saving a report:

o ODd-=

If using ADOMs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the content pane, select the report from the list, and click Edit in the toolbar.
In the Layout tab, click the Save As Template button in the toolbar.

In the Save as Template dialog box, set the following options, and click OK:

a. Name.
b. Description.

c. Category. If you are in a Security Fabric ADOM, the Category must be SecurityFabric.
The new template is now displayed on the template list.
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Viewing sample reports for predefined report templates
You can view sample reports for predefined report templates to help you visualize how the reports would look.

To view sample reports:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Gotothe Reports > Report Definitions > Templates.

3. Inthe content pane, click the HTML or PDF link in the Preview column of a template to view a sample report based
on the template.

Managing report templates

You can manage report templates in Reports > Report Definitions> Templates. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click a template to display the menu.

Option Description

Create New Creates a new report template

Edit Edits a report template. You can edit report templates that you created. You
cannot edit predefined report templates.

View Displays the settings for the predefined report template. You can copy elements
from the report template to the clipboard, but you cannot edit a predefined report
template.

Delete Deletes the selected report template. You cannot delete predefined report
templates.

Clone Clones the selected report template.

Create Report Creates the selected report template.

Install Template Pack Upload and install a template pack.

List of report templates

FortiAnalyzer includes report templates you can use as is or build upon when you create a new report. FortiAnalyzer
provide different templates for different devices.

You can find report templates in Reports > Report Definitions > Templates.

Application report templates

Template - Application Risk and Control Template - Self-Harm and Risk Indicators Report
Template - Bandwidth and Applications Report Template - Social Media Usage Report
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Template - Cyber-Bullying Indicators Report

Template - Detailed Application Usage and Risk
Template - High Bandwidth Application Usage Report
Template - SaaS Application Usage Report

Assets report templates

Template - Asset and Identity Report

Fabric report templates

Template - Fortinet Email Risk Assessment

Template - FortiPortal User Summary Report

FortiCache report templates

Template - FortiCache Default Report
Template - FortiCache Security Analysis

Template - FortiCache Web Usage Report

FortiClient report templates

Template - FortiClient Default Report
Template - FortiClient Vulnerability Scan Report

FortiDDoS report templates

Template - FortiDDoS Default Report

FortiDeceptor report templates

Template - FortiDeceptor Default Report

FortiAnalyzer 7.2.2 Administration Guide
Fortinet Inc.

Template - Top 20 Categories and Applications
(Bandwidth)

Template - Top 20 Categories and Applications (Session)

Template - Top Allowed and Blocked with Timestamps
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FortiMail report templates

Template - FortiMail Analysis Report
Template - FortiMail Default Report
Template - FortiMail Summary Report

FortiNAC report templates

Template - FortiNAC Endpoints and Network Report

FortiNDR (formerly FortiAl) report templates

Template - FortiNDR Breach Prevention Report

Template - FortiNDR Network Anomalies Report

FortiProxy report templates

Template - FortiProxy Default Report
Template - FortiProxy Security Analysis
Template - FortiProxy Web Usage Report

FortiSandbox report templates

Template - Endpoint Sandbox Detections Report
Template - FortiSandbox CTAP Report

Template - FortiSandbox Default Report

FortiWeb report templates

Template - FortiWeb Default Report

Template - FortiWeb Web Application Analysis Report

Security report templates

Template - 360-Degree Security Review Template - Security Events and Incidents Summary
Template - 360 Security Report Template - Situation Awareness Report
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Template - Cyber Threat Assessment

Template - Daily Summary Report

Template - Data Loss Prevention Detailed Report
Template - DNS Security Report

Template - Email Report

Template - FortiClient Default Report from FortiGate

Template - FortiClient Vulnerability Scan Report from
FortiGate

Template - IPS Report
Template - PCI-DSS Compliance Review

Template - Security Analysis

System report templates

Template - 360 Protection Report
Template - Admin and System Events Report
Template - DNS Report

Template - FortiGate Performance Statistics Report

User report templates

Template - Client Reputation

Template - User Detailed Browsing Log
Template - User Security Analysis

Template - User Top 500 Websites by Bandwidth

Template - User Top 500 Websites by Session

Web report templates

Template - Hourly Website Hits

Template - Top 20 Category and Websites (Bandwidth)

Template - Top 20 Category and Websites (Session)
Template - Top 500 Sessions by Bandwidth
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Template - SOC Incident Report
Template - Threat Report

Template - VPN Report

Template - Web Usage Report

Template - Web Usage Summary Report
Template - What is New Report

Template - WiFi Network Summary

Template - Wireless PCl Compliance

Template - GTP Report
Template - Secure SD-WAN Assessment Report
Template - Secure SD-WAN Report

Template - Throughput Utilization Billing Report

235



Reports

Chart library

Use the Chart library to create, edit, and manage your charts.

In a Security Fabric ADOM, you can insert charts from all device types into a single report.

Creating charts

Al
‘Q' You can also create charts using the Log View Chart Builder. See Creating charts with Chart
- Builder on page 99.

To create charts:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > Chart Library.
3. Click Create New in the toolbar.

Create Chart

Name
Description
Dataset App-Risk-App-Usage-By-Category

Resolve Inherit
Hostname

Chart Type Table

Data Bindings ~ Table Type
@® Regular O Ranked O Drilldown

Columns

Column 1 Column 2
it o it i
ftle appcat itle bandwidth
Width (o 2| %(0for Auto) Width [0 [2l| %(0for Auto)
Data Binding ~ Format Data Binding  Format
appcat v | | Default MR bandwidth + | | Default S |

{5 Order By appcat
Show Top (O for all results) 10 |2

4. Configure the settings for the new chart, the click OK.

Name Enter a name for the chart.
Description Enter a description of the chart.
Dataset Select a dataset from the dropdown list. For more information, see Datasets

on page 241. Options vary based on device type.

Resolve Hostname Select to resolve the hostname. Select one of the following: Inherit, Enabled,
or Disabled.
Chart Type Select a graph type from the dropdown list; one of: Table, Bar, Pie, Line, Area,
Donut, or Radar. This selection affects the rest of the available selections.
Data Bindings The data bindings vary depending on the chart type selected.
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Table
Table Type
Add Column

Columns

Order By

Show Top

Drilldown
Top

Bar

X-Axis

Y-axis

Bundle rest
into "Others"

Group By
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Select Regular, Ranked, or Drilldown.

Select to add a column. Up to 15 columns can be added for a Regular table.
Ranked tables have two columns, and Drilldown tables have three columns.

The following column settings must be set:

Column Title: Enter a title for the column.

Width: Enter the column width as a percentage.

Data Binding: Select a value from the dropdown list. The options vary
depending on the selected dataset.

Format: Select a value from the dropdown list.All formats are available
regardless of the data binding selected for the column. Select a format to
display the data according to your needs.

Y Some formats will only work with select data bindings.
‘?' For example, the Icon-IP Country/Region format only
- displays the correct flag icon when the Data Binding is
- dstcountry.

Add Data Binding: Add data bindings to the column. Every column must
have at least one data binding. The maximum number varies depending
on the table type.

Select what to order the table by. The available options vary depending on the
selected dataset.

Enter a numerical value. Only the first X’ items are displayed. Other items can
be bundled into the Others category for Ranked and Drilldown tables.

Enter a numerical value. Only the first ‘X’ items are displayed. This options is
only available for Drilldown tables.

Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.

Label: Enter a label for the axis.

Show Top: Enter a numerical value. Only the first ‘X’ items are displayed.
Other items are bundled into the Others category.

Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.

Format: Select a format from the dropdown list: Bandwidth, Counter,
Default, Percentage, or Severity.

Label: Enter a label for the axis.

Select to bundle the rest of the results into an Others category.

Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.
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e Show Top: Enter a numerical value. Only the first X’ items are displayed.
Other items can be bundled into the Others category.

Order By Select to order by the X-Axis or Y-Axis.
Pie, Donut, or Radar

Category e Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.
e Label: Enter alabel for the axis.
e Show Top: Enter a numerical value. Only the first X’ items are displayed.
Other items can be bundled into the Others category.

Series e Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.
e Format: Select a format from the dropdown list: Bandwidth, Counter,
Default, Percentage, or Severity.
e Label: Enter a label for the axis.

Bundle rest Select to bundle the rest of the results into an Others category.

into "Others"
Line or Area
X-Axis e Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.
e Format: Select a format from the dropdown list: Default, or Time.
e Label: Enter a label for the axis.
Lines e Data Binding: Select a value from the dropdown list. The available options
vary depending on the selected dataset.
e Format: Select a format from the dropdown list: Bandwidth, Counter,
Default, Percentage, or Severity.
» Type: Select the type from the dropdown list: Line Up or Line Down.
e Legend: Enter the legend text for the line.
Add line Select to add more lines.

Managing charts

Manage your charts in Reports > Report Definitions > Chart Library. Some options are available as buttons on the
toolbar. Some options are available in the right-click menu. Right-click a chart to display the menu.

Option Description

Create New Creates a new chart.
Edit Edits a chart. You can edit charts that you created. You cannot edit predefined
charts.
View Displays the settings for the selected predefined chart. You cannot edit a
predefined chart.
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Option Description

Delete Deletes the selected chart. You can delete charts that you create. You cannot
delete predefined charts.

Clone Clones the selected chart.

Import Imports a previously exported FortiAnalyzer chart.
Export Exports one or more FortiAnalyzer charts.

Show Predefined Displays the predefined charts.

Show Custom Displays the custom charts.

Search Lets you search for a chart name.

Viewing datasets associated with charts

To view datasets associated with charts:

If using ADOMs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > Chart Library.

Select a chart, and click View in the toolbar.

In the View Chart pane, find the name of the dataset associated with the chart in the Dataset field.
Go to Reports > Report Definitions > Datasets.

In the Search box, type the name of the dataset.

Select the dataset that is found, and click View in the toolbar to view it.

Nooahsobdb-=

Macro library

Use the Macro library to create, edit, and manage your macros.

Creating macros
FortiAnalyzer includes a number of predefined macros. You can also create new macros, or clone and edit existing
macros.

Macros are predefined to use specific datasets and queries. They are organized into categories, and can be added to,
removed from, and organized in reports.

FortiAnalyzer 7.2.2 Administration Guide 239
Fortinet Inc.



Reports

To create a new macro:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > Macro Library, and click Create New. The Create Macro pane is displayed.

Create Macro

Name
Description
Dataset App-Risk-App-Usage-By-Category

Query sele

Data Binding

Display Text

3. Provide the required information for the new macro.

Name Enter a name for the macro.

Description Enter a description of the macro.

Dataset Select a dataset from the dropdown list. The options will vary based on device
type.

Query Displays the query statement for the dataset selected.

Data Binding The data bindings vary depending on the dataset selected. Select a data

binding from the dropdown list.

Display Select a value from the dropdown list.

4. Click OK. The newly created macro is shown in the Macro library.

Managing macros

You can manage macros by Reports > Report Definitions > Macro Library. Some options are available as buttons on the
toolbar. Some options are available in the right-click menu. Right-click a macro to display the menu.

Option Description

Create New Creates a new macro.

Edit Edits the selected macro. You can edit macros that you created. You cannot edit
predefined macros.

View Displays the settings for the selected macro. You cannot edit a predefined macro.

Delete Deletes the selected macro. You can delete macros that you create. You cannot
delete predefined macros.

Clone Clones the selected macro.
Show Predefined Displays the predefined macros.
Show Custom Displays the custom macros.
Search Lets you search for a macro name.
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Viewing datasets associated with macros

To view datasets associated with macros:

If using ADOMSs, ensure that you are in the correct ADOM.
Go to Reports > Report Definitions> Macro Library.
Select a macro, and click View (for predefined macros) or Edit (for custom macros) in the toolbar.

Go to Reports > Report Definitions> Datasets.
In the Search box, type the name of the dataset.
Double-click the dataset to view it.

No o bkowobh-=

Datasets

Use the Datasets pane to create, edit, and manage your datasets.

Creating datasets

FortiAnalyzer datasets are collections of data from logs for monitored devices. Charts and macros reference datasets.

When you generate a report, the datasets populate the charts and macros to provide data for the report.

FortiAnalyzer has many predefined datasets that you can use right away. You can also create your own custom
datasets. An easy way to build a custom query is to copy and modify a predefined dataset's query.

To create a new dataset:

1. Ifusing ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > Datasets, and click Create New.
3. Inthe Create Dataset pane, provide the required information for the new dataset.

Create Dataset

Name custom_dataset Test
Log Type Application .| Time Period Previous 7 Days ~
Query 1 sELECT Devices © All Devices () Specify

2 catdesc,

3 sum(num_sess) AS nun_sess,
4  sun(bandwidth) AS bandwidth

5 FROM

Variable Expression Description

Click here to add new entry.
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In the View Macro or Edit Macro pane, find the name of the dataset associated with the macro in the Dataset field.
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Name

Log Type

Query

Validate

Analyze Query
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Enter a name for the dataset.

Select a log type from the dropdown list. Below is a list of the available log
types based on device.

FortiGate: Application, Intrusion Prevention, Content , Data Leak
Prevention, DNS, Email Filter, Event, FortiClient System Event,
FortiClient Security Event, FortiClient Traffic, File Filter, GTP,
Vulnerability Scan, Protocol, SSH, SSL, Traffic, Antivirus, VolP, Web
Application Firewall, Web Filter, Local Event.

FortiMail: Email Filter, Event, History, and Antivirus.

FortiAnalyer: Application, Event, and Local Event.

FortiWeb: Attack , Event, and Traffic.

FortiCache: Application, Intrusion Prevention, Content , Data Leak
Prevention, Email Filter, Event, Vulnerability Scan, Traffic, Antivirus,
VolIP, and Web Filter.

FortiClient: FortiClient System Event, FortiClient Security Event,
FortiClient Traffic.

Syslog: Syslog.

FortiManager: Application and Event.

FortiSandbox: Event, Vulnerability Scan, and Antivirus.
FortiDDoS: Intrusion Prevention and Event.

FortiAuthenticator: Event.

FortiProxy: Application, Intrusion Prevention, Data Leak Prevention,
DNS, Email Filter, Event, SSH, Traffic, Antivirus, VolP, and Web Filter.
FortiNAC: Asset and Event.

FortiFirewall: DNS, Event, File Filter, GTP, SSH, SSL, and Traffic.
FortiDeceptor: Event.

FortiSOAR: Event

FortiADC: Intrusion Prevention, Event, and Traffic.

FortiNDR (formerly FortiAl): Attack, Event, and Vulnerability Scan.
Fabric: Normalized.

Enter the SQL query used for the dataset.

While entering SQL in the query field, automatic suggestions are provided that
offer a list of possible commands, table names, log fields, and more to use in

your query.

Click Validate to validate the entered SQL query. If any errors are presentin
the query, the details of the error are displayed below, otherwise the message

will display OK.

Click Analyze Query to perform a detailed analysis on the SQL query. Analyze

Query displays the original SQL query, the transformed SQL query (if
applicable), and the SQL validation results.

This function also allows users to view the hcache query that is used when a
report using this dataset has enabled the auto-cache option for faster report
generation. For more information on hcache, see How auto-cache works on

page 215
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Format Click Format to automatically format the entered SQL query, making it easier
to read, update, and detect errors.

Variables Click the Add button to add variable, expression, and description information.

If added, the expression for the variable will be used when configuring filters
for reports that use this dataset. For example, if Variable = User (user) and
Expression = coalesce(nullifna("user’), ipstr("srcip’)), then the expression will
be used when User (user) is selected as the Log Field in a report's filter. See
Filtering report output on page 227.

Test Click to test the SQL query before saving the dataset configuration.
Click Stop to end a test in progress.

Time Period Use the dropdown list to select a time period. When selecting Custom, enter
the start date and time, and the end date and time.

Devices Select All Devices or Specify to select specific devices to run the SQL query
against. Click the Select Device button to add multiple devices to the query.

4. Click Test.
The query results are displayed. If the query is not successful, an error message appears in the Test Result pane.
5. Click OK.

Viewing the SQL query of an existing dataset
You can view the SQL query for a dataset, and test the query against specific devices or all devices.

To view the SQL query for an existing dataset:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.

2. Goto Reports > Report Definitions > Datasets.

3. Hover the mouse cursor over the dataset on the dataset list. The SQL query is displayed as a tooltip.
You can also open the dataset to view the Query field.

\ﬂ The SQL dataset test function can be used to determine if any errors are present in the

SQL format. It should not be used to test returned values as those may be different than the
ones used in reports.

SQL query functions

In addition to standard SQL queries, the following are some SQL functions specific to FortiAnalyzer. These are based on
standard SQL functions.

root_domain (hostname) The root domain of the FQDN. An example of using this function is:
select devid, root domain (hostname) as website FROM $log
WHERE 'user'="'USER0O1' GROUP BY devid, hostname ORDER BY
hostname LIMIT 7
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nullifna (expression) This is the inverse operation of coalesce that you can use tofilteroutn/a

values. This function takes an expression as an argument. The actual SQL syntax

thisisbaseonis select nullif (nullif (expression, 'N/A'),

'n/a').

In the following example, if the user is n/a, the source IP is returned, otherwise the

username is returned.

select coalesce(nullifna('user'), nullifna('srcip')) as user
src, coalesce(nullifna(root_domain(hostname)),'unknown')

as domain FROM $log WHERE dstport='80' GROUP BY user src,
domain ORDER BY user src LIMIT 7

email domain email domain returns the text after the @ symbol in an email address. email
cowad Eear user returns the text before the @ symbol in an email address. An example of
using this function is:

select 'from' as source, email user ('from') as e user, email
domain ('from') as e domain FROM $log LIMIT 5 OFFSET 10

from_dtime from dtime (bigint) returns the device timestamp without time zone. from
from itime itime (bigint) returns FortiAnalyzer’s timestamp without time zone. An
example of using this function is:
select itime, from itime(itime) as faz local time, dtime,
from dtime (dtime) as dev local time FROM $log LIMIT 3

get_devtype () Returns the source device type. An example of using this function is:

select get devtype (srcswversion, osname, devtype) as devtype
new, coalesce(nullifna( srcname’),nullifna( srcmac),
ipstr('srcip’)) as dev _src, sum(crscore%$65536) as scores
from $log where $filter and (logflag&l>0) and crscore is
not null group by devtype new, dev src having sum
(crscore%65536)>0 order by scores desc

This function may return null values. To replace null values with "Unknown", you

can add the following outer query:

select coalesce(nullifna( devtype new' ), 'Unknown') as
devtype newl,dev src, scores

from ### (select get devtype(srcswversion, osname, devtype) as
devtype new, coalesce(nullifna( srcname’),nullifna
(*srcmac’), ipstr('srcip’)) as dev_src, sum
(crscore%65536) as scores from $log where $filter and
(logflag&l>0) and crscore is not null group by devtype
new, dev src having sum(crscore%65536)>0 order by scores
desc ) ### t

Managing datasets

You can manage datasets by going to Reports > Report Definitions > Datasets. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click a dataset to display the menu.

Option Description

Create New Creates a new dataset.

Edit Edits the selected dataset. You can edit datasets that you created. You cannot
edit predefined datasets.
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Option Description

View Displays the settings for the selected dataset. You cannot edit predefined
datasets.
Delete Deletes the selected dataset. You can delete datasets that you create. You

cannot delete predefined datasets.

Clone Clones the selected dataset. You can edit cloned datasets.
Validate Validate selected datasets.

Validate All Custom Validates all custom datasets.

Search Lets you search for a dataset name.

Aliases and metadata tables

Aliases in predefined datasets

Some predefined FortiAnalyzer datasets make use of aliases which are labeled as t 1, t2, etc. These temporary names
can only be referenced within the dataset in which they are created.

As an example, the t1 and t2 aliases are used in the threat-Top-Intrusions-By-Types dataset to define the following
tables:

« t1:Intrusion Prevention log data.
e t2:The name, CVE, and vuln_type from the IPS_mdata table.

View Dataset

Name threat-Top-Intrusions-By-Types Go
Log Type Intrusion Prevention Time Period Previous 7 Days

Query 1 SELECT Devices @Al Devices ~

2 wuln_type,
3 count(*) AS totalnum

5 _slog t1
6 LEFT JOIN

7 SELECT

8 NAME,

9 cve,

18 vuln_type

11 FROM

12 ips_mdata

13 t2 ON tl.attack = t2.name
14 WHERE

15 $filter

16  AND vuln_type IS NOT NULL
17 GROUP BY

18  wuln_type

19 ORDER BY

28 totalnum DESC

Validate Analyze Query Format

Variables Variable Expression Description

Click here to add new entry.

FortiAnalyzer 7.2.2 Administration Guide 245
Fortinet Inc.



Reports

Metadata tables

FortiAnalyzer has access to metadata tables which are used in some predefined datasets to enrich a chart's data by
complementing log fields with information from FortiGuard. This is typically accomplished through the use of the
SQL JOIN clause.

As an example, in the threat-Top-Intrusions-By-Type dataset, the ijps_mdata metadata table is referenced. The ips_
mdata table is a collection of intrusion prevention related metadata from FortiGuard that is used by this dataset to add
information about vulnerability types, vulnerability names, and CVE data to intrusion prevention logs.

View Dataset

Name threat-Top-Intrusions-By-Types Go
Log Type Intrusion Prevention Time Period Previous 7 Days

Query 1 SELECT Devices @Al Devices ~

2 wvuln_type,
3 count(*) AS totalnum

5 _slog t1
6 LEFT JOIN
SELECT
NAME,
9 cve,
16 vuln_type
11 FROM
12 ips_mdata
13 12 ON tl.attack = t2.name
14 WHERE
15 Ffilter
16 AND vuln_type IS NOT NULL
17 GROUP BY
18  wvuln_type
19 ORDER BY
28 totalnum DESC

o ~

Validate Analyze Query Format

Variables Variable Expression  Description

Click here to add new entry.

You can view the information contained in the metadata tables (as well as other tables) using the following custom
dataset. An asterisk can be used to select all applicable fields.

select <field> from <table name>

For example, the custom dataset below displays all fields retrieved from the IPS metadata table.
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Create Dataset

Name Go

Log Type Application .| Time Period Previous 7 Days

Query 1 select * from ips_mdata Devices @Al Devices ~
id name group
10001 SafeMet.Sentinel.License.Manager.Buffer.Overflow applications
10002 CA.BrightStor.,ARCserve.UniversalAgent.Buffer.Overflow applications
10005 MS.IEValid.File.DragDrop.Code.Embedded web_client
10007 MS.Windows.HTML.Help.Control.CrossZone.Scripting web_server
10011 LHAFilename.Buffer.Overflow misc

WValidate Analyze Query Format

Variables . ) L 10016 MySQL.Create.Function.Privilege.Elevation database
Variable Expression Description
Click here to 2dd new entry. 10018  Oracle9i.XDB.FTPUnlock Overflow file._transfer

10020 MS.RPC.LLSSRV.Buffer.Overflow netbios
10029 IMAP.LOGIN.Command.Buffer.Overflow email
10041 ISC.DHCPD.Hostname.Buffer.Overflow operating_system
10052 Squid.NTLM.Authentication.Buffer.Overflow web_app
10072 Samba.NTTrans.Fragment.Buffer.Overflow netbios
10080 IBM.WebSphere.AS.Console.Buffer.Overflow web_server
10091 MS.Word.Malformed.Document.Integer.Buffer.Overflow applications

Metadata tables from FortiGuard are also available to be used in custom dataset queries. The following metadata tables
are available:

e ips_mdata

e app_mdata

« fct_mdata

e pci_dss_mdata

« td_threat_name_mdata

Output profiles

Output profiles allow you to define email addresses to which generated reports are sent and provide an option to upload
the reports to FTP, SFTP, or SCP servers. Once created, an output profile can be specified for a report.

Creating output profiles

You must configure a mail server before you can configure an output profile. See Mail Server
on page 333.
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To create output profiles:

1. Ifusing ADOMSs, ensure that you are in the correct ADOM.
2. Goto Reports > Advanced > Output Profile.
3. Click Create New. The Create Output Profile pane is displayed.

Create Output Profile

Name

Comments

Output Format O HTML PDF O XML [ €SV [ JSON

Email Generated Reports
Subject

Body

0/1023

Recipients Email Server

Click here to add new entry.

Upload Report to Server

Server Type FTP
Server 0.0.00
User

Password

Directory

[ Delete file(s) after uploading

4. Provide the following information, and click OK:

Name
Comments

Output Format

Email Generated Reports
Subject
Body

Recipients

Upload Report to Server
Server Type
Server
User
Password

Directory
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Enter a name for the new output profile.
Enter a comment about the output profile (optional).

Select the format or formats for the generated report. You can choose HTML,
PDF, XML, CSV, or JSON format.

Enable emailing of generated reports.
Enter a subject for the report email.
Enter body text for the report email.

Select the email server from the dropdown list and enter to and from email
addresses. Click Add to add another entry so that you can specify multiple
recipients.

Enable uploading of generated reports to a server.
Select FTP, SFTP, or SCP from the dropdown list.
Enter the server IP address.

Enter the username.

Enter the password.

Specify the directory where the report will be saved.
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Delete file(s) after  Select to delete the generated report after it has been uploaded to the selected
uploading server.

Managing output profiles

You can manage output profiles by going to Reports > Advanced > Output Profile. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click an output profile to display the menu.

Option Description

Create New Creates a new output profile.
Edit Edits the selected output profile.
Delete Deletes the selected output profile.

Report languages

You can specify the language of reports when creating a report.

Exporting and modifying a language

You can export a language and modify it to create a different language or modify the text in a predefined language.

One way to create a new language is to export a predefined language, modify the text to a different language, save the
file as a different language name, and import it back into FortiAnalyzer. The file name must be one of the languages in

the Advanced Settings section of the Reports Settings tab > Language dropdown list. See Advanced Settings section of
Reports Settings tab on page 222.

If you want to modify a predefined language, export the predefined language, modify the text, and import it back into
FortiAnalyzer.

To export and modify a language:

Go to Reports > Advanced > Language.

Select a language and click Export. The language is exported as a zip file into your default downloads folder.
Extract the zip file and use a text editor to modify it.

Change the text after the equal sign (=) to a different language or text.

Zip the modified file. The file name must be one of the languages in the Advanced Settings section of the Reports
Settings tab > Language dropdown list. See Advanced Settings section of Reports Settings tab on page 222.

ok oN=

The new language file is ready to be imported into FortiAnalyzer.
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Importing a language

To import a language:

3.

Go to Reports > Advanced > Language.
Click Import and locate the language file.

The language file must be a zip file with only one language file in it. Both the language file name and zip file name
must be one of the language names in the Advanced Settings section of the Reports Settings tab > Language

dropdown list. See Advanced Settings section of Reports Settings tab on page 222.
Import the language zip file.

In Reports > Advanced > Language, you can select this language when you create or run reports.

Report calendar

You can use the report calendar to view all the reports that are scheduled for the selected month. You can edit or disable

upcoming report schedules, as well as delete or download completed reports.

Viewing all scheduled reports

To view all scheduled reports:

o0 kv

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Advanced > Report Calendar.
< > today June 2018

w Sun Mon Tue Wed Thu Fri sat
22 1 2
(£ 3:00 AM Admin and System Event] (= 3:00 AM Admin and System Event)

23 3 4 5 6 7 8 9
((213:00 AM Admin and System Event) (= 3:00 AM Admin and System Event) () 3:00 AM Admin and System Event, (=] 12:00 AM Security Analysis ) (5 12:00 AM Bandwidth and Applica) (=) 3:00 AM Admin and System Event] () 3:00 AM Admin and System Event)
((5/12:00 AM Top 20 Categories and ) (5 3:00 AM Admin and System Event|
() 12:00 AM VPN Report
(100 AMVieb Usage Report_)
+2mare
24 10 11 12 13 14 15 16
(/3:00 AM Admin and System Event) (5 3:00 AM Admin and System Event () 3:00 AM Admin and System Event) (£ 12:00 AM Security Analysis ((5/12:00 AM Bandwidth and Applica) () 3:00 AM Admin and System Event, (= 3:00 AM Admin and System Event)
((=12:00 AM Top 20 Categories and J (= 3:00 AM Admin and System Event|
((112:00 AM VPN Report
(1200AM Vit Ussge ot
+2 more
25 17 18 19 20 21 22 23
(D3:00 AM Adrmin and System Event] (= 3:00 AM Admin and System Event) () 3:00 AM Admin and System Event) (21 12:00 AM Security Analysis ) (51200 AM Bandwidth and Applica) (0 3:00 AM Admin and System Event) (= 3:00 AM Admin and System Event)
(£112:00 AM Top 20 Categories and ) (5 3:00 AM Admin and System Eveni
(=112:00 AM VPN Report
(100 AMVieb Usage Report)
+2mare
26 24 25 26 27 28 29 30
(5300 AM Admin and System Event] () 3:00 AM Admin and System Event ((©) 3:00 AM Admin and System Event] (5] 12:00 AM Security Analysis ) (5 12:00 AM Bandwidth and Applica) (5 3:00 AM Admin and System Event (Z) 3:00 AM Admin and System Event)
(Z112:00 AM Top 20 Categories and ) () 3:00 AM Admin and System Eveni)
((*)12:00 AM VPN Report
(Z12:00 AM Web Usage Report

+2 more

Hover the mouse cursor over a calendar entry to display the name, status, and device type of the scheduled report.

Click a generated report to download it.
Click a scheduled report to go to the Settings tab of the report.

Click the left or right arrow at the top of the Report Calendar pane to change the month that is displayed. Click Today

to return to the current month.
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Managing report schedules
You can manage report schedules in Reports > Advanced > Report Calendar.

To edit a report schedule:

1. In Report Calendar, right-click an upcoming calendar entry, and select Edit.
2. Inthe Settings tab of the report that opens, edit the corresponding report schedule.

To disable a report schedule:

In Report Calendar, right-click an upcoming calendar entry, and select Disable. All scheduled instances of the report are
removed from the report calendar. Completed reports remain in the report calendar.

To delete or download a completed report:

In Report Calendar, right-click a past calendar entry, and select Delete or Download. The corresponding completed
report will be deleted or downloaded.

Ay
‘?' You can only delete or download scheduled reports that have a Finished status. You cannot
- delete scheduled reports with a Pending status.
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FortiRecorder

The FortiRecorder module allows you to set up, manage, and view cameras directly through the FortiAnalyzer GUI.

Cameras can be set to record continuously and/or when motion is detected. Recorded video is stored in the roof storage

of the FortiAnalyzer device, however, it can be accessed from other ADOMs.

FortiRecorder includes three panes:

o Camera Manager: Allows you to configure devices, profiles, and schedules.
« Monitor: Allows you to view streaming and recorded video from configured devices.
» Face Recognition: Allows you identify faces captured by the device and create profiles.

When upgrading from FortiAnalyzer 6.2.0 to 6.2.1 and later, previously enabled cameras are
disabled until a new camera key has been created. Once created, cameras can be re-enabled.

See Creating a camera key on page 252.

Ay
‘Q' The FortiRecorder module and its features are only available in select FortiAnalyzer
- appliances and is disabled by default. See Enabling and disabling FortiRecorder on page 266.
\‘ ! ’I
? Third-party cameras are not supported in the FortiRecorder module. For a list of supported
- cameras, see the FortiAnalyzer Release Notes.

Configuring cameras in the Camera Manager

In the Camera Manager pane, you can set up and manage the cameras connected to the FortiAnalyzer FortiRecorder
module.

This section includes the following topics:

Creating a camera key on page 252

Setting up a camera on page 253

Configuring camera profiles on page 253
Configuring video profiles on page 256

Creating and editing camera schedules on page 257
Assigning camera schedules to a profile on page 257
Enabling motion detection on page 259

Creating a camera key

In order to enable cameras in the FortiRecorder module, a camera key must be created.

FortiAnalyzer 7.2.2 Administration Guide
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Camera keys are used by FortiAnalyzer to generate camera admin and operator passwords.

Only one camera key is required per FortiAnalyzer.

To set a camera key in the CLI:

config fortirecorder global
set camera key
end

Setting up a camera

New cameras automatically detected by FortiAnalyzer will appear in the FortiRecorder > Camera dashboard.
In order for FortiAnalyzer to detect cameras automatically, the cameras must be:

« Assigned a DHCP address through a connected FortiGate.
» Connected with Power over Ethernet (PoE) to the FortiAnalyzer.

If a DHCP server is not available, cameras can also be set up with a static IP address through the Create New menu in
the Camera dashboard.

A camera key must be set before cameras can be activated in FortiAnalyzer. See Creating a camera key on page 252.

To activate a camera detected by the FortiAnalyzer:

1. Goto FortiRecorder> Camera Manager > Camera.
2. Select the Unauthorized filter.

3. Right-click a detected camera and select Authorize.
The Edit Camera Device menu will open.
4. Configure the camera settings, then select OK.

Camera settings will vary depending on the model of camera detected. For information on the individual camera
settings, see the FortiRecorder Administration Guide.

5. Once successfully authorized, the camera will be enabled.

ﬂ If a camera fails to connect, it will be displayed with an erroricon. Right-click the device to
I Disable it and then attempt to Enable it again. This will reload the default settings for the device

and may correct issues which are preventing it from connecting successfully.

N !/ P In a HA configuration, FortiRecorder devices should only be configured on the FortiAnalyzer
? device on which they were set up. When attempting to modify a camera being managed by
3 another device, a warning message will be displayed.

Configuring camera profiles

Camera profiles define which video profile, schedules, recording types, and storage options are set for each camera.

You can modify the default camera profiles, create new profiles, or clone an existing profile in the Camera Profile
dashboard.
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To create or edit a camera profile:

1. Goto FortiRecorder> Camera Manager > Camera Profile.
2. Click Create New or select an existing camera profile and click Edit.
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3. Configure the following information:

Name
Video Profiles

Recording profile

Viewing profile

Schedule

Recording & Detection
Settings

Recording type

Schedule

Storage Options

Continuous
recordings

Detection
recordings

4. Select OK.

FortiAnalyzer 7.2.2 Administration Guide
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Enter a name to identify the camera profile.

Select a video profile from the dropdown list to set the resolution, frames per
second, video codec, bitrate, quality, and audio of the recorded video. See
Configuring video profiles on page 256.

Select a video profile from the dropdown list to set the resolution, frames per
second, video codec, bitrate, quality, and audio of the streaming video. See
Configuring video profiles on page 256.

By default, the schedule is set to Always.

New schedules can initially only be added through the FortiAnalyzer CLI. See
Assigning camera schedules to a profile on page 257.

Select the recording type(s).
e Continuous: Records video for the entire duration of the schedule,
regardless of movement.
* Motion detection: Records a video clip each time the camera's sensor
detects movement.
See Enabling motion detection on page 259.

By default, the schedule is set as Always.

New schedules can initially only be added through the FortiAnalyzer CLI. See
Assigning camera schedules to a profile on page 257.

Select the storage options for continuous recordings:
» Keep until overwritten: Retain video until all available disk space is nearly
full. The oldest video will be overwritten.
« Delete: Remove video when it exceeds the specified maximum age. Note
that if the disk is full before the maximum age is reached, the oldest video
will still be overwritten.

Select the storage options for detection recordings:

» Keep until overwritten: Retain video until all available disk space is nearly
full. The oldest video will be overwritten.

« Delete: Remove video when it exceeds the specified maximum age. Note
that if the disk is full before the maximum age is reached, the oldest video
will still be overwritten.

» Use continuous recordings if available: If a recording of the detected
event is already stored as a continuous recording, the detection recording
will not be saved to avoid duplication.
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Configuring video profiles

By default, there are three video profiles.

¢ |ow-resolution
o med-resolution
« high-resolution

The default video profiles can be customized, and new profiles can be created.

To create or edit a video profile:

1. Goto FortiRecorder > Camera Manager > Video Profile.
2. Click Create New or select an existing video profile and click Edit.
3. Configure the following information:

Name Enter a name to identify the video profile.
Video codec Select a video codec from Default, H.264 AVC, and H.265 HEVC.
Resolution Select the amount of detail in the image from the dropdown menu.

Lower resolutions feature less detail but are faster to transmit.

Higher resolutions produce a clearer image but require more bandwidth. A
higher resolution is preferable if the camera is recording a large space, such
as a parking lot, where small details like faces and license plates could be
important.

Note: Resolution greatly impacts performance, bandwidth, and the rate at
which the disk space is consumed.

Frames per second Type the number of frames per second (FPS).
Conventional video is 24 frames per second. More frames per second may be
useful if you need to record very fast motion, but increasing FPS will also
increase disk usage and CPU usage.

Bitrate mode Select a bitrate:
* Variable: Automatically adjust the stream to the minimum bitrate required
by the current video frames while maintaining video quality.
» Fixed: Manually specify a constant bitrate.
Specifying a bitrate that is too low may result in poor quality.
Specifying a bitrate that is too high may needlessly consume extra

bandwidth.
Bitrate Type the bitrate that will be used.
This setting appears and is applicable only if the Bitrate mode is Fixed.
Quality Select the video quality from Extra Low, Low, Normal, High, and Extra High.
Audio enable Toggle to enable or disable audio in the video stream or recording.
4. Select OK.
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Creating and editing camera schedules

The FortiRecorder module includes one default schedule: Always.

The default schedule can be customized, and new schedules can be created.

To use a custom camera schedule, it must first be assigned to the camera profile through the

» FortiAnalyzer CLI.
I Once assigned, you can use the FortiAnalyzer GUI to select the new schedule for each

recording stream or recording type. See Assigning camera schedules to a profile on page 257.

To create or edit a camera schedule:

1. Goto FortiRecorder> Camera Manager > Schedule.
2. Click Create New or select an existing schedule and click Edit.
3. Configure the following information:

Name Enter a name to identify the camera schedule.
Description Enter a description of the schedule (optional).
Type Select a schedule type:

¢ Recurring: The schedule happens at specified times on selected days.
¢ One-time: The schedule happens only during the specified date-range.

Days Select the days you want the camera to begin recording if you have selected
the Recurring schedule type.

All day Select this option if you want the camera to record all day long.

Start time/End time Select the start and end time for the Recurring recording or the start and end
date for the One-time recording.

4. Select Save.

Assigning camera schedules to a profile

By default, camera profiles are set to use the Always schedule.

To assign a custom schedule to a camera profile, you must first enable it through the CLI. Once enabled, a table is added
to the Camera Profile editor which allows you to select the custom schedule.
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S22 FortiRecorder v Camera Manager Monitor

ADOM:root 3

@ Camera

[ Video Profile
© Schedule

Edit Profile

Name [h\th\

o]

Video Profiles
+ CreateNew [% Edit T D
O Recording Stream

O low-resolution
O high-resolution

Recording & Detection Settings

+ CreateNew [4 Edit @ D
O Recording Type

O Continuous, Motion detection
O Continuous

Storage Options
Continuous recordings Delete

Detection recordings Delete

Viewing Stream
low-resolution

— Use Recording Stream —

Schedule Name
test3

Always

After 1 Months
After[ 1 Months

Schedule Name
test1

Always

After the first custom schedule has been enabled on a profile, subsequent schedules can be selected directly through
the GUI. New schedules can be created by clicking the Create New button above the table.

For more information on creating a custom schedule, see Creating and editing camera schedules on page 257.

To enable a recording schedule in the FortiAnalyzer CLI:

config fortirecorder camera profile

edit [profile name]

config recording-schedule
edit

end

[schedule name]

To enable a video schedule in the FortiAnalyzer CLI:

config fortirecorder camera profile

edit [profile name]

config video-schedule
edit

end

[schedule name]

To assign the schedule through the GUI:

1. Goto FortiRecorder > Camera Manager > Camera Profile.
2. Select the camera profile and click Edit.

A table appears underneath the Video Profiles and/or Recordings & Detections Settings sections, depending on

where you enabled the schedule.
3. Selectarecording type or recording stream, then click Edit.
4. Select a schedule from the dropdown menu.
5. Click OK.
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Enabling motion detection
Motion detection can be enabled on cameras through the Camera Profile.

To enable motion detection:

1. Goto FortiRecorder> Camera Profile.
2. Click Create New or select an existing camera profile and click Edit.

In Recordings & Detections Settings select Motion detection as the recording type.
Both Continuous and Motion detection recording types can be enabled at the same time.

Enter any additional settings you want to configure for this camera profile and click OK.

Go to FortiRecorder> Camera and double click the camera where motion detection is to be enabled.
In the camera settings, select the profile where motion detection is enabled.

Select OK.

w

No ok

Motion detected recordings can be viewed in the Monitor dashboard, and is identified in red in the camera's activity
timeline. See Watching live and recorded video in the Monitor on page 264.

Face Recognition

In the Face Recognition pane, you can view detected faces, create profiles for internal users and guests, and view
activity reports for events within a specific time period.

This section includes the following topics:

« Enabling face recognition on page 259
« Identifying faces on page 260

» Viewing activity reports on page 261

« Viewing known faces on page 262

» Configuring the Al module on page 263

Enabling face recognition
FortiAnalyzer uses the Al module to detect faces when motion detection is enabled in the camera profile. Go to the
Camera Manager pane to enable face recognition on an authorized camera.

Requirements:

« Enabling motion detection on page 259

To enable the Al module in the CLI:

config system global
# set disable-module

For information about configuring the Al module, see Configuring the Al module on page 263.
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A\,

b [ 4
? The Al module must be enabled for face recognition to work.

To enable facial recognition in the GUI:

Go to FortiRecorder > Camera Manager.

In the camera manager pane, select an authorized camera, and click Edit. The Edit Camera Device window opens.
Set Face Recognition to ON.

Use the preview image to adjust the camera focus.

Ao b=

a. Click the magnifying glass icons to zoom in or out on the camera. Wait a few seconds for the camera to focus.
b. Click the AF icon to auto-focus the image.

O ! ’, The zoom feature is not supported on all FortiRecorder models.
? The zoom quality will depend on the FortiRecorder model. You may need to focus the
- image on the device itself.

5. Click OK. A check mark appears in the Face Recognition column.

A\,

‘Q' You can enable face recognition on a camera that is managed by another FortiAnalyzer device
- if the camera keys are the same.

Identifying faces

You can link a face detected by the camera to an existing UEBA profile. You can also use a face to create guest profiles.

To identify faces in a cluster in the GUI:

1. Go to FortiRecorder > Face Recognition.
2. Inthetree menu, go to Face Cluster > New Face Detected.
3. Inthe toolbar, configure the detection settings.
a. Click the All Cameras dropdown to select a camera.
b. Click the time period dropdown to select the time period.
c. Select the detection order.

Order by time Displays images by time stamp.
Order by count Displays images by the number of times the face was detected by the
camera.

l\ Hover over an image to view its time stamp.
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d. Click Show Unrecognizable to view images the system could not identify as a face or matchtoafaceina
cluster.

4. Selectanimage orimage cluster. The image pane displays the time the face was detected, the camera that
captured the image, and the number of images in the video.

a. Click the image to watch a video of the event.

b. Click the Images tab to view the images in the video.

c. (Optional) Click Evict Event from Face Cluster to delete the image.
5. Link aface to a profile.

Similar Faces Links the image with a known face.

Click an image in the profile pane to open the Merge Clusters window, and then click OK.
The selected images is added to Known Faces.

Link to UEBA Links the image to a user with a FortiGate endpoint.
Select a user name from the dropdown, and then click Link User.

Link to Non-UEBA Links the image to a user who does not connect to the internet, such as a site employee.
Staff e To create a new profile, enter the profile name, and click Save.
» To merge the face with a profile, click Create New to enable Merge. Select a profile
from the dropdown, and then click Save.

Link to Guest Links the image to a person a site visitor, such as salesperson.
« To create a new profile, enter the profile name, and click Save.
« To merge the face with a profile, click Create Now to enable Merge, then select a
profile from the dropdown, and click Save.

6. Click the close icon at the right side of the pane.

A\,

S L 4
q An image assigned to a profile will replace an existing user avatar in Log View.

To view face recognition logs in the GUI:

1. Goto Log View > FortiAnalyzer> Event.
2. Inthe Usercolumn, select an entry. Face recognition logs will display the image assigned to the user.
There are three types of Al logs:

LOG_EVENT AID STATUS
LOG_EVENT AID CONFIG
LOG_EVENT AID UI

Viewing activity reports

Activity reports allow you to monitor user events within a specific time period.
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To view guest activity reports in the GUI:

1.
2,

Go to FortiRecorder > Face Recognition.
In the tree menu, go to Activity Report > Guests. The report pane displays the events.
» Hoverover an eventin the time line to view when the event was detected and the camera that detected it.
« Click an eventin the time line to watch a video of the event.
« Use the scroll wheel to adjust the time frame.
o Click Reset Zoom to reset the time line.

To view internal user activity reports in the GUI:

Go to FortiRecorder > Face Recognition.

In the tree menu, go to Activity Report > Internal Users. The report pane displays the activity report.
Click a heading to sort a column in ascending or descending order.

User Name The internal user name.
Bandwidth (Sent/Received) The bandwidth sent and received by the camera in bytes.
Captured Times The number of times the camera captured an image of the user.

In the toolbar, click the time frame dropdown to specify the time period.

Viewing known faces

View the activity of known users for the last seven days.

To view known faces in the GUI:

-—

Go to FortiRecorder > Face Recognition.

In the tree menu, go to Face Cluster > Known Faces. All known internal and guest users are displayed.
« Ablueicon indicates UEBA users.
» Agreenicon indicates non-UEBA users.
« Aredicon indicates guests.

(Optional) In the Search field, enter a username to find a specific user. You can also search by UEBA, Non-UEBA,

and Guest.
Click an image to open the user information pane.

The left side of the pane displays user details such as Related Endpoint, Topology, Addresses, and Operating
System. Click a link to view drilldown information in Identity Center or Assets.

The Activity in last 7 days tab displays a graph with the number of user events. Hover over a point in the chart to
view the event time stamp, and the name of the camera that captured the event. Click a point in the chart to watch a

video the event or delete the event.
Click the All Detections tab to view the event information as a time line.
» Use the scroll wheel to zoom to adjust the time frame.
« Hover over a pointin the time line to view when the event was detected and by which camera.
« Click an event to watch a video of the event.
o Click Reset Zoom to reset the time line.

FortiAnalyzer 7.2.2 Administration Guide
Fortinet Inc.

262



FortiRecorder

Configuring the Al module

You must enable the Al module in the CLI console for face recognition to work properly. You can use the CLI console to
configure database and disk quotas, memory usage, and to backup user information.

To enable the Al module in the CLI:

config system global
# set disable-module

The disable-module command enables all of the Al modules.
fortirecorder FortiRecorder module

ai AT module

To disable an Al module in the CLI:

config system global
# set disable-module <module>

Example

# set disable-module ai

To set the database and disk quota in the CLI:

1. Set the disk quota for the Al module.
config system global
set ai-disk-quota value <disk limit in GB>

If the configuration is successful, the remaining available hard disk space will be deducted accordingly.

2. Setthe database table item count limit,
execute face-recognition setting db item count max <limit>

CPU usage:

The Al module has three daemons:

aid Pre-processes videos with deep learning algorithms which consume large amounts of CPU
resources.

aiclusterd Responsible for user interfaces and requires limited CPU and memory resources.

aisched Performs routine tasks, such as cleaning the database and disk used by the Al module

approximately once a day.
To backup an Al user's information in the CLI:
execute backup ai-config <ip:port> <filename> <username><password>

To restore an Al user's information in the CLI:

execute restore ai-config <ip:port> <filename> <username><password>
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To insert a specific camera's videos into the Al database:

execute face-recognition process <camera name>

To configure Al-specific settings in the CLI:

Show all Al setting parameters:

execute face-recognition setting
Show a specific key value:

execute face-recognition setting <key>
Modify a specific key value:

execute face-recognition setting <key> <key value>

Watching live and recorded video in the Monitor

The Monitor pane allows you to view the streaming and recorded video captured by devices configured to the
FortiAnalyzer.

To view a video stream:

1. Go to FortiRecorder> Monitor.
2. Click Add Widget.
3. Select the device to be displayed from the dropdown menu.

&.% FortiRecorder v  Camera Manager Monitor

+ Add Widget

FCM-MD20-c946
FCM-MD20-c956
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4. Once added, the widget displays the video stream from the selected camera.

So= FortiRecorder v Camera Manager Monitor
+ Add Widget

FCM-MD20-c966

FCH-MNDZA-e966

FCM-MD20-c966
13:47
Tue 9 April

To watch recorded video:

1. Go to FortiRecorder > Monitor. The recorded video clips for each camera appear in a timeline below the video

stream.

2. Tolocate a video clip, use the scroll wheel on your mouse to zoom in on a time frame. Ensure that your mouse

(GMT

~-Aav8a8)

ADOM:root  £3 @ >- (&) admin v

cursor is centered in the area that you want to zoom in. You can also navigate the timeline by dragging it to the left or

right.

3. Click on arecorded video in the timeline to begin playback.
Time periods in the timeline panel are color-coded:

« Light blue: Recorded video clips.

» Red: A motion detection-based recording that was not initiated by a schedule.
» White/blank: No recording at that time period.

So= FortiRecorder v Camera Manager Monitor
+ Add Widget

FCM-MD20-c966

P o037/037

FCM-MD20-966 | | 111 ni

09:00 09:15 09:30 09:45 10:00
Wed 10 April

2 @ - (§ adminv

10:30 10:45 11:00 11:15 11:30 11:45 12:00 12:15 12:30

4. To return to the live stream from the recording view, click Back fo Live.
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NP Video can also be viewed in a Picture in picture mode.

‘9' This option opens a small window which persists outside of the browser.

To launch Picture in picture mode, select the menu icon on the bottom-right side of the video
and choose Picture in picture.

Enabling and disabling FortiRecorder

By default, the FortiRecorder module is disabled in FortiAnalyzer.

The FortiRecorder module can be enabled or disabled on supported platforms through the FortiAnalyzer CLI.

Al
‘Q' To view supported platforms and cameras, see the product release notes in the Fortinet
- Document Library.

To enable the FortiRecorder module in the CLI:

config system global
set disable-module none
end

To disable the FortiRecorder module in the CLI:

config system global
set disable-module fortirecorder
end
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System Settings

System Settings allows you to manage system options for your FortiAnalyzer device.

click the mouse on different navigation panes on the GUI page to access these options.

x Additional configuration options and short-cuts are available using the right-click menu. Right-

This section contains the following topics:

o Dashboard on page 268

» Logging Topology on page 285

» Network on page 285

« RAID Management on page 291

o Administrative Domains (ADOMs) on page 296
» Certificates on page 305

o Log Forwarding on page 310

o Fetcher Management on page 316
« EventLog on page 321

o Task Monitor on page 322

o SNMP on page 324

» Mail Server on page 333

« Syslog Server on page 334

o Meta Fields on page 336

» Device logs on page 338

» File Management on page 342

» Advanced Settings on page 343
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Dashboard

The Dashboard contains widgets that provide performance and status information and enable you to configure basic
system settings.

Toggle Widgets v

System Information [3& %X License Information Zex
Host Name Enterprise_FortiAnalyzer 4] EBVMS License @ VMS License LI 3 3
Serial Number FAZVMSTM22002774 @ ADOM License  @No License (2 Used / 5 Total)

Platform Type FAZVM64-KVM & FortiCloud © Registered
HA Status Standalone © Remote Access =
ST Wed Sep 14 10:00:02 2022 PDT ® FortiGuard Indicators of Compr... Licensed (Expires 2023-06-04)
Firmware Version v7.2.1-build1215 220809 (GA) & Server Location s Servers located in US only &
System Configuration Last Backup : N/A 3 a 4 FOAS License  Outbreak Detection... @ Licensed (Expires 2023-06-04)
Current Administrators administrator / 1 in total E] @ Security Operati... SOC Service Licensed (Expires 2023-06-04)
Up Time 7 minutes 22 seconds [ Logging Devices/VDOMs 0/ 10,000 (0.0%)
Administrative Domain fo ) GB/Day @ 00/5(00%) =
Operation Mode ‘Anal Collect
i Mol Collector & Storage Connect... Cloud @ No License -
System Resources % [ & % Unit Operation oex
FO RTI N ET FortiAnalyzer-VM64-KVM
1 2
8% 38% 4%
Average CPU Usage Memory Usage Disk Usage
' 3¢ Restart © Shutdown
More Details

The following widgets are available:

Widget Description

System Information Displays basic information about the FortiAnalyzer system, such as up time and
firmware version. You can also enable or disable Administrative Domains and
adjust the operation mode. For more information, see System Information widget
on page 270.

From this widget you can manually update the FortiAnalyzer firmware to a
different release. For more information, see Updating the system firmware on
page 272.

The widget fields will vary based on how the FortiAnalyzer is configured, for
example, if ADOMs are enabled.

System Resources Displays the real-time and historical usage status of the CPU, memory and hard
disk. For more information, see System Resources widget on page 277.

License Information Displays whether the unit license is registered to FortiCloud, and if remote access
from FortiCloud is enabled.

Displays how many devices of the supported maximum are connected to the
FortiAnalyzer unit. See License Information widget on page 277.

From this widget you can purchase a license, add a license, or manually upload a
license for VM systems.
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Widget Description

Unit Operation Displays status and connection information for the ports of the FortiAnalyzer unit.
It also enables you to shutdown and restart the FortiAnalyzer unit or reformat a
hard disk. For more information, see Unit Operation widget on page 282.

Alert Message Console Displays log-based alert messages for both the FortiAnalyzer unit and connected
devices. For more information, see Alert Messages Console widget on page 282.

Log Receive Monitor Displays a real-time monitor of logs received. You can view data per device or per
log type. For more information, see Log Receive Monitor widget on page 282.

Insert Rate vs Receive Rate Displays the log insert and receive rates. For more information, see Insert Rate vs
Receive Rate widget on page 283.
The Insert Rate vs Receive Rate widget is hidden when the FortiAnalyzer is
operating in Collector mode, and the SQL database is disabled.

Log Insert Lag Time Displays how many seconds the database is behind in processing the logs. For
more information, see Log Insert Lag Time widget on page 283.
The Log Insert Lag Time widget is hidden when the FortiAnalyzer is operating in
Collector mode, and the SQL database is disabled.

Receive Rate vs Forwarding Displays the Receive Rate, which is the rate at which FortiAnalyzer is receiving

Rate logs. When log forwarding is configured, the widget also displays the log
forwarding rate for each configured server. For more information, see Receive
Rate vs Forwarding Rate widget on page 284.

Disk I/0 Displays the disk utilization, transaction rate, or throughput as a percentage over
time. For more information, see Disk I/0O widget on page 284.

Customizing the dashboard

The FortiAnalyzer system dashboard can be customized. You can select which widgets to display, where they are
located on the page, and whether they are minimized or maximized. It can also be viewed in full screen by selecting the
full screen button on the far right side of the toolbar.

Action Steps

Move a widget Move the widget by clicking and dragging its title bar, then dropping it in its new location
Add a widget Select Toggle Widgets from the toolbar, then select the name widget you need to add.
Delete a widget Click the Close icon in the widget's title bar.

Customize a widget For widgets with an edit icon, you can customize the widget by clicking the Edit icon and
configuring the settings.

Reset the Select Toggle Widgets > Reset to Default from the toolbar. The dashboards will be reset to the
dashboard default view.
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System Information widget

The information displayed in the System Information widget is dependent on the FortiAnalyzer model and device
settings. The following information is available on this widget:

Host Name

Serial Number

Platform Type

HA Status

System Time

Firmware Version

System Configuration

Current Administrators

Up Time

Administrative Domain

Operation Mode

The identifying name assigned to this FortiAnalyzer unit. Click the edit host name
button to change the host name. For more information, see Changing the host
name on page 271.

The serial number of the FortiAnalyzer unit. The serial number is unique to the
FortiAnalyzer unit and does not change with firmware upgrades. The serial
number is used for identification when connecting to the FortiGuard server.

Displays the FortiAnalyzer platform type, for example FAZVM64 (virtual
machine).

Displays if FortiAnalyzer unit is in High Availability mode and whether it is the
Primary or Secondary unit in the HA cluster.

The current time on the FortiAnalyzer internal clock. Click the edit system time
button to change system time settings. For more information, see Configuring the
system time on page 271.

The version number and build number of the firmware installed on the
FortiAnalyzer unit.

You can access the latest firmware version available on FortiGuard from
FortiAnalyzer.

Alternately you can manually download the latest firmware from the Customer
Service & Support website at https://support.fortinet.com. Click the update button,
then select the firmware image to load from the local hard disk or network volume.

For more information, see Updating the system firmware on page 272.

The date of the last system configuration backup. The following actions are
available:
 Click the backup button to backup the system configuration to a file; see
Backing up the system on page 274.

 Click the restore to restore the configuration from a backup file; see
Restoring the configuration on page 276. You can also migrate the
configuration to a different FortiAnalyzer model by using the CLI. See
Migrating the configuration on page 276.

The number of administrators currently logged in. Click the current session list
button to view the session details for all currently logged in administrators.

The duration of time the FortiAnalyzer unit has been running since it was last
started or restarted.

Displays whether ADOMs are enabled. Toggle the switch to change the
Administrative Domain state. See Enabling and disabling the ADOM feature on
page 299.

Displays the current operation mode of the FortiAnalyzer. Click the other mode to
change to it. For more information on operation modes, see Operation modes on
page 30.
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Changing the host name

The host name of the FortiAnalyzer unit is used in several places.

« Itappears in the System Information widget on the dashboard.
o ltis used in the command prompt of the CLI.
« ltis used as the SNMP system name.

The System Information widget and the get system status CLI command will display the full host name. However, if
the host name is longer than 16 characters, the CLI and other places display the host name in a truncated form ending
with a tilde ( ~ ) to indicate that additional characters exist, but are not displayed. For example, if the host name is
FortiAnalyzer1234567890, the CLI prompt would be FortiAnalyzer123456~#.

To change the host name:

1. Go to System Settings > Dashboard.
2. Inthe System Information widget, click the edit host name button next to the Host Name field.
3. Inthe Host Name box, type a new host name.

The host name may be up to 35 characters in length. It may include US-ASCII letters, numbers, hyphens, and
underscores. Spaces and special characters are not allowed.

4. Click the checkmark to change the host name.

Configuring the system time

You can either manually set the FortiAnalyzer system time or configure the FortiAnalyzer unit to automatically keep its
system time correct by synchronizing with a Network Time Protocol (NTP) server.

Ay
‘?' For many features to work, including scheduling, logging, and SSL-dependent features, the
- FortiAnalyzer system time must be accurate.

To configure the date and time:

1. Go to System Settings > Dashboard.
2. Inthe System Information widget, click the edit system time button next to the System Time field.

3. Configure the following settings to either manually configure the system time, or to automatically synchronize the
FortiAnalyzer unit’s clock with an NTP server:

System Time The date and time according to the FortiAnalyzer unit’s clock at the time that
this pane was loaded or when you last clicked the Refresh button.

Time Zone Select the time zone in which the FortiAnalyzer unit is located and whether or
not the system automatically adjusts for daylight savings time.
Update Time By Select Set time to manually set the time, or Synchronize with NTP Server to
automatically synchronize the time.
Set Time Manually set the data and time.
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Select Date

Select Time
Synchronize with NTP Server

Server

Min

Max

Set the date from the calendar or by manually entering it in the format:
YYYY/MM/DD.

Select the time.
Automatically synchronize the date and time.

Enter the IP address or domain name of an NTP server. Click the plus icon to
add more servers. To find an NTP server that you can use, go to
http://www.ntp.org.

Minimum poll interval in seconds as power of 2 (e.g. 6 means 64 seconds,
default = 6).

Maximum poll interval in seconds as power of 2 (e.g. 6 means 64 seconds,
default = 10).

4. Click the checkmark to apply your changes.

Updating the system firmware

To take advantage of the latest features and fixes, you can update FortiAnalyzer firmware. From the System Settings
module in FortiAnalyzer, you can access firmware images on FortiGuard and update FortiAnalyzer. Alternately you can
manually download the firmware image from the Customer Service & Support site, and then upload the image to

FortiAnalyzer.

For information about upgrading your FortiAnalyzer device, see the FortiAnalyzer Upgrade Guide or contact Fortinet

Customer Service & Support.

Back up the configuration and database before changing the firmware of FortiAnalyzer.
Changing the firmware to an older or incompatible version may reset the configuration and
database to the default values for that firmware version, resulting in data loss. For information

on backing up the configuration, see Backing up the system on page 274.

S ! ’, Before you can download firmware updates for FortiAnalyzer, you must first register your
? FortiAnalyzer unit with Customer Service & Support. For details, go to
- https://support.fortinet.com/ or contact Customer Service & Support.

To update FortiAnalyzer firmware using FortiGuard:

1. Go to System Settings.

2. Inthe System Information widget, beside Firmware Version, click Update Firmware.
The Firmware Management dialog box opens.
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Firmware Management

Current Version v6.4.0-build5663 200210 (Interim)

Upload Firmware
Upload file by drag & drop here or

FortiGuard Firmware 6.2.2(1183)
Backup Configuration EdEnable
Encryption Enable

&

3. Before upgrading your firmware, you can choose to enable or disable Backup Configuration. When this setting is
enabled, you will automatically download a backup copy of your FortiAnalyzer configuration when performing a
firmware upgrade.

If you want to encrypt the backup file, enable Encryption, then type and confirm the password you want to use. The
password can be a maximum of 63 characters.

4. From the FortiGuard Firmware box, select the version of FortiAnalyzer for the upgrade, and click OK.
The FortiGuard Firmware box displays all FortiAnalyzer firmware images available for upgrade. A green checkmark
displays beside the recommended image for FortiAnalyzer upgrade.

Firmware Management

Current Version v6.4.0-build5663 200210 (Interim)

Upload Firmware
Upload file by drag & drop here or

FortiGuard Firmware 6.2.2(1183) &
Backup Configuration 6.2.2 (1183)
Encryption 621 (1121)

6.2.0 (1050)

&

If you select an image without a green checkmark, a confirmation dialog box is displayed. Click OK to continue.

Firmware Download

Upgrade to selected firmware version is not recommended, would you like to continue?

N

FortiAnalyzer downloads the firmware image from FortiGuard.

Firmware Management

Downloading the selected image file...

Total: 1/1, @ Pending: 1, ™ In Progress: 0,
Completed: 0

I ol

Index Name Status Time Used History

4

FortiAnalyzer uses the downloaded image to update its firmware, and then restarts.
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Firmware Management

4. The image has been uploaded successfully and the system is restarting. Please wait for a
few moments.

&

After FortiAnalyzer restarts, the upgrade is complete.

To manually update FortiAnalyzer firmware:

1. Download the firmware (the . out file) from the Customer Service & Support website, https://support.fortinet.com/.
2. Goto System Settings > Dashboard.

3. Inthe System Information widget, in the Firmware Version field, click Upgrade Firmware. The Firmware Upload
dialog box opens.

4. Before upgrading your firmware, you can choose to enable or disable Backup Configuration. When this setting is
enabled, you will automatically download a backup copy of your FortiAnalyzer configuration when performing a
firmware upgrade.

If you want to encrypt the backup file, enable Encryption, then type and confirm the password you want to use. The
password can be a maximum of 63 characters.

5. Drag and drop the file onto the dialog box, or click Browse to locate the firmware package (. out file) that you
downloaded from the Customer Service & Support portal and then click Open.

6. Click OK. Your device will upload the firmware image and you will receive a confirmation message noting that the
upgrade was successful.

. Optionally, you can upgrade firmware stored on an FTP or TFTP server using the following
sy

S g’ CLI command:
? execute restore image {ftp | tftp} <file path to server> <IP of
- server> <username on server> <password>

For more information, see the FortiAnalyzer CLI Reference.

7. Refresh the browser and log back into the device.
8. Launch the Device Manager module and make sure that all formerly added devices are still listed.
9. Launch other functional modules and make sure they work properly.

Backing up the system

Fortinet recommends that you back up your FortiAnalyzer configuration to your management computer on a regular
basis to ensure that, should the system fail, you can quickly get the system back to its original state with minimal affect to
the network. You should also back up your configuration after making any changes to the FortiAnalyzer configuration or
settings that affect connected devices.

Fortinet recommends backing up all configuration settings from your FortiAnalyzer unit before upgrading the
FortiAnalyzer firmware. See Updating the system firmware on page 272.

An MD5 checksum is automatically generated in the event log when backing up the configuration. You can verify a
backup by comparing the checksum in the log entry with that of the backup file.
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To back up the FortiAnalyzer configuration:

1. Go to System Settings > Dashboard.

2. Inthe System Information widget, click the backup button next to System Configuration. The Backup System dialog
box opens

3. If you want to encrypt the backup file, select the Encryption box, then type and confirm the password you want to
use. The password can be a maximum of 63 characters.

4. Select OK and save the backup file on your management computer.

Configuring automatic backups

You can configure FortiAnalyzer to automatically backup your configuration on a set schedule. This feature can only be
configured through the CLI.

To schedule automatic backup of the FortiAnalyzer configuration:

1. Inthe FortiAnalyzer CLlI, enter the following command:
config system backup all-settings

2. Configure the backup settings:
set status {enable | disable}
set server {<ipv4 address>|<fqgdn str>}
set user <username>
set directory <string>
set week days {monday tuesday wednesday thursday friday saturday sunday}
set time <hh:mm:ss>
set protocol {ftp | scp | sftp}
set passwd <passwd>
set crptpasswd <passwd>
end

For example, the following configuration uses the FTP protocol to backup the configuration to server 172.20.120.11in
the /usr/local/backup directory every Monday at 1:00pm.
config system backup all-settings
set status enable
set server 172.20.120.11
set user admin
set directory /usr/local/backup
set week days monday
set time 13:00:00
set protocol ftp
end

For more information, see the FortiAnalyzer CLI Reference Guide on the Fortinet Documents Library.
To find the MD5 checksum generated with the backup:

1. Inthe GUI, go to System Settings > Event Log.
2. Inthe Changes column for the event log, note the MD5 checksum.
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Restoring the configuration

You can use the following procedure to restore your FortiAnalyzer configuration from a backup file on your management
computer.

To restore the FortiAnalyzer configuration:

1. Goto System Settings > Dashboard.

2. Inthe System Information widget, click the restore button next to System Configuration. The Restore System dialog
box opens.

3. Configure the following settings then select OK.

Choose Backup File Select Browse to find the configuration backup file you want to restore, or drag
and drop the file onto the dialog box.

Password Type the encryption password, if applicable.

Overwrite current IP and Select the checkbox to overwrite the current IP and routing settings.

routing settings

Migrating the configuration

You can back up the system of one FortiAnalyzer model, and then use the CLI and the FTP, SCP, or SFTP protocol to
migrate the settings to another FortiAnalyzer model.

If you encrypted the FortiAnalyzer configuration file when you created it, you need the password to decrypt the
configuration file when you migrate the file to another FortiAnalyzer model.

To migrate the FortiAnalyzer configuration:

In one FortiAnalyzer model, go to System Settings > Dashboard.
Back up the system. See Backing up the system on page 274.
In the other FortiAnalyzer model, go to System Settings > Dashboard.

In the CLI Console widget, type the following command:
execute migrate all-settings <ftp | scp | sftp> <server> <filepath> <user> <password>
[cryptpasswd]

P owbd-=

Configuring the operation mode

The FortiAnalyzer unit has two operation modes: Analyzer and Collector. For more information, see Operation modes on
page 30.

When FortiAnalyzer is operating in Collector mode, the SQL database is disabled by default so logs that require the SQL
database are not available in Collector mode unless the SQL database is enabled.

To change the operation mode:

1. Goto System Settings > Dashboard.
2. Inthe System Information widget, select Analyzer or Collector in the Operation Mode field
3. Click OKin the confirmation dialog box to change the operation mode.
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System Resources widget

The System Resources widget displays the usage status of the CPUs, memory, and hard disk. You can view system
resource information in real-time or historical format, as well as average or individual CPU usage.

On VMs, warning messages are displayed if the amount of memory or the number of CPUs assigned are too low, or if the
allocated hard drive space is less than the licensed amount. These warnings are also shown in the notification list (see
GUI overview on page 23). Clicking on a warning opens the FortiAnalyzer VM Install Guide.

System Resources 4 Oox%

3% 43% 55%

Average CPU Usage Memory Usage Disk Usage
© FortiAnalyzer VM requires minimurn 4GB Memory and 2x vCPU.

To toggle between real-time and historical data, click Edit in the widget toolbar, select Historical or Real-time, edit the
other settings as required, then click OK.

To view individual CPU usage, from the Real-Time display, click on the CPU chart. To go back to the standard view, click
the chart again.

License Information widget

The License Information widget displays the number of devices connected to the FortiAnalyzer.

License Information & K it =v
EBVMS License @ VMS License v i+lla
@ ADOM License © No License (2 Used / 5 Total) w
& FortiCloud @ Registered @ Cloud Management [
® FortiGuard Indicators of Compromise Service @ Licensed (Expires 2023-06-04)

FortiAnalyzer Outbreak Detection Service @ Licensed (Expires N/A)

Server Location 3 Servers located in US only ®
 Security Operations Security Automation O Licensed (Expires 2023-06-04)
% Logging Devices/VDOMs 8 /10,000 (0.1%)

GB/Day @ 0.0/5(0.0%) =
& Storage Connector Service  Cloud @ No License w
Q Update Server AntiVirus and IPS #5544 57 (8 Sunnyvale, California, United States)

FortiClient Update 4 e 9V (13 Sunnyvale, California, United States)
VMS License VM license information and status.

Click the Add License button to log in to FortiCloud and activate an add-on
license. See Activating add-on licenses on page 280.

Click the Upload License button to upload a new VM license file.
This field is only visible for FortiAnalyzer VM.

The Duplicate status appears when users try to upload a license that is already in
use. Additionally, the following message will be displayed in the Notifications:

Duplicate License has been found! Your VM license will expire in XX hours (Grace
time: 24 hours)

Users will have 24 hours to upload a valid license before the duplicate license is
blocked.
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ADOM License

FortiCloud

FortiGuard

Indicators of
Compromise
Service

FortiAnalyzer
Outbreak Detection
Service

Secure DNS Server

Server Location

Security Operations

Logging

Device/VDOMs

GB/Day

Storage Connector Service

Update Server

ADOM license information and status.
For Hardware models, the default number of ADOMs can be found in the Release
Notes on docs.fortinet.com.

For FortiAnalyzer-VM Subscription licenses, 5 ADOMs are included. They are
non-stackable. Additional ADOMs can be purchased with an ADOM subscription
license.

License registration status with FortiCloud. Displays Not Registered or
Registered.

When FortiCloud displays Not Registered, a Register Now link is available. You
can click the Register Now link to register the device or VM license with
FortiCloud. See Registering with FortiCloud on page 279.

If registered, you can enable/disable remote access from FortiCloud. See
Enabling remote access from FortiCloud on page 279

The license status.

Click the purchase button to go to the Fortinet Customer Service & Support
website, where you can purchase a license.

The license status. For more information, see Outbreak Alerts on page 212.

The SDNS server license status.
Click the upload image button to upload a license key.

The locations of the FortiGuard servers, either global or US only.

Click the edit icon to adjust the location. Changing the server location will cause
the FortiAnalyzer to reboot.

The license status.

The total number of devices and VDOMSs connected to the FortiAnalyzer and the
total number of device and VDOM licenses.

The gigabytes per day of logs allowed and used for this FortiAnalyzer. Click the
show details button to view the GB per day of logs used for the previous 6 days.

The GB/Day log volume can be viewed per ADOM through the CLI using:

diagnose fortilogd logvol-adom <name>.

The cloud storage license status.

Displays usage statistics as well as the license expiration date when a valid
license is present.

Click the purchase button to go to the Fortinet Customer Service & Support
website, where you can purchase a license.
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AntiVirus and IPS The IP address and physical location of the Antivirus and IPS update server.

Web and Email The IP address and physical location of the web and email filter update server.
Filter

FortiClient Update The IP address and physical location of the FortiClient update server.

Registering with FortiCloud

Register your device with FortiCloud to receive customer services, such as firmware updates and customer support.

\ﬂ To view a list of registered devices, go to the Fortinet Technical Support site

(https://support.fortinet.com/), and use your FortiCloud credentials to log in. Go to Asset >
Manage/View Products.

See also Activating VM licenses on page 19.

To register a FortiAnalyzer device:

1. Go to System Settings > Dashboard.

2. Inthe License Information widget, click Register Now for FortiCloud.
The registration dialog opens.

3. Enter the device details.
4. Click OK. FortiAnalyzer connects to FortiCloud and registers the device.
A confirmation message appears at the top of the content pane, and the Status field changes to Registered.

Enabling remote access from FortiCloud

Enable remote access to your device from FortiCloud.

The device must be registered with FortiCloud to enable remote access.

You cannot enable remote access from FortiCloud if the FortiAnalyzer is managed by a
FortiManager. You must disable the management before enabling remote access.
For a FortiAnalyzer high availability (HA) cluster, only the primary unit needs to register and enable remote access from
FortiCloud.

To enable remote access from FortiCloud using the GUI:

1. Goto System Settings > Dashboard.

2. Inthe License Information widget, click the edit icon for FortiCloud.
The Cloud Management dialog opens.
3. Enable Cloud Management.
4. Inthe Password field, type the password for the FortiCloud account.
The Serial Number and FortiCloud Account ID/Email are automatically populated.
5. Click OK.
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To enable remote access from FortiCloud using the CLI:

1. Enter the following command to set central managementto cloud-management:
config system central-management
set type cloud-management

Ifthe central management typeis setto fortimanager (default) or none, remote access from FortiCloud will
be disabled.

2. Enter the following command to log in to FortiCloud:
execute cloud-remote-access login <id> <password> <domain> <email confirm>

Activating add-on licenses

If you have purchased an add-on license and have a FortiCloud account, you can use the License Information widget to
activate an add-on license. You will need the contract registration code to activate the license.

After you enter the contract registration code for the license, FortiAnalyzer communicates with FortiCloud to activate the
license.

To purchase a new license:

1. Go to the Fortinet Technical Support site at https://support.fortinet.com/.
2. Login by using your FortiCloud account credentials.
3. Purchase alicense.
You will receive an email from Fortinet with a PDF attachment that includes a contract registration code.

To add a license:

1. Go to System Settings > Dashboard.

2. Inthe License Information widget, beside the VM License option, click the Add License button.
The Add License dialog box is displayed.

3. Complete the following options, and click OK:
a. Inthe Account ID/Email box, type the email for your FortiCloud account.
b. Inthe Password box, type the password for your FortiCloud account.

c. Inthe Registration Code box, enter the contract registration code for the add-on license.
The License Agreement is displayed.
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L

License Agreement

@

Q

4 1 of9 — | 4+ Automatic Zoom v L= I |

SERATINET

Fortinet Service Terms & Conditions
For FortiCare, FortiGuard and other Fortinet Service Offerings

THESE TERMS AND CONDITIONS APPLY TO THE PROVISION OF SERVICES BY FORTINET AND EXCLUSIVELY GOVERN THE LEGAL
RELATIONSHIP BETWEEN YOU (THE “CUSTOMER”) AND FORTINET. IT SETS FORTH THE LEGALLY BINDING RIGHTS AND OBLIGATIONS
OF THE CUSTOMER IN RELATION TO FORTICARE SUPPORT OR FORTIGUARD SUBSCRIPTION SERVICES OR OTHER FORTINET SERVICE
OFFERINGS. THE CUSTOMER CONSENTS TO BE BOUND BY THESE TERMS AND CONDITIONS (THE “AGREEMENT"”). THE CUSTOMER
REPRESENTS THAT IT IS A SOPHISTICATED ENTITY, THAT HAS READ AND UNDERSTANDS THIS AGREEMENT AND HAS HAD SUFFICIENT
QOPPORTUNITY TO CONSULT WITH COUNSEL BEFORE AGREEING TO THE TERMS HEREIN. IF THE CUSTOMER DOES NOT AGREE TO THE
TERMS, THE CUSTOMER SHOULD NOT ACCEPT THE AGREEMENT AND SHOULD CONTACT LEGAL@FORTINET.COM TO REQUEST
CHANGES TO THE AGREEMENT. THE CUSTOMER AGREES THAT ANY OF THE FOLLOWING ACTIONS BY CUSTOMER REPRESENTATIVES
REPRESENT THE CUSTOMER’S AUTHORIZED CONSENT TO BE BOUND BY THIS AGREEMENT: (I) RECEIVING, DOWNLOADING,
DEPLOYING OR USING ANY SOFTWARE PROVIDED IN CONNECTION WITH FORTINET SERVICES, (Il) RECEIVING, CONFIGURING,
LOGGING IN, REGISTERING OR OTHERWISE USING OR BENEFITTING FROM THE SERVICES, OR (lll) BY CLICKING ON THE “ACCEPT”
BUTTON UPON REGISTRATION (ANY OF (1), (I1), OR (1ll) SHALL CONSTITUTE “ACCEPTANCE” BY CUSTOMER). THE CUSTOMER HEREBY
ACKNOWLEDGES AND AGREES THAT THE PERSON ENGAGING IN (1), (I1), AND/OR (Ill) IS AUTHORIZED TO BIND THE CUSTOMER TO
THE TERMS HEREIN. FOR CLARITY, NOTWITHSTANDING ANYTHING TO THE CONTRARY, IF CUSTOMER IS USING AN
AUTOREGISTRATION TOOL OR HAS ENGAGED A FORTIPARTNER OR FORTINET TO REGISTER THE SERVICE CONTRACT ON ITS BEHALF,
CUSTOMER ACKNOWLEDGES AND AGREES THAT ANY AND ALL UNITS REGISTERED USING SUCH TOOL SHALL BE SUBJECT TO THIS
AGREEMENT.

Services are available independently or in connection with the purchase of Fortinet's commercial networking products and related
equipment, including Hardware products with embedded Software, and stand-alone Software products sold and licensed to
Customer  pursuant to Fortinet's End User License Agreement ("EULA"), which EULA is available at
https://www fortinet.com/content/dam/fortinet/assets/legal /EULA.pdf, and Customer hereby agrees to the terms of the EULA.

This Agreement constitutes a legal agreement between the parties with respect to FortiCare and FortiGuard Subscription services or
other Services, and shall supersede all prior representations, discussions, negotiations and agreements, whether written or oral.
Notwithstanding anything to the contrary, Fortinet is only bound by, and Customer is only entitled to, services pursuant to official
service descriptions that are authorized by Fortinet pursuant to this Agreement and are contractually binding on Fortinet pursuant
to the terms herein

11 have read and accept the terms in the License Agreement.

OK

4. Accept the license agreement:
a. Read the license agreement.
b. Selectthe | have read and accept the terms in the License Agreement checkbox.
c. Click OK.
The Restart Device dialog box is displayed.

Restart Device

This device must restart to apply the new license. Would you like to restart now?

Restart N Restart Later

5. Click Restart Now to apply the license.
FortiAnalyzer restarts, and the license is applied.

6. Go to System Settings > Dashboard > License Information widget.
The VM License option displays Valid <license name>.
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Unit Operation widget

The Unit Operation widget graphically displays the status of each port. The port name indicates its status by its color.
Green indicates the port is connected. Grey indicates there is no connection.

Hover the cursor over the ports to view a pop-up that displays the full name of the interface, the IP address and netmask,
the link status, the speed of the interface, and the amounts of sent and received data.

Unit Operation oo%

FORTINET

Alert Messages Console widget

The Alert Message Console widget displays log-based alert messages for both the FortiAnalyzer unit itself and
connected devices.

Alert messages help you track system events on your FortiAnalyzer unit such as firmware changes, and network events
such as detected attacks. Each message shows the date and time the event occurred.

L}
S L4
9 Alert messages can also be delivered by email, syslog, or SNMP.
Alert Message Console EROR
Time Message

May 31,09:59:02  Disk usage for Adom FortiMail is approaching the delete threshold 90% of total 102400 MB.
May 31, 09:57:26  Disk usage for Adom FortiSandb approaching the delete threshold 0% of total 102400 MB.
May 31,09:41:48  Disk usage for Adom root is ing the delete threshold 90% of total 3145728 MB.

May 31, 08:58:59  Disk usage for Adom FortiMail is approaching the delete threshold 90% of total 102400 MB.
May 31, 08:57:25  Disk usage for Adom FortiSandbox is approaching the delete threshold 90% of total 102400 MB.
May 31, 08:41:37  Disk usage for Adom root is approaching the delete threshold 90% of total 3145728 MB.

May 31,07:58:59  Disk usage for Adom FortiMail is approaching the delete threshold 90% of total 102400 MB.
May 31,07:57:25  Disk usage for Adom FortiSandbox is approaching the delete threshold 90% of total 102400 MB.
May 31,07:41:32  Disk usage for Adom root is appr ing the delete threshold 90% of total 3145728 MB

May 31, 06:58:53  Disk usage for Adom FortiMail is approaching the delete threshold 90% of total 102400 MB.

Click Edit from the widget toolbar to view the Alert Message Console Settings, where you can adjust the number of
entries that are visible in the widget, and the refresh interval.

To view a complete list of alert messages, click Show More from the widget toolbar. The widget will show the complete
list of alerts. To clear the list, click Delete All Messages. Click Show Less to return to the previous view.

Log Receive Monitor widget

The Log Receive Monitor widget displays the rate at which the FortiAnalyzer unit receives logs over time. Log data can
be displayed by either log type or device.

Hover the cursor over a point on the graph to see the exact number of logs that were received at a specific time. Click the
name of a device or log type to add or remove it from the graph. Click Edit in the widget toolbar to modify the widget's
settings.
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Log Receive Monitor - Last 1 Hour BHox
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Insert Rate vs Receive Rate widget

The Insert Rate vs Receive Rate widget displays the log insert and log receive rates over time.

« Log receive rate: how many logs are being received.
« Loginsert rate: how many logs are being actively inserted into the database.

If the log insert rate is higher than the log receive rate, then the database is rebuilding. The lag is the number of logs
waiting to be inserted.

Hover the cursor over a point on the graph to see the exact number of logs that were received and inserted at a specific
time. Click Receive Rate or Insert Rate to remove those data from the graph. Click the edit icon in the widget toolbar to
adjust the time interval shown on the graph and the refresh interval.

Insert Rate vs Receive Rate - Last 1 Hour L= B2
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o] 3
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000
2000
2000-]
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ﬂ This widget is hidden when FortiAnalyzer is operating in Collector mode, and the SQL
I database is disabled.

Log Insert Lag Time widget

The Log Insert Lag Time widget displays how many seconds the database is behind in processing the logs.

Click the edit icon in the widget toolbar to adjust the time interval shown on the graph and the refresh interval (0 to
disable) of the widget.
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Receive Rate vs Forwarding Rate widget

The Receive Rate vs Forwarding Rate widget displays the rate at which the FortiAnalyzer is receiving logs. When log
forwarding is configured, the widget also displays the log forwarding rate for each configured server.

Click the edit icon in the widget toolbar to adjust the time period shown on the graph and the refresh interval, if any, of the
widget.

Receive Rate vs Forwarding Rate - Last 24 Hours nox
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Disk 1/0 widget

The Disk I/0 widget shows the disk utilization (%), transaction rate (requests/s), or throughput (KB/s), versus time.

Click the edit icon in the widget toolbar to select which chart is displayed, the time period shown on the graph, and the
refresh interval (if any) of the chart.
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Logging Topology

The Logging Topology pane shows the physical topology of devices in the Security Fabric. Click, hold, and drag to adjust
the view in the content pane, and double-click or use the scroll wheel to change the zoom.

The visualization can be filtered to show only FortiAnalyzer devices or all devices by device count or traffic.

Hovering the cursor over a device in the visualization will show information about the device, such as the IP address and
device name. Right-click on a device and select View Related Logs to go to the Log View pane, filtered for that device.

@ FMG-VMé4

E"(é FAZVMé&4-Collector2

FAZVMS542

Network

The network settings are used to configure ports for the FortiAnalyzer unit. You should also specify what port and
methods that an administrators can use to access the FortiAnalyzer unit. If required, static routes can be configured.

The default port for FortiAnalyzer units is port 1. It can be used to configure one IP address for the FortiAnalyzer unit, or
multiple ports can be configured with multiple IP addresses for improved security.

You can configure administrative access in IPv4 or IPv6 and include settings for HTTPS, HTTP, PING, SSH, SNMP,
Web Service, and FortiManager.

L}
S L4
9 FortiAnalyzer supports SSHv2.

You can prevent unauthorized access to the GUI by creating administrator accounts with trusted hosts. With trusted
hosts configured, the administrator can only log in to the GUI when working on a computer with the trusted host as
defined in the administrator account. For more information, see Trusted hosts on page 349 and Managing administrator
accounts on page 350.
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Configuring network interfaces

Fortinet devices can be connected to any of the FortiAnalyzer unit's interfaces. The DNS servers must be on the

networks to which the FortiAnalyzer unit connects, and should have two different IP addresses.

The following port configuration is recommended:

« Use port 1 for device log traffic, and disable unneeded services on it, such as SSH, Web Service, and so on.
» Use a second port for administrator access, and enable HTTPS, Web Service, and SSH for this port. Leave other

services disabled.

To configure port 1:

1. Go to System Settings > Network.The Interface pane is displayed at the top of the page.

Interface

+ CreateNew [ Edit E Delete 4 Column Settings -

Name 1P/Netmask 1Pv6 Address Description Administrative Access IPv6 Administrative Access  Service Access Enable
portl 10.100.55.2/2 0 ATTPS, HTTP, PING, S5
port2 10.100.88.2/2 ATTPS, HTTP, PING, SSH

;
port3 0.00.0/0.000
port4 0.00.0/0.000
port5 0.00.0/0.000
porté 0.00.0/0.000
port7 0.00.0/0.000
port8 0.00.0/0.000
port9 0.00.0/0.000
port10 0.00.0/0.000
portl1 0.00.0/0.000
port12 0.00.0/0.000

00o0o0o0oo0oo0oo0oo0ooooo
5566666056060 06

8888
208.91.112.53

2. Inthe Interface pane, double-click Port1. The Edit System Interface pane is displayed.

Edit System Interface

Name
Alias
1P Address/Netmask 10.100.55.2/255.255.255.0

1Pv6 Addre /0

Administrative Access G HTTPS BHTTP BPING BSsH CISNMP OWeb Service
FortiManager

HTTPS CIHTTP CIPING CJSSH CISNMP C)Web Service
FortiManager

Status [ Enaie [

3. Configure the following settings for port1, then click OK to apply your changes.

Name Displays the name of the interface.

IP Address/Netmask The IP address and netmask associated with this interface.

IPv6 Address The IPv6 address associated with this interface.

Administrative Access Select the allowed administrative service protocols from: HTTPS, HTTP,

PING, SSH, SNMP, Web Service, and FortiManager.

IPv6 Administrative Access Select the allowed IPv6 administrative service protocols from: HTTPS, HTTP,

PING, SSH, SNMP, Web Service, and FortiManager.

Status Select Enable or Disable.
4. Configure the DNS settings, and click Apply.

Primary DNS Server The primary DNS server IP address.

FortiAnalyzer 7.2.2 Administration Guide
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Secondary DNS Server The secondary DNS server IP address.

To configure additional ports:

Go to System Settings > Network. The Interface pane is displayed at the top of the page.

In the Interface pane, double-click on a port, right-click on a port then select Edit from the pop-up menu, or select a
port then click Edit in the toolbar. The Edit System Interface pane is displayed.

Configure the settings as required.
Click OK to apply your changes.

Ay
‘?' The port name, default gateway, and DNS servers cannot be changed from the Edit System
- Interface pane. The port can be given an alias if needed.

Disabling ports

Ports can be disabled to prevent them from accepting network traffic

To disable a port:

1.
2,

Go to System Settings > Network. The Interface list is displayed.

Double-click on a port, right-click on a port then select Edit from the pop-up menu, or select a port then click Edit in
the toolbar. The Edit System Interface pane is displayed.

In the Status field, click Disable
Click OK to disable the port.

Changing administrative access

Administrative access defines the protocols that can be used to connect to the FortiAnalyzer through an interface. The
available options are: HTTPS, HTTP, PING, SSH, SNMP, Web Service, and FortiManager.

To change administrative access:

1.
2,

Go to System Settings > Network and click All Interfaces. The interface list opens.

Double-click on a port, right-click on a port then select Edit from the pop-up menu, or select a port then click Edit in
the toolbar. The Edit System Interface pane is displayed.

Select one or more access protocols for the interface for Administrative Access and IPv6 Administrator Access, as
required.

Click OK to apply your changes.

Static routes

Static routes can be managed from the routing tables for IPv4 and IPv6 routes. The routing tables can be accessed by
going to System Settings > Network.

FortiAnalyzer 7.2.2 Administration Guide
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To add a static route:

1. From the network routing table, click Create New in the toolbar. The Create New Network Route pane opens.
2. Selectthe IP Type as either IPv4 or IPv6.

3. Enter the destination IP address and netmask, or IPv6 prefix, and gateway in the requisite fields.

4

Select the network interface that connects to the gateway from the dropdown list. Ports, aggregate links, and VLANs
are available.

Click OK to create the new static route.

o

To edit a static route:

1. From the network routing table: double-click on a route, right-click on a route then select Edit from the pop-up menu,
or select a route then click Edit in the toolbar. The Edit Network Route pane opens.

2. Edit the configuration as required. The route ID cannot be changed.
3. Click OK to apply your changes.

To delete a static route or routes:

1. From the newtork routing table, right-click on a route then select Delete from the pop-up menu, or select a route or
routes then click Delete in the toolbar.

2. Click OKin the confirmation dialog box to delete the selected route or routes.

Packet capture

Packets can be captured on configured interfaces by going to System > Network > Packet Capture.

The following information is available:

Interface The name of the configured interface for which packets can be captured.
For information on configuring an interface, see Configuring network interfaces on
page 286.

Filter Criteria The values used to filter the packet.

# Packets The number of packets.

Maximum Packet Count The maximum number of packets that can be captured on a sniffer.

Progress The status of the packet capture process.

Actions Allows you to start and stop the capturing process, and download the most

recently captured packets.

To start capturing packets on an interface, select the Start capturing button in the Actions column for that interface. The
Progress column changes to Running, and the Stop capturing and Download buttons become available in the Actions
column.
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To add a packet sniffer:

1. From the Packet Capture table, click Create New in the toolbar. The Create New Sniffer pane opens.
2. Configure the following options:

Interface The interface name (non-changeable).

Max. Packets to Save Enter the maximum number of packets to capture, between 1-10000. The
default is 4000 packets.

Include IPv6 Packets Select to include IPv6 packets when capturing packets.

Include Non-IP Packets Select to include non-IP packets when capturing packets.

Enable Filters You can filter the packet by Host(s), Port(s), VLAN(s), and Protocol.
3. Click OK.

To download captured packets:

1. Inthe Actions column, click the Download button for the interface whose captured packets you want to download.
If no packets have been captured for that interface, click the Start capturing button.

2. When prompted, save the packet file (sniffer_[interface].pcap) to your management computer.
The file can then be opened using packet analyzer software.

To edit a packet sniffer:

1. From the Packet Capture table, click Edit in the toolbar. The Edit Sniffer pane opens.
2. Configure the packet sniffer options
3. Click OK.

Aggregate links

Link aggregation enables you to bind two or more physical interfaces together to form an aggregated (combined) link.
This new link has the bandwidth of all the links combined. If a link in the group fails, traffic is transferred automatically to
the remaining interfaces.

To configure aggregate links:

Go to System Settings > Network.

In the Interface toolbar, click Create New. The Create New Interface page is displayed.
In the Name field, enter a name for the interface.

In the Type field, select Aggregate.

In the Members field, select the ports you want to include in the aggregate.

In the IP Addess/Netmask field, enter the IP address for the aggregate link.

In the Administrative Access field, select the access protocol.

In the IPv6 Administrative Access area, select the access protocol.

Setthe LACP Speed to Slow or Fast.

© ®No b ON-=

FortiAnalyzer 7.2.2 Administration Guide 289
Fortinet Inc.



System Settings

10. Inthe Minimum Links Up field, enter the number of aggregated ports that must be up.

A\,

b [ 4
? You must enter a minimum value of 2 for the aggregate links to work.

11. Set Minimum Links Down to Operational or Administrative.

12. Inthe Links up Delay, set the number of milliseconds to wait before considering the link is up.
13. Click OK.

After the aggregate links are configured, log into FortiGate and go to Network > Interfaces, and configure an aggregation
interface. For information, see Aggregation and redundancy in the FortiOS Administration Guide.

To enable the interface with the GUI:

1. Go to System Settings > Network.

2. Inthe Interface pane, double-click the aggregate interface to edit it. The Edit System Interface window opens.
3. Setthe Statusto Enable.

To enable the interface with the CLI:

# config system interface
(interface) # edit Aggregationl
(Aggregationl) # set status up
(Aggregationl) # end

VLAN interfaces

You can configure a VLAN interface in FortiAnalyzer by going to System Settings > Network.

To configure a VLAN interface:

1. Go to System Settings > Network.
2. Inthe Interface toolbar, click Create New. The Create New Network Interface page is displayed.
3. Inthe Name field, enter a name for the VLAN.
4. Inthe Typefield, select VLAN.
5. Inthe VLAN IDfield, enter a VLAN ID. You can use a range between 1 and 4094.
6. Inthe Interface field, select the interface to which the VLAN will be bound.
7. Inthe Protocol field, select either IEEE 802.1Q. or IEEE 802.1AD.
8. Inthe IP Address/Netmask field, enter the IP address for the VLAN.
9. Optionally, add an IPv6 Address.
10. Inthe Administrative Access field, select the access protocol.
11. Optionally, configure the IPv6 Administrative Access.
12. Inthe Service Access field, select which services can be accessed in this VLAN.
13. Inthe Statusfield, select the VLAN status.
14. Click OK.
15. Ifrequired, you can create a static route with the VLAN interface. See Static routes on page 287.
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RAID Management

RAID helps to divide data storage over multiple disks, providing increased data reliability. For FortiAnalyzer devices
containing multiple hard disks, you can configure the RAID array for capacity, performance, and/or availability.

Al
‘?' The RAID Management tree menu is only available on FortiAnalyzer devices that support

RAID.

Supported RAID levels

FortiAnalyzer units with multiple hard drives can support the following RAID levels:

l\ See the FortiAnalyzer datasheet to determine your devices supported RAID levels.

Linear RAID

A Linear RAID array combines all hard disks into one large virtual disk. The total space available in this option is the
capacity of all disks used. There is very little performance change when using this RAID format. If any of the drives fails,
the entire set of drives is unusable until the faulty drive is replaced. All data will be lost.

RAID 0

A RAID 0 array is also referred to as striping. The FortiAnalyzer unit writes information evenly across all hard disks. The
total space available is that of all the disks in the RAID array. There is no redundancy available. If any single drive fails,
the data on that drive cannot be recovered. This RAID level is beneficial because it provides better performance, since
the FortiAnalyzer unit can distribute disk writing across multiple disks.

e Minimum number of drives: 2
o Data protection: No protection

A\,
S r'd
q RAID 0 is not recommended for mission critical environments as it is not fault-tolerant.

RAID 1

A RAID 1 array is also referred to as mirroring. The FortiAnalyzer unit writes information to one hard disk, and writes a
copy (a mirrorimage) of all information to all other hard disks. The total disk space available is that of only one hard disk,
as the others are solely used for mirroring. This provides redundant data storage with no single point of failure. Should
any of the hard disks fail, there are backup hard disks available.

e Minimum number of drives: 2
» Data protection: Single-drive failure
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A\,

~ P One write or two reads are possible per mirrored pair. RAID 1 offers redundancy of data. A re-
? build is not required in the event of a drive failure. This is the simplest RAID storage design
3 with the highest disk overhead.
RAID 1s

A RAID 1 with hot spare array uses one of the hard disks as a hot spare (a stand-by disk for the RAID). If a hard disk fails,
within a minute of the failure the hot spare is substituted for the failed drive, integrating it into the RAID array and
rebuilding the RAID’s data. When you replace the failed hard disk, the new hard disk is used as the new hot spare. The
total disk space available is the total number of disks minus two.

RAID 5

A RAID 5 array employs striping with a parity check. Similar to RAID 0, the FortiAnalyzer unit writes information evenly
across all drives but additional parity blocks are written on the same stripes. The parity block is staggered for each stripe.
The total disk space is the total number of disks in the array, minus one disk for parity storage. For example, with four
hard disks, the total capacity available is actually the total for three hard disks. RAID 5 performance is typically better
with reading than with writing, although performance is degraded when one disk has failed or is missing. With RAID 5,
one disk can fail without the loss of data. If a drive fails, it can be replaced and the FortiAnalyzer unit will restore the data
on the new disk by using reference information from the parity volume.

¢ Minimum number of drives: 3
« Data protection: Single-drive failure

RAID 5s

A RAID 5 with hot spare array uses one of the hard disks as a hot spare (a stand-by disk for the RAID). If a hard disk fails,
within a minute of the failure, the hot spare is substituted for the failed drive, integrating it into the RAID array, and
rebuilding the RAID’s data. When you replace the failed hard disk, the new hard disk is used as the new hot spare. The
total disk space available is the total number of disks minus two.

RAID 6

A RAID 6 array is the same as a RAID 5 array with an additional parity block. It uses block-level striping with two parity
blocks distributed across all member disks.

e Minimum number of drives: 4
« Data protection: Up to two disk failures.

RAID 6s

A RAID 6 with hot spare array is the same as a RAID 5 with hot spare array with an additional parity block.

RAID 10
RAID 10 (or 1+0), includes nested RAID levels 1 and 0, or a stripe (RAID 0) of mirrors (RAID 1). The total disk space
available is the total number of disks in the array (a minimum of 4) divided by 2, for example:

o 2 RAID 1 arrays of two disks each,
« 3 RAID 1 arrays of two disks each,

FortiAnalyzer 7.2.2 Administration Guide 292
Fortinet Inc.



System Settings

« 6 RAID1 arrays of two disks each.

One drive from a RAID 1 array can fail without the loss of data; however, should the other drive in the RAID 1 array fail,
all data will be lost. In this situation, it is important to replace a failed drive as quickly as possible.

e Minimum number of drives: 4
» Data protection: Up to two disk failures in each sub-array.

Ay
b ] L4
? Alternative to RAID 1 when additional performance is required.

RAID 50

RAID 50 (or 5+0) includes nested RAID levels 5 and 0, or a stripe (RAID 0) and stripe with parity (RAID 5). The total disk
space available is the total number of disks minus the number of RAID 5 sub-arrays. RAID 50 provides increased
performance and also ensures no data loss for the same reasons as RAID 5. One drive in each RAID 5 array can fail
without the loss of data.

e Minimum number of drives: 6
« Data protection: Up to one disk failure in each sub-array.

Ay
S L4

q Higher fault tolerance than RAID 5 and higher efficiency than RAID 0.
RAID 50 is only available on models with 9 or more disks. By default, two groups are used
unless otherwise configured via the CLI. Use the diagnose system raid status CLI

I command to view your current RAID level, status, size, groups, and hard disk drive
information.
RAID 60

A RAID 60 (6+ 0) array combines the straight, block-level striping of RAID 0 with the distributed double parity of RAID 6.

e Minimum number of drives: 8
« Data protection: Up to two disk failures in each sub-array.

L}
‘?' High read data transaction rate, medium write data transaction rate, and slightly lower
|| performance than RAID 50.

Configuring the RAID level

Changing the RAID level will delete all data.

>

FortiAnalyzer 7.2.2 Administration Guide 293
Fortinet Inc.



System Settings

To configure the RAID level:

1. Go to System Settings > RAID Management.
2. Click Change in the RAID Level field. The RAID Settings dialog box is displayed.
3. Fromthe RAID Level list, select a new RAID level, then click OK.

The FortiAnalyzer unit reboots. Depending on the selected RAID level, it may take a significant amount of time to
generate the RAID array.

Monitoring RAID status

To view the RAID status, go to System Settings > RAID Management. The RAID Management pane displays the RAID
level, status, and disk space usage. It also shows the status, size, and model of each disk in the RAID array.

The Alert Message Console widget, located in System Settings > Dashboard, provides
detailed information about RAID array failures. For more information see Alert Messages

A

Console widget on page 282.
I‘ v v v
& =/ =

RAID Level Raid-10 [Change]

Status System is functioning normally.

Disk Space Usage — ]25% Used
1890GB Used/ 5442GB Free/ 7332GB Total
Disk Management
Disk Number Disk Status Size(GB) Disk Model
0 A4 1862 ST2000NM0033-9ZM175
1 v 1862 ST2000NM0033-9ZM175
2 v 1862 ST2000NM0033-9ZM175
3 v 1862 ST2000NM0033-9ZM175
4 v 1862 ST2000NMO033-9ZM175
5 A4 1862 ST2000NMO033-9ZM175
6 A 4 1862 ST2000NM0033-9ZM175
7 v 1862 ST2000NM0033-9ZM175
Summary Shows summary information about the RAID array.
Graphic Displays the position and status of each disk in the RAID array. Hover the cursor
over each disk to view details.
RAID Level Displays the selected RAID level.
Click Change to change the selected RAID level. When you change the RAID
settings, all data is deleted.
Status Displays the overall status of the RAID array.

Disk Space Usage

Disk Management
Disk Number

Disk Status
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Displays the total size of the disk space, how much disk space is used, and how
much disk space is free.

Shows information about each disk in the RAID array.
Identifies the disk number for each disk.

Displays the status of each disk in the RAID array.
* Ready: The hard drive is functioning normally.
* Rebuilding: The FortiAnalyzer unit is writing data to a newly added hard drive
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in order to restore the hard drive to an optimal state. The FortiAnalyzer unit is
not fully fault tolerant until rebuilding is complete.

* Initializing: The FortiAnalyzer unit is writing to all the hard drives in the device
in order to make the array fault tolerant.

e Verifying: The FortiAnalyzer unit is ensuring that the parity data of a
redundant drive is valid.

» Degraded: The hard drive is no longer being used by the RAID controller.

* Inoperable: One or more drives are missing from the FortiAnalyzer unit. The
drive is no longer available to the operating system. Data on an inoperable
drive cannot be accessed.

Size (GB) Displays the size, in GB, of each disk.

Disk Model Displays the model number of each disk.

Swapping hard disks

If a hard disk on a FortiAnalyzer unit fails, it must be replaced. On FortiAnalyzer devices that support hardware RAID, the
hard disk can be replaced while the unit is still running - known as hot swapping. On FortiAnalyzer units with software
RAID, the device must be shutdown prior to exchanging the hard disk.

To identify which hard disk failed, read the relevant log message in the Alert Message Console widget. See Alert
Messages Console widget on page 282.

Electrostatic discharge (ESD) can damage FortiAnalyzer equipment. Only perform the
procedures described in this document from an ESD workstation. If no such station is

available, you can provide some ESD protection by wearing an anti-static wrist or ankle strap
and attaching it to an ESD connector or to a metal part of a FortiAnalyzer chassis.

When replacing a hard disk, you need to first verify that the new disk is the same size as those
supplied by Fortinet and has at least the same capacity as the old one in the FortiAnalyzer unit.
Installing a smaller hard disk will affect the RAID setup and may cause data loss. Due to

possible differences in sector layout between disks, the only way to guarantee that two disks
have the same size is to use the same brand and model.

The size provided by the hard drive manufacturer for a given disk model is only an
approximation. The exact size is determined by the number of sectors present on the disk.

To hot swap a hard disk on a device that supports hardware RAID:

1. Remove the faulty hard disk.

2. |Install a new disk.
The FortiAnalyzer unit automatically adds the new disk to the current RAID array. The status appears on the
console. The RAID Management pane displays a green checkmark icon for all disks and the RAID Status area
displays the progress of the RAID re-synchronization/rebuild.
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Adding hard disks

Some FortiAnalyzer units have space to add more hard disks to increase your storage capacity.

\‘é', Fortinet recommends you use the same disks as those supplied by Fortinet. Disks of other

brands will not be supported by Fortinet. For information on purchasing extra hard disks,
contact your Fortinet reseller.

To add more hard disks:

1. Obtain the same disks as those supplied by Fortinet.

2. Back up the log data on the FortiAnalyzer unit.
You can also migrate the data to another FortiAnalyzer unit, if you have one. Data migration reduces system down
time and the risk of data loss.

3. Install the disks in the FortiAnalyzer unit.

If your unit supports hot swapping, you can do so while the unit is running. Otherwise the unit must be shut down
first. See Unit Operation widget on page 282 for information.

4. Configure the RAID level. See Configuring the RAID level on page 293.
5. If you backed up the log data, restore it.

Administrative Domains (ADOMs)

Administrative domains (ADOMs) enable administrators to manage only those devices that they are specifically

assigned, based on the ADOMs to which they have access. When the ADOM mode is advanced, FortiGate devices with

multiple VDOMSs can be divided among multiple ADOMs.

Administrator accounts can be tied to one or more ADOMSs, or denied access to specific ADOMs. When a particular
administrator logs in, they see only those devices or VDOMs that have been enabled for their account. Super user
administrator accounts, such as the admin account, can see and maintain all ADOMs and the devices within them.

Each ADOM specifies how long to store and how much disk space to use for its logs. You can monitor disk utilization for

each ADOM and adjust storage settings for logs as needed.

The maximum number of ADOMSs you can add depends on the FortiAnalyzer system model. Please refer to the
FortiAnalyzer data sheet for more information.

When the maximum number of ADOMs has been reached, you will be unable to create a new ADOM.

When upgrading to FortiAnalyzer 6.2.1 or later, you will continue to have access to any ADOMs exceeding the limit,
however, no additional ADOMs can be created, and an alert will be issued in the Alert Message Console in System
Settings > Dashboard.

FortiAnalyzer 7.2.2 Administration Guide
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By default, ADOMs are disabled. Enabling and configuring ADOMSs can only be done by administrators with the Super_
User profile. See Administrators on page 349.

The root ADOM and Security Fabric ADOMs are available for visibility into all Fabric devices. See Security Fabric
ADOMs on page 131.

Ay
‘Q' Non-FortiGate devices are automatically located in specific ADOMs for their device type. They
- cannot be moved to other ADOMs.
Ay
S L4
? ADOMs must be enabled to support the logging and reporting of non-FortiGate devices.
Root ADOM

When ADOMs are enabled, the default root ADOM type is Fabric. Fabric ADOMs show combined results from all
Security Fabric devices in the Device Manager, Log View, FortiView, Incidents & Events and Reports panes. For more
information on Fabric ADOMs, see Security Fabric ADOMs on page 131.

In FortiAnalyzer 6.2.0 and earlier, the root ADOM is a FortiGate ADOM. When upgrading to FortiAnalyzer 6.2.1 and later,
the root ADOM type will not be changed to Fabric. Resetting the FortiAnalyzer settings through a factory reset will cause
the root ADOM to become a Fabric ADOM.

Default device type ADOMs

When ADOMs are enabled, FortiAnalyzer includes default ADOMs for specific types of devices. When you add one or
more of these devices to FortiAnalyzer, the devices are automatically added to the appropriate ADOM, and the ADOM
becomes selectable. When a default ADOM contains no devices, the ADOM is not selectable.

For example, when you add a FortiClient EMS device to the FortiAnalyzer, the FortiClient EMS device is automatically
added to the default FortiClient ADOM. After the FortiClient ADOM contains a FortiClient EMS device, the FortiClient
ADOM is selectable when you log into FortiAnalyzer or when you switch between ADOMs.

You can view all of the ADOMSs, including default ADOMs without devices, on the System Settings > All ADOMs pane.

Organizing devices into ADOMs

You can organize devices into ADOMs to allow you to better manage these devices. Devices can be organized by
whatever method you deem appropriate, for example:

» Firmware version: group all devices with the same firmware version into an ADOM.

» Geographic regions: group all devices for a specific geographic region into an ADOM, and devices for a different
region into another ADOM.

« Administrative users: group devices into separate ADOMs based for specific administrators responsible for the
group of devices.

« Customers: group all devices for one customer into an ADOM, and devices for another customer into another
ADOM.
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FortiClient support and ADOMs

FortiClient logs are stored in the device that the FortiClient endpoint is registered to.

For example, when endpoints are registered to a FortiGate device, FortiClient logs are viewed on the FortiGate device.
When endpoints are registered to a FortiClient EMS, FortiClient logs are viewed in the FortiClient ADOM that the
FortiClient EMS device is added to.

ADOMs must be enabled to support FortiClient EMS devices.

Merge FortiAnalyzer Logging Support for FortiClient EMS for Chromebooks

1. Add https-loggingtothe allowaccess list using the following CLI command:
config system interface
edit "portl"
set allowaccess https ssh https-logging
next
end
2. Add SSL certificate to enable communication.
An SSL certificate is required to support communication and send logs between FortiClient Web Filter extension
and FortiAnalyzer. If you use a public SSL certificate, you only need to add the public SSL certificate to
FortiAnalyzer.

However, if you prefer to use a certificate that is not from a common CA, you must add the SSL certificate to
FortiAnalyzer, and you must push the root CA of your certificate to the Google Chromebooks. Otherwise, the

HTTPS connection between the FortiClient EMS Chromebook Web Filter extension and FortiAnalyzer will not work.

The common name of the certificate must be the FortiAnalyzer IP address.
a. InFortiAnalyzer, go to System Settings > Certificates > Local Certificates.
b. Click Import. The Import Local Certificate dialog box appears.
c. Inthe Type list, select Certificate. Or,
In the Type list, select PKCS#12 Certificate to upload the certificate in PK12 format.
d. Beside the Certificate File field, click Browse to select the certificate.
e. Enterthe password and certificate name.
f. Click OK.
3. Select certificates for HTTPS connections:
a. InFortiAnalyzer, go to System Settings > Admin > Admin Settings.
b. Inthe HTTPS & Web Service Certificate box, select the certificate you want to use for HTTPS connections, and
click Apply.
4. Enable the FortiClient ADOM using the following CLI command:
conf sys global

set adom-status enable
end

5. Add FortiClient EMS for Chromebooks as a device to the FortiClient ADOM:
Go to Device Manager > click the + Add Device button to add FortiClient EMS for Chromebooks as a FortiClient
ADOM device.

6. Enable logging in FortiClient EMS for Chromebooks:
You will need to enable logging in FortiClient EMS for Chromebooks, see the FortiClient EMS for Chromebooks
Administration Guide for more information.
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Enabling and disabling the ADOM feature

By default, ADOMs are disabled. Enabling and configuring ADOMSs can only be done by super user administrators.

When ADOMs are enabled, the Device Manager, FortiView, Log View, FortiSoC, and Reports panes are displayed per
ADOM. You select the ADOM you need to work in when you log into the FortiAnalyzer unit. See Switching between
ADOMSs on page 26.

To enable the ADOM feature:

1. Login to the FortiAnalyzer as a super user administrator.
2. Goto System Settings > Dashboard.

3. Inthe System Information widget, toggle the Administrative Domain switch to ON.
You will be automatically logged out of the FortiAnalyzer and returned to the log in screen.

To disable the ADOM feature:

1. Remove all the devices from all non-root ADOMSs. That is, add all devices to the root ADOM.
2. Delete all non-root ADOMs. See Deleting ADOMSs on page 304.
Only after removing all the non-root ADOMs can ADOMs be disabled.
3. Goto System Settings > Dashboard.
4. Inthe System Information widget, toggle the Administrative Domain switch to OFF.
You will be automatically logged out of the FortiAnalyzer and returned to the log in screen.

Ay
‘Q' The ADOMs feature cannot be disabled if ADOMs are still configured and have managed
- devices in them.

ADOM device modes

An ADOM has two device modes: Normal (default) and Advanced.

In Normal mode, you cannot assign different FortiGate VDOM s to different ADOMs. The FortiGate unit can only be
added to a single ADOM.

In Advanced mode, you can assign a VDOM from a single device to a different ADOM. This allows you to analyze data
for individual VDOMSs, but will result in more complicated management scenarios. It is recommended only for advanced
users.

Ay
‘Q' FortiAnalyzer does not support splitting FortiGate VDOMs between multiple ADOMs in
- different device modes.

To change from Advanced mode back to Normal mode, you must ensure no FortiGate VDOMs are assigned to an
ADOM.
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To change the ADOM device mode:

1. Go to System Settings > Advanced > Advanced Settings.
2. Inthe ADOM Mode field, select either Normal or Advanced.
3. Select Apply to apply your changes.

Managing ADOMs

The ADOMs feature must be enabled before ADOMs can be created or configured. See Enabling and disabling the

ADOM feature on page 299.

To create and manage ADOMs, go to System Settings > All ADOMs.
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re Version Allocated Storage
Fabric
FortiCarrier

FortiAnalyzer
FortiAuthenticator
FortiCache
FortiClient
FortiDDoS
FortiMail
FortiManager
FortiNAC
FortiProxy
FortiSandbox
FortiWeb
Syslog

50GB
1000 MB

1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB
1000 MB

Devices

> 3 Devices (including 2 VDOMs)

Create a new ADOM. See Creating ADOMSs on page 301.

Edit the selected ADOM. This option is also available from the right-click menu.

See Editing an ADOM on page 304.

Delete the selected ADOM or ADOMs. You cannot delete default ADOMs. This
option is also available from the right-click menu. See Deleting ADOMs on page

304.

Switch to the selected ADOM. This option is also available from the right-click

menu.

Disable the selected ADOM. This option is also available from the right-click

menu.

Select Expand Devices to expand all of the ADOMs to show the devices in each

ADOM.

Select Collapse Devices to collapses the device lists.
Select an ADOM, and click Clone to make a copy of the ADOM. Devices are not

cloned to the new ADOM.

Some of these options are also available from the right-click menu.

Enter a search term to search the ADOM list.

The name of the ADOM.
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ADOMs are listed in the following groups: Security Fabric, FortiGates and Other
Device Types. A group can be collapsed or expanded by clicking the triangle next
to its name.

Firmware Version The firmware version of the ADOM. Devices in the ADOM should have the same

firmware version.

Devices The number of devices and VDOMSs that the ADOM contains.

The device list can be expanded or by clicking the triangle.

Creating ADOMs

ADOMs must be enabled, and you must be logged in as a super user administrator to create a new ADOM.

Consider the following when creating ADOMs:

The maximum number of ADOMs that can be created depends on the FortiAnalyzer model. For more information,
see the FortiAnalyzer data sheet at https://www.fortinet.com/products/management/fortianalyzer.html.

When the maximum number of ADOMs has been exceeded, an alert will be issued in the Alert Message Console in
System Settings > Dashboard.

You must use an administrator account that is assigned the Super_User administrative profile.
You can add a device to only one ADOM. You cannot add a device to multiple ADOMs.

You cannot add FortiGate and FortiCarrier devices to the same ADOM. FortiCarrier devices are added to a specific,
default FortiCarrier ADOM.

You can add one or more VDOMSs from a FortiGate device to one ADOM. If you want to add individual VDOMs from
a FortiGate device to different ADOMs, you must first enable advanced device mode. See ADOM device modes on
page 299.

You can configure how an ADOM handles log files from its devices. For example, you can configure how much disk
space an ADOM can use for logs, and then monitor how much of the allotted disk space is used. You can also
specify how long to keep logs in the SQL database and how long to keep logs stored in compressed format.

To create an ADOM:

1.
2,

Ensure that ADOMs are enabled. See Enabling and disabling the ADOM feature on page 299.
Go to System Settings > All ADOMs.
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3. Click Create New in the toolbar. The Create New ADOM pane is displayed.

Create New ADOM

| )

Type Fabric

Comments

Devices

3

Name IP Address Platform
No Device.
Data Policy
Keep Logs for Analytics 60 Days
Keep Logs for Archive 365 Days
Disk Utilization
Allocated 0 MB + | Maximum Available: 0.0 KB
Analytics : Archive 70% v 30% Modify

Alert and Delete When Usage | 90%
Reaches

*If analytic or archive log usages exceed the configured disk quota before the retention period
expires, the oldest logs will be deleted.

4. Configure the following settings, then click OK to create the ADOM.

Name Type a name that allows you to distinguish this ADOM from your other
ADOMs. ADOM names must be unique.

Type Select the type of device that you are creating an ADOM for. The ADOM type
cannot be edited.
For Security Fabric ADOMSs, select Fabric.

Although you can create a different ADOM for each type of device,
FortiAnalyzer does not enforce this setting.

Devices Add a device or devices with the selected versions to the ADOM. The search
field can be used to find specific devices. See Assigning devices to an ADOM
on page 303.
Data Policy Specify how long to keep logs in the indexed and compressed states.
Keep Logs for Specify how long to keep logs in the indexed state.
Analytics During the indexed state, logs are indexed in the SQL database for the

specified amount of time. Information about the logs can be viewed in the
FortiView, Incidents & Events/FortiSoC, and Reports modules. After the
specified length of time expires, Analytics logs are automatically purged from
the SQL database.

Keep Logs for Specify how long to keep logs in the compressed state.
Archive

FortiAnalyzer 7.2.2 Administration Guide
Fortinet Inc.

302



System Settings

Disk Utilization

Maximum Allowed

Analytics : Archive

Alert and Delete
When Usage
Reaches

During the compressed state, logs are stored in a compressed format on the
FortiAnalyzer unit. When logs are in the compressed state, information about
the log messages cannot be viewed in the FortiView, Incidents &
Events/FortiSoC, or Reports modules. After the specified length of time
expires, Archive logs are automatically deleted from the FortiAnalyzer unit.

Specify how much disk space to use for logs.

Specify the maximum amount of FortiAnalyzer disk space to use for logs, and
select the unit of measure.

The total available space on the FortiAnalyzer unit is shown.

For more information about the maximum available space for each
FortiAnalyzer unit, see Disk space allocation on page 104.

Specify the percentage of the allotted space to use for Analytics and Archive
logs.

Analytics logs require more space than Archive logs. For example, a setting of
70% and 30% indicates that 70% of the allotted disk space will be used for
Analytics logs, and 30% of the allotted space will be used for Archive logs.
Select the Modify checkbox to change the setting.

Specify at what data usage percentage an alert messages will be generated
and logs will be automatically deleted. The oldest Archive log files or Analytics
database tables are deleted first.

Assigning devices to an ADOM

To assign devices to an ADOM you must be logged in as a super user administrator. Devices cannot be assigned to

multiple ADOMs.

To assign devices to an ADOM:

1. Goto System Settings > All ADOMs.

2. Double-click on an ADOM, right-click on an ADOM and then select the Edit from the menu, or select the ADOM then
click Editin the toolbar. The Edit ADOM pane opens.

3. Click Select Device. The Select Device list opens on the right side of the screen.

4. Selectthe devices that you want to add to the ADOM. Only devices with the same version as the ADOM can be
added. The selected devices are displayed in the Devices list.

If the ADOM mode is Advanced you can add separate VDOMs to the ADOM as well as units.
5. When done selecting devices, click Close to close the Select Device list.

6. Click OK.

The selected devices are removed from their previous ADOM and added to this one.

FortiAnalyzer 7.2.2 Administration Guide
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Assigning administrators to an ADOM

Super user administrators can create other administrators and either assign ADOMs to their account or exclude them
from specific ADOMSs, constraining them to configurations and data that apply only to devices in the ADOMs they can

access.
s‘ ! ’, By default, when ADOMs are enabled, existing administrator accounts other than admin are
q assigned to the root domain, which contains all devices in the device list. For more information
= about creating other ADOMs, see Creating ADOMs on page 301.

To assign an administrator to specific ADOMs:

1. Login as a super user administrator. Other types of administrators cannot configure administrator accounts when
ADOMs are enabled.

2. Goto System Settings > Admin > Administrator.

3. Double-click on an administrator, right-click on an administrator and then select the Edit from the menu, or select the
administrator then click Edit in the toolbar. The Edit Administrator pane opens.

4. Edit the Administrative Domain field as required, either assigning or excluding specific ADOMs.
5. Select OKto apply your changes.

A\,

b ] L4
? The admin administrator account cannot be restricted to specific ADOMs.

Editing an ADOM

To edit an ADOM you must be logged in as a super user administrator. The ADOM type and version cannot be edited.
For the default ADOMs, the name cannot be edited.

To edit an ADOM:

1. Go to System Settings > All ADOMs.

2. Double-click on an ADOM, right-click on an ADOM and then select Edit from the menu, or select the ADOM then
click Editin the toolbar. The Edit ADOM pane opens.

3. Edit the settings as required, and then select OK to apply the changes.

Deleting ADOMs

To delete an ADOM, you must be logged in as a super-user administrator (see Administrator profiles on page 358), such
as the admin administrator.

Prior to deleting an ADOM:

« All devices must be removed from the ADOM. Devices can be moved to another ADOM, or to the root ADOM. See
Assigning devices to an ADOM on page 303.
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To delete an ADOM:

Go to System Settings > All ADOMs.

Ensure that the ADOM or ADOMs being deleted have no devices in them.
Select the ADOM or ADOMSs you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation box to delete the ADOM or ADOMs.

If there are users or policy packages referring to the ADOM, they are displayed in the ADOM References Detected
dialog. Click Delete Anyway to delete the ADOM or ADOMs. The references to the ADOMs are also deleted.

o gk wbh-=

\,
S r'd
? Default ADOMs cannot be deleted.

Certificates

The FortiAnalyzer generates a certificate request based on the information you entered to identify the FortiAnalyzer unit.

After you generate a certificate request, you can download the request to a management computer and then forward the
request to a CA.

Local certificates are issued for a specific server, or website. Generally they are very specific, and often for an internal
enterprise network.

CA root certificates are similar to local certificates, however they apply to a broader range of addresses or to an entire
company.

The CRL is a list of certificates that have been revoked and are no longer usable. This list includes expired, stolen, or
otherwise compromised certificates. If your certificate is on this list, it will not be accepted. CRLs are maintained by the
CA that issues the certificates and include the date and time when the next CRL will be issued, as well as a sequence
number to help ensure you have the most current versions.

Local certificates

The FortiAnalyzer unit generates a certificate request based on the information you enter to identify the FortiAnalyzer

unit. After you generate a certificate request, you can download the request to a computer that has management access
to the FortiAnalyzer unit and then forward the request to a CA.

The certificate window also enables you to export certificates for authentication, importing, and viewing.
The FortiAnalyzer has one default local certificate: Fortinet_Local.

You can manage local certificates from the System Settings > Certificates > Local Certificates page. Some options are
available in the toolbar and some are also available in the right-click menu.

vy
‘?' In order to safeguard against compromise, in FortiAnalyzer 7.2.2, FAZ-VM license files contain
- a unique certificate which is tied to the device's serial number.
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Creating a local certificate

To create a certificate request:

1. Go to System Settings > Certificates > Local Certificates.
2. Click Create New in the toolbar. The Generate Certificate Signing Request pane opens.
3. Enter the following information as required, then click OK to save the certificate request:

Certificate Name The name of the certificate.

Subject Information Select the ID type from the dropdown list:

* Host IP: Select if the unit has a static IP address. Enter the public IP
address of the unit in the Host IP field.

e Domain Name: Select if the unit has a dynamic IP address and
subscribes to a dynamic DNS service. Enter the domain name of the unit
in the Domain Name field.

e Email: Select to use an email address. Enter the email address in the
Email Address field.

Optional Information

Organization Unit
(ov)

Organization (O)
Locality (L)

State/Province
(ST)

Country (C)

E-mail Address
(EA)

Subject
Alternative Name

The name of the department. You can enter a series of OUs up to a maximum
of 5. To add or remove an OU, use the plus (+) or minus (-) icons.

Legal name of the company or organization.
Name of the city or town where the device is installed.

Name of the state or province where the FortiGate unit is installed.

Select the country where the unit is installed from the dropdown list.

Contact email address.

Optionally, enter one or more alternative names for which the certificate is also
valid. Separate names with a comma.

A name can be:

* e-mail address

* |P address

* URI

¢ DNS name (alternatives to the Common Name)

« directory name (alternatives to the Distinguished Name)
You must precede the name with the name type. Examples:

e IP:1.1.1.1

» email:test@fortinet.com

¢ email:my@other.address

* URL:http://my.url.here/

Key Type The key type can be RSA or Elliptic Curve.
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Key Size

Curve Name

Enroliment Method

Importing local certificates

To import a local certificate:

Select the key size from the dropdown list: 5712 Bit, 1024 Bit, 1536 Bit, or 2048
Bit. This option is only available when the key type is RSA.

Select the curve name from the dropdown list: secp256r1 (default),
secp384r1, or secp521ri1. This option is only available when the key type is
Elliptic Curve.

The enrollment method is set to File Based.

1. Go to System Settings > Certificates > Local Certificates.
2. Click Importin the toolbar or right-click and select Import. The Import dialog box opens.
3. Enter the following information as required, then click OK to import the local certificate:

Type
Certificate File

Key File

Password

Certificate Name

Deleting local certificates

Select the certificate type from the dropdown list: Local Certificate, PKCS #12
Certificate, or Certificate.

Click Browse... and locate the certificate file on the management computer, or
drag and drop the file onto the dialog box.

Click Browse... and locate the key file on the management computer, or drag
and drop the file onto the dialog box.

This option is only available when Type is Certificate.

Enter the certificate password.
This option is only available when Type is PKCS #12 Certificate or Certificate.

Enter the certificate name.
This option is only available when Type is PKCS #12 Certificate or Certificate.

To delete a local certificate or certificates:

o bd-=

Go to System Settings > Certificates > Local Cetrtificates.

Select the certificate or certificates you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected certificate or certificates.

Viewing details of local certificates

To view details of a local certificate:

1. Go to System Settings > Certificates > Local Certificates.

2. Select the certificates that you would like to see details about, then click View Certificate Detail in the toolbar or
right-click menu. The View Local Ceritificate page opens.
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View Local Certificate

Certificate Name ~ Fortinet_Local

Issuer €= US, ST = California, L = Sunnyvale, O = Fortinet, OU = Certificate Authority, CN = support, emailAddress = support@fortinet.com
Subject €= Us, ST = California, L = Sunnyvale, O = Fortinet, OU = FortiManager, CN = FMG-VM0000000000, emailAddress = support@fortinet.com
Valid From 2011-11-08 23:12:50 GMT

Valid To 2038-81-89 03:14:07 GMT

Version 3

Serial Number TLiead7

Extension Name: X509v3 Basic Constraints
Critical: no
Content:
CAFALSE

3. Click OKto return to the local certificates list.

Downloading local certificates

To download a local certificate:

1.
2,
3.

Go to System Settings > Certificates > Local Certificates.
Select the certificate that you need to download.

Click Download in the toolbar, or right-click and select Download, and save the certificate to the management
computer.

S ! ’, When an object is added to a policy package and assigned to an ADOM, the object is available
? in all devices that are part of the ADOM. If the object is renamed on a device locally,
- FortiManager automatically syncs the renamed object to the ADOM.

CA certificates

The FortiAnalyzer has one default CA certificate, Fortinet_CA. In this sub-menu you can delete, import, view, and
download certificates.

Importing CA certificates

To import a CA certificate:

1.
2,
3.

Go to System Settings > Cettificates > CA Certificates.
Click Import in the toolbar, or right-click and select Import. The Import dialog box opens.

Click Browse... and locate the certificate file on the management computer, or drag and drop the file onto the dialog
box.

Click OK to import the certificate.

Viewing CA certificate details

To view a CA certificate's details:

1.
2,
3.

Go to System Settings > Certificates > CA Certificates.
Select the certificates you need to see details about.
Click View Certificate Detail in the toolbar, or right-click and select View Certificate Detail. The View CA Certificate
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page opens.
4. Click OKto return to the CA certificates list.

Downloading CA certificates

To download a CA certificate:

1. Goto System Settings > Certificates > CA Certificates.
2. Select the certificate you need to download.

3. Click Download in the toolbar, or right-click and select Download, and save the certificate to the management
computer.

Deleting CA certificates

To delete a CA certificate or certificates:

Go to System Settings > Certificates > CA Certificates.

Select the certificate or certificates you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected certificate or certificates.

o bd-=

Al
S L4
? The Fortinet_CA certificate cannot be deleted.

Certificate revocation lists

When you apply for a signed personal or group certificate to install on remote clients, you can obtain the corresponding
root certificate and Certificate Revocation List (CRL) from the issuing CA.

The CRL is a list of certificates that have been revoked and are no longer usable. This list includes expired, stolen, or
otherwise compromised certificates. If your certificate is on this list, it will not be accepted. CRLs are maintained by the
CA that issues the certificates and includes the date and time when the next CRL will be issued as well as a sequence
number to help ensure you have the most current version of the CRL.

When you receive the signed personal or group certificate, install the signed certificate on the remote client(s) according
to the browser documentation. Install the corresponding root certificate (and CRL) from the issuing CA on the
FortiAnalyzer unit according to the procedures given below.

Importing a CRL

To import a CRL:

Go to System Settings > Certificates > CRL.
Click Importin the toolbar, or right-click and select Import. The Import dialog box opens.

Click Browse... and locate the CRL file on the management computer, or drag and drop the file onto the dialog box.
Click OK to import the CRL.

o bd-=

FortiAnalyzer 7.2.2 Administration Guide 309
Fortinet Inc.



System Settings

Viewing a CRL

To view a CRL:

Go to System Settings > Certificates > CRL.
Select the CRL you need to see details about.

Click View Certificate Detail in the toolbar, or right-click and select View Certificate Detail. The Result page opens.
Click OK to return to the CRL list.

o bd-=

Deleting a CRL

To delete a CRL or CRLs:

Go to System Settings > Certificates > CRL.

Select the CRL or CRLs you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected CRL or CRLs.

o bd-=

Log Forwarding

You can forward logs from a FortiAnalyzer unit to another FortiAnalyzer unit, a syslog server, or a Common Event
Format (CEF) server when you use the default forwarding mode in log forwarding.

The client is the FortiAnalyzer unit that forwards logs to another device. The server is the FortiAnalyzer unit, syslog
server, or CEF server that receives the logs.

In addition to forwarding logs to another unit or server, the client retains a local copy of the logs. The local copy of the
logs is subject to the data policy settings for archived logs. See Log storage on page 33 for more information.

involved, go to System Settings > Logging Topology. For more information, see Logging
Topology on page 285.

\ﬂ To see a graphical view of the log forwarding configuration, and to see details of the devices

Modes

FortiAnalyzer supports two log forwarding modes: forwarding (default), and aggregation.

Forwarding

Logs are forwarded in real-time or near real-time as they are received. Forwarded content files include: DLP files,
antivirus quarantine files, and IPS packet captures.

This mode can be configured in both the GUI and CLI.
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Aggregation
As FortiAnalyzer receives logs from devices, it stores them, and then forwards the collected logs at a specified time
every day. To avoid duplication, the client only sends logs that are not already on the server.

FortiAnalyzer supports log forwarding in aggregation mode only between two FortiAnalyzer units. Syslog and CEF
servers are not supported.

Al
‘Q' The client must provide super user log in credentials to get authenticated by the server to

aggregate logs.

Aggregation mode can only be configured with the 1og-forward and log-forward-service CLI commands. See
the FortiAnalyzer CLI Reference for more information.

The following table lists the differences between the two modes:

Log Forwarding Log Aggregation

Configuration Portal GUl or CLI CLI
Remote Server Type FortiAnalyzer FortiAnalyzer
Syslog/CEF
Device Filter Support Yes Yes
Log Filter Support Yes No
Log Archive Support Yes Yes
Server Port customization Yes (Except for FortiAnalyzer) No
Compression Yes (FortiAnalyzer only) No
Log Field Exclusion Yes No
Log Delay Real-time (max 5 minutes delay) Max 1 day
Log Data Masking Yes No
Meta-data synchronization Yes No
Secure channel support Yes (SSL as reliable connection) Yes (rsync + SSH)
Network bandwidth Normal (as log traffic received) Peak hour as aggregation starts to
finish
Impact on remote Normal (as log volume received) Potentially large table
FortiAnalyzer (If there is a mix of incoming real-time

and real-time logs.)

Configuring log forwarding

Forwarding mode only requires configuration on the client side. No configuration is needed on the server side. In
aggregation mode, accepting the logs must be enabled on the FortiAnalyzer that is acting as the server.
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Forwarding mode
Forwarding mode can be configured in the GUI. No configuration is required on the server side.

To configure the client:

1. Go to System Settings > Log Forwarding.
2. Click Create New in the toolbar. The Create New Log Forwarding pane opens.

Create New Log Forwarding

x

Name

Please input name.

Status ©
Remote Server Type FortiAnalyzer
Server FQDN/IP FQDN/IP
Compression fe )

Reliable Connection fe ]

Sending Frequency Real-time Every 1 Minute Every 5 Minutes

Log Forwarding Filters
Device Filters Select Device
Log Filters

Enable Exclusions

CRCN®)

Enable Masking

3. Fillin the information as per the below table, then click OK to create the new log forwarding. The FortiAnalyzer
device will start forwarding logs to the server.

Name
Status

Remote Server Type

Server FQDN/IP

Server Port

Compression

Reliable Connection

Sending Frequency

FortiAnalyzer 7.2.2 Administration Guide
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Enter a name for the remote server.
Set to On to enable log forwarding. Set to Offto disable log forwarding.

Select the type of remote server to which you are forwarding logs:
FortiAnalyzer, Syslog, Syslog Pack, or Common Event Format (CEF). The
Syslog option can be used to forward logs to FortiSIEM and FortiSOAR.

Enter the fully qualified domain name or IP for the remote server.

Enter the server port number. Default: 514.

This option is only available when the server type is Syslog, Syslog Pack, or
Common Event Format (CEF).

Turn on to enable log message compression when the remote FortiAnalyzer
also supports this format. If the remote FortiAnalyzer does not support
compression, log messages will remain uncompressed.

This option is only available when the server type is FortiAnalyzer.

Turn on to use TCP connection. Turn off to use UDP connection.

If you want to forward logs to a Syslog or CEF server, ensure this option is
supported. RELP is not supported.

If the connection goes down, logs are buffered and automatically forwarded
when the connection is restored. The buffer limitis 12GB.

Select when logs will be sent to the server: Real-time, Every 1 Minute, or
Every 5 Minutes (default).

312



System Settings

This option is only available when the server type is FortiAnalyzer.
Log Forwarding Filters
Device Filters Click Select Device, then select the devices whose logs will be forwarded.

Log Filters Turn on to configure filter on the logs that are forwarded.

Select All or Any of the Following Conditions in the Log messages that match
field to control how the filters are applied to the logs.

Add filters to the table by selecting the Log Field, Match Criteria, and Value for
each filter.

Enable Exclusions Turn on to configure filter on the logs that are forwarded.

Add exclusions to the table by selecting the Device Type and Log Type. Then,
add Log Fields to the Exclusion List by clicking Fields and specifying the
excluded log fields in the Select Log Field pane.

Enable Masking Turn on to enable log field masking.

In the Masking Data Fields, select any data fields that should be masked
during log forwarding. The remote server will receive logs with the selected
field values masked. Configure a Data Mask Key.

Al
‘Q' Devices whose logs are being forwarded to another FortiAnalyzer device are added to the
- server as unauthorized devices. To authorize devices, see Authorizing devices on page 43.

Aggregation mode

Aggregation mode can only be configured using the CLI. Aggregation mode configurations are not listed in the GUI table,
but still use a log forwarding ID number.

Ay
‘?' Use the following CLI command to see what log forwarding IDs have been used:
get system log-forward

To configure the server:

1. Ifrequired, create a new administrator with the Super_User profile. See Creating administrators on page 351.

2. Enable log aggregation and, if necessary, configure the disk quota, with the following CLI commands:
config system log-forward-service
set accept-aggregation enable
set aggregation-disk-quota <quota>
end

To configure the client:

1. Open the log forwarding command shell:
config system log-forward
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2. Create a new, or edit an existing, log forwarding entry:
edit <log forwarding ID>
3. Setthe log forwarding mode to aggregation:
set mode aggregation
4. Setthe server display name and IP address:
set server—-name <string>
set server-ip <XXX.XXX.XXX.XXX>
5. Enter the user name and password of the super user administrator on the server:
set agg-user <string>
set agg-password <string>

6. Ifrequired, set the aggregation time from 0 to 23 hours (default: 0, or midnight):
set agg-time <integer>

7. Enter the following to apply the configuration and create the log aggregation:
end

The following line will be displayed to confirm the creation of the log aggregation:

check for cfg[<log forwarding ID>] svr disp name=<server-name>

Al
S L4
? For more information, see the FortiAnalyzer CLI Reference.

Managing log forwarding

Log forwarding mode server entries can be edited and deleted using both the GUI and the CLI. Aggregation mode server
entries can only be managed using the CLI. Entries cannot be enabled or disabled using the CLI.

To enable or disable a log forwarding server entry:

1. Go to System Settings > Log Forwarding.

2. Double-click on a server entry, right-click on a server entry and select Edit, or select a server entry then click Edit in
the toolbar. The Edit Log Forwarding pane opens.

3. Setthe Statusto Off to disable the log forwarding server entry, or set it to On to enable the server entry.
Only the name of the server entry can be edited when it is disabled.

4. Click OKto apply your changes.

To edit a log forwarding server entry using the GUI:

1. Goto System Settings > Log Forwarding.

2. Double-click on a server entry, right-click on a server entry and select Edit, or select a server entry then click Edit in
the toolbar. The Edit Log Forwarding pane opens.

3. Edit the settings as required, then click OK to apply your changes.

To edit a log forwarding server entry using the CLI:

1. Open the log forwarding command shell:
config system log-forward

2. Enter an existing entry using its log forwarding ID:
edit <log forwarding ID>
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3. Editthe settings as required. See the FortiAnalyzer CLI Reference for information.

4. Enter the following command to apply your changes:
end

To delete a log forwarding server entry or entries using the GUI:

Go to System Settings > Log Forwarding.

Select the entry or entries you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected entry or entries.

Ao b=

To delete a log forwarding server entry using the CLI:

1. Open the log forwarding command shell:
config system log-forward

2. Delete an entry using its log forwarding ID:
delete <log forwarding ID>
The log forwarding server entry is immediately deleted. There is no confirmation.

To delete all log forwarding entries using the CLI:

1. Enter the following CLI command:
config system log-forward
purge
2. Enter y to delete all the entries.
This operation will clear all table!
Do you want to continue? (y/n)y

Log forwarding buffer

When log forwarding is configured, FortiAnalyzer reserves space on the system disk as a buffer between the fortilogd
and logfwd daemons. In the event of a connection failure between the log forwarding client and server (network jams,
dropped connections, etc.), logs are cached as long as space remains available. When storage space is exceeded, older
logs are deleted in favor of new logs.

The default log forward buffer size is 30% of the system reserved disk size, and can be increased to use up to 80% of the
available reserved disk. Additional storage space is available by using the disk space reserved for ADOMs. When
configuring the log forward buffer size above 80% of the reserved disk size, the space available for ADOMs is reduced.

For example, in a scenario where the FortiAnalyzer has a total disk size of 275 GB for the entire system, with a system
reserved disk size of 50 GB and an ADOM disk space of 50 GB, the log forwarding buffer can be configured up to a
maximum of 90 GB (80% of the 50 GB reserved disk size = 40 GB + 50 GB disk reserved for ADOMs = 90 GB total).

The size of the system reserved disk varies by platform and total available storage. See Disk space allocation on page

104.
The log forward buffer is shared between fortilogd for all logfwd servers.
When changes are made to the log forward cache size, each server individually resets the log
reading position to the latest one, and all logs currently in the log-forward disk cache are
dropped.
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To change the log forward cache size:

1. Inthe FortiAnalyzer CLlI, enter the following commands:
config system global (global)#
set log-forward-cache-size [number (GB)]
2. When prompted, enter Y to confirm the change.
« When entering a number outside of the valid cache size range, an error with the valid range is displayed.

« When entering a number that uses storage from both the reserved disk size and available ADOM disk, a
message displays to indicate that the cache will be allocated from the available disk quota and reserved space.
(global)# set log-forward-cache-size 50

Log-forward disk cache will be allocated from available disk quota and reserved
space.

All logs currently in log-forward disk cache will be dropped.
Do you want to continue? (y/n)

) ! ’, The diagnose test application logfwd 3 CLIcommand can be used to display log
? positions for the last log buffered and last log sent, as well as determine the buffer lag-behind.
3 See the FortiAnalyzer CLI Reference.

Fetcher Management

Log fetching is used to retrieve archived logs from one FortiAnalyzer device to another. This allows administrators to run
queries and reports against historic data, which can be useful for forensic analysis.

The fetching FortiAnalyzer can query the server FortiAnalyzer and retrieve the log data for a specified device and time
period, based on specified filters. The retrieved data are then indexed, and can be used for data analysis and reports.

Log fetching can only be done on two FortiAnalyzer devices running the same firmware. A FortiAnalyzer device can be
either the fetch server or the fetching client, and it can perform both roles at the same time with different FortiAnalyzer
devices. Only one log fetching session can be established at a time between two FortiAnalyzer devices.

The basic steps for fetching logs are:

1. Onthe client, create a fetching profile. See Fetching profiles on page 316.
2. Onthe client, send the fetch request to the server. See Fetch requests on page 317.

3. Ifthisis the first time fetching logs with the selected profile, or if any changes have been made to the devices and/or
ADOMs since the last fetch, on the client, sync devices and ADOMSs with the server. See Synchronizing devices and
ADOMs on page 319.

4. Onthe server, review the request, then either approve or reject it. See Request processing on page 319.
Monitor the fetch process on either FortiAnalyzer. See Fetch monitoring on page 320.
6. On the client, wait until the database is rebuilt before using the fetched data for analysis.

o

Fetching profiles

Fetching profiles can be managed from the Profiles tab on the System Settings > Fetcher Management pane.

Profiles can be created, edited, and deleted as required. The profile list shows the name of the profile, as well as the IP
address of the server it fetches from, the server and local ADOMs, and the administrator name on the fetch server.
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To create a new fetching profile:

1. Onthe client, go to System Settings > Fetcher Management.

2. Select the Profiles tab, then click Create New in the toolbar, or right-click and select Create New from the menu. The
Create New Profile dialog box opens.

Create New Profile

Name
Server IP
User

Password At

3. Configure the following settings, then click OK to create the profile.

Name Enter a name for the profile.
Server IP Enter the IP address of the fetch server.
User Enter the username of an administrator on the fetch server, which, together

with the password, authenticates the fetch client's access to the fetch server.

Password Enter the administrator's password, which, together with the username,
authenticates the fetch client's access to the fetch server.

Al
‘Q' The fetch server administrator user name and password must be for an administrator with
- either a Standard_User or Super_User profile.

To edit a fetching profile:

1. Go to System Settings > Fetching Management.

2. Double-click on a profile, right-click on a profile then select Edit, or select a profile then click Edit in the toolbar. The
Edit Profile pane opens.

3. Editthe settings as required, then click OK to apply your changes.

To delete a fetching profile or profiles:

Go to System Settings > Fetching Management.

Select the profile or profiles you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected profile or profiles.

P obh-=

Fetch requests

A fetch request requests archived logs from the fetch server configured in the selected fetch profile. When making the
request, the ADOM on the fetch server the logs are fetched from must be specified. An ADOM on the fetching client must
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be specified or, if needed, a new one can be created. If logs are being fetched to an existing local ADOM, you must
ensure the ADOM has enough disk space for the incoming logs.

The data policy for the local ADOM on the client must also support fetching logs from the specified time period. It must
keep both archive and analytics logs long enough so they will not be deleted in accordance with the policy. For example:
Today is July 1, the ADOM's data policy is configured to keep analytics logs for 30 days (June 1 - 30), and you need to
fetch logs from the first week of May. The data policy of the ADOM must be adjusted to keep analytics and archive logs
for at least 62 days to cover the entire time span. Otherwise, the fetched logs will be automatically deleted after they are

fetched.

To send a fetch request:

1. On the fetch client, go to System Settings > Fetcher Management and select the Profiles tab

2. Select the profile then click Request Fetch in the toolbar, or right-click and select Request Fetch from the menu. The
Fetch Logs dialog box opens.

Fetch Logs

Name
Server IP
User

Secure Connection
Server ADOM
Local ADOM

Devices

Enable Filters

Time Period

Index Fetched Logs

FAZVMé&4
222222222222

admino

root
root

FortiGate-VM64

| 2017/01/30 B »
| 2017/02/04 B »

)
Select Device ==

3. Configure the following settings, then click Request Fetch.
The request is sent to the fetch server. The status of the request can be viewed in the Sessions tab.

Name
Server IP

User

Secure Connection

Server ADOM

Local ADOM

Devices
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Displays the name of the fetch server you have specified.
Displays the IP address of the server you have specified.
Displays the username of the server administrator you have provided.
Select to use SSL connection to transfer fetched logs from the server.

Select the ADOM on the server the logs will be fetched from. Only one ADOM
can be fetched from at a time.

Select the ADOM on the client where the logs will be received.

Either select an existing ADOM from the dropdown list, or create a new ADOM
by entering a name for it into the field.

Add the devices and/or VDOMs that the logs will be fetched from. Up to 256
devices can be added.
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Click Select Device, select devices from the list, then click OK.

Enable Filters Select to enable filters on the logs that will be fetched.

Select All or Any of the Following Conditions in the Log messages that match
field to control how the filters are applied to the logs.

Add filters to the table by selecting the Log Field, Match Criteria, and Value for

each filter.
Time Period Specify what date and time range of log messages to fetch.
Index Fetch Logs If selected, the fetched logs will be indexed in the SQL database of the client

once they are received. Select this option unless you want to manually index
the fetched logs.

Synchronizing devices and ADOMs

If this is the first time the fetching client is fetching logs from the device, or if any changes have been made the devices or
ADOMs since the last fetch, then the devices and ADOMs must be synchronized with the server.

To synchronize devices and ADOMs:

1. Onthe client, go to System Settings > Fetcher Management and select the Profiles tab

2. Select the profile then click Sync Devices in the toolbar, or right-click and select Sync Devices from the menu. The
Sync Server ADOM(s) & Device(s) dialog box opens and shows the progress of the process.
Once the synchronization is complete, you can verify the changes on the client. For example, newly added devices
in the ADOM specified by the profile.

NP If anew ADOM is created, the new ADOM will mirror the disk space and data policy of the
‘Q' corresponding server ADOM. If there is not enough space on the client, the client will create an
- ADOM with the maximum allowed disk space and give a warning message. You can then

adjust disk space allocation as required.

Request processing

After a fetching client has made a fetch request, the request will be listed on the fetch server in the Received Request
section of the Sessions tab on the Fetcher Management pane. It will also be available from the notification center in the
GUI banner.

Fetch requests can be approved or rejected.

To process the fetch request:

1. Go to the notification center in the GUI banner and click the log fetcher request, or go to the Sessions tab on the
System Settings > Fetcher Management pane.

" Expand All # Collapse All

Request Time Host/Server IP User Status Action
v Received Request(1)
15:01:55 FAZVMG64(FAZ-VM0O000000001)  admino €% Waiting for appraval :]

) Fetch Request(1)
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2. Find the request in the Received Request section. You may have to expand the section, or select Expand All in the
content pane toolbar. The status of the request will be Waiting for approval.

3. Click Review to review the request. The Review Request dialog box will open.

Review Request

Host Name
Serial No.
Version
User

Devices

Filters
Time Period

Secure Connection

FAZVM64
FAZ-VM0000000000
v5.6.0
Agg
ADOM
root FGVMEV0000000000

Device

Nane

16:02 2016/01/30 - 16:02 2017/02/02

o |

VDOM

4. Click Approve to approve the request, or click Reject to reject the request.
If you approve the request, the server will start to retrieve the requested logs in the background and send them to
the client. If you reject the request, the request will be canceled and the request status will be listed as Rejected on
both the client and the server.

Fetch monitoring

The progress of an approved fetch request can be monitored on both the fetching client and the fetch server.

Go to System Settings > Fetcher Management and select the Sessions tab to monitor the fetch progress. A fetch session
can be paused by clicking Pause, and resumed by clicking Resume. It can also be canceled by clicking Cancel.

Once the log fetching is completed, the status changes to Done and the request record can be deleted by clicking
Delete. The client will start to index the logs into the database.

It can take a long time for the client to finish indexing the fetched logs and make the analyzed
data available. A progress bar is shown in the GUI banner; for more information, click on it to
open the Rebuild Log Database dialog box.

Log and report features will not be fully available until the rebuilding process is complete.

You may need to rebuild the ADOM after the transfer is complete depending on the Log Fetch settings.

To perform post fetch actions:

Is Index Fetched Yes

Logs enabled in the

Log Fetch settings? NO
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The ADOM is rebuilt automatically and the log fetch workflow is complete.

You will need to rebuild ADOM manually from the CLI.
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Event Log

The Event Log pane provides an audit log of actions made by users on FortiAnalyzer. It allows you to view log messages

that are stored in memory or on the internal hard disk drive. You can use filters to search the messages and download
the messages to the management computer.

See the FortiAnalyzer Log Message Reference, available from the Fortinet Document Library, for more information

about the log

messages.

Go to System Settings > Event Log to view the local log list.

© Last1 Hour~ |12:00:49 To 13:00:48

Add Filter

o Q )

'V Date/Time
13:00:06
12:55:58
12:49:03
12:47:58
12:46:55
12:46:55

[N N R SR Y

Device ID

FAZVMSTM20000426
FAZVMSTM20000426
FAZVMSTM20000426
FAZVMSTM20000426
FAZVMSTM20000426
FAZVMSTM20000426

Sub Type
system
logdev
logdev
fazsys
fazsys

fazsys

The following options are available:

User Message Performed On

GUI(10.100.55.25...

Operation Changes

User* ‘with profile 'Sup... login 'lwoodward' login ..

system Failed to import CSF group in root ...
system Failed to import CSF group in root ...

system Device authorizati... Failed to authorize.
Update webfilter ..

Update link prefix...

Device Enterprise_Core authoriza...

system fazcfgd update webfilter categorie... Update metadata

system fazcfgd update link prefixes file: st... Update metadata

Last... Select the amount of time to show from the available options, or select a custom
time span or any time.
Add Filter Filter the event log list based on the log level, user, sub type, or message. See

Column Settings

Event log filtering on page 322.

Select which columns are enabled or disabled in the Event Log table.

Tools
Display Raw / Click on Display Raw to view the logs in their raw state.
Formatted Log Click Formatted Log to view logs formatted into a table.
Real-time Log / Click to view the real-time or historical logs list.
Historical Log
Download Download the event logs in either CSV or the normal format to the management
computer.
Case Sensitive Enable or disable case sensitive searching.
Search
Pagination Browse the pages of logs and adjust the number of logs that are shown per page.

The following information is shown:

# The log number.

Date/Time The date and time that the log file was generated.

Device ID The ID of the related device.

Level The severity level of the message. For a description of severity levels, see the Log
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User

Sub Type

Description
Operation

Performed On

Changes

Message

Event log filtering

The user that the log message relates to.

The event log subtype. For a description of the subtypes for event logs, see the
Log Message Reference.

A description of the event.
The change or operation that triggered the event.

Entity affected by the change or operation. For example, when you log out of the
FortiAnalyzer GUI, the operation is performed on the local FortiAnalyzer GUI.

Details of the change.

Log message details. A Session ID is added to each log message. The username
of the administrator is added to log messages wherever applicable for better
traceability.

The event log can be filtered using the Add Filter box in the toolbar.

To filter event log results using the toolbar:

1. Specify filters in the Add Filter box.
» Filter mode: Click in the Add Filter box, select a filter from the dropdown list, then type a value.
« Text Mode: Click the Switch to Text Mode icon at the right end of the Add Filter box to switch to text mode. In
this mode, you can type in the whole search criteria.
Click the Switch to Filter Mode icon to return to filter mode.
Additional search operators such as "And", "Or", and "Not" can be used in event log filtering. Click the help icon
next to the filter bar in the GUI for additional information.

2. Click Goto apply the filter.

Task Monitor

Use the task monitor to view the status of the tasks you have performed.

Go to System Settings > Task Monitor to view the task monitor. The task list size can also be configured; see Advanced

Settings on page 343.

To filter the information in the monitor, enter a text string in the search field.
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+ Group Error Devices i Delete

© View Task Detail 8 Show Status ~

15 Column Settings ~

1o} Source

000 O0OO0OODOO0OODOODOOODBO

nstall Configuration
Install Package
Firmware Manager
Device Manager
Device Manager
Device Manager

Device Manager

Install Configuratior
Device Manager
Device Manager
Device Manager
Device Manager
nstall Configuration

Install Package

Description

Push config to device.
Install Package 'default
Device Image Upgrade

Add/delete Unauthorized Devices

pm devprof adom root default scops

Add Device

Delete Device

Push config to device.

Add/delete Unauthorized Devices
Add Device

Add/delete Unauthorized Devices
Delete Device

Push config to device.

Install Package 'default’

The following options are available:

Group Error Devices

Delete

View Task Detail

Show Status

Column Settings

User Status Time Used ADOM Start Time End Time
O admin (80%) 14s root Tue Jan 28 2020 3:16:40 PM N/A
O admin Success: 1 2s root Tue Jan 28 2020 3:16:37 PM Tue Jan 28 2020 3:16:39 PM
Osd’nm Success: 1 4m 1s root Tue Jan 28 2020 3:12:31 PM Tue Jan 28 2020 3:16:32 PM
O Auto link (50%) 4m 40s root Tue Jan 28 2020 3:12:14 PM N/A

e member Osd'm’v Success: 1 4s root Tue Jan 28 2020 3:10:59 PM Tue Jan 28 2020 3:11:03 PM
Osdmm Success: 1 bs root Tue Jan 28 2020 3:10:52 PM Tue Jan 28 2020 3:10:58 PM
Oed’nm Success: 1 3s root Tue Jan 28 2020 3:10:12 PM Tue Jan 28 2020 3:10:15 PM
O admin Success: 1 22s root Tue Jan 28 2020 2:55:17 PM Tue Jan 28 2020 2:55:39 PM
OA,\to link Success: 1 43s root Tue Jan 28 2020 2:54:56 PM Tue Jan 28 2020 2:55:39 PM
O admin Success: 1 5s root Tue Jan 28 2020 2:54:18 PM Tue Jan 28 2020 2:54:23 PM
Osd’nm Success: 1 2s root Tue Jan 28 2020 2:54:02 PM Tue Jan 28 2020 2:54:04 PM
0 admin Success: 1 3s root Tue Jan 28 2020 2:49:23 PM Tue Jan 28 2020 2:49:26 PM
Osd'm'\ QError: 1 32s root Tue Jan 28 2020 2:46:09 PM Tue Jan 28 2020 2:46:41 PM
O admin Success: 1 2s root Tue Jan 28 2020 2:46:06 PM Tue Jan 28 2020 2:46:08 PM

Create a group of the failed devices, allowing for re-installations to be done only
on the failed devices.

Remove the selected task or tasks from the list.
This changes to Cancel Running Task(s) when View is Running.

View the task Index, Name, Status, Time Used, and History, in a new window.

Click the icons in the History column to view the following information:

e History

¢ Promotion of device in FortiAnalyzer with autolink
» Upgrade remote device firmware

» Retrieve remote device configuration

« Installation of device templates

« Installation of policy packages

« Execution of additional scripts
To filter the information in the task details, enter a text string in the search field.
This can be useful when troubleshooting warnings and errors.

Select which tasks to view from the dropdown list, based on their status. The
available options are: All, Pending, Running, Canceling, Canceled , Done, Error,
Aborting, Aborted, and Warning.

Select the columns you want to display from the dropdown.

The following information is available:

ID
Source

Description

User

FortiAnalyzer 7.2.2 Administration Guide
Fortinet Inc.

The identification number for a task.
The platform from where the task is performed.

The nature of the task. Double-click the task to display the specific actions taken
under this task.

The user or users who performed the tasks.
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Status The status of the task:
e Success: Completed with success.
e Error: Completed without success.
* Canceled: User canceled the task.
e Canceling: User is canceling the task.
e Aborted: The FortiAnalyzer system stopped performing this task.
e Aborting: The FortiAnalyzer system is stopping performing this task.

e Running: Being processed. In this status, a percentage bar appears in the
Status column.

e Pending
e Warning
Time Used The number of seconds to complete the task.
ADOM The ADOM associated with the task.
Start Time The time that the task was started.
End Time The time that the task was completed.

SNMP

Enable the SNMP agent on the FortiAnalyzer device so it can send traps to and receive queries from the computer that is
designated as its SNMP manager. This allows for monitoring the FortiAnalyzer with an SNMP manager.

SNMP has two parts - the SNMP agent that is sending traps, and the SNMP manager that monitors those traps. The
SNMP communities on monitored FortiGate devices are hard coded and configured by the FortiAnalyzer system - they
are not user configurable.

The FortiAnalyzer SNMP implementation is read-only — SNMP v1, v2c, and v3 compliant SNMP manager applications,
such as those on your local computer, have read-only access to FortiAnalyzer system information and can receive
FortiAnalyzer system traps.

SNMP agent

The SNMP agent sends SNMP traps originating on the FortiAnalyzer system to an external monitoring SNMP manager
defined in a SNMP community. Typically an SNMP manager is an application on a local computer that can read the
SNMP traps and generate reports or graphs from them.

The SNMP manager can monitor the FortiAnalyzer system to determine if it is operating properly, or if there are any
critical events occurring. The description, location, and contact information for this FortiAnalyzer system will be part of
the information an SNMP manager will have — this information is useful if the SNMP manager is monitoring many
devices, and it will enable faster responses when the FortiAnalyzer system requires attention.
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Go to System Settings > Advanced > SNMP to configure the SNMP agent.

SNMP
SNMP Agent Enable
Description

Location

Contact

SNMP viA2c

4 Create New [# Edit [l Delete
[] 4 CommunityName Queries

SNMP v3

4 Create New [# Edit [l Delete
A User Name Security Level
Bliss

Daneel

Fallom

ooooog

Golan

Traps Enable

Notification Hosts Queries

The following information and options are available:

SNMP Agent

Description

Location

Contact

SNMP v1/2¢c

Create New

Edit
Delete

Community Name

Select to enable the SNMP agent. When this is enabled, it sends FortiAnalyzer
SNMP traps.

Optionally, type a description of this FortiAnalyzer system to help uniquely identify
this unit.

Optionally, type the location of this FortiAnalyzer system to help find it in the event
it requires attention.

Optionally, type the contact information for the person in charge of this
FortiAnalyzer system.

The list of SNMP v1/v2c communities added to the FortiAnalyzer configuration.

Select Create New to add a new SNMP community. If SNMP agent is not
selected, this control will not be visible.

For more information, see SNMP v1/v2c communities on page 326.
Edit the selected SNMP community.
Delete the selected SNMP community or communities.

The name of the SNMP community.

Queries The status of SNMP queries for each SNMP community. The enabled icon
indicates that at least one query is enabled. The disabled icon indicates that all
queries are disabled.

Traps The status of SNMP traps for each SNMP community. The enabled icon indicates
that at least one trap is enabled. The disabled icon indicates that all traps are
disabled.

Enable Enable or disable the SNMP community.

SNMP v3 The list of SNMPv3 users added to the configuration.
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Create New Select Create New to add a new SNMP user. If SNMP agent is not selected, this
control will not be visible.

For more information, see SNMP v3 users on page 329.

Edit Edit the selected SNMP user.

Delete Delete the selected SNMP user or users.

User Name The user name for the SNMPv3 user.

Security Level The security level assigned to the SNMPv3 user.

Notification Hosts The notification host or hosts assigned to the SNMPv3 user.

Queries The status of SNMP queries for each SNMP user. The enabled icon indicates
queries are enabled. The disabled icon indicates they are disabled.

SNMP v1/v2c communities

An SNMP community is a grouping of equipment for network administration purposes. You must configure your
FortiAnalyzer to belong to at least one SNMP community so that community’s SNMP managers can query the
FortiAnalyzer system information and receive SNMP traps from it.

Al
‘Q' These SNMP communities do not refer to the FortiGate devices the FortiAnalyzer system is
- managing.

Each community can have a different configuration for SNMP traps and can be configured to monitor different events.
You can add the IP addresses of up to eight hosts to each community. Hosts can receive SNMP device traps and
information.
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To create a new SNMP community:

1. Go to System Settings > Advanced > SNMP and ensure the SNMP agent is enabled.
2. Inthe SNMP v1/v2c section, click Create New in the toolbar. The New SNMP Community pane opens.

New SNMP Community
Protocol Port
vi 161
v2c 161
Traps:
Protocol Port

vl 162

v2c 162

SNMP Event

nterface IP changed

Log Disk Space Low

CPU Overuse

Memory Low

System Restart

CPU usage exclude NICE threshold
HA Failover

RAID Event

Power Supply Failed

Fan Speed Out Of Range
Temperature Out Of Range

Voltage Out Of Range

Enable
-]
-]

Enable
-]
-]

Enable

oooooan

3. Configure the following options, then click OK to create the community.

Name

Hosts

IP
Address/Netmask

Interface

Delete

FortiAnalyzer 7.2.2 Administration Guide
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Enter a name to identify the SNMP community. This name cannot be edited
later.

The list of hosts that can use the settings in this SNMP community to monitor
the FortiAnalyzer system.

When you create a new SNMP community, there are no host entries. Select
Add to create a new entry that broadcasts the SNMP traps and information to
the network connected to the specified interface.

Enter the IP address and netmask of an SNMP manager.
By default, the IP address is 0.0.0.0 so that any SNMP manager can use this
SNMP community.

Select the interface that connects to the network where this SNMP manager
is located from the dropdown list. This must be done if the SNMP manager is
on the Internet or behind a router.

Click the delete icon to remove this SNMP manager entry.
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Add
Queries
Traps
SNMP Event

To edit an SNMP community:

Select to add another entry to the Hosts list. Up to eight SNMP manager
entries can be added for a single community.

Enter the port number (161 by default) the FortiAnalyzer system uses to send
v1 and v2c queries to the FortiAnalyzer in this community. Enable queries for
each SNMP version that the FortiAnalyzer system uses.

Enter the Remote port number (162 by default) the FortiAnalyzer system
uses to send v1 and v2c traps to the FortiAnalyzer in this community. Enable
traps for each SNMP version that the FortiAnalyzer system uses.

Enable the events that will cause SNMP traps to be sent to the community.
* Interface IP changed
e Log disk space low
* CPU Overuse
* Memory Low
» System Restart
e CPU usage exclude NICE threshold
e RAID Event (only available for devices that support RAID)
» Power Supply Failed (only available on supported hardware devices)
e Fan Speed Out of Range
e Temperature Out of Range
e Voltage Out of Range
* High licensed device quota
e High licensed log GB/day
* LogAlert
e Log Rate
» Data Rate
FortiAnalyzer feature set SNMP events:

1. Go to System Settings > Advanced > SNMP.

2. Inthe SNMP v1/v2c section, double-click on a community, right-click on a community then select Edit, or select a
community then click Edit in the toolbar. The Edit SNMP Community pane opens.

3. Editthe settings as required, then click OK to apply your changes.

To delete an SNMP community or communities:

Ao b=
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Go to System Settings > Advanced > SNMP.

In the SNMP v1/v2c section, select the community or communities you need to delete.
Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected community or communities.
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SNMP v3 users

The FortiAnalyzer SNMP v3 implementation includes support for queries, traps, authentication, and privacy. SNMP v3
users can be created, edited, and deleted as required.

To create a new SNMP user:

1. Go to System Settings > Advanced > SNMP and ensure the SNMP agent is enabled.
2. Inthe SNMP v3 section, click Create New in the toolbar. The New SNMP User pane opens.

New SNMP User
User Name

Security Level No Authentication, No Privacy

Queries Enable Port
Notification Hosts +
SNMP Event Enable
nterface IP changed
Log Disk Space Low
CPU Overuse
Memory Low
System Restart
CPU usage exclude NICE threshold
HA Failover
RAID Event
Power Supply Failed
Fan Speed Qut Of Range
Temperature Out Of Range

Voltage Out Of Range

3. Configure the following options, then click OK to create the community.

User Name The name of the SNMP v3 user.

Security Level The security level of the user. Select one of the following:
¢ No Authentication, No Privacy

¢ Authentication, No Privacy: Select the Authentication Algorithm (SHA1,
MD5) and enter the password.

¢ Authentication, Privacy: Select the Authentication Algorithm (SHA1,
MD5), the Private Algorithm (AES, DES), and enter the passwords.

Queries Select to enable queries then enter the port number. The default port is 161.
Notification Hosts The IP address or addresses of the host. Click the add icon to add multiple IP
addresses.
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SNMP Event Enable the events that will cause SNMP traps to be sent to the SNMP
manager.

¢ Interface IP changed
e Log disk space low
e CPU Overuse
e Memory Low
e System Restart
e CPU usage exclude NICE threshold
¢ RAID Event (only available for devices that support RAID)
e Power Supply Failed (only available on supported hardware devices)
¢ High licensed device quota
e High licensed log GB/day
e Log Alert
¢ Log Rate
e Data Rate
e Fan Speed Out of Range
e Temperature Out of Range
¢ Voltage Out of Range
FortiAnalyzer feature set SNMP events:

To edit an SNMP user:

1. Go to System Settings > Advanced > SNMP.

2. Inthe SNMP v3 section, double-click on a user, right-click on a user then select Edit, or select a user then click Edit
in the toolbar. The Edit SNMP User pane opens.

3. Editthe settings as required, then click OK to apply your changes.

To delete an SNMP user or users:

Go to System Settings > Advanced > SNMP.

In the SNMP v3 section, select the user or users you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OK in the confirmation dialog box to delete the selected user or users.

P obh-=

SNMP MIBs

The Fortinet and FortiAnalyzer MIBs, along with the two RFC MIBs, can be obtained from Customer Service & Support
(https://support.fortinet.com). You can download the FORTINET-FORTIMANAGER-FORTIANALYZER-MIB.mib MIB file
in the firmware image file folder. The FORTINET-CORE-MIB.mib file is located in the main FortiAnalyzer 5.00 file folder.

RFC support for SNMP v3 includes Architecture for SNMP Frameworks (RFC 3411), and partial support of User-based
Security Model (RFC 3414).

To be able to communicate with the SNMP agent, you must include all of these MIBs into your SNMP manager.
Generally your SNMP manager will be an application on your local computer. Your SNMP manager might already
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include standard and private MIBs in a compiled database that is ready to use. You must add the Fortinet and
FortiAnalyzer proprietary MIBs to this database.

MIB file name or RFC Description

FORTINET-CORE-MIB.mib The proprietary Fortinet MIB includes all system configuration information and
trap information that is common to all Fortinet products.
Your SNMP manager requires this information to monitor Fortinet unit
configuration settings and receive traps from the Fortinet SNMP agent.

FORTINET-FORTIMANAGER-  The proprietary FortiAnalyzer MIB includes system information and trap
MIB.mib information for FortiAnalyzer units.

RFC-1213 (MIB II) The Fortinet SNMP agent supports MIB Il groups with the following exceptions.
¢ No support for the EGP group from MIB |l (RFC 1213, section 3.11 and 6.10).
» Protocol statistics returned for MIB Il groups (IP/ICMP/TCP/UDP/etc.) do not
accurately capture all Fortinet traffic activity. More accurate information can
be obtained from the information reported by the Fortinet MIB.

RFC-2665 (Ethernet-like MIB) The Fortinet SNMP agent supports Ethernet-like MIB information with the
following exception.

No support for the dot3Tests and dot3Errors groups.

SNMP traps

Fortinet devices share SNMP traps, but each type of device also has traps specific to that device type. For example
FortiAnalyzer units have FortiAnalyzer specific SNMP traps. To receive Fortinet device SNMP traps, you must load and
compile the FORTINET-CORE-MIB into your SNMP manager.

Traps sent include the trap message as well as the unit serial number (fnSysSerial) and host name (sysName). The Trap
Message column includes the message that is included with the trap, as well as the SNMP MIB field name to help locate
the information about the trap.

Trap message Description

ColdStart, WarmStart, LinkUp, Standard traps as described in RFC 1215.

LinkDown

CPU usage high CPU usage exceeds the set percent. This threshold can be set in the CLI
(fnTrapCpuThreshold) using the following commands:

config system snmp sysinfo
set trap-high-cpu-threshold <percentage value>

end
CPU usage excluding NICE CPU usage excluding NICE processes exceeds the set percentage. This
processes threshold can be set in the CLI using the following commands:

(fmSysCpuUsageExcludedNice) config system snmp sysinfo
set trap-cpu-high-exclude-nice-threshold <percentage
value>
end

Memory low Memory usage exceeds 90 percent. This threshold can be set in the CLI using
the following commands:
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Trap message Description
(fnTrapMemThreshold) config system snmp sysinfo
set trap-low-memory-threshold <percentage value>

end
Log disk too full Log disk usage has exceeded the configured threshold. Only available on
(fnTrapLogDiskThreshold) devices with log disks.
Temperature too high A temperature sensor on the device has exceeded its threshold. Not all
(fnTrapTempHigh) devices have thermal sensors. See manual for specifications.

Voltage outside acceptable range Power levels have fluctuated outside of normal levels. Not all devices have

(fnTrapVoltageOutOfRange) voltage monitoring instrumentation.

Power supply failure Power supply failure detected. Available on some devices that support
(fnTrapPowerSupplyFailure) redundant power supplies.

Interface IP change The IP address for an interface has changed. The trap message includes the
(fnTraplpChange) name of the interface, the new IP address and the serial number of the

Fortinet unit. You can use this trap to track interface IP address changes for
interfaces with dynamic IP addresses set using DHCP or PPPoE.

Log rate too high The incoming log rate has exceeded the peak log rate threshold.

(fmTrapLogRateThreshold) To determine the peak log rate, use the following CLI command: get
system loglimits

Data rate too high The incoming data rate has exceeded the peak data rate threshold.
(fmTrapLogDataRateThreshold) The peak data rate is calculated using the peak log rate x 512 bytes (average
log size).

Fortinet & FortiAnalyzer MIB fields

The Fortinet MIB contains fields reporting current Fortinet unit status information. The below tables list the names of the
MIB fields and describe the status information available for each one. You can view more details about the information
available from all Fortinet MIB fields by compiling the fortinet.3.00.mib file into your SNMP manager and browsing
the Fortinet MIB fields.

System MIB fields:

MIB field Description

fnSysSerial Fortinet unit serial number.

Administrator accounts:

MIB field Description

fnAdminNumber The number of administrators on the Fortinet unit.
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fnAdminTable Table of administrators.
fnAdminindex Administrator account index number.
fnAdminName The user name of the administrator account.
fnAdminAddr An address of a trusted host or subnet from
which this administrator account can be used.
fnAdminMask The netmask for fnAdminAddr.

Custom messages:

MIB field Description

fnMessages The number of custom messages on the Fortinet unit.

MIB fields and traps

MIB field Description

fmModel A table of all FortiAnalyzer models.

Mail Server

A mail server allows the FortiAnalyzer to sent email messages, such as notifications when reports are run or specific
events occur. Mail servers can be added, edited, deleted, and tested.

Go to System Settings > Advanced > Mail Serverto configure SMTP mail server settings.

Al
‘9' If an existing mail server is in use, the delete icon is removed and the mail server entry cannot
be deleted.

To add a mail server:

1. Goto System Settings > Advanced > Mail Server.
2. Click Create New in the toolbar. The Create New Mail Server Settings pane opens.

Create New Mail Server Settings x

SMTP Server Name ‘

Please input a valid name
Mail Server
SMTP Server Port 25
Enable Authentication O
E-Mail Account
Password @
Default Sender (Optional)

Default Password (Optional) @

FortiAnalyzer 7.2.2 Administration Guide 333
Fortinet Inc.



System Settings

3. Configure the following settings and then select OK to create the mail server.

SMTP Server Name Enter a name for the SMTP server.

Mail Server Enter the mail server information.

SMTP Server Port Enter the SMTP server port number. The default port is 25.

Enable Authentication Enable or disable authentication.

Email Account Enter an email account. This option is only accessible when authentication is
enabled.

Password Enter the email account password. This option is only accessible when

authentication is enabled.

To edit a mail server:

1. Go to System Settings > Advanced > Mail Server.

2. Double-click on a server, right-click on a server and then select Edit from the menu, or select a server then click Edit
in the toolbar. The Edit Mail Server Settings pane opens.

3. Editthe settings as required, and then click OK to apply the changes.

To test the mail server:

Go to System Settings > Advanced > Mail Server.

Select the server you need to test.

Click Test from the toolbar, or right-click and select Test.

Type the email address you would like to send a test email to and click OK. A confirmation or failure message will be
displayed.

Click OK to close the confirmation dialog box.

A owbdhd-=

o

To delete a mail server or servers:

Go to System Settings > Advanced > Mail Server.

Select the server or servers you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Click OK in the confirmation box to delete the server.

P owbd-=

Syslog Server

Go to System Settings > Advanced > Syslog Server to configure syslog server settings. Syslog servers can be added,
edited, deleted, and tested.

After adding a syslog server, you must also enable FortiAnalyzer to send local logs to the syslog server. See Send local
logs to syslog server on page 336.

Ay
‘Q' If an existing syslog server is in use, the delete icon is removed and the server entry cannot be
- deleted.
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To add a syslog server:

1.
2,

Go to System Settings > Advanced > Syslog Server.
Click Create New in the toolbar. The Create New Syslog Server Settings pane opens.

Name
IP address (or FQDN)
Syslog Server Port 514

Reliable Connection

Cancel

Configure the following settings and then select OK to create the syslog server.

Name Enter a name for the syslog server.

IP address (or FQDN) Enter the IP address or FQDN of the syslog server.

Syslog Server Port Enter the syslog server port number. The default port is 514.

Reliable Connection Enable or disable a reliable connection with the syslog server. The default is
disable.

Secure Connection Enable/disable connection secured by TLS/SSL. The default is disable.

This option is only available when Reliable Connection is enabled.

Local Certificate CN Enter one of the available local certificates used for secure connection:
Fortinet_Local or Fortinet_Local2. The defaultis Fortinet_Local.

This option is only available when Secure Connection is enabled.

Peer Certificate CN Enter the certificate common name of syslog server. Null means no certificate
CN for the syslog server.

This option is only available when Secure Connection is enabled.

To enable sending FortiAnalyzer local logs to syslog server:

Go to System Settings > Advanced > Syslog Server.

Double-click on a server, right-click on a server and then select Edit from the menu, or select a server then click Edlit
in the toolbar. The Edit Syslog Server Settings pane opens.

Edit the settings as required, and then click OK to apply the changes.

To edit a syslog server:

Go to System Settings > Advanced > Syslog Server.

Double-click on a server, right-click on a server and then select Edit from the menu, or select a server then click Edlit
in the toolbar. The Edit Syslog Server Settings pane opens.

Edit the settings as required, and then click OK to apply the changes.

To test the syslog server:

Go to System Settings > Advanced > Syslog Server.
Select the server you need to test.

Click Test from the toolbar, or right-click and select Test.
A confirmation or failure message will be displayed.
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To delete a syslog server or servers:

Go to System Settings > Advanced > Syslog Server.

Select the server or servers you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Click OK in the confirmation box to delete the server or servers.

oD

Send local logs to syslog server

After adding a syslog server to FortiAnalyzer, the next step is to enable FortiAnalyzer to send local logs to the syslog
server. See Syslog Server on page 334.

You can only enable these settings by using the CLI.

config system locallog syslogd setting
set severity information
set status enable
set syslog-name <syslog server name>
end

Meta Fields

Meta fields allow administrators to add extra information when configuring, adding, or maintaining FortiGate units or
adding new administrators. You can make meta fields required or optional.

When meta fields are required, administrators must supply additional information when they create an associated object.
For example, if you create a required meta field for a device object, administrators must define a value for the meta field
for all devices.

Go to System Settings > Advanced > Meta Fields to configure meta fields. Meta fields can be added, edited, and deleted.

=+ Create New # Collapse All " Expand All ¥% Column Settings ~ m
O MetaFields Length Importance Status
(0 v System Administrator (2)
O Contact Email 50 Optional Enabled
0O Contact Phone 50 Optional Enabled
[J ¥ Devicel4)
O  Company/Organization 50 Optional Enabled
O Contact Email 50 Optional Enabled
O Contact Phone Number 50 Optional Enabled
0O Address 150 Optional Enabled
) ¥ Device Group (0)
O~ Device VDOM (0)
[J v Administrative Domain (0)
9 Select Expand All or Collapse All from the toolbar or right-click menu to view all or none of the
meta fields under each object.
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To create a new meta field:

1. Go to System Settings > Advanced > Meta Fields.
2. Click Create New in the toolbar. The Create New Meta Field pane opens.

Create New Meta Fields

Object System Administrator
Name test
Length 20
Importance Optional (®)Required
Status Disabled (2)Enabled

Cancel

3. From the Objectfield, select an object.
Some objects also allow you to define a value for the meta field for each device.

Object The object this metadata field applies to: Administrative Domains, Devices,
Device Groups, Device VDOM, or System Administrator.

4. Configure the following settings:

Name Enter the label to use for the field.
When you type the name, a variable name is automatically created.

Length Select the maximum number of characters allowed for the field from the
dropdown list: 20, 50, or 255.

Importance Select Required to make the field compulsory; otherwise, select Optional.

Status Select Disabled to disable this field. The default selection is Enabled.

5. If you selected a Device or Device VDOM object, set a value for the meta field:
a. Under Values, click Create New.
The Create Meta Field Value dialog box is displayed.
b. From the Device list, select a device.
In the Value box, type a value for the device.
d. Click OK.
The value is defined for the device.
6. Click OK.
The meta field is created.

o

To edit a meta field:

1. Go to System Settings > Advanced > Meta Fields.

2. Double-click on a field, right-click on a field and then select Edit from the menu, or select a field then click Edit in the
toolbar. The Edit Meta Fields pane opens.

3. Editthe settings as required, and then click OK to apply the changes.
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Ay
b [ 4
? The Object and Name fields cannot be edited.

To delete a meta field or fields:

Go to System Settings > Advanced > Meta Fields.

Select the field or fields you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Click OK in the confirmation box to delete the field or fields.

Ao b=

\‘ ! 'l
? The default meta fields cannot be deleted.

Device logs

The FortiAnalyzer allows you to log system events to disk. You can control device log file size and the use of the
FortiAnalyzer unit’s disk space by configuring log rolling and scheduled uploads to a server.

As the FortiAnalyzer unit receives new log items, it performs the following tasks:
 Verifies whether the log file has exceeded its file size limit.
¢ Checks to see ifitis time to roll the log file if the file size is not exceeded.

When a current log file (t1og . 10g) reaches its maximum size, or reaches the scheduled time, the FortiAnalyzer unit
rolls the active log file by renaming the file. The file name will be in the form of x10g.N. 1log (for example,
tlog.1252929496.10g), where x is a letter indicating the log type and N is a unique number corresponding to the time
the first log entry was received. The file modification time will match the time when the last log was received in the log file.

Once the current log file is rolled into a numbered log file, it will not be changed. New logs will be stored in the new
currentlog called t1og. 1og. Iflog uploading is enabled, once logs are uploaded to the remote server or downloaded via
the GUI, they are in the following format:

FG3K6A3406600001-t10g.1252929496.10g-2017-09-29-08-03-54.gz

If you have enabled log uploading, you can choose to automatically delete the rolled log file after uploading, thereby
freeing the amount of disk space used by rolled log files. If the log upload fails, such as when the FTP server is
unavailable, the logs are uploaded during the next scheduled upload.

Log rolling and uploading can be enabled and configured using the GUI or CLI.

Configuring rolling and uploading of logs using the GUI

Go to System Settings > Advanced > Device Log Setting to configure device log settings.
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Device Log Settings
Registered Device Logs

Roll log file when size exceeds (10-1000)MB

ERoll log files at scheduled time

Daily v 00 v |Hour | 00 + | Minute

B Upload logs using a standard file transfer protocol

Upload Server Type FTP

Upload Server IP 0.0.0.0

User Name

Password -

Remote Directory

Upload Log Files @When rolled Dailyat 00 v | Hour

Upload log files in gzip file format

Delete log files after uploading

Local Device Log

Esend the local event logs to FortiAnalyzer/FortiManager
IP Address
Upload Option @Real-time  OSchedule Time

Severity Level Emergency
E2Reliable log transmission

Secure connection

Lo

Configure the following settings, and then select Apply:

Registered Device Logs
Roll log file when size exceeds Enter the log file size, from 10 to 500MB. Default: 200MB.

Roll log files at scheduled time Select to roll logs daily or weekly.
¢ Daily: select the hour and minute value in the dropdown lists.
¢ Weekly: select the day, hour, and minute value in the dropdown
lists.

Upload logs using a standard file  Select to upload logs and configure the following settings.
transfer protocol

Upload Server Type Select one of FTP, SFTP, or SCP.

Upload Server IP Enter the IP address of the upload server.

User Name Enter the username used to connect to the upload server.

Password Enter the password used to connect to the upload server.

Remote Directory Enter the remote directory on the upload server where the log will be
uploaded.

Upload Log Files Select to upload log files when they are rolled according to settings

selected under Roll Logs, or daily at a specific hour.

Upload rolled files in Select to gzip the logs before uploading. This will result in smaller logs
gzip file format and faster upload times.

Delete files after Select to remove device log files from the FortiAnalyzer system after
uploading they have been uploaded to the Upload Server.

Local Device Log
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Send the local event logs to Select to send local event logs to another FortiAnalyzer or
FortiAnalyzer / FortiManager FortiManager device.
IP Address Enter the IP address of the FortiAnalyzer or FortiManager.
Upload Option Select to upload logs in real time or at a scheduled time.

When selecting a scheduled time, you can specify the hour and minute
to upload logs each day.

Severity Level Select the minimum log severity level from the dropdown list. This
option is only available when Upload Option is Realtime.

Reliable log Select to use reliable log transmission.
transmission

Secure connection Select to use a secure connection for log transmission. This option is
only available when Reliable log transmission is selected.

Configuring rolling and uploading of logs using the CLI

Log rolling and uploading can be enabled and configured using the CLI. For more information, see the FortiAnalyzer CLI
Reference.

Enable or disable log file uploads
Use the following CLI commands to enable or disable log file uploads.

To enable log uploads:

config system log settings
config rolling-regular
set upload enable
end

To disable log uploads:

config system log settings
config rolling-regular
set upload disable
end

Roll logs when they reach a specific size
Use the following CLI commands to specify the size, in MB, at which a log file is rolled.

To roll logs when they reach a specific size:

config system log settings
config rolling-regular
set file-size <integer>
end
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Roll logs on a schedule

Use the following CLI commands to configure rolling logs on a set schedule, or never.

To disable log rolling:

config system log settings
config rolling-regular
set when none
end

To enable daily log rolling:

config system log settings
config rolling-regular
set upload enable
set when daily
set hour <integer>
set min <integer>
end

To enable weekly log rolling:

config system log settings
config rolling-regular
set when weekly
set days {mon | tue | wed | thu | fri | sat | sun}

set hour <integer>
set min <integer>
end

Upload logs to cloud storage

The FortiAnalyzer can be set to upload logs to cloud storage. Before enabling this feature, you must have a valid Storage
Connector Service license. See License Information widget on page 277.

For information on setting up a storage fabric connector, see Creating or editing storage connectors on page 116.

To upload logs to cloud storage:

1. Go to System Settings > Advanced > Device Log Settings.
2. Select Create New.
3. Complete the following options, and click OK.
« Enter a name for the cloud storage.
« Inthe Cloud Storage Connector list, select a Fabric Connector.
« Inthe Remote Path box, type the bucket or container name from the storage account.
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Certificates required for cloud storage

Before logs can be uploaded to cloud storage using Amazon S3, Azure Blob, or Google connectors, the cloud provider's
CA certificate(s) must be imported into FortiAnalyzer.

Third-party CA certificates, for example GlobalSign and CyberTrust, may be required. Check with your cloud storage
provider to see which CA certificates are supported.

For information on how to import certificates into FortiAnalyzer, see CA certificates on page 308.

File Management

FortiAnalyzer allows you to configure automatic deletion of device log files, quarantined files, reports, and content
archive files after a set period of time.

Go to System Settings > Advanced > File Management to configure file management settings.

File Management

Automatically Delete

Device log files older than 365 e Days + Scheduled daily at time  00:00
Reports older than 365 + Days + Scheduled daily at ime  00:00
Content archive files older than 365 z Days + Scheduled daily at time  00:00

Quarantined files older than 365 z Days v Scheduled daily at time  00:00

=

Configure the following settings, and then select Apply:

Device log files older than Select to enable automatic deletion of compressed log files.

Enter a value in the text field, select the time period (Days, Weeks, or Months),
and choose a time of day.

Reports older than Select to enable automatic deletion of reports of data from compressed log files.
Enter a value in the text field, select the time period, and choose a time of day.

Content archive files older Select to enable automatic deletion of IPS and DP archives from Archive logs.
than Enter a value in the text field, select the time period, and choose a time of day.
Quarantined files older than Select to enable automatic deletion of compressed log files of quarantined files.

Enter a value in the text field, select the time period, and choose a time of day.

The time period you select determines how often the item is checked. If you select Months, then the item is checked
once per month. If you select Weeks, then the item is checked once per week, and so on. For example, if you specify
Device log files older than 3 Months, then on July 1, the logs for April, May, and June are kept and the logs for March and
older are deleted.
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Advanced Settings

Go to System Settings > Advanced > Advanced Settings to view and configure advanced settings and download WSDL
files.

Configure the following settings and then select Apply:

ADOM Mode Select the ADOM mode, either Normal or Advanced.

Advanced mode will allow you to assign a VDOM from a single device to a
different ADOM, but will result in more complicated management scenarios. It is
recommended only for advanced users.

Download WSDL file Select the required WSDL functions then click the Download button to download
the WSDL file to your management computer.

When selecting Legacy Operations, no other options can be selected.

Web services is a standards-based, platform independent, access method for
other hardware and software APls. The file itself defines the format of commands
the FortiAnalyzer will accept as well as the responses to expect. Using the WSDL
file, third-party or custom applications can communicate with the FortiAnalyzer
unit and operate it or retrieve information, just as an administrator can from the
GUIl or CLI.

Task List Size Set a limit on the size of the task list. Default: 2000.

FortiGuard

This section includes information on FortiGuard for FortiAnalyzer, and includes the following topics:

» Subscribing FortiAnalyzer to FortiGuard on page 343
e Licensingin an air-gap environment on page 344

Subscribing FortiAnalyzer to FortiGuard

To keep your FortiAnalyzer threat database up to date:

o Ensure your FortiAnalyzer can reach FortiGuard at fds1.fortinet.com.

» Purchase a FortiGuard Indicators of Compromise Service license and apply that license to the product registration.
No change is needed on the FortiAnalyzer side.

To subscribe FortiAnalyzer to FortiGuard:

1. Goto System Settings > Dashboard.
2. Inthe License Information widget, find the FortiGuard > Indicators of Compromise Service field and click Purchase.

3. After purchasing the license, check that the FortiGuard > Indicators of Compromise Service is Licensed and shows
the expiry date.
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Licensing in an air-gap environment

When performing the initial setup of FortiAnalyzer, you are required to register your FortiAnalyzer to FortiCare, which
typically requires internet access. While operating in a closed network or air-gap environment, you must complete this
step by uploading the entitlements file through the FortiAnalyzer CLI.

To register FortiAnalyzer in an air-gap environment:

1. InFortiAnalyzer, disable access to the public FortiGuard Distribution Servers (FDS) using the following
CLI commands:
config fmupdate publicnetwork
set status disable
end

2. Connect to the FortiAnalyzer GUI, and on the FortiAnalyzer login screen, click Upload License.

FortiAnalyzer-VMé4

This product requires a valid license. You could log in to
FortiCloud to activate your purchased license, or use a free trial
license.

@® Free Trial
) Activate License

Login with FortiCloud

Register with FortiCloud

Upload license

3. Click Browse to select your FortiAnalyzer license or drag-and-drop the license file, and click Upload.

Upload License File

Upload file by drag & drop here or  Browse

Upload Cancel

The license file will be applied, and the FortiAnalyzer will be restarted in order to verify the license.
4. Signinto FortiAnalyzer.
The FortiAnalyzer Setup Wizard is displayed.
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FortiAnalyzer Setup - Register and SSO with FortiCare (2/4)

Register with FortiCare

Serial Number

Account ID/Email

Password

Country/Region

Reseller

SSO with FortiCloud

FortiCloud Single Sign-on €@

FAZ-VMTM22003795

Register Forgot your password?
Click to select -
Click to select -

[ @)

In order to access your FortiAnalyzer, it must be registered to FortiCare in the FortiAnalyzer Setup Wizard.
5. On FortiCloud, create a ticket for your FortiAnalyzer entitlements file, and Fortinet Customer Service will provide you

with the file.

6. You can upload your entitlement file either through the setup wizard or through the FortiAnalyzer CLI.

a. Onboarding wizard:

i. Select Import the Entitlement File in the FortiAnalyzer Setup wizard.
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ii. Drag and drop the entitlement file into the import area, or click Add Files to select the file location.

FortiAnalyzer Setup - Welcome (1/4)

Welcome

Perform the following steps to complete the setup of this FortiAnalyzer.

1. Register and SSO with FortiCare
Import the Entitlement File

Add files by drag & drop here or Add Files

2. Specify Hostname
3. Change Your Password v

4. Upgrade Firmware v

b. Command line interface:
i. Open the FortiAnalyzer CLI.
ii. Upload the entitlement file using the following command.

execute fmupdate <ftp | scp | tftp> import license <filename> <server> <port>
<directory> <username> <password>

The <port> variable is only required when connecting to a remote SCP host. The
ﬂ <directory>, <username>, and <password> variables are only required for
I logging into a FTP server or SCP host to download the file. For more information,
see the FortiAnalyzer CLI Reference.

For example:
execute fmupdate ftp import license entitlement-file 172.10.1.10 /pub/place
userl passwordl
This operation will replace the current package!
Do you want to continue? (y/n)y

Start getting file from FTP Server...

Transferred 0.001M of 0.001M in 0:00:00s (0.008M/s)
FTP transfer is successful.

Package installation is in process...
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This could take some time.
Update successfully

7. The FortiAnalyzer Setup wizard will display that you are successfully registered with FortiCare.

FortiAnalyzer Setup

Welcome

Perform the following steps to complete the setup of this FortiAnalyzer.

1. Register and S50 with FortiCare v
2. Specify Hostname
3. Change Your Password

4. Upgrade Firmware v

)

Restart, shut down, or reset FortiAnalyzer

Always use the operation options in the GUI or the CLI commands to reboot and shut down the FortiAnalyzer system to
avoid potential configuration problems.

Restarting FortiAnalyzer

To restart the FortiAnalyzer unit from the GUI:

1. Goto System Settings > Dashboard.
2. Inthe Unit Operation widget, click the Restart button.
3. Enter a message for the event log, then click OK to restart the system.
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To restart the FortiAnalyzer unit from the CLI:
1. From the CLI, or in the CLI/ Console menu, enter the following command:
execute reboot

The system will be rebooted.
Do you want to continue? (y/n)

2. Enter yto continue. The FortiAnalyzer system will restart.

Shutting down FortiAnalyzer

To shutdown the FortiAnalyzer unit from the GUI:

1. Goto System Settings > Dashboard.
2. Inthe Unit Operation widget, click the Shutdown button.
3. Enter a message for the event log, then click OK to shutdown the system.

To shutdown the FortiAnalyzer unit from the CLI:
1. From the CLI, or in the CLI/ Console menu, enter the following command:
execute shutdown

The system will be halted.
Do you want to continue? (y/n)

2. Enter y to continue. The FortiAnalyzer system will shutdown.

Resetting system settings
FortiAnalyzer settings can be reset to factory defaults using the CLI.

To reset settings to factory defaults:

1. From the CLI, or in the CLI/ Console menu, enter the following command:

execute reset {adom-settings | all-except ip | all-settings

Variable Description

| all-shutdown}

adom-settings <adom> Reset an ADOM's settings.
<version> <mr> <ostype> ¢ <adom>: The ADOM name.
e <version>: The ADOM version.
e <mr>: The major release number.
e <ostype>: Supported OS type.

all-except-ip Reset all settings except the current IP address and route information.
all-settings Reset to factory default settings.
all-shutdown Reset all settings and shutdown.

2. Enter y to continue. The device will reset settings based on the type of reset performed.
For example, execute reset all-settings will resetall FortiAnalyzer to factory defaults.
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The System Settings > Admin menu enables you to configure administrator accounts, access profiles, remote
authentication servers, and adjust global administrative settings for the FortiAnalyzer unit.

Administrator accounts are used to control access to the FortiAnalyzer unit. Local and remote authentication is
supported, as well as two-factor authentication. Administrator profiles define different types of administrators and the
level of access they have to the FortiAnalyzer unit, as well as its authorized devices.

Global administration settings, such as the GUI language and password policies, can be configured on the Admin
Settings pane. See Global administration settings on page 377 for more information.

This section contains the following topics:

o Trusted hosts on page 349

o Monitoring administrators on page 349

» Disconnecting administrators on page 350

« Managing administrator accounts on page 350
o Administrator profiles on page 358

» Authentication on page 365

o Global administration settings on page 377

» Two-factor authentication on page 385

Trusted hosts

Setting trusted hosts for all of your administrators increases the security of your network by further restricting
administrative permissions. In addition to knowing the password, an administrator must connect only through the subnet
or subnets you specify. You can even restrict an administrator to a single IP address if you define only one trusted host
IP address with a netmask of 255.255.255.255.

When you set trusted hosts for all administrators, the FortiAnalyzer unit does not respond to administrative access
attempts and cannot be pinged from any other hosts. This provides the highest security. If you leave even one
administrator unrestricted, the unit accepts administrative access attempts on any interface that has administrative
access enabled, potentially exposing the unit to attempts to gain unauthorized access.

The trusted hosts you define apply to both the GUI and to the CLI when accessed through SSH. CLI access through the
console connector is not affected.

Ay
‘Q' If you set trusted hosts and want to use the Console Access feature of the GUI, you must also
- set 127.0.0.1/255.255.255.255 as a trusted host.

Monitoring administrators

The Admin Session List lets you view a list of administrators currently logged in to the FortiAnalyzer unit.
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To view logged in administrators:

1.
2,

Go to System Settings > Dashboard.

In the System Information widget, in the Current Administrators field, click the Current Session List button. The
Admin Session List opens in the widget.
The following information is available:

User Name The name of the administrator account. Your session is indicated by (current).

IP Address The IP address where the administrator is logging in from. This field also displays the
logon type (GUI, jsconsole, or SSH).

Start Time The date and time the administrator logged in.

Time Out (mins) The maximum duration of the session in minutes (1 to 480 minutes).

Disconnecting administrators

Administrators can be disconnected from the FortiAnalyzer unit from the Admin Session List.

To disconnect administrators:

1.
2,

Go to System Settings > Dashboard.

In the System Information widget, in the Current Administrators field, click the Current Session List button. The
Admin Session List opens in the widget.

Select the administrator or administrators you need to disconnect.
Click Delete in the toolbar, or right-click and select Delete.
The selected administrators will be automatically disconnected from the FortiAnalyzer device.

Managing administrator accounts

Go to System Settings > Admin > Administrator to view the list of administrators and manage administrator accounts.

Only administrators with the Super_User profile can see the complete administrators list. If you do not have certain

viewing permissions, you will not see the administrator list. When ADOMs are enabled, administrators can only access

the ADOMs they have permission to access.

+ CreateNew [ Edit %a Clone T Delete [ TableView~ # Column Settings ~ | Q]
Seq.# Name Type Profile ADOMs Trusted IPv4 Hosts
1 LI LDAP Teltro FortiClient 0.0.0.0/0.0.0.0

= Wildcard FortiCarrier
FortiCache
2 R RADIUS Sup All ADOMs 0.0.0.0/0.0.0.0
Wildcard
3 TS TACACS+ Standard_User Exclude: 0.0.00/0.0.0.0
Wildcard FortiAnalyzer
4 e admin LOCAL Super_User All ADOMs 0.0.0.0/0.0.0.0
5 o admin2 LOCAL Super_User All ADOMs 0.0.0.0/0.00.0
6 e servicenow LOCAL Restricted_User All ADOMs 0.0.00/0.0.0.0
7 LOCAL Restricted_User All ADOMs 0.0.0.0/0.0.0.0
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The following options are available:

Create New
Edit
Clone

Delete

Table View/Tile View

Column Settings
Search

Change Password

The following information is shown:

Seq.#

Name
Type
Profile
ADOMs
Comments

Trusted IPv4 Hosts

Trusted IPv6 Hosts

Contact Email

Contact Phone

Creating administrators

Create a new administrator. See Creating administrators on page 351.
Edit the selected administrator. See Editing administrators on page 356.
Clone the selected administrator.

Delete the selected administrator or administrators. See Deleting administrators
on page 357.

Change the view of the administrator list.

Table view shows a list of the administrators in a table format. Tile view shows a
separate card for each administrator in a grid pattern.

Change the displayed columns.
Search the administrators.

Change the selected administrator's password. This option is only available from
the right-click menu. See Editing administrators on page 356.

The sequence number.

The name the administrator uses to log in.

The user type, as well as if the administrator uses a wildcard.

The profile applied to the administrator. See Administrator profiles on page 358
The ADOMs the administrator has access to or is excluded from.

Comments about the administrator account. This column is hidden by default.

The IPv4 trusted host(s) associated with the administrator. See Trusted hosts on
page 349.

The IPv6 trusted host(s) associated with the administrator. See Trusted hosts on
page 349. This column is hidden by default.

The contact email associated with the administrator. This column is hidden by
default.

The contact phone number associated with the administrator. This column is
hidden by default.

To create a new administrator account, you must be logged in as a super user administrator.

You need the following information to create an account:

» Which authentication method the administrator will use to log in to the FortiAnalyzer unit. Local, remote, and Public
Key Infrastructure (PKI) authentication methods are supported.

» What administrator profile the account will be assigned, or what system privileges the account requires.
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o If ADOMs are enabled, which ADOMs the administrator will require access to.
« Ifusing trusted hosts, the trusted host addresses and network masks.

Al
‘Q' For remote or PKI authentication, the authentication must be configured before you create the
- administrator. See Authentication on page 365 for details.
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To create a new administrator:

1. Go to System Settings > Admin > Administrators.
2. Inthe toolbar, click Create New to display the New Administrator pane.

Create New Administrator

User Mame
Aocatar # Add Photo -
Description

e
Admin Type LOCAL v
Mew Password K
Confirm Password @
FortiToken Cloud FortiToken Mobile | Email | SMS
Administrative Domain PNl Ol Al ADOMSs except specified ones | Specify
Admin Profile Restricted_User v
JSON AP| Access None -
Theme Mode Uze Own Theme
Trusted Hosts »
Meta Fields >

Advanced Options ~

change-password enable h
ext-auth-accprofile-override disable -
ext-auth-adom-override disable -
ext-auth-group-match undefined

fingerprint undefined

first-name undefined

last-name undefined

login-max 32

pager-number undefined

3. Configure the following settings, and then click OK to create the new administrator.

User Name Enter the name of the administrator will use to log in.
Avatar Apply a custom image to the administrator.
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Comments

Admin Type

Server or Group

Match all users on remote
server

Subject

CA

Required two-factor

authentication

New Password

Confirm Password
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Click Add Photo to select an image already loaded to the FortiAnalyzer, or to
load an new image from the management computer.

If no image is selected, the avatar will use the first letter of the user name.

Optionally, enter a description of the administrator, such as their role, location,
or the reason for their account.

Select the type of authentication the administrator will use when logging into
the FortiAnalyzer unit. One of: LOCAL, RADIUS, LDAP, TACACS+, PKI,
Group, or SSO. See Authentication on page 365 for more information.

Select the RADIUS server, LDAP server, TACACS+ server, or group, as
required.

The server must be configured prior to creating the new administrator.
This option is not available if the Admin Type is LOCAL or PKI.

Select this option to automatically add all users from a LDAP server specified
in Admin>Remote Authentication Server. All users specified in the
Distinguished Name field in the LDAP server will be added as FortiManager
users with the selected Admin Profile.

Select this option when the Admin Type is SSO to create one SAML SSO
wildcard admin user to match all users on the identity provider (IdP) server.
This FortiAnalyzer must be configured as a service provider (SP), added to the
IdP, and have the same user profile and ADOM names as the IdP. If this is
done, the user is assigned the same profile and ADOMs when logging in as an
SSO user on this SP. See SAML admin authentication on page 373.

If this option is not selected, the User Name specified must exactly match the
LDAP user specified on the LDAP server.

This option is not available if the Admin Type is LOCAL or PKI.

Enter a comment for the PKI administrator.
This option is only available if the Admin Type is PKI.

Select the CA certificate from the dropdown list.
This option is only available if the Admin Type is PKI.

Select to enable two-factor authentication.
This option is only available if the Admin Type is PKI.

Enter the password.
This option is not available if Match all users on remote serveris selected.

If the Admin Type is PKI, this option is only available when Require two-factor
authentication is selected.

If the Admin Type is RADIUS, LDAP, or TACACS+, the password is only used
when the remote server is unreachable.

Enter the password again to confirm it.
This option is not available if Match all users on remote serveris selected.

If the Admin Type is PKI, this option is only available when Require two-factor
authentication is selected.
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Force this administrator to
change password upon next
log on.

FortiToken Cloud

Administrative Domain

Admin Profile

JSON API Access

Trusted Hosts

Theme Mode

Meta Fields

Advanced Options
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Force the administrator to change their password the next time that they log in
to the FortiAnalyzer.

This option is only available if Password Policy is enabled in Admin Settings.
See Password policy on page 382.

Enable or disable two-factor authentication with FortiToken Cloud, then select
the token delivery method from the following options:

* FortiToken Mobile: Use the FortiToken Mobile app to get tokens. The
administrator is sent an email with a link to activate their token in the
FortiToken Mobile app on their mobile device.

* Email: Receive the token by email.

e SMS: Receive the token by SMS message.

This option is not available if Admin Type is set to PK/ or SSO. See Two-factor
authentication on page 385.

Choose the ADOM s this administrator will be able to access.

¢ AllADOMs: The administrator can access all the ADOMs.

e Al ADOMs except specified ones: The administrator cannot access the
selected ADOMs.

» Specify: The administrator can access the selected ADOMs. Specifying
the ADOM shows the Specify Device Group to Access check box. Select
the Specify Device Group to Access check box and select the Device
Group this administrator is allowed to access. The newly created
administrator will only be able to access the devices within the Device
Group and sub-groups.

If the Admin Profile is Super_User, then this setting is All ADOMs.
This field is available only if ADOMs are enabled. See Administrative Domains
(ADOMSs) on page 296.

Select an administrator profile from the list. The profile selected determines
the administrator’s access to the FortiAnalyzer unit’s features. See
Administrator profiles on page 358.

Select the permission for JSON API Access. Select Read-Write, Read, or
None. The default is None.

Optionally, turn on trusted hosts, then enter their IP addresses and netmasks.
Up to ten IPv4 and ten IPv6 hosts can be added.

See Trusted hosts on page 349 for more information.

Select Use Global Theme to apply a theme to all administrator accounts.
Select Use Own Theme to allow administrators to select their own theme.

Optionally, enter the new administrator's email address and phone number.

Configure advanced options, see Advanced options below.

For more information on advanced options, see the FortiAnalyzer CLI
Reference.
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Advanced options

Option Description Default
change-password Enable or Disable changing password. disable
ext-auth-accprofile- Enable or Disable overriding the account profile by administrators disable
override configured on a Remote Authentication Server.

ext-auth-adom-override Enable or Disable overriding the ADOM by administrators configured disable
on a Remote Authentication Server. This will also override the Admin
Profile configured for each ADOM.

ext-auth-group-match Specify the group configured on a Remote Authentication Server. -

fingerprint Specify the user certificate fingerprint based on MD5, SHA-1, or SHA- -
256 hash function.

This option is only available if the Admin Type is PKI.

first-name Specify the first name. -
last-name Specify the last name. -
mobile-number Specify the mobile number. -
pager-number Specify the pager number. -
restrict-access Enable or Disable restricted access. disable

Editing administrators

To edit an administrator, you must be logged in as a super user administrator. The administrator's name cannot be
edited. An administrator's password can be changed using the right-click menu, if the password is not a wildcard.

To edit an administrator:

1. Goto System Settings > Admin > Administrators.

2. Double-click on an administrator, right-click on an administrator and then select Edit from the menu, or select the
administrator then click Edit in the toolbar. The Edit Administrator pane opens.

3. Editthe settings as required, and then select OK to apply the changes.

To change an administrator's password:

1. Goto System Settings > Admin > Administrators.

2. Right-click on an administrator and select Change Password from the menu. The Change Password dialog box
opens.
3. Ifyou are editing the admin administrator's password, enter the old password in the Old Password field.
4. Enterthe new password for the administrator in the New Password and Confirm Password fields.
5. Select OKto change the administrator's password.
\‘ : ’I
q The current administrator's password can also be changed from the admin menu in the GUI
- banner. See GUI overview on page 23 for information.
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Deleting administrators

To delete an administrator or administrators, you must be logged in as a super user administrator.

Al
S L4
? You cannot delete an administrator that is currently logged in to the device.
Al
S L4
9 The admin administrator can only be deleted using the CLI.

To delete an administrator or administrators:

Go to System Settings > Admin > Administrators.

Select the administrator or administrators you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Select OKin the confirmation box to delete the administrator or administrators.

o bd-=

To delete an administrator using the CLI:

1. Open a CLI console and enter the following command:
config system admin user
delete <username>
end

Override administrator attributes from profiles

FortiAnalyzer administrator accounts can be configured to use the RPC Permit (JSON API Access) and Trusted Hosts
attributes that are defined by an administrator profile.

When an administrator has been configured to use the attributes from the profile, the attributes can no longer be
changed by editing the administrator account.

This feature can only be configured from the FortiAnalyzer CLI.

For more information, see the FortiAnalyzer CLI Reference Guide on the Fortinet Document Library.

To use RPC Permit and Trusted Host administrator attributes from a profile:

1. Goto System Settings > Admin > Administrators, and create or edit an admin user.
2. In Admin Profile dropdown, select an administrator profile, and click OK.

3. Configure the settings for the rpc-permit and/or trusthost1 attributes in the admin profile.
Enter the following commands in the FortiAnalyzer CLI:
config system admin profile
edit <profile name>
set rpc-permit {none | read | read-write}
set trusthostl <ip & netmask>
end
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4. Configure the admin user to use the from-profile option for the rpc-permit and/or trusthost1 attributes.

Enter the following commands in the FortiAnalyzer CLI:

config system admin user
edit <admin user>

set rpc-permit from-profile
set trusthostl from-profile

end

5. Inthe FortiAnalyzer GUI, go to System Settings > Admin > Administrators and view the administrator account. The
attributes that were configured to use the from-profile setting can no longer be edited and display the settings
defined in the administrator profile.

Edit Administrator

User Name

Avatar

Description

Admin Type

Admin Profile
Administrative Domain
Policy Package

J50N APl Access
Theme Mode

Trusted Hosts
Trusted IPv4 Host 1

Trusted IPv4 Host 2
Trusted IPv4 Host 3
Trusted IPvé Host 1
Trusted IPvé Host 2
Trusted IPvé Host 3

Meta Fields >
Advanced Options >

Administrator profiles

TestAdmin

T = Add Photo = Remave Photo

LOCAL

test

All ADOMSs All ADOMs except specified ones
All Packages Specify

Read-Write

Use Global Theme Use Own Theme

10.2.116.0/255.255.255.0
255.255.255.255/255.255.255.255
255.255.255.255/255.255.255.255
/0

T A A A PP P AT AP/ 128
T A A A PP P AT AP/ 128

o [

AN

{

Administrator profiles are used to control administrator access privileges to devices or system features. Profiles are

assigned to administrator accounts when an administrator is created. The profile controls access to both the
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FortiAnalyzer GUl and CLI.

There are three predefined system profiles:

Restricted_User

Standard_User

Super_User

Restricted user profiles have no system privileges enabled, and have read-only
access for all device privileges.

Standard user profiles have no system privileges enabled, and have read/write
access for all device privileges.

Super user profiles have all system and device privileges enabled. It cannot be
edited.

These profiles cannot be deleted, but standard and restricted profiles can be edited. New profiles can also be created as
required. Only super user administrators can manage administrator profiles.

Go to System Settings > Admin > Profile to view and manage administrator profiles.

+ Create New [# Edit R§ Clone Wi Delete QI

O # Name

0O 1 Restricted_User
o 2 Standard_User
a 3 Super_User

a 4 Teltro

0O s Sup

The following options are available:

Create New

Edit
Clone

Delete

Search

The following information is shown:

Name

Type

Description

Permissions

Type Description
Restricted user profiles have no System Privileges enabled, and have read-only access for all
Device Privileges.

Standard user profiles have no System Privileges enabled, but have read/write access for all
Device Privileges.

Super user profiles have all system and device privileges enabled.

Create a new administrator profile. See Creating administrator profiles on page
362.

Edit the selected profile. See Editing administrator profiles on page 364.
Clone the selected profile. See Cloning administrator profiles on page 364.

Delete the selected profile or profiles. See Deleting administrator profiles on page
365.

Search the administrator profiles list.

The name the administrator uses to log in.
The profile type.

A description of the system and device access permissions allowed for the
selected profile.

The below table lists the default permissions for the predefined administrator profiles.
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When Read-Write is selected, the user can view and make changes to the FortiAnalyzer system. When Read-Only is
selected, the user can only view information. When None is selected, the user can neither view or make changes to the
FortiAnalyzer system.

Setting Predefined Administrator Profile

Super User Standard User Restricted User

System Settings Read-Write None None

system-setting

Administrative Domain Read-Write Read-Write None

adom-switch

Device Manager Read-Write Read-Write Read-Only

device-manager

Add/Delete/Edit Read-Write Read-Write None
Devices/Groups

device-op
Log View/FortiView Read-Write Read-Write Read-Only

log-viewer

FortiSOC Read-Write Read-Write Read-Only

event-management

Create & Update Incidents Read-Write Read-Write None
update-incidents

Triage Event Read-Write Read-Write None

triage-events

Reports Read-Write Read-Write Read-Only

report-viewer

Run Report Read-Write Read-Write None

run-report

Fabric View Read-Write Read-Write Read-Only

fabric-viewer

CLI only settings

device-wan-link-load-balance Read-Write Read-Write Read-Only
device-ap Read-Write Read-Write Read-Only
device-forticlient Read-Write Read-Write Read-Only
device-fortiswitch Read-Write Read-Write Read-Only
realtime-monitor Read-Write Read-Write Read-Only
adom-lock Read-Write Read-Write Read-Only
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Setting Predefined Administrator Profile

Super User Standard User Restricted User
device-policy-package-lock Read-Write Read-Write Read-Only
extension-access Read-Write Read-Write None
fortirecorder-setting Read-Write Read-Write None
execute-playbook Read-Write Read-Write None
script-access Read-Write Read-Write None

Privacy Masking

Use Privacy Masking to help protect user privacy by masking or anonymizing user information. You can select which
fields to mask. Masked fields show anonymous data. You can unmask and see the original data by entering the Data
Mask Key that you specify in the administrator profile.

When Privacy Masking is enabled in an administrator profile, accounts using that profile have a See Original Data button
in the banner.

B AllDevices~ @ Last 1 HEEE SR ISIER
Source [ Manual Input

0.. 751963521
0. 75.196.35.21
0.. 751963521

To turn privacy masking on:

—

In System Settings > Profile, create or edit a profile.

In the Privacy Masking section, set the toggle to ON

3. Inthe Masked Data Fields section, select the fields you want to mask.

The fields you select are masked in all modules that display those fields.

In the Data Mask Key field, type the key that will allow users to unmask the data.

In the Data Unmasked Time field, type the number of days the data is unmasked.

You can enter a number between 0-365. Logs that are older than the number of days appear masked.

N

o

To see the original, unmasked data:

1. Inany list showing masked data, click See Original Data in the banner and select Screen Picker or Manual Input.
2. Ifyou select Screen Picker, click a masked field, for example, 75.196.35.21.
The Unmask Protected Data dialog box displays with the field you clicked already entered.

If you select Manual Input, enter the masked text, for example, 75.196.35.21.
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3. Enter the Data Mask Key that was set up in the administrator profile and click OK.

Unmask Protected Data

Masked Text 77.696.355.299
Data Mask Key ssss s
Unmasked Text 172.88.33.861

Creating administrator profiles

To create a new administrator profile, you must be logged in to an account with sufficient privileges, or as a super user
administrator.

To create a custom administrator profile:

1. Goto System Settings > Admin > Profile.

2. Click Create New in the toolbar. The New Profile pane is displayed.

€ Dashboard New Profile

& Logging Topology

& All ADOMs

Profile Name I |

Description
© Storage Info
4
< Network 011023
o Read-Write Read-Only None
2 Admin ~ System Settings o o ®
Administrators Administrative Domain o) o ®
Device Manager o o ®
Remote Authentication Server JO— 5 o o
Admin Settings Devices/Groups
SAML S50 Log View/FortiView o o ®
@ Certificates v FortiSOC o) o ®
Local Certificates Create & Update Incidents o o ®
CACertificates Tage Event o 5 o
CRL
Exccute Playbook o) o ®
Remote Certificates
Reports ) )
Log Forwarding o (@) ®
Fetcher Management Run Report ) o ®
B Event Log FortiFabric o) o ®
(2 Task Monitor
Privacy Masking o

Ex Advanced >

FortiAnalyzer 7.2.2 Administration Guide 362
Fortinet Inc.



Administrators

3. Configure the following settings:

Profile Name Enter a name for this profile.

Description Optionally, enter a description for this profile. While not a
requirement, a description can help to know what the profiles is for,
or the levels it is set to.

Permissions Select None, Read Only, or Read-Write access for the categories
as required.
Privacy Masking Enable/disable privacy masking.
Masked Data Fields Select the fields to mask: Destination Name, Source IP,
Destination IP, User, Source Name, Email, Message, and/or
Source MAC.
Data Mask Key Enter the data masking encryption key. You need the Data Mask
Key to see the original data.
Data Unmasked Time(0- Enter the number of days the user assigned to this profile can see
365 Days) all logs without masking.

The logs are masked if the time period in the Log View toolbar is
greater than the number of days in the Data Masked Time field.

¢ Only integers between 0-365 are supported.
N : & » Time frame masking does not apply to real tim
q e logs.
- ¢ Time frame masking applies to custom view a
nd drill-down data.

4. Click OKto create the new administrator profile.

To apply a profile to an administrator:

1. Go to System Settings > Administrators.
2. Create a new administrator or edit an existing administrator. The Edit Administrator pane is displayed.
3. From the Admin Profile list, select a profile.

Creating FortiSOC administrator profiles

FortiSOC profile permissions allow security analysts to access the FortiSOC module while preventing them from making
changes to configurations that will affect the SLA.

To create an analyst profile:

Go to System Settings > Admin > Profile.

In the toolbar, click Create New.

In the Profile Name field, give the profile a distinctive name such as, Analyst.
Set FortiSOC to Read-Only.

o bd-=
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5. Setone or more of the following settings to Read-Write.

Permission Description

Create & Update Incidents Allows analysts to create and update incidents.

Triage Event Allows analysts to acknowledge, comment, view logs, create new incidents,
and add to existing incidents.

Execute Playbook Allows analysts to view and run a playbook.

Run Report Allows analysts to view, run, and export a report.

6. Configure the other settings as required, and click OK.

To apply a profile to an administrator:

1. Go to System Settings > Administrators.
2. Create a new administrator or edit an existing administrator. The Edit Administrator pane is displayed.
3. From the Admin Profile list, select a profile.

Editing administrator profiles

To edit an administrator profile, you must be logged in to an account with sufficient privileges, or as a super user
administrator. The profile's name cannot be edited. The Super_User profile cannot be edited, and the predefined profiles
cannot be deleted.

To edit an administrator:

1. Go to System Settings > Admin > Profile.

2. Double-click on a profile, right-click on a profile and then select Edit from the menu, or select the profile then click
Edit in the toolbar. The Edit Profile pane opens.

3. Edit the settings as required, and then select OK to apply the changes.

Cloning administrator profiles

To clone an administrator profile, you must be logged in to an account with sufficient privileges, or as a super user
administrator.

To edit an administrator:

1. Go to System Settings > Admin > Profile.

2. Right-click on a profile and select Clone from the menu, or select the profile then click Clone in the toolbar. The
Clone Profile pane opens.

3. Editthe settings as required, and then select OK to apply the changes.
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Deleting administrator profiles

To delete a profile or profiles, you must be logged in to an account with sufficient privileges, or as a super user
administrator. The predefined profiles cannot be deleted.

To delete a profile or profiles:

1. Goto System Settings > Admin > Profile.

2. Select the profile or profiles you need to delete.

3. Click Delete in the toolbar, or right-click and select Delete.

4. Select OKin the confirmation box to delete the profile or profiles.
Authentication

The FortiAnalyzer system supports authentication of administrators locally, remotely with RADIUS, LDAP, or TACACS+
servers, and using PKI. Remote authentication servers can also be added to authentication groups that administrators
can use for authentication.

Security Assertion Markup Language (SAML) authentication can be enabled across all Security Fabric devices, enabling
smooth movement between devices for the administrator. FortiAnalyzer can play the role of the identity provider (IdP) or
the service provider (SP) when an external identity provider is available. See SAML admin authentication on page 373.

To use PKI authentication, you must configure the authentication before you create the administrator accounts. See
Public Key Infrastructure on page 365 for more information.

To use remote authentication servers, you must configure the appropriate server entries in the FortiAnalyzer unit for
each authentication server in your network. New LDAP remote authentication servers can be added and linked to all
ADOMs or specific ADOMs. See LDAP servers on page 368, RADIUS servers on page 370, TACACS+ servers on page
371, and Remote authentication server groups on page 372 for more information.

Public Key Infrastructure

Public Key Infrastructure (PKI) authentication uses X.509 certificate authentication library that takes a list of peers, peer
groups, and user groups and returns authentication successful or denied notifications. Administrators only need a valid
X.509 certificate for successful authentication; no username or password is necessary.

To use PKI authentication for an administrator, you must configure the authentication before you create the administrator
accounts. You will also need the following certificates:

» an X.509 certificate for the FortiManager administrator (administrator certificate)

« an X.509 certificate from the Certificate Authority (CA) which has signed the administrator’s certificate (CA
Certificate)

For more information on the CSR generation process, see Local certificates on page 305.

To get the CA certificate:

1. Log into your FortiAuthenticator.
2. Go to Certificate Management > Certificate Authorities > Local CAs.
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Select the certificate and select Export in the toolbar to save the ca_fortinet.com CA certificate to your
management computer. The saved CA certificate’s filename is ca_fortinet.com.crt.

To get the administrator certificate:

Log into your FortiAuthenticator.
Go to Certificate Management > End Entities > Users.

Select the certificate and select Export in the toolbar to save the administrator certificate to your management
computer. The saved CA certificate’s filename is admin _fortinet.com.pl2. This PCKS#12 file is password
protected. You must enter a password on export.

To import the administrator certificate into your browser:

1.
2,

In Mozilla Firefox, go to Options > Advanced > Certificates > View Certificates > Import.
Select the file admin fortinet.com.pl2 and enter the password used in the previous step.

To import the CA certificate into the FortiAnalyzer:

Log into your FortiAnalyzer.
Go to System Settings > Certificates > CA Certificates.

Click Import, and browse forthe ca_fortinet.com.crt file you saved to your management computer, or drag
and drop the file onto the dialog box. The certificate is displayed as CA_Cert_1.

To create a new PKI administrator account:

N

Go to System Settings > Admin > Administrator.
Click Create New. The New Administrator dialog box opens.
See Creating administrators on page 351 for more information.

3. Select PKlfor the Admin Type.
4. Enter a commentin the Subject field for the PKI administrator.
5. Select the CA certificate from the dropdown list in the CA field.
6. Click OKto create the new administrator account.
ﬂ PKI authentication must be enabled via the FortiAnalyzer CLI with the following commands:
config system global
I set clt-cert-reqg enable
end
ﬂ When connecting to the FortiAnalyzer GUI, you must use HTTPS when using PKI certificate
I authentication.
\‘ ! 'l
q When clt-cert-reqis set to optional, the user can use certificate authentication or user
- credentials for GUI login.
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Managing remote authentication servers

The FortiAnalyzer system supports remote authentication of administrators using LDAP, RADIUS, and TACACS+
remote servers. To use this feature, you must configure the appropriate server entries for each authentication serverin
your network, see LDAP servers on page 368, RADIUS servers on page 370, and TACACS+ servers on page 371 for
more information.

Remote authentication servers can be added, edited, deleted, and added to authentication groups (CLI only).

Go to System Settings > Admin > Remote Authentication Serverto manage remote authentication servers.

4 Create New ~» [# Edit fij Delete QI
[0 & Name Type ADOM Details
[0  Actlack TACACS+ 10.10.10.15 CHAP
[0 Dapple LDAP All ADOMs 10.10.10.11:389/cn:
[  Lapper LDAP Syslog, FortiAuthenticator, FortiCache, FortiMail, FortiWWeb 10.10.10.55:38%9/cn:
1 Rader RADIUS 10.10.10.13 PAP
[0 Radium RADIUS 10.11.10.10 10.11.11.10 MSv2

The following options are available:

Create New Add an LDAP, RADIUS, or TACACS+ remote authentication server. See LDAP
servers on page 368, RADIUS servers on page 370, and TACACS+ servers on
page 371.

Edit Edit the selected remote authentication server. See Editing remote authentication

servers on page 367.

Delete Delete the selected remote authentication server or servers. See Deleting remote
authentication servers on page 368.

The following information is displayed:

Name The name of the server.

Type The server type: LDAP, RADIUS, or TACACS+.

ADOM The administrative domain(s) which are linked to the remote authentication
server.

Details Details about the server, such as the IP address.

Editing remote authentication servers

To edit a remote authentication server, you must be logged in to an account with sufficient privileges, or as a super user
administrator. The server's name cannot be edited.

To edit a remote authentication server:

1. Goto System Settings > Admin > Remote Authentication Server.

2. Double-click on a server, right-click on a server and then select Edit from the menu, or select the server then click
Editin the toolbar. The Edit Server pane for that server type opens.
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3. Editthe settings as required, and then select OK to apply the changes.
See LDAP servers on page 368, RADIUS servers on page 370, and TACACS+ servers on page 371 for more
information.

Deleting remote authentication servers

To delete a remote authentication server or servers, you must be logged in to an account with sufficient privileges, or as
a super user administrator.

To delete a remote authentication server or servers:

Go to System Settings > Admin > Remote Authentication Server.
Select the server or servers you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Select OKin the confirmation box to delete the server or servers.

o bd-=

LDAP servers

Lightweight Directory Access Protocol (LDAP) is an Internet protocol used to maintain authentication data that may
include departments, people, groups of people, passwords, email addresses, and printers. LDAP consists of a data-
representation scheme, a set of defined operations, and a request/response network.

If you have configured LDAP support and an administrator is required to authenticate using an LDAP server, the
FortiAnalyzer unit sends the administrator’s credentials to the LDAP server for authentication. If the LDAP server can
authenticate the administrator, they are successfully authenticated with the FortiAnalyzer unit. If the LDAP server cannot
authenticate the administrator, the FortiAnalyzer unit refuses the connection.

To use an LDAP server to authenticate administrators, you must configure the server before configuring the
administrator accounts that will use it.

To add an LDAP server:

1. Go to System Settings > Admin > Remote Authentication Server.
2. Select Create New > LDAP Server from the toolbar. The New LDAP Server pane opens.

New LDAP Server
Name
Server Name/IP
Port 389
Common Name Identifier cn
Distinguished Name %
Bind Type Regular
User DN
Password esssse
Secure Connection B Enable
Protocol
Certificate No Certificate
Administrative Domain Specify
Advanced Options >
FortiAnalyzer 7.2.2 Administration Guide 368

Fortinet Inc.



Administrators

Name
Server Name/IP
Port

Common Name ldentifier

Distinguished Name

Bind Type

User DN

Password
Secure Connection

Protocol

Certificate

Administrative Domain

Advanced Options
adom-attr
attributes
connect-timeout
filter
group

memberof-attr

profile-attr
secondary-server

tertiary-server
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3. Configure the following settings, and then click OK to add the LDAP server.

Enter a name to identify the LDAP server.
Enter the IP address or fully qualified domain name of the LDAP server.

Enter the port for LDAP traffic. The default port is 389.

The common name identifier for the LDAP server. Most LDAP servers use cn.

However, some servers use other common name identifiers such as UID.

The distinguished name is used to look up entries on the LDAP server.

The distinguished name reflects the hierarchy of LDAP database object
classes above the common name identifier. Clicking the query distinguished
name icon will query the LDAP server for the name and open the LDAP
Distinguished Name Query window to display the results.

Select the type of binding for LDAP authentication: Simple, Anonymous, or
Regular.

When the Bind Type is set to Regular, enter the user DN.

When the Bind Type is set to Regular, enter the password.

Select to use a secure LDAP server connection for authentication.

When Secure Connection is enabled, select either LDAPS or STARTTLS.

When Secure Connection is enabled, select the certificate from the dropdown
list.

Choose the ADOM s that this server will be linked to for reporting: All ADOMs
(default), or Specify for specific ADOMs.

Specify an attribute for the ADOM.

Specify the attributes such as member, uniquemember, or memberuid.
Specify the connection timeout in millisecond.

Specify the filter in the format (cbjectclass=*)

Specify the name of the LDAP group.

Specify the value for this attribute. This value must match the attribute of the
group in LDAP Server. All users part of the LDAP group with the attribute
matching the memberof-attr will inherit the administrative permissions
specified for this group.

Specify the attribute for this profile.
Specify a secondary server.

Specify a tertiary server.
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RADIUS servers

Remote Authentication Dial-in User (RADIUS) is a user authentication and network-usage accounting system. When
users connect to a server they type a user name and password. This information is passed to a RADIUS server, which
authenticates the user and authorizes access to the network.

You can create or edit RADIUS server entries in the server list to support authentication of administrators. When an
administrator account’s type is set to RADIUS, the FortiAnalyzer unit uses the RADIUS server to verify the administrator
password at log on. The password is not stored on the FortiAnalyzer unit.

To use a RADIUS server to authenticate administrators, you must configure the server before configuring the

administrator accounts that will use it.

To add a RADIUS server:

1. Go to System Settings > Admin > Remote Authentication Server.
2. Select Create New > RADIUS Server from the toolbar. The New RADIUS Server pane opens.

Name

Server Name/IP 10.2.0.159
Port 1812
Server Secret ssssssns

Connection Status Successful

Test Connectivity Test User Credentials

Secondary Server Name/IP

Secondary Server Secret ssssssne

Test Connectivity

Authentication Type ANY

Advanced Options >

I

Test User Credentials

3. Configure the following settings, and then click OK to add the RADIUS server.

Name
Server Name/IP

Port

Server Secret

Test Connectivity

Test User Credentials
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Enter a name to identify the RADIUS server.
Enter the IP address or fully qualified domain name of the RADIUS server.

Enter the port for RADIUS traffic. The default portis 1812. Some RADIUS
servers use port 1645.

Enter the RADIUS server secret. Click the eye icon to Show or Hide the server
secret.

Click Test Connectivity to test the connectivity with the RADIUS server. Shows
success or failure.

Click Test User Credentials to test the user credentials. Shows success or
failure.
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Secondary Server Name/IP Enter the IP address or fully qualified domain name of the secondary RADIUS
server.

Secondary Server Secret Enter the secondary RADIUS server secret.

Authentication Type Select the authentication type the RADIUS server requires. If you select the

default ANY, FortiAnalyzer tries all authentication types.
Advanced Options
nas-ip Specify the IP address for the Network Attached Storage (NAS).

TACACS+ servers

Terminal Access Controller Access-Control System (TACACS+) is a remote authentication protocol that provides
access control for routers, network access servers, and other network computing devices via one or more centralized
servers. It allows a client to accept a user name and password and send a query to a TACACS authentication server.
The server host determines whether to accept or deny the request and sends a response back that allows or denies
network access to the user. The default TCP port fora TACACS+ server is 49.

If you have configured TACACS+ support and an administrator is required to authenticate using a TACACS+ server, the
FortiAnalyzer unit contacts the TACACS+ server for authentication. If the TACACS+ server can authenticate the
administrator, they are successfully authenticated with the FortiAnalyzer unit. If the TACACS+ server cannot
authenticate the administrator, the connection is refused by the FortiAnalyzer unit.

To use a TACACS+ server to authenticate administrators, you must configure the server before configuring the
administrator accounts that will use it.

To add a TACACS+ server:

1. Go to System Settings > Admin > Remote Authentication Server.
2. Select Create New > TACACS+ Server from the toolbar. The New TACACS+ Server pane opens.
New TACACS+ Server

Name

Server Name/IP

Port 49
Server Key

Authentication Type

3. Configure the following settings, and then click OK to add the TACACS+ server.

Name Enter a name to identify the TACACS+ server.

Server Name/IP Enter the IP address or fully qualified domain name of the TACACS+ server.
Port Enter the port for TACACS+ traffic. The default port is 49.

Server Key Enter the key to access the TACACS+ server. The server key can be a

maximum of 16 characters in length.

Authentication Type Select the authentication type the TACACS+ server requires. If you select the
default ANY, FortiAnalyzer tries all authentication types.
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Remote authentication server groups

Remote authentication server groups can be used to extend wildcard administrator access. Normally, a wildcard
administrator can only be created for a single server. If multiple servers of different types are grouped, a wildcard

administrator can be applied to all of the servers in the group.

Multiple servers of the same type can be grouped to act as backups - if one server fails, the administrator can still be

authenticated by another server in the group.

To use a server group to authenticate administrators, you must configure the group before configuring the administrator

accounts that will use it.

Remote authentication server groups can only be managed using the CLI. For more information, see the FortiAnalyzer

CLI Reference.

To create a new remote authentication server group:

1.

Open the admin group command shell:
config system admin group

Create a new group, or edit an already create group:
edit <group name>

Add remote authentication servers to the group:
set member <server name> <server name> ...

Apply your changes:

end

To edit the servers in a group:

1.

Enter the following CLI commands:
config system admin group
edit <group name>

set member <server name> <server name> ...

end
Only the servers listed in the command will be in the group.

To remove all the servers from the group:

1.

Enter the following CLI commands:
config system admin group
edit <group name>
unset member
end

All of the servers in the group will be removed.

To delete a group:

1.

Enter the following CLI commands:

config system admin group
delete <group name>

end
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SAML admin authentication

SAML can be enabled across devices, enabling smooth movement between devices for the administrator. FortiAnalyzer
can play the role of the identity provider (IdP) or the service provider (SP) when an external identity provider is available.

When FortiGate is acting as the IdP in a Security Fabric, FortiAnalyzer can be configured to automatically connect as a
Fabric SP, allowing for easy setup of SAML authentication. See Enabling SAML authentication in a Security Fabric on
page 132.

Devices configured to the IdP can be accessed through the Quick Access menu which appears in the top-right corner of
the main menu. The current device is indicated with an asterisk (currently only supported between FAZ/FMG).

Logging into an SP device will redirect you to the IdP login page. By default, it is a Fortinet login page. After successful
authentication, you can access other SP devices from within the same browser without additional authentication.

When FortiAnalyzer is registered to FortiCloud, you can enable Allow admins to login with FortiCloud. This feature allows
administrators to log in to FortiAnalyzer using their FortiCloud SSO account credentials. See FortiCloud SSO admin
authentication on page 375.

The admin user must be created on both the IdP and SP, otherwise you will see an error
M, message stating that the admin doesn't exist.
q Alternatively, you can configure the ADOM and profile names in the SP to match the IdP.
= When this is done, you can create one SAML SSO wildcard admin user on the SP to match all
users on the IdP server.

When accessing FortiGate from the Quick Access menu, if FGT is set up to use the default
login page with SSO options, you must select the via Single Sign-On button to be

automatically authenticated.

To configure FortiAnalyzer as the identity provider:

Go to System Settings > Admin > SAML SSO.

Select Identity Provider (IdP).

In the IdP Certificate dropdown, choose a certificate where IdP is used.
Select Download to get the IdP certificate, used later to configure SPs.

(Optional) A custom login page can be created by moving the Login Page Template toggle to the On position and
selecting Customize.

o obd-=

6. Inthe SP Settings table, select Create New to add a service provider.
7. Inthe Edit Service Provider window, configure the following information:
Name Enter a name for the service provider.
IdP Prefix Copy the IdP prefix. This will be required when configuring your service
providers.
SP Type Select Fortinet as the SP Type.
If the SP is not a Fortinet product, select Custom as the SP Type and copy the
SP Entity ID, SP ACS (Login) URL, and SP SLS (Logout) URL from your SPs
configuration page.
FortiAnalyzer 7.2.2 Administration Guide 373

Fortinet Inc.



Administrators

SP Address Enter the IP address of the service provider.

SAML Attributes SAML attributes can be added to a service provider to specify ADOM and/or
profile names.
FortiAnalyzer acting as IdP supports the following SAML attributes:
e Type: Username, Attribute: username
¢ Type: Profile Name, Attribute: profilename
e Type: ADOM, Attribute: adoms

SAML SSO Wildcard users

As long as the SP has the same user profile and ADOM
names as the IdP, you do not need to re-create each user
M/, fromthe IdP on the SP. Instead, you can create one SAML
9 SSO wildcard admin user on the SP with the Match all users
- on remote server setting enabled to match all users on the
IdP server. When logging in as an SSO user on the SP, the
user is assigned the same profile and ADOMs as are
configured on the IdP. See Creating administrators on page
351.

8. Select OKto save changes to the service provider.
9. Click Apply to save the |dP configuration.

To configure FortiAnalyzer as a service provider:

1. Go to System Settings > Admin > SAML SSO.

2. Select Service Provider (SP).

3. Select Fortinet as the IdP Type.

4. Enterthe IdP IP address and the IdP prefix that you obtained while configuring the IdP device.

5. Select the IdP certificate.
If this is a first-time set up, you can import the IdP certificate that you downloaded while configuring the IdP device.

6. Confirm that the information is correct and select Apply.
7. Repeat the steps for each FAZ/FMG that is to be set as a service provider.

For information on configuring FortiAnalyzer as an SP in a Security Fabric, see: Enabling SAML authentication in a
Security Fabric on page 132.

Supported SAML attribute overrides

The following SAML attributes are accepted by FortiAnalyzer SAML service provider.

SAML Attribute Description

username The username of the local/SSO user. This attribute is mandatory.

Example:
<Attribute Name="username">
<AttributeValue>userl</AttributeValue>
</Attribute>
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SAML Attribute Description

profilename The Profile assigned to the user. If a matching profile exists on the FortiAnalyzer, it will be
assigned to the user. This attribute is optional.

Example:
<Attribute Name="profilename">
<AttributeValue>SSOPROFILE</AttributeValue>
</Attribute>

adoms The ADOM(s) to which the user will have access. Multiple ADOMs can be specified in the
SAML assertion if supported by the IdP. This attribute is optional.

Example:
<Attribute Name="adoms">
<AttributeValue>ADOM1</AttributeValue>
<AttributeValue>ADOM2</AttributeValue>
</Attribute>

You can use the following command in the CLI to verify the correct adoption of the SAML attributes by FortiAnalyzer.

diagnose system admin-session list

For example:

diagnose system admin-session list
*x*k% entry 0 ***
session _id: 57410 (seq: 0)
username: userl
admin template: SSO
from: SSO(192.168.50.188) (type 7)
profile: SSOPROFILE
adom: adoml
session length: 3 (seconds)

FortiCloud SSO admin authentication

When FortiAnalyzer is registered to FortiCloud, you can enable login to FortiAnalyzer using your FortiCloud
SSO account.

By default, only the FortiCloud account ID which the FortiAnalyzer is registered to can be used to log into FortiAnalyzer.

Additional SSO users can be configured as IAM users in FortiCloud. See IAM user account login on page 376.

To enable login with FortiCloud:

1. Before enabling this feature, FortiAnalyzer must be registered to FortiCloud, and a FortiCloud account must be
configured.
You can check your FortiCloud registration status in System Settings > Dashboard in the License Information
widget.

2. Goto System Settings > Admin > SAML SSO, and enable Allow admins to login with FortiCloud.

Single Sign-On Settings

Server Address 192.168.50.249

Allow admins to login with m

FortiCloud @

Single Sign-On Mode \dentity Provider (IdP)  Service Provider (SP) Fabric SP
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3. Sign out of FortiAnalyzer to return to the sign in screen.
An option to Login with FortiCloud is now visible on the FortiAnalyzer login page.

FortiAnalyzer-VMé4

FortiCloud Login with FortiCloud

4. Click Login with FortiCloud. Enter your login credentials from FortiCloud and click LOGIN.

Email Login
Al fields are case-sensitive
Welcome Back! Forgot Email? F orgot Password?
T
LOG IN

Y| IAM Login

You are signed in with your FortiCloud user account.

IAM user account login

FortiCloud supports the creation of additional users called IAM users. Once created, you can use the IAM user account
to sign in to FortiAnalyzer.

To sign in using a FortiCloud IAM user:

1. InFortiCloud, create one or more additional IAM user accounts. See Identity and Access Management (IAM).
2. Enable Allow admins to login with FortiCloud in System Settings > SAML SSO.
3. Sign out of FortiAnalyzer, return to the FortiAnalyzer sign on page, and click Login with FortiCloud.
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4,

5.

At the bottom of the FortiCloud login portal, click Sign in as IAM user.

AN
FortiCloud

Account ID / Alias
Username

Password

LOGIN

Sign in using email Forgot password?

Learn more about FortiCloud  Privacy  Terms

Enter your IAM user credentials.
You are signed in using your FortiCloud IAM account.

Global administration settings

The administration settings page provides options for configuring global settings for administrator access to the
FortiAnalyzer device. Settings include:

Ports for HTTPS and HTTP administrative access

To improve security, you can change the default port configurations for administrative connections to the
FortiAnalyzer. When connecting to the FortiAnalyzer unit when the port has changed, the port must be included,
suchashttps://<ip address>:<port>. Forexample, if you are connecting to the FortiAnalyzer unit using
port 8080, the URL would be https://192.168.1.99:8080. When you change to the default port number for
HTTP, HTTPS, or SSH, ensure that the port number is unique.

Idle timeout settings

By default, the GUI disconnects administrative sessions if no activity occurs for five minutes. This prevents
someone from using the GUI if the management computer is left unattended.

GUI language

The language the GUI uses. For best results, you should select the language used by the management computer.
GUI theme

The default color theme of the GUI is Blueberry. You can choose another color or an image.

Password policy

Enforce password policies for administrators.

Ay
‘Q' Only super user administrators can access and configure the administration settings. The
- settings are global and apply to all administrators of the FortiAnalyzer unit.
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To configure the administration settings:
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1. Go to System Settings > Admin > Admin Settings.
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Admin Settings

Administration Settings

HTTP Port

HTTPS Port

HTTPS & Web Service
Certificate

Idle Timeout

Idle Timeout (API)
Idle Timeout (GUI)
View Settings
Language

High Contrast Theme
Other Themes

Password Policy

Fabric Authorization @

Authorization Address

Authorization Port
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2. Configure the following settings as needed, then click Apply to save your changes to all administrator accounts:

Administration Settings

HTTP Port

HTTPS Port

HTTPS & Web
Service Server
Certificate

Idle Timeout

Idle Timeout (API)

Idle Timeout (GUI)

View Settings

Language

High Contrast
Theme

Other Themes

Password Policy

Minimum Length
Must Contain

Admin Password
Expires after

Fabric Authorization

FortiAnalyzer 7.2.2 Administration Guide
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Enter the TCP port to be used for administrative HTTP access. Default: 80.
Select Redirect to HTTPS to redirect HTTP traffic to HTTPS.

Enter the TCP port to be used for administrative HTTPS access. Default: 443.

Select a certificate from the dropdown list.

Enter the number of seconds an administrative connection can be idle before
the administrator must log in again, from 60 to 28800 (eight hours). See Idle
timeout on page 383 for more information.

Enter the number of seconds an administrative connection to the API can be
idle before the administrator must log in again, from 1 to 28800 (eight hours).
Default: 900.

Enter the number of seconds an administrative connection to the GUI can be
idle before the administrator must log in again, from 60 to 28800 (eight hours).
Default: 900.

Select a language from the dropdown list. See GUI language on page 383 for
more information.

Toggle ON to enable a high contrast dark theme in order to make the
FortiAnalyzer GUI more accessible, and to aid people with visual disability in
using the FortiAnalyzer GUI.

Select a theme for the GUI. The selected theme is not applied until you click
Apply, allowing to you to sample different themes. Default: Blueberry.

Click to enable administrator password policies. See Password policy on page
382 and Password lockout and retry attempts on page 382 for more
information.

Select the minimum length for a password, from 8 to 32 characters. Default: 8.
Select the types of characters a password must contain.

Select the number of days a password is valid for, after which it must be
changed.

Specifies the accessible management IP of FortiAnalyzer for FortiOS to
retrieve and use for authorization of a Security Fabric connection to
FortiAnalyzer.

When you are using FortiOS to create a Security Fabric connection to
FortiAnalyzer, a browser pop window is displayed and connects to
FortiAnalyzer as part of the authorization process. FortiOS retrieves the
information specified in FortiAnalyzer and provides it to the browser popup
window to successfully connect to FortiAnalyzer.
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Without this information, the browser popup window cannot connect to
FortiAnalyzer in certain topologies, such as when NAT is used.

See also Security Fabric authorization information for FortiOS on page 384.

Authorization Type the accessible management IP for FortiAnalyzer.
Address

Authorization Port  If a non-default port is used for the management port of FortiAnalyzer, specify
the custom port.

Password policy
You can enable and configure password policy for the FortiAnalyzer.

To configure the password policy:

1. Go to System Settings > Admin > Admin Settings.
2. Click to enable Password Policy.
3. Configure the following settings, then click Apply to apply to password policy.

Minimum Length Specify the minimum number of characters that a password must be, from 8 to 32.
Default: 8.

Must Contain Specify the types of characters a password must contain: uppercase and lowercase
letters, numbers, and/or special characters.

Admin Password Specify the number of days a password is valid for. When the time expires, an
Expires after administrator will be prompted to enter a new password.

Password lockout and retry attempts

By default, the number password retry attempts is set to three, allowing the administrator a maximum of three attempts
atlogging in to their account before they are locked out for a set amount of time (by default, 60 seconds).

The number of attempts and the default wait time before the administrator can try to enter a password again can be
customized. Both settings can be configured using the CLI.

To configure the lockout duration:

1. Enter the following CLI commands:
config system global
set admin-lockout-duration <seconds>
end

To configure the number of retry attempts:

1. Enter the following CLI commands:
config system global
set admin-lockout-threshold <failed attempts>
end
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Example

To set the lockout threshold to one attempt and set a five minute duration before the administrator can try to log in again,

enter the following CLI commands:

config system global

set admin-lockout-duration 300
set admin-lockout-threshold 1

end

GUI language

The GUI supports multiple languages, including:

By default, the GUI language is set to Auto Detect, which automatically uses the language used by the management

English

Simplified Chinese
Traditional Chinese
Japanese

Korean

Spanish

French

computer. If that language is not supported, the GUI defaults to English. For best results, you should select the language

used by the operating system on the management computer.

For more information about language support, see the FortiAnalyzer Release Notes.

To change the GUI language:

1.

Go to System Settings > Admin > Admin Settings.
2. Under the View Settings, in the Language field, select a language, or Auto Detect, from the dropdown list.

3. Click Apply to apply the language change.

Idle timeout

To ensure security, the idle timeout period should be short. By default, administrative sessions are disconnected if no
activity takes place for 900 seconds (15 minutes). This idle timeout is recommended to prevent anyone from using the
GUIl on a PC that was logged in to the GUI and then left unattended.

To change the idle timeout:

1.

Go to System Settings > Admin > Admin Settings.

2. Change the Idle Timeout period as required.
3. Click Apply.
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Security Fabric authorization information for FortiOS

When using FortiOS to create a Security Fabric connection to FortiAnalyzer, the process includes device authorization.
The authorization process uses a browser popup window that requires communication to FortiAnalyzer. Depending on
the topology, communication might fail, unless you specify the accessible management IP address and/or port of
FortiAnalyzer that the browser popup window in FortiOS can use to connect with FortiAnalyzer.

FortiOS retrieves this information from FortiAnalyzer and makes it available to the browser popup window used for the
authorization process.

To specify the authorization address and/or port:

1. InFortiAnalyzer, go to System Settings > Admin > Admin Settings.
2. Under Fabric Authorization, set the following options:

Authorization Address Type the GUl-accessible URL for FortiAnalyzer.
Authorization Port If a non-default port is used, type the port number used for GUI access to
FortiAnalyzer.
3. Click Apply.

Control administrative access with a local-in policy

Administrative access to FortiAnalyzer can be controlled by a IPv4/IPv6 local-in policy. This feature can only be
configured using the FortiAnalyzer CLI.

For more information, see the FortiAnalyzer CLI Reference Guide on the Fortinet Docs Library.

To create an IPv4 local-in policy to control administrator access to FortiAnalyzer:

1. Access the FortiAnalyzer CLI.

2. Enter the following command to create the IPv4 local-in policy:
config system local-in-policy
(local-in-policy) # edit <policy ID>
new entry '<Policy ID>' added
3. Configure additional settings for the local-in policy using the set command.
For example:
set
action Action performed on traffic matching this policy.
dport Destination port number (0 for all).
dst Destination IP and mask.
intf Incoming interface name.
protocal Traffic protocal.
src Source IP and mask.

To create an IPv6 local-in policy to control administrator access to FortiAnalyzer:

1. Access the FortiAnalyzer CLI.

2. Enter the following command to create the IPv6 local-in policy:
config system local-in-policy6
(local-in-policy6)# edit <policy ID>
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new entry '<Policy ID>' added
3. Configure additional settings for the local-in policy using the set command.

For example:
set

action Action performed on traffic matching this policy.
dport Destination port number (0 for all).

dst Destination IP and mask.

intf Incoming interface name.

protocal Traffic protocal.

src Source IP and mask.

Two-factor authentication

FortiAnalyzer supports the following two methods for two-factor authentication:

o FortiAuthenticator
e FortiToken Cloud

Two-factor authentication with FortiAuthenticator

To configure two-factor authentication for administrators with FortiAuthenticator you will need the following:

« FortiAnalyzer
o FortiAuthenticator
e FortiToken

Configuring FortiAuthenticator

On the FortiAuthenticator, you must create a local user and a RADIUS client.

Before proceeding, ensure you have configured your FortiAuthenticator, created a NAS entry
ﬂ for your FortiAnalyzer, and created or imported FortiTokens.
I For more information, see the RADIUS Interoperability Guide and FortiAuthenticator
Administration Guide in the Fortinet Document Library.

To create a local user:

1. Go to Authentication > User Management > Local Users.

2. Click Create New in the toolbar.
3. Configure the following settings:

Username
Password creation
Password

Password confirmation

FortiAnalyzer 7.2.2 Administration Guide
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Enter a user name for the local user.
Select Specify a password from the dropdown list.
Enter a password. The password must be a minimum of 8 characters.

Re-enter the password. The passwords must match.
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Allow RADIUS authentication
Role

Enable account expiration

Enable to allow RADIUS authentication.
Select the role for the new user.

Optionally, select to enable account expiration. For more information see the
FortiAuthenticator Administration Guide.

4. Click OKto continue to the Change local user page.

Change local user

© Successfully added local user “pifry". You may editit again below.

Username: Pifry.
[ Disabled

Password-based authentication — (Change Password
[ Token-ba ntication

[] Allow RADIUS autnentication

Role: @ Administrator
QUser

[ Full permission

5. Configure the following settings, then click OK.

Disabled

Password-based
authentication

Token-based authentication

Deliver token code
by

Allow RADIUS authentication

Enable account expiration

User Role
Role

Full Permission

Web service

Restrict admin
login from trusted
management
subnets only

Allow LDAP
Browsing

FortiAnalyzer 7.2.2 Administration Guide
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Select to disable the local user.

Leave this option selected. Select [Change Password]to change the
password for this local user.

Select to enable token-based authentication.

Select to deliver token by FortiToken, email, or SMS.
Click Test Token to test the token.

Select to allow RADIUS authentication.

Optionally, select to enable account expiration. For more information see the
FortiAuthenticator Administration Guide.

Select either Administrator or User.

Select to allow Full Permission, otherwise select the admin profiles to apply to
the user. This option is only available when Role is Administrator.

Select to allow Web service, which allows the administrator to access the web
service via a REST API or by using a client application. This option is only
available when Role is Administrator.

Select to restrict admin login from trusted management subnets only, then
enter the trusted subnets in the table. This option is only available when Role
is Administrator.

Select to allow LDAP browsing. This option is only available when Role is
User.
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Create a RADIUS client:

1.
2. Click Create New in the toolbar.

Go to Authentication > RADIUS Service > Clients.

3. Configure the following settings, then click OK.

Name

Client name/IP

Secret

First profile name
Description

Apply this profile based on
RADIUS attributes

Authentication method
Username input format
Realms

Allow MAC-based
authentication

Check machine
authentication

Enable captive portal

Enter a name for the RADIUS client entry.

Enter the IP address or Fully Qualified Domain Name (FQDN) of the
FortiAnalyzer.

Enter the server secret. This value must match the FortiAnalyzer RADIUS
server setting at System Settings > Admin > Remote Authentication Server.

See the FortiAuthenticator Administration Guide.
Enter an optional description for the RADIUS client entry.

Select to apply the profile based on RADIUS attributes.

Select Enforce two-factor authentication from the list of options.
Select specific user name input formats.
Configure realms.

Optional configuration.

Select to check machine based authentication and apply groups based on the
success or failure of the authentication.

Enable various portals.

EAP types Optional configuration.
\‘ ! 'l
q For more information, see the FortiAuthenticator Administration Guide, available in the
- Fortinet Document Library.

Configuring FortiAnalyzer

On the FortiAnalyzer, you need to configure the RADIUS server and create an administrator that uses the RADIUS
server for authentication.

To configure the RADIUS server:

1.

FortiAnalyzer 7.2.2 Administration Guide

Go to System Settings > Admin > Remote Authentication Server.
2. Click Create New > RADIUS Serverin the toolbar.
3. Configure the following settings, then click OK.

Name

Fortinet Inc.

Enter a name to identify the FortiAuthenticator.
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Server Name/IP Enter the IP address or fully qualified domain name of your FortiAuthenticator.

Port Enter the port for FortiAuthenticator traffic.

Server Secret Enter the FortiAuthenticator secret.

Secondary Server Name/IP Enter the IP address or fully qualified domain name of the secondary
FortiAuthenticator, if applicable.

Secondary Server Secret Enter the secondary FortiAuthenticator secret, if applicable.

Authentication Type Select the authentication type the FortiAuthenticator requires. If you select the

default ANY, FortiAnalyzer tries all authentication types.

Note: RADIUS server authentication for local administrator users stored in
FortiAuthenticator requires the PAP authentication type.

To create the administrator:

—

Go to System Settings > Admin > Administrator.
Click Create New from the toolbar.

3. Configure the settings, selecting the previously added RADIUS server from the RADIUS Server dropdown list. See
Creating administrators on page 351.

4. Click OKto save the settings.

g

To test the configuration:

1. Attemptto log in to the FortiAnalyzer GUI with your new credentials.
2. Enteryour user name and password and click Login.
3. Enter your FortiToken pin code and click Submit to log in to the FortiAnalyzer.

Two-factor authentication with FortiToken Cloud

To use two-factor authentication with FortiToken Cloud, you must have an active FortiToken Cloud license registered on
FortiCloud. For more information about this process, see the FortiToken Cloud Admin Guide.

To configure two-factor authentication for administrators with FortiToken Cloud:

1. InFortiAnalyzer, go to System Settings > Admin > Administrators and click Create New or edit an existing
administrator.

2. Inthe FortiToken Cloud field, select the token delivery method from the following options:

» FortiToken Mobile: Use the FortiToken Mobile app to get tokens. The administrator is sent an email with a link
to activate their token in the FortiToken Mobile app on their mobile device.

» Email: Receive the token by email.
» SMS: Receive the token by SMS message.
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Create New Administrator

User Name

Avatar

Description

Admin Type

New Password
Confirm Password
FortiToken Cloud
Emiil

Country Dial Code

Mobile Number

Administrative Domain

Admin Profile
JSON APl Access
Theme Mode

Trusted Hosts

Meta Fields »

Advanced Options >

test

T | 4 AddPhoto

= Remove Photo

LOCAL

Disable | FortiToken Mobile | Email [N

test@fortinet.com

=5 United States Canada

| 1234567890

All ADOMs All ADOMs except specified ones Specify
Restricted_User

Mone

Use Global Theme Use Own Theme

(s |

3. Enter the appropriate contact information.
4. Edit other fields as needed and click OK.

When the administrator logs in, they are prompted to enter the token code from their email, SMS, or FortiToken
Mobile.

Please input FortiToken code:

test

Token C

ode

Login
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High Availability

A FortiAnalyzer high availability (HA) cluster provides the following features:

» Provide real-time redundancy in case a FortiAnalyzer primary unit fails. If the primary unit fails, another unit in the
cluster is selected as the primary unit. See If the primary unit fails on page 394.

« Synchronize logs and data securely among multiple FortiAnalyzer units. Some system and configuration settings
are also synchronized. See Configuration synchronization on page 393.

« Alleviate the load on the primary unit by using secondary (backup) units for processes such as running reports.

A FortiAnalyzer HA cluster can have a maximum of four units: one primary unit with up to three secondary units. All units
in the cluster must be of the same FortiAnalyzer series. All units are visible on the network.

All units must run in the same operation mode: Analyzer or Collector.

When devices with different licenses are used to create an HA cluster, the license that allows
for the smallest number of managed devices is used.
/- ™
port2: port2:
10.10.10.1/24 Peer Network 10.10.10.2/24 [~
FortiAnalyzer HA Primary Unit FortiAnalyzer HA Secondary Unit
‘ Cluster Virtual IP ‘
via VRRP
172.nn.nn.nnn/24
port1: port1:
172.nn.nn.nnn/24 Cluster Network: 172.nn.nn.n/24 172.nn.nn.nnn/24

Configuring HA options

To configure HA options go to System Settings > HA and configure FortiAnalyzer units to create an HA cluster or change
cluster configuration.

In System Settings > HA, use the Cluster Settings pane to create or change HA configuration, and use the Cluster Status
pane to monitor HA status.

To configure a cluster, set the Operation Mode of the primary unit to High Availability. Then add the IP addresses and
serial numbers of each secondary unit to the primary unit peer list. The IP address and serial number of the primary unit
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and all secondary units must be added to each secondary unit's HA configuration. The primary unit and all secondary
units must have the same Group Name, Group ID and Password.

You can connect to the primary unit GUI to work with FortiAnalyzer. Using configuration synchronization, you can
configure and work with the cluster in the same way as you work with a standalone FortiAnalyzer unit.

Peer SN

+ B

:|| (255

Cluster Settings
Operation Mode Standalone
Preferred Role Primary
Secondary
Cluster Virtual IP
Interface
IP Address
Cluster Settings
Peer IP and Peer SN Peer IP
Click here to add a peer.
Group Name
Group ID 4]
Password ssssssee
Heart Beat Interval 1
Failover Threshold
Priority 100
Log Data Sync m

Configure the following settings:

Cluster Status

Operation Mode

Preferred Role

Cluster Virtual IP
Interface
IP Address
Cluster Settings
Peer IP
Peer SN

Group Name
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4 (80-120)

Select High Availability to configure the FortiAnalyzer unit for HA.
Select Standalone to stop operating in HA mode.

Select the preferred role when this unit first joins the HA cluster.

If the preferred role is Primary, then this unit becomes the primary unit if it is
configured first in a new HA cluster. If there is an existing primary unit, then this
unit becomes a secondary unit.

The default is Secondary so that the unit can synchronize with the primary unit. A
secondary unit cannot become a primary unit until it is synchronized with the
current primary unit.

The interface the FortiAnalyzer HA unit uses to provide redundancy.

The IP address for which the FortiAnalyzer HA unit is to provide redundancy.

Type the IP address of another FortiAnalyzer unit in the cluster.

Type the serial number of the FortiAnalyzer unit corresponding to the entered IP
address.

Type a group name that uniquely identifies the FortiAnalyzer HA cluster. All units
in a cluster must have the same Group Name, Group ID and Password.
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Group ID Type a group ID from 1 to 255 that uniquely identifies the FortiAnalyzer
HA cluster.

Password A password for the HA cluster. All members of the HA cluster must have the same
password.

Heart Beat Interval  The time the primary unit waits between sending heartbeat packets, in seconds.
The heartbeat interval is also the amount of time that secondary units waits before
expecting to receive a heartbeat packet from the primary unit.

By default, the Heart Beat Interval is set to 1.
Failover Threshold  The number of seconds that one of the cluster units waits to receive HA heartbeat
packets from other cluster units before assuming that the other cluster units have

failed. This value corresponds to Heart Beat Interval x 3 and it is automatically
updated based on the configured Heart Beat Interval.

For example, the failure is detected after 12 seconds with the default settings:
* Heart Beat Interval: 4

e Failover Threshold: 12

The Heart Beat Interval can be increased or decreased to adapt to latency
conditions of your network and to detect legitimate failures.

Priority The priority or seniority of the secondary unit in the cluster.

Log Data Sync This option is on by default. It provides real-time log synchronization among
cluster members.

Log synchronization

To ensure logs are synchronized among all HA units, FortiAnalyzer HA synchronizes logs in two states: initial logs
synchronization and real-time log synchronization.

Initial Logs Sync

When you add a unit to an HA cluster, the primary unit synchronizes its logs with the new unit. After initial sync is
complete, the secondary unit automatically reboots. After the reboot, the secondary unit rebuilds its log database with
the synchronized logs.

You can see the status in the Cluster Status pane Initial Logs Sync column.

Log Data Sync

After the initial log synchronization, the HA cluster goes into real-time log synchronization state.
Log Data Sync is turned on by default for all units in the HA cluster.

When Log Data Sync is turned on in the primary unit, the primary unit forwards logs in real-time to all secondary units.
This ensures that the logs in the primary and secondary units are synchronized.

Log Data Sync is turned on by default in secondary units so that if the primary unit fails, the secondary unit selected to be
the new primary unit will continue to synchronize logs with secondary units.
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If you want to use a FortiAnalyzer unit as a standby unit (not as a secondary unit), then you don't need real-time log
synchronization so you can turn off Log Data Sync.

Configuration synchronization

Configuration synchronization provides redundancy and load balancing among the cluster units. A FortiAnalyzer HA
cluster synchronizes the configuration of the following modules to all cluster units:

+ Device Manager

« Incidents & Events

» Reports

o Most System Settings

FortiAnalyzer HA synchronizes most System Settings in the HA cluster. The following table shows which System Setting
configurations are synchronized:

System Setting Configuration synchronized

Dashboard > System Information Only Administrative Domain is synchronized. All other settings in the
System Information widget are not synchronized.

All ADOMs Yes
Storage Info Yes
Network No

HA No

Admin Yes
Certificates > Local Certificates No

Certificates > CA Certificates Yes
Certificates > CRL Yes
Log Forwarding Yes
Fetcher Management Yes
Event Log No

Task Monitor Yes
Advanced > SNMP Yes
Advanced > Mail Server Yes
Advanced > Syslog Server Yes
Advanced > Meta Fields Yes
Advanced > Device Log Settings Yes
Advanced > File Management Yes
Advanced > Advanced Settings Yes
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Monitoring HA status

In System Settings > HA, the Cluster Status pane shows the HA status. This pane displays information about the role of
each cluster unit, the HA status of the cluster, and the HA configuration of the cluster.

Ay
‘?' You can use the CLI command diagnose ha status to display the same HA status
- information.

The Cluster Status pane displays the following information:

Role Role of each cluster member.

Serial Number Serial number of each cluster member.

IP IP address of each cluster members including the host.
Host Name Host name of the HA cluster.

Uptime/Downtime Uptime or downtime of each cluster member.

Initial Logs Sync Status of the initial logs synchronization.
Configuration Sync Status of synchronizing configuration data.

Message Status or error messages, if any.

If the primary unit fails

If the primary unit becomes unavailable, another unit in the cluster is selected as the primary unit using the following
rules:

« All cluster units are assigned a priority from 80 — 120. The default priority is 100. If the primary unit becomes
unavailable, an available unit with the highest priority is selected as the new primary unit. For example, a unit with a
priority of 110 is selected over a unit with a priority of 100.

« If multiple units have the same priority, the unit whose primary IP address has the greatest value is selected as the
new primary unit. For example, 123.45.67.124 is selected over 123.45.67.123.

« If a new unit with a higher priority or a greater value IP address joins the cluster, the new unit does not replace (or
preempt) the current primary unit.

Load balancing

Because FortiAnalyzer HA synchronizes logs among HA units, the HA cluster can balance the load and improve overall
responsiveness. Load balancing enhances the following modules:

* Reports
o FortiView
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When generating multiple reports, the loads are distributed to all HA cluster units in a round-robin fashion. When a report
is generated, the report is synchronized with other units so that the report is visible on all HA units.

Similarly, for FortiView, cluster units share some of the load when these modules generate output for their widgets.

Upgrading the FortiAnalyzer firmware for an operating cluster

For information on upgrading the FortiAnalyzer firmware for an operating cluster, see the FortiAnalyzer Upgrade Guide
on the Fortinet Docs Library.
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Collectors and Analyzers

This topic describes how to configure two FortiAnalyzer units as the Analyzer and Collector and make them work
together. In the scenario shown in the diagram below, Company A has a remote branch network with a FortiGate unit
and a FortiAnalyzer 400E in Collector mode. In its head office, Company A has another FortiGate unitand a
FortiAnalyzer 3000D in Analyzer mode. The Collector forwards the logs of the FortiGate unit in the remote branch to the
Analyzer in the head office for data analysis and reports generation. The Collector is also used for log archival.

Remote Branch Office Head Office
) QT . =

Log Forwarding

| g
@ Log Fetching @

Ld
FortiAnalyzer 400E FortiAnalyzer 3000D
Collector Mode Analyzer Mode

For related concepts, see Operation modes on page 30 and Analyzer—Collector collaboration on page 32. You need to
complete the initial setup for your FortiAnalyzer units first. See Initial setup on page 27.

Configuring the Collector

To configure the Collector:

1. Ensure the FortiAnalyzer Operation Mode is Collector. See Configuring the operation mode on page 276.
2. Check and configure the storage policy for the Collector. See Log storage information on page 107.

NP For the Collector, you should allocate most of the disk space for Archive logs. You should
‘Q' keep the Archive logs long enough to meet the regulatory requirements of your
- organization. After this initial configuration, you can monitor the storage usage and adjust it
- as you go.
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Following is a storage configuration example of the Collector.

Edit Log Storage Policy - ADOM : Branch_office_FGT

Data Palicy
Keep Logs for Analytics 0 Days
Keep Logs for Archive 365 Days
Disk Utilization
Maximum Allowed 1 TE v Out of Available: 4.5 TB
Analytics : Archive 59 v 959 B Modify
Alert and Delete When 90%

Usage Reaches

*If analytic or archive log usages exceed the configured disk quota before the retention period
expires, the oldest logs will be deleted.

=]

3. Setup log forwarding to enable the Collector to forward the logs to the Analyzer. See Log Forwarding on page 310.
In particular,

o Set Remote Server Type to FortiAnalyzer.
« Set Server IPto the IP address of the Analyzer that this Collector will forward logs to.
» Click Select Device and select the FortiGate device that the Collector will forward logs for.

Configuring the Analyzer

To configure the Analyzer:

1. Ensure the FortiAnalyzer Operation Mode is Analyzer. See Configuring the operation mode on page 276
2. Check and configure the storage policy for the Analyzer. See Log storage information on page 107.

want to keep the Analytics logs for 30-90 days. After this initial configuration, you can

\‘é', For the Analyzer you should allocate most of the disk space for Analytics logs. You may
3 monitor the storage usage and adjust it as you go.
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Following is a storage configuration example of the Analyzer.

Edit Log Storage Policy - ADOM : For_Branch_Office

Data Palicy
Keep Logs for Analytics &0 Days
Keep Logs for Archive 0 Days
Disk Utilization
Maximum Allowed 1 TB v Out of Available: 4.5 TB
Analytics : Archive 95% « 59 B Modify
Alert and Delete When 90%

Usage Reaches

*If analytic or archive log usages exceed the configured disk quota before the retention period
expires, the oldest logs will be deleted.

3. Make sure that the aggregation service is enabled on the Analyzer. If not, use this CLI command to enable it:
config system log-forward-service
set accept-aggregation enable
end
4. Add the FortiGate device of the remote office that the Collector will forward logs for. See Authorizing devices on
page 43.

Once the FortiGate of the remote office is added, the Analyzer starts receiving its logs from the Collector.

Fetching logs from the Collector to the Analyzer

At times, you might want to fetch logs from the Collector to the Analyzer. The Collector will perform the role of the fetch
server, and the Analyzer will perform the role of fetch client. For information about how to conduct log fetching, see
Fetcher Management on page 316.
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Management Extensions

The Management Extensions pane allows you to enable licensed applications that are released and signed by Fortinet.
The applications are installed and run on FortiAnalyzer.

A number of management extension applications (MEAs) are available. The following table identifies the available
applications and any ADOM requirements needed to access the application:

Management Extension Application ADOM Requirements for Access

FortiSIEM MEA on page 399
FortiSOAR MEA on page 399 Root fabric ADOM

See also Enabling management extension applications on page 399.

For information on how to access event logs for a management extension, see Accessing management extension logs
on page 401.

FortiSIEM MEA

You can enable the FortiSIEM management extension application (MEA) on FortiAnalyzer. FortiSIEM uses machine
learning to detect unusual user and entity behavior (UEBA) without requiring the administrator to write complex rules.
FortiSIEM helps identify insider and incoming threats that would pass traditional defenses. High fidelity alerts help
prioritize which threats need immediate attention.

For details about using FortiSIEM MEA, see the FortiSIEM MEA Administration Guide on the Document Library.

FortiSOAR MEA

You can enable the Fortinet Security Orchestration, Automation, and Response (FortiSOAR) management extension
application (MEA) on FortiAnalyzer, and use it to manage the entire lifecycle of a threat or breach within your

organization. For details about using FortiSOAR MEA, see the FortiSOAR MEA Administration Guide on the Document
Library.

Enabling management extension applications

Some management extension applications require a minimum amount of memory or a

minimum number of CPU cores.
Before you enable a management extension application, review the requirements in the

FortiAnalyzer 7.0.2 Release Notes.
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Management Extensions

FortiAnalyzer provides access to applications that are released and signed by Fortinet.

“é" Only administrators with a Super_User profile can enable management extensions.

A CA certificate is required to install management extensions on FortiAnalyzer. See CA
certificates on page 308.

To enable management extensions:

1. Go to Management Extensions.

Some management applications are available only in the root ADOM or in specific ADOM versions.
2. Click a grayed out tile to enable the application.

Grayed out tiles represent disabled applications.

3. Click OKin the dialog that appears. It might take some time to install the application.

CLI for management extensions

You can use the CLI console to enable, disable, update, debug, and check the management extension.

To enable management extensions:

1. Enable the production registry:
FAZ-VM64 # config system docker
(docker) # set status
enable Enable production registry.

2. Enable the management application.
(docker) # set
fortisoar Enable/disable container.
fsmcollector Enable/disable container.

FortiAnalyzer supports FortiSIEM MEA and FortiSOAR MEA. Although you can use the CLI to

enable additional management extension applications, they are not supported by
FortiAnalyzer. Enabled, unsupported management extension applications are hidden from the

FortiAnalyzer GUI, but still consume valuable resources. Be sure to only enable

FortiSIEM MEA and/or FortiSOAR MEA on FortiAnalyzer when using the CLI.

To disable management extensions:
config system docker

(docker) # get
(docker)# set {fsmcollector | fortisoar} disable

To debug management extensions:

diagnose debug application docker

To clean up or check management extensions:

diagnose docker {cleanup|status}
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To limit CPU and RAM resources for management extensions:

config system docker
(docker) # set cpu <integer> #Set the maximum % of CPU usage (10 - 50, default = 50)
(docker) # set mem <integer> #Set the maximum $ of RAM usage (10 - 50, default

50) .

NP ¢ The CLI commands allow you to set the resource limit globally for all management
‘Q' extension applications.
- ¢ If management extension applications reach the limit of allocated FortiAnalyzer resource,
= awarning appears in the Alert Message Console widget.

See also Checking for new versions and upgrading on page 401.

Accessing management extension logs

Event logs generated by a management extension are available in the local event log of FortiAnalyzer. They are
displayed in the following locations in System Settings:

» Alert Message Console widget
» Eventlog pane

To access management extension logs in the Alert Message Console widget:

1. Go to System Settings > Dashboard.
2. Inthe Dashboard pane, locate the Alert Message Console widget.
The recently generated management extension local logs are displayed in the Alert Message Console widget.

To access management extension logs in the Event Log pane:

1. Go to System Settings > Event Log to view the local log list.
The recently generated management extension local logs are displayed in the Event Log pane.

Checking for new versions and upgrading

You can check whether a new version of an enabled management extension application is available on the Fortinet
registry by using the CLI.

When the latest version of an enabled management extension application is running on FortiAnalyzer, the version is
reported as (up to date).When a new image is available on the Fortinet registry for an enabled management
extension application, the output displays (new image available).

In the example below, FortiSOAR MEA is enabled and a new version is available for installation. You can upgrade
FortiSOAR MEA by using the CLI.

To check for new versions of enabled management extensions:

diagnose docker status
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fortisoar: running (new image available)
fsmcollector: disabled

To upgrade enabled management extensions:

diagnose docker upgrade {fsmcollector | fortisoar}
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This section identifies the request for comment (RFC) notes supported by FortiAnalyzer.

RFC 2548

Description:

Microsoft Vendor-specific RADIUS Attributes

Category:
Informational
Webpage:

http://tools.ietf.org/html/rfc2548

RFC 2665

Description:

Ethernet-like MIB parts that apply to FortiAnalyzer units.

Category:
Standards Track
Webpage:

http://tools.ietf.org/html/rfc2665

RFC 1918

Description:

Address Allocation for Private Internets.
Category:

Best Current Practice

Webpage:

http://tools.ietf.org/html/rfc1918
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RFC 1213

Description:

MIB Il parts that apply to FortiAnalyzer units.
Category:

FortiAnalyzer (SNMP)

Webpage:

http://tools.ietf.org/html/rfc1213
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Appendix B - Log Integrity and Secure Log Transfer

This section identifies the options for enabling log integrity and secure log transfer settings between FortiAnalyzer and
FortiGate devices.

Log Integrity

FortiAnalyzer can create an MD5 checksum for each log file in order to secure logs from being modified after they have
been sent to an analytics platform.

The log integrity setting selected determines the values recorded at the time of transmission or when rolling the log:

« MD5: Record the log file's MD5 hash value only.
o MDS5-auth: Record the log file's MD5 hash value and authentication code.
» None: Do not record the log file checksum (default).

Configuring log integrity settings

To configure FortiAnalyzer log integrity:

1. Inthe FortiAnalyzer CLlI, enter the following commands:
configure system global
set log-checksum {md5 | md5-auth | none}
end

Verifying log-integrity

When log integrity settings are applied, you can view the MD5 checksum for logs in FortiAnalyzer event logs and the
FortiAnalyzer CLI.

To view the log file's MD5 checksum in event logs:

1. Goto FortiSoC > Event Monitor > All Events and select an event log.

2. Inthetoolbar, select Display Raw to view the raw log details.
The MD5 checksum is included in the details of the raw log.
1d=6906469110439837696 itime=2020-12-18 06:47:59 euid=1 epid=1 dsteuid=1 dstepid=1l
log id=0031040026 subtype=logfile type=event level=information time=06:47:59
date=2020-12-18 user=system action=roll msg=Rolled log file tlog.1608270213.1log
of device FGVM01TM20000000 [FGVM01TM20000000] vdom root, MD5 checksum:
ad85f8e889a3436d75b22b4a33c492ec userfrom=system desc=Rolling disk log file
devid=FAZVMSTM20000000 devname=FAZVMSTM20000000 dtime=2020-12-18 06:47:59 itime
t=1608270479
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To query the log file's MD5 checksum in the CLI:

1. Enter the following command in the FortiAnalyzer CLI:
execute log-integrity <device name> <vdom name> <log name>
For example:
execute log-integrity FGVM01TM20000000 root tlog.1608279204.log.gz
Integrity checking passed:
MD5 checksum is [82598ec0086319db73bd0£9de2396047]

Secure Log Transfer

Optimized Fabric Transfer Protocol (OFTP) is a proprietary Fortinet protocol. It is used for connectivity, performing
health checks, file transfers, and log display on FortiGate. OF TP listens on ports TCP514 and UDP514.

In the default configuration, there are two communication streams between FortiGate and FortiAnalyzer.
OFTP communication is encrypted and log communication is not.

o OFTP communication occurs on TCP514 using TLS.
» Log communication occurs on UDP514 (default setting).

Default FortiGate Settings

OFTP - TCP514 (TLS)

Log - UDP514

To secure log transfer, you can enable TCP and encryption. When enabled, logs are transferred securely between the
FortiGate and FortiAnalyzer using TCP514 (TLS).

Secure Log Transfer

OFTP - TCP514 (TLS)

Log - TCP514 (TLS)

Configuring secure log transfer settings

To enable secure log transfer:

1. Inthe FortiGate CLI, enter the following commands:
configure log fortianalyzer setting
set reliable enable
end
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A Enabling secure log transfer over TCP will impact overall logging performance.

Ay

S L4

q OFTP SSL protocol supports SSLv3, TLSv1.0, TLSv1.2, and TLSv1.3 (default TLSv1.2).

Log caching with secure log transfer enabled

When secure log transfer is enabled, log sync logic guarantees that no logs are lost due to connection issues between
the Fortigate and FortiAnalyzer. When connection is lost, logs will be cached and sent to FortiAnalyzer once the
connection resumes.

To confirm cached logs are sent when connection is lost/resumed between FortiGate and FortiAnalyzer:

1. Confirm the value of logsync_enabledis 1 on the FortiGate device.
In the FortiGate CLI, enter the following command:
diagnose test application fgtlogd 1

faz2: global , enabled
server=10.2.169.54, realtime=1, ssl=1, state=connected
server log status=Log is allowed.,
src=, mgmt name=FGh Log root 10.2.169.54, reliable=1, sni prefix type=none,
required entitlement=none, region=ca-west-1,
logsync_enabled:1, logsync conn 1d:131071, seq no:257
status: ver=6, used disk=0, total disk=0, global=0, vfid=0 conn verified=Y
SNs: last sn update:2097 seconds ago.
Sn list:
(FAZ-VM0000000001, age=2097s) (FAZ-VMJY00000004,age=2097s)
queue: glen=0.
filter: severity=6, sz exclude list=0
2. While connection between the FortiGate and FortiAnalyzer is established, check the log sequence number on the
OFTP connection.
In the FortiAnalyzer CLI, enter the following command:
diagnose test application oftpd 3
# DEVICE CONN HOSTNAME IP UPTIME IDLETIME #PKTS

1 FGT40FTK20025663 131071: 257 FortiGate-40F 10.3.169.1 31ml4s 4s 620
The coNN column has been added to record the connection ID and log sequence number. In this example, the
connection ID is 131071 and the sequence numberis 257.
3. When connection between the FortiGate and FortiAnalyzer is lost, check the log sequence number on the OFTP
connection.
In the FortiAnalyzer CLI, enter the following command:

diagnose test application oftpd 3
# DEVICE CONN HOSTNAME IP UPTIME IDLETIME #PKTS
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1 FGT40FTK20025663 131071: 257 FortiGate-40F 10.3.169.1 35mlds 244s 620
While the connection is lost, logs generated on the FortiGate device will be stored in its memory queue. The log
squence number on the OF TP connection will not increase. In this example, the log sequence number has
remained at 257.

4. When the connection between the FortiGate and FortiAnalyzer devices resumes, check logs on the FortiGate

device.
In the FortiGate CLI, enter the following command:

diagnose test application fgtlogd 41

cache maximum: 100573388 (95MB) objects: 37 used: 25788 (0MB) allocated: 29440 (0OMB)

VDOM: root
Memory queue for: global-faz
queue:
num:0 size:0(0MB) total size:25788 (0MB) max:100573388 (95MB) logs:0
Confirm queue for: global-faz
queue:
num:25 size:17382 (0MB) total size:25788(0MB) max:100573388 (95MB) logs:81
Memory queue for: global-faz2
queue:
num:0 size:0(0MB) total size:25788 (0MB) max:100573388 (95MB) logs:0
Confirm queue for: global-faz2
queue:
num:12 size:8406(0MB) total size:25788 (0MB) max:100573388 (95MB) logs:40

The confirm queue on the FortiGate device shows all the logs that are waiting to be confirmed and cleared. Once
the confirm queue displays 0, all of the cached logs have been sent to the FortiAnalyzer device.

5. Once the logs have been confirmed and cleared from the FortiGate device, check the log sequence number on the
OFTP connection.
In the FortiAnalyzer CLI, enter the following command:

diagnose test application oftpd 3
# DEVICE CONN HOSTNAME IP UPTIME IDLETIME #PKTS

1 FGT40FTK20025663 131071: 308 FortiGate-40F 10.3.169.1 36m23s 6s 635
Once the cached logs have been sent to the FortiAnalyzer device, the log sequence number increases. In this
example, the log sequence number has increased to 308.

Supported ciphers

The list of supported ciphers is determined when configuring enc_algorithmusingthe configure log
fortianalyzer settingcommand inthe FortiGate CLI.

Cipher security levels

FortiAnalyzer allows administrators to specify the security levels for cipher suites as low, medium, or high. Using a higher

security level means using more secure ciphers. SSL static key ciphers can be disabled to support forward secrecy.

Defining the enc-algorithmand ssl-static-key-ciphers usage settings in FortiAnalyzer allows administrators

to choose which OpenSSL cipher suites are supported.

e Lowenc-algorithmuses all OpenSSL ciphers.
e Medium enc-algorithm uses high and medium OpenSSL ciphers.
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e High enc-algorithm uses only high OpenSSL ciphers.
o Disabling ss1-static-key-ciphers enables forward secrecy.

To configure the cipher suite security level in the FortiAnalyzer CLI:

1. Enter the following command in the FortiAnalyzer CLI:
config system global
set enc-algorithm {high | medium | low}
set ssl-static-key-ciphers {enable | disable}
end

Ifenc-algorithmis setto custom, configure the ssl-cipher-suites table to enforce the user specified preferred cipher
order in the incoming SSL connections. Enter the following command:

config system global
config ssl-cipher-suites
edit <priority>
set cipher <string>
set version {tlsl.2-or-below | tlsl.3}
end

If using enc-algorithmis setto high, medium, or 1ow, see the list of supported ciphers based on security level
settings below.

ssl-static-key-ciphers enabled
enc-algorithm

Low TLS_AES_256_GCM_SHA384:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_
128_GCM_SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-
AES256-GCM-SHA384:DHE-DSS-AES256-GCM-SHA384:DHE-RSA-AES256-
GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY 1305:ECDHE-RSA-
CHACHA20-POLY 1305:DHE-RSA-CHACHA20-POLY 1305:ECDHE-ECDSA-
AES256-CCM:DHE-RSA-AES256-CCM:ECDHE-ECDSA-ARIA256-GCM-
SHA384:ECDHE-ARIA256-GCM-SHA384:DHE-DSS-ARIA256-GCM-
SHA384:DHE-RSA-ARIA256-GCM-SHA384:ECDHE-ECDSA-AES256-
SHA384:ECDHE-RSA-AES256-SHA384:DHE-RSA-AES256-SHA256:DHE-DSS-
AES256-SHA256:ECDHE-ECDSA-CAMELLIA256-SHA384:ECDHE-RSA-
CAMELLIA256-SHA384:DHE-RSA-CAMELLIA256-SHA256:DHE-DSS-
CAMELLIA256-SHA256:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-
SHA:DHE-RSA-AES256-SHA:DHE-DSS-AES256-SHA: DHE-RSA-CAMELLIA256-
SHA:DHE-DSS-CAMELLIA256-SHA:RSA-PSK-AES256-GCM-SHA384:DHE-PSK-
AES256-GCM-SHA384:RSA-PSK-CHACHA20-POLY 1305:DHE-PSK-CHACHA20-
POLY1305:ECDHE-PSK-CHACHA20-POLY 1305:DHE-PSK-AES256-CCM:RSA-
PSK-ARIA256-GCM-SHA384:DHE-PSK-ARIA256-GCM-SHA384:AES256-GCM-
SHA384:AES256-CCM:ARIA256-GCM-SHA384:PSK-AES256-GCM-SHA384:PSK-
CHACHA20-POLY1305:PSK-AES256-CCM:PSK-ARIA256-GCM-
SHA384:AES256-SHA256: CAMELLIA256-SHA256:ECDHE-PSK-AES256-CBC-
SHA384:ECDHE-PSK-AES256-CBC-SHA:SRP-DSS-AES-256-CBC-SHA:SRP-
RSA-AES-256-CBC-SHA:SRP-AES-256-CBC-SHA:RSA-PSK-AES256-CBC-
SHA384:DHE-PSK-AES256-CBC-SHA384:RSA-PSK-AES256-CBC-SHA:DHE-
PSK-AES256-CBC-SHA:ECDHE-PSK-CAMELLIA256-SHA384:RSA-PSK-
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Medium

CAMELLIA256-SHA384:DHE-PSK-CAMELLIA256-SHA384:AES256-
SHA:CAMELLIA256-SHA:PSK-AES256-CBC-SHA384:PSK-AES256-CBC-
SHA:PSK-CAMELLIA256-SHA384:ECDHE-ECDSA-AES128-GCM-
SHA256:ECDHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-
SHA256:DHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-CCM:DHE-
RSA-AES128-CCM:ECDHE-ECDSA-ARIA128-GCM-SHA256:ECDHE-ARIA128-
GCM-SHA256:DHE-DSS-ARIA128-GCM-SHA256:DHE-RSA-ARIA128-GCM-
SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:DHE-
RSA-AES128-SHA256:DHE-DSS-AES128-SHA256:ECDHE-ECDSA-
CAMELLIA128-SHA256:ECDHE-RSA-CAMELLIA128-SHA256:DHE-RSA-
CAMELLIA128-SHA256:DHE-DSS-CAMELLIA128-SHA256:ECDHE-ECDSA-
AES128-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES128-SHA:DHE-DSS-
AES128-SHA:DHE-RSA-CAMELLIA128-SHA:DHE-DSS-CAMELLIA128-
SHA:RSA-PSK-AES128-GCM-SHA256:DHE-PSK-AES 128-GCM-SHA256:DHE-
PSK-AES128-CCM:RSA-PSK-ARIA128-GCM-SHA256:DHE-PSK-ARIA128-GCM-
SHA256:AES128-GCM-SHA256:AES128-CCM:ARIA128-GCM-SHA256:PSK-
AES128-GCM-SHA256:PSK-AES128-CCM:PSK-ARIA128-GCM-SHA256:AES 128-
SHA256:CAMELLIA128-SHA256:ECDHE-PSK-AES128-CBC-SHA256:ECDHE-
PSK-AES128-CBC-SHA:SRP-DSS-AES-128-CBC-SHA:SRP-RSA-AES-128-CBC-
SHA:SRP-AES-128-CBC-SHA:RSA-PSK-AES128-CBC-SHA256:DHE-PSK-
AES128-CBC-SHA256:RSA-PSK-AES128-CBC-SHA:DHE-PSK-AES128-CBC-
SHA:ECDHE-PSK-CAMELLIA128-SHA256:RSA-PSK-CAMELLIA128-
SHA256:DHE-PSK-CAMELLIA128-SHA256:AES128-SHA:CAMELLIA128-
SHA:PSK-AES128-CBC-SHA256:PSK-AES128-CBC-SHA:PSK-CAMELLIA128-
SHA256:ECDHE-ECDSA-AES256-CCM8:ECDHE-ECDSA-AES128-CCM8:DHE-
RSA-AES256-CCM8:DHE-RSA-AES128-CCM8:DHE-PSK-AES256-CCM8:DHE-
PSK-AES128-CCM8:AES256-CCM8:AES128-CCM8:PSK-AES256-CCM8:PSK-
AES128-CCM8

TLS_AES_256_GCM_SHA384:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_
128_GCM_SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-
AES256-GCM-SHA384:DHE-DSS-AES256-GCM-SHA384: DHE-RSA-AES256-
GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY 1305:ECDHE-RSA-
CHACHA20-POLY 1305:DHE-RSA-CHACHA20-POLY 1305:ECDHE-ECDSA-
AES256-CCM:DHE-RSA-AES256-CCM:ECDHE-ECDSA-ARIA256-GCM-
SHA384:ECDHE-ARIA256-GCM-SHA384:DHE-DSS-ARIA256-GCM-
SHA384:DHE-RSA-ARIA256-GCM-SHA384:ECDHE-ECDSA-AES256-
SHA384:ECDHE-RSA-AES256-SHA384:DHE-RSA-AES256-SHA256:DHE-DSS-
AES256-SHA256:ECDHE-ECDSA-CAMELLIA256-SHA384:ECDHE-RSA-
CAMELLIA256-SHA384:DHE-RSA-CAMELLIA256-SHA256:DHE-DSS-
CAMELLIA256-SHA256:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-
SHA:DHE-RSA-AES256-SHA:DHE-DSS-AES256-SHA: DHE-RSA-CAMELLIA256-
SHA:DHE-DSS-CAMELLIA256-SHA:RSA-PSK-AES256-GCM-SHA384:DHE-PSK-
AES256-GCM-SHA384:RSA-PSK-CHACHA20-POLY 1305:DHE-PSK-CHACHA20-
POLY1305:ECDHE-PSK-CHACHA20-POLY 1305:DHE-PSK-AES256-CCM:RSA-
PSK-ARIA256-GCM-SHA384:DHE-PSK-ARIA256-GCM-SHA384:AES256-GCM-
SHA384:AES256-CCM:ARIA256-GCM-SHA384:PSK-AES256-GCM-SHA384:PSK-
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High

CHACHA20-POLY1305:PSK-AES256-CCM:PSK-ARIA256-GCM-
SHA384:AES256-SHA256:CAMELLIA256-SHA256:ECDHE-PSK-AES256-CBC-
SHA384:ECDHE-PSK-AES256-CBC-SHA:SRP-DSS-AES-256-CBC-SHA:SRP-
RSA-AES-256-CBC-SHA:SRP-AES-256-CBC-SHA:RSA-PSK-AES256-CBC-
SHA384:DHE-PSK-AES256-CBC-SHA384:RSA-PSK-AES256-CBC-SHA:DHE-
PSK-AES256-CBC-SHA:ECDHE-PSK-CAMELLIA256-SHA384:RSA-PSK-
CAMELLIA256-SHA384:DHE-PSK-CAMELLIA256-SHA384:AES256-
SHA:CAMELLIA256-SHA:PSK-AES256-CBC-SHA384:PSK-AES256-CBC-
SHA:PSK-CAMELLIA256-SHA384:ECDHE-ECDSA-AES128-GCM-
SHA256:ECDHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-
SHA256:DHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-CCM:DHE-
RSA-AES128-CCM:ECDHE-ECDSA-ARIA128-GCM-SHA256:ECDHE-ARIA128-
GCM-SHA256:DHE-DSS-ARIA128-GCM-SHA256:DHE-RSA-ARIA128-GCM-
SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:DHE-
RSA-AES128-SHA256:DHE-DSS-AES128-SHA256:ECDHE-ECDSA-
CAMELLIA128-SHA256:ECDHE-RSA-CAMELLIA128-SHA256:DHE-RSA-
CAMELLIA128-SHA256:DHE-DSS-CAMELLIA128-SHA256:ECDHE-ECDSA-
AES128-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES128-SHA:DHE-DSS-
AES128-SHA:DHE-RSA-CAMELLIA128-SHA:DHE-DSS-CAMELLIA128-
SHA:RSA-PSK-AES128-GCM-SHA256:DHE-PSK-AES 128-GCM-SHA256:DHE-
PSK-AES128-CCM:RSA-PSK-ARIA128-GCM-SHA256:DHE-PSK-ARIA128-GCM-
SHA256:AES128-GCM-SHA256:AES128-CCM:ARIA128-GCM-SHA256:PSK-
AES128-GCM-SHA256:PSK-AES128-CCM:PSK-ARIA128-GCM-SHA256:AES128-
SHA256:CAMELLIA128-SHA256:ECDHE-PSK-AES128-CBC-SHA256:ECDHE-
PSK-AES128-CBC-SHA:SRP-DSS-AES-128-CBC-SHA:SRP-RSA-AES-128-CBC-
SHA:SRP-AES-128-CBC-SHA:RSA-PSK-AES128-CBC-SHA256:DHE-PSK-
AES128-CBC-SHA256:RSA-PSK-AES128-CBC-SHA:DHE-PSK-AES128-CBC-
SHA:ECDHE-PSK-CAMELLIA128-SHA256:RSA-PSK-CAMELLIA128-
SHA256:DHE-PSK-CAMELLIA128-SHA256:AES128-SHA:CAMELLIA128-
SHA:PSK-AES128-CBC-SHA256:PSK-AES128-CBC-SHA:PSK-CAMELLIA128-
SHA256:ECDHE-ECDSA-AES256-CCM8:ECDHE-ECDSA-AES128-CCM8:DHE-
RSA-AES256-CCM8:DHE-RSA-AES128-CCM8:DHE-PSK-AES256-CCM8:DHE-
PSK-AES128-CCM8:AES256-CCM8:AES128-CCM8:PSK-AES256-CCM8:PSK-
AES128-CCM8

TLS AES 256 GCM_SHA384:TLS CHACHA20 POLY1305 SHA256:TLS AES
128_GCM_SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-
AES256-GCM-SHA384:DHE-DSS-AES256-GCM-SHA384:DHE-RSA-AES256-
GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY 1305:ECDHE-RSA-
CHACHA20-POLY1305:DHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-
AES256-CCM:DHE-RSA-AES256-CCM:ECDHE-ECDSA-ARIA256-GCM-
SHA384:ECDHE-ARIA256-GCM-SHA384:DHE-DSS-ARIA256-GCM-
SHA384:DHE-RSA-ARIA256-GCM-SHA384:ECDHE-ECDSA-AES256-
SHA384:ECDHE-RSA-AES256-SHA384:DHE-RSA-AES256-SHA256: DHE-DSS-
AES256-SHA256:ECDHE-ECDSA-CAMELLIA256-SHA384:ECDHE-RSA-
CAMELLIA256-SHA384:DHE-RSA-CAMELLIA256-SHA256:DHE-DSS-
CAMELLIA256-SHA256:ECDHE-ECDSA-AES256-SHA:ECDHE-RSA-AES256-
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fips enabled

SHA:DHE-RSA-AES256-SHA:DHE-DSS-AES256-SHA:DHE-RSA-CAMELLIA256-
SHA:DHE-DSS-CAMELLIA256-SHA:RSA-PSK-AES256-GCM-SHA384:DHE-PSK-
AES256-GCM-SHA384:RSA-PSK-CHACHA20-POLY1305:DHE-PSK-CHACHA20-
POLY1305:ECDHE-PSK-CHACHA20-POLY1305:DHE-PSK-AES256-CCM:RSA-
PSK-ARIA256-GCM-SHA384:DHE-PSK-ARIA256-GCM-SHA384:AES256-GCM-
SHA384:AES256-CCM:ARIA256-GCM-SHA384:PSK-AES256-GCM-SHA384:PSK-
CHACHA20-POLY1305:PSK-AES256-CCM:PSK-ARIA256-GCM-
SHA384:AES256-SHA256:CAMELLIA256-SHA256:ECDHE-PSK-AES256-CBC-
SHA384:ECDHE-PSK-AES256-CBC-SHA:SRP-DSS-AES-256-CBC-SHA:SRP-
RSA-AES-256-CBC-SHA:SRP-AES-256-CBC-SHA:RSA-PSK-AES256-CBC-
SHA384:DHE-PSK-AES256-CBC-SHA384:RSA-PSK-AES256-CBC-SHA:DHE-
PSK-AES256-CBC-SHA:ECDHE-PSK-CAMELLIA256-SHA384:RSA-PSK-
CAMELLIA256-SHA384:DHE-PSK-CAMELLIA256-SHA384:AES256-
SHA:CAMELLIA256-SHA:PSK-AES256-CBC-SHA384:PSK-AES256-CBC-
SHA:PSK-CAMELLIA256-SHA384:ECDHE-ECDSA-AES128-GCM-
SHA256:ECDHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-
SHA256:DHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-CCM:DHE-
RSA-AES128-CCM:ECDHE-ECDSA-ARIA128-GCM-SHA256:ECDHE-ARIA128-
GCM-SHA256:DHE-DSS-ARIA128-GCM-SHA256:DHE-RSA-ARIA128-GCM-
SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA256:DHE-
RSA-AES128-SHA256:DHE-DSS-AES128-SHA256:ECDHE-ECDSA-
CAMELLIA128-SHA256:ECDHE-RSA-CAMELLIA128-SHA256:DHE-RSA-
CAMELLIA128-SHA256:DHE-DSS-CAMELLIA128-SHA256:ECDHE-ECDSA-
AES128-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES128-SHA:DHE-DSS-
AES128-SHA:DHE-RSA-CAMELLIA128-SHA:DHE-DSS-CAMELLIA128-
SHA:RSA-PSK-AES128-GCM-SHA256:DHE-PSK-AES 128-GCM-SHA256:DHE-
PSK-AES128-CCM:RSA-PSK-ARIA128-GCM-SHA256:DHE-PSK-ARIA128-GCM-
SHA256:AES128-GCM-SHA256:AES128-CCM:ARIA128-GCM-SHA256:PSK-
AES128-GCM-SHA256:PSK-AES128-CCM:PSK-ARIA128-GCM-SHA256:AES128-
SHA256:CAMELLIA128-SHA256:ECDHE-PSK-AES128-CBC-SHA256:ECDHE-
PSK-AES128-CBC-SHA:SRP-DSS-AES-128-CBC-SHA:SRP-RSA-AES-128-CBC-
SHA:SRP-AES-128-CBC-SHA:RSA-PSK-AES128-CBC-SHA256:DHE-PSK-
AES128-CBC-SHA256:RSA-PSK-AES128-CBC-SHA:DHE-PSK-AES128-CBC-
SHA:ECDHE-PSK-CAMELLIA128-SHA256:RSA-PSK-CAMELLIA128-
SHA256:DHE-PSK-CAMELLIA128-SHA256:AES128-SHA:CAMELLIA128-
SHA:PSK-AES128-CBC-SHA256:PSK-AES128-CBC-SHA:PSK-CAMELLIA128-
SHA256

TLS_AES_256_GCM_SHA384:TLS_CHACHA20_POLY1305_SHA256:TLS_AES_
128_GCM_SHA256:AES256-SHA:AES256-SHA256:DHE-RSA-AES256-
SHA:DHE-RSA-AES256-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-
AES256-GCM-SHA384:ECDHE-ECDSA-AES256-SHA:ECDHE-ECDSA-AES256-
GCM-SHA384:AES128-SHA:AES128-SHA256:DHE-RSA-AES128-SHA: DHE-
RSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-RSA-AES128-GCM-
SHA256:ECDHE-ECDSA-AES128-SHA:ECDHE-ECDSA-AES 128-GCM-SHA256

The following ciphers are not available when using forward secrecy (ss1-static-key-ciphers is disabled).

ssl-static-key-ciphers disabled
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enc-algorithm

Low

Medium

High

fips enabled

AES256-GCM-SHA384:AES256-CCM:ARIA256-GCM-SHA384:AES256-
SHA256:CAMELLIA256-SHA256:AES256-SHA:CAMELLIA256-SHA:AES128-
GCM-SHA256:AES128-CCM:AES128-SHA256: CAMELLIA128-SHA256:AES128-
SHA:CAMELLIA128-SHA:AES256-CCM8:AES128-CCM8

AES256-GCM-SHA384:AES256-CCM:ARIA256-GCM-SHA384:AES256-
SHA256:CAMELLIA256-SHA256:AES256-SHA:CAMELLIA256-SHA:AES128-
GCM-SHA256:AES128-CCM:AES128-SHA256:CAMELLIA128-SHA256:AES128-
SHA:CAMELLIA128-SHA:AES256-CCM8:AES128-CCM8

AES256-GCM-SHA384:AES256-CCM:ARIA256-GCM-SHA384:AES256-
SHA256:CAMELLIA256-SHA256:AES256-SHA:CAMELLIA256-SHA:AES128-
GCM-SHA256:AES128-CCM:AES128-SHA256:CAMELLIA128-SHA256:AES128-
SHA:CAMELLIA128-SHA

AES256-SHA:AES256-SHA256:AES128-SHA:AES128-SHA256

Maximum TLS/SSL version compatibility

The tables below indicate the maximum supported TLS version that you can configure for communication between a
FortiGate and FortiAnalyzer, as well as FortiAnalyzer's configured with log forwarding when the type is FortiAnalyzer.

For more information on secure log transfer and log integrity settings between FortiGate and FortiAnalyzer, see
Appendix B - Log Integrity and Secure Log Transfer on page 405.

Maximum configurable TLS version for FortiGate to FortiAnalyzer communication:

FGT 6.4.0+

FGT 6.2.3 -6.2.8
FGT 6.2.0 - 6.2.2
FGT 6.0.2 - 6.0.12

FGT 6.0.0 - 6.0.1

FAZ 6.4.0+ FAZ 6.2.0+ FAZ 6.0.0+

tlsv1.3 tlsv1.2 tlsv1.2

tlsv1.3 tisv1.2 tisv1.2

tisv1.2 tisv1.2 tlsv1.2

tisv1.2 tisv1.2 tisv1.2

The setting is not This setting is not This setting is not
configurable in FGT 6.0.0- | configurable in FGT 6.0.0 - | configurable in FGT 6.0.0 -
6.0.1. 6.0.1. 6.0.1.

Maximum configurable TLS version for FortiAnalyzer to FortiAnalyzer log forwarding:

FAZ 6.4.0+

FAZ 6.4.0+ FAZ 6.2.0+ FAZ 6.0.0+
tlsv1.3 tlsv1.2 tlsv1.2
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FAZ 6.2.0+ tlsv1.2 tlsv1.2 tlsv1.2

FAZ 6.0.0+ tisv1.2 tlsv1.2 tlsv1.2

To configure the global TLS/SSL version on FortiAnalyzer:

1. Inthe FortiAnalyzer CLI, enter the following:
config system global

set ssl-protocol {tlsvl.3 | tlsvl.2 | tlsvl.l | tlsvl.0 | sslv3}

To configure the global TLS/SSL version on FortiGate:

1. Inthe FortiGate CLI, enter the following:
config system global

set ssl-min-proto-version {tlsvl.3 | tlsvl.2 | tlsvl.l | tlsvl.0 | sslv3}
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Appendix C - FortiAnalyzer Ansible Collection
documentation

Documentation for the Fortinet FortiAnalyzer Ansible Collection is available through the link below.

o FortiAnalyzer Ansible Collection documentation
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https://ansible-galaxy-fortianalyzer-docs.readthedocs.io/en/latest/
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