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Introduction

Introduction

The FortiVoice phone system enables you to completely control your organization’s telephone communications. Easy to
use and reliable, the FortiVoice phone system delivers everything you need to handle calls professionally, control
communication costs, and stay connected everywhere.

The FortiVoice phone system includes all the fundamentals of enterprise-class voice communications, with no
additional cards to install. Auto attendants, voice messaging, ring groups, conferencing and much more are built-in. In
addition, the FortiVoice user portal lets your staff view their call logs, configure and manage their own messaging, and
access other features, such as the operator console and the call center console.

This document describes how to configure and use the FortiVoice phone system. Only the configuration procedures
through the web-based manager are provided.

This topic includes:

« Registering your Fortinet product on page 11
e Training on page 11

« Documentation on page 12

e Scope on page 12

« Conventions on page 12

Registering your Fortinet product

Before you begin, take a moment to register your Fortinet product at the Fortinet Technical Support website.

Many Fortinet customer services, such as firmware updates and technical support, require product
registration.

For more information, see the Fortinet Knowledge Base article Registration Frequently Asked Questions.

Customer service and technical support

Fortinet Technical Support provides services designed to make sure that you can install your Fortinet products quickly,
configure them easily, and operate them reliably in your network.

To learn about the technical support services that Fortinet provides, visit the Fortinet Technical Support website.

You can dramatically improve the time that it takes to resolve your technical support ticket by providing your
configuration file, a network diagram, and other specific information.

Training

Fortinet Training Services provides classes that orient you quickly to your new equipment, and certifications to verify
your knowledge level. Fortinet provides a variety of training programs to serve the needs of our customers and partners

FortiVoice Phone System 6.4.3 Administration Guide
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Introduction

world-wide.

To learn about the training services that Fortinet provides, visit the Fortinet Training Services website or email them at
training@fortinet.com.

Documentation

The Fortinet Technical Documentation website provides the most up-to-date versions of Fortinet publications, as well
as additional technical documentation such as technical notes.

In addition to the Fortinet Technical Documentation website, you can find Fortinet technical documentation on the
Fortinet Knowledge Base.

Fortinet Knowledge Base

The Fortinet Knowledge Base provides additional Fortinet technical documentation, such as troubleshooting and how-
to-articles, examples, FAQs, technical notes, a glossary, and more. Visit the Fortinet Knowledge Base.

Comments on Fortinet technical documentation

Please send information about any errors or omissions in this document to techdoc@fortinet.com.

Scope

This document describes how to connect the FortiVoice unit to its web-based manager and CLI and use the web-based
manager to configure the FortiVoice unit.

This document does not cover commands for the command line interface (CLI).

Conventions

Fortinet technical documentation uses the following conventions:

« |P addresses on page 12
« Cautions and notes on page 13
« Typographical conventions on page 13

IP addresses

To avoid publication of public IP addresses that belong to Fortinet or any other organization, the IP addresses used in
Fortinet technical documentation are fictional and follow the documentation guidelines specific to Fortinet. The

FortiVoice Phone System 6.4.3 Administration Guide
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addresses used are from the private |P address ranges defined in RFC 1918: Address Allocation for Private Internets.

Cautions and notes

Fortinet technical documentation uses the following guidance and styles for cautions and notes.

Warns you about commands or procedures that could have unexpected or undesirable results
including loss of data or damage to equipment.
Ay
S L4
? Highlights useful additional information, often tailored to your workplace activity.

Typographical conventions

Fortinet documentation uses the following typographical conventions:

Convention Example

Button, menu, text box, field, From Minimum log level, select Notification.
or check box label

CLI input config system dns
set primary <address ipvé4>
end
CLI output FGT-602803030703 # get system Setting
comments : (null)

opmode : nat

Emphasis HTTP connections are not secure and can be intercepted by a third party.

File content <HTML><HEAD><TITLE>Firewall
Authentication</TITLE></HEAD>
<BODY><H4>You must authenticate to use this
service.</H4>

Hyperlink Visit the Fortinet Technical Support website.
Keyboard entry Type a name for the remote VPN peer or client, such as Central Office 1.
Navigation Go to Monitor> Status > DHCP.
Publication For details, see the FortiVoice Phone System Administration Guide.
FortiVoice Phone System 6.4.3 Administration Guide 13
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Connecting to the FortiVoice system

Connecting to the FortiVoice system

After physically installing the FortiVoice unit, you need to connect to its management tools to configure, maintain, and
administer the unit. You also need to inform your phone users on how to access the user portal and use the FortiVoice
features.

This topic includes:

« Connecting to the web-based manager or CLI on page 14
o Setting up the system on page 18

o Testing the setup on page 18

« Configuring setups for phone users on page 18

Connecting to the web-based manager or CLI

There are two methods to connect to the FortiVoice unit:

« use the web-based manager, a graphical user interface (GUI), from within a web browser

« use the command line interface (CLI), an interface similar to DOS or UNIX commands, from a Secure Shell (SSH)
or Telnet terminal

Access to the CLI and/or web-based manager is not yet configured if:

« you are connecting for the first time
« Yyou have just reset the configuration to its default state

In these cases, you must access either interface using the default settings.

access protocol, administrator account and password already configured, instead of the

\‘é', If the above conditions do not apply, access the web Ul using the IP address, administrative
3 default settings.

NP Until the FortiVoice unit is configured with an IP address and connected to your network, you
S L4 . . . .
q may prefer to connect the FortiVoice unit directly to your management computer, or through a
- switch, in a peer network that is isolated from your overall network. However, isolation is not
- required.

This topicincludes:

« Connecting to the web-based manager on page 15
« Connecting to the CLI on page 16

FortiVoice Phone System 6.4.3 Administration Guide
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Connecting to the web-based manager

To connect to the web-based manager of the FortiVoice phone system using its default settings, you must have:

« acomputer with an RJ-45 Ethernet network port
« one of the recommended web browsers. For details, see the Forti\VVoice Phone System Release Notes.
« an Ethernet cable

Default settings for connecting to the web-based manager

Network interface port1

URL https://192.168.1.99/admin
Name admin

Password (none)

To connect to the web-based manager

1.  On your management computer, configure the Ethernet port with the static IP address 192.168.1.2 with a netmask
of 255.255.255.0.
2. Using the Ethernet cable, connect your computer’s Ethernet port to the FortiVoice unit’s port1.
3. Start your browser and go to https://192.168.1.99/admin.
To support HTTPS authentication, the FortiVoice unit ships with a self-signed security certificate, which it presents
to clients whenever they initiate an HTTPS connection to the FortiVoice unit. When you connect, depending on
your web browser and prior access of the FortiVoice unit, your browser might display two security warnings related
to this certificate:
« The certificate is not automatically trusted because it is self-signed, rather than being signed by a valid
certificate authority (CA). Self-signed certificates cannot be verified with a proper CA, and therefore might be
fraudulent. You must manually indicate whether or not to trust the certificate.

« The certificate may belong to another website. The common name (CN) field in the certificate, which usually
contains the host name of the website, does not exactly match the URL you requested. This could indicate
server identity theft, but could also simply indicate that the certificate contains a domain name while you have
entered an IP address. You must manually indicate whether this mismatch is normal or not.

Both warnings are normal for the default certificate.

4. Verify and accept the certificate, either permanently (the web browser will not display the self-signing warning
again) or temporarily. You cannot log in until you accept the certificate.
For details on accepting the certificate, see the documentation for your web browser.

5. Inthe Name field, type admin, then click Login. (In its default state, there is no password for this account.)

6. Click Login.
With a successful login, the web-based manager appears.

7. Set the password for this account:
a. Inthe right corner of the web-based manager, click Admin.
b. Click Change Password.

Enter a FortiVoice administrator password that is six characters or more. For better
security, enter a longer password with a complex combination of characters and

numbers, and change the password regularly. Failure to provide a strong password
could compromise the security of your FortiVoice phone system.

FortiVoice Phone System 6.4.3 Administration Guide
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c. Enter a password in New password and Confirm password.
The password can contain any character except spaces.

d. Click OK.

After you connect, you can use the web-based manager to configure basic network settings and access the web-
based manager through your network. However, if you want to update the firmware, you may want to do so before
continuing. See System Information widget on page 24.

Connecting to the CLI

Using its default settings, you can access the CLI from your management computer in two ways:

o alocal serial console connection
« an SSH connection, either local or through the network

To connect to the CLI using a local serial console connection, you must have:

« acomputer with a serial communications (COM) port
« the RJ-45-t0-DB-9 serial or null modem cable included in your FortiVoice package
« terminal emulation software, such as HyperTerminal for Microsoft Windows

To connect to the CLI using an SSH connection, you must have:

o acomputer with an RJ-45 Ethernet port
« acrossover Ethernet cable
e an SSH client, such as PuTTY

Default Setting for connecting to the CLI by SSH

Network Interface port1
IP Address 192.168.1.99
SSH Port Number 22
Name admin
Password (none)
NP If you are not connecting for the first time, nor have you just reset the configuration to its
‘?' default state or restored the firmware, administrative access Setting may have already been
- configured. In this case, access the CLI using the |P address, administrative access protocol,

administrator account and password already configured, instead of the default Setting.

‘?' The following procedure uses Microsoft HyperTerminal. Steps may vary with other terminal
emulators.

FortiVoice Phone System 6.4.3 Administration Guide
Fortinet Technologies Inc.
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To connect to the CLI using a local serial console connection

1.

o~ ODN

N o

10.

Using the RJ-45-to-DB-9 or null modem cable, connect your computer’s serial communications (COM) port to the
FortiVoice unit’s console port.

Verify that the FortiVoice unit is powered on.
On your management computer, start HyperTerminal.
On Connection Description, enter a Name for the connection and select OK.

On Connect To, from Connect using, select the communications (COM) port where you connected the FortiVoice
unit.

Select OK.
Select the following Port Setting and select OK.
Bits per second 9600
Data bits 8
Parity None
Stop bits 1
Flow control None

Press Enter.

The terminal emulator connects to the CLI and the CLI displays a login prompt.

Type admin and press Enter twice. (In its default state, there is no password for this account.)
The CLI displays a prompt, such as:

FortiVoice #

Type admin and press Enter twice. (In its default state, there is no password for this account.)
The CLI displays the following text:

Type ? for a list of commands.

You can now enter commands.

Ay
S L4
? The following procedure uses PuTTy. Steps may vary with other SSH clients.

To connect to the CLI using an SSH connection

1.

© N oo ~OWN

On your management computer, configure the Ethernet port with the static IP address 192.168.1.2 with a netmask
of 255.255.255.0.

Using the Ethernet cable, connect your computer’s Ethernet port to the FortiVoice unit’s port1.
Verify that the FortiVoice unit is powered on.

On your management computer, start your SSH client.

In Host Name (or IP Address), type 192.168.1.99.

In Port, type 22.

From Connection type, select SSH.

Select Open.

The SSH client connects to the FortiVoice unit.

The SSH client may display a warning if this is the first time you are connecting to the FortiVoice unit and its SSH
key is not yet recognized by your SSH client, or if you have previously connected to the FortiVoice unit but it used a

FortiVoice Phone System 6.4.3 Administration Guide
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different IP address or SSH key. If your management computer is directly connected to the FortiVoice unit with no
network hosts between them, this is normal.

9. Click Yes to verify the fingerprint and accept the FortiVoice unit’s SSH key. You cannot log in until you accept the
key.
The CLI displays a login prompt.
10. Type admin and press Enter twice. (In its default state, there is no password for this account.)
The CLI displays the following text:
Type ? for a list of commands.

You can now enter commands.

Setting up the system

You can follow this guide to set up the FortiVoice system. After the setup is complete, you can make phone calls
through the FortiVoice unit.

Testing the setup

After completing the configuration, you can connect a SIP phone to your VolP network and make an internal, external,
or office peer test call.

NP If the SIP phone and the FortiVoice unit (PBX) are on different subnets, proper routing should
‘Q' be set to make them reachable
- If you make a office peer test call, make sure that your FortiVoice unit and the peer office PBX
- are mutually registered. For more information, see Configuring office peers on page 216.

« Depending on the phone you use, the procedure to connect the phone may vary. Refer to the phone user manuals
for instructions.

« Generally, you need to configure the following on the phone after powering it up and connecting it to the network:
« Enter the IP address of the phone if it is not DHCP-enabled.
« Enter the SIP server |IP address and port number (5060 by default) of the FortiVoice unit.
« Enter the extension number and SIP password you have configured and make sure the extension is enabled.
If you have not imported or added any extensions, do it first. For more information, see Configuring IP extensions
on page 164. The extension number on the FortiVoice unit and your phone should match.

Configuring setups for phone users

The FortiVoice system provides a user portal where phone users can view their call logs, configure and manage their
own messaging, and access other features.

This section contains information that you may need to inform or assist your phone users so that they can use the
FortiVoice features.
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This information is notthe same as what is included in the help for FortiVoice user portal. It is included in this guide
because:

« Phone users need to know how to access the FortiVoice user portal and its online help.
« Phone users need to know the feature codes they can use on the phones.
« Phone users need to know how to change the voicemail password on the FortiVoice user portal and on the phone.

« Phone users may be confused if they try to enable a feature that you disabled (such as call waiting or do not
disturb).

« You may need to tailor some information to your network or phone users.
This topic includes:

o Accessing the user portal on page 19

o Changing the user PIN on page 20

+ Receiving and sending fax on page 20

« Using the operator console on page 20

« Setting user privileges and preferences on page 20
o Setting the feature codes on page 20

Accessing the user portal

FortiVoice user portal is a special website located on a FortiVoice Cloud. This FortiVoice user portal allows a phone user
to:

« Check your call history for received, placed, or missed calls.

« Check your voicemail including playing, deleting, forwarding, or saving voicemails.

« Manage your business and personal contacts, and view the business and corporate phone directories.
« Manage how the phone system handles your phone calls.

o Check your recorded calls including playing, deleting, or saving the voicemails.

« Receive and send faxes.

« Set up reminder events and invite guests.

« Add user conference call events in your calendar and invite attendees by email.

« View device details of desk phones and soft phones, and set up programmable keys.
« Configure your extension according to your preferences.

« Use the operator console to process organization calls.

« Use the call center console to process call queues.

Several modern, popular web browsers are supported, so you can use FortiVoice user portal through the web browser of
your choice.

For the phone user to access the FortiVoice user portal, you need to inform the phone user of:

« FortiVoice user portal URL (same with that of the FortiVoice unit except without /admin in the end)
« user extension number
o default user PIN

With this information, a user can enter the URL in the browser’s location or address bar. The user can then log into the
portal using the extension number as user name and the user PIN as password.

Once they access the FortiVoice user portal, phone users can click the Help button to learn how to use the portal.

For information on adding extension numbers and user PINs, see Configuring IP extensions on page 164.
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Changing the user PIN

Inform the phone users how to change the default user PIN on the phone. The information for changing the user PIN on
the FortiVoice user portal is in the online help of the portal.

Receiving and sending fax

Inform the phone users that they can receive and send faxes on the user portal. For more information, see Configuring
fax on page 295.

Using the operator console

If you have enabled the operator role for an extension, inform the extension user so that the user can process corporate
calls on the user portal. For more information, see Operator Role on page 141.

Setting user privileges and preferences

The call features each phone user can use is controlled by the user privilege and preferences settings associated with
the user’s extension. You may need to inform users of the features that they can use.

For information, see Configuring user privileges on page 140 and Setting extension user preferences on page 186.

Setting the feature codes

By default, the FortiVoice unit has feature codes for users to access certain features by dialing the codes. You can go to
Service > Feature Code > Feature Code and double-click a feature name to modify its code and description, but that
does not change the mapping between the code and the feature.

For details, see Modifying feature access codes on page 304.
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Using the dashboard

Dashboard displays system statuses, most of which pertain to the entire system, such as CPU usage and call statistics.
This section includes:

« Viewing the dashboard on page 21
« Viewing Call Statistics on page 26
o Using the CLI Console on page 26

Viewing the dashboard

Dashboard > Status displays first after you log in to the web UI. It contains a dashboard with widgets that each indicate
performance level or other statistics.

By default, widgets display the serial number and current system status of the FortiVoice unit, including uptime, system
resource usage, license information, service status, firmware version, system time, and statistics history.

To view the dashboard, go to Dashboard > Status.
This section includes the following topics:

« Checking the system security on page 21
« Hiding, showing and moving widget on page 24

Checking the system security

Clicking the security alert icon (ﬂ) at the top right corner of the screen displays the system's security status. If there
are any security issues, the icon will have a red exclamation mark.

For information on security settings, see Configuring security settings on page 159.

GUI field Description

Passwords

Password Policy If the SIP password and user PIN policy for
administrators and extension users are met, the shield
icon is green. Otherwise, it is red.
Click Edit Password Policy to set password policies.
See Setting password policies on page 160.

Empty Admin Password If a password is required in the admin password field

Allowed when logging in to the system, the shield icon is green.
Otherwise, it is red.
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GUI field Description

Unsafe SIP Password
Count

Unsafe PIN Count

Unsafe User Password
Count

Unaudited Password Count

Miscellaneous

Phones Not Assigned
Count

Secure TFTP System

FortiVoice Phone System 6.4.3 Administration Guide
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For information on selecting this option, see Setting
password policies on page 160.

This option counts the unsafe SIP passwords for IP and
fax extensions only.

If any unsafe SIP passwords are found, the shield icon is
red. Otherwise, it is green.

Click Password Auditor to verify the strength of IP and
fax extension passwords. See Auditing the extension
passwords on page 161.

This option counts the unsafe voicemail PINs for any
extension type that has a voicemail PIN.

If any unsafe voicemail PINs are found, the shield icon is
red. Otherwise, it is green.

For information on configuring extensions, see Setting
up local extensions on page 164.

This option counts the unsafe user passwords set in /P
Extension > User Setting > Web Access and includes
all extension types except branch page extensions.

If any unsafe user passwords are found, the shield icon is
red. Otherwise, it is green.

For information on setting user passwords, see
Configuring IP extensions.

This option counts the newly added extensions of which
the passwords have yet to be audited.

If any unaudited passwords are found, the shield icon is
red. Otherwise, it is green.

For information on verifying the strength of extension
passwords. See Auditing the extension passwords.

This option counts the number of phones that have not
been assigned extensions yet.

If any phones without extensions are found, the shield
icon is red. Otherwise, it is green.

For information on assigning phones to extensions, see
Configuring desktop phones on page 147.

Clicking the delete icon removes all unassigned phones.

This option monitors if the system TFTP is enabled.
If TFTP is enabled, the shield icon is red.
If TETP is disabled, the shield icon is green.
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GUI field Description

Secure TFTP Interfaces

HTTP Interfaces

Administrator Trusted
Hosts

Conflicting Numbers Count

Send Alert
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Clicking Edit allows you to enable or disable the system
TFTP, which also enables or disables TFTP settings in
System > Advanced > Service/Auto Provisioning. For
details, see Configuring the internal ports on page 95
and Configuring SIP phone auto-provisioning on page
96.

This option monitors if TFTP is enabled on the port
interfaces.

If TFTP is enabled, the shield icon is red.
If TETP is disabled, the shield icon is green.

If you have TFTP enabled on multiple ports, they will be
listed and

you can click a link to disable it. For details, see
Configuring the network interfaces on page 42.

This option monitors if HTTP is enabled on the port
Interfaces.

If HTTP is enabled, the shield icon is yellow (warning).
If HTTP is disabled, the shield icon is green.

If you have HTTP enabled on multiple ports, they will be
listed and

you can click a link to disable it. For details, see
Configuring the network interfaces on page 42.

This option monitors if trusted hosts are configured on
the system administrator account.

If trusted hosts are not configured, the shield icon is red.
If trusted hosts are configured, the shield icon is green.

This option counts the number of conflicting extension
numbers.

If any of conflicting extension numbers are found, the
shield icon is red. Otherwise, it is green.

You can click View to see the conflicting numbers.

For information on editing the extension numbers, see
Auditing extension numbers and MAC addresses on
page 178.

Click to email the security audit details to recipients
configured in Log & Reports > Alert > Configuration.

For details, see Configuring alert email on page 324.
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Hiding, showing and moving widget
The dashboard is customizable. You can select which widgets to display, where they are located on the tab, and

whether they are minimized or maximized.

To move a widget, position your mouse cursor on the widget’s title bar, then click and drag the widget to its new
location.

To show or hide a widget select Manage Widget and then select the widgets you want displayed on the Dashboard. If
the widget is greyed out, the widget will not display. Select Apply when you have made your selections.

Options vary slightly from widget to widget, but always include options to close, refresh, or minimize/maximize the
widget.

System Information widget

The System Information widget displays the serial number and basic system statuses such as the firmware version,
system time, and up time.

In addition to displaying basic system information, the System Information widget lets you change the firmware. To
change the firmware, click Update for Firmware version. For more information, see Installing firmware on page 371.

The number of phones that are auto discovered but have not been assigned extensions are also displayed. If this
number is abnormally high, it may mean the FortiVoice unit is under MAC address flooding attack and its performance
will be compromised. You can remove the phones.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

License Information widget

The License Information widget displays the last queried license statuses for the number of extensions supported (if
you use FortiVoice VM), hotel management, call center (if you have purchased these options), FortiFone softclient, and
third party phones.

Depending on the license you have purchased, when you first access the FortiVoice web-based manager, you need to
upload the license to enable the functions you need.

To upload the license file, first place the license file to your management computer, then click Update license and
browse for the license file.

Ay
‘?' A full VMware license is required to upload a hotel management license onto the FortiVoice
VM.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.
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System Resource widget

The System Resource widget displays the CPU, memory, and disk space usage. It also displays the system load and
current number of |P sessions.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

The system resources history can also be viewed in this widget by clicking History. The system resources history
contains four graphs. Each graph displays readings of one of the system resources: CPU, memory, IP sessions, and
network bandwidth usage. Each graph is divided by a grid.

Statistics History widget

The Statistics History widget contains charts that summarize the number of calls in each time period that the
FortiVoice unit recorded.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

Also see Viewing Call Statistics on page 26.

Service Status widget

The Service Status widget displays the number of current calls, extension status, trunk status, and device connection
status.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

Device (200D-T and 2000E-T2 models only) displays the connection status of the FortiVoice physical ports:

« Connected: The port is connected to a device.

« Disconnected: The port is not connected to any device and is ready for use.
e Alarmed: The port has an error and is not usable.

o Occupied: The port is being used.

Recent Call widget

The Recent Call widget displays the calls processed by the FortiVoice unit, including phone numbers, call directions,
call starting time and duration, and call status.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

The maximum call records shown is 8.
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Viewing Call Statistics

The Dashboard > Call Statistics tab contains summaries of the number of calls by time and direction that the
FortiVoice unit recorded.

Using the CLI Console

Go to Dashboard > Console to access the CLI without exiting from the web UI.

You can click the Open in New Window button at the bottom of the page to move the CLI Console into a pop-up
window that you can resize and reposition.
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Monitoring the FortiVoice system

The Monitor menu displays system usage, log messages, reports, and other status-indicating items.
This topicincludes:

« Viewing phone system status on page 27

« Viewing extensions and devices on page 29
« Viewing call records on page 33

« Viewing generated reports on page 34

« Viewing log messages on page 35

« Viewing call directory on page 37

o Blocking SIP device |P addresses on page 37
« Viewing call/fax storage on page 38

Viewing phone system status

Monitor > Phone System displays all the ongoing phone calls, parked calls, conference calls, trunks, and DHCP clients.
This topic includes:

« Viewing active calls on page 27

« Viewing parked calls on page 27

« Viewing conference calls on page 28
« Viewing trunk status on page 28

o Viewing DHCP client list on page 28

Viewing active calls

Monitor > Phone System > Active Calls displays all the ongoing phone calls in realtime, including the callers and
receivers, the trunks through which phone calls are connected, the call status, and the call duration.

You can stop a phone call by clicking the Hang up icon.
The call statuses include:

e Ringing: The receiver’s phone is ringing.
o Connected: Callers are connected. The voice channel is established.
o Voicemail: The call goes to the voicemail.

Viewing parked calls

A parked call is similar to a call that is on hold, except that the parked call can then be picked up from any extension.

To view parked calls, go to Monitor > Phone System > Parked Call.
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For more information on call parking, see Configuring call parking on page 295.

Viewing conference calls

Monitor > Phone System > Conference displays the conference call records, including the name of the conference call,
the extension number of the call, the displayed name of the caller, and the call duration.

You can stop a caller from attending the conference call by selecting the caller and clicking the Kick Out icon.

For more information, see Configuring conference calls on page 278.

Viewing trunk status

Monitor > Phone System > Trunk displays all the trunks in realtime, including their names, IP addresses, types, status,
and registration/connection status with the VolP or PSTN service provider.

Registration/Connection indicates if a trunk has been registered with or connected to the VolP or PSTN service
provider.

The trunk statuses include:

« Not registered: The trunk is not registered with the VolP or PSTN service provider and is not in service.
o Inservice: The trunk is registered with the VolP or PSTN service provider and is in service.

o Unavailable: The trunk is not reachable.

o Alarm detected: There is a problem with the trunk.

o Admin down: The trunkis disabled.

« Unmonitored. The trunk is not monitored.

You can stop a phone call by clicking the Hang up icon.

For more information, see Configuring trunks on page 204.

Viewing DHCP client list

Monitor > Phone System > DHCP displays all the DHCP-enabled devices connected to the FortiVoice unit in realtime.

After a DHCP-enabled phone connects to the FortiVoice unit and is auto-discovered, the FortiVoice unit assigns an IP
address to the phone and sends the basic PBX setup information to it.

For the supported DHCP-enabled phone to connect to the FortiVoice unit:

« Inthe FortiVoice DHCP server configuration, select DHCP option 66 (an advanced option on the web-based
manager) and include the IP address of the FortiVoice interface connected to the same network as the SIP phones
to be auto-provisioned. For more information, see Configuring DHCP server on page 47.
DHCP server option 66 identifies a TFTP server and includes the IP address of the TFTP server and downloads the
TFTP server identity to the device that gets an IP address from the DHCP server. DHCP option 66 is defined in
RFC 2132.

« If using your own DHCP server, set the DHCP server option 66 to the FortiVoice unit’'s TFTP server (Opt66) value.
For more information, see Configuring DHCP server on page 47.

« If the FortiVoice unit and the SIP phone with an IP assigned by a DHCP server are on different subnets, proper
route should be set to make them reachable.
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Export Select to save the DHCP client list in csv format.
MAC Address The Media Access Control address (MAC address) of the DHCP client.
Interface The FortiVoice unit port to which the DHCP client connects. For information on FortiVoice

interfaces, see Configuring network settings on page 40.

IP The IP address of the DHCP client assigned by the FortiVoice DHCP server.

Expiry Time The expiration time of the DHCP client IP address.

Device Type The brand names of the DHCP clients.

Extension When a DHCP-enabled device connects to the FortiVoice unit, the FortiVoice unit assigns

a temporary ID to the device if it is a supported device. If an extension number is
assigned to the phone, the extension number appears. For information on assigning
extensions, see Viewing desktop FortiFones on page 30.

Configuration Status « OK: The DHCP client is assigned to a new or an existing extension user.
o Not assigned: The DHCP client is not assigned to a new or an existing extension
user.
« Misconfigured: The DHCP client’s configuration has errors.

Viewing extensions and devices

Monitor > Extension & Device displays all the extensions, the extensions configured for hot desking, desktop
FortiFones, software FortiFones, and generic SIP phones.

This topicincludes:

« Viewing extension status on page 29

« Viewing desktop FortiFones on page 30

« Viewing software FortiFone phones on page 31

« Viewing generic SIP phones on page 31

« Viewing activity details of hot desking extensions on page 31
« Viewing unmanaged gateways on page 32

Viewing extension status

Monitor > Extension & Device > Extension displays all the extensions in realtime, including their statuses, numbers,
display names, types, IP addresses for SIP extensions, phone information, and if it has any auxiliary devices.

For more information, see Configuring extensions on page 164.
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Viewing desktop FortiFones

Monitor > Extension & Device > Phone lists the supported phones auto-discovered by the FortiVoice unit, assigned or

not assigned to any extension

S.

After an unassigned phone connects to the FortiVoice unit and is auto-discovered, the FortiVoice unit assigns an IP
address to the phone and sends the basic PBX setup information to it.

After assigning an extension to the phone, the extension’s full configuration file will be sent to the phone if the auto-

provisioning option is selected in the user privilege applied to the extension. For details, see Setting up local extensions

on page 164 and Configuring user privileges on page 140.

GUI field Description

New

Delete

Action

Click to add a new desktop FortiFone. For details, see Configuring desktop phones on
page 147.

Select one or more SIP phone records and click this button to remove them all at once.

Assign to New Extension: Select a SIP phone in Not Assigned management
status and click this option to add an extension and assign this phone to the
extension at the same time. For more information, see To assign a new extension
user to an unassigned phone on page 31.

Assign to Existing Extension: Select an unassigned phone and click this option to
assign this phone to an existing extension. The phone record disappears from the
Unassigned Phone list. For more information, see To assign a new extension user
to an unassigned phone on page 31.

Assign as Auxiliary to Existing Extension: Select a SIP phone in Not Assigned
management status and click this option to assign it to an existing extension as an
auxiliary device. For more information, see To assign a new extension user to an
unassigned phone as an auxiliary device on page 31and Configuring IP extensions
on page 164.

View Phone Configuration: Select a SIP phone in Assigned management status
and click this option display its configuration file.

View accounts: For FortiFone phones to which multiple extensions can be
associated, such as FON-850/860/870 and FON-D70/D71/D72, click this option to
view the associated extensions. This option is only active when a FortiFone phone
has multiple extensions associated with it.

Export: Select to save the extension list in CSV format.

MAC Address The Media Access Control address (MAC address) of the SIP phone.

Phone Model The phone brand and model.

Number The extension number of the phone.

Display Name The name displaying on the phone, such as John Doe.

IP The IP address of the phone assigned by the FortiVoice unit.

Phone Info The model, MAC address, and firmware version of the phone for this extension.

Phone Profile The profile for this phone. See Configuring SIP profiles on page 131.
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GUI field Description

Management Displays if the phone has been assigned to an extension.
Status Displays if the phone is registered with the FortiVoice unit. A registered phone is
assigned an |IP address and basic PBX setup information.
To assign a new extension user to an unassigned phone

Go to Monitor > Extension & Device > Phone.
Select a phone in Not assigned status.
Click Action and select Assign to New Extension.

1
2
3
4. Review the extension details and click Next. For details, see Configuring IP extensions on page 164.
5. Review the phone details and click Next.

6

Review the summary and click Finish.
To assign an existing extension user to an unassigned phone

Go to Monitor > Extension & Device > Phone.
Select a phone in Not assigned status.
Click Action and select Assign to Existing Extension.

Review the extension details and click Next. For details, see Configuring IP extensions on page 164.

1
2
3
4. Select the extension to associate with the unassigned phone and click Next.
5
6. Review the phone details and click Next.

7

Review the summary and click Finish.
To assign a new extension user to an unassigned phone as an auxiliary device

1. Go to Monitor > Extension & Device > Phone.

2. Select a phone in Not assigned status.

3. Click Action and select Assign as Auxiliary to Existing Extension.

4. Select the extension to associate with the unassigned phone and click Next.

5. Review the extension details and click Next. For details, see Configuring IP extensions on page 164.
6. Review the phone details and click Next.
7. Review the summary and click Finish.

Viewing software FortiFone phones

Monitor > Extension & Device > Soft FortiFone lists the software FortiFone phones auto-discovered by the FortiVoice
unit.

Viewing generic SIP phones

Monitor > Extension & Device > Generic Phone lists the third party SIP phones auto-discovered by the FortiVoice unit.

Viewing activity details of hot desking extensions

Monitor > Extension & Device > Hot Desking displays details of hot desking users, including:
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o Logout: Click to log out a Hot-Desked phone

o Renew: Click to refresh the expiration of the hot desk session.

« Status:The status of the hot desking extension: logged in or logged out.
e Number. The hot desking extension number.

« Display Name: The name displayed on the hot desking extension.

o Host Device: The extension number or MAC address (for a unassigned phone) of the phone that a hot desking
user logs into.

o Last Login: The last login time at the host device.
« Expiry: The login expiry time.

Hot desking enables users to log into another phone. However, unlike using Follow Me or Call Forwarding which simply
redirect a user's calls to another user’s phone, hot desking takes total control of another phone by applying all of the
user's own phone settings to that phone until the user logs out. Each user can log into another phone by pressing *11
and enter his extension number and user PIN following the prompts. To log out, a user can press *12.

Depending of the phone model, the host phone may reboot.

For information on configuring hot desking, see Hot-desking on page 143.

Viewing unmanaged gateways

Monitor > Extension & Device > Unmanaged Gateway lists the supported FortiVoice gateways auto-discovered by the
FortiVoice unit but not added to the FortiVoice unit.

After a gateway connects to the FortiVoice unit and boots up, it will automatically discover the FortiVoice unit through
SIP PNP.

After adding a FortiVoice gateway to the FortiVoice unit, the gateway'’s full configuration file will be sent to the gateway.
For details, see Managing FortiVoice gateways, local survivability, and firmware on page 154.

GUI field Description

Action « Create New Device: Select an unmanaged gateway and click this option to add the
gateway to the FortiVoice unit. The gateway record disappears from the
Unmanaged Gateway list. For more information, see To add a gateway to the
FortiVoice unit on page 32
« Replace Existing Device: If you need to replace a gateway for any reason, select
the gateway and click this option to find a new gateway for replacement. For more
information, see To replace an existing gateway on page 33.

Serial number The serial number of the unmanaged gateway.
Type The gateway brand and model.
IP The IP address of the unmanaged gateway assigned by the FortiVoice unit.

To add a gateway to the FortiVoice unit

1. Go to Monitor > Extension & Device > Unmanaged Gateway.
2. Select an unmanaged gateway.
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3. Click Action and select Create New Device.

GUI field Description

Name Enter a unique name for the gateway.

Enabled Select to activate the gateway if required.

Display Name The name displaying on the gateway, such as ABC Company Gateway.
Hostname/IP address Enter the hostname or IP address of LAN1 of the gateway. If you are using a

different network interface, enterits IP. If the gateway has been configured to
use a different HTTPS port, enter the port number after the IP address.

« Get device information: Click to get the serial number, device type, and
Mac address of the gateway. This will confirm the systems are able to
communicate with each other and that the password entered is valid. If
preconfiguring the system before deployment, manually enter in the serial
number and MAC address of the gateway.

« Connect Device: Click to go to the Web GUI of the gateway.

Admin user name Enter the user name for logging into the gateway.

Admin password Enter the password for logging into the gateway.

If you want to change the administrator password for logging into the gateway,
click Change password, enable and enter the new password, confirm it, and

click OK.
Serial number The serial number of the gateway.
Type Select the gateway brand and model.
MAC address Enter the Mac address of the gateway.
Description Enter any comments for the gateway.

4. Click Finish.
To replace an existing gateway

Go to Monitor > Phone System > Unmanaged Gateway.
Select the gateway to be replaced.

Click Action and select Replace existing device.

Select a new device to replace the old one.

Click Next.

Click Close.

o0 ~oDd-=

Viewing call records

Monitor > Call History > Call Detail Record (CDR) displays all the phone calls made during a certain time period,
including time of the call, caller and receiver, call duration, call status, call direction, trunks used, call type, and call
recordings.
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Double-clicking a record displays the detailed call information, including the CDR flow.
Using the More Action dropdown list, you may select a caller or callee and add them to your contact list or block them.

You can filter the call records display by clicking the Search button and enter criteria that records must match in order to
be visible. You can also save the call records by selecting an option under Download. If you enable With call flow, you
can download call records with detailed call flow information.

Viewing generated reports

The Call Report submenu displays the call reports and call center reports generated by the FortiVoice unit. You can
delete, view, and/or download generated reports.

FortiVoice units can generate reports automatically according to the report schedules that you configure. For more
information, see Configuring call center report profiles and generating reports on page 260.

L}
‘Q' To reduce the amount of hard disk space consumed by reports, regularly download then
- delete generated reports from the FortiVoice unit.

To view call or call center reports

1. Go to Monitor > Call Report> Report/Call Center Report.

GUI field Description

Download Click to create a PDF or HTML version of the report.
Directory Lists the name of the generated report, and the date and time at which it was
generated.

For example, Report 1-2012-03-31-2112 isareport named Report 1,
generated on March 31, 2012 at 9:12 PM. To view an individual section of the report
in HTML format, click + next to the report name to expand the list of HTML files that
comprise the report, then double-click one of the file names.

Last Access Time Lists the date and time when the FortiVoice unit completed the generated report.

Size Lists the file size of the report in HTML format, in bytes.

2. To view the report in PDF file format, select a report and click Download. On the pop-up menu, select Download
PDF.

3. To view the report in HTML file format, you can view all sections of the report together, or you can view report
sections individually.

« Toview all report sections together, select a report, suchas 2020-01-31-2112, then click Download and
select Download HTML. Your browser downloads a file with an archive (. tgz . gz) file extension to your
management computer. To view the report, first extract the report files from the archive, then open the HTML
files in your web browser.

« Each Query Selection in the report becomes a separate HTML file. You can view the report as individual
HTML files. In the row corresponding to the report that you want to view, click + next to the report name to
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expand the list of sections, then double-click the file name of the section that you want to view, such as
reportl.html. The report appearsin a new browser window.

4. To view the report in CSV (comma-separated value) file format that can be viewed in a spreadsheet application
such as Microsoft Excel or OpenOffice Calc, select a report and click Download. On the pop-up menu, select
Download CSV.

Viewing log messages

The Log submenu displays locally stored log files. If you configured the FortiVoice unit to store log messages locally
(that is, to the hard disk), you can view the log messages currently stored in each log file.

Logs stored remotely cannot be viewed from the web-based manager of the FortiVoice unit. If you want to view logs
from the web-based manager, also enable local storage. For details, see Configuring logs and reports on page 311.

Monitor > Log displays the logs of administrator activities and system events as well as mail, voice, fax, hotel
management (with license only), call queue (with call center license only), call center (with license only), and phone
configuration.

The log messages vary by levels. For more information, see Configuring logs and reports on page 311.
The log messages are also filtered by subtypes depending on log types.
To view the log files and their contents

1. Go to Monitor > Log > System/Generic/Voice/Fax/Queue/Hotel/Call Center/Phone Configuration.
The list of the latest log files appears with the beginning and end of a log file’s time range and the size of a log file
in bytes. The queue log files display more information.

2. To view messages contained in logs, double-click a log file.

To view the current page’s worth of the log messages, right-click and select Export. You can then open or save the
.csv file. See Using the right-click pop-up menus on page 36.

3. To search the log files, click the Search button and enter criteria that records must match in order to be visible.
Unlike the search when viewing the contents of an individual log file, this search displays results regardless of which
log file contains them. For more information, see Searching log messages on page 36.

4. Toview all log files, click List.

All log files display. You can select a log file to view, delete, or download it. Click Back to go to the list of the latest
log files.

5. Click the Configure View icon to show or hide columns, save the customized view, or reset the view to default.
When you save a customized view, future log message reports appear in this view.

Displaying and arranging log columns

When viewing logs, you can display, hide, sort and re-order columns.

For most columns, you can also filter data within the columns to include or exclude log messages which contain your
specified text in that column. For more information, see Searching log messages on page 36.

By default, each page’s worth of log messages is listed with the log message with the lowest index number towards the
top.

To sort the page’s entries in ascending or descending order
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1. Click the column heading by which you want to sort.
The log messages are sorted in ascending order.

2. To sort in descending order, click the column heading again.
Depending on your currently selected theme:

« The column heading may darken in color to indicate which column is being used to sort the page.

« A small upwards-or downwards-pointing arrow may appear in the column heading next to its name to indicate
the current sort order.

To display or hide columns

1. Go to Monitor > Log > System /Generic/Voice/Fax/Queue/Hotel/Call Center/Phone Configuration.
2. Click Configure View(icon) > Show/Hide Columns.

3. Mark the check boxes of columns that you want to display.

4. Click OK.

To change the order of the columns

1. Go to Monitor> Log > System /Generic/Voice/Fax/ Queue/Hotel/Call Center/Phone Configuration.
2. For each column whose order you want to change, click and drag its column heading to the left or right.
3. Click Configure View (icon) > Save View.

Using the right-click pop-up menus

When you right-click on a log message, a context menu appears.

Log report right-click menu options

View Details Select to display the content of the log message.

Select All Select to select all log messages in the current page, so that you can export all messages
to a table.

Clear Selection Select to deselect one or multiple log messages.

Export Select to export the selected log messages as a .csv file.

Searching log messages

You can search logs to quickly find specific log messages in a log file, rather than browsing the entire contents of the log
file.

To search log messages

1. Go to Monitor > Log > System/Generic/Voice/Fax/Queue/Hotel/Call Center/Phone Configuration.
2. Click Search.
3. Enter your search criteria by configuring one or more of the following:

GUI field Description

Keyword Enter any word or words to search for within the log messages.

For example, you might enter GUT session to locate all log messages containing
that exact phrase in any log field.
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Message Enter all or part of the Message log field.
Log ID Enter all or part of the log ID in the log message.
Match condition » Contain: searches for the exact match.

o Wildcard. supports wildcards in the entered search criteria.

Date Select the start and end time of log messages to include in the search results.

Time span Select the time span of log messages to include in the search results.

For example, you might want to search only log messages that were recorded during
the two weeks and 8 hours previous to the current date. In that case, you would
specify the current date, and also specify the size of the span of time (two weeks and
8 hours) before that date.

Load Previous Setting Select to populate the fields with the settings entered previously.

4. Click Search.
The FortiVoice unit searches for log messages that match your search criteria, and displays any matching log
messages.

Viewing phone configuration logs

Monitor > Log > Phone Configuration displays the phone configuration logs.
For information on phone configuration update and firmware upgrade jobs. See Maintaining phones on page 107.

Viewing call directory

The Monitor > Directory menu lets you view phone directories. For more information, see Creating contacts.

Blocking SIP device IP addresses

The FortiVoice unit automatically blocks the IP addresses of the SIP devices that initiate the attacks against any
extensions based on the thresholds and parameters set. For more information on configuring security settings, see
Configuring intrusion detection on page 159.

For blocked IP addresses, you may select an IP address to delete it, add it to the exempt list if it is wrongly blocked, and
view its blocked history.

For auto exempt IP addresses, you may select an IP address to delete it if you find it suspicious.
To view the blocked IP addresses, go to Monitor > Security > Blocked IP.

To view the exempted IP addresses, go to Monitor > Security > Auto Exempt IP.
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Setting the security parameters

You can use the CLI to set the threshold for blocking IP addresses and sending alert email (the default is 50 attempted
logins per minute), the time interval to check the phone call activities (the default is 60 seconds), and the maximum
notification emails to send after the threshold is reached (the default is 100).

config security sip-authentication-failure
set threshold
set interval
set max-notification

end

Viewing call/fax storage

Monitor > Storage displays the recorded calls, faxes, archived faxes, and faxes in queue.
This topic includes:

o Playing recorded calls on page 38

« Viewing current fax accounts on page 38
« Viewing archived faxes on page 39

+ Viewing fax queues on page 39

Playing recorded calls

The Recorded Call tab lists the calls recorded by the FortiVoice unit.

To listen to a call, go to Monitor > Storage > Recorded Call and double-click a call record folder to open the archived
call files. Select a call file and click the Play button.

To save a recorded call, go to Monitor > Storage and select a call record folder to open the archived call files. Select a
call file and click the Download button.

To search recorded calls, go to Monitor > Storage > Recorded Call , click Search, then New, enter the search values,
and click Create. Note that under Recording type, Conference refers to calls recorded based on the phone numbers
that are conference call numbers. System refers to all other type of calls recorded.

For information on configuring recording calls, see Recording calls on page 280.

Viewing current fax accounts

The Fax tab lists the fax accounts created on the FortiVoice unit. For more information about creating fax accounts, see
Configuring fax on page 295.

To view fax accounts, go to Monitor > Storage > Fax. The fax accounts are listed with their names, numbers, display
names, storage sizes, and faxes stored.

You can double-click a fax account and view the detailed information on the faxes it stores.

o Forward: Select a fax, click this option and enter the extension to which you want to forward the fax.
o Download PDF: Select a fax and click this option to save it.
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Viewing archived faxes

The Fax Archive tab lists the faxes sent and received through the FortiVoice unit. For more information about fax, see
Configuring fax on page 295.

To view archived faxes, go to Monitor > Storage > Fax Archive.

To search archived fax, go to Monitor > Storage > Fax Archive, click Search, then New, enter the search values, and
click Create.

You can double-click a fax folder and view the detailed information on the faxes it stores.
Viewing fax queues

The Fax Queue tab lists the faxes waiting to be sent or having failed to be sent on the FortiVoice unit. You can
download the faxes. For more information about fax, see Configuring fax on page 295.
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Configuring system settings

The System menu lets you set up configurations of the FortiVoice operation system, including administrator accounts,
network settings, system time, SIP settings, system maintenance, and more.

This topic includes:

Configuring network settings on page 40

Configuring administrator accounts and access profiles on page 49
Configuring RAID on page 52

Using high availability on page 55

Working with system configurations on page 75

Configuring advanced phone system settings on page 92
Managing certificates on page 98

Maintaining the system on page 105

Configuring network settings

The Network submenu provides options to configure network connectivity and administrative access to the web-based
manager or CLI of the FortiVoice unit through each network interface.

This topic includes:

About IPv6 Support on page 40

About the management IP on page 41

About FortiVoice logical interfaces on page 41
Configuring the network interfaces on page 42
Configuring static routes on page 45
Configuring DNS on page 46

Configuring DHCP server on page 47
Capturing voice and fax packets on page 48

About IPv6 Support

IP version 6 (IPv6) handles issues that were not around decades ago when IPv4 was created such as running out of IP
addresses, fair distributing of IP addresses, built-in quality of service (QoS) features, better multimedia support, and
improved handling of fragmentation. A bigger address space, bigger default packet size, and more optional header
extensions provide these features with flexibility to customize them to any needs.

IPv6 has 128-bit addresses compared to IPv4’s 32-bit addresses, effectively eliminating address exhaustion. This new
very large address space will likely reduce the need for network address translation (NAT) since IPv6 provides more than
a billion IP addresses for each person on Earth. All hardware and software network components must support this new
address size, an upgrade that may take a while to complete and will force IPv6 and IPv4 to work side-by-side during the
transition period.

The FortiVoice unit supports the following IPv6 features:
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« Network interface
« Network routing

« DNS

« DHCP

« Phone extension
e Trunk

About the management IP

The FortiVoice unit has an IP address for administrators to configure it through a network connection rather than a local
console. The management |P address enables administrators to connect to the FortiVoice unit through port1 or other
network ports, even when they are currently bridging.

By default, the management IP address is indirectly bound to port 1 through the bridge. If other network interfaces are
also included in the bridge with port1, you can configure the FortiVoice unit to respond to connections to the
management |IP address that arrive on those other network interfaces.

You can access the web-based manager and the FortiVoice user account using the management IP address. For
details, see Connecting to the web-based manager on page 15.

About FortiVoice logical interfaces

In addition to the FortiVoice physical interfaces, you can create the following types of logical interfaces on the FortiVoice
unit:

« VLAN subinterfaces on page 41

« Redundant interfaces on page 42

o Loopback interfaces on page 42

VLAN subinterfaces

AVirtual LAN (VLAN) subinterface, also called a VLAN, is a virtual interface on a physical interface. The subinterface
allows routing of VLAN tagged packets using that physical interface, but it is separate from any other traffic on the
physical interface.

Virtual LANs (VLANSs) use ID tags to logically separate devices on a network into smaller broadcast domains. These
smaller domains forward packets only to devices that are part of that VLAN domain. This reduces traffic and increases
network security.

One example of an application of VLANs is a company’s accounting department. Accounting computers may be located
at both main and branch offices. However, accounting computers need to communicate with each other frequently and
require increased security. VLANSs allow the accounting network traffic to be sent only to accounting computers and to
connect accounting computers in different locations as if they were on the same physical subnet.

For information about adding VLAN subinterfaces, see Configuring the network interfaces on page 42.

FortiVoice Phone System 6.4.3 Administration Guide 41
Fortinet Technologies Inc.



Configuring system settings

Redundant interfaces

On the FortiVoice unit, you can combine two or more physical interfaces to provide link redundancy. This feature allows
you to connect to two or more switches to ensure connectivity in the event one physical interface or the equipment on
that interface fails.

In a redundant interface, traffic is only going over one interface at any time. This differs from an aggregated interface
where traffic is going over all interfaces for increased bandwidth. This difference means redundant interfaces can have
more robust configurations with fewer possible points of failure. This is important in a fully-meshed high availability (HA)
configuration.

A physical interface is available to be in a redundant interface if:

« itisaphysical interface, not a VLAN interface

« itis not already part of a redundant interface

« it has no defined IP address and is not configured for DHCP
« it does not have any VLAN subinterfaces

« itis not monitored by HA

When a physical interface is included in a redundant interface, it is not listed on the System > Network > Network
page. You cannot configure the interface anymore.

For information about adding redundant interfaces, see Configuring the network interfaces on page 42.

Loopback interfaces

A loopback interface is a logical interface that is always up (no physical link dependency) and the attached subnet is
always present in the routing table.

The FortiVoice’s loopback IP address does not depend on one specific external port, and is therefore possible to access
it through several physical or VLAN interfaces. In the current release, you can only add one loopback interface on the
FortiVoice unit.

For information about adding a loopback interface, see Configuring the network interfaces on page 42.

Configuring the network interfaces

The System > Network > Network tab displays the FortiVoice unit’s network interfaces.

You must configure at least one network interface for the FortiVoice unit to connect to your network. Depending on your
network topology and other considerations, you can connect the FortiVoice unit to your network using two or more of the
network interfaces. You can configure each network interface separately. You can also configure advanced interface
options, including VLAN subinterfaces, redundant interfaces, and loopback interfaces. For more information, see About
FortiVoice logical interfaces on page 41, and Editing network interfaces on page 43.

To view the list of network interfaces, go to System > Network > Network.

GUI field Description

Name Displays the name of the network interface, such as port1.
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Type Displays the interface type: physical, VLAN, redundant, or loopback. For details,
see About FortiVoice logical interfaces on page 41.

IP/Netmask Displays the IP address and netmask of the network interface.

IPv6/Netmask Displays the IPv6 address and netmask of the network interface. For more

information about IPv6 support, see About IPv6 Support on page 40.

Access Displays the administrative access and phone user access that are enabled on the
network interface, such as HTTPS for the web-based manager.

Status Indicates the up (available) or down (unavailable) administrative status for the
network interface.
« Green up arrow: The network interface is up and can receive traffic.
o Red down arrow: The network interface is down and cannot receive traffic.
To change the administrative status (that is, bring up or down a network
interface), see Editing network interfaces on page 43.

Referenced (icon) Indicates if a network interface is used by other services, such as DHCP.
A green dot means a network interface is used by other services.
A gray dot means a network interface is not used by other services.

Editing network interfaces

You can edit FortiVoice’s physical network interfaces to change their IP addresses, netmasks, administrative access
protocols, and other Setting. You can also create or edit logical interfaces, such as VLANSs, redundant interfaces and the
loopback interface.

Enable administrative access only on network interfaces connected to trusted private
networks or directly to your management computer. If possible, enable only secure

administrative access protocols such as HTTPS or SSH. Failure to restrict administrative
access could compromise the security of your FortiVoice unit.

You can restrict which IP addresses are permitted to log in as a FortiVoice administrator through network interfaces. For
details, see Configuring administrator accounts on page 50.

To create or edit a network interface

1. Goto System > Network > Network.

2. Double-click a network interface to modify it or select the interface and click Edit. If you want to create a logical
interface, click New.
The Edit Interface dialog appears.
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3. Configure the following:

GUI field Description

Interface Name If you are editing an existing interface, this field displays the name (such as
port2) and media access control (MAC) address for this network interface.

If you are creating a logical interface, enter a name for the interface.

Type If you are creating a logical interface, select which type of interface you want
to create. For information about logical interface types, see About FortiVoice
logical interfaces on page 41.

« VLAN: If you want to create a VLAN subinterface, select the interface for
which you want to create the subinterface. Then specify a VLAN ID. Valid
VLAN ID numbers are from 1 to 4094, while 0 is used for high priority
frames, and 4095 is reserved.

o Redundant: If you want to create a redundant interface, click +in the
Interface Member field to add interface members. Usually, you need to
include two or more interfaces as the redundant interface members.

« Loopback: If you want to add a loopback interface, select the Loopback
type and the interface name will be automatically reset to “loopback”. You
can only add one loopback interface on the FortiVoice unit.

Addressing Mode o Manual: Select to enter the IP address or IPv6 address and netmask for
the network interface in IP/Netmask or IPv6/Netmask.
o DHCP: Select and click Update request to retrieve a dynamic IP address
using DHCP.

Advanced Setting

Access Enable protocols that this network interface should accept for connections to
the FortiVoice unit itself. (These options do not affect connections that will
travel through the FortiVoice unit.)

« HTTPS: Enable to allow secure HTTPS connections to the web-based
manager, and extension user account through this network interface.

e HTTP: Enable to allow HTTP connections to the web-based manager,
and extension user account through this network interface.

o PING: Enable to allow ICMP ECHO (ping) responses from this network
interface.

o SSH: Enable to allow SSH connections to the CLI through this network
interface.

o SNMP: Enable to allow SNMP connections (queries) to this network
interface.
For information on further restricting access, or on configuring the
network interface that will be the source of traps, see Configuring the
network interfaces on page 42.

o TELNET: Enable to allow Telnet connections to the CLI through this
network interface.

o TFTP: Enable to allow TFTP connections to this network interface.

o NTP: Enable to allow SIP phones to connect to this server to synchronize
time.
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GUI field Description

« LDAP: Enable to allow SIP phones to connect to this server to retrieve
phone directories.

o SIPPnP: Enable SIPPnP multicast function for the connected phones to
find the provisioning server contained in its message for the phones.

« MDNS: Enable MDNS multicast function for the connected phones to
find the TFTP provisioning server contained in its message for the
phones. This is mainly for backward support of legacy FortiFones.

HTTP and Telnet connections are not secure, and can be
intercepted by a third party. If possible, enable this option
only for network interfaces connected to a trusted private
network, or directly to your management computer. Failure
to restrict administrative access through this protocol could
compromise the security of your FortiVoice unit. For
information on further restricting access of administrative

connections, see Configuring administrator accounts on
page 50.

e« MTU: For the maximum transmission unit (MTU),enter the maximum
packet or Ethernet frame size in bytes.
If network devices between the FortiVoice unit and its traffic destinations
require smaller or larger units of traffic, packets may require additional
processing at each node in the network to fragment or defragment the
units, resulting in reduced network performance. Adjusting the MTU to
match your network can improve network performance.
The default value is 1500 bytes. The MTU size must be between 68 and
9000 bytes. Change this if you need a lower value; for example, RFC
2516 prescribes a value of 1492 for the PPPoE protocol.

o Administrative status: Select either:

« Up: Enable (that is, bring up) the network interface so that it can
send and receive traffic.

« Down: Disable (that is, bring down) the network interface so that it
cannot send or receive traffic.

Configuring static routes

The System > Network > Routing tab displays a list of routes and lets you configure static routes and gateways used by
the FortiVoice unit.

Static routes direct traffic exiting the FortiVoice unit. You can specify through which network interface a packet will
leave, and the IP address of a next-hop router that is reachable from that network interface. The router is aware of which
IP addresses are reachable through various network pathways, and can forward those packets along pathways capable
of reaching the packets’ ultimate destinations.

A default route is a special type of static route. A default route matches all packets, and defines a gateway router that
can receive and route packets if no other, more specific static route is defined for the packet’s destination IP address.
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You should configure at least one static route, a default route, that points to your gateway. However, you may configure
multiple static routes if you have multiple gateway routers, each of which should receive packets destined for a different
subset of IP addresses.

To determine which route a packet will be subject to, the FortiVoice unit compares the packet’s destination IP address
to those of the static routes and forwards the packet to the route with the large prefix match.

When you add a static route through the web-based manager, the FortiVoice unit evaluates the route to determine if it
represents a different route compared to any other route already present in the list of static routes. If no route having the
same destination exists in the list of static routes, the FortiVoice unit adds the static route.

To view or configure static routes

1. Goto System > Network > Routing.

GUI field Description

Enabled Displays the route status.

Destination Displays the destination IP address and subnet of packets subject to the static route.

IP/Netmask A setting of 0.0.0.0/0.0.0 indicates that the route matches all
destination IP addresses.

Gateway Displays the IP address of the next-hop router to which packets subject to the static
route will be forwarded.

Interface The interface that this route applies to.

Comment Displays any notes on the static route.

2. Either click New to add a route or double-click a route to modify it.
A dialog appears.
3. Select Enable to activate the route.

4. |n Destination IP/netmask, enter the destination IP address and netmask of packets that will be subject to this
static route.
To create a default route that will match all packets, enter 0.0.0.0/0.0.0.0.

5. Select the interface that this route applies to.

6. In Gateway, type the IP address of the next-hop router to which the FortiVoice unit will forward packets subject to
this static route. This router must know how to route packets to the destination IP addresses that you have
specified in Destination IP/netmask. For an Internet connection, the next hop routing gateway routes traffic to the
Internet.

7. Enter any comments you have for the route.
8. Click Create or OK.

Configuring DNS

FortiVoice units require DNS servers for features such as reverse DNS lookups. Your ISP may supply IP addresses of
DNS servers, or you may want to use the IP addresses of your own DNS servers.

Ay

S L4
? For improved FortiVoice unit performance, use DNS servers on your local network.
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The DNS tab lets you configure the DNS servers that the FortiVoice unit queries to resolve domain names into IP
addresses.

To configure the primary and secondary DNS servers

Go to System > Network > DNS.

In Primary DNS server, enter the IP address of the primary DNS server.

In Secondary DNS server, enter the IP address of the secondary DNS server.
Click Apply.

AoODbd-=

Configuring DHCP server

A DHCP server provides an address to a client on the network, when requested, from a defined address range.

You can configure one or more DHCP servers on any FortiVoice interface. A DHCP server dynamically assigns IP
addresses to the clients on the network connected to the interface. These clients must be configured to obtain their IP
addresses using DHCP.

To configure the DHCP server

1. Goto System > Network > DHCP.
2. Click New and configure the following:

GUI field Description

Network Interface Setting

ID The system will generate an ID for this configuration. This is view only.
Enable Select to enable the DHCP server.
Interface If this FortiVoice is in HA mode, make sure that the secondary unit has the

same interface as the primary unit. For information on HA, see Using high
availability on page 55.

Gateway Enter the IP address of the default gateway that the DHCP server assigns to
DHCP clients.

DNS options Select to use either a specific DNS server or the system’s DNS Setting.
If you select a specific DNS server, enter the Primary DNS server and the
Secondary DNS server fields.
For more information, see Configuring DNS on page 46.

Domain Enter the domain that the DHCP server assigns to its clients.

Netmask Enter the netmask of the addresses that the DHCP server assigns.

Advanced Setting

Lease time (Seconds) Enter the length of time an |P address remains assigned to a client. Once the
lease expires, the address is released for allocation to the next client request
for an IP address. The default time is 604800 seconds.
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3.

GUI field Description

Vender Class Identifier  Select this option to apply the DHCP configuration to the phones of a specific
option vendor identified by the VCI string supplied by the vendor or by checking
Monitor > PBX Status > DHCP > VCI.

VCI string Enter the phone VCI string supplied by the vendor.

Option 66 DHCP option 66 allows you to specify the IP addresses that this DHCP server
assigns to the DHCP clients - the extension phones in the case FortiVoice
phone system. The phones obtain the configuration files from these

addresses.

Auto provisioning Click to configure FortiVoice auto-provisioning. For details, see Configuring

settings advanced phone system settings on page 92.

DHCP IP Range Enter the start and end for the range of IP addresses that this DHCP server
assigns to the DHCP clients.

DHCP Excluded IP Enter a range of IP addresses that this server should not assign to the DHCP

Range clients.

Reserved IP Address Enter an IP address from the DHCP server to match it to a specific client using
its MAC address.

In a typical situation, an IP address is assigned ad hoc to a client, and that
assignment times out after a specific time of inactivity from the client, known
as the lease time. To ensure a client always has the same IP address, that is,
there is no lease time, use this option.

Click Create.

Capturing voice and fax packets

When troubleshooting networks, it helps to look inside the contents of the packets. This helps to determine if the

packets, route, and destination are all what you expect. Traffic capture can also be called packet sniffing, a network tap,

or logic analyzing.

Packet sniffing tells you what is happening on the network at a low level. This can be very useful for troubleshooting
problems, such as:

Finding missing traffic.
Seeing if sessions are setting up properly.
Locating ARP problems such as broadcast storm sources and causes.

Confirming which address a computer is using on the network if they have multiple addresses or are on multiple
networks.

Confirming routing is working as you expect.
Intermittent missing PING packets.

If you are running a constant traffic application such as ping, packet sniffing can tell you if the traffic is reaching the
destination, how the port enters and exits the FortiVoice unit, if the ARP resolution is correct, and if the traffic is
returning to the source as expected. You can also use packet switching to verify that NAT or other configuration is
translating addresses or routing traffic the way that you want it to.
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Before you start sniffing packets, you need to have a good idea of what you are looking for. Sniffing is used to confirm or
deny your ideas about what is happening on the network. If you try sniffing without a plan to narrow your search, you
could end up with too much data to effectively analyze. On the other hand, you need to sniff enough packets to really
understand all of the patterns and behavior that you are looking for.

To capture voice and fax packets

1. Goto System > Network > Traffic Capture.

GUI field Description

Stop Click to stop the packet capture.
Download When the capture is complete, click Download to save the packet capture file
to your hard disk for further analysis.
Name The name of the packet capture file.
Size The size of the packet capture file.
Status The status of the packet capture process, Complete or Running.
Click New.

Enter a prefix for the file generated from the captured traffic. This will make it easier to recognize the files.
Enter the time period for performing the packet capture.

o O Dd

For SIP Connection, do the following:

« Inthe Peers field, click + to add the extension or trunk of which you want to capture the voice packets. You can
select up to 3 peers.

« If you want to limit the scope of traffic capture, in the IP/HOST field, enter a maximum of 3 IP addresses or
host names for the extensions and trunks you selected. Only traffic on these |IP addresses or host names is
captured.

6. Select the filter for the traffic capture:
o SIP: Only SIP traffic of the peers you select will be captured.
« Use Protocol: Only UDP or TCP traffic of the peers you select will be captured.
o Capture All: All network traffic will be captured.

7. For Exclusion, enter the IP addresses/host names and port numbers of which you do not want to capture voice
traffic.

8. Click Create.

Configuring administrator accounts and access profiles

The Administrator submenu configures administrator accounts and access profiles.
This topic includes:

o Configuring administrator accounts on page 50
« Configuring administrator profiles on page 52
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Configuring administrator accounts

The Administratortab displays a list of the FortiVoice unit’s administrator accounts and the trusted host IP addresses
administrators use to log in (if configured).

By default, FortiVoice units have a single administrator account, admin. For more granular control over administrative
access, you can create additional administrator accounts with restricted permissions.

To view and configure administrator accounts

1. Goto System > Administrator > Administrator.

Enabled Displays the administrator status.

Name Displays the name of the administrator account.

Admin Profile The administrator profile that determines which functional areas the
administrator account may view or affect.

Authentication Type The administrator authentication type: Local,LDAP or Single Sign On.

Authentication Profile The LDAP authentication profile. For more information, see Configuring LDAP

settings on page 124.

Trusted Hosts Displays the IP address and netmask from which the administrator can log in.

2. Either click New to add an account or double-click an account to modify it.
A dialog appears.
3. Configure the following:

GUI field Description

Enable Click to activate the administrator status. By default, this is enabled.

Administrator Enter the name for this administrator account.

The name can contain numbers (0-9), uppercase and lowercase letters
(A-Z, a-z), hyphens ( - ), and underscores ( _ ). Other special characters and
spaces are not allowed.

Email address Enter the administrator's email address.

Associate extension Select the extension for the administrator account.

If you add an extension, a User portal icon appears at the top of the web-
based manager when you log into the FortiVoice unit. Clicking the icon opens
the user portal.

Click Edit to modify the selected extension or click New to configure a new
one. For more information on extensions, see Configuring IP extensions on
page 164.

Admin profile Select the name of an admin profile that determines which functional areas
the administrator account may view or affect.
Click New to create a new profile or Edit to modify the selected profile. For
details, see Configuring administrator profiles on page 52.

Access mode Specify the access privilege: CLI, GUI, or REST API.
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GUI field Description

REST API is needed for security fabric configuration. See Enabling security
fabric on page 92.

Authentication type

New password

Confirm password

LDAP profile

Trusted hosts type

Trusted Hosts

Select an administrator authentication type: Local, RADIUS, LDAP or Single

Sign On.

For information on single sign on, see Configuring single sign on on page 91.

Enter this account’s password.

The password can contain any character except spaces.
This field does not appear if Authentication type is LDAP.

Do not enter a FortiVoice administrator password less than
six characters long. For better security, enter a longer
password with a complex combination of characters and
numbers, and change the password regularly. Failure to
provide a strong password could compromise the security of
your FortiVoice unit.

Enter this account’s password again to confirm it.
This field does not appear if Authentication type is LDAP.

If you select LDAP for Authentication type, select an LDAP authentication
profile. For more information, see Configuring LDAP settings on page 124.

Select a trusted host type:
o Userdefined: Add details about the hosts in Trusted Hosts.
o RFC 1918 predefined: FortiVoice allows connections from any private IP
addresses specified by the request for comment 1918 (RFC 1918).

Enter an IPv4 or IPv6 address or subnet from which this administrator can log

n.

If you want the administrator to access the FortiVoice unit from any IP
address,use 0.0.0.0/0.0.0.0.
Enter the IP address and netmask in dotted decimal format. For example, you

might permit the administrator to log in to the FortiVoice unit from your private
network by typing 192.168.1.0/255.255.255.0.

A\,

For additional security, restrict all trusted host entries to
administrative hosts on your trusted private network. For
example, if your FortiVoice administrators log in only from
the 10.10.10.10/24 subnet, to prevent possibly fraudulent
login attempts from unauthorized locations, you could
configure that subnet in the Trusted Host #1, Trusted Host
#2, and Trusted Host #3fields.
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4.

GUI field Description

s‘é’, For information on restricting administrative access

protocols that can be used by these hosts, see Editing
network interfaces on page 43.

Click the + sign to add additional IP addresses or subnets from which the
administrator can log in.

Select language Select this administrator account’s preference for the display language of the
web-based manager.

Select theme Select this administrator account’s preference for the display theme or click
Use Current to choose the theme currently in effect.

The administrator may switch the theme at any time during a session by
clicking Next Theme.

Department only Select the checkbox if this is a department administrator.
Description Select Edit to enter any comments for the administrator account.
Departments Click the + sign to add the department to which the administrator belongs.

This option is only available if you select Department only.

Click Create.

Configuring administrator profiles

The Admin Profile tab displays a list of administrator access profiles.

Administrator profiles govern which areas of the web-based manager and CLI that an administrator can access, and
whether or not they have the permissions necessary to change the configuration or otherwise modify items in each area.

To configure administrator access profiles

1.

2.
3.
4

Go to System > Administrator > Admin Profile.
Either click New to add an account or double-click an access profile to modify it.
In Profile name, enter the name for this access profile.

For each access control option, select the permissions to be granted to administrator accounts associated with this
access profile:

o None

e Read Only

o Read-Write
Click Create.

Configuring RAID

If your FortiVoice unit model supports RAID, go to System > RAID to configure a redundant array of independent disks
(RAID) for the FortiVoice unit hard disks that are used to store logs and voice data.
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FVE-2000F, 3000F, 3000E, and 5000F can be configured to use RAID with their hard disks. The default RAID level
should give good results, but you can modify the configuration to suit your individual requirements for enhanced
performance and reliability. For more information, see Configuring RAID on page 53.

RAID events can be logged and reported with alert email. These events include disk full and disk failure notices. For
more information, see About FortiVoice logging on page 311, and Configuring alert email on page 324.

Al
b ] L4
? If your FortiVoice unit model does not support RAID, the RAID menu won'’t be displayed.

About RAID levels

The FortiVoice models supporting RAID use hardware RAID controllers that require that the log disk and voice disk use
the same RAID level.

Each of the models has 2 factory-installed hard drives. The available RAID levels are 0 and 1 and the defaultis 1. You
can replace a hard drive if required. For details, see Replacing a RAID disk on page 55.

Configuring RAID

You can modify the RAID level configuration to suit you individual requirements for enhanced performance and
reliability.

To configure RAID
1. Goto System > RAID > RAID System.

GUI item Description

Model Displays the type of the RAID controller.

Rescan Click to rebuild the RAID unit with disks that are currently a member of it, or
detect newly added hard disks, and start a diagnostic check.

Driver Displays the version of the RAID controller’s driver software.
Firmware Displays the version of the RAID controller’s firmware.
List of RAID units in the array

Device Displays the name of the RAID unit. This indicates whether it is used for voice
data or log message data. This is hard-coded and not configurable.

Unit Indicates the identifier of the RAID unit, such as uO.

Level Indicates the RAID level currently in use. You may change the level.
For more information, see About RAID levels on page 53.

Status Indicates the status of the RAID unit.
o OK: The RAID unit is operating normally.
o Waming: The RAID controller is currently performing a background task
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GUI item Description

Size

Speed

Apply

List of hard disks in the array
ID/Port

Part of Unit

Status

Size

Delete

To change RAID levels

(rebuilding, migrating, or initializing the RAID unit).

Do not remove hard disks while this status is displayed.
Removing active hard disks can cause hardware damage.

o Error: The RAID unit is degraded or inoperable. Causes vary, such as
when too many hard disks in the unit fail and the RAID unit no longer has
the minimum number of disks required to operate in your selected RAID
level. To correct such a situation, replace the failed hard disks.

o No Units: No RAID units are available.

Ay
‘?' If both Error and Warning conditions exist, the status
|| appears as Error.

Indicates the total disk space, in gigabytes (GB), available for the RAID unit.

Available space varies by your RAID level selection. Due to some space being
consumed to store data required by RAID, available storage space will not
equal the sum of the capacities of hard disks in the unit.

Displays the average speed in kilobytes (KB) per second of the data transfer
for the resynchronization. This is affected by the disk being in use during the
resynchronization.

Click to save changes.

Indicates the identifier of each hard disk visible to the RAID controller.

Indicates the RAID unit to which the hard disk belongs, if any.

To be usable by the FortiVoice unit, you must add the hard disk to a RAID
unit.

Indicates the hardware viability of the hard disk.

o OK: The hard disk is operating normally.

o UNKNOWN: The viability of the hard disk is not known. Causes vary,
such as the hard disk not being a member of a RAID unit. In such a case,
the RAID controller does not monitor its current status.

Indicates the capacity of the hard disk, in gigabytes (GB).

Click to unmount a hard disk before swapping it.
After replacing the disk, add it to a RAID unit, then click Rescan.

Back up data on the disk before beginning this procedure. Changing the device’s RAID level
temporarily suspends all mail processing and erases all data on the hard disk. For more

information on creating a backup, see Backing up configuration on page 105.
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Go to System > RAID > RAID System.

From Level, select a RAID level.

Click Apply.

The FortiVoice unit changes the RAID level and reboots.

Replacing a RAID disk

When replacing a disk in the RAID array, the new disk must have the same or greater storage capacity than the existing
disks in the array. If the new disk has a larger capacity than the other disks in the array, only the amount equal to the
smallest hard disk will be used. For example, if the RAID has 400 GB disks, and you replace one with a 500 GB disk, to
be consistent with the other disks, only 400 GB of the new disk will be used.

FortiVoice units support hot swap; shutting down the FortiVoice unit during hard disk replacement is not required.

To replace a disk in the array

1.
2.

Go to System > RAID > RAID System.

In the row corresponding to the hard disk that you want to replace (for example, p4), select the hard disk and click
Delete.

The RAID controller removes the hard disk from the list.
Protect the FortiVoice unit from static electricity by using measures such as applying an antistatic wrist strap.

Physically remove the hard disk that corresponds to the one you removed in the web Ul from its drive bay on the
FortiVoice unit.

Replace the hard disk with a new hard disk, inserting it into its drive bay on the FortiVoice unit.
Click Rescan.
The RAID controller will scan for available hard disks and should locate the new hard disk. Depending on the RAID

level, the FortiVoice unit may either automatically add the new hard disk to the RAID unit or allocate it as a spare
that will be automatically added to the array if one of the hard disks in the array fails.

The FortiVoice unit rebuilds the RAID array with the new hard disk. Time required varies by the size of the array.

Using high availability

Go to System > High Availability to configure the FortiVoice unit to act as a high availability (HA) member in order to
increase availability.

For the general procedure of how to enable and configure HA, see Enabling and configuring HA on page 58.

This section contains the following topics:

About high availability on page 56

About the heartbeat and synchronization on page 56
Enabling and configuring HA on page 58

Monitoring the HA status on page 59

Configuring service-based monitoring on page 67
Failover scenario examples: on page 69
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About high availability

FortiVoice units operate in an active-passive HA mode which has the following features:

« Two FortiVoice units are in the HA group.

« Both configuration and data are synchronized (For exceptions to synchronized configuration items, see
Unsynchronized HA Setting on page 57.)

« Only the primary unit processes phone calls.

o There is no data loss when the hardware fails although active calls are disconnected and line appearance and
extension appearance take time to restore.

« Both FortiVoice units have failover protection, but no increased processing capacity.

Active-passive HA group

Internal natwoark

Switch FortiGate

; S Internet
1 kg

I\\k I."_f-' g {-g Active-passive

“’?}H«Jq,.f.a-'] HA graup
FortiVioice

Same FortiVoice models must be used in the same HA group. All units in the HA group must have the same firmware
version with the same hardware.

Communications between HA members occur through the heartbeat and synchronization connection. For details, see
About the heartbeat and synchronization on page 56.

To configure FortiVoice units operating in HA mode, you usually connect only to the primary unit. The primary unit’s
configuration is almost entirely synchronized to secondary units, so that changes made to the primary unit are
propagated to the secondary units.

Exceptions to this rule include connecting to a secondary unit in order to view log messages recorded about the
secondary unit itself on its own hard disk, and connecting to a secondary unit to configure Setting that are not
synchronized. For details, see Unsynchronized HA Setting on page 57.

For instructions of how to enable and configure HA, see Enabling and configuring HA on page 58.
About the heartbeat and synchronization

Heartbeat and synchronization traffic consists of TCP packets transmitted between the FortiVoice units in the HA group
through the primary and secondary heartbeat interfaces.

Ay
‘Q' Service monitoring traffic can also, for short periods, be used as a heartbeat. For details, see
- Remote services as heartbeat on page 64.
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Heartbeat and synchronization traffic has three primary functions:

o To monitor the responsiveness of the HA group members.
« To synchronize configuration changes from the primary unit to the secondary units.

For exceptions to synchronized configuration items, see Unsynchronized HA Setting on page 57.
o To synchronize system and user data from the primary unit to the secondary unit.

Call data consists of the FortiVoice call detailed records, recorded calls, voicemail, call directories, fax, and voice
prompts.

When the primary unit’s configuration changes, it immediately synchronizes the change to the secondary unit through
the primary heartbeat interface. If this fails, or if you have inadvertently de-synchronized the secondary unit’s
configuration, you can manually initiate synchronization. For details, see Click HERE to Start a Configuration/Data Sync
on page 60. You can also use the CLI command diagnose system ha sync on either the primary unit or the
secondary unit to manually synchronize the configuration.

During normal operation, the secondary unit expects to constantly receive heartbeat traffic from the primary unit. Loss
of the heartbeat signal interrupts the HA group and generally triggers a failover. For details, see Failover scenario 1:
Temporary failure of the primary unit on page 69.

Exceptions include system restarts and the execute reload CLI command. In case of a system reboot or reload of
the primary unit, the primary unit signals the secondary unit to wait for the primary unit to complete the restart or reload.
For details, see Failover scenario 2: System reboot or reload of the primary unit on page 71.

Periodically, the secondary unit checks with the primary unit to see if there are any configuration changes on the primary
unit. If there are configuration changes, the secondary unit will pull the configuration changes from the primary unit,
generate a new configuration, and reload the new configuration. In this case, both the primary and secondary units can
be configured to send alert email. For details, see Failover scenario 3: System reboot or reload of the secondary unit on
page 71 and Configuring alert email on page 324.

Unsynchronized HA Setting

All configuration settings on the primary unit are synchronized to the secondary unit, except the following:

GUI item Description

Host name The host name distinguishes members of the cluster.

Static route Static routes are not synchronized because the HA units may be in different networks (see
Configuring static routes on page 45).

Interface Each FortiVoice unit in the HA group must be configured with different network interface

configuration Setting for connectivity purposes. For details, see Configuring the network interfaces on page
42.

Exceptions include some active-passive HA Setting which affect the interface configuration
for failover purposes. These Setting are synchronized.

Main HA The main HA configuration, which includes the HA mode of operation (such as Master or
configuration Slave), is not synchronized because this configuration must be different on the primary and
secondary units. For details, see Configuring the HA mode and group on page 62.
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GUI item Description

HA service In active-passive HA, the HA service monitoring configuration is not synchronized. The
monitoring remote service monitoring configuration on the secondary unit controls how the secondary
configuration unit checks the operation of the primary unit. The local services configuration on the primary

unit controls how the primary unit tests the operation of the primary unit. For details, see
Configuring service-based monitoring on page 67.

You might want to have a different service monitoring configuration on

&L the primary and secondary units. For example, after a failover you may
9 not want service monitoring to operate until you have fixed the problems

— that caused the failover and have restarted normal operation of the HA

group.

System appearance The appearance Setting you configured under System > Configuration > Appearance are not
synchronized.

Synchronization after a failover

During normal operation, extensions are in one of two states:

o registered and idle
« active call

When a failover occurs, active calls are interrupted and users have to reinitiate the calls. However, registered idle
extensions can still make and receive phone calls without being affected.

When a failover is corrected, one of the following occurs automatically:

1. The secondary unit detects the failure of the primary unit, and becomes the new primary unit.
2. The former primary unit restarts, detects the new primary unit, and becomes a secondary unit.

Ay
S L4
q You may have to manually restart the failed primary unit.

Enabling and configuring HA

In general, to enable and configure HA, you should perform the following:

1. Physically connect the FortiVoice units that will be members of the HA group.
You must connect at least one of their network interfaces for heartbeat and synchronization traffic between
members of the group. For reliability reasons, Fortinet recommends that you connect both a primary and a
secondary heartbeat interface, and that they be connected directly or through a dedicated switch that is not
connected to your overall network.
2. Oneach member of the group:
« Enable the HA mode that you want to use and select whether the individual member will act as a primary unit
or secondary unit. For information about the differences between the HA modes, see About high availability on
page 56.
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« Configure the local IP addresses of the primary and secondary heartbeat and synchronization network
interfaces.

« Configure a virtual IP address that is shared by the HA group and remains the same after a failover. The virtual
IP address is used to auto-provision the server IP address and the SIP trunk client IP address.
« Configure the behavior on failover, and how the network interfaces should be configured for whichever
FortiVoice unit is currently acting as the primary unit.
3. If you want to trigger failover when hardware or a service fails, even if the heartbeat connection is still functioning,
configure service monitoring. For details, see Configuring service-based monitoring on page 67.

4. Monitor the status of each group member. For details, see Monitoring the HA status on page 59. To monitor HA
events through log messages and/or alert email, you must first enable logging of HA activity events. For details,
see Configuring logging on page 313.

Monitoring the HA status

The Status tab in the High Availability submenu shows the configured HA mode of operation of a FortiVoice unit in an
HA group. You can also manually initiate synchronization and reset the HA mode of operation. A reset may be required
if a FortiVoice unit’s effective HA mode of operation differs from its configured HA mode of operation, such as after a
failover when a configured primary unit is currently acting as a secondary unit.

For FortiVoice units operating as secondary units, the Status tab also lets you view the status and schedule of the HA
synchronization daemon.

Before you can use the Status tab, you must first enable and configure HA. For details, see Enabling and configuring
HA on page 58.

To view the HA mode of operation status, go to System > High Availability > Status.

GUI item Description

HA Status Select a time interval for refreshing the HA status page. You can also manually
update the page by clicking Refresh.

Mode Status

Configured Operating Displays the HA operating mode that you configured, either:
Mode o Master. Configured to be the primary unit of an active-passive group.
« Slave: Configured to be the secondary unit of an active-passive group.
For information on configuring the HA operating mode, see Mode of operation on
page 62.
After a failure, the FortiVoice unit may not be acting in its configured HA
operating mode. For details, see Effective Operating Mode on page 59.

Effective Operating Mode Displays the mode that the unit is currently operating in, either:

o Master: Acting as primary unit.

« Slave: Acting as secondary unit.

« Off: For primary units, this indicates that service/interface monitoring has
detected a failure and has taken the primary unit offline, triggering failover.
For secondary units, this indicates that synchronization has failed once; a
subsequent failure will trigger failover. For details, see On failure on page
63.

o Failed: Service/network interface monitoring has detected a failure and the
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GUI item Description

diagnostic connection is currently determining whether the problem has
been corrected or failover is required. For details, see On failure on page 63.
The configured HA operating mode matches the effective operating mode unless
a failure has occurred.
For example, after a failover, a FortiVoice unit configured to operate as a
secondary unit could be acting as a primary unit.
For explanations of combinations of configured and effective HA modes of
operation, see Combinations of configured and effective HA modes of operation
on page 61.
For information on restoring the FortiVoice unit to an effective HA operating
mode that matches the configured operating mode, see Click HERE to Restore
Configured Operating Mode on page 60.

Daemon Status This option appears only for secondary units in active-passive HA groups.

Monitor Displays the time at which the secondary unit’'s HA daemon will check to make
sure that the primary unit is operating correctly, and, if monitoring has detected a
failure, the number of times that a failure has occurred.

Monitoring occurs through the heartbeat link between the primary and secondary
units. If the heartbeat link becomes disconnected, the next time the secondary
unit checks for the primary unit, the primary unit will not respond. If the maximum
number of consecutive failures is reached, and no secondary heartbeat or remote
service monitoring heartbeat is available, the secondary unit will change its
effective HA operating mode to become the new primary unit.

For details, see HA base port on page 63.

Configuration Displays the time at which the secondary unit’s HA daemon will synchronize the
FortiVoice configuration from the primary unit to the secondary unit.
The message slave unit is currently synchronizing appears
when the HA daemon is synchronizing the configuration.
For information on items that are not synchronized, see Unsynchronized HA
Setting on page 57.

Data Displays the time at which the secondary unit HA daemon will synchronize mail
data from the primary unit to the secondary unit.
The message slave unit is currently synchronizing appears
when the HA daemon is synchronizing data.

Actions
Click HERE to Start a Click to manually initiate synchronization of the configuration and call data. For
Configuration/Data Sync  information on items that are not synchronized, see Unsynchronized HA Setting
on page 57.
Click HERE to Restore Click to reset the FortiVoice unit to an effective HA operating mode that matches
Configured Operating the FortiVoice unit’s configured operating mode.
Mode
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GUI item Description

For example, for a configured primary unit whose effective HA operating mode is
now secondary, after correcting the cause of the failover, you might click this
option on the primary unit to restore the configured primary unit to active duty,
and restore the secondary unit to its secondary role.

failover, make sure to resolve any issues that caused the

\‘é’, If the effective HA operating mode has changed due to a
- failover before selecting this option.

Combinations of configured and effective HA modes of operation

Configured Effective operating Description

operating mode mode

master master Normal for the primary unit of an active-passive HA group.

slave slave Normal for the secondary unit of an active-passive HA group.

master off The primary unit has experienced a failure, or the FortiVoice unit is in

the process of switching to operating in HA mode.
HA processes and call processing are stopped.

slave off The secondary unit has detected a failure, or the FortiVoice unit is in
the process of switching to operating in HA mode.
After the secondary unit starts up and connects with the primary unit
to form an HA group, the first configuration synchronization may fail
in special circumstances. To prevent both the secondary and
primary units from simultaneously acting as primary units, the
effective HA mode of operation becomes off.
If subsequent synchronization fails, the secondary unit’s effective
HA mode of operation becomes Master .

master failed The remote service monitoring or local network interface monitoring
on the primary unit has detected a failure, and will attempt to
connect to the other FortiVoice unit. If the problem that caused the
failure has been corrected, the effective HA mode of operation
switches from failed to slave, or to match the configured HA mode of
operation, depending on the On failure setting.

master slave The primary unit has experienced a failure but then returned to
operation. When the failure occurred, the unit configured to be the
secondary unit became the primary unit. When the unit configured
to be the primary unit restarted, it detected the new primary unit and
so switched to operating as the secondary unit.

slave master The secondary unit has detected that the FortiVoice unit configured
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Configured Effective operating Description

operating mode mode

to be the primary unit failed. When the failure occurred, the unit
configured to be the secondary unit became the primary unit.

Configuring the HA mode and group

The Configuration tab in the System > High Availability submenu lets you configure the high availability (HA) options,
including:

« enabling HA

« whether this individual FortiVoice unit will act as a primary unit or a secondary unit in the group

« network interfaces that will be used for heartbeat and synchronization and virtual IP

« service monitor

HA settings, with the exception of Virtual IP Address settings, are not synchronized and must be configured separately
on each primary and secondary unit.

You must maintain the physical link between the heartbeat and synchronization network interfaces. These connections
enable a group member to detect the responsiveness of the other member, and to synchronize data. If they are
interrupted, normal operation will be interrupted and a failover will occur. For more information on heartbeat and
synchronization, see About the heartbeat and synchronization on page 56.

You can directly connect the heartbeat network interfaces of two FortiVoice units using a crossover Ethernet cable.

To configure HA options

1. Goto System > High Availability > Configuration.
2. Configure the following sections, as applicable:

« Configuring the primary HA options on page 62

o Configuring HA advanced options on page 63

« Configuring interface monitoring on page 65

« Configuring service-based monitoring on page 67
3. Click Apply.

Configuring the primary HA options

Go to System > High Availability > Configuration and click the arrow to expand the HA Configuration section, if

needed.
GUI field Description
Mode of operation Enables or disables HA, and selects the initial configured role this FortiVoice unit

in the HA group.
« Off: The FortiVoice unit is not operating in HA mode.
« Master. The FortiVoice unit is the primary unit in an active-passive HA group.
« Slave: The FortiVoice unit is the secondary unit in an active-passive HA
group.
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GUI field Description

On failure Select one of the following behaviors of the primary unit when it detects a failure,
such as on a power failure or from service/interface monitoring.

« Switch Off: Do not process phone calls or join the HA group until you
manually select the effective operating mode (see Click HERE to Start a
Configuration/Data Sync on page 60 and Click HERE to Restore Configured
Operating Mode on page 60).

« Wait for Recovery Then Restore Original Role: On recovery, the failed
primary unit's effective HA mode of operation resumes its configured primary
role. This also means that the secondary unit needs to give back the primary
role to the primary unit. This behavior may be useful if the cause of failure is
temporary and rare, but may cause problems if the cause of failure is
permanent or persistent.

« Wait for Recovery Then Restore Slave Role: On recovery, the failed
primary unit’s effective HA mode of operation becomes slave, and the
secondary unit continues to assume the masterrole. The primary unit then
synchronizes with the current primary unit. The new primary unit can then
deliver phone calls. For information on manually restoring the FortiVoice unit
to acting in its configured HA mode of operation, see Click HERE to Restore
Configured Operating Mode on page 60.

In most cases, you should select the Wait for Recovery Then Restore Slave

Role option.

For details on the effects of this option on the Effective Operating Mode, see
Combinations of configured and effective HA modes of operation on page 61. For
information on configuring service/interface monitoring, see Configuring service-

based monitoring on page 67.

This option appears only if Mode of operation on page 62 is Master.

Shared password Enter an HA password for the HA group. You must configure the same Shared
password value on both the primary and secondary units.

Configuring HA advanced options

Go to System > High Availability > Configuration > Advanced Options.

GUI item Description

HA base port Keep the default TCP port number (20000) that will be used for:
« the heartbeat signal
« synchronization control
« data synchronization
« configuration synchronization

service monitoring. For details, see Configuring service-based

\‘é’, In addition to configuring the heartbeat, you can configure
- monitoring on page 67.
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GUI item Description

Heartbeat lost threshold

Remote services as heartbeat

V) In addition to automatic immediate and periodic configuration
‘9' synchronization, you can also manually initiate
- synchronization. For details, see Click HERE to Start a
- Configuration/Data Sync on page 60.

Enter the total span of time, in seconds, for which the primary unit can be
unresponsive before it triggers a failover and the secondary unit assumes the role
of the primary unit.

The heartbeat will continue to check for availability once per second. To prevent
premature failover when the primary unit is simply experiencing very heavy load,
configure a total threshold of three (3) seconds or more to allow the secondary
unit enough time to confirm unresponsiveness by sending additional heartbeat
signals.

vy
‘?' If the failure detection time is too short, the secondary unit may

falsely detect a failure during periods of high load.

If the failure detection time is too long, the primary unit could

fail and a delay in detecting the failure could mean that a call is
delayed or lost. Decrease the failure detection time if a call is

delayed or lost because of an HA failover.

Enable to use remote service monitoring as a secondary HA heartbeat. If enabled
and both the primary and secondary heartbeat links fail or become disconnected,
and remote service monitoring still detects that the primary unit is available, a
failover will not occur.
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GUI item Description

The remote service check is only applicable for temporary
V) heartbeat link fails. If the HA process restarts due to system
‘Q' reboot or HA daemon reboot, then physical heartbeat

connections will be checked first. If physical connections are
not found, the remote service monitoring does not take effect
anymore.

Using remote services as heartbeat provides HA heartbeat
) only, not synchronization. To avoid synchronization problems,
‘Q' you should not use remote service monitoring as a heartbeat
- for extended periods. This feature is intended only as a
- temporary heartbeat solution that operates until you
reestablish a normal primary or secondary heartbeat link.

Call recording sync Select to sync recorded calls.
This option is not available if you select Off for Mode of operation under HA
Configuration.

Survivability service interface Select the interface port for a local survivable gateway (LSG) to communicate
with this FortiVoice unit.

In an LSG setup, when the central FortiVoice HA is enabled without a virtual IP,
the primary and secondary units need to identify their service interface ports for
the LSG to communicate with them. For more information about LSG, see
FortiVoice Local Survivable Gateway Deployment Guide.

In any other cases, this value is ignored by the system.

Primary Override External Enter the host/IP address to override the default external host/IP address for
Media Host media stream on the primary HA unit.

Secondary Override External Enter the host/IP address to override the default external host/IP address for
Media Host media stream on the secondary HA unit.

Configuring interface monitoring

Interface monitor checks the local interfaces on the primary unit. If a malfunctioning interface is detected, a failover will
be triggered.

To configure interface monitoring

1. Goto System > High Availability > Configuration.
2. Select Master or Slave as the mode of operation.
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3. Expand the Interface area, if required.

A\,

The interface |P address must be different from, but on the same subnet as, the IP
address of the other heartbeat network interface of the other member in the HA group.
When configuring the other FortiVoice unit in the HA group, use this value as the remote
peer IP.

4. Select arow in the table and click Edit to configure the following HA Setting on the interface.

GUI item
Port

Enable port
monitor

Heartbeat
status

Peer IP
address

Description
Displays the interface name you’re configuring.

Enable to monitor a network interface for failure. If the port fails, the primary unit will trigger a
failover.

Specify if this interface will be used for HA heartbeat and synchronization.

o Disable
Do not use this interface for HA heartbeat and synchronization.

+ Master
Select the primary network interface for heartbeat and synchronization traffic. For more
information, see About the heartbeat and synchronization on page 56.
This network interface must be connected directly or through a switch to the Master
heartbeat network interface of the other member in the HA group.

o Slave
Select the secondary network interface for heartbeat and synchronization traffic. For
more information, see About the heartbeat and synchronization on page 56.
The secondary heartbeat interface is the backup heartbeat link between the units in the
HA group. If the primary heartbeat link is functioning, the secondary heartbeat link is
used for the HA heartbeat. If the primary heartbeat link fails, the secondary link is used
for the HA heartbeat and for HA synchronization.
This network interface must be connected directly or through a switch to the Secondary
heartbeat network interfaces of the other member in the HA group.

Using the same network interface for both HA synchronization/heartbeat

traffic and other network traffic could result in issues with heartbeat and
synchronization during times of high traffic load, and is not recommende

d.
NV In general, you should isolate the network interfaces that are used for he
‘Q' artbeat traffic from your overall network. Heartbeat and synchronization
- packets contain sensitive configuration information, are latency-sensitive

, and can consume considerable network bandwidth.

Enter the IP address of the matching heartbeat network interface of the other member of the
HA group.

For example, if you are configuring the primary unit’s primary heartbeat network interface,
enter the IP address of the secondary unit’s primary heartbeat network interface.
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GUI item Description

Similarly, for the secondary heartbeat network interface, enter the IP address of the other
unit’s secondary heartbeat network interface.

For information about configuration synchronization and what is not synchronized, see About
the heartbeat and synchronization on page 56.

Peer IPv6 Enter the peer IPv6 address for this interface.

address

Virtual IP Select whether and how to configure the IP addresses and netmasks of the FortiVoice unit
action whose effective HA mode of operation is currently Master.

For example, a primary unit might be configured to receive phone call traffic through port1
and receive heartbeat and synchronization traffic through port3 and port4. In that case, you
would configure the primary unit to set the IP addresses or add virtual IP addresses for port1
of the secondary unit on failover in order to mimic that of the primary unit.

« Ignore: Do not change the network interface configuration on failover, and do not
monitor. For details on service monitoring for network interfaces, see Configuring
service-based monitoring on page 67.

o Use: Add the specified virtual IP address and netmask to the network interface on
failover. Normally, you will configure your network so that clients use the virtual IP
address. This option results in the network interface having two IP Addresses: the actual
and the virtual.

Virtual IP Enter the virtual IPv4 address for this interface.
address
Virtual IPv6 Enter the virtual IPv6 address for this interface.
address

5. Click OK.

Configuring service-based monitoring

Go to System > High Availability > Configuration to configure remote service monitoring, local network interface
monitoring, and local hard drive monitoring.

HA service monitoring Setting are not synchronized and must be configured separately on each primary and secondary
unit.

With remote service monitoring, the secondary unit confirms that it can connect to the primary unit over the network
using SIP and HTTP connections.

With local network interface monitoring and local hard drive monitoring, the primary unit monitors its own network
interfaces and hard drives.
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If service monitoring detects a failure, the effective HA operating mode of the primary unit switches to off or failed
(depending on the On failure setting). A failover then occurs, and the effective HA operating mode of the secondary unit
switches to master. For information on the On failure option, see Configuring the HA mode and group on page 62. For
information on the effective HA operating mode, see Monitoring the HA status on page 59.

To configure service monitoring

1. Goto System > High Availability > Configuration.
2. Select Master or Slave as the mode of operation.
3. Expand Service Monitor, if required.
4. Select arow in the table and click Edit to configure it.
5. For Remote HTTP, configure the following:
Enable Select to enable connection responsiveness tests for SMTP.
Name Displays the service name.
Remote IP Enter the peer IP address.
Port Enter the port number of the peer SMTP service.
Timeout Enter the timeout period for one connection test.
Interval Enter the frequency of the tests.
Retries Enter the number of consecutively failed tests that are allowed before the primary unit is

deemed unresponsive and a failover occurs.

6. For SIP UDP, configure the following:

Enable Select to enable SIP UDP service.

Name Displays the service name.

Remote IP Enter the peer IP address.

Port Enter the port number of the peer SIP UDP service.

Timeout Enter the timeout period for one connection test.

Interval Enter the frequency of the tests.

Retries Enter the number of consecutively failed tests that are allowed before the primary unit is

deemed unresponsive and a failover occurs.

7. For Interface monitor and Local hard drives, configure the following:

GUI item Description

Enable Select to enable local hard drive monitoring. Interface monitoring is enabled when you
configure interface monitoring. See Configuring interface monitoring on page 65.
Network interface monitoring tests all active network interfaces whose:
Virtual IP action on page 67 setting is not Ignore
Configuring interface monitoring on page 65 setting is enabled
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GUI item Description

Interval Enter the frequency of the test.

Retries Specify the number of consecutively failed tests that are allowed before the local interface or
hard drive is deemed unresponsive and a failover occurs.

Failover scenario examples:

This section describes basic FortiVoice active-passive HA failover scenarios. For each scenario, refer to the HA group
shown in Example active-passive HA group on page 69. To simplify the descriptions of these scenarios, the following
abbreviations are used:

o P1isthe configured primary unit.
« S2is the configured secondary unit.

Example active-passive HA group

Activa-passive
HA group
port 1
17216.5.10
- (HA virtual 1P 172185, 2)
Fortivioice "
Frimary unit {F1} @/)
Switch I
port2 3 or d
Heartbest link
FortiVoice {: S
Secondary unit {52} L\_\': P
-
port 1
17216511

This section contains the following HA failover scenarios:

« Failover scenario 1: Temporary failure of the primary unit on page 69

« Failover scenario 2: System reboot or reload of the primary unit on page 71

« Failover scenario 3: System reboot or reload of the secondary unit on page 71
« Failover scenario 4: System shutdown of the secondary unit on page 72

o Failover scenario 5: Primary heartbeat link fails on page 72

« Failover scenario 6: Network connection between primary and secondary units fails (remote service monitoring
detects a failure) on page 73

Failover scenario 1: Temporary failure of the primary unit

In this scenario, the primary unit (P1) fails because of a software failure or a recoverable hardware failure (in this
example, the P1 power cable is unplugged). HA logging and alert email are configured for the HA group.

When the secondary unit (S2) detects that P1 has failed, S2 becomes the new primary unit and continues processing
phone calls.

There is no data loss when failover happens although active calls are disconnected and line appearance and extension
appearance take time to restore. Call data consists of the FortiVoice call detailed records, recorded calls, voicemail, call
directories, fax, and voice prompts. The user portal is not affected.
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Here is what happens during this process:

1.
2.
3.

The FortiVoice HA group is operating normally.

The power is accidentally disconnected from P1.

S2’s heartbeat test detects that P1 has failed.

How soon this happens depends on the HA daemon configuration of S2.
The effective HA operating mode of S2 changes to master.

S2 sends an alert email similar to the following, indicating that S2 has determined that P1 has failed and that S2 is
switching its effective HA operating mode to master.
This is the HA machine at 172.16.5.11.

The following event has occurred
‘master heartbeat disappeared’
The state changed from ‘SLAVE’ to ‘MASTER'

S2 records event log messages (among others) indicating that S2 has determined that P1 has failed and that S2 is
switching its effective HA operating mode to MASTER.

Recovering from temporary failure of the primary unit

After P1 recovers from the hardware failure, what happens next to the HA group depends on P1’s HA On failure Setting
under System > High Availability > Configuration.

HA On Failure Setting
& HA Configuration

Mode of operation: Off -
On failure: Switch Off -
Shared password: change_me

Switch Off

P1 will not process calls or join the HA group until you manually select the effective HA operating mode (see Click
HERE to Restore Configured Operating Mode on page 60).

Wait for Recovery Then Restore Original Role

On recovery, P1’s effective HA operating mode resumes its configured primary role. This also means that S2 needs
to give back the primary role to P1. This behavior may be useful if the cause of failure is temporary and rare, but
may cause problems if the cause of failure is permanent or persistent.

In the case, the S2 will send out another alert email similar to the following:

This is the HA machine at 172.16.5.11.

The following event has occurred
‘SLAVE asks us to switch roles (recovery after a restart)’
The state changed from ‘MASTER'’ to ‘SLAVE'.

After recovery, P1 also sends out an alert email similar to the following:
This is the HA machine at 172.16.5.10.
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The following critical event was detected
The system was shutdown!

wait for recovery then restore slave role

On recovery, P1’s effective HA operating mode becomes slave, and S2 continues to assume the masterrole. P1
then synchronizes with the current primary unit, S2. For information on manually restoring the FortiVoice unit to
acting in its configured HA mode of operation, see Click HERE to Restore Configured Operating Mode on page 60.

Failover scenario 2: System reboot or reload of the primary unit

If you need to reboot or reload (not shut down) P1 for any reason, such as a firmware upgrade or a process restart, by
using the CLI commands execute reboot orexecute reload, or by clicking the Restart button under Status >
Dashboard > System Command on the GUI:

P1 will send a holdoff command to S2 so that S2 will not take over the primary role during P1’s reboot.

P1 will also send out an alert email similar to the following:

This is the HA machine at 172.16.5.10.

The following critical event was detected

The system is rebooting (or reloading)!

S2 will hold off checking the services and heartbeat with P1. Note that S2 will only hold off for about 5 minutes. In
case P1 never boots up, S2 will take over the primary role.

S2 will send out an alert email, indicating that S2 received the holdoff command from P1.

This is the HA machine at 172.16.5.11.

The following event has occurred

‘peer rebooting (or reloading)’
The state changed from ‘SLAVE’ to ‘HOLD_OFF’

After P1is up again:

P1 will send another command to S2 and ask S2 to change its state from holdoff to secondary and resume
monitoring P1’s services and heartbeat.

S2 will send out an alert email, indicating that S2 received instruction commands from P1.

This is the HA machine at 172.16.5.11.

The following event has occurred

‘peer command appeared’

The state changed from ‘HOLD_OFF’ to ‘SLAVE'.

S2 logs the event in the HA logs.

Failover scenario 3: System reboot or reload of the secondary unit

If you need to reboot or reload (not shut down) S2 for any reason, such as a firmware upgrade or a process restart, by
using the CLI commands execute reboot orexecute reload, or by clicking the Restart button under Monitor >
System Status > Status on the GUI, the behavior of P1 and S2 is as follows:

P1 will send out an alert email similar to the following, informing the administrator of the heartbeat loss with S2.
This is the HA machine at 172.16.5.10.

The following event has occurred

‘ha: SLAVE heartbeat disappeared’

S2 will send out an alert email similar to the following:

This is the HA machine at 172.16.5.11.
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The following critical event was detected
The system is rebooting (or reloading)!

« P1 will also log this event in the HA logs.

Failover scenario 4: System shutdown of the secondary unit

If you shut down S2:

« No alert email is sent out from either P1 or S2.
o P1 will log this event in the HA logs.

Failover scenario 5: Primary heartbeat link fails

If the primary heartbeat link fails, such as when the cable becomes accidentally disconnected, and if you have not
configured a secondary heartbeat link, the FortiVoice units in the HA group cannot verify that other units are operating
and assume that the other has failed. As a result, the secondary unit (S2) changes to operating as a primary unit, and
both FortiVoice units are acting as primary units.

Two primary units connected to the same network may cause address conflicts on your network. Additionally, because
the heartbeat link is interrupted, the FortiVoice units in the HA group cannot synchronize configuration changes or voice
data changes.

Even after reconnecting the heartbeat link, both units will continue operating as primary units. To return the HA group to
normal operation, you must connect to the web-based manager of S2 to restore its effective HA operating mode to
slave.

1. The FortiVoice HA group is operating normally.
2. The heartbeat link Ethernet cable is accidentally disconnected.
3. S2's HA heartbeat test detects that the primary unit has failed.
How soon this happens depends on the HA daemon configuration of S2.
4. The effective HA operating mode of S2 changes to master.
5. S2 sends an alert email similar to the following, indicating that S2 has determined that P1 has failed and that S2 is
switching its effective HA operating mode to master.
This is the HA machine at 172.16.5.11.
The following event has occurred
‘MASTER heartbeat disappeared’
The state changed from ‘SLAVE’ to ‘MASTER’
6. S2records event log messages (among others) indicating that S2 has determined that P1 has failed and that S2 is
switching its effective HA operating mode to master.

Recovering from a heartbeat link failure

Because the hardware failure is not permanent (that is, the failure of the heartbeat link was caused by a disconnected
cable, not a failed port on one of the FortiVoice units), you may want to return both FortiVoice units to operating in their
configured modes when rejoining the failed primary unit to the HA group.

To return to normal operation after the heartbeat link fails

1. Reconnect the primary heartbeat interface by reconnecting the heartbeat link Ethernet cable.
Even though the effective HA operating mode of S2 is master, S2 continues to attempt to find the other primary
unit. When the heartbeat link is reconnected, S2 finds P1 and determines that P1 is also operating as a primary
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unit. So S2 sends a heartbeat signal to notify P1 to stop operating as a primary unit. The effective HA operating
mode of P1 changes to off.

2. P1 sends an alert email similar to the following, indicating that P1 has stopped operating as the primary unit.
This is the HA machine at 172.16.5.10
The following event has occurred
'SLAVE asks us to switch roles (user requested takeover)'
The state changed from 'MASTER' to 'OFF'

3. P1 records event log messages (among others) indicating that P1 is switching to off mode.
The configured HA mode of operation of P1 is master and the effective HA operating mode of P1 is off.
The configured HA mode of operation of S2 is slave and the effective HA operating mode of S2 is master.

4. Connect to the web-based manager of P1, go to System > High Availability > Status.

5. Check for synchronization messages.
Do not proceed to the next step until P1 has synchronized with S2.

6. Connect to the web-based manager of S2, go to System > High Availability > Status and select click HERE to
restore configured operating mode.
The HA group should return to normal operation. P1 records the event log message (among others) indicating that
S2 asked P1 to return to operating as the primary unit.
P1 and S2 synchronize again. P1 processes phone calls normally.

Failover scenario 6: Network connection between primary and secondary units fails
(remote service monitoring detects a failure)

Depending on your network configuration, the network connection between the primary and secondary units can fail for
a number of reasons. In the network configuration shown in Example active-passive HA group on page 69, the
connection between port1 of primary unit (P1) and port1 of the secondary unit (S2) can fail if a network cable is
disconnected or if the switch between P1 and S2 fails.

A more complex network configuration could include a number of network devices between the primary and secondary
unit’s non-heartbeat network interfaces. In any configuration, remote service monitoring can only detect a
communication failure. Remote service monitoring cannot determine where the failure occurred or the reason for the
failure.

In this scenario, remote service monitoring has been configured to make sure that S2 can connect to P1. The On failure
setting located in the HA main configuration section is wait for recovery then restore slave role. For information on the
On failure setting, see On failure on page 63. For information about remote service monitoring, see Configuring service-
based monitoring on page 67.

The failure occurs when power to the switch that connects the P1 and S2 port1 interfaces is disconnected. Remote
service monitoring detects the failure of the network connection between the primary and slave units. Because of the On
failure setting, P1 changes its effective HA operating mode to failed.

When the failure is corrected, P1 detects the correction because while operating in failed mode P1 has been attempting
to connect to S2 using the port1 interface. When P1 can connect to S2, the effective HA operating mode of P1 changes
to slave and the voice data on P1 will be synchronized to S2. S2 can now deliver the calls. The HA group continues to
operate in this manner until an administrator resets the effective HA modes of operation of the FortiVoice units.

1. The FortiVoice HA group is operating normally.

2. The power cable for the switch between P1 and S2 is accidentally disconnected.

3. S2'sremote service monitoring cannot connect to the primary unit.
How soon this happens depends on the remote service monitoring configuration of S2.
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10.

Through the HA heartbeat link, S2 signals P1 to stop operating as the primary unit.

The effective HA operating mode of P1 changes to failed.

The effective HA operating mode of S2 changes to primary.

S2 sends an alert email similar to the following, indicating that S2 has determined that P1 has failed and that S2 is
switching its effective HA operating mode to master.

This is the HA machine at 172.16.5.11.

The following event has occurred

‘MASTER remote service disappeared’

The state changed from ‘SLAVE ' to ‘MASTER’

S2 logs the event (among others) indicating that S2 has determined that P1 has failed and that S2 is switching its
effective HA operating mode to master.

P1 sends an alert email similar to the following, indicating that P1 has stopped operating in HA mode.

This is the HA machine at 172.16.5.10.

The following event has occurred

'SLAVE asks us to switch roles (user requested takeover)'

The state changed from 'MASTER' to 'FAILED'

P1 records the log messages (among others) indicating that P1 is switching to Failed mode.

Recovering from a network connection failure

Because the network connection failure was not caused by failure of either FortiVoice unit, you may want to return both
FortiVoice units to operating in their configured modes when rejoining the failed primary unit to the HA group.

To return to normal operation after the heartbeat link fails

1. Reconnect power to the switch.
Because the effective HA operating mode of P1 is failed, P1 is using remote service monitoring to attempt to
connect to S2 through the switch.

2. When the switch resumes operating, P1 successfully connects to S2.
P1 has determined the S2 can connect to the network and process calls.

3. The effective HA operating mode of P1 switches to slave.

4. P1logs the event.

5. P1 sends an alert email similar to the following, indicating that P1 is switching its effective HA operating mode to
slave.
This is the HA machine at 172.16.5.10.
The following event has occurred
'SLAVE asks us to switch roles (user requested takeover)'
The state changed from 'FAILED' to 'SLAVE".

6. Connect to the web-based manager of P1 and go to System > High Availability > Status.

7. Check for synchronization messages.
Do not proceed to the next step until P1 has synchronized with S2.

8. Connect to the web-based manager of S2, go to System > High Availability > Status and select click HERE to
restore configured operating mode.

9. Connect to the web-based manager of P1, go to System > High Availability > Status and select click HERE to
restore configured operating mode.
P1 should return to operating as the primary unit and S2 should return to operating as the secondary unit.
P1 and S2 synchronize again. P1 can now process phone calls normally.
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Working with system configurations

The System > Configuration submenu lets you configure the system time, system options, SNMP, email setting, GUI
appearance, call data storage, single sign on, and Fortinet security fabric.

This topic includes:

o Configuring the time and date on page 75

« Configuring system options on page 78

o Configuring SNMP queries and traps on page 79

« Configuring email setting on page 85

¢ Customizing the GUI appearance on page 87

o Selecting the call data storage location on page 88
« Configuring single sign on on page 91

« Enabling security fabric on page 92

Configuring the time and date

The System > Configuration > Time tab lets you configure the system time and date of the FortiVoice unit.

You can either manually set the FortiVoice system time or configure the FortiVoice unit to automatically keep its system
time correct by synchronizing with Network Time Protocol (NTP) servers.

NP For many features to work, including scheduling, logging, and certificate-dependent features,
‘Q' the FortiVoice system time must be accurate.
- FortiVoice units support daylight savings time (DST), including recent changes in the USA,

Canada and Western Australia.

To configure the system time

1. Goto System > Configuration > Time.
2. Configure the following:

GUI field Description

System time Displays the date and time according to the FortiVoice unit’s clock at the time
that this tab was loaded, or when you last selected the Refresh button.

Time zone Select the time zone in which the FortiVoice unit is located.

« Automatically adjust clock for daylight saving time changes: Enable to
adjust the FortiVoice system clock automatically when your time zone
changes to daylight savings time (DST) and back to standard time.

When selecting time zone in CLI, use the command config system time
manual and enter the code before the time zone in Time zone codes for CLI
configuration {config system time manual} on page 76.
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3.

GUI field Description

Set date Select this option to manually set the date and time of the FortiVoice unit’s
clock, then select the Year, Month, Day, Hour, Minute, and Second fields
before you click Apply.

Alternatively, configure Synchronize with NTP server.

Synchronize with NTP Server Select to use a network time protocol (NTP) server to automatically set the
system date and time, then configure Serverand Sync Interval.

« Server: Enter the IP address or domain name of an NTP server.

You can add a maximum of 10 NTP servers. The FortiVoice unit uses the
first NTP server based on the selection mechanism of the NTP protocol.
Click the + sign to add more servers.

Click the - sign to remove servers. Note that you cannot remove the last
server.

To find the NTP servers that you can use, see http://www.ntp.org.

o Sync Interval: Enter how often, in minutes, the FortiVoice unit should
synchronize its time with the NTP server. For example, entering 1440
causes the FortiVoice unit to synchronize its time once a day.

Depending on your network traffic, it may take some time for the FortiVoice
unit to synchronize its time with the NTP server.

Click Apply.

Time zone codes for CLI configuration {config system time manual}

Code Time Zone

0

© 0 N O g b~ O N -

G O G
a b W N -~ O

GMT-12:00) Eniwetok, Kwajalein
GMT-11:00) Midway Island, Samoa
GMT-10:00) Hawaii

GMT-9:00) Alaska

GMT-8:00) Pacific Time (US&amp; Canada)
GMT-7:00) Arizona

GMT-7:00) Mountain Time (US&amp; Canada)
GMT-6:00) Central America

GMT-6:00) Central Time

GMT-6:00) Mexico City

GMT-6:00) Saskatchewan

GMT-5:00) Bogota, Lima, Quito

GMT-5:00) Eastern Time (US &amp; Canada)
GMT-5:00) Indiana (East)

GMT-4:30) Venezuela Standard Time
GMT-4:00) Atlantic Time (Canada)

—~ =N =N - N~ PN PPN PN S
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Code Time Zone

16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49

GMT-4:00) Caracas, La Paz

GMT-4:00) Santiago

GMT-3:30) Newfoundland

GMT-3:00) Brasilia

GMT-3:00) Buenos Aires, Georgetown

GMT-3:00) Greenland

GMT-2:00) Mid-Atlantic

GMT-1:00) Azores

GMT-1:00) Cape Verde Is.

GMT) Casablanca, Monrouia

GMT) Greenwich Mean Time: Dublin, Edinburgh, Lisbon, London
GMT+1:00) Amsterdam, Berlia, Bern, Rome, Stockholm, Vienna
GMT+1:00) Belgrade, Bratislava, Budapest, Ljubljana, Prague
GMT+1:00) Brussels, Copenhagen, Madrid, Paris
GMT+1:00) Sarajevo, Skopje, Sofija, Vilnius, Warsaw, Zagreb
GMT+1:00) West Central Africa
GMT+2:00) Athens, Istanbul, Minsk
GMT+2:00) Bucharest
GMT+2:00) Cairo
GMT+2:00) Harare, Pretoria
GMT+2:00) Helsinki, Riga, Tallinn
GMT+2:00) Jerusalem
GMT+3:00) Baghdad
GMT+3:00) Kuwait, Riyadh

GMT+3:00) Moscow, St.Petersburg, Volgograd
GMT+3:00) Nairobi

GMT+3:30) Tehran

GMT+4:00) Abu Dhabi, Muscat

GMT+4:00) Baku, Thilisi, Yerevan

GMT+4:30) Kabul

GMT+5:00) Ekaterinburg

GMT+5:00) Islamabad, Karachi, Tashkent
GMT+5:30) Calcutta, Chennai, Mumbai, New Delhi
GMT+5:45) Kathmandu

—~ = -~ PN - PN NPT PN N S
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Code Time Zone

50 GMT+6:00) Almaty, Novosibirsk
51 GMT+6:00) Astana, Dhaka

52
53
54
55
56
57
58
59
60 GMT+8:00) Taipei

(
(
(GMT+6:00) Sri Jayawardenepara
(
(
(
(
(
(
(
(
61 (GMT+9:00) Osaka, Sapporo, Tokyo, Seoul
(
(
(
(
(
(
(
(
(
(
(

)

)

)

GMT+6:30) Rangoon

GMT+7:00)B angkok, Hanoi, Jakarta

GMT+7:00) Krasnoyarsk

GMT+8:00) Beijing, Chong Qing, Hong Kong, Urumgi

GMT+8:00) Irkutsk, Ulaan Bataar

GMT+8:00) Kuala Lumpur, Singapore
)
)
)
)
)

GMT+8:00) Perth

62 GMT+9:00) Yakutsk

63 GMT+9:30) Adelaide, Darwin
64 GMT+10:00) Brisbane

65
66
67
68
69
70
71
72

)
GMT+10:00) Canberra, Melbourne, Sydney
GMT+10:00) Guam, Port Moresby, Hobart, Vladivostok
GMT+11:00) Magadan, Solomon Is., New Caledonia
GMT+12:00) Auckland, Wellington

GMT+12:00) Fiji, Kamchatka, Marshall Is.
GMT+13:00) Nuku'alofa

GMT-3:00) Montevideo

GMT+3:00) Minsk

Configuring system options

The System > Configuration > Options tab lets you set the following global settings:

« system idle timeout
« password enforcement policy
« administration ports on the interfaces

To view and configure the system options
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1. Goto System > Configuration > Option.
2. Configure the following:

GUI field Description

Idle timeout Enter the amount of time that an administrator may be inactive before the FortiVoice unit
automatically logs out the administrator.

For better security, use a low idle timeout value, for example, 5 minutes.

Web action host/IP  Enter the host name or IP address from where a email notification is sent to you when a
voice mail or fax is delivered to your extension. This IP address is included in the email
notification. You can open the link to view or manage the voice mail or fax. If you leave
this field empty, port1 IP will be used instead.

The value entered here replaces the default Url host variable for customizing messages.
See Customizing call report and notification email templates on page 113.

Administration Ports  Specify the TCP ports for administrative access on all interfaces.
Default port numbers:
HTTP: 80
HTTPS: 443
SSH: 22
TELNET: 23

3. Click Apply.

Configuring SNMP queries and traps

Go to System > Configuration > SNMP to configure SNMP to monitor FortiVoice system events and thresholds, or a
high availability (HA) configuration for failover messages.

To monitor FortiVoice system information and receive FortiVoice traps, you must compile Fortinet proprietary MIBs as
well as Fortinet-supported standard MIBs into your SNMP manager. RFC support includes support for most of RFC
2665 (Ethernet-like MIB) and most of RFC 1213 (MIB II). For more information, see FortiVoice MIBs on page 84.

The FortiVoice SNMP implementation is read-only. SNMP v1, v2c, and v3 compliant SNMP managers have read-only
access to FortiVoice system information and can receive FortiVoice traps.

The FortiVoice SNMP v3 implementation includes support for queries, traps, authentication, and privacy. Before you
can use its SNMP queries, you must enable SNMP access on the network interfaces that SNMP managers will use to
access the FortiVoice unit. For more information, see Editing network interfaces on page 43.

This topic includes:

o Configuring an SNMP threshold on page 80
+ Configuring email setting on page 85
« Configuring an SNMP v3 user on page 82
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Configuring an SNMP threshold

Configure under what circumstances an event is triggered.
To set SNMP thresholds

1. Goto System > Configuration > SNMP.
2. Configure the following:

GUI field Description

SNMP agent enabled Enable to activate the FortiVoice SNMP agent. This must be
enabled to accept queries from SNMP managers or send traps
from the FortiVoice unit.

Description Enter a descriptive name for the FortiVoice unit.

Location Enter the location of the FortiVoice unit.

Contact Enter administrator contact information.

SNMP Threshold To change a value in the four editable columns, select the value in

any row. It becomes editable. Change the value and click outside
of the field. A red triangle appears in the field’s corner and remains
until you click Apply.

Trap Type Displays the type of trap, such as CPU Usage.

Trigger You can enter either the percent of the resource in use or the
number of times the trigger level must be reached before it is
triggered.

For example, using the default value, if the mailbox disk is 90% or
more full, it will trigger.

Threshold Sets the number of triggers that will result in an SNMP trap.

For example, if the CPU level exceeds the set trigger percentage
once before returning to a lower level, and the threshold is set to
more than one, an SNMP trap will not be generated until that
minimum number of triggers occurs during the sample period.

Sample Period(s) Sets the time period in seconds during which the FortiVoice unit
SNMP agent counts the number of triggers that occurred.
This value should not be less than the Sample Freq(s) value.
Sample Freq(s) Sets the interval in seconds between measurements of the trap

condition. You will not receive traps faster than this rate,
depending on the selected sample period.

This value should be less than the Sample Period(s) value.
Community Displays the list of SNMP communities (for SNMP v1 and v2c)
added to the FortiVoice configuration. For information on

configuring a community, see either Configuring email setting on
page 85 or Configuring an SNMP v3 user on page 82.

Name Displays the name of the SNMP community. The SNMP Manager
must be configured with this name.
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GUI field Description

User

3. Click Apply.

Status A green check mark icon indicates that the community is enabled.
Queries A green check mark icon indicates that queries are enabled.
Traps A green check mark icon indicates that traps are enabled.

Displays the list of SNMP v3 users added to the FortiVoice
configuration. For information on configuring a v3 user, see
Configuring an SNMP v3 user on page 82.

Name Displays the name of the SNMP v3 user. The SNMP Manager
must be configured with this name.

Status A green check mark icon indicates that the user is enabled.

Queries A green check mark icon indicates that queries are enabled.

Traps A green check mark icon indicates that traps are enabled.

Security Level Displays the security level.

Configuring an SNMP v1 and v2c community

An SNMP community is a grouping of equipment for SNMP-based network administration purposes. You can add up to
three SNMP communities so that SNMP managers can connect to the FortiVoice unit to view system information and
receive SNMP traps. You can configure each community differently for SNMP traps and to monitor different events. You
can add the IP addresses of up to eight SNMP managers to each community.

To configure an SNMP community

1. Go to System > Configuration > SNMP.

2. Under Community, click New to add a community or select a community and click Edit.
The SNMP Community page appears.

3. Configure the following:

GUI field Description

Name

Enable

Community Hosts

Enter a name to identify the SNMP community. If you are editing
an existing community, you cannot change the name.

You can add up to 16 communities.

Enable to send traps to and allow queries from the community’s
SNMP managers.

Lists SNMP managers that can use the Setting in this SNMP
community to monitor the FortiVoice unit. Click Create to create a
new entry.

You can add up to 16 hosts.
IP Address Enter the IP address of an SNMP manager. By default, the IP

address is 0.0.0.0, so that any SNMP manager can use this SNMP
community.
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GUI field Description

Create Click to add a new default entry to the Hosts list that you can edit
(button) as needed.
Delete Click to remove this SNMP manager.
(button)
Queries Enter the Port number (161 by default) that the SNMP managers

in this community use for SNMP v1 and SNMP v2c queries to
receive configuration information from the FortiVoice unit. Mark
the Enable check box to activate queries for each SNMP version.

Traps Enter the Local Port and Remote Port numbers (162 local, 162
remote by default) that the FortiVoice unit uses to send SNMP v1
and SNMP v2c traps to the SNMP managers in this community.
Enable traps for each SNMP version that the SNMP managers
use.

Enable each SNMP event for which the FortiVVoice unit should send
traps to the SNMP managers in this community.

Since FortiVoice checks its status in a scheduled int
Y erval, not all the events will trigger traps. For exam
‘9' ple, FortiVoice checks its hardware status every 60
|| seconds. This means that if the power is off for a fe
- w seconds but is back on before the next status che
ck, no system event trap will be sent.

4. Click Create.

Configuring an SNMP v3 user

SNMP v3 adds more security by using authentication and privacy encryption. You can specify an SNMP v3 user on
FortiVoice so that SNMP managers can connect to the FortiVoice unit to view system information and receive SNMP
traps.

To configure an SNMP v3 user

1. Go to System > Configuration > SNMP.

2. Under User, click New to add a user or select a user and click Edit.
The SNMPv3 User page appears.

You can add up to 16 users.
3. Configure the following:

GUI field Description

User name Enter a name to identify the SNMP user. If you are editing an
existing user, you cannot change the name.

Enable Enable to send traps to and allow queries from the user's SNMP
managers.
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GUI field Description

Security level Choose one of the three security levels:

« No authentication, no privacy: This option is similar to SNMP
v1and v2.

« Authentication, no privacy: This option enables
authentication only. The SNMP manager needs to supply a
password that matches the password you specify on
FortiVoice. You must also specify the authentication protocol
(either SHA1 or MD5).

« Authentication, privacy: This option enables both
authentication and encryption. You must specify the protocols
and passwords. Both the protocols and passwords on the
SNMP manager and FortiVoice must match.

Authentication For Security level, if you select either Authentication option, you

Protocol must specify the authentication protocol and password. Both the
authentication protocol and password on the SNMP manager and
FortiVoice must match.

Privacy protocol For Security level, if you select Privacy, you must specify the
encryption protocol and password. Both the encryption protocol
and password on the SNMP manager and FortiVoice must match.

Notification Hosts Lists the SNMP managers that FortiVoice will send traps to. Click
Create to create a new entry. You can add up to 16 host.

IP Address Enter the IP address of an SNMP manager. By default, the IP
address is 0.0.0.0, so that any SNMP manager can use this SNMP
user.

Create Click to add a new default entry to the Hosts list that you can edit

(button) as needed.

Delete Click to remove this SNMP manager.

(button)

Queries Double click the default port number (161) to enter the Port

number that the SNMP managers use for SNMP v3 queries to
receive configuration information from the FortiVoice unit. Select
the Enable check box to activate queries.

Traps Double click the default local port (162) and remote port number
(162) to enter the Local Port and Remote Port numbers that the
FortiVoice unit uses to send SNMP v3 traps to the SNMP
managers. Select the Enable check box to activate traps.

Enable each SNMP event for which the FortiVVoice unit should send
traps to the SNMP managers.
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GUI field Description

Not all events trigger traps because the FortiVoice
V) unit checks its status at a scheduled interval. For
‘9' example, FortiVoice checks its hardware status

every 60 seconds. This means that if the power is
off for a few seconds but is back on before the next
status check, no system event trap will be sent.

4. Click Create.

FortiVoice MIBs

The FortiVoice SNMP agent supports Fortinet proprietary MIBs as well as standard RFC 1213 and RFC 2665 MIBs.
RFC support includes support for the parts of RFC 2665 (Ethernet-like MIB) and the parts of RFC 1213 (MIB Il) that
apply to FortiVoice unit configuration.

The FortiVoice MIBs are listed in FortiVVoice MIBs on page 84. You can obtain these MIB files from Fortinet technical
support. To communicate with the SNMP agent, you must compile these MIBs into your SNMP manager.

Your SNMP manager may already include standard and private MIBs in a compiled database that is ready to use. You
must add the Fortinet proprietary MIB to this database. If the standard MIBs used by the Fortinet SNMP agent are
already compiled into your SNMP manager you do not have to compile them again.

FortiVoice MIBs

MIB file name Description

FortiVoice.mib Displays the proprietary Fortinet MIB includes detailed FortiVoice system configuration
information. Your SNMP manager requires this information to monitor FortiVoice
configuration Setting. For more information, see MIB fields on page 84.

FortiVoice traps

The FortiVoice unit’'s SNMP agent can send traps to SNMP managers that you have added to SNMP communities. To
receive traps, you must load and compile the FortiVoice trap MIB into the SNMP manager.

All traps sent include the trap message as well as the FortiVoice unit serial number and host name.

MIB fields

Trap Description

fvTrapStorageDiskHighThreshold Trap sent if log disk usage and mailbox disk usage become too high.
fvTrapSystemEvent Trap sent when system shuts down, reboots, upgrades, etc.

fmITrapHAEvent Trap sent when an HA event occurs.
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The Fortinet MIB contains fields reporting current FortiVoice unit status information. The tables below list the names of
the MIB fields and describe the status information available for each. You can view more details about the information
available from all Fortinet MIB fields by compiling the MIB file into your SNMP manager and browsing the MIB fields.

System session MIB fields

fvSysModel FortiVoice model number, such as 400 for the FortiVoice-400.
fvSysSerial FortiVoice unit serial number.

fvSysVersion The firmware version currently running on the FortiVoice unit.
fvSysCpuUsage The current CPU usage (%).

fvSysMemUsage The current memory utilization (%).

fvSysLogDiskUsage The log disk usage (%).
fvSysStorageDiskUsage The storage disk usage (%).

fvSysEventCode System component events.
fvSysload Current system load.
fvSysHA « fvHAMode: Configured HA operating mode.

« fvHAEffectiveMoce: Effective HA operating mode.
fmIHAEventld HA event type ID.
fmIHAUnitIp Unit IP address where the event occurs.
fmIHAEventReason The reason for the HA event.

Configuring email setting

You can configure the FortiVoice unit to send email notifications to phone users when they miss a phone call or receive
a voicemail or fax.

iy
‘Q' For phone users to receive the notifications, you need to add their email addresses when
- configuring the extensions. See Configuring extensions on page 164.

To configure email setting

1. Goto System > Configuration > Mail Setting.
2. Configure the following:

GUI field Description

Local Host
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GUI field Description

Host name Enter the host name of the FortiVVoice unit, such as
fortivoice-200D.

Local domain name  Enter the local domain name of the FortiVoice unit, such as
example.com.

Mail Queue

Maximum time for Enter the maximum number of hours that deferred email

email in queue (1- messages can remain in the deferred email queue, during which

240 hours) the FortiVoice unit periodically retries to send the message. After it
reaches the maximum time, the FortiVoice unit sends a final
delivery status notification (DSN) email message to notify the
sender that the email message was undeliverable.

Time interval for Enter the number of minutes between delivery retries for email
retry (10-120 messages in the deferred mail queues.
minutes)

Relay Server Configure an SMTP relay, if needed, to which the FortiVoice unit
will relay outgoing email. This is typically provided by your Internet
service provider (ISP), but could be a mail relay on your internal
network.

Relay server name Enter the domain name of an SMTP relay.

Relay server port Enter the TCP port number on which the SMTP relay listens. This
is typically provided by your Internet service provider (ISP).

Use SMTPs Enable to initiate SSL- and TLS-secured connections to the SMTP
relay if it supports SSL/TLS. When disabled, SMTP connections
from the FortiVoice unit’s built-in MTA or proxy to the relay will
occur as clear text, unencrypted.

This option must be enabled to initiate SMTPS connections.

Authentication Select the checkbox and click the arrow to expand the section and
Required configure:
o Username: Enter the name of the FortiVoice unit’s account
on the SMTP relay.
o Password: Enter the password for the FortiVoice unit’s user
name.
o Authentication type: Available SMTP authentication types
include:
o AUTO (automatically detect and use the most secure
SMTP authentication type supported by the relay server)
o PLAIN (provides an unencrypted, scrambled password)
o LOGIN (provides an unencrypted, scrambled password)
o DIGEST-MD5 (provides an encrypted hash of the
password)
o CRAM-MD5 (provides an encrypted hash of the
password, with hash replay prevention, combined with a
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GUI field Description

challenge and response mechanism)

Customize Email Template View and reword the default email history report and notification
email templates. For more information, see Customizing call
report and notification email templates on page 113.

3. Click Apply.

Customizing the GUI appearance

The System > Configuration > Appearance tab lets you customize the default appearance of the web-based manager
and voicemail interface with your own product name, product logo, corporate logo, and language.

To customize the GUI appearance

1. Goto System > Configuration > Appearance.
2. Click the arrow to expand Administration interface and Voicemail interface.
3. Configure the following:

GUI field Description

Administration Interface

Product name Enter the name of the product. This name will precede Administrator Login in
the title on the login page of the web-based manager.

Product icon Click Change to browse for the product icon. The icon should be in .ico
format, and 16 pixels wide x16 pixels tall in size.

Top logo Click Change to upload a graphic that will appear at the top of all pages in the
web-based manager. The image’s dimensions must be 460 pixels wide by 36
pixels tall.

For best results, use an image with a transparent background. Non-
transparent backgrounds will not blend with the underlying theme graphic,
resulting in a visible rectangle around your logo graphic.

Uploading a graphic overwrites the current graphic. The
NP FortiVoice unit does not retain previous or default graphics.
S L4 q
q If you want to revert to the current graphic, use your web
- browser to save a backup copy of the image to your
- management computer, enabling you to upload it again at a
later time.

Click Reset to return to the default setting.
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GUI field Description

Default Ul language Select the default language for the display of the web-based manager.
You can configure a separate language preference for each administrator
account. For details, see Configuring administrator accounts on page 50.
Default theme Select the default theme for the web-based manager GUI.

User Portal Interface

User Portal login Enter a word or phrase that will appear on top of the user portal login page,
such as User Portal Login.

Login user name hint Enter a hint for the user name, such as Your Email Address. This hint will
appear as a mouse-over display on the login name field.

User Portal theme Select a theme for the user portal GUI.

Default Ul language Select the language in which user portal pages will be displayed. By default,
the FortiVoice unit will use the same language as the web-based manager

User Portal top logo Click Change to upload a graphic that will appear at the top of all user portal
pages. The image’s dimensions must be 460 pixels wide by 36 pixels tall.
For best results, use an image with a transparent background. Non-
transparent backgrounds will not blend with the underlying theme graphic,
resulting in a visible rectangle around your logo graphic.

Uploading a graphic overwrites the current graphic. The Fort
N - & iVoice unit does not retain previous or default graphics. If yo
q u want to revert to the current graphic, use your web browser
- to save a backup copy of the image to your management co
mputer, enabling you to upload it again at a later time.

Click Reset to return to the default setting.

4. Click Apply to save changes or Reset to return to the default setting.

Selecting the call data storage location

The System > Configuration > Storage tab lets you configure local or remote storage of call data such as the recorded
calls, faxes, and voice mails.

FortiVoice units can store call data either locally or remotely. FortiVoice units support remote storage by a network
attached storage (NAS) server using the network file system (NFS) protocol.

NAS has the benefits of remote storage which include ease of backing up the call data and more flexible storage limits.
Additionally, you can still access the call data on the NAS server if your FortiVoice unit loses connectivity.

Ay

~ P If the FortiVoice unit is a member of an active-passive HA group, and the HA group stores call
? data on a remote NAS server, disable call data synchronization to prevent duplicate call data
- traffic. For details, see Configuring the HA mode and group on page 62.
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\‘é', If you store the call data on a remote NAS device, you cannot back up the data. You can only

back up the call data stored locally on the FortiVoice hard disk. For information about backing
up call data, see Backing up configuration on page 105.

Tested and Supported NFS servers

o Linux NAS (NFS v3/v4)
« RedHat5.5
o Fedora 16/17/18/19
o Ubuntu 11/12/13
o OpenSUSE 13.1
+ FreeNAS
« Openfiler
« EMC VNXe3150 (version 2.4.2.21519(MR4 SP2))
o EMC Isilon S200 (OneFS 7.1.0.3)

Untested NFS servers

« Buffalo TeraStation
o Cisco Linksys NAS server

Non-Supported NFS Servers

o Windows 2003 R2 /Windows 2008 Service for NFS
To configure call data storage
Go to System > Configuration > Storage.

Configure the following:

GUI field Description

Local Select to store call data on the FortiVoice unit’s local disk or RAID.
NAS Select to store call data on a remote network attached storage (NAS)
server.
Storage type Select a type of the NAS server:

o NFS: To configure a network file system (NFS) server. For this
option, enter the following information:

o Hostname/IP address: the IP address or fully qualified
domain name (FQDN) of the NFS server.

o Port: the TCP port number on which the NFS server listens
for connections.

« Directory: the directory path of the NFS export on the NAS
server where the FortiVoice unit will store call data.

o iSCSI Server. To configure an Internet SCSI (Small Computer
System Interface) server. For this option, enter the following
information:

« Initiator name as username: Select to use the iSCSI
initiator node name as the user name of the FortiVoice
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GUI field Description

Test
(button)

Click here to format
this device

Click here to check
file system on this

unit’s account on the iISCSI server.

o Usemame: the user name of the FortiVoice unit’s account
on the iSCSI server.

« Password: the password of the FortiVoice unit’s account on
the iISCSI server.

o Hostname/IP address: the IP address or fully qualified
domain name (FQDN) of the iSCSI server.

o Port: the TCP port number on which the iSCSI server listens
for connections.

o Encryption key: the key that will be used to encrypt data
stored on the iISCSI server. Valid key lengths are between 6
and 64 single-byte characters.

o iSCSI ID: the iSCSI identifier in the format expected by the
iSCSI server, such as an iSCSI Qualified Name (IQN),
Extended Unique Identifier (EUI), or T11 Network Address
Authority (NAA).

Status: When available, it indicates if the iSCSI share was
successfully mounted on the FortiVoice unit’s file system. This field
appears only after you configure the iISCSI share and click Apply.
Status may take some time to appear if the iISCSI server is slow to
respond.

If Not mounted appears, the iSCSI share was not successfully
mounted. Verify that the iSCSI server is responding and the
FortiVoice unit has both read and write permissions on the iSCSI
server.

Click to verify the NAS server Setting are correct and that the
FortiVoice unit can access that location. The test action basically tries
to discover, login, mount, and unmount the remote device.

This button is available only when NAS serveris selected.

These two links appear when you configure an iSCSI server and click
Apply.

Click a link to initiate the described action (that is, format the device
or check its file system). A message appears saying the action is
being executed. Click OK to close the message and click Refresh to

device see a Status update.
If the ISCSI disk has never been formatted, the
) ! /_  FortiVoice unit needs to format it before it can be
q used. If the disk has been formatted before, you do
= not need to format it again. unless you want to wipe
out the data on it.
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Configuring single sign on

Fortinet Single Sign-On (FSSO) is the authentication protocol by which users can transparently authenticate to Fortinet
devices. The authentication system (FortiAuthenticator, ADFS, or Centrify) identifies and authenticate users based on
their authentication from a different system.

The FortiVoice SSO configuration involves the participation of a network authentication system, such as
FortiAuthenticator. The network authentication system can be integrated with the FortiVoice unit to poll administrator
logon information and send it to the FortiVoice unit.

FortiAuthenticator is used as the example authentication system here. For more information, see FortiAuthenticator
Administration Guide.

For other systems, refer to their user manuals for configuration information.
You need to have both systems open and switch between the two to exchange authentication information.

Once you complete the FortiVoice SSO configuration and log into the FortiVoice unit, the Single Sign On button will
appear on the login page. You can click it and enter the login credential of the FortiAuthenticator user account created
for the FortiVoice administrator with single sign on authentication type.

Note that once SSO is enabled:

« all administrator login authentication is controlled by the FortiAuthenticator system. Disabled administrator
accounts should not be authenticated by the FortiAuthenticator.

« the FortiVoice administrator portal must be accessed using HTTPS (i.e. https://fortivoice_ip_or_hostname )
« logging out of FortiVoice administrator portal will also log out of the FortiAuthenticator system.

To configure FortiVoice SSO

1. On the FortiAuthenticator:
a. Go to Authentication > SAML IdP > Generaland enable SAML IDP (Identity Provider).
b. Go to Authentication > SAML IdP > Service Providers.
c. Click Create New to add a SAML service provider and click the Copy idp_entity _id icon.
2. On the FortiVoice unit:
Go to System > Configuration > Single Sign On.
Select Enabled.
Click Retrieve from URL and paste the IDP entity ID you copied.
Click OK to get the IDP metadata from the FortiAuthenticator.
Refresh your browser. The FortiVoice service provider metadata is generated.
Click Download to save the FortiVoice service provider metadata.
Click Apply.
Go to System >Administrator to create an administrator account with single sign on authentication type. For
more information, see Configuring administrator accounts on page 50.
3. Onthe FortiAuthenticator:

STQ -0 2000

Go to the SAML service provider you have created.
2. Click Import SP metadata and browse for the FortiVoice service provider metadata you saved and click OK.
3. Enable SAML request must be signed by SP.
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Click OK to save the service provider configuration.

Open the SAML service provider you have created.

Click Create New under SAML Attribute.

In SAML attribute, enter "urn:0id:0.9.2342.19200300.100.1.3".
In User attribute, select an option and click OK, then OK.

Go to User Management > Local Users and create a user account for the FortiVoice administrator with single sign
on authentication type and use the FortiVoice administrator name as the account user name.

© o N GA

Enabling security fabric

Starting from this release, the FortiVoice unit can connect to an upstream FortiGate root and become an integrated
cluster member of a Security Fabric.

Make sure that REST API access mode is selected in System > Administrator > Administrator.

To configure security fabric

Go to System > Configuration > Security Fabric.

Enable the unit to become a Security Fabric member.

For Upstream IP Address, enter the IP address and port number of the upstream FortiGate root.

For Management IP/FQDN, enter the IP address and port number of the FortiVoice unit.

Click Apply.

If the connection is successful, Authorization status shows This device has been authorized by upstream. The

Security Fabric FortiGate root establishes a connection to the FortiVoice unit using the IP address and port number
specified.

You can click the Click here to log into upstream device link to open the upstream FortiGate root device.

OO

Configuring advanced phone system settings

The System > Advanced submenu lets you configure SIP setting, SIP phone auto-provisioning, prompt languages,
phone management, and system capacity.

This topic includes:

« Configuring SIP settings on page 92

o Configuring the internal ports on page 95

« Configuring external access on page 96

« Configuring SIP phone auto-provisioning on page 96

Configuring SIP settings

FortiVoice units support SIP communications.

To configure FortiVoice SIP Setting

FortiVoice Phone System 6.4.3 Administration Guide
Fortinet Technologies Inc.



Configuring system settings

1. Goto System > Advanced > SIP.

2. Configure the following:

GUI field Description

SIP Transport/Internal

RTP Setting

Ports SIP communication commonly uses TCP or UDP port 5060
and/or 5061. Port 5060 is used for nonencrypted SIP signaling
sessions and port 5061 is typically used for SIP sessions
encrypted with Transport Layer Security (TLS). The WebSocket
Secure (WSS) protocol establishes a WebSocket over an
encrypted TLS connection. The default port is 8089.

Enter the ports as required.

Port Enter the starting Real-time Transport Protocol (RTP) port that
the FortiVoice unit will use for phone call sessions. If the unit is
behind a firewall, these ports should be open. Ensure there is a
reasonable port range so that you have enough ports for all
open calls. The default port is 5000.

Enter the end RTP port that the FortiVoice unit will use for
phone call sessions. Ensure there is a reasonable port range so
that you have enough ports for all open calls. The default port is
30000.

Timeout Enter the amount of time in seconds during an active call that
the extension will wait for RTP packets before hanging up the
call. 0 means no time limit. The default is 60.

Hold timeout Enter the amount of time in seconds that the extension will wait
on hold for RTP packets before hanging up the call. 0 means no
time limit. The default is 300.

Registration/Subscription Interval If this is a dynamic account with the VolP provider, enter the

FortiVoice Phone System 6.4.3
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registration interval as required by the VolP provider. After each
registration interval, the FortiVoice unit renews the registration
of the account with the VoIP provider.

Extension To keep the extensions’ registration status with the FortiVoice
registration/subscription unit, enter the range of extension registration time interval as
interval range required by the FortiVoice unit in minutes. An extension’s

registration timeout setting is overridden by the FortiVoice
unit’s extension registration time interval range if it is out of the
range.

The default range is 1-480.

The start of the range is 1-60 and the end of the range is 30-

1440.
Internal extension Enter the default registration time interval for the extensions on
registration/subscrip your subnet as required by the FortiVoice unit in minutes. The
tion interval default is 30 and the range is 10-480.
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GUI field Description

Set a proper value for this option. If it is too low, the
performance of the FortiVoice unit is compromised due to
frequent registration. If it is too high, the connection between
the FortiVoice unit and the extension may terminate.

External extension Enter the default registration time interval for the extensions on
registration/subscrip other subnets as required by the FortiVoice unit in seconds. The
tion interval default is 30 and the range is 10-1800.

Set a proper value for this option. The FortiVoice unit requires
that external extensions register more frequently with it to keep
the connection. However, if the value is set too low, the
performance of the FortiVoice unit is compromised due to
frequent registration. If it is too high, the connection between
the FortiVoice unit and the extension may terminate.

Security By default, the FortiVoice unit screens out incoming calls from
unauthenticated source. If you want to change this default
setting, select Accept unauthenticated incoming call.

Advanced Setting SIP session helper. Select if you do not want the FortiVoice
unit to apply NAT or other SIP session help features to SIP
traffic. With the SIP session helper disabled, the FortiVoice unit
can still accept SIP sessions if they are allowed by a security
policy, but the FortiVoice unit will not be able to open pinholes
or NAT the addresses in the SIP messages.

Internal network type: Identify the internal networks designated
for phone calls on the FortiVoice unit. When a call reaches the
public IP address of the FortiVoice unit, it will be routed to one
of the internal networks.

Note that modifying internal networks terminate ongoing calls.

This option is only available if you select SIP session helper.
« Userdefined: Configure your own internal network
designated for phone calls on the FortiVoice unit.
« RFC 1918 predefined: Private |Pv4 addresses used for
internal traffic that does not route via the Internet.
SIP timer T1: Enter the SIP T1 in milliseconds. This is an
estimate of the Round Trip Time (RTT) of transactions between
a client and server. For example, when a SIP Client attempts to
send a request to a SIP Server, the time it takes between
sending out the request to the point of getting a response is the
SIP T1 timer. By default the timer is set to 500 milliseconds.
The SIP Timer object is used as specific timing attribute to the
SIP Signaling object. Use caution when adjusting these timers
because undesired outcomes from lengthy SIP retransmits to
an increase in traffic across the network may result.
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GUI field Description

SIP timer B:This is the INVITE transaction timeout timer. It
changes based on the SIP timer T1 value.
ICE support: When the FortiFone softclient is located behind a
Network Address Translator (NAT) or FortiFone softclients are
on different networks (without internetwork routing), configure
the interactive connectivity establishment (ICE) support to allow
the FortiVoice phone system to establish a valid audio path with
the FortiFone softclient.
To configure the ICE support, you have the following two
options:
« Static mapping: Uses the internal and external IP
addresses of the FortiVoice phone system.
« STUN server: Uses the IP address of a Session Traversal
Utilities for NAT (STUN) server.
Decide which option you want to configure for ICE support.
For information on configuring the static mapping, see
Configuring the static mapping for ICE support on page 95.
For information on configuring the STUN server, see
Configuring the STUN server for ICE support on page 95.

3. Click Apply.

Configuring the static mapping for ICE support

Go to System > Advanced > SIP.

Expand Advanced Setting.

In ICE Support, select Static mapping.

Click New.

Enable the static mapping record.

Enter the internal and external FortiVoice |P addresses used in your deployment.
Click Create.

Nooahkoodb-=

Configuring the STUN server for ICE support

Go to System > Advanced > SIP.

Expand Advanced Setting.

In ICE Support, select STUN server.

For STUN server, enter the IP address or host name of a Fortinet or third-party STUN server.

AoOobd-=

Configuring the internal ports

System > Advanced > Service lets you configure the FortiVoice unit listening ports for network communications.
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To configure internal port setting

1. Goto System > Advanced > Service.
2. Change the default HTTP and HTTPS port numbers if required.
3. Enable TFTP port if required.
TFTP connection is not secure, and can be intercepted by a third party.
4. Other ports are predefined and cannot be changed.
5. Click Apply.

Configuring external access

System > Advanced > External Access lets you configure the FortiVoice unit external hostname/IP and ports through
which it can be accessed by other devices through the internet.

When external extensions connect to the FortiVoice unit, they get the basic PBX configurations including the external
access |P and ports through auto provisioning. They can then use the information to register with the FortiVoice unit.
For more information, see Configuring SIP phone auto-provisioning on page 96.

Extensions are defined as external in extension configuration. For more information, see Configuring IP extensions on
page 164.

To configure external access

1. Goto System > Advanced > Extemal Access and configure the following:

GUI field Description

SIP server external Enter the hostname/IP for your SIP server external access.
hostname/IP address

SIP External Ports Enter the external access ports for SIP transport.
WSS (WebSocket Secure) is used to support FortiFone desktop application.

Other service external If you have another service for external access, enter the hostname/IP.
hostname/IP address
Service External Ports Enter the external access ports for the other service.

2. Click Apply.

Configuring SIP phone auto-provisioning

System > Advanced > Auto Provisioning allows the FortiVoice unit to discover the SIP phones on your network and
send the configuration files to them.

With auto-provisioning configured, when a supported FortiFone is connected to the network and powered on, it is
automatically discovered and receives the configuration file from the FortiVoice unit. The FortiFone will then reboot with
the pushed-in configuration file and register with the FortiVoice unit.

The FortiVoice unit can only auto provision the supported FortiFones.
To configure auto-provisioning settings

1. Goto System > Advanced > Auto Provisioning and configure the following:

FortiVoice Phone System 6.4.3 Administration Guide 96
Fortinet Technologies Inc.



Configuring system settings

GUI field Description

Auto Provisioning

Auto Discovery

Enabled Select to activate the SIP phone auto-provisioning function for
auto discovering the phones.

Unassigned phone This option is only available after auto provisioning is enabled.

(Generate default Select to generate basic phone configuration files for the
configuration for supported unassigned SIP Desktop FortiFones. For details, see
unassigned Desktop  Vjiewing desktop FortiFones on page 30.

FortiFone)

With this option selected, once a supported FortiFone connects to
the FortiVoice unit and is auto-discovered, the FortiVoice unit
sends the basic PBX setup information to it for registering with the
FortiVoice unit to be assigned an extension.

If you want to upgrade your phone system and keep the current
phone configuration, do not select this option. Otherwise your
existing phone configuration will be overridden by the upgraded
FortiVoice configuration.

Provisioning protocol Select the protocol for the phones to retrieve the configuration file
from the FortiVoice unit.

Server Setting for If you use different servers for SIP, NTP, and LDAP, select to

Phone Configuration configure the Setting of each server for the supported phones. The
servers’ port information reflect the FortiVoice unit’s network
interfaces. For details, see Configuring the network interfaces on
page 42.

o SIP server: Select or click Overrideto enter the current public
IP address or public domain name of the server. The SIP
phones connect to this server to register.

o NTP server: Select or click Override to enter the current
public IP address or public domain name of the server. The
SIP phones connect to this server to synchronize time.

o LDAP contact: Select or click Override to enter the current
public IP address or public domain name of the server. The
SIP phones connect to this server to receive phone
directories.

« Provisioning server. If you use a specific server to send PBX
setup information to the phones, select or click Override to
enter the current public IP address or public domain name of
the server. The SIP phones connect to this server to receive
the full PBX setup information.

If phone auto discovery is required, enable SIPPnP multicast function for the connected
phones to find the provisioning server contained in its message for the phones.

You can also click the DHCP server link to select or add a server that contains provisioning
server information in its message for the phones to look for. For more information, see
Configuring DHCP server on page 47.

SIPPnP multicast and DHCP server do not conflict although SIPPnP has priority. Phones
can retrieve provisioning server information from either of the two.
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GUI field Description

Other Setting

Secondary account In addition to the main account, secondary accounts can be added

(Enable secondary on the same FortiVoice unit. When you add a secondary account

account for Desktop  to your extension, you can set the secondary extension to ring at

FortiFone) the same time as your existing extension. However, the secondary
extension operates separately. For example, extension 100 sets
extension 200 to be a secondary account. When a call comesin to
extension 100, both extensions (100 and 200) will ring and you can
answer one of them. In the same example, if a call comes into
extension 200, only extension 200 will ring.

Select this option in order to add a secondary account when
configuring extensions. For details, see Advanced on page 168

Administrator PIN to  Click and enter a global password to be used by an administrator

provision phone to connect a FortiFone phone to the FortiVoice unit to set mobile
extension number. This password is also used by the administrator
to override schedules. For details, see Configuring system
capacity on page 114.
For example, you can press the default Configure Phone feature
code *17 (See Modifying feature access codes on page 304) on
any FortiFone phone that connects to the FortiVoice unit and enter
this password. You can then enter an existing extension to set it as
the extension of this phone.

Backward support of If you have legacy FortiFone phones, select this option for

legacy FortiFone backward provisioning support.

(FON TFTP provisioning server contains phone auto provisioning
470/870/360/460/  information for the phones.

560) (Obsolescent)

mDNS multicast address allows the connected phones to find the
provisioning server contained in the mDNS multicast server
message.

2. Click Apply.

Managing certificates

This section explains how to manage X.509 security certificates using the FortiVoice web-based manager. Using the
Certificate submenu, you can generate certificate requests, install signed certificates, import CA root certificates and
certificate revocation lists, and back up and restore installed certificates and private keys.

The FortiVoice unit uses certificates for PKI authentication in secure connections. PKI authentication is the process of
determining if a remote host can be trusted with access to network resources. To establish its trustworthiness, the
remote host must provide an acceptable authentication certificate by obtaining a certificate from a certification authority
(CA).

You can manage the following types of certificates on the FortiVoice unit:
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Certificate type Usage

Server certificates The FortiVoice unit must present its local server certificate for the following secure
connections:
« the web-based manager (HTTPS connections only)
« phone user portal (HTTPS connections only)
« phone and FortiVoice unit (TLS and SRTP connections only), see Configuring SIP
profiles on page 131.
For details, see Managing local certificates on page 99.

CA certificates The FortiVoice unit uses CA certificates to authenticate the PKI users, including
administrators and phone users. For details, see Managing certificate authority certificates
on page 104.

Personal certificates Phone users’ personal certificates are used for S/IMIME encryption.

OCSP server View and import the certificates of the online certificate status protocol (OCSP) servers of

certificates your certificate authority (CA).

This section contains the following topics:

« Managing local certificates on page 99

« Obtaining and installing a local certificate on page 100
« Managing certificate authority certificates on page 104
« Managing the certificate revocation list on page 104

« Managing OCSP server certificates on page 105

Managing local certificates

System > Certificate > Local Certificate displays both the signed server certificates and unsigned certificate requests.

On this tab, you can also generate certificate signing requests and import signed certificates in order to install them for
local use by the FortiVoice unit.

FortiVoice units require a local server certificate that it can present when clients request secure connections, including:

« the web-based manager (HTTPS connections only)
« phone user web interface (HTTPS connections only)

To view local certificates, go to System > Certificate > Local Certificate.

GUI field Description

View Select a certificate and click View to display its issuer, subject, and range of dates
within which the certificate is valid.

Generate Click to generate a local certificate request. For more information, see
Generating a certificate signing request on page 100.

Download Click the row of a certificate file or certificate request file in order to select it, then
click this button and select either:
« Download: Download a certificate (.cer) or certificate request (.csr) file. You
can send the request to your certificate authority (CA) to obtain a signed
certificate for the FortiVoice unit. For more information, see Downloading a
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GUI field Description

certificate signing request on page 102.
« Download PKCS12 File: Download a PKCS #12 (.p12) file. For details, see
Downloading a PKCS #12 certificate on page 104.

Assign to Click the row of a certificate in order to select it, then click this button to assign it
to a service.
Import Click to import a signed certificate for local use. For more information, see

Importing a certificate on page 103.

Obtaining and installing a local certificate

There are two methods to obtain and install a local certificate:
« If you already have a signed server certificate (a backup certificate, a certificate exported from other devices, and
so on), you can import the certificate into the FortiVoice unit. For details, see Importing a certificate on page 103
« Generate a certificate signing request on the FortiVoice unit, get the request signed by a CA, and import the signed
certificate into the FortiVoice unit.
For the second method, follow these steps:

o Generating a certificate signing request on page 100

+ Downloading a certificate signing request on page 102

« Submitting a certificate request to your CA for signing on page 102
« Importing a certificate on page 103

Generating a certificate signing request

You can generate a certificate request file, based on the information you enter to identify the FortiVoice unit. Certificate
request files can then be submitted for verification and signing by a certificate authority (CA).

For other related steps, see Obtaining and installing a local certificate on page 100.
To generate a certificate request

1. Goto System >Certificate > Local Certificate.
2. Click Generate.
3. Configure the following:

GUI field Description

Certification name Enter a unique name for the certificate request, such as fvlocal.

Subject Information Information that the certificate is required to contain in order to
uniquely identify the FortiVoice unit.

Certification name Select the type of identifier to be used in the certificate to identify
the FortiVoice unit:
o HostIP
o Domain name
o E-mail
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GUI field Description

Which type you should select varies by whether or not your
FortiVoice unit has a static IP address, a fully-qualified domain
name (FQDN), and by the primary intended use of the certificate.
For example, if your FortiVoice unit has both a static IP address
and a domain name, but you will primarily use the local certificate
for HTTPS connections to the web-based manager by the domain
name of the FortiVoice unit, you might prefer to generate a
certificate based on the domain name of the FortiVoice unit, rather
than its IP address.

« Host IP requires that the FortiVoice unit have a static, public
IP address. It may be preferable if clients will be accessing the
FortiVoice unit primarily by its IP address.

« Domain name requires that the FortiVoice unit have a fully-
qualified domain name (FQDN). It may be preferable if clients
will be accessing the FortiVoice unit primarily by its domain
name.

o E-mail does not require either a static IP address or a domain
name. It may be preferable if the FortiVoice unit does not
have a domain name or public IP address.

IP Enter the static IP address of the FortiVoice unit.
This option appears only if ID type is Host IP.

Domain name Type the fully-qualified domain name (FQDN) of the FortiVoice
unit.

The domain name may resolve to either a static or, if the
FortiVoice unit is configured to use a dynamic DNS service, a
dynamic IP address. For more information, see Configuring the
network interfaces on page 42 and Configuring DNS on page 46.

If a domain name is not available and the FortiVoice unit
subscribes to a dynamic DNS service, an unable to verify
certificate message may appear in the user's browser
whenever the public IP address of the FortiVoice unit changes.

This option appears only if ID type is Domain name.

E-mail Type the email address of the owner of the FortiVoice unit.
This option appears only if ID type is E-mail.

Optional Information Information that you may include in the certificate, but which is not
required.

Organization unit Type the name of your organizational unit, such as the name of
your department (Optional), and click >>.

You may enter more than one organizational unit name.
Organization Type the legal name of your organization. (Optional)

Locality (City) Type the name of the city or town where the FortiVoice unit is
located. (Optional)
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GUI field Description

State/Province Type the name of the state or province where the FortiVoice unit is
located. (Optional)

Country Select the name of the country where the FortiVoice unit is
located. (Optional)
E-mail Type an email address that may be used for contact purposes.
(Optional)
Key type Displays the type of algorithm used to generate the key.

This option cannot be changed, but appears in order to indicate
that only RSA is currently supported.

Key size Select a security key size of 5712 Bit, 1024 Bit, 1536 Bit or 2048
Bit. Larger keys are slower to generate, but provide better security.

4. Click Create.
The certificate is generated, and can be downloaded to your management computer for submission to a certificate
authority (CA) for signing. For more information, see Downloading a certificate signing request on page 102.

Downloading a certificate signing request

After you have generated a certificate request, you can download the request file to your management computer in
order to submit the request file to a certificate authority (CA) for signing.

For other related steps, see Obtaining and installing a local certificate on page 100.
To download a certificate request

1. Goto System >Certificate > Local Certificate.
2. Click the row that corresponds to the certificate request in order to select it.

3. Click Download, then select Download from the pop-up menu.
Your web browser downloads the certificate request (.csr) file.

Submitting a certificate request to your CA for signing

After you download the certificate request file, you can submit the request to you CA for signing.
For other related steps, see Obtaining and installing a local certificate on page 100.
To submit a certificate request

1. Using the web browser on the management computer, browse to the website for your CA.

2. Follow your CA’s instructions to place a Base64-encoded PKCS #12 certificate request, uploading your certificate
request.

3. Follow your CA’s instructions to download their root certificate and Certificate Revocation List (CRL), and then
install the root certificate and CRL on each remote client.

4. When you receive the signed certificate from the CA, install the certificate on the FortiVoice unit. For more
information, see Importing a certificate on page 103.
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Importing a certificate

You can upload Base64-encoded certificates in either privacy-enhanced email (PEM) or public key cryptography
standard #12 (PKCS #12) format from your management computer to the FortiVoice unit.

DER encoding is not supported in FortiVoice version 2.0 GA.
Importing a certificate may be useful when:

« restoring a certificate backup
« installing a certificate that has been generated on another system

« installing a certificate, after the certificate request has been generated on the FortiVoice unit and signed by a
certificate authority (CA)

If you generated the certificate request using the FortiVoice unit, after you submit the certificate request to CA, the CA
will verify the information and register the contact information in a digital certificate that contains a serial number, an
expiration date, and the public key of the CA. The CA will then sign the certificate and return it to you for installation on
the FortiVoice unit. To install the certificate, you must import it. For other related steps, see Obtaining and installing a
local certificate on page 100.

If the FortiVoice unit’s local certificate is signed by an intermediate CA rather than a root CA, before clients will trust the
FortiVoice unit’s local certificate, you must demonstrate a link with trusted root CAs, thereby proving that the FortiVoice
unit’s certificate is genuine. You can demonstrate this chain of trust either by:

« installing each intermediate CA'’s certificate in the client’s list of trusted CAs
« including a signing chain in the FortiVoice unit’s local certificate

To include a signing chain, before importing the local certificate to the FortiVoice unit, first open the FortiVoice unit’s
local certificate file in a plain text editor, append the certificate of each intermediate CA in order from the intermediate
CA who signed the FortiVoice unit’s certificate to the intermediate CA whose certificate was signed directly by a trusted
root CA, then save the certificate. For example, a local certificate which includes a signing chain might use the following
structure:

————— BEGIN CERTIFICATE-----
<FortiVoice unit’s local server certificate>

————— BEGIN CERTIFICATE-----

<certificate of intermediate CA 1, who signed the FortiVoice certificate>

————— END CERTIFICATE-----

————— BEGIN CERTIFICATE-----

<certificate of intermediate CA 2, who signed the certificate of intermediate CA
1 and whose certificate was signed by a trusted root CA>

————— END CERTIFICATE-—----

To import a local certificate

1. Goto System >Certificate > Local Certificate.
2. Click Import.
3. Select the type of the import file or files:

» Local Cetrtificate: Select this option if you are importing a signed certificate issued by your CA. For other
related steps, see Obtaining and installing a local certificate on page 100.

o PKCS12 Certificate: Select this option if you are importing an existing certificate whose certificate file and
private key are stored in a PKCS #12 (.p12) password-encrypted file.

« Cetrtificate: Select this option if you are importing an existing certificate whose certificate file (.cert) and key
file (.key) are stored separately. The private key is password-encrypted.
The remaining fields vary by your selection in Type
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4. Configure the following:
« Certificate name: Enter the name of the certificate.

« Cetrtificate file: Enter the location of the previously .cert or .pem exported certificate (or, for PKCS #12
certificates, the .p12 certificate-and-key file), or click Import to locate the file.

« Key file: Enter the location of the previously exported key file, or click Import to locate the file.
« This option appears only when Type is Certificate.

« Password.: Enter the password that was used to encrypt the file, enabling the FortiVoice unit to decrypt and
install the certificate.

This option appears only when Type is PKCS 12 certificate or Certificate.
5. Click OK.

Downloading a PKCS #12 certificate

You can export certificates from the FortiVoice unit to a PKCS #12 file for secure download and import to another
platform, or for backup purposes.

To download a PKCS #12 file

1. Goto System > Certificate > Local Certificate.

2. Click the row that corresponds to the certificate in order to select it.

3. Click Download, then select Download PKCS12 File on the pop-up menu.
A dialog appears.

4. In Password and Confirm password, enter the password that will be used to encrypt the exported certificate file.
The password must be at least four characters long.

5. Click OK.
If your browser prompts you for a location to save the file, select a location.

7. Your web browser downloads the PKCS #12 (.p12) file. For information on importing a PKCS #12 file, see
Importing a certificate on page 103.

o

Managing certificate authority certificates

Go to System > Certificate > CA Certificate to view and import certificates for certificate authorities (CA).

Certificate authorities validate and sign other certificates in order to indicate to third parties that those other certificates
may be trusted to be authentic.

CA certificates are required by connections that use transport layer security (TLS), and by S/MIME encryption.
Depending on the configuration of each PKI user, CA certificates may also be required to authenticate PKI users.

To view the list of CA certificates, go to System > Certificate > CA Certificate. You can remove, view, download, or
import a CA certificate.

Managing the certificate revocation list

The Certificate Revocation List tab lets you view and import certificate revocation lists.

To ensure that your FortiVoice unit validates only valid (not revoked) certificates, you should periodically upload a
current certificate revocation list, which may be provided by certificate authorities (CA).
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To view remote certificates, go to System >Certificate > Certificate Revocation List. You can remove, view,
download, or import a certificate revocation list.

Managing OCSP server certificates

Go to System > Certificate > Remote to view and import the certificates of the online certificate status protocol (OCSP)
servers of your certificate authority (CA).

OCSP lets you revoke or validate certificates by query, rather than by importing certificate revocation lists (CRL). For
information about importing CRLs, see Managing the certificate revocation list on page 104.

Remote certificates are required if you enable OCSP for PKI users.

To view a the list of remote certificates, go to System > Certificate > Remote.

GUI field Description

View Select a certificate and click View to display certificate details including the
certificate name, issuer, subject, and the range of dates within which the
certificate is valid.

Download Click the row of a certificate in order to select it, then click Download to save a
copy of the OCSP server certificate (.cer).

Import Click to import an OCSP server certificate.

Name Displays the name of the OCSP server certificate.

Subject Displays the Distinguished Name (DN) located in the Subject field of the
certificate.

Maintaining the system

The System > Maintenance submenu allows you to perform scheduled maintenance.
This topicincludes:

« Maintaining the system configuration on page 105

« Downloading a trace file on page 106

Maintaining the system configuration

The System > Maintenance > Configuration tab contains features for use during scheduled system maintenance:
updates, backups, restoration, and centralized administration.

Backing up configuration

Before installing FortiVoice firmware or making significant configuration changes, back up your FortiVoice configuration.
Backups let you revert to your previous configuration if the new configuration does not function correctly. Backups let
you compare changes in configuration.
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You can back up system configuration or user configuration. System configuration includes the configurations that make
the FortiVoice unit work. User configuration includes user-configured Setting, such as voicemail greetings, in addition to
system configuration.

In addition to backing up your configuration manually, you can also configure a schedule to back up the configuration
automatically to the FortiVoice local hard drive or a remote FTP/SFTP server.

To back up the configuration file

1. Go to System > Maintenance > Configuration.

2. Inthe Backup area, select System configuration or User data.

If you choose to back up user data and the user data files are not updated, select the files to be updated and click
Prepare first before proceeding to the next step.

3. Click Backup.
Your management computer downloads the configuration file. Time required varies by the size of the file and the
speed of your network connection. You can restore the backup configuration later when required. For details, see
Restoring the configuration on page 106.

To schedule a configuration backup

1. Go to System > Maintenance > Configuration.

2. Under Scheduled Backup, configure the schedule time and the maximum backup number. When the maximum
number is reached, the oldest version will be overwritten.

3. Enable Local backup if you want to back up locally. You can select a backup type to view, restore, download, or
delete a configuration file.

4. Enable Remote backup and configure the FTP/SFTP server credentials if you want to back up remotely.
5. Click Apply.

Restoring the configuration

In the Restore Configuration area under System > Maintenance > Configuration > Trace Log, you can restore the
backup FortiVoice configuration from your local PC. For details, see Restoring the configuration on page 375.

Restoring the firmware

In the Restore Firmware area under System > Maintenance > Configuration > Trace Log, you can install a FortiVoice
firmware from your local PC. For details, see Installing firmware on page 372.

Downloading a trace file

If Fortinet Technical Support requests a trace log for system analysis purposes, you can download one using the web-
based manager.

Trace logs are compressed into an archive (.gz), and contain information that is supplementary to debug-level log files.
To download a trace file

1. Go to System > Maintenance > Configuration > Trace Log.
2. Configure Trace Log settings.
3. Click Prepare to make the trace log file ready before downloading it.
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4. Click Download trace log.
Your web browser downloads trace.log.gz.

Maintaining phones

The System > Maintenance > Phone Maintenance Job tab lets you update phone configurations and upgrade phone

firmware.

Click the Phone Configuration button to view the phone configuration files you have updated. For more information, see
Viewing log messages on page 35.

Click the Phone Firmware button to view the phone firmware you have upgraded. For more information, see Managing

firmware on page 157.

To update phone configurations or upgrade phone firmware

1. Goto System > Maintenance > Phone Maintenance Job.

2. Click New and select to upgrade phone or firmware.

3. Configure the following:

GUI field

Name
Type

Extension Selection

Schedule

All related devices
(enabled)

All related devices
(disabled)

To view a phone maintenance job

Description
Enter a name for the operation.

Choose the type of operation you want to perform.

Select the extensions of which you want to perform the operation.

You want to update phone configurations or upgrade phone
firmware for all devices.

You want to update phone configurations or upgrade phone
firmware for selected devices.

Phone Model: Select the phone model of the extensions of which
you want to perform the operation.

Extension: Click in the plus sign to select the extensions for the
selected phone model.

Schedule the time to update phone configurations or upgrade
phone firmware.

1. Go to System > Maintenance > Phone Maintenance.
2. Double-click a maintenance job record to view the details of phone configuration or firmware upgrades.

3. If you want to redo an upgrade for one or multiple phones, select the phones and click Redo.

To reboot phones

1. Goto System > Maintenance > Phone Maintenance.
2. Click New > Phone Force Reboot.

FortiVoice Phone System 6.4.3 Administration Guide

Fortinet Technologies Inc.

107



Configuring system settings

3. Configure the following:

GUI field Description

Name Enter a name for the phone reboot operation.
Extension Selection Select the extensions of which you want to perform the operation.

All devices You want to reboot all of the phones registered with the FortiVoice
unit.

Selected devices You want to reboot some phones registered with the FortiVoice
unit.

Phone Model: Select the phone model of the extensions of which
you want to perform the operation.

Extension: Click the plus sign to select the extensions for the
selected phone model.

Schedule Schedule the time to reboot the phones.

4. Click Create.
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Configuring phone system

The Phone System menu lets you configure the FortiVoice PBX settings and other features for managing phone calls.
This topicincludes:

« Configuring phone system settings on page 109
« Creating contacts on page 117

« Managing phone audio settings on page 119

« Configuring LDAP settings on page 124

« Working with FortiVoice profiles on page 131

« Configuring devices on page 147

« Reviewing system configuration on page 153

Configuring phone system settings

Phone System > Setting let you configure the FortiVoice unit’s location, number management, speed dial, email
notification templates and system capacity.

Ay
‘9' You need to inform the users about some of the settings that affect them, such as number

setting and speed dial setting.

This topic includes:

« Setting PBX location and contact information on page 109

« Configuring PBX options on page 111

« Customizing call report and notification email templates on page 113
« Configuring system capacity on page 114

Setting PBX location and contact information

Identify the FortiVoice unit’s location and its number.
To set the PBX location

1. Goto Phone System > Setting > Location.
2. Configure the following:

GUI field Description

Country/Region Select the country/region where the FortiVoice unit is in.
Emergency number  Click the default number (911) to enter the emergency call number of the selected
country.
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GUI field Description

Long-distance prefix Click the default number (1) to enter the prefix for dialing long-distance calls.
International prefix ~ Click the default number (011) to enter the prefix for dialing international calls.
Outside line prefix Click the default number (9) to enter the prefix for making outbound calls.

Area code Click the default number (613) to enter the Area code for the main number of the
FortiVoice unit. This code is provided by your PSTN service provider.

Required when Select this option if the area code needs to be dialed for local phone calls.
dialing local
numbers

Main display name Enter the name displaying on the FortiVoice unit. This name is provided by your PSTN
service provider.

Main number Enter the main number of the FortiVoice unit. This number is provided by your PSTN
service provider.

Default prompt Select a new default prompt language for the FortiVoice unit. The default is English.

language This setting affects all of the FortiVoice unit’s voice prompts, such as auto attendant and

voice mail. However, if you change the sound file for an individual component, such as
auto attendant, to use a different language, it will override the default prompt language
for this component.

For information on adding prompt languages, see Managing phone audio settings on

page 119.
Default emergency  Select the default emergency contact or click + to add a new one.
Zzone For more information, see Configuring emergency zone profiles on page 145.
Default time zone Select a new default time zone for the FortiVoice unit. The default is Pacific Time.

Contact Information  Optionally, enter your contact information.

Emergency Setting  Configure to send an alert email when an emergency call is made. You can add up to 30
email addresses.
You can also add a barge number to join an ongoing emergency call.

Select Do nothing if you don’t want the FortiVoice unit to send an alert email. Otherwise,
select Send Alert Email and enter the email address.

Click Customize Email Template if you want to modify the notification email template.
For more information, see Customizing call report and notification email templates on
page 113.

Emergency barge number. Enter an authorized user’s extension number to be dialed.
When an ongoing emergency call is in progress, the phone of the authorized user also
rings. This user can listen to the call and talk, if necessary.

3. Click Apply.
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Configuring PBX options

The Phone System > Setting > Option tab lets you configure the pattern and number of digits you want the FortiVoice
unit to use for phone numbers, speed dials, and prefixes as well as the default FortiVoice system settings. These
settings apply to all extensions unless you change them when configuring the extensions. For details, see Configuring
IP extensions on page 164.

The FortiVoice unit supports the following pattern-matching syntax:

Syntax Description

X Matches any single digit from 0 to 9.
z Matches any single digit from 1 to 9.
N Matches any single digit from 2 to 9.
[15-7] Matches a single character from the range of digits specified. In this case, the

pattern matches a single 1, as well as any number in the range 5, 6, 7.
Wildcard match; matches one or more characters, no matter what they are.
! Wildcard match; matches zero or more characters, no matter what they are.

, These pattern delimiters allow you to enter multiple pattern strings at a time. For
- or example, you can enter NXXX,6XXXX;[3-5]X

Pattern-matching examples

Pattern Description

NXXX Matches any four-digit number, as long as the first digit is 2 or higher.
NXXNXOXXOXXX This pattern matches with areas with 10-digit dialing.
TNXXNXXXXXX Matches the number 1, followed by an area code between 200 and 999, then any

seven-digit number. In the North American Numbering Plan calling area, you can
use this pattern to match any long-distance number.

011. Matches any number that starts with 011 and has at least one more digit.

To configure PBX options

1. Goto Phone System > Setting > Option.
2. Configure the following:

GUI field Description

Number Management
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GUI field Description

Default Setting
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Extension number
pattern

Speed dial pattern

System prohibited
prefix

System unrestricted
prefix

Operator extension

Supporting
extension

Default SIP user
password

Default user
password

Enter the extension number pattern. For example, NXXXis any
four-digit number as long as the first digit is 2 or higher and 7XXX
is a four-digit number that always starts with 7. This pattern will be
followed when creating extensions. See Configuring IP extensions
on page 164.

Enter the speed dial number pattern. For example, *3XXis any
three-digit number that starts with 3. This pattern will be followed
when configuring speed dials. See Mapping speed dials on page
277.

Enter the phone number prefix that you want to ban, such as 900.
Click the + sign to add up to 10.

Enter the allowed phone number prefix, such as 800. Click the +
sign to add up to 10.

Enter the extension for the operator of the FortiVoice unit.

Enter the extension for technical support of the FortiVoice unit.

Enter your own password or let the FortiVoice unit generate one for
you. This password is used for configuring your SIP phone from the
phone or the Web. You need the phone's IP address to access it
from the Web. This password appears when you add an extension.
For details, see Configuring IP extensions on page 164.

Specified: Enter the password. The password cannot be
blank, must be 8 or more characters, must contain at least
one uppercase character, one lowercase character and one
number. Non-alphanumeric characters, like (- $, are not
supported in the password field.

The default password is voice#321.

Generated: Select to have a system-generated password.

Enter your own password or let the FortiVoice unit generate one for
you. This password is for user portal access. This password
appears when you add an extension. For details, see Configuring
IP extensions on page 164.

Specified: Enter the password. The password cannot be
blank, must be 8 or more characters, must contain at least
one uppercase character, one lowercase character and one
number. Non-alphanumeric characters, like (- $, are not
supported in the password field.

The default password is voice#321.

Generated: Select to have a system-generated password.
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GUI field Description

Default Voicemail Enter your own password or let the FortiVoice unit generate one for

PIN you. This password is for the extension user to access voice mail
and the user portal. This password appears when you add an
extension. For details, see Configuring IP extensions on page
164.

If you select Specified, the default password is 123123.

User ID prefix Enter the prefix for the extension user ID. When you add a new
extension, the FortiVoice unit will generate a user ID with this
prefix plus the extension number. For details, see Configuring IP
extensions on page 164.

Default ring duration  Use this option to set phone ringing time for extensions and
FortiFone softclient for mobile phones.

« Adaptive: This is recommended for extensions with mobile
softclients.
Select this option and both the extensions and mobile
softclients will ring for 40 seconds before the call is processed
(for example, the call is sent to a voice mail). This setting is to
ensure that mobile softclients will not miss any calls due to
possible network transmission delays. You do not need to
enter any ring duration value. Any ring duration value already
entered will be ignored.

o Fixed: This is recommended for extensions without mobile
softclients.
Select this option and enter the ring duration value in
seconds. The extensions will ring for the ring duration value
you entered before the call is processed (for example, the call
is sent to a voice mail). The default is 20.

Internal calls ring Select the system defined distinctive ring pattern for internal calls.
pattern
External calls ring Select the system defined distinctive ring pattern for external calls.
pattern

3. Click Apply.

Customizing call report and notification email templates

Go to Phone System > Setting > Custom Message to view and reword the default call report and notification email
templates.

The FortiVoice unit sends out call reports based on your call report configuration (see Configuring report profiles and
generating reports on page 316) and notification email when, for example, you have a new voicemail or fax in your
mailbox or missed a call. You can customize the email templates for the call report and email notifications.

You can change the content of the email template by editing the text and HTML codes and by working with email
template variables. For descriptions of the default email template variables, open a template and select Edit Variable.

To customize call report and email templates
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Go to Phone System > Setting > Custom Message.

Open Report or Email template to display the default templates.

To edit a template, double-click it or select it and click Edlit.

To format template in HTML, use HTML tags, such as <b>some bold text</b>.

There is a limit of 250 characters for the Subject field, 60 characters for the From field, and 4000 characters for
Htmibody and Textbody messages each in the Content body field.

5. Toadd a variable:
o Select Insert Variables next to the area to insert a variable. A pop-up window appears.
« Place your mouse cursor in the text message at the insertion point for the variable.
o Click the name of the variable to add. It appears at the insertion point.
o To add another variable, click the message area first, then click the variable name.
« Click the Close (X) icon to close the window.
6. Toinsert a color:

AoODdD-=

 Click Insert Color Code. A pop-up window of color selection appears.

« Place your mouse cursor in the text at the insertion point for the color code, or highlight an existing color code
to change.

o Click a color in the color selection pop-up window.
For example, to replace the color code in the HTML tag <tr bgcolor="#3366£f">, you can highlight
"#3366f£f", then select the color you want from the color palette.

To add a new color code, include it with HTML tags as applicable, such as <tr bgcolor="#3366ff">.

7. Todetermine if your HTML and color changes are correct, click Preview. The replacement message appears in
HTML format.

8. Click OK, orclick Reset To Default to revert the replacement message to its default text.

Configuring system capacity

The Phone System > Setting > Miscellaneous tab lets you set the PIN used by the administrator to override schedules,
configure voicemail greeting and message length, set phone directory options, configure CDR settings, and configure
queue logs.

To configure system capacity

1. Go to Phone System > Setting > Miscellaneous.
2. Configure the following:

GUI field Description

PBX Setting

Administrator PIN Enter the password used by the administrator to override
schedules.
This global password is also used by an administrator to connect a
FortiFone to the FortiVoice unit to set mobile extension number.
For details, see Configuring SIP phone auto-provisioning on page
96.

PBX identification Enter a unique name for the FortiVoice unit.
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GUI field Description

User portal local Select the method to access the user portal. By default, both
authenticationtype  personal password and voicemail (user) PIN can be used. Personal
password and voicemail (user) PIN are set when configuring
extensions. Usually numbers are used as voicemail PIN which are
very easy to guess and can be cracked using some HTTP
password guess tool within minutes. That is why a separate
personal password is added which can be much longer and
stronger to mitigate the risk of password guess attack and preserve
the voicemail PIN for phone access only.
For more information, see Configuring IP extensions on page 164.
o UserPassword or Voicemail PIN: Both personal password
and user PIN can be used to access the user portal.
o UserPassword Only: Use personal password to access the
user portal.

Notification expiry Enter the email notification expiry time in hours. The range is 1-

2160 hours.

QR code expiry Enter the QR code expiry time in hours. The range is 1- 2160
hours.

System block list Enable to block phone numbers on the system level.

To block a number on the system level

1. Go to Monitor > Call History > Call Detail Record (CDR).

2. Select the number you want to block from the CDR list.

3. Select More Action > Block > Block Caller/Callee as
required.

4. Go to Security > Blocked Number.
The number you selected is added to the block list.

5. Click Setting.

Enable System block list.

7. Click Apply.
Future calls from the number you selected to any extensions
on the FortiVoice unit will be blocked.

(20

Personal block list Enable to block phone numbers on a personal basis.
To block a number on a personal basis

Go to Phone System > Setting > Miscellaneous.

Enable Personal block list.

Click Apply.

Log in to the user portal.

Click Call History.

Select the number you want to block from the list.

Select More Action > Block.

Go to Contact > Personal Contact.

Click Personal Block List to verify that the blocked number is

©OeNOoOOGO RN
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GUI field Description

Match personal
contact

Business Group

Caller ID

Schedule Override

Voicemail

Directory

Dial-by-name option

FortiVoice Phone System 6.4.3 Administration Guide
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listed.
10. Log in to the FortiVoice web-based manager.

Future calls from the number you selected to your extension
will be blocked.

Enable to show the unique name added to a numberin the

personal contacts on your extension display.

To match a personal contact

Go to Phone System > Setting > Miscellaneous.

Enable Match personal contact.

Click Apply.

Log in to the User Portal.

Click Call History.

Select the number you want to match to a personal contact.

Click More Actions > Add to Contact.

Enter a unique display name and other contact information for

the number

9. Click Create.

10. Go to Contact > Personal Contact.

11.  Verify the number is listed with the unique name you entered.
When the number you selected calls, the unique display name
you entered will show on your extension screen.

ONOoOGRLON =

Select Disabled to hide business group in Extensions and select
Automatic to show it.

For more information, see Creating business groups on page 199.

Select Format incoming caller id numbers if you want the
FortiVoice unit to display the incoming caller ID in the right format.
For example, 12223334444 will be formatted to 1-222-333-4444.

Select Allow admin user to override schedule if required.

An administrator with the privilege can dial *821, *822, or *823
followed by the administrator PIN to temporarily replace the
original schedule with one of the three default ones. You may also
modify the temporary schedule. Dial *820 to go back to the original
schedule.

Enter the maximum message length, greeting length, voicemail
volume, and greeting volume you want.

Set phone directory options.

Select how a caller can check the directory by dialing a name.
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GUI field Description

Dial-by-name digits  Enter the number of letters allowed for a caller to dial someone by
name. The range is 3-9. This feature enables a caller to reach a
specific person quickly by dialing, for example, the first three
letters of their first or last name from any phone.

Read back number  Select if you want a person’s extension number to be read out after
you check the directory by dialing the person’s first or last name.

Read name Select if you want a person’s name to be read out after you check
sequence the directory by dialing the person’s first or last name.

One by one: All names matching your dialed directory checking
pattern are read out one by one.

Menu group listing: For efficiency, the FortiVoice unit breaks all
names matching your dialed directory checking pattern into groups
of 8 if applicable, and reads them out group by group.

Directory list options  Select the type of extension numbers to be included in the
directory.

Internet of Things

Amazon Alexa Select to enable configuring your FortiVoice unit’s integration with
Amazon Alexa. This is the system global control.

For more information, see Configuring Internet of things (1oT).

CDR Enter the time in month that you want to keep the call log/call
detail record and the maximum number of CDR records. For
information about call log/CDR, see Viewing call records on page
33.

Queue Log Enter the time in month that you want to keep the queue log and
the maximum number of log records. For information about queue
logs, see Viewing log messages on page 35.

3. Click Apply.

Creating contacts

The Phone System > Contact menu lets you view and set up phone directories.
You can also configure speed dial rules.
To view the phone directory

1. Go to Phone System > Contact > Directory.
All extensions on this FortiVoice unit are displayed. You can download all contacts or the search result.

To create a contact
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1. Go to Phone System > Contact > Business Contact.
2. Click New and configure the following:

GUI field Description

Display name The name displaying on the caller's phone. This is usually the name of the contact.
Main number Enter the phone number mainly used by the contact. This is compulsory.

Mobile number Enter the contact’s cellphone number.

Home number Enter the contact’s home phone number.

Description Enter any notes for the address book.

Upload/Delete Click to add or remove a picture of the business contact. This option is only available
(icons) when you edit a business contact.

By adding a picture of the business contact, when there is an incoming call from that
contact, the

caller/contact's picture/photo ID displays on the callee's phone, if the phone model
supports this feature.

3. Click Create.
To export a contact

1. Go to Phone System > Contact > Business Contact.
2. Select one or more records.

3. Click Other Actions > Export.

4. Open or save the file.

5. Click OK.

To import a contact

1. Go to Phone System > Contact > Business Contact.
2. Click Other Actions > Import.

3. Browse for the file you want.

4. Click OK.

Viewing contacts retrieved from the LDAP server

Phone System > Contact > LDAP Contact displays the contact information retrieved from the LDAP server.

If you have contact or employee information in your LDAP server, you can configure the LDAP attribute mapping
templates to retrieve the information and add it to the contact and extension lists. For details, see Configuring the LDAP
connector on page 129.

Configuring speed dials

For fast and efficient dialing, use the speed dial pattern to map the phone numbers, mostly outbound numbers.

For information on setting speed dial number pattern, see Configuring PBX options on page 111.
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To map speed dials

1. Go to Phone System > Contact > Speed Dial Rule.

Click New.

Enter a name for the speed dial mapping.

For Dialed Pattern, enter the number based on the speed dial number pattern you set. For example, 333.

For Mapped Pattemn, enter the phone number to map to the speed dial pattern.

You can enter digits 0-9, space, dash, comma, # and *.

Speed dial pattern accepts # as the lead digit ( Eg. #XX or #613XXX).

If you want to enter an auto attendant number followed by an extension, you can use comma (,) or semicolon (;) to
pause the automatic dialing.

A comma pauses dialing for two seconds, for example, 1-123-222-1234, 5678#. In this case, once pressing the

speed dial code you set, auto attendant 1-123-1234 is reached, and after two seconds, extension 5678 is
automatically dialed.

A semicolon pauses dialing for one second, for example, 1-123-222-1234; 5678#. In this case, once pressing the
speed dial code you set, auto attendant 1-123-1234 is reached, and after one second, extension 5678 is
automatically dialed.

6. Optionally, enter a note for the mapping, such as “This is for customer A”.

7. Click Create.

o~ ODd

Managing phone audio settings

The Phone System > Audio > Prompt/Music On Hold menu lets you upload, record, and play phone sound files such
as voicemail greetings and announcements. It also lets you choose the sound files to play while a call is on hold.

There are default sound files ready to use.

The sound files can be used when configuring music on hold, conference calls, and auto attendants. See To configure
music on hold on page 120 and Configuring call features on page 272.

The Phone System > Audio > Prompt Language menu lets you configure the prompt language that affects all of the
FortiVoice unit’s voice prompts, such as auto attendant and voicemail. Prompt languages are used when configuring the
PBX setting. For more information, see Setting PBX location and contact information on page 109.

However, if you change the sound file for an individual component, such as auto attendant, to use a different language,
it will override the default prompt language for this component.

The default prompt language is English.
For information on generating a prompt language file, see Recording in FortiVoice audio format on page 121.
To manage a sound file

1. Goto Phone System > Audio > Prompt.

2. Click New.
3. Enteraname and ID for the file.
4. Select afile type.
5. Optionally, enter a description for the file.
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6. For Voice language, configure the following:
If you select Prompt sound file for the profile type, you can click Upload to get an existing sound file, Record to
make a sound file, Download to save a a sound file, and Play to listen to an uploaded or recorded file (with
speakers or earphones) for the language you select.

a. Torecord a sound file, click Record.

b. Onthe Send Voice Recording Call dialog box, enter the extension that you will use to record the file, and click
Send to dial the extension. You can edit the extension or add a new one. For details, see Configuring IP
extensions on page 164.

c. When the extension rings, record the sound file and hang up.

d. On the FortiVoice web-based manager, click Yes on the Voice recording request sent to specified extension
dialog box.

If you select Music on hold for the profile type, you can click Upload to get an existing sound file, Record to make a

sound file, Download to save a sound file, and Play to listen to a uploaded or recorded file (with speakers or

earphones).

7. Click Create.
To configure music on hold

1. Go to Phone System > Audio > Music On Hold.
2. Click New.
3. Configure the following:

GUI field Description

Name Enter a name for the music on hold file.
Mode

Files If you select to use existing sound files, do the following:
« For Soundfiles, select the Available sound files and click -> to move
them into the Members field.
« For Play mode, if you want to play the selected sound files randomly,
select Random. If you want to play the files according to the orderin
the Selected field, select Sequential.

Stream If you select to use streaming files, in the Stream URL field, enter the URL
where the streaming music is, such as a radio station. This way, the music
is delivered to the FortiVoice unit and played virtually straight away. You
can click Test stream to see if the URL is added successfully.

Before doing so, make sure to only use the legal stream sources.

Volume Set the music sound volume.

Description Optionally, enter a description for the file.

4. Click Create.
To add a prompt language

1. Go to Phone System > Audio > Prompt Language.
2. Click New.
3. Click Upload to browse and upload the language file in FortiVoice language package format (*.fvl) provided by
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Fortinet Technical Support.
4. Click Create.

Recording in FortiVoice audio format

A prompt language file must be recorded in the FortiVoice language package format. This can be accomplished by
using the free and robust audio program called Audacity and a microphone.

Once this program has been installed, and the microphone connected, then the file can be recorded.

Audacity cannot natively record in the format that FortiVoice unit requires. Therefore, some adjustments need to be

made in the software as described in the following procedure.

To generate a prompt language file

1. On Audacity, go to Edit > Preferences.

2. Click the Devices menu.

3. In Channels, select 1(Mono).

Preferences: Devices

i
- Playback

- Recording

- MIDI Devices
- Quality

- Interface

- Tracks

Tracks Behaviors
L. Spectrograms

- lmport / Bxport

... Extended Import

- Librraries

- Directories
- Warnings
- Effects

- Keyboard
- Mouse

- Modules

Interface
Host: | MME w

Using: PertAudio V19.5.0-devel, revisicn unknown

Playback
Device: | Speakers / Headphones (Realtek ~

Recording

Device: Mo devices found w
R

Qﬁhannels: 1 (Meone)

R
—

Buffer length: milliseconds
Latency compensation: milliseconds

Latency

oK

Cancel

i\

4. Click the Quality menu.
5. In Default Sample Rate, select 8000 Hz.
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6. In Default Sample Format, select 16 bit.

Preferences: Quality

- Devices S T m—— e —
F'Ia}rl::lar?k r | Default Sample Rate: | 8000 Hz ~ | | 44100
- Recording {

- MO Devices L ] Default Sample Format: | 16-bit

—

o — Real-time Conversion
.. Interface

- Tracks Sample Rate Converter: | Medium Cuality

=

Tracks Behaviors | | puper. MNone
i.. Spectrograms
= |rr1F||:|r‘t K ExFIDI't
- Extended Import | | 3pnp1e Rate Converter: | Best Quality (Slowest)
- Librraries

High-quality Conversicn

- Directories Dither: Shaped

- Warnings
- Effects
- Keyboard
- Mouse
- Modules

OK

Cancel

=

7. Click OK.
8. When you are ready, record your prompt language message.
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9. Save the file in a format that works with the FortiVoice unit.
a. Goto File > Export > Export Audio.

= Export Audio

Savein:| Audacity v| (< s A

A FortiVoicel.au
Cuick access

Desktop

Libraries

i Mame # Title Contributing art

File name: || e |

q_'::S'_a'ue as type: Other uncompressed files v

Format Options

Header: Al (Sun/MeXT) W

-f_::---iincu:uding: U-Law w 2

In Save in, select the directory where you want to save the file.

c.
file name according to the format that you select in Save as type.
d. In Save as type, select Other uncompressed files.
e. In Encoding, select U-Law.
f. Click Save.
g. If the Edit Metadata tags dialog appears, you can add tags and click OK.

The recording is now in a format that you can load onto the FortiVoice unit.
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Configuring LDAP settings

Phone System > LDAP lets you configure LDAP profiles and connectors.
This topic includes:

o Configuring LDAP settings on page 124
« Configuring the LDAP connector on page 129
« Viewing LDAP contact list on page 131

Configuring LDAP profiles

The LDAP Profile submenu lets you configure LDAP profiles which can query LDAP servers for authentication.

N ! /, Before using an LDAP profile, verify each LDAP query and connectivity with your LDAP server.
9 When LDAP queries do not match with the server's schema and/or contents, unintended
3 phone call processing behaviors can result.

LDAP profiles each contains one or more queries that retrieve specific configuration data, such as user groups, from an
LDAP server. The LDAP profile list indicates which queries you have enabled in each LDAP profile.

To view the list of LDAP profiles, go to Phone System > LDAP > LDAP Profile.

GUI field Description

Profile Name The name of the profile.

Server The domain name or |P address of the LDAP server.

Port The listening port of the LDAP server.

Auth Indicates whether User Authentication Options is enabled.

Cache Indicates whether query result caching is enabled.

(Green dot in column heading) Indicates whether the entry is currently referred to by another item in the

configuration. If another item is using this entry, a red dot appears in this column,
and the entry cannot be deleted.

You can add an LDAP profile to define a set of queries that the FortiVoice unit can use with an LDAP server. You might
create more than one LDAP profile if, for example, you have more than one LDAP server, or you want to configure
multiple, separate query sets for the same LDAP server.

After you have created an LDAP profile, LDAP profile options will appear in other areas of the FortiVoice unit’'s
configuration. These options let you to select the LDAP profile where you might otherwise create a reference to a
configuration item stored locally on the FortiVoice unit itself. These other configuration areas will only allow you to
select applicable LDAP profiles — that is, those LDAP profiles in which you have enabled the query required by that
feature. For example, if a feature requires a definition of user groups, you can select only from those LDAP profiles
where Group Query Options are enabled.

To configure an LDAP profile
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1. Goto Phone System > LDAP > LDAP Profile.
2. Click New to add a profile or double-click a profile to modify it.

GUI field Description

Profile name For a new profile, enter its name.
Server name/IP Enter the fully qualified domain name (FQDN) or IP address of the LDAP
server.

Port: Enter the port number where the LDAP server listens.

The default port number varies by your selection in Use secure connection:
port 389 is typically used for non-secure connections, and port 636 is typically
used for SSL-secured (LDAPS) connections.

Fallback server name/IP Optional. Enter the fully qualified domain name (FQDN) or IP address of an
alternate LDAP server that the FortiVoice unit can query if the primary LDAP
server is unreachable.

Port: Enter the port number where the fallback LDAP server listens.

The default port number varies by your selection in Use secure connection:
port 389 is typically used for non-secure connections, and port 636 is typically
used for SSL-secured (LDAPS) connections.

Use secure connection Select whether to connect to the LDAP servers using an encrypted connection.
« none: Use a non-secure connection.
o SSL: Use an SSL-secured (LDAPS) connection.
Click Test LDAP Query to test the connection. A pop-up window appears. For
details, see Testing LDAP profile queries on page 128.

Base DN Enter the distinguished name (DN) of the part of the LDAP directory tree within
which the FortiVoice unit will search for user objects, such as
ou=People,dc=example, dc=com.

User objects should be child nodes of this location.

Bind DN Enter the bind DN, such as cn=FortiVoiceA, dc=example, dc=com, of
an LDAP user account with permissions to query the Base DN.
This field may be optional if your LDAP server does not require the FortiVoice
unit to authenticate when performing queries.

Bind password Enter the password of the Bind DN.
Click Browse to locate the LDAP directory from the location that you specified
in Base DN, or, if you have not yet entered a Base DN, beginning from the
root of the LDAP directory tree.
Browsing the LDAP tree can be useful if you need to locate your Base DN, or
need to look up attribute names. For example, if the Base DN is unknown,
browsing can help you to locate it.

Before using, first configure Server name/IP, Use secure connection,

Bind DN, Bind password, and Protocol version, then click Create or OK.

These fields provide minimum information required to establish the directory
3. browsing connection.
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4. Configure the following sections:

« Configuring authentication options on page 126
« Configuring advanced options on page 127

5. Click Create, OK or Apply.

The LDAP profile appears in the LDAP profile list. To apply it, select the profile in features that support LDAP
queries, such as protected domains and policies.

Before using the LDAP profile in other areas of the configuration, verify the configuration of each query that you
have enabled in the LDAP profile. Incorrect query configuration can result in unexpected phone processing
behavior. For information on testing queries, see Testing LDAP profile queries on page 128.

Configuring authentication options

The following procedure is part of the LDAP profile configuration process. For general procedures about how to
configure an LDAP profile, see Configuring LDAP settings on page 124.

1. Go to Phone System > LDAP > LDAP Profile.

2. Click New to create a new profile or double click on an existing profile to edit it.
3. Click the arrow to expand the User Authentication Options section.
4

Configure the following:

GUI field Description

Select to form the user’s bind DN by prepending a common name to the base
DN. Also enter the name of the user objects’ common name attribute, such as
cnoruid into the field.

Try Common Name with Base
DN as Bind DN

Search User and Try Bind DN

Select to form the user’s bind DN by using the DN retrieved for that user by
configuring the following:

LDAP user query: Enter an LDAP query filter that selects a set of user
objects from the LDAP directory.

The query string filters the result set, and should be based upon any
attributes that are common to all user objects but also exclude non-user
objects.

For example, if user objects in your directory have two distinguishing
characteristics, their objectClass and extension attributes, the
query filter might be:

(& (objectClass=inetOrgPerson)
(telephonenumber=Su))

where $u is the FortiVoice variable for a user's extension.

This option is preconfigured and read-only if you have selected from
Schema any schema style other than User Defined.

Schema: If your LDAP directory’s user objects use a common schema
style:

« Active Directory
« Lotus Domino
« Open LDAP
Select the schema style. This automatically configures the query string to
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GUI field Description

match that schema style.

If your LDAP server uses any other schema style, select User Defined,
then manually configure the query string.

o Scope: Select which level of depth to query, starting from Base DN.

« One level: Query only the one level directly below the Base DN in
the LDAP directory tree.

« Subtree: Query recursively all levels below the Base DN in the
LDAP directory tree.
« Derefer. Select the method to use, if any, when dereferencing attributes
whose values are references.

« Never. Do not dereference.

« Always: Always dereference.

« Search: Dereference only when searching.

« Find: Dereference only when finding the base search object.

Configuring advanced options

The following procedure is part of the LDAP profile configuration process. For general procedures about how to
configure an LDAP profile, see Configuring LDAP settings on page 124.

1. Goto Phone System > LDAP> LDAP Profile.

2. Click New to create a new profile or double click on an existing profile to edit it.
3. Click the arrow to expand the Advanced Options section.

4. Configure the following:

GUI field Description

Timeout (seconds) Enter the maximum amount of time in seconds that the FortiVoice unit will
wait for query responses from the LDAP server.

Protocol version Select the LDAP protocol version used by the LDAP server.

Enable cache Enable to cache LDAP query results.
Caching LDAP queries can introduce a delay between when you update LDAP
directory information and when the FortiVoice unit begins using that new
information, but also has the benefit of reducing the amount of LDAP network
traffic associated with frequent queries for information that does not change
frequently.
If this option is enabled but queries are not being cached, inspect the value of
TTL. Entering a TTL value of 0 effectively disables caching.

TTL (minutes) Enter the amount of time, in minutes, that the FortiVoice unit will cache query
results. After the TTL has elapsed, cached results expire, and any subsequent
request for that information causes the FortiVoice unit to query the LDAP
server, refreshing the cache.
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GUI field Description

The default TTL value is 1440 minutes (one day). The maximum value is
10080 minutes (one week). Entering a value of 0 effectively disables caching.

This option is applicable only if Enable cache is enabled.

Testing LDAP profile queries

After you have created an LDAP profile, you should test each enabled query in the LDAP profile to verify that the
FortiVoice unit can connect to the LDAP server, that the LDAP directory contains the required attributes and values, and
that the query configuration is correct.

When testing a query in an LDAP profile, you may encounter error messages that indicate failure of the query and how
to fix the problem.

To verify user authentication options

1. Goto Phone System > LDAP > LDAP Profile.
2. Double-click the LDAP profile whose query you want to test.

3. Click Test LDAP Query.
A pop-up window appears allowing you to test the query.

4. From Select query type, select Authentication.

5. In Username, enter the user name or extension of a user on the LDAP server, such as jdoe or 1234, depending
your selection of User Authentication Options.

6. In Password, enter the current password for that user.
7. Click Test.

The FortiVoice unit performs the query, and displays either success or failure for each operation in the query, such
as the search to locate the user record, or binding to authenticate the user.

Clearing the LDAP profile cache

You can clear the FortiVoice unit’s cache of query results for any LDAP profile.

This may be useful after, for example, you have updated parts of your LDAP directory that are used by that LDAP
profile, and you want the FortiVoice unit to discard outdated cached query results and reflect changes to the LDAP
directory. After the cache is emptied, any subsequent request for information from that LDAP profile causes the
FortiVoice unit to query the updated LDAP server, refreshing the cache.

To clear the LDAP query cache

1. Goto Phone System > LDAP > LDAP Profile.
2. Double-click the LDAP profile whose query cache you want to clear.
3. Click Test LDAP Query.
4. From Select query type, select Clear Cache.
A warning appears at the bottom of the window, notifying you that the cache for this LDAP profile will be cleared if

you proceed. All queries will therefore be new again, resulting in decreased performance until the query results are
again cached.

5. Click Ok.
The FortiVoice unit empties cached LDAP query responses associated with that LDAP profile.
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Configuring the LDAP connector

If you have contact or employee information in your LDAP server, you can configure the LDAP attribute mapping
templates to retrieve the information and add it to the contact and extension lists. Before doing so, you must
configure your LDAP server. For details, see Configuring LDAP settings on page 124.

To view the list of LDAP connectors, go to Phone System > LDAP > LDAP Connector.

GUI field Description

Clone

Actions

Extension

Name

LDAP Profile

Type

Schedule

Last Sync Time

Click to duplicate an LDAP connector configuration.

Sync-Incremental : Select an LDAP connector and click this button to let
the FortiVoice unit only synchronize the new and changed information on
the LDAP server. This is recommended because it takes less network
resources and is more efficient.

Sync-Full: Select an LDAP connector and click this button to let the
FortiVoice unit fully synchronize the new and changed information on the
LDAP server. This is recommended only if it is necessary to do so,
because it takes lots of network resources.

Sync Report: Select an LDAP connector and click this button to display
the synchronization report between the FortiVoice unit and your LDAP
server.

Purge sync data: Select an LDAP connector and click this button to
remove the data retrieved from the LDAP server.

Click to display the extensions generated based on the data retrieved from
your LDAP server.

Note that contacts generated based on the data retrieved from your LDAP
server appears in Phone System > LDAP > LDAP Contact. See Viewing
LDAP contact list on page 131.

Name of the LDAP connector.

The name of the LDAP profile that has your LDAP server information. For
details, see Configuring LDAP settings on page 124.

The type of the LDAP connector: extension or contact.

The synchronization schedule between the FortiVoice unit and your LDAP
server.

The latest synchronization time between the FortiVoice unit and your LDAP
server.

To configure extension/contact connectors
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1. Goto Phone System > LDAP > LDAP Connector.
2. Click New > Extension Connector/Contact Connector and configure the following:

GUI field Description

Name Enter a name for the extension/contact connector.
Status Select to enable the connector.
LDAP profile Select the LDAP profile that has your LDAP server information. You can add a new profile

or modify the selected one. For details, see Configuring LDAP settings on page 124.

The FortiVoice unit queries the LDAP server based on the information contained in the
LDAP profile.

Schema Select the LDAP schema that defines the rules to govern the kinds of data that the LDAP
server can hold.

This option appears after you select the LDAP profile.

Description Click to enter any notes you have for this connector.

Search criteria Enter the search attributes for the data you want the FortiVoice unit to retrieve from the
LDAP server.
Search base Enter or browse for the search base to define the search starting

point in the LDAP directory tree.

Search filter Enter the complete query filters.

Scope Select the LDAP search scope indicating the set of entries at or
below the BaseDN that may be considered potential matches for a
SearchRequest.

Max results Enter the search size limit for the returning records.

Mapping and More Enter the contact attributes used in the LDAP server that match the FortiVoice attributes
for extensions or contact lists. For example, Name may be used to represent first name
and Surname may be used for last name.

You may click the Host attribute's name icon beside each field to choose an LDAP server
attribute.

The mapping enables the FortiVoice unit to convert the data retrieved from the LDAP
server into FortiVoice extension or contact lists.

Schedule Set the time schedule for data retrieving and mapping.

3. Click Create.
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Viewing LDAP contact list

After you have configured the LDAP contact connector and synchronized the FortiVoice unit with it, the generated
FortiVoice contact list appears in Phone System > LDAP > LDAP Contact.

You can select a contact to view, modify, or delete it.
Clicking LDAP opens the LDAP Connector page.

For details about configuring contact connectors, see Configuring the LDAP connector on page 129.

Working with FortiVoice profiles

The Phone System > Profile tab lets you create user privileges and SIP profiles for configuring extensions and SIP
trunks. It also allows you to modify caller IDs, schedule the FortiVoice unit, and configure phone profiles.

This topic includes:

« Configuring SIP profiles on page 131

o Modifying caller IDs on page 132

« Configuring phone profiles on page 134

« Configuring programmable keys profiles on page 137

« Configuring RADIUS authentication profiles on page 139
« Configuring user privileges on page 140

o Configuring emergency zone profiles on page 145

« Scheduling the FortiVoice unit on page 146

Configuring SIP profiles

Configure the common SIP settings that can be applied to every SIP trunk and SIP device in your network.

NP Communicate with your VolP service provider because the profile settings are subject to the
‘?' capabilities of the VolP service provider. For example, if some of your features and codecs are
- not supported by your VolP service provider, they will not work even if they are enabled or

selected in the SIP profile.

The default SIP profiles can be edited but cannot be deleted.

For information on extensions, see Configuring extensions on page 164.
For information on SIP trunks, see Configuring trunks on page 204.

To configure a SIP profile

1. Go to Phone System > Profile > SIP and click New.
2. Select the SIP profile type.
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3. Configure the following:

GUI field Description

Name Enter a name for this profile.

DTMF Select the dual-tone multi-frequency (DTMF) method used by the VolP
provider. Options are RFC2833, Inband, and Info.

Keep alive Enter the time interval in seconds for the FortiVoice unit to talk to the SIP
server of your service provider to keep the connectivity and check its capability.
0 means no checking by the FortiVoice unit.

NAT Select if the VolP service provider supports SIP NAT translation.

T.38 Select if the VolIP service provider supports fax over VolP network. This option
is not available for every profile type.

Transport Transport: SIP commonly uses TCP or UDP port 5060 and/or 5061. Port 5060

is used for non-encrypted SIP signaling sessions and port 5061 is typically
used for SIP sessions encrypted with Transport Layer Security (TLS).

Enable the protocols as required.

This option, if applied to a user, overrides the system-wide transport Setting.
For more information, see Configuring SIP settings on page 92.

Secure RTP: Select to provide encryption, message authentication and
integrity, and replay protection to the FortiVoice Real-time Transport Protocol
data. This option is not available for every profile type.

Codec Select the codecs supported by the VolP service provider. Among the selected
ones, choose the preferred one for the VolP provider. The preferred codec is
usually the most used one in your area and provides the best quality of
communication.

If your preferred codec is different from that of your VolP service provider, the
service provider’'s codec will be used as long as it is one of your supported
codecs.

4. Click Create.

Modifying caller IDs

You can change the phone number, caller's name, or both that will appear on the destination phone.

Caller ID modifications are used when configuring dial plans. For more information, see Configuring call routing on page
224.

To modify a caller ID

1. Go to Phone System > Profile > Caller ID Modification.
2. Click New and configure the following:

GUI field Description

Name Enter the name for this caller ID modification record.
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GUI field Description

Match number Enter the extension number or number pattern you want to modify.

For example, you can enter 8134 to modify a single extension, or 81xx to
modify all the four-digit numbers starting with 81.

Number Modification If you have entered a number or number pattern in Match number field,
configure the following values to modify it:
o Strip: Enter a number to hide the starting part of an extension from
displaying. 0 means no action.
For example, if your Match numberis 8134 and Strip is 2, only 34 will be
displayed as caller ID.
« Truncate: Enter a number to hide the ending part of an extension from
displaying. 0 means no action.
For example, if your Match numberis 8134 and Truncate is 2, only 81 will
be displayed as caller ID.
« Prefix: Add a number before an extension.
For example, if your Match numberis 8134 and Prefix is 5, the caller ID
will be 58134.
o Postfix: Add a number after an extension.

For example, if your Match numberis 8134 and Postfix is 5, the caller ID
will be 81345.

Match option Select the way to match a call with caller name and number in order to modify
call number or caller ID.

o Match Number or Name: If the number is matched, modifications will be
done based on Number Modification configuration. If the name is
matched, modifications will be done based on Map to new caller ID name
configuration.

« Match Number then Name: If the number is matched, modifications will
be done based on Number Modification configuration. If both the number
and name are matched, modifications will be done based on Map to new
caller ID name configuration.

o Match Name then Number. If the Name is matched, modification will be
done based on Map to new caller ID name configuration. If both the
name and number are matched, modifications will be done based on
Number Modification configuration.

« Match Number and Name: If both the number and name are matched,
modifications will be done based on Number Modification and Map to
new caller ID name configurations.

Match caller ID name Enter the caller ID that you want to map to another one.

Caller IDs are created when configuring SIP extensions. See Configuring IP
extensions on page 164.

Map to new caller ID name Enter the new caller ID name that you want to map to the one entered in the
Match caller ID name field.

Block caller ID Select to stop your caller ID from displaying on the destination phone.

3. Click Create.
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Mapping a group of extensions to a caller ID name

If you want to map a group of extensions to a caller ID name, you can use the pattern for the extensions to do so.

For example, if you have a technical support team that has 10 extensions (8100-8110), instead of displaying each
extension when making calls, you can just display one caller ID name “Support” for the whole team.

To map a group of extensions to a caller ID name

Go to Phone System > Profile > Caller ID Modification.

Click New.

In the Match number field, enter the pattern of the extensions, such as 81xx.

In the Match option field, select Match Number or Name.

In the Map to new caller ID name field, enter the caller ID name to which you want to map, such as “Support”.
Click Create.

o0k~ ODdD-=

Configuring phone profiles

Phone profiles contain the phone configurations that are mostly used and customized, such as the programmable
phone keys. Phone profiles make extension configuration more flexible because phone users are allowed to choose the
profile they want. In addition, any changes the administrator makes to a profile is automatically applied to the
extensions that use the profile. For more information, see Configuring IP extensions on page 164.

The phone profiles configured here appear as Admin defined profiles when you configure an SIP extension.
To configure a phone profile

1. Go to Phone System > Profile > Phone.
2. Click New and configure the following:

Name Enter a name for the profile.
Phone model Select a phone model for the profile.
Time format Select the time display format on the phone.

North American: mm/dd/yyyy
International: dd/mm/yyyy

Phone book Select Local only to include the phone directory on this FortiVoice
unit, and Global to include the phone directories of any remote
FortiVoice units connected to this unit.

For information on phone directories, see The Fax Queue tab lists
the faxes waiting to be sent or having failed to be sent on the
FortiVoice unit. You can download the faxes. For more information
about fax, see Configuring fax on page 295. on page 39.

Phone language Select the language display on the phone.
Description Enter any notes you have for this profile.
FortiVoice Phone System 6.4.3 Administration Guide 134

Fortinet Technologies Inc.



Configuring phone system

GUI field Description

You may need to deploy phones using the existing IT infrastructure

VLAN

which only has one network drop for each employee. The network
switch supports 802.1Q VLAN tagging and LLDP-MED. Some
phones such as FortiFones have two network ports: LAN and PC.
The recommended solution is to connect FortiFones to the switch
using LAN port and connect the computer to the PC port of
FortiFones. VLAN tag needs to be enabled to segregate FortiFone
voice network and PC data network.

Option

If you select Manual, configure the following:

Enable VLAN tagging for voice: Select to enable VLAN tagging to
segregate FortiFone voice network and PC data network.

Voice VLAN ID: Enter your organization’s VLAN ID for voice.
Priority for voice: Enter the traffic service level recommended by
the IEEE. Each number represents a traffic type. The range is from
0-7, with 7 being the highest.

7:

0
1

2
3:
4
5
6

: Background

: Best Effort

: Excellent Effort

Critical Applications

: Video, <100 ms latency and jitter
: Voice, < 10 ms latency and jitter

: Internetwork Control

Network Control

Enable VLAN tagging for data: Select to enable VLAN tagging to
segregate PC data network and FortiFone voice network.

Voice VLAN ID: Enter your organization’s VLAN ID for data.
Priority for data: Enter the traffic service level recommended by
the IEEE. Each number represents a traffic type. The range is from
0-7, with 7 being the highest.

7

0
1

2
3:
4
5
6

: Background

: Best Effort

: Excellent Effort

Critical Applications

: Video, <100 ms latency and jitter
: Voice, <10 ms latency and jitter

: Internetwork Control

Network Control

If you select LLDP (Link Layer Discovery Protocol), the FortiVoice
unit automatically generates the configuration file. You need to
enable LLDP support on your network switch.

Automatic Configuration

Display option

Select what to display on the extension: the extension user's name

only or name and number.
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GUI field Description

Enter the digit map timeout in seconds which defines the waiting
time between the completion of dialing number entering and

FortiVoice Phone System 6.4.3 Administration Guide
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Digit map pause
timer

Intercom barge

Screensaver timer

Button transparency

Backlight time
Hangup delay

Use pound(#) as dial
or send key

Popup missed call

Keep alive

External keep alive

DST type

initiating the call.

For example, if you enter 5 and use the default digit map syntax,
the phone will initiate a call 5 seconds after you finish entering the

dialing number.

If you select FortiFone-175, 375, or 475 for Phone model, you can
enable intercom barge to allow intercom drop-in in a phone

conversation.

Select the screen saver time for the phone model you selected.
This option varies for different phone models and is not available

for all phone models.

Select the percentage of phone buttons’ background color

transparency.

This option does not apply to all models.

Set the phone backlight time to illuminate the screen in low light

conditions.

Set the delay time to disconnect calls after hanging up.
This option does not apply to all models.

Enable if required.

This option does not apply to all models.

Enable if required.

This option does not apply to all models.

Enter a value for FortiFone to send a packet to the FortiVoice unit
at the interval of the entered keep alive value to keep the firewall
ports open at all time. This is to ensure that calls are not missed
due to the registration time change for external IP extensions.
For example, if you enter 40, FortiFone will send a 2 byte packet
every 40 seconds to keep the firewall ports open.

This option does not apply to all models.

This option is available when you select FortiFone-X80 for Phone

model.

For external FortiFone-X80 extensions, the default keep alive
option is 40 seconds. This is to ensure that calls are not missed
due to the registration time change for external IP extensions.

Set the Daylight Saving Time for the phone. This option does not

apply to all models.

o Disabled: DST on the phone is disabled.
« Automatic: DST on the phone is automatically set based on

your location.
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GUI field Description

Hotel If you select FortiFone-H35 for Phone model, enter the hotel contact information and
instructions on how to dial rooms, local, long distance, and international number.

You may also select the font color for the call display.

Soft Button In Idle Optionally, enable the 4 soft buttons and make them functional in idle status.
Status This option does not apply to all models.

Phone Password Enter a password for the phone users to access their phone web GUIs and configure the
advanced settings on the phones. This only applies to the supported phones.

3. Click Create.

Configuring programmable keys profiles

The Programmable Keys submenu lets you configure the programmable keys for FortiFone phones. For FortiFone
phones with expansion modules or multiple key pages, you can select the module or page to program the keys.

After a programmable keys profile is applied to an extension, the keypad programming is always the same regardless of
the phone for the extension.

To configure a programmable keys profile

1. Go to Phone System > Profile > Programmable Keys.

2. Click New.

3. Enter the profile name, select a phone type, enter any notes you have for the profile, and click Create.
4. Double-click the profile you created and configure the following:

GUI field Description

Provisioning lines Select the phone lines you want to reserve. For example, if you
select 2 for this phone, number 1 and 2 on the keypad become
reserved for phone lines.

Number of expanded modules Select the number of expanded modules for the keypad.

This option only appears for certain FortiFone models.

Number of pages to be used on this phone  Select the number of pages for the keypad.
This option only appears for certain FortiFone models.

Base/Page/Expanded Module Fields display depending on the phone model.
Option The keypad number of the phone.
Mode Select Userto allow users to configure the programmable keys on

the user portal.
Select Admin to configure the programmable keys here.
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GUI field Description

For some functions, you need to enter the information in this field

Function Select the function assigned to this key.

Resource
based on your phone configuration. For example, if you select
function Line appearance for key 3, select what the line is forin
this field.

Label

5. Click OK.

Programmable keys descriptions

Function Description
Call forward Allows you to enable or disable and configure the Call
Forward feature.
DTMF When you are on a call and you press the DTMF key, the
system dials the configured DTMF digits.
This key is useful when you need to enter consistent
codes at an interactive voice response (IVR) system.
ﬁ‘ : '!‘
The DTMF function is only available during
acall.
-
Extension Allows you to quickly monitor the selected extension.
appearance
Intercom Allows you to use the phone speaker of a local extension

as an intercom.

'h‘ ! '!‘
This function works for internal extensions
only.

—

Line appearance Allows you to monitor the status of a line (available,

busy, or on hold).
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Resource

Stays blank.

Enter the
DTMF

digits to dial
when you press
this
programmable
key on your
phone.

Select an
extension from
the list.

Stays blank.

Select a line.

For some functions, you can add a explanatory label for the key.

Label

Edit the label
or keep the
default label
(Call forward).

Edit the label
or keep the
default label
(DTMF).

Edit the label
or keep the one
associated with
the selected
extension.

Edit the label
or keep the
default label
(Intercom).

Edit the label
or keep the one
associated with
the selected
line (or trunk).
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Function Description

Park Places the call into the first available call park slot. You
will hear a prompt telling you which slot the call has been
parked in.

Park appearance Monitors the selected call park slots, informing you if

there is a call parked.

Reserved for line By default, the FortiVoice phone system reserves the first
two programmable keys for lines on the phone so you

can monitor your own calls on those lines.

If your phone has additional lines, then you can use the
Reserved for line function to program the appearance of
those lines.

System speed dial Allows you to quickly place a call to the selected

extension or phone number at a touch of a button.

Twinning Allows an external phone to ring along with your office
phone, so you can answer the call at either phone.
Pressing the Twinning programmable key enables or

disables the feature.

Before using this function, make sure that a profile (with
twinning enabled) is applied to the extension.

User speed dial Allows you to quickly place a call to the selected

extension or phone number at a touch of a button.

Configuring RADIUS authentication profiles

Resource

Stays blank.

Select the park
slot to monitor.

If multiple
accounts have
been
configured on
this extension,
choose which
account to
monitor.

Make a
selection.

Stays blank.

Select a
contact from
your speed dial
list.

Label

Edit the label
or keep the
default label
(Auto park).

Edit the label
or keep the one
associated with
the selected
line (or slot).

Edit the label
or keep the one
associated with
the selected
line (or
account).

Edit the label
or keep the one
assigned by
the FortiVoice
system
administrator.

Edit the label
or keep the
default label
(Twinning).

Edit the label
or keep the one
associated with
the selected
contact.

The FortiVoice unit supports RADIUS authentication method by using the RADIUS profiles that you configure.

To configure a RADIUS profile

1. Go to Phone System > Profile > RADIUS.
2. Click New.
3. Configure the following:

FortiVoice Phone System 6.4.3 Administration Guide
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GUI field Description
Profile name Enter a name for this profile.
Server name/IP Enter the fully qualified domain name (FQDN) or IP address of a server that will

use RADIUS method to authenticate users.

Server port Enter the port number on which the authentication server listens. You must
change this value if the server is configured to listen on a different port number,
including if the server requires use of SSL.

The default port is 1812.

Protocol Select the authentication scheme for the RADIUS server.

Server secret Enter the secret required by the RADIUS server. It must be identical to the
secret that is configured on the RADIUS server.

Server requires domain Enable if the authentication server requires that users authenticate using their
full email address (such as user1@example.com) and not just the user name
(such as user1).

4. Click Create.

Configuring user privileges

A user privilege includes a collection of phone services and restrictions that can be applied to each extension user.
The default user privilege configurations can be edited but cannot be deleted.

For information on extensions, see Configuring extensions on page 164.

To configure a user privilege

1. Go to Phone System > Profile > User Privilege.
2. Click New.
3. Configure the following:

GUI field Description

Name Enter a name for this profile.
Basic Setting

Auto provisioning Select to enable auto-provisioning for the extension. For more
information, see Configuring SIP phone auto-provisioning on
page 96.
Once a FortiFone or supported DHCP-enabled phone connects
to the FortiVoice unit and is auto-discovered, the FortiVoice
unit assigns an IP address to the FortiFone and sends the
basic PBX setup information to it. The full PBX configuration
file will only be sent to the phone if this option is selected in the
user privilege applied to the extension associated with the
phone.

FortiVoice Phone System 6.4.3 Administration Guide 140
Fortinet Technologies Inc.



Configuring phone system

GUI field Description

List in directory Select to put the user’'s name in the dial-by-name directory
which allows a caller to find a user’s extension number, and
connect to their local extension or remote extension. This way
the caller can reach their party without speaking to the
receptionist.

Configure programmable Select to enable configuring the feature access codes. For
phone feature key/PFK more information, see Modifying feature access codes on page

304.

Softclient API login Select to enable FortiVoice softclient to log into the FortiVoice
unit.

Lookup directory Select to enable a user to view the phone directory of the local

office. For more information, see The Fax Queue tab lists the
faxes waiting to be sent or having failed to be sent on the
FortiVoice unit. You can download the faxes. For more
information about fax, see Configuring fax on page 295. on

page 39.
Lookup directory in Select to enable a user to view the phone directories of remote
remote office(s) offices. For more information, see The Fax Queue tab lists the

faxes waiting to be sent or having failed to be sent on the
FortiVoice unit. You can download the faxes. For more
information about fax, see Configuring fax on page 295. on
page 39.

Twinning Select to enable twinning function on an extension.

The twinning feature allows you to use an external telephone
(often a smartphone or home phone) to replicate your internal
office extension (often your desk phone), so that when your
desk phone rings, so does the “twin” phone. Once you return to
your desk, you may press the Twinning key on the phone to
terminate the twinning.

This is useful when you are away from your desk but still want
to receive calls to your desk phone.

With this feature selected, you can configure twinning. For
more information, see Setting extension user preferences on
page 186.

Operator Role Select to enable an extension user to process phone calls using
the FortiVoice user portal.
You can select the four options to handle calls in each
category.
When the user privilege with this option selected is applied to
an extension, an OperatorConsole button will appear on the
top of the extension user’s FortiVoice FortiVoice user portal.
Clicking the button lets the user process phone calls on the
Web.
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GUI field Description

Voicemail
Maximum messages
Voicemail retention days
Music
Music on hold
Early media
Fax

Max incoming messages

Max incoming fax
retention days

Max outgoing messages
Max outgoing fax
retention days

Call Restriction

Other Restricted Area
Code

FortiVoice Phone System 6.4.3 Administration Guide
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Select to enable the voicemail service.

Enter the number of voicemails allowed.

Enter the number of days to keep the voicemails.

Select a music on hold file. For details, see Managing phone
audio settings on page 119.

Early media is the exchange of information between the PBXes
before the establishment of a phone connection, such as the
ring tone. You can select a music file for early media. For
details, see Managing phone audio settings on page 119.

Select to set the fax rules for users. For information on fax, see
Configuring fax on page 295.

Enter the number of incoming faxes allowed.

Enter the number of days to keep the incoming faxes.

Enter the number of outgoing faxes allowed.

Enter the number of days to keep the outgoing faxes.

Select call dialing restrictions for international, long distance,
local, and internal calls.

Forbidden: Call is not allowed.

Allowed: Call is allowed.

Allowed with Account Code: Call is allowed by entering
the system account/exempt code. For information on
account code, see Configuring account codes on page
162.

Not applicable to internal calls.

Allowed with Personal Code: Call is allowed by entering
an extension’s account/exempt code. For more
information, see Configuring account codes on page 162.
Not applicable to internal calls.

Allowed with Account and Personal Code: Call is allowed
by entering the system and extension account/exempt
codes.

Not applicable to internal calls.

You can specify area codes to which an extension is allowed or
denied to make phone calls.

1.
2.

Click New.
Enter a name for this call restriction.
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GUI field Description

Monitor/Recording

Hot-desking

FortiVoice Phone System 6.4.3 Administration Guide
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Miscellaneous

Personal recording

System recording

Allow being barged

Allow barging

Call barge option

3.
4.
5.

Select Enabled to activate this restriction.

Enter the area code that you want to set restriction.
Select the permission for the area code. For more
information, see Call Restriction on page 142.
Click Create.

The max number of concurrent calls: Set the maximum
number of concurrent incoming and outgoing calls on the
extension. The range is 1-10. The default is 4.

Configure monitoring and recording outgoing and incoming
calls of an extension to which this user privilege is applied.

Select to allow users to configure personal recording of their
incoming and outgoing calls on the user web interface.

Select to allow users to configure system recording of their
incoming and outgoing calls on the user web interface.

Select to allow monitoring an extension to which this user
privilege is applied.

Select to allow the extension to which this user privilege is
applied to monitor other extensions.

To barge a call, you need to enter your user PIN. For
information on user PIN, see Configuring IP extensions on
page 164.

If you select Allow barging, choose a barging method.

To perform call barging, you need to enter your voicemail PIN.

Hot desking enables users to log into another phone. However,
unlike using Follow Me or Call Forwarding which simply
redirect a user's calls to another user’s phone, hot desking
takes total control of another phone by applying all of the user's
own phone Setting to that phone until the user logs out. Each
user can log into another phone by pressing *11 and enter his
extension number and user PIN following the prompts. To log
out, a user can press *12.

You can view hot desking configurations by going to Viewing
activity details of hot desking extensions on page 31.

Enable hot-desking login: Select to enable the hot-
desking login function.

Automatic logout hours: Enter the time in hours for the
phone to automatically log out of hot-desking.

Enable hosting hot-desking: Select if you want to log into
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GUI field Description

User Portal

Entitlement

Advanced Setting

Conference number
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a regular phone with the hot-desking phone authentication
(by pressing *11 and enter your extension number and
user PIN following the prompts).

By selecting this option, the old extension is taken over by
the new extension on this phone. After logging out the
phone with the hot-desking phone authentication, the old
extension is recovered. However, outgoing calls still
display the hotd-esking extension number.

The regular phone logs out of hot-desking when the time
set in Automatic logout hours expires.

If the two phones use different programmable phone keys, the
host phone will reboot. For information on programmable
phone keys, see Configuring phone profiles on page 134.

Enable or disable the user portal and select the features for it.
Only the selected ones will appear for the extension to which
this user privilege is applied.

This option controls the use of unified communication and
enhanced call center features.

Unified communication: Select to allow the use of third
party communication applications, including:

o Microsoft Teams

o Presence for desktop application

« Instant messaging service and clients on endpoints
« Video conferencing service and client on endpoints
o Screen sharing

o File sharing
Enhanced call center. Select to allow the use of enhanced
call center features, including:

« Agent console for desktop application
« Enhanced FortiVoice IVR
« Salesforce integration

Select the permission for conference calls:

Allow All: Select to allow the extension to join all
conference calls.

Disallow All: Select to prohibit the extension from joining
all conference calls.

Allow All with Exempt: If you select this option, click
New to enter the conference call number(s) that the
extension is banned to join.

Disallow All with Exempt: If you select this option, click
New to enter the conference call number(s) that the
extension is allowed to join.
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GUI field Description

For more information, see Configuring auto attendants on
page 272.

Paging/Intercom Select the permission for paging/intercom:

o Allow All: Select to allow the extension to page/intercom
all paging numbers.

« Disallow All: Select to prohibit the extension to
page/intercom all paging numbers.

« Allow All with Exempt: If you select this option, click
New to enter the paging/intercom number(s) that the
extension is banned to page/intercom.

« Disallow All with Exempt: If you select this option, click
New to enter the paging/intercom number(s) that the
extension is allowed to page/intercom.

For more information on paging, see Configuring auto
attendants on page 272.

Trusted hosts type Select the type of the subnet that can register with the SIP
server. Only extensions on the specified subnet can register
with the SIP server.

If you select User defined, enter the information in Trusted
hosts.

Trusted hosts Enter the IP address and netmask of the subnet that can
register with the SIP server.

You can add multiple trusted hosts.

Permitted outgoing rules  Enable or disable all available outbound calling rules. For more
information on calling rules, see Configuring outbound dial
plans on page 230.

4. Click Create.

Configuring emergency zone profiles

You configure an emergency zone profile to include the detailed contact information in case of emergencies.
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To configure an emergency zone profile

1. Go to Phone System > Profile > Emergency Zone.
2. Click New and configure the following:

GUI field Description

Name For a new profile, enter its name.

Emergency caller ID Enter the caller ID to display on the destination phone when you dial the
emergency number, such as 911.

Description Enter any notes you have for this profile.

Emergency Setting Configure to send an alert email when an emergency call is made.

Select Do nothing if you do not want the FortiVoice unit to send an alert email.
Otherwise, select Send alert email and enter the following:

« Emergency contact emails: Enter the email address for emergency
contact. You can click + and add more addresses.

« Emergency barge number. Enter an authorized user’s extension number
to be dialed. When an ongoing emergency call is in progress, the phone
of the authorized user also rings. This user can listen to the call and talk, if
necessary.

Contact Information Enter the emergency contact information for the profile.

3. Click Create.

Scheduling the FortiVoice unit

You can schedule the FortiVoice operation time and use the schedules when configuring dial plans, virtual numbers, or
call management. The default schedules, namely after_hour, any time, business_hour, and holiday, can be modified
but cannot be deleted.

Depending on your preference, you can create either a standard or a calendar-based schedule.
For information on dial plan, see Configuring call routing on page 224.

For information on virtual numbers, see Working with virtual numbers on page 202.

For information on call management, see Setting extension user preferences on page 186.

To configure a standard schedule

Go to Phone System > Profile > Schedule and click New.

Enter a profile name and select Standard for Mode.

Click Create.

In the schedule list, select the profile name you created and click Ediit.

For Week Day, select the days to include in the schedule and set the AM and PM time or select Full Day.

For Holiday, click New to set the holidays. For example, select 01/01/12 in the Date field and enter New Year's

o0k~ ODdD-=
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Day in the Description field, and click Create.
7. Click OK.

To configure a calendar-based schedule

Go to Phone System > Profile > Schedule and click New.

Enter a profile name and select Calendarfor Mode.

Click Create.

In the schedule list, select the profile name you created and click Edit.
Double-click a date to schedule an event.

Click OK.

(AN

Configuring devices

Phone System > Device allows you to configure desktop FortiFones (including Cisco CP-7841 and CP-8841 phones
with version number 12.X) and multi-cell FortiFone phones in a central place for easy management.

This topic includes:

« Configuring desktop phones on page 147
« Configuring multi-cell FortiFone phones on page 149

Configuring desktop phones

You can configure desktop phones to include their MAC addresses, phone model, phone profiles, names, and statuses.
You may also assign a phone to an extension, to FortiFone-870i, or to an extension as an auxiliary.

To view the list of desktop phones, go to Phone System > Device > Phone.

GUI field Description

Delete Select one or more phone records and click this button to remove them all at
once.
Action « Assignto New Extension: Select a phone in Not Assigned management

status and click this option to add an extension and assign this phone to the
extension at the same time. For more information, see To assign a new
extension user to an unassigned phone on page 149.

« Assignto Existing Extension: Select an unassigned phone and click this
option to assign this phone to an existing extension. The phone record
disappears from the Unassigned Phone list. For more information, see To
assign an existing extension user to an unassigned phone on page 149.

« Assignto Multi-cell Device: Select a multi-cell device (for example,
FortiFone 870i) in Not Assigned management status and click this option to
add an extension and assign this phone to the extension at the same time.
For more information, see To assign a new extension user to an unassigned
phone on page 149 and Configuring multi-cell FortiFone phones on page
149.
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GUI field Description

« Assign as Aucxiliary to Existing Extension: Select a phone in Not Assigned
management status and click this option to assign it to an existing extension
as an auxiliary device. For more information, see To assign a new extension
user to an unassigned phone as an auxiliary device on page 149.

« View Phone Configuration: Select a phone in Assigned management status
and click this option display its configuration file.

« View accounts: For phones to which multiple extensions can be associated,
such as FON-850/860/870 and FON-D70/D71/D72, click this option to view
the associated extensions. This option is only active when a phone has
multiple extensions associated with it.

o Export: Select to save the phone list in csv format.

MAC Address The Media Access Control address (MAC address) of the phone.

Phone Model The phone brand and model.

Phone Profile The profile for this phone. See Configuring phone profiles on page 134.

Management Displays if the phone has been assigned to an extension.

Number The extension number of the phone.

Display Name The name displaying on the extension. This is usually the name of the extension
user.

Status Displays if the phone is registered with the FortiVoice unit. A registered phone is
assigned an |P address and basic PBX setup information.

IP The IP address of the phone assigned by the FortiVoice unit.

Phone Info The model, MAC address, and firmware version of the phone for this extension.

To add a desktop phone

1. Go to Phone System > Device > Phone.
2. Click New and configure the following:

GUI field Description

MAC Address Enter the MAC address of the phone you want to add.

Phone model Select the phone brand and model.

Phone profile Select the profile for this phone. You may also create a profile or edit an
existing one. For more information, see Configuring phone profiles on page
134.

Status Displays if the phone is registered with the FortiVoice unit. A registered phone

is assigned an IP address and basic PBX setup information.
This field is auto-populated based on the phone information you have entered.

Description Enter any notes about the phone.

3. Click Create.
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To assignh a new extension user to an unassigned phone

Go to Phone System > Device >Phone.

Select a phone in Not assigned management status.
Click Action and select Assign to New Extension.

Review the phone details and click Next.

1
2
3
4. Enter the extension details and click Next. For details, see Configuring IP extensions on page 164.
5
6

Review the summary and click Finish.

To assign an existing extension user to an unassigned phone

Go to Phone System > Device > Phone.

Select a phone in Not assigned management status.
Click Action and select Assign to Existing Extension.

Review the extension details and click Next. For details, see Configuring IP extensions on page 164.

Review the phone details and click Next.

1
2
3
4. Select the extension to associate with the unassigned phone and click Next.
5
6
7

Review the summary and click Finish.

To assignh a new extension user to an unassigned phone as an auxiliary device

Go to Phone System > Device > Phone.

Select a phone in Not assigned management status.

Click Action and select Assign as Auxiliary to Existing Extension.

Review the extension details and click Next. For details, see Configuring IP extensions on page 164.

Review the phone details and click Next.

1
2
3
4. Select the extension to associate with the unassigned phone and click Next.
5
6
7

Review the summary and click Finish.

Configuring multi-cell FortiFone phones

The FortiVoice unit supports 2 types of multi-cell FortiFone phones: FortiFone-870i and FortiFone-D72.

Each base FortiFone-870i can support up to 15 handsets. You can configure a FortiFone-870i to work with the
FortiVoice unit by adding a primary phone (base) and multiple secondary phones (bases).

Each base FortiFone-D72 can support up to 8 handsets. You can configure a FortiFone-D72 to work with the FortiVoice
unit by adding a FON-D72-M manager, at least one FON-D72-B base, and one FON-D71-H handset.

The following prerequisites must be met for the FortiFone-870i and FortiFone-D72 configuration to work:

Multi-cell phone Prerequisites

FortiFone-870i .

FortiVoice v6.0 build 127 or later.

FortiVoice auto provisioning is enabled (see Configuring SIP phone auto-
provisioning on page 96).

FortiFone-870i firmware 3.23 or later.

Network connectivity available between FortiFone-870i and the FortiVoice
unit.
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Multi-cell phone Prerequisites

FortiFone-D72 « FortiVoice v6.0.7 build 253 or later.
« FortiVoice auto provisioning is enabled (see Configuring SIP phone auto-
provisioning on page 96).
« Network connectivity available between FortiFone-D72 and the FortiVoice
unit.

Follow the FortiFone-870i and FortiFone-D72 guides to configure the phones first. After you connect the phone to the
network, you can configure it on the FortiVoice unit.

Configuring the FortiFone-870i

Configure the FortiFone-870i on multiple web-based manager pages.

1. Goto Phone System > Device > Multi-cell Device and click New.
2. Enterthe MAC address of the intended primary station.

3. Select Enable.
4

In Device role, set the station as primary with chain ID. The chain ID should be numbers up to 5 digits. Enter any
description as needed and click Create.
You can now add extensions to the primary station. You only need to apply the extension configuration to the
primary. All secondary stations can obtain the extension information from the primary.

5. Go to Phone System > Device > Phone.

6. Select the primary station just created, click Action, and select Assign to New Extension or Assign to Existing
Extension.

7. For Assignto New Extension, see To assign a new extension user to an unassigned phone on page 149.

©

For Assign to Existing Extension, see To assign an existing extension user to an unassigned phone on page 149.

9. Add more extensions as needed with a different handset IDs. Upon completion, you should see all the extensions
listed for the primary station.

10. Since the primary station is provisioned, proceed to provision the secondary stations. Factory reset the intended
secondary station and connect it to the network. If the network and the FortiVoice unit are configured properly, it
should appear under Phone System > Device > Phone.

11. Select the unassigned FortiFone 870i station, click Action > Assign to Multi-cell Device.

12. In Device role, set the base station as secondary and select Prime (primary station) from the drop down list. Type
any description as needed.

13. Click OK.

14. On the secondary phone configuration, remove the temporary extension setting and reboot the station. See the
phone guide for more information.
Note that the temporary extension is used for initial configuration of the base and has to be removed for the phone
to work with the FortiVoice unit.

Configuring the FortiFone-D72

You can configure a FortiFone-D72 to work with the FortiVoice unit by adding a FON-D72-M (manager), at least one
FON-D72-B (base), and one FON-D71-H (handset). This solution includes the following four steps.

For more information about the FortiFone-D72, see FON-D72 User Guide.
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To configure the FON-D72-M

1. Connect the FON-D72-M to the network using a POE connection.
2. Loginto the FortiVoice web-based manager.
3. Goto Phone System > Device > Phone.
The FON-D72 is auto discovered and displays as a device with the Not Assigned management status.
4. Right-click the FortiFone-D72 and select Assign to Multi-cell Device.
5. Configure the following:
GUI field Description
Enable Select to activate the phone.
Device role Select DECT Manager for FON-D72-M.
IP address Enter the IP address of the FON-D72-M if it is not automatically filled out.
Default manager Enable to make the FON-D72-M as the default manager of the FortiFone-D72
configuration.
Description Enter any notes about the phone.
6. Click OK.

In the Phone Model column, a green icon é appears beside FortiFone-D72 indicating that it is the DECT
Manager.

To configure the FON-D72-B

1. Connect the FON-D72-B to the network using a POE connection.
2. Loginto the FortiVoice web-based manager.
3. Goto Phone System > Device > Phone.
A new FON-D72 is auto discovered, displays as a device with the Not Assigned management status, and has a
different MAC address than the DECT Manager.
4. Right-click the FortiFone-D72 and select Assign to Multi-cell Device.
5. Configure the following:
GUI field Description
Enable Select to activate the phone.
Device role Select Base for FON-D72-B.
Sync cluster Select the ID for a phone group.
A sync cluster is comprised of a number of base stations within the DECT
multi-cell system that synchronize with each other to enable handover,
roaming, list access, and load balancing.
Only phones in the same cluster can talk with each other.
For detailed information, see FON-D72 User Guide.
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GUI field Description

Sync level Select the sync level for a phone group.

Each base station is assigned to a corresponding sync level. Sync level is
based on the distance between bases. Only one base can be sync level 1, then
every other base would be 2-10, based on where they are located.

For detailed information, see FON-D72 User Guide.

Primary Select the MAC address of the default DECT Manager if it is not automatically
populated.
Default manager Enable to make the FON-D72-M as the default manager of the FortiFone-D72
configuration.
Description Enter any notes about the phone.
6. Click OK.
In the Phone Model column, a gray icon 2= appears beside FortiFone-D72 indicating that it is the base.

To configure the FON-D71-H handset as an extension

1. Login to the FortiVoice web-based manager.
2. Right-click the FortiFone-D72 that is the DECT Manager and select Assign to New Extension.
3. Configure the following:

GUI field Description

Number Enter the extension number of the FON-D71-H.
For information on extension configuration, see Configuring IP extensions on
page 164.

Enable Select to activate the extension.

Display name Enter the name displaying on the extension. This is usually the name of the

extension user.

You can click Expand to modify caller ID to add a caller ID for external calls or
emergency calls.

Description Enter any notes about the phone.
User Setting Do not do anything.
4. Click Next.

5. Verify the information and click Next.
6. Review the summary.
7. Click Finish.

To activate the FON-D72-M and register handsets

1. Enter the IP address of the FON-D72-M in a web browser.
2. Login using "admin" as the username and "23646" as the password.
3. Goto Handset & Account > Registration Center.
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4.
5.

Click Start Now.

Power on the FON-D71-H handset and press the Reg button.
The handset will search and find the FON-D72-M, register, and display the created extension number and name.

Reviewing system configuration

Phone System > Review provides a snapshot of the FortiVoice system configuration. You may also modify some
items.

The items to be reviewed or modified include:

Extension numbers (For modification information, see Configuring IP extensions on page 164.)
New voice mail check

Network summary

DID handling information

Call queues (Available for FortiVoice units with Call Center license. For modification information, see Creating call
queues on page 235.)

Agents (Available for FortiVoice units with Call Center license. For modification information, see Configuring
agents on page 246.)

Extensions that are used by other objects and their roles in the objects.
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Managing FortiVoice gateways, local survivability, and
firmware

A managed gateway is one of the FortiVoice Gateways that either contains FXS, FXO, or PRI ports that handles calls
for the FortiVoice phone system. Gateway Management enables auto-discovery of other FortiVoice gateways on the
network and offers remote device management from a centralized FortiVoice phone system. Gateways will still need to
be configured for network setting and administrator passwords, but all other configurations will be received from the
FortiVoice unit.

For information on gateway auto-discovery, see Viewing unmanaged gateways on page 32.
FVE-100E and larger systems can manage gateways.

FVE models and supported number of managed gateways

100E & VM100 5
200F & VM200 5
300E 10
VM500 15
500E & 500F 15
1000E & VM 1000 25
200D 25
2000E, 2000F & VM2000 50
3000E & VM3000 50
5000F & VM5000 100
VM 10000 100
VM50000 200

The FortiVoice Local Survivable solution is designed to provide branch resiliency for centralized deployments with multi-
sites. It is delivered and supported by a selected line of enterprise-class appliances through a firmware upgrade and
enables system administrators to seamlessly connect multiple locations with an easy-to-deploy solution.

Firmware of the FortiVoice units and FortiFones can be managed in a single place.
For information on gateway deployment, see FortiVVoice Gateway Deployment guides.

For information on local survivable gateway deployment, see FortiVoice Local Survivable Gateway Deployment
Guide.

This topic includes:

o Managing FXO gateways on page 155
« Managing FXS gateways on page 155
« Managing PRI gateways on page 156
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« Configuring local survivability on page 156
« Managing firmware on page 157

Managing FXO gateways

FXO Gateways connect your IP phone system to an outside telephone line. It allows you to connect the FXS port to the
FXO port of the gateway, which then translates the analog phone line to a VoIP call.

The FortiVoice FVG-GO08 gateways can be auto discovered by the FortiVoice unit once they connect to it. You can also
manually add gateways to be managed by the FortiVoice unit.

For FXO gateway deployment information, see FortiVoice FXO Gateway Deployment Guide.

To view the list of added GO08 gateways, go to Managed System > Gateway > FXO Gateway.

GUI field Description

Apply configuration Select a gateway from the list and click this option to apply the FortiVoice FXO
gateway configuration file to this gateway and reboot the gateway immediately.

View configuration Select a gateway from the list and click this option to display the configuration file
applied to this gateway.

Unmanaged Gateway Click to display the gateways auto discovered by the FortiVoice unit. For more
information, see Viewing unmanaged gateways on page 32.

Fetch Device Info Select a branch FortiVoice unit from the list and click this option to retrieve its
information.

Upgrade Select a gateway and select this option to upgrade it now or later.

Managing FXS gateways

FXS gateways connect traditional PBX phone lines to a VolP phone system or provider. To connect the FXO ports to the
Internet or a VoIP system, you need an FXS gateway in between.

The FortiVoice FVG-GS16 gateways can be auto discovered by the FortiVoice unit once they connect toit. You can also
manually add gateways to be managed by the FortiVoice unit.

For FXS gateway deployment information, see FortiVoice FXS Gateway Deployment Guide.

To view the list of added GS16 gateways, go to Managed System > Gateway > FXS Gateway.

GUI field Description

Apply configuration Select a gateway from the list and click this option to apply the FortiVoice FXS
gateway configuration file to this gateway and reboot the gateway immediately.

View configuration Select a gateway from the list and click this option to display the configuration file
applied to this gateway.
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GUI field Description

Unmanaged Gateway Click to display the gateways auto discovered by the FortiVoice unit. For more
information, see Viewing unmanaged gateways on page 32.

Fetch Device Info Select a branch FortiVoice unit from the list and click this option to retrieve its
information.

Upgrade Select a gateway and select this option to upgrade it now or later.

Managing PRI gateways

VolP PRI gateways seamlessly connect your legacy telephony infrastructure, made up of PRI (T1, E1) or BRI lines, to IP
networks. Businesses with legacy phone equipment (such as a TDM PBX) can use PRI gateways to connect to SIP
trunking services without altering their current network infrastructure.

The FortiVoice FVG-GT01 and GT02 gateways can be auto discovered by the FortiVoice unit once they connect to it.
You can also manually add gateways to be managed by the FortiVoice unit.

For PRI gateway deployment information, see FortiVoice PRI Gateway Deployment Guide.

To view the list of added GT01/02 gateways, go to Managed System > Gateway > PRI Gateway.

GUI field Description

Apply configuration Select a gateway from the list and click this option to apply the FortiVoice FXS
gateway configuration file to this gateway and reboot the gateway immediately.

View configuration Select a gateway from the list and click this option to display the configuration file
applied to this gateway.

Unmanaged Gateway Click to display the gateways auto discovered by the FortiVoice unit. For more
information, see Viewing unmanaged gateways on page 32.

Fetch Device Info Select a branch FortiVoice unit from the list and click this option to retrieve its
information.

Upgrade Select a gateway and select this option to upgrade it now or later.

Configuring local survivability

FortiVoice local survivability solution is designed to provide branch resiliency for centralized deployments with multi-
sites. The FortiVoice unit at the central office sends the configuration files to the FortiVoice units and extensions at the
branch offices. The central office handles all inbound calls thereby consolidating the number of lines required for an
organization.

With this solution, you have one place to look for the routing rules, logs, call records, and call recordings. You can see
the whole setup, make changes, or modify records. If an extension is added, it is operational immediately. Any users at
any location will be able to call that new extension right away without waiting for configurations to sync up, or new
policies required to be set at each location.
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If the communication between the FortiVoice unit at the central office and the FortiVoice units and extensions at the
branch offices is down, the FortiVoice units at the branch offices (survivability branches) will kick in to provide access to
lines until the communication is restored between the central unit and the extensions.

A survivability branch is a local FortiVoice unit containing local extensions that is part of a centralized deployment.

FortiVoice models 300E and up and FortiVoice VM models 500 and up provide central management.

FVE-20E2, FVE-20E4, FVE-50E6, FVE-100E, FVE-200F8, and FVE-500F can serve as local survivability (survivability

branch) models.

FVE models and supported number of survivability branches

FVE Model

300E

VM500

500E & 500F

1000E & VM 1000

200D

2000E, 2000F & VM2000
3000E & VM3000

5000F & VM5000
VM10000

VM50000

Number of survivability branches supported

10
15
15

20
20
40
40

100
100

200

For information on survivability branch deployment, see FortiVoice Local Survivable Gateway Deployment Guide.

To view the list of added survivability branches, go to Managed System > Survivability > Survivability Branch.

GUI field Description

Apply configuration

View configuration
Fetch Device Info

Upgrade

Managing firmware

Select a branch FortiVoice unit from the list and click this option to apply the
FortiVoice configuration file to this branch unit and reboot the unit immediately.

Select a branch FortiVoice unit from the list and click this option to display the
configuration file applied to this unit.

Select a branch FortiVoice unit from the list and click this option to retrieve its
information.

Select a branch FortiVoice unit and select this option to upgrade it now or later.

Managed System > Firmwatre allows you to manage firmware of the FortiVoice devices and FortiFones.

FortiVoice devices refer to the devices managed by this FortiVoice unit, such as FortiVoice gateways.
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FortiFones are those connected to this FortiVoice unit.
To manage FortiFone firmware

1. Go to Managed System > Firmware > FortiFone Firmware.

GUI field Description

Upload Click to upload a firmware file.

You can select a phone model or FortiFone desktop app, select the firmware file, enter
the firmware version number, and click OK to upload the firmware.

Note that if you selected FortiFone-DesktopApp, the Firmware version option is only
available when editing an existing firmware file.

For FortiFone-380, 480, and 580, there is a Forced option. If necessary, enable this
option to force a new build onto the phone regardless of the firmware version already on

the phone.
Download Select a firmware file and click this button to download it.
Action Select a firmware file and click this button to enable or disable a firmware upgrade for the

FortiFone phones managed by this FortiVoice unit.

Statistics Click to display the information of the managed FortiFone phones.

Upgrade Select a firmware and click Upgrade to upgrade the FortiFone firmware:

« Name: Enter a name for the firmware upgrade job.

« Extension Selection: Select All related devices if you want to upgrade all of the
devices to which the firmware applies to. Otherwise add individual devices that you
want to upgrade.

« Schedule: Schedule the upgrade. The firmware will be pushed to the managed
FortiFone phones at the scheduled time.

View upgrade job Click to display the FortiFone upgrade records. See Maintaining phones on page 107.

To manage FortiVoice firmware

1. Go to Managed System > Firmware > FortiVoice Firmware.

GUI field Description

Upload Click to upload a firmware file.
Upgrade Select a firmware file to do the FortiVoice firmware upgrade now or at a scheduled time.
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Configuring security settings

You can enhance the FortiVoice unit security by configuring intrusion detection, password policies, user privileges, and
extension blocking.

This topic includes:

« Configuring intrusion detection on page 159

« Setting password policies on page 160

« Auditing the extension passwords on page 161
« Configuring user privileges on page 162

« Configuring account codes on page 162

« Blocking phone numbers on page 162

Configuring intrusion detection

Security > Intrusion Detection lets you manually add IP addresses to be exempted from being blocked and configure
intrusion detection settings.

The manually added IP addresses are usually from the sources that you trust. For example, IP addresses from external
customer devices can be added.

IP addresses of the devices that are registered to the FortiVoice unit are automatically added to the exempt list.
For information on viewing system added exempt IPs, see Blocking SIP device IP addresses on page 37.
To add an exempt IP

1. Goto Security > Intrusion Detection > Exempt IP.

2. Click New.

3. Enterthe IP address or netmask of the network interface that you want to add to the exempt list.
4. Click Create.

To configure intrusion detection settings

1. Goto Security > Intrusion Detection > Setting.
2. Configure the following:

GUI field Description

Status « Disable: Select to stop the intrusion detection activities.
« Monitor Only: Select to only track the intrusion detection activities.
« Enable: Select to activate the intrusion detection activities.

Access tracking Select the method to track the traffic access (and IP addresses) to the FortiVoice unit.
Initial block period Enter the time in minutes to initially block every new device/IP address trying to access

the FortiVoice unit. This is to screen out spammers or attackers because they normally
will not try again after being blocked initially.
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3. Click Apply.

Setting password policies

Security > Password Policy lets you set the SIP password and user PIN policy for administrators and extension users.
For information on setting SIP password and user PIN, see Configuring IP extensions on page 164.

You can also edit extension user passwords.
To set password policies

1. Goto Security > Password Policy > Password/PIN Policy.
2. Configure the following:

GUI field Description

Password / PIN Policy Select to enable or disable the SIP password and user PIN policy for
administrators and extension users.

o Minimum password length: Set the minimum acceptable length (8) for
passwords.

o Password must contain: Select any of the following special character
types to require in a password. Each selected type must occur at least
once in the password.

o Upper-case-letter— A, B, C, ... Z

o Lower-case-letter—a, b, c, ...z

e Number—0...9

o Non-alphanumeric — punctuation marks, @,#, ... %

o Apply password policy to: Select where to apply the password policy:

o Admin user— Apply to administrator web GUI passwords. If any
password does not conform to the policy, require that administrator
to change the password at the next login.

o SIP users — Apply to FortiVoice SIP phone users’ passwords. If any
password does not conform to the policy, require that user to change
the password at the next login.

o Userpasswords: Apply to user portal access passwords. If any
password does not conform to the policy, require that user to change
the password at the next login.

o Minimum PIN length: Set the minimum acceptable length (6) for the user
PIN.

o PIN must contain:

o Number. to include a number (0-9) in the PIN.

o PIN special: Select to include special characters in the PIN.

o Apply PIN policy to: Select Voicemail users to apply the policy to
FortiVoice phone users’ user PIN. If any PIN does not conform to the
policy, require that user to change the PIN at the next login.

o PIN expiration: Select the voicemail PIN expiration options.

o Never. Users set their voicemail PIN and the PIN never expires.
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GUI field Description

o Default Only: Extension users using the default voicemail PIN is
prompted to change the PIN when accessing their voicemail for the
first time. For information on voicemail PIN, see Configuring IP
extensions on page 164.

« All: Extension users are prompted to change the voicemail PIN when
accessing their voicemail for the first time and regularly according to
the PIN expiration time.

« PIN expiration time: If you selected All for PIN expiration, select the PIN
expiry time in days.

Allow empty admin password Select to allow leaving the admin password field empty when logging in to the
system.

3. Click Apply.
To edit extension user passwords

1. Goto Security > Password Policy > Password Auditor.
2. Double-click an extension of which you want to edit the user passwords.

3. Under User Setting, change the passwords as required. For more information, see Configuring IP extensions on
page 164.

4. Click OK.

Auditing the extension passwords

You can verify the strength of IP and fax extension passwords. For information on setting IP extension and fax extension
passwords, user passwords, and voicemail PINs, see Auditing the extension passwords on page 161 and Configuring
fax extensions on page 184.

To audit a SIP extension password

1. Goto Security > Password Policy > Password Auditor.
2. Configure the following:

GUI field Description

Edit Select an extension and click Edit to modify the extension configuration. See
Auditing the extension passwords on page 161.

Audit Now Click to check the strength of the extension passwords. The time is displayed
when last audit was done.
If a password warning (red check mark) appears, double-click the extension to
view and modify the password based on the policy. See Auditing the extension
passwords on page 161.
If the password strength of an extension shows the Weak (black check mark)
icon, double-click the extension to view and modify the password based on the
policy until the password strength shows the Strong (green check mark) icon.
See Auditing the extension passwords on page 161.
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GUI field Description

Download Click to save a copy of the password audit result.

Configuring user privileges

A user privilege includes a collection of phone services and restrictions that can be applied to each extension user.

For more information, see Configuring user privileges on page 140.

Configuring account codes

You can set account codes to restrict long-distance and international calls, for instance. Users must dial these codes
first before making long-distance or international calls.

You apply the account codes in user privileges. For details, see Configuring user privileges on page 140.
To set an account code

1. Goto Security > User Privilege > Account Code.
2. Click New and configure the following:

Name Enter an account code name.

Description Enter any notes you may have for the account code.

Shared Select to use this code on any extension.

Represented in CDR Select to display the account code by code or name in CDR. For information
about CDR, see Viewing call records on page 33.

Access Code Set Click New to enter the account code such as 69, display name for the code
such as Finance, and any notes for the code.
Click Create.

3. Click Create.

Blocking phone numbers

For security reasons, you can block an inbound call by entering its number. This will block future calls from this number.
To block a number

1. Goto Security > Blocked Number.
2. Click New.
3. Enter the number you want to block.
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Click Create.

Click Setting.

In PBX Setting, enable System block list.

Click Apply.

Future calls from the number will be blocked. For more information, see Configuring phone system settings on
page 109.

N o o A~

To unblock a number

1. Goto Security > Blocked Number.
2. Select a blocked number in the list.
3. Click Delete.
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Configuring extensions

The Extension menu lets you configure local and remote extensions, extension groups, general voicemail, and virtual
numbers.

This topic includes:

« Setting up local extensions on page 164

« Creating extension groups on page 193

« Setting up general voice mailboxes on page 200
o Working with virtual numbers on page 202

Setting up local extensions

You can configure IP phone extensions, edit analog extension, and choose extension preferences.

This topic includes:

« Configuring IP extensions on page 164

« Modifying managed extensions on page 180

« Modifying analog extension (200D-T, 1000E-T, and 20E2 models only) on page 181
« Setting up remote extensions on page 183

« Configuring fax extensions on page 184

« Setting extension user preferences on page 186

Configuring IP extensions

An IP extension is an IP phone connected through a network to a system. An internal IP extension is a phone connected
on the same LAN as the system. An external IP extension is a phone connected outside the LAN.

To view the local IP extensions, go to Extension > Extension > IP Extension.

GUI field Description

LDAP Connector When you select Filter > Source > LDAP to list the extension users with LDAP
authentication, you can click this option to see the LDAP connector information.
See Configuring LDAP settings on page 124.

Actions « Batch Edit: Select to modify a group of extensions all at the same time. For

more information, see Batch editing extensions on page 175.

« Export: Select to save a copy of the extension list or download as a sample
list with or without user ID in CSV format.

« Import: Select to upload a copy of the extension list in CSV format. For
details, see Importing a list of extensions on page 179.

« View Phone Configuration: Select a FortiFone extension and click this
option to view the configuration file of the phone, desktop app, or mobile.
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GUI field Description

Configure View (icon)

« Phone: This option appears when a phone is associated with an
extension. In this case, the FortiVoice unit generates a configuration file
for the phone. For details, see To create or edit an IP extension on page
166.

« Desktop App and Mobile: These options appear when an extension is
allocated with soft FortiFone licenses. In such cases, desktop app and
mobile phone configuration files are generated. For details, see To
create or edit an IP extension on page 166.

« Apply Configuration (Main Phone): If you have edited an extension
configuration and want to apply it to the desktop phones and soft phones
associated with this extension, select the extension and click this option. This
action will not apply the configuration to the auxiliary phones associated with
this extension.

The selected phone will reboot and only the phones that meet the following

conditions will receive the new configuration:

« Phones supported by and registered to the FortiVoice unit. For the list of
supported phones and auto provisioning prerequisites, see Configuring
SIP phone auto-provisioning on page 96.

« Phone type and MAC address are correctly configured. See To create or
edit an IP extension on page 166.

« Auto-provisioning is enabled for the extension associated with the
phone through the user privilege applied to it. See Configuring user
privileges on page 140.

o Password Auditor. See Auditing SIP extension password on page 178.

« Number Auditor. See Auditing extension numbers and MAC addresses on
page 178

« Send Softclient QR Code by Email: If you have added a FortiFone softclient
to an extension and entered your email address as a notification option,
select this option to send a QR code to the email address. The QR code will
also appear on the Preferences page of the extension’s user portal.

See Auxiliary Phone on page 170 and Notification Options on page 188.

« Maintenance: Select an extension and click this button to manage a user's
voicemail box and faxes. You can check the size of the mailbox or fax folder
and empty them if required.

Click Back to return to the /P Extension tab.

Click to display or hide columns you want. You can also save the customized view
or set it back to default.

Enabled Select to activate an extension.
Number The extension number.
Display Name The name displaying on the extension. This is usually the name of the extension
user.
Phone Model The brand and model of the phone.
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GUI field Description

Emergency Zone The emergency zone profile for this extension. For more information, see
Configuring emergency zone profiles on page 145.

Survival Branch If the extension belongs to a FortiVoice survivability branch, the branch
information is listed. For information on survivability branch, see Configuring local
survivability on page 156.

Department If the extension belongs to an extension department, the department information
is listed. For information on departments, see Creating extension departments on
page 194.

Business Group If the extension belongs to a business group, the group information is listed. For

information on business groups, see Creating business groups on page 199.

Status The extension statuses, including:

Idle: The extension is not in use.

In Use: The extension is in use.

Busy: The extension is busy.

Ringing: The extension is ringing.

On Hold: The extension has an on-hold call.

Admin down: The trunk of the extension is disabled.

Under this status, the extension remains registered with the FortiVoice unit.
Not registered: The extension is not registered with the FortiVoice unit and is
not in service.

Unavailable: The extension is not reachable.

Alarm detected: There is a problem with the phone line.

Other. The status other than the above.

IP The link to the IP address of the phone using the extension number.

Phone Profile Displays the phone profile applied to the extension. For information on phone
profile, see Configuring phone profiles on page 134.

Phone Info The model, MAC address, and firmware version of the phone for this extension.

To create or edit an IP extension

1. Goto Extension > Extension > IP Extension.
2. Click New or double-click an existing extension.

3. Configure the following:

GUI field Description

Enabled

Number

Select to activate the extension.

Enter the extension number following the
extension number pattern. See Configuring
PBX options on page 111.

Click Edit Preference to configure the extension
user preferences. See Setting extension user
preferences on page 186. This option is only
available when you edit an extension.
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GUI field Description

User ID This is the system-generated ID based on the
user ID prefix you set (see User ID prefix on
page 113) and the extension number.

This option is view only and the ID only appears
when you edit an extension. You can add a new
user ID through the CLI.

Display name Enter the name displaying on the extension.
This is usually the name of the extension user.

Quotation marks (") are not allowed for display
names.
Click +:

o External caller ID: Enter the caller ID that
displays on a called phone when you make
an external call. Use the name<phone_
number>format, such as John
Doe<222134>.

o Emergency caller ID: Enter the caller ID
that displays on a called phone when you
make an emergency call. Use the
name<phone_number> format, such as
John Doe<222134>.

« Voice DID Number: Click the Edit icon to
modify the voice DID mapping for this
extension. See Configuring direct inward
dialing on page 227. This option is only
available when you edit an extension.

o Fax DID Number. Click the Editicon to
modify the fax DID mapping for this
extension. See Configuring direct inward
dialing on page 227. This option is only
available when you edit an extension.

You can also modify the voice and fax DID
numbers set in

Description Enter any notes for the extension.

Upload/Delete (icons) Click to add or remove a picture of the
extension user. This option is only available
when you edit an extension.

By adding a picture of the extension user, the
picture can be displayed on the callee's phone
screen whenever the user makes a phone call, if
the phone model supports this feature.

Edit See Setting extension user preferences on page
Preference 186.
FortiVoice Phone System 6.4.3 Administration Guide 167

Fortinet Technologies Inc.



Configuring extensions

GUI field Description

Device Setting

Phone

Type
Device

Phone model

SIP settings

Emergency zone

Programmable keys

Advanced
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Extension SIP devices include desktop phones,
soft phones, and auxiliary devices.

Select the desktop phone type.

Select the specific phone model.

Click the New icon to add a new device. See
Configuring desktop phones on page 147.

Click the Edit icon to modify a selected device.
Click the Select icon to choose an existing
device.

This option is only available if you select
FortiFone type.

The FortiFone model.

This option is only available if you select
FortiFone type.

Select the SIP profile for the phone.

Click the New icon to add a new profile. See
Configuring SIP profiles on page 131.

Click the Edit icon to modify a selected profile.

Select the emergency zone profile for the
phone.

Click the New icon to add a new profile. See
Configuring emergency zone profiles on page
145.

Click the Edit icon to modify a selected profile.

Select the keypad profile for the phone.

Click the New icon to add a profile or Edit icon
to modify a selected profile. See Configuring
programmable keys profiles on page 137.

This option is only available if you select the
FortiFone type and is not available for all
models.

Configure the following and click OK when you
finish.

o SIP password: Enter the password used
for configuring your SIP phone from the
phone or the Web. You need the phone's
IP to access it from the Web.

You can check the password strength. See
Reviewing system configuration on page
153.
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Click Generate to generate a strong
password automatically. Select View
password to display the password.

If you have configured the default SIP user
password (see Default SIP user password
on page 112), the password appears here.
However, you can change it.
Location: Select Internal if the phone does
not traverse through Network Address
Translation (NAT) to connect to the
FortiVoice unit, and External if the phone
does. These are system defined locations.
User programmable keys: By clicking Edit,
you can configure the phone
programmable keys for the extension user
if the programmable keys profile used for
this extension gives users the permission
to do so.
MWI (Message Waiting Indication): Enable
or disable MWI on the phone.
Auto answer: Enable or disable automatic
answering on the phone.
Direct call: Enable or disable direct calling
on the phone.
Number. Enter the phone number.
This is the phone number that the
FortiVoice unit automatically dials
after the phone user lifts up the phone
handset (or press the headset or
speaker button) to place a call.

After: If you want to delay the
automatic dialing, enter a value in
seconds. If the delay is set to 0, the
extension is turned into a hotline
meaning that the FortiVoice unit
immediately dials the configured
Direct call number after the extension
is off-hook.

Secondary accounts: If you enabled the
option to add a secondary account for
desktop FortiFone phones under System >
Advanced > Auto Provisioning, do it here
by selecting the FortiFone extension. For
more information, see Secondary account
(Enable secondary account for Desktop
FortiFone) on page 98.
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Soft FortiFone

License allocation

Mobile

Desktop

SIP Setting

Revoking a license

Auxiliary Phone
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Use this option to allocate FortiFone softclient
licenses, view softclient login information, and
revoke a license.

Select the number of FortiFone softclient
licenses for use on this extension. The
maximum is 5 for each extension.

Click View Login Information to view the
configuration file of the mobile softclient. Use
the user name and password from the
configuration file to log in onto the mobile
softclient, or click and scan the QR code from
the mobile softclient.

Click View Login Information to view the
configuration file of the desktop softclient. Use
the user name and password from the
configuration file to log in onto the desktop
softclient.

o Android/iOS: If the softclient is on an
Android phone or iPhone, select a SIP
profile for it. Click Edit to modify the
current profile or New to configure a new
one. For more information, see
Configuring SIP profiles on page 131.

o Windows/macOS: If the softclient is on a
Windows or Mac device, select a SIP
profile for it. Click Edit to modify the
current profile or New to configure a new
one. For more information, see
Configuring SIP profiles on page 131.

When licenses are allocated to an extension
and the devices associated with the extension
use the licenses, the devices appear.

Device Setting Phone JFTTONTISNY  Auxiliary Phone

e
© DEKTOP RANGIN -Windows 0015042-50..[]

Android/i0S G729 v+

Windows/macOS | G729 v+ m

If you want to free up a license, you can revoke
the license of a device that you no longer need
and use it for another device in need.

To do so, click the Revoke License ( o )icon
and confirm the action.

Click New to add SIP devices to the extension.
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User Setting
Management

User privilege

Department

Survival branch
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When you add an auxiliary phone to your
extension, you have two phones with the same
extension number. The phones will ring at the
same time but you can only use one phone to
answer the call. This function is useful when
you want to access the same extension from
two different locations.

For more information, see Configuring SIP
forking on page 179.

From Extension > Extension > |P Extension,
select a device and click Other Actions to apply
extension configuration to the device or view
the extension or SIP configuration file.

The selected devices will reboot and only the
devices that meet the following conditions will
receive the new configuration:

« Devices supported by and registered to the
FortiVoice unit. For the list of supported
phones and auto provisioning
prerequisites, see Configuring SIP phone
auto-provisioning on page 96.

« Device type and MAC address is correctly
configured. See To create or edit an IP
extension on page 166.

« Auto-provisioning is enabled for the
extension associated with the device
through the user privilege applied to it. See
Configuring user privileges on page 140.

Configure the extension’s role in other settings.

Select the services for the extension. Click Ediit
to modify the current user privilege or click New
to configure a new one. For more information
on user privilege, see Configuring user
privileges on page 140.

Select the department that the extension
belongs to. Click Edit to modify the current
department or click New to configure a new
one. For more information on extension
department, see Configuring agents on page
246.

Select the local survival branch FortiVoice unit
for the extension if the extension is in a local
survivability network.

Click Edit to modify the current branch unit.
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Voicemail

Web Access

Authentication type

User password
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For more information, see Configuring local
survivability on page 156.

Configure the extension’s voice mailbox.

In some cases, you may want other users or
groups to share this voice mailbox. For
example, a supervisor wants his/her co-workers
to access his/her voice mailbox while he/she is
away.

Main voice mailbox: Select the extension’s own
voice mailbox (Default) or that of another
extension as the voice mailbox of this
extension.

Typically, you use the default mailbox.

If you select the voice mailbox of another
extension, you can click Edit to modify that
extension.

Users/Groups: The FortiVoice unit turns on the
message waiting light on the phones of a user
or user group to notify the user or group of a
new voice message stored in the voice mailbox
associated with this extension.

To select users or user groups, under User(s)
and Group(s), click in the field and select the
users/groups. Click Close.

To listen to the message after being notified,
the user can dial *97 or the code you set (see
Modifying feature access codes on page 304)
and enter the user’s own user PIN.

For information on creating user groups, see
Creating extension groups on page 193.

Configure user portal and softclient access from
mobile or desktop devices.

If Password policy is disabled appears, see
Setting password policies on page 160.

Select the extension’s authentication type:
Local or LDAP.

If you selected Local as the Authentication
type, enter the password for user portal access.
This password can be much longer and stronger
to mitigate the risk of password guess attack
and preserve the voicemail PIN for phone
access only.

To let the system create the user password,
click Generate.
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LDAP profile

Authentication ID

Phone Access

Voicemail PIN
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To show the user password, click the eye icon.

Control of using user password or voicemail PIN
to access user portal is set when configuring
phone system capacity. For more information,
see Configuring system capacity on page 114.

If you select LDAP for Authentication type,
select an LDAP profile to apply to this
extension. For information on LDAP profile, see
Configuring LDAP settings on page 124.

You can click New to create a new profile or
Edit to modify the selected one.

This option is only available if you select LDAP
for Authentication type.

If you select Try common name with base DN
as bind DN as the user authentication option in
the authentication profile you select, enter the
authentication ID based on the user objects’
common name attribute you entered in the
Common name ID field of the profile, such as
jdoe.

If you select Search user and try bind DN as
the user authentication option in the
authentication profile you select, leave this field
blank.

Configure voicemail access by phone or access
to restricted phone calls.

Enter the password for the extension user to
access voicemail and the user portal.

Selection of using personal password or
voicemail PIN to access user portal is set when
configuring phone system capacity. For more
information, see Configuring system capacity
on page 114.

You can check the PIN strength. See
Reviewing system configuration on page 153.

Click Generate to generate a strong password
automatically. Select the view PIN icon to
display the password.

If you have configured the default user PIN (see
Default Voicemail PIN on page 113), the
password appears here. However, you can
change it.
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Personal code Enter the extension specific account code that
can be used to restrict calls. This code is
needed to make some restricted calls.

You can click Generate to get a code.

Conferencing ID Enter the conference organizer PIN for the
extension's conference call.

Call Center This option appears if your FortiVoice unit has a
call center license.

Save your FortiVoice configuration before
configuring call center.

Select to configure the departments that a call
center agent manages, queues that the agent
belongs to, skill sets, and skill levels. Click Call
Centerand configure the following:

« Agent profile: Select the profile for the
agent. You can also create a new one or
modify an existing one. For more
information about agent profiles, see
Configuring agent profiles on page 257.

o Managed departments: An agent manager
may need to monitor call queues in certain
departments. For information on setting up
departments, see Creating extension
departments on page 194.

Click in the field and select the
departments to be monitored and then
click Close.

« Member of Queues: Click to select the call
queues to join.

o Queues: Click in the field and select
the queues of which you want the
extension/agent to be a member.
Click Close.

o Main/Outgoing queue: This option is
for collecting the outgoing calls from
all queues by this agent and displaying
them in Working with call queue
statistics on page 259. You can select
any queue of which this agent is a
member for that purpose except None
which will not collect agent’s outgoing
call information. Click OK.

o Skill Sets: Click New to select the skill set
for the agent, including skill and level, and
click Create. For more information about
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agent skills and levels, see Adding agent
skill sets on page 256 and Creating agent
skill levels on page 256.

Click OK.

4. Click Create (for new extension) or OK (for editing extension).

Batch editing extensions

You can efficiently modify a group of extensions all at the same time.

To batch edit extensions

1.

ok 0D

Go to Extension > Extension > |IP Extension.

Under Actions, click Batch Edit.

Search or filter the extensions you want to edit, if required.

Click Next.

Select the options you want to modify and configure the following:

GUI field Description

License

License
allocation

Android/iOS

Windows/macOS

Agent profile

Call Center
Agent

Management
Status

User privilege

Department

Select the number of licenses allocated to the extensions.

Select the SIP profile for Android/iOS extension devices. You can add a
new profile or edit a selected one. For more information, see
Configuring SIP profiles on page 131

Select the SIP profile for Windows/macOS extension devices. You can
add a new profile or edit a selected one. For more information, see
Configuring SIP profiles on page 131

Enable or disable the agent profile. For more information about agent
profiles, see Configuring agent profiles on page 257.

Select the agent profile for the call center agent. You can add a new
profile or edit a selected one. For more information, see Configuring
agent profiles on page 257.

Enable or disable the extension’s role in other settings.

Select the services for the extension. Click Edit to modify the current
user privilege or click New to configure a new one.

For more information on user privilege, see Configuring user privileges
on page 140.

Select the department that the extension belongs to. Click Edit to
modify the current department or click New to configure a new one.
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Survival branch

For more information on extension department, see Configuring agents
on page 246.

Select the local survival branch FortiVoice unit for the extension if the
extension is in a local survivability network.
Click Edit to modify the current branch unit.
For more information, see Configuring local survivability on page 156.

CallerID If you do not enter the caller IDs, your organization's main number will be used. If you add
both IDs, the emergency ID will only be used when making emergency calls. All other calls
will use the external caller ID.

External caller ID

Emergency caller
ID

Authentication

Authentication
type
LDAP profile

User password

Personal code

Voicemail PIN

Enter the external caller ID that displays on a called phone when you
make a call. Use the name<phone_number> format, such as John
Doe<222134>.

Enter the caller ID that displays on a called phone when you make an
emergency call. Use the name<phone_number> format, such as John
Doe<222134>.

Select the extension’s authentication type: Local or LDAP.

If you select LDAP for Authentication type, select an LDAP profile to
apply to this extension. For information on LDAP profile, see Configuring
LDAP settings on page 124.

You can click New to create a new profile or Edit to modify the selected
one.

If you selected Local as the Authentication type, enter the password for
user portal access. This password can be much longer and stronger to
mitigate the risk of password guess attack and preserve the voicemail
PIN for phone access only.

To let the system create the user password, click Generate.
To show the user password, click the eye icon.

Control of using user password or voicemail PIN to access user portal is
set when configuring phone system capacity. For more information, see
Configuring system capacity on page 114.

Enter the extension specific account code that can be used to restrict
calls. This code is needed to make some restricted calls.

You can click Generate to get a code.

Enter the password for the extension user to access voicemail and the
user portal.

Selection of using personal password or voicemail PIN to access user
portal is set when configuring phone system capacity. For more
information, see Configuring system capacity on page 114.

You can check the PIN strength. See Reviewing system configuration
on page 153.
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Main Device

Preference

Notifications

Click Generate to generate a strong password automatically. Select the
view PIN icon to display the password.

If you have configured the default user PIN (see Default Voicemail PIN
on page 113), the password appears here. However, you can change it.

Main extension SIP devices include desktop phones and soft phones.

SIP settings

Emergency zone

Location

SIP password

Phone language

Web language
Time zone
Idle timeout

Ring duration

Missed call

Voicemail

Select the SIP profile for the phone. You can add a new profile or edit a
selected one.

For more information, see Configuring SIP profiles on page 131
Select the emergency zone profile for the phone. You can add a new
profile or edit a selected one.

For more information, see Configuring emergency zone profiles on
page 145.

Select Internal if the phone does not traverse through Network Address
Translation (NAT) to connect to the FortiVoice unit, and External if the
phone does. These are system defined locations.

Enter the password used for configuring your SIP phone from the phone
or the Web. You need the phone's IP to access it from the Web.

You can check the password strength. See Reviewing system
configuration on page 153.

Select Auto generate to let the system generate the password.

Select Default if you have configured the default SIP user password (see
Default SIP user password on page 112). In this case, the password
appears here. However, you can change it.

Select Specific to enter the password manually, or click Generate to
generate a strong password automatically. Select the eye icon to display
the password.

Select the prompt language for the extension. The default is English.

For information on adding prompt languages, see Managing phone
audio settings on page 119.

Select the language for the FortiVoice user portal.
Select the time zone for the FortiVoice user portal.
Set the timeout for the FortiVoice user portal.

Enter the phone ringing duration in seconds before an incoming call
goes to voicemail.

Select Enabled if you want to receive an email notification when an
incoming call is missed.

Select the type of email notification when this extension has a voicemail:
« None: Do not send any notification.
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« Simple: Send an email notification.
« With attachment: Send an email notification with the voicemail
attached.

Fax Select the type of email notification when this extension has a fax:
« None: Do not send any notification.
« Simple: Send an email notification.
« With attachment: Send an email notification with the fax attached.

6. Click Next, then Apply.

Auditing SIP extension password

You can verify the strength of SIP extension passwords. For information on setting SIP extension password, see
Configuring IP extensions on page 164.

To audit a SIP extension password

1. Goto Extension > Extension > |P Extension.

2. Under Actions, click Password Auditor.
The Password Auditor page opens.

3. If a password policy warning (yellow warning mark) appears, click the warning to view the password policy. To set
the policy, see Setting password policies on page 160.

4. |f the password strength of an extension shows the Weak (black check mark) icon, you can click the password and
change it based on the policy until the password strength shows the Strong (green check mark) icon.

5. Click Close.

Auditing extension numbers and MAC addresses

You can find and modify the duplicate extension numbers and conflicting MAC addresses.
Duplicate numbers occur when there are more than one extension with the same number.
Conflicting MACs occur when there are more than one extension associated with a MAC address.
To audit SIP extension numbers

1. Goto Extension > Extension > |P Extension.
2. Under Actions, click Number Auditor> Numbers.

The Number page opens and lists the duplicate numbers, if any.
3. Select the number you want to remove and click Edit.

The duplicate number’s configuration page displays.

4. Remove the duplicate number in the Number field and click OK.
For information on extension numbers, see Configuring IP extensions on page 164.
To audit extension MAC addresses

1. Goto Extension > Extension > IP Extension.
2. Under Actions, click Number Auditor> MACs.
The Conflict MAC page opens and lists the multiple extensions on a single MAC address, if any.
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3. Select the number you want to remove and click Edit.
4. Onthe IP Extension page, go to Device Setting > Device.
5. Click the Select icon and click Select None at the bottom of the page.

Importing a list of extensions

The import feature provides a simple way to add a list of new extensions in one operation. You can create a CSV file in
any spreadsheet and import the data as long as the columns match the FortiVoice format.

Your CSV file must have a headline containing the column names such as User ID,
Extension, Display name, Phone type, Mac address, and Phone profile. Otherwise, the

import will fail.

To import extension records

1. Onthe IP Extension tab, click Actions > Import.
2. Browse for the extension list file.

Configuring SIP forking

SIP forking allows you to have your desk phone ring at the same time as your softphone or a SIP phone on your mobile.
When a device is added, it inherits your primary phone’s user privileges except hot-desking and fax.

You can add two SIP extensions and one external phone number.

To add a SIP device

1. Goto Extension > Extension > IP Extension.
2. Double-click an extension and go to Device Setting > Auxiliary Phone.

FortiVoice Phone System 6.4.3 Administration Guide 179
Fortinet Technologies Inc.



Configuring extensions

3. Click New and configure the following:

GUI field Description

Type If your device is a FortiFone, configure the following:

« Device: Click the Select icon to choose a FortiFone and click OK. The
phones are configured for SIP inventory. See Configuring desktop
phones on page 147.

You may also add a new phone or edit an existing one.

« Phone model: This option appears after you select a device.

« Phone profile: This option appears after you select a device. Select the
phone profile for the extension. For information on phone profile, see
Configuring phone profiles on page 134.

« Setting: If you select Custom, configure the following:

« SIP settings: Select the SIP profile for the extension. Click Edit to
modify the current profile or New to configure a new one. For more
information, see Configuring SIP profiles on page 131.

« Emergency Zone: Select the emergency zone profile for this
extension. Click Edit to modify the current profile or New to configure
a new one. For more information, see Configuring emergency zone
profiles on page 145.

« Location: Select Intemnal if the phone does not traverse through
Network Address Translation (NAT) to connect to the FortiVoice unit,
and External if the phone does. These are system defined locations.

o Handset ID: If the device is a FortiFone-870i that supports multiple
handsets, enter or click Generate to identify the handset.

« MWI/ (Message Waiting Indication): Enable or disable MW!I on the
phone.

« Auto answer. Enable or disable automatic answering on the phone.

o Direct call: Enable or disable direct calling on the phone.

If your device is a Generic phone, configure the following:

« SIP settings: Select the SIP profile for the extension. Click Edit to modify
the current profile or New to configure a new one. For more information,
see Configuring SIP profiles on page 131.

« Emergency Zone: Select the emergency zone profile for this extension.
Click Edit to modify the current profile or New to configure a new one. For
more information, see Configuring emergency zone profiles on page 145.

4. Click Create.

Modifying managed extensions

FVG-GS16 is a FXS gateway with 16 ports. When it is added to the FortiVoice unit, 16 extensions are generated. You
can modify each of the 16 extensions.

You can also view the local survivability branch paging numbers and change its password.
For information on adding the gateway, see Managing FXS gateways on page 155.

For information on configuring local survivability branches, see Configuring local survivability on page 156
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To edit a GS16 or local survivability branch extension

1. Go to Extension > Extension > Managed Extension.
2. In Gateway device, select:

« the GS16 gateway of which you want to modify the extension, or

« thelocal survivability branch of which you want to modify the paging number.
3. Select the extension or paging number and click Edit.

4. If you selected a local survivability branch paging number, you can view the information, enter the display name,
and change the password. If you selected a GS16 gateway extension, configure the following:

GUI field Description

Number Enter the extension number following the extension number pattern. See
Configuring PBX options on page 111.

Edit Preference Click to configure the extension user preferences. See Setting extension user
preferences on page 186.

User ID This is the system-generated ID based on the user ID prefix you set (see User
ID prefix on page 113) and the extension number.

This option is view only and only appears when you edit an extension. You can
add a new user ID through the CLI.

Enable Select to activate the extension.

Display name Enter the name displaying on the extension. This is usually the name of the
extension user.
Click the + sign if you want to add caller IDs:

o External caller ID: Enter the external caller ID that displays on a called
phone when you make a call. Use the name<phone number> format,
such as HR<222134>.

o Emergency caller ID: Enter the emergency caller ID. Use the
name<phone number> format, such as HR<222134>.

If you do not enter the caller IDs, your organization's main number will be
used. If you add both IDs, the emergency ID will only be used when making
emergency calls. All other calls will use the external caller ID.

Description Enter any notes for the extension.
Device Setting See Managing FXS gateways on page 155.
User Setting See User Setting on page 171

5. Click OK.

Modifying analog extension (200D-T, 1000E-T, and 20E2 models only)

The FortiVoice 200D-T and 1000E-T each has one analog port and a default analog extension. The FortiVoice 20E2 has
two analog ports and two default analog extensions.You can edit the extensions’ default configuration.

Analog lines, also referred to as POTS (Plain Old Telephone Service), are used for standard phones, fax machines, and
modems.

To view the default analog extension, go to Extension > Extension > Analog Extensions.
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Maintenance Select an extension and click this button to manage its voicemail box. You can
check the size of the box and empty the box.

Click Back to return to the Analog tab.

Enabled Select to activate the extension.
Number The analog extension number.
Display Name The name displaying on the extension.

To edit the default analog extension

1. Goto Extension > Extension > Analog Extensions.
2. Select the default extension and click Edit.
3. Configure the following:

GUI field Description

Number Enter the extension number following the extension number pattern. See
Configuring PBX options on page 111.
If required, click Edit Preference to modify the user preferences. See Setting
extension user preferences on page 186

User ID This is the system-generated ID for the extension and is read-only.

Analog port Select the analog port for the extension. You can click Edit to modify the port.
Enable Select to activate the extension.

Display name Enter the name displaying on the extension. This is usually the name of the

extension user.

Click the + sign if you want to add caller IDs:

o External caller ID: Enter the external caller ID that displays on a called
phone when you make a call. Use the name<phone number> format,
such as HR<222134>.

o Emergency caller ID: Enter the emergency caller ID. Use the
name<phone number> format, such as HR<222134>.

If you do not enter the caller IDs, your organization's main number will be
used. If you add both IDs, the emergency ID will only be used when making
emergency calls. All other calls will use the external caller ID.

Description Add any notes for the extension.
User Setting See User Setting on page 171.
4. Click OK.
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Setting up remote extensions

A remote extension reaches an external phone by automatically selecting a line from a trunk and dialing the phone
number. For example, a remote extension could reach an employee’s cell phone or home phone, or a phone at a branch
office.

A caller can connect to a remote extension through the auto attendant, or can be transferred to a remote extension by a
call cascade. A user at a local extension can manually transfer a caller to a remote extension, or can dial a remote
extension directly. If the remote extension is busy or unanswered, the system can route the call using the remote
extension’s call cascade.

For example, a caller reaches the auto attendant and dials a local extension. The user is not there, so the call is
unanswered. The call cascade of the local extension can be configured to transfer unanswered calls to a remote
extension. The remote extension can be configured to dial the user’s cellular phone. This way the user is available
outside the office.

Remote extensions are designed to operate with local major telephone service providers. The feature may not function
correctly with some telephone and mobile operator’s networks, especially for international phone numbers and mobile
phones roaming internationally.

To configure a remote extension

1. Goto Extension > Extension > Remote Extension.
2. Click New.
3. Configure the following:

GUI field Description

Enabled Select to activate the remote extension.

Number Enter the local extension number from which calls are transferred to a remote
extension.

Remote number Enter the remote phone number to which a call to the local extension is

transferred. You can enter digits 0-9, space, dash, comma, # and *.

If you want to enter an auto attendant number followed by an extension, you
can use comma (,) or semicolon (;) to pause the automatic dialing.

A comma pauses dialing for two seconds, for example, 1-123-222-1234,
5678#. In this case, once auto attendant 1-123-1234 is dialed, and after two
seconds, extension 5678 is automatically dialed.

A semicolon pauses dialing for one second, for example, 1-123-222-1234;
5678%#. In this case, once auto attendant 1-123-1234 is dialed, and after one
second, extension 5678 is automatically dialed.

Display name The name displaying on the remote extension when a call is transferred.

You can choose to display the name differently than the one you entered here.
See Modifying caller IDs on page 132.
Click the + sign if you want to add caller IDs:
« External caller ID: Enter the external caller ID that displays on a called
phone when a call is transferred through the remote extension. Use the
name<phone number> format, such as HR<222134>.

« Emergency caller ID: Enter the emergency caller ID. Use the
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GUI field Description

name<phone number> format, such as HR<222134>.
If you do not enter the caller IDs, your organization's main number will be
used. If you add both IDs, the emergency ID will only be used when making
emergency calls. All other calls will use the external caller ID.

Description Enter any notes you have for the extension.

User Setting See User Setting on page 171.

4. Click Create.

Configuring fax extensions

If you want to continue using your fax machine with the VolP phone system, connect the fax machine to an adapter
(such as OBIHAI OBi 200, Cisco SPA 112, or Grandstream HT 702) that supports T38 first before connecting it to the
FortiVoice unit. T38 is a protocol designed to allow fax to travel over a VolP network.

In this case, the fax machine is treated like an extension. The FortiVoice unit receives faxes and relays them to the fax
machine. Faxes sent from the fax machine will follow the fax sending dial plans.

To use this option, you need to create and enable the fax extensions first. You then need to configure the FortiVoice unit
to receive and relay the faxes to the fax machine.

For information on fax configuration, see Configuring fax on page 295.
To create or edit a fax extension

1. Go to Extension > Extension > Fax Extension.
2. Click New or double-click an existing extension.
3. Configure the following:

GUI field Description

Enabled Select to enable this extension to receive and send faxes that support T38
protocol. This applies to using a fax machine connected to the FortiVoice unit
via an adapter that supports T38 protocol. For more information, see
Configuring fax on page 295.

Number Enter the extension number following the extension number pattern. See
Configuring PBX options on page 111.

User ID This is the system-generated ID based on the user ID prefix you set (see User
ID prefix on page 113) and the extension number.

This option is view only and appears when you edit an extension. You can add
a new user ID through the CLI.

Display Name Enter the name displaying on the extension.
Description Enter any notes about the extension.
Device Setting o SIP settings: Select the SIP profile for the phone.
Click the New icon to add a new profile. See Configuring SIP profiles on
page 131.
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GUI field Description

Click the Edit icon to modify a selected profile.

« Emergency zone: Select the emergency zone profile for the phone.
Click the New icon to add a new profile. See Configuring emergency
zone profiles on page 145.

Click the Edit icon to modify a selected profile.

« Advanced: Double-click to open the configuration page and click OK after
completing the task.

o SIP password: Enter the password used for configuring your SIP
phone from the phone or the Web. You need the phone's IP to
access it from the Web.

Click Generate to generate a strong password automatically. Select
View password to display the password.
If you have configured the default SIP user password (see Default
SIP user password on page 112), the password appears here.
However, you can change it.
« Location: Select Intemnal if the phone does not traverse through Network
Address Translation (NAT) to connect to the FortiVoice unit, and External
if the phone does. These are system defined locations.

User Setting
Management Configure the extension’s role in other settings.
User privilege Select the services for the extension. Click Edit to modify the current user
privilege or click New to configure a new one. For more information on user
privilege, see Configuring user privileges on page 140.
Department Select the department that the extension belongs to. Click Edit to modify the
current department or click New to configure a new one. For more information
on extension department, see Configuring agents on page 246.
Web Access Configure user portal and softclient access from mobile or desktop devices.

Authentication type Select the extension’s authentication type: Local or LDAP.

User password If you selected Local as the Authentication type, enter the password for user
portal access. This password can be much longer and stronger to mitigate the
risk of password guess attack and preserve the voicemail PIN for phone access
only.

To let the system create the user password, click Generate.
To show the user password, click the eye icon.

Control of using user password or voicemail PIN to access user portal is set
when configuring phone system capacity. For more information, see
Configuring system capacity on page 114.

LDAP profile If you select LDAP for Authentication type, select an LDAP profile to apply to
this extension. For information on LDAP profile, see Configuring LDAP
settings on page 124.

You can click New to create a new profile or Edit to modify the selected one.
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GUI field Description

Authentication ID If you select Try common name with base DN as bind DN as the user
authentication option in the authentication profile you select, enter the
authentication ID based on the user objects’ common name attribute you
entered in the Common name ID field of the profile, such as jdoe.

If you select Search user and try bind DN as the user authentication option in
the authentication profile you select, leave this field blank.

This option is only available if you select LDAP for Authentication type.
Phone Access Configure voicemail access by phone or access to restricted phone calls.
Voicemail PIN If you have configured the default user PIN (see Default Voicemail PIN on

page 113), the password appears here. However, you can change it.

Enter the password for the extension user to access voicemail and the user
portal.

Selection of using personal password or voicemail PIN to access user portal is
set when configuring phone system capacity. For more information, see
Configuring system capacity on page 114.

Click Generate to generate a strong password automatically. Select the view
PIN icon to display the password.

Personal code Enter the extension specific account code that can be used to restrict calls.
This code is needed to make some restricted calls.

You can click Generate to get a code.

4. Click Create (for new extension) or OK (for editing extension).

Setting extension user preferences

Each SIP and analog extension comes with its default user preferences, including voicemail setting and phone display
preference. You can modify these settings.

Phone users can modify the preferences on the user portal.

To view the list of extensions, go to Extension > Extension > Preference.

GUI field Description

Maintenance Select an extension and click this option to reset the user preferences and voice
messages to the default values.

Number The extension number.

Display name The name displaying on the extension. This is usually the name of the extension
user.

Voice Message Count The number of voice mails left on an extension.

To edit extension user preferences

1. Goto Extension > Extension > Preference.
2. Select an extension and click Edit.
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3. Configure the following:

GUI field Description

Setting
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Number

User ID

Display name

Emergency caller ID

External caller ID

Ring duration

Programmable keys

Call forward

Call waiting

Do not disturb

Voicemail handling
(Caller presses 0
during
announcement)

The extension number. This is read-only.

This is the system-generated ID based on the extension number.
You can add a new user ID through the CLI.

This is read-only.

The name displaying on the extension. This is usually the name of

the extension user.
This is read-only.

The caller ID to display on the destination phone when you dial the
emergency number, such as 911. This ID is set when you
configure the extension.

This is read-only.

The caller ID you want to display on a called phone instead of the
FortiVoice main number (see Main number on page 110) or the
trunk phone number (see Phone Number on page 209). This ID is
set when you configure the extension.

This is read-only.

Enter the phone ringing duration in seconds before an incoming

call goes to voicemail.

The range is from 6 to 1800 seconds inclusive.

Select the keypad profile for the phone.

Click the Edit icon to modify a selected profile. See Configuring
programmable keys profiles on page 137.

Select to forward phone calls and enter the phone number to
forward the calls. This function only works if call forwarding is
enabled in the extension’s user privilege. See Configuring user
privileges on page 140.

Select to enable call waiting. This function only works if call waiting
is enabled in the extension’s user privilege. See Configuring user
privileges on page 140.

Select to enable DND. This function only works if DND is enabled
in the extension’s user privilege. See Configuring user privileges

on page 140.

Select to enable reaching the operator by pressing 0 when you
hear the announcement of a callee’s voicemail.
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GUI field Description

Include caller ID Select to announce caller’s ID when playing the voicemail.
number when

playing voicemail

message

Include date and Select to announce date and time when playing the voicemail.

time when playing
voicemail message

Notification Options

Voicemail Select the type of email notification when this extension has a
voicemail:
« None: Do not send any notification.
« Simple: Send an email notification.
o With attachment: Send an email notification with the
voicemail attached.

Fax Select the type of email notification when this extension has a fax:
« None: Do not send any notification.
« Simple: Send an email notification.
« With attachment: Send an email notification with the fax
attached.

Missed call Select On if you want to receive an email notification when an
incoming call is missed.

Email address Enter the email address to which an email notification is sent.

Voicemail Options Configure greeting, unavailable, and busy messages.
Name: Your name of the voicemail. For example, John Doe.
« Standard: Use the system default name for the voicemail.
This will be the extension number.
« Personal: Use your own name for the voicemail.

« Click Call me to ring your extension and record a name
using the phone, such as your name or extension
number.

o Click Upload to import a name, such as your name or
extension number.

o Click Play to listen to a recorded name.

« Click Erase to delete a recorded name.

o Click Download to save a recorded name.

Greeting: Select the voicemail greeting mode and greeting
content.
« Standard: The system defined greeting.
« Simple: The customer-recorded greeting that applies to any
time except when the line is busy and extension is
unavailable.
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GUI field Description

Display Preference

Phone language

Web language

Theme

Time zone

Idle timeout
Account Management

Change PIN Number

Change User
Password
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« Scheduled: The customer-recorded greeting that comes with
a schedule.

« Conditional: The customer-recorded greeting that only
applies to occasions when the line is busy or extension is
unavailable.

« Audio file: Click to configure the greeting. This option is only
available when you select Simple, Scheduled or Conditional.

o Click Call me to ring your extension and record a
message such as a greeting, unavailable, or busy
message using the phone. This applies to the Simple
and Scheduled modes.

o Click Upload to import a message such as a greeting,
unavailable, or busy message.

« Click Play to listen to a message such as a greeting,
unavailable, or busy message.

o Click Erase to delete a message such as a greeting,
unavailable, or busy message.

« Click Download to save a message such as a greeting,
unavailable, or busy message.

Greeting file: Select the greeting file if you have uploaded a file by
clicking Audio file. This option is only available when you select
Simplefor Greeting. For information on greeting files, see
Managing phone audio settings on page 119

If you select Scheduled for Greeting, click New to add a system
schedule or create a new one.

Configure the preference for screen display on the user portal.

Select the prompt language for the extension. The default is
English.

For information on adding prompt languages, see Managing
phone audio settings on page 119.

Select the language for the FortiVoice user portal.
Select the display theme for the FortiVoice user portal.
Select the time zone for the FortiVoice user portal.

Set the timeout for the FortiVoice user portal.

Click to change the password for accessing the voice mailbox and
the FortiVoice user portal.

Click to change the password for accessing the FortiVoice user
portal.
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GUI field Description

Agent

Follow Me

Call Handling

Twinning Setting
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View Sip
Configurations

PIN required to
login/logout from
phone

PIN required to
pause/unpause from
phone

Auto-Pause after
agent login queue

Click to display the SIP configuration information which is used for
configuring your SIP phone from the phone or the Web.

This option appears if you have a call center license.

Select to enable an agent to log into/log out of a queue from the
extension using the user PIN.

For information on feature access codes, see Configuring account
codes on page 162.

Select to enable an agent to pause/unpause a queue from the
extension using the user PIN. To pause means the agent is not
answering calls.

For information on feature access codes, see Configuring account
codes on page 162.

Select to automatically put the agent in pause (not ready) status
after the agent logs into a queue. The agent can unpause a queue
to answer calls.

For information on feature access codes, see Configuring account
codes on page 162.

See Configuring follow me settings on page 191.

Retain original caller ID: Select to maintain the original caller's
identity when forwarding an inbound call.

Call screening: Select if you want the FortiVoice unit to prompt
callers for their names so that callees can identify the callers
before the connect to you.

Record caller name: By default, this option is selected when you
select Call screening. If you deselect this option, the FortiVoice
unit will not prompt callers for their names. Instead, the FortiVoice
unit will ring a called phone but will not connect to the caller. The
callee is able to pick up the phone and see the caller's ID and
decide whether to pick up the call.

For more information on normal or quick call handling, see
Handling calls on page 191.

This option is only available if Twinning is selected in the user
privileges of the extension. For more information, see Twinning on
page 141.

Setting: Select the twinning method.

Disabled: Select to disable twinning.

Simple: Select to configure a basic twinning by adding a
phone number.

Scheduled: Select to configure a twinning by adding phone
numbers based on a schedule.
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4. Click OK.

Configuring follow me settings

Follow me allows a call to an extension to be transferred to another destination when you are not available.
This configuration serves as a profile for use in managing calls. See Handling calls on page 191.
To configure follow me Setting

Go to Extension > Extension > Preference.

Double-click a record and go to Follow Me.

Click New.

Enter a Name for this setting.

Under Follow Me Numbers, click New.

Enter a phone number to which the call to your extension can be transferred.

Enter the phone ringing duration, in seconds, before the call goes to voicemail or next number in the sequence.
Click Create.

Repeat steps 4 to 7 of this procedure to add more numbers if you want to transfer a follow me call to multiple
numbers in a sequence. The numbers will be dialed according to the sequence in the follow me setting.

Click Create.

© o NGO R®DN=
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Handling calls

Extension > Extension > Preference > Call Handling allows you to manage the call process. For example, you can
configure the process to forward a call to another number on a specific schedule.

You can manage a normal call handling by configuring the call process for different situations. You can also manage
quick call handling by dialing a code to enter into a default mode and configure the call process for that particular mode
if required.

If the extension with configured call handling action is part of another FortiVoice function that also has configured call
handling action (for example, a member of a ring group or used for a virtual number), then the call handling action of the
other FortiVoice function overrides the extension call handling action.

To handle a normal call

1. Go to Extension > Extension > Preference.

2. Double-click a record and go to Call Handling.
3. Click Normal Call Handling.
4

Select a call status on top of the screen.
Each status can only be used for one call management configuration.

5. Keep System default action or select User defined.
The System default action (action shows in brackets) changes depending on the status selection.

6. If you select User defined, click New to define a call process according to a schedule.

« Select a pre-configured Schedule for the call action. You can click View to display the schedule details. For
information on configuring schedules, see Scheduling the FortiVoice unit on page 146.

« For Call from, select the call type on which you want to take an action.
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o Add an Action for the call process.
For some call handling processes that may require further actions, you need to add one or more call processes
to complete the call handling. For example, after adding a process that contains a Forward action, you can
add another process with a Go voicemail action to complete the call handling. In this case, the call will be
forwarded to the phone specified and if the phone is not picked up, a voicemail will be left on this extension.
Default action is equal to the action when you select System default action under Call Process.

« If you select Follow me, select a follow me profile. For information on configuring follow me, see Follow
Me on page 190.
This option is available only if call forwarding is enabled in the extension’s user privilege. See Configuring
user privileges on page 140.

« If you select Play announcement, select a sound file. For information on configuring sound files, see
Managing phone audio settings on page 119

« If you select Auto attendant, select an auto attendant profile. For information on configuring auto
attendant, see Configuring auto attendants on page 272.

« fyou select Forward, enter the number to which you want to forward the call.
This option is available only if call forwarding is enabled in the extension’s user privilege. See Configuring
user privileges on page 140.

o Click Create.
7. Click OK.

To handle a quick call

1. Go to Extension > Extension > Preference > Call Handling > Quick call handling.
2. Double-click a record and go to Call Handling > Quick call handling.

GUI field Description

Effective mode Displays the call handling status when you dial *720, *721, *722, and *723.

For example, if you dial *720, the status will be Normal because you have
canceled the quick mode.

*720 Dial the code to cancel the quick handling mode.

*721 Dial the code to set to Out of office mode. Click the text to modify the quick
mode option and time as required.

*722 Dial the code to set to Away mode. Click the text to modify the quick mode
option and time as required.

*723 Dial the code to set to Other mode. Click the text to modify the quick mode
option and time as required.

3. If you want to add a new quick call handling process, click Quick Call Handling.

4. Select a call status.
Each status can only be used for one call management configuration.

5. Click New to define a call process according to a schedule.

» Select a pre-configured Schedule for the call action. You can click View to display the schedule details. For
information on configuring schedules, see Scheduling the FortiVoice unit on page 146.

« Add an Action for the call process. You can add multiple actions to process a call in sequence. For example,
you can add Play announcement and then Auto attendant. In this case, an incoming call will be transferred to
the auto attendant after an announcement is played.
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6.

« Default action is equal to the action when you select System default action under Call Process.
« If you select Follow me, select a follow me profile. For information on configuring follow me, see Follow
Me on page 190.
This option is available only if call forwarding is enabled in the extension’s user privilege. See Configuring
user privileges on page 140.

« If you select Play announcement, select a sound file. For information on configuring sound files, see
Managing phone audio settings on page 119

« If you select Auto attendant, select an auto attendant profile. For information on configuring auto
attendant, see Configuring auto attendants on page 272.

« If you select Forward, enter the number to which you want to forward the call. This option is available only
if call forwarding is enabled in the extension’s user privilege. See Configuring user privileges on page 140.

o Click Create.
Click OK.

Creating extension groups

Extension > Group lets you configure extension groups including user groups, extension departments, ring groups,
page groups,message groups, pickup groups, and business groups.

This section contains the following topics:

Creating user groups on page 193

Creating extension departments on page 194
Creating ring groups on page 194

Creating paging groups on page 196

Creating multicast paging groups on page 197
Creating message groups on page 198
Creating pickup groups on page 199

Creating business groups on page 199

Creating user groups

You can create a user group and use it to simplify the configuration of an IP extension voice mailbox, a general voice
mailbox, a ring group, a page group, or a pickup group. For example, when creating a ring group, you can select the
name of a user group rather than entering each user name individually.

For information on creating IP extension voice mailboxes, see Configuring IP extensions on page 164.

For information on creating general voice mailboxes, see Setting up general voice mailboxes on page 200.

To create a user group

1.

2.
3.
4

Go to Extension > Group > User Group.
Click New.
Enter a name for the group.

Optionally, select a department from which you want to configure a user group. For information on extension
department, see Creating extension departments on page 194.

For Members, click in the field and select the available users or user groups that you want to include in the group.
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6. Click Close.
7. Click Create.

Creating extension departments

You can create department profiles for applying to the extensions. For example, you can create a department profile
called HR and apply it to extension 1111 to indicate that this extension belongs to the HR department.

For information on applying department profiles, see Setting up local extensions on page 164.

To create an extension department

1.

o~ oODd

Go to Extension > Group > Department.

Click New.

In the Name field, enter the name of the department.

In the Comment field, enter any notes you have for this department.

If you have the call center license, the Call Center section appears. For information on call centers, see Setting up
a call center on page 235.

a. To set up a call center manager group, under Manager, click in the field and select the available users or user
groups that you want to include in the group. Click Close.

b. To set up a call center member group, under Member, click in the field and select the available users or user
groups that you want to include in the group. Click Close.

c. To set up acall center queue group, under Queue, click in the field and select the available users or user
groups that you want to include in the group. Click Close.

Click Create.

Creating ring groups

Aring group is a group of local extensions and external numbers that can be called using one number. Local extensions
and auto attendants can dial a ring group.

Aring group can reach a group of extensions. For example, ring group 301 can ring the sales group at extensions 111,
112, 113, and 114. When a customer calls the sales group, the first available salesperson answers for the group.

To create a ring group

1.

Go to Extension > Group > Ring Group.

2. Click New.
3. Configure the following:

GUI field Description

Name Enter the name for the ring group.
Number Enter the ring group number following the extension number pattern. See
Configuring PBX options on page 111.

Clicking in the field displays a list of crossed-out extensions. These numbers
are already used and cannot be used as ring group numbers.

The ring group number, once dialed, will ring all the extensions in the group.
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GUI field

Display Name

Enable

Ring mode

Department

Members

External numbers

Normal Call Handling

Advanced Setting

4. Click Create.

Description

Enter the name displaying on the extensions of the ring group, such as “HR”.

Select to activate the ring group.

Select how you want the ring group to be called.

All: All extensions in the group will ring when the ring group number is
dialed.

Sequential: Each extension in the group is called one at a time in the
order in which they have been added to the group. You can set a timeout
period for each ring.

Select the department to which this group belongs.

Click in the field and select the available extensions or user groups that you
want to include in the ring group.

For information on creating extensions and user groups, see Setting up local
extensions on page 164 and Creating extension groups on page 193.

Click New to add an external phone number to the ring group. For example,
you can add the number of a remote employee to a ring group.

Use this option to configure the call handling for the ring group when you edit a

ring group. For more information, see Configuring ring group call handling on
page 195.

Ring Pattern: Select a ring pattern for the group.

Ring duration: Set the amount of time in seconds allowing all extensions
or each one to ring before going to voicemail.

Early media: Select the ring tone for the group. For creating new sound
files, see Managing phone audio settings on page 119.

Caller ID option: Select how you want the caller ID to display.

Retain original caller ID: Select to keep the original caller ID.

Call waiting: Select to enable call waiting.

Emergency call option: Select Display emergency caller ID to show the
emergency caller’s ID, or Disconnect ongoing call to stop a call that uses
the line for emergency call.

Missed call notification: Select to send a notification email when a call is
missed. Enter the email address for the notification.

Configuring ring group call handling

Use the Normal Call Handling option to configure the call automation. For example, you can configure the process to

forward a call to another number on a specific schedule.

You can only configure ring group call handling when editing a ring group.

If the ring group with configured call handling action is part of another FortiVoice function that also has configured call
handling action (for example, a member of another ring group or the ring group extension is used for a virtual number),

then the call handling action of the other FortiVoice function overrides the ring group call handling action.
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For information on the Normal Call Handling option, see Normal Call Handling on page 195.

To configure the call process

1.

On the Ring Group page, click Normal Call Handling.

2. Select a call status.

3.

4.

Each status can only be used for one call management configuration.

For the Busy status, if you set the ring group’s ring mode to All, the FortiVoice unit will declare the ring group busy
only if all extensions in the group are busy; if you set the ring group’s ring mode to Sequential, the FortiVoice unit
will declare the ring group busy only if the last extension in the group is busy after ringing the extensions
sequentially and each one is busy at the time of being rung.
The System default action changes depending on the status selection.

If you select User defined, click New to define a call process according to a schedule.

« Select a pre-configured Schedule for the call action. You can click View to display the schedule details. For

information on configuring schedules, see Scheduling the FortiVoice unit on page 146.

« Add an Action for the call process. You can add multiple actions to process a call in sequence. For example,
you can add Play announcement and then Auto attendant. In this case, an incoming call will be transferred to
the auto attendant after an announcement is played.

Default action is equal to the action when you select System default action under Call Process.
« If you select Voicemail, enter the extension number of the voice mail.

« If you select Play announcement, select a sound file. For information on configuring sound files, see
Managing phone audio settings on page 119

« If you select Auto attendant, select an auto attendant profile. For information on configuring auto
attendant, see Configuring auto attendants on page 272.
« If you select Forward, enter the number to which you want to forward the call.

This option is available only if call forwarding is enabled in the extension’s user privilege. See Configuring
user privileges on page 140.

o Click Create.
Click OK.

Creating paging groups

A paging group is a group of extensions that can be paged using one number. Paging groups require telephones that
support group paging.

A paging group can reach a group of extensions. For example, paging group 301 can ring the sales group at extensions
111, 112, 113, and 114. When a call reaches 301, all extensions in the group can pick up and answer the call.

To create a paging group

1. Go to Extension > Group > Paging Group.
2. Click New.
3. Enter a name for the group.
4. Enter the paging group number following the extension number pattern. See Configuring PBX options on page 111.
This is the number that, once paged, will ring all the extensions in the group.
5. Enter the name displaying on the extensions of the group, such as “HR”.
6. Select Enable to activate this group.
7. For Caller ID option, select how you want to display the ID of a caller to the group.
« Nochange: the caller ID will display as is.
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« Replace: the caller ID will be replaced by the Display name you set.
« Prefix: the caller ID will be prefixed with the Display name you set.

« Replace by Caller ID from IVR: the caller ID will be replaced by the IVR caller ID. For information on IVR, see
Configuring IVRs on page 246.

« Prefix with Caller ID from IVR: the caller ID will be prefixed by the IVR caller ID. For information on IVR, see
Configuring IVRs on page 246.

8. For Emergency call option, do the following:

« Select Display emergency caller ID to show the caller ID.

« Select Disconnect ongoing call to interrupt a page in progress when an emergency page comes in.
9. Select the department to which this group belongs.

10. For Members, click in the field and select the available extensions or extension groups that you want to include in
the paging group.
11. Click Create.

Creating multicast paging groups
When being applied in a message group configuration, multicast paging provides a more robust and efficient
mechanism to deliver audio and text messages to larger page groups.
For more information on message groups, see Creating message groups on page 198.
To create a multicast paging group

1. Go to Extension > Group > Multicast Paging G