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Change log

Change log
Date

Change Description

March 4, 2019

Added a new section within Remote authentication servers detailing how to configure
an Active Directory user with the minimum privileges needed to join an AD domain.

January 24, 2019

Added missing information regarding Domain groupings and SAML authentication.
Corrected minor errors.

December 13,
2018

FortiAuthenticator 5.5 document release.

November 29,
2019

Added information about installation switches to FortiClient SSO Mobility Agent on
page 164.
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What's new in FortiAuthenticator 5.5
The following list contains new and expanded features added in FortiAuthenticator 5.5.

SAML SP SSO: Multi-tenancy support
Multi-tenancy support is added to FortiAuthenticator, where each tenant can be a FortiGate or a specific
VDOM within a FortiGate:
l
l
l
l
l
l

SAML SP SSO supports multiple SAML SP portals
each SAML SP portal can point to a different SAML IdP
maintain multiple SSO session lists
each SSO session list contains the logged-in users for a set of domains
each SSO session list has its own IP space
IP spaces of different SSO session lists can overlap

SAML SP portals can be configured under Fortinet SSO Methods > SSO > SAML Authentication. See
SAML authentication for more information.
SSO sessions can be grouped together by selected user domains under Fortinet SSO Methods > SSO >
Domain Groupings. See Domain groupings for more information.
SSO sessions forwarded to the FortiGate or VDOM can be filtered by domain grouping under Fortinet
SSO Methods > SSO > FortiGate Filtering. See FortiGate filtering for more information.

REST API enhancements
FortiAuthenticator sees the following REST API enhancements:

Verify Security Question
Security question and password reset API is available for local and LDAP users. Using API calls, you can:
l
l
l
l

set the password recovery question and answer
read the password recovery question
verify the password recovery answer
reset the password

Certificate management API
An API is added to manage user certificates. The API can be used to renew and revoke user certificates.

REST API for syslog
RESTful API support is added for configuring syslog servers, and for configuring sending logs to a syslog server.
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See the FortiAuthenticator REST API Solution Guide for more information.

Token self-provisioning by group option relocated
The option to allow token self-provisioning by user group is relocated to Authentication > Self-service Portal
> Token self-provisioning. Token self-provisioning can also be configured from Authentication > Guest
Portals > Portals. See Token self-provisioning for more information,

User Lookup
Administrators can perform a user search to easily monitor the ongoing activity of a specific user. The User
Lookup page provides a consolidated view of a user's information and recent activities.
Searches for users can be performed under System > Dashboard > User Lookup. See User lookup for more
information.

Automated Firmware Upgrade for HA A-P Clusters
When upgrading the firmware of the active unit in an HA master cluster, the administrator has the option to
perform a coordinated upgrade of both cluster members. If BOTH is selected, the firmware upgrade is
performed on the passive unit first. Once the first upgrade is complete and the passive unit backs up and syncs
with the active unit, the firmware upgrade is performed on the active unit.
Automated firmware upgrades for HA A-P clusters can be performed under System > Administration >
Firmware Upgrade. See Firmware upgrade for more information.

Users Audit Report enhancements
Additional fields have been added to users audit reports. Reports now include fields that detail the date and
time of account creation, date and time of last login, type of token-based authentication, and token
information.
Download user audit reports under Logging > Audit Reports > Users Audit. See Users audit for more
information.

Merge Captive Portal into Guest Portals
Captive Portals have merged with Guest Portals. Existing Captive Portals will convert to a Guest Portal
configuration following a firmware upgrade. The look and function of converted portals will remain unchanged.
Guest Portals are configured under Authentication > Guest Portals > Portals. See for Guest portals more
information.
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SAML SP SSO: Select assertion for username
When configuring a SAML Identity Provider, administrators have the option to specify which SAML assertion to
extract the username from.
Configure SAML Identity Providers under Fortinet SSO Methods > SSO > SAML Authentication. See
SAML authentication for more information.

SAML SP SSO: Disclaimer agreement page
When enabled, a SAML SP SSO end-user is required to agree to a disclaimer before being redirected to the
SAML IdP for authentication.
The disclaimer agreement page is enabled under Fortinet SSO Methods > SSO > SAML Authentication.
See SAML authentication for more information.
Customize the Login Disclaimer Page and Disclaimer Denied Page under Authentication > Self-service
Portal > Replacement Messages. See Replacement messages for more information.

Wildcard MAC devices
When creating a new MAC-based authentication device, MAC addresses can be defined using wildcard
capability to allow access to all devices from a specific manufacturer. Instead of defining a full MAC address,
you define only the top 3 bytes (e.g. 11:22:33).
Define MAC addresses using wildcard capability under Authentication > User Management
> MAC Devices. See Non-compliant devices for more information.

HA maintenance mode
If maintenance needs to be performed on one of the FortiAuthenticator units in an HA master cluster, an
administrator can use maintenance mode to remove the unit from the cluster.
Maintenance mode is enabled under System > Administration > High Availability. See High availability
for more information.

Guest portals: Self-registration enhancements
FortiAuthenticator Guest Portals are enhanced to improve the flexibility of the self-registration process. When
configuring the self-registration pre-login services, administrators can:
l
l
l

allow self-registration using only SMS or only email
allow self-registration without SMS or email
allow self-registrating users to select SMS or email

Guest portal self-registration settings are configured under Authentication > Guest Portals > Portals. See
Portals for more information.
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Enhance FSSO DNS lookups
To improve FSSO DNS lookups, the behavior of the DNS cache on FortiAuthenticator can be configured under
System > Network > DNS. See DNS for more information.

Syslog matching rule for FortiNAC
FortiAuthenticator is preconfigured with a FSSO syslog matching rule for the FortiNAC. Syslog messages can
be sent from the FortiNAC when there is a device register, login, or unregister event on the network, and the
FortiAuthenticator can use these syslog messages for FSSO.
Syslog matching rules can be configured under Fortinet SSO Methods > SSO > Syslog Sources. See
Predefined rules for more information.

VMware tools
The open-vm-tools package is integrated into the VMware-based FortiAuthenticator-VM. The VMWare tools
package allows for additional features to be supported on the FortiAuthenticator-VM for the VMware server
operator. See open-vm-tools for more information.

NTP IPv6 support
Network Time Protocol (NTP) servers with an IPv6 address can be configured to synchronize the
FortiAuthenticator system time.
The FortiAuthenticator system time can be configured under System > Dashboard > Status. See
Configuring the system date, time, and time zone for more information.

CA2 certificate support
Support is added for a second firmware certificate, signed by Fortinet's CA2 (FortiAuthenticator-VM only).
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Introduction
The FortiAuthenticator device is an identity and access management solution. Identity and access
management solutions are an important part of an enterprise network, providing access to protected network
assets and tracking user activities to comply with security policies.
FortiAuthenticator provides user identity services to the Fortinet product range, as well as third-party devices.
FortiAuthenticator delivers multiple features including:
l

l

l

l

l

l

Authentication: FortiAuthenticator includes Remote Authentication Dial In User Service (RADIUS) and
Lightweight Directory Access Protocol (LDAP) server authentication methods, and Security Assertion
Markup Language (SAML), which is used for exchanging authentication and authorization data between
an Identity Provider (IdP) and a Service Provider (SP).
Two-Factor Authentication: FortiAuthenticator can act as a two-factor authentication server with support
for one-time passwords (OTP) using FortiToken Hardware, FortiToken Mobile, Short Message Service
(SMS), or email. FortiAuthenticator two-factor authentication is compatible with any system which
supports RADIUS.
IEEE802.1X Support: FortiAuthenticator supports 802.1X for use in FortiGate Wireless and Wired
networks.
User Identification: FortiAuthenticator can identify users through multiple data sources, including Active
Directory (AD), desktop client, guest portal logon, RADIUS accounting, Kerberos, and a Representational
State Transfer (REST) API. It can then communicate this information to FortiGate or FortiMail units for
use in identity based policies.
Certificate Management: FortiAuthenticator can create and sign digital certificates for use, for example, in
FortiGate VPNs and with the FortiToken 300 USB certificate store.
Integration: FortiAuthenticator can integrate with third-party RADIUS, LDAP, and SAML authentication
systems, allowing you to reuse existing information sources. The REST API can also be used to integrate
with external provisioning systems.

FortiAuthenticator is a critical system, and should be isolated on a network interface that is separated from
other hosts to facilitate server-related firewall protection. Be sure to take steps to prevent unauthorized access
to the FortiAuthenticator.
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FortiAuthenticator on a multiple FortiGate unit network

The FortiAuthenticator series of identity and access management appliances complement the FortiToken
range of two-factor authentication tokens for secure remote access. FortiAuthenticator allows you to extend the
support for FortiTokens across your enterprise by enabling authentication with multiple FortiGate appliances
and third-party devices. FortiAuthenticator and FortiToken deliver cost effective, scalable, secure
authentication to your entire network infrastructure.
The FortiAuthenticator device provides an easy-to-configure remote authentication option for FortiGate users.
Additionally, it can replace the Fortinet Single Sign-On (FSSO) Agent on a Windows AD network.
For more information about FortiTokens, see the FortiToken information page on the Fortinet web site.

Before you begin
Before you begin using this guide, please ensure that:
l

l
l
l

You have administrative access to the GUI and/or CLI.
For details of how to accomplish this, see the QuickStart Guide provided with your product, or online at
http://docs.fortinet.com/FortiAuthenticator/hardware.
FortiAuthenticator is integrated into your network.
The operation mode has been configured.
The system time, DNS settings, administrator password, and network interfaces have been configured.
Network Time Protocol (NTP) is critical for the time to be accurate and stable for
the Time-based One-time Password (TOTP) method used in two-factor
authentication to function correctly. See Configuring the system date, time, and
time zone on page 29.

l

Any third-party software or servers have been configured using their documentation.
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While using the instructions in this guide, note that administrators are assumed to have all permissions, unless
otherwise specified. Some restrictions will apply to administrators with limited permissions.

How this guide is organized
This FortiAuthenticator Administration Guide contains the following sections:
l
l

l

l

l

l
l
l

l
l
l

Setup describes initial setup for standalone and HA cluster FortiAuthenticator configurations.
System describes the options available in the System menu tree, including network configuration,
administration settings, and messaging settings.
Authentication describes how to configure built-in and remote authentication servers and manage users
and user groups.
Port-based network access control (PNAC) describes how to configure FortiAuthenticator for IEEE 802.1X
Extensible Authentication Protocol (EAP) authentication methods, Bring Your Own Device (BYOD), and
MAC-based device authentication.
Fortinet Single Sign-On (FSSO) describes how to use FortiAuthenticator in a single sign-on (SSO)
environment.
RADIUS Single Sign-On (RSSO) describes how to use FortiAuthenticator RADIUS accounting proxy.
Monitoring describes how to monitor SSO and authentication information.
Certificate management describes how to manage X.509 certificates and how to set up FortiAuthenticator
to act as a certificate authority (CA).
Logging describes how to view the logs on your FortiAuthenticator unit.
Troubleshooting provides suggestions to resolve common problems.
LDAP filter syntax outlines some basic filter syntax that is used to select users and groups in LDAP User
Import, Dynamic LDAP Groups, and Remote User Sync Rules.

Registering your Fortinet product
Before you begin configuring and customizing features, take a moment to register your Fortinet product at the
Fortinet Support website. Many Fortinet customer services such as firmware updates, technical support,
FortiGuard Antivirus, and other FortiGuard services require product registration.
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Setup
For information about installing FortiAuthenticator and accessing the CLI or GUI, refer to the Quick Start Guide
provided with your unit.
This chapter provides basic setup information for getting started with your FortiAuthenticator device. For more
detailed information about specific system options, see System on page 26.

Initial setup
The following section provides information about setting up the virtual machine (VM) version of
FortiAuthenticator.

FortiAuthenticator VM setup
Before using FortiAuthenticator-VM, you need to install the VMware application to host the FortiAuthenticatorVM device. The installation instructions for FortiAuthenticator-VM assume you are familiar with VMware
products and terminology.

System requirements
FortiAuthenticator-VM is compatible with HyperV Windows Server 2012 and 2016. For information on the
FortiAuthenticator-VM system requirements, please see the FortiAuthenticator datasheet.
FortiAuthenticator-VM has kernel support for more than 4GB of RAM in VM images.
However, this support also depends on the VM player version. For more information,
see http://kb.vmware.com/selfservice/microsites/search.do?language=en_

US&cmd=displayKC&externalId=1014006
The default Hardware Version is 4 in order to support the widest base of VM players.
However you can modify the VM Hardware Version by editing the following line in the
FortiAuthenticator-VM.vmx file:

virtualHW.version = "4"

FortiAuthenticator 5.3+ includes a KVM image for loading onto KVM servers, such as
Linux running Virtual Machine Manager, and on FortiHypervisor.

FortiAuthenticator-VM image installation and initial setup
The following procedure describes setup on VMware Fusion.

FortiAuthenticator 5.5.0 Administration Guide
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To set up the FortiAuthenticator VM image:
1. Download the VM image zip file to the local computer where VMware is installed.
2. Extract the files from the zip file into a folder.
3. In your VMware software, go to File > Open.
4. Navigate to the expanded VM image folder, select the FortiAuthenticator-VM.vmx file, and select
Open.
VMware will install and start FortiAuthenticator-VM. This process can take a minute or two to complete.
5. At the FortiAuthenticator login prompt, enter admin and press Enter. By default, there is no password.
6. At the CLI prompt enter the following commands:
config system interface
edit port1
set ip <ip-address>/<netmask>
set allowaccess https ssh
next
end
config router static
edit 0
set device port1
set dst 0.0.0.0/0
set gateway <ip-gateway>
next
end

Substitute your own desired FortiAuthenticator IP address and default gateway.
You can now connect to the GUI at the IP address you set for port 1.
Suspending the FortiAuthenticator-VM can have unintended consequences. Fortinet
recommends that you do not use the suspend feature of VMware. Instead, shut down
the virtual FortiAuthenticator system using the GUI or CLI, and then shut down the
virtual machine using the VMware console.

Administrative access
Administrative access is enabled by default on port 1. Using the GUI, you can enable administrative access on
other ports if necessary.

To add administrative access to an interface:
1. Go to System > Network > Interfaces and select the interface you need to add administrative access to.
See Interfaces on page 34 for more information.
2. Under Access Rights, for Admin access, select the types of access to allow.
3. Select OK.

GUI access
To use the GUI, point your browser to the IP address of port 1 (192.168.1.99 by default). For example, enter
the following in the URL box:

FortiAuthenticator 5.5.0 Administration Guide
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https://192.168.1.99
Enter admin as the User Name and leave the Password field blank.
HTTP access is not enabled by default. To enable access, use the set ha-mgmtaccess command in the CLI (see CLI commands on page 21), or enable HTTP
access on the interface in the GUI (see Interfaces on page 34).
For security reasons, the host or domain names that the GUI responds to are restricted. The list of trusted
hosts is automatically generated from the following:
l
l
l
l

Configured hostname.
Configured DNS domain name.
Network interface IP addresses that have HTTP or HTTPS enabled.
HA management IP addresses.

Additional IP addresses and host or domain names that the GUI responded to can be defined in the GUI
Access settings. See System access on page 38 for more information.

Telnet
CLI access is available using telnet to the port1 interface IP address (192.168.1.99 by default). Use the telnet K option so that telnet does not attempt to log on using your user ID. For example:
$ telnet -K 192.168.1.99
At the FortiAuthenticator login prompt, enter admin. By default there is no password. When you are finished,
use the exit command to end the telnet session.
CLI access using Telnet is not enabled by default. To enable access, use the set
ha-mgmt-access command in the CLI (see CLI commands on page 21), or enable
Telnet access on the interface in the GUI (see Interfaces on page 34).

SSH
SSH provides secure access to the CLI. Connect to the port1 interface IP address (192.168.1.99 by default).
Specify the user name admin or SSH will attempt to log on with your user name. For example:

$ ssh admin@192.168.1.99
By default there is no password. When you are finished, use the exit command to end the session.
Note that, after three failed login attempts, the interface/connection will reset, and that SSH timeout is set to
60 seconds following an incomplete login or broken session.

Adding FortiAuthenticator to your network
Before setting up FortiAuthenticator, there are some requirements for your network:
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l

l

You must have security policies that allow traffic between the client network and the subnet of the
FortiAuthenticator.
You must ensure that the following ports are open in the security policies between the FortiAuthenticator
and authentication clients, in addition to management protocols such as HTTP, HTTPS, telnet, SSH, ping,
and other protocols you may choose to allow:
l
UDP/161 (SNMP)
l
UDP/1812 (RADIUS Auth)
l
UDP/1813 (RADIUS Accounting)
l
TCP/389 (LDAP)
l
TCP/636 (LDAPS)
l
TCP/8000 (FortiGate FSSO)
l
TCP/2560 (OCSP)
l
TCP/8001 (FortiClient Single Sign-On Mobility Agent FSSO)
l
TCP/8002 (DC/TS Agent FSSO)
l
TCP/8003 (Hierarchical FSSO)

To setup FortiAuthenticator on your network:
1. Log in to the GUI with the username admin and no password.
2. Go to System > Network > DNS. Enter your internal network primary and secondary name server IP
addresses. This is essential for successful FSSO operation. See DNS on page 35 for more information.
3. Go to System > Network > Static Routing and create a default route (IP/Mask 0.0.0.0/0) to your
network gateway on the interface that connects to the gateway. See Static routing on page 36 for more
information.
4. Go to System > Dashboard > Status.
5. In the System Information widget select Change in the System Time field, and select your Time zone
from the list.
6. Either enable the NTP or manually enter the date and time. See Configuring the system date, time, and
time zone on page 29 for more information.
Enter a new time and date by either typing it manually, selecting Today or Now, or select the calendar
or clock icons.
If you will be using FortiToken devices, Fortinet strongly recommends using
NTP. FortiToken Time based authentication tokens are dependent on an
accurate system clock.
7. Select OK.
8. If the FortiAuthenticator is connected to additional subnets, configure additional FortiAuthenticator
interfaces as required. See Interfaces on page 34 for more information.

Maintenance
System maintenance tasks include:
l
l

Backing up the configuration
Upgrading the firmware
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l
l

Licensing
Swapping hard disks

Backing up the configuration
You can back up the configuration of FortiAuthenticator to your local computer. See Backing up and restoring
the configuration on page 31 for more information.
Automatic system configuration backup can also be configured. See Configuring auto-backup on page 44 for
information.

Upgrading the firmware
Periodically, Fortinet issues firmware upgrades that fix known issues, add new features and functionality, and
generally improve your FortiAuthenticator experience. See Firmware upgrade on page 44 for more information.
Before proceeding to upgrade your system, Fortinet recommends you back up your configuration. Please follow
the procedure detailed in Backing up and restoring the configuration on page 31.
To upgrade the firmware, you must first register your FortiAuthenticator with Fortinet. See Registering your
Fortinet product on page 15 for more information.

To upgrade FortiAuthenticator firmware:
1. Download the latest firmware to your local computer from the Fortinet Support website.
2. Go to System > Administration > Firmware Upgrade.
3. Select Choose File and locate the firmware image on your local computer.
4. Select OK.
When you select OK, the firmware image will upload from your local computer to
the FortiAuthenticator device, which will then reboot. You will experience a short
period of time during this reboot when the FortiAuthenticator device is offline and
unavailable for authentication.

Licensing
FortiAuthenticator-VM works in evaluation mode until it is licensed. The license is valid only if one of the
FortiAuthenticator interfaces is set to the IP address specified in the license. See Licensing on page 48 for
more information.

To license FortiAuthenticator:
1. Go to System > Administration > Licensing.
2. Select Choose File and locate on your local computer the license file you received from Fortinet.
3. Select OK.
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Swapping hard disks
If a hard disk on a FortiAuthenticator unit fails, it must be replaced. On FortiAuthenticator devices that support
hardware RAID, the hard disk can be replaced while the unit is still running - know as hot swapping. On
FortiAuthenticator units with software RAID, the device must be shutdown prior to exchanging the hard disk.
To identify the failed hard disk, go to System > Dashboard > Status and view the Disk Monitor widget.
When a hard disk fails, the RAID status shows as Degraded and the RAID status icon displays a warning
indication in yellow. In the RAID graphic, the failed hard disk will be missing from the RAID array or will show
with a blue question mark symbol.
Electrostatic discharge (ESD) can damage FortiAuthenticator equipment. Only perform
the procedures described in this document from an ESD workstation. If no such station
is available, you can provide some ESD protection by wearing an anti-static wrist or
ankle strap and attaching it to an ESD connector or to a metal part of a
FortiAuthenticator chassis.

When replacing a hard disk, you need to first verify that the new disk is the same size
as those supplied by Fortinet and has at least the same capacity as the old one in the
FortiAuthenticator unit. Installing a smaller hard disk will affect the RAID setup and
may cause data loss. Due to possible differences in sector layout between disks, the
only way to guarantee that two disks have the same size is to use the same brand and
model.
The size provided by the hard drive manufacturer for a given disk model is only an
approximation. The exact size is determined by the number of sectors present on the
disk.

To hot swap a hard disk on a device that supports hardware RAID:
1. Remove the faulty hard disk.
2. Install a new disk in the same slot from which the failed disk was removed.
The Disk Monitor widget updates. In the RAID graphic, a blue question mark symbol appears in the
representative slot where the new hard disk is installed. If the blue question mark symbol does not
appear shortly after the new disk is installed, in the widget, click Refresh to refresh the RAID status.
3. In the RAID graphic, click the blue question mark symbol.
The hard disk re-synchronization/rebuild process is initialized. This process can take over an hour to
complete, depending on the size of the hard disk. The RAID status changes to display the progress of
the RAID re-synchronization/rebuild.
Once the re-synchronization/rebuild process is complete, the RAID status changes to OK and the RAID status
icon displays a green checkmark.

CLI commands
The FortiAuthenticator has CLI commands that are accessed using SSH or Telnet, or through the CLI console if
a FortiAuthenticator is installed on a FortiHypervisor. The commands can be used to initially configure the unit,
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perform a factory reset, or reset the values if the GUI is not accessible.

Command

Description

help

Display list of valid CLI commands. You can also enter ? for help.

exit

Terminate the CLI session.

show

Display bootstrap configuration.

set port1-ip <IP/netmask>

Enter the IPv4 address and netmask for the port1 interface. Netmask
is expected in the /xx format, for example 192.168.0.1/24.
Once this port is configured, you can use the GUI to configure the
remaining ports.

set default-gw <IP>

Enter the IPv4 address of the default gateway for this interface. This
is the default route for this interface.

set date <YYYY-MM-DD>

Enter the current date. Valid format is four digit year, two digit month,
and two digit day. For example: set date 2014-08-12 sets the
date to August 12, 2014.

set time <HH:MM:SS>

Enter the current time. Valid format is two digits each for hours,
minutes, and seconds. 24-hour clock is used. For example 15:10:00
is 3:10pm.

set tz <timezone_index>

Enter the current time zone using the time zone index. To see a list of
index numbers and their corresponding time zones, enter set tz
?.

set ha-mode
{enable | disable}

Enable or disable (default) HA mode.

set ha-port <interface>

Select a network interface to use for communication between the two
cluster members. This interface must not already have an IP address
assigned and it cannot be used for authentication services. Both units
must use the same interface for HA communication.

set ha-priority
{high | low}

Set to low on one unit and high on the other. Normally, the unit with
High priority is the master unit.

set ha-password
<password>

Set the HA password.

set ha-mgmt-ip
<IP/netmask>

Enter the IP address, with netmask, that this unit uses for HA related
communication with the other FortiAuthenticator unit (e.g.
1.2.3.4/24.
The two units must have different addresses. Usually, you should
assign addresses on the same private subnet.
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Command

Description

set ha-mgmt-access
{ssh | https | http
| telnet}

Select the types of administrative access to allow.

set ha-dbg-level <level>

Enter the level for HA service debug logs. Range: -4 (fatal) to 4
(debug high). Default: -2 (warn).

unset <setting>

Restore default value. For each set command listed above, there is
an unset command, for example unset port1-ip.

raid-add-disk <slot>

Add a disk to a degraded RAID array.

ha-rebuild

Rebuild the configuration database from scratch using the HA peer's
configuration.

restore-admin

Restore factory reset's admin access settings to the port1 network
interface.

reboot

Perform a hard restart of FortiAuthenticator. All sessions will be
terminated. The unit will go offline and there will be a delay while it
restarts.

factory-reset

Enter this command to reset the FortiAuthenticator settings to factory
default settings. This includes clearing the user database.
This procedure deletes all changes that you have made to the
FortiAuthenticator configuration and reverts the system to its original
configuration, including resetting interface addresses.

shutdown

Turn off the FortiAuthenticator.

status

Display basic system status information including firmware version,
build number, serial number of the unit, and system time.

hardware-info

Display general hardware status information.

disk-attributes

Display system disk attributes.

disk-errors

Display any system disk errors.

disk-health

Display disk health information.

disk-info

Display disk hardware status information.

raid-hwinfo

Display RAID hardware status information.

nslookup

Basic tool for DNS debugging.
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Command

Description

dig

Advanced DNS debugging.

ping

Test network connectivity to another network host.

tcpdump

Examine local network traffic.

tcpdumpfile

Same as tcpdump, but the output is written to a downloadable file
that can be downloaded in the debug logs.
Debug logs can be accessed via your web browser by navigating to
https://<FortiAuthenticator-IP-Address>/debug. For
more information, see Debug logs on page 208.
Examine the route taken to another network host.

traceroute

Standardized CLI
With the release of version 5.0, FortiAuthenticator's CLI commands (concerning basic configuration) have
become more similar to other product's CLI, such as the commands commonly found in FortiOS.
The following initial-setup commands have been introduced to FortiAuthenticator; note that all existing CLI
commands found in the FortiAuthenticator now fall under the following:
l

config router static

l

config system dns

l

config system global

l

config system ha

l

config system interface
The FortiAuthenticator VM's console allows scrolling up and down through the
CLI output by using Shift+PageUp and Shift+PageDown.
Another tip to be aware of is, exactly like FortiOS, the ? key can be used to display all
possible options available to you, depending upon where you are hierarchicallysituated.

Note that get, execute, and diagnose commands are also available.

Troubleshooting
Troubleshooting includes useful tips and commands to help deal with issues that may occur. For additional
help, contact customer support. See Troubleshooting on page 207 for more information.
If you have issues when attempting authentication on a FortiGate unit using the FortiAuthenticator, there are
some FortiAuthenticator and FortiGate settings to check.
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In addition to these settings you can use log entries, monitors, and debugging information to determine more
knowledge about your authentication problems. For help with FortiAuthenticator logging, see Logging on page
200. For help with FortiGate troubleshooting, see the FortiOS Handbook for troubleshooting user
authentication.

FortiAuthenticator settings
When checking FortiAuthenticator settings, you should ensure that:
l
l

l
l
l
l
l

l

l

There is an authentication client entry for the FortiGate unit (see RADIUS service on page 117).
The user trying to authenticate has a valid active account that is not disabled, and that the username and
password are entered correctly.
The user account allows RADIUS authentication if RADIUS is enabled on the FortiGate unit.
The FortiGate unit can communicate with FortiAuthenticator, on the required ports:
RADIUS Authentication: UDP/1812
LDAP: TCP/389
The user account exists either:
l
as a local user on the FortiAuthenticator (if using RADIUS authentication),
l
in the local LDAP directory (if using local LDAP authentication),
l
and/or in the remote LDAP directory (if using RADIUS authentication with remote LDAP password
validation).
The user is a member in the expected user groups and these user groups are allowed to communicate on
the authentication client (e.g. the FortiGate).
If authentication fails with the log error "bad password", try resetting the password. If this fails, verify that
the pre-shared secret is identical on both FortiAuthenticator and the authentication client.

If FortiToken authentication is failing, try the following:
l
l

l

Verify that the token is correctly synchronized.
Remove the token from the user authentication configuration and verify authentication works when the
token is not present.
Attempt to log into the FortiAuthenticator with the user credentials.

These steps enable the administrator to identify whether the problem is with the FortiGate unit, the credentials,
or the FortiToken.

FortiGate settings
When checking FortiGate authentication settings, you should ensure that:
l
l
l

The user has membership in the required user groups and identity-based security policies.
There is a valid entry for the FortiAuthenticator device as a remote RADIUS or LDAP server.
The user is configured either explicitly or as a wildcard user.
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System
The System tab enables you to manage and configure the basic system options for FortiAuthenticator. This
includes the basic network settings to connect the device to the corporate network, the configuration of
administrators and their access privileges, managing and updating firmware for the device, and managing
messaging servers and services.

Dashboard
When you select the System tab, it automatically opens at the System > Dashboard > Status page.
The Dashboard page displays widgets that provide performance and status information, allowing you to
configure some basic system settings. These widgets appear on a single dashboard.

The following widgets are available:
System Information

Displays basic information about the FortiAuthenticator system including
host name, device FQDN name, serial number, system time, firmware
version, architecture, system configuration, current administrator, and up
time.
From this widget you can manually update the FortiAuthenticator firmware
to a different release. For more information, see System information widget
on page 28.
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System Resources

Displays the usage status of the CPU and memory. For more information,
see System resources widget on page 32.

Authentication Activity

Displays a customizable graph of the number of logins to the device. For
more information, see Authentication activity widget on page 32.

User Inventory

Displays the numbers of users, groups, FortiTokens, FSSO users, and
FortiClient users currently used or logged in, as well as the maximum
allowed number, the number still available, and the number that are
disabled. For more information, see User lookup on page 33.

HA Status

Displays whether or not HA is enabled.

License Information

Displays the device's license information, as well as SMS information. For
more information, see License information widget on page 32.

Disk Monitor

Displays if RAID is enabled, and the current disk usage in GB. For more
information, see Disk monitor widget on page 33.

Top User Lockouts

Displays the top user lockouts. For more information, see Top user lockouts
widget on page 33.

Customizing the dashboard
The FortiAuthenticator system settings dashboard is customizable. You can select which widgets to display,
where they are located on the page, and whether they are minimized or maximized.

To move a widget
Position your mouse cursor on the widget’s title bar, then click and drag the widget to its new location.

To add a widget
In the dashboard toolbar, select Add Widget, then select the widget you want to show. Multiple widgets of the
same type can be added. To hide a widget, in its title bar, select the Hide icon.

To see the available options for a widget
Position your mouse cursor over the icons in the widget’s title bar. Options include show/hide the widget, edit
the widget, refresh the widget content, and close the widget.
The following table lists the widget options.
Show/Hide arrow

Display or minimize the widget.

Widget Title

The name of the widget.

Edit

Select to change settings for the widget.
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This option appears only in certain widgets.
Refresh

Select to update the displayed information.

Remove

Select to remove the widget from the dashboard. You will be prompted to
confirm the action. To add the widget, select Widget in the toolbar and
then select the name of the widget you want to show.

To change the widget title
Widget titles can be customized by selecting the edit button in the title bar and entering a new title in the widget
settings dialog box. Some widgets have more options in their respective settings dialog box.
To reset a widget title to its default name, simply leave the Custom widget title field blank.
The widget refresh interval can also be manually adjusted from this dialog box.

System information widget
The system dashboard includes a System Information widget, which displays the current status of
FortiAuthenticator and enables you to configure basic system settings.
The following information is available on this widget:
Host Name

The identifying name assigned to this FortiAuthenticator unit. For more
information, see Changing the host name on page 29.

Device FQDN

The FQDN domain name. For more information, see Changing the FQDN
domain name on page 29.

Serial Number

The serial number of FortiAuthenticator. The serial number is unique to
FortiAuthenticator and does not change with firmware upgrades. The serial
number is used for identification when connecting to the FortiGuard server.

System Time

The current date, time, and time zone on the FortiAuthenticator internal
clock or NTP servers. For more information, see Configuring the system
date, time, and time zone on page 29.

Firmware Version

The version and build number of the firmware installed on
FortiAuthenticator. To update the firmware, you must download the latest
version from the Customer Service & Support portal at
https://support.fortinet.com. Select Upgrade and select the firmware
image to load from your management computer.

System Configuration

The date of the last system configuration backup. Select Backup/Restore
to backup or restore the system configuration. For more information, see
Backing up and restoring the configuration on page 31.

Current Administrator

The name of the currently logged on administrator.
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Uptime

The duration of time FortiAuthenticator has been running since it was last
started or restarted.

Shutdown / Reboot

Options to shutdown or reboot the device. When rebooting or shutting down
the system, you have the option to enter a message that will be added to
the event log explaining the reason for the shutdown or reboot.

Changing the host name
The System Information widget will display the full host name.

To change the host name:
1. Go to System > Dashboard > Status.
2. In the System Information widget, in the Host Name field, select Change. The Edit Host Name page
opens.
3. In the Host name field, type a new host name.
The host name may be up to 35 characters in length. It may include US-ASCII
letters, numbers, hyphens, and underscores. Spaces and special characters are not
allowed.

4. Select OK to save the setting.

Changing the FQDN domain name
To change the FQDN domain name:
1. Go to System > Dashboard > Status.
2. In the System Information widget, in the Device FQDN field, select Change. The Edit Device FQDN
page opens.
3. Type a domain name in the field.
The FQDN domain name identifies the exact location of this server in the DNS hierarchy.
4. Select OK to save the setting.

Configuring the system date, time, and time zone
You can either manually set the FortiAuthenticator system date and time, or configure the FortiAuthenticator
unit to automatically keep its system time correct by synchronizing with an NTP server.

For many features to work the FortiAuthenticator system time must be accurate.
Synchronization with a NTP server is highly recommended.
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To configure the date and time:
1. Go to System > Dashboard > Status.
2. In the System Information widget, in the System Time field, select Change. The Edit Time Setting
dialog box appears.

Note that, since the release of FortiAuthenticator 4.2, you can now configure an
additional NTP server.

3. Configure the following settings to either manually configure the system time, or to automatically
synchronize the FortiAuthenticator unit’s clock with a NTP server:
Change Time Zone
Time zone

Select a timezone from the dropdwn menu.

Change Date and Time
Set date/time

Either select Today or the calendar icon to specify the date, and either
Now or the clock icon to specify the time.

NTP enabled

Enable this option to set an NTP server. Note that, if you configure both
NTP servers, you can select the Prefer checkbox to make NTP server 1
the preferred server. The NTP server 1 is set to ntp1.fortinet.net by
default.
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In addition, you can select Enable authentication for each NTP server
configured and enter a key number, type, and the key value.

4. Select OK to apply your changes.

Backing up and restoring the configuration
Fortinet recommends that you back up your FortiAuthenticator configuration to your management computer on
a regular basis to ensure that, should the system fail, you can quickly get the system back to its original state
with minimal effect to the network. You should also perform a back up after making any changes to the
FortiAuthenticator configuration.
The backup file is encrypted to prevent tampering. This configuration file includes both the CLI and GUI
configurations of FortiAuthenticator, including users, user groups, FortiToken device list, authentication client
list, LDAP directory tree, FSSO settings, remote LDAP, and certificates.
You can perform backups manually. Fortinet recommends backing up all configuration settings from your
FortiAuthenticator unit before upgrading the FortiAuthenticator firmware.
Your FortiAuthenticator configuration can also be restored from a backup file on your management computer.

To backup or restore the FortiAuthenticator configuration:
1. Go to System > Dashboard > Status.
2. In the System Information widget, in the System Configuration field, select Backup/Restore. The
Configuration Backup and Restore page opens.
3. Select from the following settings:
Backup

Select Download backup file to save a backup file onto the
management computer.

Restore

Select Choose File to find the backup file on your management
computer, then select Restore to restore the selected backup
configuration to the device.
You will be prompted to confirm the restore action, and
FortiAuthenticator will reboot.

4. Select Cancel to return to the dashboard page.
When you restore the configuration from a backup file, any information changed since
the backup will be lost. Any active sessions will be ended and must be restarted. You
will have to log back in when the system reboots.

Restoring a configuration is only possible from a backup file made on the same model
running the same version of the operating system.

If you are restoring a configuration on the master device in an HA cluster, shutdown the
slave device until the master device is back online to ensure that the configuration
synchronization occurs correctly.
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System resources widget
The System Resources widget on the dashboard displays the usage status of the CPU and memory as a
percentage.

Authentication activity widget
The Authentication Activity widget displays a line graph of the number of logins versus time.
To adjust the data displayed in the graph, select the edit button to open the Authentication Activity Widget
Settings dialog box.
The following settings are available:
Custom widget title

Enter a custom widget title for the widget, or leave it blank to keep the
default title.

Refresh interval

Enter a custom refresh interval for the widget (in seconds), or leave it as the
default time of 300 seconds (or five minutes).

Time period

Select a time period for the graph to cover from the dropdown menu: Last 6
hours, Last 24 hours, Last 3 days, Last 7 days, or Last 30 days.

Activity Type

Select the activity type to display in the graph: All login attempts,
Successful login attempts, or Failed login attempts.

User inventory widget
The User Inventory widget displays the numbers of users, groups, FortiTokens, FSSO users, and FortiClient
users currently used or logged in, as well as the maximum allowed number, the number still available, and the
number that are disabled.

License information widget
The License Information widget displays the device's license information, as well as SMS information. You
can also add a license and more SMS messages.
To upload a new license file, select Upload in the License Type field, then browse to the license file on the
management computer.
To add more SMS messages, select Add Messages from either the Sent/Allowed field or the Status field. In
the Add Messages dialog box, enter the certificate number for the messages and then select OK to add the
messages. You can also Refresh Messages.
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Disk monitor widget
The Disk Monitor widget displays the RAID status, and the current disk usage in GB. If RAID is enabled, the
RAID status is visible and the RAID graphic displays the position and status of each disk in the RAID array.

Top user lockouts widget
The Top User Lockouts widget displays the users who are locked out the most. For more information on user
lockouts and for instruction on adjusting user lockout settings, see Lockouts on page 62.
To change the number of user lockouts displayed in the widget, select the edit icon and change the number in
the Number of lockouts field (set to 5 by default).

User lookup
You can search for users to easily manage and monitor the ongoing activity of a specific user. Selecting a user
from the search results presents a consolidated view of the user's information and recent activities, as well as
shortcuts to manage that user.
To search for users, go to System > Dashboard > User Lookup. From the search results, click the
username to see user details.
The following information and options are available:
User Info
Username

The user accounts' username.

Full name

The user accounts' first name and last name.

Email

The user account's email address.

User Type

The user account type, either Local, LDAP/<server name>, or
RADIUS/<server name>.

Account
status

The status of the user account, either Enabled, Disabled, or Locked
until <date/time>. The following account management shortcuts are
available depending on the account status:

Disable: Select to disable the account of a user that is enabled.
Re-enable: Select to enable the account of a user that is disabled.
Unlock: Select to unlock the account of a user that has been locked.
Token

The token that is assigned to the user account. Select Edit to manage the
token assigned to the account. See Configuring token-based authentication
on page 73.

RADIUS-based Usage

The user accounts' cumulative RADIUS-based usage statistics. See
RADIUS sessions on page 173 for more information.

Active RADIUS Sessions

The user accounts' active RADIUS accounting sessions. See

FortiAuthenticator 5.5.0 Administration Guide
Fortinet Technologies Inc.

33

System

RADIUS sessions on page 173 for more information.
Recent Activity

The 20 most recent system logs containing the selected username in the
log's User and/or Short message fields. For more information about system
logs, see Log access on page 200.

Refresh

Select to refresh the Recent Activity list.

View All

Select to view all logs containing the selected username. See Log access
on page 200 for more information.

Network
The Network tree menu allows you to configure device interfaces, DNS configuration, static routing, and
packet capturing.

Interfaces
To view the interface list, go to System > Network > Interfaces.
The following information is shown:
Edit

Select to edit the selected interface.

Search

Enter a search term in the search text box then select Search to search the interface list.

Interface

The names of the physical interfaces on your FortiAuthenticator unit. The name, including
number, of a physical interface depends on the model.

IPv4

The IPv4 address of the interface.

IPv6

The IPv6 address of the interface, if applicable.

Link status

The link status of the interface.

To edit an interface:
1. In the interfaces list, select the interface you need to edit and select the Edit button, or select the interface
name. The Edit Network Interface window opens.
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2. Edit the following settings as required.
Interface Status

The interface name and its current link status is displayed.

IP Address / Netmask
IPv4

Enter the IPv4 address and netmask associated with this interface.

IPv6

Enter the IPv6 address associated with this interface.

Access Rights
Admin access

Select the allowed administrative service protocols from: Telnet, SSH ,
HTTPS, HTTP, and SNMP.
Note that when HTTPS is enabled, you can also specify Admin access
and/or REST API access.

Services

Select the allowed services from: RADIUS Accounting Monitor,
RADIUS Auth, RADIUS Accounting SSO, LDAP, LDAPS,
FortiGate FSSO, OCSP, FortiClient FSSO, Hierarchical FSSO,
DC/TS Agent FSSO, and Syslog.
Note that Syslog is only available if Syslog SSO has been enabled. See
General settings on page 141 for more information.

3. Select OK to apply the edits to the network interface.

DNS
To configure DNS settings, go to System > Network > DNS.
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The following settings can be configured:
Primary DNS server

The IP address of the primary DNS server.

Secondary DNS server

The IP address of the secondary DNS server.

Enable DNS cache

Enable to cache the responses to DNS queries.

DNS cache maximum TTL

When DNS cache is enabled, configure the length of time in seconds
responses to DNS queries are cached. If the configured value is larger
than the time to live (TTL) value specified in the DNS record, the
DNS TTL value is used. The default is set to 0, which uses the TTL value
specified in the DNS record.

To apply changes, select OK.

Static routing
To view the list of static routes, go to System > Network > Static Routing. Routes can be created, edited,
and deleted as required. Use the checkboxes to select the static route entries you wish to either Delete or Edit.
The following information is shown:
Create New

Select to create a new static route.

Delete

Select to delete the selected static route.

Edit

Select to edit the selected static route.

IP/Mask

The destination IP address and netmask for this route.

Gateway

The IP address of the next hop router to which this route directs traffic.

Device

The device or interface associated with this route.
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To create a new static route:
1. In the static route list, select Create New. The Create New Static Route window opens.
2. Edit the following settings as required.
Destination IP/Mask

Enter the destination IP address and netmask for this route.

Network interface

Select the network interface that connects to the gateway.

Gateway

Enter the IP address of the next hop router to which this route directs traffic.

Comment

Optionally, enter a comment about the route.

3. Select OK to create the new static route.

Packet capture
Packets can be captured on configured interfaces by going to System > Network > Packet Capture.
The following information is available:
Edit

Select to edit the packet sniffer on the selected interface.

interface

The name of the configured interface for which packets can be captured.
For information on configuring an interface, see Interfaces on page 34.

Maximum
packets to
capture

The maximum number of packets that can be captured on a sniffer.

Status

The status of the packet capture process. Allows you to start and stop the capturing process,
and download the most recently captured packets.

To start capturing packets on an interface, select the Start capturing button in the Status column for that
interface. The Status will change to Capturing, and the Stop capturing and download buttons will become
available.

To download captured packets:
1. Select the download button for the interface whose captured packets you are downloading.
If no packets have been captured for that interface, select the Start capturing button.
2. When prompted, save the packet file (sniffer_[interface].pcap) to your management computer.
The file can then be opened using packet analyzer software.
To edit a packet sniffer:
1. Select the interface whose packet capture settings you need to configure by either selecting the configured
interface name from the interface list, or selecting the checkbox in the interface row and selecting Edit
from the toolbar.
The Edit Packet Sniffer page opens.
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2. Configure the following options:
interface

The interface name (non-changeable).

Max packets to capture

Enter the maximum number of packets to capture, between 1-10000.
The default is 500 packets.

Include IPv6 packets

Select to include IPv6 packets when capturing packets.

Include non-IP packets

Select to include non-IP packets when capturing packets.

3. Select OK to apply your changes.

Administration
Configure administrative settings for the FortiAuthenticator device.

System access
To adjust system access settings, go to System > Administration > System Access. The Edit System
Access Settings page will open.

The following settings are available:

Administrative Access
Require strong
cryptography

Enable this option to restrict administrative access using stronger
cryptographic algorithms, such as TLS 1.2, DHE, AES, and SHA256.
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Enable pre-authentication
warning message

Pre-authentication warning messages can be found under Authentication
> Self-service Portal > Replacement Messages.

CLI Access

CLI idle timeout

Enter the amount of time before the CLI times out due to inactivity, from 0
to 480 minutes (maximum of eight hours).

GUI Access
GUI idle timeout

Enter the amount of time before the GUI times out due to inactivity, from 1
to 480 minutes (maximum of eight hours).

Maximum HTTP
header length

Enter the maximum HTTP header length, from 4 to 16 KB.

HTTPS Certificate

Select an HTTPS certificate from the dropdown menu.

HTTP Strict
Transport
Security (HSTS)
Expiry

Enable or disable HSTS enforcement, to avoid SSL sniffing attacks, and set
an expiry from 0 to 730 days (where 0 means no expiry, maximum of two
years). The default is set to 180.

Certificate
authority type

Select the selected certificate’s authority type, either Local CA or Trusted
CA.

CA certificate that
issued the server
certificate

Select the issuing server certificate from the dropdown menu.

Additional
allowed
hosts/domain
names

Specify any additional hosts that this site can serve, separated by commas
or line breaks.

Public IP/FQDN
for FortiToken
Mobile

Enter the IP, or FQDN, of the FortiAuthenticator for external access.
The mobile device running the FortiToken Mobile app has to be able to
access the FortiAuthenticator interface for push to operate.
Enter the IPs/FQDNs in the following format:
ip_addr[:port] or FQDN[:port]

Select OK to apply any changes. See Certificate management on page 176 for more information about
certificates.

High availability
Multiple FortiAuthenticator units can operate as an high availability (HA) cluster to provide even higher
reliability.
There are three HA roles:
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1. Cluster member
2. Standalone master
3. Load-balancing slave
The FortiAuthenticator can operate in two separate HA modes:

1. Cluster: Active-passive clustered fail-over mode where all of the configuration is synchronized between
the devices.
2. Load-balancing: Active-active HA method in which one device acts as a standalone master with up to two
additional, geographically separated load-balancing slaves. The load can be distributed across the devices
using round-robin DNS, Auth/NAS client load distribution, or external load balancing devices. Loadbalancing mode is intended for two-FortiAuthenticator authentication deployments, as only a subset of the
configuration is synchronized between the devices.
Both HA modes can be combined with an HA cluster acting as a standalone master for geographically
distributed load-balancing slaves.
If an HA cluster is configured on an interface (such as port 2) and then disabled, it will
not be possible to re-enable HA.
This is because, when disabled, the interface's IP address is reconfigured to the
interface to allow the administrator to access the newly standalone device. To allow
the port to be available for use again in a HA cluster, the IP address must be manually
removed.

Cluster member role
In the cluster member role, one unit is active and the other is on standby. If the active unit fails, the standby
unit becomes active. The cluster is configured as a single authentication server on your FortiGate units.
Authentication requests made during a failover from one unit to another are lost, but subsequent requests
complete normally. The failover process takes about 30 seconds.
Cluster mode uses Ethernet broadcasts through UDP/720 as part of its master/slave
election mechanism and for ongoing communication. Layer 2 connectivity is required
between the two devices in an HA cluster, preferably via a crossover cable, as some
network devices might block such Ethernet broadcasts.

To configure FortiAuthenticator HA:
1. On each unit, go to System > Administration > High Availability.
2. Enter the following information:
Enable HA

Enable HA.

Role

Select Cluster member.
For more information about the other options, see Standalone master
and load-balancing slave roles below.
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Maintenance Mode

Enable to put the FortiAuthenticator unit of an HA master cluster into
maintenance mode to remove it from the cluster. Upon entering
maintenance mode, if the FortiAuthenticator unit is the active master, it
relinquishes the active master role and assumes a passive role. While in
maintenance mode, the FortiAuthenticator will continue to monitor the
status of its HA pair and announce its presence.
When set to Enabled with synchronization, the FortiAuthenticator
continues to keep its configuration synchronized with the active master.
When set to Enabled without synchronization, the
FortiAuthenticator stops synchronizing its configuration with the active
master.

Interface

Select a network interface to use for communication between the two
cluster members. This interface must not already have a IP address
assigned and it cannot be used for authentication services. Both units
must use the same interface for HA communication.

Cluster member
IP address

Enter the IP address this unit uses for HA-related communication with
the other FortiAuthenticator unit. The two units must have different
addresses. Usually, you should assign addresses on the same private
subnet.

Admin access

Select the types of administrative access to allow from: Telnet, SSH ,
HTTPS, Admin access, REST API, HTTP, and SNMP.

Priority

Set to Low on one unit and High on the other. Normally, the unit with
High priority is the master unit.

Password

Enter a string to be used as a shared key for IPsec encryption. This must
be the same on both units.

Load-balancing slaves

Add the other load-balancing cluster members by entering their
IP addresses.

Monitored interfaces

Enable the interfaces you wish to monitor.

Monitored interfaces
stability period

Define the stability period for the monitored interfaces in seconds,
between 0-3600 (or one hour). The default is set to 30.

3. Select OK to apply the settings.
When one unit has become the master, reconnect to the GUI and complete your
configuration. The configuration will automatically be copied to the slave unit.

Standalone master and load-balancing slave roles
The load-balancing HA method enables active-active HA across geographically separated locations and Layer 3
networks. Only the following authentication related features can be synchronized:
l
l
l

Token and seeds
Local user database
Remote user database

FortiAuthenticator 5.5.0 Administration Guide
Fortinet Technologies Inc.

41

System

l
l

Group mappings
Token and user mappings

Other features, such as FSSO and certificates, cannot be synchronized between devices.
The standalone master is the primary system where users, groups, and tokens are configured. The loadbalancing slave is synchronized to the master.
To improve the resilience of the master system, an active-passive master cluster with up to two load-balancing
slave devices can be configured.
Remote administrator users are not synchronized between the master and the loadbalancing slave.
As a workaround, you can import remote users to slave roles, and change their roles to
Administrator.

To configure load-balancing HA:
1. On each unit, go to System > Administration > High Availability.
2. Enter the following information:
Enable HA

Enable HA.

Role

Select Standalone master on the master device, and Load-balancing
slave on the slave device/s.

Load Balancing master IP
address

On the load-balancing slave device/s, enter IP address of the master.

Password

Enter a string to be used as a shared key for IPsec encryption. This must
be the same on both units.

Load-balancing slaves

On the master, enter IP address or IP addresses of the load-balancing
slave devices. Up to two can be added.

3. Select OK to apply the settings.

Administrative access to the HA cluster
Administrative access is available through any of the network interfaces using their assigned IP addresses or
through the HA interface using the Cluster member IP address, assigned on the System > Administration
> High Availability page. In all cases, administrative access is available only if it is enabled on the interface.
Administrative access through any of the network interface IP addresses connects only to the master unit. The
only administrative access to the slave unit is through the HA interface using the slave unit’s Cluster member
IP address.
Configuration changes made on the master unit are automatically pushed to the slave unit. The slave unit does
not permit configuration changes, but you might want to access the unit to change HA settings, or for firmware
upgrades, shutdown, reboot, or troubleshooting.
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FortiAuthenticator VMs used in a HA cluster each require a license. Each license is tied
to a specific IP address. In an HA cluster, all interface IP addresses are the same on
the two units, except for the HA interface.
Request each license based on either the unique IP address of the unit’s HA interface
or the IP address of a non-HA interface which will be the same on both units.

If you disable and then re-enable HA operation, the interface that was assigned to HA
communication will not be available for HA use. You must first go to System >
Network > Interfaces and delete the IP address from that interface.

Restoring the configuration
When restoring a configuration to an HA cluster master device, the master will reboot and in the interim the
slave device will be promoted to master. When the previous master returns to service, it will become a slave
and the existing master will overwrite its configuration, defeating the configuration restore. To avoid this, use
the following process when restoring a configuration:

1. Shutdown the slave unit.
2. Restore the configuration on the master unit.
3. Wait until the master unit is back online.
4. Turn on slave unit — it will synchronize to the restored configuration after booting up.

Firmware upgrade

For a stable HA configuration, all units in an HA cluster must be running the same
firmware version, and have the same sized license for HA devices.

When upgrading the firmware on FortiAuthenticator devices in an HA cluster, you can perform a coordinated
upgrade of both cluster members. During the coordinated upgrade, the cluster upgrades the standby (or slave)
device and then the active device to run the new firmware image. The firmware upgrade takes place without
interrupting communication through the cluster. This firmware upgrade method can only be initiated from the
active member of the cluster.
The following sequence describes the steps the cluster goes through during a coordinated firmware upgrade.

1. The administrator initiates the firmware upgrade from the active device.
2. The firmware image transfers to the slave device.
3. The firmware upgrades on the slave device.
4. The slave device reboots and synchronizes with the active device.
5. The firmware upgrade begins on the active device. The slave device becomes the new active device.
6. The former active device reboots and synchronizes with the new active device.
7. The former active device becomes the active device, and the former slave device becomes the slave
device.
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If you want to perform the firmware upgrade on each FortiAuthenticator cluster member individually, specific
steps must be taken to ensure that the upgrade is successful:

1. Start the firmware upgrade on the active, or master, device. See Upgrading the firmware on page 20.
The device will reboot. While the master device is rebooting, the slave device becomes the master.
2. Start the firmware upgrade on the new master device.
The device will reboot. Once both devices have rebooted, the original master device will again be the
master, while the slave device will return to being the slave.
If a situation arises where both devices are claiming to be the HA master due to a firmware mismatch, and the
HA port of the device that is intended to be the slave cannot be accessed (such as when a crossover cable is
being used), use the following steps:

1. Shutdown the master device to which you have access, or, if physical access to the unit is not available to
turn it back on, reboot the device. See System information widget.
Note that, if rebooting the device, Step 2 below must be completed before the device finishes rebooting,
which can be as short as 30 seconds.
2. With the previously inaccessible device now accessible, upgrade its firmware to the required version so
that both devices have the same version.
The device will reboot.
3. If you shutdown the device in Step 1, power it back on.
Once both devices are back online, they will assume the HA roles dictated by their respective HA
priorities.

Firmware upgrade
The FortiAuthenticator firmware can be upgraded by either going to System > Administration > Firmware,
or through the System Information widget on the dashboard (see System information widget on page 28).
For instructions on upgrading the device’s firmware, see Upgrading the firmware on page 20.

Upgrade history
The upgrade history of the device is shown under the Upgrade History heading in the Firmware Upgrade or
Downgrade pane. It displays the version that was upgraded to, the time and date that the upgrade took place,
and the user that performed the upgrade. This information can be useful when receiving support to identify
incorrect upgrade paths that can cause stability issues.
Always review all sections in the FortiAuthenticator Release Notes prior to upgrading your device.

Configuring auto-backup
You can configure the FortiAuthenticator to automatically perform configuration back ups to an FTP or SFTP
server.
Even though the backup file is encrypted to prevent tampering, access to the FTP server should be restricted.
This configuration file backup includes both the CLI and GUI configurations of FortiAuthenticator. The backedup information includes users, user groups, FortiToken device list, authentication client list, LDAP directory
tree, FSSO settings, remote LDAP and RADIUS, and certificates.
To configure automatic backups, go to System > Administration > Config Auto-backup.
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Enter the following information, and then select OK to apply the settings:
Enable configuration autobackup

Enable the configuration of automatic configuration backups.

Frequency

Select the automatic backup frequency: Hourly, Daily, Weekly, or
Monthly.

Backup time

Entire a time, select Now, or select the clock icon to set the scheduled time
for backups to occur.
Note that this options is not available when the frequency is set to hourly.

FTP
directory

Enter the FTP directory where the backup configuration files will be saved.

FTP server

Select the FTP server to which the backup configuration files will be saved.
See on page 50 for information on adding FTP servers.

Secondary
FTP server

Select a secondary FTP server.

SNMP
Simple Network Management Protocol (SNMP) enables you to monitor hardware on your network. You can
configure the hardware, such as the FortiAuthenticator SNMP agent, to report system information and send
traps (alarms or event messages) to SNMP managers. An SNMP manager, or host, is typically a computer
running an application that can read the incoming trap and event messages from the agent, and send out
SNMP queries to the SNMP agents.
By using an SNMP manager, you can access SNMP traps and data from any FortiAuthenticator interface
configured for SNMP management access. Part of configuring an SNMP manager is listing it as a host in a
community on FortiAuthenticator it will be monitoring. Otherwise, the SNMP monitor will not receive any traps
from that unit, or be able to query that unit.
The FortiAuthenticator SNMP implementation is read-only. SNMP v1, v2c, and v3 compliant SNMP managers
have read-only access to system information through queries and can receive trap messages from
FortiAuthenticator.
To monitor FortiAuthenticator system information and receive FortiAuthenticator traps, your SNMP manager
needs the Fortinet and FortiAuthenticator Management Information Base (MIB) files. A MIB is a text file that
lists the SNMP data objects that apply to the device to be monitored. These MIBs provide information that the
SNMP manager needs to interpret the SNMP trap, event, and query messages sent by FortiAuthenticator
SNMP agent.
The Fortinet implementation of SNMP includes support for most of RFC 2665 (Ethernet-like MIB) and most of
RFC 1213 (MIB II). RFC support for SNMP v3 includes Architecture for SNMP Frameworks (RFC 3411), and
partial support of User-based Security Model (RFC 3414).
SNMP traps alert you to important events that occur, such as overuse of memory or a high rate of
authentication failures.
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SNMP fields contain information about FortiAuthenticator, such as CPU usage percentage or the number of
sessions. This information is useful for monitoring the condition of the unit on an ongoing basis and to provide
more information when a trap occurs.

Configuring SNMP
Before a remote SNMP manager can connect to the Fortinet agent, you must configure one or more interfaces
to accept SNMP connections by going to System > Network > Interfaces. Edit the interface, and under
Admin access, enable SNMP. See Interfaces on page 34.
You can also set the thresholds that trigger various SNMP traps. Note that a setting of zero disables the trap.

To configure SNMP settings:
1. Go to System > Administration > SNMP.
2. Enter the following information:
SNMP Contact

Enter the contact information for the person responsible for this
FortiAuthenticator unit.

SNMP Description

Enter descriptive information about FortiAuthenticator.

SNMP Location

Enter the physical location of FortiAuthenticator.

User Table Nearly Full
Trap Threshold

The user table is nearly full. The threshold is a percentage of the
maximum permitted number of users.

User Group Table Nearly
Full Trap Threshold

The user group table is nearly full. The threshold is a percentage of the
maximum permitted number of user groups.

RADIUS Authentication
Client Table Nearly Full
Trap Threshold

The RADIUS authenticated client table is nearly full. The threshold is a
percentage of the maximum permitted number of RADIUS clients.

Authentication Event Rate
Over Limit Trap Threshold

High authentication load. The threshold is the number of authentication
events over a five minute period.

Authentication Failure
Rate Over Limit Trap
Threshold

High rate of authentication failure. The threshold is the number of
authentication failures over a five minute period.

CPU Utilization Trap
Threshold (%)

High load on CPU. The default is set to 90%.

Disk Utilization Trap
Threshold (%)

Disk usage is high. The default is set to 80%.

Memory Utilization Trap
Threshold (%)

Too much memory used. The default is set to 90%.

3. Select OK to apply the changes.
To create a new SNMP community:
1. Go to System > Administration > SNMP.
2. Select Create New under SNMP v1/v2c. The Create New SNMP V1/v2c window opens.
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3. Enter the following information in the SNMPv1/v2c section:
Community name

The name of the SNMP community.

Events

Select the events for which traps are enabled. Options include:
l
CPU usage is high
l
Memory is low
l
Interface IP is changed
l
Auth users threshold exceeded
l
Auth group threshold exceeded
l
Radius NAS threshold exceeded
l
Auth event rate threshold exceeded
l
Auth failure rate threshold exceeded
l
User lockout detected
l
HA status is changed
l
Power Supply Unit failure
l
Disk usage is high

4. In SNMP Hosts, select Add another SNMP Host and enter the following information:
IP/Netmask

Enter the IP address and netmask of the host.

Queries

Select if this host uses queries.

Traps

Select if this host uses traps.

Delete

Select to delete the host.

5. Select OK to create the new SNMP community.
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To create a new SNMP user:
1. Go to System > Administration > SNMP.
2. Select Create New under SNMP v3. The Create New SNMP V3 window opens.
3. Enter the following information in the General section:
Username

The name of the SNMP user.

Security level

Select the security level from the dropdown menu:
l
None: No authentication or encryption.
l
Authentication only: Select the Authentication method then
enter the authentication key in the Authentication key field.
l
Encryption and authentication: Select the Authentication
method, enter the authentication key in the Authentication key
field, then select the Encryption method and enter the encryption
key in the Encryption key field. This option is set by default.

Events

Select the events for which traps are enabled. See Events on page 47.

4. In SNMP Notification Hosts, select Add another SNMP Notification Host and enter the following
information:
IP/Netmask

Enter the IP address and netmask of the notification host.

Delete

Select to delete the notification host.

5. Select OK to create the new SNMP V3 user.
To download MIB files:
1. Go to System > Administration > SNMP.
2. Under FortiAuthenticator SNMP MIB, select the MIB file you need to download, options include the
FortiAuthenticator MIB and Fortinet Core MIB files.

Licensing
FortiAuthenticator-VM works in evaluation mode until it is licensed. In evaluation mode, only a limited number
of users can be configured on the system. To expand this capability, a stackable licence can be applied to the
system to increase both the user count, and all other metrics associated with the user count.
When a license is purchased, a registration code is provided. Go to support.fortinet.com and register your
device by entering the registration code. You will be asked for the IP address of your FortiAuthenticator unit,
and will then be provided with a license key.
Ensure that the IP address specified while registering your unit is configured on one of the device’s network
interfaces, then upload the license key to your FortiAuthenticator-VM.
The License Information widget shows the current state of the device license. See License information
widget on page 32.
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To license FortiAuthenticator:
1. Register your device at the Fortinet Support website.
2. Ensure that one of your device’s network interfaces is configured to the IP address specified during
registration.
3. Go to System > Administration > Licensing.
4. Select Choose File and locate the license file you received from Fortinet.
5. Select OK.

FortiGuard
To view and configure FortiGuard connections, go to System > Administration > FortiGuard. The
FortiGuard Distribution Network (FDN) page provides information and configuration settings for FortiGuard
subscription services. For more information about FortiGuard services, see the FortiGuard web page.
Configure the following settings, then select OK to apply them:
FortiGuard Subscription Services
Messaging
Service

The data to which the messaging service license is valid.

SMS messages

The total number of allowed SMS messages, and the number of messages
that have been used.

FortiGuard Proxy Server
Enable
FortiGuard proxy
server

If enabled, communication with FortiGuard servers will go through this
proxy server.
Enter the proxy server's address, port, and optionally specify a Username
and Password for user authentication.

FortiToken Hardware Provisioning
Server address
Server port

The server address (set to update.fortiguard.net by default) and server
port (set to 443 by default).

FortiToken Mobile Provisioning
Server address
Server port

The server address (set to directregistration.fortinet.com by default) and
server port (set to 443 by default).

Activation
timeout

The activation timeout in hours, from 1 - 168 hours (or seven days).

Token size

The token size, either 6 (set by default) or 8.

Token algorithm

Time-based One-time Password (TOTP, set by default) or Hash-based
One-time Password (HOTP) algorithm.
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Time step

The time step, either 60 (set by default) or 30.

Require PIN

Select whether or not to require a PIN, or to enforce a mandatory PIN.
When set to Required (set by default), the user has the option to set a PIN,
but doesn't have to set one. However, a user must set a PIN when set to
Enforced, which cannot be deleted.

PIN Length

The PIN length, either 8, 6, or 4 (set by default).

FTM trial license
activation

Option to disable the FortiAuthenticator's free trial FortiToken Mobile
licenses.

FortiGuard Messaging Service
Server address
Server port

The server address (set to msgctrl1.fortinet.com by default) and server
port (set to 443 by default).

As of FortiAuthenticator 4.3, FTM Push credentials for Apple and Google can now be
updated via FortiGuard without admin user intervention.

FTP servers
To view a list of the configured FTP servers, go to System > Administration > FTP Servers.
The following information is shown:
Create New

Select to create a new FTP server (this will be the only option available if no
FTP servers are configured).

Delete

Select to delete the selected FTP server or servers.

Edit

Select to edit the selected FTP server.

Name

The name of the FTP server.

Server name/IP

The server name or IP address, and port number.

To create a new FTP server:
1. Select Create New. The Create New FTP Server window will open.
2. Enter the following information:
Name

Enter a name for the FTP server.

FortiAuthenticator 5.5.0 Administration Guide
Fortinet Technologies Inc.

50

System

Connection type

Select the connection type, either FTP or SFTP.

Server name/IP

Enter the server name or IP address.

Port

Enter the port number.

Anonymous

Select to make the server anonymous.

Username

Enter the server username (if Anonymous is not selected).

Password

Enter the server password (if Anonymous is not selected).

3. Select OK to create the new FTP server.

Admin profiles
Similar to FortiOS, FortiAuthenticator can incorporate the use of admin profiles. Each administrator can be
granted either full permissions or a customized admin profile. Profiles are defined as aggregates of read-only or
read/write permission sets. The most commonly used permission sets are pre-defined, but custom permission
sets can also be created.
To create a new admin profile, go to System > Administration > Admin Profiles > Create New. You can
give the admin profile a Name, a Description, and configure the Permission sets you want for that particular
admin profile.
Go to Authentication > User Management > Local Users, and select the admin profile to an administrator.
You can assign more than one admin profile to each administrator.

Messaging
FortiAuthenticator sends email for several purposes, such as password reset requests, new user approvals,
user self-registration, and two-factor authentication.
By default, FortiAuthenticator uses its built-in Simple Mail Transfer Protocol (SMTP) server. This is provided for
convenience, but is not necessarily optimal for production environments. Fortinet recommends that you
configure the unit to use a reliable external mail relay.
There are two distinct email services:

1. Administrators: Password reset, new user approval, two-factor authentication, etc.
2. Users: Password reset, self-registration, two-factor authentication, etc.
If you will be sending SMS messages to users, you must configure the SMS gateways that you will use. Ask
your SMS provider for information about using its gateway. The FortiAuthenticator SMS gateway configuration
differs according to the protocol your SMS provider uses.

SMTP servers
To view a list of the SMTP servers, go to System > Messaging > SMTP Servers.
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Although the FortiAuthenticator can be configured to send emails from the built-in mail
server (localhost), this is not recommended. Anti-spam methods such as IP lookup,
DKIM, and SPF can cause mail from such ad-hoc mail servers to be blocked. It is highly
recommended that email is relayed via an official mail server for your domain.
The following information is shown:
Create New

Select to create a new SMTP server.

Delete

Select to delete the selected SMTP server or servers.

Edit

Select to edit the selected SMTP server.

Set as Default

Set the selected SMTP server as the default SMTP server.

Name

The name of the SMTP server.

Server

The server name and port number.

Default

Shows a green circle with a check mark for the default SMTP server. To change the
default server, select the server you would like to use as the default, then select Set as
Default in the toolbar.

To add an external SMTP server:
1. Go to System > Messaging > SMTP Servers and select Create New. The Create New SMTP Server
window opens.

2. Enter the following information:
Name

Enter a name to identify this mail server on FortiAuthenticator.

Server name/IP

Enter the IP address or Fully Qualified Domain Name (FQDN) of the
mail server.

Port

The default port 25. Change it if your SMTP server uses a different
port.

Sender name (optional)

Optionally, enter the name that will appear when sending an email
from FortiAuthenticator.

Sender email address

In the From field, enter the email address that will appear when
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sending an email from FortiAuthenticator.
Connection Security and
Authentication

Customize the secure connection and authentication for a user.
For a secure connection to the mail server, select STARTTLS from
the dropdown menu.

Secure
connection

Enable
Enable if the email server requires you to authenticate when sending
authentication email. Enter the Account username and Password if required.

3. Optionally, select Test Connection to send a test email message. Specify a recipient and select Send.
Confirm that the recipient received the message.

Note that the recipient’s email system might treat the test email message as spam.

4. Select OK to create the new SMTP server.

Email services
To view a list of the email services, go to System > Messaging > Email Services.
The following information is shown:
Edit

Select to edit the selected email service.

Recipient

The name of the email recipient.

SMTP server

The SMTP server associated with the recipient. The server can be selected
from the dropdown menu.

Save

Select to save any changes made to the email services.

To configure email services:
1. Go to System > Messaging > Email Services and select the recipient you need to edit (the user's email
service is shown below). The Edit Email Service window opens.
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2. Configure the following:
SMTP server

Select the SMTP server from the dropdown menu.

Public Address

Customize the address or link for the email.

Address
discovery
method

Select the address discovery method:
l
Automatic discovery: Use device FQDN if configured, or
automatically obtain address from the browser, or an active network
interface.
l
Specify an address: Manually enter the address and port number.
l
Use the IP address from a network interface: Select a specific
network interface from the dropdown menu.

Address

Enter the recipient IP address or FQDN. Only available if Address
discovery method is set to Specify an address.

Port

Enter the recipient port number (set to 80 by default). Only available if
Address discovery method is set to Specify an address.

Network
interface

Select a configured network interface from the dropdown menu. This
option is only available when the Address discovery method is set to
Use the IP address from a network interface.

3. Select OK to apply your changes.

SMS gateways
To view a list of the configured SMS gateways, go to System > Messaging > SMS Gateways.
The following information is shown:
Create New

Select to create a new SMS gateway.

Delete

Select to delete the selected SMS gateway or gateways.

Edit

Select to edit the selected SMS gateway.

Set as Default

Set the selected SMS gateway as the default SMS gateway.

Name

The name of the SMS gateway.

Protocol

The protocol used by the gateway.

SMTP Server

The SMTP server associated with the gateway.

API URL

The gateway’s API URL, if it has one.

Default

Shows a green circle with a check mark for the default SMS gateway. To
change the default gateway, select the gateway you would like to use as
the default, then select Set as Default in the toolbar.

You can also configure the message that you will send to users. You can use the following tags for user-specific
information:
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Tag

Information

{{:country_code}}

Telephone country code, e.g. 01 for North America.

{{:mobile_number}}

User’s mobile phone number.

{{:message}}

“Your authentication token code is ” and the code.

{{:null}}

Empty string or null value.

To create a new SMTP SMS gateway:
1. Go to System > Messaging > SMS Gateways and select Create New. The Create New SMS
Gateway window opens.

2. Enter the following information:
Name

Enter a name for the new gateway.

Protocol

Select SMTP.

SMTP server

Select the SMTP server you use to contact the SMS gateway. The
SMTP server must already be configured, see SMTP servers on page
51.

Mail-to-SMS gateway

Change domain.com to the SMS provider’s domain name. The default
entry {{:mobile_number}}@domain.com assumes that the
address is the user’s mobile number followed by @ and the domain
name. In the Email Preview section, check the To field to ensure that
the format of the address matches the information from your provider.

Email Preview

View a preview of the email message.
To

Format of the email address, as determined by the Mail-to-SMS
gateway field.
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Subject

Optionally, enter a subject for the message.

Body

Optionally, enter body text for the message.

3. Optionally, select Test Settings to send a test SMS message to the user.
4. Select OK to create a new SMTP SMS gateway.
To create a new HTTP or HTTPS SMS gateway:
1. Go to System > Messaging > SMS Gateways and select Create New. The Create New SMS
Gateway window opens.
2. Expand the HTTP/HTTPS section, then enter the following information:
HTTP/HTTPS
HTTP method

Select the method to use, either GET of POST.

API URL

Enter the gateway URL, omitting the protocol prefix http:// or
https://. Also omit the parameter string that begins with ?.

CA certificate

Select CA certificate that validates this SMS provider from the dropdown
menu.

Content-Type

Select a content type from the dropdown menu.

Authorization
Type

Enter the Username and Password for Basic Auth.

HTTP Parameters
Field

Enter the parameter names that the SMS provider’s URL requires, such
as user and password.

Value

Enter the values or tags corresponding to the fields.

Delete

Delete the field and its value.

3. If you need more parameter entries, select Add another SMS Gateway HTTP Parameter.
4. Optionally, select Test Settings to send a test SMS message to the user.
5. Select OK to create a new HTTP or HTTPS SMS gateway.
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Authentication
FortiAuthenticator provides an easy to configure authentication server for your users. Multiple FortiGate units
can use a single FortiAuthenticator unit for remote authentication and FortiToken device management.

FortiAuthenticator in a multiple FortiGate unit network

What to configure
You need to decide which elements of the FortiAuthenticator configuration you need:
l

l

l

Determine the type of authentication you will use: password-based or token-based. Optionally, you can
enable both types. This is called two-factor authentication.
Determine the type of authentication server you will use: RADIUS, built-in LDAP, or Remote LDAP. You
will need to use at least one of these server types.
Determine which FortiGate units or third-party devices will use the FortiAuthenticator. The
FortiAuthenticator must be configured on each FortiGate unit as an authentication server, either RADIUS
or LDAP. For RADIUS authentication, each FortiGate or third-party device must be configured on the
FortiAuthenticator as an authentication client.

Password-based authentication
User accounts can be created on the FortiAuthenticator device in multiple ways:
l
l

Administrator creates a user and specifies their username and password.
Administrator creates a username and a random password is automatically emailed to the user.
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l

Users are created by importing either a CSV file or from an external LDAP server.

Users can self-register for password-based authentication. This reduces the workload for the system
administrator. Users can choose their own passwords or have a randomly generated password provided in the
browser or sent to them via email or SMS. Self-registration can be instant, or it can require administrator
approval. See Self-registration on page 92.
Once created, users are automatically part of the RADIUS Authentication system and can be authenticated
remotely.
See User management on page 67 for more information about user accounts.

Two-factor authentication
Two-factor authentication increases security by requiring multiple pieces of information on top of the username
and password. There are generally two factors:
l
l

Something the user knows, usually a password,
Something the user has, such as a FortiToken device.

Requiring the two factors increases the difficulty for an unauthorized person to impersonate a legitimate user.
To enable two-factor authentication, configure both password-based and token-based authentication in the
user’s account.
FortiAuthenticator token-based authentication requires the user to enter a numeric token, or one-time
password (OTP), at login. Two types of numerical tokens are supported:
l

Time-based (TOTP): The token passcode is generated using a combination of the time and a secret key
which is known only by the token and the FortiAuthenticator device. The token password changes at
regular time intervals, and FortiAuthenticator is able to validate the entered passcode using the time and
the secret seed information for that token.
Passcodes can only be used a single time (one time passcodes) to prevent replay attacks. Fortinet has the
following time based tokens:
l
FortiToken hardware
l
FortiToken Mobile, running on a compatible smartphone

For more information about TOTP, see RFC 6238.
l

Event-based or HMAC-based (HOTP): The token passcode is generated using an event trigger and a
secret key. Event tokens are supported using a valid email account and a mobile phone number with SMS
service.
FortiToken devices, FortiToken Mobile apps, email addresses, and phone numbers must be configured in
the user’s account.
For more information about HOTP, see RFC 4226.
Only the administrator can configure token-based authentication. See Configuring token-based
authentication on page 73.

Authentication servers
FortiAuthenticator has built-in RADIUS and LDAP servers. It also supports the use of remote RADIUS and
LDAP (which can include Windows AD servers).
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The built-in servers are best used where there is no existing authentication infrastructure, or when a separate
set of credentials is required. You build a user account database on FortiAuthenticator. The database can
include additional user information such as street addresses and phone numbers that cannot be stored in a
FortiGate unit’s user authentication database. To authenticate, either LDAP or RADIUS can be used. The
remote LDAP option adds your FortiGate units to an existing LDAP structure. Optionally, you can add twofactor authentication to remote LDAP.

RADIUS
If you use RADIUS, you must enable RADIUS in each user account. FortiGate units must be registered as
RADIUS authentication clients under Authentication > RADIUS Service > Clients. See RADIUS service on
page 117. On each FortiGate unit that will use the RADIUS protocol, FortiAuthenticator must be configured as
a RADIUS server under User & Device > RADIUS Servers.

Built-in LDAP
If you use built-in LDAP, you will need to configure the LDAP directory tree. You add users from the user
database to the appropriate nodes in the LDAP hierarchy. See Creating the directory tree on page 124. On
each FortiGate unit that will use LDAP protocol, FortiAuthenticator must be configured as an LDAP server
under User & Device > LDAP Servers.

Remote LDAP
Remote LDAP is used when an existing LDAP directory exists and should be used for authentication. User
information can be selectively synchronized with FortiAuthenticator, but the user credentials (passwords)
remain on, and are validated against the LDAP directory.
To utilize remote LDAP, the authentication client (such as a FortiGate device) must connect to the
FortiAuthenticator device using RADIUS to authenticate the user information (see
User & Device > RADIUS Servers). The password is then proxied to the LDAP server for validation, while
any associated token passcode is validated locally.

Machine authentication
Machine (or computer) authentication is a feature of the Windows supplicant that allows a Windows machine to
authenticate to a network via 802.1X prior to user authentication.
Machine authentication is performed by the computer itself, which sends its computer object credentials before
the Windows logon screen appears. User authentication is performed after the user logs in to Windows.
Based on the computer credentials provided during machine authentication, limited access to the network can
be granted. For example, access can be granted to just the Active Directory server to enable user
authentication.
Following machine authentication, user authentication can take place to authenticate that the user is also valid,
and to then grant further access to the network.
Machine authentication commonly occurs on boot up or log out, and not, for example, when a device awakens
from hibernation. Because of this, the FortiAuthenticator caches authenticated devices based on their MAC
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addresses for a configurable period (see General on page 60). For more information on cached users, see
Windows device logins on page 174
To configure machine authentication, see Clients on page 117.

User account policies
General policies for user accounts include lockout settings, password policies, and custom user fields.

General
To configure general account policy settings, go to Authentication > User Account Policies > General.

Configure the following settings:

PCI DSS 3.2 two-factor
authentication

Enable to always collect all authentication factors before indicating a
success or failure.

Expire device login after

Login session timeout for Windows machine authentication via 802.1X.
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Automatically purge
disabled user accounts

Enable to automatically purge disabled user accounts. Select the frequency
of the purge in the Frequency field: Daily, Weekly, or Monthly. Enter the
time of the purge in the Time field: Now to set the time to the current time,
or select the clock icon to choose a time: Now, Midnight, 6 a.m., or
Noon.

Purge users that are
disabled due to the
following reasons

Set the reason for purging disabled users: Manually disabled, Login
inactivity, or Account expired.

Discard stale RADIUS
authentication requests

Enable to select a time after which RADIUS authentication requests are
considered stale and are discarded, from 3 - 360 seconds (or six minutes).
The default is set to 8 seconds.

Expire inactive RADIUS
accounting session after

Enter a time after which RADIUS accounting sessions timeout, from 5 to
1440 minutes (or five minutes to one day). The default is set to 60 minutes.

PCI DSS 3.2 two-factor authentication
The login flows for RADIUS authentication, SAML IdP, Guest Portals, and GUI Login all meet PCI DSS 3.2
standards regarding multi-FortiAuthenticator tor authentication.
In the case where the Bypass FortiToken authentication when user is from a trusted subnet option is
enabled (under Authentication > SAML IdP > Service Providers), and the user is logging in from a trusted
subnet, the login flow reverts to password-only regardless of the PCI mode.
The GUI login page is hard-coded to Apply two-factor authentication if available (authenticate any
user), so it will behave the same as the guest portal.
All failed authentications will return the same generic message, so as not to reveal any clue to an attacker
about which piece of information was valid or invalid:
"Please enter correct credentials. Note that the password is case-sensitive."
Remote login to the CLI (i.e. Telnet, SSH) also complies with the new PCI requirements.

Guest portal exception
There is one exception for guest portals. When a user has exceeded their time and/or data usage limit, the
FortiAuthenticator shows the "Usage exceeded" replacement message. The best behavior would be to only
show the replacement message if the credentials are valid. However, this would require a major change in the
internal flow of the current authentication implementation. Instead, the FortiAuthenticator only requires that
the account name be valid (not the credentials). The downside is that it opens the door for leaking valid account
names. Nonetheless, it is deemed acceptable because:

1. Account name leakage prevention is not a PCI requirement (just a best practice).
2. Leaked account names are not usable because they are disabled (due to exceeded usage).
3. Disabled accounts can't be leveraged to brute-force credentials (in the hope of using them if an
account gets re-enabled/usage extended).
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Lockouts
For various security reasons, you may want to lock a user’s account. For example, repeated unsuccessful
attempts to log in might indicate an attempt at unauthorized access.
Information on locked-out users can be viewed in the Top User Lockouts widget, see Top user lockouts
widget on page 33.
Currently locked-out users can be viewed in Monitor > Authentication > Locked-out Users, see
Authentication on page 173.

To configure the user lockout policy:
1. Go to Authentication > User Account Policies > Lockouts.
2. Configure the following settings, then select OK to apply any changes:
Enable user account
lockout policy
Specify lockout
period

Enable user account lockout for failed login attempts and enter the
maximum number of allowed failed attempts in the Maximum failed
login attempts field.
Enable to specify the length of the lockout period, from 60 to 86400
seconds (or one minute to one day). After the lockout period expires, the
Maximum failed login attempts number applies again.
When disabled, locked out users will be permanently disabled until an
administrator manually re-enables them.

Enable inactive user
lockout

Select to enable disabling a user account if there is no login activity for a
given number of days. In the Lock out inactive users after field, enter
the number of days, from 1 to 1825 (or one day to five years), after
which a user is locked out.

Passwords
Multiple password policies can be created and implemented for different groups, as opposed to enforcing a
global password policy.
When a user is a member of multiple user groups, FortiAuthenticator applies the strictest password policy
settings. For example, if two password policies have different password expiry periods, FortiAuthenticator
applies the shortest expiry period.

For load-balancing HA (A-A), new password policy settings in user groups must be
manually duplicated on the backup unit(s).

You can enforce a minimum length and complexity for user passwords, and can force users to change their
passwords periodically.
For information on setting a user’s password, and password recovery options, see Editing a user on page 70.
Go to Authentication > User Account Policies > Passwords and select Create New to configure a
password policy.
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To set password complexity requirements:
1. Under User Password Complexity, enter the minimum password length in the Minimum length field.
The default length is 8. The minimum length is 0, which means that there is no
minimum length but the password cannot be empty.

2. Optionally, select Check for password complexity and then configure the following password
requirements as needed:
l
Minimum upper-case letters
l

Minimum lower-case letters

l

Minimum numeric characters

Minimum non-alphanumeric characters
You can also enable Use non-alphanumeric characters in random passwords and enter the
characters in th field provided.
3. Select OK to apply the password length and complexity settings.
l
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To set a password change policy:
1. Under User Password Change Policy, optionally select Enable password expiry, then set the
Maximum password age.
The default maximum password age is 90 days. The minimum value allowed is 14 days.
You can also set the password renewal reminder intervals in the Send password renewal reminder on
field available, separating each entry by a comma. The default is every 14, 7, 3, and 1 days.
2. Optionally, select Enforce password history to prevent users from creating a new password that is the
same as their current password or recently used passwords. Then, enter the Number of passwords to
remember. New passwords must not match any of the remembered passwords.
For example, if three passwords are remembered (set by default), users cannot reuse any of their three
previous passwords.
3. Optionally, select Enable random password expiry to force randomly generated passwords to expire.
Then, enter the number of hours after which a randomly generated password will expire in the Random
passwords expire after field.
The default randomly generated password expiry age is 72 hours (or three days). The value can be set
from 1 to 168 hours (or seven days).
You can also set the number of hours users have to set a new password upon receiving a new password
email link. The default is 24 hours. The value can be set from 1 to 168 hours (or seven days).
4. Select OK to create the password policy.

Custom user fields
Custom fields can be created to be included in the user information of local users. See Local users on page 68
for information about creating and managing local users.
To edit custom fields, go to Authentication > User Account Policies > Custom User Fields. A maximum
of three custom fields can be added.

Tokens
As of FortiAuthenticator 4.2, all FortiToken settings have been moved here to be configured and controlled
separately from the General user account policy settings. Additionally, you can configure the
FortiAuthenticator to allow the Windows Agent to cache future tokens for users when they're offline by using the
Enable offline support setting.
To configure token policy settings, go to Authentication > User Account Policies > Tokens.
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Configure the following settings:

FortiTokens
TOTP
Configure the length of time, plus or minus the current time, that a
authentication FortiToken code is deemed valid, from 1 - 60 minutes. The default is set to
window size
1 minute.
HOTP
Configure the count, or number of times, that the FortiToken passcode is
authentication deemed valid, from 1 - 100 counts. The default is set to 3 counts.
window size
TOTP sync
window size

Configure the period of time in which the entry of an invalid token can
trigger a synchronization, from 5 - 480 minutes. The default is set to 60
minutes.
If the token is incorrect according to the FortiToken valid window, but
exists in the sync window, synchronization will be initiated.

HOTP sync
window size

Configure the count, or number of times, that the entry of an invalid token
can trigger a synchronization, from 5 - 500 counts. The default is set to
100 counts.
If the token is incorrect according to the FortiToken valid window, but
exists in the sync window, synchronization will be initiated.

Seed

Passphrase to derive a seed encryption key from, for seed returned when
provisioning a FortiToken Mobile via web service (REST API).
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encryption
passphrase

FortiAuthenticator Agent Offline FortiToken Support
Enable offline
support

Enable this option to set the following:

Shared secret: Set the shared secret used in offline support.
TOTP cache size: Period of time after last login to pre-cache offline
TOTP tokens, from 1 - 14 days. The default is set to 7 days.
HOTP cache size: Period of time after last login to pre-cache offline
HOTP tokens, from 1 - 1000 counts. The default is set to 10 counts.

FortiToken Mobile Transfer
Enable token
transfer
feature

Enable to let users securely transfer FortiToken Mobile tokens from one
mobile device to another. See Transfering FortiToken Mobile tokens from
old to new devices on page 66 below.

Email/SMS
Token timeout Set a time after which a token code sent via email or SMS will be marked
as expired, from 10 - 3600 seconds (or one hour). The default is set to 60
seconds.

Transfering FortiToken Mobile tokens from old to new devices
Changing devices requires the user to install new tokens on their new device, since the unique device ID is used
to form the seed decryption key.

If you wipe data from your device, or upgrade your device, you will need to re-provision
your accounts.

The option to Enable token transfer feature is available under Authentication > User Account Policies >
Tokens.

If it is not enabled, FortiAuthenticator blocks all requests to Transfer Activation Code (see below).
The process for transferring a token to a new device is as follows:

1. The end user selects a new FortiToken Mobile menu option: Initiate Token Transfer.
2. FortiToken Mobile requests a new "Token Transfer Request" service from FortiCare, and includes the
token data.
3. FortiCare stores the token data and creates a Transfer Activation Code.
4. FortiCare signals back to FortiToken Mobile on the old device that "Transfer Initialization" is complete.
5. On the old device, FortiToken Mobile sends a request to FortiAuthenticator for the Transfer Activation
Code.

FortiAuthenticator 5.5.0 Administration Guide
Fortinet Technologies Inc.

66

Authentication

6. FortiAuthenticator retrieves the Transfer Activation Code from FortiCare and signals back to
FortiToken Mobile (on the old device) that the Transfer Activation Code request was successful.
7. FortiAuthenticator sends either an email or SMS to the end user with the transfer code (as a QR code in
the case of email).
8. On the new device, the end user selects the FortiToken Mobile menu option Complete Token Transfer
and enters the transfer code (or scans the QR code).
9. FortiToken Mobile receives the token data from FortiCare and installs the token(s) on the new device.

All tokens are removed on the old device once the transfer is complete.

User management
FortiAuthenticator’s user database has the benefit of being able to associate extensive information with each
user, as you would expect of RADIUS and LDAP servers. This information includes whether the user is an
administrator, uses RADIUS authentication, or uses two-factor authentication, and includes personal
information such as full name, address, password recovery options, and the groups that the user belongs to.
The RADIUS server on FortiAuthenticator is configured using default settings. For a user to authenticate using
RADIUS, the option Allow RADIUS Authentication must be selected for that user’s entry, and the FortiGate
unit must be added to the authentication client list. See RADIUS service on page 117.

Administrators
Administrator accounts on FortiAuthenticator are standard user accounts that are flagged as administrators.
Both local users and remote LDAP users can be administrators.
Once flagged as an administrator, a user account’s administrator privileges can be set to either full access or
customized to select their administrator rights for different parts of FortiAuthenticator.
The subnets from which administrators are able to log in can be restricted by entering the IP addresses and
netmasks of trusted management subnets.
There are log events for administrator configuration activities. Administrators can also be configured to
authenticate to the local system using two-factor authentication.
An account marked as an administrator can be used for RADIUS authentication if Allow RADIUS
Authentication is selected. See RADIUS service on page 117. These administrator accounts only support
Password Authentication Protocol (PAP).
See Configuring a user as an administrator on page 73 for more information.

Groups for administrators
Local and remote user accounts with administrator or sponsor roles can be entered into groups. This provides
the following benefits:
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l
l
l

Group filtering of administrators.
A single account for individuals needing both administrator and user roles.
Inclusion of RADIUS attributes from groups in RADIUS Access-Accept responses.

Local users
Local user accounts can be created, imported, exported, edited, and deleted as needed. Expired local user
accounts can be purged manually or automatically (see General on page 60).
To manage local user accounts, go to Authentication > User Management > Local Users.
The local user account list shows the following information:
Create New

Select to create a new user.

Import

Select to import local user accounts from a CSV file or FortiGate
configuration file.
If using a CSV file, it must have one record per line, with the following
format: user name (30 characters max), first name (30 characters max),
last name (30 characters max), email address (75 characters max), mobile
number (25 characters max), password (optional, 128 characters max).
If the optional password is left out of the import file, the user will be
emailed temporary login credentials and requested to configure a new
password.
Note that, even if an optional field is empty, it still must be defined with a
comma.

Export Users

Select to export the user account list to a CSV file.

Edit

Select to edit the selected user account.

Delete

Select to delete the selected user account or accounts.

Disabled Users

Purge Disabled: This offers the option to choose which type of disabled
users to purge. All users matching the type(s) selection will be deleted.
Re-enable: This allows the administrator to re-enable disabled accounts.
Expired users accounts can only be re-enabled individually.

Search

Enter a search term in the search field, then select Search to search the
user account list.

User

The user accounts’ usernames.

First name

The user accounts’ first names, if included.

Last name

The user accounts’ last names, if included.
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Email address

The user accounts’ email addresses, if included.

Admin

If the user account is set as an administrator, a green circle with a check
mark is shown.

Status

If the user account is enabled, a green circle with a check mark is shown.

Token

The token that is assigned to that user account. Select the token name to
edit the FortiToken, see FortiToken device maintenance on page 90.

Token requested

The status of the user's token request.

Groups

The group or groups to which the user account belongs.

Authentication Methods

The authentication method used for the user account.

Expiration

The date and time that the user account expires, if an expiration date and
time have been set for the account.

Adding a user
When creating a user account, there are three ways to handle the password:

1. The administrator assigns a password immediately and communicates it to the user.
2. FortiAuthenticator creates a random password and automatically emails it to the new user.
3. No password is assigned because only token-based authentication will be used.
To add a new user:
1. In the local users list, select Create New. The Create New Local User window opens.
2. Enter the following information:
Username

Enter a username for the user.

Password creation

Select one of the options from the dropdown menu:
l
Specify a password: Manually enter a password in the
Password field, then reenter the password in the Password
confirmation field.
l
Set and email a random password: Enter an email address to
which to send the password in the Email address field, then
reenter the email address in the Confirm email address field.
l
No password, FortiToken authentication only: After you select
OK, you will need to associate a FortiToken device with this user.
See FortiAuthenticator and FortiTokens on page 89.

Allow RADIUS
authentication

For a user to authenticate using RADIUS, this must be enabled.

Force password change

Enable or disable the option for users to change their local password on
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on next logon

FortiAuthenticator at first logon. This feature prevents administrators
from having to call or email the franchisee to deliver user credentials,
which is not a secure method of delivery and adds additional time to the
onboarding process.

Role

Select whether the new account is for an Administrator, Sponsor, or
regular User. Administrators can either have full permissions or have
specific administrator profiles applied. Regular users can have their
account expirations settings configured.

Enable account expiration

Select to enable user account expiration, either after a specific amount
of time has elapsed, or on a specific date.

Expire after

Select when the account will expire:
l
Set length of time: Enter the number of hours, days, months, or
years until the account expires.
l
Set an expire date: Enter the date on which the account will
expire, either by manually typing it in, or by selecting the calendar
icon and selecting a date.

3. Select OK to create the new user. You will be redirected to the Change local user window to continue
the user configuration in greater detail.
If the password creation method was set to No password, FortiToken authentication only, you will
be required to associate a FortiToken with the user before the user can be enabled.

Editing a user
User accounts can be edited at any time. To edit a user, go to the user account list, select the user you will be
editing, and select Edit from the toolbar. Conversely, select the username in the user list.
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The following information can be viewed or configured:
Username

The username cannot be changed.

Disabled

Select to disable the user account.

Password-based
authentication

Select to enable password-based authentication.

Token-based authentication

Select to enable FortiToken-based authentication. See Configuring tokenbased authentication on page 73.

Allow RADIUS
authentication

Select to allow RADIUS authentication. This applies only to regular users.

Enable account expiration

Select to enable account expiration and specify the account's expiration.
See Enable account expiration on page 70.

User Role

Configure the user’s role.
Role

The user's password can be changed by selecting Change Password.

Select Administrator, Sponsor, or User.
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If setting a user as an administrator, see Configuring a user as an
administrator on page 73.
Allow LDAP
browsing

Select to allow LDAP browsing. This applies only to regular users.

Full permission

Enable to grant this administrator full permission, or enter an Admin profile
in the field provided. This applies only to administrators.

Web service
access

Enable to allow this administrator to access the web services either through
a REST API or using a client application. This applies only to
administrators.

Restrict admin
login from
trusted
management
subnets only

Enable and enter trusted IP addresses and netmasks for restricted
administrator login access. This applies only to administrators.

User Information

Enter user information, such as their address and phone number. See
Adding user information on page 74.

Alternative email addresses

Add alternate email addresses for the user.

Password Recovery
Options

Configure password recovery options for the user. See Configuring
password recovery options on page 74

Groups

Assign the user to one or more groups. See User groups on page 82.

Usage Information

View the user's usage information, including bytes in/out, time used, and
the option to reset the usage statistics.

Email Routing

Enter a mail host and routing address into their respective fields to
configure email routing for the user.

RADIUS Attributes

Add RADIUS attributes. See RADIUS attributes on page 88.

Certificate Bindings

Add, edit, or removed certificate bindings for the user account. See
Configuring certificate bindings on page 76.
Select the certificate name to view the certificate, or select the Revoke
Certificate button to revoke the certificate.

Devices

Add devices, based on MAC address, for the user account.

Select OK when you have finished editing the user’s information and settings.
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Configuring token-based authentication
Token-based authentication requires either a FortiToken device or a mobile device with the FortiToken Mobile
app installed, or a device with either email or SMS capability.
FortiToken and FortiToken Mobile tokens must first be registered under Authentication > User
Management > FortiTokens. For more information, see FortiTokens on page 86.

To configure an account for token-based authentication:
1. To view the token-based authentication options, edit a user and select Token-based authentication.
2. Select one of the following token delivery methods:
l

FortiToken, then select the FortiToken device serial number from the FortiToken Hardware or
FortiToken Mobile dropdown menus, as appropriate.
The device must be known to FortiAuthenticator. See FortiToken devices and mobile
apps on page 1.
Optionally, select Configure a temporary e-mail/SMS token to receive a temporary
token code via email or SMS.

l

Email, then enter the user’s email address in the User Information section.

l

SMS, then enter the user’s mobile number in the User Information section.

l

Dual (Email & SMS), then enter the user's email address and mobile number in the User
Information section.

3. Select Test Token to validate the token passcode. The Test Email Token or Test SMS Token window
opens (depending on your selection).
l
For email and SMS tokens, confirm that the contact information is correct, select Next, then enter the
token code received via email or SMS.
l
Select Back to return to edit the contact information, select Verify to verify the token passcode, or
select Resend Code if a new code is required.
l

For FortiToken, enter the token code in the Token code field, then select Verify to verify the token
passcode.

4. Select OK.
By default, token code verification must be completed within 60 seconds after the
token code is sent by email or SMS. To change this timeout, go to Authentication
> User Account Polices > Tokens and modify the Email/SMS Token timeout
field. For more information, see Lockouts on page 62.

Configuring a user as an administrator
For more information, see Administrators on page 67.

To set a user as an administrator:
1. Edit a user and set Role to Administrator under the User Role section.
2. Enable Full permission to give the administrator full administrative privileges, or enter Admin profiles
to customize the administrator’s permissions.
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3. Optionally, enable Web service access to allow the administrator to access the web services via a
REST API or FortiAuthenticator Agent for Microsoft Windows.
4. Select Restrict admin login from trusted management subnets only, then enter the IP addresses
and netmasks of trusted management subnets in the table, to restrict the subnets from which an
administrator can log in.
5. Select OK to apply the changes to the administrator account.

Adding user information
Some user information can be required depending on how the user is configured. For example, if the user is
using token-based authentication by SMS, a mobile number and SMS gateway must be configured before the
user can be enabled.
The following user information can be entered:

First name

Last name

Email address

Phone number

Mobile number

SMS gateway: select from the dropdown menu.
Select Test SMS to send a test message.

Street address
City

State/Province

Country: Select from the dropdown menu.
Language: Select a specific language from the dropdown menu, or use the default language.
Organization: Select an organization from the dropdown menu. See Organizations on page 84.

Configuring password recovery options
To replace a lost or forgotten password, FortiAuthenticator can send the user a password recovery link by email
or in a browser in response to a pre-arranged security question. The user must then set a new password.

To configure password recovery by email:
1. Edit a user and ensure that the user has an email address entered. See Adding user information on page
74.
2. Under Password Recovery Options section, enable Email recovery.
In the event that additional emal addresses have been configured under Alternative Email Addresses,
an email will be sent to all configured email addresses.
3. Select OK to apply the changes.
To configure password recovery by security question:
1. Edit a user and, under Password Recovery Options, enable Security question, and select Edit.
2. Choose one of the questions from the dropdown menu, or select Write my own question and enter a
question in the Custom question field.
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3. Enter the answer for the question in the Answer field.
4. Select OK to create the security question.
5. Select OK again to apply the changes to the user account.
How the user can configure password recovery by security question:
1. Log in to the user account.
2. Select Edit Profile at the top left of the page.
3. Under Password Recovery Options, select Security Question, and select Edit.
4. Choose one of the questions in the list, or select Write my own question and enter a question in the
Custom question field.
5. Enter the answer for your question.
6. Select OK.
How the user can configure password recovery by email:
1. Log in to the user account.
2. Select Edit Profile at the top left of the page.
3. Under Password Recovery Options, select Email recovery.
4. Optionally, select Alternative email addresses and enter additional email addresses for this user.
5. Select OK.
How the user recovers from a lost password:
1. Browse to the IP address of the FortiAuthenticator.
Security policies must be in place on the FortiGate unit to allow these sessions to be established.

2. At the login screen, select Forgot my password.
3. Select to recover your password either by Username or Email.
4. Enter either your username or email address as selected in the previous step, and select Next.
This information is used to select the user account. If your information does not match a user account,
password recovery cannot be completed.
5. Do one of the following:
l

l

If an email address was entered, check your email, open the email and select the password recovery
link.
If a username was entered, answer the security question and select Next.

6. On the Reset Password page, enter and confirm a new password and select Next.
The user can now authenticate using the new password.

Active Directory users password reset
To allow Active Directory (AD) users to reset their password from the main login page, follow the same workflow
for resetting a local user's password described above.
The Password Recovery Options setting is included in the remote LDAP users configuration page.
This feature is available for both self-service and guest portals.
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Configuring certificate bindings
To use a local certificate as part of authenticating a user, you need to:
l
l

Create a user certificate for the user (see To create a new certificate: on page 178 for more information).
Create a binding to that certificate in the user’s account.

To create a binding to a certificate in a user’s account:
1. Edit a user and expand the Certificate Bindings section.
2. Select Add Binding.
3. Select either Local CA or Trusted CA from the CA certificate dropdown menu, and select the
applicable CA certificate.
4. Enter the Common Name on the certificate. For example, if the certificate says CN=rgreen then enter
rgreen.
5. Select OK to add the new binding.

Remote users
Remote LDAP users must be imported into the FortiAuthenticator user database from LDAP servers. For more
information, see LDAP on page 111.

Note that you will only be able to import a maximum of five remote users if you have an
unlicensed version of FortiAuthenticator-VM.

A FortiToken device already allocated to a local account cannot be allocated to an
LDAP user as well; it must be a different FortiToken device.

Remote RADIUS users can be created, migrated to LDAP users, edited, and deleted.

LDAP users
To import remote LDAP users:

1. Go to Authentication > User Management > Remote Users, ensure that LDAP users is selected,
and select Import.
2. Select a server from the Remote LDAP server dropdown menu, then select Import users or Import
users by group membership, and select Go.
An LDAP server must already be configured to select it in the dropdown menu. For
information on adding a remote LDAP server, see Remote authentication servers
on page 110.
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The Import Remote LDAP Users or Import Remote LDAP Users by Group Memberships window
opens in a new browser window.

3. Optionally, enter a Filter string to reduce the number of entries returned, and then select Apply, or select
Clear to clear the filters.
Please note that the Member attribute field is only available if you select to
Import users by group membership. Use this field to specify the filter by which
users will be shown. In the example, the default attribute (member) will only show
users that are members of groups (users must be part of member attribute of the
groups).

4. The default configuration imports the attributes commonly associated with Microsoft Active Directory
LDAP implementations. Select Configure user attributes to edit the remote LDAP user mapping
attributes.
Selecting the field FirstName, for example, presents a list of detected attributes that can be selected.
This list is not exhaustive as additional, non-displayed attributes may be available for import. Consult your
LDAP administrator for a full list of available attributes.
5. Select the entries you want to import.
6. Optionally, select an organization from the Organization dropdown menu to associate the imported users
with a specific organization. See Organizations on page 84 for more information.
7. Select OK.
The amount of time required to import the remote users will vary depending on the number of users being
imported.
To add two-factor authentication to a remote LDAP user:
1. Edit the remote user, select Token-based authentication, and follow the same steps as when editing a
local user (Editing a user on page 70).
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2. Configure the User Role, User Information, RADIUS Attributes, and Certificate Bindings for the
user as needed.
3. Select OK to apply the changes.

RADIUS users
To view remote RADIUS users, go to Authentication > User Management > Remote Users and select
RADIUS users in the toolbar. See RADIUS on page 116 for more information about remote RADIUS servers.
The following options are available (when remote RADIUS users are available to edit):
Create New

Select to create a new remote RADIUS user.

Delete

Select to delete the selected user or users.

Edit

Select to edit the selected user.

Re-enable

Select to re-enable the status of a user that has been disabled.

Migrate

Select to migrate the selected user or users. See To migrate RADIUS users
to LDAP users: on page 79.

Token

Select to either Enforce or Bypass token-based authentication for the
selected user(s).

Search

Search the remote RADIUS user list.

Username

The remote user’s name.

Remote RADIUS server

The remote RADIUS server or which the user resides.

Admin

Displays whether or not the user is configured as an administrator.

Status

Displays whether or not the user is enabled or disabled.

Token

The FortiToken used by the user, if applicable.

Token Requested

Displays whether or not a FortiToken has been requested for the user.

Enforce token-based
authentication

Displays whether or not token-based authentication is enforced.

To create a new remote RADIUS user:
1. From the remote user list, select RADIUS users and select Create New.
2. Enter the following information:
Remote RADIUS

Select the remote RADIUS server on which the user will be created from
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the dropdown menu. For more information on remote RADIUS servers,
see RADIUS on page 116.
Username

Enter a username.

Enforce token-based
authentication if
configured below

Select to enforce token-based authentication, if you are configuring
token-based authentication.

Token-based
authentication

Select to configure token-based authentication.

Deliver token
code by

Select the method by which token codes will be delivered:
l
FortiToken: Select the FortiToken device serial number from the
FortiToken Hardware or FortiToken Mobile dropdown menus.
l
Email: Enter the user’s email address in the User Information
section.
l
SMS: Enter the user’s mobile number in the User Information
section.
l
Dual (Email & SMS): Enter the user’s email address and mobile
number in the User Information section.
For FortiToken, the device must be known to FortiAuthenticator. See
FortiToken physical device and FortiToken Mobile on page 88.
In addition, you can optionally select Configure a temporary email/SMS token to receive a temporary token code via email or SMS.

Allow RADIUS
authentication

Enable or disable RADIUS authentication.

User Role

Select whether the remote user is either an Administrator (along with
related permissions) or a regular User.

User Information

Enter user information as needed. The following options are available:
l
l
l
l

Email address
Mobile number and SMS gateway
Language
Organization - see Organizations on page 84.

3. Select OK to create the new remote RADIUS user.
To migrate RADIUS users to LDAP users:
1. From the remote RADIUS users list (see Learned RADIUS users on page 175), select the user or users you
need to migrate, then select Migrate from the toolbar.
2. Select an LDAP server from the dropdown menu and select Next.
3. Enter the distinguished names for the users that are being migrated, or browse the LDAP tree (see
Directory tree overview on page 123) to find the users.
4. Select Migrate to migrate the user or users.
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Remote user sync rules
Synchronization rules can be created to control how and when remote users are synchronized. To view a list of
the remote user synchronization rules, go to Authentication > User Management > Remote User Sync
Rules.

To create a new remote user synchronization rule:
1. From the Remote User Sync Rules page, select Create New.
2. Configure the following settings:
Name

Enter a name for the synchronization rule.

Remote LDAP

Select a remote LDAP server from the dropdown menu. To configure a
remote LDAP server, see Remote authentication servers on page 110.

Sync every

Select the amount of time between synchronizations.

Base distinguished name

Base DN of the remote LDAP server that automatically populates when
a remote LDAP server is selected above.

LDAP filter

Optionally, enter an LDAP filter. Select Test Filter to test that the filter
functions as expected.

Token-based
authentication sync
priorities

Select the required authentication synchronization priorities.
Drag the priorities up and down in the list change the priority order.

Sync as

Select to synchronize as a remote user or as a local user. Selecting
either option will open a pop-up dialog box displaying the user fields that
will be synchronized for that selection.

Group to associate users
with

Optionally, select a group from the dropdown menu with which to
associate the users with, or select Create New to create a new user
group. See User groups on page 82.

Organization

Optionally, select an organization from the dropdown menu with which
to associate the users with, or select Create New to create a new
organization. See Organizations on page 84.

Certificate binding CA

Certificate binding CA for users who use remote user sync rules.
When the Certificate binding common name field is populated
(under LDAP User Mapping Attributes) this field must also be
specified.

Debugging Settings

Optionally, log synchronization details, including LDAP query results.
These log files can be downloaded under Debug Report
> LDAP Sync. In addition, select whether to delete synchronized users
when they are no longer found on the remote server.

LDAP User Mapping
Attributes

Optionally, edit the remote LDAP user mapping attributes.

Preview Mapping

Select to preview the LDAP user sync mappings in a new window.

Show Sync Fields

Select to view the user fields that will be synchronized.
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3. Select OK to create the new synchronization rule.

Guest users
Guest user accounts can be created as needed. Guest users are similar to local users, only they are created
with a restricted set of attributes.
To manage guest user accounts, go to Authentication > User Management > Guest Users.
Users can be authenticated against local or remote user databases with single sign-on using client certificates
or SSO (Kerberos/SAML).
Common use cases might include:
l
l

Hotel receptionists creating room accounts
Office staff creating visitor accounts

Newly created account information can be sent to users via email, SMS, or printed out individually.

To create a new guest user/multiple guest users:
1. Go to Authentication > User Management > Guest Users and select Create New.
2. Enter the following information:
The "Sponsor" role for local and remote users is equivalent to an administrator with
Read-Write permissions to the Guest Users sub-menu only.

General

Express

Creation
Mode

There are three guest user creation methods:
l
Express: Quickly create guest user accounts without the need to
enter any user information.
Guest accounts generated this way only have four attributes:
Sponsor, Username (eight random lowercase letters—must be
unique from any other existing user account), Password, and
Expiry.
l
From CSV file: Create guest user accounts using information
from a CSV file in the following format: <first name>, <last
name>, <email>, <mobile>, <group>.
l
Manual Input: Create guest user accounts by manually entering
the user attributes for each guest user.

Expiry date

Set the date that the guest user account(s) will expire.

Expiry time

Set the time that the guest user account(s) will expire. The time can
either be manually entered, or defined from four options: Now,
Midnight, 6 a.m., or Noon.
The following is only available when Creation Mode is set to Express.
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Number of
new guest
users

Number of new guest users to be added, up to a maximum of 1000.

Groups

Choose user groups from the list available to assign the new guest
users.

CSV Import

The following is only available when Creation Mode is set to From
CSV file.
CSV file

Guest Basic Information

Add Guest
User

Choose a CSV file to import the user attributes.
The following is only available when Creation Mode is set to Manual
Input.
Manually enter guest user information, including their First name, Last
name, Email address, Mobile number, Groups, and Actions.
Choose user groups from the list available to assign the new guest
users.

User groups
Users can be assigned to groups during user account configuration (see Editing a user on page 70), or by
editing the groups to add users to it.
To view the user groups list, go to Authentication > User Management > User Groups.
Note that user groups can be created for MAC devices. However, MAC devices will only
be available to add in a MAC user group once devices have been created or imported.
See MAC devices for more information.

To create a new user group:
1. Go to Authentication > User Management > User Groups and select Create New.
2. Enter the following information:
Name

Enter a name for the group.

Type

Select the type of group: Local, Remote LDAP, Remote RADIUS, or MAC .

Users

Select from available users and move them to the Selected users box to add
them to the group.
This option is only available if Type is Local.

User retrieval

Determine group membership by selecting either Specify an LDAP filter or Set
a list of imported remote LDAP users.
This option is only available if Type is Remote LDAP.
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Remote LDAP

Select a remote LDAP server from the dropdown menu. At least one remote LDAP
server must already be configured, see Remote authentication servers on page
110.
This option is only available if Type is Remote LDAP.

Remote RADIUS

Select a remote RADIUS server from the dropdown menu. At least one remote
RADIUS server must already be configured, see Remote authentication servers on
page 110.
This option is only available if Type is Remote RADIUS.

LDAP filter

Enter an LDAP filter. Optionally, select Test filter to ensure that the filter works
as expected.
This option is only available if Type is Remote LDAP and User retrieval is set to
Specify an LDAP filter.

LDAP users

Select remote LDAP users from the Available LDAP users box and move them
to the Selected LDAP users box to add them to the remote group.
This option is only available if Type is Remote LDAP and User retrieval is set to
Set a list of imported remote users.

RADIUS users

Select remote RADIUS users from the Available RADIUS users box and move
them to the Selected RADIUS users box to add them to the remote group.
This option is only available if Type is Remote RADIUS.

MAC devices

Select from available MAC devices and move them to the Selected MAC
devices box to add them to the group.
This option is only available if Type is MAC.

3. Select OK to create the new group.
To edit a user group:
1. In the user group list, select the group that you need to edit.
2. Edit the settings as required. The settings are the same as when creating a new group.
3. Select OK to apply your changes.

User groups for MAC-based RADIUS authentication
Once created, MAC user groups can then be used under the MAC-based authentication section of RADIUS
clients, under Authentication > RADIUS Service > Clients. See Clients for more information.

Usage profile
Usage profiles can be created to determine user time and data usage on a granular level.
To view the usage profile list, go to Authentication > User Management > Usage Profile.
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To create a new usage profile:
1. Go to Authentication > User Management > Usage Profile and select Create New.
2. Enter the following information:
Name

Enter a name for the profile.

Description

Optionally, enter information about the usage profile.

Time Usage

Select how time usage is determined.

Time limit

For this profile, the user's time limit will be either unlimited or measured
from the moment their account was created, from when they first logged
on, or how much time they have used.
When the method has been chosen, enter the time period, in either
minutes, hours, days, weeks, or months. The default is set to seven
days.

Data Usage

Select how data usage is determined.

Data limit

For this profile, the user's data limit will either be unlimited or restricted
to the amount of data they have used.
If data usage is to be limited, enter the data amount in either KB, MB,
GB, or TB. The default is set to 1 GB.

Time Schedule

Timezone

Select the timezone the usage profile should follow.
Timezone the usage profile should follow. The default is set to
(GMT) UTC - No Daylight Savings.

3. Select OK to add the new usage profile.

Organizations
Organizations include a name and logo. An organization can be associated with local and remote users.
When a user provisions FortiToken Mobile on their device, the organization name and logo are automatically
pushed to the device, allowing the FortiToken Mobile App’s user interface to be rebranded.
Organizations can be created, edited, and deleted as needed. Organizations are applied to users from the
various user management pages. See Local users on page 68, Remote users on page 76, and Remote user
sync rules on page 80 for more information.
To manage organizations, go to Authentication > User Management > Organizations.

To create a new organization:
1. From the organization list, select Create New.
2. Enter a Name for the organization.
3. Optionally, upload a logo file for the organization on your computer. The image can be a maximum of
320x320 pixels, and must be 24-bit PNG file.
4. Select OK to create the new organization.
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Realms
Realms allow multiple domains to authenticate to a single FortiAuthenticator unit. Both LDAP and RADIUS
remote servers are supported. Each RADIUS realm is associated with a name, such as a domain or company
name, that is used during the login process to indicate the remote (or local) authentication server on which the
user resides.
For example, the username of the user PJFry, belonging to the company P_Express, would become any of
the following, depending on the selected format:
l

PJFry@P_Express

l

P_Express\PJFry

l

P_Express/PJFry

The FortiAuthenticator uses the specified realm to identify the back-end RADIUS or LDAP authentication server
(s) used to authenticate the user.
Acceptable realms can be configured on a per RADIUS server client basis. See RADIUS service on page 117 for
more information.
To manage realms, go to Authentication > User Management > Realms. The following options are
available:
Create New

Select to create a new realm.

Delete

Select to delete the selected realm or realms.

Edit

Select to edit the selected realm.

Name

The names of the realms.

User Source

The source of the users in the realms.

Chained token
authentication with remote
RADIUS server

Available when User source is set to an LDAP server. Enable from the
dropdown menu to chain token authentication with a RADIUS server.

To create a new realm:
1. From the realms list, select Create New.
2. Enter a Name for the realm.
The realm name may only contain letters, numbers, periods, hyphens, and
underscores. It cannot start or end with a special character.

3. Select the User source for the realm from the dropdown menu. The options include Local users, or from
specific RADIUS or LDAP servers.
4. Enable Chained token authentication with remote RADIUS server. Note that this option is only
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available when selecting a remote LDAP server as the User source.
FortiAuthenticator 4.3+ supports chained authentication, providing the ability to
chain two different authentication methods together so that, for example, a twofactor authentication RSA solution can validate passcodes via RADIUS.

5. Select OK to create the new realm.

FortiTokens
Go to Authentication > User Management > FortiTokens to view a list of configured FortiTokens. From
here, FortiTokens can be added, imported, exported, edited, deleted, and activated.
See FortiToken physical device and FortiToken Mobile on page 88 for more detailed information.
The following information is shown:
Create New

Create a new FortiToken.

Import

Import a list of FortiTokens from a serial number CSV file, a seed CSV file,
or from a FortiGate configuration.

Export FTK Hardware

Export the FortiToken list.

Refresh FTM

Refresh the Status of a FortiToken Mobile token.

Delete

Delete the selected FortiToken(s).

Edit

Edit the selected FortiToken.

Activate

Activate the selected FortiToken(s).

Search

Search the FortiToken list.

Serial number

The FortiToken’s serial number.

Token type

The FortiToken type, either FortiToken Hardware or FortiToken
Mobile.

Status

Whether or not the FortiToken is activated.

Comment

Comments about the token.

User

The user to whom the FortiToken applies.

Algorithm

The FortiToken's encryption.

Size

The size of the token.
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Drift/Counter

The time difference between the FortiAuthenticator and the FortiToken.

Timestep

The FortiToken timestep.

FTM license

The FortiToken Mobile license applied to the FortiToken.

Platform

The FortiToken's platform.

MAC devices
Non-802.1X compliant devices can be identified and accepted onto the network using MAC address
authentication. See Non-compliant devices on page 138 for more information.
Go to Authentication > User Management > MAC Devices to view a list of configured MAC devices. From
here, MAC devices can be created, imported, edited, and deleted.
The following information is shown:
Create New

Create a new MAC-based authentication devices.

Import

Import a list of MAC devices from a CSV fileTo import FortiTokens from a
CSV file: on page 90

Once created/imported, MAC devices can be added to MAC user groups. See User groups for more
information.

Device tracking
When enabled, this feature allows end users to self-register their devices, and to have those devices tracked,
based on the device MAC address.
An unregistered device is granted restricted network access, and is redirected to the FortiAuthenticator guest
portal. The user enters valid credentials, then the FortiAuthenticator detects the unregistered device and offers
the user an option to register it. If the user registers the device, it becomes part of their authorized device group
and the user is granted network access on that device (if the user does not register the device, they are
redirected to the guest portal login page).
To link a device to a user configuration, create a new MAC-based authentication device entry under
Authentication > User Management > MAC Devices, and enable This device belongs to a user.
Similarly, it is possible to link a device from a user configuration. In either case, names and MAC addresses
must be unique.
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To fully benefit from this feature, you must use a FortiAuthenticator in conjunction with a FortiGate running
FortiOS 6.0+.

RADIUS attributes
Some services can receive information about an authenticated user through RADIUS vendor-specific attributes.
FortiAuthenticator user groups and user accounts can include RADIUS attributes for Fortinet and other
vendors.
Attributes in user accounts can specify user-related information. For example, the Default attribute FramedIP-Address specifies the VPN tunnel IP address to be sent to the user by the Fortinet SSL VPN.
Attributes in user groups can specify more general information, applicable to the whole group. For example,
specifying third-party vendor attributes to a switch could enable administrative level login to all members of the
Network_Admins group, or authorize the user to the correct privilege level on the system.

To add RADIUS attributes to a user or group:
1. Go to Authentication > User Management > Local Users and select a user account to edit, or go to
Authentication > User Management > User Groups and select a group to edit.
2. In the RADIUS Attributes section, select Add Attribute. The Create New User Group RADIUS
Attribute or Create New User RADIUS Attribute window opens.
3. Select the appropriate Vendor and Attribute ID, then enter the attribute’s value in the Value field.
4. Select OK to add the new attribute to the user or group.
5. Repeat the above steps to add additional attributes as needed.

FortiToken physical device and FortiToken Mobile
A FortiToken device is a disconnected one-time password (OTP) generator. It is a small physical device with a
button that when pressed displays a six digit token passcode. FortiToken Mobile is an application for mobile
devices that performs the same one-time password function as a FortiToken device.
Each FortiAuthenticator unit or VM is supplied with two trial FortiToken Mobile tokens. To obtain the free
FortiToken Mobile tokens (if they have not been created dynamically on install), select Get FortiToken
Mobile trial tokens when adding a FortiToken Mobile token. This may be required if, for example, you are
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upgrading an unlicensed FortiAuthenticator unit to a licensed one, as the old tokens associated with the
unlicensed serial number will not be compatible with the new, licensed serial number. The tokens will still work,
but they are not able to be reassigned to a new user. In this case, you must delete the old tokens, and then
generate new ones.
Time-based token passcodes require that FortiAuthenticator clock is accurate. If possible, configure the system
time to be synchronized with an NTP server.
To perform token-based authentication, the user must enter the token passcode. If the user’s username and
password are also required, this is called two-factor authentication. The displayed code changes every 60
seconds.
FortiAuthenticator supports FortiToken OTP push notifications, or FTMv4 push
notifications. Using FTMv4, when required to authenticate themselves, FortiToken
Mobile users don't have to look-up a code in FortiToken and enter the code into their
browser. Instead FortiToken Mobile is queried and the user just responds to accept the
connection and the session is authenticated.

FortiAuthenticator and FortiTokens
With FortiOS, FortiToken identifiers must be entered into the FortiGate unit, which then contacts FortiGuard
servers to verify the information before activating them.
FortiAuthenticator on the other hand acts as a repository for all FortiToken devices used on your network. It is a
single point of registration and synchronization for easier installation and maintenance.
To register FortiTokens, you must have a valid FortiGuard connection, otherwise any
FortiTokens you enter will have an Inactive status. After the FortiTokens are
registered, the connection to FortiGuard is no longer essential.
If a token authentication fails, check that the system time on FortiAuthenticator is
correct and re-synchronize the FortiToken.

To add FortiTokens manually:
1. Go to Authentication > User Management > FortiTokens and select Create New.
2. Select the Token type, either FortiToken Hardware or FortiToken Mobile.
3. If FortiToken Hardware is selected, enter one or more token serial numbers in the Serial numbers
field.
You can also import multiple tokens by selecting Import Multiple, or by selecting Add all FortiTokens
from the same Purchase Order and entering a single token's serial number; all tokens associated with
that purchase order will then be imported.
4. If FortiToken Mobile, enter the Activation codes in the field provided, or select Get FortiToken
Mobile free trial tokens to use temporary tokens.
5. Select OK to add the FortiToken(s).
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To import FortiTokens from a CSV file:
1. From the FortiToken list, select Import.
2. Do one of the following:
l

l

Select Serial number file to load a CSV file that contains token serial numbers. FortiToken devices
have a serial number barcode on them used to create the import file.
Select Seed file to load a CSV file that contains the token serial numbers, encrypted seeds, and IV
values.

3. Select Choose File, find the configuration file, and select Open.
4. Select OK to import the FortiTokens.
To import FortiTokens from a FortiGate unit:
1. Export the FortiGate unit configuration to a file.
2. From the FortiToken list, select Import.
3. Select FortiGate configuration file.
4. For Data to import, select either Import FortiToken Hardware only, Import FortiToken Hardware
and only their associated users, or Import all FortiToken Hardware and users.
5. Select Choose File, find the configuration file, and select Open.
6. If the file is encrypted, enter the Password in the field provided.
7. Select OK to import the FortiTokens.
To export FortiTokens:
1. From the FortiToken list, select Export FTK Hardware.
2. Save the file to your computer.

Monitoring FortiTokens
To monitor the total number of FortiToken devices registered on FortiAuthenticator, as well as the number of
disabled FortiTokens, go to System > Dashboard > Status and view the User Inventory widget.
You can also view the list of FortiTokens, their status, token clock drift, and which user they are assigned to
from the FortiToken list found at Authentication > User Management > FortiTokens.

FortiToken device maintenance
Go to Authentication > User Management > FortiTokens, then select the FortiToken you need to perform
maintenance and select Edit. The following actions can be performed:
l
l

l
l

Comments can be added for FortiToken.
The device can be locked if it has been reported lost or stolen.
A reason for locking the device must be entered, and a temporary SMS token can be provided.
The device can be unlocked if it is recovered.
The device can be synchronized.
Synchronize the FortiAuthenticator and the FortiToken device when the device clock has drifted. This
ensures that the device provides the token code that FortiAuthenticator expects, as the codes are time-
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based. Fortinet recommends synchronizing all new FortiTokens.
l

The device history can be viewed, showing all commands applied to this FortiToken.

FortiToken drift adjustment
When FortiAuthenticator and FortiTokens have been initialized prior to setting an NTP server, the time
difference can be too large to correct with the synchronize function, forcing all tokens to resynchronize. To
avoid this, selected tokens can be manually drift shifted.
The following procedure is intended to be used only in special cases where some
FortiTokens are severely out-of-sync, for example, when a token is switched from
manual configuration to NTP control. Under normal circumstances, this is not required.
Only activated FortiTokens can be adjusted.

To perform time drift adjustment on a FortiToken:
1. In a browser, go to:
https://<FortiAuthenticator-IP-Address>/admin/fac_auth/fortitokendrift/

2. Select the FortiToken to adjust, then select Adjust Drift. The Adjust Token Drift window opens.

3. Enter the required Time adjustment in minutes.
Make sure to include a minus sign (-) for a negative value, but don’t use a plus sign (+) for a positive value.
4. Select OK to adjust the token drift.

Self-service portal
Configure general self-service portal options, including access control settings, self-registration options,
replacement messages, and device self-enrollment settings.

General
To configure general self-service portal settings, go to Authentication > Self-service Portal > General.
The following settings can be configured:
Default portal language

Select from several default portal language packs from the dropdown
menu.
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Add a Language
Pack

Upload a different language pack.
Obtain additional translation packs from the Fortinet Support website if you
need to translate to your local language.

Site name

Enter a name that is used when referring to this site. If left blank, the
default name will be the site DNS domain name or IP address.

Email signature

Add a signature to be appended to the end of outgoing email messages.

Allow users to change their
password

Enable to allow local and/or remote users the ability to change their own
password.

Access control
To configure self-service portal access settings, go to Authentication > Self-service Portal > Access
Control.
The following settings can be configured:
Username input format

Select from the following username input formats: username@realm,
realm\username, realm/username. The realm name is optional when
authenticating against the default realm.

Realms

Add realms to which the user will be associated.
l
Select a realm from the dropdown menu in the Realm column.
l
Select whether or not to allow local users to override remote users for
the selected realm.
l
Edit the group filter to filter users based on the groups they belong to.
l
If necessary, add more realms to the list.
l
Select the default realm for this client.

Self-registration
When self-registration is enabled, users can request registration through the FortiAuthenticator login page.
Self-registration can be configured so that a user request is emailed to the device administrator for approval.
When the account is ready for use, the user receives an email or SMS message with their account information.
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To enable self-registration:
1. Go to Authentication > Self-service Portal > Self-registration.

2. Select Enable to enable self-registration.
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3. Optionally, configure the following settings:
Require administrator
approval

Select to require that an administrator approves the user.

Enable email to
freeform
addresses

Select to send self-registration requests to the email addresses entered
in the Administrator email addresses field.

Select User
Groups allowed
to approve new
user
registrations

Select to send self-registration requests to specific user groups. Select
the required approvers from the Available groups box and move them
to the Chosen groups box.
If enabled, the guests are given a dropdown list of approvers to choose
from on the self-registration page. The FortiAuthenticator sends an
approval request to that approver's email address. The list of approvers
is the union of all the users/administrators who are members of the
specified groups. Local, remote LDAP, and remote RADIUS groups are
supported.

Account expires after

Enable to specify an expiration for self-generated accounts after they
are generated.

Use mobile number as
username

If enabled, after a successful registration, the user’s password will be
sent to them via SMS to confirm their identity.

Place registered users
into a group

Select a group into which self-registered users will be placed from the
dropdown menu.

Password creation

Select how a password is created, either User-defined or
Randomly generated.

Send account information via

Choose how to send account information to the user, either SMS,
Email, or Display on browser page.
The Display on browser page option is only available if administrator
approval is not required.

SMS gateway

Select an SMS gateway from the dropdown menu. See SMS gateways
on page 54 for more information.

Required Field
Configuration

Select the fields that the user is required to populate when selfregistering. Options include: First name, Last name, Email,
address, Address, City, State/Province, Country, Phone number,
Mobile number, Custom field 1, Custom field 2, and
Custom field 3.
See Custom user fields on page 64 for more information.

4. Select OK to apply your changes.

Self-registration approval
The self-registration page is a customizable replacement message. The default replacement message
contains a new optional field for the self-registering guest to select an approver. The list of approvers comes

FortiAuthenticator 5.5.0 Administration Guide
Fortinet Technologies Inc.

94

Authentication

from the groups specified in the configuration. The dropdown list is populated with the explicit list of group
members for local groups, remote RADIUS groups, and remote LDAP groups.
Each approver in the dropdown list is designated as "Lastname, Firstname". In cases where first and last name
are not available, an approver is designated as "username" instead. Disabled user accounts are excluded from
the list. User accounts without a configured email address are also excluded from the list.

To approve a self-registration request:
1. Select the link in the Approval Required for... email message to open the New User Approval page in
your web browser.
2. Review the information and select either Approve or Deny, as appropriate.
Approval is required only if Require administrator approval is enabled in the self-registration settings.
If the request is approved, FortiAuthenticator sends the user an email or SMS message stating that the
account has been activated.

How a user requests registration
A user can request registration, or self-register, from the FortiAuthenticator login screen.

To request registration:
1. Browse to the IP address of FortiAuthenticator.
Security policies must be in place on the FortiGate unit to allow these sessions to be established.
2. Select Register to open the user registration page.
3. Fill in all the required fields and, optionally, fill in the Additional Information fields.
4. Select OK to request registration.
If administrator approval is not required and Display on browser page is enabled, the account details
are immediately displayed to the user.

Token self-provisioning
User token self-provisioning allows users to set up their own FortiTokens without direct intervention of an
administrator.
To configure token self-provisioning settings, go to Authentication > Self-service Portal > Token selfprovisioning.
The following settings can be configured:

Token Self-registration
Allow FortiToken Hardware
self-provisioning

Enable this option if you want to allow users to self-provision their own
FortiToken Hardware tokens.

Allow FortiToken Mobile
self-provisioning

Enable this option if you want to allow mobile users to self-provision their
FortiToken Mobile.
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Token Self-registration
Allow Email selfprovisioning

Enable this option if you want to allow users to self-provision their
FortiToken Mobile via email.

Allow SMS selfprovisioning

Enable this option if you want to allow users to self-provision their
FortiToken Mobile via SMS.

Allow user to request a
token from Administrator at
this email address

Enable this option if you want to allow users to request a new token using
an email address.

Restrict token selfprovisioning to members of
specific groups

Enable this option if you want to restrict token self provisioning only to
members of selected user groups.

Token Self-revocation
Allow users to report a lost
token to the Administrator
at this email address

Enable this option if you want to allow users to report a lost token to a
specific email address.

Allow users to temporarily
use SMS token
authentication if a mobile
number was pre-configured

Enable this option if you want to allow users to switch to temporary SMS
based authentication. The administrator will also be notified.

Allow users to temporarily
use email token
authentication if an email
was pre-configured

Enable this option if you want to allow users to switch to temporary email
based authentication. The administrator will also be notified.

Allow users to re-provision
their FortiToken Mobile

Enable this option if you want to allow mobile users to re-provision their
token.

How a user registers a token
If enabled, a user can self-register a token from the user portal screen.

To self-register:
1. Browse to the IP address of the user portal and log in.
2. Go to My Account > User > Register Token to open the token registration options.
3. Fill in all the required fields.
Only options that the administrator has configured under the Token Self-registration options will be
available.
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4. Select OK to register token.
If a token is already assigned to the user, the token registration page will display the token along with its
serial number.

How a user reports a lost token
A user can report a lost token (mobile or physical) from the user portal screen.

To report lost token:
1. Browse to the IP address of the user portal.
2. Select I lost my token.
The user will be directed to a page warning them that their account will be locked and the administrator will
be notified. Select OK to continue.
3. Select the preferred option.
Only options that the administrator has configured under the Token Self-revocation options will be
available.
4. Select OK to continue.

Replacement messages
The replacement messages list allows you to view and customize replacement messages, and manage
images.
Go to Authentication > Self-service Portal > Replacement Messages to view the replacement message
list.

FortiAuthenticator 5.5.0 Administration Guide
Fortinet Technologies Inc.

97

Authentication

The replacement messages are split into seven categories: Account, Authentication, Device Certificate
Enrollment, Password Reset, User Registration, SAML IdP, and SAML SP (FSSO).
The two pre-authentication replacement messages under Authentication are only
available once pre-authentication has been enabled under System > Administration
> System Access.
Selecting a specific message will display the text and HTML or plain text of the message in the lower half of the
content pane.
Selecting Toggle Tag List will display a table of the tags used for that message atop the message’s HTML or
plain text box.

To edit a replacement message:
1. Select a message in the replacement message list.
2. Edit the plain text or HTML code in the lower right pane, or select the open in new window icon to edit the
message in a new browser window.
3. When you are finished editing the message, select Save to save your changes.
4. If you have made an error when editing the message, select Restore Default to restore the message to its
default value.
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Manage Images
Images can be managed by selecting Manage Images in the Replacement Messages window. Images can
also be added, deleted, and edited.

To add an image:
1. In the manage images screen, select Create New to open the Create New Image window.
2. Enter a name for the image in the Name field.
3. Select Browse..., find the GIF, JPEG, or PNG image file that you are adding, and then select Open.
The maximum image size is 65kB.
4. Select OK to add the image.
To delete an image:
1. In the manage images screen, select an image, then select Delete.
2. Select Yes, I’m sure in the confirmation window to delete the image.
To edit an image:
In the manage images screen, select an image, then select Edit.

1. In the Edit Image window, edit the image name and file as required.
2. Select OK to apply your changes.

Device self-enrollment
Device certificate self-enrollment is a method for local and remote users to obtain certificates for their devices.
It can be used to enable EAP-TLS for BYOD configurations, or for VPN authentication. For example:
l
l
l

l

A user brings their tablet to a BYOD organization.
They log in to FortiAuthenticator and create a certificate for the device.
With their certificate, username, and password they can authenticate to gain access to the wireless
network.
Without the certificate, they are unable to access the network.

EAP-TLS is a bidirectional certificate authentication method; the client and the
FortiAuthenticator EAP need to have matching certificates from the same CA.

To enable device self-enrollment and adjust self-enrollment settings, go to Authentication > Self-service
Portal > Device Self-enrollment and select Enable user device certificate self-enrollment.

SCEP must be enabled to activate this feature, see SCEP on page 194.
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The following settings can be configured:
SCEP enrollment template

Select a SCEP enrollment template from the dropdown menu. SCEP can
be configured in Certificate Management > SCEP.

Maximum devices

Set the maximum number of devices that a user can self-enroll.

Key size

Select the key size for self-enrolled certificates (1024, 2048, or 4096 bits).
Note that iOS devices only support 1024 and 2048.

Enable self-enrollment for
Smart Card certificate

Select to enable self-enrollment for smart card certificates.
This requires that a Device FQDN be configured (in the System
Information widget under System > Dashboard > Status), as it is used
in the CRL Distribution Points (CDPs) certificate extension.

Select OK to apply any changes you have made.

Guest portals
The following section describes how to configure custom guest portals on a per customer or per AP/controller
basis.
The portals are assigned RADIUS clients and profiles, can permit certain pre-login and post-login services for
users (such as password reset and token registration abilities), and rules and replacement messages can be
configured.

Portals
Guest portal configuration is available under Authentication > Guest Portals > Portals.
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To configure a guest portal:
1. Select Create New to configure settings for a new guest portal.
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2. Enter the following information:
Name

A name to identify the guest portal.

URL

The URL of the guest portal, in the format of:

https://<FortiAuthenticator IP/FQDN>/guests
Description

Optionally, enter information about the guest portal.

MAC device
HTTP parameter

Select one of the HTTP parameters available to use for this guest
portal:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
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ap_building
ap_mac
l
grant_url
This field must be configured if this portal's Authentication type is set
to Device only (MAC address).
l
l

Profile Configuration

Assign one or more RADIUS clients and profiles to the portal.

General

Assign an SMS gateway for self-registered users.

Authentication

Select either User credentials or Device only (MAC address) as
the authentication type:

User credentials: Selected by default, this option requires either local
or remote user account credentials, or with social site credentials:
l
Account login: Authentication with local or remote user account
credentials.
l
Social login: Authentication with social site credentials
(OAUTH), phone number or email. If RADIUS client is a FortiWLC
controller, appropriate firewall pinholes should be added under
Authentication > Guest Portals > General > FortiWLC.
Once enabled, you can optionally determine whether the social
account expires after a certain amount of time (measure in
minutes, hours, days, weeks, or months). In addition, various
social login platforms become available within which you can enter
their respective Key and Secret, including
FortiAuthenticatorebook, Google, Twitter, LinkedIn, or with phone
number or email address.
Once a social login has been successfully completed on the guest
portal via OAUTH, email, or SMS, a social login user account is
created under Authentication > User Management > Social
Login Users.
Device only (MAC address): When this option is enabled, the "MAC
device HTTP parameter" must also be configured.
When using device only authentication, the endpoint will not be
presented with the login page. Instead, the FortiAuthenticator will only
use the endpoint device's MAC address for authentication purposes.
If the RADIUS client profile associated has MAC device filtering
enabled, the MAC address is authenticated according to those
settings. If MAC device filtering is disabled, any MAC address is
accepted.
Optionally, you can determine whether the device account expires after
a certain amount of time. To configure, enable the checkbox, enter a
value, and select either minute(s), hour(s), day(s), week(s), or
month(s).
Pre-login Services

Disclaimer

Configure various pre-login services to permit to users.
Enable or disable the appearance of a disclaimer to the end-user that
must be accepted before proceeding to the login page.
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To configure the disclaimer, edit the Login Disclaimer Page
replacement message under Authentication > Guest Portals >
Replacement Messages.
Password Reset

Enable or disable pre-login password reset link.

Account
Registration

Select to configure various user account registration options:
l
Require administrator approval: Enable/disable whether the
user requires administrator approval. If enabled, select whether to
send admin approval emails to freeform addresses or to selected
user groups.
l
Account expires after: Enable/disable account expiration. If
enabled, enter the number of hours, days, months, or years the
account remains expired from the dropdown menu.
l
Use mobile number as username: Determine whether to
require the user's mobile number as their username.
l
Place registered users into a group: Determine whether to
place registered users into a group from the dropdown menu.
l
Password creation: Determine whether the user's password is
user-defined or randomly generated.
l
Enforce contact verification: Enable/disable whether to enforce
contact verification. If enabled, select whether to verify the user's
email address or mobile number, or allow the user to decide
between email address or mobile number.
l
Account delivery options available to the user: Determine
whether the user's account information is sent to them by SMS,
email, or displayed on the browser page. If more than one option
is selected, the self-registering user decides which account
delivery method to use. If Require administrator approval is
enabled, Display on browser page is disabled.
l
Required field configuration: Configure the available fields
required by the user to enter (First name, Last name, Email
address, and Mobile number are enabled by default).

Token
Revocation

Select to revoke tokens based on various conditions:
l

l

l

l

Usage Extension
Notifications
Post-login Services

Profile

Allow users who exceeded their time and/or data usage to request an
extension via an email notification.

Configure various post-login services to permit to users.
Select to determine whether authenticated users can view/edit their
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account information.
Password
Change

Select to determine whether local and/or remote users have the ability
to change their passwords once logged in.

Token
Registration

Select to configure FortiToken Mobile self-provisioning privileges.

Smart Connect

Select to assign a Smart Connect profile. See Smart Connect Profiles
for more information.

Device Tracking
and
Management

Select to require users to register their devices once logged in.

3. Select OK to add the new guest portal.

Token self-revocation
Token self-provisioning is offered as a pre-login service for guest portals.
When the token self-revocation feature is enabled (Authentication > Self-service Portal > Token selfprovisioning), the guest portal's token verification page will have an additional Lost my token link. Clicking
this link provides access to the token self-revocation service page that includes the following options:
l

Re-provision my FortiToken Mobile

l

Switch to email token authentication

l

Disable my account

Post-login device tracking
When the post-login service option Device Tracking and Management is enabled, the administrator must
specify into which device group to put the self-registered devices, as well as specify the Maximum number of
devices per user (up to 20; 3 by default). When enabled, users have access to a post-login interface where
they can add/edit/delete their list of devices. If enabled but the device is not registered, the FortiAuthenticator
presents a device registration page after account credential validation.
If the user reaches their device limit, they must select an existing device to replace. If the MAC address is
currently associated with a different user, it will be re-assigned to this newly logged-in user with the following
warning message:
"Your device had previously been registered by another user. Ownership has now been changed to your
account."

Rules
Portal rule configuration is available under Authentication > Guest Portals > Rules.
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To configure portal rules:
1. Select Create New to configure new portal rules.
2. Enter the following information:
Note that the Conditions section is only available for configuring once the rule has
already been created by selecting OK.

General

Configure the portal rule's general information, including its name and
action.
Name

A name to identify the portal rule.

Description

Optionally, enter information about the portal rule.

Action

Determine the action to take for the rule: assign a guest portal or assign
no portal for the rule.

3. Select OK to add the new portal rule.

Replacement messages
Guest portal replacement message mappings are available under Authentication > Guest Portals
> Replacement Messages.
The replacement messages are split into four categories: Authentication, Password Reset, User
Registration, and Post-Login.
Selecting a specific message will display the text and HTML or plain text of the message in the lower half of the
content pane.
Selecting Toggle Tag List will display a table of the tags used for that message atop the message’s HTML or
plain text box.

To edit a replacement message:
1. Select a message in the replacement message list.
2. Edit the plain text or HTML code in the lower right pane, or select the open in new window icon to edit the
message in a new browser window.
3. When you are finished editing the message, select Save to save your changes.
4. If you have made an error when editing the message, select Restore Default to restore the message to its
default value.

Manage Images
Images can be managed by selecting Manage Images in the Replacement Messages window. Images can
also be added, deleted, and edited.
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To add an image:
1. In the manage images screen, select Create New to open the Create New Image window.
2. Enter a name for the image in the Name field.
3. Select Browse..., find the GIF, JPEG, or PNG image file that you are adding, and then select Open.
The maximum image size is 65kB.
4. Select OK to add the image.
To delete an image:
1. In the manage images screen, select an image, then select Delete.
2. Select Yes, I’m sure in the confirmation window to delete the image.
To edit an image:
In the manage images screen, select an image, then select Edit.

1. In the Edit Image window, edit the image name and file as required.
2. Select OK to apply your changes.

Smart Connect profiles
Smart Connect profiles are available under Authentication > Guest Portals > Smart Connect Profiles.
This feature provides the ability to set up network settings (such as WiFi configuration) on an endpoint by
downloading a script or an executable (depending on the endpoint's OS) via the FortiAuthenticator's guest
portal.
Once configured, the Smart Connect feature will show up as a new button on the guest portal's post-login main
page:

When clicking on the Smart Connect button, the user is given the option to download a self-install file for the
OS type of their choice, including iOS, Android, Windows, and Linux. A device ID can also be entered too,
however this is only available if the Smart Connect profile uses EAP-TLS. If entered, the ID will be used to
generate the end-user certificate.

To configure a Smart Connect profile:
1. Select Create New to start the profile configuration wizard.
2. Enter a Name and select Next (you cannot configure a different Connect type other than Wireless).
3. Enter an SSID and select the Auth method to use: WPA2 Personal or WPA2 Enterprise.
You can optionally enable or disable Hidden SSID to show or hide the SSID. When finished, select Next.
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4. Enter a Pre-shared Key, then select Next.
5. You will see the Review All Settings page, where you can review and change any of the previously set
options, and define more settings, as shown below:

6. Select OK to apply your options and finish the configuration.
Once created, a Smart Connect profile can be associated with a guest portal and be available as a postlogin service (see Post-login Services under Portals).
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Smart Connect for Windows
The Smart Connect for Windows feature provides an executable file that adds specific network settings to an
end-user's Windows device. The Smart Connect profile settings are the same as the ones implemented for iOS
and macOS. The main difference is in how the downloaded executable file is built and packaged, so that it
installs seamlessly on Windows devices.

Self-service URL
When using the device tracking feature, users are no longer redirected by the FortiGate after initial device
registration. Instead, the FortiAuthenticator provides a specific URL for each guest portal, as derived from the
guest portal name (under Authentication > Guest Portals > Portals).
When the end user navigates to the self-service URL, they must provide valid credentials to get network
access, but the login does not trigger the call to the FortiGate's API.

Please note that special characters must be encoded in the self-service URL.

Firmware upgrade
When upgrading from a previous release, as a result of the device tracking feature, the
following occurs:
l
MAB Unauthorized devices are set to Deny access by default for existing
RADIUS clients.
l
MAB Blocked groups are set to empty by default for existing RADIUS clients.
l
Device tracking and device management are disabled by default for existing guest
portals.
l
Existing replacement messages are left unchanged for existing guest portals.
l
New (default) replacement messages are added to existing guest portals.

Remote authentication servers
If you already have LDAP or RADIUS servers configured on your network, FortiAuthenticator can connect to
them for remote authentication, much like FortiOS remote authentication.

General
Go to Authentication > Remote Auth. Servers > General to edit general settings for remote LDAP and
RADIUS authentication servers.
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Remote LDAP
Enter the number of seconds between 1-3600 (or one second to one hour) for the LDAP server response and
status cache timeouts.

Remote RADIUS
Select whether the remote RADIUS server requires case sensitive usernames.

LDAP
If you have existing LDAP servers, you may choose to continue using them with FortiAuthenticator by
configuring them as remote LDAP servers.

When entering the remote LDAP server information, if any information is missing or in
the wrong format, error messages will highlight the problem for you.

FortiAuthenticator supports multiple Windows AD server forests, with a maximum of 20
remote LDAP servers with Windows AD enabled.
To view all information about your multiple servers, go to Monitor > Authentication
> Windows AD.

To add a remote LDAP server entry:
1. Go to Authentication > Remote Auth. Servers > LDAP and select Create New. The Create New
LDAP Server window opens.
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2. Enter the following information.
Name

Enter the name for the remote LDAP server on FortiAuthenticator.

Primary server name/IP

Enter the IP address or FQDN for this remote server.

Port

Enter the port number.

Use secondary server

Select to use a secondary server. The secondary server name/IP and
port must be entered.

Secondary server name/IP

Enter the IP address or FQDN for the secondary remote server. This
option is only available when Use secondary server is selected.

Secondary port

Enter the port number for the secondary server. This option is only
available when Use secondary server is selected.
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Base distinguished name

Enter the base distinguished name for the server using the correct
X.500 or LDAP format. The maximum length of the DN is 512
characters.
You can also select the browse button to view and select the DN on the
LDAP server.

Bind Type

The Bind Type determines how the authentication information is sent to
the server. Select the bind type required by the remote LDAP server.
l
Simple: bind using the user’s password which is sent to the server
in plaintext without a search.
l
Regular: bind using the user’s DN and password and then search.
If the user records fall under one directory, you can use Simple bind
type. But Regular is required to allow a search for a user across
multiple domains.

Add supported domain
names (used only if this is
not a Windows Active
Directory server)

Select to enter multiple domain names for remote LDAP server
configurations. The FortiAuthenticator can then identify the domain that
users on the LDAP server belong to.

3. If you want to want to import a specific LDAP system's template, under Query Elements, enter the
following:
Pre-defined templates

Select a pre-defined template from the dropdown menu: Microsoft
Active Directory, OpenLDAP, or Novell eDirectory.

User object class

The type of object class to search for a user name search. The default is
person.

Username attribute

The LDAP attribute that contains the user name. The default is
sAMAccountName.

Group object class

The type of object class to search for a group name search. The default
is group.

Obtain group
memberships from

The LDAP attribute (either user or group) used to obtain group
membership. The default is User attribute.

Group membership
attribute

Used as the attribute to search for membership of users or groups in
other groups.

Force use of administrator
account for group
membership lookups

Enabling this feature prevents non-admin users from searching their
own attributes even after successful binding. This feature has been
implemented to enhance Oracle-based ODSEE LDAP support.

4. If you want to have a secure connection between FortiAuthenticator and the remote LDAP server, under
Secure Connection, select Enable, then enter the following:
Protocol

Select LDAPS or STARTLS as the LDAP server requires.

CA Certificate

Select the CA certificate that verifies the server certificate from the
dropdown menu.

5. If you want to authenticate users using MSCHAP2 PEAP in an Active Directory environment, enable
Windows Active Directory Domain Authentication, then enter the required Windows AD Domain
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Controller information.
Kerberos realm name

Enter the domain’s DNS name in uppercase letters.

Domain NetBIOS name

Enter the domain’s DNS prefix in uppercase letters.

FortiAuthentication
NetBIOS name

Enter the NetBIOS name that identifies FortiAuthenticator as a domain
member.

Administrator username

Enter the name of the user account that's used to associate
FortiAuthenticator with the domain. This user must have at least
domain user privileges.
To configure an Active Directory user with the minimum privileges
needed to join an AD domain, see Configure minimum privilege
Windows AD user account.

Administrator password

Enter the administrator account’s password.

When you are finished here, go to Authentication > RADIUS Service > Clients to choose whether
authentication is available for all Windows AD users or only for Windows AD users who belong to
particular user groups that you select. See RADIUS service on page 117 for more information.
6. If you want to import remote LDAP users, select to either Import users or Import users by group
memberships under Remote LDAP Users. Once a method is chosen, select Go. This will open a
separate window where you may specify the LDAP server, apply filters, and attributes. Select Configure
user attributes to apply/edit the following LDAP user mapping attributes:
Username

Enter the remote LDAP user's name.

First name

Enter the attribute that specifies the user's first name. Set to
givenName by default.

Last name

Enter the attribute that specifies the user's last name. Set to sn by
default.

Email

Enter the attribute that specifies the user's email address. Set to mail
by default.

Phone

Enter the attribute that specifies the user's number. Set to
telephoneNumber by default.

Mobile number

Enter the attribute that specifies the user's mobile number. Set to
mobile by default.

FTK-200 serial number

Enter the remote LDAP user's FortiToken serial number.

Certificate binding
common name

Enter the remote LDAP user's certificate-binding CN. When this field is
populated, the Certificate binding CA must also be specified.

Certificate binding CA

Local or trusted CAs to apply for the remote LDAP user. Must be
specified if the Certificate binding common name is populated.

7. Select OK to apply your changes.
You can now add remote LDAP users, as described in Remote users on page 76.
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Configure minimum privilege Windows AD user account
To respect the principle of least privilege, a domain administrator account should not be used to associate
FortiAuthenticator with a Windows AD domain. Instead, a non-administrator account can be configured with
the minimum privileges necessary to successfully join a Windows AD domain. To do this, create a user account
in the applicable hierarchy of your Active Directory, then delegate the ability to manage computer objects to the
user account.

1. In the Active Directory, create a user account with the following options selected:
l
User cannot change password
l

Password never expires

2. In Active Directory Users and Computers, right-click the container under which you want the
computers added, then click Delegate Control.
The Delegation of Control Wizard opens.
3. Click Next.
4. Click Add, then enter the user account created in step 1.
5. Click Next.
6. Select Create custom task to delegate, then click Next.
7. Select Only the following objects in the folder, and then select Computer objects.
8. Select Create selected objects in this folder, then click Next.
9. Under Permissions, select Create All Child Objects, Write All Properties, and Change password.
10. Click Next, then click Finish.

Remote LDAP password change
Windows AD users can conveniently change their passwords without provision changes being made to the
network by a Windows AD system administrator. There are three ways FortiAuthenticator supports a password
change: RADIUS login, GUI user login, and GUI user portal.

RADIUS login:
For the method to work, all of the following conditions must be met:
l
l
l
l

FortiAuthenticator has joined the Windows AD domain.
RADIUS client has been configured to "Use Windows AD domain authentication".
RADIUS authentication request uses MS-CHAPv2.
RADIUS client must also support MS-CHAPv2 password change.

A "change password" response will be produced that FortiAuthenticator will recognize, which will allow
cooperation between the NAS and the Windows AD server that will result in a password change.

GUI user login:
For this method to work, one of the following conditions must be met:
l
l

FortiAuthenticator has joined the Windows AD domain
Secure LDAP is enabled and the LDAP admin (i.e. regular bind) has the permissions to reset user
passwords

You must log in via the GUI portal. FortiAuthenticator will validate the user password against a Windows AD
server. The Windows AD server will return with a "change password" response. If that happens, the user will be
prompted to enter a new password.
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GUI user portal:
For this method to work, one of the following conditions must be met:
l
l

FortiAuthenticator has joined the Windows AD domain.
Secure LDAP is enabled.

Once successfully logged into the GUI, the user has access to the user portal. If desired, the user can change
their password in the user portal.

RADIUS
If you have existing RADIUS servers, you may choose to continue using them with FortiAuthenticator by
configuring them as remote RADIUS servers.This feature can also be used to migrate away from third-party
two-factor authentication platforms.

When entering the remote RADIUS server information, if any information is missing or
in the wrong format, error messages will highlight the problem for you.

To add a remote RADIUS server entry:
1. Go to Authentication > Remote Auth. Servers > RADIUS and select Create New. The Create New
RADIUS Server window opens.
2. Enter the following information, then select OK to add the RADIUS server.
Name

Enter the name for the remote RADIUS server on FortiAuthenticator.

Preferred auth. method

Select from either MSCHAPv2 (by default), MSCHAP, CHAP, or
PAP.

Timeout

Enter a timeout in seconds between 1-30 seconds (3 by default).
Note that a high timeout may impact the processing rate of
authentication requests if the remote RADIUS server becomes
unresponsive.

Primary Server

Enter the server name or IP address, port, and secret in the fields
provided to configure the primary server.

Secondary Server

Optionally, add redundancy by configuring a secondary server.

User Migration

Select Enable learning mode to record and learn users that
authenticate against this RADIUS server. This option should be enabled
if you need to migrate users from the server to the FortiAuthenticator.
Select View Learned Users to view the list of learned users. See
Learned RADIUS users on page 175.
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RADIUS service
Before FortiAuthenticator can accept RADIUS authentication requests from a FortiGate unit, the FortiGate unit
must be registered as a authentication client on FortiAuthenticator.
The FortiAuthenticator RADIUS server is already configured and running with default values. Each user account
on FortiAuthenticator has an option to authenticate the user using the RADIUS database.
Every time there is a change to the list of RADIUS authentication clients, two log messages are generated: one
for the client change, and one to state that the RADIUS server was restarted to apply the change.
FortiAuthenticator unit allows both RADIUS and remote authentication for RADIUS authentication client
entries. If you want to use a remote server, you must configure it first so that you can be select it in the RADIUS
authentication client configuration, see Remote authentication servers on page 110. You can configure the
built-in LDAP server before or after creating client entries, see LDAP service on page 122.
For VM appliances, the ratio for RADIUS clients is "number of max users / 3".
The number of RADIUS profiles is "number of max users x 2", since each RADIUS
client might need more than one profile.
See the Maximum values table included in the latest FortiAuthenticator Release
Notes for more details.

Clients
RADIUS accounting client can be managed from Authentication > RADIUS Service > Clients.
Clients can be added, imported, deleted, edited, and cloned as needed.

To configure a RADIUS accounting client:
1. From the RADIUS client list, select Create New to add a new RADIUS client. The Add RADIUS client
window opens.
2. Enter the following information:
Subnets and IP ranges can be defined in the Client address field. All
authentication clients within a defined subnet/IP range will share the same
configuration and secret. For example, 192.168.0.0/24 would allow all 255 IP
addresses to authenticate.
This feature saves time, as the entry only takes up a single client entry in the
license table.
Name

A name to identify the FortiGate unit.

Client address

The IP/Hostanme, Subnet, or Range of the unit.

Secret

The RADIUS passphrase that the FortiGate unit will use.

First profile name

Enter the profile name of this RADIUS client.
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Description

Optionally, enter information about the FortiGate unit.

Apply this profile based
on RADIUS attributes

Enable and apply RADIUS attributes to match to this RADIUS
profile from the FortiAuthenticator's list of vendors in RADIUS
Service > Custom Dictionaries.

EAP types

Select the 802.1X EAP authentication types to accept. If you
require mutual authentication, select EAP-TLS.

Device Authentication

To allow 802.1X authentication for non-interactive devices,
FortiAuthenticator can identify and bypass authentication for a
device based on its MAC address.
This is used for devices that do not allow the usual username or
password input to perform 802.1X authentication, such as network
printers. Enter these units in Authentication >
User Management > MAC Devices.

MAC
Authentication
Bypass (MAB)

Configure MAB for certain devices, so long as their MAC addresses
appear in the User-Name, User-Password, and Calling-StationID attributes.
Define the authorized groups for this feature. Note that authorized
groups must be first created under Authentication > User
Management > User Groups, where Type must be set to MAC,
and MAC devices are selected for MAC address authorization.
In addition, you can optionally require the Call-Check attribute for
MAC-based authentication too.

AD machine
authentication

Configure AD machine authentication. Note that full access requires
AD authentication of both the end point machine and user.
In addition, you can optionally override group membership when
specific user groups are machine or user authenticated.

MAC device
filtering

Configure MAC device filtering. Define MAC address attributes,
authorized groups, and action to take for unauthorized devices. The
MAC address attribute indicates which RADIUS attribute to
extract the MAC address from.
MAC device filtering can be enabled for any RADIUS authentication,
including Guest Portal authentication. However, when used for
Guest Portals, the FortiAuthenticator needs to know which HTTP
parameter to extract the MAC address from. You can enter the MAC
device HTTP parameter under Authentication > Guest Portals >
Portals.

User Authentication

Select one of the following:
l
l

l

l
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Enable FortiToken
Mobile push notifications
authentication

Toggle on/off FTM Push notifications for RADIUS users. This
setting is only controlled here on a per RADIUS client basis, not for
specific users.

Username input format

Select one of the following three username input formats:
l
username@realm
l
realm\username
l
realm/username

Realms

Add realms to which the client will be associated.
l
Select a realm from the dropdown menu in the Realm column.
l
Select whether or not to allow local users to override remote
users for the selected realm.
l
Select whether or not to use Windows AD domain
authentication.
l
Edit the group filter as needed. That is, filter users based on the
groups they are in.
l
If necessary, add more realms to the list.
l
Select the realm that will be the default realm for this client.

3. Select OK to add the new RADIUS client.
If authentication is failing, check that the authentication client is configured and
that its IP address is correctly specified. Common causes of problems are:
l
RADIUS packets being sent from an unexpected interface, or IP address.
l
NAT being performed between the authentication client and
FortiAuthenticator.

MAC authentication bypass
The existing MAC authentication bypass (MAB) feature (under Authentication > RADIUS Service
> Clients) supports returning Access-Accept with different RADIUS attributes for unauthorized devices, and
also supports explicitly blocking pre-defined groups of devices.
Profiles are applied in descending order based on matching RADIUS attributes. If the profile has no attributes
to match, that profile will always be applied before any that follow.
When processing MAB for an authorized device associated with a user, the FortiAuthenticator returns the
RADIUS attributes of the authorized device group(s) of which the device is a member as well as the RADIUS
attributes from the group memberships of the associated user (if any). Additionally, any RADIUS attributes
assigned directly to the associated user are returned.

Challenge message to support FortiToken Mobile Push for VPN clients
There are two Reply-Messages that the FortiAuthenticator can send to the FortiGate in the RADIUS ACCESS
CHALLENGE messages. Each message is prefixed by an uneditable string followed by an editable string (i.e.
replacement message in FortiAuthenticator):

1. If push is not available, FortiAuthenticator will send Prefix: “” followed by Default Replaceable String:
“Enter Token Code”. For example; "Enter Token Code".
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2. If push is available, FortiAuthenticator will send Prefix: “+” followed by Default Replaceable String:
“Choose FTM Push or Enter Token Code”. For example:;" + Choose FTM Push or Enter Token Code".

Client profile attributes
FortiAuthenticator supports a single authentication profile for each RADIUS Auth Client. Because of this,
authentication requirements (for example IPSec/SSLVPN, Web Filtering Override, Wireless Authentication,
and so on) require different profiles, as RADIUS authentication requests originate from the same IP address.
To distinguish the authentication requirements, you can add attributes to them.
Attributes (which can be added to authentication requirements) indicate the type of service the user has
requested, or the type of service to be provided.
Each FortiAuthenticator authentication client profile can contain up to two RADIUS
attributes.
To match a profile, all specified attributes in a profile must match, if not, the
processing will fall to the next profile (processed in top down order).
The profiles created can be re-arranged in terms of priority. FortiAuthenticator attempts to match the RADIUS
attributes from an authentication request to each profile, starting with the highest-priority profile, and moves
down the list until it finds a match. FortiAuthenticator uses the first profile that it matches.

Importing authentication clients
Authentication client information can be imported as a CSV file by selecting Import from the RADIUS client
list.
The CSV file has one record per line, with the record format: client name (maximum of 32 characters), FQDN or
IP address (maximum of 128 characters), secret (optional, maximum of 63 characters).

Extensible Authentication Protocol
FortiAuthenticator supports several IEEE 802.1X Extensible Authentication Protocol (EAP) methods. EAP
settings can be configured from Authentication > RADIUS Service > EAP. See Extensible Authentication
Protocol on page 136 for more information.

Services
You can optionally change the RADIUS authentication, accounting SSO, and accounting monitor ports under
Authentication > RADIUS Service > Services.
By default, the ports are set to:
l

RADIUS authenticaiton port: 1812

l

RADIUS accounting SSO port: 1813
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l

RADIUS accounting monitor port: 1646
When upgrading from a firmware version prior to 5.0, and the Enable RADIUS
Accounting SSO clients option is enabled under Fortinet SSO Methods >
SSO > General, both the SSO accounting port and the usage monitoring
accounting port should remain at their default values (1813 and 1646 respectively)
in order to avoid service disruption.

Custom dictionaries
The custom dictionary list enables you to view built-in vendors and their RADIUS attributes, and create new
customized entries.
Go to Authentication > RADIUS Service > Custom Dictionaries to view the list.
Some services can receive information about an authenticated user through RADIUS vendor-specific attributes.
FortiAuthenticator user groups and user accounts can include RADIUS attributes for Fortinet and other
vendors.
Attributes in user accounts can specify user-related information. For example, the Default attribute FramedIP-Address specifies the VPN tunnel IP address to be sent to the user by the Fortinet SSL VPN.
Attributes in user groups can specify more general information, applicable to the whole group. For example,
specifying third-party vendor attributes to a switch could enable administrative level login to all members of the
Network_Admins group, or authorize the user to the correct privilege level on the system.
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To create a new custom RADIUS attribute vendor, open the Custom Vendors view and select Create New
where you will be prompted to upload a RADIUS dictionary file.

To add RADIUS attributes to a user or group:
1. Go to Authentication > User Management > Local Users and select a user account to edit, or go to
Authentication > User Management > User Groups and select a group to edit.
2. In the RADIUS Attributes section, select Add Attribute. The Create New User Group RADIUS
Attribute or Create New User RADIUS Attribute window opens.
3. Select the appropriate Vendor and Attribute ID, then enter the attribute’s value in the Value field.
4. Select OK to add the new attribute to the user or group.
5. Repeat the above steps to add additional attributes as needed.

LDAP service
LDAP is an Internet protocol used to maintain authentication data that may include departments, people,
groups of people, passwords, email addresses, and printers. LDAP consists of a data-representation scheme, a
set of defined operations, and a request/response network.
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In the LDAP protocol there are a number of operations a client can request such as search, compare, and add
or delete an entry. Binding is the operation where the LDAP server authenticates the user. If the user is
successfully authenticated, binding allows the user access to the LDAP server based on the user’s permissions.

General
To configure general LDAP service settings, go to Authentication > LDAP Service > General.

LDAP Server Settings
LDAP server
certificate

Select the certificate that the LDAP server will present from the
dropdown menu.

Certificate authority
type

Select either Local CA or Trusted CA.

CA certificate that
issued the server
certificate

Select the CA certificate that issued the server certificate from the
dropdown menu.

LDAP User Auto Provisioning

Enable this feature to specify how users can be automatically
provisioned into LDAP.

Select OK to apply any changes that you have made.

Directory tree overview
The LDAP tree defines the hierarchical organization of user account entries in the LDAP database. The
FortiGate unit requesting authentication must be configured to address its request to the right part of the
hierarchy.
An LDAP server’s hierarchy often reflects the hierarchy of the organization it serves. The root represents the
organization itself, usually defined as Domain Component (DC), a DNS domain, such as example.com (as
the name contains a dot, it is written as two parts separated by a comma: dc=example,dc=com). Additional
levels of hierarchy can be added as needed; these include:
l
l
l
l
l

Country (c)
User Group (cn)
Local User (uid)
Organization (o)
Organizational Unit (ou)

The user account entries relevant to user authentication will have element names such as UID or CN; the user's
name. They can each be placed at their appropriate place in the hierarchy.
Complex LDAP hierarchies are more common in large organizations where users in different locations and
departments have different access rights. For basic authenticated access to your office network or the Internet,
a much simpler LDAP hierarchy is adequate.
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The following is a simple example of an LDAP hierarchy in which the all user account entries reside at the OU
level, just below DC.

When requesting authentication, an LDAP client, such as a FortiGate unit, must specify the part of the
hierarchy where the user account record can be found. This is called the distinguished name (DN). In the above
example, DN is ou=People,dc=example,dc=com.
The authentication request must also specify the particular user account entry. Although this is often called the
common name (CN), the identifier you use is not necessarily CN. On a computer network, it is appropriate to
use UID, the person’s user ID, as that is the information that they will provide at logon.

Creating the directory tree
The following sections provide a brief explanation of each part of the LDAP attribute directory, what is
commonly used for representation, and how to configure it on FortiAuthenticator.
When an object name includes a space, as in Test Users, you have to enclose the text
with double-quotes. For example:

cn="TesTUsers",cn=Builtin,dc=get,dc=local

Editing the root node
The root node is the top level of the LDAP directory. There can be only one. All groups, OUs, and users branch
off from the root node. Choose a DN that makes sense for your organization’s root node.
There are three common forms of DN entries:
The most common consists of one or more DC elements making up the DN. Each part of the domain has its
own DC entry. This comes directly from the DNS entry for the organization. For example, for example.com, the
DN entry is "dc=example,dc=com".
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Another popular method is to use the company’s Internet presence as the DN. This method uses the domain
name as the DN. For example, for example.com, the DN entry would be "o=example.com".
An older method is to use the company name with a country entry. For example, for Example Inc. operating in
the United States, the DN would be o="Example, Inc.",c=US. This makes less sense for international
companies.
When you configure FortiGate units to use FortiAuthenticator as an LDAP server, you
will specify the distinguished name that you created here. This identifies the correct
LDAP structure to reference.

To rename the root node:
1. Go to Authentication > LDAP Service > Directory Tree.
2. Select dc=example,dc=com to edit the entry.
3. In the Distinguished Name (DN) field, enter a new name (e.g. "dc=fortinet,dc=com").
4. Select OK to apply your changes.
If your domain name has multiple parts to it, such as shiny.widgets.example.com,
each part of the domain should be entered as part of the DN, for example:

dc=shiny,dc=widgets,dc=example,dc=com

Adding nodes to the LDAP directory tree
You can add a subordinate node at any level in the hierarchy as required.

To add a node to the tree:
1. From the LDAP directory tree, select the green plus symbol next to the DN entry where the node will be
added. The Create New LDAP Entry window opens.
2. In the Class field, select the identifier to use.
For example, to add the ou=People node from the earlier example, select Organizational Unit (ou).
3. Select the required value from the dropdown menu, or select Create New to create a new entry of the
selected class.
4. Select OK to add the node.
Nodes can be edited after creation by selecting the edit, or pencil, icon next to the node name.

Adding user accounts to the LDAP tree
You must add user account entries at the appropriate place in the LDAP tree. These users must already be
defined in the FortiAuthenticator user database. See Adding a user on page 69.

To add a user account to the tree:
1. From the LDAP directory tree, expand nodes as needed to find the required node, then select the node’s
green plus symbol.
In the earlier example, you would do this on the ou=People node.
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2. In the Class field, select User (uid).
The list of available users is displayed. You can choose to display them alphabetically by either user group
or user.
3. Select the required users in the Available Users box and move them to the Chosen Users box. If you
want all local users to be added, select Choose all below the users box.
4. Select OK to add the user account to the tree.
You can verify your users were added by expanding the node to see their UIDs listed below it.

Moving LDAP branches in the directory tree
At times you may want to rearrange the hierarchy of the LDAP structure. For example a department may be
moved from one country to another.
While it is easy to move a branch in the LDAP tree, all systems that use this
information will need to be updated to the new structure or they will not be able to
authenticate users.

To move an LDAP branch:
1. From the LDAP directory tree, select Expand All and find the branch that is to be moved.
2. Click and drag the branch from its current location to its new location
When the branch is hovered above a valid location, an arrow will appear to the left of the current branch to
indicate where the new branch will be inserted. It will be inserted below the entry with the arrow.

Removing entries from the directory tree
Adding entries to the directory tree involves placing the attribute at the proper place. However, when removing
entries it is possible to remove multiple branches at one time.
Take care not to remove more branches than you intend. Remember that all systems
using this information will need to be updated to the new structure or they will not be
able to authenticate users.

To remove an entry from the LDAP directory tree:
1. From the LDAP directory tree, select Expand All and find the branch that is to be removed.
2. Select the red X to the right of the entry name.
You will be prompted to confirm your deletion. Part of the prompt displays the message of all the entries
that will be removed with this deletion. Ensure this is the level that you intend to delete.
3. Select Yes, I’m sure to delete the entry.
If the deletion was successful there will be a green check next to the successful message above the LDAP
directory and the entry will be removed from the tree.
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Configuring a FortiGate unit for FortiAuthenticator LDAP
When you have defined the FortiAuthenticator LDAP tree, you can configure FortiGate units to access the
FortiAuthenticator as an LDAP server and authenticate users.

To configure the FortiGate unit for LDAP authentication:
1. On the FortiGate unit, go to User & Device > LDAP Servers and select Create New.
2. Enter the following information:
Name

Enter a name to identify the FortiAuthenticator LDAP server on the
FortiGate unit.

Server IP/Name

Enter the IP address FQDN of FortiAuthenticator.

Server Port

Leave at default (389).

Common Name Identifier

Enter uid, the user ID.

Distinguished Name

Enter the LDAP node where the user account entries can be found. For
example, ou=People,dc=example,dc=com

Bind Type

The FortiGate unit can be configured to use one of three types of
binding:
l
Simple: Bind using a simple password authentication without a
search.
l
Anonymous: Bind using anonymous user search.
l
Regular: Bind using username/password and then search.
You can use simple authentication if the user records all fall under one
distinguished name (DN). If the users are under more than one DN, use
the anonymous or regular type, which can search the entire LDAP
database for the required username.
If your LDAP server requires authentication to perform searches, use
the regular type and provide the Username and Password.

Secure Connection

If you select Secure Connection, you must select LDAPS or
STARTTLS protocol and the CA security certificate that verifies
FortiAuthenticator’s identity. If you select LDAPS protocol, the Server
Port will change to 636.

3. Optionally, use the Test Connectivity and Test User Credentials features. Select OK to apply your
settings.
4. Add the LDAP server to a user group. Specify that user group in identity-based security policies where you
require authentication.

SAML IdP
Security Assertion Markup Language (SAML) is used for exchanging authentication and authorization data
between an identity provider (IdP) and a service provider (SP), such as Google Apps, Office 365, and
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Salesforce. The FortiAuthenticator can be configured as an IdP, providing trust relationship authentication for
unauthenticated users trying to access an SP.
Different realms can be selectively enabled while configuring the FortiAuthenticator as the IdP. These realms
are available under Authentication > Self-service Portal > Access Control, where they can be enabled,
disabled, or group filtered.
SAML authentication works as follows:

1. A user tries to access an SP, for example Google, using a browser.
2. The SP's web server requests the SAML assertions for its service from the browser.
3. Two possibilities:
The user's browser already has valid SAML assertions, so it sends them to the SP's web server. The
web server uses them to grant or deny access to the service. SAML authentication stops here.
l
The user's browser doesn't have valid SAML assertions, so the SP's web server redirects the browser
to the SAML IdP.
4. Two possibilities:
l

l
l

The user's browser is already authenticated with the IdP, go to step 5.
The user's browser is not yet authenticated with the IdP, IdP requests and validates the user's
credentials. If successful, go to step 5. Otherwise, access is denied.

5. IdP provides SAML assertions for the SP's and redirects the user's browser back to the SP's web server. Go
back to step 2.

General
To configure general SAML IdP portal settings, go to Authentication > SAML IdP > General and select
Enable SAML Identity Provider portal.

Enter the following information:
Device FQDN

To configure this setting, you must enter a Device FQDN in the System
Information widget in the Dashboard.

Server address

Enter the IP address, or FQDN, of the FortiAuthenticator device.
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Username input format

Select one of the following three username input formats:
l
username@realm
l
realm\username
l
realm/username

Realms

Select Add a realm to add the default local realm to which the users will
be associated.
Use Groups and Filter to add specific user groups.

Login session timeout

Set the user's login session timeout limit between 5 - 1440 minutes (one
day). The default is 480 minutes (eight hours).

IDP certificate

Select a certificate from the dropdown menu.

Select OK to apply any changes that you have made.

Service providers
Service Providers can be managed from Authentication > SAML IdP > Service Providers.
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To configure a SAML service provider:
1. Select Create New.

2. Enter the following information:
SP name

Enter a name for the SP.

IDP prefix

Enter a prefix for the IDP that will be appended to the end of the
IDP URLs.
Alternatively, you can select Generate unique prefix to generate a
random 16 digit alphanumeric string.

IDP address

To configure the IDP address (and IDP settings below), you must have
already configured the server's address under Authentication
> SAML IdP > General.

IDP entity id

Configure the IDP's entity ID, for example:
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http://www.example.com/saml-idp/xxx/metadata/
IDP single sign-on URL

Configure the IDP's login URL, for example:

http://www.example.com/saml-idp/xxx/login/
IDP single logout URL

Configure the IDP's logout URL, for example:

http://www.example.com/saml-idp/xxx/logout/
SP entity id

Enter the SP's entity ID.

SP ACS (login) URL

Enter the SP's Assertion Consumer Service (ACS) login URL.

SP SLS (logout) URL

Enter the SP's Single Logout Service (SLS) logout URL.

SAML request must be
signed by SP

Enable this option and import the SP certificate for authentication
request signing by the SP.

Authentication
Authentication
method

Select one of the following:
l
l

l

l

Bypass
FortiToken
authentication
when user is
from a trusted
subnet

Enforce two-factor authentication
Apply two-factor authentication if available (authenticate
any user)
Password-only authentication (exclude users without a
password)
FortiToken-only authentication (exclude users without a
FortiToken)

Enable this option if you would like to have certain users bypass
FortiToken authentication, so long as they belong to a trusted subnet.
Select Configure subnets to be directed to configure trusted subnets
(under Authentication > User Account Policies > Trusted
Subnets).

Debugging Options
Do not return to
service provider
automatically
after successful
authentication,
wait for user
input

Enable this option to let users choose where to navigate to once
authenticated.

Disable this
service provider

Disables the SP.

Assertion Attributes

Subject NameID

Select the user attribute that serves as SAML assertion subject
NameID.
Select from either Username, Email, Remote LDAP user DN, or
Remote LDAP user objectGUID. If the attribute being selected is not
available for a user, Username will be used by default.
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Format
SAML Attribute

Select from Unspecified, Transient, or Persistent.
Select Create New to create a new attribute that will be added to
SAML assertion.
The following user attributes are available when creating a new
assertion attribute:
l
l
l
l
l
l
l
l
l
l
l

Username
First name
Last name
Email
FortiAuthenticator local group
Remote LDAP DN
Remote LDAP sAMAccountName
Remote LDAP userPrincipalName
Remote LDAP displayName
Remote LDAP objectGUID
Remote LDAP group

Customizable successful login page
The screen that appears for a successful SAML IdP login can be customized under Authentication > Selfservice Portal > Replacement Messages, under SAML IdP.
See Replacement messages for more information.

FortiAuthenticator agents
FortiAuthenticator provides multiple agents for use in two-factor authentication:
l
l

FortiAuthenticator Agent for Microsoft Windows
FortiAuthenticator Agent for Outlook Web Access

Both agents can be downloaded from the FortiAuthenticator GUI under Authentication > FortiAuthenticator
Agent.

FortiAuthenticator Agent for Microsoft Windows
FortiAuthenticator Agent for Microsoft Windows is a credential provider plug-in that allows the Windows login
process to be enhanced with a one time password, validated by FortiAuthenticator.

Configurable default domain
When configuring two-factor authentication in the FortiAuthenticator Agent for Microsoft Windows, you can
select a Default Domain at Logon Screen. The options are None, Most Recent, and a populated list of
available domains (also configurable).
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This is particularly useful for environments that have a single domain (where previously, the user had to
manually pick a domain from a dropdown every single login, even in single-domain environments).

Load-balancing HA configurations
Customers with a load-balancing HA configuration can configure the FortiAuthenticator Agent for
Microsoft Windows to try to reach the secondary FortiAuthenticator if the primary is unreachable, with retries
occurring in the same order (in round-robin fashion).
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Offline token validation at login
You can view the time remaining for offline token validation when logging in using the FortiAuthenticator Agent
for Microsoft Windows.

For all tokens, FortiAuthenticator downloads enough offline tokens for the configured cache size plus the
authentication window size (so if the HOTP cache = 50 and the HOTP window = 10, you initially have 60 tokens
remaining; when tokens are displayed but not submitted to FortiAuthenticator, this ends up being fewer than 60
authentication attempts).
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TLS 1.2 support
All network communications take place over TLS 1.2. As a result, the minimum required version of the
.NET Framework is 4.6.0. The FortiAuthenticator Agent for Microsoft Windows installer will offer to install TLS
1.2 when it is necessary.

FortiAuthenticator Agent for Outlook Web Access
FortiAuthenticator Agent for Outlook Web Access is a plug-in that allows the Outlook Web login to be enhanced
with a one time password, validated by FortiAuthenticator.
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Port-based network access control
Port-based network access control (PNAC), or 802.1X, authentication requires a client, an authenticator, and
an authentication server (such as a FortiAuthenticator device).
The client is a device that wants to connect to the network. The authenticator is simply a network device, such
as a wireless access point or switch. The authentication server is usually a host that supports the RADIUS and
EAP protocols.
The client is not allowed access to the network until the client’s identity has been validated and authorized.
Using 802.1X authentication, the client provides credentials to the authenticator, which the authenticator
forwards to the authentication server for verification. If the authentication server determines that the
credentials are valid, the client device is allowed access to the network.
FortiAuthenticator supports several IEEE 802.1X EAP methods.

Extensible Authentication Protocol
FortiAuthenticator supports several IEEE 802.1X Extensible Authentication Protocol (EAP) methods. These
include authentication methods most commonly used in WiFi networks.
EAP is defined in RFC 3748 and updated in RFC 5247. EAP does not include security for the conversation
between the client and the authentication server, so it is usually used within a secure tunnel technology such as
TLS, TTLS, or MS-CHAP.
FortiAuthenticator supports the following EAP methods:

Method

Server Auth

Client Auth

Encryption

Native OS Support

PEAP (MSCHAPv2)

Yes

Yes

Yes

Windows XP, Vista, 7, 8, 10

EAP-TTLS

Yes

No

Yes

Windows Vista, 7, 8, 10

EAP-TLS

Yes

Yes

Yes

Windows (XP, 7, 8, 10), Mac OS X,
iOS, Linux, Android

EAP-GTC

Yes

Yes

Yes

None (external supplicant required)

In addition to providing a channel for user authentication, EAP methods also provide certificate-based
authentication of the server computer. EAP-TLS provides mutual authentication: the client and server
authenticate each other using certificates. This is essential for authentication onto an enterprise network in a
BYOD environment.
For successful EAP-TLS authentication, the user’s certificate must be bound to their account in
Authentication > User Management > Local Users (see Local users on page 68) and the relevant RADIUS
client in Authentication > RADIUS Service > Clients (see RADIUS service on page 117) must permit that
user to authenticate. By default, all local users can authenticate, but it is possible to limit authentication to
specified user groups.
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FortiAuthenticator and EAP
FortiAuthenticator delivers all of the authentication features required for a successful EAP-TLS deployment,
including:
l

l

Certificate Management: Create and revoke certificates as a CA. See Certificate management on page
176.
Simple Certificate Enrollment Protocol (SCEP) Server: Exchange a certificate signing request (CSR)
and the resulting signed certificate, simplifying the process of obtaining a device certificate.

FortiAuthenticator unit configuration
To configure FortiAuthenticator, you need to:

1. Create a CA certificate for FortiAuthenticator. See Certificate authorities on page 186.
Optionally, you can skip this step and use an external CA certificate instead. Go to
Certificate Management > Certificate Authorities > Trusted CAs to import CA certificates. See Trusted
CAs on page 193.
2. Create a server certificate for FortiAuthenticator, using the CA certificate you created or imported in the
preceding step. See End entities on page 177.
3. If you configure EAP-TTLS authentication, go to Authentication > RADIUS Service > EAP and
configure the certificates for EAP. See Configuring certificates for EAP on page 137.
4. If SCEP will be used:
l

l

Configure an SMTP server to be used for sending SCEP notifications. Then configure the email
service for the administrator to use the SMTP server that you created. See Email services on page 53.
Go to Certificate Management > SCEP > General, select Enable SCEP, select the CA certificate
that you created or imported in Step 1 in the Default CA field, and select OK. See SCEP on page
194.

5. Go to Authentication > Remote Auth. Servers > LDAP and add the remote LDAP server that
contains your user database. See LDAP service on page 122.
6. Import users from the remote LDAP server. You can choose which specific users will be permitted to
authenticate. See Remote users on page 76.
7. Go to Authentication > RADIUS Service > Clients to add the FortiGate wireless controller as an
authentication client. Be sure to select the type of EAP authentication you intend to use. See RADIUS
service on page 117.

Configuring certificates for EAP
FortiAuthenticator can authenticate itself to clients with a CA certificate.

1. Go to Certificate Management > Certificate Authorities > Trusted CAs to import the certificate you
will use. See Trusted CAs on page 193.
2. Go to Authentication > RADIUS Service > EAP.
3. Select the EAP server certificate from the EAP Server Certificate dropdown menu.
4. Select the trusted CAs and local CAs to use for EAP authentication from their requisite lists.
5. Select OK to apply the settings.
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Configuring switches and wireless controllers to use 802.1X authentication
The 802.1X configuration will be largely vendor dependent. The key requirements are:
l

RADIUS server IP: This is the IP address of the FortiAuthenticator.

l

Key: The pre-shared secret configured in the FortiAuthenticator authentication client settings.

l

Authentication port: By default, FortiAuthenticator listens for authentication requests on port 1812.

Non-compliant devices
802.1X methods require interactive entry of user credentials to prove a user’s identity before allowing them
access to the network. This is not possible for non-interactive devices, such as printers. MAC Authentication
Bypass (MAB) is supported to allow non-802.1X compliant devices to be identified and accepted onto the
network using their MAC address as authentication.
This feature is only for 802.1X MAB. FortiGate captive portal MAC authentication is supported by configuring
the MAC address as a standard user, with the MAC address as both the username and password, and not by
entering it in the MAC Devices section.
Multiple MAC devices can be imported in bulk from a CSV file. The first column of the CSV file contains the
device names (maximum of 50 characters), and the second column contains the corresponding MAC addresses
(0123456789AB or 01:23:45:67:89:AB).
When creating a new MAC-based authentication device, MAC addresses can be defined using wildcard
capability to identify and accept all devices from a specific vendor. The first three bytes of a MAC address
identify the vendor of the device. Define MAC devices using only the top three bytes to include all devices from
a specific vendor. The following wildcard input formats are valid:
l
l
l
l

112233
11:22:33
112233xxxxxx
11:22:33:xx:xx:xx

To configure MAC-based authentication for a device:
1. Go to Authentication > User Management > MAC Devices. The MAC device list will be shown.
2. If you are adding a new device, select Create New to open the Create New MAC-based
Authentication Device window.
If you are editing an already existing device, select the device from the device list.
3. Enter the device name in the Name field.
4. Enter the device’s MAC address in the MAC address field. Alternatively, enter a wildcard MAC address to
represent all MAC devices from a specific vendor.
5. Select OK to apply your changes.
To import MAC devices:
1. In the MAC device list, select Import.
2. Select Browse to locate the CSV file on your computer.
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3. Select OK to import the list.
The import will fail if the maximum number of MAC devices has already been reached, or if any of the
information contained within the file does not conform, for example if the device name too long, or there is
an incorrectly formatted MAC address.
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Fortinet Single Sign-On
Fortinet Single Sign-On (FSSO) is a set of methods to transparently authenticate users to FortiGate devices.
This means that FortiAuthenticator is trusting the implicit authentication of a different system, and using that to
identify the user. FortiAuthenticator takes this framework and enhances it with several authentication methods:
l
l

l
l
l

Users can authenticate through a web portal and a set of embeddable widgets.
Users with FortiClient Endpoint Security installed can be automatically authenticated through the
FortiClient SSO Mobility Agent.
Users authenticating against Active Directory can be automatically authenticated.
RADIUS Accounting packets can be used to trigger an FSSO authentication.
Users can be identified through the FortiAuthenticator API. This is useful for integration with third-party
systems

This section describes FSSO only. FSSO authentication methods do not require
accounting proxy configuration.

FortiAuthenticator must be configured to collect the relevant user logon data. After this basic configuration is
complete, the various methods of collecting the log in information can be set up as needed.

Domain controller polling
When the FortiAuthenticator runs for the first time, it will poll the domain controller (DC) logs backwards until
either the end of the log file or the logon timeout setting, whichever is reached first.
When the FortiAuthenticator is rebooted, the memory cache is written to the disk, then re-read at startup,
allowing the previous state to be retained. Windows DC polling restarts on boot, then searches backwards in
the DC log files until it reaches either the log that matches the last known serial number found in the login
cache file, the log that is older than the last recorded read time, or the end of the log file, whichever is reached
first.
The currently logged in FSSO users list is cached in memory and periodically written to disk. In an activepassive HA cluster, this file is synchronized to the slave device.

Windows management instrumentation polling
FortiAuthenticator supports Windows Management Instrumentation (WMI) polling to detect workstation log off.
This validates the currently logged on user for an IP address that has been discovered by the DC polling
detection method.
Remote WMI access requires that the related ports are opened in the Windows firewall, and access to a
domain account that belongs to the domain admin group.
To open ports in the Windows firewall in Windows 7, run gpedit.msc, go to Computer configuration >

Administrative Templates > Network > Network Connections > Windows Firewall > Domain
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Profile, go to Allow remote admin exception, then enable remote admin exception and, if necessary,
configure an IP subnet/range.

General settings
FortiAuthenticator units listen for requests from authentication clients and can poll Windows AD servers.

To configure FortiAuthenticator FSSO polling:
1. Go to Fortinet SSO Methods > SSO > General to open the Edit SSO Configuration window. The
Edit SSO Configuration window contains sections for FortiGate, FSSO, and user group membership.
2. In the FortiGate section, configure the following settings:

Listening port

Leave at 8000 unless your network requires you to change this. Ensure
this port is allowed through the firewall.

Enable authentication

Select to enable authentication, then enter a secret key, or password, in
the Secret key field.

Login expiry

The length of time, in minutes, that users can remain logged in before
the system logs them off automatically. The default is 480 minutes (8
hours).

Extend user session
beyond logoff by

The length of time, in seconds, that a user session is extended after the
user logs off, from 0 (default) to 3600 seconds.

Enable NTLM
authentication

Select to enable NTLM authentication, then enter the NETBIOS or DNS
name of the domain that the login user belongs to in the User domain
field.
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3. In the Fortinet Single Sign-On (FSSO) section, configure the following settings:

Maximum concurrent user
sessions

Enter the maximum number of concurrent FSSO login sessions a
user is allowed to have. Use 0 for unlimited.
Select Configure Per User/Group to configure the maximum
number of concurrent sessions for each user or group. See Finegrained controls on page 158.

Log level

Select one of Debug, Info, Warning, or Error as the minimum
severity level of events to log from the dropdown menu.
Select Download all logs to download all FSSO logs to your
management computer.

Enable Windows event log
polling (e.g. domain
controllers/Exchange
servers)
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Enable polling
additional
logon events

When additional AD logon event IDs are enabled, event IDs 528,
540, and 4624 are also polled. These event are generated when
a user attempts to access a domain service or resource. When a
user logs off from the workstation, such an event will be
generated.
Enter the additional logon event timeout time in the Additional
logon event timeout field, from 1 to 480 minutes, with 5
minutes being the default time.

Note: After a user logs off, their SSO session will stay active for
the above configured period of time. During this time, if another
user changes to the previous user’s IP address, they may be able
to bypass the necessary authentication. For this reason, it is
strongly recommended that the timeout time be kept short.
Enable DNS
lookup to get
IP from
workstation
name

Select to use DNS lookup to get IP address information when an
event contains only the workstation name. This option is enabled
by default.

Directly use
domain DNS
suffix in
lookup

Select to use the domain DNS suffix when doing a DNS lookup.
This option is disabled by default.

Enable reverse
DNS lookup to
get
workstation
name from IP

Select to enable reverse DNS lookup. Reverse DNS lookup is
used when an event contains only an IP address and no
workstation name. This option is enabled by default.

Do one more
DNS lookup to
get full list of
IPs after
reverse lookup
of workstation
name

Reverse DNS lookup is used when an event contains only an IP
address and no workstation name. Once the workstation name is
determined, it is used in the DNS lookup again to get more
complete IP address information. This is useful in environments
where workstations have multiple network interfaces. This option
is disabled by default.

Include
account name
ending with $
(usually
computer
account)

Accounts that end in "$" used to exclusively denote computer
accounts with no actual user, but in some cases, valid accounts
imported from dated systems can feature them. This option is
disabled by default.

Enable Radius Accounting
SSO clients
Use RADIUS
realm as
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Windows
Active
Directory
domain
Enable Syslog SSO

Select to enable Syslog SSO, and configure syslog sources.

Enable FortiClient SSO
Mobility Agent Service

Select to enable single sign-on (SSO) by clients running
FortiClient Endpoint Security. For more information, see
FortiClient SSO Mobility Agent on page 164.

FortiClient
listening port

Enter the FortiClient listening port number.

Enable
authentication

Select to enable authentication, then enter a secret key, or
password, in the Secret key field.

Keep-alive
interval

Enter the duration between keep-alive transmissions, from 1 to
60 minutes. Default is 5 minutes.

Idle timeout

Enter an amount of time in minutes after which to logoff a user if
their status is not updated. The value cannot be lower than the
Keep-alive interval value.

Enable NTLM

Select to enable the NT LAN Manager (NTLM) to allow logon of
users who are connected to a domain that does not have the
FSSO DC Agent installed. Disable NTLM authentication only if
your network does not support NTLM authentication for security
or other reasons.
Enter an amount of time after which NTLM authentication expires
in the NTLM authentication expiry field, from 1 to 10080
minutes (7 days).

Enable hierarchical FSSO
tiering

Select to enable hierarchical FSSO tiering. Enter the collector
listening port in the Collector listening port field.

Enable DC/TS Agent Clients

Select to enable clients using DC or TS Agent. Enter the UDP
port in the DC/TS Agent listening port field. Default is 8002.
Select Enable authentication to enable authentication, then
enter a secret key, or password, in the Secret key field.

Restrict auto-discovered
domain controllers to
configured Windows event
log sources and remote
LDAP servers

Select to enable restricting automatically discovered domain
controllers to already configured domain controllers only. See
Windows event log sources on page 152.

Enable Windows Active
Directory workstation IP
verification

Select to enable workstation IP verification with Windows Active
Directory.

Disable NTLMv1 in client
authentication to Windows
AD server

Optionally disable NTLMv1, as NTLMv2 is supported.
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4. In the User Group Membership section, configure the following settings:

Group cache mode

Group cache
item lifetime

Select the group cache mode:
l
Passive: Items have an expiry time after which the are
removed and re-queried on the next logon.
l
Active: Items are periodically updated for all currently logged
on users.
Enter the amount of time in minutes between 30-10080 (maximum
of one week) after which items will expire (when Group cache
mode is set to Passive), or the amount of time after which items
will update for active logins (when Group cache mode is set to
Active).
Additionally, you can Clear cache (when in Passive), or manually
Update cache (when in Active).

Do not use cached
groups and always load
groups from server for
the following SSO
sources

Select to prevent using cached groups and to always load groups
from server for the following SSO sources:
l
l
l
l
l
l
l
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l

Base distinguished
names to search for
nesting of users/groups
into cross domain,
domain local groups

SSO web service

Enter the base distinguished names to search for nesting of users or
groups into cross domain and domain local groups.

5. Select OK to apply the settings.

Configuring FortiGate units for FSSO
Each FortiGate unit that will use FortiAuthenticator to provide Single Sign-On authentication must be
configured to use FortiAuthenticator as an SSO server.

To configure SSO authentication on the FortiGate unit:
1. On the FortiGate unit, go to User & Device > Authentication > Single Sign-On and select
Create New.
2. In the Type field, select Fortinet Single-Sign-On Agent.
3. Enter a name for FortiAuthenticator in the Name field.
4. In the Primary Agent IP/Name field, enter the IP address of FortiAuthenticator.
5. In the Password field, enter the secret key that you defined for FortiAuthenticator. See Enable
authentication on page 141.
6. Select OK.
In a few minutes, the FortiGate unit receives a list of user groups from FortiAuthenticator. When you
open the server, you can see the list of groups. The groups can be used in identity-based security
policies.

Portal services
The SSO portal supports a logon widget that you can embed in any web page. Typically, an organization would
embed the widget on its home page.
The SSO portal sets a cookie on the user’s browser. When the user browses to a page containing the login
widget, FortiAuthenticator recognizes the user and updates its database if the user’s IP address has changed.
The user will not need to re-authenticate until the login timeout expires, which can be up to 30 days. To log out
of FSSO immediately, the user can select the Logout button in the widget.
The SSO portal supports multiple authentication methods including manual authentication, embeddable
widgets, and Kerberos authentication.
To configure portal services, go to Fortinet SSO Methods > SSO > Portal Services.
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The following settings can be configured:
User Portal

Select Enable SSO on login portal to enable the SSO login portal.

Realms

Add realms to which the client will be associated. See Realms on page 85.
l
Select a realm from the dropdown menu in the Realm column.
l
Select whether or not to allow local users to override remote users for
the selected realm.
l
Select whether or not to use Windows AD domain authentication.
l
Edit and filter users based on the groups they are in.
l
If necessary, add more realms to the list.
l
Select the realm that will be the default realm for this client.

Login timeout

Set the maximum number of minutes a user is allowed to stay logged in
before being logged out automatically from SSO, between 1-10080
(maximum of one week, set by default).

Maximum delay
when redirecting
to an external
URL

Set the delay in seconds that occurs when redirecting to an external URL,
between 1-10 seconds, with a default of 7 seconds.

Embeddable
login widget

Use this code to embed the login widget onto your site. The code in the
field cannot be manually edited.
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Login widget
demo
Kerberos User Portal

Import keytab
and enable

A demo of what the login widget will look like on your site.

Select Enable Kerberos login for SSO to enable kerberos log in for
SSO. See Kerberos on page 148 for more information.
Select to open the Import Keytab window where you can import a keytab
from your computer.
A keytab must be imported for Kerberos log in for SSO to be enabled.

Kerberos
Principal
SSO Web Service

SSO user type

View the Kerberos principal.

Select Enable SSO Web Service to use the web service to log users in
and out.
Specify the type of user that the client will provide: external, local, or
remote (LDAP server must be selected from the dropdown menu).

Kerberos
Kerberos authentication allows the FortiAuthenticator to identify connecting users through a Kerberos
exchange after a redirect from a FortiGate device.
A keytab file that describes your Kerberos infrastructure is required. To generate this file, you can use a ktpass
utility. The following code can be used in a batch file to simplify the keytab file creation:
set OUTFILE=FortiAuthenticator.keytab
set USERNAME=FortiAuthenticator@corp.example.com
set PRINC=HTTP/FortiAuthenticator.corp.example.com@CORP.EXAMPLE.COM
set CRYPTO=all
set PASSWD=Pa$$p0rt
set PTYPE=KRB5_NT_PRINCIPAL
ktpass -out %OUTFILE% -pass %PASSWD% -mapuser %USERNAME% -princ %PRINC% -crypto %CRYPTO%
-ptype %PTYPE%

The FortiGate device can be configured to redirect unauthenticated users to the FortiAuthenticator, however
the Kerberos authentication URL is different than the standard login URL. The Custom Message HTML for the
Login Page HTML Redirect for Kerberos is as follows:
<!DOCTYPE HTML>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta http-equiv="refresh" content="1;url=http://<FortiAuthenticatorfqdn>/login/kerb-auth?user_continue_url=%%PROTURI%%">
<script type="text/javascript">
window.location.href = http://<FortiAuthenticator-fqdn>/login/kerb-auth?user_
continue_url=%%PROTURI%%
</script>
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<title>
Page Redirection
</title>
</head>
<body>
If you are not redirected automatically, click on the link
<a href='http://<FortiAuthenticator-fqdn>/login/kerb-auth?user_continue_
url=%%PROTURI%%'>
http://<FortiAuthenticator-fqdn>/login/kerb-auth?user_continue_url= %%PROTURI%%
</a>
</body>
</html>

SAML authentication
Security Assertion Markup Language (SAML) is an XML standard that allows for maintaining a single repository
for authentication amongst internal and/or external systems.
The FortiAuthenticator can act as a Service Provider (SP) to request user identity information from a third-party
Identity Provider (IDP). This information can then be used to sign the user on transparently based on what
information the IDP sends.
Multiple SAML SP portals can be created on the FortiAuthenticator, with each portal configured to a different
SAML IDP.
In this scenario:

1. A user attempts to connect to the Internet via FortiGate.
2. The user is not authenticated in FSSO so gets redirected to FortiAuthenticator.
3. FortiAuthenticator (a service provider) checks with the existing third-party IDP to get the user identity.
4. FortiAuthenticator pushes identity and group information into FSSO.
5. FortiAuthenticator redirects the user to the original URL.
6. FortiGate sees the user in FSSO and allows the user to pass.
To configure a SAML SP portal, go to Fortinet SSO Methods > SSO > SAML Authentication.
The following options are available:
Create New

Configure a new SAML SP portal.

Import

Import a SAML Identity Provider from a file.

Delete

Delete the selected SAML SP portals.

Edit

Edit the selected SAML SP portal.

To configure a new SAML SP portal, select Create New.
The following settings can be configured:
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Name

Enter a Name for the New SAML SP portal.

Description

Enter a Description for the New SAML SP portal.

Device FQDN

Enter the FQDN of the configured device from the system dashboard.

Downloa
d SP
metadata

Select to load the service provider SAMLv2 metadata, which will be used for
exchanging data with remote parties. All SAMLv2 protocol URLs will be recognized.

Import
IDP
certificate

Select to import the certificate of the identity provider.

URL Nomenclature

Select the method to determine the URL path of the SAML service provider.
l
Individualize:Enable to include the name of the SAML service provider in the
URL path.
l
Legacy: Enable to set the URL to a predetermined URL path. Note that Legacy
can only be enabled for an existing configured SAML identity providers.

Portal URL

The SAML service provider login URL.

Entity ID

The SAML service provider Entity ID.

ACS (login) URL

The SAML service provider Assertion Consumer Service (ACS) login URL.

IDP entity ID

Also known as the entity descriptor. Enter the unique name of the SAML identity
provider, typically an absolute URL:

https://idp_name.example.edu/idp
IDP single sign-on
URL

Enter the identity provider portal URL you want to use for SSO.

IDP certificate
fingerprint

Enter the fingerprint of the certificate file. To calculate the fingerprint, you can use
OpenSSL.
Use the following OpenSSL command:

$ openssl x509 -noout -fingerprint -in "server.crt"
Example result, showing the fingerprint:

SHA1
Fingerprint=AF:E7:1C:28:EF:74:0B:C8:74:25:BE:13:A2:26:3D:3
7:97:1D:A1:F9
Fingerprint
algorithm

The SAML portal by default uses SHA-256.

Sign SAML
requests with a

Select to choose a local SAML certificate.
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local certificate
End user must
agree to a
disclaimer before
proceeding to the
authentication

Select to require a SAML SP SSO end-user to agree to a disclaimer before being
redirected to the SAML IDP for authentication.

Single Logout

Select to enable SLS (logout) URL and set IDP single logout URL.

Enable
SAML
single
logout

The Login Disclaimer Page and Disclaimer Denied Page can be customized. See
Replacement messages on page 97 for more information.

Select to enable SLS (logout) URL and set IDP single logout URL.

Username
Obtain
username
from

Select the method to extract usernames:
l

l

Subject NameID SAML assertion: Enable to obtain usernames from the
subject NameID assertion returned by the SAML IdP.
Text SAML assertion: Enable and enter the text-based SAML assertion that
usernames are obtained from. For example: email

Group Membership
Obtain
group
members
hip from

Most SAML IdP services will return the username in the Subject NameID assertion,
however not all IdP services are consistent. FSSO requires group membership of
each user with an active SSO session while different SAML IdP services require
different methods of retrieving the group information. Before now, group information
could only be obtained from very specific (hardcoded) SAML assertions. You can
now choose to convert Azure's group membership UUIDs into names, retrieve group
membership from an LDAP service, or configure other assertions which can be used
in group membership retrieval.
Select the method to extract usernames:
l
SAML assertions: Enable and choose whether usernames are pulled in from
boolean assertions or text-based attributes.
l
Azure: Enable and enter the Username field and Groups field. If Convert
Azure UUIDs into names is enabled, you must have already created an SSO
group with the Azure UUID already added. To save time, administrators may
instead choose to import them directly from Azure.
l
LDAP lookup: Enable and select the LDAP server to pull group memberships.

Implicit
group
members
hip

Select which local group the retrieved SAML users are placed into.
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Domain
Membership
Get SSO
domain
name
from

Select the method that determines the domain name:
l
SAML assertion attribute: Enable and enter the SAML assertion attribute
that domain names are obtained from.
l
Username prefix/suffix: Enable to obtain the domain name specified in the
username. For example: user@domain, domain\user, domain/user
l
Explicitly set to: Enable and enter the domain name to assign to the user.

Windows event log sources
FortiAuthenticator must be configured to communicate with the domain controller if Active Directory (AD) will
be used to ascertain group information.
A domain controller entry can be disabled without deleting its configuration. This can be useful when
performing testing and troubleshooting, or when moving controllers within your network.
In order to properly discover the available domains and domain controllers, the DNS
settings must specify a DNS server that can provide the IP addresses of the domain
controllers. See DNS on page 35.

To add a domain controller:
1. Go to Fortinet SSO Methods > SSO > Windows Event Log Sources.
2. Select Create New to open the Create New Windows Event Log Source window.
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3. Enter the following information:
NetBIOS name

Name of the domain controller as it appears in NetBIOS.

Display name

Unique name to easily identify this domain controller.

IP

Network IP address of the controller.

Account

Account name used to access logon events. This account should have
administrator rights.

Password

Password for the above account.

Server type

Select either Domain controller or Exchange server as the server
type.

Disable

Disable the domain controller without losing any of its settings.

Priority

Define multiple domain controllers for the same domain. Each can be
designated as Primary or Secondary. The Primary unit is accessed
first.

Enable secure connection

Enable a secure connection over either LDAPS or STARTTLS with a
CA certificate.

4. Select OK.
By default, FortiAuthenticator uses auto-discovery of Domain Controllers. If you want to restrict operation to the
configured domain controllers only, go to Fortinet SSO Methods > SSO > General and enable Restrict

auto-discovered domain controllers to configured Windows event log sources and remote
LDAP servers. See General settings on page 141.

RADIUS accounting
If required, SSO can be based on RADIUS accounting records. The FortiAuthenticator receives RADIUS
accounting packets from a carrier RADIUS server or network device, such as a wireless controller, collects
additional group information, and then inserts it into FSSO to be used by multiple FortiGate devices for identity
based policies.
The FortiAuthenticator must be configured as a RADIUS accounting client to the RADIUS server.
To view the RADIUS accounting SSO client list, go to Fortinet SSO Methods > SSO > RADIUS
Accounting Sources.

To configure and enable a RADIUS accounting client:
1. From the RADIUS accounting SSO client list, select Create New. The Create New RADIUS
Accounting SSO Client window opens.
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2. Enter the following information:
Name

Enter a name in the Name field to identify the RADIUS accounting
client on the FortiAuthenticator.

Client name/IP

Enter the RADIUS accounting client’s FQDN or IP address.

Secret

Enter the RADIUS accounting client’s pre-shared key.

Description

Optionally, enter a description of the client.

SSO user type

Specify the type of user that the client will provide: external, local, or
remote (LDAP server must be selected from the dropdown menu).

Strip off prefix or suffix
from username if any

Enable to strip prefixes and suffixes from the SSO usernames.

RADIUS Attributes

If required, customize the username, client IP, and user group RADIUS
attributes to match the ones used in the incoming RADIUS accounting
records. See RADIUS attributes on page 88.

3. Select OK to apply the changes.
4. Enable RADIUS accounting SSO clients by going to Fortinet SSO Methods > SSO > General and
selecting Enable RADIUS Accounting SSO clients. See General settings on page 141.
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Syslog
The FortiAuthenticator can parse username and IP address information from a syslog feed from a third-party
device, and inject this information into FSSO so it can be used in FortiGate identity based policies.
Syslog objects include sources and matching rules. Sources identify the entities sending the syslog messages,
and matching rules extract the events from the syslog messages. Messages coming from non-configured
sources will be dropped.

Injection of IPv6 addresses using Syslog-to-FSSO and API-to-FSSO is supported. IPv6
addresses will be accepted by the backend parsing engine.

To configure syslog objects, go to Fortinet SSO Methods > SSO > Syslog Sources.
Syslog SSO must be enabled for this menu option to be available. Go to Fortinet SSO
Methods > SSO > General to enable Syslog SSO. See General settings on page
141.
The following options and information are available:
Create New

Create a new syslog source or matching rule.

Delete

Select to delete the selected object or objects.

Edit

Select to edit the selected object.

View

Select Syslog Sources or Matching Rules from the dropdown menu.

Name

The name of the source or rule.

Client name/IP

The IP address or the client.

Syslog sources
Each syslog source must be defined for traffic to be accepted by the syslog daemon. Each source must also be
configured with a matching rule (either pre-defined or custom built; see below), and syslog service must be
enabled on the network interface(s) that will listen to remote syslog traffic.

To add a new syslog source:
1. In the syslog list, select Syslog Sources from the View dropdown menu.
2. Select Create New. The Create New Syslog Source page ones.

FortiAuthenticator 5.5.0 Administration Guide
Fortinet Technologies Inc.

155

Fortinet Single Sign-On

3. Enter the following information:
Name

Enter a name for the source.

IP address

Enter the IP address of the source.

Matching rule

Select the requisite matching rule from the dropdown menu. A matching
must already be created for the source.

SSO user type

Select the SSO user type:
l
External: Users are not defined on the FortiAuthenticator and user
groups come from the source.
l
Local users: Users are defined on the FortiAuthenticator as local
users, and user groups are retrieved from the local groups. Any
group from the syslog messages will be ignored.
l
Remote users: Users are defined on a remote LDAP server and
user groups are retrieved from the LDAP server. Any group from the
syslog messages will be ignored.

Strip off prefix or suffix
from username if any

Enable to strip prefixes and suffixes from the SSO usernames.

4. Select OK to add the source.

Matching rules
A matching rule is a query, or policy, that is applied to a syslog message in order to determine required
information, such as the username and IP address. Rules are required for every syslog source.
Predefined rules are available for Fortinet's FortiNAC appliance, and Aruba and Cisco wireless controllers (see
Predefined rules on page 156). For other systems, custom policies can be created to parse message files in
various formats.

Predefined rules
Predefined matching rules are included for Fortinet's FortiNAC appliance, and Aruba and Cisco ACS or ISE
wireless controllers.

FortiNAC
Trigger

FSSO

Auth Type Indicators

Logon: login
Logoff: logout

Username field

username={{:username}}

Client IPv4 field

IP={{:client_ip}}
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Client IPv6 field

e.g. Framed-IPv6-Address={{:client_ipv6}},:

Group field

tags="{{:group}}"

Group list separator

SSO syslog feed can parse multiple groups if the names are separated by
a plus (+) symbol or a comma (,).

Aruba
Trigger

None; any logs are accepted.

Auth Type Indicators

Logon: User Authentication Successful (exact match
required; no delimiter or value)

Username field

username={{:username}}

Client IPv4 field

IP={{:client_ip}}

Client IPv6 field

e.g. Framed-IPv6-Address={{:client_ipv6}},:

Group field

AAA profile={{:group}}

Group list separator

SSO syslog feed can parse multiple groups if the names are separated by
a plus (+) symbol or a comma (,).

Cisco
Trigger

NOTICE Radius-Accounting

Auth Type Indicators

Logon: Acct-Status-Type=Start
Update: Acct-Status-Type=Interim
Logoff: Acct-Status-Type=Stop

Username field

User-Name={{:username}},

Client IPv4 field

Framed-IP-Address={{:client_ip}},

Client IPv6 field

e.g. Framed-IPv6-Address={{:client_ipv6}},:

Group field

e.g. profile={{:group}}

Group list separator

SSO syslog feed can parse multiple groups if the names are separated by
a plus (+) symbol or a comma (,).
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To create a new matching rule:
1. In the syslog list, select Matching Rules from the View dropdown menu.
2. Select Create New. The Create New Syslog Matching Rule page opens.
3. Enter the following information:
Name

Enter a name for the source.

Description

Optionally enter a description of the rule.

Fields to Extract

Configure the fields that are to be extracted from the message.

Trigger

Optionally, enter a string that must be present in all syslog
messages. This will act as a pre-filter.

Auth Type Indicators

Enter strings to differentiate between the types of user activities:
Logon, Update (optional), and Logoff (optional).

Username field

Define the semantics of the username field. For example: UserName={{:username}}, where {{:username}} indicates where the
username is extracted from.

Client IPv4 field

Define the semantics of the client IPv4 address.

Client IPv6 field

Define the semantics of the client IPv6 address.

Group field

Optionally, define the semantics of the group. The group may not
always be included in the syslog message, and may need to be
retrieved from a remote LDAP server.
Use the Group list separator to specify the separator.
Paste a sample log message into the text box, then select Test to
test that the desired fields are correctly extracted.

Test Rule

4. Select OK to add the new matching rule.

Fine-grained controls
The Fine-grained Controls menu provides options to include or exclude a user or group from SSO, and set
the maximum number of concurrent sessions that a user or group can have.
To adjust the controls, go to Fortinet SSO Methods > SSO > Fine-grained Controls.
The following options are available:
Edit

Edit the selected user’s or group’s settings.

Clear Configuration

Clear the SSO configuration for the selected users or groups.

Exclude from SSO

Select a user or users, then select Exclude from SSO to exclude them
from SSO.
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Include in SSO

Select a user or users, then select Include in SSO to include the selected
users in SSO.

SSO Type

Select the SSO type to view from the dropdown menu. The options are:
Local Users, Local Groups, SSO Users, and SSO Groups.

SSO Name

The users’ or groups’ names. Select the column title to sort the list by this
column.

Maximum Concurrent
Sessions

The maximum concurrent sessions allowed for the user or group. This
number cannot be greater than five.

Excluded from SSO

If the user or group is excluded from SSO, a red circle with a line will be
displayed.

To edit an SSO user or group:
1. In the Fine-grained Controls window, select the SSO user or group that is being edited then select Edit.
The Edit SSO Fine-grained Control Item window opens.
2. Enter the maximum number of concurrent SSO logon sessions per user that the user or group is allowed to
have. Enter 0 for unlimited. The value must be less than or equal to five.
3. If the SSO item is a user, select Exclude from SSO and select either Do not affect current user when
excluded user logs in or Logoff current user when excluded user logs in.
4. Select OK to apply the changes.

SSO users and groups
To manage SSO users and groups, go to Fortinet SSO Methods > SSO > SSO Users or SSO Groups.
The following options are available:
Create New

Select to create a new user or group.
In the Create New SSO User or Create New SSO Group window, enter
a name for the user or group, then select OK.

Import

Import SSO users or groups from a remote LDAP server.

Delete

Delete the selected users or groups.

Edit

Edit the selected user or group.

Name

The SSO user or group names.

Created/Imported

Displays whether or not the user or user group was created or imported.
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FortiAuthenticator SSO user groups cannot be used directly in a security policy on a FortiGate device. An FSSO
user group must be created on the FortiGate unit, then the FortiAuthenticator SSO groups must be added to it.
FortiGate FSSO user groups are available for selection in identity-based security policies. See the FortiOS
Handbook for more information.

To import SSO users or groups:
1. In the SSO Users or SSO Groups list, select Import.
l

l

In the Import SSO Users or Import SSO Groups window, select whether to import the DN or
Username, and select a remote LDAP server from the Remote LDAP Server dropdown menu, then
select Browse.
In the Import SSO Groups window, select a remote LDAP server from the Remote LDAP Server
dropdown menu and select Browse. Alternatively, select Azure ADFS and specify the Graph
API Service Root, Client ID, and Client key.

An LDAP server must already be configured to select it in the dropdown
menu. See LDAP service on page 122 for more information on adding a remote
LDAP server.
The Import SSO Users or Import SSO Groups window opens in a new browser window.

2. Optionally, enter a Filter string to reduce the number of entries returned, and then select Apply, or select
Clear to clear the filters.
For example, uid=j* returns only user IDs beginning with “j”.
3. The default configuration imports the attributes commonly associated with Microsoft Active Directory
LDAP implementations. Select Configure user attributes to edit the remote LDAP user mapping
attributes.
Selecting the field, FirstName for example, presents a list of attributes which have been detected and can
be selected. This list is not exhaustive; other non-displayed attributes may be available for import. Consult
your LDAP administrator for a list of available attributes.
4. Select the entries you want to import.
5. Optionally, select an organization from the Organization drop-down to associated the imported users
with a specific organization. See Organizations on page 84.
6. Select OK to import the users or groups.
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Domain groupings
Domain groupings enable you to identify and group together SSO sessions from domains belonging to a
specific FortiGate or virtual domain (VDOM). This is useful in environments where the networks behind each
FortiGate or VDOM have their own set of users and IP subnets. Domain groupings allow the FortiAuthenticator
to return only the SSO sessions belonging to users from a specific FortiGate or VDOM.
To manage domain groupings, go to Fortinet SSO Methods > SSO > Domain Groupings.
The following options are available:
Create New

Configure a new domain grouping.

Delete

Delete the selected domain groupings.

Edit

Edit the selected domain grouping.

Name

The name of the domain grouping.

Description

A description of the domain grouping.

Domains

A list of domains that belong to the domain grouping.

Logins from domains that do not belong to any other configured domain grouping will be assigned to the
Default domain grouping.

To create a new domain grouping:
1. From the Domain Groupings list, select Create New.
The Create New Domain Grouping window opens.
2. Enter the following information:
Name

Enter a name for the domain grouping.

Description

Optionally, enter a description for the domain grouping.

Domain list

Enter the domains that belong to the domain grouping, separated with
commas or line breaks.

Note: A domain can only belong to one domain grouping.
3. Select OK to create the new domain grouping.
After domain groupings are defined, the SSO sessions list displays the corresponding domain grouping of
each SSO session. See SSO on page 171 for more information.

FortiGate filtering
If you are providing FSSO to only certain groups on a remote LDAP server, you can filter the polling information
so that it includes only those groups, or organizational units (OU).
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To view a list of the FortiGate group filters, go to Fortinet SSO Methods > SSO > FortiGate Filtering.

To create a new filter:
1. From the FortiGate filters select Create New.
The Create New FortiGate Filter window opens.
2. Enter the following information:
Name

Enter a name in the Name field to identify the filter.

FortiGate name/IP

Enter the FortiGate unit’s FQDN or IP address.

Description

Optionally, enter a description of the filter.

IP Filtering

Select to enable IP filtering for this service.
Choose the desired IP filtering rules from the Available IP filtering rules
box and move them to the Selected IP filtering rules box.

Note: If you have not yet configured IP filtering rules, you can select the
[Create new rule] option in the Available IP filtering rules box, or
create them under Fortinet SSO Methods > SSO > IP Filtering Rules
(see IP filtering rules on page 162 for more information).
Domain Grouping
Filtering

Select to enable forwarding FSSO information for users from only the
selected domain groupings.
See Domain groupings on page 161 for more information.

Fortinet Single Sign-On
(FSSO)

Select to enable forwarding FSSO information for users from only the
specific subset of users, groups, or containers.
Select Create New under SSO Filtering Objects, enter a name to
identify the policy, and select from the following object types:
l
Group: Specifies the DN of a group. All users who are members of
that group must be included in SSO.
l
Group container: Specifies the DN of an LDAP container, e.g. OU.
All users who are members of a group under that container or one of
its sub-containers must be included in SSO.
l
User: Specifies the DN of a user. This user must be included in SSO.
l
User container: Specifies the DN of an LDAP container, e.g. OU. All
users who are under that container or one of its sub-containers must
be included in SSO.
l
User and group container: Specifies the DN of an LDAP container,
e.g. OU. It is the union of the user and the group containers.
You can also use the Import option to import an existing object.

3. Select OK to create the new FortiGate group filter.

IP filtering rules
The user logon information sent to FortiGate units can be restricted to specific IP addresses or address ranges.
If no filters are defined, information is sent for all addresses.
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Once created, IP filtering rules must be assigned to FortiGate filters under Fortinet SSO Methods
> SSO > FortiGate Filtering (see FortiGate filtering on page 161 for more information).
To view the list of the IP filtering rules, go to Fortinet SSO Methods > SSO > IP Filtering Rules.

To create new IP filtering rules:
1. From the IP filtering rules list, select Create New. The Create New IP Filtering Rule window opens.
2. Enter the following information:
Name

Enter a name for the rule.

Filter Mode

Either Include or Exclude the defined IPs in SSO.

Filter Type

Select whether the rule will specify an IPv4 address and netmask, an
IPv6 address range, or an IPv6 address.

Rule

Enter either an IP address and netmask or an IP address range
(depending on the selected filter type). For example:
IPv4 address/mask: 10.0.0.1/255.255.255.0
l
IP range: 10.0.0.1/10.0.0.99
l
IPv6: 2001:db8:1ced:f00d::/128
l

3. Select OK to create the new IP filtering rule.

Tiered architecture
Tier nodes can be managed by going to Fortinet SSO Methods > SSO > Tiered Architecture. A maximum
of five tier nodes can be configured.
The following options are available:
Create New

Select to create a new tier node.

Delete

Select to delete the selected node or nodes.

Edit

Select to edit the selected node.

Search

Enter a search term to search the tier node list.

Name

The node name.

Tier Role

The node’s tier role, either Collector or Supplier.

Address

The IP address of the node.

Port

The collector port number. Only applicable if Tier Role is Collector.

Serial Number

The serial number or numbers.
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Enabled

If the node is enabled, a green circle with a check mark will be shown.
A node can be disabled without losing any of its settings.

To add a new tier node:
1. From the tier node list, select Create New. The Create New Tier Node window opens.

2. Enter the following information:
Name

Enter a name to identify the node.

Serial number

Enter the device serial number.

Alternate serial number

Optionally, enter a second, or alternate, serial number for an HA cluster
member.

Tier role

Select the tier node role, either Supplier or Collector.

Node IP address

Enter the IP address for the supplier or collector.

Collector Port

Enter the collector port number. Default is 8003. This is only available
when Tier role is set to Collector.

Disable

Disable the node without losing any of its settings.

3. Select OK to create the new tier node.

FortiClient SSO Mobility Agent
The FortiClient SSO Mobility Agent is a feature of FortiClient Endpoint Security. The agent automatically
provides user name and IP address information to FortiAuthenticator for transparent authentication. IP address
changes, such as those due to WiFi roaming, are automatically sent to the FortiAuthenticator. When the user
logs off or otherwise disconnects from the network, FortiAuthenticator is aware of this and deauthenticates the
user.
The FortiClient SSO Mobility Agent Service must be enabled. See Enable FortiClient SSO Mobility Agent
Service on page 144.
Setup of the FortiClient SSO Mobility Agent uses standard Msiexec installation switches as well as FortiClient
SSO switches, including SSOSERVER , SSOPORT, and SSOPSK . For example: FortiClientSSO.msi
/qn /i SSOSERVER="1.2.3.4" SSOPORT="8001" SSOPSK="pre_shared_key".
For additional Msiexec installation switches, see Microsoft's documentation on command-line options.
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For information on configuring FortiClient, see the FortiClient Administration Guide for your device.

Fake client protection
Some attacks are based on a user authenticating to an unauthorized AD server in order to spoof a legitimate
user logon through the FortiClient SSO Mobility Agent. You can prevent this type of attack by enabling NTLM
authentication (see Enable NTLM on page 144).
FortiAuthenticator will initiate NTLM authentication with the client, proxying the communications only to the
legitimate AD servers it is configured to use.
If NTLM is enabled, FortiAuthenticator requires NTLM authentication when:
l
l
l
l
l

the user logs on to a workstation for the first time,
the user logs off and then logs on again,
the workstation IP address changes,
the workstation user changes,
and NTLM authentication expires (user configurable).
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A FortiGate or FortiMail unit can transparently identify users who have already authenticated on an external
RADIUS server by parsing RADIUS accounting records. However, this approach has potential difficulties:
l

l

The RADIUS server is business-critical IT infrastructure, limiting the changes that can be made to the
server configuration.
In some cases, the server can send accounting records only to a single endpoint. Some network topologies
may require multiple endpoints.

The FortiAuthenticator RADIUS accounting proxy overcomes these limitations by proxying the RADIUS
accounting records, modifying them, and replicating them to the multiple subscribing endpoints as needed.

RADIUS accounting proxy
The FortiAuthenticator receives RADIUS accounting packets from a carrier RADIUS server, transforms them,
and forwards them to multiple FortiGate or FortiMail devices for use in RADIUS Single Sign-On (RSSO). This
differs from the packet use of RADIUS accounting (RADIUS accounting on page 153).
The accounting proxy needs to know:
l
l
l

the rule sets to define or derive the RADIUS attributes that the FortiGate unit requires,
the source of the RADIUS accounting records (i.e. the RADIUS server),
and the destination(s) of the accounting records (i.e. the FortiGate units using this information for RSSO
authentication).

General
General RADIUS accounting proxy settings can be configured by going to Fortinet SSO Methods >
Accounting Proxy > General.
The following settings are available:
Log level

Select Error, Warning, Info, or Debug as the minimum event severity
level to log from the dropdown menu. The default is Error.

Group cache lifetime

Enter the amount of time after which user group memberships will expire in
the cache, from 1-10080 minutes (maximum of one week). The default is
480.

Number of proxy retries

Enter the number of times to retry proxy requests if they timeout, from 0-3
retries, where 0 disables retries. The default is 3.

Proxy retry timeout

Enter the retry timeout period of a proxy request, from 1-10 seconds. The
default is 5.
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Statistics update period

Enter the time between statistics updates to the seconds debug log, from
1-3600 seconds (maximum of one hour). The default is 5.

Select OK to apply your changes.

Rule sets
A rule set can contain multiple rules. Each rule can do one of the following:
l
l
l

Add an attribute with a fixed value.
Add an attribute retrieved from a user’s record on an LDAP server.
Rename an attribute to make it acceptable to the accounting proxy destination.

FortiAuthenticator can store up to 25 rule sets. You can provide both a name and description to rule sets to help
identify each rule set and their purpose.
Rules access RADIUS attributes of which there are both standard attributes and vendor-specific attributes
(VSAs). To select a standard attribute, select the default vendor. See RADIUS attributes on page 88.
To view the accounting proxy rule set list, go to Fortinet SSO Methods > Accounting Proxy > Rule Sets.

To add RADIUS accounting proxy rule sets:
1. From the rule set list, select Create New. The Create New Rule Set window opens.
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2. Enter the following information:
Name

Enter a name to use when selecting this rule set for an accounting proxy
destination.

Description

Optionally, enter a brief description of the rule’s purpose.

Rules

Enter one or more rules.
Action

The action for each rule can be either Add or Modify.
l
Add: Add either a static value or a value derived from an LDAP
server.
l
Modify: Rename an attribute.

Attribute

Select Browse and choose the appropriate Vendor and Attribute ID
in the Select a RADIUS Attribute dialog box.

Attribute 2

If Action is set to Modify, a second attribute may be selected. The first
attribute will be renamed to the second attribute.

Value type

If the action is set to Add, select a value type from the dropdown menu.
l
Static value: Adds the attribute in the Attribute field containing
the static value in the Value field.
l
Group names: Adds attribute in the Attribute field containing
"Group names" from the group membership of the Username
Attribute on the remote LDAP server.

Value

If the action is set to Add and Value Type is set to Static value, enter
the static value.

Username
attribute

If the action is set to Add, and Value Type is not set to Static value,
specify an attribute that provides the user’s name, or select Browse
and choose the appropriate Vendor and Attribute ID in the Select a
RADIUS Attribute dialog box.

Remote LDAP

If the attribute addition requires an LDAP server, select one from the
dropdown menu. See LDAP service on page 122 for information on
remote LDAP servers.

Description

A brief description of the rule is provided.

Add another
Rule

Select to add another rule to the rule set.

3. Select OK to create the new rule set.

Example rule set
The incoming accounting packets contain the following fields:
l
l
l

User-Name
NAS-IP-Address
Fortinet-Client-IP-Address

The outgoing accounting packets need to have these fields:
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l
l
l
l
l

User-Name
NAS-IP-Address
Fortinet-Client-IP-Address
Session-Timeout: Value is always 3600
Fortinet-Group-Name: Value is obtained from user's group membership on remote LDAP

The rule set needs two rules to add Session-Timeout and Fortinet-Group-Name. The following image provides
an example:

Sources
The RADIUS accounting proxy sources list can be viewed in Fortinet SSO Methods > Accounting Proxy >
Sources. Sources can be added, edited, and deleted as needed. A maximum of 500 proxy sources can be
configured.

To add a RADIUS accounting proxy source:
1. From the source list, select Create New. The Create New RADIUS Accounting Proxy Source
window opens.
2. Enter the following information:
Name

Enter the name of the RADIUS server. This is used in FortiAuthenticator
configurations.

Source name/IP

Enter the FQDN or IP address of the server.

Secret

Enter the pre-shared secret required to access the server.

Description

Optionally, enter a description of the source.

3. Select OK to add the RADIUS accounting proxy source.
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Destinations
The destination of the RADIUS accounting records is the FortiGate unit that will use the records to identify
users. When defining the destination, you also specify the source of the records (a RADIUS client already
defined as a source) and the rule set to apply to the records.
To view the RADIUS accounting proxy destinations list, go to Fortinet SSO Methods > Accounting Proxy >
Destinations. A maximum of 500 proxy destinations can be configured.

To add a RADIUS accounting proxy destinations:
1. From the destinations list, select Create New. The Create New RADIUS Accounting Proxy
Destination window opens.
2. Enter the following information:
Name

Enter a name to identify the destination device in your configuration.

Destination name/IP

Enter The FQDN or IP address of the FortiGate that will receive the
RADIUS accounting records.

Secret

Enter the pre-shared key of the destination.

Source

Select a RADIUS client defined as a source from the dropdown menu.
See Sources on page 169.

Rule set

Select an appropriate rule set from the dropdown menu or select Create
New to create a new rule set. See Rule sets on page 167.

3. Select OK to add the RADIUS accounting proxy destination.
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The Monitor menu tree provides options for monitoring SSO and authentication activity.

SSO
FortiAuthenticator can monitor the units that make up FSSO. This is useful to ensure there is a connection to
the different components when troubleshooting.

Domains
To monitor SSO domains, go to Monitor > SSO > Domains. Select Refresh to refresh the domain list.
Select Expand All to expand all of the listed domains, or Collapse All to collapse the view.
In some instances, FSSO's performance may have been impeded by Domain Controllers that were slow to
answer LDAP queries for group lookup. Because of this, new enhancements for LDAP queries have been
introduced.
Mousing-over Domain Controllers and their most recent LDAP query shows the status of the query, how long
ago it was, and the LDAP query's response time in milliseconds (ms). This response time will show a warning
icon if the highest recent response time is above 500 ms.
In addition, you can click on the domain controller entry to view statistics for the 100-most recent LDAP queries.
The listed response times will be color coordinated as follows: green for less than 500 ms, orange for between
500 and 1000 ms, and red for more than/equal to 1000 ms.

SSO sessions
To monitor SSO sessions, go to Monitor > SSO > SSO Sessions. Users can be manually logged off of if
required.
The following information is available:
Refresh

Refresh the SSO sessions list.

Logoff All

Log off all of the connected users.

Logoff Selected

Log off only the selected users.

Search

Enter a search term in the search field, then select Search to search the
SSO sessions list.

Filter

Filter the SSO session list by the source of the connection and/or by
Domain Group.
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To view SSO sessions not associated with any configured domain
grouping, select Default.
Logon Time

When the session was started.

Update Time

When the session was last updated.

Workstation

The workstation that the user is using.

IP address

The IP address of the workstation.

Domain Grouping

The domain group to which the domain belongs.

Domain

The domain to which the user belongs.

Username

The username of the user.

Source

The source of the connection.

Group

The group to which the user belongs.

Windows event log sources
Windows event log sources can be viewed by going to Monitor > SSO > Windows Event Log Sources.
The sources list can be refreshed by selecting Refresh, and searched using the search field.
The list shows the total number of events, as well as the most recent event.

FortiGates
FortiGate units that are registered with FortiAuthenticator can be viewed at Monitor > SSO > FortiGates.
The list can be refreshed by selecting Refresh and searched using the search field. The list shows the
connection time of each device, as well as its IP address and serial number.
User authentication events are logged in the FortiGate event log. See the FortiGate Handbook for more
information.

DC/TS agents
Domain controller (DC) agents and terminal server (TS) agents that are registered with FortiAuthenticator can
be viewed at Monitor > SSO > DC/TS Agents.
The list can be refreshed by selecting Refresh and searched using the search field.
The list shows the server name of each agent, as well as its IP address, its agent type, last connection time,
connection status, and the number of logged-on users.
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NTLM statistics
Dumped NTLM statistics can be viewed at Monitor > SSO > NTLM Statistics.
The statistics can be refreshed and cleared by selecting Refresh and Clear respectively.

Authentication
Locked out/inactive users, RADIUS sessions, the Windows AD server and device login sessions, and learned
RADIUS users can be monitored under Monitor > Authentication.

Locked-out users
To view the locked-out users, go to Monitor > Authentication > Locked-out Users.
To unlock a user from the list, select the user and select Unlock. The list can be refreshed by selecting
Refresh, and searched using the search field.
The list shows the username, server, the reason the user was locked out, and when their lock-out expires.
For more information on locked-out users, see Top user lockouts widget on page 33, Lockouts on page 62, and
User management on page 67.

RADIUS sessions
FortiAuthenticator administrators can monitor RADIUS activity and log out a user if they wish.
To view currently active RADIUS accounting sessions, go to Monitor > Authentication
> RADIUS Sessions.
The page shows the user's name, type, IP address, MAC address, and RADIUS client, duration, and data
usage columns. More specifically, Accounting-Start Interim-Update packets are received. A user session is
removed from this table once the Accounting-Stop packet is received, or the session doesn't receive any
RADIUS accounting packets before the timeout period expires.
To log out a user as an admin, select the user from the table and select Logoff.
There are two pages to view: Active and Cumulative. Select Cumulative to view statistics for user who have
a time and/or data usage limit. This information may be accumulated through a succession of RADIUS
accounting sessions. A user's stats are removed when explicitly deleted by the administrator (by selecting the
user and selecting Delete), or when the user's account itself is deleted.
While administrators can log out users, they can also reset a user's time and/or data usage using Reset
Usage.

For more information on user time and data usage limits, see Usage Profile.
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RADIUS accounting sessions can be configured to timeout after a specific time period has been reached. To do
so, see General.

Windows AD
FortiAuthenticator supports multiple Windows AD server forests, as shown below. A maximum of 20 remote
LDAP servers with Windows AD enabled can be configured at once. In addition, you can see when the server
was last updated, and an option to reset the connection for individual servers.
To view Windows AD server information, go to Monitor > Authentication > Windows AD.

To refresh the connection, select Refresh in the toolbar. The server name, IP address, authentication realm,
agent, and connection are shown.

Windows device logins
To view the Windows device logins, go to Monitor > Authentication > Windows Device Logins.
To refresh the list, select Refresh in the toolbar. See Machine authentication on page 59 for more information.
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Learned RADIUS users
Learned RADIUS users are users that have been learned by the FortiAuthenticator after they have
authenticated against a remote RADIUS server.
For information on enabling learning RADIUS users, see RADIUS service on page 117.
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Certificate management
This section describes managing certificates with the FortiAuthenticator device.
FortiAuthenticator can act as a CA for the creation and signing of X.509 certificates, such as server certificates
for HTTPS and SSH, and client certificates for HTTPS, SSL, and IPsec VPN.
The FortiAuthenticator unit has several roles that involve certificates:

Certificate authority

The administrator generates CA certificates that can validate the user
certificates generated on this FortiAuthenticator.
The administrator can import other authorities' CA certificates and
Certificate Revocation Lists (CRLs), as well as generate, sign, and revoke
user certificates. See End entities on page 177 for more information.

SCEP server

A SCEP client can retrieve any of the local CA certificates (Local CAs on
page 186), and can have its own user certificate signed by the
FortiAuthenticator's CA.

Remote LDAP
authentication

Acting as an LDAP client, FortiAuthenticator can authenticate users against
an external LDAP server. It verifies the identity of the external LDAP server
by using a trusted CA certificate. See Trusted CAs on page 193 for more
information.

EAP authentication

FortiAuthenticator can check that the client’s certificate is signed by one of
the configured authorized CA certificates (see Certificate authorities on
page 186). The client certificate must also match one of the user
certificates (see End entities on page 177).

Any changes made to certificates generate log entries that can be viewed under Logging > Log Access >
Logs. See Logging on page 200.

Policies
The policies section includes global configuration settings which are applied across all CAs and end-entity
certificates created on FortiAuthenticator.

Certificate expiry
Certificate expiration settings can be configured under Certificate Management > Policies > Certificate
Expiry.
Enable Warn when a certificate is about to expire to configure the following:
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Send a warning email

Enter the number of days before the certificate expires that the email will
be sent, between 0-365 (maximum of one year). The default is 7.

Administrator's email

Enter the email address to which the expiry warning message will be sent.

Select OK to apply any configuration changes.

End entities
User and server certificates are required for mutual authentication on many HTTPS, SSL, and IPsec VPN
network resources. You can create a user certificate on the FortiAuthenticator device, or import and sign a
CSR. User certificates, client certificates, or local computer certificates are all the same type of certificate.
To view the user certificate list, go to Certificate Management > End Entities > Users. To view the server
certificate list, go to Certificate Management > End Entities > Local Services.
The following information is available:
Create New

Create a new certificate.

Import

Select to import a certificate signed by a third-party CA for a previously
generated CSR (see To import a local user certificate: on page 183 and To
import a server certificate: on page 183) or to import a CSR to sign (see To
import a CSR to sign: on page 183).

Revoke

Revoke the selected certificate. See To revoke a certificate: on page 185.

Delete

Delete the selected certificate.

Export Certificate

Save the selected certificate to your computer.

Export PKCS#12

Export the PKCS#12. This is only available for user certificates.

Search

Enter a search term in the search field, then press Enter to search the
certificate list.

Filter

Select to filter the displayed certificates by status. The available selections
are: All, Pending, Expired, and Active.

Certificate ID

The certificate ID.

Subject

The certificate’s subject.

Issuer

The issuer of the certificate.

Status

The status of the certificate.
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Certificates can be created, imported, exported, revoked, and deleted as required. CSRs can be imported to
sign, and the certificate detail information can also be viewed, see To view certificate details: on page 185.

To create a new certificate:
1. To create a new user certificate, go to Certificate Management > End Entities > Users. To create a
new server certificate, go to Certificate Management > End Entities > Local Services.
2. Select Create New to open the Create New User Certificate or Create New Server Certificate
window.
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3. Configure the following settings:
Certificate ID
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Certificate Signing Options
Issuer

Select the issuer of the certificate, either Local CA or Third-party
CA. Selecting Third-party CA generates a CSR that is to be signed
by a third-party CA.

Local User (Optional)

If Local CA is selected as the issuer, you may select a local user
from the dropdown menu to whom the certificate will apply. This
option is only available when creating a new user certificate.

Certificate authority

If Local CA is selected as the issuer, select one of the available
CAs configured on FortiAuthenticator from the dropdown menu.
The CA must be valid and current. If it is not you will have to create
or import a CA certificate before continuing. See Certificate
authorities on page 186.

Subject Information
Subject input method

Select the subject input method, either Fully distinguished name
or Field-by-field.

Subject DN

If the subject input method is Fully distinguished name, enter the
full distinguished name of the subject. There should be no spaces
between attributes.
Valid DN attributes are DC, C, ST, L, O, OU, CN, and emailAddress.
They are case-sensitive.

Name (CN)

If the subject input method is Field-by-field, enter the subject name
in the Name (CN) field, and optionally fill-in the following fields:
l
l
l
l
l
l

Department (OU)
Company (O)
City (L)
State/Province (ST)
Country (C) (select from dropdown menu)
Email address

Key and Signing Options

Validity period

Select the amount of time before this certificate expires. This validity
period option is only available when Issuer is set to Local CA.
Select Set length of time to enter a specific number of days, or
select Set an expiry date to enter the specific date on which the
certificate expires.

Key type

The key type is set to RSA .

Key size

Select the key size from the dropdown menu, either 1024, 2048, or
4096 bits.

Hash algorithm

Select the hash algorithm from the dropdown menu, either SHA-256
or SHA-1.

FortiAuthenticator 5.5.0 Administration Guide
Fortinet Technologies Inc.

180

Certificate management

Subject Alternative Name

Subject alternative names (SAN) allow you to protect multiple host
names with a single SSL certificate. SAN is part of the X.509
certificate standard.
For example, SANs are used to protect multiple domain names such
as www.example.com and www.example.net, in contrast to
wildcard certificates that only protect all first-level subdomains on
one domain, such as *.example.com.

Email

Enter the email address of a user to map to this certificate.

User Principal Name
(UPN)

Enter the UPN used to find the user’s account in Microsoft Active
Directory. This will map the certificate to this specific user. The UPN
is unique for the Windows Server domain. This is a form of one-toone mapping.

URI

Enter the URI used to validate certificates.

DNS

Enter the DNS used to validate and sign the imported CSR.

Other Extensions

Add CRL Distribution
Points extension

This option is only available when creating a new user certificate,
and when Issuer is set to Local CA.
Select to add CRL distribution points extension to the certificate.
A DNS domain name must be configured. If it has not been, select
Edit DNS name to configure one. See DNS on page 35.

Note: Once a certificate is issued with this extension, the server
must be able to handle the CRL request at the specified location.
Add OCSP
Responder URL

Enable Online Certificate Status Protocol (OCSP) to obtain the
revocation status of a certificate.

Use certificate for
Smart Card logon

Select to use the certificate for smart card logon.

Advanced Options: Key
Usages

Enabling this setting will automatically enable Add CRL
Distribution Points extension.
Some certificates require the explicit presence of key usage
attributes before the certificate can be accepted for use.

Digital Signature

A high-integrity signature that assures the recipient that a message
was not altered in transit

Non Repudiation

An authentication that is deemed as genuine with high assurance.

Key Encipherment

Uses the public key to encrypt private or secret keys.

Data Encipherment

Uses the public key to encrypt data.

Key Agreement

An interactive method for multiple parties to establish a
cryptographic key, based on prior knowledge of a password.

Certificate Sign

A message from an applicant to a certificate authority in order to
apply for a digital identity certificate.
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CRL Sign

A Certificate Revocation List (CRL) Sign states a validity period for
an issued certificate.

Encipher Only

Information will be converted into code only.

Decipher Only

Code will be converted into information only.

Advanced Options: Extended
Key Usages

Some certificates require the explicit presence of extended key
usage attributes before the certificate can be accepted for use.

Server
Authentication

Authentication will only be granted when the user submits their
credentials to the server.

Client Authentication

Authentication will be granted to the server by exchanging a client
certificate.

Code Signing

Used to confirm the software author, and guarantees that the code
has not been altered or corrupted through use of a cryptographic
hash.

Secure Email

A secure email sent over SSL encryption.

OCSP Signing

Online Certificate Status Protocol (OCSP) Signing sends a request to
the server for certificate status information. The server will send back
a response of "current", "expired", or "unknown". OCSP permits a
grace period to users or are expired, allowing them a limited time
period to renew. This is typically used over CRL.

IPSec End System
IPSec Tunnel
Termination

IPsec Security Associations (SAs) are terminated through deletion or
by timing out

IPSec User
IPSec IKE
Intermediate (end
entity)

An intermediate certificate is a subordinate certificate issued by a
trusted root specifically to issue end-entity certificates. The result is a
certificate chain that begins at the trusted root CA, through the
intermediate CA (or CAs) and ending with the SSL certificate issued
to you.

Time Stamping
Microsoft Individual
Code Signing

User submits information that is compared to an independent
consumer database to validate their credentials.

Microsoft
Commercial Code
Signing

User submits information that proves their identity as corporate
representatives.

Microsoft Trust List
Signing

Uses a certificate trust list (CTL), a list of hashes of certificates. The
list is comprised of pre-authenticated items that were approved by a
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trusted signing entity.
Microsoft Server
Gated Crypto

A defunct mechanism that stepped up 40-bit and 50-bit to 128-bit
cipher suites with SSL.

Netscape Server
Gated Crypto

A defunct mechanism that stepped up 40-bit and 50-bit to 128-bit
cipher suites with SSL.

Microsoft Encrypted
File System

The Encrypted File System (EFS) enables files to be transparently
encrypted to protect confidential data.

Microsoft EFS File
Recovery

The certificate will be granted on the condition it has an EFS file
recovery agent prepared.

Smart Card Logon

The certificate will be granted on the condition that the user logs on
to the network with a smart card.

EAP over PPP

Extensible Authentication Protocol (EAP) will operate within a Pointto-Point Protocol (PPP) framework.

EAP over LAN

EAP will operate within a Local Area Network (LAN) framework.

KDC Authentication

An authentication server forwards usernames to a key distribution
center (KDC), which issues an encrypted, time-stamped ticket back
to the user.

4. Select OK to create the new certificate.
To import a local user certificate:
1. Go to Certificate Management > End Entities > Users and select Import.
2. For Type, select Local certificate.
3. Select Choose File to locate the certificate file on your computer.
4. Select OK to import the certificate.
To import a server certificate:
1. Go to Certificate Management > End Entities > Local Services and select Import.
2. Select Choose File to locate the certificate file on your computer.
3. Select OK to import the certificate.
To import a CSR to sign:
1. Go to Certificate Management > End Entities > Users and select Import.
2. For Type, select CSR to sign.
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3. Configure the following settings:
Certificate ID

Enter a unique ID for the certificate.

CSR file (.csr, .req)

Select Choose File then locate the CSR file on your computer.

Certificate Signing Options
Certificate
authority

Select one of the available CAs configured on the FortiAuthenticator
from the dropdown menu.
The CA must be valid and current. If it is not you will have to create or
import a CA certificate before continuing. See Certificate authorities on
page 186.

Validity period

Select the amount of time before this certificate expires.
Select Set length of time to enter a specific number of days, or select
Set an expiry date and enter the specific date on which the certificate
expires

Hash algorithm

Select the hash algorithm from the dropdown menu, either SHA-256 or
SHA-1.

Subject Alternative Name
Email

Enter the email address of a user to map to this certificate.

User Principal
Name (UPN)

Enter the UPN used to find the user’s account in Microsoft Active
Directory. This will map the certificate to this specific user. The UPN is
unique the Windows Server domain. This is a form of one-to-one
mapping.
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Other Extensions
Add CRL
Distribution
Points extension

Select to add CRL distribution points extension to the certificate.
A DNS domain name must be configured. If it has not been, select Edit
DNS name to configure one. See DNS on page 35.

Note: Once a certificate is issued with this extension, the server must
be able to handle the CRL request at the specified location.
Add OCSP
Responder URL

Enable Online Certificate Status Protocol (OCSP) to obtain the
revocation status of a certificate.

Use certificate
for Smart Card
logon

Select to use the certificate for smart card logon.

Advanced Options: Key
Usages and Extended Key
Usages

Enabling this setting will automatically enable Add CRL Distribution
Points extension.
Some certificates require the explicit presence of key usage attributes
before the certificate can be accepted for use.
Same settings available as when creating a new user certificate (see
above).

4. Select OK to import the CSR.
To revoke a certificate:
1. Go to Certificate Management > End Entities > Users or to Certificate Management > End
Entities > Local Services.
2. Select the certificate that will be revoked and select Revoke.
3. Select a reason for revoking the certificate from the Reason code dropdown menu. The reasons available
are:
l
Unspecified
l

Key has been compromised

l

CA has been compromised

l

Changes in affiliation

l

Superseded

l

Operation ceased

On Hold
Some of these reasons are security related (such as the key or CA being compromised), while others are
more business related. A Change in affiliation could be an employee leaving the company, while
Operation ceased could be a project that was cancelled.
l

4. Select OK to revoke the certificate.
To view certificate details:
From the certificate list, select a certificate ID to open the Certificate Detail Information window.
Select Edit next to the Certificate ID field to change the certificate ID. If any of this information is out of date
or incorrect, you will not be able to use this certificate. If this is the case, delete the certificate and re-enter the
information in a new certificate, see To create a new certificate: on page 178. Select Close to return to the
certificate list.
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Certificate authorities
A certificate authority (CA) is used to sign other server and client certificates. Different CAs can be used for
different domains or certificates. For example, if your organization is international you may have a CA for each
country, or smaller organizations might have a different CA for each department. The benefits of multiple CAs
include redundancy, in case there are problems with one of the well-known trusted authorities.
Once you have created a CA certificate, you can export it to your local computer.

Local CAs
The FortiAuthenticator device can act as a self-signed, or local, CA.
To view the certificate information, go to Certificate Management > Certificate Authorities > Local CAs.
The following information in shown:
Create New

Create a new CA certificate.

Import

Import a CA certificate. See Importing CA certificates and signing requests
on page 189.

Revoke

Revoke the selected CA certificate.

Delete

Delete the selected CA certificate.

Export

Save the selected CA certificate to your computer.

Search

Enter a search term in the search field, then press Enter to search the CA
certificate list. The search will return certificates that match either the
subject or issuer.

Filter

Select to filter the displayed CAs by status. The available selections are:
All, Pending, Expired, Revoked, and Active.

Certificate ID

The CA certificate ID.

Subject

The CA certificate subject.

Issuer

The issuer of the CA certificate.

Status

The status of the CA certificate.

CA Type

The CA type of the CA certificate.

To create a CA certificate:
1. From the local CA certificate list, select Create New. The Create New Local CA Certificate window
opens.
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2. Enter the following information:
Certificate ID

Enter a unique ID for the CA certificate.

Certificate Authority Type
Certificate type

Select one of the following options:
l
Root CA certificate: A self-signed CA certificate.
l
Intermediate CA certificate: A CA certificate that refers to a
different root CA as the authority.
l

Certificate
authority

Select one of the available CAs from the dropdown menu.
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This field is only available when the certificate type is Intermediate CA
certificate.
Subject Information
Subject input
method

Select the subject input method, either Fully distinguished name or
Field-by-field.

Subject DN

If the subject input method is Fully distinguished name, enter the full
distinguished name of the subject. There should be no spaces between
attributes.
Valid DN attributes are DC, C, ST, L, O, OU, CN, and emailAddress.
They are case-sensitive.

Name (CN)

If the subject input method is Field-by-field, enter the subject name in
the Name (CN) field, and optionally enter the following fields:
l
l
l
l
l
l

Department (OU)
Company (O)
City (L)
State/Province (ST)
Country (C) (select from dropdown menu)
Email address

Key and Signing Options
Validity period

Select the amount of time before this certificate expires.
Select Set length of time to enter a specific number of days, or select
Set an expiry date and enter the specific date on which the certificate
expires.
This option is not available when the certificate type is set to
Intermediate CA certificate signing request (CSR).

Key type

The key type is set to RSA .

Key size

Select the key size from the dropdown menu: 1024, 2048 (set by
default), or 4096 bits.

Hash algorithm

Select the hash algorithm from the dropdown menu, either SHA-256
(set by default) or SHA-1.

Subject Alternative Name

SANs allow you to protect multiple host names with a single SSL
certificate. SAN is part of the X.509 certificate standard.
This section is not available when the certificate type is Intermediate
CA certificate signing request (CSR).

Email

Enter the email address of a user to map to this certificate.

User Principal
Name (UPN)

Enter the UPN used to find the user’s account in Microsoft Active
Directory. This will map the certificate to this specific user. The UPN is
unique for the Windows Server domain. This is a form of one-to-one
mapping.

Advanced Options: Key
Usages

Some certificates require the explicit presence of extended key usage
attributes before the certificate can be accepted for use.
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For detailed information about these attributes, see End entities on
page 177.

Key Usages

l
l
l
l
l
l
l
l
l

Extended Key
Usages

l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

Certificate Revocation List
(CRL)

Digital Signature
Non Repudiation
Key Encipherment
Data Encipherment
Key Agreement
Certificate Sign
CRL Sign
Encipher Only
Decipher Only
Server Authentication
Client Authentication
Code Signing
Secure Email
OCSP Signing
IPSec End System
IPSec Tunnel Termination
IPSec User
IPSec IKE Intermediate (end entity)
Time Stamping
Microsoft Individual Code Signing
Microsoft Commercial Code Signing
Microsoft Trust List Signing
Microsoft Server Gated Crypto
Netscape Server Gated Crypto
Microsoft Encrypted File System
Microsoft EFS File Recovery
Smart Card Logon
EAP over PPP
EAP over LAN
KDC Authentication

Determine the certificate's lifetime before the CA certificate is
revoked.

Lifetime

Enter the lifetime of the certificate in days, between 1-365 (maximum of
one year). The default is 30.

Re-generate every

Enter how often the certificate will regenerate.

3. Select OK to create the new CA certificate.

Importing CA certificates and signing requests
Four options are available when importing a certificate or signing request: PKCS12 Certificate, Certificate
and Private Key, CSR to sign, and Local certificate.
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To import a PKCS12 certificate:
1. From the local CA certificate list, select Import. The Import Signing Request or Local CA Certificate
window opens.
2. Select PKCS12 Certificate in the type field.

3. Enter the following:
Certificate ID

Enter a unique ID for the certificate.

PKCS12 certificate file
(.p12)

Select Choose File to locate the certificate file on your computer.

Passphrase

Enter the certificate passphrase.

Initial Serial Number

Select the serial number radix, either Decimal or Hex, and enter the
initial serial number in the Initial serial number field.

4. Select OK to import the certificate.
To import a certificate with a private key:
1. From the local CA certificate list, select Import. The Import Signing Request or Local CA Certificate
window opens.
2. Select Certificate and Private Key in the type field.
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3. Enter the following:
Certificate ID

Enter a unique ID for the certificate.

Certificate file (.cer)

Select Choose File to locate the certificate file on your computer.

Private key file

Select Choose File to locate the private key file on your computer.

Passphrase

Enter the certificate passphrase.

Initial Serial Number

Select the serial number radix, either Decimal or Hex, and enter the
initial serial number in the Initial serial number field.

4. Select OK to import the certificate.
To import a CSR to sign:
1. From the local CA certificate list, select Import. The Import Signing Request or Local CA Certificate
window opens.
2. Select CSR to sign in the type field.
3. Enter the following:
Certificate ID

Enter a unique ID for the certificate.

CSR file (.csr, .req)

Select Choose File to locate the CSR file on your computer.

Certificate Signing Options
Certificate
authority

Select one of the available CAs from the dropdown menu.

Validity period

Select the amount of time before this certificate expires.
Select Set length of time to enter a specific number of days, or select
Set an expiry date and enter the specific date on which the certificate
expires.

Hash algorithm
Subject Alternative Name

Select the hash algorithm from the dropdown menu, either SHA-256 or
SHA-1.
SANs allow you to protect multiple host names with a single SSL
certificate. SAN is part of the X.509 certificate standard.

Email

Enter the email address of a user to map to this certificate.

User Principal
Name (UPN)

Enter the UPN used to find the user’s account in Microsoft Active
Directory. This will map the certificate to this specific user. The UPN is
unique for the Windows Server domain. This is a form of one-to-one
mapping.

Advanced Options: Key
Usages

Some certificates require the explicit presence of extended key usage
attributes before the certificate can be accepted for use.
For detailed information about these attributes, see End entities on
page 177.

4. Select OK to import the CSR.
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To import a local CA certificate:
1. From the local CA certificate list, select Import. The Import Signing Request or Local CA Certificate
window opens.
2. Select Local certificate in the type field.
3. Select Choose File to locate the certificate file on your computer.
4. Select OK to import the local CA certificate.

Certificate revocations lists
A certificate revocation list (CRL) is a file that contains a list of revoked certificates, their serial numbers, and
their revocation dates. The file also contains the name of the issuer of the CRL, the effective date, and the next
update date. By default, the shortest validity period of a CRL is one hour.
Some potential reasons for certificates to be revoked include:
l
l
l

A CA server was hacked and its certificates are no longer trusted.
A single certificate was compromised and is no longer trusted.
A certificate has expired and is not supposed to be used past its lifetime.

Go to Certificate Management > Certificate Authorities > CRLs to view the CRL list.
The following information is shown:
Import

Import a CRL.

Automatic Downloads

Select to view automatically downloaded CRLs. Select View CRLs to
switch back to the regular CRL view.

Export

Save the selected CRL to your computer.

CA Type

The CA type of CRL.

Issuer name

The name of the issuer of the CRL.

Subject

The CRL’s subject.

Revoked Certificates

The number of revoked certificates in the CRL.

To import a CRL:
1. Download the most recent CRL from a CDP. One or more CDPs are usually listed in a certificate under the
Details tab.
2. From the CRL list, select Import.
3. Select Choose File to locate the file on your computer, then select OK to import the list.
Note: Before importing a CRL file, make sure that either a local CA certificate or a trusted CA certificate for this
CRL has first been imported.
When successful, the CRL will be displayed in the CRL list on the FortiAuthenticator. You can select it to see
the details (see To view certificate details: on page 185).
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Locally created CRLs
When you import a CRL, it is from another authority. If you are creating your own CA certificates, you can also
create your own CRL to accompany them.
As a CA, you sign user certificates. If for any reason you need to revoke one of those certificates, it will go on a
local CRL. When this happens you must export the CRL to all your certificate users so they are aware of the
revoked certificate.

To create a local CRL:
1. Create a local CA certificate. See Local CAs on page 186.
2. Create one or more user certificates. See End entities on page 177.
3. Go to Certificate Management > End Entities > Users, select one or more certificates, and select
Revoke. See To revoke a certificate: on page 185.
The selected certificates will be removed from the user certificate list and a CRL will be created with those
certificates as entries in the list. If there is already a CRL for the CA that signed the user certificates, the
certificates will be added to the current CRL.
If later one or more CAs are deleted, their corresponding CRLs will also be deleted,
along with any user certificates that they signed.

Configuring OCSP
FortiAuthenticator also supports Online Certificate Status Protocol (OCSP), defined in RFC 2560. To use
OCSP, configure the FortiGate unit to use TCP port 2560 on the FortiAuthenticator IP address.
For example, enter the following to configure OCSP on the FortiGate's CLI Console, where the url is the IP
address of the FortiAuthenticator:
config vpn certificate ocsp-server
edit FortiAuthenticator_ocsp
set cert "REMOTE_Cert_1"
set url "http://172.20.120.16:2560"
end

Trusted CAs
Trusted CA certificates can be used to validate certificates signed by an external CA.
To view the trusted CA certificate list, go to Certificate Management > Certificate Authorities > Trusted
CAs.
The certificate ID, subject, issuer, and status are shown. Certificates can be imported, exported, deleted, and
searched.
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To import a trusted CA certificate:
1. From the trusted CA certificate list, select Import.
2. Enter a certificate ID in the Certificate ID field.
3. Select Choose File to locate the certificate file on your computer, and select OK to import the list.
When successful, the trusted CA certificate will be displayed in the list on the FortiAuthenticator device.
You can select it to see the details (see To view certificate details: on page 185).

SCEP
FortiAuthenticator contains a Simple Certificate Enrollment Protocol (SCEP) server that can sign user CSRs,
and distribute CRLs and CA certificates. To use SCEP, you must:
l
l
l

Enable HTTP administrative access on the interface connected to the Internet. See Interfaces on page 34.
Add the CA certificate for your certificate authority. See Certificate authorities on page 186.
Select the CA to use for SCEP. See Default CA on page 194.

Users can request a user certificate through online SCEP, found at http://<FortiAuthenticator-IPAddress>/cert/scep.

General
As an administrator, you can allow FortiAuthenticator to either automatically sign the user’s certificate or alert
you about the request for a signature.
To enable SCEP and configure general settings, go to Certificate Management > SCEP > General and
select Enable SCEP.
Configure the following settings:
Default CA

Select the default CA to use from the dropdown menu.

Enrollment method

Select the enrollment method:
l
Automatic: The certificate is pre-approved by the administrator. The
administrator enters the certificate information on FortiAuthenticator
and gives the user a challenger password to use when submitting their
request.
l
Manual and Automatic: The user submits the CSR, the request
shows up as pending on FortiAuthenticator unit, then the administrator
manually approves the pending request. Optionally, enter an email
address to be informed of pending approval notifications.

Default enrollment
password

Enter the default enrollment password that will be used when not setting a
random password.

Revoke the old certificate
on renewal

Enable to revoke the old certificate once it has been renewed.
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Select OK to apply any changes you have made.

Enrollment requests
To view and manage certificate enrollment requests, go to Certificate Management > SCEP > Enrollment
Requests.
Note that, before you can create or configure certificate enrollment requests, SCEP must be enabled, and
HTTP access must be enabled on the network interface(s) that will serve SCEP clients (under System >
Network > Interfaces).
The following information is available:
Create New

Create a new certificate enrollment request.

Delete

Delete the selected certificate enrollment request.

Approve/Reject

Approve or reject the selected certificate enrollment request.

Method

The enrollment method used.

Status

The status of the enrollment: Pending, Approved, or Rejected.

Wildcard

If it is a wildcard request, a green circle with a check mark is shown.

Issuer

The issuer of the certificate.

Subject

The certificate subject.

Renewable Before Expiry
(days)

The number of days before the certificate enrollment request expires that it
can be renewed.

Updated at

The date and time that the enrollment request was last updated.

To view the enrollment request details:
1. From the enrollment request list, select a request by clicking within its row.

FortiAuthenticator 5.5.0 Administration Guide
Fortinet Technologies Inc.

195

Certificate management

2. Select Close to return to the enrollment request window.
To reset the enrollment request status:
1. From the Certificate Enrollment Request window, select Did the client lose his/her certificate and
key? The Reset enrollment request status? window opens.

2. There are two methods to reset the enrollment request:
l

l

Manually remove the old enrollment request, revoke its certificate, then create a new enrollment
request with exactly the same configuration and subject name as the old certificate.
Re-use the same enrollment request by resetting its status and then revoking the lost certificate
(recommended).

3. To re-use the same enrollment request, select Yes, I’m sure.
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To create a new certificate enrollment request:
1. From the certificate enrollment requests list, select Create New.
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2. Enter the following information:
Automatic request type

Select the automatic request type, either Regular or Wildcard.

Certificate Authority

Select one of the available CAs configured on FortiAuthenticator from
the dropdown menu.
The CA must be valid and current. If it is not you will have to create or
import a CA certificate before continuing. See Certificate authorities on
page 186.

Subject Information
Subject input
method

Select the subject input method, either Fully distinguished name or
Field-by-field.

Subject DN

If the subject input method is Fully distinguished name, enter the
full distinguished name of the subject. There should be no spaces
between attributes.
Valid DN attributes are DC, C, ST, L, O, OU, CN, and emailAddress.
They are case-sensitive.

Name (CN)

If the subject input method is Field-by-field, enter the subject name in
the Name (CN) field (if the Automatic request type is set to
Regular), and optionally enter the following fields:
l
l
l
l
l
l

Department (OU)
Company (O)
City (L)
State/Province (ST)
Country (C) (select from dropdown menu)
Email address

Certificate Signing Options

Validity period

Select the amount of time before this certificate expires.
Select Set length of time to enter a specific number of days, or select
Set an expiry date and enter the specific date on which the certificate
expires.

Hash algorrithm

Select the hash algorithm from the dropdown menu, either SHA-256
(set by default) or SHA-1.

Challenge Password

Password
creation

Select to either set a random password, or use the default enrollment
password (see Default enrollment password on page 194).

Challenge
password
distribution

Select the challenge password distribution method. This option is only
available if Password creation is set to Set a random password.
l
Display: Display the password on the screen.
l
SMS: Send the password to a mobile phone. Enter the phone
number in the Mobile number field and select an SMS gateway
from the dropdown menu.
l
Email: Send the password to the email address entered in the
email field.
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To allow renewals, select Allow renewal, then enter the number of
days before the certificate expires (minimum of one day).

Renewal

Once renewal is enabled, you can optionally either allow or reject SCEP
renewal requests for expired and revoked certificates (as burst renewal
requests from FortiGates could exhaust the FortiAuthenticator and
create duplicate certificates), and either allow or reject SCEP renewal
requests signed using the old private key.
Subject Alternative Name

SANs allow you to protect multiple host names with a single SSL
certificate. SAN is part of the X.509 certificate standard.
This section is not available when the certificate type is Intermediate
CA certificate signing request (CSR).

Email

Enter the email address of a user to map to this certificate.

User Principal
Name (UPN)

Enter the UPN used to find the user’s account in Microsoft Active
Directory. This will map the certificate to this specific user. The UPN
is unique for the Windows Server domain. This is a form of one-to-one
mapping.

Advanced Options: Key
Usages

Some certificates require the explicit presence of extended key usage
attributes before the certificate can be accepted for use.
For detailed information about these attributes, see End entities on
page 177.

3. Select OK to create the new certificate enrollment request.
Once created, the request will have a Status of Pending. A code will be displayed which must be provided
to the client as a challenge password for the automatic certificate enrollment process.
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Logging
Accounting is an important part of FortiAuthenticator. The Logging menu tree provides a record of the events
that have taken place on FortiAuthenticator.

Log access
To view the log events table, go to Logging > Log Access > Logs.
The following options and information are available:
Refresh

Refresh the log list.

Download Raw Log

Export the FortiAuthenticator log to your computer as a text file named
FortiAuthenticator.log.

Log Type Reference

Select to view the log type reference dialog box. See Log type reference on
page 201.

Debug Report

Select to download the debug report to your computer as a file named
report.dbg.
You can also download a full debug report for one of the following (using
the dropdown menu):
l
l
l
l
l
l
l
l
l

Search for log records

Authentication
Database
GUI
LDAP Sync
RADIUS Accounting
SSO
System
Custom debug
Push Authentication

Enter a search term in the search field to search the log message list.
The search string must appear in the Message portion of the log entry to
result in a match. To prevent each term in a phrase from being matched
separately, multiple keywords must be in quotes and be an exact match.
After the search is complete the number of positive matches will be
displayed next to the Search button, with the total number of log entries in
brackets following. Select the total number of log entries to return to the full
list. Subsequent searches will search all the log entries, and not just the
previous search’s results.
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ID

The log message’s ID.

Timestamp

The time the message was received.

Level

The log severity level:
l
Emergency: The system has become unstable.
l
Alert: Immediate action is required.
l
Critical: Functionality is affected.
l
Error: An erroneous condition exists, and functionality is probably
affected.
l
Warning: Functionality could be affected.
l
Notification: Information about normal events.
l
Information: General information about system operations.
l
Debug: Detailed information useful for debugging purposes.

Category

The log category, which is always Event. See Log type reference on page
201.

Sub category

The log subcategory. See Log type reference on page 201.

Type id

The log type ID.

Action

The action which created the log message, if applicable.

Status

The status of the action that created the log message, if applicable.

Source IP

The source IP address of the relevant device if an authentication action
fails.

Short message

The log message itself, sometimes slightly shortened.

User

The user to whom the log message pertains.

To view log details:
From the log list, select the log whose details you need to view by clicking anywhere within the log’s row. The
Log Details pane will open on the right side of the window.
After viewing the log details, select the close icon in the top right corner of the pane to close the details pane.

Log type reference
Select Log Type Reference in the log list toolbar to open the log type reference dialog box.
The following information and options are available:
Search for log types

Enter a search term in the search field to search the log type reference.
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Type id

The log type ID.

Name

The name of the log type.

Sub category

The log type subcategory, one of: Admin Configuration,
Authentication, System, High Availability, User Portal, or Web
Service.

Category

The log type category, which is always Event.

Description

A brief description of the log type.

To close the Log Type Reference dialog box, select close above the top right corner of the box, or simply
click anywhere outside the box within the log list.

Sort the log messages
The log message table can be sorted by any column. To sort the log entries by a particular column, select the
title for that column. The log entries will now be displayed based on data in that column in ascending order.
Select the column heading again to sort the entries in descending order. Ascending or descending is displayed
with an arrow next to the column title, an up arrow for ascending and down arrow for descending.

Log configuration
Logs can be remotely backed up to an FTP server, automatically deleted, and sent to a remote syslog server in
lieu of storing them locally.

Log settings
To configure log backups, automatic deletion, and remote storage, go to Logging > Log Config > Log
Settings.
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To configure log backups:
1. Under Log Backup, select Enable remote backup.
2. Set the Frequency to either Daily, Weekly, or Monthly.
3. Configure the time of day that the backup will occur in one of the following ways:
l

Enter a time in the Time field.

l

Select Now to enter the current time.

l

Select the clock icon and choose a time from the pop-up menu: Now, Midnight, 6 a.m., or Noon.

4. Select an FTP server from the FTP server dropdown menu. For information on configuring an FTP server,
see on page 50.
5. Select OK to save your settings.
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To configure automatic log deletion:
1. Under Log Auto-Deletion, select Enable log auto-deletion.
2. Use the Auto-delete logs older than field and dropdown menu to specify the number of either day(s),
week(s), or month(s) after which a log will be deleted.
3. Select OK to save your settings.
To configure logging to a FortiManager/FortiAnalyzer unit:
1. Under FortiManager/FortiAnalyzer, select Send logs to FortiManager/FortiAnalyzer.
2. Enter the Internet-facing IP address of the FortiManager or FortiAnalyzer unit.
To configure logging to a remote syslog server:
1. Under Remote Syslog, select Send logs to remote Syslog servers.
2. Move the syslog servers to which the logs will be sent from the Available syslog servers box to the
Chosen syslog servers box.
For information on adding syslog servers, see Syslog servers on page 204.
3. Select OK to save your settings.

Syslog servers
Syslog servers can be used to store remote logs. To view the syslog server list, go to Logging > Log Config
> Syslog Servers. A maximum of 20 syslog servers can be configured.
Create New

Add a new syslog server.

Delete

Delete the selected syslog server or servers.

Edit

Edit the selected syslog server.

Name

The syslog server name on FortiAuthenticator.

Server name/IP

The server name or IP address, and port number.

To add a syslog server:
1. From the syslog servers list, select Create New.
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2. Enter the following information:
Name

Enter a name for the syslog server on FortiAuthenticator.

Server name/IP

Enter the syslog server name or IP address.

Port

Enter the syslog server port number. The default port is 514.

Level

Select a log level to store on the remote server from the dropdown
menu. See Level on page 201.

Facility

Select a facility from the dropdown menu.

3. Select OK to add the syslog server.

Audit reports
User audit reports can be generated in order to comply with audit requirements. These reports include various
attributes for all users configured on the FortiAuthenticator.

Users audit
To generate and download user audit reports, go to Logging > Audit Reports > Users Audit and select
Download. A CSV format file will be saved to the computer.

The following attributes are included in the .csv file:
username

Username.

user type

Set to either local, ldap, or radius.

remote server name

Set to either ldap or radius, or empty for local.

first name

User's first name.

last name

User's last name.

email address

User's email address.

active

Set to either t for true/enabled or f for false/disabled.

role

Set to either user, sponsor, or administrator.

admin profile

One of the following:
l
Set to full if role is set to administrator with full permissions.
l
Set to their admin profile names separated by "/" for multiple profiles
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l

(e.g. logging/saml) if role is set to administrator without full
permissions.
Empty is role is set to either user or sponsor.

created

Date and time of account creation.

last used

Date and time of last login.

token type

Type of token-based authentication.

token info

Token information.
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Troubleshooting
This chapter provides suggestions to resolve common problems encountered while configuring and using your
FortiAuthenticator device, as well as information on viewing debug logs.
For more support, visit the Fortinet Support website.
Before starting, please ensure that your FortiAuthenticator device is plugged in to an appropriate, and
functional, power source.

Troubleshooting
The following table describes some of the basic issues that can occur while using your FortiAuthenticator
device, and suggestions on how to solve said issues.

Problem
All user log in attempts fail,
there is no response from the
FortiAuthenticator device, and
there are no entries in the
system log.

Suggestions
l

l

l
l

All user log in attempts fail
with the message RADIUS
ACCESS-REJECT, and
invalid password shown in
the logs.
Generally, user log in attempts
are successful, however an
individual user authentication
attempt fails with
invalid password shown in
the logs.
Generally, user log in attempts
are successful, however an
individual user authentication
attempt fails with
invalid token shown in the

l

l

l

l

l
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Check that the authentication client has been correctly configured.
See Adding FortiAuthenticator to your network on page 18.
If the authentication client is not configured, all requests are silently
dropped.
Verify that traffic is reaching the FortiAuthenticator device.
Check to see if there is an intervening firewall blocking 1812/UDP
RADIUS authentication traffic, if the routing correct, if the
authentication client is configured with the correct IP address for
FortiAuthenticator, etc.
Verify that the authentication client secrets are identical to those on
FortiAuthenticator.

Reset the user’s password and try again. See Editing a user on page
70.
Have the user privately show their password to the administrator to
check for unexpected characters (possibly due to keyboard
regionalization issues).

Verify that the user is not trying to use a previously used PIN. Tokens
are one time passwords, so you cannot log in twice with the same PIN.
Verify that the time and timezone on FortiAuthenticator are correct
and, preferably, synchronized using NTP. See Configuring the system
date, time, and time zone on page 29.
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Problem

Suggestions

logs.

l

l

l

Verify that the token is correctly synchronized with FortiAuthenticator,
and verify the drift by synchronizing the token. See FortiToken drift
adjustment on page 91.
Verify the user is using the token assigned to them (validate the serial
number against FortiAuthenticator configuration). See User
management on page 67.
If the user is using an email or SMS token, verify it is being used within
the valid timeout period. See Lockouts on page 62.

Debug logs
Extended debug logs can be accessed by using your web browser to browse to
https://<FortiAuthenticator-IP-Address>/debug.

Service

Select the service whose logs are shown from the dropdown menu:
l
l
l
l
l
l
l
l

FSSO
FSSO (Filtered)
GUI
HA
LB HA Sync
LDAP
Push Authentication Service
RADIUS Accounting
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RADIUS Authentication
SNMP
l
Syslog SSO
l
Web Server
l
CLI Packet Capture (tcpdumpfile)
Note: The CLI Packet Capture (tcpdumpfile) service is only available when
the tcpdumpfile command has been entered using SSH or Telnet, or through
the CLI Console if a FortiAuthenticator is installed on a FortiHypervisor. For
more information, see CLI commands on page 21.
l
l

Max. log files size

To have access to a longer history of debug log files, a dropdown menu has been
added for changing the maximum log file size, up to a maximum of 50 MB. Note
that this is available for only certain debug log types.

Enter debug mode

If RADIUS Authentication is selected as the service, the option to enter the
debug mode is available. See RADIUS debugging on page 209.

Search

Enter a search term in the search field, then select Search to search the debug
logs.

Page navigation

Use the First Page, Previous Page, Next Page, and Last Page icons to
navigated through the logs.

Show

Select the number of lines to show per page from the dropdown menu. The
options are: 100 (default), 250, and 500.

RADIUS debugging
RADIUS authentication debugging mode can be accessed to debug RADIUS authentication issues.
From the Service dropdown menu, select RADIUS Authentication and select Enter debug mode from the
toolbar.
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Enter the username and password and select OK to test the RADIUS authentication and view the
authentication response and returned attributes.
Select Exit debug mode to deactivate the debugging mode.

TCP stack hardening
Configure the number of TCP SYNACK retries for the Linux kernel by accessing:

https://<FortiAuthenticator-IP-Address>/debug/tcp_tuning

From here, enter the number of retries between 1 - 255 (default is 3).
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LDAP filter syntax
This chapter outlines some basic filter syntax that is used to select users and groups in LDAP User Import,
Dynamic LDAP Groups, and Remote User Sync Rules.
Filters are constructed using logical operators:
=

Equal to

~=

Approximately equal to

<=

Lexicographically less than or equal to

>=

Lexicographically greater than or equal to

&

AND

|

OR

!

NOT

Filters can consist of multiple elements, such as (&(filter1)(filter2)).
More information about the query syntax of AD filters, see the following web sites:
l
l

http://msdn.microsoft.com/en-us/library/windows/desktop/aa746475(v=vs.85).aspx
http://social.technet.microsoft.com/wiki/contents/articles/5392.active-directory-ldap-syntaxfilters.aspx

Examples
The following examples are for a Windows 2008 AD server with the domain corp.example.com, default
domain administrators and users, and an additional group called FW_Admins:
l
l

Users (CN) = atano, pjfry, tleela, tbother
FW_Admins (Security Group) = atano, tbother

An unfiltered browse will return all results from the query, including system and computer accounts. To prevent
this and only return user accounts, apply the filter (objectClass=person) or
(objectCategory=user).
Even if unfiltered, only user accounts will be imported, so this is only required to clean up the results that are
displayed in the GUI.
To filter and return only members of the security group: (&(objectCategory=user)
(memberOf=CN=FW_Admin,DC=corp,DC=example,DC=com)).
It is not possible to use the filter to limit results to CNs or OUs. To achieve this, you must change the Base DN
in the LDAP Server configuration. For example, to return only users from the CompanyA OU, create an LDAP
Server entry with the following Base DN: OU=CompanyA,DC=corp,DC=example,DC=com.
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Caveats
Users do not always have a memberOf property for their primary group, this means that querying system
groups, such as Domain Users, may return zero results. This can be confusing as these are often the first
queries to be tried, and can lead the user to think the filter syntax is incorrect.
For example: (memberOf=CN=Domain Users,CN=Domain
Admins,DC=corp,DC=example,DC=com) will return no valid results.
To return all users in such a group, the filter can be made against the ID value of the Primary Group. So, for
Domain Users (Group ID = 513), the filter would be: (primaryGroupId=513).
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