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Overview

Overview

With the integration of FortiEDR and Active Directory, when a security policy assigned to a FortiEDR-protected endpoint
triggers the “Reset user password” and “Disable user account” Automated Incident Response (AIR) playbooks,

FortiEDR sends an API update to the Active Directory server and automatically resets the user password or disables the
user account to prevent further misuse of the compromised account.

A\,

‘Q' After the security incident is resolved and the affected endpoint becomes compliant, the
- administrator must manually re-enable the account.
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Prerequisites

Prerequisites

Before you start configuring the integration with Active Directory, verify the following:

» Your FortiEDR deployment includes a Jumpbox that has connectivity to the Active Directory server.

» Referto Installing the FortiEDR Core for details about how to install a FortiEDR Core and configure it as a
Jumpbox.

« Refer to Cores for more information about configuring a Jumpbox.

« The FortiEDR Central Manager has connectivity to the Fortinet Cloud Services (FCS). To verify this, make sure that
FCS is in running state (Green) in the System Components chart in the Dashboard of the FortiEDR management
console.
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Configuring Active Directory

Configuring Active Directory

To integrate FortiEDR with Active Directory, you must first create an Active Directory admin user with the correct
organization, group, and permissions to reset the user password or disable the user account. Fortinet recommends that
you create a dedicated Active Directory admin user for FortiEDR integration.

To create an Active Directory admin user for FortiEDR integration:

1. Click Start > Administrative Tools > Active Directory Users and Computers.
2. Right-click the domain and select New > Organization Unit.

: Active Directory Users and Computers [de.ad.labdog] Marme
Saved Queries I Usess
v eiegite Cortrol 7] TPM Devices
Findl.. i”“’" .
— - rogram [ata
1 Change v
kit | NTDS Quotas
Change Domain Controller.. | Managed Service Accounts
: Raise domain functional level... 7 LostaAndFound
Operations Masters. 2] LabDag OU
Mews b ] Computer
a All Tasks * Contact
View 3 Group Iz
InetCrgPerson
Refresh ) misD5-5hadowPrincipalContainer
. Export List.. msimaging-P5SPs
Properties MSMO Queue Alias
Help Organizational Unit
Printer
Lhser

Shared Foldes

3. Specify the name for the organization unit and save it.
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Configuring Active Directory

4. Right-click the newly created organization unit and select New > Group.

= Active Directory Users and Computers [de.ad.labdog) Marne
| Sawed Queries .
fedradm
v § adabdog & -
| Builtin
| Computers

2| Domain Controllers
» ] FosesgniSecuntyPrincipals
| Keys
21 LabDeg OU
] LestandFound
7| Managed Seraice Accaunts
| Program Data

7 Syshern

7 Users

7 NTDS Quotas

] TP#A Devices

_1-] Hq..u:a._ P
Delegate Contral...
Move..
Find..
Mew * Computer
Al Tasks » Contact
View » Group

InetOrgPersan

Lo s D5-ShadowPrincipalC ontainer
Lo malmeging-P5Ps
R MSMQ Queue Alias
SRS Organizational Unit
Export List... Prinkes
Properties LUser
Help Shared Falder

5. Configure the basic settings for the group (see example below).
Mew Object - Group X

% Createin:  ad.labdog/Integration Accounts
Group name:
|FE[:|ud1'mI

Group name (pre-Windows 2000):
|FEBR.ﬁdr'ns

Group scope Group type
(") Domain local (®) Security
(#) Global () Distribution
() Universal
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Configuring Active Directory

6. Right-click the newly created organization unit and select New > User.

o Actwn Dienctory Usees aned Computers |de.ad. labdog) r—
Saved D 3 Lisers
v i adlabdog —— "
e ] System
7| Camputers s -
5| Domain Controllers - "':ggm -
R D —— I 1M|mgbclf:wiu.ﬁr.cm
1 Keys
5] LabDeg QW — LasthrdFaund
1 LesthndFound &l Lablieg OU
1 Maraged Service Accounts A Keys
7 Program Dats .i.‘l Integration Accaunts
| Sasbern ”Irlfruhunure
2 Users ] ForeignSecurityPrincpsls
1 NTDS Quokes 'a] Doman Contrallizs
1 TPM Devices 1] Computess
&l Integratine Aereanke 8] Bt
Diebegate Contral..
Meve...
Fand...
Mew ¥ Compuber
Al Tazks ¥ Cantact
Cut Group
Db IretOrgPerson
B mall5-Shadowd nrcipal Conk sirer
Rileush msimaging-FiFs
MM Cueue Aliss
Peperties Orgerizational Uik
Help Pintee
User
Shared Folder

7. Configure the basic settings for the user (see example below) and click Next.

Mew Object - User

& Create in:  ad labdog/Integration Accourts

X

First name: |FEI:IR ] rikiala: |

T |Fm:ixl-|m |
User logon name

fedradimin | @adlabdag ~|
User logon name {pre-Windows 2000):

[lﬂxhg‘\. ”fadadmnl |

< Back

Cancel

8. Define the password for the user, disable the User must change password at next logon option, click Next and then

Finish.
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Configuring Active Directory

Mew Object - User x

& Create n:  ad Jabdog/Integration Accourts

Password: SRR ERERERRERRRERN |

Corfirm passwond: I"u-"n"-"n"l |

| ] User must change password at net logan |
[] User cannot change passwaord
|_] Password never expires
[J Account is disabled

< Back |Hm:-| Cancel

9. Double-click the user you just created to open the Properties window.
10. Inthe Member Of tab, click Add.

General  Address  Account Profile Telephones  Organizabon
ﬁum{:muul Member Of IPaum'qu:lcmn Didin  Object

Member of .
Hame Active Directory Domain Services Folder
Damain Usen ad I:]hgfum

| Add. =
Primary group: Domain Lisers

There is i need to change Primary group unless
SEFImE SRR o) have Macintosh clients or POSIX-complart

applications,

OK | Carcel Mooty | He

11. Type the name of the group you just created, click Check Names to verify and then click OK.
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Configuring Active Directory

Select Groups o
Salect this objsct type:
Groups o Buikin securty principals

From this location
ad lsbdog

names o select fenamples)

12. Select the the assigned group and click Set Primary Group.

fedradmin Properties 1 *
Security Enwvionment Sesmons Remote control
Remate Deskiop Services Profie COMe Atzribute Edibor

Ganeral Address  Account  Profle  Telephonea  Organization
Published Certficates Member Of  Pasaword Repication Dialin ~ Object

MName Active Directary Domain Services Folder

A |ADC o0 Lsers

ad labdog/ntegration Accounts

Primany - Domain Users
There iz no meed 1o change Primary group unless
| Set Primary Group |rmmuummum:amsmwn
applcations

[ ok || cancel || Aol Help

13. Select any other groups assigned to the user and click Remove.
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Configuring Active Directory

fedradmin Properties [}
Security [Envimnment Seamans Remote control

Ramate Desktop Sarvices Profis COMs+ Agtribute Edior

General Address  Account  Profile Telephones  Orparzation
Published Cetficates Member Of  Pagaword Repication Diakin  Object

Member of:

Mame

Active Directory Domasin Services Folder
Domain Lisers ad |abdog/ Lsers

FEDR Admins: ad labdog./ntefira

Primary group: FEDR Admins
Theere g no need to change Primary group unless

Set Prmary GRUP | o) have Macintosh clients er POSIX-camplant
applic sions

[Cox ]| cancet || oy Help

14. Click OKto save the changes.
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Configuring Active Directory

fedradmin Properties [} x
Security [Environment Seasans Remote control

Remote Deskiop Services Profie COM- Atiribute Edibor
General Address Account  Profile Telephones  Orparuzation
Published Cartficates  Member Of  Pagaword Repication  Dialin  Object

Member of:

Hame Active Directory Domain Services Folder
FEDR Admins & |abdog/Integration Accounts

Remove

Primary group: FEDR Admins

. There iz no need 1o change Primary group unless
Se Pmay BB | e have Macintosh clients er POSIX-campliant

applications

ok ][ e [ e |

15. Click Save.

16. Configure the target organizational unit or container so that FortiEDR has delegated permissions to reset
passwords and disable accounts:

FortiEDR 7.0.0 Active Directory Integration
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Configuring Active Directory

a. Right-click the organization unit or container and select Delegate Control.

] Active Directory Users and Computers [de.adlabdog)
v | Saved Queries
v 3 ad.labdog
| Builtin
| Computers
2| Demain Controllers
» | ForeignSecurityPrineipals
J Keys
2] Labl =
_' Lﬂ“ mmn
- Mar Move...
» [ Prog Find...
v [ Syst
1 Use New *
s 5] NTC All Tagks >
= TPM .
cn View »
2| Inte
Cut
Delete
Rename
Refresh
Export List...
Properties
Help

b. Click Next and then click Add.
c. Enter the name of the group that you created earlier, click Check Names, and then OK.

Select Users, Computers, or Groups A
Select this object type:

|Lhem.&u.m.w&ihmamm | mgectTypu
From this location:

|ad Jabdog || Locations...
Erter the object names to select (sxamples):

FEDR M-rmll :'l Check Names |

Advanced... | _ Cancel

d. Verify the selected group and click Next.

FortiEDR 7.0.0 Active Directory Integration
Fortinet Inc.



Configuring Active Directory

2, FEDR Admins (LABDOG\FEDR Admins)

Delegation of Control Wizard *
Users or Groups
Select one or more users or groups to whom you want to delegate control.
Selected users and groups:

<Back | Net> | | Cancel Hel

e. Select Create a custom task to delegate and click Next.

[[] Reset user passwords and force password change at next logon
[[] Read all user information

[] Create. delete and manage groups

[] Moddfy the membership of a group

[] Manage Group Policy inks

[[] Generate Resultant Set of Policy (Planning) v
<

=3 (@) Create a custom task to delegate

Delegation of Control Wizard 4
Tasks to Delegate
You can select commaon tasks or customize your own.
i) Delegate the following common tasks:
[] Create, delete, and manage user accounts ~

L 4

cBack [ _Net> | | Cancel || Heb

f. Select Only the following objects in the folder, select User objects, and then click Next.

FortiEDR 7.0.0 Active Directory Integration
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Configuring Active Directory

Delegation of Control Wizard b4
Active Directory Object Type
indicate the scope of the task you want to delegale.

Delegate control of
() Thig folder. existing objects in this folder, and creation of new objects in this folder

|® Oy the following objects in the folder: ==

[[] Ste Settings objects -
] Sies Container obiects
[[] Submet ohiects

[] Subnets Container objects
[] Trusted Domain objects
User obyects p

[(]Create selected objects in this folder
[ Delete selected objects in this folder

T T

g. Select Property-specific under Show these permissions, select the following permissions, and click Next:

¢ Reset Password

* Read and write account restrictions
* Read userAccountControl

o Write userAccountControl

Delegation of Control Wizard * Delegation of Control Wizard
Permissions Permissions
Select the pemmissons you want to delegate. Select the pemissions you wart Lo delegate,
Show these pemissions Show these pemmizsiona:
General [ General
] Propesty-apeciic ] Propesty-spectic
Creation,deletion of spechie: child abjects [ Creation /deletion of spechic child obiects
Fains
- [] Read unorliserPasaward
_ || B4 Read userdcoountCantrel

= Wirke userAccount Control
Fead useCerd

| Wik wserCet

oo [T ] | oot | [ e T

h. Verify the permissions list and click Finish.
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Delegation of Control Wizard x

Completing the Delegation of
Control Wizard

' L Tou have successfuly completed the Delegation of Contral

FEDR Adminz (LABDOG \FEDR Admina) ~

They hawve the folowng pemissons:

Rleset password
Read and wiite account restictions

Read userAocourdControl
Write userAocountControl

[For the folowing object types
Liser W

To close this wizard. clek Finish.

¥
< Back I [Fnish I Cancel Help

NP This permission delegation applies to all child objects or users within the target group. To
‘9' allow FortiEDR to update accounts with elevated privileges, such as Domain Admin, you
- must manually apply the delegated permissions to these accounts as inheritance is

disabled on these accounts by default. See this Microsoft article for more details.

FortiEDR 7.0.0 Active Directory Integration
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Configuring FortiEDR

Configuring FortiEDR

To integrate FortiEDR with Active Directory, you must configure a User Access connector and playbook policies for
Active Directory in FortiEDR. Automatic incident response actions can then include resetting the user password or
disabling the user account on Active Directory upon the detection of a FortiEDR security event.

To configure a User Access connector for Active Directory in FortiEDR:

1. Inthe FortiEDR management console, select Administration > Integrations.

2. Click the Add Connector button and select User Access from the dropdown list.
The following displays:

CONNECTORS

(® Add Conne... ¥
)
¥ a;y User Access @ Enabled
Jumpbox
Details Actions
Reset user password paseon[ ]
Authentication

+Add action

Bind DN | Password |

3. Fillin the following fields:

Field Description

Jumpbox Select the FortiEDR Jumpbox that will communicate with the Active Directory
server.

Name Specify a name of your choice to be used to identify the connector for Active
Directory.

Type Select Active Directory.

Host Specify the IP or DNS address of the Active Directory server.

Port Specify the port that is used for communication with the Active Directory

server. Typically port 389 is used for LDAP authentication.

Authentication Specify the Bind DN and password of the Active Directory admin user you
created when Configuring Active Directory on page 7.

To locate Bind DN information in Active Directory:

1. Click View > Advanced Features.

2. Double-click the admin user you created for the FortiEDR integration.

3. Inthe Attribute Editortab, select distinguishedName and click View.
The Value field include the full Bind DN information that you can copy.

FortiEDR 7.0.0 Active Directory Integration
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Configuring FortiEDR

Field Description

4. Inthe Actions area on the right, define the action to be taken by this connector:

« Touse an action provided out-of-the-box with FortiEDR (for example, Disable user account on Active
Directory), specify the baseDN field for Disable user account or Reset user password, or both according to your
needs. The baseDN is the Bind DN without the user name. For example, if the Bind DN is
CN=fedradmin,OU=Integration Accounts,DC=ad,DC=labdog, the baseDN is OU=Integration
Accounts, DC=ad, DC=labdog.

» To use a custom integration action:
i. Click the + Add Action button. The following popup window displays:

ADD CUSTOM ACTION

Action -

AD Logout user

Re-profile a device

( cancel )

ii. Inthe Action dropdown menu, select one of the previously defined actions (which were defined in
FortiEDR as described in Custom integration), or define a new action that can be triggered according to
the definitions in the Playbook:

FortiEDR 7.0.0 Active Directory Integration
Fortinet Inc.


https://docs.fortinet.com/document/fortiedr/7.0.0/administration-guide/139939/custom-integration

Configuring FortiEDR

i. Click the Create New Action button. The following displays:

Action Manager

Name New action
Mew action Description
Add Policy Block
Add MAC Quarantine
Action Scripts T Upload

Dizable interface

Assign NSX tag

Please upload a script

Slack Notification

Teams Motification

( cancel )

AWS Lambda Logout User

| Close

ii. Fill out the fields of this window as follows in order to define a new action to be triggered in response to

an incident.
In order to trigger this action, a Playbook policy must be defined that triggers
NP this action to execute the script when a security event is triggered. The
‘Q' definition of this new action here automatically adds this action as an optionin a
- Playbook policy. However, this action is not selected by default in the Playbook

policy. Therefore, you must go to the Playbook policy and select it in order for it
to be triggered when a security event is triggered.

Field Definition

Name Enter any name for this action.

Description Enter a description of this action.

FortiEDR 7.0.0 Active Directory Integration
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Field Definition

Upload Upload a Python script that calls an API from the third-party system
in order to perform the relevant action. Python 2.7 or later is
supported. The Python script must be created according to the

coding conventions that can be displayed by clicking the icon
next to the Action Scripts field. The following displays providing an
explanation of the coding conventions and provides various links
that you can click to see more detail and/or to download sample files.

Creating A Custom Incident Response Action

The following describes how to create and upload your own Python script to be assigned to an
incident response action. Playbook policies that are configured to use this action will automatically
execute this script when a security event is triggered.

Code Conventions

« AFortiEDR JumpBox on which one or more scripls are executed is deployed with various
standard Python packages. Click here to see a list of the packages that are deployed with this
type of FortiEDR JumpBox

« Atthe moment, only Python 2 is supported.

- Parameters

= Integration scripts can use properties that are part of a Connector’s configuration, such
as APl keys or information that is part of the triggering event (such as the process
name)

= These properties are stored in the config.json file and can be used as script parameters.

o Click here to see a sample config json file and a sample action script:

& custom_scriptpy  J configjson

Troubleshooting

Script execution (either in test mode or as part of a realtime incident response) is defined as

iii. Click Save. The new action is then listed in the Actions area.
5. Click the Test button to test the connectivity. If the test fails, a reason is given.
You can troubleshoot connection failures in the following ways:
 Verifying the credentials you entered in step 3.
« Verify the settings when Configuring Active Directory on page 7.

« Monitor the Active Directory logs under Windows Logs > Security in the Windows Event Viewer. Search or filter
to locate logs related to the test. For example, Event 4624 shows a successful login and Event ID 4625 shows a

FortiEDR 7.0.0 Active Directory Integration
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FortiEDR

failed login.

Event 4624, Microsolt Windows security auditing.

General Details

Restrcted Admin Mode:

Virtual Account: Mo

Elevated Token: Vs

Impersonation Level: Impersonation

FNMLGQDI’L‘

Security ID: LABDOG fedradmin

Account Name: fedradmn

Accgunt Domain: LABDOG

Logon ILE U TELSEAM

Linked Logan I0: L]

Network Account Mame: -

Netwerk Aceownt Damaire -

Legon GUID: 00000000 0000-0000-DOC0-D00000000NT]
Log Mame: Security
Source: Micreseft Windows security  Logged: TR 2023 15:3543
Event ID: 4524 Task Categony: Logon
Level: Informaticn Keywords: Audit Success
User WA Cornputer: deadlabdog
Oplode Infe

klore Information:

Event Log Online Help

6. Click Save to save the connector configuration.

Event 4625, Micresoft Windows security auditing.

Genesal  Details

Account Mame: DCs

Account Domain: LABDDG

Logon IOk e 3ET7
Logon Type: 3
Account For Whach Logon Failed:

Ser.&rl\l [[+3 MULL 510

Account Name: Tedradman

Account Domain: LABDDG

Failure Infermation:

Failure Resson: Unkncwn user name or bad password.

Status Ox CODD0060

Sub Status: x CODDODEA
Log Marme: Security
Source: Micresoft Windows security  Logged: 1870472003 15:3%15
Event ID: dh2h Task Category: Logon
Lewvek Informaticn Keywards: Audit Failure
Usar: WA Computer: de.ad.labdog
OpCode Infe

More Information:

Exent Log Online Help

To configure playbook policies to automatically reset the user password or disable the user account
upon security event triggering in FortiEDR:

1. Navigate to the SECURITY SETTINGS > Playbooks page.
2. Open the Playbook policy that is applied on devices for which you want the automatic incident response to apply.

3. Place a checkmark in the relevant Classification column next to the Disable user row under the INVESTIGATION
section or the Reset user password row under the REMEDIATION section.
FortiEDR is now configured to automatically reset the user password or disable the user account upon security
event triggering in FortiEDR.

INVESTIGATION

Isolate device with Collector

Move device to the High Security Group

Disable user

FortiEDR 7.0.0 Active Directory Integration
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Verifying the integration

If the integration is successful, in FortiEDR, the Reset user password and/or Disable user account playbook will be
triggered based on the classification trigger defined within the playbook. In the Event Viewer, you should first see an
event classified by FortinetCloudServices, similar to the following:

o

*n
LT

[ 22451725 W labdog-win11

DEVICE PROCESS

dynamiccodetestsbhaxe (1 avent )

LABDOGInmoore  LABDOG\nmoore  Unsigned

dynamiccadeteststd exe

CLASSIFICATION & DESTIMATIONS

¥ Maliclous

# Suspicious

74.125.235.20

LAST UPDATED

14-Apr-Z023, 13:13:44  1B-Apr-2023, 19:45:19

14-Apr-2023, 13:15:44  18-ADr-2023, 094510 [~ ]

CaAUsersinmoorei DeskiopiDema-Non_Malicious_ExfilrationtDemo-Non_Malicious_Exfitration'dyn... 1

% Malicious Frnmner

Threst name: Fileless. Memory.Generic
Threat family: Fileless.Mamory
Threat type: Meless

Automated analysis steps completad by Fortinet Details
Histary

= ¥ Maliclous, by FortinetCloudServices, on 18-Apr-2023, 09:45:28

= Arequest o disable user LABDOG\nmaore was sent to Active Directory
LabDiog DC ance

o Arequest io resel the password of user LABDOGInmOoore was sent io
Active Directory LabDog DG once

Once the playbook is triggered in FortiEDR, an API update will be sent to the Active Directory server to disable the user
account and/or mark it as requiring a password reset as per configuration. This activity is shown under Windows Logs >
Security in the Windows Event Viewer. A successful account disable will fall under Event 4725. A successful password

reset will fall under Event 4738. See example below:

Event 4725, Microsoft Windows security auditing.
General Details
A user account was disabled.
Subject:
Security 1D: LABDOG fedradmin
Aceount Name: fedradmin
Account Domain: LABDOG
Legon ID: (e 1853681C
Target Account:
Security 10z LAED G \nmoore
Aeeount Narme: nmoore
Account Domain: LABDOG
Log Marme Security
Source: Micrasoft Windows security  Logged: 18/0472023 084535
Event ID: 4725 Task Category:  User Account Management
Levek Information Keywords: Audit Success
User: /A Computer dec.ad.labdog
OpCode: Info

Event 4733 Microsoft Windows security auditing.

General  Details

A user account was changed.

Subject:
Security Dy
Account Name:
Accourt Domain:
Logon ID:

Target Account:
Security Dz
Account Name:
Account Domasin:

LABDOG fedradmin
fedradmin

LABDOG

D 19008998

LABDOG nmoane
nmocre
LABDOG

(Changed Attributes:
SAM Account Mame:
Display Marme:
User Principal Mame:
Home Directony:
Home Drive:
Script Path:
Profile Path:
ions:

| Password Last Set:

Fccourt Expwer
Primary Group ID: -

During subsequent logins, the user will see an error that the account has been disabled or be prompted to change the

password:

FortiEDR 7.0.0 Active Directory Integration
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Your account has been disabled. Please see your system administrator.

The user's password must be changed before signing in.
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