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Introduction

The FortiVoice phone system enables you to completely control your organization's telephone communications. Easy to
use and reliable, the FortiVoice phone system delivers everything you need to handle calls professionally, control
communication costs, and stay connected everywhere.

The FortiVoice phone system includes all the fundamentals of enterprise-class voice communications, with no additional
cards to install. Auto attendants, voice messaging, ring groups, conferencing and much more are built-in. In addition, the
FortiVoice user portal lets your staff view their call logs, configure and manage their own messaging, and access other
features, such as the operator console and the agent console.

This document describes how to configure and use the FortiVoice phone system.

This topic includes:

l Product offerings on page 11
l Registering your Fortinet product on page 11
l Training on page 12
l Documentation on page 12
l Scope on page 12
l Conventions on page 13

Product offerings

The FortiVoice phone system is available as a hardware appliance and virtual machine (VM).

Procedures in this guide are applicable to both product offerings unless otherwise specified.

For more details about the supported platforms for this release, see the FortiVoice Phone System Release Notes.

Registering your Fortinet product

Many Fortinet customer services, such as firmware updates and technical support, require
product registration.

If you have not already registered your product, use this procedure to complete the registration:

1. Visit the Fortinet Support website.
2. Log in to your existing account or register for an account.
3. Click Register Now.
4. Follow the prompts to complete the registration.

For more information, see the Registering a FortiVoice product section in the FortiVoice Cookbook.
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Introduction

Customer service and technical support

Fortinet Support provides services designed to make sure that you can install your Fortinet products quickly, configure
them easily, and operate them reliably in your network.

To learn about the technical support services that Fortinet provides, visit the Fortinet Support website.

You can dramatically improve the time that it takes to resolve your technical support ticket by providing your
configuration file, a network diagram, and other specific information.

Training

Fortinet Training Services provides classes that orient you quickly to your new equipment, and certifications to verify
your knowledge level. Fortinet provides a variety of training programs to serve the needs of our customers and partners
world-wide.

To learn about the training services that Fortinet provides, visit the Fortinet Training Services website or send an email to
training@fortinet.com.

Documentation

The Fortinet Documents Library website provides the most up-to-date versions of Fortinet publications for Fortinet
products.

Fortinet Knowledge Base

The Fortinet Knowledge Base website provides additional Fortinet technical documentation, such as troubleshooting
and how-to-articles, examples, FAQs, technical notes, a glossary, and more.

Feedback about Fortinet technical documentation

To provide feedback about this document, you can send an email to techdoc@fortinet.com.

Scope

This document describes how to connect to the FortiVoice system using its GUI and CLI.

The majority of procedures in this document use the GUI to configure the FortiVoice system. A few procedures use the
CLI.
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Introduction

Conventions

Fortinet technical documentation uses the following conventions:

l IP addresses on page 13
l Cautions and notes on page 13
l Typographical conventions on page 13

IP addresses

To avoid the publication of public IP addresses that belong to Fortinet or any other organization, the IP addresses used
in Fortinet technical documentation are fictional and follow the documentation guidelines specific to Fortinet. The
addresses used are from the private IP address ranges defined in RFC 1918: Address Allocation for Private Internets.

Cautions and notes

Fortinet technical documentation uses the following guidance and styles for cautions and notes.

Warns you about commands or procedures that could have unexpected or undesirable results
including loss of data or damage to equipment.

Highlights useful additional information, often tailored to your workplace activity.

Typographical conventions

The following table lists the typographical conventions used in this document:

Style Description Example

Italic font Used for GUI navigation. FromMinimum log level, select Notification.
Go to Phone System > Setting > Location.

Courier font and
indentation

Used for CLI input. config system dns
set primary <address_ipv4>

end

Courier font Used for CLI output. FGT-602803030703 # get system Setting

comments : (null)

opmode : nat
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Introduction

Style Description Example

Courier font Used for file content. <HTML><HEAD><TITLE>Firewall
Authentication</TITLE></HEAD>
<BODY><H4>You must authenticate to use
this service.</H4>

Courier font Used for text that you enter. Enter a name for the remote VPN peer or client, such as
Central_Office_1.

Blue font Used for hyperlinks to websites
and publications.

Visit the Fortinet Support website.
For details, see the FortiVoice User Portal Guide.

<text_in_angle_
brackets>

Describes a variable. Replace
the <text_in_angle_brackets>
with the required information for
your setup.
Do not type the angle brackets.

FortiVoice user portal link: https://<IP_address_or_
FQDN>/voice
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Connecting to the FortiVoice system

After physically installing the FortiVoice system, you need to connect to its management tools to configure, maintain, and
administer the system. You also need to inform your phone users on how to access the user portal and use the
FortiVoice features.

This topic includes:

l Connecting to the GUI or CLI on page 15
l Setting up the system on page 19
l Testing the setup on page 19
l Configuring setups for phone users on page 20

Connecting to the GUI or CLI

There are two methods to connect to the FortiVoice system:

l Use the GUI from within a web browser.
l Use the CLI from a Secure Shell (SSH) or Telnet terminal.

Access to the CLI and/or GUI is not yet configured if:

l You are connecting for the first time.
l You have just reset the configuration to its default state.

In these cases, you must access either interface using the default settings.

If the above conditions do not apply, access the GUI using the IP address, administrative
access protocol, administrator account and password already configured, instead of the
default settings.

Until the FortiVoice system is configured with an IP address and connected to your network,
you may prefer to connect the FortiVoice system directly to your management computer, or
through a switch, in a peer network that is isolated from your overall network. However,
isolation is not required.

This topic includes:

l Connecting to the GUI on page 15
l Connecting to the CLI on page 17

Connecting to the GUI

To connect to the GUI of the FortiVoice phone system using its default settings, you must have:
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Connecting to the FortiVoice system

l A computer with an RJ-45 Ethernet network port
l One of the recommended web browsers:

l Google Chrome version 110
l Microsoft Edge version 110
l Mozilla Firefox Standard Release version 110
l Apple Safari version 16

l An Ethernet cable

Default settings for connecting to the GUI

Network interface port1

URL https://192.168.1.99/admin

Name admin

Password (none)

To connect to the GUI

1. On your management computer, configure the Ethernet port with the static IP address 192.168.1.2 with a netmask
of 255.255.255.0.

2. Using the Ethernet cable, connect your computer’s Ethernet port to the FortiVoice system’s port1.
3. Start your browser and go to https://192.168.1.99/admin.

To support HTTPS authentication, the FortiVoice system ships with a self-signed security certificate, which it
presents to clients whenever they initiate an HTTPS connection to the FortiVoice system. When you connect,
depending on your web browser and prior access of the FortiVoice system, your browser might display two security
warnings related to this certificate:
l The certificate is not automatically trusted because it is self-signed, rather than being signed by a valid
certificate authority (CA). Self-signed certificates cannot be verified with a proper CA, and therefore might be
fraudulent. You must manually indicate whether or not to trust the certificate.

l The certificate might belong to another website. The common name (CN) field in the certificate, which usually
contains the host name of the website, does not exactly match the URL you requested. This could indicate
server identity theft, but could also simply indicate that the certificate contains a domain name while you have
entered an IP address. You must manually indicate whether this mismatch is normal or not.

Both warnings are normal for the default certificate.
4. Verify and accept the certificate, either permanently (the web browser will not display the self-signing warning

again) or temporarily. You cannot log in until you accept the certificate.
For details on accepting the certificate, see the documentation for your web browser.

5. In Name, enter admin.
6. Leave Password empty. In its default state, there is no password for this account.
7. Click Login.

With a successful login, you can see the FortiVoice GUI.
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Connecting to the FortiVoice system

To set the password

1. In the right corner of the FortiVoice GUI, click Admin.
2. Click Change Password.

Enter a FortiVoice administrator password that is six characters or more. For better
security, enter a longer password with a complex combination of characters and numbers,
and change the password regularly. Failure to provide a strong password could
compromise the security of your FortiVoice phone system.

3. Enter a password in New password and Confirm password.

The password can contain any character except spaces.

4. ClickOK.

Connecting to the CLI

Using its default settings, you can access the CLI from your management computer in two ways:

l A local serial console connection
l An SSH connection, either local or through the network

To connect to the CLI using a local serial console connection, you must have:

l A computer with a serial communications (COM) port
l The RJ-45-to-DB-9 serial or null modem cable included in your FortiVoice package
l Terminal emulation software, such as PuTTY

To connect to the CLI using an SSH connection, you must have:

l A computer with an RJ-45 Ethernet port
l A crossover Ethernet cable
l An SSH client, such as PuTTY

Default settings for connecting to the CLI by SSH

Network Interface port1

IP Address 192.168.1.99

SSH Port Number 22

Name admin

Password (none)

If you are not connecting for the first time, nor have you just reset the configuration to its
default state or restored the firmware, administrative access settings may have already been
configured. In this case, access the CLI using the IP address, administrative access protocol,
administrator account and password already configured, instead of the default settings .
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Connecting to the FortiVoice system

The following procedure uses PuTTY. Steps may vary with other terminal emulators.

To connect to the CLI using a local serial console connection

1. Using the RJ-45-to-DB-9 or null modem cable, connect your computer’s serial communications (COM) port to the
FortiVoice system’s console port.

2. Verify that the FortiVoice system is powered on.
3. On your management computer, start PuTTY.
4. In Category, go to Connection > SSH > Serial.
5. In Serial line to connect to, enter the communications (COM) port where you connected the FortiVoice system.
6. In the Configure the serial line section, use the following settings:
7. In the Configure the serial line section, use the following settings:

Speed (baud) 9600

Data bits 8

Parity None

Stop bits 1

Flow control None

8. Click Session.
9. In Connection type, click Serial.
10. ClickOpen.
11. Press Enter.

The terminal emulator connects to the CLI and the CLI displays a login prompt.
12. Type admin and press Enter twice. (In its default state, there is no password for this account.)

The CLI displays a prompt, such as:
FortiVoice #
You can now enter commands.

The following procedure uses PuTTY. Steps may vary with other SSH clients.

To connect to the CLI using an SSH connection

1. On your management computer, configure the Ethernet port with the static IP address 192.168.1.2 with a netmask
of 255.255.255.0.

2. Using the Ethernet cable, connect your computer’s Ethernet port to the FortiVoice system’s port1.
3. Verify that the FortiVoice system is powered on.
4. On your management computer, start your SSH client.
5. In Host Name (or IP Address), type 192.168.1.99.
6. In Port, type 22.
7. From Connection type, select SSH.
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Connecting to the FortiVoice system

8. SelectOpen.
The SSH client connects to the FortiVoice system.
The SSH client may display a warning if this is the first time you are connecting to the FortiVoice system and its SSH
key is not yet recognized by your SSH client, or if you have previously connected to the FortiVoice system but it
used a different IP address or SSH key. If your management computer is directly connected to the FortiVoice
system with no network hosts between them, this is normal.

9. Click Yes to verify the fingerprint and accept the FortiVoice system’s SSH key. You cannot log in until you accept the
key.
The CLI displays a login prompt.

10. Type admin and press Enter twice. (In its default state, there is no password for this account.)
The CLI displays the following text:
Type ? for a list of commands.

You can now enter commands.

Setting up the system

You can follow this guide to set up the FortiVoice system. After the setup is complete, you can make phone calls through
the FortiVoice system.

Testing the setup

After completing the configuration, you can connect a SIP phone to your VoIP network and make an internal, external, or
office peer test call.

If the SIP phone and the FortiVoice system (PBX) are on different subnets, proper routing
should be set to make them reachable
If you make a office peer test call, make sure that your FortiVoice system and the peer office
PBX are mutually registered. For more information, see Configuring office peers on page 213.

l Depending on the phone you use, the procedure to connect the phone may vary. Refer to the phone user manuals
for instructions.

l Generally, you need to configure the following on the phone after powering it up and connecting it to the network:
l Enter the IP address of the phone if it is not DHCP-enabled.
l Enter the SIP server IP address and port number (5060 by default) of the FortiVoice system.
l Enter the extension number and SIP password you have configured and make sure the extension is enabled.
If you have not imported or added any extensions, do it first. For more information, see Configuring IP extensions on
page 162. The extension number on the FortiVoice system and your phone should match.
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Connecting to the FortiVoice system

Configuring setups for phone users

The FortiVoice system provides a user portal where phone users can view their call logs, configure and manage their
own messaging, and access other features.

This section contains information that you may need to inform or assist your phone users so that they can use the
FortiVoice features.

This information is not the same as what is included in the help for FortiVoice user portal. It is included in this guide
because:

l Phone users need to know how to access the FortiVoice user portal and its online help.
l Phone users need to know the feature codes they can use on the phones.
l Phone users need to know how to change the voicemail password on the web portal and on the phone.
l Phone users may be confused if they try to enable a feature that you disabled (such as call waiting or do not
disturb).

l You may need to tailor some information to your network or phone users.

This topic includes:

l Accessing the user portal on page 20
l Changing the voicemail PIN on page 21
l Receiving and sending faxes on page 21
l Using the operator console on page 21

l Setting user privileges and preferences on page 21
l Setting the feature codes on page 21

Accessing the user portal

When a user has a phone extension on the FortiVoice phone system, the web-based FortiVoice user portal allows this
user to perform the following tasks for their extension:

l Check the call history for received, placed, or missed calls.
l Check the voicemail including playing, deleting, or saving the voicemails.
l Manage the business and personal contacts, and view the business and corporate phone directories.
l Manage how the phone system handles phone calls.
l Check recorded calls including playing, deleting, or saving the voicemails.
l Receive and send fax.
l Set up reminder events and invite guests.
l Add user conference call events in your calendar and invite attendees by email.
l View device details of desk phones and softclients, and set up programmable keys.
l Configure the extension according to your preferences.
l Use the operator console to process organization calls.

To access the FortiVoice user portal, phone users need the following information:

l FortiVoice user portal link: https://<IP_address_or_FQDN>/voice
Where <IP_address_or_FQDN> is the IP address or the FQDN of the FortiVoice phone system.
If you have changed the access port, then you must also include the port. For example: https://<IP_address_or_
FQDN>:446/voice.
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Connecting to the FortiVoice system

l Phone extension
l User password

For more information about the FortiVoice user portal, see FortiVoice User Portal Guide.

For information about adding extension numbers and user passwords for web access, see Configuring IP extensions on
page 162.

Changing the voicemail PIN

Inform the phone users how to change their default voicemail PIN. For details, phone users can refer to the FortiVoice
User Portal Guide.

Receiving and sending faxes

Inform the phone users that they can receive and send faxes on the user portal. For more information, see Configuring
fax on page 280.

Using the operator console

If you have enabled the operator role for an extension, inform the extension user so that the user can process corporate
calls on the user portal. For more information, see Operator Role on page 138.

Setting user privileges and preferences

The call features each phone user can use is controlled by the user privilege and preferences settings associated with
the user’s extension. You may need to inform users of the features that they can use.

For information, see Configuring user privileges on page 137 and Setting extension user preferences on page 181.

Setting the feature codes

By default, the FortiVoice system has feature codes for users to access certain features by dialing the codes. You can go
to Service > Feature Code > Feature Code and double-click a feature name to modify its code and description, but that
does not change the mapping between the code and the feature.

For details, see Modifying feature access codes on page 289.
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Navigating the GUI

To help you navigate the GUI, this section includes the following topics:

l GUI overview on page 22
l Checking the system security on page 23

GUI overview

When you connect to your FortiVoice system using a web browser, you access the following GUI:

No. Description

1 To access to the system security status and security audit details.
For detailed information, see Checking the system security on page 23.

2 To access update phone configurations and reboot phones. The Phone Maintenance icon is visible
when the FortiVoice phone system has phone configuration updates that need to be pushed to the
phones.
For detailed information, see Maintaining phones on page 104.
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No. Description

3 To access the context-sensitive help (CSH) which opens the FortiVoice online documentation in
HTML format. You can download the PDF file from the HTML page. You can also access the CSH
by pressing the F1 key.

4 To view the GUI in full screen without the top banner and menu items on the left.

5 To access the following functions:
l Change password
l Reboot
l Shut down
l Log out

6 To access the tabs associated with a selected sub-menu.
The Dashboard > Status includes areas called widgets (for example, System Information and
License Information).

7 Click a menu item to expand your selection and show related sub-menus.

8 The Search option allows you to search for keywords appearing in navigation menus, sub-menus,
and tabs and to quickly access the configuration pages.
How to search:
1. Go to the Search option and click the magnifying glass icon .
2. Enter the text that you want to find.
3. In the search results, click on a result to go to the configuration page.
How to clear a search:
1. Go to the Search option.
2. At the end of the search field, click x.

Checking the system security

To check the system security status and display security audit details, click the security alert icon . If there are any
security issues, the icon will have a red exclamation mark.

For information about security settings, see Configuring security settings on page 157.

GUI field Description

Passwords

Password Policy If the SIP password and user PIN policy for administrators and extension
users are met, the shield icon is green. Otherwise, it is red.
Click Edit Password Policy to set password policies. See Setting
password policies on page 158.

Empty Admin
Password Allowed

If a password is required in the admin password field when logging in to
the system, the shield icon is green. Otherwise, it is red.
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GUI field Description

For information on selecting this option, see Setting password policies on
page 158.

Unsafe SIP
Password Count

This option counts the unsafe SIP passwords for IP and fax extensions
only.
If any unsafe SIP passwords are found, the shield icon is red. Otherwise, it
is green.
Click Password Auditor to verify the strength of IP and fax extension
passwords. See Auditing the extension passwords on page 159.

Unsafe PIN Count This option counts the unsafe voicemail PINs for any extension type that
has a voicemail PIN.
If any unsafe voicemail PINs are found, the shield icon is red. Otherwise, it
is green.
For information on configuring extensions, see Setting up local extensions
on page 162.

Unsafe User
Password Count

This option counts the unsafe user passwords set in IP Extension > User
Setting > Web Access and includes all extension types except branch
page extensions.
If any unsafe user passwords are found, the shield icon is red. Otherwise,
it is green.
For information on setting user passwords, see Configuring IP extensions
on page 162.

Unaudited Password
Count

This option counts the newly added extensions of which the passwords
have yet to be audited.
If any unaudited passwords are found, the shield icon is red. Otherwise, it
is green.
For information on verifying the strength of extension passwords. See
Auditing the extension passwords on page 159.

Miscellaneous

Not Assigned Phone
Count

This option counts the number of phones that have not been assigned
extensions yet.
If any phones without extensions are found, the shield icon is red.
Otherwise, it is green.
For information on assigning phones to extensions, see Configuring desk
phones on page 143.
Clicking the delete icon removes all unassigned phones.

Secure TFTP
System

This option monitors if the system TFTP is enabled.
If TFTP is enabled, the shield icon is red.
If TFTP is disabled, the shield icon is green.
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Clicking Edit allows you to enable or disable the system TFTP, which also
enables or disables TFTP settings in System > Advanced > Service/Auto
Provisioning. For details, see Configuring the internal ports on page 92
and Configuring SIP phone auto-provisioning on page 93.

Secure TFTP
Interfaces

This option monitors if TFTP is enabled on the port interfaces.
If TFTP is enabled, the shield icon is red.
If TFTP is disabled, the shield icon is green.
If you have TFTP enabled on multiple ports, they will be listed and
you can click a link to disable it. For details, see Configuring the network
interfaces on page 44.

HTTP Interfaces This option monitors if HTTP is enabled on the port Interfaces.
If HTTP is enabled, the shield icon is yellow (warning).
If HTTP is disabled, the shield icon is green.
If you have HTTP enabled on multiple ports, they will be listed and
you can click a link to disable it. For details, see Configuring the network
interfaces on page 44.

Administrator
Trusted Hosts

This option monitors if trusted hosts are configured on the system
administrator account.
If trusted hosts are not configured, the shield icon is red.
If trusted hosts are configured, the shield icon is green.

APNS Push
Certificate

An iPhone running the FortiFone Softclient for iOS requires the following
valid certificates on the FortiVoice phone system:
l Apple Push Notification service (APNs): Used to receive notification
messages.

l VoIP services: Used to receive incoming calls.
This option monitors those certificates.
For more details about viewing and importing certificates, see Managing
APNs and VoIP services certificates on page 102.

Send Alert (button) Click to email the security audit details to recipients configured in Log &
Reports > Alert > Configuration.
For details, see Configuring alert email on page 310.

FortiVoice Phone System 6.0.12 Administration Guide 25
Fortinet Inc.



Using the dashboard

Dashboard displays system statuses, most of which pertain to the entire system, such as CPU usage and call statistics.

This section includes:

l Viewing the dashboard on page 26
l Viewing Call Statistics on page 28
l Using the CLI Console on page 28

Viewing the dashboard

Dashboard > Status displays first after you log in to the GUI. It contains a dashboard with widgets that each indicate
performance level or other statistics.

By default, widgets display the serial number and current system status of the FortiVoice system, including system
information, system resource usage, license information, service status, firmware version, recent calls, and statistics
history.

This section includes the following topics:

l Customizing the dashboard on page 26
l System Information widget on page 27
l License Information widget on page 27
l System Resource widget on page 27
l Statistics History widget on page 27
l Service Status widget on page 28
l Recent Calls widget on page 28

See also Navigating the GUI on page 22.

Customizing the dashboard

The dashboard is customizable. You can select which widgets to display, where they are located on the tab, and whether
they are minimized or maximized.

To move a widget, position your mouse cursor on the widget’s title bar, then click and drag the widget to its new location.

To show or hide a widget selectManageWidget and then select the widgets you want displayed on the Dashboard. If the
widget is greyed out, the widget will not display. Select Apply when you have made your selections.

Options vary slightly from widget to widget, but always include options to refresh, minimize, maximize and close the
widget.
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System Information widget

The System Information widget displays the serial number and basic system statuses such as the firmware version,
system time, and up time.

In addition to displaying basic system information, the System Information widget lets you change the firmware. To
change the firmware, click Update for Firmware version. For more information, see Managing the firmware on page 313.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

License Information widget

The License Information widget displays the last queried license statuses for the number of extensions supported (if you
use FortiVoice VM), hotel management, and call center (if you have purchased these options).

Depending on the license you have purchased, when you first access the FortiVoice GUI, you need to upload the license
to enable the functions you need.

For complete details about purchasing, registering, and uploading a license, see the Licensing section in the FortiVoice
Cookbook.

To upload a license file

1. Save the license file on your management computer.
2. Go to Dashboard > Status.
3. In the License Information widget, click Update license.
4. Browse for the license (.lic) file.
5. Select the file, and clickOpen.
6. To confirm the upload, click Yes.

System Resource widget

The System Resource widget displays the CPU, memory, and disk space usage. It also displays the system load and
current number of IP sessions.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

The system resources history can also be viewed in this widget by clicking History. The system resources history
contains four graphs. Each graph displays readings of one of the system resources: CPU, memory, IP sessions, and
network bandwidth usage. Each graph is divided by a grid.

Statistics History widget

The Statistics History widget contains charts that summarize the number of calls in each time period that the FortiVoice
system recorded.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

See also Viewing Call Statistics on page 28.
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Service Status widget

The Service Status widget displays the number of current calls, extension status, trunk status, and device connection
status.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

Device (2000E-T2 model only) displays the connection status of the FortiVoice physical ports:

l Connected: The port is connected to a device.
l Disconnected: The port is not connected to any device and is ready for use.
l Alarmed: The port has an error and is not usable.
l Occupied: The port is being used.

If there are any mismatched phones underGeneric phones > Mismatched, you can click View to display them. For
detailed information, see Viewing mismatched phones on page 34.

Recent Calls widget

The Recent Calls widget displays the calls processed by the FortiVoice system, including phone numbers, call
directions, call starting time and duration, and call status.

To view the widget, go to Status > Dashboard. If the widget is not currently shown, click Add Content, and mark the
check box for the widget.

The maximum call records shown is 8.

Viewing Call Statistics

The Dashboard > Call Statistics tab contains summaries of the number of calls by time and direction that the FortiVoice
system recorded.

Using the CLI Console

To access the CLI without exiting the FortiVoice GUI, go to Dashboard > Console.

If you want to move the CLI Console into a pop-up window that you can resize and reposition, click theOpen in New
Window button at the bottom of the page.
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TheMonitormenu displays system usage, log messages, reports, and other status-indicating items.

This topic includes:

l Viewing phone system status on page 29
l Viewing extensions and devices on page 31
l Viewing call records on page 36
l Viewing generated reports on page 36
l Viewing log messages on page 37
l Viewing call directory on page 40
l Blocking SIP device IPs on page 40
l Viewing recorded calls and fax storage on page 40

Viewing phone system status

Monitor > Phone System displays all the ongoing phone calls, parked calls, conference calls, trunks, and DHCP clients.

This topic includes:

l Viewing active calls on page 29
l Viewing parked calls on page 29
l Viewing conference calls on page 30
l Viewing trunk status on page 30
l Viewing DHCP client list on page 30

Viewing active calls

Monitor > Phone System > Active Calls displays all the ongoing phone calls in realtime, including the callers and
receivers, the trunks through which phone calls are connected, the call status, and the call duration.

You can stop a phone call by clicking the Hang up icon.

The call statuses include:

l Ringing: The receiver’s phone is ringing.
l Connected: Callers are connected. The voice channel is established.
l Voicemail: The call goes to the voicemail.

Viewing parked calls

A parked call is similar to a call that is on hold, except that the parked call can then be picked up from any extension.

To view parked calls, go toMonitor > Phone System > Parked Call.
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For more information on call parking, see Configuring call parking on page 279.

Viewing conference calls

Monitor > Phone System > Conference displays the conference call records, including the name of the conference call,
the extension number of the call, the displayed name of the caller, and the call duration.

You can stop a caller from attending the conference call by selecting the caller and clicking the Kick Out icon.

For more information, see Configuring conference calls on page 268.

Viewing trunk status

Monitor > Phone System > Trunk displays all the trunks in realtime, including their names, IP addresses, types, status,
and registration/connection status with the VoIP or PSTN service provider.

The trunk statuses include:

l Not registered: The trunk is not registered with the VoIP or PSTN service provider and is not in service.
l In service: The trunk is registered with the VoIP or PSTN service provider and is in service.
l Unavailable: The trunk is not reachable.
l Alarm detected: There is a problem with the trunk.
l Admin down: The trunk is disabled.
l Unmonitored: The trunk is not monitored.

You can stop a phone call by clicking the Hang up button.

Registration/Connection indicates if a trunk is registered with or connected to the VoIP or PSTN service provider. The
Registration/Connection column can show the following icons:

l : The trunk is registered. (This icon is for the SIP trunk, office peer, and gateway only.)
l : The trunk is OK. (This icon is for the PSTN only.)

l

: The trunk or trunk channel has a red alarm. (This icon is for the PSTN only.)

l : The trunk or trunk channel is in service. (This icon is for the PSTN only.)

l

: The trunk or trunk channel has an alarm. (This icon is for the PSTN only.)

For more information, see Configuring trunks on page 200.

Viewing DHCP client list

Monitor > Phone System > DHCP displays all the DHCP-enabled devices connected to the FortiVoice system in
realtime.

After a DHCP-enabled phone connects to the FortiVoice system and is auto-discovered, the FortiVoice system assigns
an IP address to the phone and sends the basic PBX setup information to it.

For the supported DHCP-enabled phone to connect to the FortiVoice system:
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l In the FortiVoice DHCP server configuration, select DHCP option 66 (an advanced option on the GUI) and include
the IP address of the FortiVoice interface connected to the same network as the SIP phones to be auto-provisioned.
For more information, see Configuring DHCP server on page 49.
DHCP server option 66 identifies a TFTP server and includes the IP address of the TFTP server and downloads the
TFTP server identity to the device that gets an IP address from the DHCP server. DHCP option 66 is defined in RFC
2132.

l If using your own DHCP server, set the DHCP server option 66 to the FortiVoice system’s TFTP server (Opt66)
value. For more information, see Configuring DHCP server on page 49.

l If the FortiVoice system and the SIP phone with an IP assigned by a DHCP server are on different subnets, proper
route should be set to make them reachable.

GUI field Description

Export Select to save the DHCP client list in csv format.

MAC Address The Media Access Control address (MAC address) of the DHCP client.

Interface The FortiVoice system port to which the DHCP client connects. For information on
FortiVoice interfaces, see Configuring network settings on page 42.

IP The IP address of the DHCP client assigned by the FortiVoice DHCP server.

Expiry Time The expiration time of the DHCP client IP address.

Device Type The brand names of the DHCP clients.

Extension When a DHCP-enabled device connects to the FortiVoice system, the FortiVoice system
assigns a temporary ID to the device if it is a supported device. If an extension number is
assigned to the phone, the extension number appears. For information on assigning
extensions, see Viewing FortiFone desk phones on page 32.

Configuration Status l OK: The DHCP client is assigned to a new or an existing extension user.
l Not assigned: The DHCP client is not assigned to a new or an existing extension
user.

l Misconfigured: The DHCP client’s configuration has errors.

Viewing extensions and devices

Monitor > Extension & Device displays all the extensions, the extensions configured for hot desking, FortiFone desk
phones, FortiFone softclient, and generic SIP phones.

This topic includes:

l Viewing extension status on page 32
l Viewing FortiFone desk phones on page 32
l Viewing FortiFone softclient on page 34
l Viewing generic SIP phones on page 34
l Viewing mismatched phones on page 34
l Viewing activity details of hot desking extensions on page 34
l Viewing unmanaged gateways on page 35

FortiVoice Phone System 6.0.12 Administration Guide 31
Fortinet Inc.

http://www.faqs.org/rfcs/rfc2132.html
http://www.faqs.org/rfcs/rfc2132.html


Monitoring the FortiVoice system

Viewing extension status

Monitor > Extension & Device > Extension displays all the extensions in realtime, including their statuses, IDs, numbers,
display names, types, IPs for SIP extensions, phone information, and if it has any FortiFone softclient and auxiliary
devices.

For more information, see Configuring extensions on page 162.

Viewing FortiFone desk phones

Monitor > Extension & Device > Phone lists the supported phones auto-discovered by the FortiVoice system, assigned
or not assigned to any extensions.

After an unassigned phone connects to the FortiVoice system and is auto-discovered, the FortiVoice system assigns an
IP address to the phone and sends the basic PBX setup information to it.

After assigning an extension to the phone, the extension’s full configuration file will be sent to the phone if the auto-
provisioning option is selected in the user privilege applied to the extension. For details, see Setting up local extensions
on page 162 and Configuring user privileges on page 137.

GUI field Description

New Click to add a new desktop FortiFone. For details, see Configuring desk phones on page
143.

Delete Select one or more SIP phone records and click this button to remove them all at once.

Action l Assign to New Extension: Select a SIP phone in Not Assignedmanagement status
and click this option to add an extension and assign this phone to the extension at
the same time. For more information, see To assign a new extension user to an
unassigned phone on page 33.

l Assign to Existing Extension: Select an unassigned phone and click this option to
assign this phone to an existing extension. The phone record disappears from the
Unassigned Phone list. For more information, see To assign a new extension user to
an unassigned phone on page 33.

l Assign as Auxiliary to Existing Extension: Select a SIP phone in Not Assigned
management status and click this option to assign it to an existing extension as an
auxiliary device. For more information, see To assign a new extension user to an
unassigned phone as an auxiliary device on page 33and Auxiliary Phone on page
167.

l Assign to Multi-cell Device: Select a multi-cell device (for example, FortiFone 870i)
in Not Assignedmanagement status and click this option to add an extension and
assign this phone to the extension at the same time. For more information, see To
assign a new extension user to an unassigned phone on page 33 and Configuring
multi-cell FortiFone phones on page 146.

l Edit Associated Multi-cell Device: Select a multi-cell device (for example, FortiFone-
D72) inMulti-cellmanagement status and click this option to modify the device
configuration. For more information, see Configuring multi-cell FortiFone phones on
page 146.

l Unassign Multi-cell Device: Select a multi-cell device (for example, FortiFone-D72)
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GUI field Description

inMulti-cellmanagement status and click this option to separate the device from the
associated extensions.

l View Phone Configuration: Select a SIP device in Assigned status and click this
option display its configuration file. The device can be a phone, desktop phone
application, mobile phone, or multi-cell device.

l View accounts: For FortiFones to which multiple extensions can be associated, such
as FON-850/860/870 and FON-D70/D71/D72, click this option to view the
associated extensions. This option is only active when a FortiFone has multiple
extensions associated with it.

l Export: Select to save the extension list in CSV format.

Extension When you see , it means that the phone is assigned to an extension.

MAC Address The Media Access Control address (MAC address) of the SIP phone.

Phone Model The phone brand and model.

Phone Profile The profile for this phone. See Configuring SIP profiles on page 122.

Management Displays the assignment status of the phone (Assigned or Not Assigned).

Number The extension number of the phone.

Display Name The name displaying on the phone, such as John Doe.

Status Displays if the phone is registered with the FortiVoice system. A registered phone is
assigned an IP address and basic PBX setup information.

IP The IP address of the phone assigned by the FortiVoice system.

Phone Info The model, MAC address, and firmware version of the phone for this extension.

Version The firmware version that is installed on the phone.

To assign a new extension user to an unassigned phone

1. Go toMonitor > Extension & Device > Phone.
2. UnderManagement, select a phone in Not assigned status.
3. Click Action and select Assign to New Extension.
4. Review the extension details and click Next. For details, see Configuring IP extensions on page 162.
5. Review the phone details and click Next.
6. Review the summary and click Finish.

To assign an existing extension user to an unassigned phone

1. Go toMonitor > Extension & Device > Phone.
2. UnderManagement, select a phone in Not assigned status.
3. Click Action and select Assign to Existing Extension.
4. Select the extension to associate with the unassigned phone and click Next.
5. Review the extension details and click Next. For details, see Configuring IP extensions on page 162.
6. Review the phone details and click Next.
7. Review the summary and click Finish.

To assign a new extension user to an unassigned phone as an auxiliary device

FortiVoice Phone System 6.0.12 Administration Guide 33
Fortinet Inc.



Monitoring the FortiVoice system

1. Go toMonitor > Extension & Device > Phone.
2. UnderManagement, select a phone in Not assigned status.
3. Click Action and select Assign as Auxiliary to Existing Extension.
4. Select the extension to associate with the unassigned phone and click Next.
5. Review the extension details and click Next. For details, see Configuring IP extensions on page 162.
6. Review the phone details and click Next.
7. Review the summary and click Finish.

Viewing FortiFone softclient

Monitor > Extension & Device > Soft FortiFone lists the FortiFone softclients auto-discovered by the FortiVoice system.

Viewing generic SIP phones

Monitor > Extension & Device > Generic Phone lists the third party SIP phones auto-discovered by the FortiVoice
system.

Viewing mismatched phones

Monitor > Extension & Device > Mismatched Phone displays the phones of which the registration information does not
match the desk phone models and has caused registration failure.

You can select a phone registration failure record and click Delete to remove it to avoid the confusion that the system is
compromised.

Viewing activity details of hot desking extensions

Monitor > Extension & Device > Hot Desking displays details of hot desking users, including:

l Logout: Click to log out a Hot-Desked phone
l Renew: Click to refresh the expiration of the hot desk session.
l Status:The status of the hot desking extension: logged in or logged out.
l Number: The hot desking extension number.
l Display Name: The name displayed on the hot desking extension.
l Host Device: The extension number or MAC address (for a unassigned phone) of the phone that a hot desking user
logs into.

l Last Login: The last login time at the host device.
l Expiry: The login expiry time.

Hot desking enables users to log into another phone. However, unlike using Follow Me or Call Forwarding which simply
redirect a user's calls to another user’s phone, hot desking takes total control of another phone by applying all of the
user's own phone settings to that phone until the user logs out. Each user can log into another phone by pressing *11
and enter his extension number and user PIN following the prompts. To log out, a user can press *12.

Depending of the phone model, the host phone may reboot.

For information on configuring hot desking, see Hot-desking on page 140.
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Viewing unmanaged gateways

Monitor > Extension & Device > Unmanaged Gateway lists the supported FortiVoice gateways auto-discovered by the
FortiVoice system but not added to the FortiVoice system.

After a gateway connects to the FortiVoice system and boots up, it will automatically discover the FortiVoice system
through SIP PNP.

After adding a FortiVoice gateway to the FortiVoice system, the gateway’s full configuration file will be sent to the
gateway. For details, see Managing FortiVoice gateways, local survivability, and firmware on page 151.

GUI field Description

Action l Create New Device: Select an unmanaged gateway and click this option to add the
gateway to the FortiVoice system. The gateway record disappears from the
Unmanaged Gateway list. For more information, see To add a gateway to the
FortiVoice system on page 35

l Replace Existing Device: If you need to replace a gateway for any reason, select the
gateway and click this option to find a new gateway for replacement. For more
information, see To replace an existing gateway on page 36.

Serial number The serial number of the unmanaged gateway.

Type The gateway brand and model.

IP The IP address of the unmanaged gateway assigned by the FortiVoice system.

To add a gateway to the FortiVoice system

1. Go toMonitor > Extension & Device > Unmanaged Gateway.
2. Select an unmanaged gateway.
3. Click Action and select Create New Device.

GUI field Description

Gateway Details

Name Enter a unique name for the gateway.

Enabled Select to activate the gateway if required.

Display Name The name displaying on the gateway, such as ABC Company Gateway.

Hostname/IP address Enter the hostname or IP address of LAN1 of the gateway. If you are using a
different network interface, enter its IP. If the gateway has been configured to
use a different HTTPS port, enter the port number after the IP address.
l Get device information: Click to get the serial number, device type, and
Mac address of the gateway. This will confirm the systems are able to
communicate with each other and that the password entered is valid. If
preconfiguring the system before deployment, manually enter in the serial
number and MAC address of the gateway.

l Connect device: Click to go to the Web GUI of the gateway.

Admin user name Enter the user name for logging into the gateway.
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GUI field Description

Admin password Enter the password for logging into the gateway.
If you want to change the administrator password for logging into the gateway,
click Change password, enable and enter the new password, confirm it, and
clickOK.

Serial number The serial number of the gateway.

Type Select the gateway brand and model.

MAC address Enter the Mac address of the gateway.

Description Enter any comments for the gateway.

4. Click Finish.

To replace an existing gateway

1. Go toMonitor > Phone System > Unmanaged Gateway.
2. Select the gateway to be replaced.
3. Click Action and select Replace Existing Device.
4. Select a new device to replace the old one.
5. Click Next.
6. Click Close.

Viewing call records

Monitor > Call History > Call Detail Record (CDR) displays all the phone calls made during a certain time period,
including time of the call, caller and receiver, call duration, call status, call direction, trunks used, call type, and call
recordings.

Double-clicking a record displays the detailed call information, including the CDR flow.

Using theMore Action dropdown list, you may select a caller or callee and add them to your contact list or block them.

You can filter the call records display by clicking the Search button and enter criteria that records must match in order to
be visible. You can also save the call records by selecting an option under Download. If you enableWith call flow, you
can download call records with detailed call flow information.

Viewing generated reports

The Call Report submenu displays the call reports and call center reports generated by the FortiVoice system. You can
delete, view, and/or download the reports.

FortiVoice systems can generate reports automatically according to the report schedules that you configure. For more
information, see Configuring call center report profiles and generating reports on page 252.
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To reduce the amount of hard disk space consumed by reports, regularly download then
delete generated reports from the FortiVoice system.

To view call or call center reports

1. Go toMonitor > Call Report> Report/Call Center Report.

GUI field Description

Download Click to create a PDF or HTML version of the report.

Directory Lists the name of the generated report, and the date and time at which it was
generated.
For example, Report 1-2021-03-31-2112 is a report named Report 1,
generated on March 31, 2021 at 9:12 PM. To view an individual section of the report
in HTML format, click + next to the report name to expand the list of HTML files that
comprise the report, then double-click one of the file names.

Last Access Time Lists the date and time when the FortiVoice system completed the generated report.

Size Lists the file size of the report in HTML format, in bytes.

2. To view the report in PDF file format, select a report and click Download.On the pop-up menu, select Download
PDF.

3. To view the report in HTML file format, you can view all sections of the report together, or you can view report
sections individually.
l To view all report sections together, select a report, such as 2021-03-31-2112, then click Download and
select Download HTML. Your browser downloads a file with an archive (.tgz.gz) file extension to your
management computer. To view the report, first extract the report files from the archive, then open the HTML
files in your web browser.

l EachQuery Selection in the report becomes a separate HTML file. You can view the report as individual HTML
files. In the row corresponding to the report that you want to view, click + next to the report name to expand the
list of sections, then double-click the file name of the section that you want to view, such as report1.html.
The report appears in a new browser window.

4. To view the report in CSV (comma-separated value) file format that can be viewed in a spreadsheet application
such as Microsoft Excel or OpenOffice Calc, select a report and click Download.On the pop-up menu, select
Download CSV.

Viewing log messages

The Log submenu displays locally stored log files. If you configured the FortiVoice system to store log messages locally
(that is, to the hard disk), you can view the log messages currently stored in each log file.

Logs stored remotely cannot be viewed from the GUI of the FortiVoice system. If you want to view logs from the GUI,
also enable local storage. For details, see Configuring logs and reports on page 297.

Monitor > Log displays the logs of administrator activities and system events as well as mail, voice, fax, queue, hotel
management (with license only), call center (with license only), and phone configuration.

The log messages vary by levels. For more information, see Configuring logs and reports on page 297.
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The log messages are also filtered by subtypes depending on log types.

To view the list of log files and their contents

1. Go toMonitor > Log > System/Generic/Voice/Fax/Queue/Hotel/Call Center/Phone Configuration.
The list of log files appears with the beginning and end of a log file’s time range and the size of a log file in bytes. The
queue log files display more information.

2. To search the log files, click the Search button and enter criteria that records must match in order to be visible.
Unlike the search when viewing the contents of an individual log file, this search displays results regardless of which
log file contains them. For more information, see Searching log messages on page 39.

3. To view messages contained in logs, double-click a log file.
To view the current page’s worth of the log messages, right-click and select Export. You can then open or save the
.csv file.
You can click the Configure View icon to show or hide columns, save the customized view, or reset the view to
default. When you save a customized view, future log message reports appear in this view.

Displaying and arranging log columns

When viewing logs, you can display, hide, sort and re-order columns.

For most columns, you can also filter data within the columns to include or exclude log messages which contain your
specified text in that column. For more information, see Searching log messages on page 39.

By default, each page’s worth of log messages is listed with the log message with the lowest index number towards the
top.

To sort the page’s entries in ascending or descending order

1. Click the column heading by which you want to sort.
The log messages are sorted in ascending order.

2. To sort in descending order, click the column heading again.
Depending on your currently selected theme:
l The column heading may darken in color to indicate which column is being used to sort the page.
l A small upwards-or downwards-pointing arrow may appear in the column heading next to its name to indicate
the current sort order.

To display or hide columns

1. Go toMonitor > Log > System /Generic/Voice/Fax/Queue/Hotel/Call Center/Phone Configuration.
2. Click Configure View > Show/Hide Columns.
3. Mark the check boxes of columns that you want to display.
4. ClickOK.

To change the order of the columns

1. Go toMonitor > Log > System /Generic/Voice/Fax/Queue/Hotel/Call Center/Phone Configuration.
2. For each column whose order you want to change, click and drag its column heading to the left or right.
3. Click Configure View > Save View.

Using the right-click pop-up menus

When you right-click on a log message, a context menu appears.
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Log report right-click menu options

View Details Select to display the content of the log message.

Select All Select to select all log messages in the current page, so that you can export all messages
to a table.

Clear Selection Select to deselect one or multiple log messages.

Export Select to export the selected log messages as a .csv file.

Searching log messages

You can search logs to quickly find specific log messages in a log file, rather than browsing the entire contents of the log
file.

To search log messages

1. Go toMonitor > Log > System/Generic/Voice/Fax/Queue/Hotel/Call Center/Phone Configuration.
2. Click Search.
3. Enter your search criteria by configuring one or more of the following:

GUI field Description

Keyword Enter any word or words to search for within the log messages.
For example, you might enter GUI session to locate all log messages containing
that exact phrase in any log field.

Message Enter all or part of theMessage log field.

Log ID Enter all or part of the log ID in the log message.

Match condition l Contain: searches for the exact match.
l Wildcard: supports wildcards in the entered search criteria.

Date Select the start and end time of log messages to include in the search results.

Time span Select the time span of log messages to include in the search results.
For example, you might want to search only log messages that were recorded during
the two weeks and 8 hours previous to the current date. In that case, you would
specify the current date, and also specify the size of the span of time (two weeks and
8 hours) before that date.

Load Previous Setting Select to populate the fields with the settings entered previously.

4. Click Search.
The FortiVoice system searches for log messages that match your search criteria, and displays any matching log
messages.
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Viewing phone configuration logs

Monitor > Log > Phone Configuration displays the phone configuration logs.

You can click the Phone maintenance button to:

l update phone configurations. See Maintaining phones on page 104.
l view the phone configuration update and firmware upgrade jobs. See Maintaining phones on page 104.

Viewing call directory

TheMonitor > Directorymenu lets you view phone directories and create speed dial rules. For more information, see
Creating contacts.

Blocking SIP device IPs

The FortiVoice system automatically blocks the IP addresses of the SIP devices that initiate the attacks against any
extensions based on the thresholds and parameters set. For more information on configuring security settings, see
Configuring intrusion detection on page 157.

You may select an IP to delete it, add it to the exempt list if it is wrongly blocked, and view its blocked history.

To view the blocked IPs, go toMonitor > Security > Blocked IP.

Viewing recorded calls and fax storage

Monitor > Storage displays the recorded calls, faxes, archived faxes, and faxes in queue.

This topic includes:

l Playing recorded calls on page 40
l Viewing current fax accounts on page 41
l Viewing archived faxes on page 41
l Viewing fax queues on page 41

Playing recorded calls

The Recorded Call tab lists the calls recorded by the FortiVoice system.

To listen to a recorded call

1. Go toMonitor > Storage > Recorded Call .
2. Double-click a call record folder to open the archived call files.
3. Select a call file and click the Play button.
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To save a recorded call

1. Go toMonitor > Storage > Recorded Call.
2. Select a call record folder to open the archived call files.
3. Select a call file and click the Download button.

To search recorded calls

1. Go toMonitor > Storage > Recorded Call .
2. Click Search > New.
3. Enter the search values, and click Create.

Note that under Recording type, Conference refers to calls recorded by phone number that are conference call
numbers. System refers to all other type of calls recorded.

For information about configuring recording calls, see Recording calls on page 271.

For details about how to manage the recorded call access by department, see the Managing the access to phone call
recordings in the FortiVoice Cookbook.

Viewing current fax accounts

The Fax tab lists the fax accounts created on the FortiVoice system. For more information about creating fax accounts,
see Configuring fax on page 280.

To view fax accounts, go toMonitor > Storage > Fax. The fax accounts are listed with their names, numbers, display
names, storage sizes, and faxes stored.

You can double-click a fax account and view the detailed information on the faxes it stores. You can also click Download
PDF to save a fax.

Viewing archived faxes

The Fax Archive tab lists the faxes sent and received through the FortiVoice system. For more information about fax, see
Configuring fax on page 280.

To view archived faxes, go toMonitor > Storage > Fax Archive.

You can double-click a fax folder and view the detailed information on the faxes it stores.

Viewing fax queues

The Fax Queue tab lists the faxes waiting to be sent on the FortiVoice system. For more information about fax, see
Configuring fax on page 280.
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Configuring system settings

The Systemmenu lets you set up configurations of the FortiVoice operation system, including administrator accounts,
network settings, system time, SIP settings, systemmaintenance, and more.

This topic includes:

l Configuring network settings on page 42
l Configuring administrator accounts and access profiles on page 51
l Configuring RAID on page 54
l Using high availability on page 57
l Working with system configurations on page 76
l Configuring advanced phone system settings on page 89
l Managing certificates on page 95
l Maintaining the system on page 103

Configuring network settings

The Network submenu provides options to configure network connectivity and administrative access to the GUI or CLI of
the FortiVoice system through each network interface.

This topic includes:

l About IPv6 Support on page 42
l About the management IP on page 43
l About FortiVoice logical interfaces on page 43
l Configuring the network interfaces on page 44
l Configuring static routes on page 47
l Configuring DNS on page 48
l Configuring DHCP server on page 49
l Capturing voice and fax packets on page 50

About IPv6 Support

IP version 6 (IPv6) handles issues that were not around decades ago when IPv4 was created such as running out of IP
addresses, fair distributing of IP addresses, built-in quality of service (QoS) features, better multimedia support, and
improved handling of fragmentation. A bigger address space, bigger default packet size, and more optional header
extensions provide these features with flexibility to customize them to any needs.

IPv6 has 128-bit addresses compared to IPv4’s 32-bit addresses, effectively eliminating address exhaustion. This new
very large address space will likely reduce the need for network address translation (NAT) since IPv6 provides more
than a billion IP addresses for each person on Earth. All hardware and software network components must support this
new address size, an upgrade that may take a while to complete and will force IPv6 and IPv4 to work side-by-side during
the transition period.
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The FortiVoice system supports the following IPv6 features:

l Network interface
l Network routing
l DNS
l DHCP
l Phone extension
l Trunk

About the management IP

The FortiVoice system has an IP address for administrators to configure it through a network connection rather than a
local console. The management IP address enables administrators to connect to the FortiVoice system through port1 or
other network ports, even when they are currently bridging.

By default, the management IP address is indirectly bound to port1 through the bridge. If other network interfaces are
also included in the bridge with port1, you can configure the FortiVoice system to respond to connections to the
management IP address that arrive on those other network interfaces.

You can access the GUI and the FortiVoice user account using the management IP address. For details, see Connecting
to the GUI on page 15.

About FortiVoice logical interfaces

In addition to the FortiVoice physical interfaces, you can create the following types of logical interfaces on the FortiVoice
system:

l VLAN subinterfaces on page 43
l Redundant interfaces on page 44
l Loopback interfaces on page 44

VLAN subinterfaces

A Virtual LAN (VLAN) subinterface, also called a VLAN, is a virtual interface on a physical interface. The subinterface
allows routing of VLAN tagged packets using that physical interface, but it is separate from any other traffic on the
physical interface.

Virtual LANs (VLANs) use ID tags to logically separate devices on a network into smaller broadcast domains. These
smaller domains forward packets only to devices that are part of that VLAN domain. This reduces traffic and increases
network security.

One example of an application of VLANs is a company’s accounting department. Accounting computers may be located
at both main and branch offices. However, accounting computers need to communicate with each other frequently and
require increased security. VLANs allow the accounting network traffic to be sent only to accounting computers and to
connect accounting computers in different locations as if they were on the same physical subnet.

For information about adding VLAN subinterfaces, see Configuring the network interfaces on page 44.
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Redundant interfaces

On the FortiVoice system, you can combine two or more physical interfaces to provide link redundancy. This feature
allows you to connect to two or more switches to ensure connectivity in the event one physical interface or the equipment
on that interface fails.

In a redundant interface, traffic is only going over one interface at any time. This differs from an aggregated interface
where traffic is going over all interfaces for increased bandwidth. This difference means redundant interfaces can have
more robust configurations with fewer possible points of failure. This is important in a fully-meshed high availability (HA)
configuration.

A physical interface is available to be in a redundant interface if:

l it is a physical interface, not a VLAN interface
l it is not already part of a redundant interface
l it has no defined IP address and is not configured for DHCP
l it does not have any VLAN subinterfaces
l it is not monitored by HA

When a physical interface is included in a redundant interface, it is not listed on the System > Network > Network page.
You cannot configure the interface anymore.

For information about adding redundant interfaces, see Configuring the network interfaces on page 44.

Loopback interfaces

A loopback interface is a logical interface that is always up (no physical link dependency) and the attached subnet is
always present in the routing table.

The FortiVoice’s loopback IP address does not depend on one specific external port, and is therefore possible to access
it through several physical or VLAN interfaces. In the current release, you can only add one loopback interface on the
FortiVoice system.

For information about adding a loopback interface, see Configuring the network interfaces on page 44.

Configuring the network interfaces

The System > Network > Network tab displays the FortiVoice system’s network interfaces.

You must configure at least one network interface for the FortiVoice system to connect to your network. Depending on
your network topology and other considerations, you can connect the FortiVoice system to your network using two or
more of the network interfaces. You can configure each network interface separately. You can also configure advanced
interface options, including VLAN subinterfaces, redundant interfaces, and loopback interfaces. For more information,
see About FortiVoice logical interfaces on page 43, and Editing network interfaces on page 45.

To view the list of network interfaces, go to System > Network > Network.

GUI field Description

Name Displays the name of the network interface, such as port1.
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GUI field Description

Type Displays the interface type: physical, VLAN, redundant, or loopback. For details,
see About FortiVoice logical interfaces on page 43.

IP/Netmask Displays the IP address and netmask of the network interface.

IPv6/Netmask Displays the IPv6 address and netmask of the network interface. For more
information about IPv6 support, see About IPv6 Support on page 42.

Access Displays the administrative access and phone user access that are enabled on the
network interface, such as HTTPS for the GUI.

Status Indicates the up (available) or down (unavailable) administrative status for the
network interface.
l Green check mark: The network interface is up and can receive traffic.
l Red cross mark: The network interface is down and cannot receive traffic.

To change the administrative status (that is, bring up or down a network interface),
see Editing network interfaces on page 45.

Referenced (icon) Indicates if a network interface is used by other services, such as DHCP.
A green dot means a network interface is used by other services.
A gray dot means a network interface is not used by other services.

Editing network interfaces

You can edit FortiVoice’s physical network interfaces to change their IP addresses, netmasks, administrative access
protocols, and other settings. You can also create or edit logical interfaces, such as VLANs, redundant interfaces and the
loopback interface.

Enable administrative access only on network interfaces connected to trusted private
networks or directly to your management computer. If possible, enable only secure
administrative access protocols such as HTTPS or SSH. Failure to restrict administrative
access could compromise the security of your FortiVoice system.

You can restrict which IP addresses are permitted to log in as a FortiVoice administrator through network interfaces. For
details, see Configuring administrator accounts on page 51.

To create or edit a network interface

1. Go to System > Network > Network.
2. Double-click a network interface to modify it or select the interface and click Edit. If you want to create a logical

interface, click New.
The Edit Interface dialog appears.

3. Configure the following:

GUI field Description

Interface Name If you are editing an existing interface, this field displays the name (such as
port2) and media access control (MAC) address for this network interface.
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GUI field Description

If you are creating a logical interface, enter a name for the interface.

Type If you are creating a logical interface, select which type of interface you want to
create. For information about logical interface types, see About FortiVoice
logical interfaces on page 43.
l VLAN: If you want to create a VLAN subinterface, select the interface for
which you want to create the subinterface. Then specify a VLAN ID. Valid
VLAN ID numbers are from 1 to 4094, while 0 is used for high priority
frames, and 4095 is reserved.

l Redundant: If you want to create a redundant interface, click + in the
Interface Member field to add interface members. Usually, you need to
include two or more interfaces as the redundant interface members.

l Loopback: If you want to add a loopback interface, select the Loopback
type and the interface name will be automatically reset to “loopback”. You
can only add one loopback interface on the FortiVoice system.

Addressing Mode l Manual: Select to enter the IP address or IPv6 address and netmask for
the network interface in IP/Netmask or IPv6/Netmask.

l DHCP: Select and click Update request to retrieve a dynamic IP address
using DHCP.

Advanced Setting

Access Enable protocols that this network interface should accept for connections to
the FortiVoice system itself. (These options do not affect connections that will
travel through the FortiVoice system.)
l HTTPS: Enable to allow secure HTTPS connections to the GUI, and
extension user account through this network interface.

l HTTP: Enable to allow HTTP connections to the GUI, and extension user
account through this network interface.

l PING: Enable to allow ICMP ECHO (ping) responses from this network
interface.

l SSH: Enable to allow SSH connections to the CLI through this network
interface.

l SNMP: Enable to allow SNMP connections (queries) to this network
interface.
For information on further restricting access, or on configuring the
network interface that will be the source of traps, see Configuring the
network interfaces on page 44.

l TELNET: Enable to allow Telnet connections to the CLI through this
network interface.

l TFTP: Enable to allow TFTP connections to this network interface.
l NTP: Enable to allow SIP phones to connect to this server to synchronize
time.

l LDAP: Enable to allow SIP phones to connect to this server to retrieve
phone directories.

l SIPPnP: Enable SIPPnP multicast function for the connected phones to
find the provisioning server contained in its message for the phones.
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GUI field Description

l MDNS: Enable MDNSmulticast function for the connected phones to find
the TFTP provisioning server contained in its message for the phones.
This is mainly for backward support of legacy FortiFones.

HTTP and Telnet connections are not secure, and can be
intercepted by a third party. If possible, enable this option
only for network interfaces connected to a trusted private
network, or directly to your management computer. Failure
to restrict administrative access through this protocol could
compromise the security of your FortiVoice system. For
information on further restricting access of administrative
connections, see Configuring administrator accounts on
page 51.

l MTU:For the maximum transmission unit (MTU), enter the maximum
packet or Ethernet frame size in bytes.
If network devices between the FortiVoice system and its traffic
destinations require smaller or larger units of traffic, packets may require
additional processing at each node in the network to fragment or
defragment the units, resulting in reduced network performance.
Adjusting the MTU to match your network can improve network
performance.
The default value is 1500 bytes. The MTU size must be between 68 and
9000 bytes. Change this if you need a lower value; for example, RFC
2516 prescribes a value of 1492 for the PPPoE protocol.

l Administrative status: Select either:
l Up: Enable (that is, bring up) the network interface so that it can send
and receive traffic.

l Down: Disable (that is, bring down) the network interface so that it
cannot send or receive traffic.

Configuring static routes

The System > Network > Routing tab displays a list of routes and lets you configure static routes and gateways used by
the FortiVoice system.

Static routes direct traffic exiting the FortiVoice system. You can specify through which network interface a packet will
leave, and the IP address of a next-hop router that is reachable from that network interface. The router is aware of which
IP addresses are reachable through various network pathways, and can forward those packets along pathways capable
of reaching the packets’ ultimate destinations.

A default route is a special type of static route. A default route matches all packets, and defines a gateway router that can
receive and route packets if no other, more specific static route is defined for the packet’s destination IP address.

You should configure at least one static route, a default route, that points to your gateway. However, you may configure
multiple static routes if you have multiple gateway routers, each of which should receive packets destined for a different
subset of IP addresses.
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To determine which route a packet will be subject to, the FortiVoice system compares the packet’s destination IP
address to those of the static routes and forwards the packet to the route with the large prefix match.

When you add a static route through the GUI, the FortiVoice system evaluates the route to determine if it represents a
different route compared to any other route already present in the list of static routes. If no route having the same
destination exists in the list of static routes, the FortiVoice system adds the static route.

To view or configure static routes

1. Go to System > Network > Routing.

GUI field Description

Enabled Displays the route status.

Destination IP/Netmask Displays the destination IP address and subnet of packets subject to the static route.
A setting of 0.0.0.0/0.0.0 indicates that the route matches all destination
IP addresses.

Gateway Displays the IP address of the next-hop router to which packets subject to the static
route will be forwarded.

Interface The interface that this route applies to.

Comment Displays any notes on the static route.

2. Either click New to add a route or double-click a route to modify it.
A dialog appears.

3. Select Enable to activate the route.
4. In Destination IP/netmask, enter the destination IP address and netmask of packets that will be subject to this static

route.
To create a default route that will match all packets, enter 0.0.0.0/0.0.0.0.

5. Select the interface that this route applies to.
6. InGateway, type the IP address of the next-hop router to which the FortiVoice system will forward packets subject

to this static route. This router must know how to route packets to the destination IP addresses that you have
specified in Destination IP/netmask. For an Internet connection, the next hop routing gateway routes traffic to the
Internet.

7. Enter any comments you have for the route.
8. Click Create orOK.

Configuring DNS

FortiVoice systems require DNS servers for features such as reverse DNS lookups. Your ISP may supply IP addresses
of DNS servers, or you may want to use the IP addresses of your own DNS servers.

For improved FortiVoice system performance, use DNS servers on your local network.

The DNS tab lets you configure the DNS servers that the FortiVoice system queries to resolve domain names into IP
addresses.
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To configure the primary and secondary DNS servers

1. Go to System > Network > DNS.
2. In Primary DNS server, enter the IP address of the primary DNS server.
3. In Secondary DNS server, enter the IP address of the secondary DNS server.
4. Click Apply.

Configuring DHCP server

A DHCP server provides an address to a client on the network, when requested, from a defined address range.

You can configure one or more DHCP servers on any FortiVoice interface. A DHCP server dynamically assigns IP
addresses to the clients on the network connected to the interface. These clients must be configured to obtain their IP
addresses using DHCP.

To configure the DHCP server

1. Go to System > Network > DHCP.
2. Click New and configure the following:

GUI field Description

Network Interface Setting

ID The system will generate an ID for this configuration. This is view only.

Enable Select to enable the DHCP server.

Interface If this FortiVoice is in HA mode, make sure that the secondary system has the
same interface as the primary system. For information on HA, see Using high
availability on page 57.

Gateway Enter the IP address of the default gateway that the DHCP server assigns to
DHCP clients.

DNS options Select to use either a specific DNS server or the system’s DNS settings.
If you select a specific DNS server, enter the Primary DNS server and the
Secondary DNS server fields.
For more information, see Configuring DNS on page 48.

Domain Enter the domain that the DHCP server assigns to its clients.

Netmask Enter the netmask of the addresses that the DHCP server assigns.

Advanced Setting

Lease time (Seconds) Enter the length of time an IP address remains assigned to a client. Once the
lease expires, the address is released for allocation to the next client request
for an IP address. The default time is 604800 seconds.

Vender Class Identifier
option

Select this option to apply the DHCP configuration to the phones of a specific
vendor identified by the VCI string supplied by the vendor or by checking
Monitor > PBX Status > DHCP > VCI.
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GUI field Description

VCI string Enter the phone VCI string supplied by the vendor.

Option 66

DHCP IP Range Enter the start and end for the range of IP addresses that this DHCP server
assigns to the DHCP clients.

DHCP Excluded IP
Range

Enter a range of IP addresses that this server should not assign to the DHCP
clients.

Reserved IP Address Enter an IP address from the DHCP server to match it to a specific client using
its MAC address.
In a typical situation, an IP address is assigned ad hoc to a client, and that
assignment times out after a specific time of inactivity from the client, known as
the lease time. To ensure a client always has the same IP address, that is,
there is no lease time, use this option.

3. Click Create.

Capturing voice and fax packets

When troubleshooting networks, it helps to look inside the contents of the packets. This helps to determine if the packets,
route, and destination are all what you expect. Traffic capture can also be called packet sniffing, a network tap, or logic
analyzing.

Packet sniffing tells you what is happening on the network at a low level. This can be very useful for troubleshooting
problems, such as:

l Finding missing traffic.
l Seeing if sessions are setting up properly.
l Locating ARP problems such as broadcast storm sources and causes.
l Confirming which address a computer is using on the network if they have multiple addresses or are on multiple
networks.

l Confirming routing is working as you expect.
l Intermittent missing PING packets.

If you are running a constant traffic application such as ping, packet sniffing can tell you if the traffic is reaching the
destination, how the port enters and exits the FortiVoice system, if the ARP resolution is correct, and if the traffic is
returning to the source as expected. You can also use packet switching to verify that NAT or other configuration is
translating addresses or routing traffic the way that you want it to.

Before you start sniffing packets, you need to have a good idea of what you are looking for. Sniffing is used to confirm or
deny your ideas about what is happening on the network. If you try sniffing without a plan to narrow your search, you
could end up with too much data to effectively analyze. On the other hand, you need to sniff enough packets to really
understand all of the patterns and behavior that you are looking for.
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To capture voice and fax packets

1. Go to System > Network > Traffic Capture.

GUI field Description

Stop Click to stop the packet capture.

Download When the capture is complete, click Download to save the packet capture file
to your hard disk for further analysis.

Name The name of the packet capture file.

Size The size of the packet capture file.

Status The status of the packet capture process, Complete or Running.

2. Click New.
3. Enter a prefix for the file generated from the captured traffic. This will make it easier to recognize the files.
4. Enter the time period for performing the packet capture.
5. For SIP Connection, do the following:

l In the Peers field, click + to add the extension or trunk of which you want to capture the voice packets. You can
select up to 3 peers.

l If you want to limit the scope of traffic capture, in the IP/HOST field, enter a maximum of 3 IP addresses or host
names for the extensions and trunks you selected. Only traffic on these IP addresses or host names is
captured.

6. Select the filter for the traffic capture:
l SIP: Only SIP traffic of the peers you select will be captured.
l Use protocol: Only UDP or TCP traffic of the peers you select will be captured.
l Capture all: All network traffic will be captured.

7. For Exclusion, enter the IP addresses/host names and port numbers of which you do not want to capture voice
traffic.

8. Click Create.

Configuring administrator accounts and access profiles

The Administrator submenu configures administrator accounts and access profiles.

This topic includes:

l Configuring administrator accounts on page 51
l Configuring administrator profiles on page 54

Configuring administrator accounts

The Administrator tab displays a list of the FortiVoice system’s administrator accounts and the trusted host IP addresses
administrators use to log in (if configured).

By default, FortiVoice systems have a single administrator account, admin. For more granular control over
administrative access, you can create additional administrator accounts with restricted permissions.
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To view and configure administrator accounts

1. Go to System > Administrator > Administrator.

GUI field Description

Enabled Displays the administrator status.

Name Displays the name of the administrator account.

Admin Profile The administrator profile that determines which functional areas the
administrator account may view or affect.

Authentication Type The administrator authentication type: Local or LDAP.

Authentication Profile The LDAP authentication profile. For more information, see Configuring LDAP
profiles on page 132.

Trusted Hosts Displays the IP address and netmask from which the administrator can log in.

2. Either click New to add an account or double-click an account to modify it.
A dialog appears.

3. Configure the following:

GUI field Description

Enable Click to activate the administrator status. By default, this is enabled.

Administrator Enter the name for this administrator account.
The name can contain numbers (0-9), uppercase and lowercase letters
(A-Z, a-z), hyphens ( - ), and underscores ( _ ). Other special characters and
spaces are not allowed.

Email address Enter the administrator’s email address.

Single sign-on manager Select the extension for the administrator account.
If you add an extension, a User portal icon appears at the top of the GUI when
you log into the FortiVoice system. Clicking the icon opens the user portal.
Click Edit to modify the selected extension or click New to configure a new one.
For more information on extensions, see Configuring IP extensions on page
162.

Admin profile Select the name of an admin profile that determines which functional areas the
administrator account may view or affect.
Click New to create a new profile or Edit to modify the selected profile. For
details, see Configuring administrator profiles on page 54.

Authentication type Select an administrator authentication type: Local or LDAP.

Change password Enter this account’s password.
The password can contain any character except spaces.
This field does not appear if Authentication type is LDAP.
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GUI field Description

Do not enter a FortiVoice administrator password less than
six characters long. For better security, enter a longer
password with a complex combination of characters and
numbers, and change the password regularly. Failure to
provide a strong password could compromise the security of
your FortiVoice system.

Confirm password Enter this account’s password again to confirm it.
This field does not appear if Authentication type is LDAP.

LDAP profile If you select LDAP for Authentication type, select an LDAP authentication
profile. For more information, see Configuring LDAP profiles on page 132.

Trusted hosts type Select a trusted host type:
l User defined: Add details about the hosts in Trusted hosts.
l RFC 1918 predefined: FortiVoice allows connections from any private IP
addresses specified by the request for comment 1918 (RFC 1918).

Trusted Hosts Enter an IPv4 or IPv6 address or subnet from which this administrator can log
in.
If you want the administrator to access the FortiVoice system from any IP
address, use 0.0.0.0/0.0.0.0.
Enter the IP address and netmask in dotted decimal format. For example, you
might permit the administrator to log in to the FortiVoice system from your
private network by typing 192.168.1.0/255.255.255.0.

For additional security, restrict all trusted host entries to
administrative hosts on your trusted private network. For
example, if your FortiVoice administrators log in only from the
10.10.10.10/24 subnet, to prevent possibly fraudulent login
attempts from unauthorized locations, you could configure
that subnet in the Trusted Host #1, Trusted Host #2, and
Trusted Host #3 fields.

For information on restricting administrative access protocols
that can be used by these hosts, see Editing network
interfaces on page 45.

Click the + sign to add additional IP addresses or subnets from which the
administrator can log in.

Select language Select this administrator account’s preference for the display language of the
GUI.

Select theme Select this administrator account’s preference for the display theme or click
Use Current to choose the theme currently in effect.
The administrator may switch the theme at any time during a session by
clicking Next Theme.
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GUI field Description

Department only Select the checkbox if this is a department administrator.

Description Select Edit to enter any comments for the administrator account.

Departments Select the department to which the administrator belongs.
This option is only available if you select Department only.

4. Click Create.

Configuring administrator profiles

The Admin Profile tab displays a list of administrator access profiles.

Administrator profiles govern which areas of the GUI and CLI that an administrator can access, and whether or not they
have the permissions necessary to change the configuration or otherwise modify items in each area.

To configure administrator access profiles

1. Go to System > Administrator > Admin Profile.
2. Either click New to add an account or double-click an access profile to modify it.
3. In Profile name, enter the name for this access profile.
4. For each access control option, select the permissions to be granted to administrator accounts associated with this

access profile:
l None
l Read Only
l Read-Write

5. Click Create.

Configuring RAID

If your FortiVoice systemmodel supports RAID, go to System > RAID to configure a redundant array of independent
disks (RAID) for the FortiVoice system hard disks that are used to store logs and voice data.

FVE-2000F, 3000F, 3000E, and 5000F can be configured to use RAID with their hard disks. The default RAID level
should give good results, but you can modify the configuration to suit your individual requirements for enhanced
performance and reliability. For more information, see Configuring RAID on page 55.

RAID events can be logged and reported with alert email. These events include disk full and disk failure notices. For
more information, see About FortiVoice logging on page 297, and Configuring alert email on page 310.

If your FortiVoice systemmodel does not support RAID, the RAIDmenu won’t be displayed.
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About RAID levels

The FortiVoice models supporting RAID use hardware RAID controllers that require that the log disk and voice disk use
the same RAID level.

Each of the models has 2 factory-installed hard drives. The available RAID levels are 0 and 1 and the default is 1. You
can replace a hard drive if required. For details, see Replacing a RAID disk on page 56.

Configuring RAID

You can modify the RAID level configuration to suit you individual requirements for enhanced performance and
reliability.

To configure RAID

1. Go to System > RAID > RAID System.

GUI item Description

Model Displays the type of the RAID controller.

Rescan Click to rebuild the RAID unit with disks that are currently a member of it, or
detect newly added hard disks, and start a diagnostic check.

Driver Displays the version of the RAID controller’s driver software.

Firmware Displays the version of the RAID controller’s firmware.

List of RAID units in the array

Device Displays the name of the RAID unit. This indicates whether it is used for voice
data or log message data. This is hard-coded and not configurable.

Unit Indicates the identifier of the RAID unit, such as u0.

Level Indicates the RAID level currently in use. You may change the level.
For more information, see About RAID levels on page 55.

Status Indicates the status of the RAID unit.
l OK: The RAID unit is operating normally.
l Warning: The RAID controller is currently performing a background task
(rebuilding, migrating, or initializing the RAID unit).

Do not remove hard disks while this status is displayed.
Removing active hard disks can cause hardware damage.

l Error: The RAID unit is degraded or inoperable. Causes vary, such as
when too many hard disks in the unit fail and the RAID unit no longer has
the minimum number of disks required to operate in your selected RAID
level. To correct such a situation, replace the failed hard disks.

l No Units: No RAID units are available.
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GUI item Description

If both Error andWarning conditions exist, the status
appears as Error.

Size Indicates the total disk space, in gigabytes (GB), available for the RAID unit.
Available space varies by your RAID level selection. Due to some space being
consumed to store data required by RAID, available storage space will not
equal the sum of the capacities of hard disks in the unit.

Speed Displays the average speed in kilobytes (KB) per second of the data transfer
for the resynchronization. This is affected by the disk being in use during the
resynchronization.

Apply Click to save changes.

List of hard disks in the array

ID/Port Indicates the identifier of each hard disk visible to the RAID controller.

Part of Unit Indicates the RAID unit to which the hard disk belongs, if any.
To be usable by the FortiVoice system, you must add the hard disk to a RAID
unit.

Status Indicates the hardware viability of the hard disk.
l OK: The hard disk is operating normally.
l UNKNOWN: The viability of the hard disk is not known. Causes vary,
such as the hard disk not being a member of a RAID unit. In such a case,
the RAID controller does not monitor its current status.

Size Indicates the capacity of the hard disk, in gigabytes (GB).

Delete Click to unmount a hard disk before swapping it.
After replacing the disk, add it to a RAID unit, then click Rescan.

To change RAID levels

Back up data on the disk before beginning this procedure. Changing the device’s RAID level
temporarily suspends all mail processing and erases all data on the hard disk. For more
information on creating a backup, see Backing up configuration on page 103.

1. Go to System > RAID > RAID System.
2. From Level, select a RAID level.
3. Click Apply.

The FortiVoice system changes the RAID level and reboots.

Replacing a RAID disk

When replacing a disk in the RAID array, the new disk must have the same or greater storage capacity than the existing
disks in the array. If the new disk has a larger capacity than the other disks in the array, only the amount equal to the
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smallest hard disk will be used. For example, if the RAID has 400 GB disks, and you replace one with a 500 GB disk, to
be consistent with the other disks, only 400 GB of the new disk will be used.

FortiVoice systems support hot swap; shutting down the FortiVoice system during hard disk replacement is not required.

To replace a disk in the array

1. Go to System > RAID > RAID System.
2. In the row corresponding to the hard disk that you want to replace (for example, p4), select the hard disk and click

Delete.
The RAID controller removes the hard disk from the list.

3. Protect the FortiVoice system from static electricity by using measures such as applying an antistatic wrist strap.
4. Physically remove the hard disk that corresponds to the one you removed in the GUI from its drive bay on the

FortiVoice system.
5. Replace the hard disk with a new hard disk, inserting it into its drive bay on the FortiVoice system.
6. Click Rescan.

The RAID controller will scan for available hard disks and should locate the new hard disk. Depending on the RAID
level, the FortiVoice systemmay either automatically add the new hard disk to the RAID unit or allocate it as a spare
that will be automatically added to the array if one of the hard disks in the array fails.
The FortiVoice system rebuilds the RAID array with the new hard disk. Time required varies by the size of the array.

Using high availability

Go to System > High Availability to configure the FortiVoice system to act as a high availability (HA) member in order to
increase availability.

For the general procedure of how to enable and configure HA, see Enabling and configuring HA on page 60.

This section contains the following topics:

l About high availability on page 57
l About the heartbeat and synchronization on page 58
l Enabling and configuring HA on page 60
l Monitoring the HA status on page 61
l Configuring service-based monitoring on page 68
l Failover scenario examples: on page 70

About high availability

FortiVoice systems operate in an active-passive HA mode which has the following features:

l Two FortiVoice systems are in the HA group.
l Both configuration and data are synchronized (For exceptions to synchronized configuration items, see
Unsynchronized HA settings on page 59.)

l Only the primary system processes phone calls.
l There is no data loss when the hardware fails although active calls are disconnected and line appearance and
extension appearance take time to restore.

l Both FortiVoice systems have failover protection, but no increased processing capacity.
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Active-passive HA group

Same FortiVoice models must be used in the same HA group. All systems in the HA group must have the same firmware
version with the same hardware.

Communications between HAmembers occur through the heartbeat and synchronization connection. For details, see
About the heartbeat and synchronization on page 58.

To configure FortiVoice systems operating in HA mode, you usually connect only to the primary system. The primary
system’s configuration is almost entirely synchronized to secondary systems (slave), so that changes made to the
primary system are propagated to the secondary systems.

Exceptions to this rule include connecting to a secondary system in order to view log messages recorded about the
secondary system itself on its own hard disk, and connecting to a secondary system to configure settings that are not
synchronized. For details, see Unsynchronized HA settings on page 59.

For instructions of how to enable and configure HA, see Enabling and configuring HA on page 60.

About the heartbeat and synchronization

Heartbeat and synchronization traffic consists of TCP packets transmitted between the FortiVoice systems in the HA
group through the primary and secondary heartbeat interfaces.

Service monitoring traffic can also, for short periods, be used as a heartbeat. For details, see
Remote services as heartbeat on page 66.

Heartbeat and synchronization traffic has three primary functions:

l To monitor the responsiveness of the HA group members.
l To synchronize configuration changes from the primary system to the secondary systems.
For exceptions to synchronized configuration items, see Unsynchronized HA settings on page 59.

l To synchronize system and user data from the primary system to the secondary system.
Call data consists of the FortiVoice call detailed records, recorded calls, voicemail, call directories, fax, and voice
prompts.
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When the primary system’s configuration changes, it immediately synchronizes the change to the secondary system
through the primary heartbeat interface. If this fails, or if you have inadvertently de-synchronized the secondary system’s
configuration, you can manually initiate synchronization. For details, see Click HERE to Start a Configuration/Data Sync
on page 62. You can also use the CLI command diagnose system ha sync on either the primary system or the
secondary system to manually synchronize the configuration.

During normal operation, the secondary system expects to constantly receive heartbeat traffic from the primary system.
Loss of the heartbeat signal interrupts the HA group and generally triggers a failover. For details, see Failover scenario
1: Temporary failure of the primary system on page 70.

Exceptions include system restarts and the execute reload CLI command. In case of a system reboot or reload of
the primary system, the primary system signals the secondary system to wait for the primary system to complete the
restart or reload. For details, see Failover scenario 2: System reboot or reload of the primary system on page 72.

Periodically, the secondary system checks with the primary system to see if there are any configuration changes on the
primary system. If there are configuration changes, the secondary system will pull the configuration changes from the
primary system, generate a new configuration, and reload the new configuration. In this case, both the primary and
secondary systems can be configured to send alert email. For details, see Failover scenario 3: System reboot or reload
of the secondary system on page 72 and Configuring alert email on page 310.

Unsynchronized HA settings

All configuration settings on the primary system are synchronized to the secondary system, except the following:

GUI item Description

Host name The host name distinguishes members of the cluster.

Static route Static routes are not synchronized because the HA systems may be in different networks (see
Configuring static routes on page 47).

Interface
configuration

Each FortiVoice system in the HA group must be configured with different network interface
settings for connectivity purposes. For details, see Configuring the network interfaces on
page 44.
Exceptions include some active-passive HA settings which affect the interface configuration
for failover purposes. These settings are synchronized.

Main HA
configuration

The main HA configuration, which includes the HA mode of operation (such asmaster or
slave), is not synchronized because this configuration must be different on the primary and
secondary systems. For details, see Configuring the HA mode and group on page 63.

HA service
monitoring
configuration

In active-passive HA, the HA service monitoring configuration is not synchronized. The remote
service monitoring configuration on the secondary system controls how the secondary system
checks the operation of the primary system. The local services configuration on the primary
system controls how the primary system tests the operation of the primary system. For details,
see Configuring service-based monitoring on page 68.
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GUI item Description

You might want to have a different service monitoring configuration on
the primary and secondary systems. For example, after a failover you
may not want service monitoring to operate until you have fixed the
problems that caused the failover and have restarted normal operation of
the HA group.

System appearance The appearance settings you configured under System > Configuration > Appearance are not
synchronized.

Synchronization after a failover

During normal operation, extensions are in one of two states:

l registered and idle
l active call

When a failover occurs, active calls are interrupted and users have to reinitiate the calls. However, registered idle
extensions can still make and receive phone calls without being affected.

When a failover is corrected, one of the following occurs automatically:

1. The secondary system detects the failure of the primary system, and becomes the new primary system.
2. The former primary system restarts, detects the new primary system, and becomes a secondary system.

You may have to manually restart the failed primary system.

Enabling and configuring HA

In general, to enable and configure HA, you should perform the following:

1. Physically connect the FortiVoice systems that will be members of the HA group.
You must connect at least one of their network interfaces for heartbeat and synchronization traffic between
members of the group. For reliability reasons, Fortinet recommends that you connect both a primary and a
secondary heartbeat interface, and that they be connected directly or through a dedicated switch that is not
connected to your overall network.

2. On each member of the group:
l Enable the HA mode that you want to use and select whether the individual member will act as a primary
system or secondary system. For information about the differences between the HA modes, see About high
availability on page 57.

l Configure the local IP addresses of the primary and secondary heartbeat and synchronization network
interfaces.

l Configure a virtual IP address that is shared by the HA group and remains the same after a failover. The virtual
IP address is used to auto-provision the server IP address and the SIP trunk client IP address.

l Configure the behavior on failover, and how the network interfaces should be configured for whichever
FortiVoice system is currently acting as the primary system.
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3. If you want to trigger failover when hardware or a service fails, even if the heartbeat connection is still functioning,
configure service monitoring. For details, see Configuring service-based monitoring on page 68.

4. Monitor the status of each group member. For details, see Monitoring the HA status on page 61. To monitor HA
events through log messages and/or alert email, you must first enable logging of HA activity events. For details, see
Configuring logging on page 299.

Monitoring the HA status

The Status tab in the High Availability submenu shows the configured HA mode of operation of a FortiVoice system in an
HA group. You can also manually initiate synchronization and reset the HA mode of operation. A reset may be required if
a FortiVoice system’s effective HA mode of operation differs from its configured HA mode of operation, such as after a
failover when a configured primary system is currently acting as a secondary system.

For FortiVoice systems operating as secondary systems, the Status tab also lets you view the status and schedule of the
HA synchronization daemon.

Before you can use the Status tab, you must first enable and configure HA. For details, see Enabling and configuring HA
on page 60.

To view the HA mode of operation status, go to System > High Availability > Status.

GUI item Description

HA Status Select a time interval for refreshing the HA status page. You can also manually
update the page by clicking Refresh.

Mode Status

Configured Operating
Mode

Displays the HA operating mode that you configured, either:
l master: Configured to be the primary system of an active-passive group.
l slave: Configured to be the secondary system of an active-passive group.

For information on configuring the HA operating mode, see Mode of operation on
page 64.
After a failure, the FortiVoice systemmay not be acting in its configured HA
operating mode. For details, see Effective Operating Mode on page 61.

Effective Operating Mode Displays the mode that the system is currently operating in, either:
l master: Acting as primary system.
l slave: Acting as secondary system.
l off: For primary systems, this indicates that service/interface monitoring has
detected a failure and has taken the primary system offline, triggering
failover. For secondary systems, this indicates that synchronization has
failed once; a subsequent failure will trigger failover. For details, see On
failure on page 64.

l failed: Service/network interface monitoring has detected a failure and the
diagnostic connection is currently determining whether the problem has been
corrected or failover is required. For details, see On failure on page 64.

The configured HA operating mode matches the effective operating mode unless
a failure has occurred.
For example, after a failover, a FortiVoice system configured to operate as a
secondary system could be acting as a primary system.
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GUI item Description

For explanations of combinations of configured and effective HA modes of
operation, see Combinations of configured and effective HA modes of operation
on page 63.
For information on restoring the FortiVoice system to an effective HA operating
mode that matches the configured operating mode, see Click HERE to Restore
Configured Operating Mode on page 62.

Daemon Status This option appears only for secondary systems in active-passive HA groups.

Monitor Displays the time at which the secondary system’s HA daemon will check to make
sure that the primary system is operating correctly, and, if monitoring has
detected a failure, the number of times that a failure has occurred.
Monitoring occurs through the heartbeat link between the primary and secondary
systems. If the heartbeat link becomes disconnected, the next time the secondary
system checks for the primary system, the primary system will not respond. If the
maximum number of consecutive failures is reached, and no secondary heartbeat
or remote service monitoring heartbeat is available, the secondary system will
change its effective HA operating mode to become the new primary system.
For details, see HA base port on page 65.

Configuration Displays the time at which the secondary system’s HA daemon will synchronize
the FortiVoice configuration from the primary system to the secondary system.
The message slave unit is currently synchronizing appears when
the HA daemon is synchronizing the configuration.
For information on items that are not synchronized, see Unsynchronized HA
settings on page 59.

Data Displays the time at which the secondary system HA daemon will synchronize
mail data from the primary system to the secondary system.
The message slave unit is currently synchronizing appears when
the HA daemon is synchronizing data.

Actions

Click HERE to Start a
Configuration/Data Sync

Click to manually initiate synchronization of the configuration and call data. For
information on items that are not synchronized, see Unsynchronized HA settings
on page 59.

Click HERE to Restore
Configured Operating
Mode

Click to reset the FortiVoice system to an effective HA operating mode that
matches the FortiVoice system’s configured operating mode.
For example, for a configured primary system whose effective HA operating mode
is now slave, after correcting the cause of the failover, you might click this option
on the primary system to restore the configured primary system to active duty,
and restore the secondary system to its secondary role.

If the effective HA operating mode has changed due to a
failover, make sure to resolve any issues that caused the
failover before selecting this option.
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Combinations of configured and effective HA modes of operation

Configured
operating mode

Effective
operating mode

Description

master master Normal for the primary system of an active-passive HA group.

slave slave Normal for the secondary system of an active-passive HA group.

master off The primary system has experienced a failure, or the FortiVoice
system is in the process of switching to operating in HA mode.
HA processes and call processing are stopped.

slave off The secondary system has detected a failure, or the FortiVoice
system is in the process of switching to operating in HA mode.
After the secondary system starts up and connects with the primary
system to form an HA group, the first configuration synchronization
may fail in special circumstances. To prevent both the secondary and
primary systems from simultaneously acting as primary systems, the
effective HA mode of operation becomes off. If subsequent
synchronization fails, the secondary system’s effective HA mode of
operation becomesmaster.

master failed The remote service monitoring or local network interface monitoring
on the primary system has detected a failure, and will attempt to
connect to the other FortiVoice system. If the problem that caused the
failure has been corrected, the effective HA mode of operation
switches from failed to slave, or to match the configured HA mode of
operation, depending on theOn failure setting.

master slave The primary system has experienced a failure but then returned to
operation. When the failure occurred, the system configured to be the
secondary system became the primary system. When the system
configured to be the primary system restarted, it detected the new
primary system and so switched to operating as the secondary
system.

slave master The secondary system has detected that the FortiVoice system
configured to be the primary system failed. When the failure occurred,
the system configured to be the secondary system became the
primary system.

Configuring the HA mode and group

The Configuration tab in the System > High Availability submenu lets you configure the high availability (HA) options,
including:

l enabling HA
l whether this individual FortiVoice system will act as a primary system or a secondary system in the group
l network interfaces that will be used for heartbeat and synchronization and virtual IP
l service monitor
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HA settings , with the exception of Virtual IP Address settings, are not synchronized and must be configured separately
on each primary and secondary system.

You must maintain the physical link between the heartbeat and synchronization network interfaces. These connections
enable a group member to detect the responsiveness of the other member, and to synchronize data. If they are
interrupted, normal operation will be interrupted and a failover will occur. For more information on heartbeat and
synchronization, see About the heartbeat and synchronization on page 58.

You can directly connect the heartbeat network interfaces of two FortiVoice systems using a crossover Ethernet cable.

To configure HA options

1. Go to System > High Availability > Configuration.
2. Configure the following sections, as applicable:

l Configuring the primary HA options on page 64
l Configuring HA advanced options on page 65
l Configuring interface monitoring on page 67
l Configuring service-based monitoring on page 68

3. Click Apply.

Configuring the primary HA options

Go to System > High Availability > Configuration and click the arrow to expand the HA Configuration section, if needed.

GUI field Description

Mode of operation Enables or disables HA, and selects the initial configured role this FortiVoice
system in the HA group.
l Off: The FortiVoice system is not operating in HA mode.
l Master: The FortiVoice system is the primary system in an active-passive HA
group.

l Slave: The FortiVoice system is the secondary system in an active-passive
HA group.

On failure Select one of the following behaviors of the primary system when it detects a
failure, such as on a power failure or from service/interface monitoring.
l Switch Off: Do not process phone calls or join the HA group until you
manually select the effective operating mode (see Click HERE to Start a
Configuration/Data Sync on page 62 and Click HERE to Restore Configured
Operating Mode on page 62).

l Wait for Recovery Then Restore Original Role: On recovery, the failed
primary system's effective HA mode of operation resumes its configured
primary role. This also means that the secondary system needs to give back
the primary role to the primary system. This behavior may be useful if the
cause of failure is temporary and rare, but may cause problems if the cause of
failure is permanent or persistent.

l Wait for Recovery Then Restore Slave Role: On recovery, the failed primary
system’s effective HA mode of operation becomes slave, and the secondary
system continues to assume themaster role. The primary system then
synchronizes with the current primary system. The new primary system can
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GUI field Description

then deliver phone calls. For information on manually restoring the FortiVoice
system to acting in its configured HA mode of operation, see Click HERE to
Restore Configured Operating Mode on page 62.

In most cases, you should select theWait for Recovery Then Restore Slave Role
option.
For details on the effects of this option on the Effective Operating Mode, see
Combinations of configured and effective HA modes of operation on page 63. For
information on configuring service/interface monitoring, see Configuring service-
based monitoring on page 68.
This option appears only if Mode of operation on page 64 ismaster.

Shared password Enter an HA password for the HA group. You must configure the same Shared
password value on both the primary and secondary systems.

Configuring HA advanced options

Go to System > High Availability > Configuration > Advanced Options.

GUI item Description

HA base port Keep the default TCP port number (20000) that will be used for:
l the heartbeat signal
l synchronization control
l data synchronization
l configuration synchronization

In addition to configuring the heartbeat, you can configure
service monitoring. For details, see Configuring service-based
monitoring on page 68.

In addition to automatic immediate and periodic configuration
synchronization, you can also manually initiate synchronization.
For details, see Click HERE to Start a Configuration/Data Sync
on page 62.

Heartbeat lost threshold Enter the total span of time, in seconds, for which the primary system can be
unresponsive before it triggers a failover and the secondary system assumes the
role of the primary system.
The heartbeat will continue to check for availability once per second. To prevent
premature failover when the primary system is simply experiencing very heavy
load, configure a total threshold of three (3) seconds or more to allow the
secondary system enough time to confirm unresponsiveness by sending
additional heartbeat signals.
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GUI item Description

If the failure detection time is too short, the secondary system
may falsely detect a failure during periods of high load.

If the failure detection time is too long, the primary system could
fail and a delay in detecting the failure could mean that a call is
delayed or lost. Decrease the failure detection time if a call is
delayed or lost because of an HA failover.

Remote services as heartbeat Enable to use remote service monitoring as a secondary HA heartbeat. If enabled
and both the primary and secondary heartbeat links fail or become disconnected,
and remote service monitoring still detects that the primary system is available, a
failover will not occur.

The remote service check is only applicable for temporary
heartbeat link fails. If the HA process restarts due to system
reboot or HA daemon reboot, then physical heartbeat
connections will be checked first. If physical connections are
not found, the remote service monitoring does not take effect
anymore.

Using remote services as heartbeat provides HA heartbeat
only, not synchronization. To avoid synchronization problems,
you should not use remote service monitoring as a heartbeat for
extended periods. This feature is intended only as a temporary
heartbeat solution that operates until you reestablish a normal
primary or secondary heartbeat link.

Call recording sync Select to sync recorded calls.

Survivability service interface Select the interface port for a local survivable gateway (LSG) to communicate with
this FortiVoice system.
In an LSG setup, when the central FortiVoice HA is enabled without a virtual IP,
the primary and secondary systems need to identify their service interface ports
for the LSG to communicate with them.
For more information about LSG, see FortiVoice Local Survivable Gateway
Deployment Guide.
In any other cases, this value is ignored by the system.

Primary Override External
Media Host

Enter the host/IP address to override the default external host/IP address for
media stream on the primary HA system.

Secondary Override External
Media Host

Enter the host/IP address to override the default external host/IP address for
media stream on the secondary HA system.
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Configuring interface monitoring

Interface monitor checks the local interfaces on the primary system. If a malfunctioning interface is detected, a failover
will be triggered.

To configure interface monitoring

1. Go to System > High Availability > Configuration.
2. Select master or slave as the mode of operation.
3. Expand the Interface area, if required.

The interface IP address must be different from, but on the same subnet as, the IP address
of the other heartbeat network interface of the other member in the HA group.
When configuring the other FortiVoice system in the HA group, use this value as the
remote peer IP.

4. Select a row in the table and click Edit to configure the following HA settings on the interface.

GUI item Description

Port Displays the interface name you’re configuring.

Enable port
monitor

Enable to monitor a network interface for failure. If the port fails, the primary system will trigger
a failover.

Heartbeat
status

Specify if this interface will be used for HA heartbeat and synchronization.
l Disable

Do not use this interface for HA heartbeat and synchronization.
l Primary

Select the primary network interface for heartbeat and synchronization traffic. For more
information, see About the heartbeat and synchronization on page 58.
This network interface must be connected directly or through a switch to the Primary
heartbeat network interface of the other member in the HA group.

l Secondary
Select the secondary network interface for heartbeat and synchronization traffic. For
more information, see About the heartbeat and synchronization on page 58.
The secondary heartbeat interface is the backup heartbeat link between the systems in
the HA group. If the primary heartbeat link is functioning, the secondary heartbeat link is
used for the HA heartbeat. If the primary heartbeat link fails, the secondary link is used
for the HA heartbeat and for HA synchronization.
This network interface must be connected directly or through a switch to the Secondary
heartbeat network interfaces of the other member in the HA group.

Using the same network interface for both HA synchronization/heartbeat
traffic and other network traffic could result in issues with heartbeat and
synchronization during times of high traffic load, and is not
recommended.
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GUI item Description

In general, you should isolate the network interfaces that are used for he
artbeat traffic from your overall network. Heartbeat and synchronization p
ackets contain sensitive configuration information, are latency-sensitive,
and can consume considerable network bandwidth.

Peer IP address Enter the IP address of the matching heartbeat network interface of the other member of the
HA group.
For example, if you are configuring the primary system’s primary heartbeat network interface,
enter the IP address of the secondary system’s primary heartbeat network interface.
Similarly, for the secondary heartbeat network interface, enter the IP address of the other
system’s secondary heartbeat network interface.
For information about configuration synchronization and what is not synchronized, see About
the heartbeat and synchronization on page 58.

Peer IPv6
address

Enter the peer IPv6 address for this interface.

Virtual IP action Select whether and how to configure the IP addresses and netmasks of the FortiVoice system
whose effective HA mode of operation is currentlymaster.
For example, a primary systemmight be configured to receive phone call traffic through port1
and receive heartbeat and synchronization traffic through port3 and port4. In that case, you
would configure the primary system to set the IP addresses or add virtual IP addresses for
port1 of the secondary system on failover in order to mimic that of the primary system.
l Ignore: Do not change the network interface configuration on failover, and do not monitor.
For details on service monitoring for network interfaces, see Configuring service-based
monitoring on page 68.

l Use: Add the specified virtual IP address and netmask to the network interface on
failover. Normally, you will configure your network so that clients use the virtual IP
address. This option results in the network interface having two IP Addresses: the actual
and the virtual.

Virtual IP
address

Enter the virtual IPv4 address for this interface.

Virtual IPv6
address

Enter the virtual IPv6 address for this interface.

5. ClickOK.

Configuring service-based monitoring

Go to System > High Availability > Configuration to configure remote service monitoring, local network interface
monitoring, and local hard drive monitoring.

HA service monitoring settings are not synchronized and must be configured separately on each primary and secondary
system.

With remote service monitoring, the secondary system confirms that it can connect to the primary system over the
network using SIP and HTTP connections.
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With local network interface monitoring and local hard drive monitoring, the primary systemmonitors its own network
interfaces and hard drives.

If service monitoring detects a failure, the effective HA operating mode of the primary system switches to off or failed
(depending on theOn failure setting). A failover then occurs, and the effective HA operating mode of the secondary
system switches tomaster. For information on theOn failure option, see Configuring the HA mode and group on page
63. For information on the effective HA operating mode, see Monitoring the HA status on page 61.

To configure service monitoring

1. Go to System > High Availability > Configuration.
2. Select master or slave as the mode of operation.
3. Expand Service Monitor, if required.
4. Select a row in the table and click Edit to configure it.
5. For Remote HTTP, configure the following:

GUI item Description

Enable Select to enable connection responsiveness tests for SMTP.

Name Displays the service name.

Remote IP Enter the peer IP address.

Port Enter the port number of the peer SMTP service.

Timeout Enter the timeout period for one connection test.

Interval Enter the frequency of the tests.

Retries Enter the number of consecutively failed tests that are allowed before the primary system is
deemed unresponsive and a failover occurs.

6. For SIP UDP, configure the following:

GUI Item Description

Enable Select to enable SIP UDP service.

Name Displays the service name.

Remote IP Enter the peer IP address.

Port Enter the port number of the peer SIP UDP service.

Timeout Enter the timeout period for one connection test.

Interval Enter the frequency of the tests.

Retries Enter the number of consecutively failed tests that are allowed before the primary system is
deemed unresponsive and a failover occurs.

7. For Interface monitor and Local hard drives, configure the following:

GUI item Description

Enable Select to enable local hard drive monitoring. Interface monitoring is enabled when you
configure interface monitoring. See Configuring interface monitoring on page 67.
Network interface monitoring tests all active network interfaces whose:
l Virtual IP action on page 68 setting is not Ignore

FortiVoice Phone System 6.0.12 Administration Guide 69
Fortinet Inc.



Configuring system settings

GUI item Description
l Configuring interface monitoring on page 67 setting is enabled

Interval Enter the frequency of the test.

Retries Specify the number of consecutively failed tests that are allowed before the local interface or
hard drive is deemed unresponsive and a failover occurs.

Failover scenario examples:

This section describes basic FortiVoice active-passive HA failover scenarios. For each scenario, refer to the HA group
shown in Example active-passive HA group on page 70. To simplify the descriptions of these scenarios, the following
abbreviations are used:

l P1 is the configured primary system.
l S2 is the configured secondary system.

Example active-passive HA group

This section contains the following HA failover scenarios:

l Failover scenario 1: Temporary failure of the primary system on page 70
l Failover scenario 2: System reboot or reload of the primary system on page 72
l Failover scenario 3: System reboot or reload of the secondary system on page 72
l Failover scenario 4: System shutdown of the secondary system on page 73
l Failover scenario 5: Primary heartbeat link fails on page 73
l Failover scenario 6: Network connection between primary and secondary systems fails (remote service monitoring
detects a failure) on page 74

Failover scenario 1: Temporary failure of the primary system

In this scenario, the primary system (P1) fails because of a software failure or a recoverable hardware failure (in this
example, the P1 power cable is unplugged). HA logging and alert email are configured for the HA group.
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When the secondary system (S2) detects that P1 has failed, S2 becomes the new primary system and continues
processing phone calls.

There is no data loss when failover happens although active calls are disconnected and line appearance and extension
appearance take time to restore. Call data consists of the FortiVoice call detailed records, recorded calls, voicemail, call
directories, fax, and voice prompts. The user portal is not affected.

Here is what happens during this process:

1. The FortiVoice HA group is operating normally.
2. The power is accidentally disconnected from P1.
3. S2’s heartbeat test detects that P1 has failed.

How soon this happens depends on the HA daemon configuration of S2.
4. The effective HA operating mode of S2 changes tomaster.
5. S2 sends an alert email similar to the following, indicating that S2 has determined that P1 has failed and that S2 is

switching its effective HA operating mode tomaster.
This is the HA machine at 172.16.5.11.

The following event has occurred
‘MASTER heartbeat disappeared’
The state changed from ‘SLAVE’ to ‘MASTER’

6. S2 records event log messages (among others) indicating that S2 has determined that P1 has failed and that S2 is
switching its effective HA operating mode tomaster.

Recovering from temporary failure of the primary system

After P1 recovers from the hardware failure, what happens next to the HA group depends on P1’s HAOn failure setting
under System > High Availability > Configuration.

HA On Failure setting

l Switch Off
P1 will not process calls or join the HA group until you manually select the effective HA operating mode (see Click
HERE to Restore Configured Operating Mode on page 62).

l Wait for Recovery Then Restore Original Role
On recovery, P1’s effective HA operating mode resumes its configured primary role. This also means that S2 needs
to give back the primary role to P1. This behavior may be useful if the cause of failure is temporary and rare, but may
cause problems if the cause of failure is permanent or persistent.
In the case, the S2 will send out another alert email similar to the following:
This is the HA machine at 172.16.5.11.

The following event has occurred
‘SLAVE asks us to switch roles (recovery after a restart)
The state changed from ‘MASTER’ to ‘SLAVE’
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After recovery, P1 also sends out an alert email similar to the following:
This is the HA machine at 172.16.5.10.

The following critical event was detected
The system was shutdown!

l wait for recovery then restore slave role
On recovery, P1’s effective HA operating mode becomes slave, and S2 continues to assume themaster role. P1
then synchronizes with the current primary system, S2. For information on manually restoring the FortiVoice system
to acting in its configured HA mode of operation, see Click HERE to Restore Configured Operating Mode on page
62.

Failover scenario 2: System reboot or reload of the primary system

If you need to reboot or reload (not shut down) P1 for any reason, such as a firmware upgrade or a process restart, by
using the CLI commands execute reboot or execute reload, or by clicking Reboot in the drop-down list of your
user name at the upper right corner on the GUI:

l P1 will send a holdoff command to S2 so that S2 will not take over the primary role during P1’s reboot.
l P1 will also send out an alert email similar to the following:
This is the HA machine at 172.16.5.10.
The following critical event was detected
The system is rebooting (or reloading)!

l S2 will hold off checking the services and heartbeat with P1. Note that S2 will only hold off for about 5 minutes. In
case P1 never boots up, S2 will take over the primary role.

l S2 will send out an alert email, indicating that S2 received the holdoff command from P1.
This is the HA machine at 172.16.5.11.
The following event has occurred
‘peer rebooting (or reloading)’
The state changed from ‘SLAVE’ to ‘HOLD_OFF’

After P1 is up again:

l P1 will send another command to S2 and ask S2 to change its state from holdoff to slave and resume monitoring
P1’s services and heartbeat.

l S2 will send out an alert email, indicating that S2 received instruction commands from P1.
This is the HA machine at 172.16.5.11.
The following event has occurred
‘peer command appeared’
The state changed from ‘HOLD_OFF’ to ‘SLAVE’.

l S2 logs the event in the HA logs.

Failover scenario 3: System reboot or reload of the secondary system

If you need to reboot or reload (not shut down) S2 for any reason, such as a firmware upgrade or a process restart, by
using the CLI commands execute reboot or execute reload, or by clicking Reboot in the drop-down list of your
user name at the upper right corner on the GUI. The behavior of P1 and S2 is as follows:
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l P1 will send out an alert email similar to the following, informing the administrator of the heartbeat loss with S2.
This is the HA machine at 172.16.5.10.
The following event has occurred
‘ha: SLAVE heartbeat disappeared’

l S2 will send out an alert email similar to the following:
This is the HA machine at 172.16.5.11.
The following critical event was detected
The system is rebooting (or reloading)!

l P1 will also log this event in the HA logs.

Failover scenario 4: System shutdown of the secondary system

If you shut down S2:

l No alert email is sent out from either P1 or S2.
l P1 will log this event in the HA logs.

Failover scenario 5: Primary heartbeat link fails

If the primary heartbeat link fails, such as when the cable becomes accidentally disconnected, and if you have not
configured a secondary heartbeat link, the FortiVoice systems in the HA group cannot verify that other systems are
operating and assume that the other has failed. As a result, the secondary system (S2) changes to operating as a
primary system, and both FortiVoice systems are acting as primary systems.

Two primary systems connected to the same network may cause address conflicts on your network. Additionally,
because the heartbeat link is interrupted, the FortiVoice systems in the HA group cannot synchronize configuration
changes or voice data changes.

Even after reconnecting the heartbeat link, both systems will continue operating as primary systems. To return the HA
group to normal operation, you must connect to the GUI of S2 to restore its effective HA operating mode to slave
(secondary system).

1. The FortiVoice HA group is operating normally.
2. The heartbeat link Ethernet cable is accidentally disconnected.
3. S2’s HA heartbeat test detects that the primary system has failed.

How soon this happens depends on the HA daemon configuration of S2.
4. The effective HA operating mode of S2 changes tomaster.
5. S2 sends an alert email similar to the following, indicating that S2 has determined that P1 has failed and that S2 is

switching its effective HA operating mode tomaster.
This is the HA machine at 172.16.5.11.
The following event has occurred
‘MASTER heartbeat disappeared’
The state changed from ‘SLAVE’ to ‘MASTER’

6. S2 records event log messages (among others) indicating that S2 has determined that P1 has failed and that S2 is
switching its effective HA operating mode tomaster.
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Recovering from a heartbeat link failure

Because the hardware failure is not permanent (that is, the failure of the heartbeat link was caused by a disconnected
cable, not a failed port on one of the FortiVoice systems), you may want to return both FortiVoice systems to operating in
their configured modes when rejoining the failed primary system to the HA group.

To return to normal operation after the heartbeat link fails

1. Reconnect the primary heartbeat interface by reconnecting the heartbeat link Ethernet cable.
Even though the effective HA operating mode of S2 ismaster, S2 continues to attempt to find the other primary
system. When the heartbeat link is reconnected, S2 finds P1 and determines that P1 is also operating as a primary
system. So S2 sends a heartbeat signal to notify P1 to stop operating as a primary system. The effective HA
operating mode of P1 changes to off.

2. P1 sends an alert email similar to the following, indicating that P1 has stopped operating as the primary system.
This is the HA machine at 172.16.5.10
The following event has occurred
'SLAVE asks us to switch roles (user requested takeover)'
The state changed from 'MASTER' to 'OFF'

3. P1 records event log messages (among others) indicating that P1 is switching to offmode.
The configured HA mode of operation of P1 ismaster and the effective HA operating mode of P1 is off.
The configured HA mode of operation of S2 is slave and the effective HA operating mode of S2 ismaster.

4. Connect to the GUI of P1, go to System > High Availability > Status.
5. Check for synchronization messages.

Do not proceed to the next step until P1 has synchronized with S2.
6. Connect to the GUI of S2, go to System > High Availability > Status and select click HERE to restore configured

operating mode.
The HA group should return to normal operation. P1 records the event log message (among others) indicating that
S2 asked P1 to return to operating as the primary system.
P1 and S2 synchronize again. P1 processes phone calls normally.

Failover scenario 6: Network connection between primary and secondary systems fails
(remote service monitoring detects a failure)

Depending on your network configuration, the network connection between the primary and secondary systems can fail
for a number of reasons. In the network configuration shown in Example active-passive HA group on page 70, the
connection between port1 of primary system (P1) and port1 of the secondary system (S2) can fail if a network cable is
disconnected or if the switch between P1 and S2 fails.

A more complex network configuration could include a number of network devices between the primary and secondary
system’s non-heartbeat network interfaces. In any configuration, remote service monitoring can only detect a
communication failure. Remote service monitoring cannot determine where the failure occurred or the reason for the
failure.

In this scenario, remote service monitoring has been configured to make sure that S2 can connect to P1. TheOn failure
setting located in the HA main configuration section is wait for recovery then restore slave role. For information on theOn
failure setting, see On failure on page 64. For information about remote service monitoring, see Configuring service-
based monitoring on page 68.
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The failure occurs when power to the switch that connects the P1 and S2 port1 interfaces is disconnected. Remote
service monitoring detects the failure of the network connection between the primary and secondary systems. Because
of theOn failure setting, P1 changes its effective HA operating mode to failed.

When the failure is corrected, P1 detects the correction because while operating in failed mode P1 has been attempting
to connect to S2 using the port1 interface. When P1 can connect to S2, the effective HA operating mode of P1 changes
to slave and the voice data on P1 will be synchronized to S2. S2 can now deliver the calls. The HA group continues to
operate in this manner until an administrator resets the effective HA modes of operation of the FortiVoice systems.

1. The FortiVoice HA group is operating normally.
2. The power cable for the switch between P1 and S2 is accidentally disconnected.
3. S2’s remote service monitoring cannot connect to the primary system.

How soon this happens depends on the remote service monitoring configuration of S2.
4. Through the HA heartbeat link, S2 signals P1 to stop operating as the primary system.
5. The effective HA operating mode of P1 changes to failed.
6. The effective HA operating mode of S2 changes tomaster.
7. S2 sends an alert email similar to the following, indicating that S2 has determined that P1 has failed and that S2 is

switching its effective HA operating mode tomaster.
This is the HA machine at 172.16.5.11.
The following event has occurred
‘MASTER remote service disappeared’
The state changed from ‘SLAVE’ to ‘MASTER’

8. S2 logs the event (among others) indicating that S2 has determined that P1 has failed and that S2 is switching its
effective HA operating mode tomaster.

9. P1 sends an alert email similar to the following, indicating that P1 has stopped operating in HA mode.
This is the HA machine at 172.16.5.10.
The following event has occurred
'SLAVE asks us to switch roles (user requested takeover)'
The state changed from 'MASTER' to 'FAILED'

10. P1 records the log messages (among others) indicating that P1 is switching to Failedmode.

Recovering from a network connection failure

Because the network connection failure was not caused by failure of either FortiVoice system, you may want to return
both FortiVoice systems to operating in their configured modes when rejoining the failed primary system to the HA group.

To return to normal operation after the heartbeat link fails

1. Reconnect power to the switch.
Because the effective HA operating mode of P1 is failed, P1 is using remote service monitoring to attempt to
connect to S2 through the switch.

2. When the switch resumes operating, P1 successfully connects to S2.
P1 has determined the S2 can connect to the network and process calls.

3. The effective HA operating mode of P1 switches to slave.
4. P1 logs the event.
5. P1 sends an alert email similar to the following, indicating that P1 is switching its effective HA operating mode to

slave.
This is the HA machine at 172.16.5.10.
The following event has occurred
'SLAVE asks us to switch roles (user requested takeover)'
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The state changed from 'FAILED' to 'SLAVE'
6. Connect to the GUI of P1 and go to System > High Availability > Status.
7. Check for synchronization messages.

Do not proceed to the next step until P1 has synchronized with S2.
8. Connect to the GUI of S2, go to System > High Availability > Status and select click HERE to restore configured

operating mode.
9. Connect to the GUI of P1, go to System > High Availability > Status and select click HERE to restore configured

operating mode.
P1 should return to operating as the primary system and S2 should return to operating as the secondary system.
P1 and S2 synchronize again. P1 can now process phone calls normally.

Working with system configurations

The System > Configuration submenu lets you configure the system time, system options, SNMP, email setting, GUI
appearance, and call data storage.

This topic includes:

l Configuring the time and date on page 76
l Configuring system options on page 77
l Configuring SNMP queries and traps on page 78
l Configuring email settings on page 84
l Customizing the GUI appearance on page 86
l Selecting the call data storage location on page 87

Configuring the time and date

The System > Configuration > Time tab lets you configure the system time and date of the FortiVoice system.

You can either manually set the FortiVoice system time or configure the FortiVoice system to automatically keep its
system time correct by synchronizing with Network Time Protocol (NTP) servers.

For many features to work, including scheduling, logging, and certificate-dependent features,
the FortiVoice system time must be accurate.
FortiVoice systems support daylight savings time (DST), including recent changes in the USA,
Canada andWestern Australia.
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To configure the system time

1. Go to System > Configuration > Time.
2. Configure the following:

GUI field Description

System time Displays the date and time according to the FortiVoice system’s clock at the
time that this tab was loaded, or when you last selected the Refresh button.

Time zone Select the time zone in which the FortiVoice system is located.
l Automatically adjust clock for daylight saving time changes: Enable to
adjust the FortiVoice system clock automatically when your time zone
changes to daylight savings time (DST) and back to standard time.

Set date Select this option to manually set the date and time of the FortiVoice system’s
clock, then select the Year,Month, Day, Hour,Minute, and Second fields
before you click Apply.
Alternatively, configure Synchronize with NTP server.

Synchronize with NTP Server Select to use a network time protocol (NTP) server to automatically set the
system date and time, then configure Server and Sync Interval.
l Server: Enter the IP address or domain name of an NTP server.
You can add a maximum of 10 NTP servers. The FortiVoice system uses
the first NTP server based on the selection mechanism of the NTP
protocol.
Click the + sign to add more servers.
Click the - sign to remove servers. Note that you cannot remove the last
server.
To find the NTP servers that you can use, see http://www.ntp.org.

l Sync Interval: Enter how often, in minutes, the FortiVoice system should
synchronize its time with the NTP server. For example, entering 1440
causes the FortiVoice system to synchronize its time once a day.

Depending on your network traffic, it may take some time for the FortiVoice
system to synchronize its time with the NTP server.

3. Click Apply.

Configuring system options

The System > Configuration > Options tab lets you set the following global settings:

l system idle timeout
l password enforcement policy
l administration ports on the interfaces

To view and configure the system options
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1. Go to System > Configuration > Option.
2. Configure the following:

GUI field Description

Idle timeout Enter the amount of time that an administrator may be inactive before the FortiVoice
system automatically logs out the administrator.
For better security, use a low idle timeout value, for example, 5 minutes.

Web action host/IP Enter the host name or IP address from where a email notification is sent to you when a
voice mail or fax is delivered to your extension. This IP address is included in the email
notification. You can open the link to view or manage the voice mail or fax. If you leave this
field empty, port1 IP will be used instead.
The value entered here replaces the default Url host variable for customizing messages.
See Customizing call report and notification email templates on page 111.

Administration Ports Specify the TCP ports for administrative access on all interfaces.
Default port numbers:
HTTP: 80
HTTPS: 443
SSH: 22
TELNET: 23

3. Click Apply.

Configuring SNMP queries and traps

Go to System > Configuration > SNMP to configure SNMP to monitor FortiVoice system events and thresholds, or a high
availability (HA) configuration for failover messages.

To monitor FortiVoice system information and receive FortiVoice traps, you must compile Fortinet proprietary MIBs as
well as Fortinet-supported standard MIBs into your SNMPmanager. RFC support includes support for most of RFC 2665
(Ethernet-like MIB) and most of RFC 1213 (MIB II). For more information, see FortiVoice MIBs on page 83.

The FortiVoice SNMP implementation is read-only. SNMP v1, v2c, and v3 compliant SNMPmanagers have read-only
access to FortiVoice system information and can receive FortiVoice traps.

The FortiVoice SNMP v3 implementation includes support for queries, traps, authentication, and privacy. Before you can
use its SNMP queries, you must enable SNMP access on the network interfaces that SNMPmanagers will use to access
the FortiVoice system. For more information, see Editing network interfaces on page 45.

This topic includes:

l Configuring an SNMP threshold on page 78
l Configuring email settings on page 84
l Configuring an SNMP v3 user on page 81

Configuring an SNMP threshold

Configure under what circumstances an event is triggered.

To set SNMP thresholds

FortiVoice Phone System 6.0.12 Administration Guide 78
Fortinet Inc.

http://tools.ietf.org/html/rfc2665
http://tools.ietf.org/html/rfc1213


Configuring system settings

1. Go to System > Configuration > SNMP.
2. Configure the following:

GUI field Description

SNMP agent enabled Enable to activate the FortiVoice SNMP agent. This must be
enabled to accept queries from SNMPmanagers or send traps
from the FortiVoice system.

Description Enter a descriptive name for the FortiVoice system.

Location Enter the location of the FortiVoice system.

Contact Enter administrator contact information.

SNMP Threshold To change a value in the four editable columns, select the value in
any row. It becomes editable. Change the value and click outside
of the field. A red triangle appears in the field’s corner and remains
until you click Apply.

Trap Type Displays the type of trap, such as CPU Usage.

Trigger You can enter either the percent of the resource in use or the
number of times the trigger level must be reached before it is
triggered.
For example, using the default value, if the mailbox disk is 90% or
more full, it will trigger.

Threshold Sets the number of triggers that will result in an SNMP trap.
For example, if the CPU level exceeds the set trigger percentage
once before returning to a lower level, and the threshold is set to
more than one, an SNMP trap will not be generated until that
minimum number of triggers occurs during the sample period.

Sample Period(s) Sets the time period in seconds during which the FortiVoice system
SNMP agent counts the number of triggers that occurred.
This value should not be less than the Sample Freq(s) value.

Sample Freq(s) Sets the interval in seconds between measurements of the trap
condition. You will not receive traps faster than this rate, depending
on the selected sample period.
This value should be less than the Sample Period(s) value.

Community Displays the list of SNMP communities (for SNMP v1 and v2c)
added to the FortiVoice configuration. For information on
configuring a community, see either Configuring email settings on
page 84 or Configuring an SNMP v3 user on page 81.

Name Displays the name of the SNMP community. The SNMPManager
must be configured with this name.

Status A green check mark icon indicates that the community is enabled.

Queries A green check mark icon indicates that queries are enabled.

Traps A green check mark icon indicates that traps are enabled.
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GUI field Description

User Displays the list of SNMP v3 users added to the FortiVoice
configuration. For information on configuring a v3 user, see
Configuring an SNMP v3 user on page 81.

Name Displays the name of the SNMP v3 user. The SNMPManager must
be configured with this name.

Status A green check mark icon indicates that the user is enabled.

Queries A green check mark icon indicates that queries are enabled.

Traps A green check mark icon indicates that traps are enabled.

Security Level Displays the security level.

3. Click Apply.

Configuring an SNMP v1 and v2c community

An SNMP community is a grouping of equipment for SNMP-based network administration purposes. You can add up to
three SNMP communities so that SNMPmanagers can connect to the FortiVoice system to view system information and
receive SNMP traps. You can configure each community differently for SNMP traps and to monitor different events. You
can add the IP addresses of up to eight SNMPmanagers to each community.

To configure an SNMP community

1. Go to System > Configuration > SNMP.
2. Under Community, click New to add a community or select a community and click Edit.

The SNMP Community page appears.
3. Configure the following:

GUI field Description

Name Enter a name to identify the SNMP community. If you are editing an
existing community, you cannot change the name.
You can add up to 16 communities.

Enable Enable to send traps to and allow queries from the community’s
SNMPmanagers.

Community Hosts Lists SNMPmanagers that can use the settings in this SNMP
community to monitor the FortiVoice system. Click Create to create
a new entry.
You can add up to 16 hosts.

IP Address Enter the IP address of an SNMPmanager. By default, the IP
address is 0.0.0.0, so that any SNMPmanager can use this SNMP
community.

Create
(button)

Click to add a new default entry to the Hosts list that you can edit as
needed.

Delete
(button)

Click to remove this SNMPmanager.
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GUI field Description

Queries Enter the Port number (161 by default) that the SNMPmanagers in
this community use for SNMP v1 and SNMP v2c queries to receive
configuration information from the FortiVoice system. Mark the
Enable check box to activate queries for each SNMP version.

Traps Enter the Local Port and Remote Port numbers (162 local, 162
remote by default) that the FortiVoice system uses to send SNMP
v1 and SNMP v2c traps to the SNMPmanagers in this community.
Enable traps for each SNMP version that the SNMPmanagers
use.
Enable each SNMP event for which the FortiVoice system should
send traps to the SNMPmanagers in this community.

Since FortiVoice checks its status in a scheduled
interval, not all the events will trigger traps. For
example, FortiVoice checks its hardware status
every 60 seconds. This means that if the power is
off for a few seconds but is back on before the next
status check, no system event trap will be sent.

4. Click Create.

Configuring an SNMP v3 user

SNMP v3 adds more security by using authentication and privacy encryption. You can specify an SNMP v3 user on
FortiVoice so that SNMPmanagers can connect to the FortiVoice system to view system information and receive SNMP
traps.

To configure an SNMP v3 user

1. Go to System > Configuration > SNMP.
2. Under User, click New to add a user or select a user and click Edit.

The SNMPv3 User page appears.
You can add up to 16 users.

3. Configure the following:

GUI field Description

User name Enter a name to identify the SNMP user. A user name cannot
include spaces, quotes, and backslashes.

Enable Enable to send traps to and allow queries from the user’s SNMP
managers.

Security level Choose one of the three security levels:
l No authentication, no privacy: This option is similar to SNMP
v1 and v2.

l Authentication, no privacy: This option enables authentication
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GUI field Description

only. The SNMPmanager needs to supply a password that
matches the password you specify on FortiVoice. You must
also specify the authentication protocol (either SHA1 or MD5).

l Authentication, privacy: This option enables both
authentication and encryption. You must specify the protocols
and passwords. Both the protocols and passwords on the
SNMPmanager and FortiVoice must match.

Authentication
Protocol

For Security level, if you select either Authentication option, you
must specify the authentication protocol and password. Both the
authentication protocol and password on the SNMPmanager and
FortiVoice must match.

Privacy protocol For Security level, if you select Privacy, you must specify the
encryption protocol and password. Both the encryption protocol
and password on the SNMPmanager and FortiVoice must match.

Notification Hosts Lists the SNMPmanagers that FortiVoice will send traps to. Click
Create to create a new entry. You can add up to 16 host.

IP Address Enter the IP address of an SNMPmanager. By default, the IP
address is 0.0.0.0, so that any SNMPmanager can use this SNMP
user.

Create
(button)

Click to add a new default entry to the Hosts list that you can edit as
needed.

Delete
(button)

Click to remove this SNMPmanager.

Queries Double click the default port number (161) to enter the Port number
that the SNMPmanagers use for SNMP v3 queries to receive
configuration information from the FortiVoice system. Select the
Enable check box to activate queries.

Traps Double click the default local port (162) and remote port number
(162) to enter the Local Port and Remote Port numbers that the
FortiVoice system uses to send SNMP v3 traps to the SNMP
managers. Select the Enable check box to activate traps.
Enable each SNMP event for which the FortiVoice system should
send traps to the SNMPmanagers.

Not all events trigger traps because the FortiVoice s
ystem checks its status at a scheduled interval. For
example, FortiVoice checks its hardware status eve
ry 60 seconds. This means that if the power is off fo
r a few seconds but is back on before the next statu
s check, no system event trap will be sent.

4. Click Create.
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FortiVoice MIBs

The FortiVoice SNMP agent supports Fortinet proprietary MIBs as well as standard RFC 1213 and RFC 2665 MIBs.
RFC support includes support for the parts of RFC 2665 (Ethernet-like MIB) and the parts of RFC 1213 (MIB II) that
apply to FortiVoice system configuration.

The FortiVoice MIBs are listed in FortiVoice MIBs on page 83. You can obtain these MIB files from Fortinet technical
support. To communicate with the SNMP agent, you must compile these MIBs into your SNMPmanager.

Your SNMPmanager may already include standard and private MIBs in a compiled database that is ready to use. You
must add the Fortinet proprietary MIB to this database. If the standard MIBs used by the Fortinet SNMP agent are
already compiled into your SNMPmanager you do not have to compile them again.

FortiVoice MIBs

MIB file name Description

FortiVoice.mib Displays the proprietary Fortinet MIB includes detailed FortiVoice system configuration
information. Your SNMPmanager requires this information to monitor FortiVoice
configuration settings. For more information, see MIB fields on page 83.

FortiVoice traps

The FortiVoice system’s SNMP agent can send traps to SNMPmanagers that you have added to SNMP communities.
To receive traps, you must load and compile the FortiVoice trap MIB into the SNMPmanager.

All traps sent include the trap message as well as the FortiVoice system serial number and host name.

MIB fields

Trap Description

fvTrapStorageDiskHighThreshold Trap sent if log disk usage and mailbox disk usage become too high.

fvTrapSystemEvent Trap sent when system shuts down, reboots, upgrades, etc.

fmlTrapHAEvent Trap sent when an HA event occurs.

The Fortinet MIB contains fields reporting current FortiVoice system status information. The tables below list the names
of the MIB fields and describe the status information available for each. You can view more details about the information
available from all Fortinet MIB fields by compiling the MIB file into your SNMPmanager and browsing the MIB fields.

System session MIB fields

MIB field Description

fvSysModel FortiVoice model number, such as 400 for the FortiVoice-400.

fvSysSerial FortiVoice system serial number.

fvSysVersion The firmware version currently running on the FortiVoice system.
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MIB field Description

fvSysCpuUsage The current CPU usage (%).

fvSysMemUsage The current memory utilization (%).

fvSysLogDiskUsage The log disk usage (%).

fvSysStorageDiskUsage The storage disk usage (%).

fvSysEventCode System component events.

fvSysload Current system load.

fvSysHA l fvHAMode: Configured HA operating mode.
l fvHAEffectiveMoce: Effective HA operating mode.

fmlHAEventId HA event type ID.

fmlHAUnitIp Unit IP address where the event occurs.

fmlHAEventReason The reason for the HA event.

Configuring email settings

You can configure the FortiVoice system to send email notifications to phone users when they miss a phone call or
receive a voicemail or fax.

For phone users to receive the notifications, you need to add their email addresses when
configuring the extensions. See Configuring extensions on page 162.

To configure email settings

1. Go to System > Configuration > Mail Setting.
2. Configure the following:

GUI field Description

Local Host

Host name Enter the host name of the FortiVoice system, such as
fortivoice-500F.

Local domain name Enter the local domain name of the FortiVoice system, such as
example.com.

Mail Queue
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GUI field Description

Maximum time for
email in queue (1-
240 hours)

Enter the maximum number of hours that deferred email messages
can remain in the deferred email queue, during which the
FortiVoice system periodically retries to send the message. After it
reaches the maximum time, the FortiVoice system sends a final
delivery status notification (DSN) email message to notify the
sender that the email message was undeliverable.

Time interval for
retry (10-120
minutes)

Enter the number of minutes between delivery retries for email
messages in the deferred mail queues.

Relay Server Configure an SMTP relay, if needed, to which the FortiVoice
system will relay outgoing email. This is typically provided by your
Internet service provider (ISP), but could be a mail relay on your
internal network.

Relay server name Enter the domain name of an SMTP relay.

Test
(button)

After you have entered the relay server information, you can click
the Test button to test if the relay server is accessible.
To further test mail delivery, click Advanced Group, and enter the
sender (MAIL FROM) and recipient (RCPT TO) email addresses.
EHLO (Extended HELO) information is filled in by default.
Click Test to display the test results.

Relay server port Enter the TCP port number on which the SMTP relay listens. This
is typically provided by your Internet service provider (ISP).

Use SMTPs Enable to initiate SSL- and TLS-secured connections to the SMTP
relay if it supports SSL/TLS. When disabled, SMTP connections
from the FortiVoice system’s built-in MTA or proxy to the relay will
occur as clear text, unencrypted.
This option must be enabled to initiate SMTPS connections.

Authentication
Required

Select the checkbox and click the arrow to expand the section and
configure:
l User name: Enter the name of the FortiVoice system’s
account on the SMTP relay.

l Password: Enter the password for the FortiVoice system’s
user name.

l Authentication type: Available SMTP authentication types
include:
l AUTO (automatically detect and use the most secure
SMTP authentication type supported by the relay server)

l PLAIN (provides an unencrypted, scrambled password)
l LOGIN (provides an unencrypted, scrambled password)
l DIGEST-MD5 (provides an encrypted hash of the
password)

l CRAM-MD5 (provides an encrypted hash of the
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GUI field Description

password, with hash replay prevention, combined with a
challenge and response mechanism)

Customize Email Template View and reword the default email history report and notification
email templates. For more information, see Customizing call report
and notification email templates on page 111.

3. Click Apply.

Customizing the GUI appearance

The System > Configuration > Appearance tab lets you customize the default appearance of the GUI and voicemail
interface with your own product name, product logo, corporate logo, and language.

To customize the GUI appearance

1. Go to System > Configuration > Appearance.
2. Click the arrow to expand Administration interface and Voicemail interface.
3. Configure the following:

GUI field Description

Administration interface

Product name Enter the name of the product. This name will precede Administrator Login in
the title on the login page of the GUI.

Product icon Click Change to browse for the product icon. The icon should be in .ico format,
and 16 pixels wide x16 pixels tall in size.

Top logo Click Change to upload a graphic that will appear at the top of all pages in the
GUI. The image’s dimensions must be 460 pixels wide by 36 pixels tall.
For best results, use an image with a transparent background. Non-
transparent backgrounds will not blend with the underlying theme graphic,
resulting in a visible rectangle around your logo graphic.

Uploading a graphic overwrites the current graphic. The
FortiVoice system does not retain previous graphics. If you
want to revert to the current graphic, use your web browser
to save a backup copy of the image to your management
computer, enabling you to upload it again at a later time.

Click Reset to return to the default settings.

Default UI language Select the default language for the display of the GUI.
You can configure a separate language preference for each administrator
account. For details, see Configuring administrator accounts on page 51.

Default theme Select the default theme for the GUI.
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GUI field Description

User Portal Interface

User Portal login Enter a word or phrase that will appear on top of the web user portal login
page, such as User Portal Login.

Login user name hint Enter a hint for the user name, such as Your Email Address. This hint will
appear as a mouse-over display on the login name field.

User Portal theme Select a theme for the web user portal GUI.

Default UI language Select the language in which web user portal pages will be displayed. By
default, the FortiVoice system will use the same language as the GUI.

User Portal top logo Click Change to upload a graphic that will appear at the top of all web user
portal pages. The image’s dimensions must be 460 pixels wide by 36 pixels
tall.
For best results, use an image with a transparent background. Non-
transparent backgrounds will not blend with the underlying theme graphic,
resulting in a visible rectangle around your logo graphic.

Uploading a graphic overwrites the current graphic. The Forti
Voice system does not retain previous or default graphics. If
you want to revert to the current graphic, use your web brow
ser to save a backup copy of the image to your management
computer, enabling you to upload it again at a later time.

Click Reset to return to the default settings.

4. Click Apply to save changes or Reset to return to the default settings.

Selecting the call data storage location

The System > Configuration > Storage tab lets you configure local or remote storage of call data such as the recorded
calls, faxes, and voice mails.

FortiVoice systems can store call data either locally or remotely. FortiVoice systems support remote storage by a
network attached storage (NAS) server using the network file system (NFS) protocol.

NAS has the benefits of remote storage which include ease of backing up the call data and more flexible storage limits.
Additionally, you can still access the call data on the NAS server if your FortiVoice system loses connectivity.

If the FortiVoice system is a member of an active-passive HA group, and the HA group stores
call data on a remote NAS server, disable call data synchronization to prevent duplicate call
data traffic. For details, see Configuring the HA mode and group on page 63.

If you store the call data on a remote NAS device, you cannot back up the data. You can only
back up the call data stored locally on the FortiVoice hard disk. For information about backing
up call data, see Backing up configuration on page 103.
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Tested and Supported NFS servers

l Linux NAS (NFS v3/v4)
l Red Hat 5.5
l Fedora 16/17/18/19
l Ubuntu 11/12/13
l OpenSUSE 13.1

l FreeNAS
l Openfiler
l EMC VNXe3150 (version 2.4.2.21519(MR4 SP2))
l EMC Isilon S200 (OneFS 7.1.0.3)

Untested NFS servers

l Buffalo TeraStation
l Cisco Linksys NAS server

Non-Supported NFS Servers

l Windows 2003 R2 /Windows 2008 Service for NFS

To configure call data storage

1. Go to System > Configuration > Storage.
2. Configure the following:

GUI field Description

Local Select to store call data on the FortiVoice system’s local disk or RAID.

NAS Select to store call data on a remote network attached storage (NAS) server.

Storage type Select a type of the NAS server:
l NFS: To configure a network file system (NFS) server. For this option, enter the
following information:
l Hostname/IP address: The IP address or fully qualified domain name (FQDN) of
the NFS server.

l Port: The TCP port number on which the NFS server listens for connections.
l Directory: The directory path of the NFS export on the NAS server where the
FortiVoice system will store call data.

l iSCSI Server: To configure an Internet SCSI (Small Computer System Interface)
server. For this option, enter the following information:
l Initiator name as username: Select to use the iSCSI initiator node name as the
user name of the FortiVoice system’s account on the iSCSI server.

l Username: The user name of the FortiVoice system’s account on the iSCSI
server.

l Password: The password of the FortiVoice system’s account on the iSCSI
server.

l Hostname/IP address: The IP address or fully qualified domain name (FQDN) of
the iSCSI server.

l Port: The TCP port number on which the iSCSI server listens for connections.
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GUI field Description
l Encryption key: the key that will be used to encrypt data stored on the iSCSI
server. Valid key lengths are between 6 and 64 single-byte characters.

l iSCSI ID: The iSCSI identifier in the format expected by the iSCSI server, such
as an iSCSI Qualified Name (IQN), Extended Unique Identifier (EUI), or T11
Network Address Authority (NAA).

Status: When available, it indicates if the iSCSI share was successfully mounted on the
FortiVoice system’s file system. This field appears only after you configure the iSCSI share
and click Apply. Statusmay take some time to appear if the iSCSI server is slow to
respond.
If Not mounted appears, the iSCSI share was not successfully mounted. Verify that the
iSCSI server is responding and the FortiVoice system has both read and write permissions
on the iSCSI server.

Test(button) Click to verify the NAS server settings are correct and that the FortiVoice system can
access that location. The test action basically tries to discover, login, mount, and unmount
the remote device.
This button is available only when NAS server is selected.

Click here to
format this
device

Click here to
check file
system on this
device

If the ISCSI disk has never been formatted, the FortiVoice system
needs to format it before it can be used. If the disk has been formatted
before, you do not need to format it again. unless you want to wipe out
the data on it.

These two links appear when you configure an iSCSI server and click Apply.
Click a link to initiate the described action (that is, format the device or check its file
system). A message appears saying the action is being executed. Click OK to close the
message and click Refresh to see a Status update.

Configuring advanced phone system settings

The System > Advanced submenu lets you configure SIP setting, SIP phone auto-provisioning, prompt languages,
phone management, and system capacity.

This topic includes:

l Configuring SIP settings on page 89
l Configuring the internal ports on page 92
l Configuring external access on page 93
l Configuring SIP phone auto-provisioning on page 93

Configuring SIP settings

FortiVoice systems support SIP communications.

To configure FortiVoice SIP settings
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1. Go System > Advanced > SIP.
2. Configure the following:

GUI field Description

SIP Transport and
Internal Ports

SIP communication commonly uses TCP or UDP port 5060 and/or 5061. Port 5060 is used
for nonencrypted SIP signaling sessions and port 5061 is typically used for SIP sessions
encrypted with Transport Layer Security (TLS). TheWebSocket Secure (WSS) protocol
establishes a WebSocket over an encrypted TLS connection. The default port is 8089.
Enter the ports as required.

RTP Setting

Port Enter the starting Real-time Transport Protocol (RTP) port that the FortiVoice system will
use for phone call sessions. If the system is behind a firewall, these ports should be open.
Ensure there is a reasonable port range so that you have enough ports for all open calls.
The default port is 5000.
Enter the end RTP port that the FortiVoice system will use for phone call sessions. Ensure
there is a reasonable port range so that you have enough ports for all open calls. The
default port is 30000.

Timeout Enter the amount of time in seconds during an active call that the extension will wait for
RTP packets before hanging up the call. 0 means no time limit. The default is 60.

Hold timeout Enter the amount of time in seconds that the extension will wait on hold for RTP packets
before hanging up the call. 0 means no time limit. The default is 300.

Registration Interval If this is a dynamic account with the VoIP provider, enter the registration interval as
required by the VoIP provider. After each registration interval, the FortiVoice system
renews the registration of the account with the VoIP provider.

Extension
registration
interval range

To keep the extensions’ registration status with the FortiVoice system, enter the range of
the extension registration time interval as required by the FortiVoice system in minutes. An
extension’s registration timeout setting is overridden by the FortiVoice system’s extension
registration time interval range if it is out of the range.
The default range is from 1 to 480.
The start of the range is from 1 to 60 and the end of the range is from 30 to 1440.

Internal
extension
registration
interval

Enter the registration time interval for the extensions on your subnet as required by the
FortiVoice system in minutes.
The default is 30 and the range is from 10 to 480.
Set a proper value for this option. If it is too low, the performance of the FortiVoice system
is compromised due to frequent registration. If it is too high, the connection between the
FortiVoice system and the extension may terminate.

External
extension
registration
interval

Enter the registration time interval for the extensions on other subnets as required by the
FortiVoice system in seconds.
The default is 30 and the range is from 30 to 1800.
Set a proper value for this option. The FortiVoice system requires that external extensions
register more frequently with it to keep the connection. However, if the value is set too low,
the performance of the FortiVoice system is compromised due to frequent registration. If it
is too high, the connection between the FortiVoice system and the extension may
terminate.
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GUI field Description

Subscription Interval If this is a dynamic account with the VoIP provider, enter the subscription interval as
required by the VoIP provider. After each subscription interval, the FortiVoice system
renews the subscription of the account with the VoIP provider.

Extension
subscription
interval range

To keep the extensions’ subscription status with the FortiVoice system, enter the range of
extension subscription time interval as required by the FortiVoice system in minutes. An
extension’s subscription timeout setting is overridden by the FortiVoice system’s extension
subscription time interval range if it is out of the range.
The default range is 1 to 480.
The start of the range is from 1 to 60 and the end of the range is from 30 to 2880.

Extension
subscription
interval

Enter the subscription time interval for the extensions on your subnet as required by the
FortiVoice system in minutes.
The default is 30 and the range is from 1 to 1440.
Set a proper value for this option. If it is too low, the performance of the FortiVoice system
is compromised due to frequent subscription. If it is too high, the connection between the
FortiVoice system and the extension may terminate.

Security By default, the FortiVoice system screens out incoming calls from unauthenticated source.
If you want to change this default setting, select Accept unauthenticated incoming call.

Advanced Setting

SIP session
helper

Select if you do not want the FortiVoice system to apply NAT or other SIP session help
features to SIP traffic. With the SIP session helper disabled, the FortiVoice system can still
accept SIP sessions if they are allowed by a security policy, but the FortiVoice system will
not be able to open pinholes or NAT the addresses in the SIP messages.
Internal network type: Identify the internal networks designated for phone calls on the
FortiVoice system. When a call reaches the public IP address of the FortiVoice system, it
will be routed to one of the internal networks.
Note that modifying internal networks terminate ongoing calls.
l User defined: Configure your own internal network designated for phone calls on the
FortiVoice system.

l RFC 1918 predefined: Private IPv4 addresses used for internal traffic that does not
route via the Internet.

SIP timer T1 Enter the SIP T1 in milliseconds. This is an estimate of the Round Trip Time (RTT) of
transactions between a client and server. For example, when a SIP Client attempts to
send a request to a SIP Server, the time it takes between sending out the request to the
point of getting a response is the SIP T1 timer. By default the timer is set to 500
milliseconds.
The SIP Timer object is used as specific timing attribute to the SIP Signaling object. Use
caution when adjusting these timers because undesired outcomes from lengthy SIP
retransmits to an increase in traffic across the network may result.

SIP timer B This is the INVITE transaction timeout timer. It changes based on the SIP timer T1 value.

ICE support When the FortiFone softclient is located behind a Network Address Translator (NAT) or
FortiFone softclients are on different networks (without internetwork routing), configure the
interactive connectivity establishment (ICE) support to allow the FortiVoice phone system
to establish a valid audio path with the FortiFone softclient.
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GUI field Description

To configure the ICE support, you have the following two options:
l Static mapping: Uses the internal and external IP addresses of the FortiVoice phone
system.

l STUN server: Uses the IP address of a Session Traversal Utilities for NAT (STUN)
server.

Decide which option you want to configure for ICE support.
For information about configuring the ICE static mapping, see Configuring the static
mapping for ICE support on page 92.
For information about configuring the STUN server, see Configuring the STUN server for
ICE support on page 92.

3. Click Apply.

Configuring the static mapping for ICE support

1. Go to System > Advanced > SIP.
2. Expand Advanced Setting.
3. In ICE support, select Static mapping.
4. Click New.
5. Make sure that Enabled is selected.
6. Enter the internal and external FortiVoice IP addresses used in your deployment.
7. Click Create.

Changing the ICE static mapping restarts the voice process and interrupts all ongoing
calls. The call system takes a minute to resume service.

8. To continue, click Yes.
9. Click Apply.

Configuring the STUN server for ICE support

1. Go to System > Advanced > SIP.
2. Expand Advanced Setting.
3. In ICE Support, select STUN server.
4. For STUN server, enter the IP address or host name of a Fortinet or third-party STUN server.
5. Click Apply.

Configuring the internal ports

System > Advanced > Service lets you configure the FortiVoice system listening ports for network communications.

To configure internal port settings

1. Go to System > Advanced > Service.
2. Change the default HTTP and HTTPS port numbers if required.
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3. Enable TFTP port if required.
TFTP connection is not secure, and can be intercepted by a third party.

4. Other ports are predefined and cannot be changed.
5. Click Apply.

Configuring external access

System > Advanced > External Access lets you configure the FortiVoice system external hostname/IP and ports through
which it can be accessed by other devices through the internet.

When external extensions connect to the FortiVoice system, they get the basic PBX configurations including the external
access IP and ports through auto provisioning. They can then use the information to register with the FortiVoice system.
For more information, see Configuring SIP phone auto-provisioning on page 93.

Extensions are defined as external in extension configuration. For more information, see Configuring IP extensions on
page 162.

To configure external access

1. Go to System > Advanced > External Access and configure the following:

GUI field Description

SIP server external
hostname/IP address

Enter the hostname/IP for your SIP server external access.

SIP External Ports Enter the external access ports for SIP transport.
WSS (WebSocket Secure) is used to support FortiFone desktop application.

Other service external
hostname/IP address

If you have another service for external access, enter the hostname/IP.

Service External Ports Enter the external access ports for the other service.

2. Click Apply.

Configuring SIP phone auto-provisioning

System > Advanced > Auto Provisioning allows the FortiVoice system to discover the SIP phones on your network and
send the configuration files to them.

With auto-provisioning configured, when a supported FortiFone is connected to the network and powered on, it is
automatically discovered and receives the configuration file from the FortiVoice system. The FortiFone will then reboot
with the pushed-in configuration file and register with the FortiVoice system.

The FortiVoice system can only auto provision the supported FortiFones.

To configure auto-provisioning settings

1. Go to System > Advanced > Auto Provisioning and configure the following:

GUI field Description

Auto Provisioning
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GUI field Description

Enabled Select to activate the SIP phone auto-provisioning function for
auto discovering the phones.

Unassigned phone
(Generate default
configuration for
unassigned Desktop
FortiFone)

This option is only available after auto provisioning is enabled.
Select to generate basic phone configuration files for the
supported unassigned SIP Desktop FortiFones. For details, see
Viewing FortiFone desk phones on page 32.
With this option selected, once a supported FortiFone connects
to the FortiVoice system and is auto-discovered, the FortiVoice
system sends the basic PBX setup information to it for
registering with the FortiVoice system to be assigned an
extension.
If you want to upgrade your phone system and keep the current
phone configuration, do not select this option. Otherwise your
existing phone configuration will be overridden by the upgraded
FortiVoice configuration.

Provisioning protocol Select the protocol for the phones to retrieve the configuration
file from the FortiVoice system.

Server Setting for
Phone Configuration

If you use different servers for SIP, NTP, and LDAP, select to
configure the settings of each server for the supported phones.
The servers’ port information reflect the FortiVoice system’s
network interfaces. For details, see Configuring the network
interfaces on page 44.
l SIP server: Select or clickOverrideto enter the current
public IP address or public domain name of the server. The
SIP phones connect to this server to register.

l NTP server: Select or clickOverride to enter the current
public IP address or public domain name of the server. The
SIP phones connect to this server to synchronize time.

l LDAP contact: Select or clickOverride to enter the current
public IP address or public domain name of the server. The
SIP phones connect to this server to receive phone
directories.

l Provisioning server: If you use a specific server to send
PBX setup information to the phones, select or click
Override to enter the current public IP address or public
domain name of the server. The SIP phones connect to
this server to receive the full PBX setup information.

Auto Discovery If phone auto discovery is required, enable SIPPnP multicast
function for the connected phones to find the provisioning
server contained in its message for the phones.
You can also click Configure for the DHCP server settings to
select or add a server that contains provisioning server
information in its message for the phones to look for. For more
information, see Configuring DHCP server on page 49.
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GUI field Description

SIPPnP multicast and DHCP servers do not conflict although
SIPPnP has priority. Phones can retrieve provisioning server
information from either of the two.

Other Setting

Secondary account
(Enable secondary
account for Desktop
FortiFone)

In addition to the main account, secondary accounts can be
added on the same FortiVoice system. Select this option in
order to add a secondary account when configuring extensions.
For details, see Advanced on page 165

Administrator PIN to
provision phone

Click Configure and enter a global password to be used by an
administrator to connect a FortiFone to the FortiVoice system to
set mobile extension number. This password is also used by
the administrator to override schedules. For details, see
Configuring system capacity on page 112.
For example, you can press the default Configure Phone
feature code *17 (See Modifying feature access codes on page
289) on any FortiFone that connects to the FortiVoice system
and enter this password. You can then enter an existing
extension to set it as the extension of this phone.

Backward support of
legacy FortiFone (FON
470/870/360/460/560)
(Obsolescent)

If you have legacy FortiFones, select this option for backward
provisioning support.
TFTP provisioning server contains phone auto provisioning
information for the phones.
mDNSmulticast address allows the connected phones to find
the provisioning server contained in the mDNSmulticast server
message.

2. Click Apply.

Managing certificates

This section explains how to manage X.509 security certificates using the FortiVoice GUI. Using the System >
Certificatemenu, you can generate certificate requests, install signed certificates, import CA root certificates and
certificate revocation lists, and back up and restore installed certificates and private keys.

The FortiVoice system uses certificates for PKI authentication in secure connections. PKI authentication is the process
of determining if a remote host can be trusted with access to network resources. To establish its trustworthiness, the
remote host must provide an acceptable authentication certificate by obtaining a certificate from a certification authority
(CA).

You can manage the following types of certificates on the FortiVoice system:

Certificate type Usage

Server certificates The FortiVoice systemmust present its local server certificate for the following secure
connections:
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Certificate type Usage
l GUI (HTTPS connections only)
l Phone user web interface (HTTPS connections only)
l Phone and FortiVoice system (TLS and SRTP connections only) For details, see
Configuring SIP profiles on page 122.

For details, see Managing local certificates on page 96.

CA certificates The FortiVoice system uses CA certificates to authenticate the PKI users, including
administrators and phone users. For details, see Managing certificate authority certificates
on page 102.

Personal certificates Phone users’ personal certificates are used for S/MIME encryption.

APNs certificates View and import the Apple Push Notification service (APNs) and VoIP services certificates.
For details, see Managing APNs and VoIP services certificates on page 102.

This section contains the following topics:

l Managing local certificates on page 96
l Obtaining and installing a local certificate on page 97
l Managing certificate authority certificates on page 102
l Managing the certificate revocation list on page 102
l Managing APNs and VoIP services certificates on page 102

Managing local certificates

System > Certificate > Local Certificate displays both the signed server certificates and unsigned certificate requests.

On this tab, you can also generate certificate signing requests and import signed certificates in order to install them for
local use by the FortiVoice system.

FortiVoice systems require a local server certificate that it can present when clients request secure connections,
including:

l the GUI (HTTPS connections only)
l phone user web interface (HTTPS connections only)

To view local certificates, go to System > Certificate > Local Certificate.

GUI field Description

View Select a certificate and click View to display its issuer, subject, and range of dates
within which the certificate is valid.

Generate Click to generate a local certificate request. For more information, see Generating
a certificate signing request on page 97.

Download Click the row of a certificate file or certificate request file in order to select it, then
click this button and select either:
l Download: Download a certificate (.cer) or certificate request (.csr) file. You
can send the request to your certificate authority (CA) to obtain a signed
certificate for the FortiVoice system. For more information, see Downloading
a certificate signing request on page 99.
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GUI field Description
l Download PKCS12 File: Download a PKCS #12 (.p12) file. For details, see
Downloading a PKCS #12 certificate on page 101.

Assign to Click the row of a certificate in order to select it, then click this button to assign it to
a service.

Import Click to import a signed certificate for local use. For more information, see
Importing a certificate on page 100.

Obtaining and installing a local certificate

There are two methods to obtain and install a local certificate:

l If you already have a signed server certificate (a backup certificate, a certificate exported from other devices, and so
on), you can import the certificate into the FortiVoice system. For details, see Importing a certificate on page 100
and Assigning a local certificate to a service on page 101.

l Generate a certificate signing request on the FortiVoice system, get the request signed by a CA, and import the
signed certificate into the FortiVoice system.

For the second method, follow these steps:

l Generating a certificate signing request on page 97
l Downloading a certificate signing request on page 99
l Submitting a certificate request to your CA for signing on page 99
l Importing a certificate on page 100
l Assigning a local certificate to a service on page 101

Generating a certificate signing request

You can generate a certificate request file, based on the information you enter to identify the FortiVoice system.
Certificate request files can then be submitted for verification and signing by a certificate authority (CA).

For other related steps, see Obtaining and installing a local certificate on page 97.

To generate a certificate request

1. Go to System > Certificate > Local Certificate.
2. ClickGenerate.

A dialog appears.
3. Configure the following:

GUI field Description

Certification name Enter a unique name for the certificate request, such as fvlocal.

Subject Information Information that the certificate is required to contain in order to
uniquely identify the FortiVoice system.

Certification name Select the type of identifier to be used in the certificate to identify
the FortiVoice system:
l Host IP
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GUI field Description
l Domain name
l E-mail

Which type you should select varies by whether or not your
FortiVoice system has a static IP address, a fully-qualified domain
name (FQDN), and by the primary intended use of the certificate.
For example, if your FortiVoice system has both a static IP address
and a domain name, but you will primarily use the local certificate
for HTTPS connections to the GUI by the domain name of the
FortiVoice system, you might prefer to generate a certificate based
on the domain name of the FortiVoice system, rather than its IP
address.
l Host IP requires that the FortiVoice system have a static,
public IP address. It may be preferable if clients will be
accessing the FortiVoice system primarily by its IP address.

l Domain name requires that the FortiVoice system have a fully-
qualified domain name (FQDN). It may be preferable if clients
will be accessing the FortiVoice system primarily by its domain
name.

l E-mail does not require either a static IP address or a domain
name. It may be preferable if the FortiVoice system does not
have a domain name or public IP address.

IP This option appears only if Certification name is Host IP.
Enter the static IP address of the FortiVoice system.

Domain Name This option appears only if Certification name is Domain Name.
Type the fully-qualified domain name (FQDN) of the FortiVoice
system.
The domain name may resolve to either a static or, if the FortiVoice
system is configured to use a dynamic DNS service, a dynamic IP
address. For more information, see Configuring the network
interfaces on page 44 and Configuring DNS on page 48.
If a domain name is not available and the FortiVoice system
subscribes to a dynamic DNS service, an unable to verify
certificatemessage may appear in the user’s browser
whenever the public IP address of the FortiVoice system changes.

E-mail This option appears only if Certification name is E-mail.
Type the email address of the owner of the FortiVoice system.

Optional Information Information that you may include in the certificate, but which is not
required.

Organization unit Type the name of your organizational unit, such as the name of
your department. (Optional)
To enter more than one organizational unit name, click the + icon,
and enter each organizational unit separately in each field.

Organization Type the legal name of your organization. (Optional)
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GUI field Description

Locality (City) Type the name of the city or town where the FortiVoice system is
located. (Optional)

State/Province Type the name of the state or province where the FortiVoice
system is located. (Optional)

Country Select the name of the country where the FortiVoice system is
located. (Optional)

E-mail Type an email address that may be used for contact purposes.
(Optional)

Key type Displays the type of algorithm used to generate the key.
This option cannot be changed, but appears in order to indicate
that only RSA is currently supported.

Key size Select a security key size of 512 Bit, 1024 Bit, 1536 Bit or 2048 Bit.
Larger keys are slower to generate, but provide better security.

4. Click Create.
The certificate is generated, and can be downloaded to your management computer for submission to a certificate
authority (CA) for signing. For more information, see Downloading a certificate signing request on page 99.

Downloading a certificate signing request

After you have generated a certificate request, you can download the request file to your management computer in order
to submit the request file to a certificate authority (CA) for signing.

For other related steps, see Obtaining and installing a local certificate on page 97.

To download a certificate request

1. Go to System >Certificate > Local Certificate.
2. Click the row that corresponds to the certificate request in order to select it.
3. Click Download, then select Download from the pop-up menu.

Your web browser downloads the certificate request (.csr) file.

Submitting a certificate request to your CA for signing

After you download the certificate request file, you can submit the request to you CA for signing.

For other related steps, see Obtaining and installing a local certificate on page 97.

To submit a certificate request

1. Using the web browser on the management computer, browse to the website for your CA.
2. Follow your CA’s instructions to place a Base64-encoded PKCS #12 certificate request, uploading your certificate

request.
3. Follow your CA’s instructions to download their root certificate and Certificate Revocation List (CRL), and then

install the root certificate and CRL on each remote client.
4. When you receive the signed certificate from the CA, install the certificate on the FortiVoice system. For more

information, see Importing a certificate on page 100.
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Importing a certificate

You can upload Base64-encoded certificates in either privacy-enhanced email (PEM) or public key cryptography
standard #12 (PKCS #12) format from your management computer to the FortiVoice system.

DER encoding is not supported in FortiVoice version 2.0 GA.

Importing a certificate may be useful when:

l restoring a certificate backup
l installing a certificate that has been generated on another system
l installing a certificate, after the certificate request has been generated on the FortiVoice system and signed by a
certificate authority (CA)

If you generated the certificate request using the FortiVoice system, after you submit the certificate request to CA, the
CA will verify the information and register the contact information in a digital certificate that contains a serial number, an
expiration date, and the public key of the CA. The CA will then sign the certificate and return it to you for installation on
the FortiVoice system. To install the certificate, you must import it. For other related steps, see Obtaining and installing a
local certificate on page 97.

If the FortiVoice system’s local certificate is signed by an intermediate CA rather than a root CA, before clients will trust
the FortiVoice system’s local certificate, you must demonstrate a link with trusted root CAs, thereby proving that the
FortiVoice system’s certificate is genuine. You can demonstrate this chain of trust either by:

l installing each intermediate CA’s certificate in the client’s list of trusted CAs
l including a signing chain in the FortiVoice system’s local certificate

To include a signing chain, before importing the local certificate to the FortiVoice system, first open the FortiVoice
system’s local certificate file in a plain text editor, append the certificate of each intermediate CA in order from the
intermediate CA who signed the FortiVoice system’s certificate to the intermediate CA whose certificate was signed
directly by a trusted root CA, then save the certificate. For example, a local certificate which includes a signing chain
might use the following structure:

-----BEGIN CERTIFICATE-----
<FortiVoice system’s local server certificate>
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
<certificate of intermediate CA 1, who signed the FortiVoice certificate>
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
<certificate of intermediate CA 2, who signed the certificate of intermediate CA

1 and whose certificate was signed by a trusted root CA>
-----END CERTIFICATE-----

To import a local certificate

1. Go to System >Certificate > Local Certificate.
2. Click Import.
3. Select the type of the import file or files:

l Local Certificate: Select this option if you are importing a signed certificate issued by your CA. For other related
steps, see Obtaining and installing a local certificate on page 97.

l PKCS12 Certificate: Select this option if you are importing an existing certificate whose certificate file and
private key are stored in a PKCS #12 (.p12) password-encrypted file.

l Certificate: Select this option if you are importing an existing certificate whose certificate file (.cert) and key file
(.key) are stored separately. The private key is password-encrypted.
The remaining fields vary by your selection in Type
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4. Configure the following:
l Certificate name: Enter the name of the certificate.
l Certificate file: Enter the location of the previously .cert or .pem exported certificate (or, for PKCS #12
certificates, the .p12 certificate-and-key file), or click Import to locate the file.

l Key file: Enter the location of the previously exported key file, or click Import to locate the file.
l This option appears only when Type is Certificate.
l Password: Enter the password that was used to encrypt the file, enabling the FortiVoice system to decrypt and
install the certificate.
This option appears only when Type is PKCS12 certificate or Certificate.

5. ClickOK.

Assigning a local certificate to a service

You can assign a local certificate to one or more services (HTTPS, LDAPS, SIP TLS, and SIPWSS), as applicable.

1. Go to System > Certificate > Local Certificate.
2. To select the certificate, click the row in the certificate table.
3. Click Assign to.
4. From the Predefined list, select the service, and click >> to move this service to the Selected list.
5. ClickOK.
6. If the change is for an LDAPS, SIP TLS, or SIP WSS service, all active calls will be disconnected to apply the

certificate change. To confirm the service change, click Yes.
7. If the change is for the HTTPS service, the FortiVoice GUI asks you to perform the following steps:

a. To confirm the service change, click Yes.
b. To reload the FortiVoice GUI, press OK.
c. Wait for a few seconds.
d. If the reload is unsuccessful, reload the FortiVoice GUI in your web browser.

Downloading a PKCS #12 certificate

You can export certificates from the FortiVoice system to a PKCS #12 file for secure download and import to another
platform, or for backup purposes.

To download a PKCS #12 file

1. Go to System > Certificate > Local Certificate.
2. Click the row that corresponds to the certificate in order to select it.
3. Click Download, then select Download PKCS12 File on the pop-up menu.

A dialog appears.
4. In Password and Confirm password, enter the password that will be used to encrypt the exported certificate file. The

password must be at least four characters long.
5. ClickOK.
6. If your browser prompts you for a location to save the file, select a location.
7. Your web browser downloads the PKCS #12 (.p12) file. For information on importing a PKCS #12 file, see Importing

a certificate on page 100.
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Managing certificate authority certificates

Go to System > Certificate > CA Certificate to view and import certificates for certificate authorities (CA).

Certificate authorities validate and sign other certificates in order to indicate to third parties that those other certificates
may be trusted to be authentic.

CA certificates are required by connections that use transport layer security (TLS), and by S/MIME encryption.
Depending on the configuration of each PKI user, CA certificates may also be required to authenticate PKI users.

To view the list of CA certificates, go to System > Certificate > CA Certificate. You can remove, view, download, or import
a CA certificate.

Managing the certificate revocation list

The Certificate Revocation List tab lets you view and import certificate revocation lists.

To ensure that your FortiVoice system validates only valid (not revoked) certificates, you should periodically upload a
current certificate revocation list, which may be provided by certificate authorities (CA).

To view remote certificates, go to System >Certificate > Certificate Revocation List. You can remove, view, download, or
import a certificate revocation list.

Managing APNs and VoIP services certificates

An Apple iPhone using the FortiFone softclient for iOS requires the following certificates on the FortiVoice phone system:

l Apple Push Notification service (APNs): Used to receive notification messages. The certificate name is
fortifone.push.

l VoIP services: Used to receive incoming calls. The certificate name is fortifone.voip.

To view the list of APNs and VoIP services certificates, go to System > Certificate > APNS Push Certificate.

GUI field Description

Name Displays the certificate name (fortifone.push or fortifone.voip).

Subject Displays details of the entity associated with the certificate.

Expiration Indicates the expiration status of the certificate:
l Green icon: The certificate is valid.
l Orange icon: The certificate will expire soon. You have 30 days or less to
import a new certificate.

l Red icon: The certificate is expired.

To view APNs and VoIP services certificate details

1. Go to System > Certificate > APNS Push Certificate.
2. Select a certificate and click View.

l Certificate Name is either fortifone.push or fortifone.voip.
l Issuer is the authority who has signed and issued the certificate.
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l Subject is the entity associated with the certificate.
l Valid from and Valid to specifies the period when the certificate is valid.

To import APNs and VoIP services certificates

1. Prior to the expiry of the certificates, contact Fortinet Support to start the process to obtain new certificates
(fortifone.push and fortifone.voip).

Importing an APNs certificate or a VoIP services certificate replaces an existing certificate.
You cannot delete a certificate.

2. With your assistance, a Fortinet Support representative will remotely access the FortiVoice phone system (System
> Certificate > APNS Push Certificate) to import the new certificates.

Maintaining the system

The System > Maintenance submenu allows you to perform scheduled maintenance.
This topic includes:
l Maintaining the system configuration on page 103
l Maintaining phones on page 104

Maintaining the system configuration

The System > Maintenance > Configuration tab contains features for use during scheduled systemmaintenance:
updates, backups, restoration, and centralized administration.

Backing up configuration

Before installing FortiVoice firmware or making significant configuration changes, back up your FortiVoice configuration.
Backups let you revert to your previous configuration if the new configuration does not function correctly. Backups let you
compare changes in configuration.

You can back up system configuration or user configuration. System configuration includes the configurations that make
the FortiVoice system work. User configuration includes user-configured settings, such as voicemail greetings, in
addition to system configuration.

In addition to backing up your configuration manually, you can also configure a schedule to back up the configuration
automatically to the FortiVoice local hard drive or a remote FTP/SFTP server.

To back up the configuration file
1. Go to System > Maintenance > Configuration.
2. In the Backup area, select System configuration or User data.

If you choose to back up user data and the user data files are not updated, select the files to be updated and click
Prepare first before proceeding to the next step.
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3. Click Backup.
Your management computer downloads the configuration file. Time required varies by the size of the file and the
speed of your network connection. You can restore the backup configuration later when required. For details, see
Restoring the configuration on page 104.

To schedule a configuration backup

1. Go to System > Maintenance > Configuration.
2. Under Scheduled Backup, configure the schedule time and the maximum backup number. When the maximum

number is reached, the oldest version will be overwritten.
3. Enable Local backup if you want to back up locally. You can select a backup type to view, restore, download, or

delete a configuration file.
4. Enable Remote backup and configure the FTP/SFTP server credentials if you want to back up remotely.
5. Click Apply.

Restoring the configuration

In the Restore Configuration area under System > Maintenance > Configuration > Trace Log, you can restore the backup
FortiVoice configuration from your local computer. For details, see Restoring the configuration on page 319.

Restoring the firmware

In the Restore Firmware area under System > Maintenance > Configuration > Trace Log, you can upgrade the
FortiVoice firmware from your local computer. This area has the same functionality as Dashboard > Status > Firmware
version > Update. For more details, see Upgrading the firmware on page 315.

Downloading a trace file

If Fortinet Technical Support requests a trace log for system analysis purposes, you can download one using the GUI.

Trace logs contain information that is supplementary to debug-level log files.

To download a trace file

1. Go to System > Maintenance > Configuration > Trace Log.
2. Configure trace log settings.
3. Click Prepare to make the trace log file ready before downloading it.
4. Click Download trace log.
5. Find the downloaded file and send it to Fortinet Technical Support.

Maintaining phones

The System > Maintenance > Phone Maintenance tab lets you update phone configurations, upgrade phone firmwares,
and reboot phones.

Tto view the phone configuration files that you have updated, click the Phone Configuration button. For more
information, see Viewing log messages on page 37.

To view the phone firmwares that you have upgraded, click the Phone Firmware button. For more information, see
Managing firmware on page 155.
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To update phone configurations or upgrade phone firmwares

1. Go to System > Maintenance > Phone Maintenance.
2. Click New and select Phone Configuration or Phone Firmware.
3. Configure the following:

GUI field Description

Name Enter a name for the operation.

Extension Selection Select the extension devices of which you want to perform the
operation.

All related devices
(enabled)

You want to update phone configurations or upgrade phone
firmwares for all devices.

All related devices
(disabled)

You want to update phone configurations or upgrade phone
firmwares for selected devices.

Phone Model: Select the phone model of the extensions of which
you want to perform the operation.

Extensions: Click the plus sign to select the extensions for the
selected phone model.

Schedule Schedule the time to update phone configurations or upgrade
phone
firmwares.

4. Click Create.

To view a phone maintenance job

1. Go to System > Maintenance > Phone Maintenance.
2. Double-click a maintenance job record to view the details of phone configuration or firmware upgrades.
3. If you want to redo an upgrade for one or multiple phones, select the phones and click Redo.

To reboot phones

1. Go to System > Maintenance > Phone Maintenance.
2. Click New > Phone Force Reboot.
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3. Configure the following:

GUI field Description

Name Enter a name for the phone reboot operation.

Extension Selection Select the extensions of which you want to perform the operation.

All devices You want to reboot all of the phones registered with the FortiVoice
system.

Selected devices You want to reboot some phones registered with the FortiVoice
system.

Phone Model: Select the phone model of the extensions of which
you want to perform the operation.

Extension: Click the plus sign to select the extensions for the
selected phone model.

Schedule Schedule the time to reboot the phones.

4. Click Create.
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The Phone Systemmenu lets you configure the FortiVoice PBX settings and other features for managing phone calls.

This topic includes:

l Configuring phone system settings on page 107
l Creating contacts on page 115
l Managing phone audio settings on page 117
l Working with FortiVoice profiles on page 121
l Configuring devices on page 143
l Reviewing system configuration on page 149

Configuring phone system settings

Phone System > Setting let you configure the FortiVoice system’s location, number management, speed dial, email
notification templates and system capacity.

You need to inform the users about some of the settings that affect them, such as number
setting and speed dial setting.

This topic includes:

l Setting PBX location and contact information on page 107
l Configuring PBX options on page 108
l Customizing call report and notification email templates on page 111
l Configuring system capacity on page 112

Setting PBX location and contact information

Identify the FortiVoice system’s location and its number.

To set the PBX location

1. Go to Phone System > Setting > Location.
2. Configure the following:

GUI field Description

Country/Region Select the country/region where the FortiVoice system is in.

Emergency number Click the default number (911) to enter the emergency call number of the selected country.
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GUI field Description

Long-distance prefix Click the Edit icon to enter the prefix for dialing long-distance calls.

International prefix Click the Edit icon to enter the prefix for dialing international calls.

Outside line prefix Click the Edit icon to enter the prefix for making outbound calls.

Area code Click the Edit icon to enter the Area code for the main number of the FortiVoice system.
This code is provided by your PSTN service provider.

Required when
dialing local
numbers

Select this option if the area code needs to be dialed for local phone calls.

Main display name Enter the name displaying on the FortiVoice system. This name is provided by your PSTN
service provider.

Main number Enter the main number of the FortiVoice system. This number is provided by your PSTN
service provider.

Default prompt
language

Select a new default prompt language for the FortiVoice system. The default is English.
This setting affects all of the FortiVoice system’s voice prompts, such as auto attendant
and voice mail. However, if you change the sound file for an individual component, such as
auto attendant, to use a different language, it will override the default prompt language for
this component.
For information on adding prompt languages, see Managing phone audio settings on
page 117.

Default emergency
zone

Select the default emergency contact or click + to add a new one.
For more information, see Configuring emergency zone profiles on page 142.

Default time zone Select a new default time zone for the FortiVoice system. The default is Pacific Time.

Contact Information Optionally, enter your contact information.

Emergency Setting Configure to send an alert email when an emergency call is made. You can add up to 30
email addresses.
You can also add a barge number to join an ongoing emergency call.
Select Do nothing if you do not want the FortiVoice system to send an alert email.
Otherwise, select Send Alert Email and enter the email address.
Click Customize Email Template if you want to modify the notification email template. For
more information, see Customizing call report and notification email templates on page
111.
Emergency barge number: Enter the extension number for authorized users to dial into an
ongoing emergency call to listen or provide information to the call.

3. Click Apply.

Configuring PBX options

The Phone System > Setting > Option tab lets you configure the pattern and number of digits you want the FortiVoice
system to use for phone numbers, speed dials, and prefixes as well as the default FortiVoice system settings. These
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settings apply to all extensions unless you change them when configuring the extensions. For details, see Setting up
local extensions on page 162.

The FortiVoice system supports the following pattern-matching syntax:

Syntax Description

X Matches any single digit from 0 to 9.

Z Matches any single digit from 1 to 9.

N Matches any single digit from 2 to 9.

[ ]
(square brackets)

Matches any digits in the brackets.
For a range of numbers, use a dash.
Example: [15-7].
In this example, the pattern matches 1, 5, 6, and 7.

.
(period)

Acts as a wildcard that matches any digit and allows for any number of digits to be
dialed.
Example of a pattern matching rule: XX.
In this example, the system looks for a dialed number match that has three or more digits.

!
(exclamation point)

Acts as a wildcard that matches any digit (including no digits) and allows for any number of
digits to be dialed.
Example of a pattern matching rule: XX!
In this example, the system looks for a dialed number match that has two or more digits.

Pattern-matching examples

Pattern Description

X. Matches any dialed number.

NXXXXXX Matches any seven-digit number, as long as the first digit is 2 or higher.

NXXNXXXXXX Matches any dialed number that has 10 digits.

1NXXNXXXXXX Matches any dialed number that matches this pattern: 1 + area code (between
200
and 999) + seven-digit number (first digit is 2 or higher).

011. Matches any number that starts with 011 and has at least one more digit.

XX! Matches any two or more digits.

To configure PBX options

1. Go to Phone System > Setting > Option.
2. Configure the following:

GUI field Description

Number Management
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GUI field Description

Extension number
pattern

Enter the extension number pattern. For example, NXXX is any
four-digit number as long as the first digit is 2 or higher and 7XXX is
a four-digit number that always starts with 7. This pattern will be
followed when creating extensions. See Configuring IP extensions
on page 162.

Speed dial pattern Enter the speed dial number pattern. For example, *3XX is any
three-digit number that starts with 3. This pattern will be followed
when configuring speed dials. See Mapping speed dials on page
267.

System prohibited
prefix

Enter the phone number prefix that you want to ban, such as 900.
Click the + sign to add up to 10.

System unrestricted
prefix

Enter the allowed phone number prefix, such as 800. Click the +
sign to add up to 10.

Operator extension Enter the extension for the operator of the FortiVoice system.

Supporting
extension

Enter the extension for technical support of the FortiVoice system.

Default Setting

Default SIP user
password

Enter your own password or let the FortiVoice system generate
one for you. This password is used for configuring your SIP phone
from the phone or the Web. You need the phone's IP to access it
from the Web. This password appears when you add an extension.
For details, see Configuring IP extensions on page 162.
l Specified: Enter the password. The password cannot be
blank, must be 8 or more characters, must contain at least one
uppercase character, one lowercase character and one
number. Non-alphanumeric characters, like ( - $, are not
supported in the password field.
The default password is voice#321.

l Generated: Select to have a system-generated password.

Default user
password

Enter your own password or let the FortiVoice system generate
one for you. This password is for user portal access. This password
appears when you add an extension. For details, see Configuring
IP extensions on page 162.
l Specified: Enter the password. The password cannot be
blank, must be 8 or more characters, must contain at least one
uppercase character, one lowercase character and one
number. Non-alphanumeric characters, like ( - $, are not
supported in the password field.
The default password is voice#321.

l Generated: Select to have a system-generated password.
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GUI field Description

Default Voicemail
PIN

Enter your own password or let the FortiVoice system generate
one for you. This password is for the extension user to access
voice mail and the user portal. This password appears when you
add an extension. For details, see Configuring IP extensions on
page 162.
If you select Specified, the default password is 123123.

User ID prefix Enter the prefix for the extension user ID. When you add a new
extension, the FortiVoice system will generate a user ID with this
prefix plus the extension number. For details, see Configuring IP
extensions on page 162.

Default ring duration Use this option to set phone ringing time for extensions and
FortiFone softclient for mobile phones.
l Adaptive: This is recommended for extensions with mobile
softclients.
Select this option and both the extensions and mobile
softclients will ring for 40 seconds before the call is processed
(for example, the call is sent to a voice mail). This setting is to
ensure that mobile softclients will not miss any calls due to
possible network transmission delays. You do not need to
enter any ring duration value. Any ring duration value already
entered will be ignored.

l Fixed: This is recommended for extensions without mobile
softclients.
Select this option and enter the ring duration value in seconds.
The extensions will ring for the ring duration value you entered
before the call is processed (for example, the call is sent to a
voice mail). The default is 20.

Internal calls ring
pattern

Select the system defined distinctive ring pattern for internal calls.

External calls ring
pattern

Select the system defined distinctive ring pattern for external calls.

3. Click Apply.

Customizing call report and notification email templates

Go to Phone System > Setting > CustomMessage to view and reword the default call report and notification email
templates.

The FortiVoice system sends out call reports based on your call report configuration (see Configuring report email
notifications on page 304) and notification email when, for example, you have a new voicemail or fax in your mailbox or
missed a call. You can customize the email templates for the call report and email notifications.

You can change the content of the email template by editing the text and HTML codes and by working with email
template variables. For descriptions of the default email template variables, open a template and select Edit Variable.

To customize call report and email templates
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1. Go to Phone System > Setting > CustomMessage.
2. Open Report or Email template to display the default templates.
3. To edit a template, double-click it or select it and click Edit.
4. To format template in HTML, use HTML tags, such as <b>some bold text</b>.

There is a limit of 250 characters for the Subject field, 60 characters for the From field, and 4000 characters for
Htmlbody and Textbodymessages each in the Content body field.

5. To add a variable:
l Select Insert Variables next to the area to insert a variable. A pop-up window appears.
l Place your mouse cursor in the text message at the insertion point for the variable.
l Click the name of the variable to add. It appears at the insertion point.
l To add another variable, click the message area first, then click the variable name.
l Click the Close (X) icon to close the window.

6. To insert a color:
l Click Insert Color Code. A pop-up window of color selection appears.
l Place your mouse cursor in the text at the insertion point for the color code, or highlight an existing color code to
change.

l Click a color in the color selection pop-up window.
For example, to replace the color code in the HTML tag <tr bgcolor="#3366ff">, you can highlight
"#3366ff", then select the color you want from the color palette.
To add a new color code, include it with HTML tags as applicable, such as <tr bgcolor="#3366ff">.

7. To determine if your HTML and color changes are correct, click Preview. The replacement message appears in
HTML format.

8. ClickOK, or click Reset To Default to revert the replacement message to its default text.

Configuring system capacity

The Phone System > Setting > Miscellaneous tab lets you set the PIN used by the administrator to override schedules,
configure voicemail greeting and message length, set phone directory options, configure CDR settings, and configure
queue logs.

To configure system capacity

1. Go to Phone System > Setting > Miscellaneous.
2. Configure the following:

GUI field Description

PBX Setting

Administrator PIN Enter the password used by the administrator to override
schedules.
This global password is also used by an administrator to connect a
FortiFone to the FortiVoice system to set mobile extension number.
For details, see Configuring SIP phone auto-provisioning on page
93.

PBX identification Enter a unique name for the FortiVoice system.
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GUI field Description

Local authentication
type

Select the method to access the user portal and softclient. By
default, both personal password and voicemail (user) PIN can be
used. Personal password and voicemail (user) PIN are set when
configuring extensions. Usually numbers are used as voicemail
PIN which are very easy to guess and can be cracked using some
HTTP password guess tool within minutes. That is why a separate
personal password is added which can be much longer and
stronger to mitigate the risk of password guess attack and preserve
the voicemail PIN for phone access only.
For more information, see Configuring IP extensions on page 162.
l User password or voicemail PIN: Both personal password and
user PIN can be used to access the user portal and softclient.

l User password only: Use personal password to access the
user portal and softclient.

Notification expiry Enter the email notification expiry time in hours. The range is 1-
2160 hours.

QR code expiry Enter the QR code expiry time in hours. The range is 1- 2160
hours.

System block list Enable to block phone numbers on the system level.
To block a number on the system level
1. Go toMonitor > Call History > Call Detail Record (CDR).
2. Select the number you want to block from the CDR list.
3. SelectMore Action > Block > Block Caller/Callee as required.
4. Go to Security > Blocked Number.

The number you selected is added to the block list.
5. Click Setting.
6. Enable System block list.
7. Click Apply.

Future calls from the number you selected to any extensions
on the FortiVoice system will be blocked.

Personal block list Enable to block phone numbers on a personal basis.
To block a number on a personal basis
1. Go to Phone System > Setting > Miscellaneous.
2. Enable Personal block list.
3. Click Apply.
4. Log in to the user portal.
5. Click Call History.
6. Select the number you want to block from the list.
7. SelectMore Action > Block.
8. Go to Contact > Personal Contact.
9. Click Personal Block List to verify that the blocked number is

listed.
Future calls from the number you selected to your extension
will be blocked.
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GUI field Description

Match personal
contact

Enable to show the unique name added to a number in the
personal contacts on your extension display.
To match a personal contact
1. Go to Phone System > Setting > Miscellaneous.
2. EnableMatch personal contact.
3. Click Apply.
4. Log in to the User Portal.
5. Click Call History.
6. Select the number you want to match to a personal contact.
7. ClickMore Actions > Add to Contact.
8. Enter a unique display name and other contact information for

the number
9. Click Create.
10. Go to Contact > Personal Contact.
11. Verify the number is listed with the unique name you entered.

When the number you selected calls, the unique display name
you entered will show on your extension screen.

Business Group This option is available on FVE-500E, FVE-500F, FVE-1000E, and
larger models only.
Select Disabled to hide business group in Extensions and select
Automatic to show it.
For more information, see Creating business groups on page 195.

Caller ID Select Format incoming caller id numbers to add dash signs (-) to
external or international call numbers.
For example, an incoming call with the number 13452345678 will
be formatted to 1-345-234-5678.

Schedule Override Select Allow admin user to override schedule if required.
An administrator with the privilege can dial *821, *822, or *823
followed by the administrator PIN to temporarily replace the original
schedule with one of the three default ones.
You may also modify the temporary schedule.
Dial *820 to go back to the original schedule.

Voicemail Enter the maximummessage length, greeting length, voicemail,
and greeting volume you want.

Directory Set phone directory options.

Dial-by-name option Select how a caller can check the directory by dialing a name.

Dial-by-name digits Enter the number of letters allowed for a caller to dial someone by
name. The range is 3-9. This feature enables a caller to reach a
specific person quickly by dialing, for example, the first three letters
of their first or last name from any phone.

Read back number Select if you want a person’s extension number to be read out after
you check the directory by dialing the person’s first or last name.
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GUI field Description

Read name
sequence

Select if you want a person’s name to be read out after you check
the directory by dialing the person's first or last name.
One by one: All names matching your dialed directory checking
pattern are read out one by one.
Menu group listing: For efficiency, the FortiVoice system breaks all
names matching your dialed directory checking pattern into groups
of 8 if applicable, and reads them out group by group.

List options Select the type of extension numbers to be included in the
directory.

Include directory Select to allow users to view all extension entries in the directory.

Include subdirectory To include department entries in the directory, select Department.
If your FortiVoice system supports the functionality, you may be
able to include additional subdirectories (Business Group and
Survivability Branch) but make sure to also complete the
configuration. See also: Creating business groups on page 195 or
FortiVoice Local Survivable Gateway Deployment Guide.
For complete details about directory filtering, see the Filtering the
phone directory section in the FortiVoice Cookbook.

Internet of Things

Amazon Alexa Select to enable configuring your FortiVoice system’s integration
with Amazon Alexa. This is the system global control.
For more information, see Configuring Internet of Things (IoT) on
page 294.

CDR Enter the time in months that you want to keep the call log/call
detail record and the maximum number of CDR records. For
information about call log/CDR, see Viewing call records on page
36.

Queue Log Enter the time in months that you want to keep the queue log and
the maximum number of log records. For information about queue
logs, see Viewing log messages on page 37.

3. Click Apply.

Creating contacts

The Phone System > Contactmenu lets you view phone directories and set up contacts.

You can also configure speed dial rules.

To view the phone directory

1. Go to Phone System > Contact > Directory.
All extensions on this FortiVoice system are displayed. You can download all contacts or the search result.

To create a contact
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1. Go to Phone System > Contact > Business Contact.
2. Click New and configure the following:

GUI field Description

Display name The name displaying on the caller’s phone. This is usually the name of the contact.

Main number Enter the phone number mainly used by the contact.

Mobile number Enter the contact’s cellphone number.

Home number Enter the contact’s home phone number.

Description Enter any notes for the address book.

3. Click Create.

To export a contact

1. Go to Phone System > Contact > Business Contact.
2. Select one or more records.
3. ClickOther Actions > Export.
4. Open or save the file in .csv format.
5. ClickOK.

To import a contact

1. Go to Phone System > Contact > Business Contact.
2. ClickOther Actions > Import.
3. Browse for the file you want. The file must be in .csv format.
4. ClickOK.

Configuring speed dials

For fast and efficient dialing, use the speed dial pattern to map the phone numbers, mostly outbound numbers.

For information on setting speed dial number pattern, see Configuring PBX options on page 108.

To map speed dials

1. Go to Phone System > Contact > Speed Dial Rule.
2. Click New.
3. Enter a name for the speed dial mapping.
4. For Dialed Pattern, enter the number based on the speed dial number pattern you set. For example, 333.
5. ForMapped Pattern, enter the phone number to map to the speed dial pattern.

You can enter digits 0–9, space, dash, comma, # and *.
Speed dial pattern accepts # as the lead digit ( Eg. #XX or #613XXX).
If you want to enter an auto attendant number followed by an extension, you can use comma (,) or semicolon (;) to
pause the automatic dialing.
A comma pauses dialing for two seconds, for example, 1-123-222-1234, 5678#. In this case, once pressing the
speed dial code you set, auto attendant 1-123-1234 is reached, and after two seconds, extension 5678 is
automatically dialed.
A semicolon pauses dialing for one second, for example, 1-123-222-1234; 5678#. In this case, once pressing the
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speed dial code you set, auto attendant 1-123-1234 is reached, and after one second, extension 5678 is
automatically dialed.

6. Optionally, enter a note for the mapping, such as “This is for customer A”.
7. Click Create.

Managing phone audio settings

The Phone System > Audio > Promptmenu lets you upload, record, and play phone sound files such as voicemail
greetings, announcements, and music on hold. The following default sound files are available and ready to use:

l callback_prompt_default: Includes an announcement about a callback and asks the user to wait for the next
available representative.

l greeting_default: Includes a generic greeting asking the user to press an extension or the number sign (#) to reach
the directory.

l music_on_hold_default: Includes recorded instrumental music that can play for on-hold calls, conference calls, and
auto attendants.

l welcome_default: Congratulates the user for successfully completing the set up of the FortiVoice phone system.

The Phone System > Audio > Music On Holdmenu lets you select a sound file and settings. The sound file can be used
when configuring music on hold for conference calls, call queues, and call parking. See Configuring music on hold on
page 118.

The Phone System > Audio > Prompt Languagemenu is used to set for FortiVoice voice greetings, such as auto
attendant and voicemail. The FortiVoice phone system includes eight prompt languages. The default prompt language is
English. See Uploading a prompt language on page 118. For more information about setting the default prompt
language, see Setting PBX location and contact information on page 107.

This section includes the following topics:

l Uploading or recording sound files on page 117
l Configuring music on hold on page 118
l Uploading a prompt language on page 118
l Recording sound files using an audio software on page 119

Uploading or recording sound files

1. Go to Phone System > Audio > Prompt.
2. Click New.
3. Enter a File name.
4. You can leave the File ID empty or enter a number with a maximum of 6 digits.
5. Select a file Type (Prompt Sound File orMusic on Hold).
6. Optionally, enter a Description for the file.
7. For Voice language, you have two options (Upload or Record):
8. To upload a sound file:

a. Make sure that the file you want to upload is a WAVE file (.wav) in PCM format.
l For a prompt sound file, the maximum size is 10 MB.
l For a music on hold file, the maximum size is 50 MB.
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b. Click Upload.
c. Select a file.
d. ClickOpen.

9. To record a sound file:
a. Click Record.
b. On the Send Voice Recording Call dialog box, enter the extension that you will use to record the file, and click

Send to dial the extension. You can edit the extension or add a new one. For details, see Configuring IP
extensions on page 162.

c. When the extension rings, record the sound file and hang up.
The Voice recording request sent to specified extension dialog box displays on the FortiVoice GUI.

d. Click Yes.
10. Click Create.

Configuring music on hold

1. Go to Phone System > Audio > Music on Hold.
2. Click New.
3. Configure the following:

GUI field Description

Name Enter a name for the music on hold entry.

Mode

Files If you select to use existing sound files, do the following:
l For Sound files, click + and select the sound files. For details about adding a sound
file, see Uploading or recording sound files on page 117.

l For Play mode, if you want to play the selected sound files randomly, select Random.
If you want to play the files according to the order in the Sound files field, select
Sequential.

Stream Before deciding to use streaming files, make sure to only use legal stream sources.
If you select to use streaming files, in the Stream URL field, enter the URL where the
streaming music is, such as a radio station. This way, the music is delivered to the
FortiVoice system and played virtually straight away. You can click Test stream to see if
the URL is added successfully.

Volume Set the music sound volume.

Description Optionally, enter a description for the entry.

4. Click Create.

Uploading a prompt language

The Phone System > Audio > Prompt Languagemenu includes 8 languages (English, Spanish, French, Italian, Polish,
Brazil Portuguese, Russian, Chinese). It's possible to add other prompt languages (Polish, Cantonese, Japanese,
Korean).
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1. Contact Fortinet Support to obtain the FortiVoice language package format (.fvl) file for the language that you want
to add.

2. Save the .fvl file to your management computer.
3. Go to Phone System > Audio > Prompt Language.
4. Click New.
5. Click Upload and locate the .fvl file.
6. Click Create.

Recording sound files using an audio software

You can use an audio software and a microphone to record a sound file. This section uses the Audacity software as an
example to help you choose the correct settings.

If you prefer to place a call to an extension to record a sound file, see Uploading or recording sound files on page 117.

To record a sound file

1. On Audacity, go to Edit > Preferences.
2. Click the Devicesmenu.
3. In Channels, select 1(Mono).

4. Click theQualitymenu.
5. In Default Sample Rate, select 44100 Hz.
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6. In Default Sample Format, select 16 bit.

7. ClickOK.
8. When you are ready, record your message.
9. Save the file in a format that works with the FortiVoice system.

a. Go to File > Export > Export Audio.
b. In Save in, select the directory where you want to save the file.
c. In File name, enter the required file name. The correct file extension is automatically added at the end of the file

name according to the format that you select in Save as type.
d. In Save as type, select WAV (Microsoft).
e. In Encoding, select Signed 16-bit PCM.
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f. Click Save.

g. If the Edit Metadata tags dialog appears, you can add tags and clickOK.
The recording is now in a format that you can load onto the FortiVoice system (seeUploading or recording
sound files on page 117).

Working with FortiVoice profiles

The Phone System > Profile tab lets you create user privileges and SIP profiles for configuring extensions and SIP
trunks. It also allows you to modify caller IDs, schedule the FortiVoice system, and configure phone and LDAP profiles.

This topic includes:

l Configuring SIP profiles on page 122
l Modifying caller IDs on page 124
l Configuring phone profiles on page 125
l Configuring programmable keys profiles on page 129
l Configuring LDAP profiles on page 132
l Configuring RADIUS authentication profiles on page 137
l Configuring user privileges on page 137
l Configuring emergency zone profiles on page 142
l Scheduling the FortiVoice system on page 142
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Configuring SIP profiles

Configure the supported phone features and codecs and apply them to the extensions and SIP trunks.

Communicate with your VoIP service provider because the profile settings are subject to the
capabilities of the VoIP service provider. For example, if some of your features and codecs are
not supported by your VoIP service provider, they will not work even if they are enabled or
selected in the SIP profile.

The default SIP profiles can be edited but cannot be deleted.

For information about extensions, see Configuring extensions on page 162.

For information about SIP trunks, see Configuring trunks on page 200.

To configure a SIP profile

1. Go to Phone System > Profile > SIP and click New.
2. Configure the following:

GUI field Description

Name Enter a name for this profile.

DTMF Select the dual-tone multi-frequency (DTMF) method used by the VoIP
provider. Options are RFC2833, Inband, and Info.

Keep alive Enable and enter the time interval in seconds for the FortiVoice system to talk
to the SIP server of your service provider to keep the connectivity and check its
capability.
Keep alive value must be between 30 and 600.

NAT Select if the VoIP service provider supports SIP NAT translation.

T.38 Select if the VoIP service provider supports fax over VoIP network.

Registration interval To keep the extensions’ registration status with the FortiVoice system, keep
the default value of the extension registration time interval or enter the value in
seconds as required by the FortiVoice system.
The default is 1800. The range is from 10 to 28800.
For more information, see Configuring SIP settings on page 89.
For more details about the priority of this setting, see Understanding the
hierarchy of extension registration and subscription interval settings on page
123.

Subscription interval To keep the extensions’ subscription status with the FortiVoice system, keep
the default value of the extension subscription time interval or enter the value in
minutes as required by the FortiVoice system.
The default is 60. The range is from 10 to 1440.
For more information, see Configuring SIP settings on page 89.
For more details about the priority of this setting, see Understanding the
hierarchy of extension registration and subscription interval settings on page
123.
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GUI field Description

Transport Transport: SIP commonly uses TCP or UDP port 5060 and/or 5061. Port 5060
is used for non-encrypted SIP signaling sessions and port 5061 is typically
used for SIP sessions encrypted with Transport Layer Security (TLS).
Enable the protocols as required.
This option, if applied to a user, overrides the system-wide transport settings .
For more information, see Configuring SIP settings on page 89.
Secure RTP: Select to provide encryption, message authentication and
integrity, and replay protection to the FortiVoice Real-time Transport Protocol
data.

Codec Select the audio and video codecs supported by the VoIP service provider.
Among the selected ones, choose the preferred one for the VoIP provider. The
preferred codec is usually the most used one in your area and provides the
best quality of communication.
If your preferred codec is different from that of your VoIP service provider, the
service provider’s codec will be used as long as it is one of your supported
codecs.

3. Click Create.

Understanding the hierarchy of extension registration and subscription interval
settings

As there are multiple areas where you can modify the extension registration and subscription intervals in the FortiVoice
UI, the following table shows the available options from the highest priority (1) to the lowest priority (3).

For example, if you configure the registration and subscription intervals using a SIP profile (priority 1) and survivability
branch (priority 2), the FortiVoice system uses the settings in the SIP profile because this option has a higher priority.

Priority GUI path Setting

1 Phone System > Profile > SIP l Registration interval
l Subscription interval

For more details about the settings, see Configuring SIP
profiles on page 122.

2 Managed System > Survivability >
Survivability Branch > Survivability

l SIP phone registration interval
l SIP phone subscription interval

For more details about the settings, see the FortiVoice
Local Survivable Gateway Deployment Guide.

3 System > Advanced > SIP l Registration interval
l Extension registration interval range
l Internal extension registration interval
l External extension registration interval

l Subscription interval
l Extension subscription interval range
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Priority GUI path Setting

l Extension subscription interval
For more details about the settings, see Configuring SIP
settings on page 89.

Modifying caller IDs

You can change the phone number, caller’s name, or both that will appear on the destination phone.

Caller ID modifications are used when configuring dial plans. For more information, see Configuring call routing on page
220.

To modify a caller ID

1. Go to Phone System > Profile > Caller ID Modification.
2. Click New and configure the following:

GUI field Description

Name Enter the name for this caller ID modification record. The name can only
contain numbers, underscores, and lowercase and uppercase letters.

Match number Enter the extension number or number pattern you want to modify.
For example, you can enter 8134 to modify a single extension, or 81xx to
modify all the four-digit numbers starting with 81.
For more details about the creation of a match number, see the Pattern-
matching syntax on page 227 and Pattern-matching examples on page 227.

Number Modification If you have entered a number or number pattern inMatch number field,
configure the following values to modify it:
l Strip: Enter a number to hide the starting part of an extension from
displaying. 0 means no action.
For example, if yourMatch number is 8134 and Strip is 2, only 34 will be
displayed as caller ID.

l Truncate: Enter a number to hide the ending part of an extension from
displaying. 0 means no action.
For example, if yourMatch number is 8134 and Truncate is 2, only 81 will
be displayed as caller ID.

l Prefix: Add a number before an extension.
For example, if yourMatch number is 8134 and Prefix is 5, the caller ID
will be 58134.

l Postfix: Add a number after an extension.
For example, if yourMatch number is 8134 and Postfix is 5, the caller ID
will be 81345.

Match option Select the way to match a call with caller name and number in order to modify
call number or caller ID.
l Match Number or Name: If the number is matched, modifications will be
done based on Number Modification configuration. If the name is
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GUI field Description

matched, modifications will be done based onMap to new caller ID name
configuration.

l Match Number then Name: If the number is matched, modifications will be
done based on Number Modification configuration. If both the number and
name are matched, modifications will be done based onMap to new caller
ID name configuration.

l Match Name then Number: If the Name is matched, modification will be
done based onMap to new caller ID name configuration. If both the name
and number are matched, modifications will be done based on Number
Modification configuration.

l Match Number and Name: If both the number and name are matched,
modifications will be done based on Number Modification andMap to new
caller ID name configurations.

Match caller ID name Enter the caller ID that you want to map to another one.
Caller IDs are created when configuring SIP extensions. See Configuring IP
extensions on page 162.

Map to new caller ID name Enter the new caller ID name that you want to map to the one entered in the
Match caller ID name field.

Block Caller ID Select to stop your caller ID from displaying on the destination phone.

3. Click Create.

Mapping a group of extensions to a caller ID name

If you want to map a group of extensions to a caller ID name, you can use the pattern for the extensions to do so.

For example, if you have a technical support team that has 10 extensions (8100-8110), instead of displaying each
extension when making calls, you can just display one caller ID name “Support” for the whole team.

To map a group of extensions to a caller ID name

1. Go to Phone System > Profile > Caller ID Modification.
2. Click New.
3. In theMatch new number field, enter the pattern of the extensions, such as 81xx.
4. In theMatch option field, selectMatch Number or Name.
5. In theMap to new caller ID name field, enter the caller ID name to which you want to map, such as “Support”.
6. Click Create.

Configuring phone profiles

Phone profiles contain the phone configurations that are mostly used and customized, such as the programmable phone
keys. Phone profiles make extension configuration more flexible because phone users are allowed to choose the profile
they want. In addition, any changes the administrator makes to a profile is automatically applied to the extensions that
use the profile. For more information, see Configuring IP extensions on page 162.

The phone profiles configured here appear as Admin defined profiles when you configure a SIP extension.
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To configure a phone profile

1. Go to Phone System > Profile > Phone.
2. Click New and configure the following:

GUI field Description

Name Enter a name for the profile.

Phone model Select a phone model for the profile.

Time format Select the time display format on the phone.
North American: mm/dd/yyyy
International: dd/mm/yyyy

Phone book Select Local only to include the phone directory on this FortiVoice system, andGlobal to
include the phone directories of any remote FortiVoice systems connected to this system.
For information on phone directories, see Viewing call directory on page 40.

Phone language Select the language display on the phone.

Description Enter any notes you have for this profile.

VLAN You may need to deploy phones using the existing IT infrastructure which only has one
network drop for each employee. The network switch supports 802.1Q VLAN tagging and
LLDP-MED. Some phones such as FortiFones have two network ports: LAN and PC. The
recommended solution is to connect FortiFones to the switch using LAN port and connect
the computer to the PC port of FortiFones. VLAN tag needs to be enabled to segregate
FortiFone voice network and PC data network.

Option If you selectManual, configure the following:
l Enable VLAN tagging for voice: Select to enable VLAN tagging to segregate
FortiFone voice network and PC data network.

l Voice VLAN ID: Enter your organization’s VLAN ID for voice.
l Priority for voice: Enter the traffic service level recommended by the IEEE. Each
number represents a traffic type. The range is from 0-7, with 7 being the highest.
l 0: Background
l 1: Best Effort
l 2: Excellent Effort
l 3: Critical Applications
l 4: Video, < 100 ms latency and jitter
l 5: Voice, < 10 ms latency and jitter
l 6: Internetwork Control
l 7: Network Control

l Enable VLAN tagging for data: Select to enable VLAN tagging to segregate PC data
network and FortiFone voice network.

l Data VLAN ID: Enter your organization’s VLAN ID for data.
l Priority for data: Enter the traffic service level recommended by the IEEE. Each
number represents a traffic type. The range is from 0-7, with 7 being the highest.
l 0: Background
l 1: Best Effort
l 2: Excellent Effort
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GUI field Description
l 3: Critical Applications
l 4: Video, < 100 ms latency and jitter
l 5: Voice, < 10 ms latency and jitter
l 6: Internetwork Control
l 7: Network Control

If you select LLDP (Link Layer Discovery Protocol), the FortiVoice system automatically
generates the configuration file. You need to enable LLDP support on your network switch.
Enable LLDP transmit status: Enable or disable the LLDP transmit status to allow listening
or learning LLDP-MED from the switch only. This option applies to FortiFone-175, 375,
475, 575, 670, 675, H25, and H35.

Automatic
Configuration

Display option Select what to display on the extension: the extension user’s name only or name and
number.

Digit map
pause timer

Enter the digit map timeout in seconds which defines the waiting time between the
completion of dialing number entering and initiating the call.
For example, if you enter 5 and use the default digit map syntax, the phone will initiate a
call 5 seconds after you finish entering the dialing number.

Intercom barge If you select FortiFone-175, 375, or 475 for Phone model, you can enable intercom barge
to allow intercom drop-in in a phone conversation.

Screensaver
timer

Select the screen saver time for the phone model you selected. This option varies for
different phone models and is not available for all phone models.

Button
transparency

If you select FortiFone-570 for Phone model, select the percentage of phone buttons’
background color transparency.

Backlight time Set the phone backlight time to illuminate the screen in low light conditions.

Hangup delay Set the delay time to disconnect calls after hanging up.
This option does not apply to all models.

Popup missed
call

Enable if required.
This option does not apply to all models.

Keep alive This option is available when you select FortiFone-X80 for Phone model.
Enter a value for FortiFone to send a packet to the FortiVoice system at the interval of the
entered keep alive value to keep the firewall ports open at all time. This is to ensure that
calls are not missed due to the registration time change for external IP extensions.
For example, if you enter 40, FortiFone will send a 2 byte packet every 40 seconds to keep
the firewall ports open.

External keep
alive

This option is available when you select FortiFone-X80 for Phone model.
For external FortiFone-X80 extensions, the default keep alive option is 40 seconds. This is
to ensure that calls are not missed due to the registration time change for external IP
extensions.
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GUI field Description

DST type Set the Daylight Saving Time for the phone. This option does not apply to all models.
l Disabled: DST on the phone is disabled.
l Automatic: DST on the phone is automatically set based on your location.

Appearance
Transfer

Choose the call transfer mode for the extension appearance programmable key of
FortiFone-x80 phones.
The default is Blind.
l Blind: Allows you to transfer a call without speaking to the person receiving the
transfer.

l Attended: Allows you to announce the call to the person receiving the transfer before
completing the transfer.

For information on extension appearance programmable keys, see Configuring
programmable keys profiles on page 129.

Use pound(#)
as dial or send
key

Select to enable this option.
If you enable this option, users can use the pound key (#) to invoke dialing. For example,
when the user presses 19001#, the phone calls extension 19001.
If you disable this option, users can use the pound key (#) as a phone number prefix such
as #19002.
This option does not apply to all models.

Call Busy Tone Select to enable this call busy tone option.
When a call enters the busy tone state and this option is enabled, the FON-x80 phone
plays a busy tone.
When a call enters the busy tone state and this option is disabled, the FON-x80 phone
disconnects the call instead of playing a busy tone.

TCP auto
switch

This option applies to FON-x80 phones only.
If the phone uses TCP, this option does not have any impact on sending SIP requests.
If the phone uses UDP and you enable this option, you allow the phone to send SIP
requests that are larger than 1300 bytes using TCP. However, this switch is not permanent
meaning that the phone will use UDP to send any subsequent SIP requests that are
smaller than 1300 bytes.

Phone Image
Setting

Background
image

This option only appears when you edit a phone profile.
This option allows you to change the background image on a FortiFone-x80 phone.
Click Change to upload the image. Click Reset to restore the default image setting.
File requirements for a background image:
l Supported format: jpg
l Supported sizes:

l FON-380: 480 x 320 pixels
l FON-480: 480 x 272 pixels
l FON-580: 480 x 272 pixels
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GUI field Description

Hotel If you select FortiFone-H35 for Phone model, enter the hotel contact information and
instructions on how to dial rooms, local, long distance, and international number.
You may also select the font color for the call display.

Soft Button In
Idle Status

Optionally, enable the 4 soft buttons and make them functional in idle status.
This option does not apply to all models.

Phone Password Enter a password for the phone users to access their phone web GUI and configure the
advanced settings on the phones.
This option applies to the supported phones only.

3. Click Create.

Configuring programmable keys profiles

The Programmable Keys submenu lets you configure the programmable keys for FortiFones. For FortiFones with
expansion modules or multiple key pages, you can select the module or page to program the keys.

After a programmable keys profile is applied to an extension, the keypad programming is always the same regardless of
the phone for the extension.

To configure a programmable keys profile

1. Go to Phone System > Profile > Programmable Keys.
2. Click New.
3. Enter the profile name, select a phone type, enter any notes you have for the profile, and click Create.
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4. Double-click the profile you created and configure the following:

GUI field Description

Provisioning lines Select the phone lines you want to reserve. For example, if you
select 2 for this phone, number 1 and 2 on the keypad become
reserved for phone lines.

Number of expanded modules Select the number of expanded modules for the keypad.
This option only appears for certain FortiFone models.

Number of pages to be used on this phone Select the number of pages for the keypad.
This option only appears for certain FortiFone models.

Base/Page/Expanded Module Fields display depending on the phone model.

Option The keypad number of the phone.

Mode l User: Allows the user to set a programmable key using the
FortiVoice user portal and endpoints (FortiFone desk phone
and FortiFone softclient for desktop).

l Admin (with User Assigned function): Allows the user to set a
programmable key using a FortiFone desk phone.

l Admin: Allows you to set a programmable key with a function,
resource and label, as applicable. The user cannot make
changes to that programmable key.

Function Select the function assigned to this key.

Resource For some functions, you need to enter the information in this field
based on your phone configuration. For example, if you select
function Line appearance for key 3, select what the line is for in this
field.

Label For some functions, you can add a explanatory label for the key.

5. ClickOK.

Programmable keys descriptions

Function Description Resource Label

Call forward Allows you to enable or disable and configure the Call
Forward feature.

Stays blank. Edit the label or
keep the default
label (Call
forward).

DTMF When you are on a call and you press the DTMF key,
the system dials the configured DTMF digits.
This key is useful when you need to enter consistent
codes at an interactive voice response (IVR) system.

The DTMF functions is only available
during a call.

Enter the DTMF
digits to dial
when you press
this
programmable
key on your
phone.

Edit the label or
keep the default
label (DTMF).
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Function Description Resource Label

Extension
appearance

Allows you to quickly monitor the selected extension. Select an
extension from
the list.

Edit the label or
keep the one
associated with
the selected
extension.

Intercom Allows you to use the phone speaker of a local
extension as an intercom.

This function works for internal
extensions only.

Stays blank. Edit the label or
keep the default
label (Intercom).

Line appearance Allows you to monitor the status of a line (available,
busy, or on hold).

Select a line. Edit the label or
keep the one
associated with
the selected line
(or trunk).

Park Places the call into the first available call park slot.
You will hear a prompt telling you which slot the call
has been parked in.

Stays blank. Edit the label or
keep the default
label (Auto
park).

Park appearance Allows you to perform the following actions:
l Monitor the selected call park slot to know when
there is a call parked.

l Retrieve a parked call.

Select the park
slot to monitor.

Edit the label or
keep the one
associated with
the selected line
(or slot).

Reserved for line By default, the FortiVoice phone system reserves the
first two programmable keys for lines on the phone so
you can monitor your own calls on those lines.
If your phone has additional lines, then you can use
the Reserved for line function to program the
appearance of those lines.

If multiple
accounts have
been configured
on this
extension,
choose which
account to
monitor.

Edit the label or
keep the one
associated with
the selected line
(or account).

System speed dial Allows you to quickly place a call to the selected
extension or phone number at a touch of a button.

Make a
selection.

Edit the label or
keep the one
assigned by the
FortiVoice
system
administrator.
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Function Description Resource Label

Twinning Allows an external phone to ring along with your office
phone, so you can answer the call at either phone.
Pressing the Twinning programmable key enables or
disables the feature.
Before using this function, make sure that a profile
(with twinning enabled) is applied to the extension.

Stays blank. Edit the label or
keep the default
label
(Twinning).

User speed dial Allows you to quickly place a call to the selected
extension or phone number at a touch of a button.

Select a contact
from your speed
dial list.

Edit the label or
keep the one
associated with
the selected
contact.

Configuring LDAP profiles

The LDAP submenu lets you configure LDAP profiles which can query LDAP servers for authentication.

Before using an LDAP profile, verify each LDAP query and connectivity with your LDAP
server. When LDAP queries do not match with the server’s schema and/or contents,
unintended phone call processing behaviors can result.

LDAP profiles each contains one or more queries that retrieve specific configuration data, such as user groups, from an
LDAP server. The LDAP profile list indicates which queries you have enabled in each LDAP profile.

To view the list of LDAP profiles, go to Phone System > Profile > LDAP.

GUI field Description

Profile Name The name of the profile.

Server The domain name or IP address of the LDAP server.

Port The listening port of the LDAP server.

Auth Indicates whether User Authentication Options is enabled.

Cache Indicates whether query result caching is enabled.

(Green dot in column heading) Indicates whether the entry is currently referred to by another item in the
configuration. If another item is using this entry, a red dot appears in this column,
and the entry cannot be deleted.

You can add an LDAP profile to define a set of queries that the FortiVoice system can use with an LDAP server. You
might create more than one LDAP profile if, for example, you have more than one LDAP server, or you want to configure
multiple, separate query sets for the same LDAP server.

After you have created an LDAP profile, LDAP profile options will appear in other areas of the FortiVoice system’s
configuration. These options let you to select the LDAP profile where you might otherwise create a reference to a
configuration item stored locally on the FortiVoice system itself. These other configuration areas will only allow you to
select applicable LDAP profiles — that is, those LDAP profiles in which you have enabled the query required by that
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feature. For example, if a feature requires a definition of user groups, you can select only from those LDAP profiles
whereGroup Query Options are enabled.

To configure an LDAP profile

1. Go to Phone System > > Profile > LDAP.
2. Click New to add a profile or double-click a profile to modify it.

GUI field Description

Profile name For a new profile, enter its name.

Server name/IP Enter the fully qualified domain name (FQDN) or IP address of the LDAP
server.
Port: Enter the port number where the LDAP server listens.
The default port number varies by your selection in Use secure connection:
port 389 is typically used for non-secure connections, and port 636 is typically
used for SSL-secured (LDAPS) connections.

Fallback server name/IP Optional. Enter the fully qualified domain name (FQDN) or IP address of an
alternate LDAP server that the FortiVoice system can query if the primary
LDAP server is unreachable.
Port: Enter the port number where the fallback LDAP server listens.
The default port number varies by your selection in Use secure connection:
port 389 is typically used for non-secure connections, and port 636 is typically
used for SSL-secured (LDAPS) connections.

Use secure connection Select whether to connect to the LDAP servers using an encrypted connection.
l None: Use a non-secure connection.
l SSL: Use an SSL-secured (LDAPS) connection.

Click Test LDAP Query to test the connection. A pop-up window appears. For
details, see Testing LDAP profile queries on page 136.

Base DN Enter the distinguished name (DN) of the part of the LDAP directory tree within
which the FortiVoice system will search for user objects, such as
ou=People,dc=example,dc=com.
User objects should be child nodes of this location.

Bind DN Enter the bind DN, such as cn=FortiVoiceA,dc=example,dc=com, of an
LDAP user account with permissions to query the Base DN.
This field may be optional if your LDAP server does not require the FortiVoice
system to authenticate when performing queries.

Bind password Enter the password of the Bind DN.
Click Browse to locate the LDAP directory from the location that you specified
in Base DN, or, if you have not yet entered a Base DN, beginning from the root
of the LDAP directory tree.
Browsing the LDAP tree can be useful if you need to locate your Base DN, or
need to look up attribute names. For example, if the Base DN is unknown,
browsing can help you to locate it.
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GUI field Description

Before using, first configure Server name/IP, Use secure connection, Bind DN,
Bind password, and Protocol version, then click Create orOK. These fields
provide minimum information required to establish the directory browsing
connection.

3. Configure the following sections:
l Configuring authentication options on page 134
l Configuring advanced options on page 135

4. Click Create, OK or Apply.
The LDAP profile appears in the LDAP profile list. To apply it, select the profile in features that support LDAP
queries, such as protected domains and policies.
Before using the LDAP profile in other areas of the configuration, verify the configuration of each query that you
have enabled in the LDAP profile. Incorrect query configuration can result in unexpected phone processing
behavior. For information on testing queries, see Testing LDAP profile queries on page 136.

Configuring authentication options

The following procedure is part of the LDAP profile configuration process. For general procedures about how to
configure an LDAP profile, see Configuring LDAP profiles on page 132.

1. Go to Phone System > Profile > LDAP.
2. Click New to create a new profile or double click on an existing profile to edit it.
3. Click the arrow to expand the User Authentication Options section.
4. Configure the following:

GUI field Description

Try Common Name with Base
DN as Bind DN

Select to form the user’s bind DN by prepending a common name to the base
DN. Also enter the name of the user objects’ common name attribute, such as
cn or uid into the field.

Search User and Try Bind DN Select to form the user’s bind DN by using the DN retrieved for that user by
configuring the following:
l LDAP user query: Enter an LDAP query filter that selects a set of user
objects from the LDAP directory.
The query string filters the result set, and should be based upon any
attributes that are common to all user objects but also exclude non-user
objects.
For example, if user objects in your directory have two distinguishing
characteristics, their objectClass and extension attributes, the query
filter might be:
(& (objectClass=inetOrgPerson) (telephonenumber=$u))

where $u is the FortiVoice variable for a user's extension.
This option is preconfigured and read-only if you have selected from
Schema any schema style other than User Defined.

l Schema: If your LDAP directory’s user objects use a common schema
style:
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GUI field Description
l InetOrgPerson
l Active Directory

Select the schema style. This automatically configures the query string to
match that schema style.
If your LDAP server uses any other schema style, select User Defined,
then manually configure the query string.

l Scope: Select which level of depth to query, starting from Base DN.
l One level: Query only the one level directly below the Base DN in the
LDAP directory tree.

l Subtree: Query recursively all levels below the Base DN in the LDAP
directory tree.

l Derefer: Select the method to use, if any, when dereferencing attributes
whose values are references.
l Never: Do not dereference.
l Always: Always dereference.
l Search: Dereference only when searching.
l Find: Dereference only when finding the base search object.

Configuring advanced options

The following procedure is part of the LDAP profile configuration process. For general procedures about how to
configure an LDAP profile, see Configuring LDAP profiles on page 132.

1. Go to Phone System > Profile > LDAP.
2. Click New to create a new profile or double click on an existing profile to edit it.
3. Click the arrow to expand the Advanced Options section.
4. Configure the following:

GUI field Description

Timeout (seconds) Enter the maximum amount of time in seconds that the FortiVoice system will
wait for query responses from the LDAP server.

Protocol version Select the LDAP protocol version used by the LDAP server.

Enable cache Enable to cache LDAP query results.
Caching LDAP queries can introduce a delay between when you update LDAP
directory information and when the FortiVoice system begins using that new
information, but also has the benefit of reducing the amount of LDAP network
traffic associated with frequent queries for information that does not change
frequently.
If this option is enabled but queries are not being cached, inspect the value of
TTL. Entering a TTL value of 0 effectively disables caching.

TTL (minutes) Enter the amount of time, in minutes, that the FortiVoice system will cache
query results. After the TTL has elapsed, cached results expire, and any
subsequent request for that information causes the FortiVoice system to query
the LDAP server, refreshing the cache.
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GUI field Description

The default TTL value is 1440minutes (one day). The maximum value is
10080minutes (one week). Entering a value of 0 effectively disables caching.
This option is applicable only if Enable cache is enabled.

Enable user password change Enable if you want to allow FortiVoice web portal users to change their
password.

Password schema Select your LDAP server’s user schema style, eitherOpenLDAP or Active
Directory.

Testing LDAP profile queries

After you have created an LDAP profile, you should test each enabled query in the LDAP profile to verify that the
FortiVoice system can connect to the LDAP server, that the LDAP directory contains the required attributes and values,
and that the query configuration is correct.

When testing a query in an LDAP profile, you may encounter error messages that indicate failure of the query and how to
fix the problem.

To verify user authentication options

1. Go to Phone System > Profile > LDAP.
2. Double-click the LDAP profile whose query you want to test.
3. Click Test LDAP Query.

A pop-up window appears allowing you to test the query.
4. From Select query type, select Authentication.
5. In User name, enter the user name or extension of a user on the LDAP server, such as jdoe or 1234, depending

your selection of User Authentication Options.
6. In Password, enter the current password for that user.
7. Click Test.

The FortiVoice system performs the query, and displays either success or failure for each operation in the query,
such as the search to locate the user record, or binding to authenticate the user.

Clearing the LDAP profile cache

You can clear the FortiVoice system’s cache of query results for any LDAP profile.

This may be useful after, for example, you have updated parts of your LDAP directory that are used by that LDAP profile,
and you want the FortiVoice system to discard outdated cached query results and reflect changes to the LDAP directory.
After the cache is emptied, any subsequent request for information from that LDAP profile causes the FortiVoice system
to query the updated LDAP server, refreshing the cache.

To clear the LDAP query cache

1. Go to Phone System > Profile > LDAP.
2. Double-click the LDAP profile whose query cache you want to clear.
3. Click Test LDAP Query.
4. From Select query type, select Clear Cache.

A warning appears at the bottom of the window, notifying you that the cache for this LDAP profile will be cleared if
you proceed. All queries will therefore be new again, resulting in decreased performance until the query results are
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again cached.
5. ClickOk.

The FortiVoice system empties cached LDAP query responses associated with that LDAP profile.

Configuring RADIUS authentication profiles

The FortiVoice system supports RADIUS authentication method by using the RADIUS profiles that you configure.

To configure a RADIUS profile

1. Go to Phone System > Profile > RADIUS.
2. Click New.
3. Configure the following:

GUI field Description

Profile name Enter a name for this profile.

Server name/IP Enter the fully qualified domain name (FQDN) or IP address of a server that will
use RADIUS method to authenticate users.

Server port Enter the port number on which the authentication server listens. You must
change this value if the server is configured to listen on a different port number,
including if the server requires use of SSL.
The default port is 1812.

Protocol Select the authentication scheme for the RADIUS server.

Server secret Enter the secret required by the RADIUS server. It must be identical to the
secret that is configured on the RADIUS server.

Server requires domain Enable if the authentication server requires that users authenticate using their
full email address (such as user1@example.com) and not just the user name
(such as user1).

4. Click Create.

Configuring user privileges

A user privilege includes a collection of phone services and restrictions that can be applied to each extension user.

The default user privilege configurations can be edited but cannot be deleted.

For information on extensions, see Configuring extensions on page 162.

To configure a user privilege

1. Go to Phone System > Profile > User Privilege.
2. Click New.
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3. Configure the following:

GUI field Description

Name Enter a name for this profile.

Basic Setting

Auto provisioning Select to enable auto-provisioning for the extension. For more information, see
Configuring SIP phone auto-provisioning on page 93.
Once a FortiFone or supported DHCP-enabled phone connects to the
FortiVoice system and is auto-discovered, the FortiVoice system assigns an IP
address to the FortiFone and sends the basic PBX setup information to it. The
full PBX configuration file will only be sent to the phone if this option is selected
in the user privilege applied to the extension associated with the phone.

Configure programmable
phone feature key/PFK

Select to enable configuring the feature access codes. For more information,
see Modifying feature access codes on page 289.

Twinning Select to enable twinning function on an extension.
The twinning feature allows you to use an external telephone (often a
smartphone or home phone) to replicate your internal office extension (often
your desk phone), so that when your desk phone rings, so does the “twin”
phone. Once you return to your desk, you may press the Twinning key on the
phone to terminate the twinning.
This is useful when you are away from your desk but still want to receive calls
to your desk phone.
With this feature selected, you can configure twinning. For more information,
see Setting extension user preferences on page 181.

Softclient API login Select to enable FortiVoice softclient to log into the FortiVoice system.

Internet of Things Select to enable configuring your FortiVoice system’s integration with Amazon
Alexa. This is only available if you enable the system global control under
Phone System > Setting > Miscellaneous.
For more information, see Configuring Internet of Things (IoT) on page 294.

Operator Role Select to enable an extension user to process phone calls using the FortiVoice
user portal.
You can select the four options to handle calls in each category.
When the user privilege with this option selected is applied to an extension, an
Operator Console button will appear on the top of the extension user’s
FortiVoice user portal. Clicking the button lets the user to process phone calls
on the Web.

Voicemail Select to enable the voicemail service.

Maximummessages Enter the number of voice mails allowed.

Voicemail retention days Enter the number of days to keep the voicemails.

Music
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GUI field Description

Music on hold Select a music on hold file. For details, see Managing phone audio settings on
page 117.

Early media Early media is the exchange of information between the PBXes before the
establishment of a phone connection, such as the ring tone. You can select a
music file for early media. For details, see Managing phone audio settings on
page 117.

Fax Select to set the fax rules for users. For information on fax, see Configuring fax
on page 280.

Max incoming messages Enter the number of incoming faxes allowed.

Max incoming fax retention
days

Enter the number of days to keep the incoming faxes.

Max outgoing messages Enter the number of outgoing faxes allowed.

Max outgoing fax retention
days

Enter the number of days to keep the outgoing faxes.

Call Restriction Select call dialing restrictions for international, long distance, local, and internal
calls.
l Forbidden: Call is not allowed.
l Allowed: Call is allowed.
l Allowed with Account Code: Call is allowed by entering the system
account/exempt code. For information on account code, see Configuring
account codes on page 160.
Not applicable to internal calls.

l Allowed with Personal Code: Call is allowed by entering an extension’s
account/exempt code. For more information, see Configuring account
codes on page 160.
Not applicable to internal calls.

l Allowed with Account and Personal Code: Call is allowed by entering the
system and extension account/exempt codes.
Not applicable to internal calls.

Other Restricted Area
Code

You can specify area codes to which an extension is allowed or denied to make
phone calls.
1. Click New.
2. Enter a name for this call restriction.
3. Select Enabled to activate this restriction.
4. Enter the area code that you want to set a restriction.
5. Select the permission for the area code. For more information, see Call

Restriction on page 139.
6. Click Create.
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GUI field Description

Miscellaneous The max number of concurrent calls: Set the maximum number of concurrent
incoming and outgoing calls on the extension. The range is 1-10. The default is
4.

Monitor/Recording Configure monitoring and recording outgoing and incoming calls of an
extension to which this user privilege is applied.

Personal recording Select to allow users to configure personal recording of their incoming and
outgoing calls on the user web interface.

System recording Select to allow users to configure system recording of their incoming and
outgoing calls on the user web interface.

Allow being barged Select to allow monitoring an extension to which this user privilege is applied.

Allow barging Select to allow the extension to which this user privilege is applied to monitor
other extensions.
For details about how to barge a call, see Listen/Barge on a call on page 291.

Call barge option If you select Allow barging, choose a barging method.
For details about how to barge a call, see Listen/Barge on a call on page 291.

Hot-desking Hot desking enables users to log into another phone. However, unlike using
Follow Me or Call Forwarding which simply redirect a user's calls to another
user’s phone, hot desking takes total control of another phone by applying all of
the user's own phone settings to that phone until the user logs out. Each user
can log into another phone by pressing *11 and enter his extension number
and user PIN following the prompts. To log out, a user can press *12.
You can view hot desking configurations by going to Viewing activity details of
hot desking extensions on page 34.
l Enable hot-desking login: Select to enable the hot-desking login function.
l Automatic logout hours: Enter the time in hours for the phone to
automatically log out of hot-desking.

l Enable hosting hot-desking: Select if you want to log into a regular phone
with the hot-desking phone authentication (by pressing *11 and enter your
extension number and user PIN following the prompts).
By doing so, the regular phone keeps its configuration and extension
number. However, outgoing calls display the hot-desking number.
The regular phone logs out of hot-desking when the time set in Automatic
logout hours expires.

If the two phones use different programmable phone keys, the host phone will
reboot. For information on programmable phone keys, see Configuring phone
profiles on page 125.

User Portal Enable or disable the user portal and select the features for it. Only the
selected ones will appear for the extension to which this user privilege is
applied.
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GUI field Description

Directory Set phone directory options.

List in directory Select to put the user’s name in the dial-by-name directory which allows a
caller to find a user’s extension number, and connect to their local extension or
remote extension. This way the caller can reach their party without speaking to
the receptionist.

Lookup directory Select to enable a user to view the phone directory of the local office.

Lookup directory in remote
office(s)

Select to enable a user to view the phone directories of remote offices.

Directory/subdirectory Select the directory or subdirectory that you want to include in the user
privilege.

If you select a directory or subdirectory, you must also make
your selection in the Phone System > Setting >
Miscellaneous, Directory section. For details, see
Configuring system capacity on page 112.

Advanced Setting

Conference number Select the permission for conference calls:
l Allow All: Select to allow the extension to join all conference calls.
l Disallow All: Select to prohibit the extension from joining all conference
calls.

l Allow All with Exempt: If you select this option, click New to enter the
conference call number(s) that the extension is banned to join.

l Disallow All with Exempt: If you select this option, click New to enter the
conference call number(s) that the extension is allowed to join.

For more information, see Configuring auto attendants on page 262.

Paging/Intercom Select the permission for paging/intercom:
l Allow All: Select to allow the extension to page/intercom all paging
numbers.

l Disallow All: Select to prohibit the extension to page/intercom all paging
numbers.

l Allow All with Exempt: If you select this option, click New to enter the
paging/intercom number(s) that the extension is banned to page/intercom.

l Disallow All with Exempt: If you select this option, click New to enter the
paging/intercom number(s) that the extension is allowed to
page/intercom.

For more information on paging, see Configuring auto attendants on page 262.

Trusted hosts type Select the type of the subnet that can register with the SIP server. Only
extensions on the specified subnet can register with the SIP server.
If you select User defined, enter the information in Trusted hosts.
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GUI field Description

Trusted hosts Enter the IP address and netmask of the subnet that can register with the SIP
server.
You can add multiple trusted hosts.

Permitted outgoing rules Enable or disable all available outbound calling rules. For more information on
calling rules, see Configuring outbound dial plans on page 225.

4. Click Create.

Configuring emergency zone profiles

You configure an emergency zone profile to include the detailed contact information in case of emergencies.

To configure an emergency zone profile

1. Go to Phone System > Profile > Emergency Zone.
2. Click New and configure the following:

GUI field Description

Name For a new profile, enter its name.

Emergency caller ID Enter the caller ID to display on the destination phone when you dial the
emergency number, such as 911.
If an extension in this profile already has an emergency caller ID, this ID is
overridden by the extension’s own ID. See Emergency caller ID on page 182.

Description Enter any notes you have for this profile.

Emergency setting Configure to send an alert email when an emergency call is made.
Select Do nothing if you do not want the FortiVoice system to send an alert
email. Otherwise, select Send alert email and enter the following:
l Emergency contact emails: the email address for emergency contact. You
can click + and add more addresses.

l Emergency barge number: the extension number for authorized users to
dial into an ongoing emergency call to listen or provide information to the
call.

Contact Information Enter the emergency contact information for the profile.

3. Click Create.

Scheduling the FortiVoice system

You can schedule the FortiVoice operation time and use the schedules when configuring dial plans, virtual numbers, or
call management. The default schedules, namely after_hour, any_time, business_hour, and holiday, can be modified but
cannot be deleted.

Depending on your preference, you can create either a standard or a calendar-based schedule.

FortiVoice Phone System 6.0.12 Administration Guide 142
Fortinet Inc.



Configuring the phone system

For information on dial plan, see Configuring call routing on page 220.

For information on virtual numbers, see Working with virtual numbers on page 198.

For information on call management, see Setting extension user preferences on page 181.

To configure a standard schedule

1. Go to Phone System > Profile > Schedule and click New.
2. Enter a profile name and select Standard forMode.
3. Click Create.
4. In the schedule list, select the profile name you created and click Edit.
5. ForWeek Day, select the days to include in the schedule and set the AM and PM time or select Full Day.
6. For Holiday, click New to set the holidays. For example, select 01/01/21 in the Date field and enter New Year’s Day

in the Description field, and click Create.
7. ClickOK.

To configure a calendar-based schedule

1. Go to Phone System > Profile > Schedule and click New.
2. Enter a profile name and select Calendar forMode.
3. Click Create.
4. In the schedule list, select the profile name you created and click Edit.
5. Double-click a date to schedule an event.
6. ClickOK.

Configuring devices

Phone System > Device allows you to configure desk phones (including Cisco CP-7841 and CP-8841 phones with
version number 12.X) and multi-cell FortiFone phones in a central place for easy management.

This topic includes:

l Configuring desk phones on page 143
l Configuring multi-cell FortiFone phones on page 146

Configuring desk phones

You can configure desk phones to include their MAC addresses, phone model, phone profiles, names, and statuses.
You may also assign a phone to an extension, to FortiFone-870i, or to an extension as an auxiliary.

To view the list of desk phones, go to PhoneSystem > Device > Phone.

GUI field Description

Delete Select one or more FortiFone records and click this button to remove them all at
once.

Action l Assign to New Extension: Select a phone in Not Assignedmanagement
status and click this option to add an extension and assign this phone to the
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GUI field Description

extension at the same time. For more information, see To assign a new
extension user to an unassigned phone on page 145.

l Assign to Existing Extension: Select an unassigned phone and click this
option to assign this phone to an existing extension. The phone record
disappears from the Unassigned Phone list. For more information, see To
assign an existing extension user to an unassigned phone on page 145.

l Assign to Multi-cell Device: Select a multi-cell device (for example, FortiFone
870i)in Not Assignedmanagement status and click this option to add an
extension and assign this phone to the extension at the same time. For more
information, see To assign a new extension user to an unassigned phone on
page 145 and Configuring multi-cell FortiFone phones on page 146.

l Assign as Auxiliary to Existing Extension: Select a phone in Not Assigned
management status and click this option to assign it to an existing extension
as an auxiliary device. For more information, see To assign a new extension
user to an unassigned phone as an auxiliary device on page 145 and
Auxiliary Phone on page 167.

l View Phone Configuration: Select a phone in Assignedmanagement status
and click this option display its configuration file.

l View accounts: For FortiFone phones to which multiple extensions can be
associated, such as FON-850/860/870 and FON-D70/D71/D72, click this
option to view the associated extensions. This option is only active for
FortiFone phones with multiple extensions.

l Export: Select to save the phone list in csv format.

Extension When you see , it means that the phone is assigned to an extension.

MAC Address The Media Access Control address (MAC address) of the SIP phone.

Phone Model The phone brand and model.

Phone Profile The profile for this phone. See Configuring phone profiles on page 125.

Management Displays the assignment status of the phone (Assigned or Not Assigned).

Number The extension number of the phone.

Display Name The name displaying on the extension. This is usually the name of the extension
user.

Status Displays if the phone is registered with the FortiVoice system. A registered phone
is assigned an IP address and basic PBX setup information.

IP The IP address of the phone assigned by the FortiVoice system.

Phone Info The model, MAC address, and firmware version of the phone for this extension.

To add a FortiFone desk phone

FortiVoice Phone System 6.0.12 Administration Guide 144
Fortinet Inc.



Configuring the phone system

1. Go to Phone System > Device > Phone.
2. Click New and configure the following:

GUI field Description

MAC Address Enter the MAC address of the phone you want to add.

Phone model Select the phone brand and model.

Phone profile Select the profile for this phone. You may also create a profile or edit an
existing one. For more information, see Configuring phone profiles on page
125.

Status Displays if the phone is registered with the FortiVoice system. A registered
phone is assigned an IP address and basic PBX setup information.
This field is auto-populated based on the phone information you have entered.

Description Enter any notes about the phone.

3. Click Create.

To assign a new extension user to an unassigned phone

1. Go to Phone System > Device > Phone.
2. Select a phone in Not assignedmanagement status.
3. Click Action and select Assign to New Extension.
4. Enter the extension details and click Next. For details, see Configuring IP extensions on page 162.
5. Review the phone details and click Next.
6. Review the summary and click Finish.

To assign an existing extension user to an unassigned phone

1. Go to Phone System > Device > Desktop FortiFone.
2. Select a phone in Not assignedmanagement status.
3. Click Action and select Assign to Existing Extension.
4. Select the extension to associate with the unassigned phone and click Next.
5. Review the extension details and click Next. For details, see Configuring IP extensions on page 162.
6. Review the phone details and click Next.
7. Review the summary and click Finish.

To assign a new extension user to an unassigned phone as an auxiliary device

1. Go to Phone System > Device > Phone.
2. Select a phone in Not assignedmanagement status.
3. Click Action and select Assign as Auxiliary to Existing Extension.
4. Select the extension to associate with the unassigned phone and click Next.
5. Review the extension details and click Next. For details, see Configuring IP extensions on page 162.
6. Review the phone details and click Next.
7. Review the summary and click Finish.
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Configuring multi-cell FortiFone phones

The FortiVoice system supports 2 types of multi-cell FortiFone phones: FortiFone-870i and FortiFone-D72.

Each base FortiFone-870i can support up to 15 handsets. You can configure a FortiFone-870i to work with the
FortiVoice system by adding a primary phone (base) and multiple secondary phones (bases).

Each base FortiFone-D72 can support up to 8 handsets. You can configure a FortiFone-D72 to work with the FortiVoice
system by adding a FON-D72-M manager, at least one FON-D72-B base, and one FON-D71-H handset.

The following prerequisites must be met for the FortiFone-870i and FortiFone-D72 configuration to work:

Multi-cell phone Prerequisites

FortiFone-870i l FortiVoice v6.0 build 127 or later
l FortiVoice auto provisioning is enabled (see Configuring SIP phone auto-
provisioning on page 93)

l FortiFone-870i firmware 3.23 or later
l Network connectivity available between FortiFone-870i and the FortiVoice
system

FortiFone-D72 l FortiVoice v6.0.7 build 253 or later
l FortiVoice auto provisioning is enabled (see Configuring SIP phone auto-
provisioning on page 93)

l Network connectivity available between FortiFone-D72 and the FortiVoice
system

Follow the FortiFone-870i and FortiFone-D72 guides to configure the phones first. After you connect the phone to the
network, you can configure it on the FortiVoice system.

Configuring the FortiFone-870i

Configure the FortiFone-870i on multiple GUI pages.

1. Go to Phone System > Device > Multi-cell Device and click New.
2. Enter the MAC address of the intended primary station.
3. Select Enable.
4. In Device role, set the station as primary with chain ID. The chain ID should be numbers up to 5 digits. Enter any

description as needed and click Create.
You can now add extensions to the primary station. You only need to apply the extension configuration to the
primary. All secondary stations can obtain the extension information from the primary.

5. Go to Phone System > Device > Phone.
6. Select the primary station just created, click Action, and select Assign to New Extension or Assign to Existing

Extension.
7. For Assign to New Extension, see To assign a new extension user to an unassigned phone on page 145.
8. For Assign to Existing Extension, see To assign an existing extension user to an unassigned phone on page 145.
9. Add more extensions as needed with a different handset IDs. Upon completion, you should see all the extensions

listed for the primary station.
10. Since the primary station is provisioned, proceed to provision the secondary stations. Factory reset the intended

secondary station and connect it to the network. If the network and the FortiVoice system are configured properly, it
should appear under Phone System > Device > Phone.
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11. Select the unassigned FortiFone-870i station, click Action > Assign to Multi-cell Device.
12. In Device role, set the base station as secondary and select Prime (primary station) from the drop down list. Type

any description as needed.
13. ClickOK.
14. On the secondary phone configuration, remove the temporary extension settings and reboot the station. See the

phone guide for more information.
Note that the temporary extension is used for initial configuration of the base and has to be removed for the phone to
work with the FortiVoice system.

Configuring the FortiFone-D72

You can configure a FortiFone-D72 to work with the FortiVoice system by adding a FON-D72-M (manager), at least one
FON-D72-B (base), and one FON-D71-H (handset). This solution includes the following four steps.

For more information about the FortiFone-D72, see FON-D72 User Guide.

To configure the FON-D72-M

1. Connect the FON-D72-M to the network using a POE connection.
2. Log in to the FortiVoice GUI.
3. Go to Phone System > Device > Phone.

The FON-D72 is auto discovered and displays as a device with the Not Assignedmanagement status.
4. Right-click the FortiFone-D72 and select Assign to Multi-cell Device.
5. Configure the following:

GUI field Description

Enable Select to activate the phone.

Device role Select DECTManager for FON-D72-M.

IP address Enter the IP address of the FON-D72-M if it is not automatically filled out.

Default manager Enable to make the FON-D72-M as the default manager of the FortiFone-D72
configuration.

Description Enter any notes about the phone.

6. ClickOK.

In the Phone Model column, a green icon appears beside FortiFone-D72 indicating that it is the DECT
Manager.

To configure the FON-D72-B

1. Connect the FON-D72-B to the network using a POE connection.
2. Log in to the FortiVoice GUI.
3. Go to Phone System > Device > Phone.

A new FON-D72 is auto discovered, displays as a device with the Not Assigned status, and has a different MAC
address than the DECTManager.

4. Right-click the FortiFone-D72 and select Assign to Multi-cell Device.
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5. Configure the following:

GUI field Description

Enable Select to activate the phone.

Device role Select Base for FON-D72-B.

Sync cluster Select the ID for a phone group.
A sync cluster is comprised of a number of base stations within the DECT
multi-cell system that synchronize with each other to enable handover,
roaming, list access, and load balancing.
Only phones in the same cluster can talk with each other.
For detailed information, see FON-D72 User Guide.

Sync level Select the sync level for a phone group.
Each base station is assigned to a corresponding sync level. Sync level is
based on the distance between bases. Only one base can be sync level 1, then
every other base would be 2-10, based on where they are located.
For detailed information, see FON-D72 User Guide.

Primary Select the MAC address of the default DECT Manager if it is not automatically
populated.

Default manager Enable to make the FON-D72-M as the default manager of the FortiFone-D72
configuration.

Description Enter any notes about the phone.

6. ClickOK.

In the Phone Model column, a gray icon appears beside FortiFone-D72 indicating that it is the base.

To configure the FON-D71-H handset as an extension

1. Log in to the FortiVoice GUI.
2. Right-click the FortiFone-D72 that is the DECT Manager and select Assign to New Extension.
3. Configure the following:

GUI field Description

Number Enter the extension number of the FON-D71-H.
For information on extension configuration, see Configuring IP extensions on
page 162.

Enable Select to activate the extension.

Display name Enter the name displaying on the extension. This is usually the name of the
extension user.
You can click Expand to modify caller ID to add a caller ID for external calls or
emergency calls.
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GUI field Description

Description Enter any notes about the phone.

User Setting Do not do anything.

4. Click Next.
5. Verify the information and click Next.
6. Review the summary.
7. Click Finish.

To activate the FON-D72-M and register handsets

1. Enter the IP address of the FON-D72-M in a web browser.
2. Log in using "admin" as the username and "23646" as the password.
3. Go to Handset & Account > Registration Center.
4. Click Start Now.
5. Power on the FON-D71-H handset and press the Reg button.

The handset will search and find the FON-D72-M, register, and display the created extension number and name.

Reviewing system configuration

Phone System > Review provides a snapshot of the FortiVoice system configuration. You may also modify some items.

The following table lists the items that you can review or modify:

GUI tab Description

Number You can double-click an extension to modify it. For modification information, see Configuring
IP extensions on page 162.

MWI Auditor Message waiting indicator (MWI) check for new voicemails.
You can double-click a record to view the voicemail source, including the user ID, extension
number, and extension type.

Network Summary Shows the IP address of each subnet and the number of devices connected to it.

DID Handling Direct inward dialing (DID) handling information.
For detailed information, see Configuring direct inward dialing on page 222.

Call Queue This section is available for FortiVoice systems with the Call Center license. For modification
information, see Creating call queues on page 230.

Agent This section is available for FortiVoice systems with the Call Center license. For modification
information, see Configuring agents on page 238.

Referenced
Extension

Extensions that are used by other objects and their roles in the objects.
You can double-click a referenced object to view the object details and the extension role in
the object.
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GUI tab Description

In the following example, extension 87071 is used inOttawa_Helpdesk (Virtual Number) as a
call handling destination.
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Amanaged gateway is one of the FortiVoice Gateways that either contains FXS, FXO, or PRI ports that handles calls for
the FortiVoice phone system. Gateway Management enables auto-discovery of other FortiVoice gateways on the
network and offers remote device management from a centralized FortiVoice phone system. Gateways will still need to
be configured for network settings and administrator passwords, but all other configurations will be received from the
FortiVoice system.

For information on gateway auto-discovery, see Viewing unmanaged gateways on page 35.

FVE-100E and larger systems can manage gateways.

FVE models and supported number of gateways

Model Number of gateways supported

FVE-100E and FVE-VM-100 5

FVE-200F and FVE-VM-200 5

FVE-300E 10

FVE-500E, FVE-500F, and FVE-500 15

FVE-1000E and FVE-VM-1000 25

FVE-2000E, FVE-2000F and FVE- VM-2000 50

FVE-3000E and FVE-VM-3000 50

FVE-5000F and FVE-VM-5000 100

FVE-VM-10000 100

FVE-VM-20000 100

FVE-VM-50000 200

The FortiVoice Local Survivable solution is designed to provide branch resiliency for centralized deployments with multi-
sites. It is delivered and supported by a selected line of enterprise-class appliances through a firmware upgrade and
enables system administrators to seamlessly connect multiple locations with an easy-to-deploy solution.

Firmware of the FortiVoice systems and FortiFone phones can be managed in a single place.

This topic includes:

l Managing FXO gateways on page 152
l Managing FXS gateways on page 152
l Managing PRI gateways on page 153
l Configuring local survivability on page 154
l Managing firmware on page 155
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Managing FXO gateways

FXOGateways connect your IP phone system to an outside telephone line. It allows you to connect the FXS port to the
FXO port of the gateway, which then translates the analog phone line to a VoIP call.

The FortiVoice FVG-GO08 gateways can be auto discovered by the FortiVoice system once they connect to it. You can
also manually add gateways to be managed by the FortiVoice system.

For detailed instructions about deploying a FXO gateway, see the FortiVoice FXO Gateway Deployment Guide.

To view the list of added GO08 gateways, go toManaged System > Gateway > FXO Gateway.

GUI field Description

Apply configuration
Prior to applying the configuration file, make sure that the
FortiVoice phone system and FortiVoice gateway are running
the 6.0.x firmware version.
Supported setup examples for Apply configuration: 
l FortiVoice 6.0.12 with FortiVoice gateway 6.0.11 or 6.0.12
l FortiVoice 6.0.11 with FortiVoice gateway 6.0.12

Unsupported setup example for Apply configuration:
l FortiVoice 6.4.7 with FortiVoice gateway 6.0.11 or 6.0.12

To verify the firmware version, go to Dashboard > Status. In the
System Information widget, go to Firmware version.

Select a gateway from the list and click this option to apply the FortiVoice FXO
gateway configuration file to this gateway and reboot the gateway immediately.

View configuration Select a gateway from the list and click this option to display the configuration file
applied to this gateway.

Unmanaged Gateway Click to display the gateways auto discovered by the FortiVoice system. For more
information, see Viewing unmanaged gateways on page 35.

Fetch Device Info Select a branch FortiVoice system from the list and click this option to retrieve its
information.

Upgrade Select a gateway and select this option to upgrade it now or later.

Managing FXS gateways

FXS gateways connect traditional PBX phone lines to a VoIP phone system or provider. To connect the FXO ports to the
Internet or a VoIP system, you need an FXS gateway in between.

The FortiVoice FVG-GS16 gateways can be auto discovered by the FortiVoice system once they connect to it. You can
also manually add gateways to be managed by the FortiVoice system.

For detailed instructions about deploying a FXS gateway, see the FortiVoice FXS Gateway Deployment Guide.

To view the list of added GS16 gateways, go toManaged System > Gateway > FXS Gateway.
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GUI field Description

Apply configuration
Prior to applying the configuration file, make sure that the
FortiVoice phone system and FortiVoice gateway are running
the 6.0.x firmware version.
Supported setup examples for Apply configuration: 
l FortiVoice 6.0.12 with FortiVoice gateway 6.0.11 or 6.0.12
l FortiVoice 6.0.11 with FortiVoice gateway 6.0.12

Unsupported setup example for Apply configuration:
l FortiVoice 6.4.7 with FortiVoice gateway 6.0.11 or 6.0.12

To verify the firmware version, go to Dashboard > Status. In the
System Information widget, go to Firmware version.

Select a gateway from the list and click this option to apply the FortiVoice FXS
gateway configuration file to this gateway and reboot the gateway immediately.

View configuration Select a gateway from the list and click this option to display the configuration file
applied to this gateway.

Unmanaged Gateway Click to display the gateways auto discovered by the FortiVoice system. For more
information, see Viewing unmanaged gateways on page 35.

Fetch Device Info Select a branch FortiVoice system from the list and click this option to retrieve its
information.

Upgrade Select a gateway and select this option to upgrade it now or later.

Managing PRI gateways

VoIP PRI gateways seamlessly connect your legacy telephony infrastructure, made up of PRI (T1, E1) or BRI lines, to IP
networks. Businesses with legacy phone equipment (such as a TDM PBX) can use PRI gateways to connect to SIP
trunking services without having to spend money altering their current network infrastructure.

The FortiVoice FVG-GT01 and GT02 gateways can be auto discovered by the FortiVoice system once they connect to it.
You can also manually add gateways to be managed by the FortiVoice system.

For detailed instructions about deploying a PRI gateway, see the FortiVoice PRI Gateway Deployment Guide.

To view the list of added GT01/02 gateways, go toManaged System > Gateway > PRI Gateway.

GUI field Description

Apply configuration
Prior to applying the configuration file, make sure that the
FortiVoice phone system and FortiVoice gateway are running
the 6.0.x firmware version.
Supported setup examples for Apply configuration: 
l FortiVoice 6.0.12 with FortiVoice gateway 6.0.11 or 6.0.12
l FortiVoice 6.0.11 with FortiVoice gateway 6.0.12

Unsupported setup example for Apply configuration:
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GUI field Description

l FortiVoice 6.4.7 with FortiVoice gateway 6.0.11 or 6.0.12
To verify the firmware version, go to Dashboard > Status. In the
System Information widget, go to Firmware version.

Select a gateway from the list and click this option to apply the FortiVoice FXS
gateway configuration file to this gateway and reboot the gateway immediately.

View configuration Select a gateway from the list and click this option to display the configuration file
applied to this gateway.

Unmanaged Gateway Click to display the gateways auto discovered by the FortiVoice system. For more
information, see Viewing unmanaged gateways on page 35.

Fetch Device Info Select a branch FortiVoice system from the list and click this option to retrieve its
information.

Upgrade Select a gateway and select this option to upgrade it now or later.

Configuring local survivability

FortiVoice local survivability solution is designed to provide branch resiliency for centralized deployments with multi-
sites. The FortiVoice system at the central office sends the configuration files to the FortiVoice systems and extensions
at the branch offices. The central office handles all inbound calls thereby consolidating the number of lines required for
an organization.

With this solution, you have one place to look for the routing rules, logs, call records, and call recordings. You can see
the whole setup, make changes, or modify records on the fly. If an extension is added, it is operational immediately. Any
users at any location will be able to call that new extension right away without waiting for configurations to sync up, or
new policies required to be set at each location.

If the communication between the FortiVoice system at the central office and the FortiVoice systems and extensions at
the branch offices is down, the FortiVoice systems at the branch offices (survivability branches) will kick in to provide
access to lines until the communication is restored between the central system and the extensions.

A survivability branch is a local FortiVoice system containing local extensions that is part of a centralized deployment.

For detailed instructions about deploying a survivability branch, see the FortiVoice Local Survivable Gateway
Deployment Guide.

The following FortiVoice phone systemmodels can manage one or more survivability branches :

l FVE-300E-T and larger
l FVE-VM-500 and larger

The supported FortiVoice survivability branch models are:

l FVE-20E2
l FVE-20E4
l FVE-50E6
l FVE-100E
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l FVE-200F8
l FVE-500F

FVE models and supported number of survivability branches

Model Number of survivability branches
supported

FVE-300E 10

FVE-500E, FVE-500F, and FVE-VM-500 15

FVE-1000E and FVE-VM-1000 20

FVE-2000E, FVE-2000F, and FVE-VM-2000 40

FVE-3000E and FVE-VM-3000 40

FVE-5000F and FVE-VM-5000 100

FVE-VM-10000 100

FVE-VM-20000 100

FVE-VM-50000 200

To view the list of added survivability branches, go toManaged System > Survivability > Survivability Branch.

GUI field Description

Apply configuration Select a branch FortiVoice system from the list and click this option to apply the
FortiVoice configuration file to this branch system and reboot the system
immediately.

View configuration Select a branch FortiVoice system from the list and click this option to display the
configuration file applied to this system.

Fetch Device Info Select a branch FortiVoice system from the list and click this option to retrieve its
information.

Upgrade Select a branch FortiVoice system and select this option to upgrade it now or later.

Managing firmware

Managed System > Firmware allows you to manage firmwares of the FortiVoice systems and FortiFone phones.

FortiVoice systems refer to the FortiVoice devices managed by this FortiVoice system, such as gateways.

FortiFone phones are those connected to this FortiVoice system.

To manage FortiFone firmware
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1. Go toManaged System > Firmware > FortiFone Firmware.

GUI field Description

Upload Click to upload a firmware file.
You can select a phone model or FortiFone desktop app, select the firmware file, and enter
the firmware version number to upload the firmware.
Note that if you selected FortiFone-DesktopApp, the Firmware version option is only
available when editing an existing the firmware file.
For FortiFone-380, 480, and 580, there is a Forced option. If necessary, enable this option
to force a new build onto the phone regardless of the firmware version already on the
phone.

Download Select a firmware file and click this button to download it.

Action Select a firmware file and click this button to enable or disable a firmware upgrade for the
FortiFone phones managed by this FortiVoice system.

Statistics Click to display the information of the managed FortiFone phones.

Upgrade Select a firmware and click Upgrade to upgrade the FortiFone firmware:
l Name: Enter a name for the firmware upgrade job.
l Extension Selection: Select All related devices if you want to upgrade all of the
devices to which the firmware applies to. Otherwise add individual devices that you
want to upgrade.

l Schedule: Schedule the upgrade. The firmware will be pushed to the managed
FortiFone phones at the scheduled time.

View upgrade job Click to display the FortiFone upgrade records. See Maintaining phones on page 104.

To manage FortiVoice firmware

1. Go toManaged System > Firmware > FortiVoice Firmware.

GUI field Description

Upload Click to upload a firmware file.

Upgrade Select a firmware file to do the FortiVoice firmware upgrade now or at a scheduled time.
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You can enhance the FortiVoice system security by configuring intrusion detection, password policies, passwords
auditing, user privileges, and extension blocking.

Clicking the security alert icon ( ) at the top right corner of the screen displays the system security status. If there are
any security issues, the icon will have a red exclamation mark. For details about the system security status, see
Checking the system security on page 23.

This topic includes:

l Configuring intrusion detection on page 157
l Setting password policies on page 158
l Auditing the extension passwords on page 159
l Configuring user privileges on page 160
l Configuring account codes on page 160
l Blocking phone numbers on page 161

Configuring intrusion detection

Security > Intrusion Detection lets you manually add IP addresses to be exempted from being blocked, remove system
added exempt IP addresses if you find them suspicious, and configure intrusion detection settings.

The manually added IP addresses are usually from the sources that you trust. For example, IP addresses from external
customer devices can be added.

The IP addresses of the devices that are registered to the FortiVoice system are automatically added to the exempt list.

To add an exempt IP address

1. Go to Security > Intrusion Detection > Exempt IP.
2. Click New.
3. Enter the IP address.
4. Click Create.

To remove an auto exempt IP

1. Go to Security > Intrusion Detection > Auto Exempt IP.
2. Select an IP address you want to remove and click Delete.

To configure intrusion detection settings

1. Go to Security > Intrusion Detection > Setting.
2. Configure the following:

GUI field Description

Status l Disable: Select to stop the intrusion detection activities.
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GUI field Description
l Monitor Only: Select to only track the intrusion detection activities.
l Enable: Select to activate the intrusion detection activities.

Access tracking Select the method to track the traffic access (and IPs) to the FortiVoice system.

Initial block period Enter the time in minutes to initially block every new device/IP address trying to access the
FortiVoice system. This is to screen out spammers or attackers because they normally will
not try again after being blocked initially.

3. Click Apply.

Setting password policies

Security > Password Policy lets you set the SIP password and user PIN policy for administrators and extension users.
For information on setting SIP password and user PIN, see Configuring IP extensions on page 162.

You can also edit extension user passwords.

To set password policies

1. Go to Security > Password Policy > Password/PIN Policy.
2. Configure the following:

GUI field Description

Password / PIN Policy l Minimum password length: Set the minimum acceptable length (8) for
passwords.

l Password must contain: Select any of the following special character
types to require in a password. Each selected type must occur at least
once in the password.
l Upper-case-letter—A, B, C, ... Z
l Lower-case-letter—a, b, c, ... z
l Number—0 ... 9
l Non-alphanumeric —punctuation marks, @,#, ... %

l Apply password policy to: Select where to apply the password policy:
l Admin user—Apply to administrator web GUI passwords. If any
password does not conform to the policy, require the administrator to
change the password at the next login.

l SIP users—Apply to FortiVoice SIP phone users’ passwords. If any
password does not conform to the policy, require that user to change
the password at the next login.

l User passwords: Apply to user portal and FortiFone softclient users'
access passwords. If any password does not conform to the policy,
require that user to change the password at the next login.

l Minimum PIN length: Set the minimum acceptable length (6) for the user
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GUI field Description

PIN.
l PIN must contain:

l Number: Enable to allow the use of number digits (0-9) in the PIN.
l PIN special: Enable to allow the use of the * and # special characters
in the PIN.

l Apply PIN policy to: Select Voicemail users to apply the policy to
FortiVoice phone users’ user PIN. If any PIN does not conform to the
policy, require that user to change the PIN at the next login.

l PIN expiration: Select the voicemail PIN expiration options.
l Never: Users set their voicemail PIN and the PIN never expires.
l Default Only: Extension users using the default voicemail PIN is
prompted to change the PIN when accessing their voicemail for the
first time. For information on voicemail PIN, see Configuring IP
extensions on page 162.

l All: Extension users are prompted to change the voicemail PIN when
accessing their voicemail for the first time and regularly according to
the PIN expiration time.

l PIN expiration time: If you selected All for PIN expiration, select the PIN
expiry time in days.

Allow empty admin password Select to allow leaving the admin password field empty when logging in to the
system.
This option appears if you disable Password/PIN Policy.

3. Click Apply.

To edit extension user passwords

1. Go to Security > Password Policy > Password Auditor.
2. Double-click an extension of which you want to edit the user passwords.
3. Under User Setting, go to theWeb Access and Phone Access tabs.
4. Change the passwords, as required. For more information, see Configuring IP extensions on page 162.
5. ClickOK.

Auditing the extension passwords

You can verify the strength of IP and fax extension passwords. For information about setting IP extension and fax
extension passwords, user passwords, and voicemail PINs, seeConfiguring IP extensions on page 162 and Configuring
fax extensions on page 179.

To audit extension passwords
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1. Go to Security > Password Policy > Password Auditor.
2. Configure the following:

Button Description

Edit Select an extension and click Edit to modify the extension configuration. For
details, see Configuring IP extensions on page 162.

Audit Now Click to check the strength of the extension passwords. The time is displayed
when the last audit was done.
Shield symbol colors and password status:
l - Very strong

l - Weak
l - Very weak

l - Mediocre
If the password strength of an extension does not show a green shield icon,
double-click the extension to view and modify the password based on the
policy until the password strength shows a green shield icon. For details, see
Configuring IP extensions on page 162.

Download To save a copy of the password audit result, click and select All.

Configuring user privileges

A user privilege includes a collection of phone services and restrictions that can be applied to each extension user.

For more information, see Configuring user privileges on page 137.

Configuring account codes

You can set account codes to restrict long-distance and international calls, for instance. Users must dial these codes first
before making long-distance or international calls.

You apply the account codes in user privileges. For details, see Configuring user privileges on page 137.

To set an account code

1. Go to Security > User Privilege > Account Code.
2. Click New and configure the following:

GUI field Description

Name Enter an account code name.

Description Enter any notes you may have for the account code.
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GUI field Description

Shared Select to use this code on any extension.

Represented in CDR Select to display the account code by code or name in CDR. For information
about CDR, see Viewing call records on page 36.

Access Code Set To add an account code:
1. Click New.
2. Enter the account code with a minimum of 3 digits and a maximum of 10

digits.
3. Enter a display name for the code such as Finance.
4. Add any notes for the code.
5. Click Create.

3. Click Create.

Blocking phone numbers

For security reasons, you can block an inbound call by entering its number. This will block future calls from this number.

To block a number

1. Go to Security > Blocked Number.
2. Click New.
3. Enter the number you want to block.
4. Click Create.
5. Click Setting.
6. In PBX Setting, enable System block list.
7. Click Apply.

Future calls from the number will be blocked. For more information, see Configuring phone system settings on page
107.

To unblock a number

1. Go to Security > Blocked Number.
2. Select a blocked number in the list.
3. Click Delete.
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The Extensionmenu lets you configure local and remote extensions, extension groups, general voicemail, and virtual
numbers.

This topic includes:

l Setting up local extensions on page 162
l Creating extension groups on page 188
l Setting up a general voicemail on page 196
l Working with virtual numbers on page 198

Setting up local extensions

You can configure IP phone extensions, edit analog extension, and choose extension preferences.

This topic includes:

l Configuring IP extensions on page 162
l Auditing SIP extension password on page 170
l Auditing extension numbers and MAC addresses on page 170
l Importing a list of extensions on page 171
l Configuring SIP forking on page 171

l Modifying managed extensions on page 172
l Modifying analog extensions (FVE-20E2 and FVE-50E6 models only) on page 173
l Setting up remote extensions on page 176
l Configuring fax extensions on page 179
l Setting extension user preferences on page 181
l Configuring fax extensions on page 179
l Setting extension user preferences on page 181

Configuring IP extensions

An IP extension is an IP phone connected through a network to a system. An internal IP extension is a phone connected
on the same LAN as the system. An external IP extension is a phone connected outside the LAN.

To view the local IP extensions, go to Extension > Extension > IP Extension.

GUI field Description

Actions l Export: Select to save a copy of the extension list or download as a sample
list with or without user ID in CSV format.

l Import: Select to upload a copy of the extension list in CSV format. For
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GUI field Description

details, see Importing a list of extensions on page 171.
l View Phone Configuration: Select a FortiFone extension and click this option
to view the phone’s configuration file.
When a phone is associated with an extension, the FortiVoice system
generates a configuration file for the phone. For details, see To create or edit
an IP extension on page 164.

l Apply Configuration (Main Phone): If you have edited an extension
configuration and want to apply it to the phone associated with this extension,
select the extension and click this option.
The selected phones will reboot and only the phones that meet the following
conditions will receive the new configuration:
l Phones supported by and registered to the FortiVoice system. For the
list of supported phones and auto provisioning prerequisites, see
Configuring SIP phone auto-provisioning on page 93.

l Phone type and MAC address is correctly configured. See To create or
edit an IP extension on page 164.

l Auto-provisioning is enabled for the extension associated with the
phone through the user privilege applied to it. See Configuring user
privileges on page 137.

l Password Auditor: See Auditing SIP extension password on page 170.
l Number Auditor: Auditing extension numbers and MAC addresses on page
170

l Send Softclient QR Code by Email: If you have added a FortiFone softclient
to an extension and entered your email address as a notification option,
select this option to send a QR code to the email address. The QR code will
also appear on the Preferences page of the extension’s user portal.
See Auxiliary Phone on page 167 and Notification Options on page 183.

l Maintenance: Select an extension and click this button to manage a user’s
voicemail box and faxes. You can check the size of the mailbox or fax folder
and empty them if required.
Click Back to return to the IP Extension tab.

Configure View (icon) Click to display or hide columns you want. You can also save the customized view
or set it back to default.

Enabled Select to activate an extension.

Number The extension number.

Display Name The caller ID used for internal calls. This is usually the name of the extension user.

Phone Model The brand and model of the phone.

Emergency Zone The emergency zone profile for this extension. For more information, see
Configuring emergency zone profiles on page 142.
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GUI field Description

Survival Branch If the extension belongs to a FortiVoice survivability branch, the branch
information is listed. For information on survivability branch, see Configuring local
survivability on page 154.

Department If the extension belongs to an extension department, the department information
is listed. For information on departments, see Creating extension departments on
page 189.

Business Group If the extension belongs to a business group, the group information is listed. For
information on business groups, see Creating business groups on page 195.

Status The extension statuses, including:
l Idle: The extension is not in use.
l In Use: The extension is in use.
l Busy: The extension is busy.
l Ringing: The extension is ringing.
l On Hold: The extension has an on-hold call.
l Admin down: The trunk of the extension is disabled.

Under this status, the extension remains registered with the FortiVoice
system.

l Not registered: The extension is not registered with the FortiVoice system
and is not in service.

l Unavailable: The extension is not reachable.
l Alarm detected: There is a problem with the phone line.
l Other: The status other than the above.

IP The link to the IP address of the phone using the extension number.

Phone Profile Displays the phone profile applied to the extension. For information on phone
profile, see Configuring phone profiles on page 125.

Phone Info The model, MAC address, and firmware version of the phone for this extension.

To create or edit an IP extension

1. Go to Extension > Extension > IP Extension.
2. Click New or double-click an existing extension.
3. Configure the following:

GUI field Description

Number Enter the extension number following the extension number pattern. See
Configuring PBX options on page 108.
If you are editing the extension, you can click Edit Preference to configure the
extension user preferences. See Setting extension user preferences on page 181.

User ID This option is view only and the ID only appears when you edit an extension.
This is the system-generated ID based on the user ID prefix you set (see User ID
prefix on page 111) and the extension number.

Enable Select to activate the extension.
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GUI field Description

Display name
Do not include quotation marks in an extension display names.
The recommended character length is 20 characters or less. If
you enter more than 20 characters, the name may not show
properly on some phone models.

The caller ID used for internal calls.
Enter the name that the phone can display when it receives a call from this
extension. This is usually the name of the extension user.
You can click + Expand to modify caller ID to add caller IDs for external calls and
emergency calls.

Description Enter any notes for the extension.

Device Setting Extension SIP devices include desk phones, soft phones, and auxiliary devices.

Phone

Type Select the desk phone type.

Device Select the specific phone model.
Click the New icon to add a new device. See Configuring desk phones on page 143.
Click the Edit icon to modify a selected device. See Configuring desk phones on
page 143.
Click the Select icon to choose an existing device.
This option is only available if you select FortiFone type.

SIP settings Select the SIP profile for the phone.
Click the New icon to add a new profile. See Configuring SIP profiles on page 122.
Click the Edit icon to modify a selected profile. See Configuring desk phones on
page 143.

Emergency
zone

Select the emergency zone profile for the phone.
Click the New icon to add a new profile. See Configuring emergency zone profiles
on page 142.
Click the Edit icon to modify a selected profile. See Configuring emergency zone
profiles on page 142.

Advanced Click to configure the following settings and clickOK when finished.
l SIP password: FortiVoice uses this password to register your SIP phone. When
you are registering a third-party phone, enter this password where it is needed.
You can check the password strength. For details, see Auditing the extension
passwords on page 159.
ClickGenerate to generate a strong password automatically. Select View
password to display the password.
If you have configured the default SIP user password (see Default SIP user
password on page 110), the password appears here. However, you can
change it.

l Location: Select Internal if the phone does not traverse through Network
Address Translation (NAT) to connect to the FortiVoice system, and External if
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GUI field Description

the phone does. These are system defined locations.
l User programmable keys: By clicking Edit, you can configure the phone
programmable keys for the extension user if the programmable keys profile
used for this extension gives users the permission to do so.

l MWI (MessageWaiting Indication): Enable or disable MWI on the phone.
l Auto answer: Enable or disable automatic answering on the phone.
l Direct call: Enable or disable direct calling on the phone.

Number: Enter the phone number. This is the phone number that the
FortiVoice system automatically dials after the phone user lifts up the
phone handset (or presses the headset or speaker button) to place a call.

After: If you want to delay the automatic dialing, enter a value in seconds. If
the delay is set to 0, the extension is turned into a hotline meaning that the
FortiVoice system immediately dials the configured Direct call number
after the extension is off-hook.

l Secondary accounts: If you enabled the option to add a secondary account for
desk FortiFone phones, do it here by selecting the FortiFone extension as the
secondary account. For more information, see Secondary account (Enable
secondary account for Desktop FortiFone) on page 95.

Soft FortiFone

License
allocation

Select the number of FortiFone softclient licenses for use on this extension.
If you select 0, no configuration is needed.

Mobile To update this setting, you need to edit an extension.
Click View Login Information to view the configuration file of the mobile softclient.
Use the user name and password from the configuration file to log in onto the mobile
softclient, or click and scan the QR code from the mobile softclient.

Desktop To update this setting, you need to edit an extension.
Click View Login Information to view the configuration file of the desktop softclient.
Use the user name and password from the configuration file to log in onto the
desktop softclient.

SIP Setting l Android/iOS: If the soft phone is on an Android phone or iPhone, select a SIP
profile for it. Click Edit to modify the current profile or New to configure a new
one. For more information, see Configuring SIP profiles on page 122.

l Windows/macOS: If the soft phone is on aWindows or Mac device, select a SIP
profile for it. Click Edit to modify the current profile or New to configure a new
one. For more information, see Configuring SIP profiles on page 122.

Revoking a
license

When licenses are allocated to an extension and the devices associated with the
extension use the licenses, the devices appear.
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GUI field Description

If you want to free up a license, you can revoke the license of a device that you no
longer need and use it for another device in need.

To do so, click the Revoke License ( ) icon and confirm the action.

Auxiliary Phone Click New to add SIP phones to the extension. This is known as SIP forking.
For more information, see Configuring SIP forking on page 171.
SIP forking allows you to have your desk phone ring at the same time as your soft
phone or a SIP phone on your mobile. For example, you can use SIP forking to ring
your desk phone and your Android SIP phone at the same time, allowing you to take
the call from either device easily. No forwarding rules would be necessary as both
devices would ring. In the same manner, SIP forking can be used in an office and
allow the secretary to answer calls to the extension of his/her supervisor when the
supervisor is away or unable to take the call.
Select a device and click Actions to apply extension configuration to the device or
view the extension or SIP configuration file.
The selected devices will reboot and only the devices that meet the following
conditions will receive the new configuration:
l Devices supported by and registered to the FortiVoice system. For the list of
supported phones and auto provisioning prerequisites, see Configuring SIP
phone auto-provisioning on page 93.

l Device type and MAC address is correctly configured. See To create or edit an
IP extension on page 164.

l Auto-provisioning is enabled for the extension associated with the device
through the user privilege applied to it. See Configuring user privileges on page
137.

User Setting

Management Configure the extension’s role in other settings.

User privilege Select the services for the extension. Click Edit to modify the current user privilege
or click New to configure a new one. For more information on user privilege, see
Configuring user privileges on page 137.

Department Select the department that the extension belongs to. Click Edit to modify the current
department or click New to configure a new one. For more information on extension
department, see Configuring agents on page 238.

Survival branch Select the local survival branch FortiVoice system for the extension if the extension
is in a local survivability network.
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Click Edit to modify the current branch system.
For more information, see Configuring local survivability on page 154.

Voicemail Configure the extension’s voice mailbox.
In some cases, you may want other users or groups to share this voice mailbox. For
example, a supervisor wants his/her co-workers to access his/her voice mailbox
while he/she is away.
Main voice mailbox: Select the extension’s own voice mailbox (Default) or that of
another extension as the voice mailbox of this extension.
Typically, you use the default mailbox.
If you select the voice mailbox of another extension, you can click Edit to modify that
extension.
Users/Groups: The FortiVoice system turns on the message waiting light on the
phones of a user or user group to notify the user or group of a new voice message
stored in the voice mailbox associated with this extension.
To select users or user groups, click the + sign in the field and select the
users/groups and then click Close.
To listen to the message after being notified, a user can dial *97 or the code you set
(see Modifying feature access codes on page 289) and enter the user’s own user
PIN.
For information on creating user groups, see Creating extension groups on page
188.

Web Access Configure web user portal and softclient access frommobile or desktop devices.

Authentication
type

Select the extension’s authentication type: Local or LDAP.

User password Enter the password for user portal access which can be much longer and stronger to
mitigate the risk of password guess attack and preserve the User PIN for phone
access only.
Control of using personal password or voicemail PIN to access user portal is set
when configuring phone system capacity. For more information, see Configuring
system capacity on page 112.
You can check the password strength. See Reviewing system configuration on
page 149.
ClickGenerate to generate a strong password automatically. Select View password
to display the password.
This option is only available when you select Local for Authentication Type.

LDAP profile If you select LDAP for Authentication type, select an LDAP profile to apply to this
extension. For information on LDAP profile, see Configuring LDAP profiles on page
132.
You can click New to create a new profile or Edit to modify the selected one.
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Authentication
ID

If you select Try common name with base DN as bind DN as the user authentication
option in the authentication profile you select, enter the authentication ID based on
the user objects’ common name attribute you entered in the Common name ID field
of the profile, such as jdoe.
If you select Search user and try bind DN as the user authentication option in the
authentication profile you select, leave this field blank.
This option is only available if you select LDAP for Authentication type.

Phone Access Configure voicemail access by phone or access to restricted phone calls.

Voicemail PIN Enter the password for the extension user to access voicemail and the user portal.
Selection of using personal password or voicemail PIN to access user portal is set
when configuring phone system capacity. For more information, see Configuring
system capacity on page 112.
You can check the PIN strength. See Reviewing system configuration on page 149.
ClickGenerate to generate a strong password automatically. Select the view PIN
icon to display the password.
If you have configured the default user PIN (see Default Voicemail PIN on page
111), the password appears here. However, you can change it.

Personal code Enter the extension specific account code that can be used to restrict calls. This
code is needed to make some restricted calls.
You can clickGenerate to get a code.

Call Center This option appears if your FortiVoice system has a call center license.
Select to configure the departments that a call center agent manages, queues that
the agent belongs to, skill sets, and skill levels. Click Call Centerand configure the
following:
l Agent profile: Select the profile for the agent. You can also create a new one or
modify an existing one. For more information about agent profiles, see
Configuring agent profiles on page 249.

l Managed departments: An agent manager may need to monitor call queues in
certain departments. For information on setting up departments, see Creating
extension departments on page 189.
Click the + sign in the field and select the departments to be monitored and
then click Close.

l Member of Queues: Click to select the call queues to join.
l Queues: Click the + sign in the field and select the queues of which you
want the extension/agent to be a member, and click Close.

l Main/Outgoing queue: This option is for collecting the outgoing calls from
all queues by this agent and displaying them in Working with call queue
statistics on page 250. You can select any queue of which this agent is a
member for that purpose except None which will not collect agent’s
outgoing call information. ClickOK.

l Skill Sets: Click New to select the skill set for the agent, including skill and level,
and click Create. For more information about agent skills and levels, see
Adding agent skill sets on page 248 and Creating agent skill levels on page
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248.
ClickOK.

4. Click Create (for new extension) orOK (for editing extension).

Auditing SIP extension password

You can verify the strength of SIP extension passwords. For information on setting SIP extension password, see
Configuring IP extensions on page 162.

For information on auditing passwords, see Auditing the extension passwords on page 159.

To audit a SIP extension password

1. Go to Extension > Extension > IP Extension.
2. Under Actions, click Password Auditor.

The Password Auditor page opens.
3. If a password policy warning (red check mark) appears, click the warning to view the password policy. To set the

policy, see Configuring system options on page 77.
4. If the password strength of an extension shows theWeak (black check mark) icon, you can click the password and

change it based on the policy until the password strength shows the Strong (green check mark) icon.
5. Click Close.

Auditing extension numbers and MAC addresses

You can find and modify the duplicate extension numbers and conflicting MAC addresses.

Duplicate numbers occur when there are more than one extension with the same number.

Conflicting MAC addresses occur when there are more than one extension associated with a MAC address.

To audit SIP extension numbers

1. Go to Extension > Extension > IP Extension.
2. Under Actions, click Number Auditor > Numbers.

The Number page opens and lists the duplicate numbers.
3. Select the number you want to modify and click Edit.

The duplicate number’s configuration page displays.
4. Edit the duplicate number and clickOK.

For information on extension numbers, see Configuring IP extensions on page 162.
5. Click Close.

To audit extension MAC addresses

1. Go to Extension > Extension > IP Extension.
2. Under Actions, click Number Auditor >MACs.

The Conflict MAC page opens and lists the multiple extensions on a single MAC address.
3. Select the number you want to remove and click Edit.
4. On the IP Extension page, go to Device Setting.
5. In the Device field, click the Select icon.
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6. Click Select None at the bottom of the page.
7. ClickOK, then Close.

Importing a list of extensions

The import feature provides a simple way to add a list of new extensions in one operation. You can create a CSV file in
any spreadsheet and import the data as long as the columns match the FortiVoice format.

To import of list of extensions

Your CSV file must have a header row containing the following column names. Otherwise, the
import will fail.
l User ID
l Extension
l Phone type
l Mac address
l Phone profile

The CSV file can contain an Email column with three email addresses or less. To separate the
email addresses, use a space.

1. Go to Extension > Extension > IP Extension .
2. Cick Actions > Import.
3. Locate and select the CSV file.
4. ClickOpen.

The CSV file uploads.
5. Click Import.

FortiVoice displays the results of the import.

Configuring SIP forking

SIP forking allows you to have your desk phone ring at the same time as your softphone or a SIP phone on your mobile.

When a device is added, it inherits your master phone’s user privileges except hot-desking and fax.

You can add two SIP extensions and one external phone number.

To add a SIP device

1. Go to Extension > Extension > IP Extension.
2. Double-click an extension and go to Device Setting > Auxiliary Phone.
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3. Click New and configure the following:

GUI field Description

Type If your device is a FortiFone phone, configure the following:
l Device: Click the Select icon to choose a FortiFone phone and clickOK.
The phones are configured for SIP inventory. See Configuring desk
phones on page 143.
You may also add a new phone or edit an existing one.

l Phone model: After you select a device, the device model appears.
l Setting: If you select Custom, configure the following:

l SIP settings: Select the SIP profile for the extension. Click Edit to
modify the current profile or New to configure a new one. For more
information, see Configuring SIP profiles on page 122.

l Emergency Zone: Select the emergency zone profile for this
extension. Click Edit to modify the current profile or New to configure
a new one. For more information, see Configuring emergency zone
profiles on page 142.

l Location: Select Internal if the phone does not traverse through
Network Address Translation (NAT) to connect to the FortiVoice
system, and External if the phone does. These are system defined
locations.

l Handset ID: If the device is a FortiFone-870i or FortiFone-D72 that
supports multiple handsets, enter or clickGenerate to identify the
handset.

l MWI (MessageWaiting Indicator): Enable or disable MWI on the
phone.

l Auto answer: Enable or disable automatic answering on the phone.
l Direct call: Enable or disable direct calling on the phone.

If your device is a Generic phone, configure the following:
l SIP settings: Select the SIP profile for the extension. Click Edit to modify
the current profile or New to configure a new one. For more information,
see Configuring SIP profiles on page 122.

l Emergency Zone: Select the emergency zone profile for this extension.
Click Edit to modify the current profile or New to configure a new one. For
more information, see Configuring emergency zone profiles on page 142.

4. Click Create.

Modifying managed extensions

FVG-GS16 is a FXS gateway with 16 ports. When it is added to the FortiVoice system, 16 extensions are generated. You
can modify each of the 16 extensions.

To edit a GS16 extension, go to Extension > Extension > Managed Extension.

For detailed information about editing managed extensions, see the FortiVoice FXS Gateway Deployment
GuideManaging FXS gateways on page 152
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Modifying analog extensions (FVE-20E2 and FVE-50E6 models only)

FortiVoice FVE-20E2 and FVE-50E6 have two analog ports and two default analog extensions. You can edit the default
extension configuration.

Analog lines, also referred to as POTS (Plain Old Telephone Service), are used for standard phones, fax machines, and
modems.

This section also applies to FVE 1000E-T (one analog port) which is still supported but has
reached its end-of-order (EOO) date.

To view the default analog extension, go to Extension > Extension > Analog Extension.

GUI field Description

Actions

PSTN Setting For details, see To configure the PSTN settings of an analog extension on page
175.

Maintenance Select an extension and click this button to manage the following folders:
l Voicemail:Old
l Fax:Inbox
l Fax:Sent

You can check the size of the folders and empty them.
Click Back to return to the Analog tab.

Enabled Select to activate the extension.

Number The analog extension number.

Display Name The name displaying on the extension.

To edit the default analog extension

1. Go to Extension > Extension > Analog Extension.
2. Select the default extension and click Edit.
3. Configure the following:

GUI field Description

Number Enter the extension number following the extension number pattern. See
Configuring PBX options on page 108.
If required, click Edit Preference to modify the user preferences. See Setting
extension user preferences on page 181.

User ID This is the system-generated ID for the extension and is read-only.

Analog port Select the analog port for the extension. You can click Edit to modify the port.

Enable Select to activate the extension.
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GUI field Description

Display name Enter the name displaying on the extension. This is usually the name of the
extension user.
Click the + sign if you want to add caller IDs:
l External caller ID: Enter the external caller ID that displays on a called
phone when you make a call. Use the name<phone_number> format,
such as HR<222134>.

l Emergency caller ID: Enter the emergency caller ID. Use the
name<phone_number> format, such as HR<222134>.

If you do not enter the caller IDs, your organization's main number will be used.
If you add both IDs, the emergency ID will only be used when making
emergency calls. All other calls will use the external caller ID.

Description Add any notes for the extension.

User Setting

Management

User privilege Select the services for the extension. Click Edit to modify the current user
privilege or click New to configure a new one. For more information about user
privileges, see

Voicemail Main Voicemail: Configure the extension's voicemail. Select the extension’s
own voicemail (Default) or that of another extension as the voicemail of this
extension.
Typically, you use the default voicemail.
Send voicemail notification to: You can include users and groups to be notified
when the extension receives a voicemail.
User(s) andGroup(s): To add an existing users or groups, click +, select the
users and groups, and click Close. ClickOK.

Advanced Direct call. Enable or disable direct calling for this extension. With direct calling,
you specify a phone number that the FortiVoice system automatically dials
after the phone user lifts the phone handset (or presses the headset or speaker
button) to place a call.
Number: Enter a phone number for direct calling.

Web Access Configure the web user portal and softclient (mobile and desktop) access.

Authentication type Select the extension’s authentication type: Local or LDAP.

User password This option is only available when you select Local for Authentication Type.
Enter the password to access the user portal and softclient (mobile and
desktop).

To check the password strength, hover over the shield icon. For example, .
For more details about password strength, see Auditing the extension
passwords on page 159.
To generate a strong password automatically, click Generate.
To view the password, click .
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GUI field Description

LDAP profile If you select LDAP for Authentication type, select an LDAP profile to apply to
this extension. For information about LDAP profile, see Configuring LDAP
profiles on page 132.

Authentication ID This option is only available if you select LDAP for Authentication type.
During the configuration of the LDAP profile, you have two options for the user
authentication:
l If you select Try Common Name with Base DN as Bind DN , update
update the authentication ID field to match the common name attribute
(example, uid) that you entered in the Common name ID field of the LDAP
profile. Example, jdoe.

l If you select Search User and Try Bind DN, leave the authentication ID
field blank.

Phone Access Configure voicemail access by phone or access to restricted phone calls.

Voicemail PIN Enter the PIN for the extension user to access voicemail and the user portal.

To check the PIN strength, hover over the shield icon. For example, . For
more details about password strength, see Auditing the extension passwords
on page 159.
To generate a strong PIN automatically, click Generate.
To view the PIN, click .

Personal code Enter the extension specific account code used to restrict calls. To make a
restricted call, you need this code.
To generate a strong personal code automatically, click Generate.

4. ClickOK.

To configure the PSTN settings of an analog extension

This section applies to the following models only:
l FVE-20E2
l FVE-50E6

You can configure the PSTN settings of the analog voice trunk to match the same settings of your PSTN service
provider.

1. Go to Extension > Extension > Analog Extension.
2. Select an extension.
3. Click Actions > PSTN Setting.
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4. Configure the following:

GUI field Description

Name The name of this configuration. This field is view-only.

Codec Select the Codec for the extension.

Caller ID signalling Select the caller ID signalling standard per your phone company’s request.

First digit timeout
Match digit timeout

Enter the timeout in milliseconds.
The following example explains both timeout settings using default values.
The user picks up the phone handset and hears a dialtone. If the user does not
enter a digit within the specified 16 seconds (first digit timeout), the dialtone
restarts. After pressing the first digit, the user has 3 seconds (match digit
timeout) to enter the next digit. After the user’s finger is off the button, the timer
resets and the user has another 3 seconds to enter the next digit and so on.
When the 3-second timer expires, the phone number is identified as complete,
and the call is attempted.
The default First digit timeout is 16000.
The default Match digit timeout is 3000.

5. ClickOK.

Setting up remote extensions

A remote extension reaches an external phone by automatically selecting a line from a trunk and dialing the phone
number. For example, a remote extension could reach an employee’s cell phone or home phone, or a phone at a branch
office.

A caller can connect to a remote extension through the auto attendant, or can be transferred to a remote extension by a
call cascade. A user at a local extension can manually transfer a caller to a remote extension, or can dial a remote
extension directly. If the remote extension is busy or unanswered, the system can route the call using the remote
extension’s call cascade.

For example, a caller reaches the auto attendant and dials a local extension. The user is not there, so the call is
unanswered. The call cascade of the local extension can be configured to transfer unanswered calls to a remote
extension. The remote extension can be configured to dial the user’s cellular phone. This way the user is available
outside the office.

Remote extensions are designed to operate with local major telephone service providers. The feature may not function
correctly with some telephone and mobile operator’s networks, especially for international phone numbers and mobile
phones roaming internationally.

To configure a remote extension

1. Go to Extension > Extension > Remote Extension.
2. Click New.
3. Configure the following:
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GUI field Description

Number Enter the local extension number from which calls are transferred to a remote
extension.

Remote number Enter the remote phone number to which a call to the local extension is
transferred. You can enter digits 0–9, space, dash, comma, # and *.
If you want to enter an auto attendant number followed by an extension, you
can use comma (,) or semicolon (;) to pause the automatic dialing.
A comma pauses dialing for two seconds, for example, 1-123-222-1234,
5678#. In this case, once auto attendant 1-123-1234 is dialed, and after two
seconds, extension 5678 is automatically dialed.
A semicolon pauses dialing for one second, for example, 1-123-222-1234;
5678#. In this case, once auto attendant 1-123-1234 is dialed, and after one
second, extension 5678 is automatically dialed.

Enable Select to activate the remote extension.

Display name The name displaying on the remote extension when a call is transferred.
You can choose to display the name differently than the one you entered here.
See Modifying caller IDs on page 124.
Click the + sign if you want to add caller IDs:
l External caller ID: Enter the external caller ID that displays on a called
phone when a call is transferred through the remote extension. Use the
name<phone_number> format, such as HR<222134>.

l Emergency caller ID: Enter the emergency caller ID. Use the
name<phone_number> format, such as HR<222134>.

If you do not enter the caller IDs, your organization's main number will be used.
If you add both IDs, the emergency ID will only be used when making
emergency calls. All other calls will use the external caller ID.

Description Enter any notes you have for the extension.

User Setting

Management Configure the extension’s role in other settings.

User privilege Select the services for the extension. Click Edit to modify the current user
privilege or click New to configure a new one. For more information on user
privilege, see Configuring user privileges on page 137.

Department Select the department that the extension belongs to. Click Edit to modify the
current department or click New to configure a new one. For more information
on extension department, see Configuring agents on page 238.

Voicemail Configure the extension’s voice mailbox.
In some cases, you may want other users or groups to share this voice
mailbox. For example, a supervisor wants his/her co-workers to access his/her
voice mailbox while he/she is away.
Main voice mailbox: Select the extension’s own voice mailbox (Default) or that
of another extension as the voice mailbox of this extension.
Typically, you use the default mailbox.
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GUI field Description

If you select the voice mailbox of another extension, you can click Edit to
modify that extension.
Users/Groups: The FortiVoice system turns on the message waiting light on
the phones of a user or user group to notify the user or group of a new voice
message stored in the voice mailbox associated with this extension.
To select users or user groups, click the + sign in the field and select the
users/groups and then click Close.
To listen to the message after being notified, a user can dial *97 or the code
you set (see Modifying feature access codes on page 289) and enter the user’s
own user PIN.
For information on creating user groups, see Creating extension groups on
page 188.

Web Access Configure web user portal and softclient access frommobile or desktop
devices.

Authentication type Select the extension’s authentication type: Local or LDAP.

User password This option is only available when you select Local for Authentication Type.
Enter the password for user portal access which can be much longer and
stronger to mitigate the risk of password guess attack and preserve the User
PIN for phone access only.
Control of using personal password or voicemail PIN to access user portal is
set when configuring phone system capacity. For more information, see
Configuring system capacity on page 112.
You can check the password strength. See Reviewing system configuration
on page 149.
ClickGenerate to generate a strong password automatically. Select View
password to display the password.

LDAP profile If you select LDAP for Authentication type, select an LDAP profile to apply to
this extension. For information on LDAP profile, see Configuring LDAP profiles
on page 132.
You can click New to create a new profile or Edit to modify the selected one.

Authentication ID This option is only available if you select LDAP for Authentication type.
If you select Try common name with base DN as bind DN as the user
authentication option in the authentication profile you select, enter the
authentication ID based on the user objects’ common name attribute you
entered in the Common name ID field of the profile, such as jdoe.
If you select Search user and try bind DN as the user authentication option in
the authentication profile you select, leave this field blank.

Phone Access Configure voicemail access.

Voicemail PIN Enter the password for the extension user to access voicemail and the user
portal.
You can check the PIN strength. See Reviewing system configuration on page
149.
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GUI field Description

ClickGenerate to generate a strong password automatically. Select the view
PIN icon to display the password.
If you have configured the default user PIN (see Default Voicemail PIN on page
111), the password appears here. However, you can change it.

4. Click Create.

Configuring fax extensions

If you want to continue using your fax machine with the VoIP phone system, connect the fax machine to an adapter (such
as OBIHAI OBi 200, Cisco SPA 112, or Grandstream HT 702) that supports T38 first before connecting it to the
FortiVoice system. T38 is a protocol designed to allow fax to travel over a VoIP network.

In this case, the fax machine is treated like an extension. The FortiVoice system receives faxes and relays them to the
fax machine. Faxes sent from the fax machine will follow the fax sending dial plans.

To use this option, you need to create and enable the fax extensions first. You then need to configure the FortiVoice
system to receive and relay the faxes to the fax machine.

For information on fax configuration, see Configuring fax on page 280.

To create or edit a fax extension

1. Go to Extension > Extension > Fax Extension.
2. Click New or double-click an existing extension.
3. Configure the following:

GUI field Description

Number Enter the extension number following the extension number pattern. See
Configuring PBX options on page 108.

User ID This is the system-generated ID based on the user ID prefix you set (see User
ID prefix on page 111) and the extension number.
This option is view only and only appears when you edit an extension. You can
add a new user ID through the CLI.

Enable Select to enable this extension to receive and send faxes that support T38
protocol. This applies to using a fax machine connected to the FortiVoice
system via an adapter that supports T38 protocol. For more information, see
Configuring fax on page 280.

Display Name Enter the name displaying on the extension.

Description Enter any notes about the extension.

Device Setting l SIP settings: Select the SIP profile for the phone.
Click the New icon to add a new profile. See Configuring SIP profiles on
page 122.
Click the Edit icon to modify a selected profile. See Configuring desk
phones on page 143.

l Emergency zone: Select the emergency zone profile for the phone.
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GUI field Description

Click the New icon to add a new profile. See Configuring emergency zone
profiles on page 142.
Click the Edit icon to modify a selected profile. See Configuring
emergency zone profiles on page 142.

l Advanced:
l SIP password: Enter the password used for configuring your SIP
phone from the phone or the Web. You need the phone's IP to access
it from the Web.
You can check the password strength. See Reviewing system
configuration on page 149.
ClickGenerate to generate a strong password automatically. Select
View password to display the password.
If you have configured the default SIP user password (see Default
SIP user password on page 110), the password appears here.
However, you can change it.

l Location: Select Internal if the phone does not traverse through Network
Address Translation (NAT) to connect to the FortiVoice system, and
External if the phone does. These are system defined locations.

User Setting

Management Configure the extension’s role in other settings.

User privilege Select the services for the extension. Click Edit to modify the current user
privilege or click New to configure a new one. For more information on user
privilege, see Configuring user privileges on page 137.

Department Select the department that the extension belongs to. Click Edit to modify the
current department or click New to configure a new one. For more information
on extension department, see Configuring agents on page 238.

Web Access Configure web user portal and soft client access frommobile or desktop
devices.

Authentication type Select the extension’s authentication type: Local or LDAP.

User password Enter the password for user portal access which can be much longer and
stronger to mitigate the risk of password guess attack and preserve the User
PIN for phone access only.
Control of using personal password or voicemail PIN to access user portal is
set when configuring phone system capacity. For more information, see
Configuring system capacity on page 112.
You can check the password strength. See Reviewing system configuration
on page 149.
ClickGenerate to generate a strong password automatically. Select View
password to display the password.
This option is only available when you select Local for Authentication Type.
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GUI field Description

LDAP profile If you select LDAP for Authentication type, select an LDAP profile to apply to
this extension. For information on LDAP profile, see Configuring LDAP profiles
on page 132.
You can click New to create a new profile or Edit to modify the selected one.

Authentication ID If you select Try common name with base DN as bind DN as the user
authentication option in the authentication profile you select, enter the
authentication ID based on the user objects’ common name attribute you
entered in the Common name ID field of the profile, such as jdoe.
If you select Search user and try bind DN as the user authentication option in
the authentication profile you select, leave this field blank.
This option is only available if you select LDAP for Authentication type.

Phone Access Configure voicemail access by phone or access to restricted phone calls.

Voicemail PIN Enter the password for the extension user to access voicemail and the user
portal.
Selection of using personal password or voicemail PIN to access user portal is
set when configuring phone system capacity. For more information, see
Configuring system capacity on page 112.
You can check the PIN strength. See Reviewing system configuration on page
149.
ClickGenerate to generate a strong password automatically. Select the view
PIN icon to display the password.
If you have configured the default user PIN (see Default Voicemail PIN on page
111), the password appears here. However, you can change it.

Personal code Enter the extension specific account code that can be used to restrict calls.
This code is needed to make some restricted calls.
You can clickGenerate to get a code.

4. Click Create (for new extension) orOK (for editing extension).

Setting extension user preferences

Each SIP and analog extension comes with its default user preferences, including voicemail settings and phone display
preference. You can modify these settings .

Phone users can modify the preferences on the web user portal.

To view the list of extensions, go to Extension > Extension > Preference.

GUI field Description

Maintenance Select an extension and click this option to reset the user preferences and voice
messages to the default values.

Number The extension number.
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GUI field Description

Display name The name displaying on the extension. This is usually the name of the extension
user.

Voice Message Count The number of voice mails left on an extension.

To edit extension user preferences

1. Go to Extension > Extension > Preference.
2. Select an extension and click Edit.
3. Configure the following:

GUI field Description

Setting

Number The extension number. This is read-only.

User ID This is the system-generated ID based on the extension number. You can add
a new user ID through the CLI.
This is read-only.

Display name The name displaying on the extension. This is usually the name of the
extension user.
This is read-only.

Emergency caller ID The caller ID to display on the destination phone when you dial the emergency
number, such as 911. This ID is set when you configure the extension.
This is read-only.

External caller ID The caller ID you want to display on a called phone instead of the FortiVoice
main number (see Main number on page 108) or the trunk phone number (see
Phone Number on page 204). This ID is set when you configure the extension.
This is read-only.

Ring duration Enter the phone ringing duration in seconds before an incoming call goes to
voicemail.

Programmable keys To see this item, the extension must have an assigned phone that supports
programmable keys.
Click the Edit icon to configure programmable keys. For details, see
Configuring programmable keys profiles on page 129.

Call forward Select to forward phone calls and enter the phone number to forward the calls.
This function only works if call forwarding is enabled in the extension’s user
privilege. See Configuring user privileges on page 137.

Call waiting Select to enable call waiting. This function only works if call waiting is enabled
in the extension’s user privilege. See Configuring user privileges on page 137.

Do not disturb Select to enable DND. This function only works if DND is enabled in the
extension’s user privilege. See Configuring user privileges on page 137.
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GUI field Description

Voicemail handling (Caller
press 0 during
announcement)

Select to enable reaching the operator by pressing 0 when you hear the
announcement of a callee’s voicemail.

Include caller ID number
when playing voicemail
message

Select to announce caller’s ID when playing the voicemail.

Include date and time
when playing voicemail
message

Select to announce date and time when playing the voicemail.

Notification Options

Voicemail Select the type of email notification when this extension has a voicemail:
l None: Do not send any notification.
l Simple: Send an email notification. This is the default setting.
l With attachment: Send an email notification with the voicemail attached.

Fax Select the type of email notification when this extension has a fax:
l None: Do not send any notification.
l Simple: Send an email notification. This is the default setting.
l With attachment: Send an email notification with the fax attached.

Missed call SelectOn if you want to receive an email notification when an incoming call is
missed.

Email address Enter the email address to which an email notification is sent.

Voicemail Options Configure greeting, unavailable, and busy messages.
Name: Your name of the voicemail. For example, John Doe.
l Standard: Use the system default name for the voicemail. This will be the
extension number.

l Personal: Use your own name for the voicemail.
l Click Call me to ring your extension and record a name using the
phone, such as your name or extension number.

l Click Upload to import an audio file (including your name or extension
number). The uploaded audio file must be a WAVE file (.wav) in PCM
format and with a maximum size of 10 MB.

l Click Play to listen to a recorded name.
l Click Erase to delete a recorded name.
l Click Download to save a recorded name.

Greeting: Select the voicemail greeting mode and greeting content.
l Standard: The system defined greeting.
l Simple: The customer-recorded greeting that applies to any time except
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GUI field Description

when the line is busy and extension is unavailable.
l Scheduled: The customer-recorded greeting that comes with a schedule.
l Conditional: The customer-recorded greeting that only applies to
occasions when the line is busy or extension is unavailable.

l Audio file: Click to configure the greeting. This option is only available
when you select Simple, Scheduled or Conditional.
l Click Call me to ring your extension and record a message such as a
greeting, unavailable, or busy message using the phone. This applies
to the Simple and Scheduledmodes.

l Click Upload to import a message such as a greeting, unavailable, or
busy message. The uploaded audio file must be a WAVE file (.wav) in
PCM format and with a maximum size of 10 MB.

l Click Play to listen to a message such as a greeting, unavailable, or
busy message.

l Click Erase to delete a message such as a greeting, unavailable, or
busy message.

l Click Download to save a message such as a greeting, unavailable,
or busy message.

If you select Scheduled forGreeting, click New to add a system schedule or
create a new one. You can also add a greeting file which is the audio file you
configured when clicking Audio File.
The purpose of having a separate voicemail name file is for occasions that you
just want to change the name without touching the greeting file.

Display Preference Configure the preference for screen display on the user portal.

Phone language Select the prompt language for the extension. The default is English.
For information on adding prompt languages, see Managing phone audio
settings on page 117.

Web language Select the language for the FortiVoice user portal.

Theme Select the display theme for the FortiVoice user portal.

Time zone Select the time zone for the FortiVoice user portal.

Idle timeout Set the timeout for the FortiVoice user portal.

Account Management

Change PIN number Click to change the password for accessing the voice mailbox and the
FortiVoice user portal.

Change User Password Click to change the password for accessing the FortiVoice user portal.

View Sip configurations Click to display the SIP configuration information which FortiVoice uses to
register your SIP phone.

Agent This option appears if you have a call center license.
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PIN required to login/logout
from phone

Select to enable an agent to log into/log out of a queue from the extension
using the user PIN.
For information on feature access codes, see Configuring account codes on
page 160.

PIN required to
pause/unpause from
phone

Select to enable an agent to pause/unpause a queue from the extension using
the user PIN. To pause means the agent is not answering calls.
For information on feature access codes, see Configuring account codes on
page 160.

Auto-Pause after agent
login queue

Select to automatically put the agent in pause (not ready) status after the agent
logs into a queue. The agent can unpause a queue to answer calls.
For information on feature access codes, see Configuring account codes on
page 160.

Follow Me See Configuring follow me settings on page 185.

Call Handling Retain original caller ID: Select to maintain the original caller's identity when
forwarding an inbound call.
Call screening: Select if you want the FortiVoice system to prompt callers for
their names so that callees can identify the callers before the connect to you.
Record caller name: By default, this option is selected when you select Call
screening. If you deselect this option, the FortiVoice system will not prompt
callers for their names. Instead, the FortiVoice system will ring a called phone
but will not connect to the caller. The callee is able to pick up the phone and
see the caller’s ID and decide whether to pick up the call.
For more information on normal or quick call handling, see Handling calls on
page 186.

Twinning Setting This option is only available if Twinning is selected in the user privilege (Phone
System > Profile > User Privilege) of the extension. For more information, see
Twinning on page 138.
l Setting: Select the twinning method.

l Disabled: Select to disable twinning.
l Simple: Select to configure a basic twinning by adding a phone
number.

l Scheduled: Select to configure a twinning by adding phone numbers
based on a schedule.

4. ClickOK.

Configuring follow me settings

Follow me allows a call to an extension to be transferred to another destination when you are not available.
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This configuration serves as a profile for use in managing calls. See Handling calls on page 186.

To configure follow me settings

1. Go to Extension > Extension > Preference.
2. Double-click a record and go to Follow Me.
3. Click New.
4. Enter a Name for this setting.
5. Under Follow Me Numbers, click New.
6. Enter a phone number to which the call to your extension can be transferred.
7. Enter the phone ringing duration, in seconds, before the call goes to voicemail or next number in the sequence.
8. Click Create.
9. Repeat steps 4 to 7 of this procedure to add more numbers if you want to transfer a follow me call to multiple

numbers in a sequence. The numbers will be dialed according to the sequence in the follow me settings.
10. Click Create.

Handling calls

Extension > Extension > Preference > Call Handling allows you to manage the call process. For example, you can
configure the process to forward a call to another number on a specific schedule.

You can manage a normal call handling by configuring the call process for different situations. You can also manage
quick call handling by dialing a code to enter into a default mode and configure the call process for that particular mode if
required.

If the extension with configured call handling action is part of another FortiVoice function that also has configured call
handling action (for example, a member of a ring group or used for a virtual number), then the call handling action of the
other FortiVoice function overrides the extension call handling action.

To handle a normal call

1. Go to Extension > Extension > Preference.
2. Double-click a record and go to Call Handling.
3. Click Normal Call Handling.
4. Select a call status.

Each status can only be used for one call management configuration.
5. Select System default action or User defined action.

The System default action (action shows in brackets) changes depending on the status selection.
6. If you select User defined, click New to define a call process according to a schedule.

l Select a pre-configured Schedule for the call action. You can click View to display the schedule details. For
information on configuring schedules, see Scheduling the FortiVoice system on page 142.

l For Call from, select the call type on which you want to take an action.
l Add an Action for the call process.
For some call handling processes that may require further actions, you need to add one or more call processes
to complete the call handling. For example, after adding a process that contains a Forward action, you can add
another process with aGo voicemail action to complete the call handling. In this case, the call will be forwarded
to the phone specified and if the phone is not picked up, a voicemail will be left on this extension.
Default action is equal to the action when you select System default action under Call Process.
l If you select Follow me, select a follow me profile. For information on configuring follow me, see Follow Me
on page 185.
This option is available only if call forwarding is enabled in the extension’s user privilege. See Configuring
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user privileges on page 137.
l If you select Play announcement, select a sound file. For information on configuring sound files, see
Managing phone audio settings on page 117

l If you select Auto attendant, select an auto attendant profile. For information on configuring auto
attendant, see Configuring auto attendants on page 262.

l f you select Forward, enter the number to which you want to forward the call.
This option is available only if call forwarding is enabled in the extension’s user privilege. See Configuring
user privileges on page 137.

l Click Create.
7. ClickOK.

To handle a quick call

1. Go to Extension > Extension > Preference.
2. Double-click a record and go to Call Handling > Quick call handling.

GUI field Description

Effective mode Displays the call handling status when you dial *720, *721, *722, and *723.
For example, if you dial *720, the status will be Normal because you have
canceled the quick mode.

*720 Dial the code to cancel the quick handling mode.

*721 Dial the code to set toOut of officemode. Click the text to modify the quick
mode option and time as required.

*722 Dial the code to set to Awaymode. Click the text to modify the quick mode
option and time as required.

*723 Dial the code to set toOthermode. Click the text to modify the quick mode
option and time as required.

3. If you want to add a new quick call handling process, clickQuick Call Handling.
4. Select a call status.

Each status can only be used for one call management configuration.
5. Click New to define a call process according to a schedule.

l Select a pre-configured Schedule for the call action. You can click View to display the schedule details. For
information on configuring schedules, see Scheduling the FortiVoice system on page 142.

l Add an Action for the call process. You can add multiple actions to process a call in sequence. For example,
you can add Play announcement and then Auto attendant. In this case, an incoming call will be transferred to
the auto attendant after an announcement is played.

l Default action is equal to the action when you select System default action under Call Process.
l If you select Follow me, select a follow me profile. For information on configuring follow me, see Follow Me
on page 185.
This option is available only if call forwarding is enabled in the extension’s user privilege. See Configuring
user privileges on page 137.

l If you select Play announcement, select a sound file. For information on configuring sound files, see
Managing phone audio settings on page 117.

l If you select Auto attendant, select an auto attendant profile. For information on configuring auto
attendant, see Configuring auto attendants on page 262.
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l If you select Forward, enter the number to which you want to forward the call. This option is available only if
call forwarding is enabled in the extension’s user privilege. See Configuring user privileges on page 137.

l Click Create.
6. ClickOK.

Creating extension groups

Extension > Group lets you configure extension groups including extension departments, ring groups, paging groups,
and pickup groups.

This section contains the following topics:

l Creating user groups on page 188
l Creating extension departments on page 189
l Creating ring groups on page 189
l Configuring ring group call handling on page 190
l Creating paging groups on page 191
l Creating multicast paging groups on page 192
l Creating message groups on page 193
l Creating pickup groups on page 194
l Creating business groups on page 195

Creating user groups

You can create a user group and use it to simplify the configuration of an IP extension voice mailbox, a general voice
mailbox, a ring group, a paging group, or a pickup group. For example, when creating a ring group, you can select the
name of a user group rather than entering each user name individually.

For information on creating IP extension voice mailboxes, see Configuring IP extensions on page 162.

For information on creating general voice mailboxes, see Setting up a general voicemail on page 196.

To create a user group

1. Go to Extension > Group > User Group.
2. Click New.
3. Enter a name for the group.
4. Optionally, select a department from which you want to configure a user group. For information on extension

department, see Creating extension departments on page 189.
5. ForMembers, click the + sign and select the available users or user groups that you want to include in the group.
6. Click Close.
7. Click Create.
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Creating extension departments

You can create department profiles for applying to the extensions. For example, you can create a department profile
called HR and apply it to extension 1111 to indicate that this extension belongs to the HR department.

For information on applying department profiles, see Setting up local extensions on page 162.

To create an extension department

1. Go to Extension > Group > Department.
2. Click New.
3. In the Name field, enter the name of the department.
4. In the Comment field, enter any notes you have for this department.
5. If you have the call center license, the Call Center section appears. For information on call centers, see Setting up a

call center on page 230.
a. To set up a call center manager group, underManager, click the + sign and select the available users or user

groups that you want to include in the group. Click Close.
b. To set up a call center member group, underMember, click the + sign and select the available users or user

groups that you want to include in the group. Click Close.
c. To set up a call center queue group, underQueue, click the + sign and select the available users or user groups

that you want to include in the group. Click Close.
6. Click Create.

Creating ring groups

A ring group is a group of local extensions and external numbers that can be called using one number. Local extensions
and auto attendants can dial a ring group.

A ring group can reach a group of extensions. For example, ring group 301 can ring the sales group at extensions 111,
112, 113, and 114. When a customer calls the sales group, the first available salesperson answers for the group.

To create a ring group

1. Go to Extension > Group > Ring Group.
2. Click New.
3. Configure the following:

GUI field Description

Name Enter the name for the ring group.

Number Enter the ring group number following the extension number pattern in
Configuring PBX options on page 108.
Clicking in the field displays a list of crossed-out extensions. These numbers
are already used and cannot be used as ring group numbers.
The ring group number, once dialed, will ring all the extensions in the group.

Display Name Enter the name displaying on the extensions of the ring group, such as “HR”.

Enable Select to activate the ring group.

Ring mode Select how you want the ring group to be called.
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GUI field Description
l All: All extensions in the group will ring when the ring group number is
dialed.

l Sequential: Each extension in the group is called one at a time in the order
in which they have been added to the group. You can set a timeout period
for each ring.

Department Select the department to which this group belongs.

Members Select the available extensions or user groups that you want to include in the
ring group and click -> to move them into the Selected field.
For information on creating extensions and user groups, see Setting up local
extensions on page 162 and Creating extension groups on page 188.

External numbers Click New to add an external phone number to the ring group. For example,
you can add the number of a remote employee to a ring group.

Normal Call Handling Use this option to configure the call handling for the ring group when you edit a
ring group. For more information, see Configuring ring group call handling on
page 190.

Advanced Setting l Ring pattern: Select a ring pattern for the group.
l Ring duration: Set the amount of time in seconds allowing all extensions
or each one to ring before going to voicemail.

l Early media: Select the ring tone for the group. For creating new sound
files, see Managing phone audio settings on page 117.

l Caller ID option: Select how you want the caller ID to display.
l Retain original caller ID: Select to keep the original caller ID of the
extension.

l Call waiting: Select to enable call waiting.
l Emergency call option: Select Display emergency caller ID to show the
emergency caller’s ID, or Disconnect ongoing call to stop a call that uses
the line for emergency call.

l Missed call notification: Select if you want an email notification when an
incoming call is missed. Enter the email address to which an email
notification is sent.

4. Click Create.

Configuring ring group call handling

Use the Normal Call Handling option to configure the call automation. For example, you can configure the process to
forward a call to another number on a specific schedule.

You can only configure ring group call handling when editing a ring group.

If the ring group with configured call handling action is part of another FortiVoice function that also has configured call
handling action (for example, a member of another ring group or the ring group extension is used for a virtual number),
then the call handling action of the other FortiVoice function overrides the ring group call handling action.

For information on the Normal Call Handling option, see Normal Call Handling on page 190.

To configure the call process
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1. On the Ring Group page, click Normal Call Handling.
2. Select a call status.

Each status can only be used for one call management configuration.
For the Busy status, if you set the ring group’s ring mode to All, the FortiVoice system will declare the ring group
busy only if all extensions in the group are busy; if you set the ring group’s ring mode to Sequential, the FortiVoice
system will declare the ring group busy only if the last extension in the group is busy after ringing the extensions
sequentially and each one is busy at the time of being rung.

3. Select System default action or User defined action.
The System default action changes depending on the status selection.

4. If you select User defined, click New to define a call process according to a schedule.
l Select a pre-configured Schedule for the call action. You can click View to display the schedule details. For
information on configuring schedules, see Scheduling the FortiVoice system on page 142.

l Add an Action for the call process. You can add multiple actions to process a call in sequence. For example,
you can add Play announcement and then Auto attendant. In this case, an incoming call will be transferred to
the auto attendant after an announcement is played.
Default action is equal to the action when you select System default action under Call Process.
l If you selectGo to Voicemail, enter the extension number of the voice mail.
l If you select Play announcement, select a sound file. For information on configuring sound files, see
Managing phone audio settings on page 117.

l If you select Auto attendant, select an auto attendant profile. For information on configuring auto
attendant, see Configuring auto attendants on page 262.

l If you select Forward, enter the number to which you want to forward the call.
This option is available only if call forwarding is enabled in the extension’s user privilege. See Configuring
user privileges on page 137.

l Click Create.
5. ClickOK.

Creating paging groups

A paging group allows you to make an audio announcement (page) to a group of Fortinet desk phone users who can
hear the announcement through their phone speakers.

With a paging group, you can page a group of extensions using one number.

To easily manage users in a paging group, create a user group and then add that user group to a paging group. For
details about user groups, see Creating user groups on page 188.

All Fortinet desk phones support paging.
Fortinet softclients (desktop and mobile) and third-party phones do not support paging.

To create a paging group

1. Go to Extension > Group > Paging Group.
2. Click New.

FortiVoice Phone System 6.0.12 Administration Guide 191
Fortinet Inc.



Configuring extensions

3. Configure the following:

GUI field Description

Name Enter a unique name for the group.

Number Enter the paging group number following the extension number pattern in
Configuring PBX options on page 108.
After dialing this number, you will be able to make your audio announcement
(page).

Display name Enter the name displaying on the extensions of the group, such as “HR”.

Enable Select to activate this group.

Caller ID option Decide how you want to display the caller ID of the person making the page.
l No change: The caller ID will display as is.
l Replace: The caller ID will be replaced by the Display name you set.
l Prefix: The caller ID will be prefixed with the Display name you set.
l Replace by Caller ID from IVR: The caller ID will be replaced by the IVR
caller ID. For information on IVR, see Configuring IVRs on page 238.

l Prefix with Caller ID from IVR: The caller ID will be prefixed by the IVR
caller ID. For information on IVR, see Configuring IVRs on page 238.

Emergency call option Display emergency caller ID: Select to display the caller ID when an
emergency call comes in during a page.
Disconnect ongoing call: Select to interrupt a page in progress when an
emergency call comes in.

Department If the paging group belongs to a department, select that department.

Members Click the + sign in the field and select the available extensions or user groups
that you want to include in the paging group. Click Close.

4. Click Create.

Creating multicast paging groups

When being applied in a message group configuration, multicast paging provides a more robust and efficient mechanism
to deliver audio and text messages to larger paging groups.

For more information on message groups, see Creating message groups on page 193.

To create a multicast paging group

1. Go to Extension > Group > Multicast Paging Group.
2. Click New.
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3. Configure the following:

GUI field Description

Name Enter a unique name for the group.

Number Enter the multicast paging group number following the extension number
pattern in Configuring PBX options on page 108.
After dialing this number, you will be able to make your audio announcement
(page).

Display name Enter the name displaying on the extensions of the group, such as “HR”.

Status Select to activate this group.

Multicast IP Enter the multicast address to which the FortiVoice system can send a single
copy of voice or text data, which is then distributed to an entire group of
phones.

Multicast Port Enter the port number on the multicast server through which the FortiVoice
system can send a single copy of voice or text data.

Alert tone Select to enable a notification tone.

Members Click the + sign in the field and select the available extensions or extension
groups that you want to include in the multicast group. Click Close.

Description Select Click to edit to enter any notes you have for the group.

4. Click Create.

Creating message groups

Message group provides a mass notification service for delivering audio and/or text messages to FortiFones in user
groups or a multicast paging group. This solution supports standalone FortiVoice deployments and/or integration with
3rd party Mass Notification Systems to provide emergency notification using FortiFone IP desktop phones.

For more information on multicast paging group, see Creating multicast paging groups on page 192.

To create a message group

1. Go to Extension > Group > Message Group.
2. Click New and configure the following:

GUI field Description

Name Enter a unique name for the group.

Number Enter the message group number following the extension number
pattern in Configuring PBX options on page 108.
This is the number that, once dialed, will send text or audio
message to all the extensions in the group.

Display name Enter the name displaying on the extensions of the group, such as
“HR”.

Status Select Status to activate this group.
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GUI field Description

Message type Select to send text or audio message.

If you select to send a text message, click Text and configure the following:

Title Enter the message title.

Message Use the variables to compose your message or enter your
message directly.

Display time Enter the time period (in seconds) that you want the message to
display on the extension phones.
The range is from 0 to 86400.
If you want the message to display on the FortiFone phone screen
permanently until the user takes action, enter 0.

Delay Enter the time period (in seconds) that you want to delay sending
the text.
The range is from 0 to 120.

Alert tone Select to activate notification alert on the extensions.

User group Select the user groups for this message group and clickOK.
For information on user groups, see Creating user groups on page
188.

If you select to send an audio message, click Audio and configure the following:

Sound file Select an existing sound file or click New to create a new one for
the audio message.
For information on sound files, see Managing phone audio settings
on page 117

Multicast group Select the multicast paging group for this message group or click
New to create a new one for the audio message.
For information on user groups, see Creating multicast paging
groups on page 192.

Single number Enter the external phone number to which you want to send this
message and clickOK. You can enter digits from 0 to 9.

3. Click Create.

Creating pickup groups

Some organizations cannot afford to miss phone calls on any extensions. Pickup groups allow some members in a group
to answer incoming calls that ring on other extensions while the users are away.

Pickup groups can press the feature codes to pick up incoming calls that ring on other extensions. For more information,
see Modifying feature access codes on page 289.

To create a pickup group

1. Go to Extension > Group > Pickup Group.
2. Click New.
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3. Enter a Name for the group.
4. Select Enable to activate this group.
5. Select the department to which this group belongs.
6. ForMembers, click the + sign in the field and select the extensions or user groups that you want to include in the

pickup group.
For information on creating extensions and user groups, see Setting up local extensions on page 162 and Creating
extension groups on page 188.

7. Click Close.
8. For Pickup by members, click the + sign in the field and select the extensions or user groups that are allowed to

answer incoming calls that ring on other extensions.
9. Click Close.
10. Click Create.

Creating business groups

Business groups introduce an abbreviated extension number dialing for phone users in the same logical group. As an
example, lets use a company where employees are located in three different offices (locations 1, 2, and 3). Each location
uses a different prefix code (11, 12, 13) but the same numbering pattern (XXX). Therefore, extensions in location 1 can
be 11801, 11802, 11803, and so on. Extensions in location 2 can be 12801, 12802, 12803 and so on. Extensions in
location 3 can be 13801, 13802, 13803, and so on.

When phone users in location 1 want to reach an extension in the same business group (location 1), they can dial the
abbreviated extension (such as XXX) instead of the full extension number (11XXX).

When phone users in location 1 want to reach an extension in another business group (such as location 2), they dial the
full extension number (such as 12XXX).

The business group option is available when you are using the following models and settings
only:
l FVE-500E, FVE-500F, FVE-1000E, and larger models only
l Under Phone System > Setting > Miscellaneous, go to Business Group and select
Automatic.

To create a business group

1. Go to Extension > Group > Business Group.
2. Click New.
3. Enter a Name for the group.
4. Select Status to activate this group.
5. Enter the extension Abbreviated prefix code for the group. You can enter digits from 0 to 9. The allowed length is

from 2 to 8 digits.
6. For Abbreviated dialing pattern, enter the pattern following the pattern-matching syntax. For example, XXXX

matches any four-digit number. For more details about the pattern-matching syntax, see Configuring PBX options
on page 108.

7. For Description, click Edit to enter any notes you have for the group.
8. Click Create.
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Setting up a general voicemail

Some organizations, such as the sales team of a company, may have the need to share voice mails within multiple users
or a user group for better service and efficiency. With a general voicemail, when there is a new voice mail, the entire
group is copied or notified. Any member of the group can access the voice mail and once this is done, the notification is
gone and others know that the voice mail has been taken care of.

To set up a general voicemail

1. Go to Extension > General Voicemail > General Voicemail.
2. Click New.
3. Configure the following:

GUI field Description

Number Enter the voicemail extension number following the extension number pattern. See
Configuring PBX options on page 108.

User ID This is the system-generated ID based on the voicemail extension number.
This option is view only. You can add a new user ID through the CLI.

Enable Select to activate the voicemail extension.

Display name Enter the name of the voicemail extension.

Description Enter any notes for the extension’s voicemail.

User Setting

Management Configure the voicemail extension’s role in other settings.

User privilege Select the services for the extension. Click Edit to modify the current user privilege
or click New to configure a new one. For more information on user privilege, see
Configuring user privileges on page 160.

Voicemail Configure the users for sharing this extension’s voicemail.
Mode: Select the way to deliver the voicemail from this voicemail extension to the
users sharing this voicemail.
l Centralized: Select to copy or notify the entire group when a new voicemail
comes in. Any member of the group can access the voicemail and once this is
done, the notification is gone and others know that the voicemail has been
taken care of.
l Notify message waiting light: If you select this option, the FortiVoice
system turns on the message waiting light on a user’s phone when a new
voice message is left on this voicemail.

l List as mailbox: Users can listen to a centralized voicemail by dialing *97 or
the customized code (see Modifying feature access codes on page 289 )
from their own extensions and enter the personal voicemail PIN for this
general voicemail.

l Broadcast: If you select this option, the voicemail is sent to the voicemail boxes
of the users. Users can access the voicemail by dialing *98 or the customized
code (see Modifying feature access codes on page 289) from any extensions
and enter the personal voicemail PIN.
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GUI field Description
l User(s)/Group(s): Select the users or groups to notify when a voicemail is left in
this voicemail extension. To select the users or groups to share this voicemail,
click the + sign in the field and choose the users or groups. ClickOK.
For information on creating user groups, see Creating extension groups on
page 188.

Web Access Configure user portal and softclient access frommobile or desktop devices.
If Password policy is disabled appears, see Setting password policies on page 158.

Authentication
type

Select the extension’s authentication type: Local or LDAP.

User password If you selected Local as the Authentication type, enter the password for user portal
access. This password can be much longer and stronger to mitigate the risk of
password guess attack and preserve the voicemail PIN for phone access only.
To let the system create the user password, clickGenerate.
To show the user password, click the eye icon.
Control of using user password or voicemail PIN to access user portal is set when
configuring phone system capacity. For more information, see Configuring system
capacity on page 112.

LDAP profile If you select LDAP for Authentication type, select an LDAP profile to apply to this
extension. For information on LDAP profile, see Configuring LDAP profiles on page
132.
You can click New to create a new profile or Edit to modify the selected one.

Authentication
ID

If you select Try common name with base DN as bind DN as the user authentication
option in the authentication profile you select, enter the authentication ID based on
the user objects’ common name attribute you entered in the Common name ID field
of the profile, such as jdoe.
If you select Search user and try bind DN as the user authentication option in the
authentication profile you select, leave this field blank.
This option is only available if you select LDAP for Authentication type.

Phone Access Configure voicemail access by phone or access to restricted phone calls.

Voicemail PIN Enter the password for the extension user to access voicemail and the user portal.
Selection of using personal password or voicemail PIN to access user portal is set
when configuring phone system capacity. For more information, see Configuring
system capacity on page 112.
You can check the PIN strength. See Reviewing system configuration on page 149.
ClickGenerate to generate a strong password automatically. Select the view PIN
icon to display the password.
If you have configured the default user PIN (see Default Voicemail PIN on page
111), the password appears here. However, you can change it.

4. Click Create.

FortiVoice Phone System 6.0.12 Administration Guide 197
Fortinet Inc.



Configuring extensions

Working with virtual numbers

A virtual number is an extension that is not assigned to a phone. Unlike auto attendants, when a call goes to a virtual
number, the caller does not need to manually select any options by pressing the phone keys. The call process is
automated based on time schedules. For example, for after business hour phone calls, you can configure a virtual
number to play an announcement, then transfer the call to the voice mailbox. You can also transfer the calls to the auto
attendant where the callers can manually select the options based on the auto attendant configuration.

If the virtual number with configured call handling action is part of another FortiVoice function that also has configured
call handling action (for example, a member of a ring group), then the call handling action of the other FortiVoice function
overrides the virtual number call handling action.

To configure a virtual number

1. Go to Extension > Virtual Number > Virtual Number and click New.
2. Configure the following:

GUI field Description

Name Enter a name for the virtual number.

Number Enter the virtual number which is not assigned to any phone.

Display name Enter the name displaying on the extension. This is usually the name of the
extension user.

Enable Select to activate this virtual number.

Bypass sub call handling Select if you want to bypass the call handling configuration embedded in the
call handling of this virtual number.

Comment Enter any notes you have for the virtual number.

Call Handling Use this option to configure the call handling for the virtual number. For more
information, see Configuring virtual number call handling on page 198.

3. Click Create.

Configuring virtual number call handling

Use the Call Handling optionto configure the call automation. For example, you can configure the process to forward a
call to another number on a specific schedule.

For information on the Call Handling option, see Call Handling on page 198.

To configure the call process

1. On the Virtual Number page, click New under Call Handling.
2. Select a pre-configured Schedule for the call action. You can also click New to create a schedule or Edit to modify

the selected one. For information on configuring schedules, see Scheduling the FortiVoice system on page 142.
3. Select an Action for the call handling.

Some actions require that you enter further information to complete the call process, such as Dial extension andGo
to Voicemail.
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For some call handling processes that may require further actions, you need to add one or more call processes to
complete the call handling. For example, after adding a process that contains a Set call queue priority action, you
can add another process with a Call queue action to complete the call handling. In this case, the call will be
processed again with new priority after it is transferred to the queue.

4. Click Create.
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Setting up trunks enables the FortiVoice system to connect to the outside world. You can configure trunks that go to your
VoIP service provider for long-distance calls, trunks for your PSTN circuits, and trunks that connect your various offices
together.

Trunks are applied to user extensions and dial plans. For more information, see Configuring extensions on page 162 and
Configuring call routing on page 220.

This topic includes:

l Configuring VoIP trunks on page 200
l Configuring PSTN/PRI trunks on page 206
l Configuring analog voice trunks on page 211
l Configuring office peers on page 213
l Setting up routing rules for FXO and PRI gateways on page 219

Configuring VoIP trunks

You can add one or more VoIP service providers to the FortiVoice system trunk configuration. The VoIP service
providers deliver your telephone services to customers equipped with SIP-based PBX (IP-PBX).

To view the list of VoIP service providers, go to Trunk > VoIP > SIP.

GUI field Description

Test Select to test if the trunk is created successfully.
For more information, see Testing SIP trunks on page 204.

FortiCall Select to create a SIP trunk with Fortinet’s FortiCall service.
You can only create one trunk with FortiCall and use it free for 30 days or 300
minutes, whichever comes first. Note that the trial account only allows outbound
calling and no international calling is available.
If you sign up for the service during a trial, the trial is closed and billing will start.
For more information, see Creating a SIP trunk with FortiCall service on page 205.

Enabled Select to activate this trunk.

Name The name of the VoIP service provider.

Server The VoIP provider’s domain name or IP address. For example, 172.20.120.11
or voip.example.com.

Port The port for SIP sessions.

SIP Setting The SIP profile applied to this trunk.

Status The status of the SIP trunk.
l Not registered: The trunk is not registered with the VoIP service provider and
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GUI field Description

is not in service.
l In service: The trunk is registered with the VoIP service provider and is in
service.

l Unavailable: The trunk is not reachable.
l Alarm detected: There is a problem with the phone line.
l Admin down: The trunk is disabled.
l Unmonitored: The trunk is unknown.

To create a VoIP trunk

Create a VoIP trunk for inbound and outbound calls.

1. Go to Trunk > VoIP > SIP.
2. Click New.
3. Configure the following:

GUI field Description

Name Enter a name for this trunk such as the VoIP service provider.

Enable Select to activate the SIP trunk.

Display name Enter your caller ID that will appear on the called phone, such as Example
Company.
If you entered the external caller ID in External caller ID on page 182, this trunk
display names will be overridden by the external caller ID. For more details,
see Caller ID modification hierarchy in the in the FortiVoice Cookbook.

Main number Enter the phone number provided by the VoIP service provider.

SIP Setting

SIP server Enter the VoIP provider’s IP address or domain name. For example,
172.20.120.11 or voip.example.com.

SIP port Most SIP configurations use TCP or UDP port 5060 for SIP sessions. If your
VoIP service provider uses a different port for SIP sessions, enter the port
number.
If you select the Using SRV record option, this field is greyed out.

Using SRV record If you entered the VoIP provider’s domain name in the SIP server field, select
this option to translate the domain name and obtain the SIP port.
You can only select this option if your VoIP provider uses the same settings.

User name Enter the user name provided by the VoIP service provider for the FortiVoice
system to register with the SIP server.

Password Enter the password provided by the VoIP service provider for the FortiVoice
system to register with the SIP server.

Auth. user name Some VoIP providers may provide you with an authentication user name that is
different from your user name for the FortiVoice system to register with the SIP
server. If tat is the case, enter the authentication user name here.
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GUI field Description

Realm/Domain Some VoIP service providers’ SIP servers authenticate the PBXes that register
with them by requesting the name of the host performing the authentication. If
this is the case with your VoIP service provider, enter the name of the host
performing the authentication provided by your VoIP service provider.

SIP settings Select the SIP profile to apply the supported phone features and codecs for the
trunk. To match the information of the VoIP service provider, you can edit the
existing profile or click New to add a new one. For more information, see
Configuring SIP profiles on page 122.

Max channel Each trunk contains multiple channels. The number of channels you can have
in a trunk is controlled by your VoIP service provider. This number displays
under line appearance option when you configure programmable phone keys
for phone profiles. See Configuring phone profiles on page 125.
Consult your VoIP service provider for the maximum of channels that you can
set to limit the number of concurrent calls. For example, if you want to allow six
calls at a time, enter 6.
This field accepts value in the range of 1-450 inclusive.

Overflow check If selected, the phone calls exceeding theMax channel limit will be handled
according to the call handling actions set in the dialplan applied to this trunk.
For information on dialplans, see Configuring call routing on page 220.
If unselected, the phone calls exceeding theMax channel limit will be
disconnected.

Max outgoing channel With known max channels, if you need to reserve incoming channels, you may
enter the number of outgoing channels allowed and the remaining channels
are for incoming calls.
For example, the max channel number is 10 and you want to reserve 4
channels for incoming calls, you can enter 6 forMax outgoing channel.
The maximum channel limit is 2000.

User=Phone in SIP URI Select if your service provider requires this option to make the FortiVoice
system to be compatible with the VoIP service provider’s configurations.

Inband ringtone (Early
media)

Select to enable the FortiVoice system to send ring tone to the caller of an
incoming call before the establishment of a call connection.
This option is only editable if you enable early media in Advanced Setting on
page 91.

Caller ID Option l From Header: Select the caller ID for the SIP Call-ID header field for
uniquely identifying where a call is from.
l SIP user name: Use the user name provided by the VoIP service
provider for the FortiVoice system to register with the SIP server.

l Caller ID priority rule: Use the rule specified in the IETF SIP Priority
Header Field.

l Main number: Select if you want the trunk main number to appear on
the called phone. See Main number on page 201.

l Specified: Use a specified caller ID that you enter.
l P-Asserted-Identity header: Select the caller ID for the P-Asserted-Identity
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GUI field Description

header which contains the caller ID information for the call on the INVITE
SIP packet.
l No PAI header: Do not use the P-Asserted-Identity header.
l Caller ID priority rule: Use the rule specified in the IETF SIP Priority
Header Field.

l Main number: Select if you want the trunk main number to appear on
the called phone. See Main number on page 201.

l Specified: Use a specified caller ID that you enter.

Registration

Type Enter the SIP registration information from the VoIP service provider by
selecting a registration method in Type. You can receive calls after registering
with the SIP server of the VoIP service provider.
l Disable: Select to deactivate the registration with the VoIP service
provider.

l Standard: Select to use the standard registration method which
automatically registers with the SIP server of the VoIP service provider.
Enter the registration interval in minutes.

l Registration URI: Enter the registration string provided by the VoIP
service provider.
The string in Registration URI has the following format:
<user>@<host><:port>
where <user> is the user name.
<host> is a hostname, domain name, FQDN, or IP address.
<:port> is the port number. If you omit to specify a port, the default port
(5060) is used.
Examples:
support@mycompany.com

support@mycompany.com:6000

bob@168.176.248.255

l Registrar: Select to enter the registration information from the VoIP
service provider:
l Registrar (Host/IP): Enter the VoIP service provider’s SIP registration
server domain name or IP address. For example, 172.20.120.11
or voip.example.com.

l Registrar port:Most SIP configurations use TCP or UDP port 5060
for SIP sessions. If your VoIP service provider uses a different port
for SIP sessions, enter the port number.

l Transport protocol: Select the transport protocol used for the
registration.

l Registration interval: Enter the registration interval with the SIP
server in minutes.

Outbound Proxy Some VoIP service providers use proxy servers to direct its traffic. If this is the
case, your registration request will go to the proxy server first before reaching
the registration server. Configure the following:
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GUI field Description
l Select to activate the proxy server settings.
l Proxy (Host/IP): Enter the proxy server’s domain name or IP address. For
example, 172.20.120.11 or voip.example.com.

l Proxy port: Enter the port number of the proxy server.
l Transport protocol: Select the transport protocol used for the registration.

Fax Configure fax signal automatic detection and fax handling.

Automatic fax
detection Selecting this option may cause the following behaviors:

l Delay the call response time on this trunk by
automatically adding two ring tones to detect incoming
fax signals.

l Affect toll charges on incoming lines.

Select for the FortiVoice system to detect incoming fax signal on this trunk
automatically.

Forward to DID
mapping extension

This option is available when you select Automatic fax detection.
Select this option if a DID number is mapped directly to an extension to receive
voice and fax calls (see details in Configuring direct inward dialing on page 222
and Mapping DID numbers on page 224). Faxes will be sent to the extension’s
personal fax account, accessible through the User Portal.
In Forward to eFax account (next field), select an eFax account (as configured
in Receiving faxes on page 280). Should a fax fail to be received by the DID
mapping extension, the FortiVoice will use this eFax account as a fallback.

Forward to eFax
account

This option is available when you select Automatic fax detection.
Select or edit an eFax account to receive faxes. To add a new eFax account,
click +.
For details about the eFax account configuration, see Receiving faxes on page
280.

Phone Number Adding a phone number in this field is optional and for information purposes
only.
The phone number supports digits from 0 to 9 and a maximum of 63 digits.
Click New to add the phone number provided by your VoIP service provider.
Click Create when done.
You can add multiple numbers.

4. Click Create.

Testing SIP trunks

After you create a SIP trunk, you can select the trunk and click Test to see if the trunk works.

For more information, see Test on page 200.

To test a SIP trunk
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1. Go to Trunk > VoIP > SIP.
2. Select the trunk that you want to test and click Test.
3. Select Test Call-Dry Run or Test Call.

The System Configuration Test page appears.
4. Configure the following:

GUI field Description

Test Call - Dry Run Run a system SIP trunk test without making a real phone call.

Destination
number

Enter a destination number to call.

From number Enter the number from which you want to call the destination number. The FortiVoice system
will connect this number with the destination number for the test.

Test Click to start the dry run test and check the Test result.

Reset Click to remove the test result in order to start a new test.

Test Call Test the SIP trunk by making a real phone call.

Destination
number

Enter a destination number to call.

After call is
established

Select the FortiVoice action once it calls the destination number:
l Play welcome message: The FortiVoice system will play a message to the destination
number.

l Connect test call to number: In the Number field, enter the number from which you want
to call the destination number. The FortiVoice system will connect this number with the
destination number to test the trunk.

Test Click to start the test and check the Test result.

Reset Click to remove the test result in order to start a new test.

Creating a SIP trunk with FortiCall service

You can create one trunk with FortiCall and use it free for 30 days or 300 minutes, whichever comes first. Note that the
trial account only allows outbound calling and no international calling is available.

If you sign up for the service during a trial use, the trial is closed and billing will start.

To create a SIP trunk with FortiCall service

1. Go to Trunk > VoIP > SIP.
2. Click FortiCall.

The Create SIP Trunk dialog box displays.
3. Note down theMAC Address and System ID for use if you decide to sign up for the service later.
4. Keep Create dialplans for this trunk selected unless you want to create the dialplans by yourself.

The auto-generated dialplans will replace the default inbound, outbound, and emergency call dialplans. You can
delete them if you do not choose to use the FortiCall service.

5. ClickOK.
6. For Fax, see Fax on page 204.
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7. For Register Trial Account, enter your name, email address, and reseller or partner code.
8. Click Create.
9. ClickOK.

The FortiCall trunk is created. You will receive an email with sign up and login instructions.

Configuring PSTN/PRI trunks

This section applies to the following models only:
l FVE 300E-T
l FVE 500E-T2
l FVE 1000E-T
l FVE 2000E-T2

PSTN (Public Switched Telephone Network)/PRI (Primary Rate Interface) trunks connect your PBX or VoIP network to
your PSTN service providers and through them to the outside world. These trunks can be analog or digital phone lines.

You can modify the default trunks or create new ones.

To view the PSTN trunks, go to Trunk > PRI > PRI.

GUI field Description

Enabled Select to activate the trunk.

Name The name of the trunk.

Status The trunk statuses, including:
l In service: The trunk is currently in use.
l Not activated: The trunk is not enabled.
l Idle: The trunk is not in use.
l Unavailable: The trunk is not reachable.
l Conflict: The trunk conflicts with another one.
l Alarm detected: There is a problem with the trunk.
l Admin down: The trunk is disabled.

Type The trunk type: digital or analog.

To add a T1/E1 voice circuit trunk

1. Go to Trunk > PRI > PRI.
2. Click New.
3. Configure the following:

GUI field Description

Trunk Setting

Name Enter a name for this trunk.

Enable Select to activate the trunk.
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GUI field Description

Display name Enter your caller ID that will appear on the called phone, such as
Example Company.
If you entered the external caller ID in External caller ID on page
182, this trunk display name will be overridden by the external
caller ID.

Number Enter the phone number provided by the VoIP service provider.

Relay fax Select to allow T.38 fax relay on the trunk.
Enter the fax number.

Hardware Property Use this option to configure the T1/E1 span.
Spans represent trunks (spans) of T1/E1 PSTN lines. The
FortiVoice system supports T1/E1 lines according to the installed
voice card. You can add a span name using the CLI.
In Edit span, click Edit after selecting a span to configure the
settings of the T1/E1 span to match the same settings of your
PSTN service provider. ClickOK after finishing the configuration.
For more information, see Configuring the T1/E1 span on page
208.
In Span, select the span for the trunk and move it to the Selected
field.

Max channel Indicates the total number of B channels on all spans.

Max outgoing
channel

Enter the number of outgoing channels out of the maximum
number of B channels.

Fax Configure fax and phone signal automatic detection and fax
handling.

Automatic fax
detection Selecting this option may cause the following

behaviors:
l Delay the call response time on this trunk by
automatically adding two ring tones to detect
incoming fax signals.

l Affect toll charges on incoming lines.

Select for the FortiVoice system to detect incoming fax signal on
this trunk automatically.

Forward to DID
mapping extension

This option is available when you select Automatic fax detection.
Select this option if a DID number is mapped directly to an
extension to receive voice and fax calls (see details in Configuring
direct inward dialing on page 222 and Mapping DID numbers on
page 224). Faxes will be sent to the extension’s personal fax
account, accessible through the User Portal.
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In Forward to eFax account (next field), select an eFax account (as
configured in Receiving faxes on page 280). Should a fax fail to be
received by the DID mapping extension, the FortiVoice will use this
eFax account as a fallback.

Forward to eFax
account

This option is available when you select Automatic fax detection.
Select or edit an eFax account to receive faxes. To add a new eFax
account, click +.
For details about the eFax account configuration, see Receiving
faxes on page 280.

Phone Number Adding a phone number in this field is optional and for information
purposes only.
The phone number supports digits from 0 to 9 and a maximum of
63 digits.
Click New to add the phone number provided by your VoIP service
provider. Click Create when done.
You can add multiple numbers.

4. ClickOK.

Configuring the T1/E1 span

You can configure the settings of the T1/E1 span, including full or fractional PRI (T1/E1), to match the same settings of
your PSTN service provider.

For 2000E-T2, if a PRI trunk includes two spans, the configuration of the second span is much
simpler as the spans share many configurations.

For more information, see Hardware Property on page 207.

To configure the T1/E1 span

1. On the Trunk > PRI > PRI page, select a PRI trunk and click Edit.
2. In Hardware Property, go to Edit span, select a span, and click Edit.
3. Configure the following:

GUI field Description

Standard Options

Name The name of this span. This field is view-only.

Type Select the span type: PRI T1 or PRI E1.
A T1 span usually supports 23+1 channels, while an E1 span
supports 30 channels in CAS (Channel Associate Signaling) mode
and 30 B channels and one D channel in ISDNmode.
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Signalling Select the signaling type of the ISDN PRI:
l PRI signalling, CPE (Customer Premises Equipment) side
l PRI signalling, Network Side
l PRI R2 signalling

Advanced Options

Framing and coding
option

Specify the type of framing and coding to provision the PRI with
your PSTN service provider.

Clocking options Select the FortiVoice system’s clock synchronization:
l Clock sourcing from PSTN network
l Internal clocking source

This option does not need to match that of your PSTN service
provider.

Receive sensitivity Select the level of receiver sensitivity which is the ability of the
phone receiver to pick up the required level of phone signals to
make it operate more effectively within its application.
This option does not need to match that of your PSTN service
provider.

D-channel signalling
format

Select a signalling method for the D channel which is a signalling
channel and carries the information needed to connect or
disconnect calls and to negotiate special calling parameters (for
example, automatic number ID, call waiting, data protocol). The D
channel can also carry packet-switched data using the X.25
protocol.
If you choose Lucent 5ESS, the facility service for sending the
display name is enabled automatically.

Line build out Select the line build out (LBO).
LBO settings are an inherent part of T1 and T3 network element
transmission circuitry.
Since cable lengths between network elements and digital signal
cross-connect (DSX) vary in the central office, LBO settings are
used to adjust the output power of the transmission signal to
achieve equal level point (ELP) at the DSX.

D-channel By default, depending on your selection of Type on page 208, the
typical channel numbers are:
l Full T1: 24
l Full E1: 16

You can also set the channel numbers to others such as 1.
The settings you configure must match the same settings of your
PSTN service provider.

B-channel By default, depending on your selection of Type on page 208, the
typical channel settings are:
l Full T1: 1-23

FortiVoice Phone System 6.0.12 Administration Guide 209
Fortinet Inc.



Configuring trunks

GUI field Description
l Full E1: 1-15, 17-31

You can also configure the fractional channel numbers. For
example, for T1/E1, the channels can be:
l 1-12
l 2, 3, 4, 9-15
l 2-4, 9-15

The settings you configure must match the same settings of your
PSTN service provider.

PRI R2 Setting Since there is no single signaling standard for R2, the FortiVoice
system addresses this challenge by supporting many localized
implementations of R2 signaling.
This option is active only if you select PRI R2 signalling for
Signalling on page 209.

Country Select the country for PRI R2 settings.

Max ANI digits ANI (Automatic Number Identification) is a system used by
telephone companies to identify the DN (Directory Number) of a
calling subscriber. It allows subscribers to capture or display
caller’s telephone number.
Enter the number of digits of a caller‘s phone number to be
captured.
The default is 20.

Max DNIS digits Dialed Number Identification Service (DNIS) is a service provided
by telephone companies that lets the subscribers determine which
telephone number was dialed by a caller.
Enter the number of digits of a dialed call to be sent by the
telephone company.
The default is 20.

Caller category Select the caller type.

Incoming digits
mode

Select the incoming digits mode by consulting your telephone
company.

DTMF option l DTMF dialing: Select to enable dual-tone multi-frequency
signaling (DTMF) dialing.

l DTMF answering: Select to enable dual-tone multi-frequency
signaling (DTMF) answering.

Allow collect calls Select to allow collect calls.

MF timeout To enable the multi-frequency (MF) timeout, enter a value in
milliseconds.
The default is -1, which disables the setting.

Metering pulse
timeout

To enable the metering pulse timeout, enter a value in
milliseconds.
The default is -1, which disables the setting.
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4. ClickOK.

Configuring analog voice trunks

This section applies to the following models only:
l FVE-20E2
l FVE-50E6

To configure an analog voice trunk

1. Go to Trunk > Analog > Analog.
2. Click New.
3. Configure the following:

GUI field Description

Trunk Setting

Enabled Select to activate the trunk.

Name Enter a name for this trunk.

Display name Enter your caller ID that will appear on the called phone, such as Example
Company.
If you entered the external caller ID in External caller ID on page 182, this trunk
display name will be overridden by the external caller ID.

Number Enter the phone number provided by the VoIP service provider.

Hardware Property

Port Click + and select the FXO ports you want for this trunk. Click Close.
Each FXO port provides an analog phone line for a FXO device, such as a
phone or fax.

Max channel Indicates the total number of channels on the trunk.

Max outgoing channel Enter the number of outgoing channels out of the maximum number of
channels on the trunk.

Fax Configure fax and phone signal automatic detection and fax handling.

Automatic fax detection
Selecting this option may cause the following behaviors:
l Delay the call response time on this trunk by
automatically adding two ring tones to detect incoming
fax signals.

l Affect toll charges on incoming lines.

Select for the FortiVoice system to detect incoming fax signal on this trunk
automatically.
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Forward to DID mapping
extension

This option is available when you select Automatic fax detection.
Select this option if a DID number is mapped directly to an extension to receive
voice and fax calls (see details in Configuring direct inward dialing on page
222 and Mapping DID numbers on page 224). Faxes will be sent to the
extension’s personal fax account, accessible through the User Portal.
In Forward to eFax account (next field), select an eFax account (as configured
in Receiving faxes on page 280). Should a fax fail to be received by the DID
mapping extension, the FortiVoice will use this eFax account as a fallback.

Forward to eFax account This option is available when you select Automatic fax detection.
Select or edit an eFax account to receive faxes. To add a new eFax account,
click +.
For details about the eFax account configuration, see Receiving faxes on page
280.

Phone Number Adding a phone number in this field is optional and for information purposes
only.
The phone number supports digits from 0 to 9 and a maximum of 63 digits.
Click New to add the phone number provided by your VoIP service provider.
Click Create when done.
You can add multiple numbers.

4. Click Create.

To configure the PSTN settings of an analog voice trunk

This section applies to the following models only:
l FVE-20E2
l FVE-50E6

You can configure the PSTN settings of the analog voice trunk to match the same settings of your PSTN service
provider.

1. Go to Trunk > Analog > Analog.
2. Select a trunk.
3. Click PSTN Setting.
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4. Configure the following:

GUI field Description

Name The name of this configuration. This field is view-only.

Codec Select the Codec for the trunk.

Caller ID signalling Select the caller ID signalling standard per your phone company’s request.

First digit timeout
Match digit timeout

Enter the timeout in milliseconds.
The following example explains both timeout settings using default values.
The user picks up the phone handset and hears a dialtone. If the user does not
enter a digit within the specified 16 seconds (first digit timeout), the dialtone
restarts. After pressing the first digit, the user has 3 seconds (match digit
timeout) to enter the next digit. After the user’s finger is off the button, the timer
resets and the user has another 3 seconds to enter the next digit and so on.
When the 3-second timer expires, the phone number is identified as complete,
and the call is attempted.
The default First digit timeout is 16000.
The default Match digit timeout is 3000.

5. ClickOK.

Configuring office peers

If you have offices equipped with VoIP network, you can set up office peer trunks so that offices can call each other as if
they are local extensions.

You can set up three types of peer offices:

l Site to site: The office peer uses a FortiVoice system and is in an equal position with your FortiVoice system, rather
than a primary/secondary relationship.

l Remote access: The office peer uses a FortiVoice system and is in a primary/secondary relationship with your
FortiVoice system.

l Custom: The office peer uses a third-party PBX.

For the office peers to call each other, make sure that your FortiVoice system and the peer
office PBX are mutually registered with each other’s IP address and SIP port number.

To view the list of office peer trunks, go to Trunk > Office Peer > Office Peer.

GUI field Description

Fetch Office Directory Select a trunk and click this button to obtain the phone directory from this office peer.
This option only works if the PBX of the remote office is a FortiVoice system and Fetch
directory (see Directory on page 215) is selected on the remote system.
You can view the directory by going toMonitor > Directory and selecting this office in the
Locations field. For more information, see Viewing call directory on page 40.
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GUI field Description

Enabled Select to activate this trunk.

Name The name of the office peer.

Display name Enter the name displaying on the extension.

Type The type of the trunk.

Server The domain name or IP address of the remote office’s PBX. For example, 172.20.120.11
or peer.example.com.

Port The port number for VoIP network on the remote office’s PBX.

SIP Setting The SIP profile applied to this trunk.

Status The status of the SIP trunk.
l Not registered: The trunk is not registered with the VoIP service provider and is not in
service.

l In service: The trunk is registered with the VoIP service provider and is in service.
l Unavailable: The trunk is not reachable.
l Alarm detected: There is a problem with the phone line.
l Admin down: The trunk is disabled.
l Unmonitored: The trunk is unknown.

To set up a site to site office peer

1. Go to Trunk > Office Peer > Office Peer.
2. Click New.
3. UnderOffice peer type, click Site to Site.
4. If you want to change your local number pattern, click the Edit icon beside Local/incoming digit pattern to modify it.
5. Review the basic New office peer information, click Next.
6. Configure the following:

GUI field Description

Name Enter a name for the trunk.

Display name Enter the name displaying on the extension.

Enable Select to activate the trunk.

Peer Configuration

Remote Host/IP Enter the domain name or IP address of the office peer’s FortiVoice system.

Port Enter the port number for VoIP network on the office peer’s FortiVoice system.

Authentication Optionally, you may configure to authenticate the peer.

Disabled If you do not need authentication for the office peer, select this option to disable it.

Symmetric If you want to authenticate the FortiVoice systems forming the office peer trunk.,
enter the User name and Password. These settings must be the same on both
systems.
The FortiVoice system on each end will use the settings to authenticate each other.
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GUI field Description

Asymmetric If you want to authenticate incoming and outgoing calls, enter the Inbound user
name, Outbound user name, and Password. These settings must be the same on
both FortiVoice systems forming the office peer trunk.
The system on each end will use the settings to authenticate incoming and outgoing
calls.

Outgoing digit pattern Click the Edit icon if you want to modify the digit pattern of the outgoing dial plan for
the local and peer offices.

Advanced

Local/incoming
digit pattern

Click the Edit icon if you want to modify digit pattern of the local/incoming dial plan
for the local and peer offices.

Call routing Select the call routing plan as required.

Directory Select this option and click Fetch now to obtain the phone directory from this office
peer.
This option only works if the same option is selected on the office peer's FortiVoice
system.
You can view the directory by going toMonitor > Directory and selecting this office
in theOffice field. For more information, see Viewing call directory on page 40.

Share metric Enter the hop count value for this FortiVoice system to share its phone directory
with an office peer.
Example 1: You have configured the following deployment:
l A and B are office peers.
l A and C are office peers.

If you want A, B, and C FortiVoice systems to share their phone directories, enter 2
on all three FortiVoice systems.
Example 2: If your enter 1, the directory can only be shared with the first peer office
site designated on the routing table of this FortiVoice system.

SIP settings Select the SIP profile for the trunk. You can edit the existing profile or click New to
add a new one. For more information, see Configuring SIP profiles on page 122.

Max channel Enter the maximum voice channels for the trunk.
This field accepts value in the range of 1-450 inclusive.

7. Click Create.

To set up a remote access office peer

1. Go to Trunk > Office Peer > Office Peer.
2. Click New.
3. UnderOffice peer type, click Remote Access.
4. Select the role for the office peer:Master or Slave.

In a remote access office peer configuration, the slave peer registers to the master.
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5. If you want to change your local number pattern, click the Edit icon beside Local/incoming digit pattern to modify it.
6. Review the basic New office peer information, click Next.
7. Configure the following:

GUI field Description

Name Enter a name for the trunk.

Display name Enter the name displaying on the extension.

Enable Select to activate the trunk.

Peer Configuration

Master Host/IP This option is only available if you choose slave as the role of the office peer.
Enter the domain name or IP address of the primary FortiVoice system which is your
office peer.

Port This option is only available if you choose slave as the role of the office peer.
Enter the port number for VoIP network on the primary FortiVoice system.

User name To authenticate the FortiVoice systems forming the office peer trunk., enter the User
name . This name must be the same on both systems.
The FortiVoice system on each end will use this user name to authenticate each other.

Password To authenticate the FortiVoice systems forming the office peer trunk., enter the
Password. This password must be the same on both systems.
The FortiVoice system on each end will use this password to authenticate each other.

Outgoing digit
pattern

Click the Edit icon if you want to modify the digit pattern of the outgoing dial plan for the
local and peer offices.

Advanced

Local/incoming
digit pattern

Click the Edit icon if you want to modify digit pattern of the local/incoming dial plan for
the local and peer offices.

Call routing Select the call routing plan as required.

Directory Select this option and click Fetch now to obtain the phone directory from this office
peer.
This option only works if the same option is selected on the office peer's FortiVoice
system.
You can view the directory by going toMonitor > Directory and selecting this office in
theOffice field. For more information, see Viewing call directory on page 40.

Share metric Enter the hop count value for this FortiVoice system to share its phone directory with
an office peer.
Example 1: You have configured the following deployment:
l A and B are office peers.
l A and C are office peers.

If you want A, B, and C FortiVoice systems to share their phone directories, enter 2 on
all three FortiVoice systems.
Example 2: If your enter 1, the directory can only be shared with the first peer office site
designated on the routing table of this FortiVoice system.
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GUI field Description

SIP settings Select the SIP profile for the trunk. You can edit the existing profile or click New to add
a new one. For more information, see Configuring SIP profiles on page 122.

Max channel Enter the maximum voice channels for the trunk.
This field accepts value in the range of 1-450 inclusive.

More This option is only available if you choose slave as the role of the office peer.
This feature is used for remote access office peer connection through a proxy server,
such as the case in a FortiVoice Cloud deployment.

DNS SRV
record

The DNS service (SRV) record provides host and port information for specific services
such as voice over IP (VoIP). SIP needs to connect to a specific port on a specific
server.
Enable this option to allow the FortiVoice system to query the DNS SRV record for the
IP address and port number of the master FortiVoice system (office peer) to register.

Proxy To connect to the master office peer through a proxy server, do the following:
l If you have enabled DNS SRV record, enable Proxy and enter the unique
hostname of the master office peer in the (Host/IP) field. The DNS SRV record will
use the information to look for and provide the IP address and port number of the
master office peer.

l If you do not want to use the DNS SRV record service and therefore did not
enable it, enable Proxy and enter the unique hostname of the master office peer in
the (Host/IP) field. Also select the port number and communication protocol for
the master office peer. The DNS server will use the information to look for and
provide the IP address of the master office peer.

l If you know the IP address of the master office peer, enter it in the (Host/IP) field.
In this case, you do not need to enable DNS SRV record.

Registration
interval

Select the time (in seconds) needed for your FortiVoice system to register to the
master office peer until it receives a response.

8. Click Create.

To set up a custom office peer

1. Go to Trunk > Office Peer > Office Peer.
2. Click New.
3. UnderOffice peer type, click Custom.
4. Review the basic New office peer information, click Next.
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5. Configure the following:

GUI field Description

Name Enter a name for the trunk.

Display name Enter the name displaying on the extension.

Enable Select to activate the trunk.

Peer Configuration

Connection (Site to
Site)

Host/IP Enter the domain name or IP address of the office peer’s PBX.

Port Enter the port number for VoIP network on the office peer’s PBX.

Authentication Optionally, you may configure to authenticate the peer.
Disable: If you do not need authentication for the office peer, select this option to
disable it.
Symmetric: If you want to authenticate the PBXes forming the office peer trunk,
enter the User name and Password. These settings must be the same on both
PBXes.
The PBX on each end will use the settings to authenticate each other.
Asymmetric: If you want to authenticate incoming and outgoing calls, enter the
Inbound user name, Outbound user name, and Password. These settings must be
the same on both PBXes forming the office peer trunk.
The PBX on each end will use the settings to authenticate incoming and outgoing
calls.

Connection (Remote
Access Master)

User name To authenticate the PBXes forming the office peer trunk, enter the User name . This
name must be the same on both PBXes.
The PBX on each end will use this user name to authenticate each other.

Password To authenticate the PBXes forming the office peer trunk, enter the Password. This
password must be the same on both PBXes.
The PBX on each end will use this password to authenticate each other.

Advanced

Call routing Create outgoing and incoming dial plans for the local and peer offices. For more
information, see Configuring call routing on page 220.

SIP settings Select the SIP profile for the trunk. You can edit the existing profile or click New to
add a new one. For more information, see Configuring SIP profiles on page 122.

Max channel Enter the maximum voice channels for the trunk.
This field accepts value in the range of 1-450 inclusive.

6. Click Create.
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Setting up routing rules for FXO and PRI gateways

After you create FXO or PRI gateways underManaged System, go to Trunk and refresh your browser.Gateway appears
and lists all of the FXO or PRI gateways that have been added to the system. You can enable or disable the gateway
profiles as well as edit and delete profiles from the system. Any gateway added will have a profile automatically created.

For detailed instructions about deploying a FXO gateway, see the FortiVoice FXO Gateway Deployment Guide.

For detailed instructions about deploying a PRI gateway, see the FortiVoice PRI Gateway Deployment Guide.
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Dial plans define how calls flow into and out of the FortiVoice system. Without dial plans, telephone communications
among PBXs are impossible.

This topic includes:

l Configuring inbound dial plans on page 220
l Configuring direct inward dialing on page 222
l Viewing office peers for inbound calls on page 225
l Configuring outbound dial plans on page 225
l Viewing office peers for outbound calls on page 229

Configuring inbound dial plans

The Call Routing > Inbound > Inbound submenu lets you configure dial plans for incoming calls to the FortiVoice system.

When the FortiVoice system receives a call, the call is processed according to the inbound dial plan. To process the call,
the FortiVoice system selects the dial plan rule that best matches the dialed number and processes the call using the
settings in the dial plan rule. For example, if your main line is 123-4567, you can set a dial plan rule that sends all
incoming calls dialing 123-4567 to the auto attendant. Once the auto attendant is reached, the callers can follow the
instructions, for instance, to dial an extension.

To view the inbound dial plans, go to Call Routing > Inbound > Inbound.

GUI field Description

Enabled Select to activate this dial plan.

Name The name of the dial plan.

Call handling The actions to process the incoming calls with matched dialed numbers and/or
caller IDs. For details, see Call Handling on page 221.

Handling Description The specific call handling actions.

From Trunk The trunks of the incoming calls that are subject to this dial plan.

Match DID The phone number pattern in your dial plan that matches many different numbers.
For details, see Dialed Number Match on page 221.

Match CID The caller ID pattern for this dial plan. For details, see Caller ID Match on page
221.

To set up an inbound dial plan

1. Go to Call Routing > Inbound > Inbound.
2. Click New.
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3. Configure the following:

GUI field Description

Name Enter a name for this plan.

Enable Select to activate this dial plan.

From Trunk Select the trunks of the incoming calls that are subject to this dial plan.
Click the + sign in the field and select the trunks. Click Close.

Dialed Number
Match FortiVoice ignores this Dialed Number Match setting, if you configure

Call Handing as Dial Local Number on page 222.

With dialed number pattern matching, you can create one phone number pattern in your
dial plan that matches many different numbers.
When a called number matches this pattern, FortiVoice follows the dial plan rule that you
configure in Call Handling on page 221 (Endpoint Action or Call Routing).
Create the number match following the Pattern-matching syntax on page 227 and
Pattern-matching examples on page 227.

Caller ID Match Click New to set the caller ID pattern following Pattern-matching syntax on page 227 and
Pattern-matching examples on page 227 for this dial plan, and click Create.
You can enter an incoming call’s display name string or the caller’s phone number string
as the pattern.
Click Export to open or save the caller ID match file and Import to browse for a caller ID
match file.
Caller IDs under this pattern are subject to this plan.

Caller ID Modification Click the + sign in the field and select one or more caller ID modification configurations.
You can associate multiple caller ID modification configurations with a dial plan. For more
information on caller ID modification, see Modifying caller IDs on page 124.

Call Handling Select the actions to process the incoming calls with matched dialed numbers and/or
caller IDs.

Action type Select the type of action for the plan and configure the actions accordingly.

Endpoint
Action

Select this action type if you want to send incoming calls to the local destinations
according to operation schedules. For example, send calls to the voicemail after business
hours.
1. In Action type, select Endpoint Action.
2. Click New.
3. Select the Schedule for the action. For more information on FortiVoice schedule, see

Scheduling the FortiVoice system on page 142.
4. Select an Action for the incoming calls under this plan. For some actions, you need to

enter the extension (such as Go voicemail) or select a profile (such as Play
announcement).

5. Click Create.
6. If you need ou need more actions for this action type, repeat this procedure. To avoid

schedule conflicts, do not use the same schedule for more than one action.
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GUI field Description

Dial Local
Number When you configure this Dial Local Number setting, FortiVoice

ignores Dialed Number Match on page 221.

Select this action type if you want to send incoming calls to the local destinations at any
time. For example, you can enter 222xxxx as a pattern and strip 222. The FortiVoice
system will only dial the last four digits for all called numbers matching the pattern.
To configure this action type:
1. In Action type, select Dial Local Number.
2. Click New.
3. Add a number pattern in theMatch Patternfield following Pattern-matching syntax on

page 227 and Pattern-matching examples on page 227 for this dial plan. Repeat to
add more patterns.

4. For Strip, enter a number to omit dialing the starting part of a pattern. 0 means no
action.
For example, if your Match Pattern is 222XXXX and Strip is 3, the FortiVoice system
will only dial the last four digits for all called numbers matching the pattern.

5. For Prefix, add a number before a pattern.
For example, if yourMatch Pattern is 9XXX and the numbers under this pattern have
been upgraded to have an additional digit 5 at the beginning, you can enter 5 for the
Prefix. When an incoming call matches the pattern, the FortiVoice system will add a 5
before the number.

6. For Postfix, add a number after a pattern.
For example, if yourMatch Pattern is 9XXX and the numbers under this pattern have
been upgraded to have an additional digit 5 at the end, you can enter 5 for the
Postfix. When an incoming call matches the pattern, the FortiVoice system will add a
5 after the number.

7. Click Create.

Call
Routing

Select if you want to route incoming calls from the FortiVoice system to an external phone
system using an outbound dial plan.
To configure this action type:
1. In Action type, select Call Routing.
2. You can choose to enable the Retain original caller ID.
3. Click + to select the available outbound dial plans. This means that the FortiVoice

system will route incoming calls to an external phone system using the selected
outbound dial plans. For details, see Configuring outbound dial plans on page 225.

4. Click Create.

Configuring direct inward dialing

The Call Routing > Inbound > DID Mapping submenu lets you configure how to map direct inward dialing (DID) numbers.
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A DID number allows an inbound caller to bypass the auto attendant and directly reach a company employee or
department.

A phone company can offer a DID service to provide a block of telephone numbers for calling into your company
FortiVoice system (PBX) over limited rented physical lines (also called trunk lines). The phone numbers you rent may not
be enough to provide a DID number for each extension because each DID can only be mapped to one extension. To
address this issue, the FortiVoice system offers the following two options:

l Only map the DID numbers to the extensions you want.
l Bundle caller number patterns to a DID number which can be mapped to any extension.

To configure the DID mapping

1. Go to Call Routing > Inbound > DID Mapping.
2. Click New.
3. Configure the following:

GUI field Description

Rule name Enter a name for this DID setting.

Enable Select to activate this DID setting.

Trunk Select the trunk used for dialing the DIDs.

Schedule Select a schedule to apply the rule. For information on creating schedules, see Scheduling
the FortiVoice system on page 142.

Caller ID Match Click New to set the caller ID pattern following Pattern-matching syntax on page 227 and
Pattern-matching examples on page 227 for this dial plan, and click Create.
You can enter an incoming call’s display name string or the caller’s phone number string
as the pattern.
Click Export to open or save the caller ID match file and Import to browse for a caller ID
match file.
Caller IDs under this pattern are subject to this plan.

Inbound Handling

Inbound caller
ID modification

Select the caller ID modification configuration. For more information on caller ID
modification, see Modifying caller IDs on page 124.

Inbound
fallback action

Select the action to take if a caller not in the caller list dialed the DID number mapped to an
extension.
For some actions, you need to enter the extension, such as Dial voicemail.
For information on filtering callers, see Mapping DID numbers on page 224.

Number Mapping For adding a number mapping, see Mapping DID numbers on page 224.
Click Export to open or save the number mapping file and Import to browse for a number
mapping file.
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Mapping DID numbers

You can map a DID number to one extension. You can also map a DID number to multiple extensions based on the
callers’ phone numbers. For example, calling numbers 123-4567, 123-4568, and 123-4569 can call the DID number 222-
1000 to reach extension 1234. Calling numbers 234-4567, 234-4568, and 234-4569 can call the same DID number 222-
1000 to reach extension 1265. In both cases, the calling numbers will display on the extension.

If a caller outside the configured caller list dialed the mapped DID number, the FortiVoice system will react according to
the selected fall back action. For details, see Inbound fallback action on page 223.

To map DID numbers

1. Go to Call Routing > Inbound > DID Mapping.
2. Double click on the rule that you want to edit.
3. In Number Mapping, click New.
4. Configure the following:

GUI field Description

DID number Enter the DID number that you want to map to an extension. The DID number cannot be
mapped to more than one extension unless the DID is bundled with a caller number.
Otherwise, an error message about duplicate entry appears and the DID mapping
configuration cannot be saved.

Extension Enter the extension that you want to map to the DID number.
The extension supports digits from 0 to 9 and a maximum of 16 digits.

Description Enter any notes you have for the mapping.

Option Select Inbound to direct incoming calls to the extension through the mapped DID. If this
option is not selected, incoming calls to this extension through the mapped DID will follow
the inbound fallback action configured in Inbound fallback action on page 223. By default,
this option is selected.
SelectOutbound to send the DID numbers of the extensions mapped to the DID with
outgoing calls so that the DID numbers can display on the called phones. If this option is
not selected, the extension’s DID number is not sent with outgoing calls and the phone
number displayed on the called phone could be the FortiVoice main number (see Main
number on page 108) or the trunk phone number (see Phone Number on page 204)
associated with the extension. Alternatively, you can choose the caller ID to display on the
called phone when configuring an extension.
By default, both Inbound andOutbound are selected.

Caller Number
Patterns

This option allows you to bundle caller number patterns to a DID number which can be
mapped to any extension.
Enter the caller’s phone pattern field and click Create.
Click the + icon to add more calling numbers patterns.
Only the caller numbers matching the patterns you set will reach the mapped extension
when they dial the DID number.
The caller number pattern supports digits from 0 to 9, a maximum of 16 digits, and
optionally starts with one or more + signs.

5. Click Create.
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Viewing office peers for inbound calls

The Call Routing > Inbound > Office Peers submenu lets you view the office peers involved in the inbound call routing.
You may click an office peer link to configure it. For details, see Configuring office peers on page 213.

Configuring outbound dial plans

The Call Routing > Outbound > Outbound submenu lets you configure dial plans for outgoing calls from the FortiVoice
system.

You can configure dial plans on the FortiVoice system to route calls made from a FortiVoice extension to an external
phone system. The external phone system can be one or more PSTN lines or a VoIP service provider. To route calls to
an external phone system, you add dial plan rules that define the extra digits that extension users must dial to call out of
the FortiVoice system. The rules also control how the FortiVoice system handles these calls including whether to block
or allow the call, the destinations the calls are routed to and whether to add digits to the beginning of the dialed number.

For example, if users should be able to dial 911 for emergencies, you should include a dial plan rule that sends all calls
that begin with 911 to an external phone system. This rule should also override the default outgoing prefix so that users
can dial 911 without having to dial 9 first.

To view the outbound dial plans, go to Call Routing > Outbound > Outbound.

GUI field Description

Test Select to test if the dial plan is created successfully.
For more information, see Testing outbound dial plans on page 226.

Enabled Select to activate this dial plan.

Name The name of the dial plan.

Pattern The phone number pattern in the dial plan that matches other numbers. For
details, see Dialed Number Match on page 226.

Match CID The caller ID pattern for this dial plan. For details, see Caller ID Match on page
226.

Call handling The call handling action for the numbers matching the configured number pattern
and the caller IDs matching the caller ID pattern. For details, see Call Handling on
page 226.

To set up an outbound dial plan

1. Go to Call Routing > Outbound > Outbound.
2. Click New.
3. Configure the following:

GUI field Description

Name Enter a name for this plan.

Enable Select to activate this dial plan.
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GUI field Description

Emergency Call Select to allow emergency call with this plan. By default, this is selected.
For information on setting emergency number, see Setting PBX location and
contact information on page 107.

Caller ID Match Enter a caller’s display name string or the caller’s phone number string as the
pattern following Pattern-matching syntax on page 227 and Pattern-matching
examples on page 227.
Callers with IDs under this pattern are subject to this plan.

Dialed Number Match With dialed number pattern matching, you can create one phone number
pattern in your dial plan that matches many different numbers.
The dialed numbers matching this pattern will follow this dial plan rule.
For information on adding a dialed number match, see Creating dialed number
match on page 227.

Call Handling Click New to configure the call handling action for the numbers matching the
configured number pattern and the caller IDs matching the caller ID pattern.
For details, see Configuring call handling actions on page 228.

4. Click Create.

Testing outbound dial plans

After you create a dial plan, you can select the dial plan and click Test to see if the dial plan works.

For more information, see Test on page 225.

To test an outbound dial plan

1. Go to Call Routing > Outbound > Outbound.
2. Select the dial plan that you want to test and click Test.
3. Select Test Call-Dry Run or Test Call.
4. The call test page appears.
5. Configure the following:

GUI field Description

Test Call - Dry Run Run a system outbound dial plan test without making a real phone call.

Destination
number

Enter a destination number to call.

From number Enter the number from which you want to call the destination number. The FortiVoice
system will connect this number with the destination number for the test.

Test Click to start the dry run test and view the Test result.

Reset Click to remove the test result in order to start a new test.

Test Call Test the outbound dial plan by making a real phone call.
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GUI field Description

Destination
number

Enter a destination number to call.

After call is
established

Select the FortiVoice action once it calls the destination number:
l Play welcome message: The FortiVoice system will play a message to the destination
number.

l Connect test call to number: In the Number field, enter the number from which you
want to call the destination number. The FortiVoice system will connect this number
with the destination number to test the trunk.

Test Click to start the test and view the Test result.

Reset Click to remove the test result in order to start a new test.

Creating dialed number match

You can create one extension number pattern in your dial plan that matches many different numbers for outbound calls.

The numbers matching this pattern will follow this dial plan rule.

The FortiVoice system supports the following pattern-matching syntax:

Pattern-matching syntax

Syntax Description

X Matches any single digit from 0 to 9.

Z Matches any single digit from 1 to 9.

N Matches any single digit from 2 to 9.

[ ]
(square bracket)

Matches any digits in the square brackets.
For a range of numbers, use a dash.
Example: [15-7].
In this example, the pattern matches 1, 5, 6, and 7.

.
(period)

Acts as a wildcard that matches any digit and allows for any number of digits to be dialed.
Example of a pattern matching rule: XX.
In this example, the system looks for a dialed number match that has three or more digits.

!
(exclamation point)

Acts as a wildcard that matches any digit (including no digits) and allows for any number of
digits to be dialed.
Example of a pattern matching rule: XX!
In this example, the system looks for a dialed number match that has two or more digits.

Pattern-matching examples

Pattern Description

X. Matches any dialed number.

NXXXXXX Matches any seven-digit number, as long as the first digit is 2 or higher.

FortiVoice Phone System 6.0.12 Administration Guide 227
Fortinet Inc.



Configuring call routing

Pattern Description

NXXNXXXXXX Matches any dialed number that has 10 digits.

1NXXNXXXXXX Matches any dialed number that matches this pattern: 1 + area code (between 200 and 999) +
seven-digit number (first digit is 2 or higher).

011. Matches any number that starts with 011 and has at least one more digit.

XX! Matches any two or more digits.

To create a dialed number match

1. Go to Call Routing > Outbound > Outbound.
2. Click New.
3. In Dialed Number Match, click New.
4. Configure the following:

GUI field Description

Match Pattern Enter the number pattern following Pattern-matching syntax on page 227 and Pattern-
matching examples on page 227 for this dial plan. Click the + icon to add more patterns.

Modification You can manipulate the number patterns you entered.

Strip Enter a number to omit dialing the starting part of a pattern. 0 means no action.
For example, if yourMatch Pattern is 9XXX and Strip is 1, you need to dial the full digit
9XXX, but the first digit, in this case 9, will be stripped by the system.

Prefix Add a number before a pattern, such as area code.
For example, if yourMatch Pattern is 123XXXX and its area code is 555, you can enter
555 for the Prefix. When you dial a number under this pattern, you do not need to dial the
area code 555.

Postfix Add a number after a pattern. The following characters are also acceptable:
l comma (,)
l semicolon (;)
l number sign (#)

For example, if yourMatch Pattern is 9XXX and the numbers under this pattern have been
upgraded to have an additional digit 5 at the end, you can enter 5 for the Postfix. When you
dial a number under this pattern, you do not need to dial the last digit 5.

5. Click Create.

Configuring call handling actions

Configure the call handling action for the numbers matching the configured number pattern and the caller IDs matching
the caller ID pattern.

To configure the call handling action
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1. Go to Call Routing > Outbound > Outbound.
2. Click New.
3. In Call Handling, click New.
4. Configure the following:

GUI field Description

Call Handling

Schedule Select the FortiVoice operation schedule to implement this plan. Click Edit to modify the
selected schedule or click New to configure a new one. For more information on PBX
schedule, see Scheduling the FortiVoice system on page 142.

Action Select the call handling action for the numbers matching the configured number pattern
and the caller IDs matching the caller ID pattern.

Outgoing trunk Select the trunk for the outbound calls. Click Edit to modify the selected trunk or click New
to configure a new one. For more information on trunks, see Configuring trunks on page
200.

Caller ID
modification

Select the caller ID modification configuration. Click Edit to modify the selected
configuration or click New to configure a new one. For more information on caller ID
modification, see Modifying caller IDs on page 124.

Warning
message

If you select Allow with warning or Deny with warning in the Action field, select the sound
file for the warning. Click Edit to modify the selected file or click New to configure a new
one. For more information on sound files, see Managing phone audio settings on page
117.

Delay Optionally, if you want to discourage certain users for making outbound calls, enter the call
delay time in seconds.

5. Click Create.

Viewing office peers for outbound calls

The Call Routing > Outbound > Office Peers submenu lets you view the office peer involved in the outbound call routing.
You may click an office peer link to configure it. For details, see Configuring office peers on page 213.
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This option is only available if you have purchased a call center license.

A call center allows an organization to receive or transmit a large volume of requests by telephone in a centralized office.

You can configure a call center and operate the center on the user portal.

This topic includes:

l Creating call queues and queue groups on page 230
l Configuring agents on page 238
l Configuring IVRs on page 238
l Configuring surveys on page 245
l Setting up monitor view on page 246
l Configuring other agent information on page 248
l Configuring agent profiles on page 249
l Working with call queue statistics on page 250
l Configuring report profiles and generating reports on page 302

Creating call queues and queue groups

Call queuing, or Automatic Call Distribution (ACD), enables the FortiVoice system to queue up multiple incoming calls
and aggregate them into a holding pattern. Each call is assigned a rank that determines the order for it to be delivered to
an available agent (typically, first in first out). The highest-ranked caller in the queue is delivered to an available agent
first, and every remaining caller moves up a rank.

With call queuing, callers do not need to dial back repeatedly trying to reach someone, and organizations are able to
temporarily deal with situations when callers outnumber agents.

This topic includes:

l Creating call queues on page 230
l Creating queue groups on page 237

Creating call queues

Configure a call queue and add it in an inbound dial plan as a call handling action to make it effective. For more
information, see Configuring inbound dial plans on page 220.

Call queues consist of:

l Incoming calls waiting in the queue
l Agents who answer the calls in the queues
l A plan for how to handle the queue and assign calls to agents
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l Music played while waiting in the queue
l Announcements for agents and callers

Depending on their privileges, agents can log into a queue to answer calls or transfer calls to another queue, which can
then be answered by another available agent.

Agents can be static or dynamic. Static agents are always connected to the queues, and dynamic agents need to log into
the queue in order to process calls.

To create a call queue

1. Go to Call Center > Call Queue > Call Queue.
2. Click New .
3. Configure the following:

GUI field  Description

Queue ID Enter an ID for the queue.

Number Enter an extension for callers to dial and enter into a call queue following the
extension number pattern. See Configuring PBX options on page 108.
This is another way to use a call queue configuration in addition to adding it in an
inbound dial plan as a call handling action.
In this case, the dial plan ignores this extension and still uses the extension to which
it is applied for call queue action.

Status Select to enable the call queue.

Display name Enter the queue name displaying on the queue extension, such as Support.

Description Enter any notes about this queue.

Department Select the department to which the queue belongs. For information on creating
departments, see Creating extension departments on page 189.

Queue Setting

Maximum queue
capacity

Enter the maximum number of callers for the call queue. When the call queue is full,
other callers will be dealt with according to theQueue Overflow call handling action
you set in Queue Overflow on page 236.
The maximum is 100.

Maximum queuing
time

Enter the maximum call queue waiting time in minutes, seconds, or both. When the
call waiting time is due, the callers in the queue will be dealt with according to the call
handling action you set in Queue Timeout on page 236.
The maximum is 720 minutes.

Ring duration Enter the time in seconds to ring each agent. If a call is not answered when the ring
duration is due, the call is transferred to the next agent. The range is between 5 to
120 seconds.

Music on hold Select a sound file or music on hold file to play when a caller is waiting. For more
information, see Managing phone audio settings on page 117.
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GUI field  Description

Call Distribution

Skill Based Routing Select and choose a call routing option. This option is based on agent skill level
scores. For more information, see Creating agent skill levels on page 248.
l Lowest level first: The call will ring the agent with the lowest skill level score first
and move up the rank if the agent is unable to take the call, that is, the agent’s
extension is in a Not Ready status.

l Highest level first: The call will ring the agent with the highest skill level score
first and move down the rank if the agent is unable to take the call, that is, the
agent’s extension is in a Not Ready status.

Default skill This option appears if you select a value other than Disabled in the Skill Based
Routing field.
Select the group, such as Billing, Sales, or Support, that the call distribution is
executed. You can add a new skill or modify an existing one. For more information,
see Adding agent skill sets on page 248.

Distribution policy Select a call Distribution policy.
This option works as following:
l If Skill Based Routing is not selected, calls are distributed according to the
policy you choose.

l If Skill Based Routing is selected, calls are distributed according to the skill
based call routing option you choose. This option only applies to the situation
when you have agents with the same skill level in a queue. In such cases, calls
are distributed to these agents according to the policy you choose.
l Ring all: rings all available agents (default).
l Round Robin: rings all agents in a queue equally in some rational order,
usually from the top to the bottom of a list and then starting again at the top
of the list and so on.

l Sequential: rings each agent in a sequential manner regardless of whether
they have answered calls.

l Random: rings an agent at random.
l Least Recent: rings the agent that least recently received a call.
l Fewest Calls: rings the agent that has completed the fewest calls in this
queue.

l Weight Random: rings a random agent, but uses the agent’s number of
received calls as a weight.

l Priority Based: rings agents based on call answering priorities for callers
entering the call queue. A new call always starts with the lowest priority.
However, a queue manager with privileges can change the priority of a call
on the agent console of the user portal. See Setting caller priorities on
page 249.

Additional Setting

Distinctive Setting for
Agent

Announce queue name: Select a sound file that announces the queue name. You
can add a new one or modify an existing one. For more information, see Managing
phone audio settings on page 117.
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GUI field  Description

Caller ID option: Select how you want the IDs of the calls to this queue to display. If
you select Prefix, the queue Display name on page 231 is added before the caller ID
on the agent’s phone. If you select Replace, the queue Display name on page 231
replaces the caller ID on the agent’s phone.
Ring Pattern: Select a queue extension ring pattern.

Business Schedule In Available field, select an operation schedule for the queue and click -> to move it
to the Selected field. For example, “business_hour” schedule means agents are only
available to answer the calls for this queue during business hours. For information
on scheduling, see Scheduling the FortiVoice system on page 142.

Announcement to
Caller

l Announce holdtime: Select if you want to announce the queue waiting time to a
caller at the set interval. You may also select to announce only once.

l Announce position: Select to announce a caller’s waiting position in the queue,
such as “You are caller No. 5 in the call queue”.
l No: Do not announce a caller’s position.
l Always: Always announce a caller’s position.
l Abbreviated: Announce a caller’s position only once if the caller is over the
marked position and always announce once before the caller reaches the
marked position.

l Minimal: Announce only when the caller is within the marked position.
l Mark position: Enter the benchmark for selecting Abbreviated orMinimal setting
under Announce position.
For example, if you select Abbreviated and enter 5, a caller’s position is
announced when the caller becomes No. 5 in the queue and announced only
once before the caller becomes No. 5 in the queue.

l Announcement interval: Enter the announcement frequency in seconds.
l Custom announcement: You can also customize the announcement settings. If
you select Periodic or Random, enter the announcement frequency in seconds
in Announcement interval. Also, select a greeting sound file for the
announcement. For more information, see Managing phone audio settings on
page 117.

l Queue Entry Announcement: Select Enable to announce to callers when they
enter a call queue. You can also select to disable this function. Also, select a
greeting sound file for the announcement. For more information, see Managing
phone audio settings on page 117.

Service Level l Interval: Enter the time period in minutes for calculating the threshold up to a
maximum of 10080 (or one week).

l Threshold: Enter the call answering rate for a certain period of time. The action
triggered by the threshold being reached is configured in Call Handling on page
236.

l Service level low threshold is used in call handling: Click Service level low call
handling to configure how other callers will be dealt with according to theQueue
Overflow call handling action you set in Service Level Low on page 236 when
the call queue is full.

Alert
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GUI field  Description

Events Select the event that triggers an action which is configured in Call Handling on page
236.

Setting l Send alert email: Select if you want to send an email when an alert event is
triggered. Click New to enter an email address.

l Call extension/number: Select this option and an extension number if you want
a phone call when an alert event is triggered. Click New to add an extension.

l GUI popup: Select to have a popup notification on the user portal GUI when an
alert event is triggered. This only applies to agents with the particular privilege
calledQueue alert. See Agent Console Privilege in Configuring agent profiles
on page 249.

l Alert interval: Enter a value in minutes during which time no alert is sent. For
example, if you enter 60, you will not receive any alerts for an hour even if an
alert event is triggered. This will be the case each time when you receive an
alert notification.
If you enter 0, you will receive notifications each time when an event is
triggered.

Callback Setting This option allows callers waiting in a queue to request a callback following the
recorded instructions and wait for an agent to return their call.

Prompt Select a audio file to provide callers with callback information.
If no file is selected, the default file is applied.
You can also add a new audio file or edit an existing one. For more information, see
Managing phone audio settings on page 117.

Interval After selecting a audio file, set the time interval for playing the audio file.

Status Select to enable this option.

Callback mode l Agent Call Back Manually (From Call Center Console): Select to allow an agent
to manually call the caller using the agent console on the user portal.

l Call Back When Agents Available: Select to allow the FortiVoice system to call
the caller automatically based on the callback number collected when an agent
is available.

l Virtual Placeholder: Select to allow the FortiVoice system to call a caller back
when he/she is within the next 3 calls in the queue. This happens when a caller
does not wish to wait and leaves his/her number following the prompt. If the
caller calls back before the FortiVoice callback occurs, the call will be treated as
a new call in the queue which may result in a longer waiting time.

Prompt voice
menu

Select the method to collect the callback number.
l System Default: Select to use system defined voice file.
l User Defined IVR: Select to use user configured IVR.

For more information on IVR, see Configuring IVRs on page 238.

Prompt to caller
after callback
call established

Select to ring the caller when a callback call is set up.
Select a greeting sound file for the announcement. For more information, see
Managing phone audio settings on page 117.
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GUI field  Description

Survey settings Surveys are used to collect customer feedback to ensure that the service delivered
by your call center agents consistently meets corporate standards and drives high
customer satisfaction.

Status Select to enable this option.

Survey Choose the survey configuration for the call queue. For more information on
surveys, see Configuring surveys on page 245.

Agent

Agent type Select the agent login mode.
Once enrolled into the queue, static agents are always connected to the queues
while dynamic agents need to log into the queue in order to process calls.

Auto-logout time If you select Dynamic login mode, enter the agent login expiry time in hours. For
example, if you enter 5, the agent will be logged out 5 hours after having logged into
the queue.

Logout all agents
after scheduled
business hour

If you select Dynamic login mode, select to log out all agents in the queue when the
scheduled business hour is due.

Wrap up time Enter the time (in seconds) needed by agents to complete a queue call including
taking notes or record-keeping, starting from the moment that call is hang up.
The default is 0 second.

Wrap up outgoing call Select if the agent needs to make an outgoing customer call and time to take notes
or record-keeping, starting from the moment that call is hang up.
You can enter the wrap up time in the Wrap up time on page 235 field.

Call waiting Select this option so that if an agent is on the phone when a queue call comes in, the
caller information will display on the agent’s phone. The agent can choose to answer
the call or not. If the agent does not answer the call, after the ring duration is due, the
call is transferred to the next agent.
This option is different from the call waiting feature of a regular extension (See
Setting extension user preferences on page 181). On a regular extension, the call
waiting feature only applies to the calls that directly go to the extension. On a queue
extension, the call waiting feature only applies to the calls that go to the extension
from the queue.

Agent Members l Click to expand Agent members for enrolling agents into the queue.
l Click + to select the agents for this queue.
l Click Close.
l CloseOK.

You can type an agent’s extension or name in the Search field and press Enter to
search for the agent.
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GUI field  Description

Call Handling

When no logged-in
agent

You may select to queue a caller or not if there is no agents available.
If you select Do not queue, an incoming call will be handled by your general call
handling configuration, such as auto attendant.

Scheduled Business
Hour Call Handling

This option is only available when you edit a call queue.
For details, see Configuring scheduled business hour queue call handling actions on
page 236.

Non Scheduled
Business Hour Call
Handling

This option is only available when you edit a call queue.
For details, see Configuring scheduled business hour queue call handling actions on
page 236.

4. Click Create.

Configuring scheduled business hour queue call handling actions

Configure the call handling action for the queue. This action applies to all calls once they enter into the queue.

This option is only available when you edit a queue.

To configure the call handling action

1. Go to Call Center > Call Queue > Call Queue.
2. Select a call queue for which you want to configure queue call handling actions and click Edit.
3. In Call Handling, click Scheduled Business Hour Call Handling.
4. Configure the situation upon which corresponding call process can be configured:

GUI field Description

Queue Overflow The situation when callers exceed the maximum waiting callers you set. See
Maximum queue capacity on page 231.
A popup notification appears when this barometer is triggered.

Queue Timeout Callers waiting time exceeds the maximum waiting time set in Maximum
queuing time on page 231.
A popup notification appears when this barometer is triggered.

Service Level Low Service level represents the maximum amount of time a caller should ideally
have to wait before being presented to an agent. You need to set the service-
level-calculation-option, service-level-interval, and service-level-threshold in
the FortiVoice CLI under config service call-queue.
For example, if service level interval is set to 60 seconds and the service level
percentage is 80 percent, that means 80 percent of the calls that came into the
queue were presented to an agent in less than 60 seconds. Any service level
percentage lower than 80 is considered to be low.
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GUI field Description

All Agents Logout There are no agents in the queue to answer calls. The action for this option
only works if you selectQueue caller for When no logged-in agent on page
236.

All Agents Paused There are no agents in the queue to answer calls. The action for this option
only works if you selectQueue caller for When no logged-in agent on page
236.

Unclassified Any reason that you need to schedule call handlings.

5. For each situation, click New to configure its call handling action.
l Select the FortiVoice operation schedule to implement this call handling action. For more information on
schedules, see Scheduling the FortiVoice system on page 142.

l Select the call handling action. Depending on the action selected, further configuration may be needed. For
example, if you select Dial extension for Action, enter the extension to which a call is transferred.

6. Click Create, thenOK.

Configuring non scheduled business hour queue call handling actions

Configure the call handling action for the queue. This action applies to all calls once they enter into the queue.

For some processes that may require further actions, you need to add one or more call processes to complete the call
handling. For example, after adding a process that contains a Set call queue priority action, you can add another process
with a Transfer to queue action to complete the call handling. In this case, the call will be processed again with new
priority after it is transferred to the queue.

This option is only available when you edit a queue.

To configure the call handling action

1. Go to Call Center > Call Queue > Call Queue.
2. Select a call queue for which you want to configure queue call handling actions and click Edit.
3. In Call Handling, click Non Scheduled Business Hour Call Handling.
4. On the Call Processing page, click New to configure call handling action.
5. For Schedule, select the FortiVoice operation schedule to implement this call handling action. For more information

on schedules, see Scheduling the FortiVoice system on page 142.
6. For Action, select the call handling action. Depending on the action selected, further configuration may be needed.

For example, if you select Dial extension for Action, enter the extension to which a call is transferred.
7. Click Create, thenOK.

Creating queue groups

You can group queues together to facilitate queue management.

To create a call queue group

1. Go to Call Center > Call Queue > Queue Group.
2. Click New.
3. Enter a name for the group.
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4. ForMember, click the + sign and select the available call queues that you want to include in the group.
5. Click Close, then Create.

Configuring agents

Extensions with call center agent function enabled can be further configured with other call center information, such as
agent profile, managed departments, and skill sets. Call center user groups can also be set up as a base for department
and group management.

To configure an agent

1. Go to Call Center > Agent > Agent.
All extensions with call center agent function enabled display. Clicking Extensions opens the IP extensions
configuration page. For information, see Configuring IP extensions on page 162.

2. Select the extension you want to configure and click Edit.
3. Select an agent profile. For more information, see Configuring agent profiles on page 249.
4. ForManaged departments, click the + sign and select the departments to be managed by this agent if required.
5. ClickMember of Queues to select the call queues to join.

l Queues: Select the queues of which you want the extension/agent to be a member, and click Close.
l Main/Outgoing queue: This option is for collecting the outgoing calls from all queues by this agent and
displaying them in call queue statistics (See Working with call queue statistics on page 250). You can select
any queue of which this agent is a member for that purpose except None which will not collect agent’s outgoing
call information. ClickOK.

6. Add skill sets for the agent by clicking New under Skill Sets.
7. Select the skill set for the agent, including skills and level, and click Create. For more information about agent skills

and levels, see Adding agent skill sets on page 248 and Creating agent skill levels on page 248.
8. ClickOK.

To set up an agent group

1. Go to Call Center > Agent > Group.
2. Click New.
3. Enter a name for the group.
4. Optionally, select a department from which you want to configure an agent group. For information on extension

department, see Creating extension departments on page 189.
5. ForMembers, click the + sign and select the available users or user groups that you want to include in the group.
6. Click Close.
7. Click Create.

Configuring IVRs

FortiVoice Interactive Voice Response (IVR) function allows it to interact with callers through the use of voice and DTMF
tones input via keypad. Callers proceed according to the IVR audio instructions to reach the callees or get the
information they need.
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Based on the information collected from callers and by interacting with the backend database, FortiVoice IVR can
prioritize the calls using call queues and present callers’ information to the agents.

FortiVoice IVR interfaces with RESTful Web service for querying caller information from the database.

For more information, see IVR Technical Note.

This topic includes:

l Setting up an IVR on page 239
l Configuring RESTful service on page 244

Setting up an IVR

Call Center > IVR > IVR allows you to view the existing IVR list and create new IVRs.

Creating new IVRs includes configuring:

l SIP header collector to share IVR information among multiple FortiVoice systems based on information gathered by
digit and RESTful collectors (see To configure a SIP header collector on page 239)

l the digits collector to collect digit inputs from callers (see To configure a digit collector on page 240)
l the RESTful collector to gather caller information from database (see To configure a RESTful collector on page 241)
l call handling to route the calls based on information gathered by digit and RESTful collectors, and
l error handling to deal with unknown errors and RESTful service errors.

To view the IVR list

1. Go to Call Center > IVR > IVR.
2. Click the Expand all/Collapse all.

The IVR tree list displays. Under each IVR name, configuration items are listed. Clicking an item opens its
configuration page.

To configure a SIP header collector

1. Go to Call Center > IVR > IVR and click the Switch (two opposite arrows) icon.
2. Click New and type the name of the IVR and description.
3. Click Create.
4. From the IVR name list, select the name you created and click Edit to open the IVR configuration page.
5. For Description, select Edit to enter any notes you have for the IVR.
6. Click Add SIP Header Collector.

GUI field Description

Name Enter a name for the SIP header collector.

Description Enter any notes you have for the SIP header collector.

Variable Click New and do the following:
1. For Variable, enter a value for a SIP header field based on your

organization’s SIP header definitions, for example, ticket_id. This value
must be the same on every FortiVoice system that shares IVR
information.

2. For Action on returned data, do the following:
l None: Select if you do not want to share the information that the SIP
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GUI field Description

header collector gathers with other interfaces.
l Add to agent console - Display name: Select if you want agents in the
queues where the IVR calls are routed to see the information that the
SIP header collector gathers. Enter a name for the information to
display on the agent console.

l Add to SIP header - Field name: Select if you want to share the
information that the SIP header collector gathers with other SIP
header collectors. Enter a value that matches the value on the SIP
header to enable information sharing.

l Add to Remote CDR - Field name: Select if you want to share the
information that the SIP header collector gathers with a remote CDR
database. Enter a value that matches the value on the remote CDR to
enable information sharing.

l Add to Report - Field name: Select if you want to share the
information that the SIP header collector gathers with survey reports.
Enter a value that matches the value on the surveys to enable
information sharing. For information on surveys, see Configuring
surveys on page 245.

3. Click Create.

7. Click Create.
You can create a maximum of 10 SIP header collectors which are saved as variables.

To configure a digit collector

1. After configuring the SIP header collector, click Add Digits Collector to configure digit inputs collection from callers.
You can create a maximum of 10 digit collectors.

GUI field Description

Name Enter a name for the digit collector.

Prompt Select the audio file that you want callers to listen to. You can also
create a new file or edit the selected one. For more information,
see Managing phone audio settings on page 117.

Enable read back Select if you want the digit inputs to be read out to the caller.

Action on returned data l None: Select if you do not want to share the information that
the digit collector gathers with other interfaces.

l Add to agent console - Display name: Select if you want
agents in the queues where the IVR calls are routed to see the
information that the digit collector gathers. Enter a name for
the information to display on the agent console.

l Add to SIP header - Field name: Select if you want to share
the information that the digit collector gathers with other SIP
header collectors. Enter a value that matches the value on the
SIP header to enable information sharing.

l Add to remote CDR - Field name: Select if you want to share
the information that the digit collector gathers with a remote
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GUI field Description

CDR database. Enter a value that matches the value on the
remote CDR to enable information sharing.

l Add to report - Field name: Select if you want to share the
information that the digit collector gathers with survey reports.
Enter a value that matches the value on the surveys to enable
information sharing. For information on surveys, see
Configuring surveys on page 245.

Description Enter any notes you have for the digit collector.

Digits Setting

Min digits Enter the minimum digits the digits collector allows. The range is 1-
30.

Max digits Enter the maximum digits the digits collector allows. The range is
1-30.

Max invalid input
allowed

Enter the number of times a caller is allowed for inputting wrong
digits. The call will be terminated if the limit is reached. The range is
0-10.

Timeout Enter the time limit that a caller is allowed for taking NO action after
the call is put through. The call will be terminated if the time limit is
reached. The range is 0-600 seconds.

Max timeout allowed Enter the number of timeouts a caller is allowed for taking no action
after the call is put through. The call will be terminated if the
number of timeouts limit is reached. The range is 0-10.
For example, if Timeout is set to 10 seconds andMax timeout
allowed to 3, a caller would have a total of 30 seconds timeout time
after he or she dials in and takes no action afterwards.

2. Click Create.
You can create a maximum of 10 digit collectors which are saved as variables.

To configure a RESTful collector

1. After configuring the digit collector, click Add RESTful Collector to configure the database collector for resource
querying.

GUI field Description

Name Enter a name for the RESTful collector.

Service Select the RESTful service for the collector. You can also create a
new service or edit the selected one. For more information, see
Configuring RESTful service on page 244.

Method Choose the method to submit the information collected by the
FortiVoice IVR system to the database server (as HTTP POST or
HTTP GET) and use the value as a variable in your SQL statement.
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GUI field Description

Parameters Select Edit to enter query parameters to customize the results
returned from a GET or POST operation on the database, such as
sorting or filtering.
Optionally, click Add Variable to insert self or system defined
variables into the parameters.

URL Once you select Service on page 241, its URL displays here.

HTTP Headers Select Edit to enter a HTTP header for information querying on the
RESTful web service.
Optionally, click Add Variable to insert self or system defined
variables into the HTTP header.
This option is only available if you selectGet forMethod.

Posting HTTP Headers Select Edit to enter a HTTP header for information querying on the
RESTful web service.
Optionally, click Add Variable to insert self or system defined
variables into the HTTP header.
This option is only available if you select Post forMethod.

Posting Message Body Select Edit to enter a HTTP message body for information querying
on the RESTful web service.
Optionally, click Add Variable to insert self or system defined
variables into the HTTP body.
This option is only available if you select Post forMethod.

Timeout Enter the time allowed for the query to be processed. If the time
elapses before the query response is complete, partial information
may be returned. The range is 0-600 seconds.

Max retry allowed Enter the number of database query tries allowed. The query will
be denied if the retry limit is reached. The range is 0-10.

Description Enter any notes you have for the RESTful collector.

New (under Fields) Click to name each of the attributes returned from a database
query to present it or use it as a variable.

Field Enter a name for the attribute you want to define.

Query Enter the query parameter for the attribute you want to define.
Optionally, click Add Variable to insert self or system defined
variables into the parameter.

Action on returned
data

l None: Select if you do not want to share the information that
the RESTful collector gathers with other interfaces.

l Add to agent console - Display name: Select if you want
agents in the queues where the IVR calls are routed to see the
information that the RESTful collector gathers. Enter a name
for the information to display on the agent console.

l Add to SIP header - Field name: Select if you want to share
the information that the RESTful collector gathers with other
SIP header collectors. Enter a value that matches the value on
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GUI field Description

the SIP header to enable information sharing.
l Add to remote CDR - Field name: Select if you want to share
the information that the RESTful collector gathers with a
remote CDR database. Enter a value that matches the value
on the remote CDR to enable information sharing.

l Add to report - Field name: Select if you want to share the
information that the RESTful collector gathers with survey
reports. Enter a value that matches the value on the surveys to
enable information sharing. For information on surveys, see
Configuring surveys on page 245.

2. Click Create, then Create.
You can create a maximum of 10 RESTful collectors which are saved as variables.

To configure IVR handling

1. After configuring the RESTful collectors, click Add IVR handling to configure call processing using the digit and
RESTful collector configurations.
SIP header, digit and RESTful collector configurations only take effect after IVR handling is set up.

GUI field Description

Condition Configure the conditions based on which call processing actions
are taken.

Unconditional Select if you do not need to configure the conditions. In this case,
the system default condition applies.

Variable Click Add to insert self or system defined digit or RESTful variable
for the condition.
This option appears if you deselect Unconditional.

Operator Use query operators to assign a value to the variable, or perform
mathematical operations.
This option appears if you deselect Unconditional.

Value Enter the value assigned by the operator to the variable.
Optionally, click Add Variable to insert self or system defined
variables into the value.
This option appears if you deselect Unconditional.

Description Enter any notes you have for the IVR handling.

Action Click New to configure the actions to take based on the conditions.

Action type Select the IVR action. Depending on the action type selected,
further configuration may be needed. For example, if you select
Dial extension, enter the extension to which a call is transferred.
Click Create.
You can create multiple actions.

FortiVoice Phone System 6.0.12 Administration Guide 243
Fortinet Inc.



Setting up a call center

GUI field Description

Some action types have an option for you to add a variable for
further configuration, such as Dial Extension or Call Queue.
Instead of manually adding a value, you may choose a predefined
variable which contains the further configuration information of the
action type you choose.

2. Click Create.

To configure error handling

1. After configuring IVR handling, click Add IVR Exception Handling to deal with unknown errors and RESTful service
errors.

2. For Error type, select Unspecified for unknown errors and RESTful for RESTful service errors.
3. Click New to select the action. Depending on the action type selected, further configuration may be needed. For

example, if you select Dial extension, enter the extension to which a call is transferred.
Some action types have an option for you to add a variable for further configuration, such as Dial Extension or Call
Queue. Instead of manually adding a value, you may choose a predefined variable which contains the further
configuration information of the action type you choose.

4. Click Create, then Create.
5. ClickOK to complete the IVR configuration.

Configuring RESTful service

FortiVoice IVR interfaces with RESTful web service for querying caller information from the database. When RESTful
service is set up and a caller dials in, the FortiVoice system sends caller information inquiry to the RESTful web service
which sends back the information to the agent who processes the call.

Call Center > IVR > RESTful service allows you to configure the RESTful web service.

To configure RESTful service

1. Go to Call Center > IVR > RESTful Service, click New and do the following:

GUI field Description

Name Enter a name for the configuration.

Protocol Select the protocol for the service.

Authentication Password: Select to enter the user name and password for logging onto the
RESTful server.
OAuth: Select to use Open Authorization to access the RESTful server without
exposing your account credential.
l Service format: Select Salesforce or other RESTful services configuration
format.

l Username: Enter the login user name registered on the RESTful server.
l Password: Enter the login password registered on the RESTful server.
l Login server: Enter the IP address of the RESTful server.
l Client ID: Enter the consumer key from the RESTful server.
l Client secret: Enter the consumer secret from the RESTful server. If you
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GUI field Description

choose Salesforce as Service Format, enter the consumer key and the
token from the server in the format of <consumer key><token>.

l Base URL suffix: Enter the Salesforce object name, for example, /query/,
and clickGet Salesforce API URI to populate the Base URL field. Note the
leading and trailing "/" must be entered before and after the object name.
This option is only available if you choose Salesforce for Service format.

Base URL Enter the URL of the server hosting RESTful service.
Click Test to validate the URL.

SSL verification Select if required.

Description Click Edit to enter any notes for the configuration.

2. Click Create.

Configuring surveys

You can use surveys to collect customer feedback on the service delivered by your call center agents. You can also set
survey rules.

To configure a survey

1. Go to Call Center > Survey > Survey.
2. Click New and type the name of the survey.
3. For Description, enter any comments you have for the survey.
4. Click New underQuestionnaire and configure the following:

GUI field Description

Name Enter a name for the digits collector.

Prompt Select the audio file that you want callers to listen to. You can also
create a new file or edit the selected one. For more information,
see Managing phone audio settings on page 117.

Enable read back Select if you want the digit inputs to be read out to the caller.

Question Enter the survey question.

Digits Setting

Max digits Enter the maximum digits the digits collector allows. The range is
1-30.

Max invalid input
allowed

Enter the number of times a caller is allowed for inputting wrong
digits. The call will be terminated if the limit is reached. The range is
0-10.
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GUI field Description

Timeout Enter the time limit that a caller is allowed for taking NO action after
the call is put through. The call will be terminated if the time limit is
reached. The range is 0-600 seconds.

Max timeout allowed Enter the number of timeouts a caller is allowed for taking no action
after the call is put through. The call will be terminated if the
number of timeouts limit is reached. The range is 0-10.
For example, if Timeout is set to 10 seconds andMax timeout
allowed to 3, a caller would have a total of 30 seconds timeout time
after he or she dials in and takes no action afterwards.

5. Click Create.
The survey is listed underQuestionnaire. You may click New to add more.

6. If you want callers to comment on the survey, select Caller Comment.
7. For Audio prompt, select the audio file that explains to callers how to comment on the survey. Click New to create a

new audio file. For more information, see Managing phone audio settings on page 117.
8. Click Create.

To configure survey settings

1. Go to Call Center > Survey > Setting.
2. For Survey retention month, enter the number of months that you want to keep the surveys.
3. ForMax survey records, enter the maximum number of surveys you want to keep.
4. Click Apply.

Setting up monitor view

You can create a monitor to let agents with privileges to view the snapshot of the key information of queues on the user
portal, such as number of calls in queue, longest waiting calls, and abandoned calls. You can also create monitor view
color themes in addition to the default one.

To apply the queue view configuration, you need to enable it in agent profile and apply the profile to an agent. As a result,
the agent will have aMonitor View icon once logging into the user portal.

To set up a monitor view

1. Go to Call Center > Monitor View > Monitor.
2. Click New and configure the following:

GUI field Description

Name Enter a name for the queue view.

Trusted hosts Enter the IP address and netmask of the device that is permitted to
use the monitor view.
If you have multiple devices, you may enter up to 10 trusted hosts.

Monitor Items Click New to include the queues or agents that you want to monitor.
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GUI field Description

Title Enter a name for the configuration.

Type Choose to monitor queues or agents.

Refresh interval Enter the refresh interval time for the monitor view in seconds.

Color theme Select the color theme for the monitor view. See To create a
monitor view theme on page 247.

Start time Enter the time for the monitor view to start.

Queue Click + to select the queues to be included.
Click Close, then Create.

Logo Select Customized logo to add text or logo for agents with
privileges to view on the user portal.
In the text editor window, you can type the text or copy and paste a
logo here.

3. Click Create.

To create a monitor view theme

1. Go to Call Center > Monitor View > Monitor Theme.
2. Click New and configure the following:

GUI field Description

Theme name Enter a name for the theme.

Background color
Column header color
Row header color
Row color
Text color

Click each field to select the color for the
monitor view background, column header, row
header, row, and text.

Agent Threshold Setting Click New to set the colors for agent names
display in monitor view based on status.

Status Choose an agent status for which you want to
set a color.

Threshold value Enter the refresh interval time for displaying the
agent names in seconds.

Threshold color Select the color theme for displaying the agent
names at the time interval you set.

3. Click Create, then Create.
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Configuring other agent information

Configure call agent skill sets, skill levels, reason codes, data service, and global settings to be used for configuring
agent profiles.

Adding agent skill sets

Depending on the agents skills and the nature of your business, you can classify agents into different groups, such as
Billing, Sales, or Support.

To add an agent skill set

1. Go to Call Center > Configuration > Skill Set.
2. Click New.
3. Enter a name, such as HR, and description for the skill set.
4. Click Create.

Creating agent skill levels

The FortiVoice system comes with 9 default skill levels, ranging from 10 to 90, with 10 to 30 being junior, 40 to 60 being
intermediate, and 70 to 90 being senior. You can modify the default skill level descriptions, or create new skill levels.

To create an agent skill level

1. Go to Call Center > Configuration > Skill Level.
2. Click New.
3. Enter the skill level and description.
4. Click Create.

Modifying agent reason code descriptions

Agent reason codes explain why agents are not able to take calls, such as due to lunch break, meeting, or vacation. You
can add new codes and change code descriptions of the default reason codes.

To add an agent reason code

1. Go to Call Center > Configuration > Reason Code.
2. Click New.
3. Enter a Name.
4. Enter a Code number. The code can be from 1 to 5 digits.
5. Enter a Description.
6. Click Create.
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Configuring data service

If you use a third party software to generate call center reports or statistics, you can configure the FortiVoice system to
back up the data.

To configure data service

1. Go to Call Center > Configuration > Data Service.
2. Select Enabled to activate the service.
3. Configure the schedule time.
4. Enable Local if you want to back up locally.
5. Enable Remote and configure the FTP/SFTP server credentials if you want to back up remotely.
6. Enter the email address for sending the call center reports or statistics.
7. Configure the maximum backup number. When the maximum number is reached, the oldest version will be

overwritten.
8. Click Field description to view the FortiVoice data value number and description.
9. Click Apply.

Setting caller priorities

You can set call answering priorities for callers entering the call queue. A new call always starts with the lowest priority.
However, a queue manager with privileges can change the priority of a call on the agent console of the user portal.

To set caller priorities

1. Go to Call Center > Configuration > Global Setting.
2. Enter the caller’s highest and lowest priorities.
3. Click Apply.

Configuring agent profiles

Create agent profiles to define agent privileges for processing calls. Agent profiles become effective when they are
applied to the agent extensions. For more information on extensions, see Setting up local extensions on page 162.

To create an agent profile

1. Go to Call Center > Profile > Profile.
2. Click New.
3. Configure the following:

GUI field Description

Name Enter a name for the profile.

Agent Select the calls an agent can make or process.

Pickup call from
queue

Select to allow the agent to answer queue calls.

Ring no answer Select the action to take when nobody answer a call in the queue.
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GUI field Description
l Do nothing: No action is taken and the call keeps ringing.
l Auto pause: The call is paused automatically.
l Auto logout: The agent to whom this profile applies is
automatically logged out of the queue.

l Auto hold off: The call is automatically put on hold.

Hold off time If you select Auto hold off for Ring no answer, enter the time to put
a call on hold.

Queue Select to allow an agent to prioritize the calls in the queue or
transfer calls to another queue on the agent console of the user
portal.
If you select Caller prioritization, the Priority button appears on the
agent console of the user portal. If you select Transfer call to
another queue, the Transfer button appears on the agent console
of the user portal.
For Paused agent ring option, if you want to ring agents in pause
status, select Ring Targeted.

Agent Console Privilege Select Enable agent console to choose the widget and GUI popup
alert for an agent to view on the agent console of the user portal.

Manager Privilege If the agent is a manager, select the privileges to manage the
agents using the agent console of the user portal.
The privileges include coaching, listening, and logging in and
logging out agents, or pausing and resuming agents.

Monitoring Console Privilege Select to enable monitoring console on the user portal.

Monitoring Queue

Member of queues Select to enable the agent to only monitor the queues of which the
agent is a member.

Selected Select the queues the agent is allowed to monitor by moving the
selected queues from the Available field to the Selected field. The
Available field lists all queues regardless if the agent is a member
of them.

All Select to allow the agent to monitor all call queues.

4. Click Create.

Working with call queue statistics

Go to Call Center > Statistics to view agent and queue daily summaries. You can also download the summaries. The
summaries cover a period of 30 days.

To view agent daily summary

1. Go to Call Center > Statistics > Agent Daily Summary.
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GUI field Description

Date The date of the agent call summary.

Agent The agent ID.

Work Time The agent’s total work hours for the queue that the agent worked the longest.

Talk Time The total time the agent talked on the phone in all queues combined.

N/A Time The total time the agent was away from the phone in all queues combined.

Total Answered The total calls the agent answered in all queues combined.

Total RNA The total calls not answered by the agent in all queues combined.

Out. Call The outgoing calls made by the agent. This option is dependant on your queue
management configuration in Call Center on page 169.

Out. Talk Time The total time of outgoing calls made by the agent. This option is dependant on
your queue management configuration in Call Center on page 169.

Voicemail The number of voicemails left on the agent's extension.

To view queue daily summary

1. Go to Call Center > Statistics > Queue Daily Summary.

GUI field Description

Date The date of the call queue summary.

Queue The queue name.

Calls The number of calls reached this queue.

Abandoned The number of calls that gave up after reaching the queue.

Overflow The number of callers exceeding the maximum waiting callers set for the
queue and timed-out waiting callers.
See Maximum queue capacity on page 231.

Talk Time The total phone talk time of the queue.

Wait Time The total time for holding calls in the queue.

Out. Call The outgoing calls made by the agents in the queue. This option is dependant
on your queue management configuration in Call Center on page 169.

Out. Talk Time The total time of outgoing calls made by the agents in the queue. This option is
dependant on your queue management configuration in Call Center on page
169.
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Configuring call center report profiles and generating reports

The Call Center > Report > Report tab displays a list of report profiles.

A report profile is a group of settings that contains the report name, its subject matter, its schedule, and other aspects
that the FortiVoice system considers when generating reports from log data. The FortiVoice system presents the
information in tabular and graphical format.
You can create one report profile for each type of report that you will generate on demand or on a schedule.

Generating reports can be resource intensive. To avoid phone processing performance
impacts, you may want to generate reports during times with low traffic volume, such as at
night. For more information on scheduling the generation of reports, see Configuring the report
schedule on page 304.

To view and configure report profiles
1. Go to Call Center > Report > Report.

GUI field Description

Clone Select a report and click this button to duplicate a report with a new name.

Generate Select a report and click this button to generate a report immediately. See
Generating a report manually on page 305.

View Reports Click to display the list of reports generated by the FortiVoice system. You can
delete, view, and/or download generated reports. For more information, see
Viewing generated reports on page 36.

View Supported Query Click to display supported query summary.

Name Displays the name of the report profiles.

Department The department to which the report belongs.

Schedule Displays the frequency with which the FortiVoice system generates a
scheduled report. If the report is designed for manual generation, Not
Scheduled appears in this column.

2. Click New to add a profile or double-click a profile to modify it.
A multi-section dialog appears.

3. In Name, enter a name for the report profile.
Report names cannot include spaces.

4. In Department, select the department for this report.
For information on departments, see Creating extension departments on page 189.

5. Click the arrow next to each option, and configure the following as needed:
l Configuring the report query selection on page 253
l Configuring the report time period on page 253
l Configuring report email notifications on page 1
l Configuring the report schedule on page 1
l Generating a report manually on page 1
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6. Click Create.

Configuring the report query selection

When configuring a report profile, you can select the queries that define the subject matter of the report.
Each report profile corresponds to a chart that will appear in the generated report.

To configure the report query selection

1. Go to Call Center > Report > Report.
2. Click New.
3. ExpandQuery List and click New.
4. Configure the following:

GUI field Description

Name Enter a name for this query.

Category Select a category for the report profile. The report chart will correspond to the
category selected.

Sub category Select a sub query type for the report profile. The report chart will correspond
to the type selected.

Query Depending on your selection of Category and Sub category, choose the
specific report you want to generate. Depending on the report you choose,
select queues or agents for which you want to generate reports.

5. Click Create.

Configuring the report time period

When configuring a call center report profile, you can select the time span of log messages from which to generate the
report.

To configure the report time period
1. Go to Call Center > Report > Report.
2. Click New.
3. Expand Period to select the time span option you want. This sets the range of log data to include in the report.
4. For Type, choose a relative time, such as Today, Yesterday, Last N hours, and so on. If you select an option with an

unspecified “N” value, enter the number of hours, days or weeks in the Value field, as applicable.
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Businesses such as hotels use Property Management System (PMS) to manage their services. The PMS can be
connected to a PBX such as the FortiVoice system to configure a customer’s room phone by displaying the customer’s
name on the phone, emptying voicemails when a new customer checks in, logging phone calls, setting wake-up calls,
and other services. You can also set the room condition codes for roommaids to record the room cleaning status using
the room phone.

This option is only available if you have purchased the hotel management license and
uploaded that license to the FortiVoice phone system.

This topic includes:

l Configuring hotel management settings on page 254
l Configuring hotel room status on page 256

Configuring hotel management settings

Hotel Management > Setting lets you configure the settings for the FortiVoice system to interoperate with your PMS, set
the room condition codes, such as setting 1 to represent that maid is present and 4 to represent the out-of-service status,
and configure guest check in and check out actions.

Configure your PMS settings accordingly.

To configure hotel management settings

1. Go to Hotel Management > Setting > PMS.
2. Configure the following:

GUI field Description

Enabled Select to enable the PMS.

Protocol Select the protocol used by the FortiVoice system to communicate with the
PMS.

Serial connection This option is only available for theMicros protocol.
Select to connect to the PMS using a serial cable.

LRC This option is only available for theMicros protocol.
Select to perform longitudinal redundancy check (LRC).

Mode This option is only available forMicros and Comtrol protocols.
Choose to use the FortiVoice system as a server or client when connecting to
the PMS. If it is used as a client, enter the server IP address in the Server field.
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GUI field Description

Port Enter the port number that connects to the PMS.
You need to use an adapter for the FortiVoice-PMS connection. From the port
you configured, connect the PMS serial cable to the adapter and then connect
the RJ45 cable from the FortiVoice system to the adapter.

Call billing This option is only available forMicros and Comtrol protocols.
Select to activate call billing.

Enable link establishment This option is only available for theMicros protocol.
If your PMS device needs the link establishment to exchange data with the
FortiVoice phone system, select to activate this function.

Network Setting Enter the IP address and netmask of the PMS. If the PMS uses serial
connection to an adapter, enter the IP address and netmask of the adapter.
If you have multiple PMSes, you may enter multiple trusted hosts.

Data sync This option is only available forMicros and Comtrol protocols.
When the FortiVoice system is connected to the PMS, it constantly receives all
room-based information such as guest name, room privileges, and check in
and check out times from the PMS.
Normally, you do not need to click the Data sync button since the data
synchronization is automatic. You only do so when there is a data mismatch
between the FortiVoice system and the PMS.
Fortinet recommends performing a manual data sync at off hours because all
related operations, such as check in and check out, are suspended during a
data sync.

3. Click Apply.

To configure check in and check out actions

1. Go to Hotel Management > Setting > Option.
2. Configure the following:

GUI field Description

Check In Action

Reset Set the guest information and room condition to make a room
check-in ready.
l Privilege: Select to enable phone call restriction (internal,
local, or long distance) and user privilege (option 1, 2, 3) for
the room.
If you choose this option, select a Privilege for the room user.
For information on setting user privileges, see Configuring
user privileges on page 137

l Guest name: Select to display room number or guest name on
the room extension. In the Name field, enter %%NUMBER%% or
%%NAME%%.

l Room condition: Select to clear any condition set for the room.
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GUI field Description

Check Out Action

Reset Set the guest information and room condition to make a room
check-out ready.
l Privilege: Select to enable phone call restriction (internal,
local, or long distance) and user privilege (option 1, 2, 3) for
the room.
If you choose this option, select a Privilege for the room user.
For information on setting user privileges, see Configuring
user privileges on page 137

l Guest name: Select to display room number or guest name on
the room extension. In the Name field, enter %%NUMBER%% or
%%NAME%%.

l Room condition: Select to clear any condition set for the room.
l Voicemail: Select to clear all voicemails for the room
extension.

l Wake-up call: Select to clear all wakeup call setups for the
room extension.

Advanced Choose the order for roommaids to request for room item by
phone. You can choose to dial the item code or number first.
For example, if you choose to dial code first and want to request for
two beers (code 1) and three waters (code 2), you can dial 1*2*2*3.
For information on item code, see To set mini bar code for room
maids to order room items on page 256.

3. Click Apply.

To set mini bar code for room maids to order room items

1. Go to Hotel Management > Setting > Minibar Code.
2. Click New.
3. Enter the item name, for example, Beer.
4. Enter the item code, for example, 5.
5. Click Create.

A roommaid can dial the code to order things needed for the room using the room phone. For more information, see
Advanced on page 256.

Configuring hotel room status

Hotel Management > Room Status lets you set hotel room status.

Once the PMS and the FortiVoice system is properly connected and the PMS is enabled on the FortiVoice system, all
hotel room extensions appear on the FortiVoice system.

To batch-configure hotel room statuses
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1. Go to Hotel Management > Room Status and click Server Info.
A green dot means the FortiVoice system is connected with the PMS. Otherwise, a red dot appears.

2. Click Close.
3. Select more than one room in the list.

Depending on the situations of the rooms you select, the Check in, Check out, Privilege, Room condition, Room
setting, and VIP setting buttons become active.
A green dot underGuestmeans this guest room’s extension is bound with the room. Otherwise, a red dot appears.
For more information, see Guest phone on page 257.

4. Click a button to batch-configure the room status and apply it to all rooms selected.

To configure a single hotel room status

1. Go to Hotel Management > Room Status.
2. Select a room extension and click Edit.
3. Configure the following:

GUI field Description

Guest phone Select to bind the extension with the room and make the room a
guest room.

Number The extension number of the room. You can click the number and
modify it if required. For more information, see Configuring IP
extensions on page 162.

Room The hotel room number. You can click the number and modify it if
required.

Location Click to enter the room location.

Guest Setting This option appears only if you have enabledGuest phone.

Checked-in Enable the room status to checked-in.

VIP setting Select to set the guest as a VIP. Specific VIP treatments are
determined by each hotel.

Room condition Select the cleaning status of the room.
You can add a new code or edit the current one:
1. Click New to add a code or select an existing code and click

Edit to modify it.
2. Select the protocol for connecting to your PMS.
3. Enter a code number.
4. Enter the code description.
5. Click Create.

Guest name Enter the name of the guest for this room.
This option is available only if Checked-in is enabled.

Privilege Select phone call restriction (internal, local, or long distance) and
user privilege (option 1, 2, 3) for the room. For information on
setting user privileges, see Configuring user privileges on page
137.
This option is available only if the Checkin status is Checked-in.
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GUI field Description

DND Select if the guest of the room does not want to be disturbed.
This option is available only if Checked-in is enabled.

4. ClickOK.
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With the auto dialer function, the FortiVoice system can be configured to automatically dial telephone numbers. Once the
call is answered, the FortiVoice system plays a recorded message.

This topic includes:
l Setting up an auto dialer campaign on page 259
l Creating a recorded broadcast message on page 260
l Adding contacts and contact groups on page 260
l Configuring auto dialer settings on page 261
l Viewing auto dialer reports on page 261

Setting up an auto dialer campaign

Auto Dialer > Campaign > Campaign allows you to set up an auto dialer task to broadcast a recorded message to the
dialed phone numbers.

To set up an auto dialer campaign

1. Go to Auto Dialer > Campaign > Campaign.
2. Click New and configure the following:

GUI field Description

Name Enter a name for the campaign.

Caller ID Enter the caller ID to be displayed on a called phone. You can also select an
extension number instead.

Status The current status of the campaign.

Sound file Select a recorded message that you want to broadcast. You can also create a
new one. For more information, see Creating a recorded broadcast message
on page 260.

Retry Enter the number of times you want to retry calling.

Description Enter any notes you have for this campaign.

External Numbers Click + and select the external phone numbers you want to autodial. Click
Close.
You can add these numbers by going to Auto Dialer > Contact >
Contact/Contact Group. See Adding contacts and contact groups on page
260.

Internal Numbers Click + and select the internal phone numbers you want to autodial. Click
Close.
These numbers are the internal extensions on the FortiVoice system.

3. Click Create.
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4. If you want to start a campaign, in the campaign list, select one with a status other than Completed and click Start on
top of the screen.

5. Select a campaign start and end time.
6. ClickOK.

Creating a recorded broadcast message

Auto Dialer > Campaign > Audio allows you to create a sound file for the auto dialer to broadcast.

To create a sound file

1. Go to Auto Dialer > Campaign > Audio.
2. Click New.
3. Enter a name for the sound file.
4. Select an Action:

l Upload: Make sure that the sound file is a WAVE file (.wav) in PCM format and with a maximum size of 10 MB.
Click to upload a sound file.

l Record: Click to enter a phone number and click Send. When the phone rings, pick it up and record the
message.

l Play: After a file is uploaded or recorded, click to play it.
l Download: After a file is uploaded or recorded, click to download it.

5. Click Create.

Adding contacts and contact groups

Auto Dialer > Contact > Contact/Contact Group allows you to add contacts and contact groups that can be used in an
auto dialer campaign. You may also import or export the contacts.

To import multiple auto dialer contacts using a CSV file or vCard, make sure that your
administrator account (System > Administrator > Administrator) is using an admin profile
(System > Administrator > Admin Profile) with the Auto Dialer set to Read-Write. For more
information, see Configuring administrator profiles on page 54.

To add a contact

1. Go to Auto Dialer > Contact > Contact.
2. Click New and enter the contact information.
3. Click Create.

To add a contact group

1. Go to Auto Dialer > Contact > Contact Group.
2. Click New.
3. Enter a name for the group.
4. Click in the field and select the members for the group.

Members are created by adding contacts. See To add a contact on page 260.
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5. Click Close.
6. Click Create.

Configuring auto dialer settings

Auto Dialer > Setting allows you to set the maximum of 64 call channels for campaigns. The default is 10. This value
represents the number of phones that can be auto dialed at the same time.

Viewing auto dialer reports

Auto Dialer > Report allows you to view the status of the auto dialer campaigns, including campaign IDs and names, call
status, total number of campaigns, number of uncalled, answered, unanswered calls, and retries, and call duration and
time.

Double-clicking a campaign record also displays the call log.
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The Call Featuresmenu lets you configure the settings for many call features such as conference call, auto attendant,
faxing, and much more.

This topic includes:

l Configuring auto attendants on page 262
l Mapping speed dials on page 267
l Configuring conference calls on page 268
l Recording calls on page 271
l Creating call queues and queue groups on page 275
l Configuring call parking on page 279
l Configuring fax on page 280
l Setting calendar reminder on page 288
l Modifying feature access codes on page 289
l Configuring Internet of Things (IoT) on page 294

Configuring auto attendants

An auto attendant can answer a telephone line or VoIP number, and can be included in the call cascade of a local
extension, remote extension or ring group.

An auto attendant can answer a call if the receptionist is away or if you do not have a receptionist. Each auto attendant
has a message with options. The message tells the caller what the options are. You can load a professionally pre-
recorded message, or can record a message using a handset.

Auto attendants limit on FVE models

Model Number of auto attendants supported

FVE-20E 5

FVE-50E and FVE-VM-50 5

FVE-100E and FVE-VM-100 10

FVE-200F and FVE-VM-200 20

FVE-300E 30

FVE-500E, FVE-500F, and FVE-VM500 50

FVE-1000E and FVE-VM-1000 100

FVE-2000E, FVE-2000F, and FVE-VM-2000 200

FVE-3000E and FVE-VM-3000 300

FVE-5000F and FVE-VM-5000 500
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Model Number of auto attendants supported

FVE-VM-10000 1000

FVE-VM-20000 1000

FVE-VM-50000 1000

To view the list of auto attendants, go to Call Feature > Auto Attendant > Auto Attendant.

GUI field Description

Delete Removes a selected auto attendant. You cannot remove an auto attendant that is
used in another auto attendant configuration.

Name The name of the auto attendant.

Direct Actions The number of key actions configured for the main auto attendant, excluding the
key actions for the subsidiary auto attendants.

To create an auto attendant

1. Go to Call Feature > Auto Attendant > Auto Attendant.
2. Click New.
3. Configure the following:

GUI field Description

Name Enter a name for the auto attendant.

Default language Select the language for the auto attendant greeting message
(sound file). If you select Default, the greeting message will be the
same as what you set for the FortiVoice system. For more
information, see Setting PBX location and contact information on
page 107.
You can also select other languages. The language files are
created in Managing phone audio settings on page 117.

Greeting mode If you select Simple, select a greeting message (sound file) for the
auto attendant. See Greeting on page 263.
If you select Scheduled to add a scheduled greeting, do the
following:
l In Scheduled Greeting Setting, click New.
l In the Schedule field, select a schedule for the greeting.
Scheduled are created in Scheduling the FortiVoice system on
page 142.

l In theGreeting field, select a sound file. You can click New to
add a new file or Edit to modify the selected one. For more
information, see Managing phone audio settings on page 117.

l Click Create.

Greeting Select a greeting message (sound file) for the auto attendant. You
can edit a selected file or create a new one. For more information,
see Managing phone audio settings on page 117.
This option is only available if you select the Simple greeting mode.
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GUI field Description

Ringing for Enter the number of seconds for the phone to ring before the auto
attendant answers with the greeting message.

Timeout action after Enter the number of seconds that an auto attendant should be
allowed to wait before the caller takes further action according to
the voice instructions.
Select the action when the auto attendant timeout is reached.
l Dial Operator: The call is transferred to an operator.
l Dial Extension: The call is transferred to the extension you
select. You can edit a selected extension or create a new one.
For details, see Configuring IP extensions on page 162.

l Go to Voicemail: The call is transferred to a voicemail box.
Select the voicemail extension.

l Ring Group: The call is transferred to a ring group. Select the
ring group. For more information, see Creating ring groups on
page 189.

l Call Queue: The call is transferred to a call queue. Select the
queue. For more information, see Creating call queues on
page 230.

l Start Over: The auto attendant will repeat the instructions for
the caller. Also enter the maximum times to repeat.

l Hang Up: The call will be terminated.

Invalid input action after Enter the number of seconds that an auto attendant should be
allowed to wait after the caller enters an invalid input.
Select the action when the caller enters an invalid input.

Dial Pad Key Action Configure the auto attendant keys for callers to use when
navigating through the auto attendant hierarchy. For more
information, see Configuring key actions on page 266.

Key The key that transfers a call to a resource, for example, voicemail,
if pressed.

Action The resource to which a call is transferred by pressing a key. Some
actions require further configuration. For example, if you select Dial
Extension, you need to enter the extension number.

Target The resource target if applicable. For example, an extension
number, sound file, or external phone number that leads to a
resource.

Advanced Upon finishing configuring these functions, you need to inform the
users on how to use them after they reach the auto attendant.

Access voicemail Enable to allow external callers to reach their voicemail boxes by
dialing the default voicemail prompt code *98 or the code you set.
For more information about feature code, see Modifying feature
access codes on page 289.

Dial local number Select to enable an external caller to dial local extensions.
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GUI field Description

Override schedule Select to allow a system administrator to dial a code to replace the
schedule with a system schedule. For more information, see
Configuring system capacity on page 112.

Allow recording of
prompt sound file

Select to enable an external caller to dial into the FortiVoice system
and record a sound file.

Call Bridge (DISA) Select an account code for external users to dial into the FortiVoice
system and use the FortiVoice service just like the local
extensions. Callers must dial the DISA code followed by the
account code before making the calls. You can edit a selected
account code or create a new one. For more information on DISA
code, see Modifying feature access codes on page 289. For more
information on account code, see Configuring account codes on
page 160.

Outbound dialplans
allowed for access

Select the outbound dial plan for users to call the FortiVoice system
and through it to make outbound calls. For details, see Configuring
outbound dial plans on page 225.

Business group This option is available on FVE-500E, FV-500F, FVE-1000E, and
larger models only.
Select a business group to enable an external caller to dial into an
extension within the group using the shortened number. For
information about business group, see Creating business groups
on page 195.

If you select a business group, you must also
update the Include subdirectory in the Phone
System > Setting > Miscellaneous, Directory
section. For details, see Configuring system
capacity on page 112.

Department This option is unavailable on the FVE-20E2 and FVE-50E6
models.
Select or add a department to allow a caller to access the phone
directory categorized by department.

If you select a department, you must also update
the Include subdirectory in the Phone System >
Setting > Miscellaneous, Directory section. For
details, see Configuring system capacity on page
112.

Survival branch This option is available on FVE-300E-T, FVE-VM-500, and larger
models.
Select or add a survival branch to allow a caller to access phone
directory entries that belong to a FortiVoice survivability branch.
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GUI field Description

If you select a survival branch, you must also
update the Include subdirectory in the Phone
System > Setting > Miscellaneous, Directory
section. For details, see Configuring system
capacity on page 112.

4. Click Create.

Configuring key actions

Configure the auto attendant dial pad keys for callers to use when navigating through the auto attendant hierarchy.

For more information, see Dial Pad Key Action on page 264.

To configure a key action

1. While configuring an auto attendant, click New under Dial Pad Key Action.
2. Enter the key number that transfers a call to a resource, if pressed.
3. For Language, select the language to be used for this key action.
4. Select an Action:

GUI field Description

No Action The call is not transferred to any resource.

Play Announcement Play an announcement with directions, business hours, etc.
l Select the sound file for the announcement. You can click Edit to modify
an existing one or New to add a new one. For information on sound files,
see Managing phone audio settings on page 117.

l Select an action to follow the announcement:
l No action: The auto attendant takes no action.
l Hang up: The call will be terminated.
l Start over: The auto attendant will repeat the announcement.
l Auto attendant: The call is routed to another auto attendant, which
allows actions to be nested into a powerful call routing system.

Dial Operator The call is transferred to the operator.

Dial Extension The call is transferred to a specified local extension.
Select the extension. You can click Edit to modify an existing one or New to
add a new one. For more information, see Configuring extensions on page
162.

Go to Voicemail The call is transferred to a voice mailbox, allowing the caller to leave a
message.
Select the voice mailbox. You can click Edit to modify an existing one or New to
add a new one. For more information, see Configuring IP extensions on page
162.
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GUI field Description

Ring Group The call is transferred to the call queue of a ring group. The call is placed on
hold. The system will ring the next available extension in the ring group.
Select the ring group. You can click Edit to modify an existing one or New to
add a new one. For more information, see Creating extension groups on page
188.

Dial Number The call is transferred to a specified remote extension number.
Enter the remote extension number. For more information, see Setting up
remote extensions on page 176.

Call Queue The call is transferred to a call queue.
Enter the call queue configuration. For more information, see Creating call
queues and queue groups on page 230.

Lookup Name Directory Access the dial-by-name directory so the caller can find a user’s extension
number by entering the user’s name.
Select the Directory. For details about the directory and subdirectory selection,
see the Directory section in Configuring system capacity on page 112.

Change Language Change the auto attendant greeting language. Select the language and a
follow-up action. If you choose Auto attendant for the follow-up action, select
the auto attendant.
For Language, if you select Default, the greeting message will be the same as
what you set for the FortiVoice system. For more information, see Setting PBX
location and contact information on page 107.
You can also select other languages. The language files are created in
Managing phone audio settings on page 117.

Auto Attendant Route the call to another auto attendant, which allows actions to be nested into
a powerful call routing system. For example, the main auto attendant can say
“Press one for English. Oprima dos para Español.” Option 1 goes to the
English auto attendant and option 2 goes to the Spanish auto attendant.
Select an auto attendant. For information on creating auto attendants, see
Configuring auto attendants on page 262.

Start Over The auto attendant will repeat the announcement.

Hang Up The call is terminated.

IVR Route the call to the FortiVoice IVR system. For more information, see
Configuring IVRs on page 238.

5. ForMusic on hold, select the voice prompt to be used for this key action. See Managing phone audio settings on
page 117.

6. Optionally, enter any comments about this key action.
7. Click Create.

Mapping speed dials

For fast and efficient dialing, use the speed dial pattern to map the phone numbers, mostly outbound numbers.
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You can map a speed dial code directly to a number if you only have a few numbers to map. You can also use speed dial
rules to map a group of numbers.

To map a speed dial number

1. Go to Call Feature > Speed Dial > Number.
2. Click New.
3. Enter a name for the speed dial mapping.
4. For Dialed Code, enter the number based on the speed dial number pattern you set. For example, 333. For more

information, see To set speed dial rules for mapping groups of numbers on page 268.
5. ForMapped Number, enter the phone number to map to the speed dial code.

You can enter digits 0–9, space, dash, comma, # and *.
Speed dial pattern accepts # as the lead digit ( for example, #XX or #613XXX).
If you want to enter an auto attendant number followed by an extension, you can use comma (,) or semicolon (;) to
pause the automatic dialing.
A comma pauses dialing for two seconds, for example, 1-123-222-1234, 5678#. In this case, once pressing the
speed dial code you set, auto attendant 1-123-1234 is reached, and after two seconds, extension 5678 is
automatically dialed.
A semicolon pauses dialing for one second, for example, 1-123-222-1234; 5678#. In this case, once pressing the
speed dial code you set, auto attendant 1-123-1234 is reached, and after one second, extension 5678 is
automatically dialed.

6. Optionally, enter a note for the mapping, such as “This is for customer A”.
7. Click Create.

To set speed dial rules for mapping groups of numbers

1. Go to Call Feature > Speed Dial > Rule.
2. Click New.
3. Enter a name for the speed dial mapping.
4. For Dialed Pattern, enter a speed dial pattern supported by the FortiVoice system, for example, *83XXX.

For information on setting speed dial number pattern, see Configuring PBX options on page 108.
5. ForMapped Pattern, enter the phone number pattern to map to the dialed pattern, for example, 6112239XXX.

The mapped pattern tail's number of digits must match that of the dialed pattern.
6. Optionally, enter a note for the mapping.
7. Click Create.

In our example, when you dial *83111, phone number 6112239111 will be reached.

Configuring conference calls

The Call Feature > Conferencing tab lets you configure and enable conference call settings.

FortiVoice allows two types of conferencing:

l User conferencing: You can configure and enable a user conference call privilege for extension users to hold their
own conference calls on the user portal. For details about adding a conference call event, see the FortiVoice User
Portal Guide.

l Admin conferencing: The administrator can set up static or dynamic conference calls for the users. Static
conference calls are configured directly on the GUI whereas dynamic conference calls are configured using the
calendar.
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To configure a user conferencing

1. Go to Call Feature > Conferencing > User Conferencing.
2. Configure the following:

GUI field Description

Enabled Select to activate this conference call.

Number Enter an extension number that is mapped to the external number callers can
dial to join a conference call.

External numbers info Enter the external phone number that callers can dial to join a conference call.
Conference organizers can share it with the participants.

Music on hold Select to play background music that callers hear after the joining message
and leaving message are played.
For information on creating music on hold file, see Managing phone audio
settings on page 117.

Quiet mode Select to not record and announce participant's name.

Users Click New to add an extension user who has the privilege to organize
conference calls.
l User: Select the extension for the user.
l Conferencing ID: Enter the ID (from 3 to 10 digits) that the user needs to
organize conference calls. You can also clickGenerate to get a system
generated ID. Click Create.

Click View Scheduled Conferences to display the conferences that have been
scheduled and pick a free time slot for your conference schedule.

3. Click Apply.

To set up a static conference call

1. Go to Call Feature > Conferencing > Admin Conferencing and click New.
2. Configure the following:

GUI field Description

Mode Select Static.

Name Enter a conference call name.

Enabled Select to activate this user conferencing configuration.

Number Enter a number that callers can dial to join a conference call.

Setting

Display name Enter the name displaying on the conference call extension, such
as “HR”.

Attendee PIN Enter a password for joining the conference call. A caller needs to
dial the conference call number and enter this password to join the
conference call. The default is 123456.
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GUI field Description

This password is always valid and should only be sent to the
people who need it.

Organizer PIN Enter the PIN number to be used by the conference organizer to
host a conference call. The default is 123123.
This password is always valid and should only be sent to the
people who need it.

Description Enter any notes you have for this conference call.

Music on hold Select to play background music that callers hear after the joining
message and leaving message are played.
For information on creating music on hold file, see Managing
phone audio settings on page 117.

Quiet mode Select to not record and announce participant's name.

Recursive Schedules If you want conference calls on repeating schedules, select this
option and click New to select a schedule. Enter a password for
joining the conference call and click Create.
This option is useful if you want to limit the participants to a
particular recursive conference call. They can only join the
conference call during the scheduled time period and by entering
the password you set.
For information on setting up a schedule, see Scheduling the
FortiVoice system on page 142.

One Time Schedules If you want to set up a one time conference call, select this option
and click New to enter the start and end time. Enter a password for
joining the conference call and click Create.
This option is useful if you want to limit the participants to a
particular one time conference call. They can only join the
conference call during the scheduled time period and by entering
the password you set.
If the one time schedule conflicts with the recursive schedule, the
one time schedule has priority.

3. Click Create.

To configure a dynamic conference call

1. Go to Call Feature > Conferencing > Admin Conferencing and click New.
2. Configure the following:

GUI field Description

Mode Select Dynamic.

Name Enter a conference call name.
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GUI field Description

Enabled Select to activate this conference call.

Number Enter a number that callers can dial to join a conference call.

Setting

Display name Enter the name displaying on the conference call extension, such
as “HR”.

Description Enter any notes you have for this conference call.

Music on hold Select to play background music that callers hear after the joining
message and leaving message are played.
For information on creating music on hold file, see Managing
phone audio settings on page 117.

Quiet mode Select to not to record and announce participant's name.

3. Click Create.
4. In the conference call list, select the one you created.
5. Double-click a date to schedule a conference.
6. ClickOK.

Recording calls

For supervising and monitoring purposes, you can record incoming and outgoing calls to and from the extensions
matching the caller number patterns or dialed number patterns you set. You can also select the recorded file format and
archive the recorded calls.

This topic includes:

l Configuring call recordings on page 271
l Archiving recorded calls on page 273
l Setting the recorded file format on page 274

Configuring call recordings

Call Feature > Call Recording > Policy allows you to configure call recordings by creating, editing, removing, saving, or
viewing a recording.

GUI field Description

View Recordings Click to view, listen, search, or save the recordings. You can also do so by going to
Status > Storage > Recorded Calls. For details, see Playing recorded calls on
page 40.

Enabled Select to activate this call recording service.

Name The name of the call recording service.

Description Information of call recording configuration.
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To configure a call recording

1. Go to Call Feature > Call Recording > Policy.
2. Click New.

GUI field Description

Name Enter a name for this configuration.

Enable Select to activate this configuration.

Description Select the category of calls you want to record: by phone number, department,
user group, trunk, or queue.

Caller number pattern This option appears if you select By Phone Number for Description.
Enter the number pattern to match the callers’ phone numbers following the
pattern:
^[0-9XNZ]*[^\.]*$
where X=(0-9), Z=(1-9), and N=(2-9).
For more information, see Configuring PBX options on page 108.
The phone calls from the numbers matching the pattern will be recorded.

Dialed number pattern This option appears if you select By Phone Number for Description.
Enter the number pattern to match the dialed phone numbers following the
pattern:
^[^_][0-9XNZ\.]*$
where X=(0-9), Z=(1-9), and N=(2-9).
For more information, see Configuring PBX options on page 108.
The phone calls to the numbers matching the pattern will be recorded.

Department This option appears if you select By Department for Description.
Select the extension department of which you want to record the calls. You can
add a new department or modify an existing one. For more information, see
Creating extension departments on page 189.

Group This option appears if you select By User Groupfor Description.
Select the user group of which you want to record the calls. You can add a new
group or modify an existing one. For more information, see Creating user
groups on page 188.

Trunk This option appears if you select By Trunk for Description.
Select the trunk of which you want to record the calls. You can add a new trunk
or modify an existing one. For more information, see Configuring trunks on
page 200.

Queue This option appears if you select By Queue for Description.
Select the call queue of which you want to record the calls. For more
information, see Creating call queues and queue groups on page 230.

Record ratio Enter the percentage of calls that you want to record. This value is a rolling
percentage.
In the following example scenario, FortiVoice records 50% of calls: 
1. Set the record ratio at 50.

FortiVoice Phone System 6.0.12 Administration Guide 272
Fortinet Inc.



Configuring call features

GUI field Description

2. With a system that has no recorded calls, you are at 0% of recorded calls.
The system records the first call. With the first call recorded, the record
ratio is now at 100%.

3. To reach the 50% record ratio, the system will not record the second call.
4. With the record ratio at 50%, the system does not record the third call and

the record ratio drops below 50%.
5. With the record ratio below 50%, the system records the fourth call to

achieve the 50% ratio again.
To summarize this example scenario, the system has received 4 calls and
recorded 2 calls to achieve the recorded ratio of 50%.

The following settings can have an effect on the recorded call storage:
l Retention duration on page 273
l Archiving recorded calls on page 273
l Setting the recorded file format on page 274

Retention duration Enter the days for which you want to keep the recordings.

File name format Select the format of the downloaded recorded call files generated under this
policy.
The file format is useful when you filter downloaded recorded call files by going
toMonitor > Storage. See Viewing recorded calls and fax storage on page 40.

3. Click Create.

Archiving recorded calls

Configure the settings to archive the recorded calls.

To configure the recording archive settings

1. Go to Call Feature > Call Recording > Archive.
2. Configure the following:

GUI field Description

Rotation Setting

Recording rotation size
Recording rotation time

Enter the recorded file rotation size and time.
When the file reaches either the rotation size or time specified, whichever
comes first, the archiving file is automatically renamed. The FortiVoice system
generates a new file, where it continues saving recording archives. You can
access all rotated files through search.

Archiving options when
disk quota is full

Specify what the FortiVoice system should do if it runs out of disk space. Select
Overwrite to remove the oldest archived folder in order to make space for the
new archive, or select Do Not Archive to stop archiving more recorded calls.

Destination Setting

Destination Select an archiving destination:
Local: the FortiVoice system’s local hard drive or a NAS server.
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GUI field Description

Remote: a remote FTP or SFTP storage server.

Local disk quota If Local is the archiving destination, enter the disk space quota.
The total disk quota for archiving calls cannot exceed 50% of the total storage
disk size. For example, if the storage disk has a size of 100 GB, a maximum of
50 GB can be used for call archiving.
If this quota is met and a new call must be archived, the FortiVoice system
either automatically removes the oldest call archive folder in order to make
space for the new archive or stops archiving, depending on the settings you
specify under Rotation Setting on page 273.

If Remote is the archiving destination, configure the following:

Protocol Select the protocol that the FortiVoice system will use to connect to the remote
storage server, either SFTP or FTP.

IP address Enter the IP address of the remote storage server.

User name Enter the user name of an account the FortiVoice system will use to access the
remote storage server, such as FortiVoice.

Password Enter the password for the user name of the account on the remote storage
server.

Remote directory Enter the directory path on the remote storage server where the FortiVoice
system will store archived calls, such as /home/fortivoice/call-
archives.

Remote cache quota Enter the FortiVoice cache quota that is allowed to be used for remote host
archiving. The total cache quota for archiving calls cannot exceed 20% of the
total storage disk size. For example, if the storage disk has a size of 100 GB, a
maximum of 20 GB can be used for call archiving.
If this quota is met and a new call must be archived, the FortiVoice system
either automatically removes the oldest call archive folder in order to make
space for the new archive or stops archiving, depending on the settings you
specify under Rotation Setting on page 273.

Schedule Select a schedule for the archiving.

3. Click Apply.

Setting the recorded file format

Select the format for recording calls. Recording bit rate is the number of bits that are conveyed or processed per system
of time.

To set the recorded file format

1. Go to Call Feature > Call Recording > Setting.
2. Select the format- recording bitrate: Standard or Low rate.
3. Click Apply.

FortiVoice Phone System 6.0.12 Administration Guide 274
Fortinet Inc.



Configuring call features

Creating call queues and queue groups

This option is only available if you have not purchased a call center license.
If you have purchased and installed the call center license, then the call queue related menus
are visible under Call Center > Call Queue instead. For more details, see Setting up a call
center on page 230.

Call queuing, or Automatic Call Distribution (ACD), enables the FortiVoice system to queue up multiple incoming calls
and aggregate them into a holding pattern. Each call is assigned a rank that determines the order for it to be delivered to
an available agent (typically, first in first out). The highest-ranked caller in the queue is delivered to an available agent
first, and every remaining caller moves up a rank.

With call queuing, callers do not need to dial back repeatedly trying to reach someone, and organizations are able to
temporarily deal with situations when callers outnumber agents.

This topic includes:

l Creating call queues on page 275
l Creating queue groups on page 279

Creating call queues

Configure a call queue and add it in an inbound dial plan as a call handling action to make it effective. For more
information, see Configuring inbound dial plans on page 220.

Call queues consist of:

l Incoming calls waiting in the queue
l Agents who answer the calls in the queues
l A plan for how to handle the queue and assign calls to agents
l Music played while waiting in the queue
l Announcements for agents and callers

Depending on their privileges, agents can log into a queue to answer calls or transfer calls to another queue, which can
then be answered by another available agent.

Agents can be static or dynamic. Static agents are always connected to the queues, and dynamic agents need to log into
the queue in order to process calls.

To create a call queue

1. Go to Call Feature > Call Queue > Call Queue.
2. Click New .
3. Configure the following:

GUI field Description

Queue ID Enter an ID for the queue.

Number Enter an extension for callers to dial and enter into a call queue following the extension
number pattern. See Configuring PBX options on page 108.
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GUI field Description

This is another way to use a call queue configuration in addition to adding it in an
inbound dial plan as a call handling action.
In this case, the dial plan ignores this extension and still uses the extension to which it is
applied for call queue action.

Status Select to enable the call queue.

Display name Enter the queue name displaying on the queue extension, such as Support.

Description Enter any notes about this queue.

Department Select the department to which the queue belongs. For information on creating
departments, see Creating extension departments on page 189.

Queue Setting

Distribution
policy

Select a policy for distributing phone calls.
l Ring all: Rings all available agents. This is the default setting.
l Round Robin: Rings all agents in a queue equally in some rational order, usually
from the top to the bottom of a list and then starting again at the top of the list and so
on.

l Sequential: Rings each agent in a sequential manner regardless of whether they
have answered calls.

l Random: Rings an agent at random.
l Least Recent: Rings the agent that least recently received a call.
l Fewest Calls: Rings the agent that has completed the fewest calls in this queue.
l Weight Random: Rings a random agent, but uses the agent’s number of received
calls as a weight.

l Priority Based: Rings agents based on call answering priorities for callers entering
the call queue. A new call always starts with the lowest priority.

Maximum queue
capacity

Enter the maximum number of callers for the call queue. When the call queue is full,
other callers will be dealt with according to theQueue Overflow call handling action you
set in Queue Overflow on page 278.
The maximum is 100.

Maximum
queuing time

Enter the maximum call queue waiting time in minutes, seconds, or both. When the call
waiting time is due, the callers in the queue will be dealt with according to the call
handling action you set in Queue Timeout on page 278.
The maximum is 720 minutes.

Ring duration Enter the time in seconds to ring each agent. If a call is not answered when the ring
duration is due, the call is transferred to the next agent. The range is between 5 to 120
seconds.

Music on hold Select a sound file or music on hold file to play when a caller is waiting. For more
information, see Managing phone audio settings on page 117.

Additional Setting
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GUI field Description

Distinctive
Setting for Agent

Announce queue name: Select a sound file that announces the queue name. You can
add a new one or modify an existing one. For more information, see Managing phone
audio settings on page 117.
Caller ID option: Select how you want the IDs of the calls to this queue to display. If you
select Prefix, the queue Display name on page 276 is added before the caller ID on the
agent’s phone. If you select Replace, the queue Display name on page 276 replaces the
caller ID on the agent’s phone.
Ring Pattern: Select a queue extension ring pattern.

Business
Schedule

In Available field, select an operation schedule for the queue and click -> to move it to the
Selected field. For example, “business_hour” schedule means agents are only available
to answer the calls for this queue during business hours. For information on scheduling,
see Scheduling the FortiVoice system on page 142.

Announcement
to Caller

l Announce holdtime: Select if you want to announce the queue waiting time to a
caller at the set interval. You may also select to announce only once.

l Announce position: Select to announce a caller’s waiting position in the queue, such
as “You are caller No. 5 in the call queue”.
l No: Do not announce a caller’s position.
l Always: Always announce a caller’s position.
l Abbreviated: Announce a caller’s position only once if the caller is over the
marked position and always announce once before the caller reaches the
marked position.

l Minimal: Announce only when the caller is within the marked position.
l Mark position: Enter the benchmark for selecting Abbreviated orMinimal setting
under Announce position.
For example, if you select Abbreviated and enter 5, a caller’s position is announced
when the caller becomes No. 5 in the queue and announced only once before the
caller becomes No. 5 in the queue.

l Announcement interval: Enter the announcement frequency in seconds.
l Custom announcement: You can also customize the announcement settings. If you
select Periodic or Random, enter the announcement frequency in seconds in
Announcement interval. Also, select a greeting sound file for the announcement.
For more information, see Managing phone audio settings on page 117.

l Queue Entry Announcement: Select Enable to announce to callers when they enter
a call queue. You can also select to disable this function. Also, select a greeting
sound file for the announcement. For more information, see Managing phone audio
settings on page 117.

Agent This option is only available when you edit a call queue.

Agent Members l Click to expand Agent members for enrolling agents into the queue.
l Click + to select the agents for this queue.
l Click Close.
l ClickOK.

You can type an agent’s extension or name in the Search field and press Enter to search
for the agent.
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GUI field Description

Call Handling This option is only available when you edit a call queue.

Scheduled
Business Hour
Call Handling

For details, see Configuring scheduled business hour queue call handling actions on
page 278.

Non Scheduled
Business Hour
Call Handling

For details, see Configuring non scheduled business hour queue call handling actions on
page 278.

4. Click Create.

Configuring scheduled business hour queue call handling actions

Configure the call handling action for the queue. This action applies to all calls once they enter into the queue.

To configure the call handling action

1. Go to Call Feature > Call Queue > Call Queue.
2. Select a call queue for which you want to configure queue call handling actions and click Edit.
3. In Call Handling, click Scheduled Business Hour Call Handling.
4. Configure the situation upon which corresponding call process can be configured:

GUI field Description

Queue Overflow The situation when callers exceed the maximum waiting callers you set. See
Maximum queue capacity on page 276.
A popup notification appears when this barometer is triggered.

Queue Timeout Callers waiting time exceeds the maximum waiting time set in Maximum
queuing time on page 276.
A popup notification appears when this barometer is triggered.

5. For each situation, click New to configure its call handling action.
l Select the FortiVoice operation schedule to implement this call handling action. For more information on
schedules, see Scheduling the FortiVoice system on page 142.

l Select the call handling action. Depending on the action selected, further configuration may be needed. For
example, if you select Dialextension for Action, enter the extension to which a call is transferred.

6. Click Create, thenOK.

Configuring non scheduled business hour queue call handling actions

Configure the call handling action for the queue. This action applies to all calls once they enter into the queue.

For some processes that may require further actions, you need to add one or more call processes to complete the call
handling. For example, after adding a process that contains a Set call queue priority action, you can add another process
with a Transfer to queue action to complete the call handling. In this case, the call will be processed again with new
priority after it is transferred to the queue.

To configure the call handling action
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1. Go to Call Feature > Call Queue > Call Queue.
2. Select a call queue for which you want to configure queue call handling actions and click Edit.
3. In Call Handling, click NonScheduled Business Hour Call Handling.
4. On the Call Processing page, click New to configure call handling action.
5. For Schedule, select the FortiVoice operation schedule to implement this call handling action. For more information

on schedules, see Scheduling the FortiVoice system on page 142.
6. For Action, select the call handling action. Depending on the action selected, further configuration may be needed.

For example, if you select Dialextension for Action, enter the extension to which a call is transferred.
7. Click Create, thenOK.

Creating queue groups

You can group queues together to facilitate queue management.

To create a call queue group

1. Go to Call Feature> Call Queue > Queue Group.
2. Click New.
3. Enter a name for the group.
4. ForMember, click + and select the available call queues that you want to include in the group.
5. Click Close, then Create.

Configuring call parking

Call park is a feature for placing a call on hold and then retrieving it from any other local extension. By default, the
FortiVoice system has 20 park orbits, 301–320.

To view the parked calls, see Viewing parked calls on page 29.

To configure call parking

1. Go to Call Feature > Call Parking > Call Parking.
2. For Park call number, enter the number to dial to park a call. The default is 300 which has the same effect as the call

park feature code *40. See Mid-Call/DTMF Codes on page 293.
For example, when a user receives a call and wants to park it, the user may:
l Press 300.

The FortiVoice system selects the first available park orbit (301–320). The user hears a confirmation indicating
the caller has been parked successfully and into which park orbit.

l Provide the park orbit to the person with the parked call through paging or other means. For example, “Mary,
there is a call parked for you in 301”. Mary can then pick up any phone and dial 301 to retrieve the parked call.

3. For Park line start, enter the starting park orbit. The default is 301.
4. For Park line end, enter the ending park orbit. The default is 320.
5. For Parking timeout, enter the time, in seconds, to time out the parked call. The default is 60 seconds.
6. ForMusic on hold, select the music on hold file to play while the call is place on hold. Click Edit to modify the

selected file or click New to configure a new one. For more information on music on hold, see Managing phone
audio settings on page 117.

7. Click Apply.
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Configuring fax

The FortiVoice system supports fax in the following ways:

l Use the FortiVoice system to send and receive faxes. The FortiVoice system contains a full featured fax server that
is able to receive faxes and forward them in PDF format to an extension’s user portal or a user’s email. End users
can log into their web portal to view the faxes and upload PDF or JPEG files to send faxes. For configuration
information, see Receiving faxes on page 280 and Sending faxes on page 281.

l If you want to continue using your fax machine with the VoIP phone system, connect the fax machine to an adapter
(such as OBIHAI OBi 200, Cisco SPA 112, or Grandstream HT 702) that supports T.38 first before connecting to the
FortiVoice system. T.38 is a protocol designed to allow fax to travel over a VoIP network.
In this case, the fax machine is treated like an extension. The FortiVoice system receives faxes and relays them to
the fax machine. Faxes sent from the fax machine will follow the fax sending dial plans.
To use this option, you need to create and enable the fax extensions first. You then need to configure the FortiVoice
system to receive and relay the faxes to the fax machine. See Configuring fax extensions on page 179, Receiving
faxes on page 280 and Sending faxes on page 281.

This topic includes:

l Receiving faxes on page 280
l Sending faxes on page 281
l Archiving faxes on page 286
l Configuring other fax settings on page 287

Receiving faxes

Configure the FortiVoice system to receive faxes over the VoIP network and forward the faxes to extensions or emails.
You can configure one or more faxes to meet the needs of different departments, for example.

To configure receiving faxes

1. Go to Call Feature > Fax > eFax Account ,
2. Click New.
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3. Configure the following:

GUI field Description

Incoming Fax
Setting

Name Enter a name for the receiving fax configuration.

Number Enter an extension for this fax. This is where the incoming faxes go to.

Display name Enter the name displaying on the extension.

Enable Select to activate this fax.

Description Enter any notes for the incoming fax settings.

External Numbers Map the DID numbers to the extension of the fax. Incoming faxes to the DIDs will all reach
the extension. For information on DID, see Mapping DID numbers on page 224.
To map the DID numbers:
1. Click New.
2. Select Enable to activate this DID mapping.
3. Select the trunk used for dialing the DIDs.
4. Enter the DID number that you want to map to an extension.
5. Click Create.

Select Fax Monitors Select the users that can monitor the faxes received on this fax extension in their
FortiVoice user portal and can choose to view, delete, resend, forward, or download the
faxes.
The selected users will also receive email notifications when a fax is received if their
extensions are linked with email addresses. The notification will also have a PDF
attachment of the fax if their extensions are configured with email notification attachment
option. For more information, see Setting extension user preferences on page 181.
This is useful if you have a fax that serves several departments.

Fax to Email Enter the email addresses to receive the faxes sent to this extension. Users will receive
the faxes in PDF format.
You may customize the email template. For details, see Customizing call report and
notification email templates on page 111.

Relay to Fax
Machine

Select the fax machines connected to the FortiVoice system via T.38 adapters. Faxes will
be relayed to the selected machines.

Archive Select Fax archive to activate fax archiving and enter the file name to archive following the
formats in the drop-down list.
To view faxes sent and received through the FortiVoice system, see Viewing archived
faxes on page 41.

4. Click Create.

Sending faxes

Configure the dial plans for sending faxes. The dialed fax numbers matching the configured number pattern will be
subject to the call handling actions.
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The fax sending dial plans will not interfere with phone call dial plans since the FortiVoice system deals with the dial
plans separately.

For information on dial plans, see Configuring call routing on page 220.

You send faxes in the user portal. Senders will receive email notifications when a fax is sent if their extensions are linked
with email addresses. The notification will inform if the fax has been successfully sent and have a PDF attachment of the
fax if their extensions are configured with email notification attachment option. For more information, see Setting
extension user preferences on page 181.

In addition, senders can always view the status of the fax sent in their FortiVoice user portal. For more information, see
the online help of the web user portal.

To view the outbound dial plans, go to Call Feature > Fax > Sending Rule.

GUI field Description

Test Select to test if the dial plan is created successfully.
For more information, see Testing dial plans for sending faxes on page 282.

Enabled Select to activate this dial plan.

Name The name of the dial plan.

Pattern The phone number pattern in the dial plan that matches other numbers. For details, see Dialed
Number Match on page 282.

Call handling The call handling action for the numbers matching the configured number pattern and the
caller IDs matching the caller ID pattern. For details, see Call Handling on page 282.

To set up a fax sending dial plan

1. Go to Call Feature > Fax > Sending Rule.
2. Click New.
3. Configure the following:

GUI field Description

Name Enter a name for this plan.

Enable Select to activate this dial plan.

Dialed Number
Match

With dialed number pattern matching, you can create one phone number pattern in your
dial plan that matches many different numbers.
The dialed numbers matching this pattern will follow this dial plan rule.
For information on adding a dialed number match, see Creating dialed number match on
page 283.

Call Handling Click New to configure the call handling action for the numbers matching the configured
number pattern. For details, see Configuring call handling actions on page 285.

4. Click Create.

Testing dial plans for sending faxes

After you create a dial plan, you can select the dial plan and click Test to see if the dial plan works.
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For more information, see Test on page 282.

To test a dial plan

1. Go to Call Feature > Fax > Sending Rule.
2. Select the dial plan that you want to test and click Test.
3. Select Test Call - Dry Run or Test Call.
4. Configure the following:

GUI field Description

Test Call - Dry Run Run a system outbound dial plan test without making a real phone call.

Destination
number

Enter a destination number to call.

From number Enter the number from which you want to call the destination number. The FortiVoice system
will connect this number with the destination number for the test.

Test Click to start the dry run test and view the Test result.

Reset Click to remove the test result in order to start a new test.

Test Call Test the dial plan by making a real phone call.

Destination
number

Enter a destination number to call.

After call is
established

Select the FortiVoice action once it calls the destination number:
l Play welcome message: The FortiVoice system will play a message to the destination
number.

l Connect test call to number: In the Number field, enter the number from which you want
to call the destination number. The FortiVoice system will connect this number with the
destination number to test the trunk.

Test Click to start the test and view the Test result.

Reset Click to remove the test result in order to start a new test.

Creating dialed number match

You can create one extension number pattern in your dial plan that matches many different numbers for outbound calls.

The numbers matching this pattern will follow this dial plan rule.

The FortiVoice system supports the following pattern-matching syntax:

Pattern-matching syntax

Syntax Description

X Matches any single digit from 0 to 9.

Z Matches any single digit from 1 to 9.

N Matches any single digit from 2 to 9.
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Syntax Description

[ ]
(square brackets)

Matches any digits in the brackets.
For a range of numbers, use a dash.
Example: [15-7].
In this example, the pattern matches 1, 5, 6, and 7.

.
(period)

Acts as a wildcard that matches any digit and allows for any number of digits to be
dialed.
Example of a pattern matching rule: XX.
In this example, the system looks for a dialed number match that has three or more digits.

!
(exclamation point)

Acts as a wildcard that matches any digit (including no digits) and allows for any number of
digits to be dialed.
Example of a pattern matching rule: XX!
In this example, the system looks for a dialed number match that has two or more digits.

Pattern-matching examples

Pattern Description

X. Matches any dialed number.

NXXXXXX Matches any seven-digit number, as long as the first digit is 2 or higher.

NXXNXXXXXX Matches any dialed number that has 10 digits.

1NXXNXXXXXX Matches any dialed number that matches this pattern: 1 + area code (between
200
and 999) + seven-digit number (first digit is 2 or higher).

011. Matches any number that starts with 011 and has at least one more digit.

XX! Matches any two or more digits.

To create a dialed number match

1. Go to Call Feature > Fax > Sending Rule.
2. Click New.
3. In Dialed Number Match, click New.
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4. Configure the following:

GUI field Description

Match Pattern Enter the number pattern for this rule (see Pattern-matching syntax on page 283 and
Pattern-matching examples on page 284).
Click + to add more patterns.

Modification You can manipulate the number patterns you entered.

Strip Enter a number to omit dialing the starting part of a pattern. 0 means no action.
For example, if yourMatch Pattern is 9XXX and Strip is 1, you only need to dial the last
three digits for this pattern.

Prefix Add a number before a pattern, such as area code.
For example, if yourMatch Pattern is 123XXXX and its area code is 555, you can enter
555 for the Prefix. When you dial a number under this pattern, you do not need to dial the
area code 555.

Postfix Add a number after a pattern.
For example, if yourMatch Pattern is 9XXX and the numbers under this pattern have been
upgraded to have an additional digit 5 at the end, you can enter 5 for the Postfix. When you
dial a number under this pattern, you do not need to dial the last digit 5.

5. Click Create.

Configuring call handling actions

Configure the call handling action for the numbers matching the configured number pattern.

To configure the call handling action

1. Go to Call Feature >> Fax > Sending Rule.
2. Click New.
3. In Call Handling, click New.
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4. Configure the following:

GUI field Description

Schedule Select the FortiVoice operation schedule to implement this plan. Click Edit to modify the
selected schedule or click New to configure a new one. For more information on PBX
schedule, see Scheduling the FortiVoice system on page 142.

Action Select the call handling action for the numbers matching the configured number pattern
and the caller IDs matching the caller ID pattern.

Outgoing trunk Select the trunk for sending faxes. Click Edit to modify the selected trunk or click New to
configure a new one. For more information on trunks, see Configuring trunks on page 200.

Caller ID
modification

Select the caller ID modification configuration. Click Edit to modify the selected
configuration or click New to configure a new one. For more information on caller ID
modification, see Modifying caller IDs on page 124.

Warning message If you select Allow with warning or Deny with warning in the Action field, select the sound
file for the warning. Click Edit to modify the selected file or click New to configure a new
one. For more information on sound files, see Managing phone audio settings on page
117.

Delay Optionally, if you want to discourage certain users for sending faxes, enter the call delay
time in seconds.

5. Click Create.

Archiving faxes

Configure the settings to archive the faxes.

To configure archiving faxes

1. Go to Call Feature > Fax > Archive.
2. Configure the following:

GUI field Description

Rotation Setting

Fax rotation
size
Fax rotation
time

Enter the archived fax file rotation size and time.
When the file reaches either the rotation size or time specified, whichever comes first, the
archiving file is automatically renamed. The FortiVoice system generates a new file, where
it continues saving recording archives. You can access all rotated files through search.

Archiving
options when
disk quota is full

Specify what the FortiVoice system should do if it runs out of disk space. SelectOverwrite
to remove the oldest archived folder in order to make space for the new archive, or select
Do not archive to stop archiving more recorded calls.

Schedule Select or edit a schedule for the rotation. To add a new schedule, click +.

Destination Setting

Destination Select an archiving destination:

FortiVoice Phone System 6.0.12 Administration Guide 286
Fortinet Inc.



Configuring call features

GUI field Description

Local: the FortiVoice system’s local hard drive or a NAS server.
Remote: a remote FTP or SFTP storage server.

Local disk
quota

If Local is the archiving destination, enter the disk space quota.
The total disk quota for archiving calls cannot exceed 20% of the total data disk size. For
example, if the data disk has a size of 100 GB, a maximum of 20 GB can be used for fax
archiving.
If this quota is met and a new fax must be archived, the FortiVoice system either
automatically removes the oldest fax archive folder in order to make space for the new
archive or stops archiving, depending on the settings you specify under Rotation Setting
on page 273.

If Remote is the
archiving
destination,
configure the
following:

Protocol Select the protocol that the FortiVoice system will use to connect to the remote storage
server, either SFTP or FTP.

IP address Enter the IP address of the remote storage server.

User name Enter the user name of an account the FortiVoice system will use to access the remote
storage server, such as FortiVoice.

Password Enter the password for the user name of the account on the remote storage server.

Remote
directory

Enter the directory path on the remote storage server where the FortiVoice system will
store archived calls, such as /home/fortivoice/call-archives.

Remote cache
quota

Enter the FortiVoice cache quota that is allowed to be used for remote host archiving. The
above statement regarding the Local disk quota also applied to the cache quota.

3. Click Apply.

Configuring other fax settings

Configure the station IDs, fax header, T.38 fax options, and fax sending queue for outgoing faxes.

To configure fax settings

1. Go to Call Feature > Fax > Setting.
2. Configure the following:

GUI field Description

System station ID Enter a station ID that shows on each fax sent from the FortiVoice
system.
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GUI field Description

System fax header Enter a fax subject header that shows on each fax sent from the
FortiVoice system.

Maximum Transmission Rate Select the maximum fax data transmission rate in bit per second
(bit/s).

Minimum Transmission Rate Select the minimum fax data transmission rate in bit per second
(bit/s).

Enable T.30 ECM (error correction mode) This option is for accurately detecting and correcting errors in the
fax page data to make the fax transmission successful.
This option is enabled by default.

T.38 Fax

Sending Fax: Initiate
a T.38 reinvite if the
remote end does not

Select if the fax receiving terminal does not reply to a T.38
invitation.

Sending/Receiving:
Fallback to audio
(G.711) mode on
T.38 failure

Select to use G.711 mode if T.38 communication fails.

UDPTL port start T.38/UDPTL uses UDP as its transport protocol.
Enter the UDP Transport Layer start port.

UDPTL port end Enter the UDP Transport Layer end port.

Send Queue

Max retry times Enter the maximum number of times to resend a fax. This is useful
if a fax cannot be sent due to busy lines or other reasons.

Retry interval Enter the time interval between fax sending retries.

Wait time for an
answer

Enter the waiting time for a “go-ahead” signal from the fax
receiving terminal. After the waiting time is over, the FortiVoice
system will either retry to send the fax or stop sending it
depending on theMax retry times configuration.

3. Click Apply.

Setting calendar reminder

You can schedule daily events and send event reminders. You first create a reminder record before setting up reminder
events. One reminder record can contain multiple reminder events.

To schedule an event

1. Go to Call Feature > Reminder and click New.
2. Enter a name for the reminder record. One reminder record can contain multiple reminder events.
3. Enable the reminder and add notes if required.
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4. Click Create.
5. In the reminder list, select the reminder record you just created.
6. Click Edit in calendar mode.
7. Click a date.
8. Configure the following:

GUI field Description

Title Enter a name for the reminder event.

Location Enter the location for the event.

Start time Specify when the event starts.
The start time uses the time zone setting available in System > Configuration > Time.

Recurrence If you want the reminder event to be on a repeating schedule, click None, update the
settings, and clickOK.

Description Enter any notes as required.

Guest Add guests to which you want to send event reminder calls.
l To add internal phone numbers, click +, select extensions, and click Close.
l To add an external phone number, enter a phone number in External, and click .
The number is added to the Guest list.

Reminder audio To send a reminder audio to the selected guest phones, select one of the following
options:
l Default: Select to send a beep sound as the reminder audio. To hear the beep sound,
click Play, and save the GSM file.

l Customized: Select to customize the reminder audio.
a. Click Create New.
b. You have two options to create a customized message:

l To record a message, select an extension and click Call me. You can then
follow the prompts to create a new message.

l To upload a message that you have already recorded:
l Make sure that the sound file is a WAVE file (.wav) in PCM format and
with a maximum size of 10 MB.

l Click Upload.
l Select the file and clickOpen.

c. Click Close.

9. Click Create, then Close.

Modifying feature access codes

By default, the FortiVoice system defines the following codes for users to access certain features by dialing the codes.
You can go to Call Feature > Feature Code > Vertical Service Code/Mid-Call/DTMF Code and double-click a feature
name to modify its code and description, but that does not change the mapping between the code and the feature. For
example, if you change the DISA code from the default ** to 12, dialing 12 still accesses the DISA feature.

FortiVoice Phone System 6.0.12 Administration Guide 289
Fortinet Inc.



Configuring call features

There are the following feature access codes:

l Vertical Service Codes: a sequence of digits and the signals star (*) and number sign (#) dialed on a telephone
keypad or rotary dial to enable or disable certain telephony service features.

l Mid-Call/DTMF Codes: allow you to hold, transfer, and conference calls by using DTMF digit codes entered on the
phone.

l Floating codes: allow you to limit international, long distance, or local calls.

Vertical Service Codes

GUI field Description

Call bridge (DISA) Direct Inward System Access (DISA) service allows external users to dial into PBX
and use PBX service just like the local extensions.
To use DISA, dial the PBX main number and then ** or the code you set. The PBX
will prompt you to enter the account code (account code set at PBX > Class of
Service > Account code). Once you pass authorization, you can use PBX service
just like a local extension.

Check hot desk login status Hot-desking refers to the sharing of one phone by multiple users at different time
periods.
Dial *10 or the code you set to check hot desk login status including login expiry
time.

Hot desk user login Hot-desking refers to the sharing of one phone by multiple users at different time
periods. Each user can log into the phone by pressing *11 or the code you set and
enter his extension number and voicemail PIN following the prompts.

Hot desk user logout To log out hot desking, press *12 or the code you set.

Reset the phone to be
'unassigned' by admin

This code is used to remove the extension number of a FortiFone by the
administrator.
Dial *15 or the code you set on any FortiFone that connects to the FortiVoice
system and enter the phone configuration PIN.
For information on setting the phone configuration PIN, see Configuring SIP
phone auto-provisioning on page 93.

Reset the phone to be
'unassigned' by user

This code is used to remove the extension number of a FortiFone by the user.
Dial *16 or the code you set on your FortiFone that connects to the FortiVoice
system and enter the phone configuration PIN.
For information on setting the phone configuration PIN, see Configuring SIP
phone auto-provisioning on page 93

Configure phone to an extension
by administrator

This code is used to set an extension number for a FortiFone by the administrator.
Dial *17 or the code you set on any FortiFone that connects to the FortiVoice
system and enter the phone configuration PIN. You can then enter an existing
extension to set it as the extension of this phone.
For information on setting the phone configuration PIN, see Configuring SIP
phone auto-provisioning on page 93.
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GUI field Description

Configure phone to an extension
by user

This code is used to set an extension number for a FortiFone by a phone user.
Dial *18 or the code you set on your FortiFone that connects to the FortiVoice
system and enter the phone configuration PIN provided by the administrator. You
can then enter an existing extension to set it as the extension of this phone.

Lookup name directory from
extension

Dial *411 or the code you set to access the phone directory where you can look for
an extension by entering a person’s name.

Listen/Barge on a call Dial *50 or the code you set to monitor a call by listening to it, enter your voicemail
PIN, and press #. For details about configuring a user privilege that allows call
barging, Monitor/Recording on page 140.

Agent login to all queues Dial *61 or the code you set to log into the queues of which your extension is a
member.

Agent logout from all queues Dial *62 or the code you set to log out of the queues of which your extension is a
member.

Agent login to a queue Dial *63 or the code you set and enter your voicemail password and the queue
extension to log into this queue.
The voicemail password is required only if this option is selected for your
extension. For more information, see Call Center on page 169.

Agent login from a queue Dial *64 or the code you set and enter your voicemail password and the queue
extension to log out of this queue.
The voicemail password is required only if this option is selected for your
extension. For more information, see Call Center on page 169.

Login all queue members Dial *65 or the code you set to login all members of a queue of which your
extension is a member. This is an action by the administrator.

Logout all queue members Dial *66 or the code you set to logout all members of a queue of which your
extension is a member. This is an action by the administrator.

Pause agent all queues Dial *67 or the code you set and enter your voicemail password and the reason
code to pause all queues of which this extension is a member.
For information on reason codes, see Modifying agent reason code descriptions
on page 248.

Unpause agent all queues Dial *68 or the code you set and enter your voicemail password and the reason
code to unpause all queues of which this extension is a member.
For information on reason codes, see Modifying agent reason code descriptions
on page 248.

Set call forward Dial *71 followed by a code to set user’s call forward: 1 to enable, 0 to disable, and
9 to change the forwarding number.

User’s quick mode switch Dial *72 followed by 1, 2, or 3 and enter your voicemail password to temporarily
replace the original personal schedule with one of the three default ones. You may
also modify the temporary schedule. Dial *720 to go back to the original schedule.

User’s twinning mode switch Dial *73 followed by 1 to enable twinning and 0 to disable twinning. For information
on twinning, see Twinning Setting on page 185.
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GUI field Description

Enter floating mode and make
outgoing call on floating host
device

This code allows you to make international or long distance calls from a floating
host device which is a device (usually a phone) that allows other extensions to
originate a call.
Dial *74 or the code you set and dial the outgoing call number when hearing the
dial tone. When you are prompted to input the code, enter the code based on the
call restriction in the user privileges associated with your extension. For more
information, see Floating code format on page 294.

Hotel room condition Dial *75 or the code you set and enter a maid code to show the room condition.
The maid codes varies depending on the PMS protocol selected:

FortiVoice Micros Comtrol

1: Maid present 1: Dirty/Vacant 1: Room Cleaned

2: Clean 2: Dirty/Occupied 2: Cleaning Requested

3: Not clean 3: Clean/Vacant 3: Cleaning In-Progress

4: Out of service 4: Clean/Occupied 4: Inspection Requested

5: To be inspected 5: Inspected/Vacant 5: Maintenance
Requested

6: Occupied/clean 6: Inspected/Occupied 6: Out of Order

7: Occupied/not clean 7: Pick Up

8: Vacant/clean 8: Passed Inspection

9: Vacant/not clean 9: Failed Inspection

10: Cleaning Skipped

For information on maid codes, see Configuring hotel management settings on
page 254.

Minibar notification Dial *76 or the code you set and enter a minibar code to order room items.
For information on minibar codes, see Configuring hotel management settings on
page 254.

Wake-up call Dial *77 or the code you set and enter a time for a wake-up call. The time format
should be in the format of hhmm. For example, 15:30 is entered as 1530.

DND on Dial *78 or the code you set to turn on the Do Not Disturb service. Callers will hear
the busy sound when they dial your number.

DND off Dial *79 or the code you set to turn off the Do Not Disturb service. Otherwise,
callers will hear the busy sound when they dial your number.

Pickup any ringing extension in
pickup group

As a pickup group member, you can dial *80 or the code you set on your phone to
pick up a call from any ringing extension.
For information on pickup groups, see Creating pickup groups on page 194.

Pickup group extension As a pickup group member, you can dial *81 or the code you set on your phone
followed by a ringing extension number to pick up a call from that extension.
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GUI field Description

For information on pickup groups, see Creating pickup groups on page 194.

System schedule override An administrator with the privilege can dial *82 followed by 1, 2, or 3 and the
administrator PIN to temporarily replace the original system schedule with one of
the three default ones. You may also modify the temporary schedule. Dial *820 to
go back to the original schedule. See Configuring system capacity on page 112.

Internet of Things Dial *91 or the code you set and enter the Amazon Alexa account extension to
operate your FortiVoice system through voice commands. For more information,
see Configuring Internet of Things (IoT) on page 294.

Intercom Dial *92 or the code you set and enter an extension to intercom that extension.

Prompt sound file recording Dial *93 or the code you set and enter the prompt file ID and select the language to
record your prompt file.

Voicemail direct Dial *97 or the code you set from your own phone and then enter your voicemail
password to directly access your voice mailbox.

Voicemail prompt Dial *98 or the code you set from any extension and then enter your extension
number and voicemail password to access your voice mailbox.

Operator Dial 0 or the code you set to access the operator.

One key DND This is for supporting the DND key on the FortiFone phones. Press the DND key
on the FortiFone phone to turn DND on or off.

Page group Enter PAGEGROUP or the code you set then the paging group number to page
the extension group.

Unpark This is for supporting the Unpark key on the FortiFone phones. Press this key on
the FortiFone pnone to unpark a call.

Mid-Call/DTMF Codes

GUI field Description

Blind transfer Blind transfer serves 2 purposes:
l During a call, dial *11 or the code you set and then the extension number of a
second person to transfer the call to the person without talking to the person.

l During a call, dial *11 and then the call parking number (default is 300) to park
a call. For details, see Configuring call parking on page 279.

Attended transfer During a call, dial *12 or the code you set and then the extension number of a
second person to transfer the call to the person. Since you want to inform the
second person about the call, you can have a private conversation with the person
without the first person who made the call hearing it.

Start personal recording Dial *30 or the code you set to start personal call recording. Personal recordings
can be reviewed on the user portal.
Before doing so, have the agreement of the person you talk with or check your
local laws regarding phone recording.
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GUI field Description

Pause personal recording Dial *31 or the code you set to pause personal call recording.

Start system recording Dial *35 or the code you set to start system call recording. System recordings
need administrator permission and can be viewed on the system administrator
web GUI.
Before doing so, have the agreement of the person you talk with or check your
local laws regarding phone recording.

Pause system recording Dial *36 or the code you set to pause system call recording.

Resume system recording Dial *37 or the code you set to resume system call recording.

Cancel system recording Dial *38 or the code you set to cancel system call recording.

Park Dial *40 or the code you set to park a call.

Floating code format

Caller privilege Code format

Allow *74 + extension number + * + voicemail PIN (Phone System > Setting > Option >
Default Setting > Default Voicemail PIN)
or 74* + extension number + * + extension personal code (Extension > IP
Extension > User Setting > Phone Access > Personal Code)

Allow with personal code *74 + extension number + * + voicemail PIN (Phone System > Setting > Option >
Default Setting > Default Voicemail PIN)

Allow with account code *74 + extension number + * + user privilege account code (Security > User
Privilege > Account Code)

Allow with account and personal
code

*74 + extension number + * + user privilege account code Security > User
Privilege > Account Code)
or *74 + extension number + * + voicemail PIN (Phone System > Setting > Option
> Default Setting > Default Voicemail PIN)

Configuring Internet of Things (IoT)

The FortiVoice system integrates with Amazon Alexa which allows you to operate your FortiVoice system through voice
commands.

This option is only supported on FVE-100E and above.

This option only appears if you enable it and refresh the browser. For details, see Internet of Things on page 115.

To associate an extension number with an IoT account, make sure that Internet of Thingssetting is enabled in the
extension's user privilege. For more information, see Configuring user privileges on page 137.
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To view the IoT accounts, go to Call Feature > Internet of Things > IoT Account.

GUI field Description

Register Select an account and click this option to register it on the IoT proxy server to start
the service.

Name The name of the account.

Extension The extension number associated with the account.

Services The type of the account.

Description The comments on the account.

Status Displays if the account has been registered on the IoT proxy server.

To configure an IoT account

1. Go to Phone System > Setting > Miscellaneous.
2. Select Amazon Alexa under Internet of Things, and click Apply.
3. Refresh your browser.
4. Go to Call Feature > Internet of Things.
5. Click New and configure the following:

GUI field Description

Account/Email Enter your email address as the account name.

Authorization code Enter a password or clickGenerate to have a system generated password.

Extension Select the extension number associated with the account. Make sure that Internet of
Thingssetting is enabled in the extension's user privilege. For more information, see
Configuring user privileges on page 137.

Description Enter any notes as required.

Services Select the Amazon Alexa service for the account. If you wish to use the phone to initiate
requests to Alexa, select Allow FortiVoice extension.

6. Click Create.
7. If you want to automatically register this account on the IoT proxy server, click Yes. Otherwise, click No.

The FortiVoice system generates a link for accessing Amazon Alexa on the user portal.

Configuring Amazon Alexa

After setting up an IoT account on the FortiVoice system, go to the user portal with the extension number associated with
the IoT account.

To configure Amazon Alexa

1. Log into the user portal with the extension number associated with the IoT account.
2. Go to Internet of Things.
3. Click the Authorize my extension link.
4. Accept the terms and conditions.
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5. Enter your Amazon username and password or create a new one.
6. Enter your IoT account login credential.
7. Add the FortiVoice skill through Amazon.

With Amazon Alexa now configured, you can now use it in conjunction with the FortiVoice system. To use Alexa, simply
dial *91 on the extension associated with the IoT account before issuing a command.
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The Log & Reportmenu lets you configure FortiVoice logging and reporting.
FortiVoice systems provide extensive logging capabilities for voice incidents and system events. Detailed log information
provides analysis of network activity to help you identify network issues and reduce network misuse and abuse.
Logs are useful when diagnosing problems or when you want to track actions the FortiVoice system performs as it
receives and processes phone calls.

Reports provide a way to analyze log data without manually going through a large amount of logs to get to the
information you need.

This topic includes:
l About FortiVoice logging on page 297
l Configuring logging on page 299
l Configuring call center report profiles and generating reports on page 252
l Submitting CDRs to a database on page 306
l Configuring SMDR on page 308
l Configuring alert email on page 310

About FortiVoice logging

FortiVoice systems can log multiple events. See FortiVoice log types on page 297.
You can select which severity level an activity or event must meet in order to be recorded in the logs. For more
information, see Log message severity levels on page 298.
A FortiVoice system can save log messages to its hard disk or a remote location, such as a Syslog server or a
FortiAnalyzer™ system. For more information, see Configuring logging on page 299. It can also use log messages as
the basis for reports. For more information, see Configuring call center report profiles and generating reports on page
252.

This topic includes:

l FortiVoice log types on page 297
l Log message severity levels on page 298

FortiVoice log types

FortiVoice systems can record the following types of log messages. The Event log also contains several subtypes. You
can view these logs fromMonitor > Log.

Log types

Log type Subtype Description

System Configuration
Administration

Includes system and administration events, such as downloading a
backup copy of the configuration.
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Log type Subtype Description

System
HA
DHCP
Monitor
Web mail
DNS

Also includes voicemail, FortiVoice systemmonitoring, and DNS
events.

Generic SMTP
Activity

Includes SMTP server events.

Voice Includes phone call events.

Fax Includes fax events.

DTMF Includes DTMF (Dual Tone Multi-Frequency) events.

Hotel Includes hotel management events, such as guest check-in and
check-out.

Call Center IVR Includes call center IVR events.

AGT Includes call center agent events.

Avoid recording highly frequent log types such as voice logs to the local hard disk for an
extended period of time. Excessive logging frequency can cause undue wear on the hard disk
and may cause premature failure.

Log message severity levels

Each log message contains a field that indicates the severity level of the log message, such as warning.
Log severity levels

Levels Description

0 - Emergency Indicates the system has become unusable.

1 - Alert Indicates immediate action is required.

2 - Critical Indicates functionality is affected.

3 - Error Indicates an error condition exists and functionality could be affected.

4 - Warning Indicates functionality could be affected.

5 - Notification Provides information about normal events.

6 - Information Provides general information about system operations.

6 - Debug Provides information useful to debug a problem.
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For each location where the FortiVoice system can store log files, you can define the severity threshold of the log
messages to be stored there.

Avoid recording log messages using low severity thresholds such as Information or
Notification to the local hard disk for an extended period of time. A low log severity threshold is
one possible cause of frequent logging. Excessive logging frequency can cause undue wear
on the hard disk and may cause premature failure.

The FortiVoice system stores all log messages equal to or exceeding the severity level you select. For example, if you
select Error, the FortiVoice system stores log messages whose severity level is Error, Critical, Alert, or Emergency.

Configuring logging

The Log Setting submenu includes two tabs, Local and Remote, that let you:
l set the severity level
l configure which types of log messages to record
l specify where to store the logs

You can configure the FortiVoice system to store log messages locally (that is, in RAM or to the hard disk), remotely (that
is, on a Syslog server or FortiAnalyzer system), or at both locations.
Your choice of storage location may be affected by several factors, including the following:
l Local logging by itself may not satisfy your requirements for off-site log storage.
l Very frequent logging may cause undue wear when stored on the local hard drive. A low severity threshold is one
possible cause of frequent logging. For more information on severity levels, see Log message severity levels on
page 298.

For information on viewing locally stored log messages, see Viewing log messages on page 37.
This section includes the following topics:
l Configuring logging to the hard disk on page 299
l Choosing which events to log on page 300
l Configuring logging to a Syslog server or FortiAnalyzer system on page 301

Configuring logging to the hard disk

You can store log messages locally on the hard disk of the FortiVoice system.
To ensure that the local hard disk has sufficient disk space to store new log messages and that it does not overwrite
existing logs, you should regularly download backup copies of the oldest log files to your management computer or other
storage, and then delete them from the FortiVoice system. (Alternatively, you could configure logging to a remote host.)
You can view and download these logs from the Log submenu of theMonitor tab. For more information, see Viewing log
messages on page 37.
For logging accuracy, you should also verify that the FortiVoice system’s system time is accurate. For details, see
Configuring the time and date on page 76.

To configure logging to the local hard disk

1. Go to Log & Report > Log Setting > Local.
2. Select the Enabled option to allow logging to the local hard disk.
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3. In Log file size, enter the file size limit of the current log file in megabytes (MB). The log file size limit must be
between 10 MB and 1000 MB.

4. In Log time, enter the time (in days) of file age limit.
5. In At hour, enter the hour of the day (24-hour format) when the file rotation should start.

When a log file reaches either the age or size limit, the FortiVoice system rotates the current log file: that is, it
renames the current log file (elog.log) with a file name indicating its sequential relationship to other log files of that
type (elog2.log, and so on), then creates a new current log file. For example, if you set the log time to 10 days at
hour 23, the log file will be rotated at 23 o’clock of the 10th day.

Large log files may decrease display and search performance.

6. From Log level, select the severity level that a log message must equal or exceed in order to be recorded to this
storage location.

7. From Log options when disk is full, select what the FortiVoice system will do when the local disk is full and a new log
message is caused, either:
l Do not log: Discard all new log messages.
l Overwrite: Delete the oldest log file in order to free disk space, and store the new log message.

8. In Logging Policy Configuration, click the arrow to review the options and enable the types of logs that you want to
record to this storage location. For details, see Choosing which events to log on page 300.

9. Click Apply.

Choosing which events to log

Both the local and remote server configuration recognize the following events. Select the check boxes of the events you
want to log.

Events logging options

System Select this check box and then select specific system logs. No system types are
logged unless you enable this option.
l Configuration change: Log configuration changes.
l Admin activity: Log all administrative events, such as logins, resets, and
configuration updates.

l System activity: Log all system-related events, such as rebooting the
FortiVoice system.

l HA: Log all high availability (HA) activity.
l DHCP: Log DHCP server events.
l Monitor: Log call recording, call barging, and traffic capture events.
l Voice mail: Log voicemail events.
l DNS: Log DNS events.

Generic Select this check box and then select specific events. No event types are logged
unless you enable this option.
l SMTP: Log SMTP relay or proxy events.
l Activity: Log voice user login and logout events.
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Voice Logs phone call events.

Fax Logs fax events.

DTMF (Enhanced CDR) Logs Dual Tone Multi-Frequency events.
This option is for local log setting only.

Hotel Logs hotel management events, such as guest check-in and check-out.
This option is for local log setting only and available if the FortiVoice system has a
hotel license.

Call Center Logs call center events, such as IVR and agent events.
This option is for local log setting only and available if the FortiVoice system has a
call center license.

Configuring logging to a Syslog server or FortiAnalyzer system

Instead of or in addition to logging locally, you can store log messages remotely on a Syslog server or a FortiAnalyzer
system.
You can add a maximum of three remote Syslog servers.

Logs stored remotely cannot be viewed from the GUI of the FortiVoice system. If you require
the ability to view logs from the GUI, also enable local storage. For details, see Configuring
logging to the hard disk on page 299.

Before you can log to a remote location, you must first enable logging. For details, see Choosing which events to log on
page 300. For logging accuracy, you should also verify that the FortiVoice system’s system time is accurate. For details,
see Configuring the time and date on page 76.

To configure logging to a Syslog server or FortiAnalyzer system
1. Go to Log & Report > Log Setting > Remote.
2. Click New to create a new entry or double-click an existing entry to modify it.

GUI field Description

Log to Remote Host

Enable Select to allow logging to a remote host.

Name Enter a name for the remote host.

IP Enter the IP address of the Syslog server or FortiAnalyzer system where
the FortiVoice system will store the logs.

Port If the remote host is a FortiAnalyzer system, enter 514; if the remote host
is a Syslog server, enter the UDP port number on which the Syslog
server listens for connections (by default, UDP 514).

Level Select the severity level that a log message must equal or exceed in
order to be recorded to this storage location.
For information about severity levels, see Log message severity levels
on page 298.
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GUI field Description

Facility Select the facility identifier that the FortiVoice system will use to identify
itself when sending log messages.
To easily identify log messages from the FortiVoice system when they
are stored on a remote logging server, enter a unique facility identifier,
and verify that no other network devices use the same facility identifier.

CVS format Enable this option if you want to send log messages in comma-
separated value (CSV) format.

Do not enable this option if the remote host is a FortiAnalyzer system.
FortiAnalyzer systems do not support CSV-formatted log messages.

Logging Policy Configuration Click the arrow to review the options and enable the types of logs you
want to record to this storage location. For details, see Choosing which
events to log on page 300.

3. Click Create.
4. If the remote host is a FortiAnalyzer system, confirm with the FortiAnalyzer administrator that the FortiVoice system

was added to the FortiAnalyzer system’s device list, allocated sufficient disk space quota, and assigned permission
to transmit logs to the FortiAnalyzer system. For details, see the FortiAnalyzer Administration Guide.

5. To verify logging connectivity, from the FortiVoice system, trigger a log message that matches the types and
severity levels that you have chosen to store on the remote host. Then, on the remote host, confirm that it has
received that log message.
For example, if you have chosen to record event log messages to the remote host and if they are more severe than
Information, you could log in to the GUI or download a backup copy of the FortiVoice system’s configuration file in
order to trigger an event log message.
If the remote host does not receive the log messages, verify the FortiVoice system’s network interfaces (see
Configuring the network interfaces on page 44 and About the management IP on page 43) and static routes (see
Configuring static routes on page 47), and the policies on any intermediary firewalls or routers. If ICMP ECHO (ping)
is enabled on the remote host, you can use the execute traceroute command to determine the point where
connectivity fails.

Configuring report profiles and generating reports

The Log & Report > Call Report > Call Report tab displays a list of call center report profiles.
A report profile is a group of settings that contains the report name, its subject matter, its schedule, and other aspects
that the FortiVoice system considers when generating reports from call center log data. The FortiVoice system presents
the information in tabular and graphical format.
You can create one report profile for each type of report that you will generate on demand or on a schedule.

Generating reports can be resource intensive. To avoid phone processing performance
impacts, you may want to generate reports during times with low traffic volume, such as at
night. For more information on scheduling the generation of reports, see Configuring report
email notifications on page 304.

To view and configure report profiles
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1. Go to Log & Report > Call Report > Call Report.

GUI field Description

Generate Select a report and click this button to generate a report immediately. See
Generating a report manually on page 305.

View Report Click to display the list of reports generated by the FortiVoice system. You can
delete, view, and/or download generated reports. For more information, see Viewing
generated reports on page 36.

Report Name Displays the name of the report profiles.

Schedule Displays the frequency with which the FortiVoice system generates a scheduled
report. If the report is designed for manual generation, Not Scheduled appears in this
column.

2. Click New to add a profile or double-click a profile to modify it.
3. In Name, enter a name for the report profile.

Report names cannot include spaces.
4. Enter the Time period for the report.
5. Click the arrow next to each option, and configure the following as needed:

l Configuring the report query selection on page 303
l Configuring the report query selection on page 303
l Configuring the report query selection on page 303
l Configuring report profiles and generating reports on page 302
l Generating a report manually on page 305

6. Click Create.

Configuring the report query selection

When configuring a report profile, you can select the queries that define the subject matter of the report.
Each report profile corresponds to a chart that will appear in the generated report.

To configure the report query selection

1. Go to Log & Report > Call Report > Call Report.
2. Click New.
3. ExpandQuery List and click New.
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4. Configure the following:

GUI field Description

Name Enter a name for this query.

Category Select a query type for the report profile. The report chart will correspond to the
type selected.

Subcategory Select a sub query type for the report profile. The report chart will correspond
to the type selected.

From Select to include the source of the incoming calls: Internal, External, or Any.

To Select to include the source of the outgoing calls: Internal, External, or Any.

Region Select the call region, such as international or long-distance.

Report column Select the source of the call statistics: from caller or receiver.

Sort column Select the value for filtering the call information. The caller or receiver with the
higher value moves to the top of the table.
If you select Report column, the sort column value is equal to what you select
in the Report column field.

5. Click Create.

Configuring report email notifications

When configuring a report profile, you can have the FortiVoice system email an attached copy of the generated report, in
either HTML or PDF file format, to designated recipients.

You can customize the report email notification. For more information, see Customizing call report and notification email
templates on page 111.

To configure an email notification

1. Go to Log & Report > Call Report > Call Report.
2. Expand Email.
3. In the Format field, select the format of the generated attachment, either HTML, PDF , CSV ZIP, or CSV.
4. Enter the email address of the person who will receive the report notification in the Email address field and click >>

to add it. Enter more email addresses if necessary. Select an email address and click << to remove it.

Configuring the report schedule

When configuring a report profile, you can select when the report will generate. Or, you can leave it unscheduled and
generate it on demand. See Generating a report manually on page 305.

To configure the report schedule
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1. Go to Log & Report > Call Report > Call Report.
2. Expand Schedule.
3. Configure the following:

GUI field Description

Type l None: Select if you do not want the FortiVoice system to generate the report
automatically according to a schedule. If you select this option, the report can
only be generated on demand. See Generating a report manually on page
305.

l Daily: Select to generate the report each day. Also configure Hour.
l Weekdays: Select to generate the report on specific days of each week, then
select those days in These weekdays. Also configure Hour.

l These Dates: Select to generate the report on specific date of each month,
then enter those date numbers in These days. Also configure Hour.

You can choose the call rate for calculating the phone bills. For information on setting the call rates, see Configuring
report profiles and generating reports on page 302.

To choose the call rate

1. Go to Log & Report > Call Report > Call Report.
2. Expand Rate Setting.
3. Click + and select an available rate.

Only one call rate is allowed per report.
4. Click Close.

Generating a report manually

You can always generate a report on demand whether the call center report profile includes a schedule or not.

To manually generate a report
1. Go to Log & Report > Call Report > Call Report.
2. Click to select the report profile whose settings you want to use when generating the report.
3. ClickGenerate.

The FortiVoice system immediately begins to generate a report. To view the resulting report, see Viewing generated
reports on page 36.

The Log & Report > Call Report > Rate tab lets you set call rates for calculating phone bills.

To set call rates

1. Go to Log & Report > Call Report > Rate and click New.
2. Configure the following:

GUI field Description

Name Enter a name for the rating profile.

Trunk Select the trunk that will use the rates.
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GUI field Description

Local Enter the rate for local phone calls.

Long distance Enter the rate for long-distance phone calls.

International Enter the rate for international phone calls.

Other rate Enter the rate for other types of phone calls.

Comment Click the Edit icon to enter any notes.

3. Click Create.

Submitting CDRs to a database

If you have a remote third party database, you may submit the Call Detail Records (CDR) to the database. Each CDR
contains the full life cycle of a call. Using the database’s interface, you can display and review the CDRs.

This section includes the following topics:
l Configuring CDR submission on page 306
l Modifying CDR templates on page 308
l Creating CDR filters on page 308

Configuring CDR submission

The Log & Report > CDR > Submit CDR submenu lets you configure sending CDR to a database. The configuration
values should match those of the database server.

To submit a CDR

1. Go to Log & Report > CDR > Submit CDR.
2. Click New and configure the following:

GUI field

Name Enter a name for the configuration.

Status Select to enable the configuration.

Description Click to enter any notes you have for the configuration.

Remote RESTful Server Configure the database to which CDRs are submitted. For more
information, see Configuring RESTful service on page 244.

Protocol Select the protocol used for information transmission between the
FortiVoice system and the database server.
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GUI field

HTTP headers Select Click to edit to enter a HTTP header for sending information
to the database server.

HTTP timeout Enter the time allowed for the submission to be processed. The
range is 1-60 minutes.

Authentication Password: Select to enter the user name and password for logging
onto the restful server.
l Username: Enter the login user name registered on the restful
server.

l Password: Enter the login password registered on the restful
server.

l URL: Enter the URL of the server hosting restful service.
l SSL verification: Select if required.

OAuth: Select to use Open Authorization to access the restful
server without exposing your account credential.
l Service format: Select Salesforce or other restful services
configuration format.

l Username: Enter the login user name registered on the restful
server.

l Password: Enter the login password registered on the restful
server.

l Login server: Enter the IP address of the restful server.
l Client ID: Enter the consumer key from the restful server.
l Client secret: Enter the consumer secret from the restful
server. If you choose Salesforce as Service Format, enter the
consumer key and the token from the server in the format of
<consumer key><token>.

l URL suffix: Enter the Salesforce object name, for example,
/query/, and clickGet Salesforce API URI to populate the Base
URL field. Note the leading and trailing "/" must be entered
before and after the object name.
This option is only available if you choose Salesforce for
Service format.

l URL: Enter the URL of the server hosting restful service.
l SSL verification: Select if required.

Options

CDR template Click Edit to customize the default CDR submission template
based on the requirements of the database server. ClickOK when
it is done.
For more information, see Modifying CDR templates on page 308.

CDR filter Choose or create a new CDR filter to screen CDRs submitted to
the database. For more information, see Creating CDR filters on
page 308.

Custom Value Click New to add a custom value (a token, for example) that is
required by the database server for information exchange.
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3. Click Create.

Modifying CDR templates

When configuring CDR submission, you need to customize the default CDR submission template based on the
requirements of the database server.

To modify a CDR template

1. Go to Log & Report > CDR > CDR Template.
2. Select the default CDR template and click Edit.
3. Modify the template and clickOK.

Creating CDR filters

You can use filters to limit the amount of CDRs submitted to the database.

To create a CDR filter

1. Go to Log & Report > CDR > CDR Filter.
2. Click New.
3. Enter a name for the filter.
4. Using XML, enter the CDR filters based on the values you want, such as call queues or call IDs. See the sample

filter under Log & Report > CDR > CDR Filter.
5. For Description, enter any notes you have for the filter.
6. Click Create.

Configuring SMDR

The FortiVoice Station Messaging Detail Recording (SMDR) component provides FortiVoice call detail records to third-
party devices on certain communication and format protocols based on third-party's device requirements. For example,
the Property Management System (PMS) uses the FortiVoice SMDR to manage hotel guest call charges.

Configuring FortiVoice SMDR requires advanced SMDR knowledge and should be performed
by advanced administrative users and field engineers.

This section contains the following topics:

l Configuring SMDR settings on page 308
l Setting SMDR formats on page 309

Configuring SMDR settings

Configure SMDR settings to enable the FortiVoice communications with third-party devices.

To configure SMDR settings
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1. Go to Log & Report > SMDR > SMDR.
2. Select Enabled to activate the FortiVoice SMDR function.
3. Select a format protocol for the FortiVoice communications with the third-party devices.

For information on format, see Setting SMDR formats on page 309.
4. For Port, enter the port number that connects to the third-party devices.
5. ForMax clients, enter the number of third-party devices to which the FortiVoice system provides SMDR. The range

is 1-10.
6. For Trusted hosts, enter the IP address and netmask of the third-party device.

If you have multiple third-party devices, you may enter up to 10 trusted hosts.
7. Click Apply.

Setting SMDR formats

To communicate with third-party devices, the FortiVoice SMDR format needs to be defined based on the device
requirements so that the devices can recognize the FortiVoice SMDR.

The FortiVoice system provides example XML SMDR format files. You can modify the files to meet with your needs. The
following is an example format file:

Example SMDR format file

An SMDR format is composed of parts as shown in the above example:

l smdr_type id: the name of the SMDR format file.
l discard_filter: the data you do not want to send to the third-party devices.
l formatting: the body of the SMDR format file in the form of field values (for example, <field name="AnswerTime"/>),
plus the field lengths (for example, length="13") required by the third-party devices.

To set a SMDR format

1. Go to Log & Report > SMDR > SMDR Format.
2. Click New.
3. Click FortiVoice SMDR field to display the complete list of FortiVoice SMDR field names.
4. Enter a name and description for the format.
5. For Content derived from, select an existing format as a base for configuring the new format.
6. In the Content field, follow the SMDR format requirements of the third-party device and the example format file

above, choose the displayed FortiVoice field names you need to set your SMDR format.
7. Click Create.
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8. If errors appear, click SMDR XML Types to view the Fortinet SMDR format file and correct your format file
accordingly.

Configuring alert email

The Alerts submenu lets you configure the FortiVoice system to notify selected users (including administrators) by email
when specific types of events occur and are logged. For example, if you require notification about system activity event
detections, you can have the FortiVoice system send an alert email message whenever the FortiVoice system detects a
system activity event.

To set up alerts, you must configure both the alert email recipients (see Configuring alert recipients on page 310) and
which event categories will trigger an alert email message (see Configuring alert categories on page 311).

Alert email messages also require that you supply the FortiVoice system with the IP address of at least one DNS server.
The FortiVoice system uses the domain name of the SMTP server to send alert email messages. To resolve this domain
name into an IP address, the FortiVoice systemmust be able to query a DNS server. For information on DNS, see
Configuring DNS on page 48.

You can customize the alert email. For more information, see Customizing call report and notification email templates on
page 111.

This section contains the following topics:

l Configuring alert recipients on page 310
l Configuring alert categories on page 311

Configuring alert recipients

Before the FortiVoice system can send alert email messages, you must create a recipient list.

To configure recipients of alert email messages

1. Go to Log & Report > Alert > Configuration.

GUI field Description

Test
(button)

Clicking on the button will send a test alert email to all configured recipients in
the list.

Alert Email Account Displays the names of email accounts receiving email alerts.

2. Click New to add the email address of a recipient.
A single-field dialog appears.

3. In Email to, enter a recipient email address.
4. Click Create.
5. To add more users, repeat the previous steps.
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Configuring alert categories

Before the FortiVoice system can send alert email messages, you must specify which events cause the FortiVoice
system to send an alert email message to your list of alert email recipients (see Configuring alert recipients on page
310).

To select events that will trigger an alert email message

1. Go to Log & Report > Alert > Category.
2. Enable one or more of the following event categories:

GUI field Description

Critical events Send an alert email message when the FortiVoice system detects a system
error that may affect its operation.

Disk is full Send an alert email message when the hard disk of the FortiVoice system is
full.

HA events Send an alert email message when any high availability (HA) event occurs.

Archive quota is exceeded Send an alert email message when the recorded call archiving account
reaches its quota of hard disk space. For information about recorded call
archiving account quota, see Archiving recorded calls on page 273.

Deferred emails # over Send an alert email message if the deferred email queue contains greater than
this number of email messages. Enter a number between 1 and 10 000 to
define the alert threshold, then enter the interval of time between each alert
email message that the FortiVoice system will send while the number of email
messages in the deferred email queue remains over this limit.

RESTful service alert Send an alert email message if the RESTful server does not respond to
FortiVoice inquiries. Enter the interval of time between each alert email
message that the FortiVoice system will send while the RESTful server does
not respond to FortiVoice inquiries.

Generate daily call summary at
hour

Send an alert email with a daily call summary including the number of total
calls, long distance calls, and international calls.
You need to enter the time for generating the summary which is for the 24
hours period prior to the time you set. For example, if you set 09:00, the
summary will be for the period from 9 am of the previous day to 9 am of the day
when you receive the alert email.

PRI alarm Send an alert email when the PSTN digital line has a problem.
This option is not available for every FortiVoice model.

FXO alarm Send an alert email when the PSTN analog line has a problem.
This option is not available for every FortiVoice model.

Trunk lines are saturated Send an alert email when the SIP/PSTN/PRI trunk lines are fully occupied.
SIP trunk alert only works if you selectOverflow check when configuring SIP
trunk. See Configuring VoIP trunks on page 200.
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GUI field Description

Massive SIP authentication
failure

Send an alert email when big scale SIP authentication sessions fail.

Daily Security Audit report Send an alert email with a daily security audit. For more information about the
details included in the security report, see Checking the system security on
page 23.

SIP trunk/office peer
connectivity alert

Select the trunks of which an alert email is sent when a trunk has an issue.
Also set the time interval for sending alert email in seconds.

3. Click Apply.
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Fortinet periodically releases FortiVoice firmware updates to include enhancements and resolve specific issues. Fortinet
recommends that you download and install patch releases as soon as they are available.

For information about new and changed features, supported upgrade paths, and resolved issues included in a
FortiVoice firmware version, see the Release Notes.

This section includes the following topics:

l Downloading the firmware image file on page 313
l Testing a firmware image on page 313
l Upgrading the firmware on page 315
l Downgrading the firmware on page 317
l Performing a clean firmware installation on page 320

Downloading the firmware image file

Access the Fortinet Support website and download the firmware image file for the version that you want to upgrade to.

Before you can download firmware updates for your FortiVoice system, you must first
complete the product registration with Fortinet Support. For details, see the Registering a
FortiVoice product section in the FortiVoice Cookbook.

To download the firmware image file

1. Go to the Fortinet Support website.
2. Log in to your existing account or register for an account.
3. Select Support > Firmware Download.
4. In Select Product, select FortiVoice.
5. Select the Download tab and navigate to the folder for the firmware version that you are upgrading to.
6. To download the firmware image file to your management computer, go to the end of the row and click HTTPS.
7. Save the file on your management computer.
8. Take note of the location where you save the file.

Testing a firmware image

You can test a new firmware image by temporarily running it from memory, without saving it to disk. By keeping your
existing firmware on disk, if the evaluation fails, you do not have to re-install your previous firmware. Instead, you can
quickly revert to your existing firmware by simply rebooting the FortiVoice system.
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To test a new firmware image

1. Connect your management computer to the FortiVoice console port using an RJ-45 to DB-9 serial cable or a null-
modem cable.

2. Initiate a connection from your management computer to the CLI of the FortiVoice system.
3. Connect port1 of the FortiVoice system directly or to the same subnet as a TFTP server.
4. Copy the new firmware image file to the root directory of the TFTP server.
5. Verify that the TFTP server is currently running, and that the FortiVoice system can reach the TFTP server.

To use the FortiVoice CLI to verify connectivity, enter the following command:
execute ping 192.168.2.99

where 192.168.2.99 is the IP address of the TFTP server.
6. Enter the following command to restart the FortiVoice system:

execute reboot

You have only 3 seconds to press a key. If you do not press a key soon enough, the
FortiVoice system reboots and you must log in and repeat the execute reboot
command.

7. As the FortiVoice systems starts, a series of system startup messages are displayed.
Press any key to display configuration menu........

8. Immediately press a key to interrupt the system startup.
If you successfully interrupt the startup process, the following messages appears:
[G]: Get firmware image from TFTP server.

[F]: Format boot device.

[B]: Boot with backup firmware and set as default.

[I]: Configuration and information.

[Q]: Quit menu and continue to boot with default firmware.

[H]: Display this list of options.

Enter G,F,B,I,Q,or H:

9. Type G to get the firmware image from the TFTP server.
The following message appears:

Enter TFTP server address [192.168.2.99]:

10. Type the IP address of the TFTP server and press Enter.
The following message appears:

Enter Local Address [192.168.2.99]:

11. Type a temporary IP address that can be used by the FortiVoice system to connect to the TFTP server.
The following message appears:

Enter File Name [image.out]:

12. Type the firmware image file name and press Enter.
The FortiVoice system downloads the firmware image file from the TFTP server and displays a message similar to
the following:

Save as Default firmware/Backup firmware/Run image without saving:[D/B/R]

13. Type R.
The FortiVoice image is loaded into memory and uses the current configuration,without saving the new firmware
image to disk.
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14. To verify that the new firmware image has been loaded, log in to the CLI and type:
get system status

15. Test the new firmware image.
l If the new firmware image operates successfully, you can install it to disk, overwriting the existing firmware,
using the procedure Upgrading the firmware on page 315.

l If the new firmware image does not operate successfully, reboot the FortiVoice system to discard the
temporary firmware and resume operation using the existing firmware.

Upgrading the firmware

Before upgrading the firmware of the FortiVoice system, review the Release Notes for the new
firmware version. The Release Notes document includes the most current upgrade
information such as the supported upgrade path and may contain details that were unavailable
at the time this guide was created.
Older versions of the firmware may not be supported by the configuration upgrade scripts that
are used by the newest firmware. As a result, you may need to upgrade to an intermediate
version of the firmware first, before upgrading to your intended version.

You can use either the GUI or the CLI to upgrade the firmware of the FortiVoice system.

Administrators whose access profile contains Read-Write access in theOthers category, such as the admin
administrator, can change the FortiVoice firmware version. For more details about the administrator profiles, see
Configuring administrator profiles on page 54.

To determine if you are upgrading your firmware image, examine the firmware version number. For example, if your
current firmware version is v6.0.10, build280, 2021-10-14 and you are changing it to v6.0.11, build285,2022-03-28 which
is a later build number and date, then you are upgrading the firmware image.

To upgrade the firmware using the GUI

1. Download the firmware image files from the Fortinet Support website. For details, see Downloading the firmware
image file on page 313.

2. Back up the configuration and call data. For details, see Backing up configuration on page 103.
3. Log in to the GUI as the admin administrator, or an administrator account that has system configuration read and

write privileges.
4. To upload the firmware for an upgrade:

a. Go to Dashboard > Status.
b.  In the System Information widget, go to Firmware version and click Update.
c.  Locate the file and clickOpen.
d. To confirm the upload, click Yes.

Your web browser uploads the firmware file to the FortiVoice system. The FortiVoice system installs the
firmware and restarts. Time required varies by the size of the file and the speed of your network connection.

5. Clear the cache of your web browser and restart it to ensure that it reloads the GUI and correctly displays all
changes.

6. To verify that the firmware was successfully installed, log in to the GUI and go toMonitor > System Status > Status.
Text appearing in the Firmware version row indicates the currently installed firmware version.

7. Go to Verifying the configuration after an upgrade on page 316.
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To upgrade the firmware using the CLI

1. Download the firmware image files from the Fortinet Support website. For details, see Downloading the firmware
image file on page 313.

2. Back up the configuration and call data. For details, see Backing up configuration on page 103.
3. Connect your management computer to the FortiVoice console port using an RJ-45 to DB-9 serial cable or a null-

modem cable.
4. Initiate a connection from your management computer to the CLI of the FortiVoice system, and log in as the admin

administrator, or an administrator account that has system configuration read and write privileges.
5. Connect port1 of the FortiVoice system directly or to the same subnet as a TFTP server.
6. Copy the new firmware image file to the root directory of the TFTP server.
7. Verify that the TFTP server is currently running, and that the FortiVoice system can reach the TFTP server.

To use the FortiVoice CLI to verify connectivity, enter the following command:
execute ping 192.168.2.99

where 192.168.2.99 is the IP address of the TFTP server.
8. Enter the following command to download the firmware image from the TFTP server to the FortiVoice system:

execute restore image tftp <name_str> <tftp_ipv4>

where <name_str> is the name of the firmware image file and <tftp_ipv4> is the IP address of the TFTP server.
For example, if the firmware image file name is image.out and the IP address of the TFTP server is
192.168.2.99, enter:
execute restore image tftp image.out 192.168.2.99

One of the following messages appears:
This operation will replace the current firmware version!

Do you want to continue? (y/n)

9. Type y.
The FortiVoice system downloads the firmware image file from the TFTP server. The FortiVoice system installs the
firmware and restarts. Time required varies by the size of the file and the speed of your network connection.

10. If you also use the GUI, clear the cache of your web browser and restart it to ensure that it reloads the GUI and
correctly displays all tab, button, and other changes.

11. To verify that the firmware was successfully installed, log in to the CLI and type:
get system status

12. Go to Verifying the configuration after an upgrade on page 316.

Verifying the configuration after an upgrade

After upgrading to a new firmware image, verify that the configuration has been successfully converted to the format
required by the new firmware and that no configuration data has been lost.

In addition to verifying the successful conversion, verifying the configuration also provides familiarity with new and
changed features.

To verify the configuration upgrade

1. Clear your web browser’s cache and refresh the login page of the GUI.
2. Log in to the GUI using the admin administrator account.

Other administrator accounts may not have sufficient privileges to completely review the configuration.
3. Review the configuration and compare it with your configuration backup to verify that the configuration has been

correctly converted.
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Downgrading the firmware

Downgrading the firmware is not recommended.

The downgrade process may cause the FortiVoice system to remove parts of the configuration
that are invalid for that earlier version.
After downgrading the firmware, you may be unable to restore your previous configuration
from the backup configuration file.
In some cases, you may lose all call data and configurations.

Administrators whose access profile contains Read-Write access in theOthers category, such as the admin
administrator, can change the FortiVoice firmware version. For more details about the administrator profiles, see
Configuring administrator profiles on page 54.

To determine if you are downgrading your firmware image, examine the firmware version number. For example, if your
current firmware version is v6.0.11, build285,2022-03-28 and you are changing it to an earlier build number and date
v6.0.10, build280, 2021-10-14, then you are downgrading the firmware image.

To downgrade to an earlier firmware version using the GUI

1. Download the firmware image files from the Fortinet Support website. For details, see Downloading the firmware
image file on page 313.

2. Back up the configuration and call data. For details, see Backing up configuration on page 103.
3. Log in to the GUI as the admin administrator, or an administrator account that has system configuration read and

write privileges.
4. To upload the firmware for a downgrade:

a. Go to Dashboard > Status.
b.  In the System Information widget, go to Firmware version and click Update.
c.  Locate the file and clickOpen.
d. To confirm the upload, click Yes.

Your web browser uploads the firmware file to the FortiVoice system. The FortiVoice system installs the
firmware and restarts. Time required varies by the size of the file and the speed of your network connection.
 The FortiVoice system reverts the configuration to default values for that version of the firmware.

5. Reconnect to the FortiVoice system to either reconfigure the FortiVoice system or restore the configuration file. For
details, see Reconnecting to the FortiVoice system on page 318 and Restoring the configuration on page 319.

6. To verify that the firmware was successfully installed, log in to the GUI and go toMonitor > System Status > Status.
Text appearing in the Firmware version row indicates the currently installed firmware version.

To downgrade to an earlier firmware version using the CLI

1. Download the firmware image files from the Fortinet Support website. For details, see Downloading the firmware
image file on page 313.

2. Back up the configuration and call data. For details, see Backing up configuration on page 103.
3. Connect your management computer to the FortiVoice console port using an RJ-45 to DB-9 serial cable or a null-

modem cable.
4. Initiate a connection from your management computer to the CLI of the FortiVoice system, and log in as the admin

administrator, or an administrator account that has system configuration read and write privileges.
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5. Connect port1 of the FortiVoice system directly or to the same subnet as a TFTP server.
6. Copy the new firmware image file to the root directory of the TFTP server.
7. Verify that the TFTP server is currently running, and that the FortiVoice system can reach the TFTP server.

To use the FortiVoice CLI to verify connectivity, enter the following command:
execute ping 192.168.2.99

where 192.168.2.99 is the IP address of the TFTP server.
8. Enter the following command to download the firmware image from the TFTP server to the FortiVoice system:

execute restore image tftp <name_str> <tftp_ipv4>

where <name_str> is the name of the firmware image file and <tftp_ipv4> is the IP address of the TFTP server.
For example, if the firmware image file name is image.out and the IP address of the TFTP server is
192.168.2.99, enter:
execute restore image tftp image.out 192.168.2.99

The following messages appears:
Get image from tftp server OK.

Check image OK.

This operation will downgrade the current firmware version!

Do you want to continue? (y/n)

9. Type y.
The FortiVoice system downloads the firmware image file from the TFTP server. The FortiVoice system installs the
firmware and restarts. Time required varies by the size of the file and the speed of your network connection.
The FortiVoice system reverts the configuration to default values for that version of the firmware. You must either
reconfigure the FortiVoice system or restore the configuration file.

10. To verify that the firmware was successfully installed, log in to the CLI and type:
get system status

11. Reconnect to the FortiVoice system using its default IP address for port1, 192.168.1.99, and restore the
configuration file. For details, see Reconnecting to the FortiVoice system on page 318 and Restoring the
configuration on page 319.

Reconnecting to the FortiVoice system

After a firmware downgrade, the FortiVoice system reverts to default settings for the installed firmware version, including
the IP addresses of network interfaces through which you connect to the FortiVoice GUI and/or CLI.

Perform the following steps to configure the network interface IP address and access protocols to allow you to connect to
the FortiVoice system.

If your FortiVoice system has not been reset to its default configuration, but you cannot
connect to the GUI or CLI, you can restore the firmware, resetting the FortiVoice system to its
default configuration in order to reconnect using the default network interface IP address. For
more information, see Performing a clean firmware installation on page 320.

To reconnect using the CLI

1. Connect your management computer to the FortiVoice console port using an RJ-45 to DB-9 serial cable or a null-
modem cable.

2. Start a terminal emulation software such as PuTTY.
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3. Configure the terminal emulation software to connect directly to the communications (COM) port on your computer
and clickOK.

4. Use the following serial connection settings: 

Bits per second 9600

Data bits 8

Parity None

Stop bits 1

Flow control None

5. Start a serial connection to connect to the FortiVoice CLI.
The login prompt appears.

6. Type admin and press Enter twice.
The following prompt appears:
Welcome!

7. Enter the following command:
set system interface <interface_str> mode static ip <address_ipv4> <mask_ipv4>

where:
l <interface_str> is the name of the network interface, such as port1
l <address_ipv4> is the IP address of the network interface, such as 192.168.1.10
l <mask_ipv4> is the netmask of the network interface, such as 255.255.255.0

8. Enter the following command:
set system interface <interface_str> config allowaccess <accessmethods_str>

where:
l <interface_str> is the name of the network interface configured in the previous step, such as port1
l <accessmethods_str> is a space-delimited list of the administrative access protocols that you want to allow
on that network interface, such as ping ssh https

The network interface’s IP address and netmask is saved. You can now reconnect to either the GUI or CLI through
that network interface. For information on restoring the configuration, see Restoring the configuration on page 319.

Restoring the configuration

After a firmware downgrade or clean firmware installation, you may be able to restore a backup copy of the configuration
file from your local computer using either the GUI or CLI. For information about configuration backup, see Backing up
configuration on page 103.

To restore the configuration file using the GUI

1. Clear your web browser’s cache. If your browser is currently displaying the login page of the GUI, also refresh the
page.

2. Log in to the GUI.
3. Go to System > Maintenance > Configuration.
4. Under Restore Configuration, locate and select the configuration file that you want to restore, then clickOpen.
5. To confirm, click Yes.

The FortiVoice system restores the configuration file and reboots. Time required varies by the size of the file and the
speed of your network connection.
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6. After restoring the configuration file, verify that the configuration settings have been successfully loaded.

To restore the configuration file using the CLI

1. Initiate a connection from your management computer to the CLI of the FortiVoice system, and log in as the admin
administrator, or an administrator account that has system configuration read and write privileges.

2. Connect a network interface of the FortiVoice system directly or to the same subnet as a TFTP server.
3. Copy the new firmware image file to the root directory of the TFTP server.
4. Verify that the TFTP server is currently running, and that the FortiVoice system can reach the TFTP server.

To use the FortiVoice CLI to verify connectivity, enter the following command:
execute ping 192.168.2.99

where 192.168.2.99 is the IP address of the TFTP server.
5. Enter the following command:

execute restore config tftp <file_name> <tftp_ipv4>

The following message appears:
This operation will overwrite the current Setting!

(The current admin password will be preserved.)

Do you want to continue? (y/n)

6. Enter y.
The FortiVoice system restores the configuration file and reboots. Time required varies by the size of the file and the
speed of your network connection.

7. After restoring the configuration file, access the GUI to verify that the configuration settings have been successfully
loaded.

Performing a clean firmware installation

Performing a clean firmware installation can be useful if:

l You are unable to connect to the FortiVoice system using the GUI or the CLI.
l You want to install firmwarewithout preserving any existing configuration.
l A firmware version that you want to install requires that you format the boot device (see the Release Notes
accompanying the firmware).

Unlike a firmware upgrade or downgrade, a clean firmware installation re-images the boot device. Also, a clean firmware
installation can only be done during a boot interruption, before the network connectivity is available, and therefore
requires a local console connection to the CLI. A clean firmware installation cannot be done through a network
connection.

Back up your configuration before beginning this procedure, if possible. A clean install resets
the configuration, including the IP addresses of network interfaces. For information on
backups, see Backing up configuration on page 103. For information on reconnecting to a
FortiVoice system whose network interface configuration has been reset, see Reconnecting to
the FortiVoice system on page 318.
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If you are downgrading to an earlier FortiVoice version, you may not be able to restore your
previous configuration from the backup configuration file.

To perform a clean firmware installation

1. Download the firmware image file from the Fortinet Support website. For details, see Downloading the firmware
image file on page 313.

2. Connect your management computer to the FortiVoice console port using an RJ-45 to DB-9 serial cable or a null-
modem cable.

3. Initiate a local console connection from your management computer to the CLI of the FortiVoice system, and log
in as the admin administrator, or an administrator account that has system configuration read and write privileges.

4. Connect port1 of the FortiVoice system directly to the same subnet as a TFTP server.
5. Copy the new firmware image file to the root directory of the TFTP server.
6. Verify that the TFTP server is currently running, and that the FortiVoice system can reach the TFTP server.

To use the FortiVoice CLI to verify connectivity, if it is responsive, enter the following command:
execute ping 192.168.2.99

where 192.168.2.99 is the IP address of the TFTP server.
7. Enter the following command to restart the FortiVoice system:

execute reboot

or power off and then power on the FortiVoice system.
8. As the FortiVoice systems starts, a series of system startup messages are displayed.

Press any key to display configuration menu........

9. Immediately press a key to interrupt the system startup.

You have only 3 seconds to press a key. If you do not press a key soon enough, the
FortiVoice system reboots and you must log in and repeat the execute reboot
command.

If you successfully interrupt the startup process, the following messages appear:
[G]: Get firmware image from TFTP server.

[F]: Format boot device.

[B]: Boot with backup firmware and set as default.

[I]: Configuration and information.

[Q]: Quit menu and continue to boot with default firmware.

[H]: Display this list of options.

Enter G,F,B,I,Q,or H:

10. If the firmware version requires that you first format the boot device before installing firmware, type F. (Format boot
device) before continuing.

11. Type G to get the firmware image from the TFTP server.
The following message appears:
Enter TFTP server address [192.168.2.99]:

12. Type the IP address of the TFTP server and press Enter.
The following message appears:
Enter Local Address [192.168.1.188]:
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13. Type a temporary IP address that can be used by the FortiVoice system to connect to the TFTP server.
The following message appears:
Enter File Name [image.out]:

14. Type the firmware image file name and press Enter.
The FortiVoice system downloads the firmware image file from the TFTP server and displays a message similar to
the following:
Save as Default firmware/Backup firmware/Run image without saving:[D/B/R]

15. Type D.
The FortiVoice system downloads the firmware image file from the TFTP server. The FortiVoice system installs the
firmware and restarts. Time required varies by the size of the file and the speed of your network connection.
The FortiVoice system reverts the configuration to default values for that version of the firmware.

16. Clear the cache of your web browser and restart it to ensure that it reloads the GUI and correctly displays all tab,
button, and other changes.

17. To verify that the firmware was successfully installed, log in to the CLI and type:
get system status

The firmware version number appears.
18. Either reconfigure the FortiVoice system or restore the configuration file from a backup. For details, see Restoring

the configuration on page 319.
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