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What's New in FortiAnalyzer

This chapter provides a summary of the new features and enhancements in FortiAnalyzer:

« FortiAnalyzer 6.0.8 on page 10
« FortiAnalyzer 6.0.7 on page 10
« FortiAnalyzer 6.0.6 on page 10
o FortiAnalyzer 6.0.5 on page 10
o FortiAnalyzer 6.0.4 on page 11
+ FortiAnalyzer 6.0.3 on page 11
o FortiAnalyzer 6.0.2 on page 11
« FortiAnalyzer 6.0.1 on page 12
« FortiAnalyzer 6.0.0 on page 13

Always review all sections in the FortiAnalyzer Release Notes prior to upgrading your device.

\ L}
S L4
? Not all features or enhancements are supported on all models.

FortiAnalyzer 6.0.8

FortiAnalyzer 6.0.8 includes no new features.

FortiAnalyzer 6.0.7

FortiAnalyzer 6.0.7 includes no new features.

FortiAnalyzer 6.0.6

FortiAnalyzer 6.0.6 includes no new features.

FortiAnalyzer 6.0.5

FortiAnalyzer 6.0.5 includes no new features.
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What’s New in FortiAnalyzer

FortiAnalyzer 6.0.4

FortiAnalyzer 6.0.4 includes no new features.

FortiAnalyzer 6.0.3

FortiAnalyzer 6.0.3 includes the following new features and enhancements:

Event Manager

New Default Event Handlers

The following new default Event Handlers have been added for malicious, suspicious, and high risk events:

o Default-High-Risk-App-Detection

o Default-Malicious-Code-Detection

« Default-Malicious-Destination-Detection
o Default-Malicious-File-Detetion

o Default-Suspicious-File-Detection

FortiView

Log ID for long sessions

In FortiView, Log ID = 0000000020 indicates a long session that is not yet closed. A long session has multiple logs but
is still considered one session. The sent/received data of long sessions counts all interim traffic data reported by lines
with Log ID = 0000000020.

When the session is closed, the Log ID is 13.

FortiAnalyzer 6.0.2

FortiAnalyzer 6.0.2 includes the following new features and enhancements:

Event Manager

New Default Event Handlers

New Default Event Handlers have been added for IOC Detections and Sandbox Events.

FortiAnalyzer 6.0.8 Administration Guide
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What’s New in FortiAnalyzer

Multiple Filters in one Event Handler
Additional filters can be added to an Event Handler to trigger related events from multiple log types.
Fabric View

Fabric Connectors for ITSM

Administrators can use FortiAnalyzer to send notifications to ITSM platforms upon new incident creation or any
subsequent update in the Fabric View. The Fabric Connectors allow FortiAnalyzer to send incident notifications to third-
party platforms, such as ServiceNow.

FortiView

FortiView Improvements

The FortiView Endpoints views are enhanced for content readability and presentation.
Reports

Report Languages

You can export and import report languages. One way to create a new report language is to export a predefined
language, modify it to a different language, and then import the new language into FortiAnalyzer.

FortiAnalyzer 6.0.1

FortiAnalyzer 6.0.1 includes the following new features and enhancements:

System Settings

Anonymization of user information for GDPR

Added a Privacy Masking option for administrators to mask or anonymize user information. Administrators can choose
which fields to mask. Masked fields show anonymous data in all modules that display those fields. Use the data mask
key to reveal the original, unmasked data.

FortiAnalyzer 6.0.8 Administration Guide 12
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What’s New in FortiAnalyzer

NOC

-SOC

New SOC Views

The following SOC views have been added under NOC - SOC:

The Security > Top Threat widget has a new scatter chart view.

A new Worldwide Threat Prevalence widget under Threat Research.

A new Virus Incidents widget under Threat Research.

The Security Fabric Rating Report widget (FSBP Maturity Milestones) has a new rings view.
A new Sankey topology graph in the Security > User Data Flow widget.

FortiView

FortiView Improvements

Added historical timeline charts to FortiView for improved visual representation of changes over time.

FortiAnalyzer 6.0.0

FortiAnalyzer 6.0.0 includes the following new features and enhancements:

Incident Detection & Response

Event Manager 2.0

From Event Manager > Event Monitor > All Events, you can now search and filter events, customize columns and
save filtered events to a Custom View.

The secondary Group By option from the event handler edit screen provides flexibility on event information
organization.
Built-in event handlers provide threat feed to the FortiOS automation framework. You can raise an incident from

detected events. The raised incident is listed under the /Incidents menu for further analysis and evidence collection.

SOC Dashboards

Fortinet Security Best Practice Dashboard: a simple CISO dashboard to show a snapshot of the security of your
network, including the current security ranking score, industry peer comparison, and security maturity level.

New Vulnerability Dashboard: displays a summary of detected endpoint vulnerabilities along with the detailed
FortiGuard information for each critical vulnerability.

FortiAnalyzer 6.0.8 Administration Guide
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What’s New in FortiAnalyzer

I0OC Enhancements

« |OC scan now includes Traffic logs and DNS logs to provide better detection coverage.
« The IOC Notification Service provides event notification to FortiOS when a compromised host is detected.

FortiAnalyzer High Availability

Support automatic failover over IP for log redundancy and high system availability.

Secure Syslog Forwarding

Support forwarding logs in syslog format over TLS/SSL.

FortiAnalyzer 6.0.8 Administration Guide
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Setting up FortiAnalyzer

This chapter provides information about performing some basic setups for your FortiAnalyzer units.
This section contains the following topics:

« Connecting to the GUI on page 15

« Security considerations on page 16

« GUIl overview on page 17

« Target audience and access level on page 21
o Initial setup on page 21

« FortiManager features on page 21

« Next steps on page 23

« Restarting and shutting down on page 24

Connecting to the GUI

The FortiAnalyzer unit can be configured and managed using the GUI or the CLI. This section will step you through
connecting to the unit via the GUI.

To connect to the GUI:

1. Connect the FortiAnalyzer unit to a management computer using an Ethernet cable.
2. Configure the management computer to be on the same subnet as the internal interface of the FortiAnalyzer unit:
+ |Paddress: 192.168.1.X
o Netmask: 255.255.255.0
3. Onthe management computer, start a supported web browser and browse to https://192.168.1.99.
4. Type admin in the Name field, leave the Password field blank, and click Login.
The Change Password dialog box is displayed.
5. Change the default password now, or click Laterto change the password later:
a. Inthe New Password box, type a new password.
b. Inthe Confirm Password box, type the new password again, and click OK.
6. If ADOMs are enabled, the Select an ADOM pane is displayed. Click an ADOM to select it.
The FortiAnalyzer home page is displayed.

7. Click atile to go to that pane. For example, click the Device Manager tile to go to the Device Manager pane.
See also GUI overview on page 17.

If the network interfaces have been configured differently during installation, the URL
and/or permitted administrative access protocols (such as HTTPS) may no longer be in

their default state.

FortiAnalyzer 6.0.8 Administration Guide
Fortinet Technologies Inc.



Setting up FortiAnalyzer

For information on enabling administrative access protocols and configuring IP addresses, see Configuring network
interfaces on page 138.

Ay
‘Q' If the URL is correct and you still cannot access the GUI, you may also need to configure
- static routes. For details, see Static routes on page 140.

After logging in for the first time, you should create an administrator account for yourself and assign the Super_User
profile to it. Then you should log into the FortiAnalyzer unit by using the new administrator account. See Managing
administrator accounts on page 192 for information.

Security considerations

You can take steps to prevent unauthorized access and restrict access to the GUI. This section includes the following
information:

« Restricting GUI access by trusted host on page 16
« Other security considerations on page 16

Restricting GUI access by trusted host

To prevent unauthorized access to the GUI you can configure administrator accounts with trusted hosts. With trusted
hosts configured, the administrator user can only log into the GUI when working on a computer with the trusted host as
defined in the administrator account. You can configure up to ten trusted hosts per administrator account. See
Administrators on page 191 for more details.

Other security considerations

Other security consideration for restricting access to the FortiAnalyzer GUI include the following:

« Configure administrator accounts using a complex passphrase for local accounts
« Configure administrator accounts using RADIUS, LDAP, TACACSH+, or PKI

« Configure the administrator profile to only allow read/write permission as required and restrict access using read-
only or no permission to settings which are not applicable to that administrator

« Configure the administrator account to only allow access to specific ADOMs as required

FortiAnalyzer 6.0.8 Administration Guide 16
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Setting up FortiAnalyzer

GUI overview

When you log into the FortiAnalyzer GUI, the following home page of tiles is displayed:

Device Manager

Fabric View

NN
A A

ADOM:root @ A1 (§) admin+

FortiView

o

Event Manager System Settings

Select one of the following tiles to display the respective pane. The available tiles will vary, depending on the privileges

of the current user.

Device Manager
Fabric View

FortiView

NOC - SOC

Log View

Event Manager

Reports

System Settings

Add and manage devices and VDOMSs. See Device Manager on page 30.
Configure fabric connectors. See Fabric View on page 39.

View summaries of log data in graphical formats. For example, you can view top
threats to your network, top sources of network traffic, top destinations of network
traffic and so on. For each summary view, you can drill down into details for the
event. See FortiView on page 80.

This pane is not available when the unit is in Collector mode.

View network security, WiFi security, and system performance in real-time. You
can select what activities to monitor in customizable dashboards. See NOC -
SOC Monitoring on page 73.

This pane is not available when the unit is in Collector mode.

View logs for managed devices. You can display, download, import, and delete
logs on this page. You can also define custom views and create log groups. See
Log View and Log Quota Management on page 43.

Configure and view events for logging devices. See Event and Incident
Management on page 60.

This pane is not available when the unit is in Collector mode.

Generate reports. You can also configure report templates, schedules, and
output profiles, and manage charts and datasets. See Reports on page 94.

This pane is not available when the unit is in Collector mode.

Configure system settings such as network interfaces, administrators, system
time, server settings, and others. You can also perform maintenance and
firmware operations. See System Settings on page 125.

FortiAnalyzer 6.0.8 Administration Guide
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Setting up FortiAnalyzer

The top-right corner of the home page includes a variety of possible selections:

ADOM If ADOMs are enabled, the required ADOM can be selected from the dropdown list.
The ADOMSs available from the ADOM menu will vary depending on the privileges of the
current user.

Full Screen Click to view only the content pane in the browser window. See Full-screen mode on page 19.

Help Click to open the FortiAnalyzer online help, or view the About information for your device
(Product, Version, and Build Number).

You can also open the FortiAnalyzer basic setup video
(https://video.fortinet.com/video/208/fortianalyzer-basic-setup).

Notification Click to display a list of notifications. Select a notification from the list to take action on the
issue.
admin Click to change the password or log out of the GUI.
Panes

In general, panes have four primary parts: the banner, toolbar, tree menu, and content pane.

Banner Along the top of the page; includes the home button (Fortinet logo), tile menu,
ADOM menu (when enabled), admin menu, notifications, and help button.

Tree menu On the left side of the screen; includes the menus for the selected pane.
Not available in Device Manager.

Content pane Contains widgets, lists, configuration options, or other information, depending on
the pane, menu, or options that are selected. Most management tasks are
handled in the content pane.

Toolbar Directly above the content pane; includes options for managing content in the
content pane, such as Create New and Delete.

© Last 1 Week ~

+ Add Widget ~

‘® Threats ~
Top Threats Top 10 Threats o X
Threat Map
Compromised Hosts
FortiSandbox Detection

= Traffic >

2! Applications & Websites ~
Top Applications 2018... failed-connection
Top Cloud Applications
Top Web Sites MS.DN...
Top Browsing Users . .

& VPN Prox.. Web...

= WiFi

{¥ System

& Endpoints
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Setting up FortiAnalyzer

To switch between panes, either select the home button to return to the home page, or select the tile menu then select
anew tile.

E:E Device Manager ~

0 oevices 0% storage Used

r
E CIII] ’* ‘. Log Status Down n Total 50.0 GB
o~ | A |

Device Manager FortiView NOC - S0C Log View
0O a Average Log Rate{Logs/Sec) Device Storage Description
0 ¢ N/A (0%)
o ¢ N/A (0.02%)
ot P N/A (0%)

\/\/\/\ ‘

o ¢ X N/A (0%) D
g Fabric View Event Manager Reports System Settings LUL (0%)
a8 N/A (0%)

Color themes

You can choose a color theme for the FortiAnalyzer GUI. For example, you can choose a color, such as blue or plum, or
you can choose an image, such as summer or autumn. See Global administration settings on page 209.

Full-screen mode
You can view several panes in full-screen mode. When a pane is in full-screen mode, the tree menu on the left side of
the screen is hidden.

Click the Full Screen button in the toolbar to enter full-screen mode, and press the Esc key on your keyboard to exit full-
screen mode.

Switching between ADOMs

When ADOMs are enabled, you can move between ADOMs by selecting an ADOM from the ADOM menu in the
banner.

ADOM:root (2 @ QA1 A admin~w

ADOM access is controlled by administrator accounts and the profile assigned to the administrator account. Depending
on your account privileges, you might not have access to all ADOMs. See Managing administrator accounts on page
192 for more information.

Using the right-click menu

Options are sometimes available using the right-click menu. Right-click an item in the content pane, or within some of
the tree menus, to display the menu that includes various options similar to those available in the toolbar.

FortiAnalyzer 6.0.8 Administration Guide
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Setting up FortiAnalyzer

Device Manager v Device & Groups Firmware License Provisioning Templates § »

@ Add Device ~ 38 Device Group ~ & Install Wizard & Tools v f& Quick Install (Device DB)

& Install Wizard
&
] 1 devics ! Ooe
om .
Total ' Palic:
4] Import Policy il
LI

@ Managed Devices

&t VPNTest

I Y & Recinstall Policy l Y |
LY scarch.. Q[ O  iDevice Name L Policy Package Diff Policy Package Status
# FGYMO0TM19002130 FGVMOOTM19002130 FGVMOOTM19002130

& Assign CLI Template

[# Edit
B Delete

3B Create Group

& Refresh Device

4 Add VDOM

® Run Script
I '

In the following example on the Reports pane, you can right-click a template, and select Create New, View, Clone, or
Create Report.

ADOM:root £3 @ A1 (§) admin v

ES Generated Reports + Create New [ Edit T Delete %4 Clone B Create Report h Install Language Pack

B Report Definitions

B All Reports &Temp Template  Security

+ Create New " e
y review of Application Visibility and Control, Threat Detection, Data
FaTemplate - 360-Di  [# Edit ! iy . HTML
] tion Detection, Endpoint Detection, Prevention and Recommended ~  Security
[ul Chart Library @ Security Review B Delete | PDF
£ Macro Library =l L
O ETemplate-Admin = —0'° b e fofed i atterts and syst o event counts. - HTML
= L login and fail login attempts and system severity event counts. ystem
£ Datasets @ System Events Repo 5 Create Report = © PDF
43 Advanced >| O EaTemplate - Application Application risk, categories, bandwidth by app, web categories, vulnerability HTML
English i - Application .
Bick and Cantral avnlnite vie hntnat arduare molicinee sttacke #la rancare one

When FortiClient sends logs to FortiAnalyzer, an avatar for each user can be displayed in the Source column in the
FortiView and Log View panes. FortiAnalyzer can display an avatar when the following requirements are met:

« FortiClient is managed by FortiGate or FortiClient EMS with logging to FortiAnalyzer enabled.
« FortiClient sends logs and a picture of each user to FortiAnalyzer.

If FortiAnalyzer cannot find the defined picture, a generic, gray avatar is displayed.

vy
‘9' You can also optionally define an avatar for FortiAnalyzer administrators. See

Creating administrators on page 193.

Showing and hiding passwords

In some cases you can show and hide passwords by using the toggle icon. When you can view the password, the Toggle
show password icon is displayed:

Password test @

When you can hide the password, the Toggle hide password icon is displayed:

Password [ e Wl

FortiAnalyzer 6.0.8 Administration Guide
Fortinet Technologies Inc.



Setting up FortiAnalyzer

Target audience and access level

This guide is intended for administrators with full privileges, who can access all panes in the FortiAnalyzer GUI,
including the System Settings pane.

In FortiAnalyzer, administrator privileges are controlled by administrator profiles. Administrators who are assigned
profiles with limited privileges might be unable to view some panes in the GUI and might be unable to perform some
tasks described in this guide. For more information about administrator profiles, see Administrator profiles on page 197.

s‘é’, If you logged in by using the admin administrator account, you have the Super_User

administrator profile, which is assigned to the admin account by default and gives the admin
administrator full privileges.

Initial setup

This topic provides an overview of the tasks that you need to do to get your FortiAnalyzer unit up and running.

To set up FortiAnalyzer:

1.
2
3.

Connect to the GUI. See Connecting to the GUI on page 15.
Configure the RAID level, if the FortiAnalyzer unit supports RAID. See Configuring the RAID level on page 143.
Configure network settings. See Configuring network interfaces on page 138.

\ﬂ Once the IP address of the administrative port of FortiAnalyzer is changed, you will lose

connection to FortiAnalyzer. You will have to reconfigure the IP address of the
management computer to connect again to FortiAnalyzer and continue.

(Optional) Configure administrative domains. See Managing ADOMs on page 149.
Configure administrator accounts. See Managing administrator accounts on page 192.

x After you configure the administrator accounts for the FortiAnalyzer unit, you should log in

again by using your new administrator account.

Add devices to the FortiAnalyzer unit so that the devices can send logs to the FortiAnalyzer unit. See Adding
devices on page 31.

Configure the operation mode. See Configuring the operation mode on page 132 and Two operation modes on
page 25.

FortiManager features

When FortiManager features are enabled for the FortiAnalyzer unit, the following panes are available:
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Device Manager (for Add, configure, and manage FortiGate devices.
FortiManager)

Policy and Object Centrally manage FortiGate devices by creating policies and objects and
installing them to managed devices.

AP Manager Centrally manage FortiAP access points by authorizing and monitoring FortiAP
devices. You can also edit and monitor authorized devices.

FortiClient Manager Centrally manage FortiClient profiles for FortiGate devices as well as monitor
FortiClient endpoints.

VPN Manager Centrally manage IPsec VPN communities and SSL-VPN settings.

FortiSwitch Manager Centrally manage FortiSwitch templates and VLANs, and monitor FortiSwitch
devices that are connected to FortiGate devices.

HA is not supported when FortiManager features are enabled.

For information about using FortiManager features, see the FortiManager Administration Guide.

Enable or disable FortiManager features

You can enable FortiManager features on FortiAnalyzer so it can manage a small number of FortiGate devices. All the
FortiManager features can be enabled on FortiAnalyzer except FortiGuard.

FortiAnalyzer 1000E and above devices come with a free license to manage up to two FortiGate devices when
FortiManager features are enabled.

For FortiAnalyzer devices with a two rack unit (2U) and above, you can purchase a management license to enable your
FortiAnalyzer unit to manage up to 20 FortiGate devices.

You can enable or disable FortiManager features using either the GUI or CLI.

To enable FortiManager features on FortiAnalyzer using the GUI:

1. Goto System Settings > Dashboard.
2. Inthe System Information widget, toggle the FortiManager Features switch to On.
3. After the system reboots, log in to the FortiAnalyzer GUI.
The FortiAnalyzer home page now also shows FortiManager feature tiles except FortiGuard.

To enable FortiManager features on FortiAnalyzer using the CLI:

1. From the CLI, or in the CL/ Console widget, enter the following:
config system global
set fmg-status enable
end

The following prompt is displayed:

Changing fmg status will affect FAZ feature. If you continue, system will reboot.
Do you want to continue? (y/n)
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2.
3.

Type Y.

After the system reboots, log in to the FortiAnalyzer GUI. FortiManager features, except FortiGuard, have been
enabled.

To upgrade the management license:

1.
2.

3.

Go to System Settings > Dashboard.

In the License Information widget, find the Management > Devices/VDOMs field and click the Upload license
icon.

In the dialog box, provide the license key that you have purchased.

To disable FortiManager features on FortiAnalyzer using the GUI:

1.
2
3.

Go to System Settings > Dashboard.
In the System Information widget, toggle the FortiManager Features switch to Off.

After the system reboots, log in to the FortiAnalyzer GUI.
The FortiAnalyzer home page no longer includes FortiManager feature tiles.

To disable FortiManager features on FortiAnalyzer using the CLI:

1.

2.

From the CLI, orin the CLI Console widget, enter the following:
config system global
set fmg-status disable
end
The following prompt is displayed:
Changing fmg status will affect FAZ feature. If you continue, system will reboot.
Do you want to continue? (y/n)

Type Y.

Next steps

Now that you have set up your FortiAnalyzer units and they have started receiving logs from the devices, you can start
monitoring and interpret data. You can:

View log messages collected by the FortiAnalyzer unit in Log View. See Types of logs collected for each device on
page 43.

View summaries of threats, traffic, and more in FortiView. See FortiView on page 80

View multiple panes of network activity in NOC (Network Operations Center) or SOC (Security Operations Center).
See NOC - SOC Monitoring on page 73.

Generate and view events in Event Manager. See Event and Incident Management on page 60.
Generate and view reports in Reports. See Reports on page 94.
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Restarting and shutting down

Always use the operation options in the GUI or the CLI commands to reboot and shut down the FortiAnalyzer system to
avoid potential configuration problems.

To restart the FortiAnalyzer unit from the GUI:

1. Goto System Settings > Dashboard.
2. Inthe Unit Operation widget, click the Restart button.
3. Enter a message for the event log, then click OK to restart the system.

To restart the FortiAnalyzer unit from the CLI:

1. From the CLI, or in the CL/ Console widget, enter the following command:
execute reboot
The system will be rebooted.
Do you want to continue? (y/n)

2. Enter y to continue. The FortiAnalyzer system will restart.

To shutdown the FortiAnalyzer unit from the GUI:

1. Goto System Settings > Dashboard.
2. Inthe Unit Operation widget, click the Shutdown button.
3. Enter a message for the event log, then click OK to shutdown the system.

To shutdown the FortiAnalyzer unit from the CLI:

1. From the CLI, or in the CL/ Console widget, enter the following command:
execute shutdown
The system will be halted.
Do you want to continue? (y/n)

2. Enter y to continue. The FortiAnalyzer system will shutdown.

To reset the FortiAnalyzer unit:

1. From the CLI, or in the CL/ Console widget, enter the following command:
execute reset all-settings
This operation will reset all settings to factory defaults
Do you want to continue? (y/n)

2. Enter y to continue. The device will reset to factory default settings and restart.

To reset logs and re-transfer all SQL logs to the database:

1. From the CLI, or in the CL/ Console widget, enter the following command:
execute reset-sgllog-transfer
WARNING: This operation will re-transfer all logs into database.
Do you want to continue? (y/n)

2. Enter y to continue. All SQL logs will be resent to the database.
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This section provides information about basic FortiAnalyzer concepts and terms. If you are new to FortiAnalyzer, use
this section to quickly understand this document and the FortiAnalyzer platform.

This section includes the following sections:

« Two operation modes on page 25

+ Administrative domains on page 27
« Log storage on page 27

« NOC/SOC dashboard on page 29

Two operation modes

FortiAnalyzer can run in two operation modes: Analyzer and Collector. Choose the operation mode for your
FortiAnalyzer units based on your network topology and requirements.

Analyzer mode

Analyzer mode is the default mode that supports all FortiAnalyzer features. Use this mode to aggregate logs from one
or more Collectors.
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The following diagram shows an example of deploying FortiAnalyzer in Analyzer mode.

FortiAnalyzer

l F I FortiGates |

ortiGates

Collector mode

When FortiAnalyzer is in Collector mode, its primary task is forwarding logs of the connected devices to an Analyzer and
archiving the logs. Instead of writing logs to the database, the Collector retains logs in their original binary format for
uploading. In this mode, most features are disabled.

Analyzer and Collector feature comparison

Feature Analyzer Mode Collector Mode
Device Manager Yes Yes
FortiView Yes No
FortiAnalyzer 6.0.8 Administration Guide 26

Fortinet Technologies Inc.



FortiAnalyzer Key Concepts

Feature Analyzer Mode Collector Mode
Log View Yes Raw archive logs only
Event Manager Yes No
Monitoring devices Yes No
Reporting Yes No
System Settings Yes Yes
Log Forwarding Yes Yes

Analyzer-Collector collaboration

You can deploy Analyzer mode and Collector mode on different FortiAnalyzer units and make the units work together to
improve the overall performance of log receiving, analysis, and reporting. The Analyzer offloads the log receiving task to
the Collector so that the Analyzer can focus on data analysis and report generation. This maximizes the Collector’s log
receiving performance.

For an example of setting up Analyzer—Collector collaboration, see Collectors and Analyzers on page 222.

Administrative domains

Administrative domains (ADOMs) enable the admin administrator to constrain the access privileges of other
FortiAnalyzer unit administrators to a subset of devices in the device list. For Fortinet devices with virtual domains
(VDOMSs), ADOMs can further restrict access to only data from a specific VDOM for a device.

Enabling ADOMs alters the available functions in the GUI and CLI. Access to the functions depends on whether you are
logged in as the admin administrator. If you are logged in as the admin administrator, you can access all ADOMs. If
you are not logged in as the admin administrator, the settings in your administrator account determines access to
ADOMs.

For information on enabling and disabling ADOMSs, see Enabling and disabling the ADOM feature on page 148. For
information on working with ADOMs, see Administrative Domains on page 146. For information on configuring
administrator accounts, See Managing administrator accounts on page 192.

M ADOMs must be enabled to support FortiCarrier, FortiClient EMS, FortiMail, FortiWeb,
q FortiCache, and FortiSandbox logging and reporting. See Administrative Domains on page
- 146.

Log storage

Logs and files are stored on the FortiAnalyzer disks. Logs are also temporarily stored in the SQL database.

You can configure data policy and disk utilization settings for devices. These are collectively called log storage settings.
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You can configure global log and file storage settings. These apply to all logs and files in the FortiAnalyzer system
regardless of log storage settings.

SQL database

FortiAnalyzer supports Structured Query Language (SQL) for logging and reporting. The log data is inserted into the
SQL database to support data analysis in FortiView, Log View, and Reports. Remote SQL databases are not

supported.

For more information, see FortiView on page 80, Types of logs collected for each device on page 43, and Reports on
page 94.

The log storage settings define how much FortiAnalyzer disk space to use for the SQL database.

L When FortiAnalyzer is in Collector mode, the SQL database is disabled by default. If you want
? to use logs that require SQL when FortiAnalyzer is in Collector mode, you must enable the
= SQL database. See Two operation modes on page 25.

Archive logs and Analytics logs

Logs in FortiAnalyzer are in one of the following phases. Use a data policy to control how long to retain Analytics and
Archive logs.

« Real-time log: Log entries that have just arrived and have not been added to the SQL database, i.e., have not been

rolled.

« Analytics logs or historical logs: Indexed in the SQL database and online.

« Archive logs: Compressed on hard disks and offline.

In the indexed phase, logs are indexed in the SQL database for a specified length of time for the purpose of analysis.
Logs in the indexed phase in the SQL database are considered online and you can view details about these logs in the
FortiView, Log View, and Event Manager pane. You can also generate reports about the logs in the Reports pane.

In the compressed phase, logs are compressed and archived in FortiAnalyzer disks for a specified length of time for the
purpose of retention. Logs in the compressed phase are considered offline and you cannot immediately view details
about these logs in the FortiView, Log View, and Event Manager pane. You also cannot generate reports about the
logs in the Reports pane.

Data policy and automatic deletion

Use a data policy to control how long to keep compressed and indexed logs. When ADOMs are enabled, you can specify
settings for each ADOM and the settings apply to all devices in that ADOM. When ADOMs are disabled, settings apply

to all managed devices.
A data policy specifies:

« How long to keep Analytics logs indexed in the database
When the specified length of time in the data policy expires, logs are automatically purged from the database but
remain compressed in a log file on the FortiAnalyzer disks.
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« How long to keep Archive logs on the FortiAnalyzer disks
When the specified length of time in the data policy expires, Archive logs are deleted from the FortiAnalyzer disks.

See also Log storage information on page 57.

Disk utilization for Archive and Analytic logs

You can specify how much of the total available FortiAnalyzer disk space to use for log storage. You can specify what
ratio of the allotted storage space to use for logs that are indexed in the SQL database and for logs that are stored in a
compressed format on the FortiAnalyzer disks. Then you can monitor how quickly device logs are filling up the allotted

disk space.
NP Analytic logs indexed in the SQL database require more disk space than Archive logs (purged
‘Q' from the SQL database but remain compressed on the FortiAnalyzer disks). An average
- indexed log is 400 bytes and an average compressed log is 50 bytes. Keep this difference in

mind when specifying the storage ratio for Analytics and Archive logs.

When ADOMs are enabled, you can specify settings for each ADOM and the settings apply to all devices in that ADOM.

When ADOMs are disabled, settings apply to all managed devices. See Log storage information on page 57.

NOC/SOC dashboard

FortiAnalyzer provides dashboard for Network Operations Center (NOC) or Security Operations Center (SOC)
administrators. The dashboards enhance visualization for real-time activities and historical trends for analysts to
effectively monitor network activities and security alerts. See NOC - SOC Monitoring on page 73.
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Use the Device Manager pane to add, configure, and manage devices and VDOMSs.

) ' ’, If FortiManager features are enabled, then this is the FortiManager Device Manager.
9 For information about using FortiManager features, see the FortiManager Administration
= Guide.

After you add and register a device or VDOM, the FortiAnalyzer unit starts collecting logs from that device or VDOM.
You can configure the FortiAnalyzer unit to forward logs to another device. See Log Forwarding on page 159.

ADOMs

You can organize connected devices into ADOMs to better manage the devices. ADOMs can be organized by:

« Firmware version: group all 5.4 devices into one ADOM, and all 5.2 devices into another.

« Geographic regions: group all devices for a specific geographic region into an ADOM, and devices for a separate
region into another ADOM.

« Administrator users: group devices into separate ADOMs based for specific administrators responsible for the
group of devices.

« Customers: group all devices for one customer into an ADOM, and devices for another customer into another
ADOM.

FortiAnalyzer, FortiCache, FortiClient, FortiDDos, FortiMail, FortiManager, FortiSandbox, FortiWeb, Chassis, and
FortiCarrier devices are automatically placed in their own ADOMs.

Each administrator profile can be customized to provide read-only, read/write, or restrict access to various ADOM
settings. When creating new administrator accounts, you can restrict which ADOMs the administrator can access, for
enhanced control of your administrator users. For more information on ADOM configuration and settings, see
Administrative Domains on page 146.

FortiClient EMS devices

You can add FortiClient EMS servers to FortiAnalyzer. Registered FortiClient EMS servers are added to the default

FortiClient ADOM. You must enable ADOMs to work with FortiClient EMS servers in FortiAnalyzer. When you select the
FortiClient ADOM and go to the Device Manager pane, the FortiClient EMS servers are displayed. See also FortiClient

support and ADOMs on page 147.

Unregistered devices

When a device is configured to send logs to FortiAnalyzer, the unregistered device is displayed in the Device Manager >

Devices Unregistered pane. You can then add devices to specific ADOMs or delete devices by using the toolbar
buttons or the right-click menu.
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Using FortiManager to manage FortiAnalyzer devices

You can add FortiAnalyzer devices to FortiManager and manage them. When you add a FortiAnalyzer device to

FortiManager, FortiManager automatically enables FortiAnalyzer features. FortiAnalyzer and FortiManager must be
running the same OS version, at least 5.6 or later.

In the Device Manager pane, a message informs you the device is managed by FortiManager and all changes should
be performed on FortiManager to avoid conflict. The top right of this pane displays a lock icon. If ADOMs are enabled,
the System Settings > All ADOMs pane displays a lock icon beside the ADOM managed by FortiManager.

Logs are stored on the FortiAnalyzer device, not the FortiManager device. You configure log storage settings on the
FortiAnalyzer device; you cannot change log storage settings using FortiManager.

For more information, see the FortiManager Administration Guide.

Adding devices

You must add and register devices and VDOMs to FortiAnalyzer to enable the device or VDOM to send logs to
FortiAnalyzer. Registered devices are also known as devices that have been promoted to the DVM table.

You must configure devices to send logs to FortiAnalyzer. For example, after you add and
ﬂ register a FortiGate device with FortiAnalyzer, you must also configure the FortiGate device
I to send logs to FortiAnalyzer. In the FortiGate GUI, go to Log & Report > Log Settings, and
enable Send Logs to FortiAnalyzer/FortiManager.

Ay
‘Q' If you are using high availability, you must specify the FortiGate HA group name when adding
- a FortiGate cluster.

Adding devices using the wizard

You can add devices and VDOMs to FortiAnalyzer using the Add Device wizard. When the wizard finishes, the device is
added to the FortiAnalyzer unit, registered, and is ready to start sending logs.
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To add devices using the wizard:

1.

If using ADOMSs, ensure that you are in the correct ADOM.

2. Goto Device Manager and click Add Device.

Add Device

Please input the following information to add a device.
IP Address

SN

Device Name
Device Model
Firmware Version

5.6

Description

T

3. Configure the following settings:

IP Address
SN

Device Name
Device Model

Firmware Version

Type the IP address for the device.

Type the serial number for the device.
Type a name for the device.

Select the model of the device.

Select the firmware version of the device.

Type a description of the device (optional).

The device is added to the ADOM and, if successful, is ready to begin sending logs to the FortiAnalyzer unit.

Description
4. Click Next.
Add Device
Name Wink
SN FGVMO000000000000
IP Address 333.33.2.333

Status

Device is added successfully

Creating device database
Retrieving high availability status.
Initializing configuration database
Updating group membership

Successfully add device

CEs ]

5. Click Finish to finish adding the device and close the wizard.
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Adding devices manually

You can configure supported devices to send logs to the FortiAnalyzer device. These devices are displayed in the root
ADOM as unregistered devices. You can quickly view unregistered devices by clicking Unregistered Devices in the
quick status bar. When you manually add an unregistered device to the FortiAnalyzer unit, the device is registered with
the FortiAnalyzer unit and can start receiving logs from the device.

When ADOMs are enabled, you can assign the device to an ADOM. When manually adding multiple devices at one
time, they are all added to the same ADOM.

When you delete a device or VDOM from the FortiAnalyzer unit, its raw log files are also deleted. SQL database logs are
not deleted.

To manually add devices:

1. Inthe root ADOM, go to Device Manager and click Unregistered Devices in the quick status bar. The content pane
displays the unregistered devices.

2. Select the unregistered device or devices, then click Add. The Add Device dialog box opens.

Add Device

Add the following device(s) to ADOM: branch
Device Name Assign New Device Name
FGT1KC0000000001 FGT1KC0000000001

e

3. If ADOMs are enabled, select the ADOM in the Add the following device(s) to ADOM list. If ADOMs are disabled,
select root.

4. Click OK to register the device or devices.
The device or devices are added and FortiAnalyzer can start receiving logs from the device or devices.

Adding an HA cluster

You can use a HA cluster to synchronize logs and data securely among multiple FortiGate devices.

An HA cluster can have a maximum of four devices: one primary device with up to three backup devices. All the devices
in the cluster must be of the same FortiGate series and must be visible on the network.

You can use auto-grouping in FortiAnalyzer to group devices in a cluster based on the group

i, name specified in Fortigate's HA cluster configuration. For auto-grouping to work properly,
~Q' each FortiGate cluster requires a unique group name.
— If a unique group name is not used, auto-grouping should be disabled.

FAZ # config system global
(global) # set ha-member-auto-grouping disable

To create an HA cluster:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Add the devices to Device Manager.
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3. Choose a primary device, and click Edit.
4. Inthe Edit Device pane, select HA Cluster.
5. From the Add Existing Device list, select a device, and click Add.

Name FG149

Description

IP Address 10.10.10.10

Serial Number FGYMO0000000000 (FortiGate-VMé4)

Firmware Version FortiGate 5.6, build1534

Admin User admin

Password ssssss

HA Cluster

Add Existing Device « | +
Add Other Device +
HA Cluster List #  Device Name Action

1 FG149 (FGYMO0000000000)

6. Optionally, you can use the Add Other Device field to add a new device.

I\I Adding devices before you create the HA is recommended.

7. Add more devices as necessary, and click OK. The maximum is three devices.

To view the HA in Device Manager, click Column Settings > HA Status.

Managing devices
Use the tools and commands in the Device Manager pane to manage devices and VDOMs.

Using the quick status bar
10 3 o 1045

You can see the quick status bar at the top of the Device Manager pane. The quick status bar contains the following
tabs:

o Devices Total: Displays the registered devices.

o Devices Unregistered: Displays the unregistered devices.

« Devices Log Status Down: Displays the registered devices with a log status of down.

« Storage Used: Displays the Log View > Storage Statistics page.

The Devices Total, Devices Unregistered, and the Devices Log Status Down tabs include the following default
columns:
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Column Description

Device Name Displays the name of the device.

IP Address Displays the IP address for the device.

Platform Displays the platform for the device.

Logs Identifies whether the device is successfully sending logs to the FortiAnalyzer

unit. A green circle indicates that logs are being sent. A red circle indicates that
logs are not being sent.

Alock icon displays when a secure tunnel is being used to transfer logs from the
device to the FortiAnalyzer unit.

Average Log Rate Displays the average rate at which the device is sending logs to the FortiAnalyzer
(Logs/Sec) unit in log rate per second. Click the number to display a graph of historical
average log rates.

Device Storage Displays how much of the allotted disk space has been consumed by logs.

Description Displays a description of the device (not displayed in Devices Unregistered tab).

Using the toolbar

The following buttons and menus are available for selection on the toolbar:

Button Description

Add Device Opens the Add Device Wizard to add a device to the FortiAnalyzer unit. The
device is added, but not registered with the FortiAnalyzer unit. Unregistered
devices are displayed in the Unregistered Devices tree menu.

Edit Edits the selected device.

Delete Deletes the selected devices or VDOMs from the FortiAnalyzer unit.

When you delete a device, its raw log files are also deleted. SQL database logs
are not deleted.

Column Settings Click to select which columns to display or select Reset to Default to display the
default columns.

More Displays more menu items including Import Device List and Export Device List.

Search Type the name of a device. The content pane displays the results. Clear the
search box to display all devices in the content pane.

Editing device information

Use the Edit Device page to edit information about a device. The information and options available on the Edit Device
page depend on the device type, firmware version, and which features are enabled.
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To edit information for a device or model device:

1. Goto Device Manager and click the Devices Total tab in the quick status bar.
2. Inthe content pane, select the device or model device and click Edit, or right-click on the device and select Edit.

The Edit Device pane displays.

Edit Device
Name

Description

IP Address

Serial Number
Firmware Version
Admin User
Password

HA Cluster

Add Existing Device
Add Other Device

HA Cluster List

Device Location v

Geographic Coordinate

Company/QOrganization
Country
Province/State

City

Contact

FG149

10.10.10.10
FGVMO0O000000000 (FortiGate-VM&64)
FortiGate 5.6, build1534

admin

[ITTTTY

#  Device Name
1 FG149 (FGYM0000000000)

49.25929408629 (Latitude) | -123.0115892711

Show Map
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3. Edit the device settings as required.

Name
Description

IP Address

Serial Number
Firmware Version
Admin User
Password

HA Cluster

Geographic Coordinates

Company/Organization

Country
Province/State
City

Contact

The name of the device.

Descriptive information about the device.
Enter the IP address of the device.

The serial number of the device.

The firmware version.

Enter the administrator user name.

Enter the administrator user password.

Select to identify the device as part of an HA cluster, and to identify the other
device in the cluster by selecting them from the drop-down list, or by inputting
their serial numbers.

Identifies the latitude and longitude of the device location to support the
interactive maps.

Click Show Map to open a map showing the location of the device based on

the coordinates. Click and drag the map marker to adjust the device's location.

Optionally, enter the company or organization information.
Optionally, enter the country where the device is located.
Optionally, enter the province or state.

Optionally, enter the city.

Optionally, enter the contact information.

4. After making the appropriate changes click OK.

Displaying historical average log rates

You can display a graph of the historical, average log rates for each device.

To display historical average logs rates:

1. If using ADOMs, ensure that you are in the correct ADOM.

2. Goto Device Manager and click the Devices Total tab in the quick status bar.
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3. Inthe Average Log Rate (Logs/Sec) column, click the number to display the graph.

Log Rate History (CorpFW, Last 24 Hours)
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4. Hover the cursor over the graph to display more details.

Connecting to a registered device GUI
You can connect to the GUI of a registered device from Device Manager.

To connect to a registered device GUI:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Device Manager and click the Devices Total tab in the quick status bar.
Right-click the device that you want to access, and select Connect to Device.
If necessary, change the port number and click OK.

AoODbdD =

You will be directed to the Login page of the device GUI.
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The Fabric View module enables you to create fabric connectors.
This section contains the following topics:

o |TSM on page 39

Fabric Connectors

You can use FortiAnalyzer to create the following types of fabric connectors:

e ITSM

ITSM

You can use the Fabric Connectors tab to create the following types of ITSM connectors:

« ServiceNow
« Webhook, a generic connector

Creating or editing ITSM connectors
You can create ITSM connectors for ServiceNow and Webhook.

To create or edit ITSM connectors:

1. Goto Fabric View > Fabric Connectors.

2. To create an ITSM connector, click Create New. In the Create New Fabric Connector wizard, select ServiceNow
or Webhook, and click Next.
To edit an ITSM connector, click the ITSM connector. The connector options are displayed.

3. Configure the following options, and then click OK:

Name Type a name for the fabric connector.

Description (Optional) Type a description for the fabric connector.

Protocol Select HTTPS.

Port Specify the port FortiAnalyzer uses to communicate with the external
platform.

Method Select POST.

Title Type a title for the fabric connector.
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Fabric View

URL

Enable HTTP Authentication

Status
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Type the URL of the external platform.

Using ServiceNow as an example, copy and paste the URL from ServiceNow
API URL in the Connection to ServiceNow API section in ServiceNow >
FortiAnalyzer System Properties.

Set HTTP authentication to ON or OFF.

Using ServiceNow as an example, enter the username and password from the
Connection to ServiceNow AP section in ServiceNow > FortiAnalyzer
System Properties.

Toggle ON to enable the fabric connector. Toggle OFF to disable the fabric
connector.
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FortiAnalyzer can recognize a Security Fabric group of devices and display all units in the group on the Device Manager
pane. See Adding a Security Fabric group on page 41. FortiAnalyzer supports the Security Fabric by storing and
analyzing the logs from the units in a Security Fabric group as if the logs are from a single device. You can also view the
logging topology of all units in the Security Fabric group for additional visibility. See Displaying Security Fabric topology
on page 42.

FortiAnalyzer provides dynamic data and metadata exchange with the Security Fabric and uses the data in FortiView
and Reports for additional visibility. A default report template lets you monitor new users, devices, applications,
vulnerabilities, threats and so on from the Security Fabric.

A set of dashboard widgets lets you review audit scores for a FortiGate Security Fabric group with recommended best
practices and historical audit scores and trends.

If FortiClient is installed on endpoints for endpoint control with FortiGate, you can use the endpoint telemetry data
collected by the Security Fabric agent to display user profile photos in reports and FortiView.

Adding a Security Fabric group

Before you can add a Security Fabric group to FortiAnalyzer, you need to create the Security Fabric group in FortiGate.
For more information, see the FortiOS Handbook.

Fortinet recommends using a dedicated Super_User administrator account on the FortiGate for FortiAnalyzer access.
This ensures that associated log messages are identified as originating from FortiAnalyzer activity. This dedicated
Super_User administrator account only needs Read Only access to System Configuration; all other access can be set
to None.

To add a Security Fabric group:

1. Goto Device Manager > Unregistered Devices.
2. Select all the devices corresponding to the Security Fabric group created in FortiGate.

3. Authenticate the Security Fabric group by clicking the Warning icon (yellow triangle) beside the corresponding
FortiGate root.

Authentication

Please enter admin user name and password for the root device of security fabric "csf80cm”.

Admin User ||

Password

4. Enter the Authentication Credentials. The authentication credentials are the ones you specified in FortiGate. Once
the FortiGate root has been authenticated, the Warning icon will disappear.

5. After authentication, it takes a few minutes for FortiAnalyzer to automatically populate the devices under the
FortiGate root which creates the Security Fabric group.
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Displaying Security Fabric topology
For Security Fabric devices, you can display the Security Fabric topology.

To display the Security Fabric topology:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Device Manager and click the Devices Total tab in the quick status bar.
3. Right-click a Security Fabric device and select Fabric Topology.

A pop-up window displays the Security Fabric topology for that device.

If you selected Fabric Topology by right-clicking a device within the Security Fabric group, the device is highlighted
in the topology. If you selected Fabric Topology by right-clicking the name of the Security Fabric group, no device is
highlighted in the topology.

Topology for FGP2000000000000

HA Active-Passive

FGT200DPOE-L1-root B3 FGBLE-HAL2 — 5%} FG280DPOEL3

-
2mh FGB1E-HA-LS

FGVYM-076-12
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You can view log information by device or by log group.
When rebuilding the SQL database, Log View is not available until the rebuild is complete.
Click the Show Progress link in the message to view the status of the SQL rebuild.

When ADOMs are enabled, each ADOM has its own information displayed in Log View.

Log View can display the real-time log or historical (Analytics) logs.
Log Browse can display logs from both the current, active log file and any compressed log files.

For more information, see Archive logs and Analytics logs on page 28.

Types of logs collected for each device

FortiAnalyzer can collect logs from managed FortiGate, FortiCarrier, FortiCache, FortiMail, FortiManager,
FortiSandbox, FortiWeb, FortiClient, and syslog servers. Following is a description of the types of logs FortiAnalyzer
collects from each type of device:

Device Type Log Type
FortiAnalyzer Event
FortiAuthenticator  Event

FortiGate Traffic

Security: Antivirus, Intrusion Prevention, Application Control, Web Filter, DNS, Data Leak
Prevention, Email Filter, Web Application Firewall, Vulnerability Scan, VolP, FortiClient

Event: Endpoint, HA, Compliance, System, Router, VPN, User, WAN Opt. & Cache, WiFi

FortiCarrier Traffic, Event, GTP

FortiCache Traffic, Event, Antivirus, Web Filter
FortiClient Traffic, Event, Vulnerability Scan
FortiDDoS Event, Intrusion Prevention
FortiMail History, Event, Antivirus, Email Filter
FortiManager Event

FortiSandbox Malware, Network Alerts

FortiWeb Event, Intrusion Prevention, Traffic
Syslog Generic

FortiAnalyzer 6.0.8 Administration Guide
Fortinet Technologies Inc.



Log View and Log Quota Management

Traffic logs

Traffic logs record the traffic flowing through your FortiGate unit. Since traffic needs firewall policies to properly flow
through FortiGate, this type of logging is also called firewall policy logging. Firewall policies control all traffic attempting
to pass through the FortiGate unit, between FortiGate interfaces, zones, and VLAN sub-interfaces.

Security logs

Security logs (FortiGate) record all antivirus, web filtering, application control, intrusion prevention, email filtering, data
leak prevention, vulnerability scan, and VolP activity on your managed devices.

DNS logs

DNS logs (FortiGate) record the DNS activity on your managed devices.

Event logs

Event logs record administration management and Fortinet device system activity, such as when a configuration
changes, or admin login or HA events occur. Event logs are important because they record Fortinet device system
activity which provides valuable information about how your Fortinet unit is performing. FortiGate event logs includes
System, Router, VPN, User, and WiFi menu objects to provide you with more granularity when viewing and searching

log data.
NP The logs displayed on your FortiAnalyzer depends on the device type logging to it and the
‘Q' enabled features. FortiGate, FortiCarrier, FortiCache, FortiMail, FortiManager, FortiWeb,
- FortiSandbox, FortiClient, and Syslog logging is supported. ADOMs must be enabled to

support non-FortiGate logging.

For more information on logging see the Logging and Reporting for FortiOS Handbook in the Fortinet Document
Library.

Log messages

You can view log information by device or by log group.

Viewing the log message list of a specific log type
You can find FortiMail and FortiWeb logs in their default ADOMs.

To view the log message list:

1. If using ADOMSs, ensure that you are in the correct ADOM.

2. Goto Log View, and select a log type from the tree menu.
The corresponding log messages list is displayed.
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Viewing message details

To view message details:

1. Double-click a message in the message list.
The details pane is displayed to the right of the message list, with the fields categorized in tree view.

‘ Add Filter

[0 © A AllDevices~  Last1Hour~ 01:35:47 To 02:35:46

# ¥ Date/Time Device ID

1 02:35:29
2 02:35:29
3 02:35:29
4 02:35:29
5

3 02:35:29
7 02:35:29
8 02:35:29
9 02:35:29
10  02:35:29
11 02:35:29
12 02:35:29
13 02:35:29
14 02:35:29
15 02:35:29
16 02:35:29
17 02:35:

FGT1KC0000000...
FGT1KC0000000...
FGT1KCO000000...
FGT1KCO0000000..

FGT1KC0000000..
FGT1KC0000000...

FGT1KCO000000..

FGT1KCO0000000...

FGT1KC0000000..

FGT1KC0000000...
FGT1KC0000000...
FGT1KCO000000...

FGT1KCO0000000..

FGT1KC0000000...
FGT1KC0000000..
FGT1KC0000000...

£= Total logs for analytics: 8 hours. More

Action Source

v 172.18.4.112

v lliao (§%172.28.3.133)
v £3172.16.175.133

v 5172.184.112

N S S S O S O S R R

£53172.16.175.133
#172.184.112
£4172.16.175.133
172.16.175.133
2172.184.112
172.184.112
172.16.175.133
172.184.112
££110.2.60.65
172.184.112
£5110.2.60.65
1168.2.115

Destination IP
172.18.4.108
#5157.55.56.170
172.18.4.108
172.18.4.108
E523.3.105.162
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
172.18.4.108
1+1208.91.112.53
172.18.4.108
1#1208.91.112.52
10.2.60.58

Service
HTTPS
udp/40032
HTTPS
HTTPS

~ 0.041 Second

Application
HTTPS  ~

udp/4003.
HTTPS

HTTPS

=-Security

1PS Count.
Level
Threat Score

+-General
+-Source
+}- Destination
=-Action

Action
Firewall Action
Poiicy ID
Security Action
Threat

*-Application
+) Data

+)- Threat

=+ Type

SubType
Type

+-Others

e1Ps
v dlose
2

© block
8192

forward
traffic

50 |ltemsperpage « «2 3 4 5

You can display the log details pane below the message list by clicking the Botftom icon in the log details pane.
When the log details pane is displayed below the message list, you can move it to the right of the log message list
by clicking the Right icon. This is sometimes referred to as docking the pane to the bottom or right of the screen.

The log details pane provides shortcuts for adding filters and for showing or hiding a column. Right-click a log field to
select an option.

_ ox
= -Security
L Level information
+ -General
— -Source
-Agent Debian
Device ID FG100D3G13805309
Device Name FG100D3G13805309
Source 172.28.3.15
.Source IP 172.28.3.15

ource |nterface v o
@, search "Source Interface = FMG-GUI-Team"
% T @, search "Source Interface != FMG-GUI-Team"

i 1 =+ add "Source Interface” to column settings
| Firewall Action analytics
. Policy ID 20
+ -Application
— -Type
: -Sub Type virus
- L Type utm
+-Others
Ay

If the log message contains UTM logs, you can click the UTM log icon in the log details pane
to open the UTM log view window.
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Customizing displayed columns
The columns displayed in the log message list can be customized and reordered as needed.

To customize what columns to display:

1. Inthe toolbar of the log message list view, click Column Settings and select a column to hide or display.
The available columns vary depending on the device and log type.

2. To add other columns, click More Columns. In the Column Settings dialog box, select the columns to show or

hide.
3. Toreset to the default columns, click Reset to Default.
4. Click OK.
\‘ ! 'l
? You can also add or remove a log field column in the log details pane, by right-clicking a
|| log field and selecting Add [log field name] or Remove [log field name].

To change the order of the displayed columns:

Place the cursor in the column title and move a column by drag and drop.

Filtering messages

You can apply filters to the message list. Filters are not case-sensitive by default. If available, select Tools > Case
Sensitive Search to create case-sensitive filters.
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Filtering messages using filters in the toolbar

1. Go to the view you want.

Regular search Click Add Filter and select a filter from the dropdown list, then type a value.
Only displayed columns are available in the dropdown list. You can use search
operators in regular search.

Switching between regular At the right end of the Add Filter box, click the Switch to Advanced Search
search and advanced search icon a or click the Switch to Regular Search icon .

Advanced search In Advanced Search mode, enter the search criteria (log field names and
values).

Search operators and syntax If available, click (] at the right end of the Add Filter box to view search
operators and syntax. See also Filter search operators and syntax on page 48.

CLI string “freestyle” search  Searches the string within the indexed fields configured using the CLI
command: config ts-index-field.

For example, if the indexed fields have been configured using these CLI
commands:
config system sqgl
config ts-index-field
edit "FGT-traffic"
set value "app,dstip,proto,service,srcip,user,utmaction”
next
end
end
Then if you type “Skype” in the Add Filter box, FortiAnalyzer searches for
“Skype” within these indexed fields:
app,dstip, proto, service, srcip,user and utmaction

You can combine freestyle search with other search methods, for example:
Skype user=David.

2. Inthe toolbar, make other selections such as devices, time period, which columns to display, etc.

Filtering messages using the right-click menu

In a log message list, right-click an entry and select a filter criterion. The search criterion with a @ icon returns entries
matching the filter values, while the search criterion with a & icon returns entries that do not match the filter values.

Depending on the column in which your cursor is placed when you right-click, Log View uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

NP To see log field name of a filter/column, right-click the column of a log entry and select a
‘Q' context-sensitive filter. The Add Filter box shows log field name.
- Context-sensitive filters are available for each log field in the log details pane. See Viewing

message details on page 45.
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Filtering messages using smart action filters

For Log View windows that have an Action column, the Action column displays smart information according to policy
(log field action) and utmaction (UTM profile action).

The Action column displays a green checkmark Accept icon when both policy and UTM profile allow the traffic to pass
through, that is, both the log field action and UTM profile action specify allow to this traffic.

The Action column displays a red X Deny icon and the reason when either the log field action or UTM profile action
deny the traffic.

If the traffic is denied due to policy, the deny reason is based on the policy log field action.

If the traffic is denied due to UTM profile, the deny reason is based on the FortiView threattype from craction.
craction shows which type of threat triggered the UTM action. The threattype, craction, and crscore fields
are configured in FortiGate in Log & Report. For more information, see the FortiOS - Log Message Reference in the
Fortinet Document Library.

Afilter applied to the Action column is always a smart action filter.

The smart action filter uses the FortiGate UTM profile to determine what the Action column
displays. If the FortiGate UTM profile has set an action to allow, then the Action column will
O ! ’, display that line with a green Accept icon, even if the craction field defines that traffic as a
q threat. The green Accept icon does not display any explanation.
- In the scenario where the craction field defines the traffic as a threat but the FortiGate
UTM profile has set an action to allow, that line in the Log View Action column displays a
green Accept icon. The green Accept icon does not display any explanation.

Filter search operators and syntax

Operators or symbols Syntax

And Find log entries containing all the search terms. Connect the terms with a space
character, or “and”. Examples:
1. user=henry group=sales
2. user=henry and group=sales

Or Find log entries containing any of the search terms. Separate the terms with “or”
oracomma “,”. Examples:
1. user=henry or srcip=10.1.0.15
2. user=henry, linda

Not Find log entries that do NOT contain the search terms. Add “-” before the field
name. Example:

-user=henry

> < Find log entries greater than or less than a value, or within a range. This operator
only applies to integer fields. Example:

policyid>1 and policyid<10

IP subnet/range search Find log entries within a certain IP subnet or range. Examples:
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Operators or symbols Syntax

1. srcip=192.168.1.0/24
2. srcip=10.1.0.1-10.1.0.254

Wildcard search You can use wildcard searches for all field types. Examples:
1. srcip=192.168.1.*
2. policyid=1*
3. user=*

Filtering FortiClient log messages in FortiGate traffic logs

For FortiClient endpoints registered to FortiGate devices, you can filter log messages in FortiGate traffic log files that
are triggered by FortiClient.

To Filter FortiClient log messages:

Go to Log View > Traffic.
In the Add Filterbox, type fct devid=*. Alist of FortiGate traffic logs triggered by FortiClient is displayed.
In the message log list, select a FortiGate traffic log to view the details in the bottom pane.

Click the FortiClient tab, and double-click a FortiClient traffic log to see details.
The FortiClient tab is available only when the FortiGate traffic logs reference FortiClient traffic logs.

A oODbd =

Viewing historical and real-time logs

By default, Log View displays historical logs. Custom View and Chart Builder are only available in historical log view.
To view real-time logs, in the log message list view toolbar, click Tools > Real-time Log.

To switch back to historical log view, click Tools > Historical Log.

Viewing raw and formatted logs

By default, Log View displays formatted logs. The log view you select affects available view options. You cannot
customize columns when viewing raw logs.

To view raw logs, in the log message list view toolbar, click Tools > Display Raw.
To switch back to formatted log view, click Tools > Formatted Log.

For more information about FortiGate raw logs, see the FortiGate Log Message Reference in the Fortinet Document
Library. For more information about raw logs of other devices, see the Log Message Reference for the platform type.

Custom views

Use Custom View to save the filter setting, device selection, and the time period you have specified.
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To create a new custom view:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type.
3. Inthe content pane, customize the log view as needed by adding filters, specifying devices, and/or specifying a

time period.
4. In the toolbar, click Custom View.

Save as New Custom View

5. Inthe Namefield, type a name for the new custom view.
6. Click OK. The custom view is now displayed under Log View > Custom View.

To edit a custom view:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Gotothe Log View > Custom View.

3. Inthe toolbar, edit the filter settings, and click GO.

4. Inthe toolbar, click Custom View.

5

Click Save to save the changes to the existing custom view or click Save as to save the changes to a new custom
view.

Click OK.

o

To view the traffic log of a custom view:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Gotothe Log View > Custom View.
3. Right-click the name of a custom view and select View Traffic.

Downloading log messages

You can download historical log messages to the management computer as a text or CSV file. You cannot download
real-time log messages.

To download log messages:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Log View, and select a log type.

In the toolbar, click Tools > Download.

In the Download Logs dialog box, configure download options:
« Inthe Log file format dropdown list, select Text or CSV.

AoODbd =

o To compress the downloaded file, select Compress with gzip.
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» To download only the current log message page, select Current Page. To download all the pages in the log
message list, select All Pages.

5. Click Download.

Creating charts

\ L}
‘?' You can also create charts in Reports > Report Definitions > Chart Library. See Chart library
- on page 113

Log View includes a Chart Builderfor you to build custom charts for each type of log messages.

To create charts with Chart Builder:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type.
3. Inthe toolbar, click Tools > Chart Builder.
4. Inthe Chart Builder dialog box, configure the chart and click Save.
Name Type a name for the chart.
Columns Select which columns of data to include in the chart based on the log
messages that are displayed on the Log View page.
Group By Select how to group data in the chart.
Order By Select how to order data in the chart.
Sort Select a sort order for data in the chart.
Show Limit Show Limit
Device Displays the device(s) selected on the Log View page.
Time Frame Displays the time frame selected on the Log View page.
Query Displays the query being built.
Preview Displays a preview of the chart.

Log groups

You can group devices into log groups. You can view FortiView summaries, display logs, generate reports, or create
handlers for a log group. Log groups are virtual so they do not have SQL databases or occupy additional disk space.

Ay
‘?' In FortiAnalyzer 5.0.6 and earlier, you can treat log groups as a single device that has its own
- SQL database. You cannot do this in FortiAnalyzer 5.2 and later.
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When you add a device with VDOMs to a log group, all VDOMSs are automatically added.

To create a new log group:

Go to Log View > Log Group.

In the content pane toolbar, click Create New.

In the Create New Log Group dialog box, type a log group name and add devices to the log group.
Click OK.

AoODbd-=

Log browse

When a log file reaches its maximum size or a scheduled time, FortiAnalyzer rolls the active log file by renaming the file.
The file name is in the form of x10g.N. 1og, where x is a letter indicating the log type, and N is a unique number
corresponding to the time the first log entry was received. For information about setting the maximum file size and log
rolling options, see Device logs on page 185.

Log Browse displays log files stored for both devices and the FortiAnalyzer itself, and you can logs in the compressed
phase of the log workflow.

A\,

To view log files:

In Collector mode, if you want to view the latest log messages, select the latest log file to
display its log messages.

1. Goto Log View > Log Browse

2. Select alog file, and click Display to open the log file and display the log messages in formatted view.
You can perform all the same actions as with the log message list. See Viewing message details on page 45.

Add Filter ()] B All Devices ~ (D Last 5 Minutes ~ M Display T Delete & Download ] Import
S F 3 A Device Name Serial Number VDOM Type File Name From To Size(bytes)
o1 FG100D3G00000000 FG100D3G00000000  root Event elog.log 2018-05-30 02:0... 2018-05-3013:0.. 134,358
o2 FG100D3G00000000 FG100D3G00000000 root Traffic tlog.log 2018-05-3002:0... 2018-05-3013:1... 3,924,969
(8] & FG1K2D3100000000 FG1K2D3100000000 root Event eloglog 2018-05-3002:0... 2018-05-3013:0.. 52,663

o 4 FG1K2D3100000000 FG1K2D3100000000 root Traffic tlog.log 2018-05-30 13:0... 2018-05-3013:1.. 71,916,545
o s FG3K2D3Z00000000 FG3K2D3Z00000000  root Event eloglog 2018-05-3002:0... 2018-05-3013:0.. 8,696

0 s FG3K2D3Z00000000 FG3K2D3Z00000000 root Event eloglog 2018-05-3002:0... 2018-05-3013:0... 346,536
a7 FG3K2D3Z00000000 FG3K2D3Z00000000  root Traffic tlog.log 2018-05-30 13:0... 2018-05-3013:1.. 782,844

o s FG900D3000000000 FG200D3900000000 root VolP plog.log 2018-05-3002:0... 2018-05-3013:0... 9,869
a9 FG$00D3900000000 FG200D3900000000 root Event eloglog 2018-05-3002:0... 2018-05-3013:0... 76,955

O 10 FG900D3000000000 FG200D3900000000 root Traffic tlog.log 2018-05-3002:0... 2018-05-3013:0.. 3,230,023
o 11 FG$00D3900000000 FG200D3900000000 root Event eloglog 2018-05-3002:0... 2018-05-3013:0.. 2,638

Importing a log file

Imported log files can be useful when restoring data or loading log data for temporary use. For example, if you have
older log files from a device, you can import these logs to the FortiAnalyzer unit so that you can generate reports
containing older data.
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Log files can also be imported into a different FortiAnalyzer unit. Before importing the log file you must add all devices
included in the log file to the importing FortiAnalyzer.

To insert imported logs into the SQL database, the config system sql start-time and rebuild-event-
start-time must be older than the date of the logs that are imported and the storage policy for analytic data (the
Keep Logs for Analytics field) must also extend back far enough.

To set the SQL start time and rebuild event start time using CLI commands:

config system sqgl

set start-time <start-time-and-date>

set rebuild-event-start-time <start-time-and-date>
end

Where <start-time-and-date>isinthe format hh:mm yyyy/mm/dd.

To import a log file:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto Log View > Log Browse and click Import in the toolbar.

3. Inthe Device dropdown list, select the device the imported log file belongs to or select [Take From Imported File]
to read the device ID from the log file.

If you select [Take From Imported File], the log file must contain a device id field initslog messages.

4. Drag and drop the log file onto the dialog box, or click Add Files and locate the file to be imported on your local
computer.

5. Click OK. A message appears, stating that the upload is beginning, but will be canceled if you leave the page.

6. Click OK. The upload time varies depending on the size of the file and the speed of the connection.
After the log file is successfully uploaded, FortiAnalyzer inspects the file:

o Ifthedevice idfieldinthe uploaded log file does not match the device, the import fails. Click Return to try
again.

o If you selected [Take From Imported File] and the FortiAnalyzer unit’s device list does not currently contain
that device, an error is displayed stating /nvalid Device ID.

Downloading a log file

You can download a log file to save it as a backup or to use outside the FortiAnalyzer unit. The download consists of
either the entire log file, or a partial log file, as selected by your current log view filter settings and, if downloading a raw
file, the time span specified.

To download a log file:

1. Goto Log View > Log Browse and select the log file that you want to download.
2. In the toolbar, click Download.
3. Inthe Download Log File(s) dialog box, configure download options:
« Inthe Log file format dropdown list, select Native, Text, or CSV.
« If you want to compress the downloaded file, select Compress with gzip.
4. Click Download.
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Deleting log files

To delete log files:

1. Goto Log View > Log Browse.
2. Select one or more files and click Delete.
3. Click OK to confirm.

Log and file storage

Logs and files are stored on the FortiAnalyzer hard disks. Logs are also temporarily store in the SQL database.

When ADOMs are enabled, settings can be specified for each ADOM that apply only to the devices in it. When ADOMs
are disabled, the settings apply to all managed devices.

Data policy and disk utilization settings for devices are collectively called log storage settings. Global log and file storage
settings apply to all logs and files, regardless of log storage settings (see File Management on page 189). Both the
global and log storage settings are always active.

Disk space allocation

On the FortiAnalyzer, the system reserves 5% to 20% of the disk space for system usage and unexpected quota
overflow. The remaining 80% to 95% of the disk space is available for allocation to devices.

Reports are stored in the reserved space.

Total Available Disk Size Reserved Disk Quota
Small Disk (up to 500GB) The system reserves either 20% or 50GB of disk space, whichever is smaller.
Medium Disk (up to 1TB) The system reserves either 15% or 100GB of disk space, whichever is smaller.
Large Disk (up to 5TB) The system reserves either 10% or 200GB of disk space, whichever is smaller.
Very Large Disk (5TB and The system reserves either 5% or 300GB of disk space, whichever is smaller.
higher)
s‘ ! ', The RAID level you select determines the disk size and the reserved disk quota level. For
9 example, a FortiAnalyzer 1000C with four 1TB disks configured in RAID 10 is considered a
- large disk, so 10%, or 100GB, of disk space is reserved.

Log and file workflow

When devices send logs to a FortiAnalyzer unit, the logs enter the following workflow automatically:

1. Compressed logs are received and saved in a log file on the FortiAnalyzer disks.
When a log file reaches a specified size, FortiAnalyzer rolls it over and archives it, and creates a new log file to
receive incoming logs. You can specify the size at which the log file rolls over. See Device logs on page 185.
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2. Logs are indexed in the SQL database to support analysis.
You can specify how long to keep logs indexed using a data policy. See Log storage information on page 57.

3. Logs are purged from the SQL database, but remain compressed in a log file on the FortiAnalyzer disks.

4. Logs are deleted from the FortiAnalyzer disks.
You can specify how long to keep logs using a data policy. See Log storage information on page 57.
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In the indexed phase, logs are indexed in the SQL database for a specified length of time so they can be used for
analysis. Indexed, or Analytics, logs are considered online, and details about them can be used viewed in the FortiView,
NOC - SOC, Log View, and Event Manager modules. You can also generate reports about the logs in the Reports
pane.

In the compressed phase, logs are compressed and archived in FortiAnalyzer disks for a specified length of time for the
purpose of retention. Compressed, or Archived, logs are considered offline, and their details cannot be immediately
viewed or used to generate reports.

The following table summarizes the differences between indexed and compressed log phases:

Log Phase Location Immediate Analytic Support

Indexed Compressed in log file and Yes. Logs are available for analytic use in FortiView,
indexed in SQL database NOC - SOC, Event Manager, and Reports.

Compressed Compressed in log file No.
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Automatic deletion

Logs and files are automatically deleted from the FortiAnalyzer unit according to the following settings:

« Global automatic file deletion
File management settings specify when to delete the oldest Archive logs, quarantined files, reports, and archived
files from disks, regardless of the log storage settings. For more information, see File Management on page 189.
« Data policy
Data policies specify how long to store Analytics and Archive logs for each device. When the specified length of
time expires, Archive logs for the device are automatically deleted from the FortiAnalyzer device's disks.
« Disk utilization
Disk utilization settings delete the oldest Archive logs for each device when the allotted disk space is filled. The
allotted disk space is defined by the log storage settings. Alerts warn you when the disk space usage reaches a
configured percentage.

All deletion policies are active on the FortiAnalyzer unit at all times, and you should carefully configure each policy. For
example, if the disk fullness policy for a device hits its threshold before the global automatic file deletion policy for the
FortiAnalyzer unit, Archive logs for the affected device are automatically deleted. Conversely, if the global automatic file
deletion policy hits its threshold first, the oldest Archive logs on the FortiAnalyzer unit are automatically deleted
regardless of the log storage settings associated with the device.

The following table summarizes the automatic deletion polices:

Policy Scope Trigger

Global automatic file Al logs, files, and When the specified length of time expires, old files are automatically

deletion reports on the deleted. This policy applies to all files in the system regardless of the
system data policy settings associated with devices.

Data policy Logs for the device When the specified length of retention time expires, old Archive logs

with which the data for the device are deleted. This policy affects only Archive logs for the
policy is associated device with which the data policy is associated.

Disk utilization Logs for the device When the specified threshold is reached for the allotted amount of
with which the log disk space for the device, the oldest Archive logs are deleted for the
storage settings are device. This policy affects only Archive logs for the device with which
associated the log storage settings are associated.

Logs for deleted devices

When you delete one or more devices from FortiAnalyzer, the raw log files and archive packets are deleted, and the
action is recorded in the local event log. However, the logs that have been inserted into the SQL database are not
deleted from the SQL database. As a result, logs for the deleted devices might display in the Log View and FortiView
panes, and any reports based on the logs might include results.

The following are ways you can remove logs from the SQL database for deleted devices.

« Rebuild the SQL database for the ADOM to which deleted devices belonged or rebuild the entire SQL database.

« Configure the log storage policy. When the deleted device logs are older than the Keep Logs for Analytics setting,
they are deleted. Also, when analytic logs exceed their disk quota, the SQL database is trimmed starting with the
oldest database tables. For more information, see Configuring log storage policy on page 58.
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« Configure global automatic file deletion settings in System Settings > Advanced > File Management. When the
deleted device logs are older than the configured setting, they are deleted. For more information, see File
Management on page 189.

Ay
‘9' File Management configures global settings that override other log storage settings and
- apply to all ADOMs.

Log storage information

To view log storage information and to configure log storage policies, go to System Settings > Storage Info.

If ADOMSs are enabled, you can view and configure the data policies and disk usage for each ADOM.

The log storage policy affects only the logs and SQL database of the devices associated with the log storage policy.
Reports are not affected. See Disk space allocation on page 54.

[# Edit & Refresh Q
e Analytics (Actual/Config Days)  Archive (Actual/Config Days)  Max Storage  Analytics Usage (Used/Max)  Archive Usage (Used/Max)
wortiGates (2)

FortiCarrier 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
root 0/60 2/365 | 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
wOther Device Types (10)

FortiAnalyzer 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiAuthenticator ~ 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiCache 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiClient 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiDDoS 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiMail 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiManager 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiSandbox 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiWeb 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
Syslog 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)

The following information and options are available:

Edit
Refresh
Search

Name

Analytics
(Actual/Config Days)

Archive
(Actual/Config Days)

Max Storage

Analytics Usage
(Used/Max)

Archive Usage
(Used/Max)

Edit the selected ADOM's log storage policy.
Refresh the page.
Enter a search term to search the list.

The name of the ADOM.
ADOMs are listed in two groups: FortiGates and Other Device Types.

The age, in days, of the oldest Analytics logs (Actual Days), and the number of days
Analytics logs will be kept according to the data policy (Config Days).

The age, in days, of the oldest Archive logs (Actual Days) and the number of days
Archive logs will be kept according to the data policy (Config Days).

The maximum disk space allotted to the ADOM (for both Analytics and Archive logs).
See Disk space allocation on page 54 for more information.

How much disk space Analytics logs have used, and the maximum disk space allotted
for them.

How much disk space Archive logs have used and the maximum disk space allotted for
them.
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Storage information

To view log storage policy and statistics, go to System Settings > Storage Info.

The top part of Storage Info shows visualizations of disk space usage for Analytic and Archive logs where the policy
diagrams show an overview and the graphs show disk space usage details. The bottom part shows the log storage
policy.

Analytics Policy Analytics Details Show Up to Today ~ Max Line:[]

2270000

eIV N / \

86% = \/ \ /\ JK\/\/ V/\/N \\
\

|

Keep Logs for 15 Days

Actual Logs for 7 Days

— Actual

Archive Policy Archive Details Show All Configured Days ~ Max Line:[IZ]
£40000 2| Max Quota - 629146MB
0000 2
20000
30000
g 580000 WA IWAMSS ISV A A
540000
- \
s
500000 Vi
Keep Logs for 60 Days ] i : ! : i . .
Actual Logs for 35 Days 5 1o 15 2 £ @ 3 &

— Actual — Max - - Trend

The policy diagram shows the percentage of the disk space quota that is used. Hover your cursor over the diagram to
view the used, free, and total allotted disk space. The configured length of time that logs are stored is also shown.

The graphs show the amount disk space used over time. Click Max Line to show a line on the graph for the total space
allotted. Hover over a spot in the graph to view the used and available disk space at that specific date and time. Click
the graph to view a breakdown of the disk space usage by device.

Analytics Storage Statistics - Last 15 Days

Device Name Analytics Usage Average Log Rate (logs/sec) Peak Log Rate (logs/sec)
FGT37D0000000000 743.1GB 38.35% 1087.14 1615.27
FGB0O0CO000000000 221.4 MB 0.01% 424 35.58

Weixixixi_WiFi 3.1GB 0.16% 4.48 32,80
FG3K2D0000000000 513 GB 2.65% 77.29 78174
FG1K2DOD00000000 716.4 GB 36.97% 1048.14 2376.82
FG100D0000000000 4238GB 2187% 619.99 1726.02

When the used quota approaches 100 percent, a warning message displays when accessing the Storage Statistics
pane.

Warning

Analytic is using 89% of allocated disk space.
Archive is using 88% of allocated disk space.

Please click "Configure Now" button to increase ADOM quota.

[ corue o

Click Configure Now to open the Edit Log Storage Policy dialog box where you can adjust log storage policies to
prevent running out of allocated space (see Configuring log storage policy on page 58), or click Remind Me Later to
resolve the issue another time.

Configuring log storage policy

The log storage policy affects the logs and SQL database of the device associated with the log storage policy.

FortiAnalyzer 6.0.8 Administration Guide
Fortinet Technologies Inc.



Log View and Log Quota Management

If you change log storage settings, the new date ranges affect Analytics and Archive logs

A currently in the FortiAnalyzer device. Depending on the date change, Analytics logs might be
purged from the database, Archive logs might be added back to the database, and Archive
logs outside the date range might be deleted.

To configure log storage settings:

1. Goto System Settings > Storage Info.

2. Double-click on an ADOM, right-click on an ADOM and then select Edit from the menu, or select the ADOM then
click Edit in the toolbar. Scroll to the log storage policy sections at the bottom of the Edit Log Storage Policy pane.
Edit Log Storage Policy - ADOM : root
Data Palicy
Keep Logs for Analytics 365 = Days
Keep Logs for Archive 365 > Days

Disk Utilization
Maximum Allowed 50 > GB v Out of Available: 50.0 GB

Analytics : Archive 60% v 40% Modify
Alert and Delete When Usage Reaches 100%

*If analytic or archive log usages exceed the configured disk quota before the retention period expires, the oldest logs will be deleted.

e

3. Configure the following settings, then click OK.

Data Policy
Keep Logs for Specify how long to keep Analytics logs.
Analytics
Keep Logs for Specify how long to keep Archive logs.
Archive Make sure your setting meets your organization’s regulatory requirements.

Disk Utilization

Maximum Allowed Specify the amount of disk space allotted. See also Disk space allocation on

page 54.
Analytics : Specify the disk space ratio between Analytics and Archive logs. Analytics logs
Archive require more space than Archive logs. Click the Modify checkbox to change
the setting.
Alert and Delete Specify the percentage of allotted disk space usage that will trigger an alert
When Usage messages and start automatically deleting logs. The oldest Archive log files or
Reaches Analytics database tables are deleted first.
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Use Event Managerto generate, monitor, and manage alerts and events from logs. The live monitoring of security
events is a powerful and enabling feature for security operations. Incidents can be created from events to track and
respond to suspicious or malicious activities.

Event Manager displays all events generated by event handlers.

Event handlers

Event handlers determine what events to be generated from logs. Enable an event handler to start generating events.
To see which event handlers are enabled or disabled, see Enabling event handlers on page 67.

When ADOMs are enabled, each ADOM has its own event handlers and lists of events. Ensure you are in the correct
ADOM when working in Event Manager.

You can use predefined event handlers to generate events. There are predefined event handlers for FortiGate and
FortiCarrier devices.

You can create custom event handlers. An easy way to create a custom event handler is to clone a predefined event
handler and customize its settings. See Cloning event handlers on page 68.

Configure event handlers to generate events for all devices, a specific device, or for the local FortiAnalyzer unit. You can
create event handlers for FortiGate, FortiCarrier, FortiCache, FortiMail, FortiManager, FortiWeb, FortiSandbox
devices, and syslog servers. In 5.2.0 or later, Event Manager supports local FortiAnalyzer event logs.

To see event handlers, go to Event Manager > Event Monitor > Event Handler List.

Event handlers generate events only from Analytics logs and not Archive logs. For more information, see Archive logs
and Analytics logs on page 28.

In an Analyzer—Collector collaboration scenario, the Analyzer evaluates event handlers. For more information, see
Analyzer—Collector collaboration on page 27.

Predefined event handlers

FortiAnalyzer includes many predefined event handlers for FortiGate and FortiCarrier devices that you can use to
generate events. You can easily create a custom event handler by cloning a predefined event handler and customizing
its settings. See Cloning event handlers on page 68.

The following are a small sample of predefined event handlers. To see all predefined event handlers, go to Event
Manager > Event Monitor > Event Handler List and select Show Predefined.

Event Handler Description

Application Crashed Event Enabled by default
« Event Severity: Medium
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Event Handler Description

o Log Type: Event Log
o Log Subtype: System
o Group by: Log Description
« Log messages that match all conditions:
o Log Description Equal To Application crashed
o Level Greater Than or Equal To Waming
Default-High-Risk-App- Disabled by default
Detection Filter 1:
« Event Severity: Medium
o Log Type: Application Control
o Group by: Source Endpoint, Application Name

o Log messages that match all of the following conditions:

« Action Equal To Block
« Application Risk Equal To critical
Filter 2:
« Event Severity: High
« Log Type: Application Control
o Group by: Source Endpoint, Application Name

« Log messages that match all of the following conditions:

« Action Not Equal To Block
« Application Risk Equal To critical
Filter 3:
« Event Severity: Low
o Log Type: Application Control
o Group by: Source Endpoint, Application Name

« Log messages that match all of the following conditions:

« Action Equal To Block
« Application Risk Equal To high

Filter 4:
« Event Severity: Medium
o Log Type: Application Control
o Group by: Source Endpoint, Application Name

« Log messages that match all of the following conditions:

« Action Not Equal To Block
« Application Risk Equal To high

Default - Sandbox-Detection Disabled by default
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Event Handler Description

Filter 1:
« Event Severity: Critical
o Log Type: AntiVirus
o Group by: Endpoint, Virus Name
« Log messages that match all of the following conditions:
o logid==0211009235
Filter 2:
« Event Severity: Critical
o Log Type: AntiVirus
o Group by: Endpoint, Virus Name
« Log messages that match all of the following conditions:
o logid==0211009234
Filter 3:
« Event Severity: Critical
o Log Type: AntiVirus
o Group by: Endpoint
« Log messages that match all of the following conditions:
o logid==0201009238 and fsaverdict==malicious

Default-Compromised Host- Disabled by default
Detection-by 10C Filter 1:
« Event Severity: Critical
o Log Type: Traffic Log
« Group by: Endpoint
« Log messages that match all of the following conditions:
« tdtype~infected
Filter 2:
« Event Severity: Critical
o Log Type: Web Filter
« Group by: Endpoint
« Log messages that match all of the following conditions:
« tdtype~infected
Filter 3:
« Event Severity: Critical
o Log Type: DNS Log
« Group by: Endpoint
« Log messages that match all of the following conditions:
« tdtype~infected

IPS - Critical Severity Enabled by default
o Event Severity: Critical
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Event Handler Description

o Log Type: IPS

o Group by: Attack Name

« Log messages that match all conditions:
« Severity Equal To Critical

UTM Antivirus Event Enabled by default
« Event Severity: High
o Log Type: Antivirus
« Group by: Virus Name
o Log messages that match all conditions:

o Level Greater Than or Equal To Information
o virus!="and virus!="N/A" and dtype!="fortisandbox'

UTM Web Filter Event Enabled by default

« Event Severity: Medium

o Log Type: Web Filter

o Group by: Category

« Log messages that match any of the following conditions:
o Web Category Equal To Child Abuse
o Web Category Equal To Discrimination
« Web Category Equal To Drug Abuse
« Web Category Equal To Explicit Violence
« Web Category Equal To Extremist Groups
« Web Category Equal To Hacking
o Web Category Equal To lllegal or Unethical
o Web Category Equal To Plagiarism
« Web Category Equal To Proxy Avoidance
« Web Category Equal To Malicious Websites
« Web Category Equal To Phishing
o Web Category Equal To Spam URLs

FortiGate event handlers

All FortiGates added to FortiAnalyzer use a default event handler on the FortiAnalyzer side to receive high severity
events such as Botnet Communication, IPS Attack Pass Through, and Virus Pass Through AntiVirus. You can create
custom FortiGate event handlers.

The triggered event from FortiGate Event Handler is not shown in the FortiAnalyzer GUI. The events are pushed to the
FortiGate for further processing.

Creating a custom event handler
You can create a custom event handler from scratch or clone a predefined event handler and customize its settings. See

Cloning event handlers on page 68.
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Configuring an event handler includes defining the following main sections:

Option Description

Event handler attributes Event handler attributes such as name and description.

Filters Filters are rules for event generation.
« Select the log filters to limit the logs that trigger an event.
« Group the logs by primary and secondary (optional) values to separate the
events that are generated for different Group By values.
« Set the number of occurrences within a time frame that triggers an event.
« Configure event fields such as event status and severity.

Notifications Configure notifications to be sent on event generation.
You can send alert notifications to an email address, SNMP community, or syslog
server.

Create New Handler

Status 21

Name

Description

Devices @Al Devices O Specify

Filters +

Filter 1 ~

Log Type DNS Log

Group By Device ID

Logs match OAll @ Any of the following conditions

Log Field Match Criteria Value
Level (pri) +| | EqualTo v | | Emergency o +oE

Generic Text Filter @

Generate alert when at least| 1 +1 matches occurred over a period of 30 %1 minutes

Event Message @

Event Status (Blank)

O Allow FortiAnalyzer to choose

Event Severity Medium

Tags Add a value

Notifications

Osend Alert Email

(Jsend SNMP(v1/v2) Trap

E5end SNMP(v3) Trap -+

[Jsend Alert to Syslog Server

Osend Each Alert Separately

To create a new event handler:

1. Go to Event Manager > Event Monitor > Event Handler List.
2. Inthetoolbar, click Create New.
3. Configure the settings as required and click OK.

Field Description

Status Enable or disable the event handler.
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Field Description

Enabled event handlers have a Status of ON and show the O icon in the
Event Handler List. Disabled event handlers have a a Status of OFF and

show the @ icon in the Event Handler List.

Name Add a name for the handler.
Description Type a description of the event handler.
Devices Select the devices to include.

o AllDevices.
« Specify: To add devices, click the Add icon.

« Local Device: Select if the event handler is for local FortiAnalyzer event
logs. This option is only available in the root ADOM and is used to query
FortiAnalyzer event logs.

For Local Device, the Log Type must be Event Log and Log Subtype
must be Any.

Filters Configure one or more filters for the handler. You can add multiple filters each
with its own set of filter settings. You can enable or disable specific filters in
an event handler.

Log Type Select the log type from the dropdown list.
When Devices is set to Local Device, you cannot change the Log Type or
Log Subtype.

Log Subtype Select the category of event that this handler monitors. The available options

depends on the platform type.
This option is only available when Log Type is set to Event Log or Traffic Log.

Group By Select how to group the events. Some Group By selections allow a secondary
Group By option. If available, click Add beside the Group By field to add a
secondary Group By option.

Logs match Select All or Any of the following conditions.

Log Field Select a log field to filter from the dropdown list. The available options

depends on the selected log type.

Match Criteria Select a match criteria from the dropdown list. The available options depends
on the selected log field.

Value Either select a value from the dropdown list or enter a value in the text box.
The available options depends on the selected log field.

Add Add Log Field to the filter.
Remove Delete the filter.

Generic Text Filter Enter a generic text filter.

For information on text format, hover the cursor over the help icon. The
operator ~ means contains and ! ~ means does not contain.
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Field Description

For more information on creating a generic text filter, see Using the Generic
Text Filter in an event handler on page 66.

Generate alert Enter threshold values to generate alerts. Enter the number of matching
when at least n events that must occur in the number of minutes to generate an alert.
matches occurred

over a period of n

minutes

Event Message If you wish, enter a custom event message. The default message is the
Group By value. You can use variables in the event message.

Event Status Select Allow FortiAnalyzer to choose or select a status from the dropdown
list: Unhandled, Mitigated, Contained, or (Blank).

Event Severity Select the severity from the dropdown list: Critical, High, Medium, or Low.

Tags If you wish, enter custom tags to identify that filter.

Notifications Configure alerts for the handler.

Send Alert Email Send an alert by email. Specify email parameters including the mail server.
For more information, see Mail Server on page 181.

Send SNMP(...) Select one or both checkboxes and specify an SNMP community or user from

Trap the dropdown list. Click the add icon to create a new SNMP community or
user. For more information, see SNMP on page 172.

Send Alert to Send an alert to the syslog server. Select a syslog server from the dropdown

Syslog Server list. Click the add icon to create a new syslog server. For more information,
see Syslog Server on page 183.

Send Each Alert Select to send each alert individually instead of in a group.

Separately

Using the Generic Text Filter in an event handler

You can use the Generic Text Filterto match raw log data. The Generic Text Filter uses the glibc regex library for values
with operators (~,!~), using the POSIX standard. Filter string syntax is parsed by FortiAnalyzer, and both upper and
lower case characters are supported (for example "and" is the same as "AND"). You must use an escape character when
needed. Forexample, cfgpath=firewall.policy isthe wrong syntax because it's missing an escape character.
The correct syntaxis cfgpath=firewall\.policy.

To create an event handler using the Generic Text Filter to match raw log data:

1. Goto Log View, and select a log type.

2. Inthe toolbar, click Tools > Display Raw.
The easiest method is to copy the text string you want from the raw log and paste it into the Generic Text Filter
field. Ensure you insert an escape character when necessary, for example, cfgpath=firewall\.policy.

3. Locate and copy the text in the raw log.
4. Go to Event Manager > Event Monitor > Event Handler List and click Create New.
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5. Inthe Generic Text Filter box, paste the text you copied or type the text you want. Ensure you use the raw log field
names, for example, mem (not memory) and setuprate (not setup-rate).
For information on text format and operators, hover the cursor over the help icon. The operator ~ means contains
and ! ~ means does not contain.

6. If you want to be notified of events, configure the Notifications section.

7. Configure other settings as required and click OK. For a description of the fields, see Creating a custom event
handler on page 63.

Managing event handlers

To manage event handlers, go to Event Manager > Event Monitor > Event Handler List.

FortiAnalyzer includes predefined event handlers for FortiGate and FortiCarrier devices that you can use to generate
events.

This page lists both predefined and custom event handlers with a O icon for enabled event handlers and a @ icon for

disabled event handlers.

The following options are available:

Option Description

Create New Create a new event handler.

Edit Edit the selected event handler.

Some fields in predefined event handlers cannot be modified, such as the name,
description and filter settings. However, you can clone a predefined event handler
and customize its settings. See Cloning event handlers on page 68.

Delete Delete the selected event handler. You cannot delete predefined event handlers.

Clone Clone the selected event handler. You can clone a predefined event handler and
modify it to create a customized event handler.

Enable / Disable Enable or disable the selected event handler to start or stop generating events on
the Event Manager > Event Monitor > All Events page.

Collapse All / Expand All Collapse or expand the Filters column.

Show Predefined Show or hide predefined handlers in the list.

Show Custom Show or hide custom handlers in the list.

Factory Reset If you have modified a predefined event handler, return the selected predefined

event handler to its factory default settings.

Enabling event handlers

For both predefined and custom event handlers, you must enable the event handler to generate events. The Event

Handler List page displays a O icon besides enabled event handlers and a @ icon besides disabled event handlers.

If you want to receive alerts for predefined events handlers, edit the predefined event handler to configure notifications.
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To enable event handlers:

1. Goto Event Manager > Event Monitor > Event Handler List.
2. Select one or more event handlers and click More > Enable or right-click an event handler and select Enable.

Cloning event handlers

Most predefined event handler attributes cannot be modified, such as the name, description and filter settings. You can
clone a predefined event handler and customize its settings, and give it a meaningful name that shows its function.

To clone a predefined event handler:

1. Select a predefined event handler and in the toolbar, click Clone or right-click a predefined event handler and select
Clone.

2. Configure the settings as required and click OK. For a description of the fields, see Creating a custom event
handler on page 63.

3. Click OKto clone the predefined event handler.

Resetting to factory defaults

You can change predefined event handlers as needed. If required, you can restore predefined event handlers to factory
default settings. The Factory Reset option is only available for predefined event handlers that have been changed.

To reset predefined event handlers:

1. Goto Event Manager > Event Monitor > Event Handler List.
2. Inthe More menu, ensure Show Predefined is selected.

3. Right-click an event handler and select Factory Reset or select one or more predefined event handlers and click
More > Factory Reset.

Events

After event handlers start generating events, view events and event details in Event Manager > Event Monitor. All
Events shows events in a tabular format. Calendar View shows events on a calendar.

S ! ’, When rebuilding the SQL database, you might not see a complete list of historical events.
q However, you can always see events in real-time logs. You can view the status of the SQL
- rebuild by checking the Rebuilding DB status in the Notification Center.
All Events

To view all the events, go to Event Manager > Event Monitor > All Events.
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Double-click an event line to drill down for more details.
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Refresh To manually refresh the events data, click Refresh.

You can specify a refresh interval of Every 10 Seconds, Every 30 Seconds,
Every 1 Minute, or Every 5 Minutes.

Time Period To change the time period to display, click the time icon and specify a time
period. Select Custom to specify a time period not in the dropdown list.

Collapse All/Expand All To view event summaries or details, click Collapse All or Expand All.

Show Acknowledged To include acknowledged events, click Show Acknowledged. See
Acknowledging events on page 70.

Export to CSV Download the events to a CSV file.

Custom View Save the current view including filter settings, device selection, and time period.

Filtering events

You can filter events using using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-
sensitive filter.

Filter FortiView summaries using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-
sensitive filter. You can also filter by specific devices or log groups and by time.

To filter events using filters in the toolbar:

« Specify filters in the Add Filter box.

« Regular Search: In the selected summary view, click Add Filter and select a filter from the dropdown list, then
type a value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or

”

“or”.

« Advanced Search: Click the Switch to Advanced Search icon a at the right end of the Add Filter box. In
Advanced Search mode, enter the search criteria (log field names and values). Click the Switch to Regular
Searchicon @ to go back to regular search.
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To filter events using the right-click menu:

In the event list, right-click an entry and select a filter criterion (Search <filter value>).

Depending on the column in which your mouse is placed when you right-click, FortiView uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

Event details

In an event list, to view event details, double-click an event line to drill down for more details.

The event details page contains information about the event and a list of all individual logs. You can work on events
using buttons in the toolbar or by right-clicking an event.

« To change what columns to display, click Column Settings or Column Settings > More Columns.
« In event details, to view raw logs, click Tools > Display Raw.

« To switch back to formatted log view, click Tools > Formatted Log.

« Toreturn to the previous page, click the back button.

Acknowledging events

Acknowledging an event removes it from the event list. Click Show Acknowledged to view acknowledged events.
To acknowledge events:

« Inthe event list, select one or more events, then right-click and select Acknowledge.

Calendar View

Event Monitor > Calendar View shows events by month or week in a calendar or bar chart format.
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To include only events of a specific severity, click Severity Filters and select which severity levels to include. The default
filter is critical and high severity.

Click on any element in any of the views to open the filtered events list; see Filtering events on page 69.

Click the Calendar Chart button in the toolbar to display the calendar. The monthly view of the calendar shows bar
charts of the events by severity on each day of the month. The weekly view shows the events for each hour of each day
of the week. Click the arrows on either side of the calendar heading to scroll through months or weeks.

Click the Bar Chart button in the toolbar to change to the bar chart view. The bar chart view shows a stacked, vertical
bar chart of the count versus time (days). Hovering the cursor over a bar shows the number of logs of each severity and
the total for that day.

3 Refresh {3 Severity Filters ~ < Oct02-0Oct08,2016 > \ \@i

14000

12000
W Critiel 228
10000 High 7423
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“““““ Low
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nnnnn
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Incidents

To view incidents, go to Event Manager > Incidents > All Incidents.

To configure incident settings, go to Event Manager > Incidents > Incident Settings.

Raising an incident

You can raise an incident only from alerts generated for one endpoint.
You can raise an incident in the following ways:

« In Event Manager > Incidents > All Incidents, click Create New in the toolbar. This opens the Create New
Incident pane.

« In Event Manager > All Events, right-click an event and select Raise Incident. This opens the Raise Incident pane
with the applicable fields filled in, such as the Affected Endpoint.

Following is a description of the options available in the Create New Incident and Raise Incident pane.

Incident Reporter The admin account raising the incident. This field cannot be changed.
Incident Category Select a category from the dropdown list.
Severity Select a severity level from the dropdown list.
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Status Select a status from the dropdown list.
Affected Endpoint In the Raise Incident pane, the affected endpoint is filled in and cannot be
changed.

In the Create New Incident pane, select the affected endpoint from the
dropdown list.

Description If you wish, enter a description.

Analyzing an incident

In Event Manager > Incidents > All Incidents, double-click an incident or right-click an incident and select Analysis
Page.

The incident analysis page shows the incident's Affected Endpoint and User, Incident Info, and Events related to the
incident.

In the Incident Info panel, you can change the Incident Category, Severity, Status, and Description.

In the Events panel, you can review and delete events attached to the incident.

Configuring incident settings

To configure incident settings, go to Event Manager > Incidents > Incident Settings.

When an incident is created, updated, or deleted, you can send a notification to external platforms using selected fabric
connectors.

To configure incident notification settings:

1.
2.
3.

Go to Event Manager > Incidents > Incident Settings.

Select a Fabric Connector from the dropdown list.

Select which notifications you want to receive:
« Send notification when new incident is created. Incidents with draft status will not trigger notification.
« Send notification when new incident is updated.
« Send notification when new incident is deleted.

To add more fabric connectors, click Add Fabric Connector and repeat the above steps to configure notification
settings.
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The NOC (Network Operations Center) and SOC (Security Operations Center) is designed for a network and security
operations center where multiple dashboards are displayed in large monitors in a NOC and SOC environment.

NOC - SOC displays both real-time monitoring and historical trends. This centralized monitoring and awareness help
you to effectively monitor network events, threats, and security alerts.

Use NOC - SOC dashboards to view multiple panes of network activity, including monitoring network security,
compromised hosts, vulnerabilities, Security Fabric, WiFi security, and system performance.

A typical scenario is to set up dashboards and widgets to display information most relevant to your network and security
operations. Use the main monitors in the middle to display important dashboards in a bigger size. Then use the
monitors on the sides to display other information in smaller widgets.

For example, use the top monitor in the middle to display the Top Threat Destinations widget in full screen, use the
monitor(s) below that to display other Security Monitor widgets, use the monitors on the left to display WiFi Monitor
widgets at the top and System Performance widgets at the bottom, and use the monitors on the right as a workspace to
display widgets showing the busiest network activity. You can move, add, or remove widgets.

Hide the tree menu on the left to display dashboards in full screen.

To prevent timeout, ensure /dle Timeout is greater than the widget's Refresh Interval. See
Idle timeout on page 212 and Settings icon on page 78.

NOC - SOC dashboards and widgets

NOC and SOC dashboards and widgets are very flexible and have the following features:

You can create predefined or custom dashboards.

For both predefined and custom dashboards, you can add, delete, move, or resize widgets.
You can add the same dashboard multiple times on the same or different monitors.

Each widget monitors one activity.

You can add the same widget multiple times and apply different settings to each one. For example, you can add
widgets to monitor the same activity using a different chart type, refresh interval, or time period.

You can resize widgets or display a widget in full screen.

For example, if one dashboard has too many widgets, simply create the same or a different dashboard on another
monitor to display widgets in a bigger size.
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NOC - SOC dashboards

NOC - SOC includes predefined dashboards for Security Monitor, Compromised Hosts Monitor, Vulnerabilities Monitor,
Security Fabric, System, and Threat Research. The Security Fabric dashboard is available after you create a Security
Fabric group in FortiGate and add it in FortiAnalyzer.

The default Security Monitor dashboard includes four widgets: Top Threat Destinations, Top Sources, Top
Applications, and Top Endpoint Vulnerabilities.
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NOC - SOC includes the following predefined dashboards:
Security Monitor Monitors the top security threats to your network.

Compromised Hosts Monitor  Monitors compromises and suspicious web use in your network.
Vulnerabilities Monitor Monitors user vulnerabilities in your network.

Security Fabric Monitors your network's Security Fabric rating, score, and topology.

This dashboard is available after you create a Security Fabric group in FortiGate
and add it in FortiAnalyzer.

WiFi Monitor Monitors WiFi access points and SSIDs.
System Performance Monitors the system performance of the FortiAnalyzer unit.
Global Threat Research Monitors threat prevalence and virus incidents.
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Security Monitor

The Security Monitor dashboard includes the following widgets:

Top Threat
Destinations

User Data Flow

Top Threat

Top Applications

Top Endpoint
Vulnerabilities

Top Sources

Top Countries

Top Dialup VPN

VPN Site-to-Site

FortiSandbox -
Scanning Statistics

FortiSandbox - Top
Malicious &
Suspicious File
Users

A world map, spinning 3D globe, or table showing the top 10, 20, 50, 100 threat destinations.

On the map view, hover the cursor over data points to see the source device and IP address,
destination IP address and country, threat level, and the number of incidents (blocked and
allowed).

The bandwidth breakdown of the top user destination countries or application usage. The
chart shows, from left to right, the source, device, and country or application.

The top threats to your network. Hover the cursor over data points to see the threat, category,
threat level, threat score (blocked and allowed), and the number of incidents (blocked and
allowed).
The following incidents are considered threats:

« Risk applications detected by application control

« Intrusion incidents detected by IPS

« Malicious web sites detected by web filtering

« Malware/botnets detected by antivirus

The top applications used on the network. Hover the cursor over data points to see the
application name, risk level, category, sessions (blocked and allowed), and bytes (sent and
received).

Vulnerability information about FortiClient endpoints. Hover the cursor over data points to
see the vulnerability count (critical, high, medium, and low), source |P address and device,
and category.

The highest network traffic by source IP address and interface, sessions (blocked and
allowed), threat score (blocked and allowed), and bytes (sent and received).

The highest network traffic by country, sessions (blocked and allowed), and bytes (sent and
received). You can display this widget as a treemap chart, bubble chart, or bar chart; sorted
by bandwidth or the number of sessions.

A world map showing the users accessing the network using SSL or IPsec over a VPN tunnel.
Hover the cursor over data points to see the user name or IP address, connected from IP
address and country, connection time and duration, and bytes (sent and received).

A world map showing the names of VPN tunnels with Internet protocol security (IPsec) that
are accessing the network. Hover the cursor over data points to see the site-to-site IPsec
tunnel, connected from and to IP address (including city and country if available), duration,
and bytes (sent and received).

The number of files scanned by FortiSandbox. This chart shows the files by type: malicious,
suspicious, clean, and others. Hover the cursor over data points to see the number of files of
each type.

Users or IP addresses that have the highest number of malicious and suspicious files
detected by FortiSandbox. This chart shows the username and avatar if it’s available,
otherwise it shows the IP address. Hover the cursor over data points to see the number of
files.
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Compromised Hosts Monitor

The Compromised Hosts Monitor dashboard includes the following widget:

Compromised Suspicious web use compromises. By default, this widget includes two panes: Compromised
Hosts Hosts and Compromised Hosts Incidents.

The Compromised Hosts pane automatically rotates through compromised hosts. You can
pause autoplay or click > or < to manually move to another compromised host.

The Compromised Hosts Incidents pane displays a map of compromised hosts incidents.

Click Settings to change the number of top compromised hosts, Time Period, Refresh
Interval, Autoplay Interval, and to show or hide Compromised Hosts Incidents.

Vulnerabilities Monitor

The Vulnerabilities Monitor dashboard includes the following widgets:

User Summary of user vulnerabilities. By default, this widget includes two panes: User
Vulnerabilities Vulnerabilities Summary and Critical Vulnerabilities.
Summary The User Vulnerabilities Summary pane automatically rotates through users with

vulnerabilities. You can pause autoplay or click > or < to manually move to another user.

The Critical Vulnerabilities pane displays critical vulnerabilities on the left and vulnerability
details on the right.

Click Settings to change the number of top vulnerabilities, Time Period, Refresh Interval,
Autoplay Interval, and to show or hide Critical Vulnerabilities.

Security Fabric

The Security Fabric dashboard includes the following widgets:

Security Fabric A report showing the security rating details of connected Security Fabric devices. Click a
Rating Report milestone to drill down and hover the cursor over data points to see more details.

Security Fabric The current and historical Security Fabric scores. The Historical Security Fabric Scores pane
Score displays your Security Fabric score over time and how it compares to the industry average

and the industry score range. You can hide the Historical Security Fabric Scores pane.

Security Fabric A topology map showing the logical structure of connected Security Fabric devices.
Topology

WiFi Monitor

The WiFi Monitor dashboard includes the following widgets:

Authorized APs A world map showing the names of authorized WiFi access points on the network.
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Top SSID

Top Rogue APs

System

The top SSID (service set identifiers) of authorized WiFi access points on the network. Hover
the cursor over data points to see the SSID and bytes (sent and received).

The top SSID (service set identifiers) of unauthorized WiFi access points on the network.
Hover the cursor over data points to see the SSID and total live time.

This dashboard monitors the system performance of the FortiAnalyzer unit running NOC - SOC and not the logging
devices. It includes the following widgets:

CPU & Memory
Usage

Multi-Core CPU
Usage

Insert Rate vs
Receive Rate

Receive Rate vs
Forwarding Rate

Disk 1/0

Threat Research

The usage status of the CPU and memory.

The usage status of a multi-core CPU.

The number of logs received vs the number of logs actively inserted into the database,
including the maximum and minimum rates.

« Receive rate: how many logs are being received.

« insert rate: how many logs are being actively inserted into the database.

If the insert rate is higher than the log receive rate, then the database is rebuilding. The lag is
the number of logs waiting to be inserted.

The number of logs received vs the number of logs forwarded out, including the maximum
and minimum rates.

« Receive rate: how many logs are being received.

« Forward rate: how many logs are being forwarded out.

The disk Transaction Rate (1/0s per second), Throughput (KB/s), or Utilization (%). The
Transaction Rate and Throughput graphs also show the maximum and minimum disk
activity.

This dashboard displays the system performance of the FortiAnalyzer unit running NOC - SOC and not the logging
devices. It includes the following widgets:

Worldwide Threat
Prevalence - Today
(UTC)

Virus Incidents -
Last 1 Month

The top virus, IPS, botnet, and application threats globally today based on UTC.
This data is from FortiGuard and not from FortiGate.

Summary results showing virus incidents in the last month.
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Using the NOC -

SOC dashboard

NOC - SOC dashboards contain widgets that provide network and security information. Use the controls in the
dashboard toolbar to work with a dashboard.

Add Widget

Dashboard

Create New
Reset
Rename
Delete

Select
Security
Fabric

Refresh

Background color

Hide Side-menu or
Show Side-menu

Add widgets to a predefined or custom dashboard. For details, see Customizing the NOC -
SOC dashboard on page 79.

Create a new dashboard or reset a predefined dashboard to its default settings. For custom
dashboards, you can rename or delete the custom dashboard. For details, see Customizing
the NOC - SOC dashboard on page 79.

Create a new dashboard.

Reset a predefined dashboard to its default widgets and settings.
Rename a custom dashboard.

Delete a custom dashboard.

Select the Security Fabric to display in the dashboard.

You need to create a Security Fabric group in FortiGate and add the Security Fabric group in
FortiAnalyzer to be able to select a Security Fabric option in the NOC - SOC dashboard.

Refresh the data in the widgets.

Change the background color of the dashboard to make widgets easier to view in different
room lighting.

« Day shows a brighter gray background color.

« Night shows a black background.

o Ocean shows a blue background color.

Hide or show the tree menu on the left. In a typical NOC/SOC environment, the side menu is
hidden and dashboards are displayed in full screen mode.

Use the controls in the widget title bar to work with widgets.

Settings icon

View different chart
types

Hide or show a
data type

Remove widget
icon

Change the settings of the widget. Widgets have settings applicable to that widget, such as
how many of the top items to display, Time Period, Refresh Interval, and Chart Type.

Some widget settings let you choose different chart types such as the Disk I/O and Top
Countries widget. You can add these widgets multiple times and set each widget to show a
different chart type.

For widgets that show different data types, click a data type in the title bar to hide or show
that data type in the graph.

For example, in the Insert Rate vs Receive Rate widget, click Receive Rate or Insert Rate
in the title bar to hide or show that data. In the Disk I/O widget, click Read or Write in the title
bar to hide or show that data type.

Delete the widget from a predefined or custom dashboard.
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Move widget Click and drag a widget'’s title bar to move it to another location.
Resize widget Click and drag the resize button in the bottom-right of the widget.

View more details Hover the cursor over a widget’s data points to see more details.

View a narrower Some widgets have buttons below the graph. Click and drag the buttons to view a narrower

time period time period.

Zoom in and out For widgets that show information on a map such as the Top Threat Destinations widget,
use the scroll wheel to change the zoom level. Click and drag the map to view a different
area.

Customizing the NOC - SOC dashboard

You can add any widget to a predefined dashboard. You can also move, resize, or delete widgets. You cannot rename
or delete a predefined dashboard. To reset a predefined dashboard to its default settings, click Dashboard > Reset.

You can add the same widget multiple times and configure each one differently, such as showing a different Time
Period, Refresh Interval, or Chart Type.

To create a dashboard:

1. Inthe toolbar, click Dashboard > Create New.

2. Specify the Name and whether you want to create a blank dashboard or use a template.
If you select From Template, specify which predefined dashboard you want to use as a template.

3. Click OK. The new dashboard appears In the tree menu.

To display Security Fabric in NOC - SOC:

Create a Security Fabric in FortiGate.

Add the Security Fabric in FortiAnalyzer.

Go to NOC - SOC > Dashboard > Create New.

In the Add Dashboard dialog box, select From Template.

Select the Security Fabric template and the Security Template you want to display in the NOC - SOC Dashboard.
Add desired widgets to the dashboard.

o0k, O

To add a widget:

1. Select the predefined or custom dashboard where you want to add a widget.

2. Click Add Widget to expand the menu; then locate the widget you want to add.

3. Click the + button to add widgets.

4. When you have finished adding widgets, click the close button to close the Add Widget pane.
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FortiView is a comprehensive monitoring system for your network that integrates real-time and historical data into a
single view. It can log and monitor threats to networks, filter data on multiple levels, keep track of administrative activity,
and more.

FortiView allows you to use multiple filters in the consoles, enabling you to narrow your view to a specific time, by user
ID or local IP address, by application, and others. You can use it to investigate traffic activity such as user
uploads/downloads or videos watched on YouTube on a network-wide user group or on an individual-user level. It
presents information in both text and visual format.

You can view summaries of log data in FortiView such as top threats to your network, top sources of network traffic, and
top destinations of network traffic. Depending on which summary you are viewing, you can view summary information in
different formats: table, bubble, map, or tile. For each summary view, you can drill down to see more details.

FortiGate, FortiCarrier, and FortiClient EMS devices support FortiView.

How ADOMs affect the FortiView pane

When ADOMs are enabled, each ADOM has its own data analysis in FortiView.

Logs used for FortiView

FortiView displays data from Analytics logs. Data from Archive logs is not displayed in FortiView. For more information,
see Archive logs and Analytics logs on page 28.

FortiView summary list and description

In table format, many summary views display a historical chart to show changes over the selected time period. If you
sort by a different column, the chart shows the history of the sorted column. For example, if you sort by Sessions
Blocked/Allowed, the chart shows the history of blocked and allowed sessions. If you sort by Bytes Sent/Received, the
chart shows the history of bytes sent and received.

When you drill down to view a line item, the historical chart show changes for that line item.
FortiView summaries for FortiGate and FortiCarrier devices

Category View Description

Summary An overview An overview of most used FortiView summary views. You can select which
widgets to display in the Summary.

Threats Top Threats Lists the top threats to your network.
The following incidents are considered threats:
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Category View Description

Risk applications detected by application control.
Intrusion incidents detected by IPS.

Malicious web sites detected by web filtering.
Malware/botnets detected by antivirus.

Note: If FortiGate is running FortiOS 5.0.x, turn on Security Profiles >
Client Reputation to view entries in Top Threats.

Threat Map Displays a map of the world that shows the top traffic destination country
by color. Threats are displayed when the level is equal to or greater than
warning and the source IP is a public IP address.

The list of threats at the bottom shows the location, threat, severity, and
time of the attacks. The color gradient of the darts on the map indicate the
traffic risk, where red indicates the more critical risk.

This view has no filtering options. See also Viewing the threat map on page

88.

Compromised Hosts  Displays end users with suspicious web use compromises, including end
users’ IP addresses, overall threat rating, and number of threats.

Note: To use this feature:

1.
2.

UTM logs of the connected FortiGate devices must be enabled.
The FortiAnalyzer must subscribe to FortiGuard to keep its threat
database up-to-date.

FortiSandbox Displays a summary of FortiSandbox related detections. The following
Detection information is displayed:

Filename

End User and/or IP

Destination IP

Analysis (Clean, Suspicious or Malicious rating)
Action (Passthrough, Blocked, etc)

Service (HTTP, FTP, SMTP, etc)

Traffic Top Sources Displays the highest network traffic by source IP address and interface,
device, threat score (blocked and allowed), sessions (blocked and allowed),
and bytes (sent and received).

Top Destinations Displays the highest network traffic by destination IP addresses, the
applications used to access the destination, sessions, and bytes. If
available, click the icon beside the IP address to see its WHOIS
information.

Top Countries Displays the highest network traffic by country in terms of traffic sessions,
including the destination, threat score, sessions, and bytes.

Policy Hits Lists the policy hits by policy, device name, VDOM, number of hits, bytes,
and last used time and date.
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Category View

Applications  Top Applications
& Websites

Top Cloud
Applications

Top Websites

Top Browsing Users

VPN SSL & Dialup IPsec

Site-to-Site IPsec

WiFi Rogue APs

Authorized APs
Authorized SSIDs

WiFi Clients

System Admin Logins
System Events

Resource Usage

Failed Authentication
Attempts

Endpoints All Endpoints
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Description

Displays the top applications used on the network including the application
name, category, risk level, number of clients, sessions blocked and
allowed, and bytes sent and received.

For a usage example, see Finding application and user information on
page 92.

Displays the top cloud applications used on the network.

Displays the top allowed and blocked web sites on the network. You can
view information by domain or category by using the options in the top right
of the toolbar.

Displays the top web-browsing users, including source, group, number of
sites visited, browsing time, and number of bytes sent and received.

Displays the users who are accessing the network by using the following
types of security over a virtual private network (VPN) tunnel: secure socket
layers (SSL) and Internet protocol security (IPsec).

You can view VPN traffic for a specific user from the top view and drilldown
views. In the top view, double-click a user to view the VPN traffic for the
specific user. In the drilldown view, click an entry from the table to display
the traffic logs that match the VPN user and the destination.

Displays the names of VPN tunnels with Internet protocol security (IPsec)
that are accessing the network.

Displays the service set identifiers (SSID) of unauthorized WiFi access
points on the network.

Displays the names of authorized WiFi access points on the network.

Displays the service set identifiers (SSID) of authorized WiFi access points
on the network.

Lists the names and IP addresses of the devices logged into the WiFi
network.

Displays the users who logged into the managed device.
Displays events on the managed device.

Displays device CPU, memory, logging, and other performance information
for the managed device.

Displays the IP addresses of the users who failed to log into the managed
device.

Lists the FortiClient endpoints registered to the FortiGate device.

Displays the avatars of the FortiClient endpoints registered to the
FortiGate device.
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Category View Description

Top Vulnerabilities Displays vulnerability information about the FortiClient endpoints
registered to specific FortiGate devices. View by Device or Vulnerability.

In Device view, the table shows the device, source, number and severity of
vulnerabilities, and category.

In Vulnerability view, select table or bubble format. The table format shows
the vulnerability name, severity, category, CVE ID, and host count. The
bubble graph format shows vulnerability by severity and frequency.

Top Threats Displays the top threats for registered FortiClient endpoints, including the
threat, threat level, and the number of incidents (blocked and allowed).

Top Applications Displays the top applications used by registered FortiClient endpoints,
including the application name, risk level, sessions blocked and allowed,
and bytes sent and received.

Top Web Sites Displays the top allowed and blocked web sites on the network.

FortiView summaries for FortiClient EMS devices

Category View Description

Threats Top Threats Lists the top users involved in incidents and the top threats to your network.
The following incidents are considered threats:
« Risk applications detected by application control
« Malicious web sites detected by web filtering
« Malware/botnets detected by antivirus

Applications Top Applications Displays the top applications used on the network including the application
& Websites name, category, risk level, number of clients, sessions blocked and
allowed, and bytes sent and received.

Top Websites Displays the top allowed and blocked web sites on the network.

Endpoints All Endpoints Lists the FortiClient endpoints registered to the FortiClient EMS device.

Displays the avatars of the FortiClient endpoints registered to the
FortiClient EMS device.

Top Vulnerabilities Displays vulnerability information about the FortiClient endpoints that are
registered to the FortiClient EMS device. View by Device or Vulnerability.

In Device view, the table shows the device, source, number and severity of
vulnerabilities, and category.

In Vulnerability view, select table or bubble format. The table format shows
the vulnerability name, severity, category, CVE ID, and host count. The
bubble graph format shows vulnerability by severity and frequency.
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Using FortiView

When ADOMs are enabled, FortiView displays information for each ADOM so ensure you are in the correct ADOM. See
Switching between ADOMSs on page 19.

FortiView Summary page

The FortiView Summary page shows you an overview of the most used summary views. You can configure the overall
view of the Summary page.

Each summary view is a widget. You can configure the view settings of each widget, including adding the same widget
multiple times, each showing a different view. For example, you can add two Top Threats widgets: one showing the Top
10 Threats view in a bubble chart, and the other showing the Top 20 Threats in a table.

To view the details of each summary view, you can drill down each summary view or use the tree menu to view an
individual page.
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Configuring the overall view settings for the Summary page

To add a widget to the Summary page:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto FortiView.
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3. Inthe content pane toolbar, click Add Widget and select a FortiView summary from the list.

+ Add Widget~ (® Last 1 Hour «

Top Threats

Top Sources

Top Destinations

Top Countries

Policy Hits

Top Applications

Top Web Sites

Authorized APs

Authorized 551Ds

WiFi Clients

aoooOooOoooaoan

Restore to Default

To remove a widget from the Summary page:

Click the Remove This Widget button in the top-right of the widget.

To specify a time period for all the views on the Summary page:

On the FortiView Summary page, select a time period from the time period dropdown list in the toolbar.

To refresh the view and/or set refresh rate:

On the FortiView Summary page, click the Refresh Now button in the toolbar or select a refresh rate from the
dropdown menu.

To switch to full-screen mode:
On the FortiView Summary page, click the Full Screen button in the banner. To exit full-screen mode press Esc.
Viewing each widget on the Summary page

You can view and drill down each summary view on the Summary page or you can view an individual page that you
access through the tree menu. See Filtering FortiView summaries on page 89.
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Configuring the view settings for an individual widget:

To Configure the view settings for an individual widget:

1. Onthe FortiView Summary page, click the Edit Settings button in the top-right of the widget. The summary view
flips to the settings panel.

Top Threat - Settings B
Chart Type @ E E
Show Top sLl 15 20
Sort By Threat Level ® Threat Score

2. On the settings panel, configure the settings for the widget, such as Chart Type, Show Top, and Sort By.
3. Click OKin the top-right corner to save the changes.

Viewing FortiView summaries

When viewing summary views, use the controls in the toolbar to select a display format, select a device, specify a time
period, refresh the view, set the refresh rate, export the information, and switch to full-screen mode.

Depending on which summary you are viewing, you can view summary information in different formats such as table,
bubble, map, or tile.

Some summary views support only one format. For example, Threat Map only supports the map format and Policy Hits
supports only the table format.

« Insummary views that support multiple formats, click the format icon in the top-right to select another format.
o Insimple format:

« To select which items to display, use the Sort By dropdown list in the top-left.
o Intable format:

o To select how many items to display, use the Show dropdown list in the bottom-right.
« To sort by a column, click the column title.
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o Inbubble and map format:
« If sorting is available, use the Sort By dropdown list in the top-right.
« Toview more information, hover the mouse over a graphical element.
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HTTP.BROWS.., Photobucke...

Most summary views let you drill down to view more details. To drill down to view more details, click or right-click an
element to view details about different dimensions in different tabs. You can continue to drill down by double-clicking an
entry. Click the Back button in the toolbar to return to the previous view.

Some summary views support multiple views. For example, Endpoints > Top Vulnerabilities has a Device view and a
Vulnerability view; and Applications & Websites > Top Cloud Applications has a Cloud Application view and a Cloud
Userview.
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Viewing a map of top countries
You can view a map of the Traffic > Top Countries summary view. The map shows the destination country.

To view a map of top countries:

1. Go to FortiView > Traffic > Top Countries.
2. Select the Map icon from the dropdown list in the top-right.

314,605

Choose a sort method from the Sort By drop-down menu.
To view more information, hover the mouse over the map.
To drill down to view more details, click a country to view details about different dimensions in different tabs.
You can continue drilling down by double-clicking an entry.

N o o~

Click the Back button in the toolbar to return to the previous view.

Viewing the threat map

You can view an animated world map that displays threats from unified threat management logs. Threats are displayed
in real-time. No replay or additional details are available.

display in the threat map. You can edit the device settings to identify the geographical

; ﬂ You must specify the longitude and latitude of the device to enable threats for the device to
location of the device in Device Manager.

To view the threat map:

1. Goto FortiView > Threats > Threat Map.
2. Inthe map, view the geographic location of the threats.
3. Inthe Threat Window, view the threat, level, and location.
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Filtering FortiView summaries

Filter FortiView summaries using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-
sensitive filter. You can also filter by specific devices or log groups and by time.

To filter FortiView summaries using filters in the toolbar:

1. Specify filters in the Add Filter box.

o Regular Search: In the selected summary view, click Add Filter and select a filter from the dropdown list, then
type a value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or
“or”.

« Advanced Search: Click the Switch to Advanced Search icon « at the right end of the Add Filter box. In
Advanced Search mode, enter the search criteria (log field names and values). Click the Switch to Regular
Searchicon a to go back to regular search.

2. Inthe Devicelist, select a device.
3. Inthe Timelist, select a time period.
4. If necessary, click Go.

To filter FortiView summaries using the right-click menu:

In the selected summary view, right-click an entry and select a filter criterion (Search <filter value>).

Depending on the column in which your mouse is placed when you right-click, FortiView uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

Viewing related logs

You can view the related logs for a FortiView summary in Log View. When you view related logs, the same filters that
you applied to the FortiView summary are applied to the log messages.

To view related logs for a FortiView summary, right-click the entry and select View Related Logs.

Exporting filtered summaries

You can export filtered FortiView summaries or any level of the drilldowns to PDF and report charts. Filtered summaries
are always exported in table format.

To export a filtered summary:

1. In the filtered summary view or its drilldown, click the Export button in the top-right and select Export to PDF or
Export to Report Chart.

2. Inthe dialog box, review and configure settings:
« Specify a file name for the exported file.
« Inthe Topfield, specify the number of entries to export.

o If you are in a drilldown view, the tab you are in is selected by default. You can select more tabs. If you are
exporting to report charst, the export creates one chart for each tab.

3. Click OK.
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Charts are saved in the Chart Library. You can use them in the same way you use other charts.

Al
S L4
? Only log field filters are exported. Device and time period filters are not exported.

Viewing Compromised Hosts

Compromised Hosts or Indicators of Compromise Service (IOC) is a licensed feature. To view Compromised Hosts,
you must turn on the UTM web filter of FortiGate devices and subscribe your FortiAnalyzer unit to FortiGuard to keep its
local threat database synchronized with the FortiGuard threat database. See Subscribing FortiAnalyzer to FortiGuard on
page 91.

The Indicators of Compromise Service (I0C) downloads the threat database from FortiGuard. The FortiGuard threat
database contains the blacklist and suspicious list. |IOC detects suspicious events and potentially compromised network
traffic using sophisticated algorithms on the threat database.

FortiAnalyzer identifies possible compromised hosts by checking the threat database against an event's IP, domain, and
URL in the following logs of each end user:

« Web filter logs.
+ DNSlogs.
o Trafficlogs.

When a threat match is found, sophisticated algorithms calculate a threat score for the end user. When the check is
complete, FortiAnalyzer aggregates all the threat scores of an end user and gives its verdict of the end user’s overall
IOC.

Compromised Hosts displays the results showing end users with suspicious web usage which can indicate that the
endpoint is compromised. You can drill down to view threat details.

Understanding Compromised Hosts entries

When a log entry is received and inserted into the SQL database, the log entry is scanned and compared to the blacklist
and suspicious list in the IOC threat database that is downloaded from FortiGuard.

If a match is found in the blacklist, then FortiAnalyzer displays the endpoint in Compromised Hosts with a Verdict of
Infected.

If a match is found in the suspicious list, then FortiAnalyzer flags the endpoint for further analysis.

In the analysis, FortiAnalyzer compares the flagged log entries with the previous endpoint's statistics for the same day
and then updates the score.

If the score exceeds the threshold, that endpoint is listed or updated in Compromised Hosts.
When an endpoint is displayed in Compromised Hosts, all the suspicious logs which contributed to the score are listed.

When the database is rebuilt, all log entries are reinserted and rescanned.

Working with Compromised Hosts information

Go to FortiView > Threats > Compromised Hosts.
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When viewing Compromised Hosts, use the controls in the toolbar to select Table or Tile format, select devices,
specify a time period, refresh the view, set the refresh rate, export the information, and switch to full-screen mode.

In tile format, you can view a map of the Compromised Hosts by clicking Map View in the tile. To see more details,
hover the cursor over a destination.

When you view an event, the # of Threats is the number of unique Threat Names associated with that compromised

host (end user).

When you drill down to view details, the # of Events is the number of logs matching each blacklist entry for that
compromised host (end user).

o To acknowledge a Compromised Hosts line item, click Ack on that line.
« Tofilter entries, click Add Filter and specify devices or a time period.
« Todrill down and view threat details, double-click a tile or a row.

Subscribing FortiAnalyzer to FortiGuard

To keep your FortiAnalyzer threat database up to date:

« Ensure your FortiAnalyzer can reach FortiGuard at fds1.fortinet.com.

o Purchase a FortiGuard Indicators of Compromise Service license and apply that license to the product registration.

No change is needed on the FortiAnalyzer side.

To subscribe FortiAnalyzer to FortiGuard:

1. Goto System Settings > Dashboard.

2. Inthe License Information widget, find the FortiGuard > Indicators of Compromise Service field and click
Purchase.

3. After purchasing the license, check that the FortiGuard > Indicators of Compromise Service is Licensed and
shows the expiry date.

Monitoring resource usage of devices

You can monitor how much FortiAnalyzer system resources (e.g., CPU, memory, and disk space) each device uses.
When ADOMs are enabled, this information is displayed per ADOM. In a specific ADOM, you can view the resource
usage information of all the devices under the ADOM.

Go to FortiView > System > Resource Usage to monitor resource usage for devices.
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Examples of using FortiView

You can use FortiView to find information about your network. The following are some examples.

Finding application and user information

Company ABC has over 1000 employees using different applications across different divisional areas, including supply
chain, accounting, facilities and construction, administration, and IT.

The administration team received a $6000 invoice from a software provider to license an application called Widget-Pro.
According to the software provider, an employee at Company ABC is using Widget-Pro software.

The system administrator wants to find who is using applications that are not in the company’s list of approved
applications. The administrator also wants to determine whether the user is unknown to FortiGuard signatures, identify
the list of users, and perform an analysis of their systems.

To find application and user information:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to FortiView > Applications & Websites > Top Applications.

Click Add Filter, select Application, type Widget-Pro, and click Go.

If you do not find the application in the filtered results, go to Log View > Traffic.
Click the Add Filter box, select Source IP, type the source IP address, and click Go.

o r oD

Finding unsecured wireless access points

AAA Electronics has multiple access points in their stores for their wireless point-of-sale and mobile devices the sales
team uses.

War-driving hackers found an unsecured wireless connection in the AAA Electronics network. Hackers were able to
connect to the network and install a program for stealing personal data.

The network administrator already monitors unknown applications using FortiAnalyzer alerts and was informed an
unauthorized program had been installed. Following an investigation, the administrator determined the program
secured a wireless access point. The administrator now wants to determine if any of the other AAA Electronics stores
has insecure access points.

To find information on unsecured wireless access points:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto FortiView > WiFi > Rogue APs to view the list of unsecured wireless or rogue access points.

Analyzing and reporting on network traffic

A new administrator starts at #1 Technical College. The school has a free WiFi for students on the condition that they
accept the terms and policies for school use.
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The new administrator is asked to analyze and report on the top source and destinations students visit, the source and
destinations that consume the most bandwidth, and the number of attempts to visit blocked sites.

To review the source and destination traffic and bandwidth:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto FortiView > Traffic > Top Sources.
3. Goto FortiView > Traffic > Top Destinations.
If available, click the icon beside the IP address to see its WHOIS information.

Viewing vulnerabilities with high severity and frequency

A-One Company experiences many network vulnerabilities but most of them are of low to medium severity and occur
infrequently. The network administrator wants to quickly see which vulnerabilities have high severity and frequency.

To view vulnerabilities with high severity and frequency:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto FortiView > Endpoints > Top Vulnerabilities.
3. Inthe toolbar, select the Vulnerability view and then select Bubble format.

Focus on the top right of the bubble chart which shows vulnerabilities with the highest severity and frequency. Hover the
cursor over a vulnerability to see additional information and click a vulnerability to drill down to view more details.
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You can generate data reports from logs by using the Reports feature. You can do the following:

« Use predefined reports. Predefined report templates, charts, and macros are available to help you create new
reports.

o Create customize reports.

Report files are stored in the reserved space for the FortiAnalyzer device. See Automatic deletion on page 56.

When rebuilding the SQL database, Reports are not available until the rebuild is completed.
Select the Show Progress link in the message to view the status of the SQL rebuild.

For more information on FortiAnalyzer report technology and troubleshooting report performance issues, see the
FortiAnalyzer Report Performance Troubleshooting Guide.

How ADOMs affect reports

When ADOMs are enabled, each ADOM has its own reports, libraries, and advanced settings. Make sure you are in the
correct ADOM before selecting a report. See Switching between ADOMs on page 19.

Some reports are available only when ADOMs are enabled. For example, ADOMs must be enabled to access
FortiCarrier, FortiCache, FortiClient, FortiDDoS, FortiMail, FortiSandbox, and FortiWeb reports. You can configure and
generate reports for these devices within their respective default ADOM. These devices also have device-specific charts
and datasets.

Predefined reports, templates, charts, and macros

FortiAnalyzer includes a number of predefined elements you can use to create and/or build reports.

Predefined... GUI Location Purpose
Reports Reports > Report Definitions > All You can generate reports directly or with minimum setting
Reports configurations. Predefined reports are actually report

templates with basic default setting configurations.

Templates Reports > Report Definitions > You can use directly or build upon. Report templates
Templates include charts and/or macros and specify the layout of the
report. A template populates the Layout tab of a report
that is to be created. See List of report templates on page
111.

Charts Reports > Report Definitions > Chart ~ You can use directly or build upon a report template you
Library are creating, or in the Layout tab of a report that you are
creating. Charts specify what data to extract from logs.
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Predefined... GUI Location Purpose
Macros Reports > Report Definitions > Macro  You can use directly or build upon a report template that
Library you are creating, or in the Layout tab of a report that you
are creating. Macros specify what data to extract from
logs.

Logs used for reports

Reports uses Analytics logs to generate reports. Archive logs are not used to generate reports. For more information,
see Data policy and automatic deletion on page 28.

For reports about users, the FortiGate needs to populate the user field in the logs sent to FortiAnalyzer. For more
information see the FortiOS Handbook > Authentication > Configuring authenticated access and Agent-based FSSO.

How charts and macros extract data from logs

Reports include charts and/or macros. Each chart and macro is associated with a dataset. When you generate a report,
the dataset associated with each chart and macro extracts data from the logs and populates the charts and macros.
Each chart requires a specific log type.

FortiAnalyzer includes a number of predefined charts and macros. You can also create custom charts and macros.

How auto-cache works

When you generate a report, it can take days to assemble the required dataset and produce the report, depending on
the required datasets. Instead of assembling datasets at the time of report generation, you can enable the auto-cache
feature for the report.

Auto-cache is a setting that tells the system to automatically generate hcache. The hcache (hard cache) means that
the cache stays on disk in the form of database tables instead of memory. Hcache is applied to “matured” database
tables. When a database table rolls, it becomes “mature”, meaning the table will not grow anymore. Therefore, it is
unnecessary to query this database table each time for the same SQL query, so hcache is used. Hcache runs queries
on matured database tables in advance and caches the interim results of each query. When it is time to generate the
report, much of the datasets are already assembled, and the system only needs to merge the results from hcaches.
This reduces report generation time significantly.

The auto-cache process uses system resources to assemble and cache the datasets and it takes extra space to save
the query results. You should only enable auto-cache for reports that require a long time to assemble datasets.

Generating reports

You can generate reports by using one of the predefined reports or by using a custom report that you created. You can
find all the predefined reports and custom reports listed in Reports > Report Definitions > All Reports.
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To generate a report:

1. Goto Reports > Report Definitions > All Reports.
2. Inthe content pane, select a report from the list.

3. (Optional) Click Edit in the toolbar and edit settings on the Settings and Layout tabs. For a description of the fields

in the Settings and Layout tabs, see Reports Settings tab on page 100 and Creating charts on page 113 and Macro
library on page 116.

4. Inthe toolbar, click Run Report.

Viewing completed reports

After you generate reports, you can view completed reports in Reports > Generated Reports or Reports > Report
Definitions > All Reports. You can view reports in the following formats: HTML, PDF, XML, and CSV.

To view completed reports in Generated Reports:

1. Goto Reports > Generated Reports.
This view shows all generated reports for the specified time period.
2. To sort the report list by date, click Order by Time.To sort the report list by report name, click Order by Name.
3. Locate the report and click the format in which you want to view the report to open the report in that format.
For example, if you want to review the report in HTML format, click the HTML link.

To view completed reports in All Reports:

1. Goto Reports > Report Definitions > All Reports.
2. Onthe report list, double-click a report to open it.

3. Inthe View Report tab, locate the report and click the format in which you want to view the report to open the
report in that format.

For example, if you want to review the report in HTML format, click the HTML link.

Enabling auto-cache

You can enable auto-cache to reduce report generation time for reports that require a long time to assemble datasets.
For information about auto-cache and hcache, see How auto-cache works on page 95.

You can see the status of building the cache in Reports > Report Definitions > All Reports in the Cache Status
column.

To enable auto-cache:

Go to Reports > Report Definitions > All Reports.

Select the report from the list, and click Edit in the toolbar.
In the Settings tab, select the Enable Auto-cache checkbox.
Click Apply.

AoODbdD=
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Grouping reports

If you are running a large number of reports which are very similar, you can significantly improve report generation time
by grouping the reports. Grouping reports has these advantages:

« Reduce the number of hcache tables.

o Improve auto-hcache completion time.
« Improve report completion time.

Step 1: Configure report grouping

For example, to group reports with titles containing string Security Report by device ID and VDOM, enter the
following CLI commands:

config system report group
edit O
set adom root
config group-by

edit devid
next
edit vd
next
end
set report-like Security Report
next
end
Notes:

« The report-1ike field specifies the string in report titles that is used for report grouping. This string is case-
sensitive.

« The group-by value controls how cache tables are grouped.

« To view report grouping information, enter the following CLI command, then check the Report Group column of the
table that is displayed.
execute sgl-report list-schedule <ADOM>

Step 2: Initiate a rebuild of hcache tables

To initiate a rebuild of hcache tables, enter the following CLI command:

diagnose sgl hcache rebuild-report <start-time> <end-time>

Where <start-time>and <end-time> are in the format: <yyyy-mm-dd hh:mm:ss>.

Retrieving report diagnostic logs

Once you start to run a report, FortiAnalyzer creates a log about the report generation status and system performance.
Use this diagnostic log to troubleshoot report performance issues. For example, if your report is very slow to generate,
you can use this log to check system performance and see which charts take the longest time to generate.

For information on how to interpret the report diagnostic log and troubleshoot report performance issues, see the
FortiAnalyzer Report Performance Troubleshooting Guide.
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To retrieve report generation logs:

1. In Reports > Generated Report, right-click the report and select Retrieve Diagnostic to download the log to your
computer.

2. Use atext editor to open the log.

Auto-Generated Reports

The Cyber Threat Assessment report is automatically generated. By default, the report will run at 3:00AM every
Monday. For more information on report scheduling, see Scheduling reports on page 98.

Schedules can be viewed in the Report Calendar. See Report calendar on page 123.

Al
‘Q' This will only affect newly installed FortiAnalyzer or newly created ADOM. Upgraded ADOM
- reports, scheduling and calendar will be kept as is.

Scheduling reports

You can configure a report to generate on a regular schedule. Schedules can be viewed in the Report Calendar. See
Report calendar on page 123.

To schedule a report:

Go to Reports > Report Definitions > All Reports.

Select a report and click Edit in the toolbar.

Click Settings in the toolbar.

Select the Enable Schedule checkbox and configure the schedule.
Click Apply.

o~ oODdD=

Creating reports

You can create reports from report templates, by cloning and editing predefined/existing reports, or start from scratch.

Creating reports from report templates

You can create a new report from a template. The template populates the Layout tab of the report. The template
specifies what text, charts, and macros to use in the report and the layout of the content. Report templates do not
contain any data. Data is added to the report when you generate the report.
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To create a new report from a template:

1.
2.
3.

10.

If using ADOMSs, ensure that you are in the correct ADOM.
Go to Reports > Report Definitions > All Reports.
In the toolbar, click Create New. The Create Report dialog box opens.

Create Report

Name
Create from Blank
(® From Template
Template - Cyber Threat Assessment

Save to Folder B& Al Reports

o

In the Name box, type a name for the new report. The following characters are NOT supported in report names: \ /"
'<>&, |#?%$+

Select From Template for the Create from setting, then select a template from the dropdown list. The template
populates the Layout tab of the report.

Select the folder that the new report will be saved to from the dropdown list. See Organizing reports into folders on
page 108 for information about folders.

Select OK to create the new report.

On the Settings tab, configure the settings as required. For a description of the fields, see Reports Settings tab on
page 100.

Optionally, go to the Layout tab to customize the report layout and content. For a description of the fields, see
Reports Layout tab on page 103.

Click Apply to save your changes.

Creating reports by cloning and editing

You can create reports by cloning and editing predefined and/or existing reports.

To create a report by cloning and editing:

AoODdD =

If using ADOMSs, ensure that you are in the correct ADOM.
Go to Reports > Report Definitions > All Reports.
In the content pane, select the report from the list, then click Clone in the toolbar.

In the Clone Report dialog box, type a name for the cloned report. The following characters are NOT supported in
report names: \/"'<>&, [#? % $ +

Select the folder that the new report will be saved to from the dropdown list. See Organizing reports into folders on
page 108 for information about folders.

Select OK to create the new report.

On the Settings tab, configure the settings as required. For a description of the fields, see Reports Settings tab on
page 100.

Optionally, go to the Layout tab to customize the report layout and content. For a description of the fields, see
Reports Layout tab on page 103.

Click Apply to save your changes.
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Creating reports without using a template

To create a report without using a template:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the toolbar, click Create New. The Create New Report dialog box opens.

In the Name box, type a name for the new report. The following characters are NOT supported in report names: \ /"

'<>&,|#?%$+

Select the Blank option for the Create from setting.

6. Select the folder that the new report will be saved to from the dropdown list. See Organizing reports into folders on
page 108 for information about folders.

7. Select OK to create the new report.

8. Onthe Settings tab, you can specify a time period for the report, what device logs to include in the report, and so

on. You can also add filters to the report, add a cover page to the report, and so on. For a description of the fields,

see Reports Settings tab on page 100.

AoObd -~

o

Settings menu.

x To create a custom cover page, you must select Print Cover Page in the Advanced

9. Onthe Layout tab, you can specify the charts and macros to include in the report, as well as report content and
layout.
For a description of the fields, see Reports Layout tab on page 103.

For information about creating charts and macros, see Creating charts on page 113 and Creating macros on page
116.

10. Click Apply to save your changes.

Reports Settings tab

The following options are available in the Settings tab:

Field Description

Time Period The time period the report covers. Select a time period or select Custom to
manually specify the start and end date and time.

Devices The devices to include in the report. Select either All Devices or Specify to add
specific devices. Select the add icon to select devices.
Type Select either Single Report (Group Report) or Multiple Reports (Per-Device).
This option is only available if multiple devices are selected.
Enable Schedule Select to enable report template schedules.
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Field Description

Enable Auto-Cache Select to assemble datasets before generating the report and as the data is
available. This process uses system resources and is recommended only for
reports that require days to assemble datasets. Disable this option for unused
reports and for reports that require little time to assemble datasets.

Generate PDF Report Every Select when the report is generated.

Enter a number for the frequency of the report based on the time period selected
from the dropdown list.

Start time Enter a starting date and time for the file generation.

End time Enter an ending date and time for the file generation, or set it to never ending.
Enable Notification Select to enable report notification.

Output Profile Select the output profile from the dropdown list, or click Create New to create a

new output profile. See Output profiles on page 120.
Filters section of Reports Settings tab
See Filtering report output on page 107.

Advanced Settings section of Reports Settings tab

The following options are available in the Advanced Settings section of the Settings tab.

Field Description

Language Select the report language.

Bundle rest into “Others” Select to bundle the uncategorized results into an Others category.

Print Orientation Set the print orientation to portrait or landscape.

Chart Heading Level Set the heading level for the chart heading.

Default Font Set the default font.

Hide # Column Select to hide the column numbers.

Layout Header Enter header text and select the header image. Accept the default Fortinet image

or click Browse to select a different image.

Layout Footer Select either the default footer or click Custom to enter custom footer text in the
text field.
Print Cover Page Select to print the report cover page. Click Customize to customize the cover

page. See Customizing report cover pages on page 102.

Print Table of Contents Select to include a table of contents.
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Field Description

Print Device List Select to print the device list. Select Compact, Count, or Detailed from the
dropdown list.

Print Report Filters Select to print the filters applied to the report.

Obfuscate User Select to hide user information in the report.

Resolve Hostname Select to resolve hostnames in the report.

Allow Save Maximum Select a value between 1-10000 for the maximum number of reports to save.
Color Code The color used to identify the report on the calendar. Select a color code from the

dropdown list to apply to the report schedule. Color options include: Bold Blue,
Blue, Turquoise, Green, Bold Green, Yellow, Orange, Red, Bold Red, Purple,
and Gray.

Customizing report cover pages

A report cover page is only included in the report when enabled on the Settings tab in the Advanced Settings section.

When enabled, the cover page can be customized to contain the desired information and imagery.

To customize a report cover page:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the content pane, select the report from the list, and click Edit in the toolbar.
Select the Settings tab and then click Advanced Settings.

Select the Print Cover Page checkbox, then click Customize next to the checkbox. The Edit Cover Page pane
opens.

o r oD

Edit Cover Page

Background Image Browse...

def_cove...png

Top Image Browse...
Top Image Position Center
Text Color W Black

{8 show Creation Time

FEATINET Show Data Range
Report Title (default]

360-Degree Security Review Custom Toxt 1
02, 201 0701

Report Date: June
Provirvrvpts

Data Range: 2016-06-01 07.01 2016.06-02 07-01 (FAZ local) Custom Text 2

Bottom Image Browse...
Footer Left Text (default)
Footer Right Text {default}

Footer Background Color Gray

FortiAnalyzer 6.0.8 Administration Guide 102
Fortinet Technologies Inc.



Reports

6. Configure the following settings:

Background Image

Top Image

Top Image Position

Text Color

Show Creation Time
Show Data Range
Report Title

Custom Text 1
Custom Text 2

Bottom Image

Footer Left Text
Footer Right Text

Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image as the background image of the
cover page.

Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image at the top of the cover page.

Select the top image position from the dropdown menu. Select one of the
following: Left, Center, Right.

Select a text color from the dropdown list.

Select to print the report date on the cover page.

Select to print the data range on the cover page.

Accept the default title or type another title in the Report Title field.
If you want, enter custom text for the Custom Text 1 field.

If you want, enter custom text for the Custom Text 2 field.

Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image to the bottom of the cover page.

If you want, enter custom text to be printed in the left footer of the cover page.

If you want, enter custom text to be printed in the right footer of the cover

page.
Footer Background Color Select the cover page footer background color from the dropdown list.

Reset to Default Select to reset the cover page settings to their default settings.

7. Click OK to save the configurations and return to the Settings tab.

Reports Layout tab

Because the cut, copy, and paste functions need access to the clipboard of your operating

system, some Internet browsers either block it when called from the layout editor toolbar, or
ask you to explicitly agree to it. If you're blocked from accessing the clipboard by clicking the
respective cut, copy and paste buttons from the toolbar or context menu, you can always use
keyboard shortcuts.
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The following options are available in the Layout tab (layout editor):

Field Description

Insert Chart or Edit Chart Click to insert a FortiAnalyzer chart. Charts are associated with datasets that
extract data from logs for the report.
In the Insert Chart or Chart Properties dialog box, you can specify a custom title,
width, and filters for the chart. For information on setting filters, see Filtering
report output on page 107.
You can edit a chart by right clicking the chart in the layout editor and selecting
Chart Properties or by clicking the chart to select it and then clicking Edit Chart.

Insert Macro Click to insert a FortiAnalyzer macro. Macros are associated with datasets that
extract data from logs for the report.

Image Click the Image button in the toolbar to insert an image into the report layout.
Right-click an existing image to edit image properties.

Table Click the Table button in the toolbar to insert a table into the report layout. Right-
click an existing table to edit a cell, row, column, table properties, or delete the
table.

Insert Horizontal Line Click to insert a horizontal line.

Insert Page Break for Printing Click to insert a page break for printing.

Link Click the Link button in the toolbar to open the Link dialog box. You can select to
insert a URL, a link to an anchor in the text, or an email address. Alternatively,
use the CTRL+L keyboard shortcut to open the Link dialog box.

Anchor Click the Anchorbutton in the toolbar to insert an anchor in the report layout.

Cut To cut a text fragment, start with selecting it. When the text is selected, you can
cut it using one of the following methods:
o Click the cut button in the toolbar
« Right-click and select cut in the menu
o Use the CTRL+X shortcut on your keyboard.

Copy To cut a text fragment, start with selecting it. When the text is selected, you can
cut it using one of the following methods:
o Click the cut button in the toolbar
« Right-click and select cut in the menu
o Use the CTRL+C shortcut on your keyboard.

Paste To paste text, start with cutting or copying from another source. Depending on
the security settings of your browser, you may either paste directly from the
clipboard or use the Paste dialog box.

Paste as plain text Click Paste as plain text to paste formatted text without the formatting. If the
browser blocks the editor toolbar’s access to clipboard, a Paste as Plain Text
dialog box appears and you can paste the fragment into the text box using the
CTRL+V keyboard shortcut.
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Field Description

Paste from Word

Undo

Redo

Find

Replace

Save as Template

Paragraph Format

Font Name

Font Size

You can preserve basic formatting when you paste a text fragment from Microsoft

Word. To achieve this, copy the text in a Word document and paste it using one
of the following methods:

« Click the Paste from Word button in the toolbar

o Usethe CTRL+V shortcut on your keyboard.

Click to undo the last action. Alternatively, use the CTRL+Z keyboard shortcut to
perform the undo operation.

Click to redo the last action. Alternatively, use the CTRL+Y keyboard shortcut to
perform the redo operation.

Click to find text in the report layout editor. This dialog box includes the following
elements:

« Find what: Is the text field where you enter the word or phrase you want to
find.

o Match case: Checking this option limits the search operation to words
whose case matches the spelling (uppercase and lowercase letters) given in
the search field. This means the search becomes case-sensitive.

« Match whole word. Checking this option limits the search operation to whole
words.

« Match cyclic: Checking this option means that after the editor reaches the
end of the document, the search continues from the beginning of the text.
This option is checked by default.

Click to replace text in the report layout editor. This dialog box includes consists
of the following elements:

o Find what: Is the text field where you enter the word or phrase you want to
find.

« Replace with: Is the text field where you enter the word or phrase that will
replace the search term in the document.

o Match case: Checking this option limits the search operation to words
whose case matches the spelling (uppercase and lowercase letters) given in
the search field. This means the search becomes case-sensitive.

o Match whole word: Checking this option limits the search operation to whole
words.

» Match cyclic: Checking this option means that after the editor reaches the
end of the document, the search continues from the beginning of the text.
This option is checked by default.

Click to save the layout as a template.

Select the paragraph format from the dropdown list. Select one of the following:
Normal, Heading 1, Heading 2, Heading 3, Heading 4, Heading 5, Heading 6,
Formatted, Address, or Normal (DIV).

Select the font from the dropdown list.

Select the font size from the dropdown list. Select a size ranging from 8 to 72.
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Field Description

Bold Select the text fragment and then click the Bold button in the toolbar.
Alternatively, use the CTRL+B keyboard shortcut to apply bold formatting to a
text fragment.

Italic Select the text fragment and then click the /talic button in the toolbar.
Alternatively, use the CTRL+/ keyboard shortcut to apply italics formatting to a
text fragment.

Underline Select the text fragment and then click the Underline button in the toolbar.
Alternatively, use the CTRL+U keyboard shortcut to apply underline formatting
to a text fragment.

Strike Through Select the text fragment and then click the Strike Through button in the toolbar.
Subscript Select the text fragment and then click the Subscript button in the toolbar.
Superscript Select the text fragment and then click the Superscript button in the toolbar.
Text Color You can change the color of text in the report by using a color palette. To choose

a color, select a text fragment, click the Text Colorbutton in the toolbar, and
select a color.

Background Color You can also change the color of the text background.
Insert/Remove Numbered List Click to insert or remove a numbered list.
Insert/Remove Bulleted List Click to insert or remove a bulleted list.

Decrease Indent To decrease the indentation of the element, click the Dec