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Setting up FortiAnalyzer

This chapter provides information about performing some basic setups for your FortiAnalyzer units.
This section contains the following topics:

« Connecting to the GUI on page 10

« Security considerations on page 11

« GUIl overview on page 12

« Target audience and access level on page 16
o Initial setup on page 16

« FortiManager features on page 17

+ Next steps on page 17

« Restarting and shutting down on page 17

Connecting to the GUI

The FortiAnalyzer unit can be configured and managed using the GUI or the CLI. This section will step you through
connecting to the unit via the GUI.

To connect to the GUI:

1. Connect the FortiAnalyzer unit to a management computer using an Ethernet cable.
2. Configure the management computer to be on the same subnet as the internal interface of the FortiAnalyzer unit:
+ |Paddress: 192.168.1.X
o Netmask: 255.255.255.0
3. Onthe management computer, start a supported web browser and browse to https://192.168.1.99.
4. Type admin in the Name field, leave the Password field blank, and click Login.
The Change Password dialog box is displayed.
5. Change the default password now, or click Laterto change the password later:
a. Inthe New Password box, type a new password.
b. Inthe Confirm Password box, type the new password again, and click OK.
6. If ADOMs are enabled, the Select an ADOM pane is displayed. Click an ADOM to select it.
The FortiAnalyzer home page is displayed.

7. Click atile to go to that pane. For example, click the Device Manager tile to go to the Device Manager pane.
See also GUI overview on page 12.

If the network interfaces have been configured differently during installation, the URL
and/or permitted administrative access protocols (such as HTTPS) may no longer be in

their default state.
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For information on enabling administrative access protocols and configuring IP addresses, see Configuring network
interfaces on page 167.

Ay
‘Q' If the URL is correct and you still cannot access the GUI, you may also need to configure
- static routes. For details, see Static routes on page 169.

After logging in for the first time, you should create an administrator account for yourself and assign the Super_User
profile to it. Then you should log into the FortiAnalyzer unit by using the new administrator account. See Managing
administrator accounts on page 223 for information.

Security considerations

You can take steps to prevent unauthorized access and restrict access to the GUI. This section includes the following
information:

« Restricting GUI access by trusted host on page 11
o Other security considerations on page 11

Restricting GUI access by trusted host

To prevent unauthorized access to the GUI you can configure administrator accounts with trusted hosts. With trusted
hosts configured, the administrator user can only log into the GUI when working on a computer with the trusted host as
defined in the administrator account. You can configure up to ten trusted hosts per administrator account. See
Administrators on page 222 for more details.

Other security considerations

Other security consideration for restricting access to the FortiAnalyzer GUI include the following:

« Configure administrator accounts using a complex passphrase for local accounts
« Configure administrator accounts using RADIUS, LDAP, TACACSH+, or PKI

« Configure the administrator profile to only allow read/write permission as required and restrict access using read-
only or no permission to settings which are not applicable to that administrator

« Configure the administrator account to only allow access to specific ADOMs as required

When setting up FortiAnalyzer for the first time or after a factory reset, the password cannot

NP be left blank. You are required to set a password when the admin user tries to log in to
‘?' FortiManager from GUI or CLI for the first time. This is applicable to a hardware device as
well as a VM. This is to ensure that administrators do not forget to set a password when

setting up FortiAnalyzer for the first time.
After the initial setup, you can set a blank password from System Settings > Administrators.

FortiAnalyzer 6.2.3 Administration Guide 11
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GUI overview

When you log into the FortiAnalyzer GUI, the following home page of tiles is displayed:

ADOM:root @ >— (@ admin v

Device Manager Log View

Incidents & Events Reports FortiRecorder System Settings

Select one of the following tiles to display the respective pane. The available tiles vary depending on the privileges of
the current user.

Device Manager Add and manage devices and VDOMSs. See Device Manager on page 24.
Fabric View Configure fabric connectors. See Fabric View on page 32.
SOC Summarizes SOC information in FortiView and Monitors dashboards, which

include widgets displaying log data in graphical formats, network security, WiFi
security, and system performance in real-time.

This pane is not available when the unit is in Collector mode.
Log View View logs for managed devices. You can display, download, import, and delete

logs on this page. You can also define custom views and create log groups. See
Log View and Log Quota Management on page 42.

Incidents & Events Configure and view events for logging devices. See Incident and Event
Management on page 61.
This pane is not available when the unit is in Collector mode.

Reports Generate reports. You can also configure report templates, schedules, and
output profiles, and manage charts and datasets. See Reports on page 111.
This pane is not available when the unit is in Collector mode.

FortiAnalyzer 6.2.3 Administration Guide
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FortiRecorder Manage FortiCamera devices and view camera streams and recordings through
the Monitors dashboard.

This pane is only available in physical appliances and is disabled by default. See
FortiRecorder on page 143

This pane is not available when the unit is in Collector mode.
System Settings Configure system settings such as network interfaces, administrators, system

time, server settings, and others. You can also perform maintenance and
firmware operations. See System Settings on page 154.

The top-right corner of the home page includes a variety of possible selections:

ADOM If ADOMs are enabled, the required ADOM can be selected from the dropdown list.

The ADOMs available from the ADOM menu will vary depending on the privileges of the
current user.

Full Screen Click to view only the content pane in the browser window. See Full-screen mode on page 15.

Help Click to open the FortiAnalyzer online help, or view the About information for your device
(Product, Version, and Build Number).

You can also open the FortiAnalyzer basic setup video
(https://video.fortinet.com/video/208/fortianalyzer-basic-setup).

CLI Console Click the CLI Console icon on the right side of the banner on any page.

The CLI console is a terminal window that enables you to configure the FortiAnalyzer unit
using CLI commands directly from the GUI, without making a separate SSH, or local console
connection to access the CLI.

When using the CLI console, you are logged in with the same administrator account that you
used to access the GUI. You can enter commands by typing them, or you can copy and paste
commands into or out of the console.

Click Detach in the CLI Console toolbar to open the console in a separate window.

Note: The CL/ Console requires that your web browser support JavaScript.

Notification Click to display a list of notifications. Select a notification from the list to take action on the
issue.
admin Click to change the password or log out of the GUI.
Panes

In general, panes have four primary parts: the banner, toolbar, tree menu, and content pane.

Banner Along the top of the page; includes the home button (Fortinet logo), tile menu,
ADOM menu (when enabled), admin menu, notifications, help button, and
CLI console button.

Tree menu On the left side of the screen; includes the menus for the selected pane.
Not available in Device Manager.

FortiAnalyzer 6.2.3 Administration Guide
Fortinet Technologies Inc.

13


https://video.fortinet.com/video/208/fortianalyzer-basic-setup

Setting up FortiAnalyzer

Content pane Contains widgets, lists, configuration options, or other information, depending on
the pane, menu, or options that are selected. Most management tasks are
handled in the content pane.

Toolbar Directly above the content pane; includes options for managing content in the
content pane, such as Create New and Delete.

SOC » FortiView Monitors

= AddWidget [E Dashboard ~ B Al Devices -~ (© Last 1 Hour~ 11:04
Hrafic Threat Map
Applications & Websites
Compromised Hosts
FortiSandbox Detections
Endpoints
Fabric State of Security
VPN
WiFi
Local System Performance

FortiClient Software Inventory

Archive >

To switch between panes, either select the home button to return to the home page, or select the tile menu then select
anew tile.

: B ! O 0% strage e
= (o 11l xg \;:&;\ ed Log Status Down Total 50.0 GB
(o 5 R
. EE-
Device M: 50C Log Vi Fabric Vi
0 cvice Mansger os View abric View Logs Average Log Rate(Logs/Sec) Device Storage DGt
Incidents & Events Reports FortiRecorder System Settings
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Color themes

You can choose a color theme for the FortiAnalyzer GUI. For example, you can choose a color, such as blue or plum, or
you can choose an image, such as summer or autumn. See Global administration settings on page 243.

Full-screen mode
You can view several panes in full-screen mode. When a pane is in full-screen mode, the tree menu on the left side of
the screen is hidden.

Click the Full Screen button in the toolbar to enter full-screen mode, and press the Esc key on your keyboard to exit full-
screen mode.

Switching between ADOMs

When ADOMs are enabled, you can move between ADOMs by selecting an ADOM from the ADOM menu in the
banner.

ADOM:root 2 @ >~ Q1 z admin v

ADOM access is controlled by administrator accounts and the profile assigned to the administrator account. Depending
on your account privileges, you might not have access to all ADOMs. See Managing administrator accounts on page
223 for more information.

Using the right-click menu

Options are sometimes available using the right-click menu. Right-click an item in the content pane, or within some of
the tree menus, to display the menu that includes various options similar to those available in the toolbar.

In the following example on the Reports pane, you can right-click a template, and select Create New, View, Clone, or
Create Report.

S22 Reports v ADOM:root {3 @ Q1 (§ admin +

B General ted Reports

+ Create New [# Edit ¥ Delete

¥ Clone B CreateReport & Install Language Pack

B Report Definitions ~

B All Reports B  RTemp Template

+ Create New I
y review of Application Visibility and Control, Threat Detection, Data

EgTemplate - 360-Di  [# Edit . . HTML
. tion Detection, Endpoint Detection, Prevention and Recommended ~~ Security
[ul Chart Library @ Security Review B Delete | PDF
£ Macro Library &l L

O Elemplate-Admin = © ) ) ) ) HTML

£= Datasets @ System Events Repo [ Creste Report  [ogin and falled logn attempts and system severty event counts. System -
1} Advance d >| O EgTemplate - Application HTML

English Application .
L and Cantral lirinue s#tarbe fla brancharc onE

When FortiClient sends logs to FortiAnalyzer, an avatar for each user can be displayed in the Source column in the
SOC > FortiView and Log View panes. FortiAnalyzer can display an avatar when the following requirements are met:

« FortiClient is managed by FortiGate or FortiClient EMS with logging to FortiAnalyzer enabled.
« FortiClient sends logs and a picture of each user to FortiAnalyzer.

FortiAnalyzer 6.2.3 Administration Guide
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If FortiAnalyzer cannot find the defined picture, a generic, gray avatar is displayed.

Ay
‘?' You can also optionally define an avatar for FortiAnalyzer administrators. See
- Creating administrators on page 224.

Showing and hiding passwords

In some cases you can show and hide passwords by using the toggle icon. When you can view the password, the Toggle
show password icon is displayed:

Password test @

When you can hide the password, the Toggle hide password icon is displayed:

Password [.. . },l

Target audience and access level

This guide is intended for administrators with full privileges, who can access all panes in the FortiAnalyzer GUI,
including the System Settings pane.

In FortiAnalyzer, administrator privileges are controlled by administrator profiles. Administrators who are assigned
profiles with limited privileges might be unable to view some panes in the GUI and might be unable to perform some
tasks described in this guide. For more information about administrator profiles, see Administrator profiles on page 228.

Cé’, If you logged in by using the admin administrator account, you have the Super_User

administrator profile, which is assigned to the admin account by default and gives the admin
administrator full privileges.

Initial setup

This topic provides an overview of the tasks that you need to do to get your FortiAnalyzer unit up and running.

To set up FortiAnalyzer:

1. Connect to the GUI. See Connecting to the GUI on page 10.
2. Configure the RAID level, if the FortiAnalyzer unit supports RAID. See Configuring the RAID level on page 174.
3. Configure network settings. See Configuring network interfaces on page 167.

\ﬂ Once the IP address of the administrative port of FortiAnalyzer is changed, you will lose

connection to FortiAnalyzer. You will have to reconfigure the IP address of the
management computer to connect again to FortiAnalyzer and continue.

FortiAnalyzer 6.2.3 Administration Guide 16
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(Optional) Configure administrative domains. See Managing ADOMs on page 180.
Configure administrator accounts. See Managing administrator accounts on page 223.

again by using your new administrator account.

x After you configure the administrator accounts for the FortiAnalyzer unit, you should log in

Add devices to the FortiAnalyzer unit so that the devices can send logs to the FortiAnalyzer unit. See Adding
devices on page 25.

Configure the operation mode. See Configuring the operation mode on page 161 and Two operation modes on
page 19.

FortiManager features

FortiManager features are not available in FortiAnalyzer 6.2.0 and up.

For information about FortiManager, see the FortiManager Administration Guide.

NP If FortiManager features are enabled in FortiAnalyzer before upgrading to 6.2.0 and later, the
‘9' existing feature configurations will continue to be available after the upgrade.
- FortiManager features carried over during an upgrade can be disabled through the CLI
- console.
Next steps

Now that you have set up your FortiAnalyzer units and they have started receiving logs from the devices, you can start
monitoring and interpreting data. You can:

View log messages collected by the FortiAnalyzer unit in Log View. See Types of logs collected for each device on
page 42.

View multiple panes of network activity in SOC (Security Operations Center). See SOC Monitoring on page 87.
View summaries of threats, traffic, and more in SOC > FortiView. See FortiView on page 98

Generate and view events in Incidents & Events. See Incident and Event Management on page 61.

Generate and view reports in Reports. See Reports on page 111.

Restarting and shutting down

Always use the operation options in the GUI or the CLI commands to reboot and shut down the FortiAnalyzer system to
avoid potential configuration problems.

FortiAnalyzer 6.2.3 Administration Guide
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To restart the FortiAnalyzer unit from the GUI:

1. Goto System Settings > Dashboard.
2. Inthe Unit Operation widget, click the Restart button.
3. Enter a message for the event log, then click OK to restart the system.

To restart the FortiAnalyzer unit from the CLI:

1. From the CLI, orin the CL/ Console menu, enter the following command:
execute reboot
The system will be rebooted.
Do you want to continue? (y/n)

2. Enter y to continue. The FortiAnalyzer system will restart.

To shutdown the FortiAnalyzer unit from the GUI:

1. Goto System Settings > Dashboard.
2. Inthe Unit Operation widget, click the Shutdown button.
3. Enter a message for the event log, then click OK to shutdown the system.

To shutdown the FortiAnalyzer unit from the CLI:

1. From the CLI, orin the CL/ Console menu, enter the following command:
execute shutdown
The system will be halted.
Do you want to continue? (y/n)

2. Enter y to continue. The FortiAnalyzer system will shutdown.

To reset the FortiAnalyzer unit:

1. From the CLI, or in the CL/ Console menu, enter the following command:
execute reset all-settings
This operation will reset all settings to factory defaults
Do you want to continue? (y/n)

2. Enter y to continue. The device will reset to factory default settings and restart.

To reset logs and re-transfer all SQL logs to the database:

1. From the CLI, orin the CL/ Console menu, enter the following command:
execute reset-sqgllog-transfer
WARNING: This operation will re-transfer all logs into database.
Do you want to continue? (y/n)

2. Enter y to continue. All SQL logs will be resent to the database.

FortiAnalyzer 6.2.3 Administration Guide
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FortiAnalyzer Key Concepts

This section provides information about basic FortiAnalyzer concepts and terms. If you are new to FortiAnalyzer, use
this section to quickly understand this document and the FortiAnalyzer platform.

This section includes the following sections:

« Two operation modes on page 19
+ Administrative domains on page 21
+ Log storage on page 21

o SOC dashboard on page 23

Two operation modes

FortiAnalyzer can run in two operation modes: Analyzer and Collector. Choose the operation mode for your
FortiAnalyzer units based on your network topology and requirements.

Analyzer mode

Analyzer mode is the default mode that supports all FortiAnalyzer features. Use this mode to aggregate logs from one
or more Collectors.

FortiAnalyzer 6.2.3 Administration Guide
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The following diagram shows an example of deploying FortiAnalyzer in Analyzer mode.

FortiAnalyzer

l F I FortiGates |

ortiGates

Collector mode

When FortiAnalyzer is in Collector mode, its primary task is forwarding logs of the connected devices to an Analyzer and
archiving the logs. Instead of writing logs to the database, the Collector retains logs in their original binary format for
uploading. In this mode, most features are disabled.

Analyzer and Collector feature comparison

Feature Analyzer Mode Collector Mode
Device Manager Yes Yes
FortiView Yes No
FortiAnalyzer 6.2.3 Administration Guide 20
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Feature Analyzer Mode Collector Mode
Log View Yes Raw archive logs only
Incidents & Events Yes No
Monitoring devices Yes No
Reporting Yes No
System Settings Yes Yes
Log Forwarding Yes Yes

Analyzer-Collector collaboration

You can deploy Analyzer mode and Collector mode on different FortiAnalyzer units and make the units work together to
improve the overall performance of log receiving, analysis, and reporting. The Analyzer offloads the log receiving task to
the Collector so that the Analyzer can focus on data analysis and report generation. This maximizes the Collector’s log
receiving performance.

For an example of setting up Analyzer—Collector collaboration, see Collectors and Analyzers on page 256.

Administrative domains

Administrative domains (ADOMs) enable the admin administrator to constrain the access privileges of other
FortiAnalyzer unit administrators to a subset of devices in the device list. For Fortinet devices with virtual domains
(VDOMSs), ADOMs can further restrict access to only data from a specific VDOM for a device.

Enabling ADOMs alters the available functions in the GUI and CLI. Access to the functions depends on whether you are
logged in as the admin administrator. If you are logged in as the admin administrator, you can access all ADOMs. If
you are not logged in as the admin administrator, the settings in your administrator account determines access to
ADOMs.

For information on enabling and disabling ADOMSs, see Enabling and disabling the ADOM feature on page 179. For
information on working with ADOMs, see Administrative Domains on page 176. For information on configuring
administrator accounts, see Managing administrator accounts on page 223.

M ADOMs must be enabled to support FortiCarrier, FortiClient EMS, FortiMail, FortiWeb,
q FortiCache, and FortiSandbox logging and reporting. See Administrative Domains on page
- 176.

Log storage

Logs and files are stored on the FortiAnalyzer disks. Logs are also temporarily stored in the SQL database.

You can configure data policy and disk utilization settings for devices. These are collectively called log storage settings.
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You can configure global log and file storage settings. These apply to all logs and files in the FortiAnalyzer system
regardless of log storage settings.

SQL database

FortiAnalyzer supports Structured Query Language (SQL) for logging and reporting. The log data is inserted into the
SQL database to support data analysis in SOC > FortiView, Log View, and Reports. Remote SQL databases are not

supported.

For more information, see FortiView on page 98, Types of logs collected for each device on page 42, and Reports on
page 111.

The log storage settings define how much FortiAnalyzer disk space to use for the SQL database.

L When FortiAnalyzer is in Collector mode, the SQL database is disabled by default. If you want
? to use logs that require SQL when FortiAnalyzer is in Collector mode, you must enable the
= SQL database. See Two operation modes on page 19.

Analytics and Archive logs

Logs in FortiAnalyzer are in one of the following phases. Use a data policy to control how long to retain Analytics and
Archive logs.

« Real-time log: Log entries that have just arrived and have not been added to the SQL database, i.e., have not been

rolled.

« Analytics logs or historical logs: Indexed in the SQL database and online.

« Archive logs: Compressed on hard disks and offline.

In the indexed phase, logs are indexed in the SQL database for a specified length of time for the purpose of analysis.
Logs in the indexed phase in the SQL database are considered online and you can view details about these logs in
SOC > FortiView, Log View, and Incidents & Events panes. You can also generate reports about the logs in the
Reports pane.

In the compressed phase, logs are compressed and archived in FortiAnalyzer disks for a specified length of time for the
purpose of retention. Logs in the compressed phase are considered offline and you cannot immediately view details
about these logs in the SOC > FortiView, Log View, and Incidents & Events panes. You also cannot generate reports
about the logs in the Reports pane.

Data policy and automatic deletion

Use a data policy to control how long to keep compressed and indexed logs. When ADOMs are enabled, you can specify
settings for each ADOM and the settings apply to all devices in that ADOM. When ADOMs are disabled, settings apply
to all managed devices.

A data policy specifies:

« How long to keep Analytics logs indexed in the database
When the specified length of time in the data policy expires, logs are automatically purged from the database but
remain compressed in a log file on the FortiAnalyzer disks.
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« How long to keep Archive logs on the FortiAnalyzer disks
When the specified length of time in the data policy expires, Archive logs are deleted from the FortiAnalyzer disks.

See also Log storage information on page 57.

Disk utilization for Archive and Analytic logs

You can specify how much of the total available FortiAnalyzer disk space to use for log storage. You can specify what
ratio of the allotted storage space to use for logs that are indexed in the SQL database and for logs that are stored in a
compressed format on the FortiAnalyzer disks. Then you can monitor how quickly device logs are filling up the allotted

disk space.
NP Analytic logs indexed in the SQL database require more disk space than Archive logs (purged
‘Q' from the SQL database but remain compressed on the FortiAnalyzer disks). An average
- indexed log is 400 bytes and an average compressed log is 50 bytes. Keep this difference in

mind when specifying the storage ratio for Analytics and Archive logs.

When ADOMs are enabled, you can specify settings for each ADOM and the settings apply to all devices in that ADOM.

When ADOMs are disabled, settings apply to all managed devices. See Log storage information on page 57.

SOC dashboard

FortiAnalyzer provides dashboard for Security Operations Center (SOC) administrators. SOC includes monitors which
enhance visualization for real-time activities and historical trends for analysts to effectively monitor network activities
and security alerts. See SOC Monitoring on page 87.

In high capacity environments, the SOC module can be disabled to improve performance. See Enabling and disabling
SOC on page 109.
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Use the Device Manager pane to add, configure, and manage devices and VDOMSs.

After you add and authorize a device or VDOM, the FortiAnalyzer unit starts collecting logs from that device or VDOM.
You can configure the FortiAnalyzer unit to forward logs to another device. See Log Forwarding on page 190.

ADOMs

You can organize connected devices into ADOMs to better manage the devices. ADOMs can be organized by:

« Firmware version: group all 6.0 devices into one ADOM, and all 6.2 devices into another.

« Geographic regions: group all devices for a specific geographic region into an ADOM, and devices for a separate
region into another ADOM.

« Administrator users: group devices into separate ADOMs based for specific administrators responsible for the
group of devices.

« Customers: group all devices for one customer into an ADOM, and devices for another customer into another
ADOM.

FortiAnalyzer, FortiCache, FortiClient, FortiDDos, FortiMail, FortiManager, FortiSandbox, FortiWeb, Chassis, and
FortiCarrier devices are automatically placed in their own ADOMs.

o Security Fabric: group all devices that are within the Security Fabric.

Each administrator profile can be customized to provide read-only, read/write, or restrict access to various ADOM
settings. When creating new administrator accounts, you can restrict which ADOMs the administrator can access, for
enhanced control of your administrator users. For more information on ADOM configuration and settings, see
Administrative Domains on page 176.

FortiClient EMS devices

You can add FortiClient EMS servers to FortiAnalyzer. Authorized FortiClient EMS servers are added to the default
FortiClient ADOM. You must enable ADOMs to work with FortiClient EMS servers in FortiAnalyzer. When you select the
FortiClient ADOM and go to the Device Manager pane, the FortiClient EMS servers are displayed. See also FortiClient
support and ADOMs on page 178.

Unauthorized devices

When a device is configured to send logs to FortiAnalyzer, the unauthorized device is displayed in the Device Manager
> Devices Unauthorized pane. You can then add devices to specific ADOMs or delete devices by using the toolbar
buttons or the right-click menu.
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Using FortiManager to manage FortiAnalyzer devices

You can add FortiAnalyzer devices to FortiManager and manage them. When you add a FortiAnalyzer device to
FortiManager, FortiManager automatically enables FortiAnalyzer features. FortiAnalyzer and FortiManager must be
running the same OS version, at least 5.6 or later.

In the Device Manager pane, a message informs you the device is managed by FortiManager and all changes should
be performed on FortiManager to avoid conflict. The top right of this pane displays a lock icon. If ADOMs are enabled,
the System Settings > All ADOMs pane displays a lock icon beside the ADOM managed by FortiManager.

Logs are stored on the FortiAnalyzer device, not the FortiManager device. You configure log storage settings on the
FortiAnalyzer device; you cannot change log storage settings using FortiManager.

For more information, see Adding FortiAnalyzer devices in the FortiManager Administration Guide.

Adding devices

You must add and authorize devices and VDOMs to FortiAnalyzer to enable the device or VDOM to send logs to
FortiAnalyzer. Authorized devices are also known as devices that have been promoted to the DVM table.

You must configure devices to send logs to FortiAnalyzer. For example, after you add and
ﬂ authorize a FortiGate device with FortiAnalyzer, you must also configure the FortiGate device
I to send logs to FortiAnalyzer. In the FortiGate GUI, go to Log & Report > Log Settings, and
enable Send Logs to FortiAnalyzer/FortiManager.

Adding devices using the wizard

You can add devices and VDOMs to FortiAnalyzer using the Add Device wizard. When the wizard finishes, the device is
added to the FortiAnalyzer unit, authorized, and is ready to start sending logs.

To add devices using the wizard:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Device Manager and click Add Device.

Add Device

Please input the following information to add a device.

IP Address

SN

Device Name

Device Model

Firmware Version 5.6

Description
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3. Configure the following settings:

IP Address
SN

Device Name
Device Model

Firmware Version

The device is added to the ADOM and, if successful, is ready to begin sending logs to the FortiAnalyzer unit.

Type the IP address for the device.

Type the serial number for the device.
Type a name for the device.

Select the model of the device.

Select the firmware version of the device.

Type a description of the device (optional).

Description
4. Click Next.
Add Device
Name Wink
SN FGVMO000000000000

IP Address 333.33.2.333

Status Device is added successfully

Creating device database
Retrieving high availability status
Initializing configuration database
Updating group membership

Successfully add device

CEs ]

5. Click Finish to finish adding the device and close the wizard.

Authorizing devices

You can configure supported devices to send logs to the FortiAnalyzer device. These devices are displayed in the root
ADOM as unauthorized devices. You can quickly view unauthorized devices by clicking Unauthorized Devices in the

quick status bar. You must authorize the devices before FortiAnalyzer can start receiving logs from the devices.

When ADOMs are enabled, you can assign the device to an ADOM. When authorizing multiple devices at one time,

they are all added to the same ADOM.

When you delete a device or VDOM from the FortiAnalyzer unit, its raw log files are also deleted. SQL database logs are

not deleted.

To authorize devices:

1. Inthe root ADOM, go to Device Manager and click Unauthorized Devices in the quick status bar. The content

pane displays the unauthorized devices.
2. If necessary, select the Display Hidden Devices check box to display hidden unauthorized devices.
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3. Select the unauthorized device or devices, then click Authorize. The Authorize Device dialog box opens.

Authorize Device

Add the following device(s) to ADOM: root

Device Name Assign New Device Name

FGVM010000102012 FGVM010000102012

4. If ADOMs are enabled, select the ADOM in the Add the following device(s) to ADOM list. If ADOMs are disabled,
select root.

5. Click OK to authorize the device or devices.
The device or devices are authorized and FortiAnalyzer can start receiving logs from the device or devices.

Hiding unauthorized devices

You can hide unauthorized devices from view, and choose when to view hidden devices. You can authorize or delete
hidden devices.

To hide and display unauthorized devices:

1. Inthe root ADOM, go to Device Manager and click Unauthorized Devices in the quick status bar. The content
pane displays the unauthorized devices.

2. Select the unauthorized device or devices, then click Hide.
The unauthorized devices are hidden from view.

You can view hidden devices by selecting the Display Hidden Devices check box.

Adding an HA cluster

You can use a HA cluster to synchronize logs and data securely among multiple FortiGate devices.

An HA cluster can have a maximum of four devices: one primary device with up to three backup devices. All the devices
in the cluster must be of the same FortiGate series and must be visible on the network.

You can use auto-grouping in FortiAnalyzer to group devices in a cluster based on the group

i, name specified in Fortigate's HA cluster configuration. For auto-grouping to work properly,
~Q' each FortiGate cluster requires a unique group name.
— If a unique group name is not used, auto-grouping should be disabled.

FAZ # config system global
(global) # set ha-member-auto-grouping disable

To create a HA cluster:

1. If using ADOMSs, ensure that you are in the correct ADOM.

2. Add the devices to the Device Manager.
3. Choose a device, and click Edit.
4. Inthe Edit Device pane, select HA Cluster.
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5. From the Add Existing Device list, select a device, and click Add.

Name FG149

Description

IP Address 10.10.10.10

Serial Number FGYMO0000000000 (FortiGate-VMé4)

Firmware Version FortiGate 5.6, build1534

Admin User admin

Password ssssss

HA Cluster (]

Add Existing Device « | +
Add Other Device Serial N +
HA Cluster List #  Device Name Action

1 FG149 (FGVMO0000000000)

6. Optionally, you can use the Add Other Device field to add a new device.

I\I Adding the devices before you create the HA is recommended.

7. Add more devices as necessary, and click OK.
The maximum is three standby devices.

To view the HA in the Device Manager, click Column Settings > HA Status.

Managing devices
Use the tools and commands in the Device Manager pane to manage devices and VDOMs.

Using the quick status bar

Aomve n 1 pevces u Gocices u 0% storese usea
You can see the quick status bar at the top of the Device Manager pane. The quick status bar contains the following
tabs:

o Devices Total: Displays the authorized devices.

o Devices Unauthorized: Displays the unauthorized devices.

« Devices Log Status Down: Displays the authorized devices with a log status of down.

» Storage Used: Displays the Log View > Storage Statistics page.

The Devices Total, Devices Unauthorized, and the Devices Log Status Down tabs include the following default
columns:

Column Description

Device Name Displays the name of the device.
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Column Description

IP Address Displays the IP address for the device.
Platform Displays the platform for the device.
Logs Identifies whether the device is successfully sending logs to the FortiAnalyzer

unit. A green circle indicates that logs are being sent. A red circle indicates that
logs are not being sent.

A lock icon displays when a secure tunnel is being used to transfer logs from the
device to the FortiAnalyzer unit.

Average Log Rate Displays the average rate at which the device is sending logs to the FortiAnalyzer
(Logs/Sec) unit in log rate per second. Click the number to display a graph of historical
average log rates.

Device Storage Displays how much of the allotted disk space has been consumed by logs.

Description Displays a description of the device (not displayed in Devices Unauthorized tab).

Using the toolbar

The following buttons and menus are available for selection on the toolbar:

Button Description

Add Device Opens the Add Device Wizard to add a device to the FortiAnalyzer unit. The
device is added, but not authorized. Unauthorized devices are displayed in the
Unauthorized Devices tree menu.

Edit Edits the selected device.

Delete Deletes the selected devices or VDOMs from the FortiAnalyzer unit.

When you delete a device, its raw log files are also deleted. SQL database logs
are not deleted.

Column Settings Click to select which columns to display or select Reset to Default to display the
default columns.

More Displays more menu items including Import Device List and Export Device List.

Search Type the name of a device. The content pane displays the results. Clear the
search box to display all devices in the content pane.

Editing device information

Use the Edit Device page to edit information about a device. The information and options available on the Edit Device
page depend on the device type, firmware version, and which features are enabled.
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To edit information for a device or model device:

1. Goto Device Manager and click the Devices Total tab in the quick status bar.

2. Inthe content pane, select the device or model device and click Edit, or right-click on the device and select Edit.
The Edit Device pane displays.

Edit Device

Name

Description

IP Address

Serial Number
Firmware Version
Admin User

Password

FG149

10.10.10.10
FGVMO0000000000 (FortiGate-VM&4)
FortiGate 5.6, build1534

admin

[ITTTTY

HA Cluster

Add Existing Device +
Add Other Device +
HA Cluster List #  Device Name Action

1 FG149 (FGYM0000000000)

Device Location v

Geographic Coordinate
Show Map

Company/QOrganization

Country

Province/State

City

Contact

49.25929408629

(Latitude) | -123.0115892711 (Longitude)

G

3. Edit the device settings and click OK.

Name
Description

IP Address

Serial Number
Firmware Version
Admin User
Password

HA Cluster

Geographic Coordinates

Company/Organization
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The name of the device.

Descriptive information about the device.
Enter the IP address of the device.

The serial number of the device.

The firmware version.

Enter the administrator user name.

Enter the administrator user password.

Select to identify the device as part of an HA cluster, and to identify the other
device in the cluster by selecting them from the drop-down list, or by inputting
their serial numbers.

Identifies the latitude and longitude of the device location to support the
interactive maps.

Click Show Map to open a map showing the location of the device based on

the coordinates. Click and drag the map marker to adjust the device's location.

Optionally, enter the company or organization information.
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Country
Province/State
City

Contact

Optionally, enter the country where the device is located.
Optionally, enter the province or state.
Optionally, enter the city.

Optionally, enter the contact information.

Displaying historical average log rates

You can display a graph of the historical, average log rates for each device.

To display historical average logs rates:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto Device Manager and click the Devices Total tab in the quick status bar.
3. Inthe Average Log Rate (Logs/Sec) column, click the number to display the graph.

Log Rate History (CorpFW, Last 24 Hours)

& 220

[}
g 200

1804

4. Hover the cursor over the graph to display more details.

Connecting to an authorized device GUI

You can connect to the GUI of an authorized device from Device Manager.

To connect to an authorized device GUI:

If using ADOMSs, ensure that you are in the correct ADOM.

AoODdD =

If necessary, change the port number and click OK.
You are directed to the Login page of the device GUI.
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Go to Device Manager and click the Devices Total tab in the quick status bar.
Right-click the device that you want to access, and select Connect to Device.

31



Fabric View

The Fabric View module enables you to create fabric connectors and view the list of endpoints. The Fabric View tab is
available in version 6.0 ADOMs and later.

This section contains the following topics:

o Fabric Connectors on page 32
o Asset & Identity

Fabric Connectors

You can use FortiAnalyzer to create the following types of fabric connectors:

e« ITSM
« Storage on page 33

ITSM

You can use the Fabric Connectors tab to create the following types of ITSM connectors:

o ServiceNow
« Webhook, a generic connector

Creating or editing ITSM connectors
You can create ITSM connectors for ServiceNow and Webhook.

To create or edit ITSM connectors:

1. Goto Fabric View > Fabric Connectors.

2. To create an ITSM connector, click Create New. In the Create New Fabric Connector wizard, select ServiceNow
or Webhook, and click Next.
To edit an ITSM connector, click the ITSM connector. The connector options are displayed.

3. Configure the following options, and then click OK:

Property Description

Name Type a name for the fabric connector.
Description (Optional) Type a description for the fabric connector.
Protocol Select HTTPS.
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Property Description

Port Specify the port FortiAnalyzer uses to communicate with the external
platform.

Method Select POST.

Title Type a title for the fabric connector.

URL Type the URL of the external platform.

Using ServiceNow as an example, copy and paste the URL from ServiceNow
API URL in the Connection to ServiceNow API section in ServiceNow >
FortiAnalyzer System Properties.

Enable HTTP Authentication Set HTTP authentication to ON or OFF.

Using ServiceNow as an example, enter the username and password from the
Connection to ServiceNow API section in ServiceNow > FortiAnalyzer
System Properties.

Status Toggle ON to enable the fabric connector. Toggle OFF to disable the fabric
connector.

Storage

You can use the Fabric Connectors tab to create the following types of storage connectors:

« Amazon S3
o Microsoft Azure
o Google Cloud

Creating or editing storage connectors

You can create storage connectors for Amazon S3, Microsoft Azure, and Google Cloud. Once you have created a
storage connector, you can upload FortiAnalyzer logs to cloud storage. See Upload logs to cloud storage on page 219

To create a storage connector:

1. Goto Fabric View > Fabric Connectors.

2. Select Create New. In the Create New Fabric Connector wizard, choose Amazon S3, Azure Blob, or Google and
select Next.
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3. Configure the following options and select OK.

Property Description

Name
Comments
Title
Status

Amazon S3

Azure Blob

Google

Provider
Region
Access Key ID

Secret Access Key

Storage Account
Name

Account Key

Cloud
Project Number

Service Account
Credentials

Cloud Location

Type a name for the fabric connector.
(Optional) Add comments about the connector.
Type a title for the fabric connector.

Toggle On to enable the fabric connector. Toggle Off to disable the
fabric connector.

Type AWS.
Select a region.
Paste the access key from the IAM user account.

Paste the secret access key from the IAM user account. Click the eye
icon to Show or Hide the key.

Paste the storage account name from the Microsoft Azure account.

Paste the account key from the Microsoft Azure account.

Paste the project number from the Google account.

Paste the entire Google account JSON key into the field. Click the eye
icon to Show or Hide the key.

Select a Google Cloud location. For information about Google
locations, visit the product help.

4. Advanced options will differ between the various types of storage connectors.

To edit a storage connector:

A oODbd=

Identity Center

Go to Fabric View > Fabric Connectors.

Select an existing storage connector to edit.

In the dropdown menu that appears below the connector name, modify the connector settings.
Select OK.

The Fabric View > Identity Center pane displays a list of users and endpoints in the network from relevant logs, and
correlates them with FortiAnalyzer modules.

The ldentity Center is useful for user and endpoint mapping. Some users might use multiple endpoints in the network,
endpoints might use multiple different interfaces to connect, network interfaces might have multiple IP addresses, and
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so on. A map of users and their endpoints gives you better visibility when you analyze logs, events, and incidents. This
also helps with your reporting.

To view relevant identity logs directly from the SOC, Log View, and Incidents & Events panes, click the user or endpoint
log, then click the Topography link in the pop-up that appears.

This Identity pane lists all endpoints and users from relevant logs and correlates them with FortiAnalyzer modules.

Column Description

User Name The name of the user.

User Group The group of user identities. An identity can be a:

Endpoints

Local user account (username/password stored on the FortiGate unit)

Remote user account (password stored on a RADIUS, LDAP, or TACACS+ server)

PKI user account with digital client authentication certificate stored on the FortiGate unit
RADIUS, LDAP, or TACACS+ server, optionally specifying particular user groups on that
server

User group defined on an FSSO server.

Endpoint host name, IP address, or MAC address. A user may be connected to multiple

endpoints.

Click the endpoint to display the corresponding user information in the Assets pane.

Social
Source

Last Update

The user's Name, Picture, Email, Phone Number, and Social if it is available.
The name of device that created the log.

The date and time the log was updated.

Use the toolbar to select a Security Fabric, time period, and columns.

End user information is limited if there is no FortiClient in your installation.

.

Endpoints are detected based on MAC address and displayed by IP address instead of
host name.
User related information might not be available.

Detailed information such as OS version, avatar, and social ID information are not
available.

To provide a unified experience, you can customize how identity information is displayed, including which fields are
displayed, the order, and the priority.

To configure the display settings in the Social column:

1.
2

Go to Log View >Tools > User Display Preferences.
Select the order preference tab you want to configure.

Tabs include Name, Picture, Email, Phone Number, and Social.

Rearrange the order preference as per your needs by drag-and-dropping an entry. For names, pictures, emails, and

phone numbers, only the top entry will appear in the identity pop-up window.

User information can be disabled by moving the Show toggle to the Off position in the respective tabs.
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Assets

The Fabric View > Assets pane is the central location for security analysts to view endpoint and user information to
make sure they are compliant. Endpoints are important assets in a network as they are the main entry pointsin a
cybersecurity breach.

The Assets pane is useful for the following:

« Incident response. Check assets that are infected or vulnerable as part of your SOC analysis and incident response
process.

« Compliance. Identify unknown and non-compliant users and endpoints.

To view relevant asset logs directly from the SOC, Log View, and Incidents & Events panes, click the user or endpoint
log, then click the Topography link in the pop-up that appears.

The Assets pane lists all endpoints and users from relevant logs and correlates them with FortiAnalyzer modules. Sort
by the Vulnerabilities column to see which endpoints and users have the highest vulnerabilities.

Column Description

Endpoint Endpoint host name or IP address.

User The name of the user. Click the name to view the corresponding user information in the
Identity Center pane.

MAC Address Endpoint MAC address.

IP Address IP address the endpoint is connected to. A user might be connected to multiple endpoints.

FortiClient UUID Unique ID of the FortiClient.
Hardware / OS OS name and version.

Vulnerabilities The number of vulnerabilities for critical, high, medium, and low vulnerabilities. Click the
vulnerability to view the name and category.

Network Location The location of the FortiAnalyzer device.

Last Update The date and time the log was updated.

Use the toolbar to select a Security Fabric, time period, and columns.

If there is no FortiClient in your installation, then endpoint and end user information is limited.
« Endpoints are detected based on MAC address and displayed by IP address instead of

host name.
o Userrelated information might not be available.

o Detailed information such as OS version, avatar, and social ID information are not
available.
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FortiAnalyzer can recognize a Security Fabric group of devices and display all units in the group on the Device Manager
pane. See Adding a Security Fabric group on page 37. FortiAnalyzer supports the Security Fabric by storing and
analyzing the logs from the units in a Security Fabric group as if the logs are from a single device. You can also view the
logging topology of all units in the Security Fabric group for additional visibility. See Displaying Security Fabric topology
on page 38.

FortiAnalyzer provides dynamic data and metadata exchange with the Security Fabric and uses the data in FortiView
and Reports for additional visibility. A default report template lets you monitor new users, devices, applications,
vulnerabilities, threats and so on from the Security Fabric.

A set of dashboard widgets lets you review audit scores for a FortiGate Security Fabric group with recommended best
practices and historical audit scores and trends.

If FortiClient is installed on endpoints for endpoint control with FortiGate, you can use the endpoint telemetry data
collected by the Security Fabric agent to display user profile photos in reports and FortiView.

Adding a Security Fabric group

Before you can add a Security Fabric group to FortiAnalyzer, you need to create the Security Fabric group in FortiGate.

Fortinet recommends using a dedicated Super_User administrator account on the FortiGate for FortiAnalyzer access.
This ensures that associated log messages are identified as originating from FortiAnalyzer activity. This dedicated
Super_User administrator account only needs Read Only access to System Configuration; all other access can be set
to None.

To add a Security Fabric group:

1. Goto Device Manager > Unauthorized Devices.
2. Select all the devices corresponding to the Security Fabric group created in FortiGate.

3. Authenticate the Security Fabric group by clicking the Warning icon (yellow triangle) beside the corresponding
FortiGate root.

Authentication

Please enter admin user name and password for the root device of security fabric "csf80cm”.

Admin User ||

Password

4. Enter the Authentication Credentials. The authentication credentials are the ones you specified in FortiGate. Once
the FortiGate root has been authenticated, the Warning icon will disappear.

5. After authentication, it takes a few minutes for FortiAnalyzer to automatically populate the devices under the
FortiGate root which creates the Security Fabric group.
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Displaying Security Fabric topology
For Security Fabric devices, you can display the Security Fabric topology.

To display the Security Fabric topology:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Device Manager and click the Devices Total tab in the quick status bar.

3. Right-click a Security Fabric device and select Fabric Topology.
A pop-up window displays the Security Fabric topology for that device.
If you selected Fabric Topology by right-clicking a device within the Security Fabric group, the device is highlighted
in the topology. If you selected Fabric Topology by right-clicking the name of the Security Fabric group, no device is
highlighted in the topology.

Topology for FGP2000000000000

HA Active-Passive

FGT200DPOE-L1-root B3 FGBLE-HAL2 — 5%} FG280DPOEL3

-
oo FGB1E-HA-LS

FGVYM-076-12

Security Fabric traffic log to UTM log correlation

FortiAnalyzer correlates traffic logs to corresponding UTM logs so that it can report sessions/bandwidth together with its
UTM threats. Within a single FortiGate, the correlation is performed by grouping logs with the same session I1Ds, source
and destination IP addresses, and source and destination ports.

In a Cooperative Security Fabric (CSF), the traffic log is generated by the ingress FortiGate, while UTM inspection (and
subsequent logs) can occur on any of the FortiGates. This means that the traffic logs did not have UTM related log
fields, as they would on a single FortiGate. Different CSF members also have different session IDs, and NAT can hide
or change the original source and destination IP addresses. Consequently, without a proper UTM reference, the
FortiAnalyzer will fail to report UTM threats associated with the traffic.

This feature adds extensions to traffic and UTM logs so that they can be correlated across different FortiGates within
the same security fabric. It creates a UTM reference across CSF members and generates the missing UTM related log
fields in the traffic logs as if the UTM was inspected on a single FortiGate.

NAT translation is also considered when searching sources and destinations in both trafficand UTM logs. The FortiGate
will generate a special traffic log to indicate the NAT IP addresses to the FortiAnalyzer within the CSF.

Traffic logs to DNS and SSH UTM references are also implement - the DNS and SSH counts in Log View can now be
clicked on to open the related DNS and SSH UTM log. IPS logs in the UTM reference are processed for both their
sources and destinations in the same order, and in the reverse order as the traffic log. The FortiGate log version
indicator is expanded and used to make a correct search for related IPS logs for a traffic log.
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This feature requires no special configuration. The FortiAnalyzer will check the traffic and UTM logs for all FortiGates
that are in the same CSF cluster and create the UTM references between them.

To view the logs:

1. Onthe FortiAnalyzer, go to Log View > Traffic.
The UTM security event list, showing all related UTM events that can happen in another CSF member, is shown.

2. Click the count beside a UTM event to open the related UTM event log window. In this example, the traffic log is
from the CSF child FortiGate, and the UTM log is from the CSF root FortiGate.

Antivirus

A% Wi Date/Time Dievice Name Palicy ID Action Source

| [151636 FGT_1000_CSF_root 2 1011042

=-Security
Lovel wamhg L

Threat Level eitical 5
Threat Score 50 4

=I-Source 3
Agent o RIFTART =)- Des.
Device D FGLO0D3G1 4840718 £
Bevice Kame FGT_1000_C57 oot L
End User 1D 2 il
Endpeint I s4242 !
" 1011012 !
interface ™ i
Fterface Rale ™ =1-Ag
Part 33781 e

Like other UTM logs, newly added DNS and SSH UTM references can also be shown in the FortiAnalyzer Log View.
Clicking the count next to the DNS or SSH event opens the respective UTM log.

3. Goto SOC > FortiView > Threats > Top Threats. All threats detected by any CSF member are shown.

e ADOM; CSF_tdom 23 @ (B admin +
B summary A Filtar - B- oS-
# Threats ~
Threat Score = Critical - High Medium Low
Top Threats. 1o N !
Threat Map an.
Compromised Hosts &0
FortiSandbon Detection an
= Traffic ¥ 20
§H Applications & Wehsites * o T T T T T
150500 15:10.00 151500 152000 152500 15:30:00
& PN ¥
2 WIFl N [ Threat Category CVE IO Threat Level Threat Scorel  Blocked! ™ Incidents{  Blocked/ ™
Allowad) Allowed)
»
£ System 1 W32iPaiteB Malwara 300 s
& Endioints Plz EICARTEST FILE Malware 250 5
3 kprowy.com Preoy Avoldance Mexdium 60— &
4 KProsy Prewy Medium 50 = 5 O—
2= Total logs stored for analytice: 42 days 22 hours. Show 100« | Total 4

4. The created UTM reference is also transparent to the FortiGate when it gets its logs from the FortiAnalyzer. On the
FortiGate, the traffic log shows UTM events and referred UTM logs from other CSF members, even though the
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FortiGate does not generate those UTM log fields in its traffic log. In this example, the CSF child FortiGate shows
the referred UTM logs from the CSF root FortiGate.

@ Dashboard > e] & o AddFiter
% Security Fabri > . m— = ;

% Security Fabric # | % | DateTime Souree Destination Security Events Log Details x
& Fortiview 4 N dminutes ago @0 00:0c:29:29:9a:72 172.18.32.92 : Details
+ Metwork 2 4minutes ago @ 00:0¢:29:29.92:72 172.18.32.92 = :

. s B AntiVirus = &
& System > 3 4 minutes ago 172.18.32.92 Agent 17197
. - 1 = curl/7. 1%,
B Policy & Objects | ¢ OmiEses TR I | £ isandbox Checksum  275a0216bib
@ Security Profil N 5 éminutes ago O 00:0¢:29:29:9a.72 1721832126 1EEY A submitted to FortiSandbox false
ECUrit T e5 . -
i 6 7minutes ago @0 00:0c:29:29:92:72 172.18.32.126 [ wea [B1 ave [ ?eralls hast: 172,182
2PN >17 Friinutessgo @ 00:06:29:29:972 141167.114.102230 (kprowycom) [ 1S 1 poeat el e aG1d
& User & Device > 8 9minutesago O 00:0c:29:29:92:72 172.18.32.92 Directian incoming
= WIFi & Switch Controller > | ¢ Fminutes ago @ 00:00:29:29:92:72 172.18.32.92 Detection Type Wirus
. P Log event original timestarmp 1547077055
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i “sarantine Skip ile-was-not-c
TSI 14 12 minutes ago 2 172.18.32.126 [ 100 8 Reference https://fortigu
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HA Events 21 17 minutes ago @0 00:0¢:29:29:92:72 172.18.32.126 | wes [l e G Direction cutgaing
WAN Opt. & Cache Events 22 19 minutes ago @0 00:0¢:29:29:9272 172183292 Log event ariginal timestamp 1547077055
e < i ST — s o ccs s TS sTT i on T v - EV&HETYDE urlmonitor
WiFi Events = <<l 1 N Hostname 172183212

Creating a Security Fabric ADOM

All Fortinet devices included in a Security Fabric can be placed into a Security Fabric ADOM, allowing for fast data
processing and log correlation. Fabric ADOMs enable combined results to be presented in the Device Manager, Log
View, SOC, Incidents & Events and Reports panes.

In a Fabric ADOM:
o Device Manager. View and add all Fortinet devices in the Security Fabric to the Fabric ADOM, including FortiGate,
FortiSandbox, FortiMail, FortiDDoS, and FortiClient EMS.
o Log View: View logs from all Security Fabric devices.
o SOC: FortiDDoS and FortiClient EMS widgets are available.

« Incidents & Events: Predefined event handlers for FortiGate, FortiSandbox, FortiMail, and FortiWweb ADOMs are
available, and triggered events are displayed for all device types.

« Reports: View predefined reports, templates, datasets, and charts for all device types. Charts from all device types
can be inserted into a single report.

To create a Fabric ADOM:

1. In FortiAnalyzer, go to System Settings > All ADOMs.
2. Select Create New.

3. Configure the settings for the new Fabric ADOM and select Fabric as the type.
See Creating ADOMSs on page 181 for more information on the individual settings.
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System Settings v

€ Dashboard Create New ADOM

& Logging Topology L

@ All ADOMs. Type

C storage Info Comments |

< Network Fabr

& HA FortiAnalyzer 0/128

2 Admin ~ | Devices FortiAuthenticator Q
Administrators FortiCache ™
Profile FortiCarrier

Remote Authentication Server FortiClient

FortiDDoS

Admin Settings

EB Certificates ~
Local Certificates
CA Certificates
CRL

& Log Forwarding

B8] Fetcher Management

B Event Log

[@Task Monitor

E: Advanced ~ | Data Policy
SNMP Keep Logs for Analytics 60 =] Days. v
Mail Server Keep Logs for Archive 365 B Days. v

Syslog Server Disk Utilization

Meta Fields Mowiemsion Allossind n110 o Ve | Availahle: 20 GR o
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4. Select OKto create the ADOM.
The Fabric ADOM is listed under the Security Fabric section of All ADOMs.

S5 System Settings v ADOM: my_fabric £ @ (&) admin v

© Dashboard + CreateNew [ Edit [ Delete = EnterA © Disable ADOM  { More v # Column Settings ~ Y
& Logging Topology O Name Firmware Version Allocated Storage Devices Comments.
@ All ADOMs.
O my_fabric Fabric 50GB
C Storage Info -tanr !
© Network O FortiCarrier FortiCarrier 1000 MB
£ HA O root FortiGate 168
2 Admin ~
- O Chassis - -
Administrators
O Fortinalyzer FortiAnalyzer 1000 MB
Profile O FortiAuthenticator FortiAuthenticator 1000 MB
Remote Authentication Server O FortiCache FortiCache 1000 MB
Admin Settings O FortiClient FortiClient 1000 MB
O FortiDDoS FortiDDoS 1000 MB
EB Certificates v
O FortiMail FortiMail 1000 MB
Local Certificates O FortiManager FortiManager 1000 M8
CA Certificates O FortiProxy FortiProxy 1000 MB
CRL O FortiSandbox FortiSandbox 1000 MB
- . O Fortiweb FortiWeb, 1000 MB
& Log Forwarding
O Syslog Syslog 1000 MB
Bl Fetcher Management
# Event Log.
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You can view log information by device or by log group.
When rebuilding the SQL database, Log View is not available until the rebuild is complete.
Click the Show Progress link in the message to view the status of the SQL rebuild.

When ADOMs are enabled, each ADOM has its own information displayed in Log View.

Log View can display the real-time log or historical (Analytics) logs.
Log Browse can display logs from both the current, active log file and any compressed log files.

For more information, see Analytics and Archive logs on page 22.

Types of logs collected for each device

FortiAnalyzer can collect logs from managed FortiGate, FortiCarrier, FortiCache, FortiMail, FortiManager,
FortiSandbox, FortiWeb, FortiClient, and syslog servers. Following is a description of the types of logs FortiAnalyzer
collects from each type of device:

Device Type Log Type
FortiAnalyzer Event
FortiAuthenticator  Event

FortiGate Traffic

Security: Antivirus, Intrusion Prevention, Application Control, Web Filter, File Filter, DNS,
Data Leak Prevention, Email Filter, Web Application Firewall, Vulnerability Scan, VolP,
FortiClient

Event: Endpoint, HA, Compliance, System, Router, VPN, User, WAN Opt. & Cache, WiFi

L File Filter logs are sent when the File Filter sensor is enabled in the
9 FortiOS Web Filter profile. You can enable the File Filter sensorin
- FortiOS at Security Profiles > Web Filters.
FortiCarrier Traffic, Event, GTP
FortiCache Traffic, Event, Antivirus, Web Filter
FortiClient Traffic, Event, Vulnerability Scan
FortiDDoS Event, Intrusion Prevention
FortiMail History, Event, Antivirus, Email Filter.
FortiAnalyzer 6.2.3 Administration Guide 42
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s‘é’, FortiMail logs support cross-log functionality. When viewing History,

Event, Antivirus, or Email Filter logs from FortiMail, you can click on the
Session ID to see correlated logs.

FortiManager Event
FortiSandbox Malware, Network Alerts
FortiWeb Event, Intrusion Prevention, Traffic
Syslog Generic

Traffic logs

Traffic logs record the traffic flowing through your FortiGate unit. Since traffic needs firewall policies to properly flow
through FortiGate, this type of logging is also called firewall policy logging. Firewall policies control all traffic attempting
to pass through the FortiGate unit, between FortiGate interfaces, zones, and VLAN sub-interfaces.

Security logs

Security logs (FortiGate) record all antivirus, web filtering, file filtering, application control, intrusion prevention, email
filtering, data leak prevention, vulnerability scan, and VolP activity on your managed devices.

DNS logs

DNS logs (FortiGate) record the DNS activity on your managed devices.

Event logs

Event logs record administration management and Fortinet device system activity, such as when a configuration
changes, or admin login or HA events occur. Event logs are important because they record Fortinet device system
activity which provides valuable information about how your Fortinet unit is performing. FortiGate event logs includes
System, Router, VPN, User, and WiFi menu objects to provide you with more granularity when viewing and searching
log data.

The logs displayed on your FortiAnalyzer depends on the device type logging to it and the
\‘ ! ', enabled features. FortiGate, FortiCarrier, FortiCache, FortiMail, FortiManager, FortiWeb,
q FortiSandbox, FortiClient, and Syslog logging is supported. ADOMs must be enabled to
= support non-FortiGate logging.
In a Security Fabric ADOM, all device logs are displayed.
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Log messages

You can view log information by device or by log group.

Viewing the log message list of a specific log type

You can find FortiMail and FortiWeb logs in their default ADOMSs.

To view the log message list:

1. If using ADOMs, ensure that you are in the correct ADOM.

2. Goto Log View, and select a log type from the tree menu.
The corresponding log messages list is displayed.

Viewing message details

To view message details:

1. Double-click a message in the message list.
The details pane is displayed to the right of the message list, with the fields categorized in tree view.

‘ Add Filter (] © B AllDevices~ @ Last1Hour~ 01:35:47 To 02:35:46
#  VDate/Time Device ID Action Source Destination IP Service Application ox
1 023529 FGT1KC0000000... v 172.184.112 172.184.108 HTTPS HTTPS A & ecurity
2 023529 FGT1KC0000000... v/ lliao (84172.28.3.133) EE157.55.56.170  udp/40032 udp/4003; 1PS Count
3 023529 FGT1KC0000000... ' v/ £3172.16.175.133 172.184.108 HTTPS HTTPS Level notice
4 02; FGT1KC0000000... v 4172.184.112 172.18.4.108 HTTPS HTTPS Threat Score °
5 E523.3.105.162 j : ESS::I
6  02:35: FGT1KC0000000... v/ £1172.16.175.133 172.184.108 HTTPS HTTPS %) Destination
7 023529 FGT1KC0000000... v/ 2172184.112 172.184.108 HTTPS HTTPS =) Action
8 023529 FGT1KC0000000... ' v/ £3172.16.175.133 172.18.4.108 HTTPS HTTPS : ) Qs
9 023529 FGT1KC0000000... v 172.16.175.133 172.184.108 HTTPS HTTPS ;’E:::)m 2”'““
10 02:35:29 FGT1KC0000000... v $2172.184.112 172.184.108 HTTPS HTTPS Security Action @ block
11 02:35:29 FGT1KC0000000... v 172.184.112 172.184.108 HTTPS HTTPS Threat 8192
12 02:35:29 FGT1KC0000000... v/ 172.16.175.133 172.18.4.108 HTTPS HTTPS - Application
13 023529 FGT1KC0000000... ' v/ 172.184.112 172.184.108 HTTPS HTTPS +)-Data
14 02:35:29 FGT1KC0000000... v £i10.2.60.65 [#1208.91.112.53  DNS DNS - Threat
15 02:35:29 FGT1KC0000000... £2172.184.112 172.184.108 HTTPS HTTPS 7 T“’;mm —
16 02:35:29 FGT1KC0000000... v/ £110.2.60.65 (+1208.91.112.52  DNS DNS Tyme raffic
17 02:35:29 FGT1KC0000000... v/ 192.168.2.115 10.2.60.58 RSH RSH +-Others

o nn.ae0 CoTavrnannnnn - 177104147 17910 4 100 T LT e

= Total logs for analytics: 8 hours. More

50

v |Items per page

e~n234 5

A 0.041 Second

You can display the log details pane below the message list by clicking the Bottom icon in the log details pane.
When the log details pane is displayed below the message list, you can move it to the right of the log message list
by clicking the Right icon. This is sometimes referred to as docking the pane to the bottom or right of the screen.
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The log details pane provides shortcuts for adding filters and for showing or hiding a column. Right-click a log field to
select an option.

ox

-} Security
Ll Level information
+-General
--Source
i ! Agent Debian

-~ Device ID FG100D3G13805309

- Device Name FG100D3G13805309

- Source 172.28.3.15

- Source IP 172.28.3.15

ource Interface

@, search "Source Interface = FMG-GUI-Team"

L @), search "Source Interface '= FMG-GUI-Team”
—-A
i =+ add "Source Interface” to column settings

. Firewall Action analytics

. Policy ID 20
+-Application
= Type

-~ Sub Type virus

- Type utm
+-Others

\‘ ! 'l
q If the log message contains UTM logs, you can click the UTM log icon in the log details pane
to open the UTM log view window.

Customizing displayed columns
The columns displayed in the log message list can be customized and reordered as needed.

To customize what columns to display:

1. Inthe toolbar of the log message list view, click Column Settings and select a column to hide or display.
The available columns vary depending on the device and log type.

2. To add other columns, click More Columns. In the Column Settings dialog box, select the columns to show or

hide.
3. Toreset to the default columns, click Reset to Default.
4. Click OK.
\‘ ! ’I
q You can also add or remove a log field column in the log details pane, by right-clicking a
- log field and selecting Add [log field name] or Remove [log field name].

To change the order of the displayed columns:

Place the cursor in the column title and move a column by drag and drop.
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Customizing default columns

In Log View, you can select the columns that are displayed as the default by clicking Save as Default in the Column
Settings menu when customizing columns. See Customizing displayed columns on page 45.

Column Settings

[Ipearch

B Date/Time
B Device ID
Source

O Application Category
O Application Control List

[ anslication 1D

Save as Default

Customizing the default column view can only be done on a Super_User administrator profile.
Default column customization is applied per devtype/logtype across all ADOMs.
The GUI displays columns based on the following order of priority:

1. Displays the user's column customizations (if defined).
2. Displays the default columns set by the Super_User administrator (if defined).
3. Displays the system default columns.

Customized default column configuration is preserved during upgrades.

ﬂ To reset default columns to the system default, deselect all columns from the Column
Settings selection menu and then select Sef as Default.

Filtering messages

You can apply filters to the message list. Filters are not case-sensitive by default. If available, select Tools > Case
Sensitive Search to create case-sensitive filters.
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Filtering messages using filters in the toolbar

1. Go to the view you want.

Regular search Click Add Filter and select a filter from the dropdown list, then type a value.
Only displayed columns are available in the dropdown list. You can use search
operators in regular search.

Switching between regular At the right end of the Add Filter box, click the Switch to Advanced Search
search and advanced search icon a or click the Switch to Regular Search icon .

Advanced search In Advanced Search mode, enter the search criteria (log field names and
values).

Search operators and syntax If available, click (] at the right end of the Add Filter box to view search
operators and syntax. See also Filter search operators and syntax on page 48.

CLI string “freestyle” search  Searches the string within the indexed fields configured using the CLI
command: config ts-index-field.

For example, if the indexed fields have been configured using these CLI
commands:
config system sqgl
config ts-index-field
edit "FGT-traffic"
set value "app,dstip,proto,service,srcip,user,utmaction”
next
end
end
Then if you type “Skype” in the Add Filter box, FortiAnalyzer searches for
“Skype” within these indexed fields:
app,dstip, proto, service, srcip,user and utmaction

You can combine freestyle search with other search methods, for example:
Skype user=David.

2. Inthe toolbar, make other selections such as devices, time period, which columns to display, etc.

Filtering messages using the right-click menu

In a log message list, right-click an entry and select a filter criterion. The search criterion with a @ icon returns entries
matching the filter values, while the search criterion with a & icon returns entries that do not match the filter values.

Depending on the column in which your cursor is placed when you right-click, Log View uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

NP To see log field name of a filter/column, right-click the column of a log entry and select a
‘Q' context-sensitive filter. The Add Filter box shows log field name.
- Context-sensitive filters are available for each log field in the log details pane. See Viewing

message details on page 44.
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Filtering messages using smart action filters

For Log View windows that have an Action column, the Action column displays smart information according to policy
(log field action) and utmaction (UTM profile action).

The Action column displays a green checkmark Accept icon when both policy and UTM profile allow the traffic to pass
through, that is, both the log field action and UTM profile action specify allow to this traffic.

The Action column displays a red X Deny icon and the reason when either the log field action or UTM profile action
deny the traffic.

If the traffic is denied due to policy, the deny reason is based on the policy log field action.

If the traffic is denied due to UTM profile, the deny reason is based on the FortiView threattype from craction.
craction shows which type of threat triggered the UTM action. The threattype, craction, and crscore fields
are configured in FortiGate in Log & Report. For more information, see the FortiOS - Log Message Reference in the
Fortinet Document Library.

Afilter applied to the Action column is always a smart action filter.

The smart action filter uses the FortiGate UTM profile to determine what the Action column
displays. If the FortiGate UTM profile has set an action to allow, then the Action column will
O ! ’, display that line with a green Accept icon, even if the craction field defines that traffic as a
q threat. The green Accept icon does not display any explanation.
- In the scenario where the craction field defines the traffic as a threat but the FortiGate
UTM profile has set an action to allow, that line in the Log View Action column displays a
green Accept icon. The green Accept icon does not display any explanation.

Filter search operators and syntax

Operators or symbols Syntax

And Find log entries containing all the search terms. Connect the terms with a space
character, or “and”. Examples:
1. user=henry group=sales
2. user=henry and group=sales

Or Find log entries containing any of the search terms. Separate the terms with “or”
oracomma “,”. Examples:
1. user=henry or srcip=10.1.0.15
2. user=henry, linda

Not Find log entries that do NOT contain the search terms. Add “-” before the field
name. Example:

-user=henry

> < Find log entries greater than or less than a value, or within a range. This operator
only applies to integer fields. Example:

policyid>1 and policyid<10

IP subnet/range search Find log entries within a certain IP subnet or range. Examples:
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Operators or symbols Syntax

1. srcip=192.168.1.0/24
2. srcip=10.1.0.1-10.1.0.254

Wildcard search You can use wildcard searches for all field types. Examples:
1. srcip=192.168.1.*
2. policyid=1*
3. user=*

Filtering FortiClient log messages in FortiGate traffic logs

For FortiClient endpoints registered to FortiGate devices, you can filter log messages in FortiGate traffic log files that
are triggered by FortiClient.

To Filter FortiClient log messages:

Go to Log View > Traffic.
In the Add Filterbox, type fct devid=*. Alist of FortiGate traffic logs triggered by FortiClient is displayed.
In the message log list, select a FortiGate traffic log to view the details in the bottom pane.

Click the FortiClient tab, and double-click a FortiClient traffic log to see details.
The FortiClient tab is available only when the FortiGate traffic logs reference FortiClient traffic logs.

A oODbd =

Viewing historical and real-time logs

By default, Log View displays historical logs. Custom View and Chart Builder are only available in historical log view.
To view real-time logs, in the log message list view toolbar, click Tools > Real-time Log.

To switch back to historical log view, click Tools > Historical Log.

Viewing raw and formatted logs

By default, Log View displays formatted logs. The log view you select affects available view options. You cannot
customize columns when viewing raw logs.

To view raw logs, in the log message list view toolbar, click Tools > Display Raw.
To switch back to formatted log view, click Tools > Formatted Log.

For more information about FortiGate raw logs, see the FortiGate Log Message Reference in the Fortinet Document
Library. For more information about raw logs of other devices, see the Log Message Reference for the platform type.

Custom views

Use Custom View to save the filter setting, device selection, and the time period you have specified.
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To create a new custom view:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type.
3. Inthe content pane, customize the log view as needed by adding filters, specifying devices, and/or specifying a

time period.
4. In the toolbar, click Custom View.

Save as New Custom View

5. Inthe Namefield, type a name for the new custom view.
6. Click OK. The custom view is now displayed under Log View > Custom View.

To edit a custom view:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Gotothe Log View > Custom View.

3. Inthe toolbar, edit the filter settings, and click GO.

4. Inthe toolbar, click Custom View.

5

Click Save to save the changes to the existing custom view or click Save as to save the changes to a new custom
view.

Click OK.

o

To view the traffic log of a custom view:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Gotothe Log View > Custom View.
3. Right-click the name of a custom view and select View Traffic.

Downloading log messages

You can download historical log messages to the management computer as a text or CSV file. You cannot download
real-time log messages.

To download log messages:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Log View, and select a log type.

In the toolbar, click Tools > Download.

In the Download Logs dialog box, configure download options:
« Inthe Log file format dropdown list, select Text or CSV.

AoODbd =

o To compress the downloaded file, select Compress with gzip.
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» To download only the current log message page, select Current Page. To download all the pages in the log
message list, select All Pages.

5. Click Download.

Creating charts

\ L}
‘?' You can also create charts in Reports > Report Definitions > Chart Library. See Chart library
- on page 130

Log View includes a Chart Builderfor you to build custom charts for each type of log messages.

To create charts with Chart Builder:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View, and select a log type.
3. Inthe toolbar, click Tools > Chart Builder.
4. Inthe Chart Builder dialog box, configure the chart and click Save.
Name Type a name for the chart.
Columns Select which columns of data to include in the chart based on the log
messages that are displayed on the Log View page.
Group By Select how to group data in the chart.
Order By Select how to order data in the chart.
Sort Select a sort order for data in the chart.
Show Limit Show Limit
Device Displays the device(s) selected on the Log View page.
Time Frame Displays the time frame selected on the Log View page.
Query Displays the query being built.
Preview Displays a preview of the chart.

Log groups

You can group devices into log groups. You can view FortiView summaries, display logs, generate reports, or create
handlers for a log group. Log groups are virtual so they do not have SQL databases or occupy additional disk space.

When you add a device with VDOMs to a log group, all VDOMs are automatically added.
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To create a new log group:

poOobd=

Go to Log View > Log Group.
In the content pane toolbar, click Create New.

In the Create New Log Group dialog box, type a log group name and add devices to the log group.
Click OK.

Log browse

When a log file reaches its maximum size or a scheduled time, FortiAnalyzer rolls the active log file by renaming the file.
The file name is in the form of x10g.N. 1og, where x is a letter indicating the log type, and N is a unique number
corresponding to the time the first log entry was received. For information about setting the maximum file size and log

rolling options, see Device logs on page 216.

Log Browse displays log files stored for both devices and the FortiAnalyzer itself, and you can log in the compressed
phase of the log workflow.

Ay

In Collector mode, if you want to view the latest log messages, select the latest log file to

display its log messages.

To view log files:

1.

Goto Log View > Log Browse

2. Select a log file, and click Display to open the log file and display the log messages in formatted view.
You can perform all the same actions as with the log message list. See Viewing message details on page 44.

Add Filter

;5] B All Devices ~ (D Last 5 Minutes ~

0OO0OO0ODO0OO0OOOOODODODO

Importing a log file

WoOm N e B W N e

=
[T

A Device Name

FG100D3G00000000
FG100D3G00000000
FG1K2D3100000000
FG1K2D3100000000
FG3K2D3Z00000000
FG3K2D3Z00000000
FG3K2D3Z00000000
FGZ00D3000000000
FG$00D3900000000
FGZ00D3000000000
FG$00D3900000000

Serial Number
FG100D3G00000000
FG100D3G00000000
FG1K2D3100000000
FG1K2D3100000000
FG3K2D3Z00000000
FG3K2D3Z00000000
FG3K2D3Z00000000
FG?00D3900000000
FG?00D3900000000
FG?00D3900000000
FG?00D3900000000

VDOM
root
root
root
root
root
root
root
root
root
root

root

Type

Event
Traffic
Event
Traffic
Event
Event
Traffic
VolP

Event
Traffic

Event

File Name

eloglog
tlog.log
eloglog
tlog.log
eloglog
eloglog
tlog.log
plog.log
elog.log
tlog.log
elog.log

M Display i Delete & Download ] Import

From

2018-05-3002:0...
2018-05-30 02:0...
2018-05-30 02:0...
2018-05-30 13:0...
2018-05-30 02:0...
2018-05-30 02:0...
2018-05-30 13:0...
2018-05-3002:0...
2018-05-3002:0...
2018-05-3002:0...
2018-05-3002:0...

To

2018-05-30 13:0...
2018-05-30 13:1...
2018-05-30 13:0...
2018-05-30 13:1...
2018-05-30 13:0...
2018-05-30 13:0...
2018-05-30 13:1...
2018-05-30 13:0...
2018-05-30 13:0...
2018-05-30 13:0...
2018-05-30 13:0...

Size(bytes)
134,358
3,924,969
52,663
71,916,545
8,696
346,536
782,844
9,869
76,955
3,230,023
2,638

~

Imported log files can be useful when restoring data or loading log data for temporary use. For example, if you have
older log files from a device, you can import these logs to the FortiAnalyzer unit so that you can generate reports

containing older data.

Log files can also be imported into a different FortiAnalyzer unit. Before importing the log file you must add all devices
included in the log file to the importing FortiAnalyzer.
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To insert imported logs into the SQL database, the config system sgl start-time and rebuild-event-
start—-time must be older than the date of the logs that are imported and the storage policy for analytic data (the
Keep Logs for Analytics field) must also extend back far enough.

To set the SQL start time and rebuild event start time using CLI commands:

config system sqgl

set start-time <start-time-and-date>

set rebuild-event-start-time <start-time-and-date>
end

Where <start-time-and-date>isinthe format hh:mm yyyy/mm/dd.

To import a log file:

If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Log View > Log Browse and click Import in the toolbar.

3. Inthe Device dropdown list, select the device the imported log file belongs to or select [Take From Imported File]
to read the device ID from the log file.

If you select [Take From Imported File], the log file must contain a device id field in its log messages.

4. Drag and drop the log file onto the dialog box, or click Add Files and locate the file to be imported on your local
computer.

5. Click OK. A message appears, stating that the upload is beginning, but will be canceled if you leave the page.

6. Click OK. The upload time varies depending on the size of the file and the speed of the connection.
After the log file is successfully uploaded, FortiAnalyzer inspects the file:

o Ifthedevice idfieldinthe uploaded log file does not match the device, the import fails. Click Return to try
again.

« If you selected [Take From Imported File] and the FortiAnalyzer unit’s device list does not currently contain
that device, an error is displayed stating Invalid Device ID.

Downloading a log file

You can download a log file to save it as a backup or to use outside the FortiAnalyzer unit. The download consists of
either the entire log file, or a partial log file, as selected by your current log view filter settings and, if downloading a raw
file, the time span specified.

To download a log file:

1. Goto Log View > Log Browse and select the log file that you want to download.
2. Inthe toolbar, click Download.
3. Inthe Download Log File(s) dialog box, configure download options:
« Inthe Log file format dropdown list, select Native, Text, or CSV.
« If you want to compress the downloaded file, select Compress with gzip.
4. Click Download.
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Deleting log files

To delete log files:

1. Goto Log View > Log Browse.
2. Select one or more files and click Delete.
3. Click OK to confirm.

Log and file storage

Logs and files are stored on the FortiAnalyzer hard disks. Logs are also temporarily stored in the SQL database.

When ADOMs are enabled, settings can be specified for each ADOM that apply only to the devices in it. When ADOMs
are disabled, the settings apply to all managed devices.

Data policy and disk utilization settings for devices are collectively called log storage settings. Global log and file storage
settings apply to all logs and files, regardless of log storage settings (see File Management on page 220). Both the
global and log storage settings are always active.

NP The log rate and log volume per ADOM can be viewed through the CLI using the following

‘q’ commands:
diagnose fortilogd lograte-adom <name>

diagnose fortilogd logvol-adom <name>

Disk space allocation

On the FortiAnalyzer, the system reserves 5% to 20% of the disk space for system usage and unexpected quota
overflow. The remaining 80% to 95% of the disk space is available for allocation to devices.

Reports are stored in the reserved space.

Total Available Disk Size Reserved Disk Quota
Small Disk (up to 500GB) The system reserves either 20% or 50GB of disk space, whichever is smaller.
Medium Disk (up to 1TB) The system reserves either 15% or 100GB of disk space, whichever is smaller.
Large Disk (up to 3TB) The system reserves either 10% or 200GB of disk space, whichever is smaller.
Very Large Disk (5TB and The system reserves either 5% or 300GB of disk space, whichever is smaller.
higher)
N ! /, The RAID level you select determines the disk size and the reserved disk quota level. For
9 example, a FortiAnalyzer 1000C with four 1TB disks configured in RAID 10 is considered a
- large disk, so 10%, or 100GB, of disk space is reserved.
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Log and file workflow

When devices send logs to a FortiAnalyzer unit, the logs enter the following workflow automatically:

1. Compressed logs are received and saved in a log file on the FortiAnalyzer disks.
When a log file reaches a specified size, FortiAnalyzer rolls it over and archives it, and creates a new log file to
receive incoming logs. You can specify the size at which the log file rolls over. See Device logs on page 216.
2. Logs are indexed in the SQL database to support analysis.
You can specify how long to keep logs indexed using a data policy. See Log storage information on page 57.
3. Logs are purged from the SQL database, but remain compressed in a log file on the FortiAnalyzer disks.
4. Logs are deleted from the FortiAnalyzer disks.
You can specify how long to keep logs using a data policy. See Log storage information on page 57.

FortiAnalyzer
- ™
Logs
compressed
and savedto '
log file .~ N

Logs indexed
in database

Log file rolls
over and
archived

Logs purged
from database

|

Logs deleted

R
-

- e e = = = = = = = = = = = = = = = = = = = = = = = = = e = e -

N - — - -—

- J

In the indexed phase, logs are indexed in the SQL database for a specified length of time so they can be used for
analysis. Indexed, or Analytics, logs are considered online, and details about them can be used viewed in the SOC, Log
View, and Incidents & Events panes. You can also generate reports about the logs in the Reports pane.

In the compressed phase, logs are compressed and archived in FortiAnalyzer disks for a specified length of time for the
purpose of retention. Compressed, or Archived, logs are considered offline, and their details cannot be immediately
viewed or used to generate reports.
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The following table summarizes the differences between indexed and compressed log phases:

Log Phase Location Immediate Analytic Support

Indexed Compressed in log file and Yes. Logs are available for analytic use in SOC,
indexed in SQL database Incidents & Events, and Reports.

Compressed Compressed in log file No.

Automatic deletion

Logs and files are automatically deleted from the FortiAnalyzer unit according to the following settings:

« Global automatic file deletion
File management settings specify when to delete the oldest Archive logs, quarantined files, reports, and archived
files from disks, regardless of the log storage settings. For more information, see File Management on page 220.
« Data policy
Data policies specify how long to store Analytics and Archive logs for each device. When the specified length of
time expires, Archive logs for the device are automatically deleted from the FortiAnalyzer device's disks.
« Disk utilization
Disk utilization settings delete the oldest Archive logs for each device when the allotted disk space is filled. The
allotted disk space is defined by the log storage settings. Alerts warn you when the disk space usage reaches a
configured percentage.

All deletion policies are active on the FortiAnalyzer unit at all times, and you should carefully configure each policy. For
example, if the disk fullness policy for a device hits its threshold before the global automatic file deletion policy for the
FortiAnalyzer unit, Archive logs for the affected device are automatically deleted. Conversely, if the global automatic file
deletion policy hits its threshold first, the oldest Archive logs on the FortiAnalyzer unit are automatically deleted
regardless of the log storage settings associated with the device.

The following table summarizes the automatic deletion polices:

Policy Scope Trigger

Global automatic file  All logs, files, and When the specified length of time expires, old files are automatically

deletion reports on the deleted. This policy applies to all files in the system regardless of the
system data policy settings associated with devices.

Data policy Logs for the device When the specified length of retention time expires, old Archive logs

with which the data for the device are deleted. This policy affects only Archive logs for the
policy is associated device with which the data policy is associated.

Disk utilization Logs for the device When the specified threshold is reached for the allotted amount of
with which the log disk space for the device, the oldest Archive logs are deleted for the
storage settings are device. This policy affects only Archive logs for the device with which
associated the log storage settings are associated.

Logs for deleted devices

When you delete one or more devices from FortiAnalyzer, the raw log files and archive packets are deleted, and the
action is recorded in the local event log. However, the logs that have been inserted into the SQL database are not
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deleted from the SQL database. As a result, logs for the deleted devices might display in the Log View and
SOC > FortiView panes, and any reports based on the logs might include results.

The following are ways you can remove logs from the SQL database for deleted devices.

« Rebuild the SQL database for the ADOM to which deleted devices belonged or rebuild the entire SQL database.

« Configure the log storage policy. When the deleted device logs are older than the Keep Logs for Analytics setting,
they are deleted. Also, when analytic logs exceed their disk quota, the SQL database is trimmed starting with the
oldest database tables. For more information, see Configuring log storage policy on page 59.

« Configure global automatic file deletion settings in System Settings > Advanced > File Management. When the
deleted device logs are older than the configured setting, they are deleted. For more information, see File

Management on page 220.

Ay

File Management configures global settings that override other log storage settings and
apply to all ADOMs.

Log storage information

To view log storage information and to configure log storage policies, go to System Settings > Storage Info.

If ADOMSs are enabled, you can view and configure the data policies and disk usage for each ADOM.

The log storage policy affects only the logs and SQL database of the devices associated with the log storage policy.
Reports are not affected. See Disk space allocation on page 54.

[# Edit & Refresh Q.

Name Analytics (Actual/Config Days)  Archive (Actual/Config Days)  Max Storage  Analytics Usage (Used/Max)  Archive Usage (Used/Max)
“wFortiGates (2)

FortiCarrier 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
root 0/60 2/365 | 50GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
wOther Device Types (10)

FortiAnalyzer 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiAuthenticator | 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiCache 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiClient 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiDDoS 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiMail 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiManager 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
FortiSandbox 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)
FortiWeb 0/60 0/365 50 GB 0 MB/35 GB (0%) 0MB/15 GB (0%)
Syslog 0/60 0/365 50GB 0 MB/35 GB (0%) 0MB/15GB (0%)

The following information and options are available:

Edit
Refresh
Search

Name

Analytics
(Actual/Config Days)

Edit the selected ADOM's log storage policy.
Refresh the page.
Enter a search term to search the list.

The name of the ADOM.
ADOMs are listed in two groups: FortiGates and Other Device Types.

The age, in days, of the oldest Analytics logs (Actual Days), and the number of days
Analytics logs will be kept according to the data policy (Config Days).
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Archive

The age, in days, of the oldest Archive logs (Actual Days) and the number of days
(Actual/Config Days)

Archive logs will be kept according to the data policy (Config Days).

Max Storage The maximum disk space allotted to the ADOM (for both Analytics and Archive logs).

See Disk space allocation on page 54 for more information.

Analytics Usage How much disk space Analytics logs have used, and the maximum disk space allotted

(Used/Max) for them.

Archive Usage
(Used/Max)

How much disk space Archive logs have
them.

Storage information

used and the maximum disk space allotted for

To view log storage policy and statistics, go to System Settings > Storage Info.

The top part of Storage Info shows visualizations of disk space usage for Analytic and Archive logs where the policy
diagrams show an overview and the graphs show disk space usage details. The bottom part shows the log storage

policy.

Analytics Policy Analytics Details

86%

Keep Logs for 15 Days

Show Up to Today ~ Max Line:[]

B T A A A
\/ v—\\ A \ //\/\ LA
\ \ \ / \ \ [
\ /A JARRY: \ /o
v/ \ v \/f
\/ V

A/
/ \

/ \

T T T T T
Actual Logs for 7 Days 1 2 2 i
— Actual

Archive Policy Archive Details

840000

Show All Configured Days ~ Max Line:[7]

Mex. Quots - 629146MB

Quota Used 2

Keep Logs for 60 Days

Actual Logs for 35 Days

— Actual — Max - - Trend

The policy diagram shows the percentage of the disk space quota that is used. Hover your cursor over the diagram to
view the used, free, and total allotted disk space. The configured length of time that logs are stored is also shown.

The graphs show the amount disk space used over time. Click Max Line to show a line on the graph for the total space
allotted. Hover over a spot in the graph to view the used and available disk space at that specific date and time. Click

the graph to view a breakdown of the disk space usage by device.

Device Name Analytics Usage Average Log Rate (logs/sec) Peak Log Rate (logs/sec)
FGT37D0000000000 743.1 GB 1087.14 1615.27
FG800C0000000000 221.4MB 4.24 35.58

Weixixixi_WiFi 3.1GB 448 32.80
FG3K2D0000000000 51.3GB 77.29 781.74
FG1K2D0000000000 716.4 GB 1048.14 2376.82
FG100D0000000000 423.8GB 619.99 1726.02

38.35%
0.01%
0.16%
2.65%
36.97%
21.87%
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When the used quota approaches 100 percent, a warning message displays when accessing the Storage Statistics
pane.

Warning

Analytic is using 89% of allocated disk space.
Archive is using 88% of allocated disk space.

Please click "Configure Now" button to increase ADOM quota.

[ corue o

Click Configure Now to open the Edit Log Storage Policy dialog box where you can adjust log storage policies to
prevent running out of allocated space (see Configuring log storage policy on page 59), or click Remind Me Laterto
resolve the issue another time.

Configuring log storage policy

The log storage policy affects the logs and SQL database of the device associated with the log storage policy.

If you change log storage settings, the new date ranges affect Analytics and Archive logs
currently in the FortiAnalyzer device. Depending on the date change, Analytics logs might be

purged from the database, Archive logs might be added back to the database, and Archive
logs outside the date range might be deleted.

To configure log storage settings:

1. Goto System Settings > Storage Info.

2. Double-click on an ADOM, right-click on an ADOM and then select Edit from the menu, or select the ADOM then
click Edit in the toolbar. Scroll to the log storage policy sections at the bottom of the Edit Log Storage Policy pane.

Edit Log Storage Policy - ADOM : root

Data Policy

Keep Logs for Analytics 365 = Days
Keep Logs for Archive 365 = Days
Disk Utilization
Maximum Allowed 50 = GB v Out of Available: 50.0 GB
Analytics : Archive 0% v 40% Modify

Alert and Delete When Usage Reaches | 100%

*If analytic or archive log usages exceed the configured disk quota before the retention period expires, the cldest logs will be deleted.

e

3. Configure the following settings, then click OK.

Data Policy
Keep Logs for Specify how long to keep Analytics logs.
Analytics
Keep Logs for Specify how long to keep Archive logs.
Archive Make sure your setting meets your organization’s regulatory requirements.
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Disk Utilization

Maximum Allowed

Analytics :
Archive

Alert and Delete
When Usage
Reaches

FortiAnalyzer 6.2.3 Administration Guide
Fortinet Technologies Inc.

Specify the amount of disk space allotted. See also Disk space allocation on
page 54.

Specify the disk space ratio between Analytics and Archive logs. Analytics logs
require more space than Archive logs. Click the Modify checkbox to change
the setting.

Specify the percentage of allotted disk space usage that will trigger an alert
messages and start automatically deleting logs. The oldest Archive log files or
Analytics database tables are deleted first.
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Use Incidents & Events to generate, monitor, and manage alerts and events from logs. The live monitoring of security
events is a powerful and enabling feature for security operations. Incidents can be created from events to track and
respond to suspicious or malicious activities.

Incidents & Events displays all events generated by event handlers.

Event handlers

Event handlers determine what events are to be generated from logs. Enable an event handler to start generating
events. To see which event handlers are enabled or disabled, see Enabling event handlers.

When ADOMs are enabled, each ADOM has its own event handlers and lists of events. Ensure you are in the correct
ADOM when working in Incidents & Events.

You can use predefined event handlers to generate events. There are predefined event handlers for FortiGate,
FortiSandbox, FortiMail, and FortiWeb devices. In a Security Fabric ADOM, all predefined event handlers are displayed.

You can create custom event handlers. An easy way to create a custom event handler is to clone a predefined event
handler and customize its settings. See Cloning event handlers.

Configure event handlers to generate events for all devices, a specific device, or for the local FortiAnalyzer unit. You can
create event handlers for FortiGate, FortiCarrier, FortiCache, FortiMail, FortiManager, FortiWeb, FortiSandbox
devices, and syslog servers. Incidents & Events supports local FortiAnalyzer event logs.

To see event handlers, go to Incidents & Events > Event Monitor > Event Handler List.

Event handlers generate events only from Analytics logs and not Archive logs. For more information, see Analytics and
Archive logs.

In an Analyzer—Collector collaboration scenario, the Analyzer evaluates event handlers. For more information, see
Analyzer—Collector collaboration.

You can also import and export event handlers, allowing you to develop custom event handlers and deploy them in bulk
to other ADOMS or FortiAnalyzer units. For more information, see Importing and exporting event handlers.

Predefined event handlers

FortiAnalyzer includes many predefined event handlers that you can use to generate events. You can easily create a
custom event handler by cloning a predefined event handler and customizing its settings. See Cloning event handlers

on page 69.
\‘ ! ’I
q In 6.2.0 and up, predefined event handlers have been consolidated and have multiple filters
- that can be enabled or disabled individually.
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The following are a small sample of FortiAnalyzer predefined event handlers. To see all predefined event handlers, go

to Incidents & Events > Event Monitor > Event Handler List and select Show Predefined.

Event Handler Description

Default-Compromised Host- Disabled by default
Detection-by I0C-By-Threat Filter 1:

Event Severity: Critical
Log Type: Traffic Log
Group by: dstip

Log messages that match all of the following conditions:

« tdtype~infected
Tags: By _Endpoint, IP, C&C

Filter 2:

Event Severity: Critical
Log Type: Web Filter
Group by: Hostname URL

Log messages that match all of the following conditions:

« tdtype~infected
Tags: By _Endpoint, C&C, URL

Filter 3:

Event Severity: Critical
Log Type: DNS Log
Group by: QNAME

Log messages that match all of the following conditions:

« tdtype~infected
Tags: By_Endpoint, C&C, Domain

Default-Data-Leak-Detection- Disabled by deafult
By-Threat Filter 1:

Event Severity: Medium

Log Type: DLP

Group by: Filter Category, Source Endpoint
Tags: Signature, Leak

Filter 2:

Event Severity: Low

Log Type: DLP

Group by: Filter Category
Event Status: Mitigated
Tags: Signature, Leak

Default-Sandbox-Detections- Disabled by default

By-Endpoint
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Event Handler Description

Filter 1:
« Event Severity: Critical
o Log Type: AntiVirus
o Group by: Source Endpoint, Virus Name
« Log messages that match all of the following conditions:
o logid==0211009235 or logid==0211009237
o Tags: By Endpoint, Sandbox, Signature, Malware
Filter 2:
o Event Severity: Critical
e Log Type: AntiVirus
o Group by: Source Endpoint, Virus Name
« Log messages that match all of the following conditions:
o logid==0211009234 or logid==0211009236
« Tags: By Endpoint, Sandbox, Signature, Malware
Filter 3:
« Event Severity: Critical
o Log Type: AntiVirus
« Group by: Source Endpoint
« Log messages that match all of the following conditions:
o logid==0201009238 and fsaverdict==malicious
o Tags: By Endpoint, Sandbox, Malware

Local Device Event Available only in the Root ADOM.
Enabled by default
o Devices: Local Device
« Event Severity: Medium
o Log Type: Event Log
o Event Type: Any
« Group By: Device ID
o Log messages that match the following conditions:
« Level Equal To Emergency
o Tags: System, Local

FortiOS system events

FortiOS predefined system event handlers are consolidated into a single event handler with multiple filters called
Default FOS System Events.

Events are organized by device in the Incidents & Events dashboards, which can be expanded to view all related
events.

Default FOS System Event filters apply tags to each event, allowing you to identify which Deafult FOS System Event
filter triggered the event.
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handlers which are enabled or have been modified will be available as custom handlers. In the

\{ If you are upgrading from a version before FortiAnalyzer 6.2.0, the existing legacy predefined
I Event Handler List, select the More dropdown and choose Show Custom.

FortiGate event handlers

All FortiGates added to FortiAnalyzer use a default event handler on the FortiAnalyzer side to receive high severity
events such as Botnet Communication, IPS Attack Pass Through, and Virus Pass Through AntiVirus.

Events triggered from FortiGate Event Handler are not shown in the FortiAnalyzer GUI. The events are pushed to the
FortiGate for further processing.

Custom FortiGate event handlers can also be created. See Creating a custom event handler on page 64.

Creating a custom event handler

You can create a custom event handler from scratch or clone a predefined event handler and customize its settings. See
Cloning event handlers on page 69.

Configuring an event handler includes defining the following main sections:

Option Description

Event handler attributes Event handler attributes such as name, description, and devices.

Filters Filters are rules for event generation.
« Select the log filters to limit the logs that trigger an event.
« Group the logs by primary and secondary (optional) values to separate the
events that are generated for different Group By values.
o Set the number of occurrences within a time frame that triggers an event.
« Configure event fields such as event status and severity.

Additional Info Specify what to show in the Additional Info column. You can use the system
default information or configure a custom information message.

Notifications Configure notifications to be sent on event generation.

You can send alert notifications to a fabric connector, email address, SNMP
community, or syslog server.
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ADOM:root 3 @ >~ Q1

Incidents & Events
% Event Monitor ~ | Create New Handler
) All Events Status [ on |
12 By Endpoint 71 Name
@ By Threat | Description
B System Events ” | Devices @Al Devices Ospecify O Local Device

£= Event Handler List 0
EECTEEE . @asubness Ospeaty

3 Subnet List
& Incidents > Filters
&1 All Incidents

£ Incident Settings

15 FortiGate Event Handlers Fiver1 (G
Log Device Type FortiGate
Log Type Traffic Log
Log Subtype Antivirus
Group By Virus Name
Logs match OQAll @Any of the following conditions
Log Field Match Criteria Value
Level (pri) v | [ EqualTo +| [ Emergency

Generic Text Filter

30 minutes
Event Message @
Event Status (Blank)

D Allow FortiAnalyzer to choose

Event Severity Medium
Tags Add a value...
Additional Info

® Use system default

OUse custom message @

Notifications
[ send Alert through Fabric Connectors
Osend Alert Email

Osend SNMP(v1/v2) Trap

Osend SNMP(v3) Trap

[Osend Alert to Syslog Server

OSend Each Alert Separately

To create a new event handler:

Generate alert when at least| 1 matches occurred over a period of

1. Goto Incidents & Events > Event Monitor > Event Handler List.

2. Inthe toolbar, click Create New.

3. Configure the settings as required and click OK.

Field Description

Status Enable or disable the event handler.

Enabled event handlers have a Status of ON and show the ° icon in the
Event Handler List. Disabled event handlers have a a Status of OFF and

show the @ icon in the Event Handler List.

Name Add a name for the handler.

Description Type a description of the event handler.
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Field Description

Devices

Subnets

Filters

Log Device Type

Log Type

Log Subtype

Group By

Logs match

Log Field

Match Criteria

Value

Add
Remove

Generic Text Filter
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Select the devices to include.
« All Devices.
« Specify: To add devices, click the Add icon.

« Local Device: Select if the event handler is for local FortiAnalyzer event
logs. This option is only available in the root ADOM and is used to query
FortiAnalyzer event logs.

For Local Device, the Log Type must be Event Log and Log Subtype
must be Any.

Select All Subnets to include all subnets, or select Specify to choose which
subnet(s) or subnet group(s) will be included or excluded from triggering
events.

Configure one or more filters for the handler. You can add multiple filters each
with its own set of filter settings. You can enable or disable specific filters in
an event handler.

If you are in a Security Fabric ADOM, select the log device type from the
dropdown list. If you are not in a Security Fabric ADOM, you cannot change
the Log Device Type.

Select the log type from the dropdown list.

When Devices is set to Local Device, you cannot change the Log Type or
Log Subtype.

Select the category of event that this handler monitors. The available options
depends on the platform type.

This option is only available when Log Type is set to Event Log or Traffic Log.
Select how to group the events. Some Group By selections allow a secondary

Group By option. If available, click Add beside the Group By field to add a
secondary Group By option.

Select All or Any of the following conditions.

Select a log field to filter from the dropdown list. The available options
depends on the selected log type.

Select a match criteria from the dropdown list. The available options depends
on the selected log field.

Either select a value from the dropdown list or enter a value in the text box.
The available options depends on the selected log field.

Add Log Field to the filter.
Delete the filter.

Enter a generic text filter.

For information on text format, hover the cursor over the help icon. The
operator ~ means contains and ! ~ means does not contain.
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Field Description

For more information on creating a generic text filter, see Using the Generic
Text Filter in an event handler on page 68.

Generate alert Enter threshold values to generate alerts. Enter the number of matching
when at least n events that must occur in the number of minutes to generate an alert.
matches occurred

over a period of n

minutes

Event Message If you wish, enter a custom event message. The default message is the
Group By value. You can use variables in the event message.

Event Status Select Allow FortiAnalyzer to choose or select a status from the dropdown
list: Unhandled, Mitigated, Contained, or Blank.

Event Severity Select the severity from the dropdown list: Critical, High, Medium, or Low.

Tags If you wish, enter custom tags. Tags can be used as a filter when using
default or custom views.

Additional Info Specify what to show in the Additional Info column. You can use the system

default information or configure a custom information message.

Use system Select to use the system default message in the Additional Info column.

default

Use custom Type a custom message for the Additional Info column. A custom message

message can include variables and log field names. For more information, click the
question mark icon.

Notifications Configure alerts for the handler.

Send Alert Send an alert through one or more fabric connectors. Click the + button to add

through Fabric fabric connectors. For more information, see Fabric Connectors on page 32.

Connectors

Send Alert Email Send an alert by email. Specify email parameters including the mail server.
For more information, see Mail Server on page 212.

Send SNMP(...) Select one or both checkboxes and specify an SNMP community or user from

Trap the dropdown list. Click the add icon to create a new SNMP community or
user. For more information, see SNMP on page 203.

Send Alert to Send an alert to the syslog server. Select a syslog server from the dropdown

Syslog Server list. Click the add icon to create a new syslog server. For more information,
see Syslog Server on page 214.

Send Each Alert Select to send each alert individually instead of in a group.

Separately The maximum number of alerts that can be sent for the same event is 50.
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Using the Generic Text Filter in an event handler

The Generic Text Filter uses the glibc regex library for values with operators (~,!~), using the POSIX standard. Filter
string syntax is parsed by FortiAnalyzer, and both upper and lower case characters are supported (for example "and" is
the same as "AND"). You must use an escape character when needed. For example, cfgpath=firewall.policy
is the wrong syntax because it's missing an escape character. The correct syntaxis cfgpath=firewall\.policy.

To create an event handler using the Generic Text Filter to match raw log data:

1. Goto Log View, and select a log type.
2. Inthe toolbar, click Tools > Display Raw.

The easiest method is to copy the text string you want from the raw log and paste it into the Generic Text Filter
field. Ensure you insert an escape character when necessary, for example, cfgpath=firewall\.policy.

3. Locate and copy the text in the raw log.
4. Goto Incidents & Events > Event Monitor > Event Handler List and click Create New.

5. Inthe Generic Text Filter box, paste the text you copied or type the text you want. Ensure you use the raw log field
names, for example, mem (not memory) and setuprate (not setup-rate).
For information on text format and operators, hover the cursor over the help icon. The operator ~ means contains
and ! ~ means does not contain.

6. If you want to be notified of events, configure the Notifications section.

7. Configure other settings as required and click OK. For a description of the fields, see Creating a custom event
handler on page 64.

Managing event handlers

To manage event handlers, go to Incidents & Events > Event Monitor > Event Handler List.

FortiAnalyzer includes predefined event handlers that you can use to generate events.

This page lists both predefined and custom event handlers with a O icon for enabled event handlers and a @ icon for
disabled event handlers.

The following options are available:

Option Description

Create New Create a new event handler.

Edit Edit the selected event handler.

Some fields in predefined event handlers cannot be modified, such as the name,
description and filter settings. However, you can clone a predefined event handler
and customize its settings. See Cloning event handlers on page 69.

Delete Delete the selected event handler. You cannot delete predefined event handlers.

Clone Clone the selected event handler. You can clone a predefined event handler and
modify it to create a customized event handler.

Enable / Disable Enable or disable the selected event handler to start or stop generating events on
the Incidents & Events > Event Monitor > All Events page.
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Option Description

Collapse All / Expand All Collapse or expand the Filters column.

Show Predefined Show or hide predefined handlers in the list.

Show Custom Show or hide custom handlers in the list.

Import / Export Export the selected event handlers or import an event handler you have exported.

You can export one or more predefined or custom event handlers and import
them into another ADOM or FortiAnalyzer.

Factory Reset If you have modified a predefined event handler, return the selected predefined
event handler to its factory default settings.

Enabling event handlers

For both predefined and custom event handlers, you must enable the event handler to generate events. The Event

Handler List page displays a O icon besides enabled event handlers and a @ icon besides disabled event handlers.
If you want to receive alerts for predefined events handlers, edit the predefined event handler to configure notifications.
To enable event handlers:

1. Goto Incidents & Events > Event Monitor > Event Handler List.
2. Select one or more event handlers and click More > Enable or right-click an event handler and select Enable.

Cloning event handlers

Most predefined event handler attributes cannot be modified, such as the name, description and filter settings. You can
clone a predefined event handler and customize its settings, and give it a meaningful name that shows its function.

To clone a predefined event handler:

1. Select a predefined event handler and in the toolbar, click Clone or right-click a predefined event handler and select
Clone.

2. Configure the settings as required and click OK. For a description of the fields, see Creating a custom event
handler on page 64.

3. Click OK to clone the predefined event handler.

Resetting event handlers to factory defaults

You can change predefined event handlers as needed. If required, you can restore predefined event handlers to factory
default settings. The Factory Reset option is only available for predefined event handlers that have been changed.
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To reset predefined event handlers:

1. Goto Incidents & Events > Event Monitor > Event Handler List.
2. Inthe More menu, ensure Show Predefined is selected.

3. Right-click an event handler and select Factory Reset or select one or more predefined event handlers and click
More > Factory Reset.

Importing and exporting event handlers

You can import and export event handlers. This feature allows you to develop custom event handlers and deploy them
in bulk to other ADOMs or FortiAnalyzer units. Simply export the custom event handlers, then import them into the
ADOMs or units where you want them deployed. You can also export event handlers as part of your backup procedure.

To export event handlers:

1. GotoIncidents & Events and select Event Monitor > Event Handler List.
2. Select the event handler or handlers that you are exporting, then right click on one and click Export.

£25 Incidents & Events v ADOM:root 2 @ >- Q1 (§)adminy

Filters Devices Send Alert to Events

G5 Event Monitor
3 All Events

28 By Endpoint > @ D -Detec i > 9 Filters Al Devices

= Event Handler List
= Subnet List

® By Threat > @  Default-Sandbox-Detections-By-Endpoint > 3 Filters All Devices
B System Events. %] Default-Compromised Host-Detection-IOC-By-Endpoint > 3Filters All Devices
@ Default-Risky-Destination-Detection-By-Endpoint > 7 Filters All Devices

Default-Suspicious-File-Detection-By-Endpoint

> 7 Filters

Default-Malicious-Code-Detection-By-Endpoint > 8 Filters All Devices
& Incidents ~
Defauit-Malicious-File-Detection-By-Endpoint > 24 Filters All Devices
& Allncidents
> 4 Filters All Devices
5 Incident Settings
Defauit-Malicious-File-Detection-By-Threat > 8 Filters All Devices
= FortiGate Event Handl
ernieate bvent Handlers Default-Risky-App-Detection-By-Threat > 2 Filters All Devices
Default-Rg cion-By-Threat > 9 Filters

o]

o]

o]

o

o]

a

o o

o o

O @  Default-Risky-App-Detection-By-Endpoint
o o

o o

a T,

[e) + Create New
o

o]

o

)

@  Defaultt ‘By-Threat > 8Filters Al Devices
@  Default-$ reat > 10Filters All Devices
@  Default-f hreat > 2 Filters All Devices
@  Default( fon-10C-By-Threat > 3 Filters Al Devices
@ Enable ptection-By-Threat > 9 Filters All Devices
O @ Defaultf > 8 Filters Al Devices
O © |LocalDe > 1 Filter Local Device
2 Import
[ Export
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3. Save the exported JSON file to your management computer.

4+ Create New [# Edit 79 Delete * e ~ QI
O Name Filters Devices Send Alertto  Events *
O & IPS - Critical Severity Severity Equal To Critical All Devices 8
0O @ Antivirus Event - 3 2 Rules All Devices
O & Web Filter Event Opening App Ctrl Event and 2 morejson X All Devices
App Ctrl Event ‘You have chosen to open: All Devices i i
0 @ UTM Antivirus Event [ App Ctrl Event and 2 more.json All Devices 10
O @ UTM Web Filter Event ol ST (O All Devices 24

from: blob:
0O & UTM App Ctrl Event All Devices 5
What should Firefox do with this file?
O @ UTM DLP Event All Devices.
(O Open with | Notepad++ : a free (GNU) source code editor... v
O @ IPsec Phase2 Down All Devices
@ SaveFile
O @ IPsec Phase2 Up All Devices
Do this automatically for files like this from now on. .

Interface Up ¢ All Devices
O @ Interface Down All Devices
O @ Conserve Mode es entered conserve mode All Devices
0O @ Power Supply Failure > 2 Rules All Devices
O @ HA Failover > 2 Rules All Devices
IPS - High Severity  Severity Equal To High . All Devices
O @ IPS - Medium Severity Severity Equal To Medium All Devices
O @ IPS - Low Severity Severity Equal To Low All Devices
L B o - i i . oA EYTIE N v

To import event handlers:

1. Goto Incidents & Events and select Event Monitor > Event Handler List.

2. Right click in the event handler list and click Import.
The Import Event Handler dialog box opens.

Import Event Handlers

Upload file by drag & drop here or‘

3. Drag the event handler JSON file onto the import dialog box, or click Browse to locate the file on the management
computer.
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Import Event Handlers

Upload file by drag & drop here orD

App Ctrl Event and 2 more.json

B T

4. Click OK to import the event handler or handlers.

L SRCCCCINVlE  Import successful.

RO AE ] ! admin ~

0O Name Filters Devices SendAlertto  Events *
O @ aaaTEST Level Equal To Emergency All Devices
O @ IPS - Critical Severity Severity Equal To Critical All Devices
O @ UTM Antivirus Event » 2 Rules All Devices
O & UTM Web Filter Event > 12 Rules All Devices
O @ UTM App Ctrl Event » 2 Rules All Devices
0O @UTM DLP Event Action Equal To block All Devices
O @ IPsec Phase2 Down Action Equal To phase2-down All Devices
O @ IPsec Phase2 Up Action Equal To phaseZ-up All Devices
O @ Interface Up » 2 Rules All Devices
O @ Interface Down » 2 Rules All Devices
O @ Conserve Mode Log Description Equal To System services entered conserve mode All Devices
O @ Power Supply Failure » 2 Rules All Devices
O @ HA Failover 3 2 Rules All Devices
O @ IPS - High Severity Severity Equal To High All Devices
O @ IPS - Medium Severity Severity Equal To Medium All Devices
O @IPS - Low Severity Severity Equal To Low All Devices
O @ Application Crashed Event % 2 Rules All Devices
0O @ Malware Traffic Allowed by Antivirus » 2 Rules All Devices
[l @ Mahaara Traffie Rlackod by Antuine % 7 Rulee Al Nevirae e
S ! ’, If the imported event handler's name already exists, the Unix epoch timestamp will be
9 automatically appended to the imported handler's name, for example: App Ctrl
- Event‘1544644459276775. The name can be edited as required after importing.
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If the imported file is the wrong format or has an error, the system will report an error.

Import Event Handlers

\‘ ! ’I
Upload file by drag & drop here or
App Ctrl Event and 2 more.json
-
-

nvalid params: deny to [add] objects as protected

Events

After event handlers start generating events, view events and event details in Incidents & Events > Event Monitor.

A\,

~ g o When rebuilding the SQL database, you might not see a complete list of historical events.
q However, you can always see events in real-time logs. You can view the status of the SQL
- rebuild by checking the Rebuilding DB status in the Notification Center.
All Events

To view all the events, go to Incidents & Events > Event Monitor > All Events.
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Double-click an event line to drill down for more details.

Hover your mouse over an entry to view the asset and identity information for that event.

Z73 Incidents & Events v ADOM:root 3 @ >- Q1 (@) admin v
% B~

£ Event Monitor M B AlDevices~ @last7Days..~ "Expand Al [ Show Acknowledged % Refresh ~ &

& All Events

Add Filter

18 By Endpoint > 0 #  Event Event Statu: & Event Type Count Severity  First Occurrence Last Update Additional Info
® By Threat > 1 >200.4842244(2)  Unhandled . 64 | High | .
= 5ystem Events o2 eswosnen = - o1 Hgh') 2 days ag0 2 days ago -
£ Event Handler List o e $104.220.198.212(2) - Gl High 2days ago 2 days ago -
= Subnet List o4 > 191.8.26.111(2) - 62 High | 2 daysago 2 days ago -
& Incigents .las » 121.174.141.100(2) [Unhandied | 62 High | Adayago Aday ago .
1Al Incidents O 6  >11576247.243(2) [unhandied | &3 High | Adayago Aday ago -
o ? 3 5.190.228.167(2) [Unhandied I8 61 High | Adayago Adayago -
5 Incident Settings
o8 > 162.39.218.229(2) [Unhandied I 62 High | Adayago Aday ago -
#8 FortiGate Event Handlers O e > 116.99.48.140(2) - & High AT e B
0O 10 >46.143.247.33(2) - 61 High | Adayago Aday ago -
0O 1 >190.114.233134(2) [Unhandied | 61 High | Adayago Aday ago .
0 12 >45124.169.86(2) [unhandied | 62 High | Adayago Aday ago -
0O 13 ) 9648.99.58(2) [Unhandied I8 57 High | Adayago Adayago -
0O 14 >22486184(2) - 63 High | Adayago Aday ago -
0O 15 >123.115.226.148(2) - 273 High | Adayago Aday ago -
0O 16  >91.14029232(2) - 62 High | Adayago Aday ago -
0O 17 >27.72224177(2) [unhandied I 60 High | Adayago Aday ago .
0 18 >159.192.241.180(2) [unhandied | &3 High | Adayago Aday ago - .
< >
Devices To view events for specific devices, click the devices dropdown and select a
device.
Time Period To change the time period to display, click the time icon and specify a time

period. Select Custom to specify a time period not in the dropdown list.
Collapse All/Expand All To view event summaries or details, click Collapse All or Expand All.

Show Acknowledged To include acknowledged events, click Show Acknowledged. See
Acknowledging events on page 77.

Refresh To manually refresh the events data, click Refresh.

You can specify a refresh interval of Every 10 Seconds, Every 30 Seconds,
Every 1 Minute, or Every 5 Minutes.

Export to CSV Download the events to a CSV file.
Custom View Save the current view including filter settings, device selection, and time period.
Column Settings Select which columns are displayed in the All Events pane. Columns not

displayed by default include Acknowledged, Comment, Device ID, Device
Name, Device Type, Event ID, Handler Description, Last Occurrence, Tags,
and VDOM Name.

Default event views

FortiAnalyzer event handlers apply one or more tags to events, allowing the events to be grouped into views in the
Event Monitor. These views are visible in the left navigation tree.

Default views are organized into three view categories, including:
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« By Endpoint: Provides security event views from an endpoint perspective.

o By Threat: Provides security event views from a threat perspective.

« System Events: Provides event views which cover device system events.

In order for events to be displayed in default views, the corresponding event handler(s) must be enabled. Refer to the
chart below for a list of the predefined event handlers that must be enabled to support each default view:

View category

By Endpoint

By Threat

System Events

Default view
All Security Events

Compromised Hosts

High Risk App Usage
Malicious Domain/URL Access

Malware Activity

Ongoing Intrusions
Sandbox Detections
All Security Events
C&C Call Backs

High Risk App Usage
Malicious Domain/URL Access

Malware Activity

Ongoing Intrusions
Sandbox Detections
All

FortiGate

Local Device

Required predefined event handler
Displays all events within category with enabled handlers

Default-Botnet-Communication-Detection-By-Endpoint
Default-Compromised Host-Detection-lOC-By-Endpoint

Default-Risky-App-Detection-By-Endpoint
Default-Risky-Destination-Detection-By-Endpoint

Default-Sandbox-Detections-By-Endpoint
Default-Malicious-File-Detection-By-Endpoint

Default-Malicious-Code-Detection-By-Endpoint
Default-Sandbox-Detections-By-Endpoint
Displays all events within category with enabled handlers

Default-Botnet-Communication-Detection-By-Threat
Default-Compromised Host-Detection-IOC-By-Threat

Default-Risky-App-Detection-By-Threat
Default-Risky-Destination-Detection-By-Threat

Default-Sandbox-Detections-By-Threat
Default-Malicious-File-Detection-By-Threat

Default-Malicious-Code-Detection-By-Threat
Default-Sandbox-Detections-By-Threat

Displays all events within category with enabled handlers
Default FOS System Events

Local Device Event

You can see the tags associated with each view by hovering your mouse over the view in Incidents & Events; a pop-up

is displayed.
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dents & ents DO DO @ A ad
C2 Event Monitor v All Device O La Da pand Al O Show Acknowledged
& All Events Add Filter @
28 By Endpoint v # Event Event Status Event Type Tags Severity
All Security Events 1 >101.0412(1) Unhandled IREREY LTS Default | By_Endpoint | Sandbox = Mal... [ETTI

£+ DNS Default | By_Endpoint | Risky = Domain Medium

Comp :gjjg:‘:‘:“‘H‘";‘ft;’g{:.fg;;”d“‘”“ end (teg="CAC" ortag="Sandbox’ ortag='Malware’ or tag='Intrusion’ or tag='Risky" and (tag='URL' or

High Risk App Usage 3 > ©§ VAN-200834-PC02(1) = Mitigated @ Web Filter Default | By_Endpoint | Risky = URL Medium

Malicious Domain/URL 4 > §172.17.250.79(6) Mitigated 4k Antivirus Default = Malware = To_WAN ' Downloa, Medium

Access 5 »74.120.223.19(6) Mitigated 3k Antivirus Default = Malware = To_WAN = Downloa. Medium

Malware Activity [ > §172.17.91.204(1) Mitigated ik Antivirus Default | Malware | To_WAN ' Downloa.. Medium
7 > 54.169.252.42(1) Mitigated ik Antivirus Default = Malware = To_WAN Downloa. Medium

Ongoing Intrusions

Default views can be hidden or disabled. For more information, see Managing default views.

Admins can copy existing views to create custom views. For more information, see Creating custom views.

Filtering events

You can filter events using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-sensitive
filter.

Filter FortiView summaries using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-
sensitive filter. You can also filter by specific devices or log groups and by time.

To filter events using filters in the toolbar:

« Specify filters in the Add Filter box.

« Regular Search: In the selected summary view, click Add Filter and select a filter from the dropdown list, then
type a value. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or
“or”.

o Advanced Search: Click the Switch to Advanced Searchicon « at the end of the Add Filter box. In Advanced
Search mode, enter the search criteria (log field names and values). Click the Switch to Regular Search icon
@ to go back to regular search.

To filter events using the right-click menu:

In the event list, right-click an entry and select a filter criterion (Search <filter value>).

Depending on the column in which your mouse is placed when you right-click, FortiView uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

To launch Search in Logview from an event:

In the event list, right-click an entry and select Search in Logview.
Log View will launch with the filter automatically filled in with the following information:

« Log type of the event
« Time range (the first to the last occurrence of the event)
« Event trigger and group by value

FortiAnalyzer 6.2.3 Administration Guide
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Viewing event details

In an event list, to view event details, double-click an event line to drill down for more details.

The event details page contains information about the event and a list of all individual logs. You can work on events
using buttons in the toolbar or by right-clicking an event.

« To change what columns to display, click Column Settings or Column Settings > More Columns.
« In event details, to view raw logs, click Tools > Display Raw.

« To switch back to formatted log view, click Tools > Formatted Log.

« Toreturn to the previous page, click the back button.

Acknowledging events

Acknowledging an event removes it from the event list. Click Show Acknowledged to view acknowledged events.

To acknowledge events:

« Inthe event list, select one or more events, then right-click and select Acknowledge.

Managing default views

Default views in the By Endpoint, By Threat, and System Events view categories can be hidden, disabled, or copied as a
custom view, allowing you to display only the views that are useful to the user.

To hide default views:

1. Goto Incidents & Events > Event Monitor.
2. Select an event category.
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3. Right-click on an event view and select Hide.

dents & e ADO 00 Q, A ad
L2 Event Monitor v l All Device O La Da pand Al [ Show Acknowledged b
& All Events Add Filter
28 By Endpoint > L # Event Event Status Event Type Count  Severity ¥ Last Update
‘® By Threat ~ No entry found.

All Security Events

C&C Call Backs

High Risk App Usage
Malicious Domain/URL Access
Malware Activity

Ongoing Intrusions

Sandbox Detectigs

& Hide
i System Events _
All
FortiGate
Local Device
= Event Handler List

& Subnet List

Incidents v

/172.17.93.248/p/app/2

https:/

To disable/enable default views:

1. Goto Incidents & Events.
2. Select the gearicon on the bottom of the navigation tree to access the Default Views setting.

3. Choose which views are displayed. Add a checkmark to enable the view; remove the check mark to disable the
view.
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4. Select Save.

Default Views

By Endpoint

B3 All Security Events

& Compromised Hosts
(JSandbox Detections

B3 Malware Activity

[JOngoing Intrusions

[ Malicious Dormain/URL Access
[ High Risk App Usage

By Threat

B3 All Security Events

4 CaC Call Backs

[JSandbox Detections

O Malware Activity

& Ongoing Intrusions

[ Malicious Domain/URL Access

MIUink Dicls A | laana

Creating custom views

To create a custom view:

Go to Incidents & Events.

Select an existing view to copy.

Select Add Filters to add any additional filters you want to include in the custom view.
Select the custom view icon on the top-right side of the toolbar.

Enter a name for the custom view and assign it to one of the following categories:

o By Endpoint

e By Threat

« System Events

ok Db
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« Custom View

Save as New Custom View

Name My-Malware

Category By Endpoint

By Endpoint
By Threat

System Events

Custom View "

6. Select OK to save the view.

Once the custom view is created, you can modify it further by removing or adding filters. Modifications can be
saved by selecting the custom view icon and choosing Save or Save As to save the changes as a new view.

Ay
‘9' When upgrading from versions prior to 6.2.0, existing custom views will be placed in the
| Custom Views category.

Understanding event statuses
In the Event Monitor dashboards, you can view the status of an event in the Event Status column. Event statuses
include Unhandled, Mitigated, Contained, and (blank).

Event statuses are applied by the associated event handler. When creating a custom event handler, you can manually
select an event status or choose to allow FortiAnalyzer to decide.

In general, when Allow FortiAnalyzer to choose is selected, the event status for UTM events is applied based on the

following:

Event status Description

Unhandled The security event risk is not mitigated or contained, so it is considered open.
Example: an IPS/AV log with action=pass will have the event status Unhandled.
Botnet and loC events are also considered Unhandled.

Contained The risk source is isolated.
Example: an AV log with action=quarantine will have the event status
Contained.

Mitigated The security risk is mitigated by being blocked or dropped.
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Event status Description

Example: an IPS/AV log with action=block/drop will have the event status
Mitigated.

(Blank) Other scenarios.

Subnet lists

In Incidents & Events, you can define subnet lists which can be added to subnet groups.

Subnet lists and groups can be used to create a whitelist or blacklist in event handlers.

« Creating a subnet list on page 81
+ Creating a subnet group on page 83
« Assigning subnet filters to event handlers on page 83

= = Incidents & Events + ADOM:root 2 @ >~ Q1 ‘ admin

L2 Event Monitor v + Create New ~ [# Edit % Clone W Delete
3 All Events
28 By Endpoint by ~ Subnet (13)
® By Threat ol |\ SEIPvé_Range_172_16_81_20_To_30 2000::172:16:81:20-2000:172:16:81:30
All Security Events &l =IPvé_Subnet 172 16 81 26@128 2000:172:16:81:26/128
CBC Call Backs & =IPvé_Subnet_172_16 81 26@64 2000:172:16:81:26/64
o (& =IPvé_Subnet 96 45 33 64@128 2000:96:45:33:64/128
High Risk App Usage
(Al EIPvé_Subnet_96_45_33_64@64 2000:96:45:33:64/64
Malicious Domain/URL Access
(&l ERange_172_16_81_20_To_30 172.16.81.20-172.16.81.30
Malware Activity
(] ERange_96_45_33_60_to_70 96.45.33.60-96.45.33.70
Ongoing Intrusions
going B SEsubnet_172_16_81_0@24 172.16.81.0/24
Sandbox Detections &l HSubnet_172_16_81_26@32 172.16.81.26/32
System Events I |\ HESubnet_172_243_0_0@16 172.243.00/16
i Event Handler List [&] ESubnet_172_243_138_194 172.243.138.194/32
Subnet List &l HElsubnet_96_45_33_0@24 96.45.33.0/24
& Incidents (] ESubnet_96_45_33_64@32 96.45.33.64/32

B All Incidents ~Subnet Group (2)

%% Incident Settngs | @  =epl  =IPv6_Range_ 172 _16 81 20 To_.
ZIPvé_Range_172_16_81_20_To_30.2IPvé_Subnet_172_16_81_26@128,

£2 FortiGate Event Handlers

\
‘9' Subnet filtering for event handlers is supported in FortiGate, FortiWeb, FortiMail, and Fabric
ADOMs.

Creating a subnet list

To create a new subnet:

1. Goto Incidents & Events > Subnet Lists.
2. Select Create New > Subnet.
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3. Enter a name for the subnet.

§25 Incidents & Events v ADOM:root [3 @ - 1 (@) admin v
CE Event Monitor ~ | New Subnet
€3 All Events Name @
48 By Endpoint ’ Type Subnet Notation =
® By Threa V| subnet Notation
All Security Events IP Range
C&C Call Backs Batch Add

High Risk App Usage
Malicious Domain/URL Access
Malware Activity
Ongoing Intrusions
Sandbox Detections
System Events >
£= Event Handler List
= Incidents ~
&1 All Incidents

% Incident Settings

4. Select a Subnet type and configure the corresponding information.
Subnet types include:

o Subnet Notation

e IP Range
e Batch Add
5. Select OK.

Once a subnet has been created, it can be edited, cloned, or deleted by highlighting it and selecting the
corresponding action in Subnet List toolbar.
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Creating a subnet group

To create a subnet group:

1. Goto Incidents & Events > Subnet List.
2. Select Create New > Subnet Group.

E:E Incidents & Events +

CZ Event Monitor + Create New ~ [# Edit

€3 All Events
22 By Endpoint
By Threat “| B SIPv6_Range_172_16_81_20_To_30 2000::172:16:81:20-2000::172:16:81:30
All Security Events & SIPv6_Subnet 172 16 81 26@128 2000:172:16:81:26/128
CAC Call Backs ] TIPv6_Subnet_172_16_81_26@64 2000:172:16:81:26/64
High Risk App Usage & TIPv6_Subnet_96_45_33_ 64@128 2000:96:45:33:64/128
B ] ] TIPv6_Subnet_96_45_33_64@64 2000:96:45:33:64/64
Malicious DG_W_EWURL fecess ] SRange_172_16_81 20_To_30 172.16.81.20-172.16.81.30
Malware Activity ] SRange_96_45_33_60_to_70 96.45.33.60-96.45.33.70
Ongoing Intrusions a] SSubnet_172_16_81 0@24 172.16.81.0/24
Sandbox Detections 5] Ssubnet 172 16 81 26@32 172.16.81.26/32
B System Events I |\ Ssubnet_172_243_0_0@16 172.243.0.0/16
£5 Event Handler List ] ESubnet_172_243_138_194 172.243.138.194/32
= Subnet List & SSubnet_96_45_33_0@24 96.45.33.0/24
& Incidents & SEsubnet_96_45_33_64@32 96.45.33.64/32
& All Incidents ~Subnet Group (2)
% Incident Settings ] Egrpl E|IPvé_Range_1?2_16_51_20_T0_30.EIPvé_Subnet_172_16_81_26@128
1= FortiGate Event Handlers =] Zerp2 EIPv6_Range 172 16 81 20 To 30.2IPv6 Subnet 172 16 81 26@128. [+

3. Enter a name for the subnet group.

4. Select the subnet entries to be included in the group and select OK in the pop-up window.

5. Select OK.

Once a subnet group has been created, it can be edited, cloned, or deleted by highlighting it and selecting the

corresponding action in Subnet List toolbar.

Assigning subnet filters to event handlers

You can streamline SOC processes by defining a subnet whitelist/blacklist for event handlers. These addresses can be
linked to any event handler to enable or prevent it from triggering an event. Creating a subnet whitelist/blacklist for

event handlers eliminates the need to specify common networks in every event handler.

To include or exclude subnets in an event handler:

1. Goto Incidents & Events > Event Handler List.
2. Select an event handler to edit from the list.
3. Inthe Subnet category, select Specify.
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4. Choose which subnets to include or exclude by selecting them from the corresponding dropdown menu.

Incidents & Events @01 (§adminy
L3 Event Monitor ~ | Edit Handler: 1
& All Events Status m
24 By Endpoint ) bl Name 1
@ By Threat e Description
Al Security Events Devices @ All Devices (O Specify (O Local Device
CAC CallBacks Subnets OAll Subnets @ Specify
High Risk App Usage Include Subnets [e)
Malicious Domain/URL Access ESubnet_172_16_81_0@24 -
Malware Activity 1 Entry Selected
Ongoing Intrusions g*;'“dtf 0 Select Entries (Total: 15) x
ubnets
Sandbox Detections SIRange_172_16 81 20 _To_30 x| O]
1 Entry Selected . p
B System Events > @ SUBNETS (13) -
iS Event Handler List Filters + [[]=1Pvé_Range_172_16_81_20 To_30
[[J=IPvé_Subnet_172_16_81_26@128
& Subnet List
[F]=IPv6_Subnet_172_16_81_26@64 L
& Incidents v [F1=IPv6_Subnet_96_45_33_64@128 I
& All Incidents Fiter 1 [ ~ | C=IPve_Subnet_96_45_33_64@64
£ Incident Settings Log Device FortiGate + || ¥/ =Range_172_16_81_20 To_30
T 4
iE FortiGate Event Handlers vee [C/=Range_96_45_33_60_to_70
Log Type Traffic Log * || [|=Subnet_172_16_81_0@24
Log Subtype Any » || [[&=Subnet_172_16_81_26@32
Group By Application Name I+ [[]=Subnet_172_243_0_0@16
FIESubnet 172 243 138 194 <2
Logs match OAll @ Any of the following conditions B E m Cancel
Log Field Match Criteria Value
Level {pri) = Greater Than or Equal To  « Information +| 4+ B
5. Select OK.
\
S L4
If a conflict arises between the exclude and include lists, the exclude list will take priority.
-—
-
9 Subnet filters work when either SRCIP or DSTIP hit the subnet, meaning SRCIPs and DSTIPs
share the same subnet filters.
-
-

Incidents

To view incidents, go to Incidents & Events > Incidents > All Incidents.

To configure incident settings, go to Incidents & Events > Incidents > Incident Settings.

Raising an incident

You can raise an incident only from alerts generated for one endpoint.
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You can raise an incident in the following ways:

 InIncidents & Events > Incidents > All Incidents, click Create New in the toolbar. This opens the Create New
Incident pane.

« InlIncidents & Events > All Events, right-click an event and select Raise Incident. This opens the Raise Incident
pane with the applicable fields filled in, such as the Affected Endpoint.

Following is a description of the options available in the Create New Incident and Raise Incident pane.

Incident Reporter The admin account raising the incident. This field cannot be changed.

Incident Category Select a category from the dropdown list.

Severity Select a severity level from the dropdown list.

Status Select a status from the dropdown list.

Affected Endpoint In the Raise Incident pane, the affected endpoint is filled in and cannot be
changed.

In the Create New Incident pane, select the affected endpoint from the
dropdown list.

Description If you wish, enter a description.

Analyzing an incident

In Incidents & Events > Incidents > All Incidents, double-click an incident or right-click an incident and select Analysis
Page.

The incident analysis page shows the incident's Affected Endpoint and User, Incident Life Cycle, Incident Info,
Timeline, and Events related to the incident.

In the Incident Info panel, you can change the Incident Category, Severity, Status, and Description.

In the Events panel, you can review and delete events attached to the incident.

Configuring incident settings

To configure incident settings, go to Incidents & Events > Incidents > Incident Settings.

When an incident is created, updated, or deleted, you can send a notification to external platforms using selected fabric
connectors.

To configure incident notification settings:

1. GotoIncidents & Events > Incidents > Incident Settings.

2. Select a Fabric Connector from the dropdown list.

3. Select which notifications you want to receive:
« Send notification when new incident is created. Incidents with draft status will not trigger notification.
« Send notification when new incident is updated.
« Send notification when new incident is deleted.
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4. To add more fabric connectors, click Add Fabric Connector and repeat the above steps to configure notification
settings.
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Use the Security Operations Center (SOC) to view Monitors and FortiView.

Monitors are designed for network and security operation centers where dashboards are displayed across multiple large
monitors.

FortiView is a comprehensive monitoring system for your network that integrates real-time and historical data into a
single view. It can log and monitor threats to networks, filter data on multiple levels, keep track of administrative activity,
and more.

« Monitors on page 87
« FortiView on page 98

N ! ’, To allow tuning of CPU and memory usage in high capacity environments, you can opt to
? disable SOC view, which stops the background processing for this feature. See Enabling and
- disabling SOC on page 109.
Monitors

SOC (Security Operations Center) Monitors are designed for a network and security operations center where multiple
dashboards are displayed in large monitors.

In the Monitors view, dashboards display both real-time monitoring and historical trends. Centralized monitoring and
awareness help you to effectively monitor network events, threats, and security alerts. Use Monitors dashboards to view
multiple panes of network activity, including monitoring network security, compromised hosts, endpoints, Security
Fabric, WiFi security, and FAZ system performance.

Atypical scenario is to set up dashboards and widgets to display information most relevant to your network and security
operations. Use the main monitors in the middle to display important dashboards in a larger size. Then use the monitors
on the sides to display other information in smaller widgets.

For example, use the top monitor in the middle to display the Top Threat Destinations widget in full screen, use the
monitor(s) below that to display other Threat Monitor widgets, use the monitors on the left to display WiFi Monitor
widgets at the top and FAZ Performance Monitor widgets at the bottom, and use the monitors on the right as a
workspace to display widgets showing the busiest network activity. You can move, add, or remove widgets.

Monitors dashboards and widgets are very flexible and have the following features:

« You can create predefined or custom dashboards.

« For both predefined and custom dashboards, you can add, delete, move, or resize widgets.
« You can add the same dashboard multiple times on the same or different monitors.

« Each widget monitors one activity.

« You can add the same widget multiple times and apply different settings to each one. For example, you can add
widgets to monitor the same activity using a different chart type, refresh interval, or time period.

« You can resize widgets or display a widget in full screen.
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Al
‘Q' The SOC module, which includes Monitors, can be disabled to improve performance in high
- capacity environments. For more information, see Enabling and disabling SOC on page 109
To prevent timeout, ensure /dle Timeout is greater than the widget's Refresh Interval. See
Idle timeout on page 246 and Settings icon on page 95.

SOC monitor dashboards

SOC monitors include predefined dashboards.

Both predefined and custom dashboards can be modified with widgets, including: Threats widgets, Compromised Hosts
widgets, Traffic widgets, Applications & Websites widgets, VPN widgets, WiFi widgets, Endpoints widgets, System
widgets, Threat Research widgets, Security Fabric widgets, and FortiClient Software widgets.

For example, the default Threat Monitor dashboard includes four widgets: Threat Map, Top Threat Destinations, Top
Threats, and Top Virus Incidents Over Time. These widgets can be removed, enlarged, reduced, or customized, and
new widgets can be added to the dashboard.

For more information, see Customizing the Monitors dashboard on page 96.

+ Add Widget B Dashboard v B Al Devices~ @ Last1Hour v  11:50:55 - 12:50:55 S - Night Ocean |

Threat Map Top Threat Destinations

Map  Satellite

c
2011-03-01
1996-10-44 (BT B Al 20171004 20190402
EICAR_TEST_FILE Adware/MacSeanch ISRstealer
20110228 20150105 20181211
Android/Piapps Altr JS/AgentNOI ‘W32/Qjwmankey. RXG

SOC Monitors includes the following predefined dashboards:

Threats Monitors the top security threats to your network.
Traffic Monitors the traffic on your network.
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Applications & Websites
Compromised Hosts
FortiSandbox Detections
Endpoints

Fabric State of Security

VPN
WiFi
Local System Performance

FortiClient Software Inventory

Monitors the application and website traffic on your network.
Monitors compromises and suspicious web use in your network.
Monitors FortiSandbox detections on your network.

Monitors endpoint activity on your network.

Monitors your network's Security Fabric rating, score, and topology.

This information for this dashboard is available after you create a Security Fabric
group in FortiGate and add it in FortiAnalyzer. The Security Fabric can be
selected in the settings options for each widget.

Monitors VPN activity on your network.
Monitors WiFi access points and SSIDs.
Monitors the local system performance of the FortiAnalyzer unit.

Monitors the FortiClient endpoints sending logs to FortiAnalyzer.

Archive Includes FortiAnalyzer NOC-SOC modules from versions prior to 6.2.0.
\‘ ! 'l
q When upgrading versions prior to FortiAnalyzer 6.2.0, custom dashboards will not be migrated
- and must be recreated.
Threats widgets

Threats includes the following widgets:

Top Threat A world map, spinning 3D globe, or table showing the top 10, 20, 50, 100 threat destinations.

Destinations On the map view, hover the cursor over data points to see the source device and IP address,
destination IP address and country, threat level, and the number of incidents (blocked and
allowed).

Top Threats The top threats to your network. Hover the cursor over data points to see the threat, category,

threat level, threat score (blocked and allowed), and the number of incidents (blocked and

allowed).

The following incidents are considered threats:
« Risk applications detected by application control
« Intrusion incidents detected by IPS
« Malicious web sites detected by web filtering
« Malware/botnets detected by antivirus

Top Threats The top threats to your network from risk applications, intrusion incidents, malicious
(FortiClient) websites, and malware/botnets.

Only visible in a Fabric ADOM.
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Top Threats Over
Time by Threat
Scores

Top Threats by
Weight & Count

FortiSandbox
Detection

FortiSandbox -
Scanning Statistics

FortiSandbox - Top
Malicious &
Suspicious File
Users

Threat Map

The historical threats to your network from risk applications, intrusion incidents, malicious
web sites, and malware/botnets.

The top threats by weight and count to your network from risk applications, intrusion
incidents, malicious websites, and malware/botnets.

FortiSandbox detection detail, including scan doc name, source user, destination IP, verdict
level, action, and service.

The number of files detected by FortiSandbox by type: Malicious, Suspicious, Clean, and
Others.

Users or IP addresses that have the highest number of malicious and suspicious files
detected by FortiSandbox.

Threats happening right now across the world.

Compromised Hosts widgets

Compromised Hosts includes the following widget:

Compromised
Hosts

Traffic widgets

Suspicious web use compromises. By default, this widget includes two panes: Compromised
Hosts and Compromised Hosts Incidents.

The Compromised Hosts pane automatically rotates through compromised hosts. You can
pause autoplay or click > or < to manually move to another compromised host.

The Compromised Hosts Incidents pane displays a map of compromised hosts incidents.

Click Settings to change the number of top compromised hosts, Time Period, Refresh
Interval, Autoplay Interval, and to show or hide Compromised Hosts Incidents.

Traffic includes the following widgets:

User Data Flow

Top Sources
Today

Top Sources

Top Source
Address Objects

Top
Country/Region

Bandwidth breakdown of top user destination country/region or application usage.

Near real-time network traffic by blocked and allowed sessions.

The highest network traffic by source IP address and interface, sessions (blocked and
allowed), threat score (blocked and allowed), and bytes (sent and received).

The highest network traffic by source address objects, sessions (blocked and allowed), threat
score (blocked and allowed), and bytes (sent and received).

The highest network traffic by country/region, sessions (blocked and allowed), and bytes
(sent and received).
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Top
Country/Region
Over Time by
Sessions

Top Policy Hits
Policy Hits Over

Time by Bandwidth

Top Destinations

Top Destination
Address Objects

Traffic Over Time
by Sessions

Top Cloud Users
DNS Logs

Top Source
(FortiDDoS)

Top Destination
(FortiDDoS)

Top Type
(FortiDDoS)

The historical network traffic by country/region, sessions (blocked and allowed), and bytes
(sent and received).

Top policy hits from recent traffic.

The historical policy hits from recent traffic.

Top destinations from recent traffic.

Top destination address objects from recent traffic.

The historical destinations from recent traffic.

Top cloud users from recent traffic.
Top DNS logs from recent traffic.

Top source IP addresses from recent traffic.
Only available in a Fabric ADOM.

Top destination |P addresses from recent traffic.
Only available in a Fabric ADOM.

Top types from recent traffic.
Only available in a Fabric ADOM.

Applications & Websites widgets

Applications & Websites includes the following widgets:

Top Applications

Top Applications
Over Time by
Sessions

Top Applications
(FortiClient)

Top Cloud
Applications

Cloud Applications

Over Time by
Sessions

Top Website
Domains

The top applications used on the network, including application name, risk level, category,
sessions (blocked and allowed), and bytes (sent and received).

The historical sessions of applications used on the network, including application name, risk
level, category, sessions (blocked and allowed), and bytes (sent and received).

The top applications used on the network, including application name, risk level, category,
sessions (blocked and allowed), and bytes (sent and received).

Only available in a Fabric ADOM.

Top cloud applications from recent traffic.

The historical sessions of cloud applications used on the network.

Top website domains from recent traffic.
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Top Website Top website categories from recent traffic.

Categories

Top Website Top website domains from recent traffic.

(FortiClient) Only available in a Fabric ADOM.

Website Browsing  The historical websites browsing sessions from recent traffic.
Over Time by

Sessions

Top Browsing User Top browsing users from recent traffic.

Browsing User The historical browsing users from recent traffic.
Over Time by
Bandwidth

VPN widgets

VPN includes the following widgets:

Top Dialup VPN The users accessing the network using SSL or IPsec over a VPN tunnel.
VPN Site-to-Site The names of VPN tunnels with Internet protocol security (IPsec) that are accessing the
network.

WiFi widgets
WiFi includes the following widgets:

Authorized APs The names of authorized WiFi access points on the network.

Top SSID The top SSID (service set identifiers) of authorized WiFi access points on the network. Hover
the cursor over data points to see the SSID and bytes (sent and received).

Top SSID Over The historical SSID (service set identifiers) traffic of authorized WiFi access points on the
Time by Bandwidth network.

Top Rogue APs The top SSID (service set identifiers) of unauthorized WiFi access points on the network.
Hover the cursor over data points to see the SSID and total live time.

WiFi Clients The top WiFi access points on the network by bandwidth/sessions.

Endpoints widgets

Endpoints includes the following widgets:

Top Endpoint Vulnerability information about FortiClient endpoints including vulnerability name and
Vulnerabilities CVEID.
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Top Endpoint
Vulnerabilities
(FortiClient)

Top Endpoint
Devices with
Vulnerabilities

Top Endpoint
Devices with
Vulnerabilities

(FortiClient)

User
Vulnerabilities
Summary

All Endpoints

All Endpoints
(FortiClient)

Top Endpoint
Threats

Top Endpoints
Applications

System widgets

Vulnerability information about FortiClient endpoints including vulnerability name and
CVE ID.

Only available in a Fabric ADOM.

Vulnerability information about FortiClient endpoints including source |P address and device.

Vulnerability information about FortiClient endpoints including source |IP address and device.
Only available in a Fabric ADOM.

User vulnerabilities summary.

All endpoints.

All endpoints.

Top threats from all endpoints.

Top applications from all endpoints.
Only available in a Fabric ADOM.

This dashboard monitors the system performance of the FortiAnalyzer unit running SOC and not the logging devices. It
includes the following widgets:

CPU & Memory
Usage

Multi Core CPU
Usage

Insert Rate vs
Receive Rate

Receive Rate vs
Forwarding Rate

The usage status of the CPU and memory.

The usage status of a multi-core CPU.

The number of logs received vs the number of logs actively inserted into the database,
including the maximum and minimum rates.

« Receive rate: how many logs are being received.

« Insert rate: how many logs are being actively inserted into the database.

If the insert rate is higher than the log receive rate, then the database is rebuilding. The lag is
the number of logs waiting to be inserted.

The number of logs received vs the number of logs forwarded out, including the maximum
and minimum rates.

« Receive rate: how many logs are being received.

« Forward rate: how many logs are being forwarded out.
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Disk 1/0

Resource Usage
Average

Resource Usage
Peak

Admin Logins
System Events

Failed
Authentication
Attempts

The disk Transaction Rate (1/0s per second), Throughput (KB/s), or Utilization (%). The
Transaction Rate and Throughput graphs also show the maximum and minimum disk
activity.

Overview of average resource usage history across all devices.

Overview of peak resource usage history across all devices.

Top admin logins from recent traffic.
Top system events from recent traffic.

Top unauthorized connections from recent traffic.

Threat Research widgets

Threat Research includes the following widgets:

Worldwide Threat

The top virus, IPS, botnet, and application threats globally today based on UTC.

Prevalence - Today This data is from FortiGuard and not from FortiGate.

(UTC)

Top Virus
Incidents Over
Time

Local virus incidents in the last one month.

Security Fabric widgets

Security Fabric includes the following widgets.

This information for this dashboard is available after you create a Security Fabric group in FortiGate and add it in
FortiAnalyzer. The Security Fabric can be selected in the settings options for each widget.

Security Fabric
Rating Report

Security Fabric
Score

Security Fabric
Topology

Best Practices
Overview

A report showing the security rating details of connected Security Fabric devices. Click a
milestone to drill down and hover the cursor over data points to see more details.

The current and historical Security Fabric scores. The Historical Security Fabric Scores pane
displays your Security Fabric score over time and how it compares to the industry average
and the industry score range. You can hide the Historical Security Fabric Scores pane.

A topology map showing the logical structure of connected Security Fabric devices.

Overview of the device best practices across regions of North America, Latin America, EMEA,
and APAC.
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FortiClient Software widgets

FortiClient Software includes the following widget:

FortiClient The total number of apps installed, top apps, new apps installed, top apps by installs, and top
Software Inventory  hosts by number of apps.

Using the Monitors dashboard

SOC monitors dashboards contain widgets that provide network and security information. Use the controls in the
dashboard toolbar to work with a dashboard.

Add Widget Add widgets to a predefined or custom dashboard. For details, see Customizing the
Monitors dashboard on page 96.

Dashboard Create a new dashboard or reset a predefined dashboard to its default settings. For custom
dashboards, you can rename or delete the custom dashboard. For details, see Customizing
the Monitors dashboard on page 96.

Create New Create a new dashboard.

Reset Reset a predefined dashboard to its default widgets and settings.
Rename Rename a custom dashboard.
Delete Delete a custom dashboard.

Devices Select the devices to include in the widget data.

The device list will also include a Security Fabric if available.
To select a Security Fabric, you need to first create a Security Fabric group in FortiGate and
add the Security Fabric group in FortiAnalyzer.
Time Period Select a time period from the dropdown menu, or set a custom time period.
Refresh Refresh the data in the widgets.
Background color Change the background color of the dashboard to make widgets easier to view in different
room lighting.
« Day shows a brighter gray background color.

« Night shows a black background.
« Ocean shows a blue background color.

Hide Side-menu or Hide or show the tree menu on the left. In a typical SOC environment, the side menu is
Show Side-menu hidden and dashboards are displayed in full screen mode.

Use the controls in the widget title bar to work with widgets.

Settings icon Change the settings of the widget. Widgets have settings applicable to that widget, such as
how many of the top items to display, Time Period, Refresh Interval, and Chart Type.
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View different chart
types

Hide or show a
data type

Remove widget
icon

Move widget
Resize widget
View more details

View a narrower
time period

Zoom in and out

Some widget settings let you choose different chart types such as the Disk I/O and Top
Countries widget. You can add these widgets multiple times and set each widget to show a
different chart type.

For widgets that show different data types, click a data type in the title bar to hide or show
that data type in the graph.

For example, in the Insert Rate vs Receive Rate widget, click Receive Rate or Insert Rate
in the title bar to hide or show that data. In the Disk I/0 widget, click Read or Write in the title
bar to hide or show that data type.

Delete the widget from a predefined or custom dashboard.

Click and drag a widget'’s title bar to move it to another location.
Click and drag the resize button in the bottom-right of the widget.
Hover the cursor over a widget’s data points to see more details.

Some widgets have buttons below the graph. Click and drag the buttons to view a narrower
time period.

For widgets that show information on a map such as the Top Threat Destinations widget,
use the scroll wheel to change the zoom level. Click and drag the map to view a different
area.

Customizing the Monitors dashboard

You can add any widget to a predefined dashboard. You can also move, resize, or delete widgets. You cannot rename
or delete a predefined dashboard. To reset a predefined dashboard to its default settings, click Dashboard > Reset.

You can add the same widget multiple times and configure each one differently, such as showing a different Time
Period, Refresh Interval, or Chart Type.

To create a dashboard:

1. Inthe toolbar, click Dashboard > Create New.

2. Specify the Name and whether you want to create a blank dashboard or use a template.
If you select From Template, specify which predefined dashboard you want to use as a template.

3. Click OK. The new dashboard appears In the tree menu.

To display Security Fabric in Monitors:

Create a Security Fabric in FortiGate.

. Add the Security Fabric in FortiAnalyzer.

Select the Fabric State of Security dashboard.

1
2
3. Goto SOC > Monitors > Dashboards.
4
5

Select the Security Fabric from the Devices menu.
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To add a widget:

Select the predefined or custom dashboard where you want to add a widget.

Click Add Widget to expand the menu; then locate the widget you want to add.
Click the + button to add widgets.

AoObd -~

When you have finished adding widgets, click the close button to close the Add Widget pane.
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FortiView

FortiView is a comprehensive monitoring system for your network that integrates real-time and historical data into a
single view. It can log and monitor threats to networks, filter data on multiple levels, keep track of administrative activity,
and more.

FortiView allows you to use multiple filters in the consoles, enabling you to narrow your view to a specific time, by user
ID or local IP address, by application, and others. You can use it to investigate traffic activity such as user
uploads/downloads or videos watched on YouTube on a network-wide user group or on an individual-user level.

In FortiView dashboards, you can view summaries of log data such as top threats to your network, top sources of
network traffic, and top destinations of network traffic.

Depending on which dashboard you are viewing, information can be viewed in different formats: table, bubble, map, or
tile. Alternative chart types are available in each widget's Settings menu.

For each summary, you can drill down to see more details.

FortiGate, FortiCarrier, and FortiClient EMS devices support FortiView.

x The SOC module, which includes FortiView, can be disabled to improve performance in high

capacity environments. For more information, see Enabling and disabling SOC on page 109

How ADOMs affect FortiView

When ADOM s are enabled, each ADOM has its own data analysis in FortiView.

Fabric ADOMs will show data analysis from all eligible devices in the Security Fabric.

Logs used for FortiView

FortiView displays data from Analytics logs. Data from Archive logs is not displayed in FortiView. For more
information, see Analytics and Archive logs on page 22.

FortiView dashboards

Many dashboards display a historical chart in a table format to show changes over the selected time period.

If you sort by a different column, the chart shows the history of the sorted column. For example, if you sort by Sessions
Blocked/Allowed, the chart shows the history of blocked and allowed sessions. If you sort by Bytes Sent/Received, the
chart shows the history of bytes sent and received.

When you drill down to view a line item, the historical chart show changes for that line item.
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FortiView dashboards for FortiGate and FortiCarrier devices

Category View Description

Threats Top Threats Lists the top threats to your network.

The following incidents are considered threats:
« Risk applications detected by application control.
« Intrusion incidents detected by IPS.
« Malicious web sites detected by web filtering.
« Malware/botnets detected by antivirus.

Threat Map Displays a map of the world that shows the top traffic destinations starting
at the country of origin. Threats are displayed when the threat score is
greater than zero and either the source or destination IP is a public IP
address.

The Threat Window below the map, shows the threat, source, destination,
severity, and time. The color gradient of the lines indicate the traffic risk. A
yellow line indicates a high risk and a red line indicates a critical risk.

This view does not support filtering and Day, Night, and Ocean themes.
See also Viewing the threat map on page 102.

Compromised Hosts  Displays end users with suspicious web use compromises, including end
users’ IP addresses, overall threat rating, and number of threats.
To use this feature:
1. UTM logs of the connected FortiGate devices must be enabled.
2. The FortiAnalyzer must subscribe to FortiGuard to keep its threat
database up-to-date.

FortiSandbox Displays a summary of FortiSandbox related detections.

Detection The following information is displayed: Filename, End User and/or IP,
Destination IP, Analysis (Clean, Suspicious or Malicious rating), Action
(Passthrough, Blocked, etc.), and Service (HTTP, FTP, SMTP, etc.).
Select an entry to view additional information in the drilldown menu.
Clicking a FortiSandbox action listed in the Process Flow displays details
about that action, including the Overview, Indicators, Behavior
Chronology Chart, Tree View, and more. Information included in the
Details and Tree View tab is only available with FortiSandbox 3.1.0 and
above.

FortiAnalyzer 6.2.3 Administration Guide
Fortinet Technologies Inc.



Category View Description

Traffic Top Source Displays the highest network traffic by source IP address and interface,
device, threat score (blocked and allowed), sessions (blocked and allowed),
and bytes (sent and received).

Top Source Displays the top source addresses by source object, interface, device,
Addresses threat score (blocked and allowed), sessions (blocked and allowed), and
bytes (sent and received).

Top Destinations Displays the highest network traffic by destination IP addresses, the
applications used to access the destination, sessions, and bytes. If
available, click the icon beside the IP address to see its WHOIS

information.
Top Destination Displays the top destination addresses by destination objects, applications,
Addresses sessions, and bytes. If available, click the icon beside the IP address to see

its WHOIS information.

Top Country/Region  Displays the highest network traffic by country in terms of traffic sessions,
including the destination, threat score, sessions, and bytes.

Policy Hits Lists the policy hits by policy, device name, VDOM, number of hits, bytes,
and last used time and date.

DNS Logs Summarizes the DNS activity on the network. Double click an entry to drill
down to the specific details about that domain.

Applications  Top Applications Displays the top applications used on the network including the application
& Websites name, category, risk level, and sessions blocked and allowed. Bytes sent
and received can also be enabled through the widget settings.

For a usage example, see Finding application and user information on

page 109.
Top Cloud Displays the top cloud applications used on the network.
Applications
Top Cloud Users Displays the top cloud users on the network.
Top Website Displays the top allowed and blocked website domains on the network.
Domains
Top Website Displays the top website categories.
Categories

Top Browsing Users  Displays the top web-browsing users, including source, group, number of
sites visited, browsing time, and number of bytes sent and received.

VPN SSL & Dialup IPsec Displays the users who are accessing the network by using the following
types of security over a virtual private network (VPN) tunnel: secure socket
layers (SSL) and Internet protocol security (IPsec).
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Category View Description

You can view VPN traffic for a specific user from the top view and drilldown
views. In the top view, double-click a user to view the VPN traffic for the
specific user. In the drilldown view, click an entry from the table to display
the traffic logs that match the VPN user and the destination.

Site-to-Site IPsec Displays the names of VPN tunnels with Internet protocol security (IPsec)
that are accessing the network.

System Admin Logins Displays the users who logged into the managed device.
System Events Displays events on the managed device.
Resource Usage Displays device CPU, memory, logging, and other performance information

for the managed device.

Resource Usage includes two widgets: Resource Usage Average and
Resource Usage Peak.

Failed Authentication Displays the IP addresses of the users who failed to log into the managed
Attempts device.

Using FortiView

When ADOMs are enabled, FortiView displays information for each ADOM. Please ensure you are in the correct
ADOM. See Switching between ADOMs on page 15.

« Viewing FortiView dashboards on page 101

« Filtering FortiView on page 102

« Viewing related logs on page 103

« Exporting filtered summaries on page 103

« Monitoring resource usage of devices on page 104
« Long-lived session handling on page 104

Viewing FortiView dashboards

When viewing FortiView dashboards, use the controls in the toolbar to select a device, specify a time period, refresh the
view, and switch to full-screen mode.

Many widgets on FortiView dashboards let you drill down to view more details. To drill down to view more details, click,
double-click, or right-click an element to view details about different dimensions in different tabs. You can continue to
drill down by double-clicking an entry. Click the close icon in the widget's toolbar to return to the previous view.

Many FortiView widgets support multiple chart types such as table view, bubble view, map view, tile view, etc.
« Inwidgets that support multiple views, select the settings icon in the top-right corner of the widget to choose
another view.
« If sorting is available, there is a Sort By dropdown list in the top-left.

« Some widgets have a Show dropdown list in the bottom-right for you to select how many items to display.
« Tosort by acolumnin table view, click the column title.

FortiAnalyzer 6.2.3 Administration Guide 101
Fortinet Technologies Inc.



« Toview more information in graphical views such as bubble, map, or user view, hover the mouse over a graphical
element.

Some dashboards include multiple widgets. For example, Applications & Websites > Top Cloud Applications includes
widgets for Top Cloud Application and Top Cloud User.

Viewing the threat map
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You can view an animated world map that displays threats from unified threat management logs. Threats are displayed
in real-time. No replay or additional details are available.

You must specify the longitude and latitude of the device to enable threats for the device to
ﬂ display in the threat map. You can edit the device settings to identify the geographical
I location of the device in Device Manager. For more information, see Editing device
information on page 29

To view the threat map:

1. Goto FortiView > Threats > Threat Map.

2. Inthe map, view the geographic location of the threats.
Threats are displayed when the threat level is greater than zero.
« Avyellow line indicates a high threat.
« Aredline indicates a critical threat.
3. Inthe Threat Window, view the Time, Threat, Source, Destination, and Severity(score).

Filtering FortiView

Filter FortiView widgets using the Add Filter box in the toolbar or by right-clicking an entry and selecting a context-
sensitive filter. You can also filter by specific devices or log groups and by time.
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To filter FortiView widgets using filters in the toolbar:

1. Specify filters in the Add Filter box.

« Filter Mode: In the selected summary view, click Add Filter and select a filter from the dropdown list, then type
avalue. Click NOT to negate the filter value. You can add multiple filters and connect them with “and” or “or”.

o Text Search: Click the Switch to Text Searchicon at the right end of the Add Filter box. In Text Search mode,
enter the search criteria (log field names and values). Click the Switch to Filter Mode icon to go back to Filter
Mode.

2. Inthe Device list, select a device.
3. Inthe Timelist, select a time period.

To filter FortiView widgets using the right-click menu:

In the selected view, right-click an entry and select a filter criterion (Search <filter value>).

Depending on the column in which your mouse is placed when you right-click, FortiView uses the column value as the
filter criteria. This context-sensitive filter is only available for certain columns.

Viewing related logs

You can view the related logs for a FortiView summary in Log View. When you view related logs, the same filters that
you applied to the FortiView summary are applied to the log messages.

To view related logs for a FortiView summary, right-click the entry and select View Related Logs.

Exporting filtered summaries

You can export filtered FortiView summaries or from any level of drilldown to PDF and report charts. Filtered summaries
are always exported in table format.

To export a filtered summary:

1. Inthe filtered summary view or its drilldown, select the fools icon in the top-right corner of the widget and choose
Export to PDF or Export to Report Chart.

2. Inthe dialog box, review and configure settings:
« Specify a file name for the exported file.
o Inthe Topfield, specify the number of entries to export.

« If you arein a drilldown view, the tab you are in is selected by default. You can select more tabs. If you are
exporting to report charts, the export creates one chart for each tab.

3. Click OK.

Charts are saved in the Chart Library. You can use them in the same way you use other charts.

L}
S L4
? Only log field filters are exported. Device and time period filters are not exported.
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Monitoring resource usage of devices

You can monitor how much FortiAnalyzer system resources (e.g., CPU, memory, and disk space) each device uses.
When ADOMs are enabled, this information is displayed per ADOM. In a specific ADOM, you can view the resource
usage information of all the devices under the ADOM.

Go to SOC > FortiView > System > Resource Usage to monitor resource usage for devices.

Long-lived sessi

on handling

Because traffic logs are only sent at the end of a session, long-lived sessions can be unintentionally excluded when
narrowing searches in FortiView. To account for this, interim traffic logs can be enabled through FortiOS, allowing

FortiView to show the trend of session history rather than one large volume once the session is closed.

For a long-lived session with a duration greater than two minutes, interim traffic logs are generated with the Log ID of

20.

o Forinterim traffic logs, the sentdelta and rcvddelta fields are filled in with an increment of bytes which are

sent/received after the start of the session or previous interim traffic log.

« Interim traffic logs are not counted in Sessions, but the sentdelta and recvddelta in related traffic logs will be
added when calculating the sent and received bytes.

When a long-lived session ends, a traffic log with a Log ID of 13 is sent which indicates the session is closed.

s 5

Summary Sessions Blocked —(O- Allowed

Application V2VNC !

Category Not.Scanned 08

Risk High 0.6

# of Clients 1 0.4

Sessions( " Blocked/ M Allowed) [ 1] 02

Bytes( " Sent/ M Received)

? 13“15 13:“20 13::‘25 ' 13:30 ' 13:35 13:40 13:45 13:50 13:55 14:00 ' 14:‘10
Destination ~ Country/Region Threat  Session
# ¥Date/Time Device ID Firewall Action ~ Source IP Destination |P Service Application |LogID Session ID sentdelta rcvddelta Duration
1 14:11:55 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 | 187053 180 5600 1791
2 14:09:25 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 | 187053 270 5736 1671
3 14:06:27 FGT91E4Q160005... + accept 172.18.4.112 172.18.4.201 VNC VNC 0000000020 | 187053 180 8408 1491
4 14:04:28 FGT91E4Q160005... + accept 172.18.4.112 172.18.4.201 VNC VNC 0000000020 § 187053 270 8394 1371
5 14:01:02 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 270 8298 1191
6 13:58:08 FGT91E4Q160005... + accept 172.18.4.112 172.18.4.201 VNC  VNC 0000000020 f 187053 180 5204 1011
7 13:56:09 FGT91E4Q160005... ~ accept 172.18.4.112 172.18.4.201 VNC  VNC 0000000020 f 187053 270 7788 891
8 13:53:28 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 180 5090 711
9 13:51:35 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 3518 22200 591
10  13:49:32 FGT91E4Q160005... + accept 172.18.4.112 172.18.4.201 VNC VNC 0000000020 § 187053 270 7824 471
11 13:46:27 FGT91E4Q160005... + accept 172.18.4.112 172.18.4.201 VNC VNC 0000000020 § 187053 22942 1340721 291
12 13:44:23 FGT91E4Q160005... + accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 187053 11864 411594 171
13 13:33:28 FGT91E4Q160005... + close 172.184.112 172.18.4.201 VNC  VNC 0000000013 | 186001 17584 183669 801
14 13:31:35 FGT91E4Q160005... + accept 172.18.4.112 172.18.4.201 VNC  VNC 0000000020 f 186001 21980 272402 723
15 13:29:23 FGT91E4Q160005... ~ accept 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 186001 21940 272680 602
16  13:27:30 FGT91E40160005... + accent 172.184.112 172.18.4.201 VNC  VNC 0000000020 f 186001 22004 270784 481
£= Total logs for analytics: 60 days 22 hours. 50 v |ltems per page ~ 0.281 Second
\‘ : 'l
? When enabled, interim logs must be handled specially for Reports and Events to avoid
- multiple counting.
-
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Viewing Compromised Hosts

Compromised Hosts or Indicators of Compromise Service (I0C) is a licensed feature.

To view Compromised Hosts, you must turn on the UTM web filter of FortiGate devices and subscribe your
FortiAnalyzer unit to FortiGuard to keep its local threat database synchronized with the FortiGuard threat database. See
Subscribing FortiAnalyzer to FortiGuard on page 106.

The Indicators of Compromise Service (I0C) downloads the threat database from FortiGuard. The FortiGuard threat
database contains the blacklist and suspicious list. IOC detects suspicious events and potentially compromised network
traffic using sophisticated algorithms on the threat database.

FortiAnalyzer identifies possible compromised hosts by checking the threat database against an event's IP, domain, and
URL in the following logs of each end user:

« Web filter logs.
o DNSlogs.
« Trafficlogs.

When a threat match is found, sophisticated algorithms calculate a threat score for the end user. When the check is
complete, FortiAnalyzer aggregates all the threat scores of an end user and gives its verdict of the end user’s overall
I0C.

Compromised Hosts displays the results showing end users with suspicious web usage which can indicate that the
endpoint is compromised. You can drill down to view threat details.

Understanding Compromised Hosts entries

When a log entry is received and inserted into the SQL database, the log entry is scanned and compared to the blacklist
and suspicious list in the IOC threat database that is downloaded from FortiGuard.

If a match is found in the blacklist, then FortiAnalyzer displays the endpoint in Compromised Hosts with a Verdict of
Infected.

If a match is found in the suspicious list, then FortiAnalyzer flags the endpoint for further analysis.

In the analysis, FortiAnalyzer compares the flagged log entries with the previous endpoint's statistics for the same day
and then updates the score.

If the score exceeds the threshold, that endpoint is listed or updated in Compromised Hosts.
When an endpoint is displayed in Compromised Hosts, all the suspicious logs which contributed to the score are listed.

When the database is rebuilt, all log entries are reinserted and rescanned.

Working with Compromised Hosts information

Go to SOC > FortiView > Threats > Compromised Hosts.
When viewing Compromised Hosts:

o Use the widget settings icon to select Table or Users format, set the refresh interval, and modify other widget
settings.
« Use the tools icon to export the information, edit rescan configuration, and set additional display options.
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« Use the toolbar to select devices, specify a time period, refresh the view, select a theme (Day, Night, and Ocean),
and switch to full-screen mode.

When you view an event, the # of Threats is the number of unique Threat Names associated with that compromised
host (end user).

When you drill down to view details, the # of Events is the number of logs matching each blacklist entry for that
compromised host (end user).

« To acknowledge a Compromised Hosts line item, click Ack on that line.

o Tofilter entries, click Add Filter and specify devices or a time period.

o Todrill down and view threat details, double-click a tile or a row.

Incorrectly rated |OCs can be reported within the Threat Intel Lookup screen, accessible by double-clicking on an End
User, selecting the detected pattern from the Blacklist, and clicking Report Misrated /OC.

Subscribing FortiAnalyzer to FortiGuard

To keep your FortiAnalyzer threat database up to date:

o Ensure your FortiAnalyzer can reach FortiGuard at fds1.fortinet.com.

o Purchase a FortiGuard Indicators of Compromise Service license and apply that license to the product registration.
No change is needed on the FortiAnalyzer side.

To subscribe FortiAnalyzer to FortiGuard:

1. Goto System Settings > Dashboard.

2. Inthe License Information widget, find the FortiGuard > Indicators of Compromise Service field and click
Purchase.

3. After purchasing the license, check that the FortiGuard > Indicators of Compromise Service is Licensed and
shows the expiry date.

Managing a Compromised Hosts rescan policy

The Compromised Hosts scan time range can be customized to scan previous entries so that when a new package is
received from FortiGuard, FortiAnalyzer can immediately rescan using the new definitions.

Requirements for managing a Compromised Hosts rescan policy:
N - /, « This feature requires a valid indicators of compromise (IOC) license. The rescan options
q will not be available in the GUI or CLI without a license.
= o The administrator must have System Settings write privileges to enable or disable and
configure Global |IOC Rescan.

To configure rescan settings and check rescan results:

1. Goto SOC > FortiView > Threats > Compromised Hosts.

2. From the Tools menu on the right-side of the toolbar, select Edit Rescan Configuration.
The Edit Compromised Hosts Rescan Policy Settings window opens.

FortiAnalyzer 6.2.3 Administration Guide 106
Fortinet Technologies Inc.



Edit Compromised Hosts Rescan Policy Settings

Rescan tasks

Start Time

Compromised Hosts Rescan Global Settings €

Enable Global Compromised Hosts Rescan

rent ADOM Compromised Hosts Rescan

3. Under Compromised Hosts Rescan Global Settings:
a. Enable Global Compromised Hosts Rescan.

b. Set the running time to either a specific hour of the day, or select package update to rescan when the package
is updated.

4. Under Compromised Hosts Rescan Current ADOM Settings:
a. Enable Current ADOM Compromised Hosts Rescan.
b. Select the log types to be scanned (DNS, Web Filter, and Traffic logs).
c. Set the number of previous days' logs that are scanned.
By default, all log types are selected, and the scan will cover the past 14 days. The maximum recommended
number of scan days is calculated based on historical scan speeds, or 30 days if no previous scans have been done.
5. All tasks are shown in the Rescan tasks table, which includes:
« The start and end time of each task.
« The status of the task (complete, running, etc.).
« How complete a task is, as a percentage.
« The total number of scanned logs and the threat count (the number of logs with threats) for each task.
« The |IOC package update time.
« Acount of the new threats that were added in this update.
Running tasks can be canceled by clicking the Cancel button in the Status column.
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Edit Compromised Hosts Rescan Policy Settings

Rascan tasks

Start Time
Jan 07 09.26:29
Jan 06 13:20:34
Jan 05 14:21:14
Jan 04 14:21:18
Jan 03 13:20:53

Campromised Hosts Rescan Global Sattings &

Enable Global Compromised Hosts Rescan

Runing 31 @

sttis
nning
complete
compicte
complete
complete

End Time:
Jan 07 09:50:16
Jan 06 13:35:32
Jan 05 1435145
Jan 04 14:36:20
Jan 03 13:36:16

package update +

Compromisod Hosts Rescan Current ALGM Settings.

Enabie Curment ADOM Compromised Hosts Rescan [ o ]

Log Type Filters

LastN Days

BI0KS logs

wveb fifter logs.
[Bfreatbe s

14

Log Caunt
655746608
595550740
577925226
580414704
594339489

Fackage Update Tire.
Jan 07 (9:24:23
Jan 06 13:20:26
Jan 05 142102
Jan 04 142108
Jan 03 13:20:44

6. Select a non-zero threat count number in the Rescan tasks table to drill down to a specific scans task details.

These details include the Detect Pattern, Threat Type, Threat Name, # of Events, and the Endpoint.

7. Click Back to return to the settings window.

New Compromised Hosts Rescan Blacklist (Package Upate time: Dec 29 13:21:14)

#  DetactPattern
1 1882095287

‘Threat Type.
Malware

Threat Name
cnc

#of Events

Endpoint

2 ——DESKTOP-TAZ0D76

8. Click OKto return to the compromised hosts list.

9. Inthe compromised hosts list, a rescan icon will be shown in the Last Detected column if any threats where found

during a rescan. To view only those hosts that had threats found during a rescan, select Only Show Rescan from
the Tools menu in the toolbar.

Surnerary
# Threats
Top Threats

Threat Map

Compromlsed Hosts

Fortisandbox Detection

= Traffic

8 Apodications & Websltes.

& VPN

H
*

¥

[ infected |
==

Adid Filter o © By Deviees =

& EndUser Last Detected Hast Name. 05

1 Elcrmwkur (17217.73.225) 01/03/2019 VAN-IDIZFINBZ O Windows 10

2 1721758231 01/03/2019 172.17.56.231

3 none){17217.9473)  12/31/2018 WAN-200081-FOF3 A Linux Fedora

4 [iial17217.70.58)  12/31/2018 VAN-LIA-PC =8 Windows 10

5 172175875 12/30/2018 allcate-virtual-machine & Linux 244

6 [Eliackchen | 17217.94.228 12/2%/2018 15 DESKTOP-TA4200%6 8% Windews NT 10.0 fé4)

7 hew|19216B.25) 12/27/2018 fortinet-hexu =8 Windows XP Service Pack 3
8 Pezrd[1721787.14)  01/02/2019 FGT-AZARLD2011 58 Windows XP (x86)
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Examples of using FortiView

You can use FortiView to find information about your network. The following are some examples.

o Finding application and user information on page 109
« Analyzing and reporting on network traffic on page 109

Finding application and user information

Company ABC has over 1000 employees using different applications across different divisional areas, including supply
chain, accounting, facilities and construction, administration, and IT.

The administration team received a $6000 invoice from a software provider to license an application called Widget-Pro.
According to the software provider, an employee at Company ABC is using Widget-Pro software.

The system administrator wants to find who is using applications that are not in the company’s list of approved
applications. The administrator also wants to determine whether the user is unknown to FortiGuard signatures, identify
the list of users, and perform an analysis of their systems.

To find application and user information:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to SOC > FortiView > Applications & Websites > Top Applications.

Click Add Filter, select Application, type Widget-Pro.

If you do not find the application in the filtered results, go to Log View > Traffic.
Click the Add Filter box, select Source IP, type the source IP address, and click Go.

o rODdD =

Analyzing and reporting on network traffic

A new administrator starts at #1 Technical College. The school has a free WiFi for students on the condition that they
accept the terms and policies for school use.

The new administrator is asked to analyze and report on the top source and destinations students visit, the source and
destinations that consume the most bandwidth, and the number of attempts to visit blocked sites.

To review the source and destination traffic and bandwidth:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto SOC > FortiView > Traffic > Top Sources.

3. Goto SOC > FortiView > Traffic > Top Destinations.
If available, select the icon beside the IP address to see its WHOIS information.

Enabling and disabling SOC

The FortiAnalyzer SOC module can be disabled for performance tuning through the CLI. When disabled, the GUI will
hide the SOC modules as well as the FortiView and Monitors panes, and stop background processing for this feature.
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To disable SOC in the CLI:
config system global

set disable-module fortiview-noc
end

To enable SOC in the CLI:

config system global
unset disable-module

end
Disabling the SOC module will cause the FortiAnalyzer to return the following error message
when the FortiGate attempts to retrieve FortiAnalyzer data: Server Error:
Fortiview\/NOC function is disabled on FortiAnalyzer
The FortiGate GUI displays the message: Failed to retrieve FortiView data.
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You can generate data reports from logs by using the Reports feature. You can do the following:

« Use predefined reports. Predefined report templates, charts, and macros are available to help you create new
reports.

o Create custom reports.

Report files are stored in the reserved space for the FortiAnalyzer device. See Automatic deletion on page 56.
When rebuilding the SQL database, Reports are not available until the rebuild is completed.
Select the Show Progress link in the message to view the status of the SQL rebuild.

For more information on FortiAnalyzer report technology and troubleshooting report performance issues, see the
FortiAnalyzer Report Performance Troubleshooting Guide.

How ADOMs affect reports

When ADOMs are enabled, each ADOM has its own reports, libraries, and advanced settings. Make sure you are in the
correct ADOM before selecting a report. See Switching between ADOMs on page 15.

Some reports are available only when ADOMs are enabled. For example, ADOMs must be enabled to access
FortiCarrier, FortiCache, FortiClient, FortiDDoS, FortiMail, FortiSandbox, and FortiWeb reports. In a Security Fabric
ADOM, all reports are displayed.

You can configure and generate reports for these devices within their respective default ADOM or a Security Fabric
ADOM. These devices also have device-specific charts and datasets.

Predefined reports, templates, charts, and macros

FortiAnalyzer includes a number of predefined elements you can use to create and/or build reports.

Predefined... GUI Location Purpose
Reports Reports > Report Definitions > All You can generate reports directly or with minimum setting
Reports configurations. Predefined reports are actually report

templates with basic default setting configurations.

Templates Reports > Report Definitions > You can use directly or build upon. Report templates
Templates include charts and/or macros and specify the layout of the
report. A template populates the Layout tab of a report
that is to be created. See List of report templates on page
128.
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Predefined... GUI Location Purpose
Charts Reports > Report Definitions > Chart ~ You can use directly or build upon a report template you
Library are creating, orin the Layout tab of a report that you are
creating. Charts specify what data to extract from logs.
Macros Reports > Report Definitions > Macro  You can use directly or build upon a report template that
Library you are creating, orin the Layout tab of a report that you
are creating. Macros specify what data to extract from
logs.

Logs used for reports

Reports uses Analytics logs to generate reports. Archive logs are not used to generate reports. For more information,
see Data policy and automatic deletion on page 22.

For reports about users, the FortiGate needs to populate the user field in the logs sent to FortiAnalyzer.

How charts and macros extract data from logs

Reports include charts and/or macros. Each chart and macro is associated with a dataset. When you generate a report,
the dataset associated with each chart and macro extracts data from the logs and populates the charts and macros.
Each chart requires a specific log type.

FortiAnalyzer includes a number of predefined charts and macros. You can also create custom charts and macros.

How auto-cache works

When you generate a report, it can take days to assemble the required dataset and produce the report, depending on
the required datasets. Instead of assembling datasets at the time of report generation, you can enable the auto-cache
feature for the report.

Auto-cache is a setting that tells the system to automatically generate hcache. The hcache (hard cache) means that
the cache stays on disk in the form of database tables instead of memory. Hcache is applied to “matured” database
tables. When a database table rolls, it becomes “mature”, meaning the table will not grow anymore. Therefore, it is
unnecessary to query this database table each time for the same SQL query, so hcache is used. Hcache runs queries
on matured database tables in advance and caches the interim results of each query. When it is time to generate the
report, much of the datasets are already assembled, and the system only needs to merge the results from hcaches.
This reduces report generation time significantly.

The auto-cache process uses system resources to assemble and cache the datasets and it takes extra space to save
the query results. You should only enable auto-cache for reports that require a long time to assemble datasets.

Generating reports

You can generate reports by using one of the predefined reports or by using a custom report that you created. You can
find all the predefined reports and custom reports listed in Reports > Report Definitions > All Reports.
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To generate a report:

1. Goto Reports > Report Definitions > All Reports.
2. Inthe content pane, select a report from the list.

3. (Optional) Click Edit in the toolbar and edit settings on the Settings and Layout tabs. For a description of the fields

in the Settings and Layout tabs, see Reports Settings tab on page 117 and Creating charts on page 130 and Macro
library on page 134.

4. Inthe toolbar, click Run Report.

Viewing completed reports

After you generate reports, you can view completed reports in Reports > Generated Reports or Reports > Report
Definitions > All Reports. You can view reports in the following formats: HTML, PDF, XML, and CSV.

To view completed reports in Generated Reports:

1. Goto Reports > Generated Reports.
This view shows all generated reports for the specified time period.
2. To sort the report list by date, click Order by Time.To sort the report list by report name, click Order by Name.
3. Locate the report and click the format in which you want to view the report to open the report in that format.
For example, if you want to review the report in HTML format, click the HTML link.

To view completed reports in All Reports:

1. Goto Reports > Report Definitions > All Reports.
2. Onthe report list, double-click a report to open it.

3. Inthe View Report tab, locate the report and click the format in which you want to view the report to open the
report in that format.

For example, if you want to review the report in HTML format, click the HTML link.

Enabling auto-cache

You can enable auto-cache to reduce report generation time for reports that require a long time to assemble datasets.
For information about auto-cache and hcache, see How auto-cache works on page 112.

You can see the status of building the cache in Reports > Report Definitions > All Reports in the Cache Status
column.

To enable auto-cache:

Go to Reports > Report Definitions > All Reports.

Select the report from the list, and click Edit in the toolbar.
In the Settings tab, select the Enable Auto-cache checkbox.
Click Apply.

AoODbdD=
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Grouping reports

If you are running a large number of reports which are very similar, you can significantly improve report generation time
by grouping the reports. Grouping reports has these advantages:

« Reduce the number of hcache tables.

o Improve auto-hcache completion time.
« Improve report completion time.

Step 1: Configure report grouping

For example, to group reports with titles containing string Security Report by device ID and VDOM, enter the
following CLI commands:

config system report group
edit O
set adom root
config group-by

edit devid
next
edit vd
next
end
set report-like Security Report
next
end
Notes:

« The report-1ike field specifies the string in report titles that is used for report grouping. This string is case-
sensitive.

« The group-by value controls how cache tables are grouped.

« To view report grouping information, enter the following CLI command, then check the Report Group column of the
table that is displayed.
execute sgl-report list-schedule <ADOM>

Step 2: Initiate a rebuild of hcache tables

To initiate a rebuild of hcache tables, enter the following CLI command:

diagnose sgl hcache rebuild-report <start-time> <end-time>

Where <start-time>and <end-time> are in the format: <yyyy-mm-dd hh:mm:ss>.

Retrieving report diagnostic logs

Once you start to run a report, FortiAnalyzer creates a log about the report generation status and system performance.
Use this diagnostic log to troubleshoot report performance issues. For example, if your report is very slow to generate,
you can use this log to check system performance and see which charts take the longest time to generate.

For information on how to interpret the report diagnostic log and troubleshoot report performance issues, see the
FortiAnalyzer Report Performance Troubleshooting Guide.
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To retrieve report generation logs:

1. In Reports > Generated Report, right-click the report and select Retrieve Diagnostic to download the log to your
computer.

2. Use atext editor to open the log.

Auto-Generated Reports

The Cyber Threat Assessment report is automatically generated. By default, the report will run at 3:00AM every
Monday. For more information on report scheduling, see Scheduling reports on page 115.

Schedules can be viewed in the Report Calendar. See Report calendar on page 141.

Al
‘Q' This will only affect newly installed FortiAnalyzer or newly created ADOM. Upgraded ADOM
- reports, scheduling and calendar will be kept as is.

Scheduling reports

You can configure a report to generate on a regular schedule. Schedules can be viewed in the Report Calendar. See
Report calendar on page 141.

To schedule a report:

Go to Reports > Report Definitions > All Reports.

Select a report and click Edit in the toolbar.

Click Settings in the toolbar.

Select the Enable Schedule checkbox and configure the schedule.
Click Apply.

o~ oODdD=

Creating reports

You can create reports from report templates, by cloning and editing predefined/existing reports, or start from scratch.

Creating reports from report templates

You can create a new report from a template. The template populates the Layout tab of the report. The template
specifies what text, charts, and macros to use in the report and the layout of the content. Report templates do not
contain any data. Data is added to the report when you generate the report.
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To create a new report from a template:

1.
2.
3.

10.

If using ADOMSs, ensure that you are in the correct ADOM.
Go to Reports > Report Definitions > All Reports.
In the toolbar, click Create New. The Create Report dialog box opens.

Create Report

Name
Create from Blank
(® From Template
Template - Cyber Threat Assessment

Save to Folder B& Al Reports

o

In the Name box, type a name for the new report. The following characters are NOT supported in report names: \ /"
'<>&, |#?%$+

Select From Template for the Create from setting, then select a template from the dropdown list. The template
populates the Layout tab of the report.

Select the folder that the new report will be saved to from the dropdown list. See Organizing reports into folders on
page 125 for information about folders.

Select OK to create the new report.

On the Settings tab, configure the settings as required. For a description of the fields, see Reports Settings tab on
page 117.

Optionally, go to the Layout tab to customize the report layout and content. For a description of the fields, see
Reports Layout tab on page 120.

Click Apply to save your changes.

Creating reports by cloning and editing

You can create reports by cloning and editing predefined and/or existing reports.

To create a report by cloning and editing:

AoODdD =

If using ADOMSs, ensure that you are in the correct ADOM.
Go to Reports > Report Definitions > All Reports.
In the content pane, select the report from the list, then click Clone in the toolbar.

In the Clone Report dialog box, type a name for the cloned report. The following characters are NOT supported in
report names: \/"'<>&, [#? % $ +

Select the folder that the new report will be saved to from the dropdown list. See Organizing reports into folders on
page 125 for information about folders.

Select OK to create the new report.

On the Settings tab, configure the settings as required. For a description of the fields, see Reports Settings tab on
page 117.

Optionally, go to the Layout tab to customize the report layout and content. For a description of the fields, see
Reports Layout tab on page 120.

Click Apply to save your changes.
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Creating reports without using a template

To create a report without using a template:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the toolbar, click Create New. The Create New Report dialog box opens.

In the Name box, type a name for the new report. The following characters are NOT supported in report names: \ /"

'<>&,|#?%$+

Select the Blank option for the Create from setting.

6. Select the folder that the new report will be saved to from the dropdown list. See Organizing reports into folders on
page 125 for information about folders.

7. Select OK to create the new report.

8. Onthe Settings tab, you can specify a time period for the report, what device logs to include in the report, and so

on. You can also add filters to the report, add a cover page to the report, and so on. For a description of the fields,

see Reports Settings tab on page 117.

AoObd -~
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Settings menu.

x To create a custom cover page, you must select Print Cover Page in the Advanced

9. Onthe Layout tab, you can specify the charts and macros to include in the report, as well as report content and
layout.
For a description of the fields, see Reports Layout tab on page 120.

For information about creating charts and macros, see Creating charts on page 130 and Creating macros on page
134.

10. Click Apply to save your changes.

Reports Settings tab

The following options are available in the Settings tab:

Field Description

Time Period The time period the report covers. Select a time period or select Custom to
manually specify the start and end date and time.

Devices The devices to include in the report. Select either All Devices or Specify to add
specific devices. Select the add icon to select devices.
Type Select either Single Report (Group Report) or Multiple Reports (Per-Device).
This option is only available if multiple devices are selected.
Enable Schedule Select to enable report template schedules.
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Field Description

Enable Auto-Cache Select to assemble datasets before generating the report and as the data is
available. This process uses system resources and is recommended only for
reports that require days to assemble datasets. Disable this option for unused
reports and for reports that require little time to assemble datasets.

Generate PDF Report Every Select when the report is generated.

Enter a number for the frequency of the report based on the time period selected
from the dropdown list.

Start time Enter a starting date and time for the file generation.

End time Enter an ending date and time for the file generation, or set it to never ending.
Enable Notification Select to enable report notification.

Output Profile Select the output profile from the dropdown list, or click Create New to create a

new output profile. See Output profiles on page 138.
Filters section of Reports Settings tab
See Filtering report output on page 124.

Advanced Settings section of Reports Settings tab

The following options are available in the Advanced Settings section of the Settings tab.

Field Description

Language Select the report language.

Bundle rest into “Others” Select to bundle the uncategorized results into an Others category.

Print Orientation Set the print orientation to portrait or landscape.

Chart Heading Level Set the heading level for the chart heading.

Default Font Set the default font.

Hide # Column Select to hide the column numbers.

Layout Header Enter header text and select the header image. Accept the default Fortinet image

or click Browse to select a different image.

Layout Footer Select either the default footer or click Custom to enter custom footer text in the
text field.
Print Cover Page Select to print the report cover page. Click Customize to customize the cover

page. See Customizing report cover pages on page 119.

Print Table of Contents Select to include a table of contents.
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Field Description

Print Device List Select to print the device list. Select Compact, Count, or Detailed from the
dropdown list.

Print Report Filters Select to print the filters applied to the report.

Obfuscate User Select to hide user information in the report.

Resolve Hostname Select to resolve hostnames in the report.

Allow Save Maximum Select a value between 1-10000 for the maximum number of reports to save.
Color Code The color used to identify the report on the calendar. Select a color code from the

dropdown list to apply to the report schedule. Color options include: Bold Blue,
Blue, Turquoise, Green, Bold Green, Yellow, Orange, Red, Bold Red, Purple,
and Gray.

Customizing report cover pages

A report cover page is only included in the report when enabled on the Settings tab in the Advanced Settings section.

When enabled, the cover page can be customized to contain the desired information and imagery.

To customize a report cover page:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the content pane, select the report from the list, and click Edit in the toolbar.
Select the Settings tab and then click Advanced Settings.

Select the Print Cover Page checkbox, then click Customize next to the checkbox. The Edit Cover Page pane
opens.

o r oD

Edit Cover Page

Background Image Browse...

def_cove...png

Top Image Browse...
Top Image Position Center
Text Color W Black

{8 show Creation Time

FEATINET Show Data Range
Report Title (default]

360-Degree Security Review Custom Toxt 1
02, 201 0701

Report Date: June
Provirvrvpts

Data Range: 2016-06-01 07.01 2016.06-02 07-01 (FAZ local) Custom Text 2

Bottom Image Browse...
Footer Left Text (default)
Footer Right Text {default}

Footer Background Color Gray
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6. Configure the following settings:

Background Image

Top Image

Top Image Position

Text Color

Show Creation Time
Show Data Range
Report Title

Custom Text 1
Custom Text 2

Bottom Image

Footer Left Text
Footer Right Text

Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image as the background image of the
cover page.

Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image at the top of the cover page.

Select the top image position from the dropdown menu. Select one of the
following: Left, Center, Right.

Select a text color from the dropdown list.

Select to print the report date on the cover page.

Select to print the data range on the cover page.

Accept the default title or type another title in the Report Title field.
If you want, enter custom text for the Custom Text 1 field.

If you want, enter custom text for the Custom Text 2 field.

Click Browse to open the Choose an Image dialog box.

Select an image or click Upload File to find an image on the management
computer, then click OK to add the image to the bottom of the cover page.

If you want, enter custom text to be printed in the left footer of the cover page.

If you want, enter custom text to be printed in the right footer of the cover

page.
Footer Background Color Select the cover page footer background color from the dropdown list.

Reset to Default Select to reset the cover page settings to their default settings.

7. Click OK to save the configurations and return to the Settings tab.

Reports Layout tab

Because the cut, copy, and paste functions need access to the clipboard of your operating

system, some Internet browsers either block it when called from the layout editor toolbar, or
ask you to explicitly agree to it. If you're blocked from accessing the clipboard by clicking the
respective cut, copy and paste buttons from the toolbar or context menu, you can always use
keyboard shortcuts.
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The following options are available in the Layout tab (layout editor):

Field Description

Insert Chart or Edit Chart Click to insert a FortiAnalyzer chart. Charts are associated with datasets that
extract data from logs for the report.
In the Insert Chart or Chart Properties dialog box, you can specify a custom title,
width, and filters for the chart. For information on setting filters, see Filtering
report output on page 124.
You can edit a chart by right clicking the chart in the layout editor and selecting
Chart Properties or by clicking the chart to select it and then clicking Edit Chart.

Insert Macro Click to insert a FortiAnalyzer macro. Macros are associated with datasets that
extract data from logs for the report.

Image Click the Image button in the toolbar to insert an image into the report layout.
Right-click an existing image to edit image properties.

Table Click the Table button in the toolbar to insert a table into the report layout. Right-
click an existing table to edit a cell, row, column, table properties, or delete the
table.

Insert Horizontal Line Click to insert a horizontal line.

Insert Page Break for Printing Click to insert a page break for printing.

Link Click the Link button in the toolbar to open the Link dialog box. You can select to
insert a URL, a link to an anchor in the text, or an email address. Alternatively,
use the CTRL+L keyboard shortcut to open the Link dialog box.

Anchor Click the Anchorbutton in the toolbar to insert an anchor in the report layout.

Cut To cut a text fragment, start with selecting it. When the text is selected, you can
cut it using one of the following methods:
o Click the cut button in the toolbar
« Right-click and select cut in the menu
o Use the CTRL+X shortcut on your keyboard.

Copy To cut a text fragment, start with selecting it. When the text is selected, you can
cut it using one of the following methods:
o Click the cut button in the toolbar
« Right-click and select cut in the menu
o Use the CTRL+C shortcut on your keyboard.

Paste To paste text, start with cutting or copying from another source. Depending on
the security settings of your browser, you may either paste directly from the
clipboard or use the Paste dialog box.

Paste as plain text Click Paste as plain text to paste formatted text without the formatting. If the
browser blocks the editor toolbar’s access to clipboard, a Paste as Plain Text
dialog box appears and you can paste the fragment into the text box using the
CTRL+V keyboard shortcut.
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Field Description

Paste from Word

Undo

Redo

Find

Replace

Save as Template

Paragraph Format

Font Name

Font Size

You can preserve basic formatting when you paste a text fragment from Microsoft

Word. To achieve this, copy the text in a Word document and paste it using one
of the following methods:

« Click the Paste from Word button in the toolbar

o Usethe CTRL+V shortcut on your keyboard.

Click to undo the last action. Alternatively, use the CTRL+Z keyboard shortcut to
perform the undo operation.

Click to redo the last action. Alternatively, use the CTRL+Y keyboard shortcut to
perform the redo operation.

Click to find text in the report layout editor. This dialog box includes the following
elements:

« Find what: Is the text field where you enter the word or phrase you want to
find.

o Match case: Checking this option limits the search operation to words
whose case matches the spelling (uppercase and lowercase letters) given in
the search field. This means the search becomes case-sensitive.

« Match whole word. Checking this option limits the search operation to whole
words.

« Match cyclic: Checking this option means that after the editor reaches the
end of the document, the search continues from the beginning of the text.
This option is checked by default.

Click to replace text in the report layout editor. This dialog box includes consists
of the following elements:

o Find what: Is the text field where you enter the word or phrase you want to
find.

« Replace with: Is the text field where you enter the word or phrase that will
replace the search term in the document.

o Match case: Checking this option limits the search operation to words
whose case matches the spelling (uppercase and lowercase letters) given in
the search field. This means the search becomes case-sensitive.

o Match whole word: Checking this option limits the search operation to whole
words.

» Match cyclic: Checking this option means that after the editor reaches the
end of the document, the search continues from the beginning of the text.
This option is checked by default.

Click to save the layout as a template.

Select the paragraph format from the dropdown list. Select one of the following:
Normal, Heading 1, Heading 2, Heading 3, Heading 4, Heading 5, Heading 6,
Formatted, Address, or Normal (DIV).

Select the font from the dropdown list.

Select the font size from the dropdown list. Select a size ranging from 8 to 72.
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Field Description

Bold Select the text fragment and then click the Bold button in the toolbar.
Alternatively, use the CTRL+B keyboard shortcut to apply bold formatting to a
text fragment.

Italic Select the text fragment and then click the /talic button in the toolbar.
Alternatively, use the CTRL+/ keyboard shortcut to apply italics formatting to a
text fragment.

Underline Select the text fragment and then click the Underline button in the toolbar.
Alternatively, use the CTRL+U keyboard shortcut to apply underline formatting
to a text fragment.

Strike Through Select the text fragment and then click the Strike Through button in the toolbar.
Subscript Select the text fragment and then click the Subscript button in the toolbar.
Superscript Select the text fragment and then click the Superscript button in the toolbar.
Text Color You can change the color of text in the report by using a color palette. To choose

a color, select a text fragment, click the Text Colorbutton in the toolbar, and
select a color.

Background Color You can also change the color of the text background.
Insert/Remove Numbered List Click to insert or remove a numbered list.
Insert/Remove Bulleted List Click to insert or remove a bulleted list.

Decrease Indent To decrease the indentation of the element, click the Decrease Indent toolbar
button. The indentation of a block-level element containing the cursor will
decrease by one tabulator length.

Increase Indent To increase the indentation of the element, click the Increase Indent toolbar
button. The block-level element containing the cursor will be indented with one
tabulator length.

Block Quote Block quote is used for longer quotations that are distinguished from the main
text by left and right indentation. It is recommended to use this type of formatting
when the quoted text consists of several lines or at least 100 words.

Align Left When you align your text left, the paragraph is aligned with the left margin and
the text is ragged on the right side. This is usually the default text alignment
setting for the languages with left to right direction.

Center When you center your text, the paragraph is aligned symmetrically along the
vertical axis and the text is ragged on the both sides. This setting is often used in
titles or table cells.

Align Right When you align your text right, the paragraph is aligned with the right margin and
the text is ragged on the left side. This is usually the default text alignment
setting for the languages with right to left direction.

Justify When you justify your text, the paragraph is aligned to both the left and right
margins and the text is not ragged on either side..
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Field Description

Remove Format Click to remove formatting.

Filtering report output
You can apply log message filters to reports and charts.

To filter output in a report:

Click the Settings tab and scroll to the Filters section.

To filter output in a chart:

1. Click the Layout tab.
2. Filter a new or existing chart:
 Click Insert Chart and scroll to the Filters section.
« Right-click a chart in the layout and select Chart Properties. Scroll to the Filters section.

In the Filters section, the following options are available.

Field Description

Log messages that match Available in the Settings tab only.

Select All to filter log messages based on all of the added conditions, or select
Any of the Following Conditions to filter log messages based on any one of the
conditions.

Add Filter Click to add filters. For each filter, select the field, and operator from the
dropdown lists, then enter or select the values as applicable.

Filters vary based on device type.

When adding a filter, keep the following considerations in
mind:
M « The Settings and Layout tabs use the same Log Field list
9 to filter output; however, some log fields are not used in
- charts. The Log Field you use to filter a report may not

apply to the log fields in a chart.
o The Value field is case sensitive.

LDAP Query Available in the Settings tab only.

Click to add an LDAP query, then select the LDAP Serverand the Case Change
value from the dropdown lists.

Use this option to query an LDAP server for group membership. The results of
this query is used to filter the report to only match logs for users belonging to that
group.

You must specify the group name in the filter definition.
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Field Description

If you enable LDAP Query, the group name is not used to match the group field
in logs. The group name is only used for the LDAP query to determine group
membership.

The query will not retrieve the userPrincicpalName if the
& Y P Distinguished Name in the System Settings does not contain
9 an organization unit (ou). To retrieve the UPN, add the
= Distinguished Name as it appears in the System Settings to
your query.

vy
‘?' If both chart and report filters are selected for the same report, the chart filter will be used
- instead of the report filter.

Managing reports

You can manage reports by going to Reports > Report Definitions > All Reports. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click a report to display the menu.

Option Description

Create New Creates a new report. You can choose whether to base the new report on a report
template.

Edit Edits the selected report.

Delete Deletes the selected report.

Clone Clones the selected report.

Run report Generates a report.

Folder Organizes reports into folders.

Import Imports a report from a management computer.

Export Exports a report to a management computer.

Show Scheduled Only Filters the list to include only reports that have been run or are scheduled to be
run.

Organizing reports into folders

You can create folders to organize reports.
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To organize reports into folders:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

Click Folderin the toolbar, and select Create New Folder.

Specify the folder name and location and click OK. The folder is now displayed in the report list.

AoObd -~

You can now create, clone, or import reports into this folder.

Importing and exporting reports

You can transport a report between FortiAnalyzer units. You can export a report from the FortiAnalyzer unit to the

management computer. The report is saved as a .dat file on the management computer. You can then import the report

file to another FortiAnalyzer unit.

Exporting reports only exports the report layout, charts, datasets, and images. Other report
configurations are not exported.

To export reports:

If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > All Reports.

3. Inthe content pane, select a report, and select More > Export in the toolbar to save the file to the management
computer.

To import reports:

If using ADOMSs, ensure that you are in the correct ADOM.
Go to Reports > Report Definitions > All Reports.
In the content pane, click More > Import in the toolbar. The Import Report dialog box opens.

Drag and drop the report file onto the dialog box, or click Browse and locate the file to be imported on your local
computer.

Ao bd=

o

Select a folder to save the report to from the dropdown list.
6. Click OKto import the report.

Report template library

Because the cut, copy, and paste functions need access to the clipboard of your operating
system, some Internet browsers either block it when called from the layout editor toolbar, or

ask you to explicitly agree to it. If you're blocked from accessing the clipboard by clicking the
respective cut, copy and paste buttons from the toolbar or context menu, you can always use
keyboard shortcuts.

A report template defines the charts and macros that are in the report, as well as the layout of the content.
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You can use the following items to create a report template:
o Text
« Images
« Tables
o Charts that reference datasets
+ Macros that reference datasets

Datasets for charts and macros specify what data are used from the Analytics logs when you generate the report. You
can also create custom charts and macros for use in report templates.

Creating report templates
You can create a report template by saving a report as a template or by creating a totally new template.

To create a report template:

If using ADOMSs, ensure that you are in the correct ADOM.
Go to the Reports > Report Definitions> Templates.

In the toolbar of the content pane, click Create New.

Set the following options:

a. Name.

AoODdD =

b. Description.
c. Category. If you are in a Security Fabric ADOM, the Category must be SecurityFabric.
d. Language.

5. Use the toolbar to insert and format text and graphics for the template. In particular, use the Insert Chart and
Insert Macro buttons to insert charts and macros into the template.
For a description of the fields, see Reports Layout tab on page 120. For information about creating charts and
macros, see Creating charts on page 130 and Creating macros on page 134.

6. Click OK.
The new template is now displayed on the template list.

To create a report template by saving a report:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > All Reports.

In the content pane, select the report from the list, and click Edit in the toolbar.
In the Layout tab, click the Save As Template button in the toolbar.

In the Save as Template dialog box, set the following options, and click OK:
a. Name.

oD

b. Description.

c. Category. If you are in a Security Fabric ADOM, the Category must be SecurityFabric.
The new template is now displayed on the template list.
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Viewing sample reports for predefined report templates
You can view sample reports for predefined report templates to help you visualize how the reports would look.

To view sample reports:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Gotothe Reports > Report Definitions > Templates.

3. Inthe content pane, click the HTML or PDF link in the Preview column of a template to view a sample report
based on the template.

Managing report templates

You can manage report templates in Reports > Report Definitions> Templates. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click a template to display the menu.

Option Description

Create New Creates a new report template

Edit Edits a report template. You can edit report templates that you created. You
cannot edit predefined report templates.

View Displays the settings for the predefined report template. You can copy elements
from the report template to the clipboard, but you cannot edit a predefined report
template.

Delete Deletes the selected report template. You cannot delete predefined report
templates.

Clone Clones the selected report template.

Create Report Creates the selected report template.

Install Template Pack Upload and install a template pack.

List of report templates

FortiAnalyzer includes report templates you can use as is or build upon when you create a new report. FortiAnalyzer
provide different templates for different devices.

You can find report templates in Reports > Report Definitions > Templates.

FortiGate report templates

Template - 360 Protection Report Template - Security Events and Incidents Summary
Template - 360-Degree Security Review Template - Self-Harm and Risk Indicators Report
Template - Admin and System Events Report Template - Situation Awareness Report
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Template - Application Risk and Control
Template - Bandwidth and Applications Report

Template - Client Reputation

Template - Cyber Threat Assessment

Template - Cyber-Bullying Indicators Report
Template - DNS Report

Template - Data Loss Prevention Detailed Report
Template - Detailed Application Usage and Risk
Template - Email Report

Template - FortiGate Performance Statistics Report
Template - GTP Report

Template - High Bandwidth Application Usage Report
Template - Hourly Website Hits

Template - IPS Report

Template - PCI-DSS Compliance Review

Template - SaaS Application Usage Report

Template - Security Analysis

FortiCache report templates

Template - FortiCache Default Report
Template - FortiCache Security Analysis
Template - FortiCache Web Usage Report

FortiClient report templates

Template - FortiClient Default Report

Template - FortiClient Vulnerability Scan Report

FortiDDoS report templates

Template - FortiDDoS Default Report

FortiAnalyzer 6.2.3 Administration Guide
Fortinet Technologies Inc.

Template - Social Media Usage Report
Template - Threat Report

Template - Top 20 Categories and Applications
(Bandwidth)

Template - Top 20 Categories and Applications (Session)
Template - Top 20 Category and Websites (Bandwidth)
Template - Top 20 Category and Websites (Session)
Template - Top 500 Sessions by Bandwidth

Template - Top Allowed and Blocked with Timestamps
Template - User Detailed Browsing Log

Template - User Security Analysis

Template - User Top 500 Websites by Bandwidth
Template - User Top 500 Websites by Session
Template - VPN Report

Template - Web Usage Report

Template - What is New Report

Template - WiFi Network Summary

Template - Wireless PCl Compliance
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FortiMail report templates

Template - FortiMail Analysis Report
Template - FortiMail Default Report

FortiProxy report templates

Template - FortiProxy Default Report
Template - FortiProxy Security Analysis
Template - FortiProxy Web Usage Report

FortiSandbox report templates

Template - Endpoint Sandbox Detections Report
Template - FortiSandbox Default Report

FortiWeb report templates

Template - Fortiweb Default Report

Template - FortiWeb Web Application Analysis Report

Fabric report templates

Template - Fortinet Email Risk Assessment

Chart library

Use the Chart library to create, edit, and manage your charts.

In a Security Fabric ADOM, you can insert charts from all device types into a single report.

Creating charts

Al
S L4
9 You can also create charts using the Log View Chart Builder. See Creating charts on page 51.
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To create charts:

1.
2.
3.

If using ADOMSs, ensure that you are in the correct ADOM.
Go to Reports > Report Definitions > Chart Library.
Click Create New in the toolbar.

Create Chart

Name
Description
Dataset

Resolve
Hostname

Inherit

Chart Type Table

Data Bindings Table Type

App-Risk-App-Usage-By-Category

@® Regular O Ranked O Drilldown

Columns

(e

Column 1

Title

appca

Width [0
Data Binding
appcat

{5 Order By

t
21| % (0 for Auto)

Format

v Default

appcat

Show Top (O for all results) 10 |2

4. Configure the settings for the new chart, the click OK.
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Name
Description

Dataset

Resolve Hosthame

Chart Type

Data Bindings
Table

Table Type
Add Column

Columns
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Enter a name for the chart.
Enter a description of the chart.

Select a dataset from the dropdown list. For more information, see Datasets
on page 136. Options vary based on device type.

Select to resolve the hostname. Select one of the following: Inherit, Enabled,
or Disabled.

Select a graph type from the dropdown list; one of: Table, Bar, Pie, Line,
Area, Donut, or Radar. This selection affects the rest of the available
selections.

The data bindings vary depending on the chart type selected.

Select Regular, Ranked, or Drilldown.

Select to add a column. Up to 15 columns can be added for a Regulartable.
Ranked tables have two columns, and Drilldown tables have three columns.

The following column settings must be set:

o Column Title: Enter a title for the column.

« Width: Enter the column width as a percentage.

« Data Binding: Select a value from the dropdown list. The options vary
depending on the selected dataset.

« Format: Select a value from the dropdown list.

» Add Data Binding: Add data bindings to the column. Every column must
have at least one data binding. The maximum number varies depending
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Bar

Order By

Show Top

Drilldown
Top

X-Axis

Y-axis

Bundle rest
into "Others"

Group By

Order By

Pie, Donut, or Radar

Line or Area

Category

Series

Bundle rest
into "Others"

X-Axis

FortiAnalyzer 6.2.3 Administration Guide
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on the table type.

Select what to order the table by. The available options vary depending on the
selected dataset.

Enter a numerical value. Only the first ‘X’ items are displayed. Other items
can be bundled into the Others category for Ranked and Drilldown tables.

Enter a numerical value. Only the first ‘X’ items are displayed. This options is
only available for Drilldown tables.

Data Binding: Select a value from the dropdown list. The available
options vary depending on the selected dataset.

Label: Enter a label for the axis.

Show Top: Enter a numerical value. Only the first ‘X’ items are displayed.
Other items are bundled into the Others category.

Data Binding: Select a value from the dropdown list. The available
options vary depending on the selected dataset.

Format: Select a format from the dropdown list: Bandwidth, Counter,
Default, Percentage, or Severity.

Label: Enter a label for the axis.

Select to bundle the rest of the results into an Others category.

Data Binding: Select a value from the dropdown list. The available
options vary depending on the selected dataset.

Show Top: Enter a numerical value. Only the first ‘X’ items are displayed.
Other items can be bundled into the Others category.

Select to order by the X-Axis or Y-Axis.

L]

Data Binding: Select a value from the dropdown list. The available
options vary depending on the selected dataset.

Label: Enter a label for the axis.

Show Top: Enter a numerical value. Only the first ‘X’ items are displayed.
Other items can be bundled into the Others category.

Data Binding: Select a value from the dropdown list. The available
options vary depending on the selected dataset.

Format: Select a format from the dropdown list: Bandwidth, Counter,
Default, Percentage, or Severity.

Label: Enter a label for the axis.

Select to bundle the rest of the results into an Others category.

Data Binding: Select a value from the dropdown list. The available
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options vary depending on the selected dataset.
o Format: Select a format from the dropdown list: Default, or Time.
« Label: Enter a label for the axis.

Lines « Data Binding: Select a value from the dropdown list. The available
options vary depending on the selected dataset.
« Format: Select a format from the dropdown list: Bandwidth, Counter,
Default, Percentage, or Severity.
o Type: Select the type from the dropdown list: Line Up or Line Down.
« Legend: Enter the legend text for the line.

Add line Select to add more lines.

Managing charts

Manage your charts in Reports > Report Definitions > Chart Library. Some options are available as buttons on the
toolbar. Some options are available in the right-click menu. Right-click a chart to display the menu.

Option Description

Create New Creates a new chart.

Edit Edits a chart. You can edit charts that you created. You cannot edit predefined
charts.

View Displays the settings for the selected predefined chart. You cannot edit a

predefined chart.

Delete Deletes the selected chart. You can delete charts that you create. You cannot
delete predefined charts.

Clone Clones the selected chart.

Import Imports a previously exported FortiAnalyzer chart.
Export Exports one or more FortiAnalyzer charts.

Show Predefined Displays the predefined charts.

Show Custom Displays the custom charts.

Search Lets you search for a chart name.

Viewing datasets associated with charts

To view datasets associated with charts:

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Report Definitions > Chart Library.

Select a chart, and click View in the toolbar.

In the View Chart pane, find the name of the dataset associated with the chart in the Dataset field.
Go to Reports > Report Definitions > Datasets.

o roODdD =
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6. Inthe Search box, type the name of the dataset.
7. Select the dataset that is found, and click View in the toolbar to view it.

Macro library

Use the Macro library to create, edit, and manage your macros.

Creating macros

FortiAnalyzer includes a number of predefined macros. You can also create new macros, or clone and edit existing
macros.

Macros are predefined to use specific datasets and queries. They are organized into categories, and can be added to,
removed from, and organized in reports.

Ay
b [ 4
? Macros are currently supported in FortiGate and FortiCarrier ADOMs only.

To create a new macro:

1. If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > Macro Library, and click Create New. The Create Macro pane is displayed.
Create Macro

Name
Description
Dataset App-Risk-App-Usage-By-Category
Query elect appcat, sum(coalesce(sentbyte, O)}+coalesce(rcvdbyte, C
flag&1>0 d nullifna(appcat) is not nu oup by appcat order by bandwidth desc
Data Binding

Display Text

=
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3. Provide the required information for the new macro.

Name Enter a name for the macro.

Description Enter a description of the macro.

Dataset Select a dataset from the dropdown list. The options will vary based on device
type.

Query Displays the query statement for the dataset selected.

Data Binding The data bindings vary depending on the dataset selected. Select a data

binding from the dropdown list.

Display Select a value from the dropdown list.

4. Click OK. The newly created macro is shown in the Macro library.

Managing macros

You can manage macros by Reports > Report Definitions > Macro Library. Some options are available as buttons on
the toolbar. Some options are available in the right-click menu. Right-click a macro to display the menu.

Option Description

Create New Creates a new macro.

Edit Edits the selected macro. You can edit macros that you created. You cannot edit
predefined macros.

View Displays the settings for the selected macro. You cannot edit a predefined macro.

Delete Deletes the selected macro. You can delete macros that you create. You cannot
delete predefined macros.

Clone Clones the selected macro.

Show Predefined Displays the predefined macros.
Show Custom Displays the custom macros.
Search Lets you search for a macro name.

Viewing datasets associated with macros

To view datasets associated with macros:

If using ADOMSs, ensure that you are in the correct ADOM.
Go to Reports > Report Definitions> Macro Library.
Select a macro, and click View (for predefined macros) or Edit (for custom macros) in the toolbar.

In the View Macro or Edit Macro pane, find the name of the dataset associated with the macro in the Dataset
field.

5. Goto Reports > Report Definitions> Datasets.

AoObd -~
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6. Inthe Search box, type the name of the dataset.
7. Double-click the dataset to view it.

Datasets

Use the Datasets pane to create, edit, and manage your datasets.

Creating datasets

FortiAnalyzer datasets are collections of data from logs for monitored devices. Charts and macros reference datasets.
When you generate a report, the datasets populate the charts and macros to provide data for the report.

FortiAnalyzer has many predefined datasets that you can use right away. You can also create your own custom
datasets.

To create a new dataset:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > Datasets, and click Create New.
3. Provide the required information for the new dataset.

Name Enter a name for the dataset.

Log Type Select a log type from the dropdown list.

« The following log types are available for FortiGate: Application Control,
Intrusion Prevention, Content Log, Data Leak Prevention, Email Filter,
Event, Traffic, Virus, VolP, Web Filter, Vulnerability Scan, FortiClient
Event, FortiClient Traffic, FortiClient Vulnerability Scan, Web
Application Firewall, GTP, DNS, SSH, and Local Event.

« The following log types are available for FortiMail: Email Filter, Event,
History, and Virus.

« The following log types are available for FortiWeb: Intrusion Prevention,
Event, and Traffic.

Query Enter the SQL query used for the dataset. An easy way to build a custom
query is to copy and modify a predefined dataset's query.

Variables Click the Add button to add variable, expression, and description information.
Test query with specified devices and time period

Time Period Use the dropdown list to select a time period. When selecting Custom, enter
the start date and time, and the end date and time.

Devices Select All Devices or Specify to select specific devices to run the SQL query
against. Click the Select Device button to add multiple devices to the query.

Test Click to test the SQL query before saving the dataset configuration.
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4. Click Test.

The query results are displayed. If the query is not successful, an error message appears in the Test Result pane.

5. Click OK.

Viewing the SQL query of an existing dataset

You can view the SQL query for a dataset, and test the query against specific devices or all devices.

To view the SQL query for an existing dataset:

If using ADOMSs, ensure that you are in the correct ADOM.
2. Goto Reports > Report Definitions > Datasets.

3. Hover the mouse cursor over the dataset on the dataset list. The SQL query is displayed as a tooltip.
You can also open the dataset to view the Query field.

SQL query functions

In addition to standard SQL queries, the following are some SQL functions specific to FortiAnalyzer. These are based

on standard SQL functions.

root domain (hostname)

nullifna (expression)

email domain
email user

from dtime
from itime

The root domain of the FQDN. An example of using this function is:

select devid, root domain(hostname) as website FROM S$log
WHERE 'user'='USERO1' GROUP BY devid, hostname ORDER BY
hostname LIMIT 7

This is the inverse operation of coalesce that you can use to filterout n/a

values. This function takes an expression as an argument. The actual SQL syntax

thisisbaseonis select nullif (nullif (expression, 'N/A'),

'n/a').

In the following example, if the user is n/a, the source IP is returned, otherwise

the username is returned.

select coalesce(nullifna('user'), nullifna('srcip')) as user
src, coalesce(nullifna(root_domain(hostname)),'unknown') as

domain FROM $log WHERE dstport='80' GROUP BY user src,
domain ORDER BY user src LIMIT 7

email domain returns the text after the @ symbol in an email address.
email user returns the text before the @ symbol in an email address. An
example of using this function is:

select 'from' as source, email user('from') as e user, email
domain ('from') as e domain FROM $log LIMIT 5 OFFSET 10

from dtime (bigint) returns the device timestamp without time zone.

from itime (bigint) returns FortiAnalyzer's timestamp without time zone.

An example of using this function is:

select itime, from itime(itime) as faz local time, dtime, from
dtime (dtime) as dev local time FROM Slog LIMIT 3
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Managing datasets

You can manage datasets by going to Reports > Report Definitions > Datasets. Some options are available as buttons
on the toolbar. Some options are available in the right-click menu. Right-click a dataset to display the menu.

Option Description

Create New Creates a new dataset.

Edit Edits the selected dataset. You can edit datasets that you created. You cannot
edit predefined datasets.

View Displays the settings for the selected dataset. You cannot edit predefined
datasets.
Delete Deletes the selected dataset. You can delete datasets that you create. You

cannot delete predefined datasets.

Clone Clones the selected dataset. You can edit cloned datasets.
Validate Validate selected datasets.

Validate All Custom Validates all custom datasets.

Search Lets you search for a dataset name.

Output profiles

Output profiles allow you to define email addresses to which generated reports are sent and provide an option to upload
the reports to FTP, SFTP, or SCP servers. Once created, an output profile can be specified for a report.

Creating output profiles

You must configure a mail server before you can configure an output profile. See Mail Server
on page 212.

To create output profiles:

1. If using ADOMs, ensure that you are in the correct ADOM.
2. Goto Reports > Advanced > Output Profile.
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3. Click Create New. The Create Output Profile pane is displayed.

Create Output Profile

Name

Comments

Output Format GroF HTML XML csv
B3 Email Generated Reports

Subject

Body

Recipients Email Server From

Click here to add a new entry.

B3 Upload Report to Server
Server Type FTP
Server 0.0.0.0
User

Password

Directory

Delete file(s) after uploading

To

+ @

Enter a name for the new output profile.

[ oo
4. Provide the following information, and click OK:
Name
Comments

Output Format

Email Generated Reports
Subject
Body

Recipients

Upload Report to Server
Server Type
Server
User
Password
Directory

Delete file(s) after
uploading

Managing output profiles

Enter a comment about the output profile (optional).

Select the format or formats for the generated report. You can choose PDF,
HTML, XML, or CSV format.

Enable emailing of generated reports.
Enter a subject for the report email.
Enter body text for the report email.

Select the email server from the dropdown list and enter to and from email
addresses. Click Add to add another entry so that you can specify multiple
recipients.

Enable uploading of generated reports to a server.
Select FTP, SFTP, or SCP from the dropdown list.
Enter the server |IP address.

Enter the username.

Enter the password.

Specify the directory where the report will be saved.

Select to delete the generated report after it has been uploaded to the
selected server.

You can manage output profiles by going to Reports > Advanced > Output Profile. Some options are available as
buttons on the toolbar. Some options are available in the right-click menu. Right-click an output profile to display the
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menu.
Option Description
Create New Creates a new output profile.
Edit Edits the selected output profile.
Delete Deletes the selected output profile.

Report languages
You can specify the language of reports when creating a report.

Exporting and modifying a language

You can export a language and modify it to create a different language or modify the text in a predefined language.

One way to create a new language is to export a predefined language, modify the text to a different language, save the
file as a different language name, and import it back into FortiAnalyzer. The file name must be one of the languages in
the Advanced Settings section of the Reports Settings tab > Language dropdown list. See Advanced Settings section of
Reports Settings tab on page 118.

If you want to modify a predefined language, export the predefined language, modify the text, and import it back into
FortiAnalyzer.

To export and modify a language:

Go to Reports > Advanced > Language.

Select a language and click Export. The language is exported as a zip file into your default downloads folder.
Extract the zip file and use a text editor to modify it.

Change the text after the equal sign (=) to a different language or text.

O~ OODdD-=

Zip the modified file. The file name must be one of the languages in the Advanced Settings section of the Reports
Settings tab > Language dropdown list. See Advanced Settings section of Reports Settings tab on page 118.

The new language file is ready to be imported into FortiAnalyzer.

Importing a language

To import a language:

1. Goto Reports > Advanced > Language.
2. Click Import and locate the language file.

The language file must be a zip file with only one language file in it. Both the language file name and zip file name
must be one of the language names in the Advanced Settings section of the Reports Settings tab > Language
dropdown list. See Advanced Settings section of Reports Settings tab on page 118.

3. Import the language zip file.

FortiAnalyzer 6.2.3 Administration Guide 140
Fortinet Technologies Inc.



Reports

In Reports > Advanced > Language, you can select this language when you create or run reports.

Report calendar

You can use the report calendar to view all the reports that are scheduled for the selected month. You can edit or disable
upcoming report schedules, as well as delete or download completed reports.

Viewing all scheduled reports

To view all scheduled reports:

o0 ~w

If using ADOMSs, ensure that you are in the correct ADOM.

Go to Reports > Advanced > Report Calendar.
< > today June 2018

w Sun Mon Tue Wed Thu Fri Sat
22 1 2
(£ 3:00 AM Admin and System Event] (= 3:00 AM Admin and System Event)

23 3 4 5 6 7 8 9
(7300 AM Adrrin and System Event) (5 3:00 AM Adrin and System Even (5 3:00 AM Admin and System Event) (] 12:00 AM Security Analysis ) (0 12:00 AM Banduwidth and Applica) () 3:00 AM Admin and System Event) () 3:00 AM Admin and System Event)
(£ 12:00 AM Top 20 Categories and ) (5 3:00 AM Admin and System Event)
((/12:00 AM VPN Report
(5 12:00 AM Web Usage Report |
+2 mare
24 10 1 12 13 14 15 16
((573:00 AM Adrmin and System Event) (5 3:00 AM Admin and System Event () 3:00 AM Admin and System Event (£ 12:00 AM Security Analysis ) (5 12:00 AM Bandwidth and Applica) () 3:00 AM Admin and System Event) () 3:00 AM Admin and System Event)
((=12:00 AM Top 20 Categories and J () 3:00 AM Admin and System Event|
((112:00 AM VPN Report
(1200AM Vit Ussge ot

+2 more

25 17 18 19 20 21 22 23
((213:00 AM Admin and System Event) (= 3:00 AM Admin and System Event) () 3:00 AM Admin and System Event, (=] 12:00 AM Security Analysis ) (5 12:00 AM Bandwidth and Applica) (=) 3:00 AM Admin and System Event] () 3:00 AM Admin and System Event)
((5/12:00 AM Top 20 Categories and ) (5 3:00 AM Admin and System Event|
() 12:00 AM VPN Report
(100 AMVieb Usage Report)

+2 mare

26 24 25 26 27 28 29 30
(2300 AM Admin and System Event) (5 3:00 AM Admin and System Event) () 3:00 AM Admin and System Event (=] 12:00 AM Security Analysis () 12:00 AM Bandvwith and Applica) (5 3:00 AM Admin and System Event) () 3:00AM Admin and System Event)
((=12:00 AM Top 20 Categories and J (= 3:00 AM Admin and System Event|
((112:00 AM VPN Report
(£ 12:00 AM Web Usage Report |

+2 more

Hover the mouse cursor over a calendar entry to display the name, status, and device type of the scheduled report.

Click a generated report to download it.
Click a scheduled report to go to the Settings tab of the report.

Click the left or right arrow at the top of the Report Calendar pane to change the month that is displayed. Click

Today to return to the current month.

Managing report schedules

You can manage report schedules in Reports > Advanced > Report Calendar.

To edit a report schedule:

1.
2.

In Report Calendar, right-click an upcoming calendar entry, and select Edit.
In the Settings tab of the report that opens, edit the corresponding report schedule.

FortiAnalyzer 6.2.3 Administration Guide
Fortinet Technologies Inc.

141



Reports

To disable a report schedule:

In Report Calendar, right-click an upcoming calendar entry, and select Disable. All scheduled instances of the report
are removed from the report calendar. Completed reports remain in the report calendar.

To delete or download a completed report:

In Report Calendar, right-click a past calendar entry, and select Delete or Download. The corresponding completed
report will be deleted or downloaded.

Ay
‘Q' You can only delete or download scheduled reports that have a Finished status. You cannot
- delete scheduled reports with a Pending status.
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FortiRecorder

The FortiRecorder module allows you to set up, manage, and view cameras directly through the FortiAnalyzer GUI.

Cameras can be set to record continuously and/or when motion is detected. Recorded video is stored in the root storage
of the FortiAnalyzer device, however, it can be accessed from other ADOMs.

FortiRecorder includes two panes:

o Camera Manager. Allows you to configure devices, profiles, and schedules.
o Monitor. Allows you to view streaming and recorded video from configured devices.

When upgrading from FortiAnalyzer 6.2.0 to 6.2.1 and later, previously enabled cameras are
disabled until a new camera key has been created. Once created, cameras can be re-enabled.

See Creating a camera key on page 143.

) ! 7, The FortiRecorder module and its features are only available in select FortiAnalyzer
q appliances and is disabled by default. See Enabling and disabling FortiRecorder on page 152
- and Supported platforms and cameras on page 152.
\‘ ! 'l . . . .
9 Third-party cameras are not supported in the FortiRecorder module. For a list of supported
- cameras, see Supported platforms and cameras on page 152.

Configuring cameras in the Camera Manager

In the Camera Manager pane, you can set up and manage the cameras connected to the FortiAnalyzer FortiRecorder
module.

This section includes the following topics:

« Creating a camera key on page 143

« Setting up a camera on page 144

o Configuring camera profiles on page 144

« Configuring video profiles on page 147

« Creating and editing camera schedules on page 148
« Assigning camera schedules to a profile on page 148
« Enabling motion detection on page 150

Creating a camera key

In order to enable cameras in the FortiRecorder module, a camera key must be created.

Camera keys are used by FortiAnalyzer to generate camera admin and operator passwords.
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Only one camera key is required per FortiAnalyzer.

To set a camera key in the CLI:

config fortirecorder global
set camera key
end

Setting up a camera

New cameras automatically detected by FortiAnalyzer will appear in the FortiRecorder > Camera dashboard.
In order for FortiAnalyzer to detect cameras automatically, the cameras must be:

« Assigned a DHCP address through a connected FortiGate.
« Connected with Power over Ethernet (PoE) to the FortiAnalyzer.

If a DHCP server is not available, cameras can also be set up with a static IP address through the Create New menu in
the Camera dashboard.

A camera key must be set before cameras can be activated in FortiAnalyzer. See Creating a camera key on page 143.

To activate a camera detected by the FortiAnalyzer:

1. Goto FortiRecorder > Camera Manager > Camera.
2. Select the Unauthorizedfilter.

3. Right-click a detected camera and select Authorize.
The Edit Camera Device menu will open.

4. Configure the camera settings, then select OK.
Camera settings will vary depending on the model of camera detected. For information on the individual camera
settings, see the FortiRecorder Administration Guide.

5. Once successfully authorized, the camera will be enabled.

\ﬂ If a camera fails to connect, it will be displayed with an erroricon. Right-click the device to

Disable it and then attempt to Enable it again. This will reload the default settings for the
device and may correct issues which are preventing it from connecting successfully.

N ! /., In a HA configuration, FortiRecorder devices should only be configured on the FortiAnalyzer
q device on which they were set up. When attempting to modify a camera being managed by
3 another device, a warning message will be displayed.

Configuring camera profiles

Camera profiles define which video profile, schedules, recording types, and storage options are set for each camera.

You can modify the default camera profiles, create new profiles, or clone an existing profile in the Camera Profile
dashboard.
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To create or edit a camera profile:

1. Goto FortiRecorder > Camera Manager > Camera Profile.
2. Click Create New or select an existing camera profile and click Edit.
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3. Configure the following information:

Name
Video Profiles

Recording profile

Viewing profile

Schedule

Recording & Detection
Settings

Recording type

Schedule

Storage Options

Continuous
recordings

Detection
recordings

4. Select OK.

Enter a name to identify the camera profile.

Select a video profile from the dropdown list to set the resolution, frames per
second, video codec, bitrate, quality, and audio of the recorded video. See
Configuring video profiles on page 147.

Select a video profile from the dropdown list to set the resolution, frames per
second, video codec, bitrate, quality, and audio of the streaming video. See
Configuring video profiles on page 147.

By default, the schedule is set to Always.

New schedules can initially only be added through the FortiAnalyzer CLI. See
Assigning camera schedules to a profile on page 148.

Select the recording type(s).
o Continuous: Records video for the entire duration of the schedule,
regardless of movement.
« Motion detection: Records a video clip each time the camera's sensor
detects movement.
See Enabling motion detection on page 150.

By default, the schedule is set as Always.

New schedules can initially only be added through the FortiAnalyzer CLI. See
Assigning camera schedules to a profile on page 148.

Select the storage options for continuous recordings:
o Keep until overwritten: Retain video until all available disk space is
nearly full. The oldest video will be overwritten.
o Delete: Remove video when it exceeds the specified maximum age.
Note that if the disk is full before the maximum age is reached, the oldest
video will still be overwritten.

Select the storage options for detection recordings:

« Keep until overwritten: Retain video until all available disk space is
nearly full. The oldest video will be overwritten.

« Delete: Remove video when it exceeds the specified maximum age.
Note that if the disk is full before the maximum age is reached, the oldest
video will still be overwritten.

« Use continuous recordings if available: If a recording of the detected
event is already stored as a continuous recording, the detection recording
will not be saved to avoid duplication.
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Configuring video profiles

By default, there are three video profiles.

« low-resolution
« med-resolution
« high-resolution

The default video profiles can be customized, and new profiles can be created.

To create or edit a video profile:

1. Goto FortiRecorder > Camera Manager > Video Profile.
2. Click Create New or select an existing video profile and click Edit.
3. Configure the following information:

Name
Video codec

Resolution

Frames per second

Bitrate mode

Bitrate

Quality

Audio enable

4. Select OK.
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Enter a name to identify the video profile.
Select a video codec from Default, H.264 AVC, and H.265 HEVC.

Select the amount of detail in the image from the dropdown menu.

Lower resolutions feature less detail but are faster to transmit.

Higher resolutions produce a clearer image but require more bandwidth. A
higher resolution is preferable if the camera is recording a large space, such
as a parking lot, where small details like faces and license plates could be
important.

Note: Resolution greatly impacts performance, bandwidth, and the rate at
which the disk space is consumed.

Type the number of frames per second (FPS).

Conventional video is 24 frames per second. More frames per second may be
useful if you need to record very fast motion, but increasing FPS will also
increase disk usage and CPU usage.

Select a bitrate:
« Variable: Automatically adjust the stream to the minimum bitrate
required by the current video frames while maintaining video quality.
o Fixed: Manually specify a constant bitrate.
Specifying a bitrate that is too low may result in poor quality.
Specifying a bitrate that is too high may needlessly consume extra
bandwidth.

Type the bitrate that will be used.
This setting appears and is applicable only if the Bitrate mode is Fixed.

Select the video quality from Extra Low, Low, Normal, High, and Extra High.

Toggle to enable or disable audio in the video stream or recording.
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Creating and editing camera schedules

The FortiRecorder module includes one default schedule: Always.

The default schedule can be customized, and new schedules can be created.

To use a custom camera schedule, it must first be assigned to the camera profile through the

» FortiAnalyzer CLI.
I Once assigned, you can use the FortiAnalyzer GUI to select the new schedule for each
recording stream or recording type. See Assigning camera schedules to a profile on page 148.

To create or edit a camera schedule:

1. Goto FortiRecorder > Camera Manager > Schedule.
2. Click Create New or select an existing schedule and click Edit.
3. Configure the following information:

Name Enter a name to identify the camera schedule.
Description Enter a description of the schedule (optional).
Type Select a schedule type:

o Recurring: The schedule happens at specified times on selected days.
« One-time: The schedule happens only during the specified date-range.

Days Select the days you want the camera to begin recording if you have selected
the Recurring schedule type.

All day Select this option if you want the camera to record all day long.

Start time/End time Select the start and end time for the Recurring recording or the start and end
date for the One-time recording.

4. Select Save.

Assigning camera schedules to a profile

By default, camera profiles are set to use the Always schedule.

To assign a custom schedule to a camera profile, you must first enable it through the CLI. Once enabled, a table is
added to the Camera Profile editor which allows you to select the custom schedule.
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S22 FortiRecorder v Camera Manager Monitor

ADOM:root 3

@ Camera

[ Video Profile
© Schedule

Edit Profile

Name [h\th\

o]

Video Profiles
+ CreateNew [% Edit T D
O Recording Stream

O low-resolution
O high-resolution

Recording & Detection Settings
+ CreateNew [% Edit T D

O Recording Type

Viewing Stream
low-resolution

— Use Recording Stream —

Schedule Name

O Continuous, Motion detection test3
O Continuous Always

Storage Options
Continuous recordings Delete v After| 1 Months

Detection recordings Delete .| After[1 Months

[ o

Schedule Name
test1
Always

After the first custom schedule has been enabled on a profile, subsequent schedules can be selected directly through
the GUI. New schedules can be created by clicking the Create New button above the table.

For more information on creating a custom schedule, see Creating and editing camera schedules on page 148.

To enable a recording schedule in the FortiAnalyzer CLI:

config fortirecorder camera profile
edit [profile name]
config recording-schedule
edit [schedule name]
end

To enable a video schedule in the FortiAnalyzer CLI:

config fortirecorder camera profile
edit [profile name]
config video-schedule
edit [schedule name]
end

To assign the schedule through the GUI:

1. Goto FortiRecorder > Camera Manager > Camera Profile.

2. Select the camera profile and click Edit.

A table appears underneath the Video Profiles and/or Recordings & Detections Settings sections, depending on

where you enabled the schedule.

3. Select a recording type or recording stream, then click Edit.

4. Select a schedule from the dropdown menu.
5. Click OK.
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Enabling motion detection

Motion detection can be enabled on cameras through the Camera Profile.

To enable motion detection:

1.
2.

g

N oo A~

Go to FortiRecorder> Camera Profile.
Click Create New or select an existing camera profile and click Edit.

In Recordings & Detections Settings select Motion detection as the recording type.
Both Continuous and Motion detection recording types can be enabled at the same time.

Enter any additional settings you want to configure for this camera profile and click OK.

Go to FortiRecorder > Camera and double click the camera where motion detection is to be enabled.
In the camera settings, select the profile where motion detection is enabled.

Select OK.

Motion detected recordings can be viewed in the Monitor dashboard, and is identified in red in the camera's activity
timeline. See Watching live and recorded video in the Monitor on page 150.

Watching live and recorded video in the Monitor

The Monitor pane allows you to view the streaming and recorded video captured by devices configured to the
FortiAnalyzer.

To view a video stream:

1. Go to FortiRecorder > Monitor.
2. Click Add Widget.
3. Select the device to be displayed from the dropdown menu.
£2% FortiRecorder v Camera Manager Monitor ADOM:root 3 @ >— (& admin v
+ Add Widget
FCM-MD20-c956
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4. Once added, the widget displays the video stream from the selected camera.

£22 FortiRecorder v Camera Manager Monitor

ADOM:root  £3 @ >- (&) admin v

+ Add Widget

FCM-MD20-c966

FCM-MDZB-5966 (GMT ~8788)

FCM-MD20-c966
13:47
Tue 9 April

To watch recorded video:

1. Go to FortiRecorder> Monitor. The recorded video clips for each camera appear in a timeline below the video
stream.

2. Tolocate a video clip, use the scroll wheel on your mouse to zoom in on a time frame. Ensure that your mouse
cursor is centered in the area that you want to zoom in. You can also navigate the timeline by dragging it to the left
orright.

3. Click on a recorded video in the timeline to begin playback.

Time periods in the timeline panel are color-coded:

« Light blue: Recorded video clips.

« Red: Amotion detection-based recording that was not initiated by a schedule.
o White/blank: No recording at that time period.

S2% FortiRecorder v Camera Manager Monitor ADOM:root 13 @ >— (@ admin v

+ Add Widget

FCM-MD20-c966

P o037/037

FCM-MD20-c966 | | 111 ni | Ll

09:00 09:15 09:30 09:45 10:00 10:15 10:30 10:45 11:00 11:15 11:30 11:45 12:00 12:15
Wed 10 April

12:30

4. Toreturn to the live stream from the recording view, click Back to Live.
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NP Video can also be viewed in a Picture in picture mode.

‘9' This option opens a small window which persists outside of the browser.
- To launch Picture in picture mode, select the menu icon on the bottom-right side of the video
and choose Picture in picture.

Enabling and disabling FortiRecorder

By default, the FortiRecorder module is disabled in FortiAnalyzer.

The FortiRecorder module can be enabled or disabled on supported platforms through the FortiAnalyzer CLI.

To enable the FortiRecorder module in the CLI:

config system global
set disable-module none
end

To disable the FortiRecorder module in the CLI:

config system global
set disable-module fortirecorder
end

Supported platforms and cameras

Supported platforms

Below is a list of the FortiAnalyzer appliances that support the FortiRecorder module.

Platform Maximum number of cameras Storage (TB)
FAZ-200F 4 4
FAZ-300F 6 4
FAZ-400E 12 6
FAZ-800F 16 8
FAZ-1000E 30 18
FAZ-2000E 40 30
FAZ-3000F 50 42
FAZ-3700F 60 216
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Supported cameras

The following FortiCamera models are supported in the FortiRecorder module:

« FCM-CB20
« FCM-FD20
« FCM-FD20B
« FCM-FD40
« FCM-MB40
« FCM-MD20
« FCM-MD40
« FCM-0OB30
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System Settings allows you to manage system options for your FortiAnalyzer device.

click the mouse on different navigation panes on the GUI page to access these options.

x Additional configuration options and short-cuts are available using the right-click menu. Right-

This section contains the following topics:

+ Dashboard on page 155

« Logging Topology on page 166

« Network on page 167

+ RAID Management on page 171

« Administrative Domains on page 176
o Certificates on page 185

« Log Forwarding on page 190

« Fetcher Management on page 195
« Event Log on page 200

o Task Monitor on page 202

o SNMP on page 203

« Mail Server on page 212

o Syslog Server on page 214

+ Meta Fields on page 215

« Device logs on page 216

« File Management on page 220

+ Advanced Settings on page 220
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Dashboard

The Dashboard contains widgets that provide performance and status information and enable you to configure basic

system settings.

== Toggle Widgets v

System Information
Host Name
Serial Number
Platform Type
HA Status
System Time
Firmware Version
System Configuration
Current Administrators
Up Time
Administrative Domain

Operation Mode

System Resources

0%

Average CPU Usage

FAZVMé&4

FAZ-VMO0000153588

FAZVMé64

Standalone

Thu Apr 04 12:23:27 2019 PDT
v6.2.0-build 1043 190403 (Interim)
Last Backup : N/A

admin /1 in total

4 hours 26 minutes 12 seconds

66%

Memory Usage

@ FortiAnalyzer VM requires minimum 4GB Memory and 2x vCPU.

Log Receive Monitor - Last 1 Hour

The following widgets are available:

Average Rate ( 0 Logs/Sec )

7%

Disk Usage

(5]

rd

[

License Information o %
B VM License Type Valid 2
I Logging Devices/VDOMs 1of 10,000
GB/Day 0.0 of Unlimited =
VM Storage 63.62 GB of Unlimited
£ Storage Connector Cloud No License -
Service
& FortiGuard Indicators of Compromise  Licensed (Expires 2019-06-18)
Service
Server Location &5 Servers located in US only v
2 Update Server AntiVirus and IPS 96.45.33.88 (=8 Sunnyvale, California, United States)
FortiClient Update 96.45.33.103 (&5 Sunnyvale, California, United States)
Unit Operation o %

FORTINET

FortiAnalyzer-VM64.

Alert Message Console EH80%
Time Message

Apré Total allocated disk quota of ADOMs (63.62 GB) is over the available disk space (63.62 GB). Please check
07:59:17  the quota configuration of ADOMs!

Apra, Upgrade image from v6.2.0-build1041-190402(Interim) to v6.2.0-build1043-190403

07:56:19

Apr3, Total allocated disk quota of ADOMs (63.62 GB) is over the available disk space (63.62 GB). Please check
08:22:09  the quota configuration of ADOMs!

Apr3 Upgrade image from v6.2.0-build1040-190401(Interim) to v6.2.0-build1041-190402

08:19:26

Apr2 Total allocated disk quota of ADOMs (63.62 GB) is over the available disk space (63.62 GB). Please check

16:46-06 the aunta confizuration of ADOMs!

Widget Description

System Information

System Resources

License Information
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Displays basic information about the FortiAnalyzer system, such as up time and
firmware version. You can also enable or disable Administrative Domains and
adjust the operation mode. For more information, see System Information widget
on page 157.

From this widget you can manually update the FortiAnalyzer firmware to a
different release. For more information, see Updating the system firmware on
page 159.

The widget fields will vary based on how the FortiAnalyzer is configured, for
example, if ADOMs are enabled.

Displays the real-time and historical usage status of the CPU, memory and hard
disk. For more information, see System Resources widget on page 161.

Displays how many devices of the supported maximum are connected to the
FortiAnalyzer unit. See License Information widget on page 162.

From this widget you can manually upload a license for VM systems.
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Widget Description

Unit Operation Displays status and connection information for the ports of the FortiAnalyzer unit.
It also enables you to shutdown and restart the FortiAnalyzer unit or reformat a
hard disk. For more information, see Unit Operation widget on page 163.

Alert Message Console Displays log-based alert messages for both the FortiAnalyzer unit and connected
devices. For more information, see Alert Messages Console widget on page 163.

Log Receive Monitor Displays a real-time monitor of logs received. You can view data per device or per
log type. For more information, see Log Receive Monitor widget on page 164.

Insert Rate vs Receive Rate Displays the log insert and receive rates. For more information, see Insert Rate
vs Receive Rate widget on page 164.
The Insert Rate vs Receive Rate widget is hidden when the FortiAnalyzer is
operating in Collector mode, and the SQL database is disabled.

Log Insert Lag Time Displays how many seconds the database is behind in processing the logs. For
more information, see Log Insert Lag Time widget on page 165.

The Log Insert Lag Time widget is hidden when the FortiAnalyzer is operating in
Collector mode, and the SQL database is disabled.

Receive Rate vs Forwarding Displays the Receive Rate, which is the rate at which FortiAnalyzer is receiving

Rate logs. When log forwarding is configured, the widget also displays the log
forwarding rate for each configured server. For more information, see Receive
Rate vs Forwarding Rate widget on page 165.

Disk I/0 Displays the disk utilization, transaction rate, or throughput as a percentage over
time. For more information, see Disk I/O widget on page 166.

Customizing the dashboard

The FortiAnalyzer system dashboard can be customized. You can select which widgets to display, where they are
located on the page, and whether they are minimized or maximized. It can also be viewed in full screen by selecting the
full screen button on the far right side of the toolbar.

Action Steps

Move a widget Move the widget by clicking and dragging its title bar, then dropping it in its new location
Add a widget Select Toggle Widgets from the toolbar, then select the name widget you need to add.
Delete a widget Click the Close icon in the widget's title bar.
Customize a For widgets with an edit icon, you can customize the widget by clicking the Edit icon and
widget configuring the settings.
Reset the Select Toggle Widgets > Reset to Default from the toolbar. The dashboards will be reset to
dashboard the default view.
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System Information widget

The information displayed in the System Information widget is dependent on the FortiAnalyzer model and device
settings. The following information is available on this widget:

Host Name

Serial Number

Platform Type

HA Status

System Time

Firmware Version

System Configuration

Current Administrators

Up Time

Administrative Domain

Operation Mode

The identifying name assigned to this FortiAnalyzer unit. Click the edit host name
button to change the host name. For more information, see Changing the host
name on page 158.

The serial number of the FortiAnalyzer unit. The serial number is unique to the
FortiAnalyzer unit and does not change with firmware upgrades. The serial
number is used for identification when connecting to the FortiGuard server.

Displays the FortiAnalyzer platform type, for example FAZVM64 (virtual
machine).

Displays if FortiAnalyzer unit is in High Availability mode and whether it is the
Primary or Secondary unit in the HA cluster.

The current time on the FortiAnalyzer internal clock. Click the edit system time
button to change system time settings. For more information, see Configuring
the system time on page 158.

The version number and build number of the firmware installed on the
FortiAnalyzer unit. To update the firmware, you must download the latest version
from the Customer Service & Support website at https://support.fortinet.com.
Click the update button, then select the firmware image to load from the local
hard disk or network volume. For more information, see Updating the system
firmware on page 159.

The date of the last system configuration backup. The following actions are
available:

« Click the backup button to backup the system configuration to a file; see
Backing up the system on page 160.

« Click the restore to restore the configuration from a backup file; see
Restoring the configuration on page 160. You can also migrate the
configuration to a different FortiAnalyzer model by using the CLI. See
Migrating the configuration on page 160.

The number of administrators currently logged in. Click the current session list
button to view the session details for all currently logged in administrators.

The duration of time the FortiAnalyzer unit has been running since it was last
started or restarted.

Displays whether ADOMs are enabled. Toggle the switch to change the
Administrative Domain state. See Enabling and disabling the ADOM feature on
page 179.

Displays the current operation mode of the FortiAnalyzer. Click the other mode to
change to it. For more information on operation modes, see Two operation
modes on page 19.
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Changing the host name

The host name of the FortiAnalyzer unit is used in several places.

« It appearsin the System Information widget on the dashboard.
o lItisused in the command prompt of the CLI.
o Itisused as the SNMP system name.

The System Information widget and the get system status CLI command will display the full host name.
However, if the host name is longer than 16 characters, the CLI and other places display the host name in a truncated
form ending with a tilde ( ~ ) to indicate that additional characters exist, but are not displayed. For example, if the host
name is FortiAnalyzer1234567890, the CLI prompt would be FortiAnalyzer123456~4.

To change the host name:

1. Goto System Settings > Dashboard.
2. Inthe System Information widget, click the edit host name button next to the Host Name field.
3. Inthe Host Name box, type a new host name.

The host name may be up to 35 characters in length. It may include US-ASCI| letters, numbers, hyphens, and
underscores. Spaces and special characters are not allowed.

4. Click the checkmark to change the host name.

Configuring the system time

You can either manually set the FortiAnalyzer system time or configure the FortiAnalyzer unit to automatically keep its
system time correct by synchronizing with a Network Time Protocol (NTP) server.

iy
‘?' For many features to work, including scheduling, logging, and SSL-dependent features, the
- FortiAnalyzer system time must be accurate.

To configure the date and time:

1. Goto System Settings > Dashboard.
2. Inthe System Information widget, click the edit system time button next to the System Time field.

3. Configure the following settings to either manually configure the system time, or to automatically synchronize the
FortiAnalyzer unit’s clock with an NTP server:

System Time The date and time according to the FortiAnalyzer unit’s clock at the time that
this pane was loaded or when you last clicked the Refresh button.

Time Zone Select the time zone in which the FortiAnalyzer unit is located and whether or
not the system automatically adjusts for daylight savings time.
Update Time By Select Set time to manually set the time, or Synchronize with NTP Serverto
automatically synchronize the time.
Set Time Manually set the data and time.
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Select Date Set the date from the calendar or by manually entering it in the format:
YYYY/MM/DD.
Select Time Select the time.

Synchronize with NTP Server Automatically synchronize the date and time.

Sync Interval Enter how often, in minutes, the device should synchronize its time with the
NTP server. For example, entering 1440 causes the Fortinet unit to
synchronize its time once a day.

Server Enter the IP address or domain name of an NTP server. Click the plus icon to
add more servers. To find an NTP server that you can use, go to
http://www.ntp.org.

4. Click the checkmark to apply your changes.

Updating the system firmware

To take advantage of the latest features and fixes, the FortiAnalyzer firmware can be updated. For information about
upgrading your FortiAnalyzer device, see the FortiAnalyzer Upgrade Guide or contact Fortinet Customer Service &
Support.

Backup the configuration and database before changing the firmware of your FortiAnalyzer
A unit. Changing the firmware to an older or incompatible version may reset the configuration

and database to the default values for that firmware version, resulting in data loss. For

information on backing up the configuration, see Backing up the system on page 160.

s‘é’, Before you can download firmware updates for your FortiAnalyzer unit, you must first register

your FortiAnalyzer unit with Customer Service & Support. For details, go to
https://support.fortinet.com/ or contact Customer Service & Support.

To update the FortiAnalyzer firmware:

1.

Download the firmware (the . out file) from the Customer Service & Support website,
https://support.fortinet.com/.

Go to System Settings > Dashboard.

In the System Information widget, in the Firmware Version field, click Upgrade Firmware. The Firmware Upload
dialog box opens.

Drag and drop the file onto the dialog box, or click Browse to locate the firmware package (. out file) that you
downloaded from the Customer Service & Support portal and then click Open.

Click OK. Your device will upload the firmware image and you will receive a confirmation message noting that the
upgrade was successful.

Optionally, you can upgrade firmware stored on an FTP or TFTP server using the
S : !, following CLI command:
? execute restore image {ftp | tftp} <file path to server> <IP of
- server> <username On server> <password>

For more information, see the FortiAnalyzer CLI Reference.
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6. Refresh the browser and log back into the device.
7. Launch the Device Manager module and make sure that all formerly added devices are still listed.
8. Launch other functional modules and make sure they work properly.

Backing up the system

Fortinet recommends that you back up your FortiAnalyzer configuration to your management computer on a regular
basis to ensure that, should the system fail, you can quickly get the system back to its original state with minimal affect
to the network. You should also perform a back up after making any changes to the FortiAnalyzer configuration or
settings that affect the connected devices.

Fortinet recommends backing up all configuration settings from your FortiAnalyzer unit before upgrading the
FortiAnalyzer firmware.

To back up the FortiAnalyzer configuration:

1. Goto System Settings > Dashboard.

2. Inthe System Information widget, click the backup button next to System Configuration. The Backup System
dialog box opens

3. If you want to encrypt the backup file, select the Encryption box, then type and confirm the password you want to
use. The password can be a maximum of 63 characters.

4. Select OK and save the backup file on your management computer.

Restoring the configuration

You can use the following procedure to restore your FortiAnalyzer configuration from a backup file on your management
computer.

To restore the FortiAnalyzer configuration:

1. Goto System Settings > Dashboard.

2. Inthe System Information widget, click the restore button next to System Configuration. The Restore System
dialog box opens.

3. Configure the following settings then select OK.

Choose Backup File Select Browse to find the configuration backup file you want to restore, or
drag and drop the file onto the dialog box.

Password Type the encryption password, if applicable.

Overwrite current IP and Select the checkbox to overwrite the current |P and routing settings.
routing settings

Migrating the configuration

You can back up the system of one FortiAnalyzer model, and then use the CLI and the FTP, SCP, or SFTP protocol to
migrate the settings to another FortiAnalyzer model.
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If you encrypted the FortiAnalyzer configuration file when you created it, you need the password to decrypt the
configuration file when you migrate the file to another FortiAnalyzer model.

To migrate the FortiAnalyzer configuration:

In one FortiAnalyzer model, go to System Settings > Dashboard.
Back up the system. See Backing up the system on page 160.
In the other FortiAnalyzer model, go to System Settings > Dashboard.

A oODdD=

In the CLI Console widget, type the following command:
execute migrate all-settings <ftp | scp | sftp> <server> <filepath> <user> <password>
[cryptpasswd]

Configuring the operation mode

The FortiAnalyzer unit has two operation modes: Analyzer and Collector. For more information, see Two operation
modes on page 19.

When FortiAnalyzer is operating in Collector mode, the SQL database is disabled by default so logs that require the
SQL database are not available in Collector mode unless the SQL database is enabled.

To change the operation mode:

1. Goto System Settings > Dashboard.
2. Inthe System Information widget, select Analyzer or Collectorin the Operation Mode field
3. Click OKin the confirmation dialog box to change the operation mode.

System Resources widget

The System Resources widget displays the usage status of the CPUs, memory, and hard disk. You can view system
resource information in real-time or historical format, as well as average or individual CPU usage.

On VMs, warning messages are displayed if the amount of memory or the number of CPUs assigned are too low, or if
the allocated hard drive space is less than the licensed amount. These warnings are also shown in the notification list
(see GUI overview on page 12). Clicking on a warning opens the FortiAnalyzer VM Install Guide.

System Resources L 2

3% 43% 55%

Average CPU Usage Memory Usage Disk Usage
© FortiAnalyzer VM requires minimum 4GB Memory and 2x vCPU

To toggle between real-time and historical data, click Edit in the widget toolbar, select Historical or Real-time, edit the
other settings as required, then click OK.

To view individual CPU usage, from the Real-Time display, click on the CPU chart. To go back to the standard view,
click the chart again.
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License Information widget

The License Information widget displays the number of devices connected to the FortiAnalyzer.

License Information

E8 VM License

¥ Logging

s Storage Connector Service

& FortiGuard

O Update Server

VM License

Logging
Device/VDOMs

GB/Day

VM Storage

Storage Connector Service

FortiGuard

ox

Valid 10UG 3
Devices/VDOMs | 74 of 2,000
GB/Day | 23.9 of 1000 (2.4%) =
Cloud No License -
Indicators of Compromise Licensed (Expires 2028-03-04)
Service
Server Location & Global Servers re
AntiVirus and IPS 192.168.100.205
FortiClient Update 192.168.100.207

VM license information and status.
Click the upload license button to upload a new VM license file.
This field is only visible for FortiAnalyzer VM.

The Duplicate status appears when users try to upload a license that is already
in use. Additionally, the following message will be displayed in the Notifications:

Duplicate License has been found! Your VM license will expire in XX hours
(Grace time: 24 hours)

Users will have 24 hours to upload a valid license before the duplicate license is
blocked.

The total number of devices and VDOMs connected to the FortiAnalyzer and the
total number of device and VDOM licenses.

The gigabytes per day of logs allowed and used for this FortiAnalyzer. Click the
show details button to view the GB per day of logs used for the previous 6 days.

The GB/Day log volume can be viewed per ADOM through the CLI using:
diagnose fortilogd logvol-adom <name>.

The amount of VM storage used and remaining.

This field is only visible for FortiAnalyzer VM.

The cloud storage license status.

Displays usage statistics as well as the license expiration date when a valid
license is present.

Click the purchase button to go to the Fortinet Customer Service & Support
website, where you can purchase a license.
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Indicators of The license status.
Compromise Click the purchase button to go to the Fortinet Customer Service & Support
Service

website, where you can purchase a license.

Secure DNS Server The SDNS server license status.

Click the upload image button to upload a license key.

Server Location The locations of the FortiGuard servers, either global or US only.

Click the edit icon to adjust the location. Changing the server location will cause
the FortiAnalyzer to reboot.

Update Server
AntiVirus and IPS The IP address and physical location of the Antivirus and IPS update server.

Web and Email The IP address and physical location of the web and email filter update server.
Filter

FortiClient Update  The IP address and physical location of the FortiClient update server.

Unit Operation widget

The Unit Operation widget graphically displays the status of each port. The port name indicates its status by its color.
Green indicates the port is connected. Grey indicates there is no connection.

Hover the cursor over the ports to view a pop-up that displays the full name of the interface, the IP address and
netmask, the link status, the speed of the interface, and the amounts of sent and received data.

Unit Operation o 0%

FORTINET

Alert Messages Console widget
The Alert Message Console widget displays log-based alert messages for both the FortiAnalyzer unit itself and
connected devices.

Alert messages help you track system events on your FortiAnalyzer unit such as firmware changes, and network events
such as detected attacks. Each message shows the date and time the event occurred.

Ay
S L4
q Alert messages can also be delivered by email, syslog, or SNMP.
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Alert Message Console

Time
May 31, 09:59:02
May 31,09:57:26
May 31, 09:41:48
May 31, 08:58:59
May 31, 08:57:25
May 31, 08:41:37
May 31, 07:58:59
May 31,07:57:25
May 31, 07:41:32
May 31, 06:58:53

Message

Disk usage for Adom FortiMail is approaching the delete threshold 90% of total 102400 MB.
Disk usage for Adom FortiSandbox is approaching the delete threshold 90% of total 102400 MB.
Disk usage for Adom root is approaching the delete threshold 90% of total 3145728 MB.

Disk usage for Adom FortiMail is approaching the delete threshold 90% of total 102400 MB.
Disk usage for Adom FortiSandbox is approaching the delete threshold 90% of total 102400 MB.
Disk usage for Adom root is approaching the delete threshold 90% of total 3145728 MB.

Disk usage for Adom FortiMail is approaching the delete threshold 90% of total 102400 MB.
Disk usage for Adom FertiSandbox is approaching the delete threshold 90% of total 102400 MB.
Disk usage for Adom root is approaching the delete threshold 90% of total 3145728 MB.

Disk usage for Adom FortiMail is approaching the delete threshold 90% of total 102400 MB.

Q
x

Click Edit from the widget toolbar to view the Alert Message Console Settings, where you can adjust the number of
entries that are visible in the widget, and the refresh interval.

To view a complete list of alert messages, click Show More from the widget toolbar. The widget will show the complete
list of alerts. To clear the list, click Delete All Messages. Click Show Less to return to the previous view.

Log Receive Monitor widget

The Log Receive Monitor widget displays the rate at which the FortiAnalyzer unit receives logs over time. Log data can
be displayed by either log type or device.

Hover the cursor over a point on the graph to see the exact number of logs that were received at a specific time. Click
the name of a device or log type to add or remove it from the graph. Click Edit in the widget toolbar to modify the

widget's settings.

Log Receive Monitor - Last 1 Hour
Average Rate (4,927.9 Logs/Sec)

45004

4000

20004

M FG1K2D3114800143 2751

FGT37D4615800547 874 [

M Other 657

M FGT37D4614800446 538

T T
os:51

W FG1K2D3114800143

T
0s.az os:ss 1007 10:15

10:23 10:31

FGT37D4615800547 M FGT37D4614800446 M Other

Insert Rate vs Receive Rate widget

1038

The Insert Rate vs Receive Rate widget displays the log insert and log receive rates over time.

« Log receive rate: how many logs are being received.
« Log insert rate: how many logs are being actively inserted into the database.

If the log insert rate is higher than the log receive rate, then the database is rebuilding. The lag is the number of logs

waiting to be inserted.

Hover the cursor over a point on the graph to see the exact number of logs that were received and inserted at a specific

time. Click Receive Rate or Insert Rate to remove those data from the graph. Click the edit icon in the widget toolbar to

adjust the time interval shown on the graph and the refresh interval.
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Insert Rate vs Receive Rate - Last 1 Hour L= B2
000 ,,

o] 3

s000-] M
000
2000
2000-]

10004

database is disabled.

x This widget is hidden when FortiAnalyzer is operating in Collector mode, and the SQL

Log Insert Lag Time widget

The Log Insert Lag Time widget displays how many seconds the database is behind in processing the logs.

Click the edit icon in the widget toolbar to adjust the time interval shown on the graph and the refresh interval (0 to
disable) of the widget.

Log Insert Lag Time - Last 1 hour L ol 4

M LagTime

This widget is hidden when FortiAnalyzer is operating in Collector mode, and the SQL
database is disabled.

Receive Rate vs Forwarding Rate widget

The Receive Rate vs Forwarding Rate widget displays the rate at which the FortiAnalyzer is receiving logs. When log
forwarding is configured, the widget also displays the log forwarding rate for each configured server.

Click the edit icon in the widget toolbar to adjust the time period shown on the graph and the refresh interval, if any, of
the widget.
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Receive Rate vs Forwarding Rate - Last 24 Hours [- S
s000

|

2 22:12:08 01025
M Receive Rate W FAZ200D

Disk 1/0 widget

The Disk I/0 widget shows the disk utilization (%), transaction rate (requests/s), or throughput (KB/s), versus time.

Click the edit icon in the widget toolbar to select which chart is displayed, the time period shown on the graph, and the
refresh interval (if any) of the chart.

Disk 1/O: Throughput (KB/Sec) - Last 24 Hours LR

i
TN
U by
L] W
A b
WL U
Vi I N
| VY

— T T T T T T T T T T T T T T T T T T T_T T
10:40:59 123283 18:24:47 18:18:41 220835 01:00:28 025223 08:44:17 05:38:11
M Read M Write

Logging Topology

The Logging Topology pane shows the physical topology of devices in the Security Fabric. Click, hold, and drag to
adjust the view in the content pane, and double-click or use the scroll wheel to change the zoom.

The visualization can be filtered to show only FortiAnalyzer devices or all devices by device count or traffic.
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Hovering the cursor over a device in the visualization will show information about the device, such as the IP address and
device name. Right-click on a device and select View Related Logs to go to the Log View pane, filtered for that device.

@ FMG-VMé4

E"(é FAZVMé&4-Collector2

FAZVMS542

Network

The network settings are used to configure ports for the FortiAnalyzer unit. You should also specify what port and
methods that an administrators can use to access the FortiAnalyzer unit. If required, static routes can be configured.

The default port for FortiAnalyzer units is port 1. It can be used to configure one IP address for the FortiAnalyzer unit, or
multiple ports can be configured with multiple IP addresses for improved security.

You can configure administrative access in IPv4 or IPv6 and include settings for HTTPS, HTTP, PING, SSH, SNMP,
Web Service, and FortiManager.

You can prevent unauthorized access to the GUI by creating administrator accounts with trusted hosts. With trusted
hosts configured, the administrator can only log in to the GUI when working on a computer with the trusted host as
defined in the administrator account. For more information, see Trusted hosts on page 222 and Managing administrator
accounts on page 223.

Configuring network interfaces

Fortinet devices can be connected to any of the FortiAnalyzer unit's interfaces. The DNS servers must be on the
networks to which the FortiAnalyzer unit connects, and should have two different IP addresses.

The following port configuration is recommended:

o Use port 1 for device log traffic, and disable unneeded services on it, such as SSH, Web Service, and so on.

« Use a second port for administrator access, and enable HTTPS, Web Service, and SSH for this port. Leave other
services disabled.
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To configure port 1:

1. Goto System Settings > Network. The System Network Management Interface pane is displayed.

System Network Management Interface

Name portl
IP Address/Netmask 172.18.37.148/255.255.254.0
IPv6 Address 0
Administrative Access BHTTPS BHTTP BPING E55H [JSNMP B3 Web Service
IPvé Administrative Access HTTPS LJHTTP LIPING LJSSH LISNMP LIWeb Service
Service Access B FortiGate Updates
Bind to IP Address @ 172.18.37.150/255.255.254.0
B Wweb Filtering
Bind to IP Address @ 172.18.37.149/255.255.254.0
Default Gateway 172.18.36.4
Primary DNS Server 208.91.112.52
Secondary DNS Server 208.91.112.53
All Interfaces Routing Table IPv6 Routing Table
System Network Management Interface
Name portl
IP Address/Netmask 10.21.1.173/255.255.255.0
IPv6 Address /0
Administrative Access EHTTPS EHTTP EBPING EsSH ESNMP BWweb Service EFortiManager
IPvé Administrative Access HTTPS CJHTTP CJPING ([ sSH [JSNMP [Jweb Service [JFortiManager

Default Gateway
Primary DNS Server 208.91.112.52

Secondary DNS Server 208.91.112.53

All Interfaces Routing Table IPvé Routing Table

2. Configure the following settings for port1, then click Apply to apply your changes.

Name
IP Address/Netmask
IPv6 Address

Administrative Access

IPv6 Administrative Access

Default Gateway
Primary DNS Server
Secondary DNS Server

To configure additional ports:

Displays the name of the interface.
The IP address and netmask associated with this interface.
The IPv6 address associated with this interface.

Select the allowed administrative service protocols from: HTTPS, HTTP,
PING, SSH, SNMP, Web Service, and FortiManager.

Select the allowed IPv6 administrative service protocols from: HTTPS, HTTP,
PING, SSH, SNMP, Web Service, and FortiManager.

The default gateway associated with this interface.
The primary DNS server IP address.

The secondary DNS server IP address.

1. Goto System Settings > Network and click All Interfaces. The interface list opens.

2. Double-click on a port, right-click on a port then select Edit from the pop-up menu, or select a port then click Edit in

the toolbar. The Edit System Interface pane is displayed.
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3. Configure the settings as required.

4. Click OKto apply your changes.

Ay
‘?' The port name, default gateway, and DNS servers cannot be changed from the Edit System
|| Interface pane. The port can be given an alias if needed.

Disabling ports

Ports can be disabled to prevent them from accepting network traffic

To disable a port:

1.
2.

Go to System Settings > Network and click All Interfaces. The interface list opens.

Double-click on a port, right-click on a port then select Edit from the pop-up menu, or select a port then click Edit in
the toolbar. The Edit System Interface pane is displayed.

In the Status field, click Disable
Click OK to disable the port.

Changing administrative access

Administrative access defines the protocols that can be used to connect to the FortiAnalyzer through an interface. The
available options are: HTTPS, HTTP, PING, SSH, SNMP, Web Service, and FortiManager.

To change administrative access:

1.
2

Go to System Settings > Network and click All Interfaces. The interface list opens.

Double-click on a port, right-click on a port then select Edit from the pop-up menu, or select a port then click Edit in
the toolbar. The Edit System Interface pane is displayed.

Select one or more access protocols for the interface for IPv4 and IPv6, if applicable.
Click OK to apply your changes.

Static routes

Static routes can be managed from the routing tables for IPv4 and IPv6 routes.

The routing tables can be accessed by going to System Settings > Network and clicking Routing Table and IPv6
Routing Table.

To add a static route:

A OODN=

From the IPv4 or IPv6 routing table, click Create New in the toolbar. The Create New Network Route pane opens.
Enter the destination IP address and netmask, or IPv6 prefix, and gateway in the requisite fields.

Select the network interface that connects to the gateway from the dropdown list.

Click OK to create the new static route.
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To edit a static route:

1. From the IPv4 or IPv6 routing table: double-click on a route, right-click on a route then select Edit from the pop-up
menu, or select a route then click Edit in the toolbar. The Edit Network Route pane opens.

2. Edit the configuration as required. The route ID cannot be changed.
3. Click OKto apply your changes.

To delete a static route or routes:

1. From the IPv4 or IPv6 routing table, right-click on a route then select Delete from the pop-up menu, or select a
route or routes then click Delete in the toolbar.

2. Click OKin the confirmation dialog box to delete the selected route or routes.

Packet capture

Packets can be captured on configured interfaces by going to System > Network > Packet Capture.

The following information is available:

Interface The name of the configured interface for which packets can be captured.
For information on configuring an interface, see Configuring network interfaces
on page 167.

Filter Criteria The values used to filter the packet.

# Packets The number of packets.

Maximum Packet Count The maximum number of packets that can be captured on a sniffer.

Progress The status of the packet capture process.

Actions Allows you to start and stop the capturing process, and download the most

recently captured packets.

To start capturing packets on an interface, select the Start capturing button in the Actions column for that interface.
The Progress column changes to Running, and the Stop capturing and Download buttons become available in the
Actions column.

To add a packet sniffer:

1. From the Packet Capture table, click Create New in the toolbar. The Create New Sniffer pane opens.
2. Configure the following options:

Interface The interface name (non-changeable).

Max. Packets to Save Enter the maximum number of packets to capture, between 1-10000. The
default is 4000 packets.

Include IPv6 Packets Select to include IPv6 packets when capturing packets.
Include Non-IP Packets Select to include non-IP packets when capturing packets.
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Enable Filters You can filter the packet by Host(s), Port(s), VLAN(s), and Protocol.

3. Click OK.

To download captured packets:

1. Inthe Actions column, click the Download button for the interface whose captured packets you want to download.
If no packets have been captured for that interface, click the Start capturing button.

2. When prompted, save the packet file (sniffer_[interface].pcap) to your management computer.
The file can then be opened using packet analyzer software.

To edit a packet sniffer:

1. From the Packet Capture table, click Edit in the toolbar. The Edit Sniffer pane opens.
2. Configure the packet sniffer options
3. Click OK.

RAID Management

RAID helps to divide data storage over multiple disks, providing increased data reliability. For FortiAnalyzer devices
containing multiple hard disks, you can configure the RAID array for capacity, performance, and/or availability.

Al
‘?' The RAID Management tree menu is only available on FortiAnalyzer devices that support

RAID.

Supported RAID levels

FortiAnalyzer units with multiple hard drives can support the following RAID levels:

}\' See the FortiAnalyzer datasheet to determine your devices supported RAID levels.

Linear RAID

A Linear RAID array combines all hard disks into one large virtual disk. The total space available in this option is the
capacity of all disks used. There is very little performance change when using this RAID format. If any of the drives fails,
the entire set of drives is unusable until the faulty drive is replaced. All data will be lost.

RAID 0

ARAID 0 array is also referred to as striping. The FortiAnalyzer unit writes information evenly across all hard disks. The
total space available is that of all the disks in the RAID array. There is no redundancy available. If any single drive fails,
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the data on that drive cannot be recovered. This RAID level is beneficial because it provides better performance, since
the FortiAnalyzer unit can distribute disk writing across multiple disks.

o Minimum number of drives: 2
« Data protection: No protection

A\,
S L4
? RAID 0 is not recommended for mission critical environments as it is not fault-tolerant.

RAID 1

A RAID 1 array is also referred to as mirroring. The FortiAnalyzer unit writes information to one hard disk, and writes a
copy (a mirror image) of all information to all other hard disks. The total disk space available is that of only one hard
disk, as the others are solely used for mirroring. This provides redundant data storage with no single point of failure.
Should any of the hard disks fail, there are backup hard disks available.

e Minimum number of drives: 2
« Data protection: Single-drive failure

build is not required in the event of a drive failure. This is the simplest RAID storage design

\‘é', One write or two reads are possible per mirrored pair. RAID 1 offers redundancy of data. Are-
- with the highest disk overhead.

RAID 1s

A RAID 1 with hot spare array uses one of the hard disks as a hot spare (a stand-by disk for the RAID). If a hard disk
fails, within a minute of the failure the hot spare is substituted for the failed drive, integrating it into the RAID array and
rebuilding the RAID’s data. When you replace the failed hard disk, the new hard disk is used as the new hot spare. The
total disk space available is the total number of disks minus two.

RAID 5

A RAID 5 array employs striping with a parity check. Similar to RAID 0, the FortiAnalyzer unit writes information evenly
across all drives but additional parity blocks are written on the same stripes. The parity block is staggered for each
stripe. The total disk space is the total number of disks in the array, minus one disk for parity storage. For example, with
four hard disks, the total capacity available is actually the total for three hard disks. RAID 5 performance is typically
better with reading than with writing, although performance is degraded when one disk has failed or is missing. With
RAID 5, one disk can fail without the loss of data. If a drive fails, it can be replaced and the FortiAnalyzer unit will restore
the data on the new disk by using reference information from the parity volume.

e Minimum number of drives: 3
« Data protection: Single-drive failure

RAID 5s

A RAID 5 with hot spare array uses one of the hard disks as a hot spare (a stand-by disk for the RAID). If a hard disk
fails, within a minute of the failure, the hot spare is substituted for the failed drive, integrating it into the RAID array, and
rebuilding the RAID’s data. When you replace the failed hard disk, the new hard disk is used as the new hot spare. The
total disk space available is the total number of disks minus two.
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RAID 6
A RAID 6 array is the same as a RAID 5 array with an additional parity block. It uses block-level striping with two parity
blocks distributed across all member disks.

e Minimum number of drives: 4
« Data protection: Up to two disk failures.

RAID 6s

A RAID 6 with hot spare array is the same as a RAID 5 with hot spare array with an additional parity block.

RAID 10

RAID 10 (or 1+0), includes nested RAID levels 1 and 0, or a stripe (RAID 0) of mirrors (RAID 1). The total disk space
available is the total number of disks in the array (a minimum of 4) divided by 2, for example:

o 2 RAID 1 arrays of two disks each,
+ 3 RAID 1 arrays of two disks each,
« 6 RAID1 arrays of two disks each.

One drive from a RAID 1 array can fail without the loss of data; however, should the other drive in the RAID 1 array fail,
all data will be lost. In this situation, it is important to replace a failed drive as quickly as possible.

e Minimum number of drives: 4
« Data protection: Up to two disk failures in each sub-array.

Al
S L4
? Alternative to RAID 1 when additional performance is required.

RAID 50

RAID 50 (or 5+0) includes nested RAID levels 5 and 0, or a stripe (RAID 0) and stripe with parity (RAID 5). The total disk
space available is the total number of disks minus the number of RAID 5 sub-arrays. RAID 50 provides increased
performance and also ensures no data loss for the same reasons as RAID 5. One drive in each RAID 5 array can fail
without the loss of data.

e Minimum number of drives: 6
« Data protection: Up to one disk failure in each sub-array.

Ay
S L4
q Higher fault tolerance than RAID 5 and higher efficiency than RAID 0.
RAID 50 is only available on models with 9 or more disks. By default, two groups are used
unless otherwise configured via the CLI. Use the diagnose system raid status CLI
I command to view your current RAID level, status, size, groups, and hard disk drive
information.
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RAID 60

A RAID 60 (6+ 0) array combines the straight, block-level striping of RAID 0 with the distributed double parity of RAID 6.

e Minimum number of drives: 8
« Data protection: Up to two disk failures in each sub-array.

Al
‘Q' High read data transaction rate, medium write data transaction rate, and slightly lower
- performance than RAID 50.

Configuring the RAID level

Changing the RAID level will delete all data.

To configure the RAID level:

1. Goto System Settings > RAID Management.
2. Click Change in the RAID Levelfield. The RAID Settings dialog box is displayed.
3. From the RAID Level list, select a new RAID level, then click OK.

The FortiAnalyzer unit reboots. Depending on the selected RAID level, it may take a significant amount of time to
generate the RAID array.

Monitoring RAID status

To view the RAID status, go to System Settings > RAID Management. The RAID Management pane displays the
RAID level, status, and disk space usage. It also shows the status, size, and model of each disk in the RAID array.

detailed information about RAID array failures. For more information see Alert Messages

\{ The Alert Message Console widget, located in System Settings > Dashboard, provides
I Console widget on page 163.

Summary

| )
TR v v v v
J_a v v v v

RAID Level Raid-10 [Change

Status System is functioning normally.

Disk Space Usage i ]25% Used

1890GB Used/ 5442GB Free/ 7332GB Total

Disk Management
Disk Number Disk Status SizelGB) Disk Model
0 v 1862 ST2000NM0033-9ZM175
1 v 1862 ST2000NM0033-9ZM175
2 v 1862 ST2000NM0033-9ZM175
3 « 1862 ST2000NMO033-9ZM175
4 v 1862 ST2000NMO033-9ZM175
5 v 1862 ST2000NMO033-9ZM175
6 v 1862 ST2000NMO033-92M175
7 v 1862 ST2000NMO033-9ZM175
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Summary

Graphic

RAID Level

Status

Disk Space Usage

Disk Management
Disk Number
Disk Status

Size (GB)
Disk Model

Swapping hard disks

Shows summary information about the RAID array.

Displays the position and status of each disk in the RAID array. Hover the cursor
over each disk to view details.

Displays the selected RAID level.

Click Change to change the selected RAID level. When you change the RAID
settings, all data is deleted.

Displays the overall status of the RAID array.

Displays the total size of the disk space, how much disk space is used, and how
much disk space is free.

Shows information about each disk in the RAID array.
Identifies the disk number for each disk.

Displays the status of each disk in the RAID array.

« Ready: The hard drive is functioning normally.

o Rebuilding: The FortiAnalyzer unit is writing data to a newly added hard
drive in order to restore the hard drive to an optimal state. The FortiAnalyzer
unit is not fully fault tolerant until rebuilding is complete.

« Initializing: The FortiAnalyzer unit is writing to all the hard drives in the
device in order to make the array fault tolerant.

« Verifying: The FortiAnalyzer unit is ensuring that the parity data of a
redundant drive is valid.

« Degraded: The hard drive is no longer being used by the RAID controller.

o Inoperable: One or more drives are missing from the FortiAnalyzer unit. The
drive is no longer available to the operating system. Data on an inoperable
drive cannot be accessed.

Displays the size, in GB, of each disk.

Displays the model number of each disk.

If a hard disk on a FortiAnalyzer unit fails, it must be replaced. On FortiAnalyzer devices that support hardware RAID,
the hard disk can be replaced while the unit is still running - known as hot swapping. On FortiAnalyzer units with
software RAID, the device must be shutdown prior to exchanging the hard disk.

To identify which hard disk failed, read the relevant log message in the Alert Message Console widget. See Alert
Messages Console widget on page 163.

Electrostatic discharge (ESD) can damage FortiAnalyzer equipment. Only perform the

A procedures described in this document from an ESD workstation. If no such station is
available, you can provide some ESD protection by wearing an anti-static wrist or ankle strap
and attaching it to an ESD connector or to a metal part of a FortiAnalyzer chassis.

FortiAnalyzer 6.2.3 Administration Guide
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When replacing a hard disk, you need to first verify that the new disk is the same size as those
supplied by Fortinet and has at least the same capacity as the old one in the FortiAnalyzer

unit. Installing a smaller hard disk will affect the RAID setup and may cause data loss. Due to
A possible differences in sector layout between disks, the only way to guarantee that two disks
have the same size is to use the same brand and model.

The size provided by the hard drive manufacturer for a given disk model is only an
approximation. The exact size is determined by the number of sectors present on the disk.

To hot swap a hard disk on a device that supports hardware RAID:

1. Remove the faulty hard disk.

2. |Install a new disk.
The FortiAnalyzer unit automatically adds the new disk to the current RAID array. The status appears on the
console. The RAID Management pane displays a green checkmark icon for all disks and the RAID Status area
displays the progress of the RAID re-synchronization/rebuild.

Adding hard disks

Some FortiAnalyzer units have space to add more hard disks to increase your storage capacity.

N ! /., Fortinet recommends you use the same disks as those supplied by Fortinet. Disks of other
q brands will not be supported by Fortinet. For information on purchasing extra hard disks,
3 contact your Fortinet reseller.

To add more hard disks:

1. Obtain the same disks as those supplied by Fortinet.

2. Back up the log data on the FortiAnalyzer unit.
You can also migrate the data to another FortiAnalyzer unit, if you have one. Data migration reduces system down
time and the risk of data loss.

3. Install the disks in the FortiAnalyzer unit.

If your unit supports hot swapping, you can do so while the unit is running. Otherwise the unit must be shut down
first. See Unit Operation widget on page 163 for information.

4. Configure the RAID level. See Configuring the RAID level on page 174.
5. If you backed up the log data, restore it.

Administrative Domains

Administrative domains (ADOMs) enable administrators to manage only those devices that they are specifically

assigned, based on the ADOMs to which they have access. When the ADOM mode is advanced, FortiGate devices with

multiple VDOMSs can be divided among multiple ADOMs.

FortiAnalyzer 6.2.3 Administration Guide
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Administrator accounts can be tied to one or more ADOMSs, or denied access to specific ADOMs. When a particular
administrator logs in, they see only those devices or VDOMs that have been enabled for their account. Super user
administrator accounts, such as the admin account, can see and maintain all ADOMs and the devices within them.

Each ADOM specifies how long to store and how much disk space to use for its logs. You can monitor disk utilization for
each ADOM and adjust storage settings for logs as needed.

The maximum number of ADOMs you can add depends on the FortiAnalyzer system model. Please refer to the
FortiAnalyzer data sheet for more information.

When the maximum number of ADOMs has been reached, you will be unable to create a new ADOM.

When upgrading to FortiAnalyzer 6.2.1 or later, you will continue to have access to any ADOMs exceeding the limit,
however, no additional ADOMSs can be created, and an alert will be issued in the Alert Message Console in System
Settings > Dashboard.

By default, ADOMs are disabled. Enabling and configuring ADOMs can only be done by administrators with the Super
User profile. See Administrators on page 222.

The root ADOM and Security Fabric ADOMs are available for visibility into all Fabric devices. See Creating a Security
Fabric ADOM on page 40.

YL
‘?' Non-FortiGate devices are automatically located in specific ADOMs for their device type.
|| They cannot be moved to other ADOMs.
Ay
S L4
q ADOMs must be enabled to support the logging and reporting of non-FortiGate devices.

Default ADOMs

FortiAnalyzer includes default ADOMs for specific types of devices. When you add one or more of these devices to the
FortiAnalyzer, the devices are automatically added to the appropriate ADOM, and the ADOM becomes selectable.
When a default ADOM contains no devices, the ADOM is not selectable.

For example, when you add a FortiClient EMS device to the FortiAnalyzer, the FortiClient EMS device is automatically
added to the default FortiClient ADOM. After the FortiClient ADOM contains a FortiClient EMS device, the FortiClient
ADOM is selectable when you log into FortiAnalyzer or when you switch between ADOMs.

You can view all of the ADOMs, including default ADOMs without devices, on the System Settings > All ADOMs pane.

Root ADOM

When ADOMs are enabled, the default roof ADOM type is Fabric. Fabric ADOMs show combined results from all
Security Fabric devices in the Device Manager, Log View, SOC, Incidents & Events and Reports panes. For more
information on Fabric ADOMs, see Creating a Security Fabric ADOM on page 40.

In FortiAnalyzer 6.2.0 and earlier, the root ADOM is a FortiGate ADOM. When upgrading to FortiAnalyzer 6.2.1 and
later, the root ADOM type will not be changed to Fabric. Resetting the FortiAnalyzer settings through a factory reset will
cause the root ADOM to become a Fabric ADOM.
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Organizing devices into ADOMs

You can organize devices into ADOMs to allow you to better manage these devices. Devices can be organized by
whatever method you deem appropriate, for example:

« Firmware version: group all devices with the same firmware version into an ADOM.

« Geographic regions: group all devices for a specific geographic region into an ADOM, and devices for a different
region into another ADOM.

« Administrative users: group devices into separate ADOMs based for specific administrators responsible for the
group of devices.

« Customers: group all devices for one customer into an ADOM, and devices for another customer into another
ADOM.

FortiClient support and ADOMs

FortiClient logs are stored in the device that the FortiClient endpoint is registered to.

For example, when endpoints are registered to a FortiGate device, FortiClient logs are viewed on the FortiGate device.
When endpoints are registered to a FortiClient EMS, FortiClient logs are viewed in the FortiClient ADOM that the
FortiClient EMS device is added to.

ADOMs must be enabled to support FortiClient EMS devices.

Merge FortiAnalyzer Logging Support for FortiClient EMS for Chromebooks

1. Addhttps-loggingtothe allowaccess list using the following CLI command:

config system interface

edit "portl"

set allowaccess https ssh https-logging

next

end
2. Add SSL certificate to enable communication.

An SSL certificate is required to support communication and send logs between FortiClient Web Filter extension
and FortiAnalyzer. If you use a public SSL certificate, you only need to add the public SSL certificate to
FortiAnalyzer.
However, if you prefer to use a certificate that is not from a common CA, you must add the SSL certificate to
FortiAnalyzer, and you must push the root CA of your certificate to the Google Chromebooks. Otherwise, the
HTTPS connection between the FortiClient EMS Chromebook Web Filter extension and FortiAnalyzer will not work.
The common name of the certificate must be the FortiAnalyzer IP address.
a. InFortiAnalyzer, go to System Settings > Certificates > Local Certificates.
b. Click Import. The Import Local Certificate dialog box appears.
c. Inthe Typelist, select Certificate. Or,

In the Type list, select PKCS#12 Certificate to upload the certificate in PK12 format.

Beside the Certificate File field, click Browse to select the certificate.

Enter the password and certificate name.

f. Click OK.
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3. Select certificates for HTTPS connections:
a. InFortiAnalyzer, go to System Settings > Admin > Admin Settings.
b. Inthe HTTPS & Web Service Certificate box, select the certificate you want to use for HTTPS connections,
and click Apply.

4. Enable the FortiClient ADOM using the following CLI command:
conf sys global
set adom-status enable
end

5. Add FortiClient EMS for Chromebooks as a device to the FortiClient ADOM:
Go to Device Manager > click the + Add Device button to add FortiClient EMS for Chromebooks as a FortiClient
ADOM device.

6. Enable logging in FortiClient EMS for Chromebooks:
You will need to enable logging in FortiClient EMS for Chromebooks, see the FortiClient EMS for Chromebooks
Administration Guide for more information.

Enabling and disabling the ADOM feature

By default, ADOMs are disabled. Enabling and configuring ADOMs can only be done by super user administrators.

When ADOMs are enabled, the Device Manager, SOC, Log View, Incidents & Events, and Reports panes are
displayed per ADOM. You select the ADOM you need to work in when you log into the FortiAnalyzer unit. See Switching
between ADOMs on page 15.

\y

~ P ADOMs must be enabled to support FortiMail and FortiWeb logging and reporting. When a
? FortiMail or FortiWeb device is promoted to the DVM table, the device is added to their
- respective default ADOM and will be visible in the left-hand tree menu.
\‘ ! 'l . . . . . . .
FortiGate and FortiCarrier devices cannot be grouped into the same ADOM. FortiCarrier
? devices are added to a specific default FortiCarrier ADOM.

To enable the ADOM feature:

1. Log in to the FortiAnalyzer as a super user administrator.
2. Goto System Settings > Dashboard.

3. Inthe System Information widget, toggle the Administrative Domain switch to ON.
You will be automatically logged out of the FortiAnalyzer and returned to the log in screen.

To disable the ADOM feature:

-—

Remove all the devices from all non-root ADOMSs. That is, add all devices to the root ADOM.

Delete all non-root ADOMs. See Deleting ADOMs on page 184.
Only after removing all the non-root ADOMs can ADOMs be disabled.

Go to System Settings > Dashboard.

In the System Information widget, toggle the Administrative Domain switch to OFF.
You will be automatically logged out of the FortiAnalyzer and returned to the log in screen.

N

Eall
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Ay
‘Q' The ADOM s feature cannot be disabled if ADOMs are still configured and have managed
- devices in them.

ADOM device modes

An ADOM has two device modes: Normal (default) and Advanced.

In Normal mode, you cannot assign different FortiGate VDOMs to different ADOMs. The FortiGate unit can only be
added to a single ADOM.

In Advanced mode, you can assign a VDOM from a single device to a different ADOM. This allows you to analyze data
for individual VDOM s, but will result in more complicated management scenarios. It is recommended only for advanced
users.

Ay
‘Q' FortiAnalyzer does not support splitting FortiGate VDOMs between multiple ADOMs in
- different device modes.

To change from Advanced mode back to Normal mode, you must ensure no FortiGate VDOMs are assigned to an
ADOM.

To change the ADOM device mode:

1. Goto System Settings > Advanced > Advanced Settings.
2. Inthe ADOM Mode field, select either Normal or Advanced.
3. Select Apply to apply your changes.

Managing ADOMs

The ADOMs feature must be enabled before ADOMSs can be created or configured. See Enabling and disabling the
ADOM feature on page 179.

To create and manage ADOMs, go to System Settings > All ADOMs.

4+ Create New [# Edit T[4 Delete 2 Enter ADOM € Disable ADOM ! More ~ % Column Settings =

0O Name Firmware Version Allocated Storage Devices
O root Fabric 50 GB > 3 Devices (including 2 VDOMSs)
O FortiCarrier FortiCarrier 1000 MB

O FortiAnalyzer FortiAnalyzer 1000 MB

O FortiAuthenticator FortiAuthenticator 1000 MB

O FortiCache FortiCache 1000 MB

O FortiClient FortiClient 1000 MB

O FortiDDoS FortiDDoS 1000 MB

O FortiMail FortiMail 1000 MB

O FortiManager FortiManager 1000 MB

O FortiNAC FortiNAC 1000 MB

O FortiProxy FortiProxy 1000 MB

O FortiSandbox FortiSandbox 1000 MB

O Fortiweb FortiWeb 1000 MB

O Syslog Syslog 1000 MB

O Chassis
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Create New

Edit

Delete

Enter ADOM

More

Search

Name

Firmware Version

Allocated Storage

Devices

Creating ADOMs

Create a new ADOM. See Creating ADOMs on page 181.

Edit the selected ADOM. This option is also available from the right-click menu.
See Editing an ADOM on page 184.

Delete the selected ADOM or ADOMs. You cannot delete default ADOMs. This
option is also available from the right-click menu. See Deleting ADOMs on page
184.

Switch to the selected ADOM. This option is also available from the right-click
menu.

Select Expand Devices to expand all of the ADOMs to show the devices in each
ADOM. Select Collapse Devices to collapses the device lists. These options are
also available from the right-click menu.

Enter a search term to search the ADOM list.

The name of the ADOM.

ADOMs are listed in the following groups: FortiGates and Other Device Types.
A group can be collapsed or expanded by clicking the triangle next to its name.

The firmware version of the ADOM. Devices in the ADOM should have the same
firmware version.

The amount of hard drive storage space allocated to the ADOM.

The number of devices and VDOMs that the ADOM contains.
The device list can be expanded or by clicking the triangle.

To create a new ADOM, you must be logged in as a super user administrator.

Consider the following when creating ADOMs:

« The maximum number of ADOMs that can be created depends on the FortiAnalyzer model. For more information,
see the FortiAnalyzer data sheet at https://www.fortinet.com/products/management/fortianalyzer.html.
When the maximum number of ADOMs has been exceeded, an alert will be issued in the Alert Message Console
in System Settings > Dashboard.

« You must use an administrator account that is assigned the Super_User administrative profile.
« You can add a device to only one ADOM. You cannot add a device to multiple ADOMs.

o You cannot add FortiGate and FortiCarrier devices to the same ADOM. FortiCarrier devices are added to a specific,
default FortiCarrier ADOM.

« You can add one or more VDOMs from a FortiGate device to one ADOM. If you want to add individual VDOMs from
a FortiGate device to different ADOMs, you must first enable advanced device mode. See ADOM device modes on

page 180.

« You can configure how an ADOM handles log files from its devices. For example, you can configure how much disk

space an ADOM can use for logs, and then monitor how much of the allotted disk space is used. You can also
specify how long to keep logs in the SQL database and how long to keep logs stored in compressed format.

FortiAnalyzer 6.2.3 Administration Guide
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To create an ADOM

1. Ensure that ADOMs are enabled. See Enabling and disabling the ADOM feature on page 179.
2. Goto System Settings > All ADOMs.
3. Click Create New in the toolbar. The Create New ADOM pane is displayed.

Create New ADOM

Name

Type FortiGate
Devices =+ Select Device

A Name

- B

1P Address Platform

Click to select devices for this ADOM.

Data Policy
Keep Logs for Analytics 60
Keep Logs for Archive 365
Disk Utilization
Maximum Allowed 0

Analytics : Archive 70%

Alert and Delete When Usage Reaches 90%

Days

Days

GB v Out of Available: 0.0 KB

30% Modify

“If analytic or archive log usages exceed the configured disk quota before the retention period expires, the oldest logs will be deleted.

4. Configure the following settings, then click OK to create the ADOM.

Name

Type

Devices

Data Policy

Keep Logs for
Analytics

Keep Logs for
Archive

Disk Utilization

FortiAnalyzer 6.2.3 Administration Guide
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Type a name that allows you to distinguish this ADOM from your other
ADOMs. ADOM names must be unique.

Select the type of device that you are creating an ADOM for. The ADOM type
cannot be edited.

For Security Fabric ADOMs, select Fabric.

Although you can create a different ADOM for each type of device,
FortiAnalyzer does not enforce this setting.

Add a device or devices with the selected versions to the ADOM. The search
field can be used to find specific devices. See Assigning devices to an ADOM
on page 183.

Specify how long to keep logs in the indexed and compressed states.

Specify how long to keep logs in the indexed state.

During the indexed state, logs are indexed in the SQL database for the
specified amount of time. Information about the logs can be viewed in the
SOC > FortiView, Incidents & Events, and Reports modules. After the
specified length of time expires, Analytics logs are automatically purged from
the SQL database.

Specify how long to keep logs in the compressed state.

During the compressed state, logs are stored in a compressed format on the
FortiAnalyzer unit. When logs are in the compressed state, information about
the log messages cannot be viewed in the SOC > FortiView, Incidents &
Events, or Reports modules. After the specified length of time expires,
Archive logs are automatically deleted from the FortiAnalyzer unit.

Specify how much disk space to use for logs.
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Maximum Allowed

Analytics : Archive

Alert and Delete
When Usage
Reaches

Specify the maximum amount of FortiAnalyzer disk space to use for logs, and
select the unit of measure.

The total available space on the FortiAnalyzer unit is shown.

For more information about the maximum available space for each
FortiAnalyzer unit, see Disk space allocation on page 54.

Specify the percentage of the allotted space to use for Analytics and Archive
logs.

Analytics logs require more space than Archive logs. For example, a setting of
70% and 30% indicates that 70% of the allotted disk space will be used for
Analytics logs, and 30% of the allotted space will be used for Archive logs.
Select the Modify checkbox to change the setting.

Specify at what data usage percentage an alert messages will be generated
and logs will be automatically deleted. The oldest Archive log files or Analytics
database tables are deleted first.

Assigning devices to an ADOM

To assign devices to an ADOM you must be logged in as a super user administrator. Devices cannot be assigned to

multiple ADOMs.

To assign devices to an ADOM:

1. Goto System Settings > All ADOMs.

2. Double-click on an ADOM, right-click on an ADOM and then select the Edit from the menu, or select the ADOM
then click Edit in the toolbar. The Edit ADOM pane opens.

3. Click Select Device. The Select Device list opens on the right side of the screen.

4. Select the devices that you want to add to the ADOM. Only devices with the same version as the ADOM can be
added. The selected devices are displayed in the Devices list.

If the ADOM mode is Advanced you can add separate VDOMs to the ADOM as well as units.
5. When done selecting devices, click Close to close the Select Device list.

6. Click OK.

The selected devices are removed from their previous ADOM and added to this one.

Assigning administrators to an ADOM

Super user administrators can create other administrators and either assign ADOMs to their account or exclude them
from specific ADOMs, constraining them to configurations and data that apply only to devices in the ADOMs they can

access.
N ! /., By default, when ADOMs are enabled, existing administrator accounts other than admin are
q assigned to the roof domain, which contains all devices in the device list. For more
= information about creating other ADOMs, see Creating ADOMs on page 181.
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To assign an administrator to specific ADOMs:

1.

Log in as a super user administrator. Other types of administrators cannot configure administrator accounts when
ADOMs are enabled.

Go to System Settings > Admin > Administrator.

Double-click on an administrator, right-click on an administrator and then select the Edit from the menu, or select
the administrator then click Edit in the toolbar. The Edit Administrator pane opens.

Edit the Administrative Domain field as required, either assigning or excluding specific ADOMs.

Select OK to apply your changes.

Ay

S L4
? The admin administrator account cannot be restricted to specific ADOMs.

Editing an ADOM

To edit an ADOM you must be logged in as a super user administrator. The ADOM type and version cannot be edited.
For the default ADOMs, the name cannot be edited.

To edit an ADOM:

1.
2.

Go to System Settings > All ADOMs.

Double-click on an ADOM, right-click on an ADOM and then select Edit from the menu, or select the ADOM then
click Edit in the toolbar. The Edit ADOM pane opens.

Edit the settings as required, and then select OK to apply the changes.

Deleting ADOMs

To delete an ADOM, you must be logged in as a super-user administrator (see Administrator profiles on page 228), such
as the admin administrator.

Prior to deleting an ADOM:

All devices must be removed from the ADOM. Devices can be moved to another ADOM, or to the root ADOM. See

Assigning devices to an ADOM on page 183.

To delete an ADOM:

1
2
3
4.
5
6

Go to System Settings > All ADOMs.

Ensure that the ADOM or ADOMs being deleted have no devices in them.
Select the ADOM or ADOMs you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OKin the confirmation box to delete the ADOM or ADOMs.

If there are users or policy packages referring to the ADOM, they are displayed in the ADOM References Detected

dialog. Click Delete Anyway to delete the ADOM or ADOMs. The references to the ADOMs are also deleted.
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A\,
S L4
? Default ADOMs cannot be deleted.

Certificates

The FortiAnalyzer generates a certificate request based on the information you entered to identify the FortiAnalyzer
unit. After you generate a certificate request, you can download the request to a management computer and then
forward the request to a CA.

Local certificates are issued for a specific server, or website. Generally they are very specific, and often for an internal
enterprise network.

CA root certificates are similar to local certificates, however they apply to a broader range of addresses or to an entire
company.

The CRL is a list of certificates that have been revoked and are no longer usable. This list includes expired, stolen, or
otherwise compromised certificates. If your certificate is on this list, it will not be accepted. CRLs are maintained by the
CA that issues the certificates and include the date and time when the next CRL will be issued, as well as a sequence
number to help ensure you have the most current versions.

Local certificates

The FortiAnalyzer unit generates a certificate request based on the information you enter to identify the FortiAnalyzer
unit. After you generate a certificate request, you can download the request to a computer that has management access
to the FortiAnalyzer unit and then forward the request to a CA.

The certificate window also enables you to export certificates for authentication, importing, and viewing.
The FortiAnalyzer has one default local certificate: Fortinet_Local.

You can manage local certificates from the System Settings > Certificates > Local Certificates page. Some options
are available in the toolbar and some are also available in the right-click menu.

YL
‘?' In order to safeguard against compromise, in FortiAnalyzer 6.2.3, FAZ-VM license files
|| contain a unique certificate which is tied to the device's serial number.

Creating a local certificate

To create a certificate request:

1. Goto System Settings > Certificates > Local Certificates.
2. Click Create New in the toolbar. The Generate Certificate Signing Request pane opens.
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3. Enter the following information as required, then click OK to save the certificate request:

Certificate Name

Subject Information

Optional Information

Organization Unit
(ov)

Organization (O)
Locality (L)

State/Province
(ST)

Country (C)

E-mail Address
(EA)

Subject
Alternative Name

Key Type
Key Size

Curve Name

Enrollment Method

FortiAnalyzer 6.2.3 Administration Guide
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The name of the certificate.

Select the ID type from the dropdown list:

o Host IP: Select if the unit has a static IP address. Enter the public IP
address of the unit in the Host IP field.

o Domain Name: Select if the unit has a dynamic IP address and
subscribes to a dynamic DNS service. Enter the domain name of the unit
in the Domain Name field.

o Email: Select to use an email address. Enter the email address in the
Email Address field.

The name of the department. You can enter a series of OUs up to a maximum

of 5. To add or remove an OU, use the plus (+) or minus (-) icons.
Legal name of the company or organization.
Name of the city or town where the device is installed.

Name of the state or province where the FortiGate unit is installed.

Select the country where the unit is installed from the dropdown list.

Contact email address.

Optionally, enter one or more alternative names for which the certificate is
also valid. Separate names with a comma.

A name can be:
« e-mail address
o IPaddress
« URI
o DNS name (alternatives to the Common Name)
« directory name (alternatives to the Distinguished Name)

You must precede the name with the name type. Examples:
o IP:1.1.1.1
« email:test@fortinet.com
« email:my@other.address
o URI:http://my.url.here/

The key type can be RSA or Elliptic Curve.

Select the key size from the dropdown list: 512 Bit, 1024 Bit, 1536 Bit, or
2048 Bit. This option is only available when the key type is RSA.

Select the curve name from the dropdown list: secp256r1 (default),
secp384r1, or secpb521r1. This option is only available when the key type is
Elliptic Curve.

The enrolilment method is set to File Based.
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Importing local certificates

To import a local certificate:

1. Goto System Settings > Certificates > Local Certificates.
2. Click Import in the toolbar or right-click and select Import. The Import dialog box opens.
3. Enter the following information as required, then click OK to import the local certificate:

Type
Certificate File

Key File

Password

Certificate Name

Deleting local certificates

Select the certificate type from the dropdown list: Local Certificate, PKCS
#12 Certificate, or Certificate.

Click Browse... and locate the certificate file on the management computer,
or drag and drop the file onto the dialog box.

Click Browse... and locate the key file on the management computer, or drag
and drop the file onto the dialog box.
This option is only available when Type is Certificate.

Enter the certificate password.

This option is only available when Type is PKCS #12 Certificate or
Certificate.

Enter the certificate name.

This option is only available when Type is PKCS #12 Certificate or
Certificate.

To delete a local certificate or certificates:

PO DN

Go to System Settings > Certificates > Local Certificates.

Select the certificate or certificates you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OKin the confirmation dialog box to delete the selected certificate or certificates.

Viewing details of local certificates

To view details of a local certificate:

1. Goto System Settings > Certificates > Local Certificates.

2. Select the certificates that you would like to see details about, then click View Certificate Detail in the toolbar or
right-click menu. The View Local Certificate page opens.
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3.

View Local Certificate

Certificate Name ~ Fortinet_Local

Issuer €= US, ST = California, L = Sunnyvale, O = Fortinet, OU = Certificate Authority, CN = support, emailAddress = support@fortinet.com
Subject €= Us, ST = California, L = Sunnyvale, O = Fortinet, OU = FortiManager, CN = FMG-VM0000000000, emailAddress = support@fortinet.com
Valid From 2011-11-08 23:12:50 GMT

Valid To 2038-81-89 03:14:07 GMT

Version 3

Serial Number TLiead7

Extension Name: X509v3 Basic Constraints
Critical: no
Content:
CAFALSE

Click OK to return to the local certificates list.

Downloading local certificates

To download a local certificate:

1.
2.
3.

Go to System Settings > Certificates > Local Certificates.
Select the certificate that you need to download.

Click Download in the toolbar, or right-click and select Download, and save the certificate to the management
computer.

N ! /., When an object is added to a policy package and assigned to an ADOM, the object is
? available in all devices that are part of the ADOM. If the object is renamed on a device locally,
3 FortiManager automatically syncs the renamed object to the ADOM.

CA certificates

The FortiAnalyzer has one default CA certificate, Fortinet_CA. In this sub-menu you can delete, import, view, and
download certificates.

Importing CA certificates

To import a CA certificate:

1.
2.
3.

4.

Go to System Settings > Certificates > CA Certificates.
Click Import in the toolbar, or right-click and select Import. The Import dialog box opens.

Click Browse... and locate the certificate file on the management computer, or drag and drop the file onto the
dialog box.

Click OK to import the certificate.

Viewing CA certificate details

To view a CA certificate's details:

1.
2

Go to System Settings > Certificates > CA Certificates.
Select the certificates you need to see details about.
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3. Click View Certificate Detail in the toolbar, or right-click and select View Certificate Detail. The View CA
Certificate page opens.

4. Click OK to return to the CA certificates list.

Downloading CA certificates

To download a CA certificate:

1. Goto System Settings > Certificates > CA Certificates.
2. Select the certificate you need to download.

3. Click Download in the toolbar, or right-click and select Download, and save the certificate to the management
computer.

Deleting CA certificates

To delete a CA certificate or certificates:

Go to System Settings > Certificates > CA Certificates.
Select the certificate or certificates you need to delete.
Click Delete in the toolbar, or right-click and select Delete.

AoODd-=

Click OK in the confirmation dialog box to delete the selected certificate or certificates.

vy
S L4
? The Fortinet_CA certificate cannot be deleted.

Certificate revocation lists

When you apply for a signed personal or group certificate to install on remote clients, you can obtain the corresponding
root certificate and Certificate Revocation List (CRL) from the issuing CA.

The CRL is alist of certificates that have been revoked and are no longer usable. This list includes expired, stolen, or
otherwise compromised certificates. If your certificate is on this list, it will not be accepted. CRLs are maintained by the
CA that issues the certificates and includes the date and time when the next CRL will be issued as well as a sequence
number to help ensure you have the most current version of the CRL.

When you receive the signed personal or group certificate, install the signed certificate on the remote client(s) according
to the browser documentation. Install the corresponding root certificate (and CRL) from the issuing CA on the
FortiAnalyzer unit according to the procedures given below.

Importing a CRL

To import a CRL:

1. Goto System Settings > Certificates > CRL.
2. Click Import in the toolbar, or right-click and select Import. The Import dialog box opens.
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3. Click Browse... and locate the CRL file on the management computer, or drag and drop the file onto the dialog

box.

4. Click OKto import the CRL.

Viewing a CRL

To view a CRL:

1.
2.

3.

4.

Go to System Settings > Certificates > CRL.
Select the CRL you need to see details about.

Click View Cetrtificate Detail in the toolbar, or right-click and select View Certificate Detail. The Result page
opens.

Click OK to return to the CRL list.

Deleting a CRL

To delete a CRL or CRLs:

A oObdh-=

Go to System Settings > Certificates > CRL.

Select the CRL or CRLs you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OKin the confirmation dialog box to delete the selected CRL or CRLs.

Log Forwarding

You can forward logs from a FortiAnalyzer unit to another FortiAnalyzer unit, a syslog server, or a Common Event
Format (CEF) server when you use the default forwarding mode in log forwarding.

The client is the FortiAnalyzer unit that forwards logs to another device. The serveris the FortiAnalyzer unit, syslog
server, or CEF server that receives the logs.

In addition to forwarding logs to another unit or server, the client retains a local copy of the logs. The local copy of the

logs is subject to the data policy settings for archived logs. See Log storage on page 21 for more information.

To see a graphical view of the log forwarding configuration, and to see details of the devices

I\ involved, go to System Settings > Logging Topology. For more information, see Logging

Topology on page 166.

Modes

FortiAnalyzer supports two log forwarding modes: forwarding (default), and aggregation.
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Forwarding

Logs are forwarded in real-time or near real-time as they are received. Forwarded content files include: DLP files,
antivirus quarantine files, and IPS packet captures.

This mode can be configured in both the GUI and CLI.
Aggregation

As FortiAnalyzer receives logs from devices, it stores them, and then forwards the collected logs at a specified time
every day.

FortiAnalyzer supports log forwarding in aggregation mode only between two FortiAnalyzer units. Syslog and CEF
servers are not supported.

Ay
‘Q' The client must provide super user log in credentials to get authenticated by the server to
- aggregate logs.

Aggregation mode can only be configured with the 1og-forward and log-forward-service CLI commands.
See the FortiAnalyzer CLI Reference for more information.

Configuring log forwarding

Forwarding mode only requires configuration on the client side. No configuration is needed on the server side. In
aggregation mode, accepting the logs must be enabled on the FortiAnalyzer that is acting as the server.

Forwarding mode

Forwarding mode can be configured in the GUI. No configuration is required on the server side.

To configure the client:

1. Goto System Settings > Log Forwarding.
2. Click Create New in the toolbar. The Create New Log Forwarding pane opens.

Create New Log Forwarding

Name LogForward

Status

Remote Server Type @® FortiAnalyzer O Syslog O Common Event Format(CEF)
Server IP 10.10.10.10

Reliable Connection

Sending Frequency m Every 1 Minute | Every 5 Minutes

Log Forwarding Filters

Device Filters All FortiGates g
Select Device 4
Log Filters
Log messages that match All @ Any of the Following Conditions
Log Field Match Criteria Value
Log Type v | Equalto v || Traffic M ]
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3. Fillin the information as per the below table, then click OK to create the new log forwarding. The FortiAnalyzer
device will start forwarding logs to the server.

Name
Status

Remote Server Type

Server IP

Server Port

Reliable Connection

Sending Frequency

Log Forwarding Filters
Device Filters

Log Filters

Enable Exclusions

Enter a name for the remote server.
Set to Onto enable log forwarding. Set to Off to disable log forwarding.

Select the type of remote server to which you are forwarding logs:
FortiAnalyzer, Syslog, or Common Event Format (CEF). The Syslog option
can be used when forwarding logs to FortiSIEM and FortiSOAR.

Enter the IP address of the remote server.

Enter the server port number. Default: 514.
This option is only available when the server type in not FortiAnalyzer.

Turn on to use TCP connection. Turn off to use UDP connection.

If you want to forward logs to a Syslog or CEF server, ensure this option is
supported.

RELP is not supported.

If the connection goes down, logs are buffered and automatically forwarded
when the connection is restored. The buffer limit is 12GB.

Select when logs will be sent to the server: Real-time, Every 1 Minute, or
Every 5 Minutes (default).

This option is only available when the server type is FortiAnalyzer.

Click Select Device, then select the devices whose logs will be forwarded.

Turn on to configure filter on the logs that are forwarded.
Select All or Any of the Following Conditions in the Log messages that
match field to control how the filters are applied to the logs.

Add filters to the table by selecting the Log Field, Match Criteria, and Value
for each filter.

This option is only available when the remove server is a Syslog or CEF
server.

Turn on to configure filter on the logs that are forwarded.

Add exclusions to the table by selecting the Device Type and Log Type.
Then, add Log Fields to the Exclusion List by clicking Fields and specifying
the excluded log fields in the Select Log Field pane.

server as unauthorized devices. To authorize devices, see Authorizing devices on page 26.

‘?' Devices whose logs are being forwarded to another FortiAnalyzer device are added to the
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Aggregation mode

Aggregation mode can only be configured using the CLI. Aggregation mode configurations are not listed in the GUI
table, but still use a log forwarding ID number.

Ay
‘?' Use the following CLI command to see what log forwarding IDs have been used:
get system log-forward

To configure the server:

1. If required, create a new administrator with the Super_User profile. See Creating administrators on page 224.
2. Enable log aggregation and, if necessary, configure the disk quota, with the following CLI commands:
config system log-forward-service
set accept-aggregation enable
set aggregation-disk-quota <quota>
end

To configure the client:

1. Open the log forwarding command shell:
config system log-forward

2. Create a new, or edit an existing, log forwarding entry:
edit <log forwarding ID>

o

Set the log forwarding mode to aggregation:
set mode aggregation

4. Set the server display name and IP address:

set server-name <string>

set server-ip <XxXX.XXX.XXX.XXX>

o

Enter the user name and password of the super user administrator on the server:
set agg-user <string>
set agg-password <string>

6. If required, set the aggregation time from 0 to 23 hours (default: 0, or midnight):
set agg-time <integer>
7. Enter the following to apply the configuration and create the log aggregation:

end
The following line will be displayed to confirm the creation of the log aggregation:

check for cfg[<log forwarding ID>] svr disp name=<server-name>

Ay
S L 4
9 For more information, see the FortiAnalyzer CLI Reference.

Managing log forwarding

Log forwarding mode server entries can be edited and deleted using both the GUI and the CLI. Aggregation mode
server entries can only be managed using the CLI. Entries cannot be enabled or disabled using the CLI.
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To enable or disable a log forwarding server entry:

1.
2.

4.

Go to System Settings > Log Forwarding.

Double-click on a server entry, right-click on a server entry and select Edit, or select a server entry then click Edit in
the toolbar. The Edit Log Forwarding pane opens.

Set the Status to Off to disable the log forwarding server entry, or set it to On to enable the server entry.
Only the name of the server entry can be edited when it is disabled.

Click OK to apply your changes.

To edit a log forwarding server entry using the GUI:

Go to System Settings > Log Forwarding.

Double-click on a server entry, right-click on a server entry and select Edit, or select a server entry then click Edit in
the toolbar. The Edit Log Forwarding pane opens.

Edit the settings as required, then click OK to apply your changes.

To edit a log forwarding server entry using the CLI:

1.

Open the log forwarding command shell:
config system log-forward

Enter an existing entry using its log forwarding 1D:
edit <log forwarding ID>

Edit the settings as required. See the FortiAnalyzer CLI Reference for information.

Enter the following command to apply your changes:
end

To delete a log forwarding server entry or entries using the GUI:

A oObdh-=

Go to System Settings > Log Forwarding.

Select the entry or entries you need to delete.

Click Delete in the toolbar, or right-click and select Delete.

Click OKin the confirmation dialog box to delete the selected entry or entries.

To delete a log forwarding server entry using the CLI:

1.

2.

Open the log forwarding command shell:
config system log-forward

Delete an entry using its log forwarding ID:
delete <log forwarding ID>

The log forwarding server entry is immediately deleted. There is no confirmation.

To delete all log forwarding entries using the CLI:

1.

Enter the following CLI command:
config system log-forward
purge
Enter y to delete all the entries.
This operation will clear all table!
Do you want to continue? (y/n)y
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Log forwarding buffer

When log forwarding is configured, FortiAnalyzer reserves space on the system disk as a buffer between the fortilogd
and logfwd daemons. In the event of a connection failure between the log forwarding client and server (network jams,
dropped connections, etc.), logs are cached as long as space remains available. When storage space is exceeded, older
logs are deleted in favor of new logs.

The default log forward buffer size is 30% of the system reserved disk size, and it can be configured up to 80%. The
system reserved disk size varies by platform and total available storage. See Disk space allocation on page 54.

For example, in a scenario where the FortiAnalyzer has a system reserved disk size of 50 GB, the default logfwd buffer
is 15 GB (30% of 50 GB), and the maximum configurable size is 40 GB (80% of 50 GB).

The log forward buffer is shared between fortilogd for all logfwd servers.

When changes are made to the log forward cache size, each server individually resets the log
reading position to the latest one, and all logs currently in the log-forward disk cache are
dropped.

To change the log forward cache size:

1. In the FortiAnalyzer CLlI, enter the following commands:

config system global
(global)# set log-forward-cache-size [number (GB)]

2. When prompted, enter Y to confirm the change.
Entering a number that is outside of the valid cache size range will cause the valid range to be displayed. For
example:

(global) # set log-forward-cache-size 360
Cache size must be within the range between 1GB and 240GB
node check object fail! for log-forward-cache-size 360

positions for the last log buffered and last log sent, as well as determine the buffer lag-behind.

s‘é’, The diagnose test application 3 CLIcommand can be used to display log
= See the FortiAnalyzer CLI Reference.

Fetcher Management

Log fetching is used to retrieve archived logs from one FortiAnalyzer device to another. This allows administrators to run
queries and reports against historic data, which can be useful for forensic analysis.

The fetching FortiAnalyzer can query the server FortiAnalyzer and retrieve the log data for a specified device and time
period, based on specified filters. The retrieved data are then indexed, and can be used for data analysis and reports.

Log fetching can only be done on two FortiAnalyzer devices running the same firmware. A FortiAnalyzer device can be
either the fetch server or the fetching client, and it can perform both roles at the same time with different FortiAnalyzer
devices. Only one log fetching session can be established at a time between two FortiAnalyzer devices.

The basic steps for fetching logs are:
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1. Onthe client, create a fetching profile. See Fetching profiles on page 196.
2. Onthe client, send the fetch request to the server. See Fetch requests on page 197.

3. Ifthisis the first time fetching logs with the selected profile, or if any changes have been made to the devices
and/or ADOMs since the last fetch, on the client, sync devices and ADOMs with the server. See Synchronizing
devices and ADOMs on page 199.

4. On the server, review the request, then either approve or reject it. See Request processing on page 199.

o

Monitor the fetch process on either FortiAnalyzer. See Fetch monitoring on page 200.
6. On the client, wait until the database is rebuilt before using the fetched data for analysis.

Fetching profiles

Fetching profiles can be managed from the Profiles tab on the System Settings > Fetcher Management pane.

Profiles can be created, edited, and deleted as required. The profile list shows the name of the profile, as well as the IP
address of the server it fetches from, the server and local ADOMs, and the administrator name on the fetch server.

To create a new fetching profile:

1. Onthe client, go to System Settings > Fetcher Management.

2. Select the Profiles tab, then click Create New in the toolbar, or right-click and select Create New from the menu.
The Create New Profile dialog box opens.

Create New Profile

Name
Server IP
User

Password At

3. Configure the following settings, then click OK to create the profile.

Name Enter a name for the profile.
Server IP Enter the IP address of the fetch server.
User Enter the username of an administrator on the fetch server, which, together

with the password, authenticates the fetch client's access to the fetch server.

Password Enter the administrator's password, which, together with the username,
authenticates the fetch client's access to the fetch server.

\,

‘?' The fetch server administrator user name and password must be for an administrator with
|| either a Standard_User or Super_User profile.
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To edit a fetching profile:

1. Goto System Settings > Fetching Management.

2. Double-click on a profile, right-click on a profile then select Edit, or select a profile then click Edit in the toolbar. The
Edit Profile pane opens.

3. Edit the settings as required, then click OK to apply your changes.

To delete a fetching profile or profiles:

1. Go to System Settings > Fetching Management.

2. Select the profile or profiles you need to delete.

3. Click Delete in the toolbar, or right-click and select Delete.

4. Click OKin the confirmation dialog box to delete the selected profile or profiles.

Fetch requests

A fetch request requests archived logs from the fetch server configured in the selected fetch profile. When making the
request, the ADOM on the fetch server the logs are fetched from must be specified. An ADOM on the fetching client
must be specified or, if needed, a new one can be created. If logs are being fetched to an existing local ADOM, you
must ensure the ADOM has enough disk space for the incoming logs.

The data policy for the local ADOM on the client must also support fetching logs from the specified time period. It must
keep both archive and analytics logs long enough so they will not be deleted in accordance with the policy. For example:
Today is July 1, the ADOM's data policy is configured to keep analytics logs for 30 days (June 1 - 30), and you need to
fetch logs from the first week of May. The data policy of the ADOM must be adjusted to keep analytics and archive logs
for at least 62 days to cover the entire time span. Otherwise, the fetched logs will be automatically deleted after they are
fetched.

To send a fetch request:

1. On the fetch client, go to System Settings > Fetcher Management and select the Profiles tab

2. Select the profile then click Request Fetch in the toolbar, or right-click and select Request Fetch from the menu.
The Fetch Logs dialog box opens.
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Fetch Logs

Name
Server IP
User

Secure Connection
Server ADOM
Local ADOM

Devices

Enable Filters

Time Period

Index Fetched Logs

FAZVMé&4
222222222222

admino

root
root

FortiGate-VM64

| 2017/01/30 B »
| 2017/02/04 B »

i}

Select Device 4=

3. Configure the following settings, then click Request Fetch.
The request is sent to the fetch server. The status of the request can be viewed in the Sessions tab.

Name
Server IP

User

Secure Connection

Server ADOM

Local ADOM

Devices

Enable Filters

Time Period

Index Fetch Logs

FortiAnalyzer 6.2.3 Administration Guide
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Displays the name of the fetch server you have specified.
Displays the IP address of the server you have specified.
Displays the username of the server administrator you have provided.
Select to use SSL connection to transfer fetched logs from the server.

Select the ADOM on the server the logs will be fetched from. Only one ADOM
can be fetched from at a time.

Select the ADOM on the client where the logs will be received.

Either select an existing ADOM from the dropdown list, or create a new ADOM
by entering a name for it into the field.

Add the devices and/or VDOMSs that the logs will be fetched from. Up to 256
devices can be added.

Click Select Device, select devices from the list, then click OK.

Select to enable filters on the logs that will be fetched.

Select All or Any of the Following Conditions in the Log messages that
match field to control how the filters are applied to the logs.

Add filters to the table by selecting the Log Field, Match Criteria, and Value
for each filter.

Specify what date and time range of log messages to fetch.

If selected, the fetched logs will be indexed in the SQL database of the client
once they are received. Select this option unless you want to manually index
the fetched logs.
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Synchronizing devices and ADOMs

If this is the first time the fetching client is fetching logs from the device, or if any changes have been made the devices
or ADOMs since the last fetch, then the devices and ADOMs must be synchronized with the server.

To synchronize devices and ADOMs:

1.
2.

On the client, go to System Settings > Fetcher Management and select the Profiles tab

Select the profile then click Sync Devices in the toolbar, or right-click and select Sync Devices from the menu.
The Sync Server ADOM(s) & Device(s) dialog box opens and shows the progress of the process.

Once the synchronization is complete, you can verify the changes on the client. For example, newly added devices
in the ADOM specified by the profile.

NP If a new ADOM is created, the new ADOM will mirror the disk space and data policy of the
‘Q' corresponding server ADOM. If there is not enough space on the client, the client will create
- an ADOM with the maximum allowed disk space and give a warning message. You can then

adjust disk space allocation as required.

Request processing

After a fetching client has made a fetch request, the request will be listed on the fetch server in the Received Request
section of the Sessions tab on the Fetcher Management pane. It will also be available from the notification center in
the GUI banner.

Fetch requests can be approved or rejected.

To process the fetch request:

1.

Go to the notification center in the GUI banner and click the log fetcher request, or go to the Sessions tab on the
System Settings > Fetcher Management pane.

«” Expand All # Collapse All

Request Time Host/Server IP User Status Action
w Received Request(1)
15:01:55 FAZVM64(FAZ-VMO0OD0000001) admino 8 Waiting for approval [:]

) Fetch Request(1)

Find the request in the Received Request section. You may have to expand the section, or select Expand All in
the content pane toolbar. The status of the request will be Waiting for approval.

3. Click Review to review the request. The Review Request dialog box will open.

Review Request
Host Name FAZVM&E4
Serial No. FAZ-VMO0000000000
Version v5.60
User Agg
Devices ADOM Device vDOM

root FGVMEVD000000000
Filters None
Time Period 16:02 2016/01/30 - 16:02 2017/02/02
Secure Connection

=
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4. Click Approve to approve the request, or click Reject to reject the request.
If you approve the request, the server will start to retrieve the requested logs in the background and send them to

the client. If you reject the request, the request will be canceled and the request status will be listed as Rejected on
both the client and the server.

Fetch monitoring

The progress of an approved fetch request can be monitored on both the fetching client and the fetch server.

Go to System Settings > Fetcher Management and select the Sessions tab to monitor the fetch progress. A fetch
session can be paused by clicking Pause, and resumed by clicking Resume. It can also be canceled by clicking Cancel.

Once the log fetching is completed, the status changes to Done and the request record can be deleted by clicking
Delete. The client will start to index the logs into the database.

It can take a long time for the client to finish indexing the fetched logs and make the analyzed

data available. A progress bar is shown in the GUI banner; for more information, click oniit to
open the Rebuild Log Database dialog box.

Log and report features will not be fully available until the rebuilding process is complete.

Event Log

The Event Log pane provides an audit log of actions made by users on FortiAnalyzer. It allows you to view log
messages that are stored in memory or on the internal hard disk drive. You can use filters to search the messages and
download the messages to the management computer.

See the FortiAnalyzer Log Message Reference, available from the Fortinet Document Library, for more information
about the log messages.

Go to System Settings > Event Log to view the local log list.

® Last 1 Hour~ 07:50:29 To 08:50:28

Add Filter Rkl ©
# ¥ Date/Time Device ID Sub Type User Message

1 08:16:36 FAZ-VM0000153588 system admin User 'admin’ with profile 'Super_User' login a...
2 08:16:36 FAZ-VM0000153588 system admin user ‘admin’ with profile ‘Super_User' timed ...
3 08:16:34 FAZ-VM0000153588 system admin user "admin’ with profile ‘Super_User' timed ...
4 08:08:44 FAZ-VM0000153588 fazsys system fazcfgd update app logo files: status='succes...
5 08:04:50 FAZ-VM0000153588 fazsys system fazcfgd update webfilter categories files: sta...
6 08:04:42 FAZ-VM0000153588 fazsys system fazcfgd update link prefixes file: status="succ..
7 08:04:05 FAZ-VM0000153588 logdev system Did not receive any log from device FGVMO..

8 07:59:49 FAZ-VM0000153588 diskquota system Total allocated disk quota of ADOMs (63.62 ...

The following options are available:

Add Filter Filter the event log list based on the log level, user, sub type, or message. See
Event log filtering on page 202.

Last... Select the amount of time to show from the available options, or select a custom
time span or any time.
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Column Settings
Tools

Raw Log /
Formatted Log

Real-time Log /
Historical Log

Case Sensitive
Search

Download

Pagination

The following information is shown:
#
Date/Time

Device ID

Sub Type

User

Message

FortiAnalyzer 6.2.3 Administration Guide
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Select which columns are enabled or disabled in the Event Log table.

Click on Raw Log to view the logs in their raw state.
Click Formatted Log to view them in the formatted into a table.

Click to view the real-time or historical logs list.

Enable or disable case sensitive searching.

Download the event logs in either CSV or the normal format to the management
computer.

Browse the pages of logs and adjust the number of logs that are shown per page.

The log number.
The date and time that the log file was generated.
The ID of the related device.

The log sub-type:

System manager event HA event

FG-FM protocol event Firmware manager event
Device configuration event FortiGuard service event
Global database event FortiClient manager event
Script manager event FortiMail manager event
Web portal event Debug I/0 log event
Firewall objects event Configuration change event
Policy console event Device manager event
VPN console event Web service event
Endpoint manager event FortiAnalyzer event
Revision history event Log daemon event
Deployment manager event FIPS-CC event
Real-time monitor event Managered devices event

Log and report manager event

The user that the log message relates to.

Log message details. A Session ID is added to each log message. The
username of the administrator is added to log messages wherever applicable for
better traceability.
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Event log filtering
The event log can be filtered using the Add Filter box in the toolbar.

To filter FortiView summaries using the toolbar:

1. Specify filters in the Add Filter box.

o Regular Search: In the selected summary view, click in the Add Filter box, select a filter from the dropdown
list, then type a value. Click NOT to negate the filter value. You can add multiple filters at a time, and connect
them with an "or".

« Advanced Search: Click the Switch to Advanced Search icon at the right end of the Add Filter box to switch to
advanced search mode. In this mode, you type in the whole search criteria (log field names and values). Click
the Switch to Regular Search icon to return to regular search.

2. Click Goto apply the filter.

Task Monitor

Using the task monitor, you can view the status of the tasks you have performed.

Go to System Settings > Task Monitor to view the task monitor. The task list size can also be configured; see
Advanced Settings on page 220.

Bl Delete View: ’

1 2 3 4|5 ped= last=> |25 ~

O i Source Description Status Start Time ADOM

User
n ' Policy Consistency Check | Policy Check Tue May 29 08:43:50 2018 |FG60
admin %
1

(10f1)
Total:1 Pending:0 In Progress:1 Completed ( @ Success:0 4, Warning:0 g4 Error:0 )

1 FG60 (" J D generating report @
1 (1of1)
0 3610 * Install Package Copy Package 'Root/FortiGate-VM64_root’ o — (-] Tue May 29 08:43:47 2018 FG60
O 3609 * Import Wizard Import Device Objs/Policy o — @ Tue May 29 08:41:01 2018 FG60
] 3608 ¥ Import Wizard Import Device Objs/Policy o P (] Tue May 29 08:40:48 2018 FG60
[J 3607 ¥ Import Wizard Import Device Objs/Policy o admin @ Tue May 29 08:40:34 2018 FG60
[0 3606 P Device Manager Retrieve Device Configuration firmware_manager @ Tue May 29 08:35:18 2018 FG60
[J 3605 * Firmware Manager Device Image Upgrade o admin ] Tue May 29 08:32:25 2018 FG60
[0 3604 * Device Manager Add/delete Unregistered Devices o — @ Tue May 29 08:31:10 2018 FG60
v
The following options are available:
Delete Remove the selected task or tasks from the list.

This changes to Cancel Running Task(s) when View is Running.

View Select which tasks to view from the dropdown list, based on their status. The
available options are: Running, Pending, Done, Error, Cancelling, Cancelled,
Aborting, Aborted, Warning, and All.
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Expand Arrow

Group Error
Devices

History

Pagination

In the Source column, select the expand arrow icon to display the specific actions
taken under this task.

To filter the specific actions taken for a task, select one of the options on top of
the action list. Select the history icon to view specific information on task
progress. This can be useful when troubleshooting warnings and errors.

Select Group Error Devices to create a group of the failed devices, allowing for
re-installations to easily be done on only the failed devices.

Click the history icon to view task details in a new window.

Browse the pages of tasks and adjust the number of tasks shown per page.

The following information is available:

ID

Source
Description

User

Status

Start Time
ADOM

History

SNMP

The identification number for a task.

The platform from where the task is performed. Click the expand arrow to view
details of the specific task and access the history button.

The nature of the task. Click the arrow to display the specific actions taken under
this task.

The user or users who performed the tasks.

The status of the task (hover over the icon to view the description):
o Done: Completed with success.
o Error. Completed without success.
« Canceled: User canceled the task.
o Canceling: User is canceling the task.
« Aborted: The FortiAnalyzer system stopped performing this task.
« Aborting: The FortiAnalyzer system is stopping performing this task.

« Running: Being processed. In this status, a percentage bar appears in the
Status column.

o Pending
o Waming

The time that the task was started.
The ADOM associated with the task.

Click the history button to view task details.

Enable the SNMP agent on the FortiAnalyzer device so it can send traps to and receive queries from the computer that
is designated as its SNMP manager. This allows for monitoring the FortiAnalyzer with an SNMP manager.

FortiAnalyzer 6.2.3 Administration Guide
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SNMP has two parts - the SNMP agent that is sending traps, and the SNMP manager that monitors those traps. The
SNMP communities on monitored FortiGate devices are hard coded and configured by the FortiAnalyzer system - they
are not user configurable.

The FortiAnalyzer SNMP implementation is read-only — SNMP v1, v2c, and v3 compliant SNMP manager applications,
such as those on your local computer, have read-only access to FortiAnalyzer system information and can receive
FortiAnalyzer system traps.

SNMP agent

The SNMP agent sends SNMP traps originating on the FortiAnalyzer system to an external monitoring SNMP manager
defined in a SNMP community. Typically an SNMP manager is an application on a local computer that can read the
SNMP traps and generate reports or graphs from them.

The SNMP manager can monitor the FortiAnalyzer system to determine if it is operating properly, or if there are any
critical events occurring. The description, location, and contact information for this FortiAnalyzer system will be part of
the information an SNMP manager will have — this information is useful if the SNMP manager is monitoring many
devices, and it will enable faster responses when the FortiAnalyzer system requires attention.

Go to System Settings > Advanced > SNMP to configure the SNMP agent.

SNMP

SNMP Agent Enable
Description
Location
Contact
SNMP viA2c
+ Create New [# Edit [ Delete Q
[0 4 Community Name Queries Traps Enable
SNMP v3
=+ Create New [ Edit [ Delete Q

4 User Name Security Level Notification Hosts Queries
Bliss No Authentication, No Privacy
Danesl Authentication, No Privacy

Fallom Authenticatian, Privacy

m}
m}
[m}
m}
[m}

The following information and options are available:

Golan No Authentication, No Privacy

SNMP Agent Select to enable the SNMP agent. When this is enabled, it sends FortiAnalyzer
SNMP traps.
Description Optionally, type a description of this FortiAnalyzer system to help uniquely
identify this unit.
Location Optionally, type the location of this FortiAnalyzer system to help find it in the

event it requires attention.

Contact Optionally, type the contact information for the person in charge of this
FortiAnalyzer system.

SNMP v1/2c The list of SNMP v1/v2c communities added to the FortiAnalyzer configuration.
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Create New

Edit
Delete
Community Name

Queries

Traps

Enable
SNMP v3

Create New

Edit

Delete

User Name
Security Level
Notification Hosts

Queries

SNMP v1/v2c communities

Select Create New to add a new SNMP community. If SNMP agent is not
selected, this control will not be visible.

For more information, see SNMP v1/v2c communities on page 205.
Edit the selected SNMP community.

Delete the selected SNMP community or communities.

The name of the SNMP community.

The status of SNMP queries for each SNMP community. The enabled icon
indicates that at least one query is enabled. The disabled icon indicates that all
queries are disabled.

The status of SNMP traps for each SNMP community. The enabled icon indicates
that at least one trap is enabled. The disabled icon indicates that all traps are
disabled.

Enable or disable the SNMP community.
The list of SNMPv3 users added to the configuration.

Select Create New to add a new SNMP user. If SNMP agent is not selected, this
control will not be visible.

For more information, see SNMP v3 users on page 208.
Edit the selected SNMP user.

Delete the selected SNMP user or users.

The user name for the SNMPv3 user.

The security level assigned to the SNMPv3 user.

The notification host or hosts assigned to the SNMPv3 user.

The status of SNMP queries for each SNMP user. The enabled icon indicates
queries are enabled. The disabled icon indicates they are disabled.

An SNMP community is a grouping of equipment for network administration purposes. You must configure your
FortiAnalyzer to belong to at least one SNMP community so that community’s SNMP managers can query the
FortiAnalyzer system information and receive SNMP traps from it.

\,

‘?' These SNMP communities do not refer to the FortiGate devices the FortiAnalyzer system is
- managing.

Each community can have a different configuration for SNMP traps and can be configured to monitor different events.
You can add the IP addresses of up to eight hosts to each community. Hosts can receive SNMP device traps and

information.

FortiAnalyzer 6.2.3 Administration Guide
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To create a new SNMP community:

1. Goto System Settings > Advanced > SNMP and ensure the SNMP agent is enabled.
2. Inthe SNMP v1/v2c section, click Create New in the toolbar. The New SNMP Community pane opens.

New SNMP Community
Protocol Port
vi 161
v2c 161
Traps:
Protocol Port

vl 162

v2c 162

SNMP Event

nterface IP changed

Log Disk Space Low

CPU Overuse

Memory Low

System Restart

CPU usage exclude NICE threshold
HA Failover

RAID Event

Power Supply Failed

Fan Speed Out Of Range
Temperature Out Of Range

Voltage Out Of Range

Enable
-]
-]

Enable
-]
-]

Enable

3. Configure the following options, then click OK to create the community.

Name

Hosts

IP
Address/Netmask

Interface

Delete

FortiAnalyzer 6.2.3 Administration Guide
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Enter a name to identify the SNMP community. This name cannot be edited
later.

The list of hosts that can use the settings in this SNMP community to monitor
the FortiAnalyzer system.

When you create a new SNMP community, there are no host entries. Select
Add to create a new entry that broadcasts the SNMP traps and information to
the network connected to the specified interface.

Enter the IP address and netmask of an SNMP manager.

By default, the IP address is 0.0.0.0 so that any SNMP manager can use this
SNMP community.

Select the interface that connects to the network where this SNMP manager is
located from the dropdown list. This must be done if the SNMP manager is on
the Internet or behind a router.

Click the delete icon to remove this SNMP manager entry.
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Add
Queries
Traps
SNMP Event

To edit an SNMP community:

Select to add another entry to the Hosts list. Up to eight SNMP manager
entries can be added for a single community.

Enter the port number (161 by default) the FortiAnalyzer system uses to send
v1 and v2c queries to the FortiAnalyzer in this community. Enable queries for
each SNMP version that the FortiAnalyzer system uses.

Enter the Remote port number (162 by default) the FortiAnalyzer system uses
to send v1 and v2c traps to the FortiAnalyzer in this community. Enable traps
for each SNMP version that the FortiAnalyzer system uses.

Enable the events that will cause SNMP traps to be sent to the community.

Interface IP changed

Log disk space low

CPU Overuse

Memory Low

System Restart

CPU usage exclude NICE threshold

RAID Event (only available for devices that support RAID)
Power Supply Failed (only available on supported hardware devices)
Fan Speed Out of Range

Temperature Out of Range

Voltage Out of Range

High licensed device quota

High licensed log GB/day

Log Alert

Log Rate

Data Rate

FortiAnalyzer feature set SNMP events:

1. Goto System Settings > Advanced > SNMP.

2. Inthe SNMP v1/v2c section, double-click on a community, right-click on a community then select Edit, or select a
community then click Edit in the toolbar. The Edit SNMP Community pane opens.

3. Edit the settings as required, then click OK to apply your changes.

To delete an SNMP community or communities:

Go to System Settings > Advanced > SNMP.

1

2. Inthe SNMP v1/v2c section, select the community or communities you need to delete.
3. Click Delete in the toolbar, or right-click and select Delete.
4

Click OK in the confirmation dialog box to delete the selected community or communities.

FortiAnalyzer 6.2.3 Administration Guide
Fortinet Technologies Inc.

207



System Settings

SNMP v3 users

The FortiAnalyzer SNMP v3 implementation includes support for queries, traps, authentication, and privacy. SNMP v3

users can be created, edited, and deleted as required.

To create a new SNMP user:

1. Goto System Settings > Advanced > SNMP and ensure the SNMP agent is enabled.
2. Inthe SNMP v3section, click Create New in the toolbar. The New SNMP User pane opens.

New SNMP User

User Name

Security Level No Authentication, No Privacy

Queries Enable
Notification Hosts

SNMP Event

nterface IP changed

Log Disk Space Low

CPU Overuse

Memaory Low

System Restart

CPU usage exclude NICE threshold
HA Failover

RAID Event

Power Supply Failed

Fan Speed Out Of Range
Temperature Out Of Range

Voltage Out Of Range

Port

Enable

oo 0o 0o 0o o 0o ooooaQ

3. Configure the following options, then click OK to create the community.

User Name

Security Level

Queries

Notification Hosts

FortiAnalyzer 6.2.3 Administration Guide
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The name of the SNMP v3 user.

The security level of the user. Select one of the following:
« No Authentication, No Privacy

« Authentication, No Privacy: Select the Authentication Algorithm (SHA1,
MD5) and enter the password.

« Authentication, Privacy: Select the Authentication Algorithm (SHA1,
MD5), the Private Algorithm (AES, DES), and enter the passwords.

Select to enable queries then enter the port number. The default port is 161.

The IP address or addresses of the host. Click the add icon to add multiple IP
addresses.
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SNMP Event Enable the events that will cause SNMP traps to be sent to the SNMP
manager.

« Interface IP changed
o Log disk space low
« CPU Overuse
o Memory Low
« System Restart
o CPU usage exclude NICE threshold
o RAID Event (only available for devices that support RAID)
« Power Supply Failed (only available on supported hardware devices)
« Highlicensed device quota
o Highlicensed log GB/day
o LogAlert
« Log Rate
o DataRate
o Fan Speed Out of Range
o Temperature Out of Range
« Voltage Out of Range
FortiAnalyzer feature set SNMP events:

To edit an SNMP user:

1. Goto System Settings > Advanced > SNMP.

2. Inthe SNMP v3section, double-click on a user, right-click on a user then select Edit, or select a user then click Edit
in the toolbar. The Edit SNMP User pane opens.

3. Edit the settings as required, then click OK to apply your changes.

To delete an SNMP user or users:

1. Goto System Settings > Advanced > SNMP.

2. Inthe SNMP v3 section, select the user or users you need to delete.

3. Click Delete in the toolbar, or right-click and select Delete.

4. Click OKin the confirmation dialog box to delete the selected user or users.

SNMP MIBs

The Fortinet and FortiAnalyzer MIBs, along with the two RFC MIBs, can be obtained from Customer Service & Support
(https://support.fortinet.com). You can download the FORTINET-FORTIMANAGER-FORTIANALYZER-MIB.mib
MIB file in the firmware image file folder. The FORTINET-CORE-MIB.mib file is located in the main FortiAnalyzer 5.00
file folder.

RFC support for SNMP v3 includes Architecture for SNMP Frameworks (RFC 3411), and partial support of User-based
Security Model (RFC 3414).

To be able to communicate with the SNMP agent, you must include all of these MIBs into your SNMP manager.
Generally your SNMP manager will be an application on your local computer. Your SNMP manager might already
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include standard and private MIBs in a compiled database that is ready to use. You must add the Fortinet and
FortiAnalyzer proprietary MIBs to this database.

MIB file name or RFC Description

FORTINET-CORE-MIB.mib The proprietary Fortinet MIB includes all system configuration information and
trap information that is common to all Fortinet products.

Your SNMP manager requires this information to monitor Fortinet unit
configuration settings and receive traps from the Fortinet SNMP agent.

FORTINET-FORTIMANAGER-  The proprietary FortiAnalyzer MIB includes system information and trap

MIB.mib information for FortiAnalyzer units.
RFC-1213 (MIB II) The Fortinet SNMP agent supports MIB Il groups with the following exceptions.
o No support for the EGP group from MIB |l (RFC 1213, section 3.11 and
6.10).

« Protocaol statistics returned for MIB Il groups (IP/ICMP/TCP/UDP/etc.) do not
accurately capture all Fortinet traffic activity. More accurate information can
be obtained from the information reported by the Fortinet MIB.

RFC-2665 (Ethernet-like MIB) The Fortinet SNMP agent supports Ethernet-like MIB information with the
following exception.

No support for the dot3Tests and dot3Errors groups.

SNMP traps

Fortinet devices share SNMP traps, but each type of device also has traps specific to that device type. For example
FortiAnalyzer units have FortiAnalyzer specific SNMP traps. To receive Fortinet device SNMP traps, you must load and
compile the FORTINET-CORE-MIB into your SNMP manager.

Traps sent include the trap message as well as the unit serial number (fnSysSerial) and host name (sysName). The Trap
Message column includes the message that is included with the trap, as well as the SNMP MIB field name to help
locate the information about the trap.

Trap message Description

ColdStart, WarmStart, LinkUp,  Standard traps as described in RFC 1215.

LinkDown
CPU usage high CPU usage exceeds the set percent. This threshold can be set in the CLI using
(fnTrapCpuThreshold) the following commands:

config system snmp sysinfo

set trap-high-cpu-threshold <percentage value>

end
CPU usage excluding NICE CPU usage excluding NICE processes exceeds the set percentage. This
processes threshold can be set in the CLI using the following commands:

(fmSysCpuUsageExcludedNice) config system snmp sysinfo
set trap-cpu-high-exclude-nice-threshold <percentage value>

end
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Trap message Description
Memory low Memory usage exceeds 90 percent. This threshold can be set in the CLI using
(fnTrapMemThreshold) the following commands:

config system snmp sysinfo
set trap-low-memory-threshold <percentage value>

end
Log disk too full Log disk usage has exceeded the configured threshold. Only available on
(fnTrapLogDiskThreshold) devices with log disks.
Temperature too high A temperature sensor on the device has exceeded its threshold. Not all devices
(fnTrapTempHigh) have thermal sensors. See manual for specifications.
Voltage outside acceptable Power levels have fluctuated outside of normal levels. Not all devices have
range voltage monitoring instrumentation.
(fnTrapVoltageOutOfRange)
Power supply failure Power supply failure detected. Available on some devices that support
(fnTrapPowerSupplyFailure) redundant power supplies.
Interface IP change The IP address for an interface has changed. The trap message includes the
(fnTraplpChange) name of the interface, the new IP address and the serial number of the Fortinet

unit. You can use this trap to track interface IP address changes for interfaces
with dynamic IP addresses set using DHCP or PPPoE.

Log rate too high The incoming log rate has exceeded the peak log rate threshold.

(fmTrapLogRateThreshold) To determine the peak log rate, use the following CLI command: get system
loglimits

Data rate too high The incoming data rate has exceeded the peak data rate threshold.

(fmTrapLogDataRateThreshold) The peak data rate is calculated using the peak log rate x 512 bytes (average log
size).

Fortinet & FortiAnalyzer MIB fields

The Fortinet MIB contains fields reporting current Fortinet unit status information. The below tables list the names of
the MIB fields and describe the status information available for each one. You can view more details about the
information available from all Fortinet MIB fields by compiling the fortinet.3.00.mib file into your SNMP manager
and browsing the Fortinet MIB fields.

System MIB fields:

MIB field Description

fnSysSerial Fortinet unit serial number.
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Administrator accounts:

fnAdminNumber The number of administrators on the Fortinet unit.
fnAdminTable Table of administrators.
fnAdminindex Administrator account index number.
fnAdminName The user name of the administrator account.
fnAdminAddr An address of a trusted host or subnet from
which this administrator account can be
used.
fnAdminMask The netmask for fnAdminAddr.

Custom messages:

MIB field Description

fnMessages The number of custom messages on the Fortinet unit.

MIB fields and traps

MIB field Description

fmModel Atable of all FortiAnalyzer models.

Mail Server

A mail server allows the FortiAnalyzer to sent email messages, such as notifications when reports are run or specific
events occur. Mail servers can be added, edited, deleted, and tested.

Go to System Settings > Advanced > Mail Server to configure SMTP mail server settings.

Al
‘9' If an existing mail server is in use, the delete icon is removed and the mail server entry cannot
- be deleted.
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To add a mail server:

1. Goto System Settings > Advanced > Mail Server.
2. Click Create New in the toolbar. The Create New Mail Server Settings pane opens.

Create New Mail Server Settings
SMTP Server Name
Mail Server
SMTP Server Port 25
Enable Authentication
E-Mail Account

Password

3. Configure the following settings and then select OK to create the mail server.

SMTP Server Name Enter a name for the SMTP server.

Mail Server Enter the mail server information.

SMTP Server Port Enter the SMTP server port number. The default port is 25.

Enable Authentication Select to enable authentication.

Email Account Enter an email account. This option is only accessible when authentication is
enabled.

Password Enter the email account password. This option is only accessible when

authentication is enabled.

To edit a mail server:

1. Goto System Settings > Advanced > Mail Server.

2. Double-click on a server, right-click on a server and then select Edit from the menu, or select a server then click Edit
in the toolbar. The Edit Mail Server Settings pane opens.

3. Edit the settings as required, and then click OK to apply the changes.

To test the mail server:

Go to System Settings > Advanced > Mail Server.
Select the server you need to test.
Click Test from the toolbar, or right-click and select Test.

A oODd=

Type the email address you would like to send a test email to and click OK. A confirmation or failure message will
be displayed.
5. Click OK to close the confirmation dialog box.

To delete a mail server or servers:

Go to System Settings > Advanced > Mail Server.
Select the server or servers you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Click OKin the confirmation box to delete the server.

PO D=
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Syslog Server

Go to System Settings > Advanced > Syslog Server to configure syslog server settings. Syslog servers can be added,
edited, deleted, and tested.

Al
‘?' If an existing syslog server is in use, the delete icon is removed and the server entry cannot be
deleted.

To add a syslog server:

Go to System Settings > Advanced > Syslog Server.
Click Create New in the toolbar. The Create New Syslog Server Settings pane opens.

Create New Syslog Server Settings

Name
IP address (or FQDN)

Syslog Server Port 514

o

Configure the following settings and then select OK to create the mail server.

Name Enter a name for the syslog server.
IP address (or FQDN) Enter the IP address or FQDN of the syslog server.
Syslog Server Port Enter the syslog server port number. The default port is 514.

To edit a syslog server:

Go to System Settings > Advanced > Syslog Server.

Double-click on a server, right-click on a server and then select Edit from the menu, or select a server then click Edit
in the toolbar. The Edit Syslog Server Settings pane opens.

Edit the settings as required, and then click OK to apply the changes.

To test the syslog server:

Go to System Settings > Advanced > Syslog Server.
Select the server you need to test.

Click Test from the toolbar, or right-click and select Test.
A confirmation or failure message will be displayed.

To delete a syslog server or servers:

A oODdD=

Go to System Settings > Advanced > Syslog Server.

Select the server or servers you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Click OK in the confirmation box to delete the server or servers.
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Meta Fields

Meta fields allow administrators to add extra information when configuring, adding, or maintaining FortiGate units or
adding new administrators. You can make the fields mandatory or optional, and set the length of the field.

With the fields set as mandatory, administrators must supply additional information when they create a new FortiGate
object, such as an administrator account or firewall policy. Fields for this new information are added to the FortiGate
unit dialog boxes in the locations where you create these objects. You can also provide fields for optional additional
information.

Go to System Settings > Advanced > Meta Fields to configure meta fields. Meta fields can be added, edited, and

deleted.
+ Create New [# Edit & Delete " Expand All s Collapse All
O i Meta Fields Length Importance Status
O Contact Email 50 Optional Enabled
0O Contact Phone 50 Optional Enabled
0O City 50 Optional Enabled
O Company/Organization 50 Optional Enabled
O Contact 50 Optional Enabled
0O Country 50 Optional Enabled
O Province/State 50 Optional Enabled
\‘ ! 'l
? Select Expand All or Contract All from the toolbar or right-click menu to view all of or none of
the meta fields under each object.
-—

To create a new meta field:

Go to System Settings > Advanced > Meta Fields.
Click Create New in the toolbar. The Create New Meta Field pane opens.

Create New Meta Fields

Object

Name

Length

Importance Optional (& Required

Status

Disabled (3) Enabled

3. Configure the following settings and then select OK to create the meta field.

Object The object this metadata field applies to: Devices, Device Groups, or
Administrative Domains.

Name Enter the label to use for the field.

Length Select the maximum number of characters allowed for the field from the

dropdown list: 20, 50, or 255.

Importance Select Required to make the field compulsory, otherwise select Optional.

Status Select Disabled to disable this field. The default selection is Enabled.
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To edit a meta field:

1. Goto System Settings > Advanced > Meta Fields.

2. Double-click on a field, right-click on a field and then select Edit from the menu, or select a field then click Edit in
the toolbar. The Edit Meta Fields pane opens.

3. Edit the settings as required, and then click OK to apply the changes.

Al
S L 4
? The Object and Name fields cannot be edited.

To delete a meta field or fields:

1. Goto System Settings > Advanced > Meta Fields.

2. Select the field or fields you need to delete.

3. Click Delete in the toolbar, or right-click and select Delete.
4. Click OKin the confirmation box to delete the field or fields.

\‘ ! 'l
? The default meta fields cannot be deleted.

Device logs

The FortiAnalyzer allows you to log system events to disk. You can control device log file size and the use of the
FortiAnalyzer unit’s disk space by configuring log rolling and scheduled uploads to a server.

As the FortiAnalyzer unit receives new log items, it performs the following tasks:
« Verifies whether the log file has exceeded its file size limit.
+ Checkstoseeif it istime to roll the log file if the file size is not exceeded.

When a current log file (t Log . 1og) reaches its maximum size, or reaches the scheduled time, the FortiAnalyzer unit
rolls the active log file by renaming the file. The file name will be in the form of x10g.N. 1og (for example,
tlog.1252929496.109g), where x is a letter indicating the log type and N is a unique number corresponding to the
time the first log entry was received. The file modification time will match the time when the last log was received in the
log file.

Once the current log file is rolled into a numbered log file, it will not be changed. New logs will be stored in the new

current log called t1og. Log. If log uploading is enabled, once logs are uploaded to the remote server or downloaded

via the GUI, they are in the following format:
FG3K6A3406600001-t10g.1252929496.10g-2017-09-29-08-03-54.9z

If you have enabled log uploading, you can choose to automatically delete the rolled log file after uploading, thereby
freeing the amount of disk space used by rolled log files. If the log upload fails, such as when the FTP server is
unavailable, the logs are uploaded during the next scheduled upload.

Log rolling and uploading can be enabled and configured using the GUI or CLI.
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Configuring rolling and uploading of logs using the GUI

Go to System Settings > Advanced > Device Log Setting to configure device log settings.

Device Log Settings
Registered Device Logs

Roll log file when size exceeds (10-1000)MB

ERoll log files at scheduled time

Dailly v 00 + |Hour | 0o + | Minute
B upload logs using a standard file transfer protocol
Upload Server Type FTP
Upload Server IP 0.0.0.0
User Name
Passwort d -
Remote Directory
Upload Log Files @When rolled Dailyat 00 + Hour

Upload log files in gzip file format

Delete log files after uploading

Local Device Log

Esend the local event logs to FortiAnalyzer/FortiManager
1P Address
Upload Option @Real-time O Schedule Time
Severity Level Emergency

E2Reliable log transmissi

Secure connection

L ror ]

Configure the following settings, and then select Apply:

Registered Device Logs
Roll log file when size exceeds

Roll log files at scheduled time

Upload logs using a standard
file transfer protocol

Upload Server Type
Upload Server IP
User Name
Password

Remote Directory

Upload Log Files

Upload rolled files in
gzip file format
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Enter the log file size, from 10 to 500MB. Default: 200MB.

Select to roll logs daily or weekly.
o Daily: select the hour and minute value in the dropdown lists.
« Weekly: select the day, hour, and minute value in the dropdown
lists.

Select to upload logs and configure the following settings.

Select one of FTP, SFTP, or SCP.

Enter the IP address of the upload server.

Enter the username used to connect to the upload server.
Enter the password used to connect to the upload server.

Enter the remote directory on the upload server where the log will be
uploaded.

Select to upload log files when they are rolled according to settings
selected under Roll Logs, or daily at a specific hour.

Select to gzip the logs before uploading. This will result in smaller logs
and faster upload times.
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Delete files after Select to remove device log files from the FortiAnalyzer system after
uploading they have been uploaded to the Upload Server.

Local Device Log

Send the local event logs to Select to send local event logs to another FortiAnalyzer or FortiManager
FortiAnalyzer / FortiManager device.

IP Address Enter the IP address of the FortiAnalyzer or FortiManager.

Upload Option Select to upload logs in real time or at a scheduled time.

When selecting a scheduled time, you can specify the hour and minute
to upload logs each day.

Severity Level Select the minimum log severity level from the dropdown list. This
option is only available when Upload Option is Realtime.

Reliable log Select to use reliable log transmission.
transmission

Secure connection Select to use a secure connection for log transmission. This option is
only available when Reliable log transmission is selected.

Configuring rolling and uploading of logs using the CLI

Log rolling and uploading can be enabled and configured using the CLI. For more information, see the FortiAnalyzer
CLI Reference.

Enable or disable log file uploads
Use the following CLI commands to enable or disable log file uploads.

To enable log uploads:

config system log settings
config rolling-regular
set upload enable
end

To disable log uploads:
config system log settings
config rolling-regular

set upload disable
end

Roll logs when they reach a specific size

Use the following CLI commands to specify the size, in MB, at which a log file is rolled.
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To roll logs when they reach a specific size:

config system log settings
config rolling-regular
set file-size <integer>
end

Roll logs on a schedule

Use the following CLI commands to configure rolling logs on a set schedule, or never.

To disable log rolling:

config system log settings
config rolling-regular
set when none
end

To enable daily log rolling:

config system log settings
config rolling-regular
set upload enable
set when daily
set hour <integer>
set min <integer>
end

To enable weekly log rolling:

config system log settings
config rolling-regular
set when weekly
set days {mon | tue | wed | thu | fri | sat | sun}
set hour <integer>
set min <integer>
end

Upload logs to cloud storage

The FortiAnalyzer can be set to upload logs to cloud storage. Before enabling this feature, you must have a valid
Storage Connector Service license. See License Information widget on page 162.

For information on setting up a storage fabric connector, see Creating or editing storage connectors on page 33.

To upload logs to cloud storage:

1. Goto System Settings > Advanced > Device Log Settings.
2. Select Create New.
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3. Complete the following options, and click OK.
« Enter a name for the cloud storage.

« Inthe Cloud Storage Connector list, select a Fabric Connector.
« Inthe Remote Path box, type the bucket or container name from the storage account.

File Management

FortiAnalyzer allows you to configure automatic deletion of device log files, quarantined files, reports, and content

archive files after a set period of time.

Go to System Settings > Advanced > File Management to configure file management settings.

File Management

Automatically Delete

Device log files older than 365

Reports older than 365

Content archive files older than 365

Quarantined files older than 365

Scheduled daily at time
Scheduled daily at time
Scheduled daily at time

Scheduled daily at time

=

Configure the following settings, and then select Apply:

Device log files older than

Reports older than

Content archive files older
than

Quarantined files older than

The time period you select determines how often the item is checked. If you select Months, then the item is checked
once per month. If you select Weeks, then the item is checked once per week, and so on. For example, if you specify
Device log files older than 3 Months, then on July 1, the logs for April, May, and June are kept and the logs for March

and older are deleted.

Advanced Settings

Go to System Settings > Advanced > Advanced Settings to view and configure advanced settings and download

WSDL files.

Select to enable automatic deletion of compressed log files.

Enter a value in the text field, select the time period (Days, Weeks, or Months),
and choose a time of day.

Select to enable automatic deletion of reports of data from compressed log files.
Enter a value in the text field, select the time period, and choose a time of day.

Select to enable automatic deletion of IPS and DP archives from Archive logs.
Enter a value in the text field, select the time period, and choose a time of day.

Select to enable automatic deletion of compressed log files of quarantined files.
Enter a value in the text field, select the time period, and choose a time of day.
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Configure the following settings and then select Apply:

ADOM Mode

Download WSDL file

Task List Size

Select the ADOM mode, either Normal or Advanced.

Advanced mode will allow you to assign a VDOM from a single device to a
different ADOM, but will result in more complicated management scenarios. It is
recommended only for advanced users.

Select the required WSDL functions then click the Download button to download
the WSDL file to your management computer.

When selecting Legacy Operations, no other options can be selected.

Web services is a standards-based, platform independent, access method for
other hardware and software APIs. The file itself defines the format of commands
the FortiAnalyzer will accept as well as the responses to expect. Using the WSDL
file, third-party or custom applications can communicate with the FortiAnalyzer
unit and operate it or retrieve information, just as an administrator can from the
GUI or CLI.

Set a limit on the size of the task list. Default: 2000.
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The System Settings > Admin menu enables you to configure administrator accounts, access profiles, remote
authentication servers, and adjust global administrative settings for the FortiAnalyzer unit.

Administrator accounts are used to control access to the FortiAnalyzer unit. Local and remote authentication is
supported, as well as two-factor authentication. Administrator profiles define different types of administrators and the
level of access they have to the FortiAnalyzer unit, as well as its authorized devices.

Global administration settings, such as the GUI language and password policies, can be configured on the Admin
Settings pane. See Global administration settings on page 243 for more information.

This section contains the following topics:

« Trusted hosts on page 222

« Monitoring administrators on page 222

« Disconnecting administrators on page 223

« Managing administrator accounts on page 223
o Administrator profiles on page 228

« Authentication on page 234

o Global administration settings on page 243

« Two-factor authentication on page 246

Trusted hosts

Setting trusted hosts for all of your administrators increases the security of your network by further restricting
administrative permissions. In addition to knowing the password, an administrator must connect only through the
subnet or subnets you specify. You can even restrict an administrator to a single |P address if you define only one
trusted host IP address with a netmask of 255.255.255.255.

When you set trusted hosts for all administrators, the FortiAnalyzer unit does not respond to administrative access
attempts from any other hosts. This provides the highest security. If you leave even one administrator unrestricted, the
unit accepts administrative access attempts on any interface that has administrative access enabled, potentially
exposing the unit to attempts to gain unauthorized access.

The trusted hosts you define apply to both the GUI and to the CLI when accessed through SSH. CLI access through the
console connector is not affected.

Ay
‘Q' If you set trusted hosts and want to use the Console Access feature of the GUI, you must also
- set 127.0.0.1/255.255.255.255 as a trusted host.

Monitoring administrators

The Admin Session List lets you view a list of administrators currently logged in to the FortiAnalyzer unit.
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To view logged in administrators:

1.
2.

Disconnecting administrators

Go to System Settings > Dashboard.

In the System Information widget, in the Current Administrators field, click the Current Session List button. The

Admin Session List opens in the widget.
The following information is available:

User Name The name of the administrator account. Your session is indicated by (current).

IP Address The IP address where the administrator is logging in from. This field also displays the
logon type (GUI, jsconsole, or SSH).

Start Time The date and time the administrator logged in.

Time Out (mins) The maximum duration of the session in minutes (1 to 480 minutes).

Administrators can be disconnected from the FortiAnalyzer unit from the Admin Session List.

To disconnect administrators:

1.
2

Go to System Settings > Dashboard.

In the System Information widget, in the Current Administrators field, click the Current Session List button. The

Admin Session List opens in the widget.

Select the administrator or administrators you need to disconnect.

Click Delete in the toolbar, or right-click and select Delete.

The selected administrators will be automatically disconnected from the FortiAnalyzer device.

Managing administrator accounts

Go to System Settings > Admin > Administrator to view the list of administrators and manage administrator accounts.

Only administrators with the Super_User profile can see the complete administrators list. If you do not have certain
viewing permissions, you will not see the administrator list. When ADOMSs are enabled, administrators can only access

the ADOMSs they have permission to access.

+ Create New [ Edit

Seq.d# Name Type
1 LI LDAP
Wildcard
2 R RADIUS
Wildcard
3 TS TACACS+
Wildcard
s Q 1ocaL
5 o admin2 LOcAL
s © ~ror LocaL
7 O servicenow2 LocAL

¥ Clone ¥ Delete [El TableView~ % Column Settings v

Profile

Teltro

Sup

Standard_User

Super_User

Super_User

Restricted_User

Restricted_User
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ADOMs
FortiClient
FortiCarrier
FortiCache
All ADOMs.

Exclude:
FortiAnalyzer
All ADOMs

AllADOMs
AllADOMs.

All ADOMs.

Trusted IPv4 Hosts
0.0.0.0/0.0.0.0
0.0.0.0/0.0.0.0
0.0.0.0/0.0.0.0
0.0.0.0/0.0.0.0
0.0.0.0/0.0.0.0

0.0.0.0/0.0.0.0

0.0.0.0/0.0.0.0
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The following options are available:

Create New
Edit
Clone

Delete

Table View/Tile View

Column Settings
Search

Change Password

The following information is shown:

Seq.#

Name
Type
Profile
ADOMs
Comments

Trusted IPv4 Hosts

Trusted IPv6 Hosts

Contact Email

Contact Phone

Creating administrators

To create a new administrator account, you must be logged in to an account with sufficient privileges, or as a super user

administrator.

Create a new administrator. See Creating administrators on page 224.
Edit the selected administrator. See Editing administrators on page 227.
Clone the selected administrator.

Delete the selected administrator or administrators. See Deleting administrators
on page 228.

Change the view of the administrator list.

Table view shows a list of the administrators in a table format. Tile view shows a
separate card for each administrator in a grid pattern.

Change the displayed columns.
Search the administrators.

Change the selected administrator's password. This option is only available from
the right-click menu. See Editing administrators on page 227.

The sequence number.

The name the administrator uses to log in.

The user type, as well as if the administrator uses a wildcard.

The profile applied to the administrator. See Administrator profiles on page 228
The ADOMs the administrator has access to or is excluded from.

Comments about the administrator account. This column is hidden by default.

The IPv4 trusted host(s) associated with the administrator. See Trusted hosts on
page 222.

The IPv6 trusted host(s) associated with the administrator. See Trusted hosts on
page 222. This column is hidden by default.

The contact email associated with the administrator. This column is hidden by
default.

The contact phone number associated with the administrator. This column is
hidden by default.

You need the following information to create an account:

« Which authentication method the administrator will use to log in to the FortiAnalyzer unit. Local, remote, and Public

Key Infrastructure (PKI) authentication methods are supported.
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« What administrator profile the account will be assigned, or what system privileges the account requires.
« |f ADOMs are enabled, which ADOMs the administrator will require access to.
« If using trusted hosts, the trusted host addresses and network masks.

Ay
‘?' For remote or PKI authentication, the authentication must be configured before you create
- the administrator. See Authentication on page 234 for details.

To create a new administrator:

1. Goto System Settings > Admin > Administrators.
2. Inthe toolbar, click Create New to display the New Administrator pane.

New Administrator
User Name

Avatar + Add Photo — Remove Photo
Commen its.

0/127
Admin Type LOCAL

New Password A

Confirm Password o
Force this administrator to change password upon next log on.
Admin Profile Restricted_User

Administrative Domain AllIADOMs  All ADOMs except specified ones

Trusted Hosts.
Meta Fields~
Contact Email

Contact Phone

3. Configure the following settings, and then click OK to create the new administrator.

User Name Enter the name of the administrator will use to log in.

Avatar Apply a custom image to the administrator.

Click Add Photo to select an image already loaded to the FortiAnalyzer, or to
load an new image from the management computer.

If no image is selected, the avatar will use the first letter of the user name.

Comments Optionally, enter a description of the administrator, such as their role,
location, or the reason for their account.

Admin Type Select the type of authentication the administrator will use when logging into
the FortiAnalyzer unit. One of: LOCAL, RADIUS, LDAP, TACACS+, PKI, or
Group. See Authentication on page 234 for more information.

Server or Group Select the RADIUS server, LDAP server, TACACS+ server, or group, as
required.
The server must be configured prior to creating the new administrator.
This option is not available if the Admin Type is LOCAL or PKI.
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Match all users on remote
server

Subject

CA

Required two-factor

authentication

New Password

Confirm Password

Force this administrator to
change password upon next
log on.

Admin Profile

JSON API Access

Administrative Domain
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Select this option to automatically add all users from a LDAP server specified
in Admin>Remote Authentication Server. All users specified in the
Distinguished Name field in the LDAP server will be added as FortiManager
users with the selected Admin Profile.

If this option is not selected, the User Name specified must exactly match the
LDAP user specified on the LDAP server.

This option is not available if the Admin Type is LOCAL or PKI.

Enter a comment for the PKI administrator.
This option is only available if the Admin Type is PKI.

Select the CA certificate from the dropdown list.
This option is only available if the Admin Type is PKI.

Select to enable two-factor authentication.
This option is only available if the Admin Type is PKI.

Enter the password.

This option is not available if Wildcard is selected.

If the Admin Type is PKI, this option is only available when Require two-
factor authentication is selected.

If the Admin Type is RADIUS, LDAP, or TACACS+, the password is only
used when the remote server is unreachable.

Enter the password again to confirm it.
This option is not available if Wildcard is selected.

If the Admin Type is PKI, this option is only available when Require two-
factor authentication is selected.

Force the administrator to change their password the next time that they log in
to the FortiAnalyzer.

This option is only available if Password Policy is enabled in Admin Settings.
See Password policy on page 244.

Select an administrator profile from the list. The profile selected determines
the administrator’s access to the FortiAnalyzer unit’s features. See
Administrator profiles on page 228.

Select the permission for JSON API Access. Select Read-Write, Read, or
None. The default is None.

Choose the ADOMSs this administrator will be able to access.

o AllADOMSs: The administrator can access all the ADOMs.

o AllADOMs except specified ones: The administrator cannot access the
selected ADOMs.

« Specify: The administrator can access the selected ADOMs. Specifying
the ADOM shows the Specify Device Group to Access check box.
Select the Specify Device Group to Access check box and select the
Device Group this administrator is allowed to access. The newly created
administrator will only be able to access the devices within the Device
Group and sub-groups.
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If the Admin Profile is Super_User, then this setting is All ADOMs.
This field is available only if ADOMs are enabled. See Administrative Domains
on page 176.

Trusted Hosts Optionally, turn on trusted hosts, then enter their IP addresses and netmasks.
Up to ten IPv4 and ten IPv6 hosts can be added.

See Trusted hosts on page 222 for more information.

Meta Fields Optionally, enter the new administrator's email address and phone number.
Advanced Options Configure advanced options, see Advanced options below.
For more information on advanced options, see the FortiAnalyzer CLI
Reference.
Advanced options
Option Description Default
change-password Enable or Disable changing password. disable
ext-auth-accprofile- Enable or Disable overriding the account profile by administrators disable
override configured on a Remote Authentication Server.

ext-auth-adom-override  Enable or Disable overriding the ADOM by administrators configured on  disable
a Remote Authentication Server.

ext-auth-group-match Specify the group configured on a Remote Authentication Server. -
first-name Specify the first name. -
last-name Specify the last name. -
mobile-number Specify the mobile number. -
pager-number Specify the pager number. -
restrict-access Enable or Disable restricted access. disable

Editing administrators

To edit an administrator, you must be logged in as a super user administrator. The administrator's name cannot be
edited. An administrator's password can be changed using the right-click menu, if the password is not a wildcard.

To edit an administrator:

1. Goto System Settings > Admin > Administrators.

2. Double-click on an administrator, right-click on an administrator and then select Edit from the menu, or select the
administrator then click Edit in the toolbar. The Edit Administrator pane opens.

3. Edit the settings as required, and then select OK to apply the changes.
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To change an administrator's password:

1. Goto System Settings > Admin > Administrators.

2. Right-click on an administrator and select Change Password from the menu. The Change Password dialog box
opens.

3. If you are editing the admin administrator's password, enter the old password in the Old Password field.
4. Enter the new password for the administrator in the New Password and Confirm Password fields.
5. Select OK to change the administrator's password.

vy
‘?' The current administrator's password can also be changed from the admin menu in the GUI
- banner. See GUI overview on page 12 for information.

Deleting administrators

To delete an administrator or administrators, you must be logged in as a super user administrator.

Al
S L 4
q You cannot delete an administrator that is currently logged in to the device.
\ L}
S L 4
? The admin administrator can only be deleted using the CLI.

To delete an administrator or administrators:

1. Goto System Settings > Admin > Administrators.

2. Select the administrator or administrators you need to delete.

3. Click Delete in the toolbar, or right-click and select Delete.

4. Select OKin the confirmation box to delete the administrator or administrators.

To delete an administrator using the CLI:

1. Open a CLI console and enter the following command:
config system admin user
delete <username>
end

Administrator profiles

Administrator profiles are used to control administrator access privileges to devices or system features. Profiles are
assigned to administrator accounts when an administrator is created. The profile controls access to both the
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FortiAnalyzer GUI and CLI.
There are three predefined system profiles:
Restricted_User Restricted user profiles have no system privileges enabled, and have read-only
access for all device privileges.

Standard_User Standard user profiles have no system privileges enabled, and have read/write
access for all device privileges.

Super_User Super user profiles have all system and device privileges enabled. It cannot be
edited.
These profiles cannot be deleted, but standard and restricted profiles can be edited. New profiles can also be created as
required. Only super user administrators can manage administrator profiles.

Go to System Settings > Admin > Profile to view and manage administrator profiles.

+ Create New [# Edit R§ Clone Wi Delete QI

0O # Name Type Description

0O 1 Restricted_User Restricted user profiles have no System Privileges enabled, and have read-only access for all
Device Privileges.

o 2 Standard_User Standard user profiles have no System Privileges enabled, but have read/write access for all
Device Privileges.

a 3 Super_User Super user profiles have all system and device privileges enabled.

a 4 Teltro

0O s Sup

The following options are available:

Create New Create a new administrator profile. See Creating administrator profiles on page
231.

Edit Edit the selected profile. See Editing administrator profiles on page 233.

Clone Clone the selected profile. See Cloning administrator profiles on page 233.

Delete Delete the selected profile or profiles. See Deleting administrator profiles on
page 233.

Search Search the administrator profiles list.

The following information is shown:

Name The name the administrator uses to log in.
Type The profile type.
Description A description of the system and device access permissions allowed for the

selected profile.

Permissions

The below table lists the default permissions for the predefined administrator profiles.
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When Read-Write is selected, the user can view and make changes to the FortiAnalyzer system. When Read-Only is
selected, the user can only view information. When None is selected, the user can neither view or make changes to the
FortiAnalyzer system.

Predefined Administrator Profile

Super User Standard User Restricted User

System Settings Read-Write None None
system-setting

Administrative Domain Read-Write Read-Write None
adom-switch

Device Manager Read-Write Read-Write Read-Only

device-manager

Add/Delete/Edit Read-Write Read-Write None
Devices/Groups

device-op
Log View/FortiView/SOC Read-Write Read-Write Read-Only

log-viewer

Incidents & Events Read-Write Read-Write Read-Only
event-management

Reports Read-Write Read-Write Read-Only
report-viewer

FortiRecorder Read-Write Read-Write None

CLI only settings

device-wan-link-load-balance Read-Write Read-Write Read-Only
device-ap Read-Write Read-Write Read-Only
device-forticlient Read-Write Read-Write Read-Only
device-fortiswitch Read-Write Read-Write Read-Only
realtime-monitor Read-Write Read-Write Read-Only

Privacy Masking

Use Privacy Masking to help protect user privacy by masking or anonymizing user information. You can select which
fields to mask. Masked fields show anonymous data. You can unmask and see the original data by entering the Data
Mask Key that you specify in the administrator profile.
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When Privacy Masking is enabled in an administrator profile, accounts using that profile have a See Original Data
button in the banner.

L WULSVESSM NSRS & Screen Picker | See Original Dats
Source [# Manual Input

o.. 75196.35.21
o.. 75196.35.21
o.. 75196.35.21

To turn privacy masking on:

1. In System Settings > Profile, create or edit a profile.
2. Inthe Privacy Masking section, set the toggle to ON
3. Inthe Masked Data Fields section, select the fields you want to mask.

The fields you select are masked in all modules that display those fields.
In the Data Mask Key field, type the key that will allow users to unmask the data.

In the Data Unmasked Time field, type the number of days the data is unmasked.
You can enter a number between 0-365. Logs that are older than the number of days appear masked.

U

To see the original, unmasked data:

1. In any list showing masked data, click See Original Data in the banner and select Screen Picker or Manual Input.
2. If you select Screen Picker, click a masked field, for example, 75.196.35.21.

The Unmask Protected Data dialog box displays with the field you clicked already entered.

If you select Manual Input, enter the masked text, for example, 75.196.35.21.
3. Enterthe Data Mask Key that was set up in the administrator profile and click OK.

Unmask Protected Data

Masked Text 77.696.355.299
Data Mask Key sase L

Unmasked Text 172.88.33.861

Lo

Creating administrator profiles

To create a new administrator profile, you must be logged in to an account with sufficient privileges, or as a super user
administrator.
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To create a custom administrator profile:

1. Goto System Settings > Admin > Profile.

2. Click Create New in the toolbar. The New Profile pane is displayed.

=_= System Settings v

& Dashboard

@ Logging Topology
& All ADOMs

© storage Info

B RAID Management
€3 Network

& HA

& Admin

Administrators

Remote Authentication Server
Admin Settings
SAML S50

EB Certificates

& Log Forwarding

[ Fetcher Management

¥ Event Log

[2 Task Monitor

B Advanced

New Profile

Profile Name

Description

System Settings
Administrative Domain
Device Manager

Add/Delete/Edit Devices/Groups
Log View/FortiView/SOC
Incidents & Events
Reports

FortiRecorder

Privacy Masking

Read-Write Read-Only None

[CICINCINCINCICINCINC]

OFF

3. Configure the following settings:

Profile Name

Description

Permissions

Privacy Masking

Masked Data Fields

Data Mask Key

Data Unmasked Time(0-
365 Days)

Enter a name for this profile.

Optionally, enter a description for this profile. While not a
requirement, a description can help to know what the profiles is
for, or the levels it is set to.

Select None, Read Only, or Read-Write access for the categories
as required.

Enable/disable privacy masking.

Select the fields to mask: Destination Name, Source IP,
Destination IP, User, Source Name, Email, Message, and/or
Source MAC.

Enter the data masking encryption key. You need the Data Mask
Key to see the original data.

Enter the number of days the user assigned to this profile can see
all logs without masking.

The logs are masked if the time period in the Log View toolbar is
greater than the number of days in the Data Masked Time field.

« Only integers between 0-365 are supported.
N : /, « Time frame masking does not apply to real
9 time logs.
= « Time frame masking applies to custom view
and drill-down data.

4. Click OK to create the new administrator profile.
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To apply a profile to an administrator:

1. Goto System Settings > Administrators.

2. Create a new administrator or edit an existing administrator. The Edit Administrator pane is displayed.
3. From the Admin Profile list, select a profile.

Editing administrator profiles

To edit an administrator profile, you must be logged in to an account with sufficient privileges, or as a super user

administrator. The profile's name cannot be edited. The Super_User profile cannot be edited, and the predefined
profiles cannot be deleted.

To edit an administrator:

1. Goto System Settings > Admin > Profile.

2. Double-click on a profile, right-click on a profile and then select Edit from the menu, or select the profile then click
Edit in the toolbar. The Edit Profile pane opens.

3. Edit the settings as required, and then select OK to apply the changes.

Cloning administrator profiles

To clone an administrator profile, you must be logged in to an account with sufficient privileges, or as a super user
administrator.

To edit an administrator:

1. Goto System Settings > Admin > Profile.

2. Right-click on a profile and select Clone from the menu, or select the profile then click Clone in the toolbar. The
Clone Profile pane opens.

3. Edit the settings as required, and then select OK to apply the changes.

Deleting administrator profiles

To delete a profile or profiles, you must be logged in to an account with sufficient privileges, or as a super user
administrator. The predefined profiles cannot be deleted.

To delete a profile or profiles:

Go to System Settings > Admin > Profile.

Select the profile or profiles you need to delete.

Click Delete in the toolbar, or right-click and select Delete.
Select OK in the confirmation box to delete the profile or profiles.

A oODdD=
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Authentication

The FortiAnalyzer system supports authentication of administrators locally, remotely with RADIUS, LDAP, or TACACS+
servers, and using PKI. Remote authentication servers can also be added to authentication groups that administrators
can use for authentication.

Security Assertion Markup Language (SAML) authentication can be enabled across all Security Fabric devices, enabling
smooth movement between devices for the administrator. FortiAnalyzer can play the role of the identity provider (IdP) or
the service provider (SP) when an external identity provider is available. See SAML admin authentication on page 241.

To use PKI authentication, you must configure the authentication before you create the administrator accounts. See
Public Key Infrastructure on page 234 for more information.

To use remote authentication servers, you must configure the appropriate server entries in the FortiAnalyzer unit for
each authentication server in your network. New LDAP remote authentication servers can be added and linked to all
ADOMs or specific ADOMs. See LDAP servers on page 237, RADIUS servers on page 238, TACACS+ servers on page
240, and Remote authentication server groups on page 240 for more information.

Public Key Infrastructure

Public Key Infrastructure (PKIl) authentication uses X.509 certificate authentication library that takes a list of peers, peer
groups, and user groups and returns authentication successful or denied notifications. Administrators only need a valid
X.509 certificate for successful authentication; no username or password is necessary.

To use PKI authentication for an administrator, you must configure the authentication before you create the
administrator accounts. You will also need the following certificates:

« an X.509 certificate for the FortiManager administrator (administrator certificate)

« an X.509 certificate from the Certificate Authority (CA) which has signed the administrator’s certificate (CA
Certificate)

To get the CA certificate:

Log into your FortiAuthenticator.
2. Goto Certificate Management > Certificate Authorities > Local CAs.

3. Select the certificate and select Export in the toolbar to save the ca fortinet.com CA certificate to your
management computer. The saved CA certificate’s filenameis ca_fortinet.com.crt.

To get the administrator certificate:

Log into your FortiAuthenticator.
2. Go to Certificate Management > End Entities > Users.

3. Select the certificate and select Export in the toolbar to save the administrator certificate to your management
computer. The saved CA certificate’s filename is admin fortinet.com.pl2. This PCKS#12 file is password
protected. You must enter a password on export.

To import the administrator certificate into your browser:

1. In Mozilla Firefox, go to Options > Advanced > Certificates > View Certificates > Import.
2. Select the file admin fortinet.com.pl2 and enter the password used in the previous step.
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To import the CA certificate into the FortiAnalyzer:

1. Log into your FortiAnalyzer.
2. Goto System Settings > Certificates > CA Certificates.

3. Click Import, and browse forthe ca fortinet.com. crt file you saved to your management computer, or drag

and drop the file onto the dialog box. The certificate is displayed as CA_Cert 1.

To create a new PKI administrator account:

N =

Go to System Settings > Admin > Administrator.
Click Create New. The New Administrator dialog box opens.

See Creating administrators on page 224 for more information.
Select PKI for the Admin Type.

3

4. Enter a comment in the Subject field for the PKI administrator.
5. Select the CA certificate from the dropdown list in the CA field.
6

Click OK to create the new administrator account.

PKI authentication must be enabled via the FortiAnalyzer CLI with the following commands:

config system global
set clt-cert-req enable
end

When connecting to the FortiAnalyzer GUI, you must use HTTPS when using PKI certificate

authentication.

When clt-cert-reqis set to optional, the user can use certificate authentication or user

credentials for GUI login.

Managing remote authentication servers

The FortiAnalyzer system supports remote authentication of administrators using LDAP, RADIUS, and TACACS+
remote servers. To use this feature, you must configure the appropriate server entries for each authentication server in
your network, see LDAP servers on page 237, RADIUS servers on page 238, and TACACS+ servers on page 240 for

more information.

Remote authentication servers can be added, edited, deleted, and added to authentication groups (CLI only).

Go to System Settings > Admin > Remote Authentication Serverto manage remote authentication servers.

= Create New ~ [# Edit i Delete

A Name
ActTack
Dapple
Lapper
Rader

oooood

Radium

Type
TACACS+
LDAP
LDAP
RADIUS
RADIUS

ADOM

All ADOMs
Syslog, FortiAuthenticator, FortiCache, FortiMail, FortiWeb
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Details

10.10.10.15 CHAP
10.10.10.11:38%/cn:
10.10.10.55:38%/cn:
10.10.10.13 PAP

10.11.10.10 10.11.11.10 M5v2
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The following options are available:

Create New

Edit

Delete

Add an LDAP, RADIUS, or TACACS+ remote authentication server. See LDAP
servers on page 237, RADIUS servers on page 238, and TACACS+ servers on
page 240.

Edit the selected remote authentication server. See Editing remote
authentication servers on page 236.

Delete the selected remote authentication server or servers. See Deleting remote
authentication servers on page 236.

The following information is displayed:

Name

Type
ADOM

Details

The name of the server.
The server type: LDAP, RADIUS, or TACACS+.

The administrative domain(s) which are linked to the remote authentication
server.

Details about the server, such as the |P address.

Editing remote authentication servers

To edit a remote authentication server, you must be logged in to an account with sufficient privileges, or as a super user

administrator. The server's name can

not be edited.

To edit a remote authentication server:

1. Goto System Settings > Admin

> Remote Authentication Server.

2. Double-click on a server, right-click on a server and then select Edit from the menu, or select the server then click
Edit in the toolbar. The Edit Server pane for that server type opens.

3. Edit the settings as required, and

then select OK to apply the changes.

See LDAP servers on page 237, RADIUS servers on page 238, and TACACS+ servers on page 240 for more

information.

Deleting remote authentication servers

To delete a remote authentication server or servers, you must be logged in to an account with sufficient privileges, or as

a super user administrator.

To delete a remote authentication

Click Delete in the toolbar, or righ

AoODd-=
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server or servers:

Go to System Settings > Admin > Remote Authentication Server.
Select the server or servers you need to delete.

t-click and select Delete.

Select OK in the confirmation box to delete the server or servers.
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LDAP servers

Lightweight Directory Access Protocol (LDAP) is an Internet protocol used to maintain authentication data that may
include departments, people, groups of people, passwords, email addresses, and printers. LDAP consists of a data-
representation scheme, a set of defined operations, and a request/response network.

If you have configured LDAP support and an administrator is required to authenticate using an LDAP server, the
FortiAnalyzer unit sends the administrator’s credentials to the LDAP server for authentication. If the LDAP server can
authenticate the administrator, they are successfully authenticated with the FortiAnalyzer unit. If the LDAP server
cannot authenticate the administrator, the FortiAnalyzer unit refuses the connection.

To use an LDAP server to authenticate administrators, you must configure the server before configuring the

administrator accounts that will use it.

To add an LDAP server:

1. Goto System Settings > Admin > Remote Authentication Server.
2. Select Create New > LDAP Serverfrom the toolbar. The New LDAP Server pane opens.

New LDAP Server

Name

Server Name/IP

Port 389
Common Name Identifier cn
Distinguished Name

Bind Type Regular
User DN

Password sessse

%

Secure Connection Eenable

Protocol

Certificate No Certificate
Administrative Domain Specify

Advanced Options >

3. Configure the following settings, and then click OK to add the LDAP server.

Name
Server Name/IP
Port

Common Name Identifier

Distinguished Name

Bind Type
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Enter a name to identify the LDAP server.
Enter the IP address or fully qualified domain name of the LDAP server.

Enter the port for LDAP traffic. The default port is 389.

The common name identifier for the LDAP server. Most LDAP servers use cn.

However, some servers use other common name identifiers such as UID.

The distinguished name is used to look up entries on the LDAP server.

The distinguished name reflects the hierarchy of LDAP database object
classes above the common name identifier. Clicking the query distinguished
name icon will query the LDAP server for the name and open the LDAP
Distinguished Name Query window to display the results.

Select the type of binding for LDAP authentication: Simple, Anonymous, or
Regular.
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User DN When the Bind Type is set to Regular, enter the user DN.
Password When the Bind Type is set to Regular, enter the password.

Secure Connection Select to use a secure LDAP server connection for authentication.
Protocol When Secure Connection is enabled, select either LDAPS or STARTTLS.
Certificate When Secure Connection is enabled, select the certificate from the

dropdown list.

Administrative Domain Choose the ADOMs that this server will be linked to for reporting: All ADOMs
(default), or Specify for specific ADOMs.

Advanced Options

adom-attr Specify an attribute for the ADOM.

attributes Specify the attributes such as member, uniquemember, or memberuid.
connect-timeout Specify the connection timeout in millisecond.

filter Specify the filter in the format (objectclass=*)

group Specify the name of the LDAP group.

memberof-attr Specify the value for this attribute. This value must match the attribute of the

group in LDAP Server. All users part of the LDAP group with the attribute
matching the memberof-attr will inherit the administrative permissions
specified for this group.

profile-attr Specify the attribute for this profile.
secondary-server  Specify a secondary server.

tertiary-server Specify a tertiary server.

RADIUS servers

Remote Authentication Dial-in User (RADIUS) is a user authentication and network-usage accounting system. When
users connect to a server they type a user name and password. This information is passed to a RADIUS server, which
authenticates the user and authorizes access to the network.

You can create or edit RADIUS server entries in the server list to support authentication of administrators. When an
administrator account’s type is set to RADIUS, the FortiAnalyzer unit uses the RADIUS server to verify the administrator
password at log on. The password is not stored on the FortiAnalyzer unit.

To use a RADIUS server to authenticate administrators, you must configure the server before configuring the
administrator accounts that will use it.
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To add a RADIUS server:

1. Goto System Settings > Admin > Remote Authentication Server.
2. Select Create New > RADIUS Serverfrom the toolbar. The New RADIUS Server pane opens.

Name

Server Name/IP 10.2.0.159
Port 1812
Server Secret ssssssns

Connection Status Successful

Test Connectivity Test User Credentials

Secondary Server Name/IP

Secondary Server Secret ssssssse

Test Connectivity

Authentication Type ANY

Advanced Options >

I

Test User Credentials

3. Configure the following settings, and then click OK to add the RADIUS server.

Name
Server Name/IP

Port

Server Secret

Test Connectivity

Test User Credentials

Secondary Server Name/IP

Secondary Server Secret

Authentication Type

Advanced Options

nas-ip
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Enter a name to identify the RADIUS server.
Enter the IP address or fully qualified domain name of the RADIUS server.

Enter the port for RADIUS traffic. The default port is 1812. Some RADIUS
servers use port 1645.

Enter the RADIUS server secret. Click the eye icon to Show or Hide the server
secret.

Click Test Connectivity to test the connectivity with the RADIUS server.
Shows success or failure.

Click Test User Credentials to test the user credentials. Shows success or
failure.

Enter the IP address or fully qualified domain name of the secondary RADIUS
server.

Enter the secondary RADIUS server secret.

Select the authentication type the RADIUS server requires. If you select the
default ANY, FortiAnalyzer tries all authentication types.

Specify the IP address for the Network Attached Storage (NAS).
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TACACS+ servers

Terminal Access Controller Access-Control System (TACACS+) is a remote authentication protocol that provides access
control for routers, network access servers, and other network computing devices via one or more centralized servers. It
allows a client to accept a user name and password and send a query to a TACACS authentication server. The server
host determines whether to accept or deny the request and sends a response back that allows or denies network access
to the user. The default TCP port for a TACACS+ server is 49.

If you have configured TACACS+ support and an administrator is required to authenticate using a TACACS+ server, the
FortiAnalyzer unit contacts the TACACS+ server for authentication. If the TACACS+ server can authenticate the
administrator, they are successfully authenticated with the FortiAnalyzer unit. If the TACACS+ server cannot
authenticate the administrator, the connection is refused by the FortiAnalyzer unit.

To use a TACACS+ server to authenticate administrators, you must configure the server before configuring the
administrator accounts that will use it.

To add a TACACS+ server:

1. Goto System Settings > Admin > Remote Authentication Server.
2. Select Create New > TACACS+ Serverfrom the toolbar. The New TACACS+ Server pane opens.
New TACACS+ Server

Name

Server Name/IP

Port 49
Server Key

Authentication Type

3. Configure the following settings, and then click OK to add the TACACS+ server.

Name Enter a name to identify the TACACS+ server.

Server Name/IP Enter the IP address or fully qualified domain name of the TACACS+ server.
Port Enter the port for TACACS+ traffic. The default port is 49.

Server Key Enter the key to access the TACACS+ server. The server key can be a

maximum of 16 characters in length.

Authentication Type Select the authentication type the TACACS+ server requires. If you select the
default ANY, FortiAnalyzer tries all authentication types.

Remote authentication server groups

Remote authentication server groups can be used to extend wildcard administrator access. Normally, a wildcard
administrator can only be created for a single server. If multiple servers of different types are grouped, a wildcard
administrator can be applied to all of the servers in the group.

Multiple servers of the same type can be grouped to act as backups - if one server fails, the administrator can still be
authenticated by another server in the group.

To use a server group to authenticate administrators, you must configure the group before configuring the administrator
accounts that will use it.
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Remote authentication server groups can only be managed using the CLI. For more information, see the FortiAnalyzer
CLI Reference.

To create a new remote authentication server group:

1. Open the admin group command shell:
config system admin group

2. Create a new group, or edit an already create group:
edit <group name>

3. Add remote authentication servers to the group:

set member <server name> <server name> ...

4. Apply your changes:

end

To edit the servers in a group:

1. Enter the following CLI commands:
config system admin group
edit <group name>
set member <server name> <server name> ...
end

Only the servers listed in the command will be in the group.

To remove all the servers from the group:

1. Enter the following CLI commands:
config system admin group
edit <group name>
unset member
end

All of the servers in the group will be removed.

To delete a group:

1. Enter the following CLI commands:
config system admin group
delete <group name>

end

SAML admin authentication

SAML can be enabled across all Security Fabric devices, enabling smooth movement between devices for the
administrator. FortiAnalyzer can play the role of the identity provider (IdP) or the service provider (SP) when an external
identity provider is available.

Devices configured to the IdP can be accessed through the Quick Access menu which appears in the top-right corner of
the main menu. The current device is indicated with an asterisk (this feature is currently only supported in FAZ/FMG).

Logging into an SP device will redirect you to the IdP login page. By default, it is a Fortinet login page. After successful
authentication, you can access other SP devices from within the same browser without additional authentication.
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Ay
‘Q' The admin user must be created on both the IdP and SP, otherwise you will see an error
- message stating that the admin doesn't exist.
When accessing FortiGate from the Quick Access menu, if FGT is set up to use the default
login page with SSO options, you must select the via Single Sign-On button to be

automatically authenticated.

To configure FortiAnalyzer as the identity provider:

1. Goto System Settings > SAML SSO.
2. Select Identity Provider (IdP).
3. Inthe /dP Certificate dropdown, choose a certificate where IdP is used.
4. Select Download to get the IdP certificate, used later to configure SPs.
5. Select Apply.
6. Inthe SP Settings table, select Create to add a service provider.
7. Inthe Edit Service Provider window:
« Enter a name for the SP.
o Select Fortinet as the SP Type.
« Ifthe SPis not a Fortinet product, select Custom as the SP Type and copy the SP Entity ID, SP ACS
(Login) URL, and SP SLS (Logout) URL from your SPs configuration page.
« Enterthe SP IP address.
o Copy down the IdP Prefix. It is required when configuring SPs.
8. Select OK.
9. Acustom login page can be created by moving the Login Page Template toggle to the On position and selecting

Customize.

To configure FortiAnalyzer as a service provider:

Go to System Settings > SAML SSO.

Select Service Provider (SP).

Select Fortinet as the IdP Type.

Enter the IdP |IP address and the IdP prefix that you obtained while configuring the 1dP device.

Select the IdP certificate.
If this is a first-time set up, you can import the IdP certificate that you downloaded while configuring the 1dP device.

Confirm that the information is correct and select Apply.
7. Repeat the steps for each FAZ/FMG that is to be set as a service provider.

a2

o

FortiAnalyzer 6.2.3 Administration Guide 242
Fortinet Technologies Inc.



Administrators

Global administration settings

The administration settings page provides options for configuring global settings for administrator access to the
FortiAnalyzer device. Settings include:

o Portsfor HTTPS and HTTP administrative access
To improve security, you can change the default port configurations for administrative connections to the
FortiAnalyzer. When connecting to the FortiAnalyzer unit when the port has changed, the port must be included,
suchashttps://<ip address>:<port>. Forexample, if you are connecting to the FortiAnalyzer unit using
port 8080, the URL would be https://192.168.1.99:8080. When you change to the default port number for
HTTP, HTTPS, or SSH, ensure that the port number is unique.
« ldle timeout settings
By default, the GUI disconnects administrative sessions if no activity occurs for five minutes. This prevents
someone from using the GUI if the management computer is left unattended.
« GUI language
The language the GUI uses. For best results, you should select the language used by the management computer.
o GUl theme
The default color theme of the GUI is Blueberry. You can choose another color or an image.
« Password policy
Enforce password policies for administrators.

Al
‘Q' Only super user administrators can access and configure the administration settings. The
- settings are global and apply to all administrators of the FortiAnalyzer unit.

To configure the administration settings:

1. Goto System Settings > Admin > Admin Settings.

Admin Settings

Administration Settings
HTTP Port 80 5 Redirects to HTTPS
HTTPS Port 443
HTTPS & Web Service Certificate server.crt
Idle Timeout 480 3 (1-480 Minutes)

View Settings

Language Auto Detect

Theme Blu Ebﬁ rry ing _ A tumn_
m ;de'
Winter SOt | Aeriin Emary Tunnel | Diving Technology
Hon i Northern Light || Astro m
s u
i vala
| Polar Bear | Linked World
X

Minimum Length 8 = (8-32 characters)

Must Contain Uppercase Letters Lowercase Letters
Numbers (0-9) Special Characters

Admin Password Expires after 0 = (days)

(o

2. Configure the following settings as needed, then click Apply to save your changes to all administrator accounts:

Administration Settings
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HTTP Port

HTTPS Port

HTTPS & Web
Service Server
Certificate

Idle Timeout
View Settings

Language

Theme

Password Policy

Minimum Length
Must Contain

Admin Password
Expires after

Password policy

Enter the TCP port to be used for administrative HTTP access. Default: 80.
Select Redirect to HTTPS to redirect HTTP traffic to HTTPS.

Enter the TCP port to be used for administrative HTTPS access. Default: 443.

Select a certificate from the dropdown list.

Enter the number of minutes an administrative connection can be idle before
the administrator must log in again, from 1 to 480 (8 hours). See Idle timeout
on page 246 for more information.

Select a language from the dropdown list. See GUI language on page 245 for
more information.

Select a theme for the GUI. The selected theme is not applied until you click
Apply, allowing to you to sample different themes. Default: Blueberry.

Click to enable administrator password policies. See Password policy on page
244 and Password lockout and retry attempts on page 245 for more
information.

Select the minimum length for a password, from 8 to 32 characters. Default:
8.

Select the types of characters a password must contain.

Select the number of days a password is valid for, after which it must be
changed.

You can enable and configure password policy for the FortiAnalyzer.

To configure the password policy:

1. Goto System Settings > Admin > Admin Settings.

2. Click to enable Password Policy.

3. Configure the following settings, then click Apply to apply to password policy.

Minimum Length Specify the minimum number of characters that a password must be, from 8 to 32.

Default: 8.

Must Contain Specify the types of characters a password must contain: uppercase and lowercase
letters, numbers, and/or special characters.

Admin Password Specify the number of days a password is valid for. When the time expires, an
Expires after administrator will be prompted to enter a new password.
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Password lockout and retry attempts

By default, the number password retry attempts is set to three, allowing the administrator a maximum of three attempts
at logging in to their account before they are locked out for a set amount of time (by default, 60 seconds).

The number of attempts and the default wait time before the administrator can try to enter a password again can be
customized. Both settings can be configured using the CLI.

To configure the lockout duration:

1. Enter the following CLI commands:
config system global
set admin-lockout-duration <seconds>
end

To configure the number of retry attempts:

1. Enter the following CLI commands:
config system global
set admin-lockout-threshold <failed attempts>
end

Example

To set the lockout threshold to one attempt and set a five minute duration before the administrator can try to log in
again, enter the following CLI commands:

config system global
set admin-lockout-duration 300
set admin-lockout-threshold 1
end

GUI language

The GUI supports multiple languages, including:

« English

« Simplified Chinese
o Spanish

« Traditional Chinese
« Japanese

+ Korean

By default, the GUI language is set to Auto Detect, which automatically uses the language used by the management
computer. If that language is not supported, the GUI defaults to English. For best results, you should select the
language used by the operating system on the management computer.

For more information about language support, see the FortiAnalyzer Release Notes.
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To change the GUI language:

1. Goto System Settings > Admin > Admin Settings.

2. Underthe View Settings, In the Language field, select a language, or Auto Detect, from the dropdown list.
3. Click Apply to apply the language change.

Idle timeout

To ensure security, the idle timeout period should be short. By default, administrative sessions are disconnected if no
activity takes place for five minutes. This idle timeout is recommended to prevent anyone from using the GUI on a PC
that was logged in to the GUI and then left unattended. The idle timeout period can be set from 1 to 480 minutes.

To change the idle timeout:

1. Goto System Settings > Admin > Admin Settings.
2. Change the Idle Timeout period as required.
3. Click Apply.

Two-factor authentication

To configure two-factor authentication for administrators you will need the following:

« FortiAnalyzer
« FortiAuthenticator
o FortiToken

Configuring FortiAuthenticator
On the FortiAuthenticator, you must create a local user and a RADIUS client.
Before proceeding, ensure you have configured your FortiAuthenticator, created a NAS entry
x for your FortiAnalyzer, and created or imported FortiTokens.

For more information, see the Two-Factor Authenticator Interoperability Guide and
FortiAuthenticator Administration Guide in the Fortinet Document Library.

Create a local user:

1. Goto Authentication > User Management > Local Users.
2. Click Create New in the toolbar.
3. Configure the following settings:

Username Enter a user name for the local user.
Password creation Select Specify a password from the dropdown list.
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Password
Password confirmation

Allow RADIUS
authentication

Role

Enable account expiration

Enter a password. The password must be a minimum of 8 characters.
Re-enter the password. The passwords must match.

Enable to allow RADIUS authentication.

Select the role for the new user.

Optionally, select to enable account expiration. For more information see the
FortiAuthenticator Administration Guide.

4. Click OK to continue to the Change local user page.

@ Successfully added local user "pjfry”. You may edit it again belo

Py

ed authentication  [Change Passwerd,
fthentication

au
[ Allow RADIUS authentication

Role: @ Administrator

Quser

[ Full permission

WeD senice access

[ Restrict admin login from trusted management subnets only

Disabled

Password-based
authentication

Token-based authentication

Deliver token
code by

Allow RADIUS
authentication

Enable account expiration

User Role
Role

Full Permission

Web service
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Change local user
w

5. Configure the following settings, then click OK.

Select to disable the local user.

Leave this option selected. Select [Change Password] to change the
password for this local user.

Select to enable token-based authentication.

Select to deliver token by FortiToken, email, or SMS.
Click Test Token to test the token.

Select to allow RADIUS authentication.

Optionally, select to enable account expiration. For more information see the
FortiAuthenticator Administration Guide.

Select either Administrator or User.

Select to allow Full Permission, otherwise select the admin profiles to apply to
the user. This option is only available when Role is Administrator.

Select to allow Web service, which allows the administrator to access the web
service via a REST API or by using a client application. This option is only
available when Role is Administrator.
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Restrict admin
login from trusted
management
subnets only

Select to restrict admin login from trusted management subnets only, then
enter the trusted subnets in the table. This option is only available when Role
is Administrator.

Allow LDAP
Browsing

Select to allow LDAP browsing. This option is only available when Role is
User.

Create a RADIUS client:

1. Goto Authentication > RADIUS Service > Clients.
2. Click Create New in the toolbar.
3. Configure the following settings, then click OK.

Name

Client name/IP

Secret

First profile name
Description

Apply this profile based on
RADIUS attributes

Authentication method
Username input format
Realms

Allow MAC-based
authentication

Check machine
authentication

Enable captive portal

EAP types

Enter a name for the RADIUS client entry.

Enter the IP address or Fully Qualified Domain Name (FQDN) of the
FortiAnalyzer.

Enter the server secret. This value must match the FortiAnalyzer RADIUS
server setting at System Settings > Admin > Remote Authentication Server.

See the FortiAuthenticator Administration Guide.
Enter an optional description for the RADIUS client entry.
Select to apply the profile based on RADIUS attributes.

Select Enforce two-factor authentication from the list of options.
Select specific user name input formats.
Configure realms.

Optional configuration.

Select to check machine based authentication and apply groups based on the
success or failure of the authentication.

Enable various portals.

Optional configuration.

A\,

For more information, see the FortiAuthenticator Administration Guide, available in the

Fortinet Document Library.

Configuring FortiAnalyzer

On the FortiAnalyzer, you need to configure the RADIUS server and create an administrator that uses the RADIUS
server for authentication.

FortiAnalyzer 6.2.3 Administration Guide 248

Fortinet Technologies Inc.


https://docs.fortinet.com/product/fortiauthenticator

Administrators

Configure the RADIUS server:

1. Goto System Settings > Admin > Remote Authentication Server.
2. Click Create New > RADIUS in the toolbar.
3. Configure the following settings, then click OK.

Name
Server Name/IP
Server Secret

Secondary Server Name/IP

Secondary Server Secret
Port

Authentication Type

Create the administrator:

Enter a name to identify the FortiAuthenticator.

Enter the IP address or fully qualified domain name of your FortiAuthenticator.

Enter the FortiAuthenticator secret.

Enter the IP address or fully qualified domain name of the secondary
FortiAuthenticator, if applicable.

Enter the secondary FortiAuthenticator secret, if applicable.
Enter the port for FortiAuthenticator traffic.

Select the authentication type the FortiAuthenticator requires. If you select
the default ANY, FortiAnalyzer tries all authentication types.

Note: RADIUS server authentication for local administrator users stored in
FortiAuthenticator requires the PAP authentication type.

1. Goto System Settings > Admin > Administrator.

2. Click Create New from the toolbar.

3. Configure the settings, selecting the previously added RADIUS server from the RADIUS Server dropdown list. See

Creating administrators on page 224.

4. Click OK to save the settings.

Test the configuration:

1. Attempt to log in to the FortiAnalyzer GUI with your new credentials.

2. Enter your user name and password and click Login.

3. Enter your FortiToken pin code and click Submit to log in to the FortiAnalyzer.
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A FortiAnalyzer high availability (HA) cluster provides the following features:

« Provide real-time redundancy in case a FortiAnalyzer primary unit fails. If the primary unit fails, another unit in the

cluster is selected as the primary unit. See If the primary unit fails on page 254.

« Synchronize logs and data securely among multiple FortiAnalyzer units. Some system and configuration settings

are also synchronized. See Configuration synchronization on page 253.

« Alleviate the load on the primary unit by using backup units for processes such as running reports.

A FortiAnalyzer HA cluster can have a maximum of four units: one primary unit with up to three backup units. All units in

the cluster must be of the same FortiAnalyzer series. All units are visible on the network.

All units must run in the same operation mode: Analyzer or Collector.

Due to technical limitations, the current FortiAnalyzer HA implementation is not supported by
some public cloud infrastructures, such as Microsoft Azure, Google Cloud Platform, etc.

FortiAnalyzer HA only functions under setups where VRRP is permitted.

for the smallest number of managed devices is used.

" port2:
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Configuring HA options

To configure HA options go to System Settings > HA and configure FortiAnalyzer units to create an HA cluster or

change cluster configuration.

In System Settings > HA, use the Cluster Settings pane to create or change HA configuration, and use the Cluster

Status pane to monitor HA status.

To configure a cluster, set the Operation Mode of the primary unit to High Availability. Then add the IP addresses and

serial numbers of each backup unit to primary unit peer list. The IP address and serial number of the primary unit and all
backup units must be added to each backup unit's HA configuration. The primary unit and all backup units must have the

same Group Name, Group ID

You can connect to the primary unit GUI to work with FortiAnalyzer. Using configuration synchronization, you can
configure and work with the cluster in the same way as you work with a standalone FortiAnalyzer unit.

Cluster Settings

and Password.

Operation Mode IERLEILLEE  High Availability

Preferred Role Master
®Slave

Cluster Virtual IP

Interface portl

IP Address 123.45.67.89

Cluster Settings

Peer IP and Peer SN Peer IP

Peer SN

10.10.10.2 FAZ-123456789012 +
10.10.10.3 FAZ-123456789013 +

Group Name FAZ-Group

Group ID 10 g (1-255)

Password | esssss

Heart Beat Interval 1 Seconds

Failover Threshold

Priority 100 (80-120)

Log Data Sync m

Configure the following settings:

Cluster Status

Operation Mode

Preferred Role

Cluster Virtual IP

Select High Availability to configure the FortiAnalyzer unit for HA.
Select Standalone to stop operating in HA mode.

Select the preferred role when this unit first joins the HA cluster.

If the preferred role is Master, then this unit becomes the primary unit if it is
configured first in a new HA cluster. If there is an existing primary unit, then this

unit becomes a backup unit.

The default is S/ave so that the unit can synchronize with the primary unit. A
backup unit cannot become a primary unit until it is synchronized with the current

primary unit.
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Interface

IP Address
Cluster Settings

Peer IP

Peer SN

Group Name
Group ID
Password

Heart Beat Interval

Priority
Log Data Sync

Log synchronization

The interface the FortiAnalyzer HA unit uses to provide redundancy.

The IP address for which the FortiAnalyzer HA unit is to provide redundancy.

Type the IP address of another FortiAnalyzer unit in the cluster.

Type the serial number of the FortiAnalyzer unit corresponding to the entered IP
address.

Type a group name that uniquely identifies the FortiAnalyzer HA cluster. All units
in a cluster must have the same Group Name, Group ID and Password.

Type a group ID from 1 to 255 that uniquely identifies the FortiAnalyzer
HA cluster.

A password for the HA cluster. All members of the HA cluster must have the same
password.

The time the primary unit waits between sending heartbeat packets, in seconds.
The heartbeat interval is also the amount of time that backup units waits before
expecting to receive a heartbeat packet from the primary unit.

The priority or seniority of the backup unit in the cluster.

This option is on by default. It provides real-time log synchronization among
cluster members.

To ensure logs are synchronized among all HA units, FortiAnalyzer HA synchronizes logs in two states: initial logs
synchronization and real-time log synchronization.

Initial Logs Sync

When you add a unit to an HA cluster, the primary unit synchronizes its logs with the new unit. After initial sync is
complete, the backup unit automatically reboots. After the reboot, the backup unit rebuilds its log database with the

synchronized logs.

You can see the status in the Cluster Status pane Initial Logs Sync column.

Log Data Sync

After the initial log synchronization, the HA cluster goes into real-time log synchronization state.

Log Data Sync is turned on by default for all units in the HA cluster.

When Log Data Sync is turned on in the primary unit, the primary unit forwards logs in real-time to all backup units. This
ensures that the logs in the primary and backup units are synchronized.

Log Data Sync is turned on by default in backup units so that if the primary unit fails, the backup unit selected to be the
new primary unit will continue to synchronize logs with backup units.
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If you want to use a FortiAnalyzer unit as a standby unit (not as a backup unit), then you don't need real-time log
synchronization so you can turn off Log Data Sync.

Configuration synchronization

Configuration synchronization provides redundancy and load balancing among the cluster units. A FortiAnalyzer HA
cluster synchronizes the configuration of the following modules to all cluster units:

« Device Manager

« Incidents & Events

+ Reports

o Most System Settings

FortiAnalyzer HA synchronizes most System Settings in the HA cluster. The following table shows which System
Setting configurations are synchronized:

System Setting Configuration synchronized

Dashboard > System Information Only Administrative Domain is synchronized. All other settings in the
System Information widget are not synchronized.

All ADOMs Yes
Storage Info Yes
Network No

HA No

Admin Yes
Certificates > Local Certificates No

Certificates > CA Certificates Yes
Certificates > CRL Yes
Log Forwarding Yes
Fetcher Management Yes
Event Log No

Task Monitor Yes
Advanced > SNMP Yes
Advanced > Mail Server Yes
Advanced > Syslog Server Yes
Advanced > Meta Fields Yes
Advanced > Device Log Settings Yes
Advanced > File Management Yes
Advanced > Advanced Settings Yes
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Monitoring HA status

In System Settings > HA, the Cluster Status pane shows the HA status. This pane displays information about the role
of each cluster unit, the HA status of the cluster, and the HA configuration of the cluster.

Ay
‘?' You can use the CLI command diagnose ha status to display the same HA status
- information.

The Cluster Status pane displays the following information:

Role Role of each cluster member.

Serial Number Serial number of each cluster member.

IP IP address of each cluster members including the host.
Host Name Host name of the HA cluster.

Uptime/Downtime Uptime or downtime of each cluster member.

Initial Logs Sync Status of the initial logs synchronization.
Configuration Sync Status of synchronizing configuration data.

Message Status or error messages, if any.

If the primary unit fails

If the primary unit becomes unavailable, another unit in the cluster is selected as the primary unit using the following
rules:

« All cluster units are assigned a priority from 80 — 120. The default priority is 100. If the primary unit becomes
unavailable, an available unit with the highest priority is selected as the new primary unit. For example, a unit with
a priority of 110 is selected over a unit with a priority of 100.

o If multiple units have the same priority, the unit whose primary |IP address has the greatest value is selected as the
new primary unit. For example, 123.45.67.123 is selected over 123.45.67.124.

« If a new unit with a higher priority or a greater value IP address joins the cluster, the new unit does not replace (or
preempt) the current primary unit.

If the FortiAnalyzer being replaced is the primary, after replacing it, use execute fgfm reclaim-dev-tunnel to
force FortiGates to connect to the new FortiAnalyzer.
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Load balancing

Because FortiAnalyzer HA synchronizes logs among HA units, the HA cluster can balance the load and improve overall
responsiveness. Load balancing enhances the following modules:

+ Reports
« SOC

When generating multiple reports, the loads are distributed to all HA cluster units in a round-robin fashion. When a
report is generated, the report is synchronized with other units so that the report is visible on all HA units.

Similarly, for SOC, cluster units share some of the load when these modules generate output for their widgets.

Upgrading the FortiAnalyzer firmware for an operating cluster

You can upgrade the firmware of an operating FortiAnalyzer cluster in the same way as upgrading the firmware of a
standalone FortiAnalyzer unit.

Upgrade the backup units first. Upgrade the primary unit last, after all backup units have been upgraded and have
synchronized with the primary unit. When you upgrade the primary unit, one of the backup units is automatically
selected to be the primary unit following the rules you set up in If the primary unit fails on page 254. This allows the
HA cluster to continue operating through the upgrade process with primary and backup units.

During the upgrade, you might see messages about firmware version mismatch. This is to be expected. When the
upgrade is completed and all cluster members are at the same firmware version, you should not see this message.

To upgrade FortiAnalyzer HA cluster firmware:

1. Log into each backup unit and upgrade the firmware.
See the FortiAnalyzer Release Notes and FortiAnalyzer Upgrade Guide in the Fortinet Document Library for
more information.

2. Wait for the upgrades to complete and check that the backup units have joined the HA cluster as backups.

Ensure that logs are synchronized with the primary unit.

4. Upgrade the primary unit.
When the primary unit is upgraded, it automatically becomes a backup unit and one of the backup units is
automatically selected to be the primary unit following the rules you set up in If the primary unit fails on page 254.
This allows the HA cluster to continue operating through the upgrade process with primary and backup units.

If firmware versions between cluster members do not match, configuration synchronization is
disabled. Other synchronization operations continue to function.

0

process is complete. During the upgrade, using SSH or telnet to connect to the CLI might be

\ﬂ You might not be able to connect to the FortiAnalyzer GUI until the upgrade synchronization
I slow. If necessary, use the console to connect to the CLI.
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Collectors and Analyzers

This topic describes how to configure two FortiAnalyzer units as the Analyzer and Collector and make them work
together. In the scenario shown in the diagram below, Company A has a remote branch network with a FortiGate unit
and a FortiAnalyzer 400E in Collector mode. In its head office, Company A has another FortiGate unit and a
FortiAnalyzer 3000D in Analyzer mode. The Collector forwards the logs of the FortiGate unit in the remote branch to the
Analyzer in the head office for data analysis and reports generation. The Collector is also used for log archival.

Remote Branch Office Head Office

o © - 8,

Log Forwarding

>
Log Fetching

Fortidnalyzer 400E FortiAnalyzer 3000D
Collector Mode Analyzer Mode

For related concepts, see Two operation modes on page 19 and Analyzer—Collector collaboration on page 21. You need
to complete the initial setup for your FortiAnalyzer units first. See Initial setup on page 16.

Configuring the Collector

To configure the Collector:

1. Ensure the FortiAnalyzer Operation Mode is Collector. See Configuring the operation mode on page 161.
2. Check and configure the storage policy for the Collector. See Log storage information on page 57.

NP For the Collector, you should allocate most of the disk space for Archive logs. You should
S L4 . .
q keep the Archive logs long enough to meet the regulatory requirements of your
- organization. After this initial configuration, you can monitor the storage usage and adjust
- it as you go.
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Following is a storage configuration example of the Collector.

Edit Log Storage Policy - ADOM : Branch_office_FGT

Data Policy
Keep Logs for Analytics 0 Days
Keep Logs for Archive 365 Days

Disk Utilization

Maximum Allowed 1 TB v Out of Available: 4.5 TB
Analytics : Archive 5% v 95% B Modify
Alert and Delete When 0%

Usage Reaches

*If analytic or archive log usages exceed the configured disk quota before the retention period
expires, the oldest logs will be deleted.

I

3. Set up log forwarding to enable the Collector to forward the logs to the Analyzer. See Log Forwarding on page 190.
In particular,

« Set Remote Server Type to FortiAnalyzer.
o Set Server IP to the IP address of the Analyzer that this Collector will forward logs to.
« Click Select Device and select the FortiGate device that the Collector will forward logs for.

Configuring the Analyzer

To configure the Analyzer:

1. Ensure the FortiAnalyzer Operation Mode is Analyzer. See Configuring the operation mode on page 161
2. Check and configure the storage policy for the Analyzer. See Log storage information on page 57.

N ! /., For the Analyzer you should allocate most of the disk space for Analytics logs. You may
q want to keep the Analytics logs for 30—90 days. After this initial configuration, you can
3 monitor the storage usage and adjust it as you go.

Following is a storage configuration example of the Analyzer.

Edit Log Storage Policy - ADOM : For_Branch_Office

Data Policy
Keep Logs for Analytics 60 Days
Keep Logs for Archive 0 Days

Disk Utilization

Maximum Allowed 1 B . Qut of Available: 4.5 TB
Analytics : Archive 95% 5% B Modify
Alert and Delete When 90%

Usage Reaches

*If analytic or archive log usages exceed the configured disk quota before the retention period
expires, the oldest logs will be deleted.

I
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3. Make sure that the aggregation service is enabled on the Analyzer. If not, use this CLI command to enable it:
config system log-forward-service
set accept-aggregation enable
end

4. Add the FortiGate device of the remote office that the Collector will forward logs for. See Authorizing devices on
page 26.

Once the FortiGate of the remote office is added, the Analyzer starts receiving its logs from the Collector.

Fetching logs from the Collector to the Analyzer

At times, you might want to fetch logs from the Collector to the Analyzer. The Collector will perform the role of the fetch
server, and the Analyzer will perform the role of fetch client. For information about how to conduct log fetching, see
Fetcher Management on page 195.
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Appendix A - Supported RFC Notes

This section identifies the request for comment (RFC) notes supported by FortiAnalyzer.

RFC 2665

Description:

Ethernet-like MIB parts that apply to FortiAnalyzer units.

Category:
FortiAnalyzer (SNMP)
Webpage:

http://tools.ietf.org/html/rfc2665

RFC 1918

Description:

Address Allocation for Private Internets.

Category:
FortiAnalyzer
Webpage:

http://tools.ietf.org/html/rfc1918

RFC 1213

Description:

MIB Il parts that apply to FortiAnalyzer units.
Category:

FortiAnalyzer (SNMP)

Webpage:

http://tools.ietf.org/html/rfc1213
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Change Log

Date Change Description

2019-12-19 Initial release.
2019-12-24 Updated Public Key Infrastructure on page 234.
2020-01-16 Updated Adding an HA cluster on page 27.
2020-03-04 Added additional information about remote server types to Configuring log forwarding on page
191.
2020-04-20 Added additional information to Creating a custom event handler on page 64.
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