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Change Log

Change Log
Date

Change Description

2019-03-28

Initial release.

2019-04-02

Updated Virtual Domains on page 489.

2019-04-03

Added Supported log types to FortiAnalyzer, syslog, and FortiAnalyzer Cloud on page
1334.
Added Multiple FortiSwitches in tiers via aggregate interface with MCLAG enabled only
on distribution on page 1283.

2019-04-05

Updated introduction SD-WAN on page 369.
Updated License subsections in Overlay Controller VPN (OCVPN) on page 899.

2019-04-15

Updated Email filter on page 826 with additional topics.

2019-04-16

Updated Switch Controller on page 1254 with additional topics.

2019-04-17

Added About inspection modes on page 871.

2019-04-18

Added SD-WAN Troubleshooting SD-WAN on page 437.

2019-04-24

Added Application control on page 816.

2019-04-29

Added Aggregation and redundancy on page 297.
Added DHCP server on page 456.
Added Backing up log files or dumping log messages on page 1346.
Added VoIP solutions on page 853.

2019-04-30

Added Data leak prevention on page 839.
Added topics for Flow and Device Detection on page 1302.
Added Log-related diagnose commands on page 1341.
Updated MPLS (SIP and backup) + DIA (cloud apps) on page 392.

2019-05-01

Added Explicit and transparent proxies on page 333.

2019-05-07

Updated FortiGate DNS server on page 324.
Updated VLANs on page 299.
Added topics for Web filter on page 742

2019-05-08

Added topics for DNS filter on page 793

2019-05-14

Added Using DHCP interface on page 373.

2019-05-23

Added Sample logs by log type on page 1313.
Added Zero touch provisioning with FortiDeploy on page 51.
Added Zero touch provisioning with FortiManager on page 53.

2019-05-24
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Change Log

Date

Change Description

2019-05-28

Added FortiView from FortiAnalyzer on page 262.

2019-05-29

Added Web rating override on page 889.
Added Troubleshooting for DNS filter on page 813.

2019-05-30

Updated Log and Report on page 1313.

2019-05-31

Added Endpoint control and compliance on page 1163.

2019-06-07

Updated Using the GUI on page 17.

2019-06-20

Updated Fabric connectors on page 101.

2019-06-21

Updated SD-WAN on page 369.

2019-06-25

Added Self-originating traffic on page 401 and SDN dynamic connector addresses in
SD-WAN rules on page 403.

2019-06-26

Updated Explicit and transparent proxies on page 333.

2019-06-27

Added SAML on page 1222.
Added Determining your QoS requirements on page 662.

2019-07-04

Added Compliance on page 1166.
Added Cloud application view on page 264 and FortiView from FortiGate Cloud on
page 279.
Added topics for Policies.

2019-07-09

Added DNS domain list on page 322.
Added Source and destination UUID logging on page 1339.
Added TLS 1.3 support on page 1148.

2019-07-10

Added Supported views for different log sources on page 282.

2019-07-11

Added Adding VDOMs with FortiGate v-series on page 1360.

2019-07-15

Added Web profile override on page 891.

2019-07-17

Added Direct IP support for LTE/4G on page 460.
Added DNS over TLS on page 331.

2019-07-18

Added Unified FortiCare and FortiGate Cloud login on page 44.
Added Global IP address information database on page 604.
Added Authentication policy extensions on page 632.

2019-07-19

Added IKEv2 IPsec site-to-site VPN to an Azure VPN gateway on page 978.
Added IKEv2 IPsec site-to-site VPN to an AWS VPN gateway on page 982.
Added Botnet C&C IP blocking on page 823.
Added Device summary and filtering on page 1186.
Added DHCP relay agent information option on page 457.
Added Failure detection for aggregate and redundant interfaces on page 317.
Added Flow-based web filtering on page 786.
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Change Log

Date

Change Description

2019-07-24

Added Disabling stateful SCTP inspection on page 517.
Added Enabling Active Directory recursive search on page 1197.
Added NTLM extensions on page 633.

2019-07-25

Added Fragmenting IP packets before IPsec encapsulation on page 1084.
Guide reorganized.

2019-07-26

Added VLAN inside VXLAN on page 318.
Added SMBv2 support on page 1149.
Added Terraform: FortiOS as a provider on page 1363.

2019-07-29

Added LLDP reception on page 464.
Added FSSO polling connector agent installation on page 1191.

2019-07-30

Added Protecting a server running web applications on page 868.

2019-08-09

Added HTTP to HTTPS redirect for load balancing on page 636.
Added Local-in policies on page 619.
Added SSO/Identity connectors on page 154.

2019-08-13

Added Classifying traffic by source interface on page 684.
Added Weighted random early detection queuing on page 690.

2019-08-15

Added Leveraging SAML to switch between Security Fabric FortiGates on page 241.

2019-08-16

Added OSPFv3 neighbor authentication on page 627.
Added GTPv2 in policies on page 637.
Added Adding MAC-based addresses to devices on page 1188.

2019-08-19

Added Virtual Wire Pair with VXLAN on page 318.

2019-08-22

Added FortiGate Cloud / FDN communication through an explicit proxy on page 642.
Added Explicit proxy and FortiSandbox Cloud on page 366.
Added Factory default health checks on page 378.
Added Per-link controls for policies and SLA checks on page 399.
Added Controlling traffic with BGP route mapping and service rules on page 414.

2019-08-30

Added NGFW policy mode application default service on page 570.

2019-09-17

Added Configuration scripts on page 550.
Added Using standalone configuration synchronization on page 513.

2019-09-18

Clarified how the Minimum interval option works in Creating automation stitches on
page 191.

2019-09-23

Added Introduction to the FGCP cluster on page 510.

2019-09-25

Added OCI SDN connector on page 122.
Added ADVPN and shortcut paths on page 417.

2019-10-09
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Change Log

Date

Change Description

2019-10-24

Added ClearPass endpoint connector via FortiManager on page 125.
Added ClearPass integration for dynamic address objects on page 654.
Added FSSO dynamic address subtype on page 650.
Added Symantec endpoint connector on page 162.
Added VMware NSX-T manager SDN connector on page 117.

2019-10-28

Added Configuring traffic class IDs on page 685.
Added Using wildcard FQDN addresses in firewall policies on page 659.
Updated Filtering on page 546.

2019-10-29

Added IPsec VPN wizard hub-and-spoke ADVPN support on page 1041.

2019-10-31

Added IPsec VPN to Azure on page 988.

2019-11-01

Added Upgrading FortiGates in an HA cluster on page 518.

2019-11-08

Added Enabling advanced policy options in the GUI on page 630.
Added Ignoring the AUTH TLS command on page 884.
Added SSH traffic file scanning on page 885.

2019-11-13

Added FortiGuard third party SSL validation and anycast support on page 548.
Added IPv6 FortiGuard connections on page 541.

2019-11-25

Added Execute a CLI script based on CPU and memory thresholds on page 221.

2019-12-03

Added Configuring SD-WAN in an HA cluster using internal hardware switches on page
451.

2020-08-24

Added Cisco ACI SDN connector on page 132 and Nuage SDN connector on page 134.

2020-08-25

Updated FortiSwitch multi-tenant support on page 1304.

2020-09-01

Updated Encryption algorithms on page 1076 and Configuring FortiToken Mobile on
page 1219.

2020-09-25

Added Purchase and import a signed SSL certificate on page 560 and SSL VPN best
practices on page 1092.
Updated SSL VPN with certificate authentication on page 1111.

2020-10-08

Updated Threat feeds on page 175, External resources for DNS filter on page 185, and
FortiGuard third party SSL validation and anycast support on page 548.

2020-10-23

Updated LLDP reception on page 464.
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Getting started
This section explains how to get started with a FortiGate.

Differences between models
Not all FortiGates have the same features, particularly entry-level models (models 30 to 90). A number of features on
these models are only available in the CLI.

Consult your model's QuickStart Guide, hardware manual, or the Feature / Platform Matrix for
further information about features that vary by model.

FortiGate models differ principally by the names used and the features available:
l

l

Naming conventions may vary between FortiGate models. For example, on some models the hardware switch
interface used for the local area network is called lan, while on other units it is called internal.
Certain features are not available on all models. Additionally, a particular feature may be available only through the
CLI on some models, while that same feature may be viewed in the GUI on other models.
If you believe your FortiGate model supports a feature that does not appear in the GUI, go to System > Feature
Visibility and confirm that the feature is enabled. For more information, see Feature visibility on page 554.

Using the GUI
This section presents an introduction to the graphical user interface (GUI) on your FortiGate.
The following topics are included in this section:
l
l
l
l

Connecting using a web browser
Menus
Tables
Entering values

For information about using the dashboards, see Dashboard on page 55.

Connecting using a web browser
In order to connect to the GUI using a web browser, an interface must be configured to allow administrative access over
HTTPS or over both HTTPS and HTTP. By default, an interface has already been set up that allows HTTPS access with
the IP address 192.168.1.99.
Browse to https://192.168.1.99 and enter your username and password. If you have not changed the admin account’s
password, use the default user name, admin, and leave the password field blank.
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The GUI will now be displayed in your browser.

To use a different interface to access the GUI:
1. Go to Network > Interfaces and edit the interface you wish to use for access. Take note of its assigned IP address.
2. Beside Administrative Access, select HTTPS, and any other protocol you require. You can also select HTTP,
although this is not recommended as the connection will be less secure.
3. Click OK.
4. Browse to the IP address using your chosen protocol.
The GUI will now be displayed in your browser.

Menus
If you believe your FortiGate model supports a menu that does not appear in the GUI, go to
System > Feature Visibility and ensure the feature is enabled. For more information, see
Feature visibility on page 554.
The GUI contains the following main menus, which provide access to configuration options for most FortiOS features:
Dashboard

The dashboard displays various widgets that display important system
information and allow you to configure some system options.
For more information, see Dashboard on page 55.

Security Fabric

Access the physical topology, logical topology, audit, and settings of the Fortinet
Security Fabric.
For more information, see Fortinet Security Fabric on page 64.

FortiView

A collection of dashboards and logs that give insight into network traffic, showing
which users are creating the most traffic, what sort of traffic it is, when the traffic
occurs, and what kind of threat the traffic may pose to the network.
For more information, seeFortiView on page 256.

Network

Options for networking, including configuring system interfaces and routing
options.
For more information, see Network on page 295.

System

Configure system settings, such as administrators, FortiGuard, and certificates.
For more information, see System on page 467.

Policy & Objects

Configure firewall policies, protocol options, and supporting content for policies,
including schedules, firewall addresses, and traffic shapers.
For more information, see Policy and Objects on page 564.

Security Profiles

Configure your FortiGate's security features, including Antivirus, Web Filter, and
Application Control.
For more information, see Security Profiles on page 697.

VPN

Configure options for IPsec and SSL virtual private networks (VPNs).
For more information, see IPsec VPNs on page 899 and SSL VPN on page 1091.
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User & Device

Configure user accounts, groups, and authentication methods, including external
authentication and single sign-on (SSO).

WiFi & Switch Controller

Configure the unit to act as a wireless network controller, managing the wireless
Access Point (AP) functionality of FortiWiFi and FortiAP units.
On certain FortiGate models, this menu has additional features allowing for
FortiSwitch units to be managed by the FortiGate.
For more information, see Wireless configuration on page 1253 and Switch
Controller on page 1254.

Log & Report

Configure logging and alert email as well as reports.
For more information, see Log and Report on page 1313.

Monitor

View a variety of monitors, including the Routing Monitor, VPN monitors for both
IPsec and SSL, monitors relating to wireless networking, and more.

Tables
Many GUI pages contain tables of information that can be filtered and customized to display specific information in a
specific way. Some tables allow content to be edited directly on that table, or rows to be copied and pasted.

Navigation
Some tables contain information and lists that span multiple pages. Navigation controls will be available at the bottom of
the page.

Filters
Filters are used to locate a specific set of information or content in a table. They can be particularly useful for locating
specific log entries. The filtering options vary, depending on the type of information in the log.
Depending on the table content, filters can be applied using the filter bar, using a column filter, or based on a cell's
content. Some tables allow filtering based on regular expressions.
Administrators with read and write access can define filters. Multiple filters can be applied at one time.

To manually create a filter:
1.
2.
3.
4.

Click Add Filter at the top of the table. A list of the fields available for filtering is shown.
Select the field to filter by.
Enter the value to filter by, adding modifiers as needed.
Press Enter to apply the filter.

To create a column filter:
1.
2.
3.
4.

Click the filter icon on the right side of the column header
Choose a filter type from the available options.
Enter the filter text, or select from the available values.
Click Apply.
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To create a filter based on a cell's content:
1. Right click on a cell in the table.
2. Select a filtering option from the menu.

Column settings
Columns can be rearranged, resized, and added or removed from tables.

To add or remove columns:
1. Right a column header, or click the gear icon on the left side of the header row that appears when hovering the
cursor over the headers.
2. Select columns to add or remove.
3. Click Apply.

To rearrange the columns in a table:
1. Click and drag the column header.

To resize a column:
1. Click and drag the right border of the column header.

To resize a column to fit its contents:
1. Click the dots or filter icon on the right side of the column header and select Resize to Contents.

To resize all of the columns in a table to fit their content:
1. Right a column header, or click the gear icon on the left side of the header row that appears when hovering the
cursor over the headers.
2. Click Best Fit All Columns.

To reset a table to its default view:
1. Right a column header, or click the gear icon on the left side of the header row that appears when hovering the
cursor over the headers.
2. Click Reset Table.
Resetting a table does not remove filters.

Editing objects
In some tables, parts of a configuration can be edited directly in the table. For example, security profiles can be added to
an existing firewall policy by clicking the edit icon in a cell in the Security Profiles column.
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Copying rows
In some tables, rows can be copied and pasted using the right-click menu. For example, a policy can be duplicated by
copying and pasting it.

Entering values
Numerous fields in the GUI and CLI require text strings or numbers to be entered when configuring the FortiGate. When
entering values in the GUI, you will be prevented from entering invalid characters, and a warning message will be shown
explaining what values are not allowed. If invalid values are entered in a CLI command, the setting will be rejected when
you apply it.
l
l

Text strings on page 21
Numbers on page 22

Text strings
Text strings are used to name entities in the FortiGate configuration. For example, the name of a firewall address,
administrator, or interface are all text strings.
The following characters cannot be used in text strings, as they present cross-site scripting (XSS) vulnerabilities:
l
l
l
l

“ - double quotes
' - single quote
> - greater than
< - less than

Most GUI text fields prevent XSS vulnerable characters from being added.

VDOM names and hostnames can only use numbers (0-9), letters (a-z and A-Z), dashes, and
underscores.

The tree CLI command can be used to view the number of characters allowed in a name field. For example, entering
the following commands show that a firewall address name can contain up to 80 characters, while its FQDN can contain
256 characters:
config fire address
(address) # tree
-- [address] --*name
(80)
|- uuid
|- subnet
|- type
|- start-mac
|- end-mac
|- start-ip
|- end-ip
|- fqdn
(256)
|- country
(3)
|- wildcard-fqdn
(256)
|- cache-ttl
(0,86400)
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|||||||||||||||||-

wildcard
sdn
(36)
interface
(36)
tenant
(36)
organization
(36)
epg-name
(256)
subnet-name
(256)
sdn-tag
(16)
policy-group
(16)
comment
visibility
associated-interface
(36)
color
(0,32)
filter
sdn-addr-type
obj-id
[list] --*ip
(36)
|- obj-id
(128)
+- net-id
(128)
|- [tagging] --*name
(64)
|- category
(64)
+- [tags] --*name
+- allow-routing

(80)

Numbers
Numbers are used to set sizes, rated, addresses, port numbers, priorities, and other such numeric values. They can be
entered as a series of digits (without commas or spaces), in a dotted decimal format (such as IP addresses), or
separated by colons (such as MAC addresses). Most numeric values use base 10 numbers, while some use
hexadecimal values.
Most GUI and CLI fields prevent invalid numbers from being entered. The CLI help text includes information about the
range of values allowed for applicable settings.

Using the CLI
The Command Line Interface (CLI) can be used in lieu of the GUI to configure the FortiGate. Some settings are not
available in the GUI, and can only be accessed using the CLI.
This section briefly explains basic CLI usage. For more information about the CLI, see the FortiOS CLI Reference.
l
l
l
l
l

Connecting to the CLI on page 23
CLI basics on page 25
Command syntax on page 31
Subcommands on page 34
Permissions on page 36
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Connecting to the CLI
You can connect to the CLI using a direct console connection, SSH, the CLI console in the GUI, or the FortiExplorer app
on your iOS device.
You can access the CLI in three ways:
l
l

l

Console connection: Connect your computer directly to the console port of your FortiGate.
SSH access: Connect your computer through any network interface attached to one of the network ports on your
FortiGate.
FortiExplorer: Connect your device to the FortiExplorer app on your iOS device to configure, manage, and monitor
your FortiGate. See FortiExplorer for iOS on page 36 for details.

Console connection
A direct console connections to the CLI is created by directly connecting your management computer or console to the
FortiGate unit, using its DB-9 or RJ-45 console port.
Direct console access to the FortiGate may be required if:
l
l

You are installing the FortiGate for the first time and it is not configured to connect to your network.
You are restoring the firmware using a boot interrupt. Network access to the CLI will not be available until after the
boot process has completed, making direct console access the only option.

To connect to the FortiGate console, you need:
l
l

l

A computer with an available communications port
A console cable to connect the console port on the FortiGate to a communications port on the computer (a USB
adapter may also be required)
Terminal emulation software

To connect to the CLI using a direct console connection:
1. Using the null modem or RJ-45-to-DB-9 cable, connect the FortiGate unit’s console port to the serial
communications (COM) port on your management computer. A DB-9-to-USB adapter may be required is your
computer does not have a DB-9 port.
2. Start a terminal emulation program on the management computer, select the COM port, and use the following
settings:
Bits per second

9600

Data bits

8

Parity

None

Stop bits

1

Flow control

None

3. Press Enter on the keyboard to connect to the CLI.
4. Log in to the CLI using your username and password (default: admin and no password).
5. You can now enter CLI commands, including configuring access to the CLI through SSH.
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SSH access
SSH access to the CLI is accomplished by connecting your computer to the FortiGate unit using one of its network ports.
You can either connect directly, using a peer connection between the two, or through any intermediary network.
If you do not want to use an SSH client and you have access to the GUI, you can access the
CLI through the network using the CLI console in the GUI.
The CLI console can be accessed from the upper-right hand corner of the screen and appears
as a slide-out window. For policies and objects, the CLI can be also be accessed by right
clicking on the element and selecting Edit in CLI.
SSH must be enabled on the network interface that is associated with the physical network port that is used.
If your computer is not connected either directly or through a switch to the FortiGate, you must also configure the
FortiGate with a static route to a router that can forward packets from the FortiGate to the computer. This can be done
using a local console connection, or in the GUI.
To connect to the FortiGate CLI using SSH, you need:
l
l
l
l
l

A computer with an available serial communications (COM) port and RJ-45 port
The RJ-45-to-DB-9 or null modem cable included in your FortiGate package
Terminal emulation software
A network cable
Prior configuration of the operating mode, network interface, and static route.

To enable SSH access to the CLI using a local console connection:
1. Using the network cable, connect the FortiGate unit’s port either directly to your computer’s network port, or to a
network through which your computer can reach the FortiGate unit.
2. Note the number of the physical network port.
3. Using direct console connection, connect and log into the CLI.
4. Enter the following command:
config system interface
edit <interface_str>
append allowaccess ssh
next
end

Where <interface_str> is the name of the network interface associated with the physical network port, such as
port1.
5. Confirm the configuration using the following command to show the interface’s settings:
show system interface <interface_str>

For example:
show system interface port1
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
set allowaccess ping https ssh
set type hard-switch
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set stp enable
set role lan
set snmp-index 6
next
end

Connecting using SSH
Once the FortiGate unit is configured to accept SSH connections, use an SSH client on your management computer to
connect to the CLI.
The following instructions use PuTTy. The steps may vary in other terminal emulators.

To connect to the CLI using SSH:
1. On your management computer, start PuTTy.
2. In the Host Name (or IP address) field, enter the IP address of the network interface that you are connected to and
that has SSH access enabled.
3. Set the port number to 22, if it is not set automatically.
4. Select SSH for the Connection type.
5. Click Open. The SSH client connect to the FortiGate.
The SSH client may display a warning if this is the first time that you are connecting to the FortiGate and its SSH key
is not yet recognized by the SSH client, or if you previously connected to the FortiGate using a different IP address
or SSH key. This is normal if the management computer is connected directly to the FortiGate with no network hosts
in between.
6. Click Yes to accept the FortiGate unit's SSH key.
The CLI displays the log in prompt.
7. Enter a valid administrator account name, such as admin, then press Enter.
8. Enter the administrator account password, then press Enter.
The CLI console shows the command prompt (FortiGate hostname followed by a #). You can now enter
CLI commands.

If three incorrect log in or password attempts occur in a row, you will be disconnected. If this
occurs, wait for one minute, then reconnect and attempt to log in again.

CLI basics
Basic features and characteristics of the CLI environment provide support and ease of use for many CLI tasks.

Help
Press the question mark (?) key to display command help and complete commands.
l

l

Press the question mark (?) key at the command prompt to display a list of the commands available and a
description of each command.
Enter a command followed by a space and press the question mark (?) key to display a list of the options available
for that command and a description of each option.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

25

Getting started

l

l

Enter a command followed by an option and press the question mark (?) key to display a list of additional options
available for that command option combination and a description of each option.
Enter a question mark after entering a portion of a command to see a list of valid complete commands and their
descriptions. If there is only one valid command, it will be automatically filled in.

Shortcuts and key commands
Shortcut key

Action

?

List valid complete or subsequent commands.
If multiple commands can complete the command, they are listed with their
descriptions.

Tab

Complete the word with the next available match.
Press multiple times to cycle through available matches.

Up arrow or Ctrl + P

Recall the previous command.
Command memory is limited to the current session.

Down arrow, or Ctrl + N

Recall the next command.

Left or Right arrow

Move the cursor left or right within the command line.

Ctrl + A

Move the cursor to the beginning of the command line.

Ctrl + E

Move the cursor to the end of the command line.

Ctrl + B

Move the cursor backwards one word.

Ctrl + F

Move the cursor forwards one word.

Ctrl + D

Delete the current character.

Ctrl + C

Abort current interactive commands, such as when entering multiple lines.
If you are not currently within an interactive command such as config or edit,
this closes the CLI connection.

\ then Enter

Continue typing a command on the next line for a multiline command.
For each line that you want to continue, terminate it with a backslash ( \ ). To
complete the command, enter a space instead of a backslash, and then press
Enter.

Command tree
Enter tree to display the CLI command tree. To capture the full output, connect to your device using a terminal
emulation program and capture the output to a log file. For some commands, use the tree command to view all
available variables and subcommands.

Command abbreviation
You can abbreviate words in the command line to their smallest number of non-ambiguous characters.
For example, the command get system status could be abbreviated to g sy stat.
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Adding and removing options from lists
When configuring a list, the set command will remove the previous configuration.
For example, if a user group currently includes members A, B, and C, the command set member D will remove
members A, B, and C. To avoid removing the existing members from the group, the command set members A B C D
must be used.
To avoid this issue, the following commands are available:
append

Add an option to an existing list.
For example, append member D adds user D to the user group without removing any of the
existing members.

select

Clear all of the options except for those specified.
For example, select member B removes all member from the group except for member B.

unselect

Remove an option from an existing list.
For example, unselect member C removes only member C from the group, without
affecting the other members.

Environment variables
The following environment variables are support by the CLI. Variable names are case-sensitive.
$USERFROM

The management access type (ssh, jsconsole, and so on) and the IPv4 address of the
administrator that configured the item.

$USERNAME

The account name of the administrator that configured the item.

$SerialNum

The serial number of the FortiGate unit.

For example, to set a FortiGate device's host name to its serial number, use the following CLI command:
config system global
set hostname $SerialNum
end

Special characters
The following characters cannot be used in most CLI commands: <, >, (, ), #, ', and "
If one of those characters, or a space, needs to be entered as part of a string, it can be entered by using a special
command, enclosing the entire string in quotes, or preceding it with an escape character (backslash, \).
To enter a question mark (?) or a tab, Ctrl + V must be entered first.

Character

Keys

?

Ctrl + V then ?

Tab

Ctrl + V then Tab
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Character

Keys

Space

Enclose the string in single or double quotation marks: "Security
Administrator”. or 'Security Administrator'.

(as part of a string value, not to end the string)

Precede the space with a backslash: Security\ Administrator.
'

\'

(as part of a string value, not to begin or end
the string)
"

\"

(as part of a string value, not to begin or end
the string)
\

\\

Using grep to filter command output
The get, show, and diagnose commands can produce large amounts of output. The grep command can be used to
filter the output so that it only shows the required information.
The grep command is based on the standard UNIX grep, used for searching text output based on regular expressions.
For example, the following command displays the MAC address of the internal interface:
get hardware nic internal | grep Current_HWaddr
Current_HWaddr
00:09:0f:cb:c2:75

The following command will display all TCP sessions that are in the session list, including the session list line number in
the output:
get system session list | grep -n tcp

The following command will display all of the lines in the HTTP replacement message that contain URL or url:
show system replacemsg http | grep -i url

The following options can also be used:
-A <num> After
-B <num> Before
-C <num> Context

The -f option is available to support contextual output, in order to show the complete configuration. The following
example shows the difference in the output when -f is used versus when it is not used:
Without -f:

With -f:

show | grep ldap-group1
edit "ldap-group1"
set groups "ldap-group1"

show | grep -f ldap-group1
config user group
edit "ldap-group1"
set member "pc40-LDAP"
next
end
config firewall policy
edit 2
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set srcintf "port31"
set dstintf "port32"
set srcaddr "all"
set action accept
set identity-based enable
set nat enable
config identity-based-policy
edit 1
set schedule "always"
set groups "ldap-group1"
set dstaddr "all"
set service "ALL"
next
end
next
end

Language support and regular expressions
Characters such as ñ and é, symbols, and ideographs are sometimes acceptable input. Support varies depending on the
type of item that is being configured. CLI commands, objects, field names, and options must use their exact ASCII
characters, but some items with arbitrary names or values can be input using your language of choice. To use other
languages in those cases, the correct encoding must be used.
Input is stored using Unicode UTF-8 encoding, but is not normalized from other encodings into UTF-8 before it is stored.
If your input method encodes some characters differently than in UTF-8, configured items may not display or operate as
expected.
Regular expressions are especially impacted. Matching uses the UTF-8 character values. If you enter a regular
expression using a different encoding, or if an HTTP client sends a request in a different encoding, matches may not be
what is expected.
For example, with Shift-JIS, backslashes could be inadvertently interpreted as the symbol for the Japanese yen ( ¥ ), and
vice versa. A regular expression intended to match HTTP requests containing monetary values with a yen symbol may
not work it if the symbol is entered using the wrong encoding.
For best results:
l
l

l

use UTF-8 encoding, or
use only characters whose numerically encoded values are the same in UTF-8, such as the US-ASCII characters
that are encoded using the same values in ISO 8859-1, Windows code page 1252, Shift-JIS, and other encoding
methods, or
for regular expressions that must match HTTP requests, use the same encoding as your HTTP clients.
HTTP clients may send requests in encodings other than UTF-8. Encodings usually vary
based on the client’s operating system or input language. If the client's encoding method
cannot be predicted, you might only be able to match the parts of the request that are in
English, as the values for English characters tend to be encoded identically, regardless of the
encoding method.
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If the FortiGate is configured to use an encoding method other than UTF-8, the management computer's language may
need to be changed, including the web browse and terminal emulator. If the FortiGate is configured using non-ASCII
characters, all the systems that interact with the FortiGate must also support the same encoding method. If possible, the
same encoding method should be used throughout the configuration to avoid needing to change the language settings
on the management computer.
The GUI and CLI client normally interpret output as encoded using UTF-8. If they do not, configured items may not
display correctly. Exceptions include items such as regular expression that may be configured using other encodings to
match the encoding of HTTP requests that the FortiGate receives.

To enter non-ASCII characters in a terminal emulator:
1. On the management computer, start the terminal client.
2. Configure the client to send and receive characters using UTF-8 encoding.
Support for sending and receiving international characters varies by terminal client.
3. Log in to the FortiGate unit.
4. At the command prompt, type your command and press Enter.
Words that use encoded characters may need to be enclosed in single quotes ( ' ).
Depending on your terminal client’s language support, you may need to interpret the characters into character
codes before pressing Enter. For example, you might need to enter: edit '\743\601\613\743\601\652'
5. The CLI displays the command and its output.

Screen paging
By default, the CLI will pause after displaying each page worth of text when a command has multiple pages of output.
this can be useful when viewing lengthy outputs that might exceed the buffer of terminal emulator.
When the display pauses and shows --More--, you can:
l
l
l
l
l

Press Enter to show the next line,
Press Q to stop showing results and return to the command prompt,
Press an arrow key, Insert, Home, Delete, End, Page Up, or Page Down to show the next few pages,
Press any other key to show the next page, or
Wait for about 30 seconds for the console to truncate the output and return to the command prompt.

When pausing the screen is disable, press Ctrl + C to stop the output and log out of the FortiGate.

To disable pausing the CLI output:
config system console
set output standard
end

To enable pausing the CLI output:
config system console
set output more
end
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Changing the baud rate
The baud rate of the local console connection can be changed from its default value of 9600.

To change the baud rate:
config system console
set baudrate {9600 | 19200 | 38400 | 57600 | 115200}
end

Editing the configuration file
The FortiGate configuration file can be edited on an external host by backing up the configuration, editing the
configuration file, and then restoring the configuration to the FortiGate.
Editing the configuration file can save time is many changes need to be made, particularly if the plain text editor that you
are using provides features such as batch changes.

To edit the configuration file:
1. Backup the configuration. See Configuration backups on page 59 for details.
2. Open the configuration file in a plain text editor that supports UNIX-style line endings.
3. Edit the file as needed.
Do not edit the first line of the configuration file.
This line contains information about the firmware version and FortiGate model. If you
change the model number, the FortiGate unit will reject the configuration when you attempt
to restore it.
4. Restore the modified configuration to the FortiGate. See Configuration backups on page 59 for details.
The FortiGate downloads the configuration file and checks that the model information is correct. If it is correct, the
configuration file is loaded and each line is checked for errors. If a command is invalid, that command is ignored. If
the configuration file is valid, the FortiGate restarts and loads the downloaded configuration.

Command syntax
When entering a command, the CLI console requires that you use valid syntax and conform to expected input
constraints. It rejects invalid commands. Indentation is used to indicate the levels of nested commands.
Each command line consists of a command word, usually followed by configuration data or a specific item that the
command uses or affects.

Notation
Brackets, vertical bars, and spaces are used to denote valid syntax. Constraint notations, such as <address_ipv4>,
indicate which data types or string patterns are acceptable value input.
All syntax uses the following conventions:
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Angle brackets < >

Indicate a variable of the specified data type.

Curly brackets { }

Indicate that a variable or variables are mandatory.

Square brackets [ ]

Indicate that the variable or variables are optional.
For example:
show system interface [<name_str>]

To show the settings for all interfaces, you can enter show system interface
To show the settings for the Port1 interface, you can enter show system interface
port1.
Vertical bar |

A vertical bar separates alternative, mutually exclusive options.
For example:
set protocol {ftp | sftp}

You can enter either set protocol ftp or set protocol sftp.
Space

A space separates non-mutually exclusive options.
For example:
set allowaccess {ping https ssh snmp http fgfm radius-acct proberesponse capwap ftm}

You can enter any of the following:
set allowaccess ping
set allowaccess https ping ssh
set allowaccess http https snmp ssh ping

In most cases, to make changes to lists that contain options separated by spaces, you need to
retype the entire list, including all the options that you want to apply and excluding all the
options that you want to remove.

Optional values and ranges
Any ﬁeld that is optional will use square-brackets. The overall config command will still be valid whether or not the option
is configured.
Square-brackets can be used is to show that multiple options can be set, even intermixed with ranges. The following
example shows a ﬁeld that can be set to either a speciﬁc value or range, or multiple instances:
config firewall service custom
set iprange <range1> [<range2> <range3> ...]
end

next
The next command is used to maintain a hierarchy and flow to CLI commands. It is at the same indentation level as the
preceding edit command, to mark where a table entry finishes.
The following example shows the next command used in the subcommand entries:
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After configuring table entry <2> then entering next, the <2> table entry is saved and the console returns to the
entries prompt:

You can now create more table entries as needed, or enter end to save the table and return to the filepattern table
element prompt.

end
The end command is used to maintain a hierarchy and flow to CLI commands.
The following example shows the same command and subcommand as the next command example, except end has
been entered instead of next after the subcommand:

Entering end will save the <2> table entry and the table, and exit the entries subcommand entirely. The console
returns to the filepattern table element prompt:
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Subcommands
Subcommands are available from within the scope of some commands. When you enter a subcommand level, the
command prompt changes to indicate the name of the current command scope. For example, after entering:
config system admin

the command prompt becomes:
(admin)#

Applicable subcommands are available until you exit the command, or descend an additional level into another
subcommand. Subcommand scope is indicated by indentation.
For example, the edit subcommand is only available in commands that affects tables, and the next subcommand is
available only in the edit subcommand:
config system interface
edit port1
set status up
next
end

The available subcommands vary by command. From a command prompt under the config command, subcommands
that affect tables and fields could be available.

Table subcommands
edit <table_row>

Create or edit a table value.
In objects such as security policies, <table_row> is a sequence number. To
create a new table entry without accidentally editing an existing entry, enter edit
0. The CLI will confirm that creation of entry 0, but will assign the next unused
number when the entry is saved after entering end or next.
For example, to create a new firewall policy, enter the following commands:
config firewall policy
edit 0
....
next
end

To edit an existing policy, enter the following commands:
config firewall policy
edit 27
....
next
end

The edit subcommand changes the command prompt to the name of the table
value that is being edited.
delete <table_row>

Delete a table value.
For example, to delete firewall policy 30, enter the following commands:
config firewall policy
delete 30
end
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purge

Clear all table values.
The purge command cannot be undone. To restore purged table values, the
configuration must be restored from a backup.

move

Move an ordered table value.
In the firewall policy table, this equivalent to dragging a policy into a new position.
It does not change the policy's ID number.
For example, to move policy 27 to policy 30, enter the following commands:
config firewall policy
move 27 to 30
end

The move subcommand is only available in tables where the order of the table
entries matters.
clone <table_row> to <table_
row>

Make a clone of a table entry.
For example, to create firewall policy 30 as a clone of policy 27, enter the following
commands:
config firewall policy
clone 27 to 30
end

The clone subcommand may not be available for all tables.
rename <table_row> to
<table_row>

Rename a table entry.
For example to rename an administrator from Flank to Frank, enter the following
commands:
config system admin
rename Flank to Frank
end

The rename subcommand is only available in tables where the entries can be
renamed.
get

List the current table entries.
For example, to view the existing firewall policy table entries, enter the following
commands:
config firewall policy
get

show

Show the configuration. Only table entries that are not set to default values are
shown.

end

Save the configuration and exit the current config command.
Purging the system interface or system admin tables does not reset default table
values. This can result in being unable to connect to or log in to the FortiGate, requiring the
FortiGate to be formatted and restored.

Field subcommands
set <field> <value>
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For example, the command set fsso enable sets the fsso field to the value
enable.
unset

Set the field to its default value.

select

Clear all of the options except for those specified.
For example, if a group contains members A, B, C, and D, to remove all members
except for B, use the command select member B.

unselect

Remove an option from an existing list.
For example, if a group contains members A, B, C, and D, to remove only member
B, use the command unselect member B.

append

Add an option to an existing multi-option table value.

clear

Clear all the options from a multi-option table value.

get

List the configuration of the current table entry, including default and customized
values.

show

Show the configuration. Only values that are not set to default values are shown.

next

Save changes to the table entry and exit the edit command so that you can
configure the next table entry.

abort

Exit the command without saving.

end

Save the configuration and exit the current config command.

Permissions
Administrator, or access, profiles control what CLI commands an administrator can access by assigning read, write, or
no access to each are of FortiOS. For information, see Administrator profiles on page 469.
Read access is required to view configurations. Write access is required to make configuration changes. Depending on
your account's profile, you may not have access to all CLI commands. To have access to all CLI commands, an
administrator account with the super_admin profile must be used, such as the admin account.
Accounts assigned the super_admin profile are similar to the root administrator account. They have full permission to
view and change all FortiGate configuration options, including viewing and changing other administrator accounts.
To increase account security, set strong passwords for all administrator accounts, and change the passwords regularly.

FortiExplorer for iOS
FortiExplorer for iOS is a user-friendly application that helps you to rapidly provision, deploy, and monitor Security Fabric
components from your iOS device.
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FortiExplorer for iOS requires iOS 10.0 or later and is compatible with iPhone, iPad, and Apple TV. It is supported by
FortiOS 5.6 and later, and is only available on the App Store for iOS devices.
Advanced features are available with the purchase of FortiExplorer Pro. Paid features include the ability to add more
than two devices and the ability to download firmware images from FortiCare.
Up to six members can use this app with 'Family Sharing' enabled in the App Store.

Getting started with FortiExplorer
If your FortiGate is accessible on a wireless network, you can connect to it using FortiExplorer provided that your
iOS device is on the same network (see Connecting FortiExplorer to a FortiGate via WiFi). Otherwise, you will need to
physically connect your iOS device to the FortiGate using a USB cable.

To connect and configure a FortiGate with FortiExplorer using a USB connection:
1. Connect your iOS device to your FortiGate USB A port. If prompted on your iOS device, Trust this computer.
2. Open FortiExplorer and select your FortiGate from the FortiGate Devices list . A blue USB icon will indicate that you
are connected over a USB connection.

3.
4.
5.
6.

On the Login screen, select USB.
Enter the default Username (admin) and leave the Password field blank.
Optionally, select Remember Password.
Tap Done when you are ready.
FortiExplorer opens the FortiGate management interface to the Device Status page:
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7. Go to Network > Interfaces and configure the WAN interface or interfaces.
8. The wan1 interface Address mode is set to DHCP by default. Set it to Manual and enter its Address, Netmask, and
Default Gateway, and then Apply your changes.

9. Optionally, configure Administrative Access to allow HTTPS access. This will allow administrators to access the
FortiGate GUI using a web browser.
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10. Go to Network > Interfaces and configure the local network (internal) interface.
11. Set the Address mode as before and configure Administrative Access if required.
12. Configure a DHCP Server for the internal network subnet.

13. Return to the internal interface using the < button at the top of the screen.
14. Go to Network > Static Routes and configure the static route to the gateway.

15. Go to Policy & Objects > IPv4 Policy and edit the Internet access policy. Enter a Name for the policy, enable the
required Security Profiles, configure Logging Options, then tap OK.
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Connecting FortiExplorer to a FortiGate via WiFi
You can wirelessly connect to the FortiGate if your iOS device and the FortiGate are both connected to the same
wireless network.
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To connect and configure a FortiGate with FortiExplorer wirelessly:
1. Open the FortiExplorer app and tap Add on the Devices page.
2. On the Add Device By page, tap HTTPS.

3. Enter the Host information, Username, and Password.
4. If required, change the default Port number, and optionally enable Remember Password.

5. Tap Done.
6. If the FortiGate device identity cannot be verified, tap Connect at the prompt.
FortiExplorer opens the FortiGate management interface to the Device Status page.

Running a security rating
After configuring your network, run a security rating check to identify vulnerabilities and highlight best practices that
could improve your network's security and performance.
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Go to Security Fabric > Security Rating and follow the steps to determine the score. See Security rating on page 95 for
more information.

Upgrading to FortiExplorer Pro
FortiExplorer Pro includes the option to add more than two devices and download firmware images from FortiCare.

To upgrade to FortiExplorer Pro:
1. In FortiExplorer, go to Settings.
2. Tap Upgrade to FortiExplorer Pro.
3. Follow the on-screen prompts.

Basic administration
This section contains information about basic FortiGate administration that you can do after you installing the unit in your
network.
l
l

Registration on page 43
Unified FortiCare and FortiGate Cloud login on page 44
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Registration
The FortiGate must be registered to have full access to Fortinet Customer Service and Support, and FortiGuard
services.

To register your FortiGate:
1. Connect to the FortiGate GUI. A message is shown stating that FortiCare registration is required.

2. Click Register Now.
3. If you already have a support account, set Action to Login, and enter the required information.

If you need to create an account, set Action to Create Account, and enter the required information.
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4. Click OK.
5. Go to System > FortiGuard.
6. In the License Information table, the FortiCare Support status is Registered. There may be a delay before the status
is updated on your FortiGate.

Unified FortiCare and FortiGate Cloud login
With FortinetOne, FortiGate supports a unified login to FortiCare and FortiGate Cloud. The FortiGate Cloud setup is a
subset of the FortiCare setup.
You have the following options:
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l

Activate FortiGate Cloud with a FortinetOne account.

l

Activate FortiGate Cloud with a standalone account.

l

Migrate from a standalone account to a FortinetOne account.

To migrate from a standalone account to a FortinetOne account in the GUI:
1. Go to Dashboard > Status.
2. Ensure that you are logged into FortiCare with a FortinetOne account, and that you have activated FortiGate Cloud
with a standalone account.

3. Go to Security Fabric > Settings.
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4. In the Cloud Logging or Central Management section, click Migrate Now.

5. In the Password field, enter the FortinetOne account password, then click OK.

6. Confirm that the FortiCloud account was successfully migrated from a standalone account to a FortinetOne
account.

To migrate from a standalone account to a FortinetOne account in the CLI:
execute fortiguard-log migration <password>

FortiGate Cloud
FortiGate Cloud is a hosted security management and log retention service for FortiGate devices. It provides centralized
reporting, traffic analysis, configuration management, and log retention without the need for additional hardware or
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software.
FortiGate Cloud offers a wide range of features:
l

l

l

l

l

l

Simplified central management
FortiGate Cloud provides a central GUI to manage individual or aggregated FortiGate and FortiWiFi devices.
Adding a device to the FortiGate Cloud management subscription is straightforward. FortiGate Cloud has detailed
traffic and application visibility across the whole network.
Hosted log retention with large default storage allocated
Log retention is an integral part of any security and compliance program, but administering a separate storage
system is onerous. FortiGate Cloud takes care of this automatically and stores the valuable log information in the
cloud. Different types of logs can be stored, including Traffic, System Events, Web, Applications, and Security
Events.
Monitoring and alerting in real time
Network availability is critical to a good end-user experience. FortiGate Cloud enables you to monitor your FortiGate
network in real time with different alerting mechanisms to pinpoint potential issues. Alerting mechanisms can be
delivered via email.
Customized or pre-configured reporting and analysis tools
Reporting and analysis are your eyes and ears into your network’s health and security. Pre-configured reports are
available, as well as custom reports that can be tailored to your specific reporting and compliance requirements.
The reports can be emailed as PDFs, and can cover different time periods.
Maintain important configuration information uniformly
The correct configuration of the devices within your network is essential for maintaining optimum performance and
security posture. In addition, maintaining the correct firmware (operating system) level allows you to take advantage
of the latest features.
Service security
All communication (including log information) between the devices and the cloud is encrypted. Redundant data
centers are always used to give the service high availability. Operational security measures have been put in place
to make sure your data is secure — only you can view or retrieve it.

Registration and activation

Before you can activate a FortiGate Cloud account, you must first register your device.

FortiGate Cloud accounts can be registered manually through the FortiGate Cloud website, https://www.forticloud.com,
or you can easily register and activate your account directly from your FortiGate.

To activate your FortiGate Cloud account:
1. On your device, go to Dashboard > Status.
2. In the FortiGate Cloud widget, click the Not Activated > Activate button in the Status field.
3. A pane will open asking you to register your FortiGate Cloud account. Click Create Account, enter your information,
view and accept the terms and conditions, and then click OK.
4. A second dialogue window open , asking you to enter your information to confirm your account. This sends a
confirmation email to your registered email. The dashboard widget then updates to show that confirmation is
required.
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5. Open your email, and follow the confirmation link it contains.
A FortiGate Cloud page will open, stating that your account has been confirmed. The Activation Pending message
on the dashboard will change to state the type of account you have, and will provide a link to the FortiGate Cloud
portal.

Enabling logging to FortiGate Cloud
To enable logging to FortiGate Cloud:
1.
2.
3.
4.

Go to Security Fabric > Settings or Log & Report > Log Settings.
Enable Cloud Logging.
Select an upload option: Realtime, Every Minute, or Every 5 Minutes (default).
Click Apply.

Logging into the FortiGate Cloud portal
Once logging has been configured and you have registered your account, you can log into the FortiGate Cloud portal
and begin viewing your logging results. There are two methods to reach the FortiGate Cloud portal:
l

l

If you have direct network access to the FortiGate:
a. Go to Dashboard > Status.
b. In the FortiGate Cloud widget, in the Status field, click Activated > Launch Portal, or, in the Licenses widget,
click FortiCare Support > Launch Portal.
If you do not have access to the FortiGate’s interface, visit the FortiGate Cloud website (https://forticloud.com) and
log in remotely, using your email and password. It will ask you to confirm the FortiGate Cloud account you are
connecting to and then you will be granted access.

Cloud sandboxing
FortiGate Cloud can be used for automated sample tracking, or sandboxing, for files from a FortiGate. This allows
suspicious files to be sent to be inspected without risking network security. If the file exhibits risky behavior, or is found to
contain a virus, a new virus signature is created and added to the FortiGuard antivirus signature database.

To configure cloud sandboxing:
1. Go to Security Fabric > Settings.
2. Enable Sandbox Inspection.
3. Set the FortiSandbox type to FortiSandbox Cloud.

By default, the FortiSandbox Cloud option is not visible. See Feature visibility on page 554
for instructions on making it visible.

4. Select the FortiSandbox cloud region.
5. Click Apply.
Sandboxing results are shown on the Sandbox tab in the FortiGate Cloud portal.
For more information about FortiGate Cloud, see the FortiGate Cloud documentation.
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Troubleshooting your installation
If your FortiGate does not function as desired after installation, try the following troubleshooting tips:
1. Check for equipment issues
Verify that all network equipment is powered on and operating as expected. Refer to the QuickStart Guide for
information about connecting your FortiGate to the network.
2. Check the physical network connections
Check the cables used for all physical connections to ensure that they are fully connected and do not appear
damaged, and make sure that each cable connects to the correct device and the correct Ethernet port on that
device.
3. Verify that you can connect to the internal IP address of the FortiGate
Connect to the GUI from the FortiGate’s internal interface by browsing to its IP address. From the PC, try to ping the
internal interface IP address; for example, ping 192.168.1.99. If you cannot connect to the internal interface,
verify the IP configuration of the PC. If you can ping the interface but can't connect to the GUI, check the settings for
administrative access on that interface. Alternatively, use SSH to connect to the CLI, and then confirm that HTTPS
has been enabled for Administrative Access on the interface.
4. Check the FortiGate interface configurations
Check the configuration of the FortiGate interface connected to the internal network (under Network > Interfaces)
and check that Addressing mode is set to the correct mode.
5. Verify the security policy configuration
Go to Policy & Objects > IPv4 Policy and verify that the internal interface to Internet-facing interface security policy
has been added and is located near the top of the policy list. Check the Active Sessions column to ensure that traffic
has been processed (if this column does not appear, right-click on the table header and select Active Sessions). If
you are using NAT mode, check the configuration of the policy to make sure that NAT is enabled and that Use
Outgoing Interface Address is selected.
6. Verify the static routing configuration
Go to Network > Static Routes and verify that the default route is correct. Go to Monitor > Routing Monitor and verify
that the default route appears in the list as a static route. Along with the default route, you should see two routes
shown as Connected, one for each connected FortiGate interface.
7. Verify that you can connect to the Internet-facing interface’s IP address
Ping the IP address of the Internet-facing interface of your FortiGate. If you cannot connect to the interface, the
FortiGate is not allowing sessions from the internal interface to Internet-facing interface. Verify that PING has been
enabled for Administrative Access on the interface.
8. Verify that you can connect to the gateway provided by your ISP
Ping the default gateway IP address from a PC on the internal network. If you cannot reach the gateway, contact
your ISP to verify that you are using the correct gateway.
9. Verify that you can communicate from the FortiGate to the Internet
Access the FortiGate CLI and use the command execute ping 8.8.8.8. You can also use the execute
traceroute 8.8.8.8 command to troubleshoot connectivity to the Internet.
10. Verify the DNS configurations of the FortiGate and the PCs
Check for DNS errors by pinging or using traceroute to connect to a domain name; for example: ping
www.fortinet.com.
If the name cannot be resolved, the FortiGate or PC cannot connect to a DNS server and you should confirm that
the DNS server IP addresses are present and correct.
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11. Confirm that the FortiGate can connect to the FortiGuard network
Once the FortiGate is on your network, you should confirm that it can reach the FortiGuard network. First, check the
License Information widget to make sure that the status of all FortiGuard services matches the services that you
have purchased. Go to System > FortiGuard. Scroll down to Filtering Services Availability and select Check Again.
After a minute, the GUI should indicate a successful connection.Verify that your FortiGate can resolve and reach
FortiGuard at service.fortiguard.net by pinging the domain name. If you can reach this service, you can
then verify the connection to FortiGuard servers by running the command diagnose debug rating. This
displays a list of FortiGuard IP gateways you can connect to, as well as the following information:
Weight: Based on the difference in time zone between the FortiGate and this server
RTT: Return trip time
l Flags: D (IP returned from DNS), I (Contract server contacted), T (being timed), F (failed)
l TZ: Server time zone
l Curr Lost: Current number of consecutive lost packets
l Total Lost: Total number of lost packets
12. Consider changing the MAC address of your external interface
Some ISPs do not want the MAC address of the device connecting to their network cable to change. If you have
added a FortiGate to your network, you may have to change the MAC address of the Internet-facing interface using
the following CLI command:
l
l

config system interface
edit <interface>
set macaddr <xx:xx:xx:xx:xx:xx>
end
end

13. Check the FortiGate bridge table (transparent mode)
When a FortiGate is in transparent mode, the unit acts like a bridge sending all incoming traffic out on the other
interfaces. The bridge is between interfaces on the FortiGate unit. Each bridge listed is a link between interfaces.
Where traffic is flowing between interfaces, you expect to find bridges listed. If you are having connectivity issues
and there are no bridges listed, that is a likely cause. Check for the MAC address of the interface or device in
question.To list the existing bridge instances on the FortiGate, use the following CLI command:
diagnose netlink brctl name host root.b
show bridge control interface root.b host.
fdb: size=2048, used=25, num=25, depth=1
Bridge root.b host table
port no device devname mac addr ttl attributes
3 4 wan1 00:09:0f:cb:c2:77 88
3 4 wan1 00:26:2d:24:b7:d3 0
3 4 wan1 00:13:72:38:72:21 98
4 3 internal 00:1a:a0:2f:bc:c6 6
1 6 dmz 00:09:0f:dc:90:69 0 Local Static
3 4 wan1 c4:2c:03:0d:3a:38 81
3 4 wan1 00:09:0f:15:05:46 89
3 4 wan1 c4:2c:03:1d:1b:10 0
2 5 wan2 00:09:0f:dc:90:68 0 Local Static

14. Use FortiExplorer if you can’t connect to the FortiGate over Ethernet
If you can’t connect to the FortiGate GUI or CLI, you may be able to connect using FortiExplorer. Refer to the
QuickStart Guide or see the section on FortiExplorer for more details.
15. Either reset the FortiGate to factory defaults or contact Fortinet Support for assistance
To reset the FortiGate to factory defaults, use the CLI command execute factoryreset. When prompted, type
y to confirm the reset.
If you require further assistance, visit the Fortinet Support website.
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Zero touch provisioning
This section contains instructions for configuring zero touch provisioning:
l
l

Zero touch provisioning with FortiDeploy on page 51
Zero touch provisioning with FortiManager on page 53

Zero touch provisioning with FortiDeploy
You can use this feature only when the FortiGate boots up from factory reset.

Topology

FortiGate zero touch provisioning workflow
1. Add the FortiGate Cloud product key to the FortiGate Cloud portal so that the FortiGate serial number appears in
the portal.

2. Set up a configuration template with the basic configuration in the FortiGate Cloud portal.
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3. Deploy the FortiGate to FortiGate Cloud with that template.

4. Ensure the FortiGate has an interface in default DHCP client mode and is connected to the ISP outlet.
5. Boot the FortiGate in factory reset. The FortiGate gets the DHCP lease so that it can access FortiGate Cloud in the
Internet and join FortiGate Cloud.
Initializing firewall...
System is starting...
FortiGate-201E login: admin
Password:
Welcome !
FortiGate-201E #
FortiGate-201E # diagnose debug cli 7
Debug messages will be on for 30 minutes.
FortiGate-201E # 0: config system fortiguard
0: set service-account-id "jxue@fortinet.com"
0: end
0: config log fortiguard setting
0: set status enable
0: end
FortiGate-201E # diagnose test application forticldd 1
System=FGT Platform=FG201E
Management vdom: root, id=0, ha=master.
acct_id=jxue@fortinet.com
acct_st=OK
FortiGuard log: status=enabled, full=overwrite, ssl_opt=1, source-ip=0.0.0.0
Centra Management: type=FGD, flags=000000bf.
active-tasks=0

The FortiGate Cloud server checks that the FortiGate key is valid and then deploys the FortiGate to FortiGate
Cloud.
To prevent spoofing, FortiGate Cloud invalidates that key after a successful join.
6. Complete zero touch provisioning by obtaining configuration from platform template in the Cloud.
0:
set admintimeout 50
0: end
0: config system interface
0:
edit "wan1"
0:
set allowaccess ping ssh fgfm
0:
next
0:
edit "port1"
0:
set allowaccess ping
0:
set ip 1.1.1.1 255.255.255.0
0:
next
0:
edit "port2"
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0:
set allowaccess ping
0:
set ip 2.2.2.2 255.255.255.0
0:
next
0: end

7. The FortiGate Cloud admin can change the template for different configuration requirements and then deploy the
updated template to the FortiGate.
For example, you can add a secondary DNS to the template and deploy it to FortiGate.

Zero touch provisioning with FortiManager
You can use this feature only when the FortiGate boots up from factory reset. This feature is for FortiGate devices that
cannot access the Internet.
A DHCP server includes option 240 and 241 which records FortiManager IP and domain name. FortiGate has an
interface with the default DHCP client mode that is connected to the DHCP server in the intranet.
The FortiManager admin can authorize the FortiGate the specific ADOMs and install specific configurations on the
FortiGate.
In the whole operation, you do not need to do any manual configuration on the FortiGate except connect to the DHCP
server. This is called zero touch deployment.
To prevent spoofing, if a different FortiManager IP comes from the DHCP server later, FortiGate does not change the
central management configuration.

Example of configuring DHCP server with option 240
config system dhcp server
edit 2
set dns-service default
set default-gateway 172.16.200.254
set netmask 255.255.255.0
set interface "wan1"
config ip-range
edit 2
set start-ip 172.16.200.201
set end-ip 172.16.200.209
next
end
set timezone-option default
config options
edit 1
set code 240
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set type ip
set ip "172.18.60.115"
next
end
next
end

FortiGate zero touch provisioning workflow
1. Boot the FortiGate in factory reset.
G201E4Q17901047 # diagnose fdsm fmg-auto-discovery-status
dhcp: fmg-ip=0.0.0.0, fmg-domain-name='', config-touched=0

config-touched=0 means no configuration change from the default.
2. When FortiGate boots in factory reset, it gets the DHCP lease including IP, gateway, DNS, and the FortiManager
IP/URL. Central management is automatically configured by using FortiManager IP in option 240.
FG201E4Q17901047 # show system central-management
config system central-management
set type fortimanager
set fmg "172.18.60.115"
end

3. If FortiGate changes from factory reset, you can see it in central management in config-touched=1.
FG201E4Q17901047 # diagnose fdsm fmg-auto-discovery-status
dhcp: fmg-ip=172.18.60.115, fmg-domain-name='', config-touched=1(/bin/dhcpcd)

Example of a spoofing DHCP server with a fake FortiManager IP
config options
edit 1
set code 240
set type ip
set ip "172.18.60.117"
end

After FortiGate reboots and gets DHCP renew, central management will not use the fake FortiManager IP because
config-touched=1 shows that the FortiGate is not in factory reset.
FG201E4Q17901047 # diagnose fdsm fmg-auto-discovery-status
dhcp: fmg-ip=0.0.0.0, fmg-domain-name='', config-touched=1(/bin/dhcpcd)
FG201E4Q17901047 # show system central-management
config system central-management
set type fortimanager
set fmg "172.18.60.115"
end
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FortiOS dashboards can have a Network Operations Center (NOC) or responsive layout.
l

l

On a responsive dashboard, the number of columns is determined by the size of the screen. Widgets can only be
resized horizontally, but the dashboard will fit on all screen sizes.
On a NOC dashboard, the number of columns is explicitly set. Widgets can be resized both vertically and
horizontally, but the dashboard will look best on the screen size that it is configured for.

Multiple dashboards of both types can be created, for both individual VDOMs and globally. Widgets are interactive;
clicking or hovering over most widgets shows additional information or links to relevant pages. Widgets can be
reorganized by clicking and dragging them around the screen.
Four dashboards are available by default: Status, Top Usage LAN/DMZ, Security, and System Events.
The Status dashboard includes the following widgets by default:

Widget

Description

System Information

The System Information widget lists information relevant to the FortiGate system,
including hostname, serial number, and firmware.
Clicking in the widget provides links to configure system settings and update the device
firmware.

Licenses

The Licenses widget lists the status of various licenses, such as FortiCare Support and
IPS. The number of used and available FortiTokens is also shown.
Clicking in the widget provides a link to the FortiGuard settings page.

Virtual Machine

The VM widget (shown by default in the dashboard of a FortiOS VM device) includes:
l License status and type
l vCPU allocation and usage
l RAM allocation and usage
l VMX license information (if the VM supports VMX)
Clicking on an item in the widget provides a link to the FortiGate VM License page, where
license files can be uploaded.

FortiGate Cloud

This widget displays the FortiGate Cloud and FortiSandbox Cloud status.
See FortiGate Cloud on page 90 for more information.

Security Fabric

The Security Fabric widget displays a visual summary of the devices in the Fortinet
Security Fabric.
Clicking on a product icon provides a link to a page relevancy to that product. For
example, clicking the FortiAnalyzer shows a link to log settings.
See Security Fabric status on page 87 for more information.

Security Rating

The Security Rating widget shows the security rating for your Security Fabric. It can show
the current rating percentile, or historical security rating score or percentile charts.
See Security Rating on page 88 for more information.
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Widget

Description

Administrators

This widget allows you to see logged in administrators, connected administrators, and the
protocols used by each
Clicking in the widget provides links to view active administrator sessions, and to open the
FortiExplorer page on the App Store.

CPU

This widget shows real-time CPU usage over the selected time frame. Hovering over any
point on the graph displays the percentage of CPU power used at that specific time.
It can be expanded to occupy the entire dashboard.

Memory

This widget shows real-time memory usage over the selected time frame. Hovering over
any point on the graph displays the percentage of the memory used at that specific time.
It can be expanded to occupy the entire dashboard.

Sessions

This widget shows the current number of sessions over the selected time frame. Hovering
over any point on the graph displays the number of sessions at that specific time.
It can be expanded to occupy the entire dashboard.

The Top Usage LAN/DMZ dashboard includes the following widgets by default:

Widget

Description

Top Sources by Bytes

This widget lists the top sources by the number of bytes used.

Top Destinations by
Sessions

This widget lists the top destinations by the number of sessions.

Top Applications by
Bytes

This widget lists the top applications by the number of bytes used.

Top Web Site by
Sessions

This widget lists the top websites by the number of sessions.

The Security dashboard includes the following widgets by default:

Widget

Description

Top Compromised
Hosts by Verdict

This widgets lists the compromised hosts by verdict. A FortiAnalyzer is required.

Top Threats by Threat
Level

This widget lists the top threats by threat leve,l from FortiView.

FortiClient Detected
Vulnerabilities

This widget shows the number of vulnerabilities detected by FortiClient. FortiClient must
be enabled.

It can be expanded to occupy the entire dashboard.

It can be expanded to occupy the entire dashboard.

Clicking in the widget provides a link to view the information in FortiView.
Host Scan Summary

This widget lists the total number of hosts.
Clicking in the widget provides links to view vulnerable device in FortiView, FortiClient
monitor, and the device inventory.
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Widget

Description

Top Vulnerable
Endpoint Devices by
Detected
Vulnerabilities

This widget lists the top vulnerable endpoints by the detected vulnerabilities, from
FortiView.
It can be expanded to occupy the entire dashboard.

The System Events dashboard includes the following widgets by default:

Widget

Description

Top System Events by
Events

This widgets lists the top system events, sorted by the number of events.

Top System Events by
Level

This widget lists the top system events, sorted by the events' levels.

It can be expanded to occupy the entire dashboard. Double click on an event to view the
specific event log.

It can be expanded to occupy the entire dashboard. Double click on an event to view the
specific event log.

The following optional widgets can also be added to a dashboard:

Widget

Description

FortiView Top N

This widget shows the top items from the selected FortiView category. The widget's title,
time period, visualization (table or bubble chart), and what the data is sorted by can all be
customized.

Botnet Activity

This widget shows information about botnet activity.
Clicking in the widget provides links to check botnet activity, view FortiGuard package
information, view IPS logs, and view DNS query logs.

HA Status

This widget shows the HA mode of the device.
Clicking in the widget provides a link to HA settings.

Disk Usage

This widget shows real-time disk usage over the selected time frame. Hovering over any
point on the graph displays the percentage of the disk used at that specific time.
It can be expanded to occupy the entire dashboard.

Log Rate

This widget shows the real-time log rate over the selected time frame. Hovering over any
point on the graph displays the log rate at that specific time.
Clicking in the widget provides a link to log settings.
It can be expanded to occupy the entire dashboard.

Session Rate

This widget shows the real-time session rate over the selected time frame. Hovering over
any point on the graph displays the session rate at that specific time.
It can be expanded to occupy the entire dashboard.

Fabric Device

This widget shows statistics and system information about the selected fabric device.
See Fabric Device on page 89 for more information.

Advanced Threat
Protection Statistics
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Widget

Description

Interface Bandwidth

This widget shows the real-time incoming and outgoing traffic bandwidth of the selected
interface over the selected time frame. Hovering over any point on the graph displays the
bandwidth at that specific time.
Clicking and dragging over a porting of the graph provides a link to view the data from the
highlighted time frame in FortiView.

Dashboard CLI
Dashboards and widgets can be managed using the CLI. The options available when creating a widget will vary
depending on the widget type.

To create a dashboard:
config system admin
edit <admin name>
config gui-dashboard
edit <dashboard number>
set name <name>
set vdom <vdom>
set layout-type {responsive | fixed}
set permanent {enable | disable}
next
end
next
end

To add a widget to a dashboard:
config system admin
edit <admin name>
config gui-dashboard
edit <dashboard number>
config widget
edit <widget number>
set type <widget type>
set x-pos <0 - 1000>
set y-pos <0 - 1000>
set width <1 - 50>
set height <1 - 50>
...
next
end
next
end
next
end

The widget type can be one of the following:
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CLI type

GUI name

sysinfo

System Information

licinfo

License Information

vminfo

Virtual machine information

forticloud

FortiGate Cloud Licenses

cpu-usage

CPU Usage

memory-usage

Memory Usage

disk-usage

Disk Usage

log-rate

Session Rate

sessions

Sessions

session-rate

Session Rate

tr-history

Traffic History

analytics

FortiGuard Analytics

usb-modem

USB Modem

admins

Administrators

security-fabric

Security Fabric

security-fabric-ranking

Security Fabric Ranking

ha-status

HA Status

vulnerability-summary

Vulnerability Summary

host-scan-summary

Host Scan Summary

fortiview

FortiView

botnet-activity

Botnet Activity

fabric-device

Fabric Device

Configuration backups
Once you successfully configure the FortiGate, it is extremely important that you backup the configuration. In some
cases, you may need to reset the FortiGate to factory defaults or perform a TFTP upload of the firmware, which will erase
the existing configuration. In these instances, the configuration on the device will have to be recreated, unless a backup
can be used to restore it. You should also backup the local certificates, as the unique SSL inspection CA and server
certificates that are generated by your FortiGate by default are not saved in a system backup.
We also recommend that you backup the configuration after any changes are made, to ensure you have the most current
configuration available. Also, backup the configuration before any upgrades of the FortiGate’s firmware. Should anything
happen to the configuration during the upgrade, you can easily restore the saved configuration.
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Always backup the configuration and store it on the management computer or off-site. You have the option to save the
configuration file to various locations including the local PC, USB key, FTP, and TFTP server. The last two are
configurable through the CLI only.
If you have VDOMs, you can back up the configuration of the entire FortiGate or only a specific VDOM. Note that if you
are using FortiManager or FortiGate Cloud, full backups are performed and the option to backup individual VDOMs will
not appear.
You can also backup and restore your configuration using Secure File Copy (SCP). See How
to download/upload a FortiGate configuration file using secure file copy (SCP).
You enable SCP support using the following command:
config system global
set admin-scp enable
end

For more information about this command and about SCP support, see config system global.

Backing up the configuration
To backup the configuration using the GUI:
1. Click on the user name in the upper right-hand corner of the screen and select Configuration > Backup.
2. Direct the backup to your Local PC or to a USB Disk.
The USB Disk option will not be available if no USB drive is inserted in the USB port. You can also backup to the
FortiManager using the CLI.
3. If VDOMs are enabled, indicate whether the scope of the backup is the entire FortiGate configuration (Global) or
only a specific VDOM configuration (VDOM).
If backing up a VDOM configuration, select the VDOM name from the list.
4.
5.
6.
7.

Enable Encryption. Encryption must be enabled on the backup file to back up VPN certificates.
Enter a password, and enter it again to confirm it. This password will be required to restore the configuration.
Click OK.
When prompted, select a location on the PC or USB disk to save the configuration file. The configuration file will
have a .conf extension.

To backup the configuration using the CLI:
Use one of the following commands:
execute backup config management-station <comment>

or:
execute backup config usb <backup_filename> [<backup_password>]

or for FTP, note that port number, username are optional depending on the FTP site:
execute backup config ftp <backup_filename> <ftp_server> [<port>] [<user_name>]
[<password>]

or for TFTP:
execute backup config tftp <backup_filename> <tftp_servers> <password>

Use the same commands to backup a VDOM configuration by first entering the commands:
config vdom
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edit <vdom_name>

Restoring a configuration
To restore the FortiGate configuration using the GUI:
1. Click on the user name in the upper right-hand corner of the screen and select Configuration > Restore.
2. Identify the source of the configuration file to be restored: your Local PC or a USB Disk.
The USB Disk option will not be available if no USB drive is inserted in the USB port. You can restore from the
FortiManager using the CLI.
3. Click Upload, locate the configuration file, and click Open.
4. Enter the password if required.
5. Click OK.

To restore the FortiGate configuration using the CLI:
execute restore config management-station normal 0

or:
execute restore config usb <filename> [<password>]

or for FTP, note that port number, username are optional depending on the FTP site:
execute restore config ftp <backup_filename> <ftp_server> [<port>] [<user_name>]
[<password>]

or for TFTP:
execute restore config tftp <backup_filename> <tftp_server> <password>

The FortiGate will load the configuration file and restart. Once the restart has completed, verify that the configuration has
been restored.

Troubleshooting
When restoring a configuration, errors may occur, but the solutions are usually straightforward.

Error message

Reason and Solution

Configuration file error

This error occurs when attempting to upload a configuration file that is
incompatible with the device. This may be due to the configuration file being for a
different model or being saved from a different version of firmware.
Solution: Upload a configuration file that is for the correct model of FortiGate
device and the correct version of the firmware.

Invalid password

When the configuration file is saved, it can be protected by a password. The
password entered during the upload process is not matching the one associated
with the configuration file.
Solution: Use the correct password if the file is password protected.
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Configuration revision
You can manage multiple versions of configuration files on models that have a 512MB flash memory and higher.
Revision control requires either a configured central management server or the local hard drive, if your FortiGate has this
feature. Typically, configuration backup to local drive is not available on lower-end models.
The central management server can either be a FortiManager unit or FortiGate Cloud.
If central management is not configured on your FortiGate unit, a message appears instructing you to either
l
l

Enable central management, or
Obtain a valid license.

When revision control is enabled on your FortiGate unit, and configuration backups have been made, a list of saved
revisions of those backed-up configurations appears.
Configuration revisions are viewed by clicking on the user name in the upper right-hand corner of the screen and
selecting Configuration > Revisions.

Backup and restore the local certificates
This procedure exports a server (local) certificate and private key together as a password protected PKCS12 file. The
export file is created through a customer-supplied TFTP server. Ensure that your TFTP server is running and accessible
to the FortiGate before you enter the command.

To back up the local certificates:
Connect to the CLI and use the following command:
execute vpn certificate local export tftp <cert_name> <filename> <tftp_ip>

where:
l
l
l

<cert_name> is the name of the server certificate.
<filename> is a name for the output file.
<tftp_ip> is the IP address assigned to the TFTP server host interface.

To restore the local certificates using the GUI:
1.
2.
3.
4.
5.
6.
7.

Move the output file from the TFTP server location to the management computer.
Go to System > Certificates and click Import > Local.
Select the certificate type, then click Upload in the Certificate file field.
On the management computer, browse to the file location, select it, and click Open.
If the Type is Certificate, upload the Key file as well.
If required, enter the Password that is required to upload the file or files.
Click OK.

To restore the local certificates using the CLI:
Connect to the CLI and use the following command:
execute vpn certificate local import tftp <filename> <tftp_ip>
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Restore factory defaults
There may be a need to reset the FortiGate to its original defaults; for example, to begin with a fresh configuration. There
are two options when restoring factory defaults. The first resets the entire device to the original out-of-the-box
configuration.
You can reset the device with the following CLI command:
execute factoryreset

When prompted, type y to confirm the reset.
Alternatively, in the CLI you can reset the factory defaults but retain the interface and VDOM configuration with the
following command:
execute factoryreset2
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The Fortinet Security Fabric provides an intelligent architecture that interconnects discrete security solutions into an
integrated whole to detect, monitor, block, and remediate attacks across the entire attack surface. It delivers broad
protection and visibility into every network segment and device, be they hardware, virtual, or cloud based.
l

l

l

l

The physical topology view shows all connected devices, including access layer devices. The logical topology view
shows information about the interfaces that each device is connected to.
Security rating checks analyze the Security Fabric deployment to identify potential vulnerabilities and highlight best
practices to improve the network configuration, deploy new hardware and software, and increase visibility and
control of the network.
Automation pairs an event trigger with one or more actions to monitor the network and take the designated actions
automatically when the Security Fabric detects a threat.
Fabric connectors provide integration with multiple SDN, cloud, and partner technology platforms to automate the
process of managing dynamic security updates without manual intervention.

Components
The Fortinet Security Fabric consists of different components that work together to secure you network.
The following devices are required to create a Security Fabric:

Device

Description

FortiGate

FortiGate devices are the core of the Security Fabric and can have one of the following roles:
l Root:
The root FortiGate is the main component in the Security Fabric. It is typically located on
the edge of the network and connects the internal devices and networks to the Internet
through your ISP. From the root FortiGate, you can see information about the entire
Security Fabric on the Physical and Logical Topology pages in the GUI.
l

Downstream:
After a root FortiGate is installed, all other FortiGate devices in the Security Fabric act as
Internal Segmentation Firewalls (ISFWs), located at strategic points in your internal
network, rather than on the network edge. This allows extra security measures to be
taken around key network components, such as servers that contain valuable intellectual
property. ISFW FortiGate devices create network visibility by sending traffic and
information about the devices that are connected to them to the root FortiGate.

See FortiGate on page 67 for more information about adding FortiGate devices in the Security
Fabric.
FortiGate documentation: https://docs.fortinet.com/product/fortigate
FortiAnalyzer
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Device

Description
See FortiAnalyzer on page 72 for more information about adding FortiAnalyzer devices in the
Security Fabric.
FortiAnalyzer documentation: https://docs.fortinet.com/product/fortianalyzer

The following devices are recommended:

Device

Description

FortiADC

FortiADC devices optimize the availability, user experience, and scalability of enterprise
application delivery. They enable fast, secure, and intelligent acceleration and distribution of
even the most demanding enterprise applications.
See Additional devices on page 77 for more information about adding FortiADC devices in the
Security Fabric.
FortiADC documentation: https://docs.fortinet.com/product/fortiadc

FortiAP

Add FortiAP devices to extend the Security Fabric to your wireless devices. Devices
connected to a FortiAP appear in the Physical and Logical Topology pages in the Security
Fabric menu.
See FortiAP and FortiSwitch on page 77 for more information about adding FortiAP devices in
the Security Fabric.
FortiAP documentation: https://docs.fortinet.com/product/fortiap

FortiClient

FortiClient adds endpoint control to devices that are located in the Security Fabric, allowing
only traffic from compliant devices to flow through the FortiGate. FortiClient compliance
profiles are applied by the first FortiGate that a device’s traffic flows through. Device
registration and on-net status information for a device that is running FortiClient appears only
on the FortiGate that applies the FortiClient profile to that device.
FortiClient documentation: https://docs.fortinet.com/product/forticlient

FortiClient EMS

FortiClient EMS is used in the Security Fabric to provide visibility across your network,
securely share information, and assign security profiles to endpoints.
See FortiClient EMS on page 76 for more information about adding FortiClient EMS devices in
the Security Fabric.
FortiClient EMS documentation: https://docs.fortinet.com/product/forticlient

FortiDDoS

FortiDDoS is a Network Behavior Anomaly (NBA) prevention system that detects and blocks
attacks that intend to disrupt network service by overutilizing server resources.
See Additional devices on page 77 for more information about adding FortiDDoS devices in
the Security Fabric.
FortiDDoS documentation: https://docs.fortinet.com/product/fortiddos

FortiMail

FortiMail antispam processing helps offload from other devices in the Security Fabric that
would typically carry out this process.
See Additional devices on page 77 for more information about adding FortiMail devices in the
Security Fabric.
FortiMail documentation: https://docs.fortinet.com/product/fortimail
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Device

Description

FortiManager

Add FortiManager to simplify the network management of devices in the Security Fabric by
centralizing management access in a single device. This allows you to easily control the
deployment of security policies, FortiGuard content security updates, firmware revisions, and
individual configurations for devices in the Security Fabric.
See FortiManager on page 75 for more information about adding FortiManager devices in the
Security Fabric.
FortiManager documentation: https://docs.fortinet.com/product/fortimanager

FortiSandbox

Add FortiSandbox to your Security Fabric to improve security with sandbox inspection.
Sandbox integration allows FortiGate devices in the Security Fabric to automatically receive
signature updates from FortiSandbox and add the originating URL of any malicious file to a
blocked URL list.
See FortiSandbox on page 73 for more information about adding FortiSandbox devices in the
Security Fabric.
FortiSandbox documentation: https://docs.fortinet.com/product/fortisandbox

FortiSwitch

A FortiSwitch can be added to the Security Fabric when it is managed by a FortiGate that is in
the Security Fabric with the FortiLink protocol, and connected to an interface that uses
FortiTelemetry. FortiSwitch ports to become logical extensions of the FortiGate.
Devices connected to the FortiSwitch appear in the Physical and Logical Topology pages in
the Security Fabric menu, and security features, such as FortiClient compliance profiles, are
applied to them.
See FortiAP and FortiSwitch on page 77 for more information about adding FortiSwitch
devices in the Security Fabric.
FortiSwitch documentation: https://docs.fortinet.com/product/fortiswitch

FortiWeb

Add FortiWeb to defend the application attack surface from attacks that target application
exploits. You can also configure FortiWeb to apply web application firewall features, virus
scanning, and web filtering to HTTP traffic to help offload from other devices in the Security
Fabric that would typically carry out these processes.
See Additional devices on page 77 for more information about adding FortiWeb devices in the
Security Fabric.
FortiWeb documentation: https://docs.fortinet.com/product/fortiweb

FortiWLC

FortiWLC delivers seamless mobility and superior reliability with optimized client distribution
and channel utilization. Both single and multi channel deployment options are supported,
maximizing efficiency to make the most of available wireless spectrum.
See Additional devices on page 77 for more information about adding FortiWLC devices in the
Security Fabric.
FortiWLC documentation: https://docs.fortinet.com/product/wireless-controller

The following devices are optional:

Device

Description

Other Fortinet
products

Many other Fortinet products can be added to the Security Fabric, including
FortiAuthenticator, FortiToken, FortiCache, and FortiSIEM.
Documentation: https://docs.fortinet.com/
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Device

Description

Third-party
products

Third-party products that belong to the Fortinet Fabric-Ready Partner Program can be added
to the Security Fabric.

Security Fabric device configuration
This section contains information about how to configure the following devices as part of the Fortinet Security Fabric:
l
l
l
l
l
l
l

FortiGate
FortiAnalyzer
FortiManager
FortiSandbox
FortiClient EMS
FortiAP and FortiSwitch
Additional devices

System requirements
To set up the Security Fabric, the devices that you want to include must meet the Product Integration and Support
requirements in the FortiOS Release Notes.
Some features of the Security Fabric are only available in certain firmware versions and models. Not all FortiGate
models can run the FortiGuard Security Rating Service if they are the root FortiGate in a Security Fabric. For more
information, see the Special Notices in the FortiOS Release Notes.

Prerequisites
l

l

l

If devices are not already installed in your network, complete basic installation and configuration tasks by following
the instructions in the device documentation.
Either disable VDOMs on all FortiGate devices that you want to add to the Security Fabric or make sure devices are
in split-task VDOM mode. See Virtual Domains on page 489.
Configure all FortiGate devices to operate in NAT mode.

FortiGate
The following procedures include configuration steps for a typical Security Fabric implementation, where the edge
FortiGate is the root FortiGate, and the downstream FortiGate devices are all devices that are downstream from the root
FortiGate.

Configure the root FortiGate
The edge FortiGate is typically configured as the root FortiGate, as this allows you to view the full topology of the
Security Fabric from the top down.
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To configure the root FortiGate:
1. Connect to the root FortiGate and go to Security Fabric > Settings.
2. Enable FortiGate Telemetry.
FortiAnalyzer Logging is automatically enabled.

3. Enter the Group name and select the FortiTelemetry enabled interfaces.
4. In the FortiAnalyzer Logging section, in the IP address field, enter the IP address of the FortiAnalyzer.
If you select Test Connectivity and this is the first time that you are connecting the FortiGate to the FortiAnalyzer,
you will receive a warning message because the FortiGate has not yet been authorized on the FortiAnalyzer. You
can configure this authorization when you configure the FortiAnalyzer. See FortiAnalyzer on page 72.
5. If you need log transmissions to be encrypted, enable SSL encrypt log transmission.
6. If required, enable Allow access to FortiGate REST API and, optionally, Trust FortiAnalyzer by serial number.
The FortiGate will verify the FortiAnalyzer by retrieving its serial number and checking it against the FortiAnalyzer
certificate. The FortiAnalyzer serial number is stored in the FortiGate configuration. When authorizing the FortiGate
on the FortiAnalyzer, the FortiGate admin credentials do not need to be entered. For more information, see Simplify
FortiAnalyzer Pairing, in the FortiOS 6.2.0 New Features Guide.
7. Click Apply.

Add downstream devices
Downstream FortiGate devices can be securely added to the Security Fabric without sharing the password of the root
FortiGate. Downstream device serial numbers can be authorized from the root FortiGate, or allowed to join by request.
New authorization requests include the device serial number, IP address, and HA members. HA members can include
up to four serial numbers and is used to ensure that, in the event of a fail over, the secondary FortiGate is still authorized.

Pre-authorizing the downstream FortiGate
When a downstream Fortinet device's serial number is added to the trusted list on the root FortiGate, the device can join
the Security Fabric as soon as it connects. After the new device is authorized, connected FortiAP and FortiSwitch
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devices are automatically included in the topology, where they can be authorized with one click.

To pre-authorize a FortiGate:
1. On the root FortiGate, go to Security Fabric > Settings.
2. Ensure that the interface that connects to the downstream FortiGate has FortiTelemetry enabled.
3. In the Pre-authorized FortiGates, select Edit. Add a new FortiGate to the list using the downstream device's serial
number.

4. On the downstream FortiGate, go to Security Fabric > Settings.
5. Enable FortiGate Telemetry.
6. Enable Connect to upstream FortiGate.
7. Enter the IP address of the upstream or root FortiGate in the FortiGate IP field.
8. Add the FortiTelemetry enabled interfaces.
9. Click Apply.
10. On the root FortiGate, go to Security Fabric > Settings and verify that the downstream FortiGate that you added
appears in the Security Fabric topology.
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Using LLDP
You can automatically prompt downstream FortiGate devices to join the Security Fabric using Link Layer Discovery
Protocol (LLDP) and interface role assignments.
1. On the root FortiGate, assign the LAN role to all interfaces that may connect to downstream FortiGate devices.
When the LAN role is assigned to an interface, LLDP transmission is enabled by default.
2. When a downstream FortiGate is installed, assign the WAN role to the interface that connects to the upstream
FortiGate.
When the WAN role is assigned, LLDP reception is enabled by default. The newly installed FortiGate uses LLDP to
discover the upstream FortiGate, and the administrator is prompted to configure the FortiGate to join the Security
Fabric.
3. On the root FortiGate, the new FortiGate must be authorized before it can join the Security Fabric.

If the network contains switches or routers, LLDP may not function as expected because some
devices do not pass LLDP packets.

Device request
A device can request to join the Security Fabric from another FortiGate, but it must have the IP address of the root
FortiGate. The administrator of the root FortiGate must also authorize the device before it can join the Security Fabric.
The root FortiGate must have FortiTelemetry enabled on the interface that the device connects to.

To enable FortiTelemetry on an interface:
1.
2.
3.
4.

Go to Network > Interfaces.
Edit the interface that the device that you authorizing to join the Security Fabric is connected to.
Under Administrative Access, enable FortiTelemetry.
Under Networked Devices, turn on Device Detection.

To join the Security Fabric by device request:
1.
2.
3.
4.
5.

Connect to the unauthorized FortiGate or FortiWiFi device, and go to Security Fabric > Settings.
Enable FortiGate Telemetry.
To connect, enable Connect to upstream FortiGate.
Set FortiGate IP to the IP address of the upstream FortiGate.
Connect to the root FortiGate and go to Security Fabric > Settings. The new FortiGate appears in the Topology as
unauthorized.
6. Click on the unauthorized device and select Authorize to authorize the device.

CLI commands
Use the following commands to view, accept, and deny authorization requests, to view upstream and downstream
devices, and to list or test fabric devices:
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Command

Description

diagnose sys csf authorization
pending-list

View pending authorization requests on the root FortiGate.

diagnose sys csf authorization
accept <serial-number-value>

Authorize a device to join the Security Fabric.

diagnose sys csf authorization
deny <serial-number-value>

Deny a device from joining the Security Fabric.

diagnose sys csf downstream

Show connected downstream devices.

diagnose sys csf upstream

Show connected upstream devices.

diagnose sys csf fabric-device list

List all known fabric devices.

diagnose sys csf fabric-device
test

Test connections to locally configured fabric devices.

Desynchronizing settings
By default, the settings for FortiAnalyzer logging, central management, sandbox inspection, and FortiClient EMS are
synchronized between all FortiGate devices in the Security Fabric. To disable the automatic synchronization of these
settings, use the following CLI command:
config system csf
set configuration-sync local
end

Deauthorizing a device
A device can be deauthorized to remove it from the Security Fabric.

To deauthorize a device:
1. On the root FortiGate, go to Security Fabric > Settings
2. In the Topology field, click on the device and select Deauthorize.
3. Click on the device.
After devices are deauthorized, the devices' serial numbers are saved in a trusted list that can be viewed in the CLI using
the show system csf command. For example, this result shows a deauthorized FortiSwitch:
show system csf
config system csf
set status enable
set group-name "Office-Security-Fabric"
set group-password ENC 1Z2X345V678
config trusted-list
edit "FGT6HD391806070"
next
edit "S248DF3X17000482"
set action deny
next
end
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end
end

FortiAnalyzer
FortiAnalyzer is a required component for the Security Fabric. It allows the Security Fabric to show historical data for the
Security Fabric topology and logs for the entire Security Fabric.
For more information about using FortiAnalyzer, see the FortiAnalyzer Administration Guide.

To connect a FortiAnalyzer to the Security Fabric:
1.
2.
3.
4.

Enable FortiAnalyzer Logging on the root FortiGate. See Configure the root FortiGate on page 67.
On the FortiAnalyzer, go to System Settings > Network and click All Interfaces.
Edit the port that connects to the root FortiGate.
Set the IP Address/Netmask to the IP address that is used for the Security Fabric on the root FortiGate.

5. Click OK.
If the FortiGates have already been configured, it will now be listed as an unauthorized device.
6. Go to Device Manager > Devices Unauthorized. The unauthorized FortiGate devices are listed.

7. Select the root FortiGate and downstream FortiGate devices in the list, then click Authorize. The Authorize Device
page opens.
8. Click OK to authorize the selected devices.

On the FortiGate devices, the FortiAnalyzer Logging section on the Security Fabric > Settings page will now show
the ADOM on the FortiAnalyzer that the FortiGate is in, and the storage, analytics, and archive usage.
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FortiSandbox
The Security Fabric supports FortiSandbox appliances and FortiSandbox Cloud. A FortiGate Cloud account is not
required (see Decouple FortiSandbox Cloud from FortiGate Cloud, in the FortiOS 6.2.0 New Features Guide).
To use FortiSandbox in a Security Fabric, connect the FortiSandbox to the Security Fabric, then configure an antivirus
profile to send files to the FortiSandbox. Sandbox inspection can also be used in Web Filter profiles.
FortiSandbox settings are configured on the root FortiGate of the Security Fabric. After configuration, the root FortiGate
pushes the settings to other FortiGate devices in the Security Fabric.

To add a FortiSandbox appliance to the Security Fabric:
1. On the root FortiGate, go to Security Fabric > Settings.
2. Enable Sandbox Inspection and set the FortiSandbox Type to FortiSandbox Appliance.
3. In the Server field, enter the FortiSandbox device's IP address.

4. Optionally, enter a Notifier email.
5. Click Apply.
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6.
7.
8.
9.
10.

On the FortiSandbox appliance, go to Scan Input > Device.
Edit the root FortiGate.
Under Permissions, check the Authorized box.
Click OK.
Authorize the rest of the FortiGate devices that are in the Security Fabric.

To add a FortiSandbox cloud instance to the Security Fabric:
1. On the root FortiGate, go to Security Fabric > Settings.
2. Enable Sandbox Inspection and set the FortiSandbox Type to FortiSandbox Cloud.
3. Select the FortiSandbox cloud region from the drop-down list. Data from your network will only be sent to servers in
the selected region.
4. Click Apply.

Antivirus profiles
An antivirus profile must be configured to send files to the FortiSandbox.

To configure an antivirus profile:
1. On the FortiGate, go to Security Profile > AntiVirus.
2. Create, edit, or clone an antivirus profile.

3.
4.
5.
6.

Under APT Protection Options, set Send Files to FortiSandbox Appliance for Inspection to All Supported Files.
Optionally, configure file exceptions.
Enable Use FortiSandbox Database.
Click OK.

Web Filter profiles
Sandbox inspection can be used in Web Filter profiles.
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To configure a Web Filter profile:
1.
2.
3.
4.

On the FortiGate, go to Security Profiles > Web Filter.
Create, edit, or clone a profile.
Under Static URL Filter, enable Block malicious URLs discovered by FortiSandbox.
Click OK.

FortiManager
When a FortiManager device is added to the Security Fabric, it automatically synchronizes with any connected
downstream devices.
To add a FortiManager to the Security Fabric, configure central management on the root FortiGate. The root FortiGate
then pushes this configuration to downstream FortiGate devices. The FortiManager provides remote management of
FortiGate devices over TCP port 541. The FortiManager must have internet access for it to join the Security Fabric.
Once configured, the FortiGate can receive antivirus and IPS updates, and allow remote management through
FortiManager or the FortiGate Cloud service. The FortiGate management option must be enabled so that the FortiGate
can accept management updates to its firmware and FortiGuard services.

To add a FortiManager to the Security Fabric using the CLI:
config system central-management
set type fortimanager
set fmg {<IP_address> | <FQDN_address>}
end

To add a FortiManager to the Security Fabric using the GUI:
1. On the root FortiGate, go to Security Fabric > Settings.
2. Enable Central Management.
3. Set the Type to FortiManager.

4. Enter the IP/Domain Name of the FortiManager.
5. Click Apply.
6. On the FortiManager, go to Device Manager and find the FortiGate in the Unauthorized Devices list.
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7. Select the FortiGate device or devices, and click Authorize in the toolbar.
8. In the Authorize Device pop-up, adjust the device names as needed, then click OK.
For more information about using FortiManager, see the FortiManager Administration Guide.

FortiClient EMS
You can configure endpoint control for your Security Fabric using FortiClient Endpoint Management System (EMS). Up
to three EMS servers can be added on the global Security Fabric settings page. EMS settings are synchronized between
all fabric members.

If you disable FortiClient Endpoint Management System (EMS) on the Security Fabric >
Settings page, all previously configured EMS server entries will be deleted.

To add a FortiClient EMS server to the Security Fabric using the CLI:
config endpoint-control fctems
edit <ems_name>
set server <ip_address>
set serial-number <string>
set admin-username <string>
set admin-password <string>
set https-port <integer>
set source-ip <ip_address>
next
end

The https-port is the EMS HTTPS access port number, and the source-ip is the REST API call source IP address.

To add a FortiClient EMS server to the Security Fabric using the GUI:
1. To enable endpoint control, on the root FortiGate, go to System > Feature Visibility and enable Endpoint Control.
2. Go to Security Fabric > Settings.
3. Enable FortiClient Endpoint Management System (EMS).

4. Enter a Name for the EMS server.
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5.
6.
7.
8.

Enter the IP/Domain Name and Serial Number of the EMS server in their requisite fields.
Enter the Admin User name and Password.
Optionally, click the plus icon to add up to three servers.
Click Apply.

FortiAP and FortiSwitch
FortiAP and FortiSwitch devices can be authorized in the Security Fabric with one click. After connecting a FortiAP or
FortiSwitch device to an authorized FortiGate, it will automatically be listed in the topology tree.

To authorize FortiAP and FortiSwitch devices:
1. Connect the FortiAP or FortiSwitch device to a FortiGate.
2. On the root FortiGate, go to Security Fabric > Settings. The new device will be shown in the Topology.
3. Click on the device and select Authorize.

Additional devices
The following Fortinet devices are supported by the Security Fabric:
l
l
l
l
l

FortiADC
FortiDDoS
FortiMail
FortiWeb
FortiWLC

In FortiOS, the device details can be shown in Security Fabric and Fabric Device dashboard widgets, as well as in the
Security Fabric settings, and physical and logical topologies.

To add one or more of the devices to the Security Fabric in the GUI:
1.
2.
3.
4.

On the root FortiGate, go to Security Fabric > Settings.
Enable Fabric Devices.
Enter the Name, IP, HTTPS port for the device.
Click Generate to generate an access token. The Generate Access Token pane opens.
a. Enter the device's username and password.
b. Click OK.
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5. Add more devices as required.

6. Click Apply.
The added devices are shown in the FortiGate Telemetry section Topology list.

To add one or more of the devices to the Security Fabric in the CLI:
config system csf
...
config fabric-device
edit "FortiADC-1"
set device-ip 172.18.64.36
set access-token xxxxxx
next
edit "FML-1"
set device-ip 172.18.64.48
set access-token xxxxxx
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next
edit "FWB-1"
set device-ip 172.18.64.49
set access-token xxxxxx
next
end
end

Deploying Security Fabric
This recipe provides an example of deploying Security Fabric with three downstream FortiGates connecting to one root
FortiGate. To deploy Security Fabric, you need a FortiAnalyzer running firmware version 6.2 or later.
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The following shows a sample network topology of three downstream FortiGates (Accounting, Marketing, and Sales)
connected to the root FortiGate (Edge).

To configure the root FortiGate (Edge):
1. Configure interface:
a. In the root FortiGate (Edge), go to Network > Interfaces.
b. Edit port16:
l Set Role to DMZ.
l For the interface connected to FortiAnalyzer, set the IP/Network Mask to 192.168.65.2/255.255.255.0
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c. Edit port10:
l Set Role to LAN.
l For the interface connected to the downstream FortiGate (Accounting), set the IP/Network Mask to
192.168.10.2/255.255.255.0
d. Edit port11:
l Set Role to LAN.
l For the interface connected to the downstream FortiGate (Marketing), set the IP/Network Mask to
192.168.200.2/255.255.255.0
2. Configure Security Fabric:
a. In the root FortiGate (Edge), go to Security Fabric > Settings.
l Enable FortiGate Telemetry.
l Set a Group name, such as Office-Security-Fabric.
l Add port10 and port11 to FortiTelemetry enabled interfaces.
After FortiGate Telemetry is enabled, FortiAnalyzer automatically enables Logging and Upload Option is set to
Real Time.
b. Set IP address to the FortiAnalyzer IP 192.168.65.10.
c. Select Test Connectivity.
A warning message indicates that the FortiGate is not authorized on the FortiAnalyzer. The authorization is
configured in a later step on the FortiAnalyzer.
3. Create a policy to allow the downstream FortiGate (Accounting) to access the FortiAnalyzer:
a. In the root FortiGate (Edge), go to Policy & Objects > Addresses.
l Click Create New.
l Set Name to FAZ-addr.
l Set Type to Subnet.
l Set Subnet/IP Range to 192.168.65.10/32.
l Set Interface to any.
l Click Create New.
l Set Name to Accounting.
l Set Type to Subnet.
l Set Subnet/IP Range to 192.168.10.10/32.
l Set Interface to any.
b. In the root FortiGate (Edge), go to Policy & Objects > IPv4 Policy.
l Set Name to Accounting-to-FAZ.
l Set srcintf to port10.
l Set dstintf to port16.
l Set srcaddr to Accounting-addr.
l Set dstaddr to FAZ-addr.
l Set Action to Accept.
l Set Schedule to Always.
l Set Service to All.
l Enable NAT.
l Set IP Pool Configuration to Use Outgoing Interface Address.
4. Create a policy to allow the two downstream FortiGates (Marketing and Sales) to access the FortiAnalyzer:
a. In the root FortiGate (Edge), go to Policy & Objects > Addresses and click Create New.
l Set Name to Marketing-addr.
l Set Type to Subnet.
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Set Subnet/IP Range to 192.168.200.10/32.
Set Interface to any.
b. In the root FortiGate (Edge), go to Policy & Objects > IPv4 Policy.
l Set Name to Marketing-to-FAZ.
l Set srcintf to port11.
l Set dstintf to port16.
l Set srcaddr to Marketing-addr.
l Set dstaddr to FAZ-addr.
l Set Action to Accept.
l Set Schedule to Always.
l Set Service to All.
l Enable NAT.
l Set IP Pool Configuration to Use Outgoing Interface Address.
l
l

To configure the downstream FortiGate (Accounting):
1. Configure interface:
a. In the downstream FortiGate (Accounting), go to Network > Interfaces.
b. Edit interface wan1:
l Set Role to WAN.
l For the interface connected to root, set the IP/Network Mask to 192.168.10.10/255.255.255.0
2. Configure the default static route to connect to the root FortiGate (Edge):
a. In the downstream FortiGate (Accounting), go to Network > Static Routes:
l Set Destination to 0.0.0.0/0.0.0.0.
l Set Interface to wan1.
l Set Gateway Address to 192.168.10.2.
3. Configure Security Fabric:
a. In the downstream FortiGate (Accounting), go to Security Fabric > Settings.
l Enable FortiGate Telemetry.
l Enable Connect to upstream FortiGate.
l FortiGate IP is filled in automatically with the default static route Gateway Address of 192.168.10.2 set in
the previous step.
l Leave FortiTelemetry enabled interfaces empty since there is no downstream FortiGate connecting to it.
After FortiGate Telemetry is enabled, FortiAnalyzer automatically enables Logging. Settings for the
FortiAnalyzer are retrieved from the root FortiGate (Edge) when FortiGate (Accounting) connects to the root
FortiGate (Edge).

To configure the downstream FortiGate (Marketing):
1. Configure interface:
a. In the downstream FortiGate (Marketing), go to Network > Interfaces.
b. Edit port12:
l Set Role to LAN.
l For the interface connected to the downstream FortiGate (Sales), set the IP/Network Mask to
192.168.135.11/255.255.255.0.
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c. Edit wan1:
l Set Role to WAN.
l For the interface connected to the root FortiGate (Edge), set the IP/Network Mask to
192.168.200.10/255.255.255.0.
2. Configure the default static route to connect to the root FortiGate (Edge):
a. In the downstream FortiGate (Marketing), go to Network > Static Routes:
l Set Destination to 0.0.0.0/0.0.0.0.
l Set Interface to wan1.
l Set Gateway Address to 192.168.200.2.
3. Configure Security Fabric:
a. In the downstream FortiGate (Marketing), go to Security Fabric > Settings.
l Enable FortiGate Telemetry.
l Enable Connect to upstream FortiGate.
l FortiGate IP is filled in automatically with the default static route Gateway Address of 192.168.200.2 set in
the previous step.
l In FortiTelemetry enabled interfaces, add port12.
After FortiGate Telemetry is enabled, FortiAnalyzer automatically enables Logging. Settings for the
FortiAnalyzer are retrieved from the root FortiGate (Edge) when FortiGate (Marketing) connects to the root
FortiGate (Edge).
4. Create a policy to allow another downstream FortiGate (Sales) going through FortiGate (Marketing) to access the
FortiAnalyzer:
a. In the downstream FortiGate (Marketing), go to Policy & Objects > Addresses and click Create New.
l Set Name to FAZ-addr.
l Set Type to Subnet.
l Set Subnet/IP Range to 192.168.65.10/32.
l Set Interface to any.
b. Click Create New.
l Set Name to Sales-addr.
l Set Type to Subnet.
l Set Subnet/IP Range to 192.168.135.10/32.
l Set Interface to any.
c. In the downstream FortiGate (Marketing), go to Policy & Objects > IPv4 Policy.
l Set Name to Sales-to-FAZ.
l Set srcintf to port12.
l Set dstintf to wan1.
l Set srcaddr to Sales-addr.
l Set dstaddr to FAZ-addr.
l Set Action to Accept.
l Set Schedule to Always.
l Set Service to All.
l Enable NAT.
l Set IP Pool Configuration to Use Outgoing Interface Address.
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To configure the downstream FortiGate (Accounting):
1. Configure interface:
a. In the downstream FortiGate (Accounting), go to Network > Interfaces.
b. Edit interface wan1:
l Set Role to WAN.
l For the interface connected to root, set the IP/Network Mask to 192.168.10.10/255.255.255.0
2. Configure the default static route to connect to the root FortiGate (Edge):
a. In the downstream FortiGate (Accounting), go to Network > Static Routes:
l Set Destination to 0.0.0.0/0.0.0.0.
l Set Interface to wan1.
l Set Gateway Address to 192.168.10.2.
3. Configure Security Fabric:
a. In the downstream FortiGate (Accounting), go to Security Fabric > Settings.
l Enable FortiGate Telemetry.
l Enable Connect to upstream FortiGate.
l FortiGate IP is filled in automatically with the default static route Gateway Address of 192.168.10.2 set in
the previous step.
l Leave FortiTelemetry enabled interfaces empty since there is no downstream FortiGate connecting to it.
After FortiGate Telemetry is enabled, FortiAnalyzer automatically enables Logging. Settings for the
FortiAnalyzer are retrieved from the root FortiGate (Edge) when FortiGate (Accounting) connects to the root
FortiGate (Edge).

To configure the downstream FortiGate (Sales):
1. Configure interface:
a. In the downstream FortiGate (Sales), go to Network > Interfaces.
b. Edit wan2:
l Set Role to WAN.
l For the interface connected to the upstream FortiGate (Marketing), set the IP/Network Mask to
192.168.135.10/255.255.255.0.
2. Configure the default static route to connect to the upstream FortiGate (Marketing):
a. In the downstream FortiGate (Sales), go to Network > Static Routes:
l Set Destination to 0.0.0.0/0.0.0.0.
l Set Interface to wan2.
l Set Gateway Address to 192.168.135.11.
3. Configure Security Fabric:
a. In the downstream FortiGate (Sales), go to Security Fabric > Settings.
l Enable FortiGate Telemetry.
l Enable Connect to upstream FortiGate.
l FortiGate IP is filled in automatically with the default static route Gateway Address of 192.168.135.11 set
in the previous step.
l Leave FortiTelemetry enabled interfaces empty since there is no downstream FortiGate connecting to it.
After FortiGate Telemetry is enabled, FortiAnalyzer automatically enables Logging. Settings for the
FortiAnalyzer are retrieved from the root FortiGate (Edge) when FortiGate (Sales) connects to the root
FortiGate (Edge).
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To authorize downstream FortiGates (Accounting, Marketing, and Sales) on the root FortiGate (Edge):
1. In the root FortiGate (Edge), go to Security Fabric > Settings.
The Topology field highlights two connected FortiGates with their serial numbers and asks you to authorize the
highlighted devices.
2. Select the highlighted FortiGates and select Authorize.
After they are authorized, the two downstream FortiGates (Accounting and Marketing) appear in the Topology field
in Security Fabric > Settings. This means the two downstream FortiGates (Accounting and Marketing) have
successfully joined the Security Fabric.
3. The Topology field now highlights the FortiGate with the serial number that is connected to the downstream
FortiGate (Marketing) and asks you to authorize the highlighted device.
4. Select the highlighted FortiGates and select Authorize.
After it is authorized, the downstream FortiGate ( Sales) appears in the Topology field in Security Fabric > Settings.
This means the downstream FortiGates (Sales) has successfully joined the Security Fabric.

To use FortiAnalyzer to authorize all the Security Fabric FortiGates:
1. Authorize all the Security Fabric FortiGates on the FortiAnalyzer side:
a. In the FortiAnalyzer, go to System Settings > Network > All Interfaces.
l Edit port1 and set IP Address/Netmask to 192.168.65.10/255.255.255.0.
b. Go to Device Manager > Unauthorized.
All the FortiGates are listed as unauthorized.
i. Select all the FortiGates and select Authorize.
The FortiGates are now listed as authorized.
After a moment, a warning icon appears beside the root FortiGate (Edge) because the FortiAnalyzer
needs administrative access to the root FortiGate (Edge) in the Security Fabric.
ii. Click the warning icon and enter the admin username and password of the root FortiGate (Edge).
2. Check FortiAnalyzer status on all the Security Fabric FortiGates:
l

On each FortiGates, go to Security Fabric > Settings and check that FortiAnalyzer Logging shows Storage
usage information.
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To check Security Fabric deployment result:
1. On FortiGate (Edge), go to Dashboard > Status.
The Security Fabric widget displays all the FortiGates in the Security Fabric.

2. On FortiGate (Edge), go to Security Fabric > Physical Topology.
This page shows a visualization of access layer devices in the Security Fabric.

3. On FortiGate (Edge), go to Security Fabric > Physical Topology.
This dashboard shows information about the interfaces of each device in the Security Fabric.

To run diagnose commands:
1. Run the diagnose sys csf authorization pending-list command in the root FortiGate to show the
downstream FortiGate pending for root FortiGate authorization:
Edge # diagnose sys csf authorization pending-list
Serial
IP Address
HA-Members
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-----------------------------------------------------------------------------------FG201ETK18902514
0.0.0.0
FG3H1E5818900718:FG201ETK18902514

2. Run the diagnose sys csf downstream command in the root or middle FortiGate to show the downstream
FortiGates after they join Security Fabric:
Edge # diagnose sys csf downstream
1:
FG201ETK18902514 (192.168.200.10) Management-IP: 0.0.0.0 Management-port:0
parent: FG3H1E5818900718
path:FG3H1E5818900718:FG201ETK18902514
data received: Y downstream intf:wan1 upstream intf:port11 admin-port:443
authorizer:FG3H1E5818900718
2:
FGT81ETK18002246 (192.168.10.10) Management-IP: 0.0.0.0 Management-port:0 parent:
FG3H1E5818900718
path:FG3H1E5818900718:FGT81ETK18002246
data received: Y downstream intf:wan1 upstream intf:port10 admin-port:443
authorizer:FG3H1E5818900718
3:
FG101ETK18002187 (192.168.135.10) Management-IP: 0.0.0.0 Management-port:0
parent: FG201ETK18902514
path:FG3H1E5818900718:FG201ETK18902514:FG101ETK18002187
data received: Y downstream intf:wan2 upstream intf:port12 admin-port:443
authorizer:FG3H1E5818900718

3. Run the diagnose sys csf upstream command in any downstream FortiGate to show the upstream FortiGate
after downstream FortiGate joins Security Fabric:
Marketing # diagnose sys csf upstream
Upstream Information:
Serial Number:FG3H1E5818900718
IP:192.168.200.2
Connecting interface:wan1
Connection status:Authorized

Using the Security Fabric
Dashboard widgets
Security Fabric widgets can be added to FortiGate dashboards, including:
l
l
l
l

Security Fabric status on page 87
Security Rating on page 88
Fabric Device on page 89
FortiGate Cloud on page 90

Security Fabric status
The Security Fabric status widget shows a summary of the devices in the Security Fabric.
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Hover the cursor over the top icons to view pop-ups showing the statuses of the devices in the fabric.
The device tree shows devices that are connected, or could be connected, to you Security Fabric, according to the
following color scheme:
l
l
l

Blue: connected to the network
Gray: not configured or not detected
Red: no longer connected or not authorized

Hover over a device in the tree to view details about the device, such as it's serial number, operation mode, IP address,
CPU and memory usage, and others, depending on the device type.
Unauthorized FortiAP and FortiSwitch devices are highlighted in the list, and can be authorized by clicking on the device
name.

Security Rating
The Security Rating widget shows the security rating for your Security Fabric. It can show the current rating percentile, or
historical security rating score or percentile charts.
The widget can be configured to show how your organization's security rating compares to the ratings of either all
organizations, or only organizations that are in the same industry and/or geographic region as you (determined from your
FortiCare account settings).

To switch to the historical security rating score view, select Historical Score from the view dropdown menu. Making the
widget wider makes the graph easier to read.
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To switch to the historical percentile view, select Historical Percentile from the view dropdown menu. Making the widget
wider makes the graph easier to read.

To receive a security rating score, all FortiGate devices that are in the Security Fabric must
have a valid Security Rating License.

Fabric Device
The Fabric Device widget show statistics and system information about the selected fabric device.
For a FortiMail device, the widget can show:
l
l
l
l

Mail Statistics: a chart of the total messages and total spam messages over time.
Statistics Summary: a pie chart summarizes mail statistics.
System Information: The FortiMail System Information widget
System Usage: System usage information, such as CPU, memory, and disk usage, as well as the number of active
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sessions.

FortiGate Cloud
The FortiGate Cloud widget shows the FortiGate Cloud status and information. If your account is not activated, you can
activate it from the widget.

To activate your FortiGate Cloud account:
1. Click on the Not Activated button and select Activate. The FortiCare Registration pane opens.
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2. If you already have a FortinetOne account:
a. Fill in your email address, password, country or region, and reseller.
b. Click OK.
3. If you are creating a FortinetOne account:
a. In the FortinetOne field select Create Account.
b. Fill in all of the required information.
c. Click OK.

Topology
The full Security Fabric topology can be viewed on the root FortiGate. Downstream FortiGate devices' topology views do
not include upstream devices.
The Physical Topology shows the physical structure of your network, including all connected devices and the
connections between them. The Logical Topology shows information about the interfaces that connect devices to the
Security Fabric. The size of the bubbles in the topology vary based on traffic volume. Only Fortinet devices are shown in
the topologies.
In both views, filtering and sorting options allow you to control the information that is shown. Hover the cursor over a
device icon, port number, or endpoint to open a tooltip that shows information about that specific device, port, or
endpoint. Right-click on a device to log in to it or to deauthorize it. Right-click on an endpoint to perform various tasks,
including drilling down for more details on sources or compromised hosts, quarantining the host, and banning the
IP address.
The small number that might be shown on the top right corner of a device icon is the number of security ratings
recommendations or warnings for that device. The color of the circle shows the severity of the highest security rating
check that failed. Clicking on it will open the Security Rating page. See Security rating on page 95 for more information.

Servers and server clusters are represented by squares with rounded corners, and are grouped separately from circular
endpoints. Devices are grouped by device type, and colored based on their risk level.
AWS assets are grouped by AWS security groups or subnets, and information about detected Common Vulnerabilities
and Exposures (CVEs), as well as the instance details and ID, are shown.
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WAN cloud
The WAN cloud icon includes a drop-down menu for selecting where the destination data comes from. The available
options are: Internet, Owner, IP Address, and Country/Region. These options are only available when the filtering based
on Device Traffic.
When Owner is selected, the destination hosts are shown as donut charts that show the percentage of internal (with
private IP addresses) and Internet hosts. Hover over either color in the chart to see additional information. To see more
details, right-click on the chart and select Destination Owner Details to go to the FortiView > Destinations page.

FortiAP and FortiSwitch devices
Newly discovered FortiAP and FortiSwitch devices are initial shown in the topologies with gray icons to indicate that they
have not been authorized. To authorize a device, click on the device icon or name and select Authorize. Once
authorized, the device icon will turn blue.
Right-click on an authorized FortiAP device to Deauthorize or Restart the device. Right-click on a FortiSwitch device to
Deauthorize, Restart, or Upgrade the device, or to Connect to the CLI.
FortiAP and FortiSwitch links are enhanced to show Link Aggregation Groups for the Inter-switch Link (ISL-LAG). To
differentiate them from physical links, ISL-LAG links are shown with a thicker line. The endpoint circles can also be used
as a reference to identify ISL-LAG groups that have more than two links.

Views
The topology views can be focused using filters and by sorting in different ways to help you locate the information that
you need.
Select one of Access Device or No Access Device to only show access or no access devices in the physical topology.
From the Bubble Option drop-down list, select one of the following views:
l
l

Device Traffic: Organize devices by traffic.
Device Count: Organize devices by the number of devices connected to it.
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l

l

l

Device Type: Organize devices by the device type.

Risk: Only include devices that have endpoints with medium, high, or critical risk values of the specified type: All,
Compromised Host, Vulnerability, Threat Score.
No Devices: Don't show endpoints.

The time period drop-down list filters the view by time. Options include: now (real time), 5 minutes, 1 hour, 24 hours, 7
days.

Critical risks
Click the Critical Risks button to see a list of endpoints that are deemed critical risks, organized by threat severity. These
are the red endpoints in the current topology view.

For each endpoint, the user's photo, name, IP address, email address, and phone number are shown. The number of
vulnerabilities of each severity is shown, and if the IoC verdict is that the endpoint is compromised.
If applicable, the endpoint's host can be quarantined or their IP address banned, by clicking the Quarantine Host on Ban
IP button.
The drop-down menu also provides options to drill down to more information on compromised hosts or endpoint
vulnerabilities.
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Clicking Drill Down to Compromised Hosts will open the FortiView > Compromised Hosts page showing a summary for
the selected endpoint.

Compromised host information can also be viewed on the FortiAnalyzer in SOC > FortiView > Threats > Compromised
Hosts.

The FortiAnalyzer must have a FortiGuard Indicators of Compromise service license in order
to see compromised hosts.

Clicking Drill Down to Endpoint Vulnerability will open the vulnerabilities page showing a summary of the vulnerabilities
on the selected endpoint.

FortiAnalyzer
The Security Fabric topology can also be seen on the FortiAnalyzer device. In the Device Manager, FortiGate devices
are shown as part of a Security Fabric group, with an asterisk next to the name of the root FortiGate.
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To view the Security Fabric topology, right-click on the fabric group and select Fabric Topology. Only Fortinet devices
are shown in the Security Fabric topology views.

Security rating
The security rating analyzes your Security Fabric deployment, identifies potential vulnerabilities, highlights best
practices that can be used to improve the security and performance of your network, and calculates Security Fabric
scores.
To view the security rating and run a security rating check, go to Security Fabric > Security Rating on the root FortiGate.
Click Run Now to run a security rating check. Checks can also be run automatically every four hours.
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The security rating check uses real-time monitoring to analyze the network based on the current network configuration.
When the check is complete, the results table shows a list of the checks that where performed, including:
l
l
l
l

The name and a description of the check.
The device or devices that the check was performed on.
The impact of the check on the overall security score.
The check results - whether it passed or failed.

The list can be searched, filtered to show all results or only failed checks, and exported to a CSV or JSON file. Clicking
on a color or legend name in the donut charts will also filter the results.
Hovering the cursor over a check result score will show the breakdown of how that score was calculated.
Selecting a specific check from the list shows details about that check in the Security Control Details pane, including
recommendations and compliance information. For failed checks, this includes a description of what remediation actions
could be taken. For recommendations that support Easy Apply, the device will have an EZ symbol next to its name, and
the remediation action can be taken automatically by clicking Apply under the recommendations.
For more information about security ratings, and details about each of the checks that are performed, go to Security Best
Practices & Security Rating Feature.
Security Rating licenses are required to run security rating checks across all the devices in the
Security Fabric. It also allows ratings scores to be submitted to and received from FortiGuard
for ranking networks by percentile.
See https://www.fortinet.com/support/support-services/fortiguard-securitysubscriptions/security-rating.html for information.

Automatic security rating checks
Security rating checks can be scheduled to run automatically every four hours.

To enable automatic security checks using the CLI:
config system global
security-rating-run-on-schedule {enable | disable}
end

Opt out of ranking
Security rating scores can be submitted to FortiGuard for comparison with other organizations' scores, allowing a
percentile score to be calculated. If you opt out of submitting your score, only an absolute score will be available.

To opt out of submitting the score using the CLI:
config system global
set security-rating-result-submission {enable | disable}
end

Logging the security rating
The results of past security checks is available in Log & Report > Security Rating Events.
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An event filter subtype can be created for the Security Fabric rating so that event logs are created on the root FortiGate
that summarize the results of a check, and show detailed information for the individual tests.

To configure Security Rating logging using the CLI:
config log eventfilter
set security-rating enable
end

Security Fabric score
The Security Fabric score is calculated when a security rating check is run, based on the severity level of the checks that
are passed or failed. A higher scores represents a more secure network. Points are added for passed checks, and
removed for failed checks.

Severity level

Weight (points)

Critical

50

High

25

Medium

10

Low

5

To calculate the number of points awarded to a device for a passed check, the following equation is used:
score =

<severity level weight>
<# of FortiGates>

x <secure FortiGate multiplier>

The secure FortiGate multiplier is determined using logarithms and the number of FortiGate devices in the Security
Fabric.
For example, if there are four FortiGate devices in the Security Fabric that all pass the Compatible Firmware check, the
score for each FortiGate device is calculated with the following equation:
50
4
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All of the FortiGate devices in the Security Fabric must pass the check in order to receive the points. If any one of the
FortiGate devices fails a check, the devices that passed are not awarded any points. For the device that failed the check,
the following equation is used to calculated the number of points that are lost:
score = <severity level weight> x <secure FortiGate multiplier>
For example, if the check finds two critical FortiClient vulnerabilities, the score is calculated with the following equation:
-50 x 2 = -100 points
Scores are not affect by checks that do not apply to your network. For example, if there are no FortiAP devices in the
Security Fabric, no points will be added or subtracted for the FortiAP firmware version check.

Topology view — consolidated risk
The topology view shows endpoints based on their highest severity event.
In the default topology view, you can view hosts with critical vulnerabilities and compromised hosts identified as critical
risks.
The consolidated Risk view mode displays different risks within the Security Fabric topology. You can use the Risk view
mode to filter threats by Compromised Hosts, Vulnerability, and Threat Score.

To access the default topology view:
1. Go to Security Fabric > Physical Topology.
The default topology view highlights hosts with critical vulnerabilities and compromised hosts as critical risks (three
critical risks in the example).
a. Hover over the tooltips for more details.
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2. To view the critical risk summary, click Critical Risks.
The Critical Risks pane displays on the right-side of the screen.

To access the consolidated Risk view mode:
1. In the view option dropdown button, select Risk.

2. Select one of the following options from the Risk Type dropdown menu:
l All

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

99

Fortinet Security Fabric

l

Compromised Hosts

l

Vulnerability
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l

Threat Score

Fabric connectors
Fabric connectors allow you to connect your network to external services. Following are the categories of connectors:
Public SDN, Private SDN, SSO/Identity, and Threat Feeds.
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If VDOMs are enabled, SDN and Threat Feeds connectors are in the global settings, and
SSO/Identity connectors are per VDOM.

SDN connectors
Fabric connectors to SDNs provide integration and orchestration of Fortinet products with SDN solutions. Fabric
Connectors ensure that any changes in the SDN environment are automatically updated in your network.
There are four steps to creating and using an SDN connector:
1.
2.
3.
4.

Gather the required information
Create the fabric connector on page 103
Create a fabric connector address on page 104
Add the address to a firewall policy on page 105

An example of creating a Microsoft Azure SDN connector is available at
https://docs.fortinet.com/vm/azure/fortigate/6.2/azure-cookbook/6.2.0/502895.

Required information
Specific information is required to create each connector type:

Service
Amazon Web Services

Required information
l
l
l
l

Microsoft Azure

l
l
l
l
l
l
l
l

Google Cloud Platform (GCP)

l
l
l

Oracle Cloud Infrastructure
(OCI)

l
l
l
l
l

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

Access key ID
Secret access key
Region name
VPC ID (optional)
Server region
Tenant ID
Client ID
Client secret
Subscription ID (optional)
Resource group (optional)
Login endpoint (Azure Stack only)
Resource URL (Azure Stack only)
Project name
Service account email
Private key
User ID
Tenant ID
Compartment ID
Server region
Server region type
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Service

Required information

AliCloud

l

Certificate

l

AccessKey ID
AccessKey Secret
Region ID

l
l

Kubernetes

l
l
l

VMware ESXi and NSX

l
l
l

OpenStack (Horizon)

l
l
l

Application Centric
Infrastructure (ACI)

l
l
l
l

Nuage Virtualized Services
Platform

l
l
l
l

IP address
Port
Secret token
IP address or hostname
Username
Password
IP address
Username
Password
IP address
Port
Username
Password
IP address
Port
Username
Password

Create the fabric connector
To create an SDN Fabric connector in the GUI:
1.
2.
3.
4.
5.
6.

Go to Security Fabric > Fabric Connectors.
Click Create New.
Click on the service that you are using.
Enter the Name, Status, and Update Interval for the connector.
Enter the previously collected information for the specific connector that you are creating.
Click OK.

To create an SDN Fabric connector in the CLI:
config system sdn-connector
edit <name>
set status {enable | disable}
set type {connector type}
...
set update-interval <integer>
next
end
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The available CLI commands will vary depending on the selected SDN connector type.

Create a fabric connector address
A fabric connector address can be used in the following ways:
l
l

l

As the source or destination address for firewall policies.
To automatically update changes to addresses in the environment of the service that you are using, based on
specified filtering conditions.
To automatically apply changes to firewall policies that use the address, based on specified filtering conditions.

To create a fabric connector address in the GUI:
1.
2.
3.
4.
5.
6.
7.
8.

Go to Policy & Objects > Addresses.
Click Create New > Address.
Enter a name for the address.
Set the Type to Fabric Connector Address.
Select an SDN Connector from the drop-down list, or click Create New to make a new one.
Set the SDN address type. Only addresses of the selected type will be collected.
Configure the connector specific settings.
Select an Interface for the address, or leave it as any, enable or disable Show in Address List, and optionally add
Comments.
9. Add tags.
10. Click OK.

To create a fabric connector address in the CLI:
config firewall address
edit <name>
set type dynamic
set sdn <sdn_connector>
set visibility enable
set associated-interface <interface_name>
set color <integer>
...
set comment <comment>
config tagging
edit <name>
set category <string>
set tags <strings>
next
end
next
end

The available CLI commands will vary depending on the selected SDN connector type.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

104

Fortinet Security Fabric

Add the address to a firewall policy
A fabric connector address can be used as either the source or destination address.

To add the address to a firewall policy in the GUI:
1.
2.
3.
4.
5.
6.
7.

Go to Policy & Objects > IPv4 Policy.
Click Create New.
Enter a name for the policy.
Set the incoming and outgoing interfaces.
Use the fabric connector address as the source or destination address.
Configure the remaining settings as needed.
Click OK.

To add the address to a firewall policy in the CLI:
config firewall policy
edit 0
set name <name>
set srcintf <port_name>
set dstintf <port_name>
set srcaddr <firewall_address>
set dstaddr <firewall_address>
set action accept
set schedule <schedule>
set service <service>
next
end

AliCloud SDN connector
FortiOS automatically updates dynamic addresses for AliCloud using an AliCloud SDN connector, including mapping the
following attributes from AliCloud instances to dynamic address groups in FortiOS:
l
l
l
l
l
l
l

ImageId
InstanceId
SecurityGroupId
VpcId
VSwitchId
TagKey
TagValue

To configure AliCloud SDN connector using the GUI:
1. Configure the AliCloud SDN connector:
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New, and select Alibaba Cloud.
c. Configure as shown, substituting the access key, secret, and region ID for your deployment. The update
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interval is in seconds.

2. Create a dynamic firewall address for the configured AliCloud SDN connector:
a. Go to Policy & Objects > Addresses.
b. Click Create New, then select Address.
c. Configure the address as shown, selecting the desired filter in the Filter dropdown list. In this example, the
AliCloud SDN connector will automatically populate and update IP addresses only for instances that belong to
the specified security group:

3. Ensure that the AliCloud SDN connector resolves dynamic firewall IP addresses:
a. Go to Policy & Objects > Addresses.
b. Hover over the address created in step 2 to see a list of IP addresses for instances that belong to the security
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group configured in step 2:

To configure AliCloud SDN connector using CLI commands:
1. Configure the AliCloud SDN connector:
config system sdn-connector
edit "ali1"
set type acs
set access-key "LTAIKmERWEuEOChg"
set secret-key xxxxx
set region "us-west-1"
set update-interval 30
next
end

2. Create a dynamic firewall address for the configured AliCloud SDN connector with the supported AliCloud filter. In
this example, the AliCloud SDN Connector will automatically populate and update IP addresses only for instances
that belong to the specified security group:
config firewall address
edit "ali-address-security"
set type dynamic
set sdn "ali1"
set filter "SecurityGroupId=sg-rj9bp5ax5kwy3gqdizqb"
next
end

3. Confirm that the AliCloud SDN connector resolves dynamic firewall IP addresses using the configured filter:
config firewall address
edit "ali-address-security"
set uuid 62a76df2-18f6-51e9-b555-360b18359ebe
set type dynamic
set sdn "ali1"
set filter "SecurityGroupId=sg-rj9bp5ax5kwy3gqdizqb"
config list
edit "10.0.0.16"
next
edit "10.0.0.17"
next
edit "10.0.0.20"
next
end
next
end
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AWS SDN connector with IAM credentials
For instances running in AWS (on demand or BYOL), you can set up the AWS SDN connector using AWS Identify and
Access Management (IAM) credentials.
IAM authentication is available only for FGT-AWS and FGT-AWSONDEMAND platforms.

To configure AWS SDN connector using the GUI:
1. Configure the AWS SDN connector:
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New, and select Amazon Web Services (AWS).
c. Configure as shown:

2. Create a dynamic firewall address for the configured AWS SDN connector:
a. Go to Policy & Objects > Addresses.
b. Click Create New, then select Address.
c. Configure the address as shown, selecting the desired filter in the Filter dropdown list.
Following is an example for a public SDN address type:
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Following is an example for a private SDN address type:

3. Ensure that the AWS SDN connector resolves dynamic firewall IP addresses:
a. Go to Policy & Objects > Addresses.
b. Hover over the address created in step 2 to see a list of IP addresses for instances that belong to the security
group configured in step 2.
Following is an example for a public SDN address type:
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Following is an example for a private SDN address type:

To configure AWS SDN connector using CLI commands:
1. Configure the AWS connector:
config system sdn-connector
edit "aws1"
set status enable
set type aws
set use-metadata-iam enable
set update-interval 60
next
end

2. Create a dynamic firewall address for the configured AWS SDN connector with the supported filter:
Dynamic firewall address IPs are resolved by the SDN connector.
config firewall address
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edit "aws-ec2"
set type dynamic
set sdn "aws1"
set filter "SecurityGroupId=sg-05f4749cf84267548"
set sdn-addr-type public
next
edit "aws-eks1"
set type dynamic
set sdn "aws1"
set filter "K8S_Region=us-west-2"
next
end

3. Confirm that the AWS SDN connector resolves dynamic firewall IP addresses using the configured filter:
config firewall address
edit "aws-ec2"
set uuid e756e786-3a2e-51e9-9d40-9492098de42d
set type dynamic
set sdn "aws1"
set filter "SecurityGroupId=sg-05f4749cf84267548"
set sdn-addr-type public
config list
edit "34.222.246.198"
next
edit "54.188.139.177"
next
edit "54.218.229.229"
next
end
next
edit "aws-eks1"
set uuid d84589aa-3a10-51e9-b1ac-08145abce4d6
set type dynamic
set sdn "aws1"
set filter "K8S_Region=us-west-2"
config list
edit "192.168.114.197"
next
edit "192.168.167.20"
next
edit "192.168.180.72"
next
edit "192.168.181.186"
next
edit "192.168.210.107"
next
end
next
end

Azure Stack SDN connector
FortiOS automatically updates dynamic addresses for Azure Stack on-premise environments using an Azure Stack
SDN connector, including mapping the following attributes from Azure Stack instances to dynamic address groups in
FortiOS:
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l
l
l
l
l
l
l
l

vm
tag
size
securitygroup
vnet
subnet
resourcegroup
vmss

To configure Azure Stack SDN connector using the GUI:
1. Configure the Azure Stack SDN connector:
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New, and select Microsoft Azure.
c. Configure as shown, substituting the Azure Stack settings for your deployment. The update interval is in
seconds.

2. Create a dynamic firewall address for the configured Azure Stack SDN connector:
a. Go to Policy & Objects > Addresses.
b. Click Create New, then select Address.
c. Configure the address as shown, selecting the desired filter in the Filter dropdown list. In this example, the
Azure Stack SDN connector will automatically populate and update IP addresses only for instances that are
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named tfgta:

3. Ensure that the Azure Stack SDN connector resolves dynamic firewall IP addresses:
a. Go to Policy & Objects > Addresses.
b. Hover over the address created in step 2 to see a list of IP addresses for instances that are named tftgta as
configured in step 2:

To configure Azure Stack SDN connector using CLI commands:
1. Configure the Azure Stack SDN connector:
config system sdn-connector
edit "azurestack1"
set type azure
set azure-region local
set server "azurestack.external"
set username "username@azurestoreexamplecompany.onmicrosoft.com"
set password xxxxx
set log-in endpoint "https://login.microsoftonline.com/942b80cd-1b14-42a1-8dcf4b21dece61ba"
set resource-url
"https://management.azurestoreexamplecompany.onmicrosoft.com/12b6fedd-93644cf0-822b-080d70298323"
set update-interval 30
next
end

2. Create a dynamic firewall address for the configured Azure Stack SDN connector with the supported Azure Stack
filter. In this example, the Azure Stack SDN Connector will automatically populate and update IP addresses only for
instances that are named tfgta:
config firewall address
edit "azurestack-address-name1"
set type dynamic
set sdn "azurestack1"
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set filter "vm=tfgta"
next
end

3. Confirm that the Azure Stack fabric connector resolves dynamic firewall IP addresses using the configured filter:
config firewall address
edit "azurestack-address-name1"
set type dynamic
set sdn "azurestack1"
set filter "vm=tfgta"
config list
edit "10.0.1.4"
next
edit "10.0.2.4"
next
edit "10.0.3.4"
next
edit "10.0.4.4"
next
edit "192.168.102.32"
next
edit "192.168.102.35"
next
end
next
end

VMware ESXi SDN connector
Dynamic addresses for VMware ESXi and vCenter servers can be automatically updated by using a VMware ESXi
SDN connector, including mapping the following attributes from VMware ESXi and vCenter objects to dynamic address
groups in FortiOS:
l
l
l
l
l
l
l
l
l

vmid
host
name
uuid
vmuuid
vmnetwork
guestid
guestname
annotation

To configure VMware ESXi SDN connector using the GUI:
1. Configure the VMware ESXi SDN connector:
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New, and select VMware ESXi.
c. Configure as shown, substituting the server IP address, username, and password for your deployment. The
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update interval is in seconds.

2. Create a dynamic firewall address for the configured VMware ESXi SDN connector:
a. Go to Policy & Objects > Addresses.
b. Click Create New, then select Address.
c. Configure the address as shown, selecting the desired filter in the Filter dropdown list. In this example, the
VMware ESXi fabric connector will automatically populate and update IP addresses only for instances that
belong to VLAN80:

3. Ensure that the VMware ESXi SDN connector resolves dynamic firewall IP addresses:
a. Go to Policy & Objects > Addresses.
b. Hover over the address created in step 2 to see a list of IP addresses for instances that belong to VLAN80 as
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configured in step 2:

To configure VMware ESXi SDN connector using CLI commands:
1. Configure the VMware ESXi SDN connector:
config system sdn-connector
edit "vmware1"
set type vmware
set server "172.17.48.222"
set username "example_username"
set password xxxxx
set update-interval 30
next
end

2. Create a dynamic firewall address for the configured VMware ESXi SDN connector with the supported VMware
ESXi filter. In this example, the VMware ESXi SDN connector will automatically populate and update IP addresses
only for instances that belong to the specified VLAN:
config firewall address
edit "vmware-network"
set type dynamic
set sdn "vmware1"
set filter "vmnetwork=VLAN80"
next
end

3. Confirm that the VMware ESXi SDN connector resolves dynamic firewall IP addresses using the configured filter:
config firewall address
edit "vmware-network"
set uuid abfa1748-1b80-51e9-d0fd-ea322b3bba2d
set type dynamic
set sdn "vmware1"
set filter "vmnetwork=VLAN80"
config list
edit "192.168.8.240"
next
end
next
end
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VMware NSX-T manager SDN connector
This feature provides SDN connector configuration for VMware NSX-T manager. You can import specific groups, or all
groups from the NSX-T manager.

To configure SDN connector for NSX-T manager in the GUI:
1. Go to Security Fabric > Fabric Connectors and click Create New.
2. In the Private SDN section, click VMware NSX.
3. Enter the settings and click OK.

To configure SDN connector for NSX-T manager in the CLI:
config system sdn-connector
edit "nsx_t24"
set type nsx
set server "172.18.64.205"
set username "admin"
set password xxxxxx
next
end

To import a specific group from the NSX-T manager:
# execute nsx group import nsx_t24 root csf_ns_group
[1] 336914ba-0660-4840-b0f1-9320f5c5ca5e csf_ns_group:
Name:csf_ns_group
Address:1.1.1.0
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Address:1.1.1.1
Address:172.16.10.104
Address:172.16.20.104
Address:172.16.30.104
Address:2.2.2.0
Address:2.2.2.2
Address:4.4.4.0
Address:5.5.5.0
Address:6.6.6.6
Address:7.7.7.7

To import all groups from NSX-T manager:
# execute nsx group import nsx_t24 root
[1] 663a7686-b9a3-4659-b06f-b45c908349a0
Name:ServiceInsertion_NSGroup
Address:10.0.0.2
[2] 336914ba-0660-4840-b0f1-9320f5c5ca5e
Name:csf_ns_group
Address:1.1.1.0
Address:1.1.1.1
Address:172.16.10.104
Address:172.16.20.104
Address:172.16.30.104
Address:2.2.2.0
Address:2.2.2.2
Address:4.4.4.0
Address:5.5.5.0
Address:6.6.6.6
Address:7.7.7.7
[3] c462ec4d-d526-4ceb-aeb5-3f168cecd89d
Name:charlie_test
Address:1.1.1.1
Address:2.2.2.2
Address:6.6.6.6
Address:7.7.7.7
[4] ff4dcb08-53cf-46bd-bef4-f7aeda9c0ad9
Name:fgt
Address:172.16.10.101
Address:172.16.10.102
Address:172.16.20.102
Address:172.16.30.103
[5] 3dd7df0d-2baa-44e0-b88f-bd21a92eb2e5
Name:yongyu_test
Address:1.1.1.0
Address:2.2.2.0
Address:4.4.4.0
Address:5.5.5.0
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To view the dynamic firewall IP addresses that are resolved by the SDN connector in the GUI:
1. Go to Policy & Objects > Addresses to view the IP addresses resolved by an SDN connector.

To view the dynamic firewall IP addresses that are resolved by the SDN connector in the CLI:
# show firewall address csf_ns_group
config firewall address
edit "csf_ns_group"
set uuid ee4a2696-bacd-51e9-f828-59457565b880
set type dynamic
set sdn "nsx_t24"
set obj-id "336914ba-0660-4840-b0f1-9320f5c5ca5e"
config list
edit "1.1.1.0"
next
edit "1.1.1.1"
next
edit "172.16.10.104"
next
edit "172.16.20.104"
next
edit "172.16.30.104"
next
edit "2.2.2.0"
next
edit "2.2.2.2"
next
edit "4.4.4.0"
next
edit "5.5.5.0"
next
edit "6.6.6.6"
next
edit "7.7.7.7"
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next
end
next
end

OpenStack (Horizon) SDN connector with domain filter
You can select a domain attribute when configuring an OpenStack SDN connector in FortiOS. When a domain is
configured for the OpenStack SDN connector, FortiOS resolves OpenStack dynamic firewall addresses from the
specified OpenStack domain. If a domain is not specified, FortiOS resolves the dynamic firewall addresses using the
default OpenStack domain.

To configure OpenStack SDN connector with a domain filter using the GUI:
1. Configure the OpenStack SDN connector:
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New, and select Openstack (Horizon).
c. In the Domain field, enter the desired domain name from OpenStack. The fabric connector will only resolve IP
addresses for instances that belong to the specified domain.
d. Configure as shown, substituting the server IP address, username, and password for your deployment. The
update interval is in seconds.

2. Create a dynamic firewall address for the configured OpenStack SDN connector:
a. Go to Policy & Objects > Addresses.
b. Click Create New, then select Address.
c. Configure the address as shown, selecting the desired filter in the Filter dropdown list. The OpenStack
SDN connector will automatically populate and update IP addresses only for instances that belong to the
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specified domain and network:

3. Ensure that the OpenStack SDN connector resolves dynamic firewall IP addresses:
a. Go to Policy & Objects > Addresses.
b. Hover over the address created in step 2 to see a list of IP addresses for instances that belong to the specified
domain and specified network as configured in steps 1 and 2:

To configure OpenStack SDN connector with a domain filter using CLI commands:
1. Configure the OpenStack SDN connector. The SDN connector will only resolve IP addresses for instances that
belong to the specified domain:
config system sdn-connector
edit "openstack-domain"
set type openstack
set server "http://172.16.165.86:5000"
set username "example_username"
set password xxxxx
set domain "example_domain"
set update-interval 30
next
end

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

121

Fortinet Security Fabric
2. Create a dynamic firewall address for the configured OpenStack SDN connector with the supported OpenStack
filter. The OpenStack SDN connector will automatically populate and update IP addresses only for instances that
belong to the specified domain and the specified network:
config firewall address
edit "openstack-domain-network"
set type dynamic
set sdn "openstack-domain"
set filter "Network=example-net1"
next
end

3. Confirm that the OpenStack SDN connector resolves dynamic firewall IP addresses using the configured domain
and filter:
config firewall address
edit "openstack-domain-network"
set uuid 02837298-234d-51e9-efda-559c6001438a
set type dynamic
set sdn "openstack-domain"
set filter "Network=example-net1"
config list
edit "10.0.0.13"
next
edit "10.0.0.16"
next
edit "10.0.0.3"
next
edit "172.24.4.18"
next
edit "172.24.4.24"
next
edit "172.24.4.3"
next
end
next
end

OCI SDN connector
You can configure Security Fabric connector integration with Oracle Cloud Infrastructure (OCI).

To configure an OCI SDN connector in the CLI:
1. Configure an SDN connector:
config system sdn-connector
edit "oci1"
set status enable
set type oci
set tenant-id
"ocid1.tenancy.oc1..aaaaaaaaaaa3aaaaaaaaaaaaaaaaa77xxxxxx54bbbbbb4xxxx35xx55xxxx"
set user-id
"ocid1.user.oc1..aaaaaaaaa2laaaaa3aaaaaaaaaabbbbbbbbbbcccc3ccccccccccxxxxxxxx"
set compartment-id
"ocid1.compartment.oc1..aaaaaaaaaaaaaaaaaa7bbbbbbbbbbcccccccccc6xxx53xxxx7xxxxxxxxxx"
set oci-region "us-ashburn-1"
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set oci-region-type commercial
set oci-cert "cert-sha2"
set update-interval 30
next
end

2. Create a dynamic firewall address for the SDN connector with a supported filter:
config firewall address
edit "oci-address-1"
set uuid 0b4a496e-8974-51e9-e223-fee75c935fb7
set type dynamic
set sdn "oci1"
set filter "CompartmentName=DevelopmentEngineering"
next
end

To configure an OCI SDN connector in the GUI:
1. Go to Security Fabric > Fabric Connectors and click Create New.
2. In the Public SDN section, select Oracle Cloud Infrastructure (OCI).
3. Configuration the connector as needed.

4. Click OK.
5. Go to Policy & Objects > Addresses and click Create New > Address.
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6. Configure the address as needed, selecting the OCI connector in the SDN Connector field.

7. Click OK.

To confirm that dynamic firewall addresses are resolved by the SDN connector:
1. In the CLI, check that the addresses are listed:
config firewall address
edit "oci-address-1"
set uuid 0b4a496e-8974-51e9-e223-fee75c935fb7
set type dynamic
set sdn "oci1"
set filter "CompartmentName=DevelopmentEngineering"
config list
edit "10.0.0.11"
next
edit "10.0.0.118"
next
...
next
end
next
end
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2. In the GUI, go to Policy & Objects > Addresses and hover the cursor over the address name.

ClearPass endpoint connector via FortiManager
ClearPass Policy Manager (CCPM) is a network access system that can send information about authenticated users to
third party systems, such as a FortiGate or FortiManager.
In this example, communications are established between CCPM and FortiManager, and then the FortiManager
forwards information to a managed FortiGate. On the FortiGate, the user information can be used in firewall policies and
added to FSSO dynamic addresses.

Configure the FortiManager
Establish communications between FortiManager and CPPM so that FortiManager can synchronize CPPM user groups.
See Creating a ClearPass connector in the FortiManager Administration Guide.
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FortiManager forwards the group information to managed FortiGates.

Add CPPM FSSO user groups to a local user group
To add CPPM user groups to a local user group in the GUI:
1.
2.
3.
4.

On the FortiGate, go to User & Device > User Groups.
Click Create New.
Enter a name for the group and set Type to Fortinet Single Sign-On (FSSO).
Click the Members field, and add one or more FSSO groups.
FSSO groups can come from multiple sources; CPPM FSSO groups are prefixed with cp_ and are listed under the
FortiManager heading.

5. Click OK.

To add CPPM user groups to a local user group in the CLI:
config user group
edit fsso-group
set group-type fsso-service
set member "cp_test_[Employee]" "cp_test_FSSOROLE"
next
end

Use the local FSSO user group in a firewall policy
To add the local FSSO user group to a firewall policy in the GUI:
1. Go to Policy & Objects > IPv4 Policy.
2. Create a new policy, or edit an existing one.
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3. Click in the Source field and add the fsso-group user group.

CPPM user groups can also be added directly to the policy.
4. Click OK.

To add the local FSSO user group to a firewall policy in the CLI:
config firewall policy
edit 1
set name "pol1"
set uuid 2b88ed8a-c906-51e9-fb25-8cb12172acd8
set srcintf "port2"
set dstintf "port3"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set logtraffic all
set groups "fsso-group"
set nat enable
next
end

Verification
To verify that a user was added to the FSSO list on the FortiGate:
1. Log on to the client and authenticate with CPPM.
After successful authentication, the user is added to the FSSO list on the FortiGate.
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2. On the FortiGate, go to Monitor > Firewall User Monitor to verify that the user was added.

The user group cp_test_FSSOROLE is listed separately because the user is a member of that group on the CPPM.

To verify that traffic can pass the firewall:
1. Log on to the client and browse to an external website.
2. On the FortiGate, go to FortiView > Sources.
3. Double-click on the user and select the Destinations tab to verify that traffic is being passed by the firewall.

To verify the user address groups:
show user adgrp
config user adgrp
edit "cp_test_FSSOROLE"
set server-name "FortiManager"
next
edit "cp_test_[AirGroup v1]"
set server-name "FortiManager"
next
edit "cp_test_[AirGroup v2]"
set server-name "FortiManager"
next
edit "cp_test_[Aruba TACACS read-only Admin]"
set server-name "FortiManager"
next
edit "cp_test_[Aruba TACACS root Admin]"
set server-name "FortiManager"
next
edit "cp_test_[BYOD Operator]"
set server-name "FortiManager"
next
edit "cp_test_[Contractor]"
set server-name "FortiManager"
next
edit "cp_test_[Device Registration]"
set server-name "FortiManager"
next
...
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edit "CN=group1,OU=Testing,DC=Fortinet-FSSO,DC=COM"
set server-name "Local FSSO Agent"
<----- !!!
next
end

Cisco pxGrid fabric connector
You can create an endpoint connector to Cisco pxGrid by using FortiManager. FortiManager dynamically collects
updates from pxGrid and forwards them to FortiGate by using the Fortinet Single Sign On (FSSO) protocol.

To create a Cisco pxGrid fabric connector:
1. On FortiManager, create an SSO Connector to Cisco ISE.
Communication between FortiManager and Cisco ISE is secured by using TLS. FortiManager requires a client
certificate issued by Cisco ISE. FortiManager uses the certificate to authenticate to Cisco ISE.

2. On FortiManager, map Cisco ISE groups to a Fortinet FSSO group.
Once a secured communication channel is established, Cisco sends all user groups to FortiManager.
The FortiManager administrator can select specific groups and map them to Fortinet FSSO groups.
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3. On FortiManager, add Fortinet FSSO group to a firewall policy in a policy package.

4. On FortiManager, synchronize the policy package to the firewall for the managed FortiGate.

5. On FortiGate, verify that the synced firewall policy contains the correct FSSO group and that all FSSO-related
information in user adgrp is correct.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

130

Fortinet Security Fabric

6. After successful user authentication on Cisco ISE, verify that information is forwarded to FortiManager.
On FortiManager, the icon next to the authenticated user in pxGrid Monitor should be green.

FortiGate should have two entries: one in the firewall-authenticated user list and one in the FSSO logged-on user
list.
In the FSSO logged-on user list, you can view both groups. You view the group that the user belongs to on Cisco
ISE and the Fortinet FSSO group.
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Cisco ACI SDN connector
You can use Cisco ACI (Application Centric Infrastructure) SDN connectors in dynamic firewall addresses.
The Fortinet SDN Connector for Cisco ACI and Nuage Networks is a standalone connector that connects to SDN
controllers within Cisco ACI and Nuage Networks. You must configure a connection to the Fortinet SDN connector in
FortiOS to query the dynamic addresses.

To configure a Cisco ACI connector in the GUI:
1. Create the Cisco ACI SDN connector:
a. Go to Security Fabric > Fabric Connectors and click Create New, then select .
b. In the Private SDN section, click Application Centric Infrastructure (ACI).
c. In the Cisco ACI Connector section, for Type, select Fortinet SDN Connector and configure the remaining
settings as needed.
d. Click OK.
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2. Create the dynamic firewall address for the connector:
a. Go to Policy & Objects > Addresses and click Create New > Address.
b. Configure the following settings:
i. For Type, select Dynamic.
ii. For Sub Type, select Fabric Connector Address.
iii. For SDN Connector, select the first ACI connector.
iv. Configure the remaining settings as needed.
c. Click OK.

To verify the SDN connector resolves the dynamic firewall IP addresses in the GUI:
1. Go to Policy & Objects > Addresses.
2. In the address table, hover over the address to view which IPs it resolves to.

To configure a Cisco ACI connector in the CLI:
1. Create the SDN connector:
config system sdn-connector
edit "aci1"
set type aci
set server "172.18.64.31"
set username "admin"
set password xxxxxxx
next
end

2. Create the dynamic firewall address for the connector:
config firewall address
edit "aci-address1"
set type dynamic
set sdn "aci1"
set color 17
set tenant "wqdai-ten"
set epg-name "EPG-in"
set sdn-tag "fffff"
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next
end

To verify the dynamic firewall IPs are resolved by the SDN connector in the CLI:
# diagnose firewall dynamic list
List all dynamic addresses:
aci1.aci.wqdai-ten.EPG-in.fffff: ID(171)
ADDR(192.168.100.20)

Nuage SDN connector
Nuage SDN connectors can be used in dynamic firewall addresses.
The Fortinet SDN Connector for Cisco ACI and Nuage Networks is a standalone connector that connects to SDN
controllers within Cisco ACI and Nuage Networks. You must configure a connection to the Fortinet SDN connector in
FortiOS to query the dynamic addresses.

To configure a Nuage connector in the GUI:
1. Create the Nuage SDN connector:
a. Go to Security Fabric > External Connectors and click Create New.
b. In the Private SDN section, click Nuage Virtualized Services Platform.
c. Configure the settings as needed.
d. Click OK.

2. Create the dynamic firewall address for the connector:
a. Go to Policy & Objects > Addresses and click Create New > Address.
b. Configure the following settings:
i. For Type, select Dynamic.
ii. For Sub Type, select Fabric Connector Address.
iii. For SDN Connector, select the first the first Nuage connector.
iv. Configure the remaining settings as needed.
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c. Click OK.

To verify the SDN connector resolves the dynamic firewall IP addresses in the GUI:
1. Go to Policy & Objects > Addresses.
2. In the address table, hover over an address to view which IP addresses it resolves to.

To configure a Nuage connector in the CLI:
1. Create the SDN connector:
config system sdn-connector
edit "nuage1"
set type nuage
set server "172.18.64.27"
set server-port 5671
set username "admin"
set password xxxxxxx
next
end

2. Create the dynamic firewall address for the connector:
config firewall address
edit "nuage-address1"
set type dynamic
set sdn "nuage1"
set color 19
set organization "nuage/L3"
set subnet-name "Subnet20"
next
end

To verify the SDN connector resolves the dynamic firewall IP addresses in the CLI:
# diagnose firewall dynamic list
List all dynamic addresses:
nuage1.nuage.nuage/L3.Subnet20.*: ID(196)
ADDR(192.168.20.92)
ADDR(192.168.20.240)
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Multiple concurrent SDN connectors
You can configure multiple instances configured for every SDN connector. The specific connector instance must be
specified when creating a dynamic firewall address.
This topic provides examples of how to create two Microsoft Azure SDN connectors and use them in new dynamic
firewall addresses.

Multiple concurrent SDN/Cloud connectors are not supported yet for Cisco ACI or Nuage.

To create and use two new SDN connectors with the CLI:
1. Create two new SDN connectors:
config system sdn-connector
edit "azure1"
set type azure
set tenant-id "942b80cd-bbbb-42a1-8888-4b21dece61ba"
set subscription-id "2f96c44c-cccc-4621-bbbb-65ba45185e0c"
set client-id "14dbd5cc-3333-4ea4-8888-68738141feb1"
set client-secret xxxxx
set update-interval 30
next
edit "azure2"
set type azure
set tenant-id "942b80cd-bbbb-42a1-8888-4b21dece61ba"
set client-id "3baa0acc-ffff-4444-b292-0777a2c36be6"
set client-secret xxxxx
set update-interval 30
next
end

2. Create new dynamic firewall addresses that use the new connectors:
config firewall address
edit "azure-address-location1"
set type dynamic
set color 2
set sdn azure1
set filter "location=WestUs"
next
edit "azure-address-location2"
set type dynamic
set color 2
set sdn azure2
set filter "location=NorthEurope"
next
end
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To create and use two new SDN connectors with the GUI:
1. Create two new SDN connectors:
a. Go to Security Fabric > Fabric Connectors, and click Create New in the toolbar.
b. Click on Microsoft Azure.
c. Fill in the required information, then click OK.

d. Repeat the above steps for the second connector.

Two Microsoft Azure connectors will now be created.
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2. Create new dynamic firewall addresses that use the new connectors:
a. Go to Policy and Objects > Addresses and click Create New > Address in the toolbar.
b. Enter a name for the address, and select Fabric Connector Address for the Type.
c. Select one of the previously created SDN connectors from the SDN Connector drop down list.

d. Configure the rest of the required information, then click OK to create the address.
e. Repeat the above steps to create the second address, selecting the other Microsoft Azure SDN connector.

Filter lookup in SDN connectors
When configuring dynamic address mappings for filters in SDN connectors for Azure, GCP, OpenStack, Kubernetes,
and AliCloud, FortiGate can query the filters automatically.

To use the filter lookup:
1. Navigate to Policy & Objects > Addresses.
2. Create or edit an SDN connector type dynamic IP address.
Supported SDN connector types include: AWS, Azure, GCP, OpenStack, Kubernetes, and AliCloud. The example
below is for an Azure SDN connector.
3. In the address Filter field, you can perform the following actions:
l List all available filters.
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l

Search the available filters.
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l

Create custom filters.
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l

Set filter logic [and|or].

Kubernetes (K8s) SDN connectors
The following recipes provide information about configuring Kubernetes SDN connectors:
l
l
l
l
l

Private Cloud K8s SDN connector on page 141
AWS Kubernetes (EKS) SDN connector on page 144
Azure Kubernetes (AKS) SDN connector on page 149
GCP Kubernetes (GKE) SDN connector on page 146
Oracle Kubernetes (OKE) SDN connector on page 151

Private Cloud K8s SDN connector
FortiOS automatically updates dynamic addresses for Kubernetes (K8S) by using a K8S SDN connector, enabling
FortiOS to manage K8S pods as global address objects, as with other connectors. This includes mapping the following
attributes from K8S instances to dynamic address groups in FortiOS:

Filter

Description

Namespace

Filter service IP addresses in a given namespace.

ServiceName

Filter service IP addresses by the given service name.

NodeName

Filter node IP addresses by the given node name.

Label.XXX

Filter service or node IP addresses with the given label XXX.
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To configure K8S SDN connector using the GUI:
1. Configure the K8S SDN connector:
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New, and select Kubernetes.
c. Configure as shown substituting the IP address, port number, and secret token for your deployment. The
update interval is in seconds.

2. Create a dynamic firewall address for the configured K8S SDN connector:
a. Go to Policy & Objects > Addresses.
b. Click Create New, then select Address.
c. Configure the address as shown, selecting the desired filter in the Filter dropdown list. In this example, the
K8S SDN connector will automatically populate and update IP addresses only for node instances that match
the specified node name:

3. Ensure that the K8S SDN connector resolves dynamic firewall IP addresses:
a. Go to Policy & Objects > Addresses.
b. Hover over the address created in step 2 to see a list of IP addresses for node instances that match the node
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name configured in step 2:

To configure K8S SDN connector using CLI commands:
1. Configure the K8S SDN connector:
config system sdn-connector
edit "kubernetes1"
set type kubernetes
set server "172.18.64.38"
set server-port 6443
set secret-token xxxxx
set update-interval 30
next
end

2. Create a dynamic firewall address for the configured K8S SDN connector with the supported K8S filter. In this
example, the K8S SDN connector will automatically populate and update IP addresses only for node instances that
match the specified node name:
config firewall address
edit "k8s_nodename"
set type dynamic
set sdn "kubernetes1"
set filter "K8S_NodeName=van-201669-pc1"
next
end

3. Confirm that the K8S SDN connector resolves dynamic firewall IP addresses using the configured filter:
config firewall address
edit "k8s_nodename"
set uuid 462112a2-1ab1-51e9-799c-652621ba8c0c
set type dynamic
set sdn "kubernetes1"
set filter "K8S_NodeName=van-201669-pc1"
config list
edit "172.16.65.227"
next
end
next
end
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AWS Kubernetes (EKS) SDN connector
AWS SDN connectors support dynamic address groups based on AWS Kubernetes (EKS) filters.
To filter out the Kubernetes IP addresses, the following address filters have been introduced:
k8s_cluster

Name of Kubernetes cluster.

k8s_namespace

Namespace of a Kubernetes service or pod.

k8s_svcname

Name of a Kubernetes service.

k8s_nodename

Name of a Kubernetes node.

k8s_zone

Zone of a Kubernetes node.

k8s_region

Region of a Kubernetes node.

k8s_podname

Name of a Kubernetes pod.

k8s_label.xxx

Name of label of a Kubernetes resource (cluster/service/node/Pod).

To enable an AWS SDN connector to fetch IP addresses from AWS Kubernetes:
1. In Fabric Connectors, configure an SDN connector for AWS Kubernetes.

2. Go to Policies & Objects > Addresses and create a dynamic firewall address for the configured SDN connector
using the supported Kubernetes filter.
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3. To filter out the Kubernetes IP addresses, select the address filter or filters.

4. Configure the rest of the settings, then click OK.
The dynamic firewall address IP is resolved by the SDN connector.

To configure an AWS Kubernetes SDN connector through the CLI:
1. Configure an SDN connector for Kubernetes:
config system sdn-connector
edit "aws1"
set type aws
set access-key "AKIAIJNKE75ANVN5AEQA"
set secret-key xxxxx
set region "us-west-2"
set update-interval 30
next
end

2. Create a dynamic firewall address for the SDN connector with a supported Kubernetes filter:
config firewall address
edit "aws-pod"
set type dynamic
set sdn "aws1"
set filter "K8S_PodName=aws-node-g6zhx"
next

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

145

Fortinet Security Fabric
end

The dynamic firewall address IP is resolved by the SDN connector:
config firewall address
edit "aws-pod"
set uuid a7a37298-19e6-51e9-851a-2c551ffc174d
set type dynamic
set sdn "aws1"
set filter "K8S_PodName=aws-node-g6zhx"
config list
edit "192.168.114.197"
next
end
next
end

GCP Kubernetes (GKE) SDN connector
Google Cloud Platform (GCP) SDN connectors support dynamic address groups based on GCP Kubernetes Engine
(GKE) filters.
To filter out the Kubernetes IP addresses, the following address filters have been introduced:
k8s_cluster

Name of Kubernetes cluster.

k8s_nodepool

Name of node pool for a Kubernetes cluster.

k8s_namespace

Namespace of a Kubernetes service or pod.

k8s_servicename

Name of a Kubernetes service.

k8s_nodename

Name of a Kubernetes node.

k8s_zone

Zone of a Kubernetes node.

k8s_region

Region of a Kubernetes node.

k8s_podname

Name of a Kubernetes pod.

k8s_label.xxx

Name of label of a Kubernetes resource (cluster/service/node/Pod).
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To enable a GCP SDN connector to fetch IP addresses from GKE:
1. In Fabric Connectors, configure an SDN connector for GCP.

2. Go to Policies & Objects > Addresses and create a dynamic firewall address for the configured SDN connector
using the supported Kubernetes filter.
3. To filter out the Kubernetes IP addresses, select the address filter or filters. In this example, the GCP SDN
connector will automatically populate and update IP addresses only for instances that belong to the zhmkc3 cluster:

4. Configure the rest of the settings, then click OK.
The dynamic firewall address IP is resolved by the SDN connector.
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To configure a GCP Kubernetes SDN connector through the CLI:
1. Configure an SDN connector for Kubernetes:
config system sdn-connector
edit "gcp1"
set type gcp
set gcp-project "dev-project-001-166400"
set service-account "966517025500-compute@developer.gserviceaccount.com"
set update-interval 30
next
end

2. Create a dynamic firewall address for the SDN connector with a supported Kubernetes filter:
config firewall address
edit "gcp-k8s-cluster"
set type dynamic
set sdn "gcp1"
set filter "K8S_Cluster=zhm-kc3"
next
end

The dynamic firewall address IP is resolved by the SDN connector:
config firewall address
edit "gcp-k8s-cluster"
set uuid e4a1aa3c-25be-51e9-e9af-78ab2eebe6ee
set type dynamic
set sdn "gcp1"
set filter "K8S_Cluster=zhm-kc3"
config list
edit "10.0.2.4"
next
edit "10.0.2.7"
next
edit "10.28.0.13"
next
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end
next
end

Azure Kubernetes (AKS) SDN connector
Azure SDN connectors support dynamic address groups based on Azure Kubernetes (AKS) filters.
To filter out the Kubernetes IP addresses, the following address filters have been introduced:
k8s_cluster

Kubernetes cluster name.

k8s_namespace

Namespace of a Kubernetes service or pod.

k8s_svcname

Kubernetes service name.

k8s_nodename

Kubernetes node name.

k8s_region

Kubernetes node region.

k8s_podname

Kubernetes pod name.

k8s_label.xxx

Name of label of a Kubernetes resource (cluster/service/node/Pod).

To enable an Azure SDN connector to fetch IP addresses from Azure Kubernetes:
1. Configure the Azure SDN connector:
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New, and select Azure.
c. Configure as shown substituting the region, tenant and client IDs, and client secret for your deployment. The
update interval is in seconds.

2. Create a dynamic firewall address for the configured K8S SDN connector:
a. Go to Policy & Objects > Addresses.
b. Click Create New, then select Address.
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c. Configure the address as shown, selecting the desired filter in the Filter dropdown list. In this example, the
Azure SDN connector will automatically populate and update IP addresses only for instances that belong to the
zhmKC cluster:

3. Ensure that the K8S SDN connector resolves dynamic firewall IP addresses:
a. Go to Policy & Objects > Addresses.
b. Hover over the address created in step 2 to see a list of IP addresses for instances that belong to the
zhmKC cluster as configured in step 2:

To configure an Azure Kubernetes SDN connector through the CLI:
1. Configure an SDN connector for Kubernetes:
config system sdn-connector
edit "azure1"
set type azure
set tenant-id "942b80cd-1b14-42a1-8dcf-4b21dece61ba"
set client-id "14dbd5c5-307e-4ea4-8133-68738141feb1"
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set client-secret xxxxx
set update-interval 30
next
end

2. Create a dynamic firewall address for the SDN connector with a supported Kubernetes filter. In this example, the
Azure SDN connector will automatically populate and update IP addresses only for instances that belong to the
zhmKC cluster:
config firewall address
edit "az-k8s-cluster"
set type dynamic
set sdn "azure1"
set filter "K8S_Cluster=zhmKC"
next
end

3. Confirm that the Azure SDN connector resolves dynamic firewall IP addresses using the configured filter: :
config firewall address
edit "az-k8s-cluster"
set uuid c3859270-1919-51e9-4a99-47d8caf97a01
set type dynamic
set sdn "azure1"
set filter "K8S_Cluster=zhmKC"
config list
edit "10.240.0.4"
next
edit "10.240.0.5"
next
edit "10.244.0.10"
next
end
next
end

Oracle Kubernetes (OKE) SDN connector
OCI SDN connectors support dynamic address groups based on Oracle Kubernetes (OKE) filters.
To filter out the Kubernetes IP addresses, the following address filters have been introduced:
k8s_compartment

Name of compartment that the Kubernetes cluster created in.

k8s_cluster

Name of Kubernetes cluster.

k8s_namespace

Namespace of a Kubernetes service or pod.

k8s_servicename

Name of a Kubernetes service.

k8s_nodename

Name of a Kubernetes node.

k8s_region

Region of a Kubernetes node.

k8s_zone

Zone of a Kubernetes node.

k8s_podname

name of a Kubernetes pod.

k8s_label.xxx

Name of label of a Kubernetes resource (cluster/service/node/Pod)
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To enable an OCI SDN connector to fetch IP addresses from Oracle Kubernetes:
1. Configure the OCI SDN connector:
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New, and select Oracle Cloud Infrastructure (OCI).
c. Configure as shown substituting the region, tenant and client IDs, and client secret for your deployment. The
update interval is in seconds.

2. Create dynamic firewall addresses for the configured SDN connector with supported Kubernetes filter:
a. Go to Policy & Objects > Addresses.
b. Click Create New, then select Address.
c. Configure the addresses.
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3. Confirm that the SDN connector resolves dynamic firewall IP addresses:
a. Go to Policy & Objects > Addresses.
b. Hover over the address created in step 2 to see a list of IP addresses for instances:

To configure an SDN connector through the CLI:
1. Configure the OCI SDN connector:
config system sdn-connector
edit "oci1"
set type oci
set tenant-id
"ocid1.tenancy.oc1..aaaaaaaambr3uzztoyhweohbzqqdo775h7d3t54zpmzkp4b2cf35vs5
5cxxx"
set user-id
"ocid1.user.oc1..aaaaaaaaq2lfspeo3uetzbzpiv2pqvzzevozccnys347stwssvizqlatfx
xx"
set compartment-id
"ocid1.compartment.oc1..aaaaaaaaelxxdjazqo7nzczpgypyiqcgkmytjry6nfq5345vw7e
avpwnmxxx"
set oci-region ashburn
set oci-cert "cert-sha2"
set update-interval 30
next
end

2. Create dynamic firewall addresses for the configured SDN connector with supported Kubernetes filter:
config firewall address
edit "k8s_nodename"
set type dynamic
set sdn "oci1"
set filter "K8S_NodeName=129.213.120.172"
next
end

3. Confirm that the SDN connector resolves dynamic firewall IP addresses:
config firewall address
edit "k8s_nodename"
set uuid 052f1420-3ab8-51e9-0cf8-6db6bc3395c0
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set type dynamic
set sdn "oci1"
set filter "K8S_NodeName=129.213.120.172"
config list
edit "10.0.32.2"
next
edit "10.244.2.2"
next
edit "10.244.2.3"
next
edit "10.244.2.4"
next
edit "10.244.2.5"
next
end
next
end

SSO/Identity connectors
SSO fabric connectors integrate SSO authentication into the network. This allows users to enter their credentials only
once, and have those credentials reused when accessing other network resources through the FortiGate.
The following fabric connectors are available:
l
l
l
l
l
l

FortiClient EMS connector on page 154
FortiNAC endpoint connector on page 156
Fortinet single sign-on agent on page 162
Symantec endpoint connector on page 162
Poll Active Directory server on page 170
RADIUS single sign-on (RSSO) agent on page 171

FortiClient EMS connector
This example describes how to create a FortiClient EMS connector and a user group for the connector.

To create an FortiClient EMS connector in the GUI:
1. Go to Security Fabric > Fabric Connectors.
2. Click Create New.
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3. In the SSO/Identity section, click FortiClient EMS.

4. Fill in the Name, and Primary Server IP, and select a Trusted SSL certificate.
5. Click OK.
The connector is shown on the Fabric Connectors page.

To create a user group for the EMS fabric connector using the GUI:
1. Go to User & Device > User Definition.
2. Click Create New.
3. Select FortiClient EMS User, then click Next.

4. In the Fabric Device list select the EMS fabric connector that you created.
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5. Select tags and then click Next.

6. In the Add to FSSO Group field, click Create New.
7. Enter a name for the group.

8. Click Submit.
The configured group is shown at User & Device > User Groups.

FortiNAC endpoint connector
Dynamic address definitions originating from FortiNAC can be imported to FortiGate as FSSO objects and used in
firewall policies. Changes on the FortiNAC are dynamically reflected on the FortiGate.
This example assumes that the FortiGate and FortiNAC are in the same network segment. If layer 3 routers or firewalls
are in between them, ensure that traffic on port 8000 is not blocked.
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Configuring the FortiNAC
On FortiNAC, local groups and users can be created, and they can be imported from remote servers, such as AD LDAP
and RADIUS servers. Local firewall tags, used in FortiNAC policies, are also supported.

Before creating the FortiNAC connector on the FortiGate, FSSO must be enabled:

Groups and firewall tags that will be monitored and accessed by the FortiGate must be added to a network access policy
on the FortiNAC:
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Configuring the FortiGate
To configure the FortiNAC connector in the GUI:
1. Go to Security Fabric > Fabric Connectors and click Create New.
2. In the SSO/Identity section, click FortiNAC.

3. Enter a name for the connector in the Name field, such as Fortinac-connector-1.
4. Enter the FortiNAC device's IP address and password in the Primary Server IP fields.
5. Click Apply & Refresh.
All host groups, firewall tags, and some default system groups will be pushed to the FortiGate from the FortiNAC.
6. Click View.
The Collector Agent Group Filters pane opens, showing the information pushed from FortiNAC. These objects can
be used to create FSSO user groups.
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7. Click OK.

To configure the FortiNAC connector in the CLI:
config user fsso
edit "Fortinac-connector-1"
set server "172.18.60.204"
set password XXXXXXXXXXXXXXXX
set type fortinac
next
end

To create an FSSO user group using imported FortiNAC groups and tags as members in the GUI:
1.
2.
3.
4.
5.

Go to User & Device > User Groups.
Click Create New.
In the Name field, enter a name for the group, such as Fortinac-fsso-group.
For Type, select Fortinet Single Sign-On (FSSO).
In the Members field, click +. The Select Entries pane appears. The groups and tags pulled from the FortiNAC are
shown.
6. Select the desired groups.

7. Click OK.
The group can now be used in identity based firewall policies.
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To create an FSSO user group using imported FortiNAC groups and tags as members in the CLI:
config user group
edit "Fortinac-fsso-group"
set group-type fsso-service
set authtimeout 0
set http-digest-realm ''
set member "GROUP1" "GROUP2" "TEST-TAG1"
next
end

To use the user/group creation wizard to create a new SSO group with the FortiNAC groups and firewall
tags:
1. Go to User & Device > User Definition and click Create New.

2. For the User Type, select FortiNAC User, then click Next.
3. For the Fabric Device, select the FortiNAC connector , then select the Tags.

4. Click Next.
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5. Either add the selected groups/tags to an existing SSO group, or create a new group:
l To add to an existing SSO group, click Choose Existing, and then select a group.

l

To create a new group, click Create New, and then enter a name for the group.

6. Click Next.
7. Go to User & Device > User Groups and verify that the created groups are listed with the correct members.
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Fortinet single sign-on agent
To create an FSSO agent connector in the GUI:
1. Go to Security Fabric > Fabric Connectors.
2. Click Create New.
3. In the SSO/Identity section, click Fortinet Single Sign-On Agent.

4. Fill in the Name, and Primary FSSO Agent server IP address or name and Password.
5. Optionally, add more FSSO agents by clicking the plus icon.
6. Select the User Group Source:
l Collector Agent: User groups will be pushed to the FortiGate from the collector agent. Click Apply & Refresh to
fetch group filters from the collector agent.
l Local: User groups will be specified in the FortiGate unit's configuration. Select the LDAP server from the dropdown list, then select the Users, Groups, and Organizational Units. Enable or disable Recursive as required.
7. Click OK.

Symantec endpoint connector
With the Fabric connector for Symantec Endpoint Protection Manager (SEPM), you can use the client IP information
from SEPM to assign to dynamic IP addresses on FortiOS.
When communication between FortiGate and SEPM is established, FortiGate polls every minute for updates via TLS
over port 8446. You can use the CLI to change the default one minute polling interval.
For example, you can create a dynamic Fabric Connector IP address subtype and use it in firewall policies as the source
address. The dynamic IP address contains all IP addresses sent by SEPM.
This example shows a dynamic IP address with SEPM and one client PC managed by SEPM using FortiGate as the
default gateway.

To configure SEPM on a managed client PC:
1. In SEPM, create client packages for client hosts and group them into SEPM groups.
You can install packages locally on clients or download them directly from SEPM.
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2. When a package is installed on the client host, the host is considered managed by SEPM.
Even if the host has multiple interfaces, only one IP per host is displayed.

To configure Symantec endpoint connector on FortiGate in the GUI:
1. Go to Security Fabric > Fabric Connectors.
2. Click Create New.
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3. Click Symantec Endpoint Protection.
l In the Connector Settings section, if options are left empty, then all SEPM domains and groups are monitored.
l In the Symantec Connector section:
l In the Server field, enter the SEPM IP address.
l Enter the Username and Password.
l If you want to limit the domains or groups that are monitored, enter the information in Domain and Group
name.

4. Click OK.
When the connection is established, you can see a green up arrow in the bottom right of the tile. You might need to
refresh your browser to see the established connection.

5. Go to Policy & Objects > Addresses.
6. Click Create New > Address.
l Set Type to Dynamic.
l Set Sub Type to Fabric Connector Address.
l Set SDN Connector to the Fabric Connector that you just created.
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7. Click OK.
8. Edit the address to see the configuration.
l Filter shows the hostnames of the client PCs managed by SEPM. The GUI shows the ComputerName by
default. You can change this using the CLI; see Specify filters for details.

Filter options are only available for active computers that are configured and registered in
SEPM. Free-form filters can be created manually by clicking Create and entering the filter,
in the format: filter_type=value.
Possible manual filter types are: GroupName, GroupID, ComputerName,
ComputerUUID, and OSName. For example: GroupName=MyGroup.
9. In Policy & Objects > Addresses, you can see all the IP addresses of the host.
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10. Go to Policy & Objects > IPv4 Policy, click Create New and add the dynamic IP address to the firewall policy.
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To verify the configuration:
1. On the client PC, check that it is managed by SEPM to access the Internet.

2. In FortiGate, you can check in FortiView > Sources.
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3. In FortiGate, you can also check in Log & Report > Forward Traffic.

Since this traffic is not authenticated traffic but is based on source IP address only, this
traffic is not shown in the GUI firewall monitor or in the CLI diagnose firewall auth
list command.

To configure Symantec endpoint connector on FortiGate in the CLI:
1. Create the fabric connector:
config system sdn-connector
edit "sepm-217"
set type sepm
set server "172.18.60.217"
set username "admin"
set password **********
set status enable
next
end

2. Create the dynamic IP address:
config firewall address
edit "sepm-ip"
set uuid 645552a0-d0c9-51e9-282d-c7ed6d7ee7de
set type dynamic
set sdn "sepm-217"
set filter "ComputerName=win10-1"
config list
edit "10.1.100.187"
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next
edit "10.6.30.187"
next
edit "172.16.200.187"
next
end
next
end

You can specify other filters and combine them with | and &, for example:
FGTH (sepm-ip) # set filter
<key1=value1>
[& <key2=value2>] [| <key3=value3>]
Available filter keys are:
<ComputerName><ComputerUuid><GroupId><GroupName> <DomainId><DomainName><OsName>

3. Add the dynamic IP address to the firewall policy:
config firewall policy
edit 1
set name "pol1"
set uuid 9174563c-d0c9-51e9-1a32-4e14385239e9
set srcintf "port2"
set dstintf "port1"
set srcaddr "sepm-ip"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set ssl-ssh-profile "certificate-inspection"
set av-profile "default"
set logtraffic all
set fsso disable
set nat enable
next
end

To troubleshoot Symantec SD connector in the CLI:
# diagnose debug application sepmd -1
Output is sent every minute (default). All IPv4 learned from SEPM. IPv6 also sent but not
yet supported.
2019-09-09 12:01:09 sepmd sdn connector sepm-217 start updating IP addresses
2019-09-09 12:01:09 sepmd checking firewall address object sepm-ip, vd 0
2019-09-09 12:01:09 sepmd sdn connector sepm-217 finish updating IP addresses
2019-09-09 12:01:09 sepmd reap child pid: 18079
2019-09-09 12:02:09 sepmd sdn connector sepm-217 prepare to update
2019-09-09 12:02:09 sepmd sdn connector sepm-217 start updating
2019-09-09 12:02:09 sepm-217 sdn connector will retrieve token after 9526 secs
2019-09-09 12:02:09 sym_new_ip_addr ComputerName win10-1
ComputerUuid AC894D56-BD86-A786-7DDB-7FD98B718AE0, OsName Windows 10
IP 172.16.200.187
GroupName My Company\Windows-desktops, GroupId E61FDEA2AC10C80E46D0B31BB58D7CB3
DomainName Default, DomainId 6C507580AC10C80E5F3CAED5B1711A8E
2019-09-09 12:02:09 sym_new_ip_addr ComputerName win10-1
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ComputerUuid AC894D56-BD86-A786-7DDB-7FD98B718AE0, OsName Windows 10
IP 10.6.30.187
GroupName My Company\Windows-desktops, GroupId E61FDEA2AC10C80E46D0B31BB58D7CB3
DomainName Default, DomainId 6C507580AC10C80E5F3CAED5B1711A8E
2019-09-09 12:02:09 sym_new_ip_addr ComputerName win10-1
ComputerUuid AC894D56-BD86-A786-7DDB-7FD98B718AE0, OsName Windows 10
IP 10.1.100.187
GroupName My Company\Windows-desktops, GroupId E61FDEA2AC10C80E46D0B31BB58D7CB3
DomainName Default, DomainId 6C507580AC10C80E5F3CAED5B1711A8E
2019-09-09 12:02:09 2001:0000:0000:0000:0000:0000:0000:0187 is not in IPv4 presentation
format

2019-09-09 12:02:09 sepmd sdn connector sepm-217 start updating IP addresses
2019-09-09 12:02:09 sepmd checking firewall address object sepm-ip, vd 0
2019-09-09 12:02:09 sepmd sdn connector sepm-217 finish updating IP addresses
2019-09-09 12:02:09 sepmd reap child pid: 18089
2019-09-09 12:03:09 sepmd sdn connector sepm-217 prepare to update
2019-09-09 12:03:09 sepmd sdn connector sepm-217 start updating
2019-09-09 12:03:09 sepm-217 sdn connector will retrieve token after 9466 secs
2019-09-09 12:03:09 sym_new_ip_addr ComputerName win10-1
ComputerUuid AC894D56-BD86-A786-7DDB-7FD98B718AE0, OsName Windows 10
IP 172.16.200.187
GroupName My Company\Windows-desktops, GroupId E61FDEA2AC10C80E46D0B31BB58D7CB3
DomainName Default, DomainId 6C507580AC10C80E5F3CAED5B1711A8E
2019-09-09 12:03:09 sym_new_ip_addr ComputerName win10-1
ComputerUuid AC894D56-BD86-A786-7DDB-7FD98B718AE0, OsName Windows 10
IP 10.6.30.187
GroupName My Company\Windows-desktops, GroupId E61FDEA2AC10C80E46D0B31BB58D7CB3
DomainName Default, DomainId 6C507580AC10C80E5F3CAED5B1711A8E
2019-09-09 12:03:09 sym_new_ip_addr ComputerName win10-1
ComputerUuid AC894D56-BD86-A786-7DDB-7FD98B718AE0, OsName Windows 10
IP 10.1.100.187
GroupName My Company\Windows-desktops, GroupId E61FDEA2AC10C80E46D0B31BB58D7CB3
DomainName Default, DomainId 6C507580AC10C80E5F3CAED5B1711A8E
2019-09-09 12:03:09 2001:0000:0000:0000:0000:0000:0000:0187 is not in IPv4 presentation
format

To list the SEPM daemon SDN connectors:
diagnose test application sepmd 1
sepm SDN connector list:
name: sepm-217, status: enabled, updater_interval: 60

To list the SEPM daemon SDN filters:
diagnose test application sepmd 2
sepm SDN connector sepm-217 filter list:
name: sepm-ip, vd 0, filter 'ComputerName=win10-1'

Poll Active Directory server
The FortiGate unit can authenticate users and allow them network access based on groups membership in Windows
Active Directory (AD).
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To create an AD server connector in the GUI:
1. Go to Security Fabric > Fabric Connectors.
2. Click Create New.
3. In the SSO/Identity section, click Poll Active Directory Server.

4. Fill in the Server IP/Name, User, and Password for the AD server.
5. Select the LDAP server from the list.
6. If necessary, disable Enable Polling. This can be used to temporarily stop the FortiGate from polling security event
logs on the Windows logon server, for troubleshooting purposes.
7. Click OK.

RADIUS single sign-on (RSSO) agent
With RSSO, a FortiGate can authenticate users who have authenticated on a remote RADIUS server. Based on which
user group the user belongs to, the security policy applies the appropriate UTM profiles.
The FortiGate does not interact with the remote RADIUS server; it only monitors RADIUS accounting records that the
server forwards (originating from the RADIUS client). These records include the user IP address and user group. The
remote RADIUS server sends the following accounting messages to the FortiGate:

Message

Action

Start

If the information in the start message matches the RSSO configuration on the
FortiGate, the user is added to the local list of authenticated firewall users.

Stop

The user is removed from the local list of authenticated firewall users because the
user session no longer exists on the RADIUS server.

You can configure an RSSO agent connector using the FortiOSGUI; however, in most cases, you will need to use the
CLI. There are some default options you may need to modify, which can only be done in the CLI.

To configure an RSSO agent connector:
1. Create the new connector:
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New.
c. In the SSO/Identity section, click RADIUS Single Sign-On Agent. The New Fabric Connector pane opens.
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d. Enter the connector name.
e. Enable Use RADIUS Shared Secret.
The value entered in Use RADIUS Shared Secret must be identical to what the remote
RADIUS server uses to authenticate when it sends RADIUS accounting messages to
the FortiGate.
f. Enable Send RADIUS Responses.
You should enable Send RADIUS Responses because some RADIUS servers
continue to send the same RADIUS accounting message several times if there is no
response.
g. Click OK.

2. Edit the network interface:
a. Go to Network > Interfaces.
b. Double-click the interface that will receive the RADIUS accounting messages. The Edit Interface pane opens.
c. In the Administrative Access section, select the RADIUS Accounting checkbox. This will open listening for port
1813 on this interface. The FortiGate will then be ready to receive RADIUS accounting messages.
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d. Click OK.

3. Create a local RSSO user group:
a. Go to User & Device > User Groups.
b. Click Create New.
c. Enter the group name.
d. For the Type field, click RADIUS Single-Sign-ON (RSSO).
e. Enter a value for RADIUS Attribute Value.
This value by default is the class attribute. The FortiGate uses the content of this attribute in RADIUS
accounting start messages to map a user to a FortiGate group, which then can be used in firewall policies.
In this example configuration, the FortiGate will only add a remote RADIUS user to the local firewall user list if
the class attribute in the RADIUS accounting START message contains the value group1.

If your users are in multiple groups, you will need to add another local RSSO user
group.

If the RADIUS attribute value used to map users to a local RSSO group is different than
the RADIUS attribute in the RADIUS accounting messages forwarded by the server,
you must change it in the CLI.
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f. Click OK.

4. Edit the local RSSO agent to modify default options using the CLI.
For example, the default value for rsso-endpoint-attribute might work in common remote access scenarios
where users are identified by their unique Calling-Station-Id, but in other scenarios the user name might be in
a different attribute.
config user radius
edit "Local RSSO Agent"
set rsso-endpoint-attribute <attribute>
set sso-attribute <attribute>
next
end

5. Add the local RSSO user group to a firewall policy.

Verifying the RSSO configuration
Verification requires a working remote RADIUS server configured for RADIUS accounting forwarding and wireless or
wired clients that use RADIUS for user authentication.
For a quick test, you can use one of the publicly available RADIUS test tools to send RADIUS accounting start and stop
messages to the FortiGate. You can also use radclient.

To verify the RSSO configuration:
1. In radclient, enter the RADIUS attributes. These attributes are then executed with the FortiGate IP parameters
(sends accounting messages to port 1813) and shared password you configured. -x is used for verbose output:
root@ControlPC:~# echo "Acct-Status-Type =Start,Framed-Ip-Address=10.1.100.185,UserName=test2,Acct-Session-Id=0211a4ef,Class=group1,Calling-Station-Id=00-0c-29-44-BE-B8" |
radclient -x 10.1.100.1 acct 123456
Sending Accounting-Request of id 180 to 10.1.100.1 port 1813
Acct-Status-Type = Start
Framed-IP-Address = 10.1.100.185
User-Name = "test2"
Acct-Session-Id = "0211a4ef"
Class = 0x67726f757031
Calling-Station-Id = "00-0c-29-44-BE-B8"
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rad_recv: Accounting-Response packet from host 10.1.100.1 port 1813, id=180, length=20
root@ControlPC:~#

2. Verify that the user is in the local firewall user list with the correct type (rsso) and local firewall group (rssogroup1):
# diagnose firewall auth l
10.1.100.185, test2
type: rsso, id: 0, duration: 5, idled: 5
flag(10): radius
server: vdom1
packets: in 0 out 0, bytes: in 0 out 0
group_id: 3
group_name: rsso-group-1
----- 1 listed, 0 filtered ------

Threat feeds
Threat feeds dynamically import an external block lists from an HTTP server in the form of a text file. Block lists can be
used to enforce special security requirements, such as long term policies to always block access to certain websites, or
short term requirements to block access to known compromised locations. The lists are dynamically imported, so that
any changes are immediately imported by FortiOS.
There are four types of threat feeds:
FortiGuard
Category

The file contains one URL per line. It is available as a Remote Category in Web Filter profiles and
SSL inspection exemptions.
Example:
http://example/com.url
https://example.com/url
http://example.com:8080/url

IP Address

The file contains one IP/IP range/subnet per line. It is available as an External IP Block List in
DNS Filter profiles, and as a Source/Destination in IPv4, IPv6, and proxy policies.
Example:
192.168.2.100
172.200.1.4/16
172.16.1.2/24
172.16.8.1-172.16.8.100
2001:0db8::eade:27ff:fe04:9a01/120
2001:0db8::eade:27ff:fe04:aa01-2001:0db8::eade:27ff:fe04:ab01

Domain Name

The file contains one domain per line. Simple wildcards are supported. It is available as a
Remote Category in DNS Filter profiles. See External resources for DNS filter on page 185.
Example:
mail.*.example.com
*-special.example.com
www.*example.com
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example.com

Malware Hash

The file contains one hash per line in the format <hex hash> [optional hash
description]. Each line supports MD5, SHA1, and SHA256 hex hashes. It is automatically
used for Virus Outbreak Prevention on antivirus profiles with Use External Malware Block List
enabled.
Note: For optimal performance, do not mix different hashes in the list. Only use one of MD5,
SHA1, or SHA26.
Example:
292b2e6bb027cd4ff4d24e338f5c48de
dda37961870ce079defbf185eeeef905 Trojan-Ransom.Win32.Locky.abfl
3fa86717650a17d075d856a41b3874265f8e9eab Trojan-Ransom.Win32.Locky.abfl
c35f705df9e475305c0984b05991d444450809c35dd1d96106bb8e7128b9082f
Trojan-Ransom.Win32.Locky.abfl

See External malware blocklist for antivirus on page 705 for an example.

External resources file format
File format requirements for an external resources file:
l
l
l
l
l

l
l

The file is in plain text format with each URL list, IP address, and domain name occupying one line.
The file is limited to 10 MB or 128 × 1024 (131072) entries, whichever limit is hit first.
The entry limit also follows the table size limitation defined by CMDB per model.
The external resources update period can be set to 1 minute, hourly, daily, weekly, or monthly (43200 min, 30 days).
The external resources type as category (URL list) and domain (domain name list) share the category number
range 192 to 221 (total of 30 categories).
There is no duplicated entry validation for the external resources file (entry inside each file or inside different files).
If the number of entries exceed the limit, a warning is displayed. Additional entries beyond the threshold will not be
loaded.

For domain name list (type = domain):
l
l

Simple wildcards are allowed in the domain name list, for example: *.test.com.
IDN (international domain name) is supported.

For IP address list (type = address):
l

l

The IP address can be a single IP address, subnet address, or address range. For example, 192.168.1.1,
192.168.10.0/24, or 192.168.100.1-192.168.100.254.
The address can be an IPv4 or IPv6 address. An IPv6 address does not need to be in [ ] format.

To create a threat feed in the GUI:
1. Go to Security Fabric > Fabric Connectors.
2. Click Create New.
3. In the Thread Feeds section, click on the required feed type.
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4. Configure the connector settings:
Name

Enter a name for the threat feed connector.

URI of external resource

Enter the link to the external resource file. The file should be a plain text file
with one entry on each line.

HTTP basic authentication

Enable/disable basic HTTP authentication. When enabled, enter the
username and password in the requisite fields.

Refresh Rate

The time interval to refresh the external resource, in minutes (1 - 43200,
default = 5).

Comments

Optionally, enter a description of the connector.

Status

Enable/disable the connector.

5. Click OK.

To create a threat feed in the CLI:
config system external-resource
edit <name>
set status {enable | disable}
set type {category | address | domain | malware}
set category <integer>
set username <string>
set password <string>
set comments [comments]
*set resource <resource-uri>
*set refresh-rate <integer>
set source-ip <string>
next
end

Parameters marked with a * are mandatory and must be filled in. Other parameters either have default values or are
optional.

Update history
To review the update history of a threat feed, go to Security Fabric > Fabric Connectors, select a feed, and click Edit. The
Last Update field shows the date and time that the feed was last updated.
Click View Entries to view the current entries in the list.
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External Block List (Threat Feed) – Policy
You can use the External Block List (Threat Feed) for web filtering and DNS. You can also use External Block List
(Threat Feed) in firewall policies.

Sample configuration
In Security Fabric > Fabric Connectors > Threat Feeds > IP Address, create or edit an external IP list object.

Click View Entries to see the external IP list.

To create an external iplist object using the CLI:
config system external-resource
edit "test-external-iplist-1"
set status enable
set type address
set username ''
set password ENC
set comments ''
set resource "http://10.6.30.55/ip_list_test/test-external-iplist-2.txt"
set refresh-rate 15
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next
end

To apply an external iplist object to the firewall policy using the CLI:
config firewall policy
edit 1
set name "policyid-1"
set srcintf "wan2"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "test-external-iplist-1"
set action accept
set schedule "always"
set service "ALL"
set logtraffic all
set auto-asic-offload disable
set nat enable
next
end

External Block List (Threat Feed) - Authentication
The external Threat Feed connector (block list retrieved by HTTPS) supports username and password authentication.

To enable username and password authentication:
1.
2.
3.
4.

Navigate to Security Fabric > Fabric Connectors.
Edit an existing Threat Feed or create a new one by selecting Create New.
In Connector Settings, select the HTTP basic authentication toggle to enable the feature.
Enter a username and password.

5. Select OK to save your changes.
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External Block List (Threat Feed) - File Hashes
The Malware Hash type of Threat Feed connector supports a list of file hashes that can be used as part of Virus
Outbreak Prevention.

To configure Malware Hash:
1. Navigate to Security Fabric > Fabric Connectors and click Create New.
2. In the Threat Feeds section, click Malware Hash.

The Malware Hash source objects are displayed.
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3. To configure Malware Hash, fill in the Connector Settings section.
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4. Beside the Last Update field, click View Entries to display the external Malware Hash list contents.

New Malware value for external-resource parameter in CLI
FGT_PROXY (external-resource) # edit sha1_list
new entry 'sha1_list' added
FGT_PROXY (sha1_list) # set type ?
category
FortiGuard category.
address
Firewall IP address.
domain
Domain Name.
malware
Malware hash.

To configure external Malware Hash list sources in CLI:
config global
config system external-resource
edit "md5_list"
set type malware
set comments "List of md5 hashes only"
set resource "http://172.16.200.44/outbreak/md5_list"
set refresh-rate 30
next
edit "sha1_list"
set type malware
set comments "List of sha1 hashes only"
set resource "http://172.16.200.44/outbreak/sha1_list"
set refresh-rate 30
next
edit "sha256_list"
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set
set
set
set
next

type malware
comments "List of sha256 hashes only"
resource "http://172.16.200.44/outbreak/sha256_list"
refresh-rate 30

end
end

Update to antivirus profile
In Security Profiles > AntiVirus, the Virus Outbreak Prevention section allows you to enable the following options:
l
l

Use Fortinet outbreak Prevention Database.
Use External Malware Block List.

To view Virus Outbreak Prevention options in CLI:
FGT_PROXY (vdom1) # config antivirus profile
FGT_PROXY (profile) # edit av
FGT_PROXY (av) # config outbreak-prevention
FGT_PROXY (outbreak-prevention) # set
ftgd-service
Enable/disable FortiGuard Virus outbreak prevention service.
external-blocklist
Enable/disable external malware blocklist.
FGT_PROXY (outbreak-prevention) # set
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To configure Virus Outbreak Prevention options in CLI:
You must first enable outbreak-prevention in the protocol and then enable external-blocklist under
outbreak-prevention.
config antivirus profile
edit "av"
set analytics-db enable
config http
set options scan
set outbreak-prevention full-archive
end
config ftp
set options scan
set outbreak-prevention files
end
config imap
set options scan
set outbreak-prevention full-archive
end
config pop3
set options scan
set outbreak-prevention full-archive
end
config smtp
set options scan
set outbreak-prevention files
end
config mapi
set options scan
set outbreak-prevention full-archive
end
config nntp
set options scan
set outbreak-prevention full-archive
end
config smb
set options scan
set outbreak-prevention full-archive
end
config outbreak-prevention
set ftgd-service enable
set external-blocklist enable
end
next
end

Update to utm-virus category logs
This feature adds the fields filehash and filehashsrc to outbreak prevention detection events.
Example of the utm-virus log generated when a file is detected by FortiGuard queried outbreak prevention:
2: date=2018-07-30 time=13:57:59 logid="0204008202" type="utm" subtype="virus"
eventtype="outbreak-prevention" level="warning" vd="root" evnttime=1532984279 msg="Blocked
by Virus Outbreak Prevention service." action="blocked" service="HTTP" sessionid=174777
srcip=192.168.101.20 dstip=172.16.67.148 srcport=37044 dstport=80 srcintf="lan"
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srcintfrole="lan" dstintf="wan1" dstintfrole="wan" policyid=1 proto=6 direction="incoming"
filename="zhvo_test.com" checksum="583369a5" quarskip="No-skip"
virus="503e99fe40ee120c45bc9a30835e7256fff3e46a" dtype="File Hash"
filehash="503e99fe40ee120c45bc9a30835e7256fff3e46a"
filehashsrc="fortiguard"
url="http://172.16.67.148/zhvo_test.com" profile="mhash_test" agent="Firefox/43.0"
analyticssubmit="false" crscore=30 crlevel="high&#8220;

Example of the utm-virus log generated when a file is detected by External Malware Hash List outbreak prevention:
1: date=2018-07-30 time=13:59:41 logid="0207008212" type="utm" subtype="virus"
eventtype="malware-list" level="warning" vd="root" eventtime=1532984381 msg="Blocked by
local malware list." action="blocked" service="HTTP" sessionid=174963 srcip=192.168.101.20
dstip=172.16.67.148 srcport=37045 dstport=80 srcintf="lan" srcintfrole="lan" dstintf="wan1"
dstintfrole="wan" policyid=1 proto=6 direction="incoming" filename="mhash_block.com"
checksum="90f0cb57" quarskip="No-skip" virus="mhash_block.com" dtype="File Hash"
filehash="93bdd30bd381b018b9d1b89e8e6d8753"
filehashsrc="test_list"
url="http://172.16.67.148/mhash_block.com" profile="mhash_test" agent="Firefox/43.0"
analyticssubmit="false"

External resources for DNS filter
External resources provides the ability to dynamically import an external block list into an HTTP server. This feature
enables the FortiGate to retrieve a dynamic URL, domain name, IP address, or malware hash list from an external HTTP
server periodically. The FortiGate uses these external resources as the web filter's remote categories, DNS filter's
remote categories, policy address objects, or antivirus profile's malware definitions. If external resources are updated,
FortiGate objects are also updated dynamically.
External resource is divided into four types:
l
l
l
l

URL list (type = category)
Domain name list (type = domain)
IP address list (type = address)
Malware hash list (type = malware)

Remote categories and external IP block list
The DNS filter profile can use two types of external resources: domain type (domain name list) and address type (IP
address list).
When a domain type external resource is configured, it is treated as a remote category in the DNS filter profile. If the
domain name in DNS query matches the entry in this external resource file, it is treated as the remote category and
follows the action configured for this category in DNS filter profile.
When an address type external resource is configured, it can be enabled as external-ip-blocklist in DNS filter profile. If a
DNS resolved IP address in DNS response matches the entry in the external-ip-blocklist, this DNS query is blocked by
the DNS filter.
For external resources file format and limits, see External resources file format on page 176.

Configuring external resources in the CLI
In the CLI, you can configure external resources files in an external HTTP server. Under global, configure the external
resources file location and specify the resource type.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

185

Fortinet Security Fabric

To configure external resources:
config system external-resource
edit "Ext-Resource-Type-as-Domain-1"
set type domain
set category 194
set resource "http://172.16.200.66/external-resources/Ext-Resource-Type-as-Domain1.txt"
set refresh-rate 1
next
edit "Ext-Resource-Type-as-Address-1"
set status enable
set type address
set username ''
set password
set comments ''
set resource "http://172.16.200.66/external-resources/Ext-Resource-Type-as-Address1.txt"
set refresh-rate 1
next
end

In each VDOM, the domain type external resource can be used in the DNS filter as remote category. In this example, the
domain name list in the Ext-Resource-Type-as-Domain-1.txt file is treated as a remote category (category ID 194). The
IP address list in the Ext-Resource-Type-as-Address-1.txt file can be applied in the DNS filter as an external-ipblocklist. If the DNS resolved IP address matches any entry in the list in that file, the DNS query is blocked.

To configure the external IP block list and apply it to a policy:
config dnsfilter profile
edit "default"
set comment "Default dns filtering."
config ftgd-dns
config filters
edit 1
set category 194
set action block
next
edit 2
set category 12
next
edit 3
next
end
end
set block-botnet enable
set external-ip-blocklist "Ext-Resource-Type-as-Address-1"
next
end
config firewall policy
edit 1
set name "DNSFilter"
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

186

Fortinet Security Fabric

set
set
set
set
set
set
set
set
set
set
next
end

dstaddr "all"
action accept
schedule "always"
service "ALL"
utm-status enable
logtraffic all
dnsfilter-profile "default"
profile-protocol-options "protocol"
ssl-ssh-profile "protocols"
nat enable

Configuring external resources in the GUI
To configure, edit, or view the entries for external resources from GUI:
1. Go to Global > Security Fabric > Fabric Connectors.
2. Click Create New.
3. In the Threat Feeds section, select Domain Name or IP Address.

4. Enter the Resource Name, URL, location of the resource file, resource authentication credentials, and Refresh
Rate.
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5. Click OK.

6. Double-click the Threat Feeds Object you just configured to open the Edit page.
7. Click View Entries to view the entry list in the external resources file.

8. Go to VDOM > Security Profiles > DNS Filter and open a DNS filter profile. The configured external resources
displays, and you can apply it in each DNS filter profile (remote category or external IP block lists).
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Log sample
Remote categories
Go to VDOM > Log & Report > DNS Query. Some domains that match the remote category list are rated as remote
category, overriding their original domain rating.

Log example:
1: date=2019-01-18 time=13:49:12 logid="1501054802" type="utm" subtype="dns" eventtype="dnsresponse" level="notice" vd="vdom1" eventtime=1547848151 policyid=1 sessionid=82998
srcip=10.1.100.18 srcport=42985 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
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dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="default" xid=38234
qname="www.example.com" qtype="A" qtypeval=1 qclass="IN" ipaddr="93.184.216.34" msg="Domain
is monitored" action="pass" cat=196 catdesc="Ext-Resource-Type-as-Domain-3"
2: date=2019-01-18 time=13:49:12 logid="1500054000" type="utm" subtype="dns" eventtype="dnsquery" level="information" vd="vdom1" eventtime=1547848151 policyid=1 sessionid=82998
srcip=10.1.100.18 srcport=42985 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="default" xid=38234
qname="www.example.com" qtype="A" qtypeval=1 qclass="IN"

External IP block lists
Go to VDOM > Log & Report > DNS Query. If the DNS query resolved IP address matches the entry in the externalip-blocklist, the DNS query is blocked.

Log example:
1: date=2019-01-18 time=13:50:53 logid="1501054400" type="utm" subtype="dns" eventtype="dnsresponse" level="warning" vd="vdom1" eventtime=1547848253 policyid=1 sessionid=83206
srcip=10.1.100.18 srcport=47281 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="default" xid=7501
qname="www.example.com" qtype="A" qtypeval=1 qclass="IN" msg="Domain was blocked because it
is in the domain-filter list" action="redirect" domainfilteridx=0 domainfilterlist="ExtResource-Type-as-Address-1"
2: date=2019-01-18 time=13:50:53 logid="1500054000" type="utm" subtype="dns" eventtype="dnsquery" level="information" vd="vdom1" eventtime=1547848253 policyid=1 sessionid=83206
srcip=10.1.100.18 srcport=47281 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="default" xid=7501
qname="www.example.com" qtype="A" qtypeval=1 qclass="IN"

Automation stitches
Automation stitches automate the activities between the different components in the Security Fabric, decreasing the
response times to security events. Events from any source in the Security Fabric can be monitored, and action
responses can be set up to any destination.

Automation stitches can also be used on FortiGate devices that are not part of a Security
Fabric.
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Automation stitches that use cloud-based actions, such as AWS Lambda and Azure Function, have the option to delay
an action after the previous action is completed.
An automation stitch consists of two parts, the trigger and the actions. The trigger is the condition or event on the
FortiGate that activates the action, for example, a specific log, or a failed log in attempt. The action is what the FortiGate
does in response to the trigger.
Diagnose commands are available in the CLI to test, log, and display the history and settings of stitches.

Automation stitches can only be created on the root FortiGate in a Security Fabric.

Creating automation stitches
To create an automation stitch, a trigger event and a response action or actions are selected. Automation stitches can
also be tested after they are created.

To create an automation stitch in the GUI:
1. On the root FortiGate, go to Security Fabric > Automation.
2. Click Create New. The New Automation Stitch page opens.
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3. Enter the following information:
Name

Enter a name for the automation stitch.

Status

Enable/disable the stitch.

FortiGate

Select the FortiGate device to apply the automation stitch to, or select All
FortiGates to apply it to all of them.

Trigger

Select a trigger.

Action

Select and configure one or more actions.

Minimum interval (seconds)

Enter a minimum time interval during which notifications for the same trigger
event will not be sent.
After the time interval elapses, an alert is sent that includes the last event since
the time interval elapsed.

4. Click OK.

To create an automation stitch in the CLI:
1. Create an automation trigger:
config system automation-trigger
edit <automation-trigger-name>
set trigger-type {event-based | scheduled}
set event-type <option>
set license-type <option>
set ioc-level {medium | high}
set logid <integer>
set trigger-frequency {hourly | daily | weekly | monthly}
set trigger-weekday <option>
set trigger-day <integer>
set trigger-hour <integer>
set trigger-minute <integer>
set faz-event-severity <string>
set faz-event-tags <string>
next
end

The available options will vary depending on the selected event type.
2. Create an automation action:
config system automation-action
edit <name>
set action-type <option>
set email-to <names>
set email-from <string>
set email-subject <string>
set email-body <string>
set minimum-interval <integer>
set delay <integer>
set required {enable | disable}
set aws-api-id <string>
set aws-region <string>
set aws-domain <string>
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set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set
set

aws-api-stage <string>
aws-api-path <string>
aws-api-key <string>
azure-app <string>
azure-function <string>
azure-domain <string>
azure-function-authorization {anonymous | function | admin}
azure-api-key <string>
gcp-function-region <string>
gcp-project <string>
gcp-function-domain <string>
gcp-function <string>
alicloud-account-id <string>
alicloud-region <string>
alicloud-function-domain <string>
alicloud-version <string>
alicloud-service <string>
alicloud-function <string>
alicloud-function-authorization {anonymous | function}
alicloud-access-key-id <string>
alicloud-access-key-secret <string>
protocol {http | https}
method {post | put | get | patch | delete}
uri <string>
http-body <string>
port <integer>
headers <header>
script <string>
security-tag <string>
sdn-connector <connector_name>

next
end

3. Create an automation destination:
config system automation-destination
edit <name>
set type {fortigate | ha-cluster}
set destination <serial numbers>
set ha-group-id <integer>
next
end

4. Create the automation stitch:
config system automation-stitch
edit <automation-stitch-name>
set status {enable | disable}
set trigger <trigger-name>
set action <action-name>
set destination <serial-number>
next
end

To test an automation stitch:
In the GUI, go to Security Fabric > Automation, right-click on the automation stitch and select Test Automation Stitch.
In the CLI, enter the following command:
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diagnose automation test <stitch-name> <log>

Chaining and delaying actions
Automation stitches that use cloud-based or webhook actions have the option to delay an action after the previous action
is completed. The execution of the actions can be delayed by up to 3600 seconds (one hour).
To configure this option in the GUI, select a cloud-based action, then enter the required value, in seconds, in the action
configuration's Delay field.
To configure a delay in the CLI, use the following command:
config system automation-action
edit <name>
set action-type {aws-lambda | azure-function | google-cloud-function | alicloudfunction | webhook}
set required {enable | disable}
set delay <seconds>
next
end

Triggers
The following table outlines the available automation stitch triggers:

Trigger

Description

Compromised Host

An Indicator of Compromise (IoC) is detected on a host endpoint.
The threat level must be selected and can be Medium or High. If Medium is
selected, both medium and high level threats are included.
Note: Additional actions are available only for Compromised Host triggers:
l Access Layer Quarantine
l Quarantine FortiClient via EMS
l Assign VMware NSX Security Tag
l IP Ban

Security Rating Summary

A summary is available for a recently run Security Rating.

Configuration Change

A FortiGate configuration change has occurred.

Reboot

A FortiGate is rebooting.

Low memory

This option is only available in the CLI.
Conserve mode due to low memory. See Execute a CLI script based on CPU and
memory thresholds on page 221 for an example.

High CPU

This option is only available in the CLI.
High CPU usage. See Execute a CLI script based on CPU and memory
thresholds on page 221 for an example.

License Expiry

A FortiGuard license is expiring.
The license type must be selected. Options include:
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Trigger

Description
l
l
l
l
l
l
l

FortiCare Support
FortiGuard Web Filter
FortiGuard AntiSpam
FortiGuard AntiVirus
FortiGuard IPS
FortiGuard Management Service
FortiGate Cloud

HA Failover

An HA failover is occurring.

AV & IPS DB Update

The antivirus and IPS database is updating.

FortiOS Event Log

The specified FortiOS log has occurred.
The event must be selected from the event list.

FortiAnalyzer Event Handler

The specified FortiAnalyzer event handler has occurred. See FortiAnalyzer event
handler trigger on page 195 for details.

Schedule

A scheduled monthly, weekly, daily, or hourly trigger. Set to occur on a specific
minute of an specific hour on a specific day.

FortiAnalyzer event handler trigger
You can trigger automation stitches based on FortiAnalyzer event handlers. This allows you to define rules based on
complex correlations across devices, log types, frequencies, and other criteria.
To set up a FortiAnalyzer event handler trigger:
1. Configure a FortiGate event handler on the FortiAnalyzer
2. Configure FortiAnalyzer logging on the FortiGate on page 196
3. Configure an automation stitch that is triggered by a FortiAnalyzer event handler on page 197

Configure a FortiGate event handler on the FortiAnalyzer
On the FortiAnalyzer, configure an event handler for the automation stitch. In this example, the event handler is triggered
when an administrator logs in to the FortiGate.
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To configure an event handler on the FortiAnalyzer:
1. Go to Incidents & Events > Handlers > FortiGate Event Handlers.
2. Configure an event handler for the automation stitch.

3. Click OK.

Configure FortiAnalyzer logging on the FortiGate
See FortiAnalyzer for more information.

To configure FortiAnalyzer logging in the GUI:
1. Go to Security Fabric > Settings.
2. Enable and configure FortiAnalyzer Logging.

3. Click Apply.

To configure FortiAnalyzer logging in the CLI:
config log fortianalyzer setting
set status enable
set server "10.6.30.250"
set serial "FL-4HET318900407"
set upload-option realtime
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set reliable enable
end

Configure an automation stitch that is triggered by a FortiAnalyzer event handler
When a FortiAnalyzer event handler is triggered, it sends a notification to the FortiGate automation framework, which
generates a log and triggers the automation stitch.

To configure an automation stitch that is triggered by a FortiAnalyzer event handler in the GUI:
1.
2.
3.
4.
5.

Go to Security Fabric > Automation.
Click Create New.
In the Trigger section, select FortiAnalyzer Event Handler.
Set Event handler name to the event that was created on the FortiAnalyzer.
Set the Event severity, and select or create an Event tag.

6. In the Action section, select Email and configure the email recipient and message.
7. Click OK.

To configure an automation stitch that is triggered by a FortiAnalyzer event handler in the CLI:
1. Create an automation action:
config system automation-action
edit "auto-faz-1_email"
set action-type email
set email-to "jnjssll@fortinet.com"
set email-subject "CSF stitch alert"
set email-body "User login FortiGate successfully."
next
end

2. Create an automation trigger:
config system automation-trigger
edit "auto-faz-1"
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set
set
set
set

event-type faz-event
faz-event-name "system-log-handler2"
faz-event-severity "medium"
faz-event-tags "User login successfully"

next
end

3. Create the automation stitch:
config system automation-stitch
edit "auto-faz-1"
set trigger "auto-faz-1"
set action "auto-faz-1_email"
next
end

View the trigger event log
To see the trigger event log in the GUI:
1. Log in to the FortiGate.
The FortiAnalyzer sends notification to the FortiGate automation framework, generates an event log on the
FortiGate, and triggers the automation stitch.
2. Go to Log & Report > Events and select System Events.

To see event logs in the CLI:
execute log display
...
date=2019-02-05 time=14:16:17 logid="0100046600" type="event" subtype="system"
level="notice" vd="root" eventtime=1549404977 logdesc="Automation stitch triggered"
stitch="auto-faz-1" trigger="auto-faz-1" from="log" msg="stitch:auto-faz-1 is triggered."
...

Sample email
The email sent by the action will look similar to the following:
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Actions
The following table outlines the available automation stitch actions. Multiple actions can be added and reorganized as
needed by dragging and dropping.

Action

Description

Alert

Generate a FortiOS dashboard alert.
This option is only available in the CLI.

CLI Script

Run one or more CLI scripts. See CLI script action on page 200 for details. See
Execute a CLI script based on CPU and memory thresholds on page 221 for an
example.

Disable SSID

Disable the SSID interface.
This option is only available in the CLI.

Email

Send a custom email message to the selected recipients. At least one recipient
and an email subject must be specified.
The email body can use parameters from logs or previous action results.
Wrapping the parameter with %% will replace the expression with the JSON value
for the parameter, for example: %%results.source%% is the source property from
the previous action.

FortiExplorer Notification

Send push notifications to FortiExplorer.
The FortiGate must be registered to FortiCare on the iOS App that will receive the
notification.

Access Layer Quarantine

This option is only available for Compromised Host triggers.
Impose a dynamic quarantine on multiple endpoints based on the access layer.

Quarantine FortiClient via
EMS

This option is only available for Compromised Host triggers.
Use FortiClient EMS to block all traffic from the source addresses that are flagged
as compromised hosts.
Quarantined devices are flagged on the Security Fabric topology views. Go to
Monitor > Quarantine Monitor to view and manage quarantined IP addresses.

Assign VMware NSX Security
Tag

This option is only available for Compromised Host triggers.

IP Ban

This option is only available for Compromised Host triggers.

If an endpoint instance in a VMware NSX environment is compromised, the
configured security tag is assigned to the compromised endpoint. See NSX
Quarantine action on page 202 for details.

Block all traffic from the source addresses flagged by the IoC.
Go to Monitor > Quarantine Monitor to view and manage banned IP addresses.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

199

Fortinet Security Fabric

Action

Description

AWS Lambda

Send log data to an integrated AWS service. See AWS Lambda action on page
205 for details.

Azure Function

Send log data to an Azure function. See Azure Function action on page 207 for
details.

Google Cloud Function

Send log data to a Google Cloud function. See Google Cloud Function action on
page 209 for details.

AliCloud Function

Send log data to an AliCloud function. See AliCloud Function action on page 211
for details.

Webhook

Send an HTTP request using a REST callback. See Webhook action on page 214
for details, and Slack integration webhook on page 220 for an example.

CLI script action
CLI scripts can be run when an automation stitch is triggered. The scripts can be manually entered, uploaded as a file, or
recorded in the CLI console. The output of the script can be sent as an email action.
In this example, the script sets the idle timeout value to 479 minutes, and sends an email with the script output.

To configure a CLI script automation stitch in the GUI:
1.
2.
3.
4.
5.
6.

Go to Security Fabric > Automation.
Click Create New.
Enter a name for the stitch, and select the FortiGate devices that it will be applied to.
Select a trigger, such as Security Rating Summary.
Select CLI Script and Email actions.
Configure the CLI script:
l

To manually enter the script, type it into the Script field.

l

To upload a script file, click Upload and locate the file on your management computer.
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l

To record the script in the CLI console, click >_Record in CLI console, then enter the CLI commands.

7. Configure the email action.
8. Click OK.

To configure a CLI script automation stitch in the CLI:
1. Create an automation action:
config system automation-action
edit "set admintimeout479"
set action-type cli-script
set minimum-interval 0
set delay 0
set required enable
set script "config system global
set admintimeout 480
end"
next
edit "auto-cli-1_email"
set action-type email
set email-to "jnkssll@fortinet.com"
set email-subject "CSF stitch alert"
set email-body "%%results%%"
set minimum-interval 0
next
end

2. Create an automation trigger:
config system automation-trigger
edit "auto-cli-1"
set trigger-type event-based
set event-type security-rating-summary
next
end

3. Create the automation stitch:
config system automation-stitch
edit "auto-cli-1"
set status enable
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set trigger "auto-cli-1"
set action "set admintimeout479
end

Email sample
The email sent by the action will look similar to the following:

NSX Quarantine action
If an endpoint instance in a VMware NSX environment is compromised, this action will assign the configured security tag
is to the compromised endpoint.
This action is only available when the automation trigger is set to compromised host.
To set up the NSX quarantine action, you need to:
1. Configure a VMware NSX SDN connector
2. Configure an NSX security tag automation stitch
3. Configure FortiAnalyzer logging on the FortiGate

Configure a VMware NSX SDN connector
The FortiGate retrieves security tags from the VMware NSX server through the connector.

To configure a VMware NSX SDN connector in the GUI:
1.
2.
3.
4.

Go to Security Fabric > Fabric Connectors
Click Create New.
Select VMware NSX
Configure the settings.

5. Click OK.
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To configure a VMware NSX SDN connector in the CLI:
config system sdn-connector
edit "nsx"
set type nsx
set server "172.18.64.32"
set username "admin"
set password xxxxxx
next
end

Configure an NSX security tag automation stitch
Security tags are retrieved from the VMware NSX server through the NSX SDN connector.

To configure an NSX security tag automation stitch in the GUI:
1.
2.
3.
4.
5.

Go to Security Fabric > Automation.
Click Create New.
In the Trigger section, select Compromised Host.
In the Action section, select Assign VMware NSX Security Tag.
Configure the settings.

6. Click OK.

To configure an NSX security tag automation stitch in the CLI:
1. Create an automation action:
config system automation-action
edit "pcui-test_quarantine-nsx"
set action-type quarantine-nsx
set security-tag "pcui-tag2"
set sdn-connector "nsx"
next
end

2. Create an automation trigger:
config system automation-trigger
edit "pcui-test"
set ioc-level high
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next
end

3. Create the automation stitch:
config system automation-stitch
edit "pcui-test"
set trigger "pcui-test"
set action "pcui-test_quarantine-nsx"
next
end

Configure FortiAnalyzer logging on the FortiGate
The FortiAnalyzer is used to send endpoint compromise notification to the FortiGate.
See FortiAnalyzer on page 72 for more information.

To configure FortiAnalyzer logging in the GUI:
1. Go to Security Fabric > Settings.
2. Enable and configure FortiAnalyzer Logging.

3. Click Apply.

To configure FortiAnalyzer logging in the CLI:
config log fortianalyzer setting
set status enable
set server "172.18.64.234"
set serial "FL-8HFT718900132"
set upload-option realtime
set reliable enable
end

When an endpoint instance is compromised
When an endpoint instance, such as pcui-ubuntu2, in the VMware NSX environment is compromised, the automation
stitch is triggered. The FortiGate then assigns the configured security tag, pcui-tag2 in this example, to the compromised
NSX endpoint instance.
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AWS Lambda action
AWS Lambda functions can be called when an automation stitch is triggered.

To configure an AWS Lambda function automation stitch in the GUI:
1.
2.
3.
4.
5.

Go to Security Fabric > Automation.
Click Create New.
Enter a name for the stitch, and select the FortiGate devices that it will be applied to.
Select a trigger, such as Security Rating Summary.
Select AWS Lambda Function and configure its settings.

Name

The action name.

Delay

The amount of time after the previous action before this action executes, in
seconds (0 - 3600, default = 0).

API gateway

The API gateway URL, in the format:
{restapi-id}.execute-api.{region}.{domain}/{stage}/{path}

The CLI must be used to manually enter the individual parameters.
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API key

The API key configured in your API gateway.

HTTP header

The HTTP request header name and value. Multiple headers can be added.

+

Click to add another action.
Actions can be reorganized as needed by dragging and dropping.

Name

The action name.

Delay

The amount of time after the previous action before this action executes, in
seconds (0 - 3600, default = 0).

6. Click OK.

To configure an AWS Lambda function automation stitch in the CLI:
1. Create an automation action:
config system automation-action
edit "aws-action-1"
set action-type aws-lambda
set aws-api-id "0100032001"
set aws-region "us-east-2"
set aws-api-stage "default"
set aws-api-path "jkato-automation-FGT-lambda002"
set aws-api-key ENC
nx8q83OxafVTdmAKv77GIdLYthROoRXmtYsrpF4wtuvfIMlSHvHxE9EYo8W/jquj0p5GRsZOMDrgG1zB0oUq7bvo
guLUa/Jx4IV0DgwzOWRUruoWEIIHQBHJWSnnrswbw1O0Px+p3uz4azh4XkR+Vi+U8/ngGoLKLtwWHn53Oa4YbK7w
+mKz1BJVV+DlbCfDkPmPkA==
next
end

2. Create an automation trigger:
config system automation-trigger
edit "auto-aws"
set event-type security-rating-summary
next
end

3. Create the automation stitch:
config system automation-stitch
edit "auto-aws"
set trigger "auto-aws"
set action "aws-action-1"
next
end

When the automation stitch is triggered, the FortiGate shows the stitch trigger time:
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In AWS, the log shows that the function was called, executed, and finished.

Azure Function action
Azure functions can be called when an automation stitch is triggered.

To configure an Azure function automation stitch in the GUI:
1.
2.
3.
4.
5.

Go to Security Fabric > Automation.
Click Create New.
Enter a name for the stitch, and select the FortiGate devices that it will be applied to.
Select a trigger, such as Security Rating Summary.
Select Azure Function and configure its settings.

Name

The action name.

Delay

The amount of time after the previous action before this action executes, in
seconds (0 - 3600, default = 0).

API gateway

The API gateway URL, in the format:
{application}.{domain}/api/{function}

The CLI must be used to manually enter the individual parameters.
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Authorization

The authorization level: Anonymous, Function, or Admin.

API key

The API key configured in your API gateway.
This options is only available when Authorization is not Anonymous.

HTTP header

The HTTP request header name and value. Multiple headers can be added.

+

Click to add another action.
Actions can be reorganized as needed by dragging and dropping.

6. Click OK.

To configure an Azure function automation stitch in the CLI:
1. Create an automation action:
config system automation-action
edit "azure_function"
set action-type azure-function
set azure-app "liang01-no-delete-jlum"
set azure-function "headersResponse"
set azure-function-authorization function
set azure-api-key xxxxxx
set headers "header1:value1" "header2:value2"
next
end

2. Create an automation trigger:
config system automation-trigger
edit "auto-azure"
set event-type security-rating-summary
next
end

3. Create the automation stitch:
config system automation-stitch
edit "auto-azure"
set trigger "auto-azure"
set action "azure_function"
next
end

When the automation stitch is triggered, the FortiGate shows the stitch trigger time:
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In Azure, the function log shows that the function was called, executed, and finished:

Google Cloud Function action
Google Cloud functions can be called when an automation stitch is triggered.

To configure a Google Cloud function automation stitch in the GUI:
1.
2.
3.
4.
5.

Go to Security Fabric > Automation.
Click Create New.
Enter a name for the stitch, and select the FortiGate devices that it will be applied to.
Select a trigger, such as Security Rating Summary.
Select Google Cloud Function and configure its settings.

Name
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Delay

The amount of time after the previous action before this action executes, in
seconds (0 - 3600, default = 0).

API gateway

The API gateway URL, in the format:
{region}-{project}{domain}/{function}

The CLI must be used to manually enter the individual parameters.
HTTP header

The HTTP request header name and value. Multiple headers can be added.

+

Click to add another action.
Actions can be reorganized as needed by dragging and dropping.

6. Click OK.

To configure a Google Cloud function automation stitch in the CLI:
1. Create an automation action:
config system automation-action
edit "google-echo"
set action-type google-cloud-function
set gcp-function-region "us-central1"
set gcp-project "dev-project-001-166400"
set gcp-function-domain "cloudfunctions.net"
set gcp-function "jlum-echo"
set headers "echo-header:echo-value"
next
end

2. Create an automation trigger:
config system automation-trigger
edit "auto-google1"
set event-type security-rating-summary
next
end

3. Create the automation stitch:
config system automation-stitch
edit "auto-google1"
set trigger "auto-google1"
set action "google-echo"
next
end

When the automation stitch is triggered, the FortiGate shows the stitch trigger time:
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In Google Cloud, go to Logs to see the function log showing that the configured function was called, executed, and
finished:

AliCloud Function action
AliCloud functions can be called when an automation stitch is triggered.

To configure an AliCloud function automation stitch in the GUI:
1.
2.
3.
4.

Go to Security Fabric > Automation.
Click Create New.
Enter a name for the stitch, and select the FortiGate devices that it will be applied to.
Select a trigger, such as Security Rating Summary.
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5. Select AliCloud Function and configure its settings.

Name

The action name.

Delay

The amount of time after the previous action before this action executes, in
seconds (0 - 3600, default = 0).

HTTP URL

The HTTP URL, in the format:
{account id}.{region}.{domain}/{version}/proxy/{service}/
{function}

The CLI must be used to manually enter the individual parameters.
Authorization

The authorization level: Anonymous, or Function.

AccessKey ID

The access key ID
This options is only available when Authorization is Function.

AccessKey Secret

The access key secret.
This options is only available when Authorization is Function.

HTTP header

The HTTP request header name and value. Multiple headers can be added.

+

Click to add another action.
Actions can be reorganized as needed by dragging and dropping.

6. Click OK.

To configure an AliCloud function automation stitch in the CLI:
1. Create an automation action:
config system automation-action
edit "Ali-Action-1"
set action-type alicloud-function
set alicloud-account-id "5594200612296301"
set alicloud-region "us-east-1"
set alicloud-version "2016-08-15"
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set
set
set
set
set

alicloud-service "jlum-test-function"
alicloud-function "echoBodyAuth"
alicloud-function-authorization function
alicloud-access-key-id "LTAIKmERWEuEOChg"
alicloud-access-key-secret xxxxxx

next
end

2. Create an automation trigger:
config system automation-trigger
edit "auto-ali"
set event-type security-rating-summary
next
end

3. Create the automation stitch:
config system automation-stitch
edit "auto-ali"
set trigger "auto-ali"
set action "Ali-Action-1"
next
end

When the automation stitch is triggered, the FortiGate shows the stitch trigger time:

In AliCloud, the function log shows that the function was called, executed, and finished:
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Webhook action
The webhook automation stitch action makes HTTP and HTTPS requests to a specified server, with custom headers,
bodies, ports, and methods. It can be used to leverage the ubiquity of HTML requests and APIs to integrate with many
other tools.
The URI and HTTP body can use parameters from logs or previous action results. Wrapping
the parameter with %% will replace the expression with the JSON value for the parameter, for
example: %%results.source%% is the source property from the previous action.
In this example, a specific log message (failed administrator log in attempt) triggers the FortiGate to send the contents of
the log to a server. The server responds with a generic reply. This example assumes that the server is already
configured and able to communicate with the FortiGate.

To configure the webhook automation stitch in the GUI:
1.
2.
3.
4.
5.

Go to Security Fabric > Automation.
Click Create New.
Enter a name for the stitch, and select the FortiGate devices that it will be applied to.
Select the trigger FortiOS Event Log.
Set Event to Admin login failed.
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6. Select Webhook and configure the settings:

Name

The action name.

Delay

The amount of time after the previous action before this action executes, in
seconds (0 - 3600, default = 0).

Protocol

The request protocol to use: HTTP or HTTPS.

Method

The request method: POST, PUT, GET, PATCH, or DELETE.

URI

The request API URI.

Port

The protocol port.

HTTP body

The request body, if required, as a serialized JSON string.
Use the parameter %%log%% to send the contents of the log from the trigger.

HTTP header

The HTTP request header name and value.

+

Click to add another action.
Actions can be reorganized as needed by dragging and dropping.

7. Click OK.

To configure the webhook automation stitch in the CLI:
1. Create the automation action:
config system automation-action
edit "Send Log To Server"
set action-type webhook
set uri "172.16.200.44"
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set http-body "%%log%%"
set port 80
set headers "Header:1st Action"
next
end

2. Create an automation trigger:
config system automation-trigger
edit "badLogin"
set event-type event-log
set logid 32002
next
end

3. Create the automation stitch:
config system automation-stitch
edit "badLogin"
set trigger "badLogin"
set action "Send Log To Server"
next
end

To test the automation stitch:
1. Attempt to log in to the FortiGate with an incorrect username or password.
2. On the server, check the log to see that its contents have been sent by the FortiGate.

The body content is replaced with the log of the trigger.
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3. On the FortiGate, go to Log & Report > Events and select System Events to confirm that the stitch was activated.

4. Go to Security Fabric > Automation to see the last time that the stitch was triggered.

Diagnose commands
l

Enable log dumping:
# diagnose test application autod 1
autod dumped total:1 logs, num of logids:1
autod log dumping is enabled
vdom:root(0) logid:32002 len:408 log:
date=2019-05-30 time=17:41:03 logid="0100032002" type="event" subtype="system"
level="alert" vd="root" eventtime=1559263263858888451 tz="-0700" logdesc="Admin login
failed" sn="0" user="admin" ui="http(10.6.30.254)" method="http" srcip=10.6.30.254
dstip=10.6.30.5 action="login" status="failed" reason="passwd_invalid"
msg="Administrator admin login failed from http(10.6.30.254) because of invalid
password"
autod log dumping is disabled
autod logs dumping summary:
logid:32002 count:1
autod dumped total:1 logs, num of logids:1
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l

Show automation settings:
# diagnose test application autod 2
csf: enabled
root:yes
total stitches activated: 2
stitch: badLogin
destinations: all
trigger: badLogin
local hit: 6 relayed to: 6 relayed from: 6
actions:
Send Log To Server type:webhook interval:0
delay:0 required:no
proto:0 method:0 port:80
uri: 172.16.200.44
http body: %%log%%
headers:
0. Header:1st Action

l

Show automation statistics:
# diagnose test application autod 3
stitch: badLogin
local hit: 1 relayed to: 1 relayed from: 1
last trigger:Wed Jul 10 12:14:14 2019
last relay:Wed Jul 10 12:14:14 2019
actions:
Send Log To Server:
done: 1 relayed to: 1 relayed from: 1
last trigger:Wed Jul 10 12:14:14 2019
last relay:Wed Jul 10 12:14:14 2019
logid2stitch mapping:
id:32002 local hit: 3 relayed to: 3 relayed from: 3
badLogin
action run cfg&stats:
total:55 cur:0 done:55 drop:0
email:
flags:10
stats: total:4
ios-notification:
flags:1
stats: total:0
alert:
flags:0
stats: total:0
disable-ssid:
flags:7
stats: total:0
quarantine:
flags:7
stats: total:0
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quarantine-forticlient:
flags:4
stats: total:0 cur:0 done:0 drop:0
quarantine-nsx:
flags:4
stats: total:0 cur:0 done:0 drop:0
ban-ip:
flags:7
stats: total:0 cur:0 done:0 drop:0
aws-lambda:
flags:11
stats: total:21 cur:0 done:21 drop:0
webhook:
flags:11
stats: total:6 cur:0 done:6 drop:0
cli-script:
flags:10
stats: total:4 cur:0 done:4 drop:0
azure-function:
flags:11
stats: total:0 cur:0 done:0 drop:0
google-cloud-function:
flags:11
stats: total:0 cur:0 done:0 drop:0
alicloud-function:
flags:11
stats: total:20 cur:0 done:20 drop:0
l

Enable debug output and turn on automation debug messages for about 30 minutes:
# diagnose debug enable
# diagnose debug application autod -1
__auto_generate_generic_curl_request()-358: Generating generic automation CURL request
for action (Send Log To Server).
__auto_generate_generic_curl_request()-406: Generic automation CURL request POST data
for action (Send Log To Server):
date=2019-05-30 time=16:44:43 logid="0100032002" type="event" subtype="system"
level="alert" vd="root" eventtime=1559259884209355090 tz="-0700" logdesc="Admin login
failed" sn="0" user="admin" ui="http(10.6.30.254)" method="http" srcip=10.6.30.254
dstip=10.6.30.5 action="login" status="failed" reason="passwd_invalid"
msg="Administrator admin login failed from http(10.6.30.254) because of invalid
password"
__auto_generic_curl_request_close()-512: Generic CURL request response body from
http://172.16.200.44:
{
"userId": 1,
"id": 1,
"title": "Test Response",
"body": "ABCDEFGHIJKLMNOPQRSTUVWXYZ"
}
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Slack integration webhook
A webhook can be created to post messages and notifications to Slack. For information about using incoming webhooks
in Slack, see https://api.slack.com/incoming-webhooks.
In this example, a configuration change triggers the FortiGate to post a message to Slack.

To create a webhook automation stitch for Slack integration in the GUI:
1.
2.
3.
4.
5.

Go to Security Fabric > Automation.
Click Create New.
Enter a name for the stitch.
Select the trigger Configuration Change.
Select Webhook and configure the settings:

6. Click OK.

To create a webhook automation stitch for Slack integration in the CLI:
1. Create the automation action:
config system automation-action
edit "send to Slack"
set action-type webhook
set protocol https
set uri "hooks.slack.com/services/XXXXXXXX"
set http-body "{\"channel\": \"#delivery\", \"username\": \"tleela\", \"text\":
\"Configuration changed\", \"icon_emoji\": \":worried:\"}"
set port 443
set headers "Content-type:application/json"
next
end
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2. Create the automation trigger:
config system automation-trigger
edit "config change"
set event-type config-change
next
end

3. Create the automation stitch:
config system automation-stitch
edit "Slack"
set trigger "config change"
set action "send to Slack"
next
end

Execute a CLI script based on CPU and memory thresholds
Automation stitches can be created to run a CLI script and send an email message when CPU or memory usage
exceeds specified thresholds.
In this example, two automation stitches are created that run a CLI script to collect debug information, and then email the
results of the script to a specified email address when CPU usage threshold is exceeded or memory usage causes the
FortiGate to enter conserve mode.

Automation stitches that use High CPU and Conserve Mode triggers can only be created in the
CLI. Once create, they can be edited in the GUI.

To define CPU and memory usage thresholds:
config system global
set cpu-use-threshold <percent>
set memory-use-threshold-extreme <percent>
set memory-use-threshold-green <percent>
set memory-use-threshold-red <percent>
end

Where:
cpu-use-threshold

Threshold at which CPU usage is reported, in percent of total possible CPU
utilization (default = 90).

memory-use-threshold-extreme

Threshold at which memory usage is considered extreme, and new sessions are
dropped, in percent of total RAM (default = 95).

memory-use-threshold-green

Threshold at which memory usage forces the FortiGate to exit conserve mode, in
percent of total RAM (default = 82).

memory-use-threshold-red

Threshold at which memory usage forces the FortiGate to enter conserve mode,
in percent of total RAM (default = 88).
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Configure the automation stitches
High CPU usage stitch
To create an automation stitch for high CPU usage:
1. Create an automation action to run a CLI script:
config system automation-action
edit "high_cpu_debug"
set action-type cli-script
set required enable
set script "diagnose debug cli 8
diagnose debug console timestamp enable
diagnose debug enable
diagnose debug crashlog read
get system performance status
get system session status
diagnose sys session full-stat
diagnose firewall iprope state
diagnose sys flash list
diagnose hardware sysinfo memory
diagnose hardware sysinfo slab
diagnose hardware sysinfo shm
diagnose hardware deviceinfo disk
get system arp
diagnose ip arp list
diagnose ip address list
get router info routing-table all
get router info kernel
diagnose ip rtache list
diagnose sys top-summary
diagnose sys top 9 99"
next
end

2. Create an automation action to send an email:
config system automation-action
edit "auto_high_cpu_email"
set action-type email
set email-to "person@fortinet.com"
set email-subject "CSF stitch alert: high_cpu"
set email-body "%%results%%"
next
end

3. Create an automation trigger:
config system automation-trigger
edit "auto_high_cpu"
set event-type high-cpu
next
end
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4. Create an automation stitch:
config system automation-stitch
edit "auto_high_cpu"
set trigger "auto_high_cpu"
set action "high_cpu_debug" "auto_high_cpu_email"
next
end

To edit the automation stitch in the GUI:
1. Go to Security Fabric > Automation.
2. Double click on the auto_high_cpu stitch.

3. Edit the stitch as required, then click OK.

High memory usage stitch
To create an automation stitch for high memory usage:
1. Create an automation action to run a CLI script:
config system automation-action
edit "high_memory_debug"
set action-type cli-script
set required enable
set script "diagnose debug cli 8
diagnose debug console timestamp enable
diagnose debug enable
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diagnose debug crashlog read
get system performance status
get system session status
diagnose sys session full-stat
diagnose firewall iprope state
diagnose sys flash list
diagnose hardware sysinfo memory
diagnose hardware sysinfo slab
diagnose hardware sysinfo shm
diagnose hardware deviceinfo disk
get system arp
diagnose ip arp list
diagnose ip address list
get router info routing-table all
get router info kernel
diagnose ip rtache list
diagnose sys top-summary
diagnose sys top 9 99"
next
end

2. Create an automation action to send an email:
config system automation-action
edit "auto_high_memory_email"
set action-type email
set email-to "person@fortinet.com"
set email-subject "CSF stitch alert: high_memory"
set email-body "%%results%%"
next
end

3. Create an automation trigger:
config system automation-trigger
edit "auto_high_memory"
set event-type low-memory
next
end

4. Create an automation stitch:
config system automation-stitch
edit "auto_high_memory"
set trigger "auto_high_memory"
set action "high_memory_debug" "auto_high_memory_email"
next
end
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To edit the automation stitch in the GUI:
1. Go to Security Fabric > Automation.
2. Double click on the auto_high_memory stitch.

3. Edit the stitch as required, then click OK.

Results
When FortiGate enters conserve mode due to the memory-use-threshold-red being exceeded, the GUI displays a
notice, and the auto_high_memory automation stitch is triggered, causing the CLI script to run and the results of the
script to be emailed to the specified address.

Here is an example of the email message:
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CSF stitch alert: high_memory
noreply@notification.fortinet.net
Thu 11/21/2019 11:06 AM
James Li
FGT[FGVM16TM19000026] Automation Stitch:auto_high_memory is triggered.
########## script name: autod.47 ##########
========== #1, 2019-11-21 11:07:24 ==========
FGVM16TM19000026 $ diag deb cli 8
Debug messages will be on for 25 minutes.
FGVM16TM19000026 $ diag deb console timestamp enable
FGVM16TM19000026 $ diag deb enable
FGVM16TM19000026 $ diag deb crashlog read
1: 2019-08-08 11:35:25 the killed daemon is /bin/dhcpcd: status=0x0
2: 2019-08-08 17:52:47 the killed daemon is /bin/pyfcgid: status=0x0
3: 2019-08-23 11:32:31 from=license status=INVALID
4: 2019-08-23 11:32:32 from=license status=INVALID
5: 2019-11-21 09:53:31 from=license status=VALID
...

Diagnostics
Diagnose commands are available to:
l
l
l
l

Test an automation stitch
Enable or disable log dumping for automation stitches
Display the settings of every automation stitch
Display statistics on every automation stitch

To test an automation stitch:
diagnose automation test <automation-stitch-name>

Example:
# diagnose automation test HA-failover
automation test is done. stitch:HA-failover

To toggle log dumping:
diagnose test application autod 1

Examples:
# diagnose test application autod 1
autod log dumping is enabled
# diagnose test application autod 1
autod log dumping is disabled
autod logs dumping summary:
autod dumped total:7 logs, num of logids:4

To display the settings for all of the automation stitches:
diagnose test application autod 2
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Example:
# diagnose test application autod 2
csf: enabled root:yes
total stitches activated: 3
stitch: Compromised-IP-Banned
destinations: all
trigger: Compromised-IP-Banned
local hit: 0 relayed to: 0 relayed from: 0
actions:
Compromised-IP-Banned_ban-ip type:ban-ip interval:0
stitch: HA-failover
destinations: HA-failover_ha-cluster_25;
trigger: HA-failover
local hit: 0 relayed to: 0 relayed from: 0
actions:
HA-failover_email type:email interval:0
subject: HA Failover
mailto:admin@example.com;
stitch: rebooot
destinations: all
trigger: reboot
local hit: 0 relayed to: 0 relayed from: 0
actions:
action1 type:alicloud-function interval:0
delay:1 required:yes
Account ID: id
Region: region
Function domain: fc.aliyuncs.com
Version: versoin
Service name: serv
Function name: funcy
headers:

To display statistic on all of the automation stitches:
diagnose test application autod 3

Example:
stitch: Compromised-IP-Banned
local hit: 0 relayed to: 0 relayed from: 0
last trigger:Wed Dec 31 20:00:00 1969
last relay:Wed Dec 31 20:00:00 1969
actions:
Compromised-IP-Banned_ban-ip:
done: 1 relayed to: 0 relayed from: 0
last trigger:Wed Dec 31 20:00:00 1969
last relay:
stitch: HA-failover
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local hit: 0 relayed to: 0 relayed from: 0
last trigger:Thu May 24 11:35:22 2018
last relay:Thu May 24 11:35:22 2018
actions:
HA-failover_email:
done: 1 relayed to: 1 relayed from: 1
last trigger:Thu May 24 11:35:22 2018
last relay:Thu May 24 11:35:22 2018
stitch: rebooot
local hit: 2 relayed to: 1 relayed from: 1
last trigger:Fri May 3 13:30:56 2019
last relay:Fri May 3 13:30:23 2019
actions:
action1
done: 1 relayed to: 0 relayed from: 0
last trigger:Fri May 3 13:30:56 2019
last relay:
logid2stitch mapping:
id:20103 local hit: 0 relayed to: 0 relayed from: 0
License Expiry
lambada
id:32138 local hit: 2 relayed to: 1 relayed from: 1
Compromised-IP-Banned
HA-failover
rebooot
action run cfg&stats:
total:2 cur:0 done:1 drop:1
email:
flags:10
stats: total:1 cur:0
ios-notification:
flags:1
stats: total:0 cur:0
alert:
flags:0
stats: total:0 cur:0
disable-ssid:
flags:7
stats: total:0 cur:0
quarantine:
flags:7
stats: total:0 cur:0
quarantine-forticlient:
flags:4
stats: total:0 cur:0
quarantine-nsx:
flags:4
stats: total:0 cur:0
ban-ip:
flags:7
stats: total:0 cur:0
aws-lambda:
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done:0 drop:0

done:0 drop:0

done:0 drop:0

done:0 drop:0

done:0 drop:0

done:0 drop:0

done:0 drop:0
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flags:11
stats: total:0 cur:0 done:0 drop:0
webhook:
flags:11
stats: total:0
cli-script:
flags:10
stats: total:0
azure-function:
flags:11
stats: total:1
google-cloud-function:
flags:11
stats: total:0
alicloud-function:
flags:11
stats: total:0

cur:0 done:0 drop:0

cur:0 done:0 drop:0

cur:0 done:0 drop:1

cur:0 done:0 drop:0

cur:0 done:0 drop:0

Security Fabric over IPsec VPN
This is an example of configuring Security Fabric over IPsec VPN.

Sample topology
This sample topology shows a downstream FortiGate (HQ2) connected to the root FortiGate (HQ1) over IPsec VPN to
join Security Fabric.

Sample configuration
To configure the root FortiGate (HQ1):
1. Configure interface:
a. In the root FortiGate (HQ1), go to Network > Interfaces.
b. Edit port2:
l Set Role to WAN.
l For the interface connected to the Internet, set the IP/Network Mask to 10.2.200.1/255.255.255.0
c. Edit port6:
l Set Role to DMZ.
l For the interface connected to FortiAnalyzer, set the IP/Network Mask to 192.168.8.250/255.255.255.0
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2. Configure the static route to connect to the Internet:
a. Go to Network > Static Routes and click Create New.
l Set Destination to 0.0.0.0/0.0.0.0.
l Set Interface to port2.
l Set Gateway Address to 10.2.200.2.
3. Configure IPsec VPN:
a. Go to VPN > IPsec Wizard.
l Set VPN Name to To-HQ2.
l Set Template Type to Custom.
l Click Next.
l Set Authentication to Method.
l Set Pre-shared Key to 123456.
b. Leave all other fields in their default values and click OK.
4. Configure the IPsec VPN interface IP address which will be used to form Security Fabric:
a. Go to Network > Interfaces.
b. Edit To-HQ2:
l Set Role to LAN.
l Set the IP/Network Mask to 10.10.10.1/255.255.255.255.
l Set Remote IP/Network Mask to 10.10.10.3/255.255.255.0.
5. Configure IPsec VPN local and remote subnet:
a. Go to Policy & Objects > Addresses.
l Click Create New
l Set Name to To-HQ2_local_subnet_1.
l Set Type to Subnet.
l Set IP/Network Mask to 192.168.8.0/24.
l Click OK.
l Click Create New
l Set Name to To-HQ2_remote_subnet_1.
l Set Type to Subnet.
l Set IP/Network Mask to 10.1.100.0/24.
l Click OK.
l Click Create New
l Set Name to To-HQ2_remote_subnet_2.
l Set Type to Subnet.
l Set IP/Network Mask to 10.10.10.3/32.
l Click OK.
6. Configure IPsec VPN static routes:
a. Go to Network > Static Routes and click Create New.
l For Named Address, select Type and select To-HQ2_remote_subnet_1.
l Set Interface to To-HQ2.
l Click OK.
b. Click Create New.
l For Named Address, select Type and select To-HQ2_remote_subnet_1.
l Set Interface to Blackhole.
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Set Administrative Distance to 254.
Click OK.
7. Configure IPsec VPN policies:
a. Go to Policy & Objects > IPv4 Policy and click Create New.
l Set Name to vpn_To-HQ2_local.
l Set Incoming Interface to port6.
l Set Outgoing Interface to To-HQ2.
l Set Source to To-HQ2_local_subnet_1.
l Set Destination to To-HQ2_remote_subnet_1.
l Set Schedule to Always.
l Set Service to All.
l Disable NAT.
b. Click Create New.
l Set Name to vpn_To-HQ2_remote.
l Set Incoming Interface to To-HQ2.
l Set Outgoing Interface to port6.
l Set Source to To-HQ2_remote_subnet_1, To-HQ2_remote_subnet_2.
l Set Destination to To-HQ2_local_subnet_1.
l Set Schedule to Always.
l Set Service to All.
l Enable NAT.
l Set IP Pool Configuration to Use Outgoing Interface Address.
8. Configure Security Fabric:
a. Go to Security Fabric > Settings.
l Enable FortiGate Telemetry.
l Set Group name to Office-Security-Fabric.
l In FortiTelemetry enabled interfaces, add VPN interface To-HQ2.
l Set IP address to the FortiAnalyzer IP of 192.168.8.250.
After FortiGate Telemetry is enabled, FortiAnalyzer automatically enables Logging and Upload is set to Real
Time.
l
l

To configure the downstream FortiGate (HQ2):
1. Configure interface:
a. Go to Network > Interfaces.
b. Edit interface wan1:
l Set Role to WAN.
l For the interface connected to the Internet, set the IP/Network Mask to 192.168.7.3/255.255.255.0.
c. Edit interface vlan20:
l Set Role to LAN.
l For the interface connected to local endpoint clients, set the IP/Network Mask to
10.1.100.3/255.255.255.0.
2. Configure the static route to connect to the Internet:
a. Go to Network > Static Routes and click Create New.
l Set Destination to 0.0.0.0/0.0.0.0.
l Set Interface to wan1.
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Set Gateway Address to 192.168.7.2.
3. Configure IPsec VPN:
a. Go to VPN > IPsec Wizard.
l Set VPN Name to To-HQ1.
l Set Template Type to Custom.
l Click Next.
l In the Network IP Address, enter 10.2.200.1.
l Set Interface to wan1.
l Set Authentication to Method.
l Set Pre-shared Key to 123456.
b. Leave all other fields in their default values and click OK.
4. Configure the IPsec VPN interface IP address which will be used to form Security Fabric:
a. Go to Network > Interfaces.
b. Edit To-HQ1:
l Set Role to WAN.
l Set the IP/Network Mask to 10.10.10.3/255.255.255.255.
l Set Remote IP/Network Mask to 10.10.10.1/255.255.255.0.0.
5. Configure IPsec VPN local and remote subnet:
a. Go to Policy & Objects > Addresses.
l Click Create New
l Set Name to To-HQ1_local_subnet_1.
l Set Type to Subnet.
l Set IP/Network Mask to 10.1.100.0/24.
l Click OK.
l Click Create New
l Set Name to To-HQ1_remote_subnet_1.
l Set Type to Subnet.
l Set IP/Network Mask to 192.168.8.0/24.
l Click OK.
6. Configure IPsec VPN static routes:
a. Go to Network > Static Routes and click Create New.
l For Named Address, select Type and select To-HQ1_remote_subnet_1.
l Set Interface to To-HQ1.
l Click OK.
b. Click Create New.
l For Named Address, select Type and select To-HQ1_remote_subnet_1.
l Set Interface to Blackhole.
l Set Administrative Distance to 254.
l Click OK.
7. Configure IPsec VPN policies:
a. Go to Policy & Objects > IPv4 Policy and click Create New.
l Set Name to vpn_To-HQ1_local.
l Set Incoming Interface to vlan20.
l Set Outgoing Interface to To-HQ1.
l Set Source to To-HQ1_local_subnet_1.
l
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Set Destination to To-HQ1_remote_subnet_1.
Set Schedule to Always.
l Set Service to All.
l Disable NAT.
b. Click Create New.
l Set Name to vpn_To-HQ1_remote.
l Set Incoming Interface to To-HQ1.
l Set Outgoing Interface to vlan20.
l Set Source to To-HQ1_remote_subnet_1.
l Set Destination to -HQ1_local_subnet_1.
l Set Schedule to Always.
l Set Service to All.
l Disable NAT.
8. Configure Security Fabric:
a. Go to Security Fabric > Settings.
l Enable FortiGate Telemetry.
l Enable Connect to upstream FortiGate.
l Set FortiGate IP to 10.10.10.1.
After FortiGate Telemetry is enabled, FortiAnalyzer automatically enables Logging. Settings for the
FortiAnalyzer are retrieved from the downstream FortiGate (HQ2) when it connects to the root FortiGate (HQ1).
l
l

To authorize the downstream FortiGate (HQ2) on the root FortiGate (HQ1):
1. In the root FortiGate (HQ1), go to Security Fabric > Settings.
The Topology field highlights the connected FortiGate (HQ2)with the serial number and asks you to authorize the
highlighted device.
2. Select the highlighted FortiGate and select Authorize.
After authorization, the downstream FortiGate (HQ2) appears in the Topology field in Security Fabric > Settings.
This means the downstream FortiGate (HQ2) has successfully joined the Security Fabric.

To check Security Fabric over IPsec VPN:
1. On the root FortiGate (HQ1), go to Security Fabric > Physical Topology.
The root FortiGate (HQ1) is connected by the downstream FortiGate (HQ2) with VPN icon in the middle.

2. On the root FortiGate (HQ1), go to Security Fabric > Logical Topology.
The root FortiGate (HQ1) VPN interface To-HQ2 is connected by downstream FortiGate (HQ2) VPN interface To-
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HQ1 with VPN icon in the middle.

To run diagnose commands:
1. Run the diagnose sys csf authorization pending-list command in the root FortiGate (HQ1) to show
the downstream FortiGate pending for root FortiGate authorization:
HQ1 # diagnose sys csf authorization pending-list
Serial
IP Address
HA-Members
Path
-----------------------------------------------------------------------------------FG101ETK18002187
0.0.0.0
FG3H1E5818900718:FG101ETK18002187

2. Run the diagnose sys csf downstream command in the root FortiGate (HQ1) to show the downstream
FortiGate (HQ2) after it joins Security Fabric:
HQ1 # diagnose sys csf downstream
1:
FG101ETK18002187 (10.10.10.3) Management-IP: 0.0.0.0 Management-port:0 parent:
FG3H1E5818900718
path:FG3H1E5818900718:FG101ETK18002187
data received: Y downstream intf:To-HQ1 upstream intf:To-HQ2 admin-port:443
authorizer:FG3H1E5818900718

3. Run the diagnose sys csf upstream command in the downstream FortiGate (HQ2) to show the root
FortiGate (HQ1) after the downstream FortiGate joins Security Fabric:
HQ2 # diagnose sys csf upstream
Upstream Information:
Serial Number:FG3H1E5818900718
IP:10.10.10.1
Connecting interface:To-HQ1
Connection status:Authorized

Viewing and controlling network risks via topology view
This recipe shows how to view and control compromised hosts via the Security Fabric > Physical Topology or Security
Fabric > Logical Topology view.
In the following topology, the downstream FortiGate (Marketing) is connected to the root FortiGate (Edge) through a
FortiSwitch (Distribution). The Endpoint Host is connected to the downstream FortiGate (Marketing) through another
FortiSwitch (Access).
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This recipe consists of the following steps:
1.
2.
3.
4.
5.
6.
7.

Configure the root FortiGate.
Configure the downstream FortiGate.
Authorize the downstream FortiGate on the root FortiGate.
Authorize Security Fabric FortiGates on the FortiAnalyzer.
View the compromised endpoint host.
Quarantine the compromised endpoint host.
Run diagnose commands.

To configure the root FortiGate:
1. Configure the interface:
a. In FortiOS on the downstream FortiGate, go to Network > Interfaces.
b. Edit port4. Set the role to WAN and set the IP/Network Mask to 192.168.5.2/255.255.255.0 for the interface that
is connected to the Internet.
c. Edit port6. Set the role to DMZ and set the IP/Network Mask to 192.168.8.2/255.255.255.0 for the interface
which is connected to FortiAnalyzer.
d. Edit port5. Set the Addressing mode to Dedicated to the FortiSiwitch for the interface which is connected to the
Distribution FortiSwitch.
e. Return to Network > Interfaces and click Create New. For the new interface, set the name to vlan70, Type to
VLAN, Interface to port5, VLAN ID to 70, Role to LAN, and IP/Network Mask to 192.168.7.2/255.255.255.0
2. Authorize the Distribution FortiSwitch:
a. Go to WiFi & Switch Controller > Managed FortiSwitch.
b. Click the FortiGate icon, then click Edit. Set the Name to Distribution-Switch, enable the Authorized option,
then click OK.
c. Click the FortiSwitch port1 icon. For port1's Native VLAN, select vlan70.
3. Configure the default static route to connect to the root FortiGate. Go to Network > Static Routes. Set the
Destination to 0.0.0.0/0.0.0.0, select port4 as the Interface, and set the Gateway Address as 192.168.5.254.
4. Configure the Security Fabric:
a. Go to Security Fabric > Settings.
b. Enable FortiGate Telemetry.
c. Configure a group name.
d. In FortiTelemetry enabled interfaces, add vlan70.
e. FortiAnalyzer logging is enabled and the Upload option is set to Real Time after FortiGate Telemetry is
enabled. Set the IP address to the FortiAnalyzer IP address, which in this example is 192.168.8.250.
FortiAnalyzer settings will be retrieved when the downstream FortiGate connects to the root FortiGate.
5. Create a policy to access the Internet. Go to Policy & Objects > IPv4 Policy. Click Create New, and configure the
policy as follows:
a. Set the Name to Access-internet1.
b. Set the Source Interface to vlan70 and the Destination Interface to port4.
c. Set the Source Address to all and the Destination Address to all.
d. Set the Action to ACCEPT.
e. Set the Schedule to Always.
f. Set the Service to ALL.
g. Enable NAT.
h. Set the IP Pool Configuration to Use Outgoing Interface Address.
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6. Create an address for the FortiAnalyzer:
a. Go to Policy & Objects > Addresses. Click Create New, then Address.
b. Set the Name to FAZ-addr.
c. Set the Type to Subnet.
d. Set the Subnet/IP Range to 192.168.8.250/32.
e. Set the Interface to Any.
7. Create a policy for the downstream FortiGate to access the FortiAnalyzer. Go to Policy & Objects > IPv4 Policy.
Click Create New, and configure the policy as follows:
a. Set the Name to Access-Resources.
b. Set the Source Interface to vlan70 and the Destination Interface to port6.
c. Set the Source Address to all and the Destination Address to FAZ-addr.
d. Set the Action to ACCEPT.
e. Set the Schedule to Always.
f. Set the Service to ALL.
g. Enable NAT.
h. Set the IP Pool Configuration to Use Outgoing Interface Address.

To configure the downstream FortiGate:
1. Configure the interface:
a. In FortiOS on the downstream FortiGate, go to Network > Interfaces.
b. Edit wan1. Set the role to WAN and set the IP/Network Mask to 192.168.7.3/255.255.255.0 for the interface
that is connected to the root FortiGate.
c. Edit wan2. Set the Addressing mode to Dedicated to the FortiSiwitch for the interface which is connected to the
Access FortiSwitch.
d. Return to Network > Interfaces and click Create New. For the new interface, set the name to vlan20, Type to
VLAN, Interface to wan2, VLAN ID to 20, Role to LAN, and IP/Network Mask to 10.1.100.3/255.255.255.0.
2. Authorize the Access FortiSwitch:
a. Go to WiFi & Switch Controller > Managed FortiSwitch.
b. Click the FortiGate icon, then click Edit. Set the Name to Access-Switch, enable the Authorized option, then
click OK.
c. Click the FortiSwitch port2 icon. For port2's Native VLAN, select vlan20.
3. Configure the default static route to connect to the root FortiGate. Go to Network > Static Routes. Set the
Destination to 0.0.0.0/0.0.0.0, select wan1 as the Interface, and set the Gateway Address as 192.168.7.2.
4. Configure the Security Fabric:
a. Go to Security Fabric > Settings.
b. Enable FortiGate Telemetry.
c. Under FortiGate Telemetry, enable Connect to upstream FortiGate.
d. Configure the FortiGate IP to 192.168.7.2.
e. In FortiTelemetry enabled interfaces, add vlan20.
f. FortiAnalyzer logging is enabled after FortiGate Telemetry is enabled. FortiAnalyzer settings will be retrieved
when the downstream FortiGate connects to the root FortiGate.
5. Create a policy to access the Internet. Go to Policy & Objects > IPv4 Policy. Click Create New, and configure the
policy as follows:
a. Set the Name to Access-internet2.
b. Set the Source Interface to vlan20 and the Destination Interface to wan1..
c. Set the Source Address to all and the Destination Address to all.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

236

Fortinet Security Fabric
d.
e.
f.
g.
h.
i.

Set the Action to ACCEPT.
Set the Schedule to Always.
Set the Service to ALL.
Enable NAT.
Set the IP Pool Configuration to Use Outgoing Interface Address.
Choose the default Web Filter profile.

To authorize the downstream FortiGate on the root FortiGate:
1. In FortiOS on the root FortiGate, go to Security Fabric > Settings. In the Topology field, a highlighted FortiGate with
a serial number is connecting to the root FortiGate, and a highlighted warning asks for authorization of the
highlighted device.
2. Click the highlighted FortiGate, then select Authorize. After authorization, the downstream FortiGate appears in the
Topology field in Security Fabric > Settings, meaning that the downstream FortiGate joined the Security Fabric
successfully.

To authorize Security Fabric FortiGates on the FortiAnalyzer:
1. Ensure that the FortiAnalyzer firmware is 6.2.0 or later.
2. In FortiAnalyzer, go to Device Manager > Unauthorized. All FortiGates are listed as unauthorized. Select all
FortiGates, then select authorize. The FortiGates now appear as authorized.
3. After a moment, a warning icon appears beside the root FortiGate since the FortiAnalyzer needs administrative
access to the root FortiGate in the Security Fabric. Click the warning icon, then enter the admin user and password
for the root FortiGate.

To view the compromised endpoint host:
1. Test that FortiGate detects a compromised endpoint host by opening a browser on the endpoint host and entering a
malicious website URL. The browser displays a Web Page Blocked! warning and does not allow access to the
website.
2. In FortiOS on the root FortiGate, go to Security Fabric > Physical Topology. The endpoint host, connected to the
Access FortiSwitch, is highlighted in red. Mouse over the endpoint host to view a tooltip that shows the IoC verdict.
The endpoint host is compromised.

3. Go to Security Fabric > Logical Topology. The endpoint host, connected to the downstream FortiGate, is highlighted
in red. Mouse over the endpoint host to view a tooltip that shows the IoC verdict. The endpoint host is compromised.
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To quarantine the compromised endpoint host:
1. In FortiOS on the root FortiGate, go to Security Fabric > Physical Topology.
2. Right-click the endpoint host and select Quarantine Host. Click OK to confirm the confirmation dialog.
3. Go to Monitor > Quarantine Monitor. From the dropdown list at the top right corner, select All FortiGates. The
quarantined endpoint host displays in the content pane.
4. On the endpoint host, open a browser and visit a website such as https://www.fortinet.com/. If the website cannot be
accessed, this confirms that the endpoint host is quarantined.

To run diagnose commands:
1. To show the downstream FortiGate after it joins the Security Fabric, run the diagnose sys csf downstream
command in the root FortiGate (Edge) CLI. The output should resemble the following:
Edge # diagnose sys csf downstream
1: FG101ETK18002187 (192.168.7.3) Management-IP: 0.0.0.0 Management-port:0 parent:
FG201ETK18902514
path:FG201ETK18902514:FG101ETK18002187
data received: Y downstream intf:wan1 upstream intf:vlan70 admin-port:443
authorizer:FG201ETK18902514

2. To show the upstream FortiGate after the downstream FortiGate joins the Security Fabric, run the diagnose sys
csf upstream command in the downstream FortiGate (Marketing) CLI. The output should resemble the following:
Marketing # diagnose sys csf upstream
Upstream Information:
Serial Number:FG201ETK18902514
IP:192.168.7.2
Connecting interface:wan1
Connection status:Authorized

3. To show the quarantined endpoint host in the connected FortiGate, run the following commands in the downstream
FortiGate (Marketing) CLI:
Marketing # show user quarantine
config user quarantine
config targets
edit "PC2"
set description "Manually quarantined"
config macs
edit 00:0c:29:3d:89:39
set description "manual-qtn Hostname: PC2"
next
end
next
end
end

Leveraging LLDP to simplify security fabric negotiation
This feature enables LLDP reception on WAN interfaces, and prompts FortiGates that are joining the Security Fabric if
the upstream FortiGate asks.
l
l

If an interface's role is undefined, LLDP reception and transmission inherit settings from the VDOM.
If an interface's role is WAN, LLDP reception is enabled.
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l

If an interface's role is LAN, LLDP transmission is enabled.

When a FortiGate B's WAN interface detects that FortiGate A's LAN interface is immediately upstream (through the
default gateway), and FortiGate A has Security Fabric enabled, FortiGate B will show a notification on the GUI asking to
join the Security Fabric.

To configure LLDP reception and join a Security Fabric:
1. Go To Network > Interfaces.
2. Configure an interface:
l If the interface's role is undefined, under Administrative Access, set Receive LLDP and Transmit LLDP to Use
VDOM Setting.

Using the CLI:
config system interface
edit "port3"
set lldp-reception vdom
set lldp-transmission vdom
set role undefined
...
next
end
l

If the interface's role is WAN, under Administrative Access, set Receive LLDP to Enable and Transmit LLDP to
Use VDOM Setting.
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Using the CLI:
config system interface
edit "wan1"
set lldp-reception enable
set lldp-transmission vdom
set role wan
...
next
end
l

If the interface's role is LAN, under Administrative Access, set Receive LLDP to Use VDOM Setting and
Transmit LLDP to Enable.

Using the CLI:
config system interface
edit "port2"
set lldp-reception vdom
set lldp-transmission enable
set role lan
...
next
end
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A notification will be shown on FortiGate B.

3. Click the notification. The Security Fabric Settings page opens with all the required settings automatically
configured.

4. Click Apply to apply the settings, or use the following CLI commands:
config system csf
set status enable
set upstream-ip 10.2.200.1
end

Leveraging SAML to switch between Security Fabric FortiGates
In the FortiGate GUI banner, a dropdown menu is available that you can use to easily switch between all FortiGate
devices that are connected to the Security Fabric.
l

The dropdown menu is available in both the root and downstream FortiGates. You can click a link in the menu to
navigate to any other FortiGate management IP/FQDN.
See Switching between FortiGates in a Security Fabric on page 242.
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l

l

The management IP/FQDN and port number settings can be customized in both the root and downstream
FortiGates.
In both root and downstream FortiGates, you can set both the management IP/FQDN and port options.
If the management IP/FQDN is not configured, the IP address that the FortiGate uses to connect to the Security
Fabric is shown as the management IP address and a warning message is displayed, because administrators might
be unable to access the IP address using a web browser.
See Setting the IP/FQDN on page 242.

l

l

In the root FortiGate GUI, you can use the Customize option to change the hostname, management IP/FQDN, and
port number.
See Customizing a root FortiGate on page 244.
In downstream FortiGates, the diagnose sys csf global command shows a summary of all of the connected
FortiGates in the Security Fabric.
See Viewing a summary of all connected FortiGates in a Security Fabric on page 245.

Switching between FortiGates in a Security Fabric
To switch between FortiGates in a Security Fabric:
1. Log in to a FortiGate in a Security Fabric using SSO.
2. In the banner, click the name of the FortiGate.
A dropdown menu opens, showing the root FortiGate as well as downstream FortiGates in the Security Fabric.
Hover the cursor over the name of a FortiGate to see a tooltip about that FortiGate.

3. Click on a FortiGate name to navigate to its management IP/FQDN without any further authentication.

Setting the IP/FQDN
The management IP/FQDN and port can be configured on the root FortiGate and all of the downstream FortiGates.

To set the IP/FQDN in the GUI:
1. Log into a FortiGate in the Security Fabric.
2. Go to Security Fabric > Settings.
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3. In the Management IP/FQDN field, select Specify, then enter the IP/FQDN in the text box.
4. In the Management Port field, select Specify, then enter the port number in the text box.

5. Click Apply.
If the management IP/FQDN is not configured, the IP address that the FortiGate uses to connect to the Security Fabric is
shown as the management IP address and a warning message is displayed, because administrators might be unable to
access the IP address using a web browser.
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To set the IP/FQDN in the CLI:
1. On the root FortiGate, run the following command:
config system csf
set status enable
set group-name "csf_script"
set management-ip "172.17.48.225"
set management-port 4431
......
end

2. On the downstream FortiGates, run the following command:
config
set
set
set
set
end

system csf
status enable
upstream-ip 10.2.200.1
management-ip "robot.csf"
management-port 4432

Customizing a root FortiGate
To customize a root FortiGate:
1. On the root FortiGate, click the dropdown menu in the banner and hover the cursor over the root FortiGate until the
summary pane is shown.
2. In the summary pane, click Customize.

3. Edit the settings as required.
4. Click OK.
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Viewing a summary of all connected FortiGates in a Security Fabric
To view a summary of all connected FortiGates in a Security Fabric:
1. On a downstream FortiGate run the following command:
FGTB-1 # diagnose sys csf global
Current vision:
[
{
"path":"FG3H1E5818900718",
"mgmt_ip_str":"",
"mgmt_port":0,
"sync_mode":1,
"saml_role":"disable",
"admin_port":443,
"serial":"FG3H1E5818900718",
"host_name":"FGTA-1",
"firmware_version_major":6,
"firmware_version_minor":2,
"firmware_version_patch":0,
"firmware_version_build":923,
"subtree_members":[
{
"serial":"FG201ETK18902514"
},
{
"serial":"FGT81ETK18002246"
},
{
"serial":"FG101ETK18002187"
}
]
},
{
"path":"FG3H1E5818900718:FG201ETK18902514",
"mgmt_ip_str":"robot.csf",
"mgmt_port":4432,
"sync_mode":1,
"saml_role":"service-provider",
"admin_port":443,
"serial":"FG201ETK18902514",
"host_name":"FGTB-1",
"firmware_version_major":6,
"firmware_version_minor":2,
"firmware_version_patch":0,
"firmware_version_build":923,
"upstream_intf":"port2",
"upstream_serial":"FG3H1E5818900718",
"parent_serial":"FG3H1E5818900718",
"parent_hostname":"FGTA-1",
"upstream_status":"Authorized",
"upstream_ip":29884938,
"upstream_ip_str":"10.2.200.1",
"subtree_members":[
{
"serial":"FGT81ETK18002246"
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},
{
"serial":"FG101ETK18002187"
}
],
"is_discovered":true,
"ip_str":"10.2.200.2",
"downstream_intf":"wan1",
"idx":1
},
{
"path":"FG3H1E5818900718:FG201ETK18902514:FGT81ETK18002246",
"mgmt_ip_str":"172.17.48.225",
"mgmt_port":4434,
"sync_mode":1,
"saml_role":"service-provider",
"admin_port":443,
"serial":"FGT81ETK18002246",
"host_name":"FGTD",
"firmware_version_major":6,
"firmware_version_minor":2,
"firmware_version_patch":0,
"firmware_version_build":923,
"upstream_intf":"vlan60",
"upstream_serial":"FG201ETK18902514",
"parent_serial":"FG201ETK18902514",
"parent_hostname":"FGTB-1",
"upstream_status":"Authorized",
"upstream_ip":33990848,
"upstream_ip_str":"192.168.6.2",
"subtree_members":[
],
"is_discovered":true,
"ip_str":"192.168.6.4",
"downstream_intf":"wan2",
"idx":2
},
{
"path":"FG3H1E5818900718:FG201ETK18902514:FG101ETK18002187",
"mgmt_ip_str":"",
"mgmt_port":0,
"sync_mode":1,
"saml_role":"disable",
"admin_port":443,
"serial":"FG101ETK18002187",
"host_name":"FGTC",
"firmware_version_major":6,
"firmware_version_minor":2,
"firmware_version_patch":0,
"firmware_version_build":923,
"upstream_intf":"vlan70",
"upstream_serial":"FG201ETK18902514",
"parent_serial":"FG201ETK18902514",
"parent_hostname":"FGTB-1",
"upstream_status":"Authorized",
"upstream_ip":34056384,
"upstream_ip_str":"192.168.7.2",
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"subtree_members":[
],
"is_discovered":true,
"ip_str":"192.168.7.3",
"downstream_intf":"wan1",
"idx":3
}
]

FortiManager Cloud service
This cloud-based SaaS management service is available through FortiManager. This service is also included in the 360
Protection Bundle.
Once the FortiGate has acquired a contract named FortiManager Cloud, FortinetOne creates a cloud-based
FortiManager instance under the user account. You can launch the portal for the cloud-based FortiManager from
FortinetOne, and its URL starts with the User ID.
You can use a FortiGate with a contract for FortiManager Cloud to configure central management by using the FQDN of
fortimanager.forticloud.com. A FortiGate-FortiManager tunnel is established between FortiGate and the FortiManager
instance.
After the tunnel is established, you can execute FortiManager functions from the cloud-based FortiManager portal.
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To manage FortiGate with FortiManager Cloud:
1. In the FortiCare portal, ensure you have a product entitlement for FortiManager Cloud.
a. Go to Asset > Information > Entitlement.
b. Take note of your user ID number in the top-right corner.

2. Click the FortinetOne icon in the upper-right corner.
3. Under CLOUD MANAGEMENT, select FortiManager.
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The FortiManager portal opens. The URL incorporates the user ID for the dedicated instance.

4. In FortiOS, enable FortiManager Cloud.
a. Go to Security Fabric > Settings.
b. Enable Central Management.
c. Click FortiManager Cloud.
d. Click Apply.

The FortiManager Cloud button can only be selected if you have a FortiManager Cloud
product entitlement.

5. In the FortiManager Cloud instance, go to Device Manager and authorize the FortiGate. See Authorizing devices for
more information.
When using FortiGate to enable FortiManager Cloud, the FortiGate appears as an unauthorized device.

After authorizing the FortiGate, it becomes a managed device.
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In FortiOS, the Central Management Status now displays as Registered on FortiManager.

FortiAnalyzer Cloud service
FortiGate supports the FortiAnalyzer Cloud service for event logging.

Traffic and security logs are not supported in the initial version of FortiAnalyzer Cloud.

When FortiAnalyzer Cloud is licensed and enabled (see Deploying FortiAnalyzer Cloud for more information), all
event logs are sent to FortiAnalyzer Cloud by default. All traffic logs, security logs, and archive files are not sent to
FortiAnalyzer Cloud.
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Limitations
l

l
l

You cannot enable FortiAnalyzer Cloud in vdom override-setting when global FortiAnalyzer Cloud is
disabled.
You must use the CLI to retrieve and display logs sent to FortiAnalyzer Cloud. The FortiOS GUI is not supported.
You cannot enable FortiAnalyzer Cloud and FortiGate Cloud at the same time.

Sample settings panes
In the FortiOS Security Fabric > Settings pane under Cloud Logging, FortiAnalyzer Cloud is grayed out when you do not
have a FortiAnalyzer Cloud entitlement.

When you have a FortiAnalyzer Cloud entitlement, FortiAnalyzer Cloud is available.
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You can also view the FortiAnalyzer Cloud settings in the Log & Report > Log Settings pane.
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In FortiAnalyzer Cloud, you can view logs from FortiOS in the Event > All Types pane.
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To enable fortianalyzer-cloud using the CLI:
config
set
set
set
set
set
set
set
set
set
set
set
end
config
set
set
set
set
set
set
set
set
set
set
set
set
set
set
end

log fortianalyzer-cloud setting
status enable
ips-archive disable
access-config enable
enc-algorithm high
ssl-min-proto-version default
conn-timeout 10
monitor-keepalive-period 5
monitor-failure-retry-period 5
certificate ''
source-ip ''
upload-option realtime
log fortianalyzer-cloud filter
severity information
forward-traffic disable
local-traffic disable
multicast-traffic disable
sniffer-traffic disable
anomaly disable
voip disable
dlp-archive disable
dns disable
ssh disable
ssl disable
cifs disable
filter ''
filter-type include

To disable fortianalyzer-cloud for a specific VDOM using the CLI:
config
set
end
config
set
end

log setting
faz-override enable
log fortianalyzer-cloud override-setting
status disable

To set fortianalyzer-cloud filter for a specific vdom using the CLI:
config
set
end
config
set
end
config
set
set
set
set
set
set
set

log setting
faz-override enable
log fortianalyzer-cloud override-setting
status enable
log fortianalyzer-cloud override-filter
severity information
forward-traffic disable
local-traffic disable
multicast-traffic disable
sniffer-traffic disable
anomaly disable
voip disable
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set
set
set
set
set
set
set
end

dlp-archive disable
dns disable
ssh disable
ssl disable
cifs disable
filter ''
filter-type include

To display fortianalyzer-cloud log using the CLI:
execute log filter device fortianalyzer-cloud
execute log filter category event
execute log display

Sample log
date=2019-05-01 time=17:57:45 idseq=60796052214644736 bid=100926 dvid=1027 itime="2019-05-01
17:57:48" euid=3 epid=3 dsteuid=0 dstepid=3 logver=602000890 logid=0100032002
type="event" subtype="system" level="alert" srcip=10.6.30.254 dstip=10.6.30.9
action="login" msg="Administrator ddd login failed from https(10.6.30.254) because of
invalid user name" logdesc="Admin login failed" sn="0" user="ddd" ui="https
(10.6.30.254)" status="failed" reason="name_invalid" method="https"
eventtime=1556758666274548325 devid="FG5H1E5818900076" vd="root" dtime="2019-05-01
17:57:45" itime_t=1556758668 devname="FortiGate-501E"
date=2019-05-01 time=17:57:21 idseq=60796052214644736 bid=100926 dvid=1027 itime="2019-05-01
17:57:23" euid=3 epid=3 dsteuid=0 dstepid=3 logver=602000890 logid=0100044546
type="event" subtype="system" level="information" action="Edit" msg="Edit
log.fortianalyzer-cloud.filter " logdesc="Attribute configured" user="admin" ui="ssh
(10.6.30.254)" cfgtid=164757536 cfgpath="log.fortianalyzer-cloud.filter"
cfgattr="severity[information->critical]" eventtime=1556758642413367644
devid="FG5H1E5818900076" vd="root" dtime="2019-05-01 17:57:21" itime_t=1556758643
devname="FortiGate-501E"
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FortiView is the FortiOS log view tool which is a comprehensive monitoring system for your network. FortiView integrates
real-time and historical data into a single view on your FortiGate. It can log and monitor network threats, filter data on
multiple levels, keep track of administration activities, and more.
You can use multiple filters in the consoles to narrow your view to a specific time range, by user ID or local IP address, by
application, and many more.
Use FortiView to investigate traffic activity such as user uploads/downloads or videos watched on YouTube. You view
the traffic on the whole network, by user group, or by individual. FortiView displays the information in both text and visual
format, giving you an overall picture of your network traffic activity so that you can quickly decide on actionable items.
Logging range and depth depends on the FortiGate model.
The following are just some of the FortiView categories:
l
l
l
l
l

Sources
Destinations
Applications
Cloud Application
Country

l
l
l
l

l

Web Sites
Threats
All Sessions
Failed Authentication
Attempt
System Events

l
l
l
l
l

Admin Login
VPN Login
FortiSandbox
Policy
Interface

l
l
l
l

WiFi Clients
Threat Map
Traffic Shaping
Endpoint Vulnerability

FortiOS has widgets that you can use to further customize these categories. You can place widgets where you want on
dashboards. You can also customize widgets to show information that is most important to you, such as the time range,
source logging device, and other information.
FortiView is integrated with many UTM functions and each release adds more features. For example, you can
quarantine an IP address directly in FortiView or create custom devices and addresses from a FortiView entry.

FortiView interface
FortiView dashboards allow you to access information about traffic activity on your FortiGate, visually and textually. Core
FortiView dashboards, including Sources, Destinations, Applications and more are available within the FortiView tree
menu, and include a top menu bar with the following features:
l
l
l
l

A refresh button which updates the displayed data.
A time display dropdown for switching between current and historical data.
An Add Filter button for applying filters to the displayed data.
A view selection dropdown for changing what information shown on the dashboard.

Additional FortiView information is available as widgets to be placed within default or custom
dashboards in the Dashboard menu. See FortiView dashboards and widgets on page 285.
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Time display
Using the time display dropdown, you can select the time period to be displayed on the current dashboard. Time display
options vary depending on the dashboard and can include current information (now) and historical information (1 hour,
24 hours, and 7 days).

In order to view historical information, disk logging must be enabled.

FortiView filters
You can filter FortiView dashboards by using the Add Filter box in the toolbar and selecting a context-sensitive filter.
Available filters vary depending on the FortiView dashboard.

To filter results on a FortiView dashboard:
1. Select a dashboard in FortiView.
2. Click Add Filter in the dashboard toolbar.
3. Select a filter from the available list.
Available filters are presented for quick selection. Additional filters can be added by clicking the Add Filter button in
the toolbar again.

Drill down to details
Double-click or right-click on an entry in a FortiView dashboard and select Drill Down to Details to view additional details
about the selected traffic activity. Click the back icon in the toolbar to return to the previous view. Drill down to details is
not available on the All Sessions dashboard.
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View selection
Selecting which information is shown:
Most FortiView pages include multiple views for displaying different types of information. You can switch between views
by clicking the dropdown in the top menu bar and choosing a view.

Selecting a display type:
Display types include table view, bubble charts, and country maps. Not all display types are supported by all dashboards
in FortiView. On pages that support multiple displays, select the icon in the top-right corner of the dashboard to choose a
display.
l

l

In the default table view, you can customize the columns that are displayed by hovering your mouse over the first
column header and clicking the configure table icon.
When using a bubble chart, it is possible to sort information using the Compare By dropdown menu. The size of
each bubble represents the related amount of data. You can place your cursor over a bubble to display a tool-tip
with detailed information on that item, and click on a bubble to drilldown into greater (filtered) detail.
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FortiView from disk
Prerequisites
All FortiGates with an SSD disk.

Restrictions
l
l
l

Desktop models (for example: under 100D) with SSD only supports five minutes and one hour view.
Medium models (for example: 200D, 500D) with SSD supports up to 24 hours view.
Large models (for example: 1500D and above) with SSD supports up to seven days view.
l

To enable seven days view:
config log setting
set fortiview-weekly-data enable
end

Configuration
A firewall policy needs to be in place with traffic logging enabled. For best operation with FortiView, internal interface
roles should be clearly defined as LAN; DMZ and internet facing or external interface roles should be defined as WAN.

To enable FortiView from Disk:
1. Enable disk logging from the FortiGate GUI.
a. Go to Log & Report > Log Settings > Local Log.
b. Select the checkbox next to Disk.
2. Enable historical FortiView from the FortiGate GUI.
a. Go to Log & Report > Log Settings > Local Log.
b. Select the checkbox next to Enable Historical FortiView.

3. Click Apply.

To include sniffer traffic and local-deny traffic when FortiView from Disk:
This feature is only supported through the CLI.
config report setting
set report-source forward-traffic sniffer-traffic local-deny-traffic
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end

Source View
Top Level
Sample entry:

Time

l
l

Graph

l

l

Realtime or Now entries are determined by the FortiGate's system session list.
Historical or 5 minutes and later entries are determined by traffic logs, with additional
information coming from UTM logs.
The graph shows the bytes sent/received in the time frame. Realtime does not include a
chart.
Users can customize the time frame by selecting a time period within the graph.

Bubble Chart

l

Bubble chart shows the same information as the table, but in a different graphical
manner.

Columns

l

Source shows the IP address (and user as well as user avatar if configured) of the source
device.
Device shows the device information as listed in User & Device > Device Inventory.
Device detection should be enabled on the applicable interfaces for best function.
Threat Score is the threat score of the source based on UTM features such as Web Filter
and antivirus. It shows threat scores allowed and threat scores blocked.
Bytes is the accumulated bytes sent/received. In realtime, this is calculated from the
session list, and in historical it is from logs.
Sessions is the total sessions blocked/allowed. In realtime, this is calculated from the
session list, and in historical it is from logs.
Source is a simplified version of the first column, including only the IP address without
extra information.
Source Interface is the interface from which the traffic originates. In realtime, this is
calculated from the session list, and in historical it is from the logs.
More information can be shown in a tooltip while hovering over these entries.
For realtime, two more columns are available, Bandwidth and Packets, both of which
come from the session list.

l

l

l

l

l

l

l
l

Drilldown Level
Sample entry:
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Graph

l

l

Summary
Information

l

l

l

Tabs

l

l

The graph shows the bytes sent/received in the time frame. Realtime does not include a
chart.
Users can customize the time frame by selecting a time period within the graph.
Shows information such as the user/avatar, avatar/source IP, bytes, and sessions total
for the time period.
Can quarantine host (access layer quarantine) if they are behind a FortiSwitch or
FortiAP.
Can ban IP addresses, adds the source IP address into the quarantine list.
Drilling down entries in any of these tabs (except sessions tab) will take you to the
underlying traffic log in the sessions tab.
Applications shows a list of the applications attributed to the source IP. This can include
scanned applications (using Application Control in a firewall policy or unscanned
applications.
config log gui-display
set fortiview-unscanned-apps enable
end

l
l

l

l

l

l
l

l

Destinations shows destinations grouped by IP address/FQDN.
Threats lists the threats caught by UTM profiles. This can be from antivirus, IPS, Web
Filter, Application Control, etc.
Web Sites contains the websites which were detected either with webfilter, or through
FQDN in traffic logs.
Web Categories groups entries into their categories as dictated by the Web Filter
Database.
Search Phrases shows entries of search phrases on search engines captured by a Web
Filter UTM profile, with deep inspection enabled in firewall policy.
Policies groups the entries into which polices they passed through or were blocked by.
Sessions shows the underlying logs (historical) or sessions (realtime). Drilldowns from
other tabs end up showing the underlying log located in this tab.
More information can be shown in a tooltip while hovering over these entries.

Troubleshooting
l

Use diagnose debug application httpsd -1 to check which filters were passed through httpsd.
For example:
[httpsd 3163 - 1546543360 info] api_store_parameter[227] -- add API parameter
'filter': '{ "source": "10.1.100.30", "application": "TCP\/5228", "srcintfrole":
[ "lan", "dmz", "undefined" ] }' (type=object)
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l

Use diagnose debug application miglogd 0x70000 to check what the SQL command is that is passed to
the underlying SQL database.
For example:
fortiview_request_data()-898: total:31 start:1546559580 end:1546563179
_dump_sql()-799: dataset=fv.general.chart, sql:select a.timestamp1,ses_al,ses_
bk,r,s,ifnull(sc_l,0),ifnull(sc_m,0),ifnull(sc_h,0),ifnull(sc_c,0) from (select
timestamp-(timestamp%60) timestamp1 ,sum(case when passthrough<>'block' then
sessioncount else 0 end) ses_al,sum(case when passthrough='block' then
sessioncount else 0 end) ses_bk,sum(rcvdbyte) r,sum(sentbyte) s from grp_
traffic_all_src where timestamp BETWEEN 1546559580 and 1546563179 and 1=1 AND
srcip in ('10.1.100.11') AND srcintfrole in ('lan','dmz','undefined') group by
timestamp1 ) a left join (select timestamp-(timestamp%60) timestamp1 ,sum(case
when threat_level=1 then crscore else 0 end) sc_l,sum(case when threat_level=2
then crscore else 0 end) sc_m,sum(case when threat_level=3 then crscore else 0
end) sc_h,sum(case when threat_level=4 then crscore else 0 end) sc_c from grp_
threat where timestamp BETWEEN 1546559580 and 1546563179 and 1=1 AND srcip in
('10.1.100.11') AND srcintfrole in ('lan','dmz','undefined') group by timestamp1
) b on a.timestamp1 = b.timestamp1;
takes 40(ms), agggr:0(ms)

l

Use execute report flush-cache and execute report recreate-db to clear up any irregularities that
may be caused by upgrading or cache issues.

FortiView from FortiAnalyzer
Attaching a FortiAnalyzer to the FortiGate increases the functionality of FortiView. For example, it adds the
Compromised Hosts view.
The following devices are required:
l
l

A FortiGate or FortiOS
A compatible FortiAnalyzer (see https://docs.fortinet.com/document/fortianalyzer/6.2.0/compatibility-with-fortios)

To enable FortiView from FortiAnalyzer:
1. On the FortiGate, go to Security Fabric > Settings.
2. Turn on FortiAnalyzer Logging and enter the IP address of the FortiAnalyzer device.
3. Click Test Connectivity. A message will be shown stating that the FortiGate is not authorized on the FortiAnalyzer.

4. On the FortiAnalyzer, go to Device Manager.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

262

FortiView
5. In the device list, right click the just added FortiGate, then click Authorize.

6. On the FortiGate, go to Security Fabric > Settings and click Test Connectivity to confirm that the device is now
authorized.

7. Go to FortiView > Sources.
8. Select a time range other than now from the drop-down list to view historical data.
9. From the source drop-down list, select FortiAnalyzer.

All the historical information now comes from the FortiAnalyzer.
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Cloud application view
To see different cloud application views, set up the following:
l
l
l

A FortiGate having a relative firewall policy with the Application Control security profile.
A FortiGate with log data from the local disk or FortiAnalyzer.
Optional but highly recommended: SSL Inspection set to deep-inspection on relative firewall policies.

Viewing cloud applications
Cloud applications
All cloud applications require SSL Inspection set to deep-inspection on the firewall policy. For example, Facebook_
File.Download can monitor Facebook download behavior which requires SSL deep-inspection to parse the deep
information in the network packets.
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To view cloud applications:
1. Go to Security Profiles > Application Control.
2. Select a relative Application Control profile used by the firewall policy and click View.

3. On the Edit Application Sensor page, click View Application Signatures.
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4. On the top right of the Application Signature page, click Cloud to display all cloud signature based applications.
Cloud applications have a cloud icon beside them.
The lock icon indicates that that application requires SSL deep inspection.

5. Hover over an item to see its details.
This example shows the Gmail_Attachment.Download, a cloud application signature based sensor which requires
SSL deep inspection. If any local network user behind the firewall logs into Gmail and downloads a Gmail
attachment, that activity is logged.
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Applications with cloud behavior
Applications with cloud behavior is a superset of cloud applications.
Some applications do not require SSL deep inspection, such as Facebook, Gmail, YouTube, and so on. This means that
if any traffic trigger application sensors for these applications, there is a FortiView cloud application view for that traffic.
Other applications require SSL deep inspection, such as Gmail attachment, Facebook_Workplace, and so on.

To view applications with cloud behavior:
1. In the Application Signature page, ensure the Behavior column is displayed. If necessary, add the Behavior column.
a. Hover over the left of the table column headings to display the Configure Table icon.
b. Click Configure Table and select Behavior.
c. Click Apply.

2. Click the Filter icon in the Behavior column and select Cloud to filter by Cloud. Then click Apply.
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3. The Application Signature page displays all applications with cloud behavior.

4. Use the Search box to search for applications. For example, you can search for youtube.
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5. Hover over an item to see its details.
This example shows an application sensor with no lock icon which means that this application sensor does not
require SSL deep inspection. If any local network user behind the firewall tries to navigates the YouTube website,
that activity is logged.

Configuring the Cloud Applications widget
On the Edit Application Sensor page in the Categories section, the
monitored and logged.

icon besides a category means that category is

To add the Cloud Applications widget:
1. Go to Dashboard > Top Usage LAN/DMZ.
2. Move the cursor to the bottom right, click the widget control icon and select Add Widget.
3. Select FortiView Top N.
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4. In the FortiView dropdown list, select the LAN/DMZ tab and then select Cloud Applications.

5. Click Add Widget.

6. If SSL deep inspection is enabled on the relative firewall, then the widget shows the additional details that are
logged, such as Files (Up/Down) and Videos Played.
For YouTube, the Videos Played column is triggered by the YouTube_Video.Play cloud application sensor. This
shows the number of local network users who logged into YouTube and played YouTube videos.
For Dropbox, the Files (Up/Down) column is triggered by Dropbox_File.Download and Dropbox_File.Upload cloud
application sensors. This shows the number of local network users who logged into Dropbox and uploaded or
downloaded files.

Using the Cloud Applications widget
To see additional information in the Cloud Applications widget:
1. In the top right of the widget, click the Expand to full screen icon to see additional information.
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2. For details about a specific entry, double-click the entry or right-click the entry and select Drill Down to Details.

3. To see all the sessions for an application, click Sessions.
In this example, the Application Name column shows all applications related to YouTube.
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4. To view log details, double-click a session to display the Log Details pane.
Sessions monitored by SSL deep inspection (in this example, Youtube_Video.Play) captured deep information such
as Application User, Application Details, and so on. The Log Details pane also shows additional deep information
such as application ID, Message, and so on.
Sessions not monitored by SSL deep inspection (YouTube) did not capture the deep information.

5. In the top right, click the Standalone FortiView page icon to see the page in standalone view.

6. To display a specific time period, select and drag in the timeline graph to display only the data for that time period.
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Cloud application view examples
Example of monitoring network traffic with SSL deep inspection
This is an example of monitoring network traffic for YouTube via FortiView cloud application view with SSL deep
inspection.

To monitor network traffic with SSL deep inspection:
1. Use a firewall policy with the following settings. If necessary, create a policy with these settings.
l Application Control is enabled.
l SSL Inspection is set to deep-inspection.
l Log Allowed Traffic is set to All Sessions.

2. Go to Security Profiles > Application Control.
3. Select a relative Application Control profile used by the firewall policy and click View.
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4. Because YouTube cloud applications are categorized into Video/Audio, ensure the Video/Audio category is
monitored.

5. Click View Application Signatures and hover over YouTube cloud applications to view detailed information about
YouTube application sensors.

Application Signature

Description

Application
ID

YouTube_Video.Access

An attempt to access a video on YouTube.

16420

YouTube_Video.Play

An attempt to download and play a video from YouTube.

38569

YouTube_Video.Upload

An attempt to upload a video to YouTube.

22564

YouTube

An attempt to access YouTube.

31077

This application sensor does not depend on SSL deep
inspection so it does not have a cloud or lock icon.
YouTube_Channel.Access

An attempt to access a video on a specific channel on
YouTube.

41598

YouTube_Channel.ID

An attempt to access a video on a specific channel on
YouTube.

44956

YouTube_Comment.Posting

An attempt to post comments on YouTube.

31076

6. On the test PC, log into YouTube and play some videos.
7. On the FortiGate, go to Log & Report > Application Control and look for log entries for browsing and playing
YouTube videos.
In this example, note the Application User and Application Details. Also note that the Application Control ID is 38569
showing that this entry was triggered by the application sensor YouTube_Video.Play.

8. Go to Dashboard > Top Usage LAN/DMZ.
9. In the Top Cloud Application by Bytes widget, double-click YouTube to drill down to view details.
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10. Select the Sessions tab to see all the entries for the videos played. Check the sessions for YouTube_Video.Play
with the ID 38569.

Example of monitoring network traffic without SSL deep inspection
This is an example of monitoring network traffic for YouTube via FortiView cloud application view without SSL deep
inspection.

To monitor network traffic without SSL deep inspection:
1. Use a firewall policy with the following settings. If necessary, create a policy with these settings.
l Application Control is enabled.
l SSL Inspection is set to certificate-inspection.
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l

Log Allowed Traffic is set to All Sessions.

2. On the test PC, log into YouTube and play some videos.
3. On the FortiGate, go to Log & Report > Application Control and look for log entries for browsing and playing
YouTube videos.
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In this example, the log shows only applications with the name YouTube. The log cannot show YouTube application
sensors which rely on SSL deep inspection.

4. Go to Dashboard > Top Usage LAN/DMZ and check the Top Cloud Application by Bytes widget.
The Top Cloud Application by Bytes widget shows the YouTube cloud application without the video played
information that requires SSL deep inspection.
5. Double-click YouTube and select the Sessions tab.
These sessions were triggered by the application sensor YouTube with the ID 31077. This is the application sensor
with cloud behavior which does not rely on SSL deep inspection.
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FortiView Sources usability
The Sources view displays avatar and device information (for real-time and historical views). You can also create or edit
device or address definitions.

To view avatar and device information:
1. Go to FortiView > Sources. A list of sources displays.

2. Right-click on a source and select Drill Down to Details. The Summary of box displays the avatar and device details.

To create or edit definitions in the top level view:
1. Go to FortiView > Sources.
2. Right-click on a source.
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3. Select an option. In this example, Create Custom Device is selected.

To create or edit definitions in the drill down view:
1. In the Summary of box, click the Actions button.
2. Select an option. In this example, Edit Custom Device is selected.

FortiView from FortiGate Cloud
This function requires a FortiGate that is registered and logged into a compatible FortiGate Cloud.

To enable FortiView with log source as FortiGate Cloud:
1. Go to Security Fabric > Settings.
2. Enable Cloud Logging and select FortiGate Cloud.
If the FortiGate is registered and logged into FortiGate Cloud, the Account and Region is displayed.
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If the FortiGate is logged out from FortiGate Cloud, click Activate and log in, and ensure Send logs to FortiGate
Cloud is selected.
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3. Go to Log & Report > Log Settings and set the following:
a. Set Event Logging to All.
b. Set Local Traffic Log to All.

4. Go to FortiView > Sources.
The top right has a dropdown menu to select the source.
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5. In the top right dropdown menu, select FortiGate Cloud as the source.

You can select FortiGate Cloud as the data source for all available FortiView pages and widgets.

Supported views for different log sources
The following chart identifies what log sources support which views:

Disk for
FortiOS 6.2.0

FortiAnalyzer
6.2.0

FortiGate
Cloud 4.1.1

Sources

Yes

Yes

Yes

Admin logins

Yes

Yes

No

Applications

Yes

Yes

Yes

Cloud Applications

No

No

No

Cloud User

Yes

Yes

No

Destination Countries MAP

Yes

Yes

Yes

Destination Countries Table View

Yes

Yes

Yes

Destination Countries Bubble View

Yes

Yes

Yes

Destination Interface

Yes

Yes

Yes

Destination IPS

Yes

Yes

Yes

Destination Owners

Yes

Yes

No

Destination Firewall Objects

Yes

Yes

No

Endpoint Devices

Yes

Yes

Yes

Endpoint Vulnerability

Yes

Yes

No

Failed Authentication

Yes

Yes

Yes

Interface Pair

Yes

Yes

No

Policies

Yes

Yes

Yes
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Disk for
FortiOS 6.2.0

FortiAnalyzer
6.2.0

FortiGate
Cloud 4.1.1

Search Phrases

Yes

Yes

No

Source Interface

Yes

Yes

Yes

Source Firewall Objects

Yes

Yes

No

System Events

Yes

Yes

Yes

Threats

Yes

Yes

Yes

Top FortiSandbox Files by Submitted

Yes

Yes

No

VPN

Yes

Yes

Yes

Web Category

Yes

Yes

Yes

Web Sites

Yes

Yes

Yes

WiFi Clients

Yes

Yes

No

FortiGate Cloud-based IOC
Topology, FortiView, and automation support Indicators of Compromise (IOC) detection from the FortiGate Cloud IOC
service.
FortiGate lists IOC entries on the FortiView pane, and uses the IOC event logs as a trigger for automation stitches. IOC
and webfilter licenses are required to use this feature. You must also enabled FortiGate Cloud logging on the FortiGate.
To view compromised hosts, go to FortiView > Compromised Hosts. The IOC entries are displayed when the source is
FortiGate Cloud.
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You can also view the IOC entries on FortiGate Cloud portal.

FortiView — subnet filters
In FortiView, you can filter source IPs or destination IPs with a subnet mask using the x.x.x.x/x format. You can view the
results in real-time or historical mode.

Both logging from disk and logging from FortiAnalyzer are supported.

Sample configuration of filtering IPs with a subnet mask
This example shows how to filter destination IPs with a subnet mask using the x.x.x.x/x format.

To filter destination IPs with a subnet mask:
1.
2.
3.
4.
5.

Go to FortiView > Destinations.
Click Add Filter.
In the dropdown menu, select Destination IP.
Enter the subnet mask (in the example, 91.189.0.0/16).
Press the Enter key. The filter results display.

To view results in the backend subnet filter:
# diagnose device application miglogd 0x70000
Debug messages will be on for unlimited time.
# fortiview_add_filter_field_ex()-1559: fortiview add filter field:"destination"=>"dstip"
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type:4 negate:0
fortiview_add_filter_field_ex()-1560: values:
fortiview_add_filter_field_ex()-1562: value[0]=91.189.0.0/16
fortiview_add_filter_field_ex()-1559: fortiview add filter
field:"srcintfrole"=>"srcintfrole" type:4 negate:0
fortiview_add_filter_field_ex()-1560: values:
fortiview_add_filter_field_ex()-1562: value[0]=lan
fortiview_add_filter_field_ex()-1562: value[1]=dmz
fortiview_add_filter_field_ex()-1562: value[2]=undefined
__params_from_filter()-583: filter field:dstip 91.189.0.0/16
__params_from_filter()-583: filter field:srcintfrole lan
__params_from_filter()-583: filter field:srcintfrole dmz
__params_from_filter()-583: filter field:srcintfrole undefined
fortiview_request_data()-896: dataset:fv.dest.group tabid:0
_dump_sql()-829: dataset=fv.dest.group, sql:select dstip, max(dstintf) dst_intf,max
(dstdevtype) dst_devtype,max(dstmac) dst_mac,group_concat(distinct appid) appid,group_concat
(distinct appservice||case when subapp is null then '' else '_'||subapp end) appname,sum
(sessioncount) session_count, sum(case when passthrough<>'block' then sessioncount else 0
end) session_allow, sum(case when passthrough='block' then sessioncount else 0 end) session_
block, sum(rcvdbyte) r, sum(sentbyte) s, sum(rcvdbyte + sentbyte) bandwidth ,sum(crscore)
score, sum(case when passthrough<>'block' then crscore else 0 end) score_allow, sum(case
when passthrough='block' then crscore else 0 end) score_block from grp_traffic_all_dst
where timestamp between 1551397800 and 1551484200 and 1=1 AND ( ft_ipmask(dstip, 0,
'91.189.0.0/16') ) AND srcintfrole in ('lan','dmz','undefined') group by dstip
order by
bandwidth desc
limit 100;
takes 10(ms), agggr:0(ms)
fortiview_request_data()-933: total:12 start:1551397800 end:1551484200
__params_from_filter()-583: filter field:dstip 91.189.0.0/16
__params_from_filter()-583: filter field:srcintfrole lan
__params_from_filter()-583: filter field:srcintfrole dmz
__params_from_filter()-583: filter field:srcintfrole undefined
fortiview_request_data()-896: dataset:fv.general.chart tabid:0
_dump_sql()-829: dataset=fv.general.chart, sql:select a.timestamp1,ses_al,ses_bk,r,s,ifnull
(sc_l,0),ifnull(sc_m,0),ifnull(sc_h,0),ifnull(sc_c,0) from (select timestamp-(timestamp%600)
timestamp1 ,sum(case when passthrough<>'block' then sessioncount else 0 end) ses_al,sum(case
when passthrough='block' then sessioncount else 0 end) ses_bk,sum(rcvdbyte) r,sum(sentbyte)
s from grp_traffic_all_dst where timestamp BETWEEN 1551397800 and 1551484199 and 1=1 AND (
ft_ipmask(dstip, 0, '91.189.0.0/16') ) AND srcintfrole in ('lan','dmz','undefined') group
by timestamp1 ) a left join (select timestamp-(timestamp%600) timestamp1 ,sum(case when
threat_level=1 then crscore else 0 end) sc_l,sum(case when threat_level=2 then crscore else
0 end) sc_m,sum(case when threat_level=3 then crscore else 0 end) sc_h,sum(case when threat_
level=4 then crscore else 0 end) sc_c from grp_threat where timestamp BETWEEN 1551397800
and 1551484199 and 1=1 AND ( ft_ipmask(dstip, 0, '91.189.0.0/16') ) AND srcintfrole in
('lan','dmz','undefined') group by timestamp1 ) b on a.timestamp1 = b.timestamp1;
takes 30(ms), agggr:0(ms)
fortiview_request_data()-933: total:47 start:1551397800 end:1551484199

FortiView dashboards and widgets
FortiView is consolidated within the System Dashboards. FortiView pages are available as widgets that can be added to
the flexible dashboards.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

285

FortiView

Only core FortiView pages are available in the FortiView menu. All non-core FortiView pages
are available as dashboard widgets.

Dashboards are available per VDOM.
The Dashboard menu contains the following:
l

Status dashboard

l

Top Usage LAN/DMZ dashboard
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l

Securitydashboard

Only core FortiView pages are available in the FortiView menu.

All non-core FortiView pages are available as dashboard widgets.

To add a FortiView widget in the dashboard:
1.
2.
3.
4.
5.

Within the Dashboard menu, select the dashboard you wish to edit (in the example, Top Usage LAN/DMZ).
Click the gear button in the bottom-right corner of the screen.
Click Add Widget.
Under the FortiView section, select FortiView Top N. The Add Dashboard Widget pane opens.
Under the FortiView dropdown, select the widget. There are three submenus to choose from: LAN/DMZ, WAN, or
All Segments.
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6. Configure the widget settings.
7. Click Add Widget.

VDOMs and dashboards
Once VDOMs are enabled, dashboards are created per VDOM.
l

For example, if you add a Sessions widget to the root VDOM as shown below:
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l

Notice that other VDOMs have no data in the Sessions widget.

The Threat Map is available in the Monitor tree menu.

FortiView object names
The FortiView Sources and Destinations views leverage UUID to resolve firewall object (address) names for improved
usability.

Requirements
l
l

The Firewall Objects-based view is only available when the data source is disk.
To have a historical Firewall Objects-based view, address objects' UUIDs need to be logged.
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To enable address object UUID logging in the CLI:
config system global
set log-uuid-address enable
end

Sample configuration
In this example, firewall addresses have been configured using the commands in To configure firewall addresses in the
CLI: on page 293, and each firewall address object is associated with an unique UUID.
In the Sources and Destinations views, firewall objects can be displayed in real-time or in a historical chart. Objects can
also be drilled down for more details.

To view Firewall Object-based charts in real-time:
1. In the FortiView tree menu, select the view (Sources orDestinations).
2. In the top right corner of the settings bar:
a. Select Firewall Objects as the data criterion.
b. Select now as the time criterion.
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To view Firewall Object-based charts over a historical period:
1. In the FortiView menu, select the view (Sources or Destinations).
2. In the top right corner of the settings bar:
a. Select Firewall Objects as the data criterion.
b. Select a time criterion from the dropdown (in the examples, 5 minutes).

To drill down Firewall Objects:
1. Right-click on any Source Object or Destination Object in the view results.
2. Select Drill Down to Details. More information displays about the object; there are additional criteria to filter data.
l This example shows a drill down of PC2 from the Sources view.
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l

This example shows a drill down of 172.16.200.55-PC5 from the Destinations view.

To configure firewall addresses in the CLI:
config firewall address
edit "PC2"
set uuid b3eba698-5c89-51e9-1af9-363b23a3fef8
set subnet 10.1.100.22 255.255.255.255
next
edit "10.1.100.11-PC1"
set uuid 96bcbca2-5cb5-51e9-bc02-465c0aab5e2c
set subnet 10.1.100.11 255.255.255.255
next
edit "172.16.200.55-PC5"
set uuid a2c368f2-5cb5-51e9-1c35-082a57898065
set subnet 172.16.200.55 255.255.255.255
next
edit "PW2-172-16-200-254"
set uuid def64b6a-5d45-51e9-5ab0-b0d0a3128098
set subnet 172.16.200.254 255.255.255.255
next
end

To configure the firewall policy with defined firewall addresses in the CLI:
config firewall policy
edit 1
set name "v4-out"
set uuid 4825ff5a-dc94-51e8-eeab-e138bc255e4a
set srcintf "port10"
set dstintf "port9"
set srcaddr "PC2" "10.1.100.11-PC1"
set dstaddr "172.16.200.55-PC5" "PW2-172-16-200-254"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set inspection-mode proxy
set logtraffic all
set av-profile "default"
set ssl-ssh-profile "custom-deep-inspection"
set nat enable
next
edit 2
set name "to-Internet"
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set
set
set
set
set
set
set
set
set
set
set
set
set

uuid 28379372-5c8a-51e9-c765-cc755a07a200
srcintf "port10"
dstintf "port9"
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"
utm-status enable
inspection-mode proxy
logtraffic all
av-profile "default"
nat enable

next
end
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The following topics provide information about network settings:
l
l
l
l
l
l
l
l

Interfaces on page 295
DNS on page 320
Explicit and transparent proxies on page 333
SD-WAN on page 369
DHCP server on page 456
DHCP relay agent information option on page 457
Direct IP support for LTE/4G on page 460
LLDP reception on page 464

Interfaces
Physical and virtual interfaces allow traffic to flow between internal networks, and between the internet and internal
networks. FortiGate has options for setting up interfaces and groups of subnetworks that can scale as your organization
grows. You can create and edit VLAN, EMAC-VLAN, switch interface, zones, and so on.
The following topics provide information about interfaces:
l
l
l
l
l
l
l
l
l
l
l

Interface settings on page 295
Aggregation and redundancy on page 297
VLANs on page 299
Enhanced MAC VLANs on page 304
Inter-VDOM routing on page 307
Software switch on page 312
Zone on page 313
Virtual Wire Pair on page 315
Failure detection for aggregate and redundant interfaces on page 317
VLAN inside VXLAN on page 318
Virtual Wire Pair with VXLAN on page 318

Interface settings
Administrators can configure both physical and virtual FortiGate interfaces in Network > Interfaces. There are different
options for configuring interfaces when FortiGate is in NAT mode or transparent mode.

To configure an interface in the GUI:
1. Go to Network > Interfaces.
2. Click Create New > Interface.
3. Configure the interface fields.
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To configure an interface in the CLI:
config system interface
edit "<Interface_Name>"
set vdom "<VDOM_Name>"
set mode static/dhcp/pppoe
set ip <IP_address> <netmask>
set allowaccess ping https ssh http
set secondary-IP enable
config secondaryip
edit 1
set ip 9.1.1.2 255.255.255.0
set allowaccess ping https ssh snmp http
next
end
next
end

Configure administrative access to interfaces
You can configure the protocols that administrators can use to access interfaces on the FortiGate. This helps secure
access to the FortiGate by restricting access to a limited number of protocols. It helps prevent users from accessing
interfaces that you don't want them to access, such as public-facing ports.
As a best practice, you should configure administrative access when you're setting the IP address for a port.

To configure administrative access to interfaces in the GUI:
1. Go to Network > Interfaces.
2. Create or edit an interface.
3. In the Administrative Access section, select which protocols to enable for IPv4 and IPv6 Administrative Access.
HTTPS

Allow secure HTTPS connections to the FortiGate GUI through this interface. If
configured, this option is enabled automatically.

HTTP

Allow HTTP connections to the FortiGate GUI through this interface. This option can
only be enabled if HTTPS is already enabled.

PING

The interface responds to pings. Use this setting to verify your installation and for
testing.

FMG-Access

Allow FortiManager authorization automatically during the communication
exchanges between FortiManager and FortiGate devices.

CAPWAP

Allow the FortiGate wireless controller to manage a wireless access point such as a
FortiAP device.

SSH

Allow SSH connections to the CLI through this interface.

SNMP

Allow a remote SNMP manager to request SNMP information by connecting to this
interface.

FTM

FortiToken Mobile Push (FTM) access.
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RADIUS Accounting

Allow RADIUS accounting information on this interface.

FortiTelemetry

Aggregation and redundancy
Link aggregation (IEEE 802.3ad) enables you to bind two or more physical interfaces together to form an aggregated
(combined) link. This new link has the bandwidth of all the links combined. If a link in the group fails, traffic is transferred
automatically to the remaining interfaces. The only noticeable effect is reduced bandwidth.
This feature is similar to redundant interfaces. The major difference is a redundant interface group only uses one link at a
time, where an aggregate link group uses the total bandwidth of the functioning links in the group, up to eight (or more).
An interface is available to be an aggregate interface if:
l
l
l
l
l
l
l

It is a physical interface and not a VLAN interface or subinterface.
It is not already part of an aggregate or redundant interface.
It is in the same VDOM as the aggregated interface. Aggregate ports cannot span multiple VDOMs.
It does not have an IP address and is not configured for DHCP or PPPoE.
It is not referenced in any security policy, VIP, IP Pool, or multicast policy.
It is not an HA heartbeat interface.
It is not one of the FortiGate-5000 series backplane interfaces.

When an interface is included in an aggregate interface, it is not listed on the Network > Interfaces page. Interfaces still
appear in the CLI although configuration for those interfaces do not take affect. You cannot configure the interface
individually and it is not available for inclusion in security policies, VIPs, IP pools, or routing.

Sample configuration
This example creates an aggregate interface on a FortiGate-140D POE using ports 3-5 with an internal IP address of
10.1.1.123, as well as the administrative access to HTTPS and SSH.

To create an aggregate interface using the GUI:
1.
2.
3.
4.
5.
6.
7.
8.

Go to Network > Interfaces and select Create New > Interface.
For Interface Name, enter Aggregate.
For the Type, select 802.3ad Aggregate.
In the physical Interface Members, click to add interfaces and select ports 4, 5, and 6.
For Addressing mode, select Manual.
For the IP address for the port, enter 10.1.1.123/24.
For Administrative Access, select HTTPS and SSH.
Select OK.

To create an aggregate interface using the CLI:
FG140P3G15800330 (aggregate) # show
config system interface
edit "aggregate"
set vdom "root"
set ip 10.1.1.123 255.255.255.0

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

297

Network

set
set
set
set
set
set
set
set

allowaccess ping https ssh snmp http fgfm radius-acct capwap ftm
type aggregate
member "port3" "port4" "port5"
device-identification enable
lldp-transmission enable
fortiheartbeat enable
role lan
snmp-index 45

next
end

Redundancy
In a redundant interface, traffic only goes over one interface at any time. This differs from an aggregated interface where
traffic goes over all interfaces for increased bandwidth. This difference means redundant interfaces can have more
robust configurations with fewer possible points of failure. This is important in a fully-meshed HA configuration.
An interface is available to be in a redundant interface if:
l
l
l
l
l
l
l
l
l

It is a physical interface and not a VLAN interface.
It is not already part of an aggregated or redundant interface.
It is in the same VDOM as the redundant interface.
It does not have an IP address and is not configured for DHCP or PPPoE.
It has no DHCP server or relay configured on it.
It does not have any VLAN subinterfaces.
It is not referenced in any security policy, VIP, or multicast policy.
It is not monitored by HA.
It is not one of the FortiGate-5000 series backplane interfaces.

When an interface is included in a redundant interface, it is not listed on the Network > Interfaces page. You cannot
configure the interface individually and it is not available for inclusion in security policies, VIPs, or routing.

Sample configuration
To create a redundant interface using the GUI:
1.
2.
3.
4.
5.
6.
7.
8.

Go to Network > Interfaces and select Create New > Interface.
For Interface Name, enter Redundant.
For the Type, select Redundant Interface.
In the physical Interface Members, click to add interfaces and select ports 4, 5, and 6.
For Addressing mode, select Manual.
For the IP address for the port, enter 10.13.101.100/24.
For Administrative Access, select HTTPS and SSH.
Select OK.

To create a redundant interface using the CLI:
config system interface
edit "red"
set vdom "root"
set ip 10.13.101.100 255.255.255.0
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set
set
set
set
set
set

allowaccess https http
type redundant
member "port4" "port5" "port6"
device-identification enable
role lan
snmp-index 9

next
end

VLANs
Virtual Local Area Networks (VLANs) multiply the capabilities of your FortiGate unit and can also provide added network
security. VLANs use ID tags to logically separate devices on a network into smaller broadcast domains. These smaller
domains forward packets only to devices that are part of that VLAN domain. This reduces traffic and increases network
security.

VLANs in NAT mode
In NAT mode, the FortiGate unit functions as a layer-3 device. In this mode, the FortiGate unit controls the flow of
packets between VLANs and can also remove VLAN tags from incoming VLAN packets. The FortiGate unit can also
forward untagged packets to other networks such as the Internet.
In NAT mode, the FortiGate unit supports VLAN trunk links with IEEE 802.1Q-compliant switches or routers. The trunk
link transports VLAN-tagged packets between physical subnets or networks. When you add VLAN subinterfaces to the
FortiGate's physical interfaces, the VLANs have IDs that match the VLAN IDs of packets on the trunk link. The FortiGate
unit directs packets with VLAN IDs to subinterfaces with matching IDs.
You can define VLAN subinterfaces on all FortiGate physical interfaces. However, if multiple virtual domains are
configured on the FortiGate unit, you only have access to the physical interfaces on your virtual domain. The FortiGate
unit can tag packets leaving on a VLAN subinterface. It can also remove VLAN tags from incoming packets and add a
different VLAN tag to outgoing packets.
Normally in VLAN configurations, the FortiGate unit's internal interface is connected to a VLAN trunk, and the external
interface connects to an Internet router that is not configured for VLANs. In this configuration, the FortiGate unit can
apply different policies for traffic on each VLAN interface connected to the internal interface, which results in less
network traffic and better security.

Sample topology
In this example, two different internal VLAN networks share one interface on the FortiGate unit and share the connection
to the Internet. This example shows that two networks can have separate traffic streams while sharing a single interface.
This configuration can apply to two departments in a single company or to different companies.
There are two different internal network VLANs in this example. VLAN_100 is on the 10.1.1.0/255.255.255.0 subnet, and
VLAN_200 is on the 10.1.2.0/255.255.255.0 subnet. These VLANs are connected to the VLAN switch.
The FortiGate internal interface connects to the VLAN switch through an 802.1Q trunk. The internal interface has an IP
address of 192.168.110.126 and is configured with two VLAN subinterfaces (VLAN_100 and VLAN_200). The external
interface has an IP address of 172.16.21.2 and connects to the Internet. The external interface has no VLAN
subinterfaces.
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When the VLAN switch receives packets from VLAN_100 and VLAN_200, it applies VLAN ID tags and forwards the
packets of each VLAN both to local ports and to the FortiGate unit across the trunk link. The FortiGate unit has policies
that allow traffic to flow between the VLANs, and from the VLANs to the external network.

Sample configuration
In this example, both the FortiGate unit and the Cisco 2950 switch are installed and connected and basic configuration
has been completed. On the switch, you need access to the CLI to enter commands. No VDOMs are enabled in this
example.
General configuration steps include:
1.
2.
3.
4.

Configure the external interface.
Add two VLAN subinterfaces to the internal network interface.
Add firewall addresses and address ranges for the internal and external networks.
Add security policies to allow:
l the VLAN networks to access each other.
l the VLAN networks to access the external network.

To configure the external interface:
config system interface
edit external
set mode static
set ip 172.16.21.2 255.255.255.0
end

To add VLAN subinterfaces:
config system interface
edit VLAN_100
set vdom root
set interface internal
set type vlan
set vlanid 100
set mode static
set ip 10.1.1.1 255.255.255.0
set allowaccess https ping
next
edit VLAN_200
set vdom root
set interface internal
set type vlan
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set
set
set
set

vlanid 200
mode static
ip 10.1.2.1 255.255.255.0
allowaccess https ping

end

To add the firewall addresses:
config firewall address
edit VLAN_100_Net
set type ipmask
set subnet 10.1.1.0 255.255.255.0
next
edit VLAN_200_Net
set type ipmask
set subnet 10.1.2.0 255.255.255.0
end

To add security policies:
Policies 1 and 2 do not need NAT enabled, but policies 3 and 4 do need NAT enabled.
config firewall policy
edit 1
set srcintf VLAN_100
set srcaddr VLAN_100_Net
set dstintf VLAN_200
set dstaddr VLAN_200_Net
set schedule always
set service ALL
set action accept
set nat disable
set status enable
next
edit 2
set srcintf VLAN_200
set srcaddr VLAN_200_Net
set dstintf VLAN_100
set dstaddr VLAN_100_Net
set schedule always
set service ALL
set action accept
set nat disable
set status enable
next
edit 3
set srcintf VLAN_100
set srcaddr VLAN_100_Net
set dstintf external
set dstaddr all
set schedule always
set service ALL
set action accept
set nat enable
set status enable
next
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edit 4
set
set
set
set
set
set
set
set
set
end

srcintf VLAN_200
srcaddr VLAN_200_Net
dstintf external
dstaddr all
schedule always
service ALL
action accept
nat enable
status enable

VLANs in transparent mode
In transparent mode, the FortiGate unit behaves like a layer-2 bridge but can still provide services such as antivirus
scanning, web filtering, spam filtering, and intrusion protection to traffic. Some limitations of transparent mode is that you
cannot use SSL VPN, PPTP/L2TP VPN, DHCP server, or easily perform NAT on traffic. The limits in transparent mode
apply to IEEE 802.1Q VLAN trunks passing through the unit.
You can insert the FortiGate unit operating in transparent mode into the VLAN trunk without making changes to your
network. In a typical configuration, the FortiGate unit internal interface accepts VLAN packets on a VLAN trunk from a
VLAN switch or router connected to internal network VLANs. The FortiGate external interface forwards VLAN-tagged
packets through another VLAN trunk to an external VLAN switch or router and on to external networks such as the
Internet. You can configure the unit to apply different policies for traffic on each VLAN in the trunk.
To pass VLAN traffic through the FortiGate unit, you add two VLAN subinterfaces with the same VLAN ID, one to the
internal interface and the other to the external interface. You then create a security policy to permit packets to flow from
the internal VLAN interface to the external VLAN interface. If required, create another security policy to permit packets to
flow from the external VLAN interface to the internal VLAN interface. Typically in transparent mode, you do not permit
packets to move between different VLANs. Network protection features such as spam filtering, web filtering, and antivirus scanning, are applied through the UTM profiles specified in each security policy, enabling very detailed control over
traffic.
When the FortiGate unit receives a VLAN-tagged packet on a physical interface, it directs the packet to the VLAN
subinterface with the matching VLAN ID. The VLAN tag is removed from the packet and the FortiGate unit then applies
security policies using the same method it uses for non-VLAN packets. If the packet exits the FortiGate unit through a
VLAN subinterface, the VLAN ID for that subinterface is added to the packet and the packet is sent to the corresponding
physical interface.

Sample topology
In this example, the FortiGate unit is operating in transparent mode and is configured with two VLANs: one with an ID of
100 and the other with ID 200. The internal and external physical interfaces each have two VLAN subinterfaces, one for
VLAN_100 and one for VLAN_200.
The IP range for the internal VLAN_100 network is 10.100.0.0/255.255.0.0, and for the internal VLAN_200 network is
10.200.0.0/255.255.0.0.
The internal networks are connected to a Cisco 2950 VLAN switch which combines traffic from the two VLANs onto one
in the FortiGate unit's internal interface. The VLAN traffic leaves the FortiGate unit on the external network interface,
goes on to the VLAN switch, and on to the Internet. When the FortiGate units receives a tagged packet, it directs it from
the incoming VLAN subinterface to the outgoing VLAN subinterface for that VLAN.
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In this example, we create a VLAN subinterface on the internal interface and another one on the external interface, both
with the same VLAN ID. Then we create security policies that allow packets to travel between the VLAN_100_int
interface and the VLAN_100_ext interface. Two policies are required: one for each direction of traffic. The same is
required between the VLAN_200_int interface and the VLAN_200_ext interface, for a total of four security policies.

Sample configuration
There are two main steps to configure your FortiGate unit to work with VLANs in transparent mode:
1. Add VLAN subinterfaces.
2. Add security policies.
You can also configure the protection profiles that manage antivirus scanning, web filtering, and spam filtering.

To add VLAN subinterfaces:
config system interface
edit VLAN_100_int
set type vlan
set interface internal
set vlanid 100
next
edit VLAN_100_ext
set type vlan
set interface external
set vlanid 100
next
edit VLAN_200_int
set type vlan
set interface internal
set vlanid 200
next
edit VLAN_200_ext
set type vlan
set interface external
set vlanid 200
end

To add security policies:
config firewall policy
edit 1
set srcintf VLAN_100_int
set srcaddr all
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set
set
set
set
set
next
edit 2
set
set
set
set
set
set
set
next
edit 3
set
set
set
set
set
set
set
next
edit 4
set
set
set
set
set
set
set

dstintf VLAN_100_ext
dstaddr all
action accept
schedule always
service ALL

srcintf VLAN_100_ext
srcaddr all
dstintf VLAN_100_int
dstaddr all
action accept
schedule always
service ALL

srcintf VLAN_200_int
srcaddr all
dstintf VLAN_200_ext
dstaddr all
action accept
schedule always
service ALL

srcintf VLAN_200_ext
srcaddr all
dstintf VLAN_200_int
dstaddr all
action accept
schedule always
service ALL

end

Enhanced MAC VLANs
The Media Access Control (MAC) Virtual Local Area Network (VLAN) feature in Linux allows you to configure multiple
virtual interfaces with different MAC addresses (and therefore different IP addresses) on a physical interface.
FortiGate implements an enhanced MAC VLAN consisting of a MAC VLAN with bridge functionality. Because each MAC
VLAN has a unique MAC address, virtual IP addresses (VIPs) and IP pools are supported, and you can disable Source
Network Address Translation (SNAT) in policies.
MAC VLAN cannot be used in a transparent mode virtual domain (VDOM). In a transparent mode VDOM, a packet
leaves an interface with the MAC address of the original source instead of the interface’s MAC address. FortiGate
implements an enhanced version of MAC VLAN where it adds a MAC table in the MAC VLAN which learns the MAC
addresses when traffic passes through.
If you configure a VLAN ID for an enhanced MAC VLAN, it won’t join the switch of the underlying interface. When a
packet is sent to this interface, a VLAN tag is inserted in the packet and the packet is sent to the driver of the underlying
interface. When the underlying interface receives a packet, if the VLAN ID doesn’t match, it won’t deliver the packet to
this enhanced MAC VLAN interface.
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When using a VLAN ID, the ID and the underlying interface must be a unique pair, even if the
belong to different VDOMs. This is because the underlying, physical interface uses the VLAN
ID as the identifier to dispatch traffic among the VLAN and enhanced MAC VLAN interfaces.
If you use an interface in an enhanced MAC VLAN, do not use it for other purposes such as a management interface, HA
heartbeat interface, or in Transparent VDOMs.
If a physical interface is used by an EMAC VLAN interface, you cannot use it in a Virtual Wire Pair.
In high availability (HA) configurations, enhanced MAC VLAN is treated as a physical interface. It’s assigned a unique
physical interface ID and the MAC table is synchronized with the slaves in the same HA cluster.

Example 1: Enhanced MAC VLAN configuration for multiple VDOMs that use the same
interface or VLAN
In this example, a FortiGate is connected, through port 1 to a router that’s connected to the Internet. Three VDOMs share
the same interface (port 1) which connects to the same router that’s connected to the Internet. Three enhanced MAC
VLAN interfaces are configured on port 1 for the three VDOMs. The enhanced MAC VLAN interfaces are in the same IP
subnet segment and each have unique MAC addresses.
The underlying interface (port 1) can be a physical interface, an aggregate interface, or a VLAN interface on a physical or
aggregate interface.

To configure enhanced MAC VLAN for this example in the CLI:
config system interface
edit port1.emacvlan1
set vdom VDOM1
set type emac-vlan
set interface port1
next
edit port 1.emacvlan2
set vdom VDOM2
set type emac-vlan
set interface port1
next
edit port1.emacvlan3
set vdom VDOM3
set type emac-vlan
set interface port1
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next
end

Example 2: Enhanced MAC VLAN configuration for shared VDOM links among multiple
VDOMs
In this example, multiple VDOMs can connect to each other using enhanced MAC VLAN on network processing unit
(NPU) virtual link (Vlink) interfaces.
FortiGate VDOM links (NPU-Vlink) are designed to be peer-to-peer connections and VLAN interfaces on NPU Vlink
ports use the same MAC address. Connecting more than two VDOMs using NPU Vlinks and VLAN interfaces is not
recommended.

To configure enhanced MAC VLAN for this example in the CLI:
config system interface
edit npu0_vlink0.emacvlan1
set vdom VDOM1
set type emac-vlan
set interface npu0_vlink0
next
edit npu0_vlink0.emacvlan2
set vdom VDOM3
set type emac-vlan
set interface npu0_vlink0
next
edit npu0_vlink1.emacvlan1
set vdom VDOM2
set type emac-vlan
set interface npu0_vlink1
next
end

Example 3: Enhanced MAC VLAN configuration for unique MAC addresses for each
VLAN interface on the same physical port
Some networks require a unique MAC address for each VLAN interface when the VLAN interfaces share the same
physical port. In this case, the enhanced MAC VLAN interface is used the same way as normal VLAN interfaces.
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To configure this, use the set vlanid command for the VLAN tag. The VLAN ID and interface must be a unique pair,
even if they belong to different VDOMs.

To configure enhanced MAC VLAN:
config system interface
edit <interface-name>
set type emac-vlan
set vlanid <VLAN-ID>
set interface <physical-interface>
next
end

Inter-VDOM routing
In the past, virtual domains (VDOMs) were separate from each other and there was no internal communication. Any
communication between VDOMs involved traffic leaving on a physical interface belonging to one VDOM and re-entering
the FortiGate unit on another physical interface belonging to another VDOM to be inspected by firewall policies in both
directions.
Inter-VDOM routing changes this. With VDOM links, VDOMs can communicate internally without using additional
physical interfaces.
Inter-VDOM routing is the communication between VDOMs. VDOM links are virtual interfaces that connect VDOMs. A
VDOM link contains a pair of interfaces, each one connected to a VDOM and forming either end of the inter-VDOM
connection.
When VDOMs are configured on your FortiGate unit, configuring inter-VDOM routing and VDOM-links is very much like
creating a VLAN interface. VDOM-links are managed through the web-based manager or CLI. In the web-based
manager, VDOM link interfaces are managed in the network interface list.

VDOM link does not support traffic offload. If you want to use traffic offload, use NPU-VDOMLINK.

To configure a VDOM link in the GUI:
1. Go to Network > Interfaces.
2. Click Create New > VDOM Link.
3. Configure the fields including the Name, Virtual Domain, IP information, access levels, and other fields.

To configure a VDOM link in the CLI:
config system vdom-link
edit "<vdom-link-name>"
next
end
config system interface
edit "<vdom-link-name0>"
set vdom "<VDOM Name>"
set type vdom-link
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next
end
config system interface
edit "<vdom-link-name1>"
set vdom "<VDOM Name>"
set type vdom-link
next
end

To delete a VDOM link in the GUI:
1. Go to Network > Interfaces.
2. Select a VDOM Link and click Delete.

To delete a VDOM link in the CLI:
config system vdom-link
delete <VDOM-LINK-Name>
end

Sample configuration: Inter-VDOM routing

This example shows how to configure a FortiGate unit to use inter-VDOM routing.
Two departments of a company, Accounting and Sales, are connected to one FortiGate. The company uses a single ISP
to connect to the Internet.
This example includes the following general steps. We recommend following the steps in the order below.

Create the VDOMs
To enable VDOMs and create the Sales and Accounting VDOMs:
config system global
set vdom-mode multi-vdom
end
config system vdom
edit Accounting
next
edit Sales
next
end

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

308

Network

Configure the physical interfaces
Next, configure the physical interfaces. This example uses three interfaces on the FortiGate unit: port2 (internal), port3
(DMZ), and port1 (external). Port2 and port3 interfaces each have a department’s network connected. Port1 is for all
traffic to and from the Internet and uses DHCP to configure its IP address, which is common with many ISPs.
config global
config system interface
edit port2
set alias AccountingLocal
set vdom Accounting
set mode static
set ip 172.100.1.1 255.255.0.0
set allowaccess https ping ssh
set description "The accounting dept internal interface"
next
edit port3
set alias SalesLocal
set vdom Sales
set mode static
set ip 192.168.1.1 255.255.0.0
set allowaccess https ping ssh
set description "The sales dept. internal interface"
next
edit port1
set alias ManagementExternal
set vdom root
set mode DHCP
set distance 5
set gwdetect enable
set dns-server-override enable
set allowaccess https ssh snmp
set description “The systemwide management interface.”
end
end

Configure the VDOM links
To complete the connection between each VDOM and the management VDOM, add the two VDOM links. One pair is the
Accounting – management link and the other is the Sales – management link.
When configuring inter-VDOM links, you do not have to assign IP addresses to the links unless you are using advanced
features such as dynamic routing that require them. Not assigning IP addresses results in faster configuration and more
available IP addresses on your networks.

To configure the Accounting and management VDOM link:
config global
config system vdom-link
edit AccountVlnk
next
end
config system interface
edit AccountVlnk0
set vdom Accounting
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set ip 11.11.11.2 255.255.255.0
set allowaccess https ping ssh
set description “Accounting side of the VDOM link“
next
edit AccountVlnk1
set vdom root
set ip 11.11.11.1 255.255.255.0
set allowaccess https ping ssh
set description “Management side of the VDOM link“
end
end

To configure the Sales and management VDOM link:
config global
config system vdom-link
edit SalesVlnk
end
config system interface
edit SalesVlnk0
set vdom Sales
set ip 12.12.12.2 255.255.255.0
set allowaccess https ping ssh
set description "Sales side of the VDOM link"
next
edit SalesVlnk1
set vdom root
set ip 12.12.12.1 255.255.255.0
set allowaccess https ping ssh
set description "Management side of the VDOM link"
end
end

Configure the firewall and Security Profile
With the VDOMs, physical interfaces, and VDOM links configured, the firewall must now be configured to allow the
proper traffic. Firewalls are configured per-VDOM, and firewall objects and routes must be created for each VDOM
separately.

To configure the firewall policies from AccountingLocal to Internet:
config vdom
edit Accounting
config firewall policy
edit 1
set name "Accounting-Local-to-Management"
set srcintf port2
set dstintf AccountVlnk
set srcaddr all
set dstaddr all
set action accept
set schedule always
set service ALL
set nat enable
end
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end
config vdom
edit root
config firewall policy
edit 2
set name "Accounting-VDOM-to-Internet"
set srcintf AccountVlnk
set dstintf port1
set srcaddr all
set dstaddr all
set action accept
set schedule always
set service ALL
set nat enable
end
end

To configure the firewall policies from SalesLocal to the Internet:
config vdom
edit root
config firewall policy
edit 6
set name "Sales-local-to-Management"
set srcintf port2
set srcaddr all
set dstintf SalesVlnk
set dstaddr all
set schedule always
set service ALL
set action accept
set logtraffic enable
end
end
config vdom
edit Sales
config firewall policy
edit 7
set name "Sales-VDOM-to-Internet"
set srcintf SalesVlnk
set srcaddr SalesManagement
set dstintf external
set dstaddr all
set schedule always
set service OfficeServices
set action accept
set logtraffic enable
end
end

Test the configuration
When the inter-VDOM routing has been configured, test the configuration to confirm proper operation.
Testing connectivity ensures that physical networking connections, FortiGate unit interface configurations, and firewall
policies are properly configured.
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The easiest way to test connectivity is to use the ping and traceroute command to confirm the connectivity of
different routes on the network.
Test both from AccountingLocal to Internet and from SalesLocal to Internet.

Software switch
A software switch, or soft switch, is a virtual switch that is implemented at the software or firmware level and not at the
hardware level. A software switch can be used to simplify communication between devices connected to different
FortiGate interfaces. For example, using a software switch, you can place the FortiGate interface connected to an
internal network on the same subnet as your wireless interfaces. Then devices on the internal network can communicate
with devices on the wireless network without any additional configuration on the FortiGate unit, such as additional
security policies.
A software switch can also be useful if you require more hardware ports for the switch on a FortiGate unit. For example, if
your FortiGate unit has a 4-port switch, WAN1, WAN2, and DMZ interfaces, and you need one more port, you can create
a soft switch that can include the four-port switch and the DMZ interface, all on the same subnet. These types of
applications also apply to wireless interfaces, virtual wireless interfaces, and physical interfaces such as those in
FortiWiFi and FortiAP units.
Similar to a hardware switch, a software switch functions like a single interface. A soft switch has one IP address and all
the interfaces in the software switch are on the same subnet. Traffic between devices connected to each interface are
not regulated by security policies, and traffic passing in and out of the switch are controlled by the same policy.
When setting up a software switch, consider the following:
l
l

l

l

Ensure you have a back up of the configuration.
Ensure you have at least one port or connection such as the console port to connect to the FortiGate unit. If you
accidentally combine too many ports, you need a way to undo errors.
The ports that you include must not have any link or relation to any other aspect of the FortiGate unit, such as DHCP
servers, security policies, and so on.
For increased security, you can create a captive portal for the switch to allow only specific user groups access to the
resources connected to the switch.

To create a software switch in the GUI:
1.
2.
3.
4.

Go to Network > Interfaces.
Click Create New > Interface.
Set Type to Software Switch.
Configure the Interface Name, Virtual Domain, Interface Members, and other fields.

To create a software switch in the CLI:
config system switch-interface
edit <switch-name>
set type switch
set member <interface_list>
end
config system interface
edit <switch_name>
set ip <ip_address>

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

312

Network

set allowaccess https ssh ping
end

Sample configuration: software switch
For this example, the wireless interface (WiFi) needs to be on the same subnet as the DMZ1 interface to facilitate
wireless syncing from an iPhone and a local computer. Because synching between two subnets is problematic, putting
both interfaces on the same subnet the synching will work. The software switch will accomplish this.
1. Clear the interfaces and back up the configuration.
a. Ensure the interfaces are not used for other security policy or for other use on the FortiGate unit.
b. Check the WiFi and DMZ1 ports to ensure DHCP is not enabled on the interface and that there are no other
dependencies on these interfaces.
c. Save the current configuration so that if something doesn’t work, recovery can be quick.
2. Merge the interfaces.
Merge the WiFi port and DMZ1 port to create a software switch named synchro with an IP address of 10.10.21.12.
Use the following CLI commands to create the switch, add the IP, and then set the administrative access for
HTTPS, SSH and Ping.
config system switch-interface
edit synchro
set type switch
set member dmz1 wifi
end
config system interface
edit synchro
set ip 10.10.21.12
set allowaccess https ssh ping
end

When the soft switch is set up, you now add security policies, DHCP servers, and any other configuration you
normally do to configure interfaces on the FortiGate unit.

Zone
Zones are a group of one or more physical or virtual FortiGate interfaces that you can apply security policies to control
inbound and outbound traffic. Grouping interfaces and VLAN subinterfaces into zones simplifies the creation of security
policies where a number of network segments can use the same policy settings and protection profiles.
When you add a zone, you select the names of the interfaces and VLAN subinterfaces to add to the zone. Each interface
still has its own address. Routing is still done between interfaces, that is, routing is not affected by zones. You can use
security policies to control the flow of intra-zone traffic.
For example, in the sample configuration below, the network includes three separate groups of users representing
different entities on the company network. While each group has its own set of ports and VLANs in each area, they can
all use the same security policy and protection profiles to access the Internet. Rather than the administrator making nine
separate security policies, he can make administration simpler by adding the required interfaces to a zone and creating
three policies.
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Sample configuration
You can configure policies for connections to and from a zone but not between interfaces in a zone. For this example,
you can create a security policy to go between zone 1 and zone 3, but not between WAN2 and WAN1, or WAN1 and
DMZ1.

To create a zone in the GUI:
1. Go to Network > Interfaces.

If VDOMs are enabled, go to the VDOM to create a zone.

2. Click Create New > Zone.
3. Configure the Name and add the Interface Members.

To configure a zone to include the internal interface and a VLAN using the CLI:
config system zone
edit Zone_1
set interface internal VLAN_1
set intrazone deny/allow
end
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Using zone in a firewall policy
To configure a firewall policy to allow any interface to access the Internet using the CLI:
config firewall policy
edit 2
set name "2"
set srcintf "Zone_1"
set dstintf "port15"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

Intra-zone traffic
In the zone configuration you can set intrazone deny to prohibit the different interfaces in the same zone to talk to
each other.
For example, if you have ten interfaces in your zone and the intrazone setting is deny. You now want to allow traffic
between a very small number of networks on different interfaces that are part of the zone but you do not want to disable
the intra-zone blocking.
In this example, the zone VLANs are defined as: 192.168.1.0/24, 192.168.2.0/24, ... 192.168.10.0/24.
This policy allows traffic from 192.168.1.x to 192.168.2.x even though they are in the same zone and intra-zone blocking
is enabled. The intra-zone blocking acts as a default deny rule and you have to specifically override it by creating a policy
within the zone.

To enable intra-zone traffic, create the following policy:
Source Interface

Zone-name, e.g., Vlans

Source Address

192.168.1.0/24

Destination

Zone-name (same as Source Interface, i.e., Vlans)

Destination Address

192.168.2.0/24

Virtual Wire Pair
A virtual wire pair consists of two interfaces that do not have IP addressing and are treated like a transparent mode
VDOM. All traffic received by one interface in the virtual wire pair can only be forwarded to the other interface, provided a
virtual wire pair firewall policy allows this traffic. Traffic from other interfaces cannot be routed to the interfaces in a virtual
wire pair. Redundant and 802.3ad aggregate (LACP) interfaces can be included in a virtual wire pair.
Virtual wire pairs are useful for a typical topology where MAC addresses do not behave normally. For example, port
pairing can be used in a Direct Server Return (DSR) topology where the response MAC address pair may not match the
request’s MAC address pair.
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Example
In this example, a virtual wire pair (port3 and port4) makes it easier to protect a web server that is behind a FortiGate
operating as an Internal Segmentation Firewall (ISFW). Users on the internal network access the web server through the
ISFW over the virtual wire pair.
Interfaces used in a virtual wire pair cannot be used to access the ISFW FortiGate. Before
creating a virtual wire pair, make sure you have a different port configured to allow admin
access using your preferred protocol.

To add a virtual wire pair using the CLI:
config system virtual-wire-pair
edit "VWP-name"
set member "port3" "port4"
set wildcard-vlan disable
next
end

To add a virtual wire pair using the GUI:
1. Go to Network > Interfaces.
2. Click Create New > Virtual Wire Pair.
3. Select the Interface Members to add to the virtual wire pair.
These interfaces cannot be part of a switch, such as the default LAN/internal interface.
4. If required, enable Wildcard VLAN and set the VLAN Filter..
5. Click OK.

To create a virtual wire pair policy using the CLI:
config firewall policy
edit 1
set name "VWP-Policy"
set srcintf "port3" "port4"
set dstintf "port3" "port4"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set fsso disable
next
end
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To create a virtual wire pair policy using the GUI:
1.
2.
3.
4.
5.

Go to Policy & Objects > IPv4 Virtual Wire Pair Policy.
Click Create New.
Select the direction that traffic is allowed to flow.
Configure the other fields.
Click OK.

Failure detection for aggregate and redundant interfaces
When an aggregate or redundant interface goes down, the corresponding fail-alert interface changes to down. When an
aggregate or redundant interface comes up, the corresponding fail-alert interface changes to up.

Fail-detect for aggregate and redundant interfaces can be configured using the CLI.

To configure an aggregate interface so that port3 goes down with it:
config system interface
edit "agg1"
set vdom "root"
set fail-detect enable
set fail-alert-method link-down
set fail-alert-interfaces "port3"
set type aggregate
set member "port1" "port2"
next
end

To configure a redundant interface so that port4 goes down with it:
config system interface
edit "red1"
set vdom "root"
set fail-detect enable
set fail-alert-method link-down
set fail-alert-interfaces "port4"
set type redundant
set member "port1" "port2"
next
end
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VLAN inside VXLAN
VLANs can be assigned to VXLAN interfaces. In a data center network where VXLAN is used to create an L2 overlay
network and for multitenant environments, a customer VLAN tag can be assigned to VXLAN interface.

To configure VLAN inside VXLAN:
1. Configure VXLAN:
config system vxlan
edit "vxlan1"
set interface port1
set vni 1000
set remote-ip 172.16.200.3
next
end

2. Configure system interface:
config system interface
edit vlan100
set vdom root
set vlanid 100
set interface dmz
next
edit vxlan100
set type vlan
set vlanid 100
set vdom root
set interface vxlan1
next
end

3. Configure software-switch:
config system switch-interface
edit sw1
set vdom root
set member vlan100 vxlan100
next
end

Virtual Wire Pair with VXLAN
Virtual wire pairs can be used with VXLAN interfaces.
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In this examples, VXLAN interfaces are added between FortiGate HQ1 and FortiGate HQ2, a virtual wire pair is added in
HQ1, and firewall policies are created on both HQ1 and HQ2.

To create VXLAN interface on HQ1:
config system interface
edit "port11"
set vdom "root"
set ip 10.2.2.1 255.255.255.0
set allowaccess ping https ssh snmp telnet
next
end
config system vxlan
edit "vxlan1"
set interface "port11"
set vni 1000
set remote-ip "10.2.2.2"
next
end

To create VXLAN interface on HQ2:
config system interface
edit "port11"
set vdom "root"
set ip 10.2.2.2 255.255.255.0
set allowaccess ping https ssh snmp http
next
end
config system vxlan
edit "vxlan1"
set interface "port11"
set vni 1000
set remote-ip "10.2.2.1"
next
end
config system interface
edit "vxlan1"
set vdom "root"
set ip 10.1.100.2 255.255.255.0
set allowaccess ping https ssh snmp
next
end

To create a virtual wire pair on HQ1:
config system virtual-wire-pair
edit "vwp1"
set member "port10" "vxlan1"
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next
end

To create a firewall policy on HQ1:
config firewall policy
edit 5
set name "vxlan-policy"
set srcintf "port10" "vxlan1"
set dstintf "port10" "vxlan1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set ssl-ssh-profile "certificate-inspection"
set av-profile "default"
set webfilter-profile "default"
set dnsfilter-profile "default"
set ips-sensor "default"
set application-list "default"
set fsso disable
next
end

To create a firewall policy on HQ2:
config firewall policy
edit 5
set name "1"
set srcintf "port13"
set dstintf "vxlan1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set fsso disable
set nat enable
next
end

DNS
Domain name system (DNS) is used by devices to locate websites by mapping a domain name to a website’s IP
address.
A FortiGate can serve different roles based on user requirements:
l
l

A FortiGate can control what DNS server a network uses.
A FortiGate can function as a DNS server.
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FortiGuard Dynamic DNS (DDNS) allows a remote administrator to access a FortiGate's Internet-facing interface using a
domain name that remains constant even when its IP address changes.
FortiOS supports DNS configuration for both IPv4 and IPv6 addressing. When a user requests a website, the FortiGate
looks to the configured DNS servers to provide the IP address of the website in order to know which server to contact to
complete the transaction.
The FortiGate queries the DNS servers whenever it needs to resolve a domain name into an IP address, such as for NTP
or web servers defined by their domain names.
The following topics provide information about DNS:
l
l
l
l
l
l
l

Important DNS CLI commands on page 321
DNS domain list on page 322
FortiGate DNS server on page 324
DDNS on page 326
DNS latency information on page 329
DNS over TLS on page 331
DNS troubleshooting on page 331

Important DNS CLI commands
DNS settings can be configured with the following CLI command:
config system dns
set primary <ip_address>
set secondary <ip_address>
set dns-over-tls {enable | disable | enforce}
set ssl-certificate <string>
set domain <domains>
set ip6-primary <ip6_address>
set ip6-secondary <ip6_address>
set timeout <integer>
set retry <integer>
set dns-cache-limit <integer>
set dns-cache-ttl <integer>
set cache-notfound-responses {enable | disable}
set source-ip <class_ip>
end

For a FortiGate with multiple logical CPUs, you can set the DNS process number from 1 to the number of logical CPUs.
The default DNS process number is 1.
config system global
set dnsproxy-worker-count <integer>
end

dns-over-tls
DNS over TLS (DoT) is a security protocol for encrypting and wrapping DNS queries and answers via the Transport
Layer Security (TLS) protocol. It can be enabled, disabled, or enforced:
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l
l
l

disable: Disable DNS over TLS (default).
enable: Use TLS for DNS queries if TLS is available.
enforce: Use only TLS for DNS queries. Does not fall back to unencrypted DNS queries if TLS is unavailable.

For more information, see DNS over TLS on page 331.

cache-notfound-responses
When enabled, any DNS requests that are returned with NOT FOUND can be stored in the cache. The DNS server is not
asked to resolve the host name for NOT FOUND entries. By default, this option is disabled.

dns-cache-limit
Set the number of DNS entries that are stored in the cache (0 to 4294967295, default = 5000). Entries that remain in the
cache provide a quicker response to requests than going out to the Internet to get the same information.

dns-cache-ttl
The duration that the DNS cache retains information, in seconds (60 to 86400 (1 day), default = 1800).

DNS domain list
You can configure up to eight domains in the DNS settings using the GUI or the CLI.
When a client requests a URL that does not include an FQDN, FortiOS resolves the URL by traversing through the DNS
domain list and performing a query for each domain until the first match is found.
By default, FortiGate uses FortiGuard's DNS servers:
l
l

Primary: 208.91.112.53
Secondary: 208.91.112.52

You can also customize the DNS timeout time and the number of retry attempts.

To configure a DNS domain list in the GUI:
1.
2.
3.
4.
5.

Go to Network > DNS.
Set DNS Servers to Specify.
Configure the primary and secondary DNS servers as needed.
In the Local Domain Name field, enter the first domain (sample.com in this example).
Click the + to add more domains (example.com and domainname.com in this example). You can enter up to eight
domains.
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6. Configure additional DNS settings as needed.
7. Click Apply.

To configure a DNS domain list in the CLI:
config system dns
set primary 172.16.200.1
set domain "sample.com" "example.com" "domainname.com"
end

Verify the DNS configuration
In the following example, the local DNS server has the entry for host1 mapped to the FQDN of host1.sample.com, and
the entry for host2 is mapped to the FQDN of host2.example.com.

To verify that the DNS domain list is configured:
1. Open Command Prompt.
2. Enter ping host1.
The system returns the following response:
PING host1.sample.com (1.1.1.1): 56 data bytes

As the request does not include an FQDN, FortiOS traverses the configured DNS domain list to find a match.
Because host1 is mapped to the host1.sample.com, FortiOS resolves host1 to sample.com, the first entry in the
domain list.
3. Enter ping host2.
The system returns the following response:
PING host2.example.com (2.2.2.2): 56 data bytes

FortiOS traverses the domain list to find a match. It first queries sample.com, the first entry in the domain list, but
does not find a match. It then queries the second entry in the domain list, example.com. Because host2 is mapped
to the FQDN of host2.example.com, FortiOS resolves host2 to example.com.

DNS timeout and retry settings
The DNS timeout and retry settings can be customized using the CLI.
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config system dns
set timeout <integer>
set retry <integer>
end

Variable

Description

timeout <integer>

The DNS query timeout interval, in seconds (1 - 10, default = 5).

retry <integer>

The number of times to retry the DNS query (0 - 5, default - 2).

FortiGate DNS server
You can create local DNS servers for your network. Depending on your requirements, you can either manually maintain
your entries (master DNS server), or use it to refer to an outside source (slave DNS server).
A local, master DNS server requires that you to manually add all URL and IP address combinations. Using a master DNS
server for local services can minimize inbound and outbound traffic, and access time. Making it authoritative is not
recommended, because IP addresses can change, and maintaining the list can become labor intensive.
A slave DNS server refers to an alternate source to obtain URL and IP address combinations. This is useful when there
is a master DNS server where the entry list is maintained.
In version 6.2 and later, FortiGate as a DNS server also supports TLS connections to a DNS client. See DNS over TLS
on page 331 for details.
By default, DNS server options are not available in the FortiGate GUI.

To enable DNS server options in the GUI:
1. Go to System > Feature Visibility.
2. Enable DNS Database in the Additional Features section.
3. Click Apply.

Example configuration
This section describes how to create an unauthoritative master DNS server. The interface mode is recursive so that, if
the request cannot be fulfilled, the external DNS servers will be queried.

To configure FortiGate as a master DNS server in the GUI:
1.
2.
3.
4.

Go to Network > DNS Servers.
In the DNS Database table, click Create New.
Set Type to Master.
Set View to Shadow.
The View setting controls the accessibility of the DNS server. If you select Public, external users can access or use
the DNS server. If you select Shadow, only internal users can use it.

5.
6.
7.
8.

Enter a DNS Zone, for example, WebServer.
Enter the Domain Name of the zone, for example, fortinet.com.
Enter the Hostname of the DNS server, for example, Corporate.
Enter the Contact Email Address for the administrator, for example, admin@example.com.
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9. Disable Authoritative.

10. Add DNS entries:
a. In the DNS Entries table, click Create New.
b. Select a Type, for example Address (A).
c. Set the Hostname, for example web.example.com.

d. Configure the remaining settings as needed. The options vary depending on the selected Type.
e. Click OK.
11. Add more DNS entries as needed.
12. Click OK.
13. Enable DNS services on an interface:
a. Go to Network > DNS Servers.
b. In the DNS Service on Interface table, click Create New.
c. Select the Interface for the DNS server, such as wan2.
d. Set the Mode to Recursive.
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e. Click OK.

To configure FortiGate as a master DNS server in the CLI:
config system dns-database
edit WebServer
set domain example.com
set type master
set view shadow
set ttl 86400
set primary-name corporate
set contact admin@example.com
set authoritative disable
config dns-entry
edit 1
set hostname web.example.com
set type A
set ip 192.168.21.12
set status enable
next
end
next
end
config system dns-server
edit wan1
set mode recursive
next
end

DDNS
If your external IP address changes regularly and you have a static domain name, you can configure the external
interface to use a dynamic DNS (DDNS) service. This ensures that external users and customers can always connect to
your company firewall. If you have a FortiGuard subscription, you can use FortiGuard as the DDNS server.

l
l

FortiGate does not support DDNS for pure TP mode.
FortiGate models 1000D and higher do not support DDNS in the GUI.

You can configure FortiGuard as the DDNS server using the GUI or CLI.
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Sample topology

To configure FortiGuard as the DDNS server in the GUI:
1.
2.
3.
4.
5.

Go to Network > DNS
Enable FortiGuard DDNS.
Select the Interface with the dynamic connection.
Select the Server that you have an account with.
Enter your Unique Location.

6. Click Apply.

To configure FortiGuard as the DDNS server in the CLI:
config system ddns
edit <1>
set ddns-server FortiGuardDDNS
set ddns-domain "branch.float-zone.com"
set monitor-interface "wan1"
next
end
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DDNS servers other than FortiGuard
If you do not have a FortiGuard subscription, or want to use a different DDNS server, you can configure a DDNS server
for each interface. Only the first configure port appears in the GUI. The available commands vary depending on the
selected DDNS server.

To configure DDNS servers other than FortiGuard in the CLI:
config system ddns
edit <DDNS_ID>
set monitor-interface <external_interface>
set ddns-server <ddns_server_selection>
...
next
end

Refresh DDNS IP addresses
You can configure FortiGate to refresh DDNS IP addresses. FortiGate periodically checks the DDNS server that is
configured.

To configure FortiGate to refresh DDNS IP addresses using the CLI:
config system ddns
edit <1>
set ddns-server FortiGuardDDNS
set use-public-ip enable
set update-interval seconds
next
end

Disable cleartext
When clear-text is disabled, FortiGate uses the SSL connection to send and receive (DDNS) updates.

To disable cleartext and set the SSL certificate using the CLI:
config system ddns
edit <1>
set clear-text disable
set ssl-certificate <cert_name>
next
end

DDNS update override
A DHCP server has an override command option that allows DHCP server communications to go through DDNS to
perform updates for the DHCP client. This enforces a DDNS update of the A field every time even if the DHCP client
does not request it. This allows support for the allow, ignore, and deny client-updates options.
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To enable DDNS update override using the CLI:
config system dhcp server
edit <0>
set ddns-update enable
set ddns-update_override enable
set ddns-server-ip <ddns_server_ip>
set ddns-zone <ddns_zone>
next
end

DNS latency information
High latency in DNS traffic can result in an overall sluggish experience for end-users. In the DNS Settings pane, you can
quickly identify DNS latency issues in your configuration.
Go to Network > DNS to view DNS latency information in the right side bar. If you use FortiGuard DNS, latency
information for DNS, DNS filter, web filter, and outbreak prevention servers is also visible. Hover your pointer over a
latency value to see when it was last updated.

To view DNS latency information using the CLI:
# diagnose test application dnsproxy 2
worker idx: 0
worker: count=1 idx=0
retry_interval=500 query_timeout=1495
DNS latency info:
vfid=0 server=2001::1 latency=1494 updated=73311
vfid=0 server=208.91.112.52 latency=1405 updated=2547
vfid=0 server=208.91.112.53 latency=19 updated=91
SDNS latency info:
vfid=0 server=173.243.138.221 latency=1 updated=707681
DNS_CACHE: alloc=35, hit=26
RATING_CACHE: alloc=1, hit=49
DNS UDP: req=66769 res=63438 fwd=83526 alloc=0 cmp=0 retrans=16855 to=3233
cur=111 switched=8823467 num_switched=294 v6_cur=80 v6_switched=7689041 num_v6_
switched=6
ftg_res=8 ftg_fwd=8 ftg_retrans=0
DNS TCP: req=0, res=0, fwd=0, retrans=0 alloc=0, to=0
FQDN: alloc=45 nl_write_cnt=9498 nl_send_cnt=21606 nl_cur_cnt=0
Botnet: searched=57 hit=0 filtered=57 false_positive=0
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To view the latency from web filter and outbreak protection servers using the CLI:
# diagnose debug rating
Locale
: english
Service
Status
License

: Web-filter
: Enable
: Contract

Service
Status

: Antispam
: Disable

Service
Status

: Virus Outbreak Prevention
: Disable

-=- Server List (Tue Jan 22 08:03:14 2019) -=IP
173.243.138.194
2019
173.243.138.195
2019
173.243.138.198
2019
173.243.138.196
2019
173.243.138.197
2019
96.45.33.64
2019
64.26.151.36
2019
64.26.151.35
2019
209.222.147.43
2019
66.117.56.42
2019
66.117.56.37
2019
65.210.95.239
2019
65.210.95.240
2019
45.75.200.88
2019
45.75.200.87
2019
45.75.200.85
2019
45.75.200.86
2019
62.209.40.72
2019
62.209.40.74
2019

Weight RTT Flags
10
0 DI

TZ
-8

Packets
700

Curr Lost Total Lost
0
2

Updated Time
Tue Jan 22 08:02:44

10

0

-8

698

0

4

Tue Jan 22 08:02:44

10

0

-8

698

0

4

Tue Jan 22 08:02:44

10

0

-8

697

0

3

Tue Jan 22 08:02:44

10

1

-8

694

0

0

Tue Jan 22 08:02:44

10

22 D

-8

701

0

6

Tue Jan 22 08:02:44

40

62

-5

704

0

10

Tue Jan 22 08:02:44

40

62

-5

703

0

9

Tue Jan 22 08:02:44

40

70 D

-5

696

0

1

Tue Jan 22 08:02:44

40

70

-5

697

0

3

Tue Jan 22 08:02:44

40

71

-5

702

0

9

Tue Jan 22 08:02:44

40

74

-5

695

0

1

Tue Jan 22 08:02:44

40

74

-5

695

0

1

Tue Jan 22 08:02:44

90

142

0

706

0

12

Tue Jan 22 08:02:44

90

155

0

714

0

20

Tue Jan 22 08:02:44

90

156

0

711

0

17

Tue Jan 22 08:02:44

90

159

0

704

0

10

Tue Jan 22 08:02:44

100

157

1

701

0

7

Tue Jan 22 08:02:44

100

173

1

705

0

11

Tue Jan 22 08:02:44
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62.209.40.73
2019
121.111.236.179
2019
121.111.236.180
2019

100

173

1

699

0

5

Tue Jan 22 08:02:44

180

138

9

706

0

12

Tue Jan 22 08:02:44

180

138

9

704

0

10

Tue Jan 22 08:02:44

DNS over TLS
DNS over TLS (DoT) is a security protocol for encrypting and wrapping DNS queries and answers via the TLS protocol.
The goal of DNS over TLS is to increase user privacy and security by preventing eavesdropping and manipulation of
DNS data via man-in-the-middle attacks. There is an option in the FortiOS DNS profile settings to enforce DoT for this
added security.

To configure DoT in the GUI:
1. Go to Network > DNS. The DNS Settings pane opens.
2. For DNS over TLS, click Enforce.

3. Click Apply.

To configure DoT in the CLI:
config system dns
set primary 8.8.8.8
set dns-over-tls enforce
set ssl-certificate "Fortinet_Factory"
end

DNS troubleshooting
The following diagnose command can be used to collect DNS debug information. If you do not specify worker ID, the
default worker ID is 0.
# diagnose test application dnsproxy
worker idx: 0
1. Clear DNS cache
2. Show stats
3. Dump DNS setting
4. Reload FQDN
5. Requery FQDN
6. Dump FQDN
7. Dump DNS cache
8. Dump DNS DB
9. Reload DNS DB
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10.
11.
12.
13.
14.
15.
16.
17.
99.

Dump secure DNS policy/profile
Dump Botnet domain
Reload Secure DNS setting
Show Hostname cache
Clear Hostname cache
Show SDNS rating cache
Clear SDNS rating cache
DNS debug bit mask
Restart dnsproxy worker

To view useful information about the ongoing DNS connection:
# diagnose test application dnsproxy 3
worker idx: 0
vdom: root, index=0, is master, vdom dns is disabled, mip-169.254.0.1 dns_log=1 tls=0 cert=
dns64 is disabled
vdom: vdom1, index=1, is master, vdom dns is enabled, mip-169.254.0.1 dns_log=1 tls=0 cert=
dns64 is disabled
dns-server:208.91.112.220:53 tz=-480 tls=0 req=0 to=0 res=0 rt=0 rating=1 ready=0 timer=37
probe=9 failure=0 last_failed=0
dns-server:8.8.8.8:53 tz=0 tls=0 req=73 to=0 res=73 rt=5 rating=0 ready=1 timer=0 probe=0
failure=0 last_failed=0
dns-server:65.39.139.63:53 tz=0 tls=0 req=39 to=0 res=39 rt=1 rating=0 ready=1 timer=0
probe=0 failure=0 last_failed=0
dns-server:62.209.40.75:53 tz=60 tls=0 req=0 to=0 res=0 rt=0 rating=1 ready=0 timer=37
probe=9 failure=0 last_failed=0
dns-server:209.222.147.38:53 tz=-300 tls=0 req=0 to=0 res=0 rt=0 rating=1 ready=0 timer=37
probe=9 failure=0 last_failed=0
dns-server:173.243.138.221:53 tz=-480 tls=0 req=0 to=0 res=0 rt=0 rating=1 ready=0 timer=37
probe=9 failure=0 last_failed=0
dns-server:45.75.200.89:53 tz=0 tls=0 req=0 to=0 res=0 rt=0 rating=1 ready=0 timer=37
probe=9 failure=0 last_failed=0
DNS_CACHE: hash-size=2048, ttl=1800, min-ttl=60, max-num=-1
DNS FD: udp_s=12 udp_c=17:18 ha_c=22 unix_s=23, unix_nb_s=24, unix_nc_s=25
v6_udp_s=11, v6_udp_c=20:21, snmp=26, redir=13, v6_redir=14
DNS FD: tcp_s=29, tcp_s6=27, redir=31 v6_redir=32
FQDN: hash_size=1024, current_query=1024
DNS_DB: response_buf_sz=131072
LICENSE: expiry=2015-04-08, expired=1, type=2
FDG_SERVER:208.91.112.220:53
FGD_CATEGORY_VERSION:8
SERVER_LDB: gid=eb19, tz=-480, error_allow=0
FGD_REDIR_V4:208.91.112.55 FGD_REDIR_V6:

Important fields include:
tls

1 if the connection is TLS, 0 if the connection is not TLS.

rt

The round trip time of the DNS latency.

probe

The number of probes sent.

To dump the second DNS worker's cache:
diagnose test application dnsproxy 7 1
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To enable debug on the second worker:
diagnose debug application dnsproxy -1 1

To enable debug on all workers by specifying -1 as worker ID:
diagnose debug application dnsproxy -1 -1

Explicit and transparent proxies
This section contains instructions for configuring explicit and transparent proxies.
l
l
l
l
l
l
l
l
l
l

Explicit web proxy on page 333
Transparent proxy on page 338
FTP proxy on page 336
Proxy policy addresses on page 341
Proxy policy security profiles on page 349
Explicit proxy authentication on page 355
Transparent web proxy forwarding on page 360
Multiple dynamic header count on page 361
Restricted SaaS access (Office 365, G Suite, Dropbox) on page 364
Explicit proxy and FortiSandbox Cloud on page 366

Explicit web proxy
Explicit web proxy can be configured on FortiGate for proxying HTTP and HTTPS traffic.
To deploy explicit proxy, individual client browsers can be manually configured to send requests directly to the proxy, or
they can be configured to download proxy configuration instructions from a Proxy Auto-Configuration (PAC) file.
When explicit proxy is configured on an interface, the interface IP address can be used by client browsers to forward
requests directly to the FortiGate. FortiGate also supports PAC file configuration.

To configure explicit web proxy in the GUI:
1. Enable and configure explicit web proxy:
a. Go to Network > Explicit Proxy.
b. Enable Explicit Web Proxy.
c. Select port2 as the Listen on Interfaces and set the HTTP Port to 8080.
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d. Configure the remaining settings as needed.

e. Click Apply.
2. Create an explicit web proxy policy:
a. Go to Policy & Objects > Proxy Policy.
b. Click Create New.
c. Set Proxy Type to Explicit Web and Outgoing Interface to port1.
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d. Also set Source and Destination to all, Schedule to always, Service to webproxy, and Action to ACCEPT.

e. Click OK to create the policy.

This example creates a basic policy. If required, security profiles can be enabled, and deep
SSL inspection can be selected to inspect HTTPS traffic.

3. Configure a client to use the FortiGate explicit proxy:
Set the FortiGate IP address as the proxy IP address in the browser, or use an automatic configuration script for the
PAC file.

To configure explicit web proxy in the CLI:
1. Enable and configure explicit web proxy:
config web-proxy explicit
set status enable
set ftp-over-http enable
set socks enable
set http-incoming-port 8080
set ipv6-status enable
set unknown-http-version best-effort
end
config system interface

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

335

Network

edit "port2"
set vdom "vdom1"
set ip 10.1.100.1 255.255.255.0
set allowaccess ping https ssh snmp http telnet
set type physical
set explicit-web-proxy enable
set snmp-index 12
end
next
end

2. Create an explicit web proxy policy:
config firewall proxy-policy
edit 1
set uuid 722b6130-13aa-51e9-195b-c4196568d667
set proxy explicit-web
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set service "webproxy"
set action accept
set schedule "always"
set logtraffic all
next
end

This example creates a basic policy. If required, security profiles can be enabled, and deep
SSL inspection can be selected to inspect HTTPS traffic.

3. Configure a client to use the FortiGate explicit web proxy:
Set the FortiGate IP address as the proxy IP address in the browser, or use an automatic configuration script for the
PAC file.

FTP proxy
FTP proxies can be configured on the FortiGate so that FTP traffic can be proxied. When the FortiGate is configured as
an FTP proxy, FTP client applications should be configured to send FTP requests to the FortiGate.

To configure explicit FTP proxy in the GUI:
1. Enable and configure explicit FTP proxy:
a. Go to Network > Explicit Proxy.
b. Enable Explicit FTP Proxy.
c. Select port2 as the Listen on Interfaces and set the HTTP Port to 21.
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d. Configure the Default Firewall Policy Action as needed.

e. Click Apply.
2. Create an explicit FTP proxy policy:
a. Go to Policy & Objects > Proxy Policy.
b. Click Create New.
c. Set Proxy Type to FTP and Outgoing Interface to port1.
d. Also set Source and Destination to all, Schedule to always, and Action to ACCEPT.

e. Click OK to create the policy.

This example creates a basic policy. If required, security profiles can be enabled.

3. Configure the FTP client application to use the FortiGate IP address.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

337

Network

To configure explicit FTP proxy in the CLI:
1. Enable and configure explicit FTP proxy:
config ftp-proxy explicit
set status enable
set incoming-port 21
end
config system interface
edit "port2"
set vdom "vdom1"
set ip 10.1.100.1 255.255.255.0
set allowaccess ping https ssh snmp http telnet
set type physical
set explicit-ftp-proxy enable
set snmp-index 12
end
next
end

2. Create an explicit FTP proxy policy:
config firewall proxy-policy
edit 4
set uuid 2e945a3a-565d-51e9-4fac-5215d287adc0
set proxy ftp
set dstintf "port2"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
next
end

This example creates a basic policy. If required, security profiles can be enabled.

3. Configure the FTP client application to use the FortiGate IP address.

Transparent proxy
In a transparent proxy deployment, the user's client software, such as a browser, is unaware that it is communicating
with a proxy.
Users request Internet content as usual, without any special client configuration, and the proxy serves their requests.
FortiGate also allows user to configure in transparent proxy mode.

To configure transparent proxy in the GUI:
1. Configure a regular firewall policy with HTTP redirect:
a. Go to Policy & Objects > IPv4 Policy.
b. Click Create New.
c. Name the policy appropriately, set the Incoming Interface to port2, and set the Outgoing Interface to port1.
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d. Also set Source and Destination to all, Schedule to always, Service to ALL, and Action to ACCEPT.
e. Set Inspection Mode to Proxy-based and SSL Inspection to deep-inspection.

f. Configure the remaining settings as needed.
g. Click OK.

HTTP redirect can only be configured in the CLI. To redirect HTTPS traffic, deep
inspection is required.

2. Configure a transparent proxy policy:
a. Go to Policy & Objects > Proxy Policy.
b. Click Create New.
c. Set Proxy Type to Transparent Web, set the Incoming Interface to port2, and set the Outgoing Interface to
port1.
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d. Also set Source and Destination to all, Scheduleto always, Service to webproxy, and Action to ACCEPT.

e. Configure the remaining settings as needed.
f. Click OK to create the policy.

This example creates a basic policy. If required, security profiles can be enabled, and deep
SSL inspection can be selected to inspect HTTPS traffic.

3. No special configure is required on the client to use FortiGate transparent proxy. As the client is using the FortiGate
as its default gateway, requests will first hit the regular firewall policy, and then be redirected to the transparent
proxy policy.

To configure transparent proxy in the CLI:
1. Configure a regular firewall policy with HTTP redirect:
config firewall policy
edit 1
set name "1"
set uuid c5c30442-54be-51e9-c17c-4513b1c973c0
set srcintf "port2"
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set inspection-mode proxy
set http-policy-redirect enable
set fsso disable
set ssl-ssh-profile "deep-inspection"
set nat enable
next
end
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2. Configure a transparent proxy policy:
config firewall proxy-policy
edit 5
set uuid 8fb05036-56fc-51e9-76a1-86f757d3d8dc
set proxy transparent-web
set srcintf "port2"
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set service "webproxy"
set action accept
set schedule "always"
next
end

This example creates a basic policy. If required, security profiles can be enabled, and deep
SSL inspection can be selected to inspect HTTPS traffic.

3. No special configure is required on the client to use FortiGate transparent proxy. As the client is using the FortiGate
as its default gateway, requests will first hit the regular firewall policy, and then be redirected to the transparent
proxy policy.

Proxy policy addresses
Proxy addresses are designed to be used only by proxy policies. The following address types are available:
l
l
l
l
l
l
l
l

Host regex match on page 342
URL pattern on page 342
URL category on page 343
HTTP method on page 344
HTTP header on page 345
User agent on page 346
Advanced (source) on page 347
Advanced (destination) on page 348

Fast policy match
The fast policy match function improves the performance of IPv4 explicit and transparent web proxies on FortiGate
devices.
When enabled, after the proxy policies are configured, the FortiGate builds a fast searching table based on the different
proxy policy matching criteria. When fast policy matching is disabled, web proxy traffic is compared to the policies one at
a time from the beginning of the policy list.
Fast policy matching is enabled by default, and can be configured with the following CLI command:
config web-proxy global
set fast-policy-match {enable | disable}
end
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Host regex match
In this address type, a user can create a hostname as a regular expression. Once created, the hostname address can be
selected on the destination tab of an explicit proxy policy. This means that a policy will only allow or block requests that
match the regular expression.
This example creates a host regex match address with the pattern qa.[a-z]*.com.

To create a host regex match address in the GUI:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
3. Set the following:
l
l
l
l

Category to Proxy Address,
Name to Host Regex,
Type to Host Regex Match, and
Host Regex Pattern to qa.[a-z]*.com.

4. Click OK.

To create a host regex match address in the CLI:
config firewall proxy-address
edit "Host Regex"
set uuid 8e374390-57c9-51e9-9353-ee4469629df8
set type host-regex
set host-regex "qa.[a-z]*.com"
next
end

URL pattern
In this address type, a user can create a URL path as a regular expression. Once created, the path address can be
selected in the destination tab of an explicit proxy policy. This means that a policy will only allow or block requests that
match the regular expression.
This example creates a URL pattern address with the pattern /filetypes/.
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To create a URL pattern address in the GUI:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
3. Set the following:
l Category to Proxy Address,
l Name to URL Regex,
l Type to URL Pattern,
l Host to all, and
l URL Path Regex to /filetypes/.

4. Click OK.

To create a URL pattern address in the CLI:
config firewall proxy-address
edit "URL Regex"
set uuid 267dc8e4-57cb-51e9-0cfe-27877bff51d3
set type url
set host "all"
set path "/filetypes/"
next
end

URL category
In this address type, a user can create a URL category based on a FortiGuard URL ID. Once created, the address can be
selected in the destination tab of an explicit proxy policy. This means that a policy will only allow or block requests that
match the URL category.
The example creates a URL category address for URLs in the Education category. For more information about
categories, see https://fortiguard.com/webfilter/categories.

To create a URL category address in the GUI:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
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3. Set the following:
l Category to Proxy Address,
l Name to url-category,
l Type to URL Category,
l Host to all, and
l URL Category to Education.

4. Click OK.

To create a URL category address in the CLI:
config firewall proxy-address
edit "url-category"
set uuid 7a5465d2-57cf-51e9-49fd-0c6b5ad2ff4f
set type category
set host "all"
set category 30
next
end

To see a list of all the categories and their numbers, when editing the address, enter set category ?.

HTTP method
In this address type, a user can create an address based on the HTTP request methods that are used. Multiple method
options are supported, including: CONNECT, DELETE, GET, HEAD, OPTIONS, POST, PUT, and TRACE. Once
created, the address can be selected in the source tab of an explicit proxy policy. This means that a policy will only allow
or block requests that match the selected HTTP method.
The example creates a HTTP method address that uses the GET method.

To create a HTTP method address in the GUI:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
3. Set the following:
l Category to Proxy Address,
l Name to method_get,
l Type to HTTP Method,
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l
l

Host to all, and
Request Method to GET.

4. Click OK.

To create a HTTP method address in the CLI:
config firewall proxy-address
edit "method_get"
set uuid 1e4d1a02-57d6-51e9-a5c4-73387925b7de
set type method
set host "all"
set method get
next
end

HTTP header
In this address type, a user can create a HTTP header as a regular expression. Once created, the header address can
be selected in the source tab of an explicit proxy policy. This means that a policy will only allow or block requests where
the HTTP header matches the regular expression.
This example creates a HTTP header address with the pattern Q[A-B].

To create a HTTP header address in the GUI:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
3. Set the following:
l Category to Proxy Address,
l Name to HTTP-header,
l Type to HTTP Header,
l Host to all,
l Header Name to Header_Test, and
l Header Regex to Q[A-B].
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4. Click OK.

To create a HTTP header address in the CLI:
config firewall proxy-address
edit "method_get"
set uuid a0f1b806-57e9-51e9-b214-7a1cfafa9bb3
set type header
set host "all"
set header-name "Header_Test"
set header "Q[A-B]"
next
end

User agent
In this address type, a user can create an address based on the names of the browsers that are used as user agents.
Multiple browsers are supported, such as Chrome, Firefox, Internet Explorer, and others. Once created, the address can
be selected in the destination tab of an explicit proxy policy. This means that a policy will only allow or block requests
from the specified user agent.
This example creates a user agent address for Google Chrome.

To create a user agent address in the GUI:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
3. Set the following:
l Category to Proxy Address,
l Name to UA-Chrome,
l Type to User Agent,
l Host to all, and
l User Agent to Google Chrome.
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4. Click OK.

To create a user agent address in the CLI:
config firewall proxy-address
edit "UA-Chrome"
set uuid e3550196-57d8-51e9-eed0-115095a7920b
set type ua
set host "all"
set ua chrome
next
end

Advanced (source)
In this address type, a user can create an address based on multiple parameters, including HTTP method, User Agent,
and HTTP header. Once created, the address can be selected in the source tab of an explicit proxy policy. This means
that a policy will only allow or block requests that match the selected address.
This example creates an address that uses the get method, a user agent for Google Chrome, and an HTTP header with
the pattern Q[A-B].

To create an advanced (source) address in the GUI:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
3. Set the following:
l Category to Proxy Address,
l Name to advanced_src,
l Type to Advanced (Source),
l Host to all,
l Request Method to GET,
l User Agent to Google Chrome, and
l HTTP header to Header_Test : Q[A-B].
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4. Click OK.

To create an advanced (source) address in the CLI:
config firewall proxy-address
edit "advance_src"
set uuid fb9991d0-57e3-51e9-9fed-855e0bca16c3
set type src-advanced
set host "all"
set method get
set ua chrome
config header-group
edit 1
set header-name "Header_Test"
set header "Q[A-B]"
next
end
next
end

Advanced (destination)
In this address type, a user can create an address based on URL pattern and URL category parameters. Once created,
the address can be selected in the destination tab of an explicit proxy policy. This means that a policy will only allow or
block requests that match the selected address.
This example creates an address with the URL pattern /about that are in the Education category. For more information
about categories, see https://fortiguard.com/webfilter/categories.

To create an advanced (destination) address in the GUI:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
3. Set the following:
l Category to Proxy Address,
l Name to Advanced-dst,

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

348

Network

l
l
l
l

Type to Advanced (Destination),
Host to all,
URL Path Regex to /about, and
URL Category to Education.

4. Click OK.

To create an advanced (destination) address in the CLI:
config firewall proxy-address
edit "Advanced-dst"
set uuid d9c2a0d6-57e5-51e9-8c92-6aa8b3372198
set type dst-advanced
set host "ubc"
set path "/about"
set category 30
next
end

Proxy policy security profiles
Web proxy policies support most security profile types.

Security profiles must be created before they can be used in a policy, see Security Profiles on
page 697 for information.

Explicit web proxy policy
The security profiles supported by explicit web proxy policies are:
l
l
l
l
l

AntiVirus
Web Filter
Application Control
IPS
DLP Sensor
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l
l
l

ICAP
Web Application Firewall
SSL Inspection

To configure security profiles on an explicit web proxy policy in the GUI:
1. Go to Policy & Objects > Proxy Policy.
2. Click Create New.
3. Set the following:
Proxy Type

Explicit Web

Outgoing Interface

port1

Source

all

Destination

all

Schedule

always

Service

webproxy

Action

ACCEPT

4. In the Firewall / Network Options section, set Protocol Options to default.
5. In the Security Profiles section, make the following selections (for this example, these profiles have all already been
created):
AntiVirus

av

Web Filter

urlfiler

Application Control

app

IPS

Sensor-1

DLP Sensor

dlp

ICAP

default

Web Application Firewall

default

SSL Inspection

deep-inspection

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

350

Network

6. Click OK to create the policy.

To configure security profiles on an explicit web proxy policy in the CLI:
config firewall proxy-policy
edit 1
set uuid c8a71a2c-54be-51e9-fa7a-858f83139c70
set proxy explicit-web
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set service "web"
set action accept
set schedule "always"
set utm-status enable
set av-profile "av"
set webfilter-profile "urlfilter"
set dlp-sensor "dlp"
set ips-sensor "sensor-1"
set application-list "app"
set icap-profile "default"
set waf-profile "default"
set ssl-ssh-profile "deep-inspection"
next
end
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Transparent proxy
The security profiles supported by transparent proxy policies are:
l
l
l
l
l
l
l
l

AntiVirus
Web Filter
Application Control
IPS
DLP Sensor
ICAP
Web Application Firewall
SSL Inspection

To configure security profiles on a transparent proxy policy in the GUI:
1. Go to Policy & Objects > Proxy Policy.
2. Click Create New.
3. Set the following:
Proxy Type

Explicit Web

Incoming Interfae

port2

Outgoing Interface

port1

Source

all

Destination

all

Schedule

always

Service

webproxy

Action

ACCEPT

4. In the Firewall / Network Options section, set Protocol Options to default.
5. In the Security Profiles section, make the following selections (for this example, these profiles have all already been
created):
AntiVirus

av

Web Filter

urlfiler

Application Control

app

IPS

Sensor-1

DLP Sensor

dlp

ICAP

default

Web Application Firewall

default

SSL Inspection

deep-inspection

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

352

Network

6. Click OK to create the policy.

To configure security profiles on a transparent proxy policy in the CLI:
config firewall proxy-policy
edit 2
set uuid 8fb05036-56fc-51e9-76a1-86f757d3d8dc
set proxy transparent-web
set srcintf "port2"
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set service "webproxy"
set action accept
set schedule "always"
set utm-status enable
set av-profile "av"
set webfilter-profile "urlfilter"
set dlp-sensor "dlp"
set ips-sensor "sensor-1"
set application-list "app"
set icap-profile "default"
set waf-profile "default"
set ssl-ssh-profile "certificate-inspection"
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next
end

FTP proxy
The security profiles supported by FTP proxy policies are:
l
l
l
l

AntiVirus
Application Control
IPS
DLP Sensor

To configure security profiles on an FTP proxy policy in the GUI:
1. Go to Policy & Objects > Proxy Policy.
2. Click Create New.
3. Set the following:
Proxy Type

FTP

Outgoing Interface

port1

Source

all

Destination

all

Schedule

always

Action

ACCEPT

4. In the Firewall / Network Options section, set Protocol Options to default.
5. In the Security Profiles section, make the following selections (for this example, these profiles have all already been
created):
AntiVirus

av

Application Control

app

IPS

Sensor-1

DLP Sensor

dlp
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6. Click OK to create the policy.

To configure security profiles on an FTP proxy policy in the CLI:
config firewall proxy-policy
edit 3
set uuid cb89af34-54be-51e9-4496-c69ccfc4d5d4
set proxy ftp
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set utm-status enable
set av-profile "av"
set dlp-sensor "dlp"
set ips-sensor "sensor-1"
set application-list "app"
next
end

Explicit proxy authentication
FortiGate supports multiple authentication methods. This topic explains using an external authentication server with
Kerberos as the primary and NTLM as the fallback.

To configure Explicit Proxy with authentication:
1. Enable and configure the explicit proxy on page 356.
2. Configure the authentication server and create user groups on page 356.
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3. Create an authentication scheme and rules on page 358.
4. Create an explicit proxy policy and assign a user group to the policy on page 359.
5. Verify the configuration on page 360.

Enable and configure the explicit proxy
To enable and configure explicit web proxy in the GUI:
1.
2.
3.
4.
5.

Go to Network > Explicit Proxy.
Enable Explicit Web Proxy.
Select port2 as the Listen on Interfaces and set the HTTP Port to 8080.
Configure the remaining settings as needed.
Click Apply.

To enable and configure explicit web proxy in the CLI:
config web-proxy explicit
set status enable
set ftp-over-http enable
set socks enable
set http-incoming-port 8080
set ipv6-status enable
set unknown-http-version best-effort
end
config system interface
edit "port2"
set vdom "vdom1"
set ip 10.1.100.1 255.255.255.0
set allowaccess ping https ssh snmp http telnet
set type physical
set explicit-web-proxy enable
set snmp-index 12
end
next
end

Configure the authentication server and create user groups
Since we are using an external authentication server with Kerberos authentication as the primary and NTLM as the
fallback, Kerberos authentication is configured first and then FSSO NTLM authentication is configured.
For successful authorization, the FortiGate checks if user belongs to one of the groups that is permitted in the security
policy.

To configure an authentication server and create user groups in the GUI:
1. Configure Kerberos authentication:
a. Go to User & Device > LDAP Servers.
b. Click Create New.
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c. Set the following:
Name

ldap-kerberos

Server IP

172.18.62.220

Server Port

389

Common Name Identifier

cn

Distinguished Name

dc=fortinetqa,dc=local

d. Click OK
2. Define Kerberos as an authentication service. This option is only available in the CLI.
3. Configure FSSO NTLM authentication:
FSSO NTLM authentication is supported in a Windows AD network. FSSO can also provide NTLM authentication
service to the FortiGate unit. When a user makes a request that requires authentication, the FortiGate initiates
NTLM negotiation with the client browser, but does not process the NTLM packets itself. Instead, it forwards all the
NTLM packets to the FSSO service for processing.
a. Go to Security Fabric > Fabric Connectors.
b. Click Create New and select Fortinet Single Sign-On Agent from the SSO/Identity category.
c. Set the Name to FSSO, Primary FSSO Agent to 172.16.200.220, and enter a password.
d. Click OK.
4. Create a user group for Kerberos authentication:
a. Go to User & Device > User Groups.
b. Click Create New.
c. Set the Name to Ldap-Group, and Type to Firewall.
d. In the Remote Groups table, click Add, and set the Remote Server to the previously created ldap-kerberos
server.
e. Click OK.
5. Create a user group for NTLM authentication:
a. Go to User & Device > User Groups.
b. Click Create New.
c. Set the Name to NTLM-FSSO-Group, Type to Fortinet Single Sign-On (FSSO), and add FORTINETQA/FSSO
as a member.
d. Click OK.

To configure an authentication server and create user groups in the CLI:
1. Configure Kerberos authentication:
config user ldap
edit "ldap-kerberos"
set server "172.18.62.220"
set cnid "cn"
set dn "dc=fortinetqa,dc=local"
set type regular
set username "CN=root,CN=Users,DC=fortinetqa,DC=local"
set password **********
next
end
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2. Define Kerberos as an authentication service:
config user krb-keytab
edit "http_service"
set pac-data disable
set principal "HTTP/FGT.FORTINETQA.LOCAL@FORTINETQA.LOCAL"
set ldap-server "ldap-kerberos"
set keytab
"BQIAAABFAAIAEEZPUlRJTkVUUUEuTE9DQUwABEhUVFAAFEZHVC5GT1JUSU5FVFFBLkxPQ0FMAAAAAQAAAAA
EAAEACKLCMonpitnVAAAARQACABBGT1JUSU5FVFFBLkxPQ0FMAARIVFRQABRGR1QuRk9SVElORVRRQS5MT0N
BTAAAAAEAAAAABAADAAiiwjKJ6YrZ1QAAAE0AAgAQRk9SVElORVRRQS5MT0NBTAAESFRUUAAURkdULkZPUlR
JTkVUUUEuTE9DQUwAAAABAAAAAAQAFwAQUHo9uqR9cSkzyxdzKCEXdwAAAF0AAgAQRk9SVElORVRRQS5MT0N
BTAAESFRUUAAURkdULkZPUlRJTkVUUUEuTE9DQUwAAAABAAAAAAQAEgAgzee854Aq1HhQiKJZvV4tL2Poy7h
MIARQpK8MCB//BIAAAABNAAIAEEZPUlRJTkVUUUEuTE9DQUwABEhUVFAAFEZHVC5GT1JUSU5FVFFBLkxPQ0F
MAAAAAQAAAAAEABEAEG49vHEiiBghr63Z/lnwYrU="
next
end

3. Configure FSSO NTLM authentication:
config user fsso
edit "1"
set server "172.18.62.220"
set password **********
next
end

4. Create a user group for Kerberos authentication:
config user group
edit "Ldap-Group"
set member "ldap" "ldap-kerberos"
next
end

5. Create a user group for NTLM authentication:
config user group
edit "NTLM-FSSO-Group"
set group-type fsso-service
set member "FORTINETQA/FSSO"
next
end

Create an authentication scheme and rules
Explicit proxy authentication is managed by authentication schemes and rules. An authentication scheme must be
created first, and then the authentication rule.

To create an authentication scheme and rules in the GUI:
1. Create an authentication scheme:
a. Go to Policy & Objects > Authentication Rules.
b. Click Create New > Authentication Schemes.
c. Set the Name to Auth-scheme-Negotiate and select Negotiate as the Method.
d. Click OK.
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2. Create an authentication rule:
a. Go to Policy & Objects > Authentication Rules.
b. Click Create New > Authentication Rules.
c. Set the Name to Auth-Rule, Source Address to all, and Protocol to HTTP.
d. Enable Authentication Scheme, and select the just created Auth-scheme-Negotiate scheme.
e. Click OK.

To create an authentication scheme and rules in the CLI:
1. Create an authentication scheme:
config authentication scheme
edit "Auth-scheme-Negotiate"
set method negotiate
next
end

<<< Accepts both Kerberos and NTLM as fallback

2. Create an authentication rule:
config authentication rule
edit "Auth-Rule"
set status enable
set protocol http
set srcaddr "all"
set ip-based enable
set active-auth-method "Auth-scheme-Negotiate"
set comments "Testing"
next
end

Create an explicit proxy policy and assign a user group to the policy
To create an explicit proxy policy and assign a user group to it in the GUI:
1.
2.
3.
4.
5.
6.

Go to Policy & Object > Proxy Policy.
Click Create New.
Set Proxy Type to Explicit Web and Outgoing Interface to port1.
Set Source to all, and the just created user groups NTLM-FSSO-Group and Ldap-Group.
Also set Destination to all, Schedule to always, Service to webproxy, and Action to ACCEPT.
Click OK.

To create an explicit proxy policy and assign a user group to it in the CLI:
config firewall proxy-policy
edit 1
set uuid 722b6130-13aa-51e9-195b-c4196568d667
set proxy explicit-web
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set service "web"
set action accept
set schedule "always"
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set
set
set
set

logtraffic all
groups "NTLM-FSSO-Group" "Ldap-Group"
av-profile "av"
ssl-ssh-profile "deep-custom"

next
end

Verify the configuration
Log in using a domain and system that would be authenticated using the Kerberos server, then enter the diagnose
wad user list CLI command to verify:
# diagnose wad user list
ID: 8, IP: 10.1.100.71, VDOM: vdom1
user name
: test1@FORTINETQA.LOCAL
duration
: 389
auth_type
: IP
auth_method : Negotiate
pol_id
: 1
g_id
: 1
user_based : 0
expire
: no
LAN:
bytes_in=4862 bytes_out=11893
WAN:
bytes_in=7844 bytes_out=1023

Log in using a system that is not part of the domain. The NTLM fallback server should be used:
# diagnose wad user list
ID: 2, IP: 10.1.100.202, VDOM: vdom1
user name
: TEST31@FORTINETQA
duration
: 7
auth_type
: IP
auth_method : NTLM
pol_id
: 1
g_id
: 5
user_based : 0
expire
: no
LAN:
bytes_in=6156 bytes_out=16149
WAN:
bytes_in=7618 bytes_out=1917

Transparent web proxy forwarding
In FortiOS, there is an option to enable proxy forwarding for transparent web proxy policies and regular firewall policies
for HTTP and HTTPS.
In previous versions of FortiOS, you could forward proxy traffic to another proxy server (proxy chaining) with explicit
proxy. Now, you can forward web traffic to the upstream proxy without having to reconfigure your browsers or publish a
proxy auto-reconfiguration (PAC) file.
Once configured, the FortiGate forwards traffic generated by a client to the upstream proxy. The upstream proxy then
forwards it to the server.
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To enable proxy forwarding using the CLI:
1. Configure the web proxy forwarding server:
config web-proxy forward-server
edit "PC_03"
set ip 172.16.200.46
set healthcheck enable
set monitor "http://www.google.ca"
next
end

2. Append the web proxy forwarding server to a firewall policy:
config firewall policy
edit 1
set name "LAN to WAN"
set uuid b89f6184-2a6b-51e9-5e2d-9b877903a308
set srcintf "port2"
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set logtraffic all
set webproxy-forward-server "PC_03"
set fsso disable
set av-profile "av"
set ssl-ssh-profile "deep-custom"
set nat enable
next
end

Multiple dynamic header count
Multiple dynamic headers are supported for web proxy profiles, as well as Base64 encoding and the append/new
options.
Administrators only have to select the dynamic header in the profile. The FortiGate will automatically display the
corresponding static value. For example, if the administrator selects the $client-ip header, the FortiGate will display
the actual client IP address.
The supported headers are:
$client-ip

Client IP address

$user

Authentication user name

$domain

User domain name

$local_grp

Firewall group name

$remote_grp

Group name from authentication server

$proxy_name

Proxy realm name
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To configure dynamic headers using the CLI:
Since authentication is required, FSSO NTLM authentication is configured in this example.
1. Configure LDAP:
config user ldap
edit "ldap-kerberos"
set server "172.18.62.220"
set cnid "cn"a
set dn "dc=fortinetqa,dc=local"
set type regular
set username "CN=root,CN=Users,DC=fortinetqa,DC=local"
set password **********
next
end

2. Configure FSSO:
config user fsso
edit "1"
set server "172.18.62.220"
set password **********
next
end

3. Configure a user group:
config user group
edit "NTLM-FSSO"
set group-type fsso-service
set member "FORTINETQA/FSSO"
next
end

4. Configure an authentication scheme:
config authentication scheme
edit "au-sch-ntlm"
set method ntlm
next
end

5. Configure an authentication rule:
config authentication rule
edit "au-rule-fsso"
set srcaddr "all"
set active-auth-method "au-sch-ntlm"
next
end

6. Create a web proxy profile that adds a new dynamic and custom Via header:
config web-proxy profile
edit "test"
set log-header-change enable
config headers
edit 1
set name "client-ip"
set content "$client-ip"
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next
edit 2
set
set
next
edit 3
set
set
next
edit 4
set
set
next
edit 5
set
set
next
edit 6
set
set
next
edit 7
set
set
next

name "Proxy-Name"
content "$proxy_name"

name "user"
content "$user"

name "domain"
content "$domain"

name "local_grp"
content "$local_grp"

name "remote_grp"
content "$remote_grp"

name "Via"
content "Fortigate-Proxy"

end
next
end

7. In the proxy policy, append the web proxy profile created in the previous step:
config firewall proxy-policy
edit 1
set uuid bb7488ee-2a6b-51e9-45c6-1715bdc271d8
set proxy explicit-web
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set service "web"
set action accept
set schedule "always"
set logtraffic all
set groups "NTLM-FSSO"
set webproxy-profile "test"
set utm-status enable
set av-profile "av"
set webfilter-profile "content"
set ssl-ssh-profile "deep-custom"
next
end

8. Once traffic is being generated from the client, look at the web filter logs to verify that it is working.
The corresponding values for all the added header fields displays in the Change headers section at the bottom of
the Log Details pane.
1: date=2019-02-07 time=13:57:24 logid="0344013632" type="utm" subtype="webfilter"
eventtype="http_header_change" level="notice" vd="vdom1" eventtime=1549576642 policyid=1
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transid=50331689 sessionid=1712788383 user="TEST21@FORTINETQA" group="NTLM-FSSO"
profile="test" srcip=10.1.100.116 srcport=53278 dstip=172.16.200.46 dstport=80
srcintf="port2" srcintfrole="undefined" dstintf="port1" dstintfrole="undefined" proto=6
service="HTTP" url="http://172.16.200.46/" agent="curl/7.22.0" chgheaders="Added=clientip: 10.1.100.116|Proxy-Name: 1.1 100D.qa|user: TEST21|domain: FORTINETQA|local_grp:
NTLM-FSSO|remote_grp: FORTINETQA/FSSO|Via: Fortigate-Proxy"

Restricted SaaS access (Office 365, G Suite, Dropbox)
With the web proxy profile, you can specify access permissions for Microsoft Office 365, Google G Suite, and Dropbox.
You can insert vendor-defined headers that restrict access to the specific accounts. You can also insert custom headers
for any destination.
You can configure the web proxy profile with the required headers for the specific destinations, and then directly apply it
to a policy to control the header's insertion.

To implement Office 365 tenant restriction, G Suite account access control, and Dropbox network
access control:
1. Configure a web proxy profile according to the vendors' specifications:
a. Define the traffic destination (service provider).
b. Define the header name, defined by the service provider.
c. Define the value that will be inserted into the traffic, defined by your settings.
2. Apply the web proxy profile to a policy.
The following example creates a web proxy profile for Office 365, G Suite, and Dropbox access control.

Due to vendors' changing requirements, this example may no longer comply with the vendors'
official guidelines.
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To create a web proxy profile for access control using the CLI:
1. Configure the web proxy profile:
config web-proxy profile
edit "SaaS-Tenant-Restriction"
set header-client-ip pass
set header-via-request pass
set header-via-response pass
set header-x-forwarded-for pass
set header-front-end-https pass
set header-x-authenticated-user pass
set header-x-authenticated-groups pass
set strip-encoding disable
set log-header-change disable
config headers
edit 1
set name "Restrict-Access-To-Tenants" <---header name defined by
Office365 spec. input EXACTLY as it is
set dstaddr "Microsoft Office 365" <----built-in destination address for
Office365
set action add-to-request
set base64-encoding disable
set add-option new
set protocol https http
set content "contoso.onmicrosoft.com,fabrikam.onmicrosoft.com" <---your tenants restriction configuration
next
edit 2
set name "Restrict-Access-Context" <----header name defined by
Office365 spec. input EXACTLY as it is
set dstaddr "Microsoft Office 365" <----build-in destination address
for Office365
set action add-to-request
set base64-encoding disable
set add-option new
set protocol https http
set content "456ff232-35l2-5h23-b3b3-3236w0826f3d" <----your directory
ID can find in Azure portal
next
edit 3
set name "X-GooGApps-Allowed-Domains" <----header name defined by
Google G suite.
set dstaddr "G Suite" <---- built-in G Suite destination address
set action add-to-request
set base64-encoding disable
set add-option new
set protocol https http
set content "abcd.com"
<----your domain restriction when you create G
Suite account
next
edit 4
set name "X-Dropbox-allowed-Team-Ids" <----header defined by Dropbox
set dstaddr "wildcard.dropbox.com" <----build-in destination address
for Dropbox
set action add-to-request
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set
set
set
set

base64-encoding disable
add-option new
protocol https http
content "dbmid:FDFSVF-DFSDF"

<----your team-Id in Dropbox

next
end
next
end

2. Apply the web proxy profile to a firewall policy:
config firewall policy
edit 1
set name "WF"
set uuid 09928b08-ce46-51e7-bd95-422d8fe4f200
set srcintf "port10" "wifi"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set webproxy-profile "SaaS-Tenant-Restriction"
set utm-status enable
set utm-inspection-mode proxy
set logtraffic all
set webfilter-profile "blocktest2"
set application-list "g-default"
set profile-protocol-options "protocol"
set ssl-ssh-profile "protocols"
set nat enable
next
end

References
l
l
l

Office 365: Use tenant restrictions to manage access to SaaS cloud applications
G Suite: Block access to consumer accounts
Dropbox: Network control

Explicit proxy and FortiSandbox Cloud
Explicit proxy connections can leverage FortiSandbox Cloud for advanced threat scanning and updates. This allows
FortiGates behind isolated networks to connect to FortiCloud services.
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To configure FortiGuard services to communicate with an explicit proxy server:
config system fortiguard
set proxy-server-ip 172.16.200.44
set proxy-server-port 3128
set proxy-username "test1"
set proxy-password ENC
Y0+KTg9UsILkv8+nDe+Pe3VlnlaHUMzLkfAXLATknW/xm/Xv7EdZHTnua1djM+waZA1vxCh8LV7Ci4sEhj/PABSTShSt
xskEn3E1+CjxviwVSljgF6AD+zJZF/+4jkspq+PogZT3LVO68+kqsPdU4rikuy1BbnsbZcPxC/MJyuIx7343bdKYqp+I
UprQUR2wf8tiMg==
end

To verify the explicit proxy connection to FortiSandbox Cloud:
# diagnose debug application forticldd -1
Debug messages will be on for 30 minutes.
# diagnose debug enable
[2942] fds_handle_request: Received cmd 23 from pid-2526, len 0
[40] fds_queue_task: req-23 is added to Cloud-sandbox-controller
[178] fds_svr_default_task_xmit: try to get IPs for Cloud-sandbox-controller
[239] fds_resolv_addr: resolve aptctrl1.fortinet.com
[169] fds_get_addr: name=aptctrl1.fortinet.com, id=32, cb=0x2bc089
[101] dns_parse_resp: DNS aptctrl1.fortinet.com -&gt; 172.16.102.21
[227] fds_resolv_cb: IP-1: 172.16.102.21
[665] fds_ctx_set_addr: server: 172.16.102.21:443
[129] fds_svr_default_pickup_server: Cloud-sandbox-controller: 172.16.102.21:443
[587] fds_https_start_server: server: 172.16.102.21:443
[579] ssl_new: SSL object is created
[117] https_create: proxy server 172.16.200.44 port:3128
[519] fds_https_connect: https_connect(172.16.102.21) is established.
[261] fds_svr_default_on_established: Cloud-sandbox-controller has connected to
ip=172.16.102.21
[268] fds_svr_default_on_established: server-Cloud-sandbox-controller handles cmd-23
[102] fds_pack_objects: number of objects: 1
[75] fds_print_msg: FCPC: len=109
[81] fds_print_msg: Protocol=2.0
[81] fds_print_msg: Command=RegionList
[81] fds_print_msg: Firmware=FG101E-FW-6.02-0917
[81] fds_print_msg: SerialNumber=FG101E4Q17002429
[81] fds_print_msg: TimeZone=-7
[75] fds_print_msg: http req: len=248
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[81] fds_print_msg: POST https://172.16.102.21:443/FCPService HTTP/1.1
[81] fds_print_msg: User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
[81] fds_print_msg: Host: 172.16.102.21:443
[81] fds_print_msg: Cache-Control: no-cache
[81] fds_print_msg: Connection: close
[81] fds_print_msg: Content-Type: application/octet-stream
[81] fds_print_msg: Content-Length: 301
[524] fds_https_connect: http request to 172.16.102.21: header=248, ext=301.
[257] fds_https_send: sent 248 bytes: pos=0, len=248
[265] fds_https_send: 172.16.102.21: sent 248 byte header, now send 301-byte body
[257] fds_https_send: sent 301 bytes: pos=0, len=301
[273] fds_https_send: sent the entire request to server: 172.16.102.21:443
[309] fds_https_recv: read 413 bytes: pos=413, buf_len=2048
[332] fds_https_recv: received the header from server: 172.16.102.21:443, [HTTP/1.1 200
Content-Type: application/octet-stream
Content-Length: 279
Date: Thu, 20 Jun 2019 16:41:11 GMT
Connection: close]
[396] fds_https_recv: Do memmove buf_len=279, pos=279
[406] fds_https_recv: server: 172.16.102.21:443, buf_len=279, pos=279
[453] fds_https_recv: received a packet from server-172.16.102.21:443: sz=279, objs=1
[194] __ssl_data_ctx_free: Done
[839] ssl_free: Done
[830] ssl_disconnect: Shutdown
[481] fds_https_recv: obj-0: type=FCPR, len=87
[294] fds_svr_default_on_response: server-Cloud-sandbox-controller handles cmd-23
[75] fds_print_msg: fcpr: len=83
[81] fds_print_msg: Protocol=2.0
[81] fds_print_msg: Response=202
[81] fds_print_msg: ResponseItem=Region:Europe,Global,Japan,US
[81] fds_print_msg: existing:Japan
[3220] aptctrl_region_res: Got rsp: Region:Europe,Global,Japan,US
[3222] aptctrl_region_res: Got rsp: Region existing:Japan
[439] fds_send_reply: Sending 28 bytes data.
[395] fds_free_tsk: cmd=23; req.noreply=1
# [136] fds_on_sys_fds_change: trace
[2942] fds_handle_request: Received cmd 22 from pid-170, len 0
[40] fds_queue_task: req-22 is added to Cloud-sandbox-controller
[587] fds_https_start_server: server: 172.16.102.21:443
[579] ssl_new: SSL object is created
[117] https_create: proxy server 172.16.200.44 port:3128
[519] fds_https_connect: https_connect(172.16.102.21) is established.
[261] fds_svr_default_on_established: Cloud-sandbox-controller has connected to
ip=172.16.102.21
[268] fds_svr_default_on_established: server-Cloud-sandbox-controller handles cmd-22
[102] fds_pack_objects: number of objects: 1
[75] fds_print_msg: FCPC: len=146
[81] fds_print_msg: Protocol=2.0
[81] fds_print_msg: Command=UpdateAPT
[81] fds_print_msg: Firmware=FG101E-FW-6.02-0917
[81] fds_print_msg: SerialNumber=FG101E4Q17002429
[81] fds_print_msg: TimeZone=-7
[81] fds_print_msg: TimeZoneInMin=-420
[81] fds_print_msg: DataItem=Region:US
[75] fds_print_msg: http req: len=248
[81] fds_print_msg: POST https://172.16.102.21:443/FCPService HTTP/1.1
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[81] fds_print_msg: User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
[81] fds_print_msg: Host: 172.16.102.21:443
[81] fds_print_msg: Cache-Control: no-cache
[81] fds_print_msg: Connection: close
[81] fds_print_msg: Content-Type: application/octet-stream
[81] fds_print_msg: Content-Length: 338
[524] fds_https_connect: http request to 172.16.102.21: header=248, ext=338.
[257] fds_https_send: sent 248 bytes: pos=0, len=248
[265] fds_https_send: 172.16.102.21: sent 248 byte header, now send 338-byte body
[257] fds_https_send: sent 338 bytes: pos=0, len=338
[273] fds_https_send: sent the entire request to server: 172.16.102.21:443
[309] fds_https_recv: read 456 bytes: pos=456, buf_len=2048
[332] fds_https_recv: received the header from server: 172.16.102.21:443, [HTTP/1.1 200
Content-Type: application/octet-stream
Content-Length: 322
Date: Thu, 20 Jun 2019 16:41:16 GMT
Connection: close]
[396] fds_https_recv: Do memmove buf_len=322, pos=322
[406] fds_https_recv: server: 172.16.102.21:443, buf_len=322, pos=322
[453] fds_https_recv: received a packet from server-172.16.102.21:443: sz=322, objs=1
[194] __ssl_data_ctx_free: Done
[839] ssl_free: Done
[830] ssl_disconnect: Shutdown
[481] fds_https_recv: obj-0: type=FCPR, len=130
[294] fds_svr_default_on_response: server-Cloud-sandbox-controller handles cmd-22
[75] fds_print_msg: fcpr: len=126
[81] fds_print_msg: Protocol=2.0
[81] fds_print_msg: Response=202
[81] fds_print_msg: ResponseItem=Server1:172.16.102.51:514
[81] fds_print_msg: Server2:172.16.102.52:514
[81] fds_print_msg: Contract:20210215
[81] fds_print_msg: NextRequest:86400
[615] parse_apt_contract_time_str: The APTContract is valid to Mon Feb 15 23:59:59 2021
[616] parse_apt_contract_time_str: FGT current local time is Thu Jun 20 09:41:16 2019
[3289] aptctrl_update_res: Got rsp: APT=172.16.102.51:514 APTAlter=172.16.102.52:514 nextupd=86400
[395] fds_free_tsk: cmd=22; req.noreply=1

SD-WAN
SD-WAN is a software-defined approach to managing Wide-Area Networks (WAN). It allows you to offload internetbound traffic, meaning that private WAN services remain available for real-time and mission critical applications. This
added flexibility improves traffic flow and reduces pressure on the network.
SD-WAN platforms create hybrid networks that integrate broadband and other network services into the corporate WAN
while maintaining the performance and security of real-time and sensitive applications.
SD-WAN with Application Aware Routing can measure and monitor the performance of multiple services in a hybrid
network. It uses application routing to offer more granular control of where and when an application uses a specific
service, allowing better use of the overall network.
Some of the key benefits of SD-WAN include:
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l
l
l

Reduced cost with transport independence across MPLS, 3G/4G LTE, and others.
Improve business application performance thanks to increased availability and agility.
Optimized user experience and efficiency with SaaS and public cloud applications.

SD-WAN has 3 objects:
l

l

l

SD-WAN interface
Also called members, SD-WAN interfaces are the ports and interfaces that are used to run traffic. At least one
interface must be configured for SD-WAN to function; up to 255 member interfaces can be configured. See Creating
the SD-WAN interface on page 370.
Performance-SLA
Also called health-check, performance SLAs are used to monitor member interface link quality, and to detect link
failures. They can be used to remove routes, and to reroute traffic when an SD-WAN member cannot detect the
server. They can also be used in SD-WAN rules to select the preferred member interface for forwarding traffic. See
Performance SLA - link monitoring on page 381.
SD-WAN rule
Also called service, SD-WAN rules are used to control path selection. Specific traffic can be dynamically sent to the
best link, or use a specific route. There are five modes:
auto: Assign interfaces a priority based on quality.
manual: Assign interfaces a priority manually.
l priority: Assign interfaces a priority based on the link-cost-factor quality of the interface.
l sla: Assign interfaces a priority based on selected SLA settings.
l load-balance: Distribute traffic among all available links based on the load balance algorithm.
See SD-WAN rules - best quality on page 384, SD-WAN rules - lowest cost (SLA) on page 386, and SD-WAN rules maximize bandwidth (SLA) on page 389.
l
l

Basic SD-WAN setup
The following topics provide instructions on configuring basic SD-WAN:
l
l
l
l

Creating the SD-WAN interface on page 370
Using DHCP interface on page 373
Implicit rule on page 375
Factory default health checks on page 378

Creating the SD-WAN interface
This recipe provides an example of how to start using SD-WAN for load balancing and redundancy.
In this example, two ISP internet connections (wan1 and wan2) use SD-WAN to balance traffic between them at 50%
each.
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To configure SD-WAN using the GUI:
1. On the FortiGate, enable SD-WAN and add interfaces wan1 and wan2 as members:
a. Go to Network > SD-WAN.
b. Set the Status to Enable.
c. Click the plus icon to add members, using the ISPs' proper gateways for each member.

If IPv6 visibility is enabled in the GUI, an IPv6 gateway can also be added for each member. See Feature
visibility on page 554 for details.
d. Click Apply to save your settings.
2. Create a static route with virtual-wan-link enabled:
a. Go to Network > Static Routes.
b. Click Create New. The New Static Route page opens.
c. From the Interface drop-down list, select SD-WAN.
d. Click OK to save your changes.
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3. Create a firewall policy to allow the traffic:
a. Go to Policy & Objects > IPv4 Policy.
b. Click Create New. The New Policy page opens.
c. For the Incoming Interface, select DMZ.
d. For the Outgoing Interface, select SD-WAN.
e. Configure the remaining settings as needed, then click OK to create the policy.
Outgoing traffic will balance between wan1 and wan2 at a 50:50 ratio.

To configure SD-WAN using the CLI:
1. On the FortiGate, configure the wan1 and wan2 interfaces:
config system interface
edit "wan1"
set alias to_ISP1
set ip 172.16.20.1 255.255.255.0
next
edit "wan2"
set alias to_ISP2
set ip 10.100.20.1 255.255.255.0
next
end

2. Enable SD-WAN and add the interfaces as members:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "wan1"
set gateway 172.16.20.2
next
edit 2
set interface "wan2"
set gateway 10.100.20.2
next
end
end

3. Configure a static route:
config router static
edit 1
set distance 1
set virtual-wan-link enable
next
end

4. Configure a firewall policy:
config firewall policy
edit 2
set name "VWL"
set srcintf "dmz"
set dstintf "virtual-wan-link"
set srcaddr "all"
set dstaddr "all"
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set
set
set
set

action accept
schedule "always"
service "ALL"
nat enable

next
end

5. Use a diagnose command to check the state of the SD-WAN:
# diagnose sys virtual-wan-link member
Member(1): interface: wan1, gateway: 172.16.20.2, priority: 0, weight: 0
Member(2): interface: wan2, gateway: 10.100.20.2, priority: 0, weight: 0

Using DHCP interface
This recipe provides a sample configuration for customer using the DHCP interface as SD-WAN members. SD-WAN
members can be all static IP interfaces, all DHCP interfaces, or a mix of both IP and DHCP interfaces.
In this example, a customer who has two ISP internet connections: wan1 and wan2. wan1 is a DHCP interface and wan2
is a static IP address interface.

Sample topology

To configure DHCP interface on the GUI:
1. Enable SD-WAN and add wan1 and wan2 as SD-WAN members.
a. Go to Network > SD-WAN and ensure Status is Enable.
b. In the SD-WAN Interface Members section, click the + button and add two members: wan1 and wan2.
l For the static IP member, enter the Gateway address.
l For the DHCP member, do not change the Gateway.
c. Click Apply.
2. Create static route and enable virtual-wan-link.
a. Go to Network > Static Routes and click Create New.
b. Click the Interface dropdown list and select SD-WAN.
c. Click OK.
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3. Create policy for this traffic.
a. Go to Policy & Objects > IPv4 Policy and click Create New.
b. For the Incoming Interface, select dmz.
c. For the Outgoing Interface, select SD-WAN
d. Configure other options as needed.
e. Click OK.
Outgoing traffic is balanced between wan1 and wan2 at about 50% each.

To configure the interface on the CLI:
config system interface
edit "wan1"
set alias to_ISP1
set mode dhcp
next
edit "wan2"
set alias to_ISP2
set ip 10.100.20.1 255.255.255.0
next
end

To configure SD-WAN on the CLI:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "wan1"
next
edit 2
set interface "wan2"
set gateway 10.100.20.2
next
end
end

To configure static route on the CLI:
config router static
edit 1
set distance 1
set virtual-wan-link enable
next
end

To configure firewall policy on the CLI:
config firewall policy
edit 2
set name "VWL"
set srcintf "dmz"
set dstintf "virtual-wan-link"
set srcaddr "all"
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set
set
set
set
set

dstaddr "all"
action accept
schedule "always"
service "ALL"
nat enable

next
end

To use the diagnose command to check SD-WAN state:
# diagnose sys virtual-wan-link member
Member(1): interface: wan1, gateway: 172.16.20.2, priority: 0, weight: 0
Member(2): interface: wan2, gateway: 10.100.20.2, priority: 0, weight: 0

Implicit rule
SD-WAN supports five types of implicit rules (load-balance mode):
l

l

l

l

l

Source IP (CLI command: source-ip-based): SD-WAN will load balance the traffic equally among its members
according to a hash algorithm based on the source IP addresses.
Session (weight-based): SD-WAN will load balance the traffic according to the session numbers ratio among its
members.
Spillover (usage-based): SD-WAN will use the first member until the bandwidth reaches its limit, then use the
second, and so on.
Source-Destination IP (source-dest-ip-based): SD-WAN will load balance the traffic equally among its
members according to a hash algorithm based on both the source and destination IP addresses.
Volume (measured-volume-based): SD-WAN will load balance the traffic according to the bandwidth ratio
among its members.

Examples
The following four examples demonstrate how to use the implicit rules (load-balance mode).

Example 1
Outgoing traffic is equally balanced between wan1 and wan2, using source-ip-based or source-dest-ip-based mode.
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Using the GUI:
1. On the FortiGate, enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static
route. See Creating the SD-WAN interface on page 370 for details.
2. Go to Network > SD-WAN Rules.
3. Edit the sd-wan rule (the last default rule).
4. For the Load Balancing Algorithm, select either Source IP or Source-Destination IP.

5. Click OK.

Using the CLI:
1. Enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static route. See Creating
the SD-WAN interface on page 370 for details.
2. Set the load balancing algorithm:
Source IP based:
config system virtual-wan-link
set load-balance-mode source-ip-based
end

Source-Destination IP based:
config system virtual-wan-link
set load-balance-mode source-dest-ip-based
end

Example 2
Outgoing traffic is balanced between wan1 and wan2 with a customized ratio, using weight-based mode: wan1 runs 80%
of the sessions, and wan2 runs 20% of the sessions.

Using the GUI:
1. Go to Network > SD-WAN Rules.
2. Edit the sd-wan rule (the last default rule).
3. For the Load Balancing Algorithm, select Sessions.
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4. Enter 80 in the wan1 field, and 20 in the wan2 field.

5. Click OK.

Using the CLI:
config system virtual-wan-link
set load-balance-mode weight-based
config members
edit 1
set interface "wan1"
set weight 80
next
edit 2
set interface "wan2"
set weight 20
next
end
end

Example 3
Outgoing traffic is balanced between wan1 and wan2 with a customized ratio, using measured-volume-based mode:
wan1 runs 80% of the volume, and wan2 runs 20% of the volume.

Using the GUI:
1.
2.
3.
4.
5.

Go to Network > SD-WAN Rules.
Edit the sd-wan rule (the last default rule).
For the Load Balancing Algorithm, select Volume.
Enter 80 in the wan1 field, and 20 in the wan2 field.
Click OK.

Using the CLI:
config system virtual-wan-link
set load-balance-mode measured-volume-based
config members
edit 1
set interface "wan1"
set volume-ratio 80
next
edit 2
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set interface "wan2"
set volume-ratio 20
next
end
end

Example 4
Load balancing can be used to reduce costs when internet connections are charged at different rates. For example, if
wan2 charges based on volume usage and wan1 charges a fixed monthly fee, we can use wan1 at its maximum
bandwidth, and use wan2 for overflow.
In this example, wan1's bandwidth is 10Mbps down and 2Mbps up. Traffic will use wan1 until it reaches its spillover limit,
then it will start to use wan2. Note that auto-asic-offload must be disabled in the firewall policy.

Using the GUI:
1. On the FortiGate, enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static
route. See Creating the SD-WAN interface on page 370 for details.
2. Go to Network > SD-WAN Rules.
3. Edit the sd-wan rule (the last default rule).
4. For the Load Balancing Algorithm, select Spillover.
5. Enter 10000 in the wan1 Ingress Spillover Threshold field, and 2000 in the wan1 Egress Spillover Threshold field.

6. Click OK.

Using the CLI:
config system virtual-wan-link
set load-balance-mode usage-based
config members
edit 1
set interface "wan1"
set spillover-threshold 2000
set ingress-spillover-threshold 10000
next
end
end

Factory default health checks
There are five predefined performance SLA profiles for newly created VDOMs or factory reset FortiGate devices:
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l
l
l
l
l

AWS
FortiGuard
Gmail
Google Search
Office 365

You can view and configure the SLA profiles in Network > Performance SLA.

After configuring a health check, you will be able to view packet loss, latency, and jitter data for the SLA profiles. If a
value is colored red, it means that it failed to meet the SLA requirements.

To configure the performance SLA profiles in the CLI:
config system virtual-wan-link
config health-check
edit "Default_Office_365"
set server "www.office.com"
set protocol http
set interval 1000
set recoverytime 10
config sla
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edit 1
set latency-threshold 250
set jitter-threshold 50
set packetloss-threshold 5
next
end
next
edit "Default_Gmail"
set server "gmail.com"
set interval 1000
set recoverytime 10
config sla
edit 1
set latency-threshold 250
set jitter-threshold 50
set packetloss-threshold 2
next
end
next
edit "Default_AWS"
set server "aws.amazon.com"
set protocol http
set interval 1000
set recoverytime 10
config sla
edit 1
set latency-threshold 250
set jitter-threshold 50
set packetloss-threshold 5
next
end
next
edit "Default_Google Search"
set server "www.google.com"
set protocol http
set interval 1000
set recoverytime 10
config sla
edit 1
set latency-threshold 250
set jitter-threshold 50
set packetloss-threshold 5
next
end
next
edit "Default_FortiGuard"
set server "fortiguard.com"
set protocol http
set interval 1000
set recoverytime 10
config sla
edit 1
set latency-threshold 250
set jitter-threshold 50
set packetloss-threshold 5
next
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end
next
end
end

WAN path control
The following topics provide instructions on configuring WAN path control:
l
l
l
l
l
l
l
l

Performance SLA - link monitoring on page 381
Performance SLA - SLA targets on page 382
SD-WAN rules - best quality on page 384
SD-WAN rules - lowest cost (SLA) on page 386
SD-WAN rules - maximize bandwidth (SLA) on page 389
MPLS (SIP and backup) + DIA (cloud apps) on page 392
SD-WAN traffic shaping and QoS on page 394
Per-link controls for policies and SLA checks on page 399

Performance SLA - link monitoring
Performance SLA link monitoring measures the health of links that are connected to SD-WAN member interfaces by
sending probing signals through each link to a server and measuring the link quality based on latency, jitter, and packet
loss. If a link is broken, the routes on that link are removed, and traffic is routed through other links. When the link is
working again, the routes are reenabbled. This prevents traffic being sent to a broken link and lost.

In this example:
l
l

Interfaces wan1 and wan2 connect to the internet through separate ISPs
The detection server IP address is 208.91.114.182

A performance SLA is created so that, if one link fails, its routes are removed and traffic is detoured to the other link.

To configure a Performance SLA using the GUI:
1. On the FortiGate, enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static
route. See Creating the SD-WAN interface on page 370 for details.
2. Go to Network > Performance SLA.
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3.
4.
5.
6.

Click Create New. The Performance SLA page opens.
Enter a name for the SLA and select a protocol.
In the Server field, enter the detection server IP address (208.91.114.182 in this example).
In the Participants field, select both wan1 and wan2.

7. Configured the remaining settings as needed, then click OK.

To configure a Performance SLA using the CLI:
config system virtual-wan-link
config health-check
edit "server"
set server "208.91.114.182"
set update-static-route enable
set members 1 2
next
end
end

To diagnose the Performance SLA status:
FGT # diagnose sys virtual-wan-link health-check
Health Check(server):
Seq(1): state(alive), packet-loss(0.000%) latency(15.247), jitter(5.231) sla_map=0x0
Seq(2): state(alive), packet-loss(0.000%) latency(13.621), jitter(6.905) sla_map=0x0

Performance SLA - SLA targets
SLA targets are a set of constraints that are used in SD-WAN rules to control the paths that traffic take.
The available constraints are:
l
l
l

Latency threshold: Latency for SLA to make decision, in milliseconds (0 - 10000000, default = 5).
Jitter threshold: Jitter for SLA to make decision, in milliseconds (0 - 10000000, default = 5).
Packet loss threshold: Packet loss for SLA to make decision, in percentage (0 - 100, default = 0).
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To configure Performance SLA targets using the GUI:
1. On the FortiGate, enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static
route. See Creating the SD-WAN interface on page 370 for details.
2. Go to Network > Performance SLA.
3. Create a new Performance SLA or edit an existing one. See Performance SLA - link monitoring on page 381.
4. Under SLA Targets, click the plus icon to add a target.
5. Turn on or off the required constraints, and set their values.

6. Configured the remaining settings as needed, then click OK.

To configure Performance SLA targets using the GUI:
config system virtual-wan-link
config health-check
edit "server"
set server "208.91.114.182"
set members 1 2
config sla
edit 1
set link-cost-factor latency jitter packet-loss
set latency-threshold 10
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set jitter-threshold 10
set packetloss-threshold 1
next
end
next
end
end

The link-cost-factor variable is used to select which constraints are enabled.

SD-WAN rules - best quality
SD-WAN rules are used to control how sessions are distributed to SD-WAN members. Rules can be configured in one of
five modes:
l
l
l
l

l

auto: Interfaces are assigned a priority based on quality.
Manual (manual): Interfaces are manually assigned a priority.
Best Quality (priority): Interface are assigned a priority based on the link-cost-factor of the interface.
Lowest Cost (SLA) (sla): Interfaces are assigned a priority based on selected SLA settings. See SD-WAN rules lowest cost (SLA) on page 386.
Maximize Bandwith (SLA) (load-balance): Traffic is distributed among all available links based on the selected
load balancing algorithm. See SD-WAN rules - maximize bandwidth (SLA) on page 389.

When using Best Quality mode, SD-WAN will choose the best link to forward traffic by comparing the link-cost-factor,
selected from one of the following:

GUI

CLI

Description

Latency

latency

Select a link based on latency.

Jitter

jitter

Select a link based on jitter.

Packet Loss

packet-loss

Select a link based on packet loss.

Downstream

inbandwidth

Select a link based on available bandwidth of incoming traffic.

Upstream

outbandwidth

Select a link based on available bandwidth of outgoing traffic.

Bandwidth

bibandwidth

Select a link based on available bandwidth of bidirectional traffic.

custom-profile-1

custom-profile-1

Select link based on customized profile. If selected, set the
following weights:
l packet-loss-weight: Coefficient of packet-loss.
l latency-weight: Coefficient of latency.
l jitter-weight: Coefficient of jitter.
l bandwidth-weight: Coefficient of reciprocal of available
bidirectional bandwidth.
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In this example, your wan1 and wan2 SD-WAN interfaces connect to two ISPs that both go to the public internet, and you
want Gmail services to use the link with the least latency.

To configure an SD-WAN rule to use Best Quality:
1. On the FortiGate, enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static
route. See Creating the SD-WAN interface on page 370 for details.
2. Create a new Performance SLA named google. See Performance SLA - link monitoring on page 381.
3. Go to Network > SD-WAN Rules.
4. Click Create New. The Priority Rule page opens.
5. Enter a name for the rule, such as gmail.
6. Configure the following settings:

Field

Setting

Internet Service

Google-Gmail

Strategy

Best Quality

Interface preference

wan1 and wan2

Measured SLA

google (created in step 2).

Quality criteria

Latency

7. Click OK to create the rule.
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To configure an SD-WAN rule to use priority:
config system virtual-wan-link
config health-check
edit "google"
set server "google.com"
set members 1 2
next
end
config service
edit 1
set name "gmail"
set mode priority
set internet-service enable
set internet-service-id 65646
set health-check "google"
set link-cost-factor latency
set priority-members 1 2
next
end
end

To diagnose the Performance SLA status:
FGT # diagnose sys virtual-wan-link health-check google
Health Check(google):
Seq(1): state(alive), packet-loss(0.000%) latency(14.563), jitter(4.334) sla_map=0x0
Seq(2): state(alive), packet-loss(0.000%) latency(12.633), jitter(6.265) sla_map=0x0
FGT # diagnose sys virtual-wan-link service 1
Service(1):
TOS(0x0/0x0), protocol(0: 1->65535), Mode(priority), link-cost-facotr(latency), linkcost-threshold(10), health-check(google) Members:
1: Seq_num(2), alive, latency: 12.633, selected
2: Seq_num(1), alive, latency: 14.563, selected
Internet Service: Google-Gmail(65646)

As wan2 has a smaller latency, SD-WAN will put Seq_num(2) on top of Seq_num(1) and wan2 will be used to forward
Gmail traffic.

SD-WAN rules - lowest cost (SLA)
SD-WAN rules are used to control how sessions are distributed to SD-WAN members. Rules can be configured in one of
five modes:
l
l
l

l

auto: Interfaces are assigned a priority based on quality.
Manual (manual): Interfaces are manually assigned a priority.
Best Quality (priority): Interface are assigned a priority based on the link-cost-factor of the interface. See SDWAN rules - best quality on page 384.
Lowest Cost (SLA) (sla): Interfaces are assigned a priority based on selected SLA settings.
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l

Maximize Bandwidth (SLA) (load-balance): Traffic is distributed among all available links based on the selected
load balancing algorithm. See SD-WAN rules - maximize bandwidth (SLA) on page 389.

When using Lowest Cost (SLA) mode (sla in the CLI), SD-WAN will choose the lowest cost link that satisfies SLA to
forward traffic.

In this example, your wan1 and wan2 SD-WAN interfaces connect to two ISPs that both go to the public internet. The
cost of wan2 is less than that of wan1. You want to configure Gmail services to use the lowest cost interface, but the link
quality must meet a standard of latency: 10ms, and jitter: 5ms.

To configure an SD-WAN rule to use Lowest Cost (SLA):
1. On the FortiGate, enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static
route. See Creating the SD-WAN interface on page 370 for details.
2. Create a new Performance SLA named google that includes an SLA Target 1 with Latency threshold = 10ms and
Jitter threshold = 5ms. See Performance SLA - link monitoring on page 381.
3. Go to Network > SD-WAN Rules.
4. Click Create New. The Priority Rule page opens.
5. Enter a name for the rule, such as gmail.
6. Configure the following settings:
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Field

Setting

Internet Service

Google-Gmail

Strategy

Lowest Cost (SLA)

Interface preference

wan1 and wan2

Required SLA target

google#1 (created in step 2).

7. Click OK to create the rule.

To configure an SD-WAN rule to use sla:
config system virtual-wan-link
config members
edit 1
set interface "wan1"
set cost 10
next
edit 2
set interface "wan2"
set cost 5
next
end
config health-check
edit "google"
set server "google.com"
set members 1 2
config sla
edit 1
set latency-threshold 10
set jitter-threshold 5
next
end
next
end
config service
edit 1
set name "gmail"
set mode sla
set internet-service enable
set internet-service-id 65646
config sla
edit "google"
set id 1
next
end
set priority-members 1 2
next
end
end
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To diagnose the Performance SLA status:
FGT # diagnose sys virtual-wan-link health-check google
Health Check(google):
Seq(1): state(alive), packet-loss(0.000%) latency(14.563), jitter(4.334) sla_map=0x0
Seq(2): state(alive), packet-loss(0.000%) latency(12.633), jitter(6.265) sla_map=0x0
FGT # diagnose sys virtual-wan-link service 1
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(sla)
Members:<<BR>>
1: Seq_num(2), alive, sla(0x1), cfg_order(1), selected
2: Seq_num(1), alive, sla(0x1), cfg_order(0), selected
Internet Service: Google.Gmail(65646)

When both wan1 and wan2 meet the SLA requirements, Gmail traffic will only use wan2. If only wan1 meets the SLA
requirements, Gmail traffic will only use wan1, even though it has a higher cost. If neither interface meets the
requirements, wan2 will be used.
If both interface had the same cost and both met the SLA requirements, the first link configured in set prioritymembers would be used.

SD-WAN rules - maximize bandwidth (SLA)
SD-WAN rules are used to control how sessions are distributed to SD-WAN members. Rules can be configured in one of
five modes:
l
l
l

l

l

auto: Interfaces are assigned a priority based on quality.
Manual (manual): Interfaces are manually assigned a priority.
Best Quality (priority): Interface are assigned a priority based on the link-cost-factor of the interface. See SDWAN rules - best quality on page 384.
Lowest Cost (SLA) (sla): Interfaces are assigned a priority based on selected SLA settings. See SD-WAN rules lowest cost (SLA) on page 386.
Maximize Bandwidth (SLA) (load-balance): Traffic is distributed among all available links based on the selected
load balancing algorithm.

When using Maximize Bandwidth mode (load-balance in the CLI), SD-WAN will all of the links that satisfies SLA to
forward traffic based on a round-robin load balancing algorithm.

ADVPN is not supported in this mode.
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In this example, your wan1 and wan2 SD-WAN interfaces connect to two ISPs that both go to the public internet. You
want to configure Gmail services to use both of the interface, but the link quality must meet a standard of latency: 10ms,
and jitter: 5ms. This can maximize the bandwidth usage.

To configure an SD-WAN rule to use Maximize Bandwidth (SLA):
1. On the FortiGate, enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static
route. See Creating the SD-WAN interface on page 370 for details.
2. Create a new Performance SLA named google that includes an SLA Target 1 with Latency threshold = 10ms and
Jitter threshold = 5ms. See Performance SLA - link monitoring on page 381.
3. Go to Network > SD-WAN Rules.
4. Click Create New. The Priority Rule page opens.
5. Enter a name for the rule, such as gmail.
6. Configure the following settings:

Field

Setting

Internet Service

Google-Gmail

Strategy

Maximize Bandwidth (SLA)

Interface preference

wan1 and wan2

Required SLA target

google#1 (created in step 2).
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7. Click OK to create the rule.

To configure an SD-WAN rule to use SLA:
config system virtual-wan-link
config health-check
edit "google"
set server "google.com"
set members 1 2
config sla
edit 1
set latency-threshold 10
set jitter-threshold 5
next
end
next
end
config service
edit 1
set name "gmail"
set mode load-balance
set internet-service enable
set internet-service-id 65646
config sla
edit "google"
set id 1
next
end
set priority-members 1 2
next
end
end

To diagnose the performance SLA status:
FGT # diagnose sys virtual-wan-link health-check google
Health Check(google):
Seq(1): state(alive), packet-loss(0.000%) latency(14.563), jitter(4.334) sla_map=0x0
Seq(2): state(alive), packet-loss(0.000%) latency(12.633), jitter(6.265) sla_map=0x0
FGT # diagnose sys virtual-wan-link service 1
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(load-balance)
Members:<<BR>>
1: Seq_num(1), alive, sla(0x1), num of pass(1), selected
2: Seq_num(2), alive, sla(0x1), num of pass(1), selected
Internet Service: Google.Gmail(65646)

When both wan1 and wan2 meet the SLA requirements, Gmail traffic will use both wan1 and wan2. If only one of the
interfaces meets the SLA requirements, Gmail traffic will only use that interface.
If neither interface meets the requirements but health-check is still alive, then wan1 and wan2 tie. The traffic will try to
balance between wan1 and wan2, using both interfaces to forward traffic.
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MPLS (SIP and backup) + DIA (cloud apps)
This topic covers a typical customer usage scenario where the customer's SD-WAN has two members: MPLS and DIA.
DIA is mostly used for direct Internet access to Internet applications, for example, Office365, Google applications,
Amazon, Dropbox, etc. MPLS is mostly used for SIP and works as a backup when DIA is not working.

Sample topology

Sample configuration
This sample configures all SIP traffic to use MPLS while all other traffic uses DIA. If DIA is not working, the traffic will use
MPLS.

To configure an SD-WAN rule to use SIP and DIA using the GUI:
1. On the FortiGate, enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static
route.
See Creating the SD-WAN interface on page 370.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.

When you add a firewall policy, enable Application Control.
Go to Network > SD-WAN Rules.
Click Create New. The Priority Rule page opens.
Enter a name for the rule, such as SIP.
Click the Application box to display the popup dialog box; then select the applicable SIP applications.
For Strategy, select Manual.
For Interface preference, select MPLS.
Click OK.
Click Create New to create another rule.
Enter a name for the rule, such as Internet.
Click the Address box to display the popup dialog box and select all.
For Strategy, select Manual.
For Interface preference, select DIA.
Click OK.
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To configure the firewall policy using the CLI:
config firewall policy
edit 1
set name "1"
set srcintf "dmz"
set dstintf ""virtual-wan-link""
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set fsso disable
set application-list "g-default"
set ssl-ssh-profile "certificate-inspection"
set nat enable
next
end

To configure an SD-WAN rule to use SIP and DIA using the CLI:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "MPLS"
set gateway x.x.x.x
next
edit 2
set interface "DIA"
set gateway x.x.x.x
next
end
config service
edit 1
set name "SIP"
set member 1
set internet-service enable
set internet-service-app-ctrl 34640 152305677 38938 26180 26179 30251
next
edit 2
set name "Internet"
set input-device "dmz"
set member 2
set dst "all"
next
end
end

All SIP traffic uses MPLS. All other traffic goes to DIA. If DIA is broken, the traffic uses MPLS. If you use VPN instead of
MPLS to run SIP traffic, you must configure a VPN interface, for example vpn1, and then replace member 1 from MPLS
to vpn1 for SD-WAN member.
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To use the diagnose command to check performance SLA status using the CLI:
FGT_A (root) # diagnose sys virtual-wan-link service 1
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(manual)
Members:<<BR>>
1: Seq_num(1), alive, selected
Internet Service: SIP(4294836224 34640) SIP.Method(4294836225 152305677) SIP.Via.NAT
(4294836226 38938) SIP_Media.Type.Application(4294836227 26180) SIP_Message(4294836228
26179) SIP_Voice(4294836229 30251)
FGT_A (root) # diagnose sys virtual-wan-link service 2
Service(2): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(manual)
Members:<<BR>>
1: Seq_num(2), alive, selected
Dst address: 0.0.0.0-255.255.255.255
FGT_A (root) #
FGT_A (root) # diagnose sys virtual-wan-link internet-service-app-ctrl-list
Ctrl application(SIP 34640):Internet Service ID(4294836224)
Ctrl application(SIP.Method 152305677):Internet Service ID(4294836225)
Ctrl application(SIP.Via.NAT 38938):Internet Service ID(4294836226)
Ctrl application(SIP_Media.Type.Application 26180):Internet Service ID(4294836227)
Ctrl application(SIP_Message 26179):Internet Service ID(4294836228)
Ctrl application(SIP_Voice 30251):Internet Service ID(4294836229)
FGT_A (root) #

SD-WAN traffic shaping and QoS
Use a traffic shaper in a firewall shaping policy to control traffic flow. You can use it to control maximum and guaranteed
bandwidth, or put certain traffic to one of the three different traffic priorities: high, medium, or low.
An advanced shaping policy can classify traffic into 30 groups. Use a shaping profile to define the percentage of the
interface bandwidth that is allocated to each group. Each group of traffic is shaped to the assigned speed limit based on
the outgoing bandwidth limit configured on the interface.
For more information, see the online help on shared policy traffic shaping and interface-based traffic shaping.
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Sample topology

Sample configuration
This example shows a typical customer usage where the customer's SD-WAN has two member: wan1 and wan2 and
each is 10Mb/s.
An overview of the procedures to configure SD-WAN traffic shaping and QoS with SD-WAN includes:
1. Give HTTP/HTTPS traffic high priority and give FTP low priority so that if there are conflicts, FortiGate will forward
HTTP/HTTPS traffic first.
2. Even though FTP has low priority, configure FortiGate to give it a 1Mb/s guaranteed bandwidth on each SD-WAN
member so that if there is no FTP traffic, other traffic can use all the bandwidth. If there is heavy FTP traffic, it can
still be guaranteed a 1Mb/s bandwidth.
3. Traffic going to specific destinations such as a VOIP server uses wan1 to forward, and SD-WAN forwards with an
Expedited Forwarding (EF) DSCP tag 101110.

To configure SD-WAN traffic shaping and QoS with SD-WAN in the GUI:
1. On the FortiGate, enable SD-WAN and add wan1 and wan2 as SD-WAN members, then add a policy and static
route.
See Creating the SD-WAN interface on page 370.
2. When you add a firewall policy, enable Application Control.
3. Go to Policy & Objects > Traffic Shapers and edit low-priority.
a. Enable Guaranteed Bandwidth and set it to 1000 kbps.
4. Go to Policy & Objects > Traffic Shaping Policy and click Create New.
a. Name the traffic shaping policy, for example, HTTP-HTTPS.
b. Click the Source box and select all.
c. Click the Destination box and select all.
d. Click the Service box and select HTTP and HTTPS.
e. Click the Outgoing Interface box and select SD-WAN.
f. Enable both Shared Shaper and Reverse Shaper and select high-priority for both options.
g. Click OK.
5. Go to Policy & Objects > Traffic Shaping Policy and click Create New.
a. Name the traffic shaping policy, for example, FTP.
b. Click the Source box and select all.
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c. Click the Destination box and select all.
d. Click the Service box and select FTP, FTP_GET, and FTP_PUT.
e. Click the Outgoing Interface box and select SD-WAN.
f. Enable both Shared Shaper and Reverse Shaper and select low-priority for both options.
g. Click OK
6. Go to Network > SD-WAN Rules and click Create New.
a. Enter a name for the rule, such as Internet.
b. In the Destination section, click the Address box and select the VOIP server you created in the firewall address.
c. For Strategy, select Manual.
d. For Interface preference, select wan1.
e. Click OK.
7. Use CLI commands to modify DSCP settings. See the DSCP CLI commands below.

To configure the firewall policy using the CLI:
config firewall policy
edit 1
set name "1"
set srcintf "dmz"
set dstintf ""virtual-wan-link""
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

To configure the firewall traffic shaper priority using the CLI:
config firewall shaper traffic-shaper
edit "high-priority"
set maximum-bandwidth 1048576
set per-policy enable
next
edit "low-priority"
set guaranteed-bandwidth 1000
set maximum-bandwidth 1048576
set priority low
set per-policy enable
next
end

To configure the firewall traffic shaping policy using the CLI:
config firewall shaping-policy
edit 1
set name "http-https"
set service "HTTP" "HTTPS"
set dstintf "virtual-wan-link"
set traffic-shaper "high-priority"
set traffic-shaper-reverse "high-priority"
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set srcaddr "all"
set dstaddr "all"
next
edit 2
set
set
set
set
set
set
set
next

name "FTP"
service "FTP" "FTP_GET" "FTP_PUT"
dstintf "virtual-wan-link"
traffic-shaper "low-priority"
traffic-shaper-reverse "low-priority"
srcaddr "all"
dstaddr "all"

end

To configure SD-WAN traffic shaping and QoS with SD-WAN in the CLI:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "wan1"
set gateway x.x.x.x
next
edit 2
set interface "wan2"
set gateway x.x.x.x
next
end
config service
edit 1
set name "SIP"
set member 1
set dst "voip-server"
set dscp-forward enable
set dscp-forward-tag 101110
next
end
end

To use the diagnose command to check if specific traffic is attached to the correct traffic shaper:
# diagnose firewall iprope list 100015
policy index=1 uuid_idx=0 action=accept
flag (0):
shapers: orig=high-priority(2/0/134217728) reply=high-priority(2/0/134217728)
cos_fwd=0 cos_rev=0
group=00100015 av=00000000 au=00000000 split=00000000
host=0 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 0 -> zone(2): 36 38
source(1): 0.0.0.0-255.255.255.255, uuid_idx=6,
dest(1): 0.0.0.0-255.255.255.255, uuid_idx=6,
service(2):
[6:0x0:0/(1,65535)->(80,80)] helper:auto
[6:0x0:0/(1,65535)->(443,443)] helper:auto
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policy index=2 uuid_idx=0 action=accept
flag (0):
shapers: orig=low-priority(4/128000/134217728) reply=low-priority(4/128000/134217728)
cos_fwd=0 cos_rev=0
group=00100015 av=00000000 au=00000000 split=00000000
host=0 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 0 -> zone(2): 36 38
source(1): 0.0.0.0-255.255.255.255, uuid_idx=6,
dest(1): 0.0.0.0-255.255.255.255, uuid_idx=6,
service(3):
[6:0x0:0/(1,65535)->(21,21)] helper:auto
[6:0x0:0/(1,65535)->(21,21)] helper:auto
[6:0x0:0/(1,65535)->(21,21)] helper:auto
FGT_A (root) #

To use the diagnose command to check if the correct traffic shaper is applied to the session:
# diagnose sys session list
session info: proto=6 proto_state=01 duration=11 expire=3599 timeout=3600 flags=00000000
sockflag=00000000 sockport=0 av_idx=0 use=5
origin-shaper=low-priority prio=4 guarantee 128000Bps max 1280000Bps traffic 1050Bps drops
0B
reply-shaper=
per_ip_shaper=
class_id=0 shaping_policy_id=2 ha_id=0 policy_dir=0 tunnel=/ helper=ftp vlan_cos=0/255
state=may_dirty npu npd os mif route_preserve
statistic(bytes/packets/allow_err): org=868/15/1 reply=752/10/1 tuples=2
tx speed(Bps/kbps): 76/0 rx speed(Bps/kbps): 66/0
orgin->sink: org pre->post, reply pre->post dev=39->38/38->39 gwy=172.16.200.55/0.0.0.0
hook=post dir=org act=snat 10.1.100.11:58241->172.16.200.55:21(172.16.200.1:58241)
hook=pre dir=reply act=dnat 172.16.200.55:21->172.16.200.1:58241(10.1.100.11:58241)
pos/(before,after) 0/(0,0), 0/(0,0)
misc=0 policy_id=1 auth_info=0 chk_client_info=0 vd=4
serial=0003255f tos=ff/ff app_list=0 app=0 url_cat=0
rpdb_link_id = 00000000
dd_type=0 dd_mode=0
npu_state=0x100000
npu info: flag=0x00/0x00, offload=0/0, ips_offload=0/0, epid=0/0, ipid=0/0,
vlan=0x0000/0x0000
vlifid=0/0, vtag_in=0x0000/0x0000 in_npu=0/0, out_npu=0/0, fwd_en=0/0, qid=0/0
no_ofld_reason: offload-denied helper
total session 1

To use the diagnose command to check the status of a shared traffic shaper:
# diagnose firewall shaper traffic-shaper list
name high-priority
maximum-bandwidth 131072 KB/sec
guaranteed-bandwidth 0 KB/sec
current-bandwidth 0 B/sec
priority 2
tos ff
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packets dropped 0
bytes dropped 0
name low-priority
maximum-bandwidth 131072 KB/sec
guaranteed-bandwidth 125 KB/sec
current-bandwidth 0 B/sec
priority 4
tos ff
packets dropped 0
bytes dropped 0
name high-priority
maximum-bandwidth 131072 KB/sec
guaranteed-bandwidth 0 KB/sec
current-bandwidth 0 B/sec
priority 2
policy 1
tos ff
packets dropped 0
bytes dropped 0
name low-priority
maximum-bandwidth 131072 KB/sec
guaranteed-bandwidth 125 KB/sec
current-bandwidth 0 B/sec
priority 4
policy 2
tos ff
packets dropped 0
bytes dropped 0

Per-link controls for policies and SLA checks
Firewall policies can use SD-WAN members as source and destination interfaces. This allows controlling traffic so that
certain types of traffic can only use certain SD-WAN members.
Per link health-check parameters are supported in SLA configurations using the following CLI command:
config system virtual-wan-link
config service
edit <priority_rule>
set sla-compare-method number
next
end
end

SLA values are compared based on the number of satisfied health checks, and health checks are limited to configured
member interfaces only. The member with the most health check passes is set as the priority member. This only applies
to SLA mode and load balance mode rules.

Example
In this example, a customer has four health checks and two SD-WAN members:
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l
l

health-check1 and health-check2 check SD-WAN member1
health-check3 and health-check4 check SD-WAN member2

The customer wants traffic going to destination A to use the SD-WAN member that passes the most SLAs. For example,
if health-check1 fails, then member1 only has one pass, while member2 has two passes, and traffic will use member2 for
forwarding. If both checks fail for member2, then traffic would use member1.

To configure the FortiGate device:
config system virtual-wan-link
config members
edit 1
set interface "port1"
next
edit 2
set interface "port2"
next
end
config health-check
edit "ping1"
set server "x.x.x.x"
set members 1
config sla
edit 1
next
end
next
edit "ping2"
set server "x.x.x.x"
set members 1
config sla
edit 1
next
end
next
edit "ping3"
set server "x.x.x.x"
set members 2
config sla
edit 1
next
end
next
edit "ping4"
set server "x.x.x.x"
set members 2
config sla
edit 1
next
end
next
end
config service
edit 1
set mode sla
set dst "destination-A"
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config sla
edit "ping1"
set id 1
next
edit "ping2"
set id 1
next
edit "ping3"
set id 1
next
edit "ping4"
set id 1
next
end
set priority-members 1 2
set sla-compare-method number
next
end
end

Advanced configuration
The following topics provide instructions on SD-WAN advanced configuration:
l
l
l
l
l
l
l
l
l
l

Self-originating traffic on page 401
SDN dynamic connector addresses in SD-WAN rules on page 403
Forward error correction on VPN overlay networks on page 405
Using BGP tags with SD-WAN rules on page 408
BGP multiple path support on page 411
Controlling traffic with BGP route mapping and service rules on page 414
ADVPN and shortcut paths on page 417
DSCP matching (shaping) on page 430
Dual VPN tunnel wizard on page 433
Internet service customization on page 436

See also Per packet distribution and tunnel aggregation on page 951.

Self-originating traffic

This topic applies to FortiOS 6.2.1 and earlier. In FortiOS 6.2.2 and later, self-originating
(local-out) traffic behaves differently.

By default, the policy route generated by SD-WAN rules applies on both forwarded and self-generated traffic. This
means that some dynamic routing protocols that are managing traffic, such as OSPF and BGP, can have SD-WAN rules
applied. It can also affect locally-originating traffic, such as syslog. This can cause traffic that is destined for a locally
connected subnet to egress from an undesired interface.
There are four methods that can be used to avoid SD-WAN rules affecting policy routes for local-out traffic:
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1. Do not set the Source address to all in SD-WAN rules.

2. Use an input interface in SD-WAN rules:
config system virtual-wan-link
config service
edit 1
set input-device <interface>
...
next
...
end

3. Create a policy route with Destination address set to a locally connected subnet, and Action set to Stop Policy
Routing to jump directly to forwarding information base (FIB) lookup and avoid the SD-WAN rules.

The Advanced Routing feature visibility must be enabled for the Policy Routes page to be visible; see Feature
visibility on page 554 for information.
4. Enable negating the destination address match (dst-negate) to filter out specific destinations:
config system virtual-wan-link
config service
edit 1
set dst "bgp-neighbor-address"
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set dst-negate enable
...
next
...
end

SDN dynamic connector addresses in SD-WAN rules
SDN dynamic connector addresses can be used in SD-WAN rules. FortiGate supports both public (AWS, Azure, GCP,
OCI, AliCloud) and private (Kubernetes, VMware ESXi and NSX, OpenStack, ACI, Nuage) SDN connectors.
The configuration procedure for all of the supported SDN connector types is the same. This example uses an Azure
public SDN connector.

There are four steps to create and use an SDN connector address in an SD-WAN rule:
1.
2.
3.
4.

Configure the FortiGate IP address and network gateway so that it can reach the Internet.
Create an Azure SDN connector.
Create a firewall address to associate with the configured SDN connector.
Use the firewall address in an SD-WAN service rule.

To create an Azure SDN connector:
1.
2.
3.
4.

Go to Security Fabric > Fabric Connectors.
Click Create New.
In the Public SDN section, click Microsoft Azure.
Enter the following:
Name

azure1

Status

Enabled

Update Interval

Use Default

Server region

Global

Tenant ID

942b80cd-1b14-42a1-8dcf-4b21dece61ba

Client ID

14dbd5c5-307e-4ea4-8133-68738141feb1

Client secret

xxxxxx

Resource path

disabled

5. Click OK.

To create a firewall address to associate with the configured SDN connector:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
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3. Enter the following:
Category

Address

Name

azure-address

Type

Fabric Connector Address

SDN Connector

azure1

SDN address type

Private

Filter

SecurityGroup=edsouza-centos

Interface

Any

4. Click OK.

To use the firewall address in an SD-WAN service rule:
1.
2.
3.
4.
5.
6.

Go to Network > SD-WAN Rules.
Click Create New.
Set the Name to Azure1.
For the Destination Address select azure-address.
Configure the remaining settings as needed. See WAN path control on page 381 for details.
Click OK.

Diagnostics
Use the following CLI commands to check the status of and troubleshoot the connector.

To see the status of the SDN connector:
diagnose sys sdn status
SDN Connector
Type
Status
Updating
Last update
---------------------------------------------------------------------------------------azure1
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To debug the SDN connector to resolve the firewall address:
diagnose debug application azd -1
Debug messages will be on for 30 minutes.
...
azd sdn connector azure1 start updating IP addresses
azd checking firewall address object azure-address-1, vd 0
IP address change, new list:
10.18.0.4
10.18.0.12
...
...
diagnose sys virtual-wan-link service
Service(2): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(manual)
Service role: standalone
Member sub interface:
Members:
1: Seq_num(1), alive, selected
Dst address:
10.18.0.4 - 10.18.0.4
10.18.0.12 - 10.18.0.12
... ...
... ...
... ...

Forward error correction on VPN overlay networks
This topic shows an SD-WAN with forward error correction (FEC) on VPN overlay networks. FEC is a technique used to
control and correct errors in data transmission by sending redundant data across the VPN. It uses six parameters in
IPsec phase1/phase1-interface settings:
fec-ingress

Enable/disable Forward Error Correction for ingress IPsec traffic (default = disable).

fec-egress

Enable/disable Forward Error Correction for egress IPsec traffic (default = disable).

fec-base

The number of base Forward Error Correction packets (1 - 100, default = 20).

fec-redundant

The number of redundant Forward Error Correction packets (1 - 100, default = 10).

fec-send-timeout

The time before sending Forward Error Correction packets, in milliseconds (1 - 1000, default =
8).

fec-receivetimeout

The time before dropping Forward Error Correction packets, in milliseconds (1 - 1000, default
= 5000).

For every fec-base number of sent packets, the tunnel will send fec-redundant number of redundant packets.
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If your FortiGate is NPU capable, disable npu-offload in your phase1 configurations:
config vpn ipsec phase1-interface
edit <name>
set npu-offload disable
next
end

Example
For example, a customer has two ISP connections, wan1 and wan2. Using these two connections, create two IPsec VPN
interfaces as SD-WAN members. Configure FEC on each VPN interface to lower packet loss ratio by re-transmitting the
packets using its backend algorithm.

To configure IPsec VPN:
config vpn ipsec phase1-interface
edit "vd1-p1"
set interface "wan1"
set peertype any
set net-device disable
set proposal aes256-sha256
set dhgrp 14
set remote-gw 172.16.201.2
set psksecret ftnt1234
set fec-egress enable
set fec-send-timeout 8
set fec-base 20
set fec-redundant 10
set fec-ingress enable
set fec-receive-timeout 5000
next
edit "vd1-p2"
set interface "wan2"
set peertype any
set net-device disable
set proposal aes256-sha256
set dhgrp 14
set remote-gw 172.16.202.2
set psksecret ftnt1234
set fec-egress enable
set fec-send-timeout 8
set fec-base 20
set fec-redundant 10
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set fec-ingress enable
set fec-receive-timeout 5000
next
end
config vpn ipsec phase2-interface
edit "vd1-p1"
set phase1name "vd1-p1"
next
edit "vd1-p2"
set phase1name "vd1-p2"
next
end

To configure the interface:
config system interface
edit "vd1-p1"
set ip 172.16.211.1 255.255.255.255
set remote-ip 172.16.211.2 255.255.255.255
next
edit "vd1-p2"
set ip 172.16.212.1 255.255.255.255
set remote-ip 172.16.212.2 255.255.255.255
next
end

To configure the firewall policy:
config firewall policy
edit 1
set name "1"
set srcintf "dmz"
set dstintf ""virtual-wan-link""
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

To configure SD-WAN:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "vd1-p1"
set gateway 172.16.211.2
next
edit 1
set interface "vd2-p2"
set gateway 172.16.212.2
next
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end
end

To use the diagnose command to check VPN FEC status:
# diagnose vpn tunnel list
list all ipsec tunnel in vd 0
-----------------------------------------------------name=vd1 ver=1 serial=1 172.16.200.1:0->172.16.200.2:0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/3600 options[0e10]=create_dev
frag-rfc fec-egress fec-ingress accept_traffic=1
proxyid_num=1 child_num=0 refcnt=11 ilast=8 olast=8 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
fec-egress: base=20 redundant=10 remote_port=50000
<<<<<<<<<<<<<<<<<<<<<<
fec-ingress: base=20 redundant=10
<<<<<<<<<<<<<<<<<<<<<<
proxyid=demo proto=0 sa=1 ref=2 serial=1
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:173.1.1.0/255.255.255.0:0
SA: ref=3 options=10226 type=00 soft=0 mtu=1390 expire=42897/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42899/43200
dec: spi=181f4f81 esp=aes key=16 6e8fedf2a77691ffdbf3270484cb2555
ah=sha1 key=20 f92bcf841239d15d30b36b695f78eaef3fad05c4
enc: spi=0ce10190 esp=aes key=16 2d684fb19cbae533249c8b5683937329
ah=sha1 key=20 ba7333f89cd34cf75966bd9ffa72030115919213
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0

Using BGP tags with SD-WAN rules
SD-WAN rules can use Border Gateway Protocol (BGP) learned routes as dynamic destinations.

In this example, a customer has two ISP connections, wan1 and wan2. wan1 is used primarily for direct access to
internet applications, and wan2 is used primarily for traffic to the customer's data center.
The customer could create an SD-WAN rule using the data center's IP address range as the destination to force that
traffic to use wan2, but the data center's IP range is not static. Instead, a BGP tag can be used.
For this example, wan2's BGP neighbor advertises the data center's network range with a community number of 30:5.
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This example assumes that SD-WAN is enable on the FortiGate, wan1 and wan2 are added as SD-WAN members, and
a policy and static route have been created. See Creating the SD-WAN interface on page 370 for details.

To configure BGP tags with SD-WAN rules:
1. Configure the community list:
config router community-list
edit "30:5"
config rule
edit 1
set action permit
set match "30:5"
next
end
next
end

2. Configure the route map:
config router route-map
edit "comm1"
config rule
edit 1
set match-community "30:5"
set set-route-tag 15
next
end
next
end

3. Configure BGP:
config router bgp
set as xxxxx
set router-id xxxx
config neighbor
edit "10.100.20.2"
set soft-reconfiguration enable
set remote-as xxxxx
set route-map-in "comm1"
next
end
end

4. Configure a firewall policy:
config firewall policy
edit 1
set name "1"
set srcintf "dmz"
set dstintf ""virtual-wan-link""
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set nat enable
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next
end

5. Edit the SD-WAN configuration:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "wan1"
set gateway 172.16.20.2
next
edit 2
set interface "wan2"
next
end
config service
edit 1
set name "DataCenter"
set mode manual
set route-tag 15
set members 2
next
end
end

Troubleshooting BGP tags with SD-WAN rules

Check the network community
Use the get router info bgp network command to check the network community:
# get router info bgp network
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

*>
*>
*>
*>
*>
*>
*>
*>
*>
*>
*>
*>
*>
*>
*>
*>
*>

Network Next Hop Metric LocPrf Weight RouteTag Path
0.0.0.0/0 10.100.1.5 32768 0 ?
1.1.1.1/32 0.0.0.0 32768 0 ?
10.1.100.0/24 172.16.203.2 32768 0 ?
10.100.1.0/30 0.0.0.0 32768 0 ?
10.100.1.4/30 0.0.0.0 32768 0 ?
10.100.1.248/29 0.0.0.0 32768 0 ?
10.100.10.0/24 10.100.1.5 202 10000 15 20 e
172.16.200.0/24 0.0.0.0 32768 0 ?
172.16.200.200/32
0.0.0.0 32768 0 ?
172.16.201.0/24 172.16.200.4 32768 0 ?
172.16.203.0/24 0.0.0.0 32768 0 ?
172.16.204.0/24 172.16.200.4 32768 0 ?
172.16.205.0/24 0.0.0.0 32768 0 ?
172.16.206.0/24 0.0.0.0 32768 0 ?
172.16.207.1/32 0.0.0.0 32768 0 ?
172.16.207.2/32 0.0.0.0 32768 0 ?
172.16.212.1/32 0.0.0.0 32768 0 ?
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*> 172.16.212.2/32 0.0.0.0 32768 0 ?
*> 172.17.200.200/32
0.0.0.0 32768 0 ?
*> 172.27.1.0/24 0.0.0.0 32768 0 ?
*> 172.27.2.0/24 0.0.0.0 32768 0 ?
*> 172.27.5.0/24 0.0.0.0 32768 0 ?
*> 172.27.6.0/24 0.0.0.0 32768 0 ?
*> 172.27.7.0/24 0.0.0.0 32768 0 ?
*> 172.27.8.0/24 0.0.0.0 32768 0 ?
*> 172.29.1.0/24 0.0.0.0 32768 0 ?
*> 172.29.2.0/24 0.0.0.0 32768 0 ?
*> 192.168.1.0 0.0.0.0 32768 0 ?
Total number of prefixes 28
# get router info bgp network 10.100.11.0
BGP routing table entry for 10.100.10.0/24
Paths: (2 available, best 1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
172.10.22.2
20
10.100.20.2 from 10.100.20.2 (6.6.6.6)
Origin EGP metric 200, localpref 100, weight 10000, valid, external, best
Community: 30:5 <<<<===========================
Last update: Wen Mar 20 18:45:17 2019

Check dynamic BGP addresses
Use the get router info route-map-address command to check dynamic BGP addresses:
# get router info route-map-address
Extend-tag: 15, interface(wan2:16)
10.100.11.0/255.255.255.0

Check dynamic BGP addresses used in policy routes
Use the diagnose firewall proute list command to check dynamic BGP addresses used in policy routes:
# diagnose firewall proute list
list route policy info(vf=root):
id=4278779905 vwl_service=1(DataCenter) flags=0x0 tos=0x00 tos_mask=0x00 protocol=0
sport=0:65535 iif=0 dport=1-65535 oif=16
source wildcard(1): 0.0.0.0/0.0.0.0
destination wildcard(1): 10.100.11.0/255.255.255.0

BGP multiple path support
BGP supports multiple paths, allowing an ADVPN to advertise multiple paths. This allows BGP to extend and keep
additional network paths according to RFC 7911.
In this example, Spoke1 and Spoke2 each have four VPN tunnels that are connected to the Hub with ADVPN. The
Spoke-Hub has established four BGP neighbors on all four tunnels.
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Spoke 1 and Spoke 2 can learn four different routes from each other.

To configure the hub:
config router bgp
set as 65505
set router-id 11.11.11.11
set ibgp-multipath enable
set additional-path enable
set additional-path-select 4
config neighbor-group
edit "gr1"
set capability-default-originate enable
set remote-as 65505
set additional-path both
set adv-additional-path 4
set route-reflector-client enable
next
end
config neighbor-range
edit 1
set prefix 10.10.0.0 255.255.0.0
set neighbor-group "gr1"
next
end
config network
edit 12
set prefix 11.11.11.11 255.255.255.255
next
end
end

To configure a spoke:
config router bgp
set as 65505
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set router-id 2.2.2.2
set ibgp-multipath enable
set additional-path enable
set additional-path-select 4
config neighbor
edit "10.10.100.254"
set soft-reconfiguration enable
set remote-as 65505
set additional-path both
set adv-additional-path 4
next
edit "10.10.200.254"
set soft-reconfiguration enable
set remote-as 65505
set additional-path both
set adv-additional-path 4
next
edit "10.10.203.254"
set soft-reconfiguration enable
set remote-as 65505
set additional-path both
set adv-additional-path 4
next
edit "10.10.204.254"
set soft-reconfiguration enable
set remote-as 65505
set additional-path both
set adv-additional-path 4
next
end
config network
edit 3
set prefix 22.1.1.0 255.255.255.0
next
end
end

To view the BGP routing table on a spoke:
Spoke1 # get router info routing-table bgp
Routing table for VRF=0
B*
0.0.0.0/0 [200/0] via 10.10.200.254, vd2-2, 03:57:26
[200/0] via 10.10.203.254, vd2-3, 03:57:26
[200/0] via 10.10.204.254, vd2-4, 03:57:26
[200/0] via 10.10.100.254, vd2-1, 03:57:26
B
1.1.1.1/32 [200/0] via 11.1.1.1 (recursive via 12.1.1.1), 03:57:51
[200/0] via 11.1.1.1 (recursive via 12.1.1.1), 03:57:51
[200/0] via 11.1.1.1 (recursive via 12.1.1.1), 03:57:51
[200/0] via 11.1.1.1 (recursive via 12.1.1.1), 03:57:51
B
11.11.11.11/32 [200/0] via 10.10.200.254, vd2-2, 03:57:51
[200/0] via 10.10.203.254, vd2-3, 03:57:51
[200/0] via 10.10.204.254, vd2-4, 03:57:51
[200/0] via 10.10.100.254, vd2-1, 03:57:51
B
33.1.1.0/24 [200/0] via 10.10.204.3, vd2-4, 03:57:26
[200/0] via 10.10.203.3, vd2-3, 03:57:26
[200/0] via 10.10.200.3, vd2-2, 03:57:26
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[200/0]
[200/0]
[200/0]
[200/0]
[200/0]
[200/0]
[200/0]
[200/0]
[200/0]
[200/0]
[200/0]
[200/0]
[200/0]

via
via
via
via
via
via
via
via
via
via
via
via
via

10.10.100.3,
10.10.204.3,
10.10.203.3,
10.10.200.3,
10.10.100.3,
10.10.204.3,
10.10.203.3,
10.10.200.3,
10.10.100.3,
10.10.204.3,
10.10.203.3,
10.10.200.3,
10.10.100.3,

vd2-1,
vd2-4,
vd2-3,
vd2-2,
vd2-1,
vd2-4,
vd2-3,
vd2-2,
vd2-1,
vd2-4,
vd2-3,
vd2-2,
vd2-1,

03:57:26
03:57:26
03:57:26
03:57:26
03:57:26
03:57:26
03:57:26
03:57:26
03:57:26
03:57:26
03:57:26
03:57:26
03:57:26

Controlling traffic with BGP route mapping and service rules
BGP can adapt to changes in SD-WAN link SLAs:
l
l

BGP can send a different route map to its BGP neighbor when IP SLA is not met.
Traffic can be selectively forwarded based on the status of the BGP neighbor. If the SD-WAN service rule matches
the selected rule, the service is enabled. If the service rule does not match the selected rule, then the service is
disabled.

Examples

Route mapping
Traffic is controlled when the SLA status changes by advertising a different community to the neighbor.
The customer is using two gateways, primary and secondary, that are located in different datacenters. The gateways
have a full mesh network between them. Traffic flows to the primary SD-WAN gateway, unless the link is outside of the
SLA, or completely down. When that happens, traffic routes to the secondary gateway. The SD-WAN neighbor is
configured to let BGP advertise different communities when the SLA status changes. When the SLA becomes out of
compliance, it triggers the route-map to send out a different community number to its BGP neighbor so the neighbor
can use the best path.

To configure route mapping to a BGP neighbor when SLA is not met:
1. Configure BGP:
config router bgp
set as 65412
set router-id 1.1.1.1
set ibgp-multipath enable
config neighbor
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edit "10.100.1.1"
set soft-reconfiguration enable
set remote-as 20
set route-map-out "prim-fails"
set route-map-out-preferable "comm1"
next
edit "10.100.1.5"
set soft-reconfiguration enable
set remote-as 20
set route-map-out "sec-fails"
set route-map-out-preferable "comm2"
next
end
end

2. Configure the virtual WAN link:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "port1"
next
edit 2
set interface "port2"
next
end
config health-check
edit "ping"
set server "10.100.2.22"
set members 1
config sla
edit 1
next
end
next
edit "ping2"
set server "10.100.2.23"
set failtime 3000
config sla
edit 2
next
end
next
end
config neighbor
edit "10.100.1.1"
set member 1
set role primary
set health-check "ping"
set sla-id 1
next
edit "10.100.1.5"
set member 2
set role secondary
set health-check "ping2"
set sla-id 2
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next
end
end

Service rules
Specific traffic is controlled using a service rule.
The customer wants only certain traffic to be forwarded to an SD-WAN member when both the primary BGP neighbor
and SLA statuses are good. Otherwise, the traffic is forwarded to a different SD-WAN member. If the SLAs of both BGP
neighbors are out of compliance, SD-WAN will disable the service rules.

To configure the virtual WAN link:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "port1"
next
edit 2
set interface "port2"
next
end
config health-check
edit "ping"
set server "10.100.2.22"
set members 1
config sla
edit 1
next
end
next
edit "ping2"
set server "10.100.2.23"
set failtime 3000
config sla
edit 2
next
end
next
end
config neighbor
edit "10.100.1.1"
set member 1
set role primary
set health-check "ping"
set sla-id 1
next
edit "10.100.1.5"
set member 2
set role secondary
set health-check "ping2"
set sla-id 2
next
end
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config service
edit 1
set role primary
set member 1
set dst "data-centerA"
next
edit 2
set role secondary
set member 2
set dst "data-centerB"
next
end
end

ADVPN and shortcut paths
This topic provides an example of how to use SD-WAN and ADVPN together.
ADVPN (Auto Discovery VPN) is an IPsec technology that allows a traditional hub-and-spoke VPN’s spokes to establish
dynamic, on-demand, direct tunnels between each other to avoid routing through the topology's hub device. The primary
advantage is that it provides full meshing capabilities to a standard hub-and-spoke topology. This greatly reduces the
provisioning effort for full spoke-to-spoke low delay reachability, and addresses the scalability issues associated with
very large fully meshed VPN networks.
If a customer's head office and branch offices all have two or more internet connections, they can build a dual-hub
ADVPN network. Combined with SD-WAN technology, the customer can load-balance traffic to other offices on multiple
dynamic tunnels, control specific traffic using specific connections, or choose better performance connections
dynamically.

SD-WAN load-balance mode rules do not support ADVPN members. Other modes' rules
support ADVPN members.

This topic covers three parts:
1. Configure dual-hub ADVPN with multiple branches.
2. Configure BGP to exchange routing information among hubs and spokes.
3. Configure SD-WAN on spoke to do load-balancing and control traffic.
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Configuration example

A typical ADVPN configuration with SD-WAN usually has two hubs, and each spoke connects to two ISPs and
establishes VPN tunnels with both hubs.
This example shows a hub-and-spoke configuration using two hubs and one spoke:
l
l
l
l

Hub1 and Hub2 both use wan1 to connect to the ISPs and port10 to connect to internal network.
Spoke1 uses wan1 to connect to ISP1 and wan2 to connect to ISP2.
wan1 sets up VPN to hub1.
wan2 sets up VPN to hub2.

The SD-WAN is configured on the spoke. It uses the two VPN interfaces as members and two rules to control traffic to
headquarters or other spokes using ADVPN VPN interfaces. You can create more rules if required.
For this example:
l

l
l
l
l

Use SD-WAN member 1 (via ISP1) and its dynamic shortcuts for financial department traffic if member 1 meets SLA
requirements. If it doesn't meet SLA requirements, it will use SD-WAN member 2 (via ISP2).
Use SD-WAN member 2 (via ISP2) and its dynamic shortcuts for engineering department traffic.
Load balance other traffic going to hubs and other spokes between these two members.
Set up all other traffic to go with their original ISP connection. All other traffic does not go through SD-WAN.
Set up basic network configuration to let all hubs and spokes connect to their ISPs and the Internet.

Hub internal network

172.16.101.0/24

Spoke1 internal network

10.1.100.0/24

ADVPN 1 network

10.10.100.0/24

ADVPN 2 network

10.10.200.0/24

Hub1 wan1 IP

11.1.1.11

Hub2 wan1 IP

11.1.2.11

Hub1 VPN IP

10.10.100.254

Hub2 VPN IP

10.10.200.254
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Spoke1 to hub1 VPN IP

10.10.100.2

Spoke1 to hub2 VPN IP

10.10.200.2

Ping server in Headquarters

11.11.11.11

Internal subnet of spoke1

22.1.1.0/24

Internal subnet of spoke2

33.1.1.0/24

Firewall addresses

Configure hub_subnets and spoke_subnets before using in policies. These can
be customized.

The GUI does not support some ADVPN related options, such as auto-discovery-sender, auto-discovery-receiver, autodiscovery-forwarder, and IBGP neighbor-group setting, so this example only provides CLI configuration commands.

Hub1 sample configuration
To configure the IPsec phase1 and phase2 interface:
config vpn ipsec phase1-interface
edit "hub-phase1"
set type dynamic
set interface "wan1"
set peertype any
set net-device disable
set proposal aes128-sha256 aes256-sha256 3des-sha256 aes128-sha1 aes256-sha1 3dessha1
set add-route disable
set dpd on-idle
set auto-discovery-sender enable
set tunnel-search nexthop
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "hub-phase2"
set phase1name "hub-phase1"
set proposal aes128-sha1 aes256-sha1 3des-sha1 aes128-sha256 aes256-sha256 3dessha256
next
end

To configure the VPN interface and BGP:
config system interface
edit "hub-phase1"
set ip 10.10.100.254 255.255.255.255
set remote-ip 10.10.100.253 255.255.255.0
next
end
config router bgp
set as 65505
config neighbor-group
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edit "advpn"
set link-down-failover enable
set remote-as 65505
set route-reflector-client enable
next
end
config neighbor-range
edit 1
set prefix 10.10.100.0 255.255.255.0
set neighbor-group "advpn"
next
end
config network
edit 1
set prefix 172.16.101.0 255.255.255.0
next
edit 2
set prefix 11.11.11.0 255.255.255.0
next
end
end

To configure the firewall policy:
config firewall policy
edit 1
set name "spoke2hub"
set srcintf "hub-phase1"
set dstintf "port10"
set srcaddr "spoke_subnets"
set dstaddr "hub_subnets"
set action accept
set schedule "always"
set service "ALL"
set comments "allow traffic from spokes to headquater"
next
edit 2
set name "spoke2spoke"
set srcintf "hub-phase1"
set dstintf "hub-phase1"
set srcaddr "spoke_subnets"
set dstaddr "spoke_subnets"
set action accept
set schedule "always"
set service "ALL"
set comments "allow traffic from spokes to spokes"
next
edit 3
set name "internal2spoke"
set srcintf "port10"
set dstintf "hub-phase1"
set srcaddr "hub_subnets"
set dstaddr "spoke_subnets"
set action accept
set schedule "always"
set service "ALL"
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set comments "allow traffic from headquater to spokes"
next
end

Hub2 sample configuration
Hub2 configuration is the same as hub1 except the wan1 IP address, VPN interface IP address, and BGP neighborrange prefix.

To configure the IPsec phase1 and phase2 interface:
config vpn ipsec phase1-interface
edit "hub-phase1"
set type dynamic
set interface "wan1"
set peertype any
set net-device disable
set proposal aes128-sha256 aes256-sha256 3des-sha256 aes128-sha1 aes256-sha1 3dessha1
set add-route disable
set dpd on-idle
set auto-discovery-sender enable
set tunnel-search nexthop
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "hub-phase2"
set phase1name "hub-phase1"
set proposal aes128-sha1 aes256-sha1 3des-sha1 aes128-sha256 aes256-sha256 3dessha256
next
end

To configure the VPN interface and BGP:
config system interface
edit "hub-phase1"
set ip 10.10.200.254 255.255.255.255
set remote-ip 10.10.200.253 255.255.255.0
next
end
config router bgp
set as 65505
config neighbor-group
edit "advpn"
set link-down-failover enable
set remote-as 65505
set route-reflector-client enable
next
end
config neighbor-range
edit 1
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set prefix 10.10.200.0 255.255.255.0
set neighbor-group "advpn"
next
end
config network
edit 1
set prefix 172.16.101.0 255.255.255.0
next
edit 2
set prefix 11.11.11.0 255.255.255.0
next
end
end

To configure the firewall policy:
config firewall policy
edit 1
set name "spoke2hub"
set srcintf "hub-phase1"
set dstintf "port10"
set srcaddr "spoke_subnets"
set dstaddr "hub_subnets"
set action accept
set schedule "always"
set service "ALL"
set comments "allow traffic from spokes to headquater"
next
edit 2
set name "spoke2spoke"
set srcintf "hub-phase1"
set dstintf "hub-phase1"
set srcaddr "spoke_subnets"
set dstaddr "spoke_subnets"
set action accept
set schedule "always"
set service "ALL"
set comments "allow traffic from spokes to spokes"
next
edit 3
set name "internal2spoke"
set srcintf "port10"
set dstintf "hub-phase1"
set srcaddr "hub_subnets"
set dstaddr "spoke_subnets"
set action accept
set schedule "always"
set service "ALL"
set comments "allow traffic from headquater to spokes"
next
end
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Spoke1 sample configuration
To configure the IPsec phase1 and phase2 interface:
config vpn ipsec phase1-interface
edit "spoke1-phase1"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 11.1.1.11
set psksecret sample
set dpd-retryinterval 5
next
edit "spoke1-2-phase1"
set interface "wan2"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 11.1.2.11
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "spoke1-phase2"
set phase1name "spoke1-phase1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm aes256gcm
chacha20poly1305
set auto-negotiate enable
next
edit "spoke1-2-phase2"
set phase1name "spoke1-2-phase1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm aes256gcm
chacha20poly1305
set auto-negotiate enable
next
end

To configure the VPN interface and BGP:
config system interface
edit "spoke1-phase1"
set ip 10.10.100.2 255.255.255.255
set remote-ip 10.10.100.254 255.255.255.0
next
edit "spoke1-2-phase1"
set ip 10.10.200.2 255.255.255.255
set remote-ip 10.10.200.254 255.255.255.0
next
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end
config router bgp
set as 65505
config neighbor
edit "10.10.100.254"
set advertisement-interval 1
set link-down-failover enable
set remote-as 65505
next
edit "10.10.200.254"
set advertisement-interval 1
set link-down-failover enable
set remote-as 65505
next
end
config network
edit 1
set prefix 10.1.100.0 255.255.255.0
next
end
end

To configure SD-WAN:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "spoke1-phase1"
next
edit 2
set interface "spoke1-2-phase1"
next
end
config health-check
edit "ping"
set server "11.11.11.11"
set members 1 2
config sla
edit 1
set latency-threshold 200
set jitter-threshold 50
set packetloss-threshold 5
next
end
end
next
end
config service
edit 1
set mode sla
set dst "finacial-department"
config sla
edit "ping"
set id 1
next
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end
set priority-member 1 2
next
edit 2
set member 2
set dst "engineering-department"
next
end
end

To configure the firewall policy:
config firewall policy
edit 1
set name "outbound_advpn"
set srcintf "internal"
set dstintf "virtual-wan-link"
set srcaddr "spoke_subnets"
set dstaddr "spoke_subnets" "hub_subnets"
set action accept
set schedule "always"
set service "ALL"
set comments "allow internal traffic going out to headquater and other spokes"
next
edit 2
set name "inbound_advpn"
set srcintf "virtual-wan-link"
set dstintf "internal"
set srcaddr "spoke_subnets" "hub_subnets"
set dstaddr "spoke_subnets"
set action accept
set schedule "always"
set service "ALL"
set comments "allow headquater and other spokes traffic coming in"
next
end

Troubleshooting ADVPN and shortcut paths

Before spoke vs spoke shortcut VPN is established
Use the following CLI commands to check status before spoke vs spoke shortcut VPN is established.
# get router info bgp summary
BGP router identifier 2.2.2.2, local AS number 65505
BGP table version is 13
3 BGP AS-PATH entries
0 BGP community entries
Neighbor
10.10.100.254
10.10.200.254

V
4
4

AS MsgRcvd MsgSent
65505
3286
3270
65505
3365
3319

TblVer
11
12

InQ OutQ Up/Down State/PfxRcd
0
0 00:02:15
5
0
0 00:02:14
5

Total number of neighbors 2
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# get router info routing-table bgp
Routing table for VRF=0
B*
0.0.0.0/0 [200/0] via 10.10.200.254, spoke1-2-phase1, 00:00:58
[200/0] via 10.10.100.254, spoke1-phase1, 00:00:58
B
1.1.1.1/32 [200/0] via 11.1.1.1 (recursive via 12.1.1.1), 00:01:29
[200/0] via 11.1.1.1 (recursive via 12.1.1.1), 00:01:29
B
11.11.11.0/24 [200/0] via 10.10.200.254, spoke1-2-phase1, 00:01:29
[200/0] via 10.10.100.254, spoke1-phase1, 00:01:29
B
33.1.1.0/24 [200/0] via 10.10.200.3, spoke1-2-phase1, 00:00:58
[200/0] via 10.10.100.3, spoke1-phase1, 00:00:58
[200/0] via 10.10.200.3, spoke1-2-phase1, 00:00:58
[200/0] via 10.10.100.3, spoke1-phase1, 00:00:58
# diagnose vpn tunnel list
list all ipsec tunnel in vd 3
-----------------------------------------------------name=spoke1-phase1 ver=1 serial=5 12.1.1.2:0->11.1.1.11:0 dst_mtu=15324
bound_if=48 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=22 ilast=0 olast=0 ad=r/2
stat: rxp=1 txp=185 rxb=16428 txb=11111
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=4
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1 proto=0 sa=1 ref=4 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=15262 expire=42820/0B replaywin=2048
seqno=ba esn=0 replaywin_lastseq=00000002 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42903/43200
dec: spi=03e01a2a esp=aes key=16 56e673f0df05186aa657f55cbb631c13
ah=sha1 key=20 b0d50597d9bed763c42469461b03da8041f87e88
enc: spi=2ead61bc esp=aes key=16 fe0ccd4a3ec19fe6d520c437eb6b8897
ah=sha1 key=20 e3e669bd6df41b88eadaacba66463706f26fb53a
dec:pkts/bytes=1/16368, enc:pkts/bytes=185/22360
npu_flag=03 npu_rgwy=11.1.1.11 npu_lgwy=12.1.1.2 npu_selid=0 dec_npuid=1 enc_npuid=1
-----------------------------------------------------name=spoke1-2-phase1 ver=1 serial=6 112.1.1.2:0->11.1.2.11:0 dst_mtu=15324
bound_if=90 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=21 ilast=0 olast=0 ad=r/2
stat: rxp=1 txp=186 rxb=16498 txb=11163
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=74
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1-2 proto=0 sa=1 ref=4 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=15262 expire=42818/0B replaywin=2048
seqno=bb esn=0 replaywin_lastseq=00000002 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42901/43200
dec: spi=03e01a2b esp=aes key=16 fe49f5042a5ad236250bf53312db1346
ah=sha1 key=20 5dbb15c8cbc046c284bb1c6425dac2b3e15bec85
enc: spi=2ead61bd esp=aes key=16 d6d97be52c3cccb9e88f28a9db64ac46
ah=sha1 key=20 e20916ae6ea2295c2fbd5cbc8b8f5dd8b17f52f1
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dec:pkts/bytes=1/16438, enc:pkts/bytes=186/22480
npu_flag=03 npu_rgwy=11.1.2.11 npu_lgwy=112.1.1.2 npu_selid=1 dec_npuid=1 enc_npuid=1
# diagnose sys virtual-wan-link service
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(sla)
Member sub interface:
Members:
1: Seq_num(1), alive, sla(0x1), cfg_order(0), cost(0), selected
2: Seq_num(2), alive, sla(0x1), cfg_order(1), cost(0), selected
Dst address: 33.1.1.1-33.1.1.100
Service(2): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(manual)
Member sub interface:
Members:
1: Seq_num(2), alive, selected
Dst address: 33.1.1.101-33.1.1.200
# diagnose firewall proute list
list route policy info(vf=vd2):
id=2132869121 vwl_service=1 vwl_mbr_seq=1 dscp_tag=0xff 0xff flags=0x0 tos=0x00 tos_
mask=0x00 protocol=0 sport=0:65535 iif=0 dport=1-65535 oif=70 oif=71
destination(1): 33.1.1.1-33.1.1.100
source wildcard(1): 0.0.0.0/0.0.0.0
id=2132869122 vwl_service=2 vwl_mbr_seq=2 dscp_tag=0xff 0xff flags=0x0 tos=0x00 tos_
mask=0x00 protocol=0 sport=0:65535 iif=0 dport=1-65535 oif=71
destination(1): 33.1.1.101-33.1.1.200
source wildcard(1): 0.0.0.0/0.0.0.0

After spoke vs spoke shortcut VPN is established
Use the following CLI commands to check status after spoke vs spoke shortcut VPN is established.
# get router info routing-table bgp
Routing table for VRF=0
B*
0.0.0.0/0 [200/0] via 10.10.200.254, spoke1-2-phase1, 00:01:33
[200/0] via 10.10.100.254, spoke1-phase1, 00:01:33
B
1.1.1.1/32 [200/0] via 11.1.1.1 (recursive via 12.1.1.1), 00:02:04
[200/0] via 11.1.1.1 (recursive via 12.1.1.1), 00:02:04
B
11.11.11.0/24 [200/0] via 10.10.200.254, spoke1-2-phase1, 00:02:04
[200/0] via 10.10.100.254, spoke1-phase1, 00:02:04
B
33.1.1.0/24 [200/0] via 10.10.200.3, spoke1-2-phase1_0, 00:01:33
[200/0] via 10.10.100.3, spoke1-phase1_0, 00:01:33
[200/0] via 10.10.200.3, spoke1-2-phase1_0, 00:01:33
[200/0] via 10.10.100.3, spoke1-phase1_0, 00:01:33
# diagnose sys virtual-wan-link service
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(sla)
Member sub interface:
1: seq_num(1), interface(spoke1-phase1):
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1: spoke1-phase1_0(111)
2: seq_num(2), interface(spoke1-2-phase1):
1: spoke1-2-phase1_0(113)
Members:
1: Seq_num(1), alive, sla(0x1), cfg_order(0), cost(0), selected
2: Seq_num(2), alive, sla(0x1), cfg_order(1), cost(0), selected
Dst address: 33.1.1.1-33.1.1.100
Service(2): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(manual)
Member sub interface:
1: seq_num(2), interface(spoke1-2-phase1):
1: spoke1-2-phase1_0(113)
Members:
1: Seq_num(2), alive, selected
Dst address: 33.1.1.101-33.1.1.200
# diagnose vpn tunnel list
list all ipsec tunnel in vd 3
-----------------------------------------------------name=spoke1-phase1 ver=1 serial=5 12.1.1.2:0->11.1.1.11:0 dst_mtu=15324
bound_if=48 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=1 refcnt=20 ilast=0 olast=0 ad=r/2
stat: rxp=1 txp=759 rxb=16428 txb=48627
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=4
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=vd2-1 proto=0 sa=1 ref=5 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=15262 expire=42536/0B replaywin=2048
seqno=2f8 esn=0 replaywin_lastseq=00000002 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42898/43200
dec: spi=03e01a42 esp=aes key=16 1f131bda108d33909d49fc2778bd08bb
ah=sha1 key=20 14131d3f0da9b741a2fd13d530b0553aa1f58983
enc: spi=2ead61d8 esp=aes key=16 81ed24d5cd7bb59f4a80dceb5a560e1f
ah=sha1 key=20 d2ccc2f3223ce16514e75f672cd88c4b4f48b681
dec:pkts/bytes=1/16360, enc:pkts/bytes=759/94434
npu_flag=03 npu_rgwy=11.1.1.11 npu_lgwy=12.1.1.2 npu_selid=0 dec_npuid=1 enc_npuid=1
-----------------------------------------------------name=spoke1-2-phase1 ver=1 serial=6 112.1.1.2:0->11.1.2.11:0 dst_mtu=15324
bound_if=90 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=1 refcnt=19 ilast=0 olast=0 ad=r/2
stat: rxp=1 txp=756 rxb=16450 txb=48460
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=74
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=vd2-2 proto=0 sa=1 ref=5 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=15262 expire=42538/0B replaywin=2048
seqno=2f5 esn=0 replaywin_lastseq=00000002 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42900/43200
dec: spi=03e01a43 esp=aes key=16 7fc87561369f88b56d08bfda769eb45b
ah=sha1 key=20 0ed554ef231c5ac16dc2e71d1907d7347dda33d6
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enc: spi=2ead61d9 esp=aes key=16 00286687aa1762e7d8216881d6720ef3
ah=sha1 key=20 59d5eec6299ebcf038c190860774e2833074d7c3
dec:pkts/bytes=1/16382, enc:pkts/bytes=756/94058
npu_flag=03 npu_rgwy=11.1.2.11 npu_lgwy=112.1.1.2 npu_selid=1 dec_npuid=1 enc_npuid=1
-----------------------------------------------------name=spoke1-phase1_0 ver=1 serial=55 12.1.1.2:0->13.1.1.3:0 dst_mtu=15324
bound_if=48 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/728 options[02d8]=npu
create_dev no-sysctl rgwy-chg frag-rfc accept_traffic=1
parent=vd2-1 index=0
proxyid_num=1 child_num=0 refcnt=18 ilast=8 olast=8 ad=r/2
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=vd2-1 proto=0 sa=1 ref=2 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=1a227 type=00 soft=0 mtu=15262 expire=42893/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42901/43200
dec: spi=03e01a44 esp=aes key=16 c3b77a98e3002220e2373b73af14df6e
ah=sha1 key=20 d18d107c248564933874f60999d6082fd7a78948
enc: spi=864f6dba esp=aes key=16 eb6181806ccb9bac37931f9eadd4d5eb
ah=sha1 key=20 ab788f7a372877a5603c4ede1be89a592fc21873
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
npu_flag=00 npu_rgwy=13.1.1.3 npu_lgwy=12.1.1.2 npu_selid=51 dec_npuid=0 enc_npuid=0
-----------------------------------------------------name=spoke1-2-phase1_0 ver=1 serial=57 112.1.1.2:0->113.1.1.3:0 dst_mtu=15324
bound_if=90 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/728 options[02d8]=npu
create_dev no-sysctl rgwy-chg frag-rfc accept_traffic=1
parent=vd2-2 index=0
proxyid_num=1 child_num=0 refcnt=17 ilast=5 olast=5 ad=r/2
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=vd2-2 proto=0 sa=1 ref=3 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=1a227 type=00 soft=0 mtu=15262 expire=42900/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42901/43200
dec: spi=03e01a45 esp=aes key=16 0beb519ed9f800e8b4c0aa4e1df7da35
ah=sha1 key=20 bc9f38db5296cce4208a69f1cc8a9f7ef4803c37
enc: spi=864f6dbb esp=aes key=16 1d26e3556afcdb9f8e3e33b563b44228
ah=sha1 key=20 564d05ef6f7437e1fd0a88d5fee7b6567f9d387e
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
npu_flag=00 npu_rgwy=113.1.1.3 npu_lgwy=112.1.1.2 npu_selid=53 dec_npuid=0 enc_npuid=0
# diagnose firewall proute list
list route policy info(vf=vd2):
id=2132869121 vwl_service=1 vwl_mbr_seq=1 dscp_tag=0xff 0xff flags=0x0 tos=0x00 tos_
mask=0x00 protocol=0 sport=0:65535 iif=0 dport=1-65535 oif=111 oif=70 oif=113 oif=71
destination(1): 33.1.1.1-33.1.1.100
source wildcard(1): 0.0.0.0/0.0.0.0
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id=2132869122 vwl_service=2 vwl_mbr_seq=2 dscp_tag=0xff 0xff flags=0x0 tos=0x00 tos_
mask=0x00 protocol=0 sport=0:65535 iif=0 dport=1-65535 oif=113 oif=71
destination(1): 33.1.1.101-33.1.1.200
source wildcard(1): 0.0.0.0/0.0.0.0

DSCP matching (shaping)
This feature has three parts:
l
l
l

DSCP matching in firewall policies
DSCP matching in firewall shaping policies
DSCP marking in firewall shaping policies

DSCP matching in firewall policies
Traffic is allowed or blocked according to the DSCP values in the incoming packets.
The following CLI variables are available in the config firewall policy command:
tos-mask <mask_value>

Non-zero bit positions are used for comparison. Zero bit positions are ignored
(default = 0x00).
This variable replaces the dscp-match variable.

tos <tos_value>

Type of Service (ToC) value that is used for comparison (default = 0x00). This
variable is only available when tos-mask is not zero.
This variable replaces the dscp-value variable.

tos-negate {enable |
disable}

Enable/disable negated ToS match (default = disable). This variable is only
available when tos-mask is not zero.
This variable replaces the dscp-negate variable.

DSCP matching in firewall shaping policies
Shaping is applied to the session or not according to the DSCP values in the incoming packets. The same logic and
commands as in firewall policies are used.

DSCP marking in firewall shaping policies
Traffic is allowed or blocked according to the DSCP values in the incoming packets. DSCP marking in firewall shaping
policies uses the same logic and commands as in firewall policy and traffic-shaper.
When DSCP marking on firewall shaper traffic-shaper, firewall shaping-policy, and firewall
policy all apply to the same session, shaping-policy overrides policy, and shaper traffic-shaper
overrides both shaping-policy and policy.
The following CLI variables in config firewall policy are used to mark the packets:
diffserv-forward {enable
| disable}
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diffservcode-forward
<dscp_value>

The value that packet's DiffServ is set to (default = 000000). This variable is only
available when diffserv-forward is enabled.

diffserv-reverse {enable
| disable}

Enable/disable changing a packet's reverse (reply) DiffServ values to the value
specified in diffservcode-rev (default = disable).

diffservcode-rev <dscp_
value>

The value that packet's reverse (reply) DiffServ is set to (default = 000000). This
variable is only available when diffserv-rev is enabled.

Examples

Example 1
FortiGate A marks traffic from the sales and QA teams with different DSCP values. FortiGate B does DSCP matching,
allowing only the sales team to access the database.
1. Configure FortiGate A:
config firewall policy
edit 1
set srcintf "port2"
set dstintf "port3"
set srcaddr "QA"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set diffserv-forward enable
set diffservcode-forward 110000
set nat enable
next
edit 5
set
set
set
set
set
set
set
set
set
set
next

srcintf "port2"
dstintf "port3"
srcaddr "Sales"
dstaddr "all"
action accept
schedule "always"
service "ALL"
diffserv-forward enable
diffservcode-forward 111011
nat enable

end
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2. Configure FortiGate B:
config firewall policy
edit 2
set srcintf "port3"
set dstintf "port1"
set srcaddr "all"
set dstaddr "Database"
set action accept
set schedule "always"
set service "ALL"
set tos-mask 0xf0
set tos 0xe0
set fsso disable
set nat enable
next
end

Example 2
FortiGate A marks traffic from the sales and QA teams with different DSCP values. FortiGate B uses a firewall shaping
policy to do the DSCP matching, limiting the connection speed of the sales team to the database to 10MB/s.
1. Configure FortiGate A:
config firewall policy
edit 1
set srcintf "port2"
set dstintf "port3"
set srcaddr "QA"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set diffserv-forward enable
set diffservcode-forward 110000
set nat enable
next
edit 5
set
set
set
set
set
set
set
set
set
set
next

srcintf "port2"
dstintf "port3"
srcaddr "Sales"
dstaddr "all"
action accept
schedule "always"
service "ALL"
diffserv-forward enable
diffservcode-forward 111011
nat enable

end

2. Configure FortiGate B:
config firewall policy
edit 2
set srcintf "port3"
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set
set
set
set
set
set
set

dstintf "port1"
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"
nat enable

next
end
config firewall shaper traffic-shaper
edit "10MB/s"
set guaranteed-bandwidth 60000
set maximum-bandwidth 80000
next
end
config firewall shaping-policy
edit 1
set service "ALL"
set dstintf "port1"
set tos-mask 0xf0
set tos 0xe0
set traffic-shaper "10MB/s"
set srcaddr "all"
set dstaddr "all"
next
end

Example 3
FortiGate A has a traffic shaping policy to mark traffic from the QA team with a DSCP value of 100000, while reverse
traffic is marked with 000011.
1. Configure FortiGate A:
config firewall shaping-policy
edit 1
set name "QA Team 50MB"
set service "ALL"
set dstintf "port3"
set traffic-shaper "50MB/s"
set traffic-shaper-reverse "50MB/s"
set diffserv-forward enable
set diffserv-reverse enable
set srcaddr "QA"
set dstaddr "all"
set diffservcode-forward 100000
set diffservcode-rev 000011
next
end

Dual VPN tunnel wizard
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This wizard is used to automatically set up multiple VPN tunnels to the same destination over multiple outgoing
interfaces. This includes automatically configuring IPsec, routing, and firewall settings, avoiding cumbersome and errorprone configuration steps.

To create a new SD-WAN VPN interface using the tunnel wizard:
1. Go to Network > SD-WAN.
2. Add a new interface member.

3. In the Interface drop-down, click +VPN. The Create IPsec VPN for SD-WAN members pane opens.
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4. Enter the required information, then click Create.

5. Click Close to return to the SD-WAN page.
The newly created VPN interface will be highlighted in the Interface drop-down list.

6. Select the VPN interface to add it as an SD-WAN member.
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7. Click Apply to save the SD-WAN settings.

Internet service customization
Internet Service Database (ISDB) entries can be tuned for their environments by adding custom ports and port ranges.

To add a custom port range:
config firewall internet-service-addition
edit 65646
set comment "Add custom port-range:tcp/8080-8090 into 65646"
config entry
edit 1
set protocol 6
config port-range
edit 1
set start-port 8080
set end-port 8090
next
end
next
end
next
end
Warning: Configuration will only be applied after rebooting or using the 'execute internetservice refresh' command.
# execute internet-service refresh
Internet Service database is refreshed.

To verify that the change was applied:
# diagnose internet-service info FG-traffic 6 8080 2.20.183.160
Internet Service: 65646(Google.Gmail)
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Troubleshooting SD-WAN
The following topics provide instructions on SD-WAN troubleshooting:
l
l
l
l
l
l

Tracking SD-WAN sessions on page 437
Understanding SD-WAN related logs on page 437
SD-WAN related diagnose commands on page 440
SLA logging on page 444
SLA monitoring using the REST API on page 446
SD-WAN bandwidth monitoring service on page 448

Tracking SD-WAN sessions
You can check the destination interface in FortiView in order to see which port the traffic is being forwarded to.
The example below demonstrates a source-based load-balance between two SD-WAN members.
l
l

If the source IP address is an even number, it will go to port13.
If the source IP address is an odd number, it will go to port12.

For information on other features of FortiView, see FortiView on page 256.

Understanding SD-WAN related logs
This topic lists the SD-WAN related logs and explains when the logs will be triggered.

Health-check detects a failure:
l

When health-check detects a failure, it will record a log:
34: date=2019-03-23 time=17:26:06 logid="0100022921" type="event" subtype="system"
level="critical" vd="root" eventtime=1553387165 logdesc="Routing information changed"
name="test" interface="R150" status="down" msg="Static route on interface R150 may be
removed by health-check test. Route: (10.100.1.2->10.100.2.22 ping-down)"
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l

When health-check detects a recovery, it will record a log:
32: date=2019-03-23 time=17:26:54 logid="0100022921" type="event" subtype="system"
level="critical" vd="root" eventtime=1553387214 logdesc="Routing information changed"
name="test" interface="R150" status="up" msg="Static route on interface R150 may be
added by health-check test. Route: (10.100.1.2->10.100.2.22 ping-up)"

Health-check has an SLA target and detects SLA qualification changes:
l

When health-check has an SLA target and detects SLA changes, and changes to fail:
5: date=2019-04-11 time=11:48:39 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1555008519816639290 logdesc="Virtual WAN Link status"
msg="SD-WAN Health Check(ping) SLA(1): number of pass members changes from 2 to 1."

l

When health-check has an SLA target and detects SLA changes, and changes to pass:
2: date=2019-04-11 time=11:49:46 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1555008586149038471 logdesc="Virtual WAN Link status"
msg="SD-WAN Health Check(ping) SLA(1): number of pass members changes from 1 to 2."

SD-WAN calculates a link's session/bandwidth over/under its ratio and stops/resumes traffic:
l

When SD-WAN calculates a link's session/bandwidth over its configured ratio and stops forwarding traffic:
3: date=2019-04-10 time=17:15:40 logid="0100022924" type="event" subtype="system"
level="notice" vd="root" eventtime=1554941740185866628 logdesc="Virtual WAN Link volume
status" interface="R160" msg="The member(3) enters into conservative status with limited
ablity to receive new sessions for too much traffic."

l

When SD-WAN calculates a link's session/bandwidth according to its ratio and resumes forwarding traffic:
1: date=2019-04-10 time=17:20:39 logid="0100022924" type="event" subtype="system"
level="notice" vd="root" eventtime=1554942040196041728 logdesc="Virtual WAN Link volume
status" interface="R160" msg="The member(3) resume normal status to receive new sessions
for internal adjustment."

The SLA mode service rule's SLA qualified member changes:
l

When the SLA mode service rule's SLA qualified member changes. In this example R150 fails the SLA check, but is
still alive:
14: date=2019-03-23 time=17:44:12 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553388252 logdesc="Virtual WAN Link status"
msg="Service2() prioritized by SLA will be redirected in seq-num order 2(R160) 1(R150)."
15: date=2019-03-23 time=17:44:12 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553388252 logdesc="Virtual WAN Link status"
interface="R150" msg="The member1(R150) SLA order changed from 1 to 2. "
16: date=2019-03-23 time=17:44:12 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553388252 logdesc="Virtual WAN Link status"
interface="R160" msg="The member2(R160) SLA order changed from 2 to 1. "

l

When the SLA mode service rule's SLA qualified member changes. In this example R150 changes from fail to pass:
1: date=2019-03-23 time=17:46:05 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553388365 logdesc="Virtual WAN Link status"
msg="Service2() prioritized by SLA will be redirected in seq-num order 1(R150) 2(R160)."
2: date=2019-03-23 time=17:46:05 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553388365 logdesc="Virtual WAN Link status"

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

438

Network

interface="R160" msg="The member2(R160) SLA order changed from 1 to 2. "
3: date=2019-03-23 time=17:46:05 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553388365 logdesc="Virtual WAN Link status"
interface="R150" msg="The member1(R150) SLA order changed from 2 to 1. "

The priority mode service rule member's link status changes:
l

When priority mode service rule member's link status changes. In this example R150 changes to better than R160,
and both are still alive:
1: date=2019-03-23 time=17:33:23 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553387603 logdesc="Virtual WAN Link status"
msg="Service2() prioritized by packet-loss will be redirected in seq-num order 1(R150) 2
(R160)."
2: date=2019-03-23 time=17:33:23 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553387603 logdesc="Virtual WAN Link status"
interface="R160" msg="The member2(R160) link quality packet-loss order changed from 1 to
2. "
3: date=2019-03-23 time=17:33:23 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553387603 logdesc="Virtual WAN Link status"
interface="R150" msg="The member1(R150) link quality packet-loss order changed from 2 to
1. "

l

When priority mode service rule member's link status changes. In this example R160 changes to better than R150,
and both are still alive:
6: date=2019-03-23 time=17:32:01 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553387520 logdesc="Virtual WAN Link status"
msg="Service2() prioritized by packet-loss will be redirected in seq-num order 2(R160) 1
(R150)."
7: date=2019-03-23 time=17:32:01 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553387520 logdesc="Virtual WAN Link status"
interface="R150" msg="The member1(R150) link quality packet-loss order changed from 1 to
2. "
8: date=2019-03-23 time=17:32:01 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553387520 logdesc="Virtual WAN Link status"
interface="R160" msg="The member2(R160) link quality packet-loss order changed from 2 to
1. "

SD-WAN member is used in service and it fails the health-check:
l

When SD-WAN member fails the health-check, it will stop forwarding traffic:
6: date=2019-04-11 time=13:33:21 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1555014801844089814 logdesc="Virtual WAN Link status"
interface="R160" msg="The member2(R160) link is unreachable or miss threshold. Stop
forwarding traffic. "

l

When SD-WAN member passes the health-check again, it will resume forwarding logs:
2: date=2019-04-11 time=13:33:36 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1555014815914643626 logdesc="Virtual WAN Link status"
interface="R160" msg="The member2(R160) link is available. Start forwarding traffic. "

Load-balance mode service rule's SLA qualified member changes:
l

When load-balance mode service rule's SLA qualified member changes. In this example R150 changes to not meet
SLA:
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2: date=2019-04-11 time=14:11:16 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1555017075926510687 logdesc="Virtual WAN Link status"
msg="Service1(rule2) will be load balanced among members 2(R160) with available
routing."
3: date=2019-04-11 time=14:11:16 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1555017075926508676 logdesc="Virtual WAN Link status"
interface="R150" msg="The member1(R150) SLA order changed from 1 to 2. "
4: date=2019-04-11 time=14:11:16 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1555017075926507182 logdesc="Virtual WAN Link status"
interface="R160" msg="The member2(R160) SLA order changed from 2 to 1. "
l

When load-balance mode service rule's SLA qualified member changes. In this example R150 changes to meet
SLA:
1: date=2019-04-11 time=14:33:23 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1555017075926510668 logdesc="Virtual WAN Link status"
msg="Service1(rule2) will be load balanced among members 1(R150) 2(R160) with available
routing."
2: date=2019-03-23 time=14:33:23 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553387603592651068 logdesc="Virtual WAN Link status"
interface="R160" msg="The member2(R160) link quality packet-loss order changed from 1 to
2. "
3: date=2019-03-23 time=14:33:23 logid="0100022923" type="event" subtype="system"
level="notice" vd="root" eventtime=1553387603592651068 logdesc="Virtual WAN Link status"
interface="R150" msg="The member1(R150) link quality packet-loss order changed from 2 to
1. "

SLA link status logs, generated with interval sla-fail-log-period or sla-pass-log-period:
l

When SLA fails, SLA link status logs will be generated with interval sla-fail-log-period:
7: date=2019-03-23 time=17:45:54 logid="0100022925" type="event" subtype="system"
level="notice" vd="root" eventtime=1553388352 logdesc="Link monitor SLA information"
name="test" interface="R150" status="up" msg="Latency: 0.016, jitter: 0.002, packet
loss: 21.000%, inbandwidth: 0Mbps, outbandwidth: 200Mbps, bibandwidth: 200Mbps, sla_map:
0x0"

l

When SLA passes, SLA link status logs will be generated with interval sla-pass-log-period:
5: date=2019-03-23 time=17:46:05 logid="0100022925" type="event" subtype="system"
level="information" vd="root" eventtime=1553388363 logdesc="Link monitor SLA
information" name="test" interface="R150" status="up" msg="Latency: 0.017, jitter:
0.003, packet loss: 0.000%, inbandwidth: 0Mbps, outbandwidth: 200Mbps, bibandwidth:
200Mbps, sla_map: 0x1"

SD-WAN related diagnose commands
This topic lists the SD-WAN related diagnose commands and related output.

To check SD-WAN health-check status:
FGT # diagnose sys virtual-wan-link health-check
Health Check(server):
Seq(1): state(alive), packet-loss(0.000%) latency(15.247), jitter(5.231) sla_map=0x0
Seq(2): state(alive), packet-loss(0.000%) latency(13.621), jitter(6.905) sla_map=0x0
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FGT # diagnose sys virtual-wan-link health-check
Health Check(ping):
Seq(1): state(alive), packet-loss(0.000%) latency(0.683), jitter(0.082) sla_map=0x0
Seq(2): state(dead), packet-loss(100.000%) sla_map=0x0
FGT # diagnose sys virtual-wan-link health-check google
Health Check(google):
Seq(1): state(alive), packet-loss(0.000%) latency(14.563), jitter(4.334) sla_map=0x0
Seq(2): state(alive), packet-loss(0.000%) latency(12.633), jitter(6.265) sla_map=0x0

To check SD-WAN member status:
l

When SD-WAN load-balance mode is source-ip-based/source-dest-ip-based.
FGT # diagnose sys virtual-wan-link member
Member(1): interface: port13, gateway: 10.100.1.1 2004:10:100:1::1, priority: 0, weight:
0
Member(2): interface: port15, gateway: 10.100.1.5 2004:10:100:1::5, priority: 0, weight:
0

l

When SD-WAN load-balance mode is weight-based.
FGT # diagnose sys virtual-wan-link member
Member(1): interface: port13, gateway: 10.100.1.1 2004:10:100:1::1, priority: 0, weight:
33
Member(2): interface: port15, gateway: 10.100.1.5 2004:10:100:1::5, priority: 0, weight:
66

l

When SD-WAN load-balance mode is measured-volume-based.
l Both members are under volume and still have room:
FGT # diagnose sys virtual-wan-link member
Member(1): interface: port13, gateway: 10.100.1.1 2004:10:100:1::1, priority: 0,
weight: 33
Config volume ratio: 33, last reading: 8211734579B, volume room 33MB
Member(2): interface: port15, gateway: 10.100.1.5 2004:10:100:1::5, priority: 0,
weight: 66
Config volume ratio: 66, last reading: 24548159B, volume room 66MB
l

Some members are overloaded and some still have room:
FGT # diagnose sys virtual-wan-link member
Member(1): interface: port1, gateway: 10.10.0.2, priority: 0, weight: 0
Config volume ratio: 10, last reading: 10297221000B, overload volume 1433MB
Member(2): interface: port2, gateway: 10.11.0.2, priority: 0, weight: 38
Config volume ratio: 50, last reading: 45944239916B, volume room 38MB

l

When SD-WAN load balance mode is usage-based/spillover.
l When no spillover occurs:
FGT # diagnose sys virtual-wan-link member
Member(1): interface: port13, gateway: 10.100.1.1 2004:10:100:1::1, priority: 0,
weight: 255
Egress-spillover-threshold: 400kbit/s, ingress-spillover-threshold: 300kbit/s
Egress-overbps=0, ingress-overbps=0
Member(2): interface: port15, gateway: 10.100.1.5 2004:10:100:1::5, priority: 0,
weight: 254
Egress-spillover-threshold: 0kbit/s, ingress-spillover-threshold: 0kbit/s
Egress-overbps=0, ingress-overbps=0
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l

When member has reached limit and spillover occurs:
FGT # diagnose sys virtual-wan-link member
Member(1): interface: port13, gateway: 10.100.1.1 2004:10:100:1::1, priority: 0,
weight: 255
Egress-spillover-threshold: 400kbit/s, ingress-spillover-threshold: 300kbit/s
Egress-overbps=1, ingress-overbps=1
Member(2): interface: port15, gateway: 10.100.1.5 2004:10:100:1::5, priority: 0,
weight: 254
Egress-spillover-threshold: 0kbit/s, ingress-spillover-threshold: 0kbit/s
Egress-overbps=0, ingress-overbps=0

l

You can also use the diagnose netlink dstmac list command to check if you are over the limit.
FGT # diagnose netlink dstmac list port13
dev=port13 mac=08:5b:0e:ca:94:9d rx_tcp_mss=0 tx_tcp_mss=0 egress_overspill_
threshold=51200 egress_bytes=103710 egress_over_bps=1 ingress_overspill_
threshold=38400 ingress_bytes=76816 ingress_over_bps=1 sampler_rate=0

To check SD-WAN service rules status:
l

Manual mode service rules.
FGT # diagnose sys virtual-wan-link service
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(manual)
Members:
1: Seq_num(2), alive, selected
Dst address: 10.100.21.0-10.100.21.255

l

Auto mode service rules.
FGT # diagnose sys virtual-wan-link service
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(auto), link-cost-factor(latency), link-costthreshold(10), health-check(ping)
Members:
1: Seq_num(2), alive, latency: 0.011
2: Seq_num(1), alive, latency: 0.018, selected
Dst address: 10.100.21.0-10.100.21.255

l

Priority mode service rules.
FGT # diagnose sys virtual-wan-link service
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(priority), link-cost-factor(latency), linkcost-threshold(10), health-check(ping)
Members:
1: Seq_num(2), alive, latency: 0.011, selected
2: Seq_num(1), alive, latency: 0.017, selected
Dst address: 10.100.21.0-10.100.21.255

l

Load-balance mode service rules.
FGT # diagnose sys virtual-wan-link service
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(load-balance)
Members:
1: Seq_num(1), alive, sla(0x1), num of pass(1), selected
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2: Seq_num(2), alive, sla(0x1), num of pass(1), selected
Dst address: 10.100.21.0-10.100.21.255
l

SLA mode service rules.
FGT # diagnose sys virtual-wan-link service
Service(1): Address Mode(IPV4) flags=0x0
TOS(0x0/0x0), Protocol(0: 1->65535), Mode(sla)
Members:
1: Seq_num(1), alive, sla(0x1), cfg_order(0), cost(0), selected
2: Seq_num(2), alive, sla(0x1), cfg_order(1), cost(0), selected
Dst address: 10.100.21.0-10.100.21.255

To check interface logs from the past 15 minutes:
FGT (root) # diagnose sys virtual-wan-link intf-sla-log R150
Timestamp: Fri Apr 12 11:08:36 2019, used inbandwidth: 0bps, used outbandwidth: 0bps, used
bibandwidth: 0bps, tx bytes: 860bytes, rx bytes: 1794bytes.
Timestamp: Fri Apr 12 11:08:46 2019, used inbandwidth: 1761bps, used outbandwidth: 1710bps,
used bibandwidth: 3471bps, tx bytes: 2998bytes, rx bytes: 3996bytes.
Timestamp: Fri Apr 12 11:08:56 2019, used inbandwidth: 2452bps, used outbandwidth: 2566bps,
used bibandwidth: 5018bps, tx bytes: 7275bytes, rx bytes: 7926bytes.
Timestamp: Fri Apr 12 11:09:06 2019, used inbandwidth: 2470bps, used outbandwidth: 3473bps,
used bibandwidth: 5943bps, tx bytes: 13886bytes, rx bytes: 11059bytes.
Timestamp: Fri Apr 12 11:09:16 2019, used inbandwidth: 2433bps, used outbandwidth: 3417bps,
used bibandwidth: 5850bps, tx bytes: 17946bytes, rx bytes: 13960bytes.
Timestamp: Fri Apr 12 11:09:26 2019, used inbandwidth: 2450bps, used outbandwidth: 3457bps,
used bibandwidth: 5907bps, tx bytes: 22468bytes, rx bytes: 17107bytes.

To check SLA logs in the past 15 minutes:
FGT (root) # diagnose sys virtual-wan-link sla-log ping 1
Timestamp: Fri Apr 12 11:09:27 2019, vdom root, health-check
up, latency: 0.014, jitter: 0.003, packet loss: 16.000%.
Timestamp: Fri Apr 12 11:09:28 2019, vdom root, health-check
up, latency: 0.015, jitter: 0.003, packet loss: 15.000%.
Timestamp: Fri Apr 12 11:09:28 2019, vdom root, health-check
up, latency: 0.014, jitter: 0.003, packet loss: 14.000%.
Timestamp: Fri Apr 12 11:09:29 2019, vdom root, health-check
up, latency: 0.015, jitter: 0.003, packet loss: 13.000%.

ping, interface: R150, status:
ping, interface: R150, status:
ping, interface: R150, status:
ping, interface: R150, status:

To check Application Control used in SD-WAN and the matching IP addresses:
FGT # diagnose sys virtual-wan-link internet-service-app-ctrl-list
Ctrl application(Microsoft.Authentication 41475):Internet Service ID(4294836224)
Protocol(6), Port(443)
Address(2): 104.42.72.21 131.253.61.96
Ctrl application(Microsoft.CDN 41470):Internet Service ID(4294836225)
Ctrl application(Microsoft.Lync 28554):Internet Service ID(4294836226)
Ctrl application(Microsoft.Office.365 33182):Internet Service ID(4294836227)
Ctrl application(Microsoft.Office.365.Portal 41468):Internet Service ID(4294836228)
Ctrl application(Microsoft.Office.Online 16177):Internet Service ID(4294836229)
Ctrl application(Microsoft.OneNote 40175):Internet Service ID(4294836230)
Ctrl application(Microsoft.Portal 41469):Internet Service ID(4294836231)
Protocol(6), Port(443)
Address(8): 23.58.134.172 131.253.33.200 23.58.135.29 204.79.197.200 64.4.54.254
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23.59.156.241 13.77.170.218 13.107.22.200
Ctrl application(Microsoft.Sharepoint 16190):Internet Service ID(4294836232)
Ctrl application(Microsoft.Sway 41516):Internet Service ID(4294836233)
Ctrl application(Microsoft.Tenant.Namespace 41471):Internet Service ID(4294836234)

To check IPsec aggregate interface when SD-WAN uses the per-packet distribution feature:
# diagnose sys ipsec-aggregate list
agg1 algo=L3 member=2 run_tally=2
members:
vd1-p1
vd1-p2

To check BGP learned routes and determine if they are used in SD-WAN service:
FGT # get router info bgp network
FGT # get router info bgp network 10.100.11.0
BGP routing table entry for 10.100.10.0/24
Paths: (2 available, best 1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
172.10.22.2
20
10.100.20.2 from 10.100.20.2 (6.6.6.6)
Origin EGP metric 200, localpref 100, weight 10000, valid, external, best
Community: 30:5
Last update: Wen Mar 20 18:45:17 2019
FGT # get router info route-map-address
Extend-tag: 15, interface(wan2:16)
10.100.11.0/255.255.255.0
FGT # diagnose firewall proute list
list route policy info(vf=root):
id=4278779905 vwl_service=1(DataCenter) flags=0x0 tos=0x00 tos_mask=0x00 protocol=0
sport=0:65535 iif=0 dport=1-65535 oif=16
source wildcard(1): 0.0.0.0/0.0.0.0
destination wildcard(1): 10.100.11.0/255.255.255.0

SLA logging
The features adds an SD-WAN daemon function to keep a short, 10 minute history of SLA that can be viewed in the CLI.
Performance SLA results related to interface selection, session failover, and other information, can be logged. These
logs can then be used for long-term monitoring of traffic issues at remote sites, and for reports and views in
FortiAnalyzer.
The time intervals that Performance SLA fail and pass logs are generated in can be configured.

To configure the fail and pass logs' generation time interval:
config system virtual-wan-link
config health-check
edit "ping"
set sla-fail-log-period 30
set sla-pass-log-period 60
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next
end
end

To view the 10 minute Performance SLA link status history:
FGT_A (root) # diagnose sys virtual-wan-link sla-log ping 1
Timestamp: Thu Feb 28 10:58:24 2019, vdom root, health-check
up, latency: 0.000, jitter: 0.000, packet loss: 0.000%.
Timestamp: Thu Feb 28 10:58:24 2019, vdom root, health-check
up, latency: 0.097, jitter: 0.000, packet loss: 0.000%.
Timestamp: Thu Feb 28 10:58:25 2019, vdom root, health-check
up, latency: 0.058, jitter: 0.040, packet loss: 0.000%.
Timestamp: Thu Feb 28 10:58:25 2019, vdom root, health-check
up, latency: 0.044, jitter: 0.026, packet loss: 0.000%.
... ...

ping, interface: R150, status:
ping, interface: R150, status:
ping, interface: R150, status:
ping, interface: R150, status:

SLA pass logs
The FortiGate generates Performance SLA logs at the specified pass log interval (sla-pass-log-period) when SLA
passes.
3: date=2019-02-28 time=11:53:26 logid="0100022925" type="event" subtype="system"
level="information" vd="root" eventtime=1551383604 logdesc="Link monitor SLA information"
name="ping" interface="R160" status="up" msg="Latency: 0.013, jitter: 0.001, packet loss:
0.000%, inbandwidth: 0Mbps, outbandwidth: 0Mbps, bibandwidth: 0Mbps, sla_map: 0x1"
7: date=2019-02-28 time=11:52:26 logid="0100022925" type="event" subtype="system"
level="information" vd="root" eventtime=1551383545 logdesc="Link monitor SLA information"
name="ping" interface="R160" status="up" msg="Latency: 0.013, jitter: 0.002, packet loss:
0.000%, inbandwidth: 0Mbps, outbandwidth: 0Mbps, bibandwidth: 0Mbps, sla_map: 0x1"

In the FortiAnalyzer GUI:

SLA fail logs
The FortiGate generates Performance SLA logs at the specified fail log interval (sla-fail-log-period) when SLA
fails.
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6: date=2019-02-28 time=11:52:32 logid="0100022925" type="event" subtype="system"
level="notice" vd="root" eventtime=1551383552 logdesc="Link monitor SLA information"
name="ping" interface="R150" status="down" msg="Latency: 0.000, jitter: 0.000, packet loss:
100.000%, inbandwidth: 0Mbps, outbandwidth: 200Mbps, bibandwidth: 200Mbps, sla_map: 0x0"
8: date=2019-02-28 time=11:52:02 logid="0100022925" type="event" subtype="system"
level="notice" vd="root" eventtime=1551383522 logdesc="Link monitor SLA information"
name="ping" interface="R150" status="down" msg="Latency: 0.000, jitter: 0.000, packet loss:
100.000%, inbandwidth: 0Mbps, outbandwidth: 200Mbps, bibandwidth: 200Mbps, sla_map: 0x0"

SLA monitoring using the REST API
SLA log information and interface SLA information can be monitored using the REST API. This feature is also be used by
FortiManager as part of its detailed SLA monitoring and drill-down features.

Interface log command example:
https://172.172.172.9/api/v2/monitor/virtual-wan/interface-log
{
"http_method":"GET",
"results":[
{
"interface":"port13",
"logs":[
{
"timestamp":1547087168,
"tx_bandwidth":3447,
"rx_bandwidth":3457,
"bi_bandwidth":6904,
"tx_bytes":748875,
"rx_bytes":708799,
"egress_queue":[
]
},
{
"timestamp":1547087178,
"tx_bandwidth":3364,
"rx_bandwidth":3400,
"bi_bandwidth":6764,
"tx_bytes":753789,
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"rx_bytes":712835,
"egress_queue":[
]
},
....
....

SLA log command example:
https://172.172.172.9/api/v2/monitor/virtual-wan/sla-log
{
"http_method":"GET",
"results":[
{
"name":"ping",
"interface":"port13",
"logs":[
{
"timestamp":1547087204,
"link":"up",
"latency":0.686433,
"jitter":0.063400,
"packetloss":0.000000
},
{
"timestamp":1547087205,
"link":"up",
"latency":0.688433,
"jitter":0.063133,
"packetloss":0.000000
},
{
"timestamp":1547087206,
"link":"up",
"latency":0.688300,
"jitter":0.065267,
"packetloss":0.000000
},
....
....

CLI diagnose commands:
# diagnose sys virtual-wan-link sla-log ping 1
Timestamp: Wed Jan 9 18:35:11 2019, vdom root, health-check
status: up, latency: 0.698, jitter: 0.073, packet loss: 0.000%.
Timestamp: Wed Jan 9 18:35:12 2019, vdom root, health-check
status: up, latency: 0.704, jitter: 0.073, packet loss: 0.000%.
Timestamp: Wed Jan 9 18:35:13 2019, vdom root, health-check
status: up, latency: 0.709, jitter: 0.073, packet loss: 0.000%.
Timestamp: Wed Jan 9 18:35:14 2019, vdom root, health-check
status: up, latency: 0.707, jitter: 0.066, packet loss: 0.000%.
Timestamp: Wed Jan 9 18:35:15 2019, vdom root, health-check
status: up, latency: 0.710, jitter: 0.061, packet loss: 0.000%.
Timestamp: Wed Jan 9 18:35:16 2019, vdom root, health-check
status: up, latency: 0.707, jitter: 0.055, packet loss: 0.000%.
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Timestamp: Wed Jan 9 18:35:17 2019, vdom root, health-check ping, interface: port13,
status: up, latency: 0.703, jitter: 0.055, packet loss: 0.000%.
# diagnose sys virtual-wan-link intf-sla-log port13
Timestamp: Wed Jan 9 18:33:49 2019, used inbandwidth: 3208bps, used outbandwidth:
3453bps, used bibandwidth: 6661bps, tx bytes: 947234bytes, rx bytes: 898622bytes.
Timestamp: Wed Jan 9 18:33:59 2019, used inbandwidth: 3317bps, used outbandwidth:
3450bps, used bibandwidth: 6767bps, tx bytes: 951284bytes, rx bytes: 902937bytes.
Timestamp: Wed Jan 9 18:34:09 2019, used inbandwidth: 3302bps, used outbandwidth:
3389bps, used bibandwidth: 6691bps, tx bytes: 956268bytes, rx bytes: 907114bytes.
Timestamp: Wed Jan 9 18:34:19 2019, used inbandwidth: 3279bps, used outbandwidth:
3352bps, used bibandwidth: 6631bps, tx bytes: 958920bytes, rx bytes: 910793bytes.
Timestamp: Wed Jan 9 18:34:29 2019, used inbandwidth: 3233bps, used outbandwidth:
3371bps, used bibandwidth: 6604bps, tx bytes: 964374bytes, rx bytes: 914854bytes.
Timestamp: Wed Jan 9 18:34:39 2019, used inbandwidth: 3235bps, used outbandwidth:
3362bps, used bibandwidth: 6597bps, tx bytes: 968250bytes, rx bytes: 918846bytes.
Timestamp: Wed Jan 9 18:34:49 2019, used inbandwidth: 3165bps, used outbandwidth:
3362bps, used bibandwidth: 6527bps, tx bytes: 972298bytes, rx bytes: 922724bytes.
Timestamp: Wed Jan 9 18:34:59 2019, used inbandwidth: 3184bps, used outbandwidth:
3362bps, used bibandwidth: 6546bps, tx bytes: 977282bytes, rx bytes: 927019bytes.

SD-WAN bandwidth monitoring service
The bandwidth measuring tool is used to detect true upload and download speeds. Bandwidth tests can be run on
demand or automated using a script, and can be useful when configuring SD-WAN SLA and rules to balance SD-WAN
traffic.
The speed test tool requires a valid license, either with the 360 Protection Bundle in 6.2, or an SD-WAN Bandwidth
Monitoring Service license.
The speed test tool is compatible with iperf3.6 with SSL support. It can test the upload bandwidth to the FortiGate Cloud
speed test service. It can initiate the server connection and send download requests to the server. The tool can be run up
to 10 times a day .
FortiGate downloads the speed test server list. The list expires after 24 hours. One of the speed test servers is selected,
based on user input. The speed test runs, testing upload and download speeds. The test results are shown in the
command terminal.

To download the speed test server list:
# execute speed-test-server download
Download completed.

To check the speed test server list:
# execute speed-test-server
AWS_West valid
Host: 34.210.67.183
Host: 34.210.67.183
Host: 34.210.67.183
Host: 34.210.67.183
Google_West valid
Host: 35.197.55.210
Host: 35.197.55.210
Host: 35.197.55.210
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Host:
Host:
Host:
Host:
Host:
Host:
Host:
Host:
Host:

35.197.55.210 5207 fortinet
35.230.2.124 5204 fortinet
35.230.2.124 5205 fortinet
35.230.2.124 5206 fortinet
35.230.2.124 5207 fortinet
35.197.18.234 5204 fortinet
35.197.18.234 5205 fortinet
35.197.18.234 5206 fortinet
35.197.18.234 5207 fortinet

To run the speed test:
You can run the speed test without specifying a server. The system will automatically choose one server from the list and
run the speed test.
# execute speed-test auto
The license is valid to run speed test.
Speed test quota for 2/1 is 9
current vdom=root
Run in uploading mode.
Connecting to host 35.230.2.124, port 5206
[ 16] local 172.16.78.185 port 2475 connected to 35.230.2.124 port 5206
[ ID] Interval Transfer Bitrate Retr Cwnd
[ 16] 0.00-1.01 sec 11.0 MBytes 91.4 Mbits/sec 0 486 KBytes
[ 16] 1.01-2.00 sec 11.6 MBytes 98.4 Mbits/sec 0 790 KBytes
[ 16] 2.00-3.01 sec 11.0 MBytes 91.6 Mbits/sec 15 543 KBytes
[ 16] 3.01-4.01 sec 11.2 MBytes 94.2 Mbits/sec 1 421 KBytes
[ 16] 4.01-5.01 sec 11.2 MBytes 93.5 Mbits/sec 0 461 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - [ ID] Interval Transfer Bitrate Retr
[ 16] 0.00-5.01 sec 56.1 MBytes 93.8 Mbits/sec 16 sender
[ 16] 0.00-5.06 sec 55.8 MBytes 92.6 Mbits/sec receiver
speed test Done.
Run in reverse downloading mode!
Connecting to host 35.230.2.124, port 5206
Reverse mode, remote host 35.230.2.124 is sending
[ 16] local 172.16.78.185 port 2477 connected to 35.230.2.124 port 5206
[ ID] Interval Transfer Bitrate
[ 16] 0.00-1.00 sec 10.9 MBytes 91.4 Mbits/sec
[ 16] 1.00-2.00 sec 11.2 MBytes 93.9 Mbits/sec
[ 16] 2.00-3.00 sec 11.2 MBytes 94.0 Mbits/sec
[ 16] 3.00-4.00 sec 11.2 MBytes 93.9 Mbits/sec
[ 16] 4.00-5.00 sec 10.9 MBytes 91.1 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - [ ID] Interval Transfer Bitrate Retr
[ 16] 0.00-5.03 sec 57.5 MBytes 95.9 Mbits/sec 40 sender
[ 16] 0.00-5.00 sec 55.4 MBytes 92.9 Mbits/sec receiver
speed test Done

To run the speed test on a server farm or data center:
# execute speed-test auto AWS_West
The license is valid to run speed test.
Speed test quota for 2/1 is 8
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current vdom=root
Run in uploading mode.
Connecting to host 34.210.67.183, port 5205

To run the speed test on a local interface when there are multiple valid routes:
# execute speed-test port1 Google_West
The license is valid to run speed test.
Speed test quota for 2/1 is 6
bind to local ip 172.16.78.202
current vdom=root
Specified interface port1 does not comply with default outgoing interface port2 in routing
table!
Force to use the specified interface!
Run in uploading mode.
Connecting to host 35.197.18.234, port 5205
[ 11] local 172.16.78.202 port 20852 connected to 35.197.18.234 port 5205
[ ID] Interval Transfer Bitrate Retr Cwnd
[ 11] 0.00-1.01 sec 10.7 MBytes 89.0 Mbits/sec 0 392 KBytes
[ 11] 1.01-2.01 sec 10.5 MBytes 88.5 Mbits/sec 1 379 KBytes
[ 11] 2.01-3.01 sec 11.3 MBytes 94.5 Mbits/sec 0 437 KBytes
[ 11] 3.01-4.01 sec 11.2 MBytes 94.3 Mbits/sec 0 478 KBytes
[ 11] 4.01-5.00 sec 11.3 MBytes 95.2 Mbits/sec 0 503 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - [ ID] Interval Transfer Bitrate Retr
[ 11] 0.00-5.00 sec 55.1 MBytes 92.3 Mbits/sec 1 sender
[ 11] 0.00-5.04 sec 54.5 MBytes 90.7 Mbits/sec receiver
speed test Done.
Run in reverse downloading mode!
Connecting to host 35.197.18.234, port 5205
Reverse mode, remote host 35.197.18.234 is sending
[ 11] local 172.16.78.202 port 20853 connected to 35.197.18.234 port 5205
[ ID] Interval Transfer Bitrate
[ 11] 0.00-1.00 sec 10.9 MBytes 91.1 Mbits/sec
[ 11] 1.00-2.00 sec 11.2 MBytes 94.0 Mbits/sec
[ 11] 2.00-3.00 sec 11.2 MBytes 94.0 Mbits/sec
[ 11] 3.00-4.00 sec 11.2 MBytes 94.0 Mbits/sec
[ 11] 4.00-5.00 sec 11.2 MBytes 94.0 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - [ ID] Interval Transfer Bitrate Retr
[ 11] 0.00-5.03 sec 57.4 MBytes 95.8 Mbits/sec 33 sender
[ 11] 0.00-5.00 sec 55.7 MBytes 93.4 Mbits/sec receiver
speed test Done.

To add a script to run a speed test automatically once every 24 hours:
config system auto-script
edit "speedtest"
set interval 86400
set repeat 0
set start auto
set script "
execute speed-test-server download
execute speed-test"
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next
end

To view the results of the speed test script:
execute auto-script result speedtest

Enable dynamic connector addresses in SD-WAN policies
Dynamic Fabric Connector addresses can be used in SD-WAN policies.

To add a dynamic connector address to an SD-WAN rule:
1.
2.
3.
4.
5.

Go to Network > SD-WAN Rules.
Click Create New.
In the Name field, enter the rule name.
In the Destination > Addresses field, click the +. The Select Entries pane will appear.
In the Select Entries pane, select the dynamic connector (in the example, aws1).

6. Configure the remaining settings as required.
7. Click OK to save the rule.

Configuring SD-WAN in an HA cluster using internal hardware switches
This setup is not fully compliant with a regular HA configuration. Failover is also unnecessary.
Flipping can occur if failover is configured using a ping server interface.

Two FortiGates with internal hardware switches can be configured as an active-active (A-A) HA pair. In the following
topology, both FortiGates forward traffic through internal switches connected to service providers. SD-WAN is
configured on all upstream interfaces and overlays.
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This setup is not fully compliant with a regular HA configuration. In a regular HA configuration, two logical switches are
used: one for incoming traffic and one for outgoing traffic. In this example, only incoming traffic has a switch while
outgoing traffic uses the internal switch. This means that if FortiGate A loses power, ISP 1 will not be available.
Traffic will flow either through ISP 1 directly or through ISP 2 via a connection between FortiGate A and FortiGate B’s
internal switch interface. FortiGate A decides how traffic will go through ISP 1 or ISP 2 based on SD-WAN rules. If ISP 1
is not available, then traffic will go through ISP 2.
Failover is unnecessary in this setup. Because SD-WAN will automatically failover traffic to the accessible ISP, traffic is
not blocked so there is no network downtime. Also, the hardware switch interface cannot be monitored as an HA
interface. If HA failover is required, a ping server must be used. The ping server monitor interface has to be configured
under HA settings. This failover setup, however, results in flipping. FortiGate B will act as the master after failover and
traffic will still flow to the available ISP. Since the broken link to one of the ISPs still fails, HA will start flipping until the link
is back up.

To configure the HA A-A cluster with internal hardware switches:
1. Configure two FortiGates with internal switches in an active-active HA cluster (follow the steps in HA active-active
cluster setup on page 520), starting by connecting the heartbeat interface.
2. On the master FortiGate, remove the existing interface members:
a. Go to Network > Interfaces.
b. In the LAN section, double-click the internal interface to edit it.
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c. In the Interface Members box, remove all the interfaces.

d. Click OK.
3. On the master FortiGate, configure the hardware switch interfaces for the two ISPs:
a. Go to Network > Interfaces.
b. Click Create New > Interface.
c. Enter a name (HD_SW1).
d. For type, select Hardware Switch.
e. For Interface Members, add two interfaces (internal1 and internal2).
f. Configure the other settings as needed.
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g. Click OK.

h. Repeat these steps to create a second hardware switch interface (HD_SW2) with two interface members
(internal3 and internal4).
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4. On the master FortiGate, set up SD-WAN:

The master FortiGate makes all the SD-WAN decisions.

a.
b.
c.
d.
e.
f.
g.

Go to Network > SD-WAN.
For Status, click Enable.
In the SD-WAN Interface Members section, click Create New. The New SD-WAN Member pane opens.
In the Interface dropdown, select HD_SW1 and enter the Gateway address.
Click OK.
Repeat these steps to add the second interface (HD_SW2).
Click Apply.

5. Connect the devices as shown in the topology:
a. Connect the incoming interface to the internal switch on both FortiGates.
b. On FortiGate A, connect ISP 1 to HD_SW1.
c. On FortiGate B, connect ISP 2 to HD_SW2.
d. For HD_SW1, connect FortiGate A directly to B.
e. For HD_SW2, connect FortiGate A directly to B.

The default implicit rule load-balancing algorithm for SD-WAN is the source IP address. For
more information about rule types and configurations, see Implicit rule on page 375.
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DHCP server
A DHCP server provides an address from a defined address range to a client on the network, when requested.
You can configure one or more DHCP servers on any FortiGate interface. A DHCP server dynamically assigns IP
addresses to hosts on the network connected to the interface. The host computers must be configured to obtain their IP
addresses using DHCP.
You can configure a FortiGate interface as a DHCP relay. The interface forwards DHCP requests from DHCP clients to
an external DHCP server and returns the responses to the DHCP clients. The DHCP server must have appropriate
routing so that its response packets to the DHCP clients arrive at the unit.

Configure DHCP on the FortiGate
To add a DHCP server on the GUI:
1. Go to Network > Interfaces.
2. Edit an interface.
3. Enable the DHCP Server option and configure the settings.

To add a DHCP server on the CLI:
config system dhcp server
edit 1
set dns-service default
set default-gateway 192.168.1.2
set netmask 255.255.255.0
set interface "port1"
config ip-range
edit 1
set start-ip 192.168.1.1
set end-ip 192.168.1.1
next
edit 2
set start-ip 192.168.1.3
set end-ip 192.168.1.254
next
end
set timezone-option default
set tftp-server "172.16.1.2"
next
end

DHCP options
When adding a DHCP server, you can include DHCP codes and options. The DHCP options are BOOTP vendor
information fields that provide additional vendor-independent configuration parameters to manage the DHCP server. For
example, you might need to configure a FortiGate DHCP server that gives out a separate option as well as an IP
address, such as an environment that needs to support PXE boot with Windows images.
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The option numbers and codes are specific to the application. The documentation for the application indicates the values
to use. Option codes are represented in a option value/HEX value pairs. The option is a value between 1 and 255.
You can add up to three DHCP code/option pairs per DHCP server.

To configure option 252 with value http://192.168.1.1/wpad.dat using the CLI:
config system dhcp server
edit <server_entry_number>
set option1 252 687474703a2f2f3139322e3136382e312e312f777061642e646174
next
end

For detailed information about DHCP options, see RFC 2132, DHCP Options and BOOTP Vendor Extensions.

Option-82
DHCP option 82, also known as the DHCP relay agent information option, helps protect FortiGate against attacks such
as spoofing (forging) of IP addresses and MAC addresses, and DHCP IP address starvation.
See DHCP relay agent information option on page 457 for details.

Option-42
This option specifies a list of the NTP servers available to the client by IP address.
config system dhcp server
edit 2
set ntp-service {local | default | specify}
set ntp-server1 <class_ip>
set ntp-server2 <class_ip>
set ntp-server3 <class_ip>
next
end

The NTP service options include:
l

l
l

local: The IP address of the interface that the DHCP server is added to becomes the client's NTP server
IP address.
default: Clients are assigned the FortiGate's configured NTP servers.
specify: Specify up to three NTP servers in the DHCP server configuration.

DHCP relay agent information option
Option 82 (DHCP relay information option) helps protect the FortiGate against attacks such as spoofing (or forging) of IP
and MAC addresses, and DHCP IP address starvation.
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The following CLI variables are included in the config system dhcp server > config reserved-address
command:
circuit-id-type {hex |
string}

DHCP option type; hex or string (default).

circuit-id <value>

Option 82 circuit ID of the client that will get the reserved IP address.
Format: vlan-mod-port
l vlan: VLAN ID (2 bytes)
l mod: 1 = snoop, 0 = relay (1 byte)
l port: port number (1 byte)

remote-id-type {hex |
string}

DHCP option type; hex or string (default).

remote-id <value>

Option 82 remote ID of the client that will get the reserved IP address.
Format: the MAC address of the client.

type {mac | option82}

The DHCP reserved address type; mac (default) or option82.

To create an IP address assignment rule using option 82 in the GUI:
1. Go to Network > Interfaces.
2. Edit an existing port, or create a new one.

The port Role must be LAN or Undefined.

3. Enable DHCP Server.
4. Configure the address ranges and other settings as needed.
5. Click + to expand the Advanced options.
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6. In the IP Address Assignment Rules table, click Create New.

The Create New IP Address Assignment Rule pane opens.
7. Configure the new rule:
a. For the Type, select DHCP Relay Agent.
b. Enter the Circuit ID and Remote ID.
c. Enter the IP address that will be reserved.
8. Click OK.

To create an IP address assignment rule using option 82 with the CLI:
config system dhcp server
edit 1
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set netmask 255.255.255.0
set interface "port4"
config ip-range
edit 1
set start-ip 100.100.100.1
set end-ip 100.100.100.99
next
edit 2
set start-ip 100.100.100.101
set end-ip 100.100.100.254
next
end
config reserved-address
edit 1
set type option82
set ip 100.100.100.12
set circuit-id-type hex
set circuit-id "00010102"
set remote-id-type hex
set remote-id "704ca5e477d6"
next
end
next
end

Direct IP support for LTE/4G
Direct IP is a public IP address that is assigned to a computing device, which allows the device to directly access the
internet.
When an LTE modem is enabled in FortiOS, a DHCP interface is created. As a result, the FortiGate can acquire direct IP
(which includes IP, DNS, and gateway) from the LTE network carrier.
Since some LTE modems require users to input the access point name (APN) for the LTE network, the LTE modem
configuration allows you to set the APN.

LTE modems can only be enabled by using the CLI.

To enable direct IP support using the CLI:
1. Enable the LTE modem:
config system lte-modem
set status enable
end

2. Check that the LTE interface was created:
config system interface
edit "wwan"
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set
set
set
set
set
set
next
end

vdom "root"
mode dhcp
status down
distance 1
type physical
snmp-index 23

Shortly after the LTE modem joins its carrier network, wwan is enabled and granted direct IP:
# config system interface
(interface) # edit wwan
(wwan) # get
name
: wwan
....
ip
: 100.112.75.43 255.255.255.248
....
status
: up
....
defaultgw
: enable
DHCP Gateway
: 100.112.75.41
Lease Expires
: Thu Feb 21 19:33:27 2019
dns-server-override : enable
Acquired DNS1
: 184.151.118.254
Acquired DNS2
: 70.28.245.227
....

PCs can reach the internet via the following firewall policy:
config firewall policy
....
edit 5
set name "LTE"
set uuid 61880e9a-36ce-51e9-a4f4-15cc3ffc25f3
set srcintf "port9"
set dstintf "wwan"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set fsso disable
set nat enable
next
end

Sample LTE interface
When an LTE modem is enabled, you can view the LTE interface in the GUI and check the acquired IP, DNS, and
gateway.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

461

Network

To view the LTE interface in the GUI:
1. Go to Network > Interfaces.
2. Double-click the LTE interface to view the properties.
3. Look in the Address section to view the:
a. Obtained IP
b. Acquired DNS
c. Default Gateway
4. Click Return.

To configure the firewall policy that uses the LTE interface:
1.
2.
3.
4.

Go to Policy & Objects > IPv4 Policy.
Double-click the LTE policy. The Edit Policy pane opens.
In the Outgoing Interface field, select the interface (wwan in this example).
Configure the rest of the policy as needed.
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5. Click OK.

Limitations
l

Most LTE modems have a preset APN in their SIM card. Therefore, the APN does not need to be set in the FortiOS
configuration. In cases where the internet cannot be accessed, consult with your carrier and set the APN in the LTE
modem configuration (for example, inet.bell.ca):
config system lte-modem
set status enable
set apn "inet.bell.ca"
end

l

Some models, such as the FortiGate 30E-3G4G, have built-in LTE modems. In this scenario, the LTE modem is
enabled by default. The firewall policy via the LTE interface is also created by default. Once you plug in a SIM card,
your network devices can connect to the internet.

Sample FortiGate 30E-3G4G default configuration:
config system lte-modem
set status enable
set extra-init ''
set manual-handover disable
set force-wireless-profile 0
set authtype none
set apn ''
set modem-port 255
set network-type auto
set auto-connect disable
set gpsd-enabled disable
set data-usage-tracking disable
set gps-port 255
end
config firewall policy
....
edit 3
set uuid f7c77cc6-36d1-51e9-2899-a7040791330c
set srcintf "internal"
set dstintf "wwan"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end
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LLDP reception
Natively, device detection can scan LLDP as a source for device identification. However, the FortiGate does not read or
store the full information. Enabling LLDP reception allows the FortiGate to receive and store LLDP messages, learn
about active neighbors, and makes the LLDP information available via the CLI, REST API, and SNMP.
You will need to enable device-identification at the interface level, and then lldp-reception can be enabled
on three levels: globally, per VDOM, or per interface.

To configure device identification on an interface:
config system interface
edit <port>
set device-identification enable
next
end

To configure LLDP reception globally:
config system global
set lldp-reception enable
end

To configure LLDP reception per VDOM:
config system setting
set lldp-reception enable
end

To configure LLDP reception per interface:
config system interface
edit <port>
set lldp-reception enable
next
end

To view the LLDP information in the GUI:
1. Go to User & Device > Device Inventory to view the information.
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To view the received LLDP information in the CLI:
# diagnose user device list
hosts
vd root/0 44:0a:a0:0a:0a:0a gen 3 req S/2
created 10290s gen 1 seen 0s port3 gen 1
ip 172.22.22.22 src lldp
type 20 'Other Network Device' src lldp id 155 gen 2
os 'Artist EOS ' version '4.20.4' src lldp id 155
host 'artist' src lldp

To view additional information about LLDP neighbors and ports:
# diagnose lldprx neighbor {summary | details | clear}
# diagnose lldprx port {details | summary | neighbor | filter}
# diagnose lldprx port neighbor {summary | details}

Note that the port index in the output corresponds to the port index from the following command:
# diagnose netlink interface list port2 port3 | grep index
if=port2 family=00 type=1 index=4 mtu=1500 link=0 master=0
if=port3 family=00 type=1 index=5 mtu=1500 link=0 master=0

To view the received LLDP information in the REST API:
{
"http_method":"GET",
"results":[
{
"mac":"90:9c:9c:c9:c9:90",
"chassis_id":"90:9C:9C:C9:C9:90",
"port":19,
"port_id":"port12",
"port_desc":"port12",
"system_name":"S124DN3W00000000",
"system_desc":"FortiSwitch-124D v3.6.6,build0416,180515 (GA)",
"ttl":120,
"addresses":[
{
"type":"ipv4",
"address":"192.168.1.99"
}
]
}
],
"vdom":"root",
"path":"network",
"name":"lldp",
"action":"neighbors",
"status":"success",
"serial":"FG201E4Q00000000",
"version":"v6.2.0",
"build":866
}
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{
"http_method":"GET",
"results":[
{
"name":"port1",
"rx":320,
"neighbors":1
}
],
"vdom":"root",
"path":"network",
"name":"lldp",
"action":"ports",
"mkey":"port1",
"status":"success",
"serial":"FG201E4Q00000000",
"version":"v6.2.0",
"build":866
}
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This topic contains information about FortiGate administration and system configuration that you can do after installing
the FortiGate in your network.

Basic system settings
Administrators
By default, FortiGate has an administrator account with the username admin and no password. See Administrators on
page 469 for more information.

Administrator profiles
An administrator profile defines what the administrator can see and do on the FortiGate. See Administrator profiles on
page 469 for more information.

Password policy
Set up a password policy to enforce password criteria and change frequency. See Password policy on page 473 for
more information.

Interfaces
Physical and virtual interface allow traffic to flow between internal networks, and between the internet and internal
networks. See Interfaces on page 295 for more information.

Advanced system settings
SNMP
The simple network management protocol (SNMP) allows you to monitor hardware on your network. See SNMP on page
528 for more information.

DHCP server
You can configure one or more DHCP servers on any FortiGate interface. See DHCP server on page 456 for more
information.
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VDOM
You can use virtual domains (VDOMs) to divide a FortiGate into multiple virtual devices that function independently. See
Virtual Domains on page 489 for more information.

High availability
You can configure multiple FortiGate devices, including private and public cloud VMs, in HA mode. See High Availability
on page 509 for more information.

Certificates
You can manage certificates on the FortiGate. See Certificates on page 555 for more information.

Operating modes
A FortiGate or VDOM (in multi-vdom mode) can operate in either NAT/Route mode or Transparent mode.

NAT/Route mode
The FortiGate or VDOM is installed as a gateway between two networks, such as a private network and the internet. This
allows the FortiGate to hide the IP addresses on the private network using NAT. NAT/Route mode can also be used
when several ISPs are used for redundant internet connections.
By default, new VDOMs are set to NAT/Route operation mode.
See Configure VDOM-A on page 496 for more information.

Transparent mode
The FortiGate or VDOM is installed between the internal network and the router. The FortiGate does not changes any IP
addresses, and only applies security scanning to traffic. When you add a FortiGate that is in transparent mode to a
network, it only needs to be provided with a management IP address.
Transparent mode is primarily used when increased network protection is needed without changing the network
configuration.
See Configure VDOM-A on page 506 for more information.

To change the operating mode of a FortiGate or VDOM:
config system settings
set opmode {nat | transparent}
end
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Administrators
By default, FortiGate has an administrator account with the username admin and no password. To prevent unauthorized
access to the FortiGate, this account must be protected with a password. Additional administrators can be added for
various functions, each with a unique username, password, and set of access privileges.
The following topics provide information about administrators:
l
l
l
l

Administrator profiles on page 469
Add a local administrator on page 471
Remote authentication for administrators on page 471
Password policy on page 473

Administrator profiles
Administrator profiles define what the administrator can do when logged into the FortiGate. When you set up an
administrator account, you also assign an administrator profile which dictates what the administrator sees. Depending
on the nature of the administrator’s work, access level or seniority, you can allow them to view and configure as much or
as little as is required.
By default, the FortiGate has an admin administrator account that uses the super_admin profile.

Super_admin profile
This profile has access to all components of FortiOS, including the ability to add and remove other system
administrators. For certain administrative functions, such as backing up and restoring the configuration, super_admin
access is required. To ensure that there is always a method to administer the FortiGate, the super_admin profile can't be
deleted or modified.

Lower level administrator profiles can't backup or restore the FortiOS configuration.

The super_admin profile is used by the default admin account. It is recommended that you add a password and rename
this account once you have set up your FortiGate. In order to rename the default account, a second admin account is
required.

Creating customized profiles
To create a profile in the GUI:
1. Go to System > Admin Profiles.
2. Select Create New.
3. Configure the following settings:
l Name.
l Access permissions.
l Override idle timeout.
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4. Select OK.

To create a profile in the CLI:
config system accprofile
edit "sample"
set secfabgrp read-write
set ftviewgrp read-write
set authgrp read-write
set sysgrp read-write
set netgrp read-write
set loggrp read-write
set fwgrp read-write
set vpngrp read-write
set utmgrp read-write
set wanoptgrp read-write
set wifi read-write
next
end

Edit profiles
To edit a profile in the GUI:
1. Go to System > Admin Profiles.
2. Choose the profile to be edited and select Edit.
3. Select OK to save any changes made.

To edit a profile in the CLI:
config system accprofile
edit "sample"
set secfabgrp read
next
end

Delete profiles
To delete a profile in the GUI:
1. Go to System > Admin Profiles.
2. Choose the profile to be deleted and select Delete.
3. Select OK.

To delete a profile in the CLI:
config system accprofile
delete "sample"
end
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Add a local administrator
By default, FortiGate has one super admin named admin. You can create more administrator accounts with different
privileges.

To create an administrator account in the GUI:
1. Go to System > Administrators.
2. Select Create New > Administrator.
3. Specify the Username.
Do not use the characters < > ( ) # " ' in the administrator username.
Using these characters in an administrator username might have a cross site scripting
(XSS) vulnerability.
4. Set Type to Local User.
5. Set the password and other fields.
6. Click OK.

To create an administrator account in the CLI:
config system admin
edit <admin_name>
set accprofile <profile_name>
set vdom <vdom_name>
set password <password for this admin>
next
end

Remote authentication for administrators
Administrators can use remote authentication, such as LDAP, to connect to the FortiGate.
Setting up remote authentication for administrators includes the following steps:
1. Configure the LDAP server on page 471
2. Add the LDAP server to a user group on page 472
3. Configure the administrator account on page 472

Configure the LDAP server
To configure the LDAP server in the GUI:
1.
2.
3.
4.
5.

Go to User & Device > LDAP Servers and select Create New.
Enter the server Name, Server IP address or Name.
Enter the Common Name Identifier and Distinguished Name.
Set the Bind Type to Regular and enter the Username and Password.
Click OK.
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To configure the LDAP server in the CLI:
config user ldap
edit <ldap_server_name>
set server <server_ip>
set cnid "cn"
set dn "dc=XYZ,dc=fortinet,dc=COM"
set type regular
set username "cn=Administrator,dc=XYA, dc=COM"
set password <password>
next
end

Add the LDAP server to a user group
After configuring the LDAP server, create a user group that includes that LDAP server.

To create a user group in the GUI:
1.
2.
3.
4.
5.

Go to User & Device > User Groups and select Create New.
Enter a Name for the group.
In the Remote groups section, select Create New.
Select the Remote Server from the dropdown list.
Click OK.

To create a user group in the CLI:
config user group
edit <Group_name>
set member "ldap_server_name"
next
end

Configure the administrator account
After configuring the LDAP server and adding it to a user group, create a new administrator. For this administrator,
instead of entering a password, use the new user group and the wildcard option for authentication.

To create an administrator in the GUI:
1.
2.
3.
4.
5.
6.

Go to System > Administrators.
Select Create New > Administrator.
Specify the Username.
Set Type to Match a user on a remote server group.
In Remote User Group, select the user group you created.
Select Wildcard.
The Wildcard option allows LDAP users to connect as this administrator.

7. Select an Administrator Profile.
8. Click OK.
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To create an administrator in the CLI:
config system admin
edit <admin_name>
set remote-auth enable
set accprofile super_admin
set wild card enable
set remote-group ldap
end

Other methods of administrator authentication
Administrator accounts can use different methods for authentication, including RADIUS, TACACS+, and PKI.

RADIUS authentication for administrators
To use a RADIUS server to authenticate administrators, you must:
l
l
l

Configure the FortiGate to access the RADIUS server.
Create the RADIUS user group.
Configure an administrator to authenticate with a RADIUS server.

TACACS+ authentication for administrators
To use a TACACS+ server to authenticate administrators, you must:
l
l
l

Configure the FortiGate to access the TACACS+ server.
Create a TACACS+ user group.
Configure an administrator to authenticate with a TACACS+ server.

PKI certificate authentication for administrators
To use PKI authentication for an administrator, you must:
l
l
l

Configure a PKI user.
Create a PKI user group.
Configure an administrator to authenticate with a PKI certificate.

Password policy
Brute force password software can launch more than just dictionary attacks. It can discover common passwords where a
letter is replaced by a number. For example, if p4ssw0rd is used as a password, it can be cracked.
Using secure passwords is vital for preventing unauthorized access to your FortiGate. When changing the password,
consider the following to ensure better security:
l

l
l
l

Do not use passwords that are obvious, such as the company name, administrator names, or other obvious words
or phrases.
Use numbers in place of letters, for example: passw0rd.
Administrator passwords can be up to 64 characters.
Include a mixture of numbers, symbols, and upper and lower case letters.
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l
l
l

l

Use multiple words together, or possibly even a sentence, for example: correcthorsebatterystaple.
Use a password generator.
Change the password regularly and always make the new password unique and not a variation of the existing
password. for example, do not change from password to password1.
Make note of the password and store it in a safe place away from the management computer, in case you forget it;
or ensure at least two people know the password in the event one person becomes unavailable. Alternatively, have
two different admin logins.

FortiGate allows you to create a password policy for administrators and IPsec pre-shared keys. With this policy, you can
enforce regular changes and specific criteria for a password policy, including:
l
l
l
l
l
l

Minimum length between 8 and 64 characters.
If the password must contain uppercase (A, B, C) and/or lowercase (a, b, c) characters.
If the password must contain numbers (1, 2, 3).
If the password must contain special or non-alphanumeric characters (!, @, #, $, %, ^, &, *, (, and )).
Where the password applies (admin or IPsec or both).
The duration of the password before a new one must be specified.

If you add a password policy or change the requirements on an existing policy, the next time that administrator logs into
the FortiGate, the administrator is prompted to update the password to meet the new requirements before proceeding to
log in.
For information about setting passwords, see Default administrator password on page 481.

To create a system password policy the GUI:
1.
2.
3.
4.

Go to System > Settings.
In the Password Policy section, change the Password scope to Admin, IPsec, or Both.
Configure the password policy options.
Click Apply.

To create a system password policy the CLI:
config system password-policy
set status {enable | disable}
set apply-to {admin-password | ipsec-preshared-key}
set minimum-length <8-128>
set min-lower-case-letter <0-128>
set min-upper-case-letter <0-128>
set min-non-alphanumeric <0-128>
set min-number <0-128>
set change-4-characters {enable | disable}
set expire-status {enable | disable}
set expire-day <1-999>
set reuse-password {enable | disable}
end
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Firmware
Fortinet periodically updates the FortiGate firmware to include new features and resolve important issues. After you have
registered your FortiGate unit, firmware updates can be downloaded from the Fortinet Customer Service & Support
website.

Always back up the current configuration before installing new firmware. See Configuration
backups on page 59.

Before you install any new firmware, follow the below steps:
1. Review the Release Notes for a new firmware release.
2. Review the Supported Upgrade Paths.
3. Download a copy of the currently installed firmware, in case you need to revert to it. See Downloading a firmware
image on page 475 and Downgrading to a previous firmware version on page 478 for details.
4. Have a plan in place in case there is a critical failure, such as the FortiGate not coming back online after the update.
This could include having console access to the device (Connecting to the CLI on page 23), ensuring that you TFTP
server is working (Installing firmware from system reboot on page 479), and preparing a USB drive (Restoring from
a USB drive on page 480).
5. Backup the current configuration, including local certificates. See Configuration backups on page 59 for details.
6. Test the new firmware until you are satisfied that it applies to your configuration. See Testing a firmware version on
page 476 and Controlled upgrade on page 480 for details.
Installing new firmware without reviewing release notes or testing the firmware may result in changes to settings and
unexpected issues.

Only FortiGate admin users and administrators whose access profiles contain system read
and write privileges can change the FortiGate firmware.

Downloading a firmware image
Firmware images for all FortiGate units are available on the Fortinet Customer Service & Support website.

To download firmware:
1. Log into the support site with your user name and password.
2. Go to Download > Firmware Images.
A list of Release Notes is shown. If you have not already done so, download and review the Release Notes for the
firmware version that you are upgrading your FortiGate unit to.
3. Select the Download tab.
4. Navigate to the folder for the firmware version that you are upgrading to.
5. Find your device model from the list. FortiWiFi devices have file names that start with FWF.
6. Click HTTPS in the far right column to download the firmware image to your computer.
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Firmware can also be downloaded using FTP, but as FTP is not an encrypted file transferring
protocol, HTTPS downloading is recommended.

Testing a firmware version
The integrity of firmware images downloaded from Fortinet's support portal can be verified using a file checksum. A file
checksum that does not match the expected value indicates a corrupt file. The corruption could be caused by errors in
transfer or by file modification. A list of expected checksum values for each build of released code is available on
Fortinet’s support portal.
Image integrity is also verified when the FortiGate is booting up. This integrity check is done through a cyclic redundancy
check (CRC). If the CRC fails, the FortiGate unit will encounter an error during the boot process.
Firmware images are signed and the signature is attached to the code as it is built. When upgrading an image, the
running OS will generate a signature and compare it with the signature attached to the image. If the signatures do not
match, the new OS will not load.

Testing before installation
FortiOS lets you test a new firmware image by installing the firmware image from a system reboot and saving it to system
memory. After completing this procedure, the FortiGate unit operates using the new firmware image with the current
configuration. The new firmware image is not permanently installed. The next time the FortiGate unit restarts, it operates
with the originally installed firmware image using the current configuration. If the new firmware image operates
successfully, you can install it permanently using the procedure explained in Upgrading the firmware.
For this procedure, you must install a TFTP server that you can connect to from the FortiGate internal interface. The
TFTP server should be on the same subnet as the internal interface.

To test the new firmware version:
1.
2.
3.
4.
5.

Connect to the CLI using an RJ-45 to DB-9 or null modem cable.
Ensure that the TFTP server is running.
Copy the new firmware image file to the root directory on the TFTP server.
Ensure that the FortiGate unit can connect to the TFTP server using the execute ping command.
Restart the FortiGate unit: execute reboot. The following message is shown:
This operation will reboot the system!
Do you want to continue? (y/n)

6. Type y. As the FortiGate unit starts, a series of system startup messages appears.
7. When the following messages appears:
Press any key to display configuration menu..........

Immediately press any key to interrupt the system startup.
You have only three seconds to press any key. If you do not press a key during this time, the FortiGate will reboot,
and you will have to log in and repeat the execute reboot command.
If you successfully interrupt the startup process, the following messages appears:
[G]:
[F]:
[B]:
[C]:

Get firmware image from TFTP server.
Format boot device.
Boot with backup firmware and set as default
Configuration and information
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[Q]: Quit menu and continue to boot with default firmware.
[H]: Display this list of options.
Enter G, F, Q, or H:

8. Type G to get the new firmware image from the TFTP server. The following message appears: Enter TFTP
server address [192.168.1.168]:
9. Type the address of the TFTP server, then press Enter. The following message appears: Enter Local Address
[192.168.1.188]:
10. Type the IP address of the FortiGate unit to connect to the TFTP server.
The IP address must be on the same network as the TFTP server.
Make sure that you do not enter the IP address of another device on this network.
The following message appears:
Enter File Name [image.out]:

11. Enter the firmware image file name then press Enter. The TFTP server uploads the firmware image file to the
FortiGate unit and the following message appears:
Save as Default firmware/Backup firmware/Run image without saving: [D/B/R]

12. Type R. The FortiGate image is installed to system memory and the FortiGate unit starts running the new firmware
image, but with its current configuration.
Test the new firmware image as required. When done testing, reboot the FortiGate unit, and the it will resume using the
firmware that was running before you installed the test firmware.

Upgrading the firmware
Installing a new firmware image replaces the current antivirus and attack definitions, along with the definitions included
with the firmware release that is being installing. After you install new firmware, make sure that the antivirus and attack
definitions are up to date.

Back up your configuration before making any firmware changes.

To upgrade the firmware in the GUI:
1. Log into the FortiGate GUI as the admin administrative user.
2. Go to System > Firmware.
3. Under Upload Firmware, click Browse and locate the previously downloaded firmware image file (see Downloading
a firmware image on page 475).
4. Click Backup config and upgrade.
The FortiGate unit backs up the current configuration to the management computer, uploads the firmware image
file, upgrades to the new firmware version, and restarts. This process takes a few minutes.

To upgrade the firmware in the CLI:
1. Make sure that the TFTP server is running.
2. Copy the new firmware image file to the root directory of the TFTP server.
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3. Log into the CLI.
4. Ping the TFTP server to ensure that the FortiGate can connect to it:
execute ping <tftp_ipv4>

5. Enter the following command to copy the firmware image from the TFTP server to the FortiGate unit:
execute restore image tftp <filename> <tftp_ipv4>

The FortiGate unit responds with the message:
This operation will replace the current firmware version!
Do you want to continue? (y/n)

6. Type y. The FortiGate unit uploads the firmware image file, upgrades to the new firmware version, and restarts. This
process takes a few minutes.
7. Reconnect to the CLI.
8. Update the antivirus and attack definitions:
execute update-now

Downgrading to a previous firmware version

Downgrading the firmware is not recommended.

This procedure downgrades the FortiGate to a previous firmware version. The backup configuration might not be able to
be restored after downgrading.

To downgrade to a previous firmware version in the GUI:
1. Log into the FortiGate GUI as the admin administrative user.
2. Go to System > Firmware.
3. Under Upload Firmware, click Browse and locate the previously downloaded firmware image file (see Downloading
a firmware image on page 475).
4. Click Confirm version downgrade.
5. Click Backup config and downgrade.
The FortiGate unit backs up the current configuration to the management computer, uploads the firmware image
file, upgrades to the new firmware version, and restarts. This process takes a few minutes.

To downgrade to a previous firmware version in the CLI:
1.
2.
3.
4.

Make sure that the TFTP server is running.
Copy the new firmware image file to the root directory of the TFTP server.
Log into the CLI.
Ping the TFTP server to ensure that the FortiGate can connect to it:
execute ping <tftp_ipv4>

5. Enter the following command to copy the firmware image from the TFTP server to the FortiGate unit:
execute restore image tftp <filename> <tftp_ipv4>

The FortiGate unit responds with the message:
This operation will replace the current firmware version!
Do you want to continue? (y/n)

6. Type y. The FortiGate unit uploads the firmware image file, then a message similar to the following is shown:
Get image from tftp server OK.
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Check image OK.
This operation will downgrade the current firmware version!
Do you want to continue? (y/n)

7. Type y. The FortiGate unit downgrades to the old firmware version and restarts. This process takes a few minutes.
8. Reconnect to the CLI.
9. Update the antivirus and attack definitions:
execute update-now

Installing firmware from system reboot
In the event that the firmware upgrade does not load properly and the FortiGate unit will not boot, or continuously
reboots, it is best to perform a fresh install of the firmware from a reboot using the CLI.
This procedure installs a firmware image and resets the FortiGate unit to factory default settings. You can use this
procedure to upgrade to a new firmware version, revert to an older firmware version, or re-install the current firmware.
To use this procedure, you must connect to the CLI using the FortiGate console port and a RJ-45 to DB-9, or null modem
cable. You must also install a TFTP server that you can connect to from the FortiGate internal interface. The TFTP
server should be on the same subnet as the internal interface.
Before beginning this procedure, ensure that you backup the FortiGate unit configuration. See Configuration backups on
page 59 for details. If you are reverting to a previous FortiOS version, you might not be able to restore the previous
configuration from the backup configuration file.
Installing firmware replaces your current antivirus and attack definitions, along with the definitions included with the
firmware release you are installing. After you install new firmware, make sure that antivirus and attack definitions are up
to date.

To install firmware from a system reboot:
1.
2.
3.
4.

Connect to the CLI using the RJ-45 to DB-9 or null modem cable.
Ensure that the TFTP server is running.
Copy the new firmware image file to the root directory of the TFTP server.
Ensure that the FortiGate unit can connect to the TFTP server using the execute ping command.

5. Restart the FortiGate unit: execute reboot. The following message is shown:
This operation will reboot the system!
Do you want to continue? (y/n)

6. Type y. As the FortiGate unit starts, a series of system startup messages appears.
7. When the following messages appears:
Press any key to display configuration menu..........

Immediately press any key to interrupt the system startup.
You have only three seconds to press any key. If you do not press a key during this time, the FortiGate will reboot,
and you will have to log in and repeat the execute reboot command.
If you successfully interrupt the startup process, the following messages appears:
[G]: Get firmware image from TFTP server.
[F]: Format boot device.
[B]: Boot with backup firmware and set as default
[C]: Configuration and information
[Q]: Quit menu and continue to boot with default firmware.
[H]: Display this list of options.
Enter G, F, Q, or H:
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8. Type G to get the new firmware image from the TFTP server. The following message appears: Enter TFTP
server address [192.168.1.168]:
9. Type the address of the TFTP server, then press Enter. The following message appears: Enter Local Address
[192.168.1.188]:
10. Type the IP address of the FortiGate unit to connect to the TFTP server.
The IP address must be on the same network as the TFTP server.
Make sure that you do not enter the IP address of another device on this network.
The following message appears:
Enter File Name [image.out]:

11. Enter the firmware image file name then press Enter. The TFTP server uploads the firmware image file to the
FortiGate unit and the following message appears:
Save as Default firmware/Backup firmware/Run image without saving: [D/B/R]

12. Type D. The FortiGate unit installs the new firmware image and restarts. The installation might take a few minutes to
complete.

Restoring from a USB drive
The FortiGate firmware can be restored from a USB drive.

To restore the firmware from a USB drive:
1.
2.
3.
4.

Copy the firmware file to the root directory on the USB drive.
Connect the USB drive to the USB port of the FortiGate device.
Connect to the FortiGate CLI using the RJ-45 to DB-9 or null modem cable.
Enter the following command:
execute restore image usb <filename>

The FortiGate unit responds with the following message:
This operation will replace the current firmware version! Do you want to continue?
(y/n)

5. Type y. The FortiGate unit restores the firmware and restarts. This process takes a few minutes.
6. Update the antivirus and attack definitions:
execute update-now

Controlled upgrade
Using a controlled upgrade, you can upload a new version of the FortiOS firmware to a separate partition in the FortiGate
memory for later upgrade. The FortiGate unit can be configured so that when it is rebooted, it will automatically load the
new firmware. Using this option, you can stage multiple FortiGate units to upgrade simultaneously using FortiManager or
a script.

To load the firmware for later installation:
execute restore secondary-image {ftp | tftp | usb} <filename_str>
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To set the FortiGate unit so that when it reboots, the new firmware is loaded:
execute set-next-reboot {primary | secondary}

where {primary | secondary} is the partition with the preloaded firmware.

Settings
The default administrator password should be configured immediately after the FortiGate is installed, see Default
administrator password on page 481.
After that, there are several system settings that should also be configured in System > Settings:
l
l
l
l
l
l
l

Changing the host name on page 482
Setting the system time on page 482
Configuring ports on page 486
Setting the idle timeout time on page 487
Setting the password policy on page 487
Changing the view settings on page 487
Setting the administrator password retries and lockout time on page 488

Default administrator password
By default, your FortiGate has an administrator account set up with the username admin and no password. In order to
prevent unauthorized access to the FortiGate, it is highly recommended that you add a password to this account.
In FortiOS 6.2.1 and later, adding a password to the admin administrator is mandatory. You
will be prompted to configured it the first time you log in to the FortiGate using that account,
after a factory reset, and after a new image installation.

To change the default password in the GUI:
1.
2.
3.
4.
5.
6.

Go to System > Administrators.
Edit the admin account.
Click Change Password.
If applicable, enter the current password in the Old Password field.
Enter a password in the New Password field, then enter it again in the Confirm Password field.
Click OK.

To change the default password in the CLI:
config system admin
edit admin
set password <password>
next
end
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It is also recommended that you change the user name of this account; however, since you
cannot change the user name of an account that is currently in use, a second administrator
account must be created in order to do this.

Changing the host name
The FortiGate host name is shown in the Hostname field in the System Information widget on a dashboard, as the
command prompt in the CLI, as the SNMP system name, as the device name on FortiGate Cloud, and other places. If
the FortiGate is in an HA cluster, use a unique host name to distinguish it from the other devices in the cluster.
An administrator requires System > Configuration read/write access to edit the host name. See Administrator profiles on
page 469 for details.

To change the host name in the GUI:
1. Go to System > Settings.
2. In the Host name field, enter a new name.
3. Click Apply.

To change the host name in the CLI:
config system global
set hostname <hostname>
end

Setting the system time
You can either manually set the FortiOS system time, or configure the device to automatically keep its system time
correct by synchronizing with a Network Time Protocol (NTP) server.
Daylight savings time is enabled by default, and can only be configured in the CLI.

For many features to work, including scheduling, logging, and SSL-dependent features, the
FortiOS system time must be accurate.

To configure the date and time in the GUI:
1. Go to System > Settings.
2. In the System Time section, configure the following settings to either manually set the time or use an NTP server:
Time Zone

Select a time zone from the list. This should be the time zone that the
FortiGate is in.

Set Time

Select to either Synchronize with an NTP Server, or use Manual settings.
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Synchronize with
an NTP Server

To use an NTP server other than FortiGuard, the CLI must be used.

Manual settings

Manually enter the Date, Hour (in 24-hour format), Minute, and Second in their
fields.

Setup device as local NTP
server

In the Sync interval field, enter how often, in minutes, that the device
synchronizes its time with the NTP server.

Enable to configure the FortiGate as a local NTP server.
In the Listen on Interfaces field, set the interface or interfaces that the
FortiGate will listen for NTP requests on.

3. Click Apply.

To configure the date and time in the CLI:
1. Configure the timezone and daylight savings time:
config system global
set timezone <integer>
set dst {enable | disable}
end

2. Either manually configure the date and time, or configure an NTP server:
Manual:
execute date <yyyy-mm-dd>
execute time <hh:mm:ss>

NTP server:
config system ntp
set ntpsync enable
set type {fortiguard | custom}
set syncinterval <integer>
set source-ip <ip_address>
set source-ip6 <ip6_address>
set server-mode {enable | disable}
set interface <interface>
set authentication {enable | disable}
set key-type {MD5 | SHA1}
set key <password>
set key-id <integer>
config ntpserver
edit <server_id>
set server <ip_address or hostname>
set ntpv3 {enable | disable}
set authentication {enable | disable}
set key <password>
set key-id <integer>
next
end
end
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SHA-1 authentication support (for NTPv4)
SHA-1 authentication support allows the NTP client to verify that severs are known and trusted and not intruders
masquerading (accidentally or intentionally) as legitimate servers. In cryptography, SHA-1 is a cryptographic hash
algorithmic function.

SHA-1 authentication support is only available for NTP clients, not NTP servers.

To configure authentication on a FortiGate NTP client:
config system ntp
set ntpsync enable
set type custom
set syncinterval 1
config ntpserver
edit "883502"
set server "10.1.100.11"
set authentication enable
set key
ENCi9NmcqsV3xBJvOkgIL3lFxA8mnNs2XKfB7spOQoUw4cm8FOOP0nrCbqx6rJ+om95+hVUHpaVZmepdd4KznPlAHNiu
liPgPOk
set key-id 1
next
end
end

Command

Description

authentication <enable |
disable>

Enable/disable MD5/SHA1 authentication (default = disable).

key <passwd>

Key for MD5/SHA1 authentication. Enter a password value.

key-id <integer>

Key ID for authentication. Enter an integer value from 0 to 4294967295.

To confirm that NTP authentication is set up correctly:
# diagnose sys ntp status
synchronized: yes, ntpsync: enabled, server-mode: disabled
ipv4 server(10.1.100.11) 10.1.100.11 -- reachable(0xff) S:4 T:6 selected
server-version=4, stratum=3

If NTP authentication is set up correctly, the server version is equal to 4.

PTPv2 (slave mode)
Precision time protocol (PTP) is used to synchronize network clocks. It is best suited to situations where time accuracy is
of the utmost importance, as it supports accuracy in the sub-microsecond range. Conversely, NTP accuracy is in the
range of milliseconds or tens of milliseconds.
The following CLI commands are available:
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config system ptp
set status {enable | disable}
set mode {multicast | hybrid}
set delay-mechanism {E2E | P2P}
set request-interval <integer>
set interface <interface>
end

Command

Description

status {enable | disable}

Enable or disable the FortiGate system time by synchronizing with a PTP server
(default = disable).

mode {multicast | hybrid}

Use multicast or hybrid transmission (default = multicast).

delay-mechanism {E2E | P2P}

Use end-to-end (E2E) or peer-to-peer (P2P) delay detection (default = E2E).

request-interval <integer>

The logarithmic mean interval between the delay request messages sent by the
client to the server in seconds (default = 1).

interface <interface>

The interface that the PTP client will reply through.

Sample configuration
This example uses the following topology:

To configure a FortiGate to act as a PTP client that synchronizes itself with a Linux PTP server:
1. Enable debug messages:
diagnose debug application ptpd -1

This command will provide details to debug the PTP communication with the server.
2. Check the system date:
execute date
current date is: 2019-01-01

3. Configure PTP in global mode:
config system ptp
set status enable
set interface wan2
end

The following debug message appears:
(global) # [notice]PTPDv2 started successfully on wan2 using "slaveonly" preset (PID
5958)
[info]TimingService.PTP0: PTP service init
[info]Observed_drift loaded from kernel: 0 ppb
[notice]Now in state: PTP_LISTENING
[warning]TimingService: No TimingService available for clock sync
[info]New best master selected: 000c29fffe236b0c(unknown)/1

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

485

System
[notice]Now in state: PTP_SLAVE, Best master: 000c29fffe236b0c(unknown)/1
(IPv4:172.16.200.55)
[notice]Received first Sync from Master
[critical]Offset above 1 second. Clock will step.
[warning]Change time from Tue Jan 1 00:00:28 2019 to Mon Jan 14 15:11:10 2019.
[notice]Now in state: PTP_LISTENING
[info]New best master selected: 000c29fffe236b0c(unknown)/1
[notice]Now in state: PTP_SLAVE, Best master: 000c29fffe236b0c(unknown)/1
(IPv4:172.16.200.55)
[notice]Received first Sync from Master
[info]TimingService.PTP0: now available
[notice]Received first Delay Response from Master
[notice]Received new Delay Request interval 0 from Master (was: 1)
[notice]TimingService.PTP0: elected best TimingService
[info]TimingService.PTP0: acquired clock control

4. Check the system date again after synchronization with the PTP server:
execute date
current date is: 2019-01-14

Configuring ports
To improve security, the default ports for administrative connections to the FortiGate can be changed. Port numbers
must be unique. If a conflict exists with a particular port, a warning message is shown.
When connecting to the FortiGate after a port has been changed, the port number be included, for example:
https://192.168.1.99:100.

To configure the ports in the GUI:
1.
2.
3.
4.

Go to System > Settings.
In the Administration Settings section, set the HTTP, HTTPS, SSH, and Telnet ports.
Enable Redirect to HTTPS to prevent HTTP from being used by administrators.
Click Apply.

To configure the ports in the CLI:
config system global
set admin-port <port>
set admin-sport <port>
set admin-https-redirect {enable | disable}
set admin-ssh-port <port>
set admin-telnet-port <port>
end

Custom default service port range
The default service port range can be customized using the following CLI command:
config system global
set default-service-source-port <port range>
end
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Where <port range> is the new default service port range, that can have a minimum value of 0 and a maximum value
up to 65535. The default value is 1 to 65535.

This change effects the TCP/UDP protocol.

Setting the idle timeout time
The idle timeout period is the amount of time that an administrator will stay logged in to the GUI without any activity. This
is to prevent someone from accessing the FortiGate if the management PC is left unattended. By default, it is set to five
minutes.

A setting of higher than 15 minutes will have a negative effect on a security rating score. See
Security rating on page 95 for more information.

To change the idle timeout in the GUI:
1. Go to System > Settings.
2. In the Administration Settings section, set the Idle timeout to up to 480 minutes.
3. Click Apply.

To change the idle timeout in the CLI:
config system global
set admintimeout <integer>
end

Setting the password policy
A password policy can be created for administrators and IPsec pre-shared keys. See Password policy on page 473 for
information.

Changing the view settings
The view settings change the look and language of the FortiOS GUI.
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To change the view settings in the GUI:
1. Go to System > Settings.
2. In the View Settings section, configure the following settings:
Language

Set the GUI language: English, French, Spanish, Portuguese, Japanese,
Traditional Chinese, Simplifies Chinese, Korean.

Lines per page

Set the number of lines per page, from 20 to 100.

Theme

Set the theme color: Green, Red, Blue, Melongene, or Mariner.

Date/Time Display

Set the date and time to display using the FortiGate's or the browser's
timezone.

NGFW Mode

Set the NGFW mode to either Profile-based (default) or Policy-based.
If Policy-based is selected, the SSL/SSH Inspection profile must be selected.

3. Click Apply.

To change the view settings in the CLI:
config system global
set language {english | french | spanish | portuguese | japanese | trach | simch |
korean}
set gui-lines-per-page <integer>
set gui-theme {green | red | blue | melongene | mariner}
set gui-date-time-source {system | browser}
end
config system settings
set ngfw-mode {profile-based | policy-based}
set ssl-ssh-profile {certificate-inspection | custom-deep-inspection | deep-inspection |
no-inspection}
end

Setting the administrator password retries and lockout time
By default, the number password retry attempts is set to three, allowing the administrator a maximum of three attempts
at logging in to their account before they are locked out for a set amount of time (by default, 60 seconds).
The number of attempts and the default wait time before the administrator can try to enter a password again can be
configured using the CLI.
A maximum of ten retry attempts can be configured, and the lockout period can be 1 to 2147483647 seconds (over 68
years). The higher the retry attempts, the higher the risk that someone might be able to guess the password.

To configure the lockout options:
config system global
set admin-lockout-threshold <failed_attempts>
set admin-lockout-duration <seconds>
end
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Example:
To set the number of retry attempts to 1, and the lockout time to 5 minutes, enter the following commands:
config system global
set admin-lockout-threshold 1
set admin-lockout-duration 300
end

If the time span between the first failed log in attempt and the lockout threshold failed attempt
is less than lockout time, the lockout will be triggered.

Virtual Domains
Virtual Domains (VDOMs) are used to divide a FortiGate into two or more virtual units that function independently.
VDOMs can provide separate security policies and, in NAT mode, completely separate configurations for routing and
VPN services for each connected network.
There are two VDOM modes:
l

l

Split-task VDOM mode: One VDOM is used only for management, and the other is used to manage traffic. See
Split-task VDOM mode on page 490.
Multi VDOM mode: Multiple VDOMs can be created and managed as independent units. See Multi VDOM mode on
page 493.

By default, most FortiGate units support 10 VDOMs, and many FortiGate models support purchasing a license key to
increase the maximum number.
Global settings are configured outside of a VDOM. They effect the entire FortiGate, and include settings such as
interfaces, firmware, DNS, some logging and sandboxing options, and others. Global settings should only be changed
by top level administrators.

Switching VDOM modes
Current VDOM mode

New VDOM mode

Rule

No VDOM

Split-task VDOM

Allowed

Split-task VDOM

No VDOM

Allowed

No VDOM

Multi VDOM

Allowed only if CSF is disabled

Multi VDOM

No VDOM

Allowed

Split-task VDOM

Multi VDOM

Allowed only if CSF is disabled

Multi VDOM

Split-task VDOM

Not Allowed. User must first switch to No
VDOM
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Split-task VDOM mode
In split-task VDOM mode, the FortiGate has two VDOMs: the management VDOM (root) and the traffic VDOM (FGtraffic).

The management VDOM is used to manage the FortiGate, and cannot be used to process traffic.
The following GUI sections are available when in the management VDOM:
l
l
l
l
l
l
l
l
l
l

The Status dashboard
Security Fabric topology and settings (read-only, except for HTTP Service settings)
Interface and static route configuration
FortiClient configuration
Replacement messages
Advanced system settings
Certificates
System events
Log and email alert settings
Threat weight definitions

The traffic VDOM provides separate security policies, and is used to process all network traffic.
The following GUI sections are available when in the traffic VDOM:
l
l

l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

The Status, Top Usage LAN/DMZ, and Security dashboards
Security Fabric topology, settings (read-only, except for HTTP Service settings), and Fabric Connectors
(SSO/Identity connectors only)
FortiView
Interface configuration
Packet capture
SD-WAN, SD-WAN Rules, and Performance SLA
Static and policy routes
RIP, OSPF, BGP, and Multicast
Replacement messages
Advanced system settings
Feature visibility
Tags
Certificates
Policies and objects
Security profiles
VPNs
User and device authentication
Wifi and switch controller
Logging
Monitoring
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Split-task VDOM mode is not available on all FortiGate models. The Fortinet Security Fabric supports split-task VDOM
mode.

Enable split-task VDOM mode
Split-task VDOM mode can be enabled in the GUI or CLI. Enabling it does not require a reboot, but does log you out of
the FortiGate.
When split-task VDOM mode is enabled, all current management configuration is assigned to
the root VDOM, and all non-management settings, such as firewall policies and security
profiles, are deleted.

On FortiGate 60 series models and lower, VDOMs can only be enabled using the CLI.

To enable split-task VDOM mode in the GUI:
1. On the FortiGate, go to System > Settings.
2. In the System Operation Settings section, enable Virtual Domains.

3. Select Split-Task VDOM for the VDOM mode.
4. Select a Dedicated Management Interface from the Interface list. This interface is used to access the management
VDOM, and cannot be used in firewall policies.
5. Click OK.

To enable split-task VDOM mode with the CLI:
config system global
set vdom-mode split-vdom
end
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Assign interfaces to a VDOM
An interface can only be assigned to one of the VDOMs. When split-task VDOM mode is enabled, all interfaces are
assigned to the root VDOM. To use an interface in a policy, it must first be assigned to the traffic VDOM.
An interface cannot be moved if it is referenced in an existing configuration.

In the GUI, the interface list Ref. column shows if the interface is referenced in an existing
configuration, and allows you to quickly access and edit those references.

To assign an interface to a VDOM in the GUI:
1. On the FortiGate, go to Global > Network > Interfaces.
2. Edit the interface that will be assigned to a VDOM.
3. Select the VDOM that the interface will be assigned to from the Virtual Domain list.

4. Click OK.

To assign an interface to a VDOM using the CLI:
config global
config system interface
edit <interface>
set vdom <VDOM_name>
next
end
end

Create per-VDOM administrators
Per-VDOM administrators can be created that can access only the management or traffic VDOM. These administrators
must use either the prof_admin administrator profile, or a custom profile.
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A per-VDOM administrator can only access the FortiGate through a network interface that is assigned to the VDOM that
they are assigned to. The interface must also be configured to allow management access. They can also connect to the
FortiGate using the console port.
To assign an administrator to multiple VDOMs, they must be created at the global level. When creating an administrator
at the VDOM level, the super_admin administrator profile cannot be used.

To create a per-VDOM administrator in the GUI:
1.
2.
3.
4.

On the FortiGate, connect to the management VDOM.
Go to Global > System > Administrators and click Create New > Administrator.
Fill in the required information, setting the Type as Local User.
In the Virtual Domains field, add the VDOM that the administrator will be assigned to, and if necessary, remove the
other VDOM from the list.

5. Click OK.

To create a per-VDOM administrator using the CLI:
config global
config system admin
edit <name>
set vdom <VDOM_name>
set password <password>
set accprofile <admin_profile>
...
next
end
end

Multi VDOM mode
In multi VDOM mode, the FortiGate can have multiple VDOMs that function as independent units. One VDOM is used to
manage global settings.
Multi VDOM mode isn't available on all FortiGate models. The Fortinet Security Fabric does not support multi VDOM
mode.
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There are three main configuration types in multi VDOM mode:

Independent VDOMs:

Multiple, completely separate VDOMs are created. Any VDOM can be the management VDOM, as long as it has Internet
access. There are no inter-VDOM links, and each VDOM is independently managed.

Management VDOM:

A management VDOM is located between the other VDOMs and the Internet, and the other VDOMs connect to the
management VDOM with inter-VDOM links. The management VDOM has complete control over Internet access,
including the types of traffic that are allowed in both directions. This can improve security, as there is only one point of
ingress and egress.
There is no communication between the other VDOMs.

Meshed VDOMs:

VDOMs can communicate with inter-VDOM links. In full-mesh configurations, all the VDOMs are interconnected. In
partial-mesh configurations, only some of the VDOMs are interconnected.
In this configuration, proper security must be achieved by using firewall policies and ensuring secure account access for
administrators and users.
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Multi VDOM configuration examples
The following examples show how to configure per-VDOM settings, such as operation mode, routing, and security
policies, in a network that includes the following VDOMs:
l
l
l

VDOM-A: allows the internal network to access the Internet.
VDOM-B: allows external connections to an FTP server.
root: the management VDOM.

You can use VDOMs in either NAT or transparent mode on the same FortiGate. By default, VDOMs operate in NAT
mode.
For both examples, multi VDOM mode must be enabled, and VDOM-A and VDOM-B must be created.

Enable multi VDOM mode
Multi VDOM mode can be enabled in the GUI or CLI. Enabling it does not require a reboot, but does log you out of the
device. The current configuration is assigned to the root VDOM.

On FortiGate 60 series models and lower, VDOMs can only be enabled using the CLI.

To enable multi VDOM mode in the GUI:
1.
2.
3.
4.

On the FortiGate, go to System > Settings.
In the System Operation Settings section, enable Virtual Domains.
Select Multi VDOM for the VDOM mode.
Click OK.

To enable multi VDOM mode with the CLI:
config system global
set vdom-mode multi-vdom
end
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Create the VDOMs
To create the VDOMs in the GUI:
1. In the Global VDOM, go to System > VDOM, and click Create New. The New Virtual Domain page opens.

2.
3.
4.
5.
6.

In the Virtual Domain field, enter VDOM-A.
If required, set the NGFW Mode. If the NGFW Mode is Policy-based, select an SSL/SSH Inspection from the list.
Optionally, enter a comment.
Click OK to create the VDOM.
Repeat the above steps for VDOM-B.

To create the VDOMs with the CLI:
config vdom
edit <VDOM-A>
next
edit <VDOM-B>
next
end
end

NAT mode
In this example, both VDOM-A and VDOM-B use NAT mode. A VDOM link is created that allows users on the internal
network to access the FTP server.
This configuration requires the following steps:
1. Configure VDOM-A on page 496
2. Configure VDOM-B on page 498
3. Configure the VDOM link on page 501

Configure VDOM-A
VDOM-A allows connections from devices on the internal network to the Internet. WAN 1 and port 1 are assigned to this
VDOM.
The per-VDOM configuration for VDOM-A includes the following:
l
l
l

A firewall address for the internal network
A static route to the ISP gateway
A security policy allowing the internal network to access the Internet

All procedures in this section require you to connect to VDOM-A, either using a global or per-VDOM administrator
account.
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To add the firewall addresses in the GUI:
1. Go to Policy & Objects > Addresses and create a new address.
2. Enter the following information:
Name

internal-network

Type

Subnet

Subnet / IP Range

192.168.10.0/255.255.255.0

Interface

port1

Show in Address List

enabled

To add the firewall addresses with the CLI:
config vdom
edit VDOM-A
config firewall address
edit internal-network
set associated-interface port1
set subnet 192.168.10.0 255.255.255.0
next
end
next
end

To add a default route in the GUI:
1. Go to Network > Static Routes and create a new route.
2. Enter the following information:
Destination

Subnet

IP address

0.0.0.0/0.0.0.0

Gateway

172.20.201.7

Interface

wan1

Distance

10

To add a default route with the CLI:
config vdom
edit VDOM-A
config router static
edit 0
set gateway 172.20.201.7
set device wan1
next
end
next
end
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To add the security policy in the GUI:
1. Connect to VDOM-A.
2. Go to Policy & Objects > IPv4 Policy and create a new policy.
3. Enter the following information:
Name

VDOM-A-Internet

Incoming Interface

port1

Outgoing Interface

wan1

Source Address

internal-network

Destination Address

all

Schedule

always

Service

ALL

Action

ACCEPT

NAT

enabled

To add the security policy with the CLI:
config vdom
edit VDOM-A
config firewall policy
edit 0
set name VDOM-A-Internet
set srcintf port1
set dstintf wan1
set srcaddr internal-network
set dstaddr all
set action accept
set schedule always
set service ALL
set nat enable
next
end
next
end

Configure VDOM-B
VDOM-B allows external connections to reach an internal FTP server. WAN 2 and port 2 are assigned to this VDOM.
The per-VDOM configuration for VDOM-B includes the following:
l
l
l
l

A firewall address for the FTP server
A virtual IP address for the FTP server
A static route to the ISP gateway
A security policy allowing external traffic to reach the FTP server
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All procedures in this section require you to connect to VDOM-B, either using a global or per-VDOM administrator
account.

To add the firewall addresses in the GUI:
1. Go to Policy & Objects > Addresses and create a new address.
2. Enter the following information:
Address Name

FTP-server

Type

Subnet

Subnet / IP Range

192.168.20.10/32

Interface

port2

Show in Address List

enabled

To add the firewall addresses with the CLI:
config vdom
edit VDOM-B
config firewall address
edit FTP-server
set associated-interface port2
set subnet 192.168.20.10 255.255.255.255
next
end
next
end

To add the virtual IP address in the GUI:
1. Go to Policy & Objects > Virtual IPs and create a new virtual IP address.
2. Enter the following information:
Name

FTP-server-VIP

Interface

wan2

External IP Address/Range

172.25.177.42

Internal IP Address/Range

192.168.20.10

To add the virtual IP address with the CLI:
config firewall vip
edit FTP-server-VIP
set extip 172.25.177.42
set extintf wan2
set mappedip 192.168.20.10
next
end
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To add a default route in the GUI:
1. Go to Network > Static Routes and create a new route.
2. Enter the following information:
Destination

Subnet

IP address

0.0.0.0/0.0.0.0

Gateway

172.20.10.10

Interface

wan2

Distance

10

To add a default route with the CLI:
config vdom
edit VDOM-B
config router static
edit 0
set device wan2
set gateway 172.20.10.10
next
end
next
end

To add the security policy in the GUI:
1. Go to Policy & Objects > IPv4 Policy and create a new policy.
2. Enter the following information:
Name

Access-server

Incoming Interface

wan2

Outgoing Interface

port2

Source Address

all

Destination Address

FTP-server-VIP

Schedule

always

Service

FTP

Action

ACCEPT

NAT

enabled

To add the security policy with the CLI:
config vdom
edit VDOM-B
config firewall policy
edit 0
set name Access-server
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set
set
set
set
set
set
set
set
next
end
next
end

srcintf wan2
dstintf port2
srcaddr all
dstaddr FTP-server-VIP
action accept
schedule always
service FTP
nat enable

Configure the VDOM link
The VDOM link allows connections from VDOM-A to VDOM-B. This allows users on the internal network to access the
FTP server through the FortiGate.
The configuration for the VDOM link includes the following:
l
l
l
l

The VDOM link interface
Firewall addresses for the FTP server on VDOM-A and for the internal network on VDOM-B
Static routes for the FTP server on VDOM-A and for the internal network on VDOM-B
Policies allowing traffic using the VDOM link

All procedures in this section require you to connect to the global VDOM using a global administrator account.

To add the VDOM link in the GUI:
1. Connect to root.
2. Go to Global > Network > Interfaces and select Create New > VDOM link.
3. Enter the following information:
Name

VDOM-link

Interface 0
Virtual Domain

VDOM-A

IP/Netmask

0.0.0.0/0.0.0.0

Interface 1
Virtual Domain

VDOM-B

IP/Netmask

0.0.0.0/0.0.0.0

To add the VDOM link with the CLI:
config global
config system vdom-link
edit vlink
end
config system interface
edit VDOM-link0
set vdom VDOM-A
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set ip 0.0.0.0 0.0.0.0
next
edit VDOM-link1
set vdom VDOM-B
set ip 0.0.0.0 0.0.0.0
next
end
end

To add the firewall address on VDOM-A in the GUI:
1. Connect to VDOM-A.
2. Go to Policy & Objects > Addresses and create a new address.
3. Enter the following information:
Address Name

FTP-server

Type

Subnet

Subnet / IP Range

192.168.20.10/32

Interface

VDOM-link0

Show in Address List

enabled

Static Route Configuration

enabled

To add the firewall addresses on VDOM-A with the CLI:
config vdom
edit VDOM-B
config firewall address
edit FTP-server
set associated-interface VDOM-link0
set allow-routing enable
set subnet 192.168.20.10 255.255.255.255
next
end
next
end

To add the static route on VDOM-A in the GUI:
1. Connect to VDOM-A.
2. Go to Network > Static Routes and create a new route.
3. Enter the following information:
Destination

Named Address

Named Address

FTP-server

Gateway

0.0.0.0

Interface

VDOM-link0
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To add the static route on VDOM-A with the CLI:
config vdom
edit VDOM-A
config router static
edit 0
set device VDOM-link0
set dstaddr FTP-server
next
end
next
end

To add the security policy on VDOM-A in the GUI:
1. Connect to VDOM-A.
2. Go to Policy & Objects > IPv4 Policy and create a new policy.
3. Enter the following information:
Name

Access-FTP-server

Incoming Interface

port1

Outgoing Interface

VDOM-link0

Source

internal-network

Destination

FTP-server

Schedule

always

Service

FTP

Action

ACCEPT

NAT

disabled

To add the security policy on VDOM-A with the CLI:
config vdom
edit VDOM-A
config firewall policy
edit 0
set name Access-FTP-server
set srcintf port1
set dstintf VDOM-link0
set srcaddr internal-network
set dstaddr FTP-server
set action accept
set schedule always
set service FTP
next
end
next
end
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To add the firewall address on VDOM-B in the GUI:
1. Connect to VDOM-B.
2. Go to Policy & Objects > Addresses and create a new address.
3. Enter the following information:
Address Name

internal-network

Type

Subnet

Subnet / IP Range

192.168.10.0/24

Interface

VDOM-link1

Show in Address List

enabled

Static Route Configuration

enabled

To add the firewall addresses on VDOM-B with the CLI:
config vdom
edit VDOM-B
config firewall address
edit internal-network
set associated-interface VDOM-link1
set allow-routing enable
set subnet 192.168.10.0 255.255.255.0
next
end
next
end

To add the static route on VDOM-B in the GUI:
1. Connect to VDOM-B.
2. Go to Network > Static Routes and create a new route.
3. Enter the following information:
Destination

Named Address

Named Address

internal-network

Gateway

0.0.0.0

Interface

VDOM-link1

To add the static route on VDOM-B with the CLI:
config vdom
edit VDOM-B
config router static
edit 0
set device VDOM-link1
set dstaddr internal-network
next
end
next
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end

To add the security policy on VDOM-B in the GUI:
1. Connect to VDOM-B.
2. Go to Policy & Objects > IPv4 Policy and create a new policy.
3. Enter the following information:
Name

Internal-server-access

Incoming Interface

VDOM-link1

Outgoing Interface

port2

Source

internal-network

Destination

FTP-server

Schedule

always

Service

FTP

Action

ACCEPT

NAT

disabled

To add the security policy on VDOM-B with the CLI:
config vdom
edit VDOM-B
config firewall policy
edit 0
set name Internal-server-access
set srcintf VDOM-link1
set dstintf port2
set srcaddr internal-network
set dstaddr FTP-server
set action accept
set schedule always
set service FTP
next
end
next
end

NAT and transparent mode
In this example, VDOM-A uses NAT mode and VDOM-B uses transparent mode.
This configuration requires the following steps:
1. Configure VDOM-A on page 506
2. Configure VDOM-B on page 508
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Configure VDOM-A
VDOM-A allows connections from devices on the internal network to the Internet. WAN 1 and port 1 are assigned to this
VDOM.
The per-VDOM configuration for VDOM-A includes the following:
l
l
l

A firewall address for the internal network
A static route to the ISP gateway
A security policy allowing the internal network to access the Internet

All procedures in this section require you to connect to VDOM-A, either using a global or per-VDOM administrator
account.

To add the firewall addresses in the GUI:
1. Go to Policy & Objects > Addresses and create a new address.
2. Enter the following information:
Name

internal-network

Type

Subnet

Subnet / IP Range

192.168.10.0/24

Interface

port1

Show in Address List

enabled

To add the firewall addresses with the CLI:
config vdom
edit VDOM-A
config firewall address
edit internal-network
set associated-interface port1
set subnet 192.168.10.0 255.255.255.0
next
end
next
end

To add a default route in the GUI:
1. Go to Network > Static Routes and create a new route.
2. Enter the following information:
Destination

Subnet

IP address

0.0.0.0/0.0.0.0

Gateway

172.20.201.7

Interface

wan1

Distance

10
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To add a default route with the CLI:
config vdom
edit VDOM-A
config router static
edit 0
set gateway 172.20.201.7
set device wan1
next
end
next
end

To add the security policy in the GUI:
1. Connect to VDOM-A.
2. Go to Policy & Objects > IPv4 Policy and create a new policy.
3. Enter the following information:
Name

VDOM-A-Internet

Incoming Interface

port1

Outgoing Interface

wan1

Source Address

internal-network

Destination Address

all

Schedule

always

Service

ALL

Action

ACCEPT

NAT

enabled

To add the security policy with the CLI:
config vdom
edit VDOM-A
config firewall policy
edit 0
set name VDOM-A-Internet
set srcintf port1
set dstintf wan1
set srcaddr internal-network
set dstaddr all
set action accept
set schedule always
set service ALL
set nat enable
next
end
next
end
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Configure VDOM-B
VDOM-B allows external connections to reach an internal FTP server. WAN 2 and port 2 are assigned to this VDOM.
The per-VDOM configuration for VDOM-B includes the following:
l
l
l

A firewall address for the FTP server
A static route to the ISP gateway
A security policy allowing external traffic to reach the FTP server

All procedures in this section require you to connect to VDOM-B, either using a global or per-VDOM administrator
account.

To add the firewall addresses in the GUI:
1. Go to Policy & Objects > Addresses and create a new address.
2. Enter the following information:
Address Name

FTP-server

Type

Subnet

Subnet / IP Range

172.25.177.42/32

Interface

port2

Show in Address List

enabled

To add the firewall addresses with the CLI:
config vdom
edit VDOM-B
config firewall address
edit FTP-server
set associated-interface port2
set subnet 172.25.177.42 255.255.255.255
next
end
next
end

To add a default route in the GUI:
1. Go to Network > Routing Table and create a new route.
2. Enter the following information:
Destination

Subnet

IP address

0.0.0.0/0.0.0.0

Gateway

172.20.10.10

To add a default route with the CLI:
config vdom
edit VDOM-B
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config router static
edit 0
set gateway 172.20.10.10
next
end
next
end

To add the security policy in the GUI:
1. Connect to VDOM-B.
2. Go to Policy & Objects > IPv4 Policy and create a new policy.
3. Enter the following information:
Name

Access-server

Incoming Interface

wan2

Outgoing Interface

port2

Source Address

all

Destination Address

FTP-server

Schedule

always

Service

FTP

Action

ACCEPT

To add the security policy with the CLI:
config vdom
edit VDOM-B
config firewall policy
edit 0
set name Access-server
set srcintf wan2
set dstintf port2
set srcaddr all
set dstaddr FTP-server-VIP
set action accept
set schedule always
set service FTP
next
end
next
end

High Availability
The following sections provide instructions on configuring High Availability (HA):
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l
l
l
l
l
l
l
l
l

Introduction to the FGCP cluster on page 510
Failover protection on page 511
FGSP (session synchronization) peer setup on page 512
Using standalone configuration synchronization on page 513
Troubleshoot an HA formation on page 515
Check HA sync status on page 515
Disabling stateful SCTP inspection on page 517
Upgrading FortiGates in an HA cluster on page 518
HA cluster setup examples on page 519

Introduction to the FGCP cluster
High availability (HA) is usually required in a system where there is high demand for little downtime. There are usually
hot-swaps, backup routes, or standby backup units and as soon as the active entity fails, backup entities will start
functioning. This results in minimal interruption for the users.
The FortiGate Clustering Protocol (FGCP) is a proprietary HA solution whereby FortiGates can find other member
FortiGates to negotiate and create a cluster. A FortiGate HA cluster consists of at least two FortiGates (members)
configured for HA operation. All FortiGates in the cluster must be the same model and have the same firmware installed.
Cluster members must also have the same hardware configuration (such as the same number of hard disks). All cluster
members share the same configurations except for their host name and priority in the HA settings. The cluster works like
a device but always has a hot backup device.

Critical cluster components
The following are critical components in an HA cluster:
l

l

Heartbeat connections: members will use this to communicate with each other. In general, a two-member cluster is
most common. We recommend double back-to-back heartbeat connections.
Identical connections for internal and external interfaces: as demonstrated in the topology, we recommend similar
connections from each member to the switches for the cluster to function properly.

General operation
The following are best practices for general cluster operation:
l
l

l

Ensure that heartbeat communication is present.
Enable the session synchronization option in daily operation (see FGSP (session synchronization) peer setup on
page 512).
Monitor traffic flowing in and out of the interfaces.
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Failover
FGCP provides failover protection in the following scenarios:
l
l

The active device loses power.
A monitored interface loses a connection.

After failover occurs, the user will not notice any difference, except that the active device has changed. See Failover
protection on page 511 for more information.

Failover protection
The FortiGate Clustering Protocol (FGCP) provides failover protection, meaning that a cluster can provide FortiGate
services even when one of the devices in the cluster encounters a problem that would result in the complete loss of
connectivity for a stand-alone FortiGate unit. Failover protection provides a backup mechanism that can be used to
reduce the risk of unexpected downtime, especially in mission-critical environments.
FGCP supports failover protection in three ways:
1. Link failover maintains traffic flow if a link fails.
2. If a device loses power, it automatically fails over to a backup unit with minimal impact on the network.
3. Optionally, if an SSD fails, it can automatically fail over to a backup unit.
When session-pickup is enabled in the HA settings, existing TCP session are kept, and users on the network are not
impacted by downtime as the traffic can be passed without reestablishing the sessions.

When and how the failover happens
1. Link fails
Before triggering a failover when a link fails, the administrator must ensure that monitor interfaces are configured.
Normally, the internal interface that connects to the internal network, and an outgoing interface for traffic to the internet or
outside the network, should be monitored. Any of those links going down will trigger a failover.

2. Loss of power for active unit.
When an active (master) unit loses power, a backup (slave) unit automatically becomes the master, and the impact on
traffic is minimal. There are no settings for this kind of fail over.

3. SSD failure
HA failover can be triggered by an SSD failure.

To enable an SSD failure triggering HA fail over:
config system ha
set ssd-failover enable
end
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FGSP (session synchronization) peer setup
The FortiGate Session Life Support Protocol (FGSP) is a proprietary HA solution for only sharing sessions between two
entities and is based on a peer-to-peer structure. The entities could be standalone FortiGates or an FGCP cluster.
Connect all necessary interfaces as per the topology diagram below. Interfaces may be changed depending on the
models in use. Interface names in the topology diagram are for example purposes only.

To setup an FGSP peer through the CLI:
These instructions assume that the device has been connected to the console, the CLI is accessible, and that all
FortiGates have been factory reset.
1. Connect all necessary interfaces as per the topology diagram.
2. Enter the following command to change the FortiGate unit host name:
config system global
set hostname Example1_host(Example2_host, etc)
end

3. On each FGSP peer device, enter the following command:
config system cluster-sync
set peerip xx.xx.xx.xx
passed.
end

--->> peer's interface IP for session info to be

4. Set up identical firewall policies.
FGSP peers share the same session information which goes from the same incoming interface (example: port1) to
the outgoing interface (example: port2). Firewall policies should be identical as well, and can be copied from one
device to its peer.

To test the setup:
1. Initiate TCP traffic (like HTTP access) to go through FortiGateA.
2. Check the session information.
For example:
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diagnose sys session filter src xxx.xxx.xxx.xxx (your PCs IP)
diagnose sys session list

3. Use the same command on FortiGateB to determine if the same session information appeared.

Using standalone configuration synchronization
You can configure synchronization from one standalone FortiGate to another standalone FortiGate (standaloneconfig-sync). With the exception of some configurations that do not sync (settings that identify the FortiGate to the
network), the rest of the configurations are synced, such as firewall policies, firewall addresses, and UTM profiles.
This option is useful in situations when you need to set up FGSP peers, or when you want to quickly deploy several
FortiGates with the same configurations. You can set up standalone-config-sync for multiple members.
standalone-config-sync is an independent feature and should be used with caution as
there are some limitations. We recommend disabling it once the configurations have been
synced over.

Limitations
When standalone configuration synchronization is enabled, there are some limitations, including but not limited to the
following:
l

l

l

l

Network interruptions occur during firmware upgrades: when upgrading the firmware, all members in the
standalone-config-sync group are upgraded simultaneously. This creates downtime if the FortiGates are the
only outgoing gateway in the network. We recommend disabling the option before upgrading firmware.
Some unwanted configurations might be synced: the current design and implementation of standalone-configsync is based on requirements from specific customers. Thus, some users may find that unwanted parts of the
configurations are synced. Should this occur, we recommend disabling the option and modifying those
configurations manually.
The wrong master device might be picked accidentally: standalone-config-sync is derived from the HA
primary unit selection mechanism. All members in the group will join the selection process in the same way as a the
HA cluster selection process. It is important to select the correct device as the master, otherwise the wrong device
could be selected and existing configurations could be overwritten.
Layer 2 heartbeat connections must be present: similar to HA heartbeat requirements, one or more layer 2
heartbeat connections are needed to sync configurations between the master and slave devices.

Setting up standalone configuration synchronization
Two or more standalone FortiGates should be connected to each other with one or more heartbeat interfaces, either
back-to-back or via a switch. In the following example, the device supplying the configurations is called "conf-master,"
and the devices receiving the configurations are called "conf-slaves."
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To set up standalone configuration synchronization:
1. Configure the conf-master device for the group:
config system ha
set hbdev ha1 50 ha2 100
set priority 255
set override enable
set standalone-config-sync enable
end

2. Configure the conf-master device as needed to be functional.
3. Configure the other group members as conf-slaves:
config system ha
set standalone-config-sync enable
end

4. Wait 10–15 minutes for the configurations to sync over.
5. Verify the synchronization status:
get sys ha status
path=system, objname=ha, tablename=(null), size=5912
HA Health Status:
WARNING: FG201E4Q17900771 has hbdev down;
WARNING: FG201ETK19900991 has hbdev down;
Model: FortiGate-201E
Mode: ConfigSync
Group: 0
Debug: 0
Cluster Uptime: 0 days 0:0:51
Cluster state change time: 2019-09-03 17:46:07
Master selected using:
<2019/09/03 17:46:07> FG201ETK19900991 is selected as the master because it has the
largest value of override priority.
ses_pickup: disable
override: disable
Configuration Status:
FG201E4Q17900771(updated 3 seconds ago): out-of-sync
FG201ETK19900991(updated 1 seconds ago): in-sync
System Usage stats:
FG201E4Q17900771(updated 3 seconds ago):
sessions=1, average-cpu-user/nice/system/idle=0%/0%/0%/100%, memory=16%
FG201ETK19900991(updated 1 seconds ago):
sessions=1, average-cpu-user/nice/system/idle=0%/0%/0%/100%, memory=16%
HBDEV stats:
FG201E4Q17900771(updated 3 seconds ago):
wan2: physical/1000auto, up, rx-bytes/packets/dropped/errors=114918/266/0/0,
tx=76752/178/0/0
ha: physical/00, down, rx-bytes/packets/dropped/errors=0/0/0/0, tx=0/0/0/0
FG201ETK19900991(updated 1 seconds ago):
wan2: physical/1000auto, up, rx-bytes/packets/dropped/errors=83024/192/0/0,
tx=120216/278/0/0
ha: physical/00, down, rx-bytes/packets/dropped/errors=0/0/0/0, tx=0/0/0/0
Slave : FortiGate-201E, FG201E4Q17900771, HA cluster index = 1
Master: FortiGate-201E, FG201ETK19900991, HA cluster index = 0
number of vcluster: 1
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vcluster 1: work 169.254.0.1
Slave : FG201E4Q17900771, HA operating index = 1
Master: FG201ETK19900991, HA operating index = 0

If all members are in-sync, this means all members share the same configurations, except those that should not
be synced. If any members are out-of-sync, this means the member failed to sync with the master device.

Debugging is similar when a cluster is out of sync.

Troubleshoot an HA formation
The following are requirements for setting up an HA cluster or FGSP peers.
Cluster members must have:
l
l
l
l

The same model.
The same hardware configuration.
The same connections.
The same generation.
The requirement to have the same generation is done as a best practice as it avoids issues
that can occur later on. If you are unsure if the FortiGates are from the same generation,
please contact customer service.

Troubleshooting common HA formation errors
One member keeps shutting down during HA setup (hard drive failure):
If one member has a hard drive failure but the other does not, the one with the hard drive failure will be shut down during
HA setup. In this case, RMA the member to resolve the issue.

All members are Masters and members can't see other members:
Typically, this is a heartbeat issue. It is recommended that for a two-member cluster, you use a back-to-back connection
for heartbeat communication. If there are more than three members in the cluster, a separate switch should be used to
connect all heartbeat interfaces.

Check HA sync status
The HA sync status can be viewed in the GUI through either a widget on the Dashboard or on the System > HA page. It
can also be confirmed through the CLI. When a cluster is out of sync, administrators should correct the issue as soon as
possible as it affects the configuration integrity and can cause issues to occur.
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HA sync status in the GUI
l

l

Dashboard widget:
l Following HA setup, the HA Status widget can be added to the Dashboard. The widget shows the HA sync
status by displaying a green checkmark next to each member in sync. A red mark indicates the member is out
of sync.

System > HA page:
l The same set of icons will be displayed on the System > HA page to indicate if the member is in sync.

HA sync status in the CLI
l

In the CLI, run the command get sys ha status to see if the cluster is in sync. The sync status is reported
under Configuration Status. In the following example, both members are in sync:
FGT_A # get sys ha status
HA Health Status: OK Model: FortiGate-300D Mode: HA A-P Group: 146 Debug: 0 Cluster
Uptime: 0 days 21:42:53 Cluster state change time: 2019-03-09 11:40:51 Master selected
using:
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<2019/03/08 18:56:12> FGT6HD3914800153 is selected as the master because it has the
least value 0 of link-failure + pingsvr-failure.
ses_pickup: enable, ses_pickup_delay=disable override: enable Configuration Status:
FGT6HD3914800069(updated 5 seconds ago): in-sync
FGT6HD3914800153(updated 4 seconds ago): in-sync
System Usage stats:
FGT6HD3914800069(updated 5 seconds ago):
sessions=17, average-cpu-user/nice/system/idle=0%/0%/0%/100%, memory=25%
FGT6HD3914800153(updated 4 seconds ago):
sessions=0, average-cpu-user/nice/system/idle=0%/0%/0%/100%, memory=25%
: : : Master: FGT6HD3914800069, HA operating index = 0 Slave : FGT6HD3914800153, HA
operating index = 1

Disabling stateful SCTP inspection
There is an option in FortiOS to disable stateful SCTP inspection. This option is useful when FortiGates are deployed in a
high availability (HA) cluster that uses the FortiGate Clustering Protocol (FGCP) and virtual clustering in a multihoming
topology. In this configuration, the primary stream control transmission protocol (SCTP) path traverses the master
FortiGate node by using its active VDOM (for example, VDOM1), and the backup SCTP path traverses the other passive
FortiGate node by using its active VDOM (for example, VDOM2).
When stateful SCTP inspection is enabled, SCTP heartbeat traffic fails by means of the backup path because the
primary path goes through a different platform and VDOM. Since there is no state sharing between VDOMs, the passive
FortiGate is unaware of the original SCTP session and drops the heartbeats because of no associated sessions. When
stateful SCTP inspection is disabled, the passive node permits the SCTP heartbeats to pass.
When set to enable, SCTP session creation without SCTP INIT is enabled. When set to disable, SCTP session
creation without SCTP INIT is disabled (this is the default setting):
config system settings
set sctp-session-without-init {enable | disable}
end

The following is an example topology and scenario:

In this example, FGT_A and FGT_B are in HA a-p mode with two virtual clusters. Two masters exist on different
FortiGate units. PC1 eth1 can access PC5 eth1 through Vdom1, and PC1 eth2 can access PC5 eth2 through Vdom2.
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On PC5, to listen for an SCTP connection:
sctp_darn -H 172.16.200.55 -B 172.17.200.55 -P 2500 -l

On PC1, to start an SCTP connection:
sctp_darn -H 10.1.100.11 -B 20.1.100.11 -P 2600 -c 172.16.200.55 -c 172.17.200.55 -p 2500
-s

An SCTP four-way handshake is on one VDOM, and a session is created on that VDOM. With the default configuration,
there is no session on any other VDOM, and the heartbeat on another path (another VDOM) is dropped. After enabling
sctp-session-without-init, the other VDOM creates the session when it receives the heartbeat, and the
heartbeat is forwarded:
config system settings
set sctp-session-without-init enable
end

Upgrading FortiGates in an HA cluster
You can upgrade the firmware on an HA cluster in the same way as on a standalone FortiGate. During a firmware
upgrade, the cluster upgrades the primary unit and all of the subordinate units to the new firmware image.
Before upgrading a cluster, back up your configuration (Configuration backups on page 59),
schedule a maintenance window, and make sure that you are using a supported upgrade path
(https://docs.fortinet.com/upgrade-tool).

Uninterrupted upgrade
An uninterrupted upgrade occurs without interrupting communication in the cluster.
To upgrade the cluster firmware without interrupting communication, the following steps are followed. These steps are
transparent to the user and the network, and might result in the cluster selecting a new primary unit.
1.
2.
3.
4.
5.

The administrator uploads a new firmware image using the GUI or CLI. See Firmware on page 475 for details.
The firmware is upgraded on all of the subordinate units.
A new primary unit is selected from the upgraded subordinates.
The firmware is upgraded on the former primary unit.
Primary unit selection occurs, according to the standard primary unit selection process.

If all of the subordinate units crash or otherwise stop responding during the upgrade process, the primary unit will
continue to operate normally, and will not be upgraded until at least one subordinate rejoins the cluster.

Interrupted upgrade
An interrupted upgrade upgrades all cluster members at the same time. This takes less time than an uninterrupted
upgrade, but it interrupts communication in the cluster. Interrupted upgrade is disabled by default.

To enable interrupted upgrade:
config system ha
set uninterruptible-upgrade disable
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end

HA cluster setup examples
The following examples provide instructions on HA cluster setup:
l
l
l
l

HA active-passive cluster setup on page 519
HA active-active cluster setup on page 520
HA virtual cluster setup on page 522
HA using a hardware switch to replace a physical switch on page 525

HA active-passive cluster setup
An HA Active-Passive (A-P) cluster can be set up using the GUI or CLI.
This example uses the following network topology:

To set up an HA A-P cluster using the GUI:
1. Make all the necessary connections as shown in the topology diagram.
2. Log into one of the FortiGates.
3. Go to System > HA and set the following options:
Mode

Active-Passive

Device priority

128 or higher

Group name

Example_cluster

Heartbeat interfaces

ha1 and ha2

Except for the device priority, these settings must be the same on all FortiGates in the cluster.
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4. Leave the remaining settings as their default values. They can be changed after the cluster is in operation.
5. Click OK.
The FortiGate negotiates to establish an HA cluster. Connectivity with the FortiGate may be temporarily lost as the
HA cluster negotiates and the FGCP changes the MAC addresses of the FortiGate's interfaces.
6. Factory reset the other FortiGate that will be in the cluster, configure GUI access, then repeat steps 1 to 5, omitting
setting the device priority, to join the cluster.

To set up an HA A-P cluster using the CLI:
1. Make all the necessary connections as shown in the topology diagram.
2. Log into one of the FortiGates.
3. Change the hostname of the FortiGate:
config system global
set hostname Example1_host
end

Changing the host name makes it easier to identify individual cluster units in the cluster operations.
4. Enable HA:
config system ha
set mode a-p
set group-name Example_cluster
set hbdev ha1 10 ha2 20
end

5. Leave the remaining settings as their default values. They can be changed after the cluster is in operation.
6. Repeat steps 1 to 5 on the other FortiGate devices to join the cluster.

HA active-active cluster setup
An HA Active-Active (A-A) cluster can be set up using the GUI or CLI.
This example uses the following network topology:
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To set up an HA A-A cluster using the GUI:
1. Make all the necessary connections as shown in the topology diagram.
2. Log into one of the FortiGates.
3. Go to System > HA and set the following options:
Mode

Active-Active

Device priority

128 or higher

Group name

Example_cluster

Heartbeat interfaces

ha1 and ha2

Except for the device priority, these settings must be the same on all FortiGates in the cluster.

4. Leave the remaining settings as their default values. They can be changed after the cluster is in operation.
5. Click OK.
The FortiGate negotiates to establish an HA cluster. Connectivity with the FortiGate may be temporarily lost as the
HA cluster negotiates and the FGCP changes the MAC addresses of the FortiGate's interfaces.
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6. Factory reset the other FortiGate that will be in the cluster, configure GUI access, then repeat steps 1 to 5, omitting
setting the device priority, to join the cluster.

To set up an HA A-P cluster using the CLI:
1. Make all the necessary connections as shown in the topology diagram.
2. Log into one of the FortiGates.
3. Change the hostname of the FortiGate:
config system global
set hostname Example1_host
end

Changing the host name makes it easier to identify individual cluster units in the cluster operations.
4. Enable HA:
config system ha
set mode a-a
set group-name Example_cluster
set hbdev ha1 10 ha2 20
end

5. Leave the remaining settings as their default values. They can be changed after the cluster is in operation.
6. Repeat steps 1 to 5 on the other FortiGate devices to join the cluster.

HA virtual cluster setup
An HA virtual cluster can be set up using the GUI or CLI.
This example uses the following network topology:

HA virtual clusters are based on VDOMs and are more complicated than regular clusters.
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To set up an HA virtual cluster using the GUI:
1. Make all the necessary connections as shown in the topology diagram.
2. Log into one of the FortiGates.
3. Go to System > HA and set the following options:
Mode

Active-Passive

Device priority

128 or higher

Group name

Example_cluster

Heartbeat interfaces

ha1 and ha2

Except for the device priority, these settings must be the same on all FortiGates in the cluster.
4. Leave the remaining settings as their default values. They can be changed after the cluster is in operation.
5. Click OK.
The FortiGate negotiates to establish an HA cluster. Connectivity with the FortiGate may be temporarily lost as the
HA cluster negotiates and the FGCP changes the MAC addresses of the FortiGate's interfaces.
6. Factory reset the other FortiGate that will be in the cluster, configure GUI access, then repeat steps 1 to 5, omitting
setting the device priority, to join the cluster.
7. Go to System > Settings and enable Virtual Domains.
8. Click Apply. You will be logged out of the FortiGate.
9. Log back into the FortiGate, ensure that you are in the global VDOM, and go to System > VDOM.
10. Create two new VDOMs, such as VD1 and VD2:
a. Click Create New. The New Virtual Domain page opens.
b. Enter a name for the VDOM in the Virtual Domain field, then click OK to create the VDOM.
c. Repeat these steps to create a second new VDOM.
11. Implement a virtual cluster by moving the new VDOMs to Virtual cluster 2:
a. Go to System > HA.
b. Enable VDOM Partitioning.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

523

System
c. Click on the Virtual cluster 2 field and select the new VDOMs.

d. Click OK.

To set up an HA virtual cluster using the CLI:
1. Make all the necessary connections as shown in the topology diagram.
2. Set up a regular A-P cluster. See HA active-passive cluster setup on page 519.
3. Enable VDOMs:
config system global
set vdom-mode multi-vdom
end

You will be logged out of the FortiGate.
4. Create two VDOMs:
config vdom
edit VD1
next
edit VD2
next
end

5. Reconfigure the HA settings to be a virtual cluster:
config global
config system ha
set vcluster2 enable
config secondary-vcluster
set vdom "VD1" "VD2"
end
end
end
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HA using a hardware switch to replace a physical switch
Using a hardware switch to replace a physical switch is not recommended, as it offers no redundancy or interface
monitoring.
l

l

If one FortiGate loses power, all of the clients connected to that FortiGate device cannot go to another device until
that FortiGate recovers.
A hardware switch cannot be used as a monitor interface in HA. Any incoming or outgoing link failures on hardware
member interfaces will not trigger failover; this can affect traffic.

Examples
The examples use the following topology:

Traffic between hardware switches
When using Hardware switch in HA environment, a client device connected to the hardware switch on the primary
FortiGate can communicate with client devices connected to the hardware switch on secondary FortiGates as long as
there is a direct connection between the two switches.
No configuration is required after setting up the hardware switches. If a client connected to both of the hardware switches
needs to reach destinations outside of the cluster, the firewall must be configured for it.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

525

System

To configure the FortiGate devices:
1. Connect the devices as shown in the topology diagram.
2. On each FortiGate, configure HA:
config system ha
set mode a-a
set group-name Example_cluster
set hbdev ha1 10 ha2 20
end

3. On the primary FortiGate, configure the hardware switch:
config system virtual-switch
edit Hardware-SW
set physical-switch sw0
config port
edit port3
next
edit port5
next
end
next
end

4. On each FortiGate, configure the IP addresses on the hardware switches:
config system interface
edit Hardware-SW
set ip 6.6.6.1 255.255.255.0
set allowaccess ping ssh http https
next
end

After configuring the hardware switches, PC1 and PC2 can now communicate with each other.

Traffic passes through FortiGate
If client device needs to send traffic through the FortiGate, additional firewall configuration on the FortiGate is required.
All traffic from the hardware switches on either the primary or secondary FortiGate reaches the primary FortiGate first.
The traffic is then directed according to the HA mode and firewall configuration.

To configure the FortiGate devices:
1. Connect the devices as shown in the topology diagram.
2. On each FortiGate, configure HA:
config system ha
set mode a-a
set group-name Example_cluster
set hbdev ha1 10 ha2 20
end

3. On the primary FortiGate, configure the hardware switch:
config system virtual-switch
edit Hardware-SW
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set physical-switch sw0
config port
edit port3
next
edit port5
next
end
next
edit Hardware-SW2
set physical-switch sw0
config port
edit port1
next
end
next
end

4. On each FortiGate, configure the IP addresses on the hardware switch:
config system interface
edit Hardware-SW
set ip 6.6.6.1 255.255.255.0
set allowaccess ping ssh http https
next
edit Hardware-SW2
set ip 172.16.200.1 255.255.255.0
set allowaccess ping ssh http https
next
end

5. On each FortiGate, configure a firewall policy:
config firewall policy
edit 1
set srcintf Hardware-SW
set dstintf Hardware-SW2
set srcaddr all
set dstaddr all
set service ALL
set action accept
set schedule always
set nat enable
next
end

6. On each FortiGate, configure a static route:
config router static
edit 1
set device Hardware-SW2
set gateway 172.16.200.254
next
end

Traffic from PC1 and PC2 can now reach destinations outside of the FortiGate cluster.
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SNMP
SNMP enables you to monitor hardware on your network. You can configure the hardware, such as the FortiGate SNMP
agent, to report system information and send traps (alarms or event messages) to SNMP managers. SNMP traps alert
you to events that happen, such as when a log disk is full or a virus is detected.
The FortiGate SNMP implementation is read-only. SNMP v1/v2c, and v3 compliant SNMP managers have read-only
access to FortiGate system information through queries, and can receive trap messages from the FortiGate unit.
l
l
l
l
l
l

Interface access on page 528
MIB files on page 528
SNMP agent on page 529
SNMP v1/v2c communities on page 530
SNMP v3 users on page 531
Important SNMP traps on page 532

Interface access
Before a remote SNMP manager can connect to the FortiGate SNMP agent, you must configure one or more FortiGate
interfaces to accept SNMP connections.

To configure a FortiGate interface to accept SNMP connections in the GUI:
1.
2.
3.
4.

Go to Network > Interfaces.
Edit the interface.
In the Administrative Access options, enable SNMP.
Click OK.

To configure a FortiGate interface to accept SNMP connections in the CLI:
config system interface
edit <interface>
append allowaccess snmp
set snmp-index <integer>
config ipv6
append ip6-allowaccess snmp
end
next
end

MIB files
The FortiGate SNMP agent supports Fortinet proprietary MIBs, as well as the parts of RFC 2665 and RFC 1213 that
apply to FortiGate unit configuration.
Your SNMP manager may already include standard and private MIBs in a compiled database that is ready to use. You
must add the Fortinet proprietary MIBs to this database to have access to Fortinet specific information.
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MIB file or RFC

Description

FORTINET-CORE-MIB.mib

The Fortinet core MIB includes all system configuration and trap information that
is common to all Fortinet products.
Your SNMP manager requires this information to monitor Fortinet device settings
and receive traps from the FortiGate SNMP agent.

FORTINET-FORTIGATEMIB.mib

The FortiGate MIB includes all system configuration information and trap
information that is specific to FortiGate units.
Your SNMP manager requires this information to monitor FortiGate settings and
receive traps from the FortiGate SNMP agent.

RFC-1213 (MIB II)

The FortiGate SNMP agent supports MIB II groups with the following exceptions:
l No support for the EGP group from MIB II (RFC 1213, section 3.11 and 6.10).
l Protocol statistics returned for MIB II groups (IP/ICMP/TCP/UDP/etc.) do not
accurately capture all Fortinet traffic activity. More accurate information can
be obtained from the information reported by the Fortinet MIB.

RFC-2665 (Ethernet-like MIB)

The FortiGate SNMP agent supports Ethernet-like MIB information.
FortiGate SNMP does not support for the dot3Tests and dot3Errors groups.

To download the MIB files:
1. Go to System > SNMP.
2. Click Download FortiGate MIB File and save the file to the management computer.
3. Click Download Fortinet Core MIB File and save the file to the management computer.

SNMP agent
The SNMP agent sends SNMP traps originating on the FortiGate to an external monitoring SNMP manager defined in a
SNMP community. The SNMP manager can monitor the FortiGate system to determine if it is operating properly, or if
any critical events occurring.
The description, location, and contact information for this FortiGate system will be part of the information that the SNMP
manager receives. This information is useful if the SNMP manager is monitoring many devices, and enables faster
responses when the FortiGate system requires attention.

To configure the SNMP agent in the GUI:
1.
2.
3.
4.
5.
6.

Go to System > SNMP.
Enable SNMP Agent.
Enter a description of the agent.
Enter the location of the FortiGate unit.
Enter a contact or administrator for the SNMP Agent or FortiGate unit.
Click Apply.

To configure the SNMP agent in the CLI:
config system snmp sysinfo
set status enable
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set description <string>
set contact-info <string>
set location <string>
end

SNMP v1/v2c communities
An SNMP community is a grouping of equipment for network administration purposes. A single device can belong to
multiple communities.
You must add an SNMP community to the FortiGate so that the SNMP manager can receive traps and system
information. Up to three communities can be added.

To create a n SNMP v1/v2c community in the GUI:
1. Go to System > SNMP.
2. In the SNMP v1/v2c table, click Create New.

3. Enter a Community Name and enable the community.
4. In the Hosts section, enter the IP Address and select the Host Type for each SNMP manager.
5. In the Queries section, enable or disable v1 and v2c queries, then enter the port numbers that the SNMP managers
in this community use for them.
6. In the Traps section, enable or disable v1 and v2c traps, then enter the local and remote port numbers that the
SNMP managers in this community use for them.
7. In the SNMP Events section, enable or disable the events that activate traps in this community.
8. Click OK.

To create a n SNMP v1/v2c community in the CLI:
config system snmp community
edit 2
set name <string>
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set status {enable | disable}
config hosts
edit <host_id>
set ip <ip/mask>
set source-ip <class_ip>
set ha-direct {enable | disable}
set host-type {any | query | trap}
next
end
set query-v1-port <port_number>
set query-v1-status {enable | disable}
set query-v2c-port <port_number>
set query-v2c-status {enable | disable}
set trap-v1-lport <port_number>
set trap-v1-rport <port_number>
set trap-v1-status {enable | disable}
set trap-v2c-lport <port_number>
set trap-v2c-rport <port_number>
set trap-v2c-status {enable | disable}
set events <events>
next
end

SNMP v3 users
Authentication is used to ensure the identity of users. Privacy allows for encryption of SNMP v3 messages to ensure
confidentiality of data. These protocols provide a higher level of security than is available in SNMP v1 and v2c, which use
community strings for security. Both authentication and privacy are optional.

To create a n SNMP v3 user in the GUI:
1. Go to System > SNMP.
2. In the SNMP v3 table, click Create New.
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3. Enter a Use Name and enable the user.
4. In the Security Level section, configure the security level:
l No Authentication: No authentication or encryption.
l Authentication: Select the authentication algorithm and password.
l Authentication and Private: Select both the authentication and encryption algorithms and password.
5. In the Hosts section, enter the IP Address for each SNMP manager.
6. In the Queries section, enable or disable queries, then enter the port number that the SNMP managers use for
them.
7. In the Traps section, enable or disable traps, then enter the local and remote port numbers that the SNMP
managers use for them.
8. In the SNMP Events section, enable or disable the events that activate traps.
9. Click OK.

To create an SNMP v3 user in the CLI:
config system snmp user
edit <user>
set status {enable | disable}
set trap-status {enable | disable}
set trap-lport <port_number>
set trap-rport <port_number>
set queries {enable | disable}
set query-port <port_number>
set notify-hosts <class_ip> ... <class_ip>
set source-ip <class_ip>
set ha-direct {enable | disable}
set events <events>
set security-level {no-auth-no-priv | auth-no-priv | auth-priv}
set auth-proto {md5 | sha}
set auth-pwd <password>
set prive-proto {aes | des | aes256 | aes256cisco}
set priv-pwd <password>
next
end

Important SNMP traps
Link Down and Link Up traps
This trap is sent when a FortiGate port either goes down or is brought up.
For example, the following traps are generated when the state of port34 is set to down using set status down, and
then brought up using set status up:
NET-SNMP version 5.7.3 2019-01-31 14:11:48 10.1.100.1(via UDP: [10.1.100.1]:162->
[10.1.100.11]:162) TRAP, SNMP v1, community REGR-SYS SNMPv2-MIB::snmpTraps Link Down Trap
(0) Uptime: 0:14:44.95 IF-MIB::ifIndex.42 = INTEGER: 42 IF-MIB::ifAdminStatus.42 = INTEGER:
down(2) IF-MIB::ifOperStatus.42 = INTEGER: down(2) FORTINET-CORE-MIB::fnSysSerial.0 =
STRING: FG140P3G15800330 SNMPv2-MIB::sysName.0 = STRING: FortiGate-140D-POE
2019-01-31 14:11:48 <UNKNOWN> [UDP: [10.1.100.1]:162->[10.1.100.11]:162]: DISMAN-EVENTMIB::sysUpTimeInstance = Timeticks: (88495) 0:14:44.95 SNMPv2-MIB::snmpTrapOID.0 = OID: IF-
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MIB::linkDown IF-MIB::ifIndex.42 = INTEGER: 42 IF-MIB::ifAdminStatus.42 = INTEGER: down(2)
IF-MIB::ifOperStatus.42 = INTEGER: down(2) FORTINET-CORE-MIB::fnSysSerial.0 = STRING:
FG140P3G15800330 SNMPv2-MIB::sysName.0 = STRING: FortiGate-140D-POE 2019-01-31 14:12:01
10.1.100.1(via UDP: [10.1.100.1]:162->[10.1.100.11]:162) TRAP, SNMP v1, community REGR-SYS
SNMPv2-MIB::snmpTraps Link Up Trap (0) Uptime: 0:14:57.98 IF-MIB::ifIndex.42 = INTEGER: 42
IF-MIB::ifAdminStatus.42 = INTEGER: up(1) IF-MIB::ifOperStatus.42 = INTEGER: up(1) FORTINETCORE-MIB::fnSysSerial.0 = STRING: FG140P3G15800330 SNMPv2-MIB::sysName.0 = STRING:
FortiGate-140D-POE
2019-01-31 14:12:01 <UNKNOWN> [UDP: [10.1.100.1]:162->[10.1.100.11]:162]: DISMAN-EVENTMIB::sysUpTimeInstance = Timeticks: (89798) 0:14:57.98 SNMPv2-MIB::snmpTrapOID.0 = OID: IFMIB::linkUp IF-MIB::ifIndex.42 = INTEGER: 42 IF-MIB::ifAdminStatus.42 = INTEGER: up(1) IFMIB::ifOperStatus.42 = INTEGER: up(1) FORTINET-CORE-MIB::fnSysSerial.0 = STRING:
FG140P3G15800330 SNMPv2-MIB::sysName.0 = STRING: FortiGate-140D-POE

fgFmTrapIfChange trap
This trap is sent when any changes are detected on the interface. The change can be very simple, such as giving an
IPV4 address.
For example, the user has given the IP address of 1.2.3.4/24 to port 1 and the EMS Manager has detected the following
trap:
DISMAN-EXPRESSION-MIB::sysUpTimeInstance = Timeticks: (7975058) 22:09:10.58 SNMPv2MIB::snmpTrapOID.0 = OID: FORTINET-FORTIGATE-MIB::fgFmTrapIfChange FORTINET-COREMIB::fnSysSerial.0 = STRING: FG140P3G15800330 IF-MIB::ifName.45 = STRING: port1 FORTINETFORTIGATE-MIB::fgManIfIp.0 = IpAddress: 1.2.3.4 FORTINET-FORTIGATE-MIB::fgManIfMask.0 =
IpAddress: 255.255.255.0 FORTINET-FORTIGATE-MIB::fgManIfIp6.0 = STRING: 0:0:0:0:0:0:0:0

entConfigChange trap
The change to the interface in the previous example has also triggered the ConfChange Trap which is sent along with
the fgFmTrapIfChange trap:
2018-11-15 09:30:23 FGT_A [UDP: [172.16.200.1]:162->[172.16.200.55]:162]: DISMAN-EXPRESSIONMIB::sysUpTimeInstance = Timeticks: (8035097) 22:19:10.97 SNMPv2-MIB::snmpTrapOID.0 = OID:
ENTITY-MIB::entConfigChange

fgTrapDeviceNew trap
This trap is triggered when a new device, like a FortiSwitch, is connected to the FortiGate.
For example, the following scenario has given the device a new trap for adding FortiAP on a PoE interface a FortiGate
140D-POE. The trap has important information about the device name, device MAC address, and when it was last seen.
2018-11-15 11:17:43 UDP/IPv6: [2000:172:16:200::1]:162 [UDP/IPv6: [2000:172:16:200::1]:162]:
DISMAN-EXPRESSION-MIB::sysUpTimeInstance = Timeticks: (520817) 1:26:48.17 SNMPv2MIB::snmpTrapOID.0 = OID: FORTINET-FORTIGATE-MIB::fgTrapDeviceNew FORTINET-COREMIB::fnSysSerial.0 = STRING: FG140P3G15800330 SNMPv2-MIB::sysName.0 = STRING: FGT_A IFMIB::ifIndex.0 = INTEGER: 0 FORTINET-FORTIGATE-MIB::fgVdEntIndex.0 = INTEGER: 0 FORTINETFORTIGATE-MIB::fgDeviceCreated.0 = Gauge32: 5 FORTINET-FORTIGATE-MIB::fgDeviceLastSeen.0 =
Gauge32: 5 FORTINET-FORTIGATE-MIB::fgDeviceMacAddress.0 = STRING: 90:6c:ac:f9:97:a0
2018-11-15 11:17:43 FGT_A [UDP: [172.16.200.1]:162->[172.16.200.55]:162]: DISMAN-EXPRESSIONMIB::sysUpTimeInstance = Timeticks: (520817) 1:26:48.17 SNMPv2-MIB::snmpTrapOID.0 = OID:
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FORTINET-FORTIGATE-MIB::fgTrapDeviceNew FORTINET-CORE-MIB::fnSysSerial.0 = STRING:
FG140P3G15800330 SNMPv2-MIB::sysName.0 = STRING: FGT_A IF-MIB::ifIndex.0 = INTEGER: 0
FORTINET-FORTIGATE-MIB::fgVdEntIndex.0 = INTEGER: 0 FORTINET-FORTIGATEMIB::fgDeviceCreated.0 = Gauge32: 5 FORTINET-FORTIGATE-MIB::fgDeviceLastSeen.0 = Gauge32: 5
FORTINET-FORTIGATE-MIB::fgDeviceMacAddress.0 = STRING: 90:6c:ac:f9:97:a0

fgTrapAvOversize trap
The fgTrapAvOversize trap is generated when the antivirus scanner detects an oversized file:
019-01-31 13:22:04 10.1.100.1(via UDP: [10.1.100.1]:162->[10.1.100.11]:162) TRAP, SNMP v1,
community REGR-SYS FORTINET-FORTIGATE-MIB::fgt140P Enterprise Specific Trap (602) Uptime: 1
day, 3:41:10.31 FORTINET-CORE-MIB::fnSysSerial.0 = STRING: FG140P3G15800330 SNMPv2MIB::sysName.0 = STRING: FortiGate-140D-POE 2019-01-31 13:22:29 <UNKNOWN> [UDP:
[10.1.100.1]:162->[10.1.100.11]:162]: DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks:
(9967031) 1 day, 3:41:10.31 SNMPv2-MIB::snmpTrapOID.0 = OID: FORTINET-FORTIGATEMIB::fgTrapAvOversize FORTINET-CORE-MIB::fnSysSerial.0 = STRING: FG140P3G15800330 SNMPv2MIB::sysName.0 = STRING: FortiGate-140D-POE

Replacement messages
The replacement message list in System > Replacement Messages enables you to view and customize replacement
messages. Highlight the replacement messages you want to edit and customize the message content to your
requirements. Hit Save when done. If you do not see the message you want to edit, select the Extended View option in
the upper right-hand corner of the screen.
If you make a mistake, select Restore Default to return to the original message and code base.

Replacement message images
You can add images to replacement messages on:
l
l
l
l
l
l

Disclaimer pages
Login pages
Declined disclaimer pages
Login failed pages
Login challenge pages
Keepalive pages

Supported image formats are GIF, JPEG, TIFF, and PNG. The maximum file size
supported is 24KB.
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Adding images to replacement messages
To add images to replacement messages in the GUI:
1.
2.
3.
4.
5.

Go to System > Replacement Messages.
Click Manage Images at the top of the page.
Click Create New.
Enter a name for the image.
Click Upload Image and locate the file.

6. Click OK.

To add images to replacement messages in the CLI:
config system replacemsg-image
edit <image_name>
set image-type {gif | jpg | tiff | png}
set image-base64 <string>
next
end
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Modifying replacement messages
Replacement messages can be modified to include an HTML message or content that suits your organization. A list of
common replacement messages appear in the main window. Select Extended View to see the entire list and all
categories for replacement messages.

To modify a replacement message in the GUI:
1. Go to System > Replacement Messages.
2. Select the replacement message you want to edit.
3. In the bottom pane of the GUI the message will be displayed on the left alongside the HTML code on the right. Edit
the HTML code as needed.
The message view changes in real-time as you edit the content.

4. Click Save.

To modify a replacement message in the CLI:
config system replacemsg <message_category> <message_type>
set buffer <string>
set header {none | http | 8bit}
set format {none | text | html}
end

For example, to modify the Traffic Quota Limit Exceeded Page message:
config system replacemsg traffic-quota "per-ip-shaper-block"
set buffer "<html>
<head>
<title>
Traffic Quota Control
</title>
</head>
<body>
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<font size=2>
<table width=\"100%\">
<tr>
<td bgcolor=#3300cc align=\"center\" colspan=2>
<font color=#ffffff>
<b>
Traffic blocked because exceeded session quota
</b>
</font>
</td>
</tr>
</table>
<br>
<br>
Traffic blocked because it exceeded the per IP shaper session quota. Please contact
the system administrator.
<br>
%%QUOTA_INFO%%
<br>
<br>
<hr>
</font>
</body>
</html>"
set header http
set format html
end

Replacement message groups
Replacement message groups allow you to customize replacement messages for individual policies and profiles.
There are two types of replacement message groups:
l

l

utm: Used with UTM settings in firewall policies. Messages in the following categories can be customized: mail,
http, webproxy, ftp, nntp, fortiguard-wf, spam, alertmail, admin, sslvpn, nac-quar, traffic-quota, utm, custommessage, and icap.
auth: Used with authentication pages in firewall policies. Messages in the following categories can be customized:
webproxy and auth.

The messages added to a group do not need to be customized. The body content, header type, and format of a message
will use the default values if not customized.

To create or edit a replacement message group in the CLI:
config system replacemsg-group
edit <group>
set group-type {auth | utm}
config <message_category>
edit <message_type>
set buffer <message>
set header {none | http | 8bit}
set format {none | text | html}
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next
end
next
end

To create a replacement message group in the GUI:
1. Make replacement message groups visible in the GUI with the following CLI command:
config system settings
set gui-replacement-message-groups enable
end

2.
3.
4.
5.
6.

Go to System > Replacement Message Groups.
Click Create New.
Enter a name for the new group.
Optionally, enter a comment describing the group.
Select the Group Type, either Security or Authentication.

7. Click OK.

Example
In this example, two replacement message groups are created. The UTM type message group includes custom mail
related messages, changes the formats of some spam related message, and is assigned to an email filter profile. The
authentication type message group has a custom authentication success message that is applied to a proxy-based
firewall policy that with the email filter profile assigned.

To create the replacement message groups and use them in a profile and a policy in the CLI:
1. Create the replacement message groups:
config system replacemsg-group
edit "newutm"
set group-type utm
config mail
edit "partial"
set buffer "Fragmented emails are blocked, sorry."
next
edit "email-av-fail"
set buffer "The email has been blocked for reasons."
next
end
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config spam
edit "submit"
set header http
set format html
next
edit "reversedns"
set header http
set format html
next
end
next
edit "newauth"
set group-type auth
config auth
edit "auth-success-msg"
set buffer "Welcome to the firewall. Your authentication has been
accepted, please reconnect."
set header none
set format text
next
end
next
end

2. Apply the message groups:
config emailfilter profile
edit "newmsgs"
set replacemsg-group "newutm"
next
end
config firewall policy
edit 1
...
set replacemsg-override-group "newauth"
set inspection-mode proxy
set emailfilter-profile "newmsgs"
...
next
end

To create the replacement message groups and use them in a profile and a policy in the GUI:
1. Create the Security replacement message groups:
a. Go to System > Replacement Message Groups.
b. Click Create New.
c. Enter newutm in the Name field.
d. Enter UTM message group in the Comments field.
e. Select Security as the Group Type.
f. Click OK.
2. Customize the replacement messages in the newutm group:
a. Go to System > Replacement Message Groups.
b. Edit the newutm group.
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c. Locate the AV Engine Load Error Email Block Message, edit the message, then click Save.

d. Locate the Partial Email Block Message, edit the message, then click Save.
3. Create the Authentication replacement message group:
a. Go to System Replacement Message Groups.
b. Click Create New.
c. Enter newauth in the Name field.
d. Enter Authentication message group in the Comments field.
e. Select Authentication as the Group Type.

f. Click OK.
4. Apply the newutm replacement message group to an email filter profile using the CLI.
5. Apply the newauth replacement message group and the email filter profile to a firewall policy using the CLI.

FortiGuard
FortiGuard services can be purchased and registered to your FortiGate unit. The FortiGate must be connected to the
Internet in order to automatically connect to the FortiGuard Distribution Network (FDN) to validate the license and
download FDN updates.
The FortiGuard subscription update services include:
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l
l
l
l
l
l

Antivirus (AV)
Intrusion Protection Service (IPS)
Application Control
Antispam
Web Filtering
Web Application Firewall (WAF)

To view FDN support contract information, go to System > FortiGuard. The License Information table shows the status of
your FortiGate’s support contract.
l
l
l
l
l
l
l
l
l
l

IPv6 FortiGuard connections on page 541
Configuring antivirus and IPS options on page 542
Manual updates on page 542
Automatic updates on page 543
Sending malware statistics to FortiGuard on page 545
Update server location on page 545
Filtering on page 546
Override FortiGuard servers on page 547
Online security tools on page 547
FortiGuard third party SSL validation and anycast support on page 548

IPv6 FortiGuard connections
The Fortinet DNS can resolve FortiGuard related servers to both IPv4 and IPv6 addresses. FortiOS daemons (update,
forticldd, url) connect using either IPv4 or IPv6 addresses. The first available connection will be used for updates or the
rating service.

To configure an interface and route for IPv6:
config system interface
edit "wan1"
set vdom "root"
config ipv6
set ip6-address 2000:172:16:200::1/64
end
next
end
config router static6
edit 1
set gateway 2000:172:16:200::254
set device "wan1"
next
end

To configure push updates:
config system autoupdate push-update
set status enable
set override enable

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

541

System

set address "2620:101:9005:3860::94"
end

Configuring antivirus and IPS options
To configure antivirus and IPS options:
1. Go to System > FortiGuard
2. Scroll down to the AntiVirus & IPS Updates section.
3. Configure the antivirus and IPS options for connecting and downloading definition files:
Accept push updates

Enable to allow updates to be sent automatically to your FortiGate. New
definitions will be added as soon as they are released by FortiGuard. See
Push updates on page 544.

Use override push

Only available if Accept push updates is enabled. See Override push on page
544.

Scheduled Updates

Enable to schedule updates to be sent to the FortiGate at the specified time.
See Scheduled updates on page 543.

Improve IPS quality

Enable to send information to the FortiGuard servers when an attack occurs.
This can help keep the FortiGuard database current as attacks evolve, and
improve IPS signatures.

Use extended IPS signature
package

Enable to use the extended IPS database, that includes protection from legacy
attacks, along with the regular IPS database that protects against the latest
common and in-the-wild attacks.

Update AV & IPS Definitions

Click to manually initiate an FDN update.

4. Click Apply.

Manual updates
When needed, FDN updates can be manually uploaded.

To manually update the signature definitions files:
1.
2.
3.
4.
5.
6.

Log in to the Fortinet Support website.
Go to Download > FortiGuard Service Updates.
Select your OS Version from the dropdown list.
Locate your device in the table, and download the signature definitions files.
On the FortiGate, go to System FortiGuard.
In the License Information table, locate the row of the definitions that you are updating, and click Upgrade Database
in the rightmost column.
7. In the pane that opens, click Upload, locate the downloaded definitions file on your computer, then click Open.
The download may take a few minutes to complete.
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8. Click OK.

Automatic updates
The FortiGate can be configured to request updates from FDN on a schedule, or via push notification.

Scheduled updates
Scheduling updates ensures that the virus and IPS definitions are downloaded to your FortiGate on a regular basis.
Updating definitions can cause a brief disruption in traffic that is currently being scanned while the FortiGate unit applies
the new signature database. Updates should be scheduled during off-peak hours when network usage is at a minimum
to ensure that network activity will not be affected by downloading the definitions files.
A schedule of once a week means any urgent updates will not be pushed until the scheduled
time. If an urgent update is required, click the Update AV & IPS Definitions button to manually
update the definitions.

To configure scheduled updates in the GUI:
1.
2.
3.
4.

Go to System > FortiGuard
Scroll down to the AntiVirus & IPS Updates section.
Enable Scheduled Updates.
Configure the update schedule.
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5. Click Apply.

To configure scheduled updates in the CLI:
config system autoupdate schedule
set status enable
set frequency {every | daily | weekly}
set time <hh:mm>
set day <day_of_week>
end

Push updates
Push updates enable you to get immediate updates when new viruses or intrusions are discovered and new signatures
are created. This ensures that the latest signature are sent to the FortiGate as soon as possible.
When a push notification occurs, the FortiGuard server sends a notice to the FortiGate that a new signature definition file
available. The FortiGate then initiates a download of the definition file. For maximum security, both scheduled and push
updates should be enabled.

To enable push updates - GUI:
1.
2.
3.
4.

Go to System > FortiGuard
Scroll down to the AntiVirus & IPS Updates section.
Enable Accept push updates.
Click Apply.

To enable push updates in the CLI:
config system autoupdate push-update
set status enable
set override {enable | disable}
set address <vip_address>
end

Override push
If the FortiGate is behind a NAT device (or another FortiGate), or if your organization provides updates using their own
FortiGuard server, an override server must be used to ensure that the FortiGate receives push update notifications. The
FDS will connect to the NAT device when attempting to reach the FortiGate, and the NAT device must be configured to
forward FDS traffic to the FortiGate on UDP port 9443.
Push updates must be enabled to configure a push update override.
For example, if the NAT device is another FortiGate:
1. On the FortiGate NAT device, add a port forwarding virtual IP address in Policy & Objects > Virtual IPs. See for
details.
2. On the FortiGate NAT device, add a security policy that connects to the internet and includes the port forwarding
VIP.
3. On the internal FortiGate device, configure Push update override.
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To configure push update override in the GUI:
1.
2.
3.
4.
5.
6.

Go to System > FortiGuard
Scroll down to the AntiVirus & IPS Updates section.
Enable Accept push updates.
Enable Use override push.
Enter the IP address and port number configured on the NAT device.
Click Apply.

To configure push update override in the CLI:
config system autoupdate push-update
set status enable
set override {enable | disable}
set address <vip_address>
end

Sending malware statistics to FortiGuard
FortiGate devices periodically send encrypted antivirus, IPS, botnet IP list, and application control statistics to
FortiGuard. Included with these data is the IP address and serial number of the FortiGate, and the country that it is in.
This information is never shared with external parties, Fortinet Privacy Policy.
The malware statistics are used to improve various aspects of FortiGate malware protection. For example, antivirus data
allow FortiGuard to determine what viruses are currently active. Signatures for those viruses are kept in the Active AV
Signature Database that is used by multiple Fortinet products.Inactive virus signatures are moved to the Extended AV
Signature Database (see Configuring antivirus and IPS options on page 542). When events for inactive viruses start
appearing in the malware data, the signatures are moved back into the AV Signature Database.
The FortiGate and FortiGuard servers go through a 2-way SSL/TLS 1.2 authentication before any data is transmitted.
The certificates used in this process must be trusted by each other and signed by the Fortinet CA server.
The FortiGate only accepts data from authorized FortiGuard severs. Fortinet products use DNS to find FortiGuard
servers and periodically update their FortiGate server list. All other servers are provided by a list that is updated through
the encrypted channel.
Malware statistics are accumulated and sent every 60 minutes by default.
To configure sharing this information, use the following CLI command:
config system global
set fds-statistics {enable | disable}
set fds-statistics-period <minutes>
end

Update server location
The location of the FortiGuard update server that the FortiGate connects to can be set to either only servers in the USA
only, or to the servers with the lowest latency.
On hardware FortiGate devices, the default is Lowest latency locations. On VM devices, the default is US only.
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To configure the update server location in the GUI:
1.
2.
3.
4.

Go to System > FortiGuard
Scroll down to the Update Server Location section.
Select US only or Lowest latency locations.
Click Apply.

To configure the update server location in the CLI:
config system fortiguard
set update-server-location {usa | any}
end

Filtering
Web filtering is used to block access to harmful, inappropriate, and dangerous web sites (see FortiGuard filter on page
748).
Email filtering is used to detect and block spam messages (see FortiGuard-based filters on page 831).

To configure filtering in the GUI:
1. Go to System > FortiGuard
2. Scroll down to the Filtering section.
3. Configure the settings as needed:
Web Filter Cache

Enable/disable web filter cache, and set the amount of time that the FortiGate
will store a blocked IP address or URL locally. After the time expires, the
FortiGate contacts the FDN to verify the address.

Anti-Spam Cache

Enable/disable email filter cache, and set the amount of time that the FortiGate
will store an email address locally.

FortiGuard Filtering Protocol

Select the protocol for contacting the FortiGuard servers.

FortiGuard Filtering Port

Select the port assignments for contacting the FortiGuard servers.

Filtering Service Availability

The status of the filtering service. Click Check Again if the filtering service is
not available.

Request re-evaluation of a
URL's category

Click to re-evaluate a URL category rating on the FortiGuard web filter service.

4. Click Apply.

To configure filtering in the CLI:
config system fortiguard
set protocol {https | udp | http}
set port {443 | 53 | 8888 |80}
set antispam-force-off {enable | disable}
set antispam-cache {enable | disable}
set antispam-cache-ttl <integer>
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set
set
set
set
set
set

antispam-cache-mpercent <percent>
antispam-timeout <integer>
webfilter-force-off {enable | disable}
webfilter-cache {enable | disable}
webfilter-cache-ttl <integer>
webfilter-timeout <integer>

end

FortiGuard server support for HTTPS on port 443 is supported as of FortiOS 6.2.2.

Override FortiGuard servers
By default, FortiOS will update signature packages and query rating servers using public FortiGuard servers. This list
can be overridden by adding servers to the override server list. Communication with public FortiGuard servers can also
be disabled.

To add an override FortiGuard server in the GUI:
1.
2.
3.
4.
5.
6.
7.

Go to System > FortiGuard
Scroll down to the Override FortiGuard Servers section.
In the table, click Create New. The Create New Override FortiGuard Server pane opens.
Select the server address type: IPv4, IPv6, or FQDN.
Enter the server address of the selected type in the Address field.
Select the type of server: AntiVirus & IPS Updates, Filtering, or Both.
Click Apply.

To add an override FortiGuard server in the CLI:
config system central-management
set type fortiguard
config server-list
edit <integer>
set server-type {update rating}
set server-address <ip_address>
next
end
end

Online security tools
FortiGuard Labs provides a number of online security tools, including but not limited to:
l

URL lookup
Enter a website address to see if it has been rated and what category and classification it is filed as. If you find a site
that has been wrongly categorized, use this page to request that the site be re-evaluated:
https://www.fortiguard.com/webfilter
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l

l

Threat Encyclopedia
Browse FortiGuard Labs extensive encyclopedia of threats. Search for viruses, botnet C&C, IPS, endpoint
vulnerabilities, and mobile malware: https://www.fortiguard.com/encyclopedia
Application Control
Browse FortiGuard Labs extensive encyclopedia of applications: https://www.fortiguard.com/appcontrol

FortiGuard third party SSL validation and anycast support
You can enable anycast to optimize the routing performance to FortiGuard servers. Relying on Fortinet DNS servers, the
FortiGate will get a single IP address for the domain name of each FortiGuard service. BGP routing optimization is
transparent to the FortiGate. The domain name of each FortiGuard service is the common name in that service's
certificate. The certificate is signed by a third party intermediate CA. The FortiGuard server uses the Online Certificate
Status Protocol (OCSP) stapling technique, so that the FortiGate can always validate the FortiGuard server certificate
efficiently.

To enable anycast in the FortiGuard settings:
config system fortiguard
set protocol https
set port 443
set fortiguard-anycast enable
set fortiguard-anycast-source fortinet
end

After anycast is enabled, the FortiGuard settings will enforce a connection using HTTPS and port 443.

HTTPS/443 is only supported on anycast servers. When fortiguard-anycast is disabled,
use HTTPS/8888 or HTTPS/53.

Connecting to the FortiGuard
The FortiGate will only complete the TLS handshake with a FortiGuard that provides a good OCSP status for its
certificate. Any other status will result in a failed SSL connection. OCSP stapling is reflected on the signature interval
(currently, 24 hours) so that good means that the certificate is not revoked at that timestamp. The FortiGuard servers
query the CA's OCSP responder every four hours and update its OCSP status. If the FortiGuard is unable to reach the
OCSP responder, it will keep the last known OCSP status for seven days. This cached OCSP status will be sent out
immediately when a client connection request is made, thus optimizing the response time.

The following steps are taken to connect to FortiGuard:
1. The FortiGate embeds the CA_bundle certificate, which includes the root CA with CRL list and third party
intermediate CA, in the root CA level.
2. The FortiGate finds the FortiGuard IP address from its domain name from DNS:
fds=qaupdate.fortinet.net-192.168.100.242

3. The FortiGate starts a TLS handshake with the FortiGuard IP address. The client hello includes an extension of the
status request.
4. The FortiGuard servers provide a certificate with its OCSP status: good, revoked, or unknown.
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5. The FortiGate verifies the CA chain against the root CA in the CA_bundle.
6. The FortiGate verifies the intermediate CA's revoke status against the root CA's CRL.
7. The FortiGate verifies the FortiGuard certificate's OCSP status:
OCSP Response Data:
OCSP Response Status: successful (0x0)
Response Type: Basic OCSP Response
Version: 1 (0x0)
Responder Id: 3DD350A5D6A0ADEEF34A600A65D321D4F8F8D60F
Produced At: Aug 20 07:50:58 2019 GMT
Responses:
Certificate ID:
Hash Algorithm: sha1
Issuer Name Hash: 49F4BD8A18BF760698C5DE402D683B716AE4E686
Issuer Key Hash: 3DD350A5D6A0ADEEF34A600A65D321D4F8F8D60F
Serial Number: 02555C9F3901B799DF1873402FA9392D
Cert Status: good
This Update: Aug 20 07:50:58 2019 GMT
Next Update: Aug 27 07:05:58 2019 GMT

Using FortiManager as local FortiGuard server
FortiManager can provide a local FortiGuard server with port 443 access.
Anycast FortiGuard settings force the rating process to use port 443, even with an override server. Using a unique
address in the same subnet as the FortiManager access IP address, the FortiManager can provide local FortiGuard
updates and rating access with a dedicated IP address and port 443.

To use a FortiManager as a local FortiGuard server:
config system central-management
set type fortimanager
set fmg "172.18.37.148"
config server-list
edit 1
set server-type update
set server-address 172.18.37.150
next
edit 2
set server-type rating
set server-address 172.18.37.149
next
end
set fmg-update-port 443
set include-default-servers enable
end

When fmg-update-port is set to 443, the update process will use port 443 to connect to the override update server,
which is the local FortiGuard server in the FortiManager. If this is not set, the update process will use port 8890, and the
server address setting has to be the FortiManager access IP address. Override FortiGuard services come from the
server list that is the local FortiGuard server in the FortiManager, and use the traditional, non-OCSP TLS handshake. If
override servers in the FortiManager are not available, the default FortiGuard servers are connected, and the anycast
OCSP TLS handshake is used.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

549

System

Advanced
The following topics provide information about advanced system settings options:
l
l

Configuration scripts on page 550
Workspace mode on page 552

Configuration scripts
Configuration scripts are text files that contain CLI command sequences. They can be created using a text editor,
entered directly in the CLI, copied from a CLI console, or recorded using the CLI Console Record CLI Script function.
Scripts can be scheduled to run at specific intervals a specified number of numbers, or uploaded, run once, and then
deleted. Scheduled scripts can only be created using the CLI, but can be run, stopped, deleted, and downloaded from
the GUI.
Scripts can be used to run the same task on multiple devices. For example, if your devices use the same security
policies, you can enter or record the commands to create those policies in a script, and then run the script on each
device. You could also create the policies in the GUI, and then copy and paste the CLI commands from the CLI Console
using the show command.
If the FortiGate is managed by FortiManager, scripts can be uploaded to FortiManager and then run on any other
FortiGates that are managed by that FortiManager. See Scripts in the FortiManager Administration Guide.

A comment line in a script starts with the number sign (#). Comments are not be executed.

To run a script using the GUI:
1.
2.
3.
4.

Go to System > Advanced.
Expand Configuration Scripts.
Click Upload and Run a New Script.
Locate the text file containing the script on your management computer, then click Open.
The script runs immediately, and the Script Execution History table is updated, showing if the script ran
successfully.
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To add a script to backup the configuration to a TFTP server every five minutes:
config system auto-script
edit "backup"
set interval 300
set repeat 0
set start auto
set script "execute backup config tftp backup.conf 10.10.10.2"
next
end

To add a script to backup the configuration of a FortiGate with VDOMs enabled to a FTP server every ten
minutes for the next hour:
config system auto-script
edit "backup"
set interval 600
set repeat 7
set start auto
set script "
config global
execute backup config ftp BackupFile.conf 10.10.10.2 username password"
next
end

To add a script to get the system status and performance every seven minutes using up to 20MB of
storage:
config system auto-script
edit "status"
set interval 420
set repeat 0
set start auto
set output-size 20
set script "
get system status
get system performance status"
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next
end

To stop a scheduled script:
1. Go to System > Advanced.
2. In the Scheduled Scripts area, locate the script, then click the Stop Running Scheduled Script icon.
The Status changes to Not Running, and the Run Scheduled Script icon becomes available.

To view the results of a scheduled script:
1. Go to System > Advanced.
2. In the Scheduled Scripts area, locate the script, then click the Download Scheduled Script Running Result icon.
3. Save the .OUT file to the management computer, or open it directly in a text editor.

Workspace mode
Workspace mode allows administrators to make a batch of changes that are not implemented until the transaction is
committed. Prior to committing, the changes can be reverted or edited as needed without impacting current operations.
When an object is edited in workspace mode it is locked, preventing other administrators from editing that object. A
warning message will be shown to let the administrator know that the object is currently being configured in another
transaction.
All administrators can use workspace mode; their permissions in workspace mode are the same as defined in their
account profile.
A workspace mode transaction times out after five minutes if there is no activity. When a transaction times out, all
changes are discarded. A warning message will be shown to let the administrator know that a timeout is imminent, or has
already happened:
config
config
config
config

transaction
transaction
transaction
transaction

id=1
id=1
id=1
id=1

will expire in 30 seconds
will expire in 20 seconds
will expire in 10 seconds
has expired

The following commands are not changeable in a workspace transaction:
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config
config
config
config
set
set
set
set
set
end
config
set
end
config
config
config
set
end
config
config

system console
system resource-limits
system elbc
system global
split-port
vdom-admin
management-vdom
wireless-mode
internal-switch-mode
system settings
opmode
system npu
system np6
system wireless
mode
system vdom-property
system storage

The execute batch command cannot be used in or to start workspace mode.

To use workspace mode:
1. Start workspace mode:
execute config-transaction

Once in workspace mode, the administrator can make configuration changes, all of which are made in a local CLI
process that is not viewable by other processes.
2. Commit configuration changes:
execute config-transaction commit

After performing the commit, the changes are available for all other processes, and are also made in the kernel.
3. Abort configuration changes:
execute config-transaction abort

If changes are aborted, no changes are made to the current configuration or the kernel.

Diagnose commands
diagnose sys config-transaction show txn-meta

Show config transaction meta information. For example:
# diagnose sys config-transaction show txn-meta
txn_next_id=8, txn_nr=2
diagnose sys config-transaction show txn-info

Show config transaction information. For example:
# diagnose sys config-transaction show txn-info
current_jiffies=680372
txn_id=6, expire_jiffies=706104, clicmd_fpath='/dev/cmdb/txn/6_EiLl9G.conf'
txn_id=7, expire_jiffies=707427, clicmd_fpath='/dev/cmdb/txn/7_UXK6wY.conf'
diagnose sys config-transaction show txn-entity

Show config transaction entity. For example:
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# diagnose sys config-transaction show txn-entity
vd='global', cli-node-oid=37(system.vdom), txn_id=7. location: fileid=0, storeid=0,
pgnr=0, pgidx=0
vd='global', cli-node-oid=46(system.interface), txn_id=7. location: fileid=3,
storeid=0, pgnr=0, pgidx=0
diagnose sys config-transaction show txn-lock

Show transaction lock status. For example:
# diagnose sys config-transaction show txn-lock
type=-1, refcnt=0, value=256, pid=128
diagnose sys config-transaction status

Show the transaction status in the current CLI.

Feature visibility
Feature visibility is used to control which features are visible in the GUI. This allows features that are not in use to be
hidden. Some features are also invisible by default and must be made visible before they can be configure in the GUI.
The visibility of a feature does not affect its functionality or configuration. Invisible features can still be configured using
the CLI.

To change the visibility of features:
1. Go to System > Feature Visibility.
2. Change the visibility of the features as required. To simplify setting security features, a feature set can be selected
from the dropdown list.
For information about what settings each options affects, click on the + icon to the right of the feature name.
Changes are listed on the right of the screen.
3. Click Apply.

Security feature presets
Six system presets are available:
l
l
l
l
l

l

l

NGFW: for networks that require application control and protection from external attacks.
ATP: for networks that require protection from viruses and other external threats.
WF: for networks that require web filtering.
NGFW + ATP: for networks that require protection from external threats and attacks.
UTM: for networks that require protection from external threats and wish to use security features that control
network usage. This is the default setting.
Full UTM: for networks that require the normal UTM features, as well as antivirus, application control, endpoint
control, and web filtering.
Custom should be chosen for networks that require customization of available features (including the ability to
select all features).
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Certificates
The following recipes provide instructions about certificates:
l

Microsoft CA deep packet inspection on page 555

Microsoft CA deep packet inspection
In most production environments, you want to use a certificate issued be your own PKI for deep packet inspection (DPI).
An existing Microsoft root CA can be used to issue a subordinate CA (sub CA) certificate that is installed as a DPI
certificate on the FortiGate.
Complete the following steps to create your own sub CA certificate and use it for DPI:
1.
2.
3.
4.
5.

Create a Microsoft sub CA certificate
Export the certificate and private key
Import the certificate and private key into the FortiGate
Configure a firewall policy for DPI
Verify that the sub CA certificate is being used for DPI

The FortiGate firewall uses information in the original web server certificate, then issues a new certificate signed by the
Microsoft DPI certificate. The FortiGate then sends this certificate with the issuing DPI certificate to the client's web
browser when the SSL session is being established.
The browser verifies that the certificate was issued by a valid CA, then looks for the issuing CA of the Microsoft DPI
certificate in its loca trusted root CA store to complete the path to trusted root CA.
The Microsoft CA root certificate is normally deployed to all client PCs in the Windows domain, so the client can
complete the certificate path up to a trusted root CA. The FortiGate now controlsand can inspect the two HTTPS
sessions: one with the external web server, and one with the client PC.

Create a Microsoft sub CA certificate
A Microsoft sub CA certificate can be created on a Microsoft CA server, or remotely using a web browser.
Creating a certificate remotely requires that the web enrollment option is configured on the Microsoft CA server. Remote
certificate requests require HTTPS; requests are not allowed with HTTP.

To create a Microsoft sub CA certificate remotely:
1. Open a web browser and go to one of the following URLs:
l https://<FQDN-CA-server>/CertSrv
l https://<IP-CA-server>/CertSrv.
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2. Log in to a domain administrator account that has web enrollment rights.

3. Click Request a certificate.
4. Click advanced certificate request.

5.
6.
7.
8.

Click Create and submit a request to this CA, then click Yes in the Web Access Confirmation warning.
For the Certificate Template, select Subordinate Certification Authority.
Enable Mark keys as exportable.
Fill out the remaining information according to your security policy.

9. Submit the request.
10. Click Yes in the Web Access Confirmation warning.
11. Click Install this certificate.
The certificate and private key are located in the current user's certificate store.
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Export the certificate and private key
To export the certificate and private key:
1. Open the Microsoft Management Console (MMC) and add the Certificate Snap-in.
2. Go to the user's certificate store to locate the sub CA certificate that you just installed.

3. Right-click on the certificate and select All Tasks > Export.
4. Click Next to start the Microsoft Certificate Export Wizard.
5. Follow the steps in the wizard:
l When asked, select Yes, export the private key.
l Only the PKCS #12 (.PFX) format is available, and it requires a password.
l When selecting the encryption type, select TripleDES-SHA1 if you are using an older version of FortiOS (5.6.9
and earlier). Otherwise, select AES256-SHA256.

6. Complete the wizard, and save the DPI certificate to a local folder.

Import the certificate and private key into the FortiGate
The certificate can be imported from the local computer using the GUI, or from a TFTP server using the CLI.
After importing the certificate, you can view it in the GUI to verify that it was successfully imported.

To import the certificate and private key into the FortiGate in the GUI:
1.
2.
3.
4.
5.

Go to System > Certificates.
Select Import > Local Certificate.
Set Type to PKCS #12 Certificate.
Click Upload and locate the certificate file.
Enter the Password.
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6. Optionally, modify the Certificate Name.

7. Click OK.

To import the certificate and private key into the FortiGate in the CLI:
execute vpn certificate local import <certificate file name> <tftp ip address> <password>

To verify that the certificate was imported:
1. Go to System > Certificates.
2. Locate the newly imported certificate in the table.
3. Select the certificate and click View Details to view the certificate details.

Configure a firewall policy for DPI
The certificate is used in an SSL/SSH inspection profile that is then used in a firewall policy.
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To configure a firewall policy for DPI:
1. Go to Security Profiles > SSL/SSH Inspection.
2. Click Create New.
3. Configure the inspection profile, selecting the new certificate

4.
5.
6.
7.

Click Apply.
Go to Policy & Objects > IPv4 Policy.
Create a new policy, or edit an existing policy.
In the SSL Inspection field, select the new SSL inspection profile.

8. Configure the remaining settings as needed.
9. Click OK.
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Verify that the sub CA certificate is being used for DPI
You can verify that the certificate is being used for resigning web server certificates when a user connects to an external
HTTPS website.

To verify that the certificate is being used:
1. On a client PC that is behind the FortiGate, go to an external HTTPS website.
When connecting to the website, no certificate warning should be shown.
2. In your web browser, view the certificate and certificate path.
The methods for doing this vary depending on the browser. See your browsers documentation for information.

Purchase and import a signed SSL certificate
A signed SSL certificate can be used when configuring SSL VPN, for administrator GUI access, and for other functions
that require a certificate.

Before creating a certificate, you must have a registered domain.

Follow these instructions to purchase, import, and use a signed SSL certificate:
l
l
l
l

Purchase, setup, and download an SSL certificate package from a certificate authority
Generate a CSR
Import the signed certificate into your FortiGate
Configure your FortiGate device to use the signed certificate

Purchase, setup, and download an SSL certificate package from a certificate authority
SSL certificate packages can be purchased from any Certificate Authority (CA), such as DigiCert, GoDaddy, or
GlobalSign.

A third party CA might not sign a certificate with an intranet name or IP address. For details,
see Can I request a certificate for an intranet name or IP address?

The process for purchasing, setting up, and downloading a certificate will vary depending on the CA that is used, and if a
CSR must be generated on the FortiGate.

To purchase a certificate package:
1. Create an account with your chosen vendor, or use the account that you used to purchase your domain.
2. Locate the SSL Certificates page.
3. Purchase a basic SSL certificate for domain validation only. If required, a more secure SSL certificate can be
purchased.
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4. If required, load the CSR, either by uploaded the text file or copying and pasting the contents into the requisite text
box. See Generate a CSR on page 561 for information on generating the CSR on the FortiGate.
5. If required, set the server type to Other.
6. Verify the certificate per the requirements of the CA.
7. Download the signed certificate to your computer.
8. Import the signed certificate into your FortiGate; see Import the signed certificate into your FortiGate on page 562.

Generate a CSR
Some CAs can auto-generate the CSR during the signing process, or provide tools for creating CSRs. If necessary, a
CSR can be created in your FortiGate device’s GUI.

To generate a CSR on your FortiGate:
1. Go to System > Certificates. By default, the Certificate option is not visible, see Feature visibility on page 554 for
information.
2. Click Generate. The Generate Certificate Signing Request page opens.

3. Configure the CSR request:
l Ensure that the certificate has a unique name.
l Set the ID Type to Domain Name and enter a Domain Name.
l An email address is required.
l Ensure that the Key Size is set to 2048 Bit.
l Set the Enrollment Method to File Based.
4. Click OK.
The CSR will be added to the certificate list with a status of PENDING.
5. In the certificate list, select the new CSR then click Download to save the CSR to your computer.
The CSR file can be opened in any text editor, and will resemble the following:
-----BEGIN CERTIFICATE REQUEST----MIICuTCCAaECAQAwSzEcMBoGA1UEAxMTZm9ydGlzc2x2cG5kZW1vLmNvbTErMCkG
CSqGSIb3DQEJARYcZm9ydGlzc2x2cG5kZW1vQGZvcnRpbmV0LmNvbTCCASIwDQYJ
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-----END CERTIFICATE REQUEST-----

Import the signed certificate into your FortiGate
To import the signed certificate into your FortiGate:
1. Unzip the file downloaded from the CA.
There should be two CRT files: a CA certificate with bundle in the file name, and a local certificate.
2. Log in to your FortiGate unit and go to System > Certificates.
3. Click Import > Local Certificate.

4.
5.
6.
7.

Upload the local certificate file, then click OK.
The status of the certificate will change from PENDING to OK.
Click Import > CA Certificate.
Set the Type to File, upload the CA certificate file, then click OK.
The CA certificate will be listed in the CA Certificates section of the certificates list.

Configure your FortiGate device to use the signed certificate
After the signed certificates have been imported, you can use it when configuring SSL VPN, for administrator GUI
access, and for other functions that require a certificate.

To configure your FortiGate to use the signed certificate for SSL VPN:
1. Go to VPN > SSL-VPN Settings.
2. Set Server Certificate to the new certificate.
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3. Configure other settings as needed.
4. Click Apply.
For more information on configuring SSL VPN, see SSL VPN on page 1091 and the Setup SSL VPN video in the Fortinet
Video Library.

To configure using the certificate for administrator GUI access in the CLI:
config system global
set admin-server-cert fortisslvpndemo
end

To change the certificate that is used for administrator GUI access in the GUI:
1. Go to System > Settings.
2. In the Administration Settings section, change HTTPS server certificate as needed.
3. Click Apply. You will be logged out of FortiOS.
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Policies
The firewall policy is the axis around which most features of the FortiGate revolve. Many firewall settings end up relating
to or being associated with the firewall policies and the traffic they govern. Any traffic going through a FortiGate has to be
associated with a policy. These policies are essentially discrete compartmentalized sets of instructions that control the
traffic flow going through the firewall. These instructions control where the traffic goes, how it is processed, if it is
processed, and whether or not it is allowed to pass through the FortiGate.
When the firewall receives a connection packet, it analyzes the source address, destination address, and service (by
port number). It also registers the incoming interface, the outgoing interface it needs to use, and the time of day. Using
this information, the FortiGate firewall attempts to locate a security policy that matches the packet. If a policy matches
the parameters, then the FortiGate takes the required action for that policy. If it is Accept, the traffic is allowed to proceed
to the next step. If the action is Deny or a match cannot be found, the traffic is not allowed to proceed.
The two basic actions at the initial connection are either Accept or Deny:
l

l

If the action is Accept, the policy permits communication sessions. There may be other packet processing
instructions, such as requiring authentication to use the policy or restrictions on the source and destination of the
traffic.
If the action is Deny, the policy blocks communication sessions, and you can optionally log the denied traffic. If no
security policy matches the traffic, the packets are dropped. A Deny security policy is needed when it is required to
log the denied traffic, also called violation traffic.

One other action can be associated with the policy:
l

IPsec—this is an Accept action that is specifically for IPsec VPNs.

The following topics provide instructions on configuring policies:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

Firewall policy parameters on page 565
Profile-based NGFW vs policy-based NGFW on page 565
NGFW policy mode application default service on page 570
Policy views and policy lookup on page 572
Policy with source NAT on page 574
Policy with destination NAT on page 583
Policy with Internet Service on page 596
NAT64 policy and DNS64 (DNS proxy) on page 610
NAT46 policy on page 614
Multicast processing and basic Multicast policy on page 617
Local-in policies on page 619
IPv4/IPv6 access control lists on page 620
Mirroring SSL traffic in policies on page 621
Inspection mode per policy on page 622
Combined IPv4 and IPv6 policy on page 624
FortiGuard DNS filter for IPv6 policies on page 626
OSPFv3 neighbor authentication on page 627
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l
l
l
l
l
l
l
l
l

Firewall anti-replay option per policy on page 629
Enabling advanced policy options in the GUI on page 630
Recognize anycast addresses in geo-IP blocking on page 631
Authentication policy extensions on page 632
NTLM extensions on page 633
HTTP to HTTPS redirect for load balancing on page 636
GTPv2 in policies on page 637
Use active directory objects directly in policies on page 639
FortiGate Cloud / FDN communication through an explicit proxy on page 642

Firewall policy parameters
For traffic to flow through the FortiGate firewall, there must be a policy that matches its parameters:
l
l
l
l
l
l
l
l

Incoming interface(s)
Outgoing interface(s)
Source address(es)
User(s) identity
Destination address(es)
Internet service(s)
Schedule
Service

Without all six (possibly eight) of these things matching, the traffic is declined.
Traffic flow initiated from each direction requires a policy, that is, if sessions can be initiated from both directions, each
direction requires a policy.
Just because packets can go from point A to point B on port X does not mean that the traffic can flow from point B to point
A on port X. A policy must be configured for each direction.
When designing a policy, there is often reference to the traffic flow, but most communication is two-way so trying to
determine the direction of the flow might be confusing. If traffic is HTTP web traffic, the user sends a request to the
website, but most of the traffic flow will be coming from the website to the user or in both directions? For the purposes of
determining the direction for a policy, the important factor is the direction of the initiating communication. The user is
sending a request to the website, so this is the initial communication; the website is responding so the traffic is from the
user's network to the Internet.
FortiOS does not perform a reverse-path check on reply traffic that matches an allowed
session based on the IP tuple. The request traffic can be sent on one interface and the reply
traffic could return on another interface.

Profile-based NGFW vs policy-based NGFW
Profile-based next-generation firewall (NGFW) mode is the traditional mode where you create a profile (antivirus, web
filter, and so on) and then apply the profile to a policy.
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In policy-based NGFW mode, you allow applications and URL categories to be used directly in security policies, without
requiring web filter or application control profiles.
In policy-based mode:
l

l

Central NAT is always enabled. If no Central SNAT policy exists, you must create one. See Central SNAT on page
580 for more information.
Pre-match rules are defined separately from security policies, and define broader rules, such as SSL inspection and
user authentication.

If your FortiGate operates in NAT mode, rather than enabling source NAT in individual NGFW policies, go to Policy &
Objects > Central SNAT and add source NAT policies that apply to all matching traffic. In many cases, you may only
need one SNAT policy for each interface pair.
The NGFW mode is set per VDOM, and it is only available when the VDOM inspection mode is flow-based. You can
operate your entire FortiGate or individual VDOMs in NGFW policy mode.
Switching from profile-based to policy-based mode converts your policies to policy-based. To
avoid issues, you could create a new VDOM for the policy-based mode. We recommend
backing up your configuration before switching modes. See Configuration backups on page 59
for information.

Enabling policy-based NGFW mode
To enable policy-based NGFW mode without VDOMs in the GUI:
1. Go to System > Settings.
2. In NGFW Mode, select Policy-based.
3. Click Apply.

To enable policy-based NGFW mode with VDOMs in the GUI:
1.
2.
3.
4.

Go to System > VDOM .
Double-click a VDOM to edit the settings.
In NGFW Mode, select Policy-based.
Click OK.

To enable policy-based NGFW mode without VDOMs in the CLI:
config system settings
set ngfw-mode {profile-based | policy-based}
end

To enable policy-based NGFW mode with VDOMs in the CLI:
config vdom
edit <vdom>
config system settings
set ngfw-mode policy-based
end
next
end
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Security and firewall policies
Security policies work with firewall (or consolidated) policies to inspect traffic. To allow traffic from a specific user or user
group, both firewall and security policies must be configured. Traffic will match the firewall policy first. If the traffic is
allowed, packets are sent to the IPS engine for application, URL category, user, and user group match, and then, if
enabled, UTM inspection (antivirus, IPS, DLP, and email filter) is performed.
Firewall policies are used to pre-match traffic before sending the packets to the IPS engine:
l
l
l

There are no schedule or action options; traffic matching the policy is always redirected to the IPS engine.
SSL inspection, formerly configured in the VDOM settings, is configured in a firewall policy.
Users and user groups that require authentication must be configured in a firewall policy.

Security policies work with firewall policies to inspect traffic:
l
l
l
l

l

Applications and URL categories can be configured directly in the policy.
Users and user groups that require authentication must also be configured in a security policy.
The available actions are Accept or Deny.
The Service option can be used to enforce the standard port for the selected applications. See NGFW policy mode
application default service on page 570 for details.
UTM inspection is configured in a security policy.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

567

Policy and Objects

To configure policies for Facebook and Gmail access is the CLI:
1. Configure a firewall policy:
config firewall consolidated policy
edit 1
set name "Policy-1"
set uuid b740d418-8ed3-51e9-5a7b-114e99ab6370
set srcintf "port18"
set dstintf "port17"
set srcaddr4 "all"
set dstaddr4 "all"
set service "ALL"
set ssl-ssh-profile "new-deep-inspection"
set groups "Dev" "HR" "QA" "SYS"
next
end

2. Configure security policies:
config firewall security-policy
edit 2
set uuid 364594a2-8ef1-51e9-86f9-32db9c2634b6
set name "allow-QA-Facebook"
set srcintf "port18"
set dstintf "port17"
set srcaddr4 "all"
set dstaddr4 "all"
set action accept
set schedule "always"
set application 15832
set groups "Dev" "QA"
next
edit 4
set uuid a2035210-8ef1-51e9-8b28-5a87b2cabcfa
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set
set
set
set
set
set
set
set
set

name "allow-QA-Email"
srcintf "port18"
dstintf "port17"
srcaddr4 "all"
dstaddr4 "all"
action accept
schedule "always"
url-category 23
groups "QA"

next
end

Logs
In the application control and web filter logs, securityid maps to the security policy ID.
Application control log:
date=2019-06-17 time=16:35:47 logid="1059028704" type="utm" subtype="app-ctrl"
eventtype="signature" level="information" vd="vd1" eventtime=1560814547702405829 tz="-0700"
appid=15832 user="Jack" group="QA" srcip=10.1.100.102 dstip=157.240.3.29 srcport=56572
dstport=443 srcintf="port18" srcintfrole="undefined" dstintf="port17"
dstintfrole="undefined" proto=6 service="P2P" direction="incoming" policyid=1
sessionid=42445 appcat="Social.Media" app="Facebook" action="pass" hostname="external-sea11.xx.fbcdn.net" incidentserialno=1419629662 url="/" securityid=2 msg="Social.Media:
Facebook," apprisk="medium" scertcname="*.facebook.com" scertissuer="DigiCert SHA2 High
Assurance Server CA"

Web filter log:
date=2019-06-17 time=16:42:41 logid="0317013312" type="utm" subtype="webfilter"
eventtype="ftgd_allow" level="notice" vd="vd1" eventtime=1560814961418114836 tz="-0700"
policyid=4 sessionid=43201 user="Jack" group="QA" srcip=10.1.100.102 srcport=56668
srcintf="port18" srcintfrole="undefined" dstip=172.217.3.165 dstport=443 dstintf="port17"
dstintfrole="undefined" proto=6 service="HTTPS" hostname="mail.google.com"
action="passthrough" reqtype="direct" url="/" sentbyte=709 rcvdbyte=0 direction="outgoing"
msg="URL belongs to an allowed category in policy" method="domain" cat=23 catdesc="Web-based
Email" securityid=4

Traffic logs:
date=2019-06-17 time=16:35:53 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="vd1" eventtime=1560814553778525154 tz="-0700" srcip=10.1.100.102
srcport=56572 srcintf="port18" srcintfrole="undefined" dstip=157.240.3.29 dstport=443
dstintf="port17" dstintfrole="undefined" poluuid="b740d418-8ed3-51e9-5a7b-114e99ab6370"
sessionid=42445 proto=6 action="server-rst" user="Jack" group="QA" policyid=1
policytype="consolidated" centralnatid=1 service="HTTPS" dstcountry="United States"
srccountry="Reserved" trandisp="snat" transip=172.16.200.2 transport=56572 duration=6
sentbyte=276 rcvdbyte=745 sentpkt=5 rcvdpkt=11 appid=15832 app="Facebook"
appcat="Social.Media" apprisk="medium" utmaction="allow" countapp=1 utmref=65531-294
2: date=2019-06-17 time=16:47:45 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="vd1" eventtime=1560815265058557636 tz="-0700" srcip=10.1.100.102
srcport=56668 srcintf="port18" srcintfrole="undefined" dstip=172.217.3.165 dstport=443
dstintf="port17" dstintfrole="undefined" poluuid="b740d418-8ed3-51e9-5a7b-114e99ab6370"
sessionid=43201 proto=6 action="timeout" user="Jack" group="QA" policyid=1
policytype="consolidated" centralnatid=1 service="HTTPS" dstcountry="United States"
srccountry="Reserved" trandisp="snat" transip=172.16.200.2 transport=56668 duration=303
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sentbyte=406 rcvdbyte=384 sentpkt=4 rcvdpkt=4 appcat="unscanned" utmaction="allow"
countweb=1 utmref=65531-3486

Other NGFW policy-based mode options
You can combine Application Control and Web Filter in the same NGFW mode policy. If the policy accepts applications
or URL categories, you can also apply AntiVirus, DNS Filter, IPS profiles, and logging options.

NGFW policy mode application default service
In NGFW policy-based mode, the application default service enforces applications running only on their default service
port. The applications specified in the policy are monitored, and if traffic is detected from a nonstandard port, it is
blocked, and a log entry is recorded with a port-violation event type.
If you are not using the default ports, and need to pick specific services, select Specify to select the required services.

Example
In this example, the standard port is enforced for HTTPS traffic using the HTTP.Audio application.
First, a firewall policy is created do to traffic pre-match, and then a security policy is created to allow the HTTP.Audio
application when using the default port. Fetching an MP3 file from an HTTP server using port 443 is allowed, but is
blocked when using a nonstandard port, such as 8443.

To enforce the HTTP.Audio application using the default port in the GUI:
1.
2.
3.
4.
5.
6.
7.

Create a firewall policy.
Go to Policy & Objects > Security Policy, and click Create New.
Enter a name for the policy, such as allow_HTTP.Audio.
Configure the ports as needed.
Set Service to App Default.
In the Application field, select HTTP.Audio.
Set the Action to Accept.
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8. Click OK.

To enforce the HTTP.Audio application using the default port in the CLI:
1. Create a firewall policy:
config firewall consolidated policy
edit 1
set name "consolidated_all"
set srcintf "port13"
set dstintf "port14"
set srcaddr4 "all"
set dstaddr4 "all"
set service "ALL"
set ssl-ssh-profile "new-deep-inspection"
next
end

2. Create a security policy:
config firewall security-policy
edit 1
set name "allow_HTTP.Audio"
set srcintf "port13"
set dstintf "port14"
set srcaddr4 "all"
set enforce-default-app-port enable
set action accept
set schedule "always"
set logtraffic all
set application 15879
next
end
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Logs
The application logs show logs with an event type of port-violation for traffic on port 8443 that is blocked, and an
event type of signature for traffic on port 443 that is allowed.
Blocked:
2: date=2019-06-18 time=16:15:40 logid="1060028736" type="utm" subtype="app-ctrl"
eventtype="port-violation" level="warning" vd="vd1" eventtime=1560899740218875746 tz="-0700"
appid=15879 srcip=10.1.100.22 dstip=172.16.200.216 srcport=52680 dstport=8443
srcintf="port13" srcintfrole="undefined" dstintf="port14" dstintfrole="undefined" proto=6
service="HTTPS" direction="incoming" policyid=1 sessionid=5041 appcat="Video/Audio"
app="HTTP.Audio" action="block" hostname="172.16.200.216" incidentserialno=1906780850
url="/app_data/story.mp3" securityid=2 msg="Video/Audio: HTTP.Audio," apprisk="elevated"

Allowed:
1: date=2019-06-18 time=16:15:49 logid="1059028704" type="utm" subtype="app-ctrl"
eventtype="signature" level="information" vd="vd1" eventtime=1560899749258579372 tz="-0700"
appid=15879 srcip=10.1.100.22 dstip=172.16.200.216 srcport=54527 dstport=443
srcintf="port13" srcintfrole="undefined" dstintf="port14" dstintfrole="undefined" proto=6
service="HTTPS" direction="incoming" policyid=1 sessionid=5064 appcat="Video/Audio"
app="HTTP.Audio" action="pass" hostname="172.16.200.216" incidentserialno=1139663486
url="/app_data/story.mp3" securityid=2 msg="Video/Audio: HTTP.Audio," apprisk="elevated"

Policy views and policy lookup
This topic provides a sample of firewall policy views and firewall policy lookup.

Policy views
In Policy & Objects policy list page, there are two policy views: Interface Pair View and By Sequence view.
Interface Pair View displays the policies in the order that they are checked for matching traffic, grouped by the pairs of
Incoming and Outgoing interfaces. For example, all policies referencing traffic from WAN1 to DMZ are in one section.
The policies referencing traffic from DMZ to WAN1 are in another section. The sections are collapsible so that you only
need to look at the sections you want.

By Sequence displays policies in the order that they are checked for matching traffic without any grouping.
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The default display is Interface Pair View. You can switch between the two views except if any or multiple-interfaces are
applied in the policy.

How Any or multiple-interfaces policy can change the Interface Pair View
The FortiGate unit automatically changes the view on the policy list page to By Sequence whenever there is a policy
containing any or multiple-interfaces as the Source or Destination interface. If the Interface Pair View is grayed out, it is
likely that one or more policies have used the any or multiple-interfaces.
When you use the any or multiple-interfaces, the policy goes into multiple sections because it might be any one of a
number of interface pairings. Policies are divided into sectioned using the interface pairings, for example, port1 to port2.
Each section has its own policy order. The order in which a policy is checked for matching criteria to a packet’s
information is based solely on the position of the policy within its section or within the entire list of policies. If the policy is
in multiple sections, FortiGate cannot place the policy in order in multiple sections. Therefore the view can only be By
Sequence.

Policy lookup
Firewall policy lookup is based on the Source_interfaces/Protocol/Source_Address/Destination_
Address that matches the source-port and dst-port of the protocol. Use this tool to find out which policy matches
specific traffic from a number of policies. After completing the lookup, the matching firewall policy is highlighted on the
policy list page.
The Policy Lookup tool has the following requirements:
l
l

Transparent mode does not support Policy lookup function.
When executing the policy lookup, you need to confirm whether the relevant route required for the policy work
already exists.

Sample configuration
This example uses the TCP protocol to show how policy lookup works:
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1. In Policy & Objects policy list page, click Policy Lookup and enter the traffic parameters.

2. Click Search to display the policy lookup results.

Policy with source NAT
The following recipes provide instructions on configuring policies with source NAT:
l
l
l

Static SNAT on page 574
Dynamic SNAT on page 575
Central SNAT on page 580

Static SNAT
Network Address Translation (NAT) is the process that enables a single device such as a router or firewall to act as an
agent between the Internet or Public Network and a local or private network. This agent acts in real time to translate the
source or destination IP address of a client or server on the network interface. For the source IP translation, this enables
a single public address to represent a significantly larger number of private addresses. For the destination IP translation,
the firewall can translate a public destination address to a private address. So we don't have to configure a real public IP
address for the server deployed in a private network.
We can subdivide NAT into two types: source NAT (SNAT) and destination NAT (DNAT). This topic is about SNAT, We
support three NAT working modes: static SNAT, dynamic SNAT, and central SNAT.
In static SNAT all internal IP addresses are always mapped to the same public IP address. This is a port address
translation, Since we have 60416 available port numbers, this one public IP address can handle the conversion of
60,416 internal IP addresses. See example below.
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FortiGate firewall configurations commonly use the Outgoing Interface address.

Sample configuration
The following example of static SNAT uses an internal network with subnet 10.1.100.0/24 (vlan20) and an external/ISP
network with subnet 172.16.200.0/24 (vlan30).
When the clients in internal network need to access the servers in external network, We need to translate IP addresses
from 10.1.100.0/24 to an IP address 172.16.200.0/24, In this example, we implement static SNAT by creating a firewall
policy.

To configure static NAT:
1.
2.
3.
4.

In Policy & Objects > IPv4 Policy, click Create New.
Enter the required policy parameters.
Enable NAT and select Use Outgoing Interface Address.
If needed, enable Preserve Source Port.
Enable Preserve Source Port to keep the same source port for services that expect traffic to come from a specific
source port.
Disable Preserve Source Port to allow more than one connection through the firewall for that service.

For packets that match this policy, its source IP address is translated to the IP address of the outgoing interface.

Dynamic SNAT
Dynamic SNAT maps the private IP addresses to the first available public address from a pool of addresses. In the
FortiGate firewall, this can be done by using IP pools. IP pools is a mechanism that allows sessions leaving the FortiGate
firewall to use NAT. An IP pool defines a single IP address or a range of IP addresses to be used as the source address
for the duration of the session. These assigned addresses are used instead of the IP address assigned to that FortiGate
interface.

IP pool types
FortiGate uses four types of IPv4 IP pools. This recipe focuses on some of the differences between them.
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Overload
This type of IP pool is similar to static SNAT mode. We need to define an external IP range that contains one or more IP
addresses. When there is only one IP address it is almost the same as static SNAT, the outgoing interface address is
used. When it contains multiple IP addresses, it is equivalent to an extended mode of static SNAT.
For instance, if we define an overload type IP pool with two external IP addresses (172.16.200.1—172.16.200.2), since
there are 60,416 available port numbers per IP, this IP pool can handle 60,416*2 internal IP addresses.

The mapped IP address can be calculated from the source IP address. The index number of the address in the pool is
the remainder of the source IP address, in decimal, divided by the number addresses in the pool.
To calculate the decimal value of the source IP address, either use an online calculator, or use
the following equation:
a.b.c.d = a * (256)3 + b * (256)2 + c * (256) + d
For example:
192.168.0.1 = 192 * (256)3 + 168 * (256)2 + 0 * (256) + 1 = 3232235521
If there is one IP pool, where:
l
l
l
l

P1 = the first address in the IP pool
R1 = the number of IP addresses in the IP pool
X = the source IP address as a decimal number
Y = the mapped IP address

Then the equation to determine the mapped address is:
Y = P1 + X mod R1
For example:

IP pool

Source IP address

172.26.73.20 to 172.26.73.90

192.168.1.200

1. Convert the source IP address to a decimal number:
192 * (256)3 + 168 * (256)2 + 1 * (256) + 200 = 3232235976
2. Determine the number of IP addresses in the pool:
172.26.73.90 - 172.26.73.20 = 71
3. Find the remainder of the source IP address divided by the number of addresses in the pool:
3232235976 mod 71 = 26
4. Add the remainder to the first IP address in the pool:
172.26.73.20 + 26 = 172.26.73.46
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So, the mapped IP address is 172.26.73.46.
If there are multiple IP pools, the calculation is similar to when there is only one pool.
If there are two IP pools, where:
l
l
l
l
l
l

P1 = the first address in the first IP pool
P2 = the first address in the second IP pool
R1 = the number of IP addresses in the first IP pool
R2 = the number of IP addresses in the second IP pool
X = the source IP address as a decimal number
Y = the mapped IP address

Then the equations to determine the mapped address are:
If X mod (R1 + R2) >= R1, then Y = P2 + X mod R2
If X mod (R1 + R2) < R1, then Y = P1 + X mod R1
For example:

IP pools

Source IP address

pool01: 172.26.73.20 to 172.26.73.90

192.168.1.200

pool02: 172.26.75.50 to 172.26.75.150
1. Convert the source IP address to a decimal number:
192 * (256)3 + 168 * (256)2 + 1 * (256) + 200 = 3232235976
2. Determine the total number of IP addresses in the pools:
(172.26.73.90 - 172.26.73.20) + (172.26.75.50 - 172.26.75.150) = 71 + 101 = 172
3. Find the remainder of the source IP address divided by the number of addresses in the pools:
3232235976 mod 172 = 108
4. The remainder is greater than the number of addresses in pool01, so the address is selected from pool02 and the
remainder is recalculated based only on pool02:
3232235976 mod 101 = 40
5. Add the new remainder to the first IP address in pool02:
172.26.75.50 + 40 = 172.26.75.90
So, the mapped IP address is 172.26.75.90.

One-to-one
This type of IP pool means that the internal IP address and the external (translated) IP address match one-to-one. The
port address translation (PAT) is disabled when using this type of IP pool. For example, if we define a one-to-one type IP
pool with two external IP addresses (172.16.200.1 - 172.16.200.2), this IP pool only can handle two internal IP
addresses.

Fixed port range
For the overload and one-to-one IP pool types, we do not need to define the internal IP range. For the fixed port range
type of IP pool, we can define both internal IP range and external IP range. Since each external IP address and the
number of available port numbers is a specific number, if the number of internal IP addresses is also determined, we can
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calculate the port range for each address translation combination. So we call this type fixed port range. This type of IP
pool is a type of port address translation (PAT).
For instance, if we define one external IP address (172.16.200.1) and ten internal IP addresses (10.1.100.110.1.100.10), we have translation IP+Port combination like following table:

Port block allocation
This type of IP pool is also a type of port address translation (PAT). It gives users a more flexible way to control the way
external IPs and ports are allocated. Users need to define Block Size/Block Per User and external IP range. Block Size
means how many ports each Block contains. Block per User means how many blocks each user (internal IP) can use.
The following is a simple example:
l
l
l

External IP Range: 172.16.200.1—172.16.200.1
Block Size: 128
Block Per User: 8

Result:
l
l
l

Total-PBAs: 472 (60416/128)
Maximum ports can be used per User (Internal IP Address): 1024 (128*8)
How many Internal IP can be handled: 59 (60416/1024 or 472/8)

Sample configuration
To configure overload IP pool in the GUI:
1. In Policy & Objects > IP Pools, click Create New.
2. Select IPv4 Pool and then select Overload.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

578

Policy and Objects

To configure overload IP pool in the CLI:
config firewall ippool
edit "Overload-ippool"
set startip 172.16.200.1
set endip 172.16.200.1
next
end

To configure one-to-one IP pool using the GUI:
1. In Policy & Objects > IP Pools, click Create New.
2. Select IPv4 Pool and then select One-to-One.

To configure one-to-one IP pool in the CLI:
config firewall ippool
edit "One-to-One-ippool"
set type one-to-one
set startip 172.16.200.1
set endip 172.16.200.2
next
end

To configure fixed port range IP pool in the GUI:
1. In Policy & Objects > IP Pools, click Create New.
2. Select IPv4 Pool and then select Fixed Port Range.

To configure fixed port range IP pool in the CLI:
config firewall ippool
edit "FPR-ippool"
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set
set
set
set
set

type fixed-port-range
startip 172.16.200.1
endip 172.16.200.1
source-startip 10.1.100.1
source-endip 10.1.100.10

next
end

To configure port block allocation IP pool in the GUI:
1. In Policy & Objects > IP Pools, click Create New.
2. Select IPv4 Pool and then select Port Block Allocation.

To configure port block allocation IP pool in the CLI:
config firewall ippool
edit PBA-ippool
set type port-block-allocation
set startip 172.16.200.1
set endip 172.16.200.1
set block-size 128
set num-blocks-per-user 8
next
end

Central SNAT
The central SNAT table enables you to define and control (with more granularity) the address translation performed by
FortiGate. With the NAT table, you can define the rules for the source address or address group, and which IP pool the
destination address uses.
While similar in functionality to IP pools where a single address is translated to an alternate address from a range of IP
addresses, with IP pools there is no control over the translated port. When using the IP pool for source NAT, you can
define a fixed port to ensure the source port number is unchanged. If no fixed port is defined, the port translation is
randomly chosen by FortiGate. With the central NAT table, you have full control over both the IP address and port
translation.
FortiGate reads the NAT rules from the top down until it hits a matching rule for the incoming address. This enables you
to create multiple NAT policies that dictate which IP pool is used based on the source address. NAT policies can be
rearranged within the policy list. NAT policies are applied to network traffic after a security policy.
The central SNAT table allows you to create, edit, delete, and clone central SNAT entries.
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Central SNAT notes
l
l

l
l

l

l
l

The central NAT feature is not enabled by default.
If central NAT is enabled, the NAT option under IPv4 policies is skipped and SNAT must be done via centralsnat-map. The IPv4 policy list and dialog boxes have messages and redirection links to show this information.
If NGFW mode is policy-based, then it is assumed that central NAT (specifically SNAT) is enabled implicitly.
The option to toggle NAT in central-snat-map policies has been added. Previously it was only shown in NGFW
policy-based mode.
In the central SNAT policy dialog box, the port mapping fields for the original port have been updated to accept
ranges.
If per VDOM NAT is enabled, NAT is skipped in firewall policy.
The central SNAT window contains a table of all the central SNAT policies.

Sample configuration
To enable or disable central SNAT using the CLI:
config system settings
set central-nat [enable | disable]
end

When central NAT is enabled, Policy & Objects displays the Central SNAT section.

To create central SNAT using the GUI:
1. In Policy & Objects > Central SNAT.
The right pane displays a table of Central SNAT entries.
2. To create a new entry, click Create New in the right pane.
To edit an entry, double-click the policy you want to edit.
3. To set the Incoming Interface, click + in that field.
4. In the pane on the right, select an interface to add it.
You can select multiple interfaces.
5. To set the Outgoing Interface, click click + in that field.
6. In the pane on the right, select an interface to add it.
You can select multiple interfaces.
7. To set the Source Address, click click + in that field.
8. In the pane on the right, select an address to add it.
You can select multiple addresses.
9. To set the Destination Address, click click + in that field.
10. In the pane on the right, select an address to add it.
You can select multiple addresses.
11. In NAT > IP Pool Configuration, select either Use Outgoing Interface Address or Use Dynamic IP Pool.
If you select Use Dynamic IP Pool, click + and select which IP pool to use.
12. Select one of the following Protocol parameters.
l ANY. Use any protocol traffic.
l TCP. Use TCP traffic only. Protocol number is set to 6.
l UDP. Use UDP traffic only. Protocol number is set to 17.
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SCTP. Use SCTP traffic only. Protocol number is set to 132.
Specify. You can specify the traffic filter protocol by setting the protocol number.
13. If you use the Overload type of IP pool, you can enable Explicit Port Mapping.
a. If you enable Explicit Port Mapping, set the Original Source Port to the start number of the source port range.
b. Set the Translated Port to the start number of the translated port range.
14. Click OK.
l
l

To configure central SNAT using the CLI:
config firewall central-snat-map
edit <policyID number>set status [enable|disable]
set orig-addr <valid address object preconfigured on the FortiGate>
set srcintf <name of interface on the FortiGate>
set dst-addr <valid address object preconfigured on the FortiGate>
set dstintf <name of interface on the FortiGate>
set protocol <integer for protocol number>
set orig-port <integer for original port number>
set nat-port <integer for translated port number>
set comments <string>
end

To set NAT to be not available regardless of NGFW mode:
config firewall central-snat-map
edit 1
set orig-addr "192-86-1-86"
set srcintf "port23"
set dst-addr "192-96-1-96"
set dstintf "port22"
set nat-ippool "pool1"
set protocol 17
set orig-port 2896-2897
set nat enable
next
end

To hide NAT port if NAT IP pool is not set or if NAT is disabled:
config firewall central-snat-map
edit 1
set orig-addr "192-86-1-86"
set srcintf "port23"
set dst-addr "192-96-1-96"
set dstintf "port22"
set nat-ippool "pool1"
set protocol 17
set orig-port 2896-2897
set nat disable
next
end
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To change original port to accept range:
config firewall central-snat-map
edit 1
set orig-addr "192-86-1-86"
set srcintf "port23"
set dst-addr "192-96-1-96"
set dstintf "port22"
set nat-ippool "pool1"
set protocol 17
set orig-port 2896-2897 (help text changed to: Original port or port range).
set nat-port 35804-35805
next
end

Policy with destination NAT
The following recipes provide instructions on configuring policies with destination NAT:
l
l
l
l

Static virtual IPs on page 583
Virtual IP with services on page 584
Virtual IPs with port forwarding on page 586
Virtual server on page 588

Static virtual IPs
Mapping a specific IP address to another specific IP address is usually called Destination NAT (DNAT). When this
central NAT table is not used, FortiOS calls this a Virtual IP address (VIP). DNAT, or VIP, is are used to map an external
IP address to an IP address or address range. The mapping can include all TCP/UDP ports or, if port forwarding is
enabled, it only refers to the specific configured ports. As the central NAT table is disabled by default, the term VIP is
usually used.
VIPs are typically used to NAT external or public IP addresses to internal or private IP addresses. Using a VIP between
two internal interfaces made up of private IP addresses is possible, but rare, because the two networks can just use the
IP addresses of the networks without any address translation. Using a VIP for traffic going from the inside to the internet
is supported, but unlikely to be required.

Sample configuration
To create a virtual IP using the GUI:
1. In Policy & Objects > Virtual IPs.
2. Click Create New and select Virtual IP.
3. Select a VIP Type based on the IP versions used:
l If IPv4 is on both sides of the FortiGate unit, select IPv4.
l If IPv6 is on both sides of the FortiGate unit, select IPv6.
l If traffic goes from an IPv4 network to an IPv6 network, select NAT46.
l If traffic goes from an IPv6 network to an IPv4 network, select NAT64.
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4. Enter a unique name for the virtual IP and fill in the other fields.

To create a virtual IP using the CLI:
config firewall vip
edit "Internal_WebServer"
set extip 10.1.100.199
set extintf "any"
set mappedip "172.16.200.55"
next
end

To apply a virtual IP to policy using the CLI:
config firewall policy
edit 8
set name "Example_Virtual_IP_in_Policy"
set srcintf "wan2"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "Internal_WebServer"
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

Virtual IP with services
Virtual IP with services is a more flexible virtual IP mode. This mode allows users to define services to a single port
number mapping.
This recipe shows how to use virtual IP with services enabled. This example has one public external IP address. We map
TCP ports 8080, 8081, and 8082 to an internal WebServer TCP port 80. This allows remote connections to communicate
with a server behind the firewall.
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Sample configuration
To create a virtual IP with services using the GUI:
1.
2.
3.
4.
5.

6.
7.
8.
9.
10.

In Policy & Objects > Virtual IPs.
Click Create New and select Virtual IP.
For VIP Type, select IPv4.
Enter a unique name for the virtual IP and fill in the other fields.
Configure the fields in the Network section. For example:
l Set Interface to any.
l Set External IP Address/Range to 10.1.100.199.
l Set Mapped IP Address/Range to 172.16.200.55.
Enable Optional Filters and then enable Services.
In the Services field, click + to display the Services pane.
In the Services pane, select TCP_8080, TCP_8081, and TCP_8082.
Enable Port Forwarding.
Set Map to Port to 80.

11. Click OK.

To see the results:
1. Apply the above virtual IP to the Firewall policy.
2. The results are:
l Access 10.1.100.199:8080 from external network and FortiGate maps to 172.16.200.55:80 in internal network.
l Access 10.1.100.199:8081 from external network and FortiGate maps to 172.16.200.55:80 in internal network.
l Access 10.1.100.199:8082 from external network and FortiGate maps to 172.16.200.55:80 in internal network.
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To create a virtual IP with services using the CLI:
config firewall vip
edit "WebServer_VIP_Services"
set service "TCP_8080" "TCP_8081" "TCP_8082"
set extip 10.1.100.199
set extintf "any"
set portforward enable
set mappedip "172.16.200.55"
set mappedport 80
next
end

Virtual IPs with port forwarding
If you need to hide the internal server port number or need to map several internal servers to the same public IP address,
enable port-forwarding for Virtual IP.
This recipe shows how to use virtual IPs to configure port forwarding on a FortiGate unit. This example has one public
external IP address. We map TCP ports 8080, 8081, and 8082 to different internal WebServers' TCP port 80. This allows
remote connections to communicate with a server behind the firewall.

Sample configuration
To create a virtual IP with port forwarding using the GUI:
1.
2.
3.
4.
5.

In Policy & Objects > Virtual IPs.
Click Create New and select Virtual IP.
For VIP Type, select IPv4.
Enter a unique name for the virtual IP and fill in the other fields.
Configure the fields in the Network section. For example:
l Set Interface to any.
l Set External IP Address/Range to 10.1.100.199.
l Set Mapped IP Address/Range to 172.16.200.55.
6. Leave Optional Filters disabled.
7. Enable Port Forwarding.
8. Configure the fields in the Port Forwarding section. For example:
l Set Protocol to TCP.
l Set External Service Port to 8080 - 8080.
l Set Map to Port to 80 - 80.
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9. Click OK.
10. Follow the above steps to create two additional virtual IPs.
a. For one virtual IP:
l Use a different Mapped IP Address/Range, for example, 172.16.200.56.
l Set External Service Port to 8081 - 8081.
l Use the same Map to Port numbers: 80 - 80.
b. For the other virtual IP:
l Use a different Mapped IP Address/Range, for example, 172.16.200.57.
l Set External Service Port to 8082 - 8082.
l Use the same Map to Port numbers: 80 - 80.
11. Create a Virtual IP Group and put the above three virtual IPs into that group.

To see the results:
1. Apply the above virtual IP to the Firewall policy.
2. The results are:
l Access 10.1.100.199:8080 from external network and FortiGate maps to 172.16.200.55:80 in internal network.
l Access 10.1.100.199:8081 from external network and FortiGate maps to 172.16.200.56:80 in internal network.
l Access 10.1.100.199:8082 from external network and FortiGate maps to 172.16.200.57:80 in internal network
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Virtual server
This topic shows a special virtual IP type: virtual server. Use this type of VIP to implement server load balancing.
The FortiOS server load balancing contains all the features of a server load balancing solution. You can balance traffic
across multiple backend servers based on multiple load balancing schedules including:
l
l
l

Static (failover)
Round robin
Weighted (to account for different sized servers or based on the health and performance of the server including
round trip time and number of connections)

The load balancer supports HTTP, HTTPS, IMAPS, POP3S, SMTPS, SSL/TLS, and generic TCP/UDP and IP protocols.
Session persistence is supported based on the SSL session ID based on an injected HTTP cookie, or based on the
HTTP or HTTPS host. SSL/TLS load balancing includes protection from protocol downgrade attacks. Server load
balancing is supported on most FortiGate devices and includes up to 10,000 virtual servers on high end systems.

Sample topology

SSL/TLS offloading
FortiGate SSL/TLS offloading is designed for the proliferation of SSL/TLS applications. The key exchange and
encryption/decryption tasks are offloaded to the FortiGate unit where they are accelerated using FortiASIC technology
which provides significantly more performance than a standard server or load balancer. This frees up valuable resources
on the server farm to give better response to business operations. Server load balancing offloads most SSL/TLS
versions including SSL 3.0, TLS 1.0, and TLS 1.2, and supports full mode or half mode SSL offloading with DH key sizes
up to 4096 bits.
FortiGate SSL offloading allows the application payload to be inspected before it reaches your servers. This prevents
intrusion attempts, blocks viruses, stops unwanted applications, and prevents data leakage. SSL/TLS content inspection
supports TLS versions 1.0, 1.1, and 1.2 and SSL versions 1.0, 1.1, 1.2, and 3.0.

Virtual server requirements
When creating a new virtual server, you must configure the following options:
l
l

Virtual Server Type.
Load Balancing Methods.
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l
l
l
l
l

Health check monitoring (optional).
Session persistence (optional).
Virtual Server IP (External IP Address).
Virtual Server Port (External Port).
Real Servers (Mapped IP Address & Port).

Virtual server types
Select the protocol to be load balanced by the virtual server. If you select a general protocol such as IP, TCP, or UDP,
the virtual server load balances all IP, TCP, or UDP sessions. If you select specific protocols such as HTTP, HTTPS, or
SSL, you can apply additional server load balancing features such as Persistence and HTTP Multiplexing.
HTTP

Select HTTP to load balance only HTTP sessions with the destination port number that matches the
Virtual Server Port setting. Change Virtual Server Port to match the destination port of the sessions
to be load balanced (usually port 80 for HTTP sessions). You can enable HTTP Multiplexing. You
can also set Persistence to HTTP Cookie to enable cookie-based persistence.

HTTPS

Select HTTPS to load balance only HTTPS sessions with the destination port number that matches
the Virtual Server Port setting. Change Virtual Server Port to match the destination port of the
sessions to be load balanced (usually port 443 for HTTPS sessions). You can enable HTTP
Multiplexing. You can also set Persistence to HTTP Cookie to enable cookie-based persistence, or
you can set Persistence to SSL Session ID.

IMAPS

Select IMAPS to load balance only IMAPS sessions with the destination port number that matches
the Virtual Server Port setting. Change Virtual Server Port to match the destination port of the
sessions to be load balanced (usually port 993 for IMAPS sessions). You can also set Persistence
to SSL Session ID.

POP3S

Select POP3S to load balance only POP3S sessions with the destination port number that matches
the Virtual Server Port setting. Change Virtual Server Port to match the destination port of the
sessions to be load balanced (usually port 995 for POP3S sessions). You can also set Persistence
to SSL Session ID.

SMTPS

Select SMTPS to load balance only SMTPS sessions with the destination port number that matches
the Virtual Server Port setting. Change Virtual Server Port to match the destination port of the
sessions to be load balanced (usually port 465 for SMTPS sessions). You can also set Persistence
to SSL Session ID.

SSL

Select SSL to load balance only SSL sessions with the destination port number that matches the
Virtual Server Port setting. Change Virtual Server Port to match the destination port of the sessions
to be load balanced. You can also set Persistence to SSL Session ID.

TCP

Select TCP to load balance only TCP sessions with the destination port number that matches the
Virtual Server Port setting. Change Virtual Server Port to match the destination port of the sessions
to be load balanced.

UDP

Select UDP to load balance only UDP sessions with the destination port number that matches the
Virtual Server Port setting. Change Virtual Server Port to match the destination port of the sessions
to be load balanced.

IP

Select IP to load balance all sessions accepted by the security policy that contains this virtual
server.
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Load balancing methods
The load balancing method defines how sessions are load balanced to real servers.
All load balancing methods do not send traffic to real servers that are down or not responding. FortiGate can only
determine if a real server is not responding by using a health check monitor. You should always add at least one health
check monitor to a virtual server or to real servers; otherwise load balancing might try to distribute sessions to real
servers that are not functioning.
Static

The traffic load is statically spread evenly across all real servers. Sessions are not assigned
according to how busy individual real servers are. This load balancing method provides some
persistence because all sessions from the same source address always go to the same real server.
Because the distribution is stateless, so if a real server is added, removed, or goes up or down, the
distribution is changed and persistence might be lost.

Round Robin

Directs new requests to the next real server. This method treats all real servers as equals
regardless of response time or the number of connections. This method does not direct requests to
real servers that down or non responsive.

Weighted

Real servers with a higher weight value receive a larger percentage of connections. Set the real
server weight when adding a real server.

Least Session

Directs requests to the real server that has the least number of current connections. This method
works best in environments where the real servers or other equipment you are load balancing all
have similar capabilities. This load balancing method uses the FortiGate session table to track the
number of sessions being processed by each real server. The FortiGate unit cannot detect the
number of sessions actually being processed by a real server.

Least RTT

Directs sessions to the real server with the lowest round trip time. The round trip time is determined
by a ping health check monitor. The default is 0 if no ping health check monitors are added to the
virtual server.

First Alive

Directs sessions to the first live real server. This load balancing schedule provides real server
failover protection by sending all sessions to the first live real server. If a real server fails, all
sessions are sent to the next live real server. Sessions are not distributed to all real servers so all
sessions are processed by the first real server only.

HTTP Host

Load balances HTTP host connections across multiple real servers using the host’s HTTP header
to guide the connection to the correct real server.

Health check monitoring
In the FortiGate GUI, you can configure health check monitoring so that the FortiGate unit can verify that real servers are
able respond to network connection attempts. If a real server responds to connection attempts, the load balancer
continues to send sessions to it. If a real server stops responding to connection attempts, the load balancer assumes
that the server is down and does not send sessions to it. The health check monitor configuration determines how the
load balancer tests real servers. You can use a single health check monitor for multiple load balancing configurations.
You can configure TCP, HTTP, and Ping health check monitors. You usually set the health check monitor to use the
same protocol as the traffic being load balanced to it. For example, for an HTTP load balancing configuration, you would
normally use an HTTP health check monitor.
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Session persistence
Use persistence to ensure a user is connected to the same real server every time the user makes an HTTP, HTTPS, or
SSL request that is part of the same user session. For example, if you are load balancing HTTP and HTTPS sessions to
a collection of eCommerce web servers, when users make a purchase, they will be starting multiple sessions as they
navigate the eCommerce site. In most cases, all the sessions started by this user during one eCommerce session
should be processed by the same real server. Typically, the HTTP protocol keeps track of these related sessions using
cookies. HTTP cookie persistence ensure all sessions that are part of the same user session are processed by the same
real server.
When you configure persistence, the FortiGate unit load balances a new session to a real server according to the load
balance method. If the session has an HTTP cookie or an SSL session ID, the FortiGate unit sends all subsequent
sessions with the same HTTP cookie or SSL session ID to the same real server.

Real servers
Add real servers to a load balancing virtual server to provide information the virtual server requires to send sessions to
the server. A real server configuration includes the IP address of the real server and port number the real server receives
sessions on. The FortiGate unit sends sessions to the real server’s IP address using the destination port number in the
real server configuration.
When configuring a real server, you can also specify the weight (if the load balance method is set to Weighted) and you
can limit the maximum number of open connections between the FortiGate unit and the real server. If the maximum
number of connections is reached for the real server, the FortiGate unit automatically switches all further connection
requests to other real servers until the connection number drops below the limit. Setting Maximum Connections to 0
means that the FortiGate unit does not limit the number of connections to the real server.

Sample of HTTP load balancing to three real web servers
This example describes the steps to configure the load balancing configuration below. In this configuration, a FortiGate
unit is load balancing HTTP traffic from the Internet to three HTTP servers on the internal network. HTTP sessions are
accepted at the wan1 interface with destination IP address 172.20.120.121 on TCP port 8080, and forwarded from the
internal interface to the web servers. When forwarded, the destination address of the session is translated to the IP
address of one of the web servers.
This load balancing configuration also includes session persistence using HTTP cookies, round-robin load balancing,
and TCP health monitoring for the real servers. Ping health monitoring consists of the FortiGate unit using ICMP ping to
ensure the web servers can respond to network traffic.
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General steps:
1. Create a health check monitor.
A ping health check monitor causes the FortiGate to ping the real servers every 10 seconds. If one of the servers
does not respond within 2 seconds, the FortiGate unit will retry the ping 3 times before assuming that the HTTP
server is not responding.
2. Create a load balance virtual server with three real servers.
3. Add the load balancing virtual server to a policy as the destination address.
To see the virtual servers and health check monitors options in the GUI, Load Balancing must
be selected in Feature Visibility > Additional Features. See Feature visibility on page 554 on
page 1 for details.

Configure a load balancing virtual server in the GUI
To create a health check monitor:
1. Go to Policy & Objects > Health Check.
2. Click Create New.
3. Set the following:
l Name to Ping-mon-1
l Type to Ping
l Interval to 10 seconds
l Timeout to 2 seconds
l Retry to 3 attempt(s)
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4. Click OK.

To create a virtual server:
1. Go to Policy & Objects > Virtual Servers.
2. Click Create New.
3. Set the following:
l Name to Vserver-HTTP-1
l Type to HTTP
l Interface to wan1
l Virtual Server IP to 172.20.120.121
l Virtual Server Port to 8080
l Load Balance Method to Round Robin
l Persistence to HTTP Cookie
l Health Check to Ping-mon-1

4. In the Real Servers table, click Create New.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

593

Policy and Objects
5. Set the following for the first real server:
l IP Address to 10.31.101.30
l Port to 80
l Max Connections to 0
l Mode to Active

6. Configure two more real servers with IP addresses 10.31.101.40 and 10.31.101.50, and the remaining settings the
same as the first real server.
7. Click OK.

To create a security policy that includes the load balance virtual server as the destination address:
1. Go to Policy & Objects > IPv4 Policy.
2. Click Create New.
3. Set the Inspection Mode to Proxy-based. The new virtual server will not be available if the inspection mode is Flowbased.
4. Set the following:
l Name to LB-policy
l Incoming Interface to wan1
l Outgoing Interface to internal
l Source to all
l Destination to Vserver-HTTP-1
l Schedule to always
l Service to ALL
l Action to ACCEPT
5. Enable NAT and set IP Pool Configuration to Use Outgoing Interface Address.
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6. Enable AntiVirus and select an antivirus profile.

7. Click OK.

Configure a load balancing virtual server in the CLI
To configure HTTP load balancing to three real web servers in the CLI:
1. Create a health check monitor:
config firewall ldb-monitor
edit "Ping-mon-1"
set type ping
set interval 10
set timeout 2
set retry 3
next
end

2. Create a virtual server:
config firewall vip
edit "Vserver-HTTP-1"
set type server-load-balance
set extip 172.20.120.121
set extintf "any"
set server-type http
set monitor "Ping-mon-1"
set ldb-method round-robin
set persistence http-cookie
set extport 8080
config realservers
edit 1
set ip 10.31.101.30
set port 80

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

595

Policy and Objects

next
edit 2
set
set
next
edit 3
set
set
next

ip 10.31.101.40
port 80

ip 10.31.101.50
port 80

end
next
end

3. Add the load balancing virtual server to a policy as the destination address:
config firewall policy
edit 2
set name "LB-policy"
set inspection-mode proxy
set srcintf "wan1"
set dstintf "internal"
set srcaddr "all"
set dstaddr "Vserver-HTTP-1"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set ssl-ssh-profile "certificate-inspection"
set av-profile "default"
set fsso disable
set nat enable
next
end

Results
Traffic accessing 172.20.120.121:8080 is forwarded in turn to the three real servers.
If the access request has an http-cookie, FortiGate forwards the access to the corresponding real server according to the
cookie.

Policy with Internet Service
Using Internet Service in policy
This recipe shows how to apply a predefined Internet Service entry into a policy.
The Internet Service Database is a comprehensive public IP address database that combines IP address range, IP
owner, service port number, and IP security credibility. The data comes from the FortiGuard service system. Information
is regularly added to this database, for example, geographic location, IP reputation, popularity & DNS, and so on. All this
information helps users define Internet security more effectively. You can use the contents of the database as criteria for
inclusion or exclusion in a policy.
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From FortiOS version 5.6, Internet Service is included in the firewall policy. It can be applied to a policy only as a
destination object. From version 6.0, Internet Service can be applied both as source and destination objects in a policy.
You can also apply Internet Services to shaping policy.
There are three types of Internet Services you can apply to a firewall policy:
l
l
l

Predefined Internet Services
Custom Internet Services
Extension Internet Services

Sample configuration
To apply a predefined Internet Service entry to a policy using the GUI:
1.
2.
3.
4.

Go to Policy & Objects and create a new policy.
In the Source or Destination field, click +.
In the Select Entries pane, click Internet Service.
Locate and click Google.Gmail.

5. Configure the other fields and then click OK.

To apply a predefined Internet Service entry to a policy using the CLI:
In the CLI, enable the internet-service first and then use its ID to apply the policy.
This example uses Google Gmail and its ID is 65646. Each Internet Service has a unique ID.
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config firewall policy
edit 9
set name "Internet Service in Policy"
set srcintf "wan2"
set dstintf "wan1"
set srcaddr "all"
set internet-service enable
set internet-service-id 65646
set action accept
set schedule "always"
set utm-status enable
set av-profile "g-default"
set ssl-ssh-profile "certificate-inspection"
set nat enable
next
end

To diagnose an Internet Service entry using the CLI:
# diagnose internet-service id-summary 65646
Version: 0000600096
Timestamp: 201902111802
Total number of IP ranges: 444727
Number of Groups: 7
Group(0), Singularity(20), Number of IP ranges(142740)
Group(1), Singularity(19), Number of IP ranges(1210)
Group(2), Singularity(16), Number of IP ranges(241)
Group(3), Singularity(15), Number of IP ranges(38723)
Group(4), Singularity(10), Number of IP ranges(142586)
Group(5), Singularity(8), Number of IP ranges(5336)
Group(6), Singularity(6), Number of IP ranges(113891)
Internet Service: 65646(Google.Gmail)
Number of IP range: 60
Number of IP numbers: 322845
Singularity: 15
Reputation: 5(Known and verified safe sites such as Gmail, Amazon, eBay, etc.)
Icon Id: 510
Second Level Domain: 53(gmail.com)
Direction: dst
Data source: isdb

Result
Because the IP and services related to Google Gmail on the Internet are included in this Internet Service (65646), all
traffic to Google Gmail is forwarded by this policy.

Using custom Internet Service in policy
Custom Internet Services can be created and used in firewall policies.
When creating a custom Internet Service, you must set following elements:
l
l

IP or IP ranges
Protocol number
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l
l

Port or port ranges
Reputation

You must use CLI to create a custom Internet Service.

Custom Internet Service CLI syntax
config firewall internet-service-custom
edit <name>
set comment <comment>
set reputation {1|2|3|4|5}
config entry
edit <ID #>
set protocol <number #>
set dst <object_name>
config port-range
edit <ID #>
set start-port <number #>
set end-port <number #>
next
end
next
end
end
end

Sample configuration
To configure a custom Internet Service:
config firewall internet-service-custom
edit "test-isdb-1"
set comment "Test Custom Internet Service"
set reputation 4
config entry
edit 1
set protocol 6
config port-range
edit 1
set start-port 80
set end-port 443
next
end
set dst "10-1-100-0"
next
edit 2
set protocol 6
config port-range
edit 1
set start-port 80
set end-port 80
next
end
set dst "172-16-200-0"
next

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

599

Policy and Objects

end
next
end

To apply a custom Internet Service into a policy:
config firewall policy
edit 1
set name "Internet Service in Policy"
set srcintf "wan2"
set dstintf "wan1"
set srcaddr "all"
set internet-service enable
set internet-service-id 65646
set internet-service-custom "test-isdb-1"
set action accept
set schedule "always"
set utm-status enable
set av-profile "g-default"
set ssl-ssh-profile "certificate-inspection"
set nat enable
next
end

Result
In addition to the IP address, IP address ranges, and services allowed by Google.Gmail, this policy also allows the traffic
which access to 10.1.100.0/24 and TCP/80-443 and 172.16.200.0/24 and TCP/80.

Using extension Internet Service in policy
Extension Internet Service lets you add custom or remove existing IP address and port ranges to an existing predefined
Internet Service entries. Using an extension type Internet Service is actually editing a predefined type Internet Service
entry and adding IP address and port ranges to it.
When creating an extension Internet Service and adding custom ranges, you must set following elements:
l
l
l

IP or IP ranges
Protocol number
Port or port ranges

You must use CLI to add custom IP address and port entries into a predefined Internet Service.
You must use GUI to remove entries from a predefined Internet Service.

Custom extension Internet Service CLI syntax
config firewall internet-service-extension
edit <ID #>
set comment <comment>
config entry
edit <ID #>
set protocol <number #>
set dst <object_name>
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config port-range
edit <ID #>
set start-port <number #>
set end-port <number #>
next
end
next
end
end
end

Sample configuration
To configure an extension Internet Service using the CLI:
config firewall internet-service-extension
edit 65646
set comment "Test Extension Internet Service 65646"
config entry
edit 1
set protocol 6
config port-range
edit 1
set start-port 80
set end-port 443
next
end
set dst "172-16-200-0"
next
edit 2
set protocol 17
config port-range
edit 1
set start-port 53
set end-port 53
next
end
set dst "10-1-100-0"
next
end
next
end

To remove IP address and port entries from an existing Internet Service:
1. Go to Policy & Objects > Internet Service Database.
2. Search for Google.Gmail.
3. Select Google.Gmail and click Edit.
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4. Locate the IP entry you want to remove and click Disable beside that entry.

5. Click Return.
6. When you complete the actions in the GUI, the CLI automatically generates the configuration from your GUI actions:
config firewall internet-service-extension
edit 65646
set comment "Test Extension Internet Service 65646"
config entry
edit 1
set protocol 6
config port-range
edit 1
set start-port 80
set end-port 443
next
end
set dst "172-16-200-0"
next
edit 2
set protocol 17
config port-range
edit 1
set start-port 53
set end-port 53
next
end
set dst "10-1-100-0"
next
end
config disable-entry
edit 1
set protocol 6
config port-range
edit 1
set start-port 25
set end-port 25
next
edit 2
set start-port 80
set end-port 80
next
edit 3
set start-port 110
set end-port 110
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next
edit 4
set
set
next
edit 5
set
set
next
edit 6
set
set
next
edit 7
set
set
next
edit 8
set
set
next
edit 9
set
set
next
edit 10
set
set
next

start-port 143
end-port 143

start-port 443
end-port 443

start-port 465
end-port 465

start-port 587
end-port 587

start-port 993
end-port 993

start-port 995
end-port 995

start-port 2525
end-port 2525

end
config ip-range
edit 1
set start-ip 2.20.183.160
set end-ip 2.20.183.160
next
end
next
end
next
end

To apply an extension Internet Service into policy using the CLI:
config firewall policy
edit 9
set name "Internet Service in Policy"
set srcintf "wan2"
set dstintf "wan1"
set srcaddr "all"
set internet-service enable
set internet-service-id 65646
set action accept
set schedule "always"
set utm-status enable
set av-profile "g-default"
set ssl-ssh-profile "certificate-inspection"
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set nat enable
next
end

Result
In addition to the IP addresses, IP address ranges, and services allowed by Google.Gmail, this policy also allows the
traffic which accesses 10.1.100.0/24 and UDP/53 and 172.16.200.0/24 and TCP/80-443. At the same time, the traffic
that accesses 2.20.183.160 is dropped because this IP address and port is disabled from Google.Gmail.

Global IP address information database
The Internet Service and IP Reputation databases download details about public IP address, including: ownership,
known services, geographic location, blacklisting information, and more. The details are available in drilldown
information, tooltips, and other mechanisms in the FortiView and other pages.
The global IP address database is an integrated database containing all public IP addresses, and is implemented in the
Internet Service Database.

To view the owner of the IP address:
(global) # get firewall internet-service-owner ?
id
Internet Service owner ID.
1 Google
2 Facebook
3 Apple
4 Yahoo
5 Microsoft
......
115 Cybozu
116 VNC

To check for any known service running on an IP address:
(global) # diagnose internet-service info FG-traffic 6 80 8.8.8.8
Internet Service: 65537(Google.Web)

To check GeoIP location and black list information:
(global) # diagnose internet-service id 65537 | grep 8.8.8.8
8.8.8.8-8.8.8.8 geo_id(11337) black list(0x0) proto(6) port(80 443)
8.8.8.8-8.8.8.8 geo_id(11337) black list(0x0) proto(17) port(443)

To check a known malicious server:
(global) # diagnose internet-service id-summary 3080383
Version: 0000600096
Timestamp: 201902111802
Total number of IP ranges: 444727
Number of Groups: 7
Group(0), Singularity(20), Number of IP ranges(142740)
Group(1), Singularity(19), Number of IP ranges(1210)
Group(2), Singularity(16), Number of IP ranges(241)
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Group(3), Singularity(15), Number of IP ranges(38723)
Group(4), Singularity(10), Number of IP ranges(142586)
Group(5), Singularity(8), Number of IP ranges(5336)
Group(6), Singularity(6), Number of IP ranges(113891)
Internet Service: 3080383(Botnet.C&C.Server)
Number of IP range: 111486
Number of IP numbers: 111486
Singularity: 20
Reputation: 1(Known malicious sites related to botnet servers, phishing sites, etc.)
Icon Id: 591
Second Level Domain: 1(other)
Direction: dst
Data source: irdb

To check questionable usage:
(global) # diagnose internet-service id-summary 2818238
Version: 0000600096
Timestamp: 201902111802
Total number of IP ranges: 444727
Number of Groups: 7
Group(0), Singularity(20), Number of IP ranges(142740)
Group(1), Singularity(19), Number of IP ranges(1210)
Group(2), Singularity(16), Number of IP ranges(241)
Group(3), Singularity(15), Number of IP ranges(38723)
Group(4), Singularity(10), Number of IP ranges(142586)
Group(5), Singularity(8), Number of IP ranges(5336)
Group(6), Singularity(6), Number of IP ranges(113891)
Internet Service: 2818238(Tor.Relay.Node)
Number of IP range: 13718
Number of IP numbers: 13718
Singularity: 20
Reputation: 2(Sites providing high risk services such as TOR, proxy, P2P, etc.)
Icon Id: 43
Second Level Domain: 1(other)
Direction: dst
Data source: irdb
(global) # diagnose internet-service id-summary 2818243
Version: 0000600096
Timestamp: 201902111802
Total number of IP ranges: 444727
Number of Groups: 7
Group(0), Singularity(20), Number of IP ranges(142740)
Group(1), Singularity(19), Number of IP ranges(1210)
Group(2), Singularity(16), Number of IP ranges(241)
Group(3), Singularity(15), Number of IP ranges(38723)
Group(4), Singularity(10), Number of IP ranges(142586)
Group(5), Singularity(8), Number of IP ranges(5336)
Group(6), Singularity(6), Number of IP ranges(113891)
Internet Service: 2818243(Tor.Exit.Node)
Number of IP range: 1210
Number of IP numbers: 1210
Singularity: 19
Reputation: 2(Sites providing high risk services such as TOR, proxy, P2P, etc.)
Icon Id: 43
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Second Level Domain: 1(other)
Direction: src
Data source: irdb

IP reputation filtering
There are currently five reputation levels in the Internet Service Database (ISDB), and custom reputation levels can be
defined in a custom internet service. You can configure firewall policies to filter traffic according to the desired reputation
level. If the reputation level of either the source or destination IP address is equal to or greater than the level set in the
policy, then the packet is forwarded, otherwise, the packet is dropped.
The five default reputation levels are:
1

Known malicious sites, such as phishing sites or sites related to botnet servers

2

High risk services sites, such as TOR, proxy, and P2P

3

Unverified sites

4

Reputable social media sites, such as Facebook and Twitter

5

Known and verified safe sites, such as Gmail, Amazon, and eBay

The default minimum reputation level in a policy is zero, meaning that the reputation filter is disabled.
For IP addresses that are not included in the ISDB, the default reputation level is three.
The default reputation direction is destination.

To set the reputation level and direction in a policy using the CLI:
config firewall policy
edit 1
set uuid dfcaec9c-e925-51e8-cf3e-fed9a1d42a1c
set srcintf "wan2"
set dstintf "wan1"
set dstaddr "all"
set reputation-minimum 3
set reputation-direction source
set action accept
set schedule "always"
set service "ALL"
set logtraffic all
set auto-asic-offload disable
set nat enable
next
end

Packets from the source IP address with reputation levels three, four, or five will be forwarded by this policy.
In a policy, if reputation-minimum is set, and the reputation-direction is
destination, then the dstaddr, service, and internet-service options are removed
from the policy.
If reputation-minimum is set, and the reputation-direction is source, then the
srcaddr, and internet-service-src options are removed from the policy.
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Internet service groups in policies
This feature provides support for Internet Service Groups in traffic shaping and firewall policies. Service groups can be
used as the source and destination of the policy. Internet Service Groups are used as criteria to match traffic; the shaper
will be applied when the traffic matches.
To use a group as a destination, internet-service must be enabled. To use a group as a source, internetservice-src must be enabled.
The following CLI variables are available in the firewall policy and firewall shaping-policy commands:

Variable

Description

internet-service-group <string>

Internet Service group name.

internet-service-custom-group <string>

Custom Internet Service group name.

internet-service-src-group <string>

Internet Service source group name.

internet-service-src-custom-group <string>

Custom Internet Service source group name.

Examples
The following examples use the below topology.

Example 1
In this example, the PC is allowed to access Google, so all Google services are put into an Internet Service Group.

To configure access to Google services using an Internet Service Group using the CLI:
1. Create a Service Group:
config firewall internet-service-group
edit "Google_Group"
set direction destination
set member 65537 65538 65539 65540 65542 65543 65544 65545 65550 65536 65646
next
end

2. Create a firewall policy to allow access to all Google Services from the PC:
config firewall policy
edit 1
set name "PC to Google"
set srcintf "port2"
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set
set
set
set
set
set
set
set

dstintf "port1"
srcaddr "PC"
internet-service enable
internet-service-group "Google_Group"
action accept
schedule "always"
fsso disable
nat enable

next
end

To configure access to Google services using an Internet Service Group in the GUI:
1. On the FortiGate, create a Service Group using the CLI.
2. Go to Policy & Objects > IPv4 Policy, and create a new policy.
3. Set the Destination as the just created Internet Service Group.

4. Configure the remaining options as shown, then click OK.
On the policy page, hover over the group to view a list of its members.
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Example 2
In this example, two office FTP servers are put into an Internet Custom Service Group, and the PC connection to the FTP
servers is limited to 1Mbps.

To put two FTP servers into a custom service group and limit the PC connection speed to them using
the CLI:
1. Create custom internet services for the internal FTP servers:
config firewall internet-service-custom
edit "FTP_PM"
config entry
edit 1
config port-range
edit 1
set start-port 21
set end-port 21
next
end
set dst "PM_Server"
next
end
next
edit "FTP_QA"
config entry
edit 1
config port-range
edit 1
set start-port 21
set end-port 21
next
end
set dst "QA_Server"
next
end
next
end

2. Create a custom internet server group and add the just created custom internet services to it:
config firewall internet-service-custom-group
edit "Internal_FTP"
set member "FTP_QA" "FTP_PM"
next
end

3. Create a traffic shaper to limit the maximum bandwidth:
config firewall shaper traffic-shaper
edit "Internal_FTP_Limit_1Mbps"
set guaranteed-bandwidth 500
set maximum-bandwidth 1000
set priority medium
next
end
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4. Create a firewall shaping policy to limit the speed from the PC to the internal FTP servers:
config firewall shaping-policy
edit 1
set name "For Internal FTP"
set internet-service enable
set internet-service-custom-group "Internal_FTP"
set dstintf "port1"
set traffic-shaper "Internal_FTP_Limit_1Mbps"
set traffic-shaper-reverse "Internal_FTP_Limit_1Mbps"
set srcaddr "PC"
next
end

To put two FTP servers into a custom service group and limit the PC connection speed to the using the
GUI:
1. Create custom internet services for the internal FTP servers using the CLI.
2. Create a custom internet server group and add the just created custom internet services to it using the CLI.
3. Create a traffic shaper to limit the maximum bandwidth:
a. Go to Policy & Objects > Traffic Shapers, and click Create New.
b. Enter a Name for the shaper, such as Internal_FTP_Limit_1Mbps.
c. Set the Traffic Priority to Medium.
d. Enable Max Bandwidth and set it to 1000.
e. Enable Guaranteed Bandwidth and set it to 500.
f. Click OK.
4. Create a firewall shaping policy to limit the speed from the PC to the internal FTP servers:
a. Go to Policy & Objects > Traffic Shaping Policy, and click Create New.
b. Set the Destination as the just created Custom Internet Service Group, and apply the just create traffic shaper.

c. Configure the remaining options as shown, then click OK.

NAT64 policy and DNS64 (DNS proxy)
NAT64 policy translates IPv6 addresses to IPv4 addresses so that a client on an IPv6 network can communicate
transparently with a server on an IPv4 network.
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NAT64 policy is usually implemented in combination with the DNS proxy called DNS64. DNS64 synthesizes AAAA
records from A records and is used to synthesize IPv6 addresses for hosts that only have IPv4 addresses. DNS proxy
and DNS64 are interchangeable terms.

Sample topology

In this example, a host on the internal IPv6 network communicates with ControlPC.qa.fortinet.com that only has
IPv4 address on the Internet.
1. The host on the internal network does a DNS lookup for ControlPC.qa.fortinet.com by sending a DNS query
for an AAAA record for ControlPC.qa.fortinet.com.
2. The DNS query is intercepted by the FortiGate DNS proxy. The DNS proxy performs an A-record query for
ControlPC.qa.fortinet.com and gets back an RRSet containing a single A record with the IPv4 address
172.16.200.55.
3. The DNS proxy then synthesizes an AAAA record. The IPv6 address in the AAAA record begins with the configured
NAT64 prefix in the upper 96 bits and the received IPv4 address in the lower 32 bits. By default, the resulting IPv6
address is 64:ff9b::172.16.200.55.
4. The host on the internal network receives the synthetic AAAA record and sends a packet to the destination address
64:ff9b::172.16.200.55.
5. The packet is routed to the FortiGate internal interface (port10) where it is accepted by the NAT64 security policy.
6. The FortiGate unit translates the destination address of the packets from IPv6 address
64:ff9b::172.16.200.55 to IPv4 address 172.16.200.55 and translates the source address of the packets
to 172.16.200.200 (or another address in the IP pool range) and forwards the packets out the port9 interface to
the Internet.

Sample configuration
To enable display for IPv6, NAT46/NAT64, and DNS Database using the GUI:
1. Go to System > Feature Visibility.
2. In the Basic Features section, enable IPv6.
3. In the Additional Features section, enable the following features:
l NAT46 & NAT64
l DNS Database
4. Click Apply.

To enable display for IPv6, NAT46/NAT64, and DNS Database using the CLI:
config system global
set gui-ipv6 enable
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end
config system settings
set gui-nat46-64 enable
set gui-dns-database enable
end

To enable DNS proxy on the IPv6 interface using the GUI:
1.
2.
3.
4.

Go to Network > DNS Servers.
In DNS Service on Interface, click Create New.
For Interface, select port10.
Click OK.

To enable DNS proxy on the IPv6 interface using the CLI:
config system dns-server
edit "port10"
set mode forward-only
next
end

To configure IPv6 DHCP server using the CLI:
config system dhcp6 server
edit 1
set subnet 2001:db8:1::/64
set interface "port10"
config ip-range
edit 1
set start-ip 2001:db8:1::11
set end-ip 2001:db8:1::20
next
end
set dns-server1 2001:db8:1::10
next
end

To enable NAT64 and related settings using the CLI:
Enabling NAT64 with the config system nat64 command means that all IPv6 traffic received by the current VDOM
can be subject to NAT64 if the source and destination address matches an NAT64 security policy.
By default, the setting always-synthesize-aaaa-record is enabled. If you disable this setting, the DNS proxy
(DNS64) will attempt to find an AAAA records for queries to domain names and therefore resolve the host names to IPv6
addresses. If the DNS proxy cannot find an AAAA record, it synthesizes one by adding the NAT64 prefix to the A record.
nat64-prefix setting is the nat64 prefix. By default, it is 64:ff9b::/96.
config system nat64
set status enable
end
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To create NAT64 policy using the GUI:
1. Add an IPv4 firewall address for the external network.
a. Go to Policy & Object > Addresses.
b. Click Create New.
c. For Name, enter external-net4.
d. For IP/Network, enter 17216.200.0/24.
e. For Interface, select port9.
f. Click OK.
2. Add an IPv6 firewall address for the internal network.
a. Go to Policy & Object > Addresses.
b. Click Create New.
c. Change Category to IPv6 Address.
d. For Name, enter internal-net6.
e. For IPv6 Address, enter 2001:db8:1::/48.
f. Click OK.
3. Add an IP pool containing the IPv4 address that is used as the source address of the packets exiting port9.
a. Go to Policy & Object > IP Pools.
b. Click Create New.
c. For Name, enter exit-pool4.
d. For External IP Range, enter 172.16.200.200-172.16.200.210.
e. Click OK.
4. Add a NAT64 policy that allows connections from the internal IPv6 network to the external IPv4 network.
a. Go to Policy & Object > NAT64 Policy.
b. Click Create New.
c. For Incoming Interface, select port10.
d. For Outgoing Interface, select port9.
e. For Source Address, select internal-net6.
f. For Destination Address, select external-net4.
g. Set IP Pool Configuration to Use Dynamic IP Pool and select the IP pool exit-pool4.
h. Click OK.

To create NAT64 policy using the CLI:
config firewall address
edit "external-net4"
set associated-interface "port9"
set subnet 172.16.200.0 255.255.255.0
next
end
config firewall address6
edit "internal-net6"
set ip6 2001:db8:1::/48
next
end
config firewall ippool
edit "exit-pool4"
set startip 172.16.200.200
set endip 172.16.200.210
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next
end
config firewall policy64
edit 1
set srcintf "port10"
set dstintf "port9"
set srcaddr "internal-net6"
set dstaddr "external-net4"
set action accept
set schedule "always"
set service "ALL"
set ippool enable
set poolname "exit-pool4"
next
end

NAT46 policy
NAT46 refers to the mechanism that allows IPv4 addressed hosts to communicate with IPv6 hosts. Without such a
mechanism, IPv4 environments cannot connect to IPv6 networks.

Sample topology

In this example, an IPv4 client tries to connect to an IPv6 server. A VIP is configured on FortiGate to map the server IPv6
IP address 2000:172:16:200:55 to an IPv4 address 10.1.100.55. On the other side, an IPv6 IP pool is configured
and the source address of packets from client are changed to the defined IPv6 address. In this setup, the client PC can
access the server by using IP address 10.1.100.55.

Sample configuration
To enable display for IPv6 and NAT46/NAT64 using the GUI:
1.
2.
3.
4.

Go to System > Feature Visibility.
In the Basic Features section, enable IPv6.
In the Additional Features section, enable NAT46 & NAT64.
Click Apply.

To enable display for IPv6 and NAT46/NAT64 using the CLI:
config system global
set gui-ipv6 enable
end
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config system settings
set gui-nat46-64 enable
end

To configure VIP46 using the GUI:
1.
2.
3.
4.
5.
6.

Go to Policy & Object > Virtual IPs.
Click Create New.
For Name, enter vip46_server.
For External IP Address/Range, enter 10.1.100.55- 10.1.100.55.
For Mapped IP Address/Range, enter 2000:172:16:200::55.
Click OK.

To configure VIP46 using the CLI:
config firewall vip46
edit "vip46_server"
set extip 10.1.100.55
set mappedip 2000:172:16:200::55
next
end

To configure IPv6 IP pool using the GUI:
1.
2.
3.
4.
5.

Go to Policy & Object > IP Pools.
Click Create New.
For Name, enter client_expternal.
For External IP Range, enter 2000:172:16:201::11- 2000:172:16:201::20.
Click OK.

To configure IPv6 IP pool using the CLI:
config firewall ippool6
edit "client_external"
set startip 2000:172:16:201::11
set endip 2000:172:16:201::20
next
end

To enable NAT64 and configure address prefix using the CLI:
config system nat64
set status enable
set secondary-prefix-status enable
config secondary-prefix
edit "1"
set nat64-prefix 2000:172:16:201::/96
next
end
end
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To create NAT46 policy using the GUI:
1.
2.
3.
4.
5.
6.
7.
8.

Go to Policy & Object > NAT46 Policy.
Click Create New.
For Incoming Interface, select port10.
For Outgoing Interface, select port9.
For Source Address, select all.
For Destination Address, select vip46_server.
Set IP Pool Configuration to Use Dynamic IP Pool and select the IP pool client_expernal.
Click OK.

To create NAT46 policy using the CLI:
config firewall policy46
edit 1
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "vip46_server"
set action accept
set schedule "always"
set service "ALL"
set ippool enable
set poolname "client_external"
next
end

Sample troubleshooting
Example to trace flow to see the whole process.
# diagnose debug flow filter saddr 10.1.100.11
# diagnose debug flow show function-name enable
show function name
# diagnose debug flow show iprope enable
show trace messages about iprope
# diagnose debug flow trace start 5
id=20085 trace_id=1 func=print_pkt_detail line=5401 msg="vd-root:0 received a packet
(proto=1, 10.1.100.11:27592->10.1.100.55:2048) from port10. type=8, code=0, id=27592,
seq=1."
id=20085 trace_id=1 func=init_ip_session_common line=5561 msg="allocate a new session000003b9"
id=20085 trace_id=1 func=iprope_dnat_check line=4948 msg="in-[port10], out-[]"
id=20085 trace_id=1 func=iprope_dnat_tree_check line=822 msg="len=1"
id=20085 trace_id=1 func=__iprope_check_one_dnat_policy line=4822 msg="checking gnum-100000
policy-1"
id=20085 trace_id=1 func=get_vip46_addr line=998 msg="find DNAT46: IP-2000:172:16:200::55,
port-27592"
id=20085 trace_id=1 func=__iprope_check_one_dnat_policy line=4904 msg="matched policy-1,
act=accept, vip=1, flag=100, sflag=2000000"
id=20085 trace_id=1 func=iprope_dnat_check line=4961 msg="result: skb_flags-02000000, vid-1,
ret-matched, act-accept, flag-00000100"
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id=20085 trace_id=1 func=fw_pre_route_handler line=183 msg="VIP-10.1.100.55:27592, outdevunkown"
id=20085 trace_id=1 func=__ip_session_run_tuple line=3220 msg="DNAT 10.1.100.55:8>10.1.100.55:27592"
id=20085 trace_id=1 func=vf_ip_route_input_common line=2594 msg="find a route: flag=80000000
gw-10.1.100.55 via root"
id=20085 trace_id=1 func=ip4_nat_af_input line=601 msg="nat64 ipv4 received a packet
proto=1"
id=20085 trace_id=1 func=__iprope_check line=2112 msg="gnum-100012, check-ffffffffa0024ebe"
id=20085 trace_id=1 func=__iprope_check_one_policy line=1873 msg="checked gnum-100012
policy-1, ret-matched, act-accept"
id=20085 trace_id=1 func=__iprope_user_identity_check line=1677 msg="ret-matched"
id=20085 trace_id=1 func=get_new_addr46 line=1047 msg="find SNAT46: IP-2000:172:16:201::13
(from IPPOOL), port-27592"
id=20085 trace_id=1 func=__iprope_check_one_policy line=2083 msg="policy-1 is matched, actaccept"
id=20085 trace_id=1 func=__iprope_check line=2131 msg="gnum-100012 check result: retmatched, act-accept, flag-08050500, flag2-00200000"
id=20085 trace_id=1 func=iprope_policy_group_check line=4358 msg="after check: ret-matched,
act-accept, flag-08050500, flag2-00200000"
id=20085 trace_id=1 func=resolve_ip6_tuple line=4389 msg="allocate a new session-00000081"

Multicast processing and basic Multicast policy
You need to add firewall policies to allow packets to pass from one interface to another. Multicast packets require
multicast security policies. Similar to firewall policies, in a multicast policy, the administrator specifies the source
interface, destination interfaces, the allowed source address ranges, and destination addresses of the multicast traffic.
You can also use multicast policies to configure source NAT and destination NAT for multicast packets.

Multicast forwarding in NAT mode
When multicast-forward is enabled, the FortiGate forwards any multicast IP packets in which the TTL is 2 or higher
to all interfaces and VLAN interfaces except the receiving interface. The TTL in the IP header is reduced by 1. Even
though the multicast packets are forwarded to all interfaces, you must add multicast policies to allow multicast packets
through the FortiGate.
If multicast-forward is disabled, then FortiGate unit drops packets that have multicast source or destination
addresses.
In NAT mode, there is a per-VDOM configuration to disable forwarding any multicast traffic. This command is only
available in NAT mode.
config system settings
set multicast-forward <disable|enable(default)>
end

You can also use the multicast-ttl-notchange option so that FortiGate doesn't increase the TTL value for
forwarded multicast packets. Use this option only if packets are expiring before reaching the multicast router.
config system settings
set multicast-ttl-notchange enable
end

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

617

Policy and Objects

Multicast processing in transparent mode
When multicast-skip-policy is enabled, no check is performed based on multicast policy. A multicast packet
received on an interface is flooded unconditionally to all interfaces (except the incoming interface) belonging to the same
forwarding domain. Multicast packets are forwarded even when there is no multicast policy or the multicast policy is set
to deny. To forward multicast traffic based on multicast policy, multicast-skip-policy must be disabled.
In transparent mode, there is a per-VDOM configuration to skip policy check and forward all multicast traffic. This
command is only available in transparent mode, and is disabled by default.
config system settings
set multicast-skip-policy {disable | enable}
end

Sample configuration
To allow RIP2 packets from port1 to port2 using the GUI:
1.
2.
3.
4.
5.
6.
7.

Go to Policy & Object > Multicast Policy.
Click Create New.
For Incoming Interface, select port1.
For Outgoing Interface, select port2.
For Source Address, select 10.10.0.10/32.
For Destination Address, select RIPv2.
Click OK.

To allow RIP2 packets from port1 to port2 using the CLI:
config firewall address
edit "10.10.0.10/32"
set subnet 10.10.0.10 255.255.255.255
next
end
config firewall multicast-address
edit "RIPv2"
set start-ip 224.0.0.9
set end-ip 224.0.0.9
next
end
config firewall multicast-policy
edit 2
set srcintf "port1"
set dstintf "port2"
set srcaddr "10.10.0.10/32"
set dstaddr "RIPv2"
next
end
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Local-in policies
While security profiles control traffic flowing through the FortiGate, local-in policies control inbound traffic that is going to
a FortiGate interface.
Administrative access traffic (HTTPS, PING, SSH, and others) can be controlled by allowing or denying the service in the
interface settings. Trusted hosts can be configured under an administrator to restrict the hosts that can access the
administrative service.
Local-in policies allow administrators to granularly define the source and destination addresses, interface, and services.
Traffic destined for the FortiGate interface specified in the policy that meets the other criteria is subject to the policies
action.
Local-in policies can be used to restrict administrative access or other services, such as VPN, that can be specified as
services. You can define source addresses or address groups to restrict access from. For example, by using a
geographic type address you can restrict a certain geographic set of IP addresses from accessing the FortiGate.
By default, no local-in policies are defined, so there are no restrictions on local-in traffic.
Local-in policies can only be created or edited in the CLI. You can view the existing local-in
policies in the GUI by enabling it in System > Feature Visibility under the Additional Features
section. This page does not list the custom local-in policies.

To configure a local-in policy using the CLI:
config firewall {local-in-policy | local-in-policy6}
edit <policy_number>
set intf <interface>
set srcaddr <source_address> [source_address] ...
set dstaddr <destination_address> [destination_address] ...
set action {accept | deny}
set service <service_name> [service_name] ...
set schedule <schedule_name>
set comments <string>
next
end

For example, to prevent the source subnet 10.10.10.0/24 from pinging port1, but allow administrative access for PING
on port1:
config firewall address
edit "10.10.10.0"
set subnet 10.10.10.0 255.255.255.0
next
end
config firewall local-in-policy
edit 1
set intf "port1"
set srcaddr "10.10.10.0"
set dstaddr "all"
set service "PING"
set schedule "always"
next
end
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To test the configuration:
1. From the PC at 10.10.10.12, start a continuous ping to port1:
ping 192.168.2.5 –t

2. On the FortiGate, enable debug flow:
#
#
#
#

diagnose
diagnose
diagnose
diagnose

debug
debug
debug
debug

flow filter addr 10.10.10.12
flow filter proto 1
enable
flow trace start 10

3. The output of the debug flow shows that traffic is dropped by local-in policy 1:
# id=20085 trace_id=1 func=print_pkt_detail line=5746 msg="vd-root:0 received a packet
(proto=1, 10.10.10.12:1->192.168.2.5:2048) from port1. type=8, code=0, id=1, seq=128."
id=20085 trace_id=1 func=init_ip_session_common line=5918 msg="allocate a new session0017c5ad"
id=20085 trace_id=1 func=vf_ip_route_input_common line=2615 msg="find a route:
flag=80000000 gw-192.168.2.5 via root"
id=20085 trace_id=1 func=fw_local_in_handler line=474 msg="iprope_in_check() check
failed on policy 1, drop"

Additional options
To disable or re-enable the local-in policy, use the set status {enable | disable} command.
To dedicate the interface as an HA management interface, use the set ha-mgmt-intf-only enable command.

IPv4/IPv6 access control lists
An access control list (ACL) is a granular, targeted blocklist that is used to block IPv4 and IPv6 packets on a specified
interface based on the criteria configured in the ACL policy.
On FortiGate models with ports that are connected through an internal switch fabric with TCAM capabilities, ACL
processing is offloaded to the switch fabric and does not use CPU resources. VLAN interfaces that are based on
physical switch fabric interfaces are also supported. Interfaces that are connected through an internal switch fabric
usually have names prefixed with port or lan, such as port1 or lan2; other interfaces are not supported.
The packets will be processed by the CPU when offloading is disabled or not possible, such as when a port on a
supported model does not connect to the internal fabric switch.
ACL is supported on the following FortiGate models:
l

100D, 100E, 100EF, 101E

l

140D, 140D-POE, 140E, 140E-POE

l

1200D, 1500D, 1500DT

l

3000D, 3100D, 3200D, 3700D, 3800D, 3810D, 3815D

l

All 300E and larger E-series models

l

All 100F and larger F-series models
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Example
To block all IPv4 and IPv6 Telnet traffic from port2 to Company_Servers:
config firewall acl
edit 1
set interface "port2"
set srcaddr "all"
set dstaddr "Company_Servers"
set service "TELNET"
next
end
config firewall acl6
edit 1
set interface "port2"
set srcaddr "all"
set dstaddr "Company_Servers_v6"
set service "TELNET"
next
end

Diagnose commands
To check the number of packets drop by an ACL:
# diagnose firewall acl counter
ACL id 1 dropped 0 packets
# diagnose firewall acl counter6
ACL id 2 dropped 0 packets

To clear the packet drop counter:
# diagnose firewall acl clearcounter
# diagnose firewall acl clearcounter6

Mirroring SSL traffic in policies
You can configure the mirroring of SSL inspected traffic for IPv4 and IPv6 policies in the GUI.
SSL inspection is automatically enabled when you enable a security profile in the policy configuration page.

To configure mirroring of SSL traffic in a policy:
1.
2.
3.
4.
5.

Go to Policy & Objects > IPv4 Policy or IPv6 Policy.
Create a new policy, or edit an existing one.
In the Security Profiles section, for SSL Inspection, select deep-inspection.
Enable Mirror SSL Traffic to Interfaces. The SSL Mirror Terms of Use agreement appears.
Click Agree to accept the terms.
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6. Select an interface from the dropdown.

7. Click OK to save your changes.

Inspection mode per policy
Inspection mode is configured on a per-policy basis in NGFW mode. This gives you more flexibility when setting up
different policies.
When configuring an IPv4 or IPv6 policy, you can select a Flow-based or Proxy-basedInspection Mode. The default
setting is Flow-based.

To configure inspection mode in a policy:
1. Go to Policy & Objects > IPv4 Policy or IPv6 Policy.
2. Create a new policy, or edit an existing policy.
3. Configure the policy as needed.
a. If you change the Inspection Mode to Proxy-based, the Proxy HTTP(S) traffic option displays.
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b. In the Security Profiles section, if no security profiles are enabled, the default SSL Inspection is no-inspection.

c. In the Security Profiles section, if you enable any security profile, the SSL Inspection changes to certificateinspection.

To see the inspection mode changes using the CLI:
config firewall policy
edit 1
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set
set
set
set
set
set
set
set
set
set

uuid 05d88354-4817-51e9-7494-06cb70accbf0
srcintf "wan2"
dstintf "wan1"
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"
inspection-mode proxy
nat enable

next
end

To see the HTTP and SSH policy redirect settings when inspection mode is set to proxy using the CLI:
config firewall policy
edit 1
set uuid 05d88354-4817-51e9-7494-06cb70accbf0
set srcintf "wan2"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set inspection-mode proxy
set http-policy-redirect enable
set ssh-policy-redirect enable
set nat enable
next
end

To see the default SSL-SSH policy set to no inspection using the CLI:
config firewall policy
edit 1
show fu | grep ssl-ssh-profile
set ssl-ssh-profile "no-inspection"
next
end

Combined IPv4 and IPv6 policy
In consolidated policy mode, IPv4 and IPv6 policies are combined into a single policy instead of defining separate
policies.
There is a single policy table for the GUI. The same source interface, destination interface, service, user, and schedule
are shared for IPv4 and IPv6, while there are different IP addresses and IP pool settings.
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To enable consolidated policy mode using the CLI:

Enabling consolidated policy mode will delete all existing IPv4 and IPv6 policies.

config system settings
set consolidated-firewall-mode enable
Enabling consolidated-firewall-mode will delete all firewall policy/policy6. Do you
want to continue? (y/n) y
end

To configure a consolidated policy using the CLI:
config firewall consolidated policy
edit 1
set uuid 754a86b6-2507-51e9-ef0d-13a6e4bf2e9d
set srcintf "port18"
set dstintf "port17"
set srcaddr4 "10-1-100-0" <-------- IPv4 srcaddr
set dstaddr4 "172-16-200-0" <-------- IPv4 dstaddr
set srcaddr6 "2000-10-1-100-0" <-------- IPv6 srcaddr
set dstaddr6 "2000-172-16-200-0" <-------- IPv6 dstaddr
set action accept
set schedule "always"
set service "ALL"
set logtraffic all
set ippool enable
set poolname4 "test-ippool4-1" <-------- IPv4 poolname
set poolname6 "test-ippool6-1" <-------- IPv6 poolname
set nat enable
next
end
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Limitations
The following features are not currently supported by consolidated policy mode:
l
l
l
l
l
l
l
l
l
l

Internet Services entries
address-negate and service-negate
DSCP and ToS matching
Traffic shapers
Packet capture
External IP lists
schedule-timeout, block-notification, disclaimer, custom-log-fields, or reputation
timeout-send-rst, tcp-session-without-syn, or anti-replay
Interface Pair View function in the pane toolbar
Policy Lookup function in the pane toolbar

The session/iprope tables for IPv4 and IPv6 still display separately.

FortiGuard DNS filter for IPv6 policies
You can add DNS filter profile inspection to IPv6 policies. This includes FortiGuard DNS filtering (with a web filtering
license) and portal replacement message redirect.

To apply a DNS filter profile to an IPv6 policy using the CLI:
config firewall policy6
edit 1
set name "IPV6-DNSFilter"
set uuid b1adb096-1919-51e9-05c7-87813d4e2b2a
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set dnsfilter-profile "default"
set ssl-ssh-profile "protocols"
set nat enable
next
end
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A new CLI variable is added to the DNS filter profile for the IPv6 address of the SDNS redirect portal, redirectportal6:
config dnsfilter profile
edit "default"
set comment "Default dns filtering."
config domain-filter
unset domain-filter-table
end
config ftgd-dns
unset options
config filters
edit 1
set category 2
set action monitor
next
edit 2
set category 7
set action monitor
next
......
end
set log-all-domain disable
set sdns-ftgd-err-log enable
set sdns-domain-log enable
set block-action redirect
set block-botnet enable
set safe-search disable
set redirect-portal 0.0.0.0
set redirect-portal6 ::
next
end

After the FortiGate successfully initializes communication with the SDNS server (for the domain rating service), the
following CLI command shows the default redirect portal IPv6 address:
(global) # diagnose test application dnsproxy 3
......
FGD_REDIR_V4:208.91.112.55 FGD_REDIR_V6:[2001:cdba::3257:9652]

OSPFv3 neighbor authentication
OSPFv3 neighbor authentication is available for enhanced IPv6 security.

To configure an OSPF6 interface:
config router ospf6
config ospf6-interface
edit <name>
set authentication {none | ah | esp | area}
set key-rollover-interval <integer>
set ipsec-auth-alg {md5 | sha1 | sha256 | sha384 | sha512}
set ipsec-enc-alg {null | des | 3des | aes128 | aes192 | aes256}
config ipsec-keys
edit <spi>
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set auth-key <string>
set enc-key <string>
next
end
next
end
end

To configure an OSPF6 virtual link:
config router ospf6
config area
edit <id>
config virtual-link
edit <name>
set authentication {none | ah | esp | area}
set key-rollover-interval <integer>
set ipsec-auth-alg {md5 | sha1 | sha256 | sha384 | sha512}
set ipsec-enc-alg {null | des | 3des | aes128 | aes192 | aes256}
config ipsec-keys
edit <spi>
set auth-key <string>
set enc-key <string>
next
end
next
end
next
end
end

To configure an OSPF6 area:
config router ospf6
config area
edit <id>
set authentication {none | ah | esp}
set key-rollover-interval <integer>
set ipsec-auth-alg {md5 | sha1 | sha256 | sha384 | sha512}
set ipsec-enc-alg {null | des | 3des | aes128 | aes192 | aes256}
config ipsec-keys
edit <spi>
set auth-key <string>
set enc-key <string>
next
end
next
end
end
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CLI command descriptions
Command

Description

<id>

Area entry IP address.

authentication {none | ah | esp |
area}

Authentication mode:
l none: Disable authentication
l ah: Authentication Header
l esp: Encapsulating Security Payload
l area: Use the routing area authentication configuration

key-rollover-interval <integer>

Enter an integer value (300 - 216000, default = 300).

ipsec-auth-alg {md5 | sha1 |
sha256 | sha384 | sha512}

Authentication algorithm.

ipsec-enc-alg {null | des | 3des |
aes128 | aes192 | aes256}

Encryption algorithm.

<spi>

Security Parameters Index.

auth-key <string>

Authentication key should be hexadecimal numbers.
Key length for each algorithm:
l MD5: 16 bytes
l SHA1: 20 bytes
l SHA256: 32 bytes
l SHA384:48 bytes
l SHA512:84 bytes
If the key is shorter than the required length, it will be padded with zeroes.

enc-key <string>

Encryption key should be hexadecimal numbers.
Key length for each algorithm:
l DES: 8 bytes
l 3DES: 24 bytes
l AES128: 16 bytes
l AES192: 24 bytes
l AES256: 32 bytes
If the key is shorter than the required length, it will be padded with zeroes.

Firewall anti-replay option per policy
When the global anti-replay option is disabled, the FortiGate does not check TCP flags in packets. The per policy antireplay option overrides the global setting. This allows you to control whether or not TCP flags are checked per policy.

To enable the anti-replay option so TCP flags are checked using the CLI:
config firewall policy
edit 1
set name "policyid-1"
set uuid dfcaec9c-e925-51e8-cf3e-fed9a1d42a1c
set srcintf "wan2"
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set
set
set
set
set
set
set
set
set
next
end

dstintf "wan1"
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"
anti-replay enable
logtraffic all
nat enable

Enabling advanced policy options in the GUI
Advanced policy options can be enabled so you can configure the options in the GUI.

To enable advanced policy options:
config system settings
set gui-advanced-policy enable
end

Advanced policy options are now available when creating or editing a policy in the GUI:

To enable configuring TCP sessions without SYN:
config system settings
set tcp-session-without-syn enable
end

TCP sessions without SYN can now be configured when creating or editing a policy in the GUI:

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

630

Policy and Objects

Recognize anycast addresses in geo-IP blocking
An anycast IP can be advertised from multiple locations and the router selects a path based on latency, distance, cost,
number of hops, and so on. This technique is widely used by providers to route users to the closest server. Since the IP
is hosted in multiple geographic locations, there is no way to specify one single location to that IP.
In FortiOS 6.2.0, there is an option to bypass anycast IP ranges in geo-IP blocking. The ISDB contains a list of confirmed
anycast IP ranges that can be used for this purpose.
When the source or destination is set to geoip, you can enable the geoip-anycast option. Once enabled, IPs where
the anycast option is set to 1 in geoip_db are bypassed in country matching and blocking.

You can only use the CLI to configure this feature.

To enable the geoip-anycast option using the CLI:
config firewall policy
edit 1
set name "policyid-1"
set uuid dfcaec9c-e925-51e8-cf3e-fed9a1d42a1c
set srcintf "wan2"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "test-geoip-CA_1"
set action accept
set schedule "always"
set service "ALL"
set geoip-anycast enable
set logtraffic all
set nat enable
next
end
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To check the geoip-anycast option for an IP address using the CLI:
diagnose geoip ip2country 1.0.0.1
1.0.0.1 - Australia, is anycast ip

The anycast IP is 1.0.0.1.

Authentication policy extensions
By default, unauthenticated traffic is permitted to fall to the next policy. This means that unauthenticated users are only
forced to authenticate against a policy when there are no other matching policies. To avoid this, you can force
authentication to always take place.

To set that authentication requirement:
config user setting
set auth-on-demand {always | implicitly}
end

Where:
always

Always trigger firewall authentication on demand.

implicitly (default)

Implicitly trigger firewall authentication on demand. This is the default setting (and
the behavior in FortiOS 6.0 and earlier).

In the following example, authentication is required; traffic that would otherwise be allowed by the second policy is
instead blocked by the first policy.

To use forced authentication:
config user setting
set auth-on-demand always
end
config firewall policy
edit 1
set name "QA to Database"
set srcintf "port10"
set dstintf "port9"
set srcaddr "QA_subnet"
set dstaddr "Database"
set action accept
set schedule "always"
set service "ALL"
set fsso disable
set groups "qa_group"
set nat enable
next
edit 2
set name "QA to Internet"
set srcintf "port10"
set dstintf "port9"
set srcaddr "QA_subnet"
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set
set
set
set
set
set

dstaddr "all"
action accept
schedule "always"
service "ALL"
fsso disable
nat enable

next
end

NTLM extensions
In FortiOS, agentless Windows NT LAN Manager (NTLM) authentication includes support for the following items:
l
l

Multiple servers
Individual users

You can use multiple domain controller servers for the agentless NTLM. They can be used for load balancing and high
service stability.
You can also use user-based matching in groups for Kerberos and agentless NTLM. In these scenarios, FortiOS
matches the user's group information from an LDAP server.

To support multiple domain controllers for agentless NTLM using the CLI:
1. Configure an LDAP server:
config user ldap
edit "ldap-kerberos"
set server "172.18.62.177"
set cnid "cn"
set dn "dc=fortinetqa,dc=local"
set type regular
set username "CN=root,CN=Users,DC=fortinetqa,DC=local"
set password **********
next
end

2. Configure multiple domain controllers:
config user domain-controller
edit "dc1"
set ip-address 172.18.62.177
config extra-server
edit 1
set ip-address 172.18.62.220
next
end
set ldap-server "ldap-kerberos"
next
end

3. Create an authentication scheme and rule:
config authentication scheme
edit "au-ntlm"
set method ntlm
set domain-controller "dc1"
next
end
config authentication rule
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edit "ru-ntlm"
set srcaddr "all"
set ip-based disable
set active-auth-method "au-ntlm"
next
end

4. In the proxy policy, append the user group for authorization:
config firewall proxy-policy
edit 1
set uuid 6cfe58e4-2ff1-51e9-6b4c-a7d4a8db0f30
set proxy explicit-web
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set service "web"
set action accept
set schedule "always"
set groups "ldap-group"
set utm-status enable
set av-profile "av"
set ssl-ssh-profile "deep-custom"
next
end

This configuration uses a round-robin method. When the first user logs in, the FortiGate sends the authentication
request to the first domain controller. Later when another user logs in, the FortiGate sends the authentication
request to another domain controller.
5. Verify the behavior after the user successfully logs in:
# diagnose wad user list
ID: 1825, IP: 10.1.100.71, VDOM: vdom1
user name : test1
duration : 497
auth_type : Session
auth_method : NTLM
pol_id : 1 g_id : 5
user_based : 0 e
xpire : 103
LAN:
bytes_in=2167 bytes_out=7657
WAN:
bytes_in=3718 bytes_out=270

To support individual users for agentless NTLM using the CLI:
1. Configure an LDAP server:
config user ldap
edit "ldap-kerberos"
set server "172.18.62.177"
set cnid "cn"
set dn "dc=fortinetqa,dc=local"
set type regular
set username "CN=root,CN=Users,DC=fortinetqa,DC=local"
set password **********
next
end
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2. Configure the user group and allow user-based matching:
config user group
edit "ldap-group"
set member "ldap" "ldap-kerberos"
config match
edit 1
set server-name "ldap-kerberos"
set group-name "test1"
next
end
next
end

3. Create an authentication scheme and rule:
config authentication scheme
edit "au-ntlm"
set method ntlm
set domain-controller "dc1"
next
end
config authentication rule
edit "ru-ntlm"
set srcaddr "all"
set ip-based disable
set active-auth-method "au-ntlm"
next
end

4. In the proxy policy, append the user group for authorization:
config firewall proxy-policy
edit 1
set uuid 6cfe58e4-2ff1-51e9-6b4c-a7d4a8db0f30
set proxy explicit-web
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set service "web"
set action accept
set schedule "always"
set groups "ldap-group"
set utm-status enable
set av-profile "av"
set ssl-ssh-profile "deep-custom"
next
end

This implementation lets you configure a single user instead of a whole group. The FortiGate will now allow the user
named test1.

To verify the configuration using the CLI:
diagnose wad user list
ID: 1827, IP: 10.1.15.25, VDOM: vdom1
user name : test1
duration : 161
auth_type : Session
auth_method : NTLM
pol_id : 1
g_id : 5

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

635

Policy and Objects
user_based : 0
expire : 439
LAN:
bytes_in=1309 bytes_out=4410
WAN:
bytes_in=2145 bytes_out=544

HTTP to HTTPS redirect for load balancing
Starting with FortiOS 6.2.1, you can configure a virtual server with HTTP to HTTPS redirect enabled. When enabled, a
virtual server can convert a client's HTTP requests to HTTPS requests. Through this mandatory conversion, HTTP traffic
is converted to HTTPS traffic. This conversion improves the security of the user network.
You can only enable this feature by using the CLI. After you enable this feature, traffic flows as follows:
l

l
l

When FortiGate receives an HTTP request for an external IP, such as 10.1.100.201 in the following example,
FortiGate sends an HTTP 303 response back to the original client and redirects HTTP to HTTPS, instead of
forwarding the HTTP request to the real backend servers.
The client browser restarts the TCP session to HTTPS.
The HTTPS session comes to the FortiGate where a matching IPv4 policy allows the HTTPS traffic and establishes
a secure SSL connection, and then forwards the request to the real backend servers.

To configure virtual server with HTTPS redirect enabled:
1. Create a virtual server with server-type set to http:
config firewall vip
edit "virtual-server-http"
set type server-load-balance
set extip 10.1.100.201
set extintf "wan2"
set server-type http
set ldb-method round-robin
set extport 80
config realservers
edit 1
set ip 172.16.200.44
set port 80
next
edit 2
set ip 172.16.200.55
set port 80
next
end
next
end

2. Create a virtual server with server-type set to https and with the same external IP address:
config firewall vip
edit "virtual-server-https"
set type server-load-balance
set extip 10.1.100.201
set extintf "wan2"
set server-type https
set ldb-method round-robin
set extport 443
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config realservers
edit 1 set ip 172.16.200.44
set port 443
next
edit 2
set ip 172.16.200.55
set port 443
next
end
set ssl-certificate "Fortinet_CA_SSL"
next
end

3. Enable the http-redirect option for the virtual server with server-type set to http:
config firewall vip
edit "virtual-server-http"
set http-redirect enable
next
end

4. Add the two virtual servers to a policy:
config firewall policy
edit 9
set srcintf "wan2"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "virtual-server-http" "virtual-server-https"
set action accept
set schedule "always"
set service "ALL"
set inspection-mode proxy set logtraffic all
set auto-asic-offload disable
set nat enable
next
end

GTPv2 in policies
You can use GTPv2 in the policy section of a GTP profile.
GTPv2 is only available for the following advanced fields:
l
l
l
l
l
l
l
l
l

apnmember
apn-sel-mode
messages
max-apn-restriction
imsi-prefix
msisdn-prefix
rat-type
mei
uli
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GTPv2 support includes the following changes for overall GTP support:
l
l

l

rai is no longer supported in any GTP version.
uli can coexist with CGI, SAI, RAI, TAI, ECGI, or LAI, each of which has the pattern MCC.MNC.ID or
MCC.MNC.ID.ID2.
mei can take IMEI (15 digits) or IMEISV (16 digits).

To configure a new GTPv2 policy:
config firewall gtp
edit "gtpv2"
config policy-v2
edit 1
set messages create-ses-req
next
end
next
end

To configure the new ULI format:
This example matches packets with TAI 510-519.01-09.d02a and ECGI 505.02.1409900-14099ff.
config firewall gtp
edit "gtpv2"
config policy-v2
edit 1
set messages create-ses-req
set uli "0" "0" "0" "51*.01-09.d02a" "505.02.14099*"
next
end
next
end

To configure the GTPv2 message type:
config firewall gtp
edit "gtpv2"
config policy-v2
edit 1
set messages create-ses-req create-ses-res modify-bearer-req modify-bearerres
next
end
next
end

To configure the RAT type:
This example includes virtual and NB-IoT types.
config firewall gtp
edit "gtpv2"
config policy-v2
edit 1
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set messages create-ses-req
set rat-type virtual nbiot
next
end
next
end

Use active directory objects directly in policies
Active Directory (AD) groups can be used directly in identity-based firewall policies. You do not need to add remote AD
groups to local FSSO groups before using them in policies.
FortiGate administrators can define how often group information is updated from AD LDAP servers.

To retrieve and use AD user groups in policies:
1.
2.
3.
4.

Set the FSSO Collector Agent AD access mode on page 639
Add an LDAP server on page 640
Create the FSSO collector that updates the AD user groups list on page 640
Use the AD user groups in a policy on page 642

Set the FSSO Collector Agent AD access mode
To use this feature, you must set FSSO Collector Agent to Advanced AD access mode. If the FSSO Collector Agent is
running in the default mode, FortiGate cannot correctly match user group memberships.
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Add an LDAP server
To add an LDAP server in the GUI:
1. Go to User & Device > LDAP Servers.
2. Click Create New.
3. Configure the settings as needed.

4. If secure communication over TLS is supported by the remote AD LDAP server:
a. Enable Secure Connection .
b. Select the protocol.
c. Select the certificate from the CA that issued the AD LDAP server certificate.
If the protocol is LDAPS, the port will automatically change to 636.
5. Click OK.

To add an LDAP server in the CLI:
config user ldap
edit "AD-ldap"
set server "10.1.100.131"
set cnid "cn"
set dn "dc=fortinet-fsso,dc=com"
set type regular
set username "cn=Administrator,cn=users,dc=fortinet-fsso,dc=com"
set password XXXXXXXXXXXXXXXXXXXXXXXX
next
end

Create the FSSO collector that updates the AD user groups list
To create an FSSO agent connector in the GUI:
1.
2.
3.
4.
5.
6.
7.

Go to Security Fabric > Fabric Connectors.
Click Create New.
In the SSO/Identity section, click Fortinet Single Sign-On Agent.
Fill in the Name
Set the Primary FSSO Agent to the IP address of the FSSO Collector Agent, and enter its password.
Set the User Group Source to Local.
Set the LDAP Server to the just created AD-ldap server.
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8. Enable Proactively Retrieve from LDAP Server.
9. Set the Search Filter to (&(objectClass=group)(cn=group*)).
The default search filter retrieves all groups, including Microsoft system groups. In this example, the filter is
configured to retrieve group1, group2, etc, and not groups like grp199.
The filter syntax is not automatically checked; if it is incorrect, the FortiGate might not retrieve any groups.
10. Set the Interval (minutes) to configure how often the FortiGate contacts the remote AD LDAP server to update the
group information.

11. Click OK.
12. To view the AD user groups that are retrieved by the FSSO agent, hover the cursor over the group icon on the fabric
connector listing.

To create an FSSO agent connector in the CLI:
config user fsso
edit "ad-advanced"
set server "10.1.100.131"
set password XXXXXXXXXXXXXX
set ldap-server "AD-ldap"
set ldap-poll enable
set ldap-poll-interval 2
set ldap-poll-filter "(&amp;(objectClass=group)(cn=group*))"
next
end

You view the retrieved AD user groups with the show user adgrp command.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

641

Policy and Objects

Use the AD user groups in a policy
The AD user groups retrieved by the FortiGate can be used directly in firewall policies.

FortiGate Cloud / FDN communication through an explicit proxy
Explicit proxy communication to FortiGate Cloud and FortiGuard servers from FortiGate is enabled. A proxy server can
be configured in the FortiGuard settings so that all FortiGuard connections under the forticldd process can be
established through the proxy server.

Not all FortiGuard services are supported by these proxy settings. For example, web filter
service traffic to FortiGuard will not be directed to the configured proxy.

To configure a proxy server and communicate with FortiGate Cloud though it:
1. Configure FortiGate B as a proxy server:
config firewall proxy-policy
edit 1
set proxy explicit-web
set dstintf "wan1"
set srcaddr "all"
set dstaddr "all"
set service "webproxy"

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

642

Policy and Objects

set
set
set
set

action accept
schedule "always"
logtraffic all
users "guest1"

next
end
config user local
edit "guest1"
set type password
set passwd 123456
next
end
config authentication scheme
edit "local-basic"
set method basic
set user-database "local-user-db"
next
end
config authentication rule
edit "local-basic-rule"
set srcaddr "all"
set ip-based disable
set active-auth-method "local-basic"
next
end

2. Configure a firewall policy on FortiGate B to allow FortiGate A to get DNS resolution:
config firewall policy
edit 1
set name "dns"
set uuid c55cd2fa-9486-51e9-fc0a-c17b296f9c72
set srcintf "port18"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "DNS"
set fsso disable
set nat enable
next
end

3. Configure the FortiGuard proxy settings on FortiGate A:
config system fortiguard
set proxy-server-ip 10.2.2.2
set proxy-server-port 8080
set proxy-username "guest1"
set proxy-password 123456
end

4. On FortiGate A, log in to FortiGate Cloud to activate the logging service:
execute fortiguard-log login <username> <password>

5. On FortiGate A, view the forticldd debug message to see the connection to the log controller through the proxy
server:
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#
[136] fds_on_sys_fds_change: trace
[40] fds_queue_task: req-111 is added to log-controller
[596] fds_https_start_server: server: 172.16.95.168:443
[654] ssl_new: SSL object is created
[117] https_create: proxy server 10.2.2.2 port:8080
[40] fds_queue_task: req-101 is added to message-controller
[596] fds_https_start_server: server: 172.16.95.187:443
[654] ssl_new: SSL object is created
[117] https_create: proxy server 10.2.2.2 port:8080
[124] fds_on_log_setting_change: trace
[528] fds_https_connect: https_connect(172.16.95.168) is established.
[265] fds_svr_default_on_established: log-controller has connected to ip=172.16.95.168
diagnose test application forticldd 1
System=FGT Platform=FG201E
Management vdom: vdom1, id=1, ha=master.
acct_id=user@fortinet.com
acct_st=OK
FortiGuard log: status=enabled, full=overwrite, ssl_opt=1, source-ip=0.0.0.0
Centra Management: type=FGD, flags=000000bf.
active-tasks=0

Objects
The following topics provide information about objects:
l
l
l
l
l
l

Address group exclusions on page 644
MAC addressed-based policies on page 646
Dynamic policy — fabric devices on page 648
FSSO dynamic address subtype on page 650
ClearPass integration for dynamic address objects on page 654
Using wildcard FQDN addresses in firewall policies on page 659

Address group exclusions
Specific IP addresses or ranges can be subtracted from the address group with the Exclude Members setting in IPv4
address groups.

This feature is only supported for IPv4 address groups, and only for addresses with a Type of
IP Range or Subnet.
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To exclude addresses from an address group using the GUI:
1. Go to Policy & Objects > Addresses.
2. Create a new address group, or edit an existing address group.

3. Enable Exclude Members. The Select Entries pane opens.
4. Select the addresses you want to exclude from the group.
5. Click OK.

The excluded members are listed in the Exclude Members column.

To exclude addresses from an address group using the CLI:
config firewall addrgrp
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edit <address group>
set exclude enable
set exclude-member <address> <address> ... <address>
next
end

MAC addressed-based policies
MAC address ranges can be added to the following IPv4 policies:
l
l
l
l
l

Firewall
Virtual wire pair
ACL
Central SNAT
DoS

A MAC address is a link layer-based address type and it cannot be forwarded across different IP segments.
FortiOS only supports the MAC address type as source address for policies in NAT mode VDOM. When you use the
MAC address type in a policy as source address in NAT mode VDOM, IP address translation (NAT) is still performed
according to the rules defined in the policy. The MAC address type only works for source address matching. It does not
have any association with NAT actions.
For policies in transparent mode or the virtual wire pair interface, you can use the MAC address type as source or
destination address.

To configure a MAC address range using the GUI:
1. Go to Policy & Objects > Addresses to create or edit an address:
a. For Category, select Address.
b. For Type, select MAC Address Range.
c. Enter the address range in the empty fields.
d. Configure the other fields as needed.
e. Click OK.
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2. Go to Policy & Objects > IPv4 Policy to apply the address type to a policy in NAT mode VDOM:
a. For Source, select the MAC address you just configured.
b. For Destination, select an address.

In NAT mode VDOM, this address type cannot be used as destination address.

c. Click OK.

To configure a MAC address range using the CLI:
1. Create a new MAC address range type:
config firewall address
edit <object_name>
set type mac
set start-mac <mac_address_start #>
set end-mac <mac_address_end #>
next
end

2. Apply the address type to a policy. In transparent mode or the virtual wire pair interface, this address type can be
mixed with other address types in the policy:
config firewall address
edit "test-mac-addr1"
set type mac
set start-mac 00:0c:29:41:98:88
set end-mac 00:0c:29:41:98:88
next
end
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config firewall policy
edit 1
set srcintf "port2"
set dstintf "port1"
set srcaddr "test-mac-addr1" "10-1-100-42"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set logtraffic all
set nat enable
next
end

Dynamic policy — fabric devices
The dynamic address group represents the configured IP addresses of all Fortinet devices connected to the Security
Fabric. It currently includes FortiManager, FortiAnalyzer, FortiClient EMS, FortiMail, FortiAP(s), and FortiSwitch(es).
Like other dynamic address groups for fabric connectors, it can be used in IPv4 policies and objects.
The list of firewall addresses includes a default address object called FABRIC_DEVICE. You can apply the FABRIC_
DEVICE object to the following types of policies:
l
l
l
l
l

IPv4 firewall policy (including virtual wire pairs)
IPv4 shaping policy
IPv4 ACL policy
policy64 and policy46 (IPv4 only)
Consolidated policy (IPv4 only)

You cannot apply the FABRIC_DEVICE object to the following types of policies:
l
l

All IPv6 policies
IPv4 explicit proxy policy

You also cannot use the FABRIC_DEVICE object with the following settings:
l
l

Custom extension on internet-service
Exclusion of addrgrp

Initially the FABRIC_DEVICE object does not have an address value. The address value is populated dynamically as
things change. As a result, you cannot edit the FABRIC_DEVICE object, add any addresses to the object, or remove any
addresses from the object. The Edit Address pane in the GUI only has a Return button because the object is read-only:

The FABRIC_DEVICE object address values are populated based on:
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l
l
l
l
l
l

FortiAnalyzer IP (from the Fabric Settings pane)
FortiManager IP (from the Fabric Settings pane)
FortiMail IP (from the Fabric Settings pane)
FortiClient EMS IP (from the Fabric Settings pane)
FortiAP IPs (from the FortiAP Setup pane or DHCP)
FortiSwitch IPs (from the FortiSwitch Setup page or DHCP)

To apply the FABRIC_DEVICE object to an IPv4 policy using the GUI:
1. Go to Policy & Objects > IPv4 Policy.
2. Create a new policy or edit an existing policy.
3. For the Destination field, select FABRIC_DEVICE from the list of address entries.

4. Configure the rest of the policy as needed.
5. Click OK.

To apply the FABRIC_DEVICE object to an IPv4 policy using the CLI:
(root) # show fu firewall address FABRIC_DEVICE
config firewall address
edit "FABRIC_DEVICE"
set type ipmask
set comment "IPv4 addresses of Fabric Devices."
set visibility enable
set associated-interface ''
set color 0
set allow-routing disable
set subnet 0.0.0.0 0.0.0.0
next
end
(root) # show firewall policy
config firewall policy
edit 1
set uuid cbe9e74c-37c6-51e9-9cf1-9510b503f2bf
set srcintf "port2"
set dstintf "port1"
set srcaddr "all"
set dstaddr "FABRIC_DEVICE"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set fsso disable
set nat enable
next
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end

Diagnose command
You can use the diagnose command to list which IP addresses are included in the FABRIC_DEVICE. This is currently
the only method to list content in the FABRIC_DEVICE object.

To run the diagnose command using the CLI:
(root) # diagnose firewall iprope list 100004
policy index=1 uuid_idx=25 action=accept
flag (8050108): redir nat master use_src pol_stats
flag2 (4000): resolve_sso
flag3 (20):
schedule(always)
cos_fwd=255 cos_rev=255
group=00100004 av=00004e20 au=00000000 split=00000000
host=0 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 10 -> zone(1): 9
source(1): 0.0.0.0-255.255.255.255, uuid_idx=3,
dest(5): 172.18.64.48-172.18.64.48, uuid_idx=1, 172.18.60.25-172.18.60.25, uuid_idx=1,
172.18.52.154-172.18.52.154, uuid_idx=1, 172.18.28.31-172.18.28.31, uuid_idx=1,
172.18.62.6-172.18.62.6, uuid_idx=1,
service(1):
[0:0x0:0/(0,65535)->(0,65535)] helper:auto

FSSO dynamic address subtype
The Fortinet Single Sign-ON (FSSO) dynamic firewall address subtype can be used in policies that support dynamic
address types. The FortiGate will update the dynamic address used in firewall policies based on the source IP
information for the authenticated FSSO users.
It can also be used with FSSO group information that is forwarded by ClearPass Policy Manager (CPPM) via
FortiManager, and other FSSO groups provided by the FSSO collector agent or FortiNAC.

To configure FSSO dynamic addresses with CPPM and FortiManager in the GUI:
1. Create the dynamic address object:
a. Go to Policy & Objects > Addresses > Create New > Address.
b. For Type, select Dynamic.
c. For Sub Type, select Fortinet Single Sign-On (FSSO). The Select Entries pane opens and displays all available
FSSO groups.
d. Select one or more groups.
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e. Click OK to save the configuration.

When the address table appears, there will be an error message for the address you just created (Unresolved
dynamic address: fsso). This is expected because there are currently no authenticated FSSO users (based on
source IP) in the local FSSO user list.
2. Add the dynamic address object to a firewall policy:
a. Go to Policy & Objects > IPv4 Policy.
b. Create a new policy or edit an existing policy.
c. For Source, add the dynamic FSSO address object you just created.
d. Configure the rest of the policy as needed.
e. Click OK to save your changes.

3. Test the authentication to add a source IP address to the FSSO user list:
a. Log in as user and use CPPM for user authentication to connect to an external web server. After successful
authentication, CPPM forwards the user name, source IP address, and group membership to the FortiGate via
FortiManager.
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b. Go to Monitor > Firewall User Monitor to view the user name (fsso1) and IP address.

c. Go to Policy & Objects > Addresses to view the updated address table. The error message no longer appears.
d. Hover over the dynamic FSSO address to view the IP address (fsso resolves to: 10.1.100.185).

To verify user traffic in the GUI:
1. Go to Log & Report > Forward Traffic.
Details for the user fsso1 are visible in the traffic log:
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l

If another user is authenticated by CPPM, then the dynamic address fsso entry in the address table will be
updated. The IP address for user fsso2 (10.1.100.188) is now visible:

2. Go to FortiView > Sources to verify that the users were able to successfully pass the firewall policy.

If a user logs off and CPPM receives log off confirmation, then CPPS updates the FortiGate
FSSO user list via FortiManager. The user IP address is deleted from the dynamic FSSO
address, and the user is no longer be able to pass the firewall policy.

To configure FSSO dynamic addresses with CPPM and FortiManager in the CLI:
1. Create the dynamic address object:
config firewall address
edit "fsso"
set uuid 6f63c872-c90b-51e9-ebfd-16c18807c795
set type dynamic
set sub-type fsso
set fsso-group "cp_test_FSSOROLE"
next
end

2. Add the dynamic address object to a policy:
config firewall policy
edit 1
set name "pol1"
set uuid 2b88ed8a-c906-51e9-fb25-8cb12172acd8
set srcintf "port2"
set dstintf "port3"
set srcaddr "fsso"
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set
set
set
set
set
set
set

dstaddr "all"
action accept
schedule "always"
service "ALL"
logtraffic all
fsso disable
nat enable

next
end

To verify user traffic in the CLI:
1. Check the FSSO user list:
diagnose debug authd fsso list
----FSSO logons---IP: 10.1.100.185 User: fsso1 Groups: cp_test_FSSOROLE
CPPM cp_test_FSSOROLE
Total number of logons listed: 1, filtered: 0
----end of FSSO logons----

Workstation:

MemberOf: FSSO-

2. Check the authenticated firewall users list:
diagnose firewall auth list
10.1.100.185, fsso1
type: fsso, id: 0, duration: 2928, idled: 2928
server: FortiManager
packets: in 0 out 0, bytes: in 0 out 0
group_id: 2 33554433
group_name: FSSO-CPPM cp_test_FSSOROLE
----- 1 listed, 0 filtered ------

After user traffic passes through the firewall, the nu
diagnose firewall auth list
10.1.100.185, fsso1
type: fsso, id: 0, duration: 3802, idled: 143
server: FortiManager
packets: in 1629 out 1817, bytes: in 2203319 out 133312
group_id: 2 33554433
group_name: FSSO-CPPM cp_test_FSSOROLE
----- 1 listed, 0 filtered ------

ClearPass integration for dynamic address objects
ClearPass Policy Manager (CPPM) can gather information about the statuses of network hosts, for example, the latest
patches or virus infections. Based on this information, CPPM send the IP addresses and current states, such as Healthy
or Infected, to the FortiGate.
On the FortiGate, the IP addresses received from CPPM are added to a dynamic firewall address with the clearpass-spt
subtype. This address can be used in any policy that supports dynamic addresses, such as Firewall or SSL-VPN
policies.
In this example, you create two dynamic IP addresses that are used in two firewall policies (deny and allow). One policy
allows traffic (host state = Healthy), and the other denies traffic (host state = Infected). When CPPM sends the
information, the IP addresses are assigned according to their host state: Healthy or Infected.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

654

Policy and Objects

You can then verify that traffic from the Infected host is denied access by the deny policy, and traffic from the Healthy
host is allowed access by the allow policy.

Create a REST API administrator
A RESET API administrator is required to generate an authorization token for REST API messages, and to limit hosts
that can send REST API messages to the FortiGate.

To create a REST API administrator in the GUI:
1.
2.
3.
4.
5.

Go to System > Administrators.
Click Create New > REST API Admin.
Configure the Username and other information as needed.
Disable PKI Group.
In the Trusted Hosts field, enter 10.1.100.0/24.

For this example, an administrator profile called clearpass was created with full read/write access. See
Administrator profiles for details.
6. Click OK.
The New API key pane opens.

The API key is the REST API authorization token that is used in REST API messages sent by CPPM to the
FortiGate.
7. Copy the API key to a secure location. A new key can be generated if this one is lost or compromised.
8. Click Close.
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To create a REST API administrator in the CLI:
config system api-user
edit "cpi-back"
set accprofile "clearpass"
config trusthost
edit 1
set ipv4-trusthost 10.1.100.0 255.255.255.0
next
end
next
end
execute api-user generate-key cp-api
New API key: 0f1HxGHh9r9p74k7qgfHNH40p51bjs
NOTE: The bearer of this API key will be granted all access privileges assigned to the
api-user cp-api.

Create dynamic IP addresses with the clearpass subtype
Two dynamic IP addresses are required, one for the allow policy, and the other for the deny policy.

To create the dynamic IP addresses:
config firewall address
edit "cppm"
set uuid 62a180c0-cb36-51e9-6e70-4a2034d82179
set type dynamic
set sub-type clearpass-spt
set clearpass-spt healthy
set comment ''
set visibility enable
set associated-interface ''
set color 0
next
edit "cppm-deny"
set uuid b318e962-cb36-51e9-7a34-74a34cf3bf0b
set type dynamic
set sub-type clearpass-spt
set clearpass-spt infected
set comment ''
set visibility enable
set associated-interface ''
set color 0
next
end

Create firewall policies
Two firewall policies are required, one to accept traffic (cppm-allow), and the other to deny traffic (cppm-deny).
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To create the firewall policies in the GUI:
1. Go to Policy & Objects > IPv4 Policy.
2. Configure the allow policy:
a. Click Create New.
b. Enter a name for the policy.
c. Set Source set to cppm.
d. Set Action to ACCEPT.
e. Configure the remaining settings as needed.

f. Click OK.
3. Configure the deny policy:
a. Click Create New.
b. Enter a name for the policy.
c. Set Source set to cppm-deny.
d. Set Action to DENY.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

657

Policy and Objects
e. Configure the remaining settings as needed.

f. Click OK.

To create the firewall policies in the CLI:
config firewall address
edit "cppm"
set uuid 62a180c0-cb36-51e9-6e70-4a2034d82179
set type dynamic
set sub-type clearpass-spt
set clearpass-spt healthy
set comment ''
set visibility enable
set associated-interface ''
set color 0
next
edit "cppm-deny"
set uuid b318e962-cb36-51e9-7a34-74a34cf3bf0b
set type dynamic
set sub-type clearpass-spt
set clearpass-spt infected
set comment ''
set visibility enable
set associated-interface ''
set color 0
next
end

Verification
Go to Log & Report > Forward Traffic to review traffic logs and ensure that traffic is allowed or denied as expected.
To verify that FortiGate addresses are assigned correctly, enter the following CLI command:
diagnose firewall dynamic list
List all dynamic addresses:
cppm-deny: ID(141)
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ADDR(10.1.100.188)
cppm: ID(176)
ADDR(10.1.100.185)
ADDR(10.1.100.186)

Using wildcard FQDN addresses in firewall policies
You can use wildcard FQDN addresses in firewall policies.
The firewall policy types that support wildcard FQDN addresses include IPv4, IPv6, ACL, local, shaping, NAT64, NAT46,
and NGFW.
When the wildcard FQDN gets the resolved IP addresses, FortiOS loads the addresses into the firewall policy for traffic
matching.

To create a wildcard FQDN using the GUI:
1.
2.
3.
4.

Go to Policy & Objects > Addresses and click Create New > Address.
Specify a Name.
For Type, select FQDN.
For FQDN, enter a wildcard FQDN address, for example, *.fortinet.com.

5. Click OK.

To use a wildcard FQDN in a firewall policy using the GUI:
1. Go to Policy & Objects > IPv4 Policy and click Create New..
2. For Destination, select the wildcard FQDN.
3. Configure the rest of the policy as needed.
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4. Click OK.
In this example, policy ID 2 uses the wildcard FQDN:

To create a wildcard FQDN using the CLI:
config firewall address
edit "test-wildcardfqdn-1"
set uuid 7288ba26-ce92-51e9-04c0-39c707eb4519
set type fqdn
set fqdn "*.fortinet.com"
next
end

To use wildcard FQDN in a firewall policy using the CLI:
config firewall policy
edit 2
set uuid 2f5ffcc0-cddc-51e9-0642-ab9966b202dd
set srcintf "port3"
set dstintf "port1"
set srcaddr "all"
set dstaddr "test-wildcardfqdn-1"
set action accept
set schedule "always"
set service "ALL"
set auto-asic-offload disable
set nat enable
next
end

To use the diagnose command to list resolved IP addresses of wildcard FQDN objects:
diagnose firewall fqdn list
List all FQDN:
*.fortinet.com: ID(48) ADDR(208.91.114.104) ADDR(208.91.114.142) ADDR(173.243.137.143) ADDR
(65.104.9.196) ADDR(96.45.36.210)
*.google.com: ID(66) ADDR(172.217.14.238)
login.microsoftonline.com: ID(15) ADDR(40.126.7.64) ADDR(40.126.7.65) ADDR(40.126.7.66) ADDR
(40.126.7.97) ADDR(40.126.7.99) ADDR(40.126.7.100) ADDR(40.126.7.101) ADDR(40.126.7.103)

To use the diagnose command for firewall policies which use wildcard FQDN:
diagnose firewall iprope list 100004
policy index=2 uuid_idx=46 action=accept
flag (8050108): redir nat master use_src pol_stats
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flag2 (4200): no_asic resolve_sso
flag3 (20):
schedule(always)
cos_fwd=255 cos_rev=255
group=00100004 av=00004e20 au=00000000 split=00000000
host=3 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 11 -> zone(1): 9
source(1): 0.0.0.0-255.255.255.255, uuid_idx=0,
destination fqdn or dynamic address (1):
*.fortinet.com ID(48) uuid_idx=57 ADDR(208.91.114.104) ADDR(208.91.114.142) ADDR
(173.243.137.143) ADDR(65.104.9.196) ADDR(96.45.36.210)
service(1):
[0:0x0:0/(0,0)->(0,0)] helper:auto

Traffic shaping
QoS (quality of service) is the capability to adjust quality aspects of your overall network traffic, including techniques
such as priority-based queuing and traffic policing. Because bandwidth is finite and some types of traffic are slow, jitter or
packet loss sensitive, bandwidth intensive, or critical for operations, QoS is a useful tool to optimize the performance of
various applications in your network. QoS is especially important for managing voice and streaming multimedia traffic
because these types of traffic can rapidly consume bandwidth and are sensitive to latency. You can implement QoS on
FortiGate devices using the following techniques:

Technique

Description

Traffic policing

The FortiGate drops packets that do not conform to the configured bandwidth
limitations.
Note that excessive traffic policing can degrade network performance rather than
improve it.

Traffic shaping

The FortiGate ensures that traffic consumes bandwidth at least at the guaranteed
rate by assigning a greater priority queue to the traffic if the guaranteed rate is not
being met.
The FortiGate ensures that traffic does not consume more than the maximum
configured bandwidth. Traffic that exceeds the maximum rate is subject to traffic
policing.

Queuing

The FortiGate transmits packets in the order of their assigned priority queue for
that physical interface. All traffic in a higher priority traffic queue must be
completely transmitted before traffic in lower priority queues is transmitted.

When determining how to configure QoS, it is helpful to know when a FortiGate uses each technique in the overall traffic
processing flow and the considerations for each technique. After the FortiGate accepts packets, it classifies the traffic
and may apply traffic policing at additional points during traffic processing. The FortiGate may also apply QoS
techniques, such as prioritization and traffic shaping. Traffic shaping consists of both traffic policing to enforce bandwidth
limits and adjusting priority queues to help packets achieve the guaranteed rate.
Traffic shaping accuracy is optimal for security policies without a protection profile where no FortiGate content inspection
is processed.
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You can enable traffic shaping in System > Feature Visibility under the Additional Features
section.

The following topics provide information about configuring traffic shaping policies:
l
l
l
l
l
l
l
l
l
l
l
l
l

Determining your QoS requirements on page 662
Packet rates on page 663
Interface bandwidth limit on page 665
Changing traffic shaper bandwidth unit of measurement on page 666
Shared traffic shaper on page 666
Per-IP traffic shaper on page 670
Type of Service-based prioritization and policy-based traffic shaping on page 673
Interface-based traffic shaping profile on page 676
Classifying traffic by source interface on page 684
Configuring traffic class IDs on page 685
Traffic shaping schedules on page 687
QoS assignment and rate limiting for quarantined VLANs on page 689
Weighted random early detection queuing on page 690

Determining your QoS requirements
Before implementing QoS, you should identify the types of traffic that:
l
l
l

Are important to your organization
Use high amounts of bandwidth
Are sensitive to latency or packet loss

Discovering the needs and relative importance of each traffic type on your network will help you design an appropriate
overall approach, including how you configure each available QoS component technique. Some organizations discover
they only need to configure bandwidth limits for some services. Other organizations determine they need to fully
configure interface and security policy bandwidth limits for all services, and prioritize the queuing of critical services
relative to traffic rate.
For example, your organization wants to guarantee sufficient bandwidth for revenue-producing e-commerce traffic. You
need to ensure that customers complete transactions and do not experience service delays. At the same time, you need
to ensure low latency for voice over IP (VoIP) traffic that sales and customer support teams use, while traffic latency and
bursts may be less critical to the success of other network applications, such as long term, resumable file transfers.

Best practices
The following list includes recommendations and considerations when configuring QoS in your network:
l

l

Ensure maximum bandwidth limits at the source interface and security policy are not too low. This can cause the
FortiGate to discard an excessive number of packets.
Consider the ratios of how packets are distributed between the available queues, and which queues are used by
which types of services. Assigning most packets to the same priority queue can reduce the effects of configuring
prioritization. Assigning a lot of high bandwidth services to high priority queues may take too much bandwidth away
from lower priority queues and cause increased or indefinite latency. For example, you may want to prioritize a
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l

l

latency-sensitive service, such as SIP, over a bandwidth-intensive service, such as FTP. Also consider that
bandwidth guarantees can affect queue distribution, and assign packets to queue 0 instead of their regular queue in
high-volume situations.
Decide whether or not to guarantee bandwidth because it causes the FortiGate to assign packets to queue 0 if the
guaranteed packet rate is not being met. When you compare queuing behavior for low and high bandwidth
situations, this means the effect of prioritization only becomes visible as traffic volumes rise and exceed their
guarantees. Because of this, you might want only some services to use bandwidth guarantees. This way, you can
avoid the possibility that all traffic uses the same queue in high-volume situations, which negates the effects of
configuring prioritization.
Configure prioritization for all through traffic by either ToS (type of service)-based priority or security policy priority,
not both, to simplify analysis and troubleshooting. Traffic subject to both ToS-based and security policy priorities
use a combined priority from both parts of the configuration. Traffic subject to only one of the prioritization methods
will use only that priority. If you configure both methods, or if you configure either method for only a subset of traffic,
packets that apply to the combined configuration may receive a lower priority queue than packets that apply to only
one of the priority methods, as well as packets that do not apply to the configured prioritization. For example, if both
the ToS-based priority and security policy priority dictate that a packet should receive a medium priority, in the
absence of bandwidth guarantees, a packet will use queue 3. If only ToS-based priority is configured, the packet will
use queue 1. If only security policy priority is configured, the packet will use queue 2. If no prioritization is
configured, the packet will use queue 0.
l Because you can configure QoS using a combination of security policies and ToS-based priorities, and to
distribute traffic over the six possible queues for each physical interface, the results of those configurations can
be more difficult to analyze because of their complexity. In those cases, prioritization behavior can vary by
several factors, including: traffic volume, ToS or differentiated services (DiffServ) markings, and correlation of
session to a security policy.
The FortiGate does not prioritize traffic based on the differentiated services code point
(DSCP) marking configured in the security policy. However, ToS-based prioritization
can be used for ingress traffic.

l

l

Use the UDP protocol to obtain more accurate testing results. Packets that are discarded by traffic shapers impact
flow-control mechanisms, such as TCP.
Do not oversubscribe outbandwidth throughput. For example, sum [guaranteed bandwidth] < outbandwidth. For
accurate bandwidth calculations, you must set the outbandwidth parameter on interfaces.

Packet rates
The formula for packet rates specified for maximum bandwidth or guaranteed bandwidth is:
rate = amount / time
where rate is in Kbps
Burst size cannot exceed the configured maximum bandwidth. The FortiGate drops packets that exceed the configured
maximum bandwidth. Packets deduct from the amount of bandwidth available to subsequent packets, and available
bandwidth regenerates at a fixed rate. As a result, the available bandwidth for a packet may be less than the configured
rate, down to a minimum of 0 Kbps.
Alternatively, rate calculation and behavior can be described using the token bucket metaphor. A traffic flow has an
associated bucket, which represents burst size bounds and is the size of the configured bandwidth limit. The bucket
receives tokens, which represent available bandwidth at the fixed configured rate. As time passes, tokens are added to
the bucket up to capacity, and excess tokens are discarded. When a packet arrives at the FortiGate, the packet must
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deduct bandwidth tokens from the bucket equal to its size in order to leave the FortiGate. If there are not enough tokens,
the packet cannot leave the FortiGate and is dropped.
Bursts are not redistributed over a longer interval, so bursts are propagated rather than smoothed. However, peak size is
limited. The maximum burst size is the capacity of the bucket, which is the configured bandwidth limit. The actual size
varies depending on the current number of tokens in the bucket, which may be less than the capacity of the bucket due to
deductions made by previous packets and the fixed rate at which tokens accumulate. A depleted bucket refills at the rate
of the configured bandwidth limit. Bursts cannot borrow tokens from other time intervals.
By limiting traffic peaks and token regeneration, the available bandwidth may be less than the capacity of the bucket, but
the limit of the total amount per time interval is ensured. Total bandwidth use during each interval of one second is, at
most, the integral of the configured rate.

Rate discrepancy
You may observe that external clients, such as FTP or BitTorrent, initially report rates between the maximum bandwidth
and twice the amount of the maximum bandwidth depending on the size of their initial burst. For example, when a
connection is initiated following a period of no network activity. The apparent discrepancy in rates is caused by a
difference in perspective when delimiting time intervals. A burst from the client may initially consume all tokens in the
bucket, and before the end of one second as the bucket regenerates, is allowed to consume almost another bucket
worth of bandwidth. From the perspective of the client, this equals one time interval. However, from the perspective of
the FortiGate, the bucket cannot accumulate tokens when it is full. Therefore, the time interval for token regeneration
begins after the initial burst and does not contain the burst. These different points of reference result in an initial
discrepancy equal to the size of the burst. The client's rate contains it, but the FortiGate's rate does not. However, if the
connection is sustained to its limit and time progresses over an increasing number of intervals, this discrepancy
decreases in importance relative to the bandwidth total. The client reported rate will eventually approach the configured
rate limit for the FortiGate.

Example
The maximum bandwidth is 50 Kbps, there has been no network activity for one or more seconds, and the bucket is full.
A burst from an FTP client immediately consumes 50 kilobits. Because the bucket completely regenerates over one
second, by the time another second elapses from the initial burst, traffic can consume another 49.999 kilobits, for a total
of 99.999 kilobits between the two points in time. From the vantage point of an external FTP client regulated by this
bandwidth limit, it initially appears that the bandwidth limit is 99.999 Kbps. This is almost twice the configured limit of 50
Kbps. However, bucket capacity only regenerates at the configured rate of 50 Kbps, and the connection can only
consume a maximum of 50 kilobits during each subsequent second. The result is that as bandwidth consumption is
averaged over an increasing number of time intervals, each of which are limited to 50 Kbps, the effect of the first
interval's doubled bandwidth size diminishes proportionately, and the client's reported rate eventually approaches the
configured rate limit. The following table shows the effects of a 50 Kbps limit on client reported rates:

Total size transferred (kilobits)

Time (seconds)

Rate reported by client
(Kbps)

99.999 (50 + 49.999)

1

99.999

149.999

2

74.999

199.999

3

66.666

249.999

4

62.499
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Total size transferred (kilobits)

Time (seconds)

Rate reported by client
(Kbps)

299.999

5

59.998

349.999

6

58.333

Guaranteed bandwidth can also be described using a token bucket metaphor. However, because this feature attempts
to achieve or exceed a rate rather than limit it, the FortiGate does not discard non-conforming packets, as it does for
maximum bandwidth. Instead, when the flow does not achieve the rate, the FortiGate increases the packet priority
queue, in an effort to increase the rate.
Guaranteed and maximum bandwidth rates apply to the bidirectional total for all sessions controlled by the security
policy. For example, an FTP connection may entail two separate connections for the data and control portion of the
session. Some packets may be reply traffic rather than initiating traffic. All packets for both connections are counted
when calculating the packet rate for comparison with the guaranteed and maximum bandwidth rate.

Interface bandwidth limit
You can limit interface bandwidth for arriving and departing traffic. In some cases, the traffic received on an interfaces
could exceed the maximum bandwidth limit defined in the security policy. Rather than waste processing power on
packets that will get dropped later in the process, you can configure FortiGate to preemptively drop excess packets when
they're received at the source interface. A similar command is available to the outgoing interface.
The following diagram shows how excess packets going from LAN to WAN1 can be intercepted and dropped at the
source interface.

To configure an interface bandwidth limit in the GUI:
1. Go to Network > Interfaces.
2. Edit port1.
3. In the Traffic Shaping section set the following options:
a. Enable Inbound Bandwidth and enter 200.
The default bandwidth unit is kbps.
b. Enable Outbound Bandwidth and enter 400.
The default bandwidth unit is kbps.
4. Click OK.
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To configure an interface bandwidth limit in the CLI:
1. On the FortiGate, configure the interface bandwidth limit:
config system interface
edit "port1"
.....
set inbandwidth 200
set outbandwidth 400
.....
next
end

Changing traffic shaper bandwidth unit of measurement
Bandwidth speeds are measured in kilobits per second (Kbps), and bytes that are sent and received are measured in
megabytes (MB). In some cases, this can cause confusion depending on whether your ISP uses kilobits per second
(Kbps), kilobytes per second (KBps), megabits per second (Mbps), or gigabits per second (Gbps).
You can change the unit of measurement for traffic shapers in the CLI.

To change the bandwidth unit of measurement for a shared traffic shaper:
config firewall shaper traffic-shaper
edit <traffic_shaper_name>
set bandwidth-unit {kbps | mbps | gbps}
next
end

To change the bandwidth unit of measurement for a per-IP traffic shaper:
config firewall shaper per-ip-shaper
edit <traffic_shaper_name>
set bandwidth-unit {kbps | mbps | gbps}
next
end

Shared traffic shaper
Shared traffic shaper is used in a firewall shaping policy to indicate the priority and guaranteed and maximum bandwidth
for a specified type of traffic use.
The maximum bandwidth indicates the largest amount of traffic allowed when using the policy. You can set the maximum
bandwidth to a value between 1 and 16776000 Kbps. The GUI displays an error if any value outside this range is used. If
you want to allow unlimited bandwidth, use the CLI to enter a value of 0.
The guaranteed bandwidth ensures that there is a consistent reserved bandwidth available. When setting the
guaranteed bandwidth, ensure that the value is significantly less than the interface's bandwidth capacity. Otherwise, the
interface will allow very little or no other traffic to pass through, potentially causing unwanted latency.
In a shared traffic shaper, the administrator can prioritize certain traffic as high, medium, or low. FortiOS provides
bandwidth to low priority connections only when high priority connections do not need the bandwidth. For example, you
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should assign a high traffic priority to a policy for connecting a secure web server that needs to support e-commerce
traffic. You should assign less important services a low priority.
When you configure a shared traffic shaper, you can apply bandwidth shaping per policy or for all policies. By default, a
shared traffic shaper applies traffic shaping evenly to all policies that use the shared traffic shaper.
When configuring a per-policy traffic shaper, FortiOS applies the traffic shaping rules defined for each security policy
individually. For example, if a per-policy traffic shaper is configured with a maximum bandwidth of 1000 Kbps, any
security policies that have that traffic shaper enabled get 1000 Kbps of bandwidth each.
If a traffic shaper for all policies is configured with a maximum bandwidth of 1000 Kbps, all policies share the 1000 Kbps
on a first-come, first-served basis.
The configuration is as follows:
config firewall shaper traffic-shaper
edit "traffic_shaper_name"
set per-policy enable
next
end

The shared traffic shaper selected in the traffic shaping policy affects traffic in the direction defined in the policy. For
example, if the source port is LAN and the destination is WAN1, the traffic shaping affects the flow in this direction only,
affecting the outbound traffic's upload speed. You can define the traffic shaper for the policy in the opposite direction
(reverse shaper) to affect the inbound traffic's download speed. In this example, that would be from WAN1 to LAN.
The following example shows how to apply different speeds to different types of service. The example configures two
shared traffic shapers to use in two firewall shaping policies. One policy guarantees a speed of 10 Mbps for VoIP traffic.
The other policy guarantees a speed of 1 Mbps for other traffic. In the example, FortiOS communicates with a PC using
port10 and the Internet using port9.

To configure shared traffic shapers in the FortiOS GUI:
1. Create a firewall policy:
a. Go to Policy & Objects > IPv4 Policy. Click Create New.
b. In the Name field, enter Internet Access.
c. From the Incoming Interface dropdown list, select port10.
d. From the Outgoing Interface dropdown list, select port9.
e. For the Source and Destination fields, select all.
f. From the Schedule dropdown list, select always.
g. For the Service field, select ALL.
h. Click OK.
2. Create the shared traffic shapers:
a. Go to Policy & Objects > Traffic Shapers. Click Create New.
b. In the Name field, enter 10Mbps. This shaper is for VoIP traffic.
c. From the Traffic Priority dropdown list, select High.
d. Enable Max Bandwidth and enter 20000. This equates to 20 Mbps.
e. Enable Guaranteed Bandwidth and enter 10000. This equates to 10 Mbps.
f. Click OK.
g. Repeat the process above to create another traffic shaper named 1Mbps. Set the Traffic Priority to Low, the
Max Bandwidth to 10000, and the Guaranteed Bandwidth to 1000.
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3. Create a firewall shaping policy:
a. Go to Policy & Objects > Traffic Shaping Policy. Click Create New.
b. In the Name field, enter VoIP_10Mbps_High. This policy is for VoIP traffic.
c. For the Source and Destination fields, select all.
d. For the Service field, select all VoIP services.
e. For the Outgoing Interface field, select port9.
f. Enable Shared shaper. Select 10Mbps from the dropdown list.
g. Enable Reverse shaper. Select 10Mbps from the dropdown list.
h. Click OK.
i. Repeat the process above to create a firewall shaping policy named Other_1Mbps_Low for other traffic. Set the
Source and Destination to all, Service to ALL, Outgoing Interface to port9, and Shared shaper and Reverse
shaper to 1Mbps.

To configure shared traffic shapers using the FortiOS CLI:
1. Create a firewall policy:
config firewall policy
edit 1
set name "Internet Access"
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set fsso disable
set nat enable
next
end

2. Create the shared traffic shapers:
config firewall shaper traffic-shaper
edit "10Mbps"
set guaranteed-bandwidth 10000
set maximum-bandwidth 20000
next
edit "1Mbps"
set guaranteed-bandwidth 1000
set maximum-bandwidth 10000
set priority low
next
end

3. Create a firewall shaping policy:
config firewall shaping-policy
edit 1
set name "VOIP_10Mbps_High"
set service "H323" "IRC" "MS-SQL" "MYSQL" "RTSP" "SCCP" "SIP" "SIP-MSNmessenger"
set dstintf "port9"
set traffic-shaper "10Mbps"
set traffic-shaper-reverse "10Mbps"
set srcaddr "all"
set dstaddr "all"
next
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edit 2
set
set
set
set
set
set
set
next
end

name "Other_1Mbps_Low"
service "ALL"
dstintf "port9"
traffic-shaper "1Mbps"
traffic-shaper-reverse "1Mbps"
srcaddr "all"
dstaddr "all"

To troubleshoot shared traffic shapers:
1. To check if specific traffic is attached to the correct traffic shaper, run the diagnose firewall iprope list
100015 command. The example output shows the traffic attached to the 10Mbps and 1Mbps shapers:
# diagnose firewall iprope list 100015
policy index=1 uuid_idx=0 action=accept
flag (0):
shapers: orig=10Mbps(2/1280000/2560000)
cos_fwd=0 cos_rev=0
group=00100015 av=00000000 au=00000000 split=00000000
host=4 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 0 -> zone(1): 38
source(1): 0.0.0.0-255.255.255.255, uuid_idx=0,
dest(1): 0.0.0.0-255.255.255.255, uuid_idx=0,
service(15):
[6:0x0:0/(1,65535)->(1720,1720)] helper:auto
[6:0x0:0/(1,65535)->(1503,1503)] helper:auto
[17:0x0:0/(1,65535)->(1719,1719)] helper:auto
[6:0x0:0/(1,65535)->(6660,6669)] helper:auto
[6:0x0:0/(1,65535)->(1433,1433)] helper:auto
[6:0x0:0/(1,65535)->(1434,1434)] helper:auto
[6:0x0:0/(1,65535)->(3306,3306)] helper:auto
[6:0x0:0/(1,65535)->(554,554)] helper:auto
[6:0x0:0/(1,65535)->(7070,7070)] helper:auto
[6:0x0:0/(1,65535)->(8554,8554)] helper:auto
[17:0x0:0/(1,65535)->(554,554)] helper:auto
[6:0x0:0/(1,65535)->(2000,2000)] helper:auto
[6:0x0:0/(1,65535)->(5060,5060)] helper:auto
[17:0x0:0/(1,65535)->(5060,5060)] helper:auto
[6:0x0:0/(1,65535)->(1863,1863)] helper:auto
policy index=2 uuid_idx=0 action=accept
flag (0):
shapers: orig=1Mbps(4/128000/1280000)
cos_fwd=0 cos_rev=0
group=00100015 av=00000000 au=00000000 split=00000000
host=4 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 0 -> zone(1): 38
source(1): 0.0.0.0-255.255.255.255, uuid_idx=0,
dest(1): 0.0.0.0-255.255.255.255, uuid_idx=0,
service(1):
[0:0x0:0/(0,0)->(0,0)] helper:auto
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2. To check if the correct traffic shaper is applied to the session, run the diagnose sys session list command.
The example output shows that the 1Mbps shaper is applied to the session:
# diagnose sys session list
session info: proto=6 proto_state=01 duration=11 expire=3599 timeout=3600 flags=00000000
sockflag=00000000 sockport=0 av_idx=0 use=5
origin-shaper=1Mbps prio=4 guarantee 128000Bps max 1280000Bps traffic 1050Bps drops 0B
reply-shaper=
per_ip_shaper=
class_id=0 shaping_policy_id=2 ha_id=0 policy_dir=0 tunnel=/ helper=ftp vlan_cos=0/255
state=may_dirty npu npd os mif route_preserve
statistic(bytes/packets/allow_err): org=868/15/1 reply=752/10/1 tuples=2
tx speed(Bps/kbps): 76/0 rx speed(Bps/kbps): 66/0
orgin->sink: org pre->post, reply pre->post dev=39->38/38->39 gwy=172.16.200.55/0.0.0.0
hook=post dir=org act=snat 10.1.100.11:58241->172.16.200.55:21(172.16.200.1:58241)
hook=pre dir=reply act=dnat 172.16.200.55:21->172.16.200.1:58241(10.1.100.11:58241)
pos/(before,after) 0/(0,0), 0/(0,0)
misc=0 policy_id=1 auth_info=0 chk_client_info=0 vd=4
serial=0003255f tos=ff/ff app_list=0 app=0 url_cat=0
rpdb_link_id = 00000000
dd_type=0 dd_mode=0
npu_state=0x100000
npu info: flag=0x00/0x00, offload=0/0, ips_offload=0/0, epid=0/0, ipid=0/0,
vlan=0x0000/0x0000
vlifid=0/0, vtag_in=0x0000/0x0000 in_npu=0/0, out_npu=0/0, fwd_en=0/0, qid=0/0
no_ofld_reason: offload-denied helper
total session 1

3. To check statuses of shared traffic shapers, run the diagnose firewall shaper traffic-shaper list
command. The output should resemble the following:
# diagnose firewall shaper traffic-shaper list
name 10Mbps
maximum-bandwidth 2500 KB/sec
guaranteed-bandwidth 1250 KB/sec
current-bandwidth 0 B/sec
priority 2
tos ff
packets dropped 0
bytes dropped 0
name 1Mbps
maximum-bandwidth 1250 KB/sec
guaranteed-bandwidth 125 KB/sec
current-bandwidth 0 B/sec
priority 4
tos ff
packets dropped 0
bytes dropped 0

Per-IP traffic shaper
With per-IP traffic shaping, you can limit each IP address's behavior to avoid a situation where one user uses all of the
available bandwidth. In addition to controlling the maximum bandwidth used per IP address, you can also define the
maximum number of concurrent sessions for an IP address. For example, if you apply a per-IP shaper of 1 Mbps to your
entire network, FortiOS allocates each user/IP address 1 Mbps of bandwidth. Even if the network consists of a single
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user, FortiOS allocates them 1 Mbps. If there are ten users, each user gets 1 Mbps of bandwidth, totaling 10 Mbps of
outgoing traffic.
For shared shapers, all users share the set guaranteed and maximum bandwidths. For example, if you set a shared
shaper for all PCs using an FTP service to 10 Mbps, all users uploading to the FTP server share the 10 Mbps.
Shared shapers affect upload speed. If you want to limit the download speed from the FTP server in the example, you
must configure the shared shaper as a reverse shaper. Per-IP shapers apply the speed limit on both upload and
download operations.
The following example shows how to apply a per-IP shaper to a traffic shaping policy. This shaper assigns each user a
maximum bandwidth of 1 Mbps and allows each user to have a maximum of ten concurrent connections to the FTP
server. In the example, FortiOS communicates with users using port10 and the FTP server using port9.

To configure a per-IP shaper in the FortiOS GUI:
1. Create a firewall policy:
a. Go to Policy & Objects > IPv4 Policy. Click Create New.
b. In the Name field, enter FTP Access.
c. From the Incoming Interface dropdown list, select port10.
d. From the Outgoing Interface dropdown list, select port9.
e. For the Source and Destination fields, select all and FTP_Server, respectively.
f. From the Schedule dropdown list, select always.
g. For the Service field, select ALL.
h. Click OK.
2. Create the per-IP traffic shaper:
a. Go to Policy & Objects > Traffic Shapers. Click Create New.
b. For Type, select Per-IP.
c. In the Name field, enter FTP_Max_1M. This shaper is for VoIP traffic.
d. Enable Max Bandwidth and enter 1000. This equates to 1 Mbps.
e. Enable Max Concurrent Connections and enter 10. This means that each user can have up to ten concurrent
connections to the FTP server.
f. Click OK.
3. Create a firewall shaping policy:
a. Go to Policy & Objects > Traffic Shaping Policy. Click Create New.
b. In the Name field, enter FTP speed 1M.
c. For the Source fields, select the users that need to access the FTP server.
d. For the Destination field, select FTP_Server.
e. For the Service field, select ALL.
f. For the Outgoing Interface field, select port9.
g. Enable Per-IP shaper. Select FTP_Max_1M from the dropdown list.
h. Click OK.

To configure a per-IP traffic shaper using the FortiOS CLI:
1. Create a firewall policy:
config firewall policy
edit 1
set name "FTP Access"
set srcintf "port10"
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set
set
set
set
set
set
set
set
next
end

dstintf "port9"
srcaddr "all"
dstaddr "FTP_Server"
action accept
schedule "always"
service "ALL"
fsso disable
nat enable

2. Create the per-IP traffic shaper:
config firewall shaper per-ip-shaper
edit "FTP_Max_1M"
set max-bandwidth 1000
set max-concurrent-session 10
next
end

3. Create a firewall shaping policy:
config firewall shaping-policy
edit 1
set name "FTP speed 1M"
set service "ALL"
set dstintf "port9"
set per-ip-shaper "FTP_Max_1M"
set srcaddr "PC1" "WinPC" "PC2"
set dstaddr "FTP_Server"
next
end

To troubleshoot per-IP traffic shapers:
1. To check if specific traffic is attached to the correct traffic shaper, run the diagnose firewall iprope list
100015 command. The example output shows the traffic attached to the FTP_Max_1M shaper:
# diagnose firewall iprope list 100015
policy index=3 uuid_idx=0 action=accept
flag (0):
shapers: per-ip=FTP_Max_1M
cos_fwd=0 cos_rev=0
group=00100015 av=00000000 au=00000000 split=00000000
host=2 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 0 -> zone(1): 38
source(3): 10.1.100.11-10.1.100.11, uuid_idx=30, 10.1.100.143-10.1.100.143, uuid_idx=32,
10.1.100.22-10.1.100.22, uuid_idx=31,
dest(1): 172.16.200.55-172.16.200.55, uuid_idx=89,
service(1):
[0:0x0:0/(0,65535)->(0,65535)] helper:auto

2. To check if the correct traffic shaper is applied to the session, run the diagnose sys session list command.
The example output shows that the FTP_Max_1M shaper is applied to the session:
# diagnose sys session list
session info: proto=6 proto_state=01 duration=36 expire=3567 timeout=3600 flags=00000000
sockflag=00000000 sockport=0 av_idx=0 use=4
origin-shaper=
reply-shaper=
per_ip_shaper=FTP_Max_1M
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class_id=0 shaping_policy_id=3 ha_id=0 policy_dir=0 tunnel=/ helper=ftp vlan_cos=0/255
state=may_dirty per_ip npu npd mif route_preserve
statistic(bytes/packets/allow_err): org=506/9/1 reply=416/6/1 tuples=2
tx speed(Bps/kbps): 0/0 rx speed(Bps/kbps): 0/0
orgin->sink: org pre->post, reply pre->post dev=39->38/38->39 gwy=172.16.200.55/0.0.0.0
hook=post dir=org act=snat 10.1.100.11:58275->172.16.200.55:21(172.16.200.1:58275)
hook=pre dir=reply act=dnat 172.16.200.55:21->172.16.200.1:58275(10.1.100.11:58275)
pos/(before,after) 0/(0,0), 0/(0,0)
misc=0 policy_id=1 auth_info=0 chk_client_info=0 vd=2
serial=0000211a tos=ff/ff app_list=0 app=0 url_cat=0
rpdb_link_id = 00000000
dd_type=0 dd_mode=0
npu_state=0x100000
npu info: flag=0x00/0x00, offload=0/0, ips_offload=0/0, epid=0/0, ipid=0/0,
vlan=0x0000/0x0000
vlifid=0/0, vtag_in=0x0000/0x0000 in_npu=0/0, out_npu=0/0, fwd_en=0/0, qid=0/0
no_ofld_reason: offload-denied helper

3. To check statuses of per-IP traffic shapers, run the diagnose firewall shaper per-ip-shaper list
command. The output should resemble the following:
# diagnose firewall shaper per-ip-shaper list
name FTP_Max_1M
maximum-bandwidth 125 KB/sec
maximum-concurrent-session 10
tos ff/ff
packets dropped 0
bytes dropped 0
addr=10.1.100.11 status: bps=0 ses=3

Type of Service-based prioritization and policy-based traffic shaping
Priority queues
After packet acceptance, FortiOS classifies traffic and may apply Quality of Service (QoS) techniques, such as
prioritization and traffic shaping. Traffic shaping consists of a mixture of traffic policing to enforce bandwidth limits and
priority queue adjustment to assist packets in achieving the guaranteed rate.
If you have configured prioritization, FortiOS prioritizes egressing packets by distributing them among first in first out
(FIFO) queues associated with each possible priority number. Each physical interface has six priority queues. Virtual
interfaces use the priority queues of the physical interface that they are bound to.
The physical interface's six queues are queue 0 to 5, where queue 0 is the highest priority queue. You might observe that
your traffic uses only a subset of those six queues. For example, some traffic may always use a certain queue number.
Queuing may also vary by the packet rate or mixture of services. Some queue numbers may only be used by through
traffic for which you have configured traffic shaping in the security policy that applies to that traffic session.
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l
l

l

Administrative access traffic always uses queue 0.
Traffic matching firewall policies without traffic shaping may use queue 0, 1, or 2. The queue is selected based on
the priority value you have configured for packets with that ToS bit value, if you have configured ToS-based
priorities.
Traffic matching firewall shaping policies with traffic shaping enabled can use any queue. The queue is selected
based on whether the packet rate is currently below the guaranteed bandwidth (queue 0), or above the guaranteed
bandwidth. Packets at rates greater than the maximum bandwidth limit are dropped.

Priority types
Packets can be assigned a priority in one of three types:
l
l
l

On entering ingress – for packets flowing through the firewall.
Upon generation – for packets generated by the firewall (including packets generated due to AV proxying).
On passing through a firewall policy – for packets passing through a firewall policy (firewall shaping policy) that has
a traffic shaper defined.

ToS priority
The first and second types, ingress priority and priority for generated packets, are controlled by two different CLI
settings:
config system global
set traffic-priority-level {high | medium | low}
end
config system tos-based-priority
edit 1
set tos [0-15]
<---- type of service bit in the IP datagram header with a value
between 0 and 15
set priority (high | medium | low)
<---- priority of this type of service
next
end

Each priority level is mapped to a value as follows:

ToS priority

Value

High

0

Medium

1

Low

2
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ToS-based traffic prioritization cannot be used to apply bandwidth limits and guarantees, but
can be used to prioritize traffic at per-packet levels.

Example
In the following example configuration, packets with ToS bit values of 10 are prioritized as medium and packets with ToS
bit values of 20 are prioritized as high. All the other traffic is prioritized as low.
config system global
set traffic-priority-level low
end
config system tos-based-priority
edit 1
set tos 10
set priority medium
next
edit 2
set tos 20
set priority high
next
end

Firewall shaping policy priority
You can enable traffic shaping in a firewall shaping policy. In the shared traffic shaper, you can set the firewall priority to
high, medium, or low:
config firewall shaper traffic-shaper
edit 1
set priority {high | medium | low}
next
end

As the priority in a traffic shaper is set to high by default, you must set some traffic at a lower priority to see results. Each
priority level is mapped to a value as follows:

Firewall policy priority

Value

High (default)

1

Medium

2

Low

3

Combination of two priority types
To combine the two priority types, the global or ingress ToS-based priority value is combined with the firewall policy
priority value:
ToS priority (0, 1, 2) + policy priority (1, 2, 3) = total priority (queue number)
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Consider the following scenarios:
l
l
l

If the current packet rate is less than the guaranteed bandwidth, packets use priority queue 0. Packet priority is 0.
If the current packet rate exceeds the maximum bandwidth, excess packets are dropped.
If the current packet rate is greater than the guaranteed bandwidth but less than the maximum bandwidth, FortiOS
assigns a priority queue by adding the ToS-based priority and the firewall priority.
For example, if you have enabled traffic shaping in the security policy and the security policy's traffic priority is low
(value 3), and the priority normally applied to packets with that ToS bit is medium (value 1), the packets have a total
packet priority of 4, and use priority queue 4.

Interface-based traffic shaping profile
A traffic shaping policy can be used for interface-based traffic shaping by organizing traffic into 30 groups. The shaping
profile defines the percentage of the interface bandwidth that is allocated to each group. Each traffic group is shaped to
the assigned speed according to the outgoing bandwidth limit configured to the interface.

Traffic classification
A shaping policy classifies traffic and organizes it into different groups, or class IDs, based on matching criteria. For
traffic matching a criteria, you can choose to put it into 30 different shaping groups, identified by group ID 2 to 31.
You must select an outgoing interface for the traffic. The shaping policy is only applied when the traffic goes to one of the
selected outgoing interfaces.

Criterion
Source

Description
l

l

l

Destination

l

l
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Address: match the source address of the traffic to the selected address or
address group.
User: use the user credentials of the traffic to match the selected user or user
group. At least one address, address group, or internet service must also be
selected.
Internet service: match the traffic to the selected internet service. Internet
services cannot be used if addresses or address or groups are used.
Address: match the destination address of the traffic to the selected address
or address group.
Internet service: match the traffic to the selected internet service. Internet
services cannot be used if addresses or address or groups are used.
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Criterion

Description

Schedule

Match the current date and time to the selected schedule. You can select a onetime schedule, recurring schedule, or schedule group. This setting is optional.

Service

Match the service of the traffic to the selected service or service group.

Application

Match the application of the traffic to the selected application, application
category, or application group.
Application control must be enabled in the related firewall policy to know the
application of the traffic. See Application control on page 816 for more
information.

URL category

Match the URL of the traffic to the selected URL category.
Web filter must be enabled in the related firewall policy to know the URL of the
traffic. See Web filter on page 742 for more information.

When multiple items are selected in one criterion, it is considered a match when traffic
matches any one of them.

Traffic prioritization
Shaping profiles define how different shaping groups or classes of traffic are prioritized. For each group or class, you can
define three prioritization strategies: guaranteed bandwidth, maximum bandwidth, and priority.
For each shaping profile, a default shaping group must be defined. Traffic is prioritized based on the default shaping
group in the following two circumstances:
l
l

All traffic to the outgoing interface that does not match to any shaping policy
Traffic with a shaping group that is not defined in a shaping profile

Prioritization strategy

Description

Guaranteed bandwidth

The percentage of the link speed that is reserved for the shaping group.
The total guaranteed bandwidth for all shaping groups cannot exceed 100%.

Maximum bandwidth

The maximum percentage of the link speed that the shaping group can use.

Priority

The shaping group priority: top, critical, high, medium, or low. When groups are
competing for bandwidth on the interface, the group with the higher priority wins.

Applying a shaping profile to an interface
Traffic shaping is accomplished by configuring the outgoing bandwidth and outgoing shaping profile on an interface. The
shaping profile uses the outgoing bandwidth of the interface as the maximum link speed, and it only works when the
outgoing bandwidth is configured.
This example shows how to apply interface-based traffic shaping to web and file accessing traffic according to a
schedule:
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l
l
l

The link speed of the wan1 interface is 10 Mb/s.
File access can use up to 2 Mb/s from 8:00 AM to 6:00 PM.
Web access can use 8 Mb/s from 8:00 AM to 6:00 PM.

Putting the traffic into shaping groups
To create a recurring schedule using the GUI:
1.
2.
3.
4.

Go to Policy & Objects > Schedules.
Click Create New > Schedule.
Configure a recurring schedule called Day_Hours for everyday from 8:00 AM to 6:00 PM.
Click OK.

To put the web accessing traffic into a shaping group using the GUI:
1.
2.
3.
4.
5.

Go to Policy & Objects > Traffic Shaping Policy.
Click Create New.
Enable Schedule and select the schedule you just created.
Set Service to web accessing services, such as HTTP and HTTPS.
Set Action to Assign Group, then set Outgoing interface to wan1 and Shaping group to 10.
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6. Configure the remaining settings as required.
7. Click OK.

To put the file accessing traffic into a shaping group using the GUI:
1.
2.
3.
4.
5.

Go to Policy & Objects > Traffic Shaping Policy.
Click Create New.
Enable Schedule and select the schedule you just created.
Set Service to file accessing services, such as FTP and SMB.
Set Action to Assign Group, then set Outgoing interface to wan1 and Shaping group to 20.

6. Configure the remaining settings as required.
7. Click OK.

To put the traffic into shaping groups using the CLI:
1. Create a recurring schedule:
config firewall schedule recurring
edit "Day_Hours"
set start 08:00
set end 18:00
set day sunday monday tuesday wednesday thursday friday saturday
next
end

2. Put the web and file accessing traffic into shaping groups:
config firewall shaping-policy
edit 2
set name "web_access_day_hours"
set comment "To limit web accessing traffic to 8Mb/s on day time"
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set
set
set
set
set
set
next
edit 3
set
set
set
set
set
set
set
set
next

service "HTTP" "HTTPS"
schedule "Day_Hours"
dstintf "wan1"
class-id 10
srcaddr "all"
dstaddr "all"

name "File_access_day_hours"
comment "To limit file accessing traffic to 2Mb/s on day time"
service "AFS3" "FTP" "FTP_GET" "FTP_PUT" "NFS" "SAMBA" "SMB" "TFTP"
schedule "Day_Hours"
dstintf "wan1"
class-id 20
srcaddr "all"
dstaddr "all"

end

Allocating bandwidth to the shaping groups
A traffic shaping profile defines the guaranteed and maximum bandwidths each group receives. File access can use up
to 2 Mb/s, and web access can use 8 Mb/s from 8:00 AM to 6:00 PM.

To create a traffic shaping profile using the GUI:
1. Go to Policy & Objects > Traffic Shaping Profile.
2. Click Create New.
3. Configure the default shaping group (30) for all traffic from wan1 that does not match the shaping policy.
This group has a high priority, meaning that when the other groups have reached their guaranteed bandwidths, this
default group will use the rest of the available bandwidth.
4. Under Additional Shaping Groups, click the plus icon twice to add two more shaping groups.
5. Configure shaping group 10 for web accessing traffic. Set the priority to medium.
When other types of traffic are competing for bandwidth, this group is guaranteed to 6 Mb/s, or 60% of the
bandwidth.
6. Configure shaping group 20 for file accessing traffic. Set the priority to medium.
When other types of traffic are competing for bandwidth, this group is guaranteed to 1 Mb/s, or 10% of the
bandwidth.
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7. Click OK.

To create a traffic shaping profile using the CLI:
config firewall shaping-profile
edit "Day_Hours_Profile"
set default-class-id 30
config shaping-entries
edit 1
set class-id 30
set guaranteed-bandwidth-percentage 30
set maximum-bandwidth-percentage 100
next
edit 2
set class-id 10
set priority medium
set guaranteed-bandwidth-percentage 60
set maximum-bandwidth-percentage 80
next
edit 3
set class-id 20
set priority medium
set guaranteed-bandwidth-percentage 10
set maximum-bandwidth-percentage 20
next
end
next
end
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Defining the available bandwidth on an interface
The link speed of the wan1 interface is 10 Mb/s.

To set the bandwidth of the wan1 interface using the GUI:
1.
2.
3.
4.

Go to Network > Interfaces.
Edit the wan1 interface.
Enable Outbound shaping profile and select the profile you just created, Day_Hours_Profile.
Enable Outbound Bandwidth and set it to 10000 Kbps.

5. Click OK.

To set the bandwidth of the wan1 interface using the CLI:
config system interface
edit "wan1"
....
set outbandwidth 10000
set egress-shaping-profile "Day_Hours_Profile"
....
next
end
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Diagnose commands
To check that the specific traffic is put into the correct shaping group or class ID:
# diagnose firewall iprope list 100015
policy index=2 uuid_idx=0 action=accept
flag (0):
schedule(Day_Hours)
cos_fwd=0 cos_rev=0
group=00100015 av=00000000 au=00000000 split=00000000
host=0 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 0 -> zone(1): 25
source(1): 0.0.0.0-255.255.255.255, uuid_idx=6,
dest(1): 0.0.0.0-255.255.255.255, uuid_idx=6,
service(2):
[6:0x0:0/(1,65535)->(80,80)] helper:auto
[6:0x0:0/(1,65535)->(443,443)] helper:auto
class_id: 10
policy index=3 uuid_idx=0 action=accept
flag (0):
schedule(Day_Hours)
cos_fwd=0 cos_rev=0
group=00100015 av=00000000 au=00000000 split=00000000
host=0 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 0 -> zone(1): 25
source(1): 0.0.0.0-255.255.255.255, uuid_idx=6,
dest(1): 0.0.0.0-255.255.255.255, uuid_idx=6,
service(12):
[6:0x0:0/(1,65535)->(7000,7009)] helper:auto
[17:0x0:0/(1,65535)->(7000,7009)] helper:auto
[6:0x0:0/(1,65535)->(21,21)] helper:auto
[6:0x0:0/(1,65535)->(21,21)] helper:auto
[6:0x0:0/(1,65535)->(21,21)] helper:auto
[6:0x0:0/(1,65535)->(111,111)] helper:auto
[6:0x0:0/(1,65535)->(2049,2049)] helper:auto
[17:0x0:0/(1,65535)->(111,111)] helper:auto
[17:0x0:0/(1,65535)->(2049,2049)] helper:auto
[6:0x0:0/(1,65535)->(139,139)] helper:auto
[6:0x0:0/(1,65535)->(445,445)] helper:auto
[17:0x0:0/(1,65535)->(69,69)] helper:auto
class_id: 20

To check the speed limit for each class ID on an interface:
# diagnose netlink interface list wan1
if=wan1 family=00 type=1 index=25 mtu=1500 link=0 master=0
ref=32 state=off start fw_flags=0 flags=up broadcast run allmulti multicast
Qdisc=mq hw_addr=90:6c:ac:13:ec:e0 broadcast_addr=ff:ff:ff:ff:ff:ff
egress traffic control:
bandwidth=10000(kbps) lock_hit=0 default_class=30 n_active_class=3
class-id=20
allocated-bandwidth=1000(kbps) guaranteed-bandwidth=1000(kbps)
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max-bandwidth=2000(kbps)
current-bandwidth=0(kbps)
priority=medium
total_bytes=0
drop_bytes=0
class-id=10
allocated-bandwidth=6000(kbps) guaranteed-bandwidth=6000(kbps)
max-bandwidth=8000(kbps)
current-bandwidth=0(kbps)
priority=medium
total_bytes=0
drop_bytes=0
class-id=30
allocated-bandwidth=3000(kbps) guaranteed-bandwidth=3000(kbps)
max-bandwidth=10000(kbps)
current-bandwidth=5(kbps)
priority=high
total_bytes=136K
drop_bytes=0
stat: rxp=9492 txp=8116 rxb=2761067 txb=4702526 rxe=0 txe=0 rxd=0 txd=0 mc=960 collision=0
re: rxl=0 rxo=0 rxc=0 rxf=0 rxfi=0 rxm=0
te: txa=0 txc=0 txfi=0 txh=0 txw=0
misc rxc=0 txc=0
input_type=0 state=3 arp_entry=0 refcnt=32

Classifying traffic by source interface
In firewall shaping policies, you can classify traffic by source interface with the following command:
config firewall shaping-policy
edit 1
set srcintf <interface_name>
......
next
end

Sample configuration

For this example, there are two shaping policies:
l
l

Policy 1 is for traffic from the Office to the Server, with the speed limited to 5 MB/s.
Policy 2 is for traffic from the Lab to the Server, with the speed limited to 1 MB/s.

To configure the traffic shaping policy:
config firewall shaping-policy
edit 1
set name "Office_Speed_5MB"
set service "ALL"
set srcintf "port13"
set dstintf "port9"
set traffic-shaper "5MB/s"
set traffic-shaper-reverse "5MB/s"
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set srcaddr "all"
set dstaddr "all"
next
edit 2
set
set
set
set
set
set
set
set
next

name "Lab_Speed_1MB"
service "ALL"
srcintf "port10"
dstintf "port9"
traffic-shaper "1MB/s"
traffic-shaper-reverse "1MB/s"
srcaddr "all"
dstaddr "all"

end

Configuring traffic class IDs
As of FortiOS 6.2.2, you can configure traffic class IDs with a descriptive name in the GUI or CLI. Class IDs can help you
correlate traffic shaping policy and profile entries.

GUI configurations
Within the GUI, there are three locations to configure the traffic class ID:
l
l
l

Traffic shaping policy
Traffic shaping profile
Interface

Assign Shaping Class ID replaces the Assign Group functionality in earlier versions of
FortiOS.

To configure the traffic class ID in a traffic shaping policy:
1.
2.
3.
4.
5.

Go to Policy & Objects > Traffic Shaping Policy.
Edit an existing policy, or create a new one.
In the Then: Action section, click Assign Shaping Class ID.
In Traffic shaping class ID, click Create.
Enter a value for the ID (integer) and a description for the Name.
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6. Click OK to save the class ID.

7. Configure the rest of the policy as needed.
8. Click OK to save the policy.

To configure the traffic class ID in a traffic shaping profile:
1.
2.
3.
4.
5.
6.

Go to Policy & Objects > Traffic Shaping Profile.
Edit an existing profile, or create a new one.
In the Traffic Shaping Classes section, click Create New. The Select Traffic Shaping Class ID window opens.
Click Create. The New Traffic Shaping Class ID window opens.
Enter a value for the ID (integer) and a description for the Name.
Click OK to save the class ID.

7. Click OK to add the class ID.
8. Configure the rest of the profile as needed.
9. Click OK to save the profile.
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To configure the traffic class ID in an interface:
1.
2.
3.
4.
5.
6.
7.

Go to Network > Interfaces.
Edit an existing interface, or create a new one.
In the Traffic Shaping section, enable Outbound shaping profile and Outbound Bandwidth.
Click Create. The Create Traffic Shaping Profile window opens.
Click Create New. The Select Traffic Shaping Class ID window opens.
Select an existing class ID, or create a new one.
Click OK to save the class ID.

8. Click OK to add the class ID .
9. Configure the rest of the interface as needed.
10. Click OK to save the interface.

CLI configuration
To configure the traffic class ID in the CLI:
config firewall traffic-class
edit 2
set class-name "High priority voice."
next
...
end

Traffic shaping schedules
In a shaping policy, there are many matching criteria available for administrators to match a specific traffic and apply a
traffic shaper or shaping group to the traffic, including using schedules. This feature gives shaping policy the ability to
apply different shaping profiles at different times. Administrators can select a one-time schedule, recurring schedule, or
schedule group.
Schedule is not a mandatory setting. If it is not set, then the current date and time are not used to match the traffic.
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To configure a traffic shaping policy in the GUI:
1. Navigate to Policy & Objects > Traffic Shaping Policy.
2. Create or edit a Traffic Shaping Policy.
3. Enable Schedule and select a schedule option.

4. Configure other options and click OK.

To configure a traffic shaping policy in the CLI:
config firewall schedule recurring
edit "work-hours"
set start 07:00
set end 20:00
set day monday tuesday wednesday thursday friday
next
end
config firewall shaping-policy
edit 1
set name "demo"
set service "ALL"
set schedule "work-hours" <<< Can select schedule from one-time schedule, recurring
schedule or schedule group
set dstintf "port1"
set traffic-shaper "high-priority"
set traffic-shaper-reverse "high-priority"
set srcaddr "all"
set dstaddr "all"
next
end
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To troubleshoot a traffic shaping policy in the CLI:
The selected schedule is listed in the iprope.
diagnose firewall iprope list 100015
policy index=1 uuid_idx=0 action=accept
flag (0):
schedule(work-hours)
shapers: orig=high-priority(2/0/134217728) reply=high-priority(2/0/134217728)
cos_fwd=0 cos_rev=0
group=00100015 av=00000000 au=00000000 split=00000000
host=1 chk_client_info=0x0 app_list=0 ips_view=0
misc=0 dd_type=0 dd_mode=0
zone(1): 0 -> zone(1): 9
source(1): 0.0.0.0-255.255.255.255, uuid_idx=28,
dest(1): 0.0.0.0-255.255.255.255, uuid_idx=28,
service(1):
[0:0x0:0/(0,65535)->(0,65535)] helper:auto

QoS assignment and rate limiting for quarantined VLANs
When devices are quarantined, they are isolated from the rest of the network. However, they can still impact the network
if not controlled beyond isolation. A quarantined host, which offers heavy traffic, could congest the network and create a
DOS-style reduction in service to authorized hosts.
Within the quarantined VLAN, two restrictions are available within the network:
l
l

Traffic policing (also known as rate limiting)
QoS (Quality of Service) assignment (also known as priority assignment)

Each quarantined host's traffic can be subject to rate limiting and priority adjustment. This reduces the impact that any
quarantined host can have on authorized traffic on the network.

To configure QoS assignment and rate limiting for quarantined VLANs:
1. Configure a traffic policy, or use the default "quarantine" policy:
config switch-controller traffic-policy
edit "quarantine"
set description "Rate control for quarantined traffic"
set guaranteed-bandwidth 163840
set guaranteed-burst 8192
set maximum-burst 163840
set cos-queue 0
next
end

2. Configure an interface:
config system interface
edit "qtn.aggr1"
set vdom "root"
set ip 10.254.254.254 255.255.255.0
set description "Quarantine VLAN"
set security-mode captive-portal
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set
set
set
set
set
set
set
set

replacemsg-override-group "auth-intf-qtn.aggr1"
device-identification enable
snmp-index 30
switch-controller-access-vlan enable
switch-controller-traffic-policy "quarantine"
color 6
interface "aggr1"
vlanid 4093

next
end

By default, switch-controller-traffic-policy is empty. You need to apply the necessary traffic policy (not
only limited to "quarantine").

Weighted random early detection queuing
You can use the weighted random early detection (WRED) queuing function within traffic shaping.
This topic includes three parts:
l
l
l

Traffic shaping with queuing
Burst control in queuing mode
Multi-stage DSCP marking and class ID in traffic shapers

You cannot configure or view WRED in the GUI; you must use the CLI.

WRED is not supported when traffic is offloaded to an NPU.

Traffic shaping with queuing
Traffic shaping has a queuing option. Use this option to fine-tune the queue by setting the profile queue size or
performing RED (random early drop) according to queue usage.
This example shows setting the profile queue size limit to 5 so that the queue can contain a maximum of five packets and
more packets are dropped.

To set the profile queue size limit:
config firewall shaping-profile
edit "profile"
set type queuing
set default-class-id 31
config shaping-entries
edit 31
set class-id 31
set guaranteed-bandwidth-percentage 5
set maximum-bandwidth-percentage 10
set limit 5 <range from 5 to 10000; default: 1000>
next
end
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next
end

This example shows performing RED according to queue usage by setting red-probability, min, and max. Setting
red-probability to 10 means start to drop packets when queue usage reaches the min setting. When queue usage
reaches the max setting, drop 10% of the packets.
l
l
l
l

Level 1: when queue is less than min packets, drop 0% of packets.
Level 2: when queue reaches min packets, start to drop packets.
Level 3: when queue usage is between min and max packets, drop 0–10% of packets by proportion.
Level 4: when queue (average queue size) is more than max packets, drop 100% of packets.

To set RED according to queue usage:
config firewall shaping-profile
edit "profile"
set type queuing
set default-class-id 31
config shaping-entries
edit 31
set class-id 31
set guaranteed-bandwidth-percentage 5
set maximum-bandwidth-percentage 10
set red-probability 10 <range from 0 to 20; default: 0 no drop>
set min 100 <range from 3 to 3000>
set max 300 <range from 3 to 3000>
next
end
next
end

To troubleshoot this function, use the following diagnose commands:
diagnose netlink intf-class list <intf>
diagnose netlink intf-qdisc list <intf>

Burst control in queuing mode
In an HTB algorithm, each traffic class has buckets to allow a burst of traffic. The maximum burst is determined by the
bucket size burst (for guaranteed bandwidth) and cburst (for maximum bandwidth). The shaping profile has burstin-msec and cburst-in-msec parameters for each shaping entry (class id) to control the bucket size.
This example uses the outbandwidth of the interface as 1 Mbps and the maximum bandwidth of class is 50%.
burst = burst-in-msec * guaranteed bandwidth = 100 ms × 1 Mbps x 50% = 50000 b = 6250 B
cburst = cburst-in-msec * maximum bandwidth = 200 ms × 1 Mbps x 50% = 100000 b = 12500 B
The following example sets burst-in-msec to 100 and cburst-in-msec to 200.

To set burst control in queuing mode:
config firewall shaping-profile
edit "profile"
set type queuing
set default-class-id 31
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config shaping-entries
edit 31
set class-id 31
set guaranteed-bandwidth-percentage 5
set maximum-bandwidth-percentage 50
set burst-in-msec 100 <range from 0 to 2000>
set cburst-in-msec 200 <range from 0 to 2000>
next
end
next
end

Multi-stage DSCP marking and class ID in traffic shapers
Traffic shapers have a multi-stage method so that packets are marked with a different DSCP and class id at different
traffic speeds. Marking packets with a different DSCP code is for the next hop to classify the packets. The FortiGate
benefits by marking packets with a different class id. Combined with the egress interface shaping profile, the
FortiGate can handle the traffic differently according to its class id.

Rule

DSCP code

Class ID

speed < guarantee bandwidth

diffservcode

class id in shaping policy

guarantee bandwidth < speed < exceed bandwidth

exceed-dscp

exceed-class-id

exceed bandwidth < speed

maximum-dscp

exceed-class-id

This example sets the following parameters:
l

l

l

When the current bandwidth is less than 50 Kbps, mark packets with diffservcode 100000 and set class id to
10.
When the current bandwidth is between 50 Kbps and 100 Kbps, mark packets with exceed-dscp 111000 and set
exceed-class-id to 20.
When the current bandwidth is more than 100 Kbps, mark packets with maximum-dscp 111111 and set exceedclass-id to 20.

To set multi-stage DSCP marking and class ID in a traffic shaper:
config firewall shaper traffic-shaper
edit "50k-100k-150k"
set guaranteed-bandwidth 50
set maximum-bandwidth 150
set diffserv enable
set dscp-marking-method multi-stage
set exceed-bandwidth 100
set exceed-dscp 111000
set exceed-class-id 20
set maximum-dscp 111111
set diffservcode 100000
next
end
config firewall shaping-policy
edit 1
set service "ALL"
set dstintf PORT2

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

692

Policy and Objects

set srcaddr "all"
set dstaddr "all"
set class-id 10
next
end

Traffic shapers also have an overhead option that defines the per-packet size overhead used in rate computation.

To set the traffic shaper overhead option:
config firewall shaper traffic-shaper
edit "testing"
set guaranteed-bandwidth 50
set maximum-bandwidth 150
set overhead 14 <range from 0 to 100>
next
end

Examples
Enabling RED for FTP traffic from QA
This first example shows how to enable RED for FTP traffic from QA. This example sets a maximum of 10% of the
packets to be dropped when queue usage reaches the maximum value.

To configure the firewall address:
config firewall address
edit QA_team
set subnet 10.1.100.0/24
next
end

To set the shaping policy to classify traffic into different class IDs:
config firewall shaping-policy
edit 1
set service HTTPS HTTP
set dstintf port1
set srcaddr QA_team
set dstaddr all
set class-id 10
next
edit 2
set service FTP
set dstintf port1
set srcaddr QA_team
set dstaddr all
set class-id 20
next
end
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To set the shaping policy to define the speed of each class ID:
config firewall shaping-profile
edit QA_team_profile
set type queuing
set default-class-id 30
config shaping-entries
edit 1
set class-id 10
set guaranteed-bandwidth-percentage 50
set maximum-bandwidth-percentage 100
next
edit 2
set class-id 20
set guaranteed-bandwidth-percentage 30
set maximum-bandwidth-percentage 60
set red-probability 10
next
edit 3
set class-id 30
set guaranteed-bandwidth-percentage 20
set maximum-bandwidth-percentage 50
next
end
next
end

To apply the shaping policy to the interface:
config sys interface
edit port1
set outbandwidth 10000
set egress-shaping-profile QA_team_profile
next
end

To use diagnose commands to troubleshoot:
# diagnose netlink intf-class list port1
class htb 1:1 root rate 1250000Bps ceil 1250000Bps burst 1600B/8 mpu 0B overhead 0B cburst
1600B/8 mpu 0B overhead 0B level 7 buffer [00004e20] cbuffer [00004e20]
Sent 11709 bytes 69 pkt (dropped 0, overlimits 0 requeues 0)
rate 226Bps 2pps backlog 0B 0p
lended: 3 borrowed: 0 giants: 0
tokens: 18500 ctokens: 18500
class htb 1:10 parent 1:1 leaf 10: prio 1 quantum 62500 rate 625000Bps ceil 1250000Bps burst
1600B/8 mpu 0B overhead 0B cburst 1600B/8 mpu 0B overhead 0B level 0 buffer [00009c40]
cbuffer [00004e20]
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
rate 0Bps 0pps backlog 0B 0p
lended: 0 borrowed: 0 giants: 0
tokens: 40000 ctokens: 20000
class htb 1:20 parent 1:1 leaf 20: prio 1 quantum 37500 rate 375000Bps ceil 750000Bps burst
1599B/8 mpu 0B overhead 0B cburst 1599B/8 mpu 0B overhead 0B level 0 buffer [0001046a]
cbuffer [00008235]
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
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rate 0Bps 0pps backlog 0B 0p
lended: 0 borrowed: 0 giants: 0
tokens: 66666 ctokens: 33333
class htb 1:30 parent 1:1 leaf 30: prio 1 quantum 25000 rate 250000Bps ceil 625000Bps burst
1600B/8 mpu 0B overhead 0B cburst 1600B/8 mpu 0B overhead 0B level 0 buffer [000186a0]
cbuffer [00009c40]
Sent 11709 bytes 69 pkt (dropped 0, overlimits 0 requeues 0)
rate 226Bps 2pps backlog 0B 0p
lended: 66 borrowed: 3 giants: 0
tokens: 92500 ctokens: 37000
class red 20:1 parent 20:0
# diagnose netlink intf-qdisc list port1
qdisc htb 1: root refcnt 5 r2q 10 default 30 direct_packets_stat 0 ver 3.17
Sent 18874 bytes 109 pkt (dropped 0, overlimits 5 requeues 0)
backlog 0B 0p
qdisc pfifo 10: parent 1:10 refcnt 1 limit 1000p
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
backlog 0B 0p
qdisc red 20: parent 1:20 refcnt 1 limit 4000000B min 300000B max 1000000B ewma 9 Plog 23
Scell_log 20 flags 0
Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
backlog 0B 0p
marked 0 early 0 pdrop 0 other 0
qdisc pfifo 30: parent 1:30 refcnt 1 limit 1000p
Sent 18874 bytes 109 pkt (dropped 0, overlimits 0 requeues 0)
backlog 0B 0p

Marking QA traffic with a different DSCP
This second example shows how to mark QA traffic with a different DSCP according to real-time traffic speed.

To configure the firewall address:
config firewall address
edit QA_team
set subnet 10.1.100.0/24
next
end

To configure the firewall shaper traffic shaper:
config firewall shaper traffic-shaper
edit "500k-1000k-1500k"
set guaranteed-bandwidth 500
set maximum-bandwidth 1500
set diffserv enable
set dscp-marking-method multi-stage
set exceed-bandwidth 1000
set exceed-dscp 111000
set maximum-dscp 111111
set diffservcode 100000
next
end
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config firewall shaping-policy
edit QA_team
set service "ALL"
set dstintf port1
set traffic-shaper "500k-1000k-1500k"
set traffic-shaper-reverse "500k-1000k-1500k"
set srcaddr "QA_team"
set dstaddr "all"
next
end
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This section contains information about configuring FortiGate security features, including:
l
l
l
l
l
l
l
l
l
l
l
l
l

Antivirus on page 697
Web filter on page 742
DNS filter on page 793
Application control on page 816
Intrusion prevention on page 822
Email filter on page 826
Data leak prevention on page 839
VoIP solutions on page 853
ICAP on page 864
Web application firewall on page 867
Inspection modes on page 871
Overrides on page 888
Custom signatures on page 896

If you are unable to view a security profile feature, go to System > Feature Visibility to enable
it.

Antivirus
FortiOS offers the unique ability to implement both flow-based and proxy-based antivirus concurrently, depending on the
traffic type, users, and locations. Flow-based antivirus offers higher throughput performance, while proxy-based
solutions are useful to mitigate stealthy malicious codes.
FortiOS includes two preloaded antivirus profiles:
l
l

default
wifi-default

You can customize these profiles, or you can create your own to inspect certain protocols, remove viruses, analyze
suspicious files with FortiSandbox, and apply botnet protection to network traffic. Once configured, you can add the
antivirus profile to a firewall policy.

This functionality requires a subscription to FortiGuard Antivirus.

The following topics provide information about antivirus profiles:
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l
l
l
l
l
l

Content disarm and reconstruction for antivirus on page 698
FortiGuard Outbreak Prevention for antivirus on page 702
External malware blocklist for antivirus on page 705
Checking flow antivirus statistics on page 710
CIFS support on page 713
Databases on page 719

The following topics provide information about sandbox inspection with antivirus:
l
l

Using FortiSandbox appliance with antivirus on page 720
Using FortiSandbox Cloud with antivirus on page 731

Content disarm and reconstruction for antivirus
Content Disarm and Reconstruction (CDR) allows the FortiGate to sanitize Microsoft documents and PDF (disarm) by
removing active content such as hyperlinks, embedded media, javascript, macros, etc. from the office document files
without affecting the integrity of it's textual content (reconstruction).
This feature allows network admins to protect their users from malicious office document files.
Files processed by CDR can have the original copy quarantined on the FortiGate, allowing admins to observe them.
These original copies can also be obtained in the event of a false positive.

Support and limitations
l
l
l

l
l

CDR can only be performed on Microsoft Office Document and PDF files.
Local Disk CDR quarantine is only possible on FortiGate models that contain a hard disk.
CDR is only supported on HTTP, SMTP, POP3, IMAP.
l SMTP splice and client-comfort mode is not supported.
CDR does not work on flow based inspection modes.
CDR can only work on files in .ZIP type archives.
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Configuring the feature
In order to configure antivirus to work with CDR, you must enable CDR on your antivirus profile, set the quarantine
location, and then fine tune the CDR detection parameters.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

699

Security Profiles

To enable CDR on your antivirus profile:
1. Go to Security Profiles > AntiVirus.
2. Enable the toggle for Content Disarm and Reconstruction under APT Protection Options.

To set a quarantine location:
1. Go to Security Profiles > AntiVirus.
2. Select a quarantine location from the available options, including Discard, File Quarantine, and FortiSandbox.

Discard

The default setting which discards the original document file.

File Quarantine

Saves the original document file to disk (if possible) or a connected
FortiAnalyzer based on the FortiGate's log settings, visible through Config
Global > Config Log FortiAnalyzer Setting.

FortiSandbox

Saves the original document file to a connected FortiSandbox.

3. Click Apply.

To fine tune CDR detection parameters in the FortiGate CLI:
l

Select which active content to detect/process:
l By default, all active office and PDF content types are enabled. To fine tune CDR to ignore certain content, you
must disable that particular content parameter. The example below configures the CDR to ignore Microsoft
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Office macros.
FGT_PROXY (vdom1) # config antivirus profile
FGT_PROXY (profile) # edit av
change table entry 'av'
FGT_PROXY (av) # config content-disarm
FGT_PROXY (content-disarm) # set ?
original-file-destination
Destination to
removed.
office-macro
Enable/disable
documents.
office-hylink
Enable/disable
Office documents.
office-linked
Enable/disable
Office documents.
office-embed
Enable/disable
Microsoft Office documents.
office-dde
Enable/disable
in Microsoft Office documents.
office-action
Enable/disable
Microsoft Office documents.
pdf-javacode
Enable/disable
documents.
pdf-embedfile
Enable/disable
documents.
pdf-hyperlink
Enable/disable
documents.
pdf-act-gotor
Enable/disable
access other PDF documents.
pdf-act-launch
Enable/disable
launch other applications.
pdf-act-sound
Enable/disable
play a sound.
pdf-act-movie
Enable/disable
play a movie.
pdf-act-java
Enable/disable
execute JavaScript code.
pdf-act-form
Enable/disable
submit data to other targets.
cover-page
Enable/disable
document.
detect-only
Enable/disable
alter content.

send original file if active content is
stripping of macros in Microsoft Office
stripping of hyperlinks in Microsoft
stripping of linked objects in Microsoft
stripping of embedded objects in
stripping of Dynamic Data Exchange events
stripping of PowerPoint action events in
stripping of JavaScript code in PDF
stripping of embedded files in PDF
stripping of hyperlinks from PDF
stripping of PDF document actions that
stripping of PDF document actions that
stripping of PDF document actions that
stripping of PDF document actions that
stripping of PDF document actions that
stripping of PDF document actions that
inserting a cover page into the disarmed
only detect disarmable files, do not

FGT_PROXY (content-disarm) # set office-macro disable
FGT_PROXY (content-disarm) #
l

Detect but do not modify active content:
l By default, CDR will disarm any detected documents containing active content. To prevent CDR from
disarming documents, you can set it to operate in detect-only mode. To do this, the option detect-only must be
enabled.
FGT_PROXY (vdom1) # config antivirus profile
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FGT_PROXY (profile) # edit av
change table entry 'av'
FGT_PROXY (av) # config content-disarm
FGT_PROXY (content-disarm) # set detect-only ?
disable
Disable this Content Disarm and Reconstruction feature.
enable
Enable this Content Disarm and Reconstruction feature.
FGT_PROXY (content-disarm) # set detect-only enable
FGT_PROXY (content-disarm) #
l

Enabling/disabling the CDR cover page:
l By default, a cover page will be attached to the file's content when the file has been processed by CDR. To
disable the cover page, the paramater cover-page needs to be disabled.
FGT_PROXY (vdom1) # config antivirus profile
FGT_PROXY (profile) # edit av
change table entry 'av'
FGT_PROXY (av) # config content-disarm
FGT_PROXY (content-disarm) # set cover-page
disable
Disable this Content Disarm and Reconstruction feature.
enable
Enable this Content Disarm and Reconstruction feature.
FGT_PROXY (content-disarm) # set cover-page disable
FGT_PROXY (content-disarm) #

FortiGuard Outbreak Prevention for antivirus
FortiGuard Outbreak Prevention allows the FortiGate antivirus database to be subsidized with third-party malware hash
signatures curated by the FortiGuard. The hash signatures are obtained from external sources such as VirusTotal,
Symantec, Kaspersky, and other third-party websites and services.
This feature provides the mechanism for antivirus to query the FortiGuard with the hash of a scanned file. If the
FortiGuard returns a match from its many curated signature sources, the scanned file is deemed to be malicious.
The concept of FortiGuard Outbreak Prevention is to detect zero-day malware in a collaborative approach.

Support and limitations
l

l
l

FortiGuard Outbreak Prevention can be used in both proxy-based and flow-based policy inspections across all
supported protocols.
FortiGuard Outbreak Prevention does not support AV in quick scan mode.
FortiGate must be registered with a valid FortiGuard Outbreak Prevention license before this feature can be used.
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Configuring the feature
In order for antivirus to work with an external block list, you must register the FortiGate with a FortiGuard Outbreak
Prevention license and enable FortiGuard Outbreak Prevention in the antivirus profile.

To obtain/renew a FortiGuard antivirus license:
1. See the following link for instructions on how to purchase or renew a FortiGuard Outbreak Prevention license:
https://video.fortinet.com/products/fortigate/6.0/how-to-purchase-or-renew-fortiguard-services-6-0
2. Once the license has been activated, you can verify its status by going to Global > System > FortiGuard.
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To enable FortiGuard Outbreak Prevention in the antivirus profile:
1. Go to Security Profiles > AntiVirus.
2. Select the toggle to enable Use FortiGuard Outbreak Prevention Database.

3. Click Apply.

Diagnostics and debugging
l

Check if FortiGate has Outbreak Prevention license:
FGT_PROXY (global) # diagnose debug rating
Locale
: english
Service
Status
License

: Web-filter
: Enable
: Contract

Service
Status

: Antispam
: Disable

Service
Status
License

: Virus Outbreak Prevention
: Enable
: Contract

-=- Server List (Tue Feb 19 16:36:15 2019) -=IP
Updated Time
192.168.100.185
Feb 19 16:35:55 2019
l

Weight
-218

RTT Flags
2 DI

TZ

Packets

-8

113

Curr Lost Total Lost
0

0 Tue

Scanunit daemon showing Outbreak Prevention verdict:
FGT_PROXY (vdom1) # diagnose debug application scanunit -1
Debug messages will be on for 30 minutes.
FGT_PROXY (vdom1) # diagnose debug enable
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FGT_PROXY (vdom1) # su 4739 job 1 open
su 4739 req vfid 1 id 1 ep 0 new request, size 313, policy id 1, policy type 0
su 4739 req vfid 1 id 1 ep 0 received; ack 1, data type: 0
su 4739 job 1 request info:
su 4739 job 1
client 10.1.100.11:39412 server 172.16.200.44:80
su 4739 job 1
object_name 'zhvo_test.com'
su 4739 file-typing NOT WANTED options 0x0 file_filter no
su 4739 enable databases 0b (core mmdb extended)
su 4739 job 1 begin http scan
su 4739 scan file 'zhvo_test.com' bytes 68
su 4739 job 1 outbreak-prevention scan, level 0, filename 'zhvo_test.com'
su 4739 scan result 0
su 4739 job 1 end http scan
su 4739 job 1 inc pending tasks (1)
su 4739 not wanted for analytics: analytics submission is disabled (m 0 r 0)
su 4739 job 1 suspend
su 4739 outbreak-prevention recv error
su 4739 ftgd avquery id 0 status 1
su 4739 job 1 outbreak-prevention infected entryid=0
su 4739 report AVQUERY infection priority 1
su 4739 insert infection AVQUERY SUCCEEDED loc (nil) off 0 sz 0 at index 0 total
infections 1 error 0
su 4739 job 1 dec pending tasks 0
su 4739 job 1 send result
su 4739 job 1 close
su 4739 outbreak-prevention recv error

External malware blocklist for antivirus
External Malware Blocklist is a new feature introduced in FortiOS 6.2.0 which falls under the umbrella Outbreak
Prevention.
This feature provides another means of supporting the AV Database by allowing users to add their own malware
signatures in the form of MD5, SHA1, and SHA256 hashes.
This feature provides a mechanism for Antivirus to retrieve an external malware hash list from a remote server and polls
the hash list every n minutes for updates.

Support and limitations
Malware detection using External Malware Blocklist can be used in both proxy-based and flow-based policy inspections.
Just like FortiGuard Outbreak Prevention, External Dynamic Block List is not supported in AV quick scan mode.
Using different types of hash simultaneously may slow down the performance of malware scanning. For this reason,
users are recommended to only using one type of hash (either MD5, SHA1, or SHA256), not all three simultaneously.
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Network topology example

Configuring the feature
To configure antivirus to work with External Block List:
1. Creating the Malware Hash List
The malware hash list follows a strict format in order for its contents to be valid. Malware hash signatures entries
must be separated into each line. A valid signature needs to follow the format below:
# MD5 Entry with hash description
aa67243f746e5d76f68ec809355ec234 md5_sample1
# SHA1 Entry with hash description
a57983cb39e25ab80d7d3dc05695dd0ee0e49766

sha1_sample2

# SHA256 Entry with hash description
ae9bc0b4c5639d977d720e4271da06b50f7c60d1e2070e9c75cc59ab30e49379

sha256_sample1

# Entry without hash description
0289b0d967cb7b1fb1451339c7b9818a621903090e0020366ab415c549212521
# Invalid entries
7688499dc71b932feb126347289c0b8a_md5_sample2
7614e98badca10b5e2d08f8664c519b7a906fbd5180ea5d04a82fce9796a4b87sha256_sample3
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2. Configure External Malware Blocklist source:
a. Create a new external source on Global > Security Fabric > Fabric Connectors page.

b. Select Malware Hash.
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c. Fill out the fields as shown. The URI should point to the malware hashlist on the remote server.

d. Click OK.
The malware hash source object is now created.

The user can view entries inside the malware blocklist by clicking the View Entries button:
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The Malware Has Threatfeed hash_list is shown.
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3. Enable External Malware Blocklist in antivirus profile:
a. Enable External Malware Blocklist on the antivirus profile and apply the change

Antivirus is now ready to use the external malware blocklist.

Diagnostics and debugging
Check if the scanunit daemon has updated itself with the external hashes:
FGT_PROXY # config global
FGT_PROXY (global) # diagnose sys scanunit malware-list list
md5 'aa67243f746e5d76f68ec809355ec234' profile 'hash_list' description 'md5_sample1'
sha1 'a57983cb39e25ab80d7d3dc05695dd0ee0e49766' profile 'hash_list' description 'sha1_
sample2'
sha256 '0289b0d967cb7b1fb1451339c7b9818a621903090e0020366ab415c549212521' profile 'hash_
list' description ''
sha256 'ae9bc0b4c5639d977d720e4271da06b50f7c60d1e2070e9c75cc59ab30e49379' profile 'hash_
list' description 'sha256_sample1'

Checking flow antivirus statistics
This feature provides a flow antivirus statistics check, and an API for SNMP to get AV statistics.
Two CLI commands are used to show and clear the antivirus statistics:
diagnose ips av stats show
diagnose ips av stats clear

This example uses the following topology:
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To check flow antivirus statistics:
1. Create an antivirus profile:
config antivirus profile
edit "av-test"
config http
set options scan avmonitor
end
config ftp
set options scan quarantine
end
next
end

2. Enable the profile on a firewall policy:
config firewall policy
edit 1
set name "policy1"
set srcintf "port2"
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set fsso disable
set av-profile "av-test"
set ssl-ssh-profile "custom-deep-inspection"
set nat enable
next
end

3. On the client PC, download the EICAR Standard Anti-Virus Test File via HTTP.
4. Check the antivirus statistics on the FortiGate. As the action is set to monitor for HTTP, HTTP virus detected is
increased by 1:
# diagnose
AV stats:
HTTP virus
HTTP virus
SMTP virus
SMTP virus

ips av stats show
detected: 1
blocked: 0
detected: 0
blocked: 0
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POP3 virus detected: 0
POP3 virus blocked: 0
IMAP virus detected: 0
IMAP virus blocked: 0
NNTP virus detected: 0
NNTP virus blocked: 0
FTP virus detected: 0
FTP virus blocked: 0
SMB virus detected: 0
SMB virus blocked: 0

5. On the client PC, download the EICAR file via FTP.
6. Check the antivirus statistics on the FortiGate. As the action is set to quarantine for FTP, FTP virus detected
and FTP virus blocked are both increased by 1:
# diagnose ips av stats show
AV stats:
HTTP virus detected: 1
HTTP virus blocked: 0
SMTP virus detected: 0
SMTP virus blocked: 0
POP3 virus detected: 0
POP3 virus blocked: 0
IMAP virus detected: 0
IMAP virus blocked: 0
NNTP virus detected: 0
NNTP virus blocked: 0
FTP virus detected: 1
FTP virus blocked: 1
SMB virus detected: 0
SMB virus blocked: 0

7. Check the antivirus statistics using snmpwalk:
root:~# snmpwalk -c public -v 1 10.1.100.6 1.3.6.1.4.1.12356.101.8.2.1.1
iso.3.6.1.4.1.12356.101.8.2.1.1.1.1 = Counter32: 2 (fgAvVirusDetected)
iso.3.6.1.4.1.12356.101.8.2.1.1.2.1 = Counter32: 1 (fgAvVirusBlocked)
iso.3.6.1.4.1.12356.101.8.2.1.1.3.1 = Counter32: 1 (fgAvHTTPVirusDetected)
iso.3.6.1.4.1.12356.101.8.2.1.1.4.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.5.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.6.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.7.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.8.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.9.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.10.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.11.1 = Counter32: 1 (fgAvFTPVirusDetected)
iso.3.6.1.4.1.12356.101.8.2.1.1.12.1 = Counter32: 1 (fgAvFTPVirusBlocked)
iso.3.6.1.4.1.12356.101.8.2.1.1.13.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.14.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.15.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.16.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.17.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.18.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.19.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.20.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.21.1 = Counter32: 0
iso.3.6.1.4.1.12356.101.8.2.1.1.22.1 = Counter32: 0
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8. Optionally, reset the antivirus statistics to zero:
diagnose ips av stats clear

CIFS support
File filtering and antivirus scanning for proxy-based inspection on Common Internet File System (CIFS) traffic is
supported.
File filtering for CIFS is performed by inspecting the first 4kB of the file to identify the file's magic number. If a match
occurs, CIFS file filtering prevents the CIFS command that contains that file from running.
The CIFS security profile handles the configuration of file filtering on CIFS. The antivirus profile handles the antivirus
configuration for CIFS scanning.
For a CIFS profile to be available for assignment in a policy, the policy must use proxy inspection mode. See Proxy mode
inspection on page 873 for details.
The following are not supported by CIFS scanning in proxy inspection mode:
l
l
l

l

File types and infections within archive files cannot be detected.
Oversized files cannot be detected.
Special condition archive files (encrypted, corrupted, mailbomb, etc.) marked by the antivirus engine are blocked
automatically.
IPv6 CIFS traffic is not supported.

Supported file types
File filter supports the following file types:

File Type Name

Description

7z

Match 7-zip files

arj

Match arj compressed files

cab

Match Windows cab files

lzh

Match lzh compressed files

rar

Match rar archives

tar

Match tar files

zip

Match zip files

bzip

Match bzip files

gzip

Match gzip files

bzip2

Match bzip2 files

xz

Match xz files

bat

Match Windows batch files
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File Type Name

Description

msc

Match msc files

uue

Match uue files

mime

Match mime files

base64

Match base64 files

binhex

Match binhex files

bin

Match bin files

elf

Match elf files

exe

Match Windows executable files

hta

Match hta files

html

Match html files

jad

Match jad files

class

Match class files

cod

Match cod files

javascript

Match javascript files

msoffice

Match MS-Office files. For example, doc, xls, ppt, and so on.

msofficex

Match MS-Office XML files. For example, docx, xlsx, pptx, and so on.

fsg

Match fsg files

upx

Match upx files

petite

Match petite files

aspack

Match aspack files

prc

Match prc files

sis

Match sis files

hlp

Match Windows help files

activemime

Match activemime files

jpeg

Match jpeg files

gif

Match gif files

tiff

Match tiff files

png

Match png files

bmp

Match bmp files

ignored

Match ignored files
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File Type Name

Description

unknown

Match unknown files

mpeg

Match mpeg files

mov

Match mov files

mp3

Match mp3 files

wma

Match wma files

wav

Match wav files

pdf

Match pdf files

avi

Match avi files

rm

Match rm files

torrent

Match torrent files

msi

Match Windows Installer msi bzip files

mach-o

Match Mach object files

dmg

Match Apple disk image files

.net

Match .NET files

xar

Match xar archive files

chm

Match Windows compiled HTML help files

iso

Match ISO archive files

crx

Match Chrome extension files

Configure file-type filtering and antivirus scanning on CIFS traffic
To configure file-type filtering and antivirus scanning on CIFS traffic:
1. Configure a CIFS domain controller on page 715
2. Configure a CIFS profile on page 716
3. Configure an antivirus profile on page 717

Configure a CIFS domain controller
The domain controller must be configured when CIFS traffic is encrypted, like SMB 3.0 traffic. The configuration tells the
FortiGate the network location of the domain controller and the superuser credentials.

To Configure the CIFS domain controller:
config cifs domain-controller
edit "DOMAIN"
set domain-name "EXAMPLE.COM"
set username "admin-super"
set password **********
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set ip 172.16.201.40
next
end

Configure a CIFS profile
To create a CIFS profile, configure the server credential type and add file filter entries.

Set the CIFS server credential type
The CIFS server credential type can be none, credential-replication, or credential-keytab.

none
The CIFS profile assumes the CIFS traffic is unencrypted (used with SMB 2.0). This is the default value.
config cifs profile
edit "cifs"
set server-credential-type none
next
end

credential-replication
To decrypt CIFS traffic, FortiOS obtains the session key from the domain controller by logging in to the superuser
account. The domain controller must be configured.
config cifs profile
edit "cifs"
set server-credential-type credential-replication
set domain-controller "DOMAIN"
next
end

Variable

Description

domain-controller <string>

The previously configured domain to decrypt CIFS traffic for.

credential-keytab
To decrypt CIFS traffic, FortiOS uses a series of keytab values. This method is used when the SMB connection is
authenticated by Kerberos. Keytab entries must be configured, and are stored in FortiOS in plaintext.
config cifs profile
edit "cifs"
set server-credential-type credential-keytab
config server-keytab
edit "keytab1"
set keytab
"BQIAAABFAAEAC0VYQU1QTEUuQ09NAAdleGFtcGxlAAAAAVUmAlwBABIAILdV5P6NXT8RrTvapcMJQxDYCjRQiD0Bzxh
wS9h0VgyM"
next
end
next
end
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Variable

Description

keytab <keytab>

Base64 encoded keytab file containing the credentials of the server.

Configure CIFS profile file filtering
Multiple file filter entries can be added to a profile.

To configure file filter entried in a CIFS profile:
config cifs profile
edit "cifs"
config file-filter
set status {enable | disable}
set log {enable | disable}
config entries
edit <filter>
set comment <string>
set action {log | block}
set direction {incoming | outgoing | any}
set file-type <file_type>
next
end
end
next
end

Variable

Description

status {enable | disable}

Enable/disable file filter (default = enable).

log {enable | disable}

Enable/disable file filter logging (default = enable).

comment <string>

A brief comment describing the entry.

action {log | block}

The action to take for matched files:
l log: Allow the content and write a log message (default).
l block: Block the content and write a log message.

direction {incoming | outgoing |
any}

Match files transmitted in the session's originating (incoming) and/or reply
(outgoing) direction (default = any).

file-type <file_type>

The file types to be matched (default = none). See Supported file types on page
713 for details.

Configure an antivirus profile
The antivirus profile handles the antivirus configuration for CIFS scanning.

To configure an antivirus profile:
config antivirus profile
edit "av"
...
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config cifs
set options {scan avmonitor quarantine}
set archive-block {encrypted corrupted partiallycorrupted multipart nested
mailbomb fileslimit timeout unhandled}
set archive-log {encrypted corrupted partiallycorrupted multipart nested
mailbomb fileslimit timeout unhandled}
set emulator {enable | disable}
set outbreak-prevention {disabled | files | full-archive}
end
next
end

Variable

Description

options {scan avmonitor
quarantine}

Enable/disable CIFS antivirus scanning, monitoring, and quarantine.

archive-block {encrypted
corrupted partiallycorrupted
multipart nested mailbomb
fileslimit timeout unhandled}

Select the archive types to block:
l encrypted: Block encrypted archives.
l corrupted: Block corrupted archives.
l partiallycorrupted: Block partially corrupted archives.
l multipart: Block multipart archives.
l nested: Block nested archives.
l mailbomb: Block mail bomb archives.
l fileslimit: Block exceeded archive files limit.
l timeout: Block scan timeout.
l unhandled: Block archives that FortiOS cannot open.

archive-log {encrypted corrupted
partiallycorrupted multipart
nested mailbomb fileslimit
timeout unhandled}

Select the archive types to log:
l encrypted: Log encrypted archives.
l corrupted: Log corrupted archives.
l partiallycorrupted: Log partially corrupted archives.
l multipart: Log multipart archives.
l nested: Log nested archives.
l mailbomb: Log mail bomb archives.
l fileslimit: Log exceeded archive files limit.
l timeout: Log scan timeout.
l unhandled: Log archives that FortiOS cannot open.

emulator {enable | disable}

Enable/disable the virus emulator (default = enable).

outbreak-prevention {disabled |
files | full-archive}

Enable the Virus Outbreak Prevention service:
l disabled: Disabled (default).
l files: Analyze files as sent, not the content of archives.
l full-archive: Analyze files, including the content of archives.

Log examples
File-type detection events generated by CIFS profiles are logged in the utm-cifs log category. Antivirus detection over
the CIFS protocol generates logs in the utm-virus category. See the FortiOS Log Message Reference for more
information.
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Logs generated by CIFS profile file filter:
date=2019-03-28 time=10:39:19 logid="1800063001" type="utm" subtype="cifs" eventtype="cifsfilefilter" level="notice" vd="vdom1" eventtime=1553794757 msg="File was detected by file
filter." direction="incoming" action="passthrough" service="CIFS" srcip=10.1.100.11
dstip=172.16.200.44 srcport=33372 dstport=445 srcintf="wan2" srcintfrole="wan"
dstintf="wan1" dstintfrole="wan" policyid=1 proto=16 profile="cifs" filesize="1154"
filename="virus\\test.png" filtername="2" filetype="png"
date=2019-03-28 time=10:39:12 logid="1800063001" type="utm" subtype="cifs" eventtype="cifsfilefilter" level="notice" vd="vdom1" eventtime=1553794751 msg="File was detected by file
filter." direction="incoming" action="passthrough" service="CIFS" srcip=10.1.100.11
dstip=172.16.200.44 srcport=33370 dstport=445 srcintf="wan2" srcintfrole="wan"
dstintf="wan1" dstintfrole="wan" policyid=1 proto=16 profile="cifs" filesize="81975"
filename="virus\\screen.png" filtername="2" filetype="png"
date=2019-03-28 time=10:33:55 logid="1800063000" type="utm" subtype="cifs" eventtype="cifsfilefilter" level="warning" vd="vdom1" eventtime=1553794434 msg="File was blocked by file
filter." direction="incoming" action="blocked" service="CIFS" srcip=10.1.100.11
dstip=172.16.200.44 srcport=33352 dstport=445 srcintf="wan2" srcintfrole="wan"
dstintf="wan1" dstintfrole="wan" policyid=1 proto=16 profile="cifs" filesize="28432"
filename="filetypes\\mpnotify.exe" filtername="3" filetype="exe"
date=2019-03-28 time=10:33:45 logid="1800063000" type="utm" subtype="cifs" eventtype="cifsfilefilter" level="warning" vd="vdom1" eventtime=1553794424 msg="File was blocked by file
filter." direction="incoming" action="blocked" service="CIFS" srcip=10.1.100.11
dstip=172.16.200.44 srcport=33348 dstport=445 srcintf="wan2" srcintfrole="wan"
dstintf="wan1" dstintfrole="wan" policyid=1 proto=16 profile="cifs" filesize="96528"
filename="filetypes\\winmine.exe" filtername="3" filetype="exe"

Logs generated by AV profile for infections detected over CIFS:
date=2019-04-09 time=15:19:02 logid="0204008202" type="utm" subtype="virus"
eventtype="outbreak-prevention" level="warning" vd="vdom1" eventtime=1554848342519005401
msg="Blocked by Virus Outbreak Prevention service." action="blocked" service="SMB"
sessionid=177 srcip=10.1.100.11 dstip=172.16.200.44 srcport=37444 dstport=445 srcintf="wan2"
srcintfrole="wan" dstintf="wan1" dstintfrole="wan" policyid=1 proto=6 direction="incoming"
filename="outbreak\\zhvo_test.com" quarskip="File-was-not-quarantined."
virus="503e99fe40ee120c45bc9a30835e7256fff3e46a" dtype="File Hash"
filehash="503e99fe40ee120c45bc9a30835e7256fff3e46a" filehashsrc="fortiguard" profile="av"
analyticssubmit="false" crscore=50 craction=2 crlevel="critical"
date=2019-04-09 time=15:18:59 logid="0211008192" type="utm" subtype="virus"
eventtype="infected" level="warning" vd="vdom1" eventtime=1554848339909808987 msg="File is
infected." action="blocked" service="SMB" sessionid=174 srcip=10.1.100.11
dstip=172.16.200.44 srcport=37442 dstport=445 srcintf="wan2" srcintfrole="wan"
dstintf="wan1" dstintfrole="wan" policyid=1 proto=6 direction="incoming"
filename="sample\\eicar.com" quarskip="File-was-not-quarantined." virus="EICAR_TEST_FILE"
dtype="Virus" ref="http://www.fortinet.com/ve?vn=EICAR_TEST_FILE" virusid=2172 profile="av"
analyticscksum="275a021bbfb6489e54d471899f7db9d1663fc695ec2fe2a2c4538aabf651fd0f"
analyticssubmit="false" crscore=50 craction=2 crlevel="critical"

Databases
The antivirus scanning engine uses a virus signatures database to record the unique attributes of each infection. The
antivirus scan searches for these signatures and, when one is discovered, the FortiGate unit determines if the file is
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infected and takes action.
All FortiGate units have the normal antivirus signature database. Some models also have additional databases that you
can use. The database that you use depends on your network and security needs.
Normal

Includes currently spreading viruses, as determined by the FortiGuard Global
Security Research Team. These viruses are the greatest threat.

Extended

Includes the normal database, as well as recent viruses that are no longer active.
This is the default setting. These viruses may have been spreading within the last
year but have since nearly or completely disappeared.

Extreme

Includes the extended database, as well as a large collection of zoo viruses.
These are viruses that have not spread in a long time and are largely dormant.
Some zoo viruses might rely on operating systems and hardware that are no
longer widely used.

The extended virus definitions database is the default settings and provides comprehensive antivirus protection. This
coverage comes at a cost because more processing requires additional resources.

To change the antivirus database:
config antivirus settings
set default-db {normal | extended | extreme}
end

Using FortiSandbox appliance with antivirus
Antivirus can use FortiSandbox to supplement its detection capabilities. In real-world situations, networks are always
under the threat of zero-day attacks.
Antivirus can submit potential zero-day viruses to FortiSandbox for inspection. Based on FortiSandbox's analysis, the
FortiGate can supplement its own antivirus database with FortiSandbox's database to detect files determined as
malicious/risky by FortiSandbox. This helps FortiGate antivirus detect zero-day virus and malware whose signatures are
not found in the FortiGate antivirus Database.

Support and limitations
l
l

l

FortiSandbox can be used with antivirus in both proxy-based and flow-based inspection modes.
With FortiSandbox enabled, Full Scan mode antivirus can do the following:
l Submit only suspicious files to FortiSandbox for inspection.
l Submit every file to FortiSandbox for inspection.
l Do not submit anything.
Quick Scan mode antivirus cannot submit suspicious files to FortiSandbox. It can only do the following:
l Submit every file to FortiSandbox for inspection.
l Do not submit anything.
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Network topology example

Configuring the feature
To configure antivirus to work with an external block list, the following steps are required:
1.
2.
3.
4.

Enable FortiSandbox on the FortiGate.
Authorize FortiGate on the FortiSandbox.
Enable FortiSandbox inspection.
Enable use of the FortiSandbox database.

To enable FortiSandbox on the FortiGate:
1. Go to Global > Security Fabric > Settings.
2. Set the Sandbox Inspection toggle to the On position.

3. Enter the IP address of the FortiSandbox.
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4. Add an optional Notifier Email if desired.

5. At this point, selecting Test connectivity will return an unreachable status.
This is expected behavior because the FortiGate is not yet authorized by the FortiSandbox.

6. Click Apply to save the settings.
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To authorize FortiGate on the FortiSandbox:
1. In the FortiSandbox Appliance GUI, go to Scan Input > Device.

2. Use the FortiGate serial number to quickly locate the desired FortiGate and select the link icon to authorize the
FortiGate.
3. Enable the desired VDOM in the same manner.

4. The link icon changes from an open to closed link. This indicates that the FortiSandbox has authorized this
FortiGate.
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5. In the FortiGate GUI, go to Global > Security Fabric > Settings.
6. Select Test connectivity. FortiGate is now authorized and the status now displays as Connected.
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7. FortiSandbox options are now displayed in the AV Profile page.

To enable FortiSandbox inspection:
1. Go to Security Profiles > AntiVirus.
2. Enable FortiSandbox inspection by selecting either Suspicious Files Only or All Supported Files.

3. Files can be excluded from being sent to FortiSandbox based on their file types by choosing from a list of supported
file types.
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4. Files can also be excluded from being sent to FortiSandbox by using wild card patterns.

5. Select Apply.
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To enable use of the FortiSandbox database:
1. Go to Security Profiles > AntiVirus
2. Enable use of the FortiSandbox database by setting the Use FortiSandbox Database toggle to the On position.

3. Select Apply.

Diagnostics and Debugging
Debug on the FortiGate side
l

Update daemon:
FGT_PROXY (global) # diagnose debug application quarantined -1
FGT_PROXY (global) # diagnose debug enable
quar_req_fsa_file()-890: fsa ext list new_version (1547781904)
quar_fsb_handle_quar()-1439: added a req-6 to fortisandbox-fsb5, vfid=1, oftp-name=[].
__quar_start_connection()-908: start server fortisandbox-fsb5-172.18.52.154 in vdom-1
[103] __ssl_cert_ctx_load: Added cert /etc/cert/factory/root_Fortinet_Factory.cer, root
ca Fortinet_CA, idx 0 (default)
[551] ssl_ctx_create_new_ex: SSL CTX is created
[578] ssl_new: SSL object is created
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
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upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
quar_remote_recv_send()-731: dev=fortisandbox-fsb2 xfer-status=0
__quar_build_pkt()-408: build req(id=337, type=4) for vdom-vdom1, len=99, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=99
quar_remote_send()-520: req(id=337, type=4) read response, dev=fortisandbox-fsb2, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb2, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb3 xfer-status=0
__quar_build_pkt()-408: build req(id=338, type=6) for vdom-vdom1, len=93, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=93
quar_remote_send()-520: req(id=338, type=6) read response, dev=fortisandbox-fsb3, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb3, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb5 xfer-status=0
__quar_build_pkt()-408: build req(id=340, type=6) for vdom-vdom1, len=93, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=93
quar_remote_send()-520: req(id=340, type=6) read response, dev=fortisandbox-fsb5, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb5, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb2 xfer-status=1
quar_remote_recv()-662: dev(fortisandbox-fsb2) received a packet: len=69, type=1
quar_remote_recv()-718: file-[337] is accepted by server(fortisandbox-fsb2).
quar_put_job_req()-332: Job 337 deleted
quar_remote_recv_send()-731: dev=fortisandbox-fsb4 xfer-status=0
__quar_build_pkt()-408: build req(id=339, type=6) for vdom-vdom1, len=93, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=93
quar_remote_send()-520: req(id=339, type=6) read response, dev=fortisandbox-fsb4, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb4, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb1 xfer-status=0
__quar_build_pkt()-408: build req(id=336, type=4) for vdom-root, len=98, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=98
...
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
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__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
quar_fsb_handle_quar()-1439: added a req-6 to fortisandbox-fsb1, vfid=1, oftp-name=[].
__quar_start_connection()-908: start server fortisandbox-fsb1-172.18.52.154 in vdom-1
[103] __ssl_cert_ctx_load: Added cert /etc/cert/factory/root_Fortinet_Factory.cer, root
ca Fortinet_CA, idx 0 (default)
[551] ssl_ctx_create_new_ex: SSL CTX is created
[578] ssl_new: SSL object is created
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
quar_remote_recv_send()-731: dev=fortisandbox-fsb1 xfer-status=0
__quar_build_pkt()-408: build req(id=2, type=6) for vdom-vdom1, len=93, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=93
quar_remote_send()-520: req(id=2, type=6) read response, dev=fortisandbox-fsb1, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb1, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb1 xfer-status=1
quar_remote_recv()-662: dev(fortisandbox-fsb1) received a packet: len=767, type=1
quar_store_analytics_report()-590: Analytics-report return
file=/tmp/fsb/83bb2d9928b03a68b123730399b6b9365b5cc9a5a77f8aa007a6f1a499a13b18.json.gz,
buf_sz=735
quar_store_analytics_report()-597: The request
'83bb2d9928b03a68b123730399b6b9365b5cc9a5a77f8aa007a6f1a499a13b18' score is 1
quar_remote_recv()-718: file-[2] is accepted by server(fortisandbox-fsb1).
quar_put_job_req()-332: Job 2 deleted
quar_monitor_connection_func()-978: monitoring dev fortisandbox-fsb1
quar_monitor_connection_func()-978: monitoring dev fortisandbox-fsb1
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
quar_monitor_connection_func()-978: monitoring dev fortisandbox-fsb1
quar_stop_connection()-1006: close connection to server(fortisandbox-fsb1)
[193] __ssl_data_ctx_free: Done
[805] ssl_free: Done
[185] __ssl_cert_ctx_free: Done
[815] ssl_ctx_free: Done
[796] ssl_disconnect: Shutdown
l

Appliance FortiSandbox diagnostics:
FGT_PROXY # config global
FGT_PROXY (global) # diagnose test application quarantined 1
Total remote&local devices: 8, any task full? 0
System have disk, vdom is enabled, mgmt=1, ha=2
xfer-fas is enabled: ips-archive dlp-archive, realtime=yes, taskfull=no
addr=0.0.0.0/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=0, hmac_alg=0
License=0, content_archive=0, arch_pause=0.
global-fas is disabled.
forticloud-fsb is disabled.
fortisandbox-fsb1 is enabled: analytics, realtime=yes, taskfull=no
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addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
fortisandbox-fsb2 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
fortisandbox-fsb3 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
fortisandbox-fsb4 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
fortisandbox-fsb5 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
fortisandbox-fsb6 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
global-faz is disabled.
global-faz2 is disabled.
global-faz3 is disabled.
l

Checking FortiSandbox analysis statistics:
FGT_PROXY (global) # diagnose test application quarantine 7
Total: 0
Statistics:
vfid: 0, detected: 0, clean: 0, risk_low: 0, risk_med: 0, risk_high: 0, limit_
reached:0
vfid: 3, detected: 0, clean: 0, risk_low: 0, risk_med: 0, risk_high: 0, limit_
reached:0
vfid: 4, detected: 0, clean: 0, risk_low: 0, risk_med: 0, risk_high: 0, limit_
reached:0
FGT_PROXY (global) #

Debug on the FortiSandbox side
l

Appliance FortiSandbox OFTP debug:
> diagnose-debug device FG101E4Q17002429
[2019/01/31 00:48:21] LOGIN->SUCCEED: Serial(FG101E4Q17002429), HOSTNAME(FGT_PROXY)
[2019/01/31 00:48:21] FG101E4Q17002429 VDOM: vdom1
[2019/01/31 00:48:21] FG101E4Q17002429 suspicious stats START_TIME: 1548290749
[2019/01/31 00:48:21] FG101E4Q17002429 suspicious stats END_TIME: 1548895549
[2019/01/31 00:48:21] FG101E4Q17002429 opd_data_len=37 clean=2 detected=2 risk_low=0
risk_med=0 risk_high=0 sus_limit=0
[2019/01/31 00:48:21] FG101E4Q17002429 ENTERING->HANDLE_SEND_FILE.
[2019/01/31 00:48:21] FG101E4Q17002429 ENTERING->HANDLE_SEND_FILE.
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->FGT->VDOM: vdom1
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->FGT->VDOM: vdom1
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->IMG_VERSION: 6.2.0.0818
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->IMG_VERSION: 6.2.0.0818
[2019/01/31 00:48:21] INCOMING->FGT: FG101E4Q17002429, VDOM: vdom1
[2019/01/31 00:48:21] INCOMING->FGT: FG101E4Q17002429, VDOM: vdom1
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->TYPE: 0
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[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->TYPE: 1
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->VERSION: 3 . 1795
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->VERSION: 3 . 595
[2019/01/31 00:48:21] FG101E4Q17002429 VDOM: root
[2019/01/31 00:48:21] FG101E4Q17002429 ENTERING->HANDLE_SEND_FILE.
[2019/01/31 00:48:21] FG101E4Q17002429 suspicious stats START_TIME: 1548290749
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->FGT->VDOM: vdom1
[2019/01/31 00:48:21] FG101E4Q17002429 suspicious stats END_TIME: 1548895549
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->IMG_VERSION: 6.2.0.0818
[2019/01/31 00:48:21] INCOMING->FGT: FG101E4Q17002429, VDOM: vdom1
[2019/01/31 00:48:21] FG101E4Q17002429 INCOMING->TYPE: 4
[2019/01/31 00:48:21] FG101E4Q17002429 opd_data_len=37 clean=0 detected=0 risk_low=0
risk_med=0 risk_high=0 sus_limit=0
[2019/01/31 00:48:22] FG101E4Q17002429 RETRIEVE->PKG: TYPE: av, ENTRY_VERSION: 1795,
PACKAGE_PATH: /Storage/malpkg/pkg/avsig/avsigrel_1795.pkg
[2019/01/31 00:48:22] FG101E4Q17002429 RETRIEVE->PKG: TYPE: url, ENTRY_VERSION: 595,
PACKAGE_PATH: /Storage/malpkg/pkg/url/urlrel_595.pkg.gz
[2019/01/31 00:48:29] LOGIN->SUCCEED: Serial(FG101E4Q17002429), HOSTNAME(FGT_PROXY)
[2019/01/31 00:48:32] LOGIN->SUCCEED: Serial(FG101E4Q17002429), HOSTNAME(FGT_PROXY)
[2019/01/31 00:48:59] LOGIN->SUCCEED: Serial(FG101E4Q17002429), HOSTNAME(FGT_PROXY)
[2019/01/31 00:49:03] LOGIN->SUCCEED: Serial(FG101E4Q17002429), HOSTNAME(FGT_PROXY)

Using FortiSandbox Cloud with antivirus
Feature overview
FortiSandbox Cloud allows users to take advantage of FortiSandbox features without having to purchase, operate, and
maintain a physical appliance. It works the same way as the physical FortiSandbox appliance.
FortiSandbox Cloud allows you to control the region where your traffic is sent to for analysis. This allows you to meet
your country's compliances regarding data storage locations.

Support and limitations
l
l
l

l
l

l

In FortiOS 6.2 and later, users do not require a FortiGate Cloud account to use FortiSandbox Cloud.
Without a valid AVDB license, FortiGate devices are limited to 100 FortiGate Cloud submissions per day.
Unlimited FortiGate Cloud submissions are allowed if the FortiGate has a valid AVDB license.
l There is a limit on how many submissions are sent per minute.
l Per minute submission rate is based on the FortiGate model.
FortiSandbox can be used with antivirus in both proxy-based and flow-based policy inspection modes.
With FortiSandbox enabled, Full Scan mode antivirus can do the following:
l Submit only suspicious files to FortiSandbox for inspection.
l Submit every file to FortiSandbox for inspection.
l Do not submit anything.
Quick Scan mode antivirus cannot submit suspicious files to FortiSandbox. It can only do the following:
l Submit every file to FortiSandbox for inspection.
l Do not submit anything.
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Network topology example

Configuring the feature
To configure antivirus to work with an external block list, the following steps are required:
1.
2.
3.
4.

Through FortiCare/FortinetOne, register the FortiGate device and purchase a FortiGuard antivirus license
Enable FortiSandbox Cloud on the FortiGate
Enable FortiSandbox inspection
Enable the use of the FortiSandbox database

To obtain or renew an AVDB license:
1. Please see the video How to Purchase or Renew FortiGuard Services for FortiGuard antivirus license purchase
instructions.
2. Once a FortiGuard license has been purchased or activated, users will be provided with a paid FortiSandbox Cloud
license.
a. Go to Global > Main Dashboard to view the FortiSandbox Cloud license indicator.
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b. Users can also view this indicator at Global > System > FortiGuard.

To enable FortiSandbox Cloud on the FortiGate:
1. Go to Global > Security Fabric > Settings and set the Sandbox Inspection toggle to the On position.
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2. Select FortiSandbox Cloud and choose a region from the dropdown list.

3. Select Apply to save the settings.
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4. When the FortiGate is connected to the FortiSandbox Cloud, FortiSandbox's current database version is displayed.

To enable FortiSandbox inspection:
1. Go to Security Profiles > AntiVirus.
2. Enable FortiSandbox inspection by selecting either Suspicious Files Only or All Supported Files.

3. Files can be excluded from being sent to FortiSandbox based on their file types by choosing from a list of supported
file types.
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4. Files can also be excluded from being sent to FortiSandbox by using wild card patterns.

5. Select Apply.
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To enable the use of the FortiSandbox database:
1. Go to Security Profiles > AntiVirus.
2. Enable use of the FortiSandbox database by setting the Use FortiSandbox Database toggle to the On position.

3. Select Apply.

Diagnostics and debugging
l

Checking FortiGate Cloud controller status:
FGT_FL_FULL (global) # diagnose test application forticldd 2
Server: log-controller, task=0/10, watchdog is off
Domain name: logctrl1.fortinet.com
Address of log-controller: 1
172.16.95.168:443
Statistics: total=3, discarded=1, sent=2, last_updated=12163 secs ago
http connection: is not in progress
Current address: 172.16.95.168:443
Calls: connect=9, rxtx=12
Current tasks number: 0
Account: name=empty, status=0, type=basic
Current volume: 0B
Current tasks number: 0
Update timer fires in 74240 secs

l

Checking Cloud APT server status:
FGT_FL_FULL (global) # diagnose test application forticldd 3
Debug zone info:
Domain:
Home log server: 0.0.0.0:0
Alt log server: 0.0.0.0:0
Active Server IP:
0.0.0.0
Active Server status: down
Log quota:
0MB
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Log used:
0MB
Daily volume:
0MB
fams archive pause: 0
APTContract : 1
APT server: 172.16.102.51:514
APT Altserver: 172.16.102.52:514
Active APTServer IP:
172.16.102.51
Active APTServer status: up
l

<====
<====
<====
<====
<====

FortiSandbox Cloud diagnostics:
FGT_FL_FULL (global) # diagnose test application quarantine 1
Total remote&local devices: 4, any task full? 0
System have disk, vdom is enabled, mgmt=3, ha=1
xfer-fas is enabled: ips-archive dlp-archive, realtime=yes, taskfull=no
addr=0.0.0.0/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=1, hmac_alg=0
License=0, content_archive=0, arch_pause=0.
global-fas is disabled.
forticloud-fsb is enabled: analytics, realtime=yes, taskfull=no
addr=172.16.102.51/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=1, hmac_alg=0
fortisandbox-fsb1 is disabled.
fortisandbox-fsb2 is disabled.
fortisandbox-fsb3 is disabled.
fortisandbox-fsb4 is disabled.
fortisandbox-fsb5 is disabled.
fortisandbox-fsb6 is disabled.
global-faz is disabled.
global-faz2 is disabled.
global-faz3 is disabled.

l

Checking FortiSandbox Cloud submission statistics:
FGT_FL_FULL (global) # diagnose test application quarantined 2
Quarantine daemon state:
QUAR mem: mem_used=0, mem_limit=97269, threshold=72951
dropped(0 by quard, 0 by callers)
pending-jobs=0, tot-mem=0, last_ipc_run=12353, check_new_req=1
alloc_job_failed=0, job_wrong_type=0, job_wrong_req_len=0, job_invalid_qfd=0
tgz_create_failed=0, tgz_attach_failed=0, qfd_mmap_failed=0, buf_attached=0
xfer-fas:
ips: total=0, handled=0, accepted=0
quar: total=0, handled=0, accepted=0
archive: total=0, handled=0, accepted=0
analytics: total=0, handled=0, accepted=0, local_dups=0
analytics stats: total=0, handled=0, accepted=0
last_rx=0, last_tx=0, error_rx=0, error_tx=0
max_num_tasks=10000, num_tasks=0, mem_used=0, ttl_drops=0, xfer_status=0
forticloud-fsb:
ips: total=0, handled=0, accepted=0
quar: total=0, handled=0, accepted=0
archive: total=0, handled=0, accepted=0
analytics: total=0, handled=0, accepted=0, local_dups=0
num_buffer=0(per-minute:10) last_min_count=0 last_vol_count=0 next_vol_reset_tm='Sun Feb
17 00:00:00 2019
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'
analytics stats: total=24, handled=24, accepted=24
last_rx=1224329, last_tx=1224329, error_rx=2, error_tx=0
max_num_tasks=200, num_tasks=0, mem_used=0, ttl_drops=0, xfer_status=0
l

Checking FortiSandbox analysis statistics:
FGT_FL_FULL (global) # diagnose test application quarantine 7
Total: 0
Statistics:
vfid: 0, detected: 0, clean: 0, risk_low: 0, risk_med: 0, risk_high: 0, limit_
reached:0
vfid: 3, detected: 0, clean: 0, risk_low: 0, risk_med: 0, risk_high: 0, limit_
reached:0
vfid: 4, detected: 0, clean: 0, risk_low: 0, risk_med: 0, risk_high: 0, limit_
reached:0
FGT_FL_FULL (global) #

l

Update Daemon debug:
FGT_FL_FULL (global) # diagnose debug application quarantined -1
FGT_FL_FULL (global) # diagnose debug enable
quar_req_fsa_file()-890: fsa ext list new_version (1547781904)
quar_fsb_handle_quar()-1439: added a req-6 to fortisandbox-fsb5, vfid=1, oftp-name=[].
__quar_start_connection()-908: start server fortisandbox-fsb5-172.18.52.154 in vdom-1
[103] __ssl_cert_ctx_load: Added cert /etc/cert/factory/root_Fortinet_Factory.cer, root
ca Fortinet_CA, idx 0 (default)
[551] ssl_ctx_create_new_ex: SSL CTX is created
[578] ssl_new: SSL object is created
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
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upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.004011901281000
quar_remote_recv_send()-731: dev=fortisandbox-fsb2 xfer-status=0
__quar_build_pkt()-408: build req(id=337, type=4) for vdom-vdom1, len=99, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=99
quar_remote_send()-520: req(id=337, type=4) read response, dev=fortisandbox-fsb2, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb2, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb3 xfer-status=0
__quar_build_pkt()-408: build req(id=338, type=6) for vdom-vdom1, len=93, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=93
quar_remote_send()-520: req(id=338, type=6) read response, dev=fortisandbox-fsb3, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb3, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb5 xfer-status=0
__quar_build_pkt()-408: build req(id=340, type=6) for vdom-vdom1, len=93, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=93
quar_remote_send()-520: req(id=340, type=6) read response, dev=fortisandbox-fsb5, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb5, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb2 xfer-status=1
quar_remote_recv()-662: dev(fortisandbox-fsb2) received a packet: len=69, type=1
quar_remote_recv()-718: file-[337] is accepted by server(fortisandbox-fsb2).
quar_put_job_req()-332: Job 337 deleted
quar_remote_recv_send()-731: dev=fortisandbox-fsb4 xfer-status=0
__quar_build_pkt()-408: build req(id=339, type=6) for vdom-vdom1, len=93, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=93
quar_remote_send()-520: req(id=339, type=6) read response, dev=fortisandbox-fsb4, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb4, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb1 xfer-status=0
__quar_build_pkt()-408: build req(id=336, type=4) for vdom-root, len=98, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=98
...
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
quar_fsb_handle_quar()-1439: added a req-6 to fortisandbox-fsb1, vfid=1, oftp-name=[].
__quar_start_connection()-908: start server fortisandbox-fsb1-172.18.52.154 in vdom-1
[103] __ssl_cert_ctx_load: Added cert /etc/cert/factory/root_Fortinet_Factory.cer, root
ca Fortinet_CA, idx 0 (default)
[551] ssl_ctx_create_new_ex: SSL CTX is created
[578] ssl_new: SSL object is created
upd_cfg_extract_av_db_version[378]-version=06002000AVDB00201-00066.01026-1901301530
upd_cfg_extract_ids_db_version[437]-version=06002000NIDS02403-00014.00537-1901300043
upd_cfg_extract_ids_db_version[437]-version=06002000APDB00103-00006.00741-1512010230
upd_cfg_extract_ids_db_version[437]-version=06002000ISDB00103-00014.00537-1901300043
upd_cfg_extract_ibdb_botnet_db_version[523]-version=06002000IBDB00101-00004.00401-
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1901281000
quar_remote_recv_send()-731: dev=fortisandbox-fsb1 xfer-status=0
__quar_build_pkt()-408: build req(id=2, type=6) for vdom-vdom1, len=93, oftp_name=
__quar_send()-470: dev buffer -- pos=0, len=93
quar_remote_send()-520: req(id=2, type=6) read response, dev=fortisandbox-fsb1, xfer_
status=1, buflen=12
quar_remote_recv_send()-770: dev-fortisandbox-fsb1, oevent=4, nevent=1, xfer-status=1
quar_remote_recv_send()-731: dev=fortisandbox-fsb1 xfer-status=1
quar_remote_recv()-662: dev(fortisandbox-fsb1) received a packet: len=767, type=1
quar_store_analytics_report()-590: Analytics-report return
file=/tmp/fsb/83bb2d9928b03a68b123730399b6b9365b5cc9a5a77f8aa007a6f1a499a13b18.json.gz,
buf_sz=735
quar_store_analytics_report()-597: The request
'83bb2d9928b03a68b123730399b6b9365b5cc9a5a77f8aa007a6f1a499a13b18' score is 1
quar_remote_recv()-718: file-[2] is accepted by server(fortisandbox-fsb1).
quar_put_job_req()-332: Job 2 deleted
quar_monitor_connection_func()-978: monitoring dev fortisandbox-fsb1
quar_monitor_connection_func()-978: monitoring dev fortisandbox-fsb1
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
__get_analytics_stats()-19: Received an ANALYTICS_STATS request, vfid: 0
__quar_req_handler()-127: Request 0 was handled successfully
quar_monitor_connection_func()-978: monitoring dev fortisandbox-fsb1
quar_stop_connection()-1006: close connection to server(fortisandbox-fsb1)
[193] __ssl_data_ctx_free: Done
[805] ssl_free: Done
[185] __ssl_cert_ctx_free: Done
[815] ssl_ctx_free: Done
[796] ssl_disconnect: Shutdown
l

Appliance FortiSandbox diagnostics:
FGT_PROXY # config global
FGT_PROXY (global) # diagnose test application quarantined 1
Total remote&local devices: 8, any task full? 0
System have disk, vdom is enabled, mgmt=1, ha=2
xfer-fas is enabled: ips-archive dlp-archive, realtime=yes, taskfull=no
addr=0.0.0.0/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=0, hmac_alg=0
License=0, content_archive=0, arch_pause=0.
global-fas is disabled.
forticloud-fsb is disabled.
fortisandbox-fsb1 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
fortisandbox-fsb2 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
fortisandbox-fsb3 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
fortisandbox-fsb4 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
fortisandbox-fsb5 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
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ssl_opt=3, hmac_alg=0
fortisandbox-fsb6 is enabled: analytics, realtime=yes, taskfull=no
addr=172.18.52.154/514, source-ip=0.0.0.0, keep-alive=no.
ssl_opt=3, hmac_alg=0
global-faz is disabled.
global-faz2 is disabled.
global-faz3 is disabled.

Web filter
Web filtering restricts or controls user access to web resources and can be applied to firewall policies.
In FortiOS, there are three main components of web filtering:
l
l

l

Web content filter: blocks web pages containing words or patterns that you specify.
URL filter: uses URLs and URL patterns to block or exempt web pages from specific sources, or block malicious
URLs discovered by FortiSandbox.
FortiGuard Web Filtering service: provides many additional categories you can use to filter web traffic.

These components interact with each other to provide maximum control over what users on your network can view and
protect your network from many internet content threats.
Web filters are applied in the following order:
1.
2.
3.
4.
5.

URL filter
FortiGuard Web Filtering
Web content filter
Web script filter
Antivirus scanning

FortiOS includes three preloaded web filter profiles:
l
l
l

default
monitor-all (monitors and logs all URLs visited, flow-based)
wifi-default (default configuration for offloading WiFi traffic)

You can customize these profiles, or you can create your own to manage network user access.

Some features of this functionality require a subscription to FortiGuard Web Filtering.

The following topics provide information about web filters:
l
l
l
l
l
l
l

URL filter on page 743
FortiGuard filter on page 748
Usage quota on page 756
Web content filter on page 758
File filter on page 762
Advanced filters 1 on page 768
Advanced filters 2 on page 772
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l
l
l
l

External resources for web filter on page 777
Reliable web filter statistics on page 784
Flow-based web filtering on page 786
URL certificate blacklist on page 788

URL filter
URL filter is also called static URL filter. By adding specific URLs with patterns containing text and regular expressions,
FortiGate can allow, block, exempt, and monitor web pages matching any specified URLs or patterns, and can display a
replacement message instead.

Sample topology

Create URL filter
You can create a URL filter using the GUI or CLI. After creating the URL filter, attach it to a webfilter profile.

To create URL filter in the GUI:
1. Go to Security Profiles > Web Filter and go to the Static URL Filter section.
2. Enable URL Filter.

3. Under URL Filter, select Create New to display the New URL Filter pane.
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URL Filter Type

Description

Simple

FortiGate tries to strictly match the full context. For example, if you enter
www.facebook.com in the URL field, it only matches traffic with www.facebook.com. It
won't match facebook.com or message.facebook.com.
When FortiGate finds a match, it performs the selected URL Action.

Regular
Expression or
Wildcard

FortiGate tries to match the pattern based on the rules of regular expressions or
wildcards. For example, if you enter *fa* in the URL field, it matches all the content that
has fa such as www.facebook.com, message.facebook.com, fast.com, etc.
When FortiGate finds a match, it performs the selected URL Action.

For more information, see the URL Filter expressions technical note in
https://kb.fortinet.com/kb/documentLink.do?externalID=FD37057.

URL Filter Action

Description

Block

Denies or blocks attempts to access any URL matching the URL pattern. FortiGate
displays a replacement message.

Allow

The traffic is passed to the remaining FortiGuard webfilters, web content filters, web script
filters, antivirus proxy operations, and DLP proxy operations. If the URL does not appear
in the URL list, the traffic is permitted.

Monitor

The traffic is processed the same way as the Allow action. For the Monitor action, a log
message is generated each time a matching traffic pattern is established.

Exempt

The traffic is allowed to bypass the remaining FortiGuard webfilters, web content filters,
web script filters, antivirus scanning, and DLP proxy operations

4. For example, enter *facebook.com and select Wildcard and Block; and select OK.

After creating the URL filter, attach it to a webfilter profile.

Create URL filter using CLI
To create and enable a URL filter using the CLI, create the URL filter and then attach it to a webfilter profile. The CLI
commands below show the full configuration of creating a URL filter.
config webfilter urlfilter
edit {id}
# Configure URL filter lists.
set name {string}
Name of URL filter list. size[35]
config entries
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edit {id}
# URL filter entries.
set url {string}
URL to be filtered. size[511]
set type {simple | regex | wildcard} Filter type (simple, regex, or wildcard).
simple
Simple URL string.
regex
Regular expression URL string.
wildcard Wildcard URL string.
set action {exempt | block | allow | monitor} Action to take for URL filter
matches.

set
set
operations that

set
next

exempt
Exempt matches.
block
Block matches.
allow
Allow matches (no log).
monitor Allow matches (with log).
status {enable | disable}
Enable/disable this URL filter.
exempt {option}
If action is set to exempt, select the security profile
exempt URLs skip. Separate multiple options with a space.
av
AntiVirus scanning.
web-content
Web Filter content matching.
activex-java-cookie ActiveX, Java, and cookie filtering.
dlp
DLP scanning.
fortiguard
FortiGuard web filter.
range-block
Range block feature.
pass
Pass single connection from all.
all
Exempt from all security profiles.
referrer-host {string}
Referrer host name. size[255]

next
end

To create URL filter to filter Facebook using the CLI:
config webfilter urlfilter
edit 1
set name "webfilter"
config entries
edit 1
set url "*facebook.com"
set type wildcard
set action block
next
end
next
end

To attach the URL filter to a webfilter profile:
config webfilter profile
edit "webfilter"
config web
set urlfilter-table 1
end
config ftgd-wf
unset options
end
next
end
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Attach webfilter profile to the firewall policy
After you have created the URL filter and attached it to a webfilter profile, you must attach the profile to a firewall policy.

To attach a webfilter profile to a firewall policy using the GUI:
1. Go to Policy & Objects > IPv4 Policy.
2. Edit the policy that you want to enable the webfilter.
3. In the Security Profiles section, enable Web Filter and select the profile you created.

To attach a webfilter profile to a firewall policy using the CLI:
config firewall policy
edit 1
set name "WF"
set uuid b725a4d4-5be5-51e9-43fa-6d4e67d56bad
set srcintf "wan2"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set inspection-mode proxy
set logtraffic all
set webfilter-profile "webfilter"
<-- attach the webfilter profile you just
created.
set profile-protocol-options "protocol"
set ssl-ssh-profile "protocols"
set nat enable
next
end
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Validate the URL filter results
Validate the URL filter results by going to a blocked website. For example, when you go to the Facebook website, you
see the replacement message.

To customize the URL web page blocked message:
1. Go to System > Replacement Messages.
2. Go to the Security section and select URL Block Page.
3. Set up a custom message for blocked pages.
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To check webfilter logs in the GUI:
1. Go to Log & Report > Web Filter.

2. If there are too many log entries, click Add Filter and select Event Type > urlfilter to display logs generated by the
URL filter.

To check webfilter logs in the CLI:
FGT52E-NAT-WF # execute log filter category utm-webfilter
FGT52E-NAT-WF # execute log display
1: date=2019-04-22 time=11:48:43 logid="0315012544" type="utm" subtype="webfilter"
eventtype="urlfilter" level="warning" vd="vdom1" eventtime=1555958923322174610
urlfilteridx=0 urlsource="Local URLfilter Block" policyid=1 sessionid=649063
srcip=10.1.200.15 srcport=50472 srcintf="wan2" srcintfrole="wan" dstip=157.240.18.35
dstport=443 dstintf="wan1" dstintfrole="wan" proto=6 service="HTTPS"
hostname="www.facebook.com" profile="webfilter" action="blocked" reqtype="direct" url="/"
sentbyte=1171 rcvdbyte=141 direction="outgoing" msg="URL was blocked because it is in the
URL filter list" crscore=30 craction=8 crlevel="high"

FortiGuard filter
To use this service, you must have a valid subscription on your FortiGate.
FortiGuard filter enhances the Web Filter features supplied with your FortiGate unit by sorting billions of web pages into a
wide range of categories that users can allow or block.
FortiGuard Web Filter services includes over 45 million individual website rating that applies to more than two billion
pages. When FortiGuard filter is enabled in a Web Filter and is applied to firewall policies, if a request for a web page
appears in traffic controlled by one of the firewall policies, the URL is sent to the nearest FortiGuard server. The URL
category or rating is returned. If the category is blocked, the FortiGate shows a replacement message in place of the
requested page. If the category is not blocked, the page request is sent to the requested URL as normal.
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FortiGuard Web Filter action
You can select one of the following FortiGuard Web Filter actions:

FortiGuard Web
Filter Action

Description

Allow

Permit access to the sites in the category.

Block

Prevent access to the sites in the category. Users trying to access a blocked site sees a
replacement message indicating the site is blocked.

Monitor

Permits and logs access to sites in the category. You can enable user quotas when you
enable this action.

Warning

Displays a message to the user allowing them to continue if they choose.

Authenticate

Requires the user to authenticate with the FortiGate before allowing access to the category or
category group.

FortiGuard Web Filter categories
FortiGuard has many Web Filter categories including two local categories and a special remote category. For more
information on the different categories, see the table below.

FortiGuard Web Filter
category

Where to find more information

All URL categories

https://fortiguard.com/webfilter/categories.

Remote category

External resources for web filter on page 777.

The priority of categories is local category > external category > FortiGuard built-in category. If a URL is configured as a
local category, it only follows the behavior of local category and not external or FortiGuard built-in category.

Sample configuration of blocking a web category
This example shows blocking a website based on its category (rating), for example, information technology.

To block a category in the GUI:
1. Go to Security Profiles > Web Filter and go to the FortiGuard category based filter section.

2. Open the General Interest - Business section by clicking the + icon beside it.
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3. Select Information Technology and then select Block.

To block a category in the CLI:
config webfilter profile
edit "webfilter"
config ftgd-wf
unset options
config filters
edit 1
set category 52
set action block
next
end
end
next
end

<-- the pre-set id of "information technology" caterogy
<-- set action to block

To validate that you have blocked a category:
1. Go to a website belonging to the blocked category, for example, www.fortinet.com, and you see a blocked page and
the category that is blocked.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

750

Security Profiles

To view the log of a blocked website in the GUI:
1. Go to Log & Report > Web Filter.

To view the log of a blocked website in the CLI:
FGT52E-NAT-WF # execute log filter category utm-webfilter
FGT52E-NAT-WF # execute log display
1: date=2019-04-22 time=13:46:25 logid="0316013056" type="utm" subtype="webfilter"
eventtype="ftgd_blk" level="warning" vd="vdom1" eventtime=1555965984972459609 policyid=1
sessionid=659263 srcip=10.1.200.15 srcport=49234 srcintf="wan2" srcintfrole="wan"
dstip=54.183.57.55 dstport=80 dstintf="wan1" dstintfrole="wan" proto=6 service="HTTP"
hostname="www.fortinet.com" profile="webfilter" action="blocked" reqtype="direct" url="/"
sentbyte=386 rcvdbyte=0 direction="outgoing" msg="URL belongs to a denied category in
policy" method="domain" cat=52 catdesc="Information Technology"
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Sample configuration of issuing a warning
This example shows issuing a warning when a user visits a website based on its category (rating), for example,
information technology.

To configure a warning in the GUI:
1. Go to Security Profiles > Web Filter and go to the FortiGuard category based filter section.

2. Open the General Interest - Business section by clicking the + icon beside it.
3. Select Information Technology and then select Warning.

4. Set the Warning Interval which is the interval when the warning page appears again after the user chooses to
continue.

To configure a warning in the CLI:
config webfilter profile
edit "webfilter"
config ftgd-wf
unset options
config filters
edit 1
set category 52
set action warning
next
end
end
next
end
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To validate that you have configured the warning:
1. Go to a website belonging to the selected category, for example, www.fortinet.com, and you see a warning page
where you can choose to Proceed or Go Back.

Sample configuration of authenticating a web category
This example shows authenticating a website based on its category (rating), for example, information technology.

To authenticate a category in the GUI:
1. Go to Security Profiles > Web Filter and go to the FortiGuard category based filter section.

2. Open the General Interest - Business section by clicking the + icon beside it.
3. Select Information Technology and then select Authenticate.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

753

Security Profiles
4. Set the Warning Interval which is the interval when the authentication page appears again after authentication.
5. Click the + icon beside Selected User Group and select a user group. You must have a valid user group to use this
feature.

To authenticate a category in the CLI:
config webfilter profile
edit "webfilter"
config ftgd-wf
unset options
config filters
edit 1
set category 52
set action authenticate
set auth-usr-grp "local_group"
next
end
end
next
end

<-- set the action of authenticate
<-- user to authenticate

To validate that you have configured authentication:
1. Go to a website belonging to the selected category, for example, www.fortinet.com. First, you see a warning page
where you can choose to Proceed or Go Back.
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2. Click Proceed to check that the authentication page appears.

3. Enter the username and password of the user group you selected, and click Continue.
If the credentials are correct, the traffic is allowed through.

Sample customization of the replacement page
When the FortiGuard Web Filter action is Block, Warning, or Authenticate, there is a Customize option for you to
customize the replace page.

To customize the replace page:
1. Go to Security Profiles > Web Filter and go to the FortiGuard category based filter section.
2. Right-click the item and select Customize.
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3. A pane appears for you to customize the page.

Usage quota
In addition to using category and classification blocks and overrides to limit user access to URLs, you can set a daily
quota by category, category group, or classification. Quotas allow access for a specified length of time or a specific
bandwidth, and is calculated separately for each user. Quotas are reset everyday at midnight.
Quotas can be set only for the actions of Monitor, Warning, or Authenticate. When the quota is reached, the traffic is
blocked and the replacement page displays.

You can only use quotas when inspection mode is Proxy.

Sample topology
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Sample configuration of setting a quota
This example shows setting a time quota for a category, for example, the Education category.

To configure a quota in the GUI:
1.
2.
3.
4.

Go to Security Profiles > Web Filter and go to the FortiGuard category based filter section.
Open the General Interest - Personal section by selecting the + icon beside it.
Select Education and then select Monitor.
In the Category Usage Quota section, select Create New.

5. In the right pane, select the Category field and then select Education.
6. For the Quota Type, select Time and set the Total quota to 5 minute(s).

7. Select OK and the Category Usage Quota section displays the quota.

8. Validate the configuration by visiting a website in the education category, for example https://www.harvard.edu/.
You can view websites in the education category.
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9. Check the used and remaining quota in Monitor > FortiGuard Quota.

10. When the quota reaches its limit, traffic is blocked and the replacement page displays.

To configure a quota in the CLI:
config webfilter profile
edit "webfilter"
config ftgd-wf
unset options
config filters
edit 1
set category 30 <-- the id of education category
next
end
config quota
edit 1
set category 30
set type time
set duration 5m
next
end
end
next
end

Web content filter
You can control access to web content by blocking web pages containing specific words or patterns. This helps to
prevent access to pages with questionable material. You can specify words, phrases, patterns, wildcards and Perl
regular expressions to match content on web pages. You can use multiple web content filter lists and select the best web
content filter list for each Web Filter profile.
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Pattern type
When you have created the Web Filter content list, you need to add web content patterns to it. There are two types of
patterns: wildcard and regular expression.

Wildcard
Use the wildcard setting to block or exempt one word or text strings of up to 80 characters. You can also use wildcard
symbols such as ? or * to represent one or more characters. For example, a wildcard expression forti*.com matches
fortinet.com and forticare.com. The * represents any character appearing any number of times.

Regular expression
Use the regular expression setting to block or exempt patterns of Perl expressions which use some of the same symbols
as wildcard expressions but for different purposes. In regular expressions, * represents the character before the symbol.
For example, forti*.com matches fortiii.com but not fortinet.com or fortiice.com. In this case, the symbol * represents i
appearing any number of times.
The maximum number of web content patterns in a list is 5000.

Content evaluation
The web content filter feature scans the content of every web page that is accepted by a security policy. The system
administrator can specify banned words and phrases and attach a numerical value, or score, to the importance of those
words and phrases. When the web content filter scan detects banned content, it adds the scores of banned words and
phrases found on that page. If the sum is higher than a threshold set in the Web Filter profile, FortiGate blocks the page.
The default score for web content filter is 10 and the default threshold is 10. This means that by default, a web page is
blocked by a single match.
Banned words or phrases are evaluated according to the following rules:
l

l
l

The score for each word or phrase is counted only once, even if that word or phrase appears many times in the web
page.
The score for any word in a phrase without quotation marks is counted.
The score for a phrase in quotation marks is counted only if it appears exactly as written.

Sample of applying banned pattern rules
The following table is an example of how rules are applied to the contents of a web page. For example, a web page
contains only this sentence:
The score for each word or phrase is counted only once, even if that word or phrase appears many times in the web
page.
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Banned
pattern

Assigned
score

Score
added to
the sum
for the
entire
page

Threshold
score

Comment

word

20

20

20

Appears twice but only counted once. Web page is
blocked.

word phrase

20

40

20

Each word appears twice but only counted once giving
a total score of 40. Web page is blocked.

word sentence

20

20

20

“word” appears twice, “sentence” does not appear, but
since any word in a phrase without quotation marks is
counted, the score for this pattern is 20. Web page is
blocked.

"word
sentence"

20

0

20

This phrase does not appear exactly as written. Web
page is allowed.

"word or
phrase"

20

20

20

This phrase appears twice but is counted only once.
Web page is blocked.

Sample configuration
To configure web content filter in the GUI:
1. Go to Security Profiles > Web Filter and go to the Static URL Filter section.
2. Enable Content Filter to display its options.

3. Select Create New to display the content filter options.
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4. For Pattern Type, select Regular Expression and enter fortinet in the Pattern field.
l Leave Language as Western.
l Set Action to Block.
l Set Status to Enable.

5. Select OK to see the updated Static URL Filter section.

6. Validate the configuration by visiting a website with the word fortinet, for example, www.fortinet.com. The website is
blocked and a replacement page displays.

To configure web content filter in the CLI:
1. Create a content table:
config webfilter content
edit 1
set name "webfilter"
config entries
edit "fortinet"
set pattern-type regexp
set status enable
set lang western
set score 10
set action block
next
end
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next
end

2. Attach the content table to the Web Filter profile:
config webfilter profile
edit "webfilter"
config web
set bword-threshold 10
set bword-table 1
step
end
config ftgd-wf
unset options
end
next
end

<-- the threshold is 10
<-- the id of content table we created in the previous

File filter
File Filter allows the Web Filter profile to block files passing through a FortiGate based on file type.
HTTP and FTP File Filtering is configurable in Web Filter profile.
File Filtering in Web Filter profile is based on file type (file's meta data) only, and not on file size or file content. You need
to configure a DLP sensor to block files based on size or content such as SSN numbers, credit card numbers or regexp.
File filtering only works on proxy mode policies.

Supported file types
File Filter in Web Filter profile supports the following file types:

File Type Name

Description

.net

Match .NET files

7z

Match 7-zip files

activemime

Match activemime files

arj

Match arj compressed files

aspack

Match aspack files

avi

Match avi files

base64

Match base64 files

bat

Match Windows batch files

bin

Match bin files

binhex

Match binhex files

bmp

Match bmp files

bzip

Match bzip files
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File Type Name

Description

bzip2

Match bzip2 files

cab

Match Windows cab files

chm

Match Windows compiled HTML help files

class

Match class files

cod

Match cod files

crx

Match Chrome extension files

dmg

Match Apple disk image files

elf

Match elf files

exe

Match Windows executable files

fsg

Match fsg files

gif

Match gif files

gzip

Match gzip files

hlp

Match Windows help files

hta

Match hta files

html

Match html files

ignored

Match ignored files

iso

Match ISO archive files

jad

Match jad files

javascript

Match javascript files

jpeg

Match jpeg files

lzh

Match lzh compressed files

mach-o

Match Mach object files

mime

Match mime files

mov

Match mov files

mp3

Match mp3 files

mpeg

Match mpeg files

msc

Match msc files

msi

Match Windows Installer msi bzip files

msoffice

Match MS-Office files. For example, doc, xls, ppt, and so on.

msofficex

Match MS-Office XML files. For example, docx, xlsx, pptx, and so on.
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File Type Name

Description

pdf

Match pdf files

petite

Match petite files

png

Match png files

prc

Match prc files

rar

Match rar archives

rm

Match rm files

sis

Match sis files

tar

Match tar files

tiff

Match tiff files

torrent

Match torrent files

unknown

Match unknown files

upx

Match upx files

uue

Match uue files

wav

Match wav files

wma

Match wma files

xar

Match xar archive files

xz

Match xz files

zip

Match zip files

Example
In the following example, three file filters are used in the Web Filter profile:
1. Block PDFs from entering our leaving the network (filter1).
2. Log the download of some graphics file-types via HTTP (filter2).
3. Block executable files from leaving to the network over FTP (filter3).

To configure a file-type based web filter in the CLI:
config webfilter profile
edit "webfilter-file-filter"
config file-filter
set status enable
set log enable
set scan-archive-contents enable
config entries
edit "filter1"
set comment "Block PDF files"
set protocol http ftp
set action block
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set direction any
set encryption any
set file-type "pdf"
next
edit "filter2"
set comment "Log graphics files"
set protocol http
set action log
set direction incoming
set encryption any
set file-type "jpeg" "png" "gif"
next
edit "filter3"
set comment "Block upload of EXE files"
set protocol ftp
set action block
set direction outgoing
set encryption any
set file-type "exe"
next
end
end
next
end

After configuring file filters in Web Filter profile, apply it to a firewall policy using the following command:
config firewall policy
edit 1
set name "client-to-internet"
set srcintf "dmz"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set utm-inspection-mode proxy
set logtraffic all
set webfilter profile "webfilter-filefilter"
set profile-protocol-options "protocol"
set ssl-ssh-profile "protocols"
set nat enable
next
end

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

765

Security Profiles

To configure a file-type based web filter in the GUI:
1. Go to Security Profiles > Web Filter.
2. Click Create New or select an existing profile and click Edit.

3.
4.
5.
6.

Enable File Filter.
Enable Log and Scan Archived Contents.
In the File Filter table, click Create New.
Configure the filters:
a. filter1 blocks PDFs from entering our leaving the network .
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b. filter2 logs the download of some graphics file-types via HTTP .

c. filter3 blocks EXE files from leaving to the network over FTP .

7. Click OK.
8. Add the new web filter profile to a firewall policy.

Log examples
File filter block action:
1: date=2019-03-19 time=09:42:15 logid="0346012673" type="utm" subtype="webfilter"
eventtype="file_filter" level="warning" vd="vd1" eventtime=1548438135 policyid=1
sessionid=29449 srcip=10.1.100.22 srcport=52816 srcintf="dmz" srcintfrole="undefined"
dstip=172.16.200.55 dstport=80 dstintf="wan1" dstintfrole="undefined" proto=6 service="HTTP"
hostname="172.16.200.55" profile="webfilter-filefilter" action="blocked" reqtype="direct"
url="/app_data/test1.pdf" sentbyte=0 rcvdbyte=0 direction="incoming" filename="test1.pdf"
filtername="filter1" filetype="pdf" msg="File was blocked by file filter."

File filter log action:
2: date=2019-03-19 time=10:48:23 logid="0346012672" type="utm" subtype="webfilter"
eventtype="file_filter" level="notice" vd="vd1" eventtime=1548442102 policyid=1
sessionid=521 srcip=10.1.100.22 srcport=52894 srcintf="dmz" srcintfrole="undefined"
dstip=172.16.200.55 dstport=80 dstintf="wan1" dstintfrole="undefined" proto=6 service="HTTP"
hostname="172.16.200.55" profile="webfilter-filefilter" action="passthrough"
reqtype="direct" url="/app_data/park.jpg" sentbyte=0 rcvdbyte=0 direction="incoming"
filename="park.jpg" filtername="filter2" filetype="jpeg" msg="File was detected by file
filter."
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In the GUI:
Go to VDOM > Log & Report > Web Filter:

Advanced filters 1
This topic gives examples of the following advanced filter features:
l
l
l
l
l

Block malicious URLs discovered by FortiSandbox on page 768
Allow websites when a rating error occurs on page 769
Rate URLs by domain and IP address on page 769
Block invalid URLs on page 770
Rate images by URL on page 771

Block malicious URLs discovered by FortiSandbox
To use this feature, you must be registered to a FortiSandbox and be connected to it.
This feature blocks malicious URLs that FortiSandbox finds.

To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Static URL Filter section.
2. Enable Block malicious URLs discovered by FortiSandbox.
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To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
config web
set blacklist enable
end
next
end

Allow websites when a rating error occurs
If you don't have a FortiGuard license but you have enabled services that need a FortiGuard license, such as FortiGuard
filter, then you'll get a rating error message.
Use this setting to allow access to websites that return a rating error from the FortiGuard Web Filter service.

To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Rating Options section.
2. Enable Allow websites when a rating error occurs.

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
config ftgd-wf
set options error-allow
end
next
end

Rate URLs by domain and IP address
If you enable this feature, in addition to only sending domain information to FortiGuard for rating, FortiGate always sends
both the URL domain name and the TCP/IP packet's IP address (except for private IP addresses) to FortiGuard for the
rating.
FortiGuard server might return a different category of IP address and URL domain. If they are different, FortiGate uses
the rating weight of the IP address or domain name to determine the rating result and decision. This rating weight is hardcoded in FortiGate.
For example, if we use a spoof IP of Google as www.irs.gov, FortiGate will send both the IP address and domain name to
FortiGuard to get the rating. In this example, we get two different ratings, one is search engine and portals which belongs
to the IP of Google, another is government and legal organizations which belongs to www.irs.gov. As the search engine
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and portals has a higher weight than government and legal organizations, this traffic will be rated as search engine and
portals and not rated as government and legal organizations.

To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Rating Options section.
2. Enable Rate URLs by domain and IP address.

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
config ftgd-wf
set options rate-server-ip
end
next
end

Block invalid URLs
Use this feature to block websites when their SSL certificate CN field does not contain a valid domain name.
For example, this option blocks URLs which contains spaces. If there is a space in the URL, it must be written
as: http://www.example.com/space%20here.html.

To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Static URL Filter section.
2. Enable Block invalid URLs .

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
set options block-invalid-url
next
end
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Rate images by URL
This feature enable FortiGate to retrieve ratings for individual images in addition to websites. Images in a blocked
category are not displayed even if they are part of a site in an allowed category. Blocked images are replaced with blank
placeholders. These image file types are rated: GIF, JPEG, PNG, BMP, and TIFF.
This feature requires a valid FortiGuard license, otherwise rating errors will occur. By default, this feature is enabled.
For example, if the Other Adult Materials category is blocked, before enabling Rate images by URL, the image is not
blocked:

After enabling Rate images by URL, images in the Other Adult Materials category are blocked. For example:
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To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Rating Options section.
2. Enable Rate images by URL.

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
config ftgd-wf
unset options
set rate-image-urls enable
end
next
end

Advanced filters 2
This topic gives examples of the following advanced filter features:
l
l

l
l
l
l

Safe search on page 772
YouTube education filters on page 773
l Restrict YouTube access on page 773
l YouTube channel filtering on page 774
Log all search keywords on page 775
Restrict Google account usage to specific domains on page 775
HTTP POST Action on page 776
Remove Java applets, remove ActiveX, and remove cookies on page 777

These advanced filters are only available when inspection mode is Proxy.

Safe search
This feature applies to popular search sites and prevents explicit websites and images from appearing in search results.
Supported search sites are:
l
l
l
l

Google
Yahoo
Bing
Yandex
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To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Search Engines section.
2. Enable Enforce 'Safe Search' on Google, Yahoo!, Bing, Yandex.

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
config web
set safe-search url
end
next
end

YouTube education filters
Use these features to limit users' access to YouTube channels, such as in an education environment where you want
students and users to be able to access YouTube education videos but not other YouTube videos.

Restrict YouTube access
Formerly, YouTube for Schools was a way to access educational videos inside a school network. This YouTube feature
lets schools access educational videos on YouTube EDU and to specify the videos accessible within the school network.
When Google stopped supporting YouTube for Schools on July 1, 2016, YouTube safe search also stopped working.
Google provides information on restricting YouTube content such as Restrict YouTube content available to G Suite
users. At this time, the options Google offers to restrict inappropriate content includes: DNS, HTTP headers, and
Chromebooks..

To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Search Engines section.
2. Enable Restrict YouTube Access and select Strict or Moderate.

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
config web
set youtube-restrict strict
end
next
end
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YouTube channel filtering
This Web Filter feature is also called Restrict YouTube access to specific channels. Use this feature to block or only
allow matching YouTube channels.
The following identifiers are used:
given <channel-id>, affect on:
www.youtube.com/channel/<channel-id>
www.youtube.com/user/<user-id>

matches channel-id from <meta itemprop="channelId" content="UCGzuiiLdQZu9wxDNJHO_JnA">
www.youtube.com/watch?v=<string>

matches channel-id from <meta itemprop="channelId" content="UCGzuiiLdQZu9wxDNJHO_JnA">

To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Proxy Options section.
2. Enable Restrict YouTube access to specific channels.

3. Select Create New and specify the Channel ID, for example, UCGzuiiLdQZu9wxDNJHO_JnA.

4. Select OK and the option shows the Channel ID and its Link.

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
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set youtube-channel-status whitelist
this channel id and relative identifiers

<-- whitlist: only allow the traffic belongs to

blacklist: only block the traffic belongs to
this channel id and relative identifiers and allow the other traffic pass
config youtube-channel-filter
edit 1
set channel-id "UCGzuiiLdQZu9wxDNJHO_JnA"
next
end
next
end

Log all search keywords
Use this feature to log all search phrases.

To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Search Engines section.
2. Enable Log all search keywords.

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
config web
set log-search enable
end
next
end

Restrict Google account usage to specific domains
Use this feature to block access to some Google accounts and services while allowing access to accounts in the
domains in the exception list.
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To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Proxy Options section.
2. Enable Restrict Google account usage to specific domains.

3. Select the + button and enter the domains that Google can access, for example, www.fortinet.com.

When you try to use Google services like Gmail, only traffic from the domain of www.fortinet.com can go through. Traffic
from other domains is blocked.

HTTP POST Action
Select the action to take with HTTP POST traffic. HTTP POST is the command used by your browser when you send
information, such as a form you have filled-out or a file you are uploading to a web server.
The action options are Allow or Block. The default is Allow.

To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Proxy Options section.
2. For HTTP POST Action, select Allow or Block.

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
set post-action [normal/block]
config ftgd-wf
unset options
end
next
end
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Remove Java applets, remove ActiveX, and remove cookies
The Remove Java Applets feature filters java applets from web traffic. Websites using java applets might not function
properly if you enable this filter.
The Remove ActiveX feature filters ActiveX scripts from web traffic. Websites using ActiveX might not function properly
with if you enable this filter.
The Remove Cookies feature filters cookies from web traffic. Websites using cookies might not function properly if you
enable this filter.

To enable this feature in the GUI:
1. Go to Security Profiles > Web Filter and go to the Proxy Options section.
2. Select the filters you want to use: Remove Java Applets, Remove ActiveX, and/or Remove Cookies.

To enable this feature in the CLI:
config webfilter profile
edit "webfilter"
set options activexfilter cookiefilter javafilter <-- enable one or more of
activexfilter cookiefilter javafilter.
config ftgd-wf
unset options
end
next
end

External resources for web filter
External Resources is a new feature introduced in FortiOS 6.0, which provides a capability to import an external blacklist
which sits on an HTTP server. This feature helps FortiGate retrieve a dynamic URL/Domain Name/IP Address/Malware
hash list from an external HTTP server periodically. FortiGate uses these external resources as Web Filter's remote
categories, DNS Filter's remote categories, policy address objects or antivirus profile's malware definitions. If the
external resource is updated, FortiGate objects will update dynamically.
External Resource are categorized into 4 types:
l
l

URL list (Type=category)
Domain Name List (Type=domain)

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

777

Security Profiles

l
l

IP Address list (Type=address)
Malware hash list (Type=malware)

For Web Filter profile, it can use category type external resources. Category type external resources file is a URL entries
list in a plain text file.
When a category type external resource is configured in Web Filter profile, it will be treated as a Remote Category. If the
URL in a HTTP/HTTPS request matches the entry inside this external resource file, it will be treated as the Remote
Category and follow the action configured for this category in Web Filter profile.
External resource type category also can be used in ssl-ssh-profile configuration for category-based SSL-Exempt. When
a Remote Category is configured in ssl-ssh-profile SSL-Exempt, if a HTTPS request's URL matches in the Remote
Category’s entry list, HTTPS request with destination for this URL can be exempted from SSL Deep Inspection.

External Resources File Format
External Resources File should follow the following requirements:
l

l
l
l
l

l

The external resource file is a plain text format file and each URL list/IP Address/Domain Name occupies a single
line.
The file is limited to 10M, line is limited 128K (128 x 1024 entries), and the line length limit is 4K characters.
The entries limited also follow table size limitation defined by CMDB per model.
The external resource update period can be set to 1 minute, hourly, daily, weekly, or monthly (43200 min, 30 days).
The external resource type as category (URL list) and domain (Domain Name list) share the category number range
192-221 (total 30 categories).
There's no duplicated entry validation for external resources file (entry inside each file or inside different files).

For URL list (Type=category):
Scheme is optional, and will be truncated if found (http://, https:// is not needed).
Wildcard (*) is supported (from 6.2). It supports the '*' at beginning and ending of URL, and not in the middle of URL as
follows:
+ support *.domain2.com, domain.com.* + not support: domain3.*.com

IDN (International Domain Name) and UTF encoding URL is supported (from 6.2).
IPv4,IPv6 format URL is supported. IPv6 in URL list must in [ ] form.

Configure External Resources from CLI
We can use CLI to configure the external resources files that is located on external HTTP Server. Under Global,
configure the external resource file location and specify the resource type.
Web Filter will use category type external resources as Remote Categories. In the following example, it is configured a
file Ext-Resource-Type-as-Category-1.txt as type as category, it will be treated in Web Filter as Remote Category, the
category name configured as Ext-Resource-Type-as-Category-1 and category-id as 192:
config system external-resource
edit "Ext-Resource-Type-as-Category-1"
set type category <---set category 192
<---set resource "http://172.16.200.66/external-resources/Ext-Resource-Type-as-Category1.txt"
set refresh-rate 1
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next
end

Now in each VDOM, category type external resource can be used in Web Filter as Remote Cateogry. In the example
above, URL list in "Ext-Resource-Type-as-Category-1.txt" file will be treated as remote category (category-id 192).
Configure the action for this remote category in Web Filter profile and apply it in the policy:
config webfilter profile
edit "webfilter"
config ftgd-wf
unset options
config filters
edit 1
set category 2
set action warning
next
......
edit 24
set
set
next
edit 25
set
set
next
edit 26
set
next

category 192
action block

<----

category 221
action warning

category 193

end
end
set log-all-url enable
next
end
config firewall policy
edit 1
set name "WebFilter"
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set logtraffic all
set webfilter-profile "webfilter"
set profile-protocol-options "protocol"
set ssl-ssh-profile "protocols"
set nat enable
next
end
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Configure External Resources from GUI
To configure, edit, or view the Entries for external resources from GUI:
1. Go to Global > Security Fabric > Fabric Connectors:

2. Go to Global > Security Fabric > Fabric Connectors.
3. Click Create New, and in the Threat Feeds section, select FortiGuard Category.
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4. Enter the resource name, URI location of the resource file, resource authentication credential, and Refresh Rate.

5. Click OK.
6. After a few minutes, double-click the Threat Feeds Object you just configured. It is shown in the Edit page.
7. Click View Entries to view the entry list in the external resources file:

8. Go to VDOM > Security Profiles > Web Filter. The configured external resources is shown and configured in each
Web Filter Profile:
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Log Example
If an HTTP/HTTPS request URL is matched in remote category's entry list, it will override its original FortiGuard URL
rating and be treated as a remote category.
Go to VDOM > Log & Report > Web Filter:

CLI Example:
1: date=2019-01-18 time=15:49:15 logid="0316013056" type="utm" subtype="webfilter"
eventtype="ftgd_blk" level="warning" vd="vdom1" eventtime=1547855353 policyid=1
sessionid=88922 srcip=10.1.100.18 srcport=39886 srcintf="port10" srcintfrole="undefined"
dstip=216.58.193.67 dstport=443 dstintf="port9" dstintfrole="undefined" proto=6
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service="HTTPS" hostname="www.fortinet.com" profile="webfilter" action="blocked"
reqtype="direct" url="/" sentbyte=752 rcvdbyte=10098 direction="outgoing" msg="URL belongs
to a denied category in policy" method="domain" cat=192 catdesc="Ext-Resource-Type-asCategory-1"

Remote Category in ssl-ssh-profile category-based SSL-Exempt
Remote category can be applied in ssl-ssh-profile category-based SSL-Exempt.
Go to VDOM > Security Profiles > SSL/SSH Inspection:

HTTPS request URLs matched in this remote category will be exempted from SSL deep inspection.

Log example:
3: date=2019-01-18 time=16:06:21 logid="0345012688" type="utm" subtype="webfilter"
eventtype="ssl-exempt" level="information" vd="vdom1" eventtime=1547856379 policyid=1
sessionid=90080 srcip=10.1.100.18 srcport=39942 srcintf="port10" srcintfrole="undefined"
dstip=216.58.193.67 dstport=443 dstintf="port9" dstintfrole="undefined" proto=6
service="HTTPS" hostname="www.fortinet.com" profile="webfilter" action="passthrough"
reqtype="direct" url="/" sentbyte=517 rcvdbyte=0 direction="outgoing" msg="The SSL session
was exempted." method="domain" cat=192 catdesc="Ext-Resource-Type-as-Category-1"
urlsource="exempt_type_user_cat"

Local Category and Remote Category Priority
Web Filter can have both local category and remote category at the same time. There's no duplication check between
local category URL override and remote category resource file. For example, a URL like www.example.com may be
shown both in remote category entry list and in FortiGate's local category URL override configuration. We recommend
avoiding this scenario since FortiGate does not check for duplicates. However, if a URL is duplicated in both local
category and remote category, it is rated as local category.
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Reliable web filter statistics
FortiOS 6.2 provides command line tools to view the Web Filter statistics report. These command line tools currently fall
into either proxy-based or flow-based Web Filter statistics commands.

Proxy-based Web Filter statistics report
l

The proxy-based Web Filter statistics command line tools are as follows. These commands are available in both
global or per-VDOM command lines.
#diagnose wad filter
<----define the interested objects for output
(global) # diagnose wad ?
console-log
Send WAD log messages to the console.
debug
Debug setting.
stats
Show statistics.
filter
Filter for listing sessions or tunnels. <----use filter to filter-out
interested object and output
kxp
SSL KXP diagnostics.
user
User diagnostics.
memory
WAD memory diagnostics.
restore
Restore configuration defaults.
history
Statistics history.
session
Session diagnostics.
tunnel
Tunnel diagnostics.
webcache
Web cache statistics.
worker
Worker diagnostics.
csvc
Cache service diagnostics.
#diagnose wad stat filter list/clear <----list/clear Web Filter/DLP statistics
report

l

In the example below, there are two VDOMs using proxy-based policies which have Web Filter profiles enabled.
The command line can be used to view the proxy-based Web Filter statistics report.
(global) # diagnose wad
list
clear
src
dst
sport
dport
vd
statistics report
explicit-policy
firewall-policy
drop-unknown-session
negate
protocol

filter ?
Display current filter.
Erase current filter settings.
Source address range to filter by.
Destination address range to filter by.
Source port range to filter by.
Destination port range to filter by.
Virtual Domain Name. <----filter for per-vdom or global
Index of explicit-policy. -1 matches all.
Index of firewall-policy. -1 matches all.
Enable drop message unknown sessions.
Negate the specified filter parameter.
Select protocols to filter by.

FGT_600D-ICAP-NAT (global) # diagnose wad filter vd
<vdom>
Virtual Domain Name.
ALL
all vdoms
root
vdom
vdom1
vdom
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FGT_600D-ICAP-NAT (global) # diagnose wad filter vd root
statistics
Drop_unknown_session is enabled.

<----filter-out root vdom

FGT_600D-ICAP-NAT (global) # diagnose wad stats filter list
filtering of vdom root <----Displayed the WF statistics for root vdom
dlp
= 0
<----Number of Reuqest that DLP Sensor processed;
content-type = 0
<----Number of Reuqest that matching content-type filter;
urls:
examined = 6 <----Number of Request that Proxy Web-Filter(all wad daemons)
examined;
allowed = 3
<----Number of Request that be allowed in the examined requests;
blocked = 0
<----Number of Request that be blocked in the examined requests;
logged = 0
<----Number of Request that be logged in the examined requests;
overridden = 0 <----Number of Request that be overrided to another Web Filter
profile in the examined requests;
FGT_600D-ICAP-NAT (global) # diagnose wad filter vd vdom1
statistics

<----filter-out vdom1

FGT_600D-ICAP-NAT (global) # diagnose wad stats filter list
filtering of vdom vdom1 <----Displayed the WF statistics for vdom1
dlp
= 0
content-type = 0
urls:
examined = 13
allowed = 2
blocked = 9
logged = 8
overridden = 0
FGT_600D-ICAP-NAT (global) # diagnose wad filter vd ALL
FGT_600D-ICAP-NAT (global) # diagnose wad stats filter list
filtering of all accessible vdoms <----global statistics is sum of two VDOMs
dlp
= 0
content-type = 0
urls:
examined = 19
allowed = 5
blocked = 9
logged = 8
overridden = 0

Flow-based Web Filter statistics report
l

The flow-based Web Filter statistics command line tools are as follows. These commands are available in global
command lines only.
(global) # diagnose test application ipsmonitor
IPS Engine Test Usage:
1: Display IPS engine information
2: Toggle IPS engine enable/disable status
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3: Display restart log
4: Clear restart log
5: Toggle bypass status
6: Submit attack characteristics now
10: IPS queue length
11: Clear IPS queue length
12: IPS L7 socket statistics
13: IPS session list
14: IPS NTurbo statistics
15: IPSA statistics
18: Display session info cache
19: Clear session info cache
21: Reload FSA malicious URL database
22: Reload whitelist URL database
24: Display Flow AV statistics
25: Reset Flow AV statistics
27: Display Flow urlfilter statistics
28: Reset Flow urlfilter statistics
29: Display global Flow urlfilter statistics
Statistics
30: Reset global Flow urlfilter statistics
Statistics
96: Toggle IPS engines watchdog timer
97: Start all IPS engines
98: Stop all IPS engines
99: Restart all IPS engines and monitor
l

<----List the Flow Web Filter
<----Reset the Flow Web Filter

In the example below, there are two VDOMs using flow-based policies which have Web Filter profiles enabled. The
command line can be used to view the flow-based Web Filter statistics report.
(global) # diagnose test application ipsmonitor 29
Global URLF states:
request: 14
<----Number of Requests that Flow Web-Filter(all ips engines)
received;
response: 14 <----Number of Response that Flow Web-Filter(all ips engines) sent;
pending: 0
<----Number of Requests that under processing at that moment;
request error: 0
<----Number of Request that have error;
response timeout: 0 <----Number of response that ips engine not been received intime;
blocked: 12
<----Number of Request that Flow Web-Filter blocked;
allowed: 2
<----Number of Request that Flow Web-Filter allowed;

Flow-based web filtering
Flow-based web filtering includes the following options:
l
l
l

Authenticate: requires user authentication for specific website categories.
Warn: displays a warning message for specific website categories, but allows users to continue to the website.
Override: allows users with valid credentials to override their web filter profile.

To enable Authenticate and Warning web filters:
1. Go to Security Profiles > Web Filter.
2. Edit an existing profile, or create a new one.
3. In the FortiGuard category based filter section, right-click on a category.
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4. Select the Authenticate or Warning web filter.
5. Configure other settings as needed.
6. Click Apply.

To allow users to override blocked categories:
1.
2.
3.
4.

Go to Security Profiles > Web Filter.
Edit an existing profile, or create a new one.
Enable Allow users to override blocked categories.
Enter information in the following fields:
l Groups that can override
l Profile can switch to
l Switch applies to
l Switch Duration
5. Configure other settings as needed.
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6. Click Apply.

URL certificate blacklist
As increasing numbers of malware have started to use SSL to attempt to bypass IPS, maintaining a fingerprint-based
certificate blacklist is useful to block botnet communication that relies on SSL.
This feature adds a dynamic package that is distributed by FortiGuard and is part of the Web Filtering service. It is
enabled by default for SSL/SSH profiles, and can be configured using the following CLI commands (highlighted in bold):
config vdom
edit <vdom>
config firewall ssl-ssh-profile
edit "certificate-inspection"
set comment "Read-only SSL handshake inspection profile."
config ssl
set inspect-all disable
end
config https
set ports 443
set status certificate-inspection
set invalid-server-cert block
set untrusted-server-cert allow
set sni-server-cert-check enable
end
config ftps
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set status disable
set invalid-server-cert block
set untrusted-server-cert allow
end
config imaps
set status disable
set invalid-server-cert block
set untrusted-server-cert allow
end
config pop3s
set status disable
set invalid-server-cert block
set untrusted-server-cert allow
end
config smtps
set status disable
set invalid-server-cert block
set untrusted-server-cert allow
end
config ssh
set ports 22
set status disable
set inspect-all disable
set unsupported-version bypass
set ssh-tun-policy-check disable
set ssh-algorithm compatible
end
set block-blacklisted-certificates enable
set caname "Fortinet_CA_SSL"
set ssl-anomalies-log enable
next
edit "deep-inspection"
set comment "Read-only deep inspection profile."
config ssl
set inspect-all disable
end
config https
set ports 443
set status deep-inspection
set client-cert-request bypass
set unsupported-ssl bypass
set invalid-server-cert block
set untrusted-server-cert allow
set sni-server-cert-check enable
end
config ftps
set ports 990
set status deep-inspection
set client-cert-request bypass
set unsupported-ssl bypass
set invalid-server-cert block
set untrusted-server-cert allow
end
config imaps
set ports 993
set status deep-inspection
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set
set
set
set

client-cert-request inspect
unsupported-ssl bypass
invalid-server-cert block
untrusted-server-cert allow

end
config pop3s
set ports 995
set status deep-inspection
set client-cert-request inspect
set unsupported-ssl bypass
set invalid-server-cert block
set untrusted-server-cert allow
end
config smtps
set ports 465
set status deep-inspection
set client-cert-request inspect
set unsupported-ssl bypass
set invalid-server-cert block
set untrusted-server-cert allow
end
config ssh
set ports 22
set status disable
set inspect-all disable
set unsupported-version bypass
set ssh-tun-policy-check disable
set ssh-algorithm compatible
end
set whitelist disable
set block-blacklisted-certificates enable
config ssl-exempt
edit 1
set type fortiguard-category
set fortiguard-category 31
next
edit 2
set type fortiguard-category
set fortiguard-category 33
next
edit 3
set type wildcard-fqdn
set wildcard-fqdn "g-adobe"
next
edit 4
set type wildcard-fqdn
set wildcard-fqdn "g-Adobe Login"
next
edit 5
set type wildcard-fqdn
set wildcard-fqdn "g-android"
next
edit 6
set type wildcard-fqdn
set wildcard-fqdn "g-apple"
next
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edit 7
set
set
next
edit 8
set
set
next
edit 9
set
set
next
edit 10
set
set
next
edit 11
set
set
next
edit 12
set
set
next
edit 13
set
set
next
edit 14
set
set
next
edit 15
set
set
next
edit 16
set
set
next
edit 17
set
set
next
edit 18
set
set
next
edit 19
set
set
next
edit 20
set
set
next
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type wildcard-fqdn
wildcard-fqdn "g-appstore"

type wildcard-fqdn
wildcard-fqdn "g-auth.gfx.ms"

type wildcard-fqdn
wildcard-fqdn "g-citrix"

type wildcard-fqdn
wildcard-fqdn "g-dropbox.com"

type wildcard-fqdn
wildcard-fqdn "g-eease"

type wildcard-fqdn
wildcard-fqdn "g-firefox update server"

type wildcard-fqdn
wildcard-fqdn "g-fortinet"

type wildcard-fqdn
wildcard-fqdn "g-googleapis.com"

type wildcard-fqdn
wildcard-fqdn "g-google-drive"

type wildcard-fqdn
wildcard-fqdn "g-google-play2"

type wildcard-fqdn
wildcard-fqdn "g-google-play3"

type wildcard-fqdn
wildcard-fqdn "g-Gotomeeting"

type wildcard-fqdn
wildcard-fqdn "g-icloud"

type wildcard-fqdn
wildcard-fqdn "g-itunes"
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edit 21
set
set
next
edit 22
set
set
next
edit 23
set
set
next
edit 24
set
set
next
edit 25
set
set
next
edit 26
set
set
next
edit 27
set
set
next
edit 28
set
set
next
edit 29
set
set
next
edit 30
set
set
next
end
set
set
set
set
set
set
set
set

type wildcard-fqdn
wildcard-fqdn "g-microsoft"

type wildcard-fqdn
wildcard-fqdn "g-skype"

type wildcard-fqdn
wildcard-fqdn "g-softwareupdate.vmware.com"

type wildcard-fqdn
wildcard-fqdn "g-verisign"

type wildcard-fqdn
wildcard-fqdn "g-Windows update 2"

type wildcard-fqdn
wildcard-fqdn "g-live.com"

type wildcard-fqdn
wildcard-fqdn "g-google-play"

type wildcard-fqdn
wildcard-fqdn "g-update.microsoft.com"

type wildcard-fqdn
wildcard-fqdn "g-swscan.apple.com"

type wildcard-fqdn
wildcard-fqdn "g-autoupdate.opera.com"

server-cert-mode re-sign
caname "Fortinet_CA_SSL"
untrusted-caname "Fortinet_CA_Untrusted"
ssl-anomalies-log enable
ssl-exemptions-log disable
rpc-over-https disable
mapi-over-https disable
use-ssl-server disable

next
end
next
end
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DNS filter
You can apply DNS category filtering to control user access to web resources. You can customize the default profile, or
create your own to manage network user access and apply it to a firewall policy, or you can add it to a DNS server on a
FortiGate interface.
DNS filtering has the following features:
l
l
l
l
l
l
l

FortiGuard Filtering: filters the DNS request based on the FortiGuard domain rating.
Botnet C&C domain blocking: blocks the DNS request for the known botnet C&C domains.
External dynamic category domain filtering: allows you to define your own domain category.
DNS safe search: enforces Google, Bing, and YouTube safe addresses for parental controls.
Local domain filter: allows you to define your own domain list to block or allow.
External IP block list: allows you to define an IP block list to block resolved IPs that match this list.
DNS translation: maps the resolved result to another IP that you define.

The following sample topology is used in the topics of this section. It includes an internal network and a FortiGate that is
used as a gateway device that all DNS traffic traverses.

Some features of this functionality require a subscription to FortiGuard Web Filtering.

The following topics provide information about DNS filters:
l
l
l
l
l
l
l
l

How to configure and apply a DNS filter profile on page 794
FortiGuard category-based DNS domain filtering on page 796
Botnet C&C domain blocking on page 800
DNS safe search on page 804
Local domain filter on page 805
DNS translation on page 808
Using a FortiGate as a DNS server on page 811
Troubleshooting for DNS filter on page 813
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How to configure and apply a DNS filter profile
To create or configure DNS Filter profile in the GUI:
1. Go to Security Profiles > DNS Filter.
2. You can modify the default DNS Filter and enable the options you want or you can click + at the top right to create a
new DNS Filter.

To create or configure DNS Filter profile in the CLI:
config dnsfilter profile
edit "demo"
set comment ''
config domain-filter
unset domain-filter-table
end
config ftgd-dns
set options error-allow
config filters
edit 2
set category 2
set action monitor
next
edit 7
set category 7
set action block
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next
...
edit 22
set category 0
set action monitor
next
end
end
set
set
set
set
set
set
set
set
set

log-all-domain enable
sdns-ftgd-err-log enable
sdns-domain-log enable
block-action redirect
block-botnet enable
safe-search enable
redirect-portal 93.184.216.34
redirect-portal6 ::
youtube-restrict strict

next
end

After you have created the DNS Filter profile, you can apply it to the policy. DNS filters also support IPv6 policies.

To apply DNS Filter profile to the policy in the GUI:
1. Go to Policy & Objects IPv4 Policy or IPv6 Policy.
2. In the Security Profiles section, enable DNS Filter and select the DNS filter.
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To apply DNS Filter profile to the policy in the CLI:
config firewall policy
edit 1
set name "Demo"
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set inspection-mode proxy
set logtraffic all
set fsso disable
set dnsfilter-profile "demo" <<<====
set profile-protocol-options "default"
set ssl-ssh-profile "deep-inspection"
set nat enable
next
end

FortiGuard category-based DNS domain filtering
The FortiGate must have a FortiGuard Web Filter license to use FortiGuard Category Based
Filter.

You can use the FortiGuard category-based DNS Domain Filter to inspect DNS traffic. This makes use of FortiGuard's
continually updated domain rating database for more reliable protection.

To configure FortiGuard category-based DNS Domain Filter by GUI:
1. Go to Security Profiles > DNS Filter and edit or create a DNS Filter.
2. Enable FortiGuard Category Based Filter.
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3. Select the category and then select Allow, Monitor, or Block for that category.

4. If you select Block, there are two options:
l Redirect Portal IP. If the DNS query domain will be blocked, FortiGate will use portal IP to replace the resolved
IP in DNS response packet. You can use the default portal IP 208.91.112.55 or click Specify to enter another
portal IP.
l Block. Blocked DNS query has no response return and the DNS query client will time out.
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To configure FortiGuard category-based DNS Domain Filter by CLI:
config dnsfilter profile
edit "demo"
set comment ''
config domain-filter
unset domain-filter-table
end
config ftgd-dns
set options error-allow
config filters <<<==== FortiGuard Category Based Filter
edit 2
set category 2
set action monitor
next
edit 7
set category 7
set action monitor
next
...
edit 22
set category 0
set action monitor
next
end
end
set log-all-domain enable
set sdns-ftgd-err-log enable
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set
set
set
set
set
set
set
next
end

sdns-domain-log enable
block-action redirect/block <<<==== You can specify Block or Redirect
block-botnet enable
safe-search enable
redirect-portal 93.184.216.34 <<<==== Specify Redirect portal-IP.
redirect-portal6 ::
youtube-restrict strict

Sample
To see an example of how this works, from your internal network PC, use a command line tool such as dig or nslookup to
do DNS query for some domains, for example:
#dig www.example.com
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 61252
;; Flags: qr rd ra; QUERY: 1; ANSWER: 1; AUTHORITY: 13; ADDITIONAL: 11
;; QUESTION SECTION:
;; www.example.com.

IN

A

;; ANSWER SECTION:
www.example.com.

17164

IN

A

93.184.216.34

;; AUTHORITY SECTION:
com.
com.
com.
com.
com.
com.
com.
com.
com.
com.
com.
com.
com.

20027
20027
20027
20027
20027
20027
20027
20027
20027
20027
20027
20027
20027

IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN

NS
NS
NS
NS
NS
NS
NS
NS
NS
NS
NS
NS
NS

h.gtld-servers.net.
i.gtld-servers.net.
f.gtld-servers.net.
d.gtld-servers.net.
j.gtld-servers.net.
l.gtld-servers.net.
e.gtld-servers.net.
a.gtld-servers.net.
k.gtld-servers.net.
g.gtld-servers.net.
m.gtld-servers.net.
c.gtld-servers.net.
b.gtld-servers.net.

;; ADDITIONAL SECTION:
a.gtld-servers.net.
a.gtld-servers.net.
b.gtld-servers.net.
b.gtld-servers.net.
c.gtld-servers.net.
c.gtld-servers.net.
d.gtld-servers.net.
d.gtld-servers.net.
e.gtld-servers.net.
e.gtld-servers.net.
f.gtld-servers.net.

21999
21999
21997
21997
21987
20929
3340
3340
19334
19334
3340

IN
IN
IN
IN
IN
IN
IN
IN
IN
IN
IN

A
AAAA
A
AAAA
A
AAAA
A
AAAA
A
AAAA
A

192.5.6.30
2001:503:a83e::2:30
192.33.14.30
2001:503:231d::2:30
192.26.92.30
2001:503:83eb::30
192.31.80.30
2001:500:856e::30
192.12.94.30
2001:502:1ca1::30
192.35.51.30

;; Received 509 B
;; Time 2019-04-05 09:39:33 PDT
;; From 172.16.95.16@53(UDP) in 3.8 ms
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To check the DNS Filter log in the GUI:
1. Go to Log & Report > DNS Query to view the DNS traffic that just traverse the FortiGate and the FortiGuard rating
for this domain name.

To check the DNS log in the CLI:
#execute log filter category utm-dns
# execute log display
2 logs found.
2 logs returned.
1: date=2019-04-05 time=09:39:34 logid="1501054802" type="utm" subtype="dns" eventtype="dnsresponse" level="notice" vd="vdom1" eventtime=1554482373 policyid=1 sessionid=50868
srcip=10.1.100.18 srcport=34308 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=17647
qname="www.example.com" qtype="A" qtypeval=1 qclass="IN" ipaddr="93.184.216.34" msg="Domain
is monitored" action="pass" cat=52 catdesc="Information Technology"
2: date=2019-04-05 time=09:39:34 logid="1500054000" type="utm" subtype="dns" eventtype="dnsquery" level="information" vd="vdom1" eventtime=1554482373 policyid=1 sessionid=50868
srcip=10.1.100.18 srcport=34308 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=17647
qname="www.example.com" qtype="A" qtypeval=1 qclass="IN"

Botnet C&C domain blocking
FortiGuard Service continually updates the Botnet C&C domain list (Domain DB). The botnet C&C domain blocking
feature can block the botnet website access at the DNS name resolving stage. This provides additional protection for
your network.

To configure botnet C&C domain blocking in the GUI:
1. Go to Security Profiles > DNS Filter and edit or create a DNS Filter.
2. Enable Redirect botnet C&C requests to Block Portal.
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3. Click the botnet package link to see the latest botnet C&C domain list.

Sample
To see an example of how this works, select a botnet domain from that list. Then from your internal network PC, use a
command line tool such as dig or nslookup to send a DNS query to traverse the FortiGate to see the query blocked as a
botnet domain. For example:
#dig canind.co
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 997
;; Flags: qr rd; QUERY: 1; ANSWER: 1; AUTHORITY: 0; ADDITIONAL: 0
;; QUESTION SECTION:
;; canind.co.

IN

A

;; ANSWER SECTION:
canind.co.
60
IN
blocked, redirect with portal-IP.

A

208.91.112.55

<<<==== botnet domain query

;; Received 43 B
;; Time 2019-04-05 09:55:21 PDT
;; From 172.16.95.16@53(UDP) in 0.3 ms
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To check the DNS Filter log in the GUI:
1. Go to Log & Report > DNS Query to view the DNS query blocked as a botnet domain.

To check the DNS Filter log in the CLI:
(vdom1) # execute log filter category utm-dns
(vdom1) # execute log display
2 logs found.
2 logs returned.
1: date=2019-04-04 time=16:43:59 logid="1501054601" type="utm" subtype="dns" eventtype="dnsresponse" level="warning" vd="vdom1" eventtime=1554421439 policyid=1 sessionid=14135
srcip=10.1.100.18 srcport=57447 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=24339
qname="canind.co" qtype="A" qtypeval=1 qclass="IN" msg="Domain was blocked by dns botnet
C&C" action="redirect" botnetdomain="canind.co"
2: date=2019-04-04 time=16:43:59 logid="1500054000" type="utm" subtype="dns" eventtype="dnsquery" level="information" vd="vdom1" eventtime=1554421439 policyid=1 sessionid=14135
srcip=10.1.100.18 srcport=57447 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=24339
qname="canind.co" qtype="A" qtypeval=1 qclass="IN"

Botnet C&C IPDB blocking
FortiGate also maintains a botnet C&C IP address database (botnet IPDB). If a DNS query response IP address
(resolved IP address) matches an entry inside the botnet IPDB, this DNS query is also blocked by DNS Filter botnet C&C
blocking.

To view the botnet IPDB list in the CLI:
(global) # diagnose sys botnet list 9000 10
9000. proto=TCP ip=103.228.28.166, port=80, rule_id=7630075, name_id=3, hits=0
9001. proto=TCP ip=5.9.32.166, port=481, rule_id=4146631, name_id=7, hits=0
9002. proto=TCP ip=91.89.44.166, port=80, rule_id=48, name_id=96, hits=0
9003. proto=TCP ip=46.211.46.166, port=80, rule_id=48, name_id=96, hits=0
9004. proto=TCP ip=77.52.52.166, port=80, rule_id=48, name_id=96, hits=0
9005. proto=TCP ip=98.25.53.166, port=80, rule_id=48, name_id=96, hits=0
9006. proto=TCP ip=70.120.67.166, port=80, rule_id=48, name_id=96, hits=0
9007. proto=TCP ip=85.253.77.166, port=80, rule_id=48, name_id=96, hits=0
9008. proto=TCP ip=193.106.81.166, port=80, rule_id=48, name_id=96, hits=0
9009. proto=TCP ip=58.13.84.166, port=80, rule_id=48, name_id=96, hits=0
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To see an example of how DNS Filter botnet C&C IPDB blocking works, select an IP address from the IPDB list and use
Internet reverse lookup service to find its corresponding domain name. Then from your internal network PC, use a
command line tool such as dig or nslookup to query this domain and see that it's blocked by DNS Filter botnet C&C
blocking. For example:
# dig cpe-98-25-53-166.sc.res.rr.com
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 35135
;; Flags: qr rd; QUERY: 1; ANSWER: 1; AUTHORITY: 0; ADDITIONAL: 0
;; QUESTION SECTION:
;; cpe-98-25-53-166.sc.res.rr.com.

IN

A

;; ANSWER SECTION:
cpe-98-25-53-166.sc.res.rr.com. 60
IN
A
208.91.112.55 <<<==== Since
resolved IP address match the botnet IPDB, dns query blocked with redirect portal IP.
;; Received 64 B
;; Time 2019-04-05 11:06:47 PDT
;; From 172.16.95.16@53(UDP) in 0.6 ms

To check the DNS Filter log in the GUI:
1. Go to Log & Report > DNS Query to view the DNS query blocked by botnet C&C IPDB blocking.

To check the DNS Filter log in the CLI:
1: date=2019-04-05 time=11:06:48 logid="1501054600" type="utm" subtype="dns" eventtype="dnsresponse" level="warning" vd="vdom1" eventtime=1554487606 policyid=1 sessionid=55232
srcip=10.1.100.18 srcport=60510 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=16265
qname="cpe-98-25-53-166.sc.res.rr.com" qtype="A" qtypeval=1 qclass="IN"
ipaddr="93.184.216.34" msg="Domain was blocked by dns botnet C&C" action="redirect"
botnetip=98.25.53.166
2: date=2019-04-05 time=11:06:48 logid="1500054000" type="utm" subtype="dns" eventtype="dnsquery" level="information" vd="vdom1" eventtime=1554487606 policyid=1 sessionid=55232
srcip=10.1.100.18 srcport=60510 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=16265
qname="cpe-98-25-53-166.sc.res.rr.com" qtype="A" qtypeval=1 qclass="IN"

To check botnet activity:
1. Go to Dashboard > Status and see the Botnet Activity widget.
If you cannot find the Botnet Activity widget, click the Settings button at the bottom right, select Add Widget, and add
the Botnet Activity widget.
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DNS safe search
Enable DNS Filter safe search so that FortiGate responds with the search engine's children and school safe domain or
IP address. Users might not be aware of this filter. Explicit contents are filtered by the search engine itself. This feature
isn’t 100% accurate but it can help you avoid explicit and inappropriate search results.
This feature currently supports Google, Bing, and YouTube.

To configure DNS Filter Safe Search on GUI:
1. Go to Security Profiles > DNS Filter and edit or create a DNS Filter.
2. Enable Enforce 'Safe search' on Google, Bing, YouTube.
3. For Restrict YouTube Access, select Strict or Moderate.

To configure DNS Filter Safe Search on CLI:
config dnsfilter profile
edit "demo"
config ftgd-dns
set options error-allow
config filters
edit 2
set category 2
next
...
end
end
set log-all-domain enable
set block-botnet enable
set safe-search enable <<<==== DNS Filter Safe Search option
next
end

Sample
To see an example of how this works, enable this option. Then from your internal network PC, use a command line tool
such as dig or nslookup to do a DNS query on www.bing.com. For example:

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

804

Security Profiles

# dig www.bing.com
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 46568
;; Flags: qr rd ra; QUERY: 1; ANSWER: 2; AUTHORITY: 0; ADDITIONAL: 0
;; QUESTION SECTION:
;; www.bing.com.
;; ANSWER SECTION:
www.bing.com.
strict.bing.com.

103
103

IN

A

IN
IN

CNAME
A

strict.bing.com.
204.79.197.220

<<<====

;; Received 67 B
;; Time 2019-04-05 14:34:52 PDT
;; From 172.16.95.16@53(UDP) in 196.0 ms

The DNS query for www.bing.com returns with a CNAME strict.bing.com, and A record for the CNAME. The user's web
browser then connects to this address with the same search engine UI but any explicit content search is filtered out.
Check the DNS Filter log for the message DNS Safe Search enforced.

To check the DNS Filter Safe Search log in the CLI:
1: date=2019-04-05 time=14:34:53 logid="1501054804" type="utm" subtype="dns" eventtype="dnsresponse" level="notice" vd="vdom1" eventtime=1554500093 policyid=1 sessionid=65955
srcip=10.1.100.18 srcport=36575 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=59573
qname="www.bing.com" qtype="A" qtypeval=1 qclass="IN" ipaddr="204.79.197.220" msg="DNS Safe
Search enforced" action="pass" sscname="strict.bing.com" cat=41 catdesc="Search Engines and
Portals"
2: date=2019-04-05 time=14:34:53 logid="1500054000" type="utm" subtype="dns" eventtype="dnsquery" level="information" vd="vdom1" eventtime=1554500092 policyid=1 sessionid=65955
srcip=10.1.100.18 srcport=36575 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=59573
qname="www.bing.com" qtype="A" qtypeval=1 qclass="IN"

Additional information
For each search engine's safe search specifications, see its specification page:
l
l
l

https://help.bing.microsoft.com/#apex/18/en-US/10003/0
https://support.google.com/websearch/answer/510?co=GENIE.Platform%3DDesktop&hl=en
https://support.google.com/youtube/answer/174084?co=GENIE.Platform%3DDesktop&hl=en

Local domain filter
In addition to FortiGuard's category-based domain filter, you can also can define your own local static domain filter to
allow or block specific domains.
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To configure DNS local domain filter on GUI:
1. Go to Security Profiles > DNS Filter and edit or create a DNS Filter.
2. In the Static Domain Filter section, enable Domain Filter.
3. Click Create New to create your local domain filter entries.

To configure DNS local domain filter on CLI:
config dnsfilter domain-filter
edit 1
set name "demo"
set comment ''
config entries
edit 1
set domain "www.fortinet.com"
set type simple
set action allow
set status enable
next
edit 2
set domain "*.example.com"
set type wildcard
set action block
set status enable
next
edit 3
set domain "google"
set type regex
set action monitor
set status enable
next
end
next
end
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Wildcard entries are converted to regular expressions by FortiOS. As a result of this
conversion, wildcards will match any suffix, as long as there is a word boundary following the
search term.
For example:
config entries
edit 1
set domain "*.host"
set type wildcard
next
end

will match wp36.host and wp36.host.pressdns.com, but not
wp36.host123.pressdnds.com.
To avoid this, use an explicit regular expression search string:
config entries
edit 1
set domain "^.*\\.host$"
set type regexp
next
end

To check the DNS local domain filter log in the GUI:
1. Go to Log & Report > DNS Query to view the DNS query log.

Since the local domain list "google" action is Monitor, it's blocked by FortiGuard category-based domain filter.

To check the DNS local domain filter log in the CLI:
7: date=2019-04-05 time=15:37:06 logid="1501054803" type="utm" subtype="dns" eventtype="dnsresponse" level="warning" vd="vdom1" eventtime=1554503826 policyid=1 sessionid=69132
srcip=10.1.100.18 srcport=49832 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=4612
qname="www.google.com" qtype="A" qtypeval=1 qclass="IN" ipaddr="208.91.112.55" msg="Domain
belongs to a denied category in policy" action="redirect" cat=41 catdesc="Search Engines and
Portals"
8: date=2019-04-05 time=15:37:06 logid="1500054000" type="utm" subtype="dns" eventtype="dnsquery" level="information" vd="vdom1" eventtime=1554503826 policyid=1 sessionid=69132
srcip=10.1.100.18 srcport=49832 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=4612
qname="www.google.com" qtype="A" qtypeval=1 qclass="IN"
9: date=2019-04-05 time=15:36:59 logid="1501054400" type="utm" subtype="dns" eventtype="dnsresponse" level="warning" vd="vdom1" eventtime=1554503818 policyid=1 sessionid=69121
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srcip=10.1.100.18 srcport=40659 srcintf="port10" srcintfrole="undefined" dstip=172.16.95.16
dstport=53 dstintf="port9" dstintfrole="undefined" proto=17 profile="demo" xid=24730
qname="www.example.com" qtype="A" qtypeval=1 qclass="IN" msg="Domain was blocked because it
is in the domain-filter list" action="redirect" domainfilteridx=1 domainfilterlist="demo"
10: date=2019-04-05 time=15:36:59 logid="1500054000" type="utm" subtype="dns"
eventtype="dns-query" level="information" vd="vdom1" eventtime=1554503818 policyid=1
sessionid=69121 srcip=10.1.100.18 srcport=40659 srcintf="port10" srcintfrole="undefined"
dstip=172.16.95.16 dstport=53 dstintf="port9" dstintfrole="undefined" proto=17
profile="demo" xid=24730 qname="www.example.com" qtype="A" qtypeval=1 qclass="IN"
11: date=2019-04-05 time=15:36:51 logid="1501054401" type="utm" subtype="dns"
eventtype="dns-response" level="information" vd="vdom1" eventtime=1554503810 policyid=1
sessionid=69118 srcip=10.1.100.18 srcport=33461 srcintf="port10" srcintfrole="undefined"
dstip=172.16.95.16 dstport=53 dstintf="port9" dstintfrole="undefined" proto=17
profile="demo" xid=53801 qname="www.fortinet.com" qtype="A" qtypeval=1 qclass="IN"
ipaddr="13.56.55.78, 54.183.57.55" msg="Domain was allowed because it is in the domainfilter list" action="pass" domainfilteridx=1 domainfilterlist="demo"
12: date=2019-04-05 time=15:36:51 logid="1500054000" type="utm" subtype="dns"
eventtype="dns-query" level="information" vd="vdom1" eventtime=1554503810 policyid=1
sessionid=69118 srcip=10.1.100.18 srcport=33461 srcintf="port10" srcintfrole="undefined"
dstip=172.16.95.16 dstport=53 dstintf="port9" dstintfrole="undefined" proto=17
profile="demo" xid=53801 qname="www.fortinet.com" qtype="A" qtypeval=1 qclass="IN"

Sequence and priority
In DNS Filter, local domain filter has a higher priority than FortiGuard category-based domain filter.
A DNS query is scanned and matched with local domain filter first. If an entry matches and the local filter entry's action is
block, then that DNS query is blocked or redirected.
If local domain filter list has no match, then the FortiGuard category-based domain filter is used. If a DNS query domain
name rating belongs to the block category, this query is blocked or redirected. If the FortiGuard category-based filter has
no match, then the original resolved IP address is returned to the client DNS resolver.
The local domain filter action can be Block, Allow, or Monitor. If the local domain filter action is Allow and an entry
matches, it will skip the FortiGuard category-based domain filter and directly return to client DNS resolver. If the local
domain filter action is Monitor and an entry matches, it will go to FortiGuard category-based domain filter scanning and
matching.

DNS translation
Using this feature, you can translate a DNS resolved IP address to another IP address you specify on a per-policy basis.
For example, website A has a public address 1.2.3.4. However, when your internal network users visit this website, you
want them to connect to an internal host, say, 192.168.3.4. In this case, you can use DNS translation to translate the
DNS resolved address 1.2.3.4 to 192.168.3.4. Reverse use of DNS translation is also applicable, for example, if you
want public DNS query of your internal server to get a public IP address, then you can translate a DNS resolved private
IP to a public IP address.
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Example
This example configuration forces the DNS Filter profile to translate 93.184.216.34 (www.example.com) to 192.168.3.4.
When internal network users do a DNS query for www.example.com, they do not get the original www.example.com IP
address of 93.184.216.34. Instead, it is replaced with 192.168.3.4.

To configure DNS translation in the GUI:
1. Go to Security Profiles > DNS Filter and edit or create a DNS Filter profile.
2. Enable DNS Translation and click Create New.
3. Enter the Original Destination (the domain's original IP address), the Translated Destination IP address, and the
Network Mask, and set Status to Enable.

4. Click OK.

5. Click OK to create or edit the DNS profile.

To configure DNS translation in the CLI:
config dnsfilter profile
edit "demo"
set comment ''
...
config dns-translation
edit 1
set src 93.184.216.34
set dst 192.168.3.4
set netmask 255.255.255.255
next
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end
set redirect-portal 0.0.0.0
set redirect-portal6 ::
set youtube-restrict strict
next
end

To check DNS translation using a command line tool before DNS translation:
# dig www.example.com
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 27030
;; Flags: qr rd ra; QUERY: 1; ANSWER: 1; AUTHORITY: 2; ADDITIONAL: 0
;; QUESTION SECTION:
;; www.example.com.

IN

A

;; ANSWER SECTION:
www.example.com.

33946

IN

A

93.184.216.34

;; AUTHORITY SECTION:
example.com.
example.com.

18578
18578

IN
IN

NS
NS

b.iana-servers.net.
a.iana-servers.net.

;; Received 97 B
;; Time 2019-04-08 10:47:26 PDT
;; From 172.16.95.16@53(UDP) in 0.5 ms

To check DNS translation using a command line tool after DNS translation:
# dig www.example.com
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 62060
;; Flags: qr rd ra; QUERY: 1; ANSWER: 1; AUTHORITY: 2; ADDITIONAL: 0
;; QUESTION SECTION:
;; www.example.com.
;; ANSWER SECTION:
www.example.com.
into 192.168.3.4
;; AUTHORITY SECTION:
example.com.
example.com.

IN

A

32491

IN

A

192.168.3.4

17123
17123

IN
IN

NS
NS

b.iana-servers.net.
a.iana-servers.net.

<<<==== resolved IP translated

;; Received 97 B
;; Time 2019-04-08 11:11:41 PDT
;; From 172.16.95.16@53(UDP) in 0.5 ms

DNS translation network mask
The following is an example of DNS translation and result:
config dns-translation
edit 1
set src 93.184.216.34
set dst 1.2.3.4
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set netmask 255.255.224.0
next
end
# dig www.example.com
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 6736
;; Flags: qr rd ra; QUERY: 1; ANSWER: 1; AUTHORITY: 2; ADDITIONAL: 0
;; QUESTION SECTION:
;; www.example.com.

IN

A

;; ANSWER SECTION:
www.example.com.

29322

IN

A

1.2.24.34

;; AUTHORITY SECTION:
example.com.
example.com.

13954
13954

IN
IN

NS
NS

a.iana-servers.net.
b.iana-servers.net.

;; Received 97 B
;; Time 2019-04-08 12:04:30 PDT
;; From 172.16.95.16@53(UDP) in 2.0 ms
1) AND src(Orginal IP) with negative netmask (93.184.216.34 & ~255.255.224.0)
01011101.10111000.11011000.00100010 93.184.216.34 <-- ip
00000000.00000000.00011111.11111111 ~255.255.224.0 <-- ~netmask
-------------------------------------------------------- &
00000000.00000000.00011000.00100010 0.0.24.34 <- right bits

2) AND dst(Translated IP) with netmask
00000001.00000010.00000011.00000100 1.2.3.4 <- dst
11111111.11111111.11100000.00000000 255.255.224.0 <- netmask
-------------------------------------------------------- &
00000001.00000010.00000000.00000000 1.2.0.0 <- left bits
3) Final step 2 bitwise-OR 3:
00000000.00000000.00011000.00100010 0.0.24.34
00000001.00000010.00000000.00000000 1.2.0.0
-------------------------------------------------------- |
00000001.00000010.00011000.00100010 1.2.24.34

Using a FortiGate as a DNS server
You can configure and use FortiGate as a DNS server in your network. When you enable DNS Service on a specific
interface, FortiGate will listen for DNS Service on that interface.
Depending on the configuration, DNS Service on FortiGate can work in three modes: Recursive, Non-Recursive, or
Forward to System DNS (server). For details on how to configure DNS Service on FortiGate, see the FortiGate System
Configuration Guide.
You can apply a DNS Filter profile to Recursive Mode and Forward to System DNS Mode. This is the same as FortiGate
working as a transparent DNS Proxy for DNS relay traffic.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

811

Security Profiles

To configure DNS Service on FortiGate using GUI:
1. Go to Network > DNS Servers.
2. In the DNS Service on Interface, click Create New and select an Interface.

The Recursive and Non-Recursive Mode is available only after you configure the DNS database.

To configure DNS Service on FortiGate using CLI:
config system dns-server
edit "port10"
<<<==== Enable DNS Serive on Interface
set mode forward-only
set dnsfilter-profile "demo"
<<<==== apply DNS Filter Profile for the service
next
end

Sample configuration
In this example, FortiGate port 10 is enabled as a DNS Service with the DNS Filter profile "demo". Suppose port 10 has
an IP address 10.1.100.5 and DNS Filter profile "demo" is set to block category 52 (Information Technology), then from
your internal network PC, use a command line tool such as dig or nslookup to do a DNS query. For example:
# dig @10.1.100.5 www.fortinet.com
<<<====Specify FortiGate interface address as DNS
Server
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 52809
;; Flags: qr rd; QUERY: 1; ANSWER: 1; AUTHORITY: 0; ADDITIONAL: 0
;; QUESTION SECTION:
;; www.fortinet.com.

IN

A

;; ANSWER SECTION:
www.fortinet.com.
60
IN
A
208.91.112.55
<<<==== DNS Filter profile
will filter the relay DNS traffic based on profile configuration. It blocked with redirect
portal IP
;; Received 50 B
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;; Time 2019-04-08 14:36:34 PDT
;; From 10.1.100.5@53(UDP) in 13.6 ms

Troubleshooting for DNS filter
If you have trouble with the DNS Filter profile in your policy, start with the following troubleshooting steps:
l
l
l

Check the connection between FortiGate and FortiGuard DNS rating server (SDNS server).
Check that FortiGate has a valid FortiGuard Web Filter license.
Check the FortiGate DNS Filter configuration.

Troubleshooting connection between FortiGate and FortiGuard SDNS server
Ensure FortiGate can connect to the FortiGuard SDNS server. By default, FortiGate uses UDP port 53 to connect to the
SDNS server.

To check the connection between FortiGate and the SDNS server in the CLI:
1. In the CLI Console, run the command diagnose test application dnsproxy 3 to find the FortiGuard
SDNS server.
worker idx: 0
vdom: root, index=0, is master, vdom dns is disabled, mip-169.254.0.1 dns_log=1
dns64 is disabled
vdom: vdom1, index=1, is master, vdom dns is enabled, mip-169.254.0.1 dns_log=1
dns64 is disabled
dns-server:208.91.112.220:53 tz=-480 req=0 to=0 res=0 rt=0 secure=1 ready=1 timer=0
probe=0 failure=0 last_failed=0
dns-server:208.91.112.53:53 tz=0 req=0 to=0 res=0 rt=0 secure=0 ready=1 timer=0 probe=0
failure=0 last_failed=0
dns-server:208.91.112.52:53 tz=0 req=0 to=0 res=0 rt=0 secure=0 ready=1 timer=0 probe=0
failure=0 last_failed=0
dns-server:62.209.40.75:53 tz=60 req=0 to=0 res=0 rt=0 secure=1 ready=1 timer=0 probe=0
failure=0 last_failed=0
dns-server:209.222.147.38:53 tz=-300 req=0 to=0 res=0 rt=0 secure=1 ready=1 timer=0
probe=0 failure=0 last_failed=0
dns-server:173.243.138.221:53 tz=-480 req=0 to=0 res=0 rt=0 secure=1 ready=1 timer=0
probe=0 failure=0 last_failed=0
dns-server:45.75.200.89:53 tz=0 req=0 to=0 res=0 rt=0 secure=1 ready=1 timer=0 probe=0
failure=0 last_failed=0
DNS_CACHE: hash-size=2048, ttl=1800, min-ttl=60, max-num=5000
DNS FD: udp_s=13 udp_c=16:17 ha_c=21 unix_s=22, unix_nb_s=23, unix_nc_s=24
v6_udp_s=12, v6_udp_c=19:20, snmp=25, redir=14
DNS FD: tcp_s=27, tcp_s6=26, redir=28
FQDN: hash_size=1024, current_query=1024
DNS_DB: response_buf_sz=4096
LICENSE: expiry=2029-08-21, expired=0, type=2
FDG_SERVER:208.91.112.220:53
FGD_CATEGORY_VERSION:8
SERVER_LDB: gid=6f00, tz=-420, error_allow=0
FGD_REDIR:208.91.112.55

2. Check the FDG_SERVER line. The SDNS server IP address might be different depending on location. For this
example, it is:
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FDG_SERVER:208.91.112.220:53

3. In the CLI Console under the management VDOM, run the command execute ping 208.91.112.220 to check
the communication between the FortiGate and the SDNS server.
4. Optionally, you can also check the communication using a PC on the internal network.
a. Disable the DNS Filter profile so that it does not affect your connection check.
b. Ping your ISP or a public DNS service provides's DNS server, for example, Google's public DNS server of
8.8.8.8:
#dig @8.8.8.8 www.fortinet.com

Or specify the SDNS server as DNS server:
#dig @208.91.112.220 www.fortinet.com

c. Check that you can get domain www.fortinet.com A record from the DNS server which shows that UDP port 53
connection path is not blocked.
#dig @8.8.8.8 www.fortinet.com
;; ->>HEADER<<- opcode: QUERY; status: NOERROR; id: 35121
;; Flags: qr rd ra; QUERY: 1; ANSWER: 3; AUTHORITY: 0; ADDITIONAL: 0
;; QUESTION SECTION:
;; www.fortinet.com.

IN

A

;; ANSWER SECTION:
www.fortinet.com.
289
IN
CNAME
fortinet-prod4-858839915.us-west1.elb.amazonaws.com.
fortinet-prod4-858839915.us-west-1.elb.amazonaws.com. 51
IN
A
52.8.142.247
fortinet-prod4-858839915.us-west-1.elb.amazonaws.com. 51
IN
A
13.56.55.78
;; Received 129 B
;; Time 2019-04-29 14:13:18 PDT
;; From 8.8.8.8@53(UDP) in 13.2 ms

Checking FortiGuard DNS Rating Service license
The FortiGuard DNS Rating Service shares the license with FortiGuard Web Filter so you must have a valid Web Filter
license for the DNS Rating Service to work. While the license is shared, the DNS Rating Service uses a separate
connection mechanism from the Web Filter Rating.

To check the DNS Rating Service license in the CLI:
1. In the CLI Console, run the command diagnose test application dnsproxy 3.
2. Look for the LICENSE line and check that the license has not expired, for example:
LICENSE: expiry=2029-08-21, expired=0, type=2

3. Check the dns-server lines. Some dns-server lines show secure=1 ready=1. These lines show the
functioning SDNS servers. For example:
dns-server:208.91.112.220:53 tz=-480 req=7 to=0 res=7 rt=1 secure=1 ready=1 timer=0
probe=0 failure=0 last_failed=0
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Checking FortiGate DNS Filter profile configuration
To check the FortiGate DNS Filter profile configuration:
1. Create a local domain filter and set the Action to Redirect to Block Portal.
See Local domain filter on page 805.
2. Apply this DNS Filter profile to the policy.
3. From the client PC, DNS query this domain.
If you get the profile's redirected portal address, that shows that the DNS Filter profile works as expected.

More troubleshooting steps
To reload the DNS proxy in the CLI:
(global)#diagnose test application dnsproxy 99

To debug DNS proxy details:
These commands might create more output in your console.
#diagnose debug application dnsproxy -1
#diagnose debug enable/disable

DNS proxy command reference
Use the following diagnose test application dnsproxy command line options to check DNS proxy status and
help with troubleshooting.
(global) # diagnose test application dnsproxy ?
worker idx: 0
1. Clear DNS cache
2. Show stats
3. Dump DNS setting
4. Reload FQDN
5. Requery FQDN
6. Dump FQDN
7. Dump DNS cache
8. Dump DNS DB
9. Reload DNS DB
10. Dump secure DNS policy/profile
11. Dump Botnet domain
12. Reload Secure DNS setting
13. Show Hostname cache
14. Clear Hostname cache
15. Show SDNS rating cache
16. Clear SDNS rating cache
17. DNS debug bit mask
99. Restart dnsproxy worker
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Application control
FortiGates can recognize network traffic generated by a large number of applications. Application control sensors
specify what action to take with the application traffic. Application control uses IPS protocol decoders that can analyze
network traffic to detect application traffic, even if the traffic uses non-standard ports or protocols. Application control
supports traffic detection using the HTTP protocol (versions 1.0, 1.1, and 2.0).

FortiOS includes three preloaded application sensors:
l
l
l

default (monitors all applications)
wifi-default (default configuration for offloading WiFi traffic)
block-high-risk

You can customize these sensors, or you can create your own to log and manage the applications on your network.
Once configured, you can add the application sensor to a firewall policy.

This functionality requires a subscription to FortiGuard Application Control.

The following topics provide information about application control:
l
l
l

Basic category filters and overrides on page 816
Port enforcement check on page 820
Protocol enforcement on page 821

Basic category filters and overrides
Once you have created an application sensor, you can define the applications that you want to control. You can add
applications and filters using categories, application overrides, and/or filter overrides.
l
l
l

Categories: Choose groups of signatures based on a category type.
Application overrides: Choose individual applications.
Filter overrides: Select groups of applications and override the application signature settings for them.

Categories
Categories allow you to choose groups of signatures based on a category type. Applications belonging to the category
trigger the action that is set for the category.
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To set category filters in the CLI:
config application list
edit {id}
config entries
edit 1
set category <id>
ID
Select Category ID
2
P2P
3
VoIP
5
Video/Audio
6
Proxy
7
Remote.Access
8
Game
12
General.Interest
15
Network.Service
17
Update
21
Email
22
Storage.Backup
23
Social.Media
25
Web.Client
26
Industrial
28
Collaboration
29
Business
30
Cloud.IT
31
Mobile
set action {pass | block | reset}
pass
Pass or allow matching traffic.
block
Block or drop matching traffic.
reset
Reset sessions for matching traffic.
set log {enable | disable}
next
end
next
end

To set category filters in the GUI:
1. Go to Security Profiles > Application Control.
2. Under Categories, left click the icon next to the category name to view a dropdown of actions:
l Allow
l Monitor
l Block
l Quarantine
l View signatures
3. Select OK.
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Application and filter overrides
Override type

Setting

Application

Type: Choose Application for application overrides.
Action: Can be set to Monitor/Allow/Block/Quarantine.
Application: Multiple app signatures can be added for one entry. A slide-in
presenting an application list will be shown to select specific app signatures, and
the search box can be used to filter matched signatures.

Filter

Type: Choose Filter for filter overrides.
Action: Can be set to Monitor/Allow/Block/Quarantine.
Filter: Filters can be selected by behavior, application category, technology,
popularity, protocol, risk, or vendor subtypes.
Search box: Can be used to determine if the input signature is included in
selected filters, where matched applications are shown at the bottom.

To set overrides in the CLI:
config application list
edit {id}
config entries
edit 1
set protocols <0-47>
#network protocol ID
set risk <id>
*level
Risk of allowing traffic from this application to occur (1 5; Low, Elevated, Medium, High, and Critical).
set vendor <0-25>
#vendor ID
set technology <id>
All
All
0
Network-Protocol
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set

set
set

set

1
Browser-Based
2
Client-Server
4
Peer-to-Peer
behavior <id>
All
All
2
Botnet
3
Evasive
5
Excessive-Bandwidth
6
Tunneling
9
Cloud
popularity <1-5>
#Popularity level 1-5
action {pass | block | reset}
pass
Pass or allow matching traffic.
block
Block or drop matching traffic.
reset
Reset sessions for matching traffic.
log {enable | disable}

next
end
next
end

To set overrides in the GUI:
1. Go to Security Profiles > Application Control.
2. Under the Application and Filter Overrides table, click Create New.
3. To add individual applications:
a. Select Application as the Type.
b. Choose an action to be associated with the application.
c. Click the + button in the Application field and choose the specific applications from the list where app signatures
are displayed. Multiple applications may be selected.

d. Click OK.
4. To add advanced filters:
a. Create another entry in the Application and Filter Overrides table.
b. Select Filter as the Type.
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c. Select Cloud under the behavior section from the Select Entries list.
Matched signatures are shown along the bottom.

d. Click OK.

Port enforcement check
Most networking applications run on specific ports. For example, SSH runs on port 22, and Facebook runs on ports 80
and 443.
If the default network service is enabled in the Application Control profile, a port enforcement check is done at the
application profile level, and any detected application signatures running on the non-standard TCP/IP port are blocked.
This means that each application allowed by the app control sensor is only run on its default port.

To set port enforcement check in the CLI:
config application list
edit "default_port"
set enforce-default-app-port {enable | disable}
disable
Disable default application port enforcement.
enable
Enable default application port enforcement.
config entries
edit 1
set application 15896
set action pass
next
end
next
end

For example, when applying the above appctrl sensor, FTP traffic with the standard port (port 21) is allowed, while the
non-standard port (port 2121) is blocked.
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Protocol enforcement
Protocol enforcement allows you to configure networking services (e.g. FTP, HTTP, HTTPS) on known ports (e.g. 21,
80, 443). For protocols which are not whitelisted under select ports, the IPS engine performs the violation action to block,
allow, or monitor that traffic.
This feature can be used in the following scenarios::
l

l

When one protocol dissector confirms the service of network traffic, protocol enforcement can check whether the
confirmed service is whitelisted under the server port. If it is not whitelisted, the traffic is considered a violation and
IPS can take the action specified in the configuration (block or monitor it).
When there is no confirmed service for the network traffic, the traffic is considered a service violation if
IPS dissectors rule out all of the services enforced under its server port.

In an applicable profile, a default-network-service list can be created to associate well known ports with accepted
services.

To setup protocol enforcement in the CLI:
config application list
edit "protocol-GUI"
set other-application-log enable
set control-default-network-services {enable | disable}
# Enable/Disable enforcement
of protocols over select ports
config default-network-services
# Default network service
entries
edit 1
set port 80
# Port number, enter an integer value from <0>
to <65535>
set services http
# Network protocols: http, ssh, ftp, dns,
smtp, pop3, imap, snmp, nntp, and https
next
edit 2
set port 53
set services dns
set violation-action {pass | monitor | block}
# Pass, Log, or block when
non-DNS traffic run over port 53
next
end
next
end

To setup protocol enforcement in the GUI:
1. Go to Security Profiles > Application Control.
2. Create a new application sensor or edit an existing one.
3. Enable Network Protocol Enforcement.
Enforcement entries can be created, edited, or deleted to configure network services on certain ports and determine
the violation action.
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4. Click Create New in the Network Protocol Enforcement table.

5. In the New Default Network Service pane:
a. Enter a Port number.
b. Select Enforced protocols.
c. Choose the Violation action.
d. Click OK.
6. Click OK.

Intrusion prevention
With the FortiOS intrusion prevention system (IPS), you can detect and block network-based attacks. You can configure
IPS sensors based on IPS signatures, IPS filters, outgoing connections to botnet sites, and rate-based signatures.
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FortiOS includes eight preloaded IPS sensors:
l
l
l
l
l
l
l
l

all_default
all_default_pass
default
high_security
protect_client
protect_email_server
protect_http_server
wifi-default

You can customize these sensors, or you can create your own and apply it to a firewall policy.

This functionality requires a subscription to FortiGuard IPS Service.

The following topic provides information about IPS sensors:
l

Botnet C&C IP blocking on page 823

Botnet C&C IP blocking
The Botnet C&C section consolidates multiple botnet options in the IPS profile. This allows you to enable botnet blocking
across all traffic that matches the policy by configuring one setting in the GUI, or by the scan-botnet-connections
option in the CLI.

To configure botnet C&C IP blocking using the GUI:
1.
2.
3.
4.

Go to Security Profiles > Intrusion Prevention.
Edit an existing sensor, or create a new one.
Navigate to the Botnet C&C section.
For Scan Outgoing Connections to Botnet Sites, click Block or Monitor.

5. Configure other settings as needed.
6. Click Apply. Botnet C&C is now enabled for the sensor.
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7. Add this sensor to the firewall policy.
The IPS engine will scan outgoing connections to botnet sites. If you access a botnet IP, an IPS log is generated for
this attack.
8. Go to Log & Report > Intrusion Prevention to view the log.

To configure botnet C&C IP blocking using the CLI:
config ips sensor
edit "Demo"
set scan-botnet-connections <disable | block | monitor>
next
end

The scan-botnet-connections option is no longer available in the following CLI
commands:
l config firewall policy
l config firewall interface-policy
l config firewall proxy-policy
l config firewall sniffer

Botnet IPs and domains lists
To view botnet IPs and domains lists using the GUI:
1. Go to System > FortiGuard . Botnet IPs and Botnet Domains are visible in the Intrusion Prevention section.
2. Click View List for more details.
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Botnet C&C domain blocking
To block connections to botnet domains using the GUI:
1. Go to Security Profiles > DNS Filter.
2. Edit an existing filter, or create a new one.
3. Enable Redirect botnet C&C requests to Block Portal.

4. Configure other settings as needed.
5. Click OK.
6. Add this filter profile to a firewall policy.

Botnet C&C URL blocking
To block malicious URLs using the GUI:
1. Go to Security Profiles > Intrusion Prevention.
2. Edit an existing sensor, or create a new one.
3. Enable Block malicious URLs.

4. Configure other settings as needed.
5. Click OK.
6. Add this sensor to a firewall policy.
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Botnet C&C signature blocking
To add IPS signatures to a sensor using the GUI:
1.
2.
3.
4.
5.

Go to Security Profiles > Intrusion Prevention.
Edit an existing sensor, or create a new one.
In the IPS Signatures section, click Add Signatues. A list of available signatures appears.
Select the signatures you want to include from the list.
Click Use Selected Signatures.

6. Configure other settings as needed.
7. Add this sensor to a firewall policy to detect or block attacks that match the IPS signatures.

Email filter
Email filters can be configured to perform spam detection and filtering. You can customize the default profile, or create
your own and apply it to a firewall policy.

Two kinds of filtering can be defined in a single profile, and they will act independent of one
another.

Filter options can be organized according to the source of the decision:
l

l

l

Local options: the FortiGate qualifies the email based on local conditions, such as black or white lists (BWLs),
banned words, or DNS checks using FortiGuard Antispam.
FortiGuard-based options: the FortiGate qualifies the email based on the score or verdict returned from FortiGuard
Antispam.
Third-party options: the FortiGate qualifies the email based on information from a third-party source (like an ORB
list).
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Local and FortiGuard BWLs can be enabled and combined in a single profile. When combined, the local BWL has a
higher priority than the FortiGuard black list during a decision making process. For example, if a client IP address is
blacklisted in the FortiGuard server, but you want to override this decision and allow the IP to pass through the filter, you
can define the IP address or subnet in a local BWL with the clear action. Because the information coming from the local
list has a higher priority than the FortiGuard service, the email will be considered clean.

Some features of this functionality require a subscription to FortiGuard Antispam.

The following topics provide information about email filter profiles:
l
l
l
l
l

Local-based filters on page 827
FortiGuard-based filters on page 831
File type-based filters on page 832
Protocols and actions on page 837
Configuring webmail filtering on page 838

Local-based filters
You can make black or white lists (BWLs) from emails or IP subnets to forbid or allow them to send or receive emails.
You can also define a list of banned words. Emails that contain any of these banned words are considered spam.
With the spamhelodns and spamraddrdns commands, the FortiGate performs a standard DNS check on the machine
name used in the helo SMTP message, and/or the return-to field to determine if these names belong to a registered
domain. The FortiGate does not check the FortiGuard service during these operations.

To configure a local-based email filter in the CLI:
1. Configure a BWL:
config emailfilter bwl
edit 1
set name "mtBWL"
config entries
edit 1
set status enable
set type ip
set action spam
set addr-type ipv4
set ip4-subnet 10.1.100.0 255.255.255.0
next
end
next
end

2. Configure an email filter profile:
config emailfilter profile
edit "myLocalEmailFilter"
set spam-filtering enable
set options spambwl spamhelodns spamraddrdns
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config smtp
set action tag
end
set spam-bwl-table 1
next
end

3. Use the profile in a firewall policy:
config firewall policy
edit 1
.....
set inspection-mode proxy
set emailfilter-profile "myLocalEmailFilter"
next
end

To configure a local-based email filter in the GUI:
1. Go to Security Profiles > Email Filter.
2. Click Create New or select an existing profile and click Edit.

3. In the firewall policy, create or edit a rule.
4. Set the inspection-mode to Proxy-based.
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5. Enable the Email Filter option and select the previously created profile.

6. Set SSL Inspection to a profile that has deep SSL inspection enabled.
Deep inspection is required if you intend to filter SMTP, POP3, IMAP, or any SSL/TLS encapsulated protocol. The
below SSL-inspection profile has deep inspection enabled:
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7. Click OK.

To configure bannedwords in the CLI:
1. Configure a bannedwords list:
config emailfilter bword
edit 1
set name "banned"
config entries
edit 1
set pattern "undesired_word"
next
end
next
end

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

830

Security Profiles
2. Configure an email filter profile:
config emailfilter profile
edit "myBannedWordsProfile"
config file-filter
set status disable
end
set spam-filtering enable
set options bannedword
set spam-bword-table 1
next
end

3. Use the profile in a firewall policy:
config firewall policy
edit 1
.....
set inspection-mode proxy
set emailfilter-profile "myBannedWordsProfile"
next
end

Once created, this profile should be set in the firewall policy.

Bannedwords can only be configured through the CLI.

FortiGuard-based filters
The FortiGate consults FortiGuard servers to help identify spammer IP address or emails, known phishing URLs, known
spam URLs, known spam email checksums, and others.
FortiGuard servers have maintained databases that contain black lists, which are fed from Fortinet sensors and labs
distributed all over the world.

To configure the FortiGuard filters in the CLI:
config emailfilter profile
edit "myEmailFilterProfile"
set spam-filtering enable
set options spamfsip spamfssubmit spamfschksum spamfsurl spamrbl spamhdrcheck
spamfsphish
next
end

To configure the FortiGuard filters in the GUI:
1. Go to Security Profiles > Email Filter.
2. In the FortiGuard Spam Filtering Spam Filtering section, you can enable or disable the following filters:
l IP Address Check
l URL Check
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l
l
l

Detect Phising URLs in Email
Email Checksum Check
Spam Submission

3. Click OK.

File type-based filters
With File Filter, you can define undesired file types within the email filter profile and associate an action to be taken for
each file type, such as block or log.
For each entry, you can also specify the protocol to inspect (SMTP, POP3, or IMAP) and if only encrypted files should be
matched. While file filter entries are ordered, the block action takes precedence over the log action.
File filtering in email filter profiles is based only on the file type (file meta data) and not on file size or content. You would
need to configure a DLP sensor to block files based on size or content, such as SSN numbers, credit card numbers, or
regexp.
File filtering only works in proxy mode policies. The traffic direction cannot be configured because it is implied by the
protocol.
The following file types are supported:

File Type Name

Description

7z

Match 7-zip files

arj

Match arj compressed files
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File Type Name

Description

cab

Match Windows cab files

lzh

Match lzh compressed files

rar

Match rar archives

tar

Match tar files

zip

Match zip files

bzip

Match bzip files

gzip

Match gzip files

bzip2

Match bzip2 files

xz

Match xz files

bat

Match Windows batch files

msc

Match msc files

uue

Match uue files

mime

Match mime files

base64

Match base64 files

binhex

Match binhex files

bin

Match bin files

elf

Match elf files

exe

Match Windows executable files

hta

Match hta files

html

Match html files

jad

Match jad files

class

Match class files

cod

Match cod files

javascript

Match javascript files

msoffice

Match MS-Office files. For example, doc, xls, ppt, and so on.

msofficex

Match MS-Office XML files. For example, docx, xlsx, pptx, and so on.

fsg

Match fsg files

upx

Match upx files

petite

Match petite files

aspack

Match aspack files
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File Type Name

Description

prc

Match prc files

sis

Match sis files

hlp

Match Windows help files

activemime

Match activemime files

jpeg

Match jpeg files

gif

Match gif files

tiff

Match tiff files

png

Match png files

bmp

Match bmp files

ignored

Match ignored files

unknown

Match unknown files

mpeg

Match mpeg files

mov

Match mov files

mp3

Match mp3 files

wma

Match wma files

wav

Match wav files

pdf

Match pdf files

avi

Match avi files

rm

Match rm files

torrent

Match torrent files

msi

Match Windows Installer msi bzip files

mach-o

Match Mach object files

dmg

Match Apple disk image files

.net

Match .NET files

xar

Match xar archive files

chm

Match Windows compiled HTML help files

iso

Match ISO archive files

crx

Match Chrome extension files

Example
In the following example, one file filter entry is created to block executable (exe) files from being sent or received, and a
second entry logs any documents that are sent.
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To configure a file-type based email filter in the CLI:
1. Configure an email filter profile:
config emailfilter profile
edit "file-type-filter"
config file-filter
set status enable
set log enable
set scan-archive-contents enable
config entries
edit "filter1"
set comment "Block executable files"
set protocol smtp imap pop3
set action block
set encryption any
set file-type "exe"
next
edit "filter2"
set comment "Log document files"
set protocol smtp
set action log
set encryption any
set file-type "pdf" "msoffice" "msofficex"
next
end
end
set spam-filtering enable
next
end

2. Use the profile in a firewall policy:
config firewall policy
edit 1
set name "client-to-internet"
set srcintf "port2"
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set utm-inspection-mode proxy
set logtraffic all
set emailfilter profile "file-type-filter"
set profile-protocol-options "protocol"
set ssl-ssh-profile "protocols"
set nat enable
next
end

To configure a file-type based email filter in the GUI:
1. Go to Security Profiles > Email Filter.
2. Click Create New, or select an existing profile and click Edit.
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3.
4.
5.
6.

Enable Enable Spam Detection and Filtering.
Enable File Filter.
Enable Log and Scan Archived Contents.
In the File Filter table, click Create New.

7. Configure the filters:
a. filter1 blocks all sent or received executable files.

b. filter2 logs all sent documents.
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8. Click OK.
9. Add the new email filter profile to a firewall policy.

Log examples
File filter block action:
1: date=2019-01-25 time=15:20:16 logid="0554020511" type="utm" subtype="emailfilter"
eventtype="file_filter" level="warning" vd="vdom1" eventtime=1548458416 policyid=1
sessionid=2881 srcip=10.1.100.12 srcport=45974 srcintf="port2" srcintfrole="undefined"
dstip=172.16.200.56 dstport=143 dstintf="port1" dstintfrole="undefined" proto=6
service="IMAP" action="blocked" from="emailuser1@qa.fortinet.com"
to="emailuser2@qa.fortinet.com" recipient="emailuser2" direction="incoming" subject="EXE
file block" size="622346" attachment="yes" filename="putty.exe" filtername="filter1"
filetype="exe"

File filter log action:
1: date=2019-01-25 time=15:23:16 logid="0554020510" type="utm" subtype="emailfilter"
eventtype="file_filter" level="notice" vd="vdom1" eventtime=1548458596 policyid=1
sessionid=3205 srcip=10.1.100.12 srcport=55664 srcintf="port2" srcintfrole="undefined"
dstip=172.16.200.56 dstport=25 dstintf="port1" dstintfrole="undefined" proto=6
service="SMTP" profile="emailfilter-file-filter" action="detected"
from="emailuser1@qa.fortinet.com" to="emailuser2@qa.fortinet.com"
sender="emailuser1@qa.fortinet.com" recipient="emailuser2@qa.fortinet.com"
direction="outgoing" subject="PDF file log" size="390804" attachment="yes"
filename="fortiauto.pdf" filtername="filter2" filetype="pdf"

Protocols and actions
In an email filtering profile, there are sections for SMTP, POP3, and IMAP protocols. In each section, you can set an
action to either discard, tag, or pass the log for that protocol.

Protocol

Available action

SMTP

Pass: Allow spam email to pass through.
Tag: Tag spam email with configured text in the subject or header.
Discard: Discards (blocks) spam email.

POP3 & IMAP

Pass: Allow spam email to pass through.
Tag: Tag spam email with configured text in the subject or header.

MAPI:

Pass: Allow spam email to pass through.
Discard: Discards (blocks) spam email.

For example, to tag spam SMTP email, use the following commands:
config emailfilter profile
edit "smtpFilter"
set spam-filtering enable
set options <options>
...
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config smtp
set log enable
set action tag
end
next
end

MAPI email filtering
MAPI is a proprietary protocol from Microsoft. It uses HTTPS to encapsulate email requests and responses between
Microsoft Outlook clients and Microsoft Exchange servers. The configuration of MAPI email filters are only possible
through the CLI.

To configure the MAPI email filter in the CLI:
config emailfilter profile
edit "myMapiFilter"
set spam-filtering enable
set options spamfsip spamfssubmit spamfsurl spamfsphish
config mapi
set log enable
set action "discard or pass"
end
next
end

Configuring webmail filtering
You can configure an email filter to detect and log emails sent via Gmail and Hotmail. These interfaces do not use
standard email protocols (SMTP, POP3, or IMAP) and instead use HTTPS. However, you can still configure the email
filter to detect emails that pass through the FortiGate.

The FortiGate only detects and logs the emails, it does not discard or tag them.

To configure webmail filtering in the CLI:
config emailfilter profile
edit "myWebMailDetector"
set spam-filtering enable
config msn-hotmail
set log enable
end
config gmail
set log enable
end
next
end
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Data leak prevention
The FortiGate data leak prevention (DLP) system prevents sensitive data from leaving or entering your network. You can
customize the default sensor or create your own by adding individual filters based on file type, file size, a regular
expression, an advanced rule, or a compound rule. Once configured, you can apply the DLP sensor to a firewall policy.
Data matching defined sensitive data patterns is blocked, logged, or allowed when it passes through the FortiGate.
In FortiOS 6.2.2 and later, DLP can only be configured in the CLI.

The filters in a DLP sensor can examine traffic for the following:
l
l
l
l
l
l
l

Known files using DLP fingerprinting
Known files using DLP watermarking
Particular file types
Particular file names
Files larger than a specified size
Data matching a specified regular expression
Credit card and social security numbers

Filters are ordered, but there is no precedence between the possible actions

DLP is primarily used to stop sensitive data from leaving your network. DLP can also be used to prevent unwanted data
from entering your network and to archive some or all of the content that passes through the FortiGate. DLP archiving is
configured per filter, which allows a single sensor to archive only the required data. You can configure the DLP archiving
protocol in the CLI (see Configure DLP sensors).
There are two forms of DLP archiving:
l

l

Summary only: a summary of all the activity detected by the sensor is recorded. For example, when an email
message is detected, the sender, recipient, message subject, and total size are recorded. When a user accesses
the web, every URL that they visit is recorded.
Full: detailed records of all the activity detected by the sensor is recorded. For example, when an email message is
detected, the message itself, including any attachments, is recorded. When a user accesses the web, every page
that they visit is archived.

The following topics provide information about DLP:
l
l
l

Basic DLP filter types on page 840
DLP fingerprinting on page 846
DLP watermarking on page 850
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Basic DLP filter types
Basic filter types can be configured using the GUI or CLI and include:
l
l
l
l

File type and name
File size
Regular expression
Credit card and SSN

In FortiOS 6.2.2 and later, DLP can only be configured in the CLI.

File type and name
A file type filter allows you to block, allow, log, or quarantine based on the file type specified in the file filter list.

To configure file type and name filtering using the CLI:
1. Create a file pattern to filter files based on the file name patter or file type:
config dlp filepattern
edit <filepatern_entry_integer>
set name <string>
config entries
edit <file pattern>
set filter-type <type | pattern>
set file-type <file type>
next
end
next
end

For example, to filter for GIFs and PDFs:
config dlp filepattern
edit 11
set name “sample_config”
config entries
edit "*.gif"
set filter-type pattern
next
edit "pdf"
set filter-type type
set file-type pdf
next
end
next
end
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2. Attach the file pattern to a DLP sensor, and specify the protocols and actions:
config dlp sensor
edit <string>
config filter
edit <integer>
set name <string>
set proto <smtp | pop3 | imap | http-get | http-post | ftp | nntp |
mapi>
set filter-by file-type
set file-type 11
<-- Previously configured filepattern
set action <allow | log-only| block | quarantine-ip>
next
end
next
end

To configure file type and name filtering using the GUI:
1.
2.
3.
4.

Go to Security Profiles > Data Leak Prevention.
Click Create New. The New DLP Sensor page opens.
Click Add Filter in the filter table. The New Filter pane opens.
Set Type to Files and select Specify File Types.
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5. Add file types by clicking in the File Types field and select file types from the side pane.

6. Add file name patterns by clicking in the File Name Patterns field:
a. In the side pane that opens, enter the pattern in the search bar.
b. Click Create.
c. Select the newly created pattern.

File size
A file size filter checks for files that exceed the specific size, and performs the DLP sensor's configured action on them.

To configure file size filtering using the CLI:
config dlp sensor
edit <string>
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config filter
edit <integer>
set name <string>
set proto <smtp | pop3 | imap | http-get | http-post | ftp | nntp | mapi>
set filter-by file-size <-- Match any file over with a size over the
threshold
set file-type 11
<-- Previously configured filepattern
set action <allow | log-only| block | quarantine-ip>
next
end
next
end

To configure file size filtering using the GUI:
1.
2.
3.
4.
5.

Go to Security Profiles > Data Leak Prevention.
Click Create New. The New DLP Sensor page opens.
Click Add Filter in the filter table. The New Filter pane opens.
Set Type to Files and select File size over.
Enter the maximum file size, in kilobytes, in the File size over field, then click OK.

Regular expression
A regular expression filter is used to filter files or messages based on the configured regular expression pattern.

To configure regular expression filtering using the CLI:
config dlp sensor
edit <string>
config filter
edit <integer>
set name <string>
set type <file | message>
<-- Check contents of a file or of messages, web
pages, etc.
set proto <smtp | pop3 | imap | http-get | http-post | ftp | nntp | mapi>
set filter-by regexp
<-- Use a regular expression to match content
set regexp <regexp>
<-- Input a regular expression pattern
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set action <allow | log-only| block | quarantine-ip>
next
end
next
end

To configure regular expression filtering using the GUI:
1.
2.
3.
4.
5.
6.

Go to Security Profiles > Data Leak Prevention.
Click Create New. The New DLP Sensor page opens.
Click Add Filter in the filter table. The New Filter pane opens.
For filtering regular expressions in files, set Type to Files. For filtering in messages, set Type to Messages.
Select Regular Expression.
Enter the regular expression string in the Regular Expression field, then click OK.

Credit card and SSN
The credit card sensor can match the credit card number formats used by American Express, Mastercard, and Visa. It
can be used to filter files or messages.
The SSN sensor can be used to filter files or messages for Social Security Numbers.
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To configure credit card or SSN filtering using the CLI:
config dlp sensor
edit <string>
config filter
edit <integer>
set name <string>
set type <file | message> <-- Check contents of a file, or of messages, web
pages, etc.
set proto <smtp | pop3 | imap | http-get | http-post | ftp | nntp | mapi>
set filter-by < credit-card | ssn >
<-- Match credit cards or social security
numbers
set action <allow | log-only| block | quarantine-ip>
next
end
next
end

To configure credit card or SSN filtering using the GUI:
1.
2.
3.
4.
5.
6.

Go to Security Profiles > Data Leak Prevention.
Click Create New. The New DLP Sensor page opens.
Click Add Filter in the filter table. The New Filter pane opens.
For filtering in files, set Type to Files. For filtering in messages, set Type to Messages.
Select Containing.
Select Credit Card # or SSN from the Containing drop-down list, then click OK.
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DLP fingerprinting
DLP fingerprinting can be used to detect sensitive data. The file that the DLP sensor will filter for is uploaded and the
FortiGate generates and stores a checksum fingerprint. The FortiGate unit generates a fingerprint for all of the files that
are detected in network traffic, and compares all of the checksums stored in its database. If a match is found, the
configured action is taken.
Any type of file can be detected by DLP fingerprinting, and fingerprints can be saved for each revision of a file as it is
updated.
To use fingerprinting:
l
l
l

Select the files to be fingerprinted by targeting a document source.
Add fingerprinting filters to DLP sensors.
Add the sensors to firewall policies that accept traffic that the fingerprinting will be applied on.

The document fingerprint feature requires a FortiGate device that has internal storage.

To configure a DLP fingerprint document:
config dlp fp-doc-source
edit <name_str>
set server-type smb
set server <string>
set period {none | daily | weekly | monthly}
set vdom {mgmt | current}
set scan-subdirectories {enable | disable}
set remove-deleted {enable | disable}
set keep-modified {enable | disable}
set username <string>
set password <password>
set file-path <string>
set file-pattern <string>
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set
set
set
set
saturday}
set
next
end

sensitivity <Critical | Private | Warning>
tod-hour <integer>
tod-min <integer>
weekday {sunday | monday | tuesday | wednesday | thursday | friday |
date <integer>

Command

Description

server-type smb

The protocol used to communicate with document server. Only
Samba (SMB) servers are supported.

server <string>

IPv4 or IPv6 address of the server.

period {none | daily | weekly | monthly}

The frequency that the FortiGate checks the server for new or
changed files.

vdom {mgmt | current}

The VDOM that can communicate with the file server.

scan-subdirectories {enable | disable}

Enable/disable scanning subdirectories to find files.

remove-deleted {enable | disable}

Enable/disable keeping the fingerprint database up to date when a file
is deleted from the server.

keep-modified {enable | disable}

Enable/disable keeping the old fingerprint and adding a new one
when a file is changed on the server.

username <string>

The user name required to log into the file server.

password <password>

The password required to log into the file server.

file-path <string>

The path on the server to the fingerprint files.

file-pattern <string>

Files matching this pattern on the server are fingerprinted.

sensitivity <Critical | Private | Warning>

The sensitivity or threat level for matches with this fingerprint
database.

tod-hour <integer>

Set the hour of the day. This option is only available when period is
not none.

tod-min <integer>

Set the minute of the hour. This option is only available when period
is not none.

weekday {sunday | monday | tuesday |
wednesday | thursday | friday | saturday}

Set the day of the week. This option is only available when period is
weekly.

date <integer>

Set the day of the month. This option is only available when period
is monthly.

To configure a DLP fingerprint sensor:
config dlp sensor
edit <sensor name>
config filter
edit <id number of filter>
set proto {smtp | pop3 | imap http-get | http-post | ftp | nntp | mapi}
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set
set
set
set

filter-by fingerprint
sensitivity {Critical | Private | Warning}
match-percentage <integer>
action {allow | log-only | block | ban | quarantine-ip}

next
end
next
end

Command

Description

proto {smtp | pop3 | imap http-get | http-post |
ftp | nntp | mapi}

The protocol to inspect.

filter-by fingerprint

Match against a fingerprint sensitivity.

sensitivity {Critical | Private | Warning}

Select a DLP file pattern sensitivity to match.

match-percentage <integer>

The percentage of the checksum required to match before the sensor
is triggered.

action {allow | log-only | block | ban |
quarantine-ip}

The action to take with content that this DLP sensor matches.

View the DLP fingerprint database on the FortiGate
The CLI debug command diagnose test application dlpfingerprint can be used to display the fingerprint
information that is on the FortiGate.
Fingerprint Daemon Test Usage;
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=1 : This menu
2 : Dump database
3 : Dump all files
5 : Dump all chunk
6 : Refresh all doc sources in all VDOMs
7 : Show the db file size and the limit
9 : Display stats
10 : Clear stats
99 : Restart this daemon

For example, option 3 will dump all fingerprinted files:
DLP_WANOPT-CLT (global) # diagnose test application dlpfingerprint 3
DLPFP diag_test_handler called
File DB:
--------------------------------------id, filename,
vdom, archive, deleted, scanTime,
docSourceSrvr,
sensitivity, chunkCnt, reviseCnt,
1, /fingerprint/upload/1.txt,
vdom1, 0,
0,
1494868196,
1,
2,
1,
0,
2, /fingerprint/upload/30percentage.xls,
vdom1, 0,
0,
1356118250,
1,
2,
13,
0,
3, /fingerprint/upload/50.pdf,
vdom1, 0,
0,
1356118250,
1,
2,
122, 0,
4, /fingerprint/upload/50.pdf.tar.gz,
vdom1, 0,
0,
1356118250,
1,
2,
114,
0,
5, /fingerprint/upload/check-list_AL-SIP_HA.xls,
vdom1, 0,
0,
1356118251,
1,
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2,
32,
0,
6, /fingerprint/upload/clean.zip,
vdom1, 0,
0,
1356118251,
1,
2,
1,
0,
7, /fingerprint/upload/compare.doc,
vdom1, 0,
0,
1522097410,
1,
2,
18,
0,
8, /fingerprint/upload/dlpsensor-watermark.pdf,
vdom1, 0,
0,
1356118250,
1,
2,
11,
0,
9, /fingerprint/upload/eicar.com,
vdom1, 0,
0,
1356118250,
1,
2,
1,
0,
10, /fingerprint/upload/eicar.zip,
vdom1, 0,
0,
1356118250,
1,
2,
1,
0,
11, /fingerprint/upload/EMAIL-CONTENT-ARCHIVE.ppt, vdom1, 0,
0,
1356118250,
1,
2,
11,
0,
12, /fingerprint/upload/encrypt.zip,
vdom1, 0,
0,
1356118250,
1,
2,
77,
0,
13, /fingerprint/upload/extension_7_8_1.crx,
vdom1, 0,
0,
1528751781,
1,
2,
2720,
0,
14, /fingerprint/upload/fingerprint.txt,
vdom1, 0,
0,
1498582679,
1,
2,
37,
0,
15, /fingerprint/upload/fingerprint90.txt, vdom1, 0,
0,
1498582679,
1,
2,
37,
0,
16, /fingerprint/upload/fo2.pdf,
vdom1, 0,
0,
1450488049,
1,
2,
1,
0,
17, /fingerprint/upload/foo.doc,
vdom1, 0,
0,
1388538131,
1,
2,
9,
0,
18, /fingerprint/upload/fortiauto.pdf,
vdom1, 0,
0,
1356118251,
1,
2,
146,
0,
19, /fingerprint/upload/image.out,
vdom1, 0,
0,
1531802940,
1,
2,
5410, 0,
20, /fingerprint/upload/jon_file.txt,
vdom1, 0,
0,
1536596091,
1,
2,
0,
21, /fingerprint/upload/machotest,
vdom1, 0,
0,
1528751955,
1,
2,
19,
0,
22, /fingerprint/upload/nntp-server.doc,
vdom1, 0,
0,
1356118250,
1,
2,
17,
0,
23, /fingerprint/upload/notepad++.exe,
vdom1, 0,
0,
1456090734,
1,
2,
1061,
0,
24, /fingerprint/upload/nppIExplorerShell.exe,
vdom1, 0,
0,
1438559930,
1,
2,
5,
0,
25, /fingerprint/upload/NppShell_06.dll,
vdom1, 0,
0,
1456090736,
1,
2,
111,
0,
26, /fingerprint/upload/PowerCollections.chm,
vdom1, 0,
0,
1533336889,
1,
2,
728,
0,
27, /fingerprint/upload/reflector.dmg,
vdom1, 0,
0,
1533336857,
1,
2,
21117,
0,
28, /fingerprint/upload/roxio.iso,
vdom1, 0,
0,
1517531765,
1,
2,
49251,0,
29, /fingerprint/upload/SciLexer.dll,
vdom1, 0,
0,
1456090736,
1,
2,
541,
0,
30, /fingerprint/upload/screen.jpg,
vdom1, 0,
0,
1356118250,
1,
2,
55,
0,
31, /fingerprint/upload/Spec to integrate FASE into FortiOS.doc,
vdom1, 0,
0,
1356118251,
1,
2,
31,
0,
32, /fingerprint/upload/subdirectory1/subdirectory2/subdirectory3/hibun.aea,
vdom1, 0,
0,
1529019743,
1,
2,
1,
0,
33, /fingerprint/upload/test.pdf,
vdom1, 0,
0,
1356118250,
1,
2,
5,
0,
34, /fingerprint/upload/test.tar,
vdom1, 0,
0,
1356118251,
1,
2,
3,
0,
35, /fingerprint/upload/test.tar.gz,
vdom1, 0,
0,
1356118250,
1,
2,
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0,
36, /fingerprint/upload/test1.txt,
1,
0,
37, /fingerprint/upload/thousand-files.zip,
241,
0,
38, /fingerprint/upload/Thumbs.db,
3,
0,
39, /fingerprint/upload/widget.pdf,
18,
0,
40, /fingerprint/upload/xx00-xx01.tar,
0,
41, /fingerprint/upload/xx02-xx03.tar.gz,
0,

vdom1,

0,

0,

1540317547,

1,

2,

vdom1,

0,

0,

1536611774,

1,

2,

vdom1,

0,

0,

1445878135,

1,

2,

vdom1,

0,

0,

1356118251,

1,

2,

vdom1,

0,

0,

1356118250,

1,

2,

5,

vdom1,

0,

0,

1356118251,

1,

2,

1,

DLP watermarking
Watermarking marks files with a digital pattern to designate them as proprietary to a specific company. A small pattern is
added to the file that is recognized by the DLP watermark filter, but is invisible to the end user (except for text files).
FortiExplorer client, or a Linux-based command line tool, can be used to add a watermark to the following file types:
l
l
l
l
l

.txt
.doc and .docx
.pdf
.ppt and .pptx
.xls and .xlsx

The following information is covered in this section:
l
l
l

Watermarking a file with FortiExplorer.
Watermarking a file with the Linux tool.
Configuring a DLP sensor to detect watermarked files.

FortiExplorer
In this example, a watermark will be added to small text file. The content of the file is:
This is to show how DLP watermarking is done using FortiExplorer.

FortiExplorer can also be used to watermark an entire directory.
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To watermark the text file with FortiExplorer:
1. Open the FortiExplorer client.
2. Select DLP Watermark from the left side bar.

3.
4.
5.
6.
7.
8.

Set Apply Watermark To to Select File.
Browse for the file, copy the file's path into the Select File field.
Set the Sensitivity Level. The available options are: Critical, Private, and Warning.
Enter a company identifier in the Identifier field.
Select the Output Directory where the watermarked file will be saved.
Click Apply Watermark. The file is watermarked.

9. The watermarked file content is changed to:
This is to show how DLP watermarking is done using FortiExplorer.=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=identifier=FortiDemo sensitivity=Critical=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=

The watermark pattern is visible in text files. For all other supported file types, it is invisible.
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Linux-based command line tool
A Linux-based command line tool can be used to watermark files. The tool can be executed is a Linux environment by
passing in files or directories of files.

To download the tool:
1. Log in to Fortinet Service and Support. A valid support contract is required.
2. Go to Download > Firmware Images.
3. Select the Download tab, and go to FortiGate/v5.00/5.0/5.0.0/WATERMARK.

4. Download the fortinet-watermark-linux.out file.

To run the tool:
Enter the following to run the tool on a file:
watermark_linux_amd64 <options> -f <file name> -i <identifier> -l <sensitivity level>

Enter the following to run the tool on a directory:
watermark_linux_amd64 <options> -d <directory> -i <identifier> -l <sensitivity level>

The following options are available:
-h

Print this help.

-I

Watermark the file in place (don't make a copy of the file).

-o

The output file or directory.

-e

Encode <to non-readable>.

-i

Add a watermark identifier.

-l

Add a watermark sensitivity level.

-D

Delete a watermark identifier.

-L

Delete a watermark sensitivity level.
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DLP watermark sensor
A DLP watermark sensor must be configured to detect watermarked files.

To configure a DLP watermark sensor:
config dlp sensor
edit <sensor name>
config filter
edit <id number of filter>
set proto {smtp | pop3 | imap http-get | http-post | ftp | nntp | mapi} <-Protocol to inspect
set filter-by watermark
set sensitivity {Critical | Private | Warning}
set company-identifier <string>
set action {allow | log-only | block | ban | quarantine-ip}
next
end
next
end

VoIP solutions
You can configure VoIP profiles to allow SIP and SCCP traffic and to protect your network from SIP- and SCCP-based
attacks.
FortiOS includes two preloaded VoIP profiles:
l
l

default
strict

You can customize these profiles, or you can create your own and add them to firewall policies that allow VoIP.
The following topics provide information about VoIP profiles:
l
l
l
l
l
l

General use cases on page 853
SIP message inspection and filtering on page 857
SIP pinholes on page 859
SIP over TLS on page 860
Custom SIP RTP port range support on page 861
Voice VLAN auto-assignment on page 862

General use cases
There are three scenarios in which the FortiOS session initiation protocol (SIP) solution is usually deployed:
1. The SIP server is in a private network, protected from the internet by a FortiOS device.
2. The SIP clients are in a private network, protected from the internet by a FortiOS device.
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3. The SIP server is in a private network, such as a corporation's internal network or an ISP’s network, protected from
the Internet by a FortiOS device. The SIP clients are in a remote private network, such as a SOHO network, and
behind a NAT device that is not aware of SIP applications.
The following VIP, NAT, and HNT examples show configurations for each of the three common scenarios.

VIP
A FortiGate with SIP Application Layer Gateway (ALG) or SIP Session Helper protects the SIP server from the internet,
while SIP phones from the internet need to register to the SIP server and establish calls through it.

A VIP needs to be configured for the SIP server, and the VIP must be applied in a firewall policy for the phones to send
REGISTER messages through the FortiGate from port1 to port2.
Only one firewall policy needs to be configured for all SIP phones on both the internet and private network to register to
the SIP server through Port1 and set up SIP calls.
Assuming either SIP ALG or SIP Session Helper is enabled, configure the FortiGate with the following CLI commands:
config firewall vip
edit "VIP_for_SIP_Server"
set extip 172.20.120.50
set extintf "port1"
set mappedip "10.11.101.50"
next
end
config firewall policy
edit 1
set srcintf "port1"
set dstintf "port2"
set srcaddr "all"
set dstaddr "VIP_for_SIP_Server"
set action accept
set schedule "always"
set service "SIP"
next
end

Setting service to SIP and not All in the firewall policy can improve protection by restricting
the data traffic passing through the FortiGate to the SIP call traffic only.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

854

Security Profiles

NAT
A FortiGate with SIP ALG or SIP Session Helper protects the SIP phones and the internal network from the internet,
while SIP phones in the internal network need to register to the SIP server installed on the internet and establish calls
through it.

One firewall policy needs to be configured with NAT enabled for SIP phones to send REGISTER messages through the
FortiGate from port2 to port1.
Assuming either SIP ALG or SIP Session Helper is enabled, configure the FortiGate with the following CLI commands:
config firewall policy
edit 1
set srcintf "port2"
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "SIP"
set nat enable
next
end

HNT
A FortiGate with SIP ALG or SIP Session Helper protects the SIP server from the internet, while SIP phones are in
remote private networks behind NAT devices that are not aware of the SIP application.
For example, the SIP server is located in an ISP's service cloud that is protected by the FortiGate SIP ALG, and the
SIP phones are installed in the home networks of the ISP's customers.
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The SIP messages traversing the remote NAT devices might have their IP addresses translated by the NAT device at
the network layer, but untranslated at the SIP application layer because those NAT devices are not aware of the
SIP applications. This causes problems in a SIP session initiated process. Special configurations for the Hosted NAT
Traversal (HNT) are required to resolve this issue.

To configure the FortiGate with HNT support for SIP phones A and B to set up calls with each other:
1. Identify port1 as the external interface:
config system interface
edit "port1"
set external enable
next
end

2. Configure VIP for the SIP server:
config firewall vip
edit "VIP_for_SIP_Server"
set extip 10.21.101.10
set extintf "port1"
set mappedip "10.30.120.20"
next
end

3. Configure a VoIP profile with HNT enabled:
config voip profile
edit "hnt"
config sip
set hosted-nat-traversal enable
set hnt-restrict-source-ip enable
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end
next
end

hosted-nat-traversal must be enabled.
hnt-restrict-source-ip does not have to be enabled, but can be enabled to restrict
the RTP packets’ source IP to be the same as the SIP packets’ source IP.
4. Apply the VoIP profile and VIP in a firewall policy for phone A and B to register and set up SIP calls through the
FortiGate and SIP server:
config firewall policy
edit 1
set srcintf "port1"
set dstintf "port2"
set srcaddr "all"
set dstaddr "VIP_for_SIP_Server"
set action accept
set schedule "always"
set service "SIP"
set utm-status enable
set voip-profile “hnt”
set nat enable
next
end

nat must be enabled in the firewall policy.

SIP message inspection and filtering
SIP ALG provides users with security features to inspect and control SIP messages that are transported through FortiOS
devices, including:
l
l
l

Verifying the SIP message syntax.
Blocking particular types of SIP requests.
Restricting the rate of particular SIP requests.

These features are configured in the VoIP profile:
config voip profile
edit <voip_profile_name>
config sip set ...

The VoIP profile can then be applied to a firewall policy to process the SIP call traffic.

SIP message syntax inspection
For syntax verification, the following attributes are available for configuration in the VoIP profile to determine what action
is taken when a specific syntax error or attack based on invalid syntax is detected. For example, the action can be set to
pass or discard it.
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malformed-request-line
malformed-header-via
malformed-header-from
malformed-header-to
malformed-header-call-id
malformed-header-cseq
malformed-header-rack
malformed-header-rseq
malformed-header-contact
malformed-header-record-route
malformed-header-route
malformed-header-expires
malformed-header-content-type
malformed-header-content-length
malformed-header-max-forwards
malformed-header-allow
malformed-header-p-asserted-identity
malformed-header-sdp-v
malformed-header-sdp-o
malformed-header-sdp-s
malformed-header-sdp-i
malformed-header-sdp-c
malformed-header-sdp-b
malformed-header-sdp-z
malformed-header-sdp-k
malformed-header-sdp-a
malformed-header-sdp-t
malformed-header-sdp-r
malformed-header-sdp-m

SIP message blocking
The following options are available in the VoIP profile to block SIP messages:
block-long-lines
block-unknown
block-ack
block-bye
block-cancel
block-info
block-invite
block-message
block-notify
block-options
block-prack
block-publish
block-refer
block-register
block-subscribe
block-update
block-geo-red-options

SIP message rate limiting
The rate of certain types of SIP requests that are passing through the SIP ALG can be restricted :
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register-rate
invite-rate
subscribe-rate
message-rate
notify-rate
refer-rate
update-rate
options-rate
ack-rate
prack-rate
info-rate
publish-rate
bye-rate
cancel-rate

SIP pinholes
When SIP ALG processes a SIP call, it usually opens pinholes for SIP signaling and RTP/RTCP packets. NAT usually
takes place during the process at both the network and SIP application layers. SIP ALG ensures that, with NAT
happening, corresponding SIP and RTP/RTCP pinholes are created during the process when it is necessary for call
sessions to be established through FortiOS devices.
By default, SIP ALG manages pinholes automatically, but some special configurations can be used to restrict the
pinholes if required.

SIP pinhole restriction
By default, the strict-register attribute is enabled. When enabled, after a SIP endpoint registers to the SIP server through
a firewall policy on the FortiOS device, only the SIP messages sent from the same IP address as the SIP server are
allowed to pass through the SIP pinhole that is created in the FortiOS device to reach the SIP endpoints. If the attribute is
disabled, SIP messages from any IP addresses can pass through the pinhole created after the registration.
config voip profile
edit "voip-profile-name"
config sip
set strict-register [enable|disable]
...
end
next
end

RTP/RTCP pinhole restriction
In a SIP call through SIP ALG, the NATed RTP/RTCP port range is 5117 to 65533 by default. If required, the port range
can be restricted.
config voip profile
edit "voip-profile-name"
config sip
set nat-port-range <start_port_number>-<end_port_number>
...
end
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next
end

In a SIP call session, the RTP port number is usually an even number and the RTCP port number is an odd number that
is one more than the RTP port number. It is best practice to configure start_port_number to an even number, and
end_port_number to an odd number, for example:
config voip profile
edit "voip-profile-name"
conf sip
set nat-port-range 30000-39999
end
next
end

SIP over TLS
Some SIP phones and servers can communicate using TLS to encrypt the SIP signaling traffic. To allow SIP over TLS
calls to pass through the FortiGate, the encrypted signaling traffic must be unencrypted and inspected. The FortiGate
SIP ALG intercepts, unencrypts , and inspects the SIP packets, which are then re-encrypted and forwarded to their
destination.
The SIP ALG only supports full mode TLS. This means that the SIP traffic between SIP phones and the FortiGate, and
between the FortiGate and the SIP server, is always encrypted. The highest TLS version supported by SIP ALG is TLS
1.2.
To enable SIP over TLS support, the SSL mode in the VoIP profile must be set to full. The SSL server and client
certificates can be provisioned so that the FortiGate can use them to establish connections to SIP phones and servers,
respectively.

To configure SIP over TLS:
1. Configure a VoIP profile with SSL enabled:
config voip profile
edit "tls"
config sip
set ssl-mode full
set ssl-client-certificate "ssl_client_cert"
set ssl-server-certificate "ssl_server_cert"
end
next
end

The ssl_server_cert, ssl_client_cert, and key files can be generated using a certification tool, such as
OpenSLL, and imported to the local certificate store of the FortiGate from System > Certificates in the GUI. Existing
local certificates in the certificate store can also be used. As always for TLS connections, the certificates used must
be verified and trusted at the other end of the connection when required.
For example, the CA certificate of the SIP server's certificate should be imported to the FortiGate as an external CA
certification, such that the FortiGate can use it to verify the SIP server's certificate when setting up the TLS
connection. The CA certificate configured as the ssl_server_cert should be installed as the trusted certificate
on the SIP phones. The deployment of the certificates across the network depends on the SIP client and server
devices that are used in the system.
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2. Apply the profile to the firewall policy:
config firewall policy
edit 1
set srcintf "port1"
set dstintf "port2"
set srcaddr "all"
set dstaddr "vip_sip_server"
set action accept
set schedule "always"
set service "SIP"
set utm-status enable
set voip-profile "tls"
next
end

Custom SIP RTP port range support
The nat-port-range variable is used to specify a port range in the VoIP profile to restrict the NAT port range for realtime transport protocol/real-time transport control protocol (RTP/RTCP) packets in a session initiation protocol (SIP) call
session that is handled by the SIP application layer gateway (ALG) in a FortiGate device.
When NAT is enabled, or VIP is used in a firewall policy for SIP ALG to handle a SIP call session established through a
FortiGate device, the SIP ALG can perform NAT to translate the ports used for the RTP/RTCP packets when they are
flowing through the device between the external and internal networks.
You can control the translated port range for RTP/RTCP packets using the CLI:
config voip profile
edit <profile-name>
config sip
set nat-port-range <port range>
end
next
end

Command

Description

nat-port-range <port range>

The NAT port range (minimum port number = 5117, default = 5117-65535).

Example
In this example, Phone1 is in subnet_1, and the SIP server and phone are in subnet_2. All SIP signaling messages and
RTP/RTCP packets go through the SIP Server. The RTP/RTCP ports on Phone1 are configured as 17078/17079.
The FortiGate administrator wants to use NAT for the port 17078/17079 to 30000/30001. As a result, all RTP/RTCP
packets going out of port2 have source ports of 30000/30001, and all RTP/RTCP packets going into port2 also have
destination ports of 30000/30001, which is specified in nat-port-range.
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To configure the custom port range:
config voip profile
edit "natPortRange"
config sip
set nat-port-range 30000-30001
end
next
end
configure firewall policy
edit 1
set srcintf port1
set dstintf port2
set srcaddr all
set dstaddr all
set service SIP
set action accept
set schedule always
set voip-profile natPortRange
set nat enable
end

If phone1 and phone2 are registered to the SIP server, and they establish a call session between them through the
FortiGate and the SIP server, then the RTP/RTCP ports 17078/17079 of phone1 will be translated to ports 30000/30001
at the FortiGate unit based on the NAT port range setting. That is, the RTP/RTCP packets egressing port2 of the
Fortigate will have source ports of 30000/30001, and the RTP/RTCP packets ingressing port2 will have destination ports
of 30000/30001.

Voice VLAN auto-assignment
You can leverage LLDP-MED to assign voice traffic to the desired voice VLAN. After detection and setup, the IP phone
on the network is segmented to its own VLAN for policy, prioritization, and reporting. The LLDP reception capabilities in
FortiOS have been extended to support LLDP-MED assignment for voice, voice signaling, guest, guest voice signaling,
softphone, video conferencing, streaming video, and video signaling.
You can configure this feature using the following steps:
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1.
2.
3.
4.
5.
6.

Setting up the VLAN for the voice device
Setting up the DHCP server for the voice VLAN
Setting up the LLDP network policy
Enabling LLDP on the physical interface that the VLAN belongs to
Applying the LLDP network policy on the physical interface
Confirming that the VLAN was assigned

To set up the VLAN for the voice device:
config system interface
edit "vlan_100"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
set alias "voice_vlan"
set device-identification enable
set role lan
set snmp-index 25
set interface "port10"
set vlanid 100
next
end

To set up the DHCP server for the voice VLAN:
config system dhcp server
edit 1
set dns-service default
set default-gateway 192.168.1.99
set netmask 255.255.255.0
set interface "vlan_100"
config ip-range
edit 1
set start-ip 192.168.1.110
set end-ip 192.168.1.210
next
end
next
end

To set up the LLDP network policy:
config system lldp network-policy
edit "1"
config voice
set status enable
set tag dot1q
set vlan 100
end
next
end
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To enable LLDP on the physical interface that the VLAN belongs to:
config system interface
edit "port10"
set vdom "root"
set type physical
set lldp-reception enable
set lldp-transmission enable
set snmp-index 14
next
end

To apply the LLDP network policy on the physical interface:
config system interface
edit "port10"
set lldp-network-policy "1"
next
end

To confirm that the VLAN was assigned as expected:
1. Connect an IP phone to the network.
2. Check the IP address on the phone.
The IP address should belong to the voice VLAN.
3. Sniff on the FortiGate incoming interface to see if traffic from the IP phone has the desired VLAN tag.
In the example commands above, the voice VLAN was configured as VLAN 100. Therefore, voice traffic from the IP
phone should be in VLAN 100.

ICAP
Internet Content Adaptation Protocol (ICAP) is an application layer protocol that is used to offload tasks from the firewall
to separate, specialized servers. For more information see RFC 3507.
ICAP profiles can only be applied to policies that use proxy-based inspection. If you enable ICAP in a policy, HTTP and
HTTPS (if HTTPS inspection is supported) traffic that is intercepted by the policy is transferred to the ICAP server
specified by the selected ICAP profile. Responses from the ICAP server are returned to the FortiGate, and then
forwarded to their destination.

By default, ICAP is not visible in the GUI. See Feature visibility on page 554 for instructions on
making it visible.

To configure ICAP:
1.
2.
3.
4.

Set up your ICAP server.
On the FortiGate, add an ICAP server.
Create an ICAP profile.
Use the ICAP profile in a firewall policy that covers the traffic that needs to be offloaded to the ICAP server.
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ICAP configuration example
In this example, the ICAP server performs proprietary content filtering on HTTP and HTTPS requests. If the content filter
is unable to process a request, then the request is blocked. Streaming media is not considered by the filter, so it is
allowed through and is not processed.

To add the ICAP server to the FortiGate in the GUI:
1.
2.
3.
4.
5.
6.

Go to Security Profiles > ICAP Servers.
Click Create New.
In the Name field, enter a name for the ICAP server, such as content-filtration-server4.
Select the IP Version.
In the IP Address field, enter the IP address of the ICAP server.
In the Port field, enter a new port number if required. The default value is 1344.

7. Click OK.

The maximum number of concurrent connections to ICAP server can be configured in the CLI.
The default setting is 100 connections.

To create an ICAP profile in the GUI:
1.
2.
3.
4.

Go to Security Profiles > ICAP.
Click Create New.
In the Name field, enter a name for the ICAP profile, such as Prop-Content-Filtration.
Enable Request Processing then set the following:
l Server - Select the ICAP server. In this example, select content-filtration-server4
l Path - The path to the processing component on the server, such as /proprietary_code/content-filter/.
l On Failure - Select Error to block the request. If the message cannot be processed, it will not be blocked.
5. Enable Response Processing then set the following:
l Server - Select the ICAP server: content-filtration-server4
l Path - The path to the processing component on the server, such as /proprietary_code/content-filter/.
l On Failure - Select Error to block the request. If the message cannot be processed, it will not be blocked.
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6. Enable Streaming Media Bypass to not offload streaming media to the ICAP server.

7. Click OK.

To add the ICAP profile to a policy in the GUI:
1.
2.
3.
4.
5.

Go to Policy & Objects > IPv4 Policy.
Click Create New.
Configure the policy as needed to apply to the required traffic.
Set Inspection Mode to Proxy-based.
Under Security Profiles, enable ICAP and select the ICAP server.

6. Click OK.

To configure the ICAP setup in the CLI:
1. Add the ICAP server:
config icap server
edit "content-filtration-server4"
set ip-version 4
set ip-address 172.16.100.55
set port 1344
set max-connections 200
next
end
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2. Create the ICAP profile:
config icap profile
edit "Prop-Content-Filtration"
set request enable
set response enable
set streaming-content-bypass enable
set request-server "content-filtration-server4"
set response-server "content-filtration-server4"
set request-failure error
set response-failure error
set request-path "/proprietary_code/content-filter/"
set response-path "/proprietary_code/content-filter/"
set methods delete get head options post put trace other
next
end

3. Add the ICAP profile to a policy:
config firewall policy
edit 5
set name "icap_filter3"
set srcintf "virtual-wan-link"
set dstintf "virtual-wan-link"
set srcaddr "FABRIC_DEVICE"
set dstaddr "FABRIC_DEVICE"
set dstaddr-negate enable
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set inspection-mode proxy
set ssl-ssh-profile "certificate-inspection"
set icap-profile "Prop-Content-Filtration"
set logtraffic disable
set fsso disable
set nat enable
next
end

Web application firewall
Web application firewall (WAF) profiles can detect and block known web application attacks. You can configure WAF
profiles to use signatures and constraints to examine web traffic. You can also enforce an HTTP method policy, which
controls the HTTP method that matches the specified pattern.
You can customize the default profile, or you can create your own profile to apply access rules and HTTP protocol
constraints to traffic. You can apply WAF profiles to firewall policies when the inspection mode is set to proxy-based.
The following topic provides information about WAF profiles:
l

Protecting a server running web applications on page 868
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Protecting a server running web applications
You can use a web application firewall profile to protect a server that is running a web application, such as webmail.

Web application firewall profiles are created with a variety of options called signatures and constraints. Once these
options are enabled, the action can be set to allow, monitor, or block. The severity can be set to high, medium, or low.
In the following example, the default profile will be targeted to block SQL injection attempts and generic attacks.

The web application firewall feature is only available when the policy inspection mode is proxybased.

To protect a server running web applications:
1. Enable the web application firewall:
a. Go to System > Feature Visibility.
b. Under Security Features, enable Web Application Firewall.
c. Under Additional Features, click Show More and enable Multiple Security Profiles.
d. Click Apply.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

868

Security Profiles
2. Edit the default web application firewall profile:
Trojans and Known Exploits are blocked by default.
a. Go to Security Profiles > Web Application Firewall.
b. Edit the default profile signature:
i. Enable SQL Injection (Extended) and Generic Attacks (Extended).
ii. For both signatures, set the Action to Block and the Severity to High.
iii. Click Apply.

3. Apply the profile to a security policy:
a. Go to Policy & Objects > IPv4 Policy.
b. Edit the policy that allows access to the web server:
i. Under Firewall / Network Options, select the appropriate Protocol Option.
ii. Under Security Profiles, enable Web Application Firewall and set it to use the default profile.
iii. Set the SSL Inspection to use the deep-inspection profile.
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iv. Click OK.

4. Verify that the web application firewall blocks traffic:
a. Use the following URL to simulate an attack on your web server and substitute the IP address of your server:
http://<server
IP>/index.php?username=1'%20or%20'1'%20=%20'1&password=1'%20or%20'1'%20=%20'1
An error message appears, stating that the web application firewall has blocked the traffic:

Offloading to a FortiWeb
If you have a FortiWeb, you may be able to offload the functions of the web application control to your FortiWeb. To find
out if this option is available, refer to the FortiOS or FortiWeb Release Notes for information about device compatibility.

To offload to a FortiWeb:
1. Go to Security Fabric > Settings.
2. Enable Fabric Devices.
3. Enter the following for the device:
a. Name (FortiWeb)
b. FortiWeb IP address
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c. HTTPS service port

4. Click Generate.
5. Enter your credentials to generate the access token.
6. Click OK.

Inspection modes
This section contains the following topics:
l
l
l

About inspection modes on page 871
SSL Inspection on page 878
SSH traffic file scanning on page 885

About inspection modes
FortiOS supports flow-based and proxy-based inspection in firewall policies. You can select the inspection mode when
configuring a policy.
Flow-based inspection takes a snapshot of content packets and uses pattern matching to identify security threats in the
content.
Proxy-based inspection reconstructs content that passes through the FortiGate and inspects the content for security
threats.
Each inspection mode plays a role in processing traffic en route to its destination. While both modes offer significant
security, proxy-based provides more feature configuration options, while flow-based is designed to optimize
performance.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

871

Security Profiles

This following topics provide information about inspection modes for various security profile features:
l
l
l
l
l
l
l

Flow mode inspection (default mode) on page 872
Proxy mode inspection on page 873
Inspection mode feature comparison on page 874
Inspection mode differences for antivirus on page 875
Inspection mode differences for data leak prevention on page 876
Inspection mode differences for email filter on page 876
Inspection mode differences for web filter on page 877

Flow mode inspection (default mode)
When a firewall policy’s inspection mode is set to flow, traffic flowing through the policy will not be buffered by the
FortiGate. Unlike proxy mode, the content payload passing through the policy will be inspected on a packet by packet
basis with the very last packet held by the FortiGate until the scan returns a verdict. If a violation is detected in the traffic,
a reset packet is issued to the receiver, which terminates the connection, and prevents the payload from being sent
successfully.
Because of this method, flow mode inspection cannot be as thorough as proxy mode inspection and will have some
feature limitations. For example, flow mode inspection determines a file’s size by identifying the file size information in
the protocol exchange. If a file’s size is not present in the protocol exchange, the file’s size cannot be identified. The flowbased policy will automatically block or pass the file (based on the configuration) despite the file meeting the file size
requirements.
The objective of flow-based policy is to optimize performance and increase throughput. Although it is not as thorough as
a proxy-based policy, flow mode inspection is still very reliable.

Use case
It is recommended that flow inspection is applied to policies that prioritize traffic throughput, such as allowing
connections to be made towards a streaming or file server.
You have an application server which accepts connections from users for the daily quiz show app, HQ. Each HQ session
sees 500,000+ participants, and speed is very important because participants have less than 10 seconds to answer the
quiz show questions.

In this scenario, a flow inspection policy is recommended to prioritize throughput. The success of the application
depends on providing reliable service for large numbers of concurrent users. We will apply an IPS sensor to this policy to
protect the server from external DOS attacks.
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Proxy mode inspection
When a firewall policy’s inspection mode is set to proxy, traffic flowing through the policy will be buffered by the FortiGate
for inspection. This means that the packets for a file, email message, or web page will be held by the FortiGate until the
entire payload is inspected for violations (virus, spam, or malicious web links). After FortiOS has finished the inspection,
the payload is either released to the destination (if traffic is clean) or dropped and replaced with a replacement message
(if traffic contains violations).
To optimize inspection, the policy can be configured to block or ignore files or messages that exceed a certain size. To
prevent the receiving end user from timing out, client comforting can be applied, which allows small portions of the
payload to be sent while it is undergoing inspection.
Proxy mode provides the most thorough inspection of the traffic; however, its thoroughness sacrifices performance,
making its throughput slower than that of a flow-mode policy. Under normal traffic circumstances, the throughput
difference between a proxy-based and flow-based policy is not significant.

Use case
Because proxy mode provides the most thorough inspection, it is recommended that you apply proxy inspection to
policies where preventing a data leak or malicious content is critical.
The following scenarios demonstrate common use cases for proxy inspection.

Scenario 1
Your organization deals with sensitive data on a regular basis and a data leak would significantly harm your business. At
the same time, you wish to protect your employees from malicious content, such as viruses and phishing emails, which
could be used to gain access to your network and the sensitive data on your systems.

In this scenario, a proxy inspection policy is recommended to prioritize network security. We want traffic inspection to be
as thorough as possible to avoid any data leaks from exiting the LAN and any malicious content from entering it. On this
policy, we will apply the virus filter, DLP filter, Web Filter, and email filter all operating in proxy mode.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

873

Security Profiles

Scenario 2
You have a corporate mail server in your domain, which is used by your employees for everyday business activities. You
want to protect your employees from phishing emails and viruses. At the same time, you want to also protect your web
servers from external attacks.

In this scenario, a proxy inspection policy is recommended to prioritize the safety of employee emails. Applying the
antivirus and email filter in this mode allows us to most reliably filter out any malware and spam emails received by the
mail servers via SMTP or MAPI. The IPS sensor can be used to prevent DOS attacks on the mail servers.

Inspection mode feature comparison
The following table shows which UTM profile can be configured on a flow mode or proxy mode inspection policy. Some
UTM profiles are hidden in the GUI, but can be configured using the CLI.

Flow Mode Inspection Policy

Proxy Mode Inspection
Policy

UTM Profile

GUI

CLI

GUI

CLI

Antivirus

Yes (2)

Yes (2)

Yes

Yes

Application Control

Yes

Yes

Yes

Yes

CIFS Inspection

No

No

No (1)

Yes

Data Leak Prevention

No

Yes (3)

Yes

Yes

DNS Filter

Yes

Yes

Yes

Yes

Email Filter

No

Yes (4)

Yes

Yes

ICAP

No

No

Yes

Yes

Intrusion Prevention System

Yes

Yes

Yes

Yes

SSL/SSH Inspection

Yes

Yes

Yes

Yes

VoIP

Yes

Yes

Yes

Yes

Web Filter

Yes (5)

Yes (5)

Yes

Yes

Web Application Firewall

No

No

Yes

Yes
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1. CIFS inspection cannot be configured via GUI.
2. Some Antivirus features are not supported in flow mode inspection. See Inspection mode differences for antivirus
on page 875.
3. Some Data Leak Prevention features are not supported in Flow mode inspection. See Inspection mode differences
for data leak prevention on page 876.
4. Some Email filter features are not supported in Flow mode inspection. See Inspection mode differences for email
filter on page 876.
5. Some Web Filter features are not supported in Flow mode inspection. See Inspection mode differences for web filter
on page 877.

Inspection mode differences for antivirus
This section identifies the behavioral differences between Antivirus operating in flow and proxy inspection.

Feature comparison between antivirus inspection modes
The following table indicates which Antivirus features are supported by their designated scan modes.

Part1

Replacement
Message

Content
Disarm

Mobile
Malware

Virus Outbreak

Sandbox
Inspection

NAC Quarantine

Proxy

Yes

Yes

Yes

Yes

Yes

Yes

Flow Full Mode

Yes*

No

Yes

Yes

Yes

Yes

Flow Quick Mode

Yes*

No

No

No

Yes

Yes

*IPS Engine caches the URL and a replacement message will be presented after the second attempt.

Part 2

Archive
Blocking

Emulator

Client Comforting

Infection
Quarantine

Heuristics

Treat
EXE as
Virus

Proxy

Yes

Yes

Yes

Yes (1)

Yes

Yes (2)

Flow Full Mode

Yes

Yes

No

Yes (1)

Yes

Yes (2)

Flow Quick Mode

No

No

No

No

No

No

1. Only available on FortiGate models with HDD or when FortiAnalyzer or FortiGate Cloud is connected and enabled.
2. Only applies to inspection on IMAP, POP3, SMTP, and MAPI protocols.

Protocol comparison between antivirus inspection modes
The following table indicates which protocols can be inspected by the designated antivirus scan modes.

HTTP

FTP

IMAP

POP3

SMTP

NNTP

MAPI

CIFS

Proxy

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes*

Flow Full Mode

Yes

Yes

Yes

Yes

Yes

No

No

Yes

Flow Quick Mode

Yes

Yes

Yes

Yes

Yes

No

No

Yes
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* Proxy mode antivirus inspection on CIFS protocol has the following limitations:
l
l
l
l

Cannot detect infections within archive files
Cannot detect oversized files
Will block special archive types by default
IPv6 is not supported

Other antivirus differences between inspection modes
Flow Quick mode uses a separate pre-filtering database for malware detection as opposed to the full AV signature
database that Flow Full and Proxy mode inspection use.
Proxy mode uses pre-scanning and stream-based scanning for HTTP traffic. This allows archive files that exceed the
oversize limit to be uncompressed and scanned for infections.

Inspection mode differences for data leak prevention
This section identifies the behavioral differences between data leak prevention (DLP) operating in flow and proxy
inspection.

Feature comparison between DLP inspection modes
The following table indicates which DLP filters are supported by their designated inspection modes.

Credit
Card
Filter

SSN Filter

Regex
Filter

FileType
Filter

File-Pat- Fingerprint
tern Fil- Filter
ter

Watermark
Filter

Encrypted
Filter

FileSize
Filter

Proxy

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Flow

Yes

Yes

Yes

No

Yes

No

No

Yes

Yes*

*File-size filtering will only work if file size is present in the protocol exchange.

Protocol comparison between DLP inspection modes
The following table indicates which protocols can be inspected by DLP based on the specified inspection modes.

HTTP

FTP

IMAP

POP3

SMTP

NNTP

MAPI

CIFS

Proxy

Yes

Yes

Yes

Yes

Yes

Yes

Yes

No

Flow

Yes

Yes

Yes

Yes

Yes

No

No

No

Inspection mode differences for email filter
This section identifies the behavioral differences between Email Filter operating in flow and proxy inspection.
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Feature comparison between Email Filter inspection modes
The following table indicates which Email Filters are supported by their designated inspection modes.

SMTP

POP3

IMAP

MAPI

Proxy

Yes

Yes

Yes

Yes

Flow

Yes

Yes

Yes

No

Feature comparison between Email Filter inspection modes
The following tables indicate which Email Filters are supported by the specified inspection modes for local filtering and
FortiGuard-assisted filtering.

Local Filtering

Banned
Word
Check

Black/
White
List

HELO/ EHLO
DNS Check

Return
Address
DNS Check

DNSBL/
ORBL
Check

MIME
Header
Check

File
Filter

Proxy

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Flow

Yes

No

No

No

No

Yes

No

FortiGuard-Assisted Filtering

Phishing
URL Check

Anti-Spam
Black List
Check

Submit Spam
to FortiGuard

Spam Email
Checksum
Check

Spam
URL Check

Proxy

Yes

Yes

Yes

Yes

Yes

Flow

No

No

No

No

No

Inspection mode differences for web filter
This section identifies the behavioral differences between Web Filter operating in flow and proxy inspection.

Feature comparison between Web Filter inspection modes
The following table indicates which Web Filter features are supported by their designated inspection modes.

FortiGuard
CategoryBased Filter

Category
Usage
Quota

Override
Blocked
Categories

File Fil- Search
ter
Engines

Static
URL Filter

Rating
Option

Proxy
Option

Proxy

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Flow

Yes (1)

No

Yes (2)

No

No

Yes

Yes

No

1. Local Category and Remote Category filters do not support the warning and authenticate actions.
2. Local Category and Remote Category filters cannot be overridden.
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SSL Inspection
Secure sockets layer (SSL) content scanning and inspection allows you to apply antivirus scanning, web filtering, and
email filtering to encrypted traffic. You can apply SSL inspection profiles to firewall policies.
FortiOS includes four preloaded SSL/SSH inspection profiles, three of which are read-only and can be cloned:
l
l
l

certificate-inspection
deep-inspection
no-inspection

The custom-deep-inspection profile can be edited, or you can create your own SSL/SSH inspection profiles.
Deep inspection (also known as SSL/SSH inspection) is typically applied to outbound policies where destinations are
unknown. Depending on your policy requirements, you can configure the following:
l
l
l
l
l
l

Which CA certificate will be used to decrypt the SSL encrypted traffic
Which SSL protocols will be inspected
Which ports will be associated with which SSL protocols for inspection
Whether or not to allow invalid SSL certificates
Whether or not SSH traffic will be inspected
Which addresses or web category white lists can bypass SSL inspection

The following topics provide information about SSL inspection:
l
l
l
l

Certificate inspection on page 878
Deep inspection on page 880
Protecting an SSL server on page 883
Ignoring the AUTH TLS command on page 884

Certificate inspection
FortiGate supports certificate inspection. The default configuration has a built-in certificate-inspection profile which you
can use directly. When you use certificate inspection, the FortiGate only inspects the headers up to the SSL/TLS layer.
If you do not want to deep scan for privacy reasons but you want to control web site access, you can use certificateinspection.

Inspect non-standard HTTPS ports
The built-in certificate-inspection profile is read-only and only listens on port 443. If you want to make changes, you must
create a new certificate inspection profile.
If you know the non-standard port that the web server uses, such as port 8443, you can add this port to the HTTPS field.
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If you do not know which port is used in the HTTPS web server, you can select Inspect All Ports.

Block untrusted or allow invalid certificate
The default setting in the certificate-inspection profile is to block invalid certificates and allow untrusted certificates.
For example, the server certificate has expired but you still want to access this server until you have a new server
certificate. But because certificate inspection cannot do an exemption, you have to allow the invalid certificate in your
SSL profile. This means you need to create a new certificate inspection profile using the built-in read-only certificateinspection.
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Deep inspection
You can configure address and web category white lists to bypass SSL deep inspection.

Reasons for using deep inspection
While Hypertext Transfer Protocol Secure (HTTPS) offers protection on the Internet by applying Secure Sockets Layer
(SSL) encryption to web traffic, encrypted traffic can be used to get around your network's normal defenses.
For example, you might download a file containing a virus during an e-commerce session, or you might receive a
phishing email containing a seemingly harmless download that, when launched, creates an encrypted session to a
command and control (C&C) server and downloads malware onto your computer. Because the sessions in these attacks
are encrypted, they might get past your network's security measures.
When you use deep inspection, the FortiGate impersonates the recipient of the originating SSL session, then decrypts
and inspects the content to find threats and block them. It then re-encrypts the content and sends it to the real recipient.
Deep inspection not only protects you from attacks that use HTTPS, it also protects you from other commonly-used SSLencrypted protocols such as SMTPS, POP3S, IMAPS, and FTPS.
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Browser messages when using deep inspection
When FortiGate re-encrypts the content, it uses a certificate stored on the FortiGate such as Fortinet_CA_SSL, Fortinet_
CA_Untrusted, or your own CA certificate that you uploaded.
Because there is no Fortinet_CA_SSL in the browser trusted CA list, the browser displays an untrusted certificate
warning when it receives a FortiGate re-signed server certificate. To stop the warning messages, trust the FortiGatetrusted CA Fortinet_CA_SSL and import it into your browser.
After importing Fortinet_CA_SSL into your browser, if you still get messages about untrusted certificate, it must be due to
Fortinet_CA_Untrusted. Never import the Fortinet_CA_Untrusted certificate into your browser.

To import Fortinet_CA_SSL into your browser:
1. On the FortiGate, go to Security Profiles > SSL/SSH Inspection and select deep-inspection.
2. The default CA Certificate is Fortinet_CA_SSL.
3. Select Download Certificate.

4. On the client PC, double-click the certificate file and select Open.
5. Select Install Certificate to launch the Certificate Import Wizard and use the wizard to install the certificate into
the Trusted Root Certificate Authorities store.
If a security warning appears, select Yes to install the certificate.

Exempt web sites from deep inspection
If you do not want to apply deep inspection for privacy or other reasons, you can exempt the session by address,
category, or white list.
If you know the address of the server you want to exempt, you can exempt that address. You can exempt specific
address type including IP address, IP address range, IP subnet, FQDN, wildcard-FQDN, and geography.
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If you want to exempt all bank web sites, an easy way is to exempt the Finance and Banking category which includes all
finance and bank web sites identified in FortiGuard.

If you want to exempt commonly trusted web sites, you can bypass the SSL white list in the SSL/SSH profile. The white
list includes common web sites trusted by FortiGuard. Simply enable Reputable Websites.
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Protecting an SSL server
You typically use the FortiGate Protecting SSL Server profile as an inbound policy for clients on the internet that access
the server through the internal side of the FortiGate.
Protecting SSL Server uses a server certificate to protect a single server.
You can use Protecting SSL Server if you do not want a client on the internet to directly access your internal server, and
you want the FortiGate to simulate your real server.

To upload a server certificate into FortiGate and use that certificate in the SSL/SSH inspection profile:
1.
2.
3.
4.
5.

Go to System > Certificates.
Select Import > Local Certificate and upload the certificate.
Go to Security Profiles > SSL/SSH Inspection and edit or create a new profile.
For Enable SSL Inspection of, select Protecting SSL Server.
For Server Certificate, select the local certificate you imported.
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6. Click Apply.

When you apply the Protecting SSL Server profile in a policy, the FortiGate will send the server certificate to the client as
your server does.

Ignoring the AUTH TLS command
If the FortiGate receives an AUTH TLS (PBSZ and PROT) command before receiving plain text traffic from a decrypted
device, by default, it will expect encrypted traffic, determine that the traffic belongs to an abnormal protocol, and bypass
the traffic.
When the ssl-offloaded command is enabled, the AUTH TLS command is ignored, and the traffic is treated as plain
text rather than encrypted data. SSL decryption and encryption are performed by an external device.

To enable SSL offloading:
config firewall profile-protocol-options
edit "test"
config ftp
set ssl-offloaded yes
end
config imap
set ssl-offloaded yes
end
config pop3
set ssl-offloaded yes
end
config smtp
set ssl-offloaded yes
end
next
end
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SSH traffic file scanning
FortiGates can buffer, scan, log, or block files sent over SSH traffic (SCP and SFTP) depending on the file size, type, or
contents (such as viruses or sensitive content).

This feature is supported in proxy-based inspection mode. It is currently not supported in flowbased inspection mode.

You can configure the following SSH traffic settings in the CLI:
l
l
l
l

Protocol options
Filter profile (SCP block/log options and file filter)
DLP sensor
Antivirus (profile and quarantine options)

To configure SSH protocol options:
config firewall profile-protocol-options
edit "protocol"
config ssh
set options [oversize | clientcomfort | servercomfort]
set comfort-interval [1 - 900]
set comfort-amount [1 - 65535]
set oversize-limit [1 - 798]
set uncompressed-oversize-limit [0 - 798]
set uncompressed-nest-limit [2 - 100]
set scan-bzip2 [enable | disable]
end
next
end

To configure SCP block and log options:
config ssh-filter profile
edit "ssh-test"
set block scp
set log scp
next
end

To configure the SSH file filter:
config ssh-filter profile
edit "ssh-test"
config file-filter
set status [enable | disable]
set log [enable | disable]
set scan-archive-contents [enable | disable]
config entries
edit "1"
set comment ''
set action [block | log]
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set direction [incoming | outgoing | any]
set password-protected [yes | any]
set file-type "msoffice"
next
end
end
next
end

To configure the DLP sensor:
config dlp sensor
edit "test"
set full-archive-proto ssh
set summary-proto ssh
config filter
edit 1
set proto ssh
next
end
next
end

To configure the antivirus profile options:
config antivirus profile
edit "av"
config ssh
set options [scan | avmonitor | quarantine]
set archive-block [encrypted | corrupted | partiallycorrupted | multipart |
nested | mailbomb | fileslimit | timeout | unhandled]
set archive-log [encrypted | corrupted | partiallycorrupted | multipart | nested
| mailbomb | fileslimit | timeout | unhandled]
set emulator [enable | disable]
set outbreak-prevention [disabled | files | full-archive]
end
next
end

To configure the antivirus quarantine options:
config antivirus quarantine
set drop-infected ssh
set store-infected ssh
set drop-blocked ssh
set store-blocked ssh
set drop-heuristic ssh
set store-heuristic ssh
end
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Sample logs
SCP traffic blocked by ssh-filter profile:
1: date=2019-07-24 time=10:34:42 logid="1601061010" type="utm" subtype="ssh" eventtype="sshchannel" level="warning" vd="vdom1" eventtime=1563989682560488314 tz="-0700" policyid=1
sessionid=2693 profile="ssh-test" srcip=10.1.100.11 srcport=33044 dstip=172.16.200.44
dstport=22 srcintf="port1" srcintfrole="undefined" dstintf="port3" dstintfrole="undefined"
proto=6 action="blocked" direction="outgoing" login="root" channeltype="scp"

SCP traffic blocked by file-filter:
1: date=2019-07-24 time=10:36:44 logid="1900064000" type="utm" subtype="file-filter"
eventtype="file-filter" level="warning" vd="vdom1" eventtime=1563989804387444023 tz="-0700"
policyid=1 sessionid=2732 srcip=10.1.100.11 srcport=33048 srcintf="port1"
srcintfrole="undefined" dstip=172.16.200.44 dstport=22 dstintf="port3"
dstintfrole="undefined" proto=6 service="SSH" subservice="SCP" profile="ssh-test"
direction="incoming" action="blocked" filtername="1" filename="test.xls" filesize=13824
filetype="msoffice" msg="File was blocked by file filter."

SFTP traffic blocked by file-filter:
1: date=2019-07-24 time=10:43:58 logid="1900064000" type="utm" subtype="file-filter"
eventtype="file-filter" level="warning" vd="vdom1" eventtime=1563990238339440605 tz="-0700"
policyid=1 sessionid=2849 srcip=10.1.100.11 srcport=33056 srcintf="port1"
srcintfrole="undefined" dstip=172.16.200.44 dstport=22 dstintf="port3"
dstintfrole="undefined" proto=6 service="SSH" subservice="SFTP" profile="ssh-test"
direction="incoming" action="blocked" filtername="1" filename="test.xls" filesize=13824
filetype="msoffice" msg="File was blocked by file filter."

SCP traffic blocked by dlp sensor:
1: date=2019-07-24 time=10:42:42 logid="0954024576" type="utm" subtype="dlp" eventtype="dlp"
level="warning" vd="vdom1" eventtime=1563990162266253784 tz="-0700" filteridx=1
filtername="test" dlpextra="builtin-patterns" filtertype="file-type" filtercat="file"
severity="medium" policyid=1 sessionid=2838 epoch=1425775843 eventid=0 srcip=10.1.100.11
srcport=33054 srcintf="port1" srcintfrole="undefined" dstip=172.16.200.44 dstport=22
dstintf="port3" dstintfrole="undefined" proto=6 service="SSH" subservice="SFTP"
filetype="msoffice" direction="incoming" action="block" filename="test.xls" filesize=13824
profile="test"

SFTP traffic blocked by dlp sensor:
1: date=2019-07-24 time=10:41:23 logid="0954024576" type="utm" subtype="dlp" eventtype="dlp"
level="warning" vd="vdom1" eventtime=1563990083875731367 tz="-0700" filteridx=1
filtername="test" dlpextra="builtin-patterns" filtertype="file-type" filtercat="file"
severity="medium" policyid=1 sessionid=2809 epoch=1425775842 eventid=0 srcip=10.1.100.11
srcport=33052 srcintf="port1" srcintfrole="undefined" dstip=172.16.200.44 dstport=22
dstintf="port3" dstintfrole="undefined" proto=6 service="SSH" subservice="SCP"
filetype="msoffice" direction="incoming" action="block" filename="test.xls" filesize=13824
profile="test"
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SCP traffic blocked by antivirus profile:
1: date=2019-07-24 time=10:45:57 logid="0211008192" type="utm" subtype="virus"
eventtype="infected" level="warning" vd="vdom1" eventtime=1563990357330463670 tz="-0700"
msg="File is infected." action="blocked" service="SSH" subservice="SCP" sessionid=2875
srcip=10.1.100.11 dstip=172.16.200.44 srcport=33064 dstport=22 srcintf="port1"
srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" policyid=1 proto=6
direction="incoming" filename="eicar.exe" checksum="53badd68" quarskip="No-skip"
virus="EICAR_TEST_FILE" dtype="Virus" ref="http://www.fortinet.com/ve?vn=EICAR_TEST_FILE"
virusid=2172 profile="av"
analyticscksum="7fc2dfc5a2247d743556ef59abe3e03569a6241e2b1e44b9614fc764847fb637"
analyticssubmit="false" crscore=50 craction=2 crlevel="critical"

SFTP traffic blocked by antivirus profile:
2: date=2019-07-24 time=10:45:46 logid="0211008192" type="utm" subtype="virus"
eventtype="infected" level="warning" vd="vdom1" eventtime=1563990346334781409 tz="-0700"
msg="File is infected." action="blocked" service="SSH" subservice="SFTP" sessionid=2874
srcip=10.1.100.11 dstip=172.16.200.44 srcport=33062 dstport=22 srcintf="port1"
srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" policyid=1 proto=6
direction="incoming" filename="eicar.exe" checksum="53badd68" quarskip="No-skip"
virus="EICAR_TEST_FILE" dtype="Virus" ref="http://www.fortinet.com/ve?vn=EICAR_TEST_FILE"
virusid=2172 profile="av"
analyticscksum="7fc2dfc5a2247d743556ef59abe3e03569a6241e2b1e44b9614fc764847fb637"
analyticssubmit="false" crscore=50 craction=2 crlevel="critical"

Antivirus quarantine list triggered by infected files sent over SCP/SFTP:
CHECKSUM SIZE
FIRST-TIMESTAMP LAST-TIMESTAMP
SERVICE STATUS
FILENAME DESCRIPTION
53badd68 12939
2019-07-24 10:45 2019-07-24 10:45 SSH
Infected
'eicar.exe' 'EICAR_TEST_FILE'

DC

TTL

1

FOREVER

Overrides
Web filter configuration can be separated into profile configuration and profile overrides.
You can also override web filter behavior based on the FortiGuard website categorization:
l

l

Use alternate categories (web rating overrides): this method manually assigns a specific website to a different
Fortinet category or a locally-created category.
Use alternate profiles: configured users or IP addresses can use an alternative web filter profile when attempting to
access blocked websites.

Some features of this functionality require a subscription to FortiGuard Web Filtering.

The following topics provide information about web overrides:
l
l

Web rating override on page 889
Web profile override on page 891
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Web rating override
Web rating override requires a FortiGuard license.
This option is for you to categorize websites by different criteria. Even for the same criterion, an organization might want
to block most websites in a category while allowing access to specific URLs in that category.

For example, a website called example.com is in the subcategory of pornography and the organization uses FortiGuard
Web Filter to block access to sites in the category of pornography. However, in this example, example.com is a client
and that website is for artists that specialize in nudes and erotic images. In this example, there are two approaches. The
first is to use the web rating override function to assign example.com to the nudity and risque category instead of
pornography category to match the criteria that the organization goes by. The second approach is to assign the website
to a custom category that is not blocked because the website belongs to a client and staff need to access that website.
Another example from the reverse perspective is a school decides that a website specializing in selling books online
should not be accessible because it sells books with violent subject matter. Fortinet categorizes this website,
example2.com, as General Interest - Business with the subcategory of Shopping and Auction, which is a category that is
allowed. In this example, the school can reassign this website to the category Adult Material which is a blocked category.
You can assign a website to a built-in category or a custom category.

Create a local custom category
You can create a custom or local category and assign a URL to it.

To create a custom category in the GUI:
1. Go to Security Profiles > Web Rating Overrides and click Custom Categories.
2. In the Custom Categories pane, click Create New.
3. Enter the category Name, for example, mylocalcategory.
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4. Click OK.
The custom category appears in Web Filter under Local Categories where you can change the Action for that
category.

To create a custom category in the CLI:
config webfilter ftgd-local-cat
edit "custom1"
set id 140
next
edit "custom2"
set id 141
next
edit "mylocalcategory"
<<---- the name of category you created
set id 142
<<---- the id for this category in Web Filter profile
next
end

To change the action to block for a custom category in the CLI:
config webfilter profile
edit "webfilter"
config ftgd-wf
unset options
config filters
edit 142
set action block
next
end
end
next
end

<<---- this is the id of local category
<<---- set the action to block

Override URL category
You can override a URL to another category or to a custom category. This example shows overriding www.fortinet.com
to the custom category: mylocalcategory.
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To override a URL category in the GUI:
1.
2.
3.
4.

Go to Security Profiles > Web Rating Overrides and click Create New.
In the New Web Rating Overrides pane, enter the URL you want to re-categorize.
To view the URL's current rating, click Lookup Rating.
In the Override to section:
a. For Category, select Custom Categories.
b. For Sub-Category, select mylocalcategory.

5. Click OK.
The URL www.fortinet.com now belongs to the mylocalcategory category.

To override a URL category in the CLI:
config webfilter ftgd-local-rating
edit "www.fortinet.com"
set rating 142
<<---- this is the id of mylocalcategory
next
end

Web profile override
You can use the following profile override methods:
l
l

Administrative override
Allow users to override blocked categories
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Administrative override
Administrators can grant temporary access to sites that are otherwise blocked by a web filter profile. You can grant
temporary access to a user, user group, or source IP address. You can set the time limit for days, hours, or minutes. The
default is 15 minutes.
When the administrative web profile override is enabled, a blocked access page or replacement message does not
appear, and authentication is not required.

Scope range
You can choose one of the following scope ranges:
l
l

l

User: authentication for permission to override is based on whether or not the user is using a specific user account.
User group: authentication for permission to override is based on whether or not the user account supplied as a
credential is a member of the specified user group.
Source IP: authentication for permission to override is based on the IP address of the computer that was used to
authenticate. This would be used for computers that have multiple users. For example, if a user logs on to the
computer, engages the override by using their credentials, and then logs off, anyone who logs on with an account
on that computer would be using the alternate override web filter profile.

When you enter an IP address in the administrative override method, only individual IP
addresses are allowed.

Differences between IP and identity-based scope
Using the IP scope does not require using an identity-based policy.
When using the administrative override method and IP scope, you might not see a warning message when you change
from using the original web filter profile to using the alternate profile. There is no requirement for credentials from the
user so, if allowed, the page will just appear in the browser.

Example of configuring a web profile administrative override
This example describes how to override a webfilter profile with a webfilter_new profile.

To configure web profile administrative override using the GUI:
1. Go to Security Profiles > Web Profile Overrides.
2. Click Create New.

The New Administrative Override pane opens.
3. Configure the administrative override:
a. For Scope Range, click Source IP.
b. In the Source IP field, enter the IP address for the client computer (10.1.100.11 in this example).
c. In the Original Profile dropdown, select webfilter.
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d. In the New Profile dropdown, select webfilter_new.
In the Minutes field, the default 15 minutes appears, which is the desired duration for this example.

4. Click OK. The list of web profile overrides appears.
The actual expiration time displays instead of the number of minutes.

To configure web profile administrative override using the CLI:
config webfilter override
edit 1
set status enable
set scope ip
set old-profile "webfilter"
set new-profile "webfilter_new"
set expires 2019/04/10 14:33:00
set initiator "admin"
set ip 10.1.100.11
next
end

Allow users to override blocked categories
For both override methods, the scope ranges (for specified users, user groups, or IP addresses) allow sites blocked by
web filtering profiles to be overridden for a specified length of time.
But there is a difference between the override methods when the users or user group scope ranges are selected. In both
cases, you would need to apply the user or user group as source in the firewall policy. With administrative override, if you
do not apply the source in the firewall policy, the traffic will not match the override and will be blocked by the original
profile. With Allow users to override blocked categories, the traffic will also be blocked, but instead of displaying a
blocking page, the following message appears:

When you choose the user group scope, once one user overrides, it will affect the other users in the group when they
attempt to override. For example, user1 and user2 both belong to the local_user group. Once user1 successfully
overrides, this will generate an override entry for the local_user group instead of one specific user. This means that if
user2 logs in from another PC, they can override transparently.
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Ask feature
This option is only available in the Allow users to override blocked categories method. It configures the message page to
have the user choose which scope they want to use. Normally on the message page, the scope options are greyed out
and not editable. In the following example, the Scope is predefined with IP.

When the ask option is enabled (through the Switch applies to field in the GUI), the Scope dropdown is editable. Users
can choose one of the following:
l
l
l

User
User Group
IP

User and User Group are only available when there is a user group in the firewall policy. You
must specify a user group as a source in the firewall policy so the scope includes User and
User Group; otherwise, only the IP option will be available.

Other features
Besides the scope, there are some other features in Allow users to override blocked categories.

Apply to group(s)
Individual users can not be selected. You can select one or more of the user groups recognized by the FortiGate. They
can be local to the system or from a third party authentication device, such as an AD server through FSSO.
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Switch duration
Administrative override sets a specified time frame that is always used for that override. The available options in Allow
users to override blocked categories are:
l

l

Predefined: the value entered is the set duration (length of time in days, hours, or minutes) that the override will be
in effect. If the duration variable is set to 15 minutes, the length of the override will always be 15 minutes. The option
will be visible in the override message page, but the setting will be greyed out.
Ask: the user has the option to set the override duration once it is engaged. The user can set the duration in terms of
days, hours, or minutes.

Example of creating a web profile users override
This example describes how to allow users in the local_group to override the webfilter_new profile.

To allow users to override blocked categories using the GUI:
1. Go to Security Profiles > Web Filter.
2. Click Create New.
3. Under the Category Usage Quota section, toggle on Allow users to override blocked categories.

4. Configure the web filter profile:
a. Click the Groups that can override field, and select a group (local_group in this example).
b. Click the Profile Name field, and select the webfilter_new profile.
c. For the Switch applies to field, click IP.
d. For the Switch Duration field, click Predefined. The default 15 minutes appears, which is the desired duration
for this example.
e. Configure the rest of the profile as needed.

5. Click OK.
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Custom signatures
You can create the following custom signatures and apply them to firewall policies:
l
l
l

IPS signature
Application signature
Application group

The following topic provides information about custom signatures:
l

Application groups in policies on page 896

Application groups in policies
This feature provides an application group command for firewall shaping policies.
The following CLI command is used:
config firewall shaping-policy
edit 1
set app-group <application group>...
......
next
end

Example
In this example, there are two traffic shaping policies:
l
l

Policy 1 is for traffic related to cloud applications that has high priority.
Policy 2 is for other traffic and has low priority.

To create the shaping policies using the GUI:
1. Configure an application group for cloud applications:
a. Go to Security Profiles > Custom Signatures.
b. Click Create New > Application Group. The New Application Group page opens.

c. Enter a name for the group, select the type, and then add the group the members.
d. Click OK.
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2. Create the shaping policy for the high priority cloud application traffic:
a. Go to Policy & Objects > Traffic Shaping Policy.
b. Click Create New. The New Shaping Policy page opens.

c. Configure the shaping policy, selecting the previously created cloud application group, and setting both the
Shared shaper and Reverse shaper to high-priority.
d. Click OK.

At least one firewall policy must have application control enabled for the applications to
match any policy traffic.

3. Create the shaping policy for all other traffic, setting both the Shared shaper and Reverse shaper to low-priority.

To create the shaping policies using the CLI:
1. Configure an application group for cloud applications:
config application group
edit "cloud app group"
set application 27210 36740 35944 24467 33048

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

897

Security Profiles

next
end

2. Create the shaping policies for the high priority cloud application traffic and the other, low priority traffic:
config firewall shaping-policy
edit 1
set name "For Cloud Traffic"
set service "ALL"
set app-category 30
set app-group "cloud app group"
set dstintf "port1"
set traffic-shaper "high-priority"
set traffic-shaper-reverse "high-priority"
set srcaddr "all"
set dstaddr "all"
next
edit 2
set name "For Other Traffic"
set service "ALL"
set dstintf "port1"
set traffic-shaper "low-priority"
set traffic-shaper-reverse "low-priority"
set srcaddr "all"
set dstaddr "all"
next
end
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Virtual Private Network (VPN) technology lets remote users connect to private computer networks to gain access to their
resources in a secure way. For example, an employee traveling or working at home can use a VPN to securely access
the office network through the Internet.
Instead of remotely logging into a private network using an unencrypted and unsecured Internet connection, using a
VPN ensures that unauthorized parties cannot access the office network and cannot intercept information going
between the employee and the office. Another common use of a VPN is to connect the private networks of multiple
offices.
Fortinet offers VPN capabilities in the FortiGate Unified Threat Management (UTM) appliance and in the FortiClient
Endpoint Security suite of applications. You can install a FortiGate unit on a private network and install FortiClient
software on the user’s computer. You can also use a FortiGate unit to connect to the private network instead of using
FortiClient software.
The following sections provide information about VPN:
l
l

IPsec VPNs on page 899
SSL VPN on page 1091

IPsec VPNs
The following sections provide instructions on configuring IPsec VPN connections in FortiOS 6.2.0.
l
l
l
l
l
l
l
l

Overlay Controller VPN (OCVPN) on page 899
IPsec Tunnels on page 926
Site-to-site VPN on page 961
Dialup VPN on page 1000
ADVPN on page 1014
Authentication in VPN on page 1044
VXLAN over IPsec tunnel on page 1056
Other VPN topics on page 1060

Overlay Controller VPN (OCVPN)
Overlay Controller VPN (OCVPN) is a cloud based solution to simplify IPsec VPN setup. When OCVPN is enabled,
IPsec phase1-interfaces, phase2-interfaces, static routes, and firewall policies are generated automatically on all
FortiGates that belong to the same community network. A community network is defined as all FortiGates registered to
FortiCare using the same FortiCare account.
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If the network topology changes on any FortiGates in the community (such as changing a public IP address in DHCP
mode, adding or removing protected subnets, failing over in dual WAN), the IPsec-related configuration for all devices is
updated with Cloud assistance in self-learning mode. No intervention is required.

OCVPN with SD-WAN is not currently supported.

The following topics provide instructions on configuring OCVPN:
l
l
l
l
l

Full mesh OCVPN on page 900
Hub-spoke OCVPN with ADVPN shortcut on page 904
Hub-spoke OCVPN with inter-overlay source NAT on page 908
OCVPN portal on page 912
Troubleshooting OCVPN on page 914

Full mesh OCVPN
This example shows how to configure a full mesh Overlay Controller VPN (OCVPN), establishing full mesh IPsec tunnels
between all of the FortiGates.

License
l
l

Free license: Three devices full mesh, 10 overlays, 16 subnets per overlay.
Full License: Maximum of 16 devices, 10 overlays, 16 subnets per overlay.

Prerequisites
l
l
l

All FortiGates must be running FortiOS 6.2.0 or later.
All FortiGates must have Internet access.
All FortiGates must be registered on FortiCare using the same FortiCare account.

Restrictions
l
l

Non-root VDOMs do not support OCVPN.
FortiOS 6.2.x is not compatible with FortiOS 6.0.x.

Terminology
Poll-interval

How often FortiGate tries to fetch OCVPN-related data from OCVPN Cloud.

Role

The device OCVPN role of spoke, primary-hub, or secondary-hub.

Overlay

Defines network overlays and bind to subnets.

Subnet

Internal network subnet (IPsec protected subnet). Traffic to or from this subnet enters the
IPsec tunnel encrypted by IPsec SA.
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Sample topology
The following example shows three FortiGate units registered on FortiCare using the same FortiCare account. Each
FortiGate unit has one internal subnet, and no NAT exists between the units.

Sample configuration
The following overlays and subnets are used:
l

l

l

Branch1:
l Overlay name: QA. Local subnets: 10.1.100.0/24
l Overlay name: PM. Local subnets: 10.2.100.0/24
Branch2:
l Overlay name: QA. Local interfaces: lan1
l Overlay name: PM. Local interfaces: lan2
Branch3:
l Overlay name: QA. Local subnets: 172.16.101.0/24
l Overlay name: PM. Local subnets: 172.16.102.0/24

The overlay names on each device must be the same for local and remote selector pairs to be negotiated.

To register FortiGates on FortiCare:
1. Go to System > FortiGuard > License Information > FortiCare Support.
2. To register, click Register or Launch Portal.
3. Complete the options to register FortiGate on FortiCare.

To enable OCVPN using the GUI:
1. Go to VPN > Overlay Controller VPN.
2. Create the first overlay by setting the following options:
a. For Status, click Enabled.
b. For Role, click Spoke.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

901

VPN
c. In the Overlays section, click Create New to create a network overlay.

3. Specify the Name, Local subnets, and/or Local interfaces.
The local subnet must be routable and interfaces must have IP addresses.
4. Click OK.

5. Click Apply to commit the configuration.
6. Repeat this procedure to create all the overlays.
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To enable OCVPN using the CLI:
1. Configure Branch1:
config vpn ocvpn
set status enable
config overlays
edit 1
set name "QA"
config subnets
edit 1
set subnet 10.1.100.0 255.255.255.0
next
end
next
edit 2
set name "PM"
config subnets
edit 1
set subnet 10.2.100.0 255.255.255.0
next
end
next
end
end

2. Configure Branch2:
config vpn ocvpn
set status enable
config overlays
edit 1
set name "QA"
config subnets
edit 1
set type interface
set interface "lan1"
next
end
next
edit 2
set name "PM"
config subnets
edit 1
set type interface
set interface "lan2"
next
end
next
end
end

3. Configure Branch3:
config vpn ocvpn
set status enable
config overlays
edit 1
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set name "QA"
config subnets
edit 1
set subnet 172.16.101.0 255.255.255.0
next
end
next
edit 1
set name "PM"
config subnets
edit 1
set subnet 172.16.102.0 255.255.255.0
next
end
next
end
end

Hub-spoke OCVPN with ADVPN shortcut
This topic shows a sample configuration of a hub-spoke One-Click VPN (OCVPN) with an Auto Discovery VPN (ADVPN)
shortcut. OCVPN automatically detects the network topology based on members' information. To form a hub-spoke
OCVPN, at least one device must announce its role as the primary hub, another device can work as the secondary hub
(for redundancy), while others function as spokes.

License
l
l

Free license: Hub-spoke network topology not supported.
Full license: Maximum of 2 hubs, 10 overlays, 64 subnets per overlay; 512 spokes, 10 overlays, 16 subnets per
overlay.

Prerequisites
l
l
l

All FortiGates must be running FortiOS 6.2.0 or later.
All FortiGates must have Internet access.
All FortiGates must be registered on FortiCare using the same FortiCare account.

Restrictions
l
l

Non-root VDOMs do not support OCVPN.
FortiOS 6.2.x is not compatible with FortiOS 6.0.x.

OCVPN device roles
l
l
l

Primary hub.
Secondary hub.
Spoke (OCVPN default role).
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Sample topology

Sample configuration
The steps below use the following overlays and subnets for the sample configuration:
l

l

l

l

Primary hub:
l Overlay name: QA. Local subnets: 172.16.101.0/24
l Overlay name: PM. Local subnets: 172.16.102.0/24
Secondary hub:
l Overlays are synced from primary hub.
Spoke1:
l Overlay name: QA. Local subnets: 10.1.100.0/24
l Overlay name: PM. Local subnets: 10.2.100.0/24
Spoke2:
l Overlay name: QA. Local interfaces: lan1
l Overlay name: PM. Local interfaces: lan2

To register FortiGates on FortiCare:
1. Go to System > FortiGuard > License Information > FortiCare Support.
2. To register, click Register or Launch Portal.
3. Complete the options to register FortiGate on FortiCare.

To enable hub-spoke OCVPN using the GUI:
1. Go to VPN > Overlay Controller VPN.
2. Configure the OCVPN primary hub by setting the following options:
a. For Status, click Enabled.
b. For Role, click Primary Hub.
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c. In the Overlays section, click Create New to create a network overlay.

d. Specify the Name, Local subnets, and/or Local interfaces. Then click OK.
e. Click Apply to commit the configuration.

3. Configure the OCVPN secondary hub:
Overlays are synced from the primary hub and cannot be defined in the secondary hub.
a. In the Overlay Controller VPN pane, select Secondary Hub for the Role.
b. Select Apply to commit the configuration.
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4. Configure the OCVPN spokes:
a. In the Overlay Controller VPN pane, select Spoke for the Role.
b. In the Overlays section, click Create New to create a network overlay.
c. Specify the Name, Local subnets, and/or Local interfaces.
The local subnet must be routable and interfaces must have IP addresses.
d. Click OK and then click Apply to commit the configuration.

To enable hub-spoke OCVPN using the CLI:
1. Configure the OCVPN primary hub:
config vpn ocvpn
set status enable
set role primary-hub
config overlays
edit 1
set name "QA"
config subnets
edit 1
set subnet 172.16.101.0 255.255.255.0
next
end
next
edit 2
set name "PM"
config subnets
edit 1
set subnet 172.16.102.0 255.255.255.0
next
end
next
end
end

2. Configure the OCVPN secondary hub:
config vpn ocvpn
set status enable
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set role secondary-hub
end

3. Configure the OCVPN spoke1:
config vpn ocvpn
set status enable
config overlays
edit 1
set name "QA"
config subnets
edit 1
set subnet 10.1.100.0 255.255.255.0
next
end
next
edit 2
set name "PM"
config subnets
edit 1
set subnet 10.2.100.0 255.255.255.0
next
end
next
end
end

4. Configure the OCVPN spoke2:
config vpn ocvpn
set status enable
config overlays
edit 1
set name "QA"
config subnets
edit 1
set subnet 192.168.4.0 255.255.255.0
next
end
next
edit 2
set name "PM"
config subnets
edit 1
set subnet 192.168.5.0 255.255.255.0
next
end
next
end
end

Hub-spoke OCVPN with inter-overlay source NAT
This topic shows a sample configuration of hub-spoke OCVPN with inter-overlay source NAT. OCVPN isolates traffic
between overlays by default. With NAT enabled on spokes and assign-ip enabled on hub, you can have inter-overlay
communication.
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Inter-overlay communication means devices from any source addresses and any source interfaces can communicate
with any devices in overlays' subnets when the overlay option assign-ip is enabled.
You must first disable auto-discovery before you can enable NAT.

License
l
l

Free license: Hub-spoke network topology not supported.
Full License: Maximum of 2 hubs, 10 overlays, 64 subnets per overlay; 512 spokes, 10 overlays, 16 subnets per
overlay.

Prerequisites
l
l
l

All FortiGates must be running FortiOS 6.2.0 or later.
All FortiGates must have Internet access.
All FortiGates must be registered on FortiCare using the same FortiCare account.

Restrictions
l
l

Non-root VDOMs do not support OCVPN.
FortiOS 6.2.x is not compatible with FortiOS 6.0.x.

OCVPN device roles
l
l
l

Primary hub.
Secondary hub.
Spoke (OCVPN default role).

Sample topology
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Sample configuration
You can only configure this feature using the CLI.

To enable inter-overlay source NAT using the CLI:
1. Configure the primary hub, enable overlay QA, and configure assign-ip and IP range:
config vpn ocvpn
set status enable
set role primary-hub
config overlays
edit 1
set name "QA"
set assign-ip enable
set ipv4-start-ip 172.16.101.100
set ipv4-end-ip 172.16.101.200
config subnets
edit 1
set subnet 172.16.101.0 255.255.255.0
next
end
next
edit 2
set name "PM"
set assign-ip enable
config subnets
edit 1
set subnet 172.16.102.0 255.255.255.0
next
end
next
end
end

2. Configure the secondary hub:
config vpn ocvpn
set status enable
set role secondary-hub
end

3. Configure spoke1 and enable NAT on the spoke:
config vpn ocvpn
set status enable
set auto-discovery disable
set nat enable
config overlays
edit 1
set name "QA"
config subnets
edit 1
set subnet 10.1.100.0 255.255.255.0
next
end
next
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edit 2
set name "PM"
config subnets
edit 1
set subnet 10.2.100.0 255.255.255.0
next
end
next
end
end

4. Configure spoke2 and enable NAT on the spoke:
config vpn ocvpn
set status enable
set auto-discovery disable
set nat enable
config overlays
edit 1
set name "QA"
config subnets
edit 1
set subnet 192.168.4.0 255.255.255.0
next
end
next
edit 2
set name "PM"
config subnets
edit 1
set subnet 192.168.5.0 255.255.255.0
next
end
next
end
end

A firewall policy with NAT is generated on the spoke:
edit 9
set
set
set
set
set
set
set
set
set
set
set
next

name "_OCVPN2-1.1_nat"
uuid 3f7a84b8-3d36-51e9-ee97-8f418c91e666
srcintf "any"
dstintf "_OCVPN2-1.1"
srcaddr "all"
dstaddr "_OCVPN2-1.1_remote_networks"
action accept
schedule "always"
service "ALL"
comments "Generated by OCVPN Cloud Service."
nat enable
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OCVPN portal
When you log into the OCVPN portal, the OCVPN license type and device information display. The device information
includes the device serial number, OCVPN role, hostname, public IP address, port number, and overlays.
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You can unregister an OCVPN device from the OCVPN portal under Device on the right pane.

Use the OCVPN Diagram to show the OCVPN network topology.
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Troubleshooting OCVPN
This document includes troubleshooting steps for the following OCVPN network topologies:
l
l
l

Full mesh OCVPN.
Hub-spoke OCVPN with ADVPN shortcut.
Hub-spoke OCVPN with inter-overlay source NAT.

For OCVPN configurations in other network topologies, see the other OCVPN topics.

Troubleshooting full mesh network topology
l

Branch_1 # diagnose vpn ocvpn status
Current State
Topology
Role
Server Status
Registration time
Update time
Poll time

l

Registered
Full-Mesh
Spoke
Up
Thu Feb 28 18:42:25 2019
Thu Feb 28 15:57:18 2019
Fri Mar 1 15:02:28 2019

Branch_1 # diagnose vpn ocvpn show-meta
Topology
License
Members
Max-free

l

:
:
:
:
:
:
:

::
::
::
::

auto
full
3
3

Branch_1 # diagnose vpn ocvpn show-overlays
QA
PM

l

Branch_1 # diagnose vpn ocvpn show-members
Member: { "SN": "FG100D3G15801621", "IPv4": "172.16.200.1", "port": "500", "slot": 1000,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "10.1.100.0\/255.255.255.0" ], "ip_
range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"10.2.100.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "Name": "FortiGate100D", "topology_role": "spoke" }
Member: { "SN": "FG900D3915800083", "IPv4": "172.16.200.4", "port": "500", "slot": 1001,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "172.16.101.0\/255.255.255.0" ], "ip_
range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"172.16.102.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "Name": "Branch3",
"topology_role": "spoke" }
Member: { "SN": "FGT51E3U16001314", "IPv4": "172.16.200.199", "port": "500", "slot":
1002, "overlay": [ { "id": 0, "name": "QA", "subnets": [ "192.168.4.0\/255.255.255.0" ],
"ip_range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"192.168.5.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "Name": "Branch2",
"topology_role": "spoke" }

l

Branch_1 # diagnose vpn tunnel list
list all ipsec tunnel in vd 0
-----------------------------------------------------name=_OCVPN2-3.1 ver=2 serial=4 172.16.200.1:0->172.16.200.199:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
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proxyid_num=2 child_num=0 refcnt=13 ilast=7 olast=0 ad=/0
stat: rxp=0 txp=7 rxb=0 txb=588
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=6
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-3.1 proto=0 sa=1 ref=2 serial=8 auto-negotiate
src: 0:10.1.100.0-10.1.100.255:0
dst: 0:192.168.4.0-192.168.4.255:0
SA: ref=3 options=18627 type=00 soft=0 mtu=1438 expire=42923/0B replaywin=2048
seqno=8 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42931/43200
dec: spi=c34bb752 esp=aes key=16 3c5ceeff3cac1eaa2702b5ccb713ab9b
ah=sha1 key=20 5903e358b3d8938ee64f0412887a0fe741ccb105
enc: spi=b5bd4fe1 esp=aes key=16 8ae97a8abe24dae725d614d2a6efdcb0
ah=sha1 key=20 9ec200d9c0cef9e1b7cf76e05dbf344c70f53214
dec:pkts/bytes=0/0, enc:pkts/bytes=7/1064
proxyid=_OCVPN2-3.1 proto=0 sa=0 ref=2 serial=1 auto-negotiate
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-4.1 ver=2 serial=6 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=2 child_num=0 refcnt=11 ilast=19 olast=19 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-4.1 proto=0 sa=1 ref=2 serial=7 auto-negotiate
src: 0:10.1.100.0-10.1.100.255:0
dst: 0:172.16.101.0-172.16.101.255:0
SA: ref=3 options=18627 type=00 soft=0 mtu=1438 expire=42911/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42931/43200
dec: spi=c34bb750 esp=aes key=16 8c9844a8bcd3fda6c7bd8a4f2ec81ef1
ah=sha1 key=20 680c7144346f5b52126cbad9f325821b048c7192
enc: spi=f2d1f2d4 esp=aes key=16 f9625fc8590152829eb39eecab3a3999
ah=sha1 key=20 5df8447416da541fa54dde9fa3e5c35fbfc4723f
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
proxyid=_OCVPN2-4.1 proto=0 sa=0 ref=2 serial=1 auto-negotiate
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-3.2 ver=2 serial=3 172.16.200.1:0->172.16.200.199:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=2 child_num=0 refcnt=11 ilast=6 olast=6 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-3.2 proto=0 sa=1 ref=2 serial=8 auto-negotiate
src: 0:10.2.100.0-10.2.100.255:0
dst: 0:192.168.5.0-192.168.5.255:0
SA: ref=3 options=18627 type=00 soft=0 mtu=1438 expire=42923/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
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life: type=01 bytes=0/0 timeout=42930/43200
dec: spi=c34bb753 esp=aes key=16 58ddfad9a3699f1c49f3a9f369145c28
ah=sha1 key=20 e749c7e6a7aaff119707c792eb73cd975127873b
enc: spi=b5bd4fe2 esp=aes key=16 8f2366e653f5f9ad6587be1ce1905764
ah=sha1 key=20 5347bf24e51219d483c0f7b058eceab202026204
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
proxyid=_OCVPN2-3.2 proto=0 sa=0 ref=2 serial=1 auto-negotiate
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-4.2 ver=2 serial=5 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=2 child_num=0 refcnt=11 ilast=17 olast=17 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-4.2 proto=0 sa=1 ref=2 serial=7 auto-negotiate
src: 0:10.2.100.0-10.2.100.255:0
dst: 0:172.16.102.0-172.16.102.255:0
SA: ref=3 options=18627 type=00 soft=0 mtu=1438 expire=42905/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42927/43200
dec: spi=c34bb751 esp=aes key=16 41449ee5ea43d3e1f80df05fc632cd44
ah=sha1 key=20 3ca2aea1c8764f35ccf987cdeca7cf6eb54331fb
enc: spi=f2d1f2d5 esp=aes key=16 9010dd57e502c6296b27a4649a45a6ba
ah=sha1 key=20 caf86a176ce04464221543f15fc3c63fc573b8ee
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
proxyid=_OCVPN2-4.2 proto=0 sa=0 ref=2 serial=1 auto-negotiate
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
l

Branch_1 # get router info routing-table all
Routing table for VRF=0
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default
S*
C
C
C
C
S
C
S
S
S

0.0.0.0/0 [10/0] via 172.16.200.254, port1
10.1.100.0/24 is directly connected, dmz
10.2.100.0/24 is directly connected, loop
11.101.1.0/24 is directly connected, wan1
11.102.1.0/24 is directly connected, wan2
192.168.5.0/24 [20/0] is directly connected, _OCVPN2-3.2
172.16.200.0/24 is directly connected, port1
172.16.101.0/24 [20/0] is directly connected, _OCVPN2-4.1
172.16.102.0/24 [20/0] is directly connected, _OCVPN2-4.2
192.168.4.0/24 [20/0] is directly connected, _OCVPN2-3.1
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Troubleshooting hub-spoke with ADVPN shortcut
l

Primary-Hub # diagnose vpn ocvpn status
Current State
Topology
Role
Server Status
Registration time
Poll time

l

Registered
Dual-Hub-Spoke
Primary-Hub
Up
Sat Mar 2 11:31:54 2019
Sat Mar 2 11:46:02 2019

Spoke1 # diagnose vpn ocvpn status
Current State
Topology
Role
Server Status
Registration time
Poll time

l

:
:
:
:
:
:

:
:
:
:
:
:

Registered
Dual-Hub-Spoke
Spoke
Up
Sat Mar 2 11:41:22 2019
Sat Mar 2 11:46:44 2019

Primary-Hub # diagnose vpn ocvpn show-members
Member: { "sn": "FG900D3915800083", "ip_v4": "172.16.200.4", "port": 500, "slot": 0,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "172.16.101.0\/255.255.255.0" ], "ip_
range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"172.16.102.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "name": "PrimaryHub", "topology_role": "primary_hub", "eap": "disable", "auto_discovery": "enable" }
Member: { "sn": "FG100D3G15828488", "ip_v4": "172.16.200.2", "port": 500, "slot": 1,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "172.16.101.0\/255.255.255.0" ], "ip_
range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"172.16.102.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "name": "SecondaryHub", "topology_role": "secondary_hub", "eap": "disable", "auto_discovery": "enable" }
Member: { "sn": "FG100D3G15801621", "ip_v4": "172.16.200.1", "port": 500, "slot": 1000,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "10.1.100.0\/255.255.255.0" ], "ip_
range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"10.2.100.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "name": "Spoke1",
"topology_role": "spoke" }
Member: { "sn": "FGT51E3U16001314", "ip_v4": "172.16.200.3", "port": 500, "slot": 1001,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "192.168.4.0\/255.255.255.0" ], "ip_
range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"192.168.5.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "name": "Spoke2",
"topology_role": "spoke" }

l

Primary-Hub # diagnose vpn ocvpn show-meta
Topology
License
Members
Max-free

l

::
::
::
::

auto
full
4
3

Primary-Hub # diagnose vpn ocvpn show-overlays
QA
PM

l

Spoke1 # diagnose vpn tunnel list
list all ipsec tunnel in vd 0
-----------------------------------------------------name=_OCVPN2-0.0 ver=2 serial=6 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
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bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=11 ilast=0 olast=0 ad=r/2
stat: rxp=1 txp=34 rxb=152 txb=2856
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=46
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-0.0 proto=0 sa=1 ref=2 serial=1 auto-negotiate adr
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=1a227 type=00 soft=0 mtu=1438 expire=42895/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42901/43200
dec: spi=048477c7 esp=aes key=16 240e064c0f1c980ca31980b9e7605c9d
ah=sha1 key=20 6ff022cbebcaff4c5de62eefb2e6180c40a3adb2
enc: spi=dfcffa86 esp=aes key=16 862208de164a02af377756c2bcabd588
ah=sha1 key=20 af6e54781fd42d7a2ba2119ec95d0f95629c8448
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
-----------------------------------------------------name=_OCVPN2-1.0 ver=2 serial=8 172.16.200.1:0->172.16.200.2:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=10 ilast=934 olast=934 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=20000ms retry=3 count=0 seqno=1
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-1.0 proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-0.1 ver=2 serial=5 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=11 ilast=12 olast=12 ad=r/2
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=46
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-0.1 proto=0 sa=1 ref=2 serial=1 auto-negotiate adr
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=1a227 type=00 soft=0 mtu=1438 expire=42895/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42901/43200
dec: spi=048477c8 esp=aes key=16 701ec608767f4988b76c2f662464e654
ah=sha1 key=20 93c65d106dc610d7ee3f04487f08601a9e00ffdd
enc: spi=dfcffa87 esp=aes key=16 02b2d04dce3d81ebab69e128d45cb7ca
ah=sha1 key=20 4a9283847f852c83a75691fad44d07d8409a2267
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
-----------------------------------------------------name=_OCVPN2-1.1 ver=2 serial=7 172.16.200.1:0->172.16.200.2:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=10 ilast=934 olast=934 ad=/0
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stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=20000ms retry=3 count=0 seqno=1
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-1.1 proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
l

Spoke1 # get router info routing-table all
Routing table for VRF=0
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default
S*
C
C
C
C
S
C
S
S
S

l

0.0.0.0/0 [10/0] via 172.16.200.254, port1
10.1.100.0/24 is directly connected, dmz
10.2.100.0/24 is directly connected, loop
11.101.1.0/24 is directly connected, wan1
11.102.1.0/24 is directly connected, wan2
172.16.102.0/24 [20/0] is directly connected, _OCVPN2-0.1
172.16.200.0/24 is directly connected, port1
172.16.101.0/24 [20/0] is directly connected, _OCVPN2-0.0
192.168.4.0/24 [20/0] is directly connected, _OCVPN2-0.0
192.168.5.0/24 [20/0] is directly connected, _OCVPN2-0.1

Generate traffic from spoke1 to spoke2 to trigger the ADVPN shortcut and check the VPN tunnel and routing-table
again on spoke1.
branch1 # diagnose vpn tunnel list
list all ipsec tunnel in vd 0
-----------------------------------------------------name=_OCVPN2-0.0_0 ver=2 serial=a 172.16.200.1:0->172.16.200.3:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/720 options
[02d0]=create_dev no-sysctl rgwy-chg frag-rfc accept_traffic=1
parent=_OCVPN2-0.0 index=0
proxyid_num=1 child_num=0 refcnt=14 ilast=0 olast=0 ad=r/2
stat: rxp=7 txp=7 rxb=1064 txb=588
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-0.0 proto=0 sa=1 ref=2 serial=1 auto-negotiate add-route adr
src: 0:10.1.100.0-10.1.100.255:0
dst: 0:192.168.4.0-192.168.4.255:0
SA: ref=3 options=1a227 type=00 soft=0 mtu=1438 expire=43180/0B replaywin=2048
seqno=8 esn=0 replaywin_lastseq=00000008 itn=0 qat=0
life: type=01 bytes=0/0 timeout=43187/43200
dec: spi=048477c9 esp=aes key=16 27c35d53793013ef24cf887561e9f313
ah=sha1 key=20 2c8cfd328c3b29104db0ca74a00c6063f46cafe4
enc: spi=fb9e13fd esp=aes key=16 9d0d3bf6c84b7ddaf9d9196fe74002ed
ah=sha1 key=20 d1f541db787dea384c6a4df16fc228abeb7ae334
dec:pkts/bytes=7/588, enc:pkts/bytes=7/1064
-----------------------------------------------------name=_OCVPN2-0.0 ver=2 serial=6 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
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frag-rfc

accept_traffic=1

proxyid_num=1 child_num=1 refcnt=12 ilast=7 olast=7 ad=r/2
stat: rxp=2 txp=35 rxb=304 txb=2940
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=65
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-0.0 proto=0 sa=1 ref=2 serial=1 auto-negotiate adr
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=1a227 type=00 soft=0 mtu=1438 expire=42500/0B replaywin=2048
seqno=2 esn=0 replaywin_lastseq=00000002 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42901/43200
dec: spi=048477c7 esp=aes key=16 240e064c0f1c980ca31980b9e7605c9d
ah=sha1 key=20 6ff022cbebcaff4c5de62eefb2e6180c40a3adb2
enc: spi=dfcffa86 esp=aes key=16 862208de164a02af377756c2bcabd588
ah=sha1 key=20 af6e54781fd42d7a2ba2119ec95d0f95629c8448
dec:pkts/bytes=1/84, enc:pkts/bytes=1/152
-----------------------------------------------------name=_OCVPN2-1.0 ver=2 serial=8 172.16.200.1:0->172.16.200.2:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=10 ilast=1328 olast=1328 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=20000ms retry=3 count=0 seqno=1
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-1.0 proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-0.1 ver=2 serial=5 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=11 ilast=5 olast=5 ad=r/2
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=66
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-0.1 proto=0 sa=1 ref=2 serial=1 auto-negotiate adr
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=1a227 type=00 soft=0 mtu=1438 expire=42500/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42901/43200
dec: spi=048477c8 esp=aes key=16 701ec608767f4988b76c2f662464e654
ah=sha1 key=20 93c65d106dc610d7ee3f04487f08601a9e00ffdd
enc: spi=dfcffa87 esp=aes key=16 02b2d04dce3d81ebab69e128d45cb7ca
ah=sha1 key=20 4a9283847f852c83a75691fad44d07d8409a2267
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
-----------------------------------------------------name=_OCVPN2-1.1 ver=2 serial=7 172.16.200.1:0->172.16.200.2:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=10 ilast=1328 olast=1328 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
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dpd: mode=on-idle on=0 idle=20000ms retry=3 count=0 seqno=1
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-1.1 proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0

Routing table for VRF=0
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default
S*
C
C
C
C
S
C
S
S
S
l

0.0.0.0/0 [10/0] via 172.16.200.254, port1
10.1.100.0/24 is directly connected, dmz
10.2.100.0/24 is directly connected, loop
11.101.1.0/24 is directly connected, wan1
11.102.1.0/24 is directly connected, wan2
172.16.102.0/24 [20/0] is directly connected, _OCVPN2-0.1
172.16.200.0/24 is directly connected, port1
172.16.101.0/24 [20/0] is directly connected, _OCVPN2-0.0
192.168.4.0/24 [15/0] via 172.16.200.3, _OCVPN2-0.0_0
192.168.5.0/24 [20/0] is directly connected, _OCVPN2-0.1

Simulate the primary hub being unavailable where all spokes' dialup VPN tunnels will switch to the secondary hub,
to check VPN tunnel status and routing-table.
list all ipsec tunnel in vd 0
-----------------------------------------------------name=_OCVPN2-0.0 ver=2 serial=6 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=10 ilast=25 olast=25 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=20000ms retry=3 count=0 seqno=82
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-0.0 proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-1.0 ver=2 serial=8 172.16.200.1:0->172.16.200.2:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=11 ilast=14 olast=14 ad=r/2
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=9
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-1.0 proto=0 sa=1 ref=2 serial=1 auto-negotiate adr
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=1a227 type=00 soft=0 mtu=1438 expire=42723/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42898/43200

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

921

VPN

dec: spi=048477cd esp=aes key=16 9bb363a32378b5897cd42890c92df811
ah=sha1 key=20 2ed40583b9544e37867349b4adc7c013024d7e17
enc: spi=f345fb42 esp=aes key=16 3ea31dff3310b245700a131db4565851
ah=sha1 key=20 522862dfb232514b845e436133b148da0e67b7c4
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
-----------------------------------------------------name=_OCVPN2-0.1 ver=2 serial=5 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=10 ilast=19 olast=19 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=20000ms retry=3 count=0 seqno=83
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-0.1 proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-1.1 ver=2 serial=7 172.16.200.1:0->172.16.200.2:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=11 ilast=12 olast=12 ad=r/2
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=9
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-1.1 proto=0 sa=1 ref=2 serial=1 auto-negotiate adr
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=1a227 type=00 soft=0 mtu=1438 expire=42728/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42902/43200
dec: spi=048477cf esp=aes key=16 b6f0ca7564abcd8559b5b0ebb3fd04c1
ah=sha1 key=20 4130d040554b39daca72adac7583b9cc83cce3c8
enc: spi=f345fb43 esp=aes key=16 727582f20fcedff884ba693ed2164bcd
ah=sha1 key=20 b0a625803fde701ed9d28d256079e908954b7fc8
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0

Routing table for VRF=0
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default
S*
C
C
C
C
S
C
S
S

0.0.0.0/0 [10/0] via 172.16.200.254, port1
10.1.100.0/24 is directly connected, dmz
10.2.100.0/24 is directly connected, loop
11.101.1.0/24 is directly connected, wan1
11.102.1.0/24 is directly connected, wan2
172.16.102.0/24 [21/0] is directly connected, _OCVPN2-1.1
172.16.200.0/24 is directly connected, port1
172.16.101.0/24 [21/0] is directly connected, _OCVPN2-1.0
192.168.4.0/24 [21/0] is directly connected, _OCVPN2-1.0
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S

192.168.5.0/24 [21/0] is directly connected, _OCVPN2-1.1

Troubleshooting hub-spoke with inter-overlay source NAT
l

Primary-Hub # diagnose vpn ocvpn status
Current State
Topology
Role
Server Status
Registration time
Update time
Poll time

l

Registered
Dual-Hub-Spoke
Primary-Hub
Up
Sat Mar 2 11:31:54 2019
Sat Mar 2 13:57:05 2019
Sat Mar 2 14:03:31 2019

Spoke1 # diagnose vpn ocvpn status
Current State
Topology
Role
Server Status
Registration time
Poll time

l

:
:
:
:
:
:
:

:
:
:
:
:
:

Registered
Dual-Hub-Spoke
Spoke
Up
Sat Mar 2 13:58:01 2019
Sat Mar 2 14:04:22 2019

Primary-Hub # diagnose vpn ocvpn show-members
Member: { "sn": "FG900D3915800083", "ip_v4": "172.16.200.4", "port": 500, "slot": 0,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "172.16.101.0\/255.255.255.0" ], "ip_
range": "172.16.101.100-172.16.101.200" }, { "id": 1, "name": "PM", "subnets": [
"172.16.102.0\/255.255.255.0" ], "ip_range": "172.16.102.100-172.16.102.200" } ],
"name": "Primary-Hub", "topology_role": "primary_hub", "eap": "disable", "auto_
discovery": "enable" }
Member: { "sn": "FG100D3G15828488", "ip_v4": "172.16.200.2", "port": 500, "slot": 1,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "172.16.101.0\/255.255.255.0" ], "ip_
range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"172.16.102.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "name": "SecondaryHub", "topology_role": "secondary_hub", "eap": "disable", "auto_discovery": "enable" }
Member: { "sn": "FGT51E3U16001314", "ip_v4": "172.16.200.3", "port": 500, "slot": 1001,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "192.168.4.0\/255.255.255.0" ], "ip_
range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"192.168.5.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "name": "Spoke2",
"topology_role": "spoke" }
Member: { "sn": "FG100D3G15801621", "ip_v4": "172.16.200.1", "port": 500, "slot": 1000,
"overlay": [ { "id": 0, "name": "QA", "subnets": [ "10.1.100.0\/255.255.255.0" ], "ip_
range": "0.0.0.0-0.0.0.0" }, { "id": 1, "name": "PM", "subnets": [
"10.2.100.0\/255.255.255.0" ], "ip_range": "0.0.0.0-0.0.0.0" } ], "name": "Spoke1",
"topology_role": "spoke" }

l

Primary-Hub # diagnose vpn ocvpn show-meta
Topology
License
Members
Max-free

l

::
::
::
::

auto
full
4
3

Primary-Hub # diagnose vpn ocvpn show-overlays
QA
PM
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l

Spoke1 # diagnose vpn tunnel list
list all ipsec tunnel in vd 0
-----------------------------------------------------name=_OCVPN2-0.0 ver=2 serial=c 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=3 child_num=0 refcnt=13 ilast=17 olast=17 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=29
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-0.0 proto=0 sa=1 ref=2 serial=1 auto-negotiate
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=18227 type=00 soft=0 mtu=1438 expire=42299/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42899/43200
dec: spi=0484795d esp=aes key=16 10eeb76fadd49f00c333350d83509095
ah=sha1 key=20 971bde5dcfca7e52fd1573cb3489e9c855f6154e
enc: spi=dfcffaaa esp=aes key=16 d07a4dd683ee093af2dca9485aa436eb
ah=sha1 key=20 65369be35d5ecad8cae63557318419cd6005c230
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
proxyid=_OCVPN2-0.0_nat proto=0 sa=1 ref=2 serial=3 auto-negotiate
src: 0:172.16.101.101-172.16.101.101:0
dst: 0:0.0.0.0-255.255.255.255:0
SA: ref=3 options=18627 type=00 soft=0 mtu=1438 expire=42303/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42898/43200
dec: spi=04847961 esp=aes key=16 ea181036b02e8bc8711fb520b3e98a60
ah=sha1 key=20 b3c449d96d5d3f090975087a62447f6918ce7930
enc: spi=dfcffaac esp=aes key=16 f7ea5e42e9443698e6b8b32161ace40e
ah=sha1 key=20 a7e36dd1ec0bdb6eff0aa66e442707427400c700
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
proxyid=_OCVPN2-0.0_nat proto=0 sa=0 ref=2 serial=2 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-1.0 ver=2 serial=e 172.16.200.1:0->172.16.200.2:0 dst_mtu=0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=2 child_num=0 refcnt=10 ilast=599 olast=599 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-1.0 proto=0 sa=0 ref=2 serial=1 auto-negotiate
src: 0:10.1.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
proxyid=_OCVPN2-1.0_nat proto=0 sa=0 ref=2 serial=2 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-0.1 ver=2 serial=b 172.16.200.1:0->172.16.200.4:0 dst_mtu=1500
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
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proxyid_num=3 child_num=0 refcnt=13 ilast=17 olast=17 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=29
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-0.1 proto=0 sa=1 ref=2 serial=1 auto-negotiate
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=18227 type=00 soft=0 mtu=1438 expire=42297/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42897/43200
dec: spi=0484795e esp=aes key=16 106eaa95a2be64b566e7d1ca0aa88f6a
ah=sha1 key=20 5dddfba7070b03d5a31931d41db06ff96e7bc542
enc: spi=dfcffaab esp=aes key=16 29c774dbd7e54464ee298c381e71a94e
ah=sha1 key=20 c3da7372789c0a53b3752e69baaba1a42d798820
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
proxyid=_OCVPN2-0.1_nat proto=0 sa=1 ref=2 serial=3 auto-negotiate
src: 0:172.16.102.101-172.16.102.101:0
dst: 0:0.0.0.0-255.255.255.255:0
SA: ref=3 options=18627 type=00 soft=0 mtu=1438 expire=42307/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42902/43200
dec: spi=04847962 esp=aes key=16 b7daa5807cfa86906592a012a9d2478f
ah=sha1 key=20 39c8bb4c9e3f1e9e451f22c58a172ff01155055d
enc: spi=dfcffaad esp=aes key=16 2ecc644def4cebe6b0c4b7729da43d8e
ah=sha1 key=20 469c6f319e83bd73468f55d430566afcd6215138
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
proxyid=_OCVPN2-0.1_nat proto=0 sa=0 ref=2 serial=2 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=_OCVPN2-1.1 ver=2 serial=d 172.16.200.1:0->172.16.200.2:0 dst_mtu=0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=2 child_num=0 refcnt=10 ilast=599 olast=599 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=_OCVPN2-1.1 proto=0 sa=0 ref=2 serial=1 auto-negotiate
src: 0:10.2.100.0/255.255.255.0:0
dst: 0:0.0.0.0/0.0.0.0:0
proxyid=_OCVPN2-1.1_nat proto=0 sa=0 ref=2 serial=2 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
l

Spoke1 # get router info routing-table all
Routing table for VRF=0
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default
S*
C

0.0.0.0/0 [10/0] via 172.16.200.254, port1
10.1.100.0/24 is directly connected, dmz
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C
C
C
S
C
C
S
C
S
S
l

10.2.100.0/24 is directly connected, loop
11.101.1.0/24 is directly connected, wan1
11.102.1.0/24 is directly connected, wan2
172.16.101.0/24 [20/0] is directly connected, _OCVPN2-0.1
172.16.101.101/32 is directly connected, _OCVPN2-0.1
172.16.200.0/24 is directly connected, port1
172.16.102.0/24 [20/0] is directly connected, _OCVPN2-0.0
172.16.102.101/32 is directly connected, _OCVPN2-0.0
192.168.4.0/24 [20/0] is directly connected, _OCVPN2-0.0
192.168.5.0/24 [20/0] is directly connected, _OCVPN2-0.1

Spoke1 # show firewall policy
..............................
edit 9
set name "_OCVPN2-1.1_nat"
set uuid 3f7a84b8-3d36-51e9-ee97-8f418c91e666
set srcintf "any"
set dstintf "_OCVPN2-1.1"
set srcaddr "all"
set dstaddr "_OCVPN2-1.1_remote_networks"
set action accept
set schedule "always"
set service "ALL"
set comments "Generated by OCVPN Cloud Service."
set nat enable
next
edit 12
set name "_OCVPN2-1.0_nat"
set uuid 3fafec98-3d36-51e9-80c0-5d99325bad83
set srcintf "any"
set dstintf "_OCVPN2-1.0"
set srcaddr "all"
set dstaddr "_OCVPN2-1.0_remote_networks"
set action accept
set schedule "always"
set service "ALL"
set comments "Generated by OCVPN Cloud Service."
set nat enable
next
.................................

IPsec Tunnels
The following topics provide information about IPsec Tunnels in FortiOS 6.2.0.
l
l
l
l
l
l
l

Represent multiple IPsec tunnels as a single interface on page 927
OSPF with IPsec VPN for network redundancy on page 928
GRE over IPsec on page 935
L2TP over IPsec on page 940
Policy-based IPsec tunnel on page 944
Per packet distribution and tunnel aggregation on page 951
IPsec VPN with external DHCP service on page 955
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For more information, see VXLAN over IPsec tunnel on page 1056.

Represent multiple IPsec tunnels as a single interface
Use this function to create a static aggregate interface using IPsec tunnels as members, with traffic load balanced
between the members. You can assign an IP address to the aggregate interface, dynamic routing can run on the
interface, and the interface can be a member interface in SD-WAN.
The supported load balancing algorithms are: L3, L4, round-robin (default), and redundant.

To configure multiple IPsec tunnels as a single interface :
1. Create a site to site VPN phase1 interface with net-device disabled:
config vpn ipsec phase1-interface
edit tunnel1
set interface port1
set net-device disable
set remote-gw 172.16.100.1
set psksecret sample
next
edit tunnel2
set interface port2
set net-device disable
set remote-gw 172.31.1.1
set psksecret sample
next
end

2. Configure IPsec aggregation:
config system ipsec-aggregate
edit agg1
set member tunnel1 tunnel2
next
end

3. Configure a firewall policy:
config firewall policy
edit 0
set srcaddr all
set srcintf port10
set dstaddr all
set dstintf agg1
set schedule always
set action accept
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set service ALL
next
end

4. Configure a static route:
config router static
edit 0
set device agg1
next
end

To debug the IPsec aggregation list:
#diagnose sys ipsec-aggregate list
agg1 algo=RR member=2 run_tally=2
members:
tunnel1
tunnel2

OSPF with IPsec VPN for network redundancy
This is a sample configuration of using OSPF with IPsec VPN to set up network redundancy. Route selection is based on
OSPF cost calculation. You can configure ECMP or primary/secondary routes by adjusting OSPF path cost.

Because the GUI can only complete part of the configuration, we recommend using the CLI.

To configure OSPF with IPsec VPN to achieve network redundancy using the CLI:
1. Configure the WAN interface and static route.
Each FortiGate has two WAN interfaces connected to different ISPs. The ISP1 link is for the primary FortiGate and
the IPS2 link is for the secondary FortiGate.
a. Configure HQ1.
config system interface
edit "port1"
set alias to_ISP1
set ip 172.16.200.1 255.255.255.0
next
edit "port2"
set alias to_ISP2
set ip 172.17.200.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.200.3
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set
next
edit 2
set
set
set
next
end

device "port1"

gateway 172.17.200.3
device "port2"
priority 100

b. Configure HQ2.
config system interface
edit "port25"
set alias to_ISP1
set ip 172.16.202.1 255.255.255.0
next
edit "port26"
set alias to_ISP2
set ip 172.17.202.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.202.2
set device "port25"
next
edit 2
set gateway 172.17.202.2
set device "port26"
set priority 100
next
end

2. Configure the internal (protected subnet) interface.
a. Configure HQ1.
config system interface
edit "dmz"
set ip 10.1.100.1 255.255.255.0
next
end

b. Configure HQ2.
config system interface
edit "port9"
set ip 172.16.101.1 255.255.255.0
next
end

3. Configure IPsec phase1-interface and phase-2 interface. On each FortiGate, configure two IPsec tunnels: a primary
and a secondary.
a. Configure HQ1.
config vpn ipsec phase1-interface
edit "pri_HQ2"
set interface "port1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set psksecret sample1
next
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edit "sec_HQ2"
set interface "port2"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.17.202.1
set psksecret sample2
next
end
config vpn ipsec phase2-interface
edit "pri_HQ2"
set phase1name "pri_HQ2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
edit "sec_HQ2"
set phase1name "sec_HQ2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

b. Configure HQ2.
config vpn ipsec phase1-interface
edit "pri_HQ1"
set interface "port25"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.200.1
set psksecret sample1
next
edit "sec_HQ1"
set interface "port26"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.17.200.1
set psksecret sample2
next
end
config vpn ipsec phase2-interface
edit "pri_HQ1"
set phase1name "pri_HQ1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
edit "sec_HQ1"
set phase1name "sec_HQ1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end
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4. Configure an inbound and outbound firewall policy for each IPsec tunnel.
a. Configure HQ1.
config firewall policy
edit 1
set name "pri_inbound"
set srcintf "pri_HQ2"
set dstintf "dmz"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "pri_outbound"
set srcintf "dmz"
set dstintf "pri_HQ2"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 3
set name "sec_inbound"
set srcintf "sec_HQ2"
set dstintf "dmz"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 4
set name "sec_outbound"
set srcintf "dmz"
set dstintf "sec_HQ2"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
end

b. Configure HQ2.
config firewall policy
edit 1
set name "pri_inbound"
set srcintf "pri_HQ1"
set dstintf "port9"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
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edit 2
set
set
set
set
set
set
set
set
next
edit 3
set
set
set
set
set
set
set
set
next
edit 4
set
set
set
set
set
set
set
set
next
end

name "pri_outbound"
srcintf "port9"
dstintf "pri_HQ1"
srcaddr "10.1.100.0"
dstaddr "172.16.101.0"
action accept
schedule "always"
service "ALL"

name "sec_inbound"
srcintf "sec_HQ1"
dstintf "port9"
srcaddr "10.1.100.0"
dstaddr "172.16.101.0"
action accept
schedule "always"
service "ALL"

name "sec_outbound"
srcintf "port9"
dstintf "sec_HQ1"
srcaddr "172.16.101.0"
dstaddr "10.1.100.0"
action accept
schedule "always"
service "ALL"

5. Assign an IP address to the IPsec tunnel interface.
a. Configure HQ1.
config system interface
edit "pri_HQ2"
set ip 10.10.10.1 255.255.255.255
set remote-ip 10.10.10.2 255.255.255.255
next
edit "sec_HQ2"
set ip 10.10.11.1 255.255.255.255
set remote-ip 10.10.11.2 255.255.255.255
next
end

b. Configure HQ2.
config system interface
edit "pri_HQ1"
set ip 10.10.10.2 255.255.255.255
set remote-ip 10.10.10.1 255.255.255.255
next
edit "sec_HQ1"
set ip 10.10.11.2 255.255.255.255
set remote-ip 10.10.11.1 255.255.255.255
next
end
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6. Configure OSPF.
a. Configure HQ1.
config router ospf
set router-id 1.1.1.1
config area
edit 0.0.0.0
next
end
config ospf-interface
edit "pri_HQ2"
set interface "pri_HQ2"
set cost 10
set network-type point-to-point
next
edit "sec_HQ2"
set interface "sec_HQ2"
set cost 20
set network-type point-to-point
next
end
config network
edit 1
set prefix 10.10.10.0 255.255.255.0
next
edit 2
set prefix 10.10.11.0 255.255.255.0
next
edit 3
set prefix 10.1.100.0 255.255.255.0
next
end
end

b. Configure HQ2.
config router ospf
set router-id 2.2.2.2
config area
edit 0.0.0.0
next
end
config ospf-interface
edit "pri_HQ1"
set interface "pri_HQ1"
set cost 10
set network-type point-to-point
next
edit "sec_HQ1"
set interface "sec_HQ1"
set cost 20
set network-type point-to-point
next
end
config network
edit 1
set prefix 10.10.10.0 255.255.255.0
next
edit 2
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set prefix 10.10.11.0 255.255.255.0
next
edit 3
set prefix 172.16.101.0 255.255.255.0
next
end
end

To check VPN and OSPF states using diagnose and get commands:
1. Run the HQ1 # diagnose vpn ike gateway list command. The system should return the following:
vd: root/0
name: pri_HQ2
version: 1
interface: port1 11
addr: 172.16.200.1:500 -> 172.16.202.1:500
virtual-interface-addr: 10.10.10.1 -> 10.10.10.2
created: 1024s ago
IKE SA: created 1/1 established 1/1 time 0/0/0 ms
IPsec SA: created 1/3 established 1/2 time 0/5/10 ms
id/spi: 45 d184777257b4e692/e2432f834aaf5658 direction: responder status: established
1024-1024s ago = 0ms proposal: aes128-sha256 key: 9ed41fb06c983344189538046f5ad204 lifetime/rekey: 86400/85105 DPD sent/recv: 00000003/00000000
vd: root/0
name: sec_HQ2
version: 1
interface: port2 12
addr: 172.17.200.1:500 -> 172.17.202.1:500
virtual-interface-addr: 10.10.11.1 -> 10.10.11.2
created: 346s ago
IKE SA: created 1/1 established 1/1 time 0/0/0 ms
IPsec SA: created 1/1 established 1/1 time 0/10/15 ms
id/spi: 48 d909ed68636b1ea5/163015e73ea050b8 direction: initiator status: established
0-0s ago = 0ms proposal: aes128-sha256 key: b9e93c156bdf4562-29db9fbafa256152
lifetime/rekey: 86400/86099 DPD sent/recv: 00000000/00000000

2. Run the HQ1 # diagnose vpn tunnel list command. The system should return the following:
list all ipsec tunnel in vd 0
name=pri_HQ2 ver=1 serial=1 172.16.200.1:0->172.16.202.1:0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=14 ilast=2 olast=2 ad=/0
stat: rxp=102 txp=105 rxb=14064 txb=7816
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=3
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=pri_HQ2 proto=0 sa=1 ref=2 serial=1 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0 dst: 0:0.0.0.0/0.0.0.0:0 SA: ref=3 options=18227 type=00
soft=0 mtu=1438 expire=42254/0B replaywin=2048
seqno=6a esn=0 replaywin_lastseq=00000067 itn=0
life: type=01 bytes=0/0 timeout=42932/43200 dec: spi=1071b4ee esp=aes key=16
032036b24a4ec88da63896b86f3a01db
ah=sha1 key=20 3962933e24c8da21c65c13bc2c6345d643199cdf
enc: spi=ec89b7e3 esp=aes key=16 92b1d85ef91faf695fca05843dd91626
ah=sha1 key=20 2de99d1376506313d9f32df6873902cf6c08e454
dec:pkts/bytes=102/7164, enc:pkts/bytes=105/14936
name=sec_HQ2 ver=1 serial=2 172.17.200.1:0->172.17.202.1:0
bound_if=12 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_dev
frag-rfc accept_traffic=1
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proxyid_num=1 child_num=0 refcnt=14 ilast=3 olast=0 ad=/0
stat: rxp=110 txp=114 rxb=15152 txb=8428
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=3
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=sec_HQ2 proto=0 sa=1 ref=2 serial=1 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0 dst: 0:0.0.0.0/0.0.0.0:0 SA: ref=3 options=18227 type=00
soft=0 mtu=1438 expire=42927/0B replaywin=2048
seqno=2 esn=0 replaywin_lastseq=00000002 itn=0
life: type=01 bytes=0/0 timeout=42931/43200 dec: spi=1071b4ef esp=aes key=16
bcdcabdb7d1c7c695d1f2e0f5441700a
ah=sha1 key=20 e7a0034589f82eb1af41efd59d0b2565fef8d5da
enc: spi=ec89b7e4 esp=aes key=16 234240b69e61f6bdee2b4cdec0f33bea
ah=sha1 key=20 f9d4744a84d91e5ce05f5984737c2a691a3627e8
dec:pkts/bytes=1/68, enc:pkts/bytes=1/136

3. Run the HQ1 # get router info ospf neighbor command. The system should return the following:
OSPF process 0, VRF 0:
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 1. Full/ - 00:00:37 10.10.10.2 pri_HQ2
2.2.2.2 1. Full/ - 00:00:32 10.10.11.2 sec_HQ2

4. Run the HQ1 # get router info routing-table ospf command. The system should return the following:
Routing table for VRF=0
O 172.16.101.0/24 [110/20] via 10.10.10.2, pri_HQ2 , 00:03:21

In case the primary tunnel is down after route convergence.
5. Run the HQ1 # get router info routing-table ospf command. The system should return the following:
Routing table for VRF=0
O 172.16.101.0/24 [110/110] via 10.10.11.2, sec_HQ2 , 00:00:01

GRE over IPsec
This is an example of GRE over an IPsec tunnel using a static route over GRE tunnel and tunnel-mode in the
phase2-interface settings.

To configure GRE over an IPsec tunnel:
1. Enable subnet overlapping at both HQ1 and HQ2.
config system settings
set allow-subnet-overlap enable
end
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2. Configure the WAN interface and static route.
a. HQ1.
config system interface
edit "port1"
set ip 172.16.200.1 255.255.255.0
next
edit "dmz"
set ip 10.1.100.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.200.3
set device "port1"
next
end

b. HQ2.
config system interface
edit "port25"
set ip 172.16.202.1 255.255.255.0
next
edit "port9"
set ip 172.16.101.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.202.2
set device "port25"
next
end

3. Configure IPsec phase1-interface and phase2-interface.
a. HQ1.
config vpn ipsec phase1-interface
edit "greipsec"
set interface "port1"
set peertype any
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set psksecret sample
next
end
config vpn ipsec phase2-interface
edit "greipsec"
set phase1name "greipsec"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set protocol 47
next
end

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

936

VPN
b. HQ2.
config vpn ipsec phase1-interface
edit "greipsec"
set interface "port25"
set peertype any
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.200.1
set psksecret sample
next
end
config vpn ipsec phase2-interface
edit "greipsec"
set phase1name "greipsec"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set protocol 47
next
end

4. Configure IPsec tunnel interface IP address.
a. HQ1.
config system interface
edit "greipsec"
set ip 10.10.10.1 255.255.255.255
set remote-ip 10.10.10.2 255.255.255.255
next
end

b. HQ2.
config system interface
edit "greipsec"
set ip 10.10.10.2 255.255.255.255
set remote-ip 10.10.10.1 255.255.255.255
next
end

5. Configure the GRE tunnel.
a. HQ1.
config system gre-tunnel
edit "gre_to_HQ2"
set interface "greipsec"
set remote-gw 10.10.10.2
set local-gw 10.10.10.1
next
end

b. HQ2.
config system gre-tunnel
edit "gre_to_HQ1"
set interface "greipsec"
set remote-gw 10.10.10.1
set local-gw 10.10.10.2
next
end
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6. Configure the firewall policy.
a. HQ1.
config firewall policy
edit 1
set srcintf "dmz"
set dstintf "gre_to_HQ2"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set srcintf "gre_to_HQ2"
set dstintf "dmz"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 3
set srcintf "greipsec"
set dstintf "greipsec"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
end

b. HQ2.
config firewall policy
edit 1
set srcintf "port9"
set dstintf "gre_to_HQ1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set srcintf "gre_to_HQ1"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 3
set srcintf "greipsec"
set dstintf "greipsec"
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set
set
set
set
set

srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"

next
end

7. Configure the static route.
a. HQ1.
config router static
edit 2
set dst 172.16.101.0 255.255.255.0
set device "gre_to_HQ2"
next
end

b. HQ2.
config router static
edit 2
set dst 10.1.100.0 255.255.255.0
set device "gre_to_HQ1"
next
end

To view the VPN tunnel list on HQ1:
diagnose vpn tunnel list
list all ipsec tunnel in vd 0
---name=greipsec ver=1 serial=1 172.16.200.1:0->172.16.202.1:0
bound_if=5 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/16 options[0010]=create_dev
proxyid_num=1 child_num=0 refcnt=12 ilast=19 olast=861 ad=/0
stat: rxp=347 txp=476 rxb=58296 txb=51408
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=8
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=greipsec proto=47 sa=1 ref=2 serial=2
src: 47:0.0.0.0/0.0.0.0:0
dst: 47:0.0.0.0/0.0.0.0:0
SA: ref=3 options=10226 type=00 soft=0 mtu=1438 expire=41689/0B replaywin=2048
seqno=15c esn=0 replaywin_lastseq=0000015c itn=0
life: type=01 bytes=0/0 timeout=42898/43200
dec: spi=9897bd09 esp=aes key=16 5a60e67bf68379309715bd83931680bf
ah=sha1 key=20 ff35a329056d0d506c0bfc17ef269978a4a57dd3
enc: spi=e362f336 esp=aes key=16 5574acd8587c5751a88950e1bf8fbf57
ah=sha1 key=20 d57ec76ac3c543ac89b2e4d0545518aa2d06669b
dec:pkts/bytes=347/37476, enc:pkts/bytes=347/58296

To view the static routing table on HQ1:
get router info routing-table static
Routing table for VRF=0
S*
0.0.0.0/0 [10/0] via 172.16.200.3, port1
S
172.16.101.0/24 [10/0] is directly connected, gre_to_HQ2
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L2TP over IPsec
This is an example of L2TP over IPsec.
This example uses a locally defined user for authentication, a Windows PC or Android tablet as the client, and
net-device is set to enable in the phase1-interface settings. If net-device is set to disable, only one device
can establish an L2TP over IPsec tunnel behind the same NAT device.

To configure L2TP over an IPsec tunnel using the GUI:
1. Go to VPN > IPsec Wizard.

2. Enter a VPN Name. In this example, L2tpoIPsec.
3. configure the following settings for VPN Setup:
a. For Template Type, select Remote Access.
b. For Remote Device Type, select Native and Windows Native.
c. Click Next.
4. Configure the following settings for Authentication:
a. For Incoming Interface, select port9.
b. For Authentication Method, select Pre-shared Key.
c. In the Pre-shared Key field, enter your-psk as the key.
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d. For User Group, select L2tpusergroup
e. Click Next.
5. Configure the following settings for Policy & Routing:
a. From the Local Interface dropdown menu, select port10.
b. Configure the Local Address as 172.16.101.0.
c. Configure the Client Address Range as 10.10.10.1-10.10.10.100.
d. Leave the Subnet Mask at its default value.
e. Click Create.

To configure L2TP over an IPsec tunnel using the CLI:
1. Configure the WAN interface and static route on HQ.
config system interface
edit "port9"
set alias "WAN"
set ip 22.1.1.1 255.255.255.0
next
edit "port10"
set alias "Internal"
set ip 172.16.101.1 255.255.255.0
next
end
config router static
edit 1
set gateway 22.1.1.2
set device "port9"
next
end

2. Configure IPsec phase1-interface and phase2-interface on HQ.
config vpn ipsec phase1-interface
edit "L2tpoIPsec"
set type dynamic
set interface "port9"
set peertype any
set proposal aes256-md5 3des-sha1 aes192-sha1
set dpd on-idle
set dhgrp 2
set net-device enable
set psksecret sample
set dpd-retryinterval 60
next
end
config vpn ipsec phase2-interface
edit "L2tpoIPsec"
set phase1name "L2tpoIPsec"
set proposal aes256-md5 3des-sha1 aes192-sha1
set pfs disable
set encapsulation transport-mode
set l2tp enable
next
end
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3. Configure a user and user group on HQ.
config user local
edit "usera"
set type password
set passwd usera
next
end
config user group
edit "L2tpusergroup"
set member "usera"
next
end

4. Configure L2TP on HQ.
config vpn l2tp
set status enable
set eip 10.10.10.100
set sip 10.10.10.1
set usrgrp "L2tpusergroup"
end

5. Configure a firewall address that is applied in L2TP settings to assign IP addresses to clients once the L2TP tunnel
is established.
config firewall address
edit "L2TPclients"
set type iprange
set start-ip 10.10.10.1
set end-ip 10.10.10.100
next
end

6. Configure a firewall policy.
config firewall policy
edit 1
set name "Bridge_IPsec_port9_for_l2tp negotiation"
set srcintf "L2tpoIPsec"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "L2TP"
next
edit 2
set srcintf "L2tpoIPsec"
set dstintf "port10"
set srcaddr "L2TPclients"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end
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To view the VPN tunnel list on HQ:
diagnose vpn tunnel list
list all ipsec tunnel in vd 0
---name=L2tpoIPsec_0 ver=1 serial=8 22.1.1.1:0->10.1.100.15:0
bound_if=4 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/216 options[00d8]=npu
create_dev no-sysctl rgwy-chg
parent=L2tpoIPsec index=0
proxyid_num=1 child_num=0 refcnt=13 ilast=0 olast=0 ad=/0
stat: rxp=470 txp=267 rxb=57192 txb=12679
dpd: mode=on-idle on=1 idle=60000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=L2tpoIPsec proto=17 sa=1 ref=3 serial=1 transport-mode add-route
src: 17:22.1.1.1-22.1.1.1:1701
dst: 17:10.1.100.15-10.1.100.15:0
SA: ref=3 options=1a6 type=00 soft=0 mtu=1470 expire=2339/0B replaywin=2048
seqno=10c esn=0 replaywin_lastseq=000001d6 itn=0
life: type=01 bytes=0/0 timeout=3585/3600
dec: spi=ca646443 esp=3des key=24 af62a0fffe85d3d534b5bfba29307aafc8bfda5c3f4650dc
ah=sha1 key=20 89b4b67688bed9be49fb86449bb83f8c8d8d7432
enc: spi=700d28a0 esp=3des key=24 5f68906eca8d37d853814188b9e29ac4913420a9c87362c9
ah=sha1 key=20 d37f901ffd0e6ee1e4fdccebc7fdcc7ad44f0a0a
dec:pkts/bytes=470/31698, enc:pkts/bytes=267/21744
npu_flag=00 npu_rgwy=10.1.100.15 npu_lgwy=22.1.1.1 npu_selid=6 dec_npuid=0 enc_npuid=0
---name=L2tpoIPsec_1 ver=1 serial=a 22.1.1.1:4500->22.1.1.2:64916
bound_if=4 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/472 options[01d8]=npu
create_dev no-sysctl rgwy-chg rport-chg
parent=L2tpoIPsec index=1
proxyid_num=1 child_num=0 refcnt=17 ilast=2 olast=2 ad=/0
stat: rxp=5 txp=4 rxb=592 txb=249
dpd: mode=on-idle on=1 idle=60000ms retry=3 count=0 seqno=0
natt: mode=keepalive draft=32 interval=10 remote_port=64916
proxyid=L2tpoIPsec proto=17 sa=1 ref=3 serial=1 transport-mode add-route
src: 17:22.1.1.1-22.1.1.1:1701
dst: 17:22.1.1.2-22.1.1.2:0
SA: ref=3 options=1a6 type=00 soft=0 mtu=1454 expire=28786/0B replaywin=2048
seqno=5 esn=0 replaywin_lastseq=00000005 itn=0
life: type=01 bytes=0/0 timeout=28790/28800
dec: spi=ca646446 esp=aes key=32
ea60dfbad709b3c63917c3b7299520ff7606756ca15d2eb7cbff349b6562172e
ah=md5 key=16 2f2acfff0b556935d0aab8fc5725c8ec
enc: spi=0b514df2 esp=aes key=32
a8a92c2ed0e1fd7b6e405d8a6b9eb3be5eff573d80be3f830ce694917d634196
ah=md5 key=16 e426c33a7fe9041bdc5ce802760e8a3d
dec:pkts/bytes=5/245, enc:pkts/bytes=4/464
npu_flag=00 npu_rgwy=22.1.1.2 npu_lgwy=22.1.1.1 npu_selid=8 dec_npuid=0 enc_npuid=0

To view the L2TP VPN status:
diagnose debug enable
diagnose vpn l2tp status
-------
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HQ # Num of tunnels: 2
---Tunnel ID = 1 (local id), 42 (remote id) to 10.1.100.15:1701
control_seq_num = 2, control_rec_seq_num = 4,
last recv pkt = 2
Call ID = 1 (local id), 1 (remote id), serno = 0, dev=ppp1,
assigned ip = 10.10.10.2
data_seq_num = 0,
tx = 152 bytes (2), rx= 21179 bytes (205)
Tunnel ID = 3 (local id), 34183 (remote id) to 22.1.1.2:58825
control_seq_num = 2, control_rec_seq_num = 4,
last recv pkt = 2
Call ID = 3 (local id), 18820 (remote id), serno = 2032472593, dev=ppp2,
assigned ip = 10.10.10.3
data_seq_num = 0,
tx = 152 bytes (2), rx= 0 bytes (0)
-----VD 0: Startip = 10.10.10.1, Endip = 10.10.10.100
enforece-ipsec = false
----

Policy-based IPsec tunnel
This is an example of policy-based IPsec tunnel using site-to-site VPN between branch and HQ. HQ is the IPsec
concentrator.

Sample topology
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Sample configuration
To configure a policy-based IPsec tunnel using the GUI:
l
l
l
l
l
l
l

Configure the IPsec VPN at HQ.
Configure the IPsec concentrator at HQ.
Configure the firewall policy at HQ.
Configure IPsec VPN at branch 1.
Configure the firewall policy at branch 1.
Configure IPsec VPN at branch 2.
Configure the firewall policy at branch 2.

To configure the IPsec VPN at HQ:
1. Go to VPN > IPsec Wizard to set up branch 1.
a. Enter a VPN Name. In this example, to_branch1.
b. For Template Type, click Custom. Click Next.
c. Uncheck Enable IPsec Interface Mode.
d. For Remote Gateway, select Static IP Address.
e. Enter IP address, in this example, 15.1.1.2.
f. For Interface, select port9.
g. In the Authentication section, for Method, select Pre-shared Key and enter the Pre-shared Key.
h. Click OK.
2. Go to VPN > IPsec Wizard to set up branch 2.
a. Enter a VPN Name. In this example, to_branch2.
b. For Template Type, click Custom. Click Next.
c. Uncheck Enable IPsec Interface Mode.
d. For Remote Gateway, select Static IP Address.
e. Enter IP address, in this example, 13.1.1.2.
f. For Interface, select port9.
g. In the Authentication section, for Method, select Pre-shared Key and enter the Pre-shared Key.
h. Click OK.

To configure the IPsec concentrator at HQ:
1.
2.
3.
4.

Go to VPN > IPsec Concentrator and click Create New.
Enter a name. In this example, branch.
Add the Members to_branch1 and to_branch2.
Click OK.

To configure the firewall policy at HQ:
1.
2.
3.
4.
5.
6.

Go to Policy & Objects > IPv4 Policy and click Create New.
Enter a policy Name.
For Incoming Interface, select port10.
For Outgoing Interface, select port9.
Select the Source, Destination, Schedule, Service, and set Action to IPsec.
Select the VPN Tunnel, in this example, Branch1/Branch2.
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7. In this example, enable Allow traffic to be initiated from the remote site.
8. Click OK.

To configure IPsec VPN at branch 1:
1.
2.
3.
4.
5.
6.
7.
8.
9.

Go to VPN > IPsec Wizard to set up branch 1.
Enter a VPN name. In this example, to_HQ.
For Template Type, click Custom. Click Next.
Uncheck Enable IPsec Interface Mode.
For Remote Gateway, select Static IP Address.
Enter IP address, in this example, 22.1.1.1.
For Interface, select wan1.
In the Authentication section, for Method, select Pre-shared Key and enter the Pre-shared Key.
Click OK.

To configure the firewall policy at branch 1:
1.
2.
3.
4.
5.
6.
7.
8.

Go to Policy & Objects > IPv4 Policy and click Create New.
Enter a policy Name.
Choose the Incoming Interface, in this example, internal.
Choose the Outgoing Interface, in this example, wan1.
Select the Source, Destination, Schedule, Service, and set Action to IPsec.
Select the VPN Tunnel, in this example, Branch1/Branch2.
In this example, enable Allow traffic to be initiated from the remote site.
Click OK.

To configure IPsec VPN at branch 2:
1.
2.
3.
4.
5.
6.
7.
8.
9.

Go to VPN > IPsec Wizard to set up branch 1.
Enter a VPN name. In this example, to_HQ.
For Template Type, click Custom. Click Next.
Uncheck Enable IPsec Interface Mode.
For Remote Gateway, select Static IP Address.
Enter IP address, in this example, 22.1.1.1.
For Interface, select wan1.
In the Authentication section, for Method, select Pre-shared Key and enter the Pre-shared Key.
Click OK.

To configure the firewall policy at branch 2:
1.
2.
3.
4.
5.
6.

Go to Policy & Objects > IPv4 Policy and click Create New.
Enter a policy Name.
Choose the Incoming Interface, in this example, internal.
Choose the Outgoing Interface, in this example, wan1.
Select the Source, Destination, Schedule, Service, and set Action to IPsec.
Select the VPN Tunnel, in this example, to_HQ.
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7. In this example, enable Allow traffic to be initiated from the remote site.
8. Click OK.

To configure a policy-based IPsec tunnel using the CLI:
1. Configure the HQ WAN interface and static route.
config system interface
edit "port9"
set alias "WAN"
set ip 22.1.1.1 255.255.255.0
next
edit "port10"
set alias "Internal"
set ip 172.16.101.1 255.255.255.0
next
end
config router static
edit 1
set gateway 22.1.1.2
set device "port9"
next
end

2. Configure the HQ IPsec phase1 and phase2.
config vpn ipsec phase1
edit "to_branch1"
set interface "port9"
set peertype any
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 15.1.1.2
set psksecret sample
next
edit "to_branch2"
set interface "port9"
set peertype any
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 13.1.1.2
set psksecret sample
next
end
config vpn ipsec phase2
edit "to_branch1"
set phase1name "to_branch1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
edit "to_branch2"
set phase1name "to_branch2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end
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3. Configure the firewall policy at HQ.
config firewall policy
edit 1
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "10.1.100.0"
set action ipsec
set schedule "always"
set service "ALL"
set inbound enable
set vpntunnel "to_branch1"
next
edit 2
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "192.168.4.0"
set action ipsec
set schedule "always"
set service "ALL"
set inbound enable
set vpntunnel "to_branch2"
next
end

4. Configure the IPsec concentrator at HQ.
config vpn ipsec concentrator
edit "branch"
set member "to_branch1" "to_branch2"
next
end

5. Configure the branch WAN interface and static route.
a. For branch 1.
config system interface
edit "wan1"
set alias "primary_WAN"
set ip 15.1.1.2 255.255.255.0
next
edit "internal"
set ip 10.1.100.1 255.255.255.0
next
end
config router static
edit 1
set gateway 15.1.1.1
set device "wan1"
next
end

b. For branch 2.
config system interface
edit "wan1"
set alias "primary_WAN"
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set ip 13.1.1.2 255.255.255.0
next
edit "internal"
set ip 192.168.4.1 255.255.255.0
next
end
config router static
edit 1
set gateway 13.1.1.1
set device "wan1"
next
end

6. Configure the branch IPsec phase1 and phase2.
a. For branch 1.
config vpn ipsec phase1
edit "to_HQ"
set interface "wan1"
set peertype any
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 22.1.1.1
set psksecret sample
next
end
config vpn ipsec phase2
edit "to_HQ"
set phase1name "to_HQ"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end

b. For branch 2.
config vpn ipsec phase1
edit "to_HQ"
set interface "wan1"
set peertype any
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 22.1.1.1
set psksecret sample
next
end
config vpn ipsec phase2
edit "to_HQ"
set phase1name "to_HQ"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end

7. Configure the branch firewall policy.
a. For branch 1.
config firewall policy
edit 1
set srcintf "internal"
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set
set
set
set
set
set
set
set

dstintf "wan1"
srcaddr "10.1.100.0"
dstaddr "all"
action ipsec
schedule "always"
service "ALL"
inbound enable
vpntunnel "to_HQ"

next
end

b. For branch 2.
config firewall policy
edit 1
set srcintf "internal"
set dstintf "wan1"
set srcaddr "192.168.4.0"
set dstaddr "all"
set action ipsec
set schedule "always"
set service "ALL"
set inbound enable
set vpntunnel "to_HQ"
next
end

To view the IPsec VPN tunnel list at HQ:
diagnose vpn tunnel list
list all ipsec tunnel in vd 0
---name=to_branch1 ver=1 serial=4 22.1.1.1:0->15.1.1.2:0
bound_if=42 lgwy=static/1 tun=tunnel/1 mode=auto/1 encap=none/8 options[0008]=npu
proxyid_num=1 child_num=0 refcnt=8 ilast=0 olast=0 ad=/0
stat: rxp=305409 txp=41985 rxb=47218630 txb=2130108
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=to_branch1 proto=0 sa=1 ref=3 serial=1
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=10226 type=00 soft=0 mtu=1438 expire=42604/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000680 itn=0
life: type=01 bytes=0/0 timeout=42932/43200
dec: spi=ca646442 esp=aes key=16 58c91d4463968dddccc4fd97de90a4b8
ah=sha1 key=20 c9176fe2fbc82ef7e726be9ad4af83eb1b55580a
enc: spi=747c10c4 esp=aes key=16 7cf0f75b784f697bc7f6d8b4bb8a83c1
ah=sha1 key=20 cdddc376a86f5ca0149346604a59af07a33b11c5
dec:pkts/bytes=1664/16310, enc:pkts/bytes=0/16354
npu_flag=03 npu_rgwy=15.1.1.2 npu_lgwy=22.1.1.1 npu_selid=3 dec_npuid=2 enc_npuid=2
---name=to_branch2 ver=1 serial=5 22.1.1.1:0->13.1.1.2:0
bound_if=42 lgwy=static/1 tun=tunnel/1 mode=auto/1 encap=none/8 options[0008]=npu
proxyid_num=1 child_num=0 refcnt=7 ilast=2 olast=43228 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
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natt: mode=none draft=0 interval=0 remote_port=0
proxyid=to_branch2 proto=0 sa=1 ref=2 serial=1
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=10226 type=00 soft=0 mtu=1280 expire=40489/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0
life: type=01 bytes=0/0 timeout=42931/43200
dec: spi=ca646441 esp=aes key=16 57ab680d29d4aad4e373579fb50e9909
ah=sha1 key=20 12a2bc703d2615d917ff544eaff75a6d2c17f1fe
enc: spi=f9cffb61 esp=aes key=16 3d64da9feb893874e007babce0229259
ah=sha1 key=20 f92a3ad5e56cb8e89c47af4dac10bf4b4bebff16
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0
npu_flag=00 npu_rgwy=13.1.1.2 npu_lgwy=22.1.1.1 npu_selid=4 dec_npuid=0 enc_npuid=0

To view the IPsec VPN concentrator at HQ:
diagnose vpn concentrator list
list all ipsec concentrator in vd 0
name=branch
ref=3

tuns=2 flags=0

Per packet distribution and tunnel aggregation
This example shows how to aggregate IPsec tunnels by using per-packet load-balancing among IPsec tunnels.
For example, a customer has two ISP connections, wan1 and wan2. Using these two connections, we create two VPN
interfaces and configure traffic for per-packet load-balancing among IPsec tunnels.
This feature only allows static/DDNS tunnels to be members.
Dynamic (dialup) tunnels are not allowed because dialup instances tend to have different
locations and hence different routing. This conflicts with the rule that all the members of an
aggregate must have the same routing.

Sample topology

Sample configuration
On the FortiGate, first create two IPsec VPN interfaces. Then create an ipsec-aggregate interface and add this
interface as an SD-WAN member.
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FortiGate 1 configuration
To create two IPsec VPN interfaces on FortiGate 1:
config vpn ipsec phase1-interface
edit "vd1-p1"
set interface "wan1"
set peertype any
set net-device disable
set aggregate-member enable
set proposal aes256-sha256
set dhgrp 14
set remote-gw 172.16.201.2
set psksecret ftnt1234
next
edit "vd1-p2"
set interface "wan2"
set peertype any
set net-device disable
set aggregate-member enable
set proposal aes256-sha256
set dhgrp 14
set remote-gw 172.16.202.2
set psksecret ftnt1234
next
end
config vpn ipsec phase2-interface
edit "vd1-p1"
set phase1name "vd1-p1"
next
edit "vd1-p2"
set phase1name "vd1-p2"
next
end

To create an ipsec-aggregate interface on FortiGate 1:
config system ipsec-aggregate
edit "agg1"
set member "vd1-p1" "vd1-p2"
set algorithm L3
next
end
config system interface
edit "agg1"
set vdom "root"
set ip 172.16.11.1 255.255.255.255
set allowaccess ping
set remote-ip 172.16.11.2 255.255.255.255
end

To configure the firewall policy on FortiGate 1:
config firewall policy
edit 1
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set
set
set
set
set
set
set
set
set

name "1"
srcintf "dmz"
dstintf ""virtual-wan-link""
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"
nat enable

next
end

To configure SD-WAN on FortiGate 1:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "agg1"
set gateway 172.16.11.2
next
end
end

FortiGate 2 configuration
To create two IPsec VPN interfaces on FortiGate 2:
config vpn ipsec phase1-interface
edit "vd2-p1"
set interface "wan1"
set peertype any
set net-device disable
set proposal aes256-sha256
set dhgrp 14
set remote-gw 172.16.200.1
set psksecret ftnt1234
next
edit "vd2-p2"
set interface "wan2"
set peertype any
set net-device disable
set proposal aes256-sha256
set dhgrp 14
set remote-gw 172.16.203.1
set psksecret ftnt1234
next
end
config vpn ipsec phase2-interface
edit "vd2-p1"
set phase1name "vd2-p1"
next
edit "vd2-p2"
set phase1name "vd2-p2"
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next
end

To create an ipsec-aggregate interface on FortiGate 2:
config system ipsec-aggregate
edit "agg2"
set member "vd2-p1" "vd2-p2"
set algorithm L3
next
end
config system interface
edit "agg2"
set vdom "root"
set ip 172.16.11.2 255.255.255.255
set allowaccess ping
set remote-ip 172.16.11.1 255.255.255.255
next
end

To configure the firewall policy on FortiGate 2:
config firewall policy
edit 1
set name "1"
set srcintf "dmz"
set dstintf ""virtual-wan-link""
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

To configure SD-WAN on FortiGate 2:
config system virtual-wan-link
set status enable
config members
edit 1
set interface "agg2"
set gateway 172.16.11.1
next
end
end

To use the diagnose command to display aggregate IPsec members:
# diagnose sys ipsec-aggregate list
agg1 algo=L3 member=2 run_tally=2
members:
vd1-p1
vd1-p2
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To use the diagnose command to check VPN status:
# diagnose vpn tunnel list
list all ipsec tunnel in vd 0
-----------------------------------------------------name=vd1-p1 ver=1 serial=2 172.16.200.1:0->172.16.201.2:0 dst_mtu=0
bound_if=10 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/520 options[0208]=npu frag-rfc
run_state=1 accept_traffic=0
proxyid_num=1 child_num=0 refcnt=5 ilast=15 olast=676 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=vd1-p1 proto=0 sa=0 ref=1 serial=1
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
-----------------------------------------------------name=vd1-p2 ver=1 serial=3 172.16.203.1:0->172.16.202.2:0 dst_mtu=1500
bound_if=28 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/520 options[0208]=npu frag-rfc
run_state=1 accept_traffic=1
proxyid_num=1 child_num=0 refcnt=12 ilast=1 olast=1 ad=/0
stat: rxp=1 txp=1686 rxb=16602 txb=111717
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=vd1-p2 proto=0 sa=1 ref=9 serial=1
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=4 options=10226 type=00 soft=0 mtu=1438 expire=42164/0B replaywin=2048
seqno=697 esn=0 replaywin_lastseq=00000002 itn=0 qat=0
life: type=01 bytes=0/0 timeout=42902/43200
dec: spi=f6ae9f83 esp=aes key=16 f6855c72295e3c5c49646530e6b96002
ah=sha1 key=20 f983430d6c161d0a4cd9007c7ae057f1ff011334
enc: spi=8c72ba1a esp=aes key=16 6330f8c532a6ca5c5765f6a9a6034427
ah=sha1 key=20 e5fe385ed5f0f6a33f1d507601b15743a8c70187
dec:pkts/bytes=1/16536, enc:pkts/bytes=1686/223872
npu_flag=02 npu_rgwy=172.16.202.2 npu_lgwy=172.16.203.1 npu_selid=2 dec_npuid=1 enc_
npuid=0

IPsec VPN with external DHCP service
You can use an external DHCP server to assign IP addresses to your IPsec VPN clients. This is a common scenario
found in enterprises where all DHCP leases need to be managed centrally.
In this example, the DHCP server assigns IP addresses in the range of 172.16.6.100 to 172.16.6.120. The server is
attached to internal2 on the FortiGate and has an IP address of 192.168.3.70.
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To configure a DHCP server to assign IP addresses to IPsec VPN clients:
1. Create a user group for remote users:
a. Go to User & Device > User Definition > Create New.
b. For User Type, select Local User.

c.
d.
e.
f.

Complete the wizard, and click Submit.
Go to User & Device > User Groups > Create New.
Create a Firewall user group for your remote users.
For Members, add the user you just created.
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g. Click OK.

2. Add a firewall address for the local network and IPsec VPN client range:
a. Go to Policy & Objects > Addresses.
b. Create a new Subnet address for the LAN, including the IP mask and local interface (internal2).
c. Click OK.

d. Create a new IP Range address for the IPsec VPN client range (172.16.6.100–172.16.6.120).
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e. Click OK.

3. Configure the IPsec VPN using a VPN tunnel in the CLI:
config vpn ipsec phase1-interface
edit "dhcp_vpn"
set type dynamic
set interface "wan1"
set mode aggressive
set peertype any
set net-device disable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set dpd on-idle
set dhgrp 5
set xauthtype auto
set authusrgrp "ipsecvpn"
set psksecret <xxxxxx>
set dpd-retryinterval 60
next
end
config vpn ipsec phase2-interface
edit "toclient"
set phase1name "dhcp_vpn"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set dhgrp 5
set dhcp-ipsec enable
next
end

4. Configure the IPsec VPN interface:
a. Go to Network > Interfaces and edit the newly created IPsec VPN interface.
b. Enable the DHCP Server.
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c.
d.
e.
f.

Expand Advanced and change the Mode to Relay.
Enter the external DHCP server IP address (192.168.3.70).
Change the Type to IPsec.
Click OK.

5. Create a security policy for access to the local network:
a. Go to Policy & Objects > IPv4 Policy > Create New.
b. Configure the following parameters:
i. Set the Incoming Interface to the tunnel interface created in step 3 (dhcp_vpn).
ii. Set the Outgoing Interface (internal2).
iii. Set the Source to the IPsec VPN client range defined in step 2 (ipsecvpn_range).
iv. Set the Destination to the subnet address defined in step 2 (Local LAN).
v. Set the Service to ALL.
c. Click OK.
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6. Configure FortiClient:
a. In FortiClient, go to REMOTE ACCESS > Add a new connection.

b. Configure the following parameters:
i. Set the VPN type to IPsec VPN.
ii. Enter a connection name.
iii. Set the Remote Gateway to the FortiGate external IP address.
iv. Set the Authentication Method to Pre-shared key and enter the key below.
v. Expand the Advanced Settings > VPN Settings and for Options, select DHCP over IPsec.
vi. Click Save.

c. Select the new connection, and enter the user name and password.
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d. Click Connect.

Once the connection is established, the external DHCP server assigns the user an IP address and FortiClient
displays the connection status, including the IP address, connection duration, and bytes sent and received.

Verification
1. In FortiOS, go to Monitor > IPsec Monitor and verify that the tunnel Status is Up.
2. Go to Log & Report > Forward Traffic and verify the Sent / Received column displays the traffic flow through the
tunnel.

Site-to-site VPN
A site-to-site VPN connection lets branch offices use the Internet to access the main office's intranet. A site-to-site VPN
allows offices in multiple, fixed locations to establish secure connections with each other over a public network such as
the Internet.
The following topics provide instructions on configuring basic site-to-site VPN:
l
l
l
l
l
l

IPsec VPN in an HA environment on page 961
IPsec aggregate for redundancy and traffic load-balancing on page 967
Redundant hub and spoke VPN on page 973
IKEv2 IPsec site-to-site VPN to an Azure VPN gateway on page 978
IKEv2 IPsec site-to-site VPN to an AWS VPN gateway on page 982
IPsec VPN to Azure on page 988

IPsec VPN in an HA environment
This is a sample configuration of site-to-site IPsec VPN in an HA environment.
For this example, set up HA as described in the HA topics. When setting up HA, enable the following options to ensure
IPsec VPN traffic is not interrupted during an HA failover:
l
l

session-pickup under HA settings.
ha-sync-esp-seqno under IPsec phase1-interface settings.
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You can configure IPsec VPN in an HA environment using the GUI or CLI.
In this example, the VPN name for HQ1 is "to_HQ2", and the VPN name for HQ2 is "to_HQ1".

To configure IPsec VPN in an HA environment in the GUI:
1. Set up IPsec VPN on HQ1 (the HA cluster):
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, set No NAT between sites.
v. Click Next.
b. Configure the following settings for Authentication:
i. For Remote Device, select IP Address.
ii. In the IP address field, enter 172.16.202.1.
iii. For Outgoing Interface, select port1.
iv. For Authentication Method, select Pre-shared Key.
v. In the Pre-shared Key field, enter an example key.
vi. Click Next.
c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select the local interface.
ii. Configure the Local Subnets as 10.1.100.0/24.
iii. Configure the Remote Subnets as 172.16.101.0/24.
iv. Click Create.
2. Set up IPsec VPN on HQ2:
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, set No NAT between sites.
v. Click Next.
b. Configure the following settings for Authentication:
i. For Remote Device, select IP Address.
ii. In the IP address field, enter 172.16.200.1.
iii. For Outgoing Interface, select port13.
iv. For Authentication Method, select Pre-shared Key.
v. In the Pre-shared Key field, enter an example key.
vi. Click Next.
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c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select the desired local interface. In this example, it is port9.
ii. Configure the Local Subnets as 172.16.101.0.
iii. Configure the Remote Subnets as 10.1.100.0
iv. Click Create.

To configure IPsec VPN in an HA environment using the CLI:
1. Configure HA. In this example, two FortiGates work in active-passive mode. The HA heartbeat interfaces are WAN1
and WAN2:
config
set
set
set
set
set
set
set
end

system ha
group-name "FGT-HA"
mode a-p
password sample
hbdev "wan1" 50 "wan2" 50
session-pickup enable
priority 200
override-wait-time 10

2. Configure the WAN interface and default route. The WAN interface is the interface connected to the ISP. It can work
in static mode (as shown in this example), DHCP, or PPPoE mode. The IPsec tunnel is established over the
WAN interface.
a. Configure HQ1:
config system interface
edit "port1"
set vdom "root"
set ip 172.16.200.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.200.3
set device "port1"
next
end

b. Configure HQ2:
config system interface
edit "port25"
set vdom "root"
set ip 172.16.202.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.202.2
set device "port25"
next
end

3. Configure the internal (protected subnet) interface. The internal interface connects to the corporate internal
network. Traffic from this interface routes out the IPsec VPN tunnel.
a. Configure HQ1:
config system interface
edit "dmz"
set vdom "root"
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set ip 10.1.100.1 255.255.255.0
next
end

b. Configure HQ2:
config system interface
edit "port9"
set vdom "root"
set ip 172.16.101.1 255.255.255.0
next
end

4. Configure the IPsec phase1-interface. This example uses PSK as the authentication method. You can also use
signature authentication.
a. Configure HQ1:
config vpn ipsec phase1-interface
edit "to_HQ2"
set interface "port1"
set peertype any
set net-device enable
set ha-sync-esp-seqno enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set psksecret sample
next
end

b. Configure HQ2:
config vpn ipsec phase1-interface
edit "to_HQ1"
set interface "port25"
set peertype any
set net-device enable
set ha-sync-esp-seqno enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.200.1
set psksecret sample
next

5. Configure the IPsec phase2-interface:
a. Configure HQ1:
config vpn ipsec phase2-interface
edit "to_HQ2"
set phase1name "to_HQ2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

b. Configure HQ2:
config vpn ipsec phase2-interface
edit "to_HQ1"
set phase1name "to_HQ1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end
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6. Configure static routes. Two static routes are added to reach the remote protected subnet. The blackhole route is
important to ensure IPsec traffic does not match the default route when the IPsec tunnel is down.
a. Configure HQ1:
config router static
edit 2
set dst 172.16.101.0 255.255.255.0
set device "to_HQ2"
next
edit 3
set dst 172.16.101.0 255.255.255.0
set blackhole enable
set distance 254
next
end

b. Configure HQ2:
config router static
edit 2
set dst 10.1.100.0 255.255.255.0
set device "to_HQ1"
next
edit 3
set dst 10.1.100.0 255.255.255.0
set blackhole enable
set distance 254
next
end

7. Configure two firewall policies to allow bi-directional IPsec traffic flow over the IPsec tunnel:
a. Configure HQ1:
config firewall policy
edit 1
set name "inbound"
set srcintf "to_HQ2"
set dstintf "dmz"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "outbound"
set srcintf "dmz"
set dstintf "to_HQ2"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
end

b. Configure HQ2:
config firewall policy
edit 1
set name "inbound"
set srcintf "to_HQ1"
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set
set
set
set
set
set
next
edit 2
set
set
set
set
set
set
set
set
next
end

dstintf "port9"
srcaddr "10.1.100.0"
dstaddr "172.16.101.0"
action accept
schedule "always"
service "ALL"

name "outbound"
srcintf "port9"
dstintf "to_HQ1"
srcaddr "172.16.101.0"
dstaddr "10.1.100.0"
action accept
schedule "always"
service "ALL"

8. Use the following diagnose commands to check IPsec phase1/phase2 interface status including the sequence
number on the secondary FortiGate. The diagnose debug application ike -1 command is the key to
troubleshoot why the IPsec tunnel failed to establish.
a. Run the HQ1 # diagnose vpn ike gateway list command. The system should return the following:
vd: root/0
name: to_HQ2
version: 1
interface: port1 11
addr: 172.16.200.1:500 -> 172.16.202.1:500
created: 5s ago
IKE SA: created 1/1 established 1/1 time 0/0/0 ms
IPsec SA: created 2/2 established 2/2 time 0/0/0 ms
id/spi: 12 6e8d0532e7fe8d84/3694ac323138a024 direction: responder status:
established 5-5s ago = 0ms proposal: aes128-sha256 key: b3efb46d0d385aff7bb9ee241362ee8d lifetime/rekey: 86400/86124 DPD sent/recv: 00000000/00000000

b. Run the HQ1 # diagnose vpn tunnel list command. The system should return the following:
list all ipsec tunnel in vd 0
name=to_HQ2 ver=1 serial=1 172.16.200.1:0->172.16.202.1:0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_
dev frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=11 ilast=7 olast=87 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=to_HQ2 proto=0 sa=1 ref=2 serial=1 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0 dst: 0:0.0.0.0/0.0.0.0:0 SA: ref=3 options=18227 type=00
soft=0 mtu=1438 expire=42927/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0
life: type=01 bytes=0/0 timeout=42930/43200 dec: spi=ef9ca700 esp=aes key=16
a2c6584bf654d4f956497b3436f1cfc7
ah=sha1 key=20 82c5e734bce81e6f18418328e2a11aeb7baa021b
enc: spi=791e898e esp=aes key=16 0dbb4588ba2665c6962491e85a4a8d5a
ah=sha1 key=20 2054b318d2568a8b12119120f20ecac97ab730b3
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0

ESP seqno synced to primary FortiGate every five minutes, and big gap between primary and secondary to
ensure that no packet is dropped after HA failover caused by tcp-replay. Check ESP sequence number synced
on secondary FortiGate.
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c. Run the HQ1 # execute ha manage 0 admin command.
d. Run the HQ1-Slave # diagnose vpn tunnel list command. The system should return the following:
list all ipsec tunnel in vd 0
name=to_HQ2 ver=1 serial=1 172.16.200.1:0->172.16.202.1:0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_
dev frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=11 ilast=13 olast=274 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=to_HQ2 proto=0 sa=1 ref=2 serial=1 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0 dst: 0:0.0.0.0/0.0.0.0:0 SA: ref=3 options=27 type=00
soft=0 mtu=1280 expire=42740/0B replaywin=2048
seqno=47868c01 esn=0 replaywin_lastseq=00000000 itn=0
life: type=01 bytes=0/0 timeout=42930/43200 dec: spi=ef9ca700 esp=aes key=16
a2c6584bf654d4f956497b3436f1cfc7
ah=sha1 key=20 82c5e734bce81e6f18418328e2a11aeb7baa021b
enc: spi=791e898e esp=aes key=16 0dbb4588ba2665c6962491e85a4a8d5a
ah=sha1 key=20 2054b318d2568a8b12119120f20ecac97ab730b3
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0

IPsec aggregate for redundancy and traffic load-balancing
This is a sample configuration of using IPsec aggregate to set up redundancy and traffic load-balancing. The the
following options are available:
l
l

Multiple site-to-site IPsec VPN (net-device disable) tunnel interfaces as member of ipsec-aggregate.
The supported load balancing algorithms are: L3, L4, round-robin (default), and redundant.

Because the GUI can only complete part of the configuration, we recommend using the CLI.

To configure IPsec aggregate to achieve redundancy and traffic load-balancing using the CLI:
1. Configure the WAN interface and static route. Each FortiGate has two WAN interfaces connected to different ISPs.
The ISP1 link is for the primary FortiGate and the IPS2 link is for the secondary FortiGate.
a. Configure HQ1.
config system interface
edit "port1"
set alias to_ISP1
set ip 172.16.200.1 255.255.255.0
next
edit "port2"
set alias to_ISP2
set ip 172.17.200.1 255.255.255.0
next
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end
config router static
edit 1
set gateway 172.16.200.3
set device "port1"
next
edit 2
set gateway 172.17.200.3
set device "port2"
set priority 100
next
end

b. Configure HQ2.
config system interface
edit "port25"
set alias to_ISP1
set ip 172.16.202.1 255.255.255.0
next
edit "port26"
set alias to_ISP2
set ip 172.17.202.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.202.2
set device "port25"
next
edit 2
set gateway 172.17.202.2
set device "port26"
set priority 100
next
end

2. Configure the internal (protected subnet) interface.
a. Configure HQ1.
config system interface
edit "dmz"
set ip 10.1.100.1 255.255.255.0
next
end

b. Configure HQ2.
config system interface
edit "port9"
set ip 172.16.101.1 255.255.255.0
next
end

3. Configure the IPsec phase-1 and phase-2 interfaces. On each FortiGate, configure two site-to-site phase-1
interfaces with net-device disable.
a. Configure HQ1.
config vpn ipsec phase1-interface
edit "pri_HQ2"
set interface "port1"
set peertype any
set net-device disable
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set aggregate-member enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set psksecret sample1
next
edit "sec_HQ2"
set interface "port2"
set peertype any
set net-device disable
set aggregate-member enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.17.202.1
set psksecret sample2
next
end
config vpn ipsec phase2-interface
edit "pri_HQ2"
set phase1name "pri_HQ2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
edit "sec_HQ2"
set phase1name "sec_HQ2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

b. Configure HQ2.
config vpn ipsec phase1-interface
edit "pri_HQ1"
set interface "port25"
set peertype any
set net-device disable
set aggregate-member enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.200.1
set psksecret sample1
next
edit "sec_HQ1"
set interface "port26"
set peertype any
set net-device disable
set aggregate-member enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.17.200.1
set psksecret sample2
next
end
config vpn ipsec phase2-interface
edit "pri_HQ1"
set phase1name "pri_HQ1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
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edit "sec_HQ1"
set phase1name "sec_HQ1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

4. Configure ipsec-aggregate.
a. Configure HQ1.
config system ipsec-aggregate
edit "agg_HQ2"
set member "pri_HQ2" "sec_HQ2"
next
end

b. Configure HQ2.
config system ipsec-aggregate
edit "agg_HQ1"
set member "pri_HQ" "sec_HQ1"
next
end

5. Configure the firewall policy.
a. Configure HQ1.
config firewall policy
edit 1
set name "inbound"
set srcintf "agg_HQ2"
set dstintf "dmz"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "outbound"
set srcintf "dmz"
set dstintf "agg_HQ2"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
end

b. Configure HQ2.
config firewall policy
edit 1
set name "inbound"
set srcintf "agg_HQ1"
set dstintf "port9"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
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next
edit 2
set
set
set
set
set
set
set
set
next
end

name "outbound"
srcintf "port9"
dstintf "agg_HQ1"
srcaddr "172.16.101.0"
dstaddr "10.1.100.0"
action accept
schedule "always"
service "ALL"

6. Assign an IP address to the ipsec-aggregate interface. In this example, OSPF runs over the ipsecaggregate interface. No IP address is required for the static route HQ1.
a. Configure HQ1.
config system interface
edit "agg_HQ2"
set ip 10.10.10.1 255.255.255.255
set remote-ip 10.10.10.2 255.255.255.255
next
end

b. Configure HQ2.
config system interface
edit "agg_HQ1"
set ip 10.10.10.2 255.255.255.255
set remote-ip 10.10.10.1 255.255.255.255
next
end

7. Configure OSPF.
a. Configure HQ1.
config router ospf
set router-id 1.1.1.1
config area
edit 0.0.0.0
next
end
config network
edit 1
set prefix 10.1.100.0 255.255.255.0
next
edit 2
set prefix 10.10.10.0 255.255.255.0
next
end
end

b. Configure HQ2.
config router ospf
set router-id 2.2.2.2
config area
edit 0.0.0.0
next
end
config network
edit 1
set prefix 172.16.101.0 255.255.255.0
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next
edit 2
set prefix 10.10.10.0 255.255.255.0
next
end
end

8. Run diagnose commands.
a. Run the diagnose vpn ike gateway list command. The system should return the following:
vd: root/0
name: pri_HQ2
version: 1
interface: port1 11
addr: 172.16.200.1:500 -> 172.16.202.1:500
created: 1520s ago
IKE SA: created 1/2 established 1/1 time 10/10/10 ms
IPsec SA: created 2/2 established 1/1 time 0/0/0 ms
id/spi: 173 dcdede154681579b/e32f4c48c4349fc0 direction: responder status:
established 1498-1498s ago = 10ms proposal: aes128-sha256 key:
d7230a68d7b83def-588b94495cfa9d38 lifetime/rekey: 86400/84631 DPD sent/recv:
0000000d/00000006
vd: root/0
name: sec_HQ2
version: 1
interface: port2 12
addr: 172.17.200.1:500 -> 172.17.202.1:500
created: 1520s ago
IKE SA: created 1/2 established 1/1 time 10/10/10 ms
IPsec SA: created 2/2 established 1/1 time 0/0/0 ms
id/spi: 174 a567bd7bf02a04b5/4251b6254660aee2 direction: responder status:
established 1498-1498s ago = 10ms proposal: aes128-sha256 key:
9f44f500c28d8de6-febaae9d1e6a164c lifetime/rekey: 86400/84631 DPD sent/recv:
00000008/0000000c

b. Run the diagnose vpn tunnel list command. The system should return the following:
list all ipsec tunnel in vd 0
name=sec_HQ2 ver=1 serial=2 172.17.200.1:0->172.17.202.1:0
bound_if=5 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/512 options[0200]=frag-rfc
run_state=1 accept_traffic=1
proxyid_num=1 child_num=0 refcnt=7 ilast=5 olast=5 ad=/0
stat: rxp=39 txp=40 rxb=5448 txb=2732
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=15
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=sec_HQ2 proto=0 sa=1 ref=2 serial=2 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0 dst: 0:0.0.0.0/0.0.0.0:0 SA: ref=3 options=18227 type=00
soft=0 mtu=1438 expire=41230/0B replaywin=2048
seqno=29 esn=0 replaywin_lastseq=00000028 itn=0
life: type=01 bytes=0/0 timeout=42899/43200 dec: spi=1071b4f9 esp=aes key=16
1f4dbb78bea8e97650b52d8170b5ece7
ah=sha1 key=20 cd9bf2de0f49296cf489dd915d7baf6d78bc8f12
enc: spi=ec89b7ee esp=aes key=16 0546efecd0d1b9ba5944f635896e4404
ah=sha1 key=20 34599bc7dc25e1ce63ac9615bd50928ce0667dc8
dec:pkts/bytes=39/2796, enc:pkts/bytes=40/5456
name=pri_HQ2 ver=1 serial=1 172.16.200.1:0->172.16.202.1:0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/512 options[0200]=fragrfc run_state=1 accept_traffic=1
proxyid_num=1 child_num=0 refcnt=5 ilast=15 olast=15 ad=/0
stat: rxp=38 txp=39 rxb=5152 txb=2768
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=20
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natt: mode=none draft=0 interval=0 remote_port=0
proxyid=pri_HQ2 proto=0 sa=1 ref=2 serial=2 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0 dst: 0:0.0.0.0/0.0.0.0:0 SA: ref=3 options=18227 type=00
soft=0 mtu=1438 expire=41231/0B replaywin=2048
seqno=28 esn=0 replaywin_lastseq=00000027 itn=0
life: type=01 bytes=0/0 timeout=42900/43200 dec: spi=1071b4f8 esp=aes key=16
142cce377b3432ba41e64128ade6848c
ah=sha1 key=20 20e64947e2397123f561584321adc0e7aa0c342d
enc: spi=ec89b7ed esp=aes key=16 2ec13622fd60dacce3d28ebe5fe7ab14
ah=sha1 key=20 c1787497508a87f40c73c0db0e835c70b3c3f42d
dec:pkts/bytes=38/2568, enc:pkts/bytes=39/5432

c. Run the diagnose sys ipsec-aggregate list command. The system should return the following:
agg_HQ2 algo=RR member=2 run_tally=2
members:
pri_HQ2
sec_HQ2

d. Run the get router info ospf neighbor command. The system should return the following:
OSPF process 0, VRF 0:
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 1. Full/ - 00:00:34 10.10.10.2 agg1_HQ2

e. Run the get router info routing-table ospf command. The system should return the following:
Routing table for VRF=0
O 172.16.101.0/24 [110/20] via 10.10.10.2, agg1_HQ2 , 00:18:43

Redundant hub and spoke VPN
A redundant hub and spoke configuration allows VPN connections to radiate from a central FortiGate unit (the hub) to
multiple remote peers (the spokes). Traffic can pass between private networks behind the hub and private networks
behind the remote peers. Traffic can also pass between remote peer private networks through the hub.
This is a sample configuration of hub and spoke IPsec VPN. The following applies for this scenario:
l
l

The spokes have two WAN interfaces and two IPsec VPN tunnels for redundancy.
The secondary VPN tunnel is up only when the primary tunnel is down by dead peer detection.

Because the GUI can only complete part of the configuration, we recommend using the CLI.
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To configure redundant hub and spoke VPN using the FortiOS CLI:
1. Configure the hub.
a. Configure the WAN, internal interface, and static route.
config system interface
edit "port13"
set alias "WAN"
set ip 172.16.202.1 255.255.255.0
next
edit "port9"
set alias "Internal"
set ip 172.16.101.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.202.2
set device "port13"
next
end

b. Configure the IPsec phase1-interface and phase2-interface.
config vpn ipsec phase1-interface
edit "hub"
set type dynamic
set interface "port13"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set dpd on-idle
set psksecret sample
set dpd-retryinterval 60
next
end
config vpn ipsec phase2-interface
edit "hub"
set phase1name "hub"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end

c. Configure the firewall policy.
config firewall policy
edit 1
set name "spoke-hub"
set srcintf "hub"
set dstintf "port9"
set srcaddr "all"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "spoke-spoke"
set srcintf "hub"
set dstintf "hub"

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

974

VPN
set
set
set
set
set
next
end

srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"

2. Configure the spokes.
a. Configure the WAN, internal interface, and static route.
i. Configure Spoke1.
config system interface
edit "port1"
set ip 172.16.200.1 255.255.255.0
next
edit "wan1"
set mode dhcp
set distance 10
set priority 100
next
edit "dmz"
set ip 10.1.100.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.200.2
set device "port1"
next
end

ii. Configure Spoke2.
config system interface
edit "wan1"
set ip 172.16.200.3 255.255.255.0
next
edit "wan2"
set mode dhcp
set distance 10
set priority 100
next
edit "lan1"
set ip 192.168.4.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.200.2
set device "wan1"
next
end

b. Configure IPsec phase1-interface and phase2-interface.
i. Configure Spoke1.
config vpn ipsec phase1-interface
edit "primary"
set interface "port1"
set peertype any
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set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set psksecret sample
next
edit "secondary"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set monitor "primary"
set psksecret sample
next
end
config vpn ipsec phase2-interface
edit "primary"
set phase1name "primary"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
set src-subnet 10.1.100.0 255.255.255.0
next
edit "secondary"
set phase1name "secondary"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
set src-subnet 10.1.100.0 255.255.255.0
next
end

ii. Configure Spoke2.
config vpn ipsec phase1-interface
edit "primary"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set psksecret sample
next
edit "secondary"
set interface "wan2"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set monitor "primary"
set psksecret sample
next
end
config vpn ipsec phase2-interface
edit "primary"
set phase1name "primary"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
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set src-subnet 192.168.4.0 255.255.255.0
next
edit "secondary"
set phase1name "secondary"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
set src-subnet 192.168.4.0 255.255.255.0
next
end

c. Configure the firewall policy.
i. Configure Spoke1.
config firewall policy
edit 1
set srcintf "dmz"
set dstintf "primary" "secondary"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
end

ii. Configure Spoke2.
config firewall policy
edit 1
set srcintf "lan1"
set dstintf "primary" "secondary"
set srcaddr "192.168.4.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
end

d. Configure the static route.
i. Configure Spoke1.
config router static
edit 3
set dst 172.16.101.0 255.255.255.0
set distance 1
set device "primary"
next
edit 4
set dst 172.16.101.0 255.255.255.0
set distance 3
set device "secondary"
next
end

ii. Configure Spoke2.
config router static
edit 3
set dst 172.16.101.0 255.255.255.0
set distance 1
set device "primary"
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next
edit 4
set dst 172.16.101.0 255.255.255.0
set distance 3
set device "secondary"
next
end

3. Run diagnose and get commands.
a. Run the Spoke1 # diagnose vpn tunnel list command. The system should return the following:
name=primary ver=1 serial=1 172.16.200.1:0->172.16.202.1:0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_
dev frag-rfc accept_traffic=1
proxyid_num=1 child_num=0 refcnt=15 ilast=0 olast=0 ad=/0
stat: rxp=1879 txp=1881 rxb=225480 txb=112860
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=1
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=primary proto=0 sa=1 ref=2 serial=2 auto-negotiate
src: 0:10.1.100.0/255.255.255.0:0 dst: 0:0.0.0.0/0.0.0.0:0 SA: ref=3 options=18227
type=00 soft=0 mtu=1438 expire=41002/0B replaywin=2048
seqno=758 esn=0 replaywin_lastseq=00000758 itn=0
life: type=01 bytes=0/0 timeout=42901/43200 dec: spi=0908732f esp=aes key=16
20770dfe67ea22dd8ec32c44d84ef4d5
ah=sha1 key=20 edc89fc2ec06309ba13de95e7e486f9b795b8707
enc: spi=a1d9eed1 esp=aes key=16 8eeea2526fba062e680d941083c8b5d1
ah=sha1 key=20 f0f5deaf88b2a69046c3154e9f751739b3f411f5
dec:pkts/bytes=1879/112740, enc:pkts/bytes=1879/225480
name=secondary ver=1 serial=2 172.17.200.1:0->172.16.202.1:0
bound_if=5 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_
dev frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=10 ilast=1892 olast=1892 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=0 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=secondary proto=0 sa=0 ref=2 serial=2 auto-negotiate
src: 0:10.1.100.0/255.255.255.0:0 dst: 0:0.0.0.0/0.0.0.0:0

b. Run the Spoke1 # get router info routing-table static command. The system should return
the following:
Routing table for VRF=0
................
S 172.16.101.0/24 [1/0] is directly connected, primary

IKEv2 IPsec site-to-site VPN to an Azure VPN gateway
This is a sample configuration of an IPsec site-to-site VPN connection between an on-premise FortiGate and an Azure
virtual network (VNet). This example uses Azure virtual WAN (vWAN) to establish the VPN connection.

l
l

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

Azure must use IPsec v2 for this configuration.
Azure uses overlapped subnet IP addresses for the IPsec interfaces.

978

VPN

To configure IKEv2 IPsec site-to-site VPN to an Azure VPN gateway:
1. In the Azure management portal, configure vWAN-related settings as described in Tutorial: Create a Site-to-Site
connection using Azure Virtual WAN.
2. Download the VPN configuration. The following shows an example VPN configuration:
[ {"configurationVersion":{"LastUpdatedTime":"2019-0716T22:16:28.0409002Z","Version":"be5c5787-b903-43b1-a23749eae1b373e4"},"vpnSiteConfiguration":
{"Name":"toaws","IPAddress":"3.220.252.93","BgpSetting":
{"Asn":7225,"BgpPeeringAddress":"169.254.24.25","PeerWeight":32768},"LinkName":"toa
ws"},"vpnSiteConnections":[{"hubConfiguration":
{"AddressSpace":"10.1.0.0/16","Region":"West US","ConnectedSubnets":
["10.2.0.0/16"]},"gatewayConfiguration":{"IpAddresses":
{"Instance0":"52.180.90.47","Instance1":"52.180.89.94"},"BgpSetting":
{"Asn":65515,"BgpPeeringAddresses":
{"Instance0":"10.1.0.7","Instance1":"10.1.0.6"},"PeerWeight":0}},"connectionConfigu
ration":{"IsBgpEnabled":true,"PSK":"Fortinet123#","IPsecParameters":
{"SADataSizeInKilobytes":102400000,"SALifeTimeInSeconds":3600}}}]} ]

3. Configure the following on the FortiGate. Note for set proposal, you can select from several proposals.
config vpn ipsec phase1-interface
edit "toazure1"
set interface "port1"
set ike-version 2
set keylife 28800
set peertype any
set proposal aes256-sha1
set dhgrp 2
set remote-gw 52.180.90.47
set psksecret ENC
BJeE+CnBFbdepvvMMfXmb1QlWmB/QfxAvSuj0/Ol3KI3LgP0ac1Rc80YJRHN2Q7ocGpF96/7F0MCN
RjAEk62wQHeHNi8zQKc0DGTffRIyf/ln6l3JMp+r2hVFTv41HlzfKlE5L+rOuSPj4y941rJVPjIx9
aID7dAYUMUh/D1elTB/PqAXAt
0JU+9gDbki4br5Zq8tQ==
next
edit "toazure2"
set interface "port1"
set ike-version 2
set keylife 28800
set peertype any
set proposal aes256-sha1
set dhgrp 2
set remote-gw 52.180.89.94
set psksecret ENC
sNVpQEGX79oH3u57I6AjipdPALYIERj7CMDSJY7RG39g0yUmPVJVcq1+u5v3gA6URhzaD3NjqUoIf
JD3yOE34mIWFo9Q6skowGnQURlQxukENC8kTpEl3YqYESCKULoRc3/sVKDZItyjWcZ/0iHsqkCyWv
m/jDJuy3UPxI7uOktkDtZPho8
wjnMYeKmMR5EaG28oSA==
next
end
config vpn ipsec phase2-interface
edit "toazure1"
set phase1name "toazure1"
set proposal aes256-sha1
set dhgrp 2
set keylifeseconds 3600
next
edit "toazure2"
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set phase1name "toazure2"
set proposal aes256-sha1
set dhgrp 2
set keylifeseconds 3600
next
end
config system settings
set allow-subnet-overlap enable
end
config system interface
edit "toazure1"
set vdom "root"
set ip 169.254.24.25 255.255.255.255
set type tunnel
set remote-ip 10.1.0.7 255.255.255.255
set snmp-index 4
set interface "port1"
next
edit "toazure2"
set vdom "root"
set ip 169.254.24.25 255.255.255.255
set type tunnel
set remote-ip 10.1.0.6 255.255.255.255
set snmp-index 5
set interface "port1"
next
end
config router bgp
set as 7225
set router-id 169.254.24.25
config neighbor
edit "10.1.0.7"
set remote-as 65515
next
edit "10.1.0.6"
set remote-as 65515
next
end
config network
edit 1
set prefix 172.30.101.0 255.255.255.0
next
end
config redistribute "connected"
set status enable
end
config redistribute "rip"
end
config redistribute "ospf"
end
config redistribute "static"
end
config redistribute "isis"
end
config redistribute6 "connected"
end
config redistribute6 "rip"
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end
config redistribute6 "ospf"
end
config redistribute6 "static"
end
config redistribute6 "isis"
end
end

4. Run diagnose vpn tunnel list. If the configuration was successful, the output should resemble the following:
name=toazure1 ver=2 serial=3 172.30.1.83:4500->52.180.90.47:4500
bound_if=3 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/0
proxyid_num=1 child_num=0 refcnt=15 ilast=16 olast=36 ad=/0
stat: rxp=41 txp=41 rxb=5104 txb=2209
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=1
natt: mode=keepalive draft=0 interval=10 remote_port=4500
proxyid=toazure1 proto=0 sa=1 ref=2 serial=4
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=10226 type=00 soft=0 mtu=8926 expire=2463/0B replaywin=2048
seqno=2a esn=0 replaywin_lastseq=00000029 itn=0
life: type=01 bytes=0/0 timeout=3300/3600
dec: spi=c13f7928 esp=aes key=32
009a86bb0d6f5fee66af7b8232c8c0f22e6ec5c61ba19c93569bd0cd115910a9
ah=sha1 key=20 f05bfeb0060afa89d4afdfac35960a8a7a4d4856
enc: spi=b40a6c70 esp=aes key=32
a1e361075267ba72b39924c5e6c766fd0b08e0548476de2792ee72057fe60d1d
ah=sha1 key=20 b1d24bedb0eb8fbd26de3e7c0b0a3a799548f52f
dec:pkts/bytes=41/2186, enc:pkts/bytes=41/5120
-----------------------------------------------------name=toazure2 ver=2 serial=4 172.30.1.83:4500->52.180.89.94:4500
bound_if=3 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/0
proxyid_num=1 child_num=0 refcnt=16 ilast=16 olast=16 ad=/0
stat: rxp=40 txp=40 rxb=4928 txb=2135
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=1
natt: mode=keepalive draft=0 interval=10 remote_port=4500
proxyid=toazure2 proto=0 sa=1 ref=2 serial=4
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=10626 type=00 soft=0 mtu=8926 expire=2427/0B replaywin=2048
seqno=29 esn=0 replaywin_lastseq=00000028 itn=0
life: type=01 bytes=0/0 timeout=3299/3600
dec: spi=c13f791d esp=aes key=32
759898cbb7fafe448116b1fb0fb6d2f0eb99621ea6ed8dd4417ffdb901eb82be
ah=sha1 key=20 533ec5dc8a1910221e7742b12f9de1b41205622c
enc: spi=67934bfe esp=aes key=32
9b5710bfb4ba784722241ec371ba8066629febcd75da6f8471915bdeb874ca80
ah=sha1 key=20 5099fed7edac2b960294094f1a8188ab42f34d7b
dec:pkts/bytes=40/2087, enc:pkts/bytes=40/4976

Routing table for VRF=0
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
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N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default
S*
B
C
C
B
C
C
C

0.0.0.0/0 [5/0] via 172.30.1.1, port1
10.1.0.0/16 [20/0] via 10.1.0.6, toazure2, 00:15:01
10.1.0.6/32 is directly connected, toazure2
10.1.0.7/32 is directly connected, toazure1
10.2.0.0/16 [20/0] via 10.1.0.6, toazure2, 00:15:01
169.254.24.25/32 is directly connected, toazure1
is directly connected, toazure2
172.30.1.0/24 is directly connected, port1
172.30.101.0/24 is directly connected, port2

IKEv2 IPsec site-to-site VPN to an AWS VPN gateway
This is a sample configuration of an IPsec site-to-site VPN connection between an on-premise FortiGate and an AWS
virtual private cloud (VPC).
AWS uses unique identifiers to manipulate a VPN connection's configuration. Each VPN connection is assigned an
identifier and is associated with two other identifiers: the customer gateway ID for the FortiGate and virtual private
gateway ID.
This example includes the following IDs:
l
l
l

VPN connection ID: vpn-07e988ccc1d46f749
Customer gateway ID: cgw-0440c1aebed2f418a
Virtual private gateway ID

This example assumes that you have configured VPC-related settings in the AWS management portal as described in
Create and configure your VPC.
This example includes creating and configuring two tunnels. You must configure both tunnels on your FortiGate.

To configure IKEv2 IPsec site-to-site VPN to an AWS VPN gateway:
1. Configure the first VPN tunnel:
a. Configure Internet Key Exchange (IKE).
b. Configure IPsec.
c. Configure the tunnel interface.
d. Configure border gateway protocol (BGP).
e. Configure firewall policies.
2. Configure the second VPN tunnel:
a. Configure Internet Key Exchange (IKE).
b. Configure IPsec.
c. Configure the tunnel interface.
d. Configure BGP.
e. Configure firewall policies.
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To configure IKE for the first VPN tunnel:
A policy is established for the supported ISAKMP encryption, authentication, Diffie-Hellman (DH), lifetime, and key
parameters. These sample configurations fulfill the minimum requirements for AES128, SHA1, and DH Group 2.
Category VPN connections in the GovCloud AWS region have a minimum requirement of AES128, SHA2, and
DH Group 14. To take advantage of AES256, SHA256, or other DH groups such as 14-18, 22, 23, and 24, you must
modify these sample configuration files. Higher parameters are only available for VPNs of category "VPN", not for "VPNClassic".
Your FortiGate's external interface's address must be static. Your FortiGate may reside behind a device performing NAT.
To ensure NAT traversal can function, you must adjust your firewall rules to unblock UDP port 4500. If not behind NAT, it
is recommended to disable NAT traversal.
Begin configuration in the root VDOM. The interface name must be shorter than 15 characters. It is best if the name is
shorter than 12 characters. IPsec dead peer detection (DPD) causes periodic messages to be sent to ensure a security
association remains operational.
config vpn ipsec phase1-interface
edit vpn-07e988ccc1d46f749-0
set interface "wan1"
set dpd enable
set local-gw 35.170.66.108
set dhgrp 2
set proposal aes128-sha1
set keylife 28800
set remote-gw 3.214.239.164
set psksecret iCelks0UOob8z4SYMRM6zlx.rU2C3jth
set dpd-retryinterval 10
next
end

To configure IPsec for the first VPN tunnel:
The IPsec transform set defines the encryption, authentication, and IPsec mode parameters.
config vpn ipsec phase2-interface
edit "vpn-07e988ccc1d46f749-0"
set phase1name "vpn-07e988ccc1d46f749-0"
set proposal aes128-sha1
set dhgrp 2
set pfs enable
set keylifeseconds 3600
next
end

To configure the tunnel interface for the first VPN tunnel:
You must configure a tunnel interface as the logical interface associated with the tunnel. All traffic routed to the tunnel
interface must be encrypted and transmitted to the VPC. Similarly, traffic from the VPC will be logically received on this
interface.
You must configure the interface's address with your FortiGate's address. If the address changes, you must recreate the
FortiGate and VPN connection with Amazon VPC.
The tcp-mss option causes the router to reduce the TCP packets' maximum segment size to prevent packet
fragmentation.
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config system interface
edit "vpn-07e988ccc1d46f749-0"
set vdom "root"
set ip 169.254.45.90 255.255.255.255
set allowaccess ping
set type tunnel
set tcp-mss 1379
set remote-ip 169.254.45.89
set mtu 1427
set interface "wan1"
next
end

To configure BGP for the first VPN tunnel:
BGP is used within the tunnel to exchange prefixes between the virtual private gateway and your FortiGate. The virtual
private gateway announces the prefix according to your VPC.
The local BGP autonomous system number (ASN) (65000) is configured as part of your FortiGate. If you must change
the ASN, you must recreate the FortiGate and VPN connection with AWS.
Your FortiGate may announce a default route (0.0.0.0/0) to AWS. This is done using a prefix list and route map in
FortiOS.
config router bgp
set as 65000
config neighbor
edit 169.254.45.89
set remote-as 64512
end
end
end
config router bgp
config neighbor
edit 169.254.45.89
set capability-default-originate enable
end
end
end
config router prefix-list
edit "default_route"
config rule
edit 1
set prefix 0.0.0.0 0.0.0.0
next
end
end
end
config router route-map
edit "routemap1"
config rule
edit 1
set match-ip-address "default_route"
next
end
next
end
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To advertise additional prefixes to the Amazon VPC, add these prefixes to the network statement and identify the prefix
you want to advertise. Ensure that the prefix is present in the routing table of the device with a valid next-hop. If you want
to advertise 192.168.0.0/16 to Amazon, you would do the following:
config router bgp
config network
edit 1
set prefix 192.168.0.0 255.255.0.0
next
end

To configure firewall policies for the first VPN tunnel:
Create a firewall policy permitting traffic from your local subnet to the VPC subnet, and vice-versa.
This example policy permits all traffic from the local subnet to the VPC. First, view all existing policies using the show
firewall policy command. Then, create a new firewall policy starting with the next available policy ID. In this
example, running show firewall policy displayed policies 1, 2, 3, and 4, so you would proceed to create policy 5.
config firewall policy
edit 5
set srcintf "vpn-07e988ccc1d46f749-0"
set dstintf internal
set srcaddr all
set dstaddr all
set action accept
set schedule always
set service ANY
next
end
config firewall policy
edit 5
set srcintf internal
set dstintf "vpn-07e988ccc1d46f749-0"
set srcaddr all
set dstaddr all
set action accept
set schedule always
set service ANY
next
end

To configure IKE for the second VPN tunnel:
A policy is established for the supported ISAKMP encryption, authentication, DH, lifetime, and key parameters. These
sample configurations fulfill the minimum requirements for AES128, SHA1, and DH Group 2. Category VPN connections
in the GovCloud AWS region have a minimum requirement of AES128, SHA2, and DH Group 14. To take advantage of
AES256, SHA256, or other DH groups such as 14-18, 22, 23, and 24, you must modify these sample configuration files.
Higher parameters are only available for VPNs of category "VPN", not for "VPN-Classic".
Your FortiGate's external interface's address must be static. Your FortiGate may reside behind a device performing NAT.
To ensure NAT traversal can function, you must adjust your firewall rules to unblock UDP port 4500. If not behind NAT, it
is recommended to disable NAT traversal.
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Begin configuration in the root VDOM. The interface name must be shorter than 15 characters. It is best if the name is
shorter than 12 characters. IPsec DPD causes periodic messages to be sent to ensure a security association remains
operational.
config vpn ipsec phase1-interface
edit vpn-07e988ccc1d46f749-1
set interface "wan1"
set dpd enable
set local-gw 35.170.66.108
set dhgrp 2
set proposal aes128-sha1
set keylife 28800
set remote-gw 100.25.187.58
set psksecret IjFzyDneUtDdAT4RNmQ85apUG3y4Akre
set dpd-retryinterval 10
next
end

To configure IPsec for the second VPN tunnel:
The IPsec transform set defines the encryption, authentication, and IPsec mode parameters.
config vpn ipsec phase2-interface
edit "vpn-07e988ccc1d46f749-1"
set phase1name "vpn-07e988ccc1d46f749-1"
set proposal aes128-sha1
set dhgrp 2
set pfs enable
set keylifeseconds 3600
next
end

To configure the tunnel interface for the second VPN tunnel:
You must configure a tunnel interface as the logical interface associated with the tunnel. All traffic routed to the tunnel
interface must be encrypted and transmitted to the VPC. Similarly, traffic from the VPC will be logically received on this
interface.
You must configure the interface's address with your FortiGate's address. If the address changes, you must recreate the
FortiGate and VPN connection with Amazon VPC.
The tcp-mss option causes the router to reduce the TCP packets' maximum segment size to prevent packet
fragmentation.
config system interface
edit "vpn-07e988ccc1d46f749-1"
set vdom "root"
set ip 169.254.44.162 255.255.255.255
set allowaccess ping
set type tunnel
set tcp-mss 1379
set remote-ip 169.254.44.161
set mtu 1427
set interface "wan1"
next
end
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To configure BGP for the second VPN tunnel:
BGP is used within the tunnel to exchange prefixes between the virtual private gateway and your FortiGate. The virtual
private gateway announces the prefix according to your VPC.
The local BGP ASN (65000) is configured as part of your FortiGate. If you must change the ASN, you must recreate the
FortiGate and VPN connection with AWS.
Your FortiGate may announce a default route (0.0.0.0/0) to AWS. This is done using a prefix list and route map in
FortiOS.
config router bgp
set as 65000
config neighbor
edit 169.254.44.161
set remote-as 64512
end
config router bgp
config neighbor
edit 169.254.44.161
set capability-default-originate enable
end
end
config router prefix-list
edit "default_route"
config rule
edit 1
set prefix 0.0.0.0 0.0.0.0
next
end
end
end
config router route-map
edit "routemap1"
config rule
edit 1
set match-ip-address "default_route"
next
end
next
end

To advertise additional prefixes to the Amazon VPC, add these prefixes to the network statement and identify the prefix
you want to advertise. Ensure that the prefix is present in the routing table of the device with a valid next-hop. If you want
to advertise 192.168.0.0/16 to Amazon, you would do the following:
config router bgp
config network
edit 1
set prefix 192.168.0.0 255.255.0.0
next
end

To configure firewall policies for the second VPN tunnel:
Create a firewall policy permitting traffic from your local subnet to the VPC subnet, and vice-versa.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

987

VPN

This example policy permits all traffic from the local subnet to the VPC. First, view all existing policies using the show
firewall policy command. Then, create a new firewall policy starting with the next available policy ID. In this
example, running show firewall policy displayed policies 1, 2, 3, 4, and 5, so you would proceed to create policy
6.
config firewall policy
edit 6
set srcintf "vpn-07e988ccc1d46f749-1"
set dstintf internal
set srcaddr all
set dstaddr all
set action accept
set schedule always
set service ANY
next
end
config firewall policy
edit 6
set srcintf internal
set dstintf "vpn-07e988ccc1d46f749-1"
set srcaddr all
set dstaddr all
set action accept
set schedule always
set service ANY
next
end

IPsec VPN to Azure
This example shows how to configure a site-to-site IPsec VPN tunnel to Microsoft Azure. It shows how to configure a
tunnel between each site, avoiding overlapping subnets, so that a secure tunnel can be established.

Prerequisites
l
l

A FortiGate with an Internet-facing IP address
A valid Microsoft Azure account

Sample topology
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Sample configuration
This sample configuration shows how to:
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.

Configure an Azure virtual network.
Specify the Azure DNS server.
Configure the Azure virtual network gateway.
Configure the Azure local network gateway.
Configure the FortiGate tunnel.
Create the Azure firewall object.
Create the FortiGate firewall policies.
Create the FortiGate static route.
Create the Azure site-to-site VPN connection.
Check the results.

To configure an Azure virtual network:
1. Log in to Azure and click New.
2. In Search the Marketplace, type Virtual network.
3. Click Virtual network to open the Virtual network pane.

4. At the bottom of the Virtual network pane, click the Select a deployment model dropdown list and select Resource
Manager.
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5. Click Create.

6. On the Create virtual network pane, enter you virtual network settings, and click Create.
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To specify the Azure DNS server:
1. Open the virtual network you just created.
2. Click DNS servers to open the DNS servers pane.
3. Enter the IP address of the DNS server and click Save.

To configure the Azure virtual network gateway:
1. In the portal dashboard, go to New.
2. Search for Virtual Network Gateway and click it to open the Virtual network gateway pane.

3. Click Create Virtual network gateways and enter the settings for your virtual network gateway.
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4. If needed, create a Public IP address.

5. Click Create.
Creating the virtual network gateway might take some time. When the provisioning is done, you'll receive a
notification.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

992

VPN

To configure the Azure local network gateway:
1. In the portal dashboard, click All resources.
2. Click Add and then click See all.

3. In the Everything pane, search for Local network gateway and then click Create local network gateway.
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4. For the IP address, enter the local network gateway IP address, that is, the FortiGate's external IP address.

5. Set the remaining values for your local network gateway and click Create.

To configure the FortiGate tunnel:
1. In the FortiGate, go to VPN > IP Wizard.
2. Enter a Name for the tunnel, click Custom, and then click Next.

3. Configure the Network settings.
l For Remote Gateway, select Static IP Address and enter the IP address provided by Azure.
l For Interface, select wan1.
l For NAT Traversal, select Disable,
l For Dead Peer Detection, select On Idle.
l In the Authentication section, select
4. Configure the Authentication settings.
l For Method, select Pre-shared Key and enter the Pre-shared Key.
l For IKE, select 2.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

994

VPN

5. Configure the Phase 1 Proposal settings.
l Set the Encryption and Authentication combination to the three supported encryption algorithm combinations
accepted by Azure.
l AES256 and SHA1
l 3DES and SHA1
l AES256 and SHA256
l For Diffie-Hellman Groups, select 2.
l Set Key Lifetime (seconds) to 28800.

6. In Phase 2 Selectors, expand the Advanced section to configure the Phase 2 Proposal settings.
l Set the Encryption and Authentication combinations.
l AES256 and SHA1
l 3DES and SHA1
l AES256 and SHA256
l Uncheck Enable Perfect Forward Secrecy (PFS).
l Set Key Lifetime (seconds) to 27000.
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7. Click OK.

To create the Azure firewall object:
1. In the FortiGate, go to Policy & Objects > Addresses.
2. Create a firewall object for the Azure VPN tunnel.
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To create the FortiGate firewall policies:
1. In the FortiGate, go to Policy & Objects > IPv4 Policy.
2. Create a policy for the site-to-site connection that allows outgoing traffic.
l Set the Source address and Destination address using the firewall objects you just created.
l Disable NAT.

3. Create another policy that allows incoming traffic.
l For this policy, reverse the Source address and Destination address.

4. We recommend limiting the TCP maximum segment size (MSS) being sent and received so as to avoid packet
drops and fragmentation.
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To do this, use the following CLI commands on both policies.
config firewall policy
edit <policy-id>
set tcp-mss-sender 1350
set tcp-mss-receiver 1350
next
end

To create the FortiGate static route:
1. In the FortiGate, go to Network > Static Routes.
2. Create an IPv4 Static Route that forces outgoing traffic going to Azure to go through the route-based tunnel.
3. Set the Administrative Distance to a value lower than the existing default route value.

To create the Azure site-to-site VPN connection:
1. In the Azure portal, locate and select your virtual network gateway.
2. In the Settings pane, click Connections and then click Add.

3. Enter the settings for your connection. Ensure the Shared Key (PSK) matches the Pre-shared Key for the FortiGate
tunnel.
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To check the results:
1. In the FortiGate, go to Monitor > IPsec Monitor.
l Check that the tunnel is up.

l

If the tunnel is down, right-click the tunnel and select Bring Up.

2. In the FortiGate, go to Log & Report > Events.
l Select an event to view more information and verify the connection.
3. In the Azure portal dashboard, click All resources and locate your virtual network gateway.
a. In your virtual network gateway pane, click Connections to see the status of each connection.

b. Click a connection to open the Essentials pane to view more information about that connection.
l If the connection is successful, the Status shows Connected.
l See the ingress and egress bytes to confirm traffic flowing through the tunnel.
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Dialup VPN
Dialup VPN lets users connect to the Internet using a dialup connection over traditional POTS or ISDN telephone lines.
Virtual private network (VPN) protocols are used to secure these private connections.
The following topics provide instructions on configuring dialup VPN:
l
l
l

FortiGate as dialup client on page 1000
FortiClient as dialup client on page 1006
iOS device as dialup client on page 1010

FortiGate as dialup client
This is a sample configuration of dialup IPsec VPN and the dialup client. In this example, a branch office FortiGate
connects via dialup IPsec VPN to the HQ FortiGate.

You can configure dialup IPsec VPN with FortiGate as the dialup client using the GUI or CLI.

To configure IPsec VPN with FortiGate as the dialup client in the GUI:
1. Configure the dialup VPN server FortiGate:
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, select The remote site is behind NAT.
v. Click Next.
b. Configure the following settings for Authentication:
i. For Incoming Interface, select the incoming interface.
ii. For Authentication Method, select Pre-shared Key.
iii. In the Pre-shared Key field, enter your-psk as the key.
iv. Click Next.
c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select the local interface.
ii. Configure the Local Subnets as 10.1.100.0/24.
iii. Configure the Remote Subnets as 172.16.101.0/24.
iv. Click Create.
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2. Configure the dialup VPN client FortiGate:
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, select This site is behind NAT.
v. Click Next.
b. Configure the following settings for Authentication:
i. For IP Address, enter 11.101.1.1.
ii. For Outgoing Interface, select port13.
iii. For Authentication Method, select Pre-shared Key.
iv. In the Pre-shared Key field, enter your-psk as the key.
v. Click Next.
c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select the local interface. In this example, it is port9.
ii. Configure the Local Subnets as 172.16.101.0.
iii. Configure the Remote Subnets as 10.1.100.0.
iv. Click Create.

To configure IPsec VPN with FortiGate as the dialup client in the CLI:
1. In the CLI, configure the user, user group, and firewall address. Only the HQ dialup server FortiGate needs this
configuration. The address is an IP pool to assign an IP address for the dialup client FortiGate.
config user local
edit "vpnuser1"
set type password
set passwd your-password
next
end
config user group
edit "vpngroup"
set member "vpnuser1"
next
end
config firewall address
edit "client_range"
set type iprange
set start-ip 10.10.10.1
set end-ip 10.10.10.200
next
end

2. Configure the WAN interface and default route. The WAN interface is the interface connected to the ISP. It can work
in static mode (as shown in this example), DHCP, or PPPoE mode. The IPsec tunnel is established over the
WAN interface.
a. Configure the HQ FortiGate.
config system interface
edit "wan1"
set vdom "root"
set ip 11.101.1 255.255.255.0
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next
end
config router static
edit 1
set gateway 11.101.1.2
set device "wan1"
next
end

b. Configure the branch office FortiGate.
config system interface
edit "port13"
set vdom "root"
set ip 173.1.1.1 255.255.255.0
next
end
config router static
edit 1
set gateway 173.1.1.2
set device "port13"
next
end

3. Configure the internal interface and protected subnet. The internal interface connects to the internal network. Traffic
from this interface will route out the IPsec VPN tunnel.
a. Configure the HQ FortiGate.
config system interface
edit "dmz"
set vdom "root"
set ip 10.1.100.1 255.255.255.0
next
end
config firewall address
edit "10.1.100.0"
set subnet 10.1.100.0 255.255.255.0
next
end

b. Configure the branch office FortiGate.
config system interface
edit "port9"
set vdom "root"
set ip 172.16.101.1 255.255.255.0
next
end
config firewall address
edit "172.16.101.0"
set subnet 172.16.101.0 255.255.255.0
next
end

4. Configure the IPsec phase1-interface. In this example, PSK is used as the authentication method. Signature
authentication is also an option.
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a. Configure the HQ FortiGate.
config vpn ipsec phase1-interface
edit "for_Branch"
set type dynamic
set interface "wan1"
set mode aggressive
set peertype any
set mode-cfg enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set xauthtype auto
set authusrgrp "vpngroup"
set net-device enable
set assign-ip-from name
set dns-mode auto
set ipv4-split-include "10.1.100.0"
set ipv4-name "client_range"
set save-password enable
set psksecret sample
set dpd-retryinterval 60
next
end

b. Configure the branch office FortiGate.
config vpn ipsec phase1-interface
edit "to_HQ"
set interface "port13"
set mode aggressive
set peertype any
set mode-cfg enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set xauthtype client
set authusr "vpnuser1"
set authpasswd vpnuser1-password
set remote-gw 11.101.1.1
set psksecret sample
next
end

5. Configure the IPsec phase2-interface.
a. Configure the HQ FortiGate:
config vpn ipsec phase2-interface
edit "for_Branch_p2"
set phase1 name "for_Branch"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end

b. Configure the branch office FortiGate.
config vpn ipsec phase2-interface
edit "to_HQ_p2"
set phase1name "to_HQ"
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set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end

6. Configure the static routes on the branch office FortiGate. The blackhole route is important to ensure that IPsec
traffic does not match the default route when the IPsec tunnel is down.
config router static
edit 2
set dst 10.1.100.0 255.255.255.0
set device "to_HQ"
next
edit 3
set dst 10.1.100.0 255.255.255.0
set blackhole enable
set distance 254
next
end

7. Configure the firewall policy to allow the branch office to HQ network flow over the IPsec tunnel. This configuration
only supports traffic from the branch office FortiGate to the HQ FortiGate. Traffic is dropped from the HQ FortiGate
to the branch office FortiGate.
a. Configure the HQ FortiGate.
config firewall policy
edit 1
set name "inbound"
set srcintf "for_Branch"
set dstintf "dmz"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
end

b. Configure the branch office FortiGate.
config firewall policy
edit 1
set name "outbound"
set srcintf "port9"
set dstintf "to_HQ"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
end

8. Run diagnose commands to check the IPsec phase1/phase2 interface status. The diagnose debug
application ike -1 command is the key to troubleshoot why the IPsec tunnel failed to establish.
a. Run the diagnose vpn ike gateway list command on the HQ FortiGate. The system should return the
following:
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vd: root/0
name: for_Branch_0
version: 1
interface: wan1 5
addr: 11.101.1.1:500 -> 173.1.1.1:500
created: 1972s ago
xauth-user: vpnuser1
assigned IPv4 address: 10.10.10.1/255.255.255.252
IKE SA: created 1/1 established 1/1 time 10/10/10 ms
IPsec SA: created 1/1 established 1/1 time 0/0/0 ms
id/spi: 184 5b1c59fab2029e43/bf517e686d3943d2
direction: responder
status: established 1972-1972s ago = 10ms
proposal: aes128-sha256
key: 8046488e92499247-fbbb4f6dfa4952d0
lifetime/rekey: 86400/84157
DPD sent/recv: 00000020/00000000

b. Run the diagnose vpn tunnel list command on the HQ FortiGate. The system should return the
following:
list all ipsec tunnel in vd 0
name=for_Branch_0 ver=1 serial=9 11.101.1.1:0->173.1.1.1:0
bound_if=5 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/208 options
[00d0]=create_dev no-sysctlrgwy-chg
parent=for_Branch index=0
proxyid_num=1 child_num=0 refcnt=12 ilast=8 olast=8 ad=/0
stat: rxp=8 txp=8 rxb=1216 txb=672
dpd: mode=on-idle on=1 idle=60000ms retry=3 count=0 seqno=31
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=for_Branch_p2 proto=0 sa=1 ref=2 serial=1
src: 0:0.0.0.0-255.255.255.255:0
dst: 0:0.0.0.0-255.255.255.255:0
SA: ref=3 options=226 type=00 soft=0 mtu=1438 expire=41297/0B replaywin=2048 seqno=9
esn=0 replaywin_lastseq=00000009 itn=0
life: type=01 bytes=0/0 timeout=43190/43200
dec: spi=747c10c6 esp=aes key=16 278c2430e09e74f1e229108f906603b0
ah=sha1 key=20 21dad76b008d1e8b8e53148a2fcbd013a277974a
enc: spi=ca646448 esp=aes key=16 b7801d125804e3610a556da7caefd765
ah=sha1 key=20 a70164c3094327058bd84c1a0c954ca439709206
dec:pkts/bytes=8/672, enc:pkts/bytes=8/1216
name=for_Branchver=1 serial=6 11.101.1.1:0->0.0.0.0:0
bound_if=5 lgwy=static/1 tun=intf/0 mode=dialup/2 encap=none/16 options[0010]=create_
dev
proxyid_num=0 child_num=1 refcnt=14 ilast=8523 olast=8523 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=60000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
run_tally=0

c. Run the diagnose vpn ike gateway list command on the branch office FortiGate. The system should
return the following:
vd: root/0
name: to_HQ
version: 1
interface: port13 42
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addr: 173.1.1.1:500 -> 11.101.1.1:500
created: 2016s ago
assigned IPv4 address: 10.10.10.1/255.255.255.252
IKE SA: created 1/1 established 1/1 time 0/0/0 ms
IPsec SA: created 1/1 established 1/1 time 0/0/0 ms
id/spi: 93 5b1c59fab2029e43/bf517e686d3943d2
direction: initiator
status: established 2016-2016s ago = 0ms
proposal: aes128-sha256
key: 8046488e92499247-fbbb4f6dfa4952d0
lifetime/rekey: 86400/84083
DPD sent/recv: 00000000/00000020

d. Run the diagnose vpn tunnel list command on the branch office FortiGate. The system should return
the following:
list all ipsec tunnel in vd 0
name=to_HQver=1 serial=7 173.1.1.1:0->11.101.1.1:0
bound_if=42 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/8 options[0008]=npu
proxyid_num=1 child_num=0 refcnt=13 ilast=18 olast=58 ad=/0
stat: rxp=1 txp=2 rxb=152 txb=168
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=to_HQ proto=0 sa=1 ref=2 serial=1
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=10226 type=00 soft=0 mtu=1438 expire=41015/0B replaywin=2048
seqno=3 esn=0 replaywin_lastseq=00000002 itn=0
life: type=01 bytes=0/0 timeout=42898/43200
dec: spi=ca646448 esp=aes key=16 b7801d125804e3610a556da7caefd765
ah=sha1 key=20 a70164c3094327058bd84c1a0c954ca439709206
enc: spi=747c10c6 esp=aes key=16 278c2430e09e74f1e229108f906603b0
ah=sha1 key=20 21dad76b008d1e8b8e53148a2fcbd013a277974a
dec:pkts/bytes=1/84, enc:pkts/bytes=2/304
npu_flag=03 npu_rgwy=11.101.1.1 npu_lgwy=173.1.1.1 npu_selid=5 dec_npuid=2 enc_
npuid=2

FortiClient as dialup client
This is a sample configuration of dialup IPsec VPN with FortiClient as the dialup client.

You can configure dialup IPsec VPN with FortiClient as the dialup client using the GUI or CLI.
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To configure IPsec VPN with FortiClient as the dialup client on the GUI:
1. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
a. Enter a VPN name.
b. For Template Type, select Remote Access.
c. For Remote Device Type, select Client-based > FortiClient.
d. Click Next.
2. Configure the following settings for Authentication:
a. For Incoming Interface, select wan1.
b. For Authentication Method, select Pre-shared Key.
c. In the Pre-shared Key field, enter your-psk as the key.
d. From the User Group dropdown list, select vpngroup.
e. Click Next.
3. Configure the following settings for Policy & Routing:
a. From the Local Interface dropdown menu, select lan.
b. Configure the Local Address as local_network.
c. Configure the Client Address Range as 10.10.2.1-10.10.2.200.
d. Keep the default values for the Subnet Mask, DNS Server, Enable IPv4 Split tunnel, and Allow Endpoint
Registration.
e. Click Create.

To configure IPsec VPN with FortiClient as the dialup client using the CLI:
1. In the CLI, configure the user and group.
config user local
edit "vpnuser1"
set type password
set passwd your-password
next
end
config user group
edit "vpngroup"
set member "vpnuser1"
next
end

2. Configure the internal interface. The LAN interface connects to the corporate internal network. Traffic from this
interface routes out the IPsec VPN tunnel. Creating an address group for the protected network behind this
FortiGate causes traffic to this network group to go through the IPsec tunnel.
config system interface
edit "lan"
set vdom "root"
set ip 10.10.111.1 255.255.255.0
next
end
config firewall address
edit "local_subnet_1"
set ip 10.10.111.0 255.255.255.0
next
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end
config firewall address
edit "local_subnet_2"
set ip 10.10.112.0 255.255.255.0
next
end
config firewall addrgrp
edit "local_network"
set member "local_subnet_1" "local_subnet_2"
next
end

3. Configure the WAN interface. The WAN interface is the interface connected to the ISP. It can work in static mode
(as shown in this example), DHCP, or PPPoE mode. The IPsec tunnel is established over the WAN interface.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

4. Configure the client address pool. You must create a firewall address to assign an IP address to a client from the
address pool.
config firewall address
edit "client_range"
set type iprange
set comment "VPN client range"
set start-ip 10.10.2.1
set end-ip 10.10.2.200
next
end

5. Configure the IPsec phase1-interface. In this example, PSK is used as the authentication method. Signature
authentication is also an option.
config vpn ipsec phase1-interface
edit "for_client"
set type dynamic
set interface "wan1"
set mode aggressive
set peertype any
set net-device enable
set mode-cfg enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set dpd on-idle
set xauthtype auto
set authusrgrp "vpngroup"
set assign-ip-from name
set ipv4-name "client_range"
set dns-mode auto
set ipv4-split-include "local_network"
set save-password enable
set psksecret your-psk
set dpd-retryinterval 60
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next
end

6. Configure the IPsec phase2-interface.
config vpn ipsec phase2-interface
edit "for_client"
set phase1name "for_client"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end

7. Configure the firewall policy to allow client traffic flow over the IPsec VPN tunnel.
config firewall policy
edit 1
set name "inbound"
set srcintf "for_client"
set dstintf "lan"
set srcaddr "client_range"
set dstaddr "local_network"
set action accept
set schedule "always"
set service "ALL"
next
end

8. Configure FortiClient. This example uses FortiClient (Windows) 6.0.3 build 0155.
a. In FortiClient, go to Remote Access and select Add a new connection.
b. Set the Type to IPsec VPN and the Remote Gateway to the FortiGate IP address.
c. Set the Authentication Method to Pre-Shared Key and enter the key. Click Save.
d. Select the VPN, enter the username and password, then select Connect.
9. Run diagnose commands to check the IPsec phase1/phase2 interface status. The diagnose debug
application ike -1 command is the key to troubleshoot why the IPsec tunnel failed to establish.
a. Run the diagnose vpn ike gateway list command. The system should return the following:
vd: root/0
name: for_client_0
version: 1
interface: port1 15
addr: 172.20.120.123:4500 ->172.20.120.254:64916
created: 37s ago
xauth-user: vpnuser1
assigned IPv4 address: 10.10.1.1/255.255.255.255
nat: me peer
IKE SA: created 1/1 established 1/1 time 10/10/10 ms
IPsec SA: created 1/1 established 1/1 time 0/0/0 ms
id/spi: 1 b40a32d878d5e262/8bba553563a498f4
direction: responder
status: established 37-37s ago = 10ms
proposal: aes256-sha256
key: f4ad7ec3a4fcfd09-787e2e9b7bceb9a7-0dfa183240d838ba-41539863e5378381
lifetime/rekey: 86400/86092
DPD sent/recv: 00000000/00000a0e
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b. Run the diagnose vpn tunnel list command. The system should return the following:
list all ipsec tunnel in vd 0
=
=
name=for_client_0 ver=1 serial=3 172.20.120.123:4500->172.20.120.254:64916
bound_if=15 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/984 options
[03d8]=npucreate_dev no-sysctlrgwy-chgrport-chg frag-rfcaccept_traffic=1
parent=for_client index=0
proxyid_num=1 child_num=0 refcnt=12 ilast=3 olast=3 ad=/0
stat: rxp=1 txp=0 rxb=16402 txb=0
dpd: mode=on-idle on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=keepalive draft=32 interval=10 remote_port=64916
proxyid=for_client proto=0 sa=1 ref=2 serial=1 add-route
src: 0:0.0.0.0-255.255.255.255:0
dst: 0:10.10.1.1-10.10.1.1:0
SA: ref=4 options=2a6 type=00 soft=0 mtu=1422 expire=42867/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000001 itn=0
life: type=01 bytes=0/0 timeout=43189/43200
dec: spi=36274d14 esp=aes key=16 e518b84b3c3b667b79f2e61c64a225a6
ah=sha1 key=20 9cceaa544ed042fda800c4fe5d3fd9d8b811984a
enc: spi=8b154deb esp=aes key=16 9d50f004b45c122e4e9fb7af085c457c
ah=sha1 key=20 f1d90b2a311049e23be34967008239637b50a328
dec:pkts/bytes=1/16330, enc:pkts/bytes=0/0
npu_flag=02 npu_rgwy=172.20.120.254 npu_lgwy=172.20.120.123npu_selid=0 dec_npuid=2
enc_npuid=0
name=for_clientver=1 serial=2 172.20.120.123:0->0.0.0.0:0
bound_if=15 lgwy=static/1 tun=intf/0 mode=dialup/2 encap=none/536 options
[0218]=npucreate_dev frag-rfcaccept_traffic=1
proxyid_num=0 child_num=1 refcnt=11 ilast=350 olast=350 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0

iOS device as dialup client
This is a sample configuration of dialup IPsec VPN with an iPhone or iPad as the dialup client.

You can configure dialup IPsec VPN with an iOS device as the dialup client using the GUI or CLI.

To configure IPsec VPN with an iOS device as the dialup client on the GUI:
1. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
a. Enter a VPN name.
b. For Template Type, select Remote Access.
c. For Remote Device Type, select Native > iOS Native.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1010

VPN
d. For NAT Configuration, set No NAT Between Sites.
e. Click Next.
2. Configure the following settings for Authentication:
a. For Incoming Interface, select wan1.
b. For Authentication Method, select Pre-shared Key.
c. In the Pre-shared Key field, enter your-psk as the key.
d. From the User Group dropdown list, select vpngroup.
e. Deselect Require 'Group Name' on VPN client.
f. Click Next.
3. Configure the following settings for Policy & Routing:
a. From the Local Interface dropdown menu, select lan.
b. Configure the Local Address as local_network.
c. Configure the Client Address Range as 10.10.2.1-10.10.2.200.
d. Keep the default values for the Subnet Mask, DNS Server, and Enable IPv4 Split tunnel.
e. Click Create.

To configure IPsec VPN with an iOS device as the dialup client using the CLI:
1. In the CLI, configure the user and group.
config user local
edit "vpnuser1"
set type password
set passwd your-password
next
end
config user group
edit "vpngroup"
set member "vpnuser1"
next
end

2. Configure the internal interface. The LAN interface connects to the corporate internal network. Traffic from this
interface routes out the IPsec VPN tunnel. Creating an address group for the protected network behind this
FortiGate causes traffic to this network group to go through the IPsec tunnel.
config system interface
edit "lan"
set vdom "root"
set ip 10.10.111.1 255.255.255.0
next
end
config firewall address
edit "local_subnet_1"
set ip 10.10.111.0 255.255.255.0
next
end
config firewall address
edit "local_subnet_2"
set ip 10.10.112.0 255.255.255.0
next
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end
config firewall addrgrp
edit "local_network"
set member "local_subnet_1" "local_subnet_2"
next
end

3. Configure the WAN interface. The WAN interface is the interface connected to the ISP. It can work in static mode
(as shown in this example), DHCP, or PPPoE mode. The IPsec tunnel is established over the WAN interface.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

4. Configure the client address pool. You must create a firewall address to assign an IP address to a client from the
address pool.
config firewall address
edit "client_range"
set type iprange
set comment "VPN client range"
set start-ip 10.10.2.1
set end-ip 10.10.2.200
next
end

5. Configure the IPsec phase1-interface. In this example, PSK is used as the authentication method. Signature
authentication is also an option.
config vpn ipsec phase1-interface
edit "for_ios_p1"
set type dynamic
set interface "wan1"
set peertype any
set net-device enable
set mode-cfg enable
set proposal aes256-sha256 aes256-md5 aes256-sha1
set dpd on-idle
set dhgrp 14 5 2
set xauthtype auto
set authusrgrp "vpngroup"
set assign-ip-from name
set ipv4-name "client_range"
set dns-mode auto
set ipv4-split-include "local_network"
set psksecret your-psk
set dpd-retryinterval 60
next
end

6. Configure the IPsec phase2-interface.
config vpn ipsec phase2-interface
edit "for_ios_p2"
set phase1name "for_ios_p1"
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set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set pfs disable
set keepalive enable
next
end

7. Configure the firewall policy to allow client traffic flow over the IPsec VPN tunnel.
config firewall policy
edit 1
set name "ios_vpn"
set srcintf "for_ios_p1"
set dstintf "lan"
set srcaddr "ios_range"
set dstaddr "local_network"
set action accept
set schedule "always"
set service "ALL"
next
end

8. Configure the iOS device.
a. In the iOS device, go to Settings > General > VPN and select Add VPN Configuration.
b. Set the Type to IPsec and enter a Description. Set the Server to the FortiGate's Internet-facing interface, and
enter the username in Account. Enter the user password, the preshared IPsec VPN secret, then select Done.
c. Ensure that the IPsec VPN configuration is highlighted (indicated by a checkmark), and select the Not
Connected button. The IPsec VPN connects with the user's credentials and secret. The status changes to
Connected, and a VPN icon appears at the top of the screen.
9. Run diagnose commands to check the IPsec phase1/phase2 interface status. The diagnose debug
application ike -1 command is the key to troubleshoot why the IPsec tunnel failed to establish.
a. Run the diagnose vpn ike gateway list command. The system should return the following:
vd: root/0
name: for_ios_p1_0
version: 1
interface: port1 15
addr: 172.20.120.123:4500 -> 172.20.120.254:64916
created: 17s ago
xauth-user: u1
assigned IPv4 address: 10.10.2.1/255.255.255.255
nat: me peer
IKE SA: created 1/1 established 1/1 time 150/150/150 ms
IPsec SA: created 1/1 established 1/1 time 10/10/10 ms
id/spi: 2 3c844e13c75591bf/80c2db92c8d3f602 direction: responder status: established
17-17s ago = 150ms proposal: aes256-sha256 key: 0032ea5ee160d775-51f3bf1f9909101bb89c7b5a77a07784-2c92cf9c921801ac lifetime/rekey: 3600/3312 DPD sent/recv:
00000000/00000000

b. Run the diagnose vpn tunnel list command. The system should return the following:
list all ipsec tunnel in vd 0
=
=
name=for_ios_p1_0 ver=1 serial=172.20.120.123:4500->172.20.120.254:64916
bound_if=15 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/984 options
[03d8]=npu create_dev no-sysctl rgwy-chg rport-chg frag-rfc accept_traffic=1
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parent=for_ios_p1 index=0
proxyid_num=1 child_num=0 refcnt=12 ilast=23 olast=23 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=1 idle=60000ms retry=3 count=0 seqno=0
natt: mode=keepalive draft=32 interval=10 remote_port=64916
proxyid=for_ios_p1 proto=0 sa=1 ref=2 serial=1 add-route
src: 0:10.10.111.0-10.10.111.255:0 dst: 0:10.10.2.1-10.10.2.1:0 SA: ref=3 options=a7
type=00 soft=0 mtu=1422 expire=3564/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0
life: type=01 bytes=0/0 timeout=3587/3600 dec: spi=36274d15 esp=aes key=32
5a599d796f8114c83d6589284f036fc33bdf4456541e2154b4ac2217b6aec869
ah=sha1 key=20 f1efdeb77d6f856a8dd3a30cbc23cb0f8a3e0340
enc: spi=00b0d9ab esp=aes key=32
e9232d7a1c4f390fd09f8409c2d85f80362d940c08c73f245908ab1ac3af322f
ah=sha1 key=20 a3890d6c5320756291cad85026d3a78fd42a1b42
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0 npu_flag=00 npu_rgwy=172.20.120.254 npu_
lgwy=172.20.120.123 npu_selid=1 dec_npuid=0 enc_npuid=0

ADVPN
Auto-Discovery VPN (ADVPN) allows the central hub to dynamically inform spokes about a better path for traffic
between two spokes.
The following topics provide instructions on configuring ADVPN:
l
l
l
l

ADVPN with BGP as the routing protocol on page 1014
ADVPN with OSPF as the routing protocol on page 1023
ADVPN with RIP as the routing protocol on page 1032
IPsec VPN wizard hub-and-spoke ADVPN support on page 1041

ADVPN with BGP as the routing protocol
This is a sample configuration of ADVPN with BGP as the routing protocol. The following options must be enabled for
this configuration:
l
l
l

On the hub FortiGate, IPsec phase1-interface net-device disable must be run.
IBGP must be used between the hub and spoke FortiGates.
bgp neighbor-group/neighbor-range must be reused.

Because the GUI can only complete part of the configuration, we recommend using the CLI.
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To configure ADVPN with BGP as the routing protocol using the CLI:
1. Configure hub FortiGate's WAN, internal interface, and static route.
config system interface
edit "port9"
set alias "WAN"
set ip 22.1.1.1 255.255.255.0
next
edit "port10"
set alias "Internal"
set ip 172.16.101.1 255.255.255.0
next
end
config router static
edit 1
set gateway 22.1.1.2
set device "port9"
next
end

2. Configure the hub FortiGate.
a. Configure the hub FortiGate IPsec phase1-interface and phase2-interface.
config vpn ipsec phase1-interface
edit "advpn-hub"
set type dynamic
set interface "port9"
set peertype any
set net-device disable
set proposal aes128-sha256 aes256-sha256 3des-sha256 aes128-sha1 aes256-sha1
3des-sha1
set add-route disable
set dpd on-idle
set auto-discovery-sender enable
set tunnel-search nexthop
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "advpn-hub"
set phase1name "advpn-hub"
set proposal aes128-sha1 aes256-sha1 3des-sha1 aes128-sha256 aes256-sha256
3des-sha256
next
end

b. Configure the hub FortiGate firewall policy.
config firewall policy
edit 1
set name "spoke2hub"
set srcintf "advpn-hub"
set dstintf "port10"
set srcaddr "all"
set dstaddr "172.16.101.0"
set action accept
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set schedule "always"
set service "ALL"
next
edit 2
set
set
set
set
set
set
set
set
next

name "spoke2spoke"
srcintf "advpn-hub"
dstintf "advpn-hub"
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"

end

c. Configure the hub FortiGate's IPsec tunnel interface IP address.
config system interface
edit "advpn-hub1"
set ip 10.10.10.254 255.255.255.255
set remote-ip 10.10.10.253 255.255.255.0
next
end

d. Configure the hub FortiGate's BGP.
config router bgp
set as 65412
config neighbor-group
edit "advpn"
set link-down-failover enable
set remote-as 65412
set route-reflector-client enable
next
end
config neighbor-range
edit 1
set prefix 10.10.10.0 255.255.255.0
set neighbor-group "advpn"
next
end
config network
edit 1
set prefix 172.16.101.0 255.255.255.0
next
end
end

3. Configure the spoke FortiGates.
a. Configure the spoke FortiGates' WAN, internal interfaces, and static routes.
i. Configure Spoke1.
config system interface
edit "wan1"
set alias "primary_WAN"
set ip 15.1.1.2 255.255.255.0
next
edit "wan2"
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set alias "secondary_WAN"
set ip 12.1.1.2 255.255.255.0
next
edit "internal"
set ip 10.1.100.1 255.255.255.0
next
end
config router static
edit 1
set gateway 12.1.1.1
set device "wan2"
set distance 15
next
edit 2
set gateway 15.1.1.1
set device "wan1"
next
end

ii. Configure the Spoke2.
config system interface
edit "wan1"
set alias "primary_WAN"
set ip 13.1.1.2 255.255.255.0
next
edit "wan2"
set alias "secondary_WAN"
set ip 17.1.1.2 255.255.255.0
next
edit "internal"
set ip 192.168.4.1 255.255.255.0
next
end
config router static
edit 1
set gateway 17.1.1.1
set device "wan2"
set distance 15
next
edit 2
set gateway 13.1.1.1
set device "wan1"
next
end

b. Configure the spoke FortiGates' IPsec phase1-interface and phase2-interface.
i. Configure Spoke1.
config vpn ipsec phase1-interface
edit "spoke1"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
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set remote-gw 22.1.1.1
set psksecret sample
set dpd-retryinterval 5
next
edit "spoke1_backup"
set interface "wan2"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
set monitor "spoke1"
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "spoke1"
set phase1name "spoke1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
edit "spoke1_backup"
set phase1name "spoke1_backup"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

ii. Configure Spoke2.
config vpn ipsec phase1-interface
edit "spoke2"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
set psksecret sample
set dpd-retryinterval 5
next
edit "spoke2_backup"
set interface "wan2"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
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set monitor "spoke2"
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "spoke2"
set phase1name "spoke2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
edit "spoke2_backup"
set phase1name "spoke2_backup"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

c. Configure the spoke FortiGates' firewall policies.
i. Configure Spoke1.
config firewall policy
edit 1
set name "outbound_advpn"
set srcintf "internal"
set dstintf "spoke1" "spoke1_backup"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "inbound_advpn"
set srcintf "spoke1" "spoke1_backup"
set dstintf "internal"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
end

ii. Configure Spoke2.
config firewall policy
edit 1
set name "outbound_advpn"
set srcintf "internal"
set dstintf "spoke2" "spoke2_backup"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
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next
edit 2
set
set
set
set
set
set
set
set
next

name "inbound_advpn"
srcintf "spoke2" "spoke2_backup"
dstintf "internal"
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"

end

d. Configure the spoke FortiGates' tunnel interface IP addresses.
i. Configure Spoke1.
config system interface
edit "spoke1"
set ip 10.10.10.1 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
edit "spoke1_backup"
set ip 10.10.10.2 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
end

ii. Configure Spoke2.
config system interface
edit "spoke2"
set ip 10.10.10.3 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
edit "spoke2_backup"
set ip 10.10.10.4 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
end

e. Configure the spoke FortiGates' BGP.
i. Configure Spoke1.
config router bgp
set as 65412
config neighbor
edit "10.10.10.254"
set advertisement-interval 1
set link-down-failover enable
set remote-as 65412
next
end
config network
edit 1
set prefix 10.1.100.0 255.255.255.0
next
end
end
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ii. Configure Spoke2.
config router bgp
set as 65412
config neighbor
edit "10.10.10.254"
set advertisement-interval 1
set link-down-failover enable
set remote-as 65412
next
end
config network
edit 1
set prefix 192.168.4.0 255.255.255.0
next
end
end

4. Run diagnose and get commands run on Spoke1 to check VPN and BGP states.
a. Run the diagnose vpn tunnel list command on Spoke1. The system should return the following:
list all ipsec tunnel in vd 0
---name=spoke1 ver=1 serial=2 15.1.1.2:0->22.1.1.1:0
bound_if=7 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=1
proxyid_num=1 child_num=1 refcnt=19 ilast=1 olast=1 ad=r/2
stat: rxp=1 txp=160 rxb=16428 txb=8969
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=628
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1 proto=0 sa=1 ref=6 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=1438 expire=1225/0B replaywin=1024
seqno=a1 esn=0 replaywin_lastseq=00000002 itn=0
life: type=01 bytes=0/0 timeout=2369/2400
dec: spi=c53a8f5b esp=aes key=16 cbe88682ad896a69290027b6dd8f7162
ah=sha1 key=20 7bb704b388f83783ac76c2ab0b6c9f7dcf78e93b
enc: spi=6e3633fc esp=aes key=16 1a0da3f4deed3d16becc9dda57537355
ah=sha1 key=20 368544044bd9b82592d72476ff93d5055056da8d
dec:pkts/bytes=1/16364, enc:pkts/bytes=160/19168
npu_flag=03 npu_rgwy=22.1.1.1 npu_lgwy=15.1.1.2 npu_selid=1 dec_npuid=1 enc_npuid=1
---name=spoke1_backup ver=1 serial=1 12.1.1.2:0->22.1.1.1:0
bound_if=6 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=11 ilast=0 olast=0 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=5000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1_backup proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
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b. Run the get router info bgp summary command on Spoke1. The system should return the following:
BGP router identifier 7.7.7.7, local AS number 65412
BGP table version is 2
1 BGP AS-PATH entries
0 BGP community entries
Neighbor
V
AS [[QualityAssurance62/MsgRcvd]]
[[QualityAssurance62/MsgSent]]
[[QualityAssurance62/TblVer]] InQ OutQ Up/Down
State/PfxRcd
10.10.10.254
1.
65412
143
142
1.
1.
1.
00:24:45
2
Total number of neighbors 1

c. Run the get router info routing-table bgp command on Spoke1. The system should return the
following:
Routing table for VRF=0
B
172.16.101.0/24 [200/0] via 10.10.10.254, spoke1, 00:23:57
B
192.168.4.0/24 [200/0] via 10.10.10.254, spoke1, 00:22:03

d. Generate traffic between the spokes and check the shortcut tunnel and routing table. Run the diagnose vpn
tunnel list command on Spoke1. The system should return the following:
list all ipsec tunnel in vd 0
---name=spoke1 ver=1 serial=2 15.1.1.2:0->22.1.1.1:0
bound_if=7 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=1
proxyid_num=1 child_num=1 refcnt=19 ilast=2 olast=2 ad=r/2
stat: rxp=1 txp=268 rxb=16428 txb=31243
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=714
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1 proto=0 sa=1 ref=6 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=1438 expire=345/0B replaywin=1024
seqno=10d esn=0 replaywin_lastseq=00000002 itn=0
life: type=01 bytes=0/0 timeout=2369/2400
dec: spi=c53a8f5b esp=aes key=16 cbe88682ad896a69290027b6dd8f7162
ah=sha1 key=20 7bb704b388f83783ac76c2ab0b6c9f7dcf78e93b
enc: spi=6e3633fc esp=aes key=16 1a0da3f4deed3d16becc9dda57537355
ah=sha1 key=20 368544044bd9b82592d72476ff93d5055056da8d
dec:pkts/bytes=1/16364, enc:pkts/bytes=268/48320
npu_flag=03 npu_rgwy=22.1.1.1 npu_lgwy=15.1.1.2 npu_selid=1 dec_npuid=1 enc_npuid=1
---name=spoke1_backup ver=1 serial=1 12.1.1.2:0->22.1.1.1:0
bound_if=6 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=11 ilast=8 olast=8 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=5000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1_backup proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
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dst: 0:0.0.0.0/0.0.0.0:0
---name=spoke1_0 ver=1 serial=9 15.1.1.2:4500->13.1.1.2:4500
bound_if=7 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/728 options[02d8]=npu
create_dev no-sysctl rgwy-chg frag-rfc accept_traffic=1
parent=spoke1 index=0
proxyid_num=1 child_num=0 refcnt=17 ilast=4 olast=4 ad=r/2
stat: rxp=1 txp=100 rxb=112 txb=4686
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=231
natt: mode=keepalive draft=32 interval=10 remote_port=4500
proxyid=spoke1 proto=0 sa=1 ref=5 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=1422 expire=447/0B replaywin=1024
seqno=65 esn=0 replaywin_lastseq=00000002 itn=0
life: type=01 bytes=0/0 timeout=2368/2400
dec: spi=c53a8f5c esp=aes key=16 73fd9869547475db78851e6c057ad9b7
ah=sha1 key=20 6ad3a5b1028f6b33c82ba494a370f13c7f462635
enc: spi=79cb0f2b esp=aes key=16 52ab0acdc830d58c00e5956a6484654a
ah=sha1 key=20 baa82aba4106dc60618f6fe95570728656799239
dec:pkts/bytes=1/46, enc:pkts/bytes=100/11568
npu_flag=03 npu_rgwy=13.1.1.2 npu_lgwy=15.1.1.2 npu_selid=5 dec_npuid=1 enc_npuid=1

e. Run the get router info routing-tale bgp command. The system should return the following:
Routing table for VRF=0
B
172.16.101.0/24 [200/0] via 10.10.10.254, spoke1, 00:23:57
B
192.168.4.0/24 [200/0] via 10.10.10.3, spoke1_0 , 00:22:03

ADVPN with OSPF as the routing protocol
This is a sample configuration of ADVPN with OSPF as the routing protocol. The following options must be enabled for
this configuration:
l
l

On the hub FortiGate, IPsec phase1-interface net-device enable must be run.
OSPF must be used between the hub and spoke FortiGates.

Because the GUI can only complete part of the configuration, we recommend using the CLI.
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To configure ADVPN with OSPF as the routing protocol using the CLI:
1. Configure hub FortiGate's WAN, internal interface, and static route.
config system interface
edit "port9"
set alias "WAN"
set ip 22.1.1.1 255.255.255.0
next
edit "port10"
set alias "Internal"
set ip 172.16.101.1 255.255.255.0
next
end
config router static
edit 1
set gateway 22.1.1.2
set device "port9"
next
end

2. Configure the hub FortiGate.
a. Configure the hub FortiGate IPsec phase1-interface and phase2-interface.
config vpn ipsec phase1-interface
edit "advpn-hub"
set type dynamic
set interface "port9"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 3des-sha256 aes128-sha1 aes256-sha1
3des-sha1
set add-route disable
set dpd on-idle
set auto-discovery-sender enable
set tunnel-search nexthop
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "advpn-hub"
set phase1name "advpn-hub"
set proposal aes128-sha1 aes256-sha1 3des-sha1 aes128-sha256 aes256-sha256
3des-sha256
next
end

b. Configure the hub FortiGate firewall policy.
config firewall policy
edit 1
set name "spoke2hub"
set srcintf "advpn-hub"
set dstintf "port10"
set srcaddr "all"
set dstaddr "172.16.101.0"
set action accept
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set schedule "always"
set service "ALL"
next
edit 2
set
set
set
set
set
set
set
set
next

name "spoke2spoke"
srcintf "advpn-hub"
dstintf "advpn-hub"
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"

end

c. Configure the hub FortiGate's IPsec tunnel interface IP address.
config system interface
edit "advpn-hub1"
set ip 10.10.10.254 255.255.255.255
set remote-ip 10.10.10.253 255.255.255.0
next
end

d. Configure the hub FortiGate's OSPF.
config router ospf
set router-id 1.1.1.1
config area
edit 0.0.0.0
next
end
config network
edit 1
set prefix 10.10.10.0 255.255.255.0
next
edit 2
set prefix 172.16.101.0 255.255.255.0
next
end
end

3. Configure the spoke FortiGates.
a. Configure the spoke FortiGates' WAN, internal interfaces, and static routes.
i. Configure Spoke1.
config system interface
edit "wan1"
set alias "primary_WAN"
set ip 15.1.1.2 255.255.255.0
next
edit "wan2"
set alias "secondary_WAN"
set ip 12.1.1.2 255.255.255.0
next
edit "internal"
set ip 10.1.100.1 255.255.255.0
next
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end
config router static
edit 1
set gateway 12.1.1.1
set device "wan2"
set distance 15
next
edit 2
set gateway 15.1.1.1
set device "wan1"
next
end

ii. Configure the Spoke2.
config system interface
edit "wan1"
set alias "primary_WAN"
set ip 13.1.1.2 255.255.255.0
next
edit "wan2"
set alias "secondary_WAN"
set ip 17.1.1.2 255.255.255.0
next
edit "internal"
set ip 192.168.4.1 255.255.255.0
next
end
config router static
edit 1
set gateway 17.1.1.1
set device "wan2"
set distance 15
next
edit 2
set gateway 13.1.1.1
set device "wan1"
next
end

b. Configure the spoke FortiGates' IPsec phase1-interface and phase2-interface.
i. Configure Spoke1.
config vpn ipsec phase1-interface
edit "spoke1"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
set psksecret sample
set dpd-retryinterval 5
next
edit "spoke1_backup"
set interface "wan2"
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set
set
set
set
set
set
set
set
set
set

peertype any
net-device enable
proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
add-route disable
dpd on-idle
auto-discovery-receiver enable
remote-gw 22.1.1.1
monitor "spoke1"
psksecret sample
dpd-retryinterval 5

next
end
config vpn ipsec phase2-interface
edit "spoke1"
set phase1name "spoke1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
edit "spoke1_backup"
set phase1name "spoke1_backup"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

ii. Configure Spoke2.
config vpn ipsec phase1-interface
edit "spoke2"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
set psksecret sample
set dpd-retryinterval 5
next
edit "spoke2_backup"
set interface "wan2"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
set monitor "spoke2"
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
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edit "spoke2"
set phase1name "spoke2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
edit "spoke2_backup"
set phase1name "spoke2_backup"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

c. Configure the spoke FortiGates' firewall policies.
i. Configure Spoke1.
config firewall policy
edit 1
set name "outbound_advpn"
set srcintf "internal"
set dstintf "spoke1" "spoke1_backup"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "inbound_advpn"
set srcintf "spoke1" "spoke1_backup"
set dstintf "internal"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
end

ii. Configure Spoke2.
config firewall policy
edit 1
set name "outbound_advpn"
set srcintf "internal"
set dstintf "spoke2" "spoke2_backup"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "inbound_advpn"
set srcintf "spoke2" "spoke2_backup"
set dstintf "internal"
set srcaddr "all"
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set
set
set
set

dstaddr "all"
action accept
schedule "always"
service "ALL"

next
end

d. Configure the spoke FortiGates' tunnel interface IP addresses.
i. Configure Spoke1.
config system interface
edit "spoke1"
set ip 10.10.10.1 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
edit "spoke1_backup"
set ip 10.10.10.2 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
end

ii. Configure Spoke2.
config system interface
edit "spoke2"
set ip 10.10.10.3 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
edit "spoke2_backup"
set ip 10.10.10.4 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
end

e. Configure the spoke FortiGates' OSPF.
i. Configure Spoke1.
config router ospf
set router-id 7.7.7.7
config area
edit 0.0.0.0
next
end
config network
edit 1
set prefix 10.10.10.0 255.255.255.0
next
edit 2
set prefix 10.1.100.0 255.255.255.0
next
end
end

ii. Configure Spoke2.
config router ospf
set router-id 8.8.8.8
config area
edit 0.0.0.0
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next
end
config network
edit 1
set prefix 10.10.10.0 255.255.255.0
next
edit 2
set prefix 192.168.4.0 255.255.255.0
next
end
end

4. Run diagnose and get commands on Spoke1 to check VPN and OSPF states.
a. Run the diagnose vpn tunnel list command on Spoke1. The system should return the following:
list all ipsec tunnel in vd 0
---name=spoke1 ver=1 serial=2 15.1.1.2:0->22.1.1.1:0
bound_if=7 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=1
proxyid_num=1 child_num=1 refcnt=19 ilast=5 olast=2 ad=r/2
stat: rxp=1 txp=263 rxb=16452 txb=32854
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=2283
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1 proto=0 sa=1 ref=5 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=1438 expire=1057/0B replaywin=1024
seqno=108 esn=0 replaywin_lastseq=00000003 itn=0
life: type=01 bytes=0/0 timeout=2371/2400
dec: spi=c53a8f78 esp=aes key=16 7cc50c5c9df1751f6497a4ad764c5e9a
ah=sha1 key=20 269292ddbf7309a6fc05871e63ed8a5297b5c9a1
enc: spi=6e363612 esp=aes key=16 42bd49bced1e85cf74a24d97f10eb601
ah=sha1 key=20 13964f166aad48790c2e551d6df165d7489f524b
dec:pkts/bytes=1/16394, enc:pkts/bytes=263/50096
npu_flag=03 npu_rgwy=22.1.1.1 npu_lgwy=15.1.1.2 npu_selid=1 dec_npuid=1 enc_npuid=1
---name=spoke1_backup ver=1 serial=1 12.1.1.2:0->22.1.1.1:0
bound_if=6 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=11 ilast=8 olast=8 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=5000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1_backup proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0

b. Run the get router info ospf neighbor command on Spoke1. The system should return the following:
OSPF process 0, VRF 0: Neighbor ID Pri State Dead Time Address Interface 8.8.8.8 1.
Full/ - 00:00:35 10.10.10.254 spoke1 1.1.1.1 1. Full/ - 00:00:35 10.10.10.254 spoke1

c. Run the get router info routing-table ospf command on Spoke1. The system should return the
following:
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Routing table for VRF=0
O
172.16.101.0/24 [110/110] via 10.10.10.254, spoke1, 00:23:23
O
192.168.4.0/24
[110/110] via 10.10.10.254, spoke1, 00:22:35

d. Generate traffic between the spokes, then check the shortcut tunnel and routing table. Run the diagnose
vpn tunnel list command on Spoke1. The system should return the following:
list all ipsec tunnel in vd 0
------name=spoke1 ver=1 serial=2 15.1.1.2:0->22.1.1.1:0
bound_if=7 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=1
proxyid_num=1 child_num=1 refcnt=19 ilast=2 olast=2 ad=r/2
stat: rxp=1 txp=313 rxb=16452 txb=35912
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=2303
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1 proto=0 sa=1 ref=3 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=1438 expire=782/0B replaywin=1024
seqno=13a esn=0 replaywin_lastseq=00000003 itn=0
life: type=01 bytes=0/0 timeout=2371/2400
dec: spi=c53a8f78 esp=aes key=16 7cc50c5c9df1751f6497a4ad764c5e9a
ah=sha1 key=20 269292ddbf7309a6fc05871e63ed8a5297b5c9a1
enc: spi=6e363612 esp=aes key=16 42bd49bced1e85cf74a24d97f10eb601
ah=sha1 key=20 13964f166aad48790c2e551d6df165d7489f524b
dec:pkts/bytes=1/16394, enc:pkts/bytes=313/56432
npu_flag=03 npu_rgwy=22.1.1.1 npu_lgwy=15.1.1.2 npu_selid=1 dec_npuid=1 enc_npuid=1
---name=spoke1_backup ver=1 serial=1 12.1.1.2:0->22.1.1.1:0
bound_if=6 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=11 ilast=13 olast=13 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=5000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1_backup proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
---name=spoke1_0 ver=1 serial=e 15.1.1.2:4500->13.1.1.2:4500
bound_if=7 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/728 options[02d8]=npu
create_dev no-sysctl rgwy-chg frag-rfc accept_traffic=1
parent=spoke1 index=0
proxyid_num=1 child_num=0 refcnt=19 ilast=4 olast=2 ad=r/2
stat: rxp=641 txp=1254 rxb=278648 txb=161536
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=184
natt: mode=keepalive draft=32 interval=10 remote_port=4500
proxyid=spoke1_backup proto=0 sa=1 ref=10 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=1422 expire=922/0B replaywin=1024
seqno=452 esn=0 replaywin_lastseq=00000280 itn=0
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life: type=01 bytes=0/0 timeout=2370/2400
dec: spi=c53a8f79 esp=aes key=16 324f8cf840ba6722cc7abbba46b34e0e
ah=sha1 key=20 a40e9aac596b95c4cd83a7f6372916a5ef5aa505
enc: spi=ef3327b5 esp=aes key=16 5909d6066b303de4520d2b5ae2db1b61
ah=sha1 key=20 1a42f5625b5a335d8d5282fe83b5d6c6ff26b2a4
dec:pkts/bytes=641/278568, enc:pkts/bytes=1254/178586
npu_flag=03 npu_rgwy=13.1.1.2 npu_lgwy=15.1.1.2 npu_selid=a dec_npuid=1 enc_npuid=1

e. Run the get router info routing-tale ospf command. The system should return the following:
Routing table for VRF=0
O
172.16.101.0/24 [110/110] via 10.10.10.254, spoke1, 00:27:14
O
192.168.4.0/24 [110/110] via 10.10.10.3, spoke1_0, 00:26:26

ADVPN with RIP as the routing protocol
This is a sample configuration of ADVPN with RIP as routing protocol. The following options must be enabled for this
configuration:
l
l
l

On the hub FortiGate, IPsec phase1-interface net-device disable must be run.
RIP must be used between the hub and spoke FortiGates.
split-horizon-status enable must be run on the hub FortiGate.

Because the GUI can only complete part of the configuration, we recommend using the CLI.

To configure ADVPN with RIP as the routing protocol using the CLI:
1. In the CLI, configure hub FortiGate's WAN, internal interface, and static route.
config system interface
edit "port9"
set alias "WAN"
set ip 22.1.1.1 255.255.255.0
next
edit "port10"
set alias "Internal"
set ip 172.16.101.1 255.255.255.0
next
end
config router static
edit 1
set gateway 22.1.1.2
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set device "port9"
next
end

2. Configure the hub FortiGate.
a. Configure the hub FortiGate IPsec phase1-interface and phase2-interface.
config vpn ipsec phase1-interface
edit "advpn-hub"
set type dynamic
set interface "port9"
set peertype any
set net-device disable
set proposal aes128-sha256 aes256-sha256 3des-sha256 aes128-sha1 aes256-sha1
3des-sha1
set add-route disable
set dpd on-idle
set auto-discovery-sender enable
set tunnel-search nexthop
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "advpn-hub"
set phase1name "advpn-hub"
set proposal aes128-sha1 aes256-sha1 3des-sha1 aes128-sha256 aes256-sha256
3des-sha256
next
end

b. Configure the hub FortiGate firewall policy.
config firewall policy
edit 1
set name "spoke2hub"
set srcintf "advpn-hub"
set dstintf "port10"
set srcaddr "all"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "spoke2spoke"
set srcintf "advpn-hub"
set dstintf "advpn-hub"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
end
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c. Configure the hub FortiGate's IPsec tunnel interface IP address.
config system interface
edit "advpn-hub1"
set ip 10.10.10.254 255.255.255.255
set remote-ip 10.10.10.253 255.255.255.0
next
end

d. Configure the hub FortiGate's RIP.
config router rip
set default-information-originate enable
config network
edit 1
set prefix 10.10.10.0 255.255.255.0
next
edit 2
set prefix 172.16.101.0 255.255.255.0
next
end
config interface
edit "advpn-hub"
set split-horizon-status disable
next
end
end

3. Configure the spoke FortiGates.
a. Configure the spoke FortiGates' WAN, internal interfaces, and static routes.
i. Configure Spoke1.
config system interface
edit "wan1"
set alias "primary_WAN"
set ip 15.1.1.2 255.255.255.0
next
edit "wan2"
set alias "secondary_WAN"
set ip 12.1.1.2 255.255.255.0
next
edit "internal"
set ip 10.1.100.1 255.255.255.0
next
end
config router static
edit 1
set gateway 12.1.1.1
set device "wan2"
set distance 15
next
edit 2
set gateway 15.1.1.1
set device "wan1"
next
end
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ii. Configure the Spoke2.
config system interface
edit "wan1"
set alias "primary_WAN"
set ip 13.1.1.2 255.255.255.0
next
edit "wan2"
set alias "secondary_WAN"
set ip 17.1.1.2 255.255.255.0
next
edit "internal"
set ip 192.168.4.1 255.255.255.0
next
end
config router static
edit 1
set gateway 17.1.1.1
set device "wan2"
set distance 15
next
edit 2
set gateway 13.1.1.1
set device "wan1"
next
end

b. Configure the spoke FortiGates' IPsec phase1-interface and phase2-interface.
i. Configure Spoke1.
config vpn ipsec phase1-interface
edit "spoke1"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
set psksecret sample
set dpd-retryinterval 5
next
edit "spoke1_backup"
set interface "wan2"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
set monitor "spoke1"
set psksecret sample
set dpd-retryinterval 5
next
end
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config vpn ipsec phase2-interface
edit "spoke1"
set phase1name "spoke1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
edit "spoke1_backup"
set phase1name "spoke1_backup"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

ii. Configure Spoke2.
config vpn ipsec phase1-interface
edit "spoke2"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
set psksecret sample
set dpd-retryinterval 5
next
edit "spoke2_backup"
set interface "wan2"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set add-route disable
set dpd on-idle
set auto-discovery-receiver enable
set remote-gw 22.1.1.1
set monitor "spoke2"
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "spoke2"
set phase1name "spoke2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
next
edit "spoke2_backup"
set phase1name "spoke2_backup"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256
aes128gcm aes256gcm chacha20poly1305
set auto-negotiate enable
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next
end

c. Configure the spoke FortiGates' firewall policies.
i. Configure Spoke1.
config firewall policy
edit 1
set name "outbound_advpn"
set srcintf "internal"
set dstintf "spoke1" "spoke1_backup"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "inbound_advpn"
set srcintf "spoke1" "spoke1_backup"
set dstintf "internal"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
end

ii. Configure Spoke2.
config firewall policy
edit 1
set name "outbound_advpn"
set srcintf "internal"
set dstintf "spoke2" "spoke2_backup"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "inbound_advpn"
set srcintf "spoke2" "spoke2_backup"
set dstintf "internal"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
end
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d. Configure the spoke FortiGates' tunnel interface IP addresses.
i. Configure Spoke1.
config system interface
edit "spoke1"
set ip 10.10.10.1 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
edit "spoke1_backup"
set ip 10.10.10.2 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
end

ii. Configure Spoke2.
config system interface
edit "spoke2"
set ip 10.10.10.3 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
edit "spoke2_backup"
set ip 10.10.10.4 255.255.255.255
set remote-ip 10.10.10.254 255.255.255.0
next
end

e. Configure the spoke FortiGates' RIP.
i. Configure Spoke1.
config router rip
config network
edit 1
set prefix 10.10.10.0 255.255.255.0
next
edit 2
set prefix 10.1.100.0 255.255.255.0
next
end
end

ii. Configure Spoke2.
config router rip
config network
edit 1
set prefix 10.10.10.0 255.255.255.0
next
edit 2
set prefix 192.168.4.0 255.255.255.0
next
end
end

4. Run diagnose and get commands on Spoke1.
a. Run the diagnose vpn tunnel list command on Spoke1. The system should return the following:
list all ipsec tunnel in vd 0
----
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name=spoke1 ver=1 serial=2 15.1.1.2:0->22.1.1.1:0
bound_if=7 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=1
proxyid_num=1 child_num=1 refcnt=17 ilast=2 olast=2 ad=r/2
stat: rxp=1 txp=87 rxb=200 txb=6208
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=1040
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1 proto=0 sa=1 ref=4 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=7 options=1a227 type=00 soft=0 mtu=1438 expire=1793/0B replaywin=1024
seqno=57 esn=0 replaywin_lastseq=00000002 itn=0
life: type=01 bytes=0/0 timeout=2370/2400
dec: spi=c53a8f60 esp=aes key=16 6b54e32d54d039196a74d96e96d1cf14
ah=sha1 key=20 e4903474614eafc96eda6400a3a5e88bbcb26a7f
enc: spi=6e36349d esp=aes key=16 914a40a7993eda75c4dea2f42905f27d
ah=sha1 key=20 8040eb08342edea2dae5eee058fd054a46688267
dec:pkts/bytes=1/132, enc:pkts/bytes=86/11696
npu_flag=03 npu_rgwy=22.1.1.1 npu_lgwy=15.1.1.2 npu_selid=1 dec_npuid=1 enc_npuid=1
---name=spoke1_backup ver=1 serial=1 12.1.1.2:0->22.1.1.1:0
bound_if=6 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=11 ilast=0 olast=0 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=5000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1_backup proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0

b. Run the get router info rip database command on Spoke1. The system should return the following:
Codes: R - RIP, Rc - RIP connected, Rs - RIP static, K - Kernel,
C - Connected, S - Static, O - OSPF, I - IS-IS, B - BGP

Rc
Rc
R
R

Network
10.1.100.0/24
10.10.10.2/32
172.16.101.0/24
192.168.4.0/24

Next Hop

10.10.10.254
10.10.10.254

Metric From
If
Time
1.
internal
1.
spoke1
1. 10.10.10.254
spoke1 02:28
1. 10.10.10.254
spoke1 02:44

c. Run the get router info routing-table rip command on Spoke1. The system should return the
following:
Routing table for VRF=0
R
172.16.101.0/24 [120/2] via 10.10.10.254, spoke1, 00:08:38
R
192.168.4.0/24 [120/3] via 10.10.10.254, spoke1, 00:08:38

d. Generate traffic between the spokes, then check the shortcut tunnel and routing table. Run the diagnose
vpn tunnel list command on Spoke1. The system should return the following:
list all ipsec tunnel in vd 0
---name=spoke1 ver=1 serial=2 15.1.1.2:0->22.1.1.1:0
bound_if=7 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
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create_dev frag-rfc

accept_traffic=1

proxyid_num=1 child_num=0 refcnt=19 ilast=3 olast=3 ad=r/2
stat: rxp=1 txp=78 rxb=200 txb=5546
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=1039
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1 proto=0 sa=1 ref=5 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=7 options=1a227 type=00 soft=0 mtu=1438 expire=1807/0B replaywin=1024
seqno=4e esn=0 replaywin_lastseq=00000002 itn=0
life: type=01 bytes=0/0 timeout=2370/2400
dec: spi=c53a8f60 esp=aes key=16 6b54e32d54d039196a74d96e96d1cf14
ah=sha1 key=20 e4903474614eafc96eda6400a3a5e88bbcb26a7f
enc: spi=6e36349d esp=aes key=16 914a40a7993eda75c4dea2f42905f27d
ah=sha1 key=20 8040eb08342edea2dae5eee058fd054a46688267
dec:pkts/bytes=1/132, enc:pkts/bytes=77/10456
npu_flag=03 npu_rgwy=22.1.1.1 npu_lgwy=15.1.1.2 npu_selid=1 dec_npuid=1 enc_npuid=1
---name=spoke1_backup ver=1 serial=1 12.1.1.2:0->22.1.1.1:0
bound_if=6 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu
create_dev frag-rfc accept_traffic=0
proxyid_num=1 child_num=0 refcnt=11 ilast=20 olast=20 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=5000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=spoke1_backup proto=0 sa=0 ref=2 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
---name=spoke1_0 ver=1 serial=a 15.1.1.2:4500->13.1.1.2:4500
bound_if=7 lgwy=static/1 tun=intf/0 mode=dial_inst/3 encap=none/728 options[02d8]=npu
create_dev no-sysctl rgwy-chg frag-rfc accept_traffic=1
parent=spoke1 index=0
proxyid_num=1 child_num=0 refcnt=20 ilast=2 olast=0 ad=r/2
stat: rxp=1 txp=7 rxb=112 txb=480
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=0
natt: mode=keepalive draft=32 interval=10 remote_port=4500
proxyid=spoke1 proto=0 sa=1 ref=8 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=1422 expire=2358/0B replaywin=1024
seqno=8 esn=0 replaywin_lastseq=00000002 itn=0
life: type=01 bytes=0/0 timeout=2367/2400
dec: spi=c53a8f61 esp=aes key=16 c66aa7ae9657068108ed47c048ff56b6
ah=sha1 key=20 60661c68e20bbc913c2564ade85e01ea3769e703
enc: spi=79cb0f30 esp=aes key=16 bf6c898c2e1c64baaa679ed5d79c3b58
ah=sha1 key=20 146ca78be6c34eedb9cd66cc328216e08682ecb1
dec:pkts/bytes=1/46, enc:pkts/bytes=7/992
npu_flag=03 npu_rgwy=13.1.1.2 npu_lgwy=15.1.1.2 npu_selid=6 dec_npuid=1 enc_npuid=1

e. Run the get router info routing-tale rip command. The system should return the following:
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Routing table for VRF=0
R
172.16.101.0/24 [120/2] via 10.10.10.254, spoke1, 00:09:04
R
192.168.4.0/24 [120/2] via 10.10.10.3, spoke1_0, 00:00:02

IPsec VPN wizard hub-and-spoke ADVPN support
The IPsec Wizard can be used to create hub-and-spoke VPNs, with ADVPN enabled to establish tunnels between
spokes.
The following example shows the steps in the wizard for configuring a hub and a spoke.

To configure the hub:
1. On the hub FortiGate, go to VPN > IPsec Wizard.

2. Enter a name, set the Template Type to Hub-and-Spoke, and set the Role to Hub.
3. Click Next.

4. Select the Incoming Interface and configure the Authentication method.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1041

VPN
5. Click Next.

6. Set the IP address and Remote IP/netmask.
7. Click Next.

8. Configure the Local identifier, Local interface, and Local subnets, then configure the tunnel IP addresses and
identifiers for the spokes.
9. Click Create.

10. Review the summary to ensure that everything looks as expected.
11. Copy the spokes' easy configuration keys to a temporary location for use when configuring the spokes.
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To configure a spoke:
1. On the spoke FortiGate, go to VPN > IPsec Wizard.

2. Enter a name, set the Template Type to Hub-and-Spoke, set the Role to Spoke, and paste in the requisite Easy
configuration key that you saved when configuring the hub.
3. Click Next.

4. Set the Remote IP address, select the Incoming Interface, and configure the Authentication method.
5. Click Next.

6. Set the IP address and Remote IP/netmask.
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7. Click Next.

8. Configure the Local identifier, Local interface, and Local subnets, then configure the IP address and identifier of the
hub FortiGate.
9. Click Create.

10. Review the summary to ensure that everything looks as expected.

To check the ADVPN shortcut with the IPsec monitor:
1. On either the hub or spoke FortiGate, go to Monitor > IPsec Monitor.

Authentication in VPN
To protect data via encryption, a VPN must ensure that only authorized users can access the private network. You must
use either a preshared key on both VPN gateways or RSA X.509 security certificates.
The following topics provide instructions on configuring authentication in VPN:
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l
l

IPsec VPN authenticating a remote FortiGate peer with a pre-shared key on page 1045
IPsec VPN authenticating a remote FortiGate peer with a certificate on page 1050

IPsec VPN authenticating a remote FortiGate peer with a pre-shared key
This is a sample configuration of IPsec VPN authenticating a remote FortiGate peer with a pre-shared key.

To configure IPsec VPN authenticating a remote FortiGate peer with a pre-shared key in the GUI:
1. Configure the HQ1 FortiGate.
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, select No NAT Between Sites.
v. Click Next.
b. Configure the following settings for Authentication:
i. For Remote Device, select IP Address.
ii. For the IP address, enter 172.16.202.1.
iii. For Outgoing interface, enter port1.
iv. For Authentication Method, select Pre-shared Key.
v. In the Pre-shared Key field, enter sample as the key.
vi. Click Next.
c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select the local interface.
ii. Configure the Local Subnets as 10.1.100.0.
iii. Configure the Remote Subnets as 172.16.101.0.
iv. Click Create.
2. Configure the HQ2 FortiGate.
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, select No NAT Between Sites.
v. Click Next.
b. Configure the following settings for Authentication:
i. For Remote Device, select IP Address.
ii. For the IP address, enter 172.16.2001.
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iii. For Outgoing interface, enter port25.
iv. For Authentication Method, select Pre-shared Key.
v. In the Pre-shared Key field, enter sample as the key.
vi. Click Next.
c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select the local interface.
ii. Configure Local Subnets as 172.16.101.0.
iii. Configure the Remote Subnets as 10.1.100.0.
iv. Click Create.

To configure IPsec VPN authenticating a remote FortiGate peer with a pre-shared key using the CLI:
1. Configure the WAN interface and default route. The WAN interface is the interface connected to the ISP. The IPsec
tunnel is established over the WAN interface.
a. Configure HQ1.
config system interface
edit "port1"
set vdom "root"
set ip 172.16.200.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.200.3
set device "port1"
next
end

b. Configure HQ2.
config system interface
edit "port25"
set vdom "root"
set ip 172.16.202.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.202.2
set device "port25"
next
end

2. Configure the internal (protected subnet) interface. The internal interface connects to the corporate internal
network. Traffic from this interface routes out the IPsec VPN tunnel.
a. Configure HQ1.
config system interface
edit "dmz"
set vdom "root"
set ip 10.1.100.1 255.255.255.0
next
end
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b. Configure HQ2.
config system interface
edit "port9"
set vdom "root"
set ip 172.16.101.1 255.255.255.0
next
end

3. Configure the IPsec phase1-interface.
a. Configure HQ1.
config vpn ipsec phase1-interface
edit "to_HQ2"
set interface "port1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set psksecret sample
next
end

b. Configure HQ2.
config vpn ipsec phase1-interface
edit "to_HQ1"
set interface "port25"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.200.1
set psksecret sample
next
end

4. Configure the IPsec phase2-interface.
a. Configure HQ1.
config vpn ipsec phase2-interface
edit "to_HQ2"
set phase1name "to_HQ2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

b. Configure HQ2.
config vpn ipsec phase2-interface
edit "to_HQ2"
set phase1name "to_HQ1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end
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5. Configure the static routes. Two static routes are added to reach the remote protected subnet. The blackhole route
is important to ensure that IPsec traffic does not match the default route when the IPsec tunnel is down.
a. Configure HQ1.
config router static
edit 2
set dst 172.16.101.0 255.255.255.0
set device "to_HQ2"
next
edit 3
set dst 172.16.101.0 255.255.255.0
set blackhole enable
set distance 254
next
end

b. Configure HQ2.
config router static
edit 2
set dst 10.1.100.0 255.255.255.0
set device "to_HQ1"
next
edit 3
set dst 10.1.100.0 255.255.255.0
set blackhole enable
set distance 254
next
end

6. Configure two firewall policies to allow bidirectional IPsec traffic flow over the IPsec VPN tunnel.
a. Configure HQ1.
config firewall policy
edit 1
set name "inbound"
set srcintf "to_HQ2"
set dstintf "dmz"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "outbound"
set srcintf "dmz"
set dstintf "to_HQ2"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
end
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b. Configure HQ2.
config firewall policy
edit 1
set name "inbound"
set srcintf "to_HQ1"
set dstintf "port9"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "outbound"
set srcintf "port9"
set dstintf "to_HQ1"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
end

7. Run diagnose commands. The diagnose debug application ike -1 command is the key to troubleshoot
why the IPsec tunnel failed to establish. If the PSK failed to match, the following error shows up in the debug output:
ike 0:to_HQ2:15037: parse error
ike 0:to_HQ2:15037: probable pre-shared secret mismatch'

The following commands are useful to check IPsec phase1/phase2 interface status.
a. Run the diagnose vpn ike gateway list command on HQ1. The system should return the following:
vd: root/0
name: to_HQ2
version: 1
interface: port1 11
addr: 172.16.200.1:500 -> 172.16.202.1:500
created: 5s ago
IKE SA: created 1/1 established 1/1 time 0/0/0 ms
IPsec SA: created 2/2 established 2/2 time 0/0/0 ms
id/spi: 12 6e8d0532e7fe8d84/3694ac323138a024
direction: responder
status: established 5-5s ago = 0ms
proposal: aes128-sha256
key: b3efb46d0d385aff-7bb9ee241362ee8d
lifetime/rekey: 86400/86124
DPD sent/recv: 00000000/00000000

b. Run the diagnose vpn tunnel list command on HQ1. The system should return the following:
list all ipsec tunnel in vd 0
name=to_HQ2 ver=1 serial=1 172.16.200.1:0->172.16.202.1:0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_
dev frag-rfcaccept_traffic=1
proxyid_num=1 child_num=0 refcnt=11 ilast=7 olast=87 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
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dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=to_HQ2 proto=0 sa=1 ref=2 serial=1 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=18227 type=00 soft=0 mtu=1438 expire=42927/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0
life: type=01 bytes=0/0 timeout=42930/43200
dec: spi=ef9ca700 esp=aes key=16 a2c6584bf654d4f956497b3436f1cfc7
ah=sha1 key=20 82c5e734bce81e6f18418328e2a11aeb7baa021b
enc: spi=791e898e esp=aes key=16 0dbb4588ba2665c6962491e85a4a8d5a
ah=sha1 key=20 2054b318d2568a8b12119120f20ecac97ab730b3
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0

IPsec VPN authenticating a remote FortiGate peer with a certificate
This is a sample configuration of IPsec VPN authenticating a remote FortiGate peer with a certificate. The certificate on
one peer is validated by the presence of the CA certificate installed on the other peer.

To configure IPsec VPN authenticating a remote FortiGate peer with a digital certificate in the GUI:
1. Import the certificate.
2. Configure user peers.
3. Configure the HQ1 FortiGate.
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, select No NAT Between Sites.
v. Click Next.
b. Configure the following settings for Authentication:
i. For Remote Device, select IP Address.
ii. For the IP address, enter 172.16.202.1.
iii. For Outgoing interface, enter port1.
iv. For Authentication Method, select Signature.
v. In the Certificate name field, select the imported certificate.
vi. From the Peer Certificate CA dropdown list, select the desired peer CA certificate.
vii. Click Next.
c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select the local interface.
ii. Configure the Local Subnets as 10.1.100.0.
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iii. Configure the Remote Subnets as 172.16.101.0.
iv. Click Create.
4. Configure the HQ2 FortiGate.
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, select No NAT Between Sites.
v. Click Next.
b. Configure the following settings for Authentication:
i. For Remote Device, select IP Address.
ii. For the IP address, enter 172.16.2001.
iii. For Outgoing interface, enter port25.
iv. For Authentication Method, select Signature.
v. In the Certificate name field, select the imported certificate.
vi. From the Peer Certificate CA dropdown list, select the peer CA certificate.
vii. Click Next.
c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select the local interface.
ii. Configure Local Subnets as 172.16.101.0.
iii. Configure the Remote Subnets as 10.1.100.0.
iv. Click Create.

To configure IPsec VPN authenticating a remote FortiGate peer with a digital certificate using the CLI:
1. Configure the WAN interface and default route. The WAN interface is the interface connected to the ISP. The IPsec
tunnel is established over the WAN interface.
a. Configure HQ1.
config system interface
edit "port1"
set vdom "root"
set ip 172.16.200.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.200.3
set device "port1"
next
end

b. Configure HQ2.
config system interface
edit "port25"
set vdom "root"
set ip 172.16.202.1 255.255.255.0
next
end
config router static
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edit 1
set gateway 172.16.202.2
set device "port25"
next
end

2. Configure the internal (protected subnet) interface. The internal interface connects to the corporate internal
network. Traffic from this interface routes out the IPsec VPN tunnel.
a. Configure HQ1.
config system interface
edit "dmz"
set vdom "root"
set ip 10.1.100.1 255.255.255.0
next
end

b. Configure HQ2.
config system interface
edit "port9"
set vdom "root"
set ip 172.16.101.1 255.255.255.0
next
end

3. Configure the import certificate and its CA certificate information. The certificate and its CA certificate must be
imported on the remote peer FortiGate and on the primary FortiGate before configuring IPsec VPN tunnels. If the
built-in Fortinet_Factory certificate and the Fortinet_CA CA certificate are used for authentication, you can skip this
step.
a. Configure HQ1.
config vpn certificate local
edit "test1"
...
set range global
next
end
config vpn certificate ca
edit "CA_Cert_1"
...
set range global
next
end

b. Configure HQ2.
config vpn certificate local
edit "test2"
...
set range global
next
end
config vpn certificate ca
edit "CA_Cert_1"
...
set range global
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next
end

4. Configure the peer user. The peer user is used in the IPsec VPN tunnel peer setting to authenticate the remote peer
FortiGate.
a. If not using the built-in Fortinet_Factory certificate and Fortinet_CA CA certificate, do the following:
i. Configure HQ1.
config user peer
edit "peer1"
set ca "CA_Cert_1"
next
end

ii. Configure HQ2.
config user peer
edit "peer2"
set ca "CA_Cert_1"
next
end

b. If the built-in Fortinet_Factory certificate and Fortinet_CA CA certificate are used for authentication, the peer
user must be configured based on Fortinet_CA.
i. Configure HQ1.
config user peer
edit "peer1"
set ca "Fortinet_CA"
next
end

ii. Configure HQ2.
config user peer
edit "peer2"
set ca "Fortinet_CA"
next
end

5. Configure the IPsec phase1-interface.
a. Configure HQ1.
config vpn ipsec phase1-interface
edit "to_HQ2"
set interface "port1"
set authmethod signature
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set remote-gw 172.16.202.1
set certificate "test1"
set peer "peer1"
next
end

b. Configure HQ2.
config vpn ipsec phase1-interface
edit "to_HQ1"
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set
set
set
set
set
set
set

interface "port25"
authmethod signature
net-device enable
proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
remote-gw 172.16.200.1
certificate "test2"
peer "peer2"

next
end

6. Configure the IPsec phase2-interface.
a. Configure HQ1.
config vpn ipsec phase2-interface
edit "to_HQ2"
set phase1name "to_HQ2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

b. Configure HQ2.
config vpn ipsec phase2-interface
edit "to_HQ2"
set phase1name "to_HQ1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
next
end

7. Configure the static routes. Two static routes are added to reach the remote protected subnet. The blackhole route
is important to ensure that IPsec traffic does not match the default route when the IPsec tunnel is down.
a. Configure HQ1.
config router static
edit 2
set dst 172.16.101.0 255.255.255.0
set device "to_HQ2"
next
edit 3
set dst 172.16.101.0 255.255.255.0
set blackhole enable
set distance 254
next
end

b. Configure HQ2.
config router static
edit 2
set dst 10.1.100.0 255.255.255.0
set device "to_HQ1"
next
edit 3
set dst 10.1.100.0 255.255.255.0
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set blackhole enable
set distance 254
next
end

8. Configure two firewall policies to allow bidirectional IPsec traffic flow over the IPsec VPN tunnel.
a. Configure HQ1.
config firewall policy
edit 1
set name "inbound"
set srcintf "to_HQ2"
set dstintf "dmz"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "outbound"
set srcintf "dmz"
set dstintf "to_HQ2"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
end

b. Configure HQ2.
config firewall policy
edit 1
set name "inbound"
set srcintf "to_HQ1"
set dstintf "port9"
set srcaddr "10.1.100.0"
set dstaddr "172.16.101.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "outbound"
set srcintf "port9"
set dstintf "to_HQ1"
set srcaddr "172.16.101.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
end

9. Run diagnose commands. The diagnose debug application ike -1 command is the key to troubleshoot
why the IPsec tunnel failed to establish. If the remote FortiGate certificate cannot be validated, the following error
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ike 0: to_HQ2:15314: certificate validation failed

The following commands are useful to check IPsec phase1/phase2 interface status.
a. Run the diagnose vpn ike gateway list command on HQ1. The system should return the following:
vd: root/0
name: to_HQ2
version: 1
interface: port1 11
addr: 172.16.200.1:500 -> 172.16.202.1:500
created: 7s ago
peer-id: C = CA, ST = BC, L = Burnaby, O = Fortinet, OU = QA, CN = test2
peer-id-auth: yes
IKE SA: created 1/1 established 1/1 time 70/70/70 ms
IPsec SA: created 1/1 established 1/1 time 80/80/80 ms
id/spi: 15326 295be407fbddfc13/7a5a52afa56adf14 direction: initiator status:
established 7-7s ago = 70ms proposal: aes128-sha256 key: 4aa06dbee359a4c743570710864bcf7b lifetime/rekey: 86400/86092 DPD sent/recv: 00000000/00000000 peerid: C = CA, ST = BC, L = Burnaby, O = Fortinet, OU = QA, CN = test2

b. Run the diagnose vpn tunnel list command on HQ1. The system should return the following:
list all ipsec tunnel in vd 0
name=to_HQ2 ver=1 serial=1 172.16.200.1:0->172.16.202.1:0
bound_if=11 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/528 options[0210]=create_
dev frag-rfcaccept_traffic=1
proxyid_num=1 child_num=0 refcnt=14 ilast=19 olast=179 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=vpn-f proto=0 sa=1 ref=2 serial=1 auto-negotiate
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=18227 type=00 soft=0 mtu=1438 expire=42717/0B replaywin=2048
seqno=1 esn=0 replaywin_lastseq=00000000 itn=0
life: type=01 bytes=0/0 timeout=42897/43200
dec: spi=72e87de7 esp=aes key=16 8b2b93e0c149d6f22b1c0b96ea450e6c
ah=sha1 key=20 facc655e5f33beb7c2b12e718a6d55413ce3efa2
enc: spi=5c52c865 esp=aes key=16 8d0c4e4adbf2338beed569b2b3205ece
ah=sha1 key=20 553331628612480ab6d7d563a00e2a967ebabcdd
dec:pkts/bytes=0/0, enc:pkts/bytes=0/0

VXLAN over IPsec tunnel
This is an example of VXLAN over IPsec tunnel. VXLAN encapsulation is used in the phase1-interface setting and
virtual-switch is used to bridge the internal with VXLAN over IPsec tunnel.
For more information, see IPsec Tunnels on page 926.
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Sample topology

Sample configuration
To configure VXLAN over an IPsec tunnel:
1. Configure the WAN interface and default route:
a. HQ1:
config system interface
edit "port1"
set ip 172.16.200.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.200.3
set device "port1"
next
end

b. HQ2:
config system interface
edit "port25"
set ip 172.16.202.1 255.255.255.0
next
end
config router static
edit 1
set gateway 172.16.202.2
set device "port25"
next
end

2. Configure IPsec phase1-interface:
a. HQ1:
config vpn ipsec phase1-interface
edit "to_HQ2"
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set interface "port1"
set peertype any
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set encapsulation VXLAN
set encapsulation-address ipv4
set encap-local-gw4 172.16.200.1
set encap-remote-gw4 172.16.202.1
set remote-gw 172.16.202.1
set psksecret sample
next
end
config vpn ipsec phase2-interface
edit "to_HQ2"
set phase1name "to_HQ2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end

b. HQ2:
config vpn ipsec phase1-interface
edit "to_HQ1"
set interface "port25"
set peertype any
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set encapsulation VXLAN
set encapsulation-address ipv4
set encap-local-gw4 172.16.202.1
set encap-remote-gw4 172.16.200.1
set remote-gw 172.16.200.1
set psksecret sample
next
end
config vpn ipsec phase2-interface
edit "to_HQ1"
set phase1name "to_HQ1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end

3. Configure the firewall policy:
a. HQ1:
config firewall policy
edit 1
set srcintf "dmz"
set dstintf "to_HQ2"
set srcaddr "10.1.100.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set srcintf "to_HQ2"
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set
set
set
set
set
set

dstintf "dmz"
srcaddr "10.1.100.0"
dstaddr "10.1.100.0"
action accept
schedule "always"
service "ALL"

next
end

b. HQ2:
config firewall policy
edit 1
set srcintf "port9"
set dstintf "to_HQ1"
set srcaddr "10.1.100.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set srcintf "to_HQ1"
set dstintf "port9"
set srcaddr "10.1.100.0"
set dstaddr "10.1.100.0"
set action accept
set schedule "always"
set service "ALL"
next
end

4. Configure the virtual switch:
a. HQ1:
config system switch-interface
edit "VXLAN-HQ2"
set member "dmz" "to_HQ2"
set intra-switch-policy explicit
next
end

b. HQ2:
config system switch-interface
edit "VXLAN-HQ1"
set member "port9" "to_HQ1"
set intra-switch-policy explicit
next
end

5. Optionally, view the VPN tunnel list on HQ1 with the diagnose vpn tunnel list command:
list all ipsec tunnel in vd 0
---name=to_HQ2 ver=1 serial=2 172.16.200.1:0->172.16.202.1:0
bound_if=5 lgwy=static/1 tun=intf/0 mode=auto/1 encap=VXLAN/2 options[0002]=
encap-addr: 172.16.200.1->172.16.202.1
proxyid_num=1 child_num=0 refcnt=11 ilast=8 olast=0 ad=/0
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stat: rxp=13 txp=3693 rxb=5512 txb=224900
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=45
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=to_HQ2 proto=0 sa=1 ref=2 serial=1
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=10226 type=00 soft=0 mtu=1390 expire=41944/0B replaywin=2048
seqno=e6e esn=0 replaywin_lastseq=0000000e itn=0
life: type=01 bytes=0/0 timeout=42901/43200
dec: spi=635e9bb1 esp=aes key=16 c8a374905ef9156e66504195f46a650c
ah=sha1 key=20 a09265de7d3b0620b45441fb5af44dab125f2afe
enc: spi=a4d0cd1e esp=aes key=16 e9d0f3f0bb7e15a833f80c42615a3b91
ah=sha1 key=20 609a315c385471b8909b771c76e4fa7214996e50
dec:pkts/bytes=13/4640, enc:pkts/bytes=3693/623240

6. Optionally, view the bridge control interface on HQ1 with the diagnose netlink brctl name host VXLANHQ1 command:
show bridge control interface VXLAN-HQ1 host.
fdb: size=2048, used=17, num=17, depth=1
Bridge VXLAN-a host table
port no device devname mac addr
1
1.
dmz
00:0c:29:4e:33:c9
1
1.
dmz
00:0c:29:a8:c3:ea
1
1.
dmz
90:6c:ac:53:76:29
1
1.
dmz
08:5b:0e:dd:69:cb
1
1.
dmz
90:6c:ac:84:3e:5d
1
1.
dmz
00:0b:fd:eb:21:d6
2
38
to_HQ2 56:45:c3:3f:57:b4
1
1.
dmz
00:0c:29:d2:66:40
2
38
to_HQ2 90:6c:ac:5b:a6:eb
1
1.
dmz
00:0c:29:a6:bc:e6
1
1.
dmz
00:0c:29:f0:a2:e7
1
1.
dmz
00:0c:29:d6:c4:66
1
1.
dmz
00:0c:29:e7:68:19
1
1.
dmz
00:0c:29:bf:79:30
1
1.
dmz
00:0c:29:e0:64:7d
1
1.
dmz
36:ea:c7:30:c0:f1
1
1.
dmz
36:ea:c7:30:cc:71

ttl
1.
105
18
1.
1.
1.
1.
78
124
19
1.
164
1.
19
1.
25
1.

attributes
Hit(1)
Hit(105)
Hit(18)
Local Static
Hit(5)
Hit(0)
Local Static
Hit(78)
Hit(124)
Hit(19)
Hit(0)
Hit(164)
Hit(0)
Hit(19)
Hit(0)
Hit(25)
Hit(0)

Other VPN topics
The following topics provide instructions on configuring other VPN topics.
l
l
l
l
l
l
l
l

Tunneled Internet browsing on page 1061
VPN and ASIC offload on page 1066
GRE over IPsec on page 935
L2TP over IPsec on page 940
Encryption algorithms on page 1076
Policy-based IPsec tunnel on page 944
Fragmenting IP packets before IPsec encapsulation on page 1084
VPN IPsec troubleshooting on page 1084
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Tunneled Internet browsing
This is a sample configuration of tunneled internet browsing using a dialup VPN. To centralize network management and
control, all branch office traffic is tunneled to HQ, including Internet browsing.

To configure a dialup VPN to tunnel Internet browsing using the GUI:
1. Configure the dialup VPN server FortiGate at HQ:
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name, in this example, HQ.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, select The remote site is behind NAT.
v. Click Next.
b. Configure the following settings for Authentication:
i. For Incoming Interface, select port9.
ii. For Authentication Method, select Pre-shared Key.
iii. In the Pre-shared Key field, enter sample as the key.
iv. Click Next.
c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select port10.
ii. Configure the Local Subnets as 172.16.101.0.
iii. Configure the Remote Subnets as 0.0.0.0/0.
iv. For Internet Access, select Share Local.
v. For Shared WAN, select port9.
vi. Click Create.
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2. Configure the dialup VPN client FortiGate at a branch:
a. Go to VPN > IPsec Wizard and configure the following settings for VPN Setup:
i. Enter a VPN name, in this example, Branch1 or Branch2.
ii. For Template Type, select Site to Site.
iii. For Remote Device Type, select FortiGate.
iv. For NAT Configuration, select The remote site is behind NAT.
v. Click Next.
b. Configure the following settings for Authentication:
i. For IP Address, select Remote Device and enter 22.1.1.1.
ii. For Outgoing Interface, select wan1.
iii. For Authentication Method, select Pre-shared Key.
iv. In the Pre-shared Key field, enter sample as the key.
v. Click Next.
c. Configure the following settings for Policy & Routing:
i. From the Local Interface dropdown menu, select internal.
ii. Configure the Local Subnets as 10.1.100.0/192.1684.0.
iii. Configure the Remote Subnets as 0.0.0.0/0.
iv. For Internet Access, select Use Remote.
v. Configure the Local Gateway to 15.1.1.1/13.1.1.1.
vi. Click Create.

To configure a dialup VPN to tunnel Internet browsing using the CLI:
1. Configure the WAN interface and static route on the FortiGate at HQ.
config system interface
edit "port9"
set alias "WAN"
set ip 22.1.1.1 255.255.255.0
next
edit "port10"
set alias "Internal"
set ip 172.16.101.1 255.255.255.0
next
end
config router static
edit 1
set gateway 22.1.1.2
set device "port9"
next
end

2. Configure IPsec phase1-interface and phase2-interface configuration at HQ.
config vpn ipsec phase1-interface
edit "HQ"
set type dynamic
set interface "port9"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set dpd on-idle
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set psksecret sample
set dpd-retryinterval 60
next
end
config vpn ipsec phase2-interface
edit "HQ"
set phase1name "HQ"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
next
end

3. Configure the firewall policy at HQ.
config firewall policy
edit 1
set srcintf "HQ"
set dstintf "port9" "port10"
set srcaddr "10.1.100.0" "192.168.4.0"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

4. Configure the WAN interface and static route on the FortiGate at the branches.
a. Branch1.
config system interface
edit "wan1"
set ip 15.1.1.2 255.255.255.0
next
edit "internal"
set ip 10.1.100.1 255.255.255.0
next
end
config router static
edit 1
set gateway 15.1.1.1
set device "wan1"
next
end

b. Branch2.
config system interface
edit "wan1"
set ip 13.1.1.2 255.255.255.0
next
edit "internal"
set ip 192.168.4.1 255.255.255.0
next
end
config router static
edit 1
set gateway 13.1.1.1

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1063

VPN

set device "wan1"
next
end

5. Configure IPsec phase1-interface and phase2-interface configuration at the branches.
a. Branch1.
config vpn ipsec phase1-interface
edit "branch1"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set dpd on-idle
set remote-gw 22.1.1.1
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "branch1"
set phase1name "branch1"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
set src-subnet 10.1.100.0 255.255.255.0
next
end

b. Branch2.
config vpn ipsec phase1-interface
edit "branch2"
set interface "wan1"
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set dpd on-idle
set remote-gw 22.1.1.1
set psksecret sample
set dpd-retryinterval 5
next
end
config vpn ipsec phase2-interface
edit "branch2"
set phase1name "branch2"
set proposal aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm
aes256gcm chacha20poly1305
set auto-negotiate enable
set src-subnet 192.168.4.0 255.255.255.0
next
end

6. Configure the firewall policy at the branches.
a. Branch1.
config firewall policy
edit 1
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set
set
set
set
set
set
set
set
next
edit 2
set
set
set
set
set
set
set
set
next

name "outbound"
srcintf "internal"
dstintf "branch1"
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"

name "inbound"
srcintf "branch1"
dstintf "internal"
srcaddr "all"
dstaddr "all"
action accept
schedule "always"
service "ALL"

end

b. Branch2.
config firewall policy
edit 1
set name "outbound"
set srcintf "internal"
set dstintf "branch2"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "inbound"
set srcintf "branch2"
set dstintf "internal"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
next
end

7. Configure the static routes at the branches.
a. Branch1.
config router static
edit 2
set dst 22.1.1.1/32
set gateway 15.1.1.1
set device "wan1"
set distance 1
next
edit 3
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set device "branch1"
set distance 5
next
end

b. Branch2.
config router static
edit 2
set dst 22.1.1.1/32
set gateway 13.1.1.1
set device "wan1"
set distance 1
next
edit 3
set device "branch2"
set distance 5
next
end

8. Optionally, view the VPN tunnel list on a branch with the diagnose vpn tunnel list command:
list all ipsec tunnel in vd 0
---name=branch1 ver=1 serial=2 15.1.1.2:0->22.1.1.1:0
bound_if=7 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu create_
dev frag-rfc accept_traffic=1
proxyid_num=1 child_num=1 refcnt=19 ilast=0 olast=0 ad=r/2
stat: rxp=1 txp=1661 rxb=65470 txb=167314
dpd: mode=on-idle on=1 idle=5000ms retry=3 count=0 seqno=2986
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=branch1 proto=0 sa=1 ref=5 serial=1 auto-negotiate adr
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=1a227 type=00 soft=0 mtu=1438 expire=697/0B replaywin=1024
seqno=13a esn=0 replaywin_lastseq=00000000 itn=0
life: type=01 bytes=0/0 timeout=2368/2400
dec: spi=c53a8f7e esp=aes key=16 ecee0cd48664d903d3d6822b1f902fd2
ah=sha1 key=20 2440a189126c222093ca9acd8b37127285f1f8a7
enc: spi=6e3636fe esp=aes key=16 fdaa20bcc96f74ae9885e824d3efa29d
ah=sha1 key=20 70c0891c769ad8007ea1f31a39978ffbc73242d0
dec:pkts/bytes=0/16348, enc:pkts/bytes=313/55962
npu_flag=03 npu_rgwy=22.1.1.1 npu_lgwy=15.1.1.2 npu_selid=1 dec_npuid=1 enc_npuid=1

9. Optionally, view static routing table on a branch with the get router info routing-table static
command:
Routing table for VRF=0
S*
0.0.0.0/0 [5/0] is directly connected, branch1
S*
22.1.1.1/32 [1/0] via 15.1.1.1, wan1

VPN and ASIC offload
This topic provides a brief introduction to VPN traffic offloading.
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IPsec traffic processed by NPU
1. Check the device ASIC information. For example, a FortiGate 900D has an NP6 and a CP8.
# get hardware status
Model name: [[QualityAssurance62/FortiGate]]-900D
ASIC version: CP8
ASIC SRAM: 64M
CPU: Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz
Number of CPUs: 4
RAM: 16065 MB
Compact Flash: 1925 MB /dev/sda
Hard disk: 244198 MB /dev/sdb
USB Flash: not available
Network Card chipset: [[QualityAssurance62/FortiASIC]] NP6 Adapter (rev.)

2. Check port to NPU mapping.
# diagnose npu np6 port-list
Chip
XAUI Ports
Max
Cross-chip
Speed offloading
---np6_0 0
1.
port17
1G
Yes
1.
port18
1G
Yes
1.
port19
1G
Yes
1.
port20
1G
Yes
1.
port21
1G
Yes
1.
port22
1G
Yes
1.
port23
1G
Yes
1.
port24
1G
Yes
1.
port27
1G
Yes
1.
port28
1G
Yes
1.
port25
1G
Yes
1.
port26
1G
Yes
1.
port31
1G
Yes
1.
port32
1G
Yes
1.
port29
1G
Yes
1.
port30
1G
Yes
1.
portB
10G
Yes
1.
---np6_1 0
1.
port1
1G
Yes
1.
port2
1G
Yes
1.
port3
1G
Yes
1.
port4
1G
Yes
1.
port5
1G
Yes
1.
port6
1G
Yes
1.
port7
1G
Yes
1.
port8
1G
Yes
1.
port11
1G
Yes
1.
port12
1G
Yes
1.
port9
1G
Yes
1.
port10
1G
Yes
1.
port15
1G
Yes
1.
port16
1G
Yes
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1.
1.
1.
1.

port13
port14
portA

1G
1G
10G

Yes
Yes
Yes

----

3. Configure the option in IPsec phase1 settings to control NPU encrypt/decrypt IPsec packets (enabled by default).
config vpn ipsec phase1/phase1-interface
edit "vpn_name"
set npu-offload enable/disable
next
end

4. Check NPU offloading. The NPU encrypted/decrypted counter should tick. The npu_flag 03 flag means that the
traffic processed by the NPU is bi-directional.
# diagnose vpn tunnel list
list all ipsec tunnel in vd 0
---name=test ver=2 serial=1 173.1.1.1:0->11.101.1.1:0
bound_if=42 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/8 options[0008]=npu
proxyid_num=1 child_num=0 refcnt=14 ilast=2 olast=2 ad=/0
stat: rxp=12231 txp=12617 rxb=1316052 txb=674314
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=test proto=0 sa=1 ref=4 serial=7
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=10626 type=00 soft=0 mtu=1438 expire=42921/0B replaywin=2048
seqno=802 esn=0 replaywin_lastseq=00000680 itn=0
life: type=01 bytes=0/0 timeout=42930/43200
dec: spi=e313ac46 esp=aes key=16 0dcb52642eed18b852b5c65a7dc62958
ah=md5 key=16 c61d9fe60242b9a30e60b1d01da77660
enc: spi=706ffe03 esp=aes key=16 6ad98c204fa70545dbf3d2e33fb7b529
ah=md5 key=16 dcc3b866da155ef73c0aba15ec530e2e
dec:pkts/bytes=1665/16352, enc:pkts/bytes=2051/16826
npu_flag=03 npu_rgwy=11.101.1.1 npu_lgwy=173.1.1.1 npu_selid=6 dec_npuid=2 enc_npuid=2
FGT_900D # diagnose vpn ipsec st
All ipsec crypto devices in use:
NP6_0:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 0
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 0
sha1
: 0
sha256
: 0
sha384
: 0
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sha512

: 0

NP6_1:
Encryption (encrypted/decrypted)
null
: 14976
des
: 0
3des
: 0
aes
: 1664
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 1664
sha1
: 14976
sha256
: 0
sha384
: 0
sha512
: 0
NPU Host Offloading:
Encryption (encrypted/decrypted)
null
: 3
des
: 0
3des
: 0
aes
: 3
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 3
sha1
: 3
sha256
: 0
sha384
: 0
sha512
: 0
CP8:
Encryption (encrypted/decrypted)
null
: 1
des
: 0
3des
: 0
aes
: 1
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 1
sha1
: 1
sha256
: 0
sha384
: 0
sha512
: 0
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SOFTWARE:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 0
aes-gcm
: 29882
aria
: 21688
seed
: 153774
chacha20poly1305 : 29521
Integrity (generated/validated)
null
: 59403
md5
: 0
sha1
: 175462
sha256
: 0
sha384
: 0
sha512
: 0

1.
1.
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1.
29882
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29521
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175462
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1.
1.

5. If traffic cannot be offloaded by the NPU, the CP will try to encrypt/decrypt the IPsec packets.

IPsec traffic processed by CP
1. Check the NPU flag and CP counter.
# diagnose vpn tunnel list
list all ipsec tunnel in vd 0
---name=test ver=2 serial=1 173.1.1.1:0->11.101.1.1:0
bound_if=42 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/0
proxyid_num=1 child_num=0 refcnt=13 ilast=0 olast=0 ad=/0
stat: rxp=8418 txp=8418 rxb=1251248 txb=685896
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=test proto=0 sa=1 ref=3 serial=7
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=10226 type=00 soft=0 mtu=1438 expire=42037/0B replaywin=2048
seqno=20e3 esn=0 replaywin_lastseq=000020e3 itn=0
life: type=01 bytes=0/0 timeout=42928/43200
dec: spi=e313ac48 esp=aes key=16 393770842f926266530db6e43e21c4f8
ah=md5 key=16 b2e4e025e8910e95c1745e7855479cca
enc: spi=706ffe05 esp=aes key=16 7ef749610335f9f50e252023926de29e
ah=md5 key=16 0b81e4d835919ab2b8ba8edbd01aec9d
dec:pkts/bytes=8418/685896, enc:pkts/bytes=8418/1251248
npu_flag=00 npu_rgwy=11.101.1.1 npu_lgwy=173.1.1.1 npu_selid=6 dec_npuid=0 enc_npuid=0
FGT-D # diagnose vpn ipsec status
All ipsec crypto devices in use:
NP6_0:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 0
aes-gcm
: 0
aria
: 0
seed
: 0
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chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 0
sha1
: 0
sha256
: 0
sha384
: 0
sha512
: 0
NP6_1:
Encryption (encrypted/decrypted)
null
: 14976
des
: 0
3des
: 0
aes
: 1664
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 1664
sha1
: 14976
sha256
: 0
sha384
: 0
sha512
: 0
NPU Host Offloading:
Encryption (encrypted/decrypted)
null
: 3
des
: 0
3des
: 0
aes
: 3
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 3
sha1
: 3
sha256
: 0
sha384
: 0
sha512
: 0
CP8:
Encryption (encrypted/decrypted)
null
: 1
des
: 0
3des
: 0
aes
: 8499
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
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null
md5
sha1
sha256
sha384
sha512

:
:
:
:
:
:

0
8499
1
0
0
0

SOFTWARE:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 0
aes-gcm
: 29882
aria
: 21688
seed
: 153774
chacha20poly1305 : 29521
Integrity (generated/validated)
null
: 59403
md5
: 0
sha1
: 175462
sha256
: 0
sha384
: 0
sha512
: 0

2.

1.
8499
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Two options are used to control if the CP processes packets. If disabled, packets are processed by the CPU.
config system global
set ipsec-asic-offload disable
set ipsec-hmac-offload disable
end

IPsec traffic processed by CPU
IPsec traffic might be processed by the CPU for the following reasons:
l
l
l
l

Some low end models do not have NPUs.
NPU offloading and CP IPsec traffic processing manually disabled.
Some types of proposals - SEED, ARIA, chacha20poly1305 - are not supported by the NPU or CP.
NPU flag set to 00 and software encrypt/decrypt counter ticked.

# diagnose vpn tunnel list
list all ipsec tunnel in vd 0
---name=test ver=2 serial=1 173.1.1.1:0->11.101.1.1:0
bound_if=42 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/0
proxyid_num=1 child_num=0 refcnt=14 ilast=0 olast=0 ad=/0
stat: rxp=12162 txp=12162 rxb=1691412 txb=1008216
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=test proto=0 sa=1 ref=4 serial=8
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=3 options=10602 type=00 soft=0 mtu=1453 expire=42903/0B replaywin=2048
seqno=2d70 esn=0 replaywin_lastseq=00002d70 itn=0
life: type=01 bytes=0/0 timeout=42931/43200
dec: spi=e313ac4d esp=chacha20poly1305 key=36
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812d1178784c1130d1586606e44e1b9ab157e31a09edbed583be1e9cc82e8c9f2655a2cf
ah=null key=0
enc: spi=706ffe0a esp=chacha20poly1305 key=36
f2727e001e2243549b140f1614ae3df82243adb070e60c33911f461b389b05a7a642e11a
ah=null key=0
dec:pkts/bytes=11631/976356, enc:pkts/bytes=11631/1627692
npu_flag=00 npu_rgwy=11.101.1.1 npu_lgwy=173.1.1.1 npu_selid=7 dec_npuid=0 enc_npuid=0
FGT_900D # diagnose vpn ipsec status
All ipsec crypto devices in use:
NP6_0:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 0
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 0
sha1
: 0
sha256
: 0
sha384
: 0
sha512
: 0
NP6_1:
Encryption (encrypted/decrypted)
null
: 14976
des
: 0
3des
: 0
aes
: 1664
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 1664
sha1
: 14976
sha256
: 0
sha384
: 0
sha512
: 0
NPU Host Offloading:
Encryption (encrypted/decrypted)
null
: 3
des
: 0
3des
: 0
aes
: 3
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
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Integrity (generated/validated)
null
: 0
md5
: 3
sha1
: 3
sha256
: 0
sha384
: 0
sha512
: 0
CP8:
Encryption (encrypted/decrypted)
null
: 1
des
: 0
3des
: 0
aes
: 8865
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 8865
sha1
: 1
sha256
: 0
sha384
: 0
sha512
: 0
SOFTWARE:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 531
aes-gcm
: 29882
aria
: 21688
seed
: 153774
chacha20poly1305 : 41156
Integrity (generated/validated)
null
: 71038
md5
: 531
sha1
: 175462
sha256
: 0
sha384
: 0
sha512
: 0

1.
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Disable automatic ASIC offloading
When auto-asic-offload is set to disable in the firewall policy, traffic is not offloaded and the NPU hosting counter
is ticked.
# diagnose vpn ipsec status
All ipsec crypto devices in use:
NP6_0:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1.
1.
1.

1074

VPN

aes
: 0
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 0
sha1
: 0
sha256
: 0
sha384
: 0
sha512
: 0
NP6_1:
Encryption (encrypted/decrypted)
null
: 14976
des
: 0
3des
: 0
aes
: 110080
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 110080
sha1
: 14976
sha256
: 0
sha384
: 0
sha512
: 0
NPU Host Offloading:
Encryption (encrypted/decrypted)
null
: 3
des
: 0
3des
: 0
aes
: 111090
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 111090
sha1
: 3
sha256
: 0
sha384
: 0
sha512
: 0
CP8:
Encryption (encrypted/decrypted)
null
: 1
des
: 0
3des
: 0
aes
: 8865
aes-gcm
: 0
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aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 8865
sha1
: 1
sha256
: 0
sha384
: 0
sha512
: 0
SOFTWARE:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 539
aes-gcm
: 29882
aria
: 21688
seed
: 153774
chacha20poly1305 : 41259
Integrity (generated/validated)
null
: 71141
md5
: 539
sha1
: 175462
sha256
: 0
sha384
: 0
sha512
: 0

1.
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Encryption algorithms
This topic provides a brief introduction to IPsec phase 1 and phase 2 encryption algorithms and includes the following
sections:
l
l
l
l
l

IKEv1 phase 1 encryption algorithm
IKEv1 phase 2 encryption algorithm
IKEv2 phase 1 encryption algorithm
IKEv2 phase 2 encryption algorithm
HMAC settings

IKEv1 phase 1 encryption algorithm
The default encryption algorithm is:
aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1

DES is a symmetric-key algorithm, which means the same key is used for encrypting and decrypting data. FortiOS
supports:
l
l
l
l
l

des-md5
des-sha1
des-sha256
des-sha384
des-sha512
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3DES applies the DES algorithm three times to each data. FortiOS supports:
l
l
l
l
l

3des-md5
3des-sha1
3des-sha256
3des-sha384
3des-sha512

AES is a symmetric-key algorithm with different key lengths (128, 192, and 256 bits). FortiOS supports:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

aes128-md5
aes128-sha1
aes128-sha256
aes128-sha384
aes128-sha512
aes192-md5
aes192-sha1
aes192-sha256
aes192-sha384
aes192-sha512
aes256-md5
aes256-sha1
aes256-sha256
aes256-sha384
aes256-sha512

The ARIA algorithm is based on AES with different key lengths (128, 192, and 256 bits). FortiOS supports:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

aria128-md5
aria128-sha1
aria128-sha256
aria128-sha384
aria128-sha512
aria192-md5
aria192-sha1
aria192-sha256
aria192-sha384
aria192-sha512
aria256-md5
aria256-sha1
aria256-sha256
aria256-sha384
aria256-sha512

SEED is a symmetric-key algorithm. FortiOS supports:
l
l
l

seed128-md5
seed128-sha1
seed128-sha256
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l
l

seed128-sha384
seed128-sha512

Suite-B is a set of AES encryption with ICV in GCM mode. FortiOS supports Suite-B on new kernel platforms only. IPsec
traffic cannot offload to NPU. CP9 supports Suite-B offloading, otherwise packets are encrypted and decrypted by
software. FortiOS supports:
l
l

suite-b-gcm-128
suite-b-gcm-256

IKEv1 phase 2 encryption algorithm
The default encryption algorithm is:
aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm aes256gcm chacha20poly1305

With null encryption, IPsec traffic can offload NPU/CP. FortiOS supports:
l
l
l
l
l

null-md5
null-sha1
null-sha256
null-sha384
null-sha512

With the DES encryption algorithm, IPsec traffic can offload NPU/CP. FortiOS supports:
l
l
l
l
l
l

des-null
des-md5
des-sha1
des-sha256
des-sha384
des-sha512

With the 3DES encryption algorithm, IPsec traffic can offload NPU/CP. FortiOS supports:
l
l
l
l
l
l

3des-null
3des-md5
3des-sha1
3des-sha256
3des-sha384
3des-sha512

With the AES encryption algorithm, IPsec traffic can offload NPU/CP. FortiOS supports:
l
l
l
l
l
l
l
l
l
l

aes128-null
aes128-md5
aes128-sha1
aes128-sha256
aes128-sha384
aes128-sha512
aes192-null
aes192-md5
aes192-sha1
aes192-sha256
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l
l
l
l
l
l
l
l

aes192-sha384
aes192-sha512
aes256-null
aes256-md5
aes256-sha1
aes256-sha256
aes256-sha384
aes256-sha512

With the AESGCM encryption algorithm, IPsec traffic cannot offload NPU/CP. FortiOS supports:
l
l

aes128gcm
aes256gcm

With the chacha20poly1305 encryption algorithm, IPsec traffic cannot offload NPU/CP. FortiOS supports:
l

chacha20poly1305

With the ARIA encryption algorithm, IPsec traffic cannot offload NPU/CP. FortiOS supports:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

aria128-null
aria128-md5
aria128-sha1
aria128-sha256
aria128-sha384
aria128-sha512
aria192-null
aria192-md5
aria192-sha1
aria192-sha256
aria192-sha384
aria192-sha512
aria256-null
aria256-md5
aria256-sha1
aria256-sha256
aria256-sha384
aria256-sha512

With the SEED encryption algorithm, IPsec traffic cannot offload NPU/CP. FortiOS supports:
l
l
l
l
l
l

seed-null
seed-md5
seed-sha1
seed-sha256
seed-sha384
seed-sha512
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IKEv2 phase 1 encryption algorithm
The default encryption algorithm is:
aes128-sha256 aes256-sha256 aes128gcm-prfsha256 aes256gcm-prfsha384 chacha20poly1305prfsha256

DES is a symmetric-key algorithm, which means the same key is used for encrypting and decrypting data. FortiOS
supports:
l
l
l
l
l

des-md5
des-sha1
des-sha256
des-sha384
des-sha512

3DES applies the DES algorithm three times to each data. FortiOS supports:
l
l
l
l
l

3des-md5
3des-sha1
3des-sha256
3des-sha384
3des-sha512

AES is a symmetric-key algorithm with different key lengths (128, 192, and 256 bits). FortiOS supports:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

aes128-md5
aes128-sha1
aes128-sha256
aes128-sha384
aes128-sha512
aes128gcm-prfsha1
aes128gcm-prfsha256
aes128gcm-prfsha384
aes128gcm-prfsha512
aes192-md5
aes192-sha1
aes192-sha256
aes192-sha384
aes192-sha512
aes256-md5
aes256-sha1
aes256-sha256
aes256-sha384
aes256-sha512
aes256gcm-prfsha1
aes256gcm-prfsha256
aes256gcm-prfsha384
aes256gcm-prfsha512
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The ARIA algorithm is based on AES with different key lengths (128, 192, and 256 bits). FortiOS supports:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

aria128-md5
aria128-sha1
aria128-sha256
aria128-sha384
aria128-sha512
aria192-md5
aria192-sha1
aria192-sha256
aria192-sha384
aria192-sha512
aria256-md5
aria256-sha1
aria256-sha256
aria256-sha384
aria256-sha512

With the chacha20poly1305 encryption algorithm, FortiOS supports:
l
l
l
l

chacha20poly1305-prfsha1
chacha20poly1305-prfsha256
chacha20poly1305-prfsha384
chacha20poly1305-prfsha512

SEED is a symmetric-key algorithm. FortiOS supports:
l
l
l
l
l

seed128-md5
seed128-sha1
seed128-sha256
seed128-sha384
seed128-sha512

Suite-B is a set of AES encryption with ICV in GCM mode. FortiOS supports Suite-B on new kernel platforms only. IPsec
traffic cannot offload to NPU. CP9 supports Suite-B offloading, otherwise packets are encrypted and decrypted by
software. FortiOS supports:
l
l

suite-b-gcm-128
suite-b-gcm-256

IKEv2 phase 2 encryption algorithm
The default encryption algorithm is:
aes128-sha1 aes256-sha1 aes128-sha256 aes256-sha256 aes128gcm aes256gcm chacha20poly1305

With null encryption, IPsec traffic can offload NPU/CP. FortiOS supports:
l
l
l
l
l

null-md5
null-sha1
null-sha256
null-sha384
null-sha512
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With the DES encryption algorithm, IPsec traffic can offload NPU/CP. FortiOS supports:
l
l
l
l
l
l

des-null
des-md5
des-sha1
des-sha256
des-sha384
des-sha512

With the 3DES encryption algorithm, IPsec traffic can offload NPU/CP. FortiOS supports:
l
l
l
l
l
l

3des-null
3des-md5
3des-sha1
3des-sha256
3des-sha384
3des-sha512

With the AES encryption algorithm, IPsec traffic can offload NPU/CP. FortiOS supports:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

aes128-null
aes128-md5
aes128-sha1
aes128-sha256
aes128-sha384
aes128-sha512
aes192-null
aes192-md5
aes192-sha1
aes192-sha256
aes192-sha384
aes192-sha512
aes256-null
aes256-md5
aes256-sha1
aes256-sha256
aes256-sha384
aes256-sha512

With the AESGCM encryption algorithm, IPsec traffic cannot offload NPU. CP9 supports AESGCM offloading. FortiOS
supports:
l
l

aes128gcm
aes256gcm

With the chacha20poly1305 encryption algorithm, IPsec traffic cannot offload NPU/CP. FortiOS supports:
l

chacha20poly1305

With the ARIA encryption algorithm, IPsec traffic cannot offload NPU/CP. FortiOS supports:
l
l

aria128-null
aria128-md5

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1082

VPN

l
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

aria128-sha1
aria128-sha256
aria128-sha384
aria128-sha512
aria192-null
aria192-md5
aria192-sha1
aria192-sha256
aria192-sha384
aria192-sha512
aria256-null
aria256-md5
aria256-sha1
aria256-sha256
aria256-sha384
aria256-sha512

With the SEED encryption algorithm, IPsec traffic cannot offload NPU/CP. FortiOS supports:
l
l
l
l
l
l

seed-null
seed-md5
seed-sha1
seed-sha256
seed-sha384
seed-sha512

HMAC settings
The FortiGate uses the HMAC based on the authentication proposal that is chosen in phase 1 or phase 2 of the IPsec
configuration. Each proposal consists of the encryption-hash pair (such as 3des-sha256). The FortiGate matches the
most secure proposal to negotiate with the peer.

To view the chosen proposal and the HMAC hash used:
# diagnose vpn ike gateway list
vd: root/0
name: MPLS
version: 1
interface: port1 3
addr: 192.168.2.5:500 -> 10.10.10.1:500
virtual-interface-addr: 172.31.0.2 -> 172.31.0.1
created: 1015820s ago
IKE SA: created 1/13 established 1/13 time 10/1626/21010 ms
IPsec SA: created 1/24 established 1/24 time 0/11/30 ms
id/spi: 124 43b087dae99f7733/6a8473e58cd8990a
direction: responder
status: established 68693-68693s ago = 10ms
proposal: 3des-sha256
key: e0fa6ab8dc509b33-aa2cc549999b1823-c3cb9c337432646e
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lifetime/rekey: 86400/17436
DPD sent/recv: 000001e1/00000000

Fragmenting IP packets before IPsec encapsulation
The ip-fragmentation command controls packet fragmentation before IPsec encapsulation, which can benefit
packet loss in some environments.
The following options are available for the ip-fragmentation variable.

Option

Description

pre-encapsulation

Fragment before IPsec encapsulation.

post-encapsulation (default value)

Fragment after IPsec encapsulation (RFC compliant).

To configure packet fragmentation using the CLI:
config vpn ipsec phase1-interface
edit "demo"
set interface "port1"
set authmethod signature
set peertype any
set net-device enable
set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
set ip-fragmentation pre-encapsulation
set remote-gw 172.16.200.4
set certificate "Fortinet_Factory"
next
end

VPN IPsec troubleshooting
Understanding VPN related logs
This section provides some IPsec log samples.

IPsec phase1 negotiating
logid="0101037127" type="event" subtype="vpn" level="notice" vd="root" eventtime=1544132571
logdesc="Progress IPsec phase 1" msg="progress IPsec phase 1" action="negotiate"
remip=11.101.1.1
locip=173.1.1.1 remport=500 locport=500 outintf="port13"
cookies="e41eeecb2c92b337/0000000000000000" user="N/A" group="N/A" xauthuser="N/A"
xauthgroup="N/A" assignip=N/A vpntunnel="to_HQ" status="success" init="local"
mode="aggressive" dir="outbound" stage=1 role="initiator" result="OK"

IPsec phase1 negotiated
logid="0101037127" type="event" subtype="vpn" level="notice" vd="root" eventtime=1544132571
logdesc="Progress IPsec phase 1" msg="progress IPsec phase 1" action="negotiate"
remip=11.101.1.1
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locip=173.1.1.1 remport=500 locport=500 outintf="port13"
cookies="e41eeecb2c92b337/1230131a28eb4e73" user="N/A" group="N/A" xauthuser="N/A"
xauthgroup="N/A" assignip=N/A vpntunnel="to_HQ" status="success" init="local"
mode="aggressive" dir="outbound" stage=2 role="initiator" result="DONE"

IPsec phase1 tunnel up
logid="0101037138" type="event" subtype="vpn" level="notice" vd="root" eventtime=1544132604
logdesc="IPsec connection status changed" msg="IPsec connection status change"
action="tunnel-up" remip=11.101.1.1 locip=173.1.1.1 remport=500 locport=500 outintf="port13"
cookies="5b1c59fab2029e43/bf517e686d3943d2" user="N/A" group="N/A" xauthuser="N/A"
xauthgroup="N/A" assignip=11.11.11.1 vpntunnel="to_HQ" tunnelip=N/A tunnelid=1530910918
tunneltype="ipsec" duration=0 sentbyte=0 rcvdbyte=0 nextstat=0

IPsec phase2 negotiate
logid="0101037129" type="event" subtype="vpn" level="notice" vd="root" eventtime=1544132604
logdesc="Progress IPsec phase 2" msg="progress IPsec phase 2" action="negotiate"
remip=11.101.1.1
locip=173.1.1.1 remport=500 locport=500 outintf="port13"
cookies="5b1c59fab2029e43/bf517e686d3943d2" user="N/A" group="N/A" xauthuser="N/A"
xauthgroup="N/A" assignip=11.11.11.1 vpntunnel="to_HQ" status="success" init="local"
mode="quick" dir="outbound" stage=1 role="initiator" result="OK"

IPsec phase2 tunnel up
logid="0101037139" type="event" subtype="vpn" level="notice" vd="root" eventtime=1544132604
logdesc="IPsec phase 2 status changed" msg="IPsec phase 2 status change" action="phase2-up"
remip=11.101.1.1 locip=173.1.1.1 remport=500 locport=500 outintf="port13"
cookies="5b1c59fab2029e43/bf517e686d3943d2" user="N/A" group="N/A" xauthuser="N/A"
xauthgroup="N/A" assignip=11.11.11.1 vpntunnel="to_HQ"
phase2_name="to_HQ"

IPsec phase2 sa install
logid="0101037133" type="event" subtype="vpn" level="notice" vd="root" eventtime=1544132604
logdesc="IPsec SA installed" msg="install IPsec SA" action="install_sa" remip=11.101.1.1
locip=173.1.1.1
remport=500 locport=500 outintf="port13" cookies="5b1c59fab2029e43/bf517e686d3943d2"
user="N/A" group="N/A" xauthuser="N/A" xauthgroup="N/A" assignip=11.11.11.1
vpntunnel="to_HQ" role="initiator" in_spi="ca646448" out_spi="747c10c6"

IPsec tunnel statistics
logid="0101037141" type="event" subtype="vpn" level="notice" vd="root" eventtime=1544131118
logdesc="IPsec tunnel statistics" msg="IPsec tunnel statistics" action="tunnel-stats"
remip=10.1.100.15 locip=172.16.200.4 remport=500 locport=500 outintf="mgmt1"
cookies="3539884dbd8f3567/c32e4c1beca91b36"
user="N/A" group="N/A" xauthuser="N/A" xauthgroup="N/A" assignip=N/A
vpntunnel="L2tpoIPsec_0" tunnelip=10.1.100.15 tunnelid=1530910802 tunneltype="ipsec"
duration=6231 sentbyte=57343 rcvdbyte=142640 nextstat=60
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IPsec phase2 tunnel down
logid="0101037138" type="event" subtype="vpn" level="notice" vd="root" eventtime=1544132571
logdesc="IPsec connection status changed" msg="IPsec connection status change"
action="tunnel-down" remip=11.101.1.1 locip=173.1.1.1 remport=500 locport=500
outintf="port13" cookies="30820aa390687e39/886e72bf5461fb8d" user="N/A" group="N/A"
xauthuser="N/A" xauthgroup="N/A" assignip=11.11.11.1 vpntunnel="to_HQ" tunnelip=N/A
tunnelid=1530910786 tunneltype="ipsec" duration=6425 sentbyte=504 rcvdbyte=152 nextstat=0

IPsec phase1 sa deleted
logid="0101037134" type="event" subtype="vpn" level="notice" vd="root" eventtime=1544132571
logdesc="IPsec phase 1 SA deleted" msg="delete IPsec phase 1 SA" action="delete_phase1_sa"
remip=11.101.1.1 locip=173.1.1.1 remport=500 locport=500 outintf="port13"
cookies="30820aa390687e39/886e72bf5461fb8d" user="N/A" group="N/A" xauthuser="N/A"
xauthgroup="N/A" assignip=11.11.11.1 vpntunnel="to_HQ"

IPsec related diagnose command
This section provides IPsec related diagnose commands.
l

Daemon IKE summary information list: diagnose vpn ike status
connection: 2/50
IKE SA: created 2/51 established 2/9 times 0/13/40 ms
IPsec SA: created 1/13 established 1/7 times 0/8/30 ms

l

IPsec phase1 interface status: diagnose vpn ike gateway list
vd: root/0
name: tofgtc
version: 1
interface: port13 42
addr: 173.1.1.1:500 -> 172.16.200.3:500
created: 4313s ago
IKE SA: created 1/1 established 1/1 time 10/10/10 ms
IPsec SA: created 0/0
id/spi: 92 5639f7f8a5dc54c0/809a6c9bbd266a4b
direction: initiator
status: established 4313-4313s ago = 10ms
proposal: aes128-sha256
key: 74aa3d63d88e10ea-8a1c73b296b06578
lifetime/rekey: 86400/81786
DPD sent/recv: 00000000/00000000
vd: root/0
name: to_HQ
version: 1
interface: port13 42
addr: 173.1.1.1:500 -> 11.101.1.1:500
created: 1013s ago
assigned IPv4 address: 11.11.11.1/255.255.255.252
IKE SA: created 1/1 established 1/1 time 0/0/0 ms
IPsec SA: created 1/1 established 1/1 time 0/0/0 ms
id/spi: 95 255791bd30c749f4/c2505db65210258b

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1086

VPN

direction: initiator
status: established 1013-1013s ago = 0ms
proposal: aes128-sha256
key: bb101b9127ed5844-1582fd614d5a8a33
lifetime/rekey: 86400/85086
DPD sent/recv: 00000000/00000010
l

IPsec phase2 tunnel status: diagnose vpn tunnel list
list all ipsec tunnel in vd 0
---nname=L2tpoIPsec ver=1 serial=6 172.16.200.4:0->0.0.0.0:0
bound_if=4 lgwy=static/1 tun=intf/0 mode=dialup/2 encap=none/24 options[0018]=npu
create_dev
proxyid_num=0 child_num=0 refcnt=10 ilast=13544 olast=13544 ad=/0
stat: rxp=0 txp=0 rxb=0 txb=0
dpd: mode=on-idle on=0 idle=60000ms retry=3 count=0 seqno=0
natt: mode=none draft=0 interval=0 remote_port=0
run_tally=0
---name=to_HQ ver=1 serial=7 173.1.1.1:0->11.101.1.1:0
bound_if=42 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/8 options[0008]=npu
proxyid_num=1 child_num=0 refcnt=13 ilast=10 olast=1112 ad=/0
stat: rxp=1 txp=4 rxb=152 txb=336
dpd: mode=on-demand on=1 idle=20000ms retry=3 count=0 seqno=5
natt: mode=none draft=0 interval=0 remote_port=0
proxyid=to_HQ proto=0 sa=1 ref=2 serial=1
src: 0:0.0.0.0/0.0.0.0:0
dst: 0:0.0.0.0/0.0.0.0:0
SA: ref=6 options=10226 type=00 soft=0 mtu=1438 expire=41773/0B replaywin=2048
seqno=5 esn=0 replaywin_lastseq=00000002 itn=0
life: type=01 bytes=0/0 timeout=42900/43200
dec: spi=ca64644a esp=aes key=16 6cc873fdef91337a6cf9b6948972c90f
ah=sha1 key=20 e576dbe3ff92605931e5670ad57763c50c7dc73a
enc: spi=747c10c8 esp=aes key=16 5060ad8d0da6824204e3596c0bd762f4
ah=sha1 key=20 52965cbd5b6ad95212fc825929d26c0401948abe
dec:pkts/bytes=1/84, enc:pkts/bytes=4/608
npu_flag=03 npu_rgwy=11.101.1.1 npu_lgwy=173.1.1.1 npu_selid=5 dec_npuid=2 enc_npuid=2

l

Packets encrypted/decrypted counter: diagnose vpn ipsec status
All ipsec crypto devices in use:
NP6_0:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 0
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 0
sha1
: 0
sha256
: 0
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sha384
sha512

: 0
: 0

NP6_1:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 337152
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 0
sha1
: 337152
sha256
: 0
sha384
: 0
sha512
: 0
NPU Host Offloading:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 38
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 0
sha1
: 38
sha256
: 0
sha384
: 0
sha512
: 0
CP8:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 1337
aes
: 71
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 48
sha1
: 1360
sha256
: 0
sha384
: 0
sha512
: 0
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SOFTWARE:
Encryption (encrypted/decrypted)
null
: 0
des
: 0
3des
: 0
aes
: 0
aes-gcm
: 0
aria
: 0
seed
: 0
chacha20poly1305 : 0
Integrity (generated/validated)
null
: 0
md5
: 0
sha1
: 0
sha256
: 0
sha384
: 0
sha512
: 0
l

1.
1.
1.
1.
1.
1.
1.
1.
1.
1.
1.
1.
1.
1.

diagnose debug application ike -1
l diagnose vpn ike log-filter dst-addr4 11.101.1.1
l diagnose vpn ike log-filter src-addr4 173.1.1.1
# ike 0:to_HQ:101: initiator: aggressive mode is sending 1st message...
ike 0:to_HQ:101: cookie dff03f1d4820222a/0000000000000000
ike 0:to_HQ:101: sent IKE msg (agg_i1send): 173.1.1.1:500->11.101.1.1:500, len=912,
id=dff03f1d4820222a/0000000000000000
ike 0: comes 11.101.1.1:500->173.1.1.1:500,ifindex=42....
ike 0: IKEv1 exchange=Aggressive id=dff03f1d4820222a/6c2caf4dcf5bab75 len=624
ike 0:to_HQ:101: initiator: aggressive mode get 1st response...
ike 0:to_HQ:101: VID RFC 3947 4A131C81070358455C5728F20E95452F
ike 0:to_HQ:101: VID DPD AFCAD71368A1F1C96B8696FC77570100
ike 0:to_HQ:101: DPD negotiated
ike 0:to_HQ:101: VID draft-ietf-ipsra-isakmp-xauth-06.txt 09002689DFD6B712
ike 0:to_HQ:101: VID CISCO-UNITY 12F5F28C457168A9702D9FE274CC0204
ike 0:to_HQ:101: peer supports UNITY
ike 0:to_HQ:101: VID FORTIGATE 8299031757A36082C6A621DE00000000
ike 0:to_HQ:101: peer is [[QualityAssurance62/FortiGate]]/FortiOS (v0 b0)
ike 0:to_HQ:101: VID FRAGMENTATION 4048B7D56EBCE88525E7DE7F00D6C2D3
ike 0:to_HQ:101: VID FRAGMENTATION 4048B7D56EBCE88525E7DE7F00D6C2D3C0000000
ike 0:to_HQ:101: peer identifier IPV4_ADDR 11.101.1.1
ike 0:to_HQ:101: negotiation result
ike 0:to_HQ:101: proposal id = 1:
ike 0:to_HQ:101:
protocol id = ISAKMP:
ike 0:to_HQ:101:
trans_id = KEY_IKE.
ike 0:to_HQ:101:
encapsulation = IKE/none
ike 0:to_HQ:101:
type=OAKLEY_ENCRYPT_ALG, val=AES_CBC, key-len=128
ike 0:to_HQ:101:
type=OAKLEY_HASH_ALG, val=SHA2_256.
ike 0:to_HQ:101:
type=AUTH_METHOD, val=PRESHARED_KEY_XAUTH_I.
ike 0:to_HQ:101:
type=OAKLEY_GROUP, val=MODP2048.
ike 0:to_HQ:101: ISAKMP SA lifetime=86400
ike 0:to_HQ:101: received NAT-D payload type 20
ike 0:to_HQ:101: received NAT-D payload type 20
ike 0:to_HQ:101: selected NAT-T version: RFC 3947
ike 0:to_HQ:101: NAT not detected
ike 0:to_HQ:101: ISAKMP SA dff03f1d4820222a/6c2caf4dcf5bab75 key
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16:D81CAE6B2500435BFF195491E80148F3
ike 0:to_HQ:101: PSK authentication succeeded
ike 0:to_HQ:101: authentication OK
ike 0:to_HQ:101: add INITIAL-CONTACT
ike 0:to_HQ:101: sent IKE msg (agg_i2send): 173.1.1.1:500->11.101.1.1:500, len=172,
id=dff03f1d4820222a/6c2caf4dcf5bab75
ike 0:to_HQ:101: established IKE SA dff03f1d4820222a/6c2caf4dcf5bab75
ike 0: comes 11.101.1.1:500->173.1.1.1:500,ifindex=42....
ike 0: IKEv1 exchange=Mode config id=dff03f1d4820222a/6c2caf4dcf5bab75:97d88fb4 len=92
ike 0:to_HQ:101: mode-cfg type 16521 request 0:
ike 0:to_HQ:101: mode-cfg type 16522 request 0:
ike 0:to_HQ:101: sent IKE msg (cfg_send): 173.1.1.1:500->11.101.1.1:500, len=108,
id=dff03f1d4820222a/6c2caf4dcf5bab75:97d88fb4
ike 0: comes 11.101.1.1:500->173.1.1.1:500,ifindex=42....
ike 0: IKEv1 exchange=Mode config id=dff03f1d4820222a/6c2caf4dcf5bab75:3724f295 len=92
ike 0:to_HQ:101: sent IKE msg (cfg_send): 173.1.1.1:500->11.101.1.1:500, len=92,
id=dff03f1d4820222a/6c2caf4dcf5bab75:3724f295
ike 0:to_HQ:101: initiating mode-cfg pull from peer
ike 0:to_HQ:101: mode-cfg request APPLICATION_VERSION
ike 0:to_HQ:101: mode-cfg request INTERNAL_IP4_ADDRESS
ike 0:to_HQ:101: mode-cfg request INTERNAL_IP4_NETMASK
ike 0:to_HQ:101: mode-cfg request UNITY_SPLIT_INCLUDE
ike 0:to_HQ:101: mode-cfg request UNITY_PFS
ike 0:to_HQ:101: sent IKE msg (cfg_send): 173.1.1.1:500->11.101.1.1:500, len=140,
id=dff03f1d4820222a/6c2caf4dcf5bab75:3bca961f
ike 0: comes 11.101.1.1:500->173.1.1.1:500,ifindex=42....
ike 0: IKEv1 exchange=Mode config id=dff03f1d4820222a/6c2caf4dcf5bab75:3bca961f len=172
ike 0:to_HQ:101: mode-cfg type 1 response 4:0B0B0B01
ike 0:to_HQ:101: mode-cfg received INTERNAL_IP4_ADDRESS 11.11.11.1
ike 0:to_HQ:101: mode-cfg type 2 response 4:FFFFFFFC
ike 0:to_HQ:101: mode-cfg received INTERNAL_IP4_NETMASK 255.255.255.252
ike 0:to_HQ:101: mode-cfg received UNITY_PFS 1
ike 0:to_HQ:101: mode-cfg type 28676 response
28:0A016400FFFFFF000000000000000A016500FFFFFF00000000000000
ike 0:to_HQ:101: mode-cfg received UNITY_SPLIT_INCLUDE 0 10.1.100.0/255.255.255.0:0
local port 0
ike 0:to_HQ:101: mode-cfg received UNITY_SPLIT_INCLUDE 0 10.1.101.0/255.255.255.0:0
local port 0
ike 0:to_HQ:101: mode-cfg received APPLICATION_VERSION 'FortiGate-100D
v6.0.3,build0200,181009 (GA)'
ike 0:to_HQ: mode-cfg add 11.11.11.1/255.255.255.252 to 'to_HQ'/58
ike 0:to_HQ: set oper up
ike 0:to_HQ: schedule auto-negotiate
ike 0:to_HQ:101: no pending Quick-Mode negotiations
ike shrank heap by 159744 bytes
ike 0:to_HQ:to_HQ: IPsec SA connect 42 173.1.1.1->11.101.1.1:0
ike 0:to_HQ:to_HQ: using existing connection
# ike 0:to_HQ:to_HQ: config found
ike 0:to_HQ:to_HQ: IPsec SA connect 42 173.1.1.1->11.101.1.1:500 negotiating
ike 0:to_HQ:101: cookie dff03f1d4820222a/6c2caf4dcf5bab75:32f4cc01
ike 0:to_HQ:101:to_HQ:259: initiator selectors 0 0:0.0.0.0/0.0.0.0:0:0>0:0.0.0.0/0.0.0.0:0:0
ike 0:to_HQ:101: sent IKE msg (quick_i1send): 173.1.1.1:500->11.101.1.1:500, len=620,
id=dff03f1d4820222a/6c2caf4dcf5bab75:32f4cc01
ike 0: comes 11.101.1.1:500->173.1.1.1:500,ifindex=42....
ike 0: IKEv1 exchange=Quick id=dff03f1d4820222a/6c2caf4dcf5bab75:32f4cc01 len=444
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ike 0:to_HQ:101:to_HQ:259: responder selectors 0:0.0.0.0/0.0.0.0:0->0:0.0.0.0/0.0.0.0:0
ike 0:to_HQ:101:to_HQ:259: my proposal:
ike 0:to_HQ:101:to_HQ:259: proposal id = 1:
ike 0:to_HQ:101:to_HQ:259:
protocol id = IPSEC_ESP:
ike 0:to_HQ:101:to_HQ:259:
PFS DH group = 14
ike 0:to_HQ:101:to_HQ:259:
trans_id = ESP_AES_CBC (key_len = 128)
ike 0:to_HQ:101:to_HQ:259:
encapsulation = ENCAPSULATION_MODE_TUNNEL
ike 0:to_HQ:101:to_HQ:259:
type = AUTH_ALG, val=SHA1
ike 0:to_HQ:101:to_HQ:259:
trans_id = ESP_AES_CBC (key_len = 256)
ike 0:to_HQ:101:to_HQ:259:
encapsulation = ENCAPSULATION_MODE_TUNNEL
ike 0:to_HQ:101:to_HQ:259:
type = AUTH_ALG, val=SHA1
ike 0:to_HQ:101:to_HQ:259:
trans_id = ESP_AES_CBC (key_len = 128)
ike 0:to_HQ:101:to_HQ:259:
encapsulation = ENCAPSULATION_MODE_TUNNEL
ike 0:to_HQ:101:to_HQ:259:
type = AUTH_ALG, val=SHA2_256
ike 0:to_HQ:101:to_HQ:259:
trans_id = ESP_AES_CBC (key_len = 256)
ike 0:to_HQ:101:to_HQ:259:
encapsulation = ENCAPSULATION_MODE_TUNNEL
ike 0:to_HQ:101:to_HQ:259:
type = AUTH_ALG, val=SHA2_256
ike 0:to_HQ:101:to_HQ:259:
trans_id = ESP_AES_GCM_16 (key_len = 128)
ike 0:to_HQ:101:to_HQ:259:
encapsulation = ENCAPSULATION_MODE_TUNNEL
ike 0:to_HQ:101:to_HQ:259:
type = AUTH_ALG, val=NULL
ike 0:to_HQ:101:to_HQ:259:
trans_id = ESP_AES_GCM_16 (key_len = 256)
ike 0:to_HQ:101:to_HQ:259:
encapsulation = ENCAPSULATION_MODE_TUNNEL
ike 0:to_HQ:101:to_HQ:259:
type = AUTH_ALG, val=NULL
ike 0:to_HQ:101:to_HQ:259:
trans_id = ESP_CHACHA20_POLY1305 (key_len = 256)
ike 0:to_HQ:101:to_HQ:259:
encapsulation = ENCAPSULATION_MODE_TUNNEL
ike 0:to_HQ:101:to_HQ:259:
type = AUTH_ALG, val=NULL
ike 0:to_HQ:101:to_HQ:259: incoming proposal:
ike 0:to_HQ:101:to_HQ:259: proposal id = 1:
ike 0:to_HQ:101:to_HQ:259:
protocol id = IPSEC_ESP:
ike 0:to_HQ:101:to_HQ:259:
PFS DH group = 14
ike 0:to_HQ:101:to_HQ:259:
trans_id = ESP_AES_CBC (key_len = 128)
ike 0:to_HQ:101:to_HQ:259:
encapsulation = ENCAPSULATION_MODE_TUNNEL
ike 0:to_HQ:101:to_HQ:259:
type = AUTH_ALG, val=SHA1
ike 0:to_HQ: schedule auto-negotiate
ike 0:to_HQ:101:to_HQ:259: replay protection enabled
ike 0:to_HQ:101:to_HQ:259: SA life soft seconds=42902.
ike 0:to_HQ:101:to_HQ:259: SA life hard seconds=43200.
ike 0:to_HQ:101:to_HQ:259: IPsec SA selectors #src=1 #dst=1
ike 0:to_HQ:101:to_HQ:259: src 0 4 0:0.0.0.0/0.0.0.0:0
ike 0:to_HQ:101:to_HQ:259: dst 0 4 0:0.0.0.0/0.0.0.0:0
ike 0:to_HQ:101:to_HQ:259: add IPsec SA: SPIs=ca64644b/747c10c9
ike 0:to_HQ:101:to_HQ:259: IPsec SA dec spi ca64644b key
16:D5C60F1A3951B288CE4DEC7E04D2119D auth 20:F872A7A26964208A9AA368A31AEFA3DB3F3780BC
ike 0:to_HQ:101:to_HQ:259: IPsec SA enc spi 747c10c9 key
16:97952E1594F718128D9D7B09400856EA auth 20:4D5E5BC45A9D5A9A4631E911932F5650A4639A37
ike 0:to_HQ:101:to_HQ:259: added IPsec SA: SPIs=ca64644b/747c10c9
ike 0:to_HQ:101:to_HQ:259: sending SNMP tunnel UP trap
ike 0:to_HQ:101: sent IKE msg (quick_i2send): 173.1.1.1:500->11.101.1.1:500, len=76,
id=dff03f1d4820222a/6c2caf4dcf5bab75:32f4cc01

SSL VPN
The following topics provide information about SSL VPN in FortiOS 6.2.0.
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l
l
l
l
l
l
l
l

SSL VPN best practices on page 1092
SSL VPN web mode for remote user on page 1094
SSL VPN tunnel mode
SSL VPN multi-realm on page 1107
SSL VPN authentication on page 1111
SSL VPN protocols on page 1148
SSL VPN to IPsec VPN on page 1150
SSL VPN troubleshooting on page 1160

SSL VPN best practices
Securing remote access to network resources is a critical part of security operations. SSL VPN allows administrators to
configure, administer, and deploy a remote access strategy for their remote workers.
Choosing the correct mode of operation and applying the proper levels of security are integral to providing optimal
performance and user experience, and keeping your user data safe.
The below guidelines outline selecting the correct SSL VPN mode for your deployment and employing best practices to
ensure that your data are protected.
Information about SSL VPN throughput and maximum concurrent users is available on your device's datasheet; see
Next-Generation Firewalls Models and Specifications.

Tunnel mode
In tunnel mode, the SSL VPN client encrypts all traffic from the remote client computer and sends it to the FortiGate
through an SSL VPN tunnel over the HTTPS link between the user and the FortiGate.
The FortiGate establishes a tunnel with the client, and assigns a virtual IP (VIP) address to the client from a range
reserved addresses. While the underlying protocols are different, the outcome is very similar to a IPsec VPN tunnel. All
client traffic is encrypted, allowing the users and networks to exchange a wide range of traffic, regardless of the
application or protocols.
Use this mode if you require:
l
l
l
l

A wide range of applications and protocols to be accessed by the remote client.
No proxying is done by the FortiGate.
Straightforward configuration and administration, as traffic is controlled by firewall policies.
A transparent experience for the end user. For example, a user that needs to RDP to their server only requires a
tunnel connection; they can then use the usual client application, like Windows Remote Desktop, to connect.

Full tunneling forces all traffic to pass through the FortiGate (see SSL VPN full tunnel for remote user on page 1098).
Split tunneling only routes traffic to the designated network through the FortiGate (see SSL VPN split tunnel for remote
user on page 1101).

Limitations
Tunnel mode requires that the FortiClient VPN client be installed on the remote end. The standalone FortiClient VPN
client is free to use, and can accommodate SSL VPN and IPsec VPN tunnels. For supported operating systems, see the
FortiClient Technical Specifications.
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Web mode
Web-only mode provides clientless network access using a web browser with built-in SSL encryption. Users
authenticate to FortiGate's SSL VPN Web Portal, which provides access to network services and resources, including
HTTP/HTTPS, Telnet, FTP, SMB/CIFS, VNC, RDP, and SSH. When a user starts a connection to a server from the web
portal, FortiOS proxies this communication with the server. All communication between the FortiGate and the user
continues to be over HTTPS, regardless of the service that is being accesssed.
Use this mode if you require:
l
l
l

A clientless solution in which all remote services are access through a web portal.
Tight control over the contents of the web portal.
Limited services provided to the remote users.

Limitations
l
l
l
l
l

Multiple applications and protocols are not supported.
VNC and RDP access might have limitations, such as certain shortcut keys not being supported.
In some configurations RDP can consume a significant amount of memory and CPU time.
Firewall performance might decrease as remote usage increases.
Highly customized web pages might not render correctly.

Security best practices
Integrate with authentication servers
For networks with many users, integrate your user configuration with existing authentication servers through LDAP,
RADIUS, or FortiAuthenticator.
By integrating with existing authentication servers, such as Windows AD, there is a lower change of making mistakes
when configuring local users and user groups. Your administration effort is also reduces.
See SSL VPN with LDAP-integrated certificate authentication on page 1116 for more information.

Use a non-factory SSL certificate for the SSL VPN portal
Your certificate should identify your domain so that a remote user can recognize the identity of the server or portal that
they are accessing through a trusted CA.
The default Fortinet factory self-signed certificates are provided to simplify initial installation and testing. If you use these
certificates you are vulnerable to man-in-the-middle attacks, where an attacker spoofs your certificate, compromises
your connection, and steals your personal information. It is highly recommended that you purchase a server certificate
from a trusted CA to allow remote users to connect to SSL VPN with confidence. See Purchase and import a signed SSL
certificate on page 560 for more information.
Enabling the Do not Warn Invalid Server Certificate option on the client disables the certificate warning message,
potentially allowing users to accidentally connect to untrusted servers. Disabling invalid server certificate warnings is not
recommended.
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Use multi-factor authentication
Multi-factor authentication (MFA) ensures that the end-user is who they claim to be by requiring at least two factors - a
piece of information that the user knows (password), and an asset that the user has (OTP). A third factor, something a
user is (fingerprint or face), may be enabled as well. FortiToken Mobile is typically used for MFA.
FortiGate comes with two free FortiTokens, and more can be purchased from the FortiToken Mobile iOS app or through
Fortinet partners.
See SSL VPN with FortiToken mobile push authentication on page 1122 for more information.
2FA, a subset of MFA, can also be set up with email tokens. See Email Two-Factor Authentication on FortiGate for
information.

Deploy user certificates for remote SSL VPN users
This method of 2FA uses a user certificate as the second authentication factor. This is more secure, as it identifies the
end user using a certificate. The configuration and administration of this solution is significantly more complicated, and
requires administrators with advanced knowledge of the FortiGate and certificate deployment.
See SSL VPN with certificate authentication on page 1111 for more information.

Define your minimum supported TLS version and cipher suites
Minimum and maximum supported TLS version can be configured in the FortiGate CLI. The cipher algorithm can also be
customized.
See How to control the SSL version and cipher suite for SSL VPN for more information.

Properly administer firewall policies and profiles against only the access level required for the remote
user
Users do not all require the same access. Access should only be granted after careful considerations. Typically, users
are placed in groups, and each group is allowed access to limited resources.
Using SSL VPN realms simplifies defining the control structure for mapping users and groups to the appropriate
resources.
See SSL VPN multi-realm on page 1107 for more information.

SSL VPN web mode for remote user
This is a sample configuration of remote users accessing the corporate network through an SSL VPN by web mode
using a web browser.
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Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Configure user and user group.
a. Go to User & Device > User Definition to create a local user sslvpnuser1.
b. Go to User & Device > User Groups to create a group sslvpngroup with the member sslvpnuser1.
3. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to create a web mode only portal my-web-portal.
b. Set Predefined Bookmarks for Windows server to type RDP.
4. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. For Listen on Interface(s), select wan1.
c. Set Listen on Port to 10443.
d. Choose a certificate for Server Certificate. The default is Fortinet_Factory.
e. In Authentication/Portal Mapping All Other Users/Groups, set the Portal to web-access.
f. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal my-Web-portal.
5. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name. In this example, sslvpn web mode access.
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c.
d.
e.
f.
g.
h.

Incoming interface must be SSL-VPN tunnel interface(ssl.root).
Choose an Outgoing Interface. In this example, port1.
Set the Source to all and group to sslvpngroup.
In this example, the Destination is the internal protected subnet 192.168.1.0.
Set Schedule to always, Service to ALL, and Action to Accept.
Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure the internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Configure user and user group.
config user local
edit "sslvpnuser1"
set type password
set passwd your-password
next
end
config user group
edit "sslvpngroup"
set member "vpnuser1"
next
end

4. Configure SSL VPN web portal and predefine RDP bookmark for windows server.
config vpn ssl web portal
edit "my-web-portal"
set web-mode enable
config bookmark-group
edit "gui-bookmarks"
config bookmarks
edit "Windows Server"
set apptype rdp
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set
set
set
set

host "192.168.1.114"
port 3389
logon-user "your-windows-server-user-name"
logon-password your-windows-server-password

next
end
next
end
next
end

5. Configure SSL VPN settings.
config vpn ssl settings
set servercert "Fortinet_Factory"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set tunnel-ipv6-pools "SSLVPN_TUNNEL_IPv6_ADDR1"
set source-interface "wan1"
set source-address "all"
set source-address6 "all"
set default-portal "full-access"
config authentication-rule
edit 1
set groups "sslvpngroup"
set portal "my-web-portal"
next
end

6. Configure one SSL VPN firewall policy to allow remote user to access the internal network. Traffic is dropped from
internal to remote client
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “sslvpngroup”
set action accept
set schedule "always"
set service "ALL"
next
end

To see the results:
1.
2.
3.
4.

In a web browser, log into the portal https://172.20.120.123:10443 using the credentials you've set up.
In the portal with the predefined bookmark, select the bookmark to begin an RDP session.
Go to VPN > Monitor > SSL-VPN Monitor to verify the list of SSL users.
Go to Log & Report > Traffic Log > Forward Traffic to view the details for the SSL entry.

SSL VPN tunnel mode
The following topics provide instructions on configuring SSL VPN tunnel mode:
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l
l
l

SSL VPN full tunnel for remote user
SSL VPN split tunnel for remote user
SSL VPN tunnel mode host check

SSL VPN full tunnel for remote user
This is a sample configuration of remote users accessing the corporate network and internet through an SSL VPN by
tunnel mode using FortiClient.

Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address:
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
2. Configure user and user group:
a. Go to User & Device > User Definition to create a local user sslvpnuser1.
b. Go to User & Device > User Groups to create a group sslvpngroup with the member sslvpnuser1.
3. Configure SSL VPN web portal:
a. Go to VPN > SSL-VPN Portals to create a tunnel mode only portal my-full-tunnel-portal.
b. Disable Split Tunneling.
4. Configure SSL VPN settings:
a. Go to VPN > SSL-VPN Settings.
b. For Listen on Interface(s), select wan1.
c. Set Listen on Port to 10443.
d. Choose a certificate for Server Certificate. The default is Fortinet_Factory.
e. In Authentication/Portal Mapping All Other Users/Groups, set the Portal to tunnel-access.
f. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal my-full-tunnel-portal.
5. Configure SSL VPN firewall policies to allow remote user to access the internal network:
a. Go to Policy & Objects > IPv4 Policy and click Create New.
b. Set Name to sslvpn tunnel mode access.
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c. Set Incoming Interface to SSL-VPN tunnel interface(ssl.root).
d. Set Outgoing Interface to port1.
e. Set the Source Address to SSLVPN_TUNNEL_ADDR1 and User to sslvpngroup. The source address
references the tunnel IP addresses that the remote clients are using.
f. Set Destination to all, Schedule to always, Service to ALL, and Action to Accept.
g. Click OK.
h. Click Create New.
i. Set Name to sslvpn tunnel mode outgoing.
j. Configure the same settings as the previous policy, except set Outgoing Interface to wan1.
k. Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address:
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure the internal interface and protected subnet, then connect the port1 interface to the internal network:
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end

3. Configure user and user group:
config user local
edit "sslvpnuser1"
set type password
set passwd your-password
next
end
config user group
edit "sslvpngroup"
set member "vpnuser1"
next
end

4. Configure SSL VPN web portal and predefine RDP bookmark for windows server:
config vpn ssl web portal
edit "my-full-tunnel-portal"
set tunnel-mode enable
set split-tunneling disable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
next
end
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5. Configure SSL VPN settings:
config vpn ssl settings
set servercert "Fortinet_Factory"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set tunnel-ipv6-pools "SSLVPN_TUNNEL_IPv6_ADDR1"
set source-interface "wan1"
set source-address "all"
set source-address6 "all"
set default-portal "full-access"
config authentication-rule
edit 1
set groups "sslvpngroup"
set portal "my-full-tunnel-portal"
next
end

6. Configure SSL VPN firewall policies to allow remote user to access the internal network. Traffic is dropped from
internal to remote client.
config firewall policy
edit 1
set name "sslvpn tunnel mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "all"
set groups "sslvpngroup"
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "sslvpn tunnel mode outgoing"
set srcintf "ssl.root"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "all"
set groups "sslvpngroup"
set action accept
set schedule "always"
set service "ALL"
next
end

To see the results:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access.
3. Add a new connection.
l Set VPN Type to SSL VPN.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Save your settings.
6. Use the credentials you've set up to connect to the SSL VPN tunnel.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1100

VPN
7. After connection, all traffic except the local subnet will go through the tunnel FGT.
8. Go to VPN > Monitor > SSL-VPN Monitor to verify the list of SSL users.
9. On the FortiGate, go to Log & Report > Traffic Log > Forward Traffic and view the details for the SSL entry.

SSL VPN split tunnel for remote user
This is a sample configuration of remote users accessing the corporate network and internet through an SSL VPN by
tunnel mode using FortiClient but accessing the Internet without going through the SSL VPN tunnel.

Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create address for internet subnet 192.168.1.0.
2. Configure user and user group.
a. Go to User & Device > User Definition to create a local user sslvpnuser1.
b. Go to User & Device > User Groups to create a group sslvpngroup with the member sslvpnuser1.
3. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to create a tunnel mode only portal my-split-tunnel-portal.
b. Enable Split Tunneling.
c. Select Routing Address.
4. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. For Listen on Interface(s), select wan1.
c. Set Listen on Port to 10443.
d. Choose a certificate for Server Certificate. The default is Fortinet_Factory.
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e. In Authentication/Portal Mapping All Other Users/Groups, set the Portal to tunnel-access.
f. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal my-split-tunnel-portal.
5. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name. In this example, sslvpn split tunnel access.
c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Choose an Outgoing Interface. In this example, port1.
e. Set the Source to all and group to sslvpngroup.
f. In this example, the Destination is all.
g. Set Schedule to always, Service to ALL, and Action to Accept.
h. Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Configure user and user group.
config user local
edit "sslvpnuser1"
set type password
set passwd your-password
next
end
config user group
edit "sslvpngroup"
set member "vpnuser1"
next
end

4. Configure SSL VPN web portal.
config vpn ssl web portal
edit "my-split-tunnel-portal"
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set
set
set
set

tunnel-mode enable
split-tunneling enable
split-tunneling-routing-address "192.168.1.0"
ip-pools "SSLVPN_TUNNEL_ADDR1"

next
end

5. Configure SSL VPN settings.
config vpn ssl settings
set servercert "Fortinet_Factory"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set tunnel-ipv6-pools "SSLVPN_TUNNEL_IPv6_ADDR1"
set source-interface "wan1"
set source-address "all"
set source-address6 "all"
set default-portal "full-access"
config authentication-rule
edit 1
set groups "sslvpngroup"
set portal "my-split-tunnel-portal"
next
end

6. Configure one SSL VPN firewall policy to allow remote user to access the internal network. Traffic is dropped from
internal to remote client.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “sslvpngroup”
set action accept
set schedule "always"
set service "ALL"
next
end

To see the results:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access.
3. Add a new connection.
l Set VPN Type to SSL VPN.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Save your settings.
6. Use the credentials you've set up to connect to the SSL VPN tunnel.
7. After connection, traffic to 192.168.1.0 goes through the tunnel. Other traffic goes through the local gateway.
8. In FGT, go to VPN > Monitor > SSL-VPN Monitor to verify the list of SSL users.
9. In FGT, go to Log & Report > Traffic Log > Forward Traffic and view the details for the SSL entry.
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SSL VPN tunnel mode host check
This is a sample configuration of remote users accessing the corporate network through an SSL VPN by tunnel mode
using FortiClient with AV host check.

Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Configure user and user group.
a. Go to User & Device > User Definition to create a local user sslvpnuser1.
b. Go to User & Device > User Groups to create a group sslvpngroup with the member sslvpnuser1.
3. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to create a tunnel mode only portal my-split-tunnel-portal.
b. Enable Tunnel Mode and Enable Split Tunneling.
c. Select Routing Address.
4. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. For Listen on Interface(s), select wan1.
c. Set Listen on Port to 10443.
d. Choose a certificate for Server Certificate. The default is Fortinet_Factory.
e. In Authentication/Portal Mapping All Other Users/Groups, set the Portal to tunnel-access.
f. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal my-split-tunnel-portal.
5. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name. In this example, sslvpn tunnel access with av check.
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c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Choose an Outgoing Interface. In this example, port1.
e. Set the Source to all and group to sslvpngroup.
f. In this example, the Destination is all.
g. Set Schedule to always, Service to ALL, and Action to Accept.
h. Click OK.
6. Use CLI to configure SSL VPN web portal to enable the host to check for compliant antivirus software on the user’s
computer.
config vpn ssl web portal
edit my-split-tunnel-access
set host-check av
end

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Configure user and user group.
config user local
edit "sslvpnuser1"
set type password
set passwd your-password
next
end
config user group
edit "sslvpngroup"
set member "vpnuser1"
next
end

4. Configure SSL VPN web portal.
config vpn ssl web portal
edit "my-split-tunnel-portal"
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set
set
set
set

tunnel-mode enable
split-tunneling enable
split-tunneling-routing-address "192.168.1.0"
ip-pools "SSLVPN_TUNNEL_ADDR1"

next
end

5. Configure SSL VPN settings.
config vpn ssl settings
set servercert "Fortinet_Factory"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set tunnel-ipv6-pools "SSLVPN_TUNNEL_IPv6_ADDR1"
set source-interface "wan1"
set source-address "all"
set source-address6 "all"
set default-portal "full-access"
config authentication-rule
edit 1
set groups "sslvpngroup"
set portal "my-split-tunnel-portal"
next
end

6. Configure one SSL VPN firewall policy to allow remote user to access the internal network. Traffic is dropped from
internal to remote client.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “sslvpngroup”
set action accept
set schedule "always"
set service "ALL"
next
end

7. Configure SSL VPN web portal to enable the host to check for compliant antivirus software on the user’s computer:
config vpn ssl web portal
edit my-split-tunnel-access
set host-check av
end

To see the results:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access.
3. Add a new connection.
l Set VPN Type to SSL VPN.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Save your settings.
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6. Use the credentials you've set up to connect to the SSL VPN tunnel.
If the user's computer has antivirus software, a connection is established; otherwise FortiClient shows a compliance
warning.
7. After connection, traffic to 192.168.1.0 goes through the tunnel. Other traffic goes through local gateway.
8. In FGT, go to VPN > Monitor > SSL-VPN Monitor to verify the list of SSL users.
9. In FGT, go to Log & Report > Traffic Log > Forward Traffic and view the details for the SSL entry.

SSL VPN multi-realm
This sample shows how to create a multi-realm SSL VPN that provides different portals for different user groups.

Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet QA_subnet with subnet 192.168.1.0/24
and HR_subnet with subnet 10.1.100.0/24.
2. Configure user and user group.
a. Go to User & Device > User Definition to create local users qa-user1 and hr-user1.
b. Go to User & Device > User Groups to create separate user groups for web-only and full-access portals:
l QA_group with member qa-user1.
l HR_group with the member hr-user1.
3. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to create portal qa-tunnel.
b. Enable Tunnel Mode.
c. Create a portal hr-web with Web Mode enabled.
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4. Configure SSL VPN realms.
a. Go to System > Feature Visibility to enable SSL-VPN Realms.
b. Go to VPN > SSL-VPN Realms to create realms for qa and hr.
5. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. For Listen on Interface(s), select wan1.
c. Set Listen on Port to 10443.
d. Choose a certificate for Server Certificate. The default is Fortinet_Factory.
e. In Authentication/Portal Mapping All Other Users/Groups, set the Portal to web-access.
f. Create new Authentication/Portal Mapping for group QA_group mapping portal qa-tunnel.
g. Specify the realm qa.
h. Add another entry for group HR_group mapping portal hr-web.
i. Specify the realm hr.
6. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Create a firewall policy for QA access.
c. Fill in the firewall policy name. In this example, QA sslvpn tunnel mode access.
d. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
e. Choose an Outgoing Interface. In this example, port1.
f. Set the Source to all and group to QA_group.
g. In this example, the Destination is the internal protected subnet QA_subnet.
h. Set Schedule to always, Service to ALL, and Action to Accept.
i. Click OK.
j. Create a firewall policy for HR access.
k. Fill in the firewall policy name. In this example, HR sslvpn web mode access.
l. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
m. Choose an Outgoing Interface. In this example, port1.
n. Set the Source to all and group to HR_group.
o. In this example, the Destination is the internal protected subnet HR_subnet.
p. Set Schedule to always, Service to ALL, and Action to Accept.
q. Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
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next
end
config firewall address
edit "QA_subnet"
set subnet 192.168.1.0 255.255.255.0
next
edit "HR_subnet"
set subnet 10.1.100.0 255.255.255.0
next
end

3. Configure user and user group.
config user local
edit "qa_user1"
set type password
set passwd your-password
next
end
config user group
edit "QA_group"
set member "qa_user1"
next
end
config user local
edit "hr_user1"
set type password
set passwd your-password
next
end
config user group
edit "HR_group"
set member "hr_user1"
next
end

4. Configure SSL VPN web portal.
config vpn ssl web portal
edit "qa-tunnel"
set tunnel-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling enable
set split-tunneling-routing-address "QA_subnet"
next
end
config vpn ssl web portal
edit "hr-web"
set web-mode enable
next
end

5. Configure SSL VPN realms.
Using the GUI is the easiest way to configure SSL VPN realms.
a. Go to System > Feature Visibility to enable SSL-VPN Realms.
b. Go to VPN > SSL-VPN Realms to create realms for qa and hr.
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6. Configure SSL VPN settings.
config vpn ssl settings
set servercert "Fortinet_Factory"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set tunnel-ipv6-pools "SSLVPN_TUNNEL_IPv6_ADDR1"
set source-interface "wan1"
set source-address "all"
set source-address6 "all"
set default-portal "full-access"
config authentication-rule
edit 1
set groups "QA_group"
set portal "qa-tunnel"
set realm qa
next
edit 2
set groups "HR_group"
set portal "hr-web"
set realm hr
next
end

7. Configure two SSL VPN firewall policies to allow remote QA user to access internal QA network and HR user to
access HR network.
config firewall policy
edit 1
set name "QA sslvnpn tunnel access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "QA_subnet"
set groups “QA_group”
set action accept
set schedule "always"
set service "ALL"
next
edit 2
set name "HR sslvpn web access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "HR_subnet"
set groups “HR_group”
set action accept
set schedule "always"
set service "ALL"
next
end

To see the results for QA user:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access.
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3. Add a new connection.
l Set VPN Type to SSL VPN.
l Set Remote Gateway to https://172.20.120.123:10443/qa..
4. Select Customize Port and set it to 10443.
5. Save your settings.
6. Use the credentials you've set up to connect to the SSL VPN tunnel.
If the user's computer has antivirus software, a connection is established; otherwise FortiClient shows a compliance
warning.
7. After connection, traffic to subnet 192.168.1.0 goes through the tunnel.
8. In FGT, go to VPN > Monitor > SSL-VPN Monitor to verify the list of SSL users.
9. In FGT, go to Log & Report > Traffic Log > Forward Traffic and view the details of the traffic.

To see the results for HR user:
1. In a web browser, log into the portal https://172.20.120.123:10443/hr using the credentials you've set up.
2. Go to VPN > Monitor > SSL-VPN Monitor to verify the list of SSL users.
3. Go to Log & Report > Traffic Log > Forward Traffic and view the details of the traffic.

SSL VPN authentication
The following topics provide instructions on configuring SSL VPN authentication:
l
l
l
l
l
l
l
l

SSL VPN with certificate authentication on page 1111
SSL VPN with LDAP-integrated certificate authentication on page 1116
SSL VPN with FortiToken mobile push authentication on page 1122
SSL VPN with RADIUS on FortiAuthenticator on page 1126
SSL VPN with RADIUS and FortiToken mobile push on FortiAuthenticator on page 1130
SSL VPN with local user password policy on page 1135
SSL VPN with RADIUS password renew on FortiAuthenticator on page 1140
SSL VPN with LDAP user password renew on page 1144

SSL VPN with certificate authentication
This is an example configuration of SSL VPN that requires users to authenticate using a client certificate. In this
example, the server and client certificates are signed by the same Certificate Authority (CA).
Self-signed certificates are provided by default to simplify initial installation and testing. It is
HIGHLY recommended that you acquire a signed certificate for your installation.
Continuing to use these certificates can result in your connection being compromised, allowing
attackers to steal your information, such as credit card details.
For more information, please review the Use a non-factory SSL certificate for the SSL VPN
portal on page 1093 and learn how to Purchase and import a signed SSL certificate on page
560.
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Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Install the server certificate. The server certificate is used for authentication and for encrypting SSL VPN traffic.
a. Go to System > Feature Visibility and ensure Certificates is enabled.
b. Go to System > Certificates and select Import > Local Certificate.
l Set Type to Certificate.
l Choose the Certificate file and the Key file for your certificate, and enter the Password.
l If required, you can change the Certificate Name.
The server certificate now appears in the list of Certificates.
3. Install the CA certificate.
The CA certificate is the certificate that signed both the server certificate and the user certificate. In this example, it
is used to authenticate SSL VPN users.
a. Go to System > Certificates and select Import > CA Certificate.
b. Select Local PC and then select the certificate file.
The CA certificate now appears in the list of External CA Certificates. In this example, it is called CA_Cert_1.
4. Configure PKI users and a user group.
To use certificate authentication, use the CLI to create PKI users.
config user peer
edit pki01
set ca CA_Cert_1
set subject User01
next
end

Ensure that the subject matches the name of the user certificate. In this example, User01.
When you have create a PKI user, a new menu is added to the GUI.
a. Go to User & Device > PKI to see the new user.
b. Edit the user account and expand Two-factor authentication.
c. Enable Require two-factor authentication and set a password for the account.
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d. Go to User & Device > User > User Groups and create a group sslvpngroup.
e. Add the PKI user pki01 to the group.
5. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to edit the full-access portal.
This portal supports both web and tunnel mode.
b. Disable Enable Split Tunneling so that all SSL VPN traffic goes through the FortiGate.
6. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. Select the Listen on Interface(s), in this example, wan1.
c. Set Listen on Port to 10443.
d. Set Server Certificate to the authentication certificate.
e. Enable Require Client Certificate.
f. Under Authentication/Portal Mapping, set default Portal web-access for All Other Users/Groups.
g. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal full-access.
7. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name. In this example, sslvpn certificate auth.
c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Set the Source Address to all and Source User to sslvpngroup.
e. Set the Outgoing Interface to the local network interface so that the remote user can access the internal
network. In this example, port1.
f. Set Destination Address to the internal protected subnet 192.168.1.0.
g. Set Schedule to always, Service to ALL, and Action to Accept.
h. Enable NAT.
i. Configure any remaining firewall and security options as desired.
j. Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet., then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end
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3. Install the CA certificate.
The server certificate is used for encrypting SSL VPN traffic and will be used for authentication. It is easier to install
the server certificate from GUI. However, CLI can import a p12 certificate from a tftp server.
If you want to import a p12 certificate, put the certificate server_certificate.p12 on your tftp server, then run following
command on the FortiGate.
execute vpn certificate local import tftp server_certificate.p12 <your tftp_server> p12
<your password for PKCS12 file>

To check server certificate is installed:
show vpn certificate local server_certificate

4. Install the CA certificate.
The CA certificate is the certificate that signed both the server certificate and the user certificate. In this example, it
is used to authenticate SSL VPN users.
It is easier to install the server certificate from GUI. However, CLI can import a CA certificates from a tftp server.
If you want to import a CA certificate, put the CA certificate on your tftp server, then run following command on the
FortiGate.
execute vpn certificate ca import tftp <your CA certificate name> <your tftp server>

To check that a new CA certificate is installed:
show vpn certificate ca

5. Configure PKI users and a user group.
config user peer
edit pki01
set ca CA_Cert_1
set subject User01
set two-factor enable
set passwd <your-password>
end
config user group
edit "sslvpngroup"
set member "pki01"
next
end

6. Configure SSL VPN web portal.
config vpn ssl web portal
edit "full-access"
set tunnel-mode enable
set web-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling disable
next
end

7. Configure SSL VPN settings.
config vpn ssl settings
set servercert "server_certificate"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set source-interface "wan1"
set source-address "all"
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set default-portal "web-access"
set reqclientcert enable
config authentication-rule
edit 1
set groups "sslvpngroup"
set portal "full-access"
next
end
end

8. Configure one SSL VPN firewall policy to allow remote user to access the internal network.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “sslvpngroup”
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

Sample installation
To use the user certificate, you must first install it on the user’s PC. When the user tries to authenticate, the user
certificate is checked against the CA certificate to verify that they match.
Every user should have a unique user certificate. This allows you to distinguish each user and revoke a specific user’s
certificate, such as if a user no longer has VPN access.

To install the user certificate on Windows 7, 8, and 10:
1. Double-click the certificate file to open the Import Wizard.
2. Use the Import Wizard to import the certificate into the Personal store of the current user.

To install the user certificate on Mac OS X:
1. Open the certificate file, to open Keychain Access.
2. Double-click the certificate.
3. Expand Trust and select Always Trust.

To see the results of tunnel connection:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access > Configure VPN.
3. Add a new connection.
l Set VPN Type to SSL VPN.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
4. Select Customize Port and set it to 10443.
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5. Enable Client Certificate and select the authentication certificate.
6. Save your settings.
7. Use the credentials you've set up to connect to the SSL VPN tunnel.
If the certificate is correct, you can connect.

To see the results of web portal:
1. In a web browser, log into the portal http://172.20.120.123:10443.
A message requests a certificate for authentication.
2. Select the user certificate.
3. Enter your user credentials.
If the certificate is correct, you can connect to the SSL VPN web portal.

To check the SSL VPN connection using the GUI:
1. Go to VPN > Monitor > SSL-VPN Monitor to verify the list of SSL users.
2. Go to Log & Report > VPN Events and view the details for the SSL connection log.

To check the SSL VPN connection using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
Auth Type
0
pki01,cn=User01
1
pki01,cn=User01

Timeout
1(1)
1(1)

From
229
291

SSL VPN sessions:
Index
User
Source IP
0
pki01,cn=User01

Duration
10.1.100.254

I/O Bytes
Tunnel/Dest IP
9
22099/43228
10.212.134.200

HTTP in/out
10.1.100.254
10.1.100.254

HTTPS in/out
0/0
0/0
0/0
0/0

SSL VPN with LDAP-integrated certificate authentication
This is a sample configuration of SSL VPN that requires users to authenticate using a certificate with LDAP
UserPrincipalName checking.
This sample uses Windows 2012R2 Active Directory acting as both the user certificate issuer, the certificate authority,
and the LDAP server.
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Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.
In this sample, the User Principal Name is included in the subject name of the issued certificate. This is the user field we
use to search LDAP in the connection attempt.
To use the user certificate, you must first install it on the user’s PC. When the user tries to authenticate, the user
certificate is checked against the CA certificate to verify that they match.
Every user should have a unique user certificate. This allows you to distinguish each user and revoke a specific user’s
certificate, such as if a user no longer has VPN access.

To install the server certificate:
The server certificate is used for authentication and for encrypting SSL VPN traffic.
1. Go to System > Feature Visibility and ensure Certificates is enabled.
2. Go to System > Certificates and select Import > Local Certificate.
l Set Type to Certificate.
l Choose the Certificate file and the Key file for your certificate, and enter the Password.
l If desired, you can change the Certificate Name.
The server certificate now appears in the list of Certificates.

To install the CA certificate:
The CA certificate is the certificate that signed both the server certificate and the user certificate. In this example, it is
used to authenticate SSL VPN users.
1. Go to System > Certificates and select Import > CA Certificate.
2. Select Local PC and then select the certificate file.
The CA certificate now appears in the list of External CA Certificates. In this example, it is called CA_Cert_1.
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To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Configure the LDAP server.
a. Go to User & Device > LDAP Servers > Create New.
l Specify Name and Server IP/Name.
l Set Distinguished Name to dc=fortinet-fsso,dc=com.
l Set Bind Type to Regular.
l Set Username to cn=admin,ou=testing,dc=fortinet-fsso,dc=com.
l Set Password.
3. Configure PKI users and a user group.
To use certificate authentication, use the CLI to create PKI users.
config user peer
edit user1
set ca CA_Cert_1
set ldap-server "ldap-AD"
set ldap-mode principal-name
end

When you have create a PKI user, a new menu is added to the GUI.
a.
b.
c.
d.

Go to User & Device > PKI to see the new user.
Go to User & Device > User > User Groups and create a group sslvpn-group.
Add the PKI peer object you created as a local member of the group.
Add a remote group on the LDAP server and select the group of interest.
You need these users to be members using the LDAP browser window.

4. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to edit the full-access portal.
This portal supports both web and tunnel mode.
b. Disable Enable Split Tunneling so that all SSL VPN traffic goes through the FortiGate.
5. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. Select the Listen on Interface(s), in this example, wan1.
c. Set Listen on Port to 10443.
d. Set Server Certificate to the authentication certificate.
e. Enable Require Client Certificate.
f. Under Authentication/Portal Mapping, set default Portal web-access for All Other Users/Groups.
g. Create new Authentication/Portal Mapping for group sslvpn-group mapping portal full-access.
6. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name. In this example, sslvpn certificate auth.
c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Set the Source Address to all and Source User to sslvpn-group.
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e. Set the Outgoing Interface to the local network interface so that the remote user can access the internal
network. In this example, port1.
f. Set Destination Address to the internal protected subnet 192.168.1.0.
g. Set Schedule to always, Service to ALL, and Action to Accept.
h. Enable NAT.
i. Configure any remaining firewall and security options as desired.
j. Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Configure the LDAP server.
config user ldap
edit "ldap-AD"
set server "172.18.60.206"
set cnid "cn"
set dn "dc=fortinet-fsso,dc=com"
set type regular
set username "cn=admin,ou=testing,dc=fortinet-fsso,dc=com"
set password ldap-server-password
next
end

4. Configure PKI users and a user group.
config user peer
edit user1
set ca CA_Cert_1
set ldap-server "ldap-AD"
set ldap-mode principal-name
end
config user group
edit "sslvpn-group"
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set member "ldap-AD" "user1"
config match
edit 1
set server-name "ldap-AD"
set group-name "CN=group3,OU=Testing,DC=Fortinet-FSSO,DC=COM"
next
end
next
end

5. Configure SSL VPN web portal.
config vpn ssl web portal
edit "full-access"
set tunnel-mode enable
set web-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling disable
next
end

6. Configure SSL VPN settings.
config vpn ssl settings
set servercert "server_certificate"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set source-interface "wan1"
set source-address "all"
set default-portal "web-access"
set reqclientcert enable
config authentication-rule
edit 1
set groups "sslvpn-group"
set portal "full-access"
next
end

7. Configure one SSL VPN firewall policy to allow remote user to access the internal network.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “sslvpn-group”
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

To see the results of tunnel connection:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access > Configure VPN.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1120

VPN
3. Add a new connection.
l Set the connection name.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Enable Client Certificate and select the authentication certificate.
6. Save your settings.
Connecting to the VPN only requires the user's certificate. It does not require username or password.

To see the results of web portal:
1. In a web browser, log into the portal http://172.20.120.123:10443.
A message requests a certificate for authentication.
2. Select the user certificate.
You can connect to the SSL VPN web portal.

To check the SSL VPN connection using the GUI:
1. Go to VPN > Monitor > SSL-VPN Monitor to verify the list of SSL users.
2. Go to Log & Report > VPN Events to view the details of the SSL VPN connection event log.
3. Go to Log & Report > Forward Traffic to view the details of the SSL VPN traffic.

To check the SSL VPN connection using the CLI:
Below is a sample output of diagnose debug application fnbamd -1 while the user connects. This is a
shortened output sample of a few locations to show the important parts. This sample shows lookups to find the group
memberships (three groups total) of the user and that the correct group being found results in a match.
[1148] fnbamd_ldap_recv-Response len: 16, svr: 172.18.60.206
[829] fnbamd_ldap_parse_response-Got one MESSAGE. ID:4, type:search-result
[864] fnbamd_ldap_parse_response-ret=0
[1386] __fnbamd_ldap_primary_grp_next-Auth accepted
[910] __ldap_rxtx-Change state to 'Done'
[843] __ldap_rxtx-state 23(Done)
[925] fnbamd_ldap_send-sending 7 bytes to 172.18.60.206
[937] fnbamd_ldap_send-Request is sent. ID 5
[753] __ldap_stop-svr 'ldap-AD'
[53] ldap_dn_list_del_all-Del CN=test3,OU=Testing,DC=Fortinet-FSSO,DC=COM
[399] ldap_copy_grp_list-copied CN=group3,OU=Testing,DC=Fortinet-FSSO,DC=COM
[399] ldap_copy_grp_list-copied CN=Domain Users,CN=Users,DC=Fortinet-FSSO,DC=COM
[2088] fnbamd_auth_cert_check-Matching group 'sslvpn-group'
[2007] __match_ldap_group-Matching server 'ldap-AD' - 'ldap-AD'
[2015] __match_ldap_group-Matching group 'CN=group3,OU=Testing,DC=Fortinet-FSSO,DC=COM' 'CN=group3,OU=Testing,DC=Fortinet-FSSO,DC=COM'
[2091] fnbamd_auth_cert_check-Group 'sslvpn-group' matched
[2120] fnbamd_auth_cert_result-Result for ldap svr[0] 'ldap-AD' is SUCCESS
[2126] fnbamd_auth_cert_result-matched user 'test3', matched group 'sslvpn-group'

You can also use diagnose firewall auth list to validate that a firewall user entry exists for the SSL VPN user
and is part of the right groups.
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SSL VPN with FortiToken mobile push authentication
This is a sample configuration of SSL VPN that uses FortiToken mobile push two-factor authentication. If you enable
push notifications, users can accept or deny the authentication request.

Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Register FortiGate for FortiCare Support.
To add or download a mobile token on FortiGate, FortiGate must be registered for FortiCare Support. If your
FortiGate is registered, skip this step.
a. Go to Dashboard > Licenses.
b. Hover the pointer on FortiCare Support to check if FortiCare registered. If not, click it and select Register.
3. Add FortiToken mobile to FortiGate.
If your FortiGate has FortiToken installed, skip this step.
a. Go to User & Device > FortiTokens and click Create New.
b. Select Mobile Token and type in Activation Code.
c. Every FortiGate has two free mobile tokens. Go to User & Device > FortiTokens and click Import Free Trial
Tokens.
4. Enable FortiToken mobile push.
To use FTM-push authentication, use CLI to enable FTM-Push on the FortiGate.
a. Ensure server-ip is reachable from the Internet and enter the following CLI commands:
config system ftm-push
set server-ip 172.20.120.123
set status enable
end

b. Go to Network > Interfaces.
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c. Edit the wan1 interface.
d. Under Administrative Access > IPv4, select FTM.
e. Click OK.
5. Configure user and user group.
a. Go to User & Device > User Definition to create a local user sslvpnuser1.
b. Enter the user's Email Address.
c. Enable Two-factor Authentication and select one mobile Token from the list,
d. Enable Send Activation Code and select Email.
e. Click Next and click Submit.
f. Go to User & Device > User Groups to create a group sslvpngroup with the member sslvpnuser1.
6. Activate the mobile token.
a. When the user sslvpnuser1 is created, an email is sent to the user's email address. Follow the instructions to
install your FortiToken mobile application on your device and activate your token.
7. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to edit the full-access portal.
This portal supports both web and tunnel mode.
b. Disable Enable Split Tunneling so that all SSL VPN traffic goes through the FortiGate.
8. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. Select the Listen on Interface(s), in this example, wan1.
c. Set Listen on Port to 10443.
d. Set Server Certificate to the authentication certificate.
e. Under Authentication/Portal Mapping, set default Portal web-access for All Other Users/Groups.
f. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal full-access.
9. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name. In this example, sslvpn certificate auth.
c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Set the Source Address to all and Source User to sslvpngroup.
e. Set the Outgoing Interface to the local network interface so that the remote user can access the internal
network. In this example, port1.
f. Set Destination Address to the internal protected subnet 192.168.1.0.
g. Set Schedule to always, Service to ALL, and Action to Accept.
h. Enable NAT.
i. Configure any remaining firewall and security options as desired.
j. Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end
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2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Register FortiGate for FortiCare Support.
To add or download a mobile token on FortiGate, FortiGate must be registered for FortiCare Support. If your
FortiGate is registered, skip this step.
diagnose forticare direct-registration product-registration -a "your account@xxx.com" -p
"your password" -T "Your Country/Region" -R "Your Reseller" -e 1

4. Add FortiToken mobile to FortiGate.
a. If your FortiGate has FortiToken installed, skip this step.
execute fortitoken-mobile import <your FTM code>

b. Every FortiGate has two free mobile Tokens. You can download the free token.
execute fortitoken-mobile import 0000-0000-0000-0000-0000

5. Enable FortiToken mobile push.
a. To use FTM-push authentication, ensure server-ip is reachable from the Internet and enable FTM-push in
the FortiGate.
config system ftm-push
set server-ip 172.20.120.123
set status enable
end

b. Enable FTM service on WAN interface.
config system interface
edit "wan1"
append allowaccess ftm
next
end

6. Configure user and user group.
config user local
edit "sslvpnuser1"
set type password
set two-factor fortitoken
set fortitoken <select mobile token for the option list>
set email-to <user's email address>
set passwd <user's password>
next
end
config user group
edit "sslvpngroup"
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set member "sslvpnuser1"
next
end

7. Activate the mobile token.
a. When the user sslvpnuser1 is created, an email is sent to the user's email address. Follow the instructions to
install your FortiToken mobile application on your device and activate your token.
8. Configure SSL VPN web portal.
config vpn ssl web portal
edit "full-access"
set tunnel-mode enable
set web-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling disable
next
end

9. Configure SSL VPN settings.
config vpn ssl settings
set servercert "server_certificate"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set source-interface "wan1"
set source-address "all"
set default-portal "web-access"
config authentication-rule
edit 1
set groups "sslvpngroup"
set portal "full-access"
next
end

10. Configure one SSL VPN firewall policy to allow remote user to access the internal network.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “sslvpngroup”
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

To see the results of web portal:
1. From a remote device, use a web browser to log into the SSL VPN web portal http://172.20.120.123:10443.
2. Log in using the sslvpnuser1 credentials.
The FortiGate pushes a login request notification through the FortiToken mobile application.
3. Check your mobile device and select Approve.
When the authentication is approved, sslvpnuser1 is logged into the SSL VPN portal.
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4. On the FortiGate, go to Monitor > SSL-VPN Monitor to confirm the user connection.

To see the results of tunnel connection:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access > Configure VPN.
3. Add a new connection.
l Set the connection name.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Save your settings.
6. Log in using the sslvpnuser1 credentials and click FTM Push.
The FortiGate pushes a login request notification through the FortiToken mobile application.
7. Check your mobile device and select Approve.
When the authentication is approved, sslvpnuser1 is logged into the SSL VPN tunnel.

To check the SSL VPN connection using the GUI:
1. Go to VPN > Monitor > SSL-VPN Monitor to verify the user’s connection.
2. Go to Log & Report > Forward Traffic to view the details of the SSL VPN traffic.

To check the web portal login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
0
sslvpnuser1

Auth Type
1(1)

SSL VPN sessions:
Index
User
Source IP

Timeout
229

From
10.1.100.254

Duration

I/O Bytes

HTTP in/out
0/0

HTTPS in/out
0/0

Tunnel/Dest IP

To check the tunnel login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
0
sslvpnuser1

Auth Type
1(1)

SSL VPN sessions:
Index
User
0
sslvpnuser1

Source IP
10.1.100.254

Timeout
291

From
10.1.100.254

Duration
9

I/O Bytes
22099/43228

HTTP in/out
0/0

HTTPS in/out
0/0

Tunnel/Dest IP
10.212.134.200

SSL VPN with RADIUS on FortiAuthenticator
This is a sample configuration of SSL VPN that uses FortiAuthenticator as a RADIUS authentication server.
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Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure FortiAuthenticator using the GUI:
1. Create a user on the FortiAuthenticator.
a. On the FortiAuthenticator, go to Authentication > User Management > Local Users to create a user
sslvpnuser1.
b. Enable Allow RADIUS authentication and click OK to access additional settings.
c. Go to Authentication > User Management > User Groups to create a group sslvpngroup.
d. Add sslvpnuser1 to the group by moving the user from Available users to Selected users.
2. Create the RADIUS client (FortiGate) on the FortiAuthenticator.
a. On the FortiAuthenticator, go to Authentication > RADIUS Service > Clients to add the FortiGate as a RADIUS
client OfficeServer).
b. Enter the FortiGate IP address and set a Secret.
The secret is a pre-shared secure password that the FortiGate uses to authenticate to the FortiAuthenticator.
c. Set Realms to local | Local users.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Create a RADIUS user and user group .
a. On the FortiGate, go to User & Device > RADIUS Servers to create a user to connect to the RADIUS server
(FortiAuthenticator).
b. For Name, use FAC-RADIUS.
c. Enter the IP address of the FortiAuthenticator, and enter the Secret created above.
d. Click Test Connectivity to ensure you can connect to the RADIUS server.
e. Select Test User Credentials and enter the credentials for sslvpnuser1.
The FortiGate can now connect to the FortiAuthenticator as the RADIUS client.
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f. Go to User & Device > User Groups and click Create New to map authenticated remote users to a user group
on the FortiGate.
g. For Name, use SSLVPNGroup.
h. In Remote Groups, click Add.
i. In the Remote Server dropdown list, select FAC-RADIUS.
j. Leave the Groups field blank.
3. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to edit the full-access portal.
This portal supports both web and tunnel mode.
b. Disable Enable Split Tunneling so that all SSL VPN traffic goes through the FortiGate.
4. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. Select the Listen on Interface(s), in this example, wan1.
c. Set Listen on Port to 10443.
d. Set Server Certificate to the authentication certificate.
e. Under Authentication/Portal Mapping, set default Portal web-access for All Other Users/Groups.
f. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal full-access.
5. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name. In this example, sslvpn certificate auth.
c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Set the Source Address to all and Source User to sslvpngroup.
e. Set the Outgoing Interface to the local network interface so that the remote user can access the internal
network. In this example: port1.
f. Set Destination Address to the internal protected subnet 192.168.1.0.
g. Set Schedule to always, Service to ALL, and Action to Accept.
h. Enable NAT.
i. Configure any remaining firewall and security options as desired.
j. Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
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edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Create a RADIUS user and user group.
config user radius
edit "FAC-RADIUS"
set server "172.20.120.161"
set secret <FAC client secret>
next
end
config user group
edit "sslvpngroup"
set member "FAC-RADIUS"
next
end

4. Configure SSL VPN web portal.
config vpn ssl web portal
edit "full-access"
set tunnel-mode enable
set web-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling disable
next
end

5. Configure SSL VPN settings.
config vpn ssl settings
set servercert "server_certificate"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set source-interface "wan1"
set source-address "all"
set default-portal "web-access"
config authentication-rule
edit 1
set groups "sslvpngroup"
set portal "full-access"
next
end

6. Configure one SSL VPN firewall policy to allow remote user to access the internal network.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “sslvpngroup”
set action accept
set schedule "always"
set service "ALL"
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set nat enable
next
end

To see the results of web portal:
1. From a remote device, use a web browser to log into the SSL VPN web portal http://172.20.120.123:10443.
2. Log in using the sslvpnuser1 credentials.
3. On the FortiGate, go to Monitor > SSL-VPN Monitor to confirm the user connection.

To see the results of tunnel connection:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access > Configure VPN.
3. Add a new connection.
l Set the connection name.
l Set Remote Gateway to 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Save your settings.
6. Log in using the sslvpnuser1 credentials and check that you are logged into the SSL VPN tunnel.

To check the SSL VPN connection using the GUI:
1. Go to VPN > Monitor > SSL-VPN Monitor to verify the user’s connection.
2. Go to Log & Report > Forward Traffic to view the details of the SSL VPN traffic.

To check the web portal login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
0
sslvpnuser1

Auth Type
1(1)

SSL VPN sessions:
Index
User
Source IP

Timeout
229

Duration

From
10.1.100.254

HTTP in/out
0/0

I/O Bytes

HTTPS in/out
0/0

Tunnel/Dest IP

To check the tunnel login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
0
sslvpnuser1

Auth Type
1(1)

SSL VPN sessions:
Index
User
0
sslvpnuser1

Source IP
10.1.100.254

Timeout
291

Duration
9

From
10.1.100.254

HTTP in/out
0/0

I/O Bytes
22099/43228

HTTPS in/out
0/0

Tunnel/Dest IP
10.212.134.200

SSL VPN with RADIUS and FortiToken mobile push on FortiAuthenticator
This is a sample configuration of SSL VPN that uses FortiAuthenticator as a RADIUS authentication server and
FortiToken mobile push two-factor authentication. If you enable push notifications, users can accept or deny the
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authentication request.

Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure FortiAuthenticator using the GUI:
1. Add a FortiToken mobile license on the FortiAuthenticator.
a. On the FortiAuthenticator, go to Authentication > User Management > FortiTokens.
b. Click Create New.
c. Set Token type to FortiToken Mobile and enter the FortiToken Activation codes.
2. Create the RADIUS client (FortiGate) on the FortiAuthenticator.
a. On the FortiAuthenticator, go to Authentication > RADIUS Service > Clients to add the FortiGate as a RADIUS
client OfficeServer).
b. Enter the FortiGate IP address and set a Secret.
The secret is a pre-shared secure password that the FortiGate uses to authenticate to the FortiAuthenticator.
c. Set Authentication method to Enforce two-factor authentication.
d. Select Enable FortiToken Mobile push notifications authentication.
e. Set Realms to local | Local users.
3. Create a user and assign FortiToken mobile to the user on the FortiAuthenticator.
a. On the FortiAuthenticator, go to Authentication > User Management > Local Users to create a user
sslvpnuser1.
b. Enable Allow RADIUS authentication and click OK to access additional settings.
c. Enable Token-based authentication and select to deliver the token code by FortiToken.
d. Select the FortiToken added from the FortiToken Mobile dropdown menu.
e. Set Delivery method to Email and fill in the User Information section.
f. Go to Authentication > User Management > User Groups to create a group sslvpngroup.
g. Add sslvpnuser1 to the group by moving the user from Available users to Selected users.
4. Install the FortiToken mobile application on your roid or iOS smartphone.
The FortiAuthenticator sends the FortiToken mobile activation to the user’s email address.
5. Activate the FortiToken mobile through the FortiToken mobile application by entering the activation code or
scanning the QR code.
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To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Create a RADIUS user and user group.
a. On the FortiGate, go to User & Device > RADIUS Servers to create a user to connect to the RADIUS server
(FortiAuthenticator).
b. For Name, use FAC-RADIUS.
c. Enter the IP address of the FortiAuthenticator, and enter the Secret created above.
d. Click Test Connectivity to ensure you can connect to the RADIUS server.
e. Select Test User Credentials and enter the credentials for sslvpnuser1.
The FortiGate can now connect to the FortiAuthenticator as the RADIUS client.
f. Go to User & Device > User Groups and click Create New to map authenticated remote users to a user group
on the FortiGate.
g. For Name, use SSLVPNGroup.
h. In Remote Groups, click Add.
i. In the Remote Server dropdown list, select FAC-RADIUS.
j. Leave the Groups field blank.
3. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to edit the full-access portal.
This portal supports both web and tunnel mode.
b. Disable Enable Split Tunneling so that all SSL VPN traffic goes through the FortiGate.
4. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. Select the Listen on Interface(s), in this example, wan1.
c. Set Listen on Port to 10443.
d. Set Server Certificate to the authentication certificate.
e. Under Authentication/Portal Mapping, set default Portal web-access for All Other Users/Groups.
f. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal full-access.
5. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name. In this example, sslvpn certificate auth.
c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Set the Source Address to all and Source User to sslvpngroup.
e. Set the Outgoing Interface to the local network interface so that the remote user can access the internal
network. In this example: port1.
f. Set Destination Address to the internal protected subnet 192.168.1.0.
g. Set Schedule to always, Service to ALL, and Action to Accept.
h. Enable NAT.
i. Configure any remaining firewall and security options as desired.
j. Click OK.
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To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Create a RADIUS user and user group.
config user radius
edit "FAC-RADIUS"
set server "172.20.120.161"
set secret <FAC client secret>
next
end
config user group
edit "sslvpngroup"
set member "FAC-RADIUS"
next
end

4. Configure SSL VPN web portal.
config vpn ssl web portal
edit "full-access"
set tunnel-mode enable
set web-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling disable
next
end

5. Configure SSL VPN settings.
config vpn ssl settings
set servercert "server_certificate"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set source-interface "wan1"
set source-address "all"
set default-portal "web-access"
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config authentication-rule
edit 1
set groups "sslvpngroup"
set portal "full-access"
next
end

6. Configure one SSL VPN firewall policy to allow remote user to access the internal network.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “sslvpngroup”
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

To see the results of web portal:
1. From a remote device, use a web browser to log into the SSL VPN web portal http://172.20.120.123:10443.
2. Log in using the sslvpnuser1 credentials.
The FortiAuthenticator pushes a login request notification through the FortiToken Mobile application.
3. Check your mobile device and select Approve.
When the authentication is approved, sslvpnuser1 is logged into the SSL VPN portal.
4. On the FortiGate, go to Monitor > SSL-VPN Monitor to confirm the user connection.

To see the results of tunnel connection:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access > Configure VPN.
3. Add a new connection.
l Set the connection name.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example: 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Save your settings.
6. Log in using the sslvpnuser1 credentials and click FTM Push.
The FortiAuthenticator pushes a login request notification through the FortiToken Mobile application.
7. Check your mobile device and select Approve.
When the authentication is approved, sslvpnuser1 is logged into the SSL VPN tunnel.

To check the SSL VPN connection using the GUI:
1. Go to VPN > Monitor > SSL-VPN Monitor to verify the user’s connection.
2. Go to Log & Report > Forward Traffic to view the details of the SSL VPN traffic.
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To check the web portal login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
0
sslvpnuser1

Auth Type
1(1)

SSL VPN sessions:
Index
User
Source IP

Timeout
229

From
10.1.100.254

Duration

HTTP in/out
0/0

I/O Bytes

HTTPS in/out
0/0

Tunnel/Dest IP

To check the tunnel login on CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
0
sslvpnuser1

Auth Type
1(1)

SSL VPN sessions:
Index
User
0
sslvpnuser1

Source IP
10.1.100.254

Timeout
291

Duration
9

From
10.1.100.254

HTTP in/out
0/0

I/O Bytes
22099/43228

HTTPS in/out
0/0

Tunnel/Dest IP
10.212.134.200

SSL VPN with local user password policy
This is a sample configuration of SSL VPN for users with passwords that expire after two days. Users are warned after
one day about the password expiring. The password policy can be applied to any local user password. The password
policy cannot be applied to a user group or a local remote user such as LDAP/RADIUS/TACACS+.
In FortiOS 6.2, users are warned after one day about the password expiring and have one day to renew it. If the
password expires, the user cannot renew the password and must contact the administrator for assistance.
In FortiOS 6.0/5.6, users are warned after one day about the password expiring and have to renew it. If the password
expires, the user can still renew the password.

Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.
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To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Configure user and user group.
a. Go to User & Device > User Definition to create a local user.
b. Go to User & Device > User Groups to create a user group and add that local user to it.
3. Configure and assign the password policy using the CLI.
a. Configure a password policy that includes an expiry date and warning time. The default start time for the
password is the time the user was created.
config user password-policy
edit "pwpolicy1"
set expire-days 2
set warn-days 1
next
end

b. Assign the password policy to the user you just created.
config user local
edit "sslvpnuser1"
set type password
set passwd-policy "pwpolicy1"
next
end

4. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to edit the full-access portal.
This portal supports both web and tunnel mode.
b. Disable Enable Split Tunneling so that all SSL VPN traffic goes through the FortiGate.
5. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. Select the Listen on Interface(s), in this example, wan1.
c. Set Listen on Port to 10443.
d. Set Server Certificate to the authentication certificate.
e. Under Authentication/Portal Mapping, set default Portal web-access for All Other Users/Groups.
f. Create new Authentication/Portal Mapping for group sslvpngroup mapping portal full-access.
6. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name. In this example, sslvpn certificate auth.
c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Set the Source Address to all and Source User to sslvpngroup.
e. Set the Outgoing Interface to the local network interface so that the remote user can access the internal
network. In this example, port1.
f. Set Destination Address to the internal protected subnet 192.168.1.0.
g. Set Schedule to always, Service to ALL, and Action to Accept.
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h. Enable NAT.
i. Configure any remaining firewall and security options as desired.
j. Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Configure user and user group.
config user local
edit "sslvpnuser1"
set type password
set passwd your-password
next
end
config user group
edit "sslvpngroup"
set member "vpnuser1"
next
end

4. Configure and assign the password policy.
a. Configure a password policy that includes an expiry date and warning time. The default start time for the
password is the time the user was created.
config user password-policy
edit "pwpolicy1"
set expire-days 2
set warn-days 1
next
end

b. Assign the password policy to the user you just created.
config user local
edit "sslvpnuser1"
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set type password
set passwd-policy "pwpolicy1"
next
end

5. Configure SSL VPN web portal.
config vpn ssl web portal
edit "full-access"
set tunnel-mode enable
set web-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling disable
next
end

6. Configure SSL VPN settings.
config vpn ssl settings
set servercert "server_certificate"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set source-interface "wan1"
set source-address "all"
set default-portal "web-access"
config authentication-rule
edit 1
set groups "sslvpngroup"
set portal "full-access"
next
end

7. Configure one SSL VPN firewall policy to allow remote user to access the internal network.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “sslvpngroup”
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

To see the results of web portal:
1. From a remote device, use a web browser to log into the SSL VPN web portal http://172.20.120.123:10443.
2. Log in using the sslvpnuser1 credentials.
When the warning time is reached, the user is prompted to enter a new password.
In FortiOS 6.2, when the password expires, the user cannot renew the password and must contact the
administrator.
In FortiOS 6.0/5.6, when the password expires, the user can still renew the password.
3. On the FortiGate, go to Monitor > SSL-VPN Monitor to confirm the user connection.
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To see the results of tunnel connection:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access > Configure VPN.
3. Add a new connection.
l Set the connection name.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Save your settings.
6. Log in using the sslvpnuser1 credentials.
When the warning time is reached, the user is prompted to enter a new password.

To check the SSL VPN connection using the GUI:
1. Go to VPN > Monitor > SSL-VPN Monitor to verify the user’s connection.
2. Go to Log & Report > Forward Traffic to view the details of the SSL VPN traffic.

To check that login failed due to password expired on GUI:
1. Go to Log & Report > VPN Events to see the SSL VPN alert labeled ssl-login-fail.
2. Click Details to see the log details about the Reason sslvpn_login_password_expired.

To check the web portal login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
0
sslvpnuser1

Auth Type
1(1)

SSL VPN sessions:
Index
User
Source IP

Timeout
229

From
10.1.100.254

Duration

HTTP in/out
0/0

I/O Bytes

HTTPS in/out
0/0

Tunnel/Dest IP

To check the tunnel login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
0
sslvpnuser1

Auth Type
1(1)

SSL VPN sessions:
Index
User
0
sslvpnuser1

Source IP
10.1.100.254

Timeout
291

Duration
9

From
10.1.100.254

I/O Bytes
22099/43228

HTTP in/out
0/0

HTTPS in/out
0/0

Tunnel/Dest IP
10.212.134.200

To check the FortiOS 6.2 login password expired event log:
FG201E4Q17901354 # execute log

filter category event

FG201E4Q17901354 # execute log

filter field subtype vpn

FG201E4Q17901354 # execute log

filter field action ssl-login-fail

FG201E4Q17901354 # execute log

display
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1: date=2019-02-15 time=10:57:56 logid="0101039426" type="event" subtype="vpn" level="alert"
vd="root" eventtime=1550257076 logdesc="SSL VPN login fail" action="ssl-login-fail"
tunneltype="ssl-web" tunnelid=0 remip=10.1.100.254 user="u1" group="g1" dst_host="N/A"
reason="sslvpn_login_password_expired" msg="SSL user failed to logged in"

SSL VPN with RADIUS password renew on FortiAuthenticator
This is a sample configuration of SSL VPN for RADIUS users with Force Password Change on next logon. In this
example, the RADIUS server is a FortiAuthenticator. A user test1 is configured on FortiAuthenticator with Force
password change on next logon.

Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Create a RADIUS user.
a. Go to User & Device > RADIUS Servers to create a user.
b. Set Authentication method to MS-CHAP-v2.
c. Enter the IP/Name and Secret.
d. Click Create.
Password renewal only works with the MS-CHAP-v2 authentication method.
e. To enable the password-renew option, use these CLI commands.
config user radius
edit "fac"
set server "172.20.120.161"
set secret <fac radius password>
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set auth-type ms_chap_v2
set password-renewal enable
next
end

3. Configure user group.
a. Go to User & Device > User Groups to create a user group.
b. For the Name, enter fac-group.
c. In Remote Groups, click Add to add Remote Server you just created.
4. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to edit the full-access portal.
This portal supports both web and tunnel mode.
b. Disable Enable Split Tunneling so that all SSL VPN traffic goes through the FortiGate.
5. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. Select the Listen on Interface(s), in this example, wan1.
c. Set Listen on Port to 10443.
d. Set Server Certificate to the authentication certificate.
e. Under Authentication/Portal Mapping, set default Portal web-access for All Other Users/Groups.
f. Create new Authentication/Portal Mapping for group fac-group mapping portal full-access.
6. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name, in this example, sslvpn certificate auth.
c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Set the Source Address to all and Source User to fac-group.
e. Set the Outgoing Interface to the local network interface so that the remote user can access the internal
network, in this example, port1.
f. Set Destination Address to the internal protected subnet 192.168.1.0.
g. Set Schedule to always, Service to ALL, and Action to Accept.
h. Enable NAT.
i. Configure any remaining firewall and security options as desired.
j. Click OK.

To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1141

VPN

end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Configure the RADIUS server.
config user radius
edit "fac"
set server "172.18.58.107"
set secret <fac radius password>
set auth-type ms_chap_v2
set password-renewal enable
next
end

4. Configure user group.
config user group
edit "fac-group"
set member "fac"
next
end

5. Configure SSL VPN web portal.
config vpn ssl web portal
edit "full-access"
set tunnel-mode enable
set web-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling disable
next
end

6. Configure SSL VPN settings.
config vpn ssl settings
set servercert "server_certificate"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set source-interface "wan1"
set source-address "all"
set default-portal "web-access"
config authentication-rule
edit 1
set groups "fac-group"
set portal "full-access"
next
end

7. Configure one SSL VPN firewall policy to allow remote user to access the internal network.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
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set
set
set
set
set
set

dstaddr "192.168.1.0"
groups “fac-group”
action accept
schedule "always"
service "ALL"
nat enable

next
end

To see the results of web portal:
1. From a remote device, use a web browser to log into the SSL VPN web portal http://172.20.120.123:10443.
2. Log in using the test1 credentials.
Use a user which is configured on FortiAuthenticator with Force password change on next logon.
3. Click Login. You are prompted to enter a new password.
4. Go to VPN > Monitor > SSL-VPN Monitor to verify the user’s connection.

To see the results of tunnel connection:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access > Configure VPN.
3. Add a new connection.
l Set the connection name.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Save your settings.
6. Log in using the test1 credentials.
You are prompted to enter a new password.

To check the SSL VPN connection using the GUI:
1. Go to VPN > Monitor > SSL-VPN Monitor to verify the user’s connection.
2. Go to Log & Report > VPN Events to view the details of the SSL VPN connection event log.
3. Go to Log & Report > Forward Traffic to view the details of the SSL VPN traffic.

To check the web portal login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
Auth Type
0
test1
1(1)
SSL VPN sessions:
Index
User
Source IP

Timeout
229

Duration

From
10.1.100.254

HTTP in/out
0/0

I/O Bytes

HTTPS in/out
0/0

Tunnel/Dest IP

To check the tunnel login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
Auth Type
0
test1
1(1)
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SSL VPN sessions:
Index
User
Source IP
0
test1
10.1.100.254

Duration
9

I/O Bytes
22099/43228

Tunnel/Dest IP
10.212.134.200

SSL VPN with LDAP user password renew
This is a sample configuration of SSL VPN for LDAP users with Force Password Change on next logon. In this example,
the LDAP server is a Windows 2012 AD server. A user ldu1 is configured on Windows 2012 AD server with Force
password change on next logon.
You must have generated and exported a CA certificate from the AD server and then have imported it as an external CA
certificate into the FortiGate.

Sample topology

Sample configuration
WAN interface is the interface connected to ISP. This example shows static mode. You can also use DHCP or PPPoE
mode. The SSL VPN connection is established over the WAN interface.

To configure SSL VPN using the GUI:
1. Configure the interface and firewall address. The port1 interface connects to the internal network.
a. Go to Network > Interfaces and edit the wan1 interface.
b. Set IP/Network Mask to 172.20.120.123/255.255.255.0.
c. Edit port1 interface and set IP/Network Mask to 192.168.1.99/255.255.255.0.
d. Click OK.
e. Go to Firewall & Objects > Address and create an address for internet subnet 192.168.1.0.
2. Import CA certificate into FortiGate.
a. Go to System > Features Visibility and ensure Certificates is enabled.
b. Go to System > Certificates and select Import > CA Certificate.
c. Select Local PC and then select the certificate file.
The CA certificate now appears in the list of External CA Certificates. In this example, it is called CA_Cert_1.
d. If you want, you can use CLI commands to rename the system-generated CA_Cert_1 to be more descriptive:
config vpn certificate ca
rename CA_Cert_1 to LDAPS-CA
end
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3. Configure the LDAP user.
a. Go to User & Device > LDAP Servers > Create New.
l Specify Name and Server IP/Name.
l Specify Common Name Identifier and Distinguished Name.
l Set Bind Type to Regular.
l Specify Username and Password.
l Enable Secure Connection and set Protocol to LDAPS.
l For Certificate, select LDAP server CA LDAPS-CA from the list.
b. To enable the password-renew option, use these CLI commands.
config user ldap
edit "ldaps-server"
set password-expiry-warning enable
set password-renewal enable
next
end

4. Configure user group.
a. Go to User & Device > User Groups to create a user group.
b. Enter a Name.
c. In Remote Groups, click Add to add ldaps-server.
5. Configure SSL VPN web portal.
a. Go to VPN > SSL-VPN Portals to edit the full-access portal.
This portal supports both web and tunnel mode.
b. Disable Enable Split Tunneling so that all SSL VPN traffic goes through the FortiGate.
6. Configure SSL VPN settings.
a. Go to VPN > SSL-VPN Settings.
b. Select the Listen on Interface(s), in this example, wan1.
c. Set Listen on Port to 10443.
d. Set Server Certificate to the authentication certificate.
e. Under Authentication/Portal Mapping, set default Portal web-access for All Other Users/Groups.
f. Create new Authentication/Portal Mapping for group ldaps-group mapping portal full-access.
7. Configure SSL VPN firewall policy.
a. Go to Policy & Objects > IPv4 Policy.
b. Fill in the firewall policy name, in this example, sslvpn certificate auth.
c. Incoming interface must be SSL-VPN tunnel interface(ssl.root).
d. Set the Source Address to all and Source User to ldaps-group.
e. Set the Outgoing Interface to the local network interface so that the remote user can access the internal
network, in this example, port1.
f. Set Destination Address to the internal protected subnet 192.168.1.0.
g. Set Schedule to always, Service to ALL, and Action to Accept.
h. Enable NAT.
i. Configure any remaining firewall and security options as desired.
j. Click OK.
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To configure SSL VPN using the CLI:
1. Configure the interface and firewall address.
config system interface
edit "wan1"
set vdom "root"
set ip 172.20.120.123 255.255.255.0
next
end

2. Configure internal interface and protected subnet, then connect the port1 interface to the internal network.
config system interface
edit "port1"
set vdom "root"
set ip 192.168.1.99 255.255.255.0
next
end
config firewall address
edit "192.168.1.0"
set subnet 192.168.1.0 255.255.255.0
next
end

3. Import CA certificate into FortiGate.
a. Go to System > Features Visibility and ensure Certificates is enabled.
b. Go to System > Certificates and select Import > CA Certificate.
c. Select Local PC and then select the certificate file.
The CA certificate now appears in the list of External CA Certificates. In the example, it is called CA_Cert_1.
d. If you want, you can use CLI commands to rename the system-generated CA_Cert_1 to be more descriptive:
config vpn certificate ca
rename CA_Cert_1 to LDAPS-CA
end

4. Configure the LDAP server.
config user ldap
edit "ldaps-server"
set server "172.20.120.161"
set cnid "cn"
set dn "cn=Users,dc=qa,dc=fortinet,dc=com"
set type regular
set username "CN=Administrator,cn=users,DC=qa,DC=fortinet,DC=com"
set password **********
set group-member-check group-object
set secure ldaps
set ca-cert "LDAPS-CA"
set port 636
set password-expiry-warning enable
set password-renewal enable
next
end
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5. Configure user group.
config user group
edit "ldaps-group"
set member "ldaps-server"
next
end

6. Configure SSL VPN web portal.
config vpn ssl web portal
edit "full-access"
set tunnel-mode enable
set web-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling disable
next
end

7. Configure SSL VPN settings.
config vpn ssl settings
set servercert "server_certificate"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set source-interface "wan1"
set source-address "all"
set default-portal "web-access"
config authentication-rule
edit 1
set groups "ldaps-group"
set portal "full-access"
next
end

8. Configure one SSL VPN firewall policy to allow remote user to access the internal network.
config firewall policy
edit 1
set name "sslvpn web mode access"
set srcintf "ssl.root"
set dstintf "port1"
set srcaddr "all"
set dstaddr "192.168.1.0"
set groups “ldaps-group”
set action accept
set schedule "always"
set service "ALL"
set nat enable
next
end

To see the results of web portal:
1. From a remote device, use a web browser to log into the SSL VPN web portal http://172.20.120.123:10443.
2. Log in using the ldu1 credentials.
Use a user which is configured on FortiAuthenticator with Force password change on next logon.
3. Click Login. You are prompted to enter a new password.
4. Go to VPN > Monitor > SSL-VPN Monitor to verify the user’s connection.
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To see the results of tunnel connection:
1. Download FortiClient from www.forticlient.com.
2. Open the FortiClient Console and go to Remote Access > Configure VPN.
3. Add a new connection.
l Set the connection name.
l Set Remote Gateway to the IP of the listening FortiGate interface, in this example, 172.20.120.123.
4. Select Customize Port and set it to 10443.
5. Save your settings.
6. Log in using the ldu1 credentials.
You are prompted to enter a new password.

To check the SSL VPN connection using the GUI:
1. Go to VPN > Monitor > SSL-VPN Monitor to verify the user’s connection.
2. Go to Log & Report > VPN Events to view the details of the SSL VPN connection event log.
3. Go to Log & Report > Forward Traffic to view the details of the SSL VPN traffic.

To check the web portal login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
Auth Type
0
ldu1
1(1)
SSL VPN sessions:
Index
User
Source IP

Timeout
229

Duration

From
10.1.100.254

HTTP in/out
0/0

I/O Bytes

HTTPS in/out
0/0

Tunnel/Dest IP

To check the tunnel login using the CLI:
get vpn ssl monitor
SSL VPN Login Users:
Index
User
Auth Type
0
ldu1
1(1)
SSL VPN sessions:
Index
User
Source IP
0
ldu1
10.1.100.254

Timeout
291

Duration
9

From
10.1.100.254

I/O Bytes
22099/43228

HTTP in/out
0/0

HTTPS in/out
0/0

Tunnel/Dest IP
10.212.134.200

SSL VPN protocols
The following topics provide information about SSL VPN protocols:
l
l

TLS 1.3 support on page 1148
SMBv2 support on page 1149

TLS 1.3 support
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FortiOS supports TLS 1.3 for SSL VPN.

TLS 1.3 support requires IPS engine 4.205 or later and endpoints running FortiClient 6.2.0 or
later.

To establish a client SSL VPN connection with TLS 1.3 to the FortiGate:
1. Enable TLS 1.3 support using the CLI:
config vpn ssl setting
set tlsv1-3 enable
end

2. Configure the SSL VPN and firewall policy:
a. Configure the SSL VPN settings and firewall policy as needed.
3. For Linux clients, ensure OpenSSL 1.1.1a is installed:
a. Run the following commands in the Linux client terminal:
root@PC1:~/tools# openssl
OpenSSL> version

If OpenSSL 1.1.1a is installed, the system displays a response like the following:
OpenSSL 1.1.1a 20 Nov 2018

4. For Linux clients, use OpenSSL with the TLS 1.3 option to connect to SSL VPN:
a. Run the following command in the Linux client terminal:
#openssl s_client -connect 10.1.100.10:10443 -tls1_3

5. Ensure the SSL VPN connection is established with TLS 1.3 using the CLI:
# diagnose debug application sslvpn -1
# diagnose debug enable

The system displays a response like the following:
[207:root:1d]SSL established: TLSv1.3 TLS_AES_256_GCM_SHA384

Deep inspection (flow-based)
FortiOS supports TLS 1.3 for policies that have the following security profiles applied:
l
l

Web filter profile with flow-based inspection mode enabled.
Deep inspection SSL/SSH inspection profile.

For example, when a client attempts to access a website that supports TLS 1.3, FortiOS sends the traffic to the IPS
engine. The IPS engine then decodes TLS 1.3 and the client is able to access the website.

SMBv2 support
On all FortiGate models, SMBv2 is enabled by default for SSL VPN. Client PCs can access the SMBv2 server using SSL
VPN web-only mode.
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To configure SMBv2:
1. Set the minimum and maximum SMB versions.
config vpn ssl web portal
edit portal-name
set smb-min-version smbv2
set smb-max-version smbv3
next
end

2.
3.
4.
5.

Configure SSL VPN and firewall policies as usual.
Connect to the SSL VPN web portal and create an SMB bookmark for the SMBv2 server.
Click the bookmark to connect to the SMBv2 server.
On the FortiGate, use package capture to verify that SMBv2 works:

SSL VPN to IPsec VPN
This is a sample configuration of site-to-site IPsec VPN that allows access to the remote endpoint via SSL VPN.
This example uses a pre-existing user group, a tunnel mode SSL VPN with split tunneling, and a route-based IPsec VPN
between two FortiGates. All sessions must start from the SSL VPN interface.
If you want sessions to start from the FGT_2 subnet, you need more policies. Also, if the remote subnet is beyond FGT_
2 (if there are multiple hops), you need to include the SSL VPN subnet in those routers as well.

Sample topology
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Sample configuration
To configure the site-to-site IPsec VPN on FGT_1:
1. Go to VPN > IPsec Wizard.
2. In the VPN Setup pane:
a. Specify the VPN connection Name as to_FGT_2.
b. Select Site to Site.
c. Click Next.

3. In the Authentication pane:
a. Enter the IP Address to the Internet-facing interface.
b. For Authentication Method, click Pre-shared Key and enter the Pre-shared Key.
c. Click Next.

4. In the Policy & Routing pane:
a. Set the Local Interface to the internal interface.
b. Set the Local Subnets to include the internal and SSL VPN subnets for FGT_1.
c. Set Remote Subnets to include the internal subnet for FGT_2.
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d. Click Create.

A confirmation screen shows a summary of the configuration including the firewall address groups for both the local and
remote subnets, static routes, and security policies.

To configure SSL VPN settings:
1.
2.
3.
4.
5.

Go to VPN > SSL-VPN Settings.
Set Listen on Interface(s) to wan1.
To avoid port conflicts, set Listen on Port to 10443.
For Restrict Access, select Allow access from any host.
In the Tunnel Mode Client Settings section, select Specify custom IP ranges and include the SSL VPN subnet range
created by the IPsec Wizard.
6. In the Authentication/Portal Mapping section, add the VPN user group to the tunnel-access Portal. Set All Other
Users/Groups to the web-access Portal.
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7. Click Apply.

To configure SSL VPN portal:
1. Go to VPN > SSL-VPN Portals.
2. Select tunnel-access and click Edit.
3. Turn on Enable Split Tunneling so that only traffic intended for the local or remote networks flow through FGT_1 and
follows corporate security profiles.
4. For Routing Address, add the local and remote IPsec VPN subnets created by the IPsec Wizard.
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5. For Source IP Pools, add the SSL VPN subnet range created by the IPsec Wizard.

6. Click OK.

To add policies to FGT_1:
1.
2.
3.
4.
5.
6.
7.
8.

Go to Policy & Objects > IPv4 Policy.
Click Create New to create a policy that allows SSL VPN users access to the IPsec VPN tunnel.
For Incoming Interface, select ssl.root.
For Outgoing Interface, select the IPsec tunnel interface to_FGT_2.
Set the Source to all and the VPN user group.
Set Destination to the remote IPsec VPN subnet.
Specify the Schedule.
Set the Service to ALL.
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9. In the Firewall/Network Options section, disable NAT.

10. Click OK.

To configure the site-to-site IPsec VPN on FGT_2:
1. Go to VPN > IPsec Wizard.
2. In the VPN Setup pane:
a. Specify the VPN connection Name as to FGT_1.
b. Select Site to Site.
c. Click Next.

3. In the Authentication pane:
a. Enter the IP Address to the Internet-facing interface.
b. For Authentication Method, click Pre-shared Key and enter the Pre-shared Key of the FGT_1.
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c. Click Next.

4. In the Policy & Routing pane:
a. Set the Local Interface to the internal interface.
b. Set the Local Subnets to include the internal and SSL VPN subnets for FGT_2.
c. Set Remote Subnets to include the internal subnet for FGT_1.
d. Click Create.

A confirmation screen shows a summary of the configuration including the firewall address groups for both the local and
remote subnets, static routes, and security policies.
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To check the results:
1. Go to Monitor > IPsec Monitor.
2. Select the tunnel and click Bring Up.

3. Verify that the Status changes to Up.

4. Configure the SSL VPN connection on the user's FortiClient and connect to the tunnel.

5. On the user's computer, use CLI to send a ping though the tunnel to the remote endpoint to confirm access.
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6. Go to Monitor > Routing Monitor and verify that the routes for the IPsec and SSL VPNs are added.

7. Go to Monitor > SSL-VPN Monitor and verify user connectivity.

8. Go to Log & Report > Events and view the IPsec and SSL tunnel statistics.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1158

VPN
9. Go to VPN > VPN Location Map and view VPN connection activity.

10. Go to FortiView > Policies and view policy usage.

Troubleshooting
To troubleshoot on FGT_1, use the following CLI commands:
diagnose
diagnose
diagnose
diagnose
diagnose
diagnose
diagnose

debug
debug
debug
debug
debug
debug
debug

reset
flow show function-name enable
flow show iprope enable
flow filter addr 172.16.200.55
flow filter proto 1
flow trace start 2
enable

To troubleshoot using ping:
1. Send a ping through the SSL VPN tunnel to 172.16.200.55 and analyze the output of the debug.
2. Disable the debug output with this command: diagnose debug disable.
If traffic is entering the correct VPN tunnel on FGT_1, then run the same commands on FGT_2 to check whether the
traffic is reaching the correct tunnel. If it is reaching the correct tunnel, confirm that the SSL VPN tunnel range is
configured in the remote side quick mode selectors.
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To troubleshoot using a sniffer command:
diagnose sniff packet any "host 172.16.200.44 and icmp" 4

To troubleshoot IPsec VPN issues, use the following commands on either FortiGate:
diagnose
diagnose
diagnose
diagnose

debug reset
vpn ike gateway clear
debug application ike -1
debug enable

SSL VPN troubleshooting
SSL VPN debug command
Use the following diagnose commands to identify SSL VPN issues. These commands enable debugging of SSL VPN
with a debug level of -1 for detailed results.
diagnose debug application sslvpn -1
diagnose debug enable

The CLI displays debug output similar to the following:
FGT60C3G10002814 # [282:root]SSL state:before/accept initialization (172.20.120.12)
[282:root]SSL state:SSLv3 read client hello A (172.20.120.12)
[282:root]SSL state:SSLv3 write server hello A (172.20.120.12)
[282:root]SSL state:SSLv3 write change cipher spec A (172.20.120.12)
[282:root]SSL state:SSLv3 write finished B (172.20.120.12)
[282:root]SSL state:SSLv3 flush data (172.20.120.12)
[282:root]SSL state:SSLv3 read finished A:system lib(172.20.120.12)
[282:root]SSL state:SSLv3 read finished A (172.20.120.12)
[282:root]SSL state:SSL negotiation finished successfully (172.20.120.12)
[282:root]SSL established: DHE-RSA-AES256-SHA SSLv3 Kx=DH Au=RSA Enc=AES(256) Mac=SHA1

To disable the debug:
diagnose debug disable
diagnose debug reset

Remote user authentication debug command
Use the following diagnose commands to identify remote user authentication issues.
diagnose debug application fnbamd -1
diagnose debug reset
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Troubleshooting common issues
To troubleshoot getting no response from the SSL VPN URL:
1. Go to VPN > SSL-VPN Settings.
a. Check the SSL VPN port assignment.
b. Check the Restrict Access setting to ensure the host you are connecting from is allowed.
2. Go to Policy > IPv4 Policy or Policy > IPv6 policy.
a. Check that the policy for SSL VPN traffic is configured correctly.
b. Check the URL you are attempting to connect to. It should follow this pattern:
https://<FortiGate IP>:<Port>

c. Check that you are using the correct port number in the URL. Ensure FortiGate is reachable from the computer.
ping <FortiGate IP>

d. Check the browser has TLS 1.1, TLS 1.2, and TLS 1.3 enabled.

To troubleshoot FortiGate connection issues:
1. Check the Release Notes to ensure that the FortiClient version is compatible with your version of FortiOS.
2. FortiClient uses IE security setting, In IE Internet options > Advanced > Security, check that Use TLS 1.1 and Use
TLS 1.2 are enabled.
3. Check that SSL VPN ip-pools has free IPs to sign out. The default ip-pools SSLVPN_TUNNEL_ADDR1 has 10 IP
addresses.
4. Export and check FortiClient debug logs.
a. Go to File > Settings.
b. In the Logging section, enable Export logs.
c. Set the Log Level to Debug and select Clear logs.
d. Try to connect to the VPN.
e. When you get a connection error, select Export logs.

To troubleshoot SSL VPN hanging or disconnecting at 98%:
1. A new SSL VPN driver was added to FortiClient 5.6.0 and later to resolve SSL VPN connection issues. If your
FortiOS version is compatible, upgrade to use one of these versions.
2. Latency or poor network connectivity can cause the login timeout on the FortiGate. In FortiOS 5.6.0 and later, use
the following commands to allow a user to increase the SSL VPN login timeout setting.
config vpn ssl settings
set login-timeout 180 (default is 30)
set dtls-hello-timeout 60 (default is 10)
end

To troubleshoot tunnel mode connections shutting down after a few seconds:
This might occur if there are multiple interfaces connected to the Internet, for example, SD-WAN. This can cause the
session to become “dirty”. To allow multiple interfaces to connect, use the following CLI commands.
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If you are using a FortiOS 6.0.1 or later:
config system interface
edit <name>
set preserve-session-route enable
next
end

If you are using a FortiOS 6.0.0 or earlier:
config vpn ssl settings
set route-source-interface enable
end

To troubleshoot users being assigned to the wrong IP range:
1. Go to VPN > SSL-VPN Portals and VPN > SSL-VPN Settings and ensure the same IP Pool is used in both places.
Using the same IP Pool prevents conflicts. If there is a conflict, the portal settings are used.

To troubleshoot slow SSL VPN throughput:
Many factors can contribute to slow throughput.
This recommendation tries to improve throughput by using the FortiOS Datagram Transport Layer Security (DTLS)
tunnel option, available in FortiOS 5.4 and above.
DTLS allows SSL VPN to encrypt traffic using TLS and uses UDP as the transport layer instead of TCP. This avoids
retransmission problems that can occur with TCP-in-TCP.
FortiClient 5.4.0 to 5.4.3 uses DTLS by default. FortiClient 5.4.4 and later uses normal TLS, regardless of the DTLS
setting on the FortiGate.
To use DTLS with FortiClient:
1. Go to File > Settings and enable Preferred DTLS Tunnel.
To enable DTLS tunnel on FortiGate, use the following CLI commands:
config vpn ssl settings
set dtls-tunnel enable
end
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In User & Device, you can control network access for different users and devices in your network. FortiGate
authentication controls system access by user group. By assigning individual users to the appropriate user groups you
can control each user’s access to network resources. You can define local users and peer users on the FortiGate unit.
You can also define user accounts on remote authentication servers and connect them to FortiOS.
You can control network access for different device types in your network by doing the following:
l
l
l

Identifying and monitoring the types of devices connecting to your network
Using MAC address based access control to allow or deny individual devices
Using Telemetry data received from FortiClient endpoints to construct a policy to deny access to endpoints with
known vulnerabilities or to quarantine compromised endpoints

The following sections provide information about users and devices:
l
l
l
l
l
l
l
l
l
l
l
l
l
l
l

Endpoint control and compliance on page 1163
User Definition on page 1173
User Groups on page 1174
Guest Management on page 1181
Device Inventory on page 1185
Custom Devices & Groups on page 1190
LDAP Servers on page 1191
RADIUS Servers on page 1201
TACACS+ Servers on page 1211
Authentication Settings on page 1212
FortiTokens on page 1214
SAML on page 1222
Configuring the maximum log in attempts and lockout period on page 1244
Creating a PKI/peer user on page 1244
Configuring firewall authentication on page 1245

Endpoint control and compliance
Per-policy disclaimer messages
FortiOS supports a customizable captive portal to direct users to install or enable required software.
Per-policy custom disclaimers in each VDOM are supported. For example, you may want to configure three firewall
policies, each of which matches traffic from endpoints with different FortiClient statuses:
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Endpoint status

FortiOS behavior

Endpoint does not have FortiClient installed.

Traffic matches a firewall policy that displays an in-browser warning
to install FortiClient from the provided link.

Endpoint has FortiClient installed, registered
to EMS, and connected to the FortiGate.

Traffic matches a dynamic firewall policy which allows the endpoint to
reach its destination via this policy.

Endpoint is deregistered from EMS and
disconnected from the FortiGate.

Traffic matches another dynamic firewall policy that displays warning
to register FortiClient to EMS.

To enable per-policy disclaimer messages:
config user setting
set auth-cert "Fortinet_Factory"
set per-policy-disclaimer enable
end

To configure per-policy disclaimers in the GUI:
1.
2.
3.
4.
5.
6.

Ensure the per-policy disclaimer messages option is enabled.
Go to Policy & Objects > IPv4 Policy.
Edit the policy that applies when an endpoint does not have FortiClient installed.
Under Disclaimer Options, enable Display Disclaimer.
Enable Customize Messages then click Edit Disclaimer Message. The default disclaimer message is shown.
Edit the message to warn users to install FortiClient, and provide the FortiClient download link.

7. Click Save.
8. Repeat the above steps for each policy that requires a custom disclaimer message.
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To configure per-policy disclaimers in the CLI:
config firewall policy
edit 1
set name "111"
set uuid c3ad8da0-bd7c-51e8-c0da-fe9053bf35ae
set srcintf "port12"
set dstintf "port11"
set srcaddr "all"
set dstaddr "pc155_address"
set action accept
set schedule "always"
set service "ALL"
set wsso disable
set groups "ems_03_group"
set disclaimer enable
set replacemsg-override-group "test"
set nat enable
next
edit 4
set name "44"
set uuid 686ea2ca-348d-51e9-9dca-b2b4b4aabbe2
set srcintf "port12"
set dstintf "port11"
set srcaddr "all"
set dstaddr "pc5-address"
set action accept
set schedule "always"
set service "ALL"
set wsso disable
set groups "ems_03_group"
set disclaimer enable
set replacemsg-override-group "test2"
set nat enable
next
edit 6
set name "66"
set uuid f1034e52-36d5-51e9-fbae-da21922ccd10
set srcintf "port12"
set dstintf "port11"
set srcaddr "all"
set dstaddr "all"
set status disable
set schedule "always"
set service "ALL"
set logtraffic all
set fsso disable
set block-notification enable
set replacemsg-override-group "endpoint-override"
next
end
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Compliance
FortiSandbox Cloud region selection
In FortiOS, FortiSandbox Cloud services are decoupled from the FortiGate Cloud license. This allows you to specify a
FortiSandbox Cloud region and take advantage of FortiSandbox features without a FortiGate Cloud account.
The following topology demonstrates how FortiGate Cloud Logs and FortiSandbox Cloud are separated in FortiOS:

To view the FortiGate Cloud Log and FortiSandbox licenses:
1. Go to Dashboard > Status.
2. Look in the FortiGate Cloud widget. This widget displays separate license statuses for Log Retention and
FortiSandbox Cloud.
In the following example, the FortiGate Cloud account is using a free license, and FortiSandbox Cloud is using a
paid license:
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To obtain a FortiSandbox Cloud license:
1. Go to System > FortiGuard.
2. Under License Information > FortiSandbox Cloud, click Activate.
3. Complete the prompts to obtain your license.

The FortiSandbox Cloud license is linked to your antivirus license, so they will expire at the
same time.

l

If the FortiGate is not registered with a paid antivirus license, the FortiGate will use the free FortiGate Cloud
license. This license limits the FortiGate to 100 FortiSandbox Cloud submissions per day.

To set the FortiSandbox Cloud region in the GUI:
1. Go to Security Fabric > Settings.
2. In the Sandbox Inspection section, click FortiSandbox Cloud.
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3. Select a region from the FortiSandbox cloud region dropdown.
The following regions are available:
Europe
Global
l Japan
l US
4. Click Apply.
l
l

To set the FortiSandbox Cloud region in the CLI:
FGT_PROXY (global) # execute forticloud-sandbox region
0 Europe
1 Global
2 Japan
3 US
Please select cloud sandbox region[0-3]:3
Cloud sandbox region is selected: US

The separation of the FortiGate Cloud Log and FortiSandbox services are visible in the following example:
FGT_PROXY (global) # diagnose test application forticldd 3
Debug zone info:
Domain:FortiCloud ReleaseQA Global - 172.16.95.16
Home log server: 172.16.95.93:514
Alt log server: 172.16.95.27:514
Active Server IP:
172.16.95.93
Active Server status: up
Log quota:
102400MB
Log used:
0MB
Daily volume:
20480MB
fams archive pause: 0
APTContract : 1
APT server: 172.16.102.52:514
APT Altserver: 172.16.102.51:514
Active APTServer IP:
172.16.102.52
Active APTServer status: up
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FortiGate — VM unique certificate
To safeguard against certificate compromise, FortiGate VM and FortiAnalyzer VM use the same deployment model as
FortiManager VM where the license file contains a unique certificate tied to the serial number of the virtual device.
A hardware appliance usually comes with a BIOS certificate with a unique serial number that identifies the hardware
appliance. This built-in BIOS certificate is different from a firmware certificate. A firmware certificate is distributed in all
appliances with the same firmware version.
Using a BIOS certificate with a built-in serial number provides a high trust level for the other side in X.509 authentication.
Since a VM appliance has no BIOS certificate, a signed VM license can provide an equivalent of a BIOS certificate. The
VM license assigns a serial number in the BIOS equivalent certificate. This gives the certificate an abstract access
ability, which is similar to a BIOS certificate with the same high trust level.

This feature is only supported in new, registered VM licenses.

Sample configurations
Depending on the firmware version and VM license, the common name (CN) on the certificate will be configured
differently.

To view validated certificates:
1. Go to System > Certificates.
2. Double-click on a VM certificate. There are two VM certificates:
l Fortinet_Factory
l
Fortinet_Factory_Backup
The Certificate Detail Information window displays.
l

If you are using new firmware (6.2.0 and later) with a new VM license, the CN becomes the FortiGate VM serial
number.
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l

If you are using new firmware (6.2.0) with an old VM license, the CN remains as FortiGate. It does not change
to the VM serial number.
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l

If you are using old firmware (6.0.2) with a new VM license, the CN remains as FortiGate.

Running a file system check automatically
There is an option in FortiOS to enable automatic file system checks if the FortiGate shuts down ungracefully.
By default, the automatic file system check is disabled. When an administrator logs in after an ungraceful shutdown, a
warning message appears advising them to manually run a file system check.
GUI warning:

CLI warning:
WARNING: File System Check Recommended! Unsafe reboot may have caused inconsistency in disk
drive.
It is strongly recommended that you check file system consistency before proceeding.
Please run 'execute disk scan 17'
Note: The device will reboot and scan during startup. This may take up to an hour

Enabling automatic file system checks
You can enable automatic file system checks in both the GUI and CLI.

To enable automatic file system checks in the GUI:
1. Go to System > Settings.
2. In the Start Up Settings section, enable Auto file system check.
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3. Click Apply.

To enable automatic file system checks using the CLI:
config system global
set autorun-log-fsck enable
end

FortiGuard distribution of updated Apple certificates
Push notifications for iPhone (for the purpose of two-factor authentication) require a TLS server certificate to
authenticate to Apple. As this certificate is only valid for one year, a service extension allows FortiGuard to distribute
updated TLS server certificates to FortiGate when needed.
FortiGuard update service updates local Apple push notification TLS server certificates when the local certificate is
expired. FortiGuard update service also reinstalls certificates when the certificates are lost.
You can verify that the feature is working on the FortiGate by using the CLI shell.

To verify certificate updates:
1. Using FortiOS CLI shell, verify that all certificates are installed:
/data/etc/apns # ls -al
drwxr-xr-x
2 0
drwxr-xr-x
12 0
-rw-r--r-1 0
-rw-r--r-1 0
-rw-r--r-1 0
-rw-r--r-1 0

0
0
0
0
0
0

Tue
Tue
Sat
Sat
Sat
Sat

Jan
Jan
Jan
Jan
Jan
Jan

15
15
12
12
12
12

08:42:39
08:45:00
00:06:30
00:06:30
00:06:30
00:06:30

2019
2019
2019
2019
2019
2019

1024
2048
2377
1859
8964
4482

.
..
apn-dev-cert.pem
apn-dev-key.pem
apn-dis-cert.pem
apn-dis-key.pem

2. Rename all current Apple certificates.
Apple push notification no longer works after you rename the certificates.
/data/etc/apns # mv apn-dis-cert.pem apn-dis-cert.pem.save
/data/etc/apns # mv apn-dev-key.pem apn-dev-key.pem.save
/data/etc/apns # mv apn-dev-cert.pem apn-dev-cert.pem.save
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/data/etc/apns
/data/etc/apns
drwxr-xr-x
2
drwxr-xr-x 12
-rw-r--r-1
-rw-r--r-1
-rw-r--r-1
-rw-r--r-1

# mv apn-dis-key.pem apn-dis-key.pem.save
# ls -al
0 0
Tue Jan 15 08:51:15 2019
1024 .
0 0
Tue Jan 15 08:45:00 2019
2048 ..
0 0
Sat Jan 12 00:06:30 2019
2377 apn-dev-cert.pem.save
0 0
Sat Jan 12 00:06:30 2019
1859 apn-dev-key.pem.save
0 0
Sat Jan 12 00:06:30 2019
8964 apn-dis-cert.pem.save
0 0
Sat Jan 12 00:06:30 2019
4482 apn-dis-key.pem.save

3. Run a FortiGuard update, and verify that all certificates are installed again:
/data/etc/apns # ls -al
drwxr-xr-x
2 0 0
Tue
drwxr-xr-x 12 0 0
Tue
-rw-r--r-1 0 0
Sat
-rw-r--r-1 0 0
Sat
-rw-r--r-1 0 0
Tue
from FortiGuard
-rw-r--r-1 0 0
Sat
-rw-r--r-1 0 0
Tue
from FortiGuard
-rw-r--r-1 0 0
Sat
-rw-r--r-1 0 0
Tue
from FortiGuard
/data/etc/apns #

Jan
Jan
Jan
Jan
Jan

15
15
12
12
15

08:56:20
08:56:15
00:06:30
00:06:30
08:56:20

2019
2019
2019
2019
2019

1024
2048
2377
1859
2167

.
..
apn-dev-cert.pem.save
apn-dev-key.pem.save
apn-dis-cert.pem <-- downloaded

Jan 12 00:06:30 2019
Jan 15 08:56:20 2019

8964 apn-dis-cert.pem.save
1704 apn-dis-key.pem
<-- downloaded

Jan 12 00:06:30 2019
Jan 15 08:56:20 2019

4482 apn-dis-key.pem.save
41 apn-version.dat
<-- downloaded

User Definition
User types
You can configure FortiOS users in FortiOS or on an external authentication server. The following summarizes user
account types and authentication in FortiOS:

User type

Authentication

Local

Username and password must match a user account stored in FortiOS.
Authentication by FortiOS security policy.

Remote

Username and password must match a user account stored in FortiOS and on the
remote authentication server. FortiOS supports LDAP, RADIUS, and TACACS+
servers.

Authentication server

A FortiOS user group can include user accounts or groups that exist on a remote
authentication server.

FSSO

Microsoft Windows or Novell network users can use their network credentials to
access resources through FortiOS. You can control access using FSSO user
groups that contain Windows or Novell user groups as members.

PKI/peer

Digital certificate holder who authenticates using a client certificate. No password
is required unless two-factor authentication is enabled.
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User type

Authentication

IM

FortiOS does not authenticate IM users. FortiOS allows or blocks each IM user
from accessing IM protocols. A global policy for each IM protocol governs
unknown users' access to these protocols.

Guest

Guest user accounts are temporary. The account expires after a selected period
of time. See Guest Management on page 1181.

Removing a user
When a user account is no longer in use, you should delete it. If any configuration objects, such as a user group,
reference the user account, you must remove the references before deleting the user.

To remove references to a user:
1. Go to User & Device > User Definition.
2. If the value in the Ref. column is not 0, click it.
3. FortiOS displays a list of object references to the user. Use this information to remove these references.

To remove a user using the GUI:
1. Go to User & Device > User Definition.
2. Select the desired user.
3. Click Delete, then OK.

To remove a user using the CLI:
config user local
delete exampleuser
end

User Groups
A user group is a list of users. Security policies and some VPN configurations only allow access to specified user groups.
This restricted access enforces role-based access control (RBAC) to your organization's network and resources. Users
must be in a group and that group must be part of the security policy.
In most cases, FortiOS authenticates a user by requesting their username and password. FortiOS checks local user
accounts first. Then, if it does not find a match, FortiOS checks the RADIUS, LDAP, and TACACS+ servers that belong
to the user group. Authentication succeeds when FortiOS finds a matching username and password. If the user belongs
to multiple groups on a server, FortiOS matches those groups as well.

FortiOS does not allow username overlap between RADIUS, LDAP, and TACACS+ servers.
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Configuring POP3 authentication
FortiOS can authenticate users who have accounts on POP3 or POP3s email servers.

To configure POP3 authentication:
config user pop3
edit pop3_server1
set server pop3.fortinet.com
set secure starttls
set port 110
next
end

To configure a POP3 user group:
A user group can list up to six POP3 servers as members.
config user group
edit pop3_grp
set member pop3_server1
next
end

Dynamic policies - FortiClient EMS
The FortiClient EMS FSSO connector allows objects to be defined in FortiOS that map to tags and groups on EMS. EMS
dynamically updates these endpoint groups when host compliance or other events occur, causing FortiOS to
dynamically adjust its security policies based on the group definitions.
EMS supports creating compliance verification rules based on various criteria. When a FortiClient endpoint registers to
EMS, EMS dynamically groups them based on these rules. FortiOS can receive the dynamic endpoint groups from EMS
as tags via the FSSO protocol using an FSSO agent that supports SSL and imports trusted certificates.
After FortiOS pulls the tags from EMS, they can be used as members in user groups that can have dynamic firewall
policies applied to them. When an event occur, EMS sends an update to FortiOS, and the dynamic policies are updated.
The following instructions assume EMS is installed, configured, and has endpoints connected. For information on
configuring EMS, see the FortiClient EMS Administration Guide.
The following steps provide an example of configuring a dynamic policy:
1.
2.
3.
4.

Add a compliance verification rule in EMS on page 1175
Configure an EMS FSSO agent on page 1176
Configure user groups on page 1177
Create a dynamic firewall policy on page 1178

Add a compliance verification rule in EMS
This example creates a compliance verification rule that applies to endpoints that have Windows 10 installed.
For more information see Compliance verification in the FortiClient EMS Administration Guide.
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To create a compliance verification rule in EMS:
1. In EMS, go to Compliance Verification > Compliance Verification Rules.
2. Click Add.
3. In the Name field, enter the desired rule name.
EMS uses the tag name to dynamically group endpoints, not the rule name configured in this field.
4. Turn Status on to enable the rule.
5. For Type, select Windows, Mac, or Linux. This affects what rule types are available. In this example, Windows is
selected.
6. From the Rule dropdown list, select the rule type and configure the related options. Ensure you click the + button
after entering each criterion.
In this example, OS Version is selected from the Rule dropdown list, and Windows 10 is selected from the OS
Version dropdown list.
7. Under Assign to, select All.
8. In the Tag endpoint as dropdown list, select an existing tag or enter a new tag. In this example, a new tag, WIN10_
EMS134, is created. EMS uses this tag to dynamically group together endpoints that satisfy the rule, as well as any
other rules that are configured to use this tag.

9. Click Save.
10. Go to Compliance Verification > Host Tag Monitor. All endpoints that have Windows 10 installed are shown grouped
by the WIN10_EMS134 tag.

Configure an EMS FSSO agent
In this example, the FSSO agent name is EMS_FSSO_connector, and the EMS server is located at 172.18.64.7.

To configure the EMS FSSO agent in FortiOS in the GUI:
1. Go to Security Fabric > Fabric Connectors.
2. Click Create New.
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3. In the SSO/Identity section, click Fortinet Single Sign-On Agent.

4. Fill in the Name, and Primary FSSO Agent server IP address or name and Password.
5. Set the User Group Source to Collector Agent.
User groups will be pushed to the FortiGate from the collector agent. Click Apply & Refresh to fetch group filters
from the collector agent.

6. Click OK.

To configure the EMS FSSO agent in FortiOS in the CLI:
config user fsso
edit "ems_QA_connector"
set server "172.18.64.7"
set password ******
set type fortiems
set ssl enable
next
end

Configure user groups
In this example, the user group is named ems_QA_group, and includes six dynamic endpoint groups that were pulled
from EMS as members.

To configure a user group based on EMS tags in the GUI:
1. Go to User & Device > User Groups.
2. Click Create New.
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3. In the Name field, enter ems_QA_group.
4. For Type, select Fortinet Single Sign-On (FSSO).
5. In the Members field, click +. The Select Entries pane appears. The dynamic endpoint groups pulled from EMS have
names that begin with TAG_, followed by the tag name in EMS.
6. Select the desired dynamic endpoint groups. Endpoints that currently belong to these groups in EMS will be
members of this FortiOS user group.

7. Click OK.

To configure a user group based on EMS tags in the CLI:
config user group
edit "ems_QA_group"
set group-type fsso-service
set authtimeout 0
set http-digest-realm ''
set member "TAG_FILE_QA_EMS" "TAG_LINUX1604_QA_EMS" "TAG_MACOS_QA_EMS" "TAG_WIN10_
QA_EMS" "TAG_WIN7_QA_EMS" "TAG_WINSCP_QA_EMS"
next
end

Create a dynamic firewall policy
You can create a dynamic firewall policy for the user group. This example shows how to create an IPv4 policy for the
user group.

To create a dynamic firewall policy for the user group in the GUI:
1. Go to Policy & Objects > IPv4 Policy.
2. Click Create New.
3. In the Source field, click +. The Select Entries pane opens.
a. On the User tab, select the ems_QA_group group.
b. Click Close.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1178

User & Device
4. Configure the other policy settings options as required.

5. Click OK.
6. Go to Policy & Objects > IPv4 Policy to ensure the policy was created and applied to the desired user group.
FortiOS will update this policy when it receives updates from EMS.

To create a dynamic firewall policy for the user group in the CLI:
config firewall policy
edit 4
set name 44
set srcintf port12
set dstintf port11
set srcaddr "all" "ems_QA_group" "Win10_group"
set dstaddr pc5-address
set action accept
set schedule always
set service ALL
next
end

Diagnostics
To list endpoint records, use the following CLI command:
diagnose endpoint record-list
Record #1:
IP_Address = 10.1.100.120(3)
MAC_Address = 00:0c:29:36:4e:61
Host MAC_Address = 00:0c:29:36:4e:61
MAC list = 00-0c-29-36-4e-57;00-0c-29-36-4e-61;
VDOM = vdom1
EMS serial number: FCTEMS3688727941
Quarantined: no
Online status: online
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On-net status: on-net
FortiClient connection route: Direct
FortiClient communication interface index: 19
DHCP server:
Dirty_onnet_addr: yes
FortiClient version: 6.2.0
AVDB version: 67.558
FortiClient app signature version: 14.586
FortiClient vulnerability scan engine version: 2.28
FortiClient feature version status: 0
FortiClient UID: FA4AFAF6F92442E69DC7D67ABE64BDBA (0)
FortiClient KA interval dirty: 0
FortiClient Full KA interval dirty: 0
Auth_AD_groups:
Auth_group: ems_QA_group
Auth_user: FRANK
Host_Name: DESKTOP-FJEVH8U
OS_Version: Microsoft Windows 10 Professional Edition, 64-bit (build 17763)
Host_Description: AT/AT COMPATIBLE
Domain:
Last_Login_User: frank
Host_Model: VMware Virtual Platform
Host_Manufacturer: VMware, Inc.
CPU_Model: Intel(R) Xeon(R) CPU E5-2630 v4 @ 2.20GHz
Memory_Size: 4096
Installed features: 375
Enabled features: 177
Last vul message received time: N/A
Last vul scanned time: N/A
Last vul statistic: critical=0, high=0, medium=0, low=0, info=0
Avatar source username: frank
Avatar source email:
Avatar source: Client Operating System
Phone number:
online records: 1; offline records: 0; quarantined records: 0

To list authenticated IPv4 users, use the following CLI command:
diagnose firewall auth list
2.2.2.1, JONATHANWONG
type: fsso, id: 0, duration: 18955, idled: 18955
server: ems_QA_connector
packets: in 0 out 0, bytes: in 0 out 0
10.1.100.111, FRANK111
type: fsso, id: 0, duration: 18955, idled: 18955
server: ems_QA_connector
packets: in 0 out 0, bytes: in 0 out 0
group_id: 5
group_name: ems_QA_group
10.1.100.120, FRANK
type: fsso, id: 0, duration: 18955, idled: 4
server: ems_QA_connector
packets: in 10643 out 11379, bytes: in 6014568 out 3224342
group_id: 5
group_name: ems_QA_group
10.1.100.141, ADMINISTRATOR
type: fsso, id: 0, duration: 18955, idled: 1
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server: ems_QA_connector
packets: in 9669 out 10433, bytes: in 5043948 out 2823319
group_id: 5
group_name: ems_QA_group
...
...
----- 23 listed, 0 filtered -----FGT_EC_A (vdom1) # diagnose debug authd fsso list
----FSSO logons---IP: 2.2.2.1 User: JONATHANWONG Groups: 6B8028751BF3457BA172EE3795A2BDA8 Workstation:
VAN-201740-PC
IP: 10.1.100.111 User: FRANK111 Groups: ECF57781AE384D6A9A4D2D72CB5169C6+TAG_
LINUX1604_QA_EMS Workstation: FRANK111VIRTUAL-MACHINE MemberOf: ems_QA_group
IP: 10.1.100.120 User: FRANK Groups: FA4AFAF6F92442E69DC7D67ABE64BDBA+TAG_WIN10_QA_EMS
Workstation: DESKTOP-FJEVH8U MemberOf: ems_QA_group
IP: 10.1.100.141 User: ADMINISTRATOR Groups: 6D21827915CE445F8A85F9E6BAA0C57A+TAG_
VULN_EMS_QA+TAG_WIN7_QA_EMS Workstation: LHWIN7A MemberOf: ems_QA_group
....
....
Total number of logons listed: 23, filtered: 0
----end of FSSO logons----

Guest Management
Configuring guest access
A visitor to your premises may need a user account on your network during their stay. If you are hosting a large event,
such as a conference, you may need to create many temporary accounts for the attendees. You can create many guest
accounts simultaneously using randomly generated user IDs and passwords to reduce your workload for these large
events.
The following describes managing guest access:
1. Create one or more guest user groups. All members of a group have the same user ID type, password type,
information fields used, and type and time of expiry.
2. Create guest accounts.
3. Use captive portal authentication and select the appropriate guest group.
4. The guest receives an email, SMS message, or printout containing their user ID and password from the FortiOS
administrator.
5. The guest logs onto the network using the provided credentials.
6. After the configured expiry time, the credentials are no longer valid.
This configuration consists of the following steps:
1.
2.
3.
4.

Add an SMS service.
Create a guest management administrator.
Create a guest user group.
Create guest user accounts.
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To add an SMS service:
To send SMS notifications to guest users, add an email to SMS service to your FortiGate using the following commands:
config system sms-server
edit <server-name>
set mail-server <server-name>
next
end

To create a guest management administrator:
1.
2.
3.
4.

Go to System > Administrators.
Click Create New > Administrator.
Enable Restrict admin to guest account provisioning only.
For Guest Group, select the desired guest groups.

To create a guest user group:
The guest group configuration determines the provided fields when you create a guest user account.
1.
2.
3.
4.

Go to User & Device > User Groups.
Click Create New.
For Type, select Guest.
If desired, enable Batch Guest Account Creation. When this is enabled, the following is true:
l User IDs and passwords are auto-generated.
l User accounts only have the User ID, Password, and Expiration fields. You can only edit the Expiration field. If
the expiry time is a duration, such as eight hours, the countdown starts at initial login.
l You can print the account information to provide to the guest. Guests do not receive email or SMS notifications.
5. For User ID, select one of the following:

Option

Description

Email

Guest's email address.

Auto Generated

FortiOS creates a random user ID for the guest.

Specify

The administrator assigns a user ID to the guest.

6. For Password, select one of the following:

Option

Description

Disable

No password.

Auto Generated

FortiOS creates a random password for the guest.

Specify

The administrator assigns a password to the guest.

7. For Start Countdown, select one of the following:

Option

Description

On Account Creation

FortiOS counts expiry time from time of account creation.
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Option

Description

After First Login

FortiOS counts expiry time from the guest's first login.

8. For Time, configure the expiry time. You can change this for individual users.
9. Configure any other field as required, then click OK.

Creating guest user accounts
To create a guest user account:
1.
2.
3.
4.
5.

Go to User & Device > Guest Management.
Select the desired guest group.
Click Create New.
Configure the guest as desired.
Click OK.

To create multiple guest user accounts automatically:
1.
2.
3.
4.
5.
6.

Go to User & Device > Guest Management.
Select the desired guest group. This group must have Batch Guest Account Creation enabled.
Click Create New > Multiple Users.
Enter the Number of Accounts.
If desired, change the expiry.
Click OK.

Retail environment guest access
Businesses such as coffee shops provide free Internet access for customers. In this scenario, you do not need to
configure guest management, as customers can access the WiFi access point without logon credentials.
However, consider that the business wants to contact customers with promotional offers to encourage future patronage.
You can configure an email collection portal to collect customer email addresses for this purpose. You can configure a
security policy to grant network access only to users who provide a valid email address. The first time a customer’s
device attempts WiFi connection, FortiOS requests an email address, which it validates. The customer’s subsequent
connections go directly to the Internet without interruption.
This configuration consists of the following steps:
1. Create an email collection portal.
2. Create a security policy.
3. Check for harvested emails.

Creating an email collection portal
The customer’s first contact with your network is a captive portal that presents a webpage requesting an email address.
When FortiOS has validated the email address, the customer’s device MAC address is added to the Collected Emails
device group.
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To create an email collection portal using the GUI:
1.
2.
3.
4.

Go to WiFi & Switch Controller > SSID and edit the SSID.
From the Security Mode dropdown list, select Captive Portal.
For Portal Type, select Email Collection.
(Optional) In Customize Portal Messages, select Email Collection.

To create an email collection portal using the CLI:
This example modifies the freewifi WiFi interface to present an email collection captive portal.
config wireless-controller vap
edit freewifi
set security captive-portal
set portal-type email-collect
end

Creating a security policy
You must configure a security policy that allows traffic to flow from the WiFi SSID to the Internet interface but only for
members of the Collected Emails device group. This policy must be listed first. Unknown devices are not members of the
Collected Emails device group, so they do not match the policy.

To create a security policy using the GUI:
1. Go to Policy & Objects > IPv4 Policy and select Create New.
2. Configure the policy as follows:
Incoming Interface

freewifi

Source Address

all

Source Device Type

Collected Emails

Outgoing Interface

wan1

Destination Address

all

Schedule

always

Service

ALL

Action

ACCEPT

NAT

On

3. Select OK.

To create a security policy using the CLI:
config firewall policy
edit 3
set srcintf "freewifi"
set dstintf "wan1"
set srcaddr "all"
set action accept
set devices collected-emails
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set nat enable
set schedule "always"
set service "ALL"
next
end

Checking for harvested emails
To check for harvested emails using the GUI:
1. Go to User & Device > Device Inventory.

To check for harvested emails using the CLI:
FGT-100D # diagnose user device list
hosts
vd 0 d8:d1:cb:ab:61:0f gen 35 req 30 redir 1 last 43634s 7-11_2-int
ip 10.0.2.101 ip6 fe80::dad1:cbff:feab:610f
type 2 'iPhone' src http c 1 gen 29
os 'iPhone' version 'iOS 6.0.1' src http id 358 c 1
email 'yo@yourdomain.com'
vd 0 74:e1:b6:dd:69:f9 gen 36 req 20 redir 0 last 39369s 7-11_2-int
ip 10.0.2.100 ip6 fe80::76e1:b6ff:fedd:69f9
type 1 'iPad' src http c 1 gen 5
os 'iPad' version 'iOS 6.0' src http id 293 c 1
host 'Joes’s-iPad' src dhcp
email 'you@fortinet.com'

Device Inventory
You can enable device detection to allow FortiOS to monitor your networks and gather information about devices
operating on those networks, including:
l
l
l
l
l
l

MAC address
IP address
Operating system
Hostname
Username
When FortiOS detected the device and on which interface

You can view the devices in User & Device > Device Inventory. You can assign each device an alias for easy
identification. If you do not assign an alias to a device, Device Inventory displays the device's MAC address.
You can enable device detection separately on each interface in Network > Interfaces. Device detection is intended for
devices directly connected to your LAN ports. If enabled on a WAN port, device detection may be unable to determine
the OS on some devices. You can enable active scanning on the interface to find hosts whose device types FortiOS
cannot determine passively.
You can also manually add devices to Device Inventory to ensure that a device with multiple interfaces displays as a
single device. See Creating a custom device on page 1190.
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To assign an alias to a device:
1.
2.
3.
4.

Go to User & Device > Device Inventory.
Edit the desired device.
Enter the desired alias.
Click OK.

Device Inventory categorizes devices. You can categorize a device using the CLI:
config user device
edit <category>
set category [none | android-device | blackberry-device | fortinet-device | ios-device
| windows-device]
next
end

Device summary and filtering
The Device Inventory pane contains three summary charts that provide an overview of the device type, status, and
interfaces. You can use these clickable charts to simplify filtering among your devices.

To view the device summary and apply a filter:
1. Go to User & Device > Device Inventory.
The Device Inventory pane appears with the three charts:

2. Click one item in the chart (in the legend or chart area) to apply a filter.
Once the filter is applied, the list of results displays beneath the charts.

You can combine filters by clicking one item in another chart.
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Filter examples
To filter all Linux devices:
1. In the Device Type chart, click Linux PC.

To filter all offline devices:
1. In the Status chart, click Offline.
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To filter all devices discovered on port1:
1. In the Interfaces chart, click port1.

Click the filter icon in the top-right corner of the chart to remove the filter.

Adding MAC-based addresses to devices
Assets detected by device detection appear in the User & Device > Device Inventory list. You can manage policies
around devices by adding a new device object (MAC-based address) to a device. Once you add the MAC-based
address, the device can be used in address groups or directly in policies.
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To add a MAC-based address to a device:
1. Go to User & Device > Device Inventory.
2. Right-click a device and select Create Firewall Address > MAC Address.

3. In the New Address pane, enter an address name.
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4. Click OK. The MAC address icon is now displayed in the Address column for the device.

Custom Devices & Groups
Creating a custom device
1. Go to User & Device > Custom Devices & Groups.
2. Click Create New > Device.
3. Complete the following fields:
a. Alias
b. MAC Address
c. Additional MACs: Enter the device's other interfaces.
d. Device Type
e. Custom Groups
f. Avatar
g. Comments
4. Click OK.

Creating a custom device group
You can add multiple device types to a custom device group and include the group in a security policy. This enables you
to create a different policy for devices that you know than for devices in general.

To create a custom device group:
1. Go to User & Device > Custom Devices & Groups.
2. Click Create New > Device Group.
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3. In the Name field, enter the desired name.
4. In Members, select the desired device types. Click OK.

Configuring an avatar for a custom device
You can upload an avatar for a custom device. FortiOS displays the avatar in the GUI wherever it lists the device, such
as FortiView, log viewer, or policy configuration.

To configure an avatar for a custom device:
1. Go to User & Device > Custom Devices & Groups.
2. Create a new device or edit an existing device.
3. Click Upload Image or Capture Image. The image can be in any format that your browser supports. FortiOS
automatically sizes the image to 36 x 36 pixels for use in the GUI.

LDAP Servers
FSSO polling connector agent installation
This topic gives an example of configuring a local FSSO agent on the FortiGate. The agent actively pools Windows
Security Event log entries on Windows Domain Controller (DC) for user log in information. The FSSO user groups can
then be used in a firewall policy.
This method does not require any additional software components, and all the configuration can be done on the
FortiGate.

To configure a local FSSO agent on the FortiGate:
1. Configure an LDAP server on the FortiGate on page 1191
2. Configure a local FSSO polling connector on page 1192
3. Add the FSSO groups to a policy on page 1194

Configure an LDAP server on the FortiGate
To configure an LDAP server on the FortiGate:
1. Go to User & Device > LDAP Servers.
2. Click Create New.
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3. Fill in the required information:

Common Name Identifier must be changed from the default value because, in a Windows environment,
sAMAccountName must be unique, and cn must not be unique.
l Distinguished Name is the location in the LDAP tree where the FortiGate will start searching for user and group
objects.
l Active Directory requires authentication by default, so the Bind Type is Regular, and the user account log in
information is entered in the requisite fields. Optionally, click Test User Credentials to ensure that the account
has sufficient access rights.
4. Click OK.
The FortiGate checks the connection, and updates the Connection Status. The connection must be successful
before configuring the FSSO polling connector.
l

Configure a local FSSO polling connector
To configure a local FSSO polling connector:
1. Go to Security Fabric > Fabric Connectors.
2. Click Create New.
3. In the SSO/Identity section, select Poll Active Directory Server.
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4. Fill in the required information.

5. Select the just created LDAP server from the LDAP Server dropdown list.
The structure of the LDAP tree will be shown in the Users/Groups section.
6. Go to the Groups tab.
7. Select the required groups, right click on them, and select Add Selected. Multiple groups can be selected at one
time by holding the CTRL or SHIFT keys. The groups list can be filtered or searched to limit the number of groups
that are displayed.

8. Go to the Selected tab and verify that all the required groups are listed. Unneeded groups can be removed by right
clicking and selecting Remove Selected.
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9. Click OK.
10. Go back to Security Fabric > Fabric Connectors.
11. There should be two new connectors:

The Local FSSO Agent is the backend process that is automatically created when the first FSSO polling
connector is created.
l The Active Directory Connector is the front end connector that can be configured by FortiGate administrators.
To verify the configuration, hover the cursor over the top right corner of the connector; a popup window will show the
currently selected groups. A successful connection is also shown by a green up arrow in the lower right corner of the
connector.
l

If you need to get log in information from multiple DCs, then you must configure other Active Directory connectors
for each additional DC to be monitored.

Add the FSSO groups to a policy
FSSO groups can be used in a policy by either adding them to the policy directly, or by adding them to a local user group
and then adding the group to a policy.

To add the FSSO groups to a local user group:
1.
2.
3.
4.

Go to User & Device > User Groups.
Click Create New.
Enter a name for the group in the Name field.
Set the Type to Fortinet Single Sign-On (FSSO).
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5. Add the FSSO groups as members.

6. Click OK.
7. Add the local FSSO group to a policy.

To add the FSSO groups directly to a firewall policy:
1.
2.
3.
4.
5.

Go to Policy & Objects > IPv4 Policy.
Click Create New.
Click in the Source field.
In the Select Entries pane, select the User tab.
Select the FSSO groups.

6. Configure the remaining settings as required.
7. Click OK.
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Troubleshooting
If an authenticated AD user cannot access the internet or pass the firewall policy, verify the local FSSO
user list:
# diagnose debug authd fsso list
----FSSO logons---IP: 10.1.100.188 User: test2 Groups: CN=group2,OU=Testing,DC=Fortinet-FSSO,DC=COM
Workstation: MemberOf: CN=group2,OU=Testing,DC=Fortinet-FSSO,DC=COM
Total number of logons listed: 1, filtered: 0
----end of FSSO logons----

1. Check that the group in MemberOf is allowed by the policy.
2. If the expected AD user is not in list, but other users are, it means that either:
l The FortiGate missed the log in event, which can happen if many users log in at the same time, or
l The user's workstation is unable to connect to the DC, and is currently logged in with cached credentials, so
there is no entry in the DC security event log.
3. If there are no users in the local FSSO user list:
a. Ensure that the local FSSO agent is working correctly:
# diagnose debug enable
# diagnose debug authd fsso server-status
Server Name
----------FGT_A (vdom1) # Local FSSO Agent

Connection Status
----------------connected

Version
------FSAE server 1.1

Address
------127.0.0.1

The connection status must be connected.
b. Verify the Active Directory connection status:
# diagnose debug fsso-polling detail 1
AD Server Status (connected):
ID=1, name(10.1.100.131),ip=10.1.100.131,source(security),users(0)
port=auto username=Administrator
read log eof=1, latest logon timestamp: Fri Jul 26 10:36:20 2019
polling frequency: every 10 second(s) success(274), fail(0)
LDAP query: success(0), fail(0)
LDAP max group query period(seconds): 0
LDAP status: connected
Group Filter: CN=group2,OU=Testing,DC=FortinetFSSO,DC=com+CN=group21,OU=Testing,DC=Fortinet-FSSO,DC=COM

If the polling frequency shows successes and failures, that indicates sporadic network problems or a very busy
DC. If it indicates no successes or failures, then incorrect credentials could be the issue.
If the LDAP status is connected, then the FortiGate can access the configured LDAP server. This is required for
AD group membership lookup of authenticated users because the Windows Security Event log does not
include group membership information. The FortiGate sends an LDAP search for group membership of
authenticated users to the configure LDAP server.
FortiGate adds authenticated users to the local FSSO user list only if the group membership is one of the
groups in Group Filter.
4. If necessary, capture the output of the local FortiGate daemon that polls Windows Security Event logs:
# diagnose debug application fssod -1
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This output contains a lot of detailed information which can be captured to a text file.

Limitations
l
l

l

NTLM based authentication is not supported.
If there are a large number of user log ins at the same time, the FSSO daemon may miss some. Consider using
FSSO agent mode if this will be an issue. See Fabric connectors on page 101 for information.
The FSSO daemon does not support all of the security log events that are supported by other FSSO scenarios. For
example, only Kerberos log in events 4768 and 4769 are supported.

Enabling Active Directory recursive search
By default, nested groups (groups that are members or other groups) are not searched in Windows Active Directory (AD)
LDAP servers because this can slow down the group membership search. There is an option in FortiOS to enable the
searching of nested groups for user group memberships on AD LDAP servers.

This option is not available for other LDAP servers, such as OpenLDAP-based servers.

The default behavior does not include nested groups:
config user ldap
edit "ldap-ad"
set server "10.1.100.131"
set cnid "cn"
set dn "dc=fortinet-fsso,dc=com"
set type regular
set username "cn=Administrator,cn=users,dc=fortinet-fsso,dc=com"
set password XXXXXXXXXXXXXXXXXXXXXXXX
next
end

The default search results only show groups that have the user as member, and no groups that have groups as
members:
diagnose test authserver ldap ldap-ad nuser nuser
authenticate 'nuser' against 'ldap-ad' succeeded!
Group membership(s) - CN=nested3,OU=Testing,DC=Fortinet-FSSO,DC=COM
CN=Domain Users,CN=Users,DC=Fortinet-FSSO,DC=COM

To enable recursive search to include nested groups in the results:
config user ldap
edit "ldap-ad"
set server "10.1.100.131"
set cnid "cn"
set dn "dc=fortinet-fsso,dc=com"
set type regular
set username "cn=Administrator,cn=users,dc=fortinet-fsso,dc=com"
set password XXXXXXXXXXXXXXXXXXXXXXXX
set search-type recursive
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next
end

The search results now include groups that have other groups as members:
diagnose test authserver ldap ldap-ad nuser nuser
authenticate 'nuser' against 'ldap-ad' succeeded!
Group membership(s) - CN=nested3,OU=Testing,DC=Fortinet-FSSO,DC=COM
CN=Domain Users,CN=Users,DC=Fortinet-FSSO,DC=COM
CN=nested2,OU=Testing,DC=Fortinet-FSSO,DC=COM
CN=nested1,OU=Testing,DC=Fortinet-FSSO,DC=COM

The group nested3 is a member of the group nested2, which is a member of the group nested1.

Configuring LDAP dial-in using a member attribute
In this configuration, users defined in Microsoft AD can set up a VPN connection based on an attribute that is set to
TRUE, instead of their user group. You can activate the Allow Dialin property in AD user properties, which sets the
msNPAllowDialin attribute to TRUE. You can use this procedure for other member attributes as your system requires.
This configuration consists of the following steps:
1.
2.
3.
4.

Ensure that the AD server has the msNPAllowDialin attribute set to TRUE for the desired users.
Configure user LDAP member attribute settings.
Configure LDAP group settings.
Ensure that you configured the settings correctly.

To configure user LDAP member attribute settings:
config user ldap
edit "ldap_server"
set server "192.168.201.3"
set cnid "sAMAccountName"
set dn "DC=fortilabanz,DC=com,DC=au"
set type regular
set username "fortigate@sample.com"
set password ******
set member-attr "msNPAllowDialin"
next
end

To configure LDAP group settings:
config user group
edit "ldap_grp"
set member "ldap_server"
config match
edit 1
set server-name "ldap_server"
set group-name "TRUE"
next
end
next
end
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To ensure that you configured the settings correctly:
Users that are members of the ldap_grp user group should be able to authenticate. The following shows sample
diagnose debug output when the Allow Dial-in attribute is set to TRUE:
get_member_of_groups-Get the memberOf groups.
get_member_of_groups- attr='msNPAllowDialin', found 1 values
get_member_of_groups-val[0]='TRUE'
fnbamd_ldap_get_result-Auth accepted
fnbamd_ldap_get_result-Going to DONE state res=0
fnbamd_auth_poll_ldap-Result for ldap svr 192.168.201.3 is SUCCESS
fnbamd_auth_poll_ldap-Passed group matching

If the attribute is not set to TRUE but is expected, you may see the following output:
get_member_of_groups-Get the memberOf groups.
get_member_of_groups- attr='msNPAllowDialin', found 1 values
get_member_of_groups-val[0]='FALSE'
fnbamd_ldap_get_result-Auth accepted
fnbamd_ldap_get_result-Going to DONE state res=0
fnbamd_auth_poll_ldap-Result for ldap svr 192.168.201.3 is SUCCESS
fnbamd_auth_poll_ldap-Failed group matching

The difference between the two outputs is the last line, which shows passed or failed depending on whether the member
attribute is set to the expected value.

Configuring wildcard admin accounts
To avoid setting up individual admin accounts in FortiOS, you can configure an admin account with the wildcard option
enabled, allowing multiple remote admin accounts to match one local admin account. This way, multiple LDAP admin
accounts can use one FortiOS admin account.
Benefits include:
l

l

Fast configuration of the FortiOS admin account to work with your LDAP network, saving effort and avoiding
potential errors incurred when setting up multiple admin accounts
Reduced ongoing maintenance. As long as LDAP users belong to the same group and you do not modify the
wildcard admin account in FortiOS, you do not need to configure changes on the LDAP accounts. If you add or
remove a user from the LDAP group, you do not need to perform changes in FortiOS.

Potential issues include:
l

l

Multiple users may be logged in to the same account simultaneously. This may cause issues if both users make
changes simultaneously.
Security is reduced since multiple users have login access to the same account, as opposed to an account for each
user.

Wildcard admin configuration also applies to RADIUS. If configuring for RADIUS, configure the RADIUS server and
RADIUS user group instead of LDAP. When using the GUI, wildcard admin is the only remote admin account that does
not require you to enter a password on account creation. That password is normally used when the remote
authentication server is unavailable during authentication.
This example uses default values where possible. If a specific value is not mentioned, the example sets it to its default
value.
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To configure the LDAP server:
The important parts of this configuration are the username and group lines. The username is the domain administrator
account. The group binding allows only the GRP group access.
This example uses an example domain name. Configure as appropriate for your own network.
config user ldap
edit "ldap_server"
set server "192.168.201.3"
set cnid "sAMAccountName"
set dn "DC=example,DC=com,DC=au"
set type regular
set username "CN=Administrator,CN=Users,DC=example,DC=COM”
set password *
set group-member-check group-object
set group-object-filter (&
(objectcategory=group)member="CN=GRP,OU=training,DC=example,DC=COM"))
next
end

To configure the user group and add the LDAP server:
config user group
edit "ldap_grp"
set member "ldap_server"
config match
edit 1
set server-name "ldap_server"
set group-name "CN=GRP,OU=training,DC=example,DC=COM"
next
end
next
end
end
end
end

To configure the wildcard admin account:
config system admin
edit "test"
set remote-auth enable
set accprofile "super_admin"
set wildcard enable
set remote-group "ldap_grp"
next
end

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1200

User & Device

RADIUS Servers
Configuring RADIUS SSO authentication
A common RADIUS SSO (RSSO) topology involves a medium-sized company network of users connecting to the
Internet through the FortiGate and authenticating with a RADIUS server. The following describes how to configure
FortiOS for this scenario. The example makes the following assumptions:
l
l
l
l
l

VDOMs are not enabled.
The super_admin account is used for all FortiGate configuration.
A RADIUS server is installed on a server or FortiAuthenticator and uses default attributes.
BGP is used for any dynamic routing.
You have configured authentication event logging under Log & Report.

Example.com has an office with 20 users on the internal network who need access to the Internet. The office network is
protected by a FortiGate-60C with access to the Internet through the wan1 interface, the user network on the internal
interface, and all servers are on the DMZ interface. This includes an Ubuntu sever running FreeRADIUS. This example
configures two users:

User

Account

Pat Lee

plee@example.com

Kelly Green

kgreen@example.com

Configuring this example consists of the following steps:
1.
2.
3.
4.
5.
6.

Configure RADIUS.
Configure FortiGate interfaces.
Configure a RSSO agent.
Create a RSSO user group.
Configure security policies.
Test the configuration.

To configure RADIUS:
Configuring RADIUS includes configuring a RADIUS server such as FreeRADIUS on user's computers and configuring
users in the system. In this example, Pat and Kelly belong to the exampledotcom_employees group. After completing
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the configuration, you must start the RADIUS daemon. The users have a RADIUS client installed on their PCs that allow
them to authenticate through the RADIUS server.
For any problems installing FreeRADIUS, see the FreeRADIUS documentation.

To configure FortiGate interfaces:
You must define a DHCP server for the internal network, as this network type typically uses DHCP. The wan1 and dmz
interfaces are assigned static IP addresses and do not need a DHCP server. The following table shows the FortiGate
interfaces used in this example:

Interface

Subnet

Act as DHCP server

Devices

wan1

172.20.120.141

No

Internet service provider

dmz

10.11.101.100

No

Servers including
RADIUS server

internal

10.11.102.100

Yes: x.x.x.110-250

Internal user network

1. Go to Network > Interfaces.
2. Edit wan1:
Alias

Internet

Addressing Mode

Manual

IP/Network Mask

172.20.120.141/255.255.255.0

Administrative Access

HTTPS, SSH

Enable DHCP Server

Not selected

Comments

Internet

Administrative Status

Up

3. Click OK.
4. Edit dmz:
Alias

Servers

Addressing Mode

Manual

IP/Network Mask

10.11.101.100/255.255.255.0

Administrative Access

HTTPS, SSH, PING, SNMP

Enable DHCP Server

Not selected

Listen for RADIUS
Accounting Messages

Select

Comments

Servers

Administrative Status

Up
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5. Click OK.
6. Edit internal:
Alias

Internal network

Addressing Mode

Manual

IP/Network Mask

10.11.102.100/255.255.255.0

Administrative Access

HTTPS, SSH, PING

Enable DHCP Server

Select

Address Range

10.11.102.110 - 10.11.102.250

Netmask

255.255.255.0

Default Gateway

Same as Interface IP

Comments

Internal network

Administrative Status

Up

To create a RADIUS SSO agent:
1.
2.
3.
4.

Go to Security Fabric > Fabric Connectors. Click Create New.
Under SSO/Identity, select RADIUS Single Sign-On Agent.
Enable Use RADIUS Shared Secret. Enter the RADIUS server's shared secret.
Enable Send RADIUS Responses. Click OK.

To create a RADIUS SSO user group:
1.
2.
3.
4.

Go to User & Device > User Groups. Click Create New.
For Type, select RADIUS Single Sign-On (RSSO).
In RADIUS Attribute Value, enter the name of the RADIUS user group that this local user group represents.
Click OK.

Configuring security policies
The following security policies are required for RADIUS SSO:

Sequence
Number

From

To

Type

Schedule

Description

1

internal

wan1

RADIUS SSO

Business hours

Authenticate outgoing user
traffic

2

internal

wan1

Regular

Always

Allow essential network
services and VoIP

3

dmz

wan1

Regular

Always

Allow servers to access the
Internet
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Sequence
Number

From

To

Type

Schedule

Description

4

internal

dmz

Regular

Always

Allow users to access
servers

5

any

any

Deny

Always

Implicit policy denying all
traffic that has not been
matched

You must place the RADIUS SSO policy at the top of the policy list so that it is matched first. The only exception to this is
if you have a policy to deny access to a list of banned users. In this case, you must put that policy at the top so that the
RADIUS SSO does not mistakenly match a banned user or IP address.
You must configure lists before creating security policies.

Schedule
You must configure a business_hours schedule. You can configure a standard Monday to Friday 8 AM to 5 PM
schedule, or whatever days and hours covers standard work hours at the company.

Address groups
You must configure the following address groups:

Name

Interface

Address range included

internal_network

internal

10.11.102.110 to 10.11.102.250

company_servers

dmz

10.11.101.110 to 10.11.101.250

Service groups
You must configure the service groups. The services listed are suggestions and you may include more or less as
required:

Name

Interface

Description of services to be
included

essential_network_services

internal

Any network protocols required for normal
network operation such as DNS, NTP,
BGP

essential_server_services

dmz

All the protocols required by the company
servers such as BGP, HTTP, HTTPS, FTP,
IMAP, POP3, SMTP, IKE, SQL, MYSQL,
NTP, TRACEROUTE, SOCKs, and SNMP

user_services

internal

Any protocols required by users such as
HTTP, HTTPS, FTP
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The following security policy configurations are basic and only include logging and default AV and IPS. These policies
allow or deny access to non-RADIUS SSO traffic. These are essential as network services including DNS, NTP, and
FortiGuard require access to the Internet.

To configure security policies:
1. Go to Policy & Objects > IPv4 Policy. Click Create New.
2. Configure the policy as follows, then click OK:
Incoming Interface

Internal

Source Address

internal_network

Outgoing Interface

wan1

Destination Address

all

Schedule

always

Service

essential_network_services

Action

ACCEPT

NAT

ON

Security Profiles

ON: AntiVirus, IPS

Log Allowed Traffic

ON

Comments

Essential network services

3. Click Create New, and configure the new policy as follows, then click OK:
Incoming Interface

dmz

Source Address

company_servers

Outgoing Interface

wan1

Destination Address

all

Schedule

always

Service

essential_server_services

Action

ACCEPT

NAT

ON

Security Profiles

ON: AntiVirus, IPS

Log Allowed Traffic

enable

Comments

Company servers accessing the Internet

4. Click Create New, and configure the new policy as follows, then click OK:
Incoming Interface

Internal

Source Address

internal_network
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Outgoing Interface

dmz

Destination Address

company_servers

Schedule

always

Service

all

Action

ACCEPT

NAT

ON

Security Profiles

ON: AntiVirus, IPS

Log Allowed Traffic

enable

Comments

Access company servers

5. Click Create New, and configure the RADIUS SSO policy as follows, then click OK. This policy allows access for
members of specific RADIUS groups.
Incoming Interface

Internal

Source Address

internal_network

Source User(s)

Select the user groups that you created for RSSO.

Outgoing Interface

wan1

Destination Address

all

Schedule

business_hours

Service

ALL

Action

ACCEPT

NAT

ON

Security Profiles

ON: AntiVirus, Web Filter, IPS, and Email Filter. In each case, select the
default profile.

6. Place the RSSO policy higher in the security policy list than more general policies for the same interfaces. Click OK.

To test the configuration:
Once configured, a user only needs to log in to their PC using their RADIUS account. After that, when they attempt to
access the Internet, the FortiGate uses their session information to get their RADIUS information. Once the user is
verified, they can access the website.
1. The user logs on to their PC and tries to access the Internet.
2. The FortiGate contacts the RADIUS server for the user's information. Once confirmed, the user can access the
Internet. Each step generates logs that enable you to verify that each step succeeded.
3. If a step does not succeed, confirm that your configuration is correct.
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RSA ACE (SecurID) servers
SecurID is a two-factor system produced by the company RSA that uses one-time password (OTP) authentication. This
system consists of the following:
l
l
l

Portable tokens that users carry
RSA ACE/Server
Agent host (the FortiGate)

When using SecurID, users carry a small device or "token" that generates and displays a pseudo-random password.
According to RSA, each SecurID authenticator token has a unique 64-bit symmetric key that is combined with a powerful
algorithm to generate a new code every 60 seconds. The token is time-synchronized with the SecurID RSA ACE/Server.
The RSA ACE/Server is the SecurID system's management component. It stores and validates the information about the
SecurID tokens allowed on your network. Alternately, the server can be an RSA SecurID 130 appliance.
The agent host is the server on your network. In this case, this is the FortiGate, which intercepts user logon attempts.
The agent host gathers the user ID and password entered from the SecurID token and sends the information to the RSA
ACE/Server for validation. If valid, the RSA ACE/Server returns a reply indicating that it is a valid logon and FortiOS
allows the user access to the network resources specified in the associated security policy.
Configuring SecurID with FortiOS consists of the following:
1. Configure the RSA and RADIUS servers to work with each other. See RSA server documentation.
2. Do one of the following:
a. Configure the RSA SecurID 130 appliance.
b. Configure the FortiGate as an agent host on the RSA ACE/Server.
3. Configure the RADIUS server in FortiOS.
4. Create a SecurID user group.
5. Create a SecurID user.
6. Configure authentication with SecurID.
The following instructions are based on RSA ACE/Server 5.1 and RSA SecurID 130 appliance. They assume that you
have successfully completed all external RSA and RADIUS server configuration.
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In this example, the RSA server is on the internal network and has an IP address of 192.128.100.000. The FortiOS
internal interface address is 192.168.100.3. The RADIUS shared secret is fortinet123, and the RADIUS server is at IP
address 192.168.100.202.

To configure the RSA SecurID 130 appliance:
1. Log on to the SecurID IMS console.
2. Go to RADIUS > RADIUS clients, then select Add New.

Setting

Description

RADIUS Client Basics
Client Name

FortiGate

Associated RSA Agent

FortiGate

RADIUS Client Settings
IP Address

Enter the FortiOS internal interface. In this example, it is 192.168.100.3.

Make / Model

Select Standard Radius.

Shared Secret

Enter the RADIUS shared secret. In this example, it is fortinet123.

Accounting

Leave unselected.

Client Status

Leave unselected.

3. Configure your FortiGate as a SecurID client:
4. Click Save.

To configure the FortiGate as an agent host on the RSA ACE/Server:
1. On the RSA ACE/Server, go to Start > Programs > RSA ACE/Server, then Database Administration - Host Mode.
2. From the Agent Host menu, select Add Agent Host.
3. Configure the following:

Setting

Description

Name

FortiGate

Network Address

Enter the FortiOS internal interface. In this example, it is 192.168.100.3.

Secondary Nodes

You can optionally enter other IP addresses that resolve to the FortiGate.

For more information, see the RSA ACE/Server documentation.
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To configure the RADIUS server in FortiOS:
1. Go to User & Device > RADIUS Servers, then click Create New.
2. Configure the following:

Setting

Description

Name

RSA

Authentication method

Select Default.

Primary Server
IP/Name

192.168.100.102. You can click Test to ensure the IP address is correct and
that FortiOS can contact the RADIUS server.

Secret

fortinet123

3. Click OK.

To create a SecurID user group:
1. Go to User & Device > User Groups. Click Create New.
2. Configure the following:

Setting

Description

Name

RSA_group

Type

Firewall

3. In Remote Groups, click Add, then select the RSA server.
4. Click OK.

To create a SecurID user:
1. Go to User & Device > User Definition. Click Create New.
2. Configure the following:

Setting

Description

User Type

Remote RADIUS User

Type

wloman

RADIUS Server

RSA

Contact Info

(Optional) Enter email or SMS information.

User Group

RSA_group

3. Click Create.
You can test the configuration by entering the diagnose test authserver radius RSA auto wloman
111111111 command. The series of 1s is the OTP that your RSA SecurID token generates that you enter for access.
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Configuring authentication with SecurID
You can use the SecurID user group in several FortiOS features that authenticate by user group:
l
l
l
l

Security policy on page 1210
IPsec VPN XAuth on page 1210
PPTP VPN on page 1211
SSL VPN

Unless stated otherwise, the following examples use default values.

Security policy
The example creates a security policy that allows HTTP, FTP, and POP3 traffic from the internal interface to WAN1. If
these interfaces are not available in FortiOS, substitute other similar interfaces.

To configure a security policy with SecurID authentication:
1. Go to Policy & Objects > IPv4 Policy.
2. Click Create New.
3. Configure the following:

Setting

Description

Incoming Interface

internal

Source Address

all

Source User(s)

RSA_group

Outgoing Interface

wan1

Destination Address

all

Schedule

always

Service

HTTP, FTP, POP3

Action

ACCEPT

NAT

On

Shared Shaper

If you want to limit traffic or guarantee minimum bandwidth for traffic that uses
the SecurID security policy, enable and use the default shaper, guarantee100kbps.

Log Allowed Traffic

Enable if you want to generate usage reports on traffic that this policy has
authenticated.

4. Click OK.

IPsec VPN XAuth
In VPN > IPsec Wizard, select the SecurID user group on the Authentication page. The SecurID user group members
must enter their SecurID code to authenticate.
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PPTP VPN
When configuring PPTP in the CLI, set usrgrp to the SecurID user group.

SSL VPN
You must map the SecurID user group to the portal that will serve SecurID users and include the SecurID user group in
the security policy's Source User(s) field.

To map the SecurID group to an SSL VPN portal:
1. Go to VPN > SSL-VPN Settings.
2. Under Authentication/Portal Mapping, click Create New.
3. Configure the following:

Setting

Description

Users/Groups

RSA_group

Portal

Select the desired portal.

4. Click OK.

TACACS+ Servers
TACACS+ is a remote authentication protocol that provides access control for routers, network access servers, and
other network devices through one or more centralized servers.
FortiOS sends the following proprietary TACACS+ attributes to the TACACS+ server during authorization requests:

Attribute

Description

service=<name>

User must be authorized to access the specified service.

memberof

Group that the user belongs to.

admin_prof

Administrator profile (admin access only).

Only memberof and admin_prof attributes are parsed in authentication replies.

You can configure up to ten remote TACACS+ servers in FortiOS. You must configure at least one server before you can
configure remote users.

A TACACS+ server must first be added in the CLI to make the option visible in the GUI.
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To configure TACACS+ authentication in the CLI:
1. Configure the TACACS+ server entry:
config user tacacs+
edit "TACACS-SERVER"
set server <IP address>
set key <string>
set authen-type ascii
set source-ip <IP address>
next
end

2. Configure the remote user group:
config user group
edit "TACACS-GROUP"
set group-type firewall
set member "TACACS-SERVER"
next
end

3. Configure the remote user:
config system admin
edit TACACS-USER
set remote-auth enable
set accprofile "super_admin"
set vdom "root"
set wildcard enable
set remote-group "TACACS-GROUP"
next
end

To configure a TACACS+ server in the GUI:
1. Go to User & Device > TACACS+ Servers.
2. Click Create New.
3. Configure the following settings:
Name

Enter the TACACS+ server name.

Authentication Type

Select the authentication type used for the TACACS+ server.
Selecting Auto tries PAP, MSCHAP, and CHAP, in that order.

Server IP/Name

Enter the domain name or IP address for the primary server.

Server Secret

Enter the key to access the primary server.

4. Click OK.

Authentication Settings
You can configure general authentication settings, including timeout, protocol support, and certificates.
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You cannot customize FTP and Telnet authentication replacement messages.

To configure authentication settings using the GUI:
1. Go to User & Device > Authentication Settings.
2. Configure the following settings:

Setting

Description

Authentication Timeout

Enter the desired timeout in minutes. You can enter a number between 1 and
1440 (24 hours). The authentication timeout controls how long an
authenticated connection can be idle before the user must reauthenticate. The
default value is 5.

Protocol Support

Select the protocols to challenge during firewall user authentication.
When you enable user authentication within a security policy, the
authentication challenge is normally issued for any of four protocols,
depending on the connection protocol:
l HTTP (you can set this to redirect to HTTPS)
l HTTPS
l FTP
l Telnet
The protocols selected here control which protocols support the authentication
challenge. Users must connect with a supported protocol first so they can
subsequently connect with other protocols. If HTTPS is selected as a protocol
support method, it allows the user to authenticate with a customized local
certificate.
When you enable user authentication within a security policy, FortiOS
challenges the security policy user to authenticate. For user ID and password
authentication, the user must provide their username and password. For
certificate authentication (HTTPS or HTTP redirected to HTTPS only), you can
install customized certificates on the unit and the user can also install
customized certificates on their browser. Otherwise, users see a warning
message and must accept a default Fortinet certificate. The network user's
web browser may deem the default certificate invalid.

Certificate

If using HTTPS protocol support, select the local certificate to use for
authentication. This is available only if HTTPS and/or Redirect HTTP
Challenge to a Secure Channel (HTTPS) are selected.

To configure authentication settings using the CLI:
config
set
set
set
end

user setting
auth-timeout 5
auth-type ftp http https telnet
auth-cert Fortinet_Factory
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FortiTokens
FortiToken is a disconnected one-time password (OTP) generator. It is a small physical device with a button that when
pressed displays a six digit authentication code. This code is entered with a user’s username and password as twofactor authentication. The code displayed changes every 60 seconds, and when not in use the LCD screen is blank to
extend the battery life.
You can attach a lanyard to the FortiToken and wear it around your neck, or store it with other electronic devices. Do not
put the FortiToken on a key ring as the metal ring and other metal objects can damage it.
Any time information about the FortiToken is transmitted, it is encrypted. When the FortiGate receives the code that
matches a particular FortiToken's serial number, it is delivered and stored encrypted.
The following illustrates the FortiToken two-factor authentication process:
1. The user attempts to access a network resource.
2. FortiOS matches the traffic to an authentication security policy and prompts the user for their username and
password.
3. The user enters their username and password.
4. FortiOS verifies their credentials. If valid, it prompts the user for the FortiToken code.
5. The user views the current code on their FortiToken. They enter the code at the prompt.
6. FortiOS verifies the FortiToken code. If valid, it allows the user access to network resources.
If the FortiToken has drifted, the following must take place for the FortiToken to resynchronize with FortiOS:
1. FortiOS prompts the user to enter a second code to confirm.
2. The user gets the next code from the FortiToken. They enter the code at the prompt.
3. FortiOS uses both codes to update its clock to match the FortiToken.
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If you attempt to add invalid FortiToken serial numbers, there is no error message. FortiOS
does not add invalid serial numbers to the list.

Recipes about FortiTokens include the following:
l
l
l
l
l

Configuring FortiTokens on page 1215
FortiToken Cloud on page 1218
Configuring FortiToken Mobile on page 1219
FortiToken Mobile Push on page 1221
FortiToken maintenance on page 1221

Configuring FortiTokens
Configuring FortiTokens consists of the following steps:
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1. Add FortiTokens to FortiOS.
2. Activate FortiTokens.
3. Associate FortiTokens with user accounts.

Adding FortiTokens to FortiOS
You can add FortiTokens to FortiOS in the following ways:
l
l
l
l

Add FortiToken serial numbers/activation codes using the GUI
Add FortiToken serial numbers/activation codes using the CLI
Import FortiTokens using a serial number or seed file using the GUI
Import FortiTokens from an external source using the CLI
FortiToken Mobile and physical FortiTokens store their encryption seeds on the cloud. You
can only register them to a single FortiGate or FortiAuthenticator.
Because FortiToken-200CD seed files are stored on the CD, you can register these tokens on
multiple FortiGates and/or FortiAuthenticators, but not simultaneously.

To manually add single FortiTokens to FortiOS:
1.
2.
3.
4.

Go to User & Device > FortiTokens.
Click Create New.
For Type, select Hard Token or Mobile Token.
In the Serial Number field, enter one or more FortiToken serial numbers (for hard tokens) or activation codes (for
mobile tokens). FortiToken Mobile activation codes are included in the license certificate after you purchase a
license. FortiOS includes a license for two mobile tokens.
5. Click OK.

To add multiple FortiTokens to FortiOS using the CLI:
config user fortitoken
edit <serial_number>
next
edit <serial_number2>
next
end

To import multiple FortiTokens to FortiOS using the GUI:
1.
2.
3.
4.
5.
6.
7.
8.

Go to User & Device > FortiTokens.
Click Create New.
For Type, select Hard Token.
Click Import.
Select Serial Number File or Seed File.
Click Upload.
Browse to the file's location on your local machine, select the file, then click OK.
Click OK.
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To import multiple FortiTokens to FortiOS from an external source using the CLI:
You can import physical and mobile FortiToken seed files from a FTP or TFTP server or USB drive.
execute fortitoken import ftp <file name> <ip>[:ftp port] <Enter> <user> <password>
execute fortitoken import tftp <file name> <ip>
execute fortitoken import usb <file name>

To import FortiToken Mobile seed files, replace fortitoken with fortitoken-mobile.

Activating FortiTokens
You must activate the FortiTokens. During activation, FortiOS queries FortiGuard servers about each FortiToken's
validity. FortiOS encrypts the serial number and information before sending for added security. FortiOS requires
connection to FortiGuard servers for FortiToken activation.

To activate a FortiToken using the GUI:
1.
2.
3.
4.

Go to User & Device > FortiTokens.
Select the desired FortiTokens that have an Available status.
Right-click the FortiToken entry, then select Activate.
Click Refresh. The selected FortiTokens' statuses change to Activated.

To activate a FortiToken using the CLI:
config user fortitoken
edit <token_serial_num>
set status activate
next
end

Associating FortiTokens with user accounts
You can associate FortiTokens with local user or administrator accounts.

To associate a FortiToken to a local user account using the GUI:
1.
2.
3.
4.
5.
6.

Ensure that you have successfully added your FortiToken serial number to FortiOS and that its status is Available.
Go to User & Device > User Definition. Edit the desired user account.
In the Email Address field, enter the user's email address.
Enable Two-factor Authentication.
From the Token dropdown list, select the desired FortiToken serial number.
Click OK.
For a mobile token, click Send Activation Code to send the activation code to the configured
email address. The user uses this code to activate their mobile token. You must have
configured an email service in System > Advanced to send the activation code.
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To associate a FortiToken to a local user account using the CLI:
config user local
edit <username>
set type password
set passwd "myPassword"
set two-factor fortitoken
set fortitoken <serial_number>
set email-to "username@example.com"
set status enable
next
end

To associate a FortiToken to an administrator account using the GUI:
1. Ensure that you have successfully added your FortiToken serial number to FortiOS and that its status is Available.
2. Go to System > Administrators. Edit the admin account. This example assumes that the account is fully configured
except for two-factor authentication.
3. In the Email Address field, enter the administrator's email address.
4. Enable Two-factor Authentication.
5. From the Token dropdown list, select the desired FortiToken serial number.
6. Click OK.
For a mobile token, click Send Activation Code to send the activation code to the configured
email address. The admin uses this code to activate their mobile token. You must have
configured an email service in System > Advanced to send the activation code.

To associate a FortiToken to an administrator account using the CLI:
config system admin
edit <username>
set password "myPassword"
set two-factor fortitoken
set fortitoken <serial_number>
set email-to "username@example.com"
next
end

The fortitoken keyword is not visible until you select fortitoken for the two-factor option.

Before you can use a new FortiToken, you may need to synchronize it due to clock drift.

FortiToken Cloud
Centralized token authentication is available in the cloud, as opposed to built into FortiGate or FortiAuthenticator,
simplifying FortiToken management and provisioning.
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To configure centralized token authentication in the cloud on the FortiGate:
1. Enable the FortiToken cloud service feature:
config system global
set fortitoken-cloud-service enable
end

2. Assign the token to local users or administrators using the fortitoken-cloud option:
config user local
edit "test-cl3"
set type password
set two-factor fortitoken-cloud
set email-to .........
...
next
end

The following commands can be used to manage FortiCloud users:

Command

Description

diagnose ftk-cloud show users

Show all current users on the FortiToken Cloud server.

diagnose ftk-cloud delete user
<username>

Delete the specified user from FortiToken Cloud.

diagnose ftk-cloud sync

Update the information on the FortiToken Cloud server after changing an email
address or phone number on the FortiGate.

diagnose ftk-cloud server
<server_ip>

Change the current FortiToken Cloud server. All FortiToken Cloud related
operations on the FortiGate will be synchronized with the new server.

Configuring FortiToken Mobile
FortiToken Mobile is an OATH compliant, event-based and time-based OTP generator for mobile devices. FortiToken
Mobile produces its OTP codes in an application that you can download onto your Android or iOS mobile device without
the need for a physical token.
FortiToken Mobile allows you to install multiple tokens for multi-factor authentication (MFA).
You can download the free FortiToken Mobile application for Android from the Google Play store, and for iOS from the
Apple App Store.
After your system administrator assigns your token, you receive a notification with an activation code and expiry date via
SMS or email. If you do not activate your token by the expiry date, you must contact your system administrator so that
they can reassign your token for activation.
The following instructions describe procedures when using FortiToken Mobile for iOS on an iPhone. Procedures may
vary depending on your device and OS.

To activate a Fortinet or third-party token:
1. On your device, open FortiToken Mobile. If this is your first time opening the application, it may prompt you to create
a PIN for secure access to the application and tokens.
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2. Do one of the following:
a. If you received your notification via email, select + and use the device camera to scan the token QR code in
your email.

b. If you received your notification via SMS, select Enter Manually, then select Fortinet or Other to add the token
as a third-party token. In the Name field, enter your email address. In the Key field, enter the activation key.
Select Done.

3. FortiToken Mobile provisions and activates your token and generates token codes immediately. To view the OTP's
digits, select the eye icon. After you open the application, FortiToken Mobile generates a new six-digit OTP every 30
seconds. All configured tokens display on the app's homescreen.

The MFA process commonly involves:
l Something you know: User password
l Something you have: The FortiToken OTP
A third factor of authentication may also be added to the authentication process:
l Something you are: Your fingerprint or face

To use FortiToken Mobile tokens:
1.
2.
3.
4.

Open FortiToken Mobile.
Tap and hold on the OTP code to copy the OTP.
Go to where you need to present the token's OTP, such as the FortiClient VPN client or an online portal page.
Paste the OTP and log in to pass the 2FA authentication process.
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FortiToken maintenance
To change a FortiToken's status:
config user fortitoken
edit <token_serial_num>
set status <active | lock>
next
end

A user who attempts to log in using a locked FortiToken cannot authenticate.

To list the drift on all configured FortiTokens:
diagnose fortitoken info
FORTITOKEN DRIFT STATUS
FTK2000BHV1KRZCC 0 token already activated, and seed won't be returned
FTK2001C5YCRRVEE 0 token already activated, and seed won't be returned
FTKMOB4B94972FBA 0 provisioned
FTKMOB4BA4BE9B84 0 new
Total activated token: 0
Total global activated token: 0
Token server status: reachable

This command lists the serial number and drift for each configured FortiToken. You can check if it is necessary to
synchronize the FortiGate and any particular FortiTokens.

FortiToken Mobile Push
You can configure the FortiToken Mobile Push services IP address and port number. Apple (APNS) and Google (GCM)
provide the Push service for iPhone and Android, respectively. This helps to avoid locking tokens after disabling an
already enabled two-factor authentication user.
config system ftm-push
set server-ip <ip-address>
set server-port [1-65535]
end

The default server port is 4433.
The server IP address is the public IP address of the FortiOS interface that the FTM calls back to. FortiOS uses this IP
address for incoming FTM calls.
If an SSL VPN user authenticates with their token, then logs out and attempts to reauthenticate within a minute, a Please
wait x seconds to login again message displays. This replaces a previous error/permission denied message. The x value
depends on the calculation of how much time is left in the current time step.
config system interface
edit <name>
set allowaccess ftm
next
end

FortiOS supports FortiAuthenticator-initiated FTM Push notifications for users attempting to
authenticate through a VPN and/or RADIUS (with FortiAuthenticator as the RADIUS server).
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SAML
Security Assertion Markup Language (SAML) is an open standard for exchanging authentication and authorization data
between one Identity Provider (IdP) and one or more Service Providers (SP). Both parties exchange messages using the
XML protocol as transport. FortiGate firewall devices can be configured as both IdP or SP.
When Security Fabric is enabled, you can configure the root FortiGate as the IdP. You can also configure downstream
FortiGates to be automatically configured as SPs, with all links required for SAML communication, when added to the
Security Fabric. Administrator must still be authorized on each device. Credentials are verified by the root FortiGate, and
login credentials are shared between devices. Once authorized, an administrator can move between fabric devices
without logging in again.
Optionally, the downstream FortiGate can also be manually configured as an SP, and then linked to the root FortiGate.
The authentication service is provided by the root FortiGate using local system admin accounts for authentication. Any of
the administrator account types can be used for SAML log in. After successful authentication, the administrator logs in to
the first downstream FortiGate SP, and can then connect to other downstream FortiGates that have the SSO account
properly configured, without needing to provide credentials again, as long as admins use the same browser session. In
summary, the root FortiGate IdP performs SAML SSO authentication, and individual device administrators define
authorization on FortiGate SPs by using security profiles.

SAML SSO overview
SAML SSO enables a single FortiGate device to act as the Identify Provider (IdP), while other FortiGate devices act as
Service Providers (SP) and redirect logins to the IdP.
All administrators must be actively added to each SP. When an administrator first logs in to an SP, a temporary account
is created with the no access profile assigned, and the device administrator must enable access for each account on
each device.

Following is an overview of the process:
1.
2.
3.
4.
5.
6.

Configuring a FortiGate as the IdP on page 1223.
Configuring FGT_B as an SP on page 1223.
Creating a new system administrator on the IdP (FGT_A) on page 1224
Logging in to FGT_B using SSO on page 1224.
Granting permissions to new SSO administrator accounts on page 1225.
Logging in to FGT_B again using SSO on page 1227.

You can also use the CLI. See CLI commands for SAML SSO on page 1227.
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Configuring a FortiGate as the IdP
To configure a FortiGate as the IdP:
1.
2.
3.
4.
5.

Log in to the FortiGate with the device administrator account.
Go to User & Device > SAML SSO.
Set the Mode to Identity Provider (IdP).
Configure the IdP address and certificate.
Add an SP:
a. In the Service Providers table, click Create New.
b. Enter the SP name, prefix, type, and address. Copy the prefix, as you need it when configuring the SP.
c. Configure other settings as needed.
d. Click OK.

6. Click Apply.

Configuring FGT_B as an SP
To configure FGT_B as an SP:
1.
2.
3.
4.
5.

Log in to FGT_B with the device administrator account.
Go to User & Device > SAML SSO.
Set the Mode to Service Provider (SP).
Configure the SP address.
Configure the IdP settings:
a. Set IdP type to Fortinet Product.
b. Enter the IdP address, as configured on FGT_A.
c. Enter the prefix copied from FGT_A.
d. Select the same certificate as used on FGT_A.
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6. Click Apply.

Creating a new system administrator on the IdP (FGT_A)
To create a new system administrator on the IdP (FGT_A):
1.
2.
3.
4.
5.

Log in to FGT_A with the device administrator account.
Go to System > Administrators.
Create a new administrator.
Set the Type to Local User.
Configure the other settings as needed.

6. Click OK.

Logging in to FGT_B using SSO
When the administrator logs in to the FortiGate for the first time by using the SSO option, a local SAML SSO account is
automatically created on the FortiGate SP.
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To log in to FGT_B using Single Sign-On:
1. At the FGT_B login prompt, click or via Single Sign-On.

The SSO log in prompt opens.
2. Enter the login information for the administrator that you just created on FGT_A.

3. Click Login.
A GUI warning opens.

As the account is using a restricted access profile, additional permissions must be granted by the device
administrator.
4. Click Logout.

Granting permissions to new SSO administrator accounts
By default, the SAML SSO account is assigned the no_access administrator profile. Device administrators must assign a
security profile to the SAML SSO account that allows access to the FortiGate SP.
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To grant permissions to the new SSO administrator account:
1. Log in to FGT_B with the device administrator account.
2. Go to System > Administrators.

The new Single Sign-On Administrator was automatically created when it logged in the first time.
3. Edit the new SSO admin, and change their Administrator Profile.

4. Click OK.
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Logging in to FGT_B again using SSO
To log in to FGT_B again using Single Sign-On:
1. At the FGT_B login prompt, click or via Single Sign-On. The SSO login prompt opens.
2. Enter the login information for the SSO administrator.

3. Click Login.
FGT_B is successfully logged into.

CLI commands for SAML SSO
To configure the IdP:
config system saml
set status enable
set role IDP
set cert "Fortinet_Factory"
set server-address "172.16.106.74"
config service-providers
edit "csf_172.16.106.74:12443"
set prefix "csf_ngczjwqxujfsbhgr9ivhehwu37fml20"
set sp-entity-id "http://172.16.106.74/metadata/"
set sp-single-sign-on-url "https://172.16.106.74/saml/?acs"
set sp-single-logout-url "https://172.16.106.74/saml/?sls"
set sp-portal-url "https://172.16.106.74/saml/login/"
config assertion-attributes
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edit "username"
next
edit "tdoc@fortinet.com"
set type email
next
end
next
end
end

To configure an SP:
config system saml
set status enable
set cert "Fortinet_Factory"
set idp-entity-id "http://172.16.106.74/saml-idp/csf_
ngczjwqxujfsbhgr9ivhehwu37fml20/metadata/"
set idp-single-sign-on-url "https://172.16.106.74/csf_
ngczjwqxujfsbhgr9ivhehwu37fml20/login/"
set idp-single-logout-url "https://172.16.106.74/saml-idp/csf_
ngczjwqxujfsbhgr9ivhehwu37fml20/logout/"
set idp-cert "REMOTE_Cert_1"
set server-address "172.16.106.74:12443"
end

To configure an SSO administrator:
config system sso-admin
edit "SSO-admin-name"
set accprofile <SSO admin user access profile>
set vdom <Virtual domain(s) that the administrator can access>
next
end

SAML SSO with pre-authorized FortiGates
You can set up SAML SSO authentication in a Security Fabric environment by starting with a root FortiGate that has one
or more pre-authorized FortiGates.
After the initial configuration, you can add more downstream FortiGates to the Security Fabric, and they are
automatically configured with default values for a Service Provider.
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To set up basic SAML for Security Fabric:
1. Log in to the root FortiGate of the Security Fabric.
2. Go to Security Fabric > Settings, and join two pre-authorized FortiGates to the root FortiGate.

3. Go to User & Device > SAML SSO.

4. Beside Mode, select Identity Provider (IdP).
5. In the IdP certificate list, select a valid local server certificate, and click Apply.
You can use one of the default Fortinet certificates, such as Fortinet_Factory, which is also the default server
certificate for FortiGate admin login over HTTPS. Alternatively you can use a customized server certificate issued
by a Company Root Certificate Authority (CA).
The following example shows a customized server certificate. Regardless of whether you use a default or custom
certificate, ensure that the downstream FortiGate SPs trust the issuing CA .
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6. Go to Security Fabric > Settings.
7. In the Topology area click a pre-authorized FortiGate, and select Customize.

The Customize pane appears on the right.
8. In the Customize pane, click Specify, and type an IP address in the Management IP/FQDN box and a management
port in the Management Port box, and then click OK.
This information is used to automatically configure SAML SSO on downstream FortiGates.
SAML requires that administrators can access the IP of each FortiGate by using a browser. The management
IP specifies the publicly (or internally) accessible IP that the administrator can access by using a browser.
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9. Go to User & Device > SAML SSO, and select Identify Provider (IdP) to verify the new SAML SSO configuration on
the root FortiGate IdP for downstream FortiGate SPs.

10. Select Service Provider (SP) to verify the configuration for downstream FortiGates.

The Default login page option is set to Normal by default, which means that admin login screen on this FortiGate
offers options for local system admin login and SAML SSO login.
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In the Default admin profile option, you can select one of the preconfigured profiles that gives access to FortiGate.
Alternately you can create a custom profile and select it. The default profile admin_no_access must be changed
later for every SSO admin.
In the IdP Settings area, the IdP certificate option uses the REMOTE_CERT_1 as the server certificate for the root
FortiGate.
In the SP certificate option, you can optionally select a server certificate to be used by downstream FortiGates as
client certificates when connecting to the root FortiGate. For the root FortiGate, you can select a default Fortinet
server certificate or a custom certificate.

Manual SAML SSO configuration
You can manually configure SAML SSO on FortiGate IdP and FortiGate SPs. It requires the following tasks:
1. Manually configure SAML SSO on the root FortiGate IdP.
2. Manually configure SAML SSO on FortiGate SPs.
In this case the FortiGate SP is not a member of the Security Fabric. Although the FortiGate SP is not part of the Security
Fabric, it will use the root FortiGate IdP for SAML SSO authentication.
On the root FortiGate IdP, you can see the difference between a FortiGate SP that joined the Security Fabric and
another FortiGate SP (FGT-184) that is not part of the Security Fabric:
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To manually configure SAML SSO on the root FortiGate IdP:
1. Go to User & Device > SAML SSO, and click Identity Provider (IdP).
2. click Create New.

3. In the Name box, type a descriptive name.
4. Copy the Prefix to the clipboard to use later when you configure FortiGate SPs.
The Prefix box is automatically populated with a unique value. A prefix is required when manually configuring
SAML SSO on FortiGate SP. The root FortiGate IdP uses the Prefix value to track the status of multiple,
downstream FortiGates.
5. In the SP address box, type an IP address.
The browser used by the SSO administrator must be able to reach the IP. You can add a specific port to the IP.
Separate the IP address and port number with a colon, for example, 172.18.60.185:8443.
The SP certificate toggle is optional. When enabled, the FortiGate SP requires a server certificate that is trusted by
the root FortiGate IdP.
6. Toggle on SAML Attribute.
7. Beside Type, select Username.
8. Click OK.

To manually configure SAML SSO on FortiGate SPs:
1. Go to User & Device > SAML SSO, and click Service Provider (SP).
The SP options are displayed.

2. In the SP address box, type an IP address.
This must be the same IP address that you specified on the FortiGate IdP.
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The SP certificate toggle is optional. When enabled, you must provide a local server certificate that is trusted by the
root FortiGate IdP.
The Default login page option is set to Normal by default. With the normal setting, administrators can choose
between local system administrator login or SAML SSO login on FortiGate SPs. When you select Single Sign On,
administrators can no longer log in to the GUI in a browser by using a local system administrator account.
The Default admin profile option is set to admin_no_access by default. You can change the setting to any of the
other default profiles available on the FortiGate or a custom profile created by a local administrator on the FortiGate
SP.
3. Beside IdP type, select Fortinet Product.

You can select Custom when you want to change the default settings for IdP single-sign-on URL and IdP single
logout URL, for example:

4. In the Prefix option paste the value from the Prefix option on the root FortiGate IdP.
5. In IdP certificate option, select the server certificate from the FortiGate IdP.
If the certificate is not available locally on the FortiGate SP, you must click + Import the FortiGate IdP server
certificate as REMOTE_CERT from local file system.
6. Click OK.

Navigating between Security Fabric members with SSO
After you have logged in to a Security Fabric member by using SSO, you can navigate between any Security Fabric
member with SSO configured.

To navigate between Security Fabric members:
1. Log in to a Security Fabric member by using SSO.
2. In the top banner, click the name of the device you are logged into with SSO.
A list of Security Fabric members is displayed.
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3. Click the Security Fabric member.
You are logged in to the Security Fabric member without further authentication.

Logging in to a FortiGate SP from root FortiGate IdP
You can log in to a FortiGate SP from a FortiGate IdP. This topic describes how to log in to a root FortiGate IdP, and
navigate to other FortiGate SPs in the Security Fabric without further authentication.
In this example, the local administrator account is named test3. The local administrator account must also be available
as an SSO administrator account on all downstream FortiGate SPs. Different tabs of the same browser are used to log in
to the various FortiGates.

To log in to a FortiGate SP from a root FortiGate IdP:
1. Log in to the root FortiGate IdP by using the local administrator account.
In this example, the local administrator account is named test3.
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2. Go to Security Fabric > Settings.

3. In the Topology area, click one of the downstream FortiGate SPs, and select Login to <name of FortiGate>.

The login screen is displayed.
4. In the login screen, select Single Sign-On.
By using cookies in your local browser for the already-authenticated SSO administrator, FortiGate logs you in to the
downstream FortiGate SP as the SSO administrator. In this example, the SSO administrator name is test3.
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5. While still logged into the root FortiGate IdP in your browser, go to the browser tab for the root FortiGate IdP, and log
in to another FortiGate SP that is displayed on the Security Fabric pane in the GUI.

SAML SSO login uses SAML_IDP session cookies of already authenticated admin users in your local browser
cache to send to root FGT IdP for authentication. If your browser cache is manually cleared, or you close your
browser, you must authenticate again.
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Logging in to a downstream FortiGate SP in another Security Fabric
This example describes how to log in to one downstream FortiGate SP in a Security Fabric, and then open another tab in
your browser to connect to another FortiGate SP that is not a member of the Security Fabric.

To log in to a downstream FortiGate SP in another Security Fabric:
1. Open a tab in a browser, and log in to a downstream FortiGate SP using your SSO administrator account.
In this example, the SSO administrator account is named test3.

2. Open a new tab in the browser, and log in to a FortiGate SP that is not a member of the Security Fabric, but uses the
root FortiGate IdP in the Security Fabric as the Identity Provider.
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Although the administrator named test3 on the root FortiGate IdP was used for authentication on both systems,
SSO administrator names on different FortiGate SPs can vary, depending on what was configured as the SAML
attribute type for the specific FortiGate SP on the root FortiGate IdP. This is useful in cases where the SSO
administrator and the local system administrator on the FortiGate SP both have the same login name, but are two
different entities.

Certificates for SAML SSO
Because communication between the root FortiGate IdP and FortiGate SPs is secured, you must select a local server
certificate for FortiGate IdP in the IdP certificate option. When a downstream FortiGate SP joins a root FortiGate IdP, the
FortiGate SP automatically obtains the certificate. In the following example, the IdP certificate displays REMOTE_
CERT_1, which is the root server certificate for the FortiGate IdP.

If you are manually configuring FortiGate SPs, you can download the certificate from the FortiGate IdP, and then import it
for use with the manual configuration of FortiGate SPs.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1239

User & Device

To download certificates from FortiGate IdPs:
1. On the root FortiGate IdP, go to User & Device > SAML SSO.
2. Click Identify Provider (IdP).

3. Beside IdP certificate, click Download.
The certificate is downloaded to the local file system.

To import IdP certificates to FortiGate SPs:
1. Go to User & Device > SAML SSO.
2. Click Service Provider (SP).
3. Import the downloaded certificate:
a. Beside IdP certificate, click the box, and select Import.
b. Click Upload, and select the certificate for the FortiGate IdP.
c. Click OK.
The certificate is imported.
4. In the IdP certificate list, select the certificate that you imported, and click Apply.

Unique SAML attribute types
The default SAML attribute type is username. When the attribute type is set to username, SSO administrator accounts
created on FortiGate SPs use the login username that is provided by the user for authentication on the root FortiGate
IdP.
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Because usernames might not be unique, cases can occur where the username is the same for the SSO administrator
and the local administrator on the FortiGate SP. As a result, you might be unable to distinguish between actions taken by
the local administrator and the SSO administrator on the FortiGate SP when looking at the system log. By using a unique
SAML attribute type, such as an email address, you can create unique usernames to better track what actions were
taken by each administrator.

To configure a unique SAML attribute using the GUI:
1. On FortiGate IdP, assign a unique email address to local administrator.
In this example, the local administrator name is test3.
a.
b.
c.
d.

Go to System > Administrators, and expand the list of local users.
Select the local user, and click Edit.
In the Type list, select Match a user on a remote server group.
In the Email Address box, type the email address, and click OK.

2. On FGT IdP, update the SAML configuration:
a. Go to User & Device > SAML SSO.
b. Select the FortiGate, and click Edit.
c. Beside SP type, select Custom.
d. Under SAML Attribute and beside Name, select username.
e. Beside Type, select Email address, and click OK.
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After the administrator (test3) logs in to FortiGate SP for the first time, SAML authentication occurs on FortiGate SP.
A new SSO administrator account is created, and the account name is the email address instead of the login name
(test3).

If the SAML attribute had been set to the default setting of username, the username for the SSO administrator
account would have been test3, which is the same username as the local administrator account. With the
SAML attribute set to custom, the SSO administrator account owahn@fortinet.com is used as the username on the
FortiGate SP, and it appears in the log files.

To configure a unique SAML attribute using the CLI:
config system saml
set status enable
set role identity-provider
set cert "fgt_g_san_extern_new"
set server-address "172.18.60.187"
config service-providers
edit "csf_172.18.60.185"
set prefix "csf_avju0tk4oiodifz3kbh2fms8dw688hn"
set sp-entity-id "http://172.18.60.185/metadata/"
set sp-single-sign-on-url "https://172.18.60.185/saml/?acs"
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set sp-single-logout-url "https://172.18.60.185/saml/?sls"
set sp-portal-url "https://172.18.60.185/saml/login/"
config assertion-attributes
edit "username"
next
end
next
edit "FGTA-180"
set prefix "yxs8uhq47b5b2urq"
set sp-entity-id "http://172.18.60.180/metadata/"
set sp-single-sign-on-url "https://172.18.60.180/saml/?acs"
set sp-single-logout-url "https://172.18.60.180/saml/?sls"
set sp-portal-url "https://172.18.60.180/saml/login/"
config assertion-attributes
edit "username"
next
end
next
edit "FGTA-184"
set prefix "3dktfo0gbxtldbts"
set sp-entity-id "http://172.18.60.184/metadata/"
set sp-single-sign-on-url "https://172.18.60.184/saml/?acs"
set sp-single-logout-url "https://172.18.60.184/saml/?sls"
set sp-portal-url "https://172.18.60.184/saml/login/"
config assertion-attributes
edit "username"
set type email
next
end
next
end
end

The csf_172.18.60.185 service provider was automatically added when FortiGate SP 172.18.60.185 joined root
FortiGate IdP in the Security Fabric.
All sp-* options, such as sp-portal-url, are set with default values when a service provider is created, but can be
modified by using the CLI or GUI.
A FortiGate SP that is not a member of the Security Fabric can also be configured for SAML SSO services provided by
root FortiGate IdP in a Security Fabric. However, this scenario requires manual configuration on root FortiGate IdP and
on the FortiGate SP.

FortiGate SP changes
From a root FortiGate IdP, you can edit each of the FortiGate SPs. For example, you can edit a FortiGate SP to generate
a new prefix, or you can add or modify SAML attributes. When you generate a new prefix value, it is propagated to the
respective downstream FortiGates.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1243

User & Device

Configuring the maximum log in attempts and lockout period
Failed log in attempts can indicate malicious attempts to gain access to your network. To prevent this security risk, you
can limit the number of failed log in attempts. After the configured maximum number of failed log in attempts is reached,
access to the account is blocked for the configured lockout period.

To configure number of maximum log in attempts:
This example sets the maximum number of log in attempts to five.
config user setting
set auth-lockout-threshold 5
end

To configure the lockout period in seconds:
This example sets the lockout period to five minutes (300 seconds).
config user setting
set auth-lockout-duration 300
end

Creating a PKI/peer user
A PKI/peer user is a digital certificate holder. A FortiOS PKI user account contains the information required to determine
which CA certificate to use to validate the user's certificate. You can include a peer user in a firewall user group or peer
certificate group used in IPsec VPN.
To define a peer user, you need the following:
l
l

Peer username
Text from the user's certificate's subject field, or the name of the CA certificate used to validate the user's certificate

To create a peer user for PKI authentication:
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config user peer
edit peer1
set subject peer1@mail.example.com
set ca CA_Cert_1
next
end

You can add or modify other configuration settings for PKI authentication, including configuring using an LDAP server to
check client certificate access rights. See the FortiOS CLI Reference.

Configuring firewall authentication

In this example, a Windows network is connected to the FortiGate on port 2, and another LAN, Network_1, is connected
on port 3.
All Windows network users authenticate when they log on to their network. Engineering and Sales groups members can
access the Internet without reentering their authentication credentials. The example assumes that you have already
installed and configured FSSO on the domain controller.
LAN users who belong to the Internet_users group can access the Internet after entering their username and password.
The example shows two users: User1, authenticated by a password stored in FortiOS; and User 2, authenticated on an
external authentication server. Both users are local users since you create the user accounts in FortiOS.
1.
2.
3.
4.
5.
6.

Create a locally authenticated user account.
Create a RADIUS-authenticated user account.
Create an FSSO user group.
Create a firewall user group.
Define policy addresses.
Create security policies.

Creating a locally authenticated user account
User1 is authenticated by a password stored in FortiOS.
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To create a locally authenticated user account in the GUI:
1. Go to User & Device > User Definition. Click Create New.
2. Configure the following settings:

Setting

Configuration

User Type

Local User

User Name

User1

Password

hardtoguess1@@1

User Account Status

Enabled

3. Click Submit.

To create a locally authenticated user account in the CLI:
config user local
edit user1
set type password
set passwd hardtoguess1@@1
next
end

Creating a RADIUS-authenticated user account
You must first configure FortiOS to access the external authentication server, then create the user account.

To create a RADIUS-authenticated user account in the GUI:
1. Go to User & Device > RADIUS Servers. Click Create New.
2. Configure the following settings:

Setting

Configuration

Name

OurRADIUSsrv

Authentication method

Default

Primary Server
IP/Name

10.11.101.15

Secret

OurSecret

3. Click OK.
4. Go to User & Device > User Definition. Click Create New.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1246

User & Device
5. Configure the following settings:

Setting

Configuration

User Type

Remote RADIUS User

User Name

User2

RADIUS Server

OurRADIUSsrv

User Account Status

Enabled

6. Click Submit.

To create a RADIUS-authenticated user account in the CLI:
config user radius
edit OurRADIUSsrv
set server 10.11.102.15
set secret OurSecret
set auth-type auto
next
end
config user local
edit User2
set name User2
set type radius
set radius-server OurRADIUSsrv
next
end

Creating an FSSO user group
This example assumes that you have already set up FSSO on the Windows network and that it used advanced mode,
meaning that it uses LDAP to access user group information. You must do the following:
l
l
l
l

Configure LDAP access to the Windows AD global catalog
Specify the collector agent that sends user logon information to FortiOS
Select Windows user groups to monitor
Select and add the Engineering and Sales groups to an FSSO user group

To create an FSSO user group in the GUI:
1. Configure LDAP for FSSO:
a. Go to User & Device > LDAP Servers. Click Create New.
b. Configure the following settings:

Setting

Configuration

Name

ADserver

Server Name / IP

10.11.101.160
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Setting

Configuration

Distinguished Name

dc=office,dc=example,dc=com

Bind Type

Regular

Username

cn=FSSO_Admin,cn=users,dc=office,dc=example,dc=com

Password

Enter a secure password.

c. Leave other fields as-is. Click OK.
2. Specify the collector agent for FSSO;
a. Go to Security Fabric > Fabric Connectors. Click Create New.
b. Under SSO/Identity, select Fortinet Single Sign-On Agent.
c. Configure the following settings:

Setting

Configuration

Name

Enter the Windows AD server name. This name appears in the Windows
AD server list when you create user groups. In this example, the name is
WinGroups.

Server IP/Name

Enter the IP address or name of the server where the agent is installed.
The maximum name length is 63 characters. In this example, the IP
address is 10.11.101.160.

Password

Enter the password of the server where the agent is installed. You only
need to enter a password for the collector agent if you configured the agent
to require authenticated access.
If the TCP port used for FSSO is not the default, 8000, you can run the
config user fsso command to change the setting in the CLI.

Collector Agent AD access
mode

Advanced

LDAP Server

Select the previously configured LDAP server. In this example, it is
ADserver.

User/Groups/Organization
Units

Select the users, groups, and OUs to monitor.

d. Click OK.
3. Create the FSSO_Internet_users user group:
a. Go to User & Device > User Groups. Click Create New.
b. Configure the following settings:

Setting

Configuration

Name

FSSO_Internet_users

Type

Fortinet Single Sign-On (FSSO)

Members

Engineering, Sales

c. Click OK.
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To create an FSSO user group in the CLI:
config user ldap
edit "ADserver"
set server "10.11.101.160"
set dn "cn=users,dc=office,dc=example,dc=com"
set type regular
set username "cn=administrator,cn=users,dc=office,dc=example,dc=com"
set password set_a_secure_password
next
end
config user fsso
edit "WinGroups"
set ldap-server "ADserver"
set password **********
set server "10.11.101.160"
next
end
config user group
edit FSSO_Internet_users
set group-type fsso-service
set member CN=Engineering,cn=users,dc=office,dc=example,dc=com
CN=Sales,cn=users,dc=office,dc=example,dc=com
next
end

Creating a firewall user group
This example shows a firewall user group with only two users. You can add additional members.

To create a firewall user group in the GUI:
1. Go to User & Device > User Groups. Click Create New.
2. Configure the following settings:

Setting

Configuration

Name

Internet_users

Type

Firewall

Members

User1, User2

3. Click OK.

To create a firewall user group in the CLI:
config user group
edit Internet_users
set group-type firewall
set member User1 User2
next
end
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Defining policy addresses
To define policy addresses:
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address.
3. Configure the following settings:

Setting

Configuration

Name

Internal_net

Type

Subnet

IP/Netmask

10.11.102.0/24

Interface

Port 3

4. Click OK.
5. Create another new address by repeating steps 2-4 using the following settings:

Setting

Configuration

Name

Windows_net

Type

Subnet

IP/Netmask

10.11.101.0/24

Interface

Port 2

Creating security policies
You must create two security policies: one for the firewall group connecting through port 3, and one for the FSSO group
connecting through port 2.

To create security policies using the GUI:
1. Go to Policy & Objects > IPv4 Policy.
2. Click Create New.
3. Configure the following settings:

Setting

Configuration

Incoming Interface

Port2

Source Address

Windows_net

Source User(s)

FSSO_Internet_users

Outgoing Interface

Port1

Destination Address

all
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Setting

Configuration

Schedule

always

Service

ALL

NAT

Enabled.

Security Profiles

You can enable security profiles as desired.

4. Click OK.
5. Create another new policy by repeating steps 2-4 using the following settings:

Setting

Configuration

Incoming Interface

Port3

Source Address

Internal_net

Source User(s)

Internet_users

Outgoing Interface

Port1

Destination Address

all

Schedule

always

Service

ALL

NAT

Enabled.

Security Profiles

You can enable security profiles as desired.

6. Click OK.

To create security policies using the CLI:
config firewall policy
edit 0
set srcintf port2
set dstintf port1
set srcaddr Windows_net
set dstaddr all
set action accept
set groups FSSO_Internet_users
set schedule always
set service ANY
set nat enable
next
end
config firewall policy
edit 0
set srcintf port3
set dstintf port1
set srcaddr internal_net
set dstaddr all
set action accept
set schedule always
set groups Internet_users
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set service ANY
set nat enable
next
end
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Wireless configuration
See the FortiWiFi and FortiAP Cookbook.
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Use the Switch Controller function, also known as FortiLink, to remotely manage FortiSwitch units. In the commonlyused layer 2 scenario, the FortiGate that is acting as a switch controller is connected to distribution FortiSwitch units. The
distribution FortiSwitch units are in the top tier of stacks of FortiSwitch units and connected downwards with Convergent
or Access layer FortiSwitch units. To leverage CAPWAP and the Fortinet proprietary FortiLink protocol, set up data and
control planes between the FortiGate and FortiSwitch units.
FortiLink allows administrators to create and manage different VLANs, and apply the full-fledged security functions of
FortiOS to them, such as 802.1X authentication and firewall policies. Most of the security control capabilities on the
FortiGate are extended to the edge of the entire network, combining FortiGate, FortiSwitch, and FortiAP devices, and
providing secure, seamless, and unified access control to users.

FortiLink setup
Go to WiFI & Switch Controller > FortiLink Interface to create or edit FortiLink interfaces. The available options depend
on the FortiGate model.
By automatically creating FortiLink interfaces as a logical aggregate or hard/soft switch, you can modify the FortiLink
interfaces. If the physical port in use changes, you don't need to migrate existing policies.
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To configure FortiLink interfaces:
1. Go to WiFi & Switch Controller > FortiLink Interface.

2. Configure the interface settings and click Apply.

FortiLink auto network configuration policy
The switch controller has a network auto-config option which contains configurable defaults, policy customization,
and an individual interface override. This gives administrators simple and flexible control.
Following is a description of these options:
auto-config
default

Provides the default actions for the first hop (fgt-policy) and lower-tier devices (islpolicy).

auto-config
policy

A database containing policies that can be applied as a system-wide default or to a specific
interface.

auto-config
custom

Allows for the override of the auto-config default on a specific interface. This
information is retained and is reapplied if an interface leaves and then is rediscovered.
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To configure automatic network detection:
1. Create or modify an auto-config policy:
config switch-controller auto-config policy
edit test123
get
name
: test123
qos-policy
: default
<== leverage the default qos-policy
storm-control-policy: auto-config <== leverage auto-config storm-control-policy
by default
poe-status
: enable
<== If target of auto-config is poe port,
keep poe-status enabled by default
next
end

2. Designate an auto-config policy to FortiLink, ISL, or ICL on managed FortiSwitches.
config switch-controller auto-config default
get
fgt-policy
: test123
isl-policy
: test123
icl-policy
: test123
set ?
fgt-policy
Default FortiLink auto-config policy.
isl-policy
Default ISL auto-config policy.
icl-policy
Default ICL auto-config policy.
end

3. Customize an auto-config policy for a specific FGT, ICL, or ISL interface.
config switch-controller auto-config custom
edit ?
*name
Auto-Config FortiLink or ISL/ICL interface name.
edit G5H0E391790XXXX
new entry 'G5H0E391790XXXX' added
config switch-binding
edit ?
*switch-id
Switch name.
edit S524DN4K1500XXXX
new entry 'S524DN4K1500XXXX' added
get
switch-id
: S524DN4K1500XXXX
policy
: default
next
end
next
end

FortiLink network sniffer extension
The switch controller has a traffic-sniffer option to provide a targeted approach where mirrored traffic is always
directed towards the FortiGate on a dedicated VLAN. This allows for easy sniffing by using the CLI or GUI. Also, the
traffic can be routed through the FortiGate using Encapsulated Remote Switched Port Analyzer (ERSPAN) for external
analysis and storage.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1256

Switch Controller

Use this option to define targeted sniffers by IP or MAC address. Traffic matching is replicated to the FortiGate, which is
helpful when you know what device you are looking for but don't know where it is located.
FortiLink networks can have multiple switches and traffic typically traverses several switches. If each switch mirrors any
match, the sniffer would see multiple copies of traffic. To reduce this, the targets are applied at the perimeter of the
FortiSwitch network. Traffic entering by a user port or traffic from FortiGate is considered eligible for mirroring.
You can also enable traditional port-based sniffers in the ingress or egress direction.
All sniffer traffic arrives at the FortiGate using ERSPAN and the traffic is encapsulated in generic routing encapsulation
(GRE).

You can only configure this feature using the CLI.

To use predefined sniffer-used switch VLAN interface:
config system interface
edit "snf.aggr1"
<---- Newly added pre-defined switch vlan interface. Created
automatically, once first FSW discovered and authorized.
set vdom "root"
set ip 10.254.253.254 255.255.254.0
set allowaccess ping
set description "Sniffer VLAN"
set snmp-index 33
set switch-controller-traffic-policy "sniffer"
set color 6
set interface "aggr1"
set vlanid 4092
next
end
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To enable traffic sniffer based on target IP or MAC address on target ports of managed FortiSwitch
units:
config switch-controller traffic-sniffer <---- newly added CLI stanza in FOS
set erspan-ip 2.2.2.2
<---- Designate ERSPAN collector
config target-mac
edit 11:11:11:11:11:11
next
end
config target-ip
edit 4.4.4.4
next
end
config target-port
edit "S524DN4K1500XXXX"
set in-ports "port2" "port4" "port6"
set out-ports "port3" "port5" "port7"
next
end
end

To use troubleshooting tools:
(root) # diagnose switch-controller

switch-info mirror status S524DN4K1500XXXX

Managed Switch : S524DN4K1500XXXX
flink.sniffer
Mode
: ERSPAN-auto
Status
: Active
Source-Ports:
Ingress: port2, port4, port6
Egress : port3, port5, port7
Used-by-ACLs
: True
Auto-config-state
: Resolved/Running
Last-update : 1464 seconds ago
Issues
: None
Collector-IP : 2.2.2.2
Source-IP
: 10.254.252.208
Source-MAC
: 08:5b:0e:ff:40:27
Next-Hop
:
IP
: 10.254.253.254
MAC
: 00:09:0f:09:00:0c
Via-System-Interface : sniffer
VLAN
: 4092(tagged)
Via-Switch-Interface : G5H0E391790XXXX

FortiLink MCLAG configuration
In WiFi & Switch Controller > FortiSwitch Ports, you can enable MCLAG and view ports grouped by trunks. You need to
configure ports from two switches, that is, two MCLAG peer switches to be included in one MCLAG.
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Sample configuration
In WiFi & Switch Controller > FortiSwitch Ports, there is an MC-LAG option.

In WiFi & Switch Controller > FortiSwitch Ports, there is a Trunk view.
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Standalone FortiGate as switch controller
The following recipes provide instructions on configuring a standalone FortiGate as a switch controller:
l
l
l
l

Standalone FortiGate as switch controller
Multiple FortiSwitches managed via hardware/software switch on page 1263
Multiple FortiSwitches in tiers via aggregate interface with redundant link enabled on page 1267
Multiple FortiSwitches in tiers via aggregate interface with MCLAG enabled only on distribution on page 1270

Standalone FortiGate as switch controller
In this example, one FortiSwitch is managed by a standalone FortiGate. The FortiGate uses an aggregate interface to
operate as a switch controller. This configuration might be used in branch office. It might also be used before increasing
the number of connected FortiSwitch units and evolving to a multi-tier structure.

Prerequisites:
l
l
l

The FortiGate model supports an aggregate interface.
FortiSwitch units have been upgraded to latest released software version.
Layer-3 path/route in the management VDOM is available to Internet so that the FortiSwitch units can synchronize
NTP.

Change the FortiSwitch management mode to FortiLink:
Enter the following CLI commands on the FortiSwitch:
config system global
set switch-mgmt-mode fortilink
end
This operation will cleanup all of the configuration and reboot the system!
Do you want to continue? (y/n)y
Backing up local mode config before entering FortiLink mode....

If the FortiSwitch ports used for the FortiLink connection have auto-discovery-fortilink enabled, executing
authorization on FortiGate will trigger the transformation to FortiLink mode automatically.
config switch interface
edit "port1"
set auto-discovery-fortilink enable
……
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next
end

Create an aggregate interface and designate it as Fortilink interface on the FortiGate:
Using the CLI:
config system interface
edit "aggr1"
set vdom "vdom1"
set fortilink enable
set type aggregate
set member "port11" "port12"
next
end

Using the GUI:
1. Go to WiFi & Switch Controller > FortiLink Interface.
2. In Interface members, select an existing aggregate interface (if there is one) or select one or more physical ports to
create an aggregate interface.
3. Configure other fields as necessary.
4. Click OK.

Discover and authorize the FortiSwitch:
Using the CLI:
config switch-controller managed-switch
edit "FSWSerialNum"
set fsw-wan1-admin enable
……
next
end

Check the CLI output for Connection: Connected to show that FortiLink is up:
execute switch-controller get-conn-status FSWSerialNum
Get managed-switch S248EPTF18001384 connection status:
Admin Status: Authorized
Connection: Connected
Image Version: S248EP-v6.2.0-build143,190107 (Interim)
Remote Address: 2.2.2.2
Join Time: Fri Jan 11 15:22:32 2019
interface
port1
port2
……

status
up
down

duplex
full
N/A

speed fortilink stacking
1000Mbps
no
no
0
no
no

poe status
Delivering Power
Searching

Using the GUI:
1. Go to WiFi & Switch Controller > Managed FortiSwitch.
2. Click Authorize and wait for a few minutes for the connection to be established.
When FortiLink between the FortiGate and FortiSwitch is established, the Link-up ports change to green and the
POE port that is supplying power changes to blue. The dotted line between the FortiGate and FortiSwitch changes
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to a solid line. The Connection status shows that FortiLink is up.

Extend the security perimeter to the edge of FortiSwitch:
1. Configure the VLAN arrangement.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
b. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to
FortiSwitch.
2. Configure FortiSwitch ports.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Ports.
b. Select one or more FortiSwitch ports and assign them to the switch VLAN.
c. You can also select POE/DHCP Snooping, STP, and other parameters for the FortiSwitch ports to show their
real-time status such as link status, data statistics, etc.
3. Configure access authentication.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Security Policies.
b. Configure the 802.1X security policies.
c. Select Port-based or MAC-based mode and select User groups from the existing VDOM.
d. Configure other fields as necessary.
e. Go to WiFi & Switch Controller > FortiSwitch Ports.
f. Select one or more FortiSwitch ports, click + in the Security Policy column, then make a selection from the
pane.

Troubleshooting
Authorized FortiSwitch always offline
If an authorized FortiSwitch is always offline, go to the FortiGate CLI and use the command below to see all the
checkpoints. Inspect each checkpoint to find the cause of the problem.
execute switch-controller diagnose-connection

S248EPTF18001384

Fortilink interface ... OK
aggr1 enabled
DHCP server ... OK
aggr1 enabled
NTP server ... OK
aggr1 enabled
NTP server sync ... OK
synchronized: yes, ntpsync: enabled, server-mode: enabled
ipv4 server(ntp1.fortiguard.com) 208.91.113.70
no data
ipv4 server(ntp2.fortiguard.com) 208.91.113.71
no data
ipv4 server(ntp2.fortiguard.com) 208.91.112.51
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 --
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clock offset is -0.320411 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 11495 msec
ipv4 server(ntp1.fortiguard.com) 208.91.112.50 -- reachable(0xff) S:2 T:66
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.448087 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 12542 msec
HA mode ... disabled
Fortilink
Status ... SWITCH_AUTHORIZED_READY
Last keepalive ... 1 seconds ago
CAPWAP
Remote Address: 2.2.2.2
Status ... CONNECTED
Last keepalive ... 26 seconds ago
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64
64 bytes from 2.2.2.2: icmp_seq=2 ttl=64
64 bytes from 2.2.2.2: icmp_seq=3 ttl=64
64 bytes from 2.2.2.2: icmp_seq=4 ttl=64

time=1.1 ms
time=13.9 ms
time=12.7 ms
time=2.9 ms
time=1.2 ms

--- 2.2.2.2 ping statistics --5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.1/6.3/13.9 ms

Multiple FortiSwitches managed via hardware/software switch
This example provides a recommended configuration of FortiLink where multiple FortiSwitches are managed by a
standalone FortiGate as switch controller via hardware or software switch interface; such as when you need multiple
distribution FortiSwitches but lack supporting aggregate on FortiGate.

Prerequisites:
l
l
l

The FortiGate model supports hardware or software switch interface.
FortiSwitch units have been upgraded to latest released software version.
Layer-3 path/route in the management VDOM is available to Internet so that the FortiSwitch units can synchronize
NTP.
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Change the FortiSwitch management mode to FortiLink:
Enter the following CLI commands on the FortiSwitch:
config system global
set switch-mgmt-mode fortilink
end
This operation will cleanup all of the configuration and reboot the system!
Do you want to continue? (y/n)y
Backing up local mode config before entering FortiLink mode....

If the FortiSwitch ports used for the FortiLink connection have auto-discovery-fortilink enabled, executing
authorization on FortiGate will trigger the transformation to FortiLink mode automatically.
config switch interface
edit "port1"
set auto-discovery-fortilink enable
……
next
end

Create hardware or software switch interface and designate it as FortiLink interface on the FortiGate:
Create a hardware switch using the CLI:
config system virtual-switch
edit "hardswitch1"
set physical-switch "sw0"
config port
edit "port11"
next
edit "port12"
next
end
next
end

Create a software switch using the CLI:
config system switch-interface
edit "softswitch1"
set vdom "vdom1"
set member "port11" "port12"
next
end

Using the GUI:
1. Go to WiFi & Switch Controller > FortiLink Interface.
2. In Interface members, select an existing hardware/software switch interface (if there is one) or select one or more
physical ports to create a hardware/software switch interface.
3. Configure other fields as necessary.
4. Click OK.

Discover and authorize the FortiSwitch:
Using the CLI:
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config switch-controller managed-switch
edit "FSWSerialNum"
set fsw-wan1-admin enable
……
next
end

Check the CLI output for Connection: Connected to show that FortiLink is up:
execute switch-controller get-conn-status FSWSerialNum
Get managed-switch S248EPTF18001384 connection status:
Admin Status: Authorized
Connection: Connected
Image Version: S248EP-v6.2.0-build143,190107 (Interim)
Remote Address: 2.2.2.2
Join Time: Fri Jan 11 15:22:32 2019
interface
port1
port2
……

status
up
down

duplex
full
N/A

speed fortilink stacking
1000Mbps
no
no
0
no
no

poe status
Delivering Power
Searching

Using the GUI:
1. Go to WiFi & Switch Controller > Managed FortiSwitch.
2. Click Authorize and wait for a few minutes for the connection to be established.
When FortiLink between the FortiGate and FortiSwitch is established, the Link-up ports change to green and the
POE port that is supplying power changes to blue. The dotted line between the FortiGate and FortiSwitch changes
to a solid line. The Connection status shows that FortiLink is up.

Extend the security perimeter to the edge of FortiSwitch:
1. Configure the VLAN arrangement.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
b. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to
FortiSwitch.
2. Configure FortiSwitch ports.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Ports.
b. Select one or more FortiSwitch ports and assign them to the switch VLAN.
c. You can also select POE/DHCP Snooping, STP, and other parameters for the FortiSwitch ports to show their
real-time status such as link status, data statistics, etc.
3. Configure access authentication.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Security Policies.
b. Configure the 802.1X security policies.
c. Select Port-based or MAC-based mode and select User groups from the existing VDOM.
d. Configure other fields as necessary.
e. Go to WiFi & Switch Controller > FortiSwitch Ports.
f. Select one or more FortiSwitch ports, click + in the Security Policy column, then make a selection from the
pane.
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Troubleshooting
Bind FortiLink on hardware switch interface
Fortinet recommends binding FortiLink on the hardware switch interface. Since the hardware switch interface can
leverage hardware chips to forward traffic, it does not consume CPU capacity, unlike a software switch.

Authorized FortiSwitch always offline
If an authorized FortiSwitch is always offline, go to the FortiGate CLI and use the command below to see all the
checkpoints. Inspect each checkpoint to find the cause of the problem.
execute switch-controller diagnose-connection

S248EPTF18001384

Fortilink interface ... OK
hardswitch1 enabled
DHCP server ... OK
hardswitch1 enabled
NTP server ... OK
hardswitch1 enabled
NTP server sync ... OK
synchronized: yes, ntpsync: enabled, server-mode: enabled
ipv4 server(ntp1.fortiguard.com) 208.91.113.70 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.113.71 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.112.51 -- reachable(0xff) S:2 T:66 selected
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.320411 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 11495 msec
ipv4 server(ntp1.fortiguard.com) 208.91.112.50 -- reachable(0xff) S:2 T:66
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.448087 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 12542 msec
HA mode ... disabled
Fortilink
Status ... SWITCH_AUTHORIZED_READY
Last keepalive ... 1 seconds ago
CAPWAP
Remote Address: 2.2.2.2
Status ... CONNECTED
Last keepalive ... 26 seconds ago
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64 time=1.1 ms
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64 time=13.9 ms
64 bytes from 2.2.2.2: icmp_seq=2 ttl=64 time=12.7 ms
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64 bytes from 2.2.2.2: icmp_seq=3 ttl=64 time=2.9 ms
64 bytes from 2.2.2.2: icmp_seq=4 ttl=64 time=1.2 ms
--- 2.2.2.2 ping statistics --5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.1/6.3/13.9 ms

Multiple FortiSwitches in tiers via aggregate interface with redundant link enabled
This example provides a recommended configuration of FortiLink where multi-tier FortiSwitches are managed by a
standalone FortiGate as switch controller via aggregate interface, where the FortiGate can provide redundant links to
multiple distribution FortiSwitches.

Prerequisites:
l
l
l

The FortiGate model supports an aggregate interface.
FortiSwitch units have been upgraded to latest released software version.
Layer-3 path/route in the management VDOM is available to Internet so that the FortiSwitch units can synchronize
NTP.

Change the FortiSwitch management mode to FortiLink:
Enter the following CLI commands on the FortiSwitch:
config system global
set switch-mgmt-mode fortilink
end
This operation will cleanup all of the configuration and reboot the system!
Do you want to continue? (y/n)y
Backing up local mode config before entering FortiLink mode....

If the FortiSwitch ports used for the FortiLink connection have auto-discovery-fortilink enabled, executing
authorization on FortiGate will trigger the transformation to FortiLink mode automatically.
config switch interface
edit "port1"
set auto-discovery-fortilink enable
……
next
end
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Create an aggregate interface and designate it as Fortilink interface on the FortiGate:
Using the CLI:
config system interface
edit "aggr1"
set vdom "vdom1"
set fortilink enable
set type aggregate
set member "port11" "port12"
set fortilink-split-interface enable
next
end

Using the GUI:
1. Go to WiFi & Switch Controller > FortiLink Interface.
2. In Interface members, select one or more physical ports that are connected to different distribution FortiSwitches to
create an aggregate interface.
3. Enable FortiLink split interface.
4. Configure other fields as necessary.
5. Click OK.

Discover and authorize the FortiSwitch:
Using the CLI:
config switch-controller managed-switch
edit "FSWSerialNum"
set fsw-wan1-admin enable
……
next
end

Check the CLI output for Connection: Connected to show that FortiLink is up:
execute switch-controller get-conn-status FSWSerialNum
Get managed-switch S248EPTF18001384 connection status:
Admin Status: Authorized
Connection: Connected
Image Version: S248EP-v6.2.0-build143,190107 (Interim)
Remote Address: 2.2.2.2
Join Time: Fri Jan 11 15:22:32 2019
interface
port1
port2
……

status
up
down

duplex
full
N/A

speed fortilink stacking
1000Mbps
no
no
0
no
no

poe status
Delivering Power
Searching

Using the GUI:
1. Go to WiFi & Switch Controller > Managed FortiSwitch.
2. Click Authorize and wait for a few minutes for the connection to be established.
When FortiLink between the FortiGate and FortiSwitch is established, the Link-up ports change to green and the
POE port that is supplying power changes to blue. The dotted line between the FortiGate and FortiSwitch changes
to a solid line. The Connection status shows that FortiLink is up.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1268

Switch Controller

Extend the security perimeter to the edge of FortiSwitch:
1. Configure the VLAN arrangement.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
b. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to
FortiSwitch.
2. Configure FortiSwitch ports.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Ports.
b. Select one or more FortiSwitch ports and assign them to the switch VLAN.
c. You can also select POE/DHCP Snooping, STP, and other parameters for the FortiSwitch ports to show their
real-time status such as link status, data statistics, etc.
3. Configure access authentication.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Security Policies.
b. Configure the 802.1X security policies.
c. Select Port-based or MAC-based mode and select User groups from the existing VDOM.
d. Configure other fields as necessary.
e. Go to WiFi & Switch Controller > FortiSwitch Ports.
f. Select one or more FortiSwitch ports, click + in the Security Policy column, then make a selection from the
pane.

Troubleshooting
Authorized FortiSwitch always offline
If an authorized FortiSwitch is always offline, go to the FortiGate CLI and use the command below to see all the
checkpoints. Inspect each checkpoint to find the cause of the problem.
execute switch-controller diagnose-connection

S248EPTF18001384

Fortilink interface ... OK
aggr1 enabled
DHCP server ... OK
aggr1 enabled
NTP server ... OK
aggr1 enabled
NTP server sync ... OK
synchronized: yes, ntpsync: enabled, server-mode: enabled
ipv4 server(ntp1.fortiguard.com) 208.91.113.70 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.113.71 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.112.51 -- reachable(0xff) S:2 T:66 selected
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.320411 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 11495 msec
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ipv4 server(ntp1.fortiguard.com) 208.91.112.50 -- reachable(0xff) S:2 T:66
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.448087 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 12542 msec
HA mode ... disabled
Fortilink
Status ... SWITCH_AUTHORIZED_READY
Last keepalive ... 1 seconds ago
CAPWAP
Remote Address: 2.2.2.2
Status ... CONNECTED
Last keepalive ... 26 seconds ago
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64
64 bytes from 2.2.2.2: icmp_seq=2 ttl=64
64 bytes from 2.2.2.2: icmp_seq=3 ttl=64
64 bytes from 2.2.2.2: icmp_seq=4 ttl=64

time=1.1 ms
time=13.9 ms
time=12.7 ms
time=2.9 ms
time=1.2 ms

--- 2.2.2.2 ping statistics --5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.1/6.3/13.9 ms

Multiple FortiSwitches in tiers via aggregate interface with MCLAG enabled only on
distribution
This example provides a recommended configuration of FortiLink where multi-tier FortiSwitches are managed by a
standalone FortiGate as switch controller via aggregate interface, where the FortiGate can provide active-active links to
two distribution FortiSwitches connected to each other by MCLAG.

Prerequisites:
l
l
l

l

The FortiGate model supports an aggregate interface.
FortiSwitch units have been upgraded to latest released software version.
Layer-3 path/route in the management VDOM is available to Internet so that the FortiSwitch units can synchronize
NTP.
For the FortiSwitch D series, the models above 4 just support MCLAG. For the FortiSwitch E series, the models
above 2 just support MCLAG.
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Change the FortiSwitch management mode to FortiLink:
Enter the following CLI commands on the FortiSwitch:
config system global
set switch-mgmt-mode fortilink
end
This operation will cleanup all of the configuration and reboot the system!
Do you want to continue? (y/n)y
Backing up local mode config before entering FortiLink mode....

If the FortiSwitch ports used for the FortiLink connection have auto-discovery-fortilink enabled, executing
authorization on FortiGate will trigger the transformation to FortiLink mode automatically.
config switch interface
edit "port1"
set auto-discovery-fortilink enable
……
next
end

Create an aggregate interface and designate it as Fortilink interface on the FortiGate:
Using the CLI:
config system interface
edit "aggr1"
set vdom "vdom1"
set fortilink enable
set type aggregate
set member "port11" "port12"
set fortilink-split-interface disable
next
end

fortilink-split-interface must be disabled for MCLAG to work.
Using the GUI:
1. Go to WiFi & Switch Controller > FortiLink Interface.
2. In Interface members, select one or more physical ports that are connected to different distribution FortiSwitches to
create an aggregate interface.
3. Disable FortiLink split interface.
4. Configure other fields as necessary.
5. Click OK.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1271

Switch Controller

Discover and authorize the FortiSwitch:
Using the CLI:
config switch-controller managed-switch
edit "FSWSerialNum"
set fsw-wan1-admin enable
……
next
end

Check the CLI output for Connection: Connected to show that FortiLink is up:
execute switch-controller get-conn-status FSWSerialNum
Get managed-switch S248EPTF18001384 connection status:
Admin Status: Authorized
Connection: Connected
Image Version: S248EP-v6.2.0-build143,190107 (Interim)
Remote Address: 2.2.2.2
Join Time: Fri Jan 11 15:22:32 2019
interface
port1
port2
……

status
up
down

duplex
full
N/A

speed fortilink stacking
1000Mbps
no
no
0
no
no

poe status
Delivering Power
Searching

Using the GUI:
1. Go to WiFi & Switch Controller > Managed FortiSwitch.
2. Click Authorize and wait for a few minutes for the connection to be established.
When FortiLink between the FortiGate and FortiSwitch is established, the Link-up ports change to green and the
POE port that is supplying power changes to blue. The dotted line between the FortiGate and FortiSwitch changes
to a solid line. The Connection status shows that FortiLink is up.

Enable MCLAG on the ICL link between the distribution FortiSwitch devices:
conf switch trunk
edit "4DN4K15000008-0"
set mclag-icl enable
next
end

When you enable mclag-icl, MCLAG on the FortiLink interface is enabled automatically and active-active backup
links between the distribution FortiSwitches are established.

Extend the security perimeter to the edge of FortiSwitch:
1. Configure the VLAN arrangement.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
b. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to
FortiSwitch.
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2. Configure FortiSwitch ports.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Ports.
b. Select one or more FortiSwitch ports and assign them to the switch VLAN.
c. You can also select POE/DHCP Snooping, STP, and other parameters for the FortiSwitch ports to show their
real-time status such as link status, data statistics, etc.
3. Configure access authentication.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Security Policies.
b. Configure the 802.1X security policies.
c. Select Port-based or MAC-based mode and select User groups from the existing VDOM.
d. Configure other fields as necessary.
e. Go to WiFi & Switch Controller > FortiSwitch Ports.
f. Select one or more FortiSwitch ports, click + in the Security Policy column, then make a selection from the
pane.

Troubleshooting
Authorized FortiSwitch always offline
If an authorized FortiSwitch is always offline, go to the FortiGate CLI and use the command below to see all the
checkpoints. Inspect each checkpoint to find the cause of the problem.
execute switch-controller diagnose-connection

S248EPTF18001384

Fortilink interface ... OK
aggr1 enabled
DHCP server ... OK
aggr1 enabled
NTP server ... OK
aggr1 enabled
NTP server sync ... OK
synchronized: yes, ntpsync: enabled, server-mode: enabled
ipv4 server(ntp1.fortiguard.com) 208.91.113.70 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.113.71 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.112.51 -- reachable(0xff) S:2 T:66 selected
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.320411 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 11495 msec
ipv4 server(ntp1.fortiguard.com) 208.91.112.50 -- reachable(0xff) S:2 T:66
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.448087 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 12542 msec
HA mode ... disabled
Fortilink
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Status ... SWITCH_AUTHORIZED_READY
Last keepalive ... 1 seconds ago
CAPWAP
Remote Address: 2.2.2.2
Status ... CONNECTED
Last keepalive ... 26 seconds ago
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64
64 bytes from 2.2.2.2: icmp_seq=2 ttl=64
64 bytes from 2.2.2.2: icmp_seq=3 ttl=64
64 bytes from 2.2.2.2: icmp_seq=4 ttl=64

time=1.1 ms
time=13.9 ms
time=12.7 ms
time=2.9 ms
time=1.2 ms

--- 2.2.2.2 ping statistics --5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.1/6.3/13.9 ms

HA (A-P) mode FortiGate pairs as switch controller
The following recipes provide instructions on configuring a FortiGate HA in Active-Passive (A-P) mode as a switch
controller:
l
l
l

Multiple FortiSwitches managed via hardware/software switch on page 1274
Multiple FortiSwitches in tiers via aggregate interface with redundant link enabled on page 1279
Multiple FortiSwitches in tiers via aggregate interface with MCLAG enabled only on distribution on page 1283

Multiple FortiSwitches managed via hardware/software switch
This example provides a recommended configuration of FortiLink where multiple FortiSwitches are managed by an A-P
mode HA cluster of FortiGates as switch controller via hardware or software switch interface. An example of common
usage is when you need multiple distribution FortiSwitches but lack supporting aggregate on the FortiGate pairs.

Prerequisites:
l
l
l

The FortiGate model supports hardware or software switch interface.
FortiSwitch units have been upgraded to latest released software version.
Layer-3 path/route in the management VDOM is available to Internet so that the FortiSwitch units can synchronize
NTP.
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Change the FortiSwitch management mode to FortiLink:
Enter the following CLI commands on the FortiSwitch:
config system global
set switch-mgmt-mode fortilink
end
This operation will cleanup all of the configuration and reboot the system!
Do you want to continue? (y/n)y
Backing up local mode config before entering FortiLink mode....

If the FortiSwitch ports used for the FortiLink connection have auto-discovery-fortilink enabled, executing
authorization on FortiGate will trigger the transformation to FortiLink mode automatically.
config switch interface
edit "port1"
set auto-discovery-fortilink enable
……
next
end

Set up an A-P mode HA cluster:
See HA active-passive cluster setup on page 519.

Create hardware or software switch interface and designate it as FortiLink interface on the FortiGate:
Create a hardware switch using the CLI:
config system virtual-switch
edit "hardswitch1"
set physical-switch "sw0"
config port
edit "port11"
next
edit "port12"
next
end
next
end

Create a software switch using the CLI:
config system switch-interface
edit "softswitch1"
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set vdom "vdom1"
set member "port11"

"port12"

next
end

Using the GUI:
1. Go to WiFi & Switch Controller > FortiLink Interface.
2. In Interface members, select an existing hardware/software switch interface (if there is one) or select one or more
physical ports to create a hardware/software switch interface.
3. Configure other fields as necessary.
4. Click OK.

Discover and authorize the FortiSwitch:
Using the CLI:
config switch-controller managed-switch
edit "FSWSerialNum"
set fsw-wan1-admin enable
……
next
end

Check the CLI output for Connection: Connected to show that FortiLink is up:
execute switch-controller get-conn-status FSWSerialNum
Get managed-switch S248EPTF18001384 connection status:
Admin Status: Authorized
Connection: Connected
Image Version: S248EP-v6.2.0-build143,190107 (Interim)
Remote Address: 2.2.2.2
Join Time: Fri Jan 11 15:22:32 2019
interface
port1
port2
……

status
up
down

duplex
full
N/A

speed fortilink stacking
1000Mbps
no
no
0
no
no

poe status
Delivering Power
Searching

Using the GUI:
1. Go to WiFi & Switch Controller > Managed FortiSwitch.
2. Click Authorize and wait for a few minutes for the connection to be established.
When FortiLink between the FortiGate and FortiSwitch is established, the Link-up ports change to green and the
POE port that is supplying power changes to blue. The dotted line between the FortiGate and FortiSwitch changes
to a solid line. The Connection status shows that FortiLink is up.

Extend the security perimeter to the edge of FortiSwitch:
1. Configure the VLAN arrangement.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
b. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to
FortiSwitch.
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2. Configure FortiSwitch ports.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Ports.
b. Select one or more FortiSwitch ports and assign them to the switch VLAN.
c. You can also select POE/DHCP Snooping, STP, and other parameters for the FortiSwitch ports to show their
real-time status such as link status, data statistics, etc.
3. Configure access authentication.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Security Policies.
b. Configure the 802.1X security policies.
c. Select Port-based or MAC-based mode and select User groups from the existing VDOM.
d. Configure other fields as necessary.
e. Go to WiFi & Switch Controller > FortiSwitch Ports.
f. Select one or more FortiSwitch ports, click + in the Security Policy column, then make a selection from the
pane.

Troubleshooting
Bind FortiLink on hardware switch interface
Fortinet recommends binding FortiLink on the hardware switch interface. Since the hardware switch interface can
leverage hardware chips to forward traffic, it does not consume CPU capacity, unlike a software switch.

Authorized FortiSwitch always offline
If an authorized FortiSwitch is always offline, go to the FortiGate CLI and use the command below to see all the
checkpoints. Inspect each checkpoint to find the cause of the problem.
execute switch-controller diagnose-connection

S248EPTF18001384

Fortilink interface ... OK
hardswitch1 enabled
DHCP server ... OK
hardswitch1 enabled
NTP server ... OK
hardswitch1 enabled
NTP server sync ... OK
synchronized: yes, ntpsync: enabled, server-mode: enabled
ipv4 server(ntp1.fortiguard.com) 208.91.113.70 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.113.71 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.112.51 -- reachable(0xff) S:2 T:66 selected
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.320411 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 11495 msec
ipv4 server(ntp1.fortiguard.com) 208.91.112.50 -- reachable(0xff) S:2 T:66
server-version=4, stratum=2
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reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.448087 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 12542 msec
HA mode ... disabled
Fortilink
Status ... SWITCH_AUTHORIZED_READY
Last keepalive ... 1 seconds ago
CAPWAP
Remote Address: 2.2.2.2
Status ... CONNECTED
Last keepalive ... 26 seconds ago

PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64
64 bytes from 2.2.2.2: icmp_seq=2 ttl=64
64 bytes from 2.2.2.2: icmp_seq=3 ttl=64
64 bytes from 2.2.2.2: icmp_seq=4 ttl=64

time=1.1 ms
time=13.9 ms
time=12.7 ms
time=2.9 ms
time=1.2 ms

--- 2.2.2.2 ping statistics --5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.1/6.3/13.9 ms

HA sync fails
If HA sync fails, use the command below to diagnose and locate the cause.
# diagnose sys ha checksum cluster
================== FG5H0E39179XXX9 ==================
is_manage_master()=1, is_root_master()=1
debugzone
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
checksum
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
================== FG5H0E391790XXX4 ==================
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is_manage_master()=0, is_root_master()=0
debugzone
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
checksum
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad

Multiple FortiSwitches in tiers via aggregate interface with redundant link enabled
This example provides a recommended configuration of FortiLink where multi-tier FortiSwitches are managed by an A-P
mode HA cluster of FortiGates as switch controller via aggregate interface, where each FortiGate cluster member can
provide redundant links to multiple (>=2) distribution FortiSwitches.

Prerequisites:
l
l
l

The FortiGate model supports an aggregate interface.
FortiSwitch units have been upgraded to latest released software version.
Layer-3 path/route in the management VDOM is available to Internet so that the FortiSwitch units can synchronize
NTP.

Change the FortiSwitch management mode to FortiLink:
Enter the following CLI commands on the FortiSwitch:
config system global
set switch-mgmt-mode fortilink
end
This operation will cleanup all of the configuration and reboot the system!
Do you want to continue? (y/n)y
Backing up local mode config before entering FortiLink mode....
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If the FortiSwitch ports used for the FortiLink connection have auto-discovery-fortilink enabled, executing
authorization on FortiGate will trigger the transformation to FortiLink mode automatically.
config switch interface
edit "port1"
set auto-discovery-fortilink enable
……
next
end

Set up an A-P mode HA cluster:
See HA active-passive cluster setup on page 519.

Create an aggregate interface and designate it as Fortilink interface on the FortiGate:
Using the CLI:
config system interface
edit "aggr1"
set vdom "vdom1"
set fortilink enable
set type aggregate
set member "port11" "port12"
set fortilink-split-interface enable
next
end

Using the GUI:
1. Go to WiFi & Switch Controller > FortiLink Interface.
2. In Interface members, select one or more physical ports that are connected to different distribution FortiSwitches to
create an aggregate interface.
3. Enable FortiLink split interface.
4. Configure other fields as necessary.
5. Click OK.

Discover and authorize the FortiSwitch:
Using the CLI:
config switch-controller managed-switch
edit "FSWSerialNum"
set fsw-wan1-admin enable
……
next
end

Check the CLI output for Connection: Connected to show that FortiLink is up:
execute switch-controller get-conn-status FSWSerialNum
Get managed-switch S248EPTF18001384 connection status:
Admin Status: Authorized
Connection: Connected
Image Version: S248EP-v6.2.0-build143,190107 (Interim)
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Remote Address: 2.2.2.2
Join Time: Fri Jan 11 15:22:32 2019
interface
port1
port2
……

status
up
down

duplex
full
N/A

speed fortilink stacking
1000Mbps
no
no
0
no
no

poe status
Delivering Power
Searching

Using the GUI:
1. Go to WiFi & Switch Controller > Managed FortiSwitch.
2. Click Authorize and wait for a few minutes for the connection to be established.
When FortiLink between the FortiGate and FortiSwitch is established, the Link-up ports change to green and the
POE port that is supplying power changes to blue. The dotted line between the FortiGate and FortiSwitch changes
to a solid line. The Connection status shows that FortiLink is up.

Extend the security perimeter to the edge of FortiSwitch:
1. Configure the VLAN arrangement.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
b. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to
FortiSwitch.
2. Configure FortiSwitch ports.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Ports.
b. Select one or more FortiSwitch ports and assign them to the switch VLAN.
c. You can also select POE/DHCP Snooping, STP, and other parameters for the FortiSwitch ports to show their
real-time status such as link status, data statistics, etc.
3. Configure access authentication.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Security Policies.
b. Configure the 802.1X security policies.
c. Select Port-based or MAC-based mode and select User groups from the existing VDOM.
d. Configure other fields as necessary.
e. Go to WiFi & Switch Controller > FortiSwitch Ports.
f. Select one or more FortiSwitch ports, click + in the Security Policy column, then make a selection from the
pane.

Troubleshooting
Authorized FortiSwitch always offline
If an authorized FortiSwitch is always offline, go to the FortiGate CLI and use the command below to see all the
checkpoints. Inspect each checkpoint to find the cause of the problem.
execute switch-controller diagnose-connection

S248EPTF18001384

Fortilink interface ... OK
aggr1 enabled
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DHCP server ... OK
aggr1 enabled
NTP server ... OK
aggr1 enabled
NTP server sync ... OK
synchronized: yes, ntpsync: enabled, server-mode: enabled
ipv4 server(ntp1.fortiguard.com) 208.91.113.70 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.113.71 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.112.51 -- reachable(0xff) S:2 T:66 selected
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.320411 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 11495 msec
ipv4 server(ntp1.fortiguard.com) 208.91.112.50 -- reachable(0xff) S:2 T:66
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.448087 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 12542 msec
HA mode ... disabled
Fortilink
Status ... SWITCH_AUTHORIZED_READY
Last keepalive ... 1 seconds ago
CAPWAP
Remote Address: 2.2.2.2
Status ... CONNECTED
Last keepalive ... 26 seconds ago

PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64
64 bytes from 2.2.2.2: icmp_seq=2 ttl=64
64 bytes from 2.2.2.2: icmp_seq=3 ttl=64
64 bytes from 2.2.2.2: icmp_seq=4 ttl=64

time=1.1 ms
time=13.9 ms
time=12.7 ms
time=2.9 ms
time=1.2 ms

--- 2.2.2.2 ping statistics --5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.1/6.3/13.9 ms

HA sync fails
If HA sync fails, use the command below to diagnose and locate the cause.
# diagnose sys ha checksum cluster
================== FG5H0E39179XXX9 ==================
is_manage_master()=1, is_root_master()=1
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debugzone
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
checksum
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
================== FG5H0E391790XXX4 ==================
is_manage_master()=0, is_root_master()=0
debugzone
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
checksum
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad

Multiple FortiSwitches in tiers via aggregate interface with MCLAG enabled only on
distribution
This example provides a recommended configuration of FortiLink where multi-tier FortiSwitches are managed by an A-P
mode HA cluster of FortiGates as switch controller via aggregate interface, where FortiGates provide active-active links
to two distribution FortiSwitches connected to each other by MCLAG.

Prerequisites:
l
l
l

The FortiGate model supports an aggregate interface.
FortiSwitch units have been upgraded to latest released software version.
Layer-3 path/route in the management VDOM is available to Internet so that the FortiSwitch units can synchronize
NTP.
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l

For the FortiSwitch D series, the models above 4 just support MCLAG. For the FortiSwitch E series, the models
above 2 just support MCLAG.

Change the FortiSwitch management mode to FortiLink:
Enter the following CLI commands on the FortiSwitch:
config system global
set switch-mgmt-mode fortilink
end
This operation will cleanup all of the configuration and reboot the system!
Do you want to continue? (y/n)y
Backing up local mode config before entering FortiLink mode....

If the FortiSwitch ports used for the FortiLink connection have auto-discovery-fortilink enabled, executing
authorization on FortiGate will trigger the transformation to FortiLink mode automatically.
config switch interface
edit "port1"
set auto-discovery-fortilink enable
……
next
end

Set up an A-P mode HA cluster:
See HA active-passive cluster setup on page 519.

Create an aggregate interface and designate it as Fortilink interface on the FortiGate:
Using the CLI:
config system interface
edit "aggr1"
set vdom "vdom1"
set fortilink enable
set type aggregate
set member "port11" "port12"
set fortilink-split-interface disable
next
end

fortilink-split-interface must be disabled for MCLAG to work.
Using the GUI:
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1. Go to WiFi & Switch Controller > FortiLink Interface.
2. In Interface members, select one or more physical ports that are connected to different distribution FortiSwitches to
create an aggregate interface.
3. Disable FortiLink split interface.
4. Configure other fields as necessary.
5. Click OK.

Discover and authorize the FortiSwitch:
Using the CLI:
config switch-controller managed-switch
edit "FSWSerialNum"
set fsw-wan1-admin enable
……
next
end

Check the CLI output for Connection: Connected to show that FortiLink is up:
execute switch-controller get-conn-status FSWSerialNum
Get managed-switch S248EPTF18001384 connection status:
Admin Status: Authorized
Connection: Connected
Image Version: S248EP-v6.2.0-build143,190107 (Interim)
Remote Address: 2.2.2.2
Join Time: Fri Jan 11 15:22:32 2019
interface
port1
port2
……

status
up
down

duplex
full
N/A

speed fortilink stacking
1000Mbps
no
no
0
no
no

poe status
Delivering Power
Searching

Using the GUI:
1. Go to WiFi & Switch Controller > Managed FortiSwitch.
2. Click Authorize and wait for a few minutes for the connection to be established.
When FortiLink between the FortiGate and FortiSwitch is established, the Link-up ports change to green and the
POE port that is supplying power changes to blue. The dotted line between the FortiGate and FortiSwitch changes
to a solid line. The Connection status shows that FortiLink is up.

Enable MCLAG on the ICL link between the distribution FortiSwitch devices:
conf switch trunk
edit "4DN4K15000008-0"
set mclag-icl enable
next
end

When you enable mclag-icl, MCLAG on the FortiLink interface is enabled automatically and active-active backup
links between the distribution FortiSwitches are established.
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Extend the security perimeter to the edge of FortiSwitch:
1. Configure the VLAN arrangement.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
b. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to
FortiSwitch.
2. Configure FortiSwitch ports.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Ports.
b. Select one or more FortiSwitch ports and assign them to the switch VLAN.
c. You can also select POE/DHCP Snooping, STP, and other parameters for the FortiSwitch ports to show their
real-time status such as link status, data statistics, etc.
3. Configure access authentication.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Security Policies.
b. Configure the 802.1X security policies.
c. Select Port-based or MAC-based mode and select User groups from the existing VDOM.
d. Configure other fields as necessary.
e. Go to WiFi & Switch Controller > FortiSwitch Ports.
f. Select one or more FortiSwitch ports, click + in the Security Policy column, then make a selection from the
pane.

Troubleshooting
Authorized FortiSwitch always offline
If an authorized FortiSwitch is always offline, go to the FortiGate CLI and use the command below to see all the
checkpoints. Inspect each checkpoint to find the cause of the problem.
execute switch-controller diagnose-connection

S248EPTF18001384

Fortilink interface ... OK
aggr1 enabled
DHCP server ... OK
aggr1 enabled
NTP server ... OK
aggr1 enabled
NTP server sync ... OK
synchronized: yes, ntpsync: enabled, server-mode: enabled
ipv4 server(ntp1.fortiguard.com) 208.91.113.70 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.113.71 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.112.51 -- reachable(0xff) S:2 T:66 selected
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.320411 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 11495 msec
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ipv4 server(ntp1.fortiguard.com) 208.91.112.50 -- reachable(0xff) S:2 T:66
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.448087 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 12542 msec
HA mode ... disabled
Fortilink
Status ... SWITCH_AUTHORIZED_READY
Last keepalive ... 1 seconds ago
CAPWAP
Remote Address: 2.2.2.2
Status ... CONNECTED
Last keepalive ... 26 seconds ago

PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64
64 bytes from 2.2.2.2: icmp_seq=2 ttl=64
64 bytes from 2.2.2.2: icmp_seq=3 ttl=64
64 bytes from 2.2.2.2: icmp_seq=4 ttl=64

time=1.1 ms
time=13.9 ms
time=12.7 ms
time=2.9 ms
time=1.2 ms

--- 2.2.2.2 ping statistics --5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.1/6.3/13.9 ms

HA sync fails
If HA sync fails, use the command below to diagnose and locate the cause.
# diagnose sys ha checksum cluster
================== FG5H0E39179XXX9 ==================
is_manage_master()=1, is_root_master()=1
debugzone
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
checksum
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
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================== FG5H0E391790XXX4 ==================
is_manage_master()=0, is_root_master()=0
debugzone
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
checksum
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad

Multiple FortiSwitches in tiers via aggregate interface with MCLAG enabled on all
tiers
This example provides a recommended configuration of FortiLink where multi-tier FortiSwitch devices are managed by
an A-P mode HA cluster of FortiGates acting as a switch controller via an aggregate interface. The FortiGates provide AA links to two distribution FortiSwitches that are connected to each other by MCLAG. All access FortiSwitch devices
have A-A links with two upper tier FortiSwitches, as long as the MCLAG-ICL has been enabled between the upper tiers.

Prerequisites:
l
l
l

l

The FortiGate model supports an aggregate interface.
FortiSwitch units have been upgraded to latest released software version.
Layer-3 path/route in the management VDOM is available to Internet so that the FortiSwitch units can synchronize
NTP.
For the FortiSwitch D series, the models above 4 just support MCLAG. For the FortiSwitch E series, the models
above 2 just support MCLAG.

Change the FortiSwitch management mode to FortiLink:
Enter the following CLI commands on the FortiSwitch:
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config system global
set switch-mgmt-mode fortilink
end
This operation will cleanup all of the configuration and reboot the system!
Do you want to continue? (y/n)y
Backing up local mode config before entering FortiLink mode....

If the FortiSwitch ports used for the FortiLink connection have auto-discovery-fortilink enabled, executing
authorization on FortiGate will trigger the transformation to FortiLink mode automatically.
config switch interface
edit "port1"
set auto-discovery-fortilink enable
……
next
end

Set up an A-P mode HA cluster:
See HA active-passive cluster setup on page 519.

Create an aggregate interface and designate it as Fortilink interface on the FortiGate:
Using the CLI:
config system interface
edit "aggr1"
set vdom "vdom1"
set fortilink enable
set type aggregate
set member "port11" "port12"
set fortilink-split-interface disable
next
end

fortilink-split-interface must be disabled for MCLAG to work.
Using the GUI:
1. Go to WiFi & Switch Controller > FortiLink Interface.
2. In Interface members, select one or more physical ports that are connected to different distribution FortiSwitches to
create an aggregate interface.
3. Disable FortiLink split interface.
4. Configure other fields as necessary.
5. Click OK.

Discover and authorize the FortiSwitch:
Using the CLI:
config switch-controller managed-switch
edit "FSWSerialNum"
set fsw-wan1-admin enable
……
next
end
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Check the CLI output for Connection: Connected to show that FortiLink is up:
execute switch-controller get-conn-status FSWSerialNum
Get managed-switch S248EPTF18001384 connection status:
Admin Status: Authorized
Connection: Connected
Image Version: S248EP-v6.2.0-build143,190107 (Interim)
Remote Address: 2.2.2.2
Join Time: Fri Jan 11 15:22:32 2019
interface
port1
port2
……

status
up
down

duplex
full
N/A

speed fortilink stacking
1000Mbps
no
no
0
no
no

poe status
Delivering Power
Searching

Using the GUI:
1. Go to WiFi & Switch Controller > Managed FortiSwitch.
2. Click Authorize and wait for a few minutes for the connection to be established.
When FortiLink between the FortiGate and FortiSwitch is established, the Link-up ports change to green and the
POE port that is supplying power changes to blue. The dotted line between the FortiGate and FortiSwitch changes
to a solid line. The Connection status shows that FortiLink is up.

Enable MCLAG on the ICL link between the distribution FortiSwitch devices:
conf switch trunk
edit "4DN4K15000008-0"
set mclag-icl enable
next
end

When you enable mclag-icl, MCLAG on the FortiLink interface is enabled automatically and active-active backup
links between the distribution FortiSwitches are established.

Extend the security perimeter to the edge of FortiSwitch:
1. Configure the VLAN arrangement.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
b. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to
FortiSwitch.
2. Configure FortiSwitch ports.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Ports.
b. Select one or more FortiSwitch ports and assign them to the switch VLAN.
c. You can also select POE/DHCP Snooping, STP, and other parameters for the FortiSwitch ports to show their
real-time status such as link status, data statistics, etc.
3. Configure access authentication.
a. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch Security Policies.
b. Configure the 802.1X security policies.
c. Select Port-based or MAC-based mode and select User groups from the existing VDOM.
d. Configure other fields as necessary.
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e. Go to WiFi & Switch Controller > FortiSwitch Ports.
f. Select one or more FortiSwitch ports, click + in the Security Policy column, then make a selection from the
pane.

Troubleshooting
Authorized FortiSwitch always offline
If an authorized FortiSwitch is always offline, go to the FortiGate CLI and use the command below to see all the
checkpoints. Inspect each checkpoint to find the cause of the problem.
execute switch-controller diagnose-connection

S248EPTF18001384

Fortilink interface ... OK
aggr1 enabled
DHCP server ... OK
aggr1 enabled
NTP server ... OK
aggr1 enabled
NTP server sync ... OK
synchronized: yes, ntpsync: enabled, server-mode: enabled
ipv4 server(ntp1.fortiguard.com) 208.91.113.70 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.113.71 -- reachable(0x80) S:2 T:128
no data
ipv4 server(ntp2.fortiguard.com) 208.91.112.51 -- reachable(0xff) S:2 T:66 selected
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.320411 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 11495 msec
ipv4 server(ntp1.fortiguard.com) 208.91.112.50 -- reachable(0xff) S:2 T:66
server-version=4, stratum=2
reference time is dfe3aec5.744404e6 -- UTC Sat Jan 12 00:09:41 2019
clock offset is -0.448087 sec, root delay is 0.054535 sec
root dispersion is 0.533081 sec, peer dispersion is 12542 msec
HA mode ... disabled
Fortilink
Status ... SWITCH_AUTHORIZED_READY
Last keepalive ... 1 seconds ago
CAPWAP
Remote Address: 2.2.2.2
Status ... CONNECTED
Last keepalive ... 26 seconds ago

PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64 time=1.1 ms
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64
64
64
64

bytes
bytes
bytes
bytes

from
from
from
from

2.2.2.2:
2.2.2.2:
2.2.2.2:
2.2.2.2:

icmp_seq=1
icmp_seq=2
icmp_seq=3
icmp_seq=4

ttl=64
ttl=64
ttl=64
ttl=64

time=13.9 ms
time=12.7 ms
time=2.9 ms
time=1.2 ms

--- 2.2.2.2 ping statistics --5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 1.1/6.3/13.9 ms

HA sync fails
If HA sync fails, use the command below to diagnose and locate the cause.
# diagnose sys ha checksum cluster
================== FG5H0E39179XXX9 ==================
is_manage_master()=1, is_root_master()=1
debugzone
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
checksum
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
================== FG5H0E391790XXX4 ==================
is_manage_master()=0, is_root_master()=0
debugzone
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
checksum
global: 2b e9 81 38 c2 9d 4f db b7 0e 1f 49 42 c6 1e fb
vdom5: 3d dc e7 70 69 22 c3 12 a7 ac 68 06 21 21 ef 8f
vdom3: 89 59 1f 45 7a 75 ae fc 71 bc 42 f4 5e c2 47 c8
vdom2: b2 a5 f3 e7 85 02 62 e5 2a 23 23 64 04 66 76 cc
vdom1: 1f b5 11 61 31 c4 0c 72 2e 97 8d d8 45 7e d6 0c
root: af a6 48 c5 c2 9a 8b 81 a5 53 fb 27 e9 ae 01 6a
all: 89 1f 63 77 48 8a 30 ee 57 06 ca eb 71 e6 8e ad
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Authentication and security
The following recipes provide instructions on configuring switch related authentication and security:
l
l
l
l

MAC-based 802.1X authentication on page 1293
Port-based 802.1X authentication on page 1296
MAC layer control - Sticky MAC and MAC Learning-limit on page 1299
Quarantine on page 1300

MAC-based 802.1X authentication
This example show how to configure MAC-based 802.1X authentication to managed FortiSwitch ports when using
FortiLink. Managed FortiSwitch devices will authenticate and record the MAC addresses of user devices. If there is a hub
after the FortiSwitch that connects multiple user devices, each device can access the network after passing
authentication.

Prerequisites:
l

l

The certificates and authentication protocol supported by the supplicant software and RADIUS server are
compatible.
The managed FortiSwitches using FortiLink act as authenticators.

Create a firewall policy to allow the RADIUS authentication related traffic from the Fortilink interface to
the outbound interface on the FortiGate:
config firewall policy
edit 0
set srcintf "fortilink-interface"
set dstintf "outbound-interface-to-RadiusSVR"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "RADIUS"
set nat enable
next
end

Designate a RADIUS server and create a user group:
Using the CLI:
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config user radius
edit "Radius1"
set server "172.18.60.203"
set secret ENC 1dddddd
next
end
config user group
edit "Radius-Grp1"
set member "Radius1"
next
end

Using the GUI:
1.
2.
3.
4.
5.
6.
7.
8.

On the FortiGate, go to User & Device > RADIUS Servers.
Edit an existing server, or create a new one.
If necessary, add a Name for the server.
Set the IP/Name to 172.18.60.203 and Secret to 1dddddd .
Configure other fields as necessary.
Click OK.
Go to User & Device > User Groups.
Create a new group, and add the RADIUS server to the Remote Groups list.

9. Click OK.

Use the new user group in a security policy:
Using the CLI:
config switch-controller security-policy 802-1X
edit "802-1X-policy-default"
set security-mode 802.1X-mac-based
set user-group "Radius-Grp1"
set mac-auth-bypass disable
set open-auth disable
set eap-passthru enable
set guest-vlan disable
set auth-fail-vlan disable
set framevid-apply enable
set radius-timeout-overwrite disable
next
end

Configure the guest VLAN, authentication fail VLAN, and other parameters as needed.
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Using the GUI:
1.
2.
3.
4.
5.
6.

Go to WiFi & Switch Controller > FortiSwitch Security Policies
Use the default 802-1X-policy-default, or create a new security policy.
Use the RADIUS server group in the policy.
Set the Security mode to MAC-based.
Configure other fields as necessary.
Click OK.

Apply the security policy to the ports of the managed FortiSwitches:
Using the CLI:
config switch-controller managed-switch
edit S248EPTF1800XXXX
config ports
edit "port6"
set port-security-policy "802-1X-policy-default"
next
end
next
end

On the FortiSwitch, check the configuration:
config switch interface
edit "port6"
set allowed-vlans 4093
set untagged-vlans 4093
set security-groups "Radius-Grp1"
set snmp-index 6
config port-security
set auth-fail-vlan disable
set eap-passthru enable
set framevid-apply enable
set guest-auth-delay 30
set guest-vlan disable
set mac-auth-bypass disable
set open-auth disable
set port-security-mode 802.1X-mac-based
set radius-timeout-overwrite disable
set auth-fail-vlanid 200
set guest-vlanid 100
end
next
end

Using the GUI:
1. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
2. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to FortiSwitch.
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Execute 802.1X authentication on a user device:
On Linux, run wpa_supplicant:
wpa_supplicant -c /etc/wpa_supplicant/local_supplicant.conf

-D wired -i eth2 -dd

On the FortiGate, view the status of the 802.1X authentication:
diagnose switch-controller switch-info 802.1X
Managed Switch : S248EPTF1800XXXX
port6 : Mode: mac-based (mac-by-pass disable)
Link: Link up
Port State: authorized: ( )
auth passed. Otherwise, shown failed
EAP pass-through mode : Enable
Native Vlan : 1
Allowed Vlan list: 1,4093
Untagged Vlan list: 1,4093
Guest VLAN :
Auth-Fail Vlan :

-----> MAC-based
-----> Showing authorized means

Switch sessions 1/240,
Local port sessions:1/20
Client
MAC
Type
Vlan Dynamic-Vlan
00:0c:29:d4:4f:3c
802.1x
1
0
-----> User device of
auth passed can access the network. Its MAC address is recored, while other User Devices
under same FSW ports still not allowed to access.
Sessions info:
00:0c:29:d4:4f:3c
params:reAuth=3600

Type=802.1x,MD5,state=AUTHENTICATED,etime=6,eap_cnt=3

Port-based 802.1X authentication
This example show how to configure Port-based 802.1X authentication to managed FortiSwitch ports when using
FortiLink. Managed FortiSwitch devices will authenticate user devices per each FortiSwitch port. If there is a hub after
the FortiSwitch that connects multiple user devices to the same port, they can all access the network after
authentication, which is not recommended from a security perspective.

Prerequisites:
l

l

The certificates and authentication protocol supported by the supplicant software and RADIUS server are
compatible.
The managed FortiSwitches using FortiLink act as authenticators.
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Create a firewall policy to allow the RADIUS authentication related traffic from the Fortilink interface to
the outbound interface on the FortiGate:
config firewall policy
edit 0
set srcintf "fortilink-interface"
set dstintf "outbound-interface-to-RadiusSVR"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "RADIUS"
set nat enable
next
end

Designate a RADIUS server and create a user group:
Using the CLI:
config user radius
edit "Radius1"
set server "172.18.60.203"
set secret ENC 1dddddd
next
end
config user group
edit "Radius-Grp1"
set member "Radius1"
next
end

Using the GUI:
1.
2.
3.
4.
5.
6.
7.
8.

On the FortiGate, go to User & Device > RADIUS Servers.
Edit an existing server, or create a new one.
If necessary, add a Name for the server.
Set the IP/Name to 172.18.60.203 and Secret to 1dddddd .
Configure other fields as necessary.
Click OK.
Go to User & Device > User Groups.
Create a new group, and add the RADIUS server to the Remote Groups list.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1297

Switch Controller
9. Click OK.

Use the new user group in a security policy:
Using the CLI:
config switch-controller security-policy 802-1X
edit "802-1X-policy-default"
set security-mode 802.1X
set user-group "Radius-Grp1"
set mac-auth-bypass disable
set open-auth disable
set eap-passthru enable
set guest-vlan disable
set auth-fail-vlan disable
set framevid-apply enable
set radius-timeout-overwrite disable
next
end

Configure the guest VLAN, authentication fail VLAN, and other parameters as needed.
Using the GUI:
1.
2.
3.
4.
5.
6.

Go to WiFi & Switch Controller > FortiSwitch Security Policies
Use the default 802-1X-policy-default, or create a new security policy.
Use the RADIUS server group in the policy.
Set the Security mode to Port-based.
Configure other fields as necessary.
Click OK.

Apply the security policy to the ports of the managed FortiSwitches:
Using the CLI:
config switch-controller managed-switch
edit S248EPTF1800XXXX
config ports
edit "port6"
set port-security-policy "802-1X-policy-default"
next
end
next
end

Using the GUI:
1. On the FortiGate, go to WiFi & Switch Controller > FortiSwitch VLANs.
2. Configure the VLAN interfaces that are applied on FortiSwitch.
On FortiGate, these switch VLAN interfaces are treated as layer-3 interfaces and are available to be applied by
firewall policy and other security controls in FortiOS. This means that security boundary is extended to FortiSwitch.

Execute 802.1X authentication on a user device:
On Linux, run wpa_supplicant:
wpa_supplicant -c /etc/wpa_supplicant/local_supplicant.conf
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On the FortiGate, view the status of the 802.1X authentication:
diagnose switch-controller switch-info 802.1X Managed Switch : S248EPTF18001384
port6 : Mode: port-based (mac-by-pass disable)
Link: Link up
Port State: authorized: ( )
Dynamic Authorized Vlan : 0
EAP pass-through mode : Enable
Native Vlan : 1
Allowed Vlan list: 1,4093
Untagged Vlan list: 4093
Guest VLAN :
Auth-Fail Vlan :
Sessions info:
00:0c:29:d4:4f:3c
params:reAuth=3600

Type=802.1x,MD5,state=AUTHENTICATED,etime=0,eap_cnt=6

MAC layer control - Sticky MAC and MAC Learning-limit
Persistent MAC learning, or Sticky MAC, is a port security feature that lets an interface retain dynamically learned MAC
addresses when a switch is restarted, or an interface goes down and then is brought back online.
Enabling Sticky MAC along with MAC Learning-limit restricts the number of MAC addresses that are learned. This
prevents layer 2 Denial of Service (DoS) attacks, overflow attacks on the Ethernet switching table, and DHCP starvation
attacks by limiting the number of MAC addresses that are allowed while still allowing the interface to learn a specified
number of MAC addresses. The interface is secured because, after the specified limit has been reached, additional
devices cannot connect to the port. Interfaces can be allowed to learn the MAC address of trusted workstations and
servers from the time that the interfaces are connected to the network, until the MAC address limit is reached.

Prerequisites
l
l

Sticky MAC save is hardware and CPU intensive if there are too many entries.
Dual chip device models (X48 and XX48 FortiSwitch models) do not support MAC Learning-limit on VLANs, but still
support it on FortiSwitch ports.

Enable Sticky MAC on the FortiSwitch ports view:
config switch-controller managed-switch
edit S248EPTF18001384
config ports
edit port6
set sticky-mac enable
next
end
next
end
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Check the MAC-table on the FortiSwitch to see that the status of related MAC items on the Sticky MAC enabled
ports has changed from dynamic to static:
Before Sticky-MAC is enabled:
diagnose switch mac-address list
MAC: 08:5b:0e:06:6a:d4 VLAN: 1 Port: port1(port-id 1) Flags: 0x00030440 [ hit
dynamic src-hit native move ]

After Sticky-MAC is enabled:
diagnose switch mac-address list
MAC: 00:0c:29:d4:4f:3c VLAN: 1 Port: port6(port-id 6) Flags: 0x00000020 [ static ]

Save Sticky-MAC items into the database and delete others:
Saving Sticky-MAC items from the running memory into the database, and deleting unsaved items, will ensure that, even
after the FortiSwitch is rebooted, the trusted MAC addresses will be kept and will not need to be relearned.
execute switch-controller switch-action sticky-mac save all S248EPTF1800XXXX
S248EPTF1800XXXX: Save started...
Warning: Please wait save will take longer time upto 30 seconds...
Collecting config data....Done
Collecting hardware data....Done
Saving....Done
Sticky MAC entries saved = 1 ----------------> Number of saved Sticky MAC items is
shown
execute switch-controller switch-action sticky-mac delete-unsaved all S248EPTF1800XXXX

Configure the MAC Learning-limit under the VLAN or managed FortiSwitch ports view:
VLAN view:
config system interface
edit vsw.aggr1
set switch-controller-learning-limit 10
next
end

Ports view:
config switch-controller managed-switch
edit S248EPTF1800XXXX
config ports
edit port6
set learning-limit 11
next
end
next
end

Quarantine
When the FortiGate detects devices that have lower trust scores, lack mandatory installed software, or are sending out
malicious traffic, an administrator can quarantine the device from the normal switch VLAN to the quarantine VLAN. This
can limit the device's access, or provide them specific information on the quarantine portal page.
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To quarantine an active device:
Using the CLI, based on the device's MAC address:
config user quarantine
config targets
edit "manual-qtn-1"
set description "Manually quarantined"
config macs
edit 00:0c:29:d4:4f:3c
set description "manual-qtn "
next
end
next
end
end

Using the GUI:
1. On the FortiGate, go to Security Fabric > Physical Topology, or Security Fabric > Logical Topology.
2. Mouse over the bubble of an active device, and select Quarantine Host from the right-click menu.
3. Click OK in the Quarantine Host page to quarantine the device.
The quarantined device is moved to the quarantine VLAN, and the configuration of the FortiSwitch port does not change.
The quarantined device gets its IP address from the DHCP server on the quarantine VLAN interface. The network
locations that the device can access depends on the firewall policies that are configured for the quarantine VLAN
interface. By default, the device must acknowledge and accept the information on the Quarantine Portal before it can
access any part of the network.

Release or clear the quarantine targets:
Using the CLI:
config user quarantine
config targets
delete "manual-qtn-1"
...
end
end
config user quarantine
config targets
purge
end
end

Using the GUI:
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1. Go to Monitor > Quarantine Monitor.
2. Delete the quarantine targets as needed, or click Remove All to delete all the targets.

Flow and Device Detection
The following recipes provide information on flow and device detection:
l
l

Data statistic on page 1302
Security Fabric showing on page 1303

Data statistic
This example shows a FortiLink scenario where the FortiGate acts as the switch controller that collects the data statistics
of managed FortiSwitch ports. This is counted by each FortiSwitch and concentrated in the controller.

Sample topology

To show data statistics using the GUI:
1. Go to WiFi & Switch Controller > FortiSwitch Ports.
2. Select Configure Table.
3. Select Bytes, Errors and Packets to make them visible.
The related data statistic of each managed FortiSwitch port is shown.

To show data statistics using the CLI:
# diagnose switch-controller switch-info port-stats S248EPTF180XXXX
......
Port(port50) is Admin up, line protocol is down
Interface Type is Gigabit Media Independent Interface(GMII)
Address is 70:4C:A5:E0:F3:8D, loopback is not set
MTU 9216 bytes, Encapsulation IEEE 802.3/Ethernet-II
full-duplex, 1000 Mb/s, link type is manual
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input : 0 bytes, 0 packets, 0 errors, 0 drops, 0 oversizes
0 unicasts, 0 multicasts, 0 broadcasts, 0 unknowns
output : 0 bytes, 0 packets, 0 errors, 0 drops, 0 oversizes
0 unicasts, 0 multicasts, 0 broadcasts
0 fragments, 0 undersizes, 0 collisions, 0 jabbers
......

Security Fabric showing
This example shows one of the key components in the concept of Security Fabric: FortiSwitches in FortiLink. In the
FortiGate GUI, you can see the whole picture of the Security Fabric working for your network security.

Sample topology

To show Security Fabric information:
1. Go to Security Fabric > Physical Topology.
2. To see the connection between FortiGates and managed FortiSwitches, hover the pointer over the icons to see
information about each network element.
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FortiSwitch multi-tenant support
A virtual switch provides a container for physical ports to be loaned to other VDOMs, allowing local management of the
resource.
The following example shows how to export managed FortiSwitch ports to multitenant VDOMs. In this example, the
owner VDOM is vdom1, and the tenant VDOM is root.

To export managed FortiSwitch ports to multitenant VDOMs:
1. Configure the switch VLAN interface, and assign it to the tenant VDOM:
(vdom1) # config system interface
edit "fsw_vlan"
set vdom "root"
set device-identification enable
set fortiheartbeat enable
set role lan
set snmp-index 32
set interface "fsw"
set vlanid 100
next
end

2. In the tenant VDOM, designate the default-virtual-switch-vlan, which is used to set the native VLAN of
ports leased from the owner VDOM:
(root) # config switch-controller global
set default-virtual-switch-vlan "fsw_vlan"
end

3. On vdom1, export the managed switch ports to the root:
(vdom1) # config switch-controller managed-switch
edit S248EPTF1800XXXX
set fsw-wan1-peer "fsw"
set fsw-wan1-admin enable
set version 1
set dynamic-capability 100531703
config ports
edit "port1"
set export-to "root"
next
...
end
next
end

The lease port is now available under the tenant VDOM:
(root) # config switch-controller managed-switch
show
config switch-controller managed-switch
edit "S248EPTF1800XXXX"
set type virtual
set owner-vdom "vdom1"
config ports
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edit "port1"
set vlan "fsw_vlan"
next
end
next
end

4. Export the managed FortiSwitch port to a virtual port pool for the tenant VDOM to choose from:
(vdom1) # config switch-controller virtual-port-pool
edit "tenant-monthly"
next
end
(vdom1) # config switch-controller managed-switch
edit "S248EPTF1800XXXX"
set fsw-wan1-peer "fsw"
set fsw-wan1-admin enable
set version 1
set dynamic-capability 100531703
config ports
edit "port2"
set vlan "vsw.fsw"
set allowed-vlans "qtn.fsw"
set untagged-vlans "qtn.fsw"
set export-to-pool "tenant-monthly"
set export-to "vdom1"
next
...
end
next
end

5. Request the available port in the virtual port pool to use the switch port:
(root) # execute switch-controller virtual-port-pool request S248EPTF1800XXXX port2
(root) # config switch-controller managed-switch
edit "S248EPTF1800XXXX"
set type virtual
set owner-vdom "vdom1"
config ports
edit "port2"
set vlan "fsw_vlan"
next
end
next
end

6. Return the port after use:
(root) # execute switch-controller virtual-port-pool return S248EPTF1800XXXX port2

7. Configure tags for the switch ports so the tags can be exported to virtual port pools
(vdom1) # config switch-controller switch-interface-tag
edit "vip"
next
edit "gold"
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next
edit "silver"
next
end
(vdom1) # config switch-controller managed-switch
edit "S248EPTF1800XXXX"
set fsw-wan1-peer "fsw"
set fsw-wan1-admin enable
set version 1
set dynamic-capability 100531703
config ports
edit "port2"
set export-to-pool "tenant-monthly"
set export-tags "silver"
set export-to "root"
next
edit "port3"
set vlan "vsw.fsw"
set allowed-vlans "qtn.fsw"
set untagged-vlans "qtn.fsw"
set export-to-pool "tenant-monthly"
set export-tags "vip"
set export-to "vdom1"
next
edit "port4"
set vlan "vsw.fsw"
set allowed-vlans "qtn.fsw"
set untagged-vlans "qtn.fsw"
set export-to-pool "tenant-monthly"
set export-tags "vip" "silver"
set export-to "vdom1"
next
end
next
end

8. Search for ports using tag filters:
(vdom1) # execute switch-controller virtual-port-pool show-by-tag silver
Switch
Port
Properties
Tags
---------------------------------------------------------------------------------------tenant-monthly(vdom.vdom1)
S248EPTF1800XXXX port2 (root)
10M/100M/1G/
silver
S248EPTF1800XXXX port4
10M/100M/1G/
vip,silver
(vdom1) # exe switch-controller virtual-port-pool show-by-tag vip
Switch
Port
Properties
Tags
---------------------------------------------------------------------------------------tenant-monthly(vdom.vdom1)
S248EPTF1800XXXX port3
10M/100M/1G/
vip
S248EPTF1800XXXX port4
10M/100M/1G/
vip,silver
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Persistent MAC learning
Persistent MAC learning or sticky MAC is a port security feature where dynamically learned MAC addresses are retained
when a switch or interface comes back online. The benefits of this feature include:
l

l

Prevent traffic loss from trusted workstations and servers since there is no need to relearn MAC address after a
restart.
Protect the switch and the whole network when combined with MAC-learning-limit against security attacks such as
Layer 2 DoS and overflow attacks.

Persistent MAC learning is configured in FortiGate and implemented in FortiSwitch.
This feature is disabled by default. You can use persistent MAC learning together with MAC limiting to restrict the
number of persistent MAC addresses.
This feature is hardware and CPU intensive and can take several minutes depending on the number of entries.
You can only use CLI to configure this feature.

This feature is supported on all FortiSwitch models in FSW 6.0.
This feature is supported on models in FSW 3.6 higher than the 124D series.

To enable sticky MAC on FortiGate:
config switch-controller managed-switch
edit <switch-serial-number>
conf ports
edit <port-number>
set sticky-mac enable
next
end
next
end

Before saving sticky Mac entries into CMDB, you might want to delete the unsaved sticky MAC items so that only the
items you want are saved.
Saving sticky MAC items copies the sticky MAC items from memory to CMDB on FortiSwitches and FortiGates.

To delete unsaved sticky MAC items:
execute switch-controller switch-action sticky-mac delete-unsaved <all | interface><switchserial-number>

To save sticky MAC items into CMDB:
execute switch-controller switch-action sticky-mac save <all | interface><switch-serialnumber>
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Split port mode (for QSFP / QSFP28)
The quad, small, form-factor pluggable plus (QSFP/QSPF28) is a transceiver module that offers high-density 40/100
Gigabit Ethernet connectivity options for data center and high-performance computing networks. The QSFP transceiver
module is a hot-swappable, parallel fiber-optic/copper module with four independent optical transmit and receive
channels. These channels can terminate in another Ethernet QSFP transceiver, or the channels can be broken out to
four separate physical ports.
Configuration of which FortiSwitch ports are split is controlled directly on the FortiSwitch. An administrator needs to
manually log into the FortiSwitch and set the desired split port configuration. After a split port configuration change is
made on the FortiSwitch, it will automatically reboot. If the FortiSwitch was previously discovered or authorized, it should
be deleted to allow the switch to be newly discovery again.

This feature requires a FortiSwitch model with SFP+ 40G ports, and FortiSwitch must be in
Fortlink mode when changing the split configuration.

To use previously discovered FortiSwitch with split ports with the switch controller:
1. On FortiSwitch, change the split mode:
This change requires a reboot.
config switch phy-mode
set port29-phy-mode 4x10G
set port30-phy-mode 4x10G
end

2. Delete the FortiSwitch from managed-switch stanza.
3. Discover and authorize.

To use FortiSwitch with factory defaults with split ports with the switch controller:
1. Discover and Authorize.
This change requires a reboot.
2. On FortiSwitch, change split mode.
This change requires a reboot.
3. Delete switch from managed-switch stanza.
4. Discover and authorize.
config switch-controller managed-switch
edit S524DN4K15000008
config ports
edit "port29.1"
set speed 10000
set vlan "vsw.port11"
set allowed-vlans "qtn.port11"
set untagged-vlans "qtn.port11"
set export-to "root"
next
......
edit "port29.4"
set speed 10000
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set
set
set
set

vlan "vsw.port11"
allowed-vlans "qtn.port11"
untagged-vlans "qtn.port11"
export-to "root"

next
edit "port30.1"
set speed 10000
set vlan "vsw.port11"
set allowed-vlans "qtn.port11"
set untagged-vlans "qtn.port11"
set export-to "root"
next
......
edit "port30.4"
set speed 10000
set vlan "vsw.port11"
set allowed-vlans "qtn.port11"
set untagged-vlans "qtn.port11"
set export-to "root"
next
end
next
end

Dynamic VLAN name assignment from RADIUS attribute
On the FortiGate, all VLANs are specified as a system interface. Each system interface has a well-defined and unique
name. When running FortiLink, the switch has no knowledge of the name association. The switch communicates directly
with the RADIUS server and needs to know the mapping to make the proper selection. This information must be
provided to the switch.
In order to make the feature generic and applicable to the switch in standalone mode, the system interface description
field is leveraged. The switch-controller synchronizes this field to the switch for information purposes. All descriptions on
the FortiGate remain on the FortiGate. The switch-controller synchronizes the FortiGate system interface name to the
switch VLAN description.
When FortiSwitch receives a VLAN assignment from a RADIUS server, it determines if the data is an integer or string
representation. If the representation is an integer, FortiSwitch assigns the VLAN. If the representation is a string, the
802.1x agent searches each FortiGate VLAN description field and, if a match is found, synchronizes the FortiGate
interface name to the switch's VLAN description. If no match is found, it will generate a syslog error stating that the VLAN
string was not found, the assingment could not be made, and the result is treated as in unauthorized or a failure.

To configure dynamic VLAN name assignment:
1. Configure a RADIUS server:
l Set Tunnel-Type to "VLAN"
l Set Tunnel-Medium-Type to "IEEE-802"
l Set Tunnel-Private-Group-Id to "my.vlan.10"
Designate the VLAN name instead of VLAN ID.
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2. Configure the FortiGate:
config system interface
edit "my.vlan.10"
set vdom "root"
set ip 1.1.1.254 255.255.255.0
set allowaccess ping
set interface "my.fortlink"
set vlanid 10
next
end

3. Configure the FortiSwitch:
config switch vlan
edit 10
set description "my.vlan.10"
next
end

MSTI support
Administrators can control multiple spanning tree instances (MSTI) one to 14, and allocate VLANs to specific instances.
VLANs that are not added to a specific interface are in MSTI-0. FortiLink controls MSTI-0 (CST) and MSTI-15 for
FortiLink management (VLAN 4094).
Each instance is a full and complete spanning tree. Any VLAN can be mapped to any instance, allowing the trees to have
different topologies for each MSTI. Various parameters can be configured in each instance, such as cost and priority.

To configure MSTI support:
1. Create a spanning tree protocol (STP) instance between 1 to 14:
config switch-controller stp-instance
edit 1
set vlan-range tenant-vlan3 vsw.aggr1
next
end

2. Configure a specific STP priority on different managed FortiSwitch units:
config switch-controller managed-switch
edit S248EPTF1800XXXX
config stp-instance
edit 1
set priority 8192
next
end
next
end
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Netflow and IPFIX support
You can configure Netflow (v1, v5, and v9) and IP Flow Information Export (IPFIX) on managed FortiSwitch units on
switch controller. The resulting data are available in FortiView and to FortiAnalyzer for traffic statistics and topology
views. Traffic sampling data can be used to show which users and device behind a switch are generating the most traffic.

The following CLI can be used to configure flow-tracking parameters:
config system flow-tracking
set sample-mode {local | perimeter | device-ingress}
set sample-rate <integer>
set format {netflow1 | netflow5 | netflow9 | ipfix}
set collector-ip <ip_address>
set collector-port <integer>
set transport {udp | tcp | sctp}
set level {vlan | ip | port | proto}
set max-export-pkt-size <integer>
set timeout-general <integer>
set timeout-icmp <integer>
set timeout-max <integer>
set timeout-tcp <integer>
set timeout-tcp-fin <integer>
set timeout-tcp-rst <integer>
set timeout-udp <integer>
config aggregates
edit <id>
set ip <ip_address>
next
end
end

Variable

Description

sample-mode {local | perimeter |
device-ingress}

Sample mode for flow tracking.
l local: Sample on the specific FortiSwitch port. Sampling must be enabled
on the specific FortiSwitch ports using the config switch-controller
managed-switch and config ports commands.
l perimeter: Sample on all non-fabric FortiSwitch ports, including the access
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Variable

Description

l

and FortiLink ports, but not the FortiLink ISL port.
device-ingress: Sample on all FortiSwitch ports.

sample-rate <integer>

Sample rate for the perimeter and device-ingress sampling (0 - 99999, default =
512).

format {netflow1 | netflow5 |
netflow9 | ipfix}

Flow tracking protocol (default = netflow9).

collector-ip <ip_address>

Collector IP address.
An all-zero IP address implies the feature is disabled

collector-port <integer>

Collector port number (0 - 65535, default=0).

transport {udp | tcp | sctp}

L4 transport protocol for exporting packets (default = udp).

level {vlan | ip | port | proto}

Flow tracking level.
l vlan: Collect srcip/dstip/srcport/dstport/protocol/tos/vlan from the sample
packet.
l ip: Collect srcip/dstip from the sample packet (default).
l port: Collect srcip/dstip/srcport/dstport/protocol from the sample packet.
l proto: Collect srcip/dstip/protocol from the sample packet.

max-export-pkt-size <integer>

Flow maximum export packet size, in bytes (512 - 9216, default = 512).

timeout-general <integer>

Flow session general timeout, in seconds (60 - 604800, default = 3600).

timeout-icmp <integer>

Flow session ICMP timeout, in seconds (60 - 604800, default = 300).

timeout-max <integer>

Flow session maximum timeout, in seconds (60 - 604800, default = 604800).

timeout-tcp <integer>

Flow session TCP timeout, in seconds (60 - 604800, default = 3600).

timeout-tcp-fin <integer>

Flow session TCP FIN timeout, in seconds (60 - 604800, default = 300).

timeout-tcp-rst <integer>

Flow session TCP RST timeout, in seconds (60 - 604800, default = 120).

timeout-udp <integer>

Flow session UDP timeout, in seconds (60 - 604800, default = 300).

config aggregates subcommand:
Aggregates in which all traffic sessions matching the IP address will be grouped into the same flow.
ip <ip_address>
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Logging and reporting are useful components to help you understand what is happening on your network, and to inform
you about certain network activities, such as the detection of a virus, a visit to an invalid website, an intrusion, a failed log
in attempt, and myriad others.
Logging records the traffic that passes through, starts from, or ends on the FortiGate, and records the actions the
FortiGate took during the traffic scanning process. After this information is recorded in a log message, it is stored in a log
file that is stored on a log device (a central storage location for log messages). FortiGates support several log devices,
such as FortiAnalyzer, FortiGateCloud, and syslog servers. Approximately 5% of memory is used for buffering logs sent
to FortiAnalyzer. The FortiGate system memory and local disk can also be configured to store logs, so it is also
considered a log device.
Reports show the recorded activity in a more readable format. A report gathers all the log information that it needs, then
presents it in a graphical format with a customizable design and automatically generated charts showing what is
happening on the network. Reports can be generated on FortiGate devices with disk logging and on FortiAnalyzer
devices.
FortiView is a more comprehensive network reporting and monitoring tool. It integrates real-time and historical data into
a single view in FortiOS. For more information, see FortiView on page 256.

Performance statistics are not logged to disk. Performance statistics can be received by a
syslog server or by FortiAnalyzer.

The following topics provide information about logging and reporting:
l
l
l
l
l
l
l

Sample logs by log type on page 1313
Checking the email filter log on page 1333
Supported log types to FortiAnalyzer, syslog, and FortiAnalyzer Cloud on page 1334
Configuring multiple FortiAnalyzers on a multi-VDOM FortiGate on page 1335
Configuring multiple FortiAnalyzers (or syslog servers) per VDOM on page 1337
Source and destination UUID logging on page 1339
Troubleshooting on page 1341

Sample logs by log type
This topic provides a sample raw log for each subtype and the configuration requirements.

Type and Subtype
Traffic Logs > Forward Traffic
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Log configuration requirements
config firewall policy
edit 1
set srcintf "port12"
set dstintf "port11"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set logtraffic all
set application-list "g-default"
set ssl-ssh-profile "certificate-inspection"
set nat enable
next
end

Sample log
date=2019-05-10 time=11:37:47 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="vdom1" eventtime=1557513467369913239 srcip=10.1.100.11 srcport=58012
srcintf="port12" srcintfrole="undefined" dstip=23.59.154.35 dstport=80 dstintf="port11"
dstintfrole="undefined" srcuuid="ae28f494-5735-51e9-f247-d1d2ce663f4b" dstuuid="ae28f4945735-51e9-f247-d1d2ce663f4b" poluuid="ccb269e0-5735-51e9-a218-a397dd08b7eb" sessionid=105048
proto=6 action="close" policyid=1 policytype="policy" service="HTTP" dstcountry="Canada"
srccountry="Reserved" trandisp="snat" transip=172.16.200.2 transport=58012 appid=34050
app="HTTP.BROWSER_Firefox" appcat="Web.Client" apprisk="elevated" applist="g-default"
duration=116 sentbyte=1188 rcvdbyte=1224 sentpkt=17 rcvdpkt=16 utmaction="allow" countapp=1
osname="Ubuntu" mastersrcmac="a2:e9:00:ec:40:01" srcmac="a2:e9:00:ec:40:01" srcserver=0
utmref=65500-742

Type and Subtype
Traffic Logs > Local Traffic

Log configuration requirements
config log setting
set local-in-allow enable
set local-in-deny-unicast enable
set local-in-deny-broadcast enable
set local-out enable
end

Sample log
date=2019-05-10 time=11:50:48 logid="0001000014" type="traffic" subtype="local"
level="notice" vd="vdom1" eventtime=1557514248379911176 srcip=172.16.200.254 srcport=62024
srcintf="port11" srcintfrole="undefined" dstip=172.16.200.2 dstport=443 dstintf="vdom1"
dstintfrole="undefined" sessionid=107478 proto=6 action="server-rst" policyid=0
policytype="local-in-policy" service="HTTPS" dstcountry="Reserved" srccountry="Reserved"
trandisp="noop" app="Web Management(HTTPS)" duration=5 sentbyte=1247 rcvdbyte=1719 sentpkt=5
rcvdpkt=6 appcat="unscanned"
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Type and Subtype
Traffic Logs > Multicast Traffic

Log configuration requirements
config firewall multicast-policy
edit 1
set dstaddr 230-1-0-0
set dstintf port3
set srcaddr 172-16-200-0
set srcintf port25
set action accept
set log enable
next
end
config sys setting
set multicast-forward enable
end

Sample log
date=2019-03-31 time=06:42:54 logid="0002000012" type="traffic" subtype="multicast"
level="notice" vd="vdom1" eventtime=1554039772 srcip=172.16.200.55 srcport=60660
srcintf="port25" srcintfrole="undefined" dstip=230.1.1.2 dstport=7878 dstintf="port3"
dstintfrole="undefined" sessionid=1162 proto=17 action="accept" policyid=1
policytype="multicast-policy" service="udp/7878" dstcountry="Reserved" srccountry="Reserved"
trandisp="noop" duration=22 sentbyte=5940 rcvdbyte=0 sentpkt=11 rcvdpkt=0 appcat="unscanned"

Type and Subtype
Traffic Logs > Sniffer Traffic

Log configuration requirements
config firewall sniffer
edit 3
set logtraffic all
set interface "port1"
set ips-sensor-status enable
set ips-sensor "sniffer-profile"
next
end

Sample log
date=2019-05-10 time=14:18:54 logid="0004000017" type="traffic" subtype="sniffer"
level="notice" vd="root" eventtime=1557523134021045897 srcip=208.91.114.4 srcport=50463
srcintf="port1" srcintfrole="undefined" dstip=104.80.88.154 dstport=443 dstintf="port1"
dstintfrole="undefined" sessionid=2193276 proto=6 action="accept" policyid=3
policytype="sniffer" service="HTTPS" dstcountry="United States" srccountry="Canada"
trandisp="snat" transip=0.0.0.0 transport=0 duration=10 sentbyte=0 rcvdbyte=0 sentpkt=0
rcvdpkt=0 appcat="unscanned" utmaction="allow" countips=1 crscore=5 craction=32768
sentdelta=0 rcvddelta=0 utmref=65162-7772
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Type and Subtype
Event Logs > System Events

Log configuration requirements
config log eventfilter
set event enable
set system enable
end

Sample log
date=2019-05-13 time=11:20:54 logid="0100032001" type="event" subtype="system"
level="information" vd="vdom1" eventtime=1557771654587081441 logdesc="Admin login
successful" sn="1557771654" user="admin" ui="ssh(172.16.200.254)" method="ssh"
srcip=172.16.200.254 dstip=172.16.200.2 action="login" status="success" reason="none"
profile="super_admin" msg="Administrator admin logged in successfully from ssh
(172.16.200.254)"

Type and Subtype
Event Logs > Router Events

Log configuration requirements
config log eventfilter
set event enable
set router enable
end
config router bgp
set log-neighbour-changes enable
end
config router ospf
set log-neighbour-changes enable
end

Sample log
date=2019-05-13 time=14:12:26 logid="0103020301" type="event" subtype="router"
level="warning" vd="root" eventtime=1557781946677737955 logdesc="Routing log" msg="OSPF:
RECV[Hello]: From 31.1.1.1 via port9:172.16.200.1: Invalid Area ID 0.0.0.0"

Type and Subtype
Event Logs > VPN Events

Log configuration requirements
config log eventfilter
set event enable
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set vpn enable
end

Sample log
date=2019-05-13 time=14:21:42 logid="0101037127" type="event" subtype="vpn" level="notice"
vd="root" eventtime=1557782502722231889 logdesc="Progress IPsec phase 1" msg="progress IPsec
phase 1" action="negotiate" remip=50.1.1.101 locip=50.1.1.100 remport=500 locport=500
outintf="port14" cookies="9091f4d4837ea71c/0000000000000000" user="N/A" group="N/A"
xauthuser="N/A" xauthgroup="N/A" assignip=N/A vpntunnel="test" status="success" init="local"
mode="main" dir="outbound" stage=1 role="initiator" result="OK"

Type and Subtype
Event Logs > User Events

Log configuration requirements
config log eventfilter
set event enable
set user enable
end

Sample log
date=2019-05-13 time=15:55:56 logid="0102043008" type="event" subtype="user" level="notice"
vd="root" eventtime=1557788156913809277 logdesc="Authentication success" srcip=10.1.100.11
dstip=172.16.200.55 policyid=1 interface="port10" user="bob" group="local-group1"
authproto="TELNET(10.1.100.11)" action="authentication" status="success" reason="N/A"
msg="User bob succeeded in authentication"

Type and Subtype
Event Logs > Endpoint Events

Log configuration requirements
config log eventfilter
set event enable
set endpoint enable
end

Sample log
date=2019-05-14 time=08:32:13 logid="0107045057" type="event" subtype="endpoint"
level="information" vd="root" eventtime=1557847933900764210 logdesc="FortiClient connection
added" action="add" status="success" license_limit="unlimited" used_for_type=4 connection_
type="sslvpn" count=1 user="skubas" ip=172.18.64.250 name="VAN-200957-PC"
fctuid="52C66FE08F724FE0B116DAD5062C96CD" msg="Add a FortiClient Connection."
date=2019-05-14 time=08:19:38 logid="0107045058" type="event" subtype="endpoint"
level="information" vd="root" eventtime=1557847179037488154 logdesc="FortiClient connection
closed" action="close" status="success" license_limit="unlimited" used_for_type=5

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1317

Log and Report

connection_type="sslvpn" count=1 user="skubas" ip=172.18.64.250 name="VAN-200957-PC"
fctuid="52C66FE08F724FE0B116DAD5062C96CD" msg="Close a FortiClient Connection."

Type and Subtype
Event Logs > HA Events

Log configuration requirements
config log eventfilter
set event enable
set ha enable
end

Sample log
date=2019-05-10 time=09:53:21 logid="0108037892" type="event" subtype="ha" level="notice"
vd="root" eventtime=1557507201608871077 logdesc="Virtual cluster member state moved"
msg="Virtual cluster's member state moved" ha_role="master" vcluster=1 vcluster_state="work"
vcluster_member=0 hostname="FW_QA4" sn="FG2K5E3916900348"
date=2019-05-10 time=09:53:18 logid="0108037894" type="event" subtype="ha" level="critical"
vd="root" eventtime=1557507199208575235 logdesc="Virtual cluster member joined" msg="Virtual
cluster detected member join" vcluster=1 ha_group=0 sn="FG2K5E3916900286"

Type and Subtype
Event Logs > Security Rating Events

Log configuration requirements
config log eventfilter
set event enable
set security-rating enable
end

Sample log
date=2019-05-13 time=14:40:59 logid="0110052000" type="event" subtype="security-rating"
level="notice" vd="root" eventtime=1557783659536252389 logdesc="Security Rating summary"
auditid=1557783648 audittime=1557783659 auditscore="5.0" criticalcount=1 highcount=6
mediumcount=8 lowcount=0 passedcount=38

Type and Subtype
Event Logs > WAN Opt & Cache Events

Log configuration requirements
config log eventfilter
set event enable
set wan-opt enable
end
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Sample log
date=2019-05-14 time=09:37:46 logid="0105048039" type="event" subtype="wad" level="error"
vd="root" eventtime=1557851867382676560 logdesc="SSL fatal alert sent" session_id=0
policyid=0 srcip=0.0.0.0 srcport=0 dstip=208.91.113.83 dstport=636 action="send" alert="2"
desc="certificate unknown" msg="SSL Alert sent"
date=2019-05-10 time=15:48:31 logid="0105048038" type="event" subtype="wad" level="error"
vd="root" eventtime=1557528511221374615 logdesc="SSL Fatal Alert received" session_
id=5f88ddd1 policyid=0 srcip=172.18.70.15 srcport=59880 dstip=91.189.89.223 dstport=443
action="receive" alert="2" desc="unknown ca" msg="SSL Alert received"

Type and Subtype
Event Logs > Wireless

Log configuration requirements
config log eventfilter
set event enable
set wireless-activity enable
end
config wireless-controller log
set status enable
end

Sample log
date=2019-05-13 time=11:30:08 logid="0104043568" type="event" subtype="wireless"
level="warning" vd="vdom1" eventtime=1557772208134721423 logdesc="Fake AP on air"
ssid="fortinet" bssid="90:6c:ac:89:e1:fa" aptype=0 rate=130 radioband="802.11n" channel=6
action="fake-ap-on-air" manuf="Fortinet, Inc." security="WPA2 Personal" encryption="AES"
signal=-93 noise=-95 live=353938 age=505 onwire="no" detectionmethod="N/A" stamac="N/A"
apscan="N/A" sndetected="N/A" radioiddetected=0 stacount=0 snclosest="FP320C3X17001909"
radioidclosest=0 apstatus=0 msg="Fake AP On-air fortinet 90:6c:ac:89:e1:fa chan 6 live
353938 age 505"

Type and Subtype
Event Logs > SDN Connector

Log configuration requirements
config log eventfilter
set event enable
set connector enable
end

Sample log
date=2019-05-13 time=16:09:43 logid="0112053200" type="event" subtype="connector"
level="information" vd="root" eventtime=1557788982 logdesc="IP address added" cfgobj="aws1"
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action="object-add" addr="54.210.36.196" cldobjid="i-0fe5a1ef16bb94796" netid="vpc-97e81cee"
msg="connector object discovered in addr-obj aws1, 54.210.36.196"
date=2019-05-13 time=16:09:43 logid="0112053201" type="event" subtype="connector"
level="information" vd="root" eventtime=1557788982 logdesc="IP address removed"
cfgobj="aws1" action="object-remove" addr="172.31.31.101" cldobjid="i-0fe5a1ef16bb94796"
netid="vpc-97e81cee" msg="connector object removed in addr-obj aws1, 172.31.31.101"

Type and Subtype
Event Logs > FortiExtender Events

Log configuration requirements
config log eventfilter
set event enable
set fortiextender enable
end

Sample log
date=2019-02-20 time=09:57:22 logid="0111046400" type="event" subtype="fortiextender"
level="notice" vd="root" eventtime=1550685442 logdesc="FortiExtender system activity"
action="FortiExtender Authorized"
msg="ext SN:FX04DN4N16002352 authorized"
date=2019-02-20 time=09:51:42 logid="0111046401" type="event" subtype="fortiextender"
level="notice" vd="root" eventtime=1550685102 logdesc="FortiExtender controller activity"
sn="FX04DN4N16002352" ip=11.11.11.2 action="ext session-deauthed" msg="ext
SN:FX04DN4N16002352 deauthorized"
date=2019-02-20 time=10:02:26 logid="0111046409" type="event" subtype="fortiextender"
level="information" vd="root" eventtime=1550685746 logdesc="Remote FortiExtender info
activity" sn="FX04DN4N16002352" ip=11.11.11.2 action="Cellular Connected"
imei="359376060442770" imsi="302720502331361" iccid="89302720403038146410"
phonenumber="+16045067526" carrier="Rogers" plan="Rogers-plan" apn="N/A" service="LTE"
msg="FX04DN4N16002352 STATE: sim with imsi:302720502331361 in slot:2 on carrier:Rogers
connected"
date=2019-02-20 time=10:33:57 logid="0111046407" type="event" subtype="fortiextender"
level="warning" vd="root" eventtime=1550687636 logdesc="Remote FortiExtender warning
activity" sn="FX04DN4N16002352" ip=11.11.11.2 action="Cellular Disconnected"
imei="359376060442770" imsi="N/A" iccid="N/A" phonenumber="N/A" carrier="N/A" plan="N/A"
apn="N/A" service="LTE" msg="FX04DN4N16002352 STATE: sim with imsi: in slot:2 on carrier:N/A
disconnected"
date=2019-02-20 time=10:02:24 logid="0111046409" type="event" subtype="fortiextender"
level="information" vd="root" eventtime=1550685744 logdesc="Remote FortiExtender info
activity" sn="FX04DN4N16002352" ip=11.11.11.2 action="Cellular Connecting"
imei="359376060442770" imsi="302720502331361" iccid="89302720403038146410"
phonenumber="+16045067526" carrier="Rogers" plan="Rogers-plan" apn="N/A" service="N/A"
msg="FX04DN4N16002352 STATE: sim with imsi:302720502331361 in slot:2 on carrier:Rogers
connecting
date=2019-02-20 time=10:47:19 logid="0111046407" type="event" subtype="fortiextender"
level="warning" vd="root" eventtime=1550688438 logdesc="Remote FortiExtender warning
activity" sn="FX04DN4N16002352" ip=11.11.11.2 action="SIM Change" imei="N/A" slot=2
msg="FX04DN4N16002352 SIM: SIM2 is inserted"
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date=2019-02-20 time=10:57:50 logid="0111046407" type="event" subtype="fortiextender"
level="warning" vd="root" eventtime=1550689069 logdesc="Remote FortiExtender warning
activity" sn="FX04DN4N16002352" ip=11.11.11.2 action="SIM Change" imei="359376060442770"
slot=1 msg="FX04DN4N16002352 SIM: SIM2 is plucked out"
date=2019-02-20 time=12:02:24 logid="0111046407" type="event" subtype="fortiextender"
level="warning" vd="root" eventtime=1550692942 logdesc="Remote FortiExtender warning
activity" sn="FX04DN4N16002352" ip=11.11.11.2 action="SIM Switch" imei="359376060442770"
reason="sim-switch can't take effect due to unavailability of 2 sim cards"
msg="FX04DN4N16002352 SIM: sim-switch can't take effect due to unavailability of 2 sim
cards"
date=2019-02-19 time=18:08:46 logid="0111046409" type="event" subtype="fortiextender"
level="information" vd="root" eventtime=1550628524 logdesc="Remote FortiExtender info
activity" sn="FX04DN4N16002352" ip=11.11.11.2 action="Cellular Signal Statistics"
imei="359376060442770" imsi="302720502331361" iccid="89302720403038146410"
phonenumber="+16045067526" carrier="Rogers" plan="Rogers-plan" service="LTE" sinr="7.0 dB"
rsrp="-89 dBm" rsrq="-16 dB" signalstrength="92 dBm" rssi="-54" temperature="40 C" apn="N/A"
msg="FX04DN4N16002352 INFO: LTE RSSI=-54dBm,RSRP=-89dBm,RSRQ=16dB,SINR=7.0dB,BAND=B2,CELLID=061C700F,BW=15MHz,RXCH=1025,TXCH=19025,TAC=8AAC,TEMPERATURE=4
0 C"
date=2019-02-19 time=18:09:46 logid="0111046409" type="event" subtype="fortiextender"
level="information" vd="root" eventtime=1550628585 logdesc="Remote FortiExtender info
activity" sn="FX04DN4N16002352" ip=11.11.11.2 action="Cellular Data Statistics"
imei="359376060442770" imsi="302720502331361" iccid="89302720403038146410"
phonenumber="+16045067526" carrier="Rogers" plan="Rogers-plan" service="LTE" rcvdbyte=7760
sentbyte=3315 msg="FX04DN4N16002352 INFO: SIM2 LTE, rx=7760, tx=3315, rx_diff=2538, tx_
diff=567"

Type and Subtype
Security Logs > Antivirus

Log configuration requirements
config antivirus profile
edit "test-av"
config http
set options scan
end
set av-virus-log enable
set av-block-log enable
next
end
config firewall policy
edit 1
set srcintf "port12"
set dstintf "port11"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set av-profile "test-av"
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set logtraffic utm
set nat enable
next
end

Sample log
date=2019-05-13 time=11:45:03 logid="0211008192" type="utm" subtype="virus"
eventtype="infected" level="warning" vd="vdom1" eventtime=1557773103767393505 msg="File is
infected." action="blocked" service="HTTP" sessionid=359260 srcip=10.1.100.11
dstip=172.16.200.55 srcport=60446 dstport=80 srcintf="port12" srcintfrole="undefined"
dstintf="port11" dstintfrole="undefined" policyid=4 proto=6 direction="incoming"
filename="eicar.com" quarskip="File-was-not-quarantined." virus="EICAR_TEST_FILE"
dtype="Virus" ref="http://www.fortinet.com/ve?vn=EICAR_TEST_FILE" virusid=2172
url="http://172.16.200.55/virus/eicar.com" profile="g-default" agent="curl/7.47.0"
analyticscksum="275a021bbfb6489e54d471899f7db9d1663fc695ec2fe2a2c4538aabf651fd0f"
analyticssubmit="false" crscore=50 craction=2 crlevel="critical"
# Corresponding Traffic Log #
date=2019-05-13 time=11:45:04 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="vdom1" eventtime=1557773104815101919 srcip=10.1.100.11 srcport=60446
srcintf="port12" srcintfrole="undefined" dstip=172.16.200.55 dstport=80 dstintf="port11"
dstintfrole="undefined" srcuuid="48420c8a-5c88-51e9-0424-a37f9e74621e" dstuuid="187d6f465c86-51e9-70a0-fadcfc349c3e" poluuid="3888b41a-5c88-51e9-cb32-1c32c66b4edf" sessionid=359260
proto=6 action="close" policyid=4 policytype="policy" service="HTTP" dstcountry="Reserved"
srccountry="Reserved" trandisp="snat" transip=172.16.200.2 transport=60446 appid=15893
app="HTTP.BROWSER" appcat="Web.Client" apprisk="medium" applist="g-default" duration=1
sentbyte=412 rcvdbyte=2286 sentpkt=6 rcvdpkt=6 wanin=313 wanout=92 lanin=92 lanout=92
utmaction="block" countav=1 countapp=1 crscore=50 craction=2 osname="Ubuntu"
mastersrcmac="a2:e9:00:ec:40:01" srcmac="a2:e9:00:ec:40:01" srcserver=0 utmref=65497-770

Type and Subtype
Security Logs > Web Filter

Log configuration requirements
config webfilter profile
edit "test-webfilter"
set web-content-log enable
set web-filter-activex-log enable
set web-filter-command-block-log enable
set web-filter-cookie-log enable
set web-filter-applet-log enable
set web-filter-jscript-log enable
set web-filter-js-log enable
set web-filter-vbs-log enable
set web-filter-unknown-log enable
set web-filter-referer-log enable
set web-filter-cookie-removal-log enable
set web-url-log enable
set web-invalid-domain-log enable
set web-ftgd-err-log enable
set web-ftgd-quota-usage enable
next
end
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config firewall policy
edit 1
set name "v4-out"
set srcintf "port12"
set dstintf "port11"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set logtraffic utm
set utm-status enable
set webfilter-profile "test-webfilter"
set nat enable
next
end

Sample log
date=2019-05-13 time=16:29:45 logid="0316013056" type="utm" subtype="webfilter"
eventtype="ftgd_blk" level="warning" vd="vdom1" eventtime=1557790184975119738 policyid=1
sessionid=381780 srcip=10.1.100.11 srcport=44258 srcintf="port12" srcintfrole="undefined"
dstip=185.244.31.158 dstport=80 dstintf="port11" dstintfrole="undefined" proto=6
service="HTTP" hostname="morrishittu.ddns.net" profile="test-webfilter" action="blocked"
reqtype="direct" url="/" sentbyte=84 rcvdbyte=0 direction="outgoing" msg="URL belongs to a
denied category in policy" method="domain" cat=26 catdesc="Malicious Websites" crscore=30
craction=4194304 crlevel="high"
# Corresponding traffic log #
date=2019-05-13 time=16:29:50 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="vdom1" eventtime=1557790190452146185 srcip=10.1.100.11 srcport=44258
srcintf="port12" srcintfrole="undefined" dstip=185.244.31.158 dstport=80 dstintf="port11"
dstintfrole="undefined" srcuuid="ae28f494-5735-51e9-f247-d1d2ce663f4b" dstuuid="ae28f4945735-51e9-f247-d1d2ce663f4b" poluuid="ccb269e0-5735-51e9-a218-a397dd08b7eb" sessionid=381780
proto=6 action="close" policyid=1 policytype="policy" service="HTTP" dstcountry="Germany"
srccountry="Reserved" trandisp="snat" transip=172.16.200.2 transport=44258 duration=5
sentbyte=736 rcvdbyte=3138 sentpkt=14 rcvdpkt=5 appcat="unscanned" utmaction="block"
countweb=1 crscore=30 craction=4194304 osname="Ubuntu" mastersrcmac="a2:e9:00:ec:40:01"
srcmac="a2:e9:00:ec:40:01" srcserver=0 utmref=65497-796

Type and Subtype
Security Logs > DNS Query

Log configuration requirements
config dnsfilter profile
edit "dnsfilter_fgd"
config ftgd-dns
set options error-allow
end
set log-all-domain enable
set block-botnet enable
next
end
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config firewall policy
edit 1
set srcintf "port12"
set dstintf "port11"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set dnsfilter-profile "dnsfilter_fgd"
set logtraffic utm
set nat enable
next
end

Sample log
date=2019-05-15 time=15:05:49 logid="1501054802" type="utm" subtype="dns" eventtype="dnsresponse" level="notice" vd="vdom1" eventtime=1557957949740931155 policyid=1 sessionid=6887
srcip=10.1.100.22 srcport=50002 srcintf="port12" srcintfrole="undefined"
dstip=172.16.100.100 dstport=53 dstintf="port11" dstintfrole="undefined" proto=17
profile="dnsfilter_fgd" srcmac="a2:e9:00:ec:40:41" xid=57945 qname="changelogs.ubuntu.com"
qtype="AAAA" qtypeval=28 qclass="IN" ipaddr="2001:67c:1560:8008::11" msg="Domain is
monitored" action="pass" cat=52 catdesc="Information Technology"
date=2019-05-15 time=15:05:49 logid="1500054000" type="utm" subtype="dns" eventtype="dnsquery" level="information" vd="vdom1" eventtime=1557957949653103543 policyid=1
sessionid=6887 srcip=10.1.100.22 srcport=50002 srcintf="port12" srcintfrole="undefined"
dstip=172.16.100.100 dstport=53 dstintf="port11" dstintfrole="undefined" proto=17
profile="dnsfilter_fgd" srcmac="a2:e9:00:ec:40:41" xid=57945 qname="changelogs.ubuntu.com"
qtype="AAAA" qtypeval=28 qclass="IN"
# Corresponding traffic log #
date=2019-05-15 time=15:08:49 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="vdom1" eventtime=1557958129950003945 srcip=10.1.100.22 srcport=50002
srcintf="port12" srcintfrole="undefined" dstip=172.16.100.100 dstport=53 dstintf="port11"
dstintfrole="undefined" srcuuid="ae28f494-5735-51e9-f247-d1d2ce663f4b" dstuuid="ae28f4945735-51e9-f247-d1d2ce663f4b" poluuid="ccb269e0-5735-51e9-a218-a397dd08b7eb" sessionid=6887
proto=17 action="accept" policyid=1 policytype="policy" service="DNS" dstcountry="Reserved"
srccountry="Reserved" trandisp="snat" transip=172.16.200.2 transport=50002 duration=180
sentbyte=67 rcvdbyte=207 sentpkt=1 rcvdpkt=1 appcat="unscanned" utmaction="allow" countdns=1
osname="Linux" mastersrcmac="a2:e9:00:ec:40:41" srcmac="a2:e9:00:ec:40:41" srcserver=0
utmref=65495-306

Type and Subtype
Security Logs > Application Control

Log configuration requirements
# log enabled by default in application profile entry
config application list
edit "block-social.media"
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set other-application-log enable
config entries
edit 1
set category 2 5 6 23
set log enable
next
end
next
end
config firewall policy
edit 1
set name "to_Internet"
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set logtraffic utm
set application-list "block-social.media"
set ssl-ssh-profile "deep-inspection"
set nat enable
next
end

Sample log
date=2019-05-15 time=18:03:36 logid="1059028704" type="utm" subtype="app-ctrl"
eventtype="app-ctrl-all" level="information" vd="root" eventtime=1557968615 appid=40568
srcip=10.1.100.22 dstip=195.8.215.136 srcport=50798 dstport=443 srcintf="port10"
srcintfrole="lan" dstintf="port9" dstintfrole="wan" proto=6 service="HTTPS"
direction="outgoing" policyid=1 sessionid=4414 applist="block-social.media"
appcat="Web.Client" app="HTTPS.BROWSER" action="pass" hostname="www.dailymotion.com"
incidentserialno=1962906680 url="/" msg="Web.Client: HTTPS.BROWSER," apprisk="medium"
scertcname="*.dailymotion.com" scertissuer="DigiCert SHA2 High Assurance Server CA"
date=2019-05-15 time=18:03:35 logid="1059028705" type="utm" subtype="app-ctrl"
eventtype="app-ctrl-all" level="warning" vd="root" eventtime=1557968615 appid=16072
srcip=10.1.100.22 dstip=195.8.215.136 srcport=50798 dstport=443 srcintf="port10"
srcintfrole="lan" dstintf="port9" dstintfrole="wan" proto=6 service="HTTPS"
direction="incoming" policyid=1 sessionid=4414 applist="block-social.media"
appcat="Video/Audio" app="Dailymotion" action="block" hostname="www.dailymotion.com"
incidentserialno=1962906682 url="/" msg="Video/Audio: Dailymotion," apprisk="elevated"
date=2019-05-15 time=18:03:35 logid="1059028705" type="utm" subtype="app-ctrl"
eventtype="app-ctrl-all" level="warning" vd="root" eventtime=1557968615 appid=16072
srcip=10.1.100.22 dstip=195.8.215.136 srcport=50798 dstport=443 srcintf="port10"
srcintfrole="lan" dstintf="port9" dstintfrole="wan" proto=6 service="HTTPS"
direction="incoming" policyid=1 sessionid=4414 applist="block-social.media"
appcat="Video/Audio" app="Dailymotion" action="block" hostname="www.dailymotion.com"
incidentserialno=1962906681 url="/" msg="Video/Audio: Dailymotion," apprisk="elevated"
# Corresponding Traffic Log #
date=2019-05-15 time=18:03:41 logid="0000000013" type="traffic" subtype="forward"
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level="notice" vd="root" eventtime=1557968619 srcip=10.1.100.22 srcport=50798
srcintf="port10" srcintfrole="lan" dstip=195.8.215.136 dstport=443 dstintf="port9"
dstintfrole="wan" poluuid="d8ce7a90-7763-51e9-e2be-741294c96f31" sessionid=4414 proto=6
action="client-rst" policyid=1 policytype="policy" service="HTTPS" dstcountry="France"
srccountry="Reserved" trandisp="snat" transip=172.16.200.10 transport=50798 appid=16072
app="Dailymotion" appcat="Video/Audio" apprisk="elevated" applist="block-social.media"
appact="drop-session" duration=5 sentbyte=1150 rcvdbyte=7039 sentpkt=13 utmaction="block"
countapp=3 devtype="Unknown" devcategory="None" mastersrcmac="00:0c:29:51:38:5e"
srcmac="00:0c:29:51:38:5e" srcserver=0 utmref=0-330

Type and Subtype
Security Logs > Intrusion Prevention

Log configuration requirements
# log enabled by default in ips sensor
config ips sensor
edit "block-critical-ips"
config entries
edit 1
set severity critical
set status enable
set action block
set log enable
next
end
next
end
config firewall policy
edit 1
set name "to_Internet"
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set logtraffic utm
set ips-sensor "block-critical-ips"
set nat enable
next
end

Sample log
date=2019-05-15 time=17:56:41 logid="0419016384" type="utm" subtype="ips"
eventtype="signature" level="alert" vd="root" eventtime=1557968201 severity="critical"
srcip=10.1.100.22 srccountry="Reserved" dstip=172.16.200.55 srcintf="port10"
srcintfrole="lan" dstintf="port9" dstintfrole="wan" sessionid=4017 action="dropped" proto=6
service="HTTP" policyid=1 attack="Adobe.Flash.newfunction.Handling.Code.Execution"

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1326

Log and Report

srcport=46810 dstport=80 hostname="172.16.200.55" url="/ips/sig1.pdf" direction="incoming"
attackid=23305 profile="block-critical-ips" ref="http://www.fortinet.com/ids/VID23305"
incidentserialno=582633933 msg="applications3:
Adobe.Flash.newfunction.Handling.Code.Execution," crscore=50 craction=4096
crlevel="critical"
# Corresponding Traffic Log #
date=2019-05-15 time=17:58:10 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="root" eventtime=1557968289 srcip=10.1.100.22 srcport=46810
srcintf="port10" srcintfrole="lan" dstip=172.16.200.55 dstport=80 dstintf="port9"
dstintfrole="wan" poluuid="d8ce7a90-7763-51e9-e2be-741294c96f31" sessionid=4017 proto=6
action="close" policyid=1 policytype="policy" service="HTTP" dstcountry="Reserved"
srccountry="Reserved" trandisp="snat" transip=172.16.200.10 transport=46810 duration=89
sentbyte=565 rcvdbyte=9112 sentpkt=9 rcvdpkt=8 appcat="unscanned" utmaction="block"
countips=1 crscore=50 craction=4096 devtype="Unknown" devcategory="None"
mastersrcmac="00:0c:29:51:38:5e" srcmac="00:0c:29:51:38:5e" srcserver=0 utmref=0-302

Type and Subtype
Security Logs > Anomaly

Log configuration requirements
config firewall DoS-policy
edit 1
set interface "port12"
set srcaddr "all"
set dstaddr "all"
set service "ALL"
config anomaly
edit "icmp_flood"
set status enable
set log enable
set action block
set threshold 50
next
end
next
end

Sample log
date=2019-05-13 time=17:05:59 logid="0720018433" type="utm" subtype="anomaly"
eventtype="anomaly" level="alert" vd="vdom1" eventtime=1557792359461869329
severity="critical" srcip=10.1.100.11 srccountry="Reserved" dstip=172.16.200.55
srcintf="port12" srcintfrole="undefined" sessionid=0 action="clear_session" proto=1
service="PING" count=1 attack="icmp_flood" icmpid="0x1474" icmptype="0x08" icmpcode="0x00"
attackid=16777316 policyid=1 policytype="DoS-policy"
ref="http://www.fortinet.com/ids/VID16777316" msg="anomaly: icmp_flood, 51 > threshold 50"
crscore=50 craction=4096 crlevel="critical"

Type and Subtype
Security Logs > Data Leak Prevention
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Log configuration requirements
config dlp sensor
edit "dlp-file-type-test"
set comment ''
set replacemsg-group ''
config filter
edit 1
set name ''
set severity medium
set type file
set proto http-get http-post ftp
set filter-by file-type
set file-type 1
set archive enable
set action block
next
end
set dlp-log enable
next
end
config firewall policy
edit 1
set name "to_Internet"
set srcintf "port10"
set dstintf "port9"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set inspection-mode proxy
set logtraffic utm
set dlp-sensor "dlp-file-type-test"
set ssl-ssh-profile "deep-inspection"
set nat enable
next
end

Sample log
date=2019-05-15 time=17:45:30 logid="0954024576" type="utm" subtype="dlp" eventtype="dlp"
level="warning" vd="root" eventtime=1557967528 filteridx=1 dlpextra="dlp-file-size11"
filtertype="file-type" filtercat="file" severity="medium" policyid=1 sessionid=3423
epoch=1740880646 eventid=0 srcip=10.1.100.22 srcport=50354 srcintf="port10"
srcintfrole="lan" dstip=52.216.177.83 dstport=443 dstintf="port9" dstintfrole="wan" proto=6
service="HTTPS" filetype="pdf" direction="incoming" action="block"
hostname="fortinetweb.s3.amazonaws.com" url="/docs.fortinet.com/v2/attachments/be3d0e3d4b62-11e9-94bf-00505692583a/FortiOS_6.2.0_Log_Reference.pdf" agent="Wget/1.17.1"
filename="FortiOS_6.2.0_Log_Reference.pdf" filesize=16360 profile="dlp-file-type-test"
# Corresponding Traffic Log #
date=2019-05-15 time=17:45:34 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="root" eventtime=1557967534 srcip=10.1.100.22 srcport=50354
srcintf="port10" srcintfrole="lan" dstip=52.216.177.83 dstport=443 dstintf="port9"
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dstintfrole="wan" poluuid="d8ce7a90-7763-51e9-e2be-741294c96f31" sessionid=3423 proto=6
action="server-rst" policyid=1 policytype="policy" service="HTTPS" dstcountry="United
States" srccountry="Reserved" trandisp="snat" transip=172.16.200.10 transport=50354
duration=5 sentbyte=2314 rcvdbyte=5266 sentpkt=33 rcvdpkt=12 appcat="unscanned" wanin=43936
wanout=710 lanin=753 lanout=753 utmaction="block" countdlp=1 crscore=5 craction=262144
crlevel="low" devtype="Unknown" devcategory="None" mastersrcmac="00:0c:29:51:38:5e"
srcmac="00:0c:29:51:38:5e" srcserver=0 utmref=0-152

Type and Subtype
Security Logs > SSH
Security Logs > SSL

Log configuration requirements
config ssh-filter profile
edit "ssh-deepscan"
set block shell
set log shell
set default-command-log disable
next
end
config firewall policy
edit 1
set srcintf "port21"
set dstintf "port23"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set inspection-mode proxy
set ssh-filter-profile "ssh-deepscan"
set profile-protocol-options "protocol"
set ssl-ssh-profile "ssl"
set nat enable
next
end

For SSL-Traffic-log, enable logtraffic all
config firewall policy
edit 1
set srcintf "dmz"
set dstintf "wan1"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set inspection-mode proxy
set logtraffic all
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set ssl-ssh-profile "deep-inspection"
set nat enable
next
end

For SSL-UTM-log
#EVENTTYPE="SSL-ANOMALIES"

By default, ssl-anomalies-log is enabled.
config firewall ssl-ssh-profile
edit "deep-inspection"
set comment "Read-only deep inspection profile."
set server-cert-mode re-sign
set caname "Fortinet_CA_SSL"
set untrusted-caname "Fortinet_CA_Untrusted"
set ssl-anomalies-log enable
set ssl-exemptions-log disable
set rpc-over-https disable
set mapi-over-https disable
set use-ssl-server disable
next
end
# EVENTTYPE="SSL-EXEMPT"

Need to enable ssl-exemptions-log to generate ssl-utm-exempt log.
config firewall ssl-ssh-profile
edit "deep-inspection"
set comment "Read-only deep inspection profile."
set server-cert-mode re-sign
set caname "Fortinet_CA_SSL"
set untrusted-caname "Fortinet_CA_Untrusted"
set ssl-anomalies-log enable
set ssl-exemptions-log enable
set rpc-over-https disable
set mapi-over-https disable
set use-ssl-server disable
next
end

Sample log for SSH
date=2019-05-15 time=16:18:17 logid="1601061010" type="utm" subtype="ssh" eventtype="sshchannel" level="warning" vd="vdom1" eventtime=1557962296 policyid=1 sessionid=344
profile="ssh-deepscan" srcip=10.1.100.11 srcport=43580 dstip=172.16.200.44 dstport=22
srcintf="port21" srcintfrole="undefined" dstintf="port23" dstintfrole="undefined" proto=6
action="blocked" direction="outgoing" login="root" channeltype="shell"
# Corresponding Traffic Log #
date=2019-05-15 time=16:18:18 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="vdom1" eventtime=1557962298 srcip=10.1.100.11 srcport=43580
srcintf="port21" srcintfrole="undefined" dstip=172.16.200.44 dstport=22 dstintf="port23"
dstintfrole="undefined" poluuid="49871fae-7371-51e9-17b4-43c7ff119195" sessionid=344 proto=6
action="close" policyid=1 policytype="policy" service="SSH" dstcountry="Reserved"
srccountry="Reserved" trandisp="snat" transip=172.16.200.171 transport=43580 duration=8
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sentbyte=3093 rcvdbyte=2973 sentpkt=18 rcvdpkt=16 appcat="unscanned" utmaction="block"
countssh=1 utmref=65535-0

Sample log for SSL
For SSL-Traffic-log
date=2019-05-16 time=10:08:26 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="root" eventtime=1558026506763925658 srcip=10.1.100.66 srcport=38572
srcintf="dmz" srcintfrole="dmz" dstip=104.154.89.105 dstport=443 dstintf="wan1"
dstintfrole="wan" poluuid="a17c0a38-75c6-51e9-4c0d-d547347b63e5" sessionid=100 proto=6
action="server-rst" policyid=1 policytype="policy" service="HTTPS" dstcountry="United
States" srccountry="Reserved" trandisp="snat" transip=172.16.200.11 transport=38572
duration=5 sentbyte=930 rcvdbyte=6832 sentpkt=11 rcvdpkt=19 appcat="unscanned" wanin=1779
wanout=350 lanin=754 lanout=754 utmaction="block" countssl=1 crscore=5 craction=262144
crlevel="low" utmref=65467-0

For SSL-UTM-log
#EVENTTYPE="SSL-ANOMALIES"
date=2019-03-28 time=10:44:53 logid="1700062002" type="utm" subtype="ssl" eventtype="sslanomalies" level="warning" vd="vdom1" eventtime=1553795092 policyid=1 sessionid=10796
service="HTTPS" srcip=10.1.100.66 srcport=43602 dstip=104.154.89.105 dstport=443
srcintf="port2" srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" proto=6
action="blocked" msg="Server certificate blocked" reason="block-cert-invalid"
date=2019-03-28 time=10:51:17 logid="1700062002" type="utm" subtype="ssl" eventtype="sslanomalies" level="warning" vd="vdom1" eventtime=1553795476 policyid=1 sessionid=11110
service="HTTPS" srcip=10.1.100.66 srcport=49076 dstip=172.16.200.99 dstport=443
srcintf="port2" srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" proto=6
action="blocked" msg="Server certificate blocked" reason="block-cert-untrusted"
date=2019-03-28 time=10:55:43 logid="1700062002" type="utm" subtype="ssl" eventtype="sslanomalies" level="warning" vd="vdom1" eventtime=1553795742 policyid=1 sessionid=11334
service="HTTPS" srcip=10.1.100.66 srcport=49082 dstip=172.16.200.99 dstport=443
srcintf="port2" srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" proto=6
action="blocked" msg="Server certificate blocked" reason="block-cert-req"
date=2019-03-28 time=10:57:42 logid="1700062053" type="utm" subtype="ssl" eventtype="sslanomalies" level="warning" vd="vdom1" eventtime=1553795861 policyid=1 sessionid=11424
service="SMTPS" profile="block-unsupported-ssl" srcip=10.1.100.66 srcport=41296
dstip=172.16.200.99 dstport=8080 srcintf="port2" srcintfrole="undefined" dstintf=unknown-0
dstintfrole="undefined" proto=6 action="blocked" msg="Connection is blocked due to
unsupported SSL traffic" reason="malformed input"
date=2019-03-28 time=11:00:17 logid="1700062002" type="utm" subtype="ssl" eventtype="sslanomalies" level="warning" vd="vdom1" eventtime=1553796016 policyid=1 sessionid=11554
service="HTTPS" srcip=10.1.100.66 srcport=49088 dstip=172.16.200.99 dstport=443
srcintf="port2" srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" proto=6
action="blocked" msg="Server certificate blocked" reason="block-cert-sni-mismatch"
date=2019-03-28 time=11:02:07 logid="1700062000" type="utm" subtype="ssl" eventtype="sslanomalies" level="warning" vd="vdom1" eventtime=1553796126 policyid=1 sessionid=11667
service="HTTPS" srcip=10.1.100.66 srcport=49096 dstip=172.16.200.99 dstport=443
srcintf="port2" srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" proto=6
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action="blocked" msg="Certificate blacklisted"
certhash="1115ec1857ed7f937301ff5e02f6b0681cf2ec4e" reason="Other"
# EVENTTYPE="SSL-EXEMPT"
date=2019-03-28 time=11:06:05 logid="1701062003" type="utm" subtype="ssl" eventtype="sslexempt" level="notice" vd="vdom1" eventtime=1553796363 policyid=1 sessionid=11871
service="HTTPS" srcip=10.1.100.66 srcport=47384 dstip=50.18.221.132 dstport=443
srcintf="port2" srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" proto=6
action="exempt" msg="SSL connection exempted" reason="exempt-whitelist"
date=2019-03-28 time=11:09:14 logid="1701062003" type="utm" subtype="ssl" eventtype="sslexempt" level="notice" vd="vdom1" eventtime=1553796553 policyid=1 sessionid=12079
service="HTTPS" srcip=10.1.100.66 srcport=49102 dstip=172.16.200.99 dstport=443
srcintf="port2" srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" proto=6
action="exempt" msg="SSL connection exempted" reason="exempt-addr"
date=2019-03-28 time=11:10:55 logid="1701062003" type="utm" subtype="ssl" eventtype="sslexempt" level="notice" vd="vdom1" eventtime=1553796654 policyid=1 sessionid=12171
service="HTTPS" srcip=10.1.100.66 srcport=47390 dstip=50.18.221.132 dstport=443
srcintf="port2" srcintfrole="undefined" dstintf="port3" dstintfrole="undefined" proto=6
action="exempt" msg="SSL connection exempted" reason="exempt-ftgd-cat"

Type and Subtype
Security Logs > CIFS

Log configuration requirements
config cifs profile
edit "cifs"
set server-credential-type none
config file-filter
set status enable
set log enable
config entries
edit "1"
set comment ''
set action block
set direction any
set file-type "msoffice"
next
end
end
next
end
config firewall policy
edit 1
set srcintf "port21"
set dstintf "port23"
set srcaddr "all"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
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set
set
set
set
set

inspection-mode proxy
cifs-profile "cifs"
profile-protocol-options "protocol"
ssl-ssh-profile "ssl"
nat enable

next
end

Sample log
date=2019-05-15 time=16:28:17 logid="1800063000" type="utm" subtype="cifs" eventtype="cifsfilefilter" level="warning" vd="vdom1" eventtime=1557962895 msg="File was blocked by file
filter." direction="incoming" action="blocked" service="CIFS" srcip=10.1.100.11
dstip=172.16.200.44 srcport=56348 dstport=445 srcintf="port21" srcintfrole="undefined"
dstintf="port23" dstintfrole="undefined" policyid=1 proto=16 profile="cifs" filesize="13824"
filename="sample\\test.xls" filtername="1" filetype="msoffice"

Checking the email filter log
To check the email filter log in the CLI:
execute log filter category 5
execute log display
1 logs found.
1 logs returned.
1: date=2019-04-09 time=03:41:18 logid="0510020491" type="utm" subtype="emailfilter"
eventtype="imap" level="notice" vd="vdom1" eventtime=1554806478647415130 policyid=1
sessionid=439 srcip=10.1.100.22 srcport=39937 srcintf="port21" srcintfrole="undefined"
dstip=172.16.200.45 dstport=143 dstintf="port17" dstintfrole="undefined" proto=6
service="IMAPS" profile="822881" action="blocked" from="testpc3@qa.fortinet.com"
to="testpc3@qa.fortinet.com" recipient="testpc3" direction="incoming" msg="from ip is in ip
blacklist.(path black ip 172.16.200.9)" subject="testcase822881" size="525" attachment="no"
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To check the email filter log in the GUI:
1. Go to Log & Report > Anti-Spam.

Supported log types to FortiAnalyzer, syslog, and FortiAnalyzer
Cloud
This topic describes which log messages are supported by each logging destination:

Log Type

FortiAnalyzer

Syslog

FortiAnalyzer Cloud

Traffic

Yes

Yes

No

Event

Yes

Yes

Yes

Virus

Yes

Yes

No

Webfilter

Yes

Yes

No

IPS

Yes

Yes

No

Emailfilter

Yes

Yes

No

Anomaly

Yes

Yes

No

VOIP

Yes

Yes

No

DLP

Yes

Yes

No

App-Ctrl

Yes

Yes

No

WAF

Yes

Yes

No

GTP

Yes

Yes

No

DNS

Yes

Yes

No

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1334

Log and Report

Log Type

FortiAnalyzer

Syslog

FortiAnalyzer Cloud

SSH

Yes

Yes

No

SSL

Yes

Yes

No

CIFS

No

Yes

No

Configuring multiple FortiAnalyzers on a multi-VDOM FortiGate
This topic shows a sample configuration of multiple FortiAnalyzers on a multi-VDOM FortiGate.
In this example:
l

l

The FortiGate has three VDOMs:
l Root (management VDOM)
l VDOM1
l VDOM2
There are four FortiAnalyzers.
These IP addresses are used as examples in the instructions below.
FAZ1: 172.16.200.55
FAZ2: 172.18.60.25
l FAZ3: 192.168.1.253
l FAZ4: 192.168.1.254
Set up FAZ1 and FAZ2 under global.
l These two collect logs from the root VDOM and VDOM2.
l FAZ1 and FAZ2 must be accessible from management VDOM root.
Set up FAZ3 and FAZ4 under VDOM1.
l These two collect logs from VDOM1.
l FAZ3 and FAZ4 must be accessible from VDOM1.
l
l

l

l

To set up FAZ1 as global FortiAnalyzer 1 from the GUI:
Prerequisite: FAZ1 must be reachable from the management root VDOM.
1. Go to Global > Log & Report > Log Settings.
2. Enable Send logs to FortiAnalyzer/FortiManager.
3. Enter the FortiAnalyzer IP.
In this example: 172.16.200.55.
4. For Upload option, select Real Time.
5. Click Apply.

To set up FAZ2 as global FortiAnalyzer 2 from the CLI:
Prerequisite: FAZ2 must be reachable from the management root VDOM.
config log fortianalyzer2 setting
set status enable
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set server "172.18.60.25"
set upload-option realtime
end

To set up FAZ3 and FAZ4 as VDOM1 FortiAnalyzer 1 and FortiAnalyzer 2:
Prerequisite: FAZ3 and FAZ4 must be reachable from VDOM1.
config log setting
set faz-override enable
end
config
set
set
set
end

log fortianalyzer override-setting
status enable
server "192.168.1.253"
upload-option realtime

config
set
set
set
end

log fortianalyzer2 override-setting
status enable
server "192.168.1.254"
upload-option realtime

Checking FortiAnalyzer connectivity
To use the diagnose command to check FortiAnalyzer connectivity:
1. Check the global FortiAnalyzer status:
FGTA(global) # diagnose test application miglogd 1
faz: global , enabled
server=172.16.200.55, realtime=3, ssl=1, state=connected, src=, mgmt_name=FGh_
Log_root_172.16.200.55, reliable=1
status: ver=6, used_disk=0, total_disk=0, global=0, vfid=0 conn_
verified=N
SNs: last sn update:1369 seconds ago.
Sn list:
queue: qlen=0.
filter: severity=6, sz_exclude_list=0
voip dns ssh ssl
subcategory:
traffic: forward local multicast sniffer
anomaly: anomaly
server: global, id=0, fd=90, ready=1, ipv6=0, 172.16.200.55/514
oftp-state=5
faz2: global , enabled
server=172.18.60.25, realtime=1, ssl=1, state=connected, src=, mgmt_name=FGh_
Log_root_172.18.60.25, reliable=0
status: ver=6, used_disk=0, total_disk=0, global=0, vfid=0 conn_
verified=N
SNs: last sn update:1369 seconds ago.
Sn list:
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queue: qlen=0.
filter: severity=6, sz_exclude_list=0
voip dns ssh ssl
subcategory:
traffic: forward local multicast sniffer
anomaly: anomaly
server: global, id=1, fd=95, ready=1, ipv6=0, 172.18.60.25/514
oftp-state=5

2. Check the VDOM1 override FortiAnalyzer status:
FGTA(global) # diagnose test application miglogd 3101
faz: vdom, enabled, override
server=192.168.1.253, realtime=1, ssl=1, state=connected, src=, mgmt_name=FGh_
Log_root_192.168.1.253, reliable=1
status: ver=6, used_disk=0, total_disk=0, global=0, vfid=0 conn_
verified=N
SNs: last sn update:1369 seconds ago.
Sn list:
(FAZ-VM0000000001,age=17s)
queue: qlen=0.
filter: severity=6, sz_exclude_list=0
voip dns ssh ssl
subcategory:
traffic: forward local multicast sniffer
anomaly: anomaly
server: vdom, id=0, fd=72, ready=1, ipv6=0, 192.168.1.253/514
oftp-state=5
faz2: vdom, enabled, override
server=192.168.1.254, realtime=1, ssl=1, state=connected, src=, mgmt_name=FGh_
Log_root_192.168.1.254, reliable=0
status: ver=6, used_disk=0, total_disk=0, global=0, vfid=0 conn_
verified=N
SNs: last sn update:1369 seconds ago.
Sn list:
(FL-1KET318000008,age=17s)
queue: qlen=0.
filter: severity=6, sz_exclude_list=0
voip dns ssh ssl
subcategory:
traffic: forward local multicast sniffer
anomaly: anomaly
server: vdom, id=1, fd=97, ready=1, ipv6=0, 192.168.1.254/514
oftp-state=5
faz3: vdom, disabled, override

Configuring multiple FortiAnalyzers (or syslog servers) per VDOM

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1337

Log and Report

In a VDOM, multiple FortiAnalyzer and syslog servers can be configured as follows:
l
l

Up to three override FortiAnalyzer servers
Up to four override syslog servers

If the VDOM faz-override and/or syslog-override setting is enabled or disabled (default) before upgrading, the
setting remains the same after upgrading.
If the override setting is disabled, the GUI displays the global FortiAnalyzer1 or syslog1 setting. If the override setting is
enabled, the GUI displays the VDOM override FortiAnalyzer1 or syslog1 setting.
You can only use CLI to enable the override to support multiple log servers.

To enable FortiAnalyzer and syslog server override under VDOM:
config log setting
set faz-override enable
set syslog-override enable
end

When faz-override and/or syslog-override is enabled, the following CLI commands are available for configuring
VDOM override:

To configure VDOM override for FortiAnalyzer:
1. Configure the FortiAnalyzer override settings:
config log fortianalyzer/fortianalyzer2/fortianalyzer3 override-setting
set status enable
set server "123.12.123.123"
set reliable enable
end

2. Configure the override filters:
config log fortianalyzer/fortianalyzer2/fortianalyzer3 override-filter
set severity information
set forward-traffic enable
set local-traffic enable
set multicast-traffic enable
set sniffer-traffic enable
set anomaly enable
set voip enable
set dlp-archive enable
set dns enable
set ssh enable
set ssl enable
end

To configure VDOM override for a syslog server:
1. Configure the syslog override settings:
config log syslogd/syslogd2/syslogd3/syslogd4 override-setting
set status enable
set server "123.12.123.12"
set facility local1
end
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2. Configure the override filters:
config log syslogd/syslogd2/syslogd3/syslogd4 override-filter
set severity information
set forward-traffic enable
set local-traffic enable
set multicast-traffic enable
set sniffer-traffic enable
set anomaly enable
set voip enable
set dns enable
set ssh enable
set ssl enable
end

Source and destination UUID logging
The log-uuid setting in system global is split into two settings: log-uuid-address and log-uuid policy.
The traffic log includes two internet-service name fields: Source Internet Service (srcinetsvc) and Destination
Internet Service (dstinetsvc).

Log UUIDs
UUIDs can be matched for each source and destination that match a policy that is added to the traffic log. This allows the
address objects to be referenced in log analysis and reporting.
As this may consume a significant amount of storage space, this feature is optional. By default, policy UUID insertion is
enabled and address UUID insertion is disabled.

To enable address and policy UUID insertion in traffic logs using the GUI:
1. Go to Log & Report > Log Settings.
2. Under UUIDs in Traffic Log, enable Policy and/or Address.
3. Click Apply.
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To enable address and policy UUID insertion in traffic logs using the CLI:
config system global
set log-uuid-address enable
set log-uuid-policy enable
end

Sample forward traffic log:
# date=2019-01-25 time=11:32:55 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="vdom1" eventtime=1528223575 srcip=192.168.1.183 srcname="PC24"
srcport=33709 srcintf="lan" srcintfrole="lan" dstip=192.168.70.184 dstport=80
dstintf="wan1" dstintfrole="wan" srcuuid="27dd503e-883c-51e7-ade1-7e015d46494f"
dstuuid="27dd503e-883c-51e7-ade1-7e015d46494f"
poluuid="9e0fe24c-1808-51e8-1257-68ce4245572c" sessionid=5181 proto=6
action="client-rst" policyid=4 policytype="policy" service="HTTP" trandisp="snat"
transip=192.168.70.228 transport=33709 appid=38783 app="Wget"
appcat="General.Interest" apprisk="low" applist="default" duration=5 sentbyte=450
rcvdbyte=2305 sentpkt=6 wanin=368 wanout=130 lanin=130 lanout=130 utmaction="block"
countav=2 countapp=1 crscore=50 craction=2 devtype="Linux PC" devcategory="None"
osname="Linux" mastersrcmac="00:0c:29:36:5c:c3" srcmac="00:0c:29:36:5c:c3"
srcserver=0 utmref=65523-1018

Internet service name fields
Traffic logs for internet-service include two fields: Source Internet Service and Destination Internet Service.

To view the internet-service fields using the GUI:
1. Go to Log & Report > Forward Traffic.
2. Double-click on an entry to view the Log Details. The Source Internet Service and Destination Internet Service fields
are visible in the Log Details pane.

Sample internet-service name fields in a forward traffic log:
# date=2019-01-25 time=14:17:04 logid="0000000013" type="traffic" subtype="forward"
level="notice" vd="vdom1" eventtime=1548454622 srcip=10.1.100.11 srcport=51112
srcintf="port3" srcintfrole="undefined" dstip=172.217.14.228 dstport=80
dstintf="port1" dstintfrole="undefined" poluuid="af519380-2094-51e9-391cb78e8edbddfc" srcinetsvc="isdb-875099" dstinetsvc="Google.Gmail" sessionid=6930
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proto=6 action="close" policyid=2 policytype="policy" service="HTTP"
dstcountry="United States" srccountry="Reserved" trandisp="snat"
transip=172.16.200.2 transport=51112 duration=11 sentbyte=398 rcvdbyte=756 sentpkt=6
rcvdpkt=4 appcat="unscanned" devtype="Router/NAT Device" devcategory="Fortinet
Device" mastersrcmac="90:6c:ac:41:7a:24" srcmac="90:6c:ac:41:7a:24" srcserver=0
dstdevtype="Unknown" dstdevcategory="Fortinet Device"
masterdstmac="08:5b:0e:1f:ed:ed" dstmac="08:5b:0e:1f:ed:ed" dstserver=0

Troubleshooting
The following topics provide information about troubleshooting logging and reporting:
l
l
l

Log-related diagnose commands on page 1341
Backing up log files or dumping log messages on page 1346
SNMP OID for logs that failed to send on page 1348

Log-related diagnose commands
This topic shows commonly used examples of log-related diagnose commands.
Use the following diagnose commands to identify log issues:
l

The following commands enable debugging log daemon (miglogd) at the proper debug level:
diagnose debug application miglogd x
diagnose debug enable

l

The following commands display different status/statistics of miglogd at the proper level:
diagnose test application miglogd x
diagnose debug enable

To get the list of available levels, press Enter after diagnose test/debug application miglogd. The following
are some examples of commonly use levels.
If the debug log display does not return correct entries when log filter is set:
diagnose debug application miglogd 0x1000

For example, use the following command to display all login system event logs:
execute log filter device disk
execute log filter category event
execute log filter field action login
execute log display
Files to be searched:
file_no=65523, start line=0,
file_no=65524, start line=0,
file_no=65525, start line=0,
file_no=65526, start line=0,
file_no=65527, start line=0,
file_no=65528, start line=0,
file_no=65529, start line=0,
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file_no=65530, start line=0, end_line=389
file_no=65531, start line=0, end_line=384
session ID=1, total logs=3697
back ground search. process ID=26240, session_id=1
start line=1 view line=10
( action "login" )
ID=1, total=3697, checked=238, found=5
ID=1, total=3697, checked=668, found=13
ID=1, total=3697, checked=1080, found=23
ID=1, total=3697, checked=1462, found=23
ID=1, total=3697, checked=1858, found=23
ID=1, total=3697, checked=2317, found=54
ID=1, total=3697, checked=2922, found=106
ID=1, total=3697, checked=3312, found=111
ID=1, total=3697, checked=3697, found=114

You can check and/or debug the FortiGate to FortiAnalyzer connection status.

To show connect status with detailed information:
diagnose test application miglogd 1
faz: global , enabled
server=172.18.64.234, realtime=3, ssl=1, state=connected, src=, mgmt_name=FGh_Log_
vdom1_172.18.64.234, reliable=0, sni_prefix_type=none, required_entitlement=none
status: ver=6, used_disk=0, total_disk=0, global=0, vfid=0 conn_verified=Y
SNs: last sn update:107 seconds ago.
Sn list:
(FL-8HFT718900132,age=107s)
queue: qlen=0.
filter: severity=6, sz_exclude_list=0
voip dns ssh ssl cifs
subcategory:
traffic: forward local multicast sniffer
anomaly: anomaly
server: global, id=0, fd=132, ready=1, ipv6=0, 172.18.64.234/514
oftp-state=5

To collect debug information when FortiAnalyzer is enabled:
diagnose debug application miglogd 0x100
FGT-B-LOG (global) # <16208> miglog_start_rmt_conn()-1552: setting epoll_hd:0x7fc364e125e0
to _rmt_connect
<16209> miglog_start_rmt_conn()-1552: setting epoll_hd:0x7f72647715e0 to _rmt_connect
<16206> miglog_start_rmt_conn()-1552: setting epoll_hd:0x141f69e0 to _rmt_connect
<16209> _rmt_connect()-1433: oftp is ready.
<16209> _rmt_connect()-1435: xfer_status changed from 2 to 2 for global-faz
<16209> _rmt_connect()-1439: setting epoll_hd:0x7f72647715e0 to _rmt_recv
<16209> _check_oftp_certificate()-248: checking sn:FL-8HFT718900132 vs cert sn:FL8HFT718900132
<16209> _check_oftp_certificate()-252: Verified the certificate of peer (172.18.64.234) to
match sn=FL-8HFT718900132
<16209> _faz_post_connection()-292: Certificate verification:enabled, Faz verified:1
<16209> _send_queue_item()-518: xfer_status changed from 2 to 1 for global-faz
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<16209> _send_queue_item()-523: type=0, cat=0, logcount=0, len=0
<16209> _oftp_send()-487: dev=global-faz type=17 pkt_len=34
<16209> _oftp_send()-487: opt=253, opt_len=10
<16209> _oftp_send()-487: opt=81, opt_len=12
<16208> _rmt_connect()-1433: oftp is ready.
<16208> _rmt_connect()-1435: xfer_status changed from 2 to 2 for global-faz
<16208> _rmt_connect()-1439: setting epoll_hd:0x7fc364e125e0 to _rmt_recv
<16208> _check_oftp_certificate()-248: checking sn:FL-8HFT718900132 vs cert sn:FL8HFT718900132
<16208> _check_oftp_certificate()-252: Verified the certificate of peer (172.18.64.234) to
match sn=FL-8HFT718900132
<16208> _faz_post_connection()-292: Certificate verification:enabled, Faz verified:1
<16208> _send_queue_item()-518: xfer_status changed from 2 to 1 for global-faz
<16208> _send_queue_item()-523: type=0, cat=0, logcount=0, len=0
<16208> _oftp_send()-487: dev=global-faz type=17 pkt_len=34
<16208>
<16209>
<16208>
<16209>
<16209>
<16209>
<16209>

_oftp_send()-487: opt=253, opt_len=10
_oftp_recv()-1348: opt=252, opt_len=996
_oftp_send()-487: opt=81, opt_len=12
_process_response()-960: checking opt code=252
_faz_process_oftp_resp()-488: ha nmember:1 nvcluster:0 mode:1
__is_sn_known()-356: MATCHED: idx:0 sn:FL-8HFT718900132
_faz_process_oftp_resp()-494: Received SN:FL-8HFT718900132 should update:0

<16208> _oftp_recv()-1348: dev=global-faz type=252 pkt_len=1008
<16208>
<16208>
<16208>
<16208>
<16208>

_oftp_recv()-1348: opt=252, opt_len=996
_process_response()-960: checking opt code=252
_faz_process_oftp_resp()-488: ha nmember:1 nvcluster:0 mode:1
__is_sn_known()-356: MATCHED: idx:0 sn:FL-8HFT718900132
_faz_process_oftp_resp()-494: Received SN:FL-8HFT718900132 should update:0

<16206> _rmt_connect()-1433: oftp is ready.
<16206> _rmt_connect()-1435: xfer_status changed from 2 to 2 for global-faz
<16206> _rmt_connect()-1439: setting epoll_hd:0x141f69e0 to _rmt_recv
<16206> _check_oftp_certificate()-248: checking sn:FL-8HFT718900132 vs cert sn:FL8HFT718900132
<16206> _check_oftp_certificate()-252: Verified the certificate of peer (172.18.64.234) to
match sn=FL-8HFT718900132
<16206> _faz_post_connection()-292: Certificate verification:enabled, Faz verified:1
<16206> _send_queue_item()-518: xfer_status changed from 2 to 1 for global-faz
<16206> _send_queue_item()-523: type=0, cat=0, logcount=0, len=0
<16206> _oftp_send()-487: dev=global-faz type=17 pkt_len=34
<16206> _oftp_send()-487: opt=253, opt_len=10
<16206> _oftp_send()-487: opt=81, opt_len=12
<16206> _oftp_recv()-1348: dev=global-faz type=252 pkt_len=1008
<16206>
<16206>
<16206>
<16206>
<16206>

_oftp_recv()-1348: opt=252, opt_len=996
_process_response()-960: checking opt code=252
_faz_process_oftp_resp()-488: ha nmember:1 nvcluster:0 mode:1
__is_sn_known()-356: MATCHED: idx:0 sn:FL-8HFT718900132
_faz_process_oftp_resp()-494: Received SN:FL-8HFT718900132 should update:0

<16209> _oftp_recv()-1348: dev=global-faz type=1 pkt_len=985
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<16209>
......
<16209>
<16209>
......
<16209>
<16209>

_oftp_recv()-1348: opt=12, opt_len=16
_build_ack()-784: xfer_status changed from 1 to 2 for global-faz
_process_response()-960: checking opt code=81
_send_queue_item()-523: type=1, cat=0, logcount=0, len=0
_oftp_send()-487: dev=global-faz type=1 pkt_len=24

<16209> _oftp_send()-487: opt=1, opt_len=12
<16209> _send_queue_item()-523: type=7, cat=0, logcount=0, len=988
<16209> _oftp_send()-487: dev=global-faz type=252 pkt_len=1008
<16209> _oftp_send()-487: opt=252, opt_len=996
<16208> _oftp_recv()-1348: dev=global-faz type=1 pkt_len=58
<16208>
<16208>
<16208>
<16208>
<16208>
<16208>
<16208>
<16208>

_oftp_recv()-1348: opt=12, opt_len=16
_oftp_recv()-1348: opt=51, opt_len=9
_oftp_recv()-1348: opt=49, opt_len=12
_oftp_recv()-1348: opt=52, opt_len=9
_build_ack()-784: xfer_status changed from 1 to 2 for global-faz
_process_response()-960: checking opt code=52
_send_queue_item()-523: type=1, cat=0, logcount=0, len=0
_oftp_send()-487: dev=global-faz type=1 pkt_len=24

<16208> _oftp_send()-487: opt=1, opt_len=12
<16206> _oftp_recv()-1348: dev=global-faz type=1 pkt_len=985
......
<16208>
<16206>
......
<16206>
<16206>
......
<16206>
<16206>

_send_queue_item()-523: type=3, cat=1, logcount=1, len=301
_oftp_recv()-1348: opt=78, opt_len=55
_build_ack()-784: xfer_status changed from 1 to 2 for global-faz
_process_response()-960: checking opt code=81
_send_queue_item()-523: type=1, cat=0, logcount=0, len=0
_oftp_send()-487: dev=global-faz type=1 pkt_len=24

<16206> _oftp_send()-487: opt=1, opt_len=12
<16206> _send_queue_item()-523: type=7, cat=0, logcount=0, len=988
<16206> _oftp_send()-487: dev=global-faz type=252 pkt_len=1008
<16206>
<16206>
......
<16206>
<16206>

_oftp_send()-487: opt=252, opt_len=996
_add_change_notice_queue_item()-269: Change notice packect added to queue. len=145
_send_queue_item()-523: type=2, cat=0, logcount=0, len=300
_oftp_send()-487: dev=global-faz type=37 pkt_len=300

......
<16206>
<16206>
<16206>
<16206>

_oftp_send()-487: opt=152, opt_len=40
_oftp_send()-487: opt=74, opt_len=40
_oftp_send()-487: opt=82, opt_len=93
_oftp_recv()-1348: dev=global-faz type=1 pkt_len=24

<16206> _oftp_recv()-1348: opt=1, opt_len=12
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<16206> _process_response()-960: checking opt code=1

To check the FortiGate to FortiGateCloud log server connection status:
diagnose test application miglogd 20
FGT-B-LOG# diagnose test application miglogd 20
Home log server:
Address: 172.16.95.92:514
Alternative log server:
Address: 172.16.95.26:514
oftp status: established
Debug zone info:
Server IP:
172.16.95.92
Server port:
514
Server status: up
Log quota:
102400MB
Log used:
673MB
Daily volume:
20480MB
FDS arch pause: 0
fams archive pause: 0

To check real-time log statistics by log type since the miglogd daemon start:
diagnose test application miglogd 4
FGT-B-LOG (global) # diagnose test application miglogd 4
info for vdom: root
disk
event: logs=1238 len=262534, Sun=246 Mon=247 Tue=197 Wed=0 Thu=55 Fri=246 Sat=247
compressed=163038
dns: logs=4 len=1734, Sun=0 Mon=0 Tue=0 Wed=0 Thu=4 Fri=0 Sat=0 compressed=453
report
event: logs=1244 len=225453, Sun=246 Mon=247 Tue=197 Wed=0 Thu=61 Fri=246 Sat=247
faz
event: logs=6 len=1548, Sun=0 Mon=0 Tue=6 Wed=0 Thu=0 Fri=0 Sat=0 compressed=5446
info for vdom: vdom1
memory
traffic: logs=462 len=389648, Sun=93 Mon=88 Tue=77 Wed=0 Thu=13 Fri=116 Sat=75
event: logs=3724 len=1170237, Sun=670 Mon=700 Tue=531 Wed=0 Thu=392 Fri=747 Sat=684
app-ctrl: logs=16 len=9613, Sun=3 Mon=3 Tue=3 Wed=0 Thu=0 Fri=5 Sat=2
dns: logs=71 len=29833, Sun=0 Mon=0 Tue=0 Wed=0 Thu=71 Fri=0 Sat=0
disk
traffic: logs=462 len=389648, Sun=93 Mon=88 Tue=77 Wed=0 Thu=13 Fri=116 Sat=75
compressed=134638
event: logs=2262 len=550957, Sun=382 Mon=412 Tue=307 Wed=0 Thu=306 Fri=459 Sat=396
compressed=244606
app-ctrl: logs=16 len=9613, Sun=3 Mon=3 Tue=3 Wed=0 Thu=0 Fri=5 Sat=2 compressed=3966
dns: logs=71 len=29833, Sun=0 Mon=0 Tue=0 Wed=0 Thu=71 Fri=0 Sat=0 compressed=1499
report
traffic: logs=462 len=375326, Sun=93 Mon=88 Tue=77 Wed=0 Thu=13 Fri=116 Sat=75
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event: logs=3733 len=1057123, Sun=670 Mon=700 Tue=531 Wed=0 Thu=401 Fri=747 Sat=684
app-ctrl: logs=16 len=9117, Sun=3 Mon=3 Tue=3 Wed=0 Thu=0 Fri=5 Sat=2
faz
traffic: logs=462 len=411362, Sun=93 Mon=88 Tue=77 Wed=0 Thu=13 Fri=116 Sat=75
compressed=307610
event: logs=3733 len=1348297, Sun=670 Mon=700 Tue=531 Wed=0 Thu=401 Fri=747 Sat=684
compressed=816636
app-ctrl: logs=16 len=10365, Sun=3 Mon=3 Tue=3 Wed=0 Thu=0 Fri=5 Sat=2 compressed=8193
dns: logs=71 len=33170, Sun=0 Mon=0 Tue=0 Wed=0 Thu=71 Fri=0 Sat=0 compressed=0

To check log statistics to the local/remote log device since the miglogd daemon start:
diagnose test application miglogd 6 1

<<<

1 means the first child daemon

diagnose test application miglogd 6 2

<<<

2 means the second child daemon

FGT-B-LOG (global) # diagnose test application miglogd 6 1
mem=4288, disk=4070, alert=0, alarm=0, sys=5513, faz=4307, webt=0, fds=0
interface-missed=208
Queues in all miglogds: cur:0 total-so-far:36974
global log dev statistics:
syslog 0: sent=6585, failed=152, relayed=0
faz 0: sent=13, failed=0, cached=0, dropped=0 , relayed=0

To check the miglogd daemon number and increase/decrease miglogd daemon:
diagnose test application miglogd 15

<<<

Show miglog ID

diagnose test application miglogd 13

<<<

Increase one miglogd child

diagnose test application miglogd 14

<<<

Decrease one miglogd child

FGT-B-LOG (global) # diagnose test application miglogd 15
Main miglogd: ID=0, children=2, active-children=2
ID=1, duration=70465.
ID=2, duration=70465.
FGT-B-LOG (global) # diagnose test application miglogd 13
FGT-B-LOG (global) # diagnose test application miglogd 15
Main miglogd: ID=0, children=3, active-children=3
ID=1, duration=70486.
ID=2, duration=70486.
ID=3, duration=1.
FGT-B-LOG (global) # diagnose test application miglogd 14
FGT-B-LOG (global) # diagnose test application miglogd 15
Main miglogd: ID=0, children=2, active-children=2
ID=1, duration=70604.
ID=2, duration=70604.

Backing up log files or dumping log messages
When a log issue is caused by a particular log message, it is very help to get logs from that FortiGate. This topic provides
steps for using execute log backup or dumping log messages to a USB drive.
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Backing up full logs using execute log backup
This command backs up all disk log files and is only available on FortiGates with an SSD disk.
Before running execute log backup, we recommend temporarily stopping miglogd and reportd.

To stop and kill miglogd and reportd:
diagnose sys process daemon-auto-restart disable miglogd
diagnose sys process daemon-auto-restart disable reportd

To store the log file on a USB drive:
1. Plug in a USB drive into the FortiGate.
2. Run this command:
exec log backup /usb/log.tar

To restart miglogd and reportd:
diagnose sys process daemon-auto-restart enable miglogd
diagnose sys process daemon-auto-restart enable reportd

Dumping log messages
To dump log messages:
1. Enable log dumping for miglogd daemon:
(global) # diagnose test application miglogd 26 1
miglogd(1) log dumping is enabled

2. Display all miglogd dumping status:
global) # diagnose test application miglogd 26 0 255
miglogd(0) log dumping is disabled
miglogd(1) log dumping is enabled
miglogd(2) log dumping is disabled
(global) # diagnose test application miglogd 26 2
miglogd(2) log dumping is enabled
(global) # diagnose test application miglogd 26 0
miglogd(0) log dumping is enabled
(global) #
miglogd(0)
miglogd(1)
miglogd(2)

diagnose test application miglogd 26 0 255
log dumping is enabled
log dumping is enabled
log dumping is enabled

3. Let the FortiGate run and collect log messages.
4. List the log dump files:
(global) # diagnose test application miglogd 33
2019-04-17 15:50:02
20828
log-1-0.dat
2019-04-17 15:48:31
4892
log-2-0.dat
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5. Back up log dump files to the USB drive:
(global) # diagnose test application miglogd 34
Dumping file miglog1_index0.dat copied to USB disk OK.
Dumping file miglog2_index0.dat copied to USB disk OK.

6. Disable log dumping for miglogd daemon:
(global) # diagnose test application miglogd 26 0
miglogd(0) log dumping is disabled
(global) # diagnose test application miglogd 26 1
miglogd(1) log dumping is disabled
(global) # diagnose test application miglogd 26 2
miglogd(2) log dumping is disabled
(global) #
miglogd(0)
miglogd(1)
miglogd(2)

diagnose test application miglogd 26 0 255
log dumping is disabled
log dumping is disabled
log dumping is disabled

SNMP OID for logs that failed to send
When a syslog server encounters low-performance conditions and slows down to respond, the buffered syslog
messages in the kernel might overflow after a certain number of retransmissions, causing the overflowed messages to
be lost. OIDs track the lost messages or failed logs.
SNMP query OIDs include log statistics for global log devices:
l
l

l

l

l

l

l

l

FORTINET-FORTIGATE-MIB:fortinet.fnFortiGateMib.fgLog.fgLogDeviceNumber 1.3.6.1.4.1.12356.101.21.1.1
FORTINET-FORTIGATEMIB:fortinet.fnFortiGateMib.fgLog.fgLogDevices.fgLogDeviceTable.fgLogDeviceEntry.fgLogDeviceEntryIndex
1.3.6.1.4.1.12356.101.21.2.1.1.1
FORTINET-FORTIGATEMIB:fortinet.fnFortiGateMib.fgLog.fgLogDevices.fgLogDeviceTable.fgLogDeviceEntry.fgLogDeviceEnabled
1.3.6.1.4.1.12356.101.21.2.1.1.2
FORTINET-FORTIGATEMIB:fortinet.fnFortiGateMib.fgLog.fgLogDevices.fgLogDeviceTable.fgLogDeviceEntry.fgLogDeviceName
1.3.6.1.4.1.12356.101.21.2.1.1.3
FORTINET-FORTIGATEMIB:fortinet.fnFortiGateMib.fgLog.fgLogDevices.fgLogDeviceTable.fgLogDeviceEntry.fgLogDeviceSentCount
1.3.6.1.4.1.12356.101.21.2.1.1.4
FORTINET-FORTIGATEMIB:fortinet.fnFortiGateMib.fgLog.fgLogDevices.fgLogDeviceTable.fgLogDeviceEntry.fgLogDeviceRelayedCount
1.3.6.1.4.1.12356.101.21.2.1.1.5
FORTINET-FORTIGATEMIB:fortinet.fnFortiGateMib.fgLog.fgLogDevices.fgLogDeviceTable.fgLogDeviceEntry.fgLogDeviceCachedCount
1.3.6.1.4.1.12356.101.21.2.1.1.6
FORTINET-FORTIGATEMIB:fortinet.fnFortiGateMib.fgLog.fgLogDevices.fgLogDeviceTable.fgLogDeviceEntry.fgLogDeviceFailedCount
1.3.6.1.4.1.12356.101.21.2.1.1.7
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l

FORTINET-FORTIGATEMIB:fortinet.fnFortiGateMib.fgLog.fgLogDevices.fgLogDeviceTable.fgLogDeviceEntry.fgLogDeviceDroppedCount
1.3.6.1.4.1.12356.101.21.2.1.1.8

Where:
l
l
l

fgLogDeviceNumber is the number of devices in the table.
fgLogDeviceEnabled is either 1 or 0, indicating whether the device is enabled.
fgLogDeviceName is the name of the device.

A FortiGate connected to a syslog server or FortiAnalyzer generates statistics that can be seen using the diagnose
test application miglogd command:
(global) # diagnose test application miglogd 6
mem=404, disk=657, alert=0, alarm=0, sys=920, faz=555, webt=0, fds=0
interface-missed=460
Queues in all miglogds: cur:0 total-so-far:526
global log dev statistics:
syslog 0: sent=254, failed=139, relayed=0
syslog 1: sent=220, failed=139, relayed=0
syslog 2: sent=95, failed=73, relayed=0
faz 0: sent=282, failed=0, cached=0, dropped=0 , relayed=0
Num of REST URLs: 3
/api/v2/monitor/system/csf/ : 0 : 300
/api/v2/cmdb/system/interface/ : 394.0.673.15877729363538323653.1547149763 : 1200
/api/v2/monitor/system/ha-checksums/ : 0 : 1200
faz 1: sent=272, failed=0, cached=0, dropped=0 , relayed=0
Num of REST URLs: 2
/api/v2/monitor/system/csf/ : 0 : 300
/api/v2/cmdb/system/interface/ : 394.0.673.15877729363538323653.1547149763 : 1200

The same statistics are also available in snmpwalk/snmpget on the OID 1.3.6.1.4.1.12356.101.21.
snmpwalk -v2c -c REGR-SYS 172.16.200.1 1.3.6.1.4.1.12356.101.21
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.1.1.0 = INTEGER: 9
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.1.0 = INTEGER: 0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.1.1 = INTEGER: 1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.1.2 = INTEGER: 2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.1.3 = INTEGER: 3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.1.4 = INTEGER: 4
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.1.5 = INTEGER: 5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.1.6 = INTEGER: 6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.1.7 = INTEGER: 7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.1.8 = INTEGER: 8
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.0 = INTEGER: 1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.1 = INTEGER: 1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.2 = INTEGER: 1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.3 = INTEGER: 0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.4 = INTEGER: 1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.5 = INTEGER: 1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.6 = INTEGER: 0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.7 = INTEGER: 0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.8 = INTEGER: 0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.0 = STRING: "syslog"
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.1 = STRING: "syslog2"
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.2 = STRING: "syslog3"
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.3 = STRING: "syslog4"
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.4 = STRING: "faz"
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FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.8
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.4.0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.4.1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.4.2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.4.3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.4.4
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.4.5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.4.6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.4.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.4.8
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.5.0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.5.1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.5.2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.5.3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.5.4
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.5.5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.5.6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.5.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.5.8
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.6.0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.6.1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.6.2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.6.3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.6.4
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.6.5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.6.6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.6.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.6.8
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.4
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.8
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.8.0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.8.1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.8.2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.8.3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.8.4
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.8.5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.8.6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.8.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.8.8

=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=

STRING: "faz2"
STRING: "faz3"
STRING: "webtrends"
STRING: "fds"
Counter32: 254
Counter32: 220
Counter32: 95
Counter32: 0
Counter32: 282
Counter32: 272
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Gauge32: 0
Gauge32: 0
Gauge32: 0
Gauge32: 0
Gauge32: 0
Gauge32: 0
Gauge32: 0
Gauge32: 0
Gauge32: 0
Counter32: 139
Counter32: 139
Counter32: 73
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0
Counter32: 0

To get the type of logging device that is attached to the FortiGate:
root@PC05:/home/tester/autolib/trunk# snmpwalk -v2c -c REGR-SYS 172.16.200.1
1.3.6.1.4.1.12356.101.21.2.1.1.3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.0 = STRING: "syslog"
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.1 = STRING: "syslog2"
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FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.4
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.3.8

=
=
=
=
=
=
=

STRING:
STRING:
STRING:
STRING:
STRING:
STRING:
STRING:

"syslog3"
"syslog4"
"faz"
"faz2"
"faz3"
"webtrends"
"fds"

To get the present state of the logging device that is attached to the FortiGate:
root@PC05:/home/tester/autolib/trunk# snmpwalk -v2c
1.3.6.1.4.1.12356.101.21.2.1.1.2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.4
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.2.8

-c REGR-SYS 172.16.200.1
=
=
=
=
=
=
=
=
=

INTEGER:
INTEGER:
INTEGER:
INTEGER:
INTEGER:
INTEGER:
INTEGER:
INTEGER:
INTEGER:

1
1
1
0
0
0
0
0
0

To get the failed log count value:
root@PC05:/home/tester/autolib/trunk# snmpwalk -v2c
1.3.6.1.4.1.12356.101.21.2.1.1.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.0
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.1
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.2
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.3
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.4
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.5
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.6
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.7
FORTINET-FORTIGATE-MIB::fnFortiGateMib.21.2.1.1.7.8
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=
=
=
=
=
=
=
=
=

Counter32:
Counter32:
Counter32:
Counter32:
Counter32:
Counter32:
Counter32:
Counter32:
Counter32:

139
139
73
0
0
0
0
0
0
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The following sections provide information about monitoring:
l
l
l

Policy and route checks on page 1352
WiFi client monitor on page 1354
WiFi health monitor on page 1355

Policy and route checks
Policy route look up is prioritized over static and dynamic routes when doing a route look up in the GUI.

To look up an IPv4 route in the GUI:
1. Go to Monitor > Routing Monitor.
2. Click Route Lookup.

3. Enter an IP address in the Destination field, then click Search.
The matching IPv4 route is highlighted on the Route Monitor page.
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To look up an IPv6 route in the GUI:
1. Go to Monitor > Routing Monitor.
2. Click Route Lookup.

3. Enter an IPv6 address in the Destination field, then click Search.
The matching IPv6 route is highlighted on the Route Monitor page.
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To look up an IPv4 route in the CLI:
diagnose ip proute match <destination_ip_address> <source_ip_address> <interface_name>
<protocol> <destination_port>

For example:
# diagnose ip proute match 10.100.21.44 2.2.2.2 port2 6 2
dst=10.100.21.44 src=2.2.2.2 iif=24 protocol=6 dport=2
id=7f00000c type=VWL
seq-num=12
# diagnose ip proute match 10.100.20.44 2.2.2.2 port2 6 2
dst=10.100.20.44 src=2.2.2.2 iif=24 protocol=6 dport=2
id=00000016 type=Policy Route
seq-num=22

To look up an IPv6 route in the CLI:
diagnose ipv6 proute match <destination_ipv6_address> <source_ipv6_address> <interface_name>
<protocol> <destination_port>

WiFi client monitor
The following shows a simple network topology when using FortiAPs with FortiGate:

To view connected WiFi clients on the FortiGate unit, go to Monitor > WiFi Client Monitor. The following columns display:

Column

Description

SSID

SSID that the client connected to, such as the tunnel, bridge, or mesh.

FortiAP

Serial number of the FortiAP unit that the client connected to.

User

Username if using WPA enterprise authentication.

IP

IP address assigned to the wireless client.

Device

Wireless client device type.

Channel

FortiAP operation channel.

Auth

Authentication type used.

Channel

WiFi radio channel in use.

Bandwidth Tx/Rx

Client received and transmitted bandwidth in Kbps.
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Column

Description

Signal Strength/Noise

Signal-to-noise ratio in decibels calculated from signal strength and noise level.

Association Time

How long the client has been connected to this AP.

Device OS

Wireless device OS.

Manufacturer

Wireless device manufacturer.

MIMO

Wireless device MIMO information.

WiFi health monitor
The following shows a simple network topology when using FortiAPs with FortiGate:

The Monitor > WiFi Health Monitor page displays the following charts:
l

l

Active Clients: Currently active clients on each FortiAP

AP Status: APs by status, sorted by those that have been up for over 24 hours, rebooted in the past 24 hours, and
down/missing
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l

l

l

l

Channel Utilization: Allow users to view 10-20 most and least utilized channels for each AP radio and a third
histogram view showing utilization counts

Client Count: Shows client count over time. Can view for the past hour, day, or 30 days.

Login Failures: Time, SSID, hostname, and username for failed login attempts. The widget also displays the AP
name and group of FortiAP units with failed login attempts.

Top Wireless Interference: Separate widgets for 2.4 GHz and 5 GHz bands. This requires spectrum analysis to be
enabled on the radios.
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Amazon Web Services
See the FortiOS 6.2.0 AWS Cookbook.

Microsoft Azure
See the FortiOS 6.2.0 Azure Cookbook.

Google Cloud Platform
See the FortiOS 6.2.0 GCP Cookbook.

Oracle OCI
See the FortiOS 6.2.0 OCI Cookbook.

AliCloud
See the FortiOS 6.2.0 AliCloud Cookbook.

Private cloud
See the FortiOS 6.2.0 VMware ESXi Cookbook.

FortiGate multiple connector support
This guide shows how to configure Fabric connectors and resolve dynamic firewall addresses through the configured
Fabric connector in FortiOS.
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FortiOS supports multiple Fabric connectors including public connectors (AWS, Azure, GCP, OCI, AliCloud) and private
connectors (Kubernetes, VMware ESXi, VMware NSX, OpenStack, Cisco ACI, Nuage). FortiOS also supports multiple
instances for each type of Fabric connector.
This guide uses an Azure Fabric connector as an example. The configuration procedure for all supported Fabric
connectors is the same. In the following topology, the FortiGate accesses the Azure public cloud through the Internet:

This process consists of the following:
1.
2.
3.
4.
5.
6.
7.

Configure the interface.
Configure a static route to connect to the Internet.
Configure two Azure Fabric connectors with different client IDs.
Check the configured Fabric connectors.
Create two firewall addresses.
Check the resolved firewall addresses after the update interval.
Run diagnose commands.

To configure the interface:
1. In FortiOS, go to Network > Interfaces.
2. Edit port1:
a. From the Role dropdown list, select WAN.
b. In the IP/Network Mask field, enter 10.6.30.4/255.255.255.0 for the interface connected to the Internet.

To configure a static route to connect to the Internet:
1.
2.
3.
4.

Go to Network > Static Routes. Click Create New.
In the Destination field, enter 0.0.0.0/0.0.0.0.
From the Interface dropdown list, select port1.
In the Gateway Address field, enter 10.60.30.254.

To configure two Azure Fabric connectors with different client IDs:
1. Go to Security Fabric > Fabric Connectors.
2. Click Create New. Configure the first Fabric connector:
a. Select Microsoft Azure.
b. In the Name field, enter azure1.
c. In the Status field, select Enabled.
d. From the Server region dropdown list, select Global.
e. In the Tenant ID field, enter the tenant ID. In this example, it is 942b80cd-1b14-42a1-8dcf-4b21dece61ba.
f. In the Client ID field, enter the client ID. In this example, it is 14dbd5c5-307e-4ea4-8133-68738141feb1.
g. In the Client secret field, enter the client secret.
h. Leave the Resource path disabled.
i. Click OK.
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3. Click Create New. Configure the second Fabric connector:
a. Select Microsoft Azure.
b. In the Name field, enter azure2.
c. In the Status field, select Enabled.
d. From the Server region dropdown list, select Global.
e. In the Tenant ID field, enter the tenant ID. In this example, it is 942b80cd-1b14-42a1-8dcf-4b21dece61ba.
f. In the Client ID field, enter the client ID. In this example, it is 3baf0a6c-44ff-4f94-b292-07f7a2c36be6.
g. In the Client secret field, enter the client secret.
h. Leave the Resource path disabled.
i. Click OK.

To check the configured Fabric connectors:
1. Go to Security Fabric > Fabric Connectors.
2. Click the Refresh icon in the upper right corner of each configured Fabric connector. A green up arrow appears in
the lower right corner, meaning that both Fabric connectors are connected to the Azure cloud using different client
IDs.

To create two firewall addresses:
This process creates two Fabric connector firewall addresses to associate with the configured Fabric connectors.
1. Go to Policy & Objects > Addresses.
2. Click Create New > Address. Configure the first Fabric connector firewall address:
a. In the Name field, enter azure-address-1.
b. From the Type dropdown list, select Fabric Connector address.
c. From the SDN Connector dropdown list, select azure1.
d. For SDN address type, select Private.
e. From the Filter dropdown list, select the desired filter.
f. For Interface, select any.
g. Click OK.
3. Click Create New > Address. Configure the second Fabric connector firewall address:
a. In the Name field, enter azure-address-1.
b. From the Type dropdown list, select Fabric Connector address.
c. From the SDN Connector dropdown list, select azure2.
d. For SDN address type, select Private.
e. From the Filter dropdown list, select the desired filter.
f. For Interface, select any.
g. Click OK.

To check the resolved firewall addresses after the update interval:
By default, the update interval is 60 seconds.
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1. Go to Policy & Objects > Addresses.
2. Hover over the created addresses. The firewall address that the configured Fabric connectors resolved display.

To run diagnose commands:
Run the show sdn connector status command. Both Fabric connectors should appear with a status of connected.
Run the diagnose debug application azd -1 command. The output should look like the following:
Level2-downstream-D # diagnose debug application azd -1
...
azd sdn connector azure1 start updating IP addresses
azd checking firewall address object azure-address-1, vd 0
IP address change, new list:
10.18.0.4
...

To restart the Azure Fabric connector daemon, run the diagnose test application azd 99 command.

Adding VDOMs with FortiGate v-series
Each FortiGate-VM base license type allows a default number of VDOMs. This recipe provides sample procedures to
add VDOMs beyond the default number using separately purchased VDOM licenses.
This recipe consists of the following steps:
1. Activate the FortiGate-VM with the base license.
2. Add more VDOMs to the FortiGate-VM.

To activate the FortiGate-VM with the base license:
1. Purchase and register the FortiGate-VM base license in FortiCare:
a. Purchase the FortiGate-VM base license from Fortinet or a Fortinet reseller.
b. You receive a license certification with a registration code. Open the certification.
c. Log in to Fortinet Customer Service & Support.
d. Go to Asset > Register/Activate and enter the provided registration code.
e. Follow the registration process. The serial number generates and displays on the Registration Completion
page.
f. Go to Asset > Manage/View Products. Click the serial number to download the license file.
2. Upload the FortiGate-VM base license file to FortiOS:
a. Log in to the FortiGate-VM GUI.
b. In Dashboard > Status, in the Virtual Machine widget, click FortiGate VM License.
c. Click the Upload button.
d. Select the FortiGate-VM base license file, then click OK. The FortiGate-VM reboots after applying the base
license.

FortiOS 6.2.0 Cookbook
Fortinet Technologies Inc.

1360

VM
3. Verify the FortiGate-VM base license status and VDOM information:
a. Log in to the FortiGate-VM GUI.
b. In Dashboard > Status, in the Virtual Machine widget, ensure that there is a checkmark in front of the FortiGateVM base license name. The checkmark indicates that the base license is valid.
c. You can check VDOM information using the CLI. The following output shows that the maximum number of
VDOMs is currently one. This is correct since the FortiGate-VM base license only supports the default root
VDOM that the system uses.
FGVM4VTM19000476 # get system status
Version: FortiGate-VM64 v6.2.0,build0866,190328 (GA)
Virus-DB: 69.00091(2019-06-07 12:19)
Extended DB: 1.00000(2018-04-09 18:07)
Extreme DB: 1.00000(2018-04-09 18:07)
IPS-DB: 14.00610(2019-05-09 00:14)
IPS-ETDB: 0.00000(2001-01-01 00:00)
APP-DB: 14.00610(2019-05-09 00:14)
INDUSTRIAL-DB: 14.00610(2019-05-09 00:14)
Serial-Number: FGVM4VTM19000476
IPS Malicious URL Database: 2.00325(2019-06-07 03:56)
Botnet DB: 4.00490(2019-05-30 10:00)
License Status: Valid
License Expires: 2020-04-30
VM Resources: 2 CPU/4 allowed, 3022 MB RAM/6144 MB allowed
Log hard disk: Available
Hostname: FGVM4VTM19000476
Operation Mode: NAT
Current virtual domain: root
Max number of virtual domains: 1
Virtual domains status: 1 in NAT mode, 0 in TP mode
Virtual domain configuration: disable
FIPS-CC mode: disable
Current HA mode: standalone
Branch point: 0866
Release Version Information: GA
FortiOS x86-64: Yes
System time: Fri Jun 7 14:04:55 2019

To add more VDOMs to the FortiGate-VM:
You can repeat this procedure multiple times to stack multiple VDOM licenses on the same FortiGate-VM.
1. Purchase and register the FortiGate-VM upgrade license in FortiCare. This example adds 15 VDOMs:
a. Purchase the FortiGate-VM upgrade license from Fortinet or a Fortinet reseller.
b. You receive a license certification with a registration code. Open the certification.
c. Log in to Fortinet Customer Service & Support.
d. Go to Asset > Register/Activate and enter the provided registration code.
e. On the Specify License Confirmation Information screen, enter the FortiGate-VM serial number to apply the
VDOM upgrade license to the FortiGate-VM. In this example, the FortiGate-VM serial number is
FGVM4VTM19000476.
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f. Follow the registration process.
g. Go to Asset > Manage/View Products > . Select the desired product, then click License & Key. The VDOM
upgrade license displays under Registered License(s), and a key for adding 15 VDOMs (in this example
M6JSD-8EE32-VHIJB-N) displays under Available Key(s).

2. Apply the FortiGate-VM upgrade license key to FortiOS:
a. Log in to the FortiGate-VM CLI in the local console or using SSH.
b. Apply the VDOM upgrade license key:
FGVM4VTM19000476 # execute upd-vd-license M6JSD-8EE32-VHIJB-N
update vdom license succeeded

3. Verify the FortiGate-VM VDOM information:
a. Log in to the FortiGate-VM CLI in the local console or using SSH.
b. Check VDOM information using the CLI. The following output shows that the maximum number of VDOMs is
currently 15. When you add VDOMs for the first time on a FortiGate-VM v-series instance, FortiOS does not
count the default VDOM, as the default VDOM is the so-called root VDOM that the system uses and FortiOS
does not treat it as a countable VDOM in terms of VDOM addition. Therefore, as in this example, if your
FortiGate-VM had the default VDOM configuration, then you add 15 VDOMs, FortiOS displays the maximum
VDOM number as 15, not 16.
FGVM4VTM19000476 # get system status
Version: FortiGate-VM64 v6.2.0,build0866,190328 (GA)
Virus-DB: 69.00091(2019-06-07 12:19)
Extended DB: 1.00000(2018-04-09 18:07)
Extreme DB: 1.00000(2018-04-09 18:07)
IPS-DB: 14.00610(2019-05-09 00:14)
IPS-ETDB: 0.00000(2001-01-01 00:00)
APP-DB: 14.00610(2019-05-09 00:14)
INDUSTRIAL-DB: 14.00610(2019-05-09 00:14)
Serial-Number: FGVM4VTM19000476
IPS Malicious URL Database: 2.00325(2019-06-07 03:56)
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Botnet DB: 4.00490(2019-05-30 10:00)
License Status: Valid
License Expires: 2020-04-30
VM Resources: 2 CPU/4 allowed, 3022 MB RAM/6144 MB allowed
Log hard disk: Available
Hostname: FGVM4VTM19000476
Operation Mode: NAT
Current virtual domain: root
Max number of virtual domains: 15
Virtual domains status: 1 in NAT mode, 0 in TP mode
Virtual domain configuration: disable
FIPS-CC mode: disable
Current HA mode: standalone
Branch point: 0866
Release Version Information: GA
FortiOS x86-64: Yes
System time: Fri Jun 7 14:39:27 2019

Terraform: FortiOS as a provider
Fortinet's Terraform support provides customers with more ways to efficiently deploy, manage, and automate security
across physical FortiGate appliances and virtual environments. You can use Terraform to automate various IT
infrastructure needs, thereby diminishing mistakes from repetitive manual configurations.
For example, if Fortinet is releasing a new FortiOS version, your organization may require you to test a new functionality
to determine how it may impact the environment before globally deploying the new version. In this case, the ability to
rapidly stand up environments and test these functions prior to production environment integration provides a resourceefficient and fault-tolerant approach.
The following example demonstrates how to use the Terraform FortiOS provider to perform simple configuration
changes on a FortiGate unit. It requires the following:
l
l
l
l

FortiOS 6.0 or later
FortiOS Provider: This example uses terraform-provider-fortios 1.0.0.
Terraform: This example uses Terraform 0.11.14.
REST API administrator created on the FortiGate with the API key

For more information, see the Terraform FortiOS Provider at https://www.terraform.io/docs/providers/fortios/index.html.

To create a REST API administrator:
1.
2.
3.
4.

On the FortiGate, go to System > Administrators and click Create New > REST API Admin.
Enter the Username and, optionally, enter Comments.
Select an Administrator Profile.
We recommend that you create a new profile with minimal privileges for this terraform script:
a. In the Administrator Profile drop down click Create New.
b. Enter a name for the profile.
c. Configure the Access Permissions:
l None: The REST API is not permitted access to the resource.
l Read: The REST API can send read requests (HTTP GET) to the resource.
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Read/Write: The REST API can send read and write requests (HTTP GET/POST/PUT/DELETE) to the
resource.
d. Click OK.
5. Enter Trusted Hosts to specify the devices that are allowed to access this FortiGate.
6. Click OK.
An API key is displayed. This key is only shown once, so you must copy and store it securely.
l

To configure FortiGate with Terraform Provider module support:
1. Download the terraform-provider-fortios file to a directory on the management computer.
2. Create a new file with the .tf extension for configuring your FortiGate:
root@mail:/home/terraform# ls
terraform-provider-fortios_v1.0.0_x4 test.tf

3. Edit the test.tf Terraform configuration file:
In this example, the FortiGate's IP address is 10.6.30.5, and the API user token is 17b********************63ck. Your
provider information must also be changed.
# Configure the FortiOS Provider
provider "fortios" {
hostname = "10.6.30.5"
token = "17b********************63ck"
}

4. Create the resources for configuring your DNS object and adding a static route:
resource "fortios_system_setting_dns" "test1" {
primary = "172.16.95.16"
secondary = "8.8.8.8"
}
resource "fortios_networking_route_static" "test1" {
dst = "110.2.2.122/32"
gateway = "2.2.2.2"
blackhole = "disable"
distance = "22"
weight = "3"
priority = "3"
device = "port2"
comment = "Terraform test"
}

5. Save your Terraform configuration file.
6. In the terminal, enter terraform init to initialize the working directory.
It reads the provider if the name follows the convention terraform-provider-[name]:
root@mail:/home/terraform# terraform init
Initializing the backend...
Terraform has been successfully initialized!
You may now begin working with Terraform. Try running "terraform plan" to see
any changes that are required for your infrastructure. All Terraform commands
should now work.
If you ever set or change modules or backend configuration for Terraform,
rerun this command to reinitialize your working directory. If you forget, other
commands will detect it and remind you to do so if necessary.
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7. Run terraform -v to verify the version of loaded provider module:
root@mail:/home/terraform# terraform -v
Terraform v0. 11.14
+ provider.fortios v1.0.0

8. Enter terraform plan to parse the configuration file and read from the FortiGate configuration to see what
Terraform changes:
This example create a static route and updates the DNS address. You can see that Terraform reads the DNS
addresses from the FortiGate and then lists them.
root@mail:/home/terraform# terraform plan
Refreshing Terraform state in-memory prior to plan...
The refreshed state will be used to calculate this plan, but will not be
persisted to local or remote state storage.
fortios_networking_route_static.test1: Refreshing state... (ID: 2)
fortios_system_setting_dns.test1: Refreshing state... (ID: 208.91.112.53)
-----------------------------------------------------------------------An execution plan has been generated and is shown below.
Resource actions are indicated with the following symbols:
+ create
~ update in-place
Terraform will perform the following actions:
+ fortios_networking_route_static.test1
id: <computed>
blackhole: "disable"
comment: "Terraform test"
device: "port2"
distance: "22"
dst: "110.2.2.122/32"
gateway: "2.2.2.2"
priority: "3"
weight: "3"
~ fortios_system_setting_dns.test1
primary: "208.91.112.53" => "172.16.95.16"
secondary: "208.91.112.22" => "8.8.8.8"
Plan: 1 to add, 1 to change, 0 to destroy.
-----------------------------------------------------------------------Note: You didn't specify an "-out" parameter to save this plan, so Terraform
can't guarantee that exactly these actions will be performed if
"terraform apply" is subsequently run.

If you are running terraform-provider-fortios 1.1.0, you may see the following error:
Error: Error getting CA Bundle, CA Bundle should be set when
insecure is false.

In this case, add the following line to the FortiOS provider configuration in the test.tf file:
insecure = "true"

9. Enter terraform apply to continue the configuration:
root@mail:/home/terraform# terraform apply
fortios_system_setting_dns.test1: Refreshing state... (ID: 208.91.112.53)
fortios_networking_route_static.test1: Refreshing state... (ID: 2)
An execution plan has been generated and is shown below.
Resource actions are indicated with the following symbols:
+ create
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~ update in-place
Terraform will perform the following actions:
+ fortios_networking_route_static.test1
id: <computed>
blackhole: "disable"
comment: "Terraform test"
device: "port2"
distance: "22"
dst: "110.2.2.122/32"
gateway: "2.2.2.2"
priority: "3"
weight: "3"
~ fortios_system_setting_dns.test1
primary: "208.91.112.53" => "172.16.95.16"
secondary: "208.91.112.22" => "8.8.8.8"
Plan: 1 to add, 1 to change, 0 to destroy.
Do you want to perform these actions?
Terraform will perform the actions described above.
Only 'yes' will be accepted to approve.
Enter a value: yes
fortios_networking_route_static.test1: Creating...
blackhole: "" => "disable"
comment: "" => "Terraform test"
device: "" => "port2"
distance: "" => "22"
dst: "" => "110.2.2.122/32"
gateway: "" => "2.2.2.2"
priority: "" => "3"
weight: "" => "3"
fortios_system_setting_dns.test1: Modifying... (ID: 208.91.112.53)
primary: "208.91.112.53" => "172.16.95.16"
secondary: "208.91.112.22" => "8.8.8.8"
fortios_networking_route_static.test1: Creation complete after 0s (ID: 2)
fortios_system_setting_dns.test1: Modifications complete after 0s (ID: 172.16.95.16)
Apply complete! Resources: 1 added, 1 changed, 0 destroyed.

The FortiGate is now configured according to the configuration file.
10. To change or delete something in the future, edit the configuration file and then apply it again. In supported cases, it
deletes, adds, or updates new entries as configured. For instance, in this example you can remove the static route
and revert the DNS address to its original configuration by changing the .tf file:
a. Edit the configuration file:
# Configure the FortiOS Provider
provider "fortios" {
hostname = "10.6.30.5"
token = "17b********************63ck"
}
resource "fortios_system_setting_dns" "test1" {
primary = "208.91.112.53"
secondary = "208.91.112.22"
}
#resource "fortios_networking_route_static" "test1" {
# dst = "110.2.2.122/32"
# gateway = "2.2.2.2"
# blackhole = "disable"
# distance = "22"
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# weight = "3"
# priority = "3"
# device = "port2"
# comment = "Terraform test"
#}

b. Entering terraform apply deletes the static route that is commented out of the configuration file, and
reverts the DNS address to the old address:
root@mail:/home/terraform# terraform apply
fortios_system_setting_dns.test1: Refreshing state... (ID: 172.16.95.16)
fortios_networking_route_static.test1: Refreshing state... (ID: 2)
An execution plan has been generated and is shown below.
Resource actions are indicated with the following symbols:
~ update in-place
- destroy
Terraform will perform the following actions:
- fortios_networking_route_static.test1
~ fortios_system_setting_dns.test1
primary: "172.16.95.16" => "208.91.112.53"
secondary: "8.8.8.8" => "208.91.112.22"
Plan: 0 to add, 1 to change, 1 to destroy.
Do you want to perform these actions?
Terraform will perform the actions described above.
Only 'yes' will be accepted to approve.
Enter a value: yes
fortios_networking_route_static.test1: Destroying... (ID: 2)
fortios_system_setting_dns.test1: Modifying... (ID: 172.16.95.16)
primary: "172.16.95.16" => "208.91.112.53"
secondary: "8.8.8.8" => "208.91.112.22"
fortios_networking_route_static.test1: Destruction complete after 0s
fortios_system_setting_dns.test1: Modifications complete after 0s (ID: 208.91.112.53)
Apply complete! Resources: 0 added, 1 changed, 1 destroyed.

Troubleshooting
Use the HTTPS daemon debug to begin troubleshooting why a configuration was not accepted:
# diagnose debug enable
# diagnose debug application httpsd -1
[httpsd 333 - 1560376452 info] ap_invoke_handler[569] -- new request (handler='api_cmdb_v2handler', uri='/api/v2/cmdb/router/static/2', method='GET')
[httpsd 23616 - 1560376452 info] handle_cli_req_v2_vdom[2034] -- new CMDB API request
(vdom='root',user='test')
[httpsd 333 - 1560376452 info] ap_invoke_handler[573] -- User-Agent: Go-http-client/1.1
[httpsd 23616 - 1560376452 info] api_cmdb_request_init_by_path[1438] -- new CMDB query
(path='system',name='dns')
[httpsd 333 - 1560376452 info] ap_invoke_handler[576] -- Source: 10.6.30.55:49666
Destination: 10.6.30.5:443
[httpsd 333 - 1560376452 info] api_cmdb_v2_handler[2132] -- received api_cmdb_v2_request
from '10.6.30.55'
[httpsd 23616 - 1560376452 info] api_cmdb_select_etag[2146] -- ETag check for system.dns
[httpsd 23616 - 1560376452 info] api_return_cmdb_revision[837] -- ETag check for system.dns
[httpsd 23616 - 1560376452 info] api_add_etag[918] -- no If-None-Match header
[httpsd 333 - 1560376452 warning] api_access_check_for_api_key[965] -- API Key request
authorized for test from 10.6.30.55.
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[httpsd 23616 - 1560376452 info] api_return_cmdb_revision[837] -- ETag check for system.dns
[httpsd 333 - 1560376452 info] api_store_parameter[239] -- add API parameter 'access_token'
(type=string)
[httpsd 333 - 1560376452 info] handle_cli_req_v2_vdom[2034] -- new CMDB API request
(vdom='root',user='test')
[httpsd 333 - 1560376452 info] api_cmdb_request_init_by_path[1438] -- new CMDB query
(path='router',name='static')
[httpsd 333 - 1560376452 info] api_cmdb_request_init_by_path[1467] -- querying CMDB entry
(mkey='2')
[httpsd 333 - 1560376452 info] api_cmdb_select_etag[2146] -- ETag check for router.static
[httpsd 333 - 1560376452 info] api_return_cmdb_revision[837] -- ETag check for router.static
[httpsd 333 - 1560376452 info] api_add_etag[918] -- no If-None-Match header
[httpsd 333 - 1560376452 info] api_cmdb_v2_object_select[843] -- filter by master key (seqnum)
[httpsd 23616 - 1560376452 info] ap_invoke_handler[592] -- request completed (handler='api_
cmdb_v2-handler' result==0)

The REST API 403 error means that your administrator profile does not have sufficient
permissions.
The REST API 401 error means that you do not have the correct token or trusted host.

PF SR-IOV driver support
Physical Function (PF) SR-IOV drivers for i40e and ixgbe interfaces in virtual environments are supported.
PF provides the ability for PCI Passthrough, but requires an entire Network Interface Card (NIC) for a VM. It can usually
achieve greater performance than a Virtual Function (VF) based SR-IOV. PF is also expensive; while VF allows one NIC
to be shared among multiple guests VMs, PF is allocated to one port on a VM.
The supported driver versions are:
l
l
l
l

ixgbe: 5.3.7
ixgbevf: 4.3.5
i40e: 2.4.10
i40evfL 3.5.13

All tools and software utilities for UEFI 1.X have been removed from 6.2.0 and later releases.
Update to UEFI 2.x to use the UEFI tools or software utilities.

Configuration to use PF or VF is done on the hypervisor, and is not configured on the FortiGate.
To check what driver is being used on the FortiGate:
# diagnose hardware deviceinfo nic port2
Name:
port2
Driver:
i40e
Version:
2.4.10
Bus:
0000:03:00.0
Hwaddr:
3c:fd:fe:1e:98:02
Permanent Hwaddr:3c:fd:fe:1e:98:02
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State:
up
Link:
up
Mtu:
1500
Supported:
auto 1000full 10000full
Advertised: auto 1000full 10000full
Auto:
disabled
Rx packets:
0
Rx bytes:
0
Rx compressed:
0
...
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